Namespace

Reference Library
Namespace
Namespaces »(Default Namespace)
Declaration Syntax
C# Visual Basic Visual C++
namespace
Namespace
namespace
Types
All Types Structures
Icon | Type | Description
 | CExtTabChildDialog |
 | ZdsName |
© 1998-2023 ZWSOFT CO., LTD.(Guangzhou) Software Co.,Ltd. All Rights Reserved.


CExtTabChildDialog Structure

CExtTabChildDialog Structure
Namespaces »(Default Namespace) »CExtTabChildDialog
Declaration Syntax
C# Visual Basic Visual C++
[DebugInfoInPDBAttribute]
[MiscellaneousBitsAttribute()]
[CLSCompliantAttribute(false)]
public struct CExtTabChildDialog
<DebugInfoInPDBAttribute> _
<MiscellaneousBitsAttribute()> _
<CLSCompliantAttribute(False)> _
Public Structure CExtTabChildDialog
[DebugInfoInPDBAttribute]
[MiscellaneousBitsAttribute()]
[CLSCompliantAttribute(false)]
public value class CExtTabChildDialog
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)

Assembly: ZwManaged (Module: ZwManaged)


ZdsName Structure

ZdsName Structure
Namespaces »(Default Namespace) »ZdsName
Declaration Syntax
C# Visual Basic Visual C++
public struct ZdsName
Public Structure ZdsName
public value class ZdsName
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | name1 |
 | name2 |
 | ToString()()()() | (Inherited from ValueType.)

Assembly: ZwDatabaseMgd (Module: ZwDatabaseMgd)


name1 Field

name1 Field
Namespaces »(Default Namespace) »ZdsName »name1
Declaration Syntax
C# Visual Basic Visual C++
public long name1
Public name1 As Long
public:
long long name1


name2 Field

name2 Field
Namespaces »(Default Namespace) »ZdsName »name2
Declaration Syntax
C# Visual Basic Visual C++
public long name2
Public name2 As Long
public:
long long name2


Microsoft.VisualC.MFC Namespace

Microsoft.VisualC.MFC Namespace
Namespaces »Microsoft.VisualC.MFC
Declaration Syntax
C# Visual Basic Visual C++
namespace Microsoft.VisualC.MFC
Namespace Microsoft.VisualC.MFC
namespace Microsoft.VisualC.MFC
Types
All Types Classes
Icon | Type | Description
 | CWin32Window |
 | CWinFormsEventsHelper |


CWin32Window Class

CWin32Window Class
Namespaces »Microsoft.VisualC.MFC »CWin32Window
Declaration Syntax
C# Visual Basic Visual C++
public class CWin32Window : IWin32Window
Public Class CWin32Window _
    Implements IWin32Window
public ref class CWin32Window : IWin32Window
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CWin32Window(HWND__*) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Handle |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CWin32Window

Assembly: ZwManaged (Module: ZwManaged)


CWin32Window Constructor (hWnd)

CWin32Window Constructor (hWnd)
Namespaces »Microsoft.VisualC.MFC »CWin32Window »CWin32Window(HWND__*)
Declaration Syntax
C# Visual Basic Visual C++
public CWin32Window(
    HWND__* hWnd
)
Visual Basic does not support APIs that consume or return unsafe types.
public:
CWin32Window(
    HWND__* hWnd
)
Parameters
hWnd(HWND__*)

Assembly: ZwManaged (Module: ZwManaged)


Handle Property

Handle Property
Namespaces »Microsoft.VisualC.MFC »CWin32Window »Handle
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtr Handle { get; }
Public Overridable ReadOnly Property Handle As IntPtr
    Get
public:
virtual property IntPtr Handle {
    IntPtr get ();
}

Assembly: ZwManaged (Module: ZwManaged)


CWinFormsEventsHelper Class

CWinFormsEventsHelper Class
Namespaces »Microsoft.VisualC.MFC »CWinFormsEventsHelper
Declaration Syntax
C# Visual Basic Visual C++
public class CWinFormsEventsHelper
Public Class CWinFormsEventsHelper
public ref class CWinFormsEventsHelper
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CWinFormsEventsHelper()()()() |
 | Advise(IHandleEvents*) |
 | Control |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | m_pControl |
 | m_pSink |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Unadvise(IHandleEvents*) |
Inheritance Hierarchy
Object
CWinFormsEventsHelper

Assembly: ZwManaged (Module: ZwManaged)


CWinFormsEventsHelper Constructor

CWinFormsEventsHelper Constructor
Namespaces »Microsoft.VisualC.MFC »CWinFormsEventsHelper »CWinFormsEventsHelper()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CWinFormsEventsHelper()
Public Sub New
public:
CWinFormsEventsHelper()

Assembly: ZwManaged (Module: ZwManaged)


Advise Method (pSink)

Advise Method (pSink)
Namespaces »Microsoft.VisualC.MFC »CWinFormsEventsHelper »Advise(IHandleEvents*)
Declaration Syntax
C# Visual Basic Visual C++
public void Advise(
    IHandleEvents* pSink
)
Public Sub Advise ( _
    pSink As IHandleEvents* _
)
public:
void Advise(
    IHandleEvents* pSink
)
Parameters
pSink(IHandleEvents*)

Assembly: ZwManaged (Module: ZwManaged)


Control Property

Control Property
Namespaces »Microsoft.VisualC.MFC »CWinFormsEventsHelper »Control
Declaration Syntax
C# Visual Basic Visual C++
public Control Control { get; set; }
Public Property Control As Control
    Get
    Set
public:
property Control^ Control {
    Control^ get ();
    void set (Control^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


m_pControl Field

m_pControl Field
Namespaces »Microsoft.VisualC.MFC »CWinFormsEventsHelper »m_pControl
Declaration Syntax
C# Visual Basic Visual C++
public Control m_pControl
Public m_pControl As Control
public:
Control^ m_pControl

Assembly: ZwManaged (Module: ZwManaged)


m_pSink Field

m_pSink Field
Namespaces »Microsoft.VisualC.MFC »CWinFormsEventsHelper »m_pSink
Declaration Syntax
C# Visual Basic Visual C++
public IHandleEvents* m_pSink
Visual Basic does not support APIs that consume or return unsafe types.
public:
IHandleEvents* m_pSink

Assembly: ZwManaged (Module: ZwManaged)


Unadvise Method (pSink)

Unadvise Method (pSink)
Namespaces »Microsoft.VisualC.MFC »CWinFormsEventsHelper »Unadvise(IHandleEvents*)
Declaration Syntax
C# Visual Basic Visual C++
public void Unadvise(
    IHandleEvents* pSink
)
Public Sub Unadvise ( _
    pSink As IHandleEvents* _
)
public:
void Unadvise(
    IHandleEvents* pSink
)
Parameters
pSink(IHandleEvents*)

Assembly: ZwManaged (Module: ZwManaged)


ZwSoft.ZwCAD.ApplicationServices Namespace

ZwSoft.ZwCAD.ApplicationServices Namespace
Namespaces »ZwSoft.ZwCAD.ApplicationServices
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.ApplicationServices
Namespace ZwSoft.ZwCAD.ApplicationServices
namespace ZwSoft.ZwCAD.ApplicationServices
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
 | Application |
 | CommandEventArgs |
 | CommandEventHandler |
 | CommandLinePrompts |
 | ConfigurationSectionNameAttribute |
 | Document |
 | DocumentActivationChangedEventArgs |
 | DocumentActivationChangedEventHandler |
 | DocumentBeginCloseEventArgs |
 | DocumentBeginCloseEventHandler |
 | DocumentCollection |
 | DocumentCollectionEventArgs |
 | DocumentCollectionEventHandler |
 | DocumentDestroyedEventArgs |
 | DocumentDestroyedEventHandler |
 | DocumentLock |
 | DocumentLockMode |
 | DocumentLockModeChangedEventArgs |
 | DocumentLockModeChangedEventHandler |
 | DocumentLockModeChangeVetoedEventArgs |
 | DocumentLockModeChangeVetoedEventHandler |
 | DocumentLockModeWillChangeEventArgs |
 | DocumentLockModeWillChangeEventHandler |
 | DrawingOpenEventArgs |
 | DrawingOpenEventHandler |
 | ExecuteInApplicationContextCallback |
 | IConfigurationSection |
 | LispWillStartEventArgs |
 | LispWillStartEventHandler |
 | MgdUndoCommandInfo |
 | PreTranslateMessageEventArgs |
 | PreTranslateMessageEventHandler |
 | CommandLinePrompts..::..PromptResult |
 | SystemVariableChangedEventArgs |
 | SystemVariableChangedEventHandler |
 | SystemVariableChangingEventArgs |
 | SystemVariableChangingEventHandler |
 | TabbedDialogAction |
 | TabbedDialogEventArgs |
 | TabbedDialogEventHandler |
 | TabbedDialogExtension |
 | TransactionManager |
 | UnknownCommandEventArgs |
 | UnknownCommandEventHandler |
 | UserConfigurationManager |
 | Utilities |
 | WhoHasInfo |


Application Class

Application Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application
Declaration Syntax
C# Visual Basic Visual C++
public class Application
Public Class Application
public ref class Application
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddDefaultContextMenuExtension(ContextMenuExtension) |
 | AddObjectContextMenuExtension(RXClass, ContextMenuExtension) |
 | BeginQuit |
 | DisplayingCustomizeDialog |
 | DisplayingDraftingSettingsDialog |
 | DisplayingOptionDialog |
 | DocumentManager |
 | DoDragDrop(DependencyObject, Object, DragDropEffects, DropTarget) |
 | DoDragDrop(Control, Object, DragDropEffects, DropTarget) |
 | Equals(Object) | (Inherited from Object.)
 | EvaluateDiesel(String) |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMainOwner()()()() |
 | GetSystemVariable(String) |
 | GetType()()()() | (Inherited from Object.)
 | Idle |
 | InvokeContextHelp(IntPtr, Int32) |
 | InvokeHelp(String, String) |
 | IsQuiescent |
 | LoadPartialMenu(String) |
 | MainWindow |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MenuBar |
 | MenuGroups |
 | Preferences |
 | Publisher |
 | Quit()()()() |
 | QuitAborted |
 | QuitWillStart |
 | RemoveDefaultContextMenuExtension(ContextMenuExtension) |
 | RemoveObjectContextMenuExtension(RXClass, ContextMenuExtension) |
 | SetSystemVariable(String, Object) |
 | ShowAlertDialog(String) |
 | ShowModalDialog(IWin32Window, Form, Boolean) |
 | ShowModalDialog(IntPtr, Form, Boolean) |
 | ShowModalDialog(IWin32Window, Form) |
 | ShowModalDialog(IntPtr, Form) |
 | ShowModalDialog(Form) |
 | ShowModalWindow(Window, Window, Boolean) |
 | ShowModalWindow(IntPtr, Window, Boolean) |
 | ShowModalWindow(Window, Window) |
 | ShowModalWindow(IntPtr, Window) |
 | ShowModalWindow(Window) |
 | ShowModelessDialog(IWin32Window, Form, Boolean) |
 | ShowModelessDialog(IntPtr, Form, Boolean) |
 | ShowModelessDialog(IWin32Window, Form) |
 | ShowModelessDialog(IntPtr, Form) |
 | ShowModelessDialog(Form) |
 | ShowModelessWindow(Window, Window, Boolean) |
 | ShowModelessWindow(IntPtr, Window, Boolean) |
 | ShowModelessWindow(Window, Window) |
 | ShowModelessWindow(IntPtr, Window) |
 | ShowModelessWindow(Window) |
 | StatusBar |
 | SystemVariableChanged |
 | SystemVariableChanging |
 | ToString()()()() | (Inherited from Object.)
 | UnloadPartialMenu(String) |
 | UpdateScreen()()()() |
 | UserConfigurationManager |
 | Version |
 | ZcadApplication |
Inheritance Hierarchy
Object
Application

Assembly: ZwManaged (Module: ZwManaged)


AddDefaultContextMenuExtension Method (menuExtension)

AddDefaultContextMenuExtension Method (menuExtension)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »AddDefaultContextMenuExtension(ContextMenuExtension)
Declaration Syntax
C# Visual Basic Visual C++
public static void AddDefaultContextMenuExtension(
    ContextMenuExtension menuExtension
)
Public Shared Sub AddDefaultContextMenuExtension ( _
    menuExtension As ContextMenuExtension _
)
public:
static void AddDefaultContextMenuExtension(
    ContextMenuExtension^ menuExtension
)
Parameters
menuExtension(ContextMenuExtension)

Assembly: ZwManaged (Module: ZwManaged)


AddObjectContextMenuExtension Method (runtimeClass, menuExtension)

AddObjectContextMenuExtension Method (runtimeClass, menuExtension)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »AddObjectContextMenuExtension(RXClass, ContextMenuExtension)
Declaration Syntax
C# Visual Basic Visual C++
public static void AddObjectContextMenuExtension(
    RXClass runtimeClass,
    ContextMenuExtension menuExtension
)
Public Shared Sub AddObjectContextMenuExtension ( _
    runtimeClass As RXClass, _
    menuExtension As ContextMenuExtension _
)
public:
static void AddObjectContextMenuExtension(
    RXClass^ runtimeClass,
    ContextMenuExtension^ menuExtension
)
Parameters
runtimeClass(RXClass)
menuExtension(ContextMenuExtension)

Assembly: ZwManaged (Module: ZwManaged)


BeginQuit Event

BeginQuit Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »BeginQuit
Declaration Syntax
C# Visual Basic Visual C++
public static event EventHandler BeginQuit
Public Shared Event BeginQuit As EventHandler
public:
static  event EventHandler^ BeginQuit {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DisplayingCustomizeDialog Event

DisplayingCustomizeDialog Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »DisplayingCustomizeDialog
Declaration Syntax
C# Visual Basic Visual C++
public static event TabbedDialogEventHandler DisplayingCustomizeDialog
Public Shared Event DisplayingCustomizeDialog As TabbedDialogEventHandler
public:
static  event TabbedDialogEventHandler^ DisplayingCustomizeDialog {
    void add (TabbedDialogEventHandler^ value);
    void remove (TabbedDialogEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DisplayingDraftingSettingsDialog Event

DisplayingDraftingSettingsDialog Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »DisplayingDraftingSettingsDialog
Declaration Syntax
C# Visual Basic Visual C++
public static event TabbedDialogEventHandler DisplayingDraftingSettingsDialog
Public Shared Event DisplayingDraftingSettingsDialog As TabbedDialogEventHandler
public:
static  event TabbedDialogEventHandler^ DisplayingDraftingSettingsDialog {
    void add (TabbedDialogEventHandler^ value);
    void remove (TabbedDialogEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DisplayingOptionDialog Event

DisplayingOptionDialog Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »DisplayingOptionDialog
Declaration Syntax
C# Visual Basic Visual C++
public static event TabbedDialogEventHandler DisplayingOptionDialog
Public Shared Event DisplayingOptionDialog As TabbedDialogEventHandler
public:
static  event TabbedDialogEventHandler^ DisplayingOptionDialog {
    void add (TabbedDialogEventHandler^ value);
    void remove (TabbedDialogEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentManager Property

DocumentManager Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »DocumentManager
Declaration Syntax
C# Visual Basic Visual C++
public static DocumentCollection DocumentManager { get; }
Public Shared ReadOnly Property DocumentManager As DocumentCollection
    Get
public:
static property DocumentCollection^ DocumentManager {
    DocumentCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DoDragDrop Method

DoDragDrop Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »DoDragDrop()()()()
Members
Icon | Member | Description
 | DoDragDrop(DependencyObject, Object, DragDropEffects, DropTarget) |
 | DoDragDrop(Control, Object, DragDropEffects, DropTarget) |

Assembly: ZwManaged (Module: ZwManaged)


DoDragDrop Method (dragSource, data, allowedEffects, target)

DoDragDrop Method (dragSource, data, allowedEffects, target)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »DoDragDrop(DependencyObject, Object, DragDropEffects, DropTarget)
Declaration Syntax
C# Visual Basic Visual C++
public static void DoDragDrop(
    DependencyObject dragSource,
    Object data,
    DragDropEffects allowedEffects,
    DropTarget target
)
Public Shared Sub DoDragDrop ( _
    dragSource As DependencyObject, _
    data As Object, _
    allowedEffects As DragDropEffects, _
    target As DropTarget _
)
public:
static void DoDragDrop(
    DependencyObject^ dragSource,
    Object^ data,
    DragDropEffects allowedEffects,
    DropTarget^ target
)
Parameters
dragSource(DependencyObject)
data(Object)
allowedEffects(DragDropEffects)
target(DropTarget)

Assembly: ZwManaged (Module: ZwManaged)


DoDragDrop Method (control, data, allowedEffects, target)

DoDragDrop Method (control, data, allowedEffects, target)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »DoDragDrop(Control, Object, DragDropEffects, DropTarget)
Declaration Syntax
C# Visual Basic Visual C++
public static void DoDragDrop(
    Control control,
    Object data,
    DragDropEffects allowedEffects,
    DropTarget target
)
Public Shared Sub DoDragDrop ( _
    control As Control, _
    data As Object, _
    allowedEffects As DragDropEffects, _
    target As DropTarget _
)
public:
static void DoDragDrop(
    Control^ control,
    Object^ data,
    DragDropEffects allowedEffects,
    DropTarget^ target
)
Parameters
control(Control)
data(Object)
allowedEffects(DragDropEffects)
target(DropTarget)

Assembly: ZwManaged (Module: ZwManaged)


EvaluateDiesel Method (dieselCmd)

EvaluateDiesel Method (dieselCmd)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »EvaluateDiesel(String)
Declaration Syntax
C# Visual Basic Visual C++
public static string EvaluateDiesel(
    string dieselCmd
)
Public Shared Function EvaluateDiesel ( _
    dieselCmd As String _
) As String
public:
static String^ EvaluateDiesel(
    String^ dieselCmd
)
Parameters
dieselCmd(String)

Assembly: ZwManaged (Module: ZwManaged)


GetMainOwner Method

GetMainOwner Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »GetMainOwner()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetMainOwner()
Public Shared Function GetMainOwner As IntPtr
public:
static IntPtr GetMainOwner()

Assembly: ZwManaged (Module: ZwManaged)


GetSystemVariable Method (name)

GetSystemVariable Method (name)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »GetSystemVariable(String)
Declaration Syntax
C# Visual Basic Visual C++
public static Object GetSystemVariable(
    string name
)
Public Shared Function GetSystemVariable ( _
    name As String _
) As Object
public:
static Object^ GetSystemVariable(
    String^ name
)
Parameters
name(String)

Assembly: ZwManaged (Module: ZwManaged)


Idle Event

Idle Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »Idle
Declaration Syntax
C# Visual Basic Visual C++
public static event EventHandler Idle
Public Shared Event Idle As EventHandler
public:
static  event EventHandler^ Idle {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


InvokeContextHelp Method (window, contextId)

InvokeContextHelp Method (window, contextId)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »InvokeContextHelp(IntPtr, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void InvokeContextHelp(
    IntPtr window,
    int contextId
)
Public Shared Sub InvokeContextHelp ( _
    window As IntPtr, _
    contextId As Integer _
)
public:
static void InvokeContextHelp(
    IntPtr window,
    int contextId
)
Parameters
window(IntPtr)
contextId(Int32)

Assembly: ZwManaged (Module: ZwManaged)


InvokeHelp Method (fileName, topic)

InvokeHelp Method (fileName, topic)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »InvokeHelp(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public static void InvokeHelp(
    string fileName,
    string topic
)
Public Shared Sub InvokeHelp ( _
    fileName As String, _
    topic As String _
)
public:
static void InvokeHelp(
    String^ fileName,
    String^ topic
)
Parameters
fileName(String)
topic(String)

Assembly: ZwManaged (Module: ZwManaged)


IsQuiescent Property

IsQuiescent Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »IsQuiescent
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsQuiescent { get; }
Public Shared ReadOnly Property IsQuiescent As Boolean
    Get
public:
static property bool IsQuiescent {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LoadPartialMenu Method (szMenuFileName)

LoadPartialMenu Method (szMenuFileName)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »LoadPartialMenu(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool LoadPartialMenu(
    string szMenuFileName
)
Public Shared Function LoadPartialMenu ( _
    szMenuFileName As String _
) As Boolean
public:
static bool LoadPartialMenu(
    String^ szMenuFileName
)
Parameters
szMenuFileName(String)

Assembly: ZwManaged (Module: ZwManaged)


MainWindow Property

MainWindow Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »MainWindow
Declaration Syntax
C# Visual Basic Visual C++
public static Window MainWindow { get; }
Public Shared ReadOnly Property MainWindow As Window
    Get
public:
static property Window^ MainWindow {
    Window^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MenuBar Property

MenuBar Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »MenuBar
Declaration Syntax
C# Visual Basic Visual C++
public static Object MenuBar { get; }
Public Shared ReadOnly Property MenuBar As Object
    Get
public:
static property Object^ MenuBar {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MenuGroups Property

MenuGroups Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »MenuGroups
Declaration Syntax
C# Visual Basic Visual C++
public static Object MenuGroups { get; }
Public Shared ReadOnly Property MenuGroups As Object
    Get
public:
static property Object^ MenuGroups {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Preferences Property

Preferences Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »Preferences
Declaration Syntax
C# Visual Basic Visual C++
public static Object Preferences { get; }
Public Shared ReadOnly Property Preferences As Object
    Get
public:
static property Object^ Preferences {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Publisher Property

Publisher Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »Publisher
Declaration Syntax
C# Visual Basic Visual C++
public static Publisher Publisher { get; }
Public Shared ReadOnly Property Publisher As Publisher
    Get
public:
static property Publisher^ Publisher {
    Publisher^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Quit Method

Quit Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »Quit()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static void Quit()
Public Shared Sub Quit
public:
static void Quit()

Assembly: ZwManaged (Module: ZwManaged)


QuitAborted Event

QuitAborted Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »QuitAborted
Declaration Syntax
C# Visual Basic Visual C++
public static event EventHandler QuitAborted
Public Shared Event QuitAborted As EventHandler
public:
static  event EventHandler^ QuitAborted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


QuitWillStart Event

QuitWillStart Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »QuitWillStart
Declaration Syntax
C# Visual Basic Visual C++
public static event EventHandler QuitWillStart
Public Shared Event QuitWillStart As EventHandler
public:
static  event EventHandler^ QuitWillStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


RemoveDefaultContextMenuExtension Method (menuExtension)

RemoveDefaultContextMenuExtension Method (menuExtension)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »RemoveDefaultContextMenuExtension(ContextMenuExtension)
Declaration Syntax
C# Visual Basic Visual C++
public static void RemoveDefaultContextMenuExtension(
    ContextMenuExtension menuExtension
)
Public Shared Sub RemoveDefaultContextMenuExtension ( _
    menuExtension As ContextMenuExtension _
)
public:
static void RemoveDefaultContextMenuExtension(
    ContextMenuExtension^ menuExtension
)
Parameters
menuExtension(ContextMenuExtension)

Assembly: ZwManaged (Module: ZwManaged)


RemoveObjectContextMenuExtension Method (runtimeClass, menuExtension)

RemoveObjectContextMenuExtension Method (runtimeClass, menuExtension)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »RemoveObjectContextMenuExtension(RXClass, ContextMenuExtension)
Declaration Syntax
C# Visual Basic Visual C++
public static void RemoveObjectContextMenuExtension(
    RXClass runtimeClass,
    ContextMenuExtension menuExtension
)
Public Shared Sub RemoveObjectContextMenuExtension ( _
    runtimeClass As RXClass, _
    menuExtension As ContextMenuExtension _
)
public:
static void RemoveObjectContextMenuExtension(
    RXClass^ runtimeClass,
    ContextMenuExtension^ menuExtension
)
Parameters
runtimeClass(RXClass)
menuExtension(ContextMenuExtension)

Assembly: ZwManaged (Module: ZwManaged)


SetSystemVariable Method (name, value)

SetSystemVariable Method (name, value)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »SetSystemVariable(String, Object)
Declaration Syntax
C# Visual Basic Visual C++
public static void SetSystemVariable(
    string name,
    Object value
)
Public Shared Sub SetSystemVariable ( _
    name As String, _
    value As Object _
)
public:
static void SetSystemVariable(
    String^ name,
    Object^ value
)
Parameters
name(String)
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


ShowAlertDialog Method (message)

ShowAlertDialog Method (message)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowAlertDialog(String)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowAlertDialog(
    string message
)
Public Shared Sub ShowAlertDialog ( _
    message As String _
)
public:
static void ShowAlertDialog(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


ShowModalDialog Method

ShowModalDialog Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalDialog()()()()
Members
Icon | Member | Description
 | ShowModalDialog(IWin32Window, Form, Boolean) |
 | ShowModalDialog(IntPtr, Form, Boolean) |
 | ShowModalDialog(IWin32Window, Form) |
 | ShowModalDialog(IntPtr, Form) |
 | ShowModalDialog(Form) |

Assembly: ZwManaged (Module: ZwManaged)


ShowModalDialog Method (owner, formToShow)

ShowModalDialog Method (owner, formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalDialog(IntPtr, Form)
Declaration Syntax
C# Visual Basic Visual C++
public static DialogResult ShowModalDialog(
    IntPtr owner,
    Form formToShow
)
Public Shared Function ShowModalDialog ( _
    owner As IntPtr, _
    formToShow As Form _
) As DialogResult
public:
static DialogResult ShowModalDialog(
    IntPtr owner,
    Form^ formToShow
)
Parameters
owner(IntPtr)
formToShow(Form)

Assembly: ZwManaged (Module: ZwManaged)


ShowModalDialog Method (owner, formToShow, persistSizeAndPosition)

ShowModalDialog Method (owner, formToShow, persistSizeAndPosition)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalDialog(IntPtr, Form, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static DialogResult ShowModalDialog(
    IntPtr owner,
    Form formToShow,
    bool persistSizeAndPosition
)
Public Shared Function ShowModalDialog ( _
    owner As IntPtr, _
    formToShow As Form, _
    persistSizeAndPosition As Boolean _
) As DialogResult
public:
static DialogResult ShowModalDialog(
    IntPtr owner,
    Form^ formToShow,
    bool persistSizeAndPosition
)
Parameters
owner(IntPtr)
formToShow(Form)
persistSizeAndPosition(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


ShowModalDialog Method (formToShow)

ShowModalDialog Method (formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalDialog(Form)
Declaration Syntax
C# Visual Basic Visual C++
public static DialogResult ShowModalDialog(
    Form formToShow
)
Public Shared Function ShowModalDialog ( _
    formToShow As Form _
) As DialogResult
public:
static DialogResult ShowModalDialog(
    Form^ formToShow
)
Parameters
formToShow(Form)

Assembly: ZwManaged (Module: ZwManaged)


ShowModalDialog Method (owner, formToShow)

ShowModalDialog Method (owner, formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalDialog(IWin32Window, Form)
Declaration Syntax
C# Visual Basic Visual C++
public static DialogResult ShowModalDialog(
    IWin32Window owner,
    Form formToShow
)
Public Shared Function ShowModalDialog ( _
    owner As IWin32Window, _
    formToShow As Form _
) As DialogResult
public:
static DialogResult ShowModalDialog(
    IWin32Window^ owner,
    Form^ formToShow
)
Parameters
owner(IWin32Window)
formToShow(Form)

Assembly: ZwManaged (Module: ZwManaged)


ShowModalDialog Method (owner, formToShow, persistSizeAndPosition)

ShowModalDialog Method (owner, formToShow, persistSizeAndPosition)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalDialog(IWin32Window, Form, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static DialogResult ShowModalDialog(
    IWin32Window owner,
    Form formToShow,
    bool persistSizeAndPosition
)
Public Shared Function ShowModalDialog ( _
    owner As IWin32Window, _
    formToShow As Form, _
    persistSizeAndPosition As Boolean _
) As DialogResult
public:
static DialogResult ShowModalDialog(
    IWin32Window^ owner,
    Form^ formToShow,
    bool persistSizeAndPosition
)
Parameters
owner(IWin32Window)
formToShow(Form)
persistSizeAndPosition(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


ShowModalWindow Method

ShowModalWindow Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalWindow()()()()
Members
Icon | Member | Description
 | ShowModalWindow(Window, Window, Boolean) |
 | ShowModalWindow(IntPtr, Window, Boolean) |
 | ShowModalWindow(Window, Window) |
 | ShowModalWindow(IntPtr, Window) |
 | ShowModalWindow(Window) |

Assembly: ZwManaged (Module: ZwManaged)


ShowModalWindow Method (owner, formToShow)

ShowModalWindow Method (owner, formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalWindow(IntPtr, Window)
Declaration Syntax
C# Visual Basic Visual C++
public static Nullable<bool> ShowModalWindow(
    IntPtr owner,
    Window formToShow
)
Public Shared Function ShowModalWindow ( _
    owner As IntPtr, _
    formToShow As Window _
) As Nullable(Of Boolean)
public:
static Nullable<bool> ShowModalWindow(
    IntPtr owner,
    Window^ formToShow
)
Parameters
owner(IntPtr)
formToShow(Window)

Assembly: ZwManaged (Module: ZwManaged)


ShowModalWindow Method (owner, formToShow, persistSizeAndPosition)

ShowModalWindow Method (owner, formToShow, persistSizeAndPosition)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalWindow(IntPtr, Window, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Nullable<bool> ShowModalWindow(
    IntPtr owner,
    Window formToShow,
    bool persistSizeAndPosition
)
Public Shared Function ShowModalWindow ( _
    owner As IntPtr, _
    formToShow As Window, _
    persistSizeAndPosition As Boolean _
) As Nullable(Of Boolean)
public:
static Nullable<bool> ShowModalWindow(
    IntPtr owner,
    Window^ formToShow,
    bool persistSizeAndPosition
)
Parameters
owner(IntPtr)
formToShow(Window)
persistSizeAndPosition(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


ShowModalWindow Method (formToShow)

ShowModalWindow Method (formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalWindow(Window)
Declaration Syntax
C# Visual Basic Visual C++
public static Nullable<bool> ShowModalWindow(
    Window formToShow
)
Public Shared Function ShowModalWindow ( _
    formToShow As Window _
) As Nullable(Of Boolean)
public:
static Nullable<bool> ShowModalWindow(
    Window^ formToShow
)
Parameters
formToShow(Window)

Assembly: ZwManaged (Module: ZwManaged)


ShowModalWindow Method (owner, formToShow)

ShowModalWindow Method (owner, formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalWindow(Window, Window)
Declaration Syntax
C# Visual Basic Visual C++
public static Nullable<bool> ShowModalWindow(
    Window owner,
    Window formToShow
)
Public Shared Function ShowModalWindow ( _
    owner As Window, _
    formToShow As Window _
) As Nullable(Of Boolean)
public:
static Nullable<bool> ShowModalWindow(
    Window^ owner,
    Window^ formToShow
)
Parameters
owner(Window)
formToShow(Window)

Assembly: ZwManaged (Module: ZwManaged)


ShowModalWindow Method (owner, formToShow, persistSizeAndPosition)

ShowModalWindow Method (owner, formToShow, persistSizeAndPosition)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModalWindow(Window, Window, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Nullable<bool> ShowModalWindow(
    Window owner,
    Window formToShow,
    bool persistSizeAndPosition
)
Public Shared Function ShowModalWindow ( _
    owner As Window, _
    formToShow As Window, _
    persistSizeAndPosition As Boolean _
) As Nullable(Of Boolean)
public:
static Nullable<bool> ShowModalWindow(
    Window^ owner,
    Window^ formToShow,
    bool persistSizeAndPosition
)
Parameters
owner(Window)
formToShow(Window)
persistSizeAndPosition(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessDialog Method

ShowModelessDialog Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessDialog()()()()
Members
Icon | Member | Description
 | ShowModelessDialog(IWin32Window, Form, Boolean) |
 | ShowModelessDialog(IntPtr, Form, Boolean) |
 | ShowModelessDialog(IWin32Window, Form) |
 | ShowModelessDialog(IntPtr, Form) |
 | ShowModelessDialog(Form) |

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessDialog Method (owner, formToShow)

ShowModelessDialog Method (owner, formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessDialog(IntPtr, Form)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowModelessDialog(
    IntPtr owner,
    Form formToShow
)
Public Shared Sub ShowModelessDialog ( _
    owner As IntPtr, _
    formToShow As Form _
)
public:
static void ShowModelessDialog(
    IntPtr owner,
    Form^ formToShow
)
Parameters
owner(IntPtr)
formToShow(Form)

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessDialog Method (owner, formToShow, persistSizeAndPosition)

ShowModelessDialog Method (owner, formToShow, persistSizeAndPosition)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessDialog(IntPtr, Form, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowModelessDialog(
    IntPtr owner,
    Form formToShow,
    bool persistSizeAndPosition
)
Public Shared Sub ShowModelessDialog ( _
    owner As IntPtr, _
    formToShow As Form, _
    persistSizeAndPosition As Boolean _
)
public:
static void ShowModelessDialog(
    IntPtr owner,
    Form^ formToShow,
    bool persistSizeAndPosition
)
Parameters
owner(IntPtr)
formToShow(Form)
persistSizeAndPosition(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessDialog Method (formToShow)

ShowModelessDialog Method (formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessDialog(Form)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowModelessDialog(
    Form formToShow
)
Public Shared Sub ShowModelessDialog ( _
    formToShow As Form _
)
public:
static void ShowModelessDialog(
    Form^ formToShow
)
Parameters
formToShow(Form)

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessDialog Method (owner, formToShow)

ShowModelessDialog Method (owner, formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessDialog(IWin32Window, Form)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowModelessDialog(
    IWin32Window owner,
    Form formToShow
)
Public Shared Sub ShowModelessDialog ( _
    owner As IWin32Window, _
    formToShow As Form _
)
public:
static void ShowModelessDialog(
    IWin32Window^ owner,
    Form^ formToShow
)
Parameters
owner(IWin32Window)
formToShow(Form)

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessDialog Method (owner, formToShow, persistSizeAndPosition)

ShowModelessDialog Method (owner, formToShow, persistSizeAndPosition)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessDialog(IWin32Window, Form, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowModelessDialog(
    IWin32Window owner,
    Form formToShow,
    bool persistSizeAndPosition
)
Public Shared Sub ShowModelessDialog ( _
    owner As IWin32Window, _
    formToShow As Form, _
    persistSizeAndPosition As Boolean _
)
public:
static void ShowModelessDialog(
    IWin32Window^ owner,
    Form^ formToShow,
    bool persistSizeAndPosition
)
Parameters
owner(IWin32Window)
formToShow(Form)
persistSizeAndPosition(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessWindow Method

ShowModelessWindow Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessWindow()()()()
Members
Icon | Member | Description
 | ShowModelessWindow(Window, Window, Boolean) |
 | ShowModelessWindow(IntPtr, Window, Boolean) |
 | ShowModelessWindow(Window, Window) |
 | ShowModelessWindow(IntPtr, Window) |
 | ShowModelessWindow(Window) |

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessWindow Method (owner, formToShow)

ShowModelessWindow Method (owner, formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessWindow(IntPtr, Window)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowModelessWindow(
    IntPtr owner,
    Window formToShow
)
Public Shared Sub ShowModelessWindow ( _
    owner As IntPtr, _
    formToShow As Window _
)
public:
static void ShowModelessWindow(
    IntPtr owner,
    Window^ formToShow
)
Parameters
owner(IntPtr)
formToShow(Window)

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessWindow Method (owner, formToShow, persistSizeAndPosition)

ShowModelessWindow Method (owner, formToShow, persistSizeAndPosition)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessWindow(IntPtr, Window, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowModelessWindow(
    IntPtr owner,
    Window formToShow,
    bool persistSizeAndPosition
)
Public Shared Sub ShowModelessWindow ( _
    owner As IntPtr, _
    formToShow As Window, _
    persistSizeAndPosition As Boolean _
)
public:
static void ShowModelessWindow(
    IntPtr owner,
    Window^ formToShow,
    bool persistSizeAndPosition
)
Parameters
owner(IntPtr)
formToShow(Window)
persistSizeAndPosition(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessWindow Method (formToShow)

ShowModelessWindow Method (formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessWindow(Window)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowModelessWindow(
    Window formToShow
)
Public Shared Sub ShowModelessWindow ( _
    formToShow As Window _
)
public:
static void ShowModelessWindow(
    Window^ formToShow
)
Parameters
formToShow(Window)

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessWindow Method (owner, formToShow)

ShowModelessWindow Method (owner, formToShow)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessWindow(Window, Window)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowModelessWindow(
    Window owner,
    Window formToShow
)
Public Shared Sub ShowModelessWindow ( _
    owner As Window, _
    formToShow As Window _
)
public:
static void ShowModelessWindow(
    Window^ owner,
    Window^ formToShow
)
Parameters
owner(Window)
formToShow(Window)

Assembly: ZwManaged (Module: ZwManaged)


ShowModelessWindow Method (owner, formToShow, persistSizeAndPosition)

ShowModelessWindow Method (owner, formToShow, persistSizeAndPosition)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ShowModelessWindow(Window, Window, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static void ShowModelessWindow(
    Window owner,
    Window formToShow,
    bool persistSizeAndPosition
)
Public Shared Sub ShowModelessWindow ( _
    owner As Window, _
    formToShow As Window, _
    persistSizeAndPosition As Boolean _
)
public:
static void ShowModelessWindow(
    Window^ owner,
    Window^ formToShow,
    bool persistSizeAndPosition
)
Parameters
owner(Window)
formToShow(Window)
persistSizeAndPosition(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


StatusBar Property

StatusBar Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »StatusBar
Declaration Syntax
C# Visual Basic Visual C++
public static StatusBar StatusBar { get; }
Public Shared ReadOnly Property StatusBar As StatusBar
    Get
public:
static property StatusBar^ StatusBar {
    StatusBar^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


SystemVariableChanged Event

SystemVariableChanged Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »SystemVariableChanged
Declaration Syntax
C# Visual Basic Visual C++
public static event SystemVariableChangedEventHandler SystemVariableChanged
Public Shared Event SystemVariableChanged As SystemVariableChangedEventHandler
public:
static  event SystemVariableChangedEventHandler^ SystemVariableChanged {
    void add (SystemVariableChangedEventHandler^ value);
    void remove (SystemVariableChangedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


SystemVariableChanging Event

SystemVariableChanging Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »SystemVariableChanging
Declaration Syntax
C# Visual Basic Visual C++
public static event SystemVariableChangingEventHandler SystemVariableChanging
Public Shared Event SystemVariableChanging As SystemVariableChangingEventHandler
public:
static  event SystemVariableChangingEventHandler^ SystemVariableChanging {
    void add (SystemVariableChangingEventHandler^ value);
    void remove (SystemVariableChangingEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


UnloadPartialMenu Method (szMenuFileName)

UnloadPartialMenu Method (szMenuFileName)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »UnloadPartialMenu(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool UnloadPartialMenu(
    string szMenuFileName
)
Public Shared Function UnloadPartialMenu ( _
    szMenuFileName As String _
) As Boolean
public:
static bool UnloadPartialMenu(
    String^ szMenuFileName
)
Parameters
szMenuFileName(String)

Assembly: ZwManaged (Module: ZwManaged)


UpdateScreen Method

UpdateScreen Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »UpdateScreen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static void UpdateScreen()
Public Shared Sub UpdateScreen
public:
static void UpdateScreen()

Assembly: ZwManaged (Module: ZwManaged)


UserConfigurationManager Property

UserConfigurationManager Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »UserConfigurationManager
Declaration Syntax
C# Visual Basic Visual C++
public static UserConfigurationManager UserConfigurationManager { get; }
Public Shared ReadOnly Property UserConfigurationManager As UserConfigurationManager
    Get
public:
static property UserConfigurationManager^ UserConfigurationManager {
    UserConfigurationManager^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Version Property

Version Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »Version
Declaration Syntax
C# Visual Basic Visual C++
public static Version Version { get; }
Public Shared ReadOnly Property Version As Version
    Get
public:
static property Version^ Version {
    Version^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ZcadApplication Property

ZcadApplication Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Application »ZcadApplication
Declaration Syntax
C# Visual Basic Visual C++
public static Object ZcadApplication { get; }
Public Shared ReadOnly Property ZcadApplication As Object
    Get
public:
static property Object^ ZcadApplication {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


CommandEventArgs Class

CommandEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »CommandEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CommandEventArgs : EventArgs
Public NotInheritable Class CommandEventArgs _
    Inherits EventArgs
public ref class CommandEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandEventArgs()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalCommandName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CommandEventArgs

Assembly: ZwManaged (Module: ZwManaged)


CommandEventArgs Constructor

CommandEventArgs Constructor
Namespaces »ZwSoft.ZwCAD.ApplicationServices »CommandEventArgs »CommandEventArgs()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CommandEventArgs()
Public Sub New
public:
CommandEventArgs()

Assembly: ZwManaged (Module: ZwManaged)


GlobalCommandName Property

GlobalCommandName Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »CommandEventArgs »GlobalCommandName
Declaration Syntax
C# Visual Basic Visual C++
public string GlobalCommandName { get; }
Public ReadOnly Property GlobalCommandName As String
    Get
public:
property String^ GlobalCommandName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


CommandEventHandler Delegate

CommandEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »CommandEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void CommandEventHandler(
    Object sender,
    CommandEventArgs e
)
Public Delegate Sub CommandEventHandler ( _
    sender As Object, _
    e As CommandEventArgs _
)
public delegate void CommandEventHandler(
    Object^ sender,
    CommandEventArgs^ e
)
Parameters
sender(Object)
e(CommandEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


CommandLinePrompts Class

CommandLinePrompts Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »CommandLinePrompts
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CommandLinePrompts
Public NotInheritable Class CommandLinePrompts
public ref class CommandLinePrompts sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetString(String*, String, Boolean) |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message(String) |
 | Select(ObjectIdCollection*) |
 | ToString()()()() | (Inherited from Object.)
 | UseCommandLineInterface |
Inheritance Hierarchy
Object
CommandLinePrompts

Assembly: ZwManaged (Module: ZwManaged)


GetString Method (result, prompt, returnOnly)

GetString Method (result, prompt, returnOnly)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »CommandLinePrompts »GetString(String*, String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static CommandLinePrompts..::..PromptResult GetString(
    string* result,
    string prompt,
    bool returnOnly
)
Public Shared Function GetString ( _
    <OutAttribute> result As String*, _
    prompt As String, _
    returnOnly As Boolean _
) As CommandLinePrompts..::..PromptResult
public:
static CommandLinePrompts..::..PromptResult GetString(
    [OutAttribute] String^* result,
    String^ prompt,
    bool returnOnly
)
Parameters
result(String*)
prompt(String)
returnOnly(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


Message Method (value)

Message Method (value)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »CommandLinePrompts »Message(String)
Declaration Syntax
C# Visual Basic Visual C++
public static void Message(
    string value
)
Public Shared Sub Message ( _
    value As String _
)
public:
static void Message(
    String^ value
)
Parameters
value(String)

Assembly: ZwManaged (Module: ZwManaged)


Select Method (ids)

Select Method (ids)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »CommandLinePrompts »Select(ObjectIdCollection*)
Declaration Syntax
C# Visual Basic Visual C++
public static CommandLinePrompts..::..PromptResult Select(
    ObjectIdCollection* ids
)
Public Shared Function Select ( _
    <OutAttribute> ids As ObjectIdCollection* _
) As CommandLinePrompts..::..PromptResult
public:
static CommandLinePrompts..::..PromptResult Select(
    [OutAttribute] ObjectIdCollection^* ids
)
Parameters
ids(ObjectIdCollection*)

Assembly: ZwManaged (Module: ZwManaged)


UseCommandLineInterface Property

UseCommandLineInterface Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »CommandLinePrompts »UseCommandLineInterface
Declaration Syntax
C# Visual Basic Visual C++
public static bool UseCommandLineInterface { get; }
Public Shared ReadOnly Property UseCommandLineInterface As Boolean
    Get
public:
static property bool UseCommandLineInterface {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


CommandLinePrompts.PromptResult Enumeration

CommandLinePrompts..::..PromptResult Enumeration
Namespaces »ZwSoft.ZwCAD.ApplicationServices »CommandLinePrompts »CommandLinePrompts..::..PromptResult
Declaration Syntax
C# Visual Basic Visual C++
public enum PromptResult
Public Enumeration PromptResult
public enum class PromptResult
Members
Member | Description
Cancelled |
OK |

Assembly: ZwManaged (Module: ZwManaged)


ConfigurationSectionNameAttribute Class

ConfigurationSectionNameAttribute Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »ConfigurationSectionNameAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false, Inherited = false)]
public sealed class ConfigurationSectionNameAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := False, Inherited := False)> _
Public NotInheritable Class ConfigurationSectionNameAttribute _
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false, Inherited = false)]
public ref class ConfigurationSectionNameAttribute sealed : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationSectionNameAttribute(String) |
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | ConfigurationSectionNameAttribute

Assembly: ZwManaged (Module: ZwManaged)


ConfigurationSectionNameAttribute Constructor (name)

ConfigurationSectionNameAttribute Constructor (name)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »ConfigurationSectionNameAttribute »ConfigurationSectionNameAttribute(String)
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationSectionNameAttribute(
    string name
)
Public Sub New ( _
    name As String _
)
public:
ConfigurationSectionNameAttribute(
    String^ name
)
Parameters
name(String)

Assembly: ZwManaged (Module: ZwManaged)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »ConfigurationSectionNameAttribute »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Document Class

Document Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcApDocument")]
public sealed class Document : DisposableWrapper
<WrapperAttribute("AcApDocument")> _
Public NotInheritable Class Document _
    Inherits DisposableWrapper
[WrapperAttribute(L"AcApDocument")]
public ref class Document sealed : public DisposableWrapper
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BeginDocumentClose |
 | BeginDwgOpen |
 | CapturePreviewImage(UInt32, UInt32) |
 | CloseAborted |
 | CloseAndDiscard()()()() |
 | CloseAndSave(String) |
 | CloseWillStart |
 | CommandCancelled |
 | CommandEnded |
 | CommandFailed |
 | CommandInProgress |
 | CommandWillStart |
 | Create(IntPtr) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database |
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeDocOpen(Boolean) |
 | Editor |
 | EndDwgOpen |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FromZcadDocument(Object) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | GraphicsManager |
 | ImpliedSelectionChanged |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsActive |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsReadOnly |
 | LispCancelled |
 | LispEnded |
 | LispWillStart |
 | LockDocument(DocumentLockMode, String, String, Boolean) |
 | LockDocument()()()() |
 | LockMode(Boolean) |
 | LockMode()()()() |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | PopDbmod()()()() |
 | PushDbmod()()()() |
 | SendStringToExecute(String, Boolean, Boolean, Boolean) |
 | StatusBar |
 | ToString()()()() | (Inherited from Object.)
 | TransactionManager |
 | TryGetDatabase()()()() |
 | UnknownCommand |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeDocOpen()()()() |
 | UserData |
 | ViewChanged |
 | Window |
 | ZcadDocument |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Document

Assembly: ZwManaged (Module: ZwManaged)


BeginDocumentClose Event

BeginDocumentClose Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »BeginDocumentClose
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentBeginCloseEventHandler BeginDocumentClose
Public Event BeginDocumentClose As DocumentBeginCloseEventHandler
public:
 event DocumentBeginCloseEventHandler^ BeginDocumentClose {
    void add (DocumentBeginCloseEventHandler^ value);
    void remove (DocumentBeginCloseEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


BeginDwgOpen Event

BeginDwgOpen Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »BeginDwgOpen
Declaration Syntax
C# Visual Basic Visual C++
public event DrawingOpenEventHandler BeginDwgOpen
Public Event BeginDwgOpen As DrawingOpenEventHandler
public:
 event DrawingOpenEventHandler^ BeginDwgOpen {
    void add (DrawingOpenEventHandler^ value);
    void remove (DrawingOpenEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


CapturePreviewImage Method (width, height)

CapturePreviewImage Method (width, height)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »CapturePreviewImage(UInt32, UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap CapturePreviewImage(
    uint width,
    uint height
)
Public Function CapturePreviewImage ( _
    width As UInteger, _
    height As UInteger _
) As Bitmap
public:
Bitmap^ CapturePreviewImage(
    unsigned int width,
    unsigned int height
)
Parameters
width(UInt32)
height(UInt32)

Assembly: ZwManaged (Module: ZwManaged)


CloseAborted Event

CloseAborted Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »CloseAborted
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler CloseAborted
Public Event CloseAborted As EventHandler
public:
 event EventHandler^ CloseAborted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


CloseAndDiscard Method

CloseAndDiscard Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »CloseAndDiscard()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void CloseAndDiscard()
Public Sub CloseAndDiscard
public:
void CloseAndDiscard()

Assembly: ZwManaged (Module: ZwManaged)


CloseAndSave Method (fileName)

CloseAndSave Method (fileName)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »CloseAndSave(String)
Declaration Syntax
C# Visual Basic Visual C++
public void CloseAndSave(
    string fileName
)
Public Sub CloseAndSave ( _
    fileName As String _
)
public:
void CloseAndSave(
    String^ fileName
)
Parameters
fileName(String)

Assembly: ZwManaged (Module: ZwManaged)


CloseWillStart Event

CloseWillStart Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »CloseWillStart
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler CloseWillStart
Public Event CloseWillStart As EventHandler
public:
 event EventHandler^ CloseWillStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


CommandCancelled Event

CommandCancelled Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »CommandCancelled
Declaration Syntax
C# Visual Basic Visual C++
public event CommandEventHandler CommandCancelled
Public Event CommandCancelled As CommandEventHandler
public:
 event CommandEventHandler^ CommandCancelled {
    void add (CommandEventHandler^ value);
    void remove (CommandEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


CommandEnded Event

CommandEnded Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »CommandEnded
Declaration Syntax
C# Visual Basic Visual C++
public event CommandEventHandler CommandEnded
Public Event CommandEnded As CommandEventHandler
public:
 event CommandEventHandler^ CommandEnded {
    void add (CommandEventHandler^ value);
    void remove (CommandEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


CommandFailed Event

CommandFailed Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »CommandFailed
Declaration Syntax
C# Visual Basic Visual C++
public event CommandEventHandler CommandFailed
Public Event CommandFailed As CommandEventHandler
public:
 event CommandEventHandler^ CommandFailed {
    void add (CommandEventHandler^ value);
    void remove (CommandEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


CommandInProgress Property

CommandInProgress Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »CommandInProgress
Declaration Syntax
C# Visual Basic Visual C++
public string CommandInProgress { get; }
Public ReadOnly Property CommandInProgress As String
    Get
public:
property String^ CommandInProgress {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


CommandWillStart Event

CommandWillStart Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »CommandWillStart
Declaration Syntax
C# Visual Basic Visual C++
public event CommandEventHandler CommandWillStart
Public Event CommandWillStart As CommandEventHandler
public:
 event CommandEventHandler^ CommandWillStart {
    void add (CommandEventHandler^ value);
    void remove (CommandEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Create Method (unmanagedPointer)

Create Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »Create(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static Document Create(
    IntPtr unmanagedPointer
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr _
) As Document
public:
static Document^ Create(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


Database Property

Database Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »Database
Declaration Syntax
C# Visual Basic Visual C++
public Database Database { get; }
Public ReadOnly Property Database As Database
    Get
public:
property Database^ Database {
    Database^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DowngradeDocOpen Method (bPromptForSave)

DowngradeDocOpen Method (bPromptForSave)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »DowngradeDocOpen(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void DowngradeDocOpen(
    bool bPromptForSave
)
Public Sub DowngradeDocOpen ( _
    bPromptForSave As Boolean _
)
public:
void DowngradeDocOpen(
    bool bPromptForSave
)
Parameters
bPromptForSave(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


Editor Property

Editor Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »Editor
Declaration Syntax
C# Visual Basic Visual C++
public Editor Editor { get; }
Public ReadOnly Property Editor As Editor
    Get
public:
property Editor^ Editor {
    Editor^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EndDwgOpen Event

EndDwgOpen Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »EndDwgOpen
Declaration Syntax
C# Visual Basic Visual C++
public event DrawingOpenEventHandler EndDwgOpen
Public Event EndDwgOpen As DrawingOpenEventHandler
public:
 event DrawingOpenEventHandler^ EndDwgOpen {
    void add (DrawingOpenEventHandler^ value);
    void remove (DrawingOpenEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


FromZcadDocument Method (zcadDocument)

FromZcadDocument Method (zcadDocument)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »FromZcadDocument(Object)
Declaration Syntax
C# Visual Basic Visual C++
public static Document FromZcadDocument(
    Object zcadDocument
)
Public Shared Function FromZcadDocument ( _
    zcadDocument As Object _
) As Document
public:
static Document^ FromZcadDocument(
    Object^ zcadDocument
)
Parameters
zcadDocument(Object)

Assembly: ZwManaged (Module: ZwManaged)


GraphicsManager Property

GraphicsManager Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »GraphicsManager
Declaration Syntax
C# Visual Basic Visual C++
public Manager GraphicsManager { get; }
Public ReadOnly Property GraphicsManager As Manager
    Get
public:
property Manager^ GraphicsManager {
    Manager^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ImpliedSelectionChanged Event

ImpliedSelectionChanged Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »ImpliedSelectionChanged
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ImpliedSelectionChanged
Public Event ImpliedSelectionChanged As EventHandler
public:
 event EventHandler^ ImpliedSelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


IsActive Property

IsActive Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »IsActive
Declaration Syntax
C# Visual Basic Visual C++
public bool IsActive { get; }
Public ReadOnly Property IsActive As Boolean
    Get
public:
property bool IsActive {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LispCancelled Event

LispCancelled Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »LispCancelled
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler LispCancelled
Public Event LispCancelled As EventHandler
public:
 event EventHandler^ LispCancelled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


LispEnded Event

LispEnded Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »LispEnded
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler LispEnded
Public Event LispEnded As EventHandler
public:
 event EventHandler^ LispEnded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


LispWillStart Event

LispWillStart Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »LispWillStart
Declaration Syntax
C# Visual Basic Visual C++
public event LispWillStartEventHandler LispWillStart
Public Event LispWillStart As LispWillStartEventHandler
public:
 event LispWillStartEventHandler^ LispWillStart {
    void add (LispWillStartEventHandler^ value);
    void remove (LispWillStartEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


LockDocument Method

LockDocument Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »LockDocument()()()()
Members
Icon | Member | Description
 | LockDocument(DocumentLockMode, String, String, Boolean) |
 | LockDocument()()()() |

Assembly: ZwManaged (Module: ZwManaged)


LockDocument Method

LockDocument Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »LockDocument()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLock LockDocument()
Public Function LockDocument As DocumentLock
public:
DocumentLock^ LockDocument()

Assembly: ZwManaged (Module: ZwManaged)


LockDocument Method (lockMode, globalCommandName, localCommandName, promptIfFails)

LockDocument Method (lockMode, globalCommandName, localCommandName, promptIfFails)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »LockDocument(DocumentLockMode, String, String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLock LockDocument(
    DocumentLockMode lockMode,
    string globalCommandName,
    string localCommandName,
    bool promptIfFails
)
Public Function LockDocument ( _
    lockMode As DocumentLockMode, _
    globalCommandName As String, _
    localCommandName As String, _
    promptIfFails As Boolean _
) As DocumentLock
public:
DocumentLock^ LockDocument(
    DocumentLockMode lockMode,
    String^ globalCommandName,
    String^ localCommandName,
    bool promptIfFails
)
Parameters
lockMode(DocumentLockMode)
globalCommandName(String)
localCommandName(String)
promptIfFails(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


LockMode Method

LockMode Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »LockMode()()()()
Members
Icon | Member | Description
 | LockMode(Boolean) |
 | LockMode()()()() |

Assembly: ZwManaged (Module: ZwManaged)


LockMode Method

LockMode Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »LockMode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLockMode LockMode()
Public Function LockMode As DocumentLockMode
public:
DocumentLockMode LockMode()

Assembly: ZwManaged (Module: ZwManaged)


LockMode Method (bIncludeMyLocks)

LockMode Method (bIncludeMyLocks)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »LockMode(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLockMode LockMode(
    bool bIncludeMyLocks
)
Public Function LockMode ( _
    bIncludeMyLocks As Boolean _
) As DocumentLockMode
public:
DocumentLockMode LockMode(
    bool bIncludeMyLocks
)
Parameters
bIncludeMyLocks(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PopDbmod Method

PopDbmod Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »PopDbmod()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void PopDbmod()
Public Sub PopDbmod
public:
void PopDbmod()

Assembly: ZwManaged (Module: ZwManaged)


PushDbmod Method

PushDbmod Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »PushDbmod()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void PushDbmod()
Public Sub PushDbmod
public:
void PushDbmod()

Assembly: ZwManaged (Module: ZwManaged)


SendStringToExecute Method (command, activate, wrapUpInactiveDoc, echoCommand)

SendStringToExecute Method (command, activate, wrapUpInactiveDoc, echoCommand)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »SendStringToExecute(String, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SendStringToExecute(
    string command,
    bool activate,
    bool wrapUpInactiveDoc,
    bool echoCommand
)
Public Sub SendStringToExecute ( _
    command As String, _
    activate As Boolean, _
    wrapUpInactiveDoc As Boolean, _
    echoCommand As Boolean _
)
public:
void SendStringToExecute(
    String^ command,
    bool activate,
    bool wrapUpInactiveDoc,
    bool echoCommand
)
Parameters
command(String)
activate(Boolean)
wrapUpInactiveDoc(Boolean)
echoCommand(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


StatusBar Property

StatusBar Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »StatusBar
Declaration Syntax
C# Visual Basic Visual C++
public StatusBar StatusBar { get; }
Public ReadOnly Property StatusBar As StatusBar
    Get
public:
property StatusBar^ StatusBar {
    StatusBar^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


TransactionManager Property

TransactionManager Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »TransactionManager
Declaration Syntax
C# Visual Basic Visual C++
public TransactionManager TransactionManager { get; }
Public ReadOnly Property TransactionManager As TransactionManager
    Get
public:
property TransactionManager^ TransactionManager {
    TransactionManager^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


TryGetDatabase Method

TryGetDatabase Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »TryGetDatabase()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Database TryGetDatabase()
Public Function TryGetDatabase As Database
public:
Database^ TryGetDatabase()

Assembly: ZwManaged (Module: ZwManaged)


UnknownCommand Event

UnknownCommand Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »UnknownCommand
Declaration Syntax
C# Visual Basic Visual C++
public event UnknownCommandEventHandler UnknownCommand
Public Event UnknownCommand As UnknownCommandEventHandler
public:
 event UnknownCommandEventHandler^ UnknownCommand {
    void add (UnknownCommandEventHandler^ value);
    void remove (UnknownCommandEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


UpgradeDocOpen Method

UpgradeDocOpen Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »UpgradeDocOpen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpgradeDocOpen()
Public Sub UpgradeDocOpen
public:
void UpgradeDocOpen()

Assembly: ZwManaged (Module: ZwManaged)


UserData Property

UserData Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »UserData
Declaration Syntax
C# Visual Basic Visual C++
public Hashtable UserData { get; }
Public ReadOnly Property UserData As Hashtable
    Get
public:
property Hashtable^ UserData {
    Hashtable^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ViewChanged Event

ViewChanged Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »ViewChanged
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ViewChanged
Public Event ViewChanged As EventHandler
public:
 event EventHandler^ ViewChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Window Property

Window Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »Window
Declaration Syntax
C# Visual Basic Visual C++
public Window Window { get; }
Public ReadOnly Property Window As Window
    Get
public:
property Window^ Window {
    Window^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ZcadDocument Property

ZcadDocument Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »ZcadDocument
Declaration Syntax
C# Visual Basic Visual C++
public Object ZcadDocument { get; }
Public ReadOnly Property ZcadDocument As Object
    Get
public:
property Object^ ZcadDocument {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentActivationChangedEventArgs Class

DocumentActivationChangedEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentActivationChangedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DocumentActivationChangedEventArgs : EventArgs
Public NotInheritable Class DocumentActivationChangedEventArgs _
    Inherits EventArgs
public ref class DocumentActivationChangedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewValue |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DocumentActivationChangedEventArgs

Assembly: ZwManaged (Module: ZwManaged)


NewValue Property

NewValue Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentActivationChangedEventArgs »NewValue
Declaration Syntax
C# Visual Basic Visual C++
public bool NewValue { get; }
Public ReadOnly Property NewValue As Boolean
    Get
public:
property bool NewValue {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentActivationChangedEventHandler Delegate

DocumentActivationChangedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentActivationChangedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DocumentActivationChangedEventHandler(
    Object sender,
    DocumentActivationChangedEventArgs e
)
Public Delegate Sub DocumentActivationChangedEventHandler ( _
    sender As Object, _
    e As DocumentActivationChangedEventArgs _
)
public delegate void DocumentActivationChangedEventHandler(
    Object^ sender,
    DocumentActivationChangedEventArgs^ e
)
Parameters
sender(Object)
e(DocumentActivationChangedEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


DocumentBeginCloseEventArgs Class

DocumentBeginCloseEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentBeginCloseEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DocumentBeginCloseEventArgs : EventArgs
Public NotInheritable Class DocumentBeginCloseEventArgs _
    Inherits EventArgs
public ref class DocumentBeginCloseEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DocumentBeginCloseEventArgs()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Veto()()()() |
Inheritance Hierarchy
Object
 | EventArgs
 |  | DocumentBeginCloseEventArgs

Assembly: ZwManaged (Module: ZwManaged)


DocumentBeginCloseEventArgs Constructor

DocumentBeginCloseEventArgs Constructor
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentBeginCloseEventArgs »DocumentBeginCloseEventArgs()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DocumentBeginCloseEventArgs()
Public Sub New
public:
DocumentBeginCloseEventArgs()

Assembly: ZwManaged (Module: ZwManaged)


Veto Method

Veto Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentBeginCloseEventArgs »Veto()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Veto()
Public Sub Veto
public:
void Veto()

Assembly: ZwManaged (Module: ZwManaged)


DocumentBeginCloseEventHandler Delegate

DocumentBeginCloseEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentBeginCloseEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DocumentBeginCloseEventHandler(
    Object sender,
    DocumentBeginCloseEventArgs e
)
Public Delegate Sub DocumentBeginCloseEventHandler ( _
    sender As Object, _
    e As DocumentBeginCloseEventArgs _
)
public delegate void DocumentBeginCloseEventHandler(
    Object^ sender,
    DocumentBeginCloseEventArgs^ e
)
Parameters
sender(Object)
e(DocumentBeginCloseEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


DocumentCollection Class

DocumentCollection Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcApDocManager")]
public sealed class DocumentCollection : MarshalByRefObject,
    ICollection
<WrapperAttribute("AcApDocManager")> _
Public NotInheritable Class DocumentCollection _
    Inherits MarshalByRefObject _
    Implements ICollection
[WrapperAttribute(L"AcApDocManager")]
public ref class DocumentCollection sealed : public MarshalByRefObject,
    ICollection
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Add(String) |
 | CloseAll()()()() |
 | CopyTo(array<Document>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DocumentActivated |
 | DocumentActivationChanged |
 | DocumentActivationEnabled |
 | DocumentBecameCurrent |
 | DocumentCreated |
 | DocumentCreateStarted |
 | DocumentCreationCanceled |
 | DocumentDestroyed |
 | DocumentLockModeChanged |
 | DocumentLockModeChangeVetoed |
 | DocumentLockModeWillChange |
 | DocumentToBeActivated |
 | DocumentToBeDeactivated |
 | DocumentToBeDestroyed |
 | Equals(Object) | (Inherited from Object.)
 | ExecuteInApplicationContext(ExecuteInApplicationContextCallback, Object) |
 | Finalize()()()() | (Inherited from Object.)
 | GetDocument(Database) |
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsApplicationContext |
 | ICollection..::..IsSynchronized |
 | MdiActiveDocument |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Open(String, Boolean, String) |
 | Open(String, Boolean) |
 | Open(String) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DocumentCollection

Assembly: ZwManaged (Module: ZwManaged)


Add Method (templateFileName)

Add Method (templateFileName)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »Add(String)
Declaration Syntax
C# Visual Basic Visual C++
public Document Add(
    string templateFileName
)
Public Function Add ( _
    templateFileName As String _
) As Document
public:
Document^ Add(
    String^ templateFileName
)
Parameters
templateFileName(String)

Assembly: ZwManaged (Module: ZwManaged)


CloseAll Method

CloseAll Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »CloseAll()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void CloseAll()
Public Sub CloseAll
public:
void CloseAll()

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method

CopyTo Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<Document>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub CopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void CopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »CopyTo(array<Document>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Document[] array,
    int index
)
Public Sub CopyTo ( _
    array As Document(), _
    index As Integer _
)
public:
void CopyTo(
    array<Document^>^ array,
    int index
)
Parameters
array(array< Document >[]()[][])
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentActivated Event

DocumentActivated Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentActivated
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentCollectionEventHandler DocumentActivated
Public Event DocumentActivated As DocumentCollectionEventHandler
public:
 event DocumentCollectionEventHandler^ DocumentActivated {
    void add (DocumentCollectionEventHandler^ value);
    void remove (DocumentCollectionEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentActivationChanged Event

DocumentActivationChanged Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentActivationChanged
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentActivationChangedEventHandler DocumentActivationChanged
Public Event DocumentActivationChanged As DocumentActivationChangedEventHandler
public:
 event DocumentActivationChangedEventHandler^ DocumentActivationChanged {
    void add (DocumentActivationChangedEventHandler^ value);
    void remove (DocumentActivationChangedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentActivationEnabled Property

DocumentActivationEnabled Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentActivationEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool DocumentActivationEnabled { get; set; }
Public Property DocumentActivationEnabled As Boolean
    Get
    Set
public:
property bool DocumentActivationEnabled {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentBecameCurrent Event

DocumentBecameCurrent Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentBecameCurrent
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentCollectionEventHandler DocumentBecameCurrent
Public Event DocumentBecameCurrent As DocumentCollectionEventHandler
public:
 event DocumentCollectionEventHandler^ DocumentBecameCurrent {
    void add (DocumentCollectionEventHandler^ value);
    void remove (DocumentCollectionEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentCreated Event

DocumentCreated Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentCreated
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentCollectionEventHandler DocumentCreated
Public Event DocumentCreated As DocumentCollectionEventHandler
public:
 event DocumentCollectionEventHandler^ DocumentCreated {
    void add (DocumentCollectionEventHandler^ value);
    void remove (DocumentCollectionEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentCreateStarted Event

DocumentCreateStarted Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentCreateStarted
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentCollectionEventHandler DocumentCreateStarted
Public Event DocumentCreateStarted As DocumentCollectionEventHandler
public:
 event DocumentCollectionEventHandler^ DocumentCreateStarted {
    void add (DocumentCollectionEventHandler^ value);
    void remove (DocumentCollectionEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentCreationCanceled Event

DocumentCreationCanceled Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentCreationCanceled
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentCollectionEventHandler DocumentCreationCanceled
Public Event DocumentCreationCanceled As DocumentCollectionEventHandler
public:
 event DocumentCollectionEventHandler^ DocumentCreationCanceled {
    void add (DocumentCollectionEventHandler^ value);
    void remove (DocumentCollectionEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentDestroyed Event

DocumentDestroyed Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentDestroyed
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentDestroyedEventHandler DocumentDestroyed
Public Event DocumentDestroyed As DocumentDestroyedEventHandler
public:
 event DocumentDestroyedEventHandler^ DocumentDestroyed {
    void add (DocumentDestroyedEventHandler^ value);
    void remove (DocumentDestroyedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentLockModeChanged Event

DocumentLockModeChanged Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentLockModeChanged
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentLockModeChangedEventHandler DocumentLockModeChanged
Public Event DocumentLockModeChanged As DocumentLockModeChangedEventHandler
public:
 event DocumentLockModeChangedEventHandler^ DocumentLockModeChanged {
    void add (DocumentLockModeChangedEventHandler^ value);
    void remove (DocumentLockModeChangedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentLockModeChangeVetoed Event

DocumentLockModeChangeVetoed Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentLockModeChangeVetoed
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentLockModeChangeVetoedEventHandler DocumentLockModeChangeVetoed
Public Event DocumentLockModeChangeVetoed As DocumentLockModeChangeVetoedEventHandler
public:
 event DocumentLockModeChangeVetoedEventHandler^ DocumentLockModeChangeVetoed {
    void add (DocumentLockModeChangeVetoedEventHandler^ value);
    void remove (DocumentLockModeChangeVetoedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentLockModeWillChange Event

DocumentLockModeWillChange Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentLockModeWillChange
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentLockModeWillChangeEventHandler DocumentLockModeWillChange
Public Event DocumentLockModeWillChange As DocumentLockModeWillChangeEventHandler
public:
 event DocumentLockModeWillChangeEventHandler^ DocumentLockModeWillChange {
    void add (DocumentLockModeWillChangeEventHandler^ value);
    void remove (DocumentLockModeWillChangeEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentToBeActivated Event

DocumentToBeActivated Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentToBeActivated
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentCollectionEventHandler DocumentToBeActivated
Public Event DocumentToBeActivated As DocumentCollectionEventHandler
public:
 event DocumentCollectionEventHandler^ DocumentToBeActivated {
    void add (DocumentCollectionEventHandler^ value);
    void remove (DocumentCollectionEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentToBeDeactivated Event

DocumentToBeDeactivated Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentToBeDeactivated
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentCollectionEventHandler DocumentToBeDeactivated
Public Event DocumentToBeDeactivated As DocumentCollectionEventHandler
public:
 event DocumentCollectionEventHandler^ DocumentToBeDeactivated {
    void add (DocumentCollectionEventHandler^ value);
    void remove (DocumentCollectionEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentToBeDestroyed Event

DocumentToBeDestroyed Event
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »DocumentToBeDestroyed
Declaration Syntax
C# Visual Basic Visual C++
public event DocumentCollectionEventHandler DocumentToBeDestroyed
Public Event DocumentToBeDestroyed As DocumentCollectionEventHandler
public:
 event DocumentCollectionEventHandler^ DocumentToBeDestroyed {
    void add (DocumentCollectionEventHandler^ value);
    void remove (DocumentCollectionEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


ExecuteInApplicationContext Method (callback, data)

ExecuteInApplicationContext Method (callback, data)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »ExecuteInApplicationContext(ExecuteInApplicationContextCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public void ExecuteInApplicationContext(
    ExecuteInApplicationContextCallback callback,
    Object data
)
Public Sub ExecuteInApplicationContext ( _
    callback As ExecuteInApplicationContextCallback, _
    data As Object _
)
public:
void ExecuteInApplicationContext(
    ExecuteInApplicationContextCallback^ callback,
    Object^ data
)
Parameters
callback(ExecuteInApplicationContextCallback)
data(Object)

Assembly: ZwManaged (Module: ZwManaged)


GetDocument Method (db)

GetDocument Method (db)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »GetDocument(Database)
Declaration Syntax
C# Visual Basic Visual C++
public Document GetDocument(
    Database db
)
Public Function GetDocument ( _
    db As Database _
) As Document
public:
Document^ GetDocument(
    Database^ db
)
Parameters
db(Database)

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed

Assembly: ZwManaged (Module: ZwManaged)


IsApplicationContext Property

IsApplicationContext Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »IsApplicationContext
Declaration Syntax
C# Visual Basic Visual C++
public bool IsApplicationContext { get; }
Public ReadOnly Property IsApplicationContext As Boolean
    Get
public:
property bool IsApplicationContext {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}

Assembly: ZwManaged (Module: ZwManaged)


MdiActiveDocument Property

MdiActiveDocument Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »MdiActiveDocument
Declaration Syntax
C# Visual Basic Visual C++
public Document MdiActiveDocument { get; set; }
Public Property MdiActiveDocument As Document
    Get
    Set
public:
property Document^ MdiActiveDocument {
    Document^ get ();
    void set (Document^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Open Method

Open Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »Open()()()()
Members
Icon | Member | Description
 | Open(String, Boolean, String) |
 | Open(String, Boolean) |
 | Open(String) |

Assembly: ZwManaged (Module: ZwManaged)


Open Method (fileName)

Open Method (fileName)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »Open(String)
Declaration Syntax
C# Visual Basic Visual C++
public Document Open(
    string fileName
)
Public Function Open ( _
    fileName As String _
) As Document
public:
Document^ Open(
    String^ fileName
)
Parameters
fileName(String)

Assembly: ZwManaged (Module: ZwManaged)


Open Method (fileName, forReadOnly)

Open Method (fileName, forReadOnly)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »Open(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Document Open(
    string fileName,
    bool forReadOnly
)
Public Function Open ( _
    fileName As String, _
    forReadOnly As Boolean _
) As Document
public:
Document^ Open(
    String^ fileName,
    bool forReadOnly
)
Parameters
fileName(String)
forReadOnly(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


Open Method (fileName, forReadOnly, password)

Open Method (fileName, forReadOnly, password)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »Open(String, Boolean, String)
Declaration Syntax
C# Visual Basic Visual C++
public Document Open(
    string fileName,
    bool forReadOnly,
    string password
)
Public Function Open ( _
    fileName As String, _
    forReadOnly As Boolean, _
    password As String _
) As Document
public:
Document^ Open(
    String^ fileName,
    bool forReadOnly,
    String^ password
)
Parameters
fileName(String)
forReadOnly(Boolean)
password(String)

Assembly: ZwManaged (Module: ZwManaged)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentCollectionEventArgs Class

DocumentCollectionEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollectionEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DocumentCollectionEventArgs : EventArgs
Public NotInheritable Class DocumentCollectionEventArgs _
    Inherits EventArgs
public ref class DocumentCollectionEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Document |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DocumentCollectionEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Document Property

Document Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollectionEventArgs »Document
Declaration Syntax
C# Visual Basic Visual C++
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
public:
property Document^ Document {
    Document^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentCollectionEventHandler Delegate

DocumentCollectionEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollectionEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DocumentCollectionEventHandler(
    Object sender,
    DocumentCollectionEventArgs e
)
Public Delegate Sub DocumentCollectionEventHandler ( _
    sender As Object, _
    e As DocumentCollectionEventArgs _
)
public delegate void DocumentCollectionEventHandler(
    Object^ sender,
    DocumentCollectionEventArgs^ e
)
Parameters
sender(Object)
e(DocumentCollectionEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


DocumentDestroyedEventArgs Class

DocumentDestroyedEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentDestroyedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DocumentDestroyedEventArgs : EventArgs
Public NotInheritable Class DocumentDestroyedEventArgs _
    Inherits EventArgs
public ref class DocumentDestroyedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | FileName |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DocumentDestroyedEventArgs

Assembly: ZwManaged (Module: ZwManaged)


FileName Property

FileName Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentDestroyedEventArgs »FileName
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentDestroyedEventHandler Delegate

DocumentDestroyedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentDestroyedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DocumentDestroyedEventHandler(
    Object sender,
    DocumentDestroyedEventArgs e
)
Public Delegate Sub DocumentDestroyedEventHandler ( _
    sender As Object, _
    e As DocumentDestroyedEventArgs _
)
public delegate void DocumentDestroyedEventHandler(
    Object^ sender,
    DocumentDestroyedEventArgs^ e
)
Parameters
sender(Object)
e(DocumentDestroyedEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


DocumentLock Class

DocumentLock Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLock
Declaration Syntax
C# Visual Basic Visual C++
public class DocumentLock : IDisposable
Public Class DocumentLock _
    Implements IDisposable
public ref class DocumentLock : IDisposable
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DocumentLock

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLock »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLock »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method ()

Dispose Method ()
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLock »Dispose(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool
)
Protected Overridable Sub Dispose ( _
     As Boolean _
)
protected:
virtual void Dispose(
    bool
)
Parameters
(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


DocumentLockMode Enumeration

DocumentLockMode Enumeration
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockMode
Declaration Syntax
C# Visual Basic Visual C++
public enum DocumentLockMode
Public Enumeration DocumentLockMode
public enum class DocumentLockMode
Members
Member | Description
ExclusiveWrite |
Read |
ProtectedAutoWrite |
Write |
NotLocked |
AutoWrite |
None |

Assembly: ZwManaged (Module: ZwManaged)


DocumentLockModeChangedEventArgs Class

DocumentLockModeChangedEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DocumentLockModeChangedEventArgs : EventArgs
Public NotInheritable Class DocumentLockModeChangedEventArgs _
    Inherits EventArgs
public ref class DocumentLockModeChangedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CurrentMode |
 | Document |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalCommandName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MyCurrentMode |
 | MyPreviousMode |
 | ToString()()()() | (Inherited from Object.)
 | Veto()()()() |
Inheritance Hierarchy
Object
 | EventArgs
 |  | DocumentLockModeChangedEventArgs

Assembly: ZwManaged (Module: ZwManaged)


CurrentMode Property

CurrentMode Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangedEventArgs »CurrentMode
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLockMode CurrentMode { get; }
Public ReadOnly Property CurrentMode As DocumentLockMode
    Get
public:
property DocumentLockMode CurrentMode {
    DocumentLockMode get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Document Property

Document Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangedEventArgs »Document
Declaration Syntax
C# Visual Basic Visual C++
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
public:
property Document^ Document {
    Document^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GlobalCommandName Property

GlobalCommandName Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangedEventArgs »GlobalCommandName
Declaration Syntax
C# Visual Basic Visual C++
public string GlobalCommandName { get; }
Public ReadOnly Property GlobalCommandName As String
    Get
public:
property String^ GlobalCommandName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MyCurrentMode Property

MyCurrentMode Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangedEventArgs »MyCurrentMode
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLockMode MyCurrentMode { get; }
Public ReadOnly Property MyCurrentMode As DocumentLockMode
    Get
public:
property DocumentLockMode MyCurrentMode {
    DocumentLockMode get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MyPreviousMode Property

MyPreviousMode Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangedEventArgs »MyPreviousMode
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLockMode MyPreviousMode { get; }
Public ReadOnly Property MyPreviousMode As DocumentLockMode
    Get
public:
property DocumentLockMode MyPreviousMode {
    DocumentLockMode get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Veto Method

Veto Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangedEventArgs »Veto()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Veto()
Public Sub Veto
public:
void Veto()

Assembly: ZwManaged (Module: ZwManaged)


DocumentLockModeChangedEventHandler Delegate

DocumentLockModeChangedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DocumentLockModeChangedEventHandler(
    Object sender,
    DocumentLockModeChangedEventArgs e
)
Public Delegate Sub DocumentLockModeChangedEventHandler ( _
    sender As Object, _
    e As DocumentLockModeChangedEventArgs _
)
public delegate void DocumentLockModeChangedEventHandler(
    Object^ sender,
    DocumentLockModeChangedEventArgs^ e
)
Parameters
sender(Object)
e(DocumentLockModeChangedEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


DocumentLockModeChangeVetoedEventArgs Class

DocumentLockModeChangeVetoedEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangeVetoedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DocumentLockModeChangeVetoedEventArgs : EventArgs
Public NotInheritable Class DocumentLockModeChangeVetoedEventArgs _
    Inherits EventArgs
public ref class DocumentLockModeChangeVetoedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Document |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalCommandName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DocumentLockModeChangeVetoedEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Document Property

Document Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangeVetoedEventArgs »Document
Declaration Syntax
C# Visual Basic Visual C++
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
public:
property Document^ Document {
    Document^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GlobalCommandName Property

GlobalCommandName Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangeVetoedEventArgs »GlobalCommandName
Declaration Syntax
C# Visual Basic Visual C++
public string GlobalCommandName { get; }
Public ReadOnly Property GlobalCommandName As String
    Get
public:
property String^ GlobalCommandName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentLockModeChangeVetoedEventHandler Delegate

DocumentLockModeChangeVetoedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeChangeVetoedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DocumentLockModeChangeVetoedEventHandler(
    Object sender,
    DocumentLockModeChangeVetoedEventArgs e
)
Public Delegate Sub DocumentLockModeChangeVetoedEventHandler ( _
    sender As Object, _
    e As DocumentLockModeChangeVetoedEventArgs _
)
public delegate void DocumentLockModeChangeVetoedEventHandler(
    Object^ sender,
    DocumentLockModeChangeVetoedEventArgs^ e
)
Parameters
sender(Object)
e(DocumentLockModeChangeVetoedEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


DocumentLockModeWillChangeEventArgs Class

DocumentLockModeWillChangeEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeWillChangeEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DocumentLockModeWillChangeEventArgs : EventArgs
Public NotInheritable Class DocumentLockModeWillChangeEventArgs _
    Inherits EventArgs
public ref class DocumentLockModeWillChangeEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CurrentMode |
 | Document |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalCommandName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MyCurrentMode |
 | MyNewMode |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DocumentLockModeWillChangeEventArgs

Assembly: ZwManaged (Module: ZwManaged)


CurrentMode Property

CurrentMode Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeWillChangeEventArgs »CurrentMode
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLockMode CurrentMode { get; }
Public ReadOnly Property CurrentMode As DocumentLockMode
    Get
public:
property DocumentLockMode CurrentMode {
    DocumentLockMode get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Document Property

Document Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeWillChangeEventArgs »Document
Declaration Syntax
C# Visual Basic Visual C++
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
public:
property Document^ Document {
    Document^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GlobalCommandName Property

GlobalCommandName Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeWillChangeEventArgs »GlobalCommandName
Declaration Syntax
C# Visual Basic Visual C++
public string GlobalCommandName { get; }
Public ReadOnly Property GlobalCommandName As String
    Get
public:
property String^ GlobalCommandName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MyCurrentMode Property

MyCurrentMode Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeWillChangeEventArgs »MyCurrentMode
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLockMode MyCurrentMode { get; }
Public ReadOnly Property MyCurrentMode As DocumentLockMode
    Get
public:
property DocumentLockMode MyCurrentMode {
    DocumentLockMode get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MyNewMode Property

MyNewMode Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeWillChangeEventArgs »MyNewMode
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLockMode MyNewMode { get; }
Public ReadOnly Property MyNewMode As DocumentLockMode
    Get
public:
property DocumentLockMode MyNewMode {
    DocumentLockMode get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentLockModeWillChangeEventHandler Delegate

DocumentLockModeWillChangeEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentLockModeWillChangeEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DocumentLockModeWillChangeEventHandler(
    Object sender,
    DocumentLockModeWillChangeEventArgs e
)
Public Delegate Sub DocumentLockModeWillChangeEventHandler ( _
    sender As Object, _
    e As DocumentLockModeWillChangeEventArgs _
)
public delegate void DocumentLockModeWillChangeEventHandler(
    Object^ sender,
    DocumentLockModeWillChangeEventArgs^ e
)
Parameters
sender(Object)
e(DocumentLockModeWillChangeEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


DrawingOpenEventArgs Class

DrawingOpenEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DrawingOpenEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DrawingOpenEventArgs : EventArgs
Public NotInheritable Class DrawingOpenEventArgs _
    Inherits EventArgs
public ref class DrawingOpenEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Database |
 | Equals(Object) | (Inherited from Object.)
 | FileName |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DrawingOpenEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Database Property

Database Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DrawingOpenEventArgs »Database
Declaration Syntax
C# Visual Basic Visual C++
public Database Database { get; }
Public ReadOnly Property Database As Database
    Get
public:
property Database^ Database {
    Database^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


FileName Property

FileName Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DrawingOpenEventArgs »FileName
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DrawingOpenEventHandler Delegate

DrawingOpenEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DrawingOpenEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DrawingOpenEventHandler(
    Object sender,
    DrawingOpenEventArgs e
)
Public Delegate Sub DrawingOpenEventHandler ( _
    sender As Object, _
    e As DrawingOpenEventArgs _
)
public delegate void DrawingOpenEventHandler(
    Object^ sender,
    DrawingOpenEventArgs^ e
)
Parameters
sender(Object)
e(DrawingOpenEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


ExecuteInApplicationContextCallback Delegate

ExecuteInApplicationContextCallback Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »ExecuteInApplicationContextCallback
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ExecuteInApplicationContextCallback(
    Object userData
)
Public Delegate Sub ExecuteInApplicationContextCallback ( _
    userData As Object _
)
public delegate void ExecuteInApplicationContextCallback(
    Object^ userData
)
Parameters
userData(Object)

Assembly: ZwManaged (Module: ZwManaged)


IConfigurationSection Interface

IConfigurationSection Interface
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection
Declaration Syntax
C# Visual Basic Visual C++
public interface IConfigurationSection : IDisposable
Public Interface IConfigurationSection _
    Inherits IDisposable
public interface class IConfigurationSection : IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Close()()()() |
 | Contains(String) |
 | ContainsSubsection(String) |
 | CreateSubsection(String) |
 | Delete(String) |
 | DeleteSubsection(String) |
 | Dispose()()()() | (Inherited from IDisposable.)
 | IsReadOnly |
 | OpenSubsection(String) |
 | ReadProperty(String, Object) |
 | WriteProperty(String, Object) |

Assembly: ZwManaged (Module: ZwManaged)


Close Method

Close Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection »Close()()()()
Declaration Syntax
C# Visual Basic Visual C++
void Close()
Sub Close
void Close()

Assembly: ZwManaged (Module: ZwManaged)


Contains Method (name)

Contains Method (name)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection »Contains(String)
Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    string name
)
Function Contains ( _
    name As String _
) As Boolean
bool Contains(
    String^ name
)
Parameters
name(String)

Assembly: ZwManaged (Module: ZwManaged)


ContainsSubsection Method (name)

ContainsSubsection Method (name)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection »ContainsSubsection(String)
Declaration Syntax
C# Visual Basic Visual C++
bool ContainsSubsection(
    string name
)
Function ContainsSubsection ( _
    name As String _
) As Boolean
bool ContainsSubsection(
    String^ name
)
Parameters
name(String)

Assembly: ZwManaged (Module: ZwManaged)


CreateSubsection Method (name)

CreateSubsection Method (name)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection »CreateSubsection(String)
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationSection CreateSubsection(
    string name
)
Function CreateSubsection ( _
    name As String _
) As IConfigurationSection
IConfigurationSection^ CreateSubsection(
    String^ name
)
Parameters
name(String)

Assembly: ZwManaged (Module: ZwManaged)


Delete Method (name)

Delete Method (name)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection »Delete(String)
Declaration Syntax
C# Visual Basic Visual C++
void Delete(
    string name
)
Sub Delete ( _
    name As String _
)
void Delete(
    String^ name
)
Parameters
name(String)

Assembly: ZwManaged (Module: ZwManaged)


DeleteSubsection Method (name)

DeleteSubsection Method (name)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection »DeleteSubsection(String)
Declaration Syntax
C# Visual Basic Visual C++
void DeleteSubsection(
    string name
)
Sub DeleteSubsection ( _
    name As String _
)
void DeleteSubsection(
    String^ name
)
Parameters
name(String)

Assembly: ZwManaged (Module: ZwManaged)


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get
property bool IsReadOnly {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OpenSubsection Method (name)

OpenSubsection Method (name)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection »OpenSubsection(String)
Declaration Syntax
C# Visual Basic Visual C++
IConfigurationSection OpenSubsection(
    string name
)
Function OpenSubsection ( _
    name As String _
) As IConfigurationSection
IConfigurationSection^ OpenSubsection(
    String^ name
)
Parameters
name(String)

Assembly: ZwManaged (Module: ZwManaged)


ReadProperty Method (name, defaultValue)

ReadProperty Method (name, defaultValue)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection »ReadProperty(String, Object)
Declaration Syntax
C# Visual Basic Visual C++
Object ReadProperty(
    string name,
    Object defaultValue
)
Function ReadProperty ( _
    name As String, _
    defaultValue As Object _
) As Object
Object^ ReadProperty(
    String^ name,
    Object^ defaultValue
)
Parameters
name(String)
defaultValue(Object)

Assembly: ZwManaged (Module: ZwManaged)


WriteProperty Method (name, value)

WriteProperty Method (name, value)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »IConfigurationSection »WriteProperty(String, Object)
Declaration Syntax
C# Visual Basic Visual C++
void WriteProperty(
    string name,
    Object value
)
Sub WriteProperty ( _
    name As String, _
    value As Object _
)
void WriteProperty(
    String^ name,
    Object^ value
)
Parameters
name(String)
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


LispWillStartEventArgs Class

LispWillStartEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »LispWillStartEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LispWillStartEventArgs : EventArgs
Public NotInheritable Class LispWillStartEventArgs _
    Inherits EventArgs
public ref class LispWillStartEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FirstLine |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | LispWillStartEventArgs

Assembly: ZwManaged (Module: ZwManaged)


FirstLine Property

FirstLine Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »LispWillStartEventArgs »FirstLine
Declaration Syntax
C# Visual Basic Visual C++
public string FirstLine { get; }
Public ReadOnly Property FirstLine As String
    Get
public:
property String^ FirstLine {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LispWillStartEventHandler Delegate

LispWillStartEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »LispWillStartEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void LispWillStartEventHandler(
    Object sender,
    LispWillStartEventArgs e
)
Public Delegate Sub LispWillStartEventHandler ( _
    sender As Object, _
    e As LispWillStartEventArgs _
)
public delegate void LispWillStartEventHandler(
    Object^ sender,
    LispWillStartEventArgs^ e
)
Parameters
sender(Object)
e(LispWillStartEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


MgdUndoCommandInfo Class

MgdUndoCommandInfo Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »MgdUndoCommandInfo
Declaration Syntax
C# Visual Basic Visual C++
public sealed class MgdUndoCommandInfo
Public NotInheritable Class MgdUndoCommandInfo
public ref class MgdUndoCommandInfo sealed
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MgdUndoCommandInfo(Char*, Char*, Int32) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | globalName |
 | localName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | snapshotId |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
MgdUndoCommandInfo

Assembly: ZwManaged (Module: ZwManaged)


MgdUndoCommandInfo Constructor (pGlobalName, pLocalName, ssId)

MgdUndoCommandInfo Constructor (pGlobalName, pLocalName, ssId)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »MgdUndoCommandInfo »MgdUndoCommandInfo(Char*, Char*, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MgdUndoCommandInfo(
    char* pGlobalName,
    char* pLocalName,
    int ssId
)
Visual Basic does not support APIs that consume or return unsafe types.
public:
MgdUndoCommandInfo(
    wchar_t* pGlobalName,
    wchar_t* pLocalName,
    int ssId
)
Parameters
pGlobalName(Char*)
pLocalName(Char*)
ssId(Int32)

Assembly: ZwManaged (Module: ZwManaged)


globalName Field

globalName Field
Namespaces »ZwSoft.ZwCAD.ApplicationServices »MgdUndoCommandInfo »globalName
Declaration Syntax
C# Visual Basic Visual C++
public string globalName
Public globalName As String
public:
String^ globalName

Assembly: ZwManaged (Module: ZwManaged)


localName Field

localName Field
Namespaces »ZwSoft.ZwCAD.ApplicationServices »MgdUndoCommandInfo »localName
Declaration Syntax
C# Visual Basic Visual C++
public string localName
Public localName As String
public:
String^ localName

Assembly: ZwManaged (Module: ZwManaged)


snapshotId Field

snapshotId Field
Namespaces »ZwSoft.ZwCAD.ApplicationServices »MgdUndoCommandInfo »snapshotId
Declaration Syntax
C# Visual Basic Visual C++
public int snapshotId
Public snapshotId As Integer
public:
int snapshotId

Assembly: ZwManaged (Module: ZwManaged)


PreTranslateMessageEventArgs Class

PreTranslateMessageEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »PreTranslateMessageEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PreTranslateMessageEventArgs : EventArgs
Public NotInheritable Class PreTranslateMessageEventArgs _
    Inherits EventArgs
public ref class PreTranslateMessageEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Handled |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PreTranslateMessageEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Handled Property

Handled Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »PreTranslateMessageEventArgs »Handled
Declaration Syntax
C# Visual Basic Visual C++
public int Handled { get; set; }
Public Property Handled As Integer
    Get
    Set
public:
property int Handled {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


Message Property

Message Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »PreTranslateMessageEventArgs »Message
Declaration Syntax
C# Visual Basic Visual C++
public MSG Message { get; set; }
Public Property Message As MSG
    Get
    Set
public:
property MSG Message {
    MSG get ();
    void set (MSG value);
}

Assembly: ZwManaged (Module: ZwManaged)


PreTranslateMessageEventHandler Delegate

PreTranslateMessageEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »PreTranslateMessageEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PreTranslateMessageEventHandler(
    Object sender,
    PreTranslateMessageEventArgs e
)
Public Delegate Sub PreTranslateMessageEventHandler ( _
    sender As Object, _
    e As PreTranslateMessageEventArgs _
)
public delegate void PreTranslateMessageEventHandler(
    Object^ sender,
    PreTranslateMessageEventArgs^ e
)
Parameters
sender(Object)
e(PreTranslateMessageEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


SystemVariableChangedEventArgs Class

SystemVariableChangedEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »SystemVariableChangedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SystemVariableChangedEventArgs : EventArgs
Public NotInheritable Class SystemVariableChangedEventArgs _
    Inherits EventArgs
public ref class SystemVariableChangedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Changed |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SystemVariableChangedEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Changed Property

Changed Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »SystemVariableChangedEventArgs »Changed
Declaration Syntax
C# Visual Basic Visual C++
public bool Changed { get; }
Public ReadOnly Property Changed As Boolean
    Get
public:
property bool Changed {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »SystemVariableChangedEventArgs »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


SystemVariableChangedEventHandler Delegate

SystemVariableChangedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »SystemVariableChangedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void SystemVariableChangedEventHandler(
    Object sender,
    SystemVariableChangedEventArgs e
)
Public Delegate Sub SystemVariableChangedEventHandler ( _
    sender As Object, _
    e As SystemVariableChangedEventArgs _
)
public delegate void SystemVariableChangedEventHandler(
    Object^ sender,
    SystemVariableChangedEventArgs^ e
)
Parameters
sender(Object)
e(SystemVariableChangedEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


SystemVariableChangingEventArgs Class

SystemVariableChangingEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »SystemVariableChangingEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SystemVariableChangingEventArgs : EventArgs
Public NotInheritable Class SystemVariableChangingEventArgs _
    Inherits EventArgs
public ref class SystemVariableChangingEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SystemVariableChangingEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »SystemVariableChangingEventArgs »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


SystemVariableChangingEventHandler Delegate

SystemVariableChangingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »SystemVariableChangingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void SystemVariableChangingEventHandler(
    Object sender,
    SystemVariableChangingEventArgs e
)
Public Delegate Sub SystemVariableChangingEventHandler ( _
    sender As Object, _
    e As SystemVariableChangingEventArgs _
)
public delegate void SystemVariableChangingEventHandler(
    Object^ sender,
    SystemVariableChangingEventArgs^ e
)
Parameters
sender(Object)
e(SystemVariableChangingEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


TabbedDialogAction Delegate

TabbedDialogAction Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogAction
Declaration Syntax
C# Visual Basic Visual C++
public delegate void TabbedDialogAction()
Public Delegate Sub TabbedDialogAction
public delegate void TabbedDialogAction()

Assembly: ZwManaged (Module: ZwManaged)


TabbedDialogEventArgs Class

TabbedDialogEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class TabbedDialogEventArgs : EventArgs
Public NotInheritable Class TabbedDialogEventArgs _
    Inherits EventArgs
public ref class TabbedDialogEventArgs sealed : public EventArgs
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddTab(String, TabbedDialogExtension) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | TabbedDialogEventArgs

Assembly: ZwManaged (Module: ZwManaged)


AddTab Method (name, extension)

AddTab Method (name, extension)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogEventArgs »AddTab(String, TabbedDialogExtension)
Declaration Syntax
C# Visual Basic Visual C++
public void AddTab(
    string name,
    TabbedDialogExtension extension
)
Public Sub AddTab ( _
    name As String, _
    extension As TabbedDialogExtension _
)
public:
void AddTab(
    String^ name,
    TabbedDialogExtension^ extension
)
Parameters
name(String)
extension(TabbedDialogExtension)

Assembly: ZwManaged (Module: ZwManaged)


TabbedDialogEventHandler Delegate

TabbedDialogEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void TabbedDialogEventHandler(
    Object sender,
    TabbedDialogEventArgs e
)
Public Delegate Sub TabbedDialogEventHandler ( _
    sender As Object, _
    e As TabbedDialogEventArgs _
)
public delegate void TabbedDialogEventHandler(
    Object^ sender,
    TabbedDialogEventArgs^ e
)
Parameters
sender(Object)
e(TabbedDialogEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


TabbedDialogExtension Class

TabbedDialogExtension Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogExtension
Declaration Syntax
C# Visual Basic Visual C++
public sealed class TabbedDialogExtension
Public NotInheritable Class TabbedDialogExtension
public ref class TabbedDialogExtension sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TabbedDialogExtension(Control, TabbedDialogAction, TabbedDialogAction, TabbedDialogAction) |
 | TabbedDialogExtension(Control, TabbedDialogAction, TabbedDialogAction) |
 | TabbedDialogExtension(Control, TabbedDialogAction) |
 | Control |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnCancel |
 | OnHelp |
 | OnOk |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
TabbedDialogExtension

Assembly: ZwManaged (Module: ZwManaged)


TabbedDialogExtension Constructor

TabbedDialogExtension Constructor
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogExtension »TabbedDialogExtension()()()()
Members
Icon | Member | Description
 | TabbedDialogExtension(Control, TabbedDialogAction, TabbedDialogAction, TabbedDialogAction) |
 | TabbedDialogExtension(Control, TabbedDialogAction, TabbedDialogAction) |
 | TabbedDialogExtension(Control, TabbedDialogAction) |

Assembly: ZwManaged (Module: ZwManaged)


TabbedDialogExtension Constructor (control, onOK)

TabbedDialogExtension Constructor (control, onOK)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogExtension »TabbedDialogExtension(Control, TabbedDialogAction)
Declaration Syntax
C# Visual Basic Visual C++
public TabbedDialogExtension(
    Control control,
    TabbedDialogAction onOK
)
Public Sub New ( _
    control As Control, _
    onOK As TabbedDialogAction _
)
public:
TabbedDialogExtension(
    Control^ control,
    TabbedDialogAction^ onOK
)
Parameters
control(Control)
onOK(TabbedDialogAction)

Assembly: ZwManaged (Module: ZwManaged)


TabbedDialogExtension Constructor (control, onOK, onCancel)

TabbedDialogExtension Constructor (control, onOK, onCancel)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogExtension »TabbedDialogExtension(Control, TabbedDialogAction, TabbedDialogAction)
Declaration Syntax
C# Visual Basic Visual C++
public TabbedDialogExtension(
    Control control,
    TabbedDialogAction onOK,
    TabbedDialogAction onCancel
)
Public Sub New ( _
    control As Control, _
    onOK As TabbedDialogAction, _
    onCancel As TabbedDialogAction _
)
public:
TabbedDialogExtension(
    Control^ control,
    TabbedDialogAction^ onOK,
    TabbedDialogAction^ onCancel
)
Parameters
control(Control)
onOK(TabbedDialogAction)
onCancel(TabbedDialogAction)

Assembly: ZwManaged (Module: ZwManaged)


TabbedDialogExtension Constructor (control, onOK, onCancel, onHelp)

TabbedDialogExtension Constructor (control, onOK, onCancel, onHelp)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogExtension »TabbedDialogExtension(Control, TabbedDialogAction, TabbedDialogAction, TabbedDialogAction)
Declaration Syntax
C# Visual Basic Visual C++
public TabbedDialogExtension(
    Control control,
    TabbedDialogAction onOK,
    TabbedDialogAction onCancel,
    TabbedDialogAction onHelp
)
Public Sub New ( _
    control As Control, _
    onOK As TabbedDialogAction, _
    onCancel As TabbedDialogAction, _
    onHelp As TabbedDialogAction _
)
public:
TabbedDialogExtension(
    Control^ control,
    TabbedDialogAction^ onOK,
    TabbedDialogAction^ onCancel,
    TabbedDialogAction^ onHelp
)
Parameters
control(Control)
onOK(TabbedDialogAction)
onCancel(TabbedDialogAction)
onHelp(TabbedDialogAction)

Assembly: ZwManaged (Module: ZwManaged)


Control Property

Control Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogExtension »Control
Declaration Syntax
C# Visual Basic Visual C++
public Control Control { get; }
Public ReadOnly Property Control As Control
    Get
public:
property Control^ Control {
    Control^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OnCancel Property

OnCancel Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogExtension »OnCancel
Declaration Syntax
C# Visual Basic Visual C++
public TabbedDialogAction OnCancel { get; }
Public ReadOnly Property OnCancel As TabbedDialogAction
    Get
public:
property TabbedDialogAction^ OnCancel {
    TabbedDialogAction^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OnHelp Property

OnHelp Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogExtension »OnHelp
Declaration Syntax
C# Visual Basic Visual C++
public TabbedDialogAction OnHelp { get; }
Public ReadOnly Property OnHelp As TabbedDialogAction
    Get
public:
property TabbedDialogAction^ OnHelp {
    TabbedDialogAction^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OnOk Property

OnOk Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TabbedDialogExtension »OnOk
Declaration Syntax
C# Visual Basic Visual C++
public TabbedDialogAction OnOk { get; }
Public ReadOnly Property OnOk As TabbedDialogAction
    Get
public:
property TabbedDialogAction^ OnOk {
    TabbedDialogAction^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


TransactionManager Class

TransactionManager Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TransactionManager
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcTransactionManager")]
public sealed class TransactionManager : TransactionManager
<WrapperAttribute("AcTransactionManager")> _
Public NotInheritable Class TransactionManager _
    Inherits TransactionManager
[WrapperAttribute(L"AcTransactionManager")]
public ref class TransactionManager sealed : public TransactionManager
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddNewlyCreatedDBObject(DBObject, Boolean) | (Inherited from TransactionManager.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EnableGraphicsFlush(Boolean) |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FlushGraphics()()()() |
 | GetAllObjects()()()() | (Inherited from TransactionManager.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObject(ObjectId, OpenMode, Boolean, Boolean) | (Inherited from TransactionManager.)
 | GetObject(ObjectId, OpenMode, Boolean) | (Inherited from TransactionManager.)
 | GetObject(ObjectId, OpenMode) | (Inherited from TransactionManager.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfActiveTransactions | (Inherited from TransactionManager.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | QueueForGraphicsFlush()()()() | (Inherited from TransactionManager.)
 | StartTransaction()()()() | (Overrides TransactionManager.StartTransaction()()()().)
 | TopTransaction | (Overrides TransactionManager.TopTransaction.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | TransactionManager
 |  |  |  |  | TransactionManager

Assembly: ZwManaged (Module: ZwManaged)


EnableGraphicsFlush Method (doEnable)

EnableGraphicsFlush Method (doEnable)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TransactionManager »EnableGraphicsFlush(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void EnableGraphicsFlush(
    bool doEnable
)
Public Sub EnableGraphicsFlush ( _
    doEnable As Boolean _
)
public:
void EnableGraphicsFlush(
    bool doEnable
)
Parameters
doEnable(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


FlushGraphics Method

FlushGraphics Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TransactionManager »FlushGraphics()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void FlushGraphics()
Public Sub FlushGraphics
public:
void FlushGraphics()

Assembly: ZwManaged (Module: ZwManaged)


StartTransaction Method

StartTransaction Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TransactionManager »StartTransaction()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed Transaction StartTransaction()
Public Overrides NotOverridable Function StartTransaction As Transaction
public:
virtual Transaction^ StartTransaction() override sealed

Assembly: ZwManaged (Module: ZwManaged)


TopTransaction Property

TopTransaction Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TransactionManager »TopTransaction
Declaration Syntax
C# Visual Basic Visual C++
public override sealed Transaction TopTransaction { get; }
Public Overrides NotOverridable ReadOnly Property TopTransaction As Transaction
    Get
public:
virtual property Transaction^ TopTransaction {
    Transaction^ get () override sealed;
}

Assembly: ZwManaged (Module: ZwManaged)


UnknownCommandEventArgs Class

UnknownCommandEventArgs Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »UnknownCommandEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class UnknownCommandEventArgs : EventArgs
Public NotInheritable Class UnknownCommandEventArgs _
    Inherits EventArgs
public ref class UnknownCommandEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalCommandName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UnknownCommandEventArgs

Assembly: ZwManaged (Module: ZwManaged)


GlobalCommandName Property

GlobalCommandName Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »UnknownCommandEventArgs »GlobalCommandName
Declaration Syntax
C# Visual Basic Visual C++
public string GlobalCommandName { get; }
Public ReadOnly Property GlobalCommandName As String
    Get
public:
property String^ GlobalCommandName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


UnknownCommandEventHandler Delegate

UnknownCommandEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.ApplicationServices »UnknownCommandEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void UnknownCommandEventHandler(
    Object sender,
    UnknownCommandEventArgs e
)
Public Delegate Sub UnknownCommandEventHandler ( _
    sender As Object, _
    e As UnknownCommandEventArgs _
)
public delegate void UnknownCommandEventHandler(
    Object^ sender,
    UnknownCommandEventArgs^ e
)
Parameters
sender(Object)
e(UnknownCommandEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


UserConfigurationManager Class

UserConfigurationManager Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »UserConfigurationManager
Declaration Syntax
C# Visual Basic Visual C++
public sealed class UserConfigurationManager
Public NotInheritable Class UserConfigurationManager
public ref class UserConfigurationManager sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OpenCurrentProfile()()()() |
 | OpenDialogSection(Object) |
 | OpenGlobalSection()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
UserConfigurationManager

Assembly: ZwManaged (Module: ZwManaged)


OpenCurrentProfile Method

OpenCurrentProfile Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »UserConfigurationManager »OpenCurrentProfile()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static IConfigurationSection OpenCurrentProfile()
Public Shared Function OpenCurrentProfile As IConfigurationSection
public:
static IConfigurationSection^ OpenCurrentProfile()

Assembly: ZwManaged (Module: ZwManaged)


OpenDialogSection Method (dialog)

OpenDialogSection Method (dialog)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »UserConfigurationManager »OpenDialogSection(Object)
Declaration Syntax
C# Visual Basic Visual C++
public static IConfigurationSection OpenDialogSection(
    Object dialog
)
Public Shared Function OpenDialogSection ( _
    dialog As Object _
) As IConfigurationSection
public:
static IConfigurationSection^ OpenDialogSection(
    Object^ dialog
)
Parameters
dialog(Object)

Assembly: ZwManaged (Module: ZwManaged)


OpenGlobalSection Method

OpenGlobalSection Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »UserConfigurationManager »OpenGlobalSection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static IConfigurationSection OpenGlobalSection()
Public Shared Function OpenGlobalSection As IConfigurationSection
public:
static IConfigurationSection^ OpenGlobalSection()

Assembly: ZwManaged (Module: ZwManaged)


Utilities Class

Utilities Class
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Utilities
Public NotInheritable Class Utilities
public ref class Utilities sealed
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Utilities()()()() |
 | CircleSide()()()() |
 | CreateUndoCommandSnapshot(Int32, Int32, Int32) |
 | DrawLTypeBitmap(ObjectId) |
 | DrawLWeightBitmap(LineWeight) |
 | DrawTextStyleBitmap(String, String) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetCommandStatus()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRedoCommandNames(Int32) |
 | getRegistryRootKey()()()() |
 | GetReservedString(ReservedStringEnumType, Boolean) |
 | GetType()()()() | (Inherited from Object.)
 | GetUndoCommandNames(Int32) |
 | IsFilteredLayer(LayerTableRecord) |
 | IsMultiRedoAvailable()()()() |
 | IsRibbonApp()()()() |
 | IsUndoAvailable()()()() |
 | IsUndoSnapshotOn()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberofSavedUCS()()()() |
 | RegenLayers(array<ObjectId>[]()[][], Int32) |
 | ReleaseBitmap(IntPtr) |
 | ReleaseUndoCommandSnapshot(IntPtr) |
 | ToString()()()() | (Inherited from Object.)
 | UpdateDimension(ObjectId) |
Inheritance Hierarchy
Object
Utilities

Assembly: ZwManaged (Module: ZwManaged)


Utilities Constructor

Utilities Constructor
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »Utilities()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Utilities()
Public Sub New
public:
Utilities()

Assembly: ZwManaged (Module: ZwManaged)


CircleSide Method

CircleSide Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »CircleSide()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static short CircleSide()
Public Shared Function CircleSide As Short
public:
static short CircleSide()

Assembly: ZwManaged (Module: ZwManaged)


CreateUndoCommandSnapshot Method (ssid, w, h)

CreateUndoCommandSnapshot Method (ssid, w, h)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »CreateUndoCommandSnapshot(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr CreateUndoCommandSnapshot(
    int ssid,
    int w,
    int h
)
Public Shared Function CreateUndoCommandSnapshot ( _
    ssid As Integer, _
    w As Integer, _
    h As Integer _
) As IntPtr
public:
static IntPtr CreateUndoCommandSnapshot(
    int ssid,
    int w,
    int h
)
Parameters
ssid(Int32)
w(Int32)
h(Int32)

Assembly: ZwManaged (Module: ZwManaged)


DrawLTypeBitmap Method (ltypeId)

DrawLTypeBitmap Method (ltypeId)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »DrawLTypeBitmap(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr DrawLTypeBitmap(
    ObjectId ltypeId
)
Public Shared Function DrawLTypeBitmap ( _
    ltypeId As ObjectId _
) As IntPtr
public:
static IntPtr DrawLTypeBitmap(
    ObjectId ltypeId
)
Parameters
ltypeId(ObjectId)

Assembly: ZwManaged (Module: ZwManaged)


DrawLWeightBitmap Method (LW)

DrawLWeightBitmap Method (LW)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »DrawLWeightBitmap(LineWeight)
Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr DrawLWeightBitmap(
    LineWeight LW
)
Public Shared Function DrawLWeightBitmap ( _
    LW As LineWeight _
) As IntPtr
public:
static IntPtr DrawLWeightBitmap(
    LineWeight LW
)
Parameters
LW(LineWeight)

Assembly: ZwManaged (Module: ZwManaged)


DrawTextStyleBitmap Method (strStyleName, strSampleText)

DrawTextStyleBitmap Method (strStyleName, strSampleText)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »DrawTextStyleBitmap(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr DrawTextStyleBitmap(
    string strStyleName,
    string strSampleText
)
Public Shared Function DrawTextStyleBitmap ( _
    strStyleName As String, _
    strSampleText As String _
) As IntPtr
public:
static IntPtr DrawTextStyleBitmap(
    String^ strStyleName,
    String^ strSampleText
)
Parameters
strStyleName(String)
strSampleText(String)

Assembly: ZwManaged (Module: ZwManaged)


GetCommandStatus Method

GetCommandStatus Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »GetCommandStatus()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static bool GetCommandStatus()
Public Shared Function GetCommandStatus As Boolean
public:
static bool GetCommandStatus()

Assembly: ZwManaged (Module: ZwManaged)


GetRedoCommandNames Method (nMaxNeeded)

GetRedoCommandNames Method (nMaxNeeded)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »GetRedoCommandNames(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static List<MgdUndoCommandInfo> GetRedoCommandNames(
    int nMaxNeeded
)
Public Shared Function GetRedoCommandNames ( _
    nMaxNeeded As Integer _
) As List(Of MgdUndoCommandInfo)
public:
static List<MgdUndoCommandInfo^>^ GetRedoCommandNames(
    int nMaxNeeded
)
Parameters
nMaxNeeded(Int32)

Assembly: ZwManaged (Module: ZwManaged)


getRegistryRootKey Method

getRegistryRootKey Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »getRegistryRootKey()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static string getRegistryRootKey()
Public Shared Function getRegistryRootKey As String
public:
static String^ getRegistryRootKey()

Assembly: ZwManaged (Module: ZwManaged)


GetReservedString Method (enumtype, bGetLocalized)

GetReservedString Method (enumtype, bGetLocalized)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »GetReservedString(ReservedStringEnumType, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static string GetReservedString(
    ReservedStringEnumType enumtype,
    bool bGetLocalized
)
Public Shared Function GetReservedString ( _
    enumtype As ReservedStringEnumType, _
    bGetLocalized As Boolean _
) As String
public:
static String^ GetReservedString(
    ReservedStringEnumType enumtype,
    bool bGetLocalized
)
Parameters
enumtype(ReservedStringEnumType)
bGetLocalized(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


GetUndoCommandNames Method (nMaxNeeded)

GetUndoCommandNames Method (nMaxNeeded)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »GetUndoCommandNames(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static List<MgdUndoCommandInfo> GetUndoCommandNames(
    int nMaxNeeded
)
Public Shared Function GetUndoCommandNames ( _
    nMaxNeeded As Integer _
) As List(Of MgdUndoCommandInfo)
public:
static List<MgdUndoCommandInfo^>^ GetUndoCommandNames(
    int nMaxNeeded
)
Parameters
nMaxNeeded(Int32)

Assembly: ZwManaged (Module: ZwManaged)


IsFilteredLayer Method (layer)

IsFilteredLayer Method (layer)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »IsFilteredLayer(LayerTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsFilteredLayer(
    LayerTableRecord layer
)
Public Shared Function IsFilteredLayer ( _
    layer As LayerTableRecord _
) As Boolean
public:
static bool IsFilteredLayer(
    LayerTableRecord^ layer
)
Parameters
layer(LayerTableRecord)

Assembly: ZwManaged (Module: ZwManaged)


IsMultiRedoAvailable Method

IsMultiRedoAvailable Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »IsMultiRedoAvailable()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsMultiRedoAvailable()
Public Shared Function IsMultiRedoAvailable As Boolean
public:
static bool IsMultiRedoAvailable()

Assembly: ZwManaged (Module: ZwManaged)


IsRibbonApp Method

IsRibbonApp Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »IsRibbonApp()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsRibbonApp()
Public Shared Function IsRibbonApp As Boolean
public:
static bool IsRibbonApp()

Assembly: ZwManaged (Module: ZwManaged)


IsUndoAvailable Method

IsUndoAvailable Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »IsUndoAvailable()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsUndoAvailable()
Public Shared Function IsUndoAvailable As Boolean
public:
static bool IsUndoAvailable()

Assembly: ZwManaged (Module: ZwManaged)


IsUndoSnapshotOn Method

IsUndoSnapshotOn Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »IsUndoSnapshotOn()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsUndoSnapshotOn()
Public Shared Function IsUndoSnapshotOn As Boolean
public:
static bool IsUndoSnapshotOn()

Assembly: ZwManaged (Module: ZwManaged)


NumberofSavedUCS Method

NumberofSavedUCS Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »NumberofSavedUCS()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static int NumberofSavedUCS()
Public Shared Function NumberofSavedUCS As Integer
public:
static int NumberofSavedUCS()

Assembly: ZwManaged (Module: ZwManaged)


RegenLayers Method (layers, regenPending)

RegenLayers Method (layers, regenPending)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »RegenLayers(array<ObjectId>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void RegenLayers(
    ObjectId[] layers,
    int regenPending
)
Public Shared Sub RegenLayers ( _
    layers As ObjectId(), _
    regenPending As Integer _
)
public:
static void RegenLayers(
    array<ObjectId>^ layers,
    int regenPending
)
Parameters
layers(array< ObjectId >[]()[][])
regenPending(Int32)

Assembly: ZwManaged (Module: ZwManaged)


ReleaseBitmap Method (bitmap)

ReleaseBitmap Method (bitmap)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »ReleaseBitmap(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static void ReleaseBitmap(
    IntPtr bitmap
)
Public Shared Sub ReleaseBitmap ( _
    bitmap As IntPtr _
)
public:
static void ReleaseBitmap(
    IntPtr bitmap
)
Parameters
bitmap(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


ReleaseUndoCommandSnapshot Method (bmp)

ReleaseUndoCommandSnapshot Method (bmp)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »ReleaseUndoCommandSnapshot(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static void ReleaseUndoCommandSnapshot(
    IntPtr bmp
)
Public Shared Sub ReleaseUndoCommandSnapshot ( _
    bmp As IntPtr _
)
public:
static void ReleaseUndoCommandSnapshot(
    IntPtr bmp
)
Parameters
bmp(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


UpdateDimension Method (dimId)

UpdateDimension Method (dimId)
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Utilities »UpdateDimension(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public static void UpdateDimension(
    ObjectId dimId
)
Public Shared Sub UpdateDimension ( _
    dimId As ObjectId _
)
public:
static void UpdateDimension(
    ObjectId dimId
)
Parameters
dimId(ObjectId)

Assembly: ZwManaged (Module: ZwManaged)


WhoHasInfo Structure

WhoHasInfo Structure
Namespaces »ZwSoft.ZwCAD.ApplicationServices »WhoHasInfo
Declaration Syntax
C# Visual Basic Visual C++
public struct WhoHasInfo
Public Structure WhoHasInfo
public value class WhoHasInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ComputerName |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | IsFileLocked |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OpenTime |
 | ToString()()()() | (Inherited from ValueType.)
 | UserName |

Assembly: ZwManaged (Module: ZwManaged)


ComputerName Property

ComputerName Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »WhoHasInfo »ComputerName
Declaration Syntax
C# Visual Basic Visual C++
public string ComputerName { get; }
Public ReadOnly Property ComputerName As String
    Get
public:
property String^ ComputerName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsFileLocked Property

IsFileLocked Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »WhoHasInfo »IsFileLocked
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFileLocked { get; }
Public ReadOnly Property IsFileLocked As Boolean
    Get
public:
property bool IsFileLocked {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OpenTime Property

OpenTime Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »WhoHasInfo »OpenTime
Declaration Syntax
C# Visual Basic Visual C++
public string OpenTime { get; }
Public ReadOnly Property OpenTime As String
    Get
public:
property String^ OpenTime {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


UserName Property

UserName Property
Namespaces »ZwSoft.ZwCAD.ApplicationServices »WhoHasInfo »UserName
Declaration Syntax
C# Visual Basic Visual C++
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ZwSoft.ZwCAD.Colors Namespace

ZwSoft.ZwCAD.Colors Namespace
Namespaces »ZwSoft.ZwCAD.Colors
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.Colors
Namespace ZwSoft.ZwCAD.Colors
namespace ZwSoft.ZwCAD.Colors
Types
All Types Classes Structures Enumerations
Icon | Type | Description
 | Color |
 | ColorConverter |
 | ColorMethod |
 | EntityColor |
 | EntityColorCollection |
 | EntityColorCollectionEnumerator |
 | Transparency |
 | TransparencyCollection |
 | TransparencyCollectionEnumerator |
 | TransparencyMethod |


Color Class

Color Class
Namespaces »ZwSoft.ZwCAD.Colors »Color
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcCmColor")]
[TypeConverterAttribute(typeof(ColorConverter))]
public sealed class Color : DisposableWrapper,
    IComparable, ICloneable
<WrapperAttribute("AcCmColor")> _
<TypeConverterAttribute(GetType(ColorConverter))> _
Public NotInheritable Class Color _
    Inherits DisposableWrapper _
    Implements IComparable, ICloneable
[WrapperAttribute(L"AcCmColor")]
[TypeConverterAttribute(typeof(ColorConverter))]
public ref class Color sealed : public DisposableWrapper,
    IComparable, ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Color()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Blue |
 | BookName |
 | Clone()()()() |
 | ColorIndex |
 | ColorMethod |
 | ColorName |
 | ColorNameForDisplay |
 | ColorValue |
 | CompareTo(Object) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Description |
 | DictionaryKey |
 | DictionaryKeyLength |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EntityColor |
 | Equality(Color, Color) |
 | Equals(Object) | (Overrides DisposableWrapper.Equals(Object).)
 | Explanation |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FromColor(Color) |
 | FromColorIndex(ColorMethod, Int16) |
 | FromDictionaryName(String) |
 | FromEntityColor(EntityColor) |
 | FromNames(String, String) |
 | FromRgb(Byte, Byte, Byte) |
 | GetHashCode()()()() | (Overrides DisposableWrapper.GetHashCode()()()().)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | GreaterThan(Color, Color) |
 | Green |
 | HasBookName |
 | HasColorName |
 | Inequality(Color, Color) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsByAci |
 | IsByBlock |
 | IsByColor |
 | IsByLayer |
 | IsByPen |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsForeground |
 | IsNone |
 | LessThan(Color, Color) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PenIndex |
 | Red |
 | SetNames(String, String) |
 | SetNamesFromDictionaryKey(String) |
 | SetRgb(Byte, Byte, Byte) |
 | ToString()()()() | (Overrides Object.ToString()()()().)
 | ToString(IFormatProvider) |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Color


Color Constructor

Color Constructor
Namespaces »ZwSoft.ZwCAD.Colors »Color »Color()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Color()
Public Sub New
public:
Color()


Blue Property

Blue Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »Blue
Declaration Syntax
C# Visual Basic Visual C++
public byte Blue { get; }
Public ReadOnly Property Blue As Byte
    Get
public:
property unsigned char Blue {
    unsigned char get ();
}


BookName Property

BookName Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »BookName
Declaration Syntax
C# Visual Basic Visual C++
public string BookName { get; }
Public ReadOnly Property BookName As String
    Get
public:
property String^ BookName {
    String^ get ();
}


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.Colors »Color »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed


ColorIndex Property

ColorIndex Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »ColorIndex
Declaration Syntax
C# Visual Basic Visual C++
public short ColorIndex { get; }
Public ReadOnly Property ColorIndex As Short
    Get
public:
property short ColorIndex {
    short get ();
}


ColorMethod Property

ColorMethod Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »ColorMethod
Declaration Syntax
C# Visual Basic Visual C++
public ColorMethod ColorMethod { get; }
Public ReadOnly Property ColorMethod As ColorMethod
    Get
public:
property ColorMethod ColorMethod {
    ColorMethod get ();
}


ColorName Property

ColorName Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »ColorName
Declaration Syntax
C# Visual Basic Visual C++
public string ColorName { get; }
Public ReadOnly Property ColorName As String
    Get
public:
property String^ ColorName {
    String^ get ();
}


ColorNameForDisplay Property

ColorNameForDisplay Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »ColorNameForDisplay
Declaration Syntax
C# Visual Basic Visual C++
public string ColorNameForDisplay { get; }
Public ReadOnly Property ColorNameForDisplay As String
    Get
public:
property String^ ColorNameForDisplay {
    String^ get ();
}


ColorValue Property

ColorValue Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »ColorValue
Declaration Syntax
C# Visual Basic Visual C++
public Color ColorValue { get; }
Public ReadOnly Property ColorValue As Color
    Get
public:
property Color ColorValue {
    Color get ();
}


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces »ZwSoft.ZwCAD.Colors »Color »CompareTo(Object)
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    Object obj
)
Public Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
Parameters
obj(Object)


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}


DictionaryKey Property

DictionaryKey Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »DictionaryKey
Declaration Syntax
C# Visual Basic Visual C++
public string DictionaryKey { get; }
Public ReadOnly Property DictionaryKey As String
    Get
public:
property String^ DictionaryKey {
    String^ get ();
}


DictionaryKeyLength Property

DictionaryKeyLength Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »DictionaryKeyLength
Declaration Syntax
C# Visual Basic Visual C++
public int DictionaryKeyLength { get; }
Public ReadOnly Property DictionaryKeyLength As Integer
    Get
public:
property int DictionaryKeyLength {
    int get ();
}


EntityColor Property

EntityColor Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »EntityColor
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor EntityColor { get; }
Public ReadOnly Property EntityColor As EntityColor
    Get
public:
property EntityColor EntityColor {
    EntityColor get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Colors »Color »Equality(Color, Color)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Color a,
    Color b
)
Public Shared Operator = ( _
    a As Color, _
    b As Color _
) As Boolean
public:
static bool operator ==(
    Color^ a,
    Color^ b
)
Parameters
a(Color)
b(Color)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Colors »Color »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


Explanation Property

Explanation Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »Explanation
Declaration Syntax
C# Visual Basic Visual C++
public string Explanation { get; }
Public ReadOnly Property Explanation As String
    Get
public:
property String^ Explanation {
    String^ get ();
}


FromColor Method (value)

FromColor Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »Color »FromColor(Color)
Declaration Syntax
C# Visual Basic Visual C++
public static Color FromColor(
    Color value
)
Public Shared Function FromColor ( _
    value As Color _
) As Color
public:
static Color^ FromColor(
    Color value
)
Parameters
value(Color)


FromColorIndex Method (colorMethod, colorIndex)

FromColorIndex Method (colorMethod, colorIndex)
Namespaces »ZwSoft.ZwCAD.Colors »Color »FromColorIndex(ColorMethod, Int16)
Declaration Syntax
C# Visual Basic Visual C++
public static Color FromColorIndex(
    ColorMethod colorMethod,
    short colorIndex
)
Public Shared Function FromColorIndex ( _
    colorMethod As ColorMethod, _
    colorIndex As Short _
) As Color
public:
static Color^ FromColorIndex(
    ColorMethod colorMethod,
    short colorIndex
)
Parameters
colorMethod(ColorMethod)
colorIndex(Int16)


FromDictionaryName Method (name)

FromDictionaryName Method (name)
Namespaces »ZwSoft.ZwCAD.Colors »Color »FromDictionaryName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static Color FromDictionaryName(
    string name
)
Public Shared Function FromDictionaryName ( _
    name As String _
) As Color
public:
static Color^ FromDictionaryName(
    String^ name
)
Parameters
name(String)


FromEntityColor Method (eclr)

FromEntityColor Method (eclr)
Namespaces »ZwSoft.ZwCAD.Colors »Color »FromEntityColor(EntityColor)
Declaration Syntax
C# Visual Basic Visual C++
public static Color FromEntityColor(
    EntityColor eclr
)
Public Shared Function FromEntityColor ( _
    eclr As EntityColor _
) As Color
public:
static Color^ FromEntityColor(
    EntityColor eclr
)
Parameters
eclr(EntityColor)


FromNames Method (colorName, bookName)

FromNames Method (colorName, bookName)
Namespaces »ZwSoft.ZwCAD.Colors »Color »FromNames(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public static Color FromNames(
    string colorName,
    string bookName
)
Public Shared Function FromNames ( _
    colorName As String, _
    bookName As String _
) As Color
public:
static Color^ FromNames(
    String^ colorName,
    String^ bookName
)
Parameters
colorName(String)
bookName(String)


FromRgb Method (red, green, blue)

FromRgb Method (red, green, blue)
Namespaces »ZwSoft.ZwCAD.Colors »Color »FromRgb(Byte, Byte, Byte)
Declaration Syntax
C# Visual Basic Visual C++
public static Color FromRgb(
    byte red,
    byte green,
    byte blue
)
Public Shared Function FromRgb ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
) As Color
public:
static Color^ FromRgb(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)
Parameters
red(Byte)
green(Byte)
blue(Byte)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Colors »Color »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GreaterThan Operator

GreaterThan Operator
Namespaces »ZwSoft.ZwCAD.Colors »Color »GreaterThan(Color, Color)
Declaration Syntax
C# Visual Basic Visual C++
public static int operator >(
    Color a,
    Color b
)
Public Shared Operator > ( _
    a As Color, _
    b As Color _
) As Integer
public:
static int operator >(
    Color^ a,
    Color^ b
)
Parameters
a(Color)
b(Color)


Green Property

Green Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »Green
Declaration Syntax
C# Visual Basic Visual C++
public byte Green { get; }
Public ReadOnly Property Green As Byte
    Get
public:
property unsigned char Green {
    unsigned char get ();
}


HasBookName Property

HasBookName Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »HasBookName
Declaration Syntax
C# Visual Basic Visual C++
public bool HasBookName { get; }
Public ReadOnly Property HasBookName As Boolean
    Get
public:
property bool HasBookName {
    bool get ();
}


HasColorName Property

HasColorName Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »HasColorName
Declaration Syntax
C# Visual Basic Visual C++
public bool HasColorName { get; }
Public ReadOnly Property HasColorName As Boolean
    Get
public:
property bool HasColorName {
    bool get ();
}


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Colors »Color »Inequality(Color, Color)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Color a,
    Color b
)
Public Shared Operator <> ( _
    a As Color, _
    b As Color _
) As Boolean
public:
static bool operator !=(
    Color^ a,
    Color^ b
)
Parameters
a(Color)
b(Color)


IsByAci Property

IsByAci Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »IsByAci
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByAci { get; }
Public ReadOnly Property IsByAci As Boolean
    Get
public:
property bool IsByAci {
    bool get ();
}


IsByBlock Property

IsByBlock Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »IsByBlock
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByBlock { get; }
Public ReadOnly Property IsByBlock As Boolean
    Get
public:
property bool IsByBlock {
    bool get ();
}


IsByColor Property

IsByColor Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »IsByColor
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByColor { get; }
Public ReadOnly Property IsByColor As Boolean
    Get
public:
property bool IsByColor {
    bool get ();
}


IsByLayer Property

IsByLayer Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »IsByLayer
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByLayer { get; }
Public ReadOnly Property IsByLayer As Boolean
    Get
public:
property bool IsByLayer {
    bool get ();
}


IsByPen Property

IsByPen Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »IsByPen
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByPen { get; }
Public ReadOnly Property IsByPen As Boolean
    Get
public:
property bool IsByPen {
    bool get ();
}


IsForeground Property

IsForeground Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »IsForeground
Declaration Syntax
C# Visual Basic Visual C++
public bool IsForeground { get; }
Public ReadOnly Property IsForeground As Boolean
    Get
public:
property bool IsForeground {
    bool get ();
}


IsNone Property

IsNone Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »IsNone
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNone { get; }
Public ReadOnly Property IsNone As Boolean
    Get
public:
property bool IsNone {
    bool get ();
}


LessThan Operator

LessThan Operator
Namespaces »ZwSoft.ZwCAD.Colors »Color »LessThan(Color, Color)
Declaration Syntax
C# Visual Basic Visual C++
public static int operator <(
    Color a,
    Color b
)
Public Shared Operator < ( _
    a As Color, _
    b As Color _
) As Integer
public:
static int operator <(
    Color^ a,
    Color^ b
)
Parameters
a(Color)
b(Color)


PenIndex Property

PenIndex Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »PenIndex
Declaration Syntax
C# Visual Basic Visual C++
public short PenIndex { get; }
Public ReadOnly Property PenIndex As Short
    Get
public:
property short PenIndex {
    short get ();
}


Red Property

Red Property
Namespaces »ZwSoft.ZwCAD.Colors »Color »Red
Declaration Syntax
C# Visual Basic Visual C++
public byte Red { get; }
Public ReadOnly Property Red As Byte
    Get
public:
property unsigned char Red {
    unsigned char get ();
}


SetNames Method (colorName, bookName)

SetNames Method (colorName, bookName)
Namespaces »ZwSoft.ZwCAD.Colors »Color »SetNames(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetNames(
    string colorName,
    string bookName
)
Public Sub SetNames ( _
    colorName As String, _
    bookName As String _
)
public:
void SetNames(
    String^ colorName,
    String^ bookName
)
Parameters
colorName(String)
bookName(String)


SetNamesFromDictionaryKey Method (parameter)

SetNamesFromDictionaryKey Method (parameter)
Namespaces »ZwSoft.ZwCAD.Colors »Color »SetNamesFromDictionaryKey(String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetNamesFromDictionaryKey(
    string parameter
)
Public Sub SetNamesFromDictionaryKey ( _
    parameter As String _
)
public:
void SetNamesFromDictionaryKey(
    String^ parameter
)
Parameters
parameter(String)


SetRgb Method (red, green, blue)

SetRgb Method (red, green, blue)
Namespaces »ZwSoft.ZwCAD.Colors »Color »SetRgb(Byte, Byte, Byte)
Declaration Syntax
C# Visual Basic Visual C++
public void SetRgb(
    byte red,
    byte green,
    byte blue
)
Public Sub SetRgb ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
)
public:
void SetRgb(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)
Parameters
red(Byte)
green(Byte)
blue(Byte)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Colors »Color »ToString()()()()
Members
Icon | Member | Description
 | ToString()()()() | (Overrides Object.ToString()()()().)
 | ToString(IFormatProvider) |


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Colors »Color »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Colors »Color »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


ColorConverter Class

ColorConverter Class
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter
Declaration Syntax
C# Visual Basic Visual C++
public class ColorConverter : TypeConverter
Public Class ColorConverter _
    Inherits TypeConverter
public ref class ColorConverter : public TypeConverter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ColorConverter()()()() |
 | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter.CanConvertFrom(ITypeDescriptorContext, Type).)
 | CanConvertFrom(Type) | (Inherited from TypeConverter.)
 | CanConvertTo(Type) | (Inherited from TypeConverter.)
 | CanConvertTo(ITypeDescriptorContext, Type) | (Inherited from TypeConverter.)
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
 | ConvertFrom(Object) | (Inherited from TypeConverter.)
 | ConvertFromInvariantString(String) | (Inherited from TypeConverter.)
 | ConvertFromInvariantString(ITypeDescriptorContext, String) | (Inherited from TypeConverter.)
 | ConvertFromString(String) | (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, String) | (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | (Inherited from TypeConverter.)
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) | (Inherited from TypeConverter.)
 | ConvertToInvariantString(Object) | (Inherited from TypeConverter.)
 | ConvertToInvariantString(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | ConvertToString(Object) | (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | (Inherited from TypeConverter.)
 | CreateInstance(IDictionary) | (Inherited from TypeConverter.)
 | CreateInstance(ITypeDescriptorContext, IDictionary) | (Inherited from TypeConverter.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetConvertFromException(Object) | (Inherited from TypeConverter.)
 | GetConvertToException(Object, Type) | (Inherited from TypeConverter.)
 | GetCreateInstanceSupported()()()() | (Inherited from TypeConverter.)
 | GetCreateInstanceSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetProperties(Object) | (Inherited from TypeConverter.)
 | GetProperties(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | (Inherited from TypeConverter.)
 | GetPropertiesSupported()()()() | (Inherited from TypeConverter.)
 | GetPropertiesSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValues()()()() | (Inherited from TypeConverter.)
 | GetStandardValues(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValuesExclusive()()()() | (Inherited from TypeConverter.)
 | GetStandardValuesExclusive(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValuesSupported()()()() | (Inherited from TypeConverter.)
 | GetStandardValuesSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetType()()()() | (Inherited from Object.)
 | IsValid(Object) | (Inherited from TypeConverter.)
 | IsValid(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SortProperties(PropertyDescriptorCollection, array<String>[]()[][]) | (Inherited from TypeConverter.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeConverter
 |  | ColorConverter


ColorConverter Constructor

ColorConverter Constructor
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »ColorConverter()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ColorConverter()
Public Sub New
public:
ColorConverter()


CanConvertFrom Method (context, sourceType)

CanConvertFrom Method (context, sourceType)
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »CanConvertFrom(ITypeDescriptorContext, Type)
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override
Parameters
context(ITypeDescriptorContext)
sourceType(Type)


ConvertFrom Method (context, culture, value)

ConvertFrom Method (context, culture, value)
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »ConvertFrom(ITypeDescriptorContext, CultureInfo, Object)
Declaration Syntax
C# Visual Basic Visual C++
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override
Parameters
context(ITypeDescriptorContext)
culture(CultureInfo)
value(Object)


ConvertTo Method (context, culture, value, destinationType)

ConvertTo Method (context, culture, value, destinationType)
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type)
Declaration Syntax
C# Visual Basic Visual C++
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
Parameters
context(ITypeDescriptorContext)
culture(CultureInfo)
value(Object)
destinationType(Type)


ColorMethod Enumeration

ColorMethod Enumeration
Namespaces »ZwSoft.ZwCAD.Colors »ColorMethod
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcCmEntityColor::ColorMethod")]
public enum ColorMethod
<WrapperAttribute("ZcCmEntityColor::ColorMethod")> _
Public Enumeration ColorMethod
[WrapperAttribute(L"ZcCmEntityColor::ColorMethod")]
public enum class ColorMethod
Members
Member | Description
None |
LayerFrozen |
LayerOff |
Foreground |
ByPen |
ByAci |
ByColor |
ByBlock |
ByLayer |


EntityColor Structure

EntityColor Structure
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcCmEntityColor")]
public struct EntityColor
<WrapperAttribute("AcCmEntityColor")> _
Public Structure EntityColor
[WrapperAttribute(L"AcCmEntityColor")]
public value class EntityColor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EntityColor(Byte, Byte, Byte) |
 | EntityColor(ColorMethod) |
 | EntityColor(Int32) |
 | EntityColor(ColorMethod, Int16) |
 | Blue |
 | ColorIndex |
 | ColorMethod |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Green |
 | IsByAci |
 | IsByBlock |
 | IsByColor |
 | IsByLayer |
 | IsByPen |
 | IsForeground |
 | IsLayerFrozen |
 | IsLayerFrozenOrOff |
 | IsLayerOff |
 | IsNone |
 | LayerIndex |
 | LookUpAci(Byte, Byte, Byte) |
 | LookUpRgb(Byte) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PenIndex |
 | Red |
 | SetRgb(Byte, Byte, Byte) |
 | SetTrueColor()()()() |
 | SetTrueColorMethod()()()() |
 | ToString()()()() | (Inherited from ValueType.)
 | TrueColor |
 | TrueColorMethod |


EntityColor Constructor

EntityColor Constructor
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »EntityColor()()()()
Members
Icon | Member | Description
 | EntityColor(Byte, Byte, Byte) |
 | EntityColor(ColorMethod) |
 | EntityColor(Int32) |
 | EntityColor(ColorMethod, Int16) |


EntityColor Constructor (red, green, blue)

EntityColor Constructor (red, green, blue)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »EntityColor(Byte, Byte, Byte)
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor(
    byte red,
    byte green,
    byte blue
)
Public Sub New ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
)
public:
EntityColor(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)
Parameters
red(Byte)
green(Byte)
blue(Byte)


EntityColor Constructor (trueColor)

EntityColor Constructor (trueColor)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »EntityColor(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor(
    int trueColor
)
Public Sub New ( _
    trueColor As Integer _
)
public:
EntityColor(
    int trueColor
)
Parameters
trueColor(Int32)


EntityColor Constructor (value)

EntityColor Constructor (value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »EntityColor(ColorMethod)
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor(
    ColorMethod value
)
Public Sub New ( _
    value As ColorMethod _
)
public:
EntityColor(
    ColorMethod value
)
Parameters
value(ColorMethod)


EntityColor Constructor (value, index)

EntityColor Constructor (value, index)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »EntityColor(ColorMethod, Int16)
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor(
    ColorMethod value,
    short index
)
Public Sub New ( _
    value As ColorMethod, _
    index As Short _
)
public:
EntityColor(
    ColorMethod value,
    short index
)
Parameters
value(ColorMethod)
index(Int16)


Blue Property

Blue Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »Blue
Declaration Syntax
C# Visual Basic Visual C++
public byte Blue { get; }
Public ReadOnly Property Blue As Byte
    Get
public:
property unsigned char Blue {
    unsigned char get ();
}


ColorIndex Property

ColorIndex Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »ColorIndex
Declaration Syntax
C# Visual Basic Visual C++
public short ColorIndex { get; }
Public ReadOnly Property ColorIndex As Short
    Get
public:
property short ColorIndex {
    short get ();
}


ColorMethod Property

ColorMethod Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »ColorMethod
Declaration Syntax
C# Visual Basic Visual C++
public ColorMethod ColorMethod { get; }
Public ReadOnly Property ColorMethod As ColorMethod
    Get
public:
property ColorMethod ColorMethod {
    ColorMethod get ();
}


Green Property

Green Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »Green
Declaration Syntax
C# Visual Basic Visual C++
public byte Green { get; }
Public ReadOnly Property Green As Byte
    Get
public:
property unsigned char Green {
    unsigned char get ();
}


IsByAci Property

IsByAci Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »IsByAci
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByAci { get; }
Public ReadOnly Property IsByAci As Boolean
    Get
public:
property bool IsByAci {
    bool get ();
}


IsByBlock Property

IsByBlock Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »IsByBlock
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByBlock { get; }
Public ReadOnly Property IsByBlock As Boolean
    Get
public:
property bool IsByBlock {
    bool get ();
}


IsByColor Property

IsByColor Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »IsByColor
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByColor { get; }
Public ReadOnly Property IsByColor As Boolean
    Get
public:
property bool IsByColor {
    bool get ();
}


IsByLayer Property

IsByLayer Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »IsByLayer
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByLayer { get; }
Public ReadOnly Property IsByLayer As Boolean
    Get
public:
property bool IsByLayer {
    bool get ();
}


IsByPen Property

IsByPen Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »IsByPen
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByPen { get; }
Public ReadOnly Property IsByPen As Boolean
    Get
public:
property bool IsByPen {
    bool get ();
}


IsForeground Property

IsForeground Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »IsForeground
Declaration Syntax
C# Visual Basic Visual C++
public bool IsForeground { get; }
Public ReadOnly Property IsForeground As Boolean
    Get
public:
property bool IsForeground {
    bool get ();
}


IsLayerFrozen Property

IsLayerFrozen Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »IsLayerFrozen
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLayerFrozen { get; }
Public ReadOnly Property IsLayerFrozen As Boolean
    Get
public:
property bool IsLayerFrozen {
    bool get ();
}


IsLayerFrozenOrOff Property

IsLayerFrozenOrOff Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »IsLayerFrozenOrOff
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLayerFrozenOrOff { get; }
Public ReadOnly Property IsLayerFrozenOrOff As Boolean
    Get
public:
property bool IsLayerFrozenOrOff {
    bool get ();
}


IsLayerOff Property

IsLayerOff Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »IsLayerOff
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLayerOff { get; }
Public ReadOnly Property IsLayerOff As Boolean
    Get
public:
property bool IsLayerOff {
    bool get ();
}


IsNone Property

IsNone Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »IsNone
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNone { get; }
Public ReadOnly Property IsNone As Boolean
    Get
public:
property bool IsNone {
    bool get ();
}


LayerIndex Property

LayerIndex Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »LayerIndex
Declaration Syntax
C# Visual Basic Visual C++
public short LayerIndex { get; }
Public ReadOnly Property LayerIndex As Short
    Get
public:
property short LayerIndex {
    short get ();
}


LookUpAci Method (red, green, blue)

LookUpAci Method (red, green, blue)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »LookUpAci(Byte, Byte, Byte)
Declaration Syntax
C# Visual Basic Visual C++
public static byte LookUpAci(
    byte red,
    byte green,
    byte blue
)
Public Shared Function LookUpAci ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
) As Byte
public:
static unsigned char LookUpAci(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)
Parameters
red(Byte)
green(Byte)
blue(Byte)


LookUpRgb Method (colorIndex)

LookUpRgb Method (colorIndex)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »LookUpRgb(Byte)
Declaration Syntax
C# Visual Basic Visual C++
public static int LookUpRgb(
    byte colorIndex
)
Public Shared Function LookUpRgb ( _
    colorIndex As Byte _
) As Integer
public:
static int LookUpRgb(
    unsigned char colorIndex
)
Parameters
colorIndex(Byte)


PenIndex Property

PenIndex Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »PenIndex
Declaration Syntax
C# Visual Basic Visual C++
public short PenIndex { get; }
Public ReadOnly Property PenIndex As Short
    Get
public:
property short PenIndex {
    short get ();
}


Red Property

Red Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »Red
Declaration Syntax
C# Visual Basic Visual C++
public byte Red { get; }
Public ReadOnly Property Red As Byte
    Get
public:
property unsigned char Red {
    unsigned char get ();
}


SetRgb Method (red, green, blue)

SetRgb Method (red, green, blue)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »SetRgb(Byte, Byte, Byte)
Declaration Syntax
C# Visual Basic Visual C++
public void SetRgb(
    byte red,
    byte green,
    byte blue
)
Public Sub SetRgb ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
)
public:
void SetRgb(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)
Parameters
red(Byte)
green(Byte)
blue(Byte)


SetTrueColor Method

SetTrueColor Method
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »SetTrueColor()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrueColor()
Public Sub SetTrueColor
public:
void SetTrueColor()


SetTrueColorMethod Method

SetTrueColorMethod Method
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »SetTrueColorMethod()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrueColorMethod()
Public Sub SetTrueColorMethod
public:
void SetTrueColorMethod()


TrueColor Property

TrueColor Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »TrueColor
Declaration Syntax
C# Visual Basic Visual C++
public int TrueColor { get; }
Public ReadOnly Property TrueColor As Integer
    Get
public:
property int TrueColor {
    int get ();
}


TrueColorMethod Property

TrueColorMethod Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColor »TrueColorMethod
Declaration Syntax
C# Visual Basic Visual C++
public byte TrueColorMethod { get; }
Public ReadOnly Property TrueColorMethod As Byte
    Get
public:
property unsigned char TrueColorMethod {
    unsigned char get ();
}


EntityColorCollection Class

EntityColorCollection Class
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcArray<ZcCmEntityColor>")]
public sealed class EntityColorCollection : IList
<WrapperAttribute("ZcArray<ZcCmEntityColor>")> _
Public NotInheritable Class EntityColorCollection _
    Implements IList
[WrapperAttribute(L"ZcArray<ZcCmEntityColor>")]
public ref class EntityColorCollection sealed : IList
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EntityColorCollection(Int32) |
 | EntityColorCollection(array<EntityColor>[]()[][]) |
 | EntityColorCollection()()()() |
 | Add(EntityColor) |
 | AddRange(array<EntityColor>[]()[][]) |
 | Capacity |
 | Clear()()()() |
 | Contains(EntityColor) |
 | CopyTo(array<EntityColor>[]()[][], Int32) |
 | Count |
 | DefaultSize |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IEnumerable..::..GetEnumerator()()()() |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Remove(Object) |
 | IndexOf(EntityColor) |
 | Insert(Int32, EntityColor) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(EntityColor) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() |
Inheritance Hierarchy
Object
EntityColorCollection


EntityColorCollection Constructor

EntityColorCollection Constructor
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »EntityColorCollection()()()()
Members
Icon | Member | Description
 | EntityColorCollection(Int32) |
 | EntityColorCollection(array<EntityColor>[]()[][]) |
 | EntityColorCollection()()()() |


EntityColorCollection Constructor

EntityColorCollection Constructor
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »EntityColorCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EntityColorCollection()
Public Sub New
public:
EntityColorCollection()


EntityColorCollection Constructor (capacity)

EntityColorCollection Constructor (capacity)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »EntityColorCollection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public EntityColorCollection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
EntityColorCollection(
    int capacity
)
Parameters
capacity(Int32)


EntityColorCollection Constructor (values)

EntityColorCollection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »EntityColorCollection(array<EntityColor>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public EntityColorCollection(
    EntityColor[] values
)
Public Sub New ( _
    values As EntityColor() _
)
public:
EntityColorCollection(
    array<EntityColor>^ values
)
Parameters
values(array< EntityColor >[]()[][])


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »Add(EntityColor)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    EntityColor value
)
Public Function Add ( _
    value As EntityColor _
) As Integer
public:
virtual int Add(
    EntityColor value
) sealed
Parameters
value(EntityColor)


AddRange Method (range)

AddRange Method (range)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »AddRange(array<EntityColor>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    EntityColor[] range
)
Public Sub AddRange ( _
    range As EntityColor() _
)
public:
virtual void AddRange(
    array<EntityColor>^ range
) sealed
Parameters
range(array< EntityColor >[]()[][])


Capacity Property

Capacity Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »Capacity
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »Contains(EntityColor)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    EntityColor value
)
Public Function Contains ( _
    value As EntityColor _
) As Boolean
public:
virtual bool Contains(
    EntityColor value
) sealed
Parameters
value(EntityColor)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »CopyTo(array<EntityColor>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    EntityColor[] array,
    int index
)
Public Sub CopyTo ( _
    array As EntityColor(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<EntityColor>^ array,
    int index
) sealed
Parameters
array(array< EntityColor >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DefaultSize Field

DefaultSize Field
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »DefaultSize
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultSize
Public Const DefaultSize As Integer
public:
literal int DefaultSize


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EntityColorCollectionEnumerator GetEnumerator()
Public Function GetEnumerator As EntityColorCollectionEnumerator
public:
virtual EntityColorCollectionEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (array, index)

ICollectionCopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollectionCopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IEnumerableGetEnumerator Method

IEnumerableGetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IEnumerable..::..GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
IEnumerator IEnumerable.GetEnumerator()
Private Function IEnumerableGetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ IEnumerableGetEnumerator() sealed = IEnumerable::GetEnumerator


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IListAdd Method (value)

IListAdd Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IListAdd ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IListAdd(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IListContains Method (value)

IListContains Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IListContains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IListContains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IListIndexOf Method (value)

IListIndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IListIndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IListIndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IListInsert Method (index, value)

IListInsert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IListInsert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IListInsert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IListRemove Method (value)

IListRemove Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IListRemove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IListRemove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IndexOf(EntityColor)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    EntityColor value
)
Public Function IndexOf ( _
    value As EntityColor _
) As Integer
public:
virtual int IndexOf(
    EntityColor value
) sealed
Parameters
value(EntityColor)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »Insert(Int32, EntityColor)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    EntityColor value
)
Public Sub Insert ( _
    index As Integer, _
    value As EntityColor _
)
public:
virtual void Insert(
    int index,
    EntityColor value
) sealed
Parameters
index(Int32)
value(EntityColor)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public virtual EntityColor this[
    int index
] { get; set; }
Public Overridable Default Property Item ( _
    index As Integer _
) As EntityColor
    Get
    Set
public:
virtual property EntityColor default[int index] {
    EntityColor get (int index);
    void set (int index, EntityColor value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »Remove(EntityColor)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    EntityColor value
)
Public Sub Remove ( _
    value As EntityColor _
)
public:
virtual void Remove(
    EntityColor value
) sealed
Parameters
value(EntityColor)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor[] ToArray()
Public Function ToArray As EntityColor()
public:
virtual array<EntityColor>^ ToArray() sealed


TrimToSize Method

TrimToSize Method
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollection »TrimToSize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void TrimToSize()
Public Sub TrimToSize
public:
virtual void TrimToSize() sealed


EntityColorCollectionEnumerator Class

EntityColorCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public class EntityColorCollectionEnumerator : IEnumerator
Public Class EntityColorCollectionEnumerator _
    Implements IEnumerator
public ref class EntityColorCollectionEnumerator : IEnumerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EntityColorCollectionEnumerator(EntityColorCollection) |
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
EntityColorCollectionEnumerator


EntityColorCollectionEnumerator Constructor (collection)

EntityColorCollectionEnumerator Constructor (collection)
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollectionEnumerator »EntityColorCollectionEnumerator(EntityColorCollection)
Declaration Syntax
C# Visual Basic Visual C++
protected internal EntityColorCollectionEnumerator(
    EntityColorCollection collection
)
Protected Friend Sub New ( _
    collection As EntityColorCollection _
)
protected public:
EntityColorCollectionEnumerator(
    EntityColorCollection^ collection
)
Parameters
collection(EntityColorCollection)


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.Colors »EntityColorCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()


Transparency Structure

Transparency Structure
Namespaces »ZwSoft.ZwCAD.Colors »Transparency
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdCmTransparency")]
public struct Transparency
<WrapperAttribute("OdCmTransparency")> _
Public Structure Transparency
[WrapperAttribute(L"OdCmTransparency")]
public value class Transparency
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Transparency(Byte) |
 | Transparency(TransparencyMethod) |
 | Alpha |
 | CopyFromUnmanagedObject(IntPtr) |
 | CopyToUmgObj(IntPtr) |
 | Equality(Transparency, Transparency) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(Transparency, Transparency) |
 | IsByAlpha |
 | IsByBlock |
 | IsByLayer |
 | IsClear |
 | IsSolid |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetMethod(TransparencyMethod) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


Transparency Constructor

Transparency Constructor
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »Transparency()()()()
Members
Icon | Member | Description
 | Transparency(Byte) |
 | Transparency(TransparencyMethod) |


Transparency Constructor (alpha)

Transparency Constructor (alpha)
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »Transparency(Byte)
Declaration Syntax
C# Visual Basic Visual C++
public Transparency(
    byte alpha
)
Public Sub New ( _
    alpha As Byte _
)
public:
Transparency(
    unsigned char alpha
)
Parameters
alpha(Byte)


Transparency Constructor (method)

Transparency Constructor (method)
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »Transparency(TransparencyMethod)
Declaration Syntax
C# Visual Basic Visual C++
public Transparency(
    TransparencyMethod method
)
Public Sub New ( _
    method As TransparencyMethod _
)
public:
Transparency(
    TransparencyMethod method
)
Parameters
method(TransparencyMethod)


Alpha Property

Alpha Property
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »Alpha
Declaration Syntax
C# Visual Basic Visual C++
public byte Alpha { get; }
Public ReadOnly Property Alpha As Byte
    Get
public:
property unsigned char Alpha {
    unsigned char get ();
}


CopyFromUnmanagedObject Method (unmanagedObject)

CopyFromUnmanagedObject Method (unmanagedObject)
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »CopyFromUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static Transparency CopyFromUnmanagedObject(
    IntPtr unmanagedObject
)
Public Shared Function CopyFromUnmanagedObject ( _
    unmanagedObject As IntPtr _
) As Transparency
public:
static Transparency CopyFromUnmanagedObject(
    IntPtr unmanagedObject
)
Parameters
unmanagedObject(IntPtr)


CopyToUmgObj Method (unmanagedObject)

CopyToUmgObj Method (unmanagedObject)
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »CopyToUmgObj(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyToUmgObj(
    IntPtr unmanagedObject
)
Public Sub CopyToUmgObj ( _
    unmanagedObject As IntPtr _
)
public:
void CopyToUmgObj(
    IntPtr unmanagedObject
)
Parameters
unmanagedObject(IntPtr)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »Equality(Transparency, Transparency)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Transparency a,
    Transparency b
)
Public Shared Operator = ( _
    a As Transparency, _
    b As Transparency _
) As Boolean
public:
static bool operator ==(
    Transparency a,
    Transparency b
)
Parameters
a(Transparency)
b(Transparency)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »Inequality(Transparency, Transparency)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Transparency a,
    Transparency b
)
Public Shared Operator <> ( _
    a As Transparency, _
    b As Transparency _
) As Boolean
public:
static bool operator !=(
    Transparency a,
    Transparency b
)
Parameters
a(Transparency)
b(Transparency)


IsByAlpha Property

IsByAlpha Property
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »IsByAlpha
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByAlpha { get; }
Public ReadOnly Property IsByAlpha As Boolean
    Get
public:
property bool IsByAlpha {
    bool get ();
}


IsByBlock Property

IsByBlock Property
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »IsByBlock
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByBlock { get; }
Public ReadOnly Property IsByBlock As Boolean
    Get
public:
property bool IsByBlock {
    bool get ();
}


IsByLayer Property

IsByLayer Property
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »IsByLayer
Declaration Syntax
C# Visual Basic Visual C++
public bool IsByLayer { get; }
Public ReadOnly Property IsByLayer As Boolean
    Get
public:
property bool IsByLayer {
    bool get ();
}


IsClear Property

IsClear Property
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »IsClear
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClear { get; }
Public ReadOnly Property IsClear As Boolean
    Get
public:
property bool IsClear {
    bool get ();
}


IsSolid Property

IsSolid Property
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »IsSolid
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSolid { get; }
Public ReadOnly Property IsSolid As Boolean
    Get
public:
property bool IsSolid {
    bool get ();
}


SetMethod Method (method)

SetMethod Method (method)
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »SetMethod(TransparencyMethod)
Declaration Syntax
C# Visual Basic Visual C++
public void SetMethod(
    TransparencyMethod method
)
Public Sub SetMethod ( _
    method As TransparencyMethod _
)
public:
void SetMethod(
    TransparencyMethod method
)
Parameters
method(TransparencyMethod)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Colors »Transparency »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


TransparencyCollection Class

TransparencyCollection Class
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcArray<ZcCmTransparency>")]
public sealed class TransparencyCollection : IList
<WrapperAttribute("ZcArray<ZcCmTransparency>")> _
Public NotInheritable Class TransparencyCollection _
    Implements IList
[WrapperAttribute(L"ZcArray<ZcCmTransparency>")]
public ref class TransparencyCollection sealed : IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransparencyCollection(Int32) |
 | TransparencyCollection(array<Transparency>[]()[][]) |
 | TransparencyCollection()()()() |
 | Add(Transparency) |
 | AddRange(array<Transparency>[]()[][]) |
 | Capacity |
 | Clear()()()() |
 | Contains(Transparency) |
 | Copy(array<Transparency>[]()[][], Int32, array<Transparency>[]()[][], Int32, Int32) |
 | CopyTo(array<Transparency>[]()[][], Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IEnumerable..::..GetEnumerator()()()() |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Remove(Object) |
 | IndexOf(Transparency) |
 | Insert(Int32, Transparency) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Transparency) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() |
Inheritance Hierarchy
Object
TransparencyCollection


TransparencyCollection Constructor

TransparencyCollection Constructor
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »TransparencyCollection()()()()
Members
Icon | Member | Description
 | TransparencyCollection(Int32) |
 | TransparencyCollection(array<Transparency>[]()[][]) |
 | TransparencyCollection()()()() |


TransparencyCollection Constructor

TransparencyCollection Constructor
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »TransparencyCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransparencyCollection()
Public Sub New
public:
TransparencyCollection()


TransparencyCollection Constructor (capacity)

TransparencyCollection Constructor (capacity)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »TransparencyCollection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TransparencyCollection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
TransparencyCollection(
    int capacity
)
Parameters
capacity(Int32)


TransparencyCollection Constructor (values)

TransparencyCollection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »TransparencyCollection(array<Transparency>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TransparencyCollection(
    Transparency[] values
)
Public Sub New ( _
    values As Transparency() _
)
public:
TransparencyCollection(
    array<Transparency>^ values
)
Parameters
values(array< Transparency >[]()[][])


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »Add(Transparency)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Transparency value
)
Public Function Add ( _
    value As Transparency _
) As Integer
public:
virtual int Add(
    Transparency value
) sealed
Parameters
value(Transparency)


AddRange Method (range)

AddRange Method (range)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »AddRange(array<Transparency>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    Transparency[] range
)
Public Sub AddRange ( _
    range As Transparency() _
)
public:
virtual void AddRange(
    array<Transparency>^ range
) sealed
Parameters
range(array< Transparency >[]()[][])


Capacity Property

Capacity Property
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »Capacity
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »Contains(Transparency)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Transparency value
)
Public Function Contains ( _
    value As Transparency _
) As Boolean
public:
virtual bool Contains(
    Transparency value
) sealed
Parameters
value(Transparency)


Copy Method (source, sourceIndex, destination, destinationIndex, length)

Copy Method (source, sourceIndex, destination, destinationIndex, length)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »Copy(array<Transparency>[]()[][], Int32, array<Transparency>[]()[][], Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Copy(
    Transparency[] source,
    int sourceIndex,
    Transparency[] destination,
    int destinationIndex,
    int length
)
Public Sub Copy ( _
    source As Transparency(), _
    sourceIndex As Integer, _
    destination As Transparency(), _
    destinationIndex As Integer, _
    length As Integer _
)
public:
void Copy(
    array<Transparency>^ source,
    int sourceIndex,
    array<Transparency>^ destination,
    int destinationIndex,
    int length
)
Parameters
source(array< Transparency >[]()[][])
sourceIndex(Int32)
destination(array< Transparency >[]()[][])
destinationIndex(Int32)
length(Int32)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »CopyTo(array<Transparency>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Transparency[] array,
    int index
)
Public Sub CopyTo ( _
    array As Transparency(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<Transparency>^ array,
    int index
) sealed
Parameters
array(array< Transparency >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransparencyCollectionEnumerator GetEnumerator()
Public Function GetEnumerator As TransparencyCollectionEnumerator
public:
virtual TransparencyCollectionEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (array, index)

ICollectionCopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollectionCopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IEnumerableGetEnumerator Method

IEnumerableGetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IEnumerable..::..GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
IEnumerator IEnumerable.GetEnumerator()
Private Function IEnumerableGetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ IEnumerableGetEnumerator() sealed = IEnumerable::GetEnumerator


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IListAdd Method (value)

IListAdd Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IListAdd ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IListAdd(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IListContains Method (value)

IListContains Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IListContains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IListContains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IListIndexOf Method (value)

IListIndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IListIndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IListIndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IListInsert Method (index, value)

IListInsert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IListInsert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IListInsert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IListRemove Method (value)

IListRemove Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IListRemove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IListRemove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IndexOf(Transparency)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Transparency value
)
Public Function IndexOf ( _
    value As Transparency _
) As Integer
public:
virtual int IndexOf(
    Transparency value
) sealed
Parameters
value(Transparency)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »Insert(Int32, Transparency)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Transparency value
)
Public Sub Insert ( _
    index As Integer, _
    value As Transparency _
)
public:
virtual void Insert(
    int index,
    Transparency value
) sealed
Parameters
index(Int32)
value(Transparency)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public virtual Transparency this[
    int index
] { get; set; }
Public Overridable Default Property Item ( _
    index As Integer _
) As Transparency
    Get
    Set
public:
virtual property Transparency default[int index] {
    Transparency get (int index);
    void set (int index, Transparency value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »Remove(Transparency)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Transparency value
)
Public Sub Remove ( _
    value As Transparency _
)
public:
virtual void Remove(
    Transparency value
) sealed
Parameters
value(Transparency)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Transparency[] ToArray()
Public Function ToArray As Transparency()
public:
virtual array<Transparency>^ ToArray() sealed


TrimToSize Method

TrimToSize Method
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollection »TrimToSize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void TrimToSize()
Public Sub TrimToSize
public:
virtual void TrimToSize() sealed


TransparencyCollectionEnumerator Class

TransparencyCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public sealed class TransparencyCollectionEnumerator : IEnumerator
Public NotInheritable Class TransparencyCollectionEnumerator _
    Implements IEnumerator
public ref class TransparencyCollectionEnumerator sealed : IEnumerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransparencyCollectionEnumerator(TransparencyCollection) |
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerator..::..Current |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
TransparencyCollectionEnumerator


TransparencyCollectionEnumerator Constructor (col)

TransparencyCollectionEnumerator Constructor (col)
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollectionEnumerator »TransparencyCollectionEnumerator(TransparencyCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TransparencyCollectionEnumerator(
    TransparencyCollection col
)
Public Sub New ( _
    col As TransparencyCollection _
)
public:
TransparencyCollectionEnumerator(
    TransparencyCollection^ col
)
Parameters
col(TransparencyCollection)


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual ValueType Current { get; }
Public Overridable ReadOnly Property Current As ValueType
    Get
public:
virtual property ValueType^ Current {
    ValueType^ get ();
}


IEnumeratorCurrent Property

IEnumeratorCurrent Property
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollectionEnumerator »IEnumerator..::..Current
Declaration Syntax
C# Visual Basic Visual C++
Object IEnumerator.Current { get; }
Private ReadOnly Property IEnumeratorCurrent As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ IEnumeratorCurrent {
    Object^ get () sealed = IEnumerator::Current::get;
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


TransparencyMethod Enumeration

TransparencyMethod Enumeration
Namespaces »ZwSoft.ZwCAD.Colors »TransparencyMethod
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdCmTransparency::transparencyMethod")]
public enum TransparencyMethod
<WrapperAttribute("OdCmTransparency::transparencyMethod")> _
Public Enumeration TransparencyMethod
[WrapperAttribute(L"OdCmTransparency::transparencyMethod")]
public enum class TransparencyMethod
Members
Member | Description
ByBlock |
ByLayer |
ErrorValue |
ByAlpha |


ZwSoft.ZwCAD.DatabaseServices Namespace

ZwSoft.ZwCAD.DatabaseServices Namespace
Namespaces »ZwSoft.ZwCAD.DatabaseServices
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.DatabaseServices
Namespace ZwSoft.ZwCAD.DatabaseServices
namespace ZwSoft.ZwCAD.DatabaseServices
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
 | AbstractViewTable |
 | AbstractViewTableRecord |
 | AlignedDimension |
 | AngleConstraint |
 | AnnotationScale |
 | AnnotationType |
 | AnnotativeStates |
 | ApplicationLoadReasons |
 | Arc |
 | ArcDimension |
 | AssocFlags |
 | AttachmentPoint |
 | AttributeCollection |
 | AttributeDefinition |
 | AttributeReference |
 | AuditInfo |
 | AuditPass |
 | Background |
 | BeginInsertEventArgs |
 | BeginInsertEventHandler |
 | BeginWblockBlockEventArgs |
 | BeginWblockBlockEventHandler |
 | BeginWblockEntireDatabaseEventArgs |
 | BeginWblockEntireDatabaseEventHandler |
 | BeginWblockObjectsEventArgs |
 | BeginWblockObjectsEventHandler |
 | BeginWblockSelectedObjectsEventArgs |
 | BeginWblockSelectedObjectsEventHandler |
 | BitmapDeviceFlags |
 | BlockBegin |
 | BlockConnectionType |
 | BlockEnd |
 | BlockInsertionPointsEventArgs |
 | BlockInsertionPointsEventHandler |
 | BlockReference |
 | BlockScaling |
 | BlockTable |
 | BlockTableRecord |
 | BlockTableRecordEnumerator |
 | Body |
 | BooleanOperationType |
 | BulgeVertex |
 | BulgeVertexCollection |
 | Cell |
 | CellAlignment |
 | CellBorder |
 | CellBorders |
 | CellClass |
 | CellContent |
 | CellContentLayout |
 | CellContentsCollection |
 | CellContentTypes |
 | CellEdgeMasks |
 | CellMargins |
 | CellOption |
 | CellProperties |
 | CellRange |
 | CellReference |
 | CellStates |
 | CellType |
 | Circle |
 | ClipBoundaryType |
 | CollisionType |
 | Column |
 | ColumnsCollection |
 | ColumnType |
 | ConstrainType |
 | ContentType |
 | GripData..::..Context |
 | Curve |
 | CustomObjectSnapMode |
 | CustomScale |
 | Database |
 | DatabaseIOEventArgs |
 | DatabaseIOEventHandler |
 | DatabaseSummaryInfo |
 | DatabaseSummaryInfoBuilder |
 | DataCell |
 | DataCellCollection |
 | DataColumn |
 | DataLink |
 | DataLinkGetSourceContext |
 | DataLinkManager |
 | DataLinkOption |
 | DataTable |
 | DataType |
 | DataTypeParameter |
 | DBDictionary |
 | DBDictionaryEntry |
 | DbDictionaryEnumerator |
 | DbHomeView |
 | DBObject |
 | DBObjectCollection |
 | DBObjectReference |
 | DBObjectReferenceCollection |
 | DBPoint |
 | DBText |
 | DBVisualStyle |
 | DecomposeForSaveReplacementRecord |
 | DeepCloneType |
 | DefaultLightingType |
 | DgnDefinition |
 | DgnReference |
 | DgnUnderlayItem |
 | DiametricDimension |
 | DictionaryWithDefaultDictionary |
 | DimArrowFlag |
 | DimAssoc |
 | DimAssocPointType |
 | Dimension |
 | DimensionCenterMarkType |
 | DimStyleTable |
 | DimStyleTableRecord |
 | DragStatus |
 | DrawLeaderOrderType |
 | DrawMLeaderOrderType |
 | DrawOrderTable |
 | GripData..::..DrawType |
 | DuplicateRecordCloning |
 | DwfDefinition |
 | DwfReference |
 | DwgFiler |
 | DwgVersion |
 | DxfCode |
 | DxfFiler |
 | DynamicBlockReferenceProperty |
 | DynamicBlockReferencePropertyCollection |
 | DynamicBlockReferencePropertyCollectionEnumerator |
 | DynamicBlockReferencePropertyUnitsType |
 | DynamicDimensionChangedEventArgs |
 | DynamicDimensionData |
 | DynamicDimensionDataCollection |
 | Ellipse |
 | EndCap |
 | Entity |
 | EntityVisualStyleType |
 | EraseFlags |
 | EvalFields |
 | Extents2d |
 | Extents3d |
 | ExtrudedSurface |
 | Face |
 | FaceRecord |
 | FeatureControlFrame |
 | Field |
 | FieldCodeFlags |
 | FieldCodeWithChildren |
 | FieldEngine |
 | FieldEvaluationContext |
 | FieldEvaluationOptions |
 | FieldEvaluationResult |
 | FieldEvaluationStatus |
 | FieldEvaluationStatusResult |
 | FieldEvaluator |
 | FieldEvaluatorLoader |
 | FieldFilingOptions |
 | FieldResult |
 | FieldResultImp |
 | FieldState |
 | FieldUpdateResult |
 | FileDependencyInfo |
 | FileDependencyManager |
 | FileOpenMode |
 | FilerType |
 | FillStyle |
 | FindFileHint |
 | FitData |
 | FlowDirection |
 | FormatOption |
 | FormattedTableData |
 | FrameSetting |
 | FullDwgVersion |
 | FullSubentityPath |
 | GeoLocationData |
 | GetGripPointsFlags |
 | GradientBackground |
 | GradientColor |
 | GradientPatternType |
 | Graph |
 | GraphicsMetafileType |
 | GraphNode |
 | GraphNodeCollection |
 | GridLineStyle |
 | GridLineType |
 | GridProperties |
 | GridPropertyParameter |
 | GripData |
 | GripDataCollection |
 | GripStatus |
 | GroundPlaneBackground |
 | Group |
 | GsMarkType |
 | Handle |
 | Hatch |
 | HatchEdgeType |
 | HatchLoop |
 | HatchLoopTypes |
 | HatchObjectType |
 | HatchPatternType |
 | HatchStyle |
 | Helix |
 | HostApplicationServices |
 | HyperLink |
 | HyperLinkCollection |
 | IdMapping |
 | IdMappingEventArgs |
 | IdMappingEventHandler |
 | IdPair |
 | Image |
 | ImageDisplayOptions |
 | ImageOrg |
 | ImageQuality |
 | IndexCreation |
 | Intersect |
 | ISubObject |
 | Ole2Frame..::..ItemType |
 | JoinStyle |
 | LayerEvaluation |
 | LayerStateDeletedEventArgs |
 | LayerStateDeletedEventHandler |
 | LayerStateEventArgs |
 | LayerStateEventHandler |
 | LayerStateManager |
 | LayerStateMasks |
 | LayerStateRenameEventArgs |
 | LayerStateRenameEventHandler |
 | LayerTable |
 | LayerTableRecord |
 | LayerViewportProperties |
 | Layout |
 | LayoutCopiedEventArgs |
 | LayoutCopiedEventHandler |
 | LayoutEventArgs |
 | LayoutEventHandler |
 | LayoutManager |
 | LayoutRenamedEventArgs |
 | LayoutRenamedEventHandler |
 | Leader |
 | LeaderDirectionType |
 | LeaderType |
 | LightingUnits |
 | Line |
 | LineAngularDimension2 |
 | LineEndStyle |
 | LineJoinStyle |
 | LineSpacingStyle |
 | LineType |
 | LinetypeTable |
 | LinetypeTableRecord |
 | LineWeight |
 | LineWeightConverter |
 | LinkedData |
 | LinkedTableData |
 | LinkedTableEnumerator |
 | LoftedSurface |
 | LoftOptions |
 | LoftOptionsBuilder |
 | LoftOptionsCheckCurvesOut |
 | LoftOptionsNormalOption |
 | MaintenanceReleaseVersion |
 | MatchProperties |
 | Material |
 | MeasurementValue |
 | MergeCellStyleOption |
 | MeshPointMap |
 | MeshPointMaps |
 | MInsertBlock |
 | MLeader |
 | MLeaderStyle |
 | Mline |
 | MlineJustification |
 | MlineStyle |
 | MlineStyleElement |
 | MlineStyleElementCollection |
 | MlineStyleElementCollectionEnumerator |
 | ModelerFlavor |
 | MoveGripPointsFlags |
 | MoveType |
 | MText |
 | MTextFragment |
 | MTextFragmentCallback |
 | MTextFragmentCallbackStatus |
 | NewLayerNotification |
 | NurbsData |
 | ObjectClosedEventArgs |
 | ObjectClosedEventHandler |
 | ObjectContext |
 | ObjectContextCollection |
 | ObjectContextCollectionEnumerator |
 | ObjectContextManager |
 | ObjectErasedEventArgs |
 | ObjectErasedEventHandler |
 | ObjectEventArgs |
 | ObjectEventHandler |
 | ObjectId |
 | ObjectIdCollection |
 | ObjectIdGraph |
 | ObjectIterator |
 | ObjectSnapModes |
 | ObjectTypeAttribute |
 | Ole2Frame |
 | OleDvAspect |
 | OpenMode |
 | OpenModeAttribute |
 | OrdinateDimension |
 | OrthographicView |
 | OsnapPointRef |
 | PaperOrientationStates |
 | ParseOption |
 | PasswordOptions |
 | PathOption |
 | PatternDefinition |
 | PlaceHolder |
 | Planarity |
 | PlaneSurface |
 | PlotPaperUnit |
 | PlotRotation |
 | PlotSettings |
 | PlotSettingsShadePlotType |
 | PlotSettingsValidator |
 | PlotStyle |
 | PlotStyleData |
 | PlotStyleDescriptor |
 | PlotStyleNameType |
 | PlotStyleTable |
 | PlotStyleTableChangedEventArgs |
 | PlotStyleTableChangedEventHandler |
 | PlotType |
 | Point3AngularDimension |
 | PointRef |
 | Poly2dType |
 | Poly3dType |
 | PolyFaceMesh |
 | PolyFaceMeshVertex |
 | PolygonMesh |
 | PolygonMeshVertex |
 | Polyline |
 | Polyline2d |
 | Polyline3d |
 | PolylineVertex3d |
 | PolyMeshType |
 | ProxyEntity |
 | ProxyObject |
 | ProxyResurrectionCompletedEventArgs |
 | ProxyResurrectionCompletedEventHandler |
 | RadialDimension |
 | RadialDimensionLarge |
 | RasterImage |
 | RasterImageDef |
 | RasterVariables |
 | Ray |
 | Rectangle3d |
 | RegAppTable |
 | RegAppTableRecord |
 | Region |
 | RenderMode |
 | ReservedStringEnumType |
 | ResultBuffer |
 | ResultBufferEnumerator |
 | GripData..::..ReturnValue |
 | RevolvedSurface |
 | RevolveOptions |
 | RevolveOptionsBuilder |
 | RevolveOptionsCheckRevolveCurveOut |
 | RotatedDimension |
 | RotatedDimType |
 | RotationAngle |
 | Row |
 | RowsCollection |
 | RowType |
 | SaveType |
 | ScaleEstimationMethod |
 | Section |
 | SectionGeneration |
 | SectionGeometry |
 | SectionHeight |
 | SectionHitTestInfo |
 | SectionManager |
 | SectionSettings |
 | SectionState |
 | SectionSubItem |
 | SectionType |
 | SecurityActions |
 | SecurityAlgorithm |
 | SecurityParameters |
 | SegmentType |
 | SelectType |
 | SequenceEnd |
 | ShadePlotResLevel |
 | ShadePlotType |
 | Shape |
 | SkyBackground |
 | Solid |
 | Solid3d |
 | Solid3dMassProperties |
 | SolidBackground |
 | Spline |
 | StandardScaleType |
 | GripData..::..Status |
 | StdScaleType |
 | SubentityId |
 | SubentityType |
 | Sun |
 | Surface |
 | SurfaceSliceResults |
 | SweepOptions |
 | SweepOptionsAlignOption |
 | SweepOptionsBuilder |
 | SweepOptionsCheckSweepCurveOut |
 | SweptSurface |
 | SymbolTable |
 | SymbolTableEnumerator |
 | SymbolTableRecord |
 | SymbolUtilityServices |
 | SystemVariableChangedEventArgs |
 | SystemVariableChangedEventHandler |
 | SystemVariableChangingEventArgs |
 | SystemVariableChangingEventHandler |
 | Table |
 | TableBreakFlowDirection |
 | TableBreakOptions |
 | TableCellType |
 | TableContent |
 | TableCopyOptions |
 | TableEnumerator |
 | TableEnumeratorOption |
 | TableFillOptions |
 | TableHitTestInfo |
 | TableHitTestType |
 | TableStyle |
 | TableStyleFlags |
 | TableStyleOverride |
 | TableTemplate |
 | TextAlignmentType |
 | TextAngleType |
 | TextAttachmentDirection |
 | TextAttachmentType |
 | TextHorizontalMode |
 | TextStyleTable |
 | TextStyleTableRecord |
 | TextVerticalMode |
 | TimeZone |
 | Trace |
 | Transaction |
 | TransactionManager |
 | TypedValue |
 | TypeOfCoordinates |
 | UcsTable |
 | UcsTableRecord |
 | UnderlayDefinition |
 | UnderlayFile |
 | UnderlayHost |
 | UnderlayItem |
 | UnderlayItemCollection |
 | UnderlayLayer |
 | UnderlayLayerCollection |
 | UnderlayLayerState |
 | UnderlayReference |
 | Unit |
 | UnitsConverter |
 | UnitsValue |
 | UnitType |
 | UnitTypeAttribute |
 | UpdateAction |
 | UpdateDirection |
 | UpdateOption |
 | Vertex |
 | Vertex2d |
 | Vertex2dType |
 | Vertex3dType |
 | Viewport |
 | ViewportTable |
 | ViewportTableRecord |
 | ViewTable |
 | ViewTableRecord |
 | ViewTableRecordRenderMode |
 | Visibility |
 | WblockNoticeEventArgs |
 | WblockNoticeEventHandler |
 | Wipeout |
 | Xline |
 | Xrecord |
 | XrefBeginOperationEventArgs |
 | XrefBeginOperationEventHandler |
 | XrefComandeeredEventArgs |
 | XrefComandeeredEventHandler |
 | XrefGraph |
 | XrefGraphNode |
 | XrefNotificationStatus |
 | XrefOperation |
 | XrefPreXrefLockFileEventArgs |
 | XrefPreXrefLockFileEventHandler |
 | XrefRedirectedEventArgs |
 | XrefRedirectedEventHandler |
 | XrefStatus |
 | XrefSubCommandAbortedEventHandler |
 | XrefSubCommandEventArgs |
 | XrefSubCommandStartEventHandler |
 | XrefVetoableSubCommandEventArgs |


AbstractViewTable Class

AbstractViewTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbAbstractViewTable")]
public abstract class AbstractViewTable : SymbolTable
<WrapperAttribute("AcDbAbstractViewTable")> _
Public MustInherit Class AbstractViewTable _
    Inherits SymbolTable
[WrapperAttribute(L"AcDbAbstractViewTable")]
public ref class AbstractViewTable abstract : public SymbolTable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AbstractViewTable(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) | (Inherited from SymbolTable.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() | (Inherited from SymbolTable.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) | (Inherited from SymbolTable.)
 | Has(ObjectId) | (Inherited from SymbolTable.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from SymbolTable.)
 | IncludingErased | (Inherited from SymbolTable.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from SymbolTable.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | AbstractViewTable


AbstractViewTable Constructor (unmanagedPointer, autoDelete)

AbstractViewTable Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTable »AbstractViewTable(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal AbstractViewTable(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
AbstractViewTable(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AbstractViewTableRecord Class

AbstractViewTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbAbstractViewTableRecord")]
public abstract class AbstractViewTableRecord : SymbolTableRecord
<WrapperAttribute("AcDbAbstractViewTableRecord")> _
Public MustInherit Class AbstractViewTableRecord _
    Inherits SymbolTableRecord
[WrapperAttribute(L"AcDbAbstractViewTableRecord")]
public ref class AbstractViewTableRecord abstract : public SymbolTableRecord
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AbstractViewTableRecord(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AmbientLightColor |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackClipDistance |
 | BackClipEnabled |
 | Background |
 | Bounds | (Inherited from Drawable.)
 | Brightness |
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CenterPoint |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Contrast |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DefaultLightingOn |
 | DefaultLightingType |
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Elevation |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FrontClipAtEye |
 | FrontClipDistance |
 | FrontClipEnabled |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height |
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent | (Inherited from SymbolTableRecord.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsResolved | (Inherited from SymbolTableRecord.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | LensLength |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from SymbolTableRecord.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PerspectiveEnabled |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RenderMode |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetSun(DBObject) |
 | SetUcs(Point3d, Vector3d, Vector3d) |
 | SetUcs(OrthographicView) |
 | SetUcs(ObjectId) |
 | SetUcsToWorld()()()() |
 | SetViewDirection(OrthographicView) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SunId |
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Target |
 | ToString()()()() | (Inherited from Object.)
 | Ucs |
 | UcsName |
 | UcsOrthographic |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewDirection |
 | ViewOrthographic |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | ViewTwist |
 | VisualStyleId |
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | AbstractViewTableRecord
 |  |  |  |  |  |  |  | ViewportTableRecord
 |  |  |  |  |  |  |  | ViewTableRecord


AbstractViewTableRecord Constructor (obj, autoDelete)

AbstractViewTableRecord Constructor (obj, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »AbstractViewTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal AbstractViewTableRecord(
    IntPtr obj,
    bool autoDelete
)
Protected Friend Sub New ( _
    obj As IntPtr, _
    autoDelete As Boolean _
)
protected public:
AbstractViewTableRecord(
    IntPtr obj,
    bool autoDelete
)
Parameters
obj(IntPtr)
autoDelete(Boolean)


AmbientLightColor Property

AmbientLightColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »AmbientLightColor
Declaration Syntax
C# Visual Basic Visual C++
public Color AmbientLightColor { get; set; }
Public Property AmbientLightColor As Color
    Get
    Set
public:
property Color^ AmbientLightColor {
    Color^ get ();
    void set (Color^ value);
}


BackClipDistance Property

BackClipDistance Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »BackClipDistance
Declaration Syntax
C# Visual Basic Visual C++
public double BackClipDistance { get; set; }
Public Property BackClipDistance As Double
    Get
    Set
public:
property double BackClipDistance {
    double get ();
    void set (double value);
}


BackClipEnabled Property

BackClipEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »BackClipEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BackClipEnabled { get; set; }
Public Property BackClipEnabled As Boolean
    Get
    Set
public:
property bool BackClipEnabled {
    bool get ();
    void set (bool value);
}


Background Property

Background Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »Background
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Background { get; set; }
Public Property Background As ObjectId
    Get
    Set
public:
property ObjectId Background {
    ObjectId get ();
    void set (ObjectId value);
}


Brightness Property

Brightness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »Brightness
Declaration Syntax
C# Visual Basic Visual C++
public double Brightness { get; set; }
Public Property Brightness As Double
    Get
    Set
public:
property double Brightness {
    double get ();
    void set (double value);
}


CenterPoint Property

CenterPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »CenterPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d CenterPoint { get; set; }
Public Property CenterPoint As Point2d
    Get
    Set
public:
property Point2d CenterPoint {
    Point2d get ();
    void set (Point2d value);
}


Contrast Property

Contrast Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »Contrast
Declaration Syntax
C# Visual Basic Visual C++
public double Contrast { get; set; }
Public Property Contrast As Double
    Get
    Set
public:
property double Contrast {
    double get ();
    void set (double value);
}


DefaultLightingOn Property

DefaultLightingOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »DefaultLightingOn
Declaration Syntax
C# Visual Basic Visual C++
public bool DefaultLightingOn { get; set; }
Public Property DefaultLightingOn As Boolean
    Get
    Set
public:
property bool DefaultLightingOn {
    bool get ();
    void set (bool value);
}


DefaultLightingType Property

DefaultLightingType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »DefaultLightingType
Declaration Syntax
C# Visual Basic Visual C++
public DefaultLightingType DefaultLightingType { get; set; }
Public Property DefaultLightingType As DefaultLightingType
    Get
    Set
public:
property DefaultLightingType DefaultLightingType {
    DefaultLightingType get ();
    void set (DefaultLightingType value);
}


Elevation Property

Elevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »Elevation
Declaration Syntax
C# Visual Basic Visual C++
public double Elevation { get; set; }
Public Property Elevation As Double
    Get
    Set
public:
property double Elevation {
    double get ();
    void set (double value);
}


FrontClipAtEye Property

FrontClipAtEye Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »FrontClipAtEye
Declaration Syntax
C# Visual Basic Visual C++
public bool FrontClipAtEye { get; set; }
Public Property FrontClipAtEye As Boolean
    Get
    Set
public:
property bool FrontClipAtEye {
    bool get ();
    void set (bool value);
}


FrontClipDistance Property

FrontClipDistance Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »FrontClipDistance
Declaration Syntax
C# Visual Basic Visual C++
public double FrontClipDistance { get; set; }
Public Property FrontClipDistance As Double
    Get
    Set
public:
property double FrontClipDistance {
    double get ();
    void set (double value);
}


FrontClipEnabled Property

FrontClipEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »FrontClipEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool FrontClipEnabled { get; set; }
Public Property FrontClipEnabled As Boolean
    Get
    Set
public:
property bool FrontClipEnabled {
    bool get ();
    void set (bool value);
}


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »Height
Declaration Syntax
C# Visual Basic Visual C++
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}


LensLength Property

LensLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »LensLength
Declaration Syntax
C# Visual Basic Visual C++
public double LensLength { get; set; }
Public Property LensLength As Double
    Get
    Set
public:
property double LensLength {
    double get ();
    void set (double value);
}


PerspectiveEnabled Property

PerspectiveEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »PerspectiveEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool PerspectiveEnabled { get; set; }
Public Property PerspectiveEnabled As Boolean
    Get
    Set
public:
property bool PerspectiveEnabled {
    bool get ();
    void set (bool value);
}


RenderMode Property

RenderMode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »RenderMode
Declaration Syntax
C# Visual Basic Visual C++
public ViewTableRecordRenderMode RenderMode { get; set; }
Public Property RenderMode As ViewTableRecordRenderMode
    Get
    Set
public:
property ViewTableRecordRenderMode RenderMode {
    ViewTableRecordRenderMode get ();
    void set (ViewTableRecordRenderMode value);
}


SetSun Method (sun)

SetSun Method (sun)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »SetSun(DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId SetSun(
    DBObject sun
)
Public Function SetSun ( _
    sun As DBObject _
) As ObjectId
public:
ObjectId SetSun(
    DBObject^ sun
)
Parameters
sun(DBObject)


SetUcs Method

SetUcs Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »SetUcs()()()()
Members
Icon | Member | Description
 | SetUcs(Point3d, Vector3d, Vector3d) |
 | SetUcs(OrthographicView) |
 | SetUcs(ObjectId) |


SetUcs Method (id)

SetUcs Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »SetUcs(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUcs(
    ObjectId id
)
Public Sub SetUcs ( _
    id As ObjectId _
)
public:
void SetUcs(
    ObjectId id
)
Parameters
id(ObjectId)


SetUcs Method (view)

SetUcs Method (view)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »SetUcs(OrthographicView)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUcs(
    OrthographicView view
)
Public Sub SetUcs ( _
    view As OrthographicView _
)
public:
void SetUcs(
    OrthographicView view
)
Parameters
view(OrthographicView)


SetUcs Method (origin, x, y)

SetUcs Method (origin, x, y)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »SetUcs(Point3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUcs(
    Point3d origin,
    Vector3d x,
    Vector3d y
)
Public Sub SetUcs ( _
    origin As Point3d, _
    x As Vector3d, _
    y As Vector3d _
)
public:
void SetUcs(
    Point3d origin,
    Vector3d x,
    Vector3d y
)
Parameters
origin(Point3d)
x(Vector3d)
y(Vector3d)


SetUcsToWorld Method

SetUcsToWorld Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »SetUcsToWorld()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetUcsToWorld()
Public Sub SetUcsToWorld
public:
void SetUcsToWorld()


SetViewDirection Method (view)

SetViewDirection Method (view)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »SetViewDirection(OrthographicView)
Declaration Syntax
C# Visual Basic Visual C++
public void SetViewDirection(
    OrthographicView view
)
Public Sub SetViewDirection ( _
    view As OrthographicView _
)
public:
void SetViewDirection(
    OrthographicView view
)
Parameters
view(OrthographicView)


SunId Property

SunId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »SunId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId SunId { get; }
Public ReadOnly Property SunId As ObjectId
    Get
public:
property ObjectId SunId {
    ObjectId get ();
}


Target Property

Target Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »Target
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Target { get; set; }
Public Property Target As Point3d
    Get
    Set
public:
property Point3d Target {
    Point3d get ();
    void set (Point3d value);
}


Ucs Property

Ucs Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »Ucs
Declaration Syntax
C# Visual Basic Visual C++
public CoordinateSystem3d Ucs { get; }
Public ReadOnly Property Ucs As CoordinateSystem3d
    Get
public:
property CoordinateSystem3d Ucs {
    CoordinateSystem3d get ();
}


UcsName Property

UcsName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »UcsName
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId UcsName { get; }
Public ReadOnly Property UcsName As ObjectId
    Get
public:
property ObjectId UcsName {
    ObjectId get ();
}


UcsOrthographic Property

UcsOrthographic Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »UcsOrthographic
Declaration Syntax
C# Visual Basic Visual C++
public OrthographicView UcsOrthographic { get; }
Public ReadOnly Property UcsOrthographic As OrthographicView
    Get
public:
property OrthographicView UcsOrthographic {
    OrthographicView get ();
}


ViewDirection Property

ViewDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »ViewDirection
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d ViewDirection { get; set; }
Public Property ViewDirection As Vector3d
    Get
    Set
public:
property Vector3d ViewDirection {
    Vector3d get ();
    void set (Vector3d value);
}


ViewOrthographic Property

ViewOrthographic Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »ViewOrthographic
Declaration Syntax
C# Visual Basic Visual C++
public OrthographicView ViewOrthographic { get; }
Public ReadOnly Property ViewOrthographic As OrthographicView
    Get
public:
property OrthographicView ViewOrthographic {
    OrthographicView get ();
}


ViewTwist Property

ViewTwist Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »ViewTwist
Declaration Syntax
C# Visual Basic Visual C++
public double ViewTwist { get; set; }
Public Property ViewTwist As Double
    Get
    Set
public:
property double ViewTwist {
    double get ();
    void set (double value);
}


VisualStyleId Property

VisualStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »VisualStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId VisualStyleId { get; set; }
Public Property VisualStyleId As ObjectId
    Get
    Set
public:
property ObjectId VisualStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


Width Property

Width Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »Width
Declaration Syntax
C# Visual Basic Visual C++
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}


AlignedDimension Class

AlignedDimension Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbAlignedDimension")]
public class AlignedDimension : Dimension
<WrapperAttribute("AcDbAlignedDimension")> _
Public Class AlignedDimension _
    Inherits Dimension
[WrapperAttribute(L"AcDbAlignedDimension")]
public ref class AlignedDimension : public Dimension
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AlignedDimension(Point3d, Point3d, Point3d, String, ObjectId) |
 | AlignedDimension()()()() |
 | AlignedDimension(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlternatePrefix | (Inherited from Dimension.)
 | AlternateSuffix | (Inherited from Dimension.)
 | AltSuppressLeadingZeros | (Inherited from Dimension.)
 | AltSuppressTrailingZeros | (Inherited from Dimension.)
 | AltSuppressZeroFeet | (Inherited from Dimension.)
 | AltSuppressZeroInches | (Inherited from Dimension.)
 | AltToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | AltToleranceSuppressZeroInches | (Inherited from Dimension.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | CenterMarkSize | (Inherited from Dimension.)
 | CenterMarkType | (Inherited from Dimension.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec | (Inherited from Dimension.)
 | Dimalt | (Inherited from Dimension.)
 | Dimaltd | (Inherited from Dimension.)
 | Dimaltf | (Inherited from Dimension.)
 | Dimaltrnd | (Inherited from Dimension.)
 | Dimalttd | (Inherited from Dimension.)
 | Dimalttz | (Inherited from Dimension.)
 | Dimaltu | (Inherited from Dimension.)
 | Dimaltz | (Inherited from Dimension.)
 | Dimapost | (Inherited from Dimension.)
 | Dimarcsym | (Inherited from Dimension.)
 | Dimasz | (Inherited from Dimension.)
 | Dimatfit | (Inherited from Dimension.)
 | Dimaunit | (Inherited from Dimension.)
 | Dimazin | (Inherited from Dimension.)
 | Dimblk | (Inherited from Dimension.)
 | Dimblk1 | (Inherited from Dimension.)
 | Dimblk1s | (Inherited from Dimension.)
 | Dimblk2 | (Inherited from Dimension.)
 | Dimblk2s | (Inherited from Dimension.)
 | Dimblks | (Inherited from Dimension.)
 | DimBlockId | (Inherited from Dimension.)
 | DimBlockPosition | (Inherited from Dimension.)
 | Dimcen | (Inherited from Dimension.)
 | Dimclrd | (Inherited from Dimension.)
 | Dimclre | (Inherited from Dimension.)
 | Dimclrt | (Inherited from Dimension.)
 | Dimdec | (Inherited from Dimension.)
 | Dimdle | (Inherited from Dimension.)
 | Dimdli | (Inherited from Dimension.)
 | Dimdsep | (Inherited from Dimension.)
 | DimensionStyle | (Inherited from Dimension.)
 | DimensionStyleName | (Inherited from Dimension.)
 | DimensionText | (Inherited from Dimension.)
 | Dimexe | (Inherited from Dimension.)
 | Dimexo | (Inherited from Dimension.)
 | Dimfrac | (Inherited from Dimension.)
 | Dimfxlen | (Inherited from Dimension.)
 | DimfxlenOn | (Inherited from Dimension.)
 | Dimgap | (Inherited from Dimension.)
 | Dimjogang | (Inherited from Dimension.)
 | Dimjust | (Inherited from Dimension.)
 | Dimldrblk | (Inherited from Dimension.)
 | Dimldrblks | (Inherited from Dimension.)
 | Dimlfac | (Inherited from Dimension.)
 | Dimlim | (Inherited from Dimension.)
 | DimLinePoint |
 | Dimltex1 | (Inherited from Dimension.)
 | Dimltex2 | (Inherited from Dimension.)
 | Dimltype | (Inherited from Dimension.)
 | Dimlunit | (Inherited from Dimension.)
 | Dimlwd | (Inherited from Dimension.)
 | Dimlwe | (Inherited from Dimension.)
 | Dimpost | (Inherited from Dimension.)
 | Dimrnd | (Inherited from Dimension.)
 | Dimsah | (Inherited from Dimension.)
 | Dimscale | (Inherited from Dimension.)
 | Dimsd1 | (Inherited from Dimension.)
 | Dimsd2 | (Inherited from Dimension.)
 | Dimse1 | (Inherited from Dimension.)
 | Dimse2 | (Inherited from Dimension.)
 | Dimsoxd | (Inherited from Dimension.)
 | DimstyleData | (Inherited from Dimension.)
 | Dimtad | (Inherited from Dimension.)
 | Dimtdec | (Inherited from Dimension.)
 | Dimtfac | (Inherited from Dimension.)
 | Dimtfill | (Inherited from Dimension.)
 | Dimtfillclr | (Inherited from Dimension.)
 | Dimtih | (Inherited from Dimension.)
 | Dimtix | (Inherited from Dimension.)
 | Dimtm | (Inherited from Dimension.)
 | Dimtmove | (Inherited from Dimension.)
 | Dimtofl | (Inherited from Dimension.)
 | Dimtoh | (Inherited from Dimension.)
 | Dimtol | (Inherited from Dimension.)
 | Dimtolj | (Inherited from Dimension.)
 | Dimtp | (Inherited from Dimension.)
 | Dimtsz | (Inherited from Dimension.)
 | Dimtvp | (Inherited from Dimension.)
 | Dimtxsty | (Inherited from Dimension.)
 | Dimtxt | (Inherited from Dimension.)
 | Dimtzin | (Inherited from Dimension.)
 | Dimupt | (Inherited from Dimension.)
 | Dimzin | (Inherited from Dimension.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicDimension | (Inherited from Dimension.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation | (Inherited from Dimension.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldFromMText(MText) | (Inherited from Dimension.)
 | FieldToMText(MText) | (Inherited from Dimension.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FormatMeasurement(Double, String) | (Inherited from Dimension.)
 | GenerateLayout()()()() | (Inherited from Dimension.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetDimstyleData()()()() | (Inherited from Dimension.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalRotation | (Inherited from Dimension.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | Measurement | (Inherited from Dimension.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal | (Inherited from Dimension.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | Oblique |
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Prefix | (Inherited from Dimension.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeDimensionBlock(Boolean) | (Inherited from Dimension.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveTextField()()()() | (Inherited from Dimension.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) | (Inherited from Dimension.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | Suffix | (Inherited from Dimension.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressAngularLeadingZeros | (Inherited from Dimension.)
 | SuppressAngularTrailingZeros | (Inherited from Dimension.)
 | SuppressLeadingZeros | (Inherited from Dimension.)
 | SuppressTrailingZeros | (Inherited from Dimension.)
 | SuppressZeroFeet | (Inherited from Dimension.)
 | SuppressZeroInches | (Inherited from Dimension.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAttachment | (Inherited from Dimension.)
 | TextLineSpacingFactor | (Inherited from Dimension.)
 | TextLineSpacingStyle | (Inherited from Dimension.)
 | TextPosition | (Inherited from Dimension.)
 | TextRotation | (Inherited from Dimension.)
 | TextStyleId | (Inherited from Dimension.)
 | ToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | ToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | ToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | ToleranceSuppressZeroInches | (Inherited from Dimension.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UsingDefaultTextPosition | (Inherited from Dimension.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | XLine1Point |
 | XLine2Point |
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  |  | AlignedDimension


AlignedDimension Constructor

AlignedDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »AlignedDimension()()()()
Members
Icon | Member | Description
 | AlignedDimension(Point3d, Point3d, Point3d, String, ObjectId) |
 | AlignedDimension()()()() |
 | AlignedDimension(IntPtr, Boolean) |


AlignedDimension Constructor

AlignedDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »AlignedDimension()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AlignedDimension()
Public Sub New
public:
AlignedDimension()


AlignedDimension Constructor (unmanagedObjPtr, autoDelete)

AlignedDimension Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »AlignedDimension(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal AlignedDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
AlignedDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AlignedDimension Constructor (line1Point, line2Point, dimensionLinePoint, dimensionText, dimensionStyle)

AlignedDimension Constructor (line1Point, line2Point, dimensionLinePoint, dimensionText, dimensionStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »AlignedDimension(Point3d, Point3d, Point3d, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public AlignedDimension(
    Point3d line1Point,
    Point3d line2Point,
    Point3d dimensionLinePoint,
    string dimensionText,
    ObjectId dimensionStyle
)
Public Sub New ( _
    line1Point As Point3d, _
    line2Point As Point3d, _
    dimensionLinePoint As Point3d, _
    dimensionText As String, _
    dimensionStyle As ObjectId _
)
public:
AlignedDimension(
    Point3d line1Point,
    Point3d line2Point,
    Point3d dimensionLinePoint,
    String^ dimensionText,
    ObjectId dimensionStyle
)
Parameters
line1Point(Point3d)
line2Point(Point3d)
dimensionLinePoint(Point3d)
dimensionText(String)
dimensionStyle(ObjectId)


DimLinePoint Property

DimLinePoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »DimLinePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d DimLinePoint { get; set; }
Public Property DimLinePoint As Point3d
    Get
    Set
public:
property Point3d DimLinePoint {
    Point3d get ();
    void set (Point3d value);
}


Oblique Property

Oblique Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »Oblique
Declaration Syntax
C# Visual Basic Visual C++
public double Oblique { get; set; }
Public Property Oblique As Double
    Get
    Set
public:
property double Oblique {
    double get ();
    void set (double value);
}


XLine1Point Property

XLine1Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »XLine1Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine1Point { get; set; }
Public Property XLine1Point As Point3d
    Get
    Set
public:
property Point3d XLine1Point {
    Point3d get ();
    void set (Point3d value);
}


XLine2Point Property

XLine2Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »XLine2Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine2Point { get; set; }
Public Property XLine2Point As Point3d
    Get
    Set
public:
property Point3d XLine2Point {
    Point3d get ();
    void set (Point3d value);
}


AngleConstraint Enumeration

AngleConstraint Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AngleConstraint
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::SegmentAngleType")]
public enum AngleConstraint
<WrapperAttribute("ZcDbMLeaderStyle::SegmentAngleType")> _
Public Enumeration AngleConstraint
[WrapperAttribute(L"ZcDbMLeaderStyle::SegmentAngleType")]
public enum class AngleConstraint
Members
Member | Description
DegreesHorz |
Degrees090 |
Degrees060 |
Degrees045 |
Degrees030 |
Degrees015 |
DegreesAny |


AnnotationScale Class

AnnotationScale Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbAnnotationScale")]
public class AnnotationScale : ObjectContext
<WrapperAttribute("ZcDbAnnotationScale")> _
Public Class AnnotationScale _
    Inherits ObjectContext
[WrapperAttribute(L"ZcDbAnnotationScale")]
public ref class AnnotationScale : public ObjectContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnnotationScale()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CollectionName | (Overrides ObjectContext.CollectionName.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DrawingUnits |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsTemporaryScale |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | (Overrides ObjectContext.Name.)
 | PaperUnits |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Scale |
 | ToString()()()() | (Inherited from Object.)
 | UniqueIdentifier | (Overrides ObjectContext.UniqueIdentifier.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | ObjectContext
 |  |  |  |  | AnnotationScale


AnnotationScale Constructor

AnnotationScale Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale »AnnotationScale()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AnnotationScale()
Public Sub New
public:
AnnotationScale()


CollectionName Property

CollectionName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale »CollectionName
Declaration Syntax
C# Visual Basic Visual C++
public override string CollectionName { get; }
Public Overrides ReadOnly Property CollectionName As String
    Get
public:
virtual property String^ CollectionName {
    String^ get () override;
}


DrawingUnits Property

DrawingUnits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale »DrawingUnits
Declaration Syntax
C# Visual Basic Visual C++
public double DrawingUnits { get; set; }
Public Property DrawingUnits As Double
    Get
    Set
public:
property double DrawingUnits {
    double get ();
    void set (double value);
}


IsTemporaryScale Property

IsTemporaryScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale »IsTemporaryScale
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTemporaryScale { get; }
Public ReadOnly Property IsTemporaryScale As Boolean
    Get
public:
property bool IsTemporaryScale {
    bool get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale »Name
Declaration Syntax
C# Visual Basic Visual C++
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}


PaperUnits Property

PaperUnits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale »PaperUnits
Declaration Syntax
C# Visual Basic Visual C++
public double PaperUnits { get; set; }
Public Property PaperUnits As Double
    Get
    Set
public:
property double PaperUnits {
    double get ();
    void set (double value);
}


Scale Property

Scale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale »Scale
Declaration Syntax
C# Visual Basic Visual C++
public double Scale { get; }
Public ReadOnly Property Scale As Double
    Get
public:
property double Scale {
    double get ();
}


UniqueIdentifier Property

UniqueIdentifier Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale »UniqueIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public override IntPtr UniqueIdentifier { get; }
Public Overrides ReadOnly Property UniqueIdentifier As IntPtr
    Get
public:
virtual property IntPtr UniqueIdentifier {
    IntPtr get () override;
}


AnnotationType Enumeration

AnnotationType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbLeader::AnnoType")]
public enum AnnotationType
<WrapperAttribute("ZcDbLeader::AnnoType")> _
Public Enumeration AnnotationType
[WrapperAttribute(L"ZcDbLeader::AnnoType")]
public enum class AnnotationType
Members
Member | Description
NoAnnotation |
BlockRef |
FeatureControlFrame |
MText |


AnnotativeStates Enumeration

AnnotativeStates Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotativeStates
Declaration Syntax
C# Visual Basic Visual C++
public enum AnnotativeStates
Public Enumeration AnnotativeStates
public enum class AnnotativeStates
Members
Member | Description
False |
True |
NotApplicable |


ApplicationLoadReasons Enumeration

ApplicationLoadReasons Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ApplicationLoadReasons
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum ApplicationLoadReasons
<FlagsAttribute> _
Public Enumeration ApplicationLoadReasons
[FlagsAttribute]
public enum class ApplicationLoadReasons
Members
Member | Description
TransparentlyLoadable |
LoadDisabled |
OnLoadRequest |
OnCommandInvocation |
OnAutoCADStartup |
OnProxyDetection |


Arc Class

Arc Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbArc")]
public class Arc : Curve
<WrapperAttribute("AcDbArc")> _
Public Class Arc _
    Inherits Curve
[WrapperAttribute(L"AcDbArc")]
public ref class Arc : public Curve
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Arc(Point3d, Vector3d, Double, Double, Double) |
 | Arc(Point3d, Double, Double, Double) |
 | Arc(IntPtr, Boolean) |
 | Arc()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | Center |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed | (Inherited from Curve.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EndAngle |
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Length |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Radius |
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Spline | (Inherited from Curve.)
 | StartAngle |
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Inherited from Curve.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | TotalAngle |
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Arc


Arc Constructor

Arc Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Arc()()()()
Members
Icon | Member | Description
 | Arc(Point3d, Vector3d, Double, Double, Double) |
 | Arc(Point3d, Double, Double, Double) |
 | Arc(IntPtr, Boolean) |
 | Arc()()()() |


Arc Constructor

Arc Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Arc()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Arc()
Public Sub New
public:
Arc()


Arc Constructor (unmanagedObjPtr, autoDelete)

Arc Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Arc(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Arc(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Arc(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Arc Constructor (center, radius, startAngle, endAngle)

Arc Constructor (center, radius, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Arc(Point3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Arc(
    Point3d center,
    double radius,
    double startAngle,
    double endAngle
)
Public Sub New ( _
    center As Point3d, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
Arc(
    Point3d center,
    double radius,
    double startAngle,
    double endAngle
)
Parameters
center(Point3d)
radius(Double)
startAngle(Double)
endAngle(Double)


Arc Constructor (center, normal, radius, startAngle, endAngle)

Arc Constructor (center, normal, radius, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Arc(Point3d, Vector3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Arc(
    Point3d center,
    Vector3d normal,
    double radius,
    double startAngle,
    double endAngle
)
Public Sub New ( _
    center As Point3d, _
    normal As Vector3d, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
Arc(
    Point3d center,
    Vector3d normal,
    double radius,
    double startAngle,
    double endAngle
)
Parameters
center(Point3d)
normal(Vector3d)
radius(Double)
startAngle(Double)
endAngle(Double)


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Center { get; set; }
Public Property Center As Point3d
    Get
    Set
public:
property Point3d Center {
    Point3d get ();
    void set (Point3d value);
}


EndAngle Property

EndAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »EndAngle
Declaration Syntax
C# Visual Basic Visual C++
public double EndAngle { get; set; }
Public Property EndAngle As Double
    Get
    Set
public:
property double EndAngle {
    double get ();
    void set (double value);
}


Length Property

Length Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Length
Declaration Syntax
C# Visual Basic Visual C++
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


Radius Property

Radius Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Radius
Declaration Syntax
C# Visual Basic Visual C++
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set
public:
property double Radius {
    double get ();
    void set (double value);
}


StartAngle Property

StartAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »StartAngle
Declaration Syntax
C# Visual Basic Visual C++
public double StartAngle { get; set; }
Public Property StartAngle As Double
    Get
    Set
public:
property double StartAngle {
    double get ();
    void set (double value);
}


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}


TotalAngle Property

TotalAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »TotalAngle
Declaration Syntax
C# Visual Basic Visual C++
public double TotalAngle { get; }
Public ReadOnly Property TotalAngle As Double
    Get
public:
property double TotalAngle {
    double get ();
}


ArcDimension Class

ArcDimension Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbArcDimension")]
public class ArcDimension : Dimension
<WrapperAttribute("AcDbArcDimension")> _
Public Class ArcDimension _
    Inherits Dimension
[WrapperAttribute(L"AcDbArcDimension")]
public ref class ArcDimension : public Dimension
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArcDimension(Point3d, Point3d, Point3d, Point3d, String, ObjectId) |
 | ArcDimension(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlternatePrefix | (Inherited from Dimension.)
 | AlternateSuffix | (Inherited from Dimension.)
 | AltSuppressLeadingZeros | (Inherited from Dimension.)
 | AltSuppressTrailingZeros | (Inherited from Dimension.)
 | AltSuppressZeroFeet | (Inherited from Dimension.)
 | AltSuppressZeroInches | (Inherited from Dimension.)
 | AltToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | AltToleranceSuppressZeroInches | (Inherited from Dimension.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | ArcEndParam |
 | ArcPoint |
 | ArcStartParam |
 | ArcSymbolType |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | CenterMarkSize | (Inherited from Dimension.)
 | CenterMarkType | (Inherited from Dimension.)
 | CenterPoint |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec | (Inherited from Dimension.)
 | Dimalt | (Inherited from Dimension.)
 | Dimaltd | (Inherited from Dimension.)
 | Dimaltf | (Inherited from Dimension.)
 | Dimaltrnd | (Inherited from Dimension.)
 | Dimalttd | (Inherited from Dimension.)
 | Dimalttz | (Inherited from Dimension.)
 | Dimaltu | (Inherited from Dimension.)
 | Dimaltz | (Inherited from Dimension.)
 | Dimapost | (Inherited from Dimension.)
 | Dimarcsym | (Inherited from Dimension.)
 | Dimasz | (Inherited from Dimension.)
 | Dimatfit | (Inherited from Dimension.)
 | Dimaunit | (Inherited from Dimension.)
 | Dimazin | (Inherited from Dimension.)
 | Dimblk | (Inherited from Dimension.)
 | Dimblk1 | (Inherited from Dimension.)
 | Dimblk1s | (Inherited from Dimension.)
 | Dimblk2 | (Inherited from Dimension.)
 | Dimblk2s | (Inherited from Dimension.)
 | Dimblks | (Inherited from Dimension.)
 | DimBlockId | (Inherited from Dimension.)
 | DimBlockPosition | (Inherited from Dimension.)
 | Dimcen | (Inherited from Dimension.)
 | Dimclrd | (Inherited from Dimension.)
 | Dimclre | (Inherited from Dimension.)
 | Dimclrt | (Inherited from Dimension.)
 | Dimdec | (Inherited from Dimension.)
 | Dimdle | (Inherited from Dimension.)
 | Dimdli | (Inherited from Dimension.)
 | Dimdsep | (Inherited from Dimension.)
 | DimensionStyle | (Inherited from Dimension.)
 | DimensionStyleName | (Inherited from Dimension.)
 | DimensionText | (Inherited from Dimension.)
 | Dimexe | (Inherited from Dimension.)
 | Dimexo | (Inherited from Dimension.)
 | Dimfrac | (Inherited from Dimension.)
 | Dimfxlen | (Inherited from Dimension.)
 | DimfxlenOn | (Inherited from Dimension.)
 | Dimgap | (Inherited from Dimension.)
 | Dimjogang | (Inherited from Dimension.)
 | Dimjust | (Inherited from Dimension.)
 | Dimldrblk | (Inherited from Dimension.)
 | Dimldrblks | (Inherited from Dimension.)
 | Dimlfac | (Inherited from Dimension.)
 | Dimlim | (Inherited from Dimension.)
 | Dimltex1 | (Inherited from Dimension.)
 | Dimltex2 | (Inherited from Dimension.)
 | Dimltype | (Inherited from Dimension.)
 | Dimlunit | (Inherited from Dimension.)
 | Dimlwd | (Inherited from Dimension.)
 | Dimlwe | (Inherited from Dimension.)
 | Dimpost | (Inherited from Dimension.)
 | Dimrnd | (Inherited from Dimension.)
 | Dimsah | (Inherited from Dimension.)
 | Dimscale | (Inherited from Dimension.)
 | Dimsd1 | (Inherited from Dimension.)
 | Dimsd2 | (Inherited from Dimension.)
 | Dimse1 | (Inherited from Dimension.)
 | Dimse2 | (Inherited from Dimension.)
 | Dimsoxd | (Inherited from Dimension.)
 | DimstyleData | (Inherited from Dimension.)
 | Dimtad | (Inherited from Dimension.)
 | Dimtdec | (Inherited from Dimension.)
 | Dimtfac | (Inherited from Dimension.)
 | Dimtfill | (Inherited from Dimension.)
 | Dimtfillclr | (Inherited from Dimension.)
 | Dimtih | (Inherited from Dimension.)
 | Dimtix | (Inherited from Dimension.)
 | Dimtm | (Inherited from Dimension.)
 | Dimtmove | (Inherited from Dimension.)
 | Dimtofl | (Inherited from Dimension.)
 | Dimtoh | (Inherited from Dimension.)
 | Dimtol | (Inherited from Dimension.)
 | Dimtolj | (Inherited from Dimension.)
 | Dimtp | (Inherited from Dimension.)
 | Dimtsz | (Inherited from Dimension.)
 | Dimtvp | (Inherited from Dimension.)
 | Dimtxsty | (Inherited from Dimension.)
 | Dimtxt | (Inherited from Dimension.)
 | Dimtzin | (Inherited from Dimension.)
 | Dimupt | (Inherited from Dimension.)
 | Dimzin | (Inherited from Dimension.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicDimension | (Inherited from Dimension.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation | (Inherited from Dimension.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldFromMText(MText) | (Inherited from Dimension.)
 | FieldToMText(MText) | (Inherited from Dimension.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FormatMeasurement(Double, String) | (Inherited from Dimension.)
 | GenerateLayout()()()() | (Inherited from Dimension.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetDimstyleData()()()() | (Inherited from Dimension.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasLeader |
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalRotation | (Inherited from Dimension.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPartial |
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Leader1Point |
 | Leader2Point |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | Measurement | (Inherited from Dimension.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal | (Inherited from Dimension.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Prefix | (Inherited from Dimension.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeDimensionBlock(Boolean) | (Inherited from Dimension.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveTextField()()()() | (Inherited from Dimension.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) | (Inherited from Dimension.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | Suffix | (Inherited from Dimension.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressAngularLeadingZeros | (Inherited from Dimension.)
 | SuppressAngularTrailingZeros | (Inherited from Dimension.)
 | SuppressLeadingZeros | (Inherited from Dimension.)
 | SuppressTrailingZeros | (Inherited from Dimension.)
 | SuppressZeroFeet | (Inherited from Dimension.)
 | SuppressZeroInches | (Inherited from Dimension.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAttachment | (Inherited from Dimension.)
 | TextLineSpacingFactor | (Inherited from Dimension.)
 | TextLineSpacingStyle | (Inherited from Dimension.)
 | TextPosition | (Inherited from Dimension.)
 | TextRotation | (Inherited from Dimension.)
 | TextStyleId | (Inherited from Dimension.)
 | ToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | ToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | ToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | ToleranceSuppressZeroInches | (Inherited from Dimension.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UsingDefaultTextPosition | (Inherited from Dimension.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | XLine1Point |
 | XLine2Point |
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  |  | ArcDimension


ArcDimension Constructor

ArcDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »ArcDimension()()()()
Members
Icon | Member | Description
 | ArcDimension(Point3d, Point3d, Point3d, Point3d, String, ObjectId) |
 | ArcDimension(IntPtr, Boolean) |


ArcDimension Constructor (unmanagedObjPtr, autoDelete)

ArcDimension Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »ArcDimension(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal ArcDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
ArcDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


ArcDimension Constructor (centerPoint, xLine1Point, xLine2Point, arcPoint, dimensionText, dimensionStyle)

ArcDimension Constructor (centerPoint, xLine1Point, xLine2Point, arcPoint, dimensionText, dimensionStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »ArcDimension(Point3d, Point3d, Point3d, Point3d, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public ArcDimension(
    Point3d centerPoint,
    Point3d xLine1Point,
    Point3d xLine2Point,
    Point3d arcPoint,
    string dimensionText,
    ObjectId dimensionStyle
)
Public Sub New ( _
    centerPoint As Point3d, _
    xLine1Point As Point3d, _
    xLine2Point As Point3d, _
    arcPoint As Point3d, _
    dimensionText As String, _
    dimensionStyle As ObjectId _
)
public:
ArcDimension(
    Point3d centerPoint,
    Point3d xLine1Point,
    Point3d xLine2Point,
    Point3d arcPoint,
    String^ dimensionText,
    ObjectId dimensionStyle
)
Parameters
centerPoint(Point3d)
xLine1Point(Point3d)
xLine2Point(Point3d)
arcPoint(Point3d)
dimensionText(String)
dimensionStyle(ObjectId)


ArcEndParam Property

ArcEndParam Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »ArcEndParam
Declaration Syntax
C# Visual Basic Visual C++
public double ArcEndParam { get; set; }
Public Property ArcEndParam As Double
    Get
    Set
public:
property double ArcEndParam {
    double get ();
    void set (double value);
}


ArcPoint Property

ArcPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »ArcPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ArcPoint { get; set; }
Public Property ArcPoint As Point3d
    Get
    Set
public:
property Point3d ArcPoint {
    Point3d get ();
    void set (Point3d value);
}


ArcStartParam Property

ArcStartParam Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »ArcStartParam
Declaration Syntax
C# Visual Basic Visual C++
public double ArcStartParam { get; set; }
Public Property ArcStartParam As Double
    Get
    Set
public:
property double ArcStartParam {
    double get ();
    void set (double value);
}


ArcSymbolType Property

ArcSymbolType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »ArcSymbolType
Declaration Syntax
C# Visual Basic Visual C++
public int ArcSymbolType { get; set; }
Public Property ArcSymbolType As Integer
    Get
    Set
public:
property int ArcSymbolType {
    int get ();
    void set (int value);
}


CenterPoint Property

CenterPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »CenterPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d CenterPoint { get; set; }
Public Property CenterPoint As Point3d
    Get
    Set
public:
property Point3d CenterPoint {
    Point3d get ();
    void set (Point3d value);
}


HasLeader Property

HasLeader Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »HasLeader
Declaration Syntax
C# Visual Basic Visual C++
public bool HasLeader { get; set; }
Public Property HasLeader As Boolean
    Get
    Set
public:
property bool HasLeader {
    bool get ();
    void set (bool value);
}


IsPartial Property

IsPartial Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »IsPartial
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPartial { get; set; }
Public Property IsPartial As Boolean
    Get
    Set
public:
property bool IsPartial {
    bool get ();
    void set (bool value);
}


Leader1Point Property

Leader1Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »Leader1Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Leader1Point { get; set; }
Public Property Leader1Point As Point3d
    Get
    Set
public:
property Point3d Leader1Point {
    Point3d get ();
    void set (Point3d value);
}


Leader2Point Property

Leader2Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »Leader2Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Leader2Point { get; set; }
Public Property Leader2Point As Point3d
    Get
    Set
public:
property Point3d Leader2Point {
    Point3d get ();
    void set (Point3d value);
}


XLine1Point Property

XLine1Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »XLine1Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine1Point { get; set; }
Public Property XLine1Point As Point3d
    Get
    Set
public:
property Point3d XLine1Point {
    Point3d get ();
    void set (Point3d value);
}


XLine2Point Property

XLine2Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »XLine2Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine2Point { get; set; }
Public Property XLine2Point As Point3d
    Get
    Set
public:
property Point3d XLine2Point {
    Point3d get ();
    void set (Point3d value);
}


AssocFlags Enumeration

AssocFlags Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AssocFlags
Declaration Syntax
C# Visual Basic Visual C++
public enum AssocFlags
Public Enumeration AssocFlags
public enum class AssocFlags
Members
Member | Description
FourthPoint |
ThirdPoint |
SecondPoint |
FirstPoint |


AttachmentPoint Enumeration

AttachmentPoint Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttachmentPoint
Declaration Syntax
C# Visual Basic Visual C++
public enum AttachmentPoint
Public Enumeration AttachmentPoint
public enum class AttachmentPoint
Members
Member | Description
TopRight |
TopMid |
TopLeft |
TopFit |
TopCenter |
TopAlign |
MiddleRight |
MiddleMid |
MiddleLeft |
MiddleFit |
MiddleCenter |
MiddleAlign |
BottomRight |
BottomMid |
BottomLeft |
BottomFit |
BottomCenter |
BottomAlign |
BaseRight |
BaseMid |
BaseLeft |
BaseFit |
BaseCenter |
BaseAlign |


AttributeCollection Class

AttributeCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class AttributeCollection : ICollection,
    IEnumerable
Public NotInheritable Class AttributeCollection _
    Implements ICollection, IEnumerable
public ref class AttributeCollection sealed : ICollection,
    IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AppendAttribute(AttributeReference) |
 | ICollection..::..CopyTo(Array, Int32) |
 | CopyTo(array<ObjectId>[]()[][], Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
AttributeCollection


AppendAttribute Method (attributeToAddToBlockReference)

AppendAttribute Method (attributeToAddToBlockReference)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeCollection »AppendAttribute(AttributeReference)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AppendAttribute(
    AttributeReference attributeToAddToBlockReference
)
Public Function AppendAttribute ( _
    attributeToAddToBlockReference As AttributeReference _
) As ObjectId
public:
ObjectId AppendAttribute(
    AttributeReference^ attributeToAddToBlockReference
)
Parameters
attributeToAddToBlockReference(AttributeReference)


CopyTo Method

CopyTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeCollection »CopyTo()()()()
Members
Icon | Member | Description
 | ICollection..::..CopyTo(Array, Int32) |
 | CopyTo(array<ObjectId>[]()[][], Int32) |


CopyTo Method (a, index)

CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array a,
    int index
)
Private Sub CopyTo ( _
    a As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void CopyTo(
    Array^ a,
    int index
) sealed = ICollection::CopyTo
Parameters
a(Array)
index(Int32)


CopyTo Method (__unnamed000, index)

CopyTo Method (__unnamed000, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeCollection »CopyTo(array<ObjectId>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ObjectId[] __unnamed000,
    int index
)
Public Sub CopyTo ( _
    __unnamed000 As ObjectId(), _
    index As Integer _
)
public:
void CopyTo(
    array<ObjectId>^ __unnamed000,
    int index
)
Parameters
__unnamed000(array< ObjectId >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ObjectId
    Get
public:
property ObjectId default[int index] {
    ObjectId get (int index);
}
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


AttributeDefinition Class

AttributeDefinition Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbAttributeDefinition")]
public class AttributeDefinition : DBText
<WrapperAttribute("AcDbAttributeDefinition")> _
Public Class AttributeDefinition _
    Inherits DBText
[WrapperAttribute(L"AcDbAttributeDefinition")]
public ref class AttributeDefinition : public DBText
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributeDefinition(Point3d, String, String, String, ObjectId) |
 | AttributeDefinition()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AdjustAlignment(Database) | (Inherited from DBText.)
 | AlignmentPoint | (Inherited from DBText.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Constant |
 | ConvertFieldToText()()()() | (Inherited from DBText.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CorrectSpelling()()()() | (Inherited from DBText.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldLength |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | getTextWithFieldCodes()()()() | (Inherited from DBText.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height | (Inherited from DBText.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalMode | (Inherited from DBText.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Invisible |
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDefaultAlignment | (Inherited from DBText.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsMirroredInX | (Inherited from DBText.)
 | IsMirroredInY | (Inherited from DBText.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsMTextAttributeDefinition |
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Justify | (Inherited from DBText.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | LockPositionInBlock |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MTextAttributeDefinition |
 | Normal | (Inherited from DBText.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | Oblique | (Inherited from DBText.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position | (Inherited from DBText.)
 | Preset |
 | Prompt |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation | (Inherited from DBText.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Tag |
 | TextString | (Inherited from DBText.)
 | TextStyle | (Inherited from DBText.)
 | TextStyleId | (Inherited from DBText.)
 | TextStyleName | (Inherited from DBText.)
 | Thickness | (Inherited from DBText.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateMTextAttributeDefinition()()()() |
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | Verifiable |
 | VerticalMode | (Inherited from DBText.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WidthFactor | (Inherited from DBText.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | DBText
 |  |  |  |  |  |  |  | AttributeDefinition


AttributeDefinition Constructor

AttributeDefinition Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »AttributeDefinition()()()()
Members
Icon | Member | Description
 | AttributeDefinition(Point3d, String, String, String, ObjectId) |
 | AttributeDefinition()()()() |


AttributeDefinition Constructor

AttributeDefinition Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »AttributeDefinition()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AttributeDefinition()
Public Sub New
public:
AttributeDefinition()


AttributeDefinition Constructor (position, value, tag, prompt, style)

AttributeDefinition Constructor (position, value, tag, prompt, style)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »AttributeDefinition(Point3d, String, String, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public AttributeDefinition(
    Point3d position,
    string value,
    string tag,
    string prompt,
    ObjectId style
)
Public Sub New ( _
    position As Point3d, _
    value As String, _
    tag As String, _
    prompt As String, _
    style As ObjectId _
)
public:
AttributeDefinition(
    Point3d position,
    String^ value,
    String^ tag,
    String^ prompt,
    ObjectId style
)
Parameters
position(Point3d)
value(String)
tag(String)
prompt(String)
style(ObjectId)


Constant Property

Constant Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »Constant
Declaration Syntax
C# Visual Basic Visual C++
public bool Constant { get; set; }
Public Property Constant As Boolean
    Get
    Set
public:
property bool Constant {
    bool get ();
    void set (bool value);
}


FieldLength Property

FieldLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »FieldLength
Declaration Syntax
C# Visual Basic Visual C++
public int FieldLength { get; set; }
Public Property FieldLength As Integer
    Get
    Set
public:
property int FieldLength {
    int get ();
    void set (int value);
}


Invisible Property

Invisible Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »Invisible
Declaration Syntax
C# Visual Basic Visual C++
public bool Invisible { get; set; }
Public Property Invisible As Boolean
    Get
    Set
public:
property bool Invisible {
    bool get ();
    void set (bool value);
}


IsMTextAttributeDefinition Property

IsMTextAttributeDefinition Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »IsMTextAttributeDefinition
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMTextAttributeDefinition { get; set; }
Public Property IsMTextAttributeDefinition As Boolean
    Get
    Set
public:
property bool IsMTextAttributeDefinition {
    bool get ();
    void set (bool value);
}


LockPositionInBlock Property

LockPositionInBlock Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »LockPositionInBlock
Declaration Syntax
C# Visual Basic Visual C++
public bool LockPositionInBlock { get; set; }
Public Property LockPositionInBlock As Boolean
    Get
    Set
public:
property bool LockPositionInBlock {
    bool get ();
    void set (bool value);
}


MTextAttributeDefinition Property

MTextAttributeDefinition Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »MTextAttributeDefinition
Declaration Syntax
C# Visual Basic Visual C++
public MText MTextAttributeDefinition { get; set; }
Public Property MTextAttributeDefinition As MText
    Get
    Set
public:
property MText^ MTextAttributeDefinition {
    MText^ get ();
    void set (MText^ value);
}


Preset Property

Preset Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »Preset
Declaration Syntax
C# Visual Basic Visual C++
public bool Preset { get; set; }
Public Property Preset As Boolean
    Get
    Set
public:
property bool Preset {
    bool get ();
    void set (bool value);
}


Prompt Property

Prompt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »Prompt
Declaration Syntax
C# Visual Basic Visual C++
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}


Tag Property

Tag Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »Tag
Declaration Syntax
C# Visual Basic Visual C++
public string Tag { get; set; }
Public Property Tag As String
    Get
    Set
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}


UpdateMTextAttributeDefinition Method

UpdateMTextAttributeDefinition Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »UpdateMTextAttributeDefinition()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateMTextAttributeDefinition()
Public Sub UpdateMTextAttributeDefinition
public:
void UpdateMTextAttributeDefinition()


Verifiable Property

Verifiable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »Verifiable
Declaration Syntax
C# Visual Basic Visual C++
public bool Verifiable { get; set; }
Public Property Verifiable As Boolean
    Get
    Set
public:
property bool Verifiable {
    bool get ();
    void set (bool value);
}


AttributeReference Class

AttributeReference Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbAttribute")]
public class AttributeReference : DBText
<WrapperAttribute("AcDbAttribute")> _
Public Class AttributeReference _
    Inherits DBText
[WrapperAttribute(L"AcDbAttribute")]
public ref class AttributeReference : public DBText
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributeReference(Point3d, String, String, ObjectId) |
 | AttributeReference()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AdjustAlignment(Database) | (Inherited from DBText.)
 | AlignmentPoint | (Inherited from DBText.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertFieldToText()()()() | (Inherited from DBText.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CorrectSpelling()()()() | (Inherited from DBText.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldLength |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | getTextWithFieldCodes()()()() | (Inherited from DBText.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height | (Inherited from DBText.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalMode | (Inherited from DBText.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Invisible |
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsConstant |
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDefaultAlignment | (Inherited from DBText.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsMirroredInX | (Inherited from DBText.)
 | IsMirroredInY | (Inherited from DBText.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsMTextAttribute |
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsPreset |
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsVerifiable |
 | IsWriteEnabled | (Inherited from DBObject.)
 | Justify | (Inherited from DBText.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | LockPositionInBlock |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MTextAttribute |
 | Normal | (Inherited from DBText.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | Oblique | (Inherited from DBText.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position | (Inherited from DBText.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation | (Inherited from DBText.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributeFromBlock(AttributeDefinition, Matrix3d) |
 | SetAttributeFromBlock(Matrix3d) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Tag |
 | TextString | (Inherited from DBText.)
 | TextStyle | (Inherited from DBText.)
 | TextStyleId | (Inherited from DBText.)
 | TextStyleName | (Inherited from DBText.)
 | Thickness | (Inherited from DBText.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateMTextAttribute()()()() |
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VerticalMode | (Inherited from DBText.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WidthFactor | (Inherited from DBText.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | DBText
 |  |  |  |  |  |  |  | AttributeReference


AttributeReference Constructor

AttributeReference Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »AttributeReference()()()()
Members
Icon | Member | Description
 | AttributeReference(Point3d, String, String, ObjectId) |
 | AttributeReference()()()() |


AttributeReference Constructor

AttributeReference Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »AttributeReference()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AttributeReference()
Public Sub New
public:
AttributeReference()


AttributeReference Constructor (position, value, tag, style)

AttributeReference Constructor (position, value, tag, style)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »AttributeReference(Point3d, String, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public AttributeReference(
    Point3d position,
    string value,
    string tag,
    ObjectId style
)
Public Sub New ( _
    position As Point3d, _
    value As String, _
    tag As String, _
    style As ObjectId _
)
public:
AttributeReference(
    Point3d position,
    String^ value,
    String^ tag,
    ObjectId style
)
Parameters
position(Point3d)
value(String)
tag(String)
style(ObjectId)


FieldLength Property

FieldLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »FieldLength
Declaration Syntax
C# Visual Basic Visual C++
public int FieldLength { get; set; }
Public Property FieldLength As Integer
    Get
    Set
public:
property int FieldLength {
    int get ();
    void set (int value);
}


Invisible Property

Invisible Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »Invisible
Declaration Syntax
C# Visual Basic Visual C++
public bool Invisible { get; set; }
Public Property Invisible As Boolean
    Get
    Set
public:
property bool Invisible {
    bool get ();
    void set (bool value);
}


IsConstant Property

IsConstant Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »IsConstant
Declaration Syntax
C# Visual Basic Visual C++
public bool IsConstant { get; }
Public ReadOnly Property IsConstant As Boolean
    Get
public:
property bool IsConstant {
    bool get ();
}


IsMTextAttribute Property

IsMTextAttribute Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »IsMTextAttribute
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMTextAttribute { get; set; }
Public Property IsMTextAttribute As Boolean
    Get
    Set
public:
property bool IsMTextAttribute {
    bool get ();
    void set (bool value);
}


IsPreset Property

IsPreset Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »IsPreset
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPreset { get; }
Public ReadOnly Property IsPreset As Boolean
    Get
public:
property bool IsPreset {
    bool get ();
}


IsVerifiable Property

IsVerifiable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »IsVerifiable
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVerifiable { get; }
Public ReadOnly Property IsVerifiable As Boolean
    Get
public:
property bool IsVerifiable {
    bool get ();
}


LockPositionInBlock Property

LockPositionInBlock Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »LockPositionInBlock
Declaration Syntax
C# Visual Basic Visual C++
public bool LockPositionInBlock { get; set; }
Public Property LockPositionInBlock As Boolean
    Get
    Set
public:
property bool LockPositionInBlock {
    bool get ();
    void set (bool value);
}


MTextAttribute Property

MTextAttribute Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »MTextAttribute
Declaration Syntax
C# Visual Basic Visual C++
public MText MTextAttribute { get; set; }
Public Property MTextAttribute As MText
    Get
    Set
public:
property MText^ MTextAttribute {
    MText^ get ();
    void set (MText^ value);
}


SetAttributeFromBlock Method

SetAttributeFromBlock Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »SetAttributeFromBlock()()()()
Members
Icon | Member | Description
 | SetAttributeFromBlock(AttributeDefinition, Matrix3d) |
 | SetAttributeFromBlock(Matrix3d) |


SetAttributeFromBlock Method (definition, blockTransform)

SetAttributeFromBlock Method (definition, blockTransform)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »SetAttributeFromBlock(AttributeDefinition, Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAttributeFromBlock(
    AttributeDefinition definition,
    Matrix3d blockTransform
)
Public Sub SetAttributeFromBlock ( _
    definition As AttributeDefinition, _
    blockTransform As Matrix3d _
)
public:
void SetAttributeFromBlock(
    AttributeDefinition^ definition,
    Matrix3d blockTransform
)
Parameters
definition(AttributeDefinition)
blockTransform(Matrix3d)


SetAttributeFromBlock Method (blockTransform)

SetAttributeFromBlock Method (blockTransform)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »SetAttributeFromBlock(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAttributeFromBlock(
    Matrix3d blockTransform
)
Public Sub SetAttributeFromBlock ( _
    blockTransform As Matrix3d _
)
public:
void SetAttributeFromBlock(
    Matrix3d blockTransform
)
Parameters
blockTransform(Matrix3d)


Tag Property

Tag Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »Tag
Declaration Syntax
C# Visual Basic Visual C++
public string Tag { get; set; }
Public Property Tag As String
    Get
    Set
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}


UpdateMTextAttribute Method

UpdateMTextAttribute Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »UpdateMTextAttribute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateMTextAttribute()
Public Sub UpdateMTextAttribute
public:
void UpdateMTextAttribute()


AuditInfo Class

AuditInfo Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbAuditInfo")]
public class AuditInfo : DisposableWrapper
<WrapperAttribute("AcDbAuditInfo")> _
Public Class AuditInfo _
    Inherits DisposableWrapper
[WrapperAttribute(L"AcDbAuditInfo")]
public ref class AuditInfo : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AuditInfo()()()() |
 | AuditPass |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | ErrorsFixed(Int32) |
 | ErrorsFound(Int32) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FixErrors |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | IncNumEntities()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumEntities |
 | NumErrors |
 | NumFixes |
 | PrintError(String, String, String, String) |
 | PrintError(DBObject, String, String, String) |
 | PrintNumEntities(String) |
 | RequestRegen()()()() |
 | ResetNumEntities()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | AuditInfo


AuditInfo Constructor

AuditInfo Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »AuditInfo()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AuditInfo()
Public Sub New
public:
AuditInfo()


AuditPass Property

AuditPass Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »AuditPass
Declaration Syntax
C# Visual Basic Visual C++
public AuditPass AuditPass { get; }
Public ReadOnly Property AuditPass As AuditPass
    Get
public:
property AuditPass AuditPass {
    AuditPass get ();
}


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override sealed void DeleteUnmanagedObject()
Protected Overrides NotOverridable Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override sealed


ErrorsFixed Method (count)

ErrorsFixed Method (count)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »ErrorsFixed(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void ErrorsFixed(
    int count
)
Public Sub ErrorsFixed ( _
    count As Integer _
)
public:
void ErrorsFixed(
    int count
)
Parameters
count(Int32)


ErrorsFound Method (count)

ErrorsFound Method (count)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »ErrorsFound(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void ErrorsFound(
    int count
)
Public Sub ErrorsFound ( _
    count As Integer _
)
public:
void ErrorsFound(
    int count
)
Parameters
count(Int32)


FixErrors Property

FixErrors Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »FixErrors
Declaration Syntax
C# Visual Basic Visual C++
public bool FixErrors { get; }
Public ReadOnly Property FixErrors As Boolean
    Get
public:
property bool FixErrors {
    bool get ();
}


IncNumEntities Method

IncNumEntities Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »IncNumEntities()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void IncNumEntities()
Public Sub IncNumEntities
public:
void IncNumEntities()


NumEntities Property

NumEntities Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »NumEntities
Declaration Syntax
C# Visual Basic Visual C++
public int NumEntities { get; }
Public ReadOnly Property NumEntities As Integer
    Get
public:
property int NumEntities {
    int get ();
}


NumErrors Property

NumErrors Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »NumErrors
Declaration Syntax
C# Visual Basic Visual C++
public int NumErrors { get; }
Public ReadOnly Property NumErrors As Integer
    Get
public:
property int NumErrors {
    int get ();
}


NumFixes Property

NumFixes Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »NumFixes
Declaration Syntax
C# Visual Basic Visual C++
public int NumFixes { get; }
Public ReadOnly Property NumFixes As Integer
    Get
public:
property int NumFixes {
    int get ();
}


PrintError Method

PrintError Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »PrintError()()()()
Members
Icon | Member | Description
 | PrintError(String, String, String, String) |
 | PrintError(DBObject, String, String, String) |


PrintError Method (name, value, validation, defaultValue)

PrintError Method (name, value, validation, defaultValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »PrintError(String, String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void PrintError(
    string name,
    string value,
    string validation,
    string defaultValue
)
Public Overridable Sub PrintError ( _
    name As String, _
    value As String, _
    validation As String, _
    defaultValue As String _
)
public:
virtual void PrintError(
    String^ name,
    String^ value,
    String^ validation,
    String^ defaultValue
)
Parameters
name(String)
value(String)
validation(String)
defaultValue(String)


PrintError Method (value, value2, validation, defaultValue)

PrintError Method (value, value2, validation, defaultValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »PrintError(DBObject, String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void PrintError(
    DBObject value,
    string value2,
    string validation,
    string defaultValue
)
Public Overridable Sub PrintError ( _
    value As DBObject, _
    value2 As String, _
    validation As String, _
    defaultValue As String _
)
public:
virtual void PrintError(
    DBObject^ value,
    String^ value2,
    String^ validation,
    String^ defaultValue
)
Parameters
value(DBObject)
value2(String)
validation(String)
defaultValue(String)


PrintNumEntities Method (msg)

PrintNumEntities Method (msg)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »PrintNumEntities(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void PrintNumEntities(
    string msg
)
Public Overridable Sub PrintNumEntities ( _
    msg As String _
)
public:
virtual void PrintNumEntities(
    String^ msg
)
Parameters
msg(String)


RequestRegen Method

RequestRegen Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »RequestRegen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RequestRegen()
Public Sub RequestRegen
public:
void RequestRegen()


ResetNumEntities Method

ResetNumEntities Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »ResetNumEntities()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ResetNumEntities()
Public Sub ResetNumEntities
public:
void ResetNumEntities()


AuditPass Enumeration

AuditPass Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditPass
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbAuditInfo::AuditPass")]
public enum AuditPass
<WrapperAttribute("ZcDbAuditInfo::AuditPass")> _
Public Enumeration AuditPass
[WrapperAttribute(L"ZcDbAuditInfo::AuditPass")]
public enum class AuditPass
Members
Member | Description
Pass2 |
Pass1 |


Background Class

Background Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Background
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbBackground")]
public class Background : DBObject
<WrapperAttribute("AcDbBackground")> _
Public Class Background _
    Inherits DBObject
[WrapperAttribute(L"AcDbBackground")]
public ref class Background : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Background(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetBackgroundDictionaryId(Database, Boolean) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Background
 |  |  |  |  |  |  | GradientBackground
 |  |  |  |  |  |  | GroundPlaneBackground
 |  |  |  |  |  |  | SkyBackground
 |  |  |  |  |  |  | SolidBackground


Background Constructor (unmanagedPointer, autoDelete)

Background Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Background »Background(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Background(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Background(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetBackgroundDictionaryId Method (database, createIfNotPresent)

GetBackgroundDictionaryId Method (database, createIfNotPresent)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Background »GetBackgroundDictionaryId(Database, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetBackgroundDictionaryId(
    Database database,
    bool createIfNotPresent
)
Public Shared Function GetBackgroundDictionaryId ( _
    database As Database, _
    createIfNotPresent As Boolean _
) As ObjectId
public:
static ObjectId GetBackgroundDictionaryId(
    Database^ database,
    bool createIfNotPresent
)
Parameters
database(Database)
createIfNotPresent(Boolean)


BeginInsertEventArgs Class

BeginInsertEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginInsertEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class BeginInsertEventArgs : EventArgs
Public NotInheritable Class BeginInsertEventArgs _
    Inherits EventArgs
public ref class BeginInsertEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | From |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeginInsertEventArgs


From Property

From Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginInsertEventArgs »From
Declaration Syntax
C# Visual Basic Visual C++
public Database From { get; }
Public ReadOnly Property From As Database
    Get
public:
property Database^ From {
    Database^ get ();
}


BeginInsertEventHandler Delegate

BeginInsertEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginInsertEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginInsertEventHandler(
    Object sender,
    BeginInsertEventArgs e
)
Public Delegate Sub BeginInsertEventHandler ( _
    sender As Object, _
    e As BeginInsertEventArgs _
)
public delegate void BeginInsertEventHandler(
    Object^ sender,
    BeginInsertEventArgs^ e
)
Parameters
sender(Object)
e(BeginInsertEventArgs)


BeginWblockBlockEventArgs Class

BeginWblockBlockEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockBlockEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class BeginWblockBlockEventArgs : EventArgs
Public NotInheritable Class BeginWblockBlockEventArgs _
    Inherits EventArgs
public ref class BeginWblockBlockEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BlockId |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | From |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeginWblockBlockEventArgs


BlockId Property

BlockId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockBlockEventArgs »BlockId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockId { get; }
Public ReadOnly Property BlockId As ObjectId
    Get
public:
property ObjectId BlockId {
    ObjectId get ();
}


From Property

From Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockBlockEventArgs »From
Declaration Syntax
C# Visual Basic Visual C++
public Database From { get; }
Public ReadOnly Property From As Database
    Get
public:
property Database^ From {
    Database^ get ();
}


BeginWblockBlockEventHandler Delegate

BeginWblockBlockEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockBlockEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginWblockBlockEventHandler(
    Object sender,
    BeginWblockBlockEventArgs e
)
Public Delegate Sub BeginWblockBlockEventHandler ( _
    sender As Object, _
    e As BeginWblockBlockEventArgs _
)
public delegate void BeginWblockBlockEventHandler(
    Object^ sender,
    BeginWblockBlockEventArgs^ e
)
Parameters
sender(Object)
e(BeginWblockBlockEventArgs)


BeginWblockEntireDatabaseEventArgs Class

BeginWblockEntireDatabaseEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockEntireDatabaseEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class BeginWblockEntireDatabaseEventArgs : EventArgs
Public NotInheritable Class BeginWblockEntireDatabaseEventArgs _
    Inherits EventArgs
public ref class BeginWblockEntireDatabaseEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | From |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeginWblockEntireDatabaseEventArgs


From Property

From Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockEntireDatabaseEventArgs »From
Declaration Syntax
C# Visual Basic Visual C++
public Database From { get; }
Public ReadOnly Property From As Database
    Get
public:
property Database^ From {
    Database^ get ();
}


BeginWblockEntireDatabaseEventHandler Delegate

BeginWblockEntireDatabaseEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockEntireDatabaseEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginWblockEntireDatabaseEventHandler(
    Object sender,
    BeginWblockEntireDatabaseEventArgs e
)
Public Delegate Sub BeginWblockEntireDatabaseEventHandler ( _
    sender As Object, _
    e As BeginWblockEntireDatabaseEventArgs _
)
public delegate void BeginWblockEntireDatabaseEventHandler(
    Object^ sender,
    BeginWblockEntireDatabaseEventArgs^ e
)
Parameters
sender(Object)
e(BeginWblockEntireDatabaseEventArgs)


BeginWblockObjectsEventArgs Class

BeginWblockObjectsEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockObjectsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class BeginWblockObjectsEventArgs : EventArgs
Public NotInheritable Class BeginWblockObjectsEventArgs _
    Inherits EventArgs
public ref class BeginWblockObjectsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | From |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IdMapping |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeginWblockObjectsEventArgs


From Property

From Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockObjectsEventArgs »From
Declaration Syntax
C# Visual Basic Visual C++
public Database From { get; }
Public ReadOnly Property From As Database
    Get
public:
property Database^ From {
    Database^ get ();
}


IdMapping Property

IdMapping Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockObjectsEventArgs »IdMapping
Declaration Syntax
C# Visual Basic Visual C++
public IdMapping IdMapping { get; }
Public ReadOnly Property IdMapping As IdMapping
    Get
public:
property IdMapping^ IdMapping {
    IdMapping^ get ();
}


BeginWblockObjectsEventHandler Delegate

BeginWblockObjectsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockObjectsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginWblockObjectsEventHandler(
    Object sender,
    BeginWblockObjectsEventArgs e
)
Public Delegate Sub BeginWblockObjectsEventHandler ( _
    sender As Object, _
    e As BeginWblockObjectsEventArgs _
)
public delegate void BeginWblockObjectsEventHandler(
    Object^ sender,
    BeginWblockObjectsEventArgs^ e
)
Parameters
sender(Object)
e(BeginWblockObjectsEventArgs)


BeginWblockSelectedObjectsEventArgs Class

BeginWblockSelectedObjectsEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockSelectedObjectsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class BeginWblockSelectedObjectsEventArgs : EventArgs
Public NotInheritable Class BeginWblockSelectedObjectsEventArgs _
    Inherits EventArgs
public ref class BeginWblockSelectedObjectsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | From |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InsertionPoint |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeginWblockSelectedObjectsEventArgs


From Property

From Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockSelectedObjectsEventArgs »From
Declaration Syntax
C# Visual Basic Visual C++
public Database From { get; }
Public ReadOnly Property From As Database
    Get
public:
property Database^ From {
    Database^ get ();
}


InsertionPoint Property

InsertionPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockSelectedObjectsEventArgs »InsertionPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d InsertionPoint { get; }
Public ReadOnly Property InsertionPoint As Point3d
    Get
public:
property Point3d InsertionPoint {
    Point3d get ();
}


BeginWblockSelectedObjectsEventHandler Delegate

BeginWblockSelectedObjectsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BeginWblockSelectedObjectsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginWblockSelectedObjectsEventHandler(
    Object sender,
    BeginWblockSelectedObjectsEventArgs e
)
Public Delegate Sub BeginWblockSelectedObjectsEventHandler ( _
    sender As Object, _
    e As BeginWblockSelectedObjectsEventArgs _
)
public delegate void BeginWblockSelectedObjectsEventHandler(
    Object^ sender,
    BeginWblockSelectedObjectsEventArgs^ e
)
Parameters
sender(Object)
e(BeginWblockSelectedObjectsEventArgs)


BitmapDeviceFlags Enumeration

BitmapDeviceFlags Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BitmapDeviceFlags
Declaration Syntax
C# Visual Basic Visual C++
public enum BitmapDeviceFlags
Public Enumeration BitmapDeviceFlags
public enum class BitmapDeviceFlags
Members
Member | Description
ForThumbnail |
For2dExportRenderHLR |
For2dExportRender |
UseSoftwareHLR |


BlockBegin Class

BlockBegin Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbBlockBegin")]
public sealed class BlockBegin : Entity
<WrapperAttribute("AcDbBlockBegin")> _
Public NotInheritable Class BlockBegin _
    Inherits Entity
[WrapperAttribute(L"AcDbBlockBegin")]
public ref class BlockBegin sealed : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlockBegin()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | BlockBegin


BlockBegin Constructor

BlockBegin Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »BlockBegin()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BlockBegin()
Public Sub New
public:
BlockBegin()


BlockConnectionType Enumeration

BlockConnectionType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockConnectionType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::BlockConnectionType")]
public enum BlockConnectionType
<WrapperAttribute("ZcDbMLeaderStyle::BlockConnectionType")> _
Public Enumeration BlockConnectionType
[WrapperAttribute(L"ZcDbMLeaderStyle::BlockConnectionType")]
public enum class BlockConnectionType
Members
Member | Description
ConnectBase |
ConnectExtents |


BlockEnd Class

BlockEnd Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbBlockEnd")]
public sealed class BlockEnd : Entity
<WrapperAttribute("AcDbBlockEnd")> _
Public NotInheritable Class BlockEnd _
    Inherits Entity
[WrapperAttribute(L"AcDbBlockEnd")]
public ref class BlockEnd sealed : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlockEnd()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | BlockEnd


BlockEnd Constructor

BlockEnd Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »BlockEnd()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BlockEnd()
Public Sub New
public:
BlockEnd()


BlockInsertionPointsEventArgs Class

BlockInsertionPointsEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockInsertionPointsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class BlockInsertionPointsEventArgs
Public Class BlockInsertionPointsEventArgs
public ref class BlockInsertionPointsEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlockInsertionPointsEventArgs(BlockTableRecord, Point3dCollection, Vector3dCollection) |
 | AlignmentVectors |
 | BlockTableRecord |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InsertionPoints |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
BlockInsertionPointsEventArgs


BlockInsertionPointsEventArgs Constructor (blockTableRecord, points, alignmentVectors)

BlockInsertionPointsEventArgs Constructor (blockTableRecord, points, alignmentVectors)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockInsertionPointsEventArgs »BlockInsertionPointsEventArgs(BlockTableRecord, Point3dCollection, Vector3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public BlockInsertionPointsEventArgs(
    BlockTableRecord blockTableRecord,
    Point3dCollection points,
    Vector3dCollection alignmentVectors
)
Public Sub New ( _
    blockTableRecord As BlockTableRecord, _
    points As Point3dCollection, _
    alignmentVectors As Vector3dCollection _
)
public:
BlockInsertionPointsEventArgs(
    BlockTableRecord^ blockTableRecord,
    Point3dCollection^ points,
    Vector3dCollection^ alignmentVectors
)
Parameters
blockTableRecord(BlockTableRecord)
points(Point3dCollection)
alignmentVectors(Vector3dCollection)


AlignmentVectors Property

AlignmentVectors Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockInsertionPointsEventArgs »AlignmentVectors
Declaration Syntax
C# Visual Basic Visual C++
public Vector3dCollection AlignmentVectors { get; }
Public ReadOnly Property AlignmentVectors As Vector3dCollection
    Get
public:
property Vector3dCollection^ AlignmentVectors {
    Vector3dCollection^ get ();
}


BlockTableRecord Property

BlockTableRecord Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockInsertionPointsEventArgs »BlockTableRecord
Declaration Syntax
C# Visual Basic Visual C++
public BlockTableRecord BlockTableRecord { get; }
Public ReadOnly Property BlockTableRecord As BlockTableRecord
    Get
public:
property BlockTableRecord^ BlockTableRecord {
    BlockTableRecord^ get ();
}


InsertionPoints Property

InsertionPoints Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockInsertionPointsEventArgs »InsertionPoints
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection InsertionPoints { get; }
Public ReadOnly Property InsertionPoints As Point3dCollection
    Get
public:
property Point3dCollection^ InsertionPoints {
    Point3dCollection^ get ();
}


BlockInsertionPointsEventHandler Delegate

BlockInsertionPointsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockInsertionPointsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BlockInsertionPointsEventHandler(
    Object sender,
    BlockInsertionPointsEventArgs e
)
Public Delegate Sub BlockInsertionPointsEventHandler ( _
    sender As Object, _
    e As BlockInsertionPointsEventArgs _
)
public delegate void BlockInsertionPointsEventHandler(
    Object^ sender,
    BlockInsertionPointsEventArgs^ e
)
Parameters
sender(Object)
e(BlockInsertionPointsEventArgs)


BlockReference Class

BlockReference Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbBlockReference")]
public class BlockReference : Entity
<WrapperAttribute("AcDbBlockReference")> _
Public Class BlockReference _
    Inherits Entity
[WrapperAttribute(L"AcDbBlockReference")]
public ref class BlockReference : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlockReference(Point3d, ObjectId) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | AnonymousBlockTableRecord |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | AttributeCollection |
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BlockTableRecord |
 | BlockTransform |
 | BlockUnit |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToStaticBlock(String) |
 | ConvertToStaticBlock()()()() |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Overrides DBObject.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicBlockReferencePropertyCollection |
 | DynamicBlockTableRecord |
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExplodeToOwnerSpace()()()() |
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeometryExtentsBestFit(Matrix3d) |
 | GeometryExtentsBestFit()()()() |
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsDynamicBlock |
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Name |
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetBlock()()()() |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | ScaleFactors |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | TreatAsBlockRefForExplode |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnitFactor |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | BlockReference
 |  |  |  |  |  |  |  | MInsertBlock
 |  |  |  |  |  |  |  | Table


BlockReference Constructor (position, blockTableRecord)

BlockReference Constructor (position, blockTableRecord)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »BlockReference(Point3d, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public BlockReference(
    Point3d position,
    ObjectId blockTableRecord
)
Public Sub New ( _
    position As Point3d, _
    blockTableRecord As ObjectId _
)
public:
BlockReference(
    Point3d position,
    ObjectId blockTableRecord
)
Parameters
position(Point3d)
blockTableRecord(ObjectId)


AnonymousBlockTableRecord Property

AnonymousBlockTableRecord Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »AnonymousBlockTableRecord
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AnonymousBlockTableRecord { get; }
Public ReadOnly Property AnonymousBlockTableRecord As ObjectId
    Get
public:
property ObjectId AnonymousBlockTableRecord {
    ObjectId get ();
}


AttributeCollection Property

AttributeCollection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »AttributeCollection
Declaration Syntax
C# Visual Basic Visual C++
public AttributeCollection AttributeCollection { get; }
Public ReadOnly Property AttributeCollection As AttributeCollection
    Get
public:
property AttributeCollection^ AttributeCollection {
    AttributeCollection^ get ();
}


BlockTableRecord Property

BlockTableRecord Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »BlockTableRecord
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockTableRecord { get; set; }
Public Property BlockTableRecord As ObjectId
    Get
    Set
public:
property ObjectId BlockTableRecord {
    ObjectId get ();
    void set (ObjectId value);
}


BlockTransform Property

BlockTransform Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »BlockTransform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d BlockTransform { get; set; }
Public Property BlockTransform As Matrix3d
    Get
    Set
public:
property Matrix3d BlockTransform {
    Matrix3d get ();
    void set (Matrix3d value);
}


BlockUnit Property

BlockUnit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »BlockUnit
Declaration Syntax
C# Visual Basic Visual C++
public UnitsValue BlockUnit { get; set; }
Public Property BlockUnit As UnitsValue
    Get
    Set
public:
property UnitsValue BlockUnit {
    UnitsValue get ();
    void set (UnitsValue value);
}


ConvertToStaticBlock Method

ConvertToStaticBlock Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »ConvertToStaticBlock()()()()
Members
Icon | Member | Description
 | ConvertToStaticBlock(String) |
 | ConvertToStaticBlock()()()() |


ConvertToStaticBlock Method

ConvertToStaticBlock Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »ConvertToStaticBlock()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ConvertToStaticBlock()
Public Overridable Sub ConvertToStaticBlock
public:
virtual void ConvertToStaticBlock()


ConvertToStaticBlock Method (newBlockName)

ConvertToStaticBlock Method (newBlockName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »ConvertToStaticBlock(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ConvertToStaticBlock(
    string newBlockName
)
Public Overridable Sub ConvertToStaticBlock ( _
    newBlockName As String _
)
public:
virtual void ConvertToStaticBlock(
    String^ newBlockName
)
Parameters
newBlockName(String)


Dispose Method ()

Dispose Method ()
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »Dispose(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
[HandleProcessCorruptedStateExceptionsAttribute]
protected override void Dispose(
    bool
)
<HandleProcessCorruptedStateExceptionsAttribute> _
Protected Overrides Sub Dispose ( _
     As Boolean _
)
[HandleProcessCorruptedStateExceptionsAttribute]
protected:
virtual void Dispose(
    bool
) override
Parameters
(Boolean)


DynamicBlockReferencePropertyCollection Property

DynamicBlockReferencePropertyCollection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »DynamicBlockReferencePropertyCollection
Declaration Syntax
C# Visual Basic Visual C++
public DynamicBlockReferencePropertyCollection DynamicBlockReferencePropertyCollection { get; }
Public ReadOnly Property DynamicBlockReferencePropertyCollection As DynamicBlockReferencePropertyCollection
    Get
public:
property DynamicBlockReferencePropertyCollection^ DynamicBlockReferencePropertyCollection {
    DynamicBlockReferencePropertyCollection^ get ();
}


DynamicBlockTableRecord Property

DynamicBlockTableRecord Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »DynamicBlockTableRecord
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId DynamicBlockTableRecord { get; }
Public ReadOnly Property DynamicBlockTableRecord As ObjectId
    Get
public:
property ObjectId DynamicBlockTableRecord {
    ObjectId get ();
}


ExplodeToOwnerSpace Method

ExplodeToOwnerSpace Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »ExplodeToOwnerSpace()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ExplodeToOwnerSpace()
Public Overridable Sub ExplodeToOwnerSpace
public:
virtual void ExplodeToOwnerSpace()


GeometryExtentsBestFit Method

GeometryExtentsBestFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »GeometryExtentsBestFit()()()()
Members
Icon | Member | Description
 | GeometryExtentsBestFit(Matrix3d) |
 | GeometryExtentsBestFit()()()() |


GeometryExtentsBestFit Method

GeometryExtentsBestFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »GeometryExtentsBestFit()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Extents3d GeometryExtentsBestFit()
Public Function GeometryExtentsBestFit As Extents3d
public:
Extents3d GeometryExtentsBestFit()


GeometryExtentsBestFit Method (parentTransform)

GeometryExtentsBestFit Method (parentTransform)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »GeometryExtentsBestFit(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public Extents3d GeometryExtentsBestFit(
    Matrix3d parentTransform
)
Public Function GeometryExtentsBestFit ( _
    parentTransform As Matrix3d _
) As Extents3d
public:
Extents3d GeometryExtentsBestFit(
    Matrix3d parentTransform
)
Parameters
parentTransform(Matrix3d)


IsDynamicBlock Property

IsDynamicBlock Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »IsDynamicBlock
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDynamicBlock { get; }
Public ReadOnly Property IsDynamicBlock As Boolean
    Get
public:
property bool IsDynamicBlock {
    bool get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »Position
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Position { get; set; }
Public Property Position As Point3d
    Get
    Set
public:
property Point3d Position {
    Point3d get ();
    void set (Point3d value);
}


ResetBlock Method

ResetBlock Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »ResetBlock()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ResetBlock()
Public Sub ResetBlock
public:
void ResetBlock()


Rotation Property

Rotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »Rotation
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Angle)]
public double Rotation { get; set; }
<UnitTypeAttribute(UnitType.Angle)> _
Public Property Rotation As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Angle)]
public:
property double Rotation {
    double get ();
    void set (double value);
}


ScaleFactors Property

ScaleFactors Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »ScaleFactors
Declaration Syntax
C# Visual Basic Visual C++
public Scale3d ScaleFactors { get; set; }
Public Property ScaleFactors As Scale3d
    Get
    Set
public:
property Scale3d ScaleFactors {
    Scale3d get ();
    void set (Scale3d value);
}


TreatAsBlockRefForExplode Property

TreatAsBlockRefForExplode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »TreatAsBlockRefForExplode
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TreatAsBlockRefForExplode { get; }
Public Overridable ReadOnly Property TreatAsBlockRefForExplode As Boolean
    Get
public:
virtual property bool TreatAsBlockRefForExplode {
    bool get ();
}


UnitFactor Property

UnitFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »UnitFactor
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double UnitFactor { get; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public ReadOnly Property UnitFactor As Double
    Get
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double UnitFactor {
    double get ();
}


BlockScaling Enumeration

BlockScaling Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockScaling
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbBlockTableRecord::BlockScaling")]
public enum BlockScaling
<WrapperAttribute("ZcDbBlockTableRecord::BlockScaling")> _
Public Enumeration BlockScaling
[WrapperAttribute(L"ZcDbBlockTableRecord::BlockScaling")]
public enum class BlockScaling
Members
Member | Description
Uniform |
Any |


BlockTable Class

BlockTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbBlockTable")]
public class BlockTable : SymbolTable, IEnumerable
<WrapperAttribute("AcDbBlockTable")> _
Public Class BlockTable _
    Inherits SymbolTable _
    Implements IEnumerable
[WrapperAttribute(L"AcDbBlockTable")]
public ref class BlockTable : public SymbolTable,
    IEnumerable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) | (Inherited from SymbolTable.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() | (Inherited from SymbolTable.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) | (Inherited from SymbolTable.)
 | Has(ObjectId) | (Inherited from SymbolTable.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from SymbolTable.)
 | IncludingErased | (Inherited from SymbolTable.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from SymbolTable.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | BlockTable


BlockTableRecord Class

BlockTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbBlockTableRecord")]
public class BlockTableRecord : SymbolTableRecord,
    IEnumerable
<WrapperAttribute("AcDbBlockTableRecord")> _
Public Class BlockTableRecord _
    Inherits SymbolTableRecord _
    Implements IEnumerable
[WrapperAttribute(L"AcDbBlockTableRecord")]
public ref class BlockTableRecord : public SymbolTableRecord,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BlockTableRecord()()()() |
 | BlockTableRecord(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | AppendEntity(Entity) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | AssumeOwnershipOf(ObjectIdCollection) |
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockBeginId |
 | BlockEndId |
 | BlockInsertionPoints |
 | BlockScaling |
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Comments |
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | Copy()()()() |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DrawOrderTableId |
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explodable |
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAnonymousBlockIds()()()() |
 | GetBlockReferenceIds(Boolean, Boolean) |
 | GetEnumerator()()()() |
 | GetErasedBlockReferenceIds()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | GetXrefDatabase(Boolean) |
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasAttributeDefinitions |
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasPreviewIcon |
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() |
 | IncludingErased |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAnonymous |
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent | (Inherited from SymbolTableRecord.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsDynamicBlock |
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsFromExternalReference |
 | IsFromOverlayReference |
 | IsLayout |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsResolved | (Inherited from SymbolTableRecord.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsUnloaded |
 | IsWriteEnabled | (Inherited from DBObject.)
 | LayoutId |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | ModelSpace |
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from SymbolTableRecord.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | Origin |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PaperSpace |
 | PathName |
 | PreviewIcon |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SkipDeleted |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Units |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateAnonymousBlocks()()()() |
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | XrefStatus |
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | BlockTableRecord


BlockTableRecord Constructor

BlockTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »BlockTableRecord()()()()
Members
Icon | Member | Description
 | BlockTableRecord()()()() |
 | BlockTableRecord(IntPtr, Boolean) |


BlockTableRecord Constructor

BlockTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »BlockTableRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BlockTableRecord()
Public Sub New
public:
BlockTableRecord()


BlockTableRecord Constructor (unmanagedPointer, autoDelete)

BlockTableRecord Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »BlockTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal BlockTableRecord(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
BlockTableRecord(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AppendEntity Method (entity)

AppendEntity Method (entity)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »AppendEntity(Entity)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AppendEntity(
    Entity entity
)
Public Function AppendEntity ( _
    entity As Entity _
) As ObjectId
public:
ObjectId AppendEntity(
    Entity^ entity
)
Parameters
entity(Entity)


AssumeOwnershipOf Method (entitiesToMove)

AssumeOwnershipOf Method (entitiesToMove)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »AssumeOwnershipOf(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AssumeOwnershipOf(
    ObjectIdCollection entitiesToMove
)
Public Sub AssumeOwnershipOf ( _
    entitiesToMove As ObjectIdCollection _
)
public:
void AssumeOwnershipOf(
    ObjectIdCollection^ entitiesToMove
)
Parameters
entitiesToMove(ObjectIdCollection)


BlockBeginId Property

BlockBeginId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »BlockBeginId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockBeginId { get; }
Public ReadOnly Property BlockBeginId As ObjectId
    Get
public:
property ObjectId BlockBeginId {
    ObjectId get ();
}


BlockEndId Property

BlockEndId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »BlockEndId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockEndId { get; }
Public ReadOnly Property BlockEndId As ObjectId
    Get
public:
property ObjectId BlockEndId {
    ObjectId get ();
}


BlockInsertionPoints Event

BlockInsertionPoints Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »BlockInsertionPoints
Declaration Syntax
C# Visual Basic Visual C++
public static event BlockInsertionPointsEventHandler BlockInsertionPoints
Public Shared Event BlockInsertionPoints As BlockInsertionPointsEventHandler
public:
static  event BlockInsertionPointsEventHandler^ BlockInsertionPoints {
    void add (BlockInsertionPointsEventHandler^ value);
    void remove (BlockInsertionPointsEventHandler^ value);
}


BlockScaling Property

BlockScaling Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »BlockScaling
Declaration Syntax
C# Visual Basic Visual C++
public BlockScaling BlockScaling { get; set; }
Public Property BlockScaling As BlockScaling
    Get
    Set
public:
property BlockScaling BlockScaling {
    BlockScaling get ();
    void set (BlockScaling value);
}


Comments Property

Comments Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »Comments
Declaration Syntax
C# Visual Basic Visual C++
public string Comments { get; set; }
Public Property Comments As String
    Get
    Set
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}


Copy Method

Copy Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »Copy()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal virtual BlockTableRecord Copy()
Protected Friend Overridable Function Copy As BlockTableRecord
protected public:
virtual BlockTableRecord^ Copy()


DrawOrderTableId Property

DrawOrderTableId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »DrawOrderTableId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId DrawOrderTableId { get; }
Public ReadOnly Property DrawOrderTableId As ObjectId
    Get
public:
property ObjectId DrawOrderTableId {
    ObjectId get ();
}


Explodable Property

Explodable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »Explodable
Declaration Syntax
C# Visual Basic Visual C++
public bool Explodable { get; set; }
Public Property Explodable As Boolean
    Get
    Set
public:
property bool Explodable {
    bool get ();
    void set (bool value);
}


GetAnonymousBlockIds Method

GetAnonymousBlockIds Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »GetAnonymousBlockIds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetAnonymousBlockIds()
Public Function GetAnonymousBlockIds As ObjectIdCollection
public:
ObjectIdCollection^ GetAnonymousBlockIds()


GetBlockReferenceIds Method (directOnly, forceValidity)

GetBlockReferenceIds Method (directOnly, forceValidity)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »GetBlockReferenceIds(Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetBlockReferenceIds(
    bool directOnly,
    bool forceValidity
)
Public Function GetBlockReferenceIds ( _
    directOnly As Boolean, _
    forceValidity As Boolean _
) As ObjectIdCollection
public:
ObjectIdCollection^ GetBlockReferenceIds(
    bool directOnly,
    bool forceValidity
)
Parameters
directOnly(Boolean)
forceValidity(Boolean)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual BlockTableRecordEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As BlockTableRecordEnumerator
public:
virtual BlockTableRecordEnumerator^ GetEnumerator()


GetErasedBlockReferenceIds Method

GetErasedBlockReferenceIds Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »GetErasedBlockReferenceIds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetErasedBlockReferenceIds()
Public Function GetErasedBlockReferenceIds As ObjectIdCollection
public:
ObjectIdCollection^ GetErasedBlockReferenceIds()


GetXrefDatabase Method (incrementUnresolved)

GetXrefDatabase Method (incrementUnresolved)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »GetXrefDatabase(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Database GetXrefDatabase(
    bool incrementUnresolved
)
Public Function GetXrefDatabase ( _
    incrementUnresolved As Boolean _
) As Database
public:
Database^ GetXrefDatabase(
    bool incrementUnresolved
)
Parameters
incrementUnresolved(Boolean)


HasAttributeDefinitions Property

HasAttributeDefinitions Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »HasAttributeDefinitions
Declaration Syntax
C# Visual Basic Visual C++
public bool HasAttributeDefinitions { get; }
Public ReadOnly Property HasAttributeDefinitions As Boolean
    Get
public:
property bool HasAttributeDefinitions {
    bool get ();
}


HasPreviewIcon Property

HasPreviewIcon Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »HasPreviewIcon
Declaration Syntax
C# Visual Basic Visual C++
public bool HasPreviewIcon { get; }
Public ReadOnly Property HasPreviewIcon As Boolean
    Get
public:
property bool HasPreviewIcon {
    bool get ();
}


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected virtual IEnumerator IEnumerable_GetEnumerator()
Protected Overridable Function IEnumerable_GetEnumerator As IEnumerator
protected:
virtual IEnumerator^ IEnumerable_GetEnumerator()


IncludingErased Property

IncludingErased Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »IncludingErased
Declaration Syntax
C# Visual Basic Visual C++
public BlockTableRecord IncludingErased { get; }
Public ReadOnly Property IncludingErased As BlockTableRecord
    Get
public:
property BlockTableRecord^ IncludingErased {
    BlockTableRecord^ get ();
}


IsAnonymous Property

IsAnonymous Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »IsAnonymous
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAnonymous { get; }
Public ReadOnly Property IsAnonymous As Boolean
    Get
public:
property bool IsAnonymous {
    bool get ();
}


IsDynamicBlock Property

IsDynamicBlock Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »IsDynamicBlock
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDynamicBlock { get; }
Public ReadOnly Property IsDynamicBlock As Boolean
    Get
public:
property bool IsDynamicBlock {
    bool get ();
}


IsFromExternalReference Property

IsFromExternalReference Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »IsFromExternalReference
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFromExternalReference { get; }
Public ReadOnly Property IsFromExternalReference As Boolean
    Get
public:
property bool IsFromExternalReference {
    bool get ();
}


IsFromOverlayReference Property

IsFromOverlayReference Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »IsFromOverlayReference
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFromOverlayReference { get; }
Public ReadOnly Property IsFromOverlayReference As Boolean
    Get
public:
property bool IsFromOverlayReference {
    bool get ();
}


IsLayout Property

IsLayout Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »IsLayout
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLayout { get; }
Public ReadOnly Property IsLayout As Boolean
    Get
public:
property bool IsLayout {
    bool get ();
}


IsUnloaded Property

IsUnloaded Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »IsUnloaded
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUnloaded { get; set; }
Public Property IsUnloaded As Boolean
    Get
    Set
public:
property bool IsUnloaded {
    bool get ();
    void set (bool value);
}


LayoutId Property

LayoutId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »LayoutId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LayoutId { get; set; }
Public Property LayoutId As ObjectId
    Get
    Set
public:
property ObjectId LayoutId {
    ObjectId get ();
    void set (ObjectId value);
}


ModelSpace Field

ModelSpace Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »ModelSpace
Declaration Syntax
C# Visual Basic Visual C++
public static readonly string ModelSpace
Public Shared ReadOnly ModelSpace As String
public:
static initonly String^ ModelSpace


Origin Property

Origin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »Origin
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Origin { get; set; }
Public Property Origin As Point3d
    Get
    Set
public:
property Point3d Origin {
    Point3d get ();
    void set (Point3d value);
}


PaperSpace Field

PaperSpace Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »PaperSpace
Declaration Syntax
C# Visual Basic Visual C++
public static readonly string PaperSpace
Public Shared ReadOnly PaperSpace As String
public:
static initonly String^ PaperSpace


PathName Property

PathName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »PathName
Declaration Syntax
C# Visual Basic Visual C++
public string PathName { get; set; }
Public Property PathName As String
    Get
    Set
public:
property String^ PathName {
    String^ get ();
    void set (String^ value);
}


PreviewIcon Property

PreviewIcon Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »PreviewIcon
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap PreviewIcon { get; set; }
Public Property PreviewIcon As Bitmap
    Get
    Set
public:
property Bitmap^ PreviewIcon {
    Bitmap^ get ();
    void set (Bitmap^ value);
}


SkipDeleted Property

SkipDeleted Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »SkipDeleted
Declaration Syntax
C# Visual Basic Visual C++
protected bool SkipDeleted { get; }
Protected ReadOnly Property SkipDeleted As Boolean
    Get
protected:
property bool SkipDeleted {
    bool get ();
}


Units Property

Units Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »Units
Declaration Syntax
C# Visual Basic Visual C++
public UnitsValue Units { get; set; }
Public Property Units As UnitsValue
    Get
    Set
public:
property UnitsValue Units {
    UnitsValue get ();
    void set (UnitsValue value);
}


UpdateAnonymousBlocks Method

UpdateAnonymousBlocks Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »UpdateAnonymousBlocks()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateAnonymousBlocks()
Public Sub UpdateAnonymousBlocks
public:
void UpdateAnonymousBlocks()


XrefStatus Property

XrefStatus Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »XrefStatus
Declaration Syntax
C# Visual Basic Visual C++
public XrefStatus XrefStatus { get; }
Public ReadOnly Property XrefStatus As XrefStatus
    Get
public:
property XrefStatus XrefStatus {
    XrefStatus get ();
}


BlockTableRecordEnumerator Class

BlockTableRecordEnumerator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecordEnumerator
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbBlockTableRecordIterator")]
public sealed class BlockTableRecordEnumerator : DisposableWrapper,
    IEnumerator
<WrapperAttribute("ZcDbBlockTableRecordIterator")> _
Public NotInheritable Class BlockTableRecordEnumerator _
    Inherits DisposableWrapper _
    Implements IEnumerator
[WrapperAttribute(L"ZcDbBlockTableRecordIterator")]
public ref class BlockTableRecordEnumerator sealed : public DisposableWrapper,
    IEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Current |
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerator_Current_get()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | BlockTableRecordEnumerator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecordEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Current { get; }
Public Overridable ReadOnly Property Current As ObjectId
    Get
public:
virtual property ObjectId Current {
    ObjectId get ();
}


IEnumerator_Current_get Method

IEnumerator_Current_get Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecordEnumerator »IEnumerator_Current_get()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected Object IEnumerator_Current_get()
Protected Function IEnumerator_Current_get As Object
protected:
virtual Object^ IEnumerator_Current_get() sealed


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecordEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecordEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


Body Class

Body Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbBody")]
public class Body : Entity
<WrapperAttribute("AcDbBody")> _
Public Class Body _
    Inherits Entity
[WrapperAttribute(L"AcDbBody")]
public ref class Body : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Body()()()() |
 | Body(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AcisIn(String) |
 | AcisOut(String, DBObjectCollection) |
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BodyPtr |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsNull |
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | NumChanges |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Body


Body Constructor

Body Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »Body()()()()
Members
Icon | Member | Description
 | Body()()()() |
 | Body(IntPtr, Boolean) |


Body Constructor

Body Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »Body()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Body()
Public Sub New
public:
Body()


Body Constructor (unmanagedObjPtr, autoDelete)

Body Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »Body(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Body(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Body(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AcisIn Method (fileName)

AcisIn Method (fileName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »AcisIn(String)
Declaration Syntax
C# Visual Basic Visual C++
public static DBObjectCollection AcisIn(
    string fileName
)
Public Shared Function AcisIn ( _
    fileName As String _
) As DBObjectCollection
public:
static DBObjectCollection^ AcisIn(
    String^ fileName
)
Parameters
fileName(String)


AcisOut Method (fileName, entitiesOutToFile)

AcisOut Method (fileName, entitiesOutToFile)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »AcisOut(String, DBObjectCollection)
Declaration Syntax
C# Visual Basic Visual C++
public static void AcisOut(
    string fileName,
    DBObjectCollection entitiesOutToFile
)
Public Shared Sub AcisOut ( _
    fileName As String, _
    entitiesOutToFile As DBObjectCollection _
)
public:
static void AcisOut(
    String^ fileName,
    DBObjectCollection^ entitiesOutToFile
)
Parameters
fileName(String)
entitiesOutToFile(DBObjectCollection)


BodyPtr Property

BodyPtr Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »BodyPtr
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtr BodyPtr { get; set; }
Public Overridable Property BodyPtr As IntPtr
    Get
    Set
public:
virtual property IntPtr BodyPtr {
    IntPtr get ();
    void set (IntPtr value);
}


IsNull Property

IsNull Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »IsNull
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsNull { get; }
Public Overridable ReadOnly Property IsNull As Boolean
    Get
public:
virtual property bool IsNull {
    bool get ();
}


NumChanges Property

NumChanges Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »NumChanges
Declaration Syntax
C# Visual Basic Visual C++
public virtual int NumChanges { get; }
Public Overridable ReadOnly Property NumChanges As Integer
    Get
public:
virtual property int NumChanges {
    int get ();
}


BooleanOperationType Enumeration

BooleanOperationType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BooleanOperationType
Declaration Syntax
C# Visual Basic Visual C++
public enum BooleanOperationType
Public Enumeration BooleanOperationType
public enum class BooleanOperationType
Members
Member | Description
BoolSubtract |
BoolIntersect |
BoolUnite |


BulgeVertex Class

BulgeVertex Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertex
Declaration Syntax
C# Visual Basic Visual C++
public sealed class BulgeVertex
Public NotInheritable Class BulgeVertex
public ref class BulgeVertex sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BulgeVertex(Point2d, Double) |
 | Bulge |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Vertex |
Inheritance Hierarchy
Object
BulgeVertex


BulgeVertex Constructor (point, bulge)

BulgeVertex Constructor (point, bulge)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertex »BulgeVertex(Point2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public BulgeVertex(
    Point2d point,
    double bulge
)
Public Sub New ( _
    point As Point2d, _
    bulge As Double _
)
public:
BulgeVertex(
    Point2d point,
    double bulge
)
Parameters
point(Point2d)
bulge(Double)


Bulge Property

Bulge Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertex »Bulge
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double Bulge { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property Bulge As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double Bulge {
    double get ();
    void set (double value);
}


Vertex Property

Vertex Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertex »Vertex
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Vertex { get; set; }
Public Property Vertex As Point2d
    Get
    Set
public:
property Point2d Vertex {
    Point2d get ();
    void set (Point2d value);
}


BulgeVertexCollection Class

BulgeVertexCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection
Declaration Syntax
C# Visual Basic Visual C++
public class BulgeVertexCollection : CollectionBase
Public Class BulgeVertexCollection _
    Inherits CollectionBase
public ref class BulgeVertexCollection : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BulgeVertexCollection()()()() |
 | Add(BulgeVertex) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(BulgeVertex) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<BulgeVertex>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IList..::..Item[([( Int32])]) |
 | IndexOf(BulgeVertex) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, BulgeVertex) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Overrides CollectionBase.OnValidate(Object).)
 | Remove(BulgeVertex) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | BulgeVertexCollection


BulgeVertexCollection Constructor

BulgeVertexCollection Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »BulgeVertexCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BulgeVertexCollection()
Public Sub New
public:
BulgeVertexCollection()


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »Add(BulgeVertex)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    BulgeVertex value
)
Public Function Add ( _
    value As BulgeVertex _
) As Integer
public:
int Add(
    BulgeVertex^ value
)
Parameters
value(BulgeVertex)


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »Contains(BulgeVertex)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    BulgeVertex value
)
Public Function Contains ( _
    value As BulgeVertex _
) As Boolean
public:
bool Contains(
    BulgeVertex^ value
)
Parameters
value(BulgeVertex)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »CopyTo(array<BulgeVertex>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    BulgeVertex[] array,
    int index
)
Public Sub CopyTo ( _
    array As BulgeVertex(), _
    index As Integer _
)
public:
void CopyTo(
    array<BulgeVertex^>^ array,
    int index
)
Parameters
array(array< BulgeVertex >[]()[][])
index(Int32)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »IndexOf(BulgeVertex)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    BulgeVertex value
)
Public Function IndexOf ( _
    value As BulgeVertex _
) As Integer
public:
int IndexOf(
    BulgeVertex^ value
)
Parameters
value(BulgeVertex)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »Insert(Int32, BulgeVertex)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    BulgeVertex value
)
Public Sub Insert ( _
    index As Integer, _
    value As BulgeVertex _
)
public:
void Insert(
    int index,
    BulgeVertex^ value
)
Parameters
index(Int32)
value(BulgeVertex)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public BulgeVertex this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As BulgeVertex
    Get
    Set
public:
property BulgeVertex^ default[int index] {
    BulgeVertex^ get (int index);
    void set (int index, BulgeVertex^ value);
}
Parameters
index(Int32)


OnValidate Method (value)

OnValidate Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »OnValidate(Object)
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnValidate(
    Object value
)
Protected Overrides Sub OnValidate ( _
    value As Object _
)
protected:
virtual void OnValidate(
    Object^ value
) override
Parameters
value(Object)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »Remove(BulgeVertex)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    BulgeVertex value
)
Public Sub Remove ( _
    value As BulgeVertex _
)
public:
void Remove(
    BulgeVertex^ value
)
Parameters
value(BulgeVertex)


Cell Class

Cell Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcCell")]
public class Cell : CellRange
<WrapperAttribute("AcCell")> _
Public Class Cell _
    Inherits CellRange
[WrapperAttribute(L"AcCell")]
public ref class Cell : public CellRange
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Cell(Table, Int32, Int32) |
 | Alignment | (Inherited from CellRange.)
 | AttachmentPoint |
 | BackgroundColor | (Inherited from CellRange.)
 | BlockTableRecordId |
 | Borders | (Inherited from CellRange.)
 | BottomRight | (Inherited from CellRange.)
 | BottomRightPlusOne | (Inherited from CellRange.)
 | BottomRow | (Inherited from CellRange.)
 | CanDeleteColumns | (Inherited from CellRange.)
 | CanDeleteRows | (Inherited from CellRange.)
 | CanInsertColumn | (Inherited from CellRange.)
 | CanInsertRow | (Inherited from CellRange.)
 | CellType |
 | ClearStyleOverrides()()()() | (Inherited from CellRange.)
 | Column |
 | ContentColor | (Inherited from CellRange.)
 | ContentLayout | (Inherited from CellRange.)
 | Contents |
 | ContentTypes |
 | DataFormat | (Inherited from CellRange.)
 | DataLink |
 | DataType | (Inherited from CellRange.)
 | DeleteContent()()()() | (Inherited from CellRange.)
 | Equals(Object) | (Inherited from CellRange.)
 | FieldId |
 | Finalize()()()() | (Inherited from Object.)
 | GetBlockAttributeValue(ObjectId) |
 | GetCustomData(String) | (Inherited from CellRange.)
 | GetDataLink()()()() | (Inherited from CellRange.)
 | GetDataLinkRange()()()() |
 | GetEnumerator()()()() | (Inherited from CellRange.)
 | GetExtents()()()() |
 | GetHashCode()()()() | (Inherited from CellRange.)
 | GetMergeRange()()()() |
 | GetStyleOverrides()()()() | (Inherited from CellRange.)
 | GetTextString(FormatOption) |
 | GetType()()()() | (Inherited from Object.)
 | GetValue(FormatOption) |
 | IEnumerableGetEnumerator()()()() | (Inherited from CellRange.)
 | IsBackgroundColorNone | (Inherited from CellRange.)
 | IsContentEditable | (Inherited from CellRange.)
 | IsEmpty | (Inherited from CellRange.)
 | IsFormatEditable | (Inherited from CellRange.)
 | IsLinked | (Inherited from CellRange.)
 | IsMergeAllEnabled | (Inherited from CellRange.)
 | IsMerged | (Inherited from CellRange.)
 | IsNull | (Inherited from CellRange.)
 | IsSingleCell | (Inherited from CellRange.)
 | Item[([( Int32, Int32])]) | (Inherited from CellRange.)
 | LeftColumn | (Inherited from CellRange.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Parent | (Inherited from CellRange.)
 | ParentTable | (Inherited from CellRange.)
 | RemoveDataLink()()()() |
 | ResetValue()()()() |
 | RightColumn | (Inherited from CellRange.)
 | Row |
 | SetBlockAttributeValue(ObjectId, String) |
 | SetCustomData(String, Object) | (Inherited from CellRange.)
 | SetDataLink(ObjectId, Boolean) | (Inherited from CellRange.)
 | SetValue(Object, ParseOption) |
 | State | (Inherited from CellRange.)
 | Style | (Inherited from CellRange.)
 | TextHeight | (Inherited from CellRange.)
 | TextString |
 | TextStyleId | (Inherited from CellRange.)
 | ToolTip |
 | TopLeft | (Inherited from CellRange.)
 | TopRow | (Inherited from CellRange.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateDataLink(UpdateDirection, UpdateOption) |
 | Value |
Inheritance Hierarchy
Object
 | CellRange
 |  | Cell


Cell Constructor (table, row, column)

Cell Constructor (table, row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »Cell(Table, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Cell(
    Table table,
    int row,
    int column
)
Public Sub New ( _
    table As Table, _
    row As Integer, _
    column As Integer _
)
public:
Cell(
    Table^ table,
    int row,
    int column
)
Parameters
table(Table)
row(Int32)
column(Int32)


AttachmentPoint Property

AttachmentPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »AttachmentPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d AttachmentPoint { get; }
Public ReadOnly Property AttachmentPoint As Point3d
    Get
public:
property Point3d AttachmentPoint {
    Point3d get ();
}


BlockTableRecordId Property

BlockTableRecordId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »BlockTableRecordId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockTableRecordId { get; set; }
Public Property BlockTableRecordId As ObjectId
    Get
    Set
public:
property ObjectId BlockTableRecordId {
    ObjectId get ();
    void set (ObjectId value);
}


CellType Property

CellType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »CellType
Declaration Syntax
C# Visual Basic Visual C++
public TableCellType CellType { get; }
Public ReadOnly Property CellType As TableCellType
    Get
public:
property TableCellType CellType {
    TableCellType get ();
}


Column Property

Column Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »Column
Declaration Syntax
C# Visual Basic Visual C++
public int Column { get; }
Public ReadOnly Property Column As Integer
    Get
public:
property int Column {
    int get ();
}


Contents Property

Contents Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »Contents
Declaration Syntax
C# Visual Basic Visual C++
public CellContentsCollection Contents { get; }
Public ReadOnly Property Contents As CellContentsCollection
    Get
public:
property CellContentsCollection^ Contents {
    CellContentsCollection^ get ();
}


ContentTypes Property

ContentTypes Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »ContentTypes
Declaration Syntax
C# Visual Basic Visual C++
public CellContentTypes ContentTypes { get; }
Public ReadOnly Property ContentTypes As CellContentTypes
    Get
public:
property CellContentTypes ContentTypes {
    CellContentTypes get ();
}


DataLink Property

DataLink Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »DataLink
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId DataLink { get; set; }
Public Property DataLink As ObjectId
    Get
    Set
public:
property ObjectId DataLink {
    ObjectId get ();
    void set (ObjectId value);
}


FieldId Property

FieldId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »FieldId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId FieldId { get; set; }
Public Property FieldId As ObjectId
    Get
    Set
public:
property ObjectId FieldId {
    ObjectId get ();
    void set (ObjectId value);
}


GetBlockAttributeValue Method (attDefId)

GetBlockAttributeValue Method (attDefId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »GetBlockAttributeValue(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public string GetBlockAttributeValue(
    ObjectId attDefId
)
Public Function GetBlockAttributeValue ( _
    attDefId As ObjectId _
) As String
public:
String^ GetBlockAttributeValue(
    ObjectId attDefId
)
Parameters
attDefId(ObjectId)


GetDataLinkRange Method

GetDataLinkRange Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »GetDataLinkRange()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CellRange GetDataLinkRange()
Public Function GetDataLinkRange As CellRange
public:
CellRange^ GetDataLinkRange()


GetExtents Method

GetExtents Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »GetExtents()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection GetExtents()
Public Function GetExtents As Point3dCollection
public:
Point3dCollection^ GetExtents()


GetMergeRange Method

GetMergeRange Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »GetMergeRange()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CellRange GetMergeRange()
Public Function GetMergeRange As CellRange
public:
CellRange^ GetMergeRange()


GetTextString Method (formatOption)

GetTextString Method (formatOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »GetTextString(FormatOption)
Declaration Syntax
C# Visual Basic Visual C++
public string GetTextString(
    FormatOption formatOption
)
Public Function GetTextString ( _
    formatOption As FormatOption _
) As String
public:
String^ GetTextString(
    FormatOption formatOption
)
Parameters
formatOption(FormatOption)


GetValue Method (formatOption)

GetValue Method (formatOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »GetValue(FormatOption)
Declaration Syntax
C# Visual Basic Visual C++
public Object GetValue(
    FormatOption formatOption
)
Public Function GetValue ( _
    formatOption As FormatOption _
) As Object
public:
Object^ GetValue(
    FormatOption formatOption
)
Parameters
formatOption(FormatOption)


RemoveDataLink Method

RemoveDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »RemoveDataLink()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveDataLink()
Public Sub RemoveDataLink
public:
void RemoveDataLink()


ResetValue Method

ResetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »ResetValue()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ResetValue()
Public Sub ResetValue
public:
void ResetValue()


Row Property

Row Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »Row
Declaration Syntax
C# Visual Basic Visual C++
public int Row { get; }
Public ReadOnly Property Row As Integer
    Get
public:
property int Row {
    int get ();
}


SetBlockAttributeValue Method (attDefId, value)

SetBlockAttributeValue Method (attDefId, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »SetBlockAttributeValue(ObjectId, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetBlockAttributeValue(
    ObjectId attDefId,
    string value
)
Public Sub SetBlockAttributeValue ( _
    attDefId As ObjectId, _
    value As String _
)
public:
void SetBlockAttributeValue(
    ObjectId attDefId,
    String^ value
)
Parameters
attDefId(ObjectId)
value(String)


SetValue Method (value, parseOption)

SetValue Method (value, parseOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »SetValue(Object, ParseOption)
Declaration Syntax
C# Visual Basic Visual C++
public void SetValue(
    Object value,
    ParseOption parseOption
)
Public Sub SetValue ( _
    value As Object, _
    parseOption As ParseOption _
)
public:
void SetValue(
    Object^ value,
    ParseOption parseOption
)
Parameters
value(Object)
parseOption(ParseOption)


TextString Property

TextString Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »TextString
Declaration Syntax
C# Visual Basic Visual C++
public string TextString { get; set; }
Public Property TextString As String
    Get
    Set
public:
property String^ TextString {
    String^ get ();
    void set (String^ value);
}


ToolTip Property

ToolTip Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »ToolTip
Declaration Syntax
C# Visual Basic Visual C++
public string ToolTip { get; set; }
Public Property ToolTip As String
    Get
    Set
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}


UpdateDataLink Method (dir, option)

UpdateDataLink Method (dir, option)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »UpdateDataLink(UpdateDirection, UpdateOption)
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateDataLink(
    UpdateDirection dir,
    UpdateOption option
)
Public Sub UpdateDataLink ( _
    dir As UpdateDirection, _
    option As UpdateOption _
)
public:
void UpdateDataLink(
    UpdateDirection dir,
    UpdateOption option
)
Parameters
dir(UpdateDirection)
option(UpdateOption)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Cell »Value
Declaration Syntax
C# Visual Basic Visual C++
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}


CellAlignment Enumeration

CellAlignment Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellAlignment
Declaration Syntax
C# Visual Basic Visual C++
public enum CellAlignment
Public Enumeration CellAlignment
public enum class CellAlignment
Members
Member | Description
BottomRight |
BottomLeft |
BottomCenter |
MiddleRight |
MiddleCenter |
MiddleLeft |
TopRight |
TopCenter |
TopLeft |


CellBorder Class

CellBorder Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorder
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CellBorder
Public NotInheritable Class CellBorder
public ref class CellBorder sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Color |
 | DoubleLineSpacing |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsVisible |
 | LineStyle |
 | Linetype |
 | LineWeight |
 | Margin |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Overrides |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CellBorder


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorder »Color
Declaration Syntax
C# Visual Basic Visual C++
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}


DoubleLineSpacing Property

DoubleLineSpacing Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorder »DoubleLineSpacing
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<double> DoubleLineSpacing { get; set; }
Public Property DoubleLineSpacing As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> DoubleLineSpacing {
    Nullable<double> get ();
    void set (Nullable<double> value);
}


IsVisible Property

IsVisible Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorder »IsVisible
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<bool> IsVisible { get; set; }
Public Property IsVisible As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsVisible {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}


LineStyle Property

LineStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorder »LineStyle
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<GridLineStyle> LineStyle { get; set; }
Public Property LineStyle As Nullable(Of GridLineStyle)
    Get
    Set
public:
property Nullable<GridLineStyle> LineStyle {
    Nullable<GridLineStyle> get ();
    void set (Nullable<GridLineStyle> value);
}


Linetype Property

Linetype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorder »Linetype
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<ObjectId> Linetype { get; set; }
Public Property Linetype As Nullable(Of ObjectId)
    Get
    Set
public:
property Nullable<ObjectId> Linetype {
    Nullable<ObjectId> get ();
    void set (Nullable<ObjectId> value);
}


LineWeight Property

LineWeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorder »LineWeight
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<LineWeight> LineWeight { get; set; }
Public Property LineWeight As Nullable(Of LineWeight)
    Get
    Set
public:
property Nullable<LineWeight> LineWeight {
    Nullable<LineWeight> get ();
    void set (Nullable<LineWeight> value);
}


Margin Property

Margin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorder »Margin
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<double> Margin { get; set; }
Public Property Margin As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> Margin {
    Nullable<double> get ();
    void set (Nullable<double> value);
}


Overrides Property

Overrides Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorder »Overrides
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<GridProperties> Overrides { get; set; }
Public Property Overrides As Nullable(Of GridProperties)
    Get
    Set
public:
property Nullable<GridProperties> Overrides {
    Nullable<GridProperties> get ();
    void set (Nullable<GridProperties> value);
}


CellBorders Class

CellBorders Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorders
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CellBorders
Public NotInheritable Class CellBorders
public ref class CellBorders sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Bottom |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Horizontal |
 | Left |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Right |
 | Top |
 | ToString()()()() | (Inherited from Object.)
 | Vertical |
Inheritance Hierarchy
Object
CellBorders


Bottom Property

Bottom Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorders »Bottom
Declaration Syntax
C# Visual Basic Visual C++
public CellBorder Bottom { get; }
Public ReadOnly Property Bottom As CellBorder
    Get
public:
property CellBorder^ Bottom {
    CellBorder^ get ();
}


Horizontal Property

Horizontal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorders »Horizontal
Declaration Syntax
C# Visual Basic Visual C++
public CellBorder Horizontal { get; }
Public ReadOnly Property Horizontal As CellBorder
    Get
public:
property CellBorder^ Horizontal {
    CellBorder^ get ();
}


Left Property

Left Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorders »Left
Declaration Syntax
C# Visual Basic Visual C++
public CellBorder Left { get; }
Public ReadOnly Property Left As CellBorder
    Get
public:
property CellBorder^ Left {
    CellBorder^ get ();
}


Right Property

Right Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorders »Right
Declaration Syntax
C# Visual Basic Visual C++
public CellBorder Right { get; }
Public ReadOnly Property Right As CellBorder
    Get
public:
property CellBorder^ Right {
    CellBorder^ get ();
}


Top Property

Top Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorders »Top
Declaration Syntax
C# Visual Basic Visual C++
public CellBorder Top { get; }
Public ReadOnly Property Top As CellBorder
    Get
public:
property CellBorder^ Top {
    CellBorder^ get ();
}


Vertical Property

Vertical Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellBorders »Vertical
Declaration Syntax
C# Visual Basic Visual C++
public CellBorder Vertical { get; }
Public ReadOnly Property Vertical As CellBorder
    Get
public:
property CellBorder^ Vertical {
    CellBorder^ get ();
}


CellClass Enumeration

CellClass Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellClass
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum CellClass
<FlagsAttribute> _
Public Enumeration CellClass
[FlagsAttribute]
public enum class CellClass
Members
Member | Description
Label |
None |
Data |


CellContent Class

CellContent Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent
Declaration Syntax
C# Visual Basic Visual C++
public class CellContent
Public Class CellContent
public ref class CellContent
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BlockTableRecordId |
 | ContentColor |
 | ContentTypes |
 | DataFormat |
 | DataType |
 | DeleteContent()()()() |
 | Equals(Object) | (Inherited from Object.)
 | FieldId |
 | Finalize()()()() | (Inherited from Object.)
 | Formula |
 | GetBlockAttributeValue(ObjectId) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetTextString(FormatOption) |
 | GetType()()()() | (Inherited from Object.)
 | GetValue(FormatOption) |
 | HasFormula |
 | IsAutoScale |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Overrides |
 | Rotation |
 | Scale |
 | SetBlockAttributeValue(ObjectId, String) |
 | SetValue(Object, ParseOption) |
 | TextHeight |
 | TextString |
 | TextStyleId |
 | ToString()()()() | (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
CellContent


BlockTableRecordId Property

BlockTableRecordId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »BlockTableRecordId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockTableRecordId { get; set; }
Public Property BlockTableRecordId As ObjectId
    Get
    Set
public:
property ObjectId BlockTableRecordId {
    ObjectId get ();
    void set (ObjectId value);
}


ContentColor Property

ContentColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »ContentColor
Declaration Syntax
C# Visual Basic Visual C++
public Color ContentColor { get; set; }
Public Property ContentColor As Color
    Get
    Set
public:
property Color^ ContentColor {
    Color^ get ();
    void set (Color^ value);
}


ContentTypes Property

ContentTypes Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »ContentTypes
Declaration Syntax
C# Visual Basic Visual C++
public CellContentTypes ContentTypes { get; }
Public ReadOnly Property ContentTypes As CellContentTypes
    Get
public:
property CellContentTypes ContentTypes {
    CellContentTypes get ();
}


DataFormat Property

DataFormat Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »DataFormat
Declaration Syntax
C# Visual Basic Visual C++
public string DataFormat { get; set; }
Public Property DataFormat As String
    Get
    Set
public:
property String^ DataFormat {
    String^ get ();
    void set (String^ value);
}


DataType Property

DataType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »DataType
Declaration Syntax
C# Visual Basic Visual C++
public DataTypeParameter DataType { get; set; }
Public Property DataType As DataTypeParameter
    Get
    Set
public:
property DataTypeParameter DataType {
    DataTypeParameter get ();
    void set (DataTypeParameter value);
}


DeleteContent Method

DeleteContent Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »DeleteContent()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteContent()
Public Sub DeleteContent
public:
void DeleteContent()


FieldId Property

FieldId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »FieldId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId FieldId { get; set; }
Public Property FieldId As ObjectId
    Get
    Set
public:
property ObjectId FieldId {
    ObjectId get ();
    void set (ObjectId value);
}


Formula Property

Formula Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »Formula
Declaration Syntax
C# Visual Basic Visual C++
public string Formula { get; set; }
Public Property Formula As String
    Get
    Set
public:
property String^ Formula {
    String^ get ();
    void set (String^ value);
}


GetBlockAttributeValue Method (attDefId)

GetBlockAttributeValue Method (attDefId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »GetBlockAttributeValue(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public string GetBlockAttributeValue(
    ObjectId attDefId
)
Public Function GetBlockAttributeValue ( _
    attDefId As ObjectId _
) As String
public:
String^ GetBlockAttributeValue(
    ObjectId attDefId
)
Parameters
attDefId(ObjectId)


GetTextString Method (formatOption)

GetTextString Method (formatOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »GetTextString(FormatOption)
Declaration Syntax
C# Visual Basic Visual C++
public string GetTextString(
    FormatOption formatOption
)
Public Function GetTextString ( _
    formatOption As FormatOption _
) As String
public:
String^ GetTextString(
    FormatOption formatOption
)
Parameters
formatOption(FormatOption)


GetValue Method (formatOption)

GetValue Method (formatOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »GetValue(FormatOption)
Declaration Syntax
C# Visual Basic Visual C++
public Object GetValue(
    FormatOption formatOption
)
Public Function GetValue ( _
    formatOption As FormatOption _
) As Object
public:
Object^ GetValue(
    FormatOption formatOption
)
Parameters
formatOption(FormatOption)


HasFormula Property

HasFormula Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »HasFormula
Declaration Syntax
C# Visual Basic Visual C++
public bool HasFormula { get; }
Public ReadOnly Property HasFormula As Boolean
    Get
public:
property bool HasFormula {
    bool get ();
}


IsAutoScale Property

IsAutoScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »IsAutoScale
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAutoScale { get; set; }
Public Property IsAutoScale As Boolean
    Get
    Set
public:
property bool IsAutoScale {
    bool get ();
    void set (bool value);
}


Overrides Property

Overrides Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »Overrides
Declaration Syntax
C# Visual Basic Visual C++
public CellProperties Overrides { get; set; }
Public Property Overrides As CellProperties
    Get
    Set
public:
property CellProperties Overrides {
    CellProperties get ();
    void set (CellProperties value);
}


Rotation Property

Rotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »Rotation
Declaration Syntax
C# Visual Basic Visual C++
public double Rotation { get; set; }
Public Property Rotation As Double
    Get
    Set
public:
property double Rotation {
    double get ();
    void set (double value);
}


Scale Property

Scale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »Scale
Declaration Syntax
C# Visual Basic Visual C++
public double Scale { get; set; }
Public Property Scale As Double
    Get
    Set
public:
property double Scale {
    double get ();
    void set (double value);
}


SetBlockAttributeValue Method (attDefId, value)

SetBlockAttributeValue Method (attDefId, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »SetBlockAttributeValue(ObjectId, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetBlockAttributeValue(
    ObjectId attDefId,
    string value
)
Public Sub SetBlockAttributeValue ( _
    attDefId As ObjectId, _
    value As String _
)
public:
void SetBlockAttributeValue(
    ObjectId attDefId,
    String^ value
)
Parameters
attDefId(ObjectId)
value(String)


SetValue Method (value, parseOption)

SetValue Method (value, parseOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »SetValue(Object, ParseOption)
Declaration Syntax
C# Visual Basic Visual C++
public void SetValue(
    Object value,
    ParseOption parseOption
)
Public Sub SetValue ( _
    value As Object, _
    parseOption As ParseOption _
)
public:
void SetValue(
    Object^ value,
    ParseOption parseOption
)
Parameters
value(Object)
parseOption(ParseOption)


TextHeight Property

TextHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »TextHeight
Declaration Syntax
C# Visual Basic Visual C++
public double TextHeight { get; set; }
Public Property TextHeight As Double
    Get
    Set
public:
property double TextHeight {
    double get ();
    void set (double value);
}


TextString Property

TextString Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »TextString
Declaration Syntax
C# Visual Basic Visual C++
public string TextString { get; set; }
Public Property TextString As String
    Get
    Set
public:
property String^ TextString {
    String^ get ();
    void set (String^ value);
}


TextStyleId Property

TextStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »TextStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId TextStyleId { get; set; }
Public Property TextStyleId As ObjectId
    Get
    Set
public:
property ObjectId TextStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContent »Value
Declaration Syntax
C# Visual Basic Visual C++
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}


CellContentLayout Enumeration

CellContentLayout Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentLayout
Declaration Syntax
C# Visual Basic Visual C++
public enum CellContentLayout
Public Enumeration CellContentLayout
public enum class CellContentLayout
Members
Member | Description
StackedVertical |
StackedHorizontal |
Flow |


CellContentsCollection Class

CellContentsCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentsCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CellContentsCollection : IEnumerable<CellContent>
Public NotInheritable Class CellContentsCollection _
    Implements IEnumerable(Of CellContent)
public ref class CellContentsCollection sealed : IEnumerable<CellContent^>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add()()()() |
 | Clear()()()() |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerableGetEnumerator()()()() |
 | InsertAt(Int32) |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Move(Int32, Int32) |
 | RemoveAt(Int32) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CellContentsCollection


Add Method

Add Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentsCollection »Add()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Add()
Public Sub Add
public:
void Add()


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentsCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentsCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentsCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<CellContent> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of CellContent)
public:
virtual IEnumerator<CellContent^>^ GetEnumerator() sealed


IEnumerableGetEnumerator Method

IEnumerableGetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentsCollection »IEnumerableGetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
internal IEnumerator IEnumerableGetEnumerator()
Friend Function IEnumerableGetEnumerator As IEnumerator
internal:
virtual IEnumerator^ IEnumerableGetEnumerator() sealed


InsertAt Method (index)

InsertAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentsCollection »InsertAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertAt(
    int index
)
Public Sub InsertAt ( _
    index As Integer _
)
public:
void InsertAt(
    int index
)
Parameters
index(Int32)


Item Property (val)

Item Property (val)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentsCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CellContent this[
    int val
] { get; }
Public ReadOnly Default Property Item ( _
    val As Integer _
) As CellContent
    Get
public:
property CellContent^ default[int val] {
    CellContent^ get (int val);
}
Parameters
val(Int32)


Move Method (fromIndex, toIndex)

Move Method (fromIndex, toIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentsCollection »Move(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Move(
    int fromIndex,
    int toIndex
)
Public Sub Move ( _
    fromIndex As Integer, _
    toIndex As Integer _
)
public:
void Move(
    int fromIndex,
    int toIndex
)
Parameters
fromIndex(Int32)
toIndex(Int32)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentsCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
void RemoveAt(
    int index
)
Parameters
index(Int32)


CellContentTypes Enumeration

CellContentTypes Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellContentTypes
Declaration Syntax
C# Visual Basic Visual C++
public enum CellContentTypes
Public Enumeration CellContentTypes
public enum class CellContentTypes
Members
Member | Description
Value |
Block |
Field |
Unknown |


CellEdgeMasks Enumeration

CellEdgeMasks Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellEdgeMasks
Declaration Syntax
C# Visual Basic Visual C++
public enum CellEdgeMasks
Public Enumeration CellEdgeMasks
public enum class CellEdgeMasks
Members
Member | Description
LeftMask |
BottomMask |
RightMask |
TopMask |


CellMargins Enumeration

CellMargins Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellMargins
Declaration Syntax
C# Visual Basic Visual C++
public enum CellMargins
Public Enumeration CellMargins
public enum class CellMargins
Members
Member | Description
Right |
Bottom |
Left |
Top |


CellOption Enumeration

CellOption Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellOption
Declaration Syntax
C# Visual Basic Visual C++
public enum CellOption
Public Enumeration CellOption
public enum class CellOption
Members
Member | Description
InheritCellFormat |
None |


CellProperties Enumeration

CellProperties Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellProperties
Declaration Syntax
C# Visual Basic Visual C++
public enum CellProperties
Public Enumeration CellProperties
public enum class CellProperties
Members
Member | Description
MarginVertSpacing |
MarginHorzSpacing |
FlowDirBtoT |
MergeAll |
ContentLayout |
MarginBottom |
MarginRight |
MarginTop |
MarginLeft |
BackgroundColor |
AutoScale |
TextHeight |
TextStyle |
ContentColor |
Scale |
Rotation |
DataFormat |
DataType |
Invalid |
Alignment |


CellRange Class

CellRange Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcCellRange")]
public class CellRange : ISubObject, IEnumerable
<WrapperAttribute("AcCellRange")> _
Public Class CellRange _
    Implements ISubObject, IEnumerable
[WrapperAttribute(L"AcCellRange")]
public ref class CellRange : ISubObject,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CellRange(Table, Int32, Int32, Int32, Int32) |
 | Alignment |
 | BackgroundColor |
 | Borders |
 | BottomRight |
 | BottomRightPlusOne |
 | BottomRow |
 | CanDeleteColumns |
 | CanDeleteRows |
 | CanInsertColumn |
 | CanInsertRow |
 | ClearStyleOverrides()()()() |
 | ContentColor |
 | ContentLayout |
 | Create(Table, Int32, Int32, Int32, Int32) |
 | DataFormat |
 | DataType |
 | DeleteContent()()()() |
 | Equality(CellRange, CellRange) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetCustomData(String) |
 | GetDataLink()()()() |
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Overrides Object.GetHashCode()()()().)
 | GetStyleOverrides()()()() |
 | GetType()()()() | (Inherited from Object.)
 | IEnumerableGetEnumerator()()()() |
 | Inequality(CellRange, CellRange) |
 | IsBackgroundColorNone |
 | IsContentEditable |
 | IsEmpty |
 | IsFormatEditable |
 | IsLinked |
 | IsMergeAllEnabled |
 | IsMerged |
 | IsNull |
 | IsSingleCell |
 | Item[([( Int32, Int32])]) |
 | LeftColumn |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Parent |
 | ParentTable |
 | RightColumn |
 | SetCustomData(String, Object) |
 | SetDataLink(ObjectId, Boolean) |
 | State |
 | Style |
 | TextHeight |
 | TextStyleId |
 | TopLeft |
 | TopRow |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CellRange
 |  | Cell
 |  | Column
 |  | Row


CellRange Constructor (table, topRow, leftColumn, bottomRow, rightColumn)

CellRange Constructor (table, topRow, leftColumn, bottomRow, rightColumn)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »CellRange(Table, Int32, Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
protected CellRange(
    Table table,
    int topRow,
    int leftColumn,
    int bottomRow,
    int rightColumn
)
Protected Sub New ( _
    table As Table, _
    topRow As Integer, _
    leftColumn As Integer, _
    bottomRow As Integer, _
    rightColumn As Integer _
)
protected:
CellRange(
    Table^ table,
    int topRow,
    int leftColumn,
    int bottomRow,
    int rightColumn
)
Parameters
table(Table)
topRow(Int32)
leftColumn(Int32)
bottomRow(Int32)
rightColumn(Int32)


Alignment Property

Alignment Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »Alignment
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<CellAlignment> Alignment { get; set; }
Public Property Alignment As Nullable(Of CellAlignment)
    Get
    Set
public:
property Nullable<CellAlignment> Alignment {
    Nullable<CellAlignment> get ();
    void set (Nullable<CellAlignment> value);
}


BackgroundColor Property

BackgroundColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »BackgroundColor
Declaration Syntax
C# Visual Basic Visual C++
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set
public:
property Color^ BackgroundColor {
    Color^ get ();
    void set (Color^ value);
}


Borders Property

Borders Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »Borders
Declaration Syntax
C# Visual Basic Visual C++
public CellBorders Borders { get; }
Public ReadOnly Property Borders As CellBorders
    Get
public:
property CellBorders^ Borders {
    CellBorders^ get ();
}


BottomRight Property

BottomRight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »BottomRight
Declaration Syntax
C# Visual Basic Visual C++
public Cell BottomRight { get; }
Public ReadOnly Property BottomRight As Cell
    Get
public:
property Cell^ BottomRight {
    Cell^ get ();
}


BottomRightPlusOne Property

BottomRightPlusOne Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »BottomRightPlusOne
Declaration Syntax
C# Visual Basic Visual C++
public Cell BottomRightPlusOne { get; }
Public ReadOnly Property BottomRightPlusOne As Cell
    Get
public:
property Cell^ BottomRightPlusOne {
    Cell^ get ();
}


BottomRow Property

BottomRow Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »BottomRow
Declaration Syntax
C# Visual Basic Visual C++
public int BottomRow { get; }
Public ReadOnly Property BottomRow As Integer
    Get
public:
property int BottomRow {
    int get ();
}


CanDeleteColumns Property

CanDeleteColumns Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »CanDeleteColumns
Declaration Syntax
C# Visual Basic Visual C++
public bool CanDeleteColumns { get; }
Public ReadOnly Property CanDeleteColumns As Boolean
    Get
public:
property bool CanDeleteColumns {
    bool get ();
}


CanDeleteRows Property

CanDeleteRows Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »CanDeleteRows
Declaration Syntax
C# Visual Basic Visual C++
public bool CanDeleteRows { get; }
Public ReadOnly Property CanDeleteRows As Boolean
    Get
public:
property bool CanDeleteRows {
    bool get ();
}


CanInsertColumn Property

CanInsertColumn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »CanInsertColumn
Declaration Syntax
C# Visual Basic Visual C++
public bool CanInsertColumn { get; }
Public ReadOnly Property CanInsertColumn As Boolean
    Get
public:
property bool CanInsertColumn {
    bool get ();
}


CanInsertRow Property

CanInsertRow Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »CanInsertRow
Declaration Syntax
C# Visual Basic Visual C++
public bool CanInsertRow { get; }
Public ReadOnly Property CanInsertRow As Boolean
    Get
public:
property bool CanInsertRow {
    bool get ();
}


ClearStyleOverrides Method

ClearStyleOverrides Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »ClearStyleOverrides()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ClearStyleOverrides()
Public Sub ClearStyleOverrides
public:
void ClearStyleOverrides()


ContentColor Property

ContentColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »ContentColor
Declaration Syntax
C# Visual Basic Visual C++
public Color ContentColor { get; set; }
Public Property ContentColor As Color
    Get
    Set
public:
property Color^ ContentColor {
    Color^ get ();
    void set (Color^ value);
}


ContentLayout Property

ContentLayout Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »ContentLayout
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<CellContentLayout> ContentLayout { get; set; }
Public Property ContentLayout As Nullable(Of CellContentLayout)
    Get
    Set
public:
property Nullable<CellContentLayout> ContentLayout {
    Nullable<CellContentLayout> get ();
    void set (Nullable<CellContentLayout> value);
}


Create Method (table, topRow, leftColumn, bottomRow, rightColumn)

Create Method (table, topRow, leftColumn, bottomRow, rightColumn)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »Create(Table, Int32, Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static CellRange Create(
    Table table,
    int topRow,
    int leftColumn,
    int bottomRow,
    int rightColumn
)
Public Shared Function Create ( _
    table As Table, _
    topRow As Integer, _
    leftColumn As Integer, _
    bottomRow As Integer, _
    rightColumn As Integer _
) As CellRange
public:
static CellRange^ Create(
    Table^ table,
    int topRow,
    int leftColumn,
    int bottomRow,
    int rightColumn
)
Parameters
table(Table)
topRow(Int32)
leftColumn(Int32)
bottomRow(Int32)
rightColumn(Int32)


DataFormat Property

DataFormat Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »DataFormat
Declaration Syntax
C# Visual Basic Visual C++
public string DataFormat { get; set; }
Public Property DataFormat As String
    Get
    Set
public:
property String^ DataFormat {
    String^ get ();
    void set (String^ value);
}


DataType Property

DataType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »DataType
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DataTypeParameter> DataType { get; set; }
Public Property DataType As Nullable(Of DataTypeParameter)
    Get
    Set
public:
property Nullable<DataTypeParameter> DataType {
    Nullable<DataTypeParameter> get ();
    void set (Nullable<DataTypeParameter> value);
}


DeleteContent Method

DeleteContent Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »DeleteContent()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteContent()
Public Sub DeleteContent
public:
void DeleteContent()


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »Equality(CellRange, CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    CellRange t1,
    CellRange t2
)
Public Shared Operator = ( _
    t1 As CellRange, _
    t2 As CellRange _
) As Boolean
public:
static bool operator ==(
    CellRange^ t1,
    CellRange^ t2
)
Parameters
t1(CellRange)
t2(CellRange)


Equals Method (pRange)

Equals Method (pRange)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object pRange
)
Public Overrides Function Equals ( _
    pRange As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ pRange
) override
Parameters
pRange(Object)


GetCustomData Method (key)

GetCustomData Method (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »GetCustomData(String)
Declaration Syntax
C# Visual Basic Visual C++
public Object GetCustomData(
    string key
)
Public Function GetCustomData ( _
    key As String _
) As Object
public:
Object^ GetCustomData(
    String^ key
)
Parameters
key(String)


GetDataLink Method

GetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »GetDataLink()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetDataLink()
Public Function GetDataLink As ObjectIdCollection
public:
ObjectIdCollection^ GetDataLink()


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator<CellReference> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of CellReference)
public:
virtual IEnumerator<CellReference>^ GetEnumerator()


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override


GetStyleOverrides Method

GetStyleOverrides Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »GetStyleOverrides()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TableStyleOverride[] GetStyleOverrides()
Public Function GetStyleOverrides As TableStyleOverride()
public:
array<TableStyleOverride>^ GetStyleOverrides()


IEnumerableGetEnumerator Method

IEnumerableGetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »IEnumerableGetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator IEnumerableGetEnumerator()
Public Function IEnumerableGetEnumerator As IEnumerator
public:
virtual IEnumerator^ IEnumerableGetEnumerator() sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »Inequality(CellRange, CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    CellRange t1,
    CellRange t2
)
Public Shared Operator <> ( _
    t1 As CellRange, _
    t2 As CellRange _
) As Boolean
public:
static bool operator !=(
    CellRange^ t1,
    CellRange^ t2
)
Parameters
t1(CellRange)
t2(CellRange)


IsBackgroundColorNone Property

IsBackgroundColorNone Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »IsBackgroundColorNone
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<bool> IsBackgroundColorNone { get; set; }
Public Property IsBackgroundColorNone As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsBackgroundColorNone {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}


IsContentEditable Property

IsContentEditable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »IsContentEditable
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<bool> IsContentEditable { get; }
Public ReadOnly Property IsContentEditable As Nullable(Of Boolean)
    Get
public:
property Nullable<bool> IsContentEditable {
    Nullable<bool> get ();
}


IsEmpty Property

IsEmpty Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »IsEmpty
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<bool> IsEmpty { get; }
Public ReadOnly Property IsEmpty As Nullable(Of Boolean)
    Get
public:
property Nullable<bool> IsEmpty {
    Nullable<bool> get ();
}


IsFormatEditable Property

IsFormatEditable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »IsFormatEditable
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<bool> IsFormatEditable { get; }
Public ReadOnly Property IsFormatEditable As Nullable(Of Boolean)
    Get
public:
property Nullable<bool> IsFormatEditable {
    Nullable<bool> get ();
}


IsLinked Property

IsLinked Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »IsLinked
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<bool> IsLinked { get; }
Public ReadOnly Property IsLinked As Nullable(Of Boolean)
    Get
public:
property Nullable<bool> IsLinked {
    Nullable<bool> get ();
}


IsMergeAllEnabled Property

IsMergeAllEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »IsMergeAllEnabled
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<bool> IsMergeAllEnabled { get; set; }
Public Property IsMergeAllEnabled As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> IsMergeAllEnabled {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}


IsMerged Property

IsMerged Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »IsMerged
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<bool> IsMerged { get; }
Public ReadOnly Property IsMerged As Nullable(Of Boolean)
    Get
public:
property Nullable<bool> IsMerged {
    Nullable<bool> get ();
}


IsNull Property

IsNull Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »IsNull
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNull { get; }
Public ReadOnly Property IsNull As Boolean
    Get
public:
property bool IsNull {
    bool get ();
}


IsSingleCell Property

IsSingleCell Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »IsSingleCell
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSingleCell { get; }
Public ReadOnly Property IsSingleCell As Boolean
    Get
public:
property bool IsSingleCell {
    bool get ();
}


Item Property (row, column)

Item Property (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »Item[([( Int32, Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Cell this[
    int row,
    int column
] { get; }
Public ReadOnly Default Property Item ( _
    row As Integer, _
    column As Integer _
) As Cell
    Get
public:
property Cell^ default[int row, int column] {
    Cell^ get (int row, int column);
}
Parameters
row(Int32)
column(Int32)


LeftColumn Property

LeftColumn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »LeftColumn
Declaration Syntax
C# Visual Basic Visual C++
public int LeftColumn { get; }
Public ReadOnly Property LeftColumn As Integer
    Get
public:
property int LeftColumn {
    int get ();
}


Parent Property

Parent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »Parent
Declaration Syntax
C# Visual Basic Visual C++
public Object Parent { get; set; }
Public Property Parent As Object
    Get
    Set
public:
virtual property Object^ Parent {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}


ParentTable Property

ParentTable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »ParentTable
Declaration Syntax
C# Visual Basic Visual C++
public Table ParentTable { get; }
Public ReadOnly Property ParentTable As Table
    Get
public:
property Table^ ParentTable {
    Table^ get ();
}


RightColumn Property

RightColumn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »RightColumn
Declaration Syntax
C# Visual Basic Visual C++
public int RightColumn { get; }
Public ReadOnly Property RightColumn As Integer
    Get
public:
property int RightColumn {
    int get ();
}


SetCustomData Method (key, value)

SetCustomData Method (key, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »SetCustomData(String, Object)
Declaration Syntax
C# Visual Basic Visual C++
public void SetCustomData(
    string key,
    Object value
)
Public Sub SetCustomData ( _
    key As String, _
    value As Object _
)
public:
void SetCustomData(
    String^ key,
    Object^ value
)
Parameters
key(String)
value(Object)


SetDataLink Method (dataLinkId, bUpdate)

SetDataLink Method (dataLinkId, bUpdate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »SetDataLink(ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDataLink(
    ObjectId dataLinkId,
    bool bUpdate
)
Public Sub SetDataLink ( _
    dataLinkId As ObjectId, _
    bUpdate As Boolean _
)
public:
void SetDataLink(
    ObjectId dataLinkId,
    bool bUpdate
)
Parameters
dataLinkId(ObjectId)
bUpdate(Boolean)


State Property

State Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »State
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<CellStates> State { get; set; }
Public Property State As Nullable(Of CellStates)
    Get
    Set
public:
property Nullable<CellStates> State {
    Nullable<CellStates> get ();
    void set (Nullable<CellStates> value);
}


Style Property

Style Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »Style
Declaration Syntax
C# Visual Basic Visual C++
public string Style { get; set; }
Public Property Style As String
    Get
    Set
public:
property String^ Style {
    String^ get ();
    void set (String^ value);
}


TextHeight Property

TextHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »TextHeight
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<double> TextHeight { get; set; }
Public Property TextHeight As Nullable(Of Double)
    Get
    Set
public:
property Nullable<double> TextHeight {
    Nullable<double> get ();
    void set (Nullable<double> value);
}


TextStyleId Property

TextStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »TextStyleId
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<ObjectId> TextStyleId { get; set; }
Public Property TextStyleId As Nullable(Of ObjectId)
    Get
    Set
public:
property Nullable<ObjectId> TextStyleId {
    Nullable<ObjectId> get ();
    void set (Nullable<ObjectId> value);
}


TopLeft Property

TopLeft Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »TopLeft
Declaration Syntax
C# Visual Basic Visual C++
public Cell TopLeft { get; }
Public ReadOnly Property TopLeft As Cell
    Get
public:
property Cell^ TopLeft {
    Cell^ get ();
}


TopRow Property

TopRow Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellRange »TopRow
Declaration Syntax
C# Visual Basic Visual C++
public int TopRow { get; }
Public ReadOnly Property TopRow As Integer
    Get
public:
property int TopRow {
    int get ();
}


CellReference Structure

CellReference Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellReference
Declaration Syntax
C# Visual Basic Visual C++
public struct CellReference
Public Structure CellReference
public value class CellReference
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Column |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Row |
 | ToString()()()() | (Inherited from ValueType.)


Column Property

Column Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellReference »Column
Declaration Syntax
C# Visual Basic Visual C++
public int Column { get; set; }
Public Property Column As Integer
    Get
    Set
public:
property int Column {
    int get ();
    void set (int value);
}


Row Property

Row Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellReference »Row
Declaration Syntax
C# Visual Basic Visual C++
public int Row { get; set; }
Public Property Row As Integer
    Get
    Set
public:
property int Row {
    int get ();
    void set (int value);
}


CellStates Enumeration

CellStates Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellStates
Declaration Syntax
C# Visual Basic Visual C++
public enum CellStates
Public Enumeration CellStates
public enum class CellStates
Members
Member | Description
FormatModifiedAfterUpdate |
FormatReadOnly |
FormatLocked |
ContentModifiedAfterUpdate |
Linked |
ContentReadOnly |
ContentLocked |
None |


CellType Enumeration

CellType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CellType
Declaration Syntax
C# Visual Basic Visual C++
public enum CellType
Public Enumeration CellType
public enum class CellType
Members
Member | Description
Vector |
SoftPtrId |
HardPtrId |
SoftOwnerId |
HardOwnerId |
ObjectId |
CharPtr |
Integer |
Bool |
Point |
Double |
Unknown |


Circle Class

Circle Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbCircle")]
public class Circle : Curve
<WrapperAttribute("AcDbCircle")> _
Public Class Circle _
    Inherits Curve
[WrapperAttribute(L"AcDbCircle")]
public ref class Circle : public Curve
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Circle(Point3d, Vector3d, Double) |
 | Circle(IntPtr, Boolean) |
 | Circle()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | Center |
 | Circumference |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed | (Inherited from Curve.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Diameter |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Radius |
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Spline | (Inherited from Curve.)
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Inherited from Curve.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Circle


Circle Constructor

Circle Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Circle()()()()
Members
Icon | Member | Description
 | Circle(Point3d, Vector3d, Double) |
 | Circle(IntPtr, Boolean) |
 | Circle()()()() |


Circle Constructor

Circle Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Circle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Circle()
Public Sub New
public:
Circle()


Circle Constructor (unmanagedObjPtr, autoDelete)

Circle Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Circle(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Circle(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Circle(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Circle Constructor (center, normal, radius)

Circle Constructor (center, normal, radius)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Circle(Point3d, Vector3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Circle(
    Point3d center,
    Vector3d normal,
    double radius
)
Public Sub New ( _
    center As Point3d, _
    normal As Vector3d, _
    radius As Double _
)
public:
Circle(
    Point3d center,
    Vector3d normal,
    double radius
)
Parameters
center(Point3d)
normal(Vector3d)
radius(Double)


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Center { get; set; }
Public Property Center As Point3d
    Get
    Set
public:
property Point3d Center {
    Point3d get ();
    void set (Point3d value);
}


Circumference Property

Circumference Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Circumference
Declaration Syntax
C# Visual Basic Visual C++
public double Circumference { get; set; }
Public Property Circumference As Double
    Get
    Set
public:
property double Circumference {
    double get ();
    void set (double value);
}


Diameter Property

Diameter Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Diameter
Declaration Syntax
C# Visual Basic Visual C++
public double Diameter { get; set; }
Public Property Diameter As Double
    Get
    Set
public:
property double Diameter {
    double get ();
    void set (double value);
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


Radius Property

Radius Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Radius
Declaration Syntax
C# Visual Basic Visual C++
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set
public:
property double Radius {
    double get ();
    void set (double value);
}


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}


ClipBoundaryType Enumeration

ClipBoundaryType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ClipBoundaryType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbRasterImage::ClipBoundaryType")]
public enum ClipBoundaryType
<WrapperAttribute("ZcDbRasterImage::ClipBoundaryType")> _
Public Enumeration ClipBoundaryType
[WrapperAttribute(L"ZcDbRasterImage::ClipBoundaryType")]
public enum class ClipBoundaryType
Members
Member | Description
Poly |
Invalid |
Rectangle |


CollisionType Enumeration

CollisionType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CollisionType
Declaration Syntax
C# Visual Basic Visual C++
public enum CollisionType
Public Enumeration CollisionType
public enum class CollisionType
Members
Member | Description
None |
Solid |


Column Class

Column Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Column
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Column : CellRange
Public NotInheritable Class Column _
    Inherits CellRange
public ref class Column sealed : public CellRange
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Alignment | (Inherited from CellRange.)
 | BackgroundColor | (Inherited from CellRange.)
 | Borders | (Inherited from CellRange.)
 | BottomRight | (Inherited from CellRange.)
 | BottomRightPlusOne | (Inherited from CellRange.)
 | BottomRow | (Inherited from CellRange.)
 | CanDeleteColumns | (Inherited from CellRange.)
 | CanDeleteRows | (Inherited from CellRange.)
 | CanInsertColumn | (Inherited from CellRange.)
 | CanInsertRow | (Inherited from CellRange.)
 | ClearStyleOverrides()()()() | (Inherited from CellRange.)
 | ContentColor | (Inherited from CellRange.)
 | ContentLayout | (Inherited from CellRange.)
 | DataFormat | (Inherited from CellRange.)
 | DataType | (Inherited from CellRange.)
 | DeleteContent()()()() | (Inherited from CellRange.)
 | Equals(Object) | (Inherited from CellRange.)
 | Finalize()()()() | (Inherited from Object.)
 | GetCustomData(String) | (Inherited from CellRange.)
 | GetDataLink()()()() | (Inherited from CellRange.)
 | GetEnumerator()()()() | (Inherited from CellRange.)
 | GetHashCode()()()() | (Inherited from CellRange.)
 | GetStyleOverrides()()()() | (Inherited from CellRange.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerableGetEnumerator()()()() | (Inherited from CellRange.)
 | IsBackgroundColorNone | (Inherited from CellRange.)
 | IsContentEditable | (Inherited from CellRange.)
 | IsEmpty | (Inherited from CellRange.)
 | IsFormatEditable | (Inherited from CellRange.)
 | IsLinked | (Inherited from CellRange.)
 | IsMergeAllEnabled | (Inherited from CellRange.)
 | IsMerged | (Inherited from CellRange.)
 | IsNull | (Inherited from CellRange.)
 | IsSingleCell | (Inherited from CellRange.)
 | Item[([( Int32, Int32])]) | (Inherited from CellRange.)
 | LeftColumn | (Inherited from CellRange.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumWidth |
 | Name |
 | Parent | (Inherited from CellRange.)
 | ParentTable | (Inherited from CellRange.)
 | RightColumn | (Inherited from CellRange.)
 | SetCustomData(String, Object) | (Inherited from CellRange.)
 | SetDataLink(ObjectId, Boolean) | (Inherited from CellRange.)
 | State | (Inherited from CellRange.)
 | Style | (Inherited from CellRange.)
 | TextHeight | (Inherited from CellRange.)
 | TextStyleId | (Inherited from CellRange.)
 | TopLeft | (Inherited from CellRange.)
 | TopRow | (Inherited from CellRange.)
 | ToString()()()() | (Inherited from Object.)
 | Width |
Inheritance Hierarchy
Object
 | CellRange
 |  | Column


MinimumWidth Property

MinimumWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Column »MinimumWidth
Declaration Syntax
C# Visual Basic Visual C++
public double MinimumWidth { get; }
Public ReadOnly Property MinimumWidth As Double
    Get
public:
property double MinimumWidth {
    double get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Column »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Column »Width
Declaration Syntax
C# Visual Basic Visual C++
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}


ColumnsCollection Class

ColumnsCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ColumnsCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ColumnsCollection : IEnumerable<Column>
Public NotInheritable Class ColumnsCollection _
    Implements IEnumerable(Of Column)
public ref class ColumnsCollection sealed : IEnumerable<Column^>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerableGetEnumerator()()()() |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ColumnsCollection


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ColumnsCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ColumnsCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<Column> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Column)
public:
virtual IEnumerator<Column^>^ GetEnumerator() sealed


IEnumerableGetEnumerator Method

IEnumerableGetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ColumnsCollection »IEnumerableGetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
internal IEnumerator IEnumerableGetEnumerator()
Friend Function IEnumerableGetEnumerator As IEnumerator
internal:
virtual IEnumerator^ IEnumerableGetEnumerator() sealed


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ColumnsCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Column this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Column
    Get
public:
property Column^ default[int index] {
    Column^ get (int index);
}
Parameters
index(Int32)


ColumnType Enumeration

ColumnType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ColumnType
Declaration Syntax
C# Visual Basic Visual C++
public enum ColumnType
Public Enumeration ColumnType
public enum class ColumnType
Members
Member | Description
StaticColumns |
NoColumns |
DynamicColumns |


ConstrainType Enumeration

ConstrainType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ConstrainType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbHelix::ConstrainType")]
public enum ConstrainType
<WrapperAttribute("ZcDbHelix::ConstrainType")> _
Public Enumeration ConstrainType
[WrapperAttribute(L"ZcDbHelix::ConstrainType")]
public enum class ConstrainType
Members
Member | Description
Height |
Turns |
TurnHeight |


ContentType Enumeration

ContentType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ContentType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::ContentType")]
public enum ContentType
<WrapperAttribute("ZcDbMLeaderStyle::ContentType")> _
Public Enumeration ContentType
[WrapperAttribute(L"ZcDbMLeaderStyle::ContentType")]
public enum class ContentType
Members
Member | Description
ToleranceContent |
MTextContent |
BlockContent |
NoneContent |


Curve Class

Curve Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbCurve")]
public abstract class Curve : Entity
<WrapperAttribute("AcDbCurve")> _
Public MustInherit Class Curve _
    Inherits Entity
[WrapperAttribute(L"AcDbCurve")]
public ref class Curve abstract : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Curve(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed |
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | CreateFromGeCurve(Curve3d, Vector3d) |
 | CreateFromGeCurve(Curve3d, Tolerance) |
 | CreateFromGeCurve(Curve3d) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EndParam |
 | EndPoint |
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) |
 | Extend(Double) |
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |
 | GetDistanceAtParameter(Double) |
 | GetDistAtPoint(Point3d) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) |
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) |
 | GetOrthoProjectedCurve(Plane) |
 | GetParameterAtDistance(Double) |
 | GetParameterAtPoint(Point3d) |
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) |
 | GetPointAtParameter(Double) |
 | GetProjectedCurve(Plane, Vector3d) |
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic |
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Spline |
 | StartParam |
 | StartPoint |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Arc
 |  |  |  |  |  |  |  | Circle
 |  |  |  |  |  |  |  | Ellipse
 |  |  |  |  |  |  |  | Leader
 |  |  |  |  |  |  |  | Line
 |  |  |  |  |  |  |  | Polyline
 |  |  |  |  |  |  |  | Polyline2d
 |  |  |  |  |  |  |  | Polyline3d
 |  |  |  |  |  |  |  | Ray
 |  |  |  |  |  |  |  | Spline
 |  |  |  |  |  |  |  | Xline


Curve Constructor (unmanagedObjPtr, autoDelete)

Curve Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Curve(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Curve(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Curve(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Area Property

Area Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Area
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Area { get; }
Public Overridable ReadOnly Property Area As Double
    Get
public:
virtual property double Area {
    double get ();
}


Closed Property

Closed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Closed
Declaration Syntax
C# Visual Basic Visual C++
public bool Closed { get; }
Public ReadOnly Property Closed As Boolean
    Get
public:
property bool Closed {
    bool get ();
}


CreateFromGeCurve Method

CreateFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »CreateFromGeCurve()()()()
Members
Icon | Member | Description
 | CreateFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | CreateFromGeCurve(Curve3d, Vector3d) |
 | CreateFromGeCurve(Curve3d, Tolerance) |
 | CreateFromGeCurve(Curve3d) |


CreateFromGeCurve Method (geCurve)

CreateFromGeCurve Method (geCurve)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »CreateFromGeCurve(Curve3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Curve CreateFromGeCurve(
    Curve3d geCurve
)
Public Shared Function CreateFromGeCurve ( _
    geCurve As Curve3d _
) As Curve
public:
static Curve^ CreateFromGeCurve(
    Curve3d^ geCurve
)
Parameters
geCurve(Curve3d)


CreateFromGeCurve Method (geCurve, tolerance)

CreateFromGeCurve Method (geCurve, tolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »CreateFromGeCurve(Curve3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public static Curve CreateFromGeCurve(
    Curve3d geCurve,
    Tolerance tolerance
)
Public Shared Function CreateFromGeCurve ( _
    geCurve As Curve3d, _
    tolerance As Tolerance _
) As Curve
public:
static Curve^ CreateFromGeCurve(
    Curve3d^ geCurve,
    Tolerance tolerance
)
Parameters
geCurve(Curve3d)
tolerance(Tolerance)


CreateFromGeCurve Method (geCurve, vec)

CreateFromGeCurve Method (geCurve, vec)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »CreateFromGeCurve(Curve3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Curve CreateFromGeCurve(
    Curve3d geCurve,
    Vector3d vec
)
Public Shared Function CreateFromGeCurve ( _
    geCurve As Curve3d, _
    vec As Vector3d _
) As Curve
public:
static Curve^ CreateFromGeCurve(
    Curve3d^ geCurve,
    Vector3d vec
)
Parameters
geCurve(Curve3d)
vec(Vector3d)


CreateFromGeCurve Method (geCurve, vec, tolerance)

CreateFromGeCurve Method (geCurve, vec, tolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »CreateFromGeCurve(Curve3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public static Curve CreateFromGeCurve(
    Curve3d geCurve,
    Vector3d vec,
    Tolerance tolerance
)
Public Shared Function CreateFromGeCurve ( _
    geCurve As Curve3d, _
    vec As Vector3d, _
    tolerance As Tolerance _
) As Curve
public:
static Curve^ CreateFromGeCurve(
    Curve3d^ geCurve,
    Vector3d vec,
    Tolerance tolerance
)
Parameters
geCurve(Curve3d)
vec(Vector3d)
tolerance(Tolerance)


EndParam Property

EndParam Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »EndParam
Declaration Syntax
C# Visual Basic Visual C++
public virtual double EndParam { get; }
Public Overridable ReadOnly Property EndParam As Double
    Get
public:
virtual property double EndParam {
    double get ();
}


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d EndPoint { get; set; }
Public Overridable Property EndPoint As Point3d
    Get
    Set
public:
virtual property Point3d EndPoint {
    Point3d get ();
    void set (Point3d value);
}


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


Extend Method (extendStart, toPoint)

Extend Method (extendStart, toPoint)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Extend(Boolean, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Extend(
    bool extendStart,
    Point3d toPoint
)
Public Overridable Sub Extend ( _
    extendStart As Boolean, _
    toPoint As Point3d _
)
public:
virtual void Extend(
    bool extendStart,
    Point3d toPoint
)
Parameters
extendStart(Boolean)
toPoint(Point3d)


Extend Method (newParameter)

Extend Method (newParameter)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Extend(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Extend(
    double newParameter
)
Public Overridable Sub Extend ( _
    newParameter As Double _
)
public:
virtual void Extend(
    double newParameter
)
Parameters
newParameter(Double)


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


GetClosestPointTo Method (givenPoint, extend)

GetClosestPointTo Method (givenPoint, extend)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetClosestPointTo(Point3d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d GetClosestPointTo(
    Point3d givenPoint,
    bool extend
)
Public Overridable Function GetClosestPointTo ( _
    givenPoint As Point3d, _
    extend As Boolean _
) As Point3d
public:
virtual Point3d GetClosestPointTo(
    Point3d givenPoint,
    bool extend
)
Parameters
givenPoint(Point3d)
extend(Boolean)


GetClosestPointTo Method (givenPoint, direction, extend)

GetClosestPointTo Method (givenPoint, direction, extend)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetClosestPointTo(Point3d, Vector3d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d GetClosestPointTo(
    Point3d givenPoint,
    Vector3d direction,
    bool extend
)
Public Overridable Function GetClosestPointTo ( _
    givenPoint As Point3d, _
    direction As Vector3d, _
    extend As Boolean _
) As Point3d
public:
virtual Point3d GetClosestPointTo(
    Point3d givenPoint,
    Vector3d direction,
    bool extend
)
Parameters
givenPoint(Point3d)
direction(Vector3d)
extend(Boolean)


GetDistanceAtParameter Method (value)

GetDistanceAtParameter Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetDistanceAtParameter(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetDistanceAtParameter(
    double value
)
Public Overridable Function GetDistanceAtParameter ( _
    value As Double _
) As Double
public:
virtual double GetDistanceAtParameter(
    double value
)
Parameters
value(Double)


GetDistAtPoint Method (point)

GetDistAtPoint Method (point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetDistAtPoint(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetDistAtPoint(
    Point3d point
)
Public Overridable Function GetDistAtPoint ( _
    point As Point3d _
) As Double
public:
virtual double GetDistAtPoint(
    Point3d point
)
Parameters
point(Point3d)


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


GetFirstDerivative Method (value)

GetFirstDerivative Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetFirstDerivative(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d GetFirstDerivative(
    double value
)
Public Overridable Function GetFirstDerivative ( _
    value As Double _
) As Vector3d
public:
virtual Vector3d GetFirstDerivative(
    double value
)
Parameters
value(Double)


GetFirstDerivative Method (point)

GetFirstDerivative Method (point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetFirstDerivative(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d GetFirstDerivative(
    Point3d point
)
Public Overridable Function GetFirstDerivative ( _
    point As Point3d _
) As Vector3d
public:
virtual Vector3d GetFirstDerivative(
    Point3d point
)
Parameters
point(Point3d)


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetGeCurve()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d GetGeCurve()
Public Function GetGeCurve As Curve3d
public:
Curve3d^ GetGeCurve()


GetGeCurve Method (tolerance)

GetGeCurve Method (tolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetGeCurve(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d GetGeCurve(
    Tolerance tolerance
)
Public Function GetGeCurve ( _
    tolerance As Tolerance _
) As Curve3d
public:
Curve3d^ GetGeCurve(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


GetOffsetCurves Method (offsetDist)

GetOffsetCurves Method (offsetDist)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetOffsetCurves(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObjectCollection GetOffsetCurves(
    double offsetDist
)
Public Overridable Function GetOffsetCurves ( _
    offsetDist As Double _
) As DBObjectCollection
public:
virtual DBObjectCollection^ GetOffsetCurves(
    double offsetDist
)
Parameters
offsetDist(Double)


GetOffsetCurvesGivenPlaneNormal Method (normal, offsetDist)

GetOffsetCurvesGivenPlaneNormal Method (normal, offsetDist)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetOffsetCurvesGivenPlaneNormal(Vector3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObjectCollection GetOffsetCurvesGivenPlaneNormal(
    Vector3d normal,
    double offsetDist
)
Public Overridable Function GetOffsetCurvesGivenPlaneNormal ( _
    normal As Vector3d, _
    offsetDist As Double _
) As DBObjectCollection
public:
virtual DBObjectCollection^ GetOffsetCurvesGivenPlaneNormal(
    Vector3d normal,
    double offsetDist
)
Parameters
normal(Vector3d)
offsetDist(Double)


GetOrthoProjectedCurve Method (planeToProjectOn)

GetOrthoProjectedCurve Method (planeToProjectOn)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetOrthoProjectedCurve(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Curve GetOrthoProjectedCurve(
    Plane planeToProjectOn
)
Public Overridable Function GetOrthoProjectedCurve ( _
    planeToProjectOn As Plane _
) As Curve
public:
virtual Curve^ GetOrthoProjectedCurve(
    Plane^ planeToProjectOn
)
Parameters
planeToProjectOn(Plane)


GetParameterAtDistance Method (dist)

GetParameterAtDistance Method (dist)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetParameterAtDistance(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetParameterAtDistance(
    double dist
)
Public Overridable Function GetParameterAtDistance ( _
    dist As Double _
) As Double
public:
virtual double GetParameterAtDistance(
    double dist
)
Parameters
dist(Double)


GetParameterAtPoint Method (point)

GetParameterAtPoint Method (point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetParameterAtPoint(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetParameterAtPoint(
    Point3d point
)
Public Overridable Function GetParameterAtPoint ( _
    point As Point3d _
) As Double
public:
virtual double GetParameterAtPoint(
    Point3d point
)
Parameters
point(Point3d)


GetPointAtDist Method (value)

GetPointAtDist Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetPointAtDist(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d GetPointAtDist(
    double value
)
Public Overridable Function GetPointAtDist ( _
    value As Double _
) As Point3d
public:
virtual Point3d GetPointAtDist(
    double value
)
Parameters
value(Double)


GetPointAtParameter Method (value)

GetPointAtParameter Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetPointAtParameter(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d GetPointAtParameter(
    double value
)
Public Overridable Function GetPointAtParameter ( _
    value As Double _
) As Point3d
public:
virtual Point3d GetPointAtParameter(
    double value
)
Parameters
value(Double)


GetProjectedCurve Method (planeToProjectOn, projectionDirection)

GetProjectedCurve Method (planeToProjectOn, projectionDirection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetProjectedCurve(Plane, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Curve GetProjectedCurve(
    Plane planeToProjectOn,
    Vector3d projectionDirection
)
Public Overridable Function GetProjectedCurve ( _
    planeToProjectOn As Plane, _
    projectionDirection As Vector3d _
) As Curve
public:
virtual Curve^ GetProjectedCurve(
    Plane^ planeToProjectOn,
    Vector3d projectionDirection
)
Parameters
planeToProjectOn(Plane)
projectionDirection(Vector3d)


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


GetSecondDerivative Method (value)

GetSecondDerivative Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetSecondDerivative(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d GetSecondDerivative(
    double value
)
Public Overridable Function GetSecondDerivative ( _
    value As Double _
) As Vector3d
public:
virtual Vector3d GetSecondDerivative(
    double value
)
Parameters
value(Double)


GetSecondDerivative Method (point)

GetSecondDerivative Method (point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetSecondDerivative(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d GetSecondDerivative(
    Point3d point
)
Public Overridable Function GetSecondDerivative ( _
    point As Point3d _
) As Vector3d
public:
virtual Vector3d GetSecondDerivative(
    Point3d point
)
Parameters
point(Point3d)


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


GetSplitCurves Method (value)

GetSplitCurves Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetSplitCurves(DoubleCollection)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObjectCollection GetSplitCurves(
    DoubleCollection value
)
Public Overridable Function GetSplitCurves ( _
    value As DoubleCollection _
) As DBObjectCollection
public:
virtual DBObjectCollection^ GetSplitCurves(
    DoubleCollection^ value
)
Parameters
value(DoubleCollection)


GetSplitCurves Method (points)

GetSplitCurves Method (points)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetSplitCurves(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObjectCollection GetSplitCurves(
    Point3dCollection points
)
Public Overridable Function GetSplitCurves ( _
    points As Point3dCollection _
) As DBObjectCollection
public:
virtual DBObjectCollection^ GetSplitCurves(
    Point3dCollection^ points
)
Parameters
points(Point3dCollection)


IsPeriodic Property

IsPeriodic Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »IsPeriodic
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsPeriodic { get; }
Public Overridable ReadOnly Property IsPeriodic As Boolean
    Get
public:
virtual property bool IsPeriodic {
    bool get ();
}


ReverseCurve Method

ReverseCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »ReverseCurve()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ReverseCurve()
Public Overridable Sub ReverseCurve
public:
virtual void ReverseCurve()


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


SetFromGeCurve Method (geCurve)

SetFromGeCurve Method (geCurve)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »SetFromGeCurve(Curve3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFromGeCurve(
    Curve3d geCurve
)
Public Sub SetFromGeCurve ( _
    geCurve As Curve3d _
)
public:
void SetFromGeCurve(
    Curve3d^ geCurve
)
Parameters
geCurve(Curve3d)


SetFromGeCurve Method (geCurve, tolerance)

SetFromGeCurve Method (geCurve, tolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »SetFromGeCurve(Curve3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFromGeCurve(
    Curve3d geCurve,
    Tolerance tolerance
)
Public Sub SetFromGeCurve ( _
    geCurve As Curve3d, _
    tolerance As Tolerance _
)
public:
void SetFromGeCurve(
    Curve3d^ geCurve,
    Tolerance tolerance
)
Parameters
geCurve(Curve3d)
tolerance(Tolerance)


SetFromGeCurve Method (geCurve, vec)

SetFromGeCurve Method (geCurve, vec)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »SetFromGeCurve(Curve3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFromGeCurve(
    Curve3d geCurve,
    Vector3d vec
)
Public Sub SetFromGeCurve ( _
    geCurve As Curve3d, _
    vec As Vector3d _
)
public:
void SetFromGeCurve(
    Curve3d^ geCurve,
    Vector3d vec
)
Parameters
geCurve(Curve3d)
vec(Vector3d)


SetFromGeCurve Method (geCurve, vec, tolerance)

SetFromGeCurve Method (geCurve, vec, tolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »SetFromGeCurve(Curve3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFromGeCurve(
    Curve3d geCurve,
    Vector3d vec,
    Tolerance tolerance
)
Public Sub SetFromGeCurve ( _
    geCurve As Curve3d, _
    vec As Vector3d, _
    tolerance As Tolerance _
)
public:
void SetFromGeCurve(
    Curve3d^ geCurve,
    Vector3d vec,
    Tolerance tolerance
)
Parameters
geCurve(Curve3d)
vec(Vector3d)
tolerance(Tolerance)


Spline Property

Spline Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Spline
Declaration Syntax
C# Visual Basic Visual C++
public virtual Spline Spline { get; }
Public Overridable ReadOnly Property Spline As Spline
    Get
public:
virtual property Spline^ Spline {
    Spline^ get ();
}


StartParam Property

StartParam Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »StartParam
Declaration Syntax
C# Visual Basic Visual C++
public virtual double StartParam { get; }
Public Overridable ReadOnly Property StartParam As Double
    Get
public:
virtual property double StartParam {
    double get ();
}


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d StartPoint { get; set; }
Public Overridable Property StartPoint As Point3d
    Get
    Set
public:
virtual property Point3d StartPoint {
    Point3d get ();
    void set (Point3d value);
}


CustomObjectSnapMode Class

CustomObjectSnapMode Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomObjectSnapMode
Declaration Syntax
C# Visual Basic Visual C++
public abstract class CustomObjectSnapMode : DisposableWrapper
Public MustInherit Class CustomObjectSnapMode _
    Inherits DisposableWrapper
public ref class CustomObjectSnapMode abstract : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomObjectSnapMode()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | CustomObjectSnapMode


CustomObjectSnapMode Constructor

CustomObjectSnapMode Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomObjectSnapMode »CustomObjectSnapMode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CustomObjectSnapMode()
Public Sub New
public:
CustomObjectSnapMode()


CustomScale Structure

CustomScale Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale
Declaration Syntax
C# Visual Basic Visual C++
public struct CustomScale
Public Structure CustomScale
public value class CustomScale
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomScale(Double, Double) |
 | Denominator |
 | Equality(CustomScale, CustomScale) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(CustomScale, CustomScale) |
 | IsEqualTo(CustomScale, Tolerance) |
 | IsEqualTo(CustomScale) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Numerator |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


CustomScale Constructor (numerator, denominator)

CustomScale Constructor (numerator, denominator)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »CustomScale(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public CustomScale(
    double numerator,
    double denominator
)
Public Sub New ( _
    numerator As Double, _
    denominator As Double _
)
public:
CustomScale(
    double numerator,
    double denominator
)
Parameters
numerator(Double)
denominator(Double)


Denominator Property

Denominator Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »Denominator
Declaration Syntax
C# Visual Basic Visual C++
public double Denominator { get; }
Public ReadOnly Property Denominator As Double
    Get
public:
property double Denominator {
    double get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »Equality(CustomScale, CustomScale)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    CustomScale a,
    CustomScale b
)
Public Shared Operator = ( _
    a As CustomScale, _
    b As CustomScale _
) As Boolean
public:
static bool operator ==(
    CustomScale a,
    CustomScale b
)
Parameters
a(CustomScale)
b(CustomScale)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »Inequality(CustomScale, CustomScale)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    CustomScale a,
    CustomScale b
)
Public Shared Operator <> ( _
    a As CustomScale, _
    b As CustomScale _
) As Boolean
public:
static bool operator !=(
    CustomScale a,
    CustomScale b
)
Parameters
a(CustomScale)
b(CustomScale)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(CustomScale, Tolerance) |
 | IsEqualTo(CustomScale) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »IsEqualTo(CustomScale)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    CustomScale a
)
Public Function IsEqualTo ( _
    a As CustomScale _
) As Boolean
public:
bool IsEqualTo(
    CustomScale a
)
Parameters
a(CustomScale)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »IsEqualTo(CustomScale, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    CustomScale a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As CustomScale, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    CustomScale a,
    Tolerance tolerance
)
Parameters
a(CustomScale)
tolerance(Tolerance)


Numerator Property

Numerator Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »Numerator
Declaration Syntax
C# Visual Basic Visual C++
public double Numerator { get; }
Public ReadOnly Property Numerator As Double
    Get
public:
property double Numerator {
    double get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomScale »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


Database Class

Database Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDatabase")]
public sealed class Database : RXObject
<WrapperAttribute("ZcDbDatabase")> _
Public NotInheritable Class Database _
    Inherits RXObject
[WrapperAttribute(L"ZcDbDatabase")]
public ref class Database sealed : public RXObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Database(Boolean, Boolean) |
 | Database()()()() |
 | AbortDeepClone(IdMapping) |
 | AbortDxfIn |
 | AbortDxfOut |
 | AbortSave |
 | AcadDatabase |
 | AddDBObject(DBObject) |
 | AllowExtendedNames |
 | Angbase |
 | Angdir |
 | AnnoAllVisible |
 | AnnotativeDwg |
 | ApplyPartialOpenFilters(SpatialFilter, LayerFilter) |
 | ApproxNumObjects |
 | AttachXref(String, String) |
 | Attmode |
 | Audit(AuditInfo) |
 | AuditXData(AuditInfo) |
 | Aunits |
 | Auprec |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BeginDeepClone |
 | BeginDeepCloneTranslation |
 | BeginDxfIn |
 | BeginDxfOut |
 | BeginInsert |
 | BeginSave |
 | BeginWblockBlock |
 | BeginWblockEntireDatabase |
 | BeginWblockObjects |
 | BeginWblockSelectedObjects |
 | BindXrefs(ObjectIdCollection, Boolean) |
 | BlockTableId |
 | ByBlockLinetype |
 | ByLayerLinetype |
 | CameraDisplay |
 | CameraHeight |
 | Cannoscale |
 | Cecolor |
 | Celtscale |
 | Celtype |
 | Celweight |
 | Chamfera |
 | Chamferb |
 | Chamferc |
 | Chamferd |
 | ClassDxfName(RXClass) |
 | Clayer |
 | Clone()()()() | (Inherited from RXObject.)
 | CloseInput(Boolean) |
 | Cmaterial |
 | Cmljust |
 | Cmlscale |
 | CmlstyleID |
 | ColorDictionaryId |
 | CompareTo(Object) | (Inherited from RXObject.)
 | ContinuousLinetype |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CountHardReferences(ObjectIdCollection, array<Int32>[]()[][]) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Cshadow |
 | CurrentSpaceId |
 | CurrentViewportTableRecordId |
 | DatabaseConstructed |
 | DatabaseToBeDestroyed |
 | DeepCloneAborted |
 | DeepCloneEnded |
 | DeepCloneObjects(ObjectIdCollection, ObjectId, IdMapping, Boolean) |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DetachXref(ObjectId) |
 | Dimadec |
 | Dimalt |
 | Dimaltd |
 | Dimaltf |
 | Dimaltrnd |
 | Dimalttd |
 | Dimalttz |
 | Dimaltu |
 | Dimaltz |
 | Dimapost |
 | Dimarcsym |
 | Dimaso |
 | DimAssoc |
 | Dimasz |
 | Dimatfit |
 | Dimaunit |
 | Dimazin |
 | Dimblk |
 | Dimblk1 |
 | Dimblk2 |
 | Dimcen |
 | Dimclrd |
 | Dimclre |
 | Dimclrt |
 | Dimdec |
 | Dimdle |
 | Dimdli |
 | Dimdsep |
 | Dimexe |
 | Dimexo |
 | Dimfrac |
 | Dimfxlen |
 | DimfxlenOn |
 | Dimgap |
 | Dimjogang |
 | Dimjust |
 | Dimldrblk |
 | Dimlfac |
 | Dimlim |
 | Dimltex1 |
 | Dimltex2 |
 | Dimltype |
 | Dimlunit |
 | Dimlwd |
 | Dimlwe |
 | Dimpost |
 | Dimrnd |
 | Dimsah |
 | Dimscale |
 | Dimsd1 |
 | Dimsd2 |
 | Dimse1 |
 | Dimse2 |
 | Dimsoxd |
 | Dimstyle |
 | DimstyleData |
 | DimStyleTableId |
 | Dimtad |
 | Dimtdec |
 | Dimtfac |
 | Dimtfill |
 | Dimtfillclr |
 | Dimtih |
 | Dimtix |
 | Dimtm |
 | Dimtmove |
 | Dimtofl |
 | Dimtoh |
 | Dimtol |
 | Dimtolj |
 | Dimtp |
 | Dimtsz |
 | Dimtvp |
 | Dimtxsty |
 | Dimtxt |
 | Dimtxtdirection |
 | Dimtzin |
 | Dimupt |
 | Dimzin |
 | DisablePartialOpen()()()() |
 | DisableUndoRecording(Boolean) |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Disposed |
 | DispSilh |
 | DrawOrderCtl |
 | DwgFileOpened |
 | DwgFileWasSavedByZwSoftSoftware |
 | DxfIn(String, String) |
 | DxfInComplete |
 | DxfOut(String, Int32, DwgVersion, Boolean) |
 | DxfOutComplete |
 | Elevation |
 | EndCaps |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Extmax |
 | Extmin |
 | Facetres |
 | FileDependencyManager |
 | Filename |
 | Filletrad |
 | Fillmode |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FingerprintGuid |
 | ForceWblockDatabaseCopy()()()() |
 | FromAcadDatabase(Object) |
 | GetAllDatabases()()()() |
 | GetDimensionStyleChildData(RXClass) |
 | GetDimensionStyleChildId(RXClass, ObjectId) |
 | GetDimensionStyleParentId(ObjectId) |
 | GetDimRecentStyleList()()()() |
 | GetDimstyleData()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetHostDwgXrefGraph(Boolean) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNearestLineWeight(Int32) |
 | GetObjectId(Boolean, Handle, Int32) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSupportedDxfOutVersions()()()() |
 | GetSupportedSaveVersions()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GetViewports(Boolean) |
 | GetVisualStyleList()()()() |
 | GroupDictionaryId |
 | HaloGap |
 | Handseed |
 | HasRedo |
 | HasUndo |
 | HideText |
 | HpInherit |
 | HpOrigin |
 | HyperlinkBase |
 | InitialDwgFileOpenComplete |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insbase |
 | Insert(String, String, Database, Boolean) |
 | Insert(String, Database, Boolean) |
 | Insert(Matrix3d, Database, Boolean) |
 | InsertAborted |
 | InsertEnded |
 | InsertMappingAvailable |
 | Insunits |
 | Interferecolor |
 | Interfereobjvs |
 | Interferevpvs |
 | IntersectColor |
 | IntersectDisplay |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEmr |
 | IsObjectNonPersistent(ObjectId) |
 | Isolines |
 | IsPartiallyOpened |
 | IsValidLineWeight(Int32) |
 | JoinStyle |
 | LastSavedAsMaintenanceVersion |
 | LastSavedAsVersion |
 | Latitude |
 | LayerFilters |
 | LayerStateManager |
 | LayerTableId |
 | LayerZero |
 | LayoutDictionaryId |
 | LensLength |
 | LightGlyphDisplay |
 | LightingUnits |
 | LightsInBlocks |
 | Limcheck |
 | Limmax |
 | Limmin |
 | LinetypeTableId |
 | LineWeightDisplay |
 | LoadLineTypeFile(String, String) |
 | LoadMlineStyleFile(String, String) |
 | LoftAng1 |
 | LoftAng2 |
 | LoftMag1 |
 | LoftMag2 |
 | LoftNormals |
 | LoftParam |
 | Longitude |
 | Ltscale |
 | Lunits |
 | Luprec |
 | MaintenanceReleaseVersion |
 | MarkObjectNonPersistent(ObjectId, Boolean) |
 | MaterialDictionaryId |
 | Maxactvp |
 | Measurement |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Menu |
 | Mirrtext |
 | MLeaderstyle |
 | MLeaderStyleDictionaryId |
 | MLStyleDictionaryId |
 | MsLtScale |
 | NamedObjectsDictionaryId |
 | NorthDirection |
 | NumberOfSaves |
 | ObjectAppended |
 | ObjectContextManager |
 | ObjectErased |
 | ObjectModified |
 | ObjectOpenedForModify |
 | ObjectReappended |
 | ObjectUnappended |
 | ObscuredColor |
 | ObscuredLineType |
 | OleStartUp |
 | OriginalFileMaintenanceVersion |
 | OriginalFileName |
 | OriginalFileSavedByMaintenanceVersion |
 | OriginalFileSavedByVersion |
 | OriginalFileVersion |
 | Orthomode |
 | OverlayXref(String, String) |
 | PaperSpaceVportId |
 | PartialOpenNotice |
 | Pdmode |
 | Pdsize |
 | Pelevation |
 | Pextmax |
 | Pextmin |
 | Pinsbase |
 | Plimcheck |
 | Plimmax |
 | Plimmin |
 | PlineEllipse |
 | Plinegen |
 | Plinewid |
 | PlotSettingsDictionaryId |
 | PlotStyleMode |
 | PlotStyleNameDictionaryId |
 | PlotStyleNameId |
 | ProjectName |
 | ProxyResurrectionCompleted |
 | Psltscale |
 | PsolHeight |
 | PsolWidth |
 | PucsBase |
 | Pucsname |
 | Pucsorg |
 | Pucsxdir |
 | Pucsydir |
 | Purge(ObjectIdGraph) |
 | Purge(ObjectIdCollection) |
 | Qtextmode |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ReadDwgFile(String, FileOpenMode, Boolean, String) |
 | ReadDwgFile(IntPtr, Boolean, String) |
 | ReadDwgFile(String, FileShare, Boolean, String) |
 | ReclaimMemoryFromErasedObjects(ObjectIdCollection) |
 | Redo()()()() |
 | RegAppTableId |
 | Regenmode |
 | ReloadXrefs(ObjectIdCollection) |
 | ResolveXrefs(Boolean, Boolean) |
 | RestoreForwardingXrefSymbols()()()() |
 | RestoreOriginalXrefSymbols()()()() |
 | RetainOriginalThumbnailBitmap |
 | Save()()()() |
 | SaveAs(String, SaveType, DwgVersion, Boolean, Int32) |
 | SaveAs(String, DwgVersion, Boolean, Int32) |
 | SaveAs(String, DwgVersion, Boolean) |
 | SaveAs(String, Boolean, DwgVersion, SecurityParameters) |
 | SaveAs(String, SecurityParameters) |
 | SaveAs(String, DwgVersion) |
 | SaveComplete |
 | Saveproxygraphics |
 | SectionManagerId |
 | SecurityParameters |
 | SetDimstyleData(DimStyleTableRecord) |
 | SetTimeZoneAsUtcOffset(Double) |
 | SetWorldPaperspaceUcsBaseOrigin(Point3d, OrthographicView) |
 | SetWorldUcsBaseOrigin(Point3d, OrthographicView) |
 | Shadedge |
 | Shadedif |
 | ShadowPlaneLocation |
 | ShowHist |
 | Sketchinc |
 | Skpoly |
 | SolidHist |
 | SortEnts |
 | Splframe |
 | Splinesegs |
 | Splinetype |
 | StartUndoRecord()()()() |
 | StepSize |
 | StepsPerSec |
 | StyleSheet |
 | SummaryInfo |
 | Surftab1 |
 | Surftab2 |
 | Surftype |
 | Surfu |
 | Surfv |
 | SystemVariableChanged |
 | SystemVariableWillChange |
 | Tablestyle |
 | TableStyleDictionaryId |
 | Tdcreate |
 | Tdindwg |
 | Tducreate |
 | Tdupdate |
 | Tdusrtimer |
 | Tduupdate |
 | Textsize |
 | Textstyle |
 | TextStyleTableId |
 | Thickness |
 | ThumbnailBitmap |
 | TileMode |
 | TileModeLightSynch |
 | TimeZone |
 | TimeZoneDescription(TimeZone) |
 | TimeZoneOffset(TimeZone) |
 | ToString()()()() | (Inherited from Object.)
 | Tracewid |
 | TransactionManager |
 | Treedepth |
 | TryGetObjectId(Handle, ObjectId%) |
 | TStackAlign |
 | TstackSize |
 | UcsBase |
 | Ucsname |
 | Ucsorg |
 | UcsOrthographic |
 | UcsTableId |
 | Ucsxdir |
 | Ucsydir |
 | Undo()()()() |
 | UndoRecording |
 | Unitmode |
 | UnloadXrefs(ObjectIdCollection) |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateExt(Boolean) |
 | Useri1 |
 | Useri2 |
 | Useri3 |
 | Useri4 |
 | Useri5 |
 | Userr1 |
 | Userr2 |
 | Userr3 |
 | Userr4 |
 | Userr5 |
 | Usrtimer |
 | VersionGuid |
 | ViewportScaleDefault |
 | ViewportTableId |
 | ViewTableId |
 | Visretain |
 | VisualStyleDictionaryId |
 | Wblock(Database, ObjectIdCollection, Point3d, DuplicateRecordCloning) |
 | Wblock(ObjectIdCollection, Point3d) |
 | Wblock(ObjectId) |
 | Wblock()()()() |
 | WblockAborted |
 | WblockCloneObjects(ObjectIdCollection, ObjectId, IdMapping, DuplicateRecordCloning, Boolean) |
 | WblockEnded |
 | WblockMappingAvailable |
 | WblockNotice |
 | WorldPaperspaceUcsBaseOrigin(OrthographicView) |
 | WorldUcsBaseOrigin(OrthographicView) |
 | Worldview |
 | X(RXClass) | (Inherited from RXObject.)
 | XBindXrefs(ObjectIdCollection, Boolean) |
 | XclipFrame |
 | XrefAttachAborted |
 | XrefAttachEnded |
 | XrefBeginAttached |
 | XrefBeginOtherAttached |
 | XrefBeginRestore |
 | XrefBlockId |
 | XrefComandeered |
 | XrefEditEnabled |
 | XrefPreXrefLockFile |
 | XrefRedirected |
 | XrefRestoreAborted |
 | XrefRestoreEnded |
 | XrefSubCommandAborted |
 | XrefSubCommandStart |
 | ZcadDatabase |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Database


Database Constructor

Database Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Database()()()()
Members
Icon | Member | Description
 | Database(Boolean, Boolean) |
 | Database()()()() |


Database Constructor

Database Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Database()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Database()
Public Sub New
public:
Database()


Database Constructor (buildDefaultDrawing, noDocument)

Database Constructor (buildDefaultDrawing, noDocument)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Database(Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Database(
    bool buildDefaultDrawing,
    bool noDocument
)
Public Sub New ( _
    buildDefaultDrawing As Boolean, _
    noDocument As Boolean _
)
public:
Database(
    bool buildDefaultDrawing,
    bool noDocument
)
Parameters
buildDefaultDrawing(Boolean)
noDocument(Boolean)


AbortDeepClone Method (idMap)

AbortDeepClone Method (idMap)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AbortDeepClone(IdMapping)
Declaration Syntax
C# Visual Basic Visual C++
public void AbortDeepClone(
    IdMapping idMap
)
Public Sub AbortDeepClone ( _
    idMap As IdMapping _
)
public:
void AbortDeepClone(
    IdMapping^ idMap
)
Parameters
idMap(IdMapping)


AbortDxfIn Event

AbortDxfIn Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AbortDxfIn
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler AbortDxfIn
Public Event AbortDxfIn As EventHandler
public:
 event EventHandler^ AbortDxfIn {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


AbortDxfOut Event

AbortDxfOut Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AbortDxfOut
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler AbortDxfOut
Public Event AbortDxfOut As EventHandler
public:
 event EventHandler^ AbortDxfOut {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


AbortSave Event

AbortSave Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AbortSave
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler AbortSave
Public Event AbortSave As EventHandler
public:
 event EventHandler^ AbortSave {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


AcadDatabase Property

AcadDatabase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AcadDatabase
Declaration Syntax
C# Visual Basic Visual C++
public Object AcadDatabase { get; }
Public ReadOnly Property AcadDatabase As Object
    Get
public:
property Object^ AcadDatabase {
    Object^ get ();
}


AddDBObject Method (appendIt)

AddDBObject Method (appendIt)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AddDBObject(DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AddDBObject(
    DBObject appendIt
)
Public Function AddDBObject ( _
    appendIt As DBObject _
) As ObjectId
public:
ObjectId AddDBObject(
    DBObject^ appendIt
)
Parameters
appendIt(DBObject)


AllowExtendedNames Property

AllowExtendedNames Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AllowExtendedNames
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowExtendedNames { get; set; }
Public Property AllowExtendedNames As Boolean
    Get
    Set
public:
property bool AllowExtendedNames {
    bool get ();
    void set (bool value);
}


Angbase Property

Angbase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Angbase
Declaration Syntax
C# Visual Basic Visual C++
public double Angbase { get; set; }
Public Property Angbase As Double
    Get
    Set
public:
property double Angbase {
    double get ();
    void set (double value);
}


Angdir Property

Angdir Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Angdir
Declaration Syntax
C# Visual Basic Visual C++
public bool Angdir { get; set; }
Public Property Angdir As Boolean
    Get
    Set
public:
property bool Angdir {
    bool get ();
    void set (bool value);
}


AnnoAllVisible Property

AnnoAllVisible Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AnnoAllVisible
Declaration Syntax
C# Visual Basic Visual C++
public bool AnnoAllVisible { get; set; }
Public Property AnnoAllVisible As Boolean
    Get
    Set
public:
property bool AnnoAllVisible {
    bool get ();
    void set (bool value);
}


AnnotativeDwg Property

AnnotativeDwg Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AnnotativeDwg
Declaration Syntax
C# Visual Basic Visual C++
public bool AnnotativeDwg { get; set; }
Public Property AnnotativeDwg As Boolean
    Get
    Set
public:
property bool AnnotativeDwg {
    bool get ();
    void set (bool value);
}


ApplyPartialOpenFilters Method (spatialFilter, layerFilter)

ApplyPartialOpenFilters Method (spatialFilter, layerFilter)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ApplyPartialOpenFilters(SpatialFilter, LayerFilter)
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyPartialOpenFilters(
    SpatialFilter spatialFilter,
    LayerFilter layerFilter
)
Public Sub ApplyPartialOpenFilters ( _
    spatialFilter As SpatialFilter, _
    layerFilter As LayerFilter _
)
public:
void ApplyPartialOpenFilters(
    SpatialFilter^ spatialFilter,
    LayerFilter^ layerFilter
)
Parameters
spatialFilter(SpatialFilter)
layerFilter(LayerFilter)


ApproxNumObjects Property

ApproxNumObjects Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ApproxNumObjects
Declaration Syntax
C# Visual Basic Visual C++
public int ApproxNumObjects { get; }
Public ReadOnly Property ApproxNumObjects As Integer
    Get
public:
property int ApproxNumObjects {
    int get ();
}


AttachXref Method (fileName, blockName)

AttachXref Method (fileName, blockName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AttachXref(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AttachXref(
    string fileName,
    string blockName
)
Public Function AttachXref ( _
    fileName As String, _
    blockName As String _
) As ObjectId
public:
ObjectId AttachXref(
    String^ fileName,
    String^ blockName
)
Parameters
fileName(String)
blockName(String)


Attmode Property

Attmode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Attmode
Declaration Syntax
C# Visual Basic Visual C++
public int Attmode { get; set; }
Public Property Attmode As Integer
    Get
    Set
public:
property int Attmode {
    int get ();
    void set (int value);
}


Audit Method (info)

Audit Method (info)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Audit(AuditInfo)
Declaration Syntax
C# Visual Basic Visual C++
public void Audit(
    AuditInfo info
)
Public Sub Audit ( _
    info As AuditInfo _
)
public:
void Audit(
    AuditInfo^ info
)
Parameters
info(AuditInfo)


AuditXData Method (info)

AuditXData Method (info)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »AuditXData(AuditInfo)
Declaration Syntax
C# Visual Basic Visual C++
public void AuditXData(
    AuditInfo info
)
Public Sub AuditXData ( _
    info As AuditInfo _
)
public:
void AuditXData(
    AuditInfo^ info
)
Parameters
info(AuditInfo)


Aunits Property

Aunits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Aunits
Declaration Syntax
C# Visual Basic Visual C++
public int Aunits { get; set; }
Public Property Aunits As Integer
    Get
    Set
public:
property int Aunits {
    int get ();
    void set (int value);
}


Auprec Property

Auprec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Auprec
Declaration Syntax
C# Visual Basic Visual C++
public int Auprec { get; set; }
Public Property Auprec As Integer
    Get
    Set
public:
property int Auprec {
    int get ();
    void set (int value);
}


BeginDeepClone Event

BeginDeepClone Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BeginDeepClone
Declaration Syntax
C# Visual Basic Visual C++
public event IdMappingEventHandler BeginDeepClone
Public Event BeginDeepClone As IdMappingEventHandler
public:
 event IdMappingEventHandler^ BeginDeepClone {
    void add (IdMappingEventHandler^ value);
    void remove (IdMappingEventHandler^ value);
}


BeginDeepCloneTranslation Event

BeginDeepCloneTranslation Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BeginDeepCloneTranslation
Declaration Syntax
C# Visual Basic Visual C++
public event IdMappingEventHandler BeginDeepCloneTranslation
Public Event BeginDeepCloneTranslation As IdMappingEventHandler
public:
 event IdMappingEventHandler^ BeginDeepCloneTranslation {
    void add (IdMappingEventHandler^ value);
    void remove (IdMappingEventHandler^ value);
}


BeginDxfIn Event

BeginDxfIn Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BeginDxfIn
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler BeginDxfIn
Public Event BeginDxfIn As EventHandler
public:
 event EventHandler^ BeginDxfIn {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


BeginDxfOut Event

BeginDxfOut Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BeginDxfOut
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler BeginDxfOut
Public Event BeginDxfOut As EventHandler
public:
 event EventHandler^ BeginDxfOut {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


BeginInsert Event

BeginInsert Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BeginInsert
Declaration Syntax
C# Visual Basic Visual C++
public event BeginInsertEventHandler BeginInsert
Public Event BeginInsert As BeginInsertEventHandler
public:
 event BeginInsertEventHandler^ BeginInsert {
    void add (BeginInsertEventHandler^ value);
    void remove (BeginInsertEventHandler^ value);
}


BeginSave Event

BeginSave Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BeginSave
Declaration Syntax
C# Visual Basic Visual C++
public event DatabaseIOEventHandler BeginSave
Public Event BeginSave As DatabaseIOEventHandler
public:
 event DatabaseIOEventHandler^ BeginSave {
    void add (DatabaseIOEventHandler^ value);
    void remove (DatabaseIOEventHandler^ value);
}


BeginWblockBlock Event

BeginWblockBlock Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BeginWblockBlock
Declaration Syntax
C# Visual Basic Visual C++
public event BeginWblockBlockEventHandler BeginWblockBlock
Public Event BeginWblockBlock As BeginWblockBlockEventHandler
public:
 event BeginWblockBlockEventHandler^ BeginWblockBlock {
    void add (BeginWblockBlockEventHandler^ value);
    void remove (BeginWblockBlockEventHandler^ value);
}


BeginWblockEntireDatabase Event

BeginWblockEntireDatabase Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BeginWblockEntireDatabase
Declaration Syntax
C# Visual Basic Visual C++
public event BeginWblockEntireDatabaseEventHandler BeginWblockEntireDatabase
Public Event BeginWblockEntireDatabase As BeginWblockEntireDatabaseEventHandler
public:
 event BeginWblockEntireDatabaseEventHandler^ BeginWblockEntireDatabase {
    void add (BeginWblockEntireDatabaseEventHandler^ value);
    void remove (BeginWblockEntireDatabaseEventHandler^ value);
}


BeginWblockObjects Event

BeginWblockObjects Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BeginWblockObjects
Declaration Syntax
C# Visual Basic Visual C++
public event BeginWblockObjectsEventHandler BeginWblockObjects
Public Event BeginWblockObjects As BeginWblockObjectsEventHandler
public:
 event BeginWblockObjectsEventHandler^ BeginWblockObjects {
    void add (BeginWblockObjectsEventHandler^ value);
    void remove (BeginWblockObjectsEventHandler^ value);
}


BeginWblockSelectedObjects Event

BeginWblockSelectedObjects Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BeginWblockSelectedObjects
Declaration Syntax
C# Visual Basic Visual C++
public event BeginWblockSelectedObjectsEventHandler BeginWblockSelectedObjects
Public Event BeginWblockSelectedObjects As BeginWblockSelectedObjectsEventHandler
public:
 event BeginWblockSelectedObjectsEventHandler^ BeginWblockSelectedObjects {
    void add (BeginWblockSelectedObjectsEventHandler^ value);
    void remove (BeginWblockSelectedObjectsEventHandler^ value);
}


BindXrefs Method (xrefIds, insertBind)

BindXrefs Method (xrefIds, insertBind)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BindXrefs(ObjectIdCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void BindXrefs(
    ObjectIdCollection xrefIds,
    bool insertBind
)
Public Sub BindXrefs ( _
    xrefIds As ObjectIdCollection, _
    insertBind As Boolean _
)
public:
void BindXrefs(
    ObjectIdCollection^ xrefIds,
    bool insertBind
)
Parameters
xrefIds(ObjectIdCollection)
insertBind(Boolean)


BlockTableId Property

BlockTableId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »BlockTableId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockTableId { get; }
Public ReadOnly Property BlockTableId As ObjectId
    Get
public:
property ObjectId BlockTableId {
    ObjectId get ();
}


ByBlockLinetype Property

ByBlockLinetype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ByBlockLinetype
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ByBlockLinetype { get; }
Public ReadOnly Property ByBlockLinetype As ObjectId
    Get
public:
property ObjectId ByBlockLinetype {
    ObjectId get ();
}


ByLayerLinetype Property

ByLayerLinetype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ByLayerLinetype
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ByLayerLinetype { get; }
Public ReadOnly Property ByLayerLinetype As ObjectId
    Get
public:
property ObjectId ByLayerLinetype {
    ObjectId get ();
}


CameraDisplay Property

CameraDisplay Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »CameraDisplay
Declaration Syntax
C# Visual Basic Visual C++
public bool CameraDisplay { get; set; }
Public Property CameraDisplay As Boolean
    Get
    Set
public:
property bool CameraDisplay {
    bool get ();
    void set (bool value);
}


CameraHeight Property

CameraHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »CameraHeight
Declaration Syntax
C# Visual Basic Visual C++
public double CameraHeight { get; set; }
Public Property CameraHeight As Double
    Get
    Set
public:
property double CameraHeight {
    double get ();
    void set (double value);
}


Cannoscale Property

Cannoscale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Cannoscale
Declaration Syntax
C# Visual Basic Visual C++
public AnnotationScale Cannoscale { get; set; }
Public Property Cannoscale As AnnotationScale
    Get
    Set
public:
property AnnotationScale^ Cannoscale {
    AnnotationScale^ get ();
    void set (AnnotationScale^ value);
}


Cecolor Property

Cecolor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Cecolor
Declaration Syntax
C# Visual Basic Visual C++
public Color Cecolor { get; set; }
Public Property Cecolor As Color
    Get
    Set
public:
property Color^ Cecolor {
    Color^ get ();
    void set (Color^ value);
}


Celtscale Property

Celtscale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Celtscale
Declaration Syntax
C# Visual Basic Visual C++
public double Celtscale { get; set; }
Public Property Celtscale As Double
    Get
    Set
public:
property double Celtscale {
    double get ();
    void set (double value);
}


Celtype Property

Celtype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Celtype
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Celtype { get; set; }
Public Property Celtype As ObjectId
    Get
    Set
public:
property ObjectId Celtype {
    ObjectId get ();
    void set (ObjectId value);
}


Celweight Property

Celweight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Celweight
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight Celweight { get; set; }
Public Property Celweight As LineWeight
    Get
    Set
public:
property LineWeight Celweight {
    LineWeight get ();
    void set (LineWeight value);
}


Chamfera Property

Chamfera Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Chamfera
Declaration Syntax
C# Visual Basic Visual C++
public double Chamfera { get; set; }
Public Property Chamfera As Double
    Get
    Set
public:
property double Chamfera {
    double get ();
    void set (double value);
}


Chamferb Property

Chamferb Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Chamferb
Declaration Syntax
C# Visual Basic Visual C++
public double Chamferb { get; set; }
Public Property Chamferb As Double
    Get
    Set
public:
property double Chamferb {
    double get ();
    void set (double value);
}


Chamferc Property

Chamferc Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Chamferc
Declaration Syntax
C# Visual Basic Visual C++
public double Chamferc { get; set; }
Public Property Chamferc As Double
    Get
    Set
public:
property double Chamferc {
    double get ();
    void set (double value);
}


Chamferd Property

Chamferd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Chamferd
Declaration Syntax
C# Visual Basic Visual C++
public double Chamferd { get; set; }
Public Property Chamferd As Double
    Get
    Set
public:
property double Chamferd {
    double get ();
    void set (double value);
}


ClassDxfName Method (getMyDxfName)

ClassDxfName Method (getMyDxfName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ClassDxfName(RXClass)
Declaration Syntax
C# Visual Basic Visual C++
public string ClassDxfName(
    RXClass getMyDxfName
)
Public Function ClassDxfName ( _
    getMyDxfName As RXClass _
) As String
public:
String^ ClassDxfName(
    RXClass^ getMyDxfName
)
Parameters
getMyDxfName(RXClass)


Clayer Property

Clayer Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Clayer
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Clayer { get; set; }
Public Property Clayer As ObjectId
    Get
    Set
public:
property ObjectId Clayer {
    ObjectId get ();
    void set (ObjectId value);
}


CloseInput Method (closeFile)

CloseInput Method (closeFile)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »CloseInput(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void CloseInput(
    bool closeFile
)
Public Sub CloseInput ( _
    closeFile As Boolean _
)
public:
void CloseInput(
    bool closeFile
)
Parameters
closeFile(Boolean)


Cmaterial Property

Cmaterial Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Cmaterial
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Cmaterial { get; set; }
Public Property Cmaterial As ObjectId
    Get
    Set
public:
property ObjectId Cmaterial {
    ObjectId get ();
    void set (ObjectId value);
}


Cmljust Property

Cmljust Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Cmljust
Declaration Syntax
C# Visual Basic Visual C++
public int Cmljust { get; set; }
Public Property Cmljust As Integer
    Get
    Set
public:
property int Cmljust {
    int get ();
    void set (int value);
}


Cmlscale Property

Cmlscale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Cmlscale
Declaration Syntax
C# Visual Basic Visual C++
public double Cmlscale { get; set; }
Public Property Cmlscale As Double
    Get
    Set
public:
property double Cmlscale {
    double get ();
    void set (double value);
}


CmlstyleID Property

CmlstyleID Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »CmlstyleID
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId CmlstyleID { get; set; }
Public Property CmlstyleID As ObjectId
    Get
    Set
public:
property ObjectId CmlstyleID {
    ObjectId get ();
    void set (ObjectId value);
}


ColorDictionaryId Property

ColorDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ColorDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ColorDictionaryId { get; }
Public ReadOnly Property ColorDictionaryId As ObjectId
    Get
public:
property ObjectId ColorDictionaryId {
    ObjectId get ();
}


ContinuousLinetype Property

ContinuousLinetype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ContinuousLinetype
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ContinuousLinetype { get; }
Public ReadOnly Property ContinuousLinetype As ObjectId
    Get
public:
property ObjectId ContinuousLinetype {
    ObjectId get ();
}


CountHardReferences Method (ids, count)

CountHardReferences Method (ids, count)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »CountHardReferences(ObjectIdCollection, array<Int32>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void CountHardReferences(
    ObjectIdCollection ids,
    int[] count
)
Public Sub CountHardReferences ( _
    ids As ObjectIdCollection, _
    count As Integer() _
)
public:
void CountHardReferences(
    ObjectIdCollection^ ids,
    array<int>^ count
)
Parameters
ids(ObjectIdCollection)
count(array<Int32>[]()[][])


Cshadow Property

Cshadow Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Cshadow
Declaration Syntax
C# Visual Basic Visual C++
public int Cshadow { get; set; }
Public Property Cshadow As Integer
    Get
    Set
public:
property int Cshadow {
    int get ();
    void set (int value);
}


CurrentSpaceId Property

CurrentSpaceId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »CurrentSpaceId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId CurrentSpaceId { get; }
Public ReadOnly Property CurrentSpaceId As ObjectId
    Get
public:
property ObjectId CurrentSpaceId {
    ObjectId get ();
}


CurrentViewportTableRecordId Property

CurrentViewportTableRecordId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »CurrentViewportTableRecordId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId CurrentViewportTableRecordId { get; }
Public ReadOnly Property CurrentViewportTableRecordId As ObjectId
    Get
public:
property ObjectId CurrentViewportTableRecordId {
    ObjectId get ();
}


DatabaseConstructed Event

DatabaseConstructed Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DatabaseConstructed
Declaration Syntax
C# Visual Basic Visual C++
public static event EventHandler DatabaseConstructed
Public Shared Event DatabaseConstructed As EventHandler
public:
static  event EventHandler^ DatabaseConstructed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


DatabaseToBeDestroyed Event

DatabaseToBeDestroyed Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DatabaseToBeDestroyed
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler DatabaseToBeDestroyed
Public Event DatabaseToBeDestroyed As EventHandler
public:
 event EventHandler^ DatabaseToBeDestroyed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


DeepCloneAborted Event

DeepCloneAborted Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DeepCloneAborted
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler DeepCloneAborted
Public Event DeepCloneAborted As EventHandler
public:
 event EventHandler^ DeepCloneAborted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


DeepCloneEnded Event

DeepCloneEnded Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DeepCloneEnded
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler DeepCloneEnded
Public Event DeepCloneEnded As EventHandler
public:
 event EventHandler^ DeepCloneEnded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


DeepCloneObjects Method (identifiers, id, mapping, deferTranslation)

DeepCloneObjects Method (identifiers, id, mapping, deferTranslation)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DeepCloneObjects(ObjectIdCollection, ObjectId, IdMapping, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void DeepCloneObjects(
    ObjectIdCollection identifiers,
    ObjectId id,
    IdMapping mapping,
    bool deferTranslation
)
Public Sub DeepCloneObjects ( _
    identifiers As ObjectIdCollection, _
    id As ObjectId, _
    mapping As IdMapping, _
    deferTranslation As Boolean _
)
public:
void DeepCloneObjects(
    ObjectIdCollection^ identifiers,
    ObjectId id,
    IdMapping^ mapping,
    bool deferTranslation
)
Parameters
identifiers(ObjectIdCollection)
id(ObjectId)
mapping(IdMapping)
deferTranslation(Boolean)


DetachXref Method (xrefId)

DetachXref Method (xrefId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DetachXref(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void DetachXref(
    ObjectId xrefId
)
Public Sub DetachXref ( _
    xrefId As ObjectId _
)
public:
void DetachXref(
    ObjectId xrefId
)
Parameters
xrefId(ObjectId)


Dimadec Property

Dimadec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimadec
Declaration Syntax
C# Visual Basic Visual C++
public int Dimadec { get; set; }
Public Property Dimadec As Integer
    Get
    Set
public:
property int Dimadec {
    int get ();
    void set (int value);
}


Dimalt Property

Dimalt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimalt
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimalt { get; set; }
Public Property Dimalt As Boolean
    Get
    Set
public:
property bool Dimalt {
    bool get ();
    void set (bool value);
}


Dimaltd Property

Dimaltd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimaltd
Declaration Syntax
C# Visual Basic Visual C++
public int Dimaltd { get; set; }
Public Property Dimaltd As Integer
    Get
    Set
public:
property int Dimaltd {
    int get ();
    void set (int value);
}


Dimaltf Property

Dimaltf Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimaltf
Declaration Syntax
C# Visual Basic Visual C++
public double Dimaltf { get; set; }
Public Property Dimaltf As Double
    Get
    Set
public:
property double Dimaltf {
    double get ();
    void set (double value);
}


Dimaltrnd Property

Dimaltrnd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimaltrnd
Declaration Syntax
C# Visual Basic Visual C++
public double Dimaltrnd { get; set; }
Public Property Dimaltrnd As Double
    Get
    Set
public:
property double Dimaltrnd {
    double get ();
    void set (double value);
}


Dimalttd Property

Dimalttd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimalttd
Declaration Syntax
C# Visual Basic Visual C++
public int Dimalttd { get; set; }
Public Property Dimalttd As Integer
    Get
    Set
public:
property int Dimalttd {
    int get ();
    void set (int value);
}


Dimalttz Property

Dimalttz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimalttz
Declaration Syntax
C# Visual Basic Visual C++
public int Dimalttz { get; set; }
Public Property Dimalttz As Integer
    Get
    Set
public:
property int Dimalttz {
    int get ();
    void set (int value);
}


Dimaltu Property

Dimaltu Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimaltu
Declaration Syntax
C# Visual Basic Visual C++
public int Dimaltu { get; set; }
Public Property Dimaltu As Integer
    Get
    Set
public:
property int Dimaltu {
    int get ();
    void set (int value);
}


Dimaltz Property

Dimaltz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimaltz
Declaration Syntax
C# Visual Basic Visual C++
public int Dimaltz { get; set; }
Public Property Dimaltz As Integer
    Get
    Set
public:
property int Dimaltz {
    int get ();
    void set (int value);
}


Dimapost Property

Dimapost Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimapost
Declaration Syntax
C# Visual Basic Visual C++
public string Dimapost { get; set; }
Public Property Dimapost As String
    Get
    Set
public:
property String^ Dimapost {
    String^ get ();
    void set (String^ value);
}


Dimarcsym Property

Dimarcsym Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimarcsym
Declaration Syntax
C# Visual Basic Visual C++
public int Dimarcsym { get; set; }
Public Property Dimarcsym As Integer
    Get
    Set
public:
property int Dimarcsym {
    int get ();
    void set (int value);
}


Dimaso Property

Dimaso Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimaso
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimaso { get; set; }
Public Property Dimaso As Boolean
    Get
    Set
public:
property bool Dimaso {
    bool get ();
    void set (bool value);
}


DimAssoc Property

DimAssoc Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DimAssoc
Declaration Syntax
C# Visual Basic Visual C++
public int DimAssoc { get; set; }
Public Property DimAssoc As Integer
    Get
    Set
public:
property int DimAssoc {
    int get ();
    void set (int value);
}


Dimasz Property

Dimasz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimasz
Declaration Syntax
C# Visual Basic Visual C++
public double Dimasz { get; set; }
Public Property Dimasz As Double
    Get
    Set
public:
property double Dimasz {
    double get ();
    void set (double value);
}


Dimatfit Property

Dimatfit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimatfit
Declaration Syntax
C# Visual Basic Visual C++
public int Dimatfit { get; set; }
Public Property Dimatfit As Integer
    Get
    Set
public:
property int Dimatfit {
    int get ();
    void set (int value);
}


Dimaunit Property

Dimaunit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimaunit
Declaration Syntax
C# Visual Basic Visual C++
public int Dimaunit { get; set; }
Public Property Dimaunit As Integer
    Get
    Set
public:
property int Dimaunit {
    int get ();
    void set (int value);
}


Dimazin Property

Dimazin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimazin
Declaration Syntax
C# Visual Basic Visual C++
public int Dimazin { get; set; }
Public Property Dimazin As Integer
    Get
    Set
public:
property int Dimazin {
    int get ();
    void set (int value);
}


Dimblk Property

Dimblk Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimblk
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimblk { get; set; }
Public Property Dimblk As ObjectId
    Get
    Set
public:
property ObjectId Dimblk {
    ObjectId get ();
    void set (ObjectId value);
}


Dimblk1 Property

Dimblk1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimblk1
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimblk1 { get; set; }
Public Property Dimblk1 As ObjectId
    Get
    Set
public:
property ObjectId Dimblk1 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimblk2 Property

Dimblk2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimblk2
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimblk2 { get; set; }
Public Property Dimblk2 As ObjectId
    Get
    Set
public:
property ObjectId Dimblk2 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimcen Property

Dimcen Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimcen
Declaration Syntax
C# Visual Basic Visual C++
public double Dimcen { get; set; }
Public Property Dimcen As Double
    Get
    Set
public:
property double Dimcen {
    double get ();
    void set (double value);
}


Dimclrd Property

Dimclrd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimclrd
Declaration Syntax
C# Visual Basic Visual C++
public Color Dimclrd { get; set; }
Public Property Dimclrd As Color
    Get
    Set
public:
property Color^ Dimclrd {
    Color^ get ();
    void set (Color^ value);
}


Dimclre Property

Dimclre Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimclre
Declaration Syntax
C# Visual Basic Visual C++
public Color Dimclre { get; set; }
Public Property Dimclre As Color
    Get
    Set
public:
property Color^ Dimclre {
    Color^ get ();
    void set (Color^ value);
}


Dimclrt Property

Dimclrt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimclrt
Declaration Syntax
C# Visual Basic Visual C++
public Color Dimclrt { get; set; }
Public Property Dimclrt As Color
    Get
    Set
public:
property Color^ Dimclrt {
    Color^ get ();
    void set (Color^ value);
}


Dimdec Property

Dimdec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimdec
Declaration Syntax
C# Visual Basic Visual C++
public int Dimdec { get; set; }
Public Property Dimdec As Integer
    Get
    Set
public:
property int Dimdec {
    int get ();
    void set (int value);
}


Dimdle Property

Dimdle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimdle
Declaration Syntax
C# Visual Basic Visual C++
public double Dimdle { get; set; }
Public Property Dimdle As Double
    Get
    Set
public:
property double Dimdle {
    double get ();
    void set (double value);
}


Dimdli Property

Dimdli Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimdli
Declaration Syntax
C# Visual Basic Visual C++
public double Dimdli { get; set; }
Public Property Dimdli As Double
    Get
    Set
public:
property double Dimdli {
    double get ();
    void set (double value);
}


Dimdsep Property

Dimdsep Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimdsep
Declaration Syntax
C# Visual Basic Visual C++
public char Dimdsep { get; set; }
Public Property Dimdsep As Char
    Get
    Set
public:
property wchar_t Dimdsep {
    wchar_t get ();
    void set (wchar_t value);
}


Dimexe Property

Dimexe Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimexe
Declaration Syntax
C# Visual Basic Visual C++
public double Dimexe { get; set; }
Public Property Dimexe As Double
    Get
    Set
public:
property double Dimexe {
    double get ();
    void set (double value);
}


Dimexo Property

Dimexo Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimexo
Declaration Syntax
C# Visual Basic Visual C++
public double Dimexo { get; set; }
Public Property Dimexo As Double
    Get
    Set
public:
property double Dimexo {
    double get ();
    void set (double value);
}


Dimfrac Property

Dimfrac Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimfrac
Declaration Syntax
C# Visual Basic Visual C++
public int Dimfrac { get; set; }
Public Property Dimfrac As Integer
    Get
    Set
public:
property int Dimfrac {
    int get ();
    void set (int value);
}


Dimfxlen Property

Dimfxlen Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimfxlen
Declaration Syntax
C# Visual Basic Visual C++
public double Dimfxlen { get; set; }
Public Property Dimfxlen As Double
    Get
    Set
public:
property double Dimfxlen {
    double get ();
    void set (double value);
}


DimfxlenOn Property

DimfxlenOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DimfxlenOn
Declaration Syntax
C# Visual Basic Visual C++
public bool DimfxlenOn { get; set; }
Public Property DimfxlenOn As Boolean
    Get
    Set
public:
property bool DimfxlenOn {
    bool get ();
    void set (bool value);
}


Dimgap Property

Dimgap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimgap
Declaration Syntax
C# Visual Basic Visual C++
public double Dimgap { get; set; }
Public Property Dimgap As Double
    Get
    Set
public:
property double Dimgap {
    double get ();
    void set (double value);
}


Dimjogang Property

Dimjogang Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimjogang
Declaration Syntax
C# Visual Basic Visual C++
public double Dimjogang { get; set; }
Public Property Dimjogang As Double
    Get
    Set
public:
property double Dimjogang {
    double get ();
    void set (double value);
}


Dimjust Property

Dimjust Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimjust
Declaration Syntax
C# Visual Basic Visual C++
public int Dimjust { get; set; }
Public Property Dimjust As Integer
    Get
    Set
public:
property int Dimjust {
    int get ();
    void set (int value);
}


Dimldrblk Property

Dimldrblk Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimldrblk
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimldrblk { get; set; }
Public Property Dimldrblk As ObjectId
    Get
    Set
public:
property ObjectId Dimldrblk {
    ObjectId get ();
    void set (ObjectId value);
}


Dimlfac Property

Dimlfac Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimlfac
Declaration Syntax
C# Visual Basic Visual C++
public double Dimlfac { get; set; }
Public Property Dimlfac As Double
    Get
    Set
public:
property double Dimlfac {
    double get ();
    void set (double value);
}


Dimlim Property

Dimlim Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimlim
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimlim { get; set; }
Public Property Dimlim As Boolean
    Get
    Set
public:
property bool Dimlim {
    bool get ();
    void set (bool value);
}


Dimltex1 Property

Dimltex1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimltex1
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimltex1 { get; set; }
Public Property Dimltex1 As ObjectId
    Get
    Set
public:
property ObjectId Dimltex1 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimltex2 Property

Dimltex2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimltex2
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimltex2 { get; set; }
Public Property Dimltex2 As ObjectId
    Get
    Set
public:
property ObjectId Dimltex2 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimltype Property

Dimltype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimltype
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimltype { get; set; }
Public Property Dimltype As ObjectId
    Get
    Set
public:
property ObjectId Dimltype {
    ObjectId get ();
    void set (ObjectId value);
}


Dimlunit Property

Dimlunit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimlunit
Declaration Syntax
C# Visual Basic Visual C++
public int Dimlunit { get; set; }
Public Property Dimlunit As Integer
    Get
    Set
public:
property int Dimlunit {
    int get ();
    void set (int value);
}


Dimlwd Property

Dimlwd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimlwd
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight Dimlwd { get; set; }
Public Property Dimlwd As LineWeight
    Get
    Set
public:
property LineWeight Dimlwd {
    LineWeight get ();
    void set (LineWeight value);
}


Dimlwe Property

Dimlwe Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimlwe
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight Dimlwe { get; set; }
Public Property Dimlwe As LineWeight
    Get
    Set
public:
property LineWeight Dimlwe {
    LineWeight get ();
    void set (LineWeight value);
}


Dimpost Property

Dimpost Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimpost
Declaration Syntax
C# Visual Basic Visual C++
public string Dimpost { get; set; }
Public Property Dimpost As String
    Get
    Set
public:
property String^ Dimpost {
    String^ get ();
    void set (String^ value);
}


Dimrnd Property

Dimrnd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimrnd
Declaration Syntax
C# Visual Basic Visual C++
public double Dimrnd { get; set; }
Public Property Dimrnd As Double
    Get
    Set
public:
property double Dimrnd {
    double get ();
    void set (double value);
}


Dimsah Property

Dimsah Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimsah
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimsah { get; set; }
Public Property Dimsah As Boolean
    Get
    Set
public:
property bool Dimsah {
    bool get ();
    void set (bool value);
}


Dimscale Property

Dimscale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimscale
Declaration Syntax
C# Visual Basic Visual C++
public double Dimscale { get; set; }
Public Property Dimscale As Double
    Get
    Set
public:
property double Dimscale {
    double get ();
    void set (double value);
}


Dimsd1 Property

Dimsd1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimsd1
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimsd1 { get; set; }
Public Property Dimsd1 As Boolean
    Get
    Set
public:
property bool Dimsd1 {
    bool get ();
    void set (bool value);
}


Dimsd2 Property

Dimsd2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimsd2
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimsd2 { get; set; }
Public Property Dimsd2 As Boolean
    Get
    Set
public:
property bool Dimsd2 {
    bool get ();
    void set (bool value);
}


Dimse1 Property

Dimse1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimse1
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimse1 { get; set; }
Public Property Dimse1 As Boolean
    Get
    Set
public:
property bool Dimse1 {
    bool get ();
    void set (bool value);
}


Dimse2 Property

Dimse2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimse2
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimse2 { get; set; }
Public Property Dimse2 As Boolean
    Get
    Set
public:
property bool Dimse2 {
    bool get ();
    void set (bool value);
}


Dimsoxd Property

Dimsoxd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimsoxd
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimsoxd { get; set; }
Public Property Dimsoxd As Boolean
    Get
    Set
public:
property bool Dimsoxd {
    bool get ();
    void set (bool value);
}


Dimstyle Property

Dimstyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimstyle
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimstyle { get; set; }
Public Property Dimstyle As ObjectId
    Get
    Set
public:
property ObjectId Dimstyle {
    ObjectId get ();
    void set (ObjectId value);
}


DimstyleData Property

DimstyleData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DimstyleData
Declaration Syntax
C# Visual Basic Visual C++
public DimStyleTableRecord DimstyleData { get; set; }
Public Property DimstyleData As DimStyleTableRecord
    Get
    Set
public:
property DimStyleTableRecord^ DimstyleData {
    DimStyleTableRecord^ get ();
    void set (DimStyleTableRecord^ value);
}


DimStyleTableId Property

DimStyleTableId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DimStyleTableId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId DimStyleTableId { get; }
Public ReadOnly Property DimStyleTableId As ObjectId
    Get
public:
property ObjectId DimStyleTableId {
    ObjectId get ();
}


Dimtad Property

Dimtad Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtad
Declaration Syntax
C# Visual Basic Visual C++
public int Dimtad { get; set; }
Public Property Dimtad As Integer
    Get
    Set
public:
property int Dimtad {
    int get ();
    void set (int value);
}


Dimtdec Property

Dimtdec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtdec
Declaration Syntax
C# Visual Basic Visual C++
public int Dimtdec { get; set; }
Public Property Dimtdec As Integer
    Get
    Set
public:
property int Dimtdec {
    int get ();
    void set (int value);
}


Dimtfac Property

Dimtfac Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtfac
Declaration Syntax
C# Visual Basic Visual C++
public double Dimtfac { get; set; }
Public Property Dimtfac As Double
    Get
    Set
public:
property double Dimtfac {
    double get ();
    void set (double value);
}


Dimtfill Property

Dimtfill Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtfill
Declaration Syntax
C# Visual Basic Visual C++
public int Dimtfill { get; set; }
Public Property Dimtfill As Integer
    Get
    Set
public:
property int Dimtfill {
    int get ();
    void set (int value);
}


Dimtfillclr Property

Dimtfillclr Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtfillclr
Declaration Syntax
C# Visual Basic Visual C++
public Color Dimtfillclr { get; set; }
Public Property Dimtfillclr As Color
    Get
    Set
public:
property Color^ Dimtfillclr {
    Color^ get ();
    void set (Color^ value);
}


Dimtih Property

Dimtih Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtih
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimtih { get; set; }
Public Property Dimtih As Boolean
    Get
    Set
public:
property bool Dimtih {
    bool get ();
    void set (bool value);
}


Dimtix Property

Dimtix Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtix
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimtix { get; set; }
Public Property Dimtix As Boolean
    Get
    Set
public:
property bool Dimtix {
    bool get ();
    void set (bool value);
}


Dimtm Property

Dimtm Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtm
Declaration Syntax
C# Visual Basic Visual C++
public double Dimtm { get; set; }
Public Property Dimtm As Double
    Get
    Set
public:
property double Dimtm {
    double get ();
    void set (double value);
}


Dimtmove Property

Dimtmove Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtmove
Declaration Syntax
C# Visual Basic Visual C++
public int Dimtmove { get; set; }
Public Property Dimtmove As Integer
    Get
    Set
public:
property int Dimtmove {
    int get ();
    void set (int value);
}


Dimtofl Property

Dimtofl Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtofl
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimtofl { get; set; }
Public Property Dimtofl As Boolean
    Get
    Set
public:
property bool Dimtofl {
    bool get ();
    void set (bool value);
}


Dimtoh Property

Dimtoh Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtoh
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimtoh { get; set; }
Public Property Dimtoh As Boolean
    Get
    Set
public:
property bool Dimtoh {
    bool get ();
    void set (bool value);
}


Dimtol Property

Dimtol Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtol
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimtol { get; set; }
Public Property Dimtol As Boolean
    Get
    Set
public:
property bool Dimtol {
    bool get ();
    void set (bool value);
}


Dimtolj Property

Dimtolj Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtolj
Declaration Syntax
C# Visual Basic Visual C++
public int Dimtolj { get; set; }
Public Property Dimtolj As Integer
    Get
    Set
public:
property int Dimtolj {
    int get ();
    void set (int value);
}


Dimtp Property

Dimtp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtp
Declaration Syntax
C# Visual Basic Visual C++
public double Dimtp { get; set; }
Public Property Dimtp As Double
    Get
    Set
public:
property double Dimtp {
    double get ();
    void set (double value);
}


Dimtsz Property

Dimtsz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtsz
Declaration Syntax
C# Visual Basic Visual C++
public double Dimtsz { get; set; }
Public Property Dimtsz As Double
    Get
    Set
public:
property double Dimtsz {
    double get ();
    void set (double value);
}


Dimtvp Property

Dimtvp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtvp
Declaration Syntax
C# Visual Basic Visual C++
public double Dimtvp { get; set; }
Public Property Dimtvp As Double
    Get
    Set
public:
property double Dimtvp {
    double get ();
    void set (double value);
}


Dimtxsty Property

Dimtxsty Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtxsty
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimtxsty { get; set; }
Public Property Dimtxsty As ObjectId
    Get
    Set
public:
property ObjectId Dimtxsty {
    ObjectId get ();
    void set (ObjectId value);
}


Dimtxt Property

Dimtxt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtxt
Declaration Syntax
C# Visual Basic Visual C++
public double Dimtxt { get; set; }
Public Property Dimtxt As Double
    Get
    Set
public:
property double Dimtxt {
    double get ();
    void set (double value);
}


Dimtxtdirection Property

Dimtxtdirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtxtdirection
Declaration Syntax
C# Visual Basic Visual C++
public double Dimtxtdirection { get; set; }
Public Property Dimtxtdirection As Double
    Get
    Set
public:
property double Dimtxtdirection {
    double get ();
    void set (double value);
}


Dimtzin Property

Dimtzin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimtzin
Declaration Syntax
C# Visual Basic Visual C++
public int Dimtzin { get; set; }
Public Property Dimtzin As Integer
    Get
    Set
public:
property int Dimtzin {
    int get ();
    void set (int value);
}


Dimupt Property

Dimupt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimupt
Declaration Syntax
C# Visual Basic Visual C++
public bool Dimupt { get; set; }
Public Property Dimupt As Boolean
    Get
    Set
public:
property bool Dimupt {
    bool get ();
    void set (bool value);
}


Dimzin Property

Dimzin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dimzin
Declaration Syntax
C# Visual Basic Visual C++
public int Dimzin { get; set; }
Public Property Dimzin As Integer
    Get
    Set
public:
property int Dimzin {
    int get ();
    void set (int value);
}


DisablePartialOpen Method

DisablePartialOpen Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DisablePartialOpen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void DisablePartialOpen()
Public Sub DisablePartialOpen
public:
void DisablePartialOpen()


DisableUndoRecording Method (disable)

DisableUndoRecording Method (disable)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DisableUndoRecording(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void DisableUndoRecording(
    bool disable
)
Public Sub DisableUndoRecording ( _
    disable As Boolean _
)
public:
void DisableUndoRecording(
    bool disable
)
Parameters
disable(Boolean)


Disposed Event

Disposed Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Disposed
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Disposed
Public Event Disposed As EventHandler
public:
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


DispSilh Property

DispSilh Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DispSilh
Declaration Syntax
C# Visual Basic Visual C++
public bool DispSilh { get; set; }
Public Property DispSilh As Boolean
    Get
    Set
public:
property bool DispSilh {
    bool get ();
    void set (bool value);
}


DrawOrderCtl Property

DrawOrderCtl Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DrawOrderCtl
Declaration Syntax
C# Visual Basic Visual C++
public byte DrawOrderCtl { get; set; }
Public Property DrawOrderCtl As Byte
    Get
    Set
public:
property unsigned char DrawOrderCtl {
    unsigned char get ();
    void set (unsigned char value);
}


DwgFileOpened Event

DwgFileOpened Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DwgFileOpened
Declaration Syntax
C# Visual Basic Visual C++
public event DatabaseIOEventHandler DwgFileOpened
Public Event DwgFileOpened As DatabaseIOEventHandler
public:
 event DatabaseIOEventHandler^ DwgFileOpened {
    void add (DatabaseIOEventHandler^ value);
    void remove (DatabaseIOEventHandler^ value);
}


DwgFileWasSavedByZwSoftSoftware Property

DwgFileWasSavedByZwSoftSoftware Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DwgFileWasSavedByZwSoftSoftware
Declaration Syntax
C# Visual Basic Visual C++
public bool DwgFileWasSavedByZwSoftSoftware { get; }
Public ReadOnly Property DwgFileWasSavedByZwSoftSoftware As Boolean
    Get
public:
property bool DwgFileWasSavedByZwSoftSoftware {
    bool get ();
}


DxfIn Method (fileName, logFilename)

DxfIn Method (fileName, logFilename)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DxfIn(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void DxfIn(
    string fileName,
    string logFilename
)
Public Sub DxfIn ( _
    fileName As String, _
    logFilename As String _
)
public:
void DxfIn(
    String^ fileName,
    String^ logFilename
)
Parameters
fileName(String)
logFilename(String)


DxfInComplete Event

DxfInComplete Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DxfInComplete
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler DxfInComplete
Public Event DxfInComplete As EventHandler
public:
 event EventHandler^ DxfInComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


DxfOut Method (fileName, precision, version, saveThumbnailImage)

DxfOut Method (fileName, precision, version, saveThumbnailImage)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DxfOut(String, Int32, DwgVersion, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void DxfOut(
    string fileName,
    int precision,
    DwgVersion version,
    bool saveThumbnailImage
)
Public Sub DxfOut ( _
    fileName As String, _
    precision As Integer, _
    version As DwgVersion, _
    saveThumbnailImage As Boolean _
)
public:
void DxfOut(
    String^ fileName,
    int precision,
    DwgVersion version,
    bool saveThumbnailImage
)
Parameters
fileName(String)
precision(Int32)
version(DwgVersion)
saveThumbnailImage(Boolean)


DxfOutComplete Event

DxfOutComplete Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »DxfOutComplete
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler DxfOutComplete
Public Event DxfOutComplete As EventHandler
public:
 event EventHandler^ DxfOutComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Elevation Property

Elevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Elevation
Declaration Syntax
C# Visual Basic Visual C++
public double Elevation { get; set; }
Public Property Elevation As Double
    Get
    Set
public:
property double Elevation {
    double get ();
    void set (double value);
}


EndCaps Property

EndCaps Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »EndCaps
Declaration Syntax
C# Visual Basic Visual C++
public EndCap EndCaps { get; set; }
Public Property EndCaps As EndCap
    Get
    Set
public:
property EndCap EndCaps {
    EndCap get ();
    void set (EndCap value);
}


Extmax Property

Extmax Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Extmax
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Extmax { get; set; }
Public Property Extmax As Point3d
    Get
    Set
public:
property Point3d Extmax {
    Point3d get ();
    void set (Point3d value);
}


Extmin Property

Extmin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Extmin
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Extmin { get; set; }
Public Property Extmin As Point3d
    Get
    Set
public:
property Point3d Extmin {
    Point3d get ();
    void set (Point3d value);
}


Facetres Property

Facetres Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Facetres
Declaration Syntax
C# Visual Basic Visual C++
public double Facetres { get; set; }
Public Property Facetres As Double
    Get
    Set
public:
property double Facetres {
    double get ();
    void set (double value);
}


FileDependencyManager Property

FileDependencyManager Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »FileDependencyManager
Declaration Syntax
C# Visual Basic Visual C++
public FileDependencyManager FileDependencyManager { get; }
Public ReadOnly Property FileDependencyManager As FileDependencyManager
    Get
public:
property FileDependencyManager^ FileDependencyManager {
    FileDependencyManager^ get ();
}


Filename Property

Filename Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Filename
Declaration Syntax
C# Visual Basic Visual C++
public string Filename { get; }
Public ReadOnly Property Filename As String
    Get
public:
property String^ Filename {
    String^ get ();
}


Filletrad Property

Filletrad Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Filletrad
Declaration Syntax
C# Visual Basic Visual C++
public double Filletrad { get; set; }
Public Property Filletrad As Double
    Get
    Set
public:
property double Filletrad {
    double get ();
    void set (double value);
}


Fillmode Property

Fillmode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Fillmode
Declaration Syntax
C# Visual Basic Visual C++
public bool Fillmode { get; set; }
Public Property Fillmode As Boolean
    Get
    Set
public:
property bool Fillmode {
    bool get ();
    void set (bool value);
}


FingerprintGuid Property

FingerprintGuid Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »FingerprintGuid
Declaration Syntax
C# Visual Basic Visual C++
public string FingerprintGuid { get; set; }
Public Property FingerprintGuid As String
    Get
    Set
public:
property String^ FingerprintGuid {
    String^ get ();
    void set (String^ value);
}


ForceWblockDatabaseCopy Method

ForceWblockDatabaseCopy Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ForceWblockDatabaseCopy()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ForceWblockDatabaseCopy()
Public Sub ForceWblockDatabaseCopy
public:
void ForceWblockDatabaseCopy()


FromAcadDatabase Method (acadDatabase)

FromAcadDatabase Method (acadDatabase)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »FromAcadDatabase(Object)
Declaration Syntax
C# Visual Basic Visual C++
public static Database FromAcadDatabase(
    Object acadDatabase
)
Public Shared Function FromAcadDatabase ( _
    acadDatabase As Object _
) As Database
public:
static Database^ FromAcadDatabase(
    Object^ acadDatabase
)
Parameters
acadDatabase(Object)


GetAllDatabases Method

GetAllDatabases Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetAllDatabases()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static List<Database> GetAllDatabases()
Public Shared Function GetAllDatabases As List(Of Database)
public:
static List<Database^>^ GetAllDatabases()


GetDimensionStyleChildData Method (classDescriptor)

GetDimensionStyleChildData Method (classDescriptor)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetDimensionStyleChildData(RXClass)
Declaration Syntax
C# Visual Basic Visual C++
public DimStyleTableRecord GetDimensionStyleChildData(
    RXClass classDescriptor
)
Public Function GetDimensionStyleChildData ( _
    classDescriptor As RXClass _
) As DimStyleTableRecord
public:
DimStyleTableRecord^ GetDimensionStyleChildData(
    RXClass^ classDescriptor
)
Parameters
classDescriptor(RXClass)


GetDimensionStyleChildId Method (classDescriptor, parentStyle)

GetDimensionStyleChildId Method (classDescriptor, parentStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetDimensionStyleChildId(RXClass, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetDimensionStyleChildId(
    RXClass classDescriptor,
    ObjectId parentStyle
)
Public Function GetDimensionStyleChildId ( _
    classDescriptor As RXClass, _
    parentStyle As ObjectId _
) As ObjectId
public:
ObjectId GetDimensionStyleChildId(
    RXClass^ classDescriptor,
    ObjectId parentStyle
)
Parameters
classDescriptor(RXClass)
parentStyle(ObjectId)


GetDimensionStyleParentId Method (childStyle)

GetDimensionStyleParentId Method (childStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetDimensionStyleParentId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetDimensionStyleParentId(
    ObjectId childStyle
)
Public Function GetDimensionStyleParentId ( _
    childStyle As ObjectId _
) As ObjectId
public:
ObjectId GetDimensionStyleParentId(
    ObjectId childStyle
)
Parameters
childStyle(ObjectId)


GetDimRecentStyleList Method

GetDimRecentStyleList Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetDimRecentStyleList()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetDimRecentStyleList()
Public Function GetDimRecentStyleList As ObjectIdCollection
public:
ObjectIdCollection^ GetDimRecentStyleList()


GetDimstyleData Method

GetDimstyleData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetDimstyleData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DimStyleTableRecord GetDimstyleData()
Public Function GetDimstyleData As DimStyleTableRecord
public:
DimStyleTableRecord^ GetDimstyleData()


GetHostDwgXrefGraph Method (includeGhosts)

GetHostDwgXrefGraph Method (includeGhosts)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetHostDwgXrefGraph(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public XrefGraph GetHostDwgXrefGraph(
    bool includeGhosts
)
Public Function GetHostDwgXrefGraph ( _
    includeGhosts As Boolean _
) As XrefGraph
public:
XrefGraph^ GetHostDwgXrefGraph(
    bool includeGhosts
)
Parameters
includeGhosts(Boolean)


GetNearestLineWeight Method (weight)

GetNearestLineWeight Method (weight)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetNearestLineWeight(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight GetNearestLineWeight(
    int weight
)
Public Function GetNearestLineWeight ( _
    weight As Integer _
) As LineWeight
public:
LineWeight GetNearestLineWeight(
    int weight
)
Parameters
weight(Int32)


GetObjectId Method (createIfNotFound, objHandle, identifier)

GetObjectId Method (createIfNotFound, objHandle, identifier)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetObjectId(Boolean, Handle, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetObjectId(
    bool createIfNotFound,
    Handle objHandle,
    int identifier
)
Public Function GetObjectId ( _
    createIfNotFound As Boolean, _
    objHandle As Handle, _
    identifier As Integer _
) As ObjectId
public:
ObjectId GetObjectId(
    bool createIfNotFound,
    Handle objHandle,
    int identifier
)
Parameters
createIfNotFound(Boolean)
objHandle(Handle)
identifier(Int32)


GetSupportedDxfOutVersions Method

GetSupportedDxfOutVersions Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetSupportedDxfOutVersions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DwgVersion[] GetSupportedDxfOutVersions()
Public Function GetSupportedDxfOutVersions As DwgVersion()
public:
array<DwgVersion>^ GetSupportedDxfOutVersions()


GetSupportedSaveVersions Method

GetSupportedSaveVersions Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetSupportedSaveVersions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DwgVersion[] GetSupportedSaveVersions()
Public Function GetSupportedSaveVersions As DwgVersion()
public:
array<DwgVersion>^ GetSupportedSaveVersions()


GetViewports Method (bGetPaperspaceVports)

GetViewports Method (bGetPaperspaceVports)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetViewports(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetViewports(
    bool bGetPaperspaceVports
)
Public Function GetViewports ( _
    bGetPaperspaceVports As Boolean _
) As ObjectIdCollection
public:
ObjectIdCollection^ GetViewports(
    bool bGetPaperspaceVports
)
Parameters
bGetPaperspaceVports(Boolean)


GetVisualStyleList Method

GetVisualStyleList Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GetVisualStyleList()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection GetVisualStyleList()
Public Function GetVisualStyleList As StringCollection
public:
StringCollection^ GetVisualStyleList()


GroupDictionaryId Property

GroupDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »GroupDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GroupDictionaryId { get; }
Public ReadOnly Property GroupDictionaryId As ObjectId
    Get
public:
property ObjectId GroupDictionaryId {
    ObjectId get ();
}


HaloGap Property

HaloGap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »HaloGap
Declaration Syntax
C# Visual Basic Visual C++
public int HaloGap { get; set; }
Public Property HaloGap As Integer
    Get
    Set
public:
property int HaloGap {
    int get ();
    void set (int value);
}


Handseed Property

Handseed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Handseed
Declaration Syntax
C# Visual Basic Visual C++
public Handle Handseed { get; }
Public ReadOnly Property Handseed As Handle
    Get
public:
property Handle Handseed {
    Handle get ();
}


HasRedo Property

HasRedo Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »HasRedo
Declaration Syntax
C# Visual Basic Visual C++
public bool HasRedo { get; }
Public ReadOnly Property HasRedo As Boolean
    Get
public:
property bool HasRedo {
    bool get ();
}


HasUndo Property

HasUndo Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »HasUndo
Declaration Syntax
C# Visual Basic Visual C++
public bool HasUndo { get; }
Public ReadOnly Property HasUndo As Boolean
    Get
public:
property bool HasUndo {
    bool get ();
}


HideText Property

HideText Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »HideText
Declaration Syntax
C# Visual Basic Visual C++
public int HideText { get; set; }
Public Property HideText As Integer
    Get
    Set
public:
property int HideText {
    int get ();
    void set (int value);
}


HpInherit Property

HpInherit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »HpInherit
Declaration Syntax
C# Visual Basic Visual C++
public bool HpInherit { get; set; }
Public Property HpInherit As Boolean
    Get
    Set
public:
property bool HpInherit {
    bool get ();
    void set (bool value);
}


HpOrigin Property

HpOrigin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »HpOrigin
Declaration Syntax
C# Visual Basic Visual C++
public Point2d HpOrigin { get; set; }
Public Property HpOrigin As Point2d
    Get
    Set
public:
property Point2d HpOrigin {
    Point2d get ();
    void set (Point2d value);
}


HyperlinkBase Property

HyperlinkBase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »HyperlinkBase
Declaration Syntax
C# Visual Basic Visual C++
public string HyperlinkBase { get; set; }
Public Property HyperlinkBase As String
    Get
    Set
public:
property String^ HyperlinkBase {
    String^ get ();
    void set (String^ value);
}


InitialDwgFileOpenComplete Event

InitialDwgFileOpenComplete Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »InitialDwgFileOpenComplete
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler InitialDwgFileOpenComplete
Public Event InitialDwgFileOpenComplete As EventHandler
public:
 event EventHandler^ InitialDwgFileOpenComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Insbase Property

Insbase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Insbase
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Insbase { get; set; }
Public Property Insbase As Point3d
    Get
    Set
public:
property Point3d Insbase {
    Point3d get ();
    void set (Point3d value);
}


Insert Method

Insert Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Insert()()()()
Members
Icon | Member | Description
 | Insert(String, String, Database, Boolean) |
 | Insert(String, Database, Boolean) |
 | Insert(Matrix3d, Database, Boolean) |


Insert Method (sourceBlockName, destinationBlockName, dataBase, preserveSourceDatabase)

Insert Method (sourceBlockName, destinationBlockName, dataBase, preserveSourceDatabase)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Insert(String, String, Database, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Insert(
    string sourceBlockName,
    string destinationBlockName,
    Database dataBase,
    bool preserveSourceDatabase
)
Public Function Insert ( _
    sourceBlockName As String, _
    destinationBlockName As String, _
    dataBase As Database, _
    preserveSourceDatabase As Boolean _
) As ObjectId
public:
ObjectId Insert(
    String^ sourceBlockName,
    String^ destinationBlockName,
    Database^ dataBase,
    bool preserveSourceDatabase
)
Parameters
sourceBlockName(String)
destinationBlockName(String)
dataBase(Database)
preserveSourceDatabase(Boolean)


Insert Method (blockName, dataBase, preserveSourceDatabase)

Insert Method (blockName, dataBase, preserveSourceDatabase)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Insert(String, Database, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Insert(
    string blockName,
    Database dataBase,
    bool preserveSourceDatabase
)
Public Function Insert ( _
    blockName As String, _
    dataBase As Database, _
    preserveSourceDatabase As Boolean _
) As ObjectId
public:
ObjectId Insert(
    String^ blockName,
    Database^ dataBase,
    bool preserveSourceDatabase
)
Parameters
blockName(String)
dataBase(Database)
preserveSourceDatabase(Boolean)


Insert Method (transform, dataBase, preserveSourceDatabase)

Insert Method (transform, dataBase, preserveSourceDatabase)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Insert(Matrix3d, Database, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    Matrix3d transform,
    Database dataBase,
    bool preserveSourceDatabase
)
Public Sub Insert ( _
    transform As Matrix3d, _
    dataBase As Database, _
    preserveSourceDatabase As Boolean _
)
public:
void Insert(
    Matrix3d transform,
    Database^ dataBase,
    bool preserveSourceDatabase
)
Parameters
transform(Matrix3d)
dataBase(Database)
preserveSourceDatabase(Boolean)


InsertAborted Event

InsertAborted Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »InsertAborted
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler InsertAborted
Public Event InsertAborted As EventHandler
public:
 event EventHandler^ InsertAborted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


InsertEnded Event

InsertEnded Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »InsertEnded
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler InsertEnded
Public Event InsertEnded As EventHandler
public:
 event EventHandler^ InsertEnded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


InsertMappingAvailable Event

InsertMappingAvailable Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »InsertMappingAvailable
Declaration Syntax
C# Visual Basic Visual C++
public event IdMappingEventHandler InsertMappingAvailable
Public Event InsertMappingAvailable As IdMappingEventHandler
public:
 event IdMappingEventHandler^ InsertMappingAvailable {
    void add (IdMappingEventHandler^ value);
    void remove (IdMappingEventHandler^ value);
}


Insunits Property

Insunits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Insunits
Declaration Syntax
C# Visual Basic Visual C++
public UnitsValue Insunits { get; set; }
Public Property Insunits As UnitsValue
    Get
    Set
public:
property UnitsValue Insunits {
    UnitsValue get ();
    void set (UnitsValue value);
}


Interferecolor Property

Interferecolor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Interferecolor
Declaration Syntax
C# Visual Basic Visual C++
public Color Interferecolor { get; set; }
Public Property Interferecolor As Color
    Get
    Set
public:
property Color^ Interferecolor {
    Color^ get ();
    void set (Color^ value);
}


Interfereobjvs Property

Interfereobjvs Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Interfereobjvs
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Interfereobjvs { get; set; }
Public Property Interfereobjvs As ObjectId
    Get
    Set
public:
property ObjectId Interfereobjvs {
    ObjectId get ();
    void set (ObjectId value);
}


Interferevpvs Property

Interferevpvs Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Interferevpvs
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Interferevpvs { get; set; }
Public Property Interferevpvs As ObjectId
    Get
    Set
public:
property ObjectId Interferevpvs {
    ObjectId get ();
    void set (ObjectId value);
}


IntersectColor Property

IntersectColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »IntersectColor
Declaration Syntax
C# Visual Basic Visual C++
public int IntersectColor { get; set; }
Public Property IntersectColor As Integer
    Get
    Set
public:
property int IntersectColor {
    int get ();
    void set (int value);
}


IntersectDisplay Property

IntersectDisplay Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »IntersectDisplay
Declaration Syntax
C# Visual Basic Visual C++
public int IntersectDisplay { get; set; }
Public Property IntersectDisplay As Integer
    Get
    Set
public:
property int IntersectDisplay {
    int get ();
    void set (int value);
}


IsEmr Property

IsEmr Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »IsEmr
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEmr { get; }
Public ReadOnly Property IsEmr As Boolean
    Get
public:
property bool IsEmr {
    bool get ();
}


IsObjectNonPersistent Method (id)

IsObjectNonPersistent Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »IsObjectNonPersistent(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsObjectNonPersistent(
    ObjectId id
)
Public Shared Function IsObjectNonPersistent ( _
    id As ObjectId _
) As Boolean
public:
static bool IsObjectNonPersistent(
    ObjectId id
)
Parameters
id(ObjectId)


Isolines Property

Isolines Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Isolines
Declaration Syntax
C# Visual Basic Visual C++
public int Isolines { get; set; }
Public Property Isolines As Integer
    Get
    Set
public:
property int Isolines {
    int get ();
    void set (int value);
}


IsPartiallyOpened Property

IsPartiallyOpened Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »IsPartiallyOpened
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPartiallyOpened { get; }
Public ReadOnly Property IsPartiallyOpened As Boolean
    Get
public:
property bool IsPartiallyOpened {
    bool get ();
}


IsValidLineWeight Method (weight)

IsValidLineWeight Method (weight)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »IsValidLineWeight(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsValidLineWeight(
    int weight
)
Public Function IsValidLineWeight ( _
    weight As Integer _
) As Boolean
public:
bool IsValidLineWeight(
    int weight
)
Parameters
weight(Int32)


JoinStyle Property

JoinStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »JoinStyle
Declaration Syntax
C# Visual Basic Visual C++
public JoinStyle JoinStyle { get; set; }
Public Property JoinStyle As JoinStyle
    Get
    Set
public:
property JoinStyle JoinStyle {
    JoinStyle get ();
    void set (JoinStyle value);
}


LastSavedAsMaintenanceVersion Property

LastSavedAsMaintenanceVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LastSavedAsMaintenanceVersion
Declaration Syntax
C# Visual Basic Visual C++
public MaintenanceReleaseVersion LastSavedAsMaintenanceVersion { get; }
Public ReadOnly Property LastSavedAsMaintenanceVersion As MaintenanceReleaseVersion
    Get
public:
property MaintenanceReleaseVersion LastSavedAsMaintenanceVersion {
    MaintenanceReleaseVersion get ();
}


LastSavedAsVersion Property

LastSavedAsVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LastSavedAsVersion
Declaration Syntax
C# Visual Basic Visual C++
public DwgVersion LastSavedAsVersion { get; }
Public ReadOnly Property LastSavedAsVersion As DwgVersion
    Get
public:
property DwgVersion LastSavedAsVersion {
    DwgVersion get ();
}


Latitude Property

Latitude Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Latitude
Declaration Syntax
C# Visual Basic Visual C++
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}


LayerFilters Property

LayerFilters Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LayerFilters
Declaration Syntax
C# Visual Basic Visual C++
public LayerFilterTree LayerFilters { get; set; }
Public Property LayerFilters As LayerFilterTree
    Get
    Set
public:
property LayerFilterTree LayerFilters {
    LayerFilterTree get ();
    void set (LayerFilterTree value);
}


LayerStateManager Property

LayerStateManager Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LayerStateManager
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateManager LayerStateManager { get; }
Public ReadOnly Property LayerStateManager As LayerStateManager
    Get
public:
property LayerStateManager^ LayerStateManager {
    LayerStateManager^ get ();
}


LayerTableId Property

LayerTableId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LayerTableId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LayerTableId { get; }
Public ReadOnly Property LayerTableId As ObjectId
    Get
public:
property ObjectId LayerTableId {
    ObjectId get ();
}


LayerZero Property

LayerZero Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LayerZero
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LayerZero { get; }
Public ReadOnly Property LayerZero As ObjectId
    Get
public:
property ObjectId LayerZero {
    ObjectId get ();
}


LayoutDictionaryId Property

LayoutDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LayoutDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LayoutDictionaryId { get; }
Public ReadOnly Property LayoutDictionaryId As ObjectId
    Get
public:
property ObjectId LayoutDictionaryId {
    ObjectId get ();
}


LensLength Property

LensLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LensLength
Declaration Syntax
C# Visual Basic Visual C++
public double LensLength { get; set; }
Public Property LensLength As Double
    Get
    Set
public:
property double LensLength {
    double get ();
    void set (double value);
}


LightGlyphDisplay Property

LightGlyphDisplay Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LightGlyphDisplay
Declaration Syntax
C# Visual Basic Visual C++
public int LightGlyphDisplay { get; set; }
Public Property LightGlyphDisplay As Integer
    Get
    Set
public:
property int LightGlyphDisplay {
    int get ();
    void set (int value);
}


LightingUnits Property

LightingUnits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LightingUnits
Declaration Syntax
C# Visual Basic Visual C++
public byte LightingUnits { get; set; }
Public Property LightingUnits As Byte
    Get
    Set
public:
property unsigned char LightingUnits {
    unsigned char get ();
    void set (unsigned char value);
}


LightsInBlocks Property

LightsInBlocks Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LightsInBlocks
Declaration Syntax
C# Visual Basic Visual C++
public bool LightsInBlocks { get; set; }
Public Property LightsInBlocks As Boolean
    Get
    Set
public:
property bool LightsInBlocks {
    bool get ();
    void set (bool value);
}


Limcheck Property

Limcheck Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Limcheck
Declaration Syntax
C# Visual Basic Visual C++
public bool Limcheck { get; set; }
Public Property Limcheck As Boolean
    Get
    Set
public:
property bool Limcheck {
    bool get ();
    void set (bool value);
}


Limmax Property

Limmax Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Limmax
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Limmax { get; set; }
Public Property Limmax As Point2d
    Get
    Set
public:
property Point2d Limmax {
    Point2d get ();
    void set (Point2d value);
}


Limmin Property

Limmin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Limmin
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Limmin { get; set; }
Public Property Limmin As Point2d
    Get
    Set
public:
property Point2d Limmin {
    Point2d get ();
    void set (Point2d value);
}


LinetypeTableId Property

LinetypeTableId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LinetypeTableId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LinetypeTableId { get; }
Public ReadOnly Property LinetypeTableId As ObjectId
    Get
public:
property ObjectId LinetypeTableId {
    ObjectId get ();
}


LineWeightDisplay Property

LineWeightDisplay Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LineWeightDisplay
Declaration Syntax
C# Visual Basic Visual C++
public bool LineWeightDisplay { get; set; }
Public Property LineWeightDisplay As Boolean
    Get
    Set
public:
property bool LineWeightDisplay {
    bool get ();
    void set (bool value);
}


LoadLineTypeFile Method (lineTypeName, filename)

LoadLineTypeFile Method (lineTypeName, filename)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LoadLineTypeFile(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void LoadLineTypeFile(
    string lineTypeName,
    string filename
)
Public Sub LoadLineTypeFile ( _
    lineTypeName As String, _
    filename As String _
)
public:
void LoadLineTypeFile(
    String^ lineTypeName,
    String^ filename
)
Parameters
lineTypeName(String)
filename(String)


LoadMlineStyleFile Method (mlineStyleName, fileName)

LoadMlineStyleFile Method (mlineStyleName, fileName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LoadMlineStyleFile(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void LoadMlineStyleFile(
    string mlineStyleName,
    string fileName
)
Public Sub LoadMlineStyleFile ( _
    mlineStyleName As String, _
    fileName As String _
)
public:
void LoadMlineStyleFile(
    String^ mlineStyleName,
    String^ fileName
)
Parameters
mlineStyleName(String)
fileName(String)


LoftAng1 Property

LoftAng1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LoftAng1
Declaration Syntax
C# Visual Basic Visual C++
public double LoftAng1 { get; set; }
Public Property LoftAng1 As Double
    Get
    Set
public:
property double LoftAng1 {
    double get ();
    void set (double value);
}


LoftAng2 Property

LoftAng2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LoftAng2
Declaration Syntax
C# Visual Basic Visual C++
public double LoftAng2 { get; set; }
Public Property LoftAng2 As Double
    Get
    Set
public:
property double LoftAng2 {
    double get ();
    void set (double value);
}


LoftMag1 Property

LoftMag1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LoftMag1
Declaration Syntax
C# Visual Basic Visual C++
public double LoftMag1 { get; set; }
Public Property LoftMag1 As Double
    Get
    Set
public:
property double LoftMag1 {
    double get ();
    void set (double value);
}


LoftMag2 Property

LoftMag2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LoftMag2
Declaration Syntax
C# Visual Basic Visual C++
public double LoftMag2 { get; set; }
Public Property LoftMag2 As Double
    Get
    Set
public:
property double LoftMag2 {
    double get ();
    void set (double value);
}


LoftNormals Property

LoftNormals Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LoftNormals
Declaration Syntax
C# Visual Basic Visual C++
public int LoftNormals { get; set; }
Public Property LoftNormals As Integer
    Get
    Set
public:
property int LoftNormals {
    int get ();
    void set (int value);
}


LoftParam Property

LoftParam Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »LoftParam
Declaration Syntax
C# Visual Basic Visual C++
public int LoftParam { get; set; }
Public Property LoftParam As Integer
    Get
    Set
public:
property int LoftParam {
    int get ();
    void set (int value);
}


Longitude Property

Longitude Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Longitude
Declaration Syntax
C# Visual Basic Visual C++
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}


Ltscale Property

Ltscale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Ltscale
Declaration Syntax
C# Visual Basic Visual C++
public double Ltscale { get; set; }
Public Property Ltscale As Double
    Get
    Set
public:
property double Ltscale {
    double get ();
    void set (double value);
}


Lunits Property

Lunits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Lunits
Declaration Syntax
C# Visual Basic Visual C++
public int Lunits { get; set; }
Public Property Lunits As Integer
    Get
    Set
public:
property int Lunits {
    int get ();
    void set (int value);
}


Luprec Property

Luprec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Luprec
Declaration Syntax
C# Visual Basic Visual C++
public int Luprec { get; set; }
Public Property Luprec As Integer
    Get
    Set
public:
property int Luprec {
    int get ();
    void set (int value);
}


MaintenanceReleaseVersion Property

MaintenanceReleaseVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »MaintenanceReleaseVersion
Declaration Syntax
C# Visual Basic Visual C++
public int MaintenanceReleaseVersion { get; }
Public ReadOnly Property MaintenanceReleaseVersion As Integer
    Get
public:
property int MaintenanceReleaseVersion {
    int get ();
}


MarkObjectNonPersistent Method (id, value)

MarkObjectNonPersistent Method (id, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »MarkObjectNonPersistent(ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static void MarkObjectNonPersistent(
    ObjectId id,
    bool value
)
Public Shared Sub MarkObjectNonPersistent ( _
    id As ObjectId, _
    value As Boolean _
)
public:
static void MarkObjectNonPersistent(
    ObjectId id,
    bool value
)
Parameters
id(ObjectId)
value(Boolean)


MaterialDictionaryId Property

MaterialDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »MaterialDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId MaterialDictionaryId { get; }
Public ReadOnly Property MaterialDictionaryId As ObjectId
    Get
public:
property ObjectId MaterialDictionaryId {
    ObjectId get ();
}


Maxactvp Property

Maxactvp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Maxactvp
Declaration Syntax
C# Visual Basic Visual C++
public int Maxactvp { get; set; }
Public Property Maxactvp As Integer
    Get
    Set
public:
property int Maxactvp {
    int get ();
    void set (int value);
}


Measurement Property

Measurement Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Measurement
Declaration Syntax
C# Visual Basic Visual C++
public MeasurementValue Measurement { get; set; }
Public Property Measurement As MeasurementValue
    Get
    Set
public:
property MeasurementValue Measurement {
    MeasurementValue get ();
    void set (MeasurementValue value);
}


Menu Property

Menu Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Menu
Declaration Syntax
C# Visual Basic Visual C++
public string Menu { get; }
Public ReadOnly Property Menu As String
    Get
public:
property String^ Menu {
    String^ get ();
}


Mirrtext Property

Mirrtext Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Mirrtext
Declaration Syntax
C# Visual Basic Visual C++
public bool Mirrtext { get; set; }
Public Property Mirrtext As Boolean
    Get
    Set
public:
property bool Mirrtext {
    bool get ();
    void set (bool value);
}


MLeaderstyle Property

MLeaderstyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »MLeaderstyle
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId MLeaderstyle { get; set; }
Public Property MLeaderstyle As ObjectId
    Get
    Set
public:
property ObjectId MLeaderstyle {
    ObjectId get ();
    void set (ObjectId value);
}


MLeaderStyleDictionaryId Property

MLeaderStyleDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »MLeaderStyleDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId MLeaderStyleDictionaryId { get; }
Public ReadOnly Property MLeaderStyleDictionaryId As ObjectId
    Get
public:
property ObjectId MLeaderStyleDictionaryId {
    ObjectId get ();
}


MLStyleDictionaryId Property

MLStyleDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »MLStyleDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId MLStyleDictionaryId { get; }
Public ReadOnly Property MLStyleDictionaryId As ObjectId
    Get
public:
property ObjectId MLStyleDictionaryId {
    ObjectId get ();
}


MsLtScale Property

MsLtScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »MsLtScale
Declaration Syntax
C# Visual Basic Visual C++
public bool MsLtScale { get; set; }
Public Property MsLtScale As Boolean
    Get
    Set
public:
property bool MsLtScale {
    bool get ();
    void set (bool value);
}


NamedObjectsDictionaryId Property

NamedObjectsDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »NamedObjectsDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId NamedObjectsDictionaryId { get; }
Public ReadOnly Property NamedObjectsDictionaryId As ObjectId
    Get
public:
property ObjectId NamedObjectsDictionaryId {
    ObjectId get ();
}


NorthDirection Property

NorthDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »NorthDirection
Declaration Syntax
C# Visual Basic Visual C++
public double NorthDirection { get; set; }
Public Property NorthDirection As Double
    Get
    Set
public:
property double NorthDirection {
    double get ();
    void set (double value);
}


NumberOfSaves Property

NumberOfSaves Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »NumberOfSaves
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfSaves { get; }
Public ReadOnly Property NumberOfSaves As Integer
    Get
public:
property int NumberOfSaves {
    int get ();
}


ObjectAppended Event

ObjectAppended Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ObjectAppended
Declaration Syntax
C# Visual Basic Visual C++
public event ObjectEventHandler ObjectAppended
Public Event ObjectAppended As ObjectEventHandler
public:
 event ObjectEventHandler^ ObjectAppended {
    void add (ObjectEventHandler^ value);
    void remove (ObjectEventHandler^ value);
}


ObjectContextManager Property

ObjectContextManager Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ObjectContextManager
Declaration Syntax
C# Visual Basic Visual C++
public ObjectContextManager ObjectContextManager { get; }
Public ReadOnly Property ObjectContextManager As ObjectContextManager
    Get
public:
property ObjectContextManager^ ObjectContextManager {
    ObjectContextManager^ get ();
}


ObjectErased Event

ObjectErased Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ObjectErased
Declaration Syntax
C# Visual Basic Visual C++
public event ObjectErasedEventHandler ObjectErased
Public Event ObjectErased As ObjectErasedEventHandler
public:
 event ObjectErasedEventHandler^ ObjectErased {
    void add (ObjectErasedEventHandler^ value);
    void remove (ObjectErasedEventHandler^ value);
}


ObjectModified Event

ObjectModified Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ObjectModified
Declaration Syntax
C# Visual Basic Visual C++
public event ObjectEventHandler ObjectModified
Public Event ObjectModified As ObjectEventHandler
public:
 event ObjectEventHandler^ ObjectModified {
    void add (ObjectEventHandler^ value);
    void remove (ObjectEventHandler^ value);
}


ObjectOpenedForModify Event

ObjectOpenedForModify Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ObjectOpenedForModify
Declaration Syntax
C# Visual Basic Visual C++
public event ObjectEventHandler ObjectOpenedForModify
Public Event ObjectOpenedForModify As ObjectEventHandler
public:
 event ObjectEventHandler^ ObjectOpenedForModify {
    void add (ObjectEventHandler^ value);
    void remove (ObjectEventHandler^ value);
}


ObjectReappended Event

ObjectReappended Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ObjectReappended
Declaration Syntax
C# Visual Basic Visual C++
public event ObjectEventHandler ObjectReappended
Public Event ObjectReappended As ObjectEventHandler
public:
 event ObjectEventHandler^ ObjectReappended {
    void add (ObjectEventHandler^ value);
    void remove (ObjectEventHandler^ value);
}


ObjectUnappended Event

ObjectUnappended Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ObjectUnappended
Declaration Syntax
C# Visual Basic Visual C++
public event ObjectEventHandler ObjectUnappended
Public Event ObjectUnappended As ObjectEventHandler
public:
 event ObjectEventHandler^ ObjectUnappended {
    void add (ObjectEventHandler^ value);
    void remove (ObjectEventHandler^ value);
}


ObscuredColor Property

ObscuredColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ObscuredColor
Declaration Syntax
C# Visual Basic Visual C++
public int ObscuredColor { get; set; }
Public Property ObscuredColor As Integer
    Get
    Set
public:
property int ObscuredColor {
    int get ();
    void set (int value);
}


ObscuredLineType Property

ObscuredLineType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ObscuredLineType
Declaration Syntax
C# Visual Basic Visual C++
public int ObscuredLineType { get; set; }
Public Property ObscuredLineType As Integer
    Get
    Set
public:
property int ObscuredLineType {
    int get ();
    void set (int value);
}


OleStartUp Property

OleStartUp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »OleStartUp
Declaration Syntax
C# Visual Basic Visual C++
public bool OleStartUp { get; set; }
Public Property OleStartUp As Boolean
    Get
    Set
public:
property bool OleStartUp {
    bool get ();
    void set (bool value);
}


OriginalFileMaintenanceVersion Property

OriginalFileMaintenanceVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »OriginalFileMaintenanceVersion
Declaration Syntax
C# Visual Basic Visual C++
public MaintenanceReleaseVersion OriginalFileMaintenanceVersion { get; }
Public ReadOnly Property OriginalFileMaintenanceVersion As MaintenanceReleaseVersion
    Get
public:
property MaintenanceReleaseVersion OriginalFileMaintenanceVersion {
    MaintenanceReleaseVersion get ();
}


OriginalFileName Property

OriginalFileName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »OriginalFileName
Declaration Syntax
C# Visual Basic Visual C++
public string OriginalFileName { get; }
Public ReadOnly Property OriginalFileName As String
    Get
public:
property String^ OriginalFileName {
    String^ get ();
}


OriginalFileSavedByMaintenanceVersion Property

OriginalFileSavedByMaintenanceVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »OriginalFileSavedByMaintenanceVersion
Declaration Syntax
C# Visual Basic Visual C++
public MaintenanceReleaseVersion OriginalFileSavedByMaintenanceVersion { get; }
Public ReadOnly Property OriginalFileSavedByMaintenanceVersion As MaintenanceReleaseVersion
    Get
public:
property MaintenanceReleaseVersion OriginalFileSavedByMaintenanceVersion {
    MaintenanceReleaseVersion get ();
}


OriginalFileSavedByVersion Property

OriginalFileSavedByVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »OriginalFileSavedByVersion
Declaration Syntax
C# Visual Basic Visual C++
public DwgVersion OriginalFileSavedByVersion { get; }
Public ReadOnly Property OriginalFileSavedByVersion As DwgVersion
    Get
public:
property DwgVersion OriginalFileSavedByVersion {
    DwgVersion get ();
}


OriginalFileVersion Property

OriginalFileVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »OriginalFileVersion
Declaration Syntax
C# Visual Basic Visual C++
public DwgVersion OriginalFileVersion { get; }
Public ReadOnly Property OriginalFileVersion As DwgVersion
    Get
public:
property DwgVersion OriginalFileVersion {
    DwgVersion get ();
}


Orthomode Property

Orthomode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Orthomode
Declaration Syntax
C# Visual Basic Visual C++
public bool Orthomode { get; set; }
Public Property Orthomode As Boolean
    Get
    Set
public:
property bool Orthomode {
    bool get ();
    void set (bool value);
}


OverlayXref Method (fileName, blockName)

OverlayXref Method (fileName, blockName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »OverlayXref(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId OverlayXref(
    string fileName,
    string blockName
)
Public Function OverlayXref ( _
    fileName As String, _
    blockName As String _
) As ObjectId
public:
ObjectId OverlayXref(
    String^ fileName,
    String^ blockName
)
Parameters
fileName(String)
blockName(String)


PaperSpaceVportId Property

PaperSpaceVportId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »PaperSpaceVportId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId PaperSpaceVportId { get; }
Public ReadOnly Property PaperSpaceVportId As ObjectId
    Get
public:
property ObjectId PaperSpaceVportId {
    ObjectId get ();
}


PartialOpenNotice Event

PartialOpenNotice Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »PartialOpenNotice
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler PartialOpenNotice
Public Event PartialOpenNotice As EventHandler
public:
 event EventHandler^ PartialOpenNotice {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Pdmode Property

Pdmode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Pdmode
Declaration Syntax
C# Visual Basic Visual C++
public int Pdmode { get; set; }
Public Property Pdmode As Integer
    Get
    Set
public:
property int Pdmode {
    int get ();
    void set (int value);
}


Pdsize Property

Pdsize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Pdsize
Declaration Syntax
C# Visual Basic Visual C++
public double Pdsize { get; set; }
Public Property Pdsize As Double
    Get
    Set
public:
property double Pdsize {
    double get ();
    void set (double value);
}


Pelevation Property

Pelevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Pelevation
Declaration Syntax
C# Visual Basic Visual C++
public double Pelevation { get; set; }
Public Property Pelevation As Double
    Get
    Set
public:
property double Pelevation {
    double get ();
    void set (double value);
}


Pextmax Property

Pextmax Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Pextmax
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Pextmax { get; set; }
Public Property Pextmax As Point3d
    Get
    Set
public:
property Point3d Pextmax {
    Point3d get ();
    void set (Point3d value);
}


Pextmin Property

Pextmin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Pextmin
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Pextmin { get; set; }
Public Property Pextmin As Point3d
    Get
    Set
public:
property Point3d Pextmin {
    Point3d get ();
    void set (Point3d value);
}


Pinsbase Property

Pinsbase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Pinsbase
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Pinsbase { get; set; }
Public Property Pinsbase As Point3d
    Get
    Set
public:
property Point3d Pinsbase {
    Point3d get ();
    void set (Point3d value);
}


Plimcheck Property

Plimcheck Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Plimcheck
Declaration Syntax
C# Visual Basic Visual C++
public bool Plimcheck { get; set; }
Public Property Plimcheck As Boolean
    Get
    Set
public:
property bool Plimcheck {
    bool get ();
    void set (bool value);
}


Plimmax Property

Plimmax Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Plimmax
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Plimmax { get; set; }
Public Property Plimmax As Point2d
    Get
    Set
public:
property Point2d Plimmax {
    Point2d get ();
    void set (Point2d value);
}


Plimmin Property

Plimmin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Plimmin
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Plimmin { get; set; }
Public Property Plimmin As Point2d
    Get
    Set
public:
property Point2d Plimmin {
    Point2d get ();
    void set (Point2d value);
}


PlineEllipse Property

PlineEllipse Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »PlineEllipse
Declaration Syntax
C# Visual Basic Visual C++
public bool PlineEllipse { get; set; }
Public Property PlineEllipse As Boolean
    Get
    Set
public:
property bool PlineEllipse {
    bool get ();
    void set (bool value);
}


Plinegen Property

Plinegen Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Plinegen
Declaration Syntax
C# Visual Basic Visual C++
public bool Plinegen { get; set; }
Public Property Plinegen As Boolean
    Get
    Set
public:
property bool Plinegen {
    bool get ();
    void set (bool value);
}


Plinewid Property

Plinewid Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Plinewid
Declaration Syntax
C# Visual Basic Visual C++
public double Plinewid { get; set; }
Public Property Plinewid As Double
    Get
    Set
public:
property double Plinewid {
    double get ();
    void set (double value);
}


PlotSettingsDictionaryId Property

PlotSettingsDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »PlotSettingsDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId PlotSettingsDictionaryId { get; }
Public ReadOnly Property PlotSettingsDictionaryId As ObjectId
    Get
public:
property ObjectId PlotSettingsDictionaryId {
    ObjectId get ();
}


PlotStyleMode Property

PlotStyleMode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »PlotStyleMode
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotStyleMode { get; }
Public ReadOnly Property PlotStyleMode As Boolean
    Get
public:
property bool PlotStyleMode {
    bool get ();
}


PlotStyleNameDictionaryId Property

PlotStyleNameDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »PlotStyleNameDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId PlotStyleNameDictionaryId { get; }
Public ReadOnly Property PlotStyleNameDictionaryId As ObjectId
    Get
public:
property ObjectId PlotStyleNameDictionaryId {
    ObjectId get ();
}


PlotStyleNameId Property

PlotStyleNameId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »PlotStyleNameId
Declaration Syntax
C# Visual Basic Visual C++
public PlotStyleDescriptor PlotStyleNameId { get; set; }
Public Property PlotStyleNameId As PlotStyleDescriptor
    Get
    Set
public:
property PlotStyleDescriptor PlotStyleNameId {
    PlotStyleDescriptor get ();
    void set (PlotStyleDescriptor value);
}


ProjectName Property

ProjectName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ProjectName
Declaration Syntax
C# Visual Basic Visual C++
public string ProjectName { get; set; }
Public Property ProjectName As String
    Get
    Set
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}


ProxyResurrectionCompleted Event

ProxyResurrectionCompleted Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ProxyResurrectionCompleted
Declaration Syntax
C# Visual Basic Visual C++
public event ProxyResurrectionCompletedEventHandler ProxyResurrectionCompleted
Public Event ProxyResurrectionCompleted As ProxyResurrectionCompletedEventHandler
public:
 event ProxyResurrectionCompletedEventHandler^ ProxyResurrectionCompleted {
    void add (ProxyResurrectionCompletedEventHandler^ value);
    void remove (ProxyResurrectionCompletedEventHandler^ value);
}


Psltscale Property

Psltscale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Psltscale
Declaration Syntax
C# Visual Basic Visual C++
public bool Psltscale { get; set; }
Public Property Psltscale As Boolean
    Get
    Set
public:
property bool Psltscale {
    bool get ();
    void set (bool value);
}


PsolHeight Property

PsolHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »PsolHeight
Declaration Syntax
C# Visual Basic Visual C++
public double PsolHeight { get; set; }
Public Property PsolHeight As Double
    Get
    Set
public:
property double PsolHeight {
    double get ();
    void set (double value);
}


PsolWidth Property

PsolWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »PsolWidth
Declaration Syntax
C# Visual Basic Visual C++
public double PsolWidth { get; set; }
Public Property PsolWidth As Double
    Get
    Set
public:
property double PsolWidth {
    double get ();
    void set (double value);
}


PucsBase Property

PucsBase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »PucsBase
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId PucsBase { get; set; }
Public Property PucsBase As ObjectId
    Get
    Set
public:
property ObjectId PucsBase {
    ObjectId get ();
    void set (ObjectId value);
}


Pucsname Property

Pucsname Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Pucsname
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Pucsname { get; }
Public ReadOnly Property Pucsname As ObjectId
    Get
public:
property ObjectId Pucsname {
    ObjectId get ();
}


Pucsorg Property

Pucsorg Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Pucsorg
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Pucsorg { get; }
Public ReadOnly Property Pucsorg As Point3d
    Get
public:
property Point3d Pucsorg {
    Point3d get ();
}


Pucsxdir Property

Pucsxdir Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Pucsxdir
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Pucsxdir { get; }
Public ReadOnly Property Pucsxdir As Vector3d
    Get
public:
property Vector3d Pucsxdir {
    Vector3d get ();
}


Pucsydir Property

Pucsydir Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Pucsydir
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Pucsydir { get; }
Public ReadOnly Property Pucsydir As Vector3d
    Get
public:
property Vector3d Pucsydir {
    Vector3d get ();
}


Purge Method

Purge Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Purge()()()()
Members
Icon | Member | Description
 | Purge(ObjectIdGraph) |
 | Purge(ObjectIdCollection) |


Purge Method (ids)

Purge Method (ids)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Purge(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void Purge(
    ObjectIdCollection ids
)
Public Sub Purge ( _
    ids As ObjectIdCollection _
)
public:
void Purge(
    ObjectIdCollection^ ids
)
Parameters
ids(ObjectIdCollection)


Purge Method (idGraph)

Purge Method (idGraph)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Purge(ObjectIdGraph)
Declaration Syntax
C# Visual Basic Visual C++
public void Purge(
    ObjectIdGraph idGraph
)
Public Sub Purge ( _
    idGraph As ObjectIdGraph _
)
public:
void Purge(
    ObjectIdGraph^ idGraph
)
Parameters
idGraph(ObjectIdGraph)


Qtextmode Property

Qtextmode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Qtextmode
Declaration Syntax
C# Visual Basic Visual C++
public bool Qtextmode { get; set; }
Public Property Qtextmode As Boolean
    Get
    Set
public:
property bool Qtextmode {
    bool get ();
    void set (bool value);
}


ReadDwgFile Method

ReadDwgFile Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ReadDwgFile()()()()
Members
Icon | Member | Description
 | ReadDwgFile(String, FileOpenMode, Boolean, String) |
 | ReadDwgFile(IntPtr, Boolean, String) |
 | ReadDwgFile(String, FileShare, Boolean, String) |


ReadDwgFile Method (drawingFile, allowCPConversion, password)

ReadDwgFile Method (drawingFile, allowCPConversion, password)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ReadDwgFile(IntPtr, Boolean, String)
Declaration Syntax
C# Visual Basic Visual C++
public void ReadDwgFile(
    IntPtr drawingFile,
    bool allowCPConversion,
    string password
)
Public Sub ReadDwgFile ( _
    drawingFile As IntPtr, _
    allowCPConversion As Boolean, _
    password As String _
)
public:
void ReadDwgFile(
    IntPtr drawingFile,
    bool allowCPConversion,
    String^ password
)
Parameters
drawingFile(IntPtr)
allowCPConversion(Boolean)
password(String)


ReadDwgFile Method (fileName, fileSharing, allowCPConversion, password)

ReadDwgFile Method (fileName, fileSharing, allowCPConversion, password)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ReadDwgFile(String, FileShare, Boolean, String)
Declaration Syntax
C# Visual Basic Visual C++
public void ReadDwgFile(
    string fileName,
    FileShare fileSharing,
    bool allowCPConversion,
    string password
)
Public Sub ReadDwgFile ( _
    fileName As String, _
    fileSharing As FileShare, _
    allowCPConversion As Boolean, _
    password As String _
)
public:
void ReadDwgFile(
    String^ fileName,
    FileShare fileSharing,
    bool allowCPConversion,
    String^ password
)
Parameters
fileName(String)
fileSharing(FileShare)
allowCPConversion(Boolean)
password(String)


ReadDwgFile Method (fileName, mode, allowCPConversion, password)

ReadDwgFile Method (fileName, mode, allowCPConversion, password)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ReadDwgFile(String, FileOpenMode, Boolean, String)
Declaration Syntax
C# Visual Basic Visual C++
public void ReadDwgFile(
    string fileName,
    FileOpenMode mode,
    bool allowCPConversion,
    string password
)
Public Sub ReadDwgFile ( _
    fileName As String, _
    mode As FileOpenMode, _
    allowCPConversion As Boolean, _
    password As String _
)
public:
void ReadDwgFile(
    String^ fileName,
    FileOpenMode mode,
    bool allowCPConversion,
    String^ password
)
Parameters
fileName(String)
mode(FileOpenMode)
allowCPConversion(Boolean)
password(String)


ReclaimMemoryFromErasedObjects Method (ids)

ReclaimMemoryFromErasedObjects Method (ids)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ReclaimMemoryFromErasedObjects(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void ReclaimMemoryFromErasedObjects(
    ObjectIdCollection ids
)
Public Sub ReclaimMemoryFromErasedObjects ( _
    ids As ObjectIdCollection _
)
public:
void ReclaimMemoryFromErasedObjects(
    ObjectIdCollection^ ids
)
Parameters
ids(ObjectIdCollection)


Redo Method

Redo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Redo()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Redo()
Public Sub Redo
public:
void Redo()


RegAppTableId Property

RegAppTableId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »RegAppTableId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId RegAppTableId { get; }
Public ReadOnly Property RegAppTableId As ObjectId
    Get
public:
property ObjectId RegAppTableId {
    ObjectId get ();
}


Regenmode Property

Regenmode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Regenmode
Declaration Syntax
C# Visual Basic Visual C++
public bool Regenmode { get; set; }
Public Property Regenmode As Boolean
    Get
    Set
public:
property bool Regenmode {
    bool get ();
    void set (bool value);
}


ReloadXrefs Method (xrefIds)

ReloadXrefs Method (xrefIds)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ReloadXrefs(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void ReloadXrefs(
    ObjectIdCollection xrefIds
)
Public Sub ReloadXrefs ( _
    xrefIds As ObjectIdCollection _
)
public:
void ReloadXrefs(
    ObjectIdCollection^ xrefIds
)
Parameters
xrefIds(ObjectIdCollection)


ResolveXrefs Method (useThreadEngine, doNewOnly)

ResolveXrefs Method (useThreadEngine, doNewOnly)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ResolveXrefs(Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void ResolveXrefs(
    bool useThreadEngine,
    bool doNewOnly
)
Public Sub ResolveXrefs ( _
    useThreadEngine As Boolean, _
    doNewOnly As Boolean _
)
public:
void ResolveXrefs(
    bool useThreadEngine,
    bool doNewOnly
)
Parameters
useThreadEngine(Boolean)
doNewOnly(Boolean)


RestoreForwardingXrefSymbols Method

RestoreForwardingXrefSymbols Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »RestoreForwardingXrefSymbols()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RestoreForwardingXrefSymbols()
Public Sub RestoreForwardingXrefSymbols
public:
void RestoreForwardingXrefSymbols()


RestoreOriginalXrefSymbols Method

RestoreOriginalXrefSymbols Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »RestoreOriginalXrefSymbols()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RestoreOriginalXrefSymbols()
Public Sub RestoreOriginalXrefSymbols
public:
void RestoreOriginalXrefSymbols()


RetainOriginalThumbnailBitmap Property

RetainOriginalThumbnailBitmap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »RetainOriginalThumbnailBitmap
Declaration Syntax
C# Visual Basic Visual C++
public bool RetainOriginalThumbnailBitmap { get; set; }
Public Property RetainOriginalThumbnailBitmap As Boolean
    Get
    Set
public:
property bool RetainOriginalThumbnailBitmap {
    bool get ();
    void set (bool value);
}


Save Method

Save Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Save()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Save()
Public Sub Save
public:
void Save()


SaveAs Method

SaveAs Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SaveAs()()()()
Members
Icon | Member | Description
 | SaveAs(String, SaveType, DwgVersion, Boolean, Int32) |
 | SaveAs(String, DwgVersion, Boolean, Int32) |
 | SaveAs(String, DwgVersion, Boolean) |
 | SaveAs(String, Boolean, DwgVersion, SecurityParameters) |
 | SaveAs(String, SecurityParameters) |
 | SaveAs(String, DwgVersion) |


SaveAs Method (fileName, bBakAndRename, version, security)

SaveAs Method (fileName, bBakAndRename, version, security)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SaveAs(String, Boolean, DwgVersion, SecurityParameters)
Declaration Syntax
C# Visual Basic Visual C++
public void SaveAs(
    string fileName,
    bool bBakAndRename,
    DwgVersion version,
    SecurityParameters security
)
Public Sub SaveAs ( _
    fileName As String, _
    bBakAndRename As Boolean, _
    version As DwgVersion, _
    security As SecurityParameters _
)
public:
void SaveAs(
    String^ fileName,
    bool bBakAndRename,
    DwgVersion version,
    SecurityParameters^ security
)
Parameters
fileName(String)
bBakAndRename(Boolean)
version(DwgVersion)
security(SecurityParameters)


SaveAs Method (fileName, version)

SaveAs Method (fileName, version)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SaveAs(String, DwgVersion)
Declaration Syntax
C# Visual Basic Visual C++
public void SaveAs(
    string fileName,
    DwgVersion version
)
Public Sub SaveAs ( _
    fileName As String, _
    version As DwgVersion _
)
public:
void SaveAs(
    String^ fileName,
    DwgVersion version
)
Parameters
fileName(String)
version(DwgVersion)


SaveAs Method (fileName, version, saveThumbnailImage)

SaveAs Method (fileName, version, saveThumbnailImage)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SaveAs(String, DwgVersion, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SaveAs(
    string fileName,
    DwgVersion version,
    bool saveThumbnailImage
)
Public Sub SaveAs ( _
    fileName As String, _
    version As DwgVersion, _
    saveThumbnailImage As Boolean _
)
public:
void SaveAs(
    String^ fileName,
    DwgVersion version,
    bool saveThumbnailImage
)
Parameters
fileName(String)
version(DwgVersion)
saveThumbnailImage(Boolean)


SaveAs Method (fileName, version, saveThumbnailImage, dxfPrecision)

SaveAs Method (fileName, version, saveThumbnailImage, dxfPrecision)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SaveAs(String, DwgVersion, Boolean, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SaveAs(
    string fileName,
    DwgVersion version,
    bool saveThumbnailImage,
    int dxfPrecision
)
Public Sub SaveAs ( _
    fileName As String, _
    version As DwgVersion, _
    saveThumbnailImage As Boolean, _
    dxfPrecision As Integer _
)
public:
void SaveAs(
    String^ fileName,
    DwgVersion version,
    bool saveThumbnailImage,
    int dxfPrecision
)
Parameters
fileName(String)
version(DwgVersion)
saveThumbnailImage(Boolean)
dxfPrecision(Int32)


SaveAs Method (fileName, st, version, saveThumbnailImage, dxfPrecision)

SaveAs Method (fileName, st, version, saveThumbnailImage, dxfPrecision)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SaveAs(String, SaveType, DwgVersion, Boolean, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SaveAs(
    string fileName,
    SaveType st,
    DwgVersion version,
    bool saveThumbnailImage,
    int dxfPrecision
)
Public Sub SaveAs ( _
    fileName As String, _
    st As SaveType, _
    version As DwgVersion, _
    saveThumbnailImage As Boolean, _
    dxfPrecision As Integer _
)
public:
void SaveAs(
    String^ fileName,
    SaveType st,
    DwgVersion version,
    bool saveThumbnailImage,
    int dxfPrecision
)
Parameters
fileName(String)
st(SaveType)
version(DwgVersion)
saveThumbnailImage(Boolean)
dxfPrecision(Int32)


SaveAs Method (fileName, security)

SaveAs Method (fileName, security)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SaveAs(String, SecurityParameters)
Declaration Syntax
C# Visual Basic Visual C++
public void SaveAs(
    string fileName,
    SecurityParameters security
)
Public Sub SaveAs ( _
    fileName As String, _
    security As SecurityParameters _
)
public:
void SaveAs(
    String^ fileName,
    SecurityParameters^ security
)
Parameters
fileName(String)
security(SecurityParameters)


SaveComplete Event

SaveComplete Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SaveComplete
Declaration Syntax
C# Visual Basic Visual C++
public event DatabaseIOEventHandler SaveComplete
Public Event SaveComplete As DatabaseIOEventHandler
public:
 event DatabaseIOEventHandler^ SaveComplete {
    void add (DatabaseIOEventHandler^ value);
    void remove (DatabaseIOEventHandler^ value);
}


Saveproxygraphics Property

Saveproxygraphics Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Saveproxygraphics
Declaration Syntax
C# Visual Basic Visual C++
public int Saveproxygraphics { get; set; }
Public Property Saveproxygraphics As Integer
    Get
    Set
public:
property int Saveproxygraphics {
    int get ();
    void set (int value);
}


SectionManagerId Property

SectionManagerId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SectionManagerId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId SectionManagerId { get; }
Public ReadOnly Property SectionManagerId As ObjectId
    Get
public:
property ObjectId SectionManagerId {
    ObjectId get ();
}


SecurityParameters Property

SecurityParameters Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SecurityParameters
Declaration Syntax
C# Visual Basic Visual C++
public SecurityParameters SecurityParameters { get; set; }
Public Property SecurityParameters As SecurityParameters
    Get
    Set
public:
property SecurityParameters^ SecurityParameters {
    SecurityParameters^ get ();
    void set (SecurityParameters^ value);
}


SetDimstyleData Method (style)

SetDimstyleData Method (style)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SetDimstyleData(DimStyleTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDimstyleData(
    DimStyleTableRecord style
)
Public Sub SetDimstyleData ( _
    style As DimStyleTableRecord _
)
public:
void SetDimstyleData(
    DimStyleTableRecord^ style
)
Parameters
style(DimStyleTableRecord)


SetTimeZoneAsUtcOffset Method (offset)

SetTimeZoneAsUtcOffset Method (offset)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SetTimeZoneAsUtcOffset(Double)
Declaration Syntax
C# Visual Basic Visual C++
public TimeZone SetTimeZoneAsUtcOffset(
    double offset
)
Public Function SetTimeZoneAsUtcOffset ( _
    offset As Double _
) As TimeZone
public:
TimeZone SetTimeZoneAsUtcOffset(
    double offset
)
Parameters
offset(Double)


SetWorldPaperspaceUcsBaseOrigin Method (origin, orthoView)

SetWorldPaperspaceUcsBaseOrigin Method (origin, orthoView)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SetWorldPaperspaceUcsBaseOrigin(Point3d, OrthographicView)
Declaration Syntax
C# Visual Basic Visual C++
public void SetWorldPaperspaceUcsBaseOrigin(
    Point3d origin,
    OrthographicView orthoView
)
Public Sub SetWorldPaperspaceUcsBaseOrigin ( _
    origin As Point3d, _
    orthoView As OrthographicView _
)
public:
void SetWorldPaperspaceUcsBaseOrigin(
    Point3d origin,
    OrthographicView orthoView
)
Parameters
origin(Point3d)
orthoView(OrthographicView)


SetWorldUcsBaseOrigin Method (origin, orthoView)

SetWorldUcsBaseOrigin Method (origin, orthoView)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SetWorldUcsBaseOrigin(Point3d, OrthographicView)
Declaration Syntax
C# Visual Basic Visual C++
public void SetWorldUcsBaseOrigin(
    Point3d origin,
    OrthographicView orthoView
)
Public Sub SetWorldUcsBaseOrigin ( _
    origin As Point3d, _
    orthoView As OrthographicView _
)
public:
void SetWorldUcsBaseOrigin(
    Point3d origin,
    OrthographicView orthoView
)
Parameters
origin(Point3d)
orthoView(OrthographicView)


Shadedge Property

Shadedge Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Shadedge
Declaration Syntax
C# Visual Basic Visual C++
public int Shadedge { get; set; }
Public Property Shadedge As Integer
    Get
    Set
public:
property int Shadedge {
    int get ();
    void set (int value);
}


Shadedif Property

Shadedif Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Shadedif
Declaration Syntax
C# Visual Basic Visual C++
public int Shadedif { get; set; }
Public Property Shadedif As Integer
    Get
    Set
public:
property int Shadedif {
    int get ();
    void set (int value);
}


ShadowPlaneLocation Property

ShadowPlaneLocation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ShadowPlaneLocation
Declaration Syntax
C# Visual Basic Visual C++
public double ShadowPlaneLocation { get; set; }
Public Property ShadowPlaneLocation As Double
    Get
    Set
public:
property double ShadowPlaneLocation {
    double get ();
    void set (double value);
}


ShowHist Property

ShowHist Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ShowHist
Declaration Syntax
C# Visual Basic Visual C++
public int ShowHist { get; set; }
Public Property ShowHist As Integer
    Get
    Set
public:
property int ShowHist {
    int get ();
    void set (int value);
}


Sketchinc Property

Sketchinc Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Sketchinc
Declaration Syntax
C# Visual Basic Visual C++
public double Sketchinc { get; set; }
Public Property Sketchinc As Double
    Get
    Set
public:
property double Sketchinc {
    double get ();
    void set (double value);
}


Skpoly Property

Skpoly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Skpoly
Declaration Syntax
C# Visual Basic Visual C++
public bool Skpoly { get; set; }
Public Property Skpoly As Boolean
    Get
    Set
public:
property bool Skpoly {
    bool get ();
    void set (bool value);
}


SolidHist Property

SolidHist Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SolidHist
Declaration Syntax
C# Visual Basic Visual C++
public int SolidHist { get; set; }
Public Property SolidHist As Integer
    Get
    Set
public:
property int SolidHist {
    int get ();
    void set (int value);
}


SortEnts Property

SortEnts Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SortEnts
Declaration Syntax
C# Visual Basic Visual C++
public int SortEnts { get; set; }
Public Property SortEnts As Integer
    Get
    Set
public:
property int SortEnts {
    int get ();
    void set (int value);
}


Splframe Property

Splframe Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Splframe
Declaration Syntax
C# Visual Basic Visual C++
public bool Splframe { get; set; }
Public Property Splframe As Boolean
    Get
    Set
public:
property bool Splframe {
    bool get ();
    void set (bool value);
}


Splinesegs Property

Splinesegs Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Splinesegs
Declaration Syntax
C# Visual Basic Visual C++
public int Splinesegs { get; set; }
Public Property Splinesegs As Integer
    Get
    Set
public:
property int Splinesegs {
    int get ();
    void set (int value);
}


Splinetype Property

Splinetype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Splinetype
Declaration Syntax
C# Visual Basic Visual C++
public int Splinetype { get; set; }
Public Property Splinetype As Integer
    Get
    Set
public:
property int Splinetype {
    int get ();
    void set (int value);
}


StartUndoRecord Method

StartUndoRecord Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »StartUndoRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void StartUndoRecord()
Public Sub StartUndoRecord
public:
void StartUndoRecord()


StepSize Property

StepSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »StepSize
Declaration Syntax
C# Visual Basic Visual C++
public double StepSize { get; set; }
Public Property StepSize As Double
    Get
    Set
public:
property double StepSize {
    double get ();
    void set (double value);
}


StepsPerSec Property

StepsPerSec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »StepsPerSec
Declaration Syntax
C# Visual Basic Visual C++
public double StepsPerSec { get; set; }
Public Property StepsPerSec As Double
    Get
    Set
public:
property double StepsPerSec {
    double get ();
    void set (double value);
}


StyleSheet Property

StyleSheet Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »StyleSheet
Declaration Syntax
C# Visual Basic Visual C++
public string StyleSheet { get; set; }
Public Property StyleSheet As String
    Get
    Set
public:
property String^ StyleSheet {
    String^ get ();
    void set (String^ value);
}


SummaryInfo Property

SummaryInfo Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SummaryInfo
Declaration Syntax
C# Visual Basic Visual C++
public DatabaseSummaryInfo SummaryInfo { get; set; }
Public Property SummaryInfo As DatabaseSummaryInfo
    Get
    Set
public:
property DatabaseSummaryInfo SummaryInfo {
    DatabaseSummaryInfo get ();
    void set (DatabaseSummaryInfo value);
}


Surftab1 Property

Surftab1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Surftab1
Declaration Syntax
C# Visual Basic Visual C++
public int Surftab1 { get; set; }
Public Property Surftab1 As Integer
    Get
    Set
public:
property int Surftab1 {
    int get ();
    void set (int value);
}


Surftab2 Property

Surftab2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Surftab2
Declaration Syntax
C# Visual Basic Visual C++
public int Surftab2 { get; set; }
Public Property Surftab2 As Integer
    Get
    Set
public:
property int Surftab2 {
    int get ();
    void set (int value);
}


Surftype Property

Surftype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Surftype
Declaration Syntax
C# Visual Basic Visual C++
public int Surftype { get; set; }
Public Property Surftype As Integer
    Get
    Set
public:
property int Surftype {
    int get ();
    void set (int value);
}


Surfu Property

Surfu Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Surfu
Declaration Syntax
C# Visual Basic Visual C++
public int Surfu { get; set; }
Public Property Surfu As Integer
    Get
    Set
public:
property int Surfu {
    int get ();
    void set (int value);
}


Surfv Property

Surfv Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Surfv
Declaration Syntax
C# Visual Basic Visual C++
public int Surfv { get; set; }
Public Property Surfv As Integer
    Get
    Set
public:
property int Surfv {
    int get ();
    void set (int value);
}


SystemVariableChanged Event

SystemVariableChanged Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SystemVariableChanged
Declaration Syntax
C# Visual Basic Visual C++
public event SystemVariableChangedEventHandler SystemVariableChanged
Public Event SystemVariableChanged As SystemVariableChangedEventHandler
public:
 event SystemVariableChangedEventHandler^ SystemVariableChanged {
    void add (SystemVariableChangedEventHandler^ value);
    void remove (SystemVariableChangedEventHandler^ value);
}


SystemVariableWillChange Event

SystemVariableWillChange Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »SystemVariableWillChange
Declaration Syntax
C# Visual Basic Visual C++
public event SystemVariableChangingEventHandler SystemVariableWillChange
Public Event SystemVariableWillChange As SystemVariableChangingEventHandler
public:
 event SystemVariableChangingEventHandler^ SystemVariableWillChange {
    void add (SystemVariableChangingEventHandler^ value);
    void remove (SystemVariableChangingEventHandler^ value);
}


Tablestyle Property

Tablestyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Tablestyle
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Tablestyle { get; set; }
Public Property Tablestyle As ObjectId
    Get
    Set
public:
property ObjectId Tablestyle {
    ObjectId get ();
    void set (ObjectId value);
}


TableStyleDictionaryId Property

TableStyleDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TableStyleDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId TableStyleDictionaryId { get; }
Public ReadOnly Property TableStyleDictionaryId As ObjectId
    Get
public:
property ObjectId TableStyleDictionaryId {
    ObjectId get ();
}


Tdcreate Property

Tdcreate Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Tdcreate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Tdcreate { get; }
Public ReadOnly Property Tdcreate As DateTime
    Get
public:
property DateTime Tdcreate {
    DateTime get ();
}


Tdindwg Property

Tdindwg Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Tdindwg
Declaration Syntax
C# Visual Basic Visual C++
public TimeSpan Tdindwg { get; }
Public ReadOnly Property Tdindwg As TimeSpan
    Get
public:
property TimeSpan Tdindwg {
    TimeSpan get ();
}


Tducreate Property

Tducreate Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Tducreate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Tducreate { get; }
Public ReadOnly Property Tducreate As DateTime
    Get
public:
property DateTime Tducreate {
    DateTime get ();
}


Tdupdate Property

Tdupdate Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Tdupdate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Tdupdate { get; }
Public ReadOnly Property Tdupdate As DateTime
    Get
public:
property DateTime Tdupdate {
    DateTime get ();
}


Tdusrtimer Property

Tdusrtimer Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Tdusrtimer
Declaration Syntax
C# Visual Basic Visual C++
public TimeSpan Tdusrtimer { get; }
Public ReadOnly Property Tdusrtimer As TimeSpan
    Get
public:
property TimeSpan Tdusrtimer {
    TimeSpan get ();
}


Tduupdate Property

Tduupdate Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Tduupdate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Tduupdate { get; }
Public ReadOnly Property Tduupdate As DateTime
    Get
public:
property DateTime Tduupdate {
    DateTime get ();
}


Textsize Property

Textsize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Textsize
Declaration Syntax
C# Visual Basic Visual C++
public double Textsize { get; set; }
Public Property Textsize As Double
    Get
    Set
public:
property double Textsize {
    double get ();
    void set (double value);
}


Textstyle Property

Textstyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Textstyle
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Textstyle { get; set; }
Public Property Textstyle As ObjectId
    Get
    Set
public:
property ObjectId Textstyle {
    ObjectId get ();
    void set (ObjectId value);
}


TextStyleTableId Property

TextStyleTableId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TextStyleTableId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId TextStyleTableId { get; }
Public ReadOnly Property TextStyleTableId As ObjectId
    Get
public:
property ObjectId TextStyleTableId {
    ObjectId get ();
}


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}


ThumbnailBitmap Property

ThumbnailBitmap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ThumbnailBitmap
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap ThumbnailBitmap { get; set; }
Public Property ThumbnailBitmap As Bitmap
    Get
    Set
public:
property Bitmap^ ThumbnailBitmap {
    Bitmap^ get ();
    void set (Bitmap^ value);
}


TileMode Property

TileMode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TileMode
Declaration Syntax
C# Visual Basic Visual C++
public bool TileMode { get; set; }
Public Property TileMode As Boolean
    Get
    Set
public:
property bool TileMode {
    bool get ();
    void set (bool value);
}


TileModeLightSynch Property

TileModeLightSynch Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TileModeLightSynch
Declaration Syntax
C# Visual Basic Visual C++
public int TileModeLightSynch { get; set; }
Public Property TileModeLightSynch As Integer
    Get
    Set
public:
property int TileModeLightSynch {
    int get ();
    void set (int value);
}


TimeZone Property

TimeZone Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TimeZone
Declaration Syntax
C# Visual Basic Visual C++
public TimeZone TimeZone { get; set; }
Public Property TimeZone As TimeZone
    Get
    Set
public:
property TimeZone TimeZone {
    TimeZone get ();
    void set (TimeZone value);
}


TimeZoneDescription Method (tz)

TimeZoneDescription Method (tz)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TimeZoneDescription(TimeZone)
Declaration Syntax
C# Visual Basic Visual C++
public string TimeZoneDescription(
    TimeZone tz
)
Public Function TimeZoneDescription ( _
    tz As TimeZone _
) As String
public:
String^ TimeZoneDescription(
    TimeZone tz
)
Parameters
tz(TimeZone)


TimeZoneOffset Method (tz)

TimeZoneOffset Method (tz)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TimeZoneOffset(TimeZone)
Declaration Syntax
C# Visual Basic Visual C++
public double TimeZoneOffset(
    TimeZone tz
)
Public Function TimeZoneOffset ( _
    tz As TimeZone _
) As Double
public:
double TimeZoneOffset(
    TimeZone tz
)
Parameters
tz(TimeZone)


Tracewid Property

Tracewid Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Tracewid
Declaration Syntax
C# Visual Basic Visual C++
public double Tracewid { get; set; }
Public Property Tracewid As Double
    Get
    Set
public:
property double Tracewid {
    double get ();
    void set (double value);
}


TransactionManager Property

TransactionManager Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TransactionManager
Declaration Syntax
C# Visual Basic Visual C++
public TransactionManager TransactionManager { get; }
Public ReadOnly Property TransactionManager As TransactionManager
    Get
public:
property TransactionManager^ TransactionManager {
    TransactionManager^ get ();
}


Treedepth Property

Treedepth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Treedepth
Declaration Syntax
C# Visual Basic Visual C++
public int Treedepth { get; set; }
Public Property Treedepth As Integer
    Get
    Set
public:
property int Treedepth {
    int get ();
    void set (int value);
}


TryGetObjectId Method (objHandle, id)

TryGetObjectId Method (objHandle, id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TryGetObjectId(Handle, ObjectId%)
Declaration Syntax
C# Visual Basic Visual C++
public bool TryGetObjectId(
    Handle objHandle,
    out ObjectId id
)
Public Function TryGetObjectId ( _
    objHandle As Handle, _
    <OutAttribute> ByRef id As ObjectId _
) As Boolean
public:
bool TryGetObjectId(
    Handle objHandle,
    [OutAttribute] ObjectId% id
)
Parameters
objHandle(Handle)
id(ObjectId %)


TStackAlign Property

TStackAlign Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TStackAlign
Declaration Syntax
C# Visual Basic Visual C++
public int TStackAlign { get; set; }
Public Property TStackAlign As Integer
    Get
    Set
public:
property int TStackAlign {
    int get ();
    void set (int value);
}


TstackSize Property

TstackSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »TstackSize
Declaration Syntax
C# Visual Basic Visual C++
public int TstackSize { get; set; }
Public Property TstackSize As Integer
    Get
    Set
public:
property int TstackSize {
    int get ();
    void set (int value);
}


UcsBase Property

UcsBase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »UcsBase
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId UcsBase { get; set; }
Public Property UcsBase As ObjectId
    Get
    Set
public:
property ObjectId UcsBase {
    ObjectId get ();
    void set (ObjectId value);
}


Ucsname Property

Ucsname Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Ucsname
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Ucsname { get; }
Public ReadOnly Property Ucsname As ObjectId
    Get
public:
property ObjectId Ucsname {
    ObjectId get ();
}


Ucsorg Property

Ucsorg Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Ucsorg
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Ucsorg { get; }
Public ReadOnly Property Ucsorg As Point3d
    Get
public:
property Point3d Ucsorg {
    Point3d get ();
}


UcsOrthographic Property

UcsOrthographic Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »UcsOrthographic
Declaration Syntax
C# Visual Basic Visual C++
public OrthographicView UcsOrthographic { get; }
Public ReadOnly Property UcsOrthographic As OrthographicView
    Get
public:
property OrthographicView UcsOrthographic {
    OrthographicView get ();
}


UcsTableId Property

UcsTableId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »UcsTableId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId UcsTableId { get; }
Public ReadOnly Property UcsTableId As ObjectId
    Get
public:
property ObjectId UcsTableId {
    ObjectId get ();
}


Ucsxdir Property

Ucsxdir Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Ucsxdir
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Ucsxdir { get; }
Public ReadOnly Property Ucsxdir As Vector3d
    Get
public:
property Vector3d Ucsxdir {
    Vector3d get ();
}


Ucsydir Property

Ucsydir Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Ucsydir
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Ucsydir { get; }
Public ReadOnly Property Ucsydir As Vector3d
    Get
public:
property Vector3d Ucsydir {
    Vector3d get ();
}


Undo Method

Undo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Undo()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Undo()
Public Sub Undo
public:
void Undo()


UndoRecording Property

UndoRecording Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »UndoRecording
Declaration Syntax
C# Visual Basic Visual C++
public bool UndoRecording { get; }
Public ReadOnly Property UndoRecording As Boolean
    Get
public:
property bool UndoRecording {
    bool get ();
}


Unitmode Property

Unitmode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Unitmode
Declaration Syntax
C# Visual Basic Visual C++
public int Unitmode { get; set; }
Public Property Unitmode As Integer
    Get
    Set
public:
property int Unitmode {
    int get ();
    void set (int value);
}


UnloadXrefs Method (xrefIds)

UnloadXrefs Method (xrefIds)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »UnloadXrefs(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void UnloadXrefs(
    ObjectIdCollection xrefIds
)
Public Sub UnloadXrefs ( _
    xrefIds As ObjectIdCollection _
)
public:
void UnloadXrefs(
    ObjectIdCollection^ xrefIds
)
Parameters
xrefIds(ObjectIdCollection)


UpdateExt Method (doBestFit)

UpdateExt Method (doBestFit)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »UpdateExt(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateExt(
    bool doBestFit
)
Public Sub UpdateExt ( _
    doBestFit As Boolean _
)
public:
void UpdateExt(
    bool doBestFit
)
Parameters
doBestFit(Boolean)


Useri1 Property

Useri1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Useri1
Declaration Syntax
C# Visual Basic Visual C++
public int Useri1 { get; set; }
Public Property Useri1 As Integer
    Get
    Set
public:
property int Useri1 {
    int get ();
    void set (int value);
}


Useri2 Property

Useri2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Useri2
Declaration Syntax
C# Visual Basic Visual C++
public int Useri2 { get; set; }
Public Property Useri2 As Integer
    Get
    Set
public:
property int Useri2 {
    int get ();
    void set (int value);
}


Useri3 Property

Useri3 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Useri3
Declaration Syntax
C# Visual Basic Visual C++
public int Useri3 { get; set; }
Public Property Useri3 As Integer
    Get
    Set
public:
property int Useri3 {
    int get ();
    void set (int value);
}


Useri4 Property

Useri4 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Useri4
Declaration Syntax
C# Visual Basic Visual C++
public int Useri4 { get; set; }
Public Property Useri4 As Integer
    Get
    Set
public:
property int Useri4 {
    int get ();
    void set (int value);
}


Useri5 Property

Useri5 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Useri5
Declaration Syntax
C# Visual Basic Visual C++
public int Useri5 { get; set; }
Public Property Useri5 As Integer
    Get
    Set
public:
property int Useri5 {
    int get ();
    void set (int value);
}


Userr1 Property

Userr1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Userr1
Declaration Syntax
C# Visual Basic Visual C++
public double Userr1 { get; set; }
Public Property Userr1 As Double
    Get
    Set
public:
property double Userr1 {
    double get ();
    void set (double value);
}


Userr2 Property

Userr2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Userr2
Declaration Syntax
C# Visual Basic Visual C++
public double Userr2 { get; set; }
Public Property Userr2 As Double
    Get
    Set
public:
property double Userr2 {
    double get ();
    void set (double value);
}


Userr3 Property

Userr3 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Userr3
Declaration Syntax
C# Visual Basic Visual C++
public double Userr3 { get; set; }
Public Property Userr3 As Double
    Get
    Set
public:
property double Userr3 {
    double get ();
    void set (double value);
}


Userr4 Property

Userr4 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Userr4
Declaration Syntax
C# Visual Basic Visual C++
public double Userr4 { get; set; }
Public Property Userr4 As Double
    Get
    Set
public:
property double Userr4 {
    double get ();
    void set (double value);
}


Userr5 Property

Userr5 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Userr5
Declaration Syntax
C# Visual Basic Visual C++
public double Userr5 { get; set; }
Public Property Userr5 As Double
    Get
    Set
public:
property double Userr5 {
    double get ();
    void set (double value);
}


Usrtimer Property

Usrtimer Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Usrtimer
Declaration Syntax
C# Visual Basic Visual C++
public bool Usrtimer { get; set; }
Public Property Usrtimer As Boolean
    Get
    Set
public:
property bool Usrtimer {
    bool get ();
    void set (bool value);
}


VersionGuid Property

VersionGuid Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »VersionGuid
Declaration Syntax
C# Visual Basic Visual C++
public string VersionGuid { get; set; }
Public Property VersionGuid As String
    Get
    Set
public:
property String^ VersionGuid {
    String^ get ();
    void set (String^ value);
}


ViewportScaleDefault Property

ViewportScaleDefault Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ViewportScaleDefault
Declaration Syntax
C# Visual Basic Visual C++
public double ViewportScaleDefault { get; set; }
Public Property ViewportScaleDefault As Double
    Get
    Set
public:
property double ViewportScaleDefault {
    double get ();
    void set (double value);
}


ViewportTableId Property

ViewportTableId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ViewportTableId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ViewportTableId { get; }
Public ReadOnly Property ViewportTableId As ObjectId
    Get
public:
property ObjectId ViewportTableId {
    ObjectId get ();
}


ViewTableId Property

ViewTableId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ViewTableId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ViewTableId { get; }
Public ReadOnly Property ViewTableId As ObjectId
    Get
public:
property ObjectId ViewTableId {
    ObjectId get ();
}


Visretain Property

Visretain Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Visretain
Declaration Syntax
C# Visual Basic Visual C++
public bool Visretain { get; set; }
Public Property Visretain As Boolean
    Get
    Set
public:
property bool Visretain {
    bool get ();
    void set (bool value);
}


VisualStyleDictionaryId Property

VisualStyleDictionaryId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »VisualStyleDictionaryId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId VisualStyleDictionaryId { get; }
Public ReadOnly Property VisualStyleDictionaryId As ObjectId
    Get
public:
property ObjectId VisualStyleDictionaryId {
    ObjectId get ();
}


Wblock Method

Wblock Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Wblock()()()()
Members
Icon | Member | Description
 | Wblock(Database, ObjectIdCollection, Point3d, DuplicateRecordCloning) |
 | Wblock(ObjectIdCollection, Point3d) |
 | Wblock(ObjectId) |
 | Wblock()()()() |


Wblock Method

Wblock Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Wblock()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Database Wblock()
Public Function Wblock As Database
public:
Database^ Wblock()


Wblock Method (outputDataBase, outObjIds, basePoint, cloning)

Wblock Method (outputDataBase, outObjIds, basePoint, cloning)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Wblock(Database, ObjectIdCollection, Point3d, DuplicateRecordCloning)
Declaration Syntax
C# Visual Basic Visual C++
public void Wblock(
    Database outputDataBase,
    ObjectIdCollection outObjIds,
    Point3d basePoint,
    DuplicateRecordCloning cloning
)
Public Sub Wblock ( _
    outputDataBase As Database, _
    outObjIds As ObjectIdCollection, _
    basePoint As Point3d, _
    cloning As DuplicateRecordCloning _
)
public:
void Wblock(
    Database^ outputDataBase,
    ObjectIdCollection^ outObjIds,
    Point3d basePoint,
    DuplicateRecordCloning cloning
)
Parameters
outputDataBase(Database)
outObjIds(ObjectIdCollection)
basePoint(Point3d)
cloning(DuplicateRecordCloning)


Wblock Method (blockId)

Wblock Method (blockId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Wblock(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public Database Wblock(
    ObjectId blockId
)
Public Function Wblock ( _
    blockId As ObjectId _
) As Database
public:
Database^ Wblock(
    ObjectId blockId
)
Parameters
blockId(ObjectId)


Wblock Method (outObjIds, basePoint)

Wblock Method (outObjIds, basePoint)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Wblock(ObjectIdCollection, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Database Wblock(
    ObjectIdCollection outObjIds,
    Point3d basePoint
)
Public Function Wblock ( _
    outObjIds As ObjectIdCollection, _
    basePoint As Point3d _
) As Database
public:
Database^ Wblock(
    ObjectIdCollection^ outObjIds,
    Point3d basePoint
)
Parameters
outObjIds(ObjectIdCollection)
basePoint(Point3d)


WblockAborted Event

WblockAborted Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »WblockAborted
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler WblockAborted
Public Event WblockAborted As EventHandler
public:
 event EventHandler^ WblockAborted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


WblockCloneObjects Method (identifiers, id, mapping, cloning, deferTranslation)

WblockCloneObjects Method (identifiers, id, mapping, cloning, deferTranslation)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »WblockCloneObjects(ObjectIdCollection, ObjectId, IdMapping, DuplicateRecordCloning, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void WblockCloneObjects(
    ObjectIdCollection identifiers,
    ObjectId id,
    IdMapping mapping,
    DuplicateRecordCloning cloning,
    bool deferTranslation
)
Public Sub WblockCloneObjects ( _
    identifiers As ObjectIdCollection, _
    id As ObjectId, _
    mapping As IdMapping, _
    cloning As DuplicateRecordCloning, _
    deferTranslation As Boolean _
)
public:
void WblockCloneObjects(
    ObjectIdCollection^ identifiers,
    ObjectId id,
    IdMapping^ mapping,
    DuplicateRecordCloning cloning,
    bool deferTranslation
)
Parameters
identifiers(ObjectIdCollection)
id(ObjectId)
mapping(IdMapping)
cloning(DuplicateRecordCloning)
deferTranslation(Boolean)


WblockEnded Event

WblockEnded Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »WblockEnded
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler WblockEnded
Public Event WblockEnded As EventHandler
public:
 event EventHandler^ WblockEnded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


WblockMappingAvailable Event

WblockMappingAvailable Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »WblockMappingAvailable
Declaration Syntax
C# Visual Basic Visual C++
public event IdMappingEventHandler WblockMappingAvailable
Public Event WblockMappingAvailable As IdMappingEventHandler
public:
 event IdMappingEventHandler^ WblockMappingAvailable {
    void add (IdMappingEventHandler^ value);
    void remove (IdMappingEventHandler^ value);
}


WblockNotice Event

WblockNotice Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »WblockNotice
Declaration Syntax
C# Visual Basic Visual C++
public event WblockNoticeEventHandler WblockNotice
Public Event WblockNotice As WblockNoticeEventHandler
public:
 event WblockNoticeEventHandler^ WblockNotice {
    void add (WblockNoticeEventHandler^ value);
    void remove (WblockNoticeEventHandler^ value);
}


WorldPaperspaceUcsBaseOrigin Method (orthoView)

WorldPaperspaceUcsBaseOrigin Method (orthoView)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »WorldPaperspaceUcsBaseOrigin(OrthographicView)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d WorldPaperspaceUcsBaseOrigin(
    OrthographicView orthoView
)
Public Function WorldPaperspaceUcsBaseOrigin ( _
    orthoView As OrthographicView _
) As Point3d
public:
Point3d WorldPaperspaceUcsBaseOrigin(
    OrthographicView orthoView
)
Parameters
orthoView(OrthographicView)


WorldUcsBaseOrigin Method (orthoView)

WorldUcsBaseOrigin Method (orthoView)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »WorldUcsBaseOrigin(OrthographicView)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d WorldUcsBaseOrigin(
    OrthographicView orthoView
)
Public Function WorldUcsBaseOrigin ( _
    orthoView As OrthographicView _
) As Point3d
public:
Point3d WorldUcsBaseOrigin(
    OrthographicView orthoView
)
Parameters
orthoView(OrthographicView)


Worldview Property

Worldview Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Worldview
Declaration Syntax
C# Visual Basic Visual C++
public bool Worldview { get; set; }
Public Property Worldview As Boolean
    Get
    Set
public:
property bool Worldview {
    bool get ();
    void set (bool value);
}


XBindXrefs Method (xrefSymbolIds, insertBind)

XBindXrefs Method (xrefSymbolIds, insertBind)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XBindXrefs(ObjectIdCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void XBindXrefs(
    ObjectIdCollection xrefSymbolIds,
    bool insertBind
)
Public Sub XBindXrefs ( _
    xrefSymbolIds As ObjectIdCollection, _
    insertBind As Boolean _
)
public:
void XBindXrefs(
    ObjectIdCollection^ xrefSymbolIds,
    bool insertBind
)
Parameters
xrefSymbolIds(ObjectIdCollection)
insertBind(Boolean)


XclipFrame Property

XclipFrame Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XclipFrame
Declaration Syntax
C# Visual Basic Visual C++
public bool XclipFrame { get; set; }
Public Property XclipFrame As Boolean
    Get
    Set
public:
property bool XclipFrame {
    bool get ();
    void set (bool value);
}


XrefAttachAborted Event

XrefAttachAborted Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefAttachAborted
Declaration Syntax
C# Visual Basic Visual C++
public static event EventHandler XrefAttachAborted
Public Shared Event XrefAttachAborted As EventHandler
public:
static  event EventHandler^ XrefAttachAborted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


XrefAttachEnded Event

XrefAttachEnded Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefAttachEnded
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler XrefAttachEnded
Public Event XrefAttachEnded As EventHandler
public:
 event EventHandler^ XrefAttachEnded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


XrefBeginAttached Event

XrefBeginAttached Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefBeginAttached
Declaration Syntax
C# Visual Basic Visual C++
public event XrefBeginOperationEventHandler XrefBeginAttached
Public Event XrefBeginAttached As XrefBeginOperationEventHandler
public:
 event XrefBeginOperationEventHandler^ XrefBeginAttached {
    void add (XrefBeginOperationEventHandler^ value);
    void remove (XrefBeginOperationEventHandler^ value);
}


XrefBeginOtherAttached Event

XrefBeginOtherAttached Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefBeginOtherAttached
Declaration Syntax
C# Visual Basic Visual C++
public event XrefBeginOperationEventHandler XrefBeginOtherAttached
Public Event XrefBeginOtherAttached As XrefBeginOperationEventHandler
public:
 event XrefBeginOperationEventHandler^ XrefBeginOtherAttached {
    void add (XrefBeginOperationEventHandler^ value);
    void remove (XrefBeginOperationEventHandler^ value);
}


XrefBeginRestore Event

XrefBeginRestore Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefBeginRestore
Declaration Syntax
C# Visual Basic Visual C++
public event XrefBeginOperationEventHandler XrefBeginRestore
Public Event XrefBeginRestore As XrefBeginOperationEventHandler
public:
 event XrefBeginOperationEventHandler^ XrefBeginRestore {
    void add (XrefBeginOperationEventHandler^ value);
    void remove (XrefBeginOperationEventHandler^ value);
}


XrefBlockId Property

XrefBlockId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefBlockId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId XrefBlockId { get; }
Public ReadOnly Property XrefBlockId As ObjectId
    Get
public:
property ObjectId XrefBlockId {
    ObjectId get ();
}


XrefComandeered Event

XrefComandeered Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefComandeered
Declaration Syntax
C# Visual Basic Visual C++
public event XrefComandeeredEventHandler XrefComandeered
Public Event XrefComandeered As XrefComandeeredEventHandler
public:
 event XrefComandeeredEventHandler^ XrefComandeered {
    void add (XrefComandeeredEventHandler^ value);
    void remove (XrefComandeeredEventHandler^ value);
}


XrefEditEnabled Property

XrefEditEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefEditEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool XrefEditEnabled { get; set; }
Public Property XrefEditEnabled As Boolean
    Get
    Set
public:
property bool XrefEditEnabled {
    bool get ();
    void set (bool value);
}


XrefPreXrefLockFile Event

XrefPreXrefLockFile Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefPreXrefLockFile
Declaration Syntax
C# Visual Basic Visual C++
public event XrefPreXrefLockFileEventHandler XrefPreXrefLockFile
Public Event XrefPreXrefLockFile As XrefPreXrefLockFileEventHandler
public:
 event XrefPreXrefLockFileEventHandler^ XrefPreXrefLockFile {
    void add (XrefPreXrefLockFileEventHandler^ value);
    void remove (XrefPreXrefLockFileEventHandler^ value);
}


XrefRedirected Event

XrefRedirected Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefRedirected
Declaration Syntax
C# Visual Basic Visual C++
public event XrefRedirectedEventHandler XrefRedirected
Public Event XrefRedirected As XrefRedirectedEventHandler
public:
 event XrefRedirectedEventHandler^ XrefRedirected {
    void add (XrefRedirectedEventHandler^ value);
    void remove (XrefRedirectedEventHandler^ value);
}


XrefRestoreAborted Event

XrefRestoreAborted Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefRestoreAborted
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler XrefRestoreAborted
Public Event XrefRestoreAborted As EventHandler
public:
 event EventHandler^ XrefRestoreAborted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


XrefRestoreEnded Event

XrefRestoreEnded Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefRestoreEnded
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler XrefRestoreEnded
Public Event XrefRestoreEnded As EventHandler
public:
 event EventHandler^ XrefRestoreEnded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


XrefSubCommandAborted Event

XrefSubCommandAborted Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefSubCommandAborted
Declaration Syntax
C# Visual Basic Visual C++
public event XrefSubCommandAbortedEventHandler XrefSubCommandAborted
Public Event XrefSubCommandAborted As XrefSubCommandAbortedEventHandler
public:
 event XrefSubCommandAbortedEventHandler^ XrefSubCommandAborted {
    void add (XrefSubCommandAbortedEventHandler^ value);
    void remove (XrefSubCommandAbortedEventHandler^ value);
}


XrefSubCommandStart Event

XrefSubCommandStart Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »XrefSubCommandStart
Declaration Syntax
C# Visual Basic Visual C++
public event XrefSubCommandStartEventHandler XrefSubCommandStart
Public Event XrefSubCommandStart As XrefSubCommandStartEventHandler
public:
 event XrefSubCommandStartEventHandler^ XrefSubCommandStart {
    void add (XrefSubCommandStartEventHandler^ value);
    void remove (XrefSubCommandStartEventHandler^ value);
}


ZcadDatabase Property

ZcadDatabase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »ZcadDatabase
Declaration Syntax
C# Visual Basic Visual C++
public Object ZcadDatabase { get; }
Public ReadOnly Property ZcadDatabase As Object
    Get
public:
property Object^ ZcadDatabase {
    Object^ get ();
}


DatabaseIOEventArgs Class

DatabaseIOEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseIOEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DatabaseIOEventArgs : EventArgs
Public NotInheritable Class DatabaseIOEventArgs _
    Inherits EventArgs
public ref class DatabaseIOEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | FileName |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DatabaseIOEventArgs


FileName Property

FileName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseIOEventArgs »FileName
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}


DatabaseIOEventHandler Delegate

DatabaseIOEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseIOEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DatabaseIOEventHandler(
    Object sender,
    DatabaseIOEventArgs e
)
Public Delegate Sub DatabaseIOEventHandler ( _
    sender As Object, _
    e As DatabaseIOEventArgs _
)
public delegate void DatabaseIOEventHandler(
    Object^ sender,
    DatabaseIOEventArgs^ e
)
Parameters
sender(Object)
e(DatabaseIOEventArgs)


DatabaseSummaryInfo Structure

DatabaseSummaryInfo Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDatabaseSummaryInfo")]
public struct DatabaseSummaryInfo
<WrapperAttribute("ZcDbDatabaseSummaryInfo")> _
Public Structure DatabaseSummaryInfo
[WrapperAttribute(L"ZcDbDatabaseSummaryInfo")]
public value class DatabaseSummaryInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Author |
 | Comments |
 | CustomProperties |
 | Equality(DatabaseSummaryInfo, DatabaseSummaryInfo) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | HyperlinkBase |
 | Inequality(DatabaseSummaryInfo, DatabaseSummaryInfo) |
 | Keywords |
 | LastSavedBy |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RevisionNumber |
 | Subject |
 | Title |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


Author Property

Author Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »Author
Declaration Syntax
C# Visual Basic Visual C++
public string Author { get; }
Public ReadOnly Property Author As String
    Get
public:
property String^ Author {
    String^ get ();
}


Comments Property

Comments Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »Comments
Declaration Syntax
C# Visual Basic Visual C++
public string Comments { get; }
Public ReadOnly Property Comments As String
    Get
public:
property String^ Comments {
    String^ get ();
}


CustomProperties Property

CustomProperties Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »CustomProperties
Declaration Syntax
C# Visual Basic Visual C++
public IDictionaryEnumerator CustomProperties { get; }
Public ReadOnly Property CustomProperties As IDictionaryEnumerator
    Get
public:
property IDictionaryEnumerator^ CustomProperties {
    IDictionaryEnumerator^ get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »Equality(DatabaseSummaryInfo, DatabaseSummaryInfo)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    DatabaseSummaryInfo a,
    DatabaseSummaryInfo b
)
Public Shared Operator = ( _
    a As DatabaseSummaryInfo, _
    b As DatabaseSummaryInfo _
) As Boolean
public:
static bool operator ==(
    DatabaseSummaryInfo a,
    DatabaseSummaryInfo b
)
Parameters
a(DatabaseSummaryInfo)
b(DatabaseSummaryInfo)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


HyperlinkBase Property

HyperlinkBase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »HyperlinkBase
Declaration Syntax
C# Visual Basic Visual C++
public string HyperlinkBase { get; }
Public ReadOnly Property HyperlinkBase As String
    Get
public:
property String^ HyperlinkBase {
    String^ get ();
}


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »Inequality(DatabaseSummaryInfo, DatabaseSummaryInfo)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    DatabaseSummaryInfo a,
    DatabaseSummaryInfo b
)
Public Shared Operator <> ( _
    a As DatabaseSummaryInfo, _
    b As DatabaseSummaryInfo _
) As Boolean
public:
static bool operator !=(
    DatabaseSummaryInfo a,
    DatabaseSummaryInfo b
)
Parameters
a(DatabaseSummaryInfo)
b(DatabaseSummaryInfo)


Keywords Property

Keywords Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »Keywords
Declaration Syntax
C# Visual Basic Visual C++
public string Keywords { get; }
Public ReadOnly Property Keywords As String
    Get
public:
property String^ Keywords {
    String^ get ();
}


LastSavedBy Property

LastSavedBy Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »LastSavedBy
Declaration Syntax
C# Visual Basic Visual C++
public string LastSavedBy { get; }
Public ReadOnly Property LastSavedBy As String
    Get
public:
property String^ LastSavedBy {
    String^ get ();
}


RevisionNumber Property

RevisionNumber Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »RevisionNumber
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionNumber { get; }
Public ReadOnly Property RevisionNumber As String
    Get
public:
property String^ RevisionNumber {
    String^ get ();
}


Subject Property

Subject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »Subject
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; }
Public ReadOnly Property Subject As String
    Get
public:
property String^ Subject {
    String^ get ();
}


Title Property

Title Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »Title
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfo »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


DatabaseSummaryInfoBuilder Class

DatabaseSummaryInfoBuilder Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder
Declaration Syntax
C# Visual Basic Visual C++
public class DatabaseSummaryInfoBuilder
Public Class DatabaseSummaryInfoBuilder
public ref class DatabaseSummaryInfoBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseSummaryInfoBuilder(DatabaseSummaryInfo) |
 | DatabaseSummaryInfoBuilder()()()() |
 | Author |
 | Comments |
 | CustomProperties | Obsolete.
 | CustomPropertyTable |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HyperlinkBase |
 | Keywords |
 | LastSavedBy |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RevisionNumber |
 | Subject |
 | Title |
 | ToDatabaseSummaryInfo()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DatabaseSummaryInfoBuilder


DatabaseSummaryInfoBuilder Constructor

DatabaseSummaryInfoBuilder Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »DatabaseSummaryInfoBuilder()()()()
Members
Icon | Member | Description
 | DatabaseSummaryInfoBuilder(DatabaseSummaryInfo) |
 | DatabaseSummaryInfoBuilder()()()() |


DatabaseSummaryInfoBuilder Constructor

DatabaseSummaryInfoBuilder Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »DatabaseSummaryInfoBuilder()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DatabaseSummaryInfoBuilder()
Public Sub New
public:
DatabaseSummaryInfoBuilder()


DatabaseSummaryInfoBuilder Constructor (value)

DatabaseSummaryInfoBuilder Constructor (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »DatabaseSummaryInfoBuilder(DatabaseSummaryInfo)
Declaration Syntax
C# Visual Basic Visual C++
public DatabaseSummaryInfoBuilder(
    DatabaseSummaryInfo value
)
Public Sub New ( _
    value As DatabaseSummaryInfo _
)
public:
DatabaseSummaryInfoBuilder(
    DatabaseSummaryInfo value
)
Parameters
value(DatabaseSummaryInfo)


Author Property

Author Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »Author
Declaration Syntax
C# Visual Basic Visual C++
public string Author { get; set; }
Public Property Author As String
    Get
    Set
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}


Comments Property

Comments Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »Comments
Declaration Syntax
C# Visual Basic Visual C++
public string Comments { get; set; }
Public Property Comments As String
    Get
    Set
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}


CustomProperties Property

CustomProperties Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »CustomProperties
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use CustomPropertyTable instead")]
public StringDictionary CustomProperties { get; }
<ObsoleteAttribute("Use CustomPropertyTable instead")> _
Public ReadOnly Property CustomProperties As StringDictionary
    Get
[ObsoleteAttribute(L"Use CustomPropertyTable instead")]
public:
property StringDictionary^ CustomProperties {
    StringDictionary^ get ();
}


CustomPropertyTable Property

CustomPropertyTable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »CustomPropertyTable
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary CustomPropertyTable { get; }
Public ReadOnly Property CustomPropertyTable As IDictionary
    Get
public:
property IDictionary^ CustomPropertyTable {
    IDictionary^ get ();
}


HyperlinkBase Property

HyperlinkBase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »HyperlinkBase
Declaration Syntax
C# Visual Basic Visual C++
public string HyperlinkBase { get; set; }
Public Property HyperlinkBase As String
    Get
    Set
public:
property String^ HyperlinkBase {
    String^ get ();
    void set (String^ value);
}


Keywords Property

Keywords Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »Keywords
Declaration Syntax
C# Visual Basic Visual C++
public string Keywords { get; set; }
Public Property Keywords As String
    Get
    Set
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}


LastSavedBy Property

LastSavedBy Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »LastSavedBy
Declaration Syntax
C# Visual Basic Visual C++
public string LastSavedBy { get; set; }
Public Property LastSavedBy As String
    Get
    Set
public:
property String^ LastSavedBy {
    String^ get ();
    void set (String^ value);
}


RevisionNumber Property

RevisionNumber Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »RevisionNumber
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionNumber { get; set; }
Public Property RevisionNumber As String
    Get
    Set
public:
property String^ RevisionNumber {
    String^ get ();
    void set (String^ value);
}


Subject Property

Subject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »Subject
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}


Title Property

Title Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »Title
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}


ToDatabaseSummaryInfo Method

ToDatabaseSummaryInfo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DatabaseSummaryInfoBuilder »ToDatabaseSummaryInfo()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DatabaseSummaryInfo ToDatabaseSummaryInfo()
Public Function ToDatabaseSummaryInfo As DatabaseSummaryInfo
public:
DatabaseSummaryInfo ToDatabaseSummaryInfo()


DataCell Class

DataCell Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDataCell")]
public sealed class DataCell : RXObject
<WrapperAttribute("ZcDbDataCell")> _
Public NotInheritable Class DataCell _
    Inherits RXObject
[WrapperAttribute(L"ZcDbDataCell")]
public ref class DataCell sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCell()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CellType |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | Init()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SetBool(Boolean) |
 | SetDouble(Double) |
 | SetHardOwnershipId(ObjectId) |
 | SetHardPointerId(ObjectId) |
 | SetInteger(Int32) |
 | SetObjectId(ObjectId) |
 | SetPoint(Point3d) |
 | SetSoftOwnershipId(ObjectId) |
 | SetSoftPointerId(ObjectId) |
 | SetString(String) |
 | SetVector(Vector3d) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Value |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DataCell


DataCell Constructor

DataCell Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »DataCell()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DataCell()
Public Sub New
public:
DataCell()


CellType Property

CellType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »CellType
Declaration Syntax
C# Visual Basic Visual C++
public CellType CellType { get; }
Public ReadOnly Property CellType As CellType
    Get
public:
property CellType CellType {
    CellType get ();
}


Init Method

Init Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »Init()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Init()
Public Sub Init
public:
void Init()


SetBool Method (value)

SetBool Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetBool(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetBool(
    bool value
)
Public Sub SetBool ( _
    value As Boolean _
)
public:
void SetBool(
    bool value
)
Parameters
value(Boolean)


SetDouble Method (value)

SetDouble Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetDouble(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDouble(
    double value
)
Public Sub SetDouble ( _
    value As Double _
)
public:
void SetDouble(
    double value
)
Parameters
value(Double)


SetHardOwnershipId Method (value)

SetHardOwnershipId Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetHardOwnershipId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHardOwnershipId(
    ObjectId value
)
Public Sub SetHardOwnershipId ( _
    value As ObjectId _
)
public:
void SetHardOwnershipId(
    ObjectId value
)
Parameters
value(ObjectId)


SetHardPointerId Method (value)

SetHardPointerId Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetHardPointerId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHardPointerId(
    ObjectId value
)
Public Sub SetHardPointerId ( _
    value As ObjectId _
)
public:
void SetHardPointerId(
    ObjectId value
)
Parameters
value(ObjectId)


SetInteger Method (value)

SetInteger Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetInteger(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SetInteger(
    int value
)
Public Sub SetInteger ( _
    value As Integer _
)
public:
void SetInteger(
    int value
)
Parameters
value(Int32)


SetObjectId Method (value)

SetObjectId Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetObjectId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetObjectId(
    ObjectId value
)
Public Sub SetObjectId ( _
    value As ObjectId _
)
public:
void SetObjectId(
    ObjectId value
)
Parameters
value(ObjectId)


SetPoint Method (value)

SetPoint Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetPoint(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPoint(
    Point3d value
)
Public Sub SetPoint ( _
    value As Point3d _
)
public:
void SetPoint(
    Point3d value
)
Parameters
value(Point3d)


SetSoftOwnershipId Method (value)

SetSoftOwnershipId Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetSoftOwnershipId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetSoftOwnershipId(
    ObjectId value
)
Public Sub SetSoftOwnershipId ( _
    value As ObjectId _
)
public:
void SetSoftOwnershipId(
    ObjectId value
)
Parameters
value(ObjectId)


SetSoftPointerId Method (value)

SetSoftPointerId Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetSoftPointerId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetSoftPointerId(
    ObjectId value
)
Public Sub SetSoftPointerId ( _
    value As ObjectId _
)
public:
void SetSoftPointerId(
    ObjectId value
)
Parameters
value(ObjectId)


SetString Method (value)

SetString Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetString(String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetString(
    string value
)
Public Sub SetString ( _
    value As String _
)
public:
void SetString(
    String^ value
)
Parameters
value(String)


SetVector Method (value)

SetVector Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »SetVector(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetVector(
    Vector3d value
)
Public Sub SetVector ( _
    value As Vector3d _
)
public:
void SetVector(
    Vector3d value
)
Parameters
value(Vector3d)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »Value
Declaration Syntax
C# Visual Basic Visual C++
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
public:
property Object^ Value {
    Object^ get ();
}


DataCellCollection Class

DataCellCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDataCellArray")]
public sealed class DataCellCollection : DisposableWrapper,
    IList
<WrapperAttribute("ZcDbDataCellArray")> _
Public NotInheritable Class DataCellCollection _
    Inherits DisposableWrapper _
    Implements IList
[WrapperAttribute(L"ZcDbDataCellArray")]
public ref class DataCellCollection sealed : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataCellCollection()()()() |
 | Add(DataCell) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(DataCell) |
 | CopyTo(array<DataCell>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..IsFixedSize |
 | IList..::..IsReadOnly |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(DataCell) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, DataCell) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(DataCell) |
 | RemoveAt(Int32) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | DataCellCollection


DataCellCollection Constructor

DataCellCollection Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »DataCellCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DataCellCollection()
Public Sub New
public:
DataCellCollection()


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »Add(DataCell)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DataCell value
)
Public Function Add ( _
    value As DataCell _
) As Integer
public:
int Add(
    DataCell^ value
)
Parameters
value(DataCell)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »Contains(DataCell)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DataCell value
)
Public Function Contains ( _
    value As DataCell _
) As Boolean
public:
bool Contains(
    DataCell^ value
)
Parameters
value(DataCell)


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »CopyTo(array<DataCell>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DataCell[] arr,
    int index
)
Public Sub CopyTo ( _
    arr As DataCell(), _
    index As Integer _
)
public:
void CopyTo(
    array<DataCell^>^ arr,
    int index
)
Parameters
arr(array< DataCell >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (arr, index)

ICollectionCopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array arr,
    int index
)
Private Sub ICollectionCopyTo ( _
    arr As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ arr,
    int index
) sealed = ICollection::CopyTo
Parameters
arr(Array)
index(Int32)


IListAdd Method (value)

IListAdd Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IListAdd ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IListAdd(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IListContains Method (value)

IListContains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IListContains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IListContains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IListIndexOf Method (value)

IListIndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IListIndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IListIndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IListInsert Method (index, value)

IListInsert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IListInsert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IListInsert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IListIsFixedSize Property

IListIsFixedSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »IList..::..IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
bool IList.IsFixedSize { get; }
Private ReadOnly Property IListIsFixedSize As Boolean
    Implements IList.IsFixedSize
    Get
private:
virtual property bool IListIsFixedSize {
    bool get () sealed = IList::IsFixedSize::get;
}


IListIsReadOnly Property

IListIsReadOnly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »IList..::..IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
bool IList.IsReadOnly { get; }
Private ReadOnly Property IListIsReadOnly As Boolean
    Implements IList.IsReadOnly
    Get
private:
virtual property bool IListIsReadOnly {
    bool get () sealed = IList::IsReadOnly::get;
}


IListItem Property (index)

IListItem Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IListItem ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IListItem[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IListRemove Method (value)

IListRemove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IListRemove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IListRemove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »IndexOf(DataCell)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DataCell value
)
Public Function IndexOf ( _
    value As DataCell _
) As Integer
public:
int IndexOf(
    DataCell^ value
)
Parameters
value(DataCell)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »Insert(Int32, DataCell)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DataCell value
)
Public Sub Insert ( _
    index As Integer, _
    value As DataCell _
)
public:
void Insert(
    int index,
    DataCell^ value
)
Parameters
index(Int32)
value(DataCell)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DataCell this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DataCell
    Get
    Set
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »Remove(DataCell)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DataCell value
)
Public Sub Remove ( _
    value As DataCell _
)
public:
void Remove(
    DataCell^ value
)
Parameters
value(DataCell)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


DataColumn Class

DataColumn Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDataColumn")]
public class DataColumn : RXObject
<WrapperAttribute("ZcDbDataColumn")> _
Public Class DataColumn _
    Inherits RXObject
[WrapperAttribute(L"ZcDbDataColumn")]
public ref class DataColumn : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataColumn(CellType, String) |
 | DataColumn(DataColumn) |
 | DataColumn()()()() |
 | DataColumn(IntPtr, Boolean) |
 | AppendCell(DataCell) |
 | Assign(DataColumn) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | ColumnName |
 | ColumnType |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetCellAt(Int32) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetIndexAtCell(DataCell) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | GrowLength |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertCellAt(Int32, DataCell) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumCells |
 | PhysicalLength |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RemoveCellAt(Int32) |
 | SetCellAt(Int32, DataCell) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DataColumn


DataColumn Constructor

DataColumn Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »DataColumn()()()()
Members
Icon | Member | Description
 | DataColumn(CellType, String) |
 | DataColumn(DataColumn) |
 | DataColumn()()()() |
 | DataColumn(IntPtr, Boolean) |


DataColumn Constructor

DataColumn Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »DataColumn()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DataColumn()
Public Sub New
public:
DataColumn()


DataColumn Constructor (unmanagedPointer, autoDelete)

DataColumn Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »DataColumn(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DataColumn(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DataColumn(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DataColumn Constructor (type, columnName)

DataColumn Constructor (type, columnName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »DataColumn(CellType, String)
Declaration Syntax
C# Visual Basic Visual C++
public DataColumn(
    CellType type,
    string columnName
)
Public Sub New ( _
    type As CellType, _
    columnName As String _
)
public:
DataColumn(
    CellType type,
    String^ columnName
)
Parameters
type(CellType)
columnName(String)


DataColumn Constructor (column)

DataColumn Constructor (column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »DataColumn(DataColumn)
Declaration Syntax
C# Visual Basic Visual C++
public DataColumn(
    DataColumn column
)
Public Sub New ( _
    column As DataColumn _
)
public:
DataColumn(
    DataColumn^ column
)
Parameters
column(DataColumn)


AppendCell Method (cell)

AppendCell Method (cell)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »AppendCell(DataCell)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AppendCell(
    DataCell cell
)
Public Overridable Sub AppendCell ( _
    cell As DataCell _
)
public:
virtual void AppendCell(
    DataCell^ cell
)
Parameters
cell(DataCell)


Assign Method (col)

Assign Method (col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »Assign(DataColumn)
Declaration Syntax
C# Visual Basic Visual C++
public void Assign(
    DataColumn col
)
Public Sub Assign ( _
    col As DataColumn _
)
public:
void Assign(
    DataColumn^ col
)
Parameters
col(DataColumn)


ColumnName Property

ColumnName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »ColumnName
Declaration Syntax
C# Visual Basic Visual C++
public string ColumnName { get; set; }
Public Property ColumnName As String
    Get
    Set
public:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}


ColumnType Property

ColumnType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »ColumnType
Declaration Syntax
C# Visual Basic Visual C++
public CellType ColumnType { get; set; }
Public Property ColumnType As CellType
    Get
    Set
public:
property CellType ColumnType {
    CellType get ();
    void set (CellType value);
}


GetCellAt Method (index)

GetCellAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »GetCellAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell GetCellAt(
    int index
)
Public Overridable Function GetCellAt ( _
    index As Integer _
) As DataCell
public:
virtual DataCell^ GetCellAt(
    int index
)
Parameters
index(Int32)


GetIndexAtCell Method (cell)

GetIndexAtCell Method (cell)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »GetIndexAtCell(DataCell)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int GetIndexAtCell(
    DataCell cell
)
Public Overridable Function GetIndexAtCell ( _
    cell As DataCell _
) As Integer
public:
virtual int GetIndexAtCell(
    DataCell^ cell
)
Parameters
cell(DataCell)


GrowLength Property

GrowLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »GrowLength
Declaration Syntax
C# Visual Basic Visual C++
public int GrowLength { get; set; }
Public Property GrowLength As Integer
    Get
    Set
public:
property int GrowLength {
    int get ();
    void set (int value);
}


InsertCellAt Method (index, cell)

InsertCellAt Method (index, cell)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »InsertCellAt(Int32, DataCell)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void InsertCellAt(
    int index,
    DataCell cell
)
Public Overridable Sub InsertCellAt ( _
    index As Integer, _
    cell As DataCell _
)
public:
virtual void InsertCellAt(
    int index,
    DataCell^ cell
)
Parameters
index(Int32)
cell(DataCell)


NumCells Property

NumCells Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »NumCells
Declaration Syntax
C# Visual Basic Visual C++
public int NumCells { get; }
Public ReadOnly Property NumCells As Integer
    Get
public:
property int NumCells {
    int get ();
}


PhysicalLength Property

PhysicalLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »PhysicalLength
Declaration Syntax
C# Visual Basic Visual C++
public int PhysicalLength { get; set; }
Public Property PhysicalLength As Integer
    Get
    Set
public:
property int PhysicalLength {
    int get ();
    void set (int value);
}


RemoveCellAt Method (index)

RemoveCellAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »RemoveCellAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveCellAt(
    int index
)
Public Overridable Sub RemoveCellAt ( _
    index As Integer _
)
public:
virtual void RemoveCellAt(
    int index
)
Parameters
index(Int32)


SetCellAt Method (index, cell)

SetCellAt Method (index, cell)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »SetCellAt(Int32, DataCell)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCellAt(
    int index,
    DataCell cell
)
Public Overridable Sub SetCellAt ( _
    index As Integer, _
    cell As DataCell _
)
public:
virtual void SetCellAt(
    int index,
    DataCell^ cell
)
Parameters
index(Int32)
cell(DataCell)


DataLink Class

DataLink Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDataLink")]
public sealed class DataLink : DBObject
<WrapperAttribute("AcDbDataLink")> _
Public NotInheritable Class DataLink _
    Inherits DBObject
[WrapperAttribute(L"AcDbDataLink")]
public ref class DataLink sealed : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataLink()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | ConnectionString |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DataAdapterId |
 | Database | (Inherited from DBObject.)
 | DataLinkOption |
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Description |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSourceFiles(DataLinkGetSourceContext) |
 | GetTargets()()()() |
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetUpdateStatus(UpdateDirection%, DateTime%, String) |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsValid |
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RepathSourceFiles(String, PathOption) |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToolTip |
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Update(UpdateDirection, UpdateOption) |
 | UpdateOption |
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | DataLink


DataLink Constructor

DataLink Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »DataLink()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DataLink()
Public Sub New
public:
DataLink()


ConnectionString Property

ConnectionString Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »ConnectionString
Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}


DataAdapterId Property

DataAdapterId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »DataAdapterId
Declaration Syntax
C# Visual Basic Visual C++
public string DataAdapterId { get; set; }
Public Property DataAdapterId As String
    Get
    Set
public:
property String^ DataAdapterId {
    String^ get ();
    void set (String^ value);
}


DataLinkOption Property

DataLinkOption Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »DataLinkOption
Declaration Syntax
C# Visual Basic Visual C++
public DataLinkOption DataLinkOption { get; set; }
Public Property DataLinkOption As DataLinkOption
    Get
    Set
public:
property DataLinkOption DataLinkOption {
    DataLinkOption get ();
    void set (DataLinkOption value);
}


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


GetSourceFiles Method (nContext)

GetSourceFiles Method (nContext)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »GetSourceFiles(DataLinkGetSourceContext)
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetSourceFiles(
    DataLinkGetSourceContext nContext
)
Public Function GetSourceFiles ( _
    nContext As DataLinkGetSourceContext _
) As ArrayList
public:
ArrayList^ GetSourceFiles(
    DataLinkGetSourceContext nContext
)
Parameters
nContext(DataLinkGetSourceContext)


GetTargets Method

GetTargets Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »GetTargets()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetTargets()
Public Function GetTargets As ObjectIdCollection
public:
ObjectIdCollection^ GetTargets()


GetUpdateStatus Method (pDir, pTime, errMessage)

GetUpdateStatus Method (pDir, pTime, errMessage)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »GetUpdateStatus(UpdateDirection%, DateTime%, String)
Declaration Syntax
C# Visual Basic Visual C++
public ErrorStatus GetUpdateStatus(
    ref UpdateDirection pDir,
    ref DateTime pTime,
    string errMessage
)
Public Function GetUpdateStatus ( _
    ByRef pDir As UpdateDirection, _
    ByRef pTime As DateTime, _
    errMessage As String _
) As ErrorStatus
public:
ErrorStatus GetUpdateStatus(
    UpdateDirection% pDir,
    DateTime% pTime,
    String^ errMessage
)
Parameters
pDir(UpdateDirection %)
pTime(DateTime%)
errMessage(String)


IsValid Property

IsValid Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »IsValid
Declaration Syntax
C# Visual Basic Visual C++
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


RepathSourceFiles Method (sBasePath, nOption)

RepathSourceFiles Method (sBasePath, nOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »RepathSourceFiles(String, PathOption)
Declaration Syntax
C# Visual Basic Visual C++
public void RepathSourceFiles(
    string sBasePath,
    PathOption nOption
)
Public Sub RepathSourceFiles ( _
    sBasePath As String, _
    nOption As PathOption _
)
public:
void RepathSourceFiles(
    String^ sBasePath,
    PathOption nOption
)
Parameters
sBasePath(String)
nOption(PathOption)


ToolTip Property

ToolTip Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »ToolTip
Declaration Syntax
C# Visual Basic Visual C++
public string ToolTip { get; set; }
Public Property ToolTip As String
    Get
    Set
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}


Update Method (dir, option)

Update Method (dir, option)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »Update(UpdateDirection, UpdateOption)
Declaration Syntax
C# Visual Basic Visual C++
public void Update(
    UpdateDirection dir,
    UpdateOption option
)
Public Sub Update ( _
    dir As UpdateDirection, _
    option As UpdateOption _
)
public:
void Update(
    UpdateDirection dir,
    UpdateOption option
)
Parameters
dir(UpdateDirection)
option(UpdateOption)


UpdateOption Property

UpdateOption Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »UpdateOption
Declaration Syntax
C# Visual Basic Visual C++
public int UpdateOption { get; set; }
Public Property UpdateOption As Integer
    Get
    Set
public:
property int UpdateOption {
    int get ();
    void set (int value);
}


DataLinkGetSourceContext Enumeration

DataLinkGetSourceContext Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkGetSourceContext
Declaration Syntax
C# Visual Basic Visual C++
public enum DataLinkGetSourceContext
Public Enumeration DataLinkGetSourceContext
public enum class DataLinkGetSourceContext
Members
Member | Description
Unknown |
OrignalPath |
XrefManager |
FileWatcher |
Etransmit |
Other |


DataLinkManager Class

DataLinkManager Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDataLinkManager")]
public sealed class DataLinkManager : RXObject
<WrapperAttribute("AcDbDataLinkManager")> _
Public NotInheritable Class DataLinkManager _
    Inherits RXObject
[WrapperAttribute(L"AcDbDataLinkManager")]
public ref class DataLinkManager sealed : public RXObject
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddDataLink(DataLink) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DataLinkCount |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetDataLink(String) |
 | GetDataLink()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RemoveDataLink(String) |
 | RemoveDataLink(ObjectId) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Update(ObjectIdCollection, UpdateDirection, UpdateOption) |
 | Update(UpdateDirection, UpdateOption) |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DataLinkManager


AddDataLink Method (dataLink)

AddDataLink Method (dataLink)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »AddDataLink(DataLink)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AddDataLink(
    DataLink dataLink
)
Public Function AddDataLink ( _
    dataLink As DataLink _
) As ObjectId
public:
ObjectId AddDataLink(
    DataLink^ dataLink
)
Parameters
dataLink(DataLink)


DataLinkCount Property

DataLinkCount Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »DataLinkCount
Declaration Syntax
C# Visual Basic Visual C++
public int DataLinkCount { get; }
Public ReadOnly Property DataLinkCount As Integer
    Get
public:
property int DataLinkCount {
    int get ();
}


GetDataLink Method

GetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »GetDataLink()()()()
Members
Icon | Member | Description
 | GetDataLink(String) |
 | GetDataLink()()()() |


GetDataLink Method

GetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »GetDataLink()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetDataLink()
Public Function GetDataLink As ObjectIdCollection
public:
ObjectIdCollection^ GetDataLink()


GetDataLink Method (name)

GetDataLink Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »GetDataLink(String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetDataLink(
    string name
)
Public Function GetDataLink ( _
    name As String _
) As ObjectId
public:
ObjectId GetDataLink(
    String^ name
)
Parameters
name(String)


RemoveDataLink Method

RemoveDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »RemoveDataLink()()()()
Members
Icon | Member | Description
 | RemoveDataLink(String) |
 | RemoveDataLink(ObjectId) |


RemoveDataLink Method (name)

RemoveDataLink Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »RemoveDataLink(String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId RemoveDataLink(
    string name
)
Public Function RemoveDataLink ( _
    name As String _
) As ObjectId
public:
ObjectId RemoveDataLink(
    String^ name
)
Parameters
name(String)


RemoveDataLink Method (idDataLink)

RemoveDataLink Method (idDataLink)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »RemoveDataLink(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveDataLink(
    ObjectId idDataLink
)
Public Sub RemoveDataLink ( _
    idDataLink As ObjectId _
)
public:
void RemoveDataLink(
    ObjectId idDataLink
)
Parameters
idDataLink(ObjectId)


Update Method

Update Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »Update()()()()
Members
Icon | Member | Description
 | Update(ObjectIdCollection, UpdateDirection, UpdateOption) |
 | Update(UpdateDirection, UpdateOption) |


Update Method (dataIds, direction, option)

Update Method (dataIds, direction, option)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »Update(ObjectIdCollection, UpdateDirection, UpdateOption)
Declaration Syntax
C# Visual Basic Visual C++
public void Update(
    ObjectIdCollection dataIds,
    UpdateDirection direction,
    UpdateOption option
)
Public Sub Update ( _
    dataIds As ObjectIdCollection, _
    direction As UpdateDirection, _
    option As UpdateOption _
)
public:
void Update(
    ObjectIdCollection^ dataIds,
    UpdateDirection direction,
    UpdateOption option
)
Parameters
dataIds(ObjectIdCollection)
direction(UpdateDirection)
option(UpdateOption)


Update Method (direction, option)

Update Method (direction, option)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »Update(UpdateDirection, UpdateOption)
Declaration Syntax
C# Visual Basic Visual C++
public void Update(
    UpdateDirection direction,
    UpdateOption option
)
Public Sub Update ( _
    direction As UpdateDirection, _
    option As UpdateOption _
)
public:
void Update(
    UpdateDirection direction,
    UpdateOption option
)
Parameters
direction(UpdateDirection)
option(UpdateOption)


DataLinkOption Enumeration

DataLinkOption Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkOption
Declaration Syntax
C# Visual Basic Visual C++
public enum DataLinkOption
Public Enumeration DataLinkOption
public enum class DataLinkOption
Members
Member | Description
None |
PersistCache |
DisableInLT |
Anonymous |


DataTable Class

DataTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDataTable")]
public class DataTable : DBObject
<WrapperAttribute("AcDbDataTable")> _
Public Class DataTable _
    Inherits DBObject
[WrapperAttribute(L"AcDbDataTable")]
public ref class DataTable : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataTable()()()() |
 | DataTable(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | AppendColumn(CellType, String) |
 | AppendRow(DataCellCollection, Boolean) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Assign(DataTable) |
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetCellAt(Int32, Int32) |
 | GetColumnAt(Int32) |
 | GetColumnIndexAtName(String) |
 | GetColumnNameAt(Int32) |
 | GetColumnTypeAt(Int32) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRowAt(Int32) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertColumnAt(Int32, CellType, String) |
 | InsertRowAt(Int32, DataCellCollection, Boolean) |
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | NumColsGrowSize |
 | NumColsPhysicalSize |
 | NumColumns |
 | NumRows |
 | NumRowsGrowSize |
 | NumRowsPhysicalSize |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveColumnAt(Int32) |
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveRowAt(Int32) |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetCellAt(Int32, Int32, DataCell) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetRowAt(Int32, DataCellCollection, Boolean) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TableName |
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | DataTable


DataTable Constructor

DataTable Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »DataTable()()()()
Members
Icon | Member | Description
 | DataTable()()()() |
 | DataTable(IntPtr, Boolean) |


DataTable Constructor

DataTable Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »DataTable()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DataTable()
Public Sub New
public:
DataTable()


DataTable Constructor (unmanagedPointer, autoDelete)

DataTable Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »DataTable(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DataTable(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DataTable(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AppendColumn Method (type, columnName)

AppendColumn Method (type, columnName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »AppendColumn(CellType, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AppendColumn(
    CellType type,
    string columnName
)
Public Overridable Sub AppendColumn ( _
    type As CellType, _
    columnName As String _
)
public:
virtual void AppendColumn(
    CellType type,
    String^ columnName
)
Parameters
type(CellType)
columnName(String)


AppendRow Method (row, validate)

AppendRow Method (row, validate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »AppendRow(DataCellCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AppendRow(
    DataCellCollection row,
    bool validate
)
Public Overridable Sub AppendRow ( _
    row As DataCellCollection, _
    validate As Boolean _
)
public:
virtual void AppendRow(
    DataCellCollection^ row,
    bool validate
)
Parameters
row(DataCellCollection)
validate(Boolean)


Assign Method (other)

Assign Method (other)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »Assign(DataTable)
Declaration Syntax
C# Visual Basic Visual C++
public void Assign(
    DataTable other
)
Public Sub Assign ( _
    other As DataTable _
)
public:
void Assign(
    DataTable^ other
)
Parameters
other(DataTable)


GetCellAt Method (row, col)

GetCellAt Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »GetCellAt(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCell GetCellAt(
    int row,
    int col
)
Public Overridable Function GetCellAt ( _
    row As Integer, _
    col As Integer _
) As DataCell
public:
virtual DataCell^ GetCellAt(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


GetColumnAt Method (index)

GetColumnAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »GetColumnAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataColumn GetColumnAt(
    int index
)
Public Overridable Function GetColumnAt ( _
    index As Integer _
) As DataColumn
public:
virtual DataColumn^ GetColumnAt(
    int index
)
Parameters
index(Int32)


GetColumnIndexAtName Method (name)

GetColumnIndexAtName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »GetColumnIndexAtName(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int GetColumnIndexAtName(
    string name
)
Public Overridable Function GetColumnIndexAtName ( _
    name As String _
) As Integer
public:
virtual int GetColumnIndexAtName(
    String^ name
)
Parameters
name(String)


GetColumnNameAt Method (index)

GetColumnNameAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »GetColumnNameAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetColumnNameAt(
    int index
)
Public Overridable Function GetColumnNameAt ( _
    index As Integer _
) As String
public:
virtual String^ GetColumnNameAt(
    int index
)
Parameters
index(Int32)


GetColumnTypeAt Method (index)

GetColumnTypeAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »GetColumnTypeAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellType GetColumnTypeAt(
    int index
)
Public Overridable Function GetColumnTypeAt ( _
    index As Integer _
) As CellType
public:
virtual CellType GetColumnTypeAt(
    int index
)
Parameters
index(Int32)


GetRowAt Method (index)

GetRowAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »GetRowAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataCellCollection GetRowAt(
    int index
)
Public Overridable Function GetRowAt ( _
    index As Integer _
) As DataCellCollection
public:
virtual DataCellCollection^ GetRowAt(
    int index
)
Parameters
index(Int32)


InsertColumnAt Method (index, type, columnName)

InsertColumnAt Method (index, type, columnName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »InsertColumnAt(Int32, CellType, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void InsertColumnAt(
    int index,
    CellType type,
    string columnName
)
Public Overridable Sub InsertColumnAt ( _
    index As Integer, _
    type As CellType, _
    columnName As String _
)
public:
virtual void InsertColumnAt(
    int index,
    CellType type,
    String^ columnName
)
Parameters
index(Int32)
type(CellType)
columnName(String)


InsertRowAt Method (index, row, validate)

InsertRowAt Method (index, row, validate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »InsertRowAt(Int32, DataCellCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void InsertRowAt(
    int index,
    DataCellCollection row,
    bool validate
)
Public Overridable Sub InsertRowAt ( _
    index As Integer, _
    row As DataCellCollection, _
    validate As Boolean _
)
public:
virtual void InsertRowAt(
    int index,
    DataCellCollection^ row,
    bool validate
)
Parameters
index(Int32)
row(DataCellCollection)
validate(Boolean)


NumColsGrowSize Property

NumColsGrowSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »NumColsGrowSize
Declaration Syntax
C# Visual Basic Visual C++
public int NumColsGrowSize { get; set; }
Public Property NumColsGrowSize As Integer
    Get
    Set
public:
property int NumColsGrowSize {
    int get ();
    void set (int value);
}


NumColsPhysicalSize Property

NumColsPhysicalSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »NumColsPhysicalSize
Declaration Syntax
C# Visual Basic Visual C++
public int NumColsPhysicalSize { get; set; }
Public Property NumColsPhysicalSize As Integer
    Get
    Set
public:
property int NumColsPhysicalSize {
    int get ();
    void set (int value);
}


NumColumns Property

NumColumns Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »NumColumns
Declaration Syntax
C# Visual Basic Visual C++
public int NumColumns { get; }
Public ReadOnly Property NumColumns As Integer
    Get
public:
property int NumColumns {
    int get ();
}


NumRows Property

NumRows Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »NumRows
Declaration Syntax
C# Visual Basic Visual C++
public int NumRows { get; }
Public ReadOnly Property NumRows As Integer
    Get
public:
property int NumRows {
    int get ();
}


NumRowsGrowSize Property

NumRowsGrowSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »NumRowsGrowSize
Declaration Syntax
C# Visual Basic Visual C++
public int NumRowsGrowSize { get; set; }
Public Property NumRowsGrowSize As Integer
    Get
    Set
public:
property int NumRowsGrowSize {
    int get ();
    void set (int value);
}


NumRowsPhysicalSize Property

NumRowsPhysicalSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »NumRowsPhysicalSize
Declaration Syntax
C# Visual Basic Visual C++
public int NumRowsPhysicalSize { get; set; }
Public Property NumRowsPhysicalSize As Integer
    Get
    Set
public:
property int NumRowsPhysicalSize {
    int get ();
    void set (int value);
}


RemoveColumnAt Method (index)

RemoveColumnAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »RemoveColumnAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveColumnAt(
    int index
)
Public Overridable Sub RemoveColumnAt ( _
    index As Integer _
)
public:
virtual void RemoveColumnAt(
    int index
)
Parameters
index(Int32)


RemoveRowAt Method (index)

RemoveRowAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »RemoveRowAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveRowAt(
    int index
)
Public Overridable Sub RemoveRowAt ( _
    index As Integer _
)
public:
virtual void RemoveRowAt(
    int index
)
Parameters
index(Int32)


SetCellAt Method (row, col, cell)

SetCellAt Method (row, col, cell)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »SetCellAt(Int32, Int32, DataCell)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCellAt(
    int row,
    int col,
    DataCell cell
)
Public Overridable Sub SetCellAt ( _
    row As Integer, _
    col As Integer, _
    cell As DataCell _
)
public:
virtual void SetCellAt(
    int row,
    int col,
    DataCell^ cell
)
Parameters
row(Int32)
col(Int32)
cell(DataCell)


SetRowAt Method (index, row, validate)

SetRowAt Method (index, row, validate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »SetRowAt(Int32, DataCellCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetRowAt(
    int index,
    DataCellCollection row,
    bool validate
)
Public Overridable Sub SetRowAt ( _
    index As Integer, _
    row As DataCellCollection, _
    validate As Boolean _
)
public:
virtual void SetRowAt(
    int index,
    DataCellCollection^ row,
    bool validate
)
Parameters
index(Int32)
row(DataCellCollection)
validate(Boolean)


TableName Property

TableName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »TableName
Declaration Syntax
C# Visual Basic Visual C++
public string TableName { get; set; }
Public Property TableName As String
    Get
    Set
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}


DataType Enumeration

DataType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataType
Declaration Syntax
C# Visual Basic Visual C++
public enum DataType
Public Enumeration DataType
public enum class DataType
Members
Member | Description
ObjectId |
Long |
General |
Resbuf |
Point3d |
Buffer |
Date |
Point |
String |
Double |
Unknown |


DataTypeParameter Structure

DataTypeParameter Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTypeParameter
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::DataType")]
public struct DataTypeParameter
<WrapperAttribute("ZcDb::DataType")> _
Public Structure DataTypeParameter
[WrapperAttribute(L"ZcDb::DataType")]
public value class DataTypeParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataTypeParameter(DataType, UnitType) |
 | DataType |
 | Equality(DataTypeParameter, DataTypeParameter) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(DataTypeParameter, DataTypeParameter) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)
 | UnitType |


DataTypeParameter Constructor (dataType, unitType)

DataTypeParameter Constructor (dataType, unitType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTypeParameter »DataTypeParameter(DataType, UnitType)
Declaration Syntax
C# Visual Basic Visual C++
public DataTypeParameter(
    DataType dataType,
    UnitType unitType
)
Public Sub New ( _
    dataType As DataType, _
    unitType As UnitType _
)
public:
DataTypeParameter(
    DataType dataType,
    UnitType unitType
)
Parameters
dataType(DataType)
unitType(UnitType)


DataType Property

DataType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTypeParameter »DataType
Declaration Syntax
C# Visual Basic Visual C++
public DataType DataType { get; set; }
Public Property DataType As DataType
    Get
    Set
public:
property DataType DataType {
    DataType get ();
    void set (DataType value);
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTypeParameter »Equality(DataTypeParameter, DataTypeParameter)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    DataTypeParameter t1,
    DataTypeParameter t2
)
Public Shared Operator = ( _
    t1 As DataTypeParameter, _
    t2 As DataTypeParameter _
) As Boolean
public:
static bool operator ==(
    DataTypeParameter t1,
    DataTypeParameter t2
)
Parameters
t1(DataTypeParameter)
t2(DataTypeParameter)


Equals Method (other)

Equals Method (other)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTypeParameter »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object other
)
Public Overrides NotOverridable Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override sealed
Parameters
other(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTypeParameter »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTypeParameter »Inequality(DataTypeParameter, DataTypeParameter)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    DataTypeParameter t1,
    DataTypeParameter t2
)
Public Shared Operator <> ( _
    t1 As DataTypeParameter, _
    t2 As DataTypeParameter _
) As Boolean
public:
static bool operator !=(
    DataTypeParameter t1,
    DataTypeParameter t2
)
Parameters
t1(DataTypeParameter)
t2(DataTypeParameter)


UnitType Property

UnitType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTypeParameter »UnitType
Declaration Syntax
C# Visual Basic Visual C++
public UnitType UnitType { get; set; }
Public Property UnitType As UnitType
    Get
    Set
public:
property UnitType UnitType {
    UnitType get ();
    void set (UnitType value);
}


DBDictionary Class

DBDictionary Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDictionary")]
public class DBDictionary : DBObject,
    IDictionary
<WrapperAttribute("AcDbDictionary")> _
Public Class DBDictionary _
    Inherits DBObject _
    Implements IDictionary
[WrapperAttribute(L"AcDbDictionary")]
public ref class DBDictionary : public DBObject,
    IDictionary
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DBDictionary()()()() |
 | DBDictionary(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Contains(String) |
 | Contains(ObjectId) |
 | Copied | (Inherited from DBObject.)
 | Copy()()()() |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyTo(array<DBDictionaryEntry>[]()[][], Int32) |
 | Count |
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAt(String) |
 | GetEnumerator()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | ICollection_CopyTo(Array, Int32) |
 | Id | (Inherited from DBObject.)
 | IDictionary_Add(Object, Object) |
 | IDictionary_Clear()()()() |
 | IDictionary_Contains(Object) |
 | IDictionary_GetEnumerator()()()() |
 | IDictionary_IsFixedSize |
 | IDictionary_IsReadOnly |
 | IDictionary_IsSynchronized |
 | IDictionary_Item[([( Object])]) |
 | IDictionary_Keys |
 | IDictionary_Remove(Object) |
 | IDictionary_SyncRoot |
 | IDictionary_Values |
 | IEnumerable_GetEnumerator()()()() |
 | IncludingErased |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsFixedSize |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReadOnly |
 | IsReallyClosing | (Inherited from DBObject.)
 | IsSynchronized |
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) |
 | Keys |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Overrides DBObject.MergeStyle.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | NameAt(ObjectId) |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | Remove(String) |
 | Remove(ObjectId) |
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAt(String, DBObject) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetName(String, String) |
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SkipDeleted |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | TreatElementsAsHard |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | Values |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | DBDictionary
 |  |  |  |  |  |  | DictionaryWithDefaultDictionary


DBDictionary Constructor

DBDictionary Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »DBDictionary()()()()
Members
Icon | Member | Description
 | DBDictionary()()()() |
 | DBDictionary(IntPtr, Boolean) |


DBDictionary Constructor

DBDictionary Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »DBDictionary()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DBDictionary()
Public Sub New
public:
DBDictionary()


DBDictionary Constructor (obj, autoDelete)

DBDictionary Constructor (obj, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »DBDictionary(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DBDictionary(
    IntPtr obj,
    bool autoDelete
)
Protected Friend Sub New ( _
    obj As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DBDictionary(
    IntPtr obj,
    bool autoDelete
)
Parameters
obj(IntPtr)
autoDelete(Boolean)


Contains Method

Contains Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Contains()()()()
Members
Icon | Member | Description
 | Contains(String) |
 | Contains(ObjectId) |


Contains Method (entryName)

Contains Method (entryName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Contains(String)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string entryName
)
Public Function Contains ( _
    entryName As String _
) As Boolean
public:
bool Contains(
    String^ entryName
)
Parameters
entryName(String)


Contains Method (objId)

Contains Method (objId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Contains(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ObjectId objId
)
Public Function Contains ( _
    objId As ObjectId _
) As Boolean
public:
bool Contains(
    ObjectId objId
)
Parameters
objId(ObjectId)


Copy Method

Copy Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Copy()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected virtual DBDictionary Copy()
Protected Overridable Function Copy As DBDictionary
protected:
virtual DBDictionary^ Copy()


CopyTo Method (copy, index)

CopyTo Method (copy, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »CopyTo(array<DBDictionaryEntry>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DBDictionaryEntry[] copy,
    int index
)
Public Sub CopyTo ( _
    copy As DBDictionaryEntry(), _
    index As Integer _
)
public:
void CopyTo(
    array<DBDictionaryEntry>^ copy,
    int index
)
Parameters
copy(array< DBDictionaryEntry >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetAt Method (entryName)

GetAt Method (entryName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »GetAt(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetAt(
    string entryName
)
Public Overridable Function GetAt ( _
    entryName As String _
) As ObjectId
public:
virtual ObjectId GetAt(
    String^ entryName
)
Parameters
entryName(String)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DbDictionaryEnumerator GetEnumerator()
Public Function GetEnumerator As DbDictionaryEnumerator
public:
DbDictionaryEnumerator^ GetEnumerator()


ICollection_CopyTo Method (arr, index)

ICollection_CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »ICollection_CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void ICollection_CopyTo(
    Array arr,
    int index
)
Protected Overridable Sub ICollection_CopyTo ( _
    arr As Array, _
    index As Integer _
)
protected:
virtual void ICollection_CopyTo(
    Array^ arr,
    int index
)
Parameters
arr(Array)
index(Int32)


IDictionary_Add Method (key, value)

IDictionary_Add Method (key, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_Add(Object, Object)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void IDictionary_Add(
    Object key,
    Object value
)
Protected Overridable Sub IDictionary_Add ( _
    key As Object, _
    value As Object _
)
protected:
virtual void IDictionary_Add(
    Object^ key,
    Object^ value
)
Parameters
key(Object)
value(Object)


IDictionary_Clear Method

IDictionary_Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void IDictionary_Clear()
Protected Overridable Sub IDictionary_Clear
protected:
virtual void IDictionary_Clear()


IDictionary_Contains Method (key)

IDictionary_Contains Method (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IDictionary_Contains(
    Object key
)
Protected Overridable Function IDictionary_Contains ( _
    key As Object _
) As Boolean
protected:
virtual bool IDictionary_Contains(
    Object^ key
)
Parameters
key(Object)


IDictionary_GetEnumerator Method

IDictionary_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected virtual IDictionaryEnumerator IDictionary_GetEnumerator()
Protected Overridable Function IDictionary_GetEnumerator As IDictionaryEnumerator
protected:
virtual IDictionaryEnumerator^ IDictionary_GetEnumerator()


IDictionary_IsFixedSize Property

IDictionary_IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IDictionary_IsFixedSize { get; }
Protected Overridable ReadOnly Property IDictionary_IsFixedSize As Boolean
    Get
protected:
virtual property bool IDictionary_IsFixedSize {
    bool get ();
}


IDictionary_IsReadOnly Property

IDictionary_IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IDictionary_IsReadOnly { get; }
Protected Overridable ReadOnly Property IDictionary_IsReadOnly As Boolean
    Get
protected:
virtual property bool IDictionary_IsReadOnly {
    bool get ();
}


IDictionary_IsSynchronized Property

IDictionary_IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IDictionary_IsSynchronized { get; }
Protected Overridable ReadOnly Property IDictionary_IsSynchronized As Boolean
    Get
protected:
virtual property bool IDictionary_IsSynchronized {
    bool get ();
}


IDictionary_Item Property (key)

IDictionary_Item Property (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_Item[([( Object])])
Declaration Syntax
C# Visual Basic Visual C++
protected virtual Object this[
    Object key
] { get; set; }
Protected Overridable Property IDictionary_Item ( _
    key As Object _
) As Object
    Get
    Set
protected:
virtual property Object^ IDictionary_Item[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}
Parameters
key(Object)


IDictionary_Keys Property

IDictionary_Keys Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_Keys
Declaration Syntax
C# Visual Basic Visual C++
protected virtual ICollection IDictionary_Keys { get; }
Protected Overridable ReadOnly Property IDictionary_Keys As ICollection
    Get
protected:
virtual property ICollection^ IDictionary_Keys {
    ICollection^ get ();
}


IDictionary_Remove Method (key)

IDictionary_Remove Method (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void IDictionary_Remove(
    Object key
)
Protected Overridable Sub IDictionary_Remove ( _
    key As Object _
)
protected:
virtual void IDictionary_Remove(
    Object^ key
)
Parameters
key(Object)


IDictionary_SyncRoot Property

IDictionary_SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
protected virtual Object IDictionary_SyncRoot { get; }
Protected Overridable ReadOnly Property IDictionary_SyncRoot As Object
    Get
protected:
virtual property Object^ IDictionary_SyncRoot {
    Object^ get ();
}


IDictionary_Values Property

IDictionary_Values Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IDictionary_Values
Declaration Syntax
C# Visual Basic Visual C++
protected virtual ICollection IDictionary_Values { get; }
Protected Overridable ReadOnly Property IDictionary_Values As ICollection
    Get
protected:
virtual property ICollection^ IDictionary_Values {
    ICollection^ get ();
}


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected virtual IEnumerator IEnumerable_GetEnumerator()
Protected Overridable Function IEnumerable_GetEnumerator As IEnumerator
protected:
virtual IEnumerator^ IEnumerable_GetEnumerator()


IncludingErased Property

IncludingErased Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IncludingErased
Declaration Syntax
C# Visual Basic Visual C++
public DBDictionary IncludingErased { get; }
Public ReadOnly Property IncludingErased As DBDictionary
    Get
public:
property DBDictionary^ IncludingErased {
    DBDictionary^ get ();
}


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
protected bool IsFixedSize { get; }
Protected ReadOnly Property IsFixedSize As Boolean
    Get
protected:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
protected bool IsReadOnly { get; }
Protected ReadOnly Property IsReadOnly As Boolean
    Get
protected:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
protected bool IsSynchronized { get; }
Protected ReadOnly Property IsSynchronized As Boolean
    Get
protected:
property bool IsSynchronized {
    bool get ();
}


Item Property (key)

Item Property (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Item[([( String])])
Declaration Syntax
C# Visual Basic Visual C++
public Object this[
    string key
] { get; set; }
Public Default Property Item ( _
    key As String _
) As Object
    Get
    Set
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}
Parameters
key(String)


Keys Property

Keys Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Keys
Declaration Syntax
C# Visual Basic Visual C++
protected ICollection Keys { get; }
Protected ReadOnly Property Keys As ICollection
    Get
protected:
property ICollection^ Keys {
    ICollection^ get ();
}


MergeStyle Property

MergeStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »MergeStyle
Declaration Syntax
C# Visual Basic Visual C++
public override DuplicateRecordCloning MergeStyle { get; set; }
Public Overrides Property MergeStyle As DuplicateRecordCloning
    Get
    Set
public:
virtual property DuplicateRecordCloning MergeStyle {
    DuplicateRecordCloning get () override;
    void set (DuplicateRecordCloning value) override;
}


NameAt Method (objId)

NameAt Method (objId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »NameAt(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string NameAt(
    ObjectId objId
)
Public Overridable Function NameAt ( _
    objId As ObjectId _
) As String
public:
virtual String^ NameAt(
    ObjectId objId
)
Parameters
objId(ObjectId)


Remove Method

Remove Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Remove()()()()
Members
Icon | Member | Description
 | Remove(String) |
 | Remove(ObjectId) |


Remove Method (key)

Remove Method (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Remove(String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Remove(
    string key
)
Public Function Remove ( _
    key As String _
) As ObjectId
public:
ObjectId Remove(
    String^ key
)
Parameters
key(String)


Remove Method (objId)

Remove Method (objId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Remove(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ObjectId objId
)
Public Sub Remove ( _
    objId As ObjectId _
)
public:
void Remove(
    ObjectId objId
)
Parameters
objId(ObjectId)


SetAt Method (searchKey, newValue)

SetAt Method (searchKey, newValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »SetAt(String, DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId SetAt(
    string searchKey,
    DBObject newValue
)
Public Function SetAt ( _
    searchKey As String, _
    newValue As DBObject _
) As ObjectId
public:
ObjectId SetAt(
    String^ searchKey,
    DBObject^ newValue
)
Parameters
searchKey(String)
newValue(DBObject)


SetName Method (oldName, newName)

SetName Method (oldName, newName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »SetName(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetName(
    string oldName,
    string newName
)
Public Sub SetName ( _
    oldName As String, _
    newName As String _
)
public:
void SetName(
    String^ oldName,
    String^ newName
)
Parameters
oldName(String)
newName(String)


SkipDeleted Property

SkipDeleted Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »SkipDeleted
Declaration Syntax
C# Visual Basic Visual C++
protected internal bool SkipDeleted { get; }
Protected Friend ReadOnly Property SkipDeleted As Boolean
    Get
protected public:
property bool SkipDeleted {
    bool get ();
}


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
protected Object SyncRoot { get; }
Protected ReadOnly Property SyncRoot As Object
    Get
protected:
property Object^ SyncRoot {
    Object^ get ();
}


TreatElementsAsHard Property

TreatElementsAsHard Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »TreatElementsAsHard
Declaration Syntax
C# Visual Basic Visual C++
public bool TreatElementsAsHard { get; set; }
Public Property TreatElementsAsHard As Boolean
    Get
    Set
public:
property bool TreatElementsAsHard {
    bool get ();
    void set (bool value);
}


Values Property

Values Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Values
Declaration Syntax
C# Visual Basic Visual C++
protected ICollection Values { get; }
Protected ReadOnly Property Values As ICollection
    Get
protected:
property ICollection^ Values {
    ICollection^ get ();
}


DBDictionaryEntry Structure

DBDictionaryEntry Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public struct DBDictionaryEntry
<SerializableAttribute> _
Public Structure DBDictionaryEntry
[SerializableAttribute]
public value class DBDictionaryEntry
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DBDictionaryEntry(String, ObjectId) |
 | Equals(Object) | (Inherited from ValueType.)
 | ExplicitNarrowingExplicitExplicitExplicit(DBDictionaryEntry to DictionaryEntry) |
 | ExplicitNarrowingExplicitExplicitExplicit(DictionaryEntry to DBDictionaryEntry) |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Key |
 | m_key |
 | m_value |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | Value |


DBDictionaryEntry Constructor (key, value)

DBDictionaryEntry Constructor (key, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »DBDictionaryEntry(String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public DBDictionaryEntry(
    string key,
    ObjectId value
)
Public Sub New ( _
    key As String, _
    value As ObjectId _
)
public:
DBDictionaryEntry(
    String^ key,
    ObjectId value
)
Parameters
key(String)
value(ObjectId)


Explicit Method

Explicit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »Explicit()()()()
Members
Icon | Member | Description
 | ExplicitNarrowingExplicitExplicitExplicit(DBDictionaryEntry to DictionaryEntry) |
 | ExplicitNarrowingExplicitExplicitExplicit(DictionaryEntry to DBDictionaryEntry) |


Explicit Operator

Explicit Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »ExplicitNarrowingExplicitExplicitExplicit(DictionaryEntry to DBDictionaryEntry)
Declaration Syntax
C# Visual Basic Visual C++
public static explicit operator DBDictionaryEntry (
    DictionaryEntry entry
)
Public Shared Narrowing Operator CType ( _
    entry As DictionaryEntry _
) As DBDictionaryEntry
static explicit operator DBDictionaryEntry (
    DictionaryEntry entry
)
Parameters
entry(DictionaryEntry)


Explicit Operator

Explicit Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »ExplicitNarrowingExplicitExplicitExplicit(DBDictionaryEntry to DictionaryEntry)
Declaration Syntax
C# Visual Basic Visual C++
public static explicit operator DictionaryEntry (
    DBDictionaryEntry entry
)
Public Shared Narrowing Operator CType ( _
    entry As DBDictionaryEntry _
) As DictionaryEntry
static explicit operator DictionaryEntry (
    DBDictionaryEntry entry
)
Parameters
entry(DBDictionaryEntry)


Key Property

Key Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »Key
Declaration Syntax
C# Visual Basic Visual C++
public string Key { get; set; }
Public Property Key As String
    Get
    Set
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}


m_key Field

m_key Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »m_key
Declaration Syntax
C# Visual Basic Visual C++
public string m_key
Public m_key As String
public:
String^ m_key


m_value Field

m_value Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »m_value
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId m_value
Public m_value As ObjectId
public:
ObjectId m_value


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionaryEntry »Value
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Value { get; set; }
Public Property Value As ObjectId
    Get
    Set
public:
property ObjectId Value {
    ObjectId get ();
    void set (ObjectId value);
}


DbDictionaryEnumerator Class

DbDictionaryEnumerator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDictionaryIterator")]
public class DbDictionaryEnumerator : RXObject,
    IDictionaryEnumerator
<WrapperAttribute("ZcDbDictionaryIterator")> _
Public Class DbDictionaryEnumerator _
    Inherits RXObject _
    Implements IDictionaryEnumerator
[WrapperAttribute(L"ZcDbDictionaryIterator")]
public ref class DbDictionaryEnumerator : public RXObject,
    IDictionaryEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Current |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Entry |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | IDictionaryEnumeratorCurrent |
 | IDictionaryEnumeratorEntry |
 | IDictionaryEnumeratorKey |
 | IDictionaryEnumeratorValue |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Key |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Value |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DbDictionaryEnumerator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public DBDictionaryEntry Current { get; }
Public ReadOnly Property Current As DBDictionaryEntry
    Get
public:
property DBDictionaryEntry Current {
    DBDictionaryEntry get ();
}


Entry Property

Entry Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »Entry
Declaration Syntax
C# Visual Basic Visual C++
public DBDictionaryEntry Entry { get; }
Public ReadOnly Property Entry As DBDictionaryEntry
    Get
public:
property DBDictionaryEntry Entry {
    DBDictionaryEntry get ();
}


IDictionaryEnumeratorCurrent Property

IDictionaryEnumeratorCurrent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »IDictionaryEnumeratorCurrent
Declaration Syntax
C# Visual Basic Visual C++
internal virtual Object IDictionaryEnumeratorCurrent { get; }
Friend Overridable ReadOnly Property IDictionaryEnumeratorCurrent As Object
    Get
internal:
virtual property Object^ IDictionaryEnumeratorCurrent {
    Object^ get ();
}


IDictionaryEnumeratorEntry Property

IDictionaryEnumeratorEntry Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »IDictionaryEnumeratorEntry
Declaration Syntax
C# Visual Basic Visual C++
internal virtual DictionaryEntry IDictionaryEnumeratorEntry { get; }
Friend Overridable ReadOnly Property IDictionaryEnumeratorEntry As DictionaryEntry
    Get
internal:
virtual property DictionaryEntry IDictionaryEnumeratorEntry {
    DictionaryEntry get ();
}


IDictionaryEnumeratorKey Property

IDictionaryEnumeratorKey Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »IDictionaryEnumeratorKey
Declaration Syntax
C# Visual Basic Visual C++
internal virtual Object IDictionaryEnumeratorKey { get; }
Friend Overridable ReadOnly Property IDictionaryEnumeratorKey As Object
    Get
internal:
virtual property Object^ IDictionaryEnumeratorKey {
    Object^ get ();
}


IDictionaryEnumeratorValue Property

IDictionaryEnumeratorValue Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »IDictionaryEnumeratorValue
Declaration Syntax
C# Visual Basic Visual C++
internal virtual Object IDictionaryEnumeratorValue { get; }
Friend Overridable ReadOnly Property IDictionaryEnumeratorValue As Object
    Get
internal:
virtual property Object^ IDictionaryEnumeratorValue {
    Object^ get ();
}


Key Property

Key Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »Key
Declaration Syntax
C# Visual Basic Visual C++
public string Key { get; }
Public ReadOnly Property Key As String
    Get
public:
property String^ Key {
    String^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »Value
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Value { get; }
Public ReadOnly Property Value As ObjectId
    Get
public:
property ObjectId Value {
    ObjectId get ();
}


DbHomeView Class

DbHomeView Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbHomeView
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbHomeView")]
public class DbHomeView : DisposableWrapper, ICloneable
<WrapperAttribute("ZcDbHomeView")> _
Public Class DbHomeView _
    Inherits DisposableWrapper _
    Implements ICloneable
[WrapperAttribute(L"ZcDbHomeView")]
public ref class DbHomeView : public DisposableWrapper,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DbHomeView(IntPtr, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equality(DbHomeView, DbHomeView) |
 | Equals(Object) | (Overrides DisposableWrapper.Equals(Object).)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(DbHomeView, DbHomeView) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToggleDefaultSettings()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | DbHomeView


DbHomeView Constructor (unmanagedPointer, autoDelete)

DbHomeView Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbHomeView »DbHomeView(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DbHomeView(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
public:
DbHomeView(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbHomeView »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbHomeView »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbHomeView »Equality(DbHomeView, DbHomeView)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    DbHomeView lhvw,
    DbHomeView rhvw
)
Public Shared Operator = ( _
    lhvw As DbHomeView, _
    rhvw As DbHomeView _
) As Boolean
public:
static bool operator ==(
    DbHomeView^ lhvw,
    DbHomeView^ rhvw
)
Parameters
lhvw(DbHomeView)
rhvw(DbHomeView)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbHomeView »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj(Object)


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbHomeView »Inequality(DbHomeView, DbHomeView)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    DbHomeView lhvm,
    DbHomeView rhvw
)
Public Shared Operator <> ( _
    lhvm As DbHomeView, _
    rhvw As DbHomeView _
) As Boolean
public:
static bool operator !=(
    DbHomeView^ lhvm,
    DbHomeView^ rhvw
)
Parameters
lhvm(DbHomeView)
rhvw(DbHomeView)


ToggleDefaultSettings Method

ToggleDefaultSettings Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbHomeView »ToggleDefaultSettings()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ToggleDefaultSettings()
Public Sub ToggleDefaultSettings
public:
void ToggleDefaultSettings()


DBObject Class

DBObject Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbObject")]
public abstract class DBObject : Drawable
<WrapperAttribute("AcDbObject")> _
Public MustInherit Class DBObject _
    Inherits Drawable
[WrapperAttribute(L"AcDbObject")]
public ref class DBObject abstract : public Drawable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DBObject(IntPtr, Boolean) |
 | AcadObject |
 | AddContext(ObjectContext) |
 | AddPersistentReactor(ObjectId) |
 | Annotative |
 | ApplyPartialUndo(DwgFiler, RXClass) |
 | AssertNotifyEnabled()()()() |
 | AssertReadEnabled()()()() |
 | AssertWriteEnabled(Boolean, Boolean) |
 | Audit(AuditInfo) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete.
 | Cancelled |
 | ClassID |
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete.
 | CloseAndPage(Boolean) | Obsolete.
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database |
 | DecomposeForSave(DwgVersion) |
 | DeepClone(DBObject, IdMapping, Boolean) |
 | DeleteUnmanagedObject()()()() | (Overrides RXObject.DeleteUnmanagedObject()()()().)
 | DisableUndoRecording(Boolean) |
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() |
 | DowngradeToNotify(Boolean) |
 | Drawable |
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) |
 | DwgInFields(DwgFiler) |
 | DwgOut(DwgFiler) |
 | DwgOutFields(DwgFiler) |
 | DxfIn(DxfFiler) |
 | DxfInFields(DxfFiler) |
 | DxfOut(DxfFiler) |
 | DxfOutFields(DxfFiler) |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) |
 | Erase()()()() |
 | Erased |
 | ExtensionDictionary |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FromAcadObject(Object) |
 | FromZcadObject(Object) |
 | GetEventExtender(Boolean) |
 | GetField(String) |
 | GetField()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |
 | GetPersistentReactorIds()()()() |
 | GetReactors()()()() | Obsolete.
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) |
 | Goodbye |
 | Handle |
 | HandOverTo(DBObject, Boolean, Boolean) |
 | HasContext(ObjectContext) |
 | HasFields |
 | HasPersistentReactor(ObjectId) |
 | HasSaveVersionOverride |
 | Id | (Overrides Drawable.Id.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy |
 | IsCancelling |
 | IsCustomObject(ObjectId) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased |
 | IsEraseStatusToggled |
 | IsModified |
 | IsModifiedGraphics |
 | IsModifiedXData |
 | IsNewObject |
 | IsNotifyEnabled |
 | IsNotifying |
 | IsObjectIdsInFlux |
 | IsPersistent | (Overrides Drawable.IsPersistent.)
 | IsReadEnabled |
 | IsReallyClosing |
 | IsTransactionResident |
 | IsUndoing |
 | IsWriteEnabled |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle |
 | Modified |
 | ModifiedXData |
 | ModifyUndone |
 | ObjectBirthVersion |
 | ObjectClosed |
 | ObjectId |
 | OpenedForModify |
 | OwnerId |
 | PaperOrientation |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended |
 | ReleaseExtensionDictionary()()()() |
 | RemoveContext(ObjectContext) |
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |
 | RemovePersistentReactor(ObjectId) |
 | ResetScaleDependentProperties()()()() |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) |
 | SetField(Field) |
 | SetFromStyle()()()() |
 | SetObjectIdsInFlux()()()() |
 | SetPaperOrientation(Boolean) |
 | SubObjectModified |
 | SubSetAttributes(DrawableTraits) | (Overrides Drawable.SubSetAttributes(DrawableTraits).)
 | SubViewportDraw(ViewportDraw) | (Overrides Drawable.SubViewportDraw(ViewportDraw).)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Overrides Drawable.SubViewportDrawLogicalFlags(ViewportDraw).)
 | SubWorldDraw(WorldDraw) | (Overrides Drawable.SubWorldDraw(WorldDraw).)
 | SupportsCollection(String) |
 | SwapIdWith(ObjectId, Boolean, Boolean) |
 | SwapReferences(IdMapping) |
 | ToString()()()() | (Inherited from Object.)
 | Unappended |
 | UndoFiler |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() |
 | UpgradeOpen()()()() |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData |
 | XDataTransformBy(Matrix3d) |
 | ZcadObject |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Background
 |  |  |  |  |  | DataLink
 |  |  |  |  |  | DataTable
 |  |  |  |  |  | DBDictionary
 |  |  |  |  |  | DBVisualStyle
 |  |  |  |  |  | DimAssoc
 |  |  |  |  |  | DrawOrderTable
 |  |  |  |  |  | Entity
 |  |  |  |  |  | Field
 |  |  |  |  |  | Filter
 |  |  |  |  |  | Index
 |  |  |  |  |  | GeoLocationData
 |  |  |  |  |  | Group
 |  |  |  |  |  | LinkedData
 |  |  |  |  |  | Material
 |  |  |  |  |  | MLeaderStyle
 |  |  |  |  |  | MlineStyle
 |  |  |  |  |  | PlaceHolder
 |  |  |  |  |  | PlotSettings
 |  |  |  |  |  | ProxyObject
 |  |  |  |  |  | RasterImageDef
 |  |  |  |  |  | RasterVariables
 |  |  |  |  |  | SectionManager
 |  |  |  |  |  | SectionSettings
 |  |  |  |  |  | Sun
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  | TableStyle
 |  |  |  |  |  | UnderlayDefinition
 |  |  |  |  |  | Xrecord


DBObject Constructor (unmanagedObjPtr, autoDelete)

DBObject Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DBObject(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DBObject(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DBObject(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AcadObject Property

AcadObject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »AcadObject
Declaration Syntax
C# Visual Basic Visual C++
public Object AcadObject { get; }
Public ReadOnly Property AcadObject As Object
    Get
public:
property Object^ AcadObject {
    Object^ get ();
}


AddContext Method (context)

AddContext Method (context)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »AddContext(ObjectContext)
Declaration Syntax
C# Visual Basic Visual C++
public void AddContext(
    ObjectContext context
)
Public Sub AddContext ( _
    context As ObjectContext _
)
public:
void AddContext(
    ObjectContext^ context
)
Parameters
context(ObjectContext)


AddPersistentReactor Method (objId)

AddPersistentReactor Method (objId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »AddPersistentReactor(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void AddPersistentReactor(
    ObjectId objId
)
Public Sub AddPersistentReactor ( _
    objId As ObjectId _
)
public:
void AddPersistentReactor(
    ObjectId objId
)
Parameters
objId(ObjectId)


Annotative Property

Annotative Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Annotative
Declaration Syntax
C# Visual Basic Visual C++
public AnnotativeStates Annotative { get; set; }
Public Property Annotative As AnnotativeStates
    Get
    Set
public:
property AnnotativeStates Annotative {
    AnnotativeStates get ();
    void set (AnnotativeStates value);
}


ApplyPartialUndo Method (undoFiler, classObj)

ApplyPartialUndo Method (undoFiler, classObj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ApplyPartialUndo(DwgFiler, RXClass)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ApplyPartialUndo(
    DwgFiler undoFiler,
    RXClass classObj
)
Public Overridable Sub ApplyPartialUndo ( _
    undoFiler As DwgFiler, _
    classObj As RXClass _
)
public:
virtual void ApplyPartialUndo(
    DwgFiler^ undoFiler,
    RXClass^ classObj
)
Parameters
undoFiler(DwgFiler)
classObj(RXClass)


AssertNotifyEnabled Method

AssertNotifyEnabled Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »AssertNotifyEnabled()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected void AssertNotifyEnabled()
Protected Sub AssertNotifyEnabled
protected:
void AssertNotifyEnabled()


AssertReadEnabled Method

AssertReadEnabled Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »AssertReadEnabled()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected void AssertReadEnabled()
Protected Sub AssertReadEnabled
protected:
void AssertReadEnabled()


AssertWriteEnabled Method (autoUndo, recordModified)

AssertWriteEnabled Method (autoUndo, recordModified)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »AssertWriteEnabled(Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected void AssertWriteEnabled(
    bool autoUndo,
    bool recordModified
)
Protected Sub AssertWriteEnabled ( _
    autoUndo As Boolean, _
    recordModified As Boolean _
)
protected:
void AssertWriteEnabled(
    bool autoUndo,
    bool recordModified
)
Parameters
autoUndo(Boolean)
recordModified(Boolean)


Audit Method (auditInfo)

Audit Method (auditInfo)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Audit(AuditInfo)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Audit(
    AuditInfo auditInfo
)
Public Overridable Sub Audit ( _
    auditInfo As AuditInfo _
)
public:
virtual void Audit(
    AuditInfo^ auditInfo
)
Parameters
auditInfo(AuditInfo)


Cancel Method

Cancel Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Cancel()()()()
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Transaction instead")]
public void Cancel()
<ObsoleteAttribute("Use Transaction instead")> _
Public Sub Cancel
[ObsoleteAttribute(L"Use Transaction instead")]
public:
void Cancel()


Cancelled Event

Cancelled Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Cancelled
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Cancelled
Public Event Cancelled As EventHandler
public:
 event EventHandler^ Cancelled {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ClassID Property

ClassID Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ClassID
Declaration Syntax
C# Visual Basic Visual C++
public virtual Guid ClassID { get; }
Public Overridable ReadOnly Property ClassID As Guid
    Get
public:
virtual property Guid ClassID {
    Guid get ();
}


Close Method

Close Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Close()()()()
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Transaction instead")]
public void Close()
<ObsoleteAttribute("Use Transaction instead")> _
Public Sub Close
[ObsoleteAttribute(L"Use Transaction instead")]
public:
void Close()


CloseAndPage Method (onlyWhenClean)

CloseAndPage Method (onlyWhenClean)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »CloseAndPage(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Transaction instead")]
public void CloseAndPage(
    bool onlyWhenClean
)
<ObsoleteAttribute("Use Transaction instead")> _
Public Sub CloseAndPage ( _
    onlyWhenClean As Boolean _
)
[ObsoleteAttribute(L"Use Transaction instead")]
public:
void CloseAndPage(
    bool onlyWhenClean
)
Parameters
onlyWhenClean(Boolean)


Copied Event

Copied Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Copied
Declaration Syntax
C# Visual Basic Visual C++
public event ObjectEventHandler Copied
Public Event Copied As ObjectEventHandler
public:
 event ObjectEventHandler^ Copied {
    void add (ObjectEventHandler^ value);
    void remove (ObjectEventHandler^ value);
}


CreateExtensionDictionary Method

CreateExtensionDictionary Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »CreateExtensionDictionary()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void CreateExtensionDictionary()
Public Sub CreateExtensionDictionary
public:
void CreateExtensionDictionary()


Database Property

Database Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Database
Declaration Syntax
C# Visual Basic Visual C++
public Database Database { get; }
Public ReadOnly Property Database As Database
    Get
public:
property Database^ Database {
    Database^ get ();
}


DecomposeForSave Method (version)

DecomposeForSave Method (version)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DecomposeForSave(DwgVersion)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DecomposeForSaveReplacementRecord DecomposeForSave(
    DwgVersion version
)
Public Overridable Function DecomposeForSave ( _
    version As DwgVersion _
) As DecomposeForSaveReplacementRecord
public:
virtual DecomposeForSaveReplacementRecord DecomposeForSave(
    DwgVersion version
)
Parameters
version(DwgVersion)


DeepClone Method (ownerPointer, idMap, isPrimary)

DeepClone Method (ownerPointer, idMap, isPrimary)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DeepClone(DBObject, IdMapping, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObject DeepClone(
    DBObject ownerPointer,
    IdMapping idMap,
    bool isPrimary
)
Public Overridable Function DeepClone ( _
    ownerPointer As DBObject, _
    idMap As IdMapping, _
    isPrimary As Boolean _
) As DBObject
public:
virtual DBObject^ DeepClone(
    DBObject^ ownerPointer,
    IdMapping^ idMap,
    bool isPrimary
)
Parameters
ownerPointer(DBObject)
idMap(IdMapping)
isPrimary(Boolean)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


DisableUndoRecording Method (disable)

DisableUndoRecording Method (disable)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DisableUndoRecording(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void DisableUndoRecording(
    bool disable
)
Public Sub DisableUndoRecording ( _
    disable As Boolean _
)
public:
void DisableUndoRecording(
    bool disable
)
Parameters
disable(Boolean)


Dispose Method ()

Dispose Method ()
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Dispose(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
[HandleProcessCorruptedStateExceptionsAttribute]
protected override void Dispose(
    bool
)
<HandleProcessCorruptedStateExceptionsAttribute> _
Protected Overrides Sub Dispose ( _
     As Boolean _
)
[HandleProcessCorruptedStateExceptionsAttribute]
protected:
virtual void Dispose(
    bool
) override
Parameters
(Boolean)


DowngradeOpen Method

DowngradeOpen Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DowngradeOpen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void DowngradeOpen()
Public Sub DowngradeOpen
public:
void DowngradeOpen()


DowngradeToNotify Method (wasWritable)

DowngradeToNotify Method (wasWritable)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DowngradeToNotify(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void DowngradeToNotify(
    bool wasWritable
)
Public Sub DowngradeToNotify ( _
    wasWritable As Boolean _
)
public:
void DowngradeToNotify(
    bool wasWritable
)
Parameters
wasWritable(Boolean)


Drawable Property

Drawable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Drawable
Declaration Syntax
C# Visual Basic Visual C++
public Drawable Drawable { get; }
Public ReadOnly Property Drawable As Drawable
    Get
public:
property Drawable^ Drawable {
    Drawable^ get ();
}


DwgIn Method (filer)

DwgIn Method (filer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DwgIn(DwgFiler)
Declaration Syntax
C# Visual Basic Visual C++
public void DwgIn(
    DwgFiler filer
)
Public Sub DwgIn ( _
    filer As DwgFiler _
)
public:
void DwgIn(
    DwgFiler^ filer
)
Parameters
filer(DwgFiler)


DwgInFields Method (filer)

DwgInFields Method (filer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DwgInFields(DwgFiler)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void DwgInFields(
    DwgFiler filer
)
Protected Overridable Sub DwgInFields ( _
    filer As DwgFiler _
)
protected:
virtual void DwgInFields(
    DwgFiler^ filer
)
Parameters
filer(DwgFiler)


DwgOut Method (filer)

DwgOut Method (filer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DwgOut(DwgFiler)
Declaration Syntax
C# Visual Basic Visual C++
public void DwgOut(
    DwgFiler filer
)
Public Sub DwgOut ( _
    filer As DwgFiler _
)
public:
void DwgOut(
    DwgFiler^ filer
)
Parameters
filer(DwgFiler)


DwgOutFields Method (filer)

DwgOutFields Method (filer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DwgOutFields(DwgFiler)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void DwgOutFields(
    DwgFiler filer
)
Protected Overridable Sub DwgOutFields ( _
    filer As DwgFiler _
)
protected:
virtual void DwgOutFields(
    DwgFiler^ filer
)
Parameters
filer(DwgFiler)


DxfIn Method (filer)

DxfIn Method (filer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DxfIn(DxfFiler)
Declaration Syntax
C# Visual Basic Visual C++
public void DxfIn(
    DxfFiler filer
)
Public Sub DxfIn ( _
    filer As DxfFiler _
)
public:
void DxfIn(
    DxfFiler^ filer
)
Parameters
filer(DxfFiler)


DxfInFields Method (filer)

DxfInFields Method (filer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DxfInFields(DxfFiler)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void DxfInFields(
    DxfFiler filer
)
Protected Overridable Sub DxfInFields ( _
    filer As DxfFiler _
)
protected:
virtual void DxfInFields(
    DxfFiler^ filer
)
Parameters
filer(DxfFiler)


DxfOut Method (filer)

DxfOut Method (filer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DxfOut(DxfFiler)
Declaration Syntax
C# Visual Basic Visual C++
public void DxfOut(
    DxfFiler filer
)
Public Sub DxfOut ( _
    filer As DxfFiler _
)
public:
void DxfOut(
    DxfFiler^ filer
)
Parameters
filer(DxfFiler)


DxfOutFields Method (filer)

DxfOutFields Method (filer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »DxfOutFields(DxfFiler)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void DxfOutFields(
    DxfFiler filer
)
Protected Overridable Sub DxfOutFields ( _
    filer As DxfFiler _
)
protected:
virtual void DxfOutFields(
    DxfFiler^ filer
)
Parameters
filer(DxfFiler)


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Erase()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Erase()
Public Sub Erase
public:
void Erase()


Erase Method (erasing)

Erase Method (erasing)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Erase(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void Erase(
    bool erasing
)
Public Sub Erase ( _
    erasing As Boolean _
)
public:
void Erase(
    bool erasing
)
Parameters
erasing(Boolean)


Erased Event

Erased Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Erased
Declaration Syntax
C# Visual Basic Visual C++
public event ObjectErasedEventHandler Erased
Public Event Erased As ObjectErasedEventHandler
public:
 event ObjectErasedEventHandler^ Erased {
    void add (ObjectErasedEventHandler^ value);
    void remove (ObjectErasedEventHandler^ value);
}


ExtensionDictionary Property

ExtensionDictionary Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ExtensionDictionary
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ExtensionDictionary { get; }
Public ReadOnly Property ExtensionDictionary As ObjectId
    Get
public:
property ObjectId ExtensionDictionary {
    ObjectId get ();
}


FromAcadObject Method (acadObj)

FromAcadObject Method (acadObj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »FromAcadObject(Object)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId FromAcadObject(
    Object acadObj
)
Public Shared Function FromAcadObject ( _
    acadObj As Object _
) As ObjectId
public:
static ObjectId FromAcadObject(
    Object^ acadObj
)
Parameters
acadObj(Object)


FromZcadObject Method (zcadObj)

FromZcadObject Method (zcadObj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »FromZcadObject(Object)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId FromZcadObject(
    Object zcadObj
)
Public Shared Function FromZcadObject ( _
    zcadObj As Object _
) As ObjectId
public:
static ObjectId FromZcadObject(
    Object^ zcadObj
)
Parameters
zcadObj(Object)


GetEventExtender Method (create)

GetEventExtender Method (create)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetEventExtender(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DBObjectEventExtender GetEventExtender(
    bool create
)
Public Function GetEventExtender ( _
    create As Boolean _
) As DBObjectEventExtender
public:
DBObjectEventExtender^ GetEventExtender(
    bool create
)
Parameters
create(Boolean)


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetField()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetField()
Public Function GetField As ObjectId
public:
ObjectId GetField()


GetField Method (propertyName)

GetField Method (propertyName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetField(String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetField(
    string propertyName
)
Public Function GetField ( _
    propertyName As String _
) As ObjectId
public:
ObjectId GetField(
    String^ propertyName
)
Parameters
propertyName(String)


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetObjectSaveVersion Method (filer)

GetObjectSaveVersion Method (filer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetObjectSaveVersion(DwgFiler)
Declaration Syntax
C# Visual Basic Visual C++
public virtual FullDwgVersion GetObjectSaveVersion(
    DwgFiler filer
)
Public Overridable Function GetObjectSaveVersion ( _
    filer As DwgFiler _
) As FullDwgVersion
public:
virtual FullDwgVersion GetObjectSaveVersion(
    DwgFiler^ filer
)
Parameters
filer(DwgFiler)


GetObjectSaveVersion Method (filer)

GetObjectSaveVersion Method (filer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetObjectSaveVersion(DxfFiler)
Declaration Syntax
C# Visual Basic Visual C++
public virtual FullDwgVersion GetObjectSaveVersion(
    DxfFiler filer
)
Public Overridable Function GetObjectSaveVersion ( _
    filer As DxfFiler _
) As FullDwgVersion
public:
virtual FullDwgVersion GetObjectSaveVersion(
    DxfFiler^ filer
)
Parameters
filer(DxfFiler)


GetPersistentReactorIds Method

GetPersistentReactorIds Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetPersistentReactorIds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetPersistentReactorIds()
Public Function GetPersistentReactorIds As ObjectIdCollection
public:
ObjectIdCollection^ GetPersistentReactorIds()


GetReactors Method

GetReactors Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetReactors()()()()
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use GetTransientReactors() instead.")]
public List<RXObject> GetReactors()
<ObsoleteAttribute("Use GetTransientReactors() instead.")> _
Public Function GetReactors As List(Of RXObject)
[ObsoleteAttribute(L"Use GetTransientReactors() instead.")]
public:
List<RXObject^>^ GetReactors()


GetTransientReactors Method

GetTransientReactors Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetTransientReactors()()()()
Declaration Syntax
C# Visual Basic Visual C++
public List<RXObject> GetTransientReactors()
Public Function GetTransientReactors As List(Of RXObject)
public:
List<RXObject^>^ GetTransientReactors()


GetXDataForApplication Method (applicationName)

GetXDataForApplication Method (applicationName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »GetXDataForApplication(String)
Declaration Syntax
C# Visual Basic Visual C++
public ResultBuffer GetXDataForApplication(
    string applicationName
)
Public Function GetXDataForApplication ( _
    applicationName As String _
) As ResultBuffer
public:
ResultBuffer^ GetXDataForApplication(
    String^ applicationName
)
Parameters
applicationName(String)


Goodbye Event

Goodbye Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Goodbye
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Goodbye
Public Event Goodbye As EventHandler
public:
 event EventHandler^ Goodbye {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Handle Property

Handle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Handle
Declaration Syntax
C# Visual Basic Visual C++
public Handle Handle { get; }
Public ReadOnly Property Handle As Handle
    Get
public:
property Handle Handle {
    Handle get ();
}


HandOverTo Method (newPointer, keepXData, keepExtensionDictionary)

HandOverTo Method (newPointer, keepXData, keepExtensionDictionary)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »HandOverTo(DBObject, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void HandOverTo(
    DBObject newPointer,
    bool keepXData,
    bool keepExtensionDictionary
)
Public Sub HandOverTo ( _
    newPointer As DBObject, _
    keepXData As Boolean, _
    keepExtensionDictionary As Boolean _
)
public:
void HandOverTo(
    DBObject^ newPointer,
    bool keepXData,
    bool keepExtensionDictionary
)
Parameters
newPointer(DBObject)
keepXData(Boolean)
keepExtensionDictionary(Boolean)


HasContext Method (context)

HasContext Method (context)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »HasContext(ObjectContext)
Declaration Syntax
C# Visual Basic Visual C++
public bool HasContext(
    ObjectContext context
)
Public Function HasContext ( _
    context As ObjectContext _
) As Boolean
public:
bool HasContext(
    ObjectContext^ context
)
Parameters
context(ObjectContext)


HasFields Property

HasFields Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »HasFields
Declaration Syntax
C# Visual Basic Visual C++
public bool HasFields { get; }
Public ReadOnly Property HasFields As Boolean
    Get
public:
property bool HasFields {
    bool get ();
}


HasPersistentReactor Method (objId)

HasPersistentReactor Method (objId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »HasPersistentReactor(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool HasPersistentReactor(
    ObjectId objId
)
Public Function HasPersistentReactor ( _
    objId As ObjectId _
) As Boolean
public:
bool HasPersistentReactor(
    ObjectId objId
)
Parameters
objId(ObjectId)


HasSaveVersionOverride Property

HasSaveVersionOverride Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »HasSaveVersionOverride
Declaration Syntax
C# Visual Basic Visual C++
public bool HasSaveVersionOverride { get; set; }
Public Property HasSaveVersionOverride As Boolean
    Get
    Set
public:
property bool HasSaveVersionOverride {
    bool get ();
    void set (bool value);
}


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Id
Declaration Syntax
C# Visual Basic Visual C++
public override ObjectId Id { get; }
Public Overrides ReadOnly Property Id As ObjectId
    Get
public:
virtual property ObjectId Id {
    ObjectId get () override;
}


IsAProxy Property

IsAProxy Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsAProxy
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAProxy { get; }
Public ReadOnly Property IsAProxy As Boolean
    Get
public:
property bool IsAProxy {
    bool get ();
}


IsCancelling Property

IsCancelling Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsCancelling
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCancelling { get; }
Public ReadOnly Property IsCancelling As Boolean
    Get
public:
property bool IsCancelling {
    bool get ();
}


IsCustomObject Method (id)

IsCustomObject Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsCustomObject(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsCustomObject(
    ObjectId id
)
Public Shared Function IsCustomObject ( _
    id As ObjectId _
) As Boolean
public:
static bool IsCustomObject(
    ObjectId id
)
Parameters
id(ObjectId)


IsErased Property

IsErased Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsErased
Declaration Syntax
C# Visual Basic Visual C++
public bool IsErased { get; }
Public ReadOnly Property IsErased As Boolean
    Get
public:
property bool IsErased {
    bool get ();
}


IsEraseStatusToggled Property

IsEraseStatusToggled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsEraseStatusToggled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEraseStatusToggled { get; }
Public ReadOnly Property IsEraseStatusToggled As Boolean
    Get
public:
property bool IsEraseStatusToggled {
    bool get ();
}


IsModified Property

IsModified Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsModified
Declaration Syntax
C# Visual Basic Visual C++
public bool IsModified { get; }
Public ReadOnly Property IsModified As Boolean
    Get
public:
property bool IsModified {
    bool get ();
}


IsModifiedGraphics Property

IsModifiedGraphics Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsModifiedGraphics
Declaration Syntax
C# Visual Basic Visual C++
public bool IsModifiedGraphics { get; }
Public ReadOnly Property IsModifiedGraphics As Boolean
    Get
public:
property bool IsModifiedGraphics {
    bool get ();
}


IsModifiedXData Property

IsModifiedXData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsModifiedXData
Declaration Syntax
C# Visual Basic Visual C++
public bool IsModifiedXData { get; }
Public ReadOnly Property IsModifiedXData As Boolean
    Get
public:
property bool IsModifiedXData {
    bool get ();
}


IsNewObject Property

IsNewObject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsNewObject
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNewObject { get; }
Public ReadOnly Property IsNewObject As Boolean
    Get
public:
property bool IsNewObject {
    bool get ();
}


IsNotifyEnabled Property

IsNotifyEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsNotifyEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNotifyEnabled { get; }
Public ReadOnly Property IsNotifyEnabled As Boolean
    Get
public:
property bool IsNotifyEnabled {
    bool get ();
}


IsNotifying Property

IsNotifying Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsNotifying
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNotifying { get; }
Public ReadOnly Property IsNotifying As Boolean
    Get
public:
property bool IsNotifying {
    bool get ();
}


IsObjectIdsInFlux Property

IsObjectIdsInFlux Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsObjectIdsInFlux
Declaration Syntax
C# Visual Basic Visual C++
public bool IsObjectIdsInFlux { get; }
Public ReadOnly Property IsObjectIdsInFlux As Boolean
    Get
public:
property bool IsObjectIdsInFlux {
    bool get ();
}


IsPersistent Property

IsPersistent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsPersistent
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsPersistent { get; }
Public Overrides ReadOnly Property IsPersistent As Boolean
    Get
public:
virtual property bool IsPersistent {
    bool get () override;
}


IsReadEnabled Property

IsReadEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsReadEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadEnabled { get; }
Public ReadOnly Property IsReadEnabled As Boolean
    Get
public:
property bool IsReadEnabled {
    bool get ();
}


IsReallyClosing Property

IsReallyClosing Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsReallyClosing
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReallyClosing { get; }
Public ReadOnly Property IsReallyClosing As Boolean
    Get
public:
property bool IsReallyClosing {
    bool get ();
}


IsTransactionResident Property

IsTransactionResident Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsTransactionResident
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTransactionResident { get; }
Public ReadOnly Property IsTransactionResident As Boolean
    Get
public:
property bool IsTransactionResident {
    bool get ();
}


IsUndoing Property

IsUndoing Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsUndoing
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUndoing { get; }
Public ReadOnly Property IsUndoing As Boolean
    Get
public:
property bool IsUndoing {
    bool get ();
}


IsWriteEnabled Property

IsWriteEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »IsWriteEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsWriteEnabled { get; }
Public ReadOnly Property IsWriteEnabled As Boolean
    Get
public:
property bool IsWriteEnabled {
    bool get ();
}


MergeStyle Property

MergeStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »MergeStyle
Declaration Syntax
C# Visual Basic Visual C++
public virtual DuplicateRecordCloning MergeStyle { get; set; }
Public Overridable Property MergeStyle As DuplicateRecordCloning
    Get
    Set
public:
virtual property DuplicateRecordCloning MergeStyle {
    DuplicateRecordCloning get ();
    void set (DuplicateRecordCloning value);
}


Modified Event

Modified Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Modified
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Modified
Public Event Modified As EventHandler
public:
 event EventHandler^ Modified {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ModifiedXData Event

ModifiedXData Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ModifiedXData
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ModifiedXData
Public Event ModifiedXData As EventHandler
public:
 event EventHandler^ ModifiedXData {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ModifyUndone Event

ModifyUndone Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ModifyUndone
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler ModifyUndone
Public Event ModifyUndone As EventHandler
public:
 event EventHandler^ ModifyUndone {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ObjectBirthVersion Property

ObjectBirthVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ObjectBirthVersion
Declaration Syntax
C# Visual Basic Visual C++
public virtual FullDwgVersion ObjectBirthVersion { get; }
Public Overridable ReadOnly Property ObjectBirthVersion As FullDwgVersion
    Get
public:
virtual property FullDwgVersion ObjectBirthVersion {
    FullDwgVersion get ();
}


ObjectClosed Event

ObjectClosed Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ObjectClosed
Declaration Syntax
C# Visual Basic Visual C++
public event ObjectClosedEventHandler ObjectClosed
Public Event ObjectClosed As ObjectClosedEventHandler
public:
 event ObjectClosedEventHandler^ ObjectClosed {
    void add (ObjectClosedEventHandler^ value);
    void remove (ObjectClosedEventHandler^ value);
}


ObjectId Property

ObjectId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ObjectId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ObjectId { get; }
Public ReadOnly Property ObjectId As ObjectId
    Get
public:
property ObjectId ObjectId {
    ObjectId get ();
}


OpenedForModify Event

OpenedForModify Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »OpenedForModify
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler OpenedForModify
Public Event OpenedForModify As EventHandler
public:
 event EventHandler^ OpenedForModify {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


OwnerId Property

OwnerId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »OwnerId
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId OwnerId { get; }
Public Overridable ReadOnly Property OwnerId As ObjectId
    Get
public:
virtual property ObjectId OwnerId {
    ObjectId get ();
}


PaperOrientation Property

PaperOrientation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »PaperOrientation
Declaration Syntax
C# Visual Basic Visual C++
public PaperOrientationStates PaperOrientation { get; }
Public ReadOnly Property PaperOrientation As PaperOrientationStates
    Get
public:
property PaperOrientationStates PaperOrientation {
    PaperOrientationStates get ();
}


Reappended Event

Reappended Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Reappended
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Reappended
Public Event Reappended As EventHandler
public:
 event EventHandler^ Reappended {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ReleaseExtensionDictionary Method

ReleaseExtensionDictionary Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ReleaseExtensionDictionary()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ReleaseExtensionDictionary()
Public Sub ReleaseExtensionDictionary
public:
void ReleaseExtensionDictionary()


RemoveContext Method (context)

RemoveContext Method (context)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »RemoveContext(ObjectContext)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveContext(
    ObjectContext context
)
Public Sub RemoveContext ( _
    context As ObjectContext _
)
public:
void RemoveContext(
    ObjectContext^ context
)
Parameters
context(ObjectContext)


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »RemoveField()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId RemoveField()
Public Function RemoveField As ObjectId
public:
ObjectId RemoveField()


RemoveField Method (propertyName)

RemoveField Method (propertyName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »RemoveField(String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId RemoveField(
    string propertyName
)
Public Function RemoveField ( _
    propertyName As String _
) As ObjectId
public:
ObjectId RemoveField(
    String^ propertyName
)
Parameters
propertyName(String)


RemoveField Method (id)

RemoveField Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »RemoveField(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveField(
    ObjectId id
)
Public Sub RemoveField ( _
    id As ObjectId _
)
public:
void RemoveField(
    ObjectId id
)
Parameters
id(ObjectId)


RemovePersistentReactor Method (objId)

RemovePersistentReactor Method (objId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »RemovePersistentReactor(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void RemovePersistentReactor(
    ObjectId objId
)
Public Sub RemovePersistentReactor ( _
    objId As ObjectId _
)
public:
void RemovePersistentReactor(
    ObjectId objId
)
Parameters
objId(ObjectId)


ResetScaleDependentProperties Method

ResetScaleDependentProperties Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ResetScaleDependentProperties()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ResetScaleDependentProperties()
Public Sub ResetScaleDependentProperties
public:
void ResetScaleDependentProperties()


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method (propertyName, field)

SetField Method (propertyName, field)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SetField(String, Field)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId SetField(
    string propertyName,
    Field field
)
Public Function SetField ( _
    propertyName As String, _
    field As Field _
) As ObjectId
public:
ObjectId SetField(
    String^ propertyName,
    Field^ field
)
Parameters
propertyName(String)
field(Field)


SetField Method (field)

SetField Method (field)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SetField(Field)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId SetField(
    Field field
)
Public Function SetField ( _
    field As Field _
) As ObjectId
public:
ObjectId SetField(
    Field^ field
)
Parameters
field(Field)


SetFromStyle Method

SetFromStyle Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SetFromStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool SetFromStyle()
Public Function SetFromStyle As Boolean
public:
bool SetFromStyle()


SetObjectIdsInFlux Method

SetObjectIdsInFlux Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SetObjectIdsInFlux()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetObjectIdsInFlux()
Public Sub SetObjectIdsInFlux
public:
void SetObjectIdsInFlux()


SetPaperOrientation Method (bPaperOrientation)

SetPaperOrientation Method (bPaperOrientation)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SetPaperOrientation(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPaperOrientation(
    bool bPaperOrientation
)
Public Sub SetPaperOrientation ( _
    bPaperOrientation As Boolean _
)
public:
void SetPaperOrientation(
    bool bPaperOrientation
)
Parameters
bPaperOrientation(Boolean)


SubObjectModified Event

SubObjectModified Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SubObjectModified
Declaration Syntax
C# Visual Basic Visual C++
public event ObjectEventHandler SubObjectModified
Public Event SubObjectModified As ObjectEventHandler
public:
 event ObjectEventHandler^ SubObjectModified {
    void add (ObjectEventHandler^ value);
    void remove (ObjectEventHandler^ value);
}


SubSetAttributes Method (traits)

SubSetAttributes Method (traits)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SubSetAttributes(DrawableTraits)
Declaration Syntax
C# Visual Basic Visual C++
protected internal override int SubSetAttributes(
    DrawableTraits traits
)
Protected Friend Overrides Function SubSetAttributes ( _
    traits As DrawableTraits _
) As Integer
protected public:
virtual int SubSetAttributes(
    DrawableTraits^ traits
) override
Parameters
traits(DrawableTraits)


SubViewportDraw Method (vd)

SubViewportDraw Method (vd)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SubViewportDraw(ViewportDraw)
Declaration Syntax
C# Visual Basic Visual C++
protected internal override void SubViewportDraw(
    ViewportDraw vd
)
Protected Friend Overrides Sub SubViewportDraw ( _
    vd As ViewportDraw _
)
protected public:
virtual void SubViewportDraw(
    ViewportDraw^ vd
) override
Parameters
vd(ViewportDraw)


SubViewportDrawLogicalFlags Method (vd)

SubViewportDrawLogicalFlags Method (vd)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SubViewportDrawLogicalFlags(ViewportDraw)
Declaration Syntax
C# Visual Basic Visual C++
protected internal override int SubViewportDrawLogicalFlags(
    ViewportDraw vd
)
Protected Friend Overrides Function SubViewportDrawLogicalFlags ( _
    vd As ViewportDraw _
) As Integer
protected public:
virtual int SubViewportDrawLogicalFlags(
    ViewportDraw^ vd
) override
Parameters
vd(ViewportDraw)


SubWorldDraw Method (wd)

SubWorldDraw Method (wd)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SubWorldDraw(WorldDraw)
Declaration Syntax
C# Visual Basic Visual C++
protected internal override bool SubWorldDraw(
    WorldDraw wd
)
Protected Friend Overrides Function SubWorldDraw ( _
    wd As WorldDraw _
) As Boolean
protected public:
virtual bool SubWorldDraw(
    WorldDraw^ wd
) override
Parameters
wd(WorldDraw)


SupportsCollection Method (collectionName)

SupportsCollection Method (collectionName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SupportsCollection(String)
Declaration Syntax
C# Visual Basic Visual C++
public bool SupportsCollection(
    string collectionName
)
Public Function SupportsCollection ( _
    collectionName As String _
) As Boolean
public:
bool SupportsCollection(
    String^ collectionName
)
Parameters
collectionName(String)


SwapIdWith Method (otherId, swapExtendedData, swapExtensionDictionary)

SwapIdWith Method (otherId, swapExtendedData, swapExtensionDictionary)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SwapIdWith(ObjectId, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SwapIdWith(
    ObjectId otherId,
    bool swapExtendedData,
    bool swapExtensionDictionary
)
Public Sub SwapIdWith ( _
    otherId As ObjectId, _
    swapExtendedData As Boolean, _
    swapExtensionDictionary As Boolean _
)
public:
void SwapIdWith(
    ObjectId otherId,
    bool swapExtendedData,
    bool swapExtensionDictionary
)
Parameters
otherId(ObjectId)
swapExtendedData(Boolean)
swapExtensionDictionary(Boolean)


SwapReferences Method (idMap)

SwapReferences Method (idMap)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »SwapReferences(IdMapping)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SwapReferences(
    IdMapping idMap
)
Public Overridable Sub SwapReferences ( _
    idMap As IdMapping _
)
public:
virtual void SwapReferences(
    IdMapping^ idMap
)
Parameters
idMap(IdMapping)


Unappended Event

Unappended Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Unappended
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Unappended
Public Event Unappended As EventHandler
public:
 event EventHandler^ Unappended {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


UndoFiler Property

UndoFiler Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »UndoFiler
Declaration Syntax
C# Visual Basic Visual C++
public DwgFiler UndoFiler { get; }
Public ReadOnly Property UndoFiler As DwgFiler
    Get
public:
property DwgFiler^ UndoFiler {
    DwgFiler^ get ();
}


UpgradeFromNotify Method

UpgradeFromNotify Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »UpgradeFromNotify()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool UpgradeFromNotify()
Public Function UpgradeFromNotify As Boolean
public:
bool UpgradeFromNotify()


UpgradeOpen Method

UpgradeOpen Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »UpgradeOpen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpgradeOpen()
Public Sub UpgradeOpen
public:
void UpgradeOpen()


WblockClone Method (ownerPointer, idMap, isPrimary)

WblockClone Method (ownerPointer, idMap, isPrimary)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »WblockClone(RXObject, IdMapping, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObject WblockClone(
    RXObject ownerPointer,
    IdMapping idMap,
    bool isPrimary
)
Public Overridable Function WblockClone ( _
    ownerPointer As RXObject, _
    idMap As IdMapping, _
    isPrimary As Boolean _
) As DBObject
public:
virtual DBObject^ WblockClone(
    RXObject^ ownerPointer,
    IdMapping^ idMap,
    bool isPrimary
)
Parameters
ownerPointer(RXObject)
idMap(IdMapping)
isPrimary(Boolean)


XData Property

XData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »XData
Declaration Syntax
C# Visual Basic Visual C++
public virtual ResultBuffer XData { get; set; }
Public Overridable Property XData As ResultBuffer
    Get
    Set
public:
virtual property ResultBuffer^ XData {
    ResultBuffer^ get ();
    void set (ResultBuffer^ value);
}


XDataTransformBy Method (transform)

XDataTransformBy Method (transform)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »XDataTransformBy(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public void XDataTransformBy(
    Matrix3d transform
)
Public Sub XDataTransformBy ( _
    transform As Matrix3d _
)
public:
void XDataTransformBy(
    Matrix3d transform
)
Parameters
transform(Matrix3d)


ZcadObject Property

ZcadObject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »ZcadObject
Declaration Syntax
C# Visual Basic Visual C++
public Object ZcadObject { get; }
Public ReadOnly Property ZcadObject As Object
    Get
public:
property Object^ ZcadObject {
    Object^ get ();
}


DBObjectCollection Class

DBObjectCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbVoidPtrArray")]
public class DBObjectCollection : DisposableWrapper,
    IList
<WrapperAttribute("AcDbVoidPtrArray")> _
Public Class DBObjectCollection _
    Inherits DisposableWrapper _
    Implements IList
[WrapperAttribute(L"AcDbVoidPtrArray")]
public ref class DBObjectCollection : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DBObjectCollection()()()() |
 | Add(DBObject) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(DBObject) |
 | CopyTo(array<DBObject>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Remove(Object) |
 | IndexOf(DBObject) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, DBObject) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IList..::..IsFixedSize |
 | IList..::..IsReadOnly |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(DBObject) |
 | RemoveAt(Int32) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | DBObjectCollection


DBObjectCollection Constructor

DBObjectCollection Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »DBObjectCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DBObjectCollection()
Public Sub New
public:
DBObjectCollection()


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »Add(DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DBObject value
)
Public Function Add ( _
    value As DBObject _
) As Integer
public:
int Add(
    DBObject^ value
)
Parameters
value(DBObject)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »Contains(DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DBObject value
)
Public Function Contains ( _
    value As DBObject _
) As Boolean
public:
bool Contains(
    DBObject^ value
)
Parameters
value(DBObject)


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »CopyTo(array<DBObject>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DBObject[] arr,
    int index
)
Public Sub CopyTo ( _
    arr As DBObject(), _
    index As Integer _
)
public:
void CopyTo(
    array<DBObject^>^ arr,
    int index
)
Parameters
arr(array< DBObject >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override sealed void DeleteUnmanagedObject()
Protected Overrides NotOverridable Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override sealed


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()


ICollectionCopyTo Method (array, index)

ICollectionCopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollectionCopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IListAdd Method (value)

IListAdd Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IListAdd ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IListAdd(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IListContains Method (value)

IListContains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IListContains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IListContains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IListIndexOf Method (value)

IListIndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IListIndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IListIndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IListInsert Method (index, value)

IListInsert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IListInsert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IListInsert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IListRemove Method (value)

IListRemove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IListRemove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IListRemove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »IndexOf(DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DBObject value
)
Public Function IndexOf ( _
    value As DBObject _
) As Integer
public:
int IndexOf(
    DBObject^ value
)
Parameters
value(DBObject)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »Insert(Int32, DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DBObject value
)
Public Sub Insert ( _
    index As Integer, _
    value As DBObject _
)
public:
void Insert(
    int index,
    DBObject^ value
)
Parameters
index(Int32)
value(DBObject)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »IList..::..IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
bool IList.IsFixedSize { get; }
Private ReadOnly Property IsFixedSize As Boolean
    Implements IList.IsFixedSize
    Get
private:
virtual property bool IsFixedSize {
    bool get () sealed = IList::IsFixedSize::get;
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »IList..::..IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
bool IList.IsReadOnly { get; }
Private ReadOnly Property IsReadOnly As Boolean
    Implements IList.IsReadOnly
    Get
private:
virtual property bool IsReadOnly {
    bool get () sealed = IList::IsReadOnly::get;
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DBObject this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DBObject
    Get
    Set
public:
property DBObject^ default[int index] {
    DBObject^ get (int index);
    void set (int index, DBObject^ value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »Remove(DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DBObject value
)
Public Sub Remove ( _
    value As DBObject _
)
public:
void Remove(
    DBObject^ value
)
Parameters
value(DBObject)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


DBObjectReference Structure

DBObjectReference Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReference
Declaration Syntax
C# Visual Basic Visual C++
public struct DBObjectReference
Public Structure DBObjectReference
public value class DBObjectReference
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DBObjectReference(ObjectId, Int32) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Kind |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObjectId |
 | ToString()()()() | (Inherited from ValueType.)


DBObjectReference Constructor (id, kind)

DBObjectReference Constructor (id, kind)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReference »DBObjectReference(ObjectId, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DBObjectReference(
    ObjectId id,
    int kind
)
Public Sub New ( _
    id As ObjectId, _
    kind As Integer _
)
public:
DBObjectReference(
    ObjectId id,
    int kind
)
Parameters
id(ObjectId)
kind(Int32)


Kind Property

Kind Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReference »Kind
Declaration Syntax
C# Visual Basic Visual C++
public int Kind { get; }
Public ReadOnly Property Kind As Integer
    Get
public:
property int Kind {
    int get ();
}


ObjectId Property

ObjectId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReference »ObjectId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ObjectId { get; }
Public ReadOnly Property ObjectId As ObjectId
    Get
public:
property ObjectId ObjectId {
    ObjectId get ();
}


DBObjectReferenceCollection Class

DBObjectReferenceCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DBObjectReferenceCollection : CollectionBase
Public NotInheritable Class DBObjectReferenceCollection _
    Inherits CollectionBase
public ref class DBObjectReferenceCollection sealed : public CollectionBase
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(DBObjectReference) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DBObjectReference) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DBObjectReference>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DBObjectReference) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DBObjectReference) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DBObjectReference) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DBObjectReferenceCollection


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »Add(DBObjectReference)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DBObjectReference value
)
Public Function Add ( _
    value As DBObjectReference _
) As Integer
public:
int Add(
    DBObjectReference value
)
Parameters
value(DBObjectReference)


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »Contains(DBObjectReference)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DBObjectReference value
)
Public Function Contains ( _
    value As DBObjectReference _
) As Boolean
public:
bool Contains(
    DBObjectReference value
)
Parameters
value(DBObjectReference)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »CopyTo(array<DBObjectReference>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DBObjectReference[] array,
    int index
)
Public Sub CopyTo ( _
    array As DBObjectReference(), _
    index As Integer _
)
public:
void CopyTo(
    array<DBObjectReference>^ array,
    int index
)
Parameters
array(array< DBObjectReference >[]()[][])
index(Int32)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »IndexOf(DBObjectReference)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DBObjectReference value
)
Public Function IndexOf ( _
    value As DBObjectReference _
) As Integer
public:
int IndexOf(
    DBObjectReference value
)
Parameters
value(DBObjectReference)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »Insert(Int32, DBObjectReference)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DBObjectReference value
)
Public Sub Insert ( _
    index As Integer, _
    value As DBObjectReference _
)
public:
void Insert(
    int index,
    DBObjectReference value
)
Parameters
index(Int32)
value(DBObjectReference)


Item Property (iIndex)

Item Property (iIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DBObjectReference this[
    int iIndex
] { get; set; }
Public Default Property Item ( _
    iIndex As Integer _
) As DBObjectReference
    Get
    Set
public:
property DBObjectReference default[int iIndex] {
    DBObjectReference get (int iIndex);
    void set (int iIndex, DBObjectReference value);
}
Parameters
iIndex(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »Remove(DBObjectReference)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DBObjectReference value
)
Public Sub Remove ( _
    value As DBObjectReference _
)
public:
void Remove(
    DBObjectReference value
)
Parameters
value(DBObjectReference)


DBPoint Class

DBPoint Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbPoint")]
public class DBPoint : Entity
<WrapperAttribute("AcDbPoint")> _
Public Class DBPoint _
    Inherits Entity
[WrapperAttribute(L"AcDbPoint")]
public ref class DBPoint : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DBPoint(IntPtr, Boolean) |
 | DBPoint(Point3d) |
 | DBPoint()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EcsRotation |
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | DBPoint


DBPoint Constructor

DBPoint Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »DBPoint()()()()
Members
Icon | Member | Description
 | DBPoint(IntPtr, Boolean) |
 | DBPoint(Point3d) |
 | DBPoint()()()() |


DBPoint Constructor

DBPoint Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »DBPoint()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DBPoint()
Public Sub New
public:
DBPoint()


DBPoint Constructor (unmanagedObjPtr, autoDelete)

DBPoint Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »DBPoint(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DBPoint(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DBPoint(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


DBPoint Constructor (position)

DBPoint Constructor (position)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »DBPoint(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public DBPoint(
    Point3d position
)
Public Sub New ( _
    position As Point3d _
)
public:
DBPoint(
    Point3d position
)
Parameters
position(Point3d)


EcsRotation Property

EcsRotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »EcsRotation
Declaration Syntax
C# Visual Basic Visual C++
public double EcsRotation { get; set; }
Public Property EcsRotation As Double
    Get
    Set
public:
property double EcsRotation {
    double get ();
    void set (double value);
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »Position
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Position { get; set; }
Public Property Position As Point3d
    Get
    Set
public:
property Point3d Position {
    Point3d get ();
    void set (Point3d value);
}


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}


DBText Class

DBText Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbText")]
public class DBText : Entity
<WrapperAttribute("AcDbText")> _
Public Class DBText _
    Inherits Entity
[WrapperAttribute(L"AcDbText")]
public ref class DBText : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DBText()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AdjustAlignment(Database) |
 | AlignmentPoint |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertFieldToText()()()() |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CorrectSpelling()()()() |
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | getTextWithFieldCodes()()()() |
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height |
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalMode |
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDefaultAlignment |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsMirroredInX |
 | IsMirroredInY |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Justify |
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | Oblique |
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextString |
 | TextStyle |
 | TextStyleId |
 | TextStyleName |
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VerticalMode |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WidthFactor |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | DBText
 |  |  |  |  |  |  |  | AttributeDefinition
 |  |  |  |  |  |  |  | AttributeReference


DBText Constructor

DBText Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »DBText()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DBText()
Public Sub New
public:
DBText()


AdjustAlignment Method (alternateDatabaseToUse)

AdjustAlignment Method (alternateDatabaseToUse)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »AdjustAlignment(Database)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AdjustAlignment(
    Database alternateDatabaseToUse
)
Public Overridable Sub AdjustAlignment ( _
    alternateDatabaseToUse As Database _
)
public:
virtual void AdjustAlignment(
    Database^ alternateDatabaseToUse
)
Parameters
alternateDatabaseToUse(Database)


AlignmentPoint Property

AlignmentPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »AlignmentPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d AlignmentPoint { get; set; }
Public Property AlignmentPoint As Point3d
    Get
    Set
public:
property Point3d AlignmentPoint {
    Point3d get ();
    void set (Point3d value);
}


ConvertFieldToText Method

ConvertFieldToText Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »ConvertFieldToText()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ConvertFieldToText()
Public Sub ConvertFieldToText
public:
void ConvertFieldToText()


CorrectSpelling Method

CorrectSpelling Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »CorrectSpelling()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int CorrectSpelling()
Public Function CorrectSpelling As Integer
public:
int CorrectSpelling()


getTextWithFieldCodes Method

getTextWithFieldCodes Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »getTextWithFieldCodes()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string getTextWithFieldCodes()
Public Function getTextWithFieldCodes As String
public:
String^ getTextWithFieldCodes()


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Height
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Height { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Height As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Height {
    double get ();
    void set (double value);
}


HorizontalMode Property

HorizontalMode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »HorizontalMode
Declaration Syntax
C# Visual Basic Visual C++
public TextHorizontalMode HorizontalMode { get; set; }
Public Property HorizontalMode As TextHorizontalMode
    Get
    Set
public:
property TextHorizontalMode HorizontalMode {
    TextHorizontalMode get ();
    void set (TextHorizontalMode value);
}


IsDefaultAlignment Property

IsDefaultAlignment Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »IsDefaultAlignment
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDefaultAlignment { get; }
Public ReadOnly Property IsDefaultAlignment As Boolean
    Get
public:
property bool IsDefaultAlignment {
    bool get ();
}


IsMirroredInX Property

IsMirroredInX Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »IsMirroredInX
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMirroredInX { get; set; }
Public Property IsMirroredInX As Boolean
    Get
    Set
public:
property bool IsMirroredInX {
    bool get ();
    void set (bool value);
}


IsMirroredInY Property

IsMirroredInY Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »IsMirroredInY
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMirroredInY { get; set; }
Public Property IsMirroredInY As Boolean
    Get
    Set
public:
property bool IsMirroredInY {
    bool get ();
    void set (bool value);
}


Justify Property

Justify Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Justify
Declaration Syntax
C# Visual Basic Visual C++
public AttachmentPoint Justify { get; set; }
Public Property Justify As AttachmentPoint
    Get
    Set
public:
property AttachmentPoint Justify {
    AttachmentPoint get ();
    void set (AttachmentPoint value);
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


Oblique Property

Oblique Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Oblique
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.AngleNotTransformed)]
public double Oblique { get; set; }
<UnitTypeAttribute(UnitType.AngleNotTransformed)> _
Public Property Oblique As Double
    Get
    Set
[UnitTypeAttribute(UnitType::AngleNotTransformed)]
public:
property double Oblique {
    double get ();
    void set (double value);
}


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Position
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Position { get; set; }
Public Property Position As Point3d
    Get
    Set
public:
property Point3d Position {
    Point3d get ();
    void set (Point3d value);
}


Rotation Property

Rotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Rotation
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Angle)]
public double Rotation { get; set; }
<UnitTypeAttribute(UnitType.Angle)> _
Public Property Rotation As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Angle)]
public:
property double Rotation {
    double get ();
    void set (double value);
}


TextString Property

TextString Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »TextString
Declaration Syntax
C# Visual Basic Visual C++
public string TextString { get; set; }
Public Property TextString As String
    Get
    Set
public:
property String^ TextString {
    String^ get ();
    void set (String^ value);
}


TextStyle Property

TextStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »TextStyle
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId TextStyle { get; set; }
Public Property TextStyle As ObjectId
    Get
    Set
public:
property ObjectId TextStyle {
    ObjectId get ();
    void set (ObjectId value);
}


TextStyleId Property

TextStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »TextStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId TextStyleId { get; set; }
Public Property TextStyleId As ObjectId
    Get
    Set
public:
property ObjectId TextStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


TextStyleName Property

TextStyleName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »TextStyleName
Declaration Syntax
C# Visual Basic Visual C++
public string TextStyleName { get; }
Public ReadOnly Property TextStyleName As String
    Get
public:
property String^ TextStyleName {
    String^ get ();
}


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Thickness
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Thickness { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Thickness As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Thickness {
    double get ();
    void set (double value);
}


VerticalMode Property

VerticalMode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »VerticalMode
Declaration Syntax
C# Visual Basic Visual C++
public TextVerticalMode VerticalMode { get; set; }
Public Property VerticalMode As TextVerticalMode
    Get
    Set
public:
property TextVerticalMode VerticalMode {
    TextVerticalMode get ();
    void set (TextVerticalMode value);
}


WidthFactor Property

WidthFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »WidthFactor
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double WidthFactor { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property WidthFactor As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double WidthFactor {
    double get ();
    void set (double value);
}


DBVisualStyle Class

DBVisualStyle Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbVisualStyle")]
public class DBVisualStyle : DBObject
<WrapperAttribute("ZcDbVisualStyle")> _
Public Class DBVisualStyle _
    Inherits DBObject
[WrapperAttribute(L"ZcDbVisualStyle")]
public ref class DBVisualStyle : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DBVisualStyle(IntPtr, Boolean) |
 | DBVisualStyle()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(VisualStyle) |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyTo(VisualStyle) |
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Description |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTrait(VisualStyleProperty) |
 | GetTraitFlag(VisualStyleProperty, UInt32) |
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InternalUseOnly |
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetTrait(VisualStyleProperty, Double, Double, Double, VisualStyleOperation) |
 | SetTrait(VisualStyleProperty, Int32, VisualStyleOperation) |
 | SetTrait(VisualStyleProperty, Double, VisualStyleOperation) |
 | SetTrait(VisualStyleProperty, Boolean, VisualStyleOperation) |
 | SetTrait(VisualStyleProperty, Variant, VisualStyleOperation) |
 | SetTrait(VisualStyleProperty, Color, VisualStyleOperation) |
 | SetTraitFlag(VisualStyleProperty, UInt32, Boolean) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | DBVisualStyle


DBVisualStyle Constructor

DBVisualStyle Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »DBVisualStyle()()()()
Members
Icon | Member | Description
 | DBVisualStyle(IntPtr, Boolean) |
 | DBVisualStyle()()()() |


DBVisualStyle Constructor

DBVisualStyle Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »DBVisualStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DBVisualStyle()
Public Sub New
public:
DBVisualStyle()


DBVisualStyle Constructor (unmanagedPointer, autoDelete)

DBVisualStyle Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »DBVisualStyle(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DBVisualStyle(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DBVisualStyle(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


CopyFrom Method (pSrc)

CopyFrom Method (pSrc)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »CopyFrom(VisualStyle)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyFrom(
    VisualStyle pSrc
)
Public Overridable Sub CopyFrom ( _
    pSrc As VisualStyle _
)
public:
virtual void CopyFrom(
    VisualStyle^ pSrc
)
Parameters
pSrc(VisualStyle)


CopyTo Method (pDest)

CopyTo Method (pDest)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »CopyTo(VisualStyle)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyTo(
    VisualStyle pDest
)
Public Overridable Sub CopyTo ( _
    pDest As VisualStyle _
)
public:
virtual void CopyTo(
    VisualStyle^ pDest
)
Parameters
pDest(VisualStyle)


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


GetTrait Method (vsProp)

GetTrait Method (vsProp)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »GetTrait(VisualStyleProperty)
Declaration Syntax
C# Visual Basic Visual C++
public Variant GetTrait(
    VisualStyleProperty vsProp
)
Public Function GetTrait ( _
    vsProp As VisualStyleProperty _
) As Variant
public:
Variant^ GetTrait(
    VisualStyleProperty vsProp
)
Parameters
vsProp(VisualStyleProperty)


GetTraitFlag Method (vsProp, flagValue)

GetTraitFlag Method (vsProp, flagValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »GetTraitFlag(VisualStyleProperty, UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public bool GetTraitFlag(
    VisualStyleProperty vsProp,
    uint flagValue
)
Public Function GetTraitFlag ( _
    vsProp As VisualStyleProperty, _
    flagValue As UInteger _
) As Boolean
public:
bool GetTraitFlag(
    VisualStyleProperty vsProp,
    unsigned int flagValue
)
Parameters
vsProp(VisualStyleProperty)
flagValue(UInt32)


InternalUseOnly Property

InternalUseOnly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »InternalUseOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool InternalUseOnly { get; set; }
Public Property InternalUseOnly As Boolean
    Get
    Set
public:
property bool InternalUseOnly {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


SetTrait Method

SetTrait Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »SetTrait()()()()
Members
Icon | Member | Description
 | SetTrait(VisualStyleProperty, Double, Double, Double, VisualStyleOperation) |
 | SetTrait(VisualStyleProperty, Int32, VisualStyleOperation) |
 | SetTrait(VisualStyleProperty, Double, VisualStyleOperation) |
 | SetTrait(VisualStyleProperty, Boolean, VisualStyleOperation) |
 | SetTrait(VisualStyleProperty, Variant, VisualStyleOperation) |
 | SetTrait(VisualStyleProperty, Color, VisualStyleOperation) |


SetTrait Method (vsProp, bVal, vsOp)

SetTrait Method (vsProp, bVal, vsOp)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »SetTrait(VisualStyleProperty, Boolean, VisualStyleOperation)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrait(
    VisualStyleProperty vsProp,
    bool bVal,
    VisualStyleOperation vsOp
)
Public Sub SetTrait ( _
    vsProp As VisualStyleProperty, _
    bVal As Boolean, _
    vsOp As VisualStyleOperation _
)
public:
void SetTrait(
    VisualStyleProperty vsProp,
    bool bVal,
    VisualStyleOperation vsOp
)
Parameters
vsProp(VisualStyleProperty)
bVal(Boolean)
vsOp(VisualStyleOperation)


SetTrait Method (vsProp, red, green, blue, vsOp)

SetTrait Method (vsProp, red, green, blue, vsOp)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »SetTrait(VisualStyleProperty, Double, Double, Double, VisualStyleOperation)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrait(
    VisualStyleProperty vsProp,
    double red,
    double green,
    double blue,
    VisualStyleOperation vsOp
)
Public Sub SetTrait ( _
    vsProp As VisualStyleProperty, _
    red As Double, _
    green As Double, _
    blue As Double, _
    vsOp As VisualStyleOperation _
)
public:
void SetTrait(
    VisualStyleProperty vsProp,
    double red,
    double green,
    double blue,
    VisualStyleOperation vsOp
)
Parameters
vsProp(VisualStyleProperty)
red(Double)
green(Double)
blue(Double)
vsOp(VisualStyleOperation)


SetTrait Method (vsProp, dVal, vsOp)

SetTrait Method (vsProp, dVal, vsOp)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »SetTrait(VisualStyleProperty, Double, VisualStyleOperation)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrait(
    VisualStyleProperty vsProp,
    double dVal,
    VisualStyleOperation vsOp
)
Public Sub SetTrait ( _
    vsProp As VisualStyleProperty, _
    dVal As Double, _
    vsOp As VisualStyleOperation _
)
public:
void SetTrait(
    VisualStyleProperty vsProp,
    double dVal,
    VisualStyleOperation vsOp
)
Parameters
vsProp(VisualStyleProperty)
dVal(Double)
vsOp(VisualStyleOperation)


SetTrait Method (vsProp, nVal, vsOp)

SetTrait Method (vsProp, nVal, vsOp)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »SetTrait(VisualStyleProperty, Int32, VisualStyleOperation)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrait(
    VisualStyleProperty vsProp,
    int nVal,
    VisualStyleOperation vsOp
)
Public Sub SetTrait ( _
    vsProp As VisualStyleProperty, _
    nVal As Integer, _
    vsOp As VisualStyleOperation _
)
public:
void SetTrait(
    VisualStyleProperty vsProp,
    int nVal,
    VisualStyleOperation vsOp
)
Parameters
vsProp(VisualStyleProperty)
nVal(Int32)
vsOp(VisualStyleOperation)


SetTrait Method (vsProp, color, vsOp)

SetTrait Method (vsProp, color, vsOp)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »SetTrait(VisualStyleProperty, Color, VisualStyleOperation)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrait(
    VisualStyleProperty vsProp,
    Color color,
    VisualStyleOperation vsOp
)
Public Sub SetTrait ( _
    vsProp As VisualStyleProperty, _
    color As Color, _
    vsOp As VisualStyleOperation _
)
public:
void SetTrait(
    VisualStyleProperty vsProp,
    Color^ color,
    VisualStyleOperation vsOp
)
Parameters
vsProp(VisualStyleProperty)
color(Color)
vsOp(VisualStyleOperation)


SetTrait Method (vsProp, val, vsOp)

SetTrait Method (vsProp, val, vsOp)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »SetTrait(VisualStyleProperty, Variant, VisualStyleOperation)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrait(
    VisualStyleProperty vsProp,
    Variant val,
    VisualStyleOperation vsOp
)
Public Sub SetTrait ( _
    vsProp As VisualStyleProperty, _
    val As Variant, _
    vsOp As VisualStyleOperation _
)
public:
void SetTrait(
    VisualStyleProperty vsProp,
    Variant^ val,
    VisualStyleOperation vsOp
)
Parameters
vsProp(VisualStyleProperty)
val(Variant)
vsOp(VisualStyleOperation)


SetTraitFlag Method (vsProp, flagVal, bEnable)

SetTraitFlag Method (vsProp, flagVal, bEnable)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »SetTraitFlag(VisualStyleProperty, UInt32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTraitFlag(
    VisualStyleProperty vsProp,
    uint flagVal,
    bool bEnable
)
Public Sub SetTraitFlag ( _
    vsProp As VisualStyleProperty, _
    flagVal As UInteger, _
    bEnable As Boolean _
)
public:
void SetTraitFlag(
    VisualStyleProperty vsProp,
    unsigned int flagVal,
    bool bEnable
)
Parameters
vsProp(VisualStyleProperty)
flagVal(UInt32)
bEnable(Boolean)


Type Property

Type Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »Type
Declaration Syntax
C# Visual Basic Visual C++
public VisualStyleType Type { get; set; }
Public Property Type As VisualStyleType
    Get
    Set
public:
property VisualStyleType Type {
    VisualStyleType get ();
    void set (VisualStyleType value);
}


DecomposeForSaveReplacementRecord Structure

DecomposeForSaveReplacementRecord Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DecomposeForSaveReplacementRecord
Declaration Syntax
C# Visual Basic Visual C++
public struct DecomposeForSaveReplacementRecord
Public Structure DecomposeForSaveReplacementRecord
public value class DecomposeForSaveReplacementRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DecomposeForSaveReplacementRecord(ObjectId, Boolean) |
 | DecomposeForSaveReplacementRecord(DBObject, Boolean) |
 | Equals(Object) | (Inherited from ValueType.)
 | ExchangeXData |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReplacementId |
 | ReplacementObject |
 | ToString()()()() | (Inherited from ValueType.)


DecomposeForSaveReplacementRecord Constructor

DecomposeForSaveReplacementRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DecomposeForSaveReplacementRecord »DecomposeForSaveReplacementRecord()()()()
Members
Icon | Member | Description
 | DecomposeForSaveReplacementRecord(ObjectId, Boolean) |
 | DecomposeForSaveReplacementRecord(DBObject, Boolean) |


DecomposeForSaveReplacementRecord Constructor (replacement, exchangeXData)

DecomposeForSaveReplacementRecord Constructor (replacement, exchangeXData)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DecomposeForSaveReplacementRecord »DecomposeForSaveReplacementRecord(DBObject, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DecomposeForSaveReplacementRecord(
    DBObject replacement,
    bool exchangeXData
)
Public Sub New ( _
    replacement As DBObject, _
    exchangeXData As Boolean _
)
public:
DecomposeForSaveReplacementRecord(
    DBObject^ replacement,
    bool exchangeXData
)
Parameters
replacement(DBObject)
exchangeXData(Boolean)


DecomposeForSaveReplacementRecord Constructor (replacement, exchangeXData)

DecomposeForSaveReplacementRecord Constructor (replacement, exchangeXData)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DecomposeForSaveReplacementRecord »DecomposeForSaveReplacementRecord(ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DecomposeForSaveReplacementRecord(
    ObjectId replacement,
    bool exchangeXData
)
Public Sub New ( _
    replacement As ObjectId, _
    exchangeXData As Boolean _
)
public:
DecomposeForSaveReplacementRecord(
    ObjectId replacement,
    bool exchangeXData
)
Parameters
replacement(ObjectId)
exchangeXData(Boolean)


ExchangeXData Property

ExchangeXData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DecomposeForSaveReplacementRecord »ExchangeXData
Declaration Syntax
C# Visual Basic Visual C++
public bool ExchangeXData { get; }
Public ReadOnly Property ExchangeXData As Boolean
    Get
public:
property bool ExchangeXData {
    bool get ();
}


ReplacementId Property

ReplacementId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DecomposeForSaveReplacementRecord »ReplacementId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ReplacementId { get; }
Public ReadOnly Property ReplacementId As ObjectId
    Get
public:
property ObjectId ReplacementId {
    ObjectId get ();
}


ReplacementObject Property

ReplacementObject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DecomposeForSaveReplacementRecord »ReplacementObject
Declaration Syntax
C# Visual Basic Visual C++
public DBObject ReplacementObject { get; }
Public ReadOnly Property ReplacementObject As DBObject
    Get
public:
property DBObject^ ReplacementObject {
    DBObject^ get ();
}


DeepCloneType Enumeration

DeepCloneType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DeepCloneType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::DeepCloneType")]
public enum DeepCloneType
<WrapperAttribute("ZcDb::DeepCloneType")> _
Public Enumeration DeepCloneType
[WrapperAttribute(L"ZcDb::DeepCloneType")]
public enum class DeepCloneType
Members
Member | Description
WblockObjects |
InsertCopy |
XrefInsert |
Objects |
Wblock |
SymbolTableMerge |
XrefBind |
Explode |
Insert |
Copy |
Block |


DefaultLightingType Enumeration

DefaultLightingType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DefaultLightingType
Declaration Syntax
C# Visual Basic Visual C++
public enum DefaultLightingType
Public Enumeration DefaultLightingType
public enum class DefaultLightingType
Members
Member | Description
TwoDistantLights |
OneDistantLight |


DgnDefinition Class

DgnDefinition Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDgnDefinition")]
public class DgnDefinition : UnderlayDefinition
<WrapperAttribute("AcDbDgnDefinition")> _
Public Class DgnDefinition _
    Inherits UnderlayDefinition
[WrapperAttribute(L"AcDbDgnDefinition")]
public ref class DgnDefinition : public UnderlayDefinition
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DgnDefinition()()()() |
 | DgnDefinition(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Load(String) | (Inherited from UnderlayDefinition.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetUnderlayItem(String, String, UnderlayItem) | (Inherited from UnderlayDefinition.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UnderlayItem | (Inherited from UnderlayDefinition.)
 | UndoFiler | (Inherited from DBObject.)
 | Unload()()()() | (Inherited from UnderlayDefinition.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | UnderlayDefinition
 |  |  |  |  |  |  | DgnDefinition


DgnDefinition Constructor

DgnDefinition Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition »DgnDefinition()()()()
Members
Icon | Member | Description
 | DgnDefinition()()()() |
 | DgnDefinition(IntPtr, Boolean) |


DgnDefinition Constructor

DgnDefinition Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition »DgnDefinition()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DgnDefinition()
Public Sub New
public:
DgnDefinition()


DgnDefinition Constructor (unmanagedObjPtr, autoDelete)

DgnDefinition Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition »DgnDefinition(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DgnDefinition(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DgnDefinition(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


DgnReference Class

DgnReference Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDgnReference")]
public class DgnReference : UnderlayReference
<WrapperAttribute("AcDbDgnReference")> _
Public Class DgnReference _
    Inherits UnderlayReference
[WrapperAttribute(L"AcDbDgnReference")]
public ref class DgnReference : public UnderlayReference
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DgnReference(IntPtr, Boolean) |
 | DgnReference()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GenerateClipBoundaryFromPline(ObjectId) | (Inherited from UnderlayReference.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClipBoundary()()()() | (Inherited from UnderlayReference.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height | (Inherited from UnderlayReference.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Name | (Inherited from UnderlayReference.)
 | NameOfSheet | (Inherited from UnderlayReference.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | Path | (Inherited from UnderlayReference.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetClipBoundary(array<Point2d>[]()[][]) | (Inherited from UnderlayReference.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UnderlayLayerCollection | (Inherited from UnderlayReference.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width | (Inherited from UnderlayReference.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | UnderlayReference
 |  |  |  |  |  |  |  | DgnReference


DgnReference Constructor

DgnReference Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »DgnReference()()()()
Members
Icon | Member | Description
 | DgnReference(IntPtr, Boolean) |
 | DgnReference()()()() |


DgnReference Constructor

DgnReference Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »DgnReference()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DgnReference()
Public Sub New
public:
DgnReference()


DgnReference Constructor (unmanagedObjPtr, autoDelete)

DgnReference Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »DgnReference(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DgnReference(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DgnReference(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


DgnUnderlayItem Class

DgnUnderlayItem Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnUnderlayItem
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDgnUnderlayItem")]
public class DgnUnderlayItem : UnderlayItem
<WrapperAttribute("ZcDbDgnUnderlayItem")> _
Public Class DgnUnderlayItem _
    Inherits UnderlayItem
[WrapperAttribute(L"ZcDbDgnUnderlayItem")]
public ref class DgnUnderlayItem : public UnderlayItem
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from UnderlayItem.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Extents | (Inherited from UnderlayItem.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | (Inherited from UnderlayItem.)
 | SetShowRasterRef |
 | ShowRasterRef |
 | Thumbnail | (Inherited from UnderlayItem.)
 | ToString()()()() | (Inherited from Object.)
 | Units | (Inherited from UnderlayItem.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UseMasterUnits |
 | UsingPartialContent | (Inherited from UnderlayItem.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | UnderlayItem
 |  |  |  | DgnUnderlayItem


SetShowRasterRef Property

SetShowRasterRef Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnUnderlayItem »SetShowRasterRef
Declaration Syntax
C# Visual Basic Visual C++
public bool SetShowRasterRef { set; }
Public WriteOnly Property SetShowRasterRef As Boolean
    Set
public:
property bool SetShowRasterRef {
    void set (bool value);
}


ShowRasterRef Property

ShowRasterRef Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnUnderlayItem »ShowRasterRef
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowRasterRef { get; }
Public ReadOnly Property ShowRasterRef As Boolean
    Get
public:
property bool ShowRasterRef {
    bool get ();
}


UseMasterUnits Property

UseMasterUnits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnUnderlayItem »UseMasterUnits
Declaration Syntax
C# Visual Basic Visual C++
public bool UseMasterUnits { get; set; }
Public Property UseMasterUnits As Boolean
    Get
    Set
public:
property bool UseMasterUnits {
    bool get ();
    void set (bool value);
}


DiametricDimension Class

DiametricDimension Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDiametricDimension")]
public class DiametricDimension : Dimension
<WrapperAttribute("AcDbDiametricDimension")> _
Public Class DiametricDimension _
    Inherits Dimension
[WrapperAttribute(L"AcDbDiametricDimension")]
public ref class DiametricDimension : public Dimension
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DiametricDimension(Point3d, Point3d, Double, String, ObjectId) |
 | DiametricDimension(IntPtr, Boolean) |
 | DiametricDimension()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlternatePrefix | (Inherited from Dimension.)
 | AlternateSuffix | (Inherited from Dimension.)
 | AltSuppressLeadingZeros | (Inherited from Dimension.)
 | AltSuppressTrailingZeros | (Inherited from Dimension.)
 | AltSuppressZeroFeet | (Inherited from Dimension.)
 | AltSuppressZeroInches | (Inherited from Dimension.)
 | AltToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | AltToleranceSuppressZeroInches | (Inherited from Dimension.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | CenterMarkSize | (Inherited from Dimension.)
 | CenterMarkType | (Inherited from Dimension.)
 | ChordPoint |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec | (Inherited from Dimension.)
 | Dimalt | (Inherited from Dimension.)
 | Dimaltd | (Inherited from Dimension.)
 | Dimaltf | (Inherited from Dimension.)
 | Dimaltrnd | (Inherited from Dimension.)
 | Dimalttd | (Inherited from Dimension.)
 | Dimalttz | (Inherited from Dimension.)
 | Dimaltu | (Inherited from Dimension.)
 | Dimaltz | (Inherited from Dimension.)
 | Dimapost | (Inherited from Dimension.)
 | Dimarcsym | (Inherited from Dimension.)
 | Dimasz | (Inherited from Dimension.)
 | Dimatfit | (Inherited from Dimension.)
 | Dimaunit | (Inherited from Dimension.)
 | Dimazin | (Inherited from Dimension.)
 | Dimblk | (Inherited from Dimension.)
 | Dimblk1 | (Inherited from Dimension.)
 | Dimblk1s | (Inherited from Dimension.)
 | Dimblk2 | (Inherited from Dimension.)
 | Dimblk2s | (Inherited from Dimension.)
 | Dimblks | (Inherited from Dimension.)
 | DimBlockId | (Inherited from Dimension.)
 | DimBlockPosition | (Inherited from Dimension.)
 | Dimcen | (Inherited from Dimension.)
 | Dimclrd | (Inherited from Dimension.)
 | Dimclre | (Inherited from Dimension.)
 | Dimclrt | (Inherited from Dimension.)
 | Dimdec | (Inherited from Dimension.)
 | Dimdle | (Inherited from Dimension.)
 | Dimdli | (Inherited from Dimension.)
 | Dimdsep | (Inherited from Dimension.)
 | DimensionStyle | (Inherited from Dimension.)
 | DimensionStyleName | (Inherited from Dimension.)
 | DimensionText | (Inherited from Dimension.)
 | Dimexe | (Inherited from Dimension.)
 | Dimexo | (Inherited from Dimension.)
 | Dimfrac | (Inherited from Dimension.)
 | Dimfxlen | (Inherited from Dimension.)
 | DimfxlenOn | (Inherited from Dimension.)
 | Dimgap | (Inherited from Dimension.)
 | Dimjogang | (Inherited from Dimension.)
 | Dimjust | (Inherited from Dimension.)
 | Dimldrblk | (Inherited from Dimension.)
 | Dimldrblks | (Inherited from Dimension.)
 | Dimlfac | (Inherited from Dimension.)
 | Dimlim | (Inherited from Dimension.)
 | Dimltex1 | (Inherited from Dimension.)
 | Dimltex2 | (Inherited from Dimension.)
 | Dimltype | (Inherited from Dimension.)
 | Dimlunit | (Inherited from Dimension.)
 | Dimlwd | (Inherited from Dimension.)
 | Dimlwe | (Inherited from Dimension.)
 | Dimpost | (Inherited from Dimension.)
 | Dimrnd | (Inherited from Dimension.)
 | Dimsah | (Inherited from Dimension.)
 | Dimscale | (Inherited from Dimension.)
 | Dimsd1 | (Inherited from Dimension.)
 | Dimsd2 | (Inherited from Dimension.)
 | Dimse1 | (Inherited from Dimension.)
 | Dimse2 | (Inherited from Dimension.)
 | Dimsoxd | (Inherited from Dimension.)
 | DimstyleData | (Inherited from Dimension.)
 | Dimtad | (Inherited from Dimension.)
 | Dimtdec | (Inherited from Dimension.)
 | Dimtfac | (Inherited from Dimension.)
 | Dimtfill | (Inherited from Dimension.)
 | Dimtfillclr | (Inherited from Dimension.)
 | Dimtih | (Inherited from Dimension.)
 | Dimtix | (Inherited from Dimension.)
 | Dimtm | (Inherited from Dimension.)
 | Dimtmove | (Inherited from Dimension.)
 | Dimtofl | (Inherited from Dimension.)
 | Dimtoh | (Inherited from Dimension.)
 | Dimtol | (Inherited from Dimension.)
 | Dimtolj | (Inherited from Dimension.)
 | Dimtp | (Inherited from Dimension.)
 | Dimtsz | (Inherited from Dimension.)
 | Dimtvp | (Inherited from Dimension.)
 | Dimtxsty | (Inherited from Dimension.)
 | Dimtxt | (Inherited from Dimension.)
 | Dimtzin | (Inherited from Dimension.)
 | Dimupt | (Inherited from Dimension.)
 | Dimzin | (Inherited from Dimension.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicDimension | (Inherited from Dimension.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation | (Inherited from Dimension.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FarChordPoint |
 | FieldFromMText(MText) | (Inherited from Dimension.)
 | FieldToMText(MText) | (Inherited from Dimension.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FormatMeasurement(Double, String) | (Inherited from Dimension.)
 | GenerateLayout()()()() | (Inherited from Dimension.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetDimstyleData()()()() | (Inherited from Dimension.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalRotation | (Inherited from Dimension.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | LeaderLength |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | Measurement | (Inherited from Dimension.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal | (Inherited from Dimension.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Prefix | (Inherited from Dimension.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeDimensionBlock(Boolean) | (Inherited from Dimension.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveTextField()()()() | (Inherited from Dimension.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) | (Inherited from Dimension.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | Suffix | (Inherited from Dimension.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressAngularLeadingZeros | (Inherited from Dimension.)
 | SuppressAngularTrailingZeros | (Inherited from Dimension.)
 | SuppressLeadingZeros | (Inherited from Dimension.)
 | SuppressTrailingZeros | (Inherited from Dimension.)
 | SuppressZeroFeet | (Inherited from Dimension.)
 | SuppressZeroInches | (Inherited from Dimension.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAttachment | (Inherited from Dimension.)
 | TextLineSpacingFactor | (Inherited from Dimension.)
 | TextLineSpacingStyle | (Inherited from Dimension.)
 | TextPosition | (Inherited from Dimension.)
 | TextRotation | (Inherited from Dimension.)
 | TextStyleId | (Inherited from Dimension.)
 | ToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | ToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | ToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | ToleranceSuppressZeroInches | (Inherited from Dimension.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UsingDefaultTextPosition | (Inherited from Dimension.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  |  | DiametricDimension


DiametricDimension Constructor

DiametricDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »DiametricDimension()()()()
Members
Icon | Member | Description
 | DiametricDimension(Point3d, Point3d, Double, String, ObjectId) |
 | DiametricDimension(IntPtr, Boolean) |
 | DiametricDimension()()()() |


DiametricDimension Constructor

DiametricDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »DiametricDimension()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DiametricDimension()
Public Sub New
public:
DiametricDimension()


DiametricDimension Constructor (unmanagedObjPtr, autoDelete)

DiametricDimension Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »DiametricDimension(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DiametricDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DiametricDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


DiametricDimension Constructor (chordPoint, farChordPoint, leaderLength, dimensionText, dimensionStyle)

DiametricDimension Constructor (chordPoint, farChordPoint, leaderLength, dimensionText, dimensionStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »DiametricDimension(Point3d, Point3d, Double, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public DiametricDimension(
    Point3d chordPoint,
    Point3d farChordPoint,
    double leaderLength,
    string dimensionText,
    ObjectId dimensionStyle
)
Public Sub New ( _
    chordPoint As Point3d, _
    farChordPoint As Point3d, _
    leaderLength As Double, _
    dimensionText As String, _
    dimensionStyle As ObjectId _
)
public:
DiametricDimension(
    Point3d chordPoint,
    Point3d farChordPoint,
    double leaderLength,
    String^ dimensionText,
    ObjectId dimensionStyle
)
Parameters
chordPoint(Point3d)
farChordPoint(Point3d)
leaderLength(Double)
dimensionText(String)
dimensionStyle(ObjectId)


ChordPoint Property

ChordPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »ChordPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ChordPoint { get; set; }
Public Property ChordPoint As Point3d
    Get
    Set
public:
property Point3d ChordPoint {
    Point3d get ();
    void set (Point3d value);
}


FarChordPoint Property

FarChordPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »FarChordPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d FarChordPoint { get; set; }
Public Property FarChordPoint As Point3d
    Get
    Set
public:
property Point3d FarChordPoint {
    Point3d get ();
    void set (Point3d value);
}


LeaderLength Property

LeaderLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »LeaderLength
Declaration Syntax
C# Visual Basic Visual C++
public double LeaderLength { get; set; }
Public Property LeaderLength As Double
    Get
    Set
public:
property double LeaderLength {
    double get ();
    void set (double value);
}


DictionaryWithDefaultDictionary Class

DictionaryWithDefaultDictionary Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDictionaryWithDefault")]
public class DictionaryWithDefaultDictionary : DBDictionary
<WrapperAttribute("AcDbDictionaryWithDefault")> _
Public Class DictionaryWithDefaultDictionary _
    Inherits DBDictionary
[WrapperAttribute(L"AcDbDictionaryWithDefault")]
public ref class DictionaryWithDefaultDictionary : public DBDictionary
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DictionaryWithDefaultDictionary()()()() |
 | DictionaryWithDefaultDictionary(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Contains(String) | (Inherited from DBDictionary.)
 | Contains(ObjectId) | (Inherited from DBDictionary.)
 | Copied | (Inherited from DBObject.)
 | Copy()()()() | (Inherited from DBDictionary.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyTo(array<DBDictionaryEntry>[]()[][], Int32) | (Inherited from DBDictionary.)
 | Count | (Inherited from DBDictionary.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DefaultId |
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAt(String) | (Inherited from DBDictionary.)
 | GetEnumerator()()()() | (Inherited from DBDictionary.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | ICollection_CopyTo(Array, Int32) | (Inherited from DBDictionary.)
 | Id | (Inherited from DBObject.)
 | IDictionary_Add(Object, Object) | (Inherited from DBDictionary.)
 | IDictionary_Clear()()()() | (Inherited from DBDictionary.)
 | IDictionary_Contains(Object) | (Inherited from DBDictionary.)
 | IDictionary_GetEnumerator()()()() | (Inherited from DBDictionary.)
 | IDictionary_IsFixedSize | (Inherited from DBDictionary.)
 | IDictionary_IsReadOnly | (Inherited from DBDictionary.)
 | IDictionary_IsSynchronized | (Inherited from DBDictionary.)
 | IDictionary_Item[([( Object])]) | (Inherited from DBDictionary.)
 | IDictionary_Keys | (Inherited from DBDictionary.)
 | IDictionary_Remove(Object) | (Inherited from DBDictionary.)
 | IDictionary_SyncRoot | (Inherited from DBDictionary.)
 | IDictionary_Values | (Inherited from DBDictionary.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from DBDictionary.)
 | IncludingErased | (Inherited from DBDictionary.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsFixedSize | (Inherited from DBDictionary.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReadOnly | (Inherited from DBDictionary.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsSynchronized | (Inherited from DBDictionary.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from DBDictionary.)
 | Keys | (Inherited from DBDictionary.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBDictionary.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | NameAt(ObjectId) | (Inherited from DBDictionary.)
 | ObjectBirthVersion | (Overrides DBObject.ObjectBirthVersion.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | Remove(String) | (Inherited from DBDictionary.)
 | Remove(ObjectId) | (Inherited from DBDictionary.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAt(String, DBObject) | (Inherited from DBDictionary.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetName(String, String) | (Inherited from DBDictionary.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SkipDeleted | (Inherited from DBDictionary.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | SyncRoot | (Inherited from DBDictionary.)
 | ToString()()()() | (Inherited from Object.)
 | TreatElementsAsHard | (Inherited from DBDictionary.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | Values | (Inherited from DBDictionary.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | DBDictionary
 |  |  |  |  |  |  | DictionaryWithDefaultDictionary


DictionaryWithDefaultDictionary Constructor

DictionaryWithDefaultDictionary Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »DictionaryWithDefaultDictionary()()()()
Members
Icon | Member | Description
 | DictionaryWithDefaultDictionary()()()() |
 | DictionaryWithDefaultDictionary(IntPtr, Boolean) |


DictionaryWithDefaultDictionary Constructor

DictionaryWithDefaultDictionary Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »DictionaryWithDefaultDictionary()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DictionaryWithDefaultDictionary()
Public Sub New
public:
DictionaryWithDefaultDictionary()


DictionaryWithDefaultDictionary Constructor (unmanagedPointer, autoDelete)

DictionaryWithDefaultDictionary Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »DictionaryWithDefaultDictionary(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DictionaryWithDefaultDictionary(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DictionaryWithDefaultDictionary(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DefaultId Property

DefaultId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »DefaultId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId DefaultId { get; set; }
Public Property DefaultId As ObjectId
    Get
    Set
public:
property ObjectId DefaultId {
    ObjectId get ();
    void set (ObjectId value);
}


ObjectBirthVersion Property

ObjectBirthVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »ObjectBirthVersion
Declaration Syntax
C# Visual Basic Visual C++
public override FullDwgVersion ObjectBirthVersion { get; }
Public Overrides ReadOnly Property ObjectBirthVersion As FullDwgVersion
    Get
public:
virtual property FullDwgVersion ObjectBirthVersion {
    FullDwgVersion get () override;
}


DimArrowFlag Enumeration

DimArrowFlag Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimArrowFlag
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("DimArrowFlags")]
public enum DimArrowFlag
<WrapperAttribute("DimArrowFlags")> _
Public Enumeration DimArrowFlag
[WrapperAttribute(L"DimArrowFlags")]
public enum class DimArrowFlag
Members
Member | Description
SecondArrow |
FirstArrow |


DimAssoc Class

DimAssoc Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDimAssoc")]
public sealed class DimAssoc : DBObject
<WrapperAttribute("AcDbDimAssoc")> _
Public NotInheritable Class DimAssoc _
    Inherits DBObject
[WrapperAttribute(L"AcDbDimAssoc")]
public ref class DimAssoc sealed : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DimAssoc()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddToDimensionReactor(Boolean) |
 | AddToDimensionReactor()()()() |
 | AddToPointRefReactor()()()() |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | AssocFlag |
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied(DBObject, DBObject) |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DimObjId |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased(DBObject) |
 | Erased(DBObject, Boolean) |
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetDimAssocGeomIds(ObjectIdCollection) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAllGeomErased()()()() |
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedGraphics(DBObject) |
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify(DBObject) |
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PointRef(DimAssocPointType) |
 | Post(ObjectId, ObjectId, Boolean) |
 | Post(ObjectId, ObjectId) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveAssociativity(Boolean) |
 | RemoveAssociativity()()()() |
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemovePointRef(Boolean) |
 | RemovePointRef()()()() |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | RotatedType |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPointRef(DimAssocPointType, OsnapPointRef) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransSpatial |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateDimension(Boolean, Boolean) |
 | UpdateDimension(Boolean) |
 | UpdateDimension()()()() |
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | DimAssoc


DimAssoc Constructor

DimAssoc Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »DimAssoc()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DimAssoc()
Public Sub New
public:
DimAssoc()


AddToDimensionReactor Method

AddToDimensionReactor Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »AddToDimensionReactor()()()()
Members
Icon | Member | Description
 | AddToDimensionReactor(Boolean) |
 | AddToDimensionReactor()()()() |


AddToDimensionReactor Method

AddToDimensionReactor Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »AddToDimensionReactor()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void AddToDimensionReactor()
Public Sub AddToDimensionReactor
public:
void AddToDimensionReactor()


AddToDimensionReactor Method (isAdd)

AddToDimensionReactor Method (isAdd)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »AddToDimensionReactor(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void AddToDimensionReactor(
    bool isAdd
)
Public Sub AddToDimensionReactor ( _
    isAdd As Boolean _
)
public:
void AddToDimensionReactor(
    bool isAdd
)
Parameters
isAdd(Boolean)


AddToPointRefReactor Method

AddToPointRefReactor Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »AddToPointRefReactor()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void AddToPointRefReactor()
Public Sub AddToPointRefReactor
public:
void AddToPointRefReactor()


AssocFlag Property

AssocFlag Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »AssocFlag
Declaration Syntax
C# Visual Basic Visual C++
public AssocFlags AssocFlag { get; }
Public ReadOnly Property AssocFlag As AssocFlags
    Get
public:
property AssocFlags AssocFlag {
    AssocFlags get ();
}


Copied Method (pObj, pNewObj)

Copied Method (pObj, pNewObj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »Copied(DBObject, DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public void Copied(
    DBObject pObj,
    DBObject pNewObj
)
Public Sub Copied ( _
    pObj As DBObject, _
    pNewObj As DBObject _
)
public:
void Copied(
    DBObject^ pObj,
    DBObject^ pNewObj
)
Parameters
pObj(DBObject)
pNewObj(DBObject)


DimObjId Property

DimObjId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »DimObjId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId DimObjId { get; set; }
Public Property DimObjId As ObjectId
    Get
    Set
public:
property ObjectId DimObjId {
    ObjectId get ();
    void set (ObjectId value);
}


Erased Method

Erased Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »Erased()()()()
Members
Icon | Member | Description
 | Erased(DBObject) |
 | Erased(DBObject, Boolean) |
 | Erased |


Erased Method (pObj)

Erased Method (pObj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »Erased(DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public void Erased(
    DBObject pObj
)
Public Sub Erased ( _
    pObj As DBObject _
)
public:
void Erased(
    DBObject^ pObj
)
Parameters
pObj(DBObject)


Erased Method (pObj, erasing)

Erased Method (pObj, erasing)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »Erased(DBObject, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void Erased(
    DBObject pObj,
    bool erasing
)
Public Sub Erased ( _
    pObj As DBObject, _
    erasing As Boolean _
)
public:
void Erased(
    DBObject^ pObj,
    bool erasing
)
Parameters
pObj(DBObject)
erasing(Boolean)


GetDimAssocGeomIds Method (geomIds)

GetDimAssocGeomIds Method (geomIds)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »GetDimAssocGeomIds(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void GetDimAssocGeomIds(
    ObjectIdCollection geomIds
)
Public Sub GetDimAssocGeomIds ( _
    geomIds As ObjectIdCollection _
)
public:
void GetDimAssocGeomIds(
    ObjectIdCollection^ geomIds
)
Parameters
geomIds(ObjectIdCollection)


IsAllGeomErased Method

IsAllGeomErased Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »IsAllGeomErased()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAllGeomErased()
Public Function IsAllGeomErased As Boolean
public:
bool IsAllGeomErased()


ModifiedGraphics Method (pObj)

ModifiedGraphics Method (pObj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »ModifiedGraphics(DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public void ModifiedGraphics(
    DBObject pObj
)
Public Sub ModifiedGraphics ( _
    pObj As DBObject _
)
public:
void ModifiedGraphics(
    DBObject^ pObj
)
Parameters
pObj(DBObject)


OpenedForModify Method (pObject)

OpenedForModify Method (pObject)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »OpenedForModify(DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public void OpenedForModify(
    DBObject pObject
)
Public Sub OpenedForModify ( _
    pObject As DBObject _
)
public:
void OpenedForModify(
    DBObject^ pObject
)
Parameters
pObject(DBObject)


PointRef Method (pointIndex)

PointRef Method (pointIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »PointRef(DimAssocPointType)
Declaration Syntax
C# Visual Basic Visual C++
public OsnapPointRef PointRef(
    DimAssocPointType pointIndex
)
Public Function PointRef ( _
    pointIndex As DimAssocPointType _
) As OsnapPointRef
public:
OsnapPointRef^ PointRef(
    DimAssocPointType pointIndex
)
Parameters
pointIndex(DimAssocPointType)


Post Method

Post Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »Post()()()()
Members
Icon | Member | Description
 | Post(ObjectId, ObjectId, Boolean) |
 | Post(ObjectId, ObjectId) |


Post Method (dimId, dimAssocId)

Post Method (dimId, dimAssocId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »Post(ObjectId, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Post(
    ObjectId dimId,
    ObjectId dimAssocId
)
Public Sub Post ( _
    dimId As ObjectId, _
    dimAssocId As ObjectId _
)
public:
void Post(
    ObjectId dimId,
    ObjectId dimAssocId
)
Parameters
dimId(ObjectId)
dimAssocId(ObjectId)


Post Method (dimId, dimAssocId, isActive)

Post Method (dimId, dimAssocId, isActive)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »Post(ObjectId, ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void Post(
    ObjectId dimId,
    ObjectId dimAssocId,
    bool isActive
)
Public Sub Post ( _
    dimId As ObjectId, _
    dimAssocId As ObjectId, _
    isActive As Boolean _
)
public:
void Post(
    ObjectId dimId,
    ObjectId dimAssocId,
    bool isActive
)
Parameters
dimId(ObjectId)
dimAssocId(ObjectId)
isActive(Boolean)


RemoveAssociativity Method

RemoveAssociativity Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »RemoveAssociativity()()()()
Members
Icon | Member | Description
 | RemoveAssociativity(Boolean) |
 | RemoveAssociativity()()()() |


RemoveAssociativity Method

RemoveAssociativity Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »RemoveAssociativity()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAssociativity()
Public Sub RemoveAssociativity
public:
void RemoveAssociativity()


RemoveAssociativity Method (force)

RemoveAssociativity Method (force)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »RemoveAssociativity(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAssociativity(
    bool force
)
Public Sub RemoveAssociativity ( _
    force As Boolean _
)
public:
void RemoveAssociativity(
    bool force
)
Parameters
force(Boolean)


RemovePointRef Method

RemovePointRef Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »RemovePointRef()()()()
Members
Icon | Member | Description
 | RemovePointRef(Boolean) |
 | RemovePointRef()()()() |


RemovePointRef Method

RemovePointRef Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »RemovePointRef()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RemovePointRef()
Public Sub RemovePointRef
public:
void RemovePointRef()


RemovePointRef Method (force)

RemovePointRef Method (force)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »RemovePointRef(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void RemovePointRef(
    bool force
)
Public Sub RemovePointRef ( _
    force As Boolean _
)
public:
void RemovePointRef(
    bool force
)
Parameters
force(Boolean)


RotatedType Property

RotatedType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »RotatedType
Declaration Syntax
C# Visual Basic Visual C++
public RotatedDimType RotatedType { get; set; }
Public Property RotatedType As RotatedDimType
    Get
    Set
public:
property RotatedDimType RotatedType {
    RotatedDimType get ();
    void set (RotatedDimType value);
}


SetPointRef Method (pointIndex, pOsnapPointRef)

SetPointRef Method (pointIndex, pOsnapPointRef)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »SetPointRef(DimAssocPointType, OsnapPointRef)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPointRef(
    DimAssocPointType pointIndex,
    OsnapPointRef pOsnapPointRef
)
Public Sub SetPointRef ( _
    pointIndex As DimAssocPointType, _
    pOsnapPointRef As OsnapPointRef _
)
public:
void SetPointRef(
    DimAssocPointType pointIndex,
    OsnapPointRef^ pOsnapPointRef
)
Parameters
pointIndex(DimAssocPointType)
pOsnapPointRef(OsnapPointRef)


TransSpatial Property

TransSpatial Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »TransSpatial
Declaration Syntax
C# Visual Basic Visual C++
public bool TransSpatial { get; set; }
Public Property TransSpatial As Boolean
    Get
    Set
public:
property bool TransSpatial {
    bool get ();
    void set (bool value);
}


UpdateDimension Method

UpdateDimension Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »UpdateDimension()()()()
Members
Icon | Member | Description
 | UpdateDimension(Boolean, Boolean) |
 | UpdateDimension(Boolean) |
 | UpdateDimension()()()() |


UpdateDimension Method

UpdateDimension Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »UpdateDimension()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateDimension()
Public Sub UpdateDimension
public:
void UpdateDimension()


UpdateDimension Method (update)

UpdateDimension Method (update)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »UpdateDimension(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateDimension(
    bool update
)
Public Sub UpdateDimension ( _
    update As Boolean _
)
public:
void UpdateDimension(
    bool update
)
Parameters
update(Boolean)


UpdateDimension Method (update, skipReactors)

UpdateDimension Method (update, skipReactors)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »UpdateDimension(Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateDimension(
    bool update,
    bool skipReactors
)
Public Sub UpdateDimension ( _
    update As Boolean, _
    skipReactors As Boolean _
)
public:
void UpdateDimension(
    bool update,
    bool skipReactors
)
Parameters
update(Boolean)
skipReactors(Boolean)


DimAssocPointType Enumeration

DimAssocPointType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssocPointType
Declaration Syntax
C# Visual Basic Visual C++
public enum DimAssocPointType
Public Enumeration DimAssocPointType
public enum class DimAssocPointType
Members
Member | Description
LeaderPoint |
AngLineEnd |
JogPoint |
AngLineStart |
OverrideCenterPoint |
FarChordPoint |
CenterPoint |
ChordPoint |
VertexPoint |
Xline2End |
Xline2Start |
Xline1End |
Xline1Start |
DefiningPoint |
OriginPoint |
Xline2Point |
Xline1Point |


Dimension Class

Dimension Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDimension")]
public abstract class Dimension : Entity
<WrapperAttribute("AcDbDimension")> _
Public MustInherit Class Dimension _
    Inherits Entity
[WrapperAttribute(L"AcDbDimension")]
public ref class Dimension abstract : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Dimension(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlternatePrefix |
 | AlternateSuffix |
 | AltSuppressLeadingZeros |
 | AltSuppressTrailingZeros |
 | AltSuppressZeroFeet |
 | AltSuppressZeroInches |
 | AltToleranceSuppressLeadingZeros |
 | AltToleranceSuppressTrailingZeros |
 | AltToleranceSuppressZeroFeet |
 | AltToleranceSuppressZeroInches |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | CenterMarkSize |
 | CenterMarkType |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec |
 | Dimalt |
 | Dimaltd |
 | Dimaltf |
 | Dimaltrnd |
 | Dimalttd |
 | Dimalttz |
 | Dimaltu |
 | Dimaltz |
 | Dimapost |
 | Dimarcsym |
 | Dimasz |
 | Dimatfit |
 | Dimaunit |
 | Dimazin |
 | Dimblk |
 | Dimblk1 |
 | Dimblk1s |
 | Dimblk2 |
 | Dimblk2s |
 | Dimblks |
 | DimBlockId |
 | DimBlockPosition |
 | Dimcen |
 | Dimclrd |
 | Dimclre |
 | Dimclrt |
 | Dimdec |
 | Dimdle |
 | Dimdli |
 | Dimdsep |
 | DimensionStyle |
 | DimensionStyleName |
 | DimensionText |
 | Dimexe |
 | Dimexo |
 | Dimfrac |
 | Dimfxlen |
 | DimfxlenOn |
 | Dimgap |
 | Dimjogang |
 | Dimjust |
 | Dimldrblk |
 | Dimldrblks |
 | Dimlfac |
 | Dimlim |
 | Dimltex1 |
 | Dimltex2 |
 | Dimltype |
 | Dimlunit |
 | Dimlwd |
 | Dimlwe |
 | Dimpost |
 | Dimrnd |
 | Dimsah |
 | Dimscale |
 | Dimsd1 |
 | Dimsd2 |
 | Dimse1 |
 | Dimse2 |
 | Dimsoxd |
 | DimstyleData |
 | Dimtad |
 | Dimtdec |
 | Dimtfac |
 | Dimtfill |
 | Dimtfillclr |
 | Dimtih |
 | Dimtix |
 | Dimtm |
 | Dimtmove |
 | Dimtofl |
 | Dimtoh |
 | Dimtol |
 | Dimtolj |
 | Dimtp |
 | Dimtsz |
 | Dimtvp |
 | Dimtxsty |
 | Dimtxt |
 | Dimtzin |
 | Dimupt |
 | Dimzin |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicDimension |
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation |
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldFromMText(MText) |
 | FieldToMText(MText) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FormatMeasurement(Double, String) |
 | GenerateLayout()()()() |
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetDimstyleData()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalRotation |
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | Measurement |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Prefix |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeDimensionBlock(Boolean) |
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveTextField()()()() |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) |
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | Suffix |
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressAngularLeadingZeros |
 | SuppressAngularTrailingZeros |
 | SuppressLeadingZeros |
 | SuppressTrailingZeros |
 | SuppressZeroFeet |
 | SuppressZeroInches |
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAttachment |
 | TextLineSpacingFactor |
 | TextLineSpacingStyle |
 | TextPosition |
 | TextRotation |
 | TextStyleId |
 | ToleranceSuppressLeadingZeros |
 | ToleranceSuppressTrailingZeros |
 | ToleranceSuppressZeroFeet |
 | ToleranceSuppressZeroInches |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UsingDefaultTextPosition |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  |  | AlignedDimension
 |  |  |  |  |  |  |  | ArcDimension
 |  |  |  |  |  |  |  | DiametricDimension
 |  |  |  |  |  |  |  | LineAngularDimension2
 |  |  |  |  |  |  |  | OrdinateDimension
 |  |  |  |  |  |  |  | Point3AngularDimension
 |  |  |  |  |  |  |  | RadialDimension
 |  |  |  |  |  |  |  | RadialDimensionLarge
 |  |  |  |  |  |  |  | RotatedDimension


Dimension Constructor (unmanagedObjPtr, autoDelete)

Dimension Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimension(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Dimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Dimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AlternatePrefix Property

AlternatePrefix Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »AlternatePrefix
Declaration Syntax
C# Visual Basic Visual C++
public virtual string AlternatePrefix { get; set; }
Public Overridable Property AlternatePrefix As String
    Get
    Set
public:
virtual property String^ AlternatePrefix {
    String^ get ();
    void set (String^ value);
}


AlternateSuffix Property

AlternateSuffix Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »AlternateSuffix
Declaration Syntax
C# Visual Basic Visual C++
public virtual string AlternateSuffix { get; set; }
Public Overridable Property AlternateSuffix As String
    Get
    Set
public:
virtual property String^ AlternateSuffix {
    String^ get ();
    void set (String^ value);
}


AltSuppressLeadingZeros Property

AltSuppressLeadingZeros Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »AltSuppressLeadingZeros
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AltSuppressLeadingZeros { get; set; }
Public Overridable Property AltSuppressLeadingZeros As Boolean
    Get
    Set
public:
virtual property bool AltSuppressLeadingZeros {
    bool get ();
    void set (bool value);
}


AltSuppressTrailingZeros Property

AltSuppressTrailingZeros Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »AltSuppressTrailingZeros
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AltSuppressTrailingZeros { get; set; }
Public Overridable Property AltSuppressTrailingZeros As Boolean
    Get
    Set
public:
virtual property bool AltSuppressTrailingZeros {
    bool get ();
    void set (bool value);
}


AltSuppressZeroFeet Property

AltSuppressZeroFeet Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »AltSuppressZeroFeet
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AltSuppressZeroFeet { get; set; }
Public Overridable Property AltSuppressZeroFeet As Boolean
    Get
    Set
public:
virtual property bool AltSuppressZeroFeet {
    bool get ();
    void set (bool value);
}


AltSuppressZeroInches Property

AltSuppressZeroInches Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »AltSuppressZeroInches
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AltSuppressZeroInches { get; set; }
Public Overridable Property AltSuppressZeroInches As Boolean
    Get
    Set
public:
virtual property bool AltSuppressZeroInches {
    bool get ();
    void set (bool value);
}


AltToleranceSuppressLeadingZeros Property

AltToleranceSuppressLeadingZeros Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »AltToleranceSuppressLeadingZeros
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AltToleranceSuppressLeadingZeros { get; set; }
Public Overridable Property AltToleranceSuppressLeadingZeros As Boolean
    Get
    Set
public:
virtual property bool AltToleranceSuppressLeadingZeros {
    bool get ();
    void set (bool value);
}


AltToleranceSuppressTrailingZeros Property

AltToleranceSuppressTrailingZeros Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »AltToleranceSuppressTrailingZeros
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AltToleranceSuppressTrailingZeros { get; set; }
Public Overridable Property AltToleranceSuppressTrailingZeros As Boolean
    Get
    Set
public:
virtual property bool AltToleranceSuppressTrailingZeros {
    bool get ();
    void set (bool value);
}


AltToleranceSuppressZeroFeet Property

AltToleranceSuppressZeroFeet Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »AltToleranceSuppressZeroFeet
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AltToleranceSuppressZeroFeet { get; set; }
Public Overridable Property AltToleranceSuppressZeroFeet As Boolean
    Get
    Set
public:
virtual property bool AltToleranceSuppressZeroFeet {
    bool get ();
    void set (bool value);
}


AltToleranceSuppressZeroInches Property

AltToleranceSuppressZeroInches Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »AltToleranceSuppressZeroInches
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AltToleranceSuppressZeroInches { get; set; }
Public Overridable Property AltToleranceSuppressZeroInches As Boolean
    Get
    Set
public:
virtual property bool AltToleranceSuppressZeroInches {
    bool get ();
    void set (bool value);
}


CenterMarkSize Property

CenterMarkSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »CenterMarkSize
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double CenterMarkSize { get; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public ReadOnly Property CenterMarkSize As Double
    Get
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double CenterMarkSize {
    double get ();
}


CenterMarkType Property

CenterMarkType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »CenterMarkType
Declaration Syntax
C# Visual Basic Visual C++
public DimensionCenterMarkType CenterMarkType { get; }
Public ReadOnly Property CenterMarkType As DimensionCenterMarkType
    Get
public:
property DimensionCenterMarkType CenterMarkType {
    DimensionCenterMarkType get ();
}


Dimadec Property

Dimadec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimadec
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimadec { get; set; }
Public Overridable Property Dimadec As Integer
    Get
    Set
public:
virtual property int Dimadec {
    int get ();
    void set (int value);
}


Dimalt Property

Dimalt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimalt
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimalt { get; set; }
Public Overridable Property Dimalt As Boolean
    Get
    Set
public:
virtual property bool Dimalt {
    bool get ();
    void set (bool value);
}


Dimaltd Property

Dimaltd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimaltd
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimaltd { get; set; }
Public Overridable Property Dimaltd As Integer
    Get
    Set
public:
virtual property int Dimaltd {
    int get ();
    void set (int value);
}


Dimaltf Property

Dimaltf Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimaltf
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public virtual double Dimaltf { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Overridable Property Dimaltf As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
virtual property double Dimaltf {
    double get ();
    void set (double value);
}


Dimaltrnd Property

Dimaltrnd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimaltrnd
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimaltrnd { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimaltrnd As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimaltrnd {
    double get ();
    void set (double value);
}


Dimalttd Property

Dimalttd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimalttd
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimalttd { get; set; }
Public Overridable Property Dimalttd As Integer
    Get
    Set
public:
virtual property int Dimalttd {
    int get ();
    void set (int value);
}


Dimalttz Property

Dimalttz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimalttz
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimalttz { get; set; }
Public Overridable Property Dimalttz As Integer
    Get
    Set
public:
virtual property int Dimalttz {
    int get ();
    void set (int value);
}


Dimaltu Property

Dimaltu Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimaltu
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimaltu { get; set; }
Public Overridable Property Dimaltu As Integer
    Get
    Set
public:
virtual property int Dimaltu {
    int get ();
    void set (int value);
}


Dimaltz Property

Dimaltz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimaltz
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimaltz { get; set; }
Public Overridable Property Dimaltz As Integer
    Get
    Set
public:
virtual property int Dimaltz {
    int get ();
    void set (int value);
}


Dimapost Property

Dimapost Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimapost
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Dimapost { get; set; }
Public Overridable Property Dimapost As String
    Get
    Set
public:
virtual property String^ Dimapost {
    String^ get ();
    void set (String^ value);
}


Dimarcsym Property

Dimarcsym Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimarcsym
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimarcsym { get; set; }
Public Overridable Property Dimarcsym As Integer
    Get
    Set
public:
virtual property int Dimarcsym {
    int get ();
    void set (int value);
}


Dimasz Property

Dimasz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimasz
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimasz { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimasz As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimasz {
    double get ();
    void set (double value);
}


Dimatfit Property

Dimatfit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimatfit
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimatfit { get; set; }
Public Overridable Property Dimatfit As Integer
    Get
    Set
public:
virtual property int Dimatfit {
    int get ();
    void set (int value);
}


Dimaunit Property

Dimaunit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimaunit
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimaunit { get; set; }
Public Overridable Property Dimaunit As Integer
    Get
    Set
public:
virtual property int Dimaunit {
    int get ();
    void set (int value);
}


Dimazin Property

Dimazin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimazin
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimazin { get; set; }
Public Overridable Property Dimazin As Integer
    Get
    Set
public:
virtual property int Dimazin {
    int get ();
    void set (int value);
}


Dimblk Property

Dimblk Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimblk
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimblk { get; set; }
Public Overridable Property Dimblk As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimblk {
    ObjectId get ();
    void set (ObjectId value);
}


Dimblk1 Property

Dimblk1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimblk1
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimblk1 { get; set; }
Public Overridable Property Dimblk1 As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimblk1 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimblk1s Property

Dimblk1s Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimblk1s
Declaration Syntax
C# Visual Basic Visual C++
public string Dimblk1s { get; set; }
Public Property Dimblk1s As String
    Get
    Set
public:
property String^ Dimblk1s {
    String^ get ();
    void set (String^ value);
}


Dimblk2 Property

Dimblk2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimblk2
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimblk2 { get; set; }
Public Overridable Property Dimblk2 As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimblk2 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimblk2s Property

Dimblk2s Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimblk2s
Declaration Syntax
C# Visual Basic Visual C++
public string Dimblk2s { get; set; }
Public Property Dimblk2s As String
    Get
    Set
public:
property String^ Dimblk2s {
    String^ get ();
    void set (String^ value);
}


Dimblks Property

Dimblks Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimblks
Declaration Syntax
C# Visual Basic Visual C++
public string Dimblks { get; set; }
Public Property Dimblks As String
    Get
    Set
public:
property String^ Dimblks {
    String^ get ();
    void set (String^ value);
}


DimBlockId Property

DimBlockId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »DimBlockId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId DimBlockId { get; set; }
Public Property DimBlockId As ObjectId
    Get
    Set
public:
property ObjectId DimBlockId {
    ObjectId get ();
    void set (ObjectId value);
}


DimBlockPosition Property

DimBlockPosition Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »DimBlockPosition
Declaration Syntax
C# Visual Basic Visual C++
public Point3d DimBlockPosition { get; }
Public ReadOnly Property DimBlockPosition As Point3d
    Get
public:
property Point3d DimBlockPosition {
    Point3d get ();
}


Dimcen Property

Dimcen Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimcen
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimcen { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimcen As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimcen {
    double get ();
    void set (double value);
}


Dimclrd Property

Dimclrd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimclrd
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color Dimclrd { get; set; }
Public Overridable Property Dimclrd As Color
    Get
    Set
public:
virtual property Color^ Dimclrd {
    Color^ get ();
    void set (Color^ value);
}


Dimclre Property

Dimclre Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimclre
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color Dimclre { get; set; }
Public Overridable Property Dimclre As Color
    Get
    Set
public:
virtual property Color^ Dimclre {
    Color^ get ();
    void set (Color^ value);
}


Dimclrt Property

Dimclrt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimclrt
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color Dimclrt { get; set; }
Public Overridable Property Dimclrt As Color
    Get
    Set
public:
virtual property Color^ Dimclrt {
    Color^ get ();
    void set (Color^ value);
}


Dimdec Property

Dimdec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimdec
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimdec { get; set; }
Public Overridable Property Dimdec As Integer
    Get
    Set
public:
virtual property int Dimdec {
    int get ();
    void set (int value);
}


Dimdle Property

Dimdle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimdle
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimdle { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimdle As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimdle {
    double get ();
    void set (double value);
}


Dimdli Property

Dimdli Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimdli
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimdli { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimdli As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimdli {
    double get ();
    void set (double value);
}


Dimdsep Property

Dimdsep Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimdsep
Declaration Syntax
C# Visual Basic Visual C++
public virtual char Dimdsep { get; set; }
Public Overridable Property Dimdsep As Char
    Get
    Set
public:
virtual property wchar_t Dimdsep {
    wchar_t get ();
    void set (wchar_t value);
}


DimensionStyle Property

DimensionStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »DimensionStyle
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId DimensionStyle { get; set; }
Public Property DimensionStyle As ObjectId
    Get
    Set
public:
property ObjectId DimensionStyle {
    ObjectId get ();
    void set (ObjectId value);
}


DimensionStyleName Property

DimensionStyleName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »DimensionStyleName
Declaration Syntax
C# Visual Basic Visual C++
public string DimensionStyleName { get; set; }
Public Property DimensionStyleName As String
    Get
    Set
public:
property String^ DimensionStyleName {
    String^ get ();
    void set (String^ value);
}


DimensionText Property

DimensionText Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »DimensionText
Declaration Syntax
C# Visual Basic Visual C++
public string DimensionText { get; set; }
Public Property DimensionText As String
    Get
    Set
public:
property String^ DimensionText {
    String^ get ();
    void set (String^ value);
}


Dimexe Property

Dimexe Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimexe
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimexe { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimexe As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimexe {
    double get ();
    void set (double value);
}


Dimexo Property

Dimexo Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimexo
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimexo { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimexo As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimexo {
    double get ();
    void set (double value);
}


Dimfrac Property

Dimfrac Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimfrac
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimfrac { get; set; }
Public Overridable Property Dimfrac As Integer
    Get
    Set
public:
virtual property int Dimfrac {
    int get ();
    void set (int value);
}


Dimfxlen Property

Dimfxlen Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimfxlen
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimfxlen { get; set; }
Public Overridable Property Dimfxlen As Double
    Get
    Set
public:
virtual property double Dimfxlen {
    double get ();
    void set (double value);
}


DimfxlenOn Property

DimfxlenOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »DimfxlenOn
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool DimfxlenOn { get; set; }
Public Overridable Property DimfxlenOn As Boolean
    Get
    Set
public:
virtual property bool DimfxlenOn {
    bool get ();
    void set (bool value);
}


Dimgap Property

Dimgap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimgap
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimgap { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimgap As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimgap {
    double get ();
    void set (double value);
}


Dimjogang Property

Dimjogang Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimjogang
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.AngleNotTransformed)]
public virtual double Dimjogang { get; set; }
<UnitTypeAttribute(UnitType.AngleNotTransformed)> _
Public Overridable Property Dimjogang As Double
    Get
    Set
[UnitTypeAttribute(UnitType::AngleNotTransformed)]
public:
virtual property double Dimjogang {
    double get ();
    void set (double value);
}


Dimjust Property

Dimjust Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimjust
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimjust { get; set; }
Public Overridable Property Dimjust As Integer
    Get
    Set
public:
virtual property int Dimjust {
    int get ();
    void set (int value);
}


Dimldrblk Property

Dimldrblk Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimldrblk
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimldrblk { get; set; }
Public Overridable Property Dimldrblk As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimldrblk {
    ObjectId get ();
    void set (ObjectId value);
}


Dimldrblks Property

Dimldrblks Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimldrblks
Declaration Syntax
C# Visual Basic Visual C++
public string Dimldrblks { get; set; }
Public Property Dimldrblks As String
    Get
    Set
public:
property String^ Dimldrblks {
    String^ get ();
    void set (String^ value);
}


Dimlfac Property

Dimlfac Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimlfac
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public virtual double Dimlfac { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Overridable Property Dimlfac As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
virtual property double Dimlfac {
    double get ();
    void set (double value);
}


Dimlim Property

Dimlim Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimlim
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimlim { get; set; }
Public Overridable Property Dimlim As Boolean
    Get
    Set
public:
virtual property bool Dimlim {
    bool get ();
    void set (bool value);
}


Dimltex1 Property

Dimltex1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimltex1
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimltex1 { get; set; }
Public Overridable Property Dimltex1 As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimltex1 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimltex2 Property

Dimltex2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimltex2
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimltex2 { get; set; }
Public Overridable Property Dimltex2 As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimltex2 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimltype Property

Dimltype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimltype
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimltype { get; set; }
Public Overridable Property Dimltype As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimltype {
    ObjectId get ();
    void set (ObjectId value);
}


Dimlunit Property

Dimlunit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimlunit
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimlunit { get; set; }
Public Overridable Property Dimlunit As Integer
    Get
    Set
public:
virtual property int Dimlunit {
    int get ();
    void set (int value);
}


Dimlwd Property

Dimlwd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimlwd
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight Dimlwd { get; set; }
Public Overridable Property Dimlwd As LineWeight
    Get
    Set
public:
virtual property LineWeight Dimlwd {
    LineWeight get ();
    void set (LineWeight value);
}


Dimlwe Property

Dimlwe Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimlwe
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight Dimlwe { get; set; }
Public Overridable Property Dimlwe As LineWeight
    Get
    Set
public:
virtual property LineWeight Dimlwe {
    LineWeight get ();
    void set (LineWeight value);
}


Dimpost Property

Dimpost Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimpost
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Dimpost { get; set; }
Public Overridable Property Dimpost As String
    Get
    Set
public:
virtual property String^ Dimpost {
    String^ get ();
    void set (String^ value);
}


Dimrnd Property

Dimrnd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimrnd
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimrnd { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimrnd As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimrnd {
    double get ();
    void set (double value);
}


Dimsah Property

Dimsah Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimsah
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimsah { get; set; }
Public Overridable Property Dimsah As Boolean
    Get
    Set
public:
virtual property bool Dimsah {
    bool get ();
    void set (bool value);
}


Dimscale Property

Dimscale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimscale
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public virtual double Dimscale { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Overridable Property Dimscale As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
virtual property double Dimscale {
    double get ();
    void set (double value);
}


Dimsd1 Property

Dimsd1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimsd1
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimsd1 { get; set; }
Public Overridable Property Dimsd1 As Boolean
    Get
    Set
public:
virtual property bool Dimsd1 {
    bool get ();
    void set (bool value);
}


Dimsd2 Property

Dimsd2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimsd2
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimsd2 { get; set; }
Public Overridable Property Dimsd2 As Boolean
    Get
    Set
public:
virtual property bool Dimsd2 {
    bool get ();
    void set (bool value);
}


Dimse1 Property

Dimse1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimse1
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimse1 { get; set; }
Public Overridable Property Dimse1 As Boolean
    Get
    Set
public:
virtual property bool Dimse1 {
    bool get ();
    void set (bool value);
}


Dimse2 Property

Dimse2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimse2
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimse2 { get; set; }
Public Overridable Property Dimse2 As Boolean
    Get
    Set
public:
virtual property bool Dimse2 {
    bool get ();
    void set (bool value);
}


Dimsoxd Property

Dimsoxd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimsoxd
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimsoxd { get; set; }
Public Overridable Property Dimsoxd As Boolean
    Get
    Set
public:
virtual property bool Dimsoxd {
    bool get ();
    void set (bool value);
}


DimstyleData Property

DimstyleData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »DimstyleData
Declaration Syntax
C# Visual Basic Visual C++
public DimStyleTableRecord DimstyleData { get; set; }
Public Property DimstyleData As DimStyleTableRecord
    Get
    Set
public:
property DimStyleTableRecord^ DimstyleData {
    DimStyleTableRecord^ get ();
    void set (DimStyleTableRecord^ value);
}


Dimtad Property

Dimtad Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtad
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtad { get; set; }
Public Overridable Property Dimtad As Integer
    Get
    Set
public:
virtual property int Dimtad {
    int get ();
    void set (int value);
}


Dimtdec Property

Dimtdec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtdec
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtdec { get; set; }
Public Overridable Property Dimtdec As Integer
    Get
    Set
public:
virtual property int Dimtdec {
    int get ();
    void set (int value);
}


Dimtfac Property

Dimtfac Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtfac
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimtfac { get; set; }
Public Overridable Property Dimtfac As Double
    Get
    Set
public:
virtual property double Dimtfac {
    double get ();
    void set (double value);
}


Dimtfill Property

Dimtfill Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtfill
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtfill { get; set; }
Public Overridable Property Dimtfill As Integer
    Get
    Set
public:
virtual property int Dimtfill {
    int get ();
    void set (int value);
}


Dimtfillclr Property

Dimtfillclr Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtfillclr
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color Dimtfillclr { get; set; }
Public Overridable Property Dimtfillclr As Color
    Get
    Set
public:
virtual property Color^ Dimtfillclr {
    Color^ get ();
    void set (Color^ value);
}


Dimtih Property

Dimtih Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtih
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimtih { get; set; }
Public Overridable Property Dimtih As Boolean
    Get
    Set
public:
virtual property bool Dimtih {
    bool get ();
    void set (bool value);
}


Dimtix Property

Dimtix Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtix
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimtix { get; set; }
Public Overridable Property Dimtix As Boolean
    Get
    Set
public:
virtual property bool Dimtix {
    bool get ();
    void set (bool value);
}


Dimtm Property

Dimtm Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtm
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimtm { get; set; }
Public Overridable Property Dimtm As Double
    Get
    Set
public:
virtual property double Dimtm {
    double get ();
    void set (double value);
}


Dimtmove Property

Dimtmove Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtmove
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtmove { get; set; }
Public Overridable Property Dimtmove As Integer
    Get
    Set
public:
virtual property int Dimtmove {
    int get ();
    void set (int value);
}


Dimtofl Property

Dimtofl Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtofl
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimtofl { get; set; }
Public Overridable Property Dimtofl As Boolean
    Get
    Set
public:
virtual property bool Dimtofl {
    bool get ();
    void set (bool value);
}


Dimtoh Property

Dimtoh Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtoh
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimtoh { get; set; }
Public Overridable Property Dimtoh As Boolean
    Get
    Set
public:
virtual property bool Dimtoh {
    bool get ();
    void set (bool value);
}


Dimtol Property

Dimtol Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtol
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimtol { get; set; }
Public Overridable Property Dimtol As Boolean
    Get
    Set
public:
virtual property bool Dimtol {
    bool get ();
    void set (bool value);
}


Dimtolj Property

Dimtolj Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtolj
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtolj { get; set; }
Public Overridable Property Dimtolj As Integer
    Get
    Set
public:
virtual property int Dimtolj {
    int get ();
    void set (int value);
}


Dimtp Property

Dimtp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtp
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimtp { get; set; }
Public Overridable Property Dimtp As Double
    Get
    Set
public:
virtual property double Dimtp {
    double get ();
    void set (double value);
}


Dimtsz Property

Dimtsz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtsz
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimtsz { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimtsz As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimtsz {
    double get ();
    void set (double value);
}


Dimtvp Property

Dimtvp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtvp
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public virtual double Dimtvp { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Overridable Property Dimtvp As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
virtual property double Dimtvp {
    double get ();
    void set (double value);
}


Dimtxsty Property

Dimtxsty Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtxsty
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimtxsty { get; set; }
Public Overridable Property Dimtxsty As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimtxsty {
    ObjectId get ();
    void set (ObjectId value);
}


Dimtxt Property

Dimtxt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtxt
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimtxt { get; set; }
Public Overridable Property Dimtxt As Double
    Get
    Set
public:
virtual property double Dimtxt {
    double get ();
    void set (double value);
}


Dimtzin Property

Dimtzin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimtzin
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtzin { get; set; }
Public Overridable Property Dimtzin As Integer
    Get
    Set
public:
virtual property int Dimtzin {
    int get ();
    void set (int value);
}


Dimupt Property

Dimupt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimupt
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimupt { get; set; }
Public Overridable Property Dimupt As Boolean
    Get
    Set
public:
virtual property bool Dimupt {
    bool get ();
    void set (bool value);
}


Dimzin Property

Dimzin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dimzin
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimzin { get; set; }
Public Overridable Property Dimzin As Integer
    Get
    Set
public:
virtual property int Dimzin {
    int get ();
    void set (int value);
}


DynamicDimension Property

DynamicDimension Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »DynamicDimension
Declaration Syntax
C# Visual Basic Visual C++
public bool DynamicDimension { get; set; }
Public Property DynamicDimension As Boolean
    Get
    Set
public:
property bool DynamicDimension {
    bool get ();
    void set (bool value);
}


Elevation Property

Elevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Elevation
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Elevation { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Elevation As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Elevation {
    double get ();
    void set (double value);
}


FieldFromMText Method (dimMText)

FieldFromMText Method (dimMText)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »FieldFromMText(MText)
Declaration Syntax
C# Visual Basic Visual C++
public void FieldFromMText(
    MText dimMText
)
Public Sub FieldFromMText ( _
    dimMText As MText _
)
public:
void FieldFromMText(
    MText^ dimMText
)
Parameters
dimMText(MText)


FieldToMText Method (dimMText)

FieldToMText Method (dimMText)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »FieldToMText(MText)
Declaration Syntax
C# Visual Basic Visual C++
public void FieldToMText(
    MText dimMText
)
Public Sub FieldToMText ( _
    dimMText As MText _
)
public:
void FieldToMText(
    MText^ dimMText
)
Parameters
dimMText(MText)


FormatMeasurement Method (measurement, dimensionText)

FormatMeasurement Method (measurement, dimensionText)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »FormatMeasurement(Double, String)
Declaration Syntax
C# Visual Basic Visual C++
public string FormatMeasurement(
    double measurement,
    string dimensionText
)
Public Function FormatMeasurement ( _
    measurement As Double, _
    dimensionText As String _
) As String
public:
String^ FormatMeasurement(
    double measurement,
    String^ dimensionText
)
Parameters
measurement(Double)
dimensionText(String)


GenerateLayout Method

GenerateLayout Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »GenerateLayout()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateLayout()
Public Sub GenerateLayout
public:
void GenerateLayout()


GetDimstyleData Method

GetDimstyleData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »GetDimstyleData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DimStyleTableRecord GetDimstyleData()
Public Function GetDimstyleData As DimStyleTableRecord
public:
DimStyleTableRecord^ GetDimstyleData()


HorizontalRotation Property

HorizontalRotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »HorizontalRotation
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.AngleNotTransformed)]
public double HorizontalRotation { get; set; }
<UnitTypeAttribute(UnitType.AngleNotTransformed)> _
Public Property HorizontalRotation As Double
    Get
    Set
[UnitTypeAttribute(UnitType::AngleNotTransformed)]
public:
property double HorizontalRotation {
    double get ();
    void set (double value);
}


Measurement Property

Measurement Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Measurement
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Measurement { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property Measurement As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Measurement {
    double get ();
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


Prefix Property

Prefix Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Prefix
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Prefix { get; set; }
Public Overridable Property Prefix As String
    Get
    Set
public:
virtual property String^ Prefix {
    String^ get ();
    void set (String^ value);
}


RecomputeDimensionBlock Method (forceUpdate)

RecomputeDimensionBlock Method (forceUpdate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »RecomputeDimensionBlock(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void RecomputeDimensionBlock(
    bool forceUpdate
)
Public Sub RecomputeDimensionBlock ( _
    forceUpdate As Boolean _
)
public:
void RecomputeDimensionBlock(
    bool forceUpdate
)
Parameters
forceUpdate(Boolean)


RemoveTextField Method

RemoveTextField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »RemoveTextField()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveTextField()
Public Sub RemoveTextField
public:
void RemoveTextField()


SetDimstyleData Method (style)

SetDimstyleData Method (style)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »SetDimstyleData(DimStyleTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDimstyleData(
    DimStyleTableRecord style
)
Public Sub SetDimstyleData ( _
    style As DimStyleTableRecord _
)
public:
void SetDimstyleData(
    DimStyleTableRecord^ style
)
Parameters
style(DimStyleTableRecord)


Suffix Property

Suffix Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Suffix
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Suffix { get; set; }
Public Overridable Property Suffix As String
    Get
    Set
public:
virtual property String^ Suffix {
    String^ get ();
    void set (String^ value);
}


SuppressAngularLeadingZeros Property

SuppressAngularLeadingZeros Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »SuppressAngularLeadingZeros
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool SuppressAngularLeadingZeros { get; set; }
Public Overridable Property SuppressAngularLeadingZeros As Boolean
    Get
    Set
public:
virtual property bool SuppressAngularLeadingZeros {
    bool get ();
    void set (bool value);
}


SuppressAngularTrailingZeros Property

SuppressAngularTrailingZeros Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »SuppressAngularTrailingZeros
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool SuppressAngularTrailingZeros { get; set; }
Public Overridable Property SuppressAngularTrailingZeros As Boolean
    Get
    Set
public:
virtual property bool SuppressAngularTrailingZeros {
    bool get ();
    void set (bool value);
}


SuppressLeadingZeros Property

SuppressLeadingZeros Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »SuppressLeadingZeros
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool SuppressLeadingZeros { get; set; }
Public Overridable Property SuppressLeadingZeros As Boolean
    Get
    Set
public:
virtual property bool SuppressLeadingZeros {
    bool get ();
    void set (bool value);
}


SuppressTrailingZeros Property

SuppressTrailingZeros Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »SuppressTrailingZeros
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool SuppressTrailingZeros { get; set; }
Public Overridable Property SuppressTrailingZeros As Boolean
    Get
    Set
public:
virtual property bool SuppressTrailingZeros {
    bool get ();
    void set (bool value);
}


SuppressZeroFeet Property

SuppressZeroFeet Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »SuppressZeroFeet
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool SuppressZeroFeet { get; set; }
Public Overridable Property SuppressZeroFeet As Boolean
    Get
    Set
public:
virtual property bool SuppressZeroFeet {
    bool get ();
    void set (bool value);
}


SuppressZeroInches Property

SuppressZeroInches Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »SuppressZeroInches
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool SuppressZeroInches { get; set; }
Public Overridable Property SuppressZeroInches As Boolean
    Get
    Set
public:
virtual property bool SuppressZeroInches {
    bool get ();
    void set (bool value);
}


TextAttachment Property

TextAttachment Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »TextAttachment
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public AttachmentPoint TextAttachment { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property TextAttachment As AttachmentPoint
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property AttachmentPoint TextAttachment {
    AttachmentPoint get ();
    void set (AttachmentPoint value);
}


TextLineSpacingFactor Property

TextLineSpacingFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »TextLineSpacingFactor
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double TextLineSpacingFactor { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property TextLineSpacingFactor As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double TextLineSpacingFactor {
    double get ();
    void set (double value);
}


TextLineSpacingStyle Property

TextLineSpacingStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »TextLineSpacingStyle
Declaration Syntax
C# Visual Basic Visual C++
public LineSpacingStyle TextLineSpacingStyle { get; set; }
Public Property TextLineSpacingStyle As LineSpacingStyle
    Get
    Set
public:
property LineSpacingStyle TextLineSpacingStyle {
    LineSpacingStyle get ();
    void set (LineSpacingStyle value);
}


TextPosition Property

TextPosition Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »TextPosition
Declaration Syntax
C# Visual Basic Visual C++
public Point3d TextPosition { get; set; }
Public Property TextPosition As Point3d
    Get
    Set
public:
property Point3d TextPosition {
    Point3d get ();
    void set (Point3d value);
}


TextRotation Property

TextRotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »TextRotation
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.AngleNotTransformed)]
public double TextRotation { get; set; }
<UnitTypeAttribute(UnitType.AngleNotTransformed)> _
Public Property TextRotation As Double
    Get
    Set
[UnitTypeAttribute(UnitType::AngleNotTransformed)]
public:
property double TextRotation {
    double get ();
    void set (double value);
}


TextStyleId Property

TextStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »TextStyleId
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId TextStyleId { get; set; }
Public Overridable Property TextStyleId As ObjectId
    Get
    Set
public:
virtual property ObjectId TextStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


ToleranceSuppressLeadingZeros Property

ToleranceSuppressLeadingZeros Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »ToleranceSuppressLeadingZeros
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ToleranceSuppressLeadingZeros { get; set; }
Public Overridable Property ToleranceSuppressLeadingZeros As Boolean
    Get
    Set
public:
virtual property bool ToleranceSuppressLeadingZeros {
    bool get ();
    void set (bool value);
}


ToleranceSuppressTrailingZeros Property

ToleranceSuppressTrailingZeros Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »ToleranceSuppressTrailingZeros
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ToleranceSuppressTrailingZeros { get; set; }
Public Overridable Property ToleranceSuppressTrailingZeros As Boolean
    Get
    Set
public:
virtual property bool ToleranceSuppressTrailingZeros {
    bool get ();
    void set (bool value);
}


ToleranceSuppressZeroFeet Property

ToleranceSuppressZeroFeet Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »ToleranceSuppressZeroFeet
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ToleranceSuppressZeroFeet { get; set; }
Public Overridable Property ToleranceSuppressZeroFeet As Boolean
    Get
    Set
public:
virtual property bool ToleranceSuppressZeroFeet {
    bool get ();
    void set (bool value);
}


ToleranceSuppressZeroInches Property

ToleranceSuppressZeroInches Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »ToleranceSuppressZeroInches
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ToleranceSuppressZeroInches { get; set; }
Public Overridable Property ToleranceSuppressZeroInches As Boolean
    Get
    Set
public:
virtual property bool ToleranceSuppressZeroInches {
    bool get ();
    void set (bool value);
}


UsingDefaultTextPosition Property

UsingDefaultTextPosition Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »UsingDefaultTextPosition
Declaration Syntax
C# Visual Basic Visual C++
public bool UsingDefaultTextPosition { get; set; }
Public Property UsingDefaultTextPosition As Boolean
    Get
    Set
public:
property bool UsingDefaultTextPosition {
    bool get ();
    void set (bool value);
}


DimensionCenterMarkType Enumeration

DimensionCenterMarkType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimensionCenterMarkType
Declaration Syntax
C# Visual Basic Visual C++
public enum DimensionCenterMarkType
Public Enumeration DimensionCenterMarkType
public enum class DimensionCenterMarkType
Members
Member | Description
Mark |
Line |
None |


DimStyleTable Class

DimStyleTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDimStyleTable")]
public sealed class DimStyleTable : SymbolTable
<WrapperAttribute("AcDbDimStyleTable")> _
Public NotInheritable Class DimStyleTable _
    Inherits SymbolTable
[WrapperAttribute(L"AcDbDimStyleTable")]
public ref class DimStyleTable sealed : public SymbolTable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) | (Inherited from SymbolTable.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() | (Inherited from SymbolTable.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) | (Inherited from SymbolTable.)
 | Has(ObjectId) | (Inherited from SymbolTable.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from SymbolTable.)
 | IncludingErased | (Inherited from SymbolTable.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from SymbolTable.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | DimStyleTable


DimStyleTableRecord Class

DimStyleTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDimStyleTableRecord")]
public class DimStyleTableRecord : SymbolTableRecord
<WrapperAttribute("AcDbDimStyleTableRecord")> _
Public Class DimStyleTableRecord _
    Inherits SymbolTableRecord
[WrapperAttribute(L"AcDbDimStyleTableRecord")]
public ref class DimStyleTableRecord : public SymbolTableRecord
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DimStyleTableRecord(IntPtr, Boolean) |
 | DimStyleTableRecord()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec |
 | Dimalt |
 | Dimaltd |
 | Dimaltf |
 | Dimaltrnd |
 | Dimalttd |
 | Dimalttz |
 | Dimaltu |
 | Dimaltz |
 | Dimapost |
 | Dimarcsym |
 | Dimasz |
 | Dimatfit |
 | Dimaunit |
 | Dimazin |
 | Dimblk |
 | Dimblk1 |
 | Dimblk1s |
 | Dimblk2 |
 | Dimblk2s |
 | Dimblks |
 | Dimcen |
 | Dimclrd |
 | Dimclre |
 | Dimclrt |
 | Dimdec |
 | Dimdle |
 | Dimdli |
 | Dimdsep |
 | Dimexe |
 | Dimexo |
 | Dimfrac |
 | Dimfxlen |
 | DimfxlenOn |
 | Dimgap |
 | Dimjogang |
 | Dimjust |
 | Dimldrblk |
 | Dimldrblks |
 | Dimlfac |
 | Dimlim |
 | Dimltex1 |
 | Dimltex2 |
 | Dimltype |
 | Dimlunit |
 | Dimlwd |
 | Dimlwe |
 | Dimpost |
 | Dimrnd |
 | Dimsah |
 | Dimscale |
 | Dimsd1 |
 | Dimsd2 |
 | Dimse1 |
 | Dimse2 |
 | Dimsoxd |
 | Dimtad |
 | Dimtdec |
 | Dimtfac |
 | Dimtfill |
 | Dimtfillclr |
 | Dimtih |
 | Dimtix |
 | Dimtm |
 | Dimtmove |
 | Dimtofl |
 | Dimtoh |
 | Dimtol |
 | Dimtolj |
 | Dimtp |
 | Dimtsz |
 | Dimtvp |
 | Dimtxsty |
 | Dimtxt |
 | Dimtzin |
 | Dimupt |
 | Dimzin |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArrowId(DimArrowFlag) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent | (Inherited from SymbolTableRecord.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedForRecompute |
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsResolved | (Inherited from SymbolTableRecord.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from SymbolTableRecord.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | DimStyleTableRecord


DimStyleTableRecord Constructor

DimStyleTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »DimStyleTableRecord()()()()
Members
Icon | Member | Description
 | DimStyleTableRecord(IntPtr, Boolean) |
 | DimStyleTableRecord()()()() |


DimStyleTableRecord Constructor

DimStyleTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »DimStyleTableRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DimStyleTableRecord()
Public Sub New
public:
DimStyleTableRecord()


DimStyleTableRecord Constructor (obj, autoDelete)

DimStyleTableRecord Constructor (obj, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »DimStyleTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DimStyleTableRecord(
    IntPtr obj,
    bool autoDelete
)
Protected Friend Sub New ( _
    obj As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DimStyleTableRecord(
    IntPtr obj,
    bool autoDelete
)
Parameters
obj(IntPtr)
autoDelete(Boolean)


Dimadec Property

Dimadec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimadec
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimadec { get; set; }
Public Overridable Property Dimadec As Integer
    Get
    Set
public:
virtual property int Dimadec {
    int get ();
    void set (int value);
}


Dimalt Property

Dimalt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimalt
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimalt { get; set; }
Public Overridable Property Dimalt As Boolean
    Get
    Set
public:
virtual property bool Dimalt {
    bool get ();
    void set (bool value);
}


Dimaltd Property

Dimaltd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimaltd
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimaltd { get; set; }
Public Overridable Property Dimaltd As Integer
    Get
    Set
public:
virtual property int Dimaltd {
    int get ();
    void set (int value);
}


Dimaltf Property

Dimaltf Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimaltf
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimaltf { get; set; }
Public Overridable Property Dimaltf As Double
    Get
    Set
public:
virtual property double Dimaltf {
    double get ();
    void set (double value);
}


Dimaltrnd Property

Dimaltrnd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimaltrnd
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimaltrnd { get; set; }
Public Overridable Property Dimaltrnd As Double
    Get
    Set
public:
virtual property double Dimaltrnd {
    double get ();
    void set (double value);
}


Dimalttd Property

Dimalttd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimalttd
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimalttd { get; set; }
Public Overridable Property Dimalttd As Integer
    Get
    Set
public:
virtual property int Dimalttd {
    int get ();
    void set (int value);
}


Dimalttz Property

Dimalttz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimalttz
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimalttz { get; set; }
Public Overridable Property Dimalttz As Integer
    Get
    Set
public:
virtual property int Dimalttz {
    int get ();
    void set (int value);
}


Dimaltu Property

Dimaltu Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimaltu
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimaltu { get; set; }
Public Overridable Property Dimaltu As Integer
    Get
    Set
public:
virtual property int Dimaltu {
    int get ();
    void set (int value);
}


Dimaltz Property

Dimaltz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimaltz
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimaltz { get; set; }
Public Overridable Property Dimaltz As Integer
    Get
    Set
public:
virtual property int Dimaltz {
    int get ();
    void set (int value);
}


Dimapost Property

Dimapost Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimapost
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Dimapost { get; set; }
Public Overridable Property Dimapost As String
    Get
    Set
public:
virtual property String^ Dimapost {
    String^ get ();
    void set (String^ value);
}


Dimarcsym Property

Dimarcsym Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimarcsym
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimarcsym { get; set; }
Public Overridable Property Dimarcsym As Integer
    Get
    Set
public:
virtual property int Dimarcsym {
    int get ();
    void set (int value);
}


Dimasz Property

Dimasz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimasz
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimasz { get; set; }
Public Overridable Property Dimasz As Double
    Get
    Set
public:
virtual property double Dimasz {
    double get ();
    void set (double value);
}


Dimatfit Property

Dimatfit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimatfit
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimatfit { get; set; }
Public Overridable Property Dimatfit As Integer
    Get
    Set
public:
virtual property int Dimatfit {
    int get ();
    void set (int value);
}


Dimaunit Property

Dimaunit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimaunit
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimaunit { get; set; }
Public Overridable Property Dimaunit As Integer
    Get
    Set
public:
virtual property int Dimaunit {
    int get ();
    void set (int value);
}


Dimazin Property

Dimazin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimazin
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimazin { get; set; }
Public Overridable Property Dimazin As Integer
    Get
    Set
public:
virtual property int Dimazin {
    int get ();
    void set (int value);
}


Dimblk Property

Dimblk Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimblk
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimblk { get; set; }
Public Property Dimblk As ObjectId
    Get
    Set
public:
property ObjectId Dimblk {
    ObjectId get ();
    void set (ObjectId value);
}


Dimblk1 Property

Dimblk1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimblk1
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimblk1 { get; set; }
Public Property Dimblk1 As ObjectId
    Get
    Set
public:
property ObjectId Dimblk1 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimblk1s Property

Dimblk1s Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimblk1s
Declaration Syntax
C# Visual Basic Visual C++
public string Dimblk1s { get; set; }
Public Property Dimblk1s As String
    Get
    Set
public:
property String^ Dimblk1s {
    String^ get ();
    void set (String^ value);
}


Dimblk2 Property

Dimblk2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimblk2
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimblk2 { get; set; }
Public Property Dimblk2 As ObjectId
    Get
    Set
public:
property ObjectId Dimblk2 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimblk2s Property

Dimblk2s Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimblk2s
Declaration Syntax
C# Visual Basic Visual C++
public string Dimblk2s { get; set; }
Public Property Dimblk2s As String
    Get
    Set
public:
property String^ Dimblk2s {
    String^ get ();
    void set (String^ value);
}


Dimblks Property

Dimblks Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimblks
Declaration Syntax
C# Visual Basic Visual C++
public string Dimblks { get; set; }
Public Property Dimblks As String
    Get
    Set
public:
property String^ Dimblks {
    String^ get ();
    void set (String^ value);
}


Dimcen Property

Dimcen Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimcen
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimcen { get; set; }
Public Overridable Property Dimcen As Double
    Get
    Set
public:
virtual property double Dimcen {
    double get ();
    void set (double value);
}


Dimclrd Property

Dimclrd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimclrd
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color Dimclrd { get; set; }
Public Overridable Property Dimclrd As Color
    Get
    Set
public:
virtual property Color^ Dimclrd {
    Color^ get ();
    void set (Color^ value);
}


Dimclre Property

Dimclre Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimclre
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color Dimclre { get; set; }
Public Overridable Property Dimclre As Color
    Get
    Set
public:
virtual property Color^ Dimclre {
    Color^ get ();
    void set (Color^ value);
}


Dimclrt Property

Dimclrt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimclrt
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color Dimclrt { get; set; }
Public Overridable Property Dimclrt As Color
    Get
    Set
public:
virtual property Color^ Dimclrt {
    Color^ get ();
    void set (Color^ value);
}


Dimdec Property

Dimdec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimdec
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimdec { get; set; }
Public Overridable Property Dimdec As Integer
    Get
    Set
public:
virtual property int Dimdec {
    int get ();
    void set (int value);
}


Dimdle Property

Dimdle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimdle
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimdle { get; set; }
Public Overridable Property Dimdle As Double
    Get
    Set
public:
virtual property double Dimdle {
    double get ();
    void set (double value);
}


Dimdli Property

Dimdli Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimdli
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimdli { get; set; }
Public Overridable Property Dimdli As Double
    Get
    Set
public:
virtual property double Dimdli {
    double get ();
    void set (double value);
}


Dimdsep Property

Dimdsep Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimdsep
Declaration Syntax
C# Visual Basic Visual C++
public virtual char Dimdsep { get; set; }
Public Overridable Property Dimdsep As Char
    Get
    Set
public:
virtual property wchar_t Dimdsep {
    wchar_t get ();
    void set (wchar_t value);
}


Dimexe Property

Dimexe Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimexe
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimexe { get; set; }
Public Overridable Property Dimexe As Double
    Get
    Set
public:
virtual property double Dimexe {
    double get ();
    void set (double value);
}


Dimexo Property

Dimexo Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimexo
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimexo { get; set; }
Public Overridable Property Dimexo As Double
    Get
    Set
public:
virtual property double Dimexo {
    double get ();
    void set (double value);
}


Dimfrac Property

Dimfrac Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimfrac
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimfrac { get; set; }
Public Overridable Property Dimfrac As Integer
    Get
    Set
public:
virtual property int Dimfrac {
    int get ();
    void set (int value);
}


Dimfxlen Property

Dimfxlen Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimfxlen
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimfxlen { get; set; }
Public Overridable Property Dimfxlen As Double
    Get
    Set
public:
virtual property double Dimfxlen {
    double get ();
    void set (double value);
}


DimfxlenOn Property

DimfxlenOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »DimfxlenOn
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool DimfxlenOn { get; set; }
Public Overridable Property DimfxlenOn As Boolean
    Get
    Set
public:
virtual property bool DimfxlenOn {
    bool get ();
    void set (bool value);
}


Dimgap Property

Dimgap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimgap
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimgap { get; set; }
Public Overridable Property Dimgap As Double
    Get
    Set
public:
virtual property double Dimgap {
    double get ();
    void set (double value);
}


Dimjogang Property

Dimjogang Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimjogang
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimjogang { get; set; }
Public Overridable Property Dimjogang As Double
    Get
    Set
public:
virtual property double Dimjogang {
    double get ();
    void set (double value);
}


Dimjust Property

Dimjust Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimjust
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimjust { get; set; }
Public Overridable Property Dimjust As Integer
    Get
    Set
public:
virtual property int Dimjust {
    int get ();
    void set (int value);
}


Dimldrblk Property

Dimldrblk Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimldrblk
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimldrblk { get; set; }
Public Overridable Property Dimldrblk As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimldrblk {
    ObjectId get ();
    void set (ObjectId value);
}


Dimldrblks Property

Dimldrblks Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimldrblks
Declaration Syntax
C# Visual Basic Visual C++
public string Dimldrblks { get; set; }
Public Property Dimldrblks As String
    Get
    Set
public:
property String^ Dimldrblks {
    String^ get ();
    void set (String^ value);
}


Dimlfac Property

Dimlfac Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimlfac
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimlfac { get; set; }
Public Overridable Property Dimlfac As Double
    Get
    Set
public:
virtual property double Dimlfac {
    double get ();
    void set (double value);
}


Dimlim Property

Dimlim Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimlim
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimlim { get; set; }
Public Overridable Property Dimlim As Boolean
    Get
    Set
public:
virtual property bool Dimlim {
    bool get ();
    void set (bool value);
}


Dimltex1 Property

Dimltex1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimltex1
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimltex1 { get; set; }
Public Overridable Property Dimltex1 As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimltex1 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimltex2 Property

Dimltex2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimltex2
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimltex2 { get; set; }
Public Overridable Property Dimltex2 As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimltex2 {
    ObjectId get ();
    void set (ObjectId value);
}


Dimltype Property

Dimltype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimltype
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimltype { get; set; }
Public Overridable Property Dimltype As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimltype {
    ObjectId get ();
    void set (ObjectId value);
}


Dimlunit Property

Dimlunit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimlunit
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimlunit { get; set; }
Public Overridable Property Dimlunit As Integer
    Get
    Set
public:
virtual property int Dimlunit {
    int get ();
    void set (int value);
}


Dimlwd Property

Dimlwd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimlwd
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight Dimlwd { get; set; }
Public Overridable Property Dimlwd As LineWeight
    Get
    Set
public:
virtual property LineWeight Dimlwd {
    LineWeight get ();
    void set (LineWeight value);
}


Dimlwe Property

Dimlwe Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimlwe
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight Dimlwe { get; set; }
Public Overridable Property Dimlwe As LineWeight
    Get
    Set
public:
virtual property LineWeight Dimlwe {
    LineWeight get ();
    void set (LineWeight value);
}


Dimpost Property

Dimpost Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimpost
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Dimpost { get; set; }
Public Overridable Property Dimpost As String
    Get
    Set
public:
virtual property String^ Dimpost {
    String^ get ();
    void set (String^ value);
}


Dimrnd Property

Dimrnd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimrnd
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimrnd { get; set; }
Public Overridable Property Dimrnd As Double
    Get
    Set
public:
virtual property double Dimrnd {
    double get ();
    void set (double value);
}


Dimsah Property

Dimsah Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimsah
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimsah { get; set; }
Public Overridable Property Dimsah As Boolean
    Get
    Set
public:
virtual property bool Dimsah {
    bool get ();
    void set (bool value);
}


Dimscale Property

Dimscale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimscale
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimscale { get; set; }
Public Overridable Property Dimscale As Double
    Get
    Set
public:
virtual property double Dimscale {
    double get ();
    void set (double value);
}


Dimsd1 Property

Dimsd1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimsd1
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimsd1 { get; set; }
Public Overridable Property Dimsd1 As Boolean
    Get
    Set
public:
virtual property bool Dimsd1 {
    bool get ();
    void set (bool value);
}


Dimsd2 Property

Dimsd2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimsd2
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimsd2 { get; set; }
Public Overridable Property Dimsd2 As Boolean
    Get
    Set
public:
virtual property bool Dimsd2 {
    bool get ();
    void set (bool value);
}


Dimse1 Property

Dimse1 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimse1
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimse1 { get; set; }
Public Overridable Property Dimse1 As Boolean
    Get
    Set
public:
virtual property bool Dimse1 {
    bool get ();
    void set (bool value);
}


Dimse2 Property

Dimse2 Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimse2
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimse2 { get; set; }
Public Overridable Property Dimse2 As Boolean
    Get
    Set
public:
virtual property bool Dimse2 {
    bool get ();
    void set (bool value);
}


Dimsoxd Property

Dimsoxd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimsoxd
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimsoxd { get; set; }
Public Overridable Property Dimsoxd As Boolean
    Get
    Set
public:
virtual property bool Dimsoxd {
    bool get ();
    void set (bool value);
}


Dimtad Property

Dimtad Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtad
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtad { get; set; }
Public Overridable Property Dimtad As Integer
    Get
    Set
public:
virtual property int Dimtad {
    int get ();
    void set (int value);
}


Dimtdec Property

Dimtdec Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtdec
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtdec { get; set; }
Public Overridable Property Dimtdec As Integer
    Get
    Set
public:
virtual property int Dimtdec {
    int get ();
    void set (int value);
}


Dimtfac Property

Dimtfac Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtfac
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimtfac { get; set; }
Public Overridable Property Dimtfac As Double
    Get
    Set
public:
virtual property double Dimtfac {
    double get ();
    void set (double value);
}


Dimtfill Property

Dimtfill Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtfill
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtfill { get; set; }
Public Overridable Property Dimtfill As Integer
    Get
    Set
public:
virtual property int Dimtfill {
    int get ();
    void set (int value);
}


Dimtfillclr Property

Dimtfillclr Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtfillclr
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color Dimtfillclr { get; set; }
Public Overridable Property Dimtfillclr As Color
    Get
    Set
public:
virtual property Color^ Dimtfillclr {
    Color^ get ();
    void set (Color^ value);
}


Dimtih Property

Dimtih Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtih
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimtih { get; set; }
Public Overridable Property Dimtih As Boolean
    Get
    Set
public:
virtual property bool Dimtih {
    bool get ();
    void set (bool value);
}


Dimtix Property

Dimtix Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtix
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimtix { get; set; }
Public Overridable Property Dimtix As Boolean
    Get
    Set
public:
virtual property bool Dimtix {
    bool get ();
    void set (bool value);
}


Dimtm Property

Dimtm Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtm
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimtm { get; set; }
Public Overridable Property Dimtm As Double
    Get
    Set
public:
virtual property double Dimtm {
    double get ();
    void set (double value);
}


Dimtmove Property

Dimtmove Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtmove
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtmove { get; set; }
Public Overridable Property Dimtmove As Integer
    Get
    Set
public:
virtual property int Dimtmove {
    int get ();
    void set (int value);
}


Dimtofl Property

Dimtofl Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtofl
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimtofl { get; set; }
Public Overridable Property Dimtofl As Boolean
    Get
    Set
public:
virtual property bool Dimtofl {
    bool get ();
    void set (bool value);
}


Dimtoh Property

Dimtoh Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtoh
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimtoh { get; set; }
Public Overridable Property Dimtoh As Boolean
    Get
    Set
public:
virtual property bool Dimtoh {
    bool get ();
    void set (bool value);
}


Dimtol Property

Dimtol Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtol
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimtol { get; set; }
Public Overridable Property Dimtol As Boolean
    Get
    Set
public:
virtual property bool Dimtol {
    bool get ();
    void set (bool value);
}


Dimtolj Property

Dimtolj Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtolj
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtolj { get; set; }
Public Overridable Property Dimtolj As Integer
    Get
    Set
public:
virtual property int Dimtolj {
    int get ();
    void set (int value);
}


Dimtp Property

Dimtp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtp
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimtp { get; set; }
Public Overridable Property Dimtp As Double
    Get
    Set
public:
virtual property double Dimtp {
    double get ();
    void set (double value);
}


Dimtsz Property

Dimtsz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtsz
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimtsz { get; set; }
Public Overridable Property Dimtsz As Double
    Get
    Set
public:
virtual property double Dimtsz {
    double get ();
    void set (double value);
}


Dimtvp Property

Dimtvp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtvp
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimtvp { get; set; }
Public Overridable Property Dimtvp As Double
    Get
    Set
public:
virtual property double Dimtvp {
    double get ();
    void set (double value);
}


Dimtxsty Property

Dimtxsty Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtxsty
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimtxsty { get; set; }
Public Overridable Property Dimtxsty As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimtxsty {
    ObjectId get ();
    void set (ObjectId value);
}


Dimtxt Property

Dimtxt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtxt
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Dimtxt { get; set; }
Public Overridable Property Dimtxt As Double
    Get
    Set
public:
virtual property double Dimtxt {
    double get ();
    void set (double value);
}


Dimtzin Property

Dimtzin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimtzin
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtzin { get; set; }
Public Overridable Property Dimtzin As Integer
    Get
    Set
public:
virtual property int Dimtzin {
    int get ();
    void set (int value);
}


Dimupt Property

Dimupt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimupt
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimupt { get; set; }
Public Overridable Property Dimupt As Boolean
    Get
    Set
public:
virtual property bool Dimupt {
    bool get ();
    void set (bool value);
}


Dimzin Property

Dimzin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dimzin
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimzin { get; set; }
Public Overridable Property Dimzin As Integer
    Get
    Set
public:
virtual property int Dimzin {
    int get ();
    void set (int value);
}


GetArrowId Method (whichArrow)

GetArrowId Method (whichArrow)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »GetArrowId(DimArrowFlag)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetArrowId(
    DimArrowFlag whichArrow
)
Public Function GetArrowId ( _
    whichArrow As DimArrowFlag _
) As ObjectId
public:
ObjectId GetArrowId(
    DimArrowFlag whichArrow
)
Parameters
whichArrow(DimArrowFlag)


IsModifiedForRecompute Property

IsModifiedForRecompute Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »IsModifiedForRecompute
Declaration Syntax
C# Visual Basic Visual C++
public bool IsModifiedForRecompute { get; }
Public ReadOnly Property IsModifiedForRecompute As Boolean
    Get
public:
property bool IsModifiedForRecompute {
    bool get ();
}


DragStatus Enumeration

DragStatus Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DragStatus
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::DragStatus")]
public enum DragStatus
<WrapperAttribute("ZcDb::DragStatus")> _
Public Enumeration DragStatus
[WrapperAttribute(L"ZcDb::DragStatus")]
public enum class DragStatus
Members
Member | Description
DragStart |
DragEnd |
DragAbort |


DrawLeaderOrderType Enumeration

DrawLeaderOrderType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawLeaderOrderType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::DrawLeaderOrderType")]
public enum DrawLeaderOrderType
<WrapperAttribute("ZcDbMLeaderStyle::DrawLeaderOrderType")> _
Public Enumeration DrawLeaderOrderType
[WrapperAttribute(L"ZcDbMLeaderStyle::DrawLeaderOrderType")]
public enum class DrawLeaderOrderType
Members
Member | Description
DrawLeaderTailFirst |
DrawLeaderHeadFirst |


DrawMLeaderOrderType Enumeration

DrawMLeaderOrderType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawMLeaderOrderType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::DrawMLeaderOrderType")]
public enum DrawMLeaderOrderType
<WrapperAttribute("ZcDbMLeaderStyle::DrawMLeaderOrderType")> _
Public Enumeration DrawMLeaderOrderType
[WrapperAttribute(L"ZcDbMLeaderStyle::DrawMLeaderOrderType")]
public enum class DrawMLeaderOrderType
Members
Member | Description
DrawLeaderFirst |
DrawContentFirst |


DrawOrderTable Class

DrawOrderTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSortentsTable")]
public class DrawOrderTable : DBObject
<WrapperAttribute("AcDbSortentsTable")> _
Public Class DrawOrderTable _
    Inherits DBObject
[WrapperAttribute(L"AcDbSortentsTable")]
public ref class DrawOrderTable : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DrawOrderTable(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId |
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FirstEntityIsDrawnBeforeSecond(ObjectId, ObjectId) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFullDrawOrder(Byte) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRelativeDrawOrder(Byte) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSortHandle(ObjectId) |
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveAbove(ObjectIdCollection, ObjectId) |
 | MoveBelow(ObjectIdCollection, ObjectId) |
 | MoveToBottom(ObjectIdCollection) |
 | MoveToTop(ObjectIdCollection) |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetRelativeDrawOrder(ObjectIdCollection) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapOrder(ObjectId, ObjectId) |
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | DrawOrderTable


DrawOrderTable Constructor (unmanagedPointer, autoDelete)

DrawOrderTable Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »DrawOrderTable(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DrawOrderTable(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DrawOrderTable(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


BlockId Property

BlockId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »BlockId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockId { get; set; }
Public Property BlockId As ObjectId
    Get
    Set
public:
property ObjectId BlockId {
    ObjectId get ();
    void set (ObjectId value);
}


FirstEntityIsDrawnBeforeSecond Method (first, second)

FirstEntityIsDrawnBeforeSecond Method (first, second)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »FirstEntityIsDrawnBeforeSecond(ObjectId, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool FirstEntityIsDrawnBeforeSecond(
    ObjectId first,
    ObjectId second
)
Public Function FirstEntityIsDrawnBeforeSecond ( _
    first As ObjectId, _
    second As ObjectId _
) As Boolean
public:
bool FirstEntityIsDrawnBeforeSecond(
    ObjectId first,
    ObjectId second
)
Parameters
first(ObjectId)
second(ObjectId)


GetFullDrawOrder Method (honorSortEntitiesMask)

GetFullDrawOrder Method (honorSortEntitiesMask)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »GetFullDrawOrder(Byte)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetFullDrawOrder(
    byte honorSortEntitiesMask
)
Public Function GetFullDrawOrder ( _
    honorSortEntitiesMask As Byte _
) As ObjectIdCollection
public:
ObjectIdCollection^ GetFullDrawOrder(
    unsigned char honorSortEntitiesMask
)
Parameters
honorSortEntitiesMask(Byte)


GetRelativeDrawOrder Method (honorSortEntitiesMask)

GetRelativeDrawOrder Method (honorSortEntitiesMask)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »GetRelativeDrawOrder(Byte)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetRelativeDrawOrder(
    byte honorSortEntitiesMask
)
Public Function GetRelativeDrawOrder ( _
    honorSortEntitiesMask As Byte _
) As ObjectIdCollection
public:
ObjectIdCollection^ GetRelativeDrawOrder(
    unsigned char honorSortEntitiesMask
)
Parameters
honorSortEntitiesMask(Byte)


GetSortHandle Method (id)

GetSortHandle Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »GetSortHandle(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public Handle GetSortHandle(
    ObjectId id
)
Public Function GetSortHandle ( _
    id As ObjectId _
) As Handle
public:
Handle GetSortHandle(
    ObjectId id
)
Parameters
id(ObjectId)


MoveAbove Method (collection, target)

MoveAbove Method (collection, target)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »MoveAbove(ObjectIdCollection, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void MoveAbove(
    ObjectIdCollection collection,
    ObjectId target
)
Public Sub MoveAbove ( _
    collection As ObjectIdCollection, _
    target As ObjectId _
)
public:
void MoveAbove(
    ObjectIdCollection^ collection,
    ObjectId target
)
Parameters
collection(ObjectIdCollection)
target(ObjectId)


MoveBelow Method (collection, target)

MoveBelow Method (collection, target)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »MoveBelow(ObjectIdCollection, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void MoveBelow(
    ObjectIdCollection collection,
    ObjectId target
)
Public Sub MoveBelow ( _
    collection As ObjectIdCollection, _
    target As ObjectId _
)
public:
void MoveBelow(
    ObjectIdCollection^ collection,
    ObjectId target
)
Parameters
collection(ObjectIdCollection)
target(ObjectId)


MoveToBottom Method (collection)

MoveToBottom Method (collection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »MoveToBottom(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void MoveToBottom(
    ObjectIdCollection collection
)
Public Sub MoveToBottom ( _
    collection As ObjectIdCollection _
)
public:
void MoveToBottom(
    ObjectIdCollection^ collection
)
Parameters
collection(ObjectIdCollection)


MoveToTop Method (collection)

MoveToTop Method (collection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »MoveToTop(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void MoveToTop(
    ObjectIdCollection collection
)
Public Sub MoveToTop ( _
    collection As ObjectIdCollection _
)
public:
void MoveToTop(
    ObjectIdCollection^ collection
)
Parameters
collection(ObjectIdCollection)


SetRelativeDrawOrder Method (collection)

SetRelativeDrawOrder Method (collection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »SetRelativeDrawOrder(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void SetRelativeDrawOrder(
    ObjectIdCollection collection
)
Public Sub SetRelativeDrawOrder ( _
    collection As ObjectIdCollection _
)
public:
void SetRelativeDrawOrder(
    ObjectIdCollection^ collection
)
Parameters
collection(ObjectIdCollection)


SwapOrder Method (id1, id2)

SwapOrder Method (id1, id2)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »SwapOrder(ObjectId, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SwapOrder(
    ObjectId id1,
    ObjectId id2
)
Public Sub SwapOrder ( _
    id1 As ObjectId, _
    id2 As ObjectId _
)
public:
void SwapOrder(
    ObjectId id1,
    ObjectId id2
)
Parameters
id1(ObjectId)
id2(ObjectId)


DuplicateRecordCloning Enumeration

DuplicateRecordCloning Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DuplicateRecordCloning
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::DuplicateRecordCloning")]
public enum DuplicateRecordCloning
<WrapperAttribute("ZcDb::DuplicateRecordCloning")> _
Public Enumeration DuplicateRecordCloning
[WrapperAttribute(L"ZcDb::DuplicateRecordCloning")]
public enum class DuplicateRecordCloning
Members
Member | Description
UnmangleName |
MangleName |
RefMangleName |
Ignore |
NotApplicable |
Replace |


DwfDefinition Class

DwfDefinition Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDwfDefinition")]
public class DwfDefinition : UnderlayDefinition
<WrapperAttribute("AcDbDwfDefinition")> _
Public Class DwfDefinition _
    Inherits UnderlayDefinition
[WrapperAttribute(L"AcDbDwfDefinition")]
public ref class DwfDefinition : public UnderlayDefinition
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DwfDefinition()()()() |
 | DwfDefinition(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | isDWFx |
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Load(String) | (Inherited from UnderlayDefinition.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetUnderlayItem(String, String, UnderlayItem) | (Inherited from UnderlayDefinition.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UnderlayItem | (Inherited from UnderlayDefinition.)
 | UndoFiler | (Inherited from DBObject.)
 | Unload()()()() | (Inherited from UnderlayDefinition.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | UnderlayDefinition
 |  |  |  |  |  |  | DwfDefinition


DwfDefinition Constructor

DwfDefinition Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »DwfDefinition()()()()
Members
Icon | Member | Description
 | DwfDefinition()()()() |
 | DwfDefinition(IntPtr, Boolean) |


DwfDefinition Constructor

DwfDefinition Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »DwfDefinition()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DwfDefinition()
Public Sub New
public:
DwfDefinition()


DwfDefinition Constructor (unmanagedObjPtr, autoDelete)

DwfDefinition Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »DwfDefinition(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DwfDefinition(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DwfDefinition(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


isDWFx Property

isDWFx Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »isDWFx
Declaration Syntax
C# Visual Basic Visual C++
public bool isDWFx { get; }
Public ReadOnly Property isDWFx As Boolean
    Get
public:
property bool isDWFx {
    bool get ();
}


DwfReference Class

DwfReference Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbDwfReference")]
public class DwfReference : UnderlayReference
<WrapperAttribute("AcDbDwfReference")> _
Public Class DwfReference _
    Inherits UnderlayReference
[WrapperAttribute(L"AcDbDwfReference")]
public ref class DwfReference : public UnderlayReference
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DwfReference(IntPtr, Boolean) |
 | DwfReference()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GenerateClipBoundaryFromPline(ObjectId) | (Inherited from UnderlayReference.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClipBoundary()()()() | (Inherited from UnderlayReference.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height | (Inherited from UnderlayReference.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Name | (Inherited from UnderlayReference.)
 | NameOfSheet | (Inherited from UnderlayReference.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | Path | (Inherited from UnderlayReference.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetClipBoundary(array<Point2d>[]()[][]) | (Inherited from UnderlayReference.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UnderlayLayerCollection | (Inherited from UnderlayReference.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width | (Inherited from UnderlayReference.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | UnderlayReference
 |  |  |  |  |  |  |  | DwfReference


DwfReference Constructor

DwfReference Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »DwfReference()()()()
Members
Icon | Member | Description
 | DwfReference(IntPtr, Boolean) |
 | DwfReference()()()() |


DwfReference Constructor

DwfReference Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »DwfReference()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DwfReference()
Public Sub New
public:
DwfReference()


DwfReference Constructor (unmanagedObjPtr, autoDelete)

DwfReference Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »DwfReference(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DwfReference(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DwfReference(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


DwgFiler Class

DwgFiler Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDwgFiler")]
public abstract class DwgFiler : RXObject
<WrapperAttribute("ZcDbDwgFiler")> _
Public MustInherit Class DwgFiler _
    Inherits RXObject
[WrapperAttribute(L"ZcDbDwgFiler")]
public ref class DwgFiler abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DwgFiler(IntPtr, Boolean) |
 | DwgFiler()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DwgVersion |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | FilerStatus |
 | FilerType |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Position |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ReadAddress()()()() |
 | ReadBinaryChunk()()()() |
 | ReadBoolean()()()() |
 | ReadByte()()()() |
 | ReadBytes(array<Byte>[]()[][]) |
 | ReadDouble()()()() |
 | ReadHandle()()()() |
 | ReadHardOwnershipId()()()() |
 | ReadHardPointerId()()()() |
 | ReadInt16()()()() |
 | ReadInt32()()()() |
 | ReadInt64()()()() |
 | ReadPoint2d()()()() |
 | ReadPoint3d()()()() |
 | ReadScale3d()()()() |
 | ReadSoftOwnershipId()()()() |
 | ReadSoftPointerId()()()() |
 | ReadString()()()() |
 | ReadUInt16()()()() |
 | ReadUInt32()()()() |
 | ReadUInt64()()()() |
 | ReadVector2d()()()() |
 | ReadVector3d()()()() |
 | ResetFilerStatus()()()() |
 | Seek(Int32, Int32) |
 | Seek(Int64, Int32) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | WriteAddress(IntPtr) |
 | WriteBinaryChunk(array<Byte>[]()[][]) |
 | WriteBoolean(Boolean) |
 | WriteByte(Byte) |
 | WriteBytes(array<Byte>[]()[][]) |
 | WriteDouble(Double) |
 | WriteHandle(Handle) |
 | WriteHardOwnershipId(ObjectId) |
 | WriteHardPointerId(ObjectId) |
 | WriteInt16(Int16) |
 | WriteInt32(Int32) |
 | WriteInt64(Int64) |
 | WritePoint2d(Point2d) |
 | WritePoint3d(Point3d) |
 | WriteScale3d(Scale3d) |
 | WriteSoftOwnershipId(ObjectId) |
 | WriteSoftPointerId(ObjectId) |
 | WriteString(String) |
 | WriteUInt16(UInt16) |
 | WriteUInt32(UInt32) |
 | WriteUInt64(UInt64) |
 | WriteVector2d(Vector2d) |
 | WriteVector3d(Vector3d) |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DwgFiler


DwgFiler Constructor

DwgFiler Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »DwgFiler()()()()
Members
Icon | Member | Description
 | DwgFiler(IntPtr, Boolean) |
 | DwgFiler()()()() |


DwgFiler Constructor

DwgFiler Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »DwgFiler()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected DwgFiler()
Protected Sub New
protected:
DwgFiler()


DwgFiler Constructor (unmanagedPointer, autoDelete)

DwgFiler Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »DwgFiler(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected DwgFiler(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
DwgFiler(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Database Property

Database Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »Database
Declaration Syntax
C# Visual Basic Visual C++
public virtual Database Database { get; }
Public Overridable ReadOnly Property Database As Database
    Get
public:
virtual property Database^ Database {
    Database^ get ();
}


DwgVersion Property

DwgVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »DwgVersion
Declaration Syntax
C# Visual Basic Visual C++
public virtual FullDwgVersion DwgVersion { get; }
Public Overridable ReadOnly Property DwgVersion As FullDwgVersion
    Get
public:
virtual property FullDwgVersion DwgVersion {
    FullDwgVersion get ();
}


FilerStatus Property

FilerStatus Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »FilerStatus
Declaration Syntax
C# Visual Basic Visual C++
public abstract ErrorStatus FilerStatus { get; set; }
Public MustOverride Property FilerStatus As ErrorStatus
    Get
    Set
public:
virtual property ErrorStatus FilerStatus {
    ErrorStatus get () abstract;
    void set (ErrorStatus value) abstract;
}


FilerType Property

FilerType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »FilerType
Declaration Syntax
C# Visual Basic Visual C++
public abstract FilerType FilerType { get; }
Public MustOverride ReadOnly Property FilerType As FilerType
    Get
public:
virtual property FilerType FilerType {
    FilerType get () abstract;
}


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »Position
Declaration Syntax
C# Visual Basic Visual C++
public abstract long Position { get; }
Public MustOverride ReadOnly Property Position As Long
    Get
public:
virtual property long long Position {
    long long get () abstract;
}


ReadAddress Method

ReadAddress Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadAddress()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract IntPtr ReadAddress()
Public MustOverride Function ReadAddress As IntPtr
public:
virtual IntPtr ReadAddress() abstract


ReadBinaryChunk Method

ReadBinaryChunk Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadBinaryChunk()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract byte[] ReadBinaryChunk()
Public MustOverride Function ReadBinaryChunk As Byte()
public:
virtual array<unsigned char>^ ReadBinaryChunk() abstract


ReadBoolean Method

ReadBoolean Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadBoolean()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool ReadBoolean()
Public MustOverride Function ReadBoolean As Boolean
public:
virtual bool ReadBoolean() abstract


ReadByte Method

ReadByte Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadByte()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract byte ReadByte()
Public MustOverride Function ReadByte As Byte
public:
virtual unsigned char ReadByte() abstract


ReadBytes Method (value)

ReadBytes Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadBytes(array<Byte>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public abstract void ReadBytes(
    byte[] value
)
Public MustOverride Sub ReadBytes ( _
    value As Byte() _
)
public:
virtual void ReadBytes(
    array<unsigned char>^ value
) abstract
Parameters
value(array<Byte>[]()[][])


ReadDouble Method

ReadDouble Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadDouble()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract double ReadDouble()
Public MustOverride Function ReadDouble As Double
public:
virtual double ReadDouble() abstract


ReadHandle Method

ReadHandle Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadHandle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract Handle ReadHandle()
Public MustOverride Function ReadHandle As Handle
public:
virtual Handle ReadHandle() abstract


ReadHardOwnershipId Method

ReadHardOwnershipId Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadHardOwnershipId()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId ReadHardOwnershipId()
Public MustOverride Function ReadHardOwnershipId As ObjectId
public:
virtual ObjectId ReadHardOwnershipId() abstract


ReadHardPointerId Method

ReadHardPointerId Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadHardPointerId()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId ReadHardPointerId()
Public MustOverride Function ReadHardPointerId As ObjectId
public:
virtual ObjectId ReadHardPointerId() abstract


ReadInt16 Method

ReadInt16 Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadInt16()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract short ReadInt16()
Public MustOverride Function ReadInt16 As Short
public:
virtual short ReadInt16() abstract


ReadInt32 Method

ReadInt32 Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadInt32()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract int ReadInt32()
Public MustOverride Function ReadInt32 As Integer
public:
virtual int ReadInt32() abstract


ReadInt64 Method

ReadInt64 Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadInt64()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract long ReadInt64()
Public MustOverride Function ReadInt64 As Long
public:
virtual long long ReadInt64() abstract


ReadPoint2d Method

ReadPoint2d Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadPoint2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract Point2d ReadPoint2d()
Public MustOverride Function ReadPoint2d As Point2d
public:
virtual Point2d ReadPoint2d() abstract


ReadPoint3d Method

ReadPoint3d Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadPoint3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract Point3d ReadPoint3d()
Public MustOverride Function ReadPoint3d As Point3d
public:
virtual Point3d ReadPoint3d() abstract


ReadScale3d Method

ReadScale3d Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadScale3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract Scale3d ReadScale3d()
Public MustOverride Function ReadScale3d As Scale3d
public:
virtual Scale3d ReadScale3d() abstract


ReadSoftOwnershipId Method

ReadSoftOwnershipId Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadSoftOwnershipId()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId ReadSoftOwnershipId()
Public MustOverride Function ReadSoftOwnershipId As ObjectId
public:
virtual ObjectId ReadSoftOwnershipId() abstract


ReadSoftPointerId Method

ReadSoftPointerId Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadSoftPointerId()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId ReadSoftPointerId()
Public MustOverride Function ReadSoftPointerId As ObjectId
public:
virtual ObjectId ReadSoftPointerId() abstract


ReadString Method

ReadString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract string ReadString()
Public MustOverride Function ReadString As String
public:
virtual String^ ReadString() abstract


ReadUInt16 Method

ReadUInt16 Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadUInt16()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract ushort ReadUInt16()
Public MustOverride Function ReadUInt16 As UShort
public:
virtual unsigned short ReadUInt16() abstract


ReadUInt32 Method

ReadUInt32 Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadUInt32()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract uint ReadUInt32()
Public MustOverride Function ReadUInt32 As UInteger
public:
virtual unsigned int ReadUInt32() abstract


ReadUInt64 Method

ReadUInt64 Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadUInt64()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract ulong ReadUInt64()
Public MustOverride Function ReadUInt64 As ULong
public:
virtual unsigned long long ReadUInt64() abstract


ReadVector2d Method

ReadVector2d Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadVector2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract Vector2d ReadVector2d()
Public MustOverride Function ReadVector2d As Vector2d
public:
virtual Vector2d ReadVector2d() abstract


ReadVector3d Method

ReadVector3d Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ReadVector3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract Vector3d ReadVector3d()
Public MustOverride Function ReadVector3d As Vector3d
public:
virtual Vector3d ReadVector3d() abstract


ResetFilerStatus Method

ResetFilerStatus Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »ResetFilerStatus()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void ResetFilerStatus()
Public MustOverride Sub ResetFilerStatus
public:
virtual void ResetFilerStatus() abstract


Seek Method

Seek Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »Seek()()()()
Members
Icon | Member | Description
 | Seek(Int32, Int32) |
 | Seek(Int64, Int32) |


Seek Method (offset, method)

Seek Method (offset, method)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »Seek(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Seek(
    int offset,
    int method
)
Public MustOverride Sub Seek ( _
    offset As Integer, _
    method As Integer _
)
public:
virtual void Seek(
    int offset,
    int method
) abstract
Parameters
offset(Int32)
method(Int32)


Seek Method (offset, method)

Seek Method (offset, method)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »Seek(Int64, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Seek(
    long offset,
    int method
)
Public MustOverride Sub Seek ( _
    offset As Long, _
    method As Integer _
)
public:
virtual void Seek(
    long long offset,
    int method
) abstract
Parameters
offset(Int64)
method(Int32)


WriteAddress Method (value)

WriteAddress Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteAddress(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteAddress(
    IntPtr value
)
Public MustOverride Sub WriteAddress ( _
    value As IntPtr _
)
public:
virtual void WriteAddress(
    IntPtr value
) abstract
Parameters
value(IntPtr)


WriteBinaryChunk Method (chunk)

WriteBinaryChunk Method (chunk)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteBinaryChunk(array<Byte>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteBinaryChunk(
    byte[] chunk
)
Public MustOverride Sub WriteBinaryChunk ( _
    chunk As Byte() _
)
public:
virtual void WriteBinaryChunk(
    array<unsigned char>^ chunk
) abstract
Parameters
chunk(array<Byte>[]()[][])


WriteBoolean Method (value)

WriteBoolean Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteBoolean(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteBoolean(
    bool value
)
Public MustOverride Sub WriteBoolean ( _
    value As Boolean _
)
public:
virtual void WriteBoolean(
    bool value
) abstract
Parameters
value(Boolean)


WriteByte Method (value)

WriteByte Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteByte(Byte)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteByte(
    byte value
)
Public MustOverride Sub WriteByte ( _
    value As Byte _
)
public:
virtual void WriteByte(
    unsigned char value
) abstract
Parameters
value(Byte)


WriteBytes Method (value)

WriteBytes Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteBytes(array<Byte>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteBytes(
    byte[] value
)
Public MustOverride Sub WriteBytes ( _
    value As Byte() _
)
public:
virtual void WriteBytes(
    array<unsigned char>^ value
) abstract
Parameters
value(array<Byte>[]()[][])


WriteDouble Method (value)

WriteDouble Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteDouble(Double)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteDouble(
    double value
)
Public MustOverride Sub WriteDouble ( _
    value As Double _
)
public:
virtual void WriteDouble(
    double value
) abstract
Parameters
value(Double)


WriteHandle Method (handle)

WriteHandle Method (handle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteHandle(Handle)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteHandle(
    Handle handle
)
Public MustOverride Sub WriteHandle ( _
    handle As Handle _
)
public:
virtual void WriteHandle(
    Handle handle
) abstract
Parameters
handle(Handle)


WriteHardOwnershipId Method (value)

WriteHardOwnershipId Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteHardOwnershipId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteHardOwnershipId(
    ObjectId value
)
Public MustOverride Sub WriteHardOwnershipId ( _
    value As ObjectId _
)
public:
virtual void WriteHardOwnershipId(
    ObjectId value
) abstract
Parameters
value(ObjectId)


WriteHardPointerId Method (value)

WriteHardPointerId Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteHardPointerId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteHardPointerId(
    ObjectId value
)
Public MustOverride Sub WriteHardPointerId ( _
    value As ObjectId _
)
public:
virtual void WriteHardPointerId(
    ObjectId value
) abstract
Parameters
value(ObjectId)


WriteInt16 Method (value)

WriteInt16 Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteInt16(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteInt16(
    short value
)
Public MustOverride Sub WriteInt16 ( _
    value As Short _
)
public:
virtual void WriteInt16(
    short value
) abstract
Parameters
value(Int16)


WriteInt32 Method (value)

WriteInt32 Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteInt32(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteInt32(
    int value
)
Public MustOverride Sub WriteInt32 ( _
    value As Integer _
)
public:
virtual void WriteInt32(
    int value
) abstract
Parameters
value(Int32)


WriteInt64 Method (value)

WriteInt64 Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteInt64(Int64)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteInt64(
    long value
)
Public MustOverride Sub WriteInt64 ( _
    value As Long _
)
public:
virtual void WriteInt64(
    long long value
) abstract
Parameters
value(Int64)


WritePoint2d Method (value)

WritePoint2d Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WritePoint2d(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WritePoint2d(
    Point2d value
)
Public MustOverride Sub WritePoint2d ( _
    value As Point2d _
)
public:
virtual void WritePoint2d(
    Point2d value
) abstract
Parameters
value(Point2d)


WritePoint3d Method (value)

WritePoint3d Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WritePoint3d(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WritePoint3d(
    Point3d value
)
Public MustOverride Sub WritePoint3d ( _
    value As Point3d _
)
public:
virtual void WritePoint3d(
    Point3d value
) abstract
Parameters
value(Point3d)


WriteScale3d Method (value)

WriteScale3d Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteScale3d(Scale3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteScale3d(
    Scale3d value
)
Public MustOverride Sub WriteScale3d ( _
    value As Scale3d _
)
public:
virtual void WriteScale3d(
    Scale3d value
) abstract
Parameters
value(Scale3d)


WriteSoftOwnershipId Method (value)

WriteSoftOwnershipId Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteSoftOwnershipId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteSoftOwnershipId(
    ObjectId value
)
Public MustOverride Sub WriteSoftOwnershipId ( _
    value As ObjectId _
)
public:
virtual void WriteSoftOwnershipId(
    ObjectId value
) abstract
Parameters
value(ObjectId)


WriteSoftPointerId Method (value)

WriteSoftPointerId Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteSoftPointerId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteSoftPointerId(
    ObjectId value
)
Public MustOverride Sub WriteSoftPointerId ( _
    value As ObjectId _
)
public:
virtual void WriteSoftPointerId(
    ObjectId value
) abstract
Parameters
value(ObjectId)


WriteString Method (value)

WriteString Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteString(String)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteString(
    string value
)
Public MustOverride Sub WriteString ( _
    value As String _
)
public:
virtual void WriteString(
    String^ value
) abstract
Parameters
value(String)


WriteUInt16 Method (value)

WriteUInt16 Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteUInt16(UInt16)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteUInt16(
    ushort value
)
Public MustOverride Sub WriteUInt16 ( _
    value As UShort _
)
public:
virtual void WriteUInt16(
    unsigned short value
) abstract
Parameters
value(UInt16)


WriteUInt32 Method (value)

WriteUInt32 Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteUInt32(UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteUInt32(
    uint value
)
Public MustOverride Sub WriteUInt32 ( _
    value As UInteger _
)
public:
virtual void WriteUInt32(
    unsigned int value
) abstract
Parameters
value(UInt32)


WriteUInt64 Method (value)

WriteUInt64 Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteUInt64(UInt64)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteUInt64(
    ulong value
)
Public MustOverride Sub WriteUInt64 ( _
    value As ULong _
)
public:
virtual void WriteUInt64(
    unsigned long long value
) abstract
Parameters
value(UInt64)


WriteVector2d Method (value)

WriteVector2d Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteVector2d(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteVector2d(
    Vector2d value
)
Public MustOverride Sub WriteVector2d ( _
    value As Vector2d _
)
public:
virtual void WriteVector2d(
    Vector2d value
) abstract
Parameters
value(Vector2d)


WriteVector3d Method (value)

WriteVector3d Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »WriteVector3d(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteVector3d(
    Vector3d value
)
Public MustOverride Sub WriteVector3d ( _
    value As Vector3d _
)
public:
virtual void WriteVector3d(
    Vector3d value
) abstract
Parameters
value(Vector3d)


DwgVersion Enumeration

DwgVersion Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgVersion
Declaration Syntax
C# Visual Basic Visual C++
public enum DwgVersion
Public Enumeration DwgVersion
public enum class DwgVersion
Members
Member | Description
Max |
Unknown |
Newest |
AC2700a |
AC2400a |
AC2100a |
AC1800a |
AC1800 |
AC1500 |
AC1027 |
AC1024 |
AC1021 |
AC1015 |
AC1014 |
AC1013 |
AC1012 |
AC1011 |
AC1010 |
AC1009 |
AC1008 |
AC1007 |
AC1006 |
AC1005 |
AC1004 |
AC1003 |
AC1002 |
AC1001 |
AC2To22 |
AC2To21 |
AC2To20 |
AC2To10 |
AC1To50 |
AC1To40 |
AC1To2 |
MC0To0 |
vAC27 |
vAC24 |
vAC21 |
vAC18 |
vAC15 |
vAC14 |
vAC14beta |
vAC13 |
vAC12 |
vAC10 |
vAC09 |
vAC026 |
vAC025 |
Current |


DxfCode Enumeration

DxfCode Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfCode
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::DxfCode")]
public enum DxfCode
<WrapperAttribute("ZcDb::DxfCode")> _
Public Enumeration DxfCode
[WrapperAttribute(L"ZcDb::DxfCode")]
public enum class DxfCode
Members
Member | Description
Thickness |
PlotStyleNameType |
LineWeight |
Handle |
ZCoordinate |
YCoordinate |
XXInt16 |
XTextString |
XRefPath |
XReal |
XInt16 |
XDictionary |
XDataStart |
XCoordinate |
ViewWidth |
ViewportZoom |
ViewportVisibility |
ViewportTwist |
ViewportSnapStyle |
ViewportSnapPair |
ViewportSnapAngle |
ViewportSnap |
ViewportNumber |
ViewportIcon |
ViewportHeight |
ViewportGrid |
ViewportAspect |
ViewportActive |
ViewMode |
ViewLensLength |
ViewHeight |
ViewFrontClip |
ViewBackClip |
UcsOrientationY |
UcsOrientationX |
UcsOrg |
TxtStyleXScale |
TxtStylePSize |
TxtStyleFlags |
TxtSize |
TextStyleName |
TextFontFile |
TextBigFontFile |
SymbolTableRecordName |
SymbolTableRecordComments |
SymbolTableName |
Subclass |
SoftPointerId |
SoftOwnershipId |
ShapeYOffset |
ShapeXOffset |
ShapeScale |
ShapeName |
RegAppFlags |
Real |
PReactors |
PlotStyleNameId |
PixelScale |
NormalZ |
NormalY |
NormalX |
MlineStyleName |
MlineOffset |
LinetypeScale |
LinetypeProse |
LinetypePdc |
LinetypeName |
LinetypeElement |
LinetypeAlign |
LayoutName |
LayerName |
LayerLinetype |
Invalid |
Int8 |
HeaderId |
HasSubentities |
HardPointerId |
HardOwnershipId |
GradientTintVal |
GradientTintType |
GradientShift |
GradientPatType |
GradientObjType |
GradientName |
GradientColVal |
GradientColCount |
GradientAngle |
FirstEntityId |
ExtendedInt16 |
ExtendedDataZCoordinate |
ExtendedDataYCoordinate |
ExtendedDataXCoordinate |
ExtendedDataWorldZDisp |
ExtendedDataWorldZDir |
ExtendedDataWorldZCoordinate |
ExtendedDataWorldYDisp |
ExtendedDataWorldYDir |
ExtendedDataWorldYCoordinate |
ExtendedDataWorldXDisp |
ExtendedDataWorldXDir |
ExtendedDataWorldXCoordinate |
ExtendedDataScale |
ExtendedDataRegAppName |
ExtendedDataReal |
ExtendedDataLayerName |
ExtendedDataInteger32 |
ExtendedDataInteger16 |
ExtendedDataHandle |
ExtendedDataDist |
ExtendedDataControlString |
ExtendedDataBinaryChunk |
ExtendedDataAsciiString |
EmbeddedObjectStart |
Elevation |
DimVarHandle |
DimStyleName |
DimPostString |
DimensionBlock |
DimensionAlternativePrefixSuffix |
DimBlk2 |
DimBlk1 |
DashLength |
ControlString |
Comment |
ColorRgb |
CLShapeText |
CLShapeName |
CircleSides |
Bool |
BlockName |
BinaryChunk |
AttributeTag |
AttributePrompt |
ArbitraryHandle |
Angle |
Visibility |
Start |
RenderMode |
End |
Description |
ColorName |
Text |
Operator |
Int32 |
Int16 |
Color |
Alpha |


DxfFiler Class

DxfFiler Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDxfFiler")]
public abstract class DxfFiler : RXObject
<WrapperAttribute("ZcDbDxfFiler")> _
Public MustInherit Class DxfFiler _
    Inherits RXObject
[WrapperAttribute(L"ZcDbDxfFiler")]
public ref class DxfFiler abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DxfFiler(IntPtr, Boolean) |
 | DxfFiler()()()() |
 | AtEmbeddedObjectStart |
 | AtEndOfFile |
 | AtEndOfObject |
 | AtExtendedData |
 | AtSubclassData(String) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DwgVersion |
 | Elevation |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | ErrorMessage |
 | FilerStatus |
 | FilerType |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | HaltAtClassBoundaries(Boolean) |
 | IncludesDefaultValues |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsModifyingExistingObject |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Position |
 | Precision |
 | PushBackItem()()()() |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ReadResultBuffer()()()() |
 | ResetFilerStatus()()()() |
 | RewindFiler()()()() |
 | SetError(ErrorStatus, String, array<String>[]()[][]) |
 | SetError(String, array<String>[]()[][]) |
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | WriteBool(DxfCode, Boolean) |
 | WriteBoolean(DxfCode, Boolean) |
 | WriteByte(DxfCode, Byte) |
 | WriteBytes(DxfCode, array<Byte>[]()[][]) |
 | WriteDouble(DxfCode, Double, Int32) |
 | WriteEmbeddedObjectStart()()()() |
 | WriteHandle(DxfCode, Handle) |
 | WriteInt16(DxfCode, Int16) |
 | WriteInt32(DxfCode, Int32) |
 | WriteInt64(DxfCode, Int64) |
 | WriteObjectId(DxfCode, ObjectId) |
 | WritePoint2d(DxfCode, Point2d, Int32) |
 | WritePoint3d(DxfCode, Point3d, Int32) |
 | WriteResultBuffer(ResultBuffer) |
 | WriteScale3d(DxfCode, Scale3d, Int32) |
 | WriteString(DxfCode, String) |
 | WriteUInt16(DxfCode, UInt16) |
 | WriteUInt32(DxfCode, UInt32) |
 | WriteUInt64(DxfCode, UInt64) |
 | WriteVector2d(DxfCode, Vector2d, Int32) |
 | WriteVector3d(DxfCode, Vector3d, Int32) |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DxfFiler


DxfFiler Constructor

DxfFiler Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »DxfFiler()()()()
Members
Icon | Member | Description
 | DxfFiler(IntPtr, Boolean) |
 | DxfFiler()()()() |


DxfFiler Constructor

DxfFiler Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »DxfFiler()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected DxfFiler()
Protected Sub New
protected:
DxfFiler()


DxfFiler Constructor (unmanagedPointer, autoDelete)

DxfFiler Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »DxfFiler(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DxfFiler(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
DxfFiler(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AtEmbeddedObjectStart Property

AtEmbeddedObjectStart Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »AtEmbeddedObjectStart
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AtEmbeddedObjectStart { get; }
Public Overridable ReadOnly Property AtEmbeddedObjectStart As Boolean
    Get
public:
virtual property bool AtEmbeddedObjectStart {
    bool get ();
}


AtEndOfFile Property

AtEndOfFile Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »AtEndOfFile
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool AtEndOfFile { get; }
Public MustOverride ReadOnly Property AtEndOfFile As Boolean
    Get
public:
virtual property bool AtEndOfFile {
    bool get () abstract;
}


AtEndOfObject Property

AtEndOfObject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »AtEndOfObject
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool AtEndOfObject { get; }
Public MustOverride ReadOnly Property AtEndOfObject As Boolean
    Get
public:
virtual property bool AtEndOfObject {
    bool get () abstract;
}


AtExtendedData Property

AtExtendedData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »AtExtendedData
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool AtExtendedData { get; }
Public MustOverride ReadOnly Property AtExtendedData As Boolean
    Get
public:
virtual property bool AtExtendedData {
    bool get () abstract;
}


AtSubclassData Method (value)

AtSubclassData Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »AtSubclassData(String)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool AtSubclassData(
    string value
)
Public MustOverride Function AtSubclassData ( _
    value As String _
) As Boolean
public:
virtual bool AtSubclassData(
    String^ value
) abstract
Parameters
value(String)


Database Property

Database Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »Database
Declaration Syntax
C# Visual Basic Visual C++
public virtual Database Database { get; }
Public Overridable ReadOnly Property Database As Database
    Get
public:
virtual property Database^ Database {
    Database^ get ();
}


DwgVersion Property

DwgVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »DwgVersion
Declaration Syntax
C# Visual Basic Visual C++
public virtual FullDwgVersion DwgVersion { get; }
Public Overridable ReadOnly Property DwgVersion As FullDwgVersion
    Get
public:
virtual property FullDwgVersion DwgVersion {
    FullDwgVersion get ();
}


Elevation Property

Elevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »Elevation
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Elevation { get; }
Public Overridable ReadOnly Property Elevation As Double
    Get
public:
virtual property double Elevation {
    double get ();
}


ErrorMessage Property

ErrorMessage Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »ErrorMessage
Declaration Syntax
C# Visual Basic Visual C++
public virtual string ErrorMessage { get; }
Public Overridable ReadOnly Property ErrorMessage As String
    Get
public:
virtual property String^ ErrorMessage {
    String^ get ();
}


FilerStatus Property

FilerStatus Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »FilerStatus
Declaration Syntax
C# Visual Basic Visual C++
public abstract ErrorStatus FilerStatus { get; set; }
Public MustOverride Property FilerStatus As ErrorStatus
    Get
    Set
public:
virtual property ErrorStatus FilerStatus {
    ErrorStatus get () abstract;
    void set (ErrorStatus value) abstract;
}


FilerType Property

FilerType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »FilerType
Declaration Syntax
C# Visual Basic Visual C++
public abstract FilerType FilerType { get; }
Public MustOverride ReadOnly Property FilerType As FilerType
    Get
public:
virtual property FilerType FilerType {
    FilerType get () abstract;
}


HaltAtClassBoundaries Method (value)

HaltAtClassBoundaries Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »HaltAtClassBoundaries(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void HaltAtClassBoundaries(
    bool value
)
Public Overridable Sub HaltAtClassBoundaries ( _
    value As Boolean _
)
public:
virtual void HaltAtClassBoundaries(
    bool value
)
Parameters
value(Boolean)


IncludesDefaultValues Property

IncludesDefaultValues Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »IncludesDefaultValues
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludesDefaultValues { get; }
Public ReadOnly Property IncludesDefaultValues As Boolean
    Get
public:
property bool IncludesDefaultValues {
    bool get ();
}


IsModifyingExistingObject Property

IsModifyingExistingObject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »IsModifyingExistingObject
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsModifyingExistingObject { get; }
Public Overridable ReadOnly Property IsModifyingExistingObject As Boolean
    Get
public:
virtual property bool IsModifyingExistingObject {
    bool get ();
}


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »Position
Declaration Syntax
C# Visual Basic Visual C++
public abstract long Position { get; }
Public MustOverride ReadOnly Property Position As Long
    Get
public:
virtual property long long Position {
    long long get () abstract;
}


Precision Property

Precision Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »Precision
Declaration Syntax
C# Visual Basic Visual C++
public abstract int Precision { get; set; }
Public MustOverride Property Precision As Integer
    Get
    Set
public:
virtual property int Precision {
    int get () abstract;
    void set (int value) abstract;
}


PushBackItem Method

PushBackItem Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »PushBackItem()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void PushBackItem()
Public MustOverride Sub PushBackItem
public:
virtual void PushBackItem() abstract


ReadResultBuffer Method

ReadResultBuffer Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »ReadResultBuffer()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract ResultBuffer ReadResultBuffer()
Public MustOverride Function ReadResultBuffer As ResultBuffer
public:
virtual ResultBuffer^ ReadResultBuffer() abstract


ResetFilerStatus Method

ResetFilerStatus Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »ResetFilerStatus()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void ResetFilerStatus()
Public MustOverride Sub ResetFilerStatus
public:
virtual void ResetFilerStatus() abstract


RewindFiler Method

RewindFiler Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »RewindFiler()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual int RewindFiler()
Public Overridable Function RewindFiler As Integer
public:
virtual int RewindFiler()


SetError Method

SetError Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »SetError()()()()
Members
Icon | Member | Description
 | SetError(ErrorStatus, String, array<String>[]()[][]) |
 | SetError(String, array<String>[]()[][]) |


SetError Method (format, values)

SetError Method (format, values)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »SetError(String, array<String>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetError(
    string format,
    string[] values
)
Public Overridable Sub SetError ( _
    format As String, _
    values As String() _
)
public:
virtual void SetError(
    String^ format,
    array<String^>^ values
)
Parameters
format(String)
values(array<String>[]()[][])


SetError Method (value, format, values)

SetError Method (value, format, values)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »SetError(ErrorStatus, String, array<String>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetError(
    ErrorStatus value,
    string format,
    string[] values
)
Public Overridable Sub SetError ( _
    value As ErrorStatus, _
    format As String, _
    values As String() _
)
public:
virtual void SetError(
    ErrorStatus value,
    String^ format,
    array<String^>^ values
)
Parameters
value(ErrorStatus)
format(String)
values(array<String>[]()[][])


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Thickness { get; }
Public Overridable ReadOnly Property Thickness As Double
    Get
public:
virtual property double Thickness {
    double get ();
}


WriteBool Method (opCode, value)

WriteBool Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteBool(DxfCode, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void WriteBool(
    DxfCode opCode,
    bool value
)
Public Overridable Sub WriteBool ( _
    opCode As DxfCode, _
    value As Boolean _
)
public:
virtual void WriteBool(
    DxfCode opCode,
    bool value
)
Parameters
opCode(DxfCode)
value(Boolean)


WriteBoolean Method (opCode, value)

WriteBoolean Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteBoolean(DxfCode, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteBoolean(
    DxfCode opCode,
    bool value
)
Public MustOverride Sub WriteBoolean ( _
    opCode As DxfCode, _
    value As Boolean _
)
public:
virtual void WriteBoolean(
    DxfCode opCode,
    bool value
) abstract
Parameters
opCode(DxfCode)
value(Boolean)


WriteByte Method (opCode, value)

WriteByte Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteByte(DxfCode, Byte)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteByte(
    DxfCode opCode,
    byte value
)
Public MustOverride Sub WriteByte ( _
    opCode As DxfCode, _
    value As Byte _
)
public:
virtual void WriteByte(
    DxfCode opCode,
    unsigned char value
) abstract
Parameters
opCode(DxfCode)
value(Byte)


WriteBytes Method (opCode, chunk)

WriteBytes Method (opCode, chunk)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteBytes(DxfCode, array<Byte>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteBytes(
    DxfCode opCode,
    byte[] chunk
)
Public MustOverride Sub WriteBytes ( _
    opCode As DxfCode, _
    chunk As Byte() _
)
public:
virtual void WriteBytes(
    DxfCode opCode,
    array<unsigned char>^ chunk
) abstract
Parameters
opCode(DxfCode)
chunk(array<Byte>[]()[][])


WriteDouble Method (opCode, value, precision)

WriteDouble Method (opCode, value, precision)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteDouble(DxfCode, Double, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteDouble(
    DxfCode opCode,
    double value,
    int precision
)
Public MustOverride Sub WriteDouble ( _
    opCode As DxfCode, _
    value As Double, _
    precision As Integer _
)
public:
virtual void WriteDouble(
    DxfCode opCode,
    double value,
    int precision
) abstract
Parameters
opCode(DxfCode)
value(Double)
precision(Int32)


WriteEmbeddedObjectStart Method

WriteEmbeddedObjectStart Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteEmbeddedObjectStart()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void WriteEmbeddedObjectStart()
Public Overridable Sub WriteEmbeddedObjectStart
public:
virtual void WriteEmbeddedObjectStart()


WriteHandle Method (opCode, value)

WriteHandle Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteHandle(DxfCode, Handle)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteHandle(
    DxfCode opCode,
    Handle value
)
Public MustOverride Sub WriteHandle ( _
    opCode As DxfCode, _
    value As Handle _
)
public:
virtual void WriteHandle(
    DxfCode opCode,
    Handle value
) abstract
Parameters
opCode(DxfCode)
value(Handle)


WriteInt16 Method (opCode, value)

WriteInt16 Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteInt16(DxfCode, Int16)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteInt16(
    DxfCode opCode,
    short value
)
Public MustOverride Sub WriteInt16 ( _
    opCode As DxfCode, _
    value As Short _
)
public:
virtual void WriteInt16(
    DxfCode opCode,
    short value
) abstract
Parameters
opCode(DxfCode)
value(Int16)


WriteInt32 Method (opCode, value)

WriteInt32 Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteInt32(DxfCode, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteInt32(
    DxfCode opCode,
    int value
)
Public MustOverride Sub WriteInt32 ( _
    opCode As DxfCode, _
    value As Integer _
)
public:
virtual void WriteInt32(
    DxfCode opCode,
    int value
) abstract
Parameters
opCode(DxfCode)
value(Int32)


WriteInt64 Method (opCode, value)

WriteInt64 Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteInt64(DxfCode, Int64)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteInt64(
    DxfCode opCode,
    long value
)
Public MustOverride Sub WriteInt64 ( _
    opCode As DxfCode, _
    value As Long _
)
public:
virtual void WriteInt64(
    DxfCode opCode,
    long long value
) abstract
Parameters
opCode(DxfCode)
value(Int64)


WriteObjectId Method (opCode, value)

WriteObjectId Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteObjectId(DxfCode, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteObjectId(
    DxfCode opCode,
    ObjectId value
)
Public MustOverride Sub WriteObjectId ( _
    opCode As DxfCode, _
    value As ObjectId _
)
public:
virtual void WriteObjectId(
    DxfCode opCode,
    ObjectId value
) abstract
Parameters
opCode(DxfCode)
value(ObjectId)


WritePoint2d Method (opCode, value, precision)

WritePoint2d Method (opCode, value, precision)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WritePoint2d(DxfCode, Point2d, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WritePoint2d(
    DxfCode opCode,
    Point2d value,
    int precision
)
Public MustOverride Sub WritePoint2d ( _
    opCode As DxfCode, _
    value As Point2d, _
    precision As Integer _
)
public:
virtual void WritePoint2d(
    DxfCode opCode,
    Point2d value,
    int precision
) abstract
Parameters
opCode(DxfCode)
value(Point2d)
precision(Int32)


WritePoint3d Method (opCode, value, precision)

WritePoint3d Method (opCode, value, precision)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WritePoint3d(DxfCode, Point3d, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WritePoint3d(
    DxfCode opCode,
    Point3d value,
    int precision
)
Public MustOverride Sub WritePoint3d ( _
    opCode As DxfCode, _
    value As Point3d, _
    precision As Integer _
)
public:
virtual void WritePoint3d(
    DxfCode opCode,
    Point3d value,
    int precision
) abstract
Parameters
opCode(DxfCode)
value(Point3d)
precision(Int32)


WriteResultBuffer Method (buffer)

WriteResultBuffer Method (buffer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteResultBuffer(ResultBuffer)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteResultBuffer(
    ResultBuffer buffer
)
Public MustOverride Sub WriteResultBuffer ( _
    buffer As ResultBuffer _
)
public:
virtual void WriteResultBuffer(
    ResultBuffer^ buffer
) abstract
Parameters
buffer(ResultBuffer)


WriteScale3d Method (opCode, value, precision)

WriteScale3d Method (opCode, value, precision)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteScale3d(DxfCode, Scale3d, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteScale3d(
    DxfCode opCode,
    Scale3d value,
    int precision
)
Public MustOverride Sub WriteScale3d ( _
    opCode As DxfCode, _
    value As Scale3d, _
    precision As Integer _
)
public:
virtual void WriteScale3d(
    DxfCode opCode,
    Scale3d value,
    int precision
) abstract
Parameters
opCode(DxfCode)
value(Scale3d)
precision(Int32)


WriteString Method (opCode, value)

WriteString Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteString(DxfCode, String)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteString(
    DxfCode opCode,
    string value
)
Public MustOverride Sub WriteString ( _
    opCode As DxfCode, _
    value As String _
)
public:
virtual void WriteString(
    DxfCode opCode,
    String^ value
) abstract
Parameters
opCode(DxfCode)
value(String)


WriteUInt16 Method (opCode, value)

WriteUInt16 Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteUInt16(DxfCode, UInt16)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteUInt16(
    DxfCode opCode,
    ushort value
)
Public MustOverride Sub WriteUInt16 ( _
    opCode As DxfCode, _
    value As UShort _
)
public:
virtual void WriteUInt16(
    DxfCode opCode,
    unsigned short value
) abstract
Parameters
opCode(DxfCode)
value(UInt16)


WriteUInt32 Method (opCode, value)

WriteUInt32 Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteUInt32(DxfCode, UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteUInt32(
    DxfCode opCode,
    uint value
)
Public MustOverride Sub WriteUInt32 ( _
    opCode As DxfCode, _
    value As UInteger _
)
public:
virtual void WriteUInt32(
    DxfCode opCode,
    unsigned int value
) abstract
Parameters
opCode(DxfCode)
value(UInt32)


WriteUInt64 Method (opCode, value)

WriteUInt64 Method (opCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteUInt64(DxfCode, UInt64)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteUInt64(
    DxfCode opCode,
    ulong value
)
Public MustOverride Sub WriteUInt64 ( _
    opCode As DxfCode, _
    value As ULong _
)
public:
virtual void WriteUInt64(
    DxfCode opCode,
    unsigned long long value
) abstract
Parameters
opCode(DxfCode)
value(UInt64)


WriteVector2d Method (opCode, value, precision)

WriteVector2d Method (opCode, value, precision)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteVector2d(DxfCode, Vector2d, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteVector2d(
    DxfCode opCode,
    Vector2d value,
    int precision
)
Public MustOverride Sub WriteVector2d ( _
    opCode As DxfCode, _
    value As Vector2d, _
    precision As Integer _
)
public:
virtual void WriteVector2d(
    DxfCode opCode,
    Vector2d value,
    int precision
) abstract
Parameters
opCode(DxfCode)
value(Vector2d)
precision(Int32)


WriteVector3d Method (opCode, value, precision)

WriteVector3d Method (opCode, value, precision)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »WriteVector3d(DxfCode, Vector3d, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void WriteVector3d(
    DxfCode opCode,
    Vector3d value,
    int precision
)
Public MustOverride Sub WriteVector3d ( _
    opCode As DxfCode, _
    value As Vector3d, _
    precision As Integer _
)
public:
virtual void WriteVector3d(
    DxfCode opCode,
    Vector3d value,
    int precision
) abstract
Parameters
opCode(DxfCode)
value(Vector3d)
precision(Int32)


DynamicBlockReferenceProperty Class

DynamicBlockReferenceProperty Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferenceProperty
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDynBlockReferenceProperty")]
public sealed class DynamicBlockReferenceProperty
<WrapperAttribute("ZcDbDynBlockReferenceProperty")> _
Public NotInheritable Class DynamicBlockReferenceProperty
[WrapperAttribute(L"ZcDbDynBlockReferenceProperty")]
public ref class DynamicBlockReferenceProperty sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BlockId |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAllowedValues()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PropertyName |
 | PropertyTypeCode |
 | ReadOnly |
 | Show |
 | ToString()()()() | (Inherited from Object.)
 | UnitsType |
 | Value |
Inheritance Hierarchy
Object
DynamicBlockReferenceProperty


BlockId Property

BlockId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferenceProperty »BlockId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockId { get; }
Public ReadOnly Property BlockId As ObjectId
    Get
public:
property ObjectId BlockId {
    ObjectId get ();
}


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferenceProperty »Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}


GetAllowedValues Method

GetAllowedValues Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferenceProperty »GetAllowedValues()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Object[] GetAllowedValues()
Public Function GetAllowedValues As Object()
public:
array<Object^>^ GetAllowedValues()


PropertyName Property

PropertyName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferenceProperty »PropertyName
Declaration Syntax
C# Visual Basic Visual C++
public string PropertyName { get; }
Public ReadOnly Property PropertyName As String
    Get
public:
property String^ PropertyName {
    String^ get ();
}


PropertyTypeCode Property

PropertyTypeCode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferenceProperty »PropertyTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public short PropertyTypeCode { get; }
Public ReadOnly Property PropertyTypeCode As Short
    Get
public:
property short PropertyTypeCode {
    short get ();
}


ReadOnly Property

ReadOnly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferenceProperty »ReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
property bool ReadOnly {
    bool get ();
}


Show Property

Show Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferenceProperty »Show
Declaration Syntax
C# Visual Basic Visual C++
public bool Show { get; }
Public ReadOnly Property Show As Boolean
    Get
public:
property bool Show {
    bool get ();
}


UnitsType Property

UnitsType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferenceProperty »UnitsType
Declaration Syntax
C# Visual Basic Visual C++
public DynamicBlockReferencePropertyUnitsType UnitsType { get; }
Public ReadOnly Property UnitsType As DynamicBlockReferencePropertyUnitsType
    Get
public:
property DynamicBlockReferencePropertyUnitsType UnitsType {
    DynamicBlockReferencePropertyUnitsType get ();
}


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferenceProperty »Value
Declaration Syntax
C# Visual Basic Visual C++
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}


DynamicBlockReferencePropertyCollection Class

DynamicBlockReferencePropertyCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDynBlockReferencePropertyArray")]
public sealed class DynamicBlockReferencePropertyCollection : DisposableWrapper,
    ICollection, IEnumerable
<WrapperAttribute("ZcDbDynBlockReferencePropertyArray")> _
Public NotInheritable Class DynamicBlockReferencePropertyCollection _
    Inherits DisposableWrapper _
    Implements ICollection, IEnumerable
[WrapperAttribute(L"ZcDbDynBlockReferencePropertyArray")]
public ref class DynamicBlockReferencePropertyCollection sealed : public DisposableWrapper,
    ICollection, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CopyTo(array<DynamicBlockReferenceProperty>[]()[][], Int32) |
 | CopyTo(Array, Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | DynamicBlockReferencePropertyCollection


CopyTo Method

CopyTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection »CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DynamicBlockReferenceProperty>[]()[][], Int32) |
 | CopyTo(Array, Int32) |


CopyTo Method (a, index)

CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection »CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
internal void CopyTo(
    Array a,
    int index
)
Friend Sub CopyTo ( _
    a As Array, _
    index As Integer _
)
internal:
virtual void CopyTo(
    Array^ a,
    int index
) sealed
Parameters
a(Array)
index(Int32)


CopyTo Method (a, index)

CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection »CopyTo(array<DynamicBlockReferenceProperty>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DynamicBlockReferenceProperty[] a,
    int index
)
Public Sub CopyTo ( _
    a As DynamicBlockReferenceProperty(), _
    index As Integer _
)
public:
void CopyTo(
    array<DynamicBlockReferenceProperty^>^ a,
    int index
)
Parameters
a(array< DynamicBlockReferenceProperty >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
internal virtual bool IsSynchronized { get; }
Friend Overridable ReadOnly Property IsSynchronized As Boolean
    Get
internal:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property ()

Item Property ()
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DynamicBlockReferenceProperty this[
    int
] { get; }
Public ReadOnly Default Property Item ( _
     As Integer _
) As DynamicBlockReferenceProperty
    Get
public:
property DynamicBlockReferenceProperty^ default[int ] {
    DynamicBlockReferenceProperty^ get (int );
}
Parameters
(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
internal virtual Object SyncRoot { get; }
Friend Overridable ReadOnly Property SyncRoot As Object
    Get
internal:
virtual property Object^ SyncRoot {
    Object^ get ();
}


DynamicBlockReferencePropertyCollectionEnumerator Class

DynamicBlockReferencePropertyCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DynamicBlockReferencePropertyCollectionEnumerator : IEnumerator
Public NotInheritable Class DynamicBlockReferencePropertyCollectionEnumerator _
    Implements IEnumerator
public ref class DynamicBlockReferencePropertyCollectionEnumerator sealed : IEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DynamicBlockReferencePropertyCollectionEnumerator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


DynamicBlockReferencePropertyUnitsType Enumeration

DynamicBlockReferencePropertyUnitsType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyUnitsType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDynBlockReferenceProperty::UnitsType")]
public enum DynamicBlockReferencePropertyUnitsType
<WrapperAttribute("ZcDbDynBlockReferenceProperty::UnitsType")> _
Public Enumeration DynamicBlockReferencePropertyUnitsType
[WrapperAttribute(L"ZcDbDynBlockReferenceProperty::UnitsType")]
public enum class DynamicBlockReferencePropertyUnitsType
Members
Member | Description
NoUnits |
Distance |
Angular |
Area |


DynamicDimensionChangedEventArgs Class

DynamicDimensionChangedEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionChangedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DynamicDimensionChangedEventArgs
Public NotInheritable Class DynamicDimensionChangedEventArgs
public ref class DynamicDimensionChangedEventArgs sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DynamicDimensionChangedEventArgs(Int32, Double) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Index |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
DynamicDimensionChangedEventArgs


DynamicDimensionChangedEventArgs Constructor (index, value)

DynamicDimensionChangedEventArgs Constructor (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionChangedEventArgs »DynamicDimensionChangedEventArgs(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public DynamicDimensionChangedEventArgs(
    int index,
    double value
)
Public Sub New ( _
    index As Integer, _
    value As Double _
)
public:
DynamicDimensionChangedEventArgs(
    int index,
    double value
)
Parameters
index(Int32)
value(Double)


Index Property

Index Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionChangedEventArgs »Index
Declaration Syntax
C# Visual Basic Visual C++
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionChangedEventArgs »Value
Declaration Syntax
C# Visual Basic Visual C++
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
public:
property double Value {
    double get ();
}


DynamicDimensionData Class

DynamicDimensionData Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDimData")]
public sealed class DynamicDimensionData : DisposableWrapper
<WrapperAttribute("ZcDbDimData")> _
Public NotInheritable Class DynamicDimensionData _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcDbDimData")]
public ref class DynamicDimensionData sealed : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DynamicDimensionData(Dimension, Boolean, Boolean) |
 | DynamicDimensionData(Dimension, Boolean) |
 | DynamicDimensionData(Dimension) |
 | DynamicDimensionData()()()() |
 | ApplicationData |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dimension |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Editable |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | Focal |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | HideIfValueIsZero |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Visible |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | DynamicDimensionData


DynamicDimensionData Constructor

DynamicDimensionData Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »DynamicDimensionData()()()()
Members
Icon | Member | Description
 | DynamicDimensionData(Dimension, Boolean, Boolean) |
 | DynamicDimensionData(Dimension, Boolean) |
 | DynamicDimensionData(Dimension) |
 | DynamicDimensionData()()()() |


DynamicDimensionData Constructor

DynamicDimensionData Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »DynamicDimensionData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DynamicDimensionData()
Public Sub New
public:
DynamicDimensionData()


DynamicDimensionData Constructor (dimension)

DynamicDimensionData Constructor (dimension)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »DynamicDimensionData(Dimension)
Declaration Syntax
C# Visual Basic Visual C++
public DynamicDimensionData(
    Dimension dimension
)
Public Sub New ( _
    dimension As Dimension _
)
public:
DynamicDimensionData(
    Dimension^ dimension
)
Parameters
dimension(Dimension)


DynamicDimensionData Constructor (dimension, editable)

DynamicDimensionData Constructor (dimension, editable)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »DynamicDimensionData(Dimension, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DynamicDimensionData(
    Dimension dimension,
    bool editable
)
Public Sub New ( _
    dimension As Dimension, _
    editable As Boolean _
)
public:
DynamicDimensionData(
    Dimension^ dimension,
    bool editable
)
Parameters
dimension(Dimension)
editable(Boolean)


DynamicDimensionData Constructor (dimension, editable, hideIfValueIsZero)

DynamicDimensionData Constructor (dimension, editable, hideIfValueIsZero)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »DynamicDimensionData(Dimension, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DynamicDimensionData(
    Dimension dimension,
    bool editable,
    bool hideIfValueIsZero
)
Public Sub New ( _
    dimension As Dimension, _
    editable As Boolean, _
    hideIfValueIsZero As Boolean _
)
public:
DynamicDimensionData(
    Dimension^ dimension,
    bool editable,
    bool hideIfValueIsZero
)
Parameters
dimension(Dimension)
editable(Boolean)
hideIfValueIsZero(Boolean)


ApplicationData Property

ApplicationData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »ApplicationData
Declaration Syntax
C# Visual Basic Visual C++
public Object ApplicationData { get; set; }
Public Property ApplicationData As Object
    Get
    Set
public:
property Object^ ApplicationData {
    Object^ get ();
    void set (Object^ value);
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static DynamicDimensionData Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As DynamicDimensionData
public:
static DynamicDimensionData^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Dimension Property

Dimension Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »Dimension
Declaration Syntax
C# Visual Basic Visual C++
public Dimension Dimension { get; set; }
Public Property Dimension As Dimension
    Get
    Set
public:
property Dimension^ Dimension {
    Dimension^ get ();
    void set (Dimension^ value);
}


Editable Property

Editable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »Editable
Declaration Syntax
C# Visual Basic Visual C++
public bool Editable { get; set; }
Public Property Editable As Boolean
    Get
    Set
public:
property bool Editable {
    bool get ();
    void set (bool value);
}


Focal Property

Focal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »Focal
Declaration Syntax
C# Visual Basic Visual C++
public bool Focal { get; set; }
Public Property Focal As Boolean
    Get
    Set
public:
property bool Focal {
    bool get ();
    void set (bool value);
}


HideIfValueIsZero Property

HideIfValueIsZero Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »HideIfValueIsZero
Declaration Syntax
C# Visual Basic Visual C++
public bool HideIfValueIsZero { get; set; }
Public Property HideIfValueIsZero As Boolean
    Get
    Set
public:
property bool HideIfValueIsZero {
    bool get ();
    void set (bool value);
}


Visible Property

Visible Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »Visible
Declaration Syntax
C# Visual Basic Visual C++
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}


DynamicDimensionDataCollection Class

DynamicDimensionDataCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DynamicDimensionDataCollection : DisposableWrapper,
    ICollection
Public NotInheritable Class DynamicDimensionDataCollection _
    Inherits DisposableWrapper _
    Implements ICollection
public ref class DynamicDimensionDataCollection sealed : public DisposableWrapper,
    ICollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DynamicDimensionDataCollection()()()() |
 | Add(DynamicDimensionData) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | CopyTo(array<DynamicDimensionData>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RemoveAt(Int32) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | DynamicDimensionDataCollection


DynamicDimensionDataCollection Constructor

DynamicDimensionDataCollection Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »DynamicDimensionDataCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DynamicDimensionDataCollection()
Public Sub New
public:
DynamicDimensionDataCollection()


Add Method (data)

Add Method (data)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »Add(DynamicDimensionData)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DynamicDimensionData data
)
Public Function Add ( _
    data As DynamicDimensionData _
) As Integer
public:
int Add(
    DynamicDimensionData^ data
)
Parameters
data(DynamicDimensionData)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »CopyTo(array<DynamicDimensionData>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DynamicDimensionData[] arr,
    int index
)
Public Sub CopyTo ( _
    arr As DynamicDimensionData(), _
    index As Integer _
)
public:
void CopyTo(
    array<DynamicDimensionData^>^ arr,
    int index
)
Parameters
arr(array< DynamicDimensionData >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (arr, index)

ICollectionCopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array arr,
    int index
)
Private Sub ICollectionCopyTo ( _
    arr As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ arr,
    int index
) sealed = ICollection::CopyTo
Parameters
arr(Array)
index(Int32)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DynamicDimensionData this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DynamicDimensionData
    Get
    Set
public:
property DynamicDimensionData^ default[int index] {
    DynamicDimensionData^ get (int index);
    void set (int index, DynamicDimensionData^ value);
}
Parameters
index(Int32)


RemoveAt Method (i)

RemoveAt Method (i)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int i
)
Public Sub RemoveAt ( _
    i As Integer _
)
public:
void RemoveAt(
    int i
)
Parameters
i(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


Ellipse Class

Ellipse Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbEllipse")]
public class Ellipse : Curve
<WrapperAttribute("AcDbEllipse")> _
Public Class Ellipse _
    Inherits Curve
[WrapperAttribute(L"AcDbEllipse")]
public ref class Ellipse : public Curve
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ellipse(Point3d, Vector3d, Vector3d, Double, Double, Double) |
 | Ellipse(IntPtr, Boolean) |
 | Ellipse()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | Center |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed | (Inherited from Curve.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EndAngle |
 | EndParam | (Overrides Curve.EndParam.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetAngleAtParameter(Double) |
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtAngle(Double) |
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsNull |
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | MajorAxis |
 | MajorRadius |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | MinorAxis |
 | MinorRadius |
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RadiusRatio |
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | Set(Point3d, Vector3d, Vector3d, Double, Double, Double) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Spline | (Inherited from Curve.)
 | StartAngle |
 | StartParam | (Overrides Curve.StartParam.)
 | StartPoint | (Inherited from Curve.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Ellipse


Ellipse Constructor

Ellipse Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Ellipse()()()()
Members
Icon | Member | Description
 | Ellipse(Point3d, Vector3d, Vector3d, Double, Double, Double) |
 | Ellipse(IntPtr, Boolean) |
 | Ellipse()()()() |


Ellipse Constructor

Ellipse Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Ellipse()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Ellipse()
Public Sub New
public:
Ellipse()


Ellipse Constructor (unmanagedObjPtr, autoDelete)

Ellipse Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Ellipse(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Ellipse(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Ellipse(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Ellipse Constructor (center, unitNormal, majorAxis, radiusRatio, startAngle, endAngle)

Ellipse Constructor (center, unitNormal, majorAxis, radiusRatio, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Ellipse(Point3d, Vector3d, Vector3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Ellipse(
    Point3d center,
    Vector3d unitNormal,
    Vector3d majorAxis,
    double radiusRatio,
    double startAngle,
    double endAngle
)
Public Sub New ( _
    center As Point3d, _
    unitNormal As Vector3d, _
    majorAxis As Vector3d, _
    radiusRatio As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
Ellipse(
    Point3d center,
    Vector3d unitNormal,
    Vector3d majorAxis,
    double radiusRatio,
    double startAngle,
    double endAngle
)
Parameters
center(Point3d)
unitNormal(Vector3d)
majorAxis(Vector3d)
radiusRatio(Double)
startAngle(Double)
endAngle(Double)


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Center { get; set; }
Public Property Center As Point3d
    Get
    Set
public:
property Point3d Center {
    Point3d get ();
    void set (Point3d value);
}


EndAngle Property

EndAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »EndAngle
Declaration Syntax
C# Visual Basic Visual C++
public double EndAngle { get; set; }
Public Property EndAngle As Double
    Get
    Set
public:
property double EndAngle {
    double get ();
    void set (double value);
}


EndParam Property

EndParam Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »EndParam
Declaration Syntax
C# Visual Basic Visual C++
public override double EndParam { get; set; }
Public Overrides Property EndParam As Double
    Get
    Set
public:
virtual property double EndParam {
    double get () override;
    void set (double value) override;
}


GetAngleAtParameter Method (value)

GetAngleAtParameter Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetAngleAtParameter(Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetAngleAtParameter(
    double value
)
Public Function GetAngleAtParameter ( _
    value As Double _
) As Double
public:
double GetAngleAtParameter(
    double value
)
Parameters
value(Double)


GetParameterAtAngle Method (angle)

GetParameterAtAngle Method (angle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetParameterAtAngle(Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetParameterAtAngle(
    double angle
)
Public Function GetParameterAtAngle ( _
    angle As Double _
) As Double
public:
double GetParameterAtAngle(
    double angle
)
Parameters
angle(Double)


IsNull Property

IsNull Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »IsNull
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNull { get; }
Public ReadOnly Property IsNull As Boolean
    Get
public:
property bool IsNull {
    bool get ();
}


MajorAxis Property

MajorAxis Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »MajorAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d MajorAxis { get; }
Public ReadOnly Property MajorAxis As Vector3d
    Get
public:
property Vector3d MajorAxis {
    Vector3d get ();
}


MajorRadius Property

MajorRadius Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »MajorRadius
Declaration Syntax
C# Visual Basic Visual C++
public double MajorRadius { get; }
Public ReadOnly Property MajorRadius As Double
    Get
public:
property double MajorRadius {
    double get ();
}


MinorAxis Property

MinorAxis Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »MinorAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d MinorAxis { get; }
Public ReadOnly Property MinorAxis As Vector3d
    Get
public:
property Vector3d MinorAxis {
    Vector3d get ();
}


MinorRadius Property

MinorRadius Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »MinorRadius
Declaration Syntax
C# Visual Basic Visual C++
public double MinorRadius { get; }
Public ReadOnly Property MinorRadius As Double
    Get
public:
property double MinorRadius {
    double get ();
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; }
Public ReadOnly Property Normal As Vector3d
    Get
public:
property Vector3d Normal {
    Vector3d get ();
}


RadiusRatio Property

RadiusRatio Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »RadiusRatio
Declaration Syntax
C# Visual Basic Visual C++
public double RadiusRatio { get; set; }
Public Property RadiusRatio As Double
    Get
    Set
public:
property double RadiusRatio {
    double get ();
    void set (double value);
}


Set Method (center, unitNormal, majorAxis, radiusRatio, startAngle, endAngle)

Set Method (center, unitNormal, majorAxis, radiusRatio, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Set(Point3d, Vector3d, Vector3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d center,
    Vector3d unitNormal,
    Vector3d majorAxis,
    double radiusRatio,
    double startAngle,
    double endAngle
)
Public Sub Set ( _
    center As Point3d, _
    unitNormal As Vector3d, _
    majorAxis As Vector3d, _
    radiusRatio As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
void Set(
    Point3d center,
    Vector3d unitNormal,
    Vector3d majorAxis,
    double radiusRatio,
    double startAngle,
    double endAngle
)
Parameters
center(Point3d)
unitNormal(Vector3d)
majorAxis(Vector3d)
radiusRatio(Double)
startAngle(Double)
endAngle(Double)


StartAngle Property

StartAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »StartAngle
Declaration Syntax
C# Visual Basic Visual C++
public double StartAngle { get; set; }
Public Property StartAngle As Double
    Get
    Set
public:
property double StartAngle {
    double get ();
    void set (double value);
}


StartParam Property

StartParam Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »StartParam
Declaration Syntax
C# Visual Basic Visual C++
public override double StartParam { get; set; }
Public Overrides Property StartParam As Double
    Get
    Set
public:
virtual property double StartParam {
    double get () override;
    void set (double value) override;
}


EndCap Enumeration

EndCap Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »EndCap
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::EndCaps")]
public enum EndCap
<WrapperAttribute("ZcDb::EndCaps")> _
Public Enumeration EndCap
[WrapperAttribute(L"ZcDb::EndCaps")]
public enum class EndCap
Members
Member | Description
Round |
None |
Square |
Angle |


Entity Class

Entity Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbEntity")]
public abstract class Entity : DBObject
<WrapperAttribute("AcDbEntity")> _
Public MustInherit Class Entity _
    Inherits DBObject
[WrapperAttribute(L"AcDbEntity")]
public ref class Entity abstract : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Entity(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId |
 | BlockName |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging |
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType |
 | Color |
 | ColorIndex |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) |
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() |
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs |
 | EdgeStyleId |
 | EntityColor |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) |
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible |
 | GeometricExtents |
 | GeomExtents |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) |
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() |
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) |
 | GetSubentity(FullSubentityPath) |
 | GetSubentityGeometricExtents(FullSubentityPath) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.
 | GetTransformedCopy(Matrix3d) |
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |
 | Hyperlinks |
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar |
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer |
 | LayerId |
 | Linetype |
 | LinetypeId |
 | LinetypeScale |
 | LineWeight |
 | List()()()() |
 | Material |
 | MaterialId |
 | MaterialMapper |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveStretchPointsAt(IntegerCollection, Vector3d) |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName |
 | PlotStyleNameId |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows |
 | RecordGraphicsModified(Boolean) |
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |
 | SetDragStatus(DragStatus) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) |
 | SetLayerId(ObjectId, Boolean) |
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) |
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) |
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) |
 | Transparency |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible |
 | VisualStyleId |
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | BlockBegin
 |  |  |  |  |  |  | BlockEnd
 |  |  |  |  |  |  | BlockReference
 |  |  |  |  |  |  | Body
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  | DBPoint
 |  |  |  |  |  |  | DBText
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  | Face
 |  |  |  |  |  |  | FeatureControlFrame
 |  |  |  |  |  |  | Hatch
 |  |  |  |  |  |  | Image
 |  |  |  |  |  |  | MLeader
 |  |  |  |  |  |  | Mline
 |  |  |  |  |  |  | MText
 |  |  |  |  |  |  | Ole2Frame
 |  |  |  |  |  |  | PolyFaceMesh
 |  |  |  |  |  |  | PolygonMesh
 |  |  |  |  |  |  | ProxyEntity
 |  |  |  |  |  |  | Region
 |  |  |  |  |  |  | Section
 |  |  |  |  |  |  | SequenceEnd
 |  |  |  |  |  |  | Shape
 |  |  |  |  |  |  | Solid
 |  |  |  |  |  |  | Solid3d
 |  |  |  |  |  |  | Surface
 |  |  |  |  |  |  | Trace
 |  |  |  |  |  |  | UnderlayReference
 |  |  |  |  |  |  | Vertex
 |  |  |  |  |  |  | Viewport


Entity Constructor (unmanagedObjPtr, autoDelete)

Entity Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Entity(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Entity(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Entity(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AddSubentityPaths Method (subPaths)

AddSubentityPaths Method (subPaths)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »AddSubentityPaths(array<FullSubentityPath>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddSubentityPaths(
    FullSubentityPath[] subPaths
)
Public Overridable Sub AddSubentityPaths ( _
    subPaths As FullSubentityPath() _
)
public:
virtual void AddSubentityPaths(
    array<FullSubentityPath>^ subPaths
)
Parameters
subPaths(array< FullSubentityPath >[]()[][])


BlockId Property

BlockId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »BlockId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockId { get; }
Public ReadOnly Property BlockId As ObjectId
    Get
public:
property ObjectId BlockId {
    ObjectId get ();
}


BlockName Property

BlockName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »BlockName
Declaration Syntax
C# Visual Basic Visual C++
public string BlockName { get; }
Public ReadOnly Property BlockName As String
    Get
public:
property String^ BlockName {
    String^ get ();
}


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


BoundingBoxIntersectWith Method (entityPointer, intersectType, projectionPlane, points, thisGraphicSystemMarker, otherGraphicSystemMarker)

BoundingBoxIntersectWith Method (entityPointer, intersectType, projectionPlane, points, thisGraphicSystemMarker, otherGraphicSystemMarker)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use the overload taking IntPtr instead.")]
public void BoundingBoxIntersectWith(
    Entity entityPointer,
    Intersect intersectType,
    Plane projectionPlane,
    Point3dCollection points,
    int thisGraphicSystemMarker,
    int otherGraphicSystemMarker
)
<ObsoleteAttribute("Use the overload taking IntPtr instead.")> _
Public Sub BoundingBoxIntersectWith ( _
    entityPointer As Entity, _
    intersectType As Intersect, _
    projectionPlane As Plane, _
    points As Point3dCollection, _
    thisGraphicSystemMarker As Integer, _
    otherGraphicSystemMarker As Integer _
)
[ObsoleteAttribute(L"Use the overload taking IntPtr instead.")]
public:
void BoundingBoxIntersectWith(
    Entity^ entityPointer,
    Intersect intersectType,
    Plane^ projectionPlane,
    Point3dCollection^ points,
    int thisGraphicSystemMarker,
    int otherGraphicSystemMarker
)
Parameters
entityPointer(Entity)
intersectType(Intersect)
projectionPlane(Plane)
points(Point3dCollection)
thisGraphicSystemMarker(Int32)
otherGraphicSystemMarker(Int32)


BoundingBoxIntersectWith Method (entityPointer, intersectType, projectionPlane, points, thisGraphicSystemMarker, otherGraphicSystemMarker)

BoundingBoxIntersectWith Method (entityPointer, intersectType, projectionPlane, points, thisGraphicSystemMarker, otherGraphicSystemMarker)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void BoundingBoxIntersectWith(
    Entity entityPointer,
    Intersect intersectType,
    Plane projectionPlane,
    Point3dCollection points,
    IntPtr thisGraphicSystemMarker,
    IntPtr otherGraphicSystemMarker
)
Public Sub BoundingBoxIntersectWith ( _
    entityPointer As Entity, _
    intersectType As Intersect, _
    projectionPlane As Plane, _
    points As Point3dCollection, _
    thisGraphicSystemMarker As IntPtr, _
    otherGraphicSystemMarker As IntPtr _
)
public:
void BoundingBoxIntersectWith(
    Entity^ entityPointer,
    Intersect intersectType,
    Plane^ projectionPlane,
    Point3dCollection^ points,
    IntPtr thisGraphicSystemMarker,
    IntPtr otherGraphicSystemMarker
)
Parameters
entityPointer(Entity)
intersectType(Intersect)
projectionPlane(Plane)
points(Point3dCollection)
thisGraphicSystemMarker(IntPtr)
otherGraphicSystemMarker(IntPtr)


BoundingBoxIntersectWith Method (entityPointer, intersectType, points, thisGraphicSystemMarker, otherGraphicSystemMarker)

BoundingBoxIntersectWith Method (entityPointer, intersectType, points, thisGraphicSystemMarker, otherGraphicSystemMarker)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use the overload taking IntPtr instead.")]
public void BoundingBoxIntersectWith(
    Entity entityPointer,
    Intersect intersectType,
    Point3dCollection points,
    int thisGraphicSystemMarker,
    int otherGraphicSystemMarker
)
<ObsoleteAttribute("Use the overload taking IntPtr instead.")> _
Public Sub BoundingBoxIntersectWith ( _
    entityPointer As Entity, _
    intersectType As Intersect, _
    points As Point3dCollection, _
    thisGraphicSystemMarker As Integer, _
    otherGraphicSystemMarker As Integer _
)
[ObsoleteAttribute(L"Use the overload taking IntPtr instead.")]
public:
void BoundingBoxIntersectWith(
    Entity^ entityPointer,
    Intersect intersectType,
    Point3dCollection^ points,
    int thisGraphicSystemMarker,
    int otherGraphicSystemMarker
)
Parameters
entityPointer(Entity)
intersectType(Intersect)
points(Point3dCollection)
thisGraphicSystemMarker(Int32)
otherGraphicSystemMarker(Int32)


BoundingBoxIntersectWith Method (entityPointer, intersectType, points, thisGraphicSystemMarker, otherGraphicSystemMarker)

BoundingBoxIntersectWith Method (entityPointer, intersectType, points, thisGraphicSystemMarker, otherGraphicSystemMarker)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void BoundingBoxIntersectWith(
    Entity entityPointer,
    Intersect intersectType,
    Point3dCollection points,
    IntPtr thisGraphicSystemMarker,
    IntPtr otherGraphicSystemMarker
)
Public Sub BoundingBoxIntersectWith ( _
    entityPointer As Entity, _
    intersectType As Intersect, _
    points As Point3dCollection, _
    thisGraphicSystemMarker As IntPtr, _
    otherGraphicSystemMarker As IntPtr _
)
public:
void BoundingBoxIntersectWith(
    Entity^ entityPointer,
    Intersect intersectType,
    Point3dCollection^ points,
    IntPtr thisGraphicSystemMarker,
    IntPtr otherGraphicSystemMarker
)
Parameters
entityPointer(Entity)
intersectType(Intersect)
points(Point3dCollection)
thisGraphicSystemMarker(IntPtr)
otherGraphicSystemMarker(IntPtr)


CastShadows Property

CastShadows Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »CastShadows
Declaration Syntax
C# Visual Basic Visual C++
public bool CastShadows { get; set; }
Public Property CastShadows As Boolean
    Get
    Set
public:
property bool CastShadows {
    bool get ();
    void set (bool value);
}


CloneMeForDragging Property

CloneMeForDragging Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »CloneMeForDragging
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool CloneMeForDragging { get; }
Public Overridable ReadOnly Property CloneMeForDragging As Boolean
    Get
public:
virtual property bool CloneMeForDragging {
    bool get ();
}


CollisionType Property

CollisionType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »CollisionType
Declaration Syntax
C# Visual Basic Visual C++
public virtual CollisionType CollisionType { get; }
Public Overridable ReadOnly Property CollisionType As CollisionType
    Get
public:
virtual property CollisionType CollisionType {
    CollisionType get ();
}


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Color
Declaration Syntax
C# Visual Basic Visual C++
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}


ColorIndex Property

ColorIndex Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »ColorIndex
Declaration Syntax
C# Visual Basic Visual C++
public int ColorIndex { get; set; }
Public Property ColorIndex As Integer
    Get
    Set
public:
property int ColorIndex {
    int get ();
    void set (int value);
}


CompoundObjectTransform Property

CompoundObjectTransform Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »CompoundObjectTransform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d CompoundObjectTransform { get; }
Public ReadOnly Property CompoundObjectTransform As Matrix3d
    Get
public:
property Matrix3d CompoundObjectTransform {
    Matrix3d get ();
}


DeleteSubentityPaths Method (subPaths)

DeleteSubentityPaths Method (subPaths)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »DeleteSubentityPaths(array<FullSubentityPath>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DeleteSubentityPaths(
    FullSubentityPath[] subPaths
)
Public Overridable Sub DeleteSubentityPaths ( _
    subPaths As FullSubentityPath() _
)
public:
virtual void DeleteSubentityPaths(
    array<FullSubentityPath>^ subPaths
)
Parameters
subPaths(array< FullSubentityPath >[]()[][])


Draw Method

Draw Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Draw()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Draw()
Public Sub Draw
public:
void Draw()


Ecs Property

Ecs Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Ecs
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d Ecs { get; }
Public ReadOnly Property Ecs As Matrix3d
    Get
public:
property Matrix3d Ecs {
    Matrix3d get ();
}


EdgeStyleId Property

EdgeStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »EdgeStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId EdgeStyleId { get; set; }
Public Property EdgeStyleId As ObjectId
    Get
    Set
public:
property ObjectId EdgeStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


EntityColor Property

EntityColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »EntityColor
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor EntityColor { get; }
Public ReadOnly Property EntityColor As EntityColor
    Get
public:
property EntityColor EntityColor {
    EntityColor get ();
}


Explode Method (entitySet)

Explode Method (entitySet)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Explode(DBObjectCollection)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Explode(
    DBObjectCollection entitySet
)
Public Overridable Sub Explode ( _
    entitySet As DBObjectCollection _
)
public:
virtual void Explode(
    DBObjectCollection^ entitySet
)
Parameters
entitySet(DBObjectCollection)


FaceStyleId Property

FaceStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »FaceStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId FaceStyleId { get; set; }
Public Property FaceStyleId As ObjectId
    Get
    Set
public:
property ObjectId FaceStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


ForceAnnoAllVisible Property

ForceAnnoAllVisible Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »ForceAnnoAllVisible
Declaration Syntax
C# Visual Basic Visual C++
public bool ForceAnnoAllVisible { get; set; }
Public Property ForceAnnoAllVisible As Boolean
    Get
    Set
public:
property bool ForceAnnoAllVisible {
    bool get ();
    void set (bool value);
}


GeometricExtents Property

GeometricExtents Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GeometricExtents
Declaration Syntax
C# Visual Basic Visual C++
public Extents3d GeometricExtents { get; }
Public ReadOnly Property GeometricExtents As Extents3d
    Get
public:
property Extents3d GeometricExtents {
    Extents3d get ();
}


GeomExtents Property

GeomExtents Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GeomExtents
Declaration Syntax
C# Visual Basic Visual C++
public virtual Extents3d GeomExtents { get; }
Public Overridable ReadOnly Property GeomExtents As Extents3d
    Get
public:
virtual property Extents3d GeomExtents {
    Extents3d get ();
}


GetGraphicsMarkersAtSubentityPathIntPtr Method (subPath)

GetGraphicsMarkersAtSubentityPathIntPtr Method (subPath)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath)
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtrCollection GetGraphicsMarkersAtSubentityPathIntPtr(
    FullSubentityPath subPath
)
Public Overridable Function GetGraphicsMarkersAtSubentityPathIntPtr ( _
    subPath As FullSubentityPath _
) As IntPtrCollection
public:
virtual IntPtrCollection^ GetGraphicsMarkersAtSubentityPathIntPtr(
    FullSubentityPath subPath
)
Parameters
subPath(FullSubentityPath)


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetGripPoints Method (grips, curViewUnitSize, gripSize, curViewDir, bitFlags)

GetGripPoints Method (grips, curViewUnitSize, gripSize, curViewDir, bitFlags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool GetGripPoints(
    GripDataCollection grips,
    double curViewUnitSize,
    int gripSize,
    Vector3d curViewDir,
    GetGripPointsFlags bitFlags
)
Public Overridable Function GetGripPoints ( _
    grips As GripDataCollection, _
    curViewUnitSize As Double, _
    gripSize As Integer, _
    curViewDir As Vector3d, _
    bitFlags As GetGripPointsFlags _
) As Boolean
public:
virtual bool GetGripPoints(
    GripDataCollection^ grips,
    double curViewUnitSize,
    int gripSize,
    Vector3d curViewDir,
    GetGripPointsFlags bitFlags
)
Parameters
grips(GripDataCollection)
curViewUnitSize(Double)
gripSize(Int32)
curViewDir(Vector3d)
bitFlags(GetGripPointsFlags)


GetGripPoints Method (gripPoints, snapModes, geometryIds)

GetGripPoints Method (gripPoints, snapModes, geometryIds)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetGripPoints(
    Point3dCollection gripPoints,
    IntegerCollection snapModes,
    IntegerCollection geometryIds
)
Public Overridable Sub GetGripPoints ( _
    gripPoints As Point3dCollection, _
    snapModes As IntegerCollection, _
    geometryIds As IntegerCollection _
)
public:
virtual void GetGripPoints(
    Point3dCollection^ gripPoints,
    IntegerCollection^ snapModes,
    IntegerCollection^ geometryIds
)
Parameters
gripPoints(Point3dCollection)
snapModes(IntegerCollection)
geometryIds(IntegerCollection)


GetGripPointsAtSubentityPath Method (subPath, grips, curViewUnitSize, gripSize, curViewDir, bitFlags)

GetGripPointsAtSubentityPath Method (subPath, grips, curViewUnitSize, gripSize, curViewDir, bitFlags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool GetGripPointsAtSubentityPath(
    FullSubentityPath subPath,
    GripDataCollection grips,
    double curViewUnitSize,
    int gripSize,
    Vector3d curViewDir,
    GetGripPointsFlags bitFlags
)
Public Overridable Function GetGripPointsAtSubentityPath ( _
    subPath As FullSubentityPath, _
    grips As GripDataCollection, _
    curViewUnitSize As Double, _
    gripSize As Integer, _
    curViewDir As Vector3d, _
    bitFlags As GetGripPointsFlags _
) As Boolean
public:
virtual bool GetGripPointsAtSubentityPath(
    FullSubentityPath subPath,
    GripDataCollection^ grips,
    double curViewUnitSize,
    int gripSize,
    Vector3d curViewDir,
    GetGripPointsFlags bitFlags
)
Parameters
subPath(FullSubentityPath)
grips(GripDataCollection)
curViewUnitSize(Double)
gripSize(Int32)
curViewDir(Vector3d)
bitFlags(GetGripPointsFlags)


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetObjectSnapPoints Method (snapMode, gsSelectionMark, pickPoint, lastPoint, viewTransform, snapPoints, geometryIds)

GetObjectSnapPoints Method (snapMode, gsSelectionMark, pickPoint, lastPoint, viewTransform, snapPoints, geometryIds)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectSnapPoints(
    ObjectSnapModes snapMode,
    int gsSelectionMark,
    Point3d pickPoint,
    Point3d lastPoint,
    Matrix3d viewTransform,
    Point3dCollection snapPoints,
    IntegerCollection geometryIds
)
Public Overridable Sub GetObjectSnapPoints ( _
    snapMode As ObjectSnapModes, _
    gsSelectionMark As Integer, _
    pickPoint As Point3d, _
    lastPoint As Point3d, _
    viewTransform As Matrix3d, _
    snapPoints As Point3dCollection, _
    geometryIds As IntegerCollection _
)
public:
virtual void GetObjectSnapPoints(
    ObjectSnapModes snapMode,
    int gsSelectionMark,
    Point3d pickPoint,
    Point3d lastPoint,
    Matrix3d viewTransform,
    Point3dCollection^ snapPoints,
    IntegerCollection^ geometryIds
)
Parameters
snapMode(ObjectSnapModes)
gsSelectionMark(Int32)
pickPoint(Point3d)
lastPoint(Point3d)
viewTransform(Matrix3d)
snapPoints(Point3dCollection)
geometryIds(IntegerCollection)


GetObjectSnapPoints Method (snapMode, gsSelectionMark, pickPoint, lastPoint, viewTransform, snapPoints, geometryIds, insertionMat)

GetObjectSnapPoints Method (snapMode, gsSelectionMark, pickPoint, lastPoint, viewTransform, snapPoints, geometryIds, insertionMat)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectSnapPoints(
    ObjectSnapModes snapMode,
    int gsSelectionMark,
    Point3d pickPoint,
    Point3d lastPoint,
    Matrix3d viewTransform,
    Point3dCollection snapPoints,
    IntegerCollection geometryIds,
    Matrix3d insertionMat
)
Public Overridable Sub GetObjectSnapPoints ( _
    snapMode As ObjectSnapModes, _
    gsSelectionMark As Integer, _
    pickPoint As Point3d, _
    lastPoint As Point3d, _
    viewTransform As Matrix3d, _
    snapPoints As Point3dCollection, _
    geometryIds As IntegerCollection, _
    insertionMat As Matrix3d _
)
public:
virtual void GetObjectSnapPoints(
    ObjectSnapModes snapMode,
    int gsSelectionMark,
    Point3d pickPoint,
    Point3d lastPoint,
    Matrix3d viewTransform,
    Point3dCollection^ snapPoints,
    IntegerCollection^ geometryIds,
    Matrix3d insertionMat
)
Parameters
snapMode(ObjectSnapModes)
gsSelectionMark(Int32)
pickPoint(Point3d)
lastPoint(Point3d)
viewTransform(Matrix3d)
snapPoints(Point3dCollection)
geometryIds(IntegerCollection)
insertionMat(Matrix3d)


GetPlane Method

GetPlane Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetPlane()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Plane GetPlane()
Public Overridable Function GetPlane As Plane
public:
virtual Plane^ GetPlane()


GetStretchPoints Method (stretchPoints)

GetStretchPoints Method (stretchPoints)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetStretchPoints(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetStretchPoints(
    Point3dCollection stretchPoints
)
Public Overridable Sub GetStretchPoints ( _
    stretchPoints As Point3dCollection _
)
public:
virtual void GetStretchPoints(
    Point3dCollection^ stretchPoints
)
Parameters
stretchPoints(Point3dCollection)


GetSubentity Method (id)

GetSubentity Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetSubentity(FullSubentityPath)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Entity GetSubentity(
    FullSubentityPath id
)
Public Overridable Function GetSubentity ( _
    id As FullSubentityPath _
) As Entity
public:
virtual Entity^ GetSubentity(
    FullSubentityPath id
)
Parameters
id(FullSubentityPath)


GetSubentityGeometricExtents Method (subPath)

GetSubentityGeometricExtents Method (subPath)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetSubentityGeometricExtents(FullSubentityPath)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Extents3d GetSubentityGeometricExtents(
    FullSubentityPath subPath
)
Public Overridable Function GetSubentityGeometricExtents ( _
    subPath As FullSubentityPath _
) As Extents3d
public:
virtual Extents3d GetSubentityGeometricExtents(
    FullSubentityPath subPath
)
Parameters
subPath(FullSubentityPath)


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetSubentityPathsAtGraphicsMarker Method (type, gsMark, pickPoint, viewTransform, numInserts, entityAndInsertStack)

GetSubentityPathsAtGraphicsMarker Method (type, gsMark, pickPoint, viewTransform, numInserts, entityAndInsertStack)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use the overload taking IntPtr instead.")]
public virtual FullSubentityPath[] GetSubentityPathsAtGraphicsMarker(
    SubentityType type,
    int gsMark,
    Point3d pickPoint,
    Matrix3d viewTransform,
    int numInserts,
    ObjectId[] entityAndInsertStack
)
<ObsoleteAttribute("Use the overload taking IntPtr instead.")> _
Public Overridable Function GetSubentityPathsAtGraphicsMarker ( _
    type As SubentityType, _
    gsMark As Integer, _
    pickPoint As Point3d, _
    viewTransform As Matrix3d, _
    numInserts As Integer, _
    entityAndInsertStack As ObjectId() _
) As FullSubentityPath()
[ObsoleteAttribute(L"Use the overload taking IntPtr instead.")]
public:
virtual array<FullSubentityPath>^ GetSubentityPathsAtGraphicsMarker(
    SubentityType type,
    int gsMark,
    Point3d pickPoint,
    Matrix3d viewTransform,
    int numInserts,
    array<ObjectId>^ entityAndInsertStack
)
Parameters
type(SubentityType)
gsMark(Int32)
pickPoint(Point3d)
viewTransform(Matrix3d)
numInserts(Int32)
entityAndInsertStack(array< ObjectId >[]()[][])


GetSubentityPathsAtGraphicsMarker Method (type, gsMark, pickPoint, viewTransform, entityAndInsertStack)

GetSubentityPathsAtGraphicsMarker Method (type, gsMark, pickPoint, viewTransform, entityAndInsertStack)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual FullSubentityPath[] GetSubentityPathsAtGraphicsMarker(
    SubentityType type,
    IntPtr gsMark,
    Point3d pickPoint,
    Matrix3d viewTransform,
    ObjectId[] entityAndInsertStack
)
Public Overridable Function GetSubentityPathsAtGraphicsMarker ( _
    type As SubentityType, _
    gsMark As IntPtr, _
    pickPoint As Point3d, _
    viewTransform As Matrix3d, _
    entityAndInsertStack As ObjectId() _
) As FullSubentityPath()
public:
virtual array<FullSubentityPath>^ GetSubentityPathsAtGraphicsMarker(
    SubentityType type,
    IntPtr gsMark,
    Point3d pickPoint,
    Matrix3d viewTransform,
    array<ObjectId>^ entityAndInsertStack
)
Parameters
type(SubentityType)
gsMark(IntPtr)
pickPoint(Point3d)
viewTransform(Matrix3d)
entityAndInsertStack(array< ObjectId >[]()[][])


GetTransformedCopy Method (transform)

GetTransformedCopy Method (transform)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetTransformedCopy(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Entity GetTransformedCopy(
    Matrix3d transform
)
Public Overridable Function GetTransformedCopy ( _
    transform As Matrix3d _
) As Entity
public:
virtual Entity^ GetTransformedCopy(
    Matrix3d transform
)
Parameters
transform(Matrix3d)


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Highlight()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Highlight()
Public Overridable Sub Highlight
public:
virtual void Highlight()


Highlight Method (subId, highlightAll)

Highlight Method (subId, highlightAll)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Highlight(FullSubentityPath, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Highlight(
    FullSubentityPath subId,
    bool highlightAll
)
Public Overridable Sub Highlight ( _
    subId As FullSubentityPath, _
    highlightAll As Boolean _
)
public:
virtual void Highlight(
    FullSubentityPath subId,
    bool highlightAll
)
Parameters
subId(FullSubentityPath)
highlightAll(Boolean)


Hyperlinks Property

Hyperlinks Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Hyperlinks
Declaration Syntax
C# Visual Basic Visual C++
public HyperLinkCollection Hyperlinks { get; }
Public ReadOnly Property Hyperlinks As HyperLinkCollection
    Get
public:
property HyperLinkCollection^ Hyperlinks {
    HyperLinkCollection^ get ();
}


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IntersectWith Method (entityPointer, intersectType, projectionPlane, points, thisGraphicSystemMarker, otherGraphicSystemMarker)

IntersectWith Method (entityPointer, intersectType, projectionPlane, points, thisGraphicSystemMarker, otherGraphicSystemMarker)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use the overload taking IntPtr instead.")]
public virtual void IntersectWith(
    Entity entityPointer,
    Intersect intersectType,
    Plane projectionPlane,
    Point3dCollection points,
    int thisGraphicSystemMarker,
    int otherGraphicSystemMarker
)
<ObsoleteAttribute("Use the overload taking IntPtr instead.")> _
Public Overridable Sub IntersectWith ( _
    entityPointer As Entity, _
    intersectType As Intersect, _
    projectionPlane As Plane, _
    points As Point3dCollection, _
    thisGraphicSystemMarker As Integer, _
    otherGraphicSystemMarker As Integer _
)
[ObsoleteAttribute(L"Use the overload taking IntPtr instead.")]
public:
virtual void IntersectWith(
    Entity^ entityPointer,
    Intersect intersectType,
    Plane^ projectionPlane,
    Point3dCollection^ points,
    int thisGraphicSystemMarker,
    int otherGraphicSystemMarker
)
Parameters
entityPointer(Entity)
intersectType(Intersect)
projectionPlane(Plane)
points(Point3dCollection)
thisGraphicSystemMarker(Int32)
otherGraphicSystemMarker(Int32)


IntersectWith Method (entityPointer, intersectType, projectionPlane, points, thisGraphicSystemMarker, otherGraphicSystemMarker)

IntersectWith Method (entityPointer, intersectType, projectionPlane, points, thisGraphicSystemMarker, otherGraphicSystemMarker)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void IntersectWith(
    Entity entityPointer,
    Intersect intersectType,
    Plane projectionPlane,
    Point3dCollection points,
    IntPtr thisGraphicSystemMarker,
    IntPtr otherGraphicSystemMarker
)
Public Overridable Sub IntersectWith ( _
    entityPointer As Entity, _
    intersectType As Intersect, _
    projectionPlane As Plane, _
    points As Point3dCollection, _
    thisGraphicSystemMarker As IntPtr, _
    otherGraphicSystemMarker As IntPtr _
)
public:
virtual void IntersectWith(
    Entity^ entityPointer,
    Intersect intersectType,
    Plane^ projectionPlane,
    Point3dCollection^ points,
    IntPtr thisGraphicSystemMarker,
    IntPtr otherGraphicSystemMarker
)
Parameters
entityPointer(Entity)
intersectType(Intersect)
projectionPlane(Plane)
points(Point3dCollection)
thisGraphicSystemMarker(IntPtr)
otherGraphicSystemMarker(IntPtr)


IntersectWith Method (entityPointer, intersectType, points, thisGraphicSystemMarker, otherGraphicSystemMarker)

IntersectWith Method (entityPointer, intersectType, points, thisGraphicSystemMarker, otherGraphicSystemMarker)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use the overload taking IntPtr instead.")]
public virtual void IntersectWith(
    Entity entityPointer,
    Intersect intersectType,
    Point3dCollection points,
    int thisGraphicSystemMarker,
    int otherGraphicSystemMarker
)
<ObsoleteAttribute("Use the overload taking IntPtr instead.")> _
Public Overridable Sub IntersectWith ( _
    entityPointer As Entity, _
    intersectType As Intersect, _
    points As Point3dCollection, _
    thisGraphicSystemMarker As Integer, _
    otherGraphicSystemMarker As Integer _
)
[ObsoleteAttribute(L"Use the overload taking IntPtr instead.")]
public:
virtual void IntersectWith(
    Entity^ entityPointer,
    Intersect intersectType,
    Point3dCollection^ points,
    int thisGraphicSystemMarker,
    int otherGraphicSystemMarker
)
Parameters
entityPointer(Entity)
intersectType(Intersect)
points(Point3dCollection)
thisGraphicSystemMarker(Int32)
otherGraphicSystemMarker(Int32)


IntersectWith Method (entityPointer, intersectType, points, thisGraphicSystemMarker, otherGraphicSystemMarker)

IntersectWith Method (entityPointer, intersectType, points, thisGraphicSystemMarker, otherGraphicSystemMarker)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void IntersectWith(
    Entity entityPointer,
    Intersect intersectType,
    Point3dCollection points,
    IntPtr thisGraphicSystemMarker,
    IntPtr otherGraphicSystemMarker
)
Public Overridable Sub IntersectWith ( _
    entityPointer As Entity, _
    intersectType As Intersect, _
    points As Point3dCollection, _
    thisGraphicSystemMarker As IntPtr, _
    otherGraphicSystemMarker As IntPtr _
)
public:
virtual void IntersectWith(
    Entity^ entityPointer,
    Intersect intersectType,
    Point3dCollection^ points,
    IntPtr thisGraphicSystemMarker,
    IntPtr otherGraphicSystemMarker
)
Parameters
entityPointer(Entity)
intersectType(Intersect)
points(Point3dCollection)
thisGraphicSystemMarker(IntPtr)
otherGraphicSystemMarker(IntPtr)


IsContentSnappable Method

IsContentSnappable Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »IsContentSnappable()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsContentSnappable()
Public Overridable Function IsContentSnappable As Boolean
public:
virtual bool IsContentSnappable()


IsPlanar Property

IsPlanar Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »IsPlanar
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsPlanar { get; }
Public Overridable ReadOnly Property IsPlanar As Boolean
    Get
public:
virtual property bool IsPlanar {
    bool get ();
}


Layer Property

Layer Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Layer
Declaration Syntax
C# Visual Basic Visual C++
public string Layer { get; set; }
Public Property Layer As String
    Get
    Set
public:
property String^ Layer {
    String^ get ();
    void set (String^ value);
}


LayerId Property

LayerId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »LayerId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LayerId { get; set; }
Public Property LayerId As ObjectId
    Get
    Set
public:
property ObjectId LayerId {
    ObjectId get ();
    void set (ObjectId value);
}


Linetype Property

Linetype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Linetype
Declaration Syntax
C# Visual Basic Visual C++
public string Linetype { get; set; }
Public Property Linetype As String
    Get
    Set
public:
property String^ Linetype {
    String^ get ();
    void set (String^ value);
}


LinetypeId Property

LinetypeId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »LinetypeId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LinetypeId { get; set; }
Public Property LinetypeId As ObjectId
    Get
    Set
public:
property ObjectId LinetypeId {
    ObjectId get ();
    void set (ObjectId value);
}


LinetypeScale Property

LinetypeScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »LinetypeScale
Declaration Syntax
C# Visual Basic Visual C++
public double LinetypeScale { get; set; }
Public Property LinetypeScale As Double
    Get
    Set
public:
property double LinetypeScale {
    double get ();
    void set (double value);
}


LineWeight Property

LineWeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »LineWeight
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight LineWeight { get; set; }
Public Property LineWeight As LineWeight
    Get
    Set
public:
property LineWeight LineWeight {
    LineWeight get ();
    void set (LineWeight value);
}


List Method

List Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »List()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void List()
Public Sub List
public:
void List()


Material Property

Material Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Material
Declaration Syntax
C# Visual Basic Visual C++
public string Material { get; set; }
Public Property Material As String
    Get
    Set
public:
property String^ Material {
    String^ get ();
    void set (String^ value);
}


MaterialId Property

MaterialId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »MaterialId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId MaterialId { get; set; }
Public Property MaterialId As ObjectId
    Get
    Set
public:
property ObjectId MaterialId {
    ObjectId get ();
    void set (ObjectId value);
}


MaterialMapper Property

MaterialMapper Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »MaterialMapper
Declaration Syntax
C# Visual Basic Visual C++
public Mapper MaterialMapper { get; set; }
Public Property MaterialMapper As Mapper
    Get
    Set
public:
property Mapper^ MaterialMapper {
    Mapper^ get ();
    void set (Mapper^ value);
}


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


MoveGripPointsAt Method (appData, offset, bitFlags)

MoveGripPointsAt Method (appData, offset, bitFlags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void MoveGripPointsAt(
    IntPtr[] appData,
    Vector3d offset,
    MoveGripPointsFlags bitFlags
)
Public Overridable Sub MoveGripPointsAt ( _
    appData As IntPtr(), _
    offset As Vector3d, _
    bitFlags As MoveGripPointsFlags _
)
public:
virtual void MoveGripPointsAt(
    array<IntPtr>^ appData,
    Vector3d offset,
    MoveGripPointsFlags bitFlags
)
Parameters
appData(array<IntPtr>[]()[][])
offset(Vector3d)
bitFlags(MoveGripPointsFlags)


MoveGripPointsAt Method (indices, offset)

MoveGripPointsAt Method (indices, offset)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »MoveGripPointsAt(IntegerCollection, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void MoveGripPointsAt(
    IntegerCollection indices,
    Vector3d offset
)
Public Overridable Sub MoveGripPointsAt ( _
    indices As IntegerCollection, _
    offset As Vector3d _
)
public:
virtual void MoveGripPointsAt(
    IntegerCollection^ indices,
    Vector3d offset
)
Parameters
indices(IntegerCollection)
offset(Vector3d)


MoveGripPointsAtSubentityPaths Method (subPaths, appData, offset, bitFlags)

MoveGripPointsAtSubentityPaths Method (subPaths, appData, offset, bitFlags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void MoveGripPointsAtSubentityPaths(
    FullSubentityPath[] subPaths,
    IntPtr[] appData,
    Vector3d offset,
    MoveGripPointsFlags bitFlags
)
Public Overridable Sub MoveGripPointsAtSubentityPaths ( _
    subPaths As FullSubentityPath(), _
    appData As IntPtr(), _
    offset As Vector3d, _
    bitFlags As MoveGripPointsFlags _
)
public:
virtual void MoveGripPointsAtSubentityPaths(
    array<FullSubentityPath>^ subPaths,
    array<IntPtr>^ appData,
    Vector3d offset,
    MoveGripPointsFlags bitFlags
)
Parameters
subPaths(array< FullSubentityPath >[]()[][])
appData(array<IntPtr>[]()[][])
offset(Vector3d)
bitFlags(MoveGripPointsFlags)


MoveStretchPointsAt Method (indices, offset)

MoveStretchPointsAt Method (indices, offset)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »MoveStretchPointsAt(IntegerCollection, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void MoveStretchPointsAt(
    IntegerCollection indices,
    Vector3d offset
)
Public Overridable Sub MoveStretchPointsAt ( _
    indices As IntegerCollection, _
    offset As Vector3d _
)
public:
virtual void MoveStretchPointsAt(
    IntegerCollection^ indices,
    Vector3d offset
)
Parameters
indices(IntegerCollection)
offset(Vector3d)


PlotStyleName Property

PlotStyleName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »PlotStyleName
Declaration Syntax
C# Visual Basic Visual C++
public string PlotStyleName { get; set; }
Public Property PlotStyleName As String
    Get
    Set
public:
property String^ PlotStyleName {
    String^ get ();
    void set (String^ value);
}


PlotStyleNameId Property

PlotStyleNameId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »PlotStyleNameId
Declaration Syntax
C# Visual Basic Visual C++
public PlotStyleDescriptor PlotStyleNameId { get; set; }
Public Property PlotStyleNameId As PlotStyleDescriptor
    Get
    Set
public:
property PlotStyleDescriptor PlotStyleNameId {
    PlotStyleDescriptor get ();
    void set (PlotStyleDescriptor value);
}


ReceiveShadows Property

ReceiveShadows Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »ReceiveShadows
Declaration Syntax
C# Visual Basic Visual C++
public bool ReceiveShadows { get; set; }
Public Property ReceiveShadows As Boolean
    Get
    Set
public:
property bool ReceiveShadows {
    bool get ();
    void set (bool value);
}


RecordGraphicsModified Method (setModified)

RecordGraphicsModified Method (setModified)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »RecordGraphicsModified(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void RecordGraphicsModified(
    bool setModified
)
Public Sub RecordGraphicsModified ( _
    setModified As Boolean _
)
public:
void RecordGraphicsModified(
    bool setModified
)
Parameters
setModified(Boolean)


SaveAs Method (mode, st)

SaveAs Method (mode, st)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »SaveAs(WorldDraw, SaveType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SaveAs(
    WorldDraw mode,
    SaveType st
)
Public Overridable Sub SaveAs ( _
    mode As WorldDraw, _
    st As SaveType _
)
public:
virtual void SaveAs(
    WorldDraw^ mode,
    SaveType st
)
Parameters
mode(WorldDraw)
st(SaveType)


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »SetDatabaseDefaults()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetDatabaseDefaults()
Public Sub SetDatabaseDefaults
public:
void SetDatabaseDefaults()


SetDatabaseDefaults Method (sourceDatabase)

SetDatabaseDefaults Method (sourceDatabase)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »SetDatabaseDefaults(Database)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDatabaseDefaults(
    Database sourceDatabase
)
Public Sub SetDatabaseDefaults ( _
    sourceDatabase As Database _
)
public:
void SetDatabaseDefaults(
    Database^ sourceDatabase
)
Parameters
sourceDatabase(Database)


SetDragStatus Method (status)

SetDragStatus Method (status)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »SetDragStatus(DragStatus)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDragStatus(
    DragStatus status
)
Public Overridable Sub SetDragStatus ( _
    status As DragStatus _
)
public:
virtual void SetDragStatus(
    DragStatus status
)
Parameters
status(DragStatus)


SetGripStatus Method (status)

SetGripStatus Method (status)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »SetGripStatus(GripStatus)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGripStatus(
    GripStatus status
)
Public Overridable Sub SetGripStatus ( _
    status As GripStatus _
)
public:
virtual void SetGripStatus(
    GripStatus status
)
Parameters
status(GripStatus)


SetLayerId Method (newValue, allowHidden)

SetLayerId Method (newValue, allowHidden)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »SetLayerId(ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetLayerId(
    ObjectId newValue,
    bool allowHidden
)
Public Overridable Sub SetLayerId ( _
    newValue As ObjectId, _
    allowHidden As Boolean _
)
public:
virtual void SetLayerId(
    ObjectId newValue,
    bool allowHidden
)
Parameters
newValue(ObjectId)
allowHidden(Boolean)


SetPropertiesFrom Method (entityPointer)

SetPropertiesFrom Method (entityPointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »SetPropertiesFrom(Entity)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPropertiesFrom(
    Entity entityPointer
)
Public Sub SetPropertiesFrom ( _
    entityPointer As Entity _
)
public:
void SetPropertiesFrom(
    Entity^ entityPointer
)
Parameters
entityPointer(Entity)


SetSubentityGripStatus Method (status, subentity)

SetSubentityGripStatus Method (status, subentity)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »SetSubentityGripStatus(GripStatus, FullSubentityPath)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSubentityGripStatus(
    GripStatus status,
    FullSubentityPath subentity
)
Public Overridable Sub SetSubentityGripStatus ( _
    status As GripStatus, _
    subentity As FullSubentityPath _
)
public:
virtual void SetSubentityGripStatus(
    GripStatus status,
    FullSubentityPath subentity
)
Parameters
status(GripStatus)
subentity(FullSubentityPath)


TransformBy Method (transform)

TransformBy Method (transform)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »TransformBy(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void TransformBy(
    Matrix3d transform
)
Public Overridable Sub TransformBy ( _
    transform As Matrix3d _
)
public:
virtual void TransformBy(
    Matrix3d transform
)
Parameters
transform(Matrix3d)


TransformSubentityPathsBy Method (subPaths, transform)

TransformSubentityPathsBy Method (subPaths, transform)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void TransformSubentityPathsBy(
    FullSubentityPath[] subPaths,
    Matrix3d transform
)
Public Overridable Sub TransformSubentityPathsBy ( _
    subPaths As FullSubentityPath(), _
    transform As Matrix3d _
)
public:
virtual void TransformSubentityPathsBy(
    array<FullSubentityPath>^ subPaths,
    Matrix3d transform
)
Parameters
subPaths(array< FullSubentityPath >[]()[][])
transform(Matrix3d)


Transparency Property

Transparency Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Transparency
Declaration Syntax
C# Visual Basic Visual C++
public virtual Transparency Transparency { get; set; }
Public Overridable Property Transparency As Transparency
    Get
    Set
public:
virtual property Transparency Transparency {
    Transparency get ();
    void set (Transparency value);
}


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Unhighlight()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Unhighlight()
Public Overridable Sub Unhighlight
public:
virtual void Unhighlight()


Unhighlight Method (subId, highlightAll)

Unhighlight Method (subId, highlightAll)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Unhighlight(FullSubentityPath, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Unhighlight(
    FullSubentityPath subId,
    bool highlightAll
)
Public Overridable Sub Unhighlight ( _
    subId As FullSubentityPath, _
    highlightAll As Boolean _
)
public:
virtual void Unhighlight(
    FullSubentityPath subId,
    bool highlightAll
)
Parameters
subId(FullSubentityPath)
highlightAll(Boolean)


Visible Property

Visible Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Visible
Declaration Syntax
C# Visual Basic Visual C++
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}


VisualStyleId Property

VisualStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »VisualStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId VisualStyleId { get; set; }
Public Property VisualStyleId As ObjectId
    Get
    Set
public:
property ObjectId VisualStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


EntityVisualStyleType Enumeration

EntityVisualStyleType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »EntityVisualStyleType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbEntity::VisualStyleType")]
public enum EntityVisualStyleType
<WrapperAttribute("AcDbEntity::VisualStyleType")> _
Public Enumeration EntityVisualStyleType
[WrapperAttribute(L"AcDbEntity::VisualStyleType")]
public enum class EntityVisualStyleType
Members
Member | Description
FullVisualStyle |
FaceVisualStyle |
EdgeVisualStyle |


EraseFlags Enumeration

EraseFlags Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »EraseFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum EraseFlags
<FlagsAttribute> _
Public Enumeration EraseFlags
[FlagsAttribute]
public enum class EraseFlags
Members
Member | Description
ZeroLengthCurve |
EmptyText |
AllEmptyObj |


EvalFields Enumeration

EvalFields Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »EvalFields
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum EvalFields
<FlagsAttribute> _
Public Enumeration EvalFields
[FlagsAttribute]
public enum class EvalFields
Members
Member | Description
NoFlags |
Recursive |


Extents2d Structure

Extents2d Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d
Declaration Syntax
C# Visual Basic Visual C++
public struct Extents2d : IFormattable
Public Structure Extents2d _
    Implements IFormattable
public value class Extents2d : IFormattable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Extents2d(Double, Double, Double, Double) |
 | Extents2d(Point2d, Point2d) |
 | Equality(Extents2d, Extents2d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(Extents2d, Extents2d) |
 | IsEqualTo(Extents2d, Tolerance) |
 | IsEqualTo(Extents2d) |
 | MaxPoint |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinPoint |
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


Extents2d Constructor

Extents2d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »Extents2d()()()()
Members
Icon | Member | Description
 | Extents2d(Double, Double, Double, Double) |
 | Extents2d(Point2d, Point2d) |


Extents2d Constructor (minX, minY, maxX, maxY)

Extents2d Constructor (minX, minY, maxX, maxY)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »Extents2d(Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Extents2d(
    double minX,
    double minY,
    double maxX,
    double maxY
)
Public Sub New ( _
    minX As Double, _
    minY As Double, _
    maxX As Double, _
    maxY As Double _
)
public:
Extents2d(
    double minX,
    double minY,
    double maxX,
    double maxY
)
Parameters
minX(Double)
minY(Double)
maxX(Double)
maxY(Double)


Extents2d Constructor (minimum, maximum)

Extents2d Constructor (minimum, maximum)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »Extents2d(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Extents2d(
    Point2d minimum,
    Point2d maximum
)
Public Sub New ( _
    minimum As Point2d, _
    maximum As Point2d _
)
public:
Extents2d(
    Point2d minimum,
    Point2d maximum
)
Parameters
minimum(Point2d)
maximum(Point2d)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »Equality(Extents2d, Extents2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Extents2d a,
    Extents2d b
)
Public Shared Operator = ( _
    a As Extents2d, _
    b As Extents2d _
) As Boolean
public:
static bool operator ==(
    Extents2d a,
    Extents2d b
)
Parameters
a(Extents2d)
b(Extents2d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »Inequality(Extents2d, Extents2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Extents2d a,
    Extents2d b
)
Public Shared Operator <> ( _
    a As Extents2d, _
    b As Extents2d _
) As Boolean
public:
static bool operator !=(
    Extents2d a,
    Extents2d b
)
Parameters
a(Extents2d)
b(Extents2d)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Extents2d, Tolerance) |
 | IsEqualTo(Extents2d) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »IsEqualTo(Extents2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Extents2d a
)
Public Function IsEqualTo ( _
    a As Extents2d _
) As Boolean
public:
bool IsEqualTo(
    Extents2d a
)
Parameters
a(Extents2d)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »IsEqualTo(Extents2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Extents2d a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As Extents2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Extents2d a,
    Tolerance tolerance
)
Parameters
a(Extents2d)
tolerance(Tolerance)


MaxPoint Property

MaxPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »MaxPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d MaxPoint { get; }
Public ReadOnly Property MaxPoint As Point2d
    Get
public:
property Point2d MaxPoint {
    Point2d get ();
}


MinPoint Property

MinPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »MinPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d MinPoint { get; }
Public ReadOnly Property MinPoint As Point2d
    Get
public:
property Point2d MinPoint {
    Point2d get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents2d »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


Extents3d Structure

Extents3d Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbExtents")]
public struct Extents3d
<WrapperAttribute("AcDbExtents")> _
Public Structure Extents3d
[WrapperAttribute(L"AcDbExtents")]
public value class Extents3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Extents3d(Point3d, Point3d) |
 | AddBlockExtents(BlockTableRecord) |
 | AddExtents(Extents3d) |
 | AddPoint(Point3d) |
 | Equality(Extents3d, Extents3d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | ExpandBy(Vector3d) |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(Extents3d, Extents3d) |
 | IsEqualTo(Extents3d, Tolerance) |
 | IsEqualTo(Extents3d) |
 | MaxPoint |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinPoint |
 | Set(Point3d, Point3d) |
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | TransformBy(Matrix3d) |


Extents3d Constructor (min, max)

Extents3d Constructor (min, max)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »Extents3d(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Extents3d(
    Point3d min,
    Point3d max
)
Public Sub New ( _
    min As Point3d, _
    max As Point3d _
)
public:
Extents3d(
    Point3d min,
    Point3d max
)
Parameters
min(Point3d)
max(Point3d)


AddBlockExtents Method (pointerToBlockTableRecord)

AddBlockExtents Method (pointerToBlockTableRecord)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »AddBlockExtents(BlockTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public void AddBlockExtents(
    BlockTableRecord pointerToBlockTableRecord
)
Public Sub AddBlockExtents ( _
    pointerToBlockTableRecord As BlockTableRecord _
)
public:
void AddBlockExtents(
    BlockTableRecord^ pointerToBlockTableRecord
)
Parameters
pointerToBlockTableRecord(BlockTableRecord)


AddExtents Method (source)

AddExtents Method (source)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »AddExtents(Extents3d)
Declaration Syntax
C# Visual Basic Visual C++
public void AddExtents(
    Extents3d source
)
Public Sub AddExtents ( _
    source As Extents3d _
)
public:
void AddExtents(
    Extents3d source
)
Parameters
source(Extents3d)


AddPoint Method (pt)

AddPoint Method (pt)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »AddPoint(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void AddPoint(
    Point3d pt
)
Public Sub AddPoint ( _
    pt As Point3d _
)
public:
void AddPoint(
    Point3d pt
)
Parameters
pt(Point3d)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »Equality(Extents3d, Extents3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Extents3d a,
    Extents3d b
)
Public Shared Operator = ( _
    a As Extents3d, _
    b As Extents3d _
) As Boolean
public:
static bool operator ==(
    Extents3d a,
    Extents3d b
)
Parameters
a(Extents3d)
b(Extents3d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


ExpandBy Method (vector)

ExpandBy Method (vector)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »ExpandBy(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void ExpandBy(
    Vector3d vector
)
Public Sub ExpandBy ( _
    vector As Vector3d _
)
public:
void ExpandBy(
    Vector3d vector
)
Parameters
vector(Vector3d)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »Inequality(Extents3d, Extents3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Extents3d a,
    Extents3d b
)
Public Shared Operator <> ( _
    a As Extents3d, _
    b As Extents3d _
) As Boolean
public:
static bool operator !=(
    Extents3d a,
    Extents3d b
)
Parameters
a(Extents3d)
b(Extents3d)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Extents3d, Tolerance) |
 | IsEqualTo(Extents3d) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »IsEqualTo(Extents3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Extents3d a
)
Public Function IsEqualTo ( _
    a As Extents3d _
) As Boolean
public:
bool IsEqualTo(
    Extents3d a
)
Parameters
a(Extents3d)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »IsEqualTo(Extents3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Extents3d a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As Extents3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Extents3d a,
    Tolerance tolerance
)
Parameters
a(Extents3d)
tolerance(Tolerance)


MaxPoint Property

MaxPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »MaxPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d MaxPoint { get; }
Public ReadOnly Property MaxPoint As Point3d
    Get
public:
property Point3d MaxPoint {
    Point3d get ();
}


MinPoint Property

MinPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »MinPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d MinPoint { get; }
Public ReadOnly Property MinPoint As Point3d
    Get
public:
property Point3d MinPoint {
    Point3d get ();
}


Set Method (min, max)

Set Method (min, max)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »Set(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d min,
    Point3d max
)
Public Sub Set ( _
    min As Point3d, _
    max As Point3d _
)
public:
void Set(
    Point3d min,
    Point3d max
)
Parameters
min(Point3d)
max(Point3d)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


TransformBy Method (mat)

TransformBy Method (mat)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Extents3d »TransformBy(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public void TransformBy(
    Matrix3d mat
)
Public Sub TransformBy ( _
    mat As Matrix3d _
)
public:
void TransformBy(
    Matrix3d mat
)
Parameters
mat(Matrix3d)


ExtrudedSurface Class

ExtrudedSurface Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbExtrudedSurface")]
public class ExtrudedSurface : Surface
<WrapperAttribute("AcDbExtrudedSurface")> _
Public Class ExtrudedSurface _
    Inherits Surface
[WrapperAttribute(L"AcDbExtrudedSurface")]
public ref class ExtrudedSurface : public Surface
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtrudedSurface()()()() |
 | ExtrudedSurface(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BooleanIntersect(Surface) | (Inherited from Surface.)
 | BooleanIntersect(Solid3d) | (Inherited from Surface.)
 | BooleanSubtract(Surface) | (Inherited from Surface.)
 | BooleanSubtract(Solid3d) | (Inherited from Surface.)
 | BooleanUnion(Surface) | (Inherited from Surface.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ChamferEdges(array<SubentityId>[]()[][], SubentityId, Double, Double) | (Inherited from Surface.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToRegion()()()() | (Inherited from Surface.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateExtrudedSurface(Entity, Vector3d, SweepOptions) |
 | CreateInterferenceObjects(Entity, Int32) | (Inherited from Surface.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateSectionObjects(Plane) | (Inherited from Surface.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FilletEdges(array<SubentityId>[]()[][], DoubleCollection, DoubleCollection, DoubleCollection) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetArea()()()() | (Inherited from Surface.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityColor(SubentityId) | (Inherited from Surface.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityMaterial(SubentityId) | (Inherited from Surface.)
 | GetSubentityMaterialMapper(SubentityId) | (Inherited from Surface.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | ImprintEntity(Entity) | (Inherited from Surface.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | ProjectOnToSurface(Entity, Vector3d) | (Inherited from Surface.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RayTest(Point3d, Vector3d, Double, array<SubentityId>[]()[][]%, DoubleCollection%) | (Inherited from Surface.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetExtrude(Vector3d, SweepOptions) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityColor(SubentityId, Color) | (Inherited from Surface.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetSubentityMaterial(SubentityId, ObjectId) | (Inherited from Surface.)
 | SetSubentityMaterialMapper(SubentityId, Mapper) | (Inherited from Surface.)
 | SliceByPlane(Plane) | (Inherited from Surface.)
 | SliceBySurface(Surface) | (Inherited from Surface.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | SweepEntity |
 | SweepOptions |
 | TaperAngle |
 | Thicken(Double, Boolean) | (Inherited from Surface.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | UIsoLineDensity | (Inherited from Surface.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VIsoLineDensity | (Inherited from Surface.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Surface
 |  |  |  |  |  |  |  | ExtrudedSurface


ExtrudedSurface Constructor

ExtrudedSurface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »ExtrudedSurface()()()()
Members
Icon | Member | Description
 | ExtrudedSurface()()()() |
 | ExtrudedSurface(IntPtr, Boolean) |


ExtrudedSurface Constructor

ExtrudedSurface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »ExtrudedSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExtrudedSurface()
Public Sub New
public:
ExtrudedSurface()


ExtrudedSurface Constructor (unmanagedPointer, autoDelete)

ExtrudedSurface Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »ExtrudedSurface(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal ExtrudedSurface(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
ExtrudedSurface(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


CreateExtrudedSurface Method (sweepEnt, directionVec, sweepOptions)

CreateExtrudedSurface Method (sweepEnt, directionVec, sweepOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »CreateExtrudedSurface(Entity, Vector3d, SweepOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateExtrudedSurface(
    Entity sweepEnt,
    Vector3d directionVec,
    SweepOptions sweepOptions
)
Public Overridable Sub CreateExtrudedSurface ( _
    sweepEnt As Entity, _
    directionVec As Vector3d, _
    sweepOptions As SweepOptions _
)
public:
virtual void CreateExtrudedSurface(
    Entity^ sweepEnt,
    Vector3d directionVec,
    SweepOptions^ sweepOptions
)
Parameters
sweepEnt(Entity)
directionVec(Vector3d)
sweepOptions(SweepOptions)


SetExtrude Method (sweepVec, sweepOptions)

SetExtrude Method (sweepVec, sweepOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »SetExtrude(Vector3d, SweepOptions)
Declaration Syntax
C# Visual Basic Visual C++
public void SetExtrude(
    Vector3d sweepVec,
    SweepOptions sweepOptions
)
Public Sub SetExtrude ( _
    sweepVec As Vector3d, _
    sweepOptions As SweepOptions _
)
public:
void SetExtrude(
    Vector3d sweepVec,
    SweepOptions^ sweepOptions
)
Parameters
sweepVec(Vector3d)
sweepOptions(SweepOptions)


SweepEntity Property

SweepEntity Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »SweepEntity
Declaration Syntax
C# Visual Basic Visual C++
public Entity SweepEntity { get; }
Public ReadOnly Property SweepEntity As Entity
    Get
public:
property Entity^ SweepEntity {
    Entity^ get ();
}


SweepOptions Property

SweepOptions Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »SweepOptions
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptions SweepOptions { get; set; }
Public Property SweepOptions As SweepOptions
    Get
    Set
public:
property SweepOptions^ SweepOptions {
    SweepOptions^ get ();
    void set (SweepOptions^ value);
}


TaperAngle Property

TaperAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »TaperAngle
Declaration Syntax
C# Visual Basic Visual C++
public double TaperAngle { get; set; }
Public Property TaperAngle As Double
    Get
    Set
public:
property double TaperAngle {
    double get ();
    void set (double value);
}


Face Class

Face Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbFace")]
public class Face : Entity
<WrapperAttribute("AcDbFace")> _
Public Class Face _
    Inherits Entity
[WrapperAttribute(L"AcDbFace")]
public ref class Face : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Face(Point3d, Point3d, Point3d, Point3d, Boolean, Boolean, Boolean, Boolean) |
 | Face(Point3d, Point3d, Point3d, Boolean, Boolean, Boolean, Boolean) |
 | Face()()()() |
 | Face(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetVertexAt(Int16) |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEdgeVisibleAt(Int16) |
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | MakeEdgeInvisibleAt(Int16) |
 | MakeEdgeVisibleAt(Int16) |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetVertexAt(Int16, Point3d) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Face


Face Constructor

Face Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »Face()()()()
Members
Icon | Member | Description
 | Face(Point3d, Point3d, Point3d, Point3d, Boolean, Boolean, Boolean, Boolean) |
 | Face(Point3d, Point3d, Point3d, Boolean, Boolean, Boolean, Boolean) |
 | Face()()()() |
 | Face(IntPtr, Boolean) |


Face Constructor

Face Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »Face()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Face()
Public Sub New
public:
Face()


Face Constructor (unmanagedObjPtr, autoDelete)

Face Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »Face(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Face(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Face(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Face Constructor (pointer1, pointer2, pointer3, value1, value2, value3, value4)

Face Constructor (pointer1, pointer2, pointer3, value1, value2, value3, value4)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »Face(Point3d, Point3d, Point3d, Boolean, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Face(
    Point3d pointer1,
    Point3d pointer2,
    Point3d pointer3,
    bool value1,
    bool value2,
    bool value3,
    bool value4
)
Public Sub New ( _
    pointer1 As Point3d, _
    pointer2 As Point3d, _
    pointer3 As Point3d, _
    value1 As Boolean, _
    value2 As Boolean, _
    value3 As Boolean, _
    value4 As Boolean _
)
public:
Face(
    Point3d pointer1,
    Point3d pointer2,
    Point3d pointer3,
    bool value1,
    bool value2,
    bool value3,
    bool value4
)
Parameters
pointer1(Point3d)
pointer2(Point3d)
pointer3(Point3d)
value1(Boolean)
value2(Boolean)
value3(Boolean)
value4(Boolean)


Face Constructor (pointer1, pointer2, pointer3, pointer4, value1, value2, value3, value4)

Face Constructor (pointer1, pointer2, pointer3, pointer4, value1, value2, value3, value4)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »Face(Point3d, Point3d, Point3d, Point3d, Boolean, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Face(
    Point3d pointer1,
    Point3d pointer2,
    Point3d pointer3,
    Point3d pointer4,
    bool value1,
    bool value2,
    bool value3,
    bool value4
)
Public Sub New ( _
    pointer1 As Point3d, _
    pointer2 As Point3d, _
    pointer3 As Point3d, _
    pointer4 As Point3d, _
    value1 As Boolean, _
    value2 As Boolean, _
    value3 As Boolean, _
    value4 As Boolean _
)
public:
Face(
    Point3d pointer1,
    Point3d pointer2,
    Point3d pointer3,
    Point3d pointer4,
    bool value1,
    bool value2,
    bool value3,
    bool value4
)
Parameters
pointer1(Point3d)
pointer2(Point3d)
pointer3(Point3d)
pointer4(Point3d)
value1(Boolean)
value2(Boolean)
value3(Boolean)
value4(Boolean)


GetVertexAt Method (value)

GetVertexAt Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »GetVertexAt(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetVertexAt(
    short value
)
Public Function GetVertexAt ( _
    value As Short _
) As Point3d
public:
Point3d GetVertexAt(
    short value
)
Parameters
value(Int16)


IsEdgeVisibleAt Method (vertexIndex)

IsEdgeVisibleAt Method (vertexIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »IsEdgeVisibleAt(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEdgeVisibleAt(
    short vertexIndex
)
Public Function IsEdgeVisibleAt ( _
    vertexIndex As Short _
) As Boolean
public:
bool IsEdgeVisibleAt(
    short vertexIndex
)
Parameters
vertexIndex(Int16)


MakeEdgeInvisibleAt Method (vertexIndex)

MakeEdgeInvisibleAt Method (vertexIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »MakeEdgeInvisibleAt(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public void MakeEdgeInvisibleAt(
    short vertexIndex
)
Public Sub MakeEdgeInvisibleAt ( _
    vertexIndex As Short _
)
public:
void MakeEdgeInvisibleAt(
    short vertexIndex
)
Parameters
vertexIndex(Int16)


MakeEdgeVisibleAt Method (vertexIndex)

MakeEdgeVisibleAt Method (vertexIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »MakeEdgeVisibleAt(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public void MakeEdgeVisibleAt(
    short vertexIndex
)
Public Sub MakeEdgeVisibleAt ( _
    vertexIndex As Short _
)
public:
void MakeEdgeVisibleAt(
    short vertexIndex
)
Parameters
vertexIndex(Int16)


SetVertexAt Method (vertexIndex, vertexPosition)

SetVertexAt Method (vertexIndex, vertexPosition)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »SetVertexAt(Int16, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetVertexAt(
    short vertexIndex,
    Point3d vertexPosition
)
Public Sub SetVertexAt ( _
    vertexIndex As Short, _
    vertexPosition As Point3d _
)
public:
void SetVertexAt(
    short vertexIndex,
    Point3d vertexPosition
)
Parameters
vertexIndex(Int16)
vertexPosition(Point3d)


FaceRecord Class

FaceRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbFaceRecord")]
public class FaceRecord : Vertex
<WrapperAttribute("AcDbFaceRecord")> _
Public Class FaceRecord _
    Inherits Vertex
[WrapperAttribute(L"AcDbFaceRecord")]
public ref class FaceRecord : public Vertex
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FaceRecord(Int16, Int16, Int16, Int16) |
 | FaceRecord()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetVertexAt(Int16) |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEdgeVisibleAt(Int16) |
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | MakeEdgeInvisibleAt(Int16) |
 | MakeEdgeVisibleAt(Int16) |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetVertexAt(Int16, Int16) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Vertex
 |  |  |  |  |  |  |  | FaceRecord


FaceRecord Constructor

FaceRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »FaceRecord()()()()
Members
Icon | Member | Description
 | FaceRecord(Int16, Int16, Int16, Int16) |
 | FaceRecord()()()() |


FaceRecord Constructor

FaceRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »FaceRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FaceRecord()
Public Sub New
public:
FaceRecord()


FaceRecord Constructor (vertex0, vertex1, vertex2, vertex3)

FaceRecord Constructor (vertex0, vertex1, vertex2, vertex3)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »FaceRecord(Int16, Int16, Int16, Int16)
Declaration Syntax
C# Visual Basic Visual C++
public FaceRecord(
    short vertex0,
    short vertex1,
    short vertex2,
    short vertex3
)
Public Sub New ( _
    vertex0 As Short, _
    vertex1 As Short, _
    vertex2 As Short, _
    vertex3 As Short _
)
public:
FaceRecord(
    short vertex0,
    short vertex1,
    short vertex2,
    short vertex3
)
Parameters
vertex0(Int16)
vertex1(Int16)
vertex2(Int16)
vertex3(Int16)


GetVertexAt Method (faceIndex)

GetVertexAt Method (faceIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »GetVertexAt(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public short GetVertexAt(
    short faceIndex
)
Public Function GetVertexAt ( _
    faceIndex As Short _
) As Short
public:
short GetVertexAt(
    short faceIndex
)
Parameters
faceIndex(Int16)


IsEdgeVisibleAt Method (faceIndex)

IsEdgeVisibleAt Method (faceIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »IsEdgeVisibleAt(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEdgeVisibleAt(
    short faceIndex
)
Public Function IsEdgeVisibleAt ( _
    faceIndex As Short _
) As Boolean
public:
bool IsEdgeVisibleAt(
    short faceIndex
)
Parameters
faceIndex(Int16)


MakeEdgeInvisibleAt Method (faceIndex)

MakeEdgeInvisibleAt Method (faceIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »MakeEdgeInvisibleAt(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public void MakeEdgeInvisibleAt(
    short faceIndex
)
Public Sub MakeEdgeInvisibleAt ( _
    faceIndex As Short _
)
public:
void MakeEdgeInvisibleAt(
    short faceIndex
)
Parameters
faceIndex(Int16)


MakeEdgeVisibleAt Method (faceIndex)

MakeEdgeVisibleAt Method (faceIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »MakeEdgeVisibleAt(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public void MakeEdgeVisibleAt(
    short faceIndex
)
Public Sub MakeEdgeVisibleAt ( _
    faceIndex As Short _
)
public:
void MakeEdgeVisibleAt(
    short faceIndex
)
Parameters
faceIndex(Int16)


SetVertexAt Method (faceIndex, vertexIndex)

SetVertexAt Method (faceIndex, vertexIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »SetVertexAt(Int16, Int16)
Declaration Syntax
C# Visual Basic Visual C++
public void SetVertexAt(
    short faceIndex,
    short vertexIndex
)
Public Sub SetVertexAt ( _
    faceIndex As Short, _
    vertexIndex As Short _
)
public:
void SetVertexAt(
    short faceIndex,
    short vertexIndex
)
Parameters
faceIndex(Int16)
vertexIndex(Int16)


FeatureControlFrame Class

FeatureControlFrame Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbFcf")]
public class FeatureControlFrame : Entity
<WrapperAttribute("AcDbFcf")> _
Public Class FeatureControlFrame _
    Inherits Entity
[WrapperAttribute(L"AcDbFcf")]
public ref class FeatureControlFrame : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeatureControlFrame(String, Point3d, Vector3d, Vector3d) |
 | FeatureControlFrame()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimclrd |
 | Dimclrt |
 | DimensionStyle |
 | DimensionStyleName |
 | Dimgap |
 | Dimscale |
 | DimstyleData |
 | Dimtxsty |
 | Dimtxt |
 | Direction |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetBoundingPoints()()()() |
 | GetBoundingPolyline()()()() |
 | GetDimstyleData()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Location |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) |
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetOrientation(Vector3d, Vector3d) |
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Text |
 | TextStyleId |
 | TextStyleName |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | FeatureControlFrame


FeatureControlFrame Constructor

FeatureControlFrame Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »FeatureControlFrame()()()()
Members
Icon | Member | Description
 | FeatureControlFrame(String, Point3d, Vector3d, Vector3d) |
 | FeatureControlFrame()()()() |


FeatureControlFrame Constructor

FeatureControlFrame Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »FeatureControlFrame()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeatureControlFrame()
Public Sub New
public:
FeatureControlFrame()


FeatureControlFrame Constructor (codes, insertionPoint, normalVector, x)

FeatureControlFrame Constructor (codes, insertionPoint, normalVector, x)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »FeatureControlFrame(String, Point3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public FeatureControlFrame(
    string codes,
    Point3d insertionPoint,
    Vector3d normalVector,
    Vector3d x
)
Public Sub New ( _
    codes As String, _
    insertionPoint As Point3d, _
    normalVector As Vector3d, _
    x As Vector3d _
)
public:
FeatureControlFrame(
    String^ codes,
    Point3d insertionPoint,
    Vector3d normalVector,
    Vector3d x
)
Parameters
codes(String)
insertionPoint(Point3d)
normalVector(Vector3d)
x(Vector3d)


Dimclrd Property

Dimclrd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Dimclrd
Declaration Syntax
C# Visual Basic Visual C++
public Color Dimclrd { get; set; }
Public Property Dimclrd As Color
    Get
    Set
public:
property Color^ Dimclrd {
    Color^ get ();
    void set (Color^ value);
}


Dimclrt Property

Dimclrt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Dimclrt
Declaration Syntax
C# Visual Basic Visual C++
public Color Dimclrt { get; set; }
Public Property Dimclrt As Color
    Get
    Set
public:
property Color^ Dimclrt {
    Color^ get ();
    void set (Color^ value);
}


DimensionStyle Property

DimensionStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »DimensionStyle
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId DimensionStyle { get; set; }
Public Property DimensionStyle As ObjectId
    Get
    Set
public:
property ObjectId DimensionStyle {
    ObjectId get ();
    void set (ObjectId value);
}


DimensionStyleName Property

DimensionStyleName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »DimensionStyleName
Declaration Syntax
C# Visual Basic Visual C++
public string DimensionStyleName { get; set; }
Public Property DimensionStyleName As String
    Get
    Set
public:
property String^ DimensionStyleName {
    String^ get ();
    void set (String^ value);
}


Dimgap Property

Dimgap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Dimgap
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Dimgap { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Dimgap As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Dimgap {
    double get ();
    void set (double value);
}


Dimscale Property

Dimscale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Dimscale
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double Dimscale { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property Dimscale As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double Dimscale {
    double get ();
    void set (double value);
}


DimstyleData Property

DimstyleData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »DimstyleData
Declaration Syntax
C# Visual Basic Visual C++
public DimStyleTableRecord DimstyleData { get; set; }
Public Property DimstyleData As DimStyleTableRecord
    Get
    Set
public:
property DimStyleTableRecord^ DimstyleData {
    DimStyleTableRecord^ get ();
    void set (DimStyleTableRecord^ value);
}


Dimtxsty Property

Dimtxsty Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Dimtxsty
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Dimtxsty { get; set; }
Public Property Dimtxsty As ObjectId
    Get
    Set
public:
property ObjectId Dimtxsty {
    ObjectId get ();
    void set (ObjectId value);
}


Dimtxt Property

Dimtxt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Dimtxt
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Dimtxt { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Dimtxt As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Dimtxt {
    double get ();
    void set (double value);
}


Direction Property

Direction Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Direction
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d Direction { get; }
Public Overridable ReadOnly Property Direction As Vector3d
    Get
public:
virtual property Vector3d Direction {
    Vector3d get ();
}


GetBoundingPoints Method

GetBoundingPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »GetBoundingPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3dCollection GetBoundingPoints()
Public Overridable Function GetBoundingPoints As Point3dCollection
public:
virtual Point3dCollection^ GetBoundingPoints()


GetBoundingPolyline Method

GetBoundingPolyline Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »GetBoundingPolyline()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3dCollection GetBoundingPolyline()
Public Overridable Function GetBoundingPolyline As Point3dCollection
public:
virtual Point3dCollection^ GetBoundingPolyline()


GetDimstyleData Method

GetDimstyleData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »GetDimstyleData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DimStyleTableRecord GetDimstyleData()
Public Function GetDimstyleData As DimStyleTableRecord
public:
DimStyleTableRecord^ GetDimstyleData()


Location Property

Location Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Location
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d Location { get; set; }
Public Overridable Property Location As Point3d
    Get
    Set
public:
virtual property Point3d Location {
    Point3d get ();
    void set (Point3d value);
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Normal
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d Normal { get; }
Public Overridable ReadOnly Property Normal As Vector3d
    Get
public:
virtual property Vector3d Normal {
    Vector3d get ();
}


SetDimstyleData Method (style)

SetDimstyleData Method (style)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »SetDimstyleData(DimStyleTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDimstyleData(
    DimStyleTableRecord style
)
Public Sub SetDimstyleData ( _
    style As DimStyleTableRecord _
)
public:
void SetDimstyleData(
    DimStyleTableRecord^ style
)
Parameters
style(DimStyleTableRecord)


SetOrientation Method (norm, dir)

SetOrientation Method (norm, dir)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »SetOrientation(Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetOrientation(
    Vector3d norm,
    Vector3d dir
)
Public Overridable Sub SetOrientation ( _
    norm As Vector3d, _
    dir As Vector3d _
)
public:
virtual void SetOrientation(
    Vector3d norm,
    Vector3d dir
)
Parameters
norm(Vector3d)
dir(Vector3d)


Text Property

Text Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Text
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}


TextStyleId Property

TextStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »TextStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId TextStyleId { get; set; }
Public Property TextStyleId As ObjectId
    Get
    Set
public:
property ObjectId TextStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


TextStyleName Property

TextStyleName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »TextStyleName
Declaration Syntax
C# Visual Basic Visual C++
public string TextStyleName { get; set; }
Public Property TextStyleName As String
    Get
    Set
public:
property String^ TextStyleName {
    String^ get ();
    void set (String^ value);
}


Field Class

Field Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbField")]
public class Field : DBObject
<WrapperAttribute("AcDbField")> _
Public Class Field _
    Inherits DBObject
[WrapperAttribute(L"AcDbField")]
public ref class Field : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Field(String, Boolean) |
 | Field(String) |
 | Field()()()() |
 | Field(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | ConvertToTextField()()()() |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DataType |
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Evaluate(Int32, Database) |
 | Evaluate()()()() |
 | EvaluationOption |
 | EvaluationStatus |
 | EvaluatorId |
 | ExtensionDictionary | (Inherited from DBObject.)
 | FilingOption |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FindField(String, Int32, Int32%, Int32%) |
 | Format |
 | GetChildren()()()() |
 | GetData(String) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFieldCode(FieldCodeFlags) |
 | GetFieldCode()()()() |
 | GetFieldCodeWithChildren(FieldCodeFlags) |
 | GetFieldCodeWithChildren()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStringValue()()()() |
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | HyperLink |
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTextField |
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetData(String, Object, Boolean) |
 | SetData(String, Object) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFieldCode(String) |
 | SetFieldCodeWithChildren(FieldCodeFlags, FieldCodeWithChildren) |
 | SetFieldCodeWithChildren(FieldCodeWithChildren) |
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | State |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | Value |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Field


Field Constructor

Field Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Field()()()()
Members
Icon | Member | Description
 | Field(String, Boolean) |
 | Field(String) |
 | Field()()()() |
 | Field(IntPtr, Boolean) |


Field Constructor

Field Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Field()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Field()
Public Sub New
public:
Field()


Field Constructor (unmanagedPointer, autoDelete)

Field Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Field(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Field(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Field(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Field Constructor (fieldCode)

Field Constructor (fieldCode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Field(String)
Declaration Syntax
C# Visual Basic Visual C++
public Field(
    string fieldCode
)
Public Sub New ( _
    fieldCode As String _
)
public:
Field(
    String^ fieldCode
)
Parameters
fieldCode(String)


Field Constructor (fieldCode, textField)

Field Constructor (fieldCode, textField)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Field(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Field(
    string fieldCode,
    bool textField
)
Public Sub New ( _
    fieldCode As String, _
    textField As Boolean _
)
public:
Field(
    String^ fieldCode,
    bool textField
)
Parameters
fieldCode(String)
textField(Boolean)


ConvertToTextField Method

ConvertToTextField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »ConvertToTextField()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ConvertToTextField()
Public Sub ConvertToTextField
public:
void ConvertToTextField()


DataType Property

DataType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »DataType
Declaration Syntax
C# Visual Basic Visual C++
public DataType DataType { get; }
Public ReadOnly Property DataType As DataType
    Get
public:
property DataType DataType {
    DataType get ();
}


Evaluate Method

Evaluate Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Evaluate()()()()
Members
Icon | Member | Description
 | Evaluate(Int32, Database) |
 | Evaluate()()()() |


Evaluate Method

Evaluate Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Evaluate()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Evaluate()
Public Sub Evaluate
public:
void Evaluate()


Evaluate Method (evaluationOptions, database)

Evaluate Method (evaluationOptions, database)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Evaluate(Int32, Database)
Declaration Syntax
C# Visual Basic Visual C++
public void Evaluate(
    int evaluationOptions,
    Database database
)
Public Sub Evaluate ( _
    evaluationOptions As Integer, _
    database As Database _
)
public:
void Evaluate(
    int evaluationOptions,
    Database^ database
)
Parameters
evaluationOptions(Int32)
database(Database)


EvaluationOption Property

EvaluationOption Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »EvaluationOption
Declaration Syntax
C# Visual Basic Visual C++
public FieldEvaluationOptions EvaluationOption { get; set; }
Public Property EvaluationOption As FieldEvaluationOptions
    Get
    Set
public:
property FieldEvaluationOptions EvaluationOption {
    FieldEvaluationOptions get ();
    void set (FieldEvaluationOptions value);
}


EvaluationStatus Property

EvaluationStatus Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »EvaluationStatus
Declaration Syntax
C# Visual Basic Visual C++
public FieldEvaluationStatusResult EvaluationStatus { get; }
Public ReadOnly Property EvaluationStatus As FieldEvaluationStatusResult
    Get
public:
property FieldEvaluationStatusResult EvaluationStatus {
    FieldEvaluationStatusResult get ();
}


EvaluatorId Property

EvaluatorId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »EvaluatorId
Declaration Syntax
C# Visual Basic Visual C++
public string EvaluatorId { get; set; }
Public Property EvaluatorId As String
    Get
    Set
public:
property String^ EvaluatorId {
    String^ get ();
    void set (String^ value);
}


FilingOption Property

FilingOption Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »FilingOption
Declaration Syntax
C# Visual Basic Visual C++
public FieldFilingOptions FilingOption { get; set; }
Public Property FilingOption As FieldFilingOptions
    Get
    Set
public:
property FieldFilingOptions FilingOption {
    FieldFilingOptions get ();
    void set (FieldFilingOptions value);
}


FindField Method (text, iSearchFrom, nStartPos, nEndPos)

FindField Method (text, iSearchFrom, nStartPos, nEndPos)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »FindField(String, Int32, Int32%, Int32%)
Declaration Syntax
C# Visual Basic Visual C++
public static bool FindField(
    string text,
    int iSearchFrom,
    ref int nStartPos,
    ref int nEndPos
)
Public Shared Function FindField ( _
    text As String, _
    iSearchFrom As Integer, _
    ByRef nStartPos As Integer, _
    ByRef nEndPos As Integer _
) As Boolean
public:
static bool FindField(
    String^ text,
    int iSearchFrom,
    int% nStartPos,
    int% nEndPos
)
Parameters
text(String)
iSearchFrom(Int32)
nStartPos(Int32%)
nEndPos(Int32%)


Format Property

Format Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Format
Declaration Syntax
C# Visual Basic Visual C++
public string Format { get; set; }
Public Property Format As String
    Get
    Set
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}


GetChildren Method

GetChildren Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetChildren()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Field[] GetChildren()
Public Function GetChildren As Field()
public:
array<Field^>^ GetChildren()


GetData Method (key)

GetData Method (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetData(String)
Declaration Syntax
C# Visual Basic Visual C++
public Object GetData(
    string key
)
Public Function GetData ( _
    key As String _
) As Object
public:
Object^ GetData(
    String^ key
)
Parameters
key(String)


GetFieldCode Method

GetFieldCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetFieldCode()()()()
Members
Icon | Member | Description
 | GetFieldCode(FieldCodeFlags) |
 | GetFieldCode()()()() |


GetFieldCode Method

GetFieldCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetFieldCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string GetFieldCode()
Public Function GetFieldCode As String
public:
String^ GetFieldCode()


GetFieldCode Method (flags)

GetFieldCode Method (flags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetFieldCode(FieldCodeFlags)
Declaration Syntax
C# Visual Basic Visual C++
public string GetFieldCode(
    FieldCodeFlags flags
)
Public Function GetFieldCode ( _
    flags As FieldCodeFlags _
) As String
public:
String^ GetFieldCode(
    FieldCodeFlags flags
)
Parameters
flags(FieldCodeFlags)


GetFieldCodeWithChildren Method

GetFieldCodeWithChildren Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetFieldCodeWithChildren()()()()
Members
Icon | Member | Description
 | GetFieldCodeWithChildren(FieldCodeFlags) |
 | GetFieldCodeWithChildren()()()() |


GetFieldCodeWithChildren Method

GetFieldCodeWithChildren Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetFieldCodeWithChildren()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FieldCodeWithChildren GetFieldCodeWithChildren()
Public Function GetFieldCodeWithChildren As FieldCodeWithChildren
public:
FieldCodeWithChildren^ GetFieldCodeWithChildren()


GetFieldCodeWithChildren Method (flags)

GetFieldCodeWithChildren Method (flags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetFieldCodeWithChildren(FieldCodeFlags)
Declaration Syntax
C# Visual Basic Visual C++
public FieldCodeWithChildren GetFieldCodeWithChildren(
    FieldCodeFlags flags
)
Public Function GetFieldCodeWithChildren ( _
    flags As FieldCodeFlags _
) As FieldCodeWithChildren
public:
FieldCodeWithChildren^ GetFieldCodeWithChildren(
    FieldCodeFlags flags
)
Parameters
flags(FieldCodeFlags)


GetStringValue Method

GetStringValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetStringValue()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string GetStringValue()
Public Function GetStringValue As String
public:
String^ GetStringValue()


HyperLink Property

HyperLink Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »HyperLink
Declaration Syntax
C# Visual Basic Visual C++
public HyperLink HyperLink { get; set; }
Public Property HyperLink As HyperLink
    Get
    Set
public:
property HyperLink^ HyperLink {
    HyperLink^ get ();
    void set (HyperLink^ value);
}


IsTextField Property

IsTextField Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »IsTextField
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTextField { get; }
Public ReadOnly Property IsTextField As Boolean
    Get
public:
property bool IsTextField {
    bool get ();
}


SetData Method

SetData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »SetData()()()()
Members
Icon | Member | Description
 | SetData(String, Object, Boolean) |
 | SetData(String, Object) |


SetData Method (key, data)

SetData Method (key, data)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »SetData(String, Object)
Declaration Syntax
C# Visual Basic Visual C++
public void SetData(
    string key,
    Object data
)
Public Sub SetData ( _
    key As String, _
    data As Object _
)
public:
void SetData(
    String^ key,
    Object^ data
)
Parameters
key(String)
data(Object)


SetData Method (key, data, recursive)

SetData Method (key, data, recursive)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »SetData(String, Object, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetData(
    string key,
    Object data,
    bool recursive
)
Public Sub SetData ( _
    key As String, _
    data As Object, _
    recursive As Boolean _
)
public:
void SetData(
    String^ key,
    Object^ data,
    bool recursive
)
Parameters
key(String)
data(Object)
recursive(Boolean)


SetFieldCode Method (fieldCode)

SetFieldCode Method (fieldCode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »SetFieldCode(String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFieldCode(
    string fieldCode
)
Public Sub SetFieldCode ( _
    fieldCode As String _
)
public:
void SetFieldCode(
    String^ fieldCode
)
Parameters
fieldCode(String)


SetFieldCodeWithChildren Method

SetFieldCodeWithChildren Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »SetFieldCodeWithChildren()()()()
Members
Icon | Member | Description
 | SetFieldCodeWithChildren(FieldCodeFlags, FieldCodeWithChildren) |
 | SetFieldCodeWithChildren(FieldCodeWithChildren) |


SetFieldCodeWithChildren Method (flag, fieldCode)

SetFieldCodeWithChildren Method (flag, fieldCode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »SetFieldCodeWithChildren(FieldCodeFlags, FieldCodeWithChildren)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFieldCodeWithChildren(
    FieldCodeFlags flag,
    FieldCodeWithChildren fieldCode
)
Public Sub SetFieldCodeWithChildren ( _
    flag As FieldCodeFlags, _
    fieldCode As FieldCodeWithChildren _
)
public:
void SetFieldCodeWithChildren(
    FieldCodeFlags flag,
    FieldCodeWithChildren^ fieldCode
)
Parameters
flag(FieldCodeFlags)
fieldCode(FieldCodeWithChildren)


SetFieldCodeWithChildren Method (fieldCode)

SetFieldCodeWithChildren Method (fieldCode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »SetFieldCodeWithChildren(FieldCodeWithChildren)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFieldCodeWithChildren(
    FieldCodeWithChildren fieldCode
)
Public Sub SetFieldCodeWithChildren ( _
    fieldCode As FieldCodeWithChildren _
)
public:
void SetFieldCodeWithChildren(
    FieldCodeWithChildren^ fieldCode
)
Parameters
fieldCode(FieldCodeWithChildren)


State Property

State Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »State
Declaration Syntax
C# Visual Basic Visual C++
public FieldState State { get; }
Public ReadOnly Property State As FieldState
    Get
public:
property FieldState State {
    FieldState get ();
}


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Value
Declaration Syntax
C# Visual Basic Visual C++
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
public:
property Object^ Value {
    Object^ get ();
}


FieldCodeFlags Enumeration

FieldCodeFlags Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldCodeFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum FieldCodeFlags
<FlagsAttribute> _
Public Enumeration FieldCodeFlags
[FlagsAttribute]
public enum class FieldCodeFlags
Members
Member | Description
TextField |
PreserveFields |
StripOptions |
EscapeBackslash |
AddMarkers |
ObjectReference |
EvaluatedChildren |
EvaluatedText |
FieldCode |


FieldCodeWithChildren Class

FieldCodeWithChildren Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldCodeWithChildren
Declaration Syntax
C# Visual Basic Visual C++
public class FieldCodeWithChildren
Public Class FieldCodeWithChildren
public ref class FieldCodeWithChildren
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(Int32, Field) |
 | Children |
 | Equals(Object) | (Inherited from Object.)
 | FieldCode |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
FieldCodeWithChildren


Add Method (i, field)

Add Method (i, field)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldCodeWithChildren »Add(Int32, Field)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    int i,
    Field field
)
Public Sub Add ( _
    i As Integer, _
    field As Field _
)
public:
void Add(
    int i,
    Field^ field
)
Parameters
i(Int32)
field(Field)


Children Property

Children Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldCodeWithChildren »Children
Declaration Syntax
C# Visual Basic Visual C++
public Field[] Children { get; }
Public ReadOnly Property Children As Field()
    Get
public:
property array<Field^>^ Children {
    array<Field^>^ get ();
}


FieldCode Property

FieldCode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldCodeWithChildren »FieldCode
Declaration Syntax
C# Visual Basic Visual C++
public string FieldCode { get; set; }
Public Property FieldCode As String
    Get
    Set
public:
property String^ FieldCode {
    String^ get ();
    void set (String^ value);
}


FieldEngine Class

FieldEngine Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdFdFieldEngine")]
public class FieldEngine : RXObject
<WrapperAttribute("OdFdFieldEngine")> _
Public Class FieldEngine _
    Inherits RXObject
[WrapperAttribute(L"OdFdFieldEngine")]
public ref class FieldEngine : public RXObject
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluateFields(Database, Int32, ObjectIdCollection, ObjectIdCollection, String, EvalFields) |
 | EvaluatorLoaderCount |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FindEvaluator(Field, String%) |
 | GetEvaluator(String) |
 | GetEvaluatorLoader(Int32) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | Global |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RegisterEvaluatorLoader(FieldEvaluatorLoader) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UnregisterEvaluatorLoader(FieldEvaluatorLoader) |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | FieldEngine


EvaluateFields Method (pDb, nContext, objIds, pFieldsToEvaluate, pszEvaluatorId, nEvalFlag)

EvaluateFields Method (pDb, nContext, objIds, pFieldsToEvaluate, pszEvaluatorId, nEvalFlag)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine »EvaluateFields(Database, Int32, ObjectIdCollection, ObjectIdCollection, String, EvalFields)
Declaration Syntax
C# Visual Basic Visual C++
public static FieldUpdateResult EvaluateFields(
    Database pDb,
    int nContext,
    ObjectIdCollection objIds,
    ObjectIdCollection pFieldsToEvaluate,
    string pszEvaluatorId,
    EvalFields nEvalFlag
)
Public Shared Function EvaluateFields ( _
    pDb As Database, _
    nContext As Integer, _
    objIds As ObjectIdCollection, _
    pFieldsToEvaluate As ObjectIdCollection, _
    pszEvaluatorId As String, _
    nEvalFlag As EvalFields _
) As FieldUpdateResult
public:
static FieldUpdateResult EvaluateFields(
    Database^ pDb,
    int nContext,
    ObjectIdCollection^ objIds,
    ObjectIdCollection^ pFieldsToEvaluate,
    String^ pszEvaluatorId,
    EvalFields nEvalFlag
)
Parameters
pDb(Database)
nContext(Int32)
objIds(ObjectIdCollection)
pFieldsToEvaluate(ObjectIdCollection)
pszEvaluatorId(String)
nEvalFlag(EvalFields)


EvaluatorLoaderCount Property

EvaluatorLoaderCount Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine »EvaluatorLoaderCount
Declaration Syntax
C# Visual Basic Visual C++
public int EvaluatorLoaderCount { get; }
Public ReadOnly Property EvaluatorLoaderCount As Integer
    Get
public:
property int EvaluatorLoaderCount {
    int get ();
}


FindEvaluator Method (pField, pszEvalId)

FindEvaluator Method (pField, pszEvalId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine »FindEvaluator(Field, String%)
Declaration Syntax
C# Visual Basic Visual C++
public virtual FieldEvaluator FindEvaluator(
    Field pField,
    ref string pszEvalId
)
Public Overridable Function FindEvaluator ( _
    pField As Field, _
    ByRef pszEvalId As String _
) As FieldEvaluator
public:
virtual FieldEvaluator^ FindEvaluator(
    Field^ pField,
    String^% pszEvalId
)
Parameters
pField(Field)
pszEvalId(String%)


GetEvaluator Method (pszEvalId)

GetEvaluator Method (pszEvalId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine »GetEvaluator(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual FieldEvaluator GetEvaluator(
    string pszEvalId
)
Public Overridable Function GetEvaluator ( _
    pszEvalId As String _
) As FieldEvaluator
public:
virtual FieldEvaluator^ GetEvaluator(
    String^ pszEvalId
)
Parameters
pszEvalId(String)


GetEvaluatorLoader Method (inputIndex)

GetEvaluatorLoader Method (inputIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine »GetEvaluatorLoader(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual FieldEvaluatorLoader GetEvaluatorLoader(
    int inputIndex
)
Public Overridable Function GetEvaluatorLoader ( _
    inputIndex As Integer _
) As FieldEvaluatorLoader
public:
virtual FieldEvaluatorLoader^ GetEvaluatorLoader(
    int inputIndex
)
Parameters
inputIndex(Int32)


Global Property

Global Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine »Global
Declaration Syntax
C# Visual Basic Visual C++
public static FieldEngine Global { get; }
Public Shared ReadOnly Property Global As FieldEngine
    Get
public:
static property FieldEngine^ Global {
    FieldEngine^ get ();
}


RegisterEvaluatorLoader Method (pLoader)

RegisterEvaluatorLoader Method (pLoader)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine »RegisterEvaluatorLoader(FieldEvaluatorLoader)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RegisterEvaluatorLoader(
    FieldEvaluatorLoader pLoader
)
Public Overridable Sub RegisterEvaluatorLoader ( _
    pLoader As FieldEvaluatorLoader _
)
public:
virtual void RegisterEvaluatorLoader(
    FieldEvaluatorLoader^ pLoader
)
Parameters
pLoader(FieldEvaluatorLoader)


UnregisterEvaluatorLoader Method (pLoader)

UnregisterEvaluatorLoader Method (pLoader)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine »UnregisterEvaluatorLoader(FieldEvaluatorLoader)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UnregisterEvaluatorLoader(
    FieldEvaluatorLoader pLoader
)
Public Overridable Sub UnregisterEvaluatorLoader ( _
    pLoader As FieldEvaluatorLoader _
)
public:
virtual void UnregisterEvaluatorLoader(
    FieldEvaluatorLoader^ pLoader
)
Parameters
pLoader(FieldEvaluatorLoader)


FieldEvaluationContext Enumeration

FieldEvaluationContext Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationContext
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum FieldEvaluationContext
<FlagsAttribute> _
Public Enumeration FieldEvaluationContext
[FlagsAttribute]
public enum class FieldEvaluationContext
Members
Member | Description
Preview |
Regen |
Etransmit |
Plot |
Demand |
Save |
Open |


FieldEvaluationOptions Enumeration

FieldEvaluationOptions Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationOptions
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum FieldEvaluationOptions
<FlagsAttribute> _
Public Enumeration FieldEvaluationOptions
[FlagsAttribute]
public enum class FieldEvaluationOptions
Members
Member | Description
OnSave |
Automatic |
OnDemand |
OnRegen |
OnEtransmit |
OnPlot |
OnOpen |
Disable |


FieldEvaluationResult Structure

FieldEvaluationResult Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationResult
Declaration Syntax
C# Visual Basic Visual C++
public struct FieldEvaluationResult
Public Structure FieldEvaluationResult
public value class FieldEvaluationResult
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from ValueType.)
 | Evaluated |
 | Finalize()()()() | (Inherited from Object.)
 | Found |
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)


Evaluated Property

Evaluated Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationResult »Evaluated
Declaration Syntax
C# Visual Basic Visual C++
public int Evaluated { get; }
Public ReadOnly Property Evaluated As Integer
    Get
public:
property int Evaluated {
    int get ();
}


Found Property

Found Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationResult »Found
Declaration Syntax
C# Visual Basic Visual C++
public int Found { get; }
Public ReadOnly Property Found As Integer
    Get
public:
property int Found {
    int get ();
}


FieldEvaluationStatus Enumeration

FieldEvaluationStatus Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationStatus
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum FieldEvaluationStatus
<FlagsAttribute> _
Public Enumeration FieldEvaluationStatus
[FlagsAttribute]
public enum class FieldEvaluationStatus
Members
Member | Description
InvalidContext |
OtherError |
InvalidCode |
SyntaxError |
EvaluatorNotFound |
Success |
NotYetEvaluated |


FieldEvaluationStatusResult Structure

FieldEvaluationStatusResult Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationStatusResult
Declaration Syntax
C# Visual Basic Visual C++
public struct FieldEvaluationStatusResult
Public Structure FieldEvaluationStatusResult
public value class FieldEvaluationStatusResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldEvaluationStatusResult(FieldEvaluationStatus, Int32, String) |
 | Equals(Object) | (Inherited from ValueType.)
 | ErrorCode |
 | ErrorMessage |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | ToString()()()() | (Inherited from ValueType.)


FieldEvaluationStatusResult Constructor (s, e, m)

FieldEvaluationStatusResult Constructor (s, e, m)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationStatusResult »FieldEvaluationStatusResult(FieldEvaluationStatus, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public FieldEvaluationStatusResult(
    FieldEvaluationStatus s,
    int e,
    string m
)
Public Sub New ( _
    s As FieldEvaluationStatus, _
    e As Integer, _
    m As String _
)
public:
FieldEvaluationStatusResult(
    FieldEvaluationStatus s,
    int e,
    String^ m
)
Parameters
s(FieldEvaluationStatus)
e(Int32)
m(String)


ErrorCode Property

ErrorCode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationStatusResult »ErrorCode
Declaration Syntax
C# Visual Basic Visual C++
public int ErrorCode { get; }
Public ReadOnly Property ErrorCode As Integer
    Get
public:
property int ErrorCode {
    int get ();
}


ErrorMessage Property

ErrorMessage Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationStatusResult »ErrorMessage
Declaration Syntax
C# Visual Basic Visual C++
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
public:
property String^ ErrorMessage {
    String^ get ();
}


Status Property

Status Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluationStatusResult »Status
Declaration Syntax
C# Visual Basic Visual C++
public FieldEvaluationStatus Status { get; }
Public ReadOnly Property Status As FieldEvaluationStatus
    Get
public:
property FieldEvaluationStatus Status {
    FieldEvaluationStatus get ();
}


FieldEvaluator Class

FieldEvaluator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdFdFieldEvaluator")]
public abstract class FieldEvaluator : RXObject
<WrapperAttribute("OdFdFieldEvaluator")> _
Public MustInherit Class FieldEvaluator _
    Inherits RXObject
[WrapperAttribute(L"OdFdFieldEvaluator")]
public ref class FieldEvaluator abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldEvaluator()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Compile(Field, Database, FieldResult) |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Evaluate(Field, Int32, Database, FieldResult) |
 | EvaluatorId(Field) |
 | EvaluatorId()()()() |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | Format(Field) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | Initialize(Field) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | FieldEvaluator


FieldEvaluator Constructor

FieldEvaluator Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator »FieldEvaluator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FieldEvaluator()
Public Sub New
public:
FieldEvaluator()


Compile Method (pField, pDb, result)

Compile Method (pField, pDb, result)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator »Compile(Field, Database, FieldResult)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Compile(
    Field pField,
    Database pDb,
    FieldResult result
)
Public MustOverride Sub Compile ( _
    pField As Field, _
    pDb As Database, _
    result As FieldResult _
)
public:
virtual void Compile(
    Field^ pField,
    Database^ pDb,
    FieldResult^ result
) abstract
Parameters
pField(Field)
pDb(Database)
result(FieldResult)


Evaluate Method (pField, nContext, pDb, pResult)

Evaluate Method (pField, nContext, pDb, pResult)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator »Evaluate(Field, Int32, Database, FieldResult)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Evaluate(
    Field pField,
    int nContext,
    Database pDb,
    FieldResult pResult
)
Public MustOverride Sub Evaluate ( _
    pField As Field, _
    nContext As Integer, _
    pDb As Database, _
    pResult As FieldResult _
)
public:
virtual void Evaluate(
    Field^ pField,
    int nContext,
    Database^ pDb,
    FieldResult^ pResult
) abstract
Parameters
pField(Field)
nContext(Int32)
pDb(Database)
pResult(FieldResult)


EvaluatorId Method

EvaluatorId Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator »EvaluatorId()()()()
Members
Icon | Member | Description
 | EvaluatorId(Field) |
 | EvaluatorId()()()() |


EvaluatorId Method

EvaluatorId Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator »EvaluatorId()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract string EvaluatorId()
Public MustOverride Function EvaluatorId As String
public:
virtual String^ EvaluatorId() abstract


EvaluatorId Method (pField)

EvaluatorId Method (pField)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator »EvaluatorId(Field)
Declaration Syntax
C# Visual Basic Visual C++
public abstract string EvaluatorId(
    Field pField
)
Public MustOverride Function EvaluatorId ( _
    pField As Field _
) As String
public:
virtual String^ EvaluatorId(
    Field^ pField
) abstract
Parameters
pField(Field)


Format Method (pField)

Format Method (pField)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator »Format(Field)
Declaration Syntax
C# Visual Basic Visual C++
public abstract string Format(
    Field pField
)
Public MustOverride Function Format ( _
    pField As Field _
) As String
public:
virtual String^ Format(
    Field^ pField
) abstract
Parameters
pField(Field)


Initialize Method (pField)

Initialize Method (pField)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator »Initialize(Field)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Initialize(
    Field pField
)
Public MustOverride Sub Initialize ( _
    pField As Field _
)
public:
virtual void Initialize(
    Field^ pField
) abstract
Parameters
pField(Field)


FieldEvaluatorLoader Class

FieldEvaluatorLoader Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluatorLoader
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdFdFieldEvaluatorLoader")]
public abstract class FieldEvaluatorLoader : RXObject
<WrapperAttribute("OdFdFieldEvaluatorLoader")> _
Public MustInherit Class FieldEvaluatorLoader _
    Inherits RXObject
[WrapperAttribute(L"OdFdFieldEvaluatorLoader")]
public ref class FieldEvaluatorLoader abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldEvaluatorLoader()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FindEvaluator(Field, String%) |
 | GetEvaluator(String) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | FieldEvaluatorLoader


FieldEvaluatorLoader Constructor

FieldEvaluatorLoader Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluatorLoader »FieldEvaluatorLoader()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FieldEvaluatorLoader()
Public Sub New
public:
FieldEvaluatorLoader()


FindEvaluator Method (pField, pszEvalId)

FindEvaluator Method (pField, pszEvalId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluatorLoader »FindEvaluator(Field, String%)
Declaration Syntax
C# Visual Basic Visual C++
public abstract FieldEvaluator FindEvaluator(
    Field pField,
    ref string pszEvalId
)
Public MustOverride Function FindEvaluator ( _
    pField As Field, _
    ByRef pszEvalId As String _
) As FieldEvaluator
public:
virtual FieldEvaluator^ FindEvaluator(
    Field^ pField,
    String^% pszEvalId
) abstract
Parameters
pField(Field)
pszEvalId(String%)


GetEvaluator Method (pszEvalId)

GetEvaluator Method (pszEvalId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluatorLoader »GetEvaluator(String)
Declaration Syntax
C# Visual Basic Visual C++
public abstract FieldEvaluator GetEvaluator(
    string pszEvalId
)
Public MustOverride Function GetEvaluator ( _
    pszEvalId As String _
) As FieldEvaluator
public:
virtual FieldEvaluator^ GetEvaluator(
    String^ pszEvalId
) abstract
Parameters
pszEvalId(String)


FieldFilingOptions Enumeration

FieldFilingOptions Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldFilingOptions
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum FieldFilingOptions
<FlagsAttribute> _
Public Enumeration FieldFilingOptions
[FlagsAttribute]
public enum class FieldFilingOptions
Members
Member | Description
SkipFilingResult |


FieldResult Class

FieldResult Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResult
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdFdFieldResult")]
public abstract class FieldResult : RXObject
<WrapperAttribute("OdFdFieldResult")> _
Public MustInherit Class FieldResult _
    Inherits RXObject
[WrapperAttribute(L"OdFdFieldResult")]
public ref class FieldResult abstract : public RXObject
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | setEvaluationStatus(FieldEvaluationStatus, Int32, String) |
 | SetFieldValue(Object) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | FieldResult
 |  |  |  |  | FieldResultImp


setEvaluationStatus Method (errorStatus, errorCode, errorMessage)

setEvaluationStatus Method (errorStatus, errorCode, errorMessage)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResult »setEvaluationStatus(FieldEvaluationStatus, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void setEvaluationStatus(
    FieldEvaluationStatus errorStatus,
    int errorCode,
    string errorMessage
)
Public MustOverride Sub setEvaluationStatus ( _
    errorStatus As FieldEvaluationStatus, _
    errorCode As Integer, _
    errorMessage As String _
)
public:
virtual void setEvaluationStatus(
    FieldEvaluationStatus errorStatus,
    int errorCode,
    String^ errorMessage
) abstract
Parameters
errorStatus(FieldEvaluationStatus)
errorCode(Int32)
errorMessage(String)


SetFieldValue Method (pValue)

SetFieldValue Method (pValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResult »SetFieldValue(Object)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void SetFieldValue(
    Object pValue
)
Public MustOverride Sub SetFieldValue ( _
    pValue As Object _
)
public:
virtual void SetFieldValue(
    Object^ pValue
) abstract
Parameters
pValue(Object)


FieldResultImp Class

FieldResultImp Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResultImp
Declaration Syntax
C# Visual Basic Visual C++
public class FieldResultImp : FieldResult
Public Class FieldResultImp _
    Inherits FieldResult
public ref class FieldResultImp : public FieldResult
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FieldResultImp(ZcFdFieldResult*) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetUnmanagedObject()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | setEvaluationStatus(FieldEvaluationStatus, Int32, String) | (Overrides FieldResult.setEvaluationStatus(FieldEvaluationStatus, Int32, String).)
 | SetFieldValue(Object) | (Overrides FieldResult.SetFieldValue(Object).)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | FieldResult
 |  |  |  |  | FieldResultImp


FieldResultImp Constructor (fr)

FieldResultImp Constructor (fr)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResultImp »FieldResultImp(ZcFdFieldResult*)
Declaration Syntax
C# Visual Basic Visual C++
public FieldResultImp(
    ZcFdFieldResult* fr
)
Visual Basic does not support APIs that consume or return unsafe types.
public:
FieldResultImp(
    ZcFdFieldResult* fr
)
Parameters
fr(ZcFdFieldResult*)


GetUnmanagedObject Method

GetUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResultImp »GetUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ZcFdFieldResult* GetUnmanagedObject()
Public Function GetUnmanagedObject As ZcFdFieldResult*
public:
ZcFdFieldResult* GetUnmanagedObject()


setEvaluationStatus Method (errorStatus, errorCode, errorMessage)

setEvaluationStatus Method (errorStatus, errorCode, errorMessage)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResultImp »setEvaluationStatus(FieldEvaluationStatus, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public override void setEvaluationStatus(
    FieldEvaluationStatus errorStatus,
    int errorCode,
    string errorMessage
)
Public Overrides Sub setEvaluationStatus ( _
    errorStatus As FieldEvaluationStatus, _
    errorCode As Integer, _
    errorMessage As String _
)
public:
virtual void setEvaluationStatus(
    FieldEvaluationStatus errorStatus,
    int errorCode,
    String^ errorMessage
) override
Parameters
errorStatus(FieldEvaluationStatus)
errorCode(Int32)
errorMessage(String)


SetFieldValue Method (pValue)

SetFieldValue Method (pValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResultImp »SetFieldValue(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override void SetFieldValue(
    Object pValue
)
Public Overrides Sub SetFieldValue ( _
    pValue As Object _
)
public:
virtual void SetFieldValue(
    Object^ pValue
) override
Parameters
pValue(Object)


FieldState Enumeration

FieldState Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldState
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum FieldState
<FlagsAttribute> _
Public Enumeration FieldState
[FlagsAttribute]
public enum class FieldState
Members
Member | Description
Modified |
HasFormattedString |
HasCache |
Compiled |
Initialized |
Evaluated |


FieldUpdateResult Structure

FieldUpdateResult Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldUpdateResult
Declaration Syntax
C# Visual Basic Visual C++
public struct FieldUpdateResult
Public Structure FieldUpdateResult
public value class FieldUpdateResult
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumEvaluated |
 | NumFound |
 | ToString()()()() | (Inherited from ValueType.)


NumEvaluated Field

NumEvaluated Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldUpdateResult »NumEvaluated
Declaration Syntax
C# Visual Basic Visual C++
public int NumEvaluated
Public NumEvaluated As Integer
public:
int NumEvaluated


NumFound Field

NumFound Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldUpdateResult »NumFound
Declaration Syntax
C# Visual Basic Visual C++
public int NumFound
Public NumFound As Integer
public:
int NumFound


FileDependencyInfo Structure

FileDependencyInfo Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdFileDependencyInfo")]
public struct FileDependencyInfo
<WrapperAttribute("OdFileDependencyInfo")> _
Public Structure FileDependencyInfo
[WrapperAttribute(L"OdFileDependencyInfo")]
public value class FileDependencyInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from ValueType.)
 | Feature |
 | FileName |
 | FileSize |
 | Finalize()()()() | (Inherited from Object.)
 | FingerprintGuid |
 | FoundPath |
 | FullFileName |
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Index |
 | IsAffectsGraphics |
 | IsModified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReferenceCount |
 | TimeStamp |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | VersionGuid |


Feature Property

Feature Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »Feature
Declaration Syntax
C# Visual Basic Visual C++
public string Feature { get; }
Public ReadOnly Property Feature As String
    Get
public:
property String^ Feature {
    String^ get ();
}


FileName Property

FileName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »FileName
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}


FileSize Property

FileSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »FileSize
Declaration Syntax
C# Visual Basic Visual C++
public int FileSize { get; }
Public ReadOnly Property FileSize As Integer
    Get
public:
property int FileSize {
    int get ();
}


FingerprintGuid Property

FingerprintGuid Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »FingerprintGuid
Declaration Syntax
C# Visual Basic Visual C++
public string FingerprintGuid { get; }
Public ReadOnly Property FingerprintGuid As String
    Get
public:
property String^ FingerprintGuid {
    String^ get ();
}


FoundPath Property

FoundPath Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »FoundPath
Declaration Syntax
C# Visual Basic Visual C++
public string FoundPath { get; }
Public ReadOnly Property FoundPath As String
    Get
public:
property String^ FoundPath {
    String^ get ();
}


FullFileName Property

FullFileName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »FullFileName
Declaration Syntax
C# Visual Basic Visual C++
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}


Index Property

Index Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »Index
Declaration Syntax
C# Visual Basic Visual C++
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}


IsAffectsGraphics Property

IsAffectsGraphics Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »IsAffectsGraphics
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAffectsGraphics { get; }
Public ReadOnly Property IsAffectsGraphics As Boolean
    Get
public:
property bool IsAffectsGraphics {
    bool get ();
}


IsModified Property

IsModified Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »IsModified
Declaration Syntax
C# Visual Basic Visual C++
public bool IsModified { get; }
Public ReadOnly Property IsModified As Boolean
    Get
public:
property bool IsModified {
    bool get ();
}


ReferenceCount Property

ReferenceCount Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »ReferenceCount
Declaration Syntax
C# Visual Basic Visual C++
public int ReferenceCount { get; }
Public ReadOnly Property ReferenceCount As Integer
    Get
public:
property int ReferenceCount {
    int get ();
}


TimeStamp Property

TimeStamp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »TimeStamp
Declaration Syntax
C# Visual Basic Visual C++
public int TimeStamp { get; }
Public ReadOnly Property TimeStamp As Integer
    Get
public:
property int TimeStamp {
    int get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


VersionGuid Property

VersionGuid Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyInfo »VersionGuid
Declaration Syntax
C# Visual Basic Visual C++
public string VersionGuid { get; }
Public ReadOnly Property VersionGuid As String
    Get
public:
property String^ VersionGuid {
    String^ get ();
}


FileDependencyManager Class

FileDependencyManager Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcFileDependencyManager")]
public sealed class FileDependencyManager : DisposableWrapper
<WrapperAttribute("ZcFileDependencyManager")> _
Public NotInheritable Class FileDependencyManager _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcFileDependencyManager")]
public ref class FileDependencyManager sealed : public DisposableWrapper
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CountEntries |
 | CreateEntry(String, String, Boolean, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EraseEntry(String, String, Boolean) |
 | EraseEntry(Int32, Boolean) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEntry(String, String) |
 | GetEntry(Int32) |
 | GetEntry(String, String, Boolean) |
 | GetEntry(Int32, Boolean) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IteratorInitialize(String, Boolean, Boolean, Boolean) |
 | IteratorNext |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateEntry(String, String) |
 | UpdateEntry(Int32) |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | FileDependencyManager


CountEntries Property

CountEntries Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »CountEntries
Declaration Syntax
C# Visual Basic Visual C++
public int CountEntries { get; }
Public ReadOnly Property CountEntries As Integer
    Get
public:
property int CountEntries {
    int get ();
}


CreateEntry Method (feature, fullFileName, affectsGraphics, noIncrement)

CreateEntry Method (feature, fullFileName, affectsGraphics, noIncrement)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »CreateEntry(String, String, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public int CreateEntry(
    string feature,
    string fullFileName,
    bool affectsGraphics,
    bool noIncrement
)
Public Function CreateEntry ( _
    feature As String, _
    fullFileName As String, _
    affectsGraphics As Boolean, _
    noIncrement As Boolean _
) As Integer
public:
int CreateEntry(
    String^ feature,
    String^ fullFileName,
    bool affectsGraphics,
    bool noIncrement
)
Parameters
feature(String)
fullFileName(String)
affectsGraphics(Boolean)
noIncrement(Boolean)


EraseEntry Method

EraseEntry Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »EraseEntry()()()()
Members
Icon | Member | Description
 | EraseEntry(String, String, Boolean) |
 | EraseEntry(Int32, Boolean) |


EraseEntry Method (index, forceRemove)

EraseEntry Method (index, forceRemove)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »EraseEntry(Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void EraseEntry(
    int index,
    bool forceRemove
)
Public Sub EraseEntry ( _
    index As Integer, _
    forceRemove As Boolean _
)
public:
void EraseEntry(
    int index,
    bool forceRemove
)
Parameters
index(Int32)
forceRemove(Boolean)


EraseEntry Method (feature, fullFileName, forceRemove)

EraseEntry Method (feature, fullFileName, forceRemove)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »EraseEntry(String, String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void EraseEntry(
    string feature,
    string fullFileName,
    bool forceRemove
)
Public Sub EraseEntry ( _
    feature As String, _
    fullFileName As String, _
    forceRemove As Boolean _
)
public:
void EraseEntry(
    String^ feature,
    String^ fullFileName,
    bool forceRemove
)
Parameters
feature(String)
fullFileName(String)
forceRemove(Boolean)


GetEntry Method

GetEntry Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »GetEntry()()()()
Members
Icon | Member | Description
 | GetEntry(String, String) |
 | GetEntry(Int32) |
 | GetEntry(String, String, Boolean) |
 | GetEntry(Int32, Boolean) |


GetEntry Method (fdlIndex)

GetEntry Method (fdlIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »GetEntry(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public FileDependencyInfo GetEntry(
    int fdlIndex
)
Public Function GetEntry ( _
    fdlIndex As Integer _
) As FileDependencyInfo
public:
FileDependencyInfo GetEntry(
    int fdlIndex
)
Parameters
fdlIndex(Int32)


GetEntry Method (fdlIndex, useCachedInfo)

GetEntry Method (fdlIndex, useCachedInfo)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »GetEntry(Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public FileDependencyInfo GetEntry(
    int fdlIndex,
    bool useCachedInfo
)
Public Function GetEntry ( _
    fdlIndex As Integer, _
    useCachedInfo As Boolean _
) As FileDependencyInfo
public:
FileDependencyInfo GetEntry(
    int fdlIndex,
    bool useCachedInfo
)
Parameters
fdlIndex(Int32)
useCachedInfo(Boolean)


GetEntry Method (feature, fullFileName)

GetEntry Method (feature, fullFileName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »GetEntry(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public FileDependencyInfo GetEntry(
    string feature,
    string fullFileName
)
Public Function GetEntry ( _
    feature As String, _
    fullFileName As String _
) As FileDependencyInfo
public:
FileDependencyInfo GetEntry(
    String^ feature,
    String^ fullFileName
)
Parameters
feature(String)
fullFileName(String)


GetEntry Method (feature, fullFileName, useCachedInfo)

GetEntry Method (feature, fullFileName, useCachedInfo)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »GetEntry(String, String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public FileDependencyInfo GetEntry(
    string feature,
    string fullFileName,
    bool useCachedInfo
)
Public Function GetEntry ( _
    feature As String, _
    fullFileName As String, _
    useCachedInfo As Boolean _
) As FileDependencyInfo
public:
FileDependencyInfo GetEntry(
    String^ feature,
    String^ fullFileName,
    bool useCachedInfo
)
Parameters
feature(String)
fullFileName(String)
useCachedInfo(Boolean)


IteratorInitialize Method (feature, modifiedOnly, affectsGraphicsOnly, walkXRefTree)

IteratorInitialize Method (feature, modifiedOnly, affectsGraphicsOnly, walkXRefTree)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »IteratorInitialize(String, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void IteratorInitialize(
    string feature,
    bool modifiedOnly,
    bool affectsGraphicsOnly,
    bool walkXRefTree
)
Public Sub IteratorInitialize ( _
    feature As String, _
    modifiedOnly As Boolean, _
    affectsGraphicsOnly As Boolean, _
    walkXRefTree As Boolean _
)
public:
void IteratorInitialize(
    String^ feature,
    bool modifiedOnly,
    bool affectsGraphicsOnly,
    bool walkXRefTree
)
Parameters
feature(String)
modifiedOnly(Boolean)
affectsGraphicsOnly(Boolean)
walkXRefTree(Boolean)


IteratorNext Property

IteratorNext Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »IteratorNext
Declaration Syntax
C# Visual Basic Visual C++
public int IteratorNext { get; }
Public ReadOnly Property IteratorNext As Integer
    Get
public:
property int IteratorNext {
    int get ();
}


UpdateEntry Method

UpdateEntry Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »UpdateEntry()()()()
Members
Icon | Member | Description
 | UpdateEntry(String, String) |
 | UpdateEntry(Int32) |


UpdateEntry Method (index)

UpdateEntry Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »UpdateEntry(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateEntry(
    int index
)
Public Sub UpdateEntry ( _
    index As Integer _
)
public:
void UpdateEntry(
    int index
)
Parameters
index(Int32)


UpdateEntry Method (feature, fullFileName)

UpdateEntry Method (feature, fullFileName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »UpdateEntry(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateEntry(
    string feature,
    string fullFileName
)
Public Sub UpdateEntry ( _
    feature As String, _
    fullFileName As String _
)
public:
void UpdateEntry(
    String^ feature,
    String^ fullFileName
)
Parameters
feature(String)
fullFileName(String)


FileOpenMode Enumeration

FileOpenMode Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileOpenMode
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbDatabase::OpenMode")]
public enum FileOpenMode
<WrapperAttribute("ZcDbDatabase::OpenMode")> _
Public Enumeration FileOpenMode
[WrapperAttribute(L"ZcDbDatabase::OpenMode")]
public enum class FileOpenMode
Members
Member | Description
OpenTryForReadShare |
OpenForReadAndAllShare |
OpenForReadAndWriteNoShare |
OpenForReadAndReadShare |


FilerType Enumeration

FilerType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FilerType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbFiler::FilerType")]
public enum FilerType
<WrapperAttribute("AcDbFiler::FilerType")> _
Public Enumeration FilerType
[WrapperAttribute(L"AcDbFiler::FilerType")]
public enum class FilerType
Members
Member | Description
WblockCloneFiler |
PurgeFiler |
IdFiler |
DeepCloneFiler |
PageFiler |
IdXlateFiler |
BagFiler |
UndoFiler |
CopyFiler |
FileFiler |


FillStyle Enumeration

FillStyle Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FillStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdPs::FillStyle")]
public enum FillStyle
<WrapperAttribute("OdPs::FillStyle")> _
Public Enumeration FillStyle
[WrapperAttribute(L"OdPs::FillStyle")]
public enum class FillStyle
Members
Member | Description
FsLast |
FsUseObject |
FsVerticalBars |
FsSquareDots |
FsSlantRight |
FsSlantLeft |
FsHorizontalBars |
FsDiamonds |
FsCrosshatch |
FsCheckerboard |
FsSolid |


FindFileHint Enumeration

FindFileHint Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FindFileHint
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbHostAppServices::FindFileHint")]
public enum FindFileHint
<WrapperAttribute("ZcDbHostAppServices::FindFileHint")> _
Public Enumeration FindFileHint
[WrapperAttribute(L"ZcDbHostAppServices::FindFileHint")]
public enum class FindFileHint
Members
Member | Description
TextureMapFile |
UnderlayFile |
FontMapFile |
ArxApplication |
PatternFile |
XRefDrawing |
EmbeddedImageFile |
TrueTypeFontFile |
CompiledShapeFile |
FontFile |
Default |


FitData Structure

FitData Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData
Declaration Syntax
C# Visual Basic Visual C++
public struct FitData
Public Structure FitData
public value class FitData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Degree |
 | EndTangent |
 | Equality(FitData, FitData) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | FitTolerance |
 | GetFitPoints()()()() |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(FitData, FitData) |
 | IsEqualTo(FitData, Tolerance) |
 | IsEqualTo(FitData) |
 | KnotParam |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | StartTangent |
 | TangentsExist |
 | ToString()()()() | (Inherited from ValueType.)


Degree Property

Degree Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »Degree
Declaration Syntax
C# Visual Basic Visual C++
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}


EndTangent Property

EndTangent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »EndTangent
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d EndTangent { get; }
Public ReadOnly Property EndTangent As Vector3d
    Get
public:
property Vector3d EndTangent {
    Vector3d get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »Equality(FitData, FitData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    FitData a,
    FitData b
)
Public Shared Operator = ( _
    a As FitData, _
    b As FitData _
) As Boolean
public:
static bool operator ==(
    FitData a,
    FitData b
)
Parameters
a(FitData)
b(FitData)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


FitTolerance Property

FitTolerance Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »FitTolerance
Declaration Syntax
C# Visual Basic Visual C++
public double FitTolerance { get; }
Public ReadOnly Property FitTolerance As Double
    Get
public:
property double FitTolerance {
    double get ();
}


GetFitPoints Method

GetFitPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »GetFitPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection GetFitPoints()
Public Function GetFitPoints As Point3dCollection
public:
Point3dCollection^ GetFitPoints()


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »Inequality(FitData, FitData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    FitData a,
    FitData b
)
Public Shared Operator <> ( _
    a As FitData, _
    b As FitData _
) As Boolean
public:
static bool operator !=(
    FitData a,
    FitData b
)
Parameters
a(FitData)
b(FitData)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(FitData, Tolerance) |
 | IsEqualTo(FitData) |


IsEqualTo Method (other)

IsEqualTo Method (other)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »IsEqualTo(FitData)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    FitData other
)
Public Function IsEqualTo ( _
    other As FitData _
) As Boolean
public:
bool IsEqualTo(
    FitData other
)
Parameters
other(FitData)


IsEqualTo Method (other, tolerance)

IsEqualTo Method (other, tolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »IsEqualTo(FitData, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    FitData other,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    other As FitData, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    FitData other,
    Tolerance tolerance
)
Parameters
other(FitData)
tolerance(Tolerance)


KnotParam Property

KnotParam Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »KnotParam
Declaration Syntax
C# Visual Basic Visual C++
public KnotParameterizationEnum KnotParam { get; }
Public ReadOnly Property KnotParam As KnotParameterizationEnum
    Get
public:
property KnotParameterizationEnum KnotParam {
    KnotParameterizationEnum get ();
}


StartTangent Property

StartTangent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »StartTangent
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d StartTangent { get; }
Public ReadOnly Property StartTangent As Vector3d
    Get
public:
property Vector3d StartTangent {
    Vector3d get ();
}


TangentsExist Property

TangentsExist Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FitData »TangentsExist
Declaration Syntax
C# Visual Basic Visual C++
public bool TangentsExist { get; }
Public ReadOnly Property TangentsExist As Boolean
    Get
public:
property bool TangentsExist {
    bool get ();
}


FlowDirection Enumeration

FlowDirection Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FlowDirection
Declaration Syntax
C# Visual Basic Visual C++
public enum FlowDirection
Public Enumeration FlowDirection
public enum class FlowDirection
Members
Member | Description
TopToBottom |
RightToLeft |
LeftToRight |
ByStyle |
BottomToTop |
NotSet |


FormatOption Enumeration

FormatOption Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormatOption
Declaration Syntax
C# Visual Basic Visual C++
public enum FormatOption
Public Enumeration FormatOption
public enum class FormatOption
Members
Member | Description
UseMaximumPrecision |
IgnoreMtextFormat |
ForExpression |
ForEditing |
FormatOptionNone |


FormattedTableData Class

FormattedTableData Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbFormattedTableData")]
public class FormattedTableData : LinkedTableData
<WrapperAttribute("ZcDbFormattedTableData")> _
Public Class FormattedTableData _
    Inherits LinkedTableData
[WrapperAttribute(L"ZcDbFormattedTableData")]
public ref class FormattedTableData : public LinkedTableData
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormattedTableData()()()() |
 | FormattedTableData(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | AppendColumn(Int32) | (Inherited from LinkedTableData.)
 | AppendRow(Int32) | (Inherited from LinkedTableData.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clear()()()() | (Inherited from LinkedData.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | Create(IntPtr, Boolean) |
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DataType(Int32, Int32) | (Inherited from LinkedTableData.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteColumn(Int32, Int32) | (Inherited from LinkedTableData.)
 | DeleteContent(Int32, Int32) | (Inherited from LinkedTableData.)
 | DeleteRow(Int32, Int32) | (Inherited from LinkedTableData.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAlignment(Int32, Int32) |
 | GetBackgroundColor(Int32, Int32) |
 | GetBlockAttributeValue(Int32, Int32, ObjectId) | (Inherited from LinkedTableData.)
 | GetBlockTableRecordId(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetCellState(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetColumnName(Int32) | (Inherited from LinkedTableData.)
 | GetContentColor(Int32, Int32) |
 | GetContentTypes(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetCustomData(Int32, Int32, String) | (Inherited from LinkedTableData.)
 | GetDataFormat(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetDataLink(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetDataLink(CellRange) | (Inherited from LinkedTableData.)
 | GetDataLink()()()() | (Inherited from LinkedTableData.)
 | GetEnumerator(TableEnumeratorOption) | (Inherited from LinkedTableData.)
 | GetEnumerator()()()() | (Inherited from LinkedTableData.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFieldId(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetGridColor(Int32, Int32, GridLineType) |
 | GetGridLinetype(Int32, Int32, GridLineType) |
 | GetGridLineWeight(Int32, Int32, GridLineType) |
 | GetGridVisibility(Int32, Int32, GridLineType) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetMargin(Int32, Int32, CellMargins) |
 | GetMergeRange(Int32, Int32) |
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetOverride(Int32, Int32, Int32) |
 | GetOverride(Int32, Int32, GridLineType) |
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRotation(Int32, Int32) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetScale(Int32, Int32) |
 | GetTextHeight(Int32, Int32) |
 | GetTextStyle(Int32, Int32) |
 | GetToolTip(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetValue(Int32, Int32, Int32, FormatOption) | (Inherited from LinkedTableData.)
 | GetValue(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertColumn(Int32, Int32) | (Inherited from LinkedTableData.)
 | InsertRow(Int32, Int32) | (Inherited from LinkedTableData.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentEditable(Int32, Int32) | (Inherited from LinkedTableData.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEmpty | (Inherited from LinkedData.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsFormatEditable(Int32, Int32) |
 | IsLinked(Int32, Int32) | (Inherited from LinkedTableData.)
 | IsMerged(Int32, Int32) |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Merge(CellRange) |
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from LinkedData.)
 | NumberOfColumns | (Inherited from LinkedTableData.)
 | NumberOfRows | (Inherited from LinkedTableData.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveAllOverrides(Int32, Int32) |
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAlignment(Int32, Int32, CellAlignment) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetBackgroundColor(Int32, Int32, Color) |
 | SetBlockAttributeValue(Int32, Int32, ObjectId, String) | (Inherited from LinkedTableData.)
 | SetBlockTableRecordId(Int32, Int32, ObjectId) | (Inherited from LinkedTableData.)
 | SetCellState(Int32, Int32, CellStates) | (Inherited from LinkedTableData.)
 | SetColumnName(Int32, String) | (Inherited from LinkedTableData.)
 | SetContentColor(Int32, Int32, Color) |
 | SetCustomData(Int32, Int32, String, Object) | (Inherited from LinkedTableData.)
 | SetDataFormat(Int32, Int32, String) | (Inherited from LinkedTableData.)
 | SetDataLink(Int32, Int32, ObjectId, Boolean) | (Inherited from LinkedTableData.)
 | SetDataLink(CellRange, ObjectId, Boolean) | (Inherited from LinkedTableData.)
 | SetDataType(Int32, Int32, DataType, UnitType) | (Inherited from LinkedTableData.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFieldId(Int32, Int32, ObjectId) | (Inherited from LinkedTableData.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGridColor(Int32, Int32, GridLineType, Color) |
 | SetGridLinetype(Int32, Int32, GridLineType, ObjectId) |
 | SetGridLineWeight(Int32, Int32, GridLineType, LineWeight) |
 | SetGridVisibility(Int32, Int32, GridLineType, Visibility) |
 | SetMargin(Int32, Int32, CellMargins, Double) |
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetOverride(Int32, Int32, Int32, CellProperties) |
 | SetOverride(Int32, Int32, GridLineType, GridProperties) |
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetRotation(Int32, Int32, Double) |
 | SetScale(Int32, Int32, Double) |
 | SetSize(Int32, Int32) | (Inherited from LinkedTableData.)
 | SetTextHeight(Int32, Int32, Double) |
 | SetTextStyle(Int32, Int32, ObjectId) |
 | SetToolTip(Int32, Int32, String) | (Inherited from LinkedTableData.)
 | SetValue(Int32, Int32, Int32, Object, ParseOption) | (Inherited from LinkedTableData.)
 | SetValue(Int32, Int32, Object) | (Inherited from LinkedTableData.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnitType(Int32, Int32) | (Inherited from LinkedTableData.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Unmerge(CellRange) |
 | UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) | (Inherited from LinkedTableData.)
 | UpdateDataLink(UpdateDirection, UpdateOption) | (Inherited from LinkedTableData.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | LinkedData
 |  |  |  |  |  |  | LinkedTableData
 |  |  |  |  |  |  |  | FormattedTableData
 |  |  |  |  |  |  |  |  | TableContent


FormattedTableData Constructor

FormattedTableData Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »FormattedTableData()()()()
Members
Icon | Member | Description
 | FormattedTableData()()()() |
 | FormattedTableData(IntPtr, Boolean) |


FormattedTableData Constructor

FormattedTableData Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »FormattedTableData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FormattedTableData()
Public Sub New
public:
FormattedTableData()


FormattedTableData Constructor (unmanagedObjPtr, autoDelete)

FormattedTableData Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »FormattedTableData(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal FormattedTableData(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
FormattedTableData(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal static FormattedTableData Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As FormattedTableData
protected public:
static FormattedTableData^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetAlignment Method (row, column)

GetAlignment Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetAlignment(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellAlignment GetAlignment(
    int row,
    int column
)
Public Overridable Function GetAlignment ( _
    row As Integer, _
    column As Integer _
) As CellAlignment
public:
virtual CellAlignment GetAlignment(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetBackgroundColor Method (row, column)

GetBackgroundColor Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetBackgroundColor(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color GetBackgroundColor(
    int row,
    int column
)
Public Overridable Function GetBackgroundColor ( _
    row As Integer, _
    column As Integer _
) As Color
public:
virtual Color^ GetBackgroundColor(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetContentColor Method (row, column)

GetContentColor Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetContentColor(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color GetContentColor(
    int row,
    int column
)
Public Overridable Function GetContentColor ( _
    row As Integer, _
    column As Integer _
) As Color
public:
virtual Color^ GetContentColor(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetGridColor Method (row, column, gridLinetype)

GetGridColor Method (row, column, gridLinetype)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetGridColor(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color GetGridColor(
    int row,
    int column,
    GridLineType gridLinetype
)
Public Overridable Function GetGridColor ( _
    row As Integer, _
    column As Integer, _
    gridLinetype As GridLineType _
) As Color
public:
virtual Color^ GetGridColor(
    int row,
    int column,
    GridLineType gridLinetype
)
Parameters
row(Int32)
column(Int32)
gridLinetype(GridLineType)


GetGridLinetype Method (row, column, gridLinetype)

GetGridLinetype Method (row, column, gridLinetype)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetGridLinetype(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetGridLinetype(
    int row,
    int column,
    GridLineType gridLinetype
)
Public Overridable Function GetGridLinetype ( _
    row As Integer, _
    column As Integer, _
    gridLinetype As GridLineType _
) As ObjectId
public:
virtual ObjectId GetGridLinetype(
    int row,
    int column,
    GridLineType gridLinetype
)
Parameters
row(Int32)
column(Int32)
gridLinetype(GridLineType)


GetGridLineWeight Method (row, column, gridLinetype)

GetGridLineWeight Method (row, column, gridLinetype)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetGridLineWeight(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight GetGridLineWeight(
    int row,
    int column,
    GridLineType gridLinetype
)
Public Overridable Function GetGridLineWeight ( _
    row As Integer, _
    column As Integer, _
    gridLinetype As GridLineType _
) As LineWeight
public:
virtual LineWeight GetGridLineWeight(
    int row,
    int column,
    GridLineType gridLinetype
)
Parameters
row(Int32)
column(Int32)
gridLinetype(GridLineType)


GetGridVisibility Method (row, column, gridLinetype)

GetGridVisibility Method (row, column, gridLinetype)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetGridVisibility(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Visibility GetGridVisibility(
    int row,
    int column,
    GridLineType gridLinetype
)
Public Overridable Function GetGridVisibility ( _
    row As Integer, _
    column As Integer, _
    gridLinetype As GridLineType _
) As Visibility
public:
virtual Visibility GetGridVisibility(
    int row,
    int column,
    GridLineType gridLinetype
)
Parameters
row(Int32)
column(Int32)
gridLinetype(GridLineType)


GetMargin Method (row, column, margin)

GetMargin Method (row, column, margin)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetMargin(Int32, Int32, CellMargins)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetMargin(
    int row,
    int column,
    CellMargins margin
)
Public Overridable Function GetMargin ( _
    row As Integer, _
    column As Integer, _
    margin As CellMargins _
) As Double
public:
virtual double GetMargin(
    int row,
    int column,
    CellMargins margin
)
Parameters
row(Int32)
column(Int32)
margin(CellMargins)


GetMergeRange Method (row, column)

GetMergeRange Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetMergeRange(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellRange GetMergeRange(
    int row,
    int column
)
Public Overridable Function GetMergeRange ( _
    row As Integer, _
    column As Integer _
) As CellRange
public:
virtual CellRange^ GetMergeRange(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetOverride Method

GetOverride Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetOverride()()()()
Members
Icon | Member | Description
 | GetOverride(Int32, Int32, Int32) |
 | GetOverride(Int32, Int32, GridLineType) |


GetOverride Method (row, column, content)

GetOverride Method (row, column, content)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetOverride(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellProperties GetOverride(
    int row,
    int column,
    int content
)
Public Overridable Function GetOverride ( _
    row As Integer, _
    column As Integer, _
    content As Integer _
) As CellProperties
public:
virtual CellProperties GetOverride(
    int row,
    int column,
    int content
)
Parameters
row(Int32)
column(Int32)
content(Int32)


GetOverride Method (row, column, gridLinetype)

GetOverride Method (row, column, gridLinetype)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetOverride(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual GridProperties GetOverride(
    int row,
    int column,
    GridLineType gridLinetype
)
Public Overridable Function GetOverride ( _
    row As Integer, _
    column As Integer, _
    gridLinetype As GridLineType _
) As GridProperties
public:
virtual GridProperties GetOverride(
    int row,
    int column,
    GridLineType gridLinetype
)
Parameters
row(Int32)
column(Int32)
gridLinetype(GridLineType)


GetRotation Method (row, column)

GetRotation Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetRotation(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetRotation(
    int row,
    int column
)
Public Overridable Function GetRotation ( _
    row As Integer, _
    column As Integer _
) As Double
public:
virtual double GetRotation(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetScale Method (row, column)

GetScale Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetScale(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetScale(
    int row,
    int column
)
Public Overridable Function GetScale ( _
    row As Integer, _
    column As Integer _
) As Double
public:
virtual double GetScale(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetTextHeight Method (row, column)

GetTextHeight Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetTextHeight(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetTextHeight(
    int row,
    int column
)
Public Overridable Function GetTextHeight ( _
    row As Integer, _
    column As Integer _
) As Double
public:
virtual double GetTextHeight(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetTextStyle Method (row, column)

GetTextStyle Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetTextStyle(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetTextStyle(
    int row,
    int column
)
Public Overridable Function GetTextStyle ( _
    row As Integer, _
    column As Integer _
) As ObjectId
public:
virtual ObjectId GetTextStyle(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


IsFormatEditable Method (row, column)

IsFormatEditable Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »IsFormatEditable(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFormatEditable(
    int row,
    int column
)
Public Overridable Function IsFormatEditable ( _
    row As Integer, _
    column As Integer _
) As Boolean
public:
virtual bool IsFormatEditable(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


IsMerged Method (row, column)

IsMerged Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »IsMerged(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsMerged(
    int row,
    int column
)
Public Overridable Function IsMerged ( _
    row As Integer, _
    column As Integer _
) As Boolean
public:
virtual bool IsMerged(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


Merge Method (range)

Merge Method (range)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »Merge(CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Merge(
    CellRange range
)
Public Overridable Sub Merge ( _
    range As CellRange _
)
public:
virtual void Merge(
    CellRange^ range
)
Parameters
range(CellRange)


RemoveAllOverrides Method (row, column)

RemoveAllOverrides Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »RemoveAllOverrides(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveAllOverrides(
    int row,
    int column
)
Public Overridable Sub RemoveAllOverrides ( _
    row As Integer, _
    column As Integer _
)
public:
virtual void RemoveAllOverrides(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


SetAlignment Method (row, column, value)

SetAlignment Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetAlignment(Int32, Int32, CellAlignment)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetAlignment(
    int row,
    int column,
    CellAlignment value
)
Public Overridable Sub SetAlignment ( _
    row As Integer, _
    column As Integer, _
    value As CellAlignment _
)
public:
virtual void SetAlignment(
    int row,
    int column,
    CellAlignment value
)
Parameters
row(Int32)
column(Int32)
value(CellAlignment)


SetBackgroundColor Method (row, column, value)

SetBackgroundColor Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetBackgroundColor(Int32, Int32, Color)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBackgroundColor(
    int row,
    int column,
    Color value
)
Public Overridable Sub SetBackgroundColor ( _
    row As Integer, _
    column As Integer, _
    value As Color _
)
public:
virtual void SetBackgroundColor(
    int row,
    int column,
    Color^ value
)
Parameters
row(Int32)
column(Int32)
value(Color)


SetContentColor Method (row, column, value)

SetContentColor Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetContentColor(Int32, Int32, Color)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetContentColor(
    int row,
    int column,
    Color value
)
Public Overridable Sub SetContentColor ( _
    row As Integer, _
    column As Integer, _
    value As Color _
)
public:
virtual void SetContentColor(
    int row,
    int column,
    Color^ value
)
Parameters
row(Int32)
column(Int32)
value(Color)


SetGridColor Method (row, column, gridLinetype, value)

SetGridColor Method (row, column, gridLinetype, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetGridColor(Int32, Int32, GridLineType, Color)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridColor(
    int row,
    int column,
    GridLineType gridLinetype,
    Color value
)
Public Overridable Sub SetGridColor ( _
    row As Integer, _
    column As Integer, _
    gridLinetype As GridLineType, _
    value As Color _
)
public:
virtual void SetGridColor(
    int row,
    int column,
    GridLineType gridLinetype,
    Color^ value
)
Parameters
row(Int32)
column(Int32)
gridLinetype(GridLineType)
value(Color)


SetGridLinetype Method (row, column, gridLinetype, value)

SetGridLinetype Method (row, column, gridLinetype, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetGridLinetype(Int32, Int32, GridLineType, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridLinetype(
    int row,
    int column,
    GridLineType gridLinetype,
    ObjectId value
)
Public Overridable Sub SetGridLinetype ( _
    row As Integer, _
    column As Integer, _
    gridLinetype As GridLineType, _
    value As ObjectId _
)
public:
virtual void SetGridLinetype(
    int row,
    int column,
    GridLineType gridLinetype,
    ObjectId value
)
Parameters
row(Int32)
column(Int32)
gridLinetype(GridLineType)
value(ObjectId)


SetGridLineWeight Method (row, column, gridLinetype, value)

SetGridLineWeight Method (row, column, gridLinetype, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetGridLineWeight(Int32, Int32, GridLineType, LineWeight)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridLineWeight(
    int row,
    int column,
    GridLineType gridLinetype,
    LineWeight value
)
Public Overridable Sub SetGridLineWeight ( _
    row As Integer, _
    column As Integer, _
    gridLinetype As GridLineType, _
    value As LineWeight _
)
public:
virtual void SetGridLineWeight(
    int row,
    int column,
    GridLineType gridLinetype,
    LineWeight value
)
Parameters
row(Int32)
column(Int32)
gridLinetype(GridLineType)
value(LineWeight)


SetGridVisibility Method (row, column, gridLinetype, value)

SetGridVisibility Method (row, column, gridLinetype, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetGridVisibility(Int32, Int32, GridLineType, Visibility)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridVisibility(
    int row,
    int column,
    GridLineType gridLinetype,
    Visibility value
)
Public Overridable Sub SetGridVisibility ( _
    row As Integer, _
    column As Integer, _
    gridLinetype As GridLineType, _
    value As Visibility _
)
public:
virtual void SetGridVisibility(
    int row,
    int column,
    GridLineType gridLinetype,
    Visibility value
)
Parameters
row(Int32)
column(Int32)
gridLinetype(GridLineType)
value(Visibility)


SetMargin Method (row, column, margin, value)

SetMargin Method (row, column, margin, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetMargin(Int32, Int32, CellMargins, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetMargin(
    int row,
    int column,
    CellMargins margin,
    double value
)
Public Overridable Sub SetMargin ( _
    row As Integer, _
    column As Integer, _
    margin As CellMargins, _
    value As Double _
)
public:
virtual void SetMargin(
    int row,
    int column,
    CellMargins margin,
    double value
)
Parameters
row(Int32)
column(Int32)
margin(CellMargins)
value(Double)


SetOverride Method

SetOverride Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetOverride()()()()
Members
Icon | Member | Description
 | SetOverride(Int32, Int32, Int32, CellProperties) |
 | SetOverride(Int32, Int32, GridLineType, GridProperties) |


SetOverride Method (row, column, content, cellProperty)

SetOverride Method (row, column, content, cellProperty)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetOverride(Int32, Int32, Int32, CellProperties)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetOverride(
    int row,
    int column,
    int content,
    CellProperties cellProperty
)
Public Overridable Sub SetOverride ( _
    row As Integer, _
    column As Integer, _
    content As Integer, _
    cellProperty As CellProperties _
)
public:
virtual void SetOverride(
    int row,
    int column,
    int content,
    CellProperties cellProperty
)
Parameters
row(Int32)
column(Int32)
content(Int32)
cellProperty(CellProperties)


SetOverride Method (row, column, gridLinetype, gridProperty)

SetOverride Method (row, column, gridLinetype, gridProperty)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetOverride(Int32, Int32, GridLineType, GridProperties)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetOverride(
    int row,
    int column,
    GridLineType gridLinetype,
    GridProperties gridProperty
)
Public Overridable Sub SetOverride ( _
    row As Integer, _
    column As Integer, _
    gridLinetype As GridLineType, _
    gridProperty As GridProperties _
)
public:
virtual void SetOverride(
    int row,
    int column,
    GridLineType gridLinetype,
    GridProperties gridProperty
)
Parameters
row(Int32)
column(Int32)
gridLinetype(GridLineType)
gridProperty(GridProperties)


SetRotation Method (row, column, value)

SetRotation Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetRotation(Int32, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetRotation(
    int row,
    int column,
    double value
)
Public Overridable Sub SetRotation ( _
    row As Integer, _
    column As Integer, _
    value As Double _
)
public:
virtual void SetRotation(
    int row,
    int column,
    double value
)
Parameters
row(Int32)
column(Int32)
value(Double)


SetScale Method (row, column, value)

SetScale Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetScale(Int32, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetScale(
    int row,
    int column,
    double value
)
Public Overridable Sub SetScale ( _
    row As Integer, _
    column As Integer, _
    value As Double _
)
public:
virtual void SetScale(
    int row,
    int column,
    double value
)
Parameters
row(Int32)
column(Int32)
value(Double)


SetTextHeight Method (row, column, value)

SetTextHeight Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetTextHeight(Int32, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextHeight(
    int row,
    int column,
    double value
)
Public Overridable Sub SetTextHeight ( _
    row As Integer, _
    column As Integer, _
    value As Double _
)
public:
virtual void SetTextHeight(
    int row,
    int column,
    double value
)
Parameters
row(Int32)
column(Int32)
value(Double)


SetTextStyle Method (row, column, value)

SetTextStyle Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetTextStyle(Int32, Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextStyle(
    int row,
    int column,
    ObjectId value
)
Public Overridable Sub SetTextStyle ( _
    row As Integer, _
    column As Integer, _
    value As ObjectId _
)
public:
virtual void SetTextStyle(
    int row,
    int column,
    ObjectId value
)
Parameters
row(Int32)
column(Int32)
value(ObjectId)


Unmerge Method (range)

Unmerge Method (range)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »Unmerge(CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Unmerge(
    CellRange range
)
Public Overridable Sub Unmerge ( _
    range As CellRange _
)
public:
virtual void Unmerge(
    CellRange^ range
)
Parameters
range(CellRange)


FrameSetting Enumeration

FrameSetting Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FrameSetting
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbRasterVariables::FrameSettings")]
public enum FrameSetting
<WrapperAttribute("ZcDbRasterVariables::FrameSettings")> _
Public Enumeration FrameSetting
[WrapperAttribute(L"ZcDbRasterVariables::FrameSettings")]
public enum class FrameSetting
Members
Member | Description
ImageFrameOnNoPlot |
ImageFrameBelow |
ImageFrameAbove |
ImageFrameOff |
ImageFrameInvalid |


FullDwgVersion Structure

FullDwgVersion Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullDwgVersion
Declaration Syntax
C# Visual Basic Visual C++
public struct FullDwgVersion
Public Structure FullDwgVersion
public value class FullDwgVersion
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FullDwgVersion(DwgVersion, MaintenanceReleaseVersion) |
 | Equality(FullDwgVersion, FullDwgVersion) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(FullDwgVersion, FullDwgVersion) |
 | MajorVersion |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinorVersion |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


FullDwgVersion Constructor (majorVersion, minorVersion)

FullDwgVersion Constructor (majorVersion, minorVersion)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullDwgVersion »FullDwgVersion(DwgVersion, MaintenanceReleaseVersion)
Declaration Syntax
C# Visual Basic Visual C++
public FullDwgVersion(
    DwgVersion majorVersion,
    MaintenanceReleaseVersion minorVersion
)
Public Sub New ( _
    majorVersion As DwgVersion, _
    minorVersion As MaintenanceReleaseVersion _
)
public:
FullDwgVersion(
    DwgVersion majorVersion,
    MaintenanceReleaseVersion minorVersion
)
Parameters
majorVersion(DwgVersion)
minorVersion(MaintenanceReleaseVersion)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullDwgVersion »Equality(FullDwgVersion, FullDwgVersion)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    FullDwgVersion ver1,
    FullDwgVersion ver2
)
Public Shared Operator = ( _
    ver1 As FullDwgVersion, _
    ver2 As FullDwgVersion _
) As Boolean
public:
static bool operator ==(
    FullDwgVersion ver1,
    FullDwgVersion ver2
)
Parameters
ver1(FullDwgVersion)
ver2(FullDwgVersion)


Equals Method (other)

Equals Method (other)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullDwgVersion »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object other
)
Public Overrides NotOverridable Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override sealed
Parameters
other(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullDwgVersion »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullDwgVersion »Inequality(FullDwgVersion, FullDwgVersion)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    FullDwgVersion ver1,
    FullDwgVersion ver2
)
Public Shared Operator <> ( _
    ver1 As FullDwgVersion, _
    ver2 As FullDwgVersion _
) As Boolean
public:
static bool operator !=(
    FullDwgVersion ver1,
    FullDwgVersion ver2
)
Parameters
ver1(FullDwgVersion)
ver2(FullDwgVersion)


MajorVersion Property

MajorVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullDwgVersion »MajorVersion
Declaration Syntax
C# Visual Basic Visual C++
public DwgVersion MajorVersion { get; }
Public ReadOnly Property MajorVersion As DwgVersion
    Get
public:
property DwgVersion MajorVersion {
    DwgVersion get ();
}


MinorVersion Property

MinorVersion Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullDwgVersion »MinorVersion
Declaration Syntax
C# Visual Basic Visual C++
public MaintenanceReleaseVersion MinorVersion { get; }
Public ReadOnly Property MinorVersion As MaintenanceReleaseVersion
    Get
public:
property MaintenanceReleaseVersion MinorVersion {
    MaintenanceReleaseVersion get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullDwgVersion »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


FullSubentityPath Structure

FullSubentityPath Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbFullSubentPath")]
public struct FullSubentityPath
<WrapperAttribute("ZcDbFullSubentPath")> _
Public Structure FullSubentityPath
[WrapperAttribute(L"ZcDbFullSubentPath")]
public value class FullSubentityPath
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FullSubentityPath(array<ObjectId>[]()[][], SubentityId) |
 | CopyToUnmanagedObject(IntPtr) |
 | Equality(FullSubentityPath, FullSubentityPath) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetObjectIds()()()() |
 | GetType()()()() | (Inherited from Object.)
 | Inequality(FullSubentityPath, FullSubentityPath) |
 | IsNull |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Null |
 | SubentId |
 | ToString()()()() | (Inherited from ValueType.)


FullSubentityPath Constructor (ids, index)

FullSubentityPath Constructor (ids, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath »FullSubentityPath(array<ObjectId>[]()[][], SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public FullSubentityPath(
    ObjectId[] ids,
    SubentityId index
)
Public Sub New ( _
    ids As ObjectId(), _
    index As SubentityId _
)
public:
FullSubentityPath(
    array<ObjectId>^ ids,
    SubentityId index
)
Parameters
ids(array< ObjectId >[]()[][])
index(SubentityId)


CopyToUnmanagedObject Method (unmanagedPointer)

CopyToUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath »CopyToUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyToUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Sub CopyToUnmanagedObject ( _
    unmanagedPointer As IntPtr _
)
public:
void CopyToUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath »Equality(FullSubentityPath, FullSubentityPath)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    FullSubentityPath a,
    FullSubentityPath b
)
Public Shared Operator = ( _
    a As FullSubentityPath, _
    b As FullSubentityPath _
) As Boolean
public:
static bool operator ==(
    FullSubentityPath a,
    FullSubentityPath b
)
Parameters
a(FullSubentityPath)
b(FullSubentityPath)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetObjectIds Method

GetObjectIds Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath »GetObjectIds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId[] GetObjectIds()
Public Function GetObjectIds As ObjectId()
public:
array<ObjectId>^ GetObjectIds()


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath »Inequality(FullSubentityPath, FullSubentityPath)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    FullSubentityPath a,
    FullSubentityPath b
)
Public Shared Operator <> ( _
    a As FullSubentityPath, _
    b As FullSubentityPath _
) As Boolean
public:
static bool operator !=(
    FullSubentityPath a,
    FullSubentityPath b
)
Parameters
a(FullSubentityPath)
b(FullSubentityPath)


IsNull Property

IsNull Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath »IsNull
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNull { get; }
Public ReadOnly Property IsNull As Boolean
    Get
public:
property bool IsNull {
    bool get ();
}


Null Property

Null Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath »Null
Declaration Syntax
C# Visual Basic Visual C++
public static FullSubentityPath Null { get; }
Public Shared ReadOnly Property Null As FullSubentityPath
    Get
public:
static property FullSubentityPath Null {
    FullSubentityPath get ();
}


SubentId Property

SubentId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FullSubentityPath »SubentId
Declaration Syntax
C# Visual Basic Visual C++
public SubentityId SubentId { get; }
Public ReadOnly Property SubentId As SubentityId
    Get
public:
property SubentityId SubentId {
    SubentityId get ();
}


GeoLocationData Class

GeoLocationData Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GeoLocationData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbGeoData")]
public class GeoLocationData : DBObject
<WrapperAttribute("ZcDbGeoData")> _
Public Class GeoLocationData _
    Inherits DBObject
[WrapperAttribute(L"ZcDbGeoData")]
public ref class GeoLocationData : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeoLocationData()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | GeoLocationData


GeoLocationData Constructor

GeoLocationData Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GeoLocationData »GeoLocationData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GeoLocationData()
Public Sub New
public:
GeoLocationData()


GetGripPointsFlags Enumeration

GetGripPointsFlags Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GetGripPointsFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
[WrapperAttribute("ZcDbGripOperations::GetGripPointsFlags")]
public enum GetGripPointsFlags
<FlagsAttribute> _
<WrapperAttribute("ZcDbGripOperations::GetGripPointsFlags")> _
Public Enumeration GetGripPointsFlags
[FlagsAttribute]
[WrapperAttribute(L"ZcDbGripOperations::GetGripPointsFlags")]
public enum class GetGripPointsFlags
Members
Member | Description
DynamicDimensionMode |
CyclableGripsOnly |
GripPointsOnly |


GradientBackground Class

GradientBackground Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbGradientBackground")]
public class GradientBackground : Background
<WrapperAttribute("AcDbGradientBackground")> _
Public Class GradientBackground _
    Inherits Background
[WrapperAttribute(L"AcDbGradientBackground")]
public ref class GradientBackground : public Background
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GradientBackground()()()() |
 | GradientBackground(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Background
 |  |  |  |  |  |  | GradientBackground


GradientBackground Constructor

GradientBackground Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground »GradientBackground()()()()
Members
Icon | Member | Description
 | GradientBackground()()()() |
 | GradientBackground(IntPtr, Boolean) |


GradientBackground Constructor

GradientBackground Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground »GradientBackground()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GradientBackground()
Public Sub New
public:
GradientBackground()


GradientBackground Constructor (unmanagedPointer, autoDelete)

GradientBackground Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground »GradientBackground(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal GradientBackground(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
GradientBackground(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GradientColor Structure

GradientColor Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientColor
Declaration Syntax
C# Visual Basic Visual C++
public struct GradientColor
Public Structure GradientColor
public value class GradientColor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GradientColor(Color, Single) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | get_Color()()()() |
 | get_Value()()()() |
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)


GradientColor Constructor (color, value)

GradientColor Constructor (color, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientColor »GradientColor(Color, Single)
Declaration Syntax
C# Visual Basic Visual C++
public GradientColor(
    Color color,
    float value
)
Public Sub New ( _
    color As Color, _
    value As Single _
)
public:
GradientColor(
    Color^ color,
    float value
)
Parameters
color(Color)
value(Single)


get_Color Method

get_Color Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientColor »get_Color()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Color get_Color()
Public Function get_Color As Color
public:
Color^ get_Color()


get_Value Method

get_Value Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientColor »get_Value()()()()
Declaration Syntax
C# Visual Basic Visual C++
public float get_Value()
Public Function get_Value As Single
public:
float get_Value()


GradientPatternType Enumeration

GradientPatternType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientPatternType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbHatch::GradientPatternType")]
public enum GradientPatternType
<WrapperAttribute("ZcDbHatch::GradientPatternType")> _
Public Enumeration GradientPatternType
[WrapperAttribute(L"ZcDbHatch::GradientPatternType")]
public enum class GradientPatternType
Members
Member | Description
UserDefinedGradient |
PreDefinedGradient |


Graph Class

Graph Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbGraph")]
public class Graph : DisposableWrapper
<WrapperAttribute("ZcDbGraph")> _
Public Class Graph _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcDbGraph")]
public ref class Graph : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Graph(GraphNode) |
 | Graph(IntPtr, Boolean) |
 | AddEdge(GraphNode, GraphNode) |
 | AddNode(GraphNode) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BreakCycleEdge(GraphNode, GraphNode) |
 | ClearAll(Byte) |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | DelNode(GraphNode) |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FindCycles(GraphNode) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetOutgoing()()()() |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEmpty |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Node(Int32) |
 | NumNodes |
 | Reset()()()() |
 | RootNode |
 | SetNodeGrowthRate(Int32) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Graph
 |  |  |  | ObjectIdGraph
 |  |  |  | XrefGraph


Graph Constructor

Graph Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »Graph()()()()
Members
Icon | Member | Description
 | Graph(GraphNode) |
 | Graph(IntPtr, Boolean) |


Graph Constructor (unmanagedPointer, autoDelete)

Graph Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »Graph(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Graph(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Graph(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Graph Constructor (root)

Graph Constructor (root)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »Graph(GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public Graph(
    GraphNode root
)
Public Sub New ( _
    root As GraphNode _
)
public:
Graph(
    GraphNode^ root
)
Parameters
root(GraphNode)


AddEdge Method (from, toPointer)

AddEdge Method (from, toPointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »AddEdge(GraphNode, GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public void AddEdge(
    GraphNode from,
    GraphNode toPointer
)
Public Sub AddEdge ( _
    from As GraphNode, _
    toPointer As GraphNode _
)
public:
void AddEdge(
    GraphNode^ from,
    GraphNode^ toPointer
)
Parameters
from(GraphNode)
toPointer(GraphNode)


AddNode Method (nodeToAdd)

AddNode Method (nodeToAdd)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »AddNode(GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public void AddNode(
    GraphNode nodeToAdd
)
Public Sub AddNode ( _
    nodeToAdd As GraphNode _
)
public:
void AddNode(
    GraphNode^ nodeToAdd
)
Parameters
nodeToAdd(GraphNode)


BreakCycleEdge Method (from, toPointer)

BreakCycleEdge Method (from, toPointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »BreakCycleEdge(GraphNode, GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public void BreakCycleEdge(
    GraphNode from,
    GraphNode toPointer
)
Public Sub BreakCycleEdge ( _
    from As GraphNode, _
    toPointer As GraphNode _
)
public:
void BreakCycleEdge(
    GraphNode^ from,
    GraphNode^ toPointer
)
Parameters
from(GraphNode)
toPointer(GraphNode)


ClearAll Method (flags)

ClearAll Method (flags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »ClearAll(Byte)
Declaration Syntax
C# Visual Basic Visual C++
public void ClearAll(
    byte flags
)
Public Sub ClearAll ( _
    flags As Byte _
)
public:
void ClearAll(
    unsigned char flags
)
Parameters
flags(Byte)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Graph Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Graph
public:
static Graph^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


DelNode Method (nodeToDelete)

DelNode Method (nodeToDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »DelNode(GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public void DelNode(
    GraphNode nodeToDelete
)
Public Sub DelNode ( _
    nodeToDelete As GraphNode _
)
public:
void DelNode(
    GraphNode^ nodeToDelete
)
Parameters
nodeToDelete(GraphNode)


FindCycles Method (start)

FindCycles Method (start)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »FindCycles(GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool FindCycles(
    GraphNode start
)
Public Overridable Function FindCycles ( _
    start As GraphNode _
) As Boolean
public:
virtual bool FindCycles(
    GraphNode^ start
)
Parameters
start(GraphNode)


GetOutgoing Method

GetOutgoing Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »GetOutgoing()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GraphNodeCollection GetOutgoing()
Public Function GetOutgoing As GraphNodeCollection
public:
GraphNodeCollection^ GetOutgoing()


IsEmpty Property

IsEmpty Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »IsEmpty
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}


Node Method (index)

Node Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »Node(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public GraphNode Node(
    int index
)
Public Function Node ( _
    index As Integer _
) As GraphNode
public:
GraphNode^ Node(
    int index
)
Parameters
index(Int32)


NumNodes Property

NumNodes Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »NumNodes
Declaration Syntax
C# Visual Basic Visual C++
public int NumNodes { get; }
Public ReadOnly Property NumNodes As Integer
    Get
public:
property int NumNodes {
    int get ();
}


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
void Reset()


RootNode Property

RootNode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »RootNode
Declaration Syntax
C# Visual Basic Visual C++
public GraphNode RootNode { get; }
Public ReadOnly Property RootNode As GraphNode
    Get
public:
property GraphNode^ RootNode {
    GraphNode^ get ();
}


SetNodeGrowthRate Method (rate)

SetNodeGrowthRate Method (rate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »SetNodeGrowthRate(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SetNodeGrowthRate(
    int rate
)
Public Sub SetNodeGrowthRate ( _
    rate As Integer _
)
public:
void SetNodeGrowthRate(
    int rate
)
Parameters
rate(Int32)


GraphicsMetafileType Enumeration

GraphicsMetafileType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphicsMetafileType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbProxyEntity::GraphicsMetafileType")]
public enum GraphicsMetafileType
<WrapperAttribute("ZcDbProxyEntity::GraphicsMetafileType")> _
Public Enumeration GraphicsMetafileType
[WrapperAttribute(L"ZcDbProxyEntity::GraphicsMetafileType")]
public enum class GraphicsMetafileType
Members
Member | Description
FullGraphics |
BoundingBox |
NoMetafile |


GraphNode Class

GraphNode Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbGraphNode")]
public class GraphNode : DisposableWrapper
<WrapperAttribute("ZcDbGraphNode")> _
Public Class GraphNode _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcDbGraphNode")]
public ref class GraphNode : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GraphNode()()()() |
 | GraphNode(IntPtr, Boolean) |
 | AddRefTo(GraphNode) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear(Byte) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CycleIn(Int32) |
 | CycleOut(Int32) |
 | Data |
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | DisconnectAll()()()() |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | In(Int32) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsCycleNode |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsMarkedAs(Int32) |
 | MarkAs(Byte) |
 | MarkTree(Byte, GraphNodeCollection) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NextCycleNode |
 | NumCycleIn |
 | NumCycleOut |
 | NumIn |
 | NumOut |
 | Out(Int32) |
 | Owner |
 | RemoveRefTo(GraphNode) |
 | SetEdgeGrowthRate(Int32, Int32) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | GraphNode
 |  |  |  | XrefGraphNode


GraphNode Constructor

GraphNode Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »GraphNode()()()()
Members
Icon | Member | Description
 | GraphNode()()()() |
 | GraphNode(IntPtr, Boolean) |


GraphNode Constructor

GraphNode Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »GraphNode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GraphNode()
Public Sub New
public:
GraphNode()


GraphNode Constructor (unmanagedPointer, autoDelete)

GraphNode Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »GraphNode(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal GraphNode(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
GraphNode(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AddRefTo Method (outGoingNode)

AddRefTo Method (outGoingNode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »AddRefTo(GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRefTo(
    GraphNode outGoingNode
)
Public Sub AddRefTo ( _
    outGoingNode As GraphNode _
)
public:
void AddRefTo(
    GraphNode^ outGoingNode
)
Parameters
outGoingNode(GraphNode)


Clear Method (flags)

Clear Method (flags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »Clear(Byte)
Declaration Syntax
C# Visual Basic Visual C++
public void Clear(
    byte flags
)
Public Sub Clear ( _
    flags As Byte _
)
public:
void Clear(
    unsigned char flags
)
Parameters
flags(Byte)


CycleIn Method (index)

CycleIn Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »CycleIn(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public GraphNode CycleIn(
    int index
)
Public Function CycleIn ( _
    index As Integer _
) As GraphNode
public:
GraphNode^ CycleIn(
    int index
)
Parameters
index(Int32)


CycleOut Method (index)

CycleOut Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »CycleOut(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public GraphNode CycleOut(
    int index
)
Public Function CycleOut ( _
    index As Integer _
) As GraphNode
public:
GraphNode^ CycleOut(
    int index
)
Parameters
index(Int32)


Data Property

Data Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »Data
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr Data { get; set; }
Public Property Data As IntPtr
    Get
    Set
public:
property IntPtr Data {
    IntPtr get ();
    void set (IntPtr value);
}


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


DisconnectAll Method

DisconnectAll Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »DisconnectAll()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void DisconnectAll()
Public Sub DisconnectAll
public:
void DisconnectAll()


In Method (index)

In Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »In(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public GraphNode In(
    int index
)
Public Function In ( _
    index As Integer _
) As GraphNode
public:
GraphNode^ In(
    int index
)
Parameters
index(Int32)


IsCycleNode Property

IsCycleNode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »IsCycleNode
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCycleNode { get; }
Public ReadOnly Property IsCycleNode As Boolean
    Get
public:
property bool IsCycleNode {
    bool get ();
}


IsMarkedAs Method (flag)

IsMarkedAs Method (flag)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »IsMarkedAs(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMarkedAs(
    int flag
)
Public Function IsMarkedAs ( _
    flag As Integer _
) As Boolean
public:
bool IsMarkedAs(
    int flag
)
Parameters
flag(Int32)


MarkAs Method (flags)

MarkAs Method (flags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »MarkAs(Byte)
Declaration Syntax
C# Visual Basic Visual C++
public void MarkAs(
    byte flags
)
Public Sub MarkAs ( _
    flags As Byte _
)
public:
void MarkAs(
    unsigned char flags
)
Parameters
flags(Byte)


MarkTree Method (flags, appendedTo)

MarkTree Method (flags, appendedTo)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »MarkTree(Byte, GraphNodeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void MarkTree(
    byte flags,
    GraphNodeCollection appendedTo
)
Public Sub MarkTree ( _
    flags As Byte, _
    appendedTo As GraphNodeCollection _
)
public:
void MarkTree(
    unsigned char flags,
    GraphNodeCollection^ appendedTo
)
Parameters
flags(Byte)
appendedTo(GraphNodeCollection)


NextCycleNode Property

NextCycleNode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »NextCycleNode
Declaration Syntax
C# Visual Basic Visual C++
public GraphNode NextCycleNode { get; }
Public ReadOnly Property NextCycleNode As GraphNode
    Get
public:
property GraphNode^ NextCycleNode {
    GraphNode^ get ();
}


NumCycleIn Property

NumCycleIn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »NumCycleIn
Declaration Syntax
C# Visual Basic Visual C++
public int NumCycleIn { get; }
Public ReadOnly Property NumCycleIn As Integer
    Get
public:
property int NumCycleIn {
    int get ();
}


NumCycleOut Property

NumCycleOut Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »NumCycleOut
Declaration Syntax
C# Visual Basic Visual C++
public int NumCycleOut { get; }
Public ReadOnly Property NumCycleOut As Integer
    Get
public:
property int NumCycleOut {
    int get ();
}


NumIn Property

NumIn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »NumIn
Declaration Syntax
C# Visual Basic Visual C++
public int NumIn { get; }
Public ReadOnly Property NumIn As Integer
    Get
public:
property int NumIn {
    int get ();
}


NumOut Property

NumOut Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »NumOut
Declaration Syntax
C# Visual Basic Visual C++
public int NumOut { get; }
Public ReadOnly Property NumOut As Integer
    Get
public:
property int NumOut {
    int get ();
}


Out Method (index)

Out Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »Out(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public GraphNode Out(
    int index
)
Public Function Out ( _
    index As Integer _
) As GraphNode
public:
GraphNode^ Out(
    int index
)
Parameters
index(Int32)


Owner Property

Owner Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »Owner
Declaration Syntax
C# Visual Basic Visual C++
public Graph Owner { get; }
Public ReadOnly Property Owner As Graph
    Get
public:
property Graph^ Owner {
    Graph^ get ();
}


RemoveRefTo Method (nodeToRemoveReference)

RemoveRefTo Method (nodeToRemoveReference)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »RemoveRefTo(GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveRefTo(
    GraphNode nodeToRemoveReference
)
Public Sub RemoveRefTo ( _
    nodeToRemoveReference As GraphNode _
)
public:
void RemoveRefTo(
    GraphNode^ nodeToRemoveReference
)
Parameters
nodeToRemoveReference(GraphNode)


SetEdgeGrowthRate Method (outEdgeRate, inEdgeRate)

SetEdgeGrowthRate Method (outEdgeRate, inEdgeRate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »SetEdgeGrowthRate(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SetEdgeGrowthRate(
    int outEdgeRate,
    int inEdgeRate
)
Public Sub SetEdgeGrowthRate ( _
    outEdgeRate As Integer, _
    inEdgeRate As Integer _
)
public:
void SetEdgeGrowthRate(
    int outEdgeRate,
    int inEdgeRate
)
Parameters
outEdgeRate(Int32)
inEdgeRate(Int32)


GraphNodeCollection Class

GraphNodeCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class GraphNodeCollection : DisposableWrapper,
    IList
Public NotInheritable Class GraphNodeCollection _
    Inherits DisposableWrapper _
    Implements IList
public ref class GraphNodeCollection sealed : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GraphNodeCollection()()()() |
 | Add(GraphNode) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(GraphNode) |
 | CopyTo(array<GraphNode>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IListIsFixedSize |
 | IListIsReadOnly |
 | IListItem[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(GraphNode) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, GraphNode) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(GraphNode) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | GraphNodeCollection


GraphNodeCollection Constructor

GraphNodeCollection Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »GraphNodeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GraphNodeCollection()
Public Sub New
public:
GraphNodeCollection()


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »Add(GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    GraphNode value
)
Public Function Add ( _
    value As GraphNode _
) As Integer
public:
int Add(
    GraphNode^ value
)
Parameters
value(GraphNode)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »Contains(GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    GraphNode value
)
Public Function Contains ( _
    value As GraphNode _
) As Boolean
public:
bool Contains(
    GraphNode^ value
)
Parameters
value(GraphNode)


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »CopyTo(array<GraphNode>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    GraphNode[] arr,
    int index
)
Public Sub CopyTo ( _
    arr As GraphNode(), _
    index As Integer _
)
public:
void CopyTo(
    array<GraphNode^>^ arr,
    int index
)
Parameters
arr(array< GraphNode >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (arr, index)

ICollectionCopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array arr,
    int index
)
Private Sub ICollectionCopyTo ( _
    arr As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ arr,
    int index
) sealed = ICollection::CopyTo
Parameters
arr(Array)
index(Int32)


IListAdd Method (value)

IListAdd Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IListAdd ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IListAdd(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IListContains Method (value)

IListContains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IListContains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IListContains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IListIndexOf Method (value)

IListIndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IListIndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IListIndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IListInsert Method (index, value)

IListInsert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IListInsert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IListInsert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IListIsFixedSize Property

IListIsFixedSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »IListIsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IListIsFixedSize { get; }
Protected Overridable ReadOnly Property IListIsFixedSize As Boolean
    Get
protected:
virtual property bool IListIsFixedSize {
    bool get ();
}


IListIsReadOnly Property

IListIsReadOnly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »IListIsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IListIsReadOnly { get; }
Protected Overridable ReadOnly Property IListIsReadOnly As Boolean
    Get
protected:
virtual property bool IListIsReadOnly {
    bool get ();
}


IListItem Property (index)

IListItem Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »IListItem[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
protected virtual Object this[
    int index
] { get; set; }
Protected Overridable Property IListItem ( _
    index As Integer _
) As Object
    Get
    Set
protected:
virtual property Object^ IListItem[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}
Parameters
index(Int32)


IListRemove Method (value)

IListRemove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IListRemove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IListRemove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »IndexOf(GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    GraphNode value
)
Public Function IndexOf ( _
    value As GraphNode _
) As Integer
public:
int IndexOf(
    GraphNode^ value
)
Parameters
value(GraphNode)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »Insert(Int32, GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    GraphNode value
)
Public Sub Insert ( _
    index As Integer, _
    value As GraphNode _
)
public:
void Insert(
    int index,
    GraphNode^ value
)
Parameters
index(Int32)
value(GraphNode)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IsSynchronized { get; }
Protected Overridable ReadOnly Property IsSynchronized As Boolean
    Get
protected:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public virtual GraphNode this[
    int index
] { get; set; }
Public Overridable Default Property Item ( _
    index As Integer _
) As GraphNode
    Get
    Set
public:
virtual property GraphNode^ default[int index] {
    GraphNode^ get (int index);
    void set (int index, GraphNode^ value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »Remove(GraphNode)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    GraphNode value
)
Public Sub Remove ( _
    value As GraphNode _
)
public:
void Remove(
    GraphNode^ value
)
Parameters
value(GraphNode)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
protected virtual Object SyncRoot { get; }
Protected Overridable ReadOnly Property SyncRoot As Object
    Get
protected:
virtual property Object^ SyncRoot {
    Object^ get ();
}


GridLineStyle Enumeration

GridLineStyle Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridLineStyle
Declaration Syntax
C# Visual Basic Visual C++
public enum GridLineStyle
Public Enumeration GridLineStyle
public enum class GridLineStyle
Members
Member | Description
Double |
Single |


GridLineType Enumeration

GridLineType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridLineType
Declaration Syntax
C# Visual Basic Visual C++
public enum GridLineType
Public Enumeration GridLineType
public enum class GridLineType
Members
Member | Description
AllGridLines |
VerticalGridLines |
OuterGridLines |
VerticalRight |
InnerGridLines |
VerticalInside |
VerticalLeft |
HorizontalGridLines |
HorizontalBottom |
HorizontalInside |
HorizontalTop |
InvalidGridLine |


GridProperties Enumeration

GridProperties Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridProperties
Declaration Syntax
C# Visual Basic Visual C++
public enum GridProperties
Public Enumeration GridProperties
public enum class GridProperties
Members
Member | Description
LineWeight |
DoubleLineSpacing |
Visibility |
LineStyle |
Invalid |
Linetype |
Color |


GridPropertyParameter Structure

GridPropertyParameter Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridPropertyParameter
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGridProperty")]
public struct GridPropertyParameter
<WrapperAttribute("ZcGridProperty")> _
Public Structure GridPropertyParameter
[WrapperAttribute(L"ZcGridProperty")]
public value class GridPropertyParameter
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Color |
 | DoubleLineSpacing |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | LineStyle |
 | Linetype |
 | LineWeight |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PropertyMask |
 | ToString()()()() | (Inherited from ValueType.)
 | Visibility |


Color Field

Color Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridPropertyParameter »Color
Declaration Syntax
C# Visual Basic Visual C++
public Color Color
Public Color As Color
public:
Color^ Color


DoubleLineSpacing Field

DoubleLineSpacing Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridPropertyParameter »DoubleLineSpacing
Declaration Syntax
C# Visual Basic Visual C++
public double DoubleLineSpacing
Public DoubleLineSpacing As Double
public:
double DoubleLineSpacing


LineStyle Field

LineStyle Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridPropertyParameter »LineStyle
Declaration Syntax
C# Visual Basic Visual C++
public GridLineStyle LineStyle
Public LineStyle As GridLineStyle
public:
GridLineStyle LineStyle


Linetype Field

Linetype Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridPropertyParameter »Linetype
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Linetype
Public Linetype As ObjectId
public:
ObjectId Linetype


LineWeight Field

LineWeight Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridPropertyParameter »LineWeight
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight LineWeight
Public LineWeight As LineWeight
public:
LineWeight LineWeight


PropertyMask Field

PropertyMask Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridPropertyParameter »PropertyMask
Declaration Syntax
C# Visual Basic Visual C++
public GridProperties PropertyMask
Public PropertyMask As GridProperties
public:
GridProperties PropertyMask


Visibility Field

Visibility Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GridPropertyParameter »Visibility
Declaration Syntax
C# Visual Basic Visual C++
public Visibility Visibility
Public Visibility As Visibility
public:
Visibility Visibility


GripData Class

GripData Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbGripData")]
public class GripData : DisposableWrapper
<WrapperAttribute("ZcDbGripData")> _
Public Class GripData _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcDbGripData")]
public ref class GripData : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GripData()()()() |
 | AlternateBasePoint |
 | AppData |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CallHotGrip(ObjectId, GripData..::..Context) |
 | CallHoverGrip(ObjectId, GripData..::..Context) |
 | CallTooltip()()()() |
 | CallViewportDraw(ViewportDraw, ObjectId, GripData..::..DrawType, Nullable<(Of <<'(Point3d>)>>), Int32) |
 | CallWorldDraw(WorldDraw, ObjectId, GripData..::..DrawType, Nullable<(Of <<'(Point3d>)>>), Double) |
 | ChangeGripStatus(ObjectId, GripData..::..Status) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DrawAtDragImageGripPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForcedPickOn |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetHotGripDimensionData(Double) |
 | GetHoverDimensionData(Double) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetTooltip()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GizmosEnabled |
 | GripPoint |
 | HotGripInvokesRightClick |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsPerViewport |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModeKeywordsDisabled |
 | OnGripStatusChanged(ObjectId, GripData..::..Status) |
 | OnHotGrip(ObjectId, GripData..::..Context) |
 | OnHover(ObjectId, GripData..::..Context) |
 | OnRightClick(GripDataCollection, ObjectIdCollection, Object) |
 | RubberBandLineDisabled |
 | SkipWhenShared |
 | ToString()()()() | (Inherited from Object.)
 | TriggerGrip |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | ViewportDraw(ViewportDraw, ObjectId, GripData..::..DrawType, Nullable<(Of <<'(Point3d>)>>), Int32) |
 | WorldDraw(WorldDraw, ObjectId, GripData..::..DrawType, Nullable<(Of <<'(Point3d>)>>), Double) |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | GripData


GripData Constructor

GripData Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »GripData()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected GripData()
Protected Sub New
protected:
GripData()


AlternateBasePoint Property

AlternateBasePoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »AlternateBasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<Point3d> AlternateBasePoint { get; set; }
Public Property AlternateBasePoint As Nullable(Of Point3d)
    Get
    Set
public:
property Nullable<Point3d> AlternateBasePoint {
    Nullable<Point3d> get ();
    void set (Nullable<Point3d> value);
}


AppData Property

AppData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »AppData
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr AppData { get; }
Public ReadOnly Property AppData As IntPtr
    Get
public:
property IntPtr AppData {
    IntPtr get ();
}


CallHotGrip Method (entityId, contextFlags)

CallHotGrip Method (entityId, contextFlags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »CallHotGrip(ObjectId, GripData..::..Context)
Declaration Syntax
C# Visual Basic Visual C++
public GripData..::..ReturnValue CallHotGrip(
    ObjectId entityId,
    GripData..::..Context contextFlags
)
Public Function CallHotGrip ( _
    entityId As ObjectId, _
    contextFlags As GripData..::..Context _
) As GripData..::..ReturnValue
public:
GripData..::..ReturnValue CallHotGrip(
    ObjectId entityId,
    GripData..::..Context contextFlags
)
Parameters
entityId(ObjectId)
contextFlags(GripData..::..Context)


CallHoverGrip Method (entityId, contextFlags)

CallHoverGrip Method (entityId, contextFlags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »CallHoverGrip(ObjectId, GripData..::..Context)
Declaration Syntax
C# Visual Basic Visual C++
public GripData..::..ReturnValue CallHoverGrip(
    ObjectId entityId,
    GripData..::..Context contextFlags
)
Public Function CallHoverGrip ( _
    entityId As ObjectId, _
    contextFlags As GripData..::..Context _
) As GripData..::..ReturnValue
public:
GripData..::..ReturnValue CallHoverGrip(
    ObjectId entityId,
    GripData..::..Context contextFlags
)
Parameters
entityId(ObjectId)
contextFlags(GripData..::..Context)


CallTooltip Method

CallTooltip Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »CallTooltip()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string CallTooltip()
Public Function CallTooltip As String
public:
String^ CallTooltip()


CallViewportDraw Method (worldDraw, entityId, t, imageGripPoint, gripSizeInPixels)

CallViewportDraw Method (worldDraw, entityId, t, imageGripPoint, gripSizeInPixels)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »CallViewportDraw(ViewportDraw, ObjectId, GripData..::..DrawType, Nullable<(Of <<'(Point3d>)>>), Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CallViewportDraw(
    ViewportDraw worldDraw,
    ObjectId entityId,
    GripData..::..DrawType t,
    Nullable<Point3d> imageGripPoint,
    int gripSizeInPixels
)
Public Sub CallViewportDraw ( _
    worldDraw As ViewportDraw, _
    entityId As ObjectId, _
    t As GripData..::..DrawType, _
    imageGripPoint As Nullable(Of Point3d), _
    gripSizeInPixels As Integer _
)
public:
void CallViewportDraw(
    ViewportDraw^ worldDraw,
    ObjectId entityId,
    GripData..::..DrawType t,
    Nullable<Point3d> imageGripPoint,
    int gripSizeInPixels
)
Parameters
worldDraw(ViewportDraw)
entityId(ObjectId)
t(GripData..::..DrawType)
imageGripPoint(Nullable<(Of <(<' Point3d >)>)>)
gripSizeInPixels(Int32)


CallWorldDraw Method (worldDraw, entityId, t, imageGripPoint, dGripSize)

CallWorldDraw Method (worldDraw, entityId, t, imageGripPoint, dGripSize)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »CallWorldDraw(WorldDraw, ObjectId, GripData..::..DrawType, Nullable<(Of <<'(Point3d>)>>), Double)
Declaration Syntax
C# Visual Basic Visual C++
public bool CallWorldDraw(
    WorldDraw worldDraw,
    ObjectId entityId,
    GripData..::..DrawType t,
    Nullable<Point3d> imageGripPoint,
    double dGripSize
)
Public Function CallWorldDraw ( _
    worldDraw As WorldDraw, _
    entityId As ObjectId, _
    t As GripData..::..DrawType, _
    imageGripPoint As Nullable(Of Point3d), _
    dGripSize As Double _
) As Boolean
public:
bool CallWorldDraw(
    WorldDraw^ worldDraw,
    ObjectId entityId,
    GripData..::..DrawType t,
    Nullable<Point3d> imageGripPoint,
    double dGripSize
)
Parameters
worldDraw(WorldDraw)
entityId(ObjectId)
t(GripData..::..DrawType)
imageGripPoint(Nullable<(Of <(<' Point3d >)>)>)
dGripSize(Double)


ChangeGripStatus Method (entityId, newStatus)

ChangeGripStatus Method (entityId, newStatus)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »ChangeGripStatus(ObjectId, GripData..::..Status)
Declaration Syntax
C# Visual Basic Visual C++
public void ChangeGripStatus(
    ObjectId entityId,
    GripData..::..Status newStatus
)
Public Sub ChangeGripStatus ( _
    entityId As ObjectId, _
    newStatus As GripData..::..Status _
)
public:
void ChangeGripStatus(
    ObjectId entityId,
    GripData..::..Status newStatus
)
Parameters
entityId(ObjectId)
newStatus(GripData..::..Status)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


DrawAtDragImageGripPoint Property

DrawAtDragImageGripPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »DrawAtDragImageGripPoint
Declaration Syntax
C# Visual Basic Visual C++
public bool DrawAtDragImageGripPoint { get; set; }
Public Property DrawAtDragImageGripPoint As Boolean
    Get
    Set
public:
property bool DrawAtDragImageGripPoint {
    bool get ();
    void set (bool value);
}


ForcedPickOn Property

ForcedPickOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »ForcedPickOn
Declaration Syntax
C# Visual Basic Visual C++
public bool ForcedPickOn { get; set; }
Public Property ForcedPickOn As Boolean
    Get
    Set
public:
property bool ForcedPickOn {
    bool get ();
    void set (bool value);
}


GetHotGripDimensionData Method (dimScale)

GetHotGripDimensionData Method (dimScale)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »GetHotGripDimensionData(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DynamicDimensionDataCollection GetHotGripDimensionData(
    double dimScale
)
Public Overridable Function GetHotGripDimensionData ( _
    dimScale As Double _
) As DynamicDimensionDataCollection
public:
virtual DynamicDimensionDataCollection^ GetHotGripDimensionData(
    double dimScale
)
Parameters
dimScale(Double)


GetHoverDimensionData Method (dimScale)

GetHoverDimensionData Method (dimScale)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »GetHoverDimensionData(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DynamicDimensionDataCollection GetHoverDimensionData(
    double dimScale
)
Public Overridable Function GetHoverDimensionData ( _
    dimScale As Double _
) As DynamicDimensionDataCollection
public:
virtual DynamicDimensionDataCollection^ GetHoverDimensionData(
    double dimScale
)
Parameters
dimScale(Double)


GetTooltip Method

GetTooltip Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »GetTooltip()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetTooltip()
Public Overridable Function GetTooltip As String
public:
virtual String^ GetTooltip()


GizmosEnabled Property

GizmosEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »GizmosEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool GizmosEnabled { get; set; }
Public Property GizmosEnabled As Boolean
    Get
    Set
public:
property bool GizmosEnabled {
    bool get ();
    void set (bool value);
}


GripPoint Property

GripPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »GripPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GripPoint { get; set; }
Public Property GripPoint As Point3d
    Get
    Set
public:
property Point3d GripPoint {
    Point3d get ();
    void set (Point3d value);
}


HotGripInvokesRightClick Property

HotGripInvokesRightClick Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »HotGripInvokesRightClick
Declaration Syntax
C# Visual Basic Visual C++
public bool HotGripInvokesRightClick { get; set; }
Public Property HotGripInvokesRightClick As Boolean
    Get
    Set
public:
property bool HotGripInvokesRightClick {
    bool get ();
    void set (bool value);
}


IsPerViewport Property

IsPerViewport Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »IsPerViewport
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerViewport { get; set; }
Public Property IsPerViewport As Boolean
    Get
    Set
public:
property bool IsPerViewport {
    bool get ();
    void set (bool value);
}


ModeKeywordsDisabled Property

ModeKeywordsDisabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »ModeKeywordsDisabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ModeKeywordsDisabled { get; set; }
Public Property ModeKeywordsDisabled As Boolean
    Get
    Set
public:
property bool ModeKeywordsDisabled {
    bool get ();
    void set (bool value);
}


OnGripStatusChanged Method (entityId, newStatus)

OnGripStatusChanged Method (entityId, newStatus)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »OnGripStatusChanged(ObjectId, GripData..::..Status)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OnGripStatusChanged(
    ObjectId entityId,
    GripData..::..Status newStatus
)
Public Overridable Sub OnGripStatusChanged ( _
    entityId As ObjectId, _
    newStatus As GripData..::..Status _
)
public:
virtual void OnGripStatusChanged(
    ObjectId entityId,
    GripData..::..Status newStatus
)
Parameters
entityId(ObjectId)
newStatus(GripData..::..Status)


OnHotGrip Method (entityId, contextFlags)

OnHotGrip Method (entityId, contextFlags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »OnHotGrip(ObjectId, GripData..::..Context)
Declaration Syntax
C# Visual Basic Visual C++
public virtual GripData..::..ReturnValue OnHotGrip(
    ObjectId entityId,
    GripData..::..Context contextFlags
)
Public Overridable Function OnHotGrip ( _
    entityId As ObjectId, _
    contextFlags As GripData..::..Context _
) As GripData..::..ReturnValue
public:
virtual GripData..::..ReturnValue OnHotGrip(
    ObjectId entityId,
    GripData..::..Context contextFlags
)
Parameters
entityId(ObjectId)
contextFlags(GripData..::..Context)


OnHover Method (entityId, contextFlags)

OnHover Method (entityId, contextFlags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »OnHover(ObjectId, GripData..::..Context)
Declaration Syntax
C# Visual Basic Visual C++
public virtual GripData..::..ReturnValue OnHover(
    ObjectId entityId,
    GripData..::..Context contextFlags
)
Public Overridable Function OnHover ( _
    entityId As ObjectId, _
    contextFlags As GripData..::..Context _
) As GripData..::..ReturnValue
public:
virtual GripData..::..ReturnValue OnHover(
    ObjectId entityId,
    GripData..::..Context contextFlags
)
Parameters
entityId(ObjectId)
contextFlags(GripData..::..Context)


OnRightClick Method (hotGrips, entities, menu)

OnRightClick Method (hotGrips, entities, menu)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »OnRightClick(GripDataCollection, ObjectIdCollection, Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual GripData..::..ReturnValue OnRightClick(
    GripDataCollection hotGrips,
    ObjectIdCollection entities,
    Object menu
)
Public Overridable Function OnRightClick ( _
    hotGrips As GripDataCollection, _
    entities As ObjectIdCollection, _
    menu As Object _
) As GripData..::..ReturnValue
public:
virtual GripData..::..ReturnValue OnRightClick(
    GripDataCollection^ hotGrips,
    ObjectIdCollection^ entities,
    Object^ menu
)
Parameters
hotGrips(GripDataCollection)
entities(ObjectIdCollection)
menu(Object)


RubberBandLineDisabled Property

RubberBandLineDisabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »RubberBandLineDisabled
Declaration Syntax
C# Visual Basic Visual C++
public bool RubberBandLineDisabled { get; set; }
Public Property RubberBandLineDisabled As Boolean
    Get
    Set
public:
property bool RubberBandLineDisabled {
    bool get ();
    void set (bool value);
}


SkipWhenShared Property

SkipWhenShared Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »SkipWhenShared
Declaration Syntax
C# Visual Basic Visual C++
public bool SkipWhenShared { get; set; }
Public Property SkipWhenShared As Boolean
    Get
    Set
public:
property bool SkipWhenShared {
    bool get ();
    void set (bool value);
}


TriggerGrip Property

TriggerGrip Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »TriggerGrip
Declaration Syntax
C# Visual Basic Visual C++
public bool TriggerGrip { get; set; }
Public Property TriggerGrip As Boolean
    Get
    Set
public:
property bool TriggerGrip {
    bool get ();
    void set (bool value);
}


ViewportDraw Method (worldDraw, entityId, t, imageGripPoint, gripSizeInPixels)

ViewportDraw Method (worldDraw, entityId, t, imageGripPoint, gripSizeInPixels)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »ViewportDraw(ViewportDraw, ObjectId, GripData..::..DrawType, Nullable<(Of <<'(Point3d>)>>), Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ViewportDraw(
    ViewportDraw worldDraw,
    ObjectId entityId,
    GripData..::..DrawType t,
    Nullable<Point3d> imageGripPoint,
    int gripSizeInPixels
)
Public Overridable Function ViewportDraw ( _
    worldDraw As ViewportDraw, _
    entityId As ObjectId, _
    t As GripData..::..DrawType, _
    imageGripPoint As Nullable(Of Point3d), _
    gripSizeInPixels As Integer _
) As Boolean
public:
virtual bool ViewportDraw(
    ViewportDraw^ worldDraw,
    ObjectId entityId,
    GripData..::..DrawType t,
    Nullable<Point3d> imageGripPoint,
    int gripSizeInPixels
)
Parameters
worldDraw(ViewportDraw)
entityId(ObjectId)
t(GripData..::..DrawType)
imageGripPoint(Nullable<(Of <(<' Point3d >)>)>)
gripSizeInPixels(Int32)


WorldDraw Method (worldDraw, entityId, t, imageGripPoint, dGripSize)

WorldDraw Method (worldDraw, entityId, t, imageGripPoint, dGripSize)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »WorldDraw(WorldDraw, ObjectId, GripData..::..DrawType, Nullable<(Of <<'(Point3d>)>>), Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool WorldDraw(
    WorldDraw worldDraw,
    ObjectId entityId,
    GripData..::..DrawType t,
    Nullable<Point3d> imageGripPoint,
    double dGripSize
)
Public Overridable Function WorldDraw ( _
    worldDraw As WorldDraw, _
    entityId As ObjectId, _
    t As GripData..::..DrawType, _
    imageGripPoint As Nullable(Of Point3d), _
    dGripSize As Double _
) As Boolean
public:
virtual bool WorldDraw(
    WorldDraw^ worldDraw,
    ObjectId entityId,
    GripData..::..DrawType t,
    Nullable<Point3d> imageGripPoint,
    double dGripSize
)
Parameters
worldDraw(WorldDraw)
entityId(ObjectId)
t(GripData..::..DrawType)
imageGripPoint(Nullable<(Of <(<' Point3d >)>)>)
dGripSize(Double)


GripData.Context Enumeration

GripData..::..Context Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »GripData..::..Context
Declaration Syntax
C# Visual Basic Visual C++
public enum Context
Public Enumeration Context
public enum class Context
Members
Member | Description
SharedGrip |
MultiHotGrip |


GripData.DrawType Enumeration

GripData..::..DrawType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »GripData..::..DrawType
Declaration Syntax
C# Visual Basic Visual C++
public enum DrawType
Public Enumeration DrawType
public enum class DrawType
Members
Member | Description
DragImageGrip |
HotGrip |
HoverGrip |
WarmGrip |


GripData.ReturnValue Enumeration

GripData..::..ReturnValue Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »GripData..::..ReturnValue
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("Zcad::ErrorStatus")]
public enum ReturnValue
<WrapperAttribute("Zcad::ErrorStatus")> _
Public Enumeration ReturnValue
[WrapperAttribute(L"Zcad::ErrorStatus")]
public enum class ReturnValue
Members
Member | Description
GetNewGripPoints |
GripHotToWarm |
NoRedrawGrip |
Failure |
Ok |


GripData.Status Enumeration

GripData..::..Status Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »GripData..::..Status
Declaration Syntax
C# Visual Basic Visual C++
public enum Status
Public Enumeration Status
public enum class Status
Members
Member | Description
PopUpMenu |
DimFocusChanged |
Scale |
Rotate |
Move |
Stretch |
GripAbort |
GripEnd |
GripStart |
Mirror |


GripDataCollection Class

GripDataCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbGripDataPtrArray")]
public sealed class GripDataCollection : DisposableWrapper,
    ICollection<GripData>
<WrapperAttribute("ZcDbGripDataPtrArray")> _
Public NotInheritable Class GripDataCollection _
    Inherits DisposableWrapper _
    Implements ICollection(Of GripData)
[WrapperAttribute(L"ZcDbGripDataPtrArray")]
public ref class GripDataCollection sealed : public DisposableWrapper,
    ICollection<GripData^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GripDataCollection()()()() |
 | Add(GripData) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(GripData) |
 | CopyTo(array<GripData>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerable..::..GetEnumerator()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsReadOnly |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(GripData) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | GripDataCollection


GripDataCollection Constructor

GripDataCollection Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »GripDataCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GripDataCollection()
Public Sub New
public:
GripDataCollection()


Add Method (gripData)

Add Method (gripData)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »Add(GripData)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    GripData gripData
)
Public Sub Add ( _
    gripData As GripData _
)
public:
virtual void Add(
    GripData^ gripData
) sealed
Parameters
gripData(GripData)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (gripData)

Contains Method (gripData)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »Contains(GripData)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    GripData gripData
)
Public Function Contains ( _
    gripData As GripData _
) As Boolean
public:
virtual bool Contains(
    GripData^ gripData
) sealed
Parameters
gripData(GripData)


CopyTo Method (, )

CopyTo Method (, )
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »CopyTo(array<GripData>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    GripData[] ,
    int
)
Public Sub CopyTo ( _
     As GripData(), _
     As Integer _
)
public:
virtual void CopyTo(
    array<GripData^>^ ,
    int
) sealed
Parameters
(array< GripData >[]()[][])
(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<GripData> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of GripData)
public:
virtual IEnumerator<GripData^>^ GetEnumerator() sealed


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »IEnumerable..::..GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
IEnumerator IEnumerable.GetEnumerator()
Private Function IEnumerable_GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ IEnumerable_GetEnumerator() sealed = IEnumerable::GetEnumerator


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


Item Property ()

Item Property ()
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public GripData this[
    int
] { get; }
Public ReadOnly Default Property Item ( _
     As Integer _
) As GripData
    Get
public:
property GripData^ default[int ] {
    GripData^ get (int );
}
Parameters
(Int32)


Remove Method (gripData)

Remove Method (gripData)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »Remove(GripData)
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    GripData gripData
)
Public Function Remove ( _
    gripData As GripData _
) As Boolean
public:
virtual bool Remove(
    GripData^ gripData
) sealed
Parameters
gripData(GripData)


GripStatus Enumeration

GripStatus Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripStatus
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::GripStat")]
public enum GripStatus
<WrapperAttribute("ZcDb::GripStat")> _
Public Enumeration GripStatus
[WrapperAttribute(L"ZcDb::GripStat")]
public enum class GripStatus
Members
Member | Description
DimDataToBeDeleted |
GripsToBeDeleted |
GripsDone |


GroundPlaneBackground Class

GroundPlaneBackground Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbGroundPlaneBackground")]
public class GroundPlaneBackground : Background
<WrapperAttribute("AcDbGroundPlaneBackground")> _
Public Class GroundPlaneBackground _
    Inherits Background
[WrapperAttribute(L"AcDbGroundPlaneBackground")]
public ref class GroundPlaneBackground : public Background
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GroundPlaneBackground()()()() |
 | GroundPlaneBackground(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Background
 |  |  |  |  |  |  | GroundPlaneBackground


GroundPlaneBackground Constructor

GroundPlaneBackground Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground »GroundPlaneBackground()()()()
Members
Icon | Member | Description
 | GroundPlaneBackground()()()() |
 | GroundPlaneBackground(IntPtr, Boolean) |


GroundPlaneBackground Constructor

GroundPlaneBackground Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground »GroundPlaneBackground()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GroundPlaneBackground()
Public Sub New
public:
GroundPlaneBackground()


GroundPlaneBackground Constructor (unmanagedPointer, autoDelete)

GroundPlaneBackground Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground »GroundPlaneBackground(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal GroundPlaneBackground(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
GroundPlaneBackground(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Group Class

Group Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbGroup")]
public class Group : DBObject
<WrapperAttribute("AcDbGroup")> _
Public Class Group _
    Inherits DBObject
[WrapperAttribute(L"AcDbGroup")]
public ref class Group : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Group(String, Boolean) |
 | Group()()()() |
 | Group(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | Append(ObjectIdCollection) |
 | Append(ObjectId) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clear()()()() |
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Description |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAllEntityIds()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetIndex(ObjectId) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(Entity) |
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertAt(Int32, ObjectIdCollection) |
 | InsertAt(Int32, ObjectId) |
 | IsAnonymous |
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotAccessible |
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name |
 | NumEntities |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | Prepend(ObjectIdCollection) |
 | Prepend(ObjectId) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | Remove(ObjectIdCollection) |
 | Remove(ObjectId) |
 | RemoveAt(Int32, ObjectIdCollection) |
 | RemoveAt(Int32) |
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Replace(ObjectId, ObjectId) |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Reverse()()()() |
 | Selectable |
 | SetAnonymous()()()() |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetColor(Color) |
 | SetColorIndex(Int32) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetHighlight(Boolean) |
 | SetLayer(String) |
 | SetLayer(ObjectId) |
 | SetLinetype(String) |
 | SetLinetype(ObjectId) |
 | SetLinetypeScale(Double) |
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetVisibility(Boolean) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Transfer(Int32, Int32, Int32) |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Group


Group Constructor

Group Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Group()()()()
Members
Icon | Member | Description
 | Group(String, Boolean) |
 | Group()()()() |
 | Group(IntPtr, Boolean) |


Group Constructor

Group Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Group()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Group()
Public Sub New
public:
Group()


Group Constructor (unmanagedPointer, autoDelete)

Group Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Group(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Group(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Group(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Group Constructor (description, selectable)

Group Constructor (description, selectable)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Group(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Group(
    string description,
    bool selectable
)
Public Sub New ( _
    description As String, _
    selectable As Boolean _
)
public:
Group(
    String^ description,
    bool selectable
)
Parameters
description(String)
selectable(Boolean)


Append Method

Append Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Append()()()()
Members
Icon | Member | Description
 | Append(ObjectIdCollection) |
 | Append(ObjectId) |


Append Method (id)

Append Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Append(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Append(
    ObjectId id
)
Public Sub Append ( _
    id As ObjectId _
)
public:
void Append(
    ObjectId id
)
Parameters
id(ObjectId)


Append Method (ids)

Append Method (ids)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Append(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void Append(
    ObjectIdCollection ids
)
Public Sub Append ( _
    ids As ObjectIdCollection _
)
public:
void Append(
    ObjectIdCollection^ ids
)
Parameters
ids(ObjectIdCollection)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


GetAllEntityIds Method

GetAllEntityIds Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »GetAllEntityIds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId[] GetAllEntityIds()
Public Function GetAllEntityIds As ObjectId()
public:
array<ObjectId>^ GetAllEntityIds()


GetIndex Method (id)

GetIndex Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »GetIndex(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public int GetIndex(
    ObjectId id
)
Public Function GetIndex ( _
    id As ObjectId _
) As Integer
public:
int GetIndex(
    ObjectId id
)
Parameters
id(ObjectId)


Has Method (entity)

Has Method (entity)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Has(Entity)
Declaration Syntax
C# Visual Basic Visual C++
public bool Has(
    Entity entity
)
Public Function Has ( _
    entity As Entity _
) As Boolean
public:
bool Has(
    Entity^ entity
)
Parameters
entity(Entity)


InsertAt Method

InsertAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »InsertAt()()()()
Members
Icon | Member | Description
 | InsertAt(Int32, ObjectIdCollection) |
 | InsertAt(Int32, ObjectId) |


InsertAt Method (index, id)

InsertAt Method (index, id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »InsertAt(Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertAt(
    int index,
    ObjectId id
)
Public Sub InsertAt ( _
    index As Integer, _
    id As ObjectId _
)
public:
void InsertAt(
    int index,
    ObjectId id
)
Parameters
index(Int32)
id(ObjectId)


InsertAt Method (index, ids)

InsertAt Method (index, ids)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »InsertAt(Int32, ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertAt(
    int index,
    ObjectIdCollection ids
)
Public Sub InsertAt ( _
    index As Integer, _
    ids As ObjectIdCollection _
)
public:
void InsertAt(
    int index,
    ObjectIdCollection^ ids
)
Parameters
index(Int32)
ids(ObjectIdCollection)


IsAnonymous Property

IsAnonymous Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »IsAnonymous
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAnonymous { get; }
Public ReadOnly Property IsAnonymous As Boolean
    Get
public:
property bool IsAnonymous {
    bool get ();
}


IsNotAccessible Property

IsNotAccessible Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »IsNotAccessible
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNotAccessible { get; }
Public ReadOnly Property IsNotAccessible As Boolean
    Get
public:
property bool IsNotAccessible {
    bool get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NumEntities Property

NumEntities Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »NumEntities
Declaration Syntax
C# Visual Basic Visual C++
public int NumEntities { get; }
Public ReadOnly Property NumEntities As Integer
    Get
public:
property int NumEntities {
    int get ();
}


Prepend Method

Prepend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Prepend()()()()
Members
Icon | Member | Description
 | Prepend(ObjectIdCollection) |
 | Prepend(ObjectId) |


Prepend Method (id)

Prepend Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Prepend(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Prepend(
    ObjectId id
)
Public Sub Prepend ( _
    id As ObjectId _
)
public:
void Prepend(
    ObjectId id
)
Parameters
id(ObjectId)


Prepend Method (ids)

Prepend Method (ids)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Prepend(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void Prepend(
    ObjectIdCollection ids
)
Public Sub Prepend ( _
    ids As ObjectIdCollection _
)
public:
void Prepend(
    ObjectIdCollection^ ids
)
Parameters
ids(ObjectIdCollection)


Remove Method

Remove Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Remove()()()()
Members
Icon | Member | Description
 | Remove(ObjectIdCollection) |
 | Remove(ObjectId) |


Remove Method (id)

Remove Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Remove(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ObjectId id
)
Public Sub Remove ( _
    id As ObjectId _
)
public:
void Remove(
    ObjectId id
)
Parameters
id(ObjectId)


Remove Method (ids)

Remove Method (ids)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Remove(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ObjectIdCollection ids
)
Public Sub Remove ( _
    ids As ObjectIdCollection _
)
public:
void Remove(
    ObjectIdCollection^ ids
)
Parameters
ids(ObjectIdCollection)


RemoveAt Method

RemoveAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »RemoveAt()()()()
Members
Icon | Member | Description
 | RemoveAt(Int32, ObjectIdCollection) |
 | RemoveAt(Int32) |


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
void RemoveAt(
    int index
)
Parameters
index(Int32)


RemoveAt Method (index, ids)

RemoveAt Method (index, ids)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »RemoveAt(Int32, ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index,
    ObjectIdCollection ids
)
Public Sub RemoveAt ( _
    index As Integer, _
    ids As ObjectIdCollection _
)
public:
void RemoveAt(
    int index,
    ObjectIdCollection^ ids
)
Parameters
index(Int32)
ids(ObjectIdCollection)


Replace Method (oldId, newId)

Replace Method (oldId, newId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Replace(ObjectId, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Replace(
    ObjectId oldId,
    ObjectId newId
)
Public Sub Replace ( _
    oldId As ObjectId, _
    newId As ObjectId _
)
public:
void Replace(
    ObjectId oldId,
    ObjectId newId
)
Parameters
oldId(ObjectId)
newId(ObjectId)


Reverse Method

Reverse Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Reverse()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reverse()
Public Sub Reverse
public:
void Reverse()


Selectable Property

Selectable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Selectable
Declaration Syntax
C# Visual Basic Visual C++
public bool Selectable { get; set; }
Public Property Selectable As Boolean
    Get
    Set
public:
property bool Selectable {
    bool get ();
    void set (bool value);
}


SetAnonymous Method

SetAnonymous Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetAnonymous()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetAnonymous()
Public Sub SetAnonymous
public:
void SetAnonymous()


SetColor Method (color)

SetColor Method (color)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetColor(Color)
Declaration Syntax
C# Visual Basic Visual C++
public void SetColor(
    Color color
)
Public Sub SetColor ( _
    color As Color _
)
public:
void SetColor(
    Color^ color
)
Parameters
color(Color)


SetColorIndex Method (color)

SetColorIndex Method (color)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetColorIndex(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SetColorIndex(
    int color
)
Public Sub SetColorIndex ( _
    color As Integer _
)
public:
void SetColorIndex(
    int color
)
Parameters
color(Int32)


SetHighlight Method (value)

SetHighlight Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetHighlight(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHighlight(
    bool value
)
Public Sub SetHighlight ( _
    value As Boolean _
)
public:
void SetHighlight(
    bool value
)
Parameters
value(Boolean)


SetLayer Method

SetLayer Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetLayer()()()()
Members
Icon | Member | Description
 | SetLayer(String) |
 | SetLayer(ObjectId) |


SetLayer Method (value)

SetLayer Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetLayer(String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayer(
    string value
)
Public Sub SetLayer ( _
    value As String _
)
public:
void SetLayer(
    String^ value
)
Parameters
value(String)


SetLayer Method (value)

SetLayer Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetLayer(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayer(
    ObjectId value
)
Public Sub SetLayer ( _
    value As ObjectId _
)
public:
void SetLayer(
    ObjectId value
)
Parameters
value(ObjectId)


SetLinetype Method

SetLinetype Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetLinetype()()()()
Members
Icon | Member | Description
 | SetLinetype(String) |
 | SetLinetype(ObjectId) |


SetLinetype Method (value)

SetLinetype Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetLinetype(String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLinetype(
    string value
)
Public Sub SetLinetype ( _
    value As String _
)
public:
void SetLinetype(
    String^ value
)
Parameters
value(String)


SetLinetype Method (value)

SetLinetype Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetLinetype(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLinetype(
    ObjectId value
)
Public Sub SetLinetype ( _
    value As ObjectId _
)
public:
void SetLinetype(
    ObjectId value
)
Parameters
value(ObjectId)


SetLinetypeScale Method (value)

SetLinetypeScale Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetLinetypeScale(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLinetypeScale(
    double value
)
Public Sub SetLinetypeScale ( _
    value As Double _
)
public:
void SetLinetypeScale(
    double value
)
Parameters
value(Double)


SetVisibility Method (value)

SetVisibility Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetVisibility(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetVisibility(
    bool value
)
Public Sub SetVisibility ( _
    value As Boolean _
)
public:
void SetVisibility(
    bool value
)
Parameters
value(Boolean)


Transfer Method (fromIndex, toIndex, numItems)

Transfer Method (fromIndex, toIndex, numItems)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Transfer(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Transfer(
    int fromIndex,
    int toIndex,
    int numItems
)
Public Sub Transfer ( _
    fromIndex As Integer, _
    toIndex As Integer, _
    numItems As Integer _
)
public:
void Transfer(
    int fromIndex,
    int toIndex,
    int numItems
)
Parameters
fromIndex(Int32)
toIndex(Int32)
numItems(Int32)


GsMarkType Enumeration

GsMarkType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GsMarkType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeader::gsMarkType")]
public enum GsMarkType
<WrapperAttribute("ZcDbMLeader::gsMarkType")> _
Public Enumeration GsMarkType
[WrapperAttribute(L"ZcDbMLeader::gsMarkType")]
public enum class GsMarkType
Members
Member | Description
None |
ToleranceMark |
MTextUnderLineMark |
MTextMark |
LeaderLineMark |
DoglegMark |
BlockMark |
ArrowMark |


Handle Structure

Handle Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle
Declaration Syntax
C# Visual Basic Visual C++
public struct Handle
Public Structure Handle
public value class Handle
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Handle(Int64) |
 | Equality(Handle, Handle) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(Handle, Handle) |
 | IsOne |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | Value |


Handle Constructor (v)

Handle Constructor (v)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle »Handle(Int64)
Declaration Syntax
C# Visual Basic Visual C++
public Handle(
    long v
)
Public Sub New ( _
    v As Long _
)
public:
Handle(
    long long v
)
Parameters
v(Int64)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle »Equality(Handle, Handle)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Handle a,
    Handle b
)
Public Shared Operator = ( _
    a As Handle, _
    b As Handle _
) As Boolean
public:
static bool operator ==(
    Handle a,
    Handle b
)
Parameters
a(Handle)
b(Handle)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle »Inequality(Handle, Handle)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Handle a,
    Handle b
)
Public Shared Operator <> ( _
    a As Handle, _
    b As Handle _
) As Boolean
public:
static bool operator !=(
    Handle a,
    Handle b
)
Parameters
a(Handle)
b(Handle)


IsOne Property

IsOne Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle »IsOne
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOne { get; }
Public ReadOnly Property IsOne As Boolean
    Get
public:
property bool IsOne {
    bool get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Handle »Value
Declaration Syntax
C# Visual Basic Visual C++
public long Value { get; }
Public ReadOnly Property Value As Long
    Get
public:
property long long Value {
    long long get ();
}


Hatch Class

Hatch Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbHatch")]
public class Hatch : Entity
<WrapperAttribute("AcDbHatch")> _
Public Class Hatch _
    Inherits Entity
[WrapperAttribute(L"AcDbHatch")]
public ref class Hatch : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Hatch()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | AppendLoop(HatchLoopTypes, Point2dCollection, DoubleCollection) |
 | AppendLoop(HatchLoopTypes, ObjectIdCollection) |
 | AppendLoop(HatchLoop) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Associative |
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation |
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | EvaluateGradientColorAt(Single) |
 | EvaluateHatch(Boolean) |
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetAssociatedObjectIds()()()() |
 | GetAssociatedObjectIdsAt(Int32) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGradientColors()()()() |
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetHatchLineDataAt(Int32) |
 | GetHatchLinesData()()()() |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLoopAt(Int32) |
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPatternDefinitionAt(Int32) |
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | GradientAngle |
 | GradientName |
 | GradientOneColorMode |
 | GradientShift |
 | GradientType |
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | HatchObjectType |
 | HatchStyle |
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertLoopAt(Int32, HatchLoopTypes, ObjectIdCollection) |
 | InsertLoopAt(Int32, HatchLoop) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsGradient |
 | IsHatch |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsSolidFill |
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | LoopTypeAt(Int32) |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | NumberOfHatchLines |
 | NumberOfLoops |
 | NumberOfPatternDefinitions |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | Origin |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PatternAngle |
 | PatternDouble |
 | PatternName |
 | PatternScale |
 | PatternSpace |
 | PatternType |
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveAssociatedObjectIds()()()() |
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemoveLoopAt(Int32) |
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGradient(GradientPatternType, String) |
 | SetGradientColors(array<GradientColor>[]()[][]) |
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetHatchPattern(HatchPatternType, String) |
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | ShadeTintValue |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Hatch


Hatch Constructor

Hatch Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »Hatch()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Hatch()
Public Sub New
public:
Hatch()


AppendLoop Method

AppendLoop Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »AppendLoop()()()()
Members
Icon | Member | Description
 | AppendLoop(HatchLoopTypes, Point2dCollection, DoubleCollection) |
 | AppendLoop(HatchLoopTypes, ObjectIdCollection) |
 | AppendLoop(HatchLoop) |


AppendLoop Method (hatchLoop)

AppendLoop Method (hatchLoop)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »AppendLoop(HatchLoop)
Declaration Syntax
C# Visual Basic Visual C++
public void AppendLoop(
    HatchLoop hatchLoop
)
Public Sub AppendLoop ( _
    hatchLoop As HatchLoop _
)
public:
void AppendLoop(
    HatchLoop^ hatchLoop
)
Parameters
hatchLoop(HatchLoop)


AppendLoop Method (loopType, dbObjIds)

AppendLoop Method (loopType, dbObjIds)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »AppendLoop(HatchLoopTypes, ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AppendLoop(
    HatchLoopTypes loopType,
    ObjectIdCollection dbObjIds
)
Public Sub AppendLoop ( _
    loopType As HatchLoopTypes, _
    dbObjIds As ObjectIdCollection _
)
public:
void AppendLoop(
    HatchLoopTypes loopType,
    ObjectIdCollection^ dbObjIds
)
Parameters
loopType(HatchLoopTypes)
dbObjIds(ObjectIdCollection)


AppendLoop Method (loopType, vertexCollection, bulgeCollection)

AppendLoop Method (loopType, vertexCollection, bulgeCollection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »AppendLoop(HatchLoopTypes, Point2dCollection, DoubleCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AppendLoop(
    HatchLoopTypes loopType,
    Point2dCollection vertexCollection,
    DoubleCollection bulgeCollection
)
Public Sub AppendLoop ( _
    loopType As HatchLoopTypes, _
    vertexCollection As Point2dCollection, _
    bulgeCollection As DoubleCollection _
)
public:
void AppendLoop(
    HatchLoopTypes loopType,
    Point2dCollection^ vertexCollection,
    DoubleCollection^ bulgeCollection
)
Parameters
loopType(HatchLoopTypes)
vertexCollection(Point2dCollection)
bulgeCollection(DoubleCollection)


Area Property

Area Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »Area
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Area)]
public double Area { get; }
<UnitTypeAttribute(UnitType.Area)> _
Public ReadOnly Property Area As Double
    Get
[UnitTypeAttribute(UnitType::Area)]
public:
property double Area {
    double get ();
}


Associative Property

Associative Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »Associative
Declaration Syntax
C# Visual Basic Visual C++
public bool Associative { get; set; }
Public Property Associative As Boolean
    Get
    Set
public:
property bool Associative {
    bool get ();
    void set (bool value);
}


Elevation Property

Elevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »Elevation
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Elevation { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Elevation As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Elevation {
    double get ();
    void set (double value);
}


EvaluateGradientColorAt Method (value)

EvaluateGradientColorAt Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »EvaluateGradientColorAt(Single)
Declaration Syntax
C# Visual Basic Visual C++
public Color EvaluateGradientColorAt(
    float value
)
Public Function EvaluateGradientColorAt ( _
    value As Single _
) As Color
public:
Color^ EvaluateGradientColorAt(
    float value
)
Parameters
value(Single)


EvaluateHatch Method (underEstimateNumLines)

EvaluateHatch Method (underEstimateNumLines)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »EvaluateHatch(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void EvaluateHatch(
    bool underEstimateNumLines
)
Public Sub EvaluateHatch ( _
    underEstimateNumLines As Boolean _
)
public:
void EvaluateHatch(
    bool underEstimateNumLines
)
Parameters
underEstimateNumLines(Boolean)


GetAssociatedObjectIds Method

GetAssociatedObjectIds Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetAssociatedObjectIds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetAssociatedObjectIds()
Public Function GetAssociatedObjectIds As ObjectIdCollection
public:
ObjectIdCollection^ GetAssociatedObjectIds()


GetAssociatedObjectIdsAt Method (loopIndex)

GetAssociatedObjectIdsAt Method (loopIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetAssociatedObjectIdsAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetAssociatedObjectIdsAt(
    int loopIndex
)
Public Function GetAssociatedObjectIdsAt ( _
    loopIndex As Integer _
) As ObjectIdCollection
public:
ObjectIdCollection^ GetAssociatedObjectIdsAt(
    int loopIndex
)
Parameters
loopIndex(Int32)


GetGradientColors Method

GetGradientColors Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetGradientColors()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GradientColor[] GetGradientColors()
Public Function GetGradientColors As GradientColor()
public:
array<GradientColor>^ GetGradientColors()


GetHatchLineDataAt Method (index)

GetHatchLineDataAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetHatchLineDataAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Line2d GetHatchLineDataAt(
    int index
)
Public Function GetHatchLineDataAt ( _
    index As Integer _
) As Line2d
public:
Line2d^ GetHatchLineDataAt(
    int index
)
Parameters
index(Int32)


GetHatchLinesData Method

GetHatchLinesData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetHatchLinesData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Line2dCollection GetHatchLinesData()
Public Function GetHatchLinesData As Line2dCollection
public:
Line2dCollection^ GetHatchLinesData()


GetLoopAt Method (loopIndex)

GetLoopAt Method (loopIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetLoopAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public HatchLoop GetLoopAt(
    int loopIndex
)
Public Function GetLoopAt ( _
    loopIndex As Integer _
) As HatchLoop
public:
HatchLoop^ GetLoopAt(
    int loopIndex
)
Parameters
loopIndex(Int32)


GetPatternDefinitionAt Method (index)

GetPatternDefinitionAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetPatternDefinitionAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PatternDefinition GetPatternDefinitionAt(
    int index
)
Public Function GetPatternDefinitionAt ( _
    index As Integer _
) As PatternDefinition
public:
PatternDefinition GetPatternDefinitionAt(
    int index
)
Parameters
index(Int32)


GradientAngle Property

GradientAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GradientAngle
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Angle)]
public double GradientAngle { get; set; }
<UnitTypeAttribute(UnitType.Angle)> _
Public Property GradientAngle As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Angle)]
public:
property double GradientAngle {
    double get ();
    void set (double value);
}


GradientName Property

GradientName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GradientName
Declaration Syntax
C# Visual Basic Visual C++
public string GradientName { get; }
Public ReadOnly Property GradientName As String
    Get
public:
property String^ GradientName {
    String^ get ();
}


GradientOneColorMode Property

GradientOneColorMode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GradientOneColorMode
Declaration Syntax
C# Visual Basic Visual C++
public bool GradientOneColorMode { get; set; }
Public Property GradientOneColorMode As Boolean
    Get
    Set
public:
property bool GradientOneColorMode {
    bool get ();
    void set (bool value);
}


GradientShift Property

GradientShift Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GradientShift
Declaration Syntax
C# Visual Basic Visual C++
public float GradientShift { get; set; }
Public Property GradientShift As Single
    Get
    Set
public:
property float GradientShift {
    float get ();
    void set (float value);
}


GradientType Property

GradientType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GradientType
Declaration Syntax
C# Visual Basic Visual C++
public GradientPatternType GradientType { get; }
Public ReadOnly Property GradientType As GradientPatternType
    Get
public:
property GradientPatternType GradientType {
    GradientPatternType get ();
}


HatchObjectType Property

HatchObjectType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »HatchObjectType
Declaration Syntax
C# Visual Basic Visual C++
public HatchObjectType HatchObjectType { get; set; }
Public Property HatchObjectType As HatchObjectType
    Get
    Set
public:
property HatchObjectType HatchObjectType {
    HatchObjectType get ();
    void set (HatchObjectType value);
}


HatchStyle Property

HatchStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »HatchStyle
Declaration Syntax
C# Visual Basic Visual C++
public HatchStyle HatchStyle { get; set; }
Public Property HatchStyle As HatchStyle
    Get
    Set
public:
property HatchStyle HatchStyle {
    HatchStyle get ();
    void set (HatchStyle value);
}


InsertLoopAt Method

InsertLoopAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »InsertLoopAt()()()()
Members
Icon | Member | Description
 | InsertLoopAt(Int32, HatchLoopTypes, ObjectIdCollection) |
 | InsertLoopAt(Int32, HatchLoop) |


InsertLoopAt Method (loopIndex, hatchLoop)

InsertLoopAt Method (loopIndex, hatchLoop)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »InsertLoopAt(Int32, HatchLoop)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertLoopAt(
    int loopIndex,
    HatchLoop hatchLoop
)
Public Sub InsertLoopAt ( _
    loopIndex As Integer, _
    hatchLoop As HatchLoop _
)
public:
void InsertLoopAt(
    int loopIndex,
    HatchLoop^ hatchLoop
)
Parameters
loopIndex(Int32)
hatchLoop(HatchLoop)


InsertLoopAt Method (loopIndex, loopType, dbObjIds)

InsertLoopAt Method (loopIndex, loopType, dbObjIds)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »InsertLoopAt(Int32, HatchLoopTypes, ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertLoopAt(
    int loopIndex,
    HatchLoopTypes loopType,
    ObjectIdCollection dbObjIds
)
Public Sub InsertLoopAt ( _
    loopIndex As Integer, _
    loopType As HatchLoopTypes, _
    dbObjIds As ObjectIdCollection _
)
public:
void InsertLoopAt(
    int loopIndex,
    HatchLoopTypes loopType,
    ObjectIdCollection^ dbObjIds
)
Parameters
loopIndex(Int32)
loopType(HatchLoopTypes)
dbObjIds(ObjectIdCollection)


IsGradient Property

IsGradient Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »IsGradient
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsGradient { get; }
Public Overridable ReadOnly Property IsGradient As Boolean
    Get
public:
virtual property bool IsGradient {
    bool get ();
}


IsHatch Property

IsHatch Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »IsHatch
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsHatch { get; }
Public Overridable ReadOnly Property IsHatch As Boolean
    Get
public:
virtual property bool IsHatch {
    bool get ();
}


IsSolidFill Property

IsSolidFill Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »IsSolidFill
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSolidFill { get; }
Public ReadOnly Property IsSolidFill As Boolean
    Get
public:
property bool IsSolidFill {
    bool get ();
}


LoopTypeAt Method (loopIndex)

LoopTypeAt Method (loopIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »LoopTypeAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public HatchLoopTypes LoopTypeAt(
    int loopIndex
)
Public Function LoopTypeAt ( _
    loopIndex As Integer _
) As HatchLoopTypes
public:
HatchLoopTypes LoopTypeAt(
    int loopIndex
)
Parameters
loopIndex(Int32)


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


NumberOfHatchLines Property

NumberOfHatchLines Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »NumberOfHatchLines
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfHatchLines { get; }
Public ReadOnly Property NumberOfHatchLines As Integer
    Get
public:
property int NumberOfHatchLines {
    int get ();
}


NumberOfLoops Property

NumberOfLoops Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »NumberOfLoops
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfLoops { get; }
Public ReadOnly Property NumberOfLoops As Integer
    Get
public:
property int NumberOfLoops {
    int get ();
}


NumberOfPatternDefinitions Property

NumberOfPatternDefinitions Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »NumberOfPatternDefinitions
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfPatternDefinitions { get; }
Public ReadOnly Property NumberOfPatternDefinitions As Integer
    Get
public:
property int NumberOfPatternDefinitions {
    int get ();
}


Origin Property

Origin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »Origin
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Origin { get; set; }
Public Property Origin As Point2d
    Get
    Set
public:
property Point2d Origin {
    Point2d get ();
    void set (Point2d value);
}


PatternAngle Property

PatternAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »PatternAngle
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Angle)]
public double PatternAngle { get; set; }
<UnitTypeAttribute(UnitType.Angle)> _
Public Property PatternAngle As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Angle)]
public:
property double PatternAngle {
    double get ();
    void set (double value);
}


PatternDouble Property

PatternDouble Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »PatternDouble
Declaration Syntax
C# Visual Basic Visual C++
public bool PatternDouble { get; set; }
Public Property PatternDouble As Boolean
    Get
    Set
public:
property bool PatternDouble {
    bool get ();
    void set (bool value);
}


PatternName Property

PatternName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »PatternName
Declaration Syntax
C# Visual Basic Visual C++
public string PatternName { get; }
Public ReadOnly Property PatternName As String
    Get
public:
property String^ PatternName {
    String^ get ();
}


PatternScale Property

PatternScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »PatternScale
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double PatternScale { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property PatternScale As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double PatternScale {
    double get ();
    void set (double value);
}


PatternSpace Property

PatternSpace Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »PatternSpace
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double PatternSpace { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property PatternSpace As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double PatternSpace {
    double get ();
    void set (double value);
}


PatternType Property

PatternType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »PatternType
Declaration Syntax
C# Visual Basic Visual C++
public HatchPatternType PatternType { get; }
Public ReadOnly Property PatternType As HatchPatternType
    Get
public:
property HatchPatternType PatternType {
    HatchPatternType get ();
}


RemoveAssociatedObjectIds Method

RemoveAssociatedObjectIds Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »RemoveAssociatedObjectIds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAssociatedObjectIds()
Public Sub RemoveAssociatedObjectIds
public:
void RemoveAssociatedObjectIds()


RemoveLoopAt Method (loopIndex)

RemoveLoopAt Method (loopIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »RemoveLoopAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveLoopAt(
    int loopIndex
)
Public Sub RemoveLoopAt ( _
    loopIndex As Integer _
)
public:
void RemoveLoopAt(
    int loopIndex
)
Parameters
loopIndex(Int32)


SetGradient Method (gradientType, gradientName)

SetGradient Method (gradientType, gradientName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »SetGradient(GradientPatternType, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetGradient(
    GradientPatternType gradientType,
    string gradientName
)
Public Sub SetGradient ( _
    gradientType As GradientPatternType, _
    gradientName As String _
)
public:
void SetGradient(
    GradientPatternType gradientType,
    String^ gradientName
)
Parameters
gradientType(GradientPatternType)
gradientName(String)


SetGradientColors Method (value)

SetGradientColors Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »SetGradientColors(array<GradientColor>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetGradientColors(
    GradientColor[] value
)
Public Sub SetGradientColors ( _
    value As GradientColor() _
)
public:
void SetGradientColors(
    array<GradientColor>^ value
)
Parameters
value(array< GradientColor >[]()[][])


SetHatchPattern Method (patternType, patternName)

SetHatchPattern Method (patternType, patternName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »SetHatchPattern(HatchPatternType, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHatchPattern(
    HatchPatternType patternType,
    string patternName
)
Public Sub SetHatchPattern ( _
    patternType As HatchPatternType, _
    patternName As String _
)
public:
void SetHatchPattern(
    HatchPatternType patternType,
    String^ patternName
)
Parameters
patternType(HatchPatternType)
patternName(String)


ShadeTintValue Property

ShadeTintValue Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »ShadeTintValue
Declaration Syntax
C# Visual Basic Visual C++
public float ShadeTintValue { get; set; }
Public Property ShadeTintValue As Single
    Get
    Set
public:
property float ShadeTintValue {
    float get ();
    void set (float value);
}


HatchEdgeType Enumeration

HatchEdgeType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchEdgeType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbHatch::HatchEdgeType")]
public enum HatchEdgeType
<WrapperAttribute("ZcDbHatch::HatchEdgeType")> _
Public Enumeration HatchEdgeType
[WrapperAttribute(L"ZcDbHatch::HatchEdgeType")]
public enum class HatchEdgeType
Members
Member | Description
Spline |
Line |
EllipticalArc |
CircularArc |


HatchLoop Class

HatchLoop Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchLoop
Declaration Syntax
C# Visual Basic Visual C++
public sealed class HatchLoop
Public NotInheritable Class HatchLoop
public ref class HatchLoop sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HatchLoop(HatchLoopTypes) |
 | Curves |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsPolyline |
 | LoopType |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Polyline |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
HatchLoop


HatchLoop Constructor (loopType)

HatchLoop Constructor (loopType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchLoop »HatchLoop(HatchLoopTypes)
Declaration Syntax
C# Visual Basic Visual C++
public HatchLoop(
    HatchLoopTypes loopType
)
Public Sub New ( _
    loopType As HatchLoopTypes _
)
public:
HatchLoop(
    HatchLoopTypes loopType
)
Parameters
loopType(HatchLoopTypes)


Curves Property

Curves Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchLoop »Curves
Declaration Syntax
C# Visual Basic Visual C++
public Curve2dCollection Curves { get; }
Public ReadOnly Property Curves As Curve2dCollection
    Get
public:
property Curve2dCollection^ Curves {
    Curve2dCollection^ get ();
}


IsPolyline Property

IsPolyline Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchLoop »IsPolyline
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPolyline { get; }
Public ReadOnly Property IsPolyline As Boolean
    Get
public:
property bool IsPolyline {
    bool get ();
}


LoopType Property

LoopType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchLoop »LoopType
Declaration Syntax
C# Visual Basic Visual C++
public HatchLoopTypes LoopType { get; }
Public ReadOnly Property LoopType As HatchLoopTypes
    Get
public:
property HatchLoopTypes LoopType {
    HatchLoopTypes get ();
}


Polyline Property

Polyline Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchLoop »Polyline
Declaration Syntax
C# Visual Basic Visual C++
public BulgeVertexCollection Polyline { get; }
Public ReadOnly Property Polyline As BulgeVertexCollection
    Get
public:
property BulgeVertexCollection^ Polyline {
    BulgeVertexCollection^ get ();
}


HatchLoopTypes Enumeration

HatchLoopTypes Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchLoopTypes
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
[WrapperAttribute("ZcDbHatch::HatchLoopType")]
public enum HatchLoopTypes
<FlagsAttribute> _
<WrapperAttribute("ZcDbHatch::HatchLoopType")> _
Public Enumeration HatchLoopTypes
[FlagsAttribute]
[WrapperAttribute(L"ZcDbHatch::HatchLoopType")]
public enum class HatchLoopTypes
Members
Member | Description
Duplicate |
TextIsland |
SelfIntersecting |
NotClosed |
Outermost |
Textbox |
Derived |
External |
Default |
Polyline |


HatchObjectType Enumeration

HatchObjectType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchObjectType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbHatch::HatchObjectType")]
public enum HatchObjectType
<WrapperAttribute("ZcDbHatch::HatchObjectType")> _
Public Enumeration HatchObjectType
[WrapperAttribute(L"ZcDbHatch::HatchObjectType")]
public enum class HatchObjectType
Members
Member | Description
GradientObject |
HatchObject |


HatchPatternType Enumeration

HatchPatternType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchPatternType
Declaration Syntax
C# Visual Basic Visual C++
public enum HatchPatternType
Public Enumeration HatchPatternType
public enum class HatchPatternType
Members
Member | Description
CustomDefined |
PreDefined |
UserDefined |


HatchStyle Enumeration

HatchStyle Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HatchStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbHatch::HatchStyle")]
public enum HatchStyle
<WrapperAttribute("ZcDbHatch::HatchStyle")> _
Public Enumeration HatchStyle
[WrapperAttribute(L"ZcDbHatch::HatchStyle")]
public enum class HatchStyle
Members
Member | Description
Normal |
Outer |
Ignore |


Helix Class

Helix Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbHelix")]
public class Helix : Spline
<WrapperAttribute("AcDbHelix")> _
Public Class Helix _
    Inherits Spline
[WrapperAttribute(L"AcDbHelix")]
public ref class Helix : public Spline
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Helix()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | AxisVector |
 | BaseRadius |
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed | (Inherited from Curve.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Constrain |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateHelix()()()() |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Degree | (Inherited from Spline.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | ElevateDegree(Int32) | (Inherited from Spline.)
 | EndFitTangent | (Inherited from Spline.)
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FitData | (Inherited from Spline.)
 | FitTolerance | (Inherited from Spline.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetAxisPoint()()()() |
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetControlPointAt(Int32) | (Inherited from Spline.)
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetFitPointAt(Int32) | (Inherited from Spline.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasFitData | (Inherited from Spline.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height |
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertFitPointAt(Int32, Point3d) | (Inherited from Spline.)
 | InsertKnot(Double) | (Inherited from Spline.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsNull | (Inherited from Spline.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Spline.)
 | IsRational | (Inherited from Spline.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | NumControlPoints | (Inherited from Spline.)
 | NumFitPoints | (Inherited from Spline.)
 | NurbsData | (Inherited from Spline.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | PurgeFitData()()()() | (Inherited from Spline.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemoveFitPointAt(Int32) | (Inherited from Spline.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetAxisPoint(Point3d, Boolean) |
 | SetControlPointAt(Int32, Point3d) | (Inherited from Spline.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFitPointAt(Int32, Point3d) | (Inherited from Spline.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetWeightAt(Int32, Double) | (Inherited from Spline.)
 | Spline | (Inherited from Curve.)
 | StartFitTangent | (Inherited from Spline.)
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Overrides Curve.StartPoint.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToPolyline(UInt32) | (Inherited from Spline.)
 | ToPolyline()()()() | (Inherited from Spline.)
 | ToPolylineWithPrecision(Int32) | (Inherited from Spline.)
 | TopRadius |
 | ToString()()()() | (Inherited from Object.)
 | TotalLength |
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | TurnHeight |
 | Turns |
 | TurnSlope |
 | Twist |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateFitData()()()() | (Inherited from Spline.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WeightAt(Int32) | (Inherited from Spline.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Spline
 |  |  |  |  |  |  |  |  | Helix


Helix Constructor

Helix Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »Helix()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Helix()
Public Sub New
public:
Helix()


AxisVector Property

AxisVector Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »AxisVector
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d AxisVector { get; set; }
Public Property AxisVector As Vector3d
    Get
    Set
public:
property Vector3d AxisVector {
    Vector3d get ();
    void set (Vector3d value);
}


BaseRadius Property

BaseRadius Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »BaseRadius
Declaration Syntax
C# Visual Basic Visual C++
public double BaseRadius { get; set; }
Public Property BaseRadius As Double
    Get
    Set
public:
property double BaseRadius {
    double get ();
    void set (double value);
}


Constrain Property

Constrain Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »Constrain
Declaration Syntax
C# Visual Basic Visual C++
public ConstrainType Constrain { get; set; }
Public Property Constrain As ConstrainType
    Get
    Set
public:
property ConstrainType Constrain {
    ConstrainType get ();
    void set (ConstrainType value);
}


CreateHelix Method

CreateHelix Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »CreateHelix()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void CreateHelix()
Public Sub CreateHelix
public:
void CreateHelix()


GetAxisPoint Method

GetAxisPoint Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetAxisPoint()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetAxisPoint()
Public Function GetAxisPoint As Point3d
public:
Point3d GetAxisPoint()


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »Height
Declaration Syntax
C# Visual Basic Visual C++
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}


SetAxisPoint Method (axisPoint, moveStartPoint)

SetAxisPoint Method (axisPoint, moveStartPoint)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »SetAxisPoint(Point3d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAxisPoint(
    Point3d axisPoint,
    bool moveStartPoint
)
Public Sub SetAxisPoint ( _
    axisPoint As Point3d, _
    moveStartPoint As Boolean _
)
public:
void SetAxisPoint(
    Point3d axisPoint,
    bool moveStartPoint
)
Parameters
axisPoint(Point3d)
moveStartPoint(Boolean)


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public override Point3d StartPoint { get; set; }
Public Overrides Property StartPoint As Point3d
    Get
    Set
public:
virtual property Point3d StartPoint {
    Point3d get () override;
    void set (Point3d value) override;
}


TopRadius Property

TopRadius Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »TopRadius
Declaration Syntax
C# Visual Basic Visual C++
public double TopRadius { get; set; }
Public Property TopRadius As Double
    Get
    Set
public:
property double TopRadius {
    double get ();
    void set (double value);
}


TotalLength Property

TotalLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »TotalLength
Declaration Syntax
C# Visual Basic Visual C++
public double TotalLength { get; }
Public ReadOnly Property TotalLength As Double
    Get
public:
property double TotalLength {
    double get ();
}


TurnHeight Property

TurnHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »TurnHeight
Declaration Syntax
C# Visual Basic Visual C++
public double TurnHeight { get; set; }
Public Property TurnHeight As Double
    Get
    Set
public:
property double TurnHeight {
    double get ();
    void set (double value);
}


Turns Property

Turns Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »Turns
Declaration Syntax
C# Visual Basic Visual C++
public double Turns { get; set; }
Public Property Turns As Double
    Get
    Set
public:
property double Turns {
    double get ();
    void set (double value);
}


TurnSlope Property

TurnSlope Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »TurnSlope
Declaration Syntax
C# Visual Basic Visual C++
public double TurnSlope { get; }
Public ReadOnly Property TurnSlope As Double
    Get
public:
property double TurnSlope {
    double get ();
}


Twist Property

Twist Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »Twist
Declaration Syntax
C# Visual Basic Visual C++
public bool Twist { get; set; }
Public Property Twist As Boolean
    Get
    Set
public:
property bool Twist {
    bool get ();
    void set (bool value);
}


HostApplicationServices Class

HostApplicationServices Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbHostApplicationServices")]
public abstract class HostApplicationServices : RXObject
<WrapperAttribute("AcDbHostApplicationServices")> _
Public MustInherit Class HostApplicationServices _
    Inherits RXObject
[WrapperAttribute(L"AcDbHostApplicationServices")]
public ref class HostApplicationServices abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HostApplicationServices()()()() |
 | AlternateFontName |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompanyName |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Current |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FindFile(String, Database, FindFileHint) |
 | FontMapFileName |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetPassword(String, PasswordOptions) |
 | GetRemoteFile(Uri, Boolean) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetUrl(String) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsUrl(String) |
 | LoadApplication(String, ApplicationLoadReasons, Boolean, Boolean) |
 | LocalRootFolder |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModelerFlavor |
 | Product |
 | Program |
 | PutRemoteFile(Uri, String) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RegistryProductRootKey |
 | RoamableRootFolder |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | WorkingDatabase |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | HostApplicationServices


HostApplicationServices Constructor

HostApplicationServices Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »HostApplicationServices()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal HostApplicationServices()
Protected Friend Sub New
protected public:
HostApplicationServices()


AlternateFontName Property

AlternateFontName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »AlternateFontName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string AlternateFontName { get; }
Public Overridable ReadOnly Property AlternateFontName As String
    Get
public:
virtual property String^ AlternateFontName {
    String^ get ();
}


CompanyName Property

CompanyName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »CompanyName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string CompanyName { get; }
Public Overridable ReadOnly Property CompanyName As String
    Get
public:
virtual property String^ CompanyName {
    String^ get ();
}


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »Current
Declaration Syntax
C# Visual Basic Visual C++
public static HostApplicationServices Current { get; set; }
Public Shared Property Current As HostApplicationServices
    Get
    Set
public:
static property HostApplicationServices^ Current {
    HostApplicationServices^ get ();
    void set (HostApplicationServices^ value);
}


FindFile Method (fileName, database, hint)

FindFile Method (fileName, database, hint)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »FindFile(String, Database, FindFileHint)
Declaration Syntax
C# Visual Basic Visual C++
public abstract string FindFile(
    string fileName,
    Database database,
    FindFileHint hint
)
Public MustOverride Function FindFile ( _
    fileName As String, _
    database As Database, _
    hint As FindFileHint _
) As String
public:
virtual String^ FindFile(
    String^ fileName,
    Database^ database,
    FindFileHint hint
) abstract
Parameters
fileName(String)
database(Database)
hint(FindFileHint)


FontMapFileName Property

FontMapFileName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »FontMapFileName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string FontMapFileName { get; }
Public Overridable ReadOnly Property FontMapFileName As String
    Get
public:
virtual property String^ FontMapFileName {
    String^ get ();
}


GetPassword Method (dwgName, options)

GetPassword Method (dwgName, options)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »GetPassword(String, PasswordOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetPassword(
    string dwgName,
    PasswordOptions options
)
Public Overridable Function GetPassword ( _
    dwgName As String, _
    options As PasswordOptions _
) As String
public:
virtual String^ GetPassword(
    String^ dwgName,
    PasswordOptions options
)
Parameters
dwgName(String)
options(PasswordOptions)


GetRemoteFile Method (url, bIgnoreCache)

GetRemoteFile Method (url, bIgnoreCache)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »GetRemoteFile(Uri, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetRemoteFile(
    Uri url,
    bool bIgnoreCache
)
Public Overridable Function GetRemoteFile ( _
    url As Uri, _
    bIgnoreCache As Boolean _
) As String
public:
virtual String^ GetRemoteFile(
    Uri^ url,
    bool bIgnoreCache
)
Parameters
url(Uri)
bIgnoreCache(Boolean)


GetUrl Method (localFile)

GetUrl Method (localFile)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »GetUrl(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Uri GetUrl(
    string localFile
)
Public Overridable Function GetUrl ( _
    localFile As String _
) As Uri
public:
virtual Uri^ GetUrl(
    String^ localFile
)
Parameters
localFile(String)


IsUrl Method (url)

IsUrl Method (url)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »IsUrl(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsUrl(
    string url
)
Public Overridable Function IsUrl ( _
    url As String _
) As Boolean
public:
virtual bool IsUrl(
    String^ url
)
Parameters
url(String)


LoadApplication Method (appName, why, printit, asCmd)

LoadApplication Method (appName, why, printit, asCmd)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »LoadApplication(String, ApplicationLoadReasons, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void LoadApplication(
    string appName,
    ApplicationLoadReasons why,
    bool printit,
    bool asCmd
)
Public Overridable Sub LoadApplication ( _
    appName As String, _
    why As ApplicationLoadReasons, _
    printit As Boolean, _
    asCmd As Boolean _
)
public:
virtual void LoadApplication(
    String^ appName,
    ApplicationLoadReasons why,
    bool printit,
    bool asCmd
)
Parameters
appName(String)
why(ApplicationLoadReasons)
printit(Boolean)
asCmd(Boolean)


LocalRootFolder Property

LocalRootFolder Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »LocalRootFolder
Declaration Syntax
C# Visual Basic Visual C++
public virtual string LocalRootFolder { get; }
Public Overridable ReadOnly Property LocalRootFolder As String
    Get
public:
virtual property String^ LocalRootFolder {
    String^ get ();
}


ModelerFlavor Property

ModelerFlavor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »ModelerFlavor
Declaration Syntax
C# Visual Basic Visual C++
public virtual ModelerFlavor ModelerFlavor { get; }
Public Overridable ReadOnly Property ModelerFlavor As ModelerFlavor
    Get
public:
virtual property ModelerFlavor ModelerFlavor {
    ModelerFlavor get ();
}


Product Property

Product Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »Product
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Product { get; }
Public Overridable ReadOnly Property Product As String
    Get
public:
virtual property String^ Product {
    String^ get ();
}


Program Property

Program Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »Program
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Program { get; }
Public Overridable ReadOnly Property Program As String
    Get
public:
virtual property String^ Program {
    String^ get ();
}


PutRemoteFile Method (url, localFile)

PutRemoteFile Method (url, localFile)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »PutRemoteFile(Uri, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void PutRemoteFile(
    Uri url,
    string localFile
)
Public Overridable Sub PutRemoteFile ( _
    url As Uri, _
    localFile As String _
)
public:
virtual void PutRemoteFile(
    Uri^ url,
    String^ localFile
)
Parameters
url(Uri)
localFile(String)


RegistryProductRootKey Property

RegistryProductRootKey Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »RegistryProductRootKey
Declaration Syntax
C# Visual Basic Visual C++
public virtual string RegistryProductRootKey { get; }
Public Overridable ReadOnly Property RegistryProductRootKey As String
    Get
public:
virtual property String^ RegistryProductRootKey {
    String^ get ();
}


RoamableRootFolder Property

RoamableRootFolder Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »RoamableRootFolder
Declaration Syntax
C# Visual Basic Visual C++
public virtual string RoamableRootFolder { get; }
Public Overridable ReadOnly Property RoamableRootFolder As String
    Get
public:
virtual property String^ RoamableRootFolder {
    String^ get ();
}


WorkingDatabase Property

WorkingDatabase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »WorkingDatabase
Declaration Syntax
C# Visual Basic Visual C++
public static Database WorkingDatabase { get; set; }
Public Shared Property WorkingDatabase As Database
    Get
    Set
public:
static property Database^ WorkingDatabase {
    Database^ get ();
    void set (Database^ value);
}


HyperLink Class

HyperLink Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbHyperlink")]
public sealed class HyperLink : DisposableWrapper
<WrapperAttribute("ZcDbHyperlink")> _
Public NotInheritable Class HyperLink _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcDbHyperlink")]
public ref class HyperLink sealed : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HyperLink()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Description |
 | DisplayString |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Overrides DisposableWrapper.Equals(Object).)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Overrides DisposableWrapper.GetHashCode()()()().)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsOutermostContainer |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | NestedLevel |
 | SubLocation |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | HyperLink


HyperLink Constructor

HyperLink Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »HyperLink()()()()
Declaration Syntax
C# Visual Basic Visual C++
public HyperLink()
Public Sub New
public:
HyperLink()


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DisplayString Property

DisplayString Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »DisplayString
Declaration Syntax
C# Visual Basic Visual C++
public string DisplayString { get; }
Public ReadOnly Property DisplayString As String
    Get
public:
property String^ DisplayString {
    String^ get ();
}


Equals Method (other)

Equals Method (other)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object other
)
Public Overrides NotOverridable Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override sealed
Parameters
other(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


IsOutermostContainer Property

IsOutermostContainer Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »IsOutermostContainer
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOutermostContainer { get; }
Public ReadOnly Property IsOutermostContainer As Boolean
    Get
public:
property bool IsOutermostContainer {
    bool get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NestedLevel Property

NestedLevel Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »NestedLevel
Declaration Syntax
C# Visual Basic Visual C++
public int NestedLevel { get; }
Public ReadOnly Property NestedLevel As Integer
    Get
public:
property int NestedLevel {
    int get ();
}


SubLocation Property

SubLocation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »SubLocation
Declaration Syntax
C# Visual Basic Visual C++
public string SubLocation { get; set; }
Public Property SubLocation As String
    Get
    Set
public:
property String^ SubLocation {
    String^ get ();
    void set (String^ value);
}


HyperLinkCollection Class

HyperLinkCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbHyperlinkCollection")]
public sealed class HyperLinkCollection : DisposableWrapper,
    IList
<WrapperAttribute("ZcDbHyperlinkCollection")> _
Public NotInheritable Class HyperLinkCollection _
    Inherits DisposableWrapper _
    Implements IList
[WrapperAttribute(L"ZcDbHyperlinkCollection")]
public ref class HyperLinkCollection sealed : public DisposableWrapper,
    IList
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(HyperLink) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(HyperLink) |
 | CopyTo(array<HyperLink>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Remove(Object) |
 | IndexOf(HyperLink) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, HyperLink) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IList..::..IsFixedSize |
 | IList..::..IsReadOnly |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(HyperLink) |
 | RemoveAt(Int32) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | HyperLinkCollection


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »Add(HyperLink)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    HyperLink value
)
Public Function Add ( _
    value As HyperLink _
) As Integer
public:
int Add(
    HyperLink^ value
)
Parameters
value(HyperLink)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »Contains(HyperLink)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    HyperLink value
)
Public Function Contains ( _
    value As HyperLink _
) As Boolean
public:
bool Contains(
    HyperLink^ value
)
Parameters
value(HyperLink)


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »CopyTo(array<HyperLink>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    HyperLink[] arr,
    int index
)
Public Sub CopyTo ( _
    arr As HyperLink(), _
    index As Integer _
)
public:
void CopyTo(
    array<HyperLink^>^ arr,
    int index
)
Parameters
arr(array< HyperLink >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (array, index)

ICollectionCopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollectionCopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IListAdd Method (value)

IListAdd Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IListAdd ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IListAdd(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IListContains Method (value)

IListContains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IListContains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IListContains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IListIndexOf Method (value)

IListIndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IListIndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IListIndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IListInsert Method (index, value)

IListInsert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IListInsert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IListInsert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IListRemove Method (value)

IListRemove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IListRemove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IListRemove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »IndexOf(HyperLink)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    HyperLink value
)
Public Function IndexOf ( _
    value As HyperLink _
) As Integer
public:
int IndexOf(
    HyperLink^ value
)
Parameters
value(HyperLink)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »Insert(Int32, HyperLink)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    HyperLink value
)
Public Sub Insert ( _
    index As Integer, _
    value As HyperLink _
)
public:
void Insert(
    int index,
    HyperLink^ value
)
Parameters
index(Int32)
value(HyperLink)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »IList..::..IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
bool IList.IsFixedSize { get; }
Private ReadOnly Property IsFixedSize As Boolean
    Implements IList.IsFixedSize
    Get
private:
virtual property bool IsFixedSize {
    bool get () sealed = IList::IsFixedSize::get;
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »IList..::..IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
bool IList.IsReadOnly { get; }
Private ReadOnly Property IsReadOnly As Boolean
    Implements IList.IsReadOnly
    Get
private:
virtual property bool IsReadOnly {
    bool get () sealed = IList::IsReadOnly::get;
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public HyperLink this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As HyperLink
    Get
    Set
public:
property HyperLink^ default[int index] {
    HyperLink^ get (int index);
    void set (int index, HyperLink^ value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »Remove(HyperLink)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    HyperLink value
)
Public Sub Remove ( _
    value As HyperLink _
)
public:
void Remove(
    HyperLink^ value
)
Parameters
value(HyperLink)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


IdMapping Class

IdMapping Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbIdMapping")]
public sealed class IdMapping : RXObject,
    IEnumerable
<WrapperAttribute("ZcDbIdMapping")> _
Public NotInheritable Class IdMapping _
    Inherits RXObject _
    Implements IEnumerable
[WrapperAttribute(L"ZcDbIdMapping")]
public ref class IdMapping sealed : public RXObject,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IdMapping()()()() |
 | Add(IdPair) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Change(IdPair) |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Contains(ObjectId) |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeepCloneContext |
 | Delete(ObjectId) |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DestinationDatabase |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DuplicateRecordCloning |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Item[([( ObjectId])]) |
 | Lookup(ObjectId) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OriginalDatabase |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | IdMapping


IdMapping Constructor

IdMapping Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »IdMapping()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IdMapping()
Public Sub New
public:
IdMapping()


Add Method (pairToAdd)

Add Method (pairToAdd)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »Add(IdPair)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    IdPair pairToAdd
)
Public Sub Add ( _
    pairToAdd As IdPair _
)
public:
void Add(
    IdPair pairToAdd
)
Parameters
pairToAdd(IdPair)


Change Method (pairToChange)

Change Method (pairToChange)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »Change(IdPair)
Declaration Syntax
C# Visual Basic Visual C++
public void Change(
    IdPair pairToChange
)
Public Sub Change ( _
    pairToChange As IdPair _
)
public:
void Change(
    IdPair pairToChange
)
Parameters
pairToChange(IdPair)


Contains Method (key)

Contains Method (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »Contains(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ObjectId key
)
Public Function Contains ( _
    key As ObjectId _
) As Boolean
public:
bool Contains(
    ObjectId key
)
Parameters
key(ObjectId)


DeepCloneContext Property

DeepCloneContext Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »DeepCloneContext
Declaration Syntax
C# Visual Basic Visual C++
public DeepCloneType DeepCloneContext { get; }
Public ReadOnly Property DeepCloneContext As DeepCloneType
    Get
public:
property DeepCloneType DeepCloneContext {
    DeepCloneType get ();
}


Delete Method (key)

Delete Method (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »Delete(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Delete(
    ObjectId key
)
Public Sub Delete ( _
    key As ObjectId _
)
public:
void Delete(
    ObjectId key
)
Parameters
key(ObjectId)


DestinationDatabase Property

DestinationDatabase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »DestinationDatabase
Declaration Syntax
C# Visual Basic Visual C++
public Database DestinationDatabase { get; set; }
Public Property DestinationDatabase As Database
    Get
    Set
public:
property Database^ DestinationDatabase {
    Database^ get ();
    void set (Database^ value);
}


DuplicateRecordCloning Property

DuplicateRecordCloning Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »DuplicateRecordCloning
Declaration Syntax
C# Visual Basic Visual C++
public DuplicateRecordCloning DuplicateRecordCloning { get; }
Public ReadOnly Property DuplicateRecordCloning As DuplicateRecordCloning
    Get
public:
property DuplicateRecordCloning DuplicateRecordCloning {
    DuplicateRecordCloning get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


Item Property (key)

Item Property (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »Item[([( ObjectId])])
Declaration Syntax
C# Visual Basic Visual C++
public IdPair this[
    ObjectId key
] { get; set; }
Public Default Property Item ( _
    key As ObjectId _
) As IdPair
    Get
    Set
public:
property IdPair default[ObjectId key] {
    IdPair get (ObjectId key);
    void set (ObjectId key, IdPair value);
}
Parameters
key(ObjectId)


Lookup Method (key)

Lookup Method (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »Lookup(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public IdPair Lookup(
    ObjectId key
)
Public Function Lookup ( _
    key As ObjectId _
) As IdPair
public:
IdPair Lookup(
    ObjectId key
)
Parameters
key(ObjectId)


OriginalDatabase Property

OriginalDatabase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »OriginalDatabase
Declaration Syntax
C# Visual Basic Visual C++
public Database OriginalDatabase { get; }
Public ReadOnly Property OriginalDatabase As Database
    Get
public:
property Database^ OriginalDatabase {
    Database^ get ();
}


IdMappingEventArgs Class

IdMappingEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMappingEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class IdMappingEventArgs : EventArgs
Public NotInheritable Class IdMappingEventArgs _
    Inherits EventArgs
public ref class IdMappingEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IdMapping |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | IdMappingEventArgs


IdMapping Property

IdMapping Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMappingEventArgs »IdMapping
Declaration Syntax
C# Visual Basic Visual C++
public IdMapping IdMapping { get; }
Public ReadOnly Property IdMapping As IdMapping
    Get
public:
property IdMapping^ IdMapping {
    IdMapping^ get ();
}


IdMappingEventHandler Delegate

IdMappingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMappingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void IdMappingEventHandler(
    Object sender,
    IdMappingEventArgs e
)
Public Delegate Sub IdMappingEventHandler ( _
    sender As Object, _
    e As IdMappingEventArgs _
)
public delegate void IdMappingEventHandler(
    Object^ sender,
    IdMappingEventArgs^ e
)
Parameters
sender(Object)
e(IdMappingEventArgs)


IdPair Structure

IdPair Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbIdPair")]
public struct IdPair
<WrapperAttribute("AcDbIdPair")> _
Public Structure IdPair
[WrapperAttribute(L"AcDbIdPair")]
public value class IdPair
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IdPair(ObjectId, ObjectId, Boolean, Boolean, Boolean) |
 | Equality(IdPair, IdPair) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(IdPair, IdPair) |
 | IsCloned |
 | IsOwnerTranslated |
 | IsPrimary |
 | Key |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | Value |


IdPair Constructor (key, value, isCloned, isPrimary, isOwnerTranslated)

IdPair Constructor (key, value, isCloned, isPrimary, isOwnerTranslated)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »IdPair(ObjectId, ObjectId, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public IdPair(
    ObjectId key,
    ObjectId value,
    bool isCloned,
    bool isPrimary,
    bool isOwnerTranslated
)
Public Sub New ( _
    key As ObjectId, _
    value As ObjectId, _
    isCloned As Boolean, _
    isPrimary As Boolean, _
    isOwnerTranslated As Boolean _
)
public:
IdPair(
    ObjectId key,
    ObjectId value,
    bool isCloned,
    bool isPrimary,
    bool isOwnerTranslated
)
Parameters
key(ObjectId)
value(ObjectId)
isCloned(Boolean)
isPrimary(Boolean)
isOwnerTranslated(Boolean)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »Equality(IdPair, IdPair)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    IdPair a,
    IdPair b
)
Public Shared Operator = ( _
    a As IdPair, _
    b As IdPair _
) As Boolean
public:
static bool operator ==(
    IdPair a,
    IdPair b
)
Parameters
a(IdPair)
b(IdPair)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »Inequality(IdPair, IdPair)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    IdPair a,
    IdPair b
)
Public Shared Operator <> ( _
    a As IdPair, _
    b As IdPair _
) As Boolean
public:
static bool operator !=(
    IdPair a,
    IdPair b
)
Parameters
a(IdPair)
b(IdPair)


IsCloned Property

IsCloned Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »IsCloned
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCloned { get; }
Public ReadOnly Property IsCloned As Boolean
    Get
public:
property bool IsCloned {
    bool get ();
}


IsOwnerTranslated Property

IsOwnerTranslated Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »IsOwnerTranslated
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOwnerTranslated { get; }
Public ReadOnly Property IsOwnerTranslated As Boolean
    Get
public:
property bool IsOwnerTranslated {
    bool get ();
}


IsPrimary Property

IsPrimary Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »IsPrimary
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPrimary { get; }
Public ReadOnly Property IsPrimary As Boolean
    Get
public:
property bool IsPrimary {
    bool get ();
}


Key Property

Key Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »Key
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Key { get; }
Public ReadOnly Property Key As ObjectId
    Get
public:
property ObjectId Key {
    ObjectId get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdPair »Value
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Value { get; }
Public ReadOnly Property Value As ObjectId
    Get
public:
property ObjectId Value {
    ObjectId get ();
}


Image Class

Image Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbImage")]
public class Image : Entity
<WrapperAttribute("AcDbImage")> _
Public Class Image _
    Inherits Entity
[WrapperAttribute(L"AcDbImage")]
public ref class Image : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Image(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Image
 |  |  |  |  |  |  |  | RasterImage


Image Constructor (unmanagedObjPtr, autoDelete)

Image Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »Image(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Image(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Image(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


ImageDisplayOptions Enumeration

ImageDisplayOptions Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ImageDisplayOptions
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
[WrapperAttribute("ZcDbRasterImage::ImageDisplayOpt")]
public enum ImageDisplayOptions
<FlagsAttribute> _
<WrapperAttribute("ZcDbRasterImage::ImageDisplayOpt")> _
Public Enumeration ImageDisplayOptions
[FlagsAttribute]
[WrapperAttribute(L"ZcDbRasterImage::ImageDisplayOpt")]
public enum class ImageDisplayOptions
Members
Member | Description
Transparent |
Clip |
ShowUnaligned |
Show |


ImageOrg Enumeration

ImageOrg Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ImageOrg
Declaration Syntax
C# Visual Basic Visual C++
public enum ImageOrg
Public Enumeration ImageOrg
public enum class ImageOrg
Members
Member | Description
Gray |
BGR |
ABGR |
ARGB |
BGRA |
RGBA |
Palette |
Bitonal |
RGB |


ImageQuality Enumeration

ImageQuality Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ImageQuality
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbRasterVariables::ImageQuality")]
public enum ImageQuality
<WrapperAttribute("ZcDbRasterVariables::ImageQuality")> _
Public Enumeration ImageQuality
[WrapperAttribute(L"ZcDbRasterVariables::ImageQuality")]
public enum class ImageQuality
Members
Member | Description
Invalid |
High |
Draft |


IndexCreation Enumeration

IndexCreation Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IndexCreation
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum IndexCreation
<FlagsAttribute> _
Public Enumeration IndexCreation
[FlagsAttribute]
public enum class IndexCreation
Members
Member | Description
NoIndex |
IndexSpatially |
IndexByLayer |


Intersect Enumeration

Intersect Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Intersect
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::Intersect")]
public enum Intersect
<WrapperAttribute("ZcDb::Intersect")> _
Public Enumeration Intersect
[WrapperAttribute(L"ZcDb::Intersect")]
public enum class Intersect
Members
Member | Description
ExtendBoth |
ExtendArgument |
ExtendThis |
OnBothOperands |


ISubObject Interface

ISubObject Interface
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ISubObject
Declaration Syntax
C# Visual Basic Visual C++
public interface ISubObject
Public Interface ISubObject
public interface class ISubObject
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Parent |


Parent Property

Parent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ISubObject »Parent
Declaration Syntax
C# Visual Basic Visual C++
Object Parent { get; set; }
Property Parent As Object
    Get
    Set
property Object^ Parent {
    Object^ get ();
    void set (Object^ value);
}


JoinStyle Enumeration

JoinStyle Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »JoinStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::JoinStyle")]
public enum JoinStyle
<WrapperAttribute("ZcDb::JoinStyle")> _
Public Enumeration JoinStyle
[WrapperAttribute(L"ZcDb::JoinStyle")]
public enum class JoinStyle
Members
Member | Description
StyleFlat |
StyleAngle |
StyleRound |
StyleNone |


LayerEvaluation Enumeration

LayerEvaluation Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerEvaluation
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum LayerEvaluation
<FlagsAttribute> _
Public Enumeration LayerEvaluation
[FlagsAttribute]
public enum class LayerEvaluation
Members
Member | Description
NoNewLayerEvaluation |
EvalNewXrefLayers |
EvalAllNewLayers |


LayerStateDeletedEventArgs Class

LayerStateDeletedEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateDeletedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LayerStateDeletedEventArgs : EventArgs
Public NotInheritable Class LayerStateDeletedEventArgs _
    Inherits EventArgs
public ref class LayerStateDeletedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | LayerStateDeletedEventArgs


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateDeletedEventArgs »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


LayerStateDeletedEventHandler Delegate

LayerStateDeletedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateDeletedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void LayerStateDeletedEventHandler(
    Object sender,
    LayerStateDeletedEventArgs e
)
Public Delegate Sub LayerStateDeletedEventHandler ( _
    sender As Object, _
    e As LayerStateDeletedEventArgs _
)
public delegate void LayerStateDeletedEventHandler(
    Object^ sender,
    LayerStateDeletedEventArgs^ e
)
Parameters
sender(Object)
e(LayerStateDeletedEventArgs)


LayerStateEventArgs Class

LayerStateEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LayerStateEventArgs : EventArgs
Public NotInheritable Class LayerStateEventArgs _
    Inherits EventArgs
public ref class LayerStateEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | LayerStateEventArgs


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateEventArgs »Id
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Id { get; }
Public ReadOnly Property Id As ObjectId
    Get
public:
property ObjectId Id {
    ObjectId get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateEventArgs »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


LayerStateEventHandler Delegate

LayerStateEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void LayerStateEventHandler(
    Object sender,
    LayerStateEventArgs e
)
Public Delegate Sub LayerStateEventHandler ( _
    sender As Object, _
    e As LayerStateEventArgs _
)
public delegate void LayerStateEventHandler(
    Object^ sender,
    LayerStateEventArgs^ e
)
Parameters
sender(Object)
e(LayerStateEventArgs)


LayerStateManager Class

LayerStateManager Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbLayerStateManager")]
public sealed class LayerStateManager : RXObject
<WrapperAttribute("ZcDbLayerStateManager")> _
Public NotInheritable Class LayerStateManager _
    Inherits RXObject
[WrapperAttribute(L"ZcDbLayerStateManager")]
public ref class LayerStateManager sealed : public RXObject
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayerStateManager(Database) |
 | AbortLayerStateDelete |
 | AbortLayerStateRename |
 | AbortLayerStateRestore |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareLayerStateToDb(String, ObjectId) |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteLayerState(String) |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | ExportLayerState(String, String) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLayerStateDescription(String) |
 | GetLayerStateLayers(String, Boolean) |
 | GetLayerStateMask(String) |
 | GetLayerStateNames(Boolean, Boolean) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | HasLayerState(String) |
 | ImportLayerState(String) |
 | ImportLayerStateFromDb(String, Database) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | LastRestoredLayerState |
 | LayerStateCompareFailed |
 | LayerStateCreated |
 | LayerStateDeleted |
 | LayerStateHasViewportData(String) |
 | LayerStateRenamed |
 | LayerStateRestored |
 | LayerStatesDictionaryId(Boolean) |
 | LayerStateToBeDeleted |
 | LayerStateToBeRenamed |
 | LayerStateToBeRestored |
 | m_pAbortLayerStateDelete |
 | m_pAbortLayerStateRename |
 | m_pAbortLayerStateRestore |
 | m_pLayerStateCompareFailed |
 | m_pLayerStateCreated |
 | m_pLayerStateDeleted |
 | m_pLayerStateRenamed |
 | m_pLayerStateRestored |
 | m_pLayerStateToBeDeleted |
 | m_pLayerStateToBeRenamed |
 | m_pLayerStateToBeRestored |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RenameLayerState(String, String) |
 | RestoreLayerState(String, ObjectId, Int32, LayerStateMasks) |
 | SaveLayerState(String, LayerStateMasks, ObjectId) |
 | SetLayerStateDescription(String, String) |
 | SetLayerStateMask(String, LayerStateMasks) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | LayerStateManager


LayerStateManager Constructor (database)

LayerStateManager Constructor (database)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStateManager(Database)
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateManager(
    Database database
)
Public Sub New ( _
    database As Database _
)
public:
LayerStateManager(
    Database^ database
)
Parameters
database(Database)


AbortLayerStateDelete Event

AbortLayerStateDelete Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »AbortLayerStateDelete
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateEventHandler AbortLayerStateDelete
Public Event AbortLayerStateDelete As LayerStateEventHandler
public:
 event LayerStateEventHandler^ AbortLayerStateDelete {
    void add (LayerStateEventHandler^ value);
    void remove (LayerStateEventHandler^ value);
}


AbortLayerStateRename Event

AbortLayerStateRename Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »AbortLayerStateRename
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateRenameEventHandler AbortLayerStateRename
Public Event AbortLayerStateRename As LayerStateRenameEventHandler
public:
 event LayerStateRenameEventHandler^ AbortLayerStateRename {
    void add (LayerStateRenameEventHandler^ value);
    void remove (LayerStateRenameEventHandler^ value);
}


AbortLayerStateRestore Event

AbortLayerStateRestore Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »AbortLayerStateRestore
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateEventHandler AbortLayerStateRestore
Public Event AbortLayerStateRestore As LayerStateEventHandler
public:
 event LayerStateEventHandler^ AbortLayerStateRestore {
    void add (LayerStateEventHandler^ value);
    void remove (LayerStateEventHandler^ value);
}


CompareLayerStateToDb Method (name, idVp)

CompareLayerStateToDb Method (name, idVp)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »CompareLayerStateToDb(String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool CompareLayerStateToDb(
    string name,
    ObjectId idVp
)
Public Function CompareLayerStateToDb ( _
    name As String, _
    idVp As ObjectId _
) As Boolean
public:
bool CompareLayerStateToDb(
    String^ name,
    ObjectId idVp
)
Parameters
name(String)
idVp(ObjectId)


DeleteLayerState Method (name)

DeleteLayerState Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »DeleteLayerState(String)
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteLayerState(
    string name
)
Public Sub DeleteLayerState ( _
    name As String _
)
public:
void DeleteLayerState(
    String^ name
)
Parameters
name(String)


ExportLayerState Method (nameToExport, fileName)

ExportLayerState Method (nameToExport, fileName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »ExportLayerState(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void ExportLayerState(
    string nameToExport,
    string fileName
)
Public Sub ExportLayerState ( _
    nameToExport As String, _
    fileName As String _
)
public:
void ExportLayerState(
    String^ nameToExport,
    String^ fileName
)
Parameters
nameToExport(String)
fileName(String)


GetLayerStateDescription Method (name)

GetLayerStateDescription Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »GetLayerStateDescription(String)
Declaration Syntax
C# Visual Basic Visual C++
public string GetLayerStateDescription(
    string name
)
Public Function GetLayerStateDescription ( _
    name As String _
) As String
public:
String^ GetLayerStateDescription(
    String^ name
)
Parameters
name(String)


GetLayerStateLayers Method (name, bInvert)

GetLayerStateLayers Method (name, bInvert)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »GetLayerStateLayers(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetLayerStateLayers(
    string name,
    bool bInvert
)
Public Function GetLayerStateLayers ( _
    name As String, _
    bInvert As Boolean _
) As ArrayList
public:
ArrayList^ GetLayerStateLayers(
    String^ name,
    bool bInvert
)
Parameters
name(String)
bInvert(Boolean)


GetLayerStateMask Method (name)

GetLayerStateMask Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »GetLayerStateMask(String)
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateMasks GetLayerStateMask(
    string name
)
Public Function GetLayerStateMask ( _
    name As String _
) As LayerStateMasks
public:
LayerStateMasks GetLayerStateMask(
    String^ name
)
Parameters
name(String)


GetLayerStateNames Method (bIncludeHidden, bIncludeXref)

GetLayerStateNames Method (bIncludeHidden, bIncludeXref)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »GetLayerStateNames(Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetLayerStateNames(
    bool bIncludeHidden,
    bool bIncludeXref
)
Public Function GetLayerStateNames ( _
    bIncludeHidden As Boolean, _
    bIncludeXref As Boolean _
) As ArrayList
public:
ArrayList^ GetLayerStateNames(
    bool bIncludeHidden,
    bool bIncludeXref
)
Parameters
bIncludeHidden(Boolean)
bIncludeXref(Boolean)


HasLayerState Method (name)

HasLayerState Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »HasLayerState(String)
Declaration Syntax
C# Visual Basic Visual C++
public bool HasLayerState(
    string name
)
Public Function HasLayerState ( _
    name As String _
) As Boolean
public:
bool HasLayerState(
    String^ name
)
Parameters
name(String)


ImportLayerState Method (fileName)

ImportLayerState Method (fileName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »ImportLayerState(String)
Declaration Syntax
C# Visual Basic Visual C++
public void ImportLayerState(
    string fileName
)
Public Sub ImportLayerState ( _
    fileName As String _
)
public:
void ImportLayerState(
    String^ fileName
)
Parameters
fileName(String)


ImportLayerStateFromDb Method (name, database)

ImportLayerStateFromDb Method (name, database)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »ImportLayerStateFromDb(String, Database)
Declaration Syntax
C# Visual Basic Visual C++
public void ImportLayerStateFromDb(
    string name,
    Database database
)
Public Sub ImportLayerStateFromDb ( _
    name As String, _
    database As Database _
)
public:
void ImportLayerStateFromDb(
    String^ name,
    Database^ database
)
Parameters
name(String)
database(Database)


LastRestoredLayerState Property

LastRestoredLayerState Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LastRestoredLayerState
Declaration Syntax
C# Visual Basic Visual C++
public string LastRestoredLayerState { get; }
Public ReadOnly Property LastRestoredLayerState As String
    Get
public:
property String^ LastRestoredLayerState {
    String^ get ();
}


LayerStateCompareFailed Event

LayerStateCompareFailed Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStateCompareFailed
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateEventHandler LayerStateCompareFailed
Public Event LayerStateCompareFailed As LayerStateEventHandler
public:
 event LayerStateEventHandler^ LayerStateCompareFailed {
    void add (LayerStateEventHandler^ value);
    void remove (LayerStateEventHandler^ value);
}


LayerStateCreated Event

LayerStateCreated Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStateCreated
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateEventHandler LayerStateCreated
Public Event LayerStateCreated As LayerStateEventHandler
public:
 event LayerStateEventHandler^ LayerStateCreated {
    void add (LayerStateEventHandler^ value);
    void remove (LayerStateEventHandler^ value);
}


LayerStateDeleted Event

LayerStateDeleted Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStateDeleted
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateDeletedEventHandler LayerStateDeleted
Public Event LayerStateDeleted As LayerStateDeletedEventHandler
public:
 event LayerStateDeletedEventHandler^ LayerStateDeleted {
    void add (LayerStateDeletedEventHandler^ value);
    void remove (LayerStateDeletedEventHandler^ value);
}


LayerStateHasViewportData Method (name)

LayerStateHasViewportData Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStateHasViewportData(String)
Declaration Syntax
C# Visual Basic Visual C++
public bool LayerStateHasViewportData(
    string name
)
Public Function LayerStateHasViewportData ( _
    name As String _
) As Boolean
public:
bool LayerStateHasViewportData(
    String^ name
)
Parameters
name(String)


LayerStateRenamed Event

LayerStateRenamed Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStateRenamed
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateRenameEventHandler LayerStateRenamed
Public Event LayerStateRenamed As LayerStateRenameEventHandler
public:
 event LayerStateRenameEventHandler^ LayerStateRenamed {
    void add (LayerStateRenameEventHandler^ value);
    void remove (LayerStateRenameEventHandler^ value);
}


LayerStateRestored Event

LayerStateRestored Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStateRestored
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateEventHandler LayerStateRestored
Public Event LayerStateRestored As LayerStateEventHandler
public:
 event LayerStateEventHandler^ LayerStateRestored {
    void add (LayerStateEventHandler^ value);
    void remove (LayerStateEventHandler^ value);
}


LayerStatesDictionaryId Method (createIfNotPresent)

LayerStatesDictionaryId Method (createIfNotPresent)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStatesDictionaryId(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LayerStatesDictionaryId(
    bool createIfNotPresent
)
Public Function LayerStatesDictionaryId ( _
    createIfNotPresent As Boolean _
) As ObjectId
public:
ObjectId LayerStatesDictionaryId(
    bool createIfNotPresent
)
Parameters
createIfNotPresent(Boolean)


LayerStateToBeDeleted Event

LayerStateToBeDeleted Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStateToBeDeleted
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateEventHandler LayerStateToBeDeleted
Public Event LayerStateToBeDeleted As LayerStateEventHandler
public:
 event LayerStateEventHandler^ LayerStateToBeDeleted {
    void add (LayerStateEventHandler^ value);
    void remove (LayerStateEventHandler^ value);
}


LayerStateToBeRenamed Event

LayerStateToBeRenamed Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStateToBeRenamed
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateRenameEventHandler LayerStateToBeRenamed
Public Event LayerStateToBeRenamed As LayerStateRenameEventHandler
public:
 event LayerStateRenameEventHandler^ LayerStateToBeRenamed {
    void add (LayerStateRenameEventHandler^ value);
    void remove (LayerStateRenameEventHandler^ value);
}


LayerStateToBeRestored Event

LayerStateToBeRestored Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »LayerStateToBeRestored
Declaration Syntax
C# Visual Basic Visual C++
public event LayerStateEventHandler LayerStateToBeRestored
Public Event LayerStateToBeRestored As LayerStateEventHandler
public:
 event LayerStateEventHandler^ LayerStateToBeRestored {
    void add (LayerStateEventHandler^ value);
    void remove (LayerStateEventHandler^ value);
}


m_pAbortLayerStateDelete Field

m_pAbortLayerStateDelete Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pAbortLayerStateDelete
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateEventHandler m_pAbortLayerStateDelete
Public m_pAbortLayerStateDelete As LayerStateEventHandler
public:
LayerStateEventHandler^ m_pAbortLayerStateDelete


m_pAbortLayerStateRename Field

m_pAbortLayerStateRename Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pAbortLayerStateRename
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateRenameEventHandler m_pAbortLayerStateRename
Public m_pAbortLayerStateRename As LayerStateRenameEventHandler
public:
LayerStateRenameEventHandler^ m_pAbortLayerStateRename


m_pAbortLayerStateRestore Field

m_pAbortLayerStateRestore Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pAbortLayerStateRestore
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateEventHandler m_pAbortLayerStateRestore
Public m_pAbortLayerStateRestore As LayerStateEventHandler
public:
LayerStateEventHandler^ m_pAbortLayerStateRestore


m_pLayerStateCompareFailed Field

m_pLayerStateCompareFailed Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pLayerStateCompareFailed
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateEventHandler m_pLayerStateCompareFailed
Public m_pLayerStateCompareFailed As LayerStateEventHandler
public:
LayerStateEventHandler^ m_pLayerStateCompareFailed


m_pLayerStateCreated Field

m_pLayerStateCreated Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pLayerStateCreated
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateEventHandler m_pLayerStateCreated
Public m_pLayerStateCreated As LayerStateEventHandler
public:
LayerStateEventHandler^ m_pLayerStateCreated


m_pLayerStateDeleted Field

m_pLayerStateDeleted Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pLayerStateDeleted
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateDeletedEventHandler m_pLayerStateDeleted
Public m_pLayerStateDeleted As LayerStateDeletedEventHandler
public:
LayerStateDeletedEventHandler^ m_pLayerStateDeleted


m_pLayerStateRenamed Field

m_pLayerStateRenamed Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pLayerStateRenamed
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateRenameEventHandler m_pLayerStateRenamed
Public m_pLayerStateRenamed As LayerStateRenameEventHandler
public:
LayerStateRenameEventHandler^ m_pLayerStateRenamed


m_pLayerStateRestored Field

m_pLayerStateRestored Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pLayerStateRestored
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateEventHandler m_pLayerStateRestored
Public m_pLayerStateRestored As LayerStateEventHandler
public:
LayerStateEventHandler^ m_pLayerStateRestored


m_pLayerStateToBeDeleted Field

m_pLayerStateToBeDeleted Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pLayerStateToBeDeleted
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateEventHandler m_pLayerStateToBeDeleted
Public m_pLayerStateToBeDeleted As LayerStateEventHandler
public:
LayerStateEventHandler^ m_pLayerStateToBeDeleted


m_pLayerStateToBeRenamed Field

m_pLayerStateToBeRenamed Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pLayerStateToBeRenamed
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateRenameEventHandler m_pLayerStateToBeRenamed
Public m_pLayerStateToBeRenamed As LayerStateRenameEventHandler
public:
LayerStateRenameEventHandler^ m_pLayerStateToBeRenamed


m_pLayerStateToBeRestored Field

m_pLayerStateToBeRestored Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »m_pLayerStateToBeRestored
Declaration Syntax
C# Visual Basic Visual C++
public LayerStateEventHandler m_pLayerStateToBeRestored
Public m_pLayerStateToBeRestored As LayerStateEventHandler
public:
LayerStateEventHandler^ m_pLayerStateToBeRestored


RenameLayerState Method (name, newName)

RenameLayerState Method (name, newName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »RenameLayerState(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void RenameLayerState(
    string name,
    string newName
)
Public Sub RenameLayerState ( _
    name As String, _
    newName As String _
)
public:
void RenameLayerState(
    String^ name,
    String^ newName
)
Parameters
name(String)
newName(String)


RestoreLayerState Method (name, id, undefinedLayerStatePolicy, clientMask)

RestoreLayerState Method (name, id, undefinedLayerStatePolicy, clientMask)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »RestoreLayerState(String, ObjectId, Int32, LayerStateMasks)
Declaration Syntax
C# Visual Basic Visual C++
public void RestoreLayerState(
    string name,
    ObjectId id,
    int undefinedLayerStatePolicy,
    LayerStateMasks clientMask
)
Public Sub RestoreLayerState ( _
    name As String, _
    id As ObjectId, _
    undefinedLayerStatePolicy As Integer, _
    clientMask As LayerStateMasks _
)
public:
void RestoreLayerState(
    String^ name,
    ObjectId id,
    int undefinedLayerStatePolicy,
    LayerStateMasks clientMask
)
Parameters
name(String)
id(ObjectId)
undefinedLayerStatePolicy(Int32)
clientMask(LayerStateMasks)


SaveLayerState Method (name, mask, id)

SaveLayerState Method (name, mask, id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »SaveLayerState(String, LayerStateMasks, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SaveLayerState(
    string name,
    LayerStateMasks mask,
    ObjectId id
)
Public Sub SaveLayerState ( _
    name As String, _
    mask As LayerStateMasks, _
    id As ObjectId _
)
public:
void SaveLayerState(
    String^ name,
    LayerStateMasks mask,
    ObjectId id
)
Parameters
name(String)
mask(LayerStateMasks)
id(ObjectId)


SetLayerStateDescription Method (name, description)

SetLayerStateDescription Method (name, description)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »SetLayerStateDescription(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayerStateDescription(
    string name,
    string description
)
Public Sub SetLayerStateDescription ( _
    name As String, _
    description As String _
)
public:
void SetLayerStateDescription(
    String^ name,
    String^ description
)
Parameters
name(String)
description(String)


SetLayerStateMask Method (name, mask)

SetLayerStateMask Method (name, mask)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »SetLayerStateMask(String, LayerStateMasks)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayerStateMask(
    string name,
    LayerStateMasks mask
)
Public Sub SetLayerStateMask ( _
    name As String, _
    mask As LayerStateMasks _
)
public:
void SetLayerStateMask(
    String^ name,
    LayerStateMasks mask
)
Parameters
name(String)
mask(LayerStateMasks)


LayerStateMasks Enumeration

LayerStateMasks Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateMasks
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
[WrapperAttribute("ZcDbLayerState::Mask")]
public enum LayerStateMasks
<FlagsAttribute> _
<WrapperAttribute("ZcDbLayerState::Mask")> _
Public Enumeration LayerStateMasks
[FlagsAttribute]
[WrapperAttribute(L"ZcDbLayerState::Mask")]
public enum class LayerStateMasks
Members
Member | Description
LastRestored |
CurrentViewport |
PlotStyle |
NewViewport |
Plot |
Locked |
On |
None |
LineWeight |
LineType |
Color |
Frozen |


LayerStateRenameEventArgs Class

LayerStateRenameEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateRenameEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LayerStateRenameEventArgs : EventArgs
Public NotInheritable Class LayerStateRenameEventArgs _
    Inherits EventArgs
public ref class LayerStateRenameEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | NewName |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | LayerStateRenameEventArgs


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateRenameEventArgs »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


NewName Property

NewName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateRenameEventArgs »NewName
Declaration Syntax
C# Visual Basic Visual C++
public string NewName { get; }
Public ReadOnly Property NewName As String
    Get
public:
property String^ NewName {
    String^ get ();
}


LayerStateRenameEventHandler Delegate

LayerStateRenameEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateRenameEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void LayerStateRenameEventHandler(
    Object sender,
    LayerStateRenameEventArgs e
)
Public Delegate Sub LayerStateRenameEventHandler ( _
    sender As Object, _
    e As LayerStateRenameEventArgs _
)
public delegate void LayerStateRenameEventHandler(
    Object^ sender,
    LayerStateRenameEventArgs^ e
)
Parameters
sender(Object)
e(LayerStateRenameEventArgs)


LayerTable Class

LayerTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbLayerTable")]
public sealed class LayerTable : SymbolTable
<WrapperAttribute("AcDbLayerTable")> _
Public NotInheritable Class LayerTable _
    Inherits SymbolTable
[WrapperAttribute(L"AcDbLayerTable")]
public ref class LayerTable sealed : public SymbolTable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) | (Inherited from SymbolTable.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GenerateUsageData()()()() |
 | GetEnumerator()()()() | (Overrides SymbolTable.GetEnumerator()()()().)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) | (Inherited from SymbolTable.)
 | Has(ObjectId) | (Inherited from SymbolTable.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from SymbolTable.)
 | IncludingErased | (Inherited from SymbolTable.)
 | IncludingHidden |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from SymbolTable.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SkippingReconciled |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | LayerTable


GenerateUsageData Method

GenerateUsageData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »GenerateUsageData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateUsageData()
Public Sub GenerateUsageData
public:
void GenerateUsageData()


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed SymbolTableEnumerator GetEnumerator()
Public Overrides NotOverridable Function GetEnumerator As SymbolTableEnumerator
public:
virtual SymbolTableEnumerator^ GetEnumerator() override sealed


IncludingHidden Property

IncludingHidden Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »IncludingHidden
Declaration Syntax
C# Visual Basic Visual C++
public LayerTable IncludingHidden { get; }
Public ReadOnly Property IncludingHidden As LayerTable
    Get
public:
property LayerTable^ IncludingHidden {
    LayerTable^ get ();
}


SkippingReconciled Property

SkippingReconciled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »SkippingReconciled
Declaration Syntax
C# Visual Basic Visual C++
public LayerTable SkippingReconciled { get; }
Public ReadOnly Property SkippingReconciled As LayerTable
    Get
public:
property LayerTable^ SkippingReconciled {
    LayerTable^ get ();
}


LayerTableRecord Class

LayerTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbLayerTableRecord")]
public class LayerTableRecord : SymbolTableRecord
<WrapperAttribute("AcDbLayerTableRecord")> _
Public Class LayerTableRecord _
    Inherits SymbolTableRecord
[WrapperAttribute(L"AcDbLayerTableRecord")]
public ref class LayerTableRecord : public SymbolTableRecord
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayerTableRecord()()()() |
 | LayerTableRecord(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Color |
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Description |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | EntityColor |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetViewportOverrides(ObjectId) |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasOverrides |
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | HasViewportOverrides(ObjectId) |
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent | (Inherited from SymbolTableRecord.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsFrozen |
 | IsHidden |
 | IsLocked |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsOff |
 | IsPersistent | (Inherited from DBObject.)
 | IsPlottable |
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsReconciled |
 | IsResolved | (Inherited from SymbolTableRecord.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsUsed |
 | IsWriteEnabled | (Inherited from DBObject.)
 | LinetypeObjectId |
 | LineWeight |
 | MaterialId |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from SymbolTableRecord.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName |
 | PlotStyleNameId |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveAllOverrides()()()() |
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Transparency |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | ViewportVisibilityDefault |
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | LayerTableRecord


LayerTableRecord Constructor

LayerTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »LayerTableRecord()()()()
Members
Icon | Member | Description
 | LayerTableRecord()()()() |
 | LayerTableRecord(IntPtr, Boolean) |


LayerTableRecord Constructor

LayerTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »LayerTableRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LayerTableRecord()
Public Sub New
public:
LayerTableRecord()


LayerTableRecord Constructor (unmanagedPointer, autoDelete)

LayerTableRecord Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »LayerTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LayerTableRecord(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
LayerTableRecord(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »Color
Declaration Syntax
C# Visual Basic Visual C++
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EntityColor Property

EntityColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »EntityColor
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor EntityColor { get; }
Public ReadOnly Property EntityColor As EntityColor
    Get
public:
property EntityColor EntityColor {
    EntityColor get ();
}


GetViewportOverrides Method (viewportId)

GetViewportOverrides Method (viewportId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »GetViewportOverrides(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public LayerViewportProperties GetViewportOverrides(
    ObjectId viewportId
)
Public Function GetViewportOverrides ( _
    viewportId As ObjectId _
) As LayerViewportProperties
public:
LayerViewportProperties^ GetViewportOverrides(
    ObjectId viewportId
)
Parameters
viewportId(ObjectId)


HasOverrides Property

HasOverrides Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »HasOverrides
Declaration Syntax
C# Visual Basic Visual C++
public bool HasOverrides { get; }
Public ReadOnly Property HasOverrides As Boolean
    Get
public:
property bool HasOverrides {
    bool get ();
}


HasViewportOverrides Method (viewportId)

HasViewportOverrides Method (viewportId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »HasViewportOverrides(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool HasViewportOverrides(
    ObjectId viewportId
)
Public Function HasViewportOverrides ( _
    viewportId As ObjectId _
) As Boolean
public:
bool HasViewportOverrides(
    ObjectId viewportId
)
Parameters
viewportId(ObjectId)


IsFrozen Property

IsFrozen Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »IsFrozen
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFrozen { get; set; }
Public Property IsFrozen As Boolean
    Get
    Set
public:
property bool IsFrozen {
    bool get ();
    void set (bool value);
}


IsHidden Property

IsHidden Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »IsHidden
Declaration Syntax
C# Visual Basic Visual C++
public bool IsHidden { get; set; }
Public Property IsHidden As Boolean
    Get
    Set
public:
property bool IsHidden {
    bool get ();
    void set (bool value);
}


IsLocked Property

IsLocked Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »IsLocked
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLocked { get; set; }
Public Property IsLocked As Boolean
    Get
    Set
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}


IsOff Property

IsOff Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »IsOff
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOff { get; set; }
Public Property IsOff As Boolean
    Get
    Set
public:
property bool IsOff {
    bool get ();
    void set (bool value);
}


IsPlottable Property

IsPlottable Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »IsPlottable
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPlottable { get; set; }
Public Property IsPlottable As Boolean
    Get
    Set
public:
property bool IsPlottable {
    bool get ();
    void set (bool value);
}


IsReconciled Property

IsReconciled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »IsReconciled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReconciled { get; set; }
Public Property IsReconciled As Boolean
    Get
    Set
public:
property bool IsReconciled {
    bool get ();
    void set (bool value);
}


IsUsed Property

IsUsed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »IsUsed
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUsed { get; }
Public ReadOnly Property IsUsed As Boolean
    Get
public:
property bool IsUsed {
    bool get ();
}


LinetypeObjectId Property

LinetypeObjectId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »LinetypeObjectId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LinetypeObjectId { get; set; }
Public Property LinetypeObjectId As ObjectId
    Get
    Set
public:
property ObjectId LinetypeObjectId {
    ObjectId get ();
    void set (ObjectId value);
}


LineWeight Property

LineWeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »LineWeight
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight LineWeight { get; set; }
Public Property LineWeight As LineWeight
    Get
    Set
public:
property LineWeight LineWeight {
    LineWeight get ();
    void set (LineWeight value);
}


MaterialId Property

MaterialId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »MaterialId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId MaterialId { get; set; }
Public Property MaterialId As ObjectId
    Get
    Set
public:
property ObjectId MaterialId {
    ObjectId get ();
    void set (ObjectId value);
}


PlotStyleName Property

PlotStyleName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »PlotStyleName
Declaration Syntax
C# Visual Basic Visual C++
public string PlotStyleName { get; set; }
Public Property PlotStyleName As String
    Get
    Set
public:
property String^ PlotStyleName {
    String^ get ();
    void set (String^ value);
}


PlotStyleNameId Property

PlotStyleNameId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »PlotStyleNameId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId PlotStyleNameId { get; set; }
Public Property PlotStyleNameId As ObjectId
    Get
    Set
public:
property ObjectId PlotStyleNameId {
    ObjectId get ();
    void set (ObjectId value);
}


RemoveAllOverrides Method

RemoveAllOverrides Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »RemoveAllOverrides()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAllOverrides()
Public Sub RemoveAllOverrides
public:
void RemoveAllOverrides()


Transparency Property

Transparency Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »Transparency
Declaration Syntax
C# Visual Basic Visual C++
public Transparency Transparency { get; set; }
Public Property Transparency As Transparency
    Get
    Set
public:
property Transparency Transparency {
    Transparency get ();
    void set (Transparency value);
}


ViewportVisibilityDefault Property

ViewportVisibilityDefault Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »ViewportVisibilityDefault
Declaration Syntax
C# Visual Basic Visual C++
public bool ViewportVisibilityDefault { get; set; }
Public Property ViewportVisibilityDefault As Boolean
    Get
    Set
public:
property bool ViewportVisibilityDefault {
    bool get ();
    void set (bool value);
}


LayerViewportProperties Class

LayerViewportProperties Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LayerViewportProperties
Public NotInheritable Class LayerViewportProperties
public ref class LayerViewportProperties sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Color |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsColorOverridden |
 | IsLinetypeOverridden |
 | IsLineWeightOverridden |
 | IsPlotStyleOverridden |
 | LinetypeObjectId |
 | LineWeight |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotStyleName |
 | PlotStyleNameId |
 | RemoveOverrides()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LayerViewportProperties


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties »Color
Declaration Syntax
C# Visual Basic Visual C++
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}


IsColorOverridden Property

IsColorOverridden Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties »IsColorOverridden
Declaration Syntax
C# Visual Basic Visual C++
public bool IsColorOverridden { get; set; }
Public Property IsColorOverridden As Boolean
    Get
    Set
public:
property bool IsColorOverridden {
    bool get ();
    void set (bool value);
}


IsLinetypeOverridden Property

IsLinetypeOverridden Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties »IsLinetypeOverridden
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLinetypeOverridden { get; set; }
Public Property IsLinetypeOverridden As Boolean
    Get
    Set
public:
property bool IsLinetypeOverridden {
    bool get ();
    void set (bool value);
}


IsLineWeightOverridden Property

IsLineWeightOverridden Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties »IsLineWeightOverridden
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLineWeightOverridden { get; set; }
Public Property IsLineWeightOverridden As Boolean
    Get
    Set
public:
property bool IsLineWeightOverridden {
    bool get ();
    void set (bool value);
}


IsPlotStyleOverridden Property

IsPlotStyleOverridden Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties »IsPlotStyleOverridden
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPlotStyleOverridden { get; set; }
Public Property IsPlotStyleOverridden As Boolean
    Get
    Set
public:
property bool IsPlotStyleOverridden {
    bool get ();
    void set (bool value);
}


LinetypeObjectId Property

LinetypeObjectId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties »LinetypeObjectId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LinetypeObjectId { get; set; }
Public Property LinetypeObjectId As ObjectId
    Get
    Set
public:
property ObjectId LinetypeObjectId {
    ObjectId get ();
    void set (ObjectId value);
}


LineWeight Property

LineWeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties »LineWeight
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight LineWeight { get; set; }
Public Property LineWeight As LineWeight
    Get
    Set
public:
property LineWeight LineWeight {
    LineWeight get ();
    void set (LineWeight value);
}


PlotStyleName Property

PlotStyleName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties »PlotStyleName
Declaration Syntax
C# Visual Basic Visual C++
public string PlotStyleName { get; set; }
Public Property PlotStyleName As String
    Get
    Set
public:
property String^ PlotStyleName {
    String^ get ();
    void set (String^ value);
}


PlotStyleNameId Property

PlotStyleNameId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties »PlotStyleNameId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId PlotStyleNameId { get; set; }
Public Property PlotStyleNameId As ObjectId
    Get
    Set
public:
property ObjectId PlotStyleNameId {
    ObjectId get ();
    void set (ObjectId value);
}


RemoveOverrides Method

RemoveOverrides Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerViewportProperties »RemoveOverrides()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveOverrides()
Public Sub RemoveOverrides
public:
void RemoveOverrides()


Layout Class

Layout Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbLayout")]
public class Layout : PlotSettings
<WrapperAttribute("AcDbLayout")> _
Public Class Layout _
    Inherits PlotSettings
[WrapperAttribute(L"AcDbLayout")]
public ref class Layout : public PlotSettings
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Layout()()()() |
 | Layout(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddToLayoutDictionary(Database, ObjectId) |
 | AddToPlotSettingsDictionary(Database) | (Inherited from PlotSettings.)
 | AnnoAllVisible |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockTableRecordId |
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CanonicalMediaName | (Inherited from PlotSettings.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CurrentStyleSheet | (Inherited from PlotSettings.)
 | CurrentViewportId |
 | CustomPrintScale | (Inherited from PlotSettings.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DrawViewportsFirst | (Inherited from PlotSettings.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Extents |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetViewports()()()() |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | Initialize()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | LayoutName |
 | Limits |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | ModelType | (Inherited from PlotSettings.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotAsRaster | (Inherited from PlotSettings.)
 | PlotCentered | (Inherited from PlotSettings.)
 | PlotConfigurationName | (Inherited from PlotSettings.)
 | PlotHidden | (Inherited from PlotSettings.)
 | PlotOrigin | (Inherited from PlotSettings.)
 | PlotPaperMargins | (Inherited from PlotSettings.)
 | PlotPaperSize | (Inherited from PlotSettings.)
 | PlotPaperUnits | (Inherited from PlotSettings.)
 | PlotPlotStyles | (Inherited from PlotSettings.)
 | PlotRotation | (Inherited from PlotSettings.)
 | PlotSettingsName | (Inherited from PlotSettings.)
 | PlotType | (Inherited from PlotSettings.)
 | PlotViewName | (Inherited from PlotSettings.)
 | PlotViewportBorders | (Inherited from PlotSettings.)
 | PlotWindowArea | (Inherited from PlotSettings.)
 | PlotWireframe | (Inherited from PlotSettings.)
 | PrintLineweights | (Inherited from PlotSettings.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ScaleLineweights | (Inherited from PlotSettings.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetShadePlot(PlotSettingsShadePlotType, ObjectId) | (Inherited from PlotSettings.)
 | ShadePlot | (Inherited from PlotSettings.)
 | ShadePlotCustomDpi | (Inherited from PlotSettings.)
 | ShadePlotId | (Inherited from PlotSettings.)
 | ShadePlotResLevel | (Inherited from PlotSettings.)
 | ShowPlotStyles | (Inherited from PlotSettings.)
 | StdScale | (Inherited from PlotSettings.)
 | StdScaleType | (Inherited from PlotSettings.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TabOrder |
 | TabSelected |
 | Thumbnail |
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UseStandardScale | (Inherited from PlotSettings.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | PlotSettings
 |  |  |  |  |  |  | Layout


Layout Constructor

Layout Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »Layout()()()()
Members
Icon | Member | Description
 | Layout()()()() |
 | Layout(IntPtr, Boolean) |


Layout Constructor

Layout Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »Layout()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Layout()
Public Sub New
public:
Layout()


Layout Constructor (unmanagedPointer, autoDelete)

Layout Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »Layout(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Layout(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Layout(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AddToLayoutDictionary Method (toWhichDatabase, blockTableRecordId)

AddToLayoutDictionary Method (toWhichDatabase, blockTableRecordId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »AddToLayoutDictionary(Database, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddToLayoutDictionary(
    Database toWhichDatabase,
    ObjectId blockTableRecordId
)
Public Overridable Sub AddToLayoutDictionary ( _
    toWhichDatabase As Database, _
    blockTableRecordId As ObjectId _
)
public:
virtual void AddToLayoutDictionary(
    Database^ toWhichDatabase,
    ObjectId blockTableRecordId
)
Parameters
toWhichDatabase(Database)
blockTableRecordId(ObjectId)


AnnoAllVisible Property

AnnoAllVisible Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »AnnoAllVisible
Declaration Syntax
C# Visual Basic Visual C++
public bool AnnoAllVisible { get; set; }
Public Property AnnoAllVisible As Boolean
    Get
    Set
public:
property bool AnnoAllVisible {
    bool get ();
    void set (bool value);
}


BlockTableRecordId Property

BlockTableRecordId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »BlockTableRecordId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockTableRecordId { get; set; }
Public Property BlockTableRecordId As ObjectId
    Get
    Set
public:
property ObjectId BlockTableRecordId {
    ObjectId get ();
    void set (ObjectId value);
}


CurrentViewportId Property

CurrentViewportId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »CurrentViewportId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId CurrentViewportId { get; }
Public ReadOnly Property CurrentViewportId As ObjectId
    Get
public:
property ObjectId CurrentViewportId {
    ObjectId get ();
}


Extents Property

Extents Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »Extents
Declaration Syntax
C# Visual Basic Visual C++
public Extents3d Extents { get; }
Public ReadOnly Property Extents As Extents3d
    Get
public:
property Extents3d Extents {
    Extents3d get ();
}


GetViewports Method

GetViewports Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »GetViewports()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetViewports()
Public Function GetViewports As ObjectIdCollection
public:
ObjectIdCollection^ GetViewports()


Initialize Method

Initialize Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »Initialize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Initialize()
Public Function Initialize As ObjectId
public:
ObjectId Initialize()


LayoutName Property

LayoutName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »LayoutName
Declaration Syntax
C# Visual Basic Visual C++
public string LayoutName { get; set; }
Public Property LayoutName As String
    Get
    Set
public:
property String^ LayoutName {
    String^ get ();
    void set (String^ value);
}


Limits Property

Limits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »Limits
Declaration Syntax
C# Visual Basic Visual C++
public Extents2d Limits { get; }
Public ReadOnly Property Limits As Extents2d
    Get
public:
property Extents2d Limits {
    Extents2d get ();
}


TabOrder Property

TabOrder Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »TabOrder
Declaration Syntax
C# Visual Basic Visual C++
public int TabOrder { get; set; }
Public Property TabOrder As Integer
    Get
    Set
public:
property int TabOrder {
    int get ();
    void set (int value);
}


TabSelected Property

TabSelected Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »TabSelected
Declaration Syntax
C# Visual Basic Visual C++
public bool TabSelected { get; set; }
Public Property TabSelected As Boolean
    Get
    Set
public:
property bool TabSelected {
    bool get ();
    void set (bool value);
}


Thumbnail Property

Thumbnail Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »Thumbnail
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap Thumbnail { get; set; }
Public Property Thumbnail As Bitmap
    Get
    Set
public:
property Bitmap^ Thumbnail {
    Bitmap^ get ();
    void set (Bitmap^ value);
}


LayoutCopiedEventArgs Class

LayoutCopiedEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutCopiedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LayoutCopiedEventArgs : EventArgs
Public NotInheritable Class LayoutCopiedEventArgs _
    Inherits EventArgs
public ref class LayoutCopiedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | NewId |
 | NewName |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | LayoutCopiedEventArgs


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutCopiedEventArgs »Id
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Id { get; }
Public ReadOnly Property Id As ObjectId
    Get
public:
property ObjectId Id {
    ObjectId get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutCopiedEventArgs »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


NewId Property

NewId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutCopiedEventArgs »NewId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId NewId { get; }
Public ReadOnly Property NewId As ObjectId
    Get
public:
property ObjectId NewId {
    ObjectId get ();
}


NewName Property

NewName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutCopiedEventArgs »NewName
Declaration Syntax
C# Visual Basic Visual C++
public string NewName { get; }
Public ReadOnly Property NewName As String
    Get
public:
property String^ NewName {
    String^ get ();
}


LayoutCopiedEventHandler Delegate

LayoutCopiedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutCopiedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void LayoutCopiedEventHandler(
    Object sender,
    LayoutCopiedEventArgs e
)
Public Delegate Sub LayoutCopiedEventHandler ( _
    sender As Object, _
    e As LayoutCopiedEventArgs _
)
public delegate void LayoutCopiedEventHandler(
    Object^ sender,
    LayoutCopiedEventArgs^ e
)
Parameters
sender(Object)
e(LayoutCopiedEventArgs)


LayoutEventArgs Class

LayoutEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LayoutEventArgs : EventArgs
Public NotInheritable Class LayoutEventArgs _
    Inherits EventArgs
public ref class LayoutEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | LayoutEventArgs


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutEventArgs »Id
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Id { get; }
Public ReadOnly Property Id As ObjectId
    Get
public:
property ObjectId Id {
    ObjectId get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutEventArgs »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


LayoutEventHandler Delegate

LayoutEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void LayoutEventHandler(
    Object sender,
    LayoutEventArgs e
)
Public Delegate Sub LayoutEventHandler ( _
    sender As Object, _
    e As LayoutEventArgs _
)
public delegate void LayoutEventHandler(
    Object^ sender,
    LayoutEventArgs^ e
)
Parameters
sender(Object)
e(LayoutEventArgs)


LayoutManager Class

LayoutManager Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbLayoutManager")]
public class LayoutManager : RXObject
<WrapperAttribute("ZcDbLayoutManager")> _
Public Class LayoutManager _
    Inherits RXObject
[WrapperAttribute(L"ZcDbLayoutManager")]
public ref class LayoutManager : public RXObject
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayoutManager(IntPtr, Database) |
 | AbortLayoutCopied |
 | AbortLayoutRemoved |
 | AbortLayoutRename |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneLayout(String, String, Int32) |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyLayout(String, String) |
 | CreateLayout(String) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Current |
 | CurrentLayout |
 | DeleteLayout(String) |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLayoutId(String) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNonRectangularViewportIdFromClipId(ObjectId) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | LayoutCopied |
 | LayoutCount |
 | LayoutCreated |
 | LayoutRemoved |
 | LayoutRenamed |
 | LayoutsReordered |
 | LayoutSwitched |
 | LayoutToBeCopied |
 | LayoutToBeRemoved |
 | LayoutToBeRenamed |
 | m_pAbortLayoutCopied |
 | m_pAbortLayoutRemoved |
 | m_pAbortLayoutRename |
 | m_pLayoutCopied |
 | m_pLayoutCreated |
 | m_pLayoutRemoved |
 | m_pLayoutRenamed |
 | m_pLayoutsReordered |
 | m_pLayoutSwitched |
 | m_pLayoutToBeCopied |
 | m_pLayoutToBeRemoved |
 | m_pLayoutToBeRenamed |
 | m_pPlotStyleTableChanged |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotStyleTableChanged |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RenameLayout(String, String) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | LayoutManager


LayoutManager Constructor (pImpObj, db)

LayoutManager Constructor (pImpObj, db)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutManager(IntPtr, Database)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LayoutManager(
    IntPtr pImpObj,
    Database db
)
Protected Friend Sub New ( _
    pImpObj As IntPtr, _
    db As Database _
)
protected public:
LayoutManager(
    IntPtr pImpObj,
    Database^ db
)
Parameters
pImpObj(IntPtr)
db(Database)


AbortLayoutCopied Event

AbortLayoutCopied Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »AbortLayoutCopied
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutEventHandler AbortLayoutCopied
Public Event AbortLayoutCopied As LayoutEventHandler
public:
 event LayoutEventHandler^ AbortLayoutCopied {
    void add (LayoutEventHandler^ value);
    void remove (LayoutEventHandler^ value);
}


AbortLayoutRemoved Event

AbortLayoutRemoved Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »AbortLayoutRemoved
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutEventHandler AbortLayoutRemoved
Public Event AbortLayoutRemoved As LayoutEventHandler
public:
 event LayoutEventHandler^ AbortLayoutRemoved {
    void add (LayoutEventHandler^ value);
    void remove (LayoutEventHandler^ value);
}


AbortLayoutRename Event

AbortLayoutRename Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »AbortLayoutRename
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutRenamedEventHandler AbortLayoutRename
Public Event AbortLayoutRename As LayoutRenamedEventHandler
public:
 event LayoutRenamedEventHandler^ AbortLayoutRename {
    void add (LayoutRenamedEventHandler^ value);
    void remove (LayoutRenamedEventHandler^ value);
}


CloneLayout Method (copyName, newName, newTabOrder)

CloneLayout Method (copyName, newName, newTabOrder)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »CloneLayout(String, String, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CloneLayout(
    string copyName,
    string newName,
    int newTabOrder
)
Public Sub CloneLayout ( _
    copyName As String, _
    newName As String, _
    newTabOrder As Integer _
)
public:
void CloneLayout(
    String^ copyName,
    String^ newName,
    int newTabOrder
)
Parameters
copyName(String)
newName(String)
newTabOrder(Int32)


CopyLayout Method (copyName, newName)

CopyLayout Method (copyName, newName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »CopyLayout(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyLayout(
    string copyName,
    string newName
)
Public Sub CopyLayout ( _
    copyName As String, _
    newName As String _
)
public:
void CopyLayout(
    String^ copyName,
    String^ newName
)
Parameters
copyName(String)
newName(String)


CreateLayout Method (newName)

CreateLayout Method (newName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »CreateLayout(String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId CreateLayout(
    string newName
)
Public Function CreateLayout ( _
    newName As String _
) As ObjectId
public:
ObjectId CreateLayout(
    String^ newName
)
Parameters
newName(String)


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »Current
Declaration Syntax
C# Visual Basic Visual C++
public static LayoutManager Current { get; }
Public Shared ReadOnly Property Current As LayoutManager
    Get
public:
static property LayoutManager^ Current {
    LayoutManager^ get ();
}


CurrentLayout Property

CurrentLayout Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »CurrentLayout
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentLayout { get; set; }
Public Property CurrentLayout As String
    Get
    Set
public:
property String^ CurrentLayout {
    String^ get ();
    void set (String^ value);
}


DeleteLayout Method (deleteName)

DeleteLayout Method (deleteName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »DeleteLayout(String)
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteLayout(
    string deleteName
)
Public Sub DeleteLayout ( _
    deleteName As String _
)
public:
void DeleteLayout(
    String^ deleteName
)
Parameters
deleteName(String)


GetLayoutId Method (name)

GetLayoutId Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »GetLayoutId(String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetLayoutId(
    string name
)
Public Function GetLayoutId ( _
    name As String _
) As ObjectId
public:
ObjectId GetLayoutId(
    String^ name
)
Parameters
name(String)


GetNonRectangularViewportIdFromClipId Method (clipId)

GetNonRectangularViewportIdFromClipId Method (clipId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »GetNonRectangularViewportIdFromClipId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetNonRectangularViewportIdFromClipId(
    ObjectId clipId
)
Public Function GetNonRectangularViewportIdFromClipId ( _
    clipId As ObjectId _
) As ObjectId
public:
ObjectId GetNonRectangularViewportIdFromClipId(
    ObjectId clipId
)
Parameters
clipId(ObjectId)


LayoutCopied Event

LayoutCopied Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutCopied
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutCopiedEventHandler LayoutCopied
Public Event LayoutCopied As LayoutCopiedEventHandler
public:
 event LayoutCopiedEventHandler^ LayoutCopied {
    void add (LayoutCopiedEventHandler^ value);
    void remove (LayoutCopiedEventHandler^ value);
}


LayoutCount Property

LayoutCount Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutCount
Declaration Syntax
C# Visual Basic Visual C++
public int LayoutCount { get; }
Public ReadOnly Property LayoutCount As Integer
    Get
public:
property int LayoutCount {
    int get ();
}


LayoutCreated Event

LayoutCreated Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutCreated
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutEventHandler LayoutCreated
Public Event LayoutCreated As LayoutEventHandler
public:
 event LayoutEventHandler^ LayoutCreated {
    void add (LayoutEventHandler^ value);
    void remove (LayoutEventHandler^ value);
}


LayoutRemoved Event

LayoutRemoved Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutRemoved
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutEventHandler LayoutRemoved
Public Event LayoutRemoved As LayoutEventHandler
public:
 event LayoutEventHandler^ LayoutRemoved {
    void add (LayoutEventHandler^ value);
    void remove (LayoutEventHandler^ value);
}


LayoutRenamed Event

LayoutRenamed Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutRenamed
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutRenamedEventHandler LayoutRenamed
Public Event LayoutRenamed As LayoutRenamedEventHandler
public:
 event LayoutRenamedEventHandler^ LayoutRenamed {
    void add (LayoutRenamedEventHandler^ value);
    void remove (LayoutRenamedEventHandler^ value);
}


LayoutsReordered Event

LayoutsReordered Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutsReordered
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler LayoutsReordered
Public Event LayoutsReordered As EventHandler
public:
 event EventHandler^ LayoutsReordered {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


LayoutSwitched Event

LayoutSwitched Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutSwitched
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutEventHandler LayoutSwitched
Public Event LayoutSwitched As LayoutEventHandler
public:
 event LayoutEventHandler^ LayoutSwitched {
    void add (LayoutEventHandler^ value);
    void remove (LayoutEventHandler^ value);
}


LayoutToBeCopied Event

LayoutToBeCopied Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutToBeCopied
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutEventHandler LayoutToBeCopied
Public Event LayoutToBeCopied As LayoutEventHandler
public:
 event LayoutEventHandler^ LayoutToBeCopied {
    void add (LayoutEventHandler^ value);
    void remove (LayoutEventHandler^ value);
}


LayoutToBeRemoved Event

LayoutToBeRemoved Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutToBeRemoved
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutEventHandler LayoutToBeRemoved
Public Event LayoutToBeRemoved As LayoutEventHandler
public:
 event LayoutEventHandler^ LayoutToBeRemoved {
    void add (LayoutEventHandler^ value);
    void remove (LayoutEventHandler^ value);
}


LayoutToBeRenamed Event

LayoutToBeRenamed Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »LayoutToBeRenamed
Declaration Syntax
C# Visual Basic Visual C++
public event LayoutRenamedEventHandler LayoutToBeRenamed
Public Event LayoutToBeRenamed As LayoutRenamedEventHandler
public:
 event LayoutRenamedEventHandler^ LayoutToBeRenamed {
    void add (LayoutRenamedEventHandler^ value);
    void remove (LayoutRenamedEventHandler^ value);
}


m_pAbortLayoutCopied Field

m_pAbortLayoutCopied Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pAbortLayoutCopied
Declaration Syntax
C# Visual Basic Visual C++
public LayoutEventHandler m_pAbortLayoutCopied
Public m_pAbortLayoutCopied As LayoutEventHandler
public:
LayoutEventHandler^ m_pAbortLayoutCopied


m_pAbortLayoutRemoved Field

m_pAbortLayoutRemoved Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pAbortLayoutRemoved
Declaration Syntax
C# Visual Basic Visual C++
public LayoutEventHandler m_pAbortLayoutRemoved
Public m_pAbortLayoutRemoved As LayoutEventHandler
public:
LayoutEventHandler^ m_pAbortLayoutRemoved


m_pAbortLayoutRename Field

m_pAbortLayoutRename Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pAbortLayoutRename
Declaration Syntax
C# Visual Basic Visual C++
public LayoutRenamedEventHandler m_pAbortLayoutRename
Public m_pAbortLayoutRename As LayoutRenamedEventHandler
public:
LayoutRenamedEventHandler^ m_pAbortLayoutRename


m_pLayoutCopied Field

m_pLayoutCopied Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pLayoutCopied
Declaration Syntax
C# Visual Basic Visual C++
public LayoutCopiedEventHandler m_pLayoutCopied
Public m_pLayoutCopied As LayoutCopiedEventHandler
public:
LayoutCopiedEventHandler^ m_pLayoutCopied


m_pLayoutCreated Field

m_pLayoutCreated Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pLayoutCreated
Declaration Syntax
C# Visual Basic Visual C++
public LayoutEventHandler m_pLayoutCreated
Public m_pLayoutCreated As LayoutEventHandler
public:
LayoutEventHandler^ m_pLayoutCreated


m_pLayoutRemoved Field

m_pLayoutRemoved Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pLayoutRemoved
Declaration Syntax
C# Visual Basic Visual C++
public LayoutEventHandler m_pLayoutRemoved
Public m_pLayoutRemoved As LayoutEventHandler
public:
LayoutEventHandler^ m_pLayoutRemoved


m_pLayoutRenamed Field

m_pLayoutRenamed Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pLayoutRenamed
Declaration Syntax
C# Visual Basic Visual C++
public LayoutRenamedEventHandler m_pLayoutRenamed
Public m_pLayoutRenamed As LayoutRenamedEventHandler
public:
LayoutRenamedEventHandler^ m_pLayoutRenamed


m_pLayoutsReordered Field

m_pLayoutsReordered Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pLayoutsReordered
Declaration Syntax
C# Visual Basic Visual C++
public EventHandler m_pLayoutsReordered
Public m_pLayoutsReordered As EventHandler
public:
EventHandler^ m_pLayoutsReordered


m_pLayoutSwitched Field

m_pLayoutSwitched Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pLayoutSwitched
Declaration Syntax
C# Visual Basic Visual C++
public LayoutEventHandler m_pLayoutSwitched
Public m_pLayoutSwitched As LayoutEventHandler
public:
LayoutEventHandler^ m_pLayoutSwitched


m_pLayoutToBeCopied Field

m_pLayoutToBeCopied Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pLayoutToBeCopied
Declaration Syntax
C# Visual Basic Visual C++
public LayoutEventHandler m_pLayoutToBeCopied
Public m_pLayoutToBeCopied As LayoutEventHandler
public:
LayoutEventHandler^ m_pLayoutToBeCopied


m_pLayoutToBeRemoved Field

m_pLayoutToBeRemoved Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pLayoutToBeRemoved
Declaration Syntax
C# Visual Basic Visual C++
public LayoutEventHandler m_pLayoutToBeRemoved
Public m_pLayoutToBeRemoved As LayoutEventHandler
public:
LayoutEventHandler^ m_pLayoutToBeRemoved


m_pLayoutToBeRenamed Field

m_pLayoutToBeRenamed Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pLayoutToBeRenamed
Declaration Syntax
C# Visual Basic Visual C++
public LayoutRenamedEventHandler m_pLayoutToBeRenamed
Public m_pLayoutToBeRenamed As LayoutRenamedEventHandler
public:
LayoutRenamedEventHandler^ m_pLayoutToBeRenamed


m_pPlotStyleTableChanged Field

m_pPlotStyleTableChanged Field
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »m_pPlotStyleTableChanged
Declaration Syntax
C# Visual Basic Visual C++
public PlotStyleTableChangedEventHandler m_pPlotStyleTableChanged
Public m_pPlotStyleTableChanged As PlotStyleTableChangedEventHandler
public:
PlotStyleTableChangedEventHandler^ m_pPlotStyleTableChanged


PlotStyleTableChanged Event

PlotStyleTableChanged Event
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »PlotStyleTableChanged
Declaration Syntax
C# Visual Basic Visual C++
public event PlotStyleTableChangedEventHandler PlotStyleTableChanged
Public Event PlotStyleTableChanged As PlotStyleTableChangedEventHandler
public:
 event PlotStyleTableChangedEventHandler^ PlotStyleTableChanged {
    void add (PlotStyleTableChangedEventHandler^ value);
    void remove (PlotStyleTableChangedEventHandler^ value);
}


RenameLayout Method (oldName, newName)

RenameLayout Method (oldName, newName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »RenameLayout(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void RenameLayout(
    string oldName,
    string newName
)
Public Sub RenameLayout ( _
    oldName As String, _
    newName As String _
)
public:
void RenameLayout(
    String^ oldName,
    String^ newName
)
Parameters
oldName(String)
newName(String)


LayoutRenamedEventArgs Class

LayoutRenamedEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutRenamedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LayoutRenamedEventArgs : EventArgs
Public NotInheritable Class LayoutRenamedEventArgs _
    Inherits EventArgs
public ref class LayoutRenamedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | NewName |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | LayoutRenamedEventArgs


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutRenamedEventArgs »Id
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Id { get; }
Public ReadOnly Property Id As ObjectId
    Get
public:
property ObjectId Id {
    ObjectId get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutRenamedEventArgs »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


NewName Property

NewName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutRenamedEventArgs »NewName
Declaration Syntax
C# Visual Basic Visual C++
public string NewName { get; }
Public ReadOnly Property NewName As String
    Get
public:
property String^ NewName {
    String^ get ();
}


LayoutRenamedEventHandler Delegate

LayoutRenamedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutRenamedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void LayoutRenamedEventHandler(
    Object sender,
    LayoutRenamedEventArgs e
)
Public Delegate Sub LayoutRenamedEventHandler ( _
    sender As Object, _
    e As LayoutRenamedEventArgs _
)
public delegate void LayoutRenamedEventHandler(
    Object^ sender,
    LayoutRenamedEventArgs^ e
)
Parameters
sender(Object)
e(LayoutRenamedEventArgs)


Leader Class

Leader Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbLeader")]
public class Leader : Curve
<WrapperAttribute("AcDbLeader")> _
Public Class Leader _
    Inherits Curve
[WrapperAttribute(L"AcDbLeader")]
public ref class Leader : public Curve
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Leader()()()() |
 | Leader(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AnnoHeight |
 | Annotation |
 | AnnotationOffset |
 | Annotative | (Inherited from DBObject.)
 | AnnoType |
 | AnnoWidth |
 | AppendVertex(Point3d) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed | (Inherited from Curve.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimasz |
 | Dimclrd |
 | DimensionStyle |
 | DimensionStyleName |
 | Dimgap |
 | Dimldrblk |
 | Dimlwd |
 | Dimsah |
 | Dimscale |
 | DimstyleData |
 | Dimtad |
 | Dimtxsty | Obsolete.
 | Dimtxt |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | EvaluateLeader()()()() |
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FirstVertex |
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetDimstyleData()()()() |
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasArrowHead |
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasHookLine |
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsSplined |
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | LastVertex |
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | NumVertices |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemoveLastVertex()()()() |
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) |
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPlane(Plane) |
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetVertexAt(Int32, Point3d) |
 | Spline | (Inherited from Curve.)
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Inherited from Curve.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextStyleId |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VertexAt(Int32) |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Leader


Leader Constructor

Leader Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Leader()()()()
Members
Icon | Member | Description
 | Leader()()()() |
 | Leader(IntPtr, Boolean) |


Leader Constructor

Leader Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Leader()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Leader()
Public Sub New
public:
Leader()


Leader Constructor (unmanagedObjPtr, autoDelete)

Leader Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Leader(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Leader(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Leader(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AnnoHeight Property

AnnoHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »AnnoHeight
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double AnnoHeight { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property AnnoHeight As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double AnnoHeight {
    double get ();
}


Annotation Property

Annotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Annotation
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Annotation { get; set; }
Public Overridable Property Annotation As ObjectId
    Get
    Set
public:
virtual property ObjectId Annotation {
    ObjectId get ();
    void set (ObjectId value);
}


AnnotationOffset Property

AnnotationOffset Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »AnnotationOffset
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d AnnotationOffset { get; set; }
Public Overridable Property AnnotationOffset As Vector3d
    Get
    Set
public:
virtual property Vector3d AnnotationOffset {
    Vector3d get ();
    void set (Vector3d value);
}


AnnoType Property

AnnoType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »AnnoType
Declaration Syntax
C# Visual Basic Visual C++
public AnnotationType AnnoType { get; }
Public ReadOnly Property AnnoType As AnnotationType
    Get
public:
property AnnotationType AnnoType {
    AnnotationType get ();
}


AnnoWidth Property

AnnoWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »AnnoWidth
Declaration Syntax
C# Visual Basic Visual C++
public double AnnoWidth { get; }
Public ReadOnly Property AnnoWidth As Double
    Get
public:
property double AnnoWidth {
    double get ();
}


AppendVertex Method (pointToAdd)

AppendVertex Method (pointToAdd)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »AppendVertex(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AppendVertex(
    Point3d pointToAdd
)
Public Overridable Function AppendVertex ( _
    pointToAdd As Point3d _
) As Boolean
public:
virtual bool AppendVertex(
    Point3d pointToAdd
)
Parameters
pointToAdd(Point3d)


Dimasz Property

Dimasz Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dimasz
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimasz { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimasz As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimasz {
    double get ();
    void set (double value);
}


Dimclrd Property

Dimclrd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dimclrd
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color Dimclrd { get; set; }
Public Overridable Property Dimclrd As Color
    Get
    Set
public:
virtual property Color^ Dimclrd {
    Color^ get ();
    void set (Color^ value);
}


DimensionStyle Property

DimensionStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »DimensionStyle
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId DimensionStyle { get; set; }
Public Overridable Property DimensionStyle As ObjectId
    Get
    Set
public:
virtual property ObjectId DimensionStyle {
    ObjectId get ();
    void set (ObjectId value);
}


DimensionStyleName Property

DimensionStyleName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »DimensionStyleName
Declaration Syntax
C# Visual Basic Visual C++
public string DimensionStyleName { get; set; }
Public Property DimensionStyleName As String
    Get
    Set
public:
property String^ DimensionStyleName {
    String^ get ();
    void set (String^ value);
}


Dimgap Property

Dimgap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dimgap
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimgap { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimgap As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimgap {
    double get ();
    void set (double value);
}


Dimldrblk Property

Dimldrblk Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dimldrblk
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Dimldrblk { get; set; }
Public Overridable Property Dimldrblk As ObjectId
    Get
    Set
public:
virtual property ObjectId Dimldrblk {
    ObjectId get ();
    void set (ObjectId value);
}


Dimlwd Property

Dimlwd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dimlwd
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight Dimlwd { get; set; }
Public Overridable Property Dimlwd As LineWeight
    Get
    Set
public:
virtual property LineWeight Dimlwd {
    LineWeight get ();
    void set (LineWeight value);
}


Dimsah Property

Dimsah Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dimsah
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Dimsah { get; set; }
Public Overridable Property Dimsah As Boolean
    Get
    Set
public:
virtual property bool Dimsah {
    bool get ();
    void set (bool value);
}


Dimscale Property

Dimscale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dimscale
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public virtual double Dimscale { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Overridable Property Dimscale As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
virtual property double Dimscale {
    double get ();
    void set (double value);
}


DimstyleData Property

DimstyleData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »DimstyleData
Declaration Syntax
C# Visual Basic Visual C++
public DimStyleTableRecord DimstyleData { get; set; }
Public Property DimstyleData As DimStyleTableRecord
    Get
    Set
public:
property DimStyleTableRecord^ DimstyleData {
    DimStyleTableRecord^ get ();
    void set (DimStyleTableRecord^ value);
}


Dimtad Property

Dimtad Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dimtad
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Dimtad { get; set; }
Public Overridable Property Dimtad As Integer
    Get
    Set
public:
virtual property int Dimtad {
    int get ();
    void set (int value);
}


Dimtxsty Property

Dimtxsty Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dimtxsty
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use TextStyleId functionality instead.")]
public virtual ObjectId Dimtxsty { get; set; }
<ObsoleteAttribute("Use TextStyleId functionality instead.")> _
Public Overridable Property Dimtxsty As ObjectId
    Get
    Set
[ObsoleteAttribute(L"Use TextStyleId functionality instead.")]
public:
virtual property ObjectId Dimtxsty {
    ObjectId get ();
    void set (ObjectId value);
}


Dimtxt Property

Dimtxt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dimtxt
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public virtual double Dimtxt { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Overridable Property Dimtxt As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
virtual property double Dimtxt {
    double get ();
    void set (double value);
}


EvaluateLeader Method

EvaluateLeader Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »EvaluateLeader()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void EvaluateLeader()
Public Overridable Sub EvaluateLeader
public:
virtual void EvaluateLeader()


FirstVertex Property

FirstVertex Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »FirstVertex
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d FirstVertex { get; }
Public Overridable ReadOnly Property FirstVertex As Point3d
    Get
public:
virtual property Point3d FirstVertex {
    Point3d get ();
}


GetDimstyleData Method

GetDimstyleData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetDimstyleData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DimStyleTableRecord GetDimstyleData()
Public Function GetDimstyleData As DimStyleTableRecord
public:
DimStyleTableRecord^ GetDimstyleData()


HasArrowHead Property

HasArrowHead Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »HasArrowHead
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool HasArrowHead { get; set; }
Public Overridable Property HasArrowHead As Boolean
    Get
    Set
public:
virtual property bool HasArrowHead {
    bool get ();
    void set (bool value);
}


HasHookLine Property

HasHookLine Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »HasHookLine
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool HasHookLine { get; }
Public Overridable ReadOnly Property HasHookLine As Boolean
    Get
public:
virtual property bool HasHookLine {
    bool get ();
}


IsSplined Property

IsSplined Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »IsSplined
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSplined { get; set; }
Public Overridable Property IsSplined As Boolean
    Get
    Set
public:
virtual property bool IsSplined {
    bool get ();
    void set (bool value);
}


LastVertex Property

LastVertex Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »LastVertex
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d LastVertex { get; }
Public Overridable ReadOnly Property LastVertex As Point3d
    Get
public:
virtual property Point3d LastVertex {
    Point3d get ();
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Normal
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d Normal { get; }
Public Overridable ReadOnly Property Normal As Vector3d
    Get
public:
virtual property Vector3d Normal {
    Vector3d get ();
}


NumVertices Property

NumVertices Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »NumVertices
Declaration Syntax
C# Visual Basic Visual C++
public virtual int NumVertices { get; }
Public Overridable ReadOnly Property NumVertices As Integer
    Get
public:
virtual property int NumVertices {
    int get ();
}


RemoveLastVertex Method

RemoveLastVertex Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »RemoveLastVertex()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveLastVertex()
Public Overridable Sub RemoveLastVertex
public:
virtual void RemoveLastVertex()


SetDimstyleData Method (style)

SetDimstyleData Method (style)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »SetDimstyleData(DimStyleTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDimstyleData(
    DimStyleTableRecord style
)
Public Sub SetDimstyleData ( _
    style As DimStyleTableRecord _
)
public:
void SetDimstyleData(
    DimStyleTableRecord^ style
)
Parameters
style(DimStyleTableRecord)


SetPlane Method (value)

SetPlane Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »SetPlane(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetPlane(
    Plane value
)
Public Overridable Sub SetPlane ( _
    value As Plane _
)
public:
virtual void SetPlane(
    Plane^ value
)
Parameters
value(Plane)


SetVertexAt Method (index, pointValue)

SetVertexAt Method (index, pointValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »SetVertexAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool SetVertexAt(
    int index,
    Point3d pointValue
)
Public Overridable Function SetVertexAt ( _
    index As Integer, _
    pointValue As Point3d _
) As Boolean
public:
virtual bool SetVertexAt(
    int index,
    Point3d pointValue
)
Parameters
index(Int32)
pointValue(Point3d)


TextStyleId Property

TextStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »TextStyleId
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId TextStyleId { get; set; }
Public Overridable Property TextStyleId As ObjectId
    Get
    Set
public:
virtual property ObjectId TextStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


VertexAt Method (value)

VertexAt Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »VertexAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d VertexAt(
    int value
)
Public Overridable Function VertexAt ( _
    value As Integer _
) As Point3d
public:
virtual Point3d VertexAt(
    int value
)
Parameters
value(Int32)


LeaderDirectionType Enumeration

LeaderDirectionType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LeaderDirectionType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::LeaderDirectionType")]
public enum LeaderDirectionType
<WrapperAttribute("ZcDbMLeaderStyle::LeaderDirectionType")> _
Public Enumeration LeaderDirectionType
[WrapperAttribute(L"ZcDbMLeaderStyle::LeaderDirectionType")]
public enum class LeaderDirectionType
Members
Member | Description
RightLeader |
LeftLeader |
UnknownLeader |


LeaderType Enumeration

LeaderType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LeaderType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::LeaderType")]
public enum LeaderType
<WrapperAttribute("ZcDbMLeaderStyle::LeaderType")> _
Public Enumeration LeaderType
[WrapperAttribute(L"ZcDbMLeaderStyle::LeaderType")]
public enum class LeaderType
Members
Member | Description
SplineLeader |
StraightLeader |
InVisibleLeader |


LightingUnits Enumeration

LightingUnits Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LightingUnits
Declaration Syntax
C# Visual Basic Visual C++
public enum LightingUnits
Public Enumeration LightingUnits
public enum class LightingUnits
Members
Member | Description
LightingUnitsInternational |
LightingUnitsGeneric |
LightingUnitsAmerican |


Line Class

Line Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbLine")]
public class Line : Curve
<WrapperAttribute("AcDbLine")> _
Public Class Line _
    Inherits Curve
[WrapperAttribute(L"AcDbLine")]
public ref class Line : public Curve
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Line(Point3d, Point3d) |
 | Line()()()() |
 | Line(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Angle |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed | (Inherited from Curve.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Delta |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Overrides Curve.EndPoint.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Length |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Spline | (Inherited from Curve.)
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Overrides Curve.StartPoint.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Line


Line Constructor

Line Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Line()()()()
Members
Icon | Member | Description
 | Line(Point3d, Point3d) |
 | Line()()()() |
 | Line(IntPtr, Boolean) |


Line Constructor

Line Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Line()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Line()
Public Sub New
public:
Line()


Line Constructor (unmanagedObjPtr, autoDelete)

Line Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Line(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Line(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Line(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Line Constructor (stPoint, endPoint)

Line Constructor (stPoint, endPoint)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Line(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Line(
    Point3d stPoint,
    Point3d endPoint
)
Public Sub New ( _
    stPoint As Point3d, _
    endPoint As Point3d _
)
public:
Line(
    Point3d stPoint,
    Point3d endPoint
)
Parameters
stPoint(Point3d)
endPoint(Point3d)


Angle Property

Angle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Angle
Declaration Syntax
C# Visual Basic Visual C++
public double Angle { get; }
Public ReadOnly Property Angle As Double
    Get
public:
property double Angle {
    double get ();
}


Delta Property

Delta Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Delta
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Delta { get; }
Public ReadOnly Property Delta As Vector3d
    Get
public:
property Vector3d Delta {
    Vector3d get ();
}


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public override Point3d EndPoint { get; set; }
Public Overrides Property EndPoint As Point3d
    Get
    Set
public:
virtual property Point3d EndPoint {
    Point3d get () override;
    void set (Point3d value) override;
}


Length Property

Length Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Length
Declaration Syntax
C# Visual Basic Visual C++
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public override Point3d StartPoint { get; set; }
Public Overrides Property StartPoint As Point3d
    Get
    Set
public:
virtual property Point3d StartPoint {
    Point3d get () override;
    void set (Point3d value) override;
}


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}


LineAngularDimension2 Class

LineAngularDimension2 Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDb2LineAngularDimension")]
public class LineAngularDimension2 : Dimension
<WrapperAttribute("AcDb2LineAngularDimension")> _
Public Class LineAngularDimension2 _
    Inherits Dimension
[WrapperAttribute(L"AcDb2LineAngularDimension")]
public ref class LineAngularDimension2 : public Dimension
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LineAngularDimension2(Point3d, Point3d, Point3d, Point3d, Point3d, String, ObjectId) |
 | LineAngularDimension2(IntPtr, Boolean) |
 | LineAngularDimension2()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlternatePrefix | (Inherited from Dimension.)
 | AlternateSuffix | (Inherited from Dimension.)
 | AltSuppressLeadingZeros | (Inherited from Dimension.)
 | AltSuppressTrailingZeros | (Inherited from Dimension.)
 | AltSuppressZeroFeet | (Inherited from Dimension.)
 | AltSuppressZeroInches | (Inherited from Dimension.)
 | AltToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | AltToleranceSuppressZeroInches | (Inherited from Dimension.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | ArcPoint |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | CenterMarkSize | (Inherited from Dimension.)
 | CenterMarkType | (Inherited from Dimension.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec | (Inherited from Dimension.)
 | Dimalt | (Inherited from Dimension.)
 | Dimaltd | (Inherited from Dimension.)
 | Dimaltf | (Inherited from Dimension.)
 | Dimaltrnd | (Inherited from Dimension.)
 | Dimalttd | (Inherited from Dimension.)
 | Dimalttz | (Inherited from Dimension.)
 | Dimaltu | (Inherited from Dimension.)
 | Dimaltz | (Inherited from Dimension.)
 | Dimapost | (Inherited from Dimension.)
 | Dimarcsym | (Inherited from Dimension.)
 | Dimasz | (Inherited from Dimension.)
 | Dimatfit | (Inherited from Dimension.)
 | Dimaunit | (Inherited from Dimension.)
 | Dimazin | (Inherited from Dimension.)
 | Dimblk | (Inherited from Dimension.)
 | Dimblk1 | (Inherited from Dimension.)
 | Dimblk1s | (Inherited from Dimension.)
 | Dimblk2 | (Inherited from Dimension.)
 | Dimblk2s | (Inherited from Dimension.)
 | Dimblks | (Inherited from Dimension.)
 | DimBlockId | (Inherited from Dimension.)
 | DimBlockPosition | (Inherited from Dimension.)
 | Dimcen | (Inherited from Dimension.)
 | Dimclrd | (Inherited from Dimension.)
 | Dimclre | (Inherited from Dimension.)
 | Dimclrt | (Inherited from Dimension.)
 | Dimdec | (Inherited from Dimension.)
 | Dimdle | (Inherited from Dimension.)
 | Dimdli | (Inherited from Dimension.)
 | Dimdsep | (Inherited from Dimension.)
 | DimensionStyle | (Inherited from Dimension.)
 | DimensionStyleName | (Inherited from Dimension.)
 | DimensionText | (Inherited from Dimension.)
 | Dimexe | (Inherited from Dimension.)
 | Dimexo | (Inherited from Dimension.)
 | Dimfrac | (Inherited from Dimension.)
 | Dimfxlen | (Inherited from Dimension.)
 | DimfxlenOn | (Inherited from Dimension.)
 | Dimgap | (Inherited from Dimension.)
 | Dimjogang | (Inherited from Dimension.)
 | Dimjust | (Inherited from Dimension.)
 | Dimldrblk | (Inherited from Dimension.)
 | Dimldrblks | (Inherited from Dimension.)
 | Dimlfac | (Inherited from Dimension.)
 | Dimlim | (Inherited from Dimension.)
 | Dimltex1 | (Inherited from Dimension.)
 | Dimltex2 | (Inherited from Dimension.)
 | Dimltype | (Inherited from Dimension.)
 | Dimlunit | (Inherited from Dimension.)
 | Dimlwd | (Inherited from Dimension.)
 | Dimlwe | (Inherited from Dimension.)
 | Dimpost | (Inherited from Dimension.)
 | Dimrnd | (Inherited from Dimension.)
 | Dimsah | (Inherited from Dimension.)
 | Dimscale | (Inherited from Dimension.)
 | Dimsd1 | (Inherited from Dimension.)
 | Dimsd2 | (Inherited from Dimension.)
 | Dimse1 | (Inherited from Dimension.)
 | Dimse2 | (Inherited from Dimension.)
 | Dimsoxd | (Inherited from Dimension.)
 | DimstyleData | (Inherited from Dimension.)
 | Dimtad | (Inherited from Dimension.)
 | Dimtdec | (Inherited from Dimension.)
 | Dimtfac | (Inherited from Dimension.)
 | Dimtfill | (Inherited from Dimension.)
 | Dimtfillclr | (Inherited from Dimension.)
 | Dimtih | (Inherited from Dimension.)
 | Dimtix | (Inherited from Dimension.)
 | Dimtm | (Inherited from Dimension.)
 | Dimtmove | (Inherited from Dimension.)
 | Dimtofl | (Inherited from Dimension.)
 | Dimtoh | (Inherited from Dimension.)
 | Dimtol | (Inherited from Dimension.)
 | Dimtolj | (Inherited from Dimension.)
 | Dimtp | (Inherited from Dimension.)
 | Dimtsz | (Inherited from Dimension.)
 | Dimtvp | (Inherited from Dimension.)
 | Dimtxsty | (Inherited from Dimension.)
 | Dimtxt | (Inherited from Dimension.)
 | Dimtzin | (Inherited from Dimension.)
 | Dimupt | (Inherited from Dimension.)
 | Dimzin | (Inherited from Dimension.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicDimension | (Inherited from Dimension.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation | (Inherited from Dimension.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldFromMText(MText) | (Inherited from Dimension.)
 | FieldToMText(MText) | (Inherited from Dimension.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FormatMeasurement(Double, String) | (Inherited from Dimension.)
 | GenerateLayout()()()() | (Inherited from Dimension.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetDimstyleData()()()() | (Inherited from Dimension.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalRotation | (Inherited from Dimension.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | Measurement | (Inherited from Dimension.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal | (Inherited from Dimension.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Prefix | (Inherited from Dimension.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeDimensionBlock(Boolean) | (Inherited from Dimension.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveTextField()()()() | (Inherited from Dimension.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) | (Inherited from Dimension.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | Suffix | (Inherited from Dimension.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressAngularLeadingZeros | (Inherited from Dimension.)
 | SuppressAngularTrailingZeros | (Inherited from Dimension.)
 | SuppressLeadingZeros | (Inherited from Dimension.)
 | SuppressTrailingZeros | (Inherited from Dimension.)
 | SuppressZeroFeet | (Inherited from Dimension.)
 | SuppressZeroInches | (Inherited from Dimension.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAttachment | (Inherited from Dimension.)
 | TextLineSpacingFactor | (Inherited from Dimension.)
 | TextLineSpacingStyle | (Inherited from Dimension.)
 | TextPosition | (Inherited from Dimension.)
 | TextRotation | (Inherited from Dimension.)
 | TextStyleId | (Inherited from Dimension.)
 | ToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | ToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | ToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | ToleranceSuppressZeroInches | (Inherited from Dimension.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UsingDefaultTextPosition | (Inherited from Dimension.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | XLine1End |
 | XLine1Start |
 | XLine2End |
 | XLine2Start |
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  |  | LineAngularDimension2


LineAngularDimension2 Constructor

LineAngularDimension2 Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »LineAngularDimension2()()()()
Members
Icon | Member | Description
 | LineAngularDimension2(Point3d, Point3d, Point3d, Point3d, Point3d, String, ObjectId) |
 | LineAngularDimension2(IntPtr, Boolean) |
 | LineAngularDimension2()()()() |


LineAngularDimension2 Constructor

LineAngularDimension2 Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »LineAngularDimension2()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LineAngularDimension2()
Public Sub New
public:
LineAngularDimension2()


LineAngularDimension2 Constructor (unmanagedObjPtr, autoDelete)

LineAngularDimension2 Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »LineAngularDimension2(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LineAngularDimension2(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
LineAngularDimension2(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


LineAngularDimension2 Constructor (line1Start, line1End, line2Start, line2End, arcPoint, dimensionText, dimensionStyle)

LineAngularDimension2 Constructor (line1Start, line1End, line2Start, line2End, arcPoint, dimensionText, dimensionStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »LineAngularDimension2(Point3d, Point3d, Point3d, Point3d, Point3d, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public LineAngularDimension2(
    Point3d line1Start,
    Point3d line1End,
    Point3d line2Start,
    Point3d line2End,
    Point3d arcPoint,
    string dimensionText,
    ObjectId dimensionStyle
)
Public Sub New ( _
    line1Start As Point3d, _
    line1End As Point3d, _
    line2Start As Point3d, _
    line2End As Point3d, _
    arcPoint As Point3d, _
    dimensionText As String, _
    dimensionStyle As ObjectId _
)
public:
LineAngularDimension2(
    Point3d line1Start,
    Point3d line1End,
    Point3d line2Start,
    Point3d line2End,
    Point3d arcPoint,
    String^ dimensionText,
    ObjectId dimensionStyle
)
Parameters
line1Start(Point3d)
line1End(Point3d)
line2Start(Point3d)
line2End(Point3d)
arcPoint(Point3d)
dimensionText(String)
dimensionStyle(ObjectId)


ArcPoint Property

ArcPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »ArcPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ArcPoint { get; set; }
Public Property ArcPoint As Point3d
    Get
    Set
public:
property Point3d ArcPoint {
    Point3d get ();
    void set (Point3d value);
}


XLine1End Property

XLine1End Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »XLine1End
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine1End { get; set; }
Public Property XLine1End As Point3d
    Get
    Set
public:
property Point3d XLine1End {
    Point3d get ();
    void set (Point3d value);
}


XLine1Start Property

XLine1Start Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »XLine1Start
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine1Start { get; set; }
Public Property XLine1Start As Point3d
    Get
    Set
public:
property Point3d XLine1Start {
    Point3d get ();
    void set (Point3d value);
}


XLine2End Property

XLine2End Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »XLine2End
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine2End { get; set; }
Public Property XLine2End As Point3d
    Get
    Set
public:
property Point3d XLine2End {
    Point3d get ();
    void set (Point3d value);
}


XLine2Start Property

XLine2Start Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »XLine2Start
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine2Start { get; set; }
Public Property XLine2Start As Point3d
    Get
    Set
public:
property Point3d XLine2Start {
    Point3d get ();
    void set (Point3d value);
}


LineEndStyle Enumeration

LineEndStyle Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineEndStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdPs::LineEndStyle")]
public enum LineEndStyle
<WrapperAttribute("OdPs::LineEndStyle")> _
Public Enumeration LineEndStyle
[WrapperAttribute(L"OdPs::LineEndStyle")]
public enum class LineEndStyle
Members
Member | Description
LesUseObject |
LesDiamond |
LesRound |
LesSquare |
LesButt |


LineJoinStyle Enumeration

LineJoinStyle Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineJoinStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdPs::LineJoinStyle")]
public enum LineJoinStyle
<WrapperAttribute("OdPs::LineJoinStyle")> _
Public Enumeration LineJoinStyle
[WrapperAttribute(L"OdPs::LineJoinStyle")]
public enum class LineJoinStyle
Members
Member | Description
LjsUseObject |
LjsDiamond |
LjsRound |
LjsBevel |
LjsMiter |


LineSpacingStyle Enumeration

LineSpacingStyle Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineSpacingStyle
Declaration Syntax
C# Visual Basic Visual C++
public enum LineSpacingStyle
Public Enumeration LineSpacingStyle
public enum class LineSpacingStyle
Members
Member | Description
Exactly |
AtLeast |


LineType Enumeration

LineType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdPs::LineType")]
public enum LineType
<WrapperAttribute("OdPs::LineType")> _
Public Enumeration LineType
[WrapperAttribute(L"OdPs::LineType")]
public enum class LineType
Members
Member | Description
LtpLast |
LtpUseObject |
LtpISODoubleDashTripleDot |
LtpISODashTripleDot |
LtpISODoubleDashDoubleDot |
LtpISODashDoubleDot |
LtpISODoubleDashDot |
LtpISODashDot |
LtpISOLongDashDoubleShortDash |
LtpISOLongDashShortDash |
LtpISODot |
LtpISOLongDashTripleDot |
LtpISOLongDashDoubleDot |
LtpISOLongDashDot |
LtpISODashSpace |
LtpISODash |
LtpSparseDot |
LtpMediumDashDotShortDashDot |
LtpLongDashDot |
LtpLongDashDotDot |
LtpLongDashShortDash |
LtpMediumDashShortDashShortDash |
LtpMediumLongDash |
LtpLongDashX2 |
LtpMediumDashX2 |
LtpShortDashX2 |
LtpLongDash |
LtpMediumDash |
LtpShortDash |
LtpDashDot |
LtpDotted |
LtpDashed |
LtpSolid |


LinetypeTable Class

LinetypeTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbLinetypeTable")]
public sealed class LinetypeTable : SymbolTable
<WrapperAttribute("AcDbLinetypeTable")> _
Public NotInheritable Class LinetypeTable _
    Inherits SymbolTable
[WrapperAttribute(L"AcDbLinetypeTable")]
public ref class LinetypeTable sealed : public SymbolTable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) | (Inherited from SymbolTable.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() | (Inherited from SymbolTable.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) | (Inherited from SymbolTable.)
 | Has(ObjectId) | (Inherited from SymbolTable.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from SymbolTable.)
 | IncludingErased | (Inherited from SymbolTable.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from SymbolTable.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | LinetypeTable


LinetypeTableRecord Class

LinetypeTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbLinetypeTableRecord")]
public class LinetypeTableRecord : SymbolTableRecord
<WrapperAttribute("AcDbLinetypeTableRecord")> _
Public Class LinetypeTableRecord _
    Inherits SymbolTableRecord
[WrapperAttribute(L"AcDbLinetypeTableRecord")]
public ref class LinetypeTableRecord : public SymbolTableRecord
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinetypeTableRecord(IntPtr, Boolean) |
 | LinetypeTableRecord()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AsciiDescription |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Comments |
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DashLengthAt(Int32) |
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent | (Inherited from SymbolTableRecord.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsResolved | (Inherited from SymbolTableRecord.)
 | IsScaledToFit |
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from SymbolTableRecord.)
 | NumDashes |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PatternLength |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDashLengthAt(Int32, Double) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetShapeIsUcsOrientedAt(Int32, Boolean) |
 | SetShapeNumberAt(Int32, Int32) |
 | SetShapeOffsetAt(Int32, Vector2d) |
 | SetShapeRotationAt(Int32, Double) |
 | SetShapeScaleAt(Int32, Double) |
 | SetShapeStyleAt(Int32, ObjectId) |
 | SetTextAt(Int32, String) |
 | ShapeIsUcsOrientedAt(Int32) |
 | ShapeNumberAt(Int32) |
 | ShapeOffsetAt(Int32) |
 | ShapeRotationAt(Int32) |
 | ShapeScaleAt(Int32) |
 | ShapeStyleAt(Int32) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAt(Int32) |
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | LinetypeTableRecord


LinetypeTableRecord Constructor

LinetypeTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »LinetypeTableRecord()()()()
Members
Icon | Member | Description
 | LinetypeTableRecord(IntPtr, Boolean) |
 | LinetypeTableRecord()()()() |


LinetypeTableRecord Constructor

LinetypeTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »LinetypeTableRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LinetypeTableRecord()
Public Sub New
public:
LinetypeTableRecord()


LinetypeTableRecord Constructor (obj, autoDelete)

LinetypeTableRecord Constructor (obj, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »LinetypeTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LinetypeTableRecord(
    IntPtr obj,
    bool autoDelete
)
Protected Friend Sub New ( _
    obj As IntPtr, _
    autoDelete As Boolean _
)
protected public:
LinetypeTableRecord(
    IntPtr obj,
    bool autoDelete
)
Parameters
obj(IntPtr)
autoDelete(Boolean)


AsciiDescription Property

AsciiDescription Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »AsciiDescription
Declaration Syntax
C# Visual Basic Visual C++
public string AsciiDescription { get; set; }
Public Property AsciiDescription As String
    Get
    Set
public:
property String^ AsciiDescription {
    String^ get ();
    void set (String^ value);
}


Comments Property

Comments Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »Comments
Declaration Syntax
C# Visual Basic Visual C++
public string Comments { get; set; }
Public Property Comments As String
    Get
    Set
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}


DashLengthAt Method (index)

DashLengthAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »DashLengthAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double DashLengthAt(
    int index
)
Public Function DashLengthAt ( _
    index As Integer _
) As Double
public:
double DashLengthAt(
    int index
)
Parameters
index(Int32)


IsScaledToFit Property

IsScaledToFit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »IsScaledToFit
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScaledToFit { get; set; }
Public Property IsScaledToFit As Boolean
    Get
    Set
public:
property bool IsScaledToFit {
    bool get ();
    void set (bool value);
}


NumDashes Property

NumDashes Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »NumDashes
Declaration Syntax
C# Visual Basic Visual C++
public int NumDashes { get; set; }
Public Property NumDashes As Integer
    Get
    Set
public:
property int NumDashes {
    int get ();
    void set (int value);
}


PatternLength Property

PatternLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »PatternLength
Declaration Syntax
C# Visual Basic Visual C++
public double PatternLength { get; set; }
Public Property PatternLength As Double
    Get
    Set
public:
property double PatternLength {
    double get ();
    void set (double value);
}


SetDashLengthAt Method (index, value)

SetDashLengthAt Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »SetDashLengthAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDashLengthAt(
    int index,
    double value
)
Public Sub SetDashLengthAt ( _
    index As Integer, _
    value As Double _
)
public:
void SetDashLengthAt(
    int index,
    double value
)
Parameters
index(Int32)
value(Double)


SetShapeIsUcsOrientedAt Method (index, isOriented)

SetShapeIsUcsOrientedAt Method (index, isOriented)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »SetShapeIsUcsOrientedAt(Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetShapeIsUcsOrientedAt(
    int index,
    bool isOriented
)
Public Sub SetShapeIsUcsOrientedAt ( _
    index As Integer, _
    isOriented As Boolean _
)
public:
void SetShapeIsUcsOrientedAt(
    int index,
    bool isOriented
)
Parameters
index(Int32)
isOriented(Boolean)


SetShapeNumberAt Method (index, shapeNumber)

SetShapeNumberAt Method (index, shapeNumber)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »SetShapeNumberAt(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SetShapeNumberAt(
    int index,
    int shapeNumber
)
Public Sub SetShapeNumberAt ( _
    index As Integer, _
    shapeNumber As Integer _
)
public:
void SetShapeNumberAt(
    int index,
    int shapeNumber
)
Parameters
index(Int32)
shapeNumber(Int32)


SetShapeOffsetAt Method (index, offset)

SetShapeOffsetAt Method (index, offset)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »SetShapeOffsetAt(Int32, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetShapeOffsetAt(
    int index,
    Vector2d offset
)
Public Sub SetShapeOffsetAt ( _
    index As Integer, _
    offset As Vector2d _
)
public:
void SetShapeOffsetAt(
    int index,
    Vector2d offset
)
Parameters
index(Int32)
offset(Vector2d)


SetShapeRotationAt Method (index, rotation)

SetShapeRotationAt Method (index, rotation)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »SetShapeRotationAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetShapeRotationAt(
    int index,
    double rotation
)
Public Sub SetShapeRotationAt ( _
    index As Integer, _
    rotation As Double _
)
public:
void SetShapeRotationAt(
    int index,
    double rotation
)
Parameters
index(Int32)
rotation(Double)


SetShapeScaleAt Method (index, scale)

SetShapeScaleAt Method (index, scale)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »SetShapeScaleAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetShapeScaleAt(
    int index,
    double scale
)
Public Sub SetShapeScaleAt ( _
    index As Integer, _
    scale As Double _
)
public:
void SetShapeScaleAt(
    int index,
    double scale
)
Parameters
index(Int32)
scale(Double)


SetShapeStyleAt Method (index, id)

SetShapeStyleAt Method (index, id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »SetShapeStyleAt(Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetShapeStyleAt(
    int index,
    ObjectId id
)
Public Sub SetShapeStyleAt ( _
    index As Integer, _
    id As ObjectId _
)
public:
void SetShapeStyleAt(
    int index,
    ObjectId id
)
Parameters
index(Int32)
id(ObjectId)


SetTextAt Method (index, value)

SetTextAt Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »SetTextAt(Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTextAt(
    int index,
    string value
)
Public Sub SetTextAt ( _
    index As Integer, _
    value As String _
)
public:
void SetTextAt(
    int index,
    String^ value
)
Parameters
index(Int32)
value(String)


ShapeIsUcsOrientedAt Method (index)

ShapeIsUcsOrientedAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »ShapeIsUcsOrientedAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool ShapeIsUcsOrientedAt(
    int index
)
Public Function ShapeIsUcsOrientedAt ( _
    index As Integer _
) As Boolean
public:
bool ShapeIsUcsOrientedAt(
    int index
)
Parameters
index(Int32)


ShapeNumberAt Method (index)

ShapeNumberAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »ShapeNumberAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int ShapeNumberAt(
    int index
)
Public Function ShapeNumberAt ( _
    index As Integer _
) As Integer
public:
int ShapeNumberAt(
    int index
)
Parameters
index(Int32)


ShapeOffsetAt Method (index)

ShapeOffsetAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »ShapeOffsetAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d ShapeOffsetAt(
    int index
)
Public Function ShapeOffsetAt ( _
    index As Integer _
) As Vector2d
public:
Vector2d ShapeOffsetAt(
    int index
)
Parameters
index(Int32)


ShapeRotationAt Method (index)

ShapeRotationAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »ShapeRotationAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double ShapeRotationAt(
    int index
)
Public Function ShapeRotationAt ( _
    index As Integer _
) As Double
public:
double ShapeRotationAt(
    int index
)
Parameters
index(Int32)


ShapeScaleAt Method (index)

ShapeScaleAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »ShapeScaleAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double ShapeScaleAt(
    int index
)
Public Function ShapeScaleAt ( _
    index As Integer _
) As Double
public:
double ShapeScaleAt(
    int index
)
Parameters
index(Int32)


ShapeStyleAt Method (index)

ShapeStyleAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »ShapeStyleAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ShapeStyleAt(
    int index
)
Public Function ShapeStyleAt ( _
    index As Integer _
) As ObjectId
public:
ObjectId ShapeStyleAt(
    int index
)
Parameters
index(Int32)


TextAt Method (index)

TextAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »TextAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public string TextAt(
    int index
)
Public Function TextAt ( _
    index As Integer _
) As String
public:
String^ TextAt(
    int index
)
Parameters
index(Int32)


LineWeight Enumeration

LineWeight Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeight
Declaration Syntax
C# Visual Basic Visual C++
[TypeConverterAttribute(typeof(LineWeightConverter))]
public enum LineWeight
<TypeConverterAttribute(GetType(LineWeightConverter))> _
Public Enumeration LineWeight
[TypeConverterAttribute(typeof(LineWeightConverter))]
public enum class LineWeight
Members
Member | Description
LineWeight211 |
LineWeight200 |
LineWeight158 |
LineWeight140 |
LineWeight120 |
LineWeight106 |
LineWeight100 |
LineWeight090 |
LineWeight080 |
LineWeight070 |
LineWeight060 |
LineWeight053 |
LineWeight050 |
LineWeight040 |
LineWeight035 |
LineWeight030 |
LineWeight025 |
LineWeight020 |
LineWeight018 |
LineWeight015 |
LineWeight013 |
LineWeight009 |
LineWeight005 |
LineWeight000 |
ByLineWeightDefault |
ByLayer |
ByBlock |


LineWeightConverter Class

LineWeightConverter Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter
Declaration Syntax
C# Visual Basic Visual C++
public class LineWeightConverter : TypeConverter
Public Class LineWeightConverter _
    Inherits TypeConverter
public ref class LineWeightConverter : public TypeConverter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LineWeightConverter()()()() |
 | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter.CanConvertFrom(ITypeDescriptorContext, Type).)
 | CanConvertFrom(Type) | (Inherited from TypeConverter.)
 | CanConvertTo(Type) | (Inherited from TypeConverter.)
 | CanConvertTo(ITypeDescriptorContext, Type) | (Inherited from TypeConverter.)
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
 | ConvertFrom(Object) | (Inherited from TypeConverter.)
 | ConvertFromInvariantString(String) | (Inherited from TypeConverter.)
 | ConvertFromInvariantString(ITypeDescriptorContext, String) | (Inherited from TypeConverter.)
 | ConvertFromString(String) | (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, String) | (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | (Inherited from TypeConverter.)
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) | (Inherited from TypeConverter.)
 | ConvertToInvariantString(Object) | (Inherited from TypeConverter.)
 | ConvertToInvariantString(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | ConvertToString(Object) | (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | (Inherited from TypeConverter.)
 | CreateInstance(IDictionary) | (Inherited from TypeConverter.)
 | CreateInstance(ITypeDescriptorContext, IDictionary) | (Inherited from TypeConverter.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetConvertFromException(Object) | (Inherited from TypeConverter.)
 | GetConvertToException(Object, Type) | (Inherited from TypeConverter.)
 | GetCreateInstanceSupported()()()() | (Inherited from TypeConverter.)
 | GetCreateInstanceSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetProperties(Object) | (Inherited from TypeConverter.)
 | GetProperties(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | (Inherited from TypeConverter.)
 | GetPropertiesSupported()()()() | (Inherited from TypeConverter.)
 | GetPropertiesSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValues()()()() | (Inherited from TypeConverter.)
 | GetStandardValues(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValuesExclusive()()()() | (Inherited from TypeConverter.)
 | GetStandardValuesExclusive(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValuesSupported()()()() | (Inherited from TypeConverter.)
 | GetStandardValuesSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetType()()()() | (Inherited from Object.)
 | IsValid(Object) | (Inherited from TypeConverter.)
 | IsValid(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SortProperties(PropertyDescriptorCollection, array<String>[]()[][]) | (Inherited from TypeConverter.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeConverter
 |  | LineWeightConverter


LineWeightConverter Constructor

LineWeightConverter Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »LineWeightConverter()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LineWeightConverter()
Public Sub New
public:
LineWeightConverter()


CanConvertFrom Method (context, sourceType)

CanConvertFrom Method (context, sourceType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »CanConvertFrom(ITypeDescriptorContext, Type)
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override
Parameters
context(ITypeDescriptorContext)
sourceType(Type)


ConvertFrom Method (context, culture, value)

ConvertFrom Method (context, culture, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »ConvertFrom(ITypeDescriptorContext, CultureInfo, Object)
Declaration Syntax
C# Visual Basic Visual C++
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override
Parameters
context(ITypeDescriptorContext)
culture(CultureInfo)
value(Object)


ConvertTo Method (context, culture, value, destinationType)

ConvertTo Method (context, culture, value, destinationType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type)
Declaration Syntax
C# Visual Basic Visual C++
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
Parameters
context(ITypeDescriptorContext)
culture(CultureInfo)
value(Object)
destinationType(Type)


LinkedData Class

LinkedData Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbLinkedData")]
public abstract class LinkedData : DBObject
<WrapperAttribute("ZcDbLinkedData")> _
Public MustInherit Class LinkedData _
    Inherits DBObject
[WrapperAttribute(L"ZcDbLinkedData")]
public ref class LinkedData abstract : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinkedData(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clear()()()() |
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEmpty |
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | LinkedData
 |  |  |  |  |  |  | LinkedTableData


LinkedData Constructor (unmanagedObjPtr, autoDelete)

LinkedData Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »LinkedData(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LinkedData(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
LinkedData(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()


IsEmpty Property

IsEmpty Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »IsEmpty
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »Name
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}


LinkedTableData Class

LinkedTableData Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbLinkedTableData")]
public class LinkedTableData : LinkedData
<WrapperAttribute("ZcDbLinkedTableData")> _
Public Class LinkedTableData _
    Inherits LinkedData
[WrapperAttribute(L"ZcDbLinkedTableData")]
public ref class LinkedTableData : public LinkedData
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinkedTableData()()()() |
 | LinkedTableData(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | AppendColumn(Int32) |
 | AppendRow(Int32) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clear()()()() | (Inherited from LinkedData.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | Create(IntPtr, Boolean) |
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DataType(Int32, Int32) |
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteColumn(Int32, Int32) |
 | DeleteContent(Int32, Int32) |
 | DeleteRow(Int32, Int32) |
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetBlockAttributeValue(Int32, Int32, ObjectId) |
 | GetBlockTableRecordId(Int32, Int32) |
 | GetCellState(Int32, Int32) |
 | GetColumnName(Int32) |
 | GetContentTypes(Int32, Int32) |
 | GetCustomData(Int32, Int32, String) |
 | GetDataFormat(Int32, Int32) |
 | GetDataLink(Int32, Int32) |
 | GetDataLink(CellRange) |
 | GetDataLink()()()() |
 | GetEnumerator(TableEnumeratorOption) |
 | GetEnumerator()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFieldId(Int32, Int32) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetToolTip(Int32, Int32) |
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetValue(Int32, Int32, Int32, FormatOption) |
 | GetValue(Int32, Int32) |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertColumn(Int32, Int32) |
 | InsertRow(Int32, Int32) |
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentEditable(Int32, Int32) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEmpty | (Inherited from LinkedData.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsLinked(Int32, Int32) |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from LinkedData.)
 | NumberOfColumns |
 | NumberOfRows |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetBlockAttributeValue(Int32, Int32, ObjectId, String) |
 | SetBlockTableRecordId(Int32, Int32, ObjectId) |
 | SetCellState(Int32, Int32, CellStates) |
 | SetColumnName(Int32, String) |
 | SetCustomData(Int32, Int32, String, Object) |
 | SetDataFormat(Int32, Int32, String) |
 | SetDataLink(Int32, Int32, ObjectId, Boolean) |
 | SetDataLink(CellRange, ObjectId, Boolean) |
 | SetDataType(Int32, Int32, DataType, UnitType) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFieldId(Int32, Int32, ObjectId) |
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetSize(Int32, Int32) |
 | SetToolTip(Int32, Int32, String) |
 | SetValue(Int32, Int32, Int32, Object, ParseOption) |
 | SetValue(Int32, Int32, Object) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnitType(Int32, Int32) |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) |
 | UpdateDataLink(UpdateDirection, UpdateOption) |
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | LinkedData
 |  |  |  |  |  |  | LinkedTableData
 |  |  |  |  |  |  |  | FormattedTableData


LinkedTableData Constructor

LinkedTableData Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »LinkedTableData()()()()
Members
Icon | Member | Description
 | LinkedTableData()()()() |
 | LinkedTableData(IntPtr, Boolean) |


LinkedTableData Constructor

LinkedTableData Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »LinkedTableData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LinkedTableData()
Public Sub New
public:
LinkedTableData()


LinkedTableData Constructor (unmanagedObjPtr, autoDelete)

LinkedTableData Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »LinkedTableData(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LinkedTableData(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
LinkedTableData(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AppendColumn Method (columnsNumber)

AppendColumn Method (columnsNumber)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »AppendColumn(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int AppendColumn(
    int columnsNumber
)
Public Overridable Function AppendColumn ( _
    columnsNumber As Integer _
) As Integer
public:
virtual int AppendColumn(
    int columnsNumber
)
Parameters
columnsNumber(Int32)


AppendRow Method (rowsNumber)

AppendRow Method (rowsNumber)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »AppendRow(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int AppendRow(
    int rowsNumber
)
Public Overridable Function AppendRow ( _
    rowsNumber As Integer _
) As Integer
public:
virtual int AppendRow(
    int rowsNumber
)
Parameters
rowsNumber(Int32)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal static LinkedTableData Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As LinkedTableData
protected public:
static LinkedTableData^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DataType Method (row, column)

DataType Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »DataType(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataType DataType(
    int row,
    int column
)
Public Overridable Function DataType ( _
    row As Integer, _
    column As Integer _
) As DataType
public:
virtual DataType DataType(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


DeleteColumn Method (index, columnsNumberToDelete)

DeleteColumn Method (index, columnsNumberToDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »DeleteColumn(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DeleteColumn(
    int index,
    int columnsNumberToDelete
)
Public Overridable Sub DeleteColumn ( _
    index As Integer, _
    columnsNumberToDelete As Integer _
)
public:
virtual void DeleteColumn(
    int index,
    int columnsNumberToDelete
)
Parameters
index(Int32)
columnsNumberToDelete(Int32)


DeleteContent Method (row, column)

DeleteContent Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »DeleteContent(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DeleteContent(
    int row,
    int column
)
Public Overridable Sub DeleteContent ( _
    row As Integer, _
    column As Integer _
)
public:
virtual void DeleteContent(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


DeleteRow Method (index, rowsNumberToDelete)

DeleteRow Method (index, rowsNumberToDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »DeleteRow(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DeleteRow(
    int index,
    int rowsNumberToDelete
)
Public Overridable Sub DeleteRow ( _
    index As Integer, _
    rowsNumberToDelete As Integer _
)
public:
virtual void DeleteRow(
    int index,
    int rowsNumberToDelete
)
Parameters
index(Int32)
rowsNumberToDelete(Int32)


GetBlockAttributeValue Method (row, column, attributeDefinitionId)

GetBlockAttributeValue Method (row, column, attributeDefinitionId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetBlockAttributeValue(Int32, Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetBlockAttributeValue(
    int row,
    int column,
    ObjectId attributeDefinitionId
)
Public Overridable Function GetBlockAttributeValue ( _
    row As Integer, _
    column As Integer, _
    attributeDefinitionId As ObjectId _
) As String
public:
virtual String^ GetBlockAttributeValue(
    int row,
    int column,
    ObjectId attributeDefinitionId
)
Parameters
row(Int32)
column(Int32)
attributeDefinitionId(ObjectId)


GetBlockTableRecordId Method (row, column)

GetBlockTableRecordId Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetBlockTableRecordId(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetBlockTableRecordId(
    int row,
    int column
)
Public Overridable Function GetBlockTableRecordId ( _
    row As Integer, _
    column As Integer _
) As ObjectId
public:
virtual ObjectId GetBlockTableRecordId(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetCellState Method (row, column)

GetCellState Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetCellState(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellStates GetCellState(
    int row,
    int column
)
Public Overridable Function GetCellState ( _
    row As Integer, _
    column As Integer _
) As CellStates
public:
virtual CellStates GetCellState(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetColumnName Method (index)

GetColumnName Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetColumnName(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetColumnName(
    int index
)
Public Overridable Function GetColumnName ( _
    index As Integer _
) As String
public:
virtual String^ GetColumnName(
    int index
)
Parameters
index(Int32)


GetContentTypes Method (row, column)

GetContentTypes Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetContentTypes(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellContentTypes GetContentTypes(
    int row,
    int column
)
Public Overridable Function GetContentTypes ( _
    row As Integer, _
    column As Integer _
) As CellContentTypes
public:
virtual CellContentTypes GetContentTypes(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetCustomData Method (row, column, key)

GetCustomData Method (row, column, key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetCustomData(Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object GetCustomData(
    int row,
    int column,
    string key
)
Public Overridable Function GetCustomData ( _
    row As Integer, _
    column As Integer, _
    key As String _
) As Object
public:
virtual Object^ GetCustomData(
    int row,
    int column,
    String^ key
)
Parameters
row(Int32)
column(Int32)
key(String)


GetDataFormat Method (row, column)

GetDataFormat Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetDataFormat(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetDataFormat(
    int row,
    int column
)
Public Overridable Function GetDataFormat ( _
    row As Integer, _
    column As Integer _
) As String
public:
virtual String^ GetDataFormat(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetDataLink Method

GetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetDataLink()()()()
Members
Icon | Member | Description
 | GetDataLink(Int32, Int32) |
 | GetDataLink(CellRange) |
 | GetDataLink()()()() |


GetDataLink Method

GetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetDataLink()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectIdCollection GetDataLink()
Public Overridable Function GetDataLink As ObjectIdCollection
public:
virtual ObjectIdCollection^ GetDataLink()


GetDataLink Method (row, column)

GetDataLink Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetDataLink(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetDataLink(
    int row,
    int column
)
Public Overridable Function GetDataLink ( _
    row As Integer, _
    column As Integer _
) As ObjectId
public:
virtual ObjectId GetDataLink(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetDataLink Method (range)

GetDataLink Method (range)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetDataLink(CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectIdCollection GetDataLink(
    CellRange range
)
Public Overridable Function GetDataLink ( _
    range As CellRange _
) As ObjectIdCollection
public:
virtual ObjectIdCollection^ GetDataLink(
    CellRange^ range
)
Parameters
range(CellRange)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetEnumerator()()()()
Members
Icon | Member | Description
 | GetEnumerator(TableEnumeratorOption) |
 | GetEnumerator()()()() |


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TableEnumerator GetEnumerator()
Public Function GetEnumerator As TableEnumerator
public:
TableEnumerator^ GetEnumerator()


GetEnumerator Method (option)

GetEnumerator Method (option)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetEnumerator(TableEnumeratorOption)
Declaration Syntax
C# Visual Basic Visual C++
public TableEnumerator GetEnumerator(
    TableEnumeratorOption option
)
Public Function GetEnumerator ( _
    option As TableEnumeratorOption _
) As TableEnumerator
public:
TableEnumerator^ GetEnumerator(
    TableEnumeratorOption option
)
Parameters
option(TableEnumeratorOption)


GetFieldId Method (row, column)

GetFieldId Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetFieldId(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetFieldId(
    int row,
    int column
)
Public Overridable Function GetFieldId ( _
    row As Integer, _
    column As Integer _
) As ObjectId
public:
virtual ObjectId GetFieldId(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetToolTip Method (row, column)

GetToolTip Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetToolTip(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetToolTip(
    int row,
    int column
)
Public Overridable Function GetToolTip ( _
    row As Integer, _
    column As Integer _
) As String
public:
virtual String^ GetToolTip(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetValue Method

GetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetValue()()()()
Members
Icon | Member | Description
 | GetValue(Int32, Int32, Int32, FormatOption) |
 | GetValue(Int32, Int32) |


GetValue Method (row, column)

GetValue Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetValue(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object GetValue(
    int row,
    int column
)
Public Overridable Function GetValue ( _
    row As Integer, _
    column As Integer _
) As Object
public:
virtual Object^ GetValue(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetValue Method (row, column, content, formatOption)

GetValue Method (row, column, content, formatOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetValue(Int32, Int32, Int32, FormatOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object GetValue(
    int row,
    int column,
    int content,
    FormatOption formatOption
)
Public Overridable Function GetValue ( _
    row As Integer, _
    column As Integer, _
    content As Integer, _
    formatOption As FormatOption _
) As Object
public:
virtual Object^ GetValue(
    int row,
    int column,
    int content,
    FormatOption formatOption
)
Parameters
row(Int32)
column(Int32)
content(Int32)
formatOption(FormatOption)


InsertColumn Method (index, columnsNumber)

InsertColumn Method (index, columnsNumber)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »InsertColumn(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int InsertColumn(
    int index,
    int columnsNumber
)
Public Overridable Function InsertColumn ( _
    index As Integer, _
    columnsNumber As Integer _
) As Integer
public:
virtual int InsertColumn(
    int index,
    int columnsNumber
)
Parameters
index(Int32)
columnsNumber(Int32)


InsertRow Method (index, rowsNumber)

InsertRow Method (index, rowsNumber)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »InsertRow(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int InsertRow(
    int index,
    int rowsNumber
)
Public Overridable Function InsertRow ( _
    index As Integer, _
    rowsNumber As Integer _
) As Integer
public:
virtual int InsertRow(
    int index,
    int rowsNumber
)
Parameters
index(Int32)
rowsNumber(Int32)


IsContentEditable Method (row, column)

IsContentEditable Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »IsContentEditable(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsContentEditable(
    int row,
    int column
)
Public Overridable Function IsContentEditable ( _
    row As Integer, _
    column As Integer _
) As Boolean
public:
virtual bool IsContentEditable(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


IsLinked Method (row, column)

IsLinked Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »IsLinked(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsLinked(
    int row,
    int column
)
Public Overridable Function IsLinked ( _
    row As Integer, _
    column As Integer _
) As Boolean
public:
virtual bool IsLinked(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


NumberOfColumns Property

NumberOfColumns Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »NumberOfColumns
Declaration Syntax
C# Visual Basic Visual C++
public virtual int NumberOfColumns { get; }
Public Overridable ReadOnly Property NumberOfColumns As Integer
    Get
public:
virtual property int NumberOfColumns {
    int get ();
}


NumberOfRows Property

NumberOfRows Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »NumberOfRows
Declaration Syntax
C# Visual Basic Visual C++
public virtual int NumberOfRows { get; }
Public Overridable ReadOnly Property NumberOfRows As Integer
    Get
public:
virtual property int NumberOfRows {
    int get ();
}


SetBlockAttributeValue Method (row, column, attributeDefinitionId, value)

SetBlockAttributeValue Method (row, column, attributeDefinitionId, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetBlockAttributeValue(Int32, Int32, ObjectId, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBlockAttributeValue(
    int row,
    int column,
    ObjectId attributeDefinitionId,
    string value
)
Public Overridable Sub SetBlockAttributeValue ( _
    row As Integer, _
    column As Integer, _
    attributeDefinitionId As ObjectId, _
    value As String _
)
public:
virtual void SetBlockAttributeValue(
    int row,
    int column,
    ObjectId attributeDefinitionId,
    String^ value
)
Parameters
row(Int32)
column(Int32)
attributeDefinitionId(ObjectId)
value(String)


SetBlockTableRecordId Method (row, column, value)

SetBlockTableRecordId Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetBlockTableRecordId(Int32, Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBlockTableRecordId(
    int row,
    int column,
    ObjectId value
)
Public Overridable Sub SetBlockTableRecordId ( _
    row As Integer, _
    column As Integer, _
    value As ObjectId _
)
public:
virtual void SetBlockTableRecordId(
    int row,
    int column,
    ObjectId value
)
Parameters
row(Int32)
column(Int32)
value(ObjectId)


SetCellState Method (row, column, value)

SetCellState Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetCellState(Int32, Int32, CellStates)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCellState(
    int row,
    int column,
    CellStates value
)
Public Overridable Sub SetCellState ( _
    row As Integer, _
    column As Integer, _
    value As CellStates _
)
public:
virtual void SetCellState(
    int row,
    int column,
    CellStates value
)
Parameters
row(Int32)
column(Int32)
value(CellStates)


SetColumnName Method (index, name)

SetColumnName Method (index, name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetColumnName(Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetColumnName(
    int index,
    string name
)
Public Overridable Sub SetColumnName ( _
    index As Integer, _
    name As String _
)
public:
virtual void SetColumnName(
    int index,
    String^ name
)
Parameters
index(Int32)
name(String)


SetCustomData Method (row, column, key, value)

SetCustomData Method (row, column, key, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetCustomData(Int32, Int32, String, Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCustomData(
    int row,
    int column,
    string key,
    Object value
)
Public Overridable Sub SetCustomData ( _
    row As Integer, _
    column As Integer, _
    key As String, _
    value As Object _
)
public:
virtual void SetCustomData(
    int row,
    int column,
    String^ key,
    Object^ value
)
Parameters
row(Int32)
column(Int32)
key(String)
value(Object)


SetDataFormat Method (row, column, format)

SetDataFormat Method (row, column, format)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetDataFormat(Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataFormat(
    int row,
    int column,
    string format
)
Public Overridable Sub SetDataFormat ( _
    row As Integer, _
    column As Integer, _
    format As String _
)
public:
virtual void SetDataFormat(
    int row,
    int column,
    String^ format
)
Parameters
row(Int32)
column(Int32)
format(String)


SetDataLink Method

SetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetDataLink()()()()
Members
Icon | Member | Description
 | SetDataLink(Int32, Int32, ObjectId, Boolean) |
 | SetDataLink(CellRange, ObjectId, Boolean) |


SetDataLink Method (row, column, dataLinkId, bUpdate)

SetDataLink Method (row, column, dataLinkId, bUpdate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetDataLink(Int32, Int32, ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataLink(
    int row,
    int column,
    ObjectId dataLinkId,
    bool bUpdate
)
Public Overridable Sub SetDataLink ( _
    row As Integer, _
    column As Integer, _
    dataLinkId As ObjectId, _
    bUpdate As Boolean _
)
public:
virtual void SetDataLink(
    int row,
    int column,
    ObjectId dataLinkId,
    bool bUpdate
)
Parameters
row(Int32)
column(Int32)
dataLinkId(ObjectId)
bUpdate(Boolean)


SetDataLink Method (range, dataLinkId, bUpdate)

SetDataLink Method (range, dataLinkId, bUpdate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetDataLink(CellRange, ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataLink(
    CellRange range,
    ObjectId dataLinkId,
    bool bUpdate
)
Public Overridable Sub SetDataLink ( _
    range As CellRange, _
    dataLinkId As ObjectId, _
    bUpdate As Boolean _
)
public:
virtual void SetDataLink(
    CellRange^ range,
    ObjectId dataLinkId,
    bool bUpdate
)
Parameters
range(CellRange)
dataLinkId(ObjectId)
bUpdate(Boolean)


SetDataType Method (row, column, dataType, unitType)

SetDataType Method (row, column, dataType, unitType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetDataType(Int32, Int32, DataType, UnitType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataType(
    int row,
    int column,
    DataType dataType,
    UnitType unitType
)
Public Overridable Sub SetDataType ( _
    row As Integer, _
    column As Integer, _
    dataType As DataType, _
    unitType As UnitType _
)
public:
virtual void SetDataType(
    int row,
    int column,
    DataType dataType,
    UnitType unitType
)
Parameters
row(Int32)
column(Int32)
dataType(DataType)
unitType(UnitType)


SetFieldId Method (row, column, value)

SetFieldId Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetFieldId(Int32, Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetFieldId(
    int row,
    int column,
    ObjectId value
)
Public Overridable Sub SetFieldId ( _
    row As Integer, _
    column As Integer, _
    value As ObjectId _
)
public:
virtual void SetFieldId(
    int row,
    int column,
    ObjectId value
)
Parameters
row(Int32)
column(Int32)
value(ObjectId)


SetSize Method (numRows, numCols)

SetSize Method (numRows, numCols)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetSize(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSize(
    int numRows,
    int numCols
)
Public Overridable Sub SetSize ( _
    numRows As Integer, _
    numCols As Integer _
)
public:
virtual void SetSize(
    int numRows,
    int numCols
)
Parameters
numRows(Int32)
numCols(Int32)


SetToolTip Method (row, column, value)

SetToolTip Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetToolTip(Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetToolTip(
    int row,
    int column,
    string value
)
Public Overridable Sub SetToolTip ( _
    row As Integer, _
    column As Integer, _
    value As String _
)
public:
virtual void SetToolTip(
    int row,
    int column,
    String^ value
)
Parameters
row(Int32)
column(Int32)
value(String)


SetValue Method

SetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetValue()()()()
Members
Icon | Member | Description
 | SetValue(Int32, Int32, Int32, Object, ParseOption) |
 | SetValue(Int32, Int32, Object) |


SetValue Method (row, column, content, value, parseOption)

SetValue Method (row, column, content, value, parseOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetValue(Int32, Int32, Int32, Object, ParseOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetValue(
    int row,
    int column,
    int content,
    Object value,
    ParseOption parseOption
)
Public Overridable Sub SetValue ( _
    row As Integer, _
    column As Integer, _
    content As Integer, _
    value As Object, _
    parseOption As ParseOption _
)
public:
virtual void SetValue(
    int row,
    int column,
    int content,
    Object^ value,
    ParseOption parseOption
)
Parameters
row(Int32)
column(Int32)
content(Int32)
value(Object)
parseOption(ParseOption)


SetValue Method (row, column, value)

SetValue Method (row, column, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetValue(Int32, Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetValue(
    int row,
    int column,
    Object value
)
Public Overridable Sub SetValue ( _
    row As Integer, _
    column As Integer, _
    value As Object _
)
public:
virtual void SetValue(
    int row,
    int column,
    Object^ value
)
Parameters
row(Int32)
column(Int32)
value(Object)


UnitType Method (row, column)

UnitType Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »UnitType(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual UnitType UnitType(
    int row,
    int column
)
Public Overridable Function UnitType ( _
    row As Integer, _
    column As Integer _
) As UnitType
public:
virtual UnitType UnitType(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


UpdateDataLink Method

UpdateDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »UpdateDataLink()()()()
Members
Icon | Member | Description
 | UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) |
 | UpdateDataLink(UpdateDirection, UpdateOption) |


UpdateDataLink Method (row, column, dir, option)

UpdateDataLink Method (row, column, dir, option)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UpdateDataLink(
    int row,
    int column,
    UpdateDirection dir,
    UpdateOption option
)
Public Overridable Sub UpdateDataLink ( _
    row As Integer, _
    column As Integer, _
    dir As UpdateDirection, _
    option As UpdateOption _
)
public:
virtual void UpdateDataLink(
    int row,
    int column,
    UpdateDirection dir,
    UpdateOption option
)
Parameters
row(Int32)
column(Int32)
dir(UpdateDirection)
option(UpdateOption)


UpdateDataLink Method (dir, option)

UpdateDataLink Method (dir, option)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »UpdateDataLink(UpdateDirection, UpdateOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UpdateDataLink(
    UpdateDirection dir,
    UpdateOption option
)
Public Overridable Sub UpdateDataLink ( _
    dir As UpdateDirection, _
    option As UpdateOption _
)
public:
virtual void UpdateDataLink(
    UpdateDirection dir,
    UpdateOption option
)
Parameters
dir(UpdateDirection)
option(UpdateOption)


LinkedTableEnumerator Class

LinkedTableEnumerator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LinkedTableEnumerator : TableEnumerator
Public NotInheritable Class LinkedTableEnumerator _
    Inherits TableEnumerator
public ref class LinkedTableEnumerator sealed : public TableEnumerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinkedTableEnumerator(LinkedTableData, TableEnumeratorOption) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumeratorCurrent | (Inherited from TableEnumerator.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() | (Overrides TableEnumerator.MoveNext()()()().)
 | Reset()()()() | (Overrides TableEnumerator.Reset()()()().)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | TableEnumerator
 |  | LinkedTableEnumerator


LinkedTableEnumerator Constructor (tab, eOpt)

LinkedTableEnumerator Constructor (tab, eOpt)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableEnumerator »LinkedTableEnumerator(LinkedTableData, TableEnumeratorOption)
Declaration Syntax
C# Visual Basic Visual C++
public LinkedTableEnumerator(
    LinkedTableData tab,
    TableEnumeratorOption eOpt
)
Public Sub New ( _
    tab As LinkedTableData, _
    eOpt As TableEnumeratorOption _
)
public:
LinkedTableEnumerator(
    LinkedTableData^ tab,
    TableEnumeratorOption eOpt
)
Parameters
tab(LinkedTableData)
eOpt(TableEnumeratorOption)


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool MoveNext()
Public Overrides NotOverridable Function MoveNext As Boolean
public:
virtual bool MoveNext() override sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed void Reset()
Public Overrides NotOverridable Sub Reset
public:
virtual void Reset() override sealed


LoftedSurface Class

LoftedSurface Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbLoftedSurface")]
public class LoftedSurface : Surface
<WrapperAttribute("AcDbLoftedSurface")> _
Public Class LoftedSurface _
    Inherits Surface
[WrapperAttribute(L"AcDbLoftedSurface")]
public ref class LoftedSurface : public Surface
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoftedSurface()()()() |
 | LoftedSurface(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BooleanIntersect(Surface) | (Inherited from Surface.)
 | BooleanIntersect(Solid3d) | (Inherited from Surface.)
 | BooleanSubtract(Surface) | (Inherited from Surface.)
 | BooleanSubtract(Solid3d) | (Inherited from Surface.)
 | BooleanUnion(Surface) | (Inherited from Surface.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ChamferEdges(array<SubentityId>[]()[][], SubentityId, Double, Double) | (Inherited from Surface.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToRegion()()()() | (Inherited from Surface.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateInterferenceObjects(Entity, Int32) | (Inherited from Surface.)
 | CreateLoftedSurface(array<Entity>[]()[][], array<Entity>[]()[][], Entity, LoftOptions) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateSectionObjects(Plane) | (Inherited from Surface.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FilletEdges(array<SubentityId>[]()[][], DoubleCollection, DoubleCollection, DoubleCollection) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetArea()()()() | (Inherited from Surface.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityColor(SubentityId) | (Inherited from Surface.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityMaterial(SubentityId) | (Inherited from Surface.)
 | GetSubentityMaterialMapper(SubentityId) | (Inherited from Surface.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | ImprintEntity(Entity) | (Inherited from Surface.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | ProjectOnToSurface(Entity, Vector3d) | (Inherited from Surface.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RayTest(Point3d, Vector3d, Double, array<SubentityId>[]()[][]%, DoubleCollection%) | (Inherited from Surface.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityColor(SubentityId, Color) | (Inherited from Surface.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetSubentityMaterial(SubentityId, ObjectId) | (Inherited from Surface.)
 | SetSubentityMaterialMapper(SubentityId, Mapper) | (Inherited from Surface.)
 | SliceByPlane(Plane) | (Inherited from Surface.)
 | SliceBySurface(Surface) | (Inherited from Surface.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thicken(Double, Boolean) | (Inherited from Surface.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | UIsoLineDensity | (Inherited from Surface.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VIsoLineDensity | (Inherited from Surface.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Surface
 |  |  |  |  |  |  |  | LoftedSurface


LoftedSurface Constructor

LoftedSurface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »LoftedSurface()()()()
Members
Icon | Member | Description
 | LoftedSurface()()()() |
 | LoftedSurface(IntPtr, Boolean) |


LoftedSurface Constructor

LoftedSurface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »LoftedSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LoftedSurface()
Public Sub New
public:
LoftedSurface()


LoftedSurface Constructor (unmanagedPointer, autoDelete)

LoftedSurface Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »LoftedSurface(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LoftedSurface(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
LoftedSurface(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


CreateLoftedSurface Method (crossSections, guideCurves, pathCurve, loftOptions)

CreateLoftedSurface Method (crossSections, guideCurves, pathCurve, loftOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »CreateLoftedSurface(array<Entity>[]()[][], array<Entity>[]()[][], Entity, LoftOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateLoftedSurface(
    Entity[] crossSections,
    Entity[] guideCurves,
    Entity pathCurve,
    LoftOptions loftOptions
)
Public Overridable Sub CreateLoftedSurface ( _
    crossSections As Entity(), _
    guideCurves As Entity(), _
    pathCurve As Entity, _
    loftOptions As LoftOptions _
)
public:
virtual void CreateLoftedSurface(
    array<Entity^>^ crossSections,
    array<Entity^>^ guideCurves,
    Entity^ pathCurve,
    LoftOptions^ loftOptions
)
Parameters
crossSections(array< Entity >[]()[][])
guideCurves(array< Entity >[]()[][])
pathCurve(Entity)
loftOptions(LoftOptions)


LoftOptions Class

LoftOptions Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbLoftOptions")]
public class LoftOptions : DisposableWrapper,
    ICloneable
<WrapperAttribute("ZcDbLoftOptions")> _
Public Class LoftOptions _
    Inherits DisposableWrapper _
    Implements ICloneable
[WrapperAttribute(L"ZcDbLoftOptions")]
public ref class LoftOptions : public DisposableWrapper,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoftOptions(LoftOptions) |
 | LoftOptions()()()() |
 | LoftOptions(IntPtr, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CheckCrossSectionCurves(array<Entity>[]()[][], Boolean) |
 | CheckGuideCurves(array<Entity>[]()[][], Boolean) |
 | CheckLoftCurves(array<Entity>[]()[][], array<Entity>[]()[][], Entity, Boolean) |
 | CheckPathCurve(Entity, Boolean) |
 | Clone()()()() |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | LoftOptions


LoftOptions Constructor

LoftOptions Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »LoftOptions()()()()
Members
Icon | Member | Description
 | LoftOptions(LoftOptions) |
 | LoftOptions()()()() |
 | LoftOptions(IntPtr, Boolean) |


LoftOptions Constructor

LoftOptions Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »LoftOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LoftOptions()
Public Sub New
public:
LoftOptions()


LoftOptions Constructor (unmanagedPointer, autoDelete)

LoftOptions Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »LoftOptions(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LoftOptions(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
LoftOptions(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


LoftOptions Constructor (opts)

LoftOptions Constructor (opts)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »LoftOptions(LoftOptions)
Declaration Syntax
C# Visual Basic Visual C++
public LoftOptions(
    LoftOptions opts
)
Public Sub New ( _
    opts As LoftOptions _
)
public:
LoftOptions(
    LoftOptions^ opts
)
Parameters
opts(LoftOptions)


CheckCrossSectionCurves Method (crossSectionCurves, displayErrorMessages)

CheckCrossSectionCurves Method (crossSectionCurves, displayErrorMessages)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »CheckCrossSectionCurves(array<Entity>[]()[][], Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public LoftOptionsCheckCurvesOut CheckCrossSectionCurves(
    Entity[] crossSectionCurves,
    bool displayErrorMessages
)
Public Function CheckCrossSectionCurves ( _
    crossSectionCurves As Entity(), _
    displayErrorMessages As Boolean _
) As LoftOptionsCheckCurvesOut
public:
LoftOptionsCheckCurvesOut^ CheckCrossSectionCurves(
    array<Entity^>^ crossSectionCurves,
    bool displayErrorMessages
)
Parameters
crossSectionCurves(array< Entity >[]()[][])
displayErrorMessages(Boolean)


CheckGuideCurves Method (guideCurves, displayErrorMessages)

CheckGuideCurves Method (guideCurves, displayErrorMessages)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »CheckGuideCurves(array<Entity>[]()[][], Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void CheckGuideCurves(
    Entity[] guideCurves,
    bool displayErrorMessages
)
Public Sub CheckGuideCurves ( _
    guideCurves As Entity(), _
    displayErrorMessages As Boolean _
)
public:
void CheckGuideCurves(
    array<Entity^>^ guideCurves,
    bool displayErrorMessages
)
Parameters
guideCurves(array< Entity >[]()[][])
displayErrorMessages(Boolean)


CheckLoftCurves Method (crossSectionCurves, guideCurves, pPathCurve, displayErrorMessages)

CheckLoftCurves Method (crossSectionCurves, guideCurves, pPathCurve, displayErrorMessages)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »CheckLoftCurves(array<Entity>[]()[][], array<Entity>[]()[][], Entity, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public LoftOptionsCheckCurvesOut CheckLoftCurves(
    Entity[] crossSectionCurves,
    Entity[] guideCurves,
    Entity pPathCurve,
    bool displayErrorMessages
)
Public Function CheckLoftCurves ( _
    crossSectionCurves As Entity(), _
    guideCurves As Entity(), _
    pPathCurve As Entity, _
    displayErrorMessages As Boolean _
) As LoftOptionsCheckCurvesOut
public:
LoftOptionsCheckCurvesOut^ CheckLoftCurves(
    array<Entity^>^ crossSectionCurves,
    array<Entity^>^ guideCurves,
    Entity^ pPathCurve,
    bool displayErrorMessages
)
Parameters
crossSectionCurves(array< Entity >[]()[][])
guideCurves(array< Entity >[]()[][])
pPathCurve(Entity)
displayErrorMessages(Boolean)


CheckPathCurve Method (pathCurve, displayErrorMessages)

CheckPathCurve Method (pathCurve, displayErrorMessages)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »CheckPathCurve(Entity, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void CheckPathCurve(
    Entity pathCurve,
    bool displayErrorMessages
)
Public Sub CheckPathCurve ( _
    pathCurve As Entity, _
    displayErrorMessages As Boolean _
)
public:
void CheckPathCurve(
    Entity^ pathCurve,
    bool displayErrorMessages
)
Parameters
pathCurve(Entity)
displayErrorMessages(Boolean)


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override sealed void DeleteUnmanagedObject()
Protected Overrides NotOverridable Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override sealed


LoftOptionsBuilder Class

LoftOptionsBuilder Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsBuilder
Declaration Syntax
C# Visual Basic Visual C++
public class LoftOptionsBuilder
Public Class LoftOptionsBuilder
public ref class LoftOptionsBuilder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LoftOptionsBuilder(LoftOptions) |
 | LoftOptionsBuilder()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetOptionsFromSysvars(Database) |
 | ToLoftOptions()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LoftOptionsBuilder


LoftOptionsBuilder Constructor

LoftOptionsBuilder Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsBuilder »LoftOptionsBuilder()()()()
Members
Icon | Member | Description
 | LoftOptionsBuilder(LoftOptions) |
 | LoftOptionsBuilder()()()() |


LoftOptionsBuilder Constructor

LoftOptionsBuilder Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsBuilder »LoftOptionsBuilder()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LoftOptionsBuilder()
Public Sub New
public:
LoftOptionsBuilder()


LoftOptionsBuilder Constructor (value)

LoftOptionsBuilder Constructor (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsBuilder »LoftOptionsBuilder(LoftOptions)
Declaration Syntax
C# Visual Basic Visual C++
public LoftOptionsBuilder(
    LoftOptions value
)
Public Sub New ( _
    value As LoftOptions _
)
public:
LoftOptionsBuilder(
    LoftOptions^ value
)
Parameters
value(LoftOptions)


SetOptionsFromSysvars Method (pDb)

SetOptionsFromSysvars Method (pDb)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsBuilder »SetOptionsFromSysvars(Database)
Declaration Syntax
C# Visual Basic Visual C++
public void SetOptionsFromSysvars(
    Database pDb
)
Public Sub SetOptionsFromSysvars ( _
    pDb As Database _
)
public:
void SetOptionsFromSysvars(
    Database^ pDb
)
Parameters
pDb(Database)


ToLoftOptions Method

ToLoftOptions Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsBuilder »ToLoftOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LoftOptions ToLoftOptions()
Public Function ToLoftOptions As LoftOptions
public:
LoftOptions^ ToLoftOptions()


LoftOptionsCheckCurvesOut Class

LoftOptionsCheckCurvesOut Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsCheckCurvesOut
Declaration Syntax
C# Visual Basic Visual C++
public class LoftOptionsCheckCurvesOut
Public Class LoftOptionsCheckCurvesOut
public ref class LoftOptionsCheckCurvesOut
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoftOptionsCheckCurvesOut()()()() |
 | AllClosed |
 | AllOpen |
 | AllPlanar |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LoftOptionsCheckCurvesOut


LoftOptionsCheckCurvesOut Constructor

LoftOptionsCheckCurvesOut Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsCheckCurvesOut »LoftOptionsCheckCurvesOut()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LoftOptionsCheckCurvesOut()
Public Sub New
public:
LoftOptionsCheckCurvesOut()


AllClosed Property

AllClosed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsCheckCurvesOut »AllClosed
Declaration Syntax
C# Visual Basic Visual C++
public bool AllClosed { get; }
Public ReadOnly Property AllClosed As Boolean
    Get
public:
property bool AllClosed {
    bool get ();
}


AllOpen Property

AllOpen Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsCheckCurvesOut »AllOpen
Declaration Syntax
C# Visual Basic Visual C++
public bool AllOpen { get; }
Public ReadOnly Property AllOpen As Boolean
    Get
public:
property bool AllOpen {
    bool get ();
}


AllPlanar Property

AllPlanar Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsCheckCurvesOut »AllPlanar
Declaration Syntax
C# Visual Basic Visual C++
public bool AllPlanar { get; }
Public ReadOnly Property AllPlanar As Boolean
    Get
public:
property bool AllPlanar {
    bool get ();
}


LoftOptionsNormalOption Enumeration

LoftOptionsNormalOption Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptionsNormalOption
Declaration Syntax
C# Visual Basic Visual C++
public enum LoftOptionsNormalOption
Public Enumeration LoftOptionsNormalOption
public enum class LoftOptionsNormalOption
Members
Member | Description
UseDraftAngles |
AllNormal |
EndsNormal |
LastNormal |
FirstNormal |
NoNormal |


MaintenanceReleaseVersion Enumeration

MaintenanceReleaseVersion Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MaintenanceReleaseVersion
Declaration Syntax
C# Visual Basic Visual C++
public enum MaintenanceReleaseVersion
Public Enumeration MaintenanceReleaseVersion
public enum class MaintenanceReleaseVersion
Members
Member | Description
ReleaseMax |
ReleaseKnown |
ReleaseCurrent |
Release49 |
Release48 |
Release47 |
Release46 |
Release45 |
Release44 |
Release43 |
Release42 |
Release41 |
Release40 |
Release39 |
Release38 |
Release37 |
Release36 |
Release35 |
Release34 |
Release33 |
Release32 |
Release31 |
Release30 |
Release29 |
Release28 |
Release27 |
Release26 |
Release25 |
Release24 |
Release23 |
Release22 |
Release21 |
Release20 |
Release19 |
Release18 |
Release17 |
Release16 |
Release15 |
Release14 |
Release13 |
Release12 |
Release11 |
Release10 |
Release9 |
Release8 |
Release7 |
Release6 |
Release5 |
Release4 |
Release3 |
Release2 |
Release1 |
Release0 |


MatchProperties Class

MatchProperties Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MatchProperties
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbMatchProperties")]
public class MatchProperties : RXObject
<WrapperAttribute("AcDbMatchProperties")> _
Public Class MatchProperties _
    Inherits RXObject
[WrapperAttribute(L"AcDbMatchProperties")]
public ref class MatchProperties : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MatchProperties(IntPtr, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyProperties(Entity, Entity, Int32) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | MatchProperties


MatchProperties Constructor (unmanagedPointer, autoDelete)

MatchProperties Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MatchProperties »MatchProperties(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal MatchProperties(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
MatchProperties(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


CopyProperties Method (sourceEntity, targetEntity, flag)

CopyProperties Method (sourceEntity, targetEntity, flag)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MatchProperties »CopyProperties(Entity, Entity, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyProperties(
    Entity sourceEntity,
    Entity targetEntity,
    int flag
)
Public Overridable Sub CopyProperties ( _
    sourceEntity As Entity, _
    targetEntity As Entity, _
    flag As Integer _
)
public:
virtual void CopyProperties(
    Entity^ sourceEntity,
    Entity^ targetEntity,
    int flag
)
Parameters
sourceEntity(Entity)
targetEntity(Entity)
flag(Int32)


Material Class

Material Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Material
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbMaterial")]
public class Material : DBObject
<WrapperAttribute("AcDbMaterial")> _
Public Class Material _
    Inherits DBObject
[WrapperAttribute(L"AcDbMaterial")]
public ref class Material : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Material()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Material


Material Constructor

Material Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Material »Material()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Material()
Public Sub New
public:
Material()


MeasurementValue Enumeration

MeasurementValue Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MeasurementValue
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::MeasurementValue")]
public enum MeasurementValue
<WrapperAttribute("ZcDb::MeasurementValue")> _
Public Enumeration MeasurementValue
[WrapperAttribute(L"ZcDb::MeasurementValue")]
public enum class MeasurementValue
Members
Member | Description
Metric |
English |


MergeCellStyleOption Enumeration

MergeCellStyleOption Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MergeCellStyleOption
Declaration Syntax
C# Visual Basic Visual C++
public enum MergeCellStyleOption
Public Enumeration MergeCellStyleOption
public enum class MergeCellStyleOption
Members
Member | Description
None |
OverwriteDuplicates |
IgnoreNewStyles |
CopyDuplicates |
ConvertDuplicatesToOverrrides |


MeshPointMap Structure

MeshPointMap Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MeshPointMap
Declaration Syntax
C# Visual Basic Visual C++
public struct MeshPointMap
Public Structure MeshPointMap
public value class MeshPointMap
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MeshPointMap(Point2d, Point2d) |
 | DestPoint |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SourcePoint |
 | ToString()()()() | (Inherited from ValueType.)


MeshPointMap Constructor (sourcePt, destPt)

MeshPointMap Constructor (sourcePt, destPt)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MeshPointMap »MeshPointMap(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public MeshPointMap(
    Point2d sourcePt,
    Point2d destPt
)
Public Sub New ( _
    sourcePt As Point2d, _
    destPt As Point2d _
)
public:
MeshPointMap(
    Point2d sourcePt,
    Point2d destPt
)
Parameters
sourcePt(Point2d)
destPt(Point2d)


DestPoint Property

DestPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MeshPointMap »DestPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d DestPoint { get; set; }
Public Property DestPoint As Point2d
    Get
    Set
public:
property Point2d DestPoint {
    Point2d get ();
    void set (Point2d value);
}


SourcePoint Property

SourcePoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MeshPointMap »SourcePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d SourcePoint { get; set; }
Public Property SourcePoint As Point2d
    Get
    Set
public:
property Point2d SourcePoint {
    Point2d get ();
    void set (Point2d value);
}


MeshPointMaps Structure

MeshPointMaps Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MeshPointMaps
Declaration Syntax
C# Visual Basic Visual C++
public struct MeshPointMaps
Public Structure MeshPointMaps
public value class MeshPointMaps
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MeshPointMaps(Point2dCollection, Point2dCollection) |
 | DestPonints |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SourcePonints |
 | ToString()()()() | (Inherited from ValueType.)


MeshPointMaps Constructor (sourcePts, destPts)

MeshPointMaps Constructor (sourcePts, destPts)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MeshPointMaps »MeshPointMaps(Point2dCollection, Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MeshPointMaps(
    Point2dCollection sourcePts,
    Point2dCollection destPts
)
Public Sub New ( _
    sourcePts As Point2dCollection, _
    destPts As Point2dCollection _
)
public:
MeshPointMaps(
    Point2dCollection^ sourcePts,
    Point2dCollection^ destPts
)
Parameters
sourcePts(Point2dCollection)
destPts(Point2dCollection)


DestPonints Property

DestPonints Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MeshPointMaps »DestPonints
Declaration Syntax
C# Visual Basic Visual C++
public Point2dCollection DestPonints { get; set; }
Public Property DestPonints As Point2dCollection
    Get
    Set
public:
property Point2dCollection^ DestPonints {
    Point2dCollection^ get ();
    void set (Point2dCollection^ value);
}


SourcePonints Property

SourcePonints Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MeshPointMaps »SourcePonints
Declaration Syntax
C# Visual Basic Visual C++
public Point2dCollection SourcePonints { get; set; }
Public Property SourcePonints As Point2dCollection
    Get
    Set
public:
property Point2dCollection^ SourcePonints {
    Point2dCollection^ get ();
    void set (Point2dCollection^ value);
}


MInsertBlock Class

MInsertBlock Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbMInsertBlock")]
public class MInsertBlock : BlockReference
<WrapperAttribute("AcDbMInsertBlock")> _
Public Class MInsertBlock _
    Inherits BlockReference
[WrapperAttribute(L"AcDbMInsertBlock")]
public ref class MInsertBlock : public BlockReference
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MInsertBlock(Point3d, ObjectId, Int16, Int16, Double, Double) |
 | MInsertBlock()()()() |
 | MInsertBlock(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | AnonymousBlockTableRecord | (Inherited from BlockReference.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | AttributeCollection | (Inherited from BlockReference.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BlockTableRecord | (Inherited from BlockReference.)
 | BlockTransform | (Inherited from BlockReference.)
 | BlockUnit | (Inherited from BlockReference.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | Columns |
 | ColumnSpacing |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToStaticBlock(String) | (Inherited from BlockReference.)
 | ConvertToStaticBlock()()()() | (Inherited from BlockReference.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from BlockReference.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicBlockReferencePropertyCollection | (Inherited from BlockReference.)
 | DynamicBlockTableRecord | (Inherited from BlockReference.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExplodeToOwnerSpace()()()() | (Inherited from BlockReference.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeometryExtentsBestFit(Matrix3d) | (Inherited from BlockReference.)
 | GeometryExtentsBestFit()()()() | (Inherited from BlockReference.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsDynamicBlock | (Inherited from BlockReference.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Name | (Inherited from BlockReference.)
 | Normal | (Inherited from BlockReference.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position | (Inherited from BlockReference.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetBlock()()()() | (Inherited from BlockReference.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation | (Inherited from BlockReference.)
 | Rows |
 | RowSpacing |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | ScaleFactors | (Inherited from BlockReference.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | TreatAsBlockRefForExplode | (Inherited from BlockReference.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnitFactor | (Inherited from BlockReference.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | BlockReference
 |  |  |  |  |  |  |  | MInsertBlock


MInsertBlock Constructor

MInsertBlock Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »MInsertBlock()()()()
Members
Icon | Member | Description
 | MInsertBlock(Point3d, ObjectId, Int16, Int16, Double, Double) |
 | MInsertBlock()()()() |
 | MInsertBlock(IntPtr, Boolean) |


MInsertBlock Constructor

MInsertBlock Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »MInsertBlock()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MInsertBlock()
Public Sub New
public:
MInsertBlock()


MInsertBlock Constructor (unmanagedObjPtr, autoDelete)

MInsertBlock Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »MInsertBlock(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal MInsertBlock(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
MInsertBlock(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


MInsertBlock Constructor (position, blockTableRecord, columns, rows, colSpacing, rowSpacing)

MInsertBlock Constructor (position, blockTableRecord, columns, rows, colSpacing, rowSpacing)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »MInsertBlock(Point3d, ObjectId, Int16, Int16, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public MInsertBlock(
    Point3d position,
    ObjectId blockTableRecord,
    short columns,
    short rows,
    double colSpacing,
    double rowSpacing
)
Public Sub New ( _
    position As Point3d, _
    blockTableRecord As ObjectId, _
    columns As Short, _
    rows As Short, _
    colSpacing As Double, _
    rowSpacing As Double _
)
public:
MInsertBlock(
    Point3d position,
    ObjectId blockTableRecord,
    short columns,
    short rows,
    double colSpacing,
    double rowSpacing
)
Parameters
position(Point3d)
blockTableRecord(ObjectId)
columns(Int16)
rows(Int16)
colSpacing(Double)
rowSpacing(Double)


Columns Property

Columns Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »Columns
Declaration Syntax
C# Visual Basic Visual C++
public short Columns { get; set; }
Public Property Columns As Short
    Get
    Set
public:
property short Columns {
    short get ();
    void set (short value);
}


ColumnSpacing Property

ColumnSpacing Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »ColumnSpacing
Declaration Syntax
C# Visual Basic Visual C++
public double ColumnSpacing { get; set; }
Public Property ColumnSpacing As Double
    Get
    Set
public:
property double ColumnSpacing {
    double get ();
    void set (double value);
}


Rows Property

Rows Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »Rows
Declaration Syntax
C# Visual Basic Visual C++
public short Rows { get; set; }
Public Property Rows As Short
    Get
    Set
public:
property short Rows {
    short get ();
    void set (short value);
}


RowSpacing Property

RowSpacing Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »RowSpacing
Declaration Syntax
C# Visual Basic Visual C++
public double RowSpacing { get; set; }
Public Property RowSpacing As Double
    Get
    Set
public:
property double RowSpacing {
    double get ();
    void set (double value);
}


MLeader Class

MLeader Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbMLeader")]
public class MLeader : Entity
<WrapperAttribute("AcDbMLeader")> _
Public Class MLeader _
    Inherits Entity
[WrapperAttribute(L"AcDbMLeader")]
public ref class MLeader : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MLeader()()()() |
 | MLeader(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddFirstVertex(Int32, Point3d) |
 | AddLastVertex(Int32, Point3d) |
 | AddLeader()()()() |
 | AddLeaderLine(Int32) |
 | AddLeaderLine(Point3d) |
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | ArrowSize |
 | ArrowSymbolId |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockColor |
 | BlockConnectionType |
 | BlockContentId |
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BlockPosition |
 | BlockRotation |
 | BlockScale |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConnectionPoint(Vector3d, TextAttachmentDirection) |
 | ConnectionPoint(Vector3d) |
 | ContentType |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DoglegLength |
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EnableAnnotationScale |
 | EnableDogleg |
 | EnableFrameText |
 | EnableLanding |
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetArrowSize(Int32) |
 | GetArrowSymbolId(Int32) |
 | GetBlockAttribute(ObjectId) |
 | GetContentGeomExtents()()()() |
 | getContextDataManager()()()() |
 | GetDogleg(Int32) |
 | GetDoglegLength(Int32) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstVertex(Int32) |
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLastVertex(Int32) |
 | GetLeaderIndex(Int32) |
 | GetLeaderIndexes()()()() |
 | GetLeaderLineColor(Int32) |
 | GetLeaderLineIndexes(Int32) |
 | GetLeaderLineType(Int32) |
 | GetLeaderLineTypeId(Int32) |
 | GetLeaderLineWeight(Int32) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | getOverridedMLeaderStyle(MLeaderStyle) |
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Overrides Entity.GetPlane()()()().)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTextAttachmentType(LeaderDirectionType) |
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetVertex(Int32, Int32) |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContent()()()() |
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | LandingGap |
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | LeaderCount | Obsolete.
 | LeaderLineColor |
 | LeaderLineCount | Obsolete.
 | LeaderLineType |
 | LeaderLineTypeId |
 | LeaderLineWeight |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | MLeaderStyle |
 | MLeaderText |
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveMLeader(Vector3d, MoveType) |
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MText |
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | PostMLeaderToDb(Database) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | recomputeBreakPoints()()()() |
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemoveFirstVertex(Int32) |
 | RemoveLastVertex(Int32) |
 | RemoveLeader(Int32) |
 | RemoveLeaderLine(Int32) |
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetArrowSize(Int32, Double) |
 | SetArrowSymbolId(Int32, ObjectId) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetBlockAttribute(ObjectId, AttributeReference) |
 | SetContextDataManager(IntPtr) |
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDogleg(Int32, Vector3d) |
 | SetDoglegLength(Int32, Double) |
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFirstVertex(Int32, Point3d) |
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLastVertex(Int32, Point3d) |
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetLeaderLineColor(Int32, Color) |
 | SetLeaderLineType(Int32, LeaderType) |
 | SetLeaderLineTypeId(Int32, ObjectId) |
 | SetLeaderLineWeight(Int32, LineWeight) |
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPlane(Plane) |
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetTextAttachmentType(TextAttachmentType, LeaderDirectionType) |
 | SetVertex(Int32, Int32, Point3d) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAlignmentType |
 | TextAngleType |
 | TextAttachmentDirection |
 | TextAttachmentType |
 | TextColor |
 | TextHeight |
 | TextLocation |
 | TextStyleId |
 | ToleranceLocation |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VerticesCount(Int32) |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | MLeader


MLeader Constructor

MLeader Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »MLeader()()()()
Members
Icon | Member | Description
 | MLeader()()()() |
 | MLeader(IntPtr, Boolean) |


MLeader Constructor

MLeader Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »MLeader()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MLeader()
Public Sub New
public:
MLeader()


MLeader Constructor (unmanagedObjPtr, autoDelete)

MLeader Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »MLeader(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal MLeader(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
MLeader(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AddFirstVertex Method (leaderLineIndex, point)

AddFirstVertex Method (leaderLineIndex, point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »AddFirstVertex(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void AddFirstVertex(
    int leaderLineIndex,
    Point3d point
)
Public Sub AddFirstVertex ( _
    leaderLineIndex As Integer, _
    point As Point3d _
)
public:
void AddFirstVertex(
    int leaderLineIndex,
    Point3d point
)
Parameters
leaderLineIndex(Int32)
point(Point3d)


AddLastVertex Method (leaderLineIndex, point)

AddLastVertex Method (leaderLineIndex, point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »AddLastVertex(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void AddLastVertex(
    int leaderLineIndex,
    Point3d point
)
Public Sub AddLastVertex ( _
    leaderLineIndex As Integer, _
    point As Point3d _
)
public:
void AddLastVertex(
    int leaderLineIndex,
    Point3d point
)
Parameters
leaderLineIndex(Int32)
point(Point3d)


AddLeader Method

AddLeader Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »AddLeader()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int AddLeader()
Public Function AddLeader As Integer
public:
int AddLeader()


AddLeaderLine Method

AddLeaderLine Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »AddLeaderLine()()()()
Members
Icon | Member | Description
 | AddLeaderLine(Int32) |
 | AddLeaderLine(Point3d) |


AddLeaderLine Method (leaderIndex)

AddLeaderLine Method (leaderIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »AddLeaderLine(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int AddLeaderLine(
    int leaderIndex
)
Public Function AddLeaderLine ( _
    leaderIndex As Integer _
) As Integer
public:
int AddLeaderLine(
    int leaderIndex
)
Parameters
leaderIndex(Int32)


AddLeaderLine Method (point)

AddLeaderLine Method (point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »AddLeaderLine(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public int AddLeaderLine(
    Point3d point
)
Public Function AddLeaderLine ( _
    point As Point3d _
) As Integer
public:
int AddLeaderLine(
    Point3d point
)
Parameters
point(Point3d)


ArrowSize Property

ArrowSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »ArrowSize
Declaration Syntax
C# Visual Basic Visual C++
public double ArrowSize { get; set; }
Public Property ArrowSize As Double
    Get
    Set
public:
property double ArrowSize {
    double get ();
    void set (double value);
}


ArrowSymbolId Property

ArrowSymbolId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »ArrowSymbolId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ArrowSymbolId { get; set; }
Public Property ArrowSymbolId As ObjectId
    Get
    Set
public:
property ObjectId ArrowSymbolId {
    ObjectId get ();
    void set (ObjectId value);
}


BlockColor Property

BlockColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »BlockColor
Declaration Syntax
C# Visual Basic Visual C++
public Color BlockColor { get; set; }
Public Property BlockColor As Color
    Get
    Set
public:
property Color^ BlockColor {
    Color^ get ();
    void set (Color^ value);
}


BlockConnectionType Property

BlockConnectionType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »BlockConnectionType
Declaration Syntax
C# Visual Basic Visual C++
public BlockConnectionType BlockConnectionType { get; set; }
Public Property BlockConnectionType As BlockConnectionType
    Get
    Set
public:
property BlockConnectionType BlockConnectionType {
    BlockConnectionType get ();
    void set (BlockConnectionType value);
}


BlockContentId Property

BlockContentId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »BlockContentId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockContentId { get; set; }
Public Property BlockContentId As ObjectId
    Get
    Set
public:
property ObjectId BlockContentId {
    ObjectId get ();
    void set (ObjectId value);
}


BlockPosition Property

BlockPosition Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »BlockPosition
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BlockPosition { get; set; }
Public Property BlockPosition As Point3d
    Get
    Set
public:
property Point3d BlockPosition {
    Point3d get ();
    void set (Point3d value);
}


BlockRotation Property

BlockRotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »BlockRotation
Declaration Syntax
C# Visual Basic Visual C++
public double BlockRotation { get; set; }
Public Property BlockRotation As Double
    Get
    Set
public:
property double BlockRotation {
    double get ();
    void set (double value);
}


BlockScale Property

BlockScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »BlockScale
Declaration Syntax
C# Visual Basic Visual C++
public Scale3d BlockScale { get; set; }
Public Property BlockScale As Scale3d
    Get
    Set
public:
property Scale3d BlockScale {
    Scale3d get ();
    void set (Scale3d value);
}


ConnectionPoint Method

ConnectionPoint Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »ConnectionPoint()()()()
Members
Icon | Member | Description
 | ConnectionPoint(Vector3d, TextAttachmentDirection) |
 | ConnectionPoint(Vector3d) |


ConnectionPoint Method (direction)

ConnectionPoint Method (direction)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »ConnectionPoint(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ConnectionPoint(
    Vector3d direction
)
Public Function ConnectionPoint ( _
    direction As Vector3d _
) As Point3d
public:
Point3d ConnectionPoint(
    Vector3d direction
)
Parameters
direction(Vector3d)


ConnectionPoint Method (direction, attachDirection)

ConnectionPoint Method (direction, attachDirection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »ConnectionPoint(Vector3d, TextAttachmentDirection)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ConnectionPoint(
    Vector3d direction,
    TextAttachmentDirection attachDirection
)
Public Function ConnectionPoint ( _
    direction As Vector3d, _
    attachDirection As TextAttachmentDirection _
) As Point3d
public:
Point3d ConnectionPoint(
    Vector3d direction,
    TextAttachmentDirection attachDirection
)
Parameters
direction(Vector3d)
attachDirection(TextAttachmentDirection)


ContentType Property

ContentType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »ContentType
Declaration Syntax
C# Visual Basic Visual C++
public ContentType ContentType { get; set; }
Public Property ContentType As ContentType
    Get
    Set
public:
property ContentType ContentType {
    ContentType get ();
    void set (ContentType value);
}


DoglegLength Property

DoglegLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »DoglegLength
Declaration Syntax
C# Visual Basic Visual C++
public double DoglegLength { get; set; }
Public Property DoglegLength As Double
    Get
    Set
public:
property double DoglegLength {
    double get ();
    void set (double value);
}


EnableAnnotationScale Property

EnableAnnotationScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »EnableAnnotationScale
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableAnnotationScale { get; set; }
Public Property EnableAnnotationScale As Boolean
    Get
    Set
public:
property bool EnableAnnotationScale {
    bool get ();
    void set (bool value);
}


EnableDogleg Property

EnableDogleg Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »EnableDogleg
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableDogleg { get; set; }
Public Property EnableDogleg As Boolean
    Get
    Set
public:
property bool EnableDogleg {
    bool get ();
    void set (bool value);
}


EnableFrameText Property

EnableFrameText Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »EnableFrameText
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableFrameText { get; set; }
Public Property EnableFrameText As Boolean
    Get
    Set
public:
property bool EnableFrameText {
    bool get ();
    void set (bool value);
}


EnableLanding Property

EnableLanding Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »EnableLanding
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableLanding { get; set; }
Public Property EnableLanding As Boolean
    Get
    Set
public:
property bool EnableLanding {
    bool get ();
    void set (bool value);
}


GetArrowSize Method (leaderLineIndex)

GetArrowSize Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetArrowSize(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetArrowSize(
    int leaderLineIndex
)
Public Function GetArrowSize ( _
    leaderLineIndex As Integer _
) As Double
public:
double GetArrowSize(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


GetArrowSymbolId Method (leaderLineIndex)

GetArrowSymbolId Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetArrowSymbolId(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetArrowSymbolId(
    int leaderLineIndex
)
Public Function GetArrowSymbolId ( _
    leaderLineIndex As Integer _
) As ObjectId
public:
ObjectId GetArrowSymbolId(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


GetBlockAttribute Method (attDefId)

GetBlockAttribute Method (attDefId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetBlockAttribute(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public AttributeReference GetBlockAttribute(
    ObjectId attDefId
)
Public Function GetBlockAttribute ( _
    attDefId As ObjectId _
) As AttributeReference
public:
AttributeReference^ GetBlockAttribute(
    ObjectId attDefId
)
Parameters
attDefId(ObjectId)


GetContentGeomExtents Method

GetContentGeomExtents Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetContentGeomExtents()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Extents3d GetContentGeomExtents()
Public Function GetContentGeomExtents As Extents3d
public:
Extents3d GetContentGeomExtents()


getContextDataManager Method

getContextDataManager Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »getContextDataManager()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr getContextDataManager()
Public Function getContextDataManager As IntPtr
public:
IntPtr getContextDataManager()


GetDogleg Method (leaderIndex)

GetDogleg Method (leaderIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetDogleg(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetDogleg(
    int leaderIndex
)
Public Function GetDogleg ( _
    leaderIndex As Integer _
) As Vector3d
public:
Vector3d GetDogleg(
    int leaderIndex
)
Parameters
leaderIndex(Int32)


GetDoglegLength Method (leaderIndex)

GetDoglegLength Method (leaderIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetDoglegLength(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetDoglegLength(
    int leaderIndex
)
Public Function GetDoglegLength ( _
    leaderIndex As Integer _
) As Double
public:
double GetDoglegLength(
    int leaderIndex
)
Parameters
leaderIndex(Int32)


GetFirstVertex Method (leaderLineIndex)

GetFirstVertex Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetFirstVertex(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetFirstVertex(
    int leaderLineIndex
)
Public Function GetFirstVertex ( _
    leaderLineIndex As Integer _
) As Point3d
public:
Point3d GetFirstVertex(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


GetLastVertex Method (leaderLineIndex)

GetLastVertex Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetLastVertex(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetLastVertex(
    int leaderLineIndex
)
Public Function GetLastVertex ( _
    leaderLineIndex As Integer _
) As Point3d
public:
Point3d GetLastVertex(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


GetLeaderIndex Method (leaderLineIndex)

GetLeaderIndex Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetLeaderIndex(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int GetLeaderIndex(
    int leaderLineIndex
)
Public Function GetLeaderIndex ( _
    leaderLineIndex As Integer _
) As Integer
public:
int GetLeaderIndex(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


GetLeaderIndexes Method

GetLeaderIndexes Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetLeaderIndexes()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetLeaderIndexes()
Public Function GetLeaderIndexes As ArrayList
public:
ArrayList^ GetLeaderIndexes()


GetLeaderLineColor Method (leaderLineIndex)

GetLeaderLineColor Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetLeaderLineColor(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Color GetLeaderLineColor(
    int leaderLineIndex
)
Public Function GetLeaderLineColor ( _
    leaderLineIndex As Integer _
) As Color
public:
Color^ GetLeaderLineColor(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


GetLeaderLineIndexes Method (leaderIndex)

GetLeaderLineIndexes Method (leaderIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetLeaderLineIndexes(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetLeaderLineIndexes(
    int leaderIndex
)
Public Function GetLeaderLineIndexes ( _
    leaderIndex As Integer _
) As ArrayList
public:
ArrayList^ GetLeaderLineIndexes(
    int leaderIndex
)
Parameters
leaderIndex(Int32)


GetLeaderLineType Method (leaderLineIndex)

GetLeaderLineType Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetLeaderLineType(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public LeaderType GetLeaderLineType(
    int leaderLineIndex
)
Public Function GetLeaderLineType ( _
    leaderLineIndex As Integer _
) As LeaderType
public:
LeaderType GetLeaderLineType(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


GetLeaderLineTypeId Method (leaderLineIndex)

GetLeaderLineTypeId Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetLeaderLineTypeId(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetLeaderLineTypeId(
    int leaderLineIndex
)
Public Function GetLeaderLineTypeId ( _
    leaderLineIndex As Integer _
) As ObjectId
public:
ObjectId GetLeaderLineTypeId(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


GetLeaderLineWeight Method (leaderLineIndex)

GetLeaderLineWeight Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetLeaderLineWeight(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight GetLeaderLineWeight(
    int leaderLineIndex
)
Public Function GetLeaderLineWeight ( _
    leaderLineIndex As Integer _
) As LineWeight
public:
LineWeight GetLeaderLineWeight(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


getOverridedMLeaderStyle Method (mleaderStyle)

getOverridedMLeaderStyle Method (mleaderStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »getOverridedMLeaderStyle(MLeaderStyle)
Declaration Syntax
C# Visual Basic Visual C++
public void getOverridedMLeaderStyle(
    MLeaderStyle mleaderStyle
)
Public Sub getOverridedMLeaderStyle ( _
    mleaderStyle As MLeaderStyle _
)
public:
void getOverridedMLeaderStyle(
    MLeaderStyle^ mleaderStyle
)
Parameters
mleaderStyle(MLeaderStyle)


GetPlane Method

GetPlane Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetPlane()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override Plane GetPlane()
Public Overrides Function GetPlane As Plane
public:
virtual Plane^ GetPlane() override


GetTextAttachmentType Method (leaderDirection)

GetTextAttachmentType Method (leaderDirection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetTextAttachmentType(LeaderDirectionType)
Declaration Syntax
C# Visual Basic Visual C++
public TextAttachmentType GetTextAttachmentType(
    LeaderDirectionType leaderDirection
)
Public Function GetTextAttachmentType ( _
    leaderDirection As LeaderDirectionType _
) As TextAttachmentType
public:
TextAttachmentType GetTextAttachmentType(
    LeaderDirectionType leaderDirection
)
Parameters
leaderDirection(LeaderDirectionType)


GetVertex Method (leaderLineIndex, index)

GetVertex Method (leaderLineIndex, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetVertex(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetVertex(
    int leaderLineIndex,
    int index
)
Public Function GetVertex ( _
    leaderLineIndex As Integer, _
    index As Integer _
) As Point3d
public:
Point3d GetVertex(
    int leaderLineIndex,
    int index
)
Parameters
leaderLineIndex(Int32)
index(Int32)


HasContent Method

HasContent Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »HasContent()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool HasContent()
Public Function HasContent As Boolean
public:
bool HasContent()


LandingGap Property

LandingGap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »LandingGap
Declaration Syntax
C# Visual Basic Visual C++
public double LandingGap { get; set; }
Public Property LandingGap As Double
    Get
    Set
public:
property double LandingGap {
    double get ();
    void set (double value);
}


LeaderCount Property

LeaderCount Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »LeaderCount
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use GetLeaderIndexes instead")]
public int LeaderCount { get; }
<ObsoleteAttribute("Use GetLeaderIndexes instead")> _
Public ReadOnly Property LeaderCount As Integer
    Get
[ObsoleteAttribute(L"Use GetLeaderIndexes instead")]
public:
property int LeaderCount {
    int get ();
}


LeaderLineColor Property

LeaderLineColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »LeaderLineColor
Declaration Syntax
C# Visual Basic Visual C++
public Color LeaderLineColor { get; set; }
Public Property LeaderLineColor As Color
    Get
    Set
public:
property Color^ LeaderLineColor {
    Color^ get ();
    void set (Color^ value);
}


LeaderLineCount Property

LeaderLineCount Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »LeaderLineCount
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use GetLeaderLineIndexes instead")]
public int LeaderLineCount { get; }
<ObsoleteAttribute("Use GetLeaderLineIndexes instead")> _
Public ReadOnly Property LeaderLineCount As Integer
    Get
[ObsoleteAttribute(L"Use GetLeaderLineIndexes instead")]
public:
property int LeaderLineCount {
    int get ();
}


LeaderLineType Property

LeaderLineType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »LeaderLineType
Declaration Syntax
C# Visual Basic Visual C++
public LeaderType LeaderLineType { get; set; }
Public Property LeaderLineType As LeaderType
    Get
    Set
public:
property LeaderType LeaderLineType {
    LeaderType get ();
    void set (LeaderType value);
}


LeaderLineTypeId Property

LeaderLineTypeId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »LeaderLineTypeId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LeaderLineTypeId { get; set; }
Public Property LeaderLineTypeId As ObjectId
    Get
    Set
public:
property ObjectId LeaderLineTypeId {
    ObjectId get ();
    void set (ObjectId value);
}


LeaderLineWeight Property

LeaderLineWeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »LeaderLineWeight
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight LeaderLineWeight { get; set; }
Public Property LeaderLineWeight As LineWeight
    Get
    Set
public:
property LineWeight LeaderLineWeight {
    LineWeight get ();
    void set (LineWeight value);
}


MLeaderStyle Property

MLeaderStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »MLeaderStyle
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId MLeaderStyle { get; set; }
Public Property MLeaderStyle As ObjectId
    Get
    Set
public:
property ObjectId MLeaderStyle {
    ObjectId get ();
    void set (ObjectId value);
}


MLeaderText Property

MLeaderText Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »MLeaderText
Declaration Syntax
C# Visual Basic Visual C++
public MText MLeaderText { get; set; }
Public Property MLeaderText As MText
    Get
    Set
public:
property MText^ MLeaderText {
    MText^ get ();
    void set (MText^ value);
}


MoveMLeader Method (vec, type)

MoveMLeader Method (vec, type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »MoveMLeader(Vector3d, MoveType)
Declaration Syntax
C# Visual Basic Visual C++
public void MoveMLeader(
    Vector3d vec,
    MoveType type
)
Public Sub MoveMLeader ( _
    vec As Vector3d, _
    type As MoveType _
)
public:
void MoveMLeader(
    Vector3d vec,
    MoveType type
)
Parameters
vec(Vector3d)
type(MoveType)


MText Property

MText Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »MText
Declaration Syntax
C# Visual Basic Visual C++
public MText MText { get; set; }
Public Property MText As MText
    Get
    Set
public:
property MText^ MText {
    MText^ get ();
    void set (MText^ value);
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; }
Public ReadOnly Property Normal As Vector3d
    Get
public:
property Vector3d Normal {
    Vector3d get ();
}


PostMLeaderToDb Method (db)

PostMLeaderToDb Method (db)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »PostMLeaderToDb(Database)
Declaration Syntax
C# Visual Basic Visual C++
public void PostMLeaderToDb(
    Database db
)
Public Sub PostMLeaderToDb ( _
    db As Database _
)
public:
void PostMLeaderToDb(
    Database^ db
)
Parameters
db(Database)


recomputeBreakPoints Method

recomputeBreakPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »recomputeBreakPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void recomputeBreakPoints()
Public Sub recomputeBreakPoints
public:
void recomputeBreakPoints()


RemoveFirstVertex Method (leaderLineIndex)

RemoveFirstVertex Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »RemoveFirstVertex(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveFirstVertex(
    int leaderLineIndex
)
Public Sub RemoveFirstVertex ( _
    leaderLineIndex As Integer _
)
public:
void RemoveFirstVertex(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


RemoveLastVertex Method (leaderLineIndex)

RemoveLastVertex Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »RemoveLastVertex(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveLastVertex(
    int leaderLineIndex
)
Public Sub RemoveLastVertex ( _
    leaderLineIndex As Integer _
)
public:
void RemoveLastVertex(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


RemoveLeader Method (index)

RemoveLeader Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »RemoveLeader(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveLeader(
    int index
)
Public Sub RemoveLeader ( _
    index As Integer _
)
public:
void RemoveLeader(
    int index
)
Parameters
index(Int32)


RemoveLeaderLine Method (leaderLineIndex)

RemoveLeaderLine Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »RemoveLeaderLine(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveLeaderLine(
    int leaderLineIndex
)
Public Sub RemoveLeaderLine ( _
    leaderLineIndex As Integer _
)
public:
void RemoveLeaderLine(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


SetArrowSize Method (leaderLineIndex, arrowSize)

SetArrowSize Method (leaderLineIndex, arrowSize)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetArrowSize(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetArrowSize(
    int leaderLineIndex,
    double arrowSize
)
Public Sub SetArrowSize ( _
    leaderLineIndex As Integer, _
    arrowSize As Double _
)
public:
void SetArrowSize(
    int leaderLineIndex,
    double arrowSize
)
Parameters
leaderLineIndex(Int32)
arrowSize(Double)


SetArrowSymbolId Method (leaderLineIndex, id)

SetArrowSymbolId Method (leaderLineIndex, id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetArrowSymbolId(Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetArrowSymbolId(
    int leaderLineIndex,
    ObjectId id
)
Public Sub SetArrowSymbolId ( _
    leaderLineIndex As Integer, _
    id As ObjectId _
)
public:
void SetArrowSymbolId(
    int leaderLineIndex,
    ObjectId id
)
Parameters
leaderLineIndex(Int32)
id(ObjectId)


SetBlockAttribute Method (attDefId, attributeValue)

SetBlockAttribute Method (attDefId, attributeValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetBlockAttribute(ObjectId, AttributeReference)
Declaration Syntax
C# Visual Basic Visual C++
public void SetBlockAttribute(
    ObjectId attDefId,
    AttributeReference attributeValue
)
Public Sub SetBlockAttribute ( _
    attDefId As ObjectId, _
    attributeValue As AttributeReference _
)
public:
void SetBlockAttribute(
    ObjectId attDefId,
    AttributeReference^ attributeValue
)
Parameters
attDefId(ObjectId)
attributeValue(AttributeReference)


SetContextDataManager Method (contextDataManager)

SetContextDataManager Method (contextDataManager)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetContextDataManager(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void SetContextDataManager(
    IntPtr contextDataManager
)
Public Sub SetContextDataManager ( _
    contextDataManager As IntPtr _
)
public:
void SetContextDataManager(
    IntPtr contextDataManager
)
Parameters
contextDataManager(IntPtr)


SetDogleg Method (leaderIndex, vector)

SetDogleg Method (leaderIndex, vector)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetDogleg(Int32, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDogleg(
    int leaderIndex,
    Vector3d vector
)
Public Sub SetDogleg ( _
    leaderIndex As Integer, _
    vector As Vector3d _
)
public:
void SetDogleg(
    int leaderIndex,
    Vector3d vector
)
Parameters
leaderIndex(Int32)
vector(Vector3d)


SetDoglegLength Method (leaderIndex, doglegLength)

SetDoglegLength Method (leaderIndex, doglegLength)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetDoglegLength(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDoglegLength(
    int leaderIndex,
    double doglegLength
)
Public Sub SetDoglegLength ( _
    leaderIndex As Integer, _
    doglegLength As Double _
)
public:
void SetDoglegLength(
    int leaderIndex,
    double doglegLength
)
Parameters
leaderIndex(Int32)
doglegLength(Double)


SetFirstVertex Method (leaderLineIndex, point)

SetFirstVertex Method (leaderLineIndex, point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetFirstVertex(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFirstVertex(
    int leaderLineIndex,
    Point3d point
)
Public Sub SetFirstVertex ( _
    leaderLineIndex As Integer, _
    point As Point3d _
)
public:
void SetFirstVertex(
    int leaderLineIndex,
    Point3d point
)
Parameters
leaderLineIndex(Int32)
point(Point3d)


SetLastVertex Method (leaderLineIndex, point)

SetLastVertex Method (leaderLineIndex, point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetLastVertex(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLastVertex(
    int leaderLineIndex,
    Point3d point
)
Public Sub SetLastVertex ( _
    leaderLineIndex As Integer, _
    point As Point3d _
)
public:
void SetLastVertex(
    int leaderLineIndex,
    Point3d point
)
Parameters
leaderLineIndex(Int32)
point(Point3d)


SetLeaderLineColor Method (leaderLineIndex, leaderLineTypeId)

SetLeaderLineColor Method (leaderLineIndex, leaderLineTypeId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetLeaderLineColor(Int32, Color)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLeaderLineColor(
    int leaderLineIndex,
    Color leaderLineTypeId
)
Public Sub SetLeaderLineColor ( _
    leaderLineIndex As Integer, _
    leaderLineTypeId As Color _
)
public:
void SetLeaderLineColor(
    int leaderLineIndex,
    Color^ leaderLineTypeId
)
Parameters
leaderLineIndex(Int32)
leaderLineTypeId(Color)


SetLeaderLineType Method (leaderLineIndex, leaderLineType)

SetLeaderLineType Method (leaderLineIndex, leaderLineType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetLeaderLineType(Int32, LeaderType)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLeaderLineType(
    int leaderLineIndex,
    LeaderType leaderLineType
)
Public Sub SetLeaderLineType ( _
    leaderLineIndex As Integer, _
    leaderLineType As LeaderType _
)
public:
void SetLeaderLineType(
    int leaderLineIndex,
    LeaderType leaderLineType
)
Parameters
leaderLineIndex(Int32)
leaderLineType(LeaderType)


SetLeaderLineTypeId Method (leaderLineIndex, leaderLineTypeId)

SetLeaderLineTypeId Method (leaderLineIndex, leaderLineTypeId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetLeaderLineTypeId(Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLeaderLineTypeId(
    int leaderLineIndex,
    ObjectId leaderLineTypeId
)
Public Sub SetLeaderLineTypeId ( _
    leaderLineIndex As Integer, _
    leaderLineTypeId As ObjectId _
)
public:
void SetLeaderLineTypeId(
    int leaderLineIndex,
    ObjectId leaderLineTypeId
)
Parameters
leaderLineIndex(Int32)
leaderLineTypeId(ObjectId)


SetLeaderLineWeight Method (leaderLineIndex, leaderLineWeight)

SetLeaderLineWeight Method (leaderLineIndex, leaderLineWeight)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetLeaderLineWeight(Int32, LineWeight)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLeaderLineWeight(
    int leaderLineIndex,
    LineWeight leaderLineWeight
)
Public Sub SetLeaderLineWeight ( _
    leaderLineIndex As Integer, _
    leaderLineWeight As LineWeight _
)
public:
void SetLeaderLineWeight(
    int leaderLineIndex,
    LineWeight leaderLineWeight
)
Parameters
leaderLineIndex(Int32)
leaderLineWeight(LineWeight)


SetPlane Method (value)

SetPlane Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetPlane(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetPlane(
    Plane value
)
Public Overridable Sub SetPlane ( _
    value As Plane _
)
public:
virtual void SetPlane(
    Plane^ value
)
Parameters
value(Plane)


SetTextAttachmentType Method (textAttachmentType, leaderDirection)

SetTextAttachmentType Method (textAttachmentType, leaderDirection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetTextAttachmentType(TextAttachmentType, LeaderDirectionType)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTextAttachmentType(
    TextAttachmentType textAttachmentType,
    LeaderDirectionType leaderDirection
)
Public Sub SetTextAttachmentType ( _
    textAttachmentType As TextAttachmentType, _
    leaderDirection As LeaderDirectionType _
)
public:
void SetTextAttachmentType(
    TextAttachmentType textAttachmentType,
    LeaderDirectionType leaderDirection
)
Parameters
textAttachmentType(TextAttachmentType)
leaderDirection(LeaderDirectionType)


SetVertex Method (leaderLineIndex, index, point)

SetVertex Method (leaderLineIndex, index, point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetVertex(Int32, Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetVertex(
    int leaderLineIndex,
    int index,
    Point3d point
)
Public Sub SetVertex ( _
    leaderLineIndex As Integer, _
    index As Integer, _
    point As Point3d _
)
public:
void SetVertex(
    int leaderLineIndex,
    int index,
    Point3d point
)
Parameters
leaderLineIndex(Int32)
index(Int32)
point(Point3d)


TextAlignmentType Property

TextAlignmentType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »TextAlignmentType
Declaration Syntax
C# Visual Basic Visual C++
public TextAlignmentType TextAlignmentType { get; set; }
Public Property TextAlignmentType As TextAlignmentType
    Get
    Set
public:
property TextAlignmentType TextAlignmentType {
    TextAlignmentType get ();
    void set (TextAlignmentType value);
}


TextAngleType Property

TextAngleType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »TextAngleType
Declaration Syntax
C# Visual Basic Visual C++
public TextAngleType TextAngleType { get; set; }
Public Property TextAngleType As TextAngleType
    Get
    Set
public:
property TextAngleType TextAngleType {
    TextAngleType get ();
    void set (TextAngleType value);
}


TextAttachmentDirection Property

TextAttachmentDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »TextAttachmentDirection
Declaration Syntax
C# Visual Basic Visual C++
public TextAttachmentDirection TextAttachmentDirection { get; set; }
Public Property TextAttachmentDirection As TextAttachmentDirection
    Get
    Set
public:
property TextAttachmentDirection TextAttachmentDirection {
    TextAttachmentDirection get ();
    void set (TextAttachmentDirection value);
}


TextAttachmentType Property

TextAttachmentType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »TextAttachmentType
Declaration Syntax
C# Visual Basic Visual C++
public TextAttachmentType TextAttachmentType { get; set; }
Public Property TextAttachmentType As TextAttachmentType
    Get
    Set
public:
property TextAttachmentType TextAttachmentType {
    TextAttachmentType get ();
    void set (TextAttachmentType value);
}


TextColor Property

TextColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »TextColor
Declaration Syntax
C# Visual Basic Visual C++
public Color TextColor { get; set; }
Public Property TextColor As Color
    Get
    Set
public:
property Color^ TextColor {
    Color^ get ();
    void set (Color^ value);
}


TextHeight Property

TextHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »TextHeight
Declaration Syntax
C# Visual Basic Visual C++
public double TextHeight { get; set; }
Public Property TextHeight As Double
    Get
    Set
public:
property double TextHeight {
    double get ();
    void set (double value);
}


TextLocation Property

TextLocation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »TextLocation
Declaration Syntax
C# Visual Basic Visual C++
public Point3d TextLocation { get; set; }
Public Property TextLocation As Point3d
    Get
    Set
public:
property Point3d TextLocation {
    Point3d get ();
    void set (Point3d value);
}


TextStyleId Property

TextStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »TextStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId TextStyleId { get; set; }
Public Property TextStyleId As ObjectId
    Get
    Set
public:
property ObjectId TextStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


ToleranceLocation Property

ToleranceLocation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »ToleranceLocation
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ToleranceLocation { get; set; }
Public Property ToleranceLocation As Point3d
    Get
    Set
public:
property Point3d ToleranceLocation {
    Point3d get ();
    void set (Point3d value);
}


VerticesCount Method (leaderLineIndex)

VerticesCount Method (leaderLineIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »VerticesCount(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int VerticesCount(
    int leaderLineIndex
)
Public Function VerticesCount ( _
    leaderLineIndex As Integer _
) As Integer
public:
int VerticesCount(
    int leaderLineIndex
)
Parameters
leaderLineIndex(Int32)


MLeaderStyle Class

MLeaderStyle Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbMLeaderStyle")]
public class MLeaderStyle : DBObject
<WrapperAttribute("AcDbMLeaderStyle")> _
Public Class MLeaderStyle _
    Inherits DBObject
[WrapperAttribute(L"AcDbMLeaderStyle")]
public ref class MLeaderStyle : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MLeaderStyle(IntPtr, Boolean) |
 | MLeaderStyle(MLeaderStyle) |
 | MLeaderStyle()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | ArrowSize |
 | ArrowSymbolId |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockColor |
 | BlockConnectionType |
 | BlockId |
 | BlockRotation |
 | BlockScale |
 | Bounds | (Inherited from Drawable.)
 | BreakSize |
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | ContentType |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DefaultMText |
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DoglegLength |
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DrawLeaderOrderType |
 | DrawMLeaderOrderType |
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | EnableBlockRotation |
 | EnableBlockScale |
 | EnableDogleg |
 | EnableFrameText |
 | EnableLanding |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FirstSegmentAngleConstraint |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTextAttachmentType(LeaderDirectionType) |
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | LandingGap |
 | LeaderLineColor |
 | LeaderLineType |
 | LeaderLineTypeId |
 | LeaderLineWeight |
 | MaxLeaderSegmentsPoints |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OverwritePropChanged()()()() |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PostMLeaderStyleToDb(Database, String) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Scale |
 | SecondSegmentAngleConstraint |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetTextAttachmentType(TextAttachmentType, LeaderDirectionType) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAlignAlwaysLeft |
 | TextAlignmentType |
 | TextAngleType |
 | TextAttachmentDirection |
 | TextAttachmentType |
 | TextColor |
 | TextHeight |
 | TextStyleId |
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | MLeaderStyle


MLeaderStyle Constructor

MLeaderStyle Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »MLeaderStyle()()()()
Members
Icon | Member | Description
 | MLeaderStyle(IntPtr, Boolean) |
 | MLeaderStyle(MLeaderStyle) |
 | MLeaderStyle()()()() |


MLeaderStyle Constructor

MLeaderStyle Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »MLeaderStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MLeaderStyle()
Public Sub New
public:
MLeaderStyle()


MLeaderStyle Constructor (unmanagedObjPtr, autoDelete)

MLeaderStyle Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »MLeaderStyle(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal MLeaderStyle(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
MLeaderStyle(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


MLeaderStyle Constructor (mleaderStyle)

MLeaderStyle Constructor (mleaderStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »MLeaderStyle(MLeaderStyle)
Declaration Syntax
C# Visual Basic Visual C++
public MLeaderStyle(
    MLeaderStyle mleaderStyle
)
Public Sub New ( _
    mleaderStyle As MLeaderStyle _
)
public:
MLeaderStyle(
    MLeaderStyle^ mleaderStyle
)
Parameters
mleaderStyle(MLeaderStyle)


Annotative Property

Annotative Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »Annotative
Declaration Syntax
C# Visual Basic Visual C++
public AnnotativeStates Annotative { get; set; }
Public Property Annotative As AnnotativeStates
    Get
    Set
public:
property AnnotativeStates Annotative {
    AnnotativeStates get ();
    void set (AnnotativeStates value);
}


ArrowSize Property

ArrowSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »ArrowSize
Declaration Syntax
C# Visual Basic Visual C++
public double ArrowSize { get; set; }
Public Property ArrowSize As Double
    Get
    Set
public:
property double ArrowSize {
    double get ();
    void set (double value);
}


ArrowSymbolId Property

ArrowSymbolId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »ArrowSymbolId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ArrowSymbolId { get; set; }
Public Property ArrowSymbolId As ObjectId
    Get
    Set
public:
property ObjectId ArrowSymbolId {
    ObjectId get ();
    void set (ObjectId value);
}


BlockColor Property

BlockColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »BlockColor
Declaration Syntax
C# Visual Basic Visual C++
public Color BlockColor { get; set; }
Public Property BlockColor As Color
    Get
    Set
public:
property Color^ BlockColor {
    Color^ get ();
    void set (Color^ value);
}


BlockConnectionType Property

BlockConnectionType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »BlockConnectionType
Declaration Syntax
C# Visual Basic Visual C++
public BlockConnectionType BlockConnectionType { get; set; }
Public Property BlockConnectionType As BlockConnectionType
    Get
    Set
public:
property BlockConnectionType BlockConnectionType {
    BlockConnectionType get ();
    void set (BlockConnectionType value);
}


BlockId Property

BlockId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »BlockId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockId { get; set; }
Public Property BlockId As ObjectId
    Get
    Set
public:
property ObjectId BlockId {
    ObjectId get ();
    void set (ObjectId value);
}


BlockRotation Property

BlockRotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »BlockRotation
Declaration Syntax
C# Visual Basic Visual C++
public double BlockRotation { get; set; }
Public Property BlockRotation As Double
    Get
    Set
public:
property double BlockRotation {
    double get ();
    void set (double value);
}


BlockScale Property

BlockScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »BlockScale
Declaration Syntax
C# Visual Basic Visual C++
public Scale3d BlockScale { get; set; }
Public Property BlockScale As Scale3d
    Get
    Set
public:
property Scale3d BlockScale {
    Scale3d get ();
    void set (Scale3d value);
}


BreakSize Property

BreakSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »BreakSize
Declaration Syntax
C# Visual Basic Visual C++
public double BreakSize { get; set; }
Public Property BreakSize As Double
    Get
    Set
public:
property double BreakSize {
    double get ();
    void set (double value);
}


ContentType Property

ContentType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »ContentType
Declaration Syntax
C# Visual Basic Visual C++
public ContentType ContentType { get; set; }
Public Property ContentType As ContentType
    Get
    Set
public:
property ContentType ContentType {
    ContentType get ();
    void set (ContentType value);
}


DefaultMText Property

DefaultMText Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »DefaultMText
Declaration Syntax
C# Visual Basic Visual C++
public MText DefaultMText { get; set; }
Public Property DefaultMText As MText
    Get
    Set
public:
property MText^ DefaultMText {
    MText^ get ();
    void set (MText^ value);
}


DoglegLength Property

DoglegLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »DoglegLength
Declaration Syntax
C# Visual Basic Visual C++
public double DoglegLength { get; set; }
Public Property DoglegLength As Double
    Get
    Set
public:
property double DoglegLength {
    double get ();
    void set (double value);
}


DrawLeaderOrderType Property

DrawLeaderOrderType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »DrawLeaderOrderType
Declaration Syntax
C# Visual Basic Visual C++
public DrawLeaderOrderType DrawLeaderOrderType { get; set; }
Public Property DrawLeaderOrderType As DrawLeaderOrderType
    Get
    Set
public:
property DrawLeaderOrderType DrawLeaderOrderType {
    DrawLeaderOrderType get ();
    void set (DrawLeaderOrderType value);
}


DrawMLeaderOrderType Property

DrawMLeaderOrderType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »DrawMLeaderOrderType
Declaration Syntax
C# Visual Basic Visual C++
public DrawMLeaderOrderType DrawMLeaderOrderType { get; set; }
Public Property DrawMLeaderOrderType As DrawMLeaderOrderType
    Get
    Set
public:
property DrawMLeaderOrderType DrawMLeaderOrderType {
    DrawMLeaderOrderType get ();
    void set (DrawMLeaderOrderType value);
}


EnableBlockRotation Property

EnableBlockRotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »EnableBlockRotation
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableBlockRotation { get; set; }
Public Property EnableBlockRotation As Boolean
    Get
    Set
public:
property bool EnableBlockRotation {
    bool get ();
    void set (bool value);
}


EnableBlockScale Property

EnableBlockScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »EnableBlockScale
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableBlockScale { get; set; }
Public Property EnableBlockScale As Boolean
    Get
    Set
public:
property bool EnableBlockScale {
    bool get ();
    void set (bool value);
}


EnableDogleg Property

EnableDogleg Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »EnableDogleg
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableDogleg { get; set; }
Public Property EnableDogleg As Boolean
    Get
    Set
public:
property bool EnableDogleg {
    bool get ();
    void set (bool value);
}


EnableFrameText Property

EnableFrameText Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »EnableFrameText
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableFrameText { get; set; }
Public Property EnableFrameText As Boolean
    Get
    Set
public:
property bool EnableFrameText {
    bool get ();
    void set (bool value);
}


EnableLanding Property

EnableLanding Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »EnableLanding
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableLanding { get; set; }
Public Property EnableLanding As Boolean
    Get
    Set
public:
property bool EnableLanding {
    bool get ();
    void set (bool value);
}


FirstSegmentAngleConstraint Property

FirstSegmentAngleConstraint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »FirstSegmentAngleConstraint
Declaration Syntax
C# Visual Basic Visual C++
public AngleConstraint FirstSegmentAngleConstraint { get; set; }
Public Property FirstSegmentAngleConstraint As AngleConstraint
    Get
    Set
public:
property AngleConstraint FirstSegmentAngleConstraint {
    AngleConstraint get ();
    void set (AngleConstraint value);
}


GetTextAttachmentType Method (leaderDirection)

GetTextAttachmentType Method (leaderDirection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »GetTextAttachmentType(LeaderDirectionType)
Declaration Syntax
C# Visual Basic Visual C++
public TextAttachmentType GetTextAttachmentType(
    LeaderDirectionType leaderDirection
)
Public Function GetTextAttachmentType ( _
    leaderDirection As LeaderDirectionType _
) As TextAttachmentType
public:
TextAttachmentType GetTextAttachmentType(
    LeaderDirectionType leaderDirection
)
Parameters
leaderDirection(LeaderDirectionType)


LandingGap Property

LandingGap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »LandingGap
Declaration Syntax
C# Visual Basic Visual C++
public double LandingGap { get; set; }
Public Property LandingGap As Double
    Get
    Set
public:
property double LandingGap {
    double get ();
    void set (double value);
}


LeaderLineColor Property

LeaderLineColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »LeaderLineColor
Declaration Syntax
C# Visual Basic Visual C++
public Color LeaderLineColor { get; set; }
Public Property LeaderLineColor As Color
    Get
    Set
public:
property Color^ LeaderLineColor {
    Color^ get ();
    void set (Color^ value);
}


LeaderLineType Property

LeaderLineType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »LeaderLineType
Declaration Syntax
C# Visual Basic Visual C++
public LeaderType LeaderLineType { get; set; }
Public Property LeaderLineType As LeaderType
    Get
    Set
public:
property LeaderType LeaderLineType {
    LeaderType get ();
    void set (LeaderType value);
}


LeaderLineTypeId Property

LeaderLineTypeId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »LeaderLineTypeId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LeaderLineTypeId { get; set; }
Public Property LeaderLineTypeId As ObjectId
    Get
    Set
public:
property ObjectId LeaderLineTypeId {
    ObjectId get ();
    void set (ObjectId value);
}


LeaderLineWeight Property

LeaderLineWeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »LeaderLineWeight
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight LeaderLineWeight { get; set; }
Public Property LeaderLineWeight As LineWeight
    Get
    Set
public:
property LineWeight LeaderLineWeight {
    LineWeight get ();
    void set (LineWeight value);
}


MaxLeaderSegmentsPoints Property

MaxLeaderSegmentsPoints Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »MaxLeaderSegmentsPoints
Declaration Syntax
C# Visual Basic Visual C++
public int MaxLeaderSegmentsPoints { get; set; }
Public Property MaxLeaderSegmentsPoints As Integer
    Get
    Set
public:
property int MaxLeaderSegmentsPoints {
    int get ();
    void set (int value);
}


OverwritePropChanged Method

OverwritePropChanged Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »OverwritePropChanged()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool OverwritePropChanged()
Public Function OverwritePropChanged As Boolean
public:
bool OverwritePropChanged()


PostMLeaderStyleToDb Method (db, styleName)

PostMLeaderStyleToDb Method (db, styleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »PostMLeaderStyleToDb(Database, String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId PostMLeaderStyleToDb(
    Database db,
    string styleName
)
Public Function PostMLeaderStyleToDb ( _
    db As Database, _
    styleName As String _
) As ObjectId
public:
ObjectId PostMLeaderStyleToDb(
    Database^ db,
    String^ styleName
)
Parameters
db(Database)
styleName(String)


Scale Property

Scale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »Scale
Declaration Syntax
C# Visual Basic Visual C++
public double Scale { get; set; }
Public Property Scale As Double
    Get
    Set
public:
property double Scale {
    double get ();
    void set (double value);
}


SecondSegmentAngleConstraint Property

SecondSegmentAngleConstraint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »SecondSegmentAngleConstraint
Declaration Syntax
C# Visual Basic Visual C++
public AngleConstraint SecondSegmentAngleConstraint { get; set; }
Public Property SecondSegmentAngleConstraint As AngleConstraint
    Get
    Set
public:
property AngleConstraint SecondSegmentAngleConstraint {
    AngleConstraint get ();
    void set (AngleConstraint value);
}


SetTextAttachmentType Method (textAttachmentType, leaderDirection)

SetTextAttachmentType Method (textAttachmentType, leaderDirection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »SetTextAttachmentType(TextAttachmentType, LeaderDirectionType)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTextAttachmentType(
    TextAttachmentType textAttachmentType,
    LeaderDirectionType leaderDirection
)
Public Sub SetTextAttachmentType ( _
    textAttachmentType As TextAttachmentType, _
    leaderDirection As LeaderDirectionType _
)
public:
void SetTextAttachmentType(
    TextAttachmentType textAttachmentType,
    LeaderDirectionType leaderDirection
)
Parameters
textAttachmentType(TextAttachmentType)
leaderDirection(LeaderDirectionType)


TextAlignAlwaysLeft Property

TextAlignAlwaysLeft Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »TextAlignAlwaysLeft
Declaration Syntax
C# Visual Basic Visual C++
public bool TextAlignAlwaysLeft { get; set; }
Public Property TextAlignAlwaysLeft As Boolean
    Get
    Set
public:
property bool TextAlignAlwaysLeft {
    bool get ();
    void set (bool value);
}


TextAlignmentType Property

TextAlignmentType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »TextAlignmentType
Declaration Syntax
C# Visual Basic Visual C++
public TextAlignmentType TextAlignmentType { get; set; }
Public Property TextAlignmentType As TextAlignmentType
    Get
    Set
public:
property TextAlignmentType TextAlignmentType {
    TextAlignmentType get ();
    void set (TextAlignmentType value);
}


TextAngleType Property

TextAngleType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »TextAngleType
Declaration Syntax
C# Visual Basic Visual C++
public TextAngleType TextAngleType { get; set; }
Public Property TextAngleType As TextAngleType
    Get
    Set
public:
property TextAngleType TextAngleType {
    TextAngleType get ();
    void set (TextAngleType value);
}


TextAttachmentDirection Property

TextAttachmentDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »TextAttachmentDirection
Declaration Syntax
C# Visual Basic Visual C++
public TextAttachmentDirection TextAttachmentDirection { get; set; }
Public Property TextAttachmentDirection As TextAttachmentDirection
    Get
    Set
public:
property TextAttachmentDirection TextAttachmentDirection {
    TextAttachmentDirection get ();
    void set (TextAttachmentDirection value);
}


TextAttachmentType Property

TextAttachmentType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »TextAttachmentType
Declaration Syntax
C# Visual Basic Visual C++
public TextAttachmentType TextAttachmentType { get; set; }
Public Property TextAttachmentType As TextAttachmentType
    Get
    Set
public:
property TextAttachmentType TextAttachmentType {
    TextAttachmentType get ();
    void set (TextAttachmentType value);
}


TextColor Property

TextColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »TextColor
Declaration Syntax
C# Visual Basic Visual C++
public Color TextColor { get; set; }
Public Property TextColor As Color
    Get
    Set
public:
property Color^ TextColor {
    Color^ get ();
    void set (Color^ value);
}


TextHeight Property

TextHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »TextHeight
Declaration Syntax
C# Visual Basic Visual C++
public double TextHeight { get; set; }
Public Property TextHeight As Double
    Get
    Set
public:
property double TextHeight {
    double get ();
    void set (double value);
}


TextStyleId Property

TextStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »TextStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId TextStyleId { get; set; }
Public Property TextStyleId As ObjectId
    Get
    Set
public:
property ObjectId TextStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


Mline Class

Mline Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbMline")]
public class Mline : Entity
<WrapperAttribute("AcDbMline")> _
Public Class Mline _
    Inherits Entity
[WrapperAttribute(L"AcDbMline")]
public ref class Mline : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Mline(IntPtr, Boolean) |
 | Mline()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | AppendSegment(Point3d) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Element(Point3d) |
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean, Boolean) |
 | GetClosestPointTo(Point3d, Boolean, Boolean) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsClosed |
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Justification |
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveVertexAt(Int32, Point3d) |
 | Normal |
 | NumberOfVertices |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemoveLastSegment(Point3d) |
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | Scale |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Style |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SupressEndCaps |
 | SupressStartCaps |
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VertexAt(Int32) |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Mline


Mline Constructor

Mline Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Mline()()()()
Members
Icon | Member | Description
 | Mline(IntPtr, Boolean) |
 | Mline()()()() |


Mline Constructor

Mline Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Mline()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Mline()
Public Sub New
public:
Mline()


Mline Constructor (unmanagedObjPtr, autoDelete)

Mline Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Mline(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Mline(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Mline(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AppendSegment Method (newVertex)

AppendSegment Method (newVertex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »AppendSegment(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void AppendSegment(
    Point3d newVertex
)
Public Sub AppendSegment ( _
    newVertex As Point3d _
)
public:
void AppendSegment(
    Point3d newVertex
)
Parameters
newVertex(Point3d)


Element Method (pt)

Element Method (pt)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Element(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public int Element(
    Point3d pt
)
Public Function Element ( _
    pt As Point3d _
) As Integer
public:
int Element(
    Point3d pt
)
Parameters
pt(Point3d)


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean, Boolean) |
 | GetClosestPointTo(Point3d, Boolean, Boolean) |


GetClosestPointTo Method (givenPoint, extend, excludeCaps)

GetClosestPointTo Method (givenPoint, extend, excludeCaps)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »GetClosestPointTo(Point3d, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetClosestPointTo(
    Point3d givenPoint,
    bool extend,
    bool excludeCaps
)
Public Function GetClosestPointTo ( _
    givenPoint As Point3d, _
    extend As Boolean, _
    excludeCaps As Boolean _
) As Point3d
public:
Point3d GetClosestPointTo(
    Point3d givenPoint,
    bool extend,
    bool excludeCaps
)
Parameters
givenPoint(Point3d)
extend(Boolean)
excludeCaps(Boolean)


GetClosestPointTo Method (givenPoint, normal, extend, excludeCaps)

GetClosestPointTo Method (givenPoint, normal, extend, excludeCaps)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »GetClosestPointTo(Point3d, Vector3d, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetClosestPointTo(
    Point3d givenPoint,
    Vector3d normal,
    bool extend,
    bool excludeCaps
)
Public Function GetClosestPointTo ( _
    givenPoint As Point3d, _
    normal As Vector3d, _
    extend As Boolean, _
    excludeCaps As Boolean _
) As Point3d
public:
Point3d GetClosestPointTo(
    Point3d givenPoint,
    Vector3d normal,
    bool extend,
    bool excludeCaps
)
Parameters
givenPoint(Point3d)
normal(Vector3d)
extend(Boolean)
excludeCaps(Boolean)


IsClosed Property

IsClosed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »IsClosed
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed { get; set; }
Public Property IsClosed As Boolean
    Get
    Set
public:
property bool IsClosed {
    bool get ();
    void set (bool value);
}


Justification Property

Justification Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Justification
Declaration Syntax
C# Visual Basic Visual C++
public MlineJustification Justification { get; set; }
Public Property Justification As MlineJustification
    Get
    Set
public:
property MlineJustification Justification {
    MlineJustification get ();
    void set (MlineJustification value);
}


MoveVertexAt Method (index, newPosition)

MoveVertexAt Method (index, newPosition)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »MoveVertexAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void MoveVertexAt(
    int index,
    Point3d newPosition
)
Public Sub MoveVertexAt ( _
    index As Integer, _
    newPosition As Point3d _
)
public:
void MoveVertexAt(
    int index,
    Point3d newPosition
)
Parameters
index(Int32)
newPosition(Point3d)


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


NumberOfVertices Property

NumberOfVertices Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »NumberOfVertices
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfVertices { get; }
Public ReadOnly Property NumberOfVertices As Integer
    Get
public:
property int NumberOfVertices {
    int get ();
}


RemoveLastSegment Method (lastVertex)

RemoveLastSegment Method (lastVertex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »RemoveLastSegment(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveLastSegment(
    Point3d lastVertex
)
Public Sub RemoveLastSegment ( _
    lastVertex As Point3d _
)
public:
void RemoveLastSegment(
    Point3d lastVertex
)
Parameters
lastVertex(Point3d)


Scale Property

Scale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Scale
Declaration Syntax
C# Visual Basic Visual C++
public double Scale { get; set; }
Public Property Scale As Double
    Get
    Set
public:
property double Scale {
    double get ();
    void set (double value);
}


Style Property

Style Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Style
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Style { get; set; }
Public Property Style As ObjectId
    Get
    Set
public:
property ObjectId Style {
    ObjectId get ();
    void set (ObjectId value);
}


SupressEndCaps Property

SupressEndCaps Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »SupressEndCaps
Declaration Syntax
C# Visual Basic Visual C++
public bool SupressEndCaps { get; set; }
Public Property SupressEndCaps As Boolean
    Get
    Set
public:
property bool SupressEndCaps {
    bool get ();
    void set (bool value);
}


SupressStartCaps Property

SupressStartCaps Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »SupressStartCaps
Declaration Syntax
C# Visual Basic Visual C++
public bool SupressStartCaps { get; set; }
Public Property SupressStartCaps As Boolean
    Get
    Set
public:
property bool SupressStartCaps {
    bool get ();
    void set (bool value);
}


VertexAt Method (index)

VertexAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »VertexAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d VertexAt(
    int index
)
Public Function VertexAt ( _
    index As Integer _
) As Point3d
public:
Point3d VertexAt(
    int index
)
Parameters
index(Int32)


MlineJustification Enumeration

MlineJustification Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineJustification
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("Mline::MlineJustification")]
public enum MlineJustification
<WrapperAttribute("Mline::MlineJustification")> _
Public Enumeration MlineJustification
[WrapperAttribute(L"Mline::MlineJustification")]
public enum class MlineJustification
Members
Member | Description
Bottom |
Zero |
Top |


MlineStyle Class

MlineStyle Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbMlineStyle")]
public class MlineStyle : DBObject
<WrapperAttribute("AcDbMlineStyle")> _
Public Class MlineStyle _
    Inherits DBObject
[WrapperAttribute(L"AcDbMlineStyle")]
public ref class MlineStyle : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MlineStyle(IntPtr, Boolean) |
 | MlineStyle()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Description |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Elements |
 | EndAngle |
 | EndInnerArcs |
 | EndRoundCap |
 | EndSquareCap |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FillColor |
 | Filled |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Reset()()()() |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Set(MlineStyle, Boolean) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | ShowMiters |
 | StartAngle |
 | StartInnerArcs |
 | StartRoundCap |
 | StartSquareCap |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | MlineStyle


MlineStyle Constructor

MlineStyle Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »MlineStyle()()()()
Members
Icon | Member | Description
 | MlineStyle(IntPtr, Boolean) |
 | MlineStyle()()()() |


MlineStyle Constructor

MlineStyle Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »MlineStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MlineStyle()
Public Sub New
public:
MlineStyle()


MlineStyle Constructor (unmanagedPointer, autoDelete)

MlineStyle Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »MlineStyle(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal MlineStyle(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
MlineStyle(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Elements Property

Elements Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »Elements
Declaration Syntax
C# Visual Basic Visual C++
public MlineStyleElementCollection Elements { get; }
Public ReadOnly Property Elements As MlineStyleElementCollection
    Get
public:
property MlineStyleElementCollection^ Elements {
    MlineStyleElementCollection^ get ();
}


EndAngle Property

EndAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »EndAngle
Declaration Syntax
C# Visual Basic Visual C++
public double EndAngle { get; set; }
Public Property EndAngle As Double
    Get
    Set
public:
property double EndAngle {
    double get ();
    void set (double value);
}


EndInnerArcs Property

EndInnerArcs Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »EndInnerArcs
Declaration Syntax
C# Visual Basic Visual C++
public bool EndInnerArcs { get; set; }
Public Property EndInnerArcs As Boolean
    Get
    Set
public:
property bool EndInnerArcs {
    bool get ();
    void set (bool value);
}


EndRoundCap Property

EndRoundCap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »EndRoundCap
Declaration Syntax
C# Visual Basic Visual C++
public bool EndRoundCap { get; set; }
Public Property EndRoundCap As Boolean
    Get
    Set
public:
property bool EndRoundCap {
    bool get ();
    void set (bool value);
}


EndSquareCap Property

EndSquareCap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »EndSquareCap
Declaration Syntax
C# Visual Basic Visual C++
public bool EndSquareCap { get; set; }
Public Property EndSquareCap As Boolean
    Get
    Set
public:
property bool EndSquareCap {
    bool get ();
    void set (bool value);
}


FillColor Property

FillColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »FillColor
Declaration Syntax
C# Visual Basic Visual C++
public Color FillColor { get; set; }
Public Property FillColor As Color
    Get
    Set
public:
property Color^ FillColor {
    Color^ get ();
    void set (Color^ value);
}


Filled Property

Filled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »Filled
Declaration Syntax
C# Visual Basic Visual C++
public bool Filled { get; set; }
Public Property Filled As Boolean
    Get
    Set
public:
property bool Filled {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
void Reset()


Set Method (source, checkIfReferenced)

Set Method (source, checkIfReferenced)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »Set(MlineStyle, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    MlineStyle source,
    bool checkIfReferenced
)
Public Sub Set ( _
    source As MlineStyle, _
    checkIfReferenced As Boolean _
)
public:
void Set(
    MlineStyle^ source,
    bool checkIfReferenced
)
Parameters
source(MlineStyle)
checkIfReferenced(Boolean)


ShowMiters Property

ShowMiters Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »ShowMiters
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowMiters { get; set; }
Public Property ShowMiters As Boolean
    Get
    Set
public:
property bool ShowMiters {
    bool get ();
    void set (bool value);
}


StartAngle Property

StartAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »StartAngle
Declaration Syntax
C# Visual Basic Visual C++
public double StartAngle { get; set; }
Public Property StartAngle As Double
    Get
    Set
public:
property double StartAngle {
    double get ();
    void set (double value);
}


StartInnerArcs Property

StartInnerArcs Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »StartInnerArcs
Declaration Syntax
C# Visual Basic Visual C++
public bool StartInnerArcs { get; set; }
Public Property StartInnerArcs As Boolean
    Get
    Set
public:
property bool StartInnerArcs {
    bool get ();
    void set (bool value);
}


StartRoundCap Property

StartRoundCap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »StartRoundCap
Declaration Syntax
C# Visual Basic Visual C++
public bool StartRoundCap { get; set; }
Public Property StartRoundCap As Boolean
    Get
    Set
public:
property bool StartRoundCap {
    bool get ();
    void set (bool value);
}


StartSquareCap Property

StartSquareCap Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »StartSquareCap
Declaration Syntax
C# Visual Basic Visual C++
public bool StartSquareCap { get; set; }
Public Property StartSquareCap As Boolean
    Get
    Set
public:
property bool StartSquareCap {
    bool get ();
    void set (bool value);
}


MlineStyleElement Structure

MlineStyleElement Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElement
Declaration Syntax
C# Visual Basic Visual C++
public struct MlineStyleElement
Public Structure MlineStyleElement
public value class MlineStyleElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MlineStyleElement(Double, Color, ObjectId) |
 | Color |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | LinetypeId |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Offset |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


MlineStyleElement Constructor (offset, color, linetypeId)

MlineStyleElement Constructor (offset, color, linetypeId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElement »MlineStyleElement(Double, Color, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public MlineStyleElement(
    double offset,
    Color color,
    ObjectId linetypeId
)
Public Sub New ( _
    offset As Double, _
    color As Color, _
    linetypeId As ObjectId _
)
public:
MlineStyleElement(
    double offset,
    Color^ color,
    ObjectId linetypeId
)
Parameters
offset(Double)
color(Color)
linetypeId(ObjectId)


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElement »Color
Declaration Syntax
C# Visual Basic Visual C++
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
public:
property Color^ Color {
    Color^ get ();
}


LinetypeId Property

LinetypeId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElement »LinetypeId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LinetypeId { get; }
Public ReadOnly Property LinetypeId As ObjectId
    Get
public:
property ObjectId LinetypeId {
    ObjectId get ();
}


Offset Property

Offset Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElement »Offset
Declaration Syntax
C# Visual Basic Visual C++
public double Offset { get; }
Public ReadOnly Property Offset As Double
    Get
public:
property double Offset {
    double get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElement »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElement »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElement »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


MlineStyleElementCollection Class

MlineStyleElementCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class MlineStyleElementCollection : ICollection
Public NotInheritable Class MlineStyleElementCollection _
    Implements ICollection
public ref class MlineStyleElementCollection sealed : ICollection
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(MlineStyleElement, Boolean) |
 | CopyTo(array<MlineStyleElement>[]()[][], Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IEnumerable..::..GetEnumerator()()()() |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RemoveAt(Int32) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
MlineStyleElementCollection


Add Method (element, checkIfReferenced)

Add Method (element, checkIfReferenced)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection »Add(MlineStyleElement, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MlineStyleElement element,
    bool checkIfReferenced
)
Public Function Add ( _
    element As MlineStyleElement, _
    checkIfReferenced As Boolean _
) As Integer
public:
int Add(
    MlineStyleElement element,
    bool checkIfReferenced
)
Parameters
element(MlineStyleElement)
checkIfReferenced(Boolean)


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection »CopyTo(array<MlineStyleElement>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MlineStyleElement[] arr,
    int index
)
Public Sub CopyTo ( _
    arr As MlineStyleElement(), _
    index As Integer _
)
public:
void CopyTo(
    array<MlineStyleElement>^ arr,
    int index
)
Parameters
arr(array< MlineStyleElement >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MlineStyleElementCollectionEnumerator GetEnumerator()
Public Function GetEnumerator As MlineStyleElementCollectionEnumerator
public:
MlineStyleElementCollectionEnumerator^ GetEnumerator()


ICollection_CopyTo Method (arr, index)

ICollection_CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array arr,
    int index
)
Private Sub ICollection_CopyTo ( _
    arr As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ arr,
    int index
) sealed = ICollection::CopyTo
Parameters
arr(Array)
index(Int32)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection »IEnumerable..::..GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
IEnumerator IEnumerable.GetEnumerator()
Private Function IEnumerable_GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ IEnumerable_GetEnumerator() sealed = IEnumerable::GetEnumerator


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MlineStyleElement this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MlineStyleElement
    Get
    Set
public:
property MlineStyleElement default[int index] {
    MlineStyleElement get (int index);
    void set (int index, MlineStyleElement value);
}
Parameters
index(Int32)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
void RemoveAt(
    int index
)
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


MlineStyleElementCollectionEnumerator Class

MlineStyleElementCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public sealed class MlineStyleElementCollectionEnumerator : IEnumerator
Public NotInheritable Class MlineStyleElementCollectionEnumerator _
    Implements IEnumerator
public ref class MlineStyleElementCollectionEnumerator sealed : IEnumerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MlineStyleElementCollectionEnumerator(MlineStyleElementCollection) |
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerator..::..Current |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
MlineStyleElementCollectionEnumerator


MlineStyleElementCollectionEnumerator Constructor (col)

MlineStyleElementCollectionEnumerator Constructor (col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollectionEnumerator »MlineStyleElementCollectionEnumerator(MlineStyleElementCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MlineStyleElementCollectionEnumerator(
    MlineStyleElementCollection col
)
Public Sub New ( _
    col As MlineStyleElementCollection _
)
public:
MlineStyleElementCollectionEnumerator(
    MlineStyleElementCollection^ col
)
Parameters
col(MlineStyleElementCollection)


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public MlineStyleElement Current { get; }
Public ReadOnly Property Current As MlineStyleElement
    Get
public:
property MlineStyleElement Current {
    MlineStyleElement get ();
}


IEnumerator_Current Property

IEnumerator_Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollectionEnumerator »IEnumerator..::..Current
Declaration Syntax
C# Visual Basic Visual C++
Object IEnumerator.Current { get; }
Private ReadOnly Property IEnumerator_Current As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ IEnumerator_Current {
    Object^ get () sealed = IEnumerator::Current::get;
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyleElementCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


ModelerFlavor Enumeration

ModelerFlavor Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ModelerFlavor
Declaration Syntax
C# Visual Basic Visual C++
public enum ModelerFlavor
Public Enumeration ModelerFlavor
public enum class ModelerFlavor
Members
Member | Description
ObjectsOnly |
RegionsOnly |
Full |


MoveGripPointsFlags Enumeration

MoveGripPointsFlags Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MoveGripPointsFlags
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbGripOperations::MoveGripPointsFlags")]
[FlagsAttribute]
public enum MoveGripPointsFlags
<WrapperAttribute("ZcDbGripOperations::MoveGripPointsFlags")> _
<FlagsAttribute> _
Public Enumeration MoveGripPointsFlags
[WrapperAttribute(L"ZcDbGripOperations::MoveGripPointsFlags")]
[FlagsAttribute]
public enum class MoveGripPointsFlags
Members
Member | Description
Keyboard |
ZDir |
ObjectTrack |
Polar |
Osnapped |


MoveType Enumeration

MoveType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MoveType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeader::MoveType")]
public enum MoveType
<WrapperAttribute("ZcDbMLeader::MoveType")> _
Public Enumeration MoveType
[WrapperAttribute(L"ZcDbMLeader::MoveType")]
public enum class MoveType
Members
Member | Description
MoveContentAndDoglegPoints |
MoveAllExceptArrowHeaderPoints |
MoveAllPoints |


MText Class

MText Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbMText")]
public class MText : Entity
<WrapperAttribute("AcDbMText")> _
Public Class MText _
    Inherits Entity
[WrapperAttribute(L"AcDbMText")]
public ref class MText : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MText()()()() |
 | AcadObject | (Inherited from DBObject.)
 | ActualHeight |
 | ActualWidth |
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlignChange |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Ascent |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Attachment |
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackgroundFill |
 | BackgroundFillColor |
 | BackgroundScaleFactor |
 | BackgroundTransparency |
 | BlockBegin |
 | BlockEnd |
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorChange |
 | ColorIndex | (Inherited from Entity.)
 | ColumnAutoHeight |
 | ColumnCount |
 | ColumnFlowReversed |
 | ColumnGutterWidth |
 | ColumnWidth |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Contents |
 | ConvertFieldToText()()()() |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CorrectSpelling()()()() |
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Descent |
 | Direction |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExplodeFragments(MTextFragmentCallback, Object, WorldDraw) |
 | ExplodeFragments(MTextFragmentCallback, Object) |
 | ExplodeFragments(MTextFragmentCallback) |
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FlowDirection |
 | FontChange |
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetBoundingPoints()()()() |
 | GetColumnHeight(Int32) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | getMTextWithFieldCodes()()()() |
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height |
 | HeightChange |
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | LineBreak |
 | LineSpaceDistance |
 | LineSpacingFactor |
 | LineSpacingStyle |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Location |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | NonBreakSpace |
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | ObliqueChange |
 | OpenedForModify | (Inherited from DBObject.)
 | OverlineOff |
 | OverlineOn |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | ParagraphBreak |
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttachmentMovingLocation(AttachmentPoint) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetColumnHeight(Int32, Double) |
 | SetContentsRtf(String) |
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetDynamicColumns(Double, Double, Boolean) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetStaticColumns(Double, Double, Int32) |
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | StackStart |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Text |
 | TextHeight |
 | TextStyle | Obsolete.
 | TextStyleId |
 | TextStyleName |
 | ToString()()()() | (Inherited from Object.)
 | TrackChange |
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UnderlineOff |
 | UnderlineOn |
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UseBackgroundColor |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width |
 | WidthChange |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | MText


MText Constructor

MText Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »MText()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MText()
Public Sub New
public:
MText()


ActualHeight Property

ActualHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ActualHeight
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double ActualHeight { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property ActualHeight As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double ActualHeight {
    double get ();
}


ActualWidth Property

ActualWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ActualWidth
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double ActualWidth { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property ActualWidth As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double ActualWidth {
    double get ();
}


AlignChange Property

AlignChange Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »AlignChange
Declaration Syntax
C# Visual Basic Visual C++
public static string AlignChange { get; }
Public Shared ReadOnly Property AlignChange As String
    Get
public:
static property String^ AlignChange {
    String^ get ();
}


Ascent Property

Ascent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Ascent
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Ascent { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property Ascent As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Ascent {
    double get ();
}


Attachment Property

Attachment Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Attachment
Declaration Syntax
C# Visual Basic Visual C++
public AttachmentPoint Attachment { get; set; }
Public Property Attachment As AttachmentPoint
    Get
    Set
public:
property AttachmentPoint Attachment {
    AttachmentPoint get ();
    void set (AttachmentPoint value);
}


BackgroundFill Property

BackgroundFill Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »BackgroundFill
Declaration Syntax
C# Visual Basic Visual C++
public bool BackgroundFill { get; set; }
Public Property BackgroundFill As Boolean
    Get
    Set
public:
property bool BackgroundFill {
    bool get ();
    void set (bool value);
}


BackgroundFillColor Property

BackgroundFillColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »BackgroundFillColor
Declaration Syntax
C# Visual Basic Visual C++
public Color BackgroundFillColor { get; set; }
Public Property BackgroundFillColor As Color
    Get
    Set
public:
property Color^ BackgroundFillColor {
    Color^ get ();
    void set (Color^ value);
}


BackgroundScaleFactor Property

BackgroundScaleFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »BackgroundScaleFactor
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double BackgroundScaleFactor { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property BackgroundScaleFactor As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double BackgroundScaleFactor {
    double get ();
    void set (double value);
}


BackgroundTransparency Property

BackgroundTransparency Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »BackgroundTransparency
Declaration Syntax
C# Visual Basic Visual C++
public Transparency BackgroundTransparency { get; set; }
Public Property BackgroundTransparency As Transparency
    Get
    Set
public:
property Transparency BackgroundTransparency {
    Transparency get ();
    void set (Transparency value);
}


BlockBegin Property

BlockBegin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »BlockBegin
Declaration Syntax
C# Visual Basic Visual C++
public static string BlockBegin { get; }
Public Shared ReadOnly Property BlockBegin As String
    Get
public:
static property String^ BlockBegin {
    String^ get ();
}


BlockEnd Property

BlockEnd Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »BlockEnd
Declaration Syntax
C# Visual Basic Visual C++
public static string BlockEnd { get; }
Public Shared ReadOnly Property BlockEnd As String
    Get
public:
static property String^ BlockEnd {
    String^ get ();
}


ColorChange Property

ColorChange Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ColorChange
Declaration Syntax
C# Visual Basic Visual C++
public static string ColorChange { get; }
Public Shared ReadOnly Property ColorChange As String
    Get
public:
static property String^ ColorChange {
    String^ get ();
}


ColumnAutoHeight Property

ColumnAutoHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ColumnAutoHeight
Declaration Syntax
C# Visual Basic Visual C++
public bool ColumnAutoHeight { get; set; }
Public Property ColumnAutoHeight As Boolean
    Get
    Set
public:
property bool ColumnAutoHeight {
    bool get ();
    void set (bool value);
}


ColumnCount Property

ColumnCount Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ColumnCount
Declaration Syntax
C# Visual Basic Visual C++
public int ColumnCount { get; set; }
Public Property ColumnCount As Integer
    Get
    Set
public:
property int ColumnCount {
    int get ();
    void set (int value);
}


ColumnFlowReversed Property

ColumnFlowReversed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ColumnFlowReversed
Declaration Syntax
C# Visual Basic Visual C++
public bool ColumnFlowReversed { get; set; }
Public Property ColumnFlowReversed As Boolean
    Get
    Set
public:
property bool ColumnFlowReversed {
    bool get ();
    void set (bool value);
}


ColumnGutterWidth Property

ColumnGutterWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ColumnGutterWidth
Declaration Syntax
C# Visual Basic Visual C++
public double ColumnGutterWidth { get; set; }
Public Property ColumnGutterWidth As Double
    Get
    Set
public:
property double ColumnGutterWidth {
    double get ();
    void set (double value);
}


ColumnWidth Property

ColumnWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ColumnWidth
Declaration Syntax
C# Visual Basic Visual C++
public double ColumnWidth { get; set; }
Public Property ColumnWidth As Double
    Get
    Set
public:
property double ColumnWidth {
    double get ();
    void set (double value);
}


Contents Property

Contents Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Contents
Declaration Syntax
C# Visual Basic Visual C++
public string Contents { get; set; }
Public Property Contents As String
    Get
    Set
public:
property String^ Contents {
    String^ get ();
    void set (String^ value);
}


ConvertFieldToText Method

ConvertFieldToText Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ConvertFieldToText()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ConvertFieldToText()
Public Sub ConvertFieldToText
public:
void ConvertFieldToText()


CorrectSpelling Method

CorrectSpelling Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »CorrectSpelling()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int CorrectSpelling()
Public Function CorrectSpelling As Integer
public:
int CorrectSpelling()


Descent Property

Descent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Descent
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Descent { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property Descent As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Descent {
    double get ();
}


Direction Property

Direction Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Direction
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Direction { get; set; }
Public Property Direction As Vector3d
    Get
    Set
public:
property Vector3d Direction {
    Vector3d get ();
    void set (Vector3d value);
}


ExplodeFragments Method

ExplodeFragments Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ExplodeFragments()()()()
Members
Icon | Member | Description
 | ExplodeFragments(MTextFragmentCallback, Object, WorldDraw) |
 | ExplodeFragments(MTextFragmentCallback, Object) |
 | ExplodeFragments(MTextFragmentCallback) |


ExplodeFragments Method (enumerator)

ExplodeFragments Method (enumerator)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ExplodeFragments(MTextFragmentCallback)
Declaration Syntax
C# Visual Basic Visual C++
public void ExplodeFragments(
    MTextFragmentCallback enumerator
)
Public Sub ExplodeFragments ( _
    enumerator As MTextFragmentCallback _
)
public:
void ExplodeFragments(
    MTextFragmentCallback^ enumerator
)
Parameters
enumerator(MTextFragmentCallback)


ExplodeFragments Method (enumerator, userData)

ExplodeFragments Method (enumerator, userData)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ExplodeFragments(MTextFragmentCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public void ExplodeFragments(
    MTextFragmentCallback enumerator,
    Object userData
)
Public Sub ExplodeFragments ( _
    enumerator As MTextFragmentCallback, _
    userData As Object _
)
public:
void ExplodeFragments(
    MTextFragmentCallback^ enumerator,
    Object^ userData
)
Parameters
enumerator(MTextFragmentCallback)
userData(Object)


ExplodeFragments Method (enumerator, userData, context)

ExplodeFragments Method (enumerator, userData, context)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ExplodeFragments(MTextFragmentCallback, Object, WorldDraw)
Declaration Syntax
C# Visual Basic Visual C++
public void ExplodeFragments(
    MTextFragmentCallback enumerator,
    Object userData,
    WorldDraw context
)
Public Sub ExplodeFragments ( _
    enumerator As MTextFragmentCallback, _
    userData As Object, _
    context As WorldDraw _
)
public:
void ExplodeFragments(
    MTextFragmentCallback^ enumerator,
    Object^ userData,
    WorldDraw^ context
)
Parameters
enumerator(MTextFragmentCallback)
userData(Object)
context(WorldDraw)


FlowDirection Property

FlowDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »FlowDirection
Declaration Syntax
C# Visual Basic Visual C++
public FlowDirection FlowDirection { get; set; }
Public Property FlowDirection As FlowDirection
    Get
    Set
public:
property FlowDirection FlowDirection {
    FlowDirection get ();
    void set (FlowDirection value);
}


FontChange Property

FontChange Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »FontChange
Declaration Syntax
C# Visual Basic Visual C++
public static string FontChange { get; }
Public Shared ReadOnly Property FontChange As String
    Get
public:
static property String^ FontChange {
    String^ get ();
}


GetBoundingPoints Method

GetBoundingPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »GetBoundingPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection GetBoundingPoints()
Public Function GetBoundingPoints As Point3dCollection
public:
Point3dCollection^ GetBoundingPoints()


GetColumnHeight Method (index)

GetColumnHeight Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »GetColumnHeight(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetColumnHeight(
    int index
)
Public Function GetColumnHeight ( _
    index As Integer _
) As Double
public:
double GetColumnHeight(
    int index
)
Parameters
index(Int32)


getMTextWithFieldCodes Method

getMTextWithFieldCodes Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »getMTextWithFieldCodes()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string getMTextWithFieldCodes()
Public Function getMTextWithFieldCodes As String
public:
String^ getMTextWithFieldCodes()


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Height
Declaration Syntax
C# Visual Basic Visual C++
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}


HeightChange Property

HeightChange Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »HeightChange
Declaration Syntax
C# Visual Basic Visual C++
public static string HeightChange { get; }
Public Shared ReadOnly Property HeightChange As String
    Get
public:
static property String^ HeightChange {
    String^ get ();
}


LineBreak Property

LineBreak Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »LineBreak
Declaration Syntax
C# Visual Basic Visual C++
public static string LineBreak { get; }
Public Shared ReadOnly Property LineBreak As String
    Get
public:
static property String^ LineBreak {
    String^ get ();
}


LineSpaceDistance Property

LineSpaceDistance Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »LineSpaceDistance
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double LineSpaceDistance { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property LineSpaceDistance As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double LineSpaceDistance {
    double get ();
    void set (double value);
}


LineSpacingFactor Property

LineSpacingFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »LineSpacingFactor
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double LineSpacingFactor { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property LineSpacingFactor As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double LineSpacingFactor {
    double get ();
    void set (double value);
}


LineSpacingStyle Property

LineSpacingStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »LineSpacingStyle
Declaration Syntax
C# Visual Basic Visual C++
public LineSpacingStyle LineSpacingStyle { get; set; }
Public Property LineSpacingStyle As LineSpacingStyle
    Get
    Set
public:
property LineSpacingStyle LineSpacingStyle {
    LineSpacingStyle get ();
    void set (LineSpacingStyle value);
}


Location Property

Location Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Location
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Location { get; set; }
Public Property Location As Point3d
    Get
    Set
public:
property Point3d Location {
    Point3d get ();
    void set (Point3d value);
}


NonBreakSpace Property

NonBreakSpace Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »NonBreakSpace
Declaration Syntax
C# Visual Basic Visual C++
public static string NonBreakSpace { get; }
Public Shared ReadOnly Property NonBreakSpace As String
    Get
public:
static property String^ NonBreakSpace {
    String^ get ();
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


ObliqueChange Property

ObliqueChange Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ObliqueChange
Declaration Syntax
C# Visual Basic Visual C++
public static string ObliqueChange { get; }
Public Shared ReadOnly Property ObliqueChange As String
    Get
public:
static property String^ ObliqueChange {
    String^ get ();
}


OverlineOff Property

OverlineOff Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »OverlineOff
Declaration Syntax
C# Visual Basic Visual C++
public static string OverlineOff { get; }
Public Shared ReadOnly Property OverlineOff As String
    Get
public:
static property String^ OverlineOff {
    String^ get ();
}


OverlineOn Property

OverlineOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »OverlineOn
Declaration Syntax
C# Visual Basic Visual C++
public static string OverlineOn { get; }
Public Shared ReadOnly Property OverlineOn As String
    Get
public:
static property String^ OverlineOn {
    String^ get ();
}


ParagraphBreak Property

ParagraphBreak Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »ParagraphBreak
Declaration Syntax
C# Visual Basic Visual C++
public static string ParagraphBreak { get; }
Public Shared ReadOnly Property ParagraphBreak As String
    Get
public:
static property String^ ParagraphBreak {
    String^ get ();
}


Rotation Property

Rotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Rotation
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Angle)]
public double Rotation { get; set; }
<UnitTypeAttribute(UnitType.Angle)> _
Public Property Rotation As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Angle)]
public:
property double Rotation {
    double get ();
    void set (double value);
}


SetAttachmentMovingLocation Method (value)

SetAttachmentMovingLocation Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »SetAttachmentMovingLocation(AttachmentPoint)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAttachmentMovingLocation(
    AttachmentPoint value
)
Public Sub SetAttachmentMovingLocation ( _
    value As AttachmentPoint _
)
public:
void SetAttachmentMovingLocation(
    AttachmentPoint value
)
Parameters
value(AttachmentPoint)


SetColumnHeight Method (index, height)

SetColumnHeight Method (index, height)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »SetColumnHeight(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetColumnHeight(
    int index,
    double height
)
Public Sub SetColumnHeight ( _
    index As Integer, _
    height As Double _
)
public:
void SetColumnHeight(
    int index,
    double height
)
Parameters
index(Int32)
height(Double)


SetContentsRtf Method (value)

SetContentsRtf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »SetContentsRtf(String)
Declaration Syntax
C# Visual Basic Visual C++
public int SetContentsRtf(
    string value
)
Public Function SetContentsRtf ( _
    value As String _
) As Integer
public:
int SetContentsRtf(
    String^ value
)
Parameters
value(String)


SetDynamicColumns Method (width, gutter, auto_height)

SetDynamicColumns Method (width, gutter, auto_height)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »SetDynamicColumns(Double, Double, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDynamicColumns(
    double width,
    double gutter,
    bool auto_height
)
Public Sub SetDynamicColumns ( _
    width As Double, _
    gutter As Double, _
    auto_height As Boolean _
)
public:
void SetDynamicColumns(
    double width,
    double gutter,
    bool auto_height
)
Parameters
width(Double)
gutter(Double)
auto_height(Boolean)


SetStaticColumns Method (width, gutter, count)

SetStaticColumns Method (width, gutter, count)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »SetStaticColumns(Double, Double, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SetStaticColumns(
    double width,
    double gutter,
    int count
)
Public Sub SetStaticColumns ( _
    width As Double, _
    gutter As Double, _
    count As Integer _
)
public:
void SetStaticColumns(
    double width,
    double gutter,
    int count
)
Parameters
width(Double)
gutter(Double)
count(Int32)


StackStart Property

StackStart Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »StackStart
Declaration Syntax
C# Visual Basic Visual C++
public static string StackStart { get; }
Public Shared ReadOnly Property StackStart As String
    Get
public:
static property String^ StackStart {
    String^ get ();
}


Text Property

Text Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Text
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}


TextHeight Property

TextHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »TextHeight
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double TextHeight { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property TextHeight As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double TextHeight {
    double get ();
    void set (double value);
}


TextStyle Property

TextStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »TextStyle
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use TextStyleId functionality instead.")]
public ObjectId TextStyle { get; set; }
<ObsoleteAttribute("Use TextStyleId functionality instead.")> _
Public Property TextStyle As ObjectId
    Get
    Set
[ObsoleteAttribute(L"Use TextStyleId functionality instead.")]
public:
property ObjectId TextStyle {
    ObjectId get ();
    void set (ObjectId value);
}


TextStyleId Property

TextStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »TextStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId TextStyleId { get; set; }
Public Property TextStyleId As ObjectId
    Get
    Set
public:
property ObjectId TextStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


TextStyleName Property

TextStyleName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »TextStyleName
Declaration Syntax
C# Visual Basic Visual C++
public string TextStyleName { get; }
Public ReadOnly Property TextStyleName As String
    Get
public:
property String^ TextStyleName {
    String^ get ();
}


TrackChange Property

TrackChange Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »TrackChange
Declaration Syntax
C# Visual Basic Visual C++
public static string TrackChange { get; }
Public Shared ReadOnly Property TrackChange As String
    Get
public:
static property String^ TrackChange {
    String^ get ();
}


UnderlineOff Property

UnderlineOff Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »UnderlineOff
Declaration Syntax
C# Visual Basic Visual C++
public static string UnderlineOff { get; }
Public Shared ReadOnly Property UnderlineOff As String
    Get
public:
static property String^ UnderlineOff {
    String^ get ();
}


UnderlineOn Property

UnderlineOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »UnderlineOn
Declaration Syntax
C# Visual Basic Visual C++
public static string UnderlineOn { get; }
Public Shared ReadOnly Property UnderlineOn As String
    Get
public:
static property String^ UnderlineOn {
    String^ get ();
}


UseBackgroundColor Property

UseBackgroundColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »UseBackgroundColor
Declaration Syntax
C# Visual Basic Visual C++
public bool UseBackgroundColor { get; set; }
Public Property UseBackgroundColor As Boolean
    Get
    Set
public:
property bool UseBackgroundColor {
    bool get ();
    void set (bool value);
}


Width Property

Width Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Width
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Width { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Width As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Width {
    double get ();
    void set (double value);
}


WidthChange Property

WidthChange Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »WidthChange
Declaration Syntax
C# Visual Basic Visual C++
public static string WidthChange { get; }
Public Shared ReadOnly Property WidthChange As String
    Get
public:
static property String^ WidthChange {
    String^ get ();
}


MTextFragment Class

MTextFragment Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMTextFragment")]
public sealed class MTextFragment : DisposableWrapper
<WrapperAttribute("ZcDbMTextFragment")> _
Public NotInheritable Class MTextFragment _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcDbMTextFragment")]
public ref class MTextFragment sealed : public DisposableWrapper
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BigFont |
 | Bold |
 | CapsHeight |
 | Color |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Direction |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Extents |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetOverLinePoints()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GetUnderLinePoints()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Italic |
 | LineBreak |
 | Location |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewParagraph |
 | Normal |
 | ObliqueAngle |
 | Overlined |
 | ShxFont |
 | StackBottom |
 | StackTop |
 | Text |
 | ToString()()()() | (Inherited from Object.)
 | TrackingFactor |
 | TrueTypeFont |
 | Underlined |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | WidthFactor |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | MTextFragment


BigFont Property

BigFont Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »BigFont
Declaration Syntax
C# Visual Basic Visual C++
public string BigFont { get; }
Public ReadOnly Property BigFont As String
    Get
public:
property String^ BigFont {
    String^ get ();
}


Bold Property

Bold Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Bold
Declaration Syntax
C# Visual Basic Visual C++
public bool Bold { get; }
Public ReadOnly Property Bold As Boolean
    Get
public:
property bool Bold {
    bool get ();
}


CapsHeight Property

CapsHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »CapsHeight
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double CapsHeight { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property CapsHeight As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double CapsHeight {
    double get ();
}


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Color
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor Color { get; }
Public ReadOnly Property Color As EntityColor
    Get
public:
property EntityColor Color {
    EntityColor get ();
}


Direction Property

Direction Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Direction
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Direction { get; }
Public ReadOnly Property Direction As Vector3d
    Get
public:
property Vector3d Direction {
    Vector3d get ();
}


Extents Property

Extents Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Extents
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Extents { get; }
Public ReadOnly Property Extents As Point2d
    Get
public:
property Point2d Extents {
    Point2d get ();
}


GetOverLinePoints Method

GetOverLinePoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »GetOverLinePoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] GetOverLinePoints()
Public Function GetOverLinePoints As Point3d()
public:
array<Point3d>^ GetOverLinePoints()


GetUnderLinePoints Method

GetUnderLinePoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »GetUnderLinePoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] GetUnderLinePoints()
Public Function GetUnderLinePoints As Point3d()
public:
array<Point3d>^ GetUnderLinePoints()


Italic Property

Italic Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Italic
Declaration Syntax
C# Visual Basic Visual C++
public bool Italic { get; }
Public ReadOnly Property Italic As Boolean
    Get
public:
property bool Italic {
    bool get ();
}


LineBreak Property

LineBreak Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »LineBreak
Declaration Syntax
C# Visual Basic Visual C++
public bool LineBreak { get; }
Public ReadOnly Property LineBreak As Boolean
    Get
public:
property bool LineBreak {
    bool get ();
}


Location Property

Location Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Location
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Location { get; }
Public ReadOnly Property Location As Point3d
    Get
public:
property Point3d Location {
    Point3d get ();
}


NewParagraph Property

NewParagraph Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »NewParagraph
Declaration Syntax
C# Visual Basic Visual C++
public bool NewParagraph { get; }
Public ReadOnly Property NewParagraph As Boolean
    Get
public:
property bool NewParagraph {
    bool get ();
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; }
Public ReadOnly Property Normal As Vector3d
    Get
public:
property Vector3d Normal {
    Vector3d get ();
}


ObliqueAngle Property

ObliqueAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »ObliqueAngle
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Angle)]
public double ObliqueAngle { get; }
<UnitTypeAttribute(UnitType.Angle)> _
Public ReadOnly Property ObliqueAngle As Double
    Get
[UnitTypeAttribute(UnitType::Angle)]
public:
property double ObliqueAngle {
    double get ();
}


Overlined Property

Overlined Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Overlined
Declaration Syntax
C# Visual Basic Visual C++
public bool Overlined { get; }
Public ReadOnly Property Overlined As Boolean
    Get
public:
property bool Overlined {
    bool get ();
}


ShxFont Property

ShxFont Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »ShxFont
Declaration Syntax
C# Visual Basic Visual C++
public string ShxFont { get; }
Public ReadOnly Property ShxFont As String
    Get
public:
property String^ ShxFont {
    String^ get ();
}


StackBottom Property

StackBottom Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »StackBottom
Declaration Syntax
C# Visual Basic Visual C++
public bool StackBottom { get; }
Public ReadOnly Property StackBottom As Boolean
    Get
public:
property bool StackBottom {
    bool get ();
}


StackTop Property

StackTop Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »StackTop
Declaration Syntax
C# Visual Basic Visual C++
public bool StackTop { get; }
Public ReadOnly Property StackTop As Boolean
    Get
public:
property bool StackTop {
    bool get ();
}


Text Property

Text Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Text
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}


TrackingFactor Property

TrackingFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »TrackingFactor
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double TrackingFactor { get; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public ReadOnly Property TrackingFactor As Double
    Get
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double TrackingFactor {
    double get ();
}


TrueTypeFont Property

TrueTypeFont Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »TrueTypeFont
Declaration Syntax
C# Visual Basic Visual C++
public string TrueTypeFont { get; }
Public ReadOnly Property TrueTypeFont As String
    Get
public:
property String^ TrueTypeFont {
    String^ get ();
}


Underlined Property

Underlined Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Underlined
Declaration Syntax
C# Visual Basic Visual C++
public bool Underlined { get; }
Public ReadOnly Property Underlined As Boolean
    Get
public:
property bool Underlined {
    bool get ();
}


WidthFactor Property

WidthFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »WidthFactor
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double WidthFactor { get; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public ReadOnly Property WidthFactor As Double
    Get
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double WidthFactor {
    double get ();
}


MTextFragmentCallback Delegate

MTextFragmentCallback Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragmentCallback
Declaration Syntax
C# Visual Basic Visual C++
public delegate MTextFragmentCallbackStatus MTextFragmentCallback(
    MTextFragment fragment,
    Object userdata
)
Public Delegate Function MTextFragmentCallback ( _
    fragment As MTextFragment, _
    userdata As Object _
) As MTextFragmentCallbackStatus
public delegate MTextFragmentCallbackStatus MTextFragmentCallback(
    MTextFragment^ fragment,
    Object^ userdata
)
Parameters
fragment(MTextFragment)
userdata(Object)


MTextFragmentCallbackStatus Enumeration

MTextFragmentCallbackStatus Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragmentCallbackStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum MTextFragmentCallbackStatus
Public Enumeration MTextFragmentCallbackStatus
public enum class MTextFragmentCallbackStatus
Members
Member | Description
Terminate |
Continue |


NewLayerNotification Enumeration

NewLayerNotification Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NewLayerNotification
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum NewLayerNotification
<FlagsAttribute> _
Public Enumeration NewLayerNotification
[FlagsAttribute]
public enum class NewLayerNotification
Members
Member | Description
NotifyOnXrefAttachAndReload |
NotifyOnSave |
NotifyOnPlot |
NotifyOnOpen |
NotifyOnLayerStateRestore |
NotifyOnInsert |
NoNewLayerNotification |


NurbsData Structure

NurbsData Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData
Declaration Syntax
C# Visual Basic Visual C++
public struct NurbsData
Public Structure NurbsData
public value class NurbsData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Closed |
 | ControlPointTolerance |
 | Degree |
 | Equality(NurbsData, NurbsData) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetControlPoints()()()() |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetKnots()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GetWeights()()()() |
 | Inequality(NurbsData, NurbsData) |
 | IsEqualTo(NurbsData, Tolerance) |
 | IsEqualTo(NurbsData) |
 | KnotTolerance |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Periodic |
 | Rational |
 | ToString()()()() | (Inherited from ValueType.)


Closed Property

Closed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »Closed
Declaration Syntax
C# Visual Basic Visual C++
public bool Closed { get; }
Public ReadOnly Property Closed As Boolean
    Get
public:
property bool Closed {
    bool get ();
}


ControlPointTolerance Property

ControlPointTolerance Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »ControlPointTolerance
Declaration Syntax
C# Visual Basic Visual C++
public double ControlPointTolerance { get; }
Public ReadOnly Property ControlPointTolerance As Double
    Get
public:
property double ControlPointTolerance {
    double get ();
}


Degree Property

Degree Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »Degree
Declaration Syntax
C# Visual Basic Visual C++
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »Equality(NurbsData, NurbsData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    NurbsData a,
    NurbsData b
)
Public Shared Operator = ( _
    a As NurbsData, _
    b As NurbsData _
) As Boolean
public:
static bool operator ==(
    NurbsData a,
    NurbsData b
)
Parameters
a(NurbsData)
b(NurbsData)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetControlPoints Method

GetControlPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »GetControlPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection GetControlPoints()
Public Function GetControlPoints As Point3dCollection
public:
Point3dCollection^ GetControlPoints()


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetKnots Method

GetKnots Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »GetKnots()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetKnots()
Public Function GetKnots As DoubleCollection
public:
DoubleCollection^ GetKnots()


GetWeights Method

GetWeights Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »GetWeights()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetWeights()
Public Function GetWeights As DoubleCollection
public:
DoubleCollection^ GetWeights()


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »Inequality(NurbsData, NurbsData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    NurbsData a,
    NurbsData b
)
Public Shared Operator <> ( _
    a As NurbsData, _
    b As NurbsData _
) As Boolean
public:
static bool operator !=(
    NurbsData a,
    NurbsData b
)
Parameters
a(NurbsData)
b(NurbsData)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(NurbsData, Tolerance) |
 | IsEqualTo(NurbsData) |


IsEqualTo Method (other)

IsEqualTo Method (other)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »IsEqualTo(NurbsData)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    NurbsData other
)
Public Function IsEqualTo ( _
    other As NurbsData _
) As Boolean
public:
bool IsEqualTo(
    NurbsData other
)
Parameters
other(NurbsData)


IsEqualTo Method (other, tolerance)

IsEqualTo Method (other, tolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »IsEqualTo(NurbsData, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    NurbsData other,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    other As NurbsData, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    NurbsData other,
    Tolerance tolerance
)
Parameters
other(NurbsData)
tolerance(Tolerance)


KnotTolerance Property

KnotTolerance Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »KnotTolerance
Declaration Syntax
C# Visual Basic Visual C++
public double KnotTolerance { get; }
Public ReadOnly Property KnotTolerance As Double
    Get
public:
property double KnotTolerance {
    double get ();
}


Periodic Property

Periodic Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »Periodic
Declaration Syntax
C# Visual Basic Visual C++
public bool Periodic { get; }
Public ReadOnly Property Periodic As Boolean
    Get
public:
property bool Periodic {
    bool get ();
}


Rational Property

Rational Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »NurbsData »Rational
Declaration Syntax
C# Visual Basic Visual C++
public bool Rational { get; }
Public ReadOnly Property Rational As Boolean
    Get
public:
property bool Rational {
    bool get ();
}


ObjectClosedEventArgs Class

ObjectClosedEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectClosedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ObjectClosedEventArgs : EventArgs
Public NotInheritable Class ObjectClosedEventArgs _
    Inherits EventArgs
public ref class ObjectClosedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ObjectClosedEventArgs


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectClosedEventArgs »Id
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Id { get; }
Public ReadOnly Property Id As ObjectId
    Get
public:
property ObjectId Id {
    ObjectId get ();
}


ObjectClosedEventHandler Delegate

ObjectClosedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectClosedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ObjectClosedEventHandler(
    Object sender,
    ObjectClosedEventArgs e
)
Public Delegate Sub ObjectClosedEventHandler ( _
    sender As Object, _
    e As ObjectClosedEventArgs _
)
public delegate void ObjectClosedEventHandler(
    Object^ sender,
    ObjectClosedEventArgs^ e
)
Parameters
sender(Object)
e(ObjectClosedEventArgs)


ObjectContext Class

ObjectContext Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContext
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbObjectContext")]
public abstract class ObjectContext : RXObject
<WrapperAttribute("ZcDbObjectContext")> _
Public MustInherit Class ObjectContext _
    Inherits RXObject
[WrapperAttribute(L"ZcDbObjectContext")]
public ref class ObjectContext abstract : public RXObject
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CollectionName |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UniqueIdentifier |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | ObjectContext
 |  |  |  |  | AnnotationScale


CollectionName Property

CollectionName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContext »CollectionName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string CollectionName { get; }
Public Overridable ReadOnly Property CollectionName As String
    Get
public:
virtual property String^ CollectionName {
    String^ get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContext »Name
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}


UniqueIdentifier Property

UniqueIdentifier Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContext »UniqueIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtr UniqueIdentifier { get; }
Public Overridable ReadOnly Property UniqueIdentifier As IntPtr
    Get
public:
virtual property IntPtr UniqueIdentifier {
    IntPtr get ();
}


ObjectContextCollection Class

ObjectContextCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbObjectContextCollection")]
public abstract class ObjectContextCollection : RXObject,
    IEnumerable
<WrapperAttribute("ZcDbObjectContextCollection")> _
Public MustInherit Class ObjectContextCollection _
    Inherits RXObject _
    Implements IEnumerable
[WrapperAttribute(L"ZcDbObjectContextCollection")]
public ref class ObjectContextCollection abstract : public RXObject,
    IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddContext(ObjectContext) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CurrentContext |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetContext(String) |
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | HasContext(String) |
 | IEnumerable_GetEnumerator()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RemoveContext(String) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | ObjectContextCollection


AddContext Method (ctx)

AddContext Method (ctx)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection »AddContext(ObjectContext)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddContext(
    ObjectContext ctx
)
Public Overridable Sub AddContext ( _
    ctx As ObjectContext _
)
public:
virtual void AddContext(
    ObjectContext^ ctx
)
Parameters
ctx(ObjectContext)


CurrentContext Property

CurrentContext Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection »CurrentContext
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectContext CurrentContext { get; set; }
Public Overridable Property CurrentContext As ObjectContext
    Get
    Set
public:
virtual property ObjectContext^ CurrentContext {
    ObjectContext^ get ();
    void set (ObjectContext^ value);
}


GetContext Method (contextName)

GetContext Method (contextName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection »GetContext(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectContext GetContext(
    string contextName
)
Public Overridable Function GetContext ( _
    contextName As String _
) As ObjectContext
public:
virtual ObjectContext^ GetContext(
    String^ contextName
)
Parameters
contextName(String)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectContextCollectionEnumerator GetEnumerator()
Public Function GetEnumerator As ObjectContextCollectionEnumerator
public:
ObjectContextCollectionEnumerator^ GetEnumerator()


HasContext Method (contextName)

HasContext Method (contextName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection »HasContext(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool HasContext(
    string contextName
)
Public Overridable Function HasContext ( _
    contextName As String _
) As Boolean
public:
virtual bool HasContext(
    String^ contextName
)
Parameters
contextName(String)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator IEnumerable_GetEnumerator()
Public Overridable Function IEnumerable_GetEnumerator As IEnumerator
public:
virtual IEnumerator^ IEnumerable_GetEnumerator()


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection »Name
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}


RemoveContext Method (contextName)

RemoveContext Method (contextName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection »RemoveContext(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveContext(
    string contextName
)
Public Overridable Sub RemoveContext ( _
    contextName As String _
)
public:
virtual void RemoveContext(
    String^ contextName
)
Parameters
contextName(String)


ObjectContextCollectionEnumerator Class

ObjectContextCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public class ObjectContextCollectionEnumerator : RXObject,
    IEnumerator
Public Class ObjectContextCollectionEnumerator _
    Inherits RXObject _
    Implements IEnumerator
public ref class ObjectContextCollectionEnumerator : public RXObject,
    IEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Current |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerator_get_Current()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | ObjectContextCollectionEnumerator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public ObjectContext Current { get; }
Public ReadOnly Property Current As ObjectContext
    Get
public:
property ObjectContext^ Current {
    ObjectContext^ get ();
}


IEnumerator_get_Current Method

IEnumerator_get_Current Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollectionEnumerator »IEnumerator_get_Current()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object IEnumerator_get_Current()
Public Overridable Function IEnumerator_get_Current As Object
public:
virtual Object^ IEnumerator_get_Current()


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()


ObjectContextManager Class

ObjectContextManager Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextManager
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbObjectContextManager")]
public class ObjectContextManager : RXObject
<WrapperAttribute("ZcDbObjectContextManager")> _
Public Class ObjectContextManager _
    Inherits RXObject
[WrapperAttribute(L"ZcDbObjectContextManager")]
public ref class ObjectContextManager : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ObjectContextManager()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetContextCollection(String) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RegisterContextCollection(String, ObjectContextCollection) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UnregisterContextCollection(String) |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | ObjectContextManager


ObjectContextManager Constructor

ObjectContextManager Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextManager »ObjectContextManager()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectContextManager()
Public Sub New
public:
ObjectContextManager()


GetContextCollection Method (collectionName)

GetContextCollection Method (collectionName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextManager »GetContextCollection(String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectContextCollection GetContextCollection(
    string collectionName
)
Public Function GetContextCollection ( _
    collectionName As String _
) As ObjectContextCollection
public:
ObjectContextCollection^ GetContextCollection(
    String^ collectionName
)
Parameters
collectionName(String)


RegisterContextCollection Method (collectionName, collection)

RegisterContextCollection Method (collectionName, collection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextManager »RegisterContextCollection(String, ObjectContextCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void RegisterContextCollection(
    string collectionName,
    ObjectContextCollection collection
)
Public Sub RegisterContextCollection ( _
    collectionName As String, _
    collection As ObjectContextCollection _
)
public:
void RegisterContextCollection(
    String^ collectionName,
    ObjectContextCollection^ collection
)
Parameters
collectionName(String)
collection(ObjectContextCollection)


UnregisterContextCollection Method (collectionName)

UnregisterContextCollection Method (collectionName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextManager »UnregisterContextCollection(String)
Declaration Syntax
C# Visual Basic Visual C++
public void UnregisterContextCollection(
    string collectionName
)
Public Sub UnregisterContextCollection ( _
    collectionName As String _
)
public:
void UnregisterContextCollection(
    String^ collectionName
)
Parameters
collectionName(String)


ObjectErasedEventArgs Class

ObjectErasedEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectErasedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ObjectErasedEventArgs : EventArgs
Public NotInheritable Class ObjectErasedEventArgs _
    Inherits EventArgs
public ref class ObjectErasedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DBObject |
 | Equals(Object) | (Inherited from Object.)
 | Erased |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ObjectErasedEventArgs


DBObject Property

DBObject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectErasedEventArgs »DBObject
Declaration Syntax
C# Visual Basic Visual C++
public DBObject DBObject { get; }
Public ReadOnly Property DBObject As DBObject
    Get
public:
property DBObject^ DBObject {
    DBObject^ get ();
}


Erased Property

Erased Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectErasedEventArgs »Erased
Declaration Syntax
C# Visual Basic Visual C++
public bool Erased { get; }
Public ReadOnly Property Erased As Boolean
    Get
public:
property bool Erased {
    bool get ();
}


ObjectErasedEventHandler Delegate

ObjectErasedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectErasedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ObjectErasedEventHandler(
    Object sender,
    ObjectErasedEventArgs e
)
Public Delegate Sub ObjectErasedEventHandler ( _
    sender As Object, _
    e As ObjectErasedEventArgs _
)
public delegate void ObjectErasedEventHandler(
    Object^ sender,
    ObjectErasedEventArgs^ e
)
Parameters
sender(Object)
e(ObjectErasedEventArgs)


ObjectEventArgs Class

ObjectEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ObjectEventArgs : EventArgs
Public NotInheritable Class ObjectEventArgs _
    Inherits EventArgs
public ref class ObjectEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DBObject |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ObjectEventArgs


DBObject Property

DBObject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectEventArgs »DBObject
Declaration Syntax
C# Visual Basic Visual C++
public DBObject DBObject { get; }
Public ReadOnly Property DBObject As DBObject
    Get
public:
property DBObject^ DBObject {
    DBObject^ get ();
}


ObjectEventHandler Delegate

ObjectEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ObjectEventHandler(
    Object sender,
    ObjectEventArgs e
)
Public Delegate Sub ObjectEventHandler ( _
    sender As Object, _
    e As ObjectEventArgs _
)
public delegate void ObjectEventHandler(
    Object^ sender,
    ObjectEventArgs^ e
)
Parameters
sender(Object)
e(ObjectEventArgs)


ObjectId Structure

ObjectId Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbObjectId")]
public struct ObjectId
<WrapperAttribute("ZcDbObjectId")> _
Public Structure ObjectId
[WrapperAttribute(L"ZcDbObjectId")]
public value class ObjectId
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ObjectId(IntPtr) |
 | Compare(ObjectId) |
 | CompareTo(ObjectId) |
 | ConvertToRedirectedId()()()() |
 | Database |
 | Equality(ObjectId, ObjectId) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetObject(OpenMode, Boolean, Boolean) |
 | GetObject(OpenMode, Boolean) |
 | GetObject(OpenMode) |
 | GetType()()()() | (Inherited from Object.)
 | GreaterThan(ObjectId, ObjectId) |
 | Handle |
 | Inequality(ObjectId, ObjectId) |
 | IsEffectivelyErased |
 | IsErased |
 | IsNull |
 | IsResident |
 | IsValid |
 | LessThan(ObjectId, ObjectId) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NonForwardedHandle |
 | Null |
 | ObjectClass |
 | ObjectLeftOnDisk |
 | OldId | Obsolete.
 | OldIdPtr |
 | Open(OpenMode, Boolean, Boolean) | Obsolete.
 | Open(OpenMode, Boolean) | Obsolete.
 | Open(OpenMode) | Obsolete.
 | OriginalDatabase |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ObjectId Constructor (pId)

ObjectId Constructor (pId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »ObjectId(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId(
    IntPtr pId
)
Public Sub New ( _
    pId As IntPtr _
)
public:
ObjectId(
    IntPtr pId
)
Parameters
pId(IntPtr)


Compare Method (value1)

Compare Method (value1)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Compare(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool Compare(
    ObjectId value1
)
Public Function Compare ( _
    value1 As ObjectId _
) As Boolean
public:
bool Compare(
    ObjectId value1
)
Parameters
value1(ObjectId)


CompareTo Method (other)

CompareTo Method (other)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »CompareTo(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    ObjectId other
)
Public Function CompareTo ( _
    other As ObjectId _
) As Integer
public:
int CompareTo(
    ObjectId other
)
Parameters
other(ObjectId)


ConvertToRedirectedId Method

ConvertToRedirectedId Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »ConvertToRedirectedId()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ConvertToRedirectedId()
Public Function ConvertToRedirectedId As ObjectId
public:
ObjectId ConvertToRedirectedId()


Database Property

Database Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Database
Declaration Syntax
C# Visual Basic Visual C++
public Database Database { get; }
Public ReadOnly Property Database As Database
    Get
public:
property Database^ Database {
    Database^ get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Equality(ObjectId, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    ObjectId a,
    ObjectId b
)
Public Shared Operator = ( _
    a As ObjectId, _
    b As ObjectId _
) As Boolean
public:
static bool operator ==(
    ObjectId a,
    ObjectId b
)
Parameters
a(ObjectId)
b(ObjectId)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetObject Method

GetObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »GetObject()()()()
Members
Icon | Member | Description
 | GetObject(OpenMode, Boolean, Boolean) |
 | GetObject(OpenMode, Boolean) |
 | GetObject(OpenMode) |


GetObject Method (mode)

GetObject Method (mode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »GetObject(OpenMode)
Declaration Syntax
C# Visual Basic Visual C++
public DBObject GetObject(
    OpenMode mode
)
Public Function GetObject ( _
    mode As OpenMode _
) As DBObject
public:
DBObject^ GetObject(
    OpenMode mode
)
Parameters
mode(OpenMode)


GetObject Method (mode, openErased)

GetObject Method (mode, openErased)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »GetObject(OpenMode, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DBObject GetObject(
    OpenMode mode,
    bool openErased
)
Public Function GetObject ( _
    mode As OpenMode, _
    openErased As Boolean _
) As DBObject
public:
DBObject^ GetObject(
    OpenMode mode,
    bool openErased
)
Parameters
mode(OpenMode)
openErased(Boolean)


GetObject Method (mode, openErased, forceOpenOnLockedLayer)

GetObject Method (mode, openErased, forceOpenOnLockedLayer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »GetObject(OpenMode, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DBObject GetObject(
    OpenMode mode,
    bool openErased,
    bool forceOpenOnLockedLayer
)
Public Function GetObject ( _
    mode As OpenMode, _
    openErased As Boolean, _
    forceOpenOnLockedLayer As Boolean _
) As DBObject
public:
DBObject^ GetObject(
    OpenMode mode,
    bool openErased,
    bool forceOpenOnLockedLayer
)
Parameters
mode(OpenMode)
openErased(Boolean)
forceOpenOnLockedLayer(Boolean)


GreaterThan Operator

GreaterThan Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »GreaterThan(ObjectId, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator >(
    ObjectId value1,
    ObjectId value2
)
Public Shared Operator > ( _
    value1 As ObjectId, _
    value2 As ObjectId _
) As Boolean
public:
static bool operator >(
    ObjectId value1,
    ObjectId value2
)
Parameters
value1(ObjectId)
value2(ObjectId)


Handle Property

Handle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Handle
Declaration Syntax
C# Visual Basic Visual C++
public Handle Handle { get; }
Public ReadOnly Property Handle As Handle
    Get
public:
property Handle Handle {
    Handle get ();
}


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Inequality(ObjectId, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    ObjectId a,
    ObjectId b
)
Public Shared Operator <> ( _
    a As ObjectId, _
    b As ObjectId _
) As Boolean
public:
static bool operator !=(
    ObjectId a,
    ObjectId b
)
Parameters
a(ObjectId)
b(ObjectId)


IsEffectivelyErased Property

IsEffectivelyErased Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »IsEffectivelyErased
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEffectivelyErased { get; }
Public ReadOnly Property IsEffectivelyErased As Boolean
    Get
public:
property bool IsEffectivelyErased {
    bool get ();
}


IsErased Property

IsErased Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »IsErased
Declaration Syntax
C# Visual Basic Visual C++
public bool IsErased { get; }
Public ReadOnly Property IsErased As Boolean
    Get
public:
property bool IsErased {
    bool get ();
}


IsNull Property

IsNull Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »IsNull
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNull { get; }
Public ReadOnly Property IsNull As Boolean
    Get
public:
property bool IsNull {
    bool get ();
}


IsResident Property

IsResident Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »IsResident
Declaration Syntax
C# Visual Basic Visual C++
public bool IsResident { get; }
Public ReadOnly Property IsResident As Boolean
    Get
public:
property bool IsResident {
    bool get ();
}


IsValid Property

IsValid Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »IsValid
Declaration Syntax
C# Visual Basic Visual C++
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}


LessThan Operator

LessThan Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »LessThan(ObjectId, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator <(
    ObjectId value1,
    ObjectId value2
)
Public Shared Operator < ( _
    value1 As ObjectId, _
    value2 As ObjectId _
) As Boolean
public:
static bool operator <(
    ObjectId value1,
    ObjectId value2
)
Parameters
value1(ObjectId)
value2(ObjectId)


NonForwardedHandle Property

NonForwardedHandle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »NonForwardedHandle
Declaration Syntax
C# Visual Basic Visual C++
public Handle NonForwardedHandle { get; }
Public ReadOnly Property NonForwardedHandle As Handle
    Get
public:
property Handle NonForwardedHandle {
    Handle get ();
}


Null Property

Null Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Null
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId Null { get; }
Public Shared ReadOnly Property Null As ObjectId
    Get
public:
static property ObjectId Null {
    ObjectId get ();
}


ObjectClass Property

ObjectClass Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »ObjectClass
Declaration Syntax
C# Visual Basic Visual C++
public RXClass ObjectClass { get; }
Public ReadOnly Property ObjectClass As RXClass
    Get
public:
property RXClass^ ObjectClass {
    RXClass^ get ();
}


ObjectLeftOnDisk Property

ObjectLeftOnDisk Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »ObjectLeftOnDisk
Declaration Syntax
C# Visual Basic Visual C++
public bool ObjectLeftOnDisk { get; }
Public ReadOnly Property ObjectLeftOnDisk As Boolean
    Get
public:
property bool ObjectLeftOnDisk {
    bool get ();
}


OldId Property

OldId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »OldId
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use System::IntPtr OldIdPtr")]
public long OldId { get; }
<ObsoleteAttribute("Use System::IntPtr OldIdPtr")> _
Public ReadOnly Property OldId As Long
    Get
[ObsoleteAttribute(L"Use System::IntPtr OldIdPtr")]
public:
property long long OldId {
    long long get ();
}


OldIdPtr Property

OldIdPtr Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »OldIdPtr
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr OldIdPtr { get; }
Public ReadOnly Property OldIdPtr As IntPtr
    Get
public:
property IntPtr OldIdPtr {
    IntPtr get ();
}


Open Method

Open Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Open()()()()
Members
Icon | Member | Description
 | Open(OpenMode, Boolean, Boolean) | Obsolete.
 | Open(OpenMode, Boolean) | Obsolete.
 | Open(OpenMode) | Obsolete.


Open Method (mode)

Open Method (mode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Open(OpenMode)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("For advanced use only. Use GetObject instead")]
public DBObject Open(
    OpenMode mode
)
<ObsoleteAttribute("For advanced use only. Use GetObject instead")> _
Public Function Open ( _
    mode As OpenMode _
) As DBObject
[ObsoleteAttribute(L"For advanced use only. Use GetObject instead")]
public:
DBObject^ Open(
    OpenMode mode
)
Parameters
mode(OpenMode)


Open Method (mode, openErased)

Open Method (mode, openErased)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Open(OpenMode, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("For advanced use only. Use GetObject instead")]
public DBObject Open(
    OpenMode mode,
    bool openErased
)
<ObsoleteAttribute("For advanced use only. Use GetObject instead")> _
Public Function Open ( _
    mode As OpenMode, _
    openErased As Boolean _
) As DBObject
[ObsoleteAttribute(L"For advanced use only. Use GetObject instead")]
public:
DBObject^ Open(
    OpenMode mode,
    bool openErased
)
Parameters
mode(OpenMode)
openErased(Boolean)


Open Method (mode, openErased, forceOpenOnLockedLayer)

Open Method (mode, openErased, forceOpenOnLockedLayer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »Open(OpenMode, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("For advanced use only. Use GetObject instead")]
public DBObject Open(
    OpenMode mode,
    bool openErased,
    bool forceOpenOnLockedLayer
)
<ObsoleteAttribute("For advanced use only. Use GetObject instead")> _
Public Function Open ( _
    mode As OpenMode, _
    openErased As Boolean, _
    forceOpenOnLockedLayer As Boolean _
) As DBObject
[ObsoleteAttribute(L"For advanced use only. Use GetObject instead")]
public:
DBObject^ Open(
    OpenMode mode,
    bool openErased,
    bool forceOpenOnLockedLayer
)
Parameters
mode(OpenMode)
openErased(Boolean)
forceOpenOnLockedLayer(Boolean)


OriginalDatabase Property

OriginalDatabase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »OriginalDatabase
Declaration Syntax
C# Visual Basic Visual C++
public Database OriginalDatabase { get; }
Public ReadOnly Property OriginalDatabase As Database
    Get
public:
property Database^ OriginalDatabase {
    Database^ get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectId »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


ObjectIdCollection Class

ObjectIdCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbObjectIdArray")]
public sealed class ObjectIdCollection : DisposableWrapper,
    IList
<WrapperAttribute("ZcDbObjectIdArray")> _
Public NotInheritable Class ObjectIdCollection _
    Inherits DisposableWrapper _
    Implements IList
[WrapperAttribute(L"ZcDbObjectIdArray")]
public ref class ObjectIdCollection sealed : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ObjectIdCollection(array<ObjectId>[]()[][]) |
 | ObjectIdCollection()()()() |
 | Add(ObjectId) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(ObjectId) |
 | CopyTo(array<ObjectId>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Remove(Object) |
 | IndexOf(ObjectId) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, ObjectId) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IList..::..IsFixedSize |
 | IList..::..IsReadOnly |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(ObjectId) |
 | RemoveAt(Int32) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | ObjectIdCollection


ObjectIdCollection Constructor

ObjectIdCollection Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »ObjectIdCollection()()()()
Members
Icon | Member | Description
 | ObjectIdCollection(array<ObjectId>[]()[][]) |
 | ObjectIdCollection()()()() |


ObjectIdCollection Constructor

ObjectIdCollection Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »ObjectIdCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection()
Public Sub New
public:
ObjectIdCollection()


ObjectIdCollection Constructor (values)

ObjectIdCollection Constructor (values)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »ObjectIdCollection(array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection(
    ObjectId[] values
)
Public Sub New ( _
    values As ObjectId() _
)
public:
ObjectIdCollection(
    array<ObjectId>^ values
)
Parameters
values(array< ObjectId >[]()[][])


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »Add(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ObjectId value
)
Public Function Add ( _
    value As ObjectId _
) As Integer
public:
int Add(
    ObjectId value
)
Parameters
value(ObjectId)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »Contains(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ObjectId value
)
Public Function Contains ( _
    value As ObjectId _
) As Boolean
public:
bool Contains(
    ObjectId value
)
Parameters
value(ObjectId)


CopyTo Method (a, index)

CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »CopyTo(array<ObjectId>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ObjectId[] a,
    int index
)
Public Sub CopyTo ( _
    a As ObjectId(), _
    index As Integer _
)
public:
void CopyTo(
    array<ObjectId>^ a,
    int index
)
Parameters
a(array< ObjectId >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (array, index)

ICollectionCopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollectionCopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IListAdd Method (value)

IListAdd Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IListAdd ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IListAdd(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IListContains Method (value)

IListContains Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IListContains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IListContains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IListIndexOf Method (value)

IListIndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IListIndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IListIndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IListInsert Method (index, value)

IListInsert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IListInsert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IListInsert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IListRemove Method (value)

IListRemove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IListRemove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IListRemove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »IndexOf(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ObjectId value
)
Public Function IndexOf ( _
    value As ObjectId _
) As Integer
public:
int IndexOf(
    ObjectId value
)
Parameters
value(ObjectId)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »Insert(Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ObjectId value
)
Public Sub Insert ( _
    index As Integer, _
    value As ObjectId _
)
public:
void Insert(
    int index,
    ObjectId value
)
Parameters
index(Int32)
value(ObjectId)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »IList..::..IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
bool IList.IsFixedSize { get; }
Private ReadOnly Property IsFixedSize As Boolean
    Implements IList.IsFixedSize
    Get
private:
virtual property bool IsFixedSize {
    bool get () sealed = IList::IsFixedSize::get;
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »IList..::..IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
bool IList.IsReadOnly { get; }
Private ReadOnly Property IsReadOnly As Boolean
    Implements IList.IsReadOnly
    Get
private:
virtual property bool IsReadOnly {
    bool get () sealed = IList::IsReadOnly::get;
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ObjectId
    Get
    Set
public:
property ObjectId default[int index] {
    ObjectId get (int index);
    void set (int index, ObjectId value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »Remove(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ObjectId value
)
Public Sub Remove ( _
    value As ObjectId _
)
public:
void Remove(
    ObjectId value
)
Parameters
value(ObjectId)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


ObjectIdGraph Class

ObjectIdGraph Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdGraph
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbObjectIdGraph")]
public class ObjectIdGraph : Graph
<WrapperAttribute("ZcDbObjectIdGraph")> _
Public Class ObjectIdGraph _
    Inherits Graph
[WrapperAttribute(L"ZcDbObjectIdGraph")]
public ref class ObjectIdGraph : public Graph
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddEdge(GraphNode, GraphNode) | (Inherited from Graph.)
 | AddNode(GraphNode) | (Inherited from Graph.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BreakCycleEdge(GraphNode, GraphNode) | (Inherited from Graph.)
 | ClearAll(Byte) | (Inherited from Graph.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Graph.)
 | DelNode(GraphNode) | (Inherited from Graph.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FindCycles(GraphNode) | (Inherited from Graph.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetOutgoing()()()() | (Inherited from Graph.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEmpty | (Inherited from Graph.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Node(Int32) | (Inherited from Graph.)
 | NumNodes | (Inherited from Graph.)
 | Reset()()()() | (Inherited from Graph.)
 | RootNode | (Inherited from Graph.)
 | SetNodeGrowthRate(Int32) | (Inherited from Graph.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Graph
 |  |  |  | ObjectIdGraph


ObjectIterator Class

ObjectIterator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIterator
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbObjectIterator")]
public sealed class ObjectIterator : RXObject,
    IEnumerator
<WrapperAttribute("ZcDbObjectIterator")> _
Public NotInheritable Class ObjectIterator _
    Inherits RXObject _
    Implements IEnumerator
[WrapperAttribute(L"ZcDbObjectIterator")]
public ref class ObjectIterator sealed : public RXObject,
    IEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Current |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | ObjectIterator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIterator »Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIterator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIterator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


ObjectSnapModes Enumeration

ObjectSnapModes Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectSnapModes
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::OsnapMode")]
[FlagsAttribute]
public enum ObjectSnapModes
<WrapperAttribute("ZcDb::OsnapMode")> _
<FlagsAttribute> _
Public Enumeration ObjectSnapModes
[WrapperAttribute(L"ZcDb::OsnapMode")]
[FlagsAttribute]
public enum class ObjectSnapModes
Members
Member | Description
ModeTangent |
ModeQuad |
ModePerpendicular |
ModeNode |
ModeNear |
ModeMid |
ModeIns |
ModeEnd |
ModeCenter |


ObjectTypeAttribute Class

ObjectTypeAttribute Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectTypeAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field|AttributeTargets.Parameter|AttributeTargets.ReturnValue, AllowMultiple = false,
    Inherited = true)]
public sealed class ObjectTypeAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.ReturnValue, AllowMultiple := False,  _
    Inherited := True)> _
Public NotInheritable Class ObjectTypeAttribute _
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Property|AttributeTargets::Field|AttributeTargets::Parameter|AttributeTargets::ReturnValue, AllowMultiple = false,
    Inherited = true)]
public ref class ObjectTypeAttribute sealed : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ObjectTypeAttribute(Type) |
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObjectType |
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | ObjectTypeAttribute


ObjectTypeAttribute Constructor (type)

ObjectTypeAttribute Constructor (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectTypeAttribute »ObjectTypeAttribute(Type)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectTypeAttribute(
    Type type
)
Public Sub New ( _
    type As Type _
)
public:
ObjectTypeAttribute(
    Type^ type
)
Parameters
type(Type)


ObjectType Property

ObjectType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectTypeAttribute »ObjectType
Declaration Syntax
C# Visual Basic Visual C++
public Type ObjectType { get; }
Public ReadOnly Property ObjectType As Type
    Get
public:
property Type^ ObjectType {
    Type^ get ();
}


Ole2Frame Class

Ole2Frame Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbOle2Frame")]
public class Ole2Frame : Entity
<WrapperAttribute("AcDbOle2Frame")> _
Public Class Ole2Frame _
    Inherits Entity
[WrapperAttribute(L"AcDbOle2Frame")]
public ref class Ole2Frame : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ole2Frame()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | AutoOutputQuality |
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DrawAspect |
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsLinked |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | LinkName |
 | LinkPath |
 | List()()()() | (Inherited from Entity.)
 | Location |
 | LockAspect |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OleObject |
 | OpenedForModify | (Inherited from DBObject.)
 | OutputQuality |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position2d |
 | Position3d |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | ScaleHeight |
 | ScaleWidth |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Type |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UserType |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WcsHeight |
 | WcsWidth |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Ole2Frame


Ole2Frame Constructor

Ole2Frame Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Ole2Frame()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Ole2Frame()
Public Sub New
public:
Ole2Frame()


AutoOutputQuality Property

AutoOutputQuality Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »AutoOutputQuality
Declaration Syntax
C# Visual Basic Visual C++
public byte AutoOutputQuality { get; set; }
Public Property AutoOutputQuality As Byte
    Get
    Set
public:
property unsigned char AutoOutputQuality {
    unsigned char get ();
    void set (unsigned char value);
}


DrawAspect Property

DrawAspect Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »DrawAspect
Declaration Syntax
C# Visual Basic Visual C++
public OleDvAspect DrawAspect { get; set; }
Public Property DrawAspect As OleDvAspect
    Get
    Set
public:
property OleDvAspect DrawAspect {
    OleDvAspect get ();
    void set (OleDvAspect value);
}


IsLinked Property

IsLinked Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »IsLinked
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsLinked { get; }
Public Overridable ReadOnly Property IsLinked As Boolean
    Get
public:
virtual property bool IsLinked {
    bool get ();
}


LinkName Property

LinkName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »LinkName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string LinkName { get; }
Public Overridable ReadOnly Property LinkName As String
    Get
public:
virtual property String^ LinkName {
    String^ get ();
}


LinkPath Property

LinkPath Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »LinkPath
Declaration Syntax
C# Visual Basic Visual C++
public virtual string LinkPath { get; }
Public Overridable ReadOnly Property LinkPath As String
    Get
public:
virtual property String^ LinkPath {
    String^ get ();
}


Location Property

Location Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Location
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Location { get; }
Public ReadOnly Property Location As Point3d
    Get
public:
property Point3d Location {
    Point3d get ();
}


LockAspect Property

LockAspect Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »LockAspect
Declaration Syntax
C# Visual Basic Visual C++
public bool LockAspect { get; set; }
Public Property LockAspect As Boolean
    Get
    Set
public:
property bool LockAspect {
    bool get ();
    void set (bool value);
}


OleObject Property

OleObject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »OleObject
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object OleObject { get; }
Public Overridable ReadOnly Property OleObject As Object
    Get
public:
virtual property Object^ OleObject {
    Object^ get ();
}


OutputQuality Property

OutputQuality Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »OutputQuality
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte OutputQuality { get; set; }
Public Overridable Property OutputQuality As Byte
    Get
    Set
public:
virtual property unsigned char OutputQuality {
    unsigned char get ();
    void set (unsigned char value);
}


Position2d Property

Position2d Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Position2d
Declaration Syntax
C# Visual Basic Visual C++
public virtual Rectangle Position2d { get; set; }
Public Overridable Property Position2d As Rectangle
    Get
    Set
public:
virtual property Rectangle Position2d {
    Rectangle get ();
    void set (Rectangle value);
}


Position3d Property

Position3d Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Position3d
Declaration Syntax
C# Visual Basic Visual C++
public Rectangle3d Position3d { get; set; }
Public Property Position3d As Rectangle3d
    Get
    Set
public:
property Rectangle3d Position3d {
    Rectangle3d get ();
    void set (Rectangle3d value);
}


Rotation Property

Rotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Rotation
Declaration Syntax
C# Visual Basic Visual C++
public double Rotation { get; set; }
Public Property Rotation As Double
    Get
    Set
public:
property double Rotation {
    double get ();
    void set (double value);
}


ScaleHeight Property

ScaleHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »ScaleHeight
Declaration Syntax
C# Visual Basic Visual C++
public double ScaleHeight { get; set; }
Public Property ScaleHeight As Double
    Get
    Set
public:
property double ScaleHeight {
    double get ();
    void set (double value);
}


ScaleWidth Property

ScaleWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »ScaleWidth
Declaration Syntax
C# Visual Basic Visual C++
public double ScaleWidth { get; set; }
Public Property ScaleWidth As Double
    Get
    Set
public:
property double ScaleWidth {
    double get ();
    void set (double value);
}


Type Property

Type Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Type
Declaration Syntax
C# Visual Basic Visual C++
public virtual Ole2Frame..::..ItemType Type { get; }
Public Overridable ReadOnly Property Type As Ole2Frame..::..ItemType
    Get
public:
virtual property Ole2Frame..::..ItemType Type {
    Ole2Frame..::..ItemType get ();
}


UserType Property

UserType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »UserType
Declaration Syntax
C# Visual Basic Visual C++
public virtual string UserType { get; }
Public Overridable ReadOnly Property UserType As String
    Get
public:
virtual property String^ UserType {
    String^ get ();
}


WcsHeight Property

WcsHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »WcsHeight
Declaration Syntax
C# Visual Basic Visual C++
public double WcsHeight { get; set; }
Public Property WcsHeight As Double
    Get
    Set
public:
property double WcsHeight {
    double get ();
    void set (double value);
}


WcsWidth Property

WcsWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »WcsWidth
Declaration Syntax
C# Visual Basic Visual C++
public double WcsWidth { get; set; }
Public Property WcsWidth As Double
    Get
    Set
public:
property double WcsWidth {
    double get ();
    void set (double value);
}


Ole2Frame.ItemType Enumeration

Ole2Frame..::..ItemType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Ole2Frame..::..ItemType
Declaration Syntax
C# Visual Basic Visual C++
public enum ItemType
Public Enumeration ItemType
public enum class ItemType
Members
Member | Description
Link |
Embedded |
Static |


OleDvAspect Enumeration

OleDvAspect Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OleDvAspect
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::SubentType")]
public enum OleDvAspect
<WrapperAttribute("ZcDb::SubentType")> _
Public Enumeration OleDvAspect
[WrapperAttribute(L"ZcDb::SubentType")]
public enum class OleDvAspect
Members
Member | Description
DocPrint |
Thumbnail |
Content |
Icon |


OpenMode Enumeration

OpenMode Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OpenMode
Declaration Syntax
C# Visual Basic Visual C++
public enum OpenMode
Public Enumeration OpenMode
public enum class OpenMode
Members
Member | Description
ForNotify |
ForWrite |
ForRead |


OpenModeAttribute Class

OpenModeAttribute Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OpenModeAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = false, Inherited = true)]
public sealed class OpenModeAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)> _
Public NotInheritable Class OpenModeAttribute _
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = false, Inherited = true)]
public ref class OpenModeAttribute sealed : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenModeAttribute(OpenMode) |
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OpenMode |
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | OpenModeAttribute


OpenModeAttribute Constructor (mode)

OpenModeAttribute Constructor (mode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OpenModeAttribute »OpenModeAttribute(OpenMode)
Declaration Syntax
C# Visual Basic Visual C++
public OpenModeAttribute(
    OpenMode mode
)
Public Sub New ( _
    mode As OpenMode _
)
public:
OpenModeAttribute(
    OpenMode mode
)
Parameters
mode(OpenMode)


OpenMode Property

OpenMode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OpenModeAttribute »OpenMode
Declaration Syntax
C# Visual Basic Visual C++
public OpenMode OpenMode { get; }
Public ReadOnly Property OpenMode As OpenMode
    Get
public:
property OpenMode OpenMode {
    OpenMode get ();
}


OrdinateDimension Class

OrdinateDimension Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbOrdinateDimension")]
public class OrdinateDimension : Dimension
<WrapperAttribute("AcDbOrdinateDimension")> _
Public Class OrdinateDimension _
    Inherits Dimension
[WrapperAttribute(L"AcDbOrdinateDimension")]
public ref class OrdinateDimension : public Dimension
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OrdinateDimension(Boolean, Point3d, Point3d, String, ObjectId) |
 | OrdinateDimension(IntPtr, Boolean) |
 | OrdinateDimension()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlternatePrefix | (Inherited from Dimension.)
 | AlternateSuffix | (Inherited from Dimension.)
 | AltSuppressLeadingZeros | (Inherited from Dimension.)
 | AltSuppressTrailingZeros | (Inherited from Dimension.)
 | AltSuppressZeroFeet | (Inherited from Dimension.)
 | AltSuppressZeroInches | (Inherited from Dimension.)
 | AltToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | AltToleranceSuppressZeroInches | (Inherited from Dimension.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | CenterMarkSize | (Inherited from Dimension.)
 | CenterMarkType | (Inherited from Dimension.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DefiningPoint |
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec | (Inherited from Dimension.)
 | Dimalt | (Inherited from Dimension.)
 | Dimaltd | (Inherited from Dimension.)
 | Dimaltf | (Inherited from Dimension.)
 | Dimaltrnd | (Inherited from Dimension.)
 | Dimalttd | (Inherited from Dimension.)
 | Dimalttz | (Inherited from Dimension.)
 | Dimaltu | (Inherited from Dimension.)
 | Dimaltz | (Inherited from Dimension.)
 | Dimapost | (Inherited from Dimension.)
 | Dimarcsym | (Inherited from Dimension.)
 | Dimasz | (Inherited from Dimension.)
 | Dimatfit | (Inherited from Dimension.)
 | Dimaunit | (Inherited from Dimension.)
 | Dimazin | (Inherited from Dimension.)
 | Dimblk | (Inherited from Dimension.)
 | Dimblk1 | (Inherited from Dimension.)
 | Dimblk1s | (Inherited from Dimension.)
 | Dimblk2 | (Inherited from Dimension.)
 | Dimblk2s | (Inherited from Dimension.)
 | Dimblks | (Inherited from Dimension.)
 | DimBlockId | (Inherited from Dimension.)
 | DimBlockPosition | (Inherited from Dimension.)
 | Dimcen | (Inherited from Dimension.)
 | Dimclrd | (Inherited from Dimension.)
 | Dimclre | (Inherited from Dimension.)
 | Dimclrt | (Inherited from Dimension.)
 | Dimdec | (Inherited from Dimension.)
 | Dimdle | (Inherited from Dimension.)
 | Dimdli | (Inherited from Dimension.)
 | Dimdsep | (Inherited from Dimension.)
 | DimensionStyle | (Inherited from Dimension.)
 | DimensionStyleName | (Inherited from Dimension.)
 | DimensionText | (Inherited from Dimension.)
 | Dimexe | (Inherited from Dimension.)
 | Dimexo | (Inherited from Dimension.)
 | Dimfrac | (Inherited from Dimension.)
 | Dimfxlen | (Inherited from Dimension.)
 | DimfxlenOn | (Inherited from Dimension.)
 | Dimgap | (Inherited from Dimension.)
 | Dimjogang | (Inherited from Dimension.)
 | Dimjust | (Inherited from Dimension.)
 | Dimldrblk | (Inherited from Dimension.)
 | Dimldrblks | (Inherited from Dimension.)
 | Dimlfac | (Inherited from Dimension.)
 | Dimlim | (Inherited from Dimension.)
 | Dimltex1 | (Inherited from Dimension.)
 | Dimltex2 | (Inherited from Dimension.)
 | Dimltype | (Inherited from Dimension.)
 | Dimlunit | (Inherited from Dimension.)
 | Dimlwd | (Inherited from Dimension.)
 | Dimlwe | (Inherited from Dimension.)
 | Dimpost | (Inherited from Dimension.)
 | Dimrnd | (Inherited from Dimension.)
 | Dimsah | (Inherited from Dimension.)
 | Dimscale | (Inherited from Dimension.)
 | Dimsd1 | (Inherited from Dimension.)
 | Dimsd2 | (Inherited from Dimension.)
 | Dimse1 | (Inherited from Dimension.)
 | Dimse2 | (Inherited from Dimension.)
 | Dimsoxd | (Inherited from Dimension.)
 | DimstyleData | (Inherited from Dimension.)
 | Dimtad | (Inherited from Dimension.)
 | Dimtdec | (Inherited from Dimension.)
 | Dimtfac | (Inherited from Dimension.)
 | Dimtfill | (Inherited from Dimension.)
 | Dimtfillclr | (Inherited from Dimension.)
 | Dimtih | (Inherited from Dimension.)
 | Dimtix | (Inherited from Dimension.)
 | Dimtm | (Inherited from Dimension.)
 | Dimtmove | (Inherited from Dimension.)
 | Dimtofl | (Inherited from Dimension.)
 | Dimtoh | (Inherited from Dimension.)
 | Dimtol | (Inherited from Dimension.)
 | Dimtolj | (Inherited from Dimension.)
 | Dimtp | (Inherited from Dimension.)
 | Dimtsz | (Inherited from Dimension.)
 | Dimtvp | (Inherited from Dimension.)
 | Dimtxsty | (Inherited from Dimension.)
 | Dimtxt | (Inherited from Dimension.)
 | Dimtzin | (Inherited from Dimension.)
 | Dimupt | (Inherited from Dimension.)
 | Dimzin | (Inherited from Dimension.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicDimension | (Inherited from Dimension.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation | (Inherited from Dimension.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldFromMText(MText) | (Inherited from Dimension.)
 | FieldToMText(MText) | (Inherited from Dimension.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FormatMeasurement(Double, String) | (Inherited from Dimension.)
 | GenerateLayout()()()() | (Inherited from Dimension.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetDimstyleData()()()() | (Inherited from Dimension.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalRotation | (Inherited from Dimension.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | LeaderEndPoint |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | Measurement | (Inherited from Dimension.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal | (Inherited from Dimension.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | Origin |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Prefix | (Inherited from Dimension.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeDimensionBlock(Boolean) | (Inherited from Dimension.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveTextField()()()() | (Inherited from Dimension.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) | (Inherited from Dimension.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | Suffix | (Inherited from Dimension.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressAngularLeadingZeros | (Inherited from Dimension.)
 | SuppressAngularTrailingZeros | (Inherited from Dimension.)
 | SuppressLeadingZeros | (Inherited from Dimension.)
 | SuppressTrailingZeros | (Inherited from Dimension.)
 | SuppressZeroFeet | (Inherited from Dimension.)
 | SuppressZeroInches | (Inherited from Dimension.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAttachment | (Inherited from Dimension.)
 | TextLineSpacingFactor | (Inherited from Dimension.)
 | TextLineSpacingStyle | (Inherited from Dimension.)
 | TextPosition | (Inherited from Dimension.)
 | TextRotation | (Inherited from Dimension.)
 | TextStyleId | (Inherited from Dimension.)
 | ToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | ToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | ToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | ToleranceSuppressZeroInches | (Inherited from Dimension.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UsingDefaultTextPosition | (Inherited from Dimension.)
 | UsingXAxis |
 | UsingYAxis |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  |  | OrdinateDimension


OrdinateDimension Constructor

OrdinateDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »OrdinateDimension()()()()
Members
Icon | Member | Description
 | OrdinateDimension(Boolean, Point3d, Point3d, String, ObjectId) |
 | OrdinateDimension(IntPtr, Boolean) |
 | OrdinateDimension()()()() |


OrdinateDimension Constructor

OrdinateDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »OrdinateDimension()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OrdinateDimension()
Public Sub New
public:
OrdinateDimension()


OrdinateDimension Constructor (useXAxis, definingPoint, leaderEndPoint, dimText, dimStyle)

OrdinateDimension Constructor (useXAxis, definingPoint, leaderEndPoint, dimText, dimStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »OrdinateDimension(Boolean, Point3d, Point3d, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public OrdinateDimension(
    bool useXAxis,
    Point3d definingPoint,
    Point3d leaderEndPoint,
    string dimText,
    ObjectId dimStyle
)
Public Sub New ( _
    useXAxis As Boolean, _
    definingPoint As Point3d, _
    leaderEndPoint As Point3d, _
    dimText As String, _
    dimStyle As ObjectId _
)
public:
OrdinateDimension(
    bool useXAxis,
    Point3d definingPoint,
    Point3d leaderEndPoint,
    String^ dimText,
    ObjectId dimStyle
)
Parameters
useXAxis(Boolean)
definingPoint(Point3d)
leaderEndPoint(Point3d)
dimText(String)
dimStyle(ObjectId)


OrdinateDimension Constructor (unmanagedObjPtr, autoDelete)

OrdinateDimension Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »OrdinateDimension(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal OrdinateDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
OrdinateDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


DefiningPoint Property

DefiningPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »DefiningPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d DefiningPoint { get; set; }
Public Property DefiningPoint As Point3d
    Get
    Set
public:
property Point3d DefiningPoint {
    Point3d get ();
    void set (Point3d value);
}


LeaderEndPoint Property

LeaderEndPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »LeaderEndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d LeaderEndPoint { get; set; }
Public Property LeaderEndPoint As Point3d
    Get
    Set
public:
property Point3d LeaderEndPoint {
    Point3d get ();
    void set (Point3d value);
}


Origin Property

Origin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »Origin
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Origin { get; set; }
Public Property Origin As Point3d
    Get
    Set
public:
property Point3d Origin {
    Point3d get ();
    void set (Point3d value);
}


UsingXAxis Property

UsingXAxis Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »UsingXAxis
Declaration Syntax
C# Visual Basic Visual C++
public bool UsingXAxis { get; set; }
Public Property UsingXAxis As Boolean
    Get
    Set
public:
property bool UsingXAxis {
    bool get ();
    void set (bool value);
}


UsingYAxis Property

UsingYAxis Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »UsingYAxis
Declaration Syntax
C# Visual Basic Visual C++
public bool UsingYAxis { get; }
Public ReadOnly Property UsingYAxis As Boolean
    Get
public:
property bool UsingYAxis {
    bool get ();
}


OrthographicView Enumeration

OrthographicView Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrthographicView
Declaration Syntax
C# Visual Basic Visual C++
public enum OrthographicView
Public Enumeration OrthographicView
public enum class OrthographicView
Members
Member | Description
TopView |
RightView |
NonOrthoView |
LeftView |
FrontView |
BottomView |
BackView |


OsnapPointRef Class

OsnapPointRef Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbOsnapPointRef")]
public class OsnapPointRef : PointRef
<WrapperAttribute("AcDbOsnapPointRef")> _
Public Class OsnapPointRef _
    Inherits PointRef
[WrapperAttribute(L"AcDbOsnapPointRef")]
public ref class OsnapPointRef : public PointRef
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OsnapPointRef()()()() |
 | OsnapPointRef(IntPtr, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvalPoint()()()() | (Overrides PointRef.EvalPoint()()()().)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEntities(Boolean) | (Overrides PointRef.GetEntities(Boolean).)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | IdPath |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntIdPath |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsGeomErased()()()() | (Overrides PointRef.IsGeomErased()()()().)
 | IsXrefObj(ObjectIdCollection, ObjectIdCollection, Boolean) | (Overrides PointRef.IsXrefObj(ObjectIdCollection, ObjectIdCollection, Boolean).)
 | LastPointRef |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NearPointParam |
 | OsnapType |
 | Point |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateDueToMirror(Boolean) | (Overrides PointRef.UpdateDueToMirror(Boolean).)
 | UpdateSubentPath(IdMapping) | (Overrides PointRef.UpdateSubentPath(IdMapping).)
 | UpdateXrefSubentPath()()()() | (Overrides PointRef.UpdateXrefSubentPath()()()().)
 | X(RXClass) | (Inherited from RXObject.)
 | XrefHandles |
 | XrefIntHandles |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | PointRef
 |  |  |  |  | OsnapPointRef


OsnapPointRef Constructor

OsnapPointRef Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »OsnapPointRef()()()()
Members
Icon | Member | Description
 | OsnapPointRef()()()() |
 | OsnapPointRef(IntPtr, Boolean) |


OsnapPointRef Constructor

OsnapPointRef Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »OsnapPointRef()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OsnapPointRef()
Public Sub New
public:
OsnapPointRef()


OsnapPointRef Constructor (unmanagedObject, autoDelete)

OsnapPointRef Constructor (unmanagedObject, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »OsnapPointRef(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal OsnapPointRef(
    IntPtr unmanagedObject,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObject As IntPtr, _
    autoDelete As Boolean _
)
protected public:
OsnapPointRef(
    IntPtr unmanagedObject,
    bool autoDelete
)
Parameters
unmanagedObject(IntPtr)
autoDelete(Boolean)


EvalPoint Method

EvalPoint Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »EvalPoint()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override Point3d EvalPoint()
Public Overrides Function EvalPoint As Point3d
public:
virtual Point3d EvalPoint() override


GetEntities Method (getLastPtRef)

GetEntities Method (getLastPtRef)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »GetEntities(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public override FullSubentityPath[] GetEntities(
    bool getLastPtRef
)
Public Overrides Function GetEntities ( _
    getLastPtRef As Boolean _
) As FullSubentityPath()
public:
virtual array<FullSubentityPath>^ GetEntities(
    bool getLastPtRef
) override
Parameters
getLastPtRef(Boolean)


IdPath Property

IdPath Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »IdPath
Declaration Syntax
C# Visual Basic Visual C++
public FullSubentityPath IdPath { get; set; }
Public Property IdPath As FullSubentityPath
    Get
    Set
public:
property FullSubentityPath IdPath {
    FullSubentityPath get ();
    void set (FullSubentityPath value);
}


IntIdPath Property

IntIdPath Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »IntIdPath
Declaration Syntax
C# Visual Basic Visual C++
public FullSubentityPath IntIdPath { get; set; }
Public Property IntIdPath As FullSubentityPath
    Get
    Set
public:
property FullSubentityPath IntIdPath {
    FullSubentityPath get ();
    void set (FullSubentityPath value);
}


IsGeomErased Method

IsGeomErased Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »IsGeomErased()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsGeomErased()
Public Overrides Function IsGeomErased As Boolean
public:
virtual bool IsGeomErased() override


IsXrefObj Method (ids1, ids2, isMainObj)

IsXrefObj Method (ids1, ids2, isMainObj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »IsXrefObj(ObjectIdCollection, ObjectIdCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsXrefObj(
    ObjectIdCollection ids1,
    ObjectIdCollection ids2,
    bool isMainObj
)
Public Overrides Function IsXrefObj ( _
    ids1 As ObjectIdCollection, _
    ids2 As ObjectIdCollection, _
    isMainObj As Boolean _
) As Boolean
public:
virtual bool IsXrefObj(
    ObjectIdCollection^ ids1,
    ObjectIdCollection^ ids2,
    bool isMainObj
) override
Parameters
ids1(ObjectIdCollection)
ids2(ObjectIdCollection)
isMainObj(Boolean)


LastPointRef Property

LastPointRef Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »LastPointRef
Declaration Syntax
C# Visual Basic Visual C++
public OsnapPointRef LastPointRef { get; set; }
Public Property LastPointRef As OsnapPointRef
    Get
    Set
public:
property OsnapPointRef^ LastPointRef {
    OsnapPointRef^ get ();
    void set (OsnapPointRef^ value);
}


NearPointParam Property

NearPointParam Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »NearPointParam
Declaration Syntax
C# Visual Basic Visual C++
public double NearPointParam { get; set; }
Public Property NearPointParam As Double
    Get
    Set
public:
property double NearPointParam {
    double get ();
    void set (double value);
}


OsnapType Property

OsnapType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »OsnapType
Declaration Syntax
C# Visual Basic Visual C++
public ObjectSnapModes OsnapType { get; set; }
Public Property OsnapType As ObjectSnapModes
    Get
    Set
public:
property ObjectSnapModes OsnapType {
    ObjectSnapModes get ();
    void set (ObjectSnapModes value);
}


Point Property

Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Point { get; set; }
Public Property Point As Point3d
    Get
    Set
public:
property Point3d Point {
    Point3d get ();
    void set (Point3d value);
}


UpdateDueToMirror Method (inMirror)

UpdateDueToMirror Method (inMirror)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »UpdateDueToMirror(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public override void UpdateDueToMirror(
    bool inMirror
)
Public Overrides Sub UpdateDueToMirror ( _
    inMirror As Boolean _
)
public:
virtual void UpdateDueToMirror(
    bool inMirror
) override
Parameters
inMirror(Boolean)


UpdateSubentPath Method (idMap)

UpdateSubentPath Method (idMap)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »UpdateSubentPath(IdMapping)
Declaration Syntax
C# Visual Basic Visual C++
public override void UpdateSubentPath(
    IdMapping idMap
)
Public Overrides Sub UpdateSubentPath ( _
    idMap As IdMapping _
)
public:
virtual void UpdateSubentPath(
    IdMapping^ idMap
) override
Parameters
idMap(IdMapping)


UpdateXrefSubentPath Method

UpdateXrefSubentPath Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »UpdateXrefSubentPath()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void UpdateXrefSubentPath()
Public Overrides Sub UpdateXrefSubentPath
public:
virtual void UpdateXrefSubentPath() override


XrefHandles Property

XrefHandles Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »XrefHandles
Declaration Syntax
C# Visual Basic Visual C++
public Handle[] XrefHandles { get; set; }
Public Property XrefHandles As Handle()
    Get
    Set
public:
property array<Handle>^ XrefHandles {
    array<Handle>^ get ();
    void set (array<Handle>^ value);
}


XrefIntHandles Property

XrefIntHandles Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »XrefIntHandles
Declaration Syntax
C# Visual Basic Visual C++
public Handle[] XrefIntHandles { get; set; }
Public Property XrefIntHandles As Handle()
    Get
    Set
public:
property array<Handle>^ XrefIntHandles {
    array<Handle>^ get ();
    void set (array<Handle>^ value);
}


PaperOrientationStates Enumeration

PaperOrientationStates Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PaperOrientationStates
Declaration Syntax
C# Visual Basic Visual C++
public enum PaperOrientationStates
Public Enumeration PaperOrientationStates
public enum class PaperOrientationStates
Members
Member | Description
False |
True |
NotApplicable |


ParseOption Enumeration

ParseOption Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ParseOption
Declaration Syntax
C# Visual Basic Visual C++
public enum ParseOption
Public Enumeration ParseOption
public enum class ParseOption
Members
Member | Description
PreserveMtextFormat |
SetDefaultFormat |
ParseOptionNone |


PasswordOptions Enumeration

PasswordOptions Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PasswordOptions
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbHostAppServices::PasswordOptions")]
[FlagsAttribute]
public enum PasswordOptions
<WrapperAttribute("ZcDbHostAppServices::PasswordOptions")> _
<FlagsAttribute> _
Public Enumeration PasswordOptions
[WrapperAttribute(L"ZcDbHostAppServices::PasswordOptions")]
[FlagsAttribute]
public enum class PasswordOptions
Members
Member | Description
IsExternalReference |
UpperCase |
Default |


PathOption Enumeration

PathOption Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PathOption
Declaration Syntax
C# Visual Basic Visual C++
public enum PathOption
Public Enumeration PathOption
public enum class PathOption
Members
Member | Description
RelativePath |
PathAndFile |
NoPath |
AbsolutePath |


PatternDefinition Structure

PatternDefinition Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PatternDefinition
Declaration Syntax
C# Visual Basic Visual C++
public struct PatternDefinition
Public Structure PatternDefinition
public value class PatternDefinition
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PatternDefinition(Double, Point2d, Point2d, DoubleCollection) |
 | Angle |
 | BaseX |
 | BaseY |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDashes()()()() |
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OffsetX |
 | OffsetY |
 | ToString()()()() | (Inherited from ValueType.)


PatternDefinition Constructor (patternAngle, basePoint, offsetVector, dashOffsets)

PatternDefinition Constructor (patternAngle, basePoint, offsetVector, dashOffsets)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PatternDefinition »PatternDefinition(Double, Point2d, Point2d, DoubleCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PatternDefinition(
    double patternAngle,
    Point2d basePoint,
    Point2d offsetVector,
    DoubleCollection dashOffsets
)
Public Sub New ( _
    patternAngle As Double, _
    basePoint As Point2d, _
    offsetVector As Point2d, _
    dashOffsets As DoubleCollection _
)
public:
PatternDefinition(
    double patternAngle,
    Point2d basePoint,
    Point2d offsetVector,
    DoubleCollection^ dashOffsets
)
Parameters
patternAngle(Double)
basePoint(Point2d)
offsetVector(Point2d)
dashOffsets(DoubleCollection)


Angle Property

Angle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PatternDefinition »Angle
Declaration Syntax
C# Visual Basic Visual C++
public double Angle { get; }
Public ReadOnly Property Angle As Double
    Get
public:
property double Angle {
    double get ();
}


BaseX Property

BaseX Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PatternDefinition »BaseX
Declaration Syntax
C# Visual Basic Visual C++
public double BaseX { get; }
Public ReadOnly Property BaseX As Double
    Get
public:
property double BaseX {
    double get ();
}


BaseY Property

BaseY Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PatternDefinition »BaseY
Declaration Syntax
C# Visual Basic Visual C++
public double BaseY { get; }
Public ReadOnly Property BaseY As Double
    Get
public:
property double BaseY {
    double get ();
}


GetDashes Method

GetDashes Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PatternDefinition »GetDashes()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetDashes()
Public Function GetDashes As DoubleCollection
public:
DoubleCollection^ GetDashes()


OffsetX Property

OffsetX Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PatternDefinition »OffsetX
Declaration Syntax
C# Visual Basic Visual C++
public double OffsetX { get; }
Public ReadOnly Property OffsetX As Double
    Get
public:
property double OffsetX {
    double get ();
}


OffsetY Property

OffsetY Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PatternDefinition »OffsetY
Declaration Syntax
C# Visual Basic Visual C++
public double OffsetY { get; }
Public ReadOnly Property OffsetY As Double
    Get
public:
property double OffsetY {
    double get ();
}


PlaceHolder Class

PlaceHolder Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaceHolder
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbPlaceHolder")]
public sealed class PlaceHolder : DBObject
<WrapperAttribute("AcDbPlaceHolder")> _
Public NotInheritable Class PlaceHolder _
    Inherits DBObject
[WrapperAttribute(L"AcDbPlaceHolder")]
public ref class PlaceHolder sealed : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlaceHolder()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | PlaceHolder


PlaceHolder Constructor

PlaceHolder Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaceHolder »PlaceHolder()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PlaceHolder()
Public Sub New
public:
PlaceHolder()


Planarity Enumeration

Planarity Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Planarity
Declaration Syntax
C# Visual Basic Visual C++
public enum Planarity
Public Enumeration Planarity
public enum class Planarity
Members
Member | Description
Linear |
NonPlanar |
Planar |


PlaneSurface Class

PlaneSurface Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbPlaneSurface")]
public class PlaneSurface : Surface
<WrapperAttribute("AcDbPlaneSurface")> _
Public Class PlaneSurface _
    Inherits Surface
[WrapperAttribute(L"AcDbPlaneSurface")]
public ref class PlaneSurface : public Surface
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlaneSurface()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BooleanIntersect(Surface) | (Inherited from Surface.)
 | BooleanIntersect(Solid3d) | (Inherited from Surface.)
 | BooleanSubtract(Surface) | (Inherited from Surface.)
 | BooleanSubtract(Solid3d) | (Inherited from Surface.)
 | BooleanUnion(Surface) | (Inherited from Surface.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ChamferEdges(array<SubentityId>[]()[][], SubentityId, Double, Double) | (Inherited from Surface.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToRegion()()()() | (Inherited from Surface.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateFromRegion(Region) |
 | CreateInterferenceObjects(Entity, Int32) | (Inherited from Surface.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateSectionObjects(Plane) | (Inherited from Surface.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FilletEdges(array<SubentityId>[]()[][], DoubleCollection, DoubleCollection, DoubleCollection) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetArea()()()() | (Inherited from Surface.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityColor(SubentityId) | (Inherited from Surface.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityMaterial(SubentityId) | (Inherited from Surface.)
 | GetSubentityMaterialMapper(SubentityId) | (Inherited from Surface.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | ImprintEntity(Entity) | (Inherited from Surface.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | ProjectOnToSurface(Entity, Vector3d) | (Inherited from Surface.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RayTest(Point3d, Vector3d, Double, array<SubentityId>[]()[][]%, DoubleCollection%) | (Inherited from Surface.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityColor(SubentityId, Color) | (Inherited from Surface.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetSubentityMaterial(SubentityId, ObjectId) | (Inherited from Surface.)
 | SetSubentityMaterialMapper(SubentityId, Mapper) | (Inherited from Surface.)
 | SliceByPlane(Plane) | (Inherited from Surface.)
 | SliceBySurface(Surface) | (Inherited from Surface.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thicken(Double, Boolean) | (Inherited from Surface.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | UIsoLineDensity | (Inherited from Surface.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VIsoLineDensity | (Inherited from Surface.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Surface
 |  |  |  |  |  |  |  | PlaneSurface


PlaneSurface Constructor

PlaneSurface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »PlaneSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PlaneSurface()
Public Sub New
public:
PlaneSurface()


CreateFromRegion Method (region)

CreateFromRegion Method (region)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »CreateFromRegion(Region)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateFromRegion(
    Region region
)
Public Overridable Sub CreateFromRegion ( _
    region As Region _
)
public:
virtual void CreateFromRegion(
    Region^ region
)
Parameters
region(Region)


PlotPaperUnit Enumeration

PlotPaperUnit Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotPaperUnit
Declaration Syntax
C# Visual Basic Visual C++
public enum PlotPaperUnit
Public Enumeration PlotPaperUnit
public enum class PlotPaperUnit
Members
Member | Description
Pixels |
Millimeters |
Inches |


PlotRotation Enumeration

PlotRotation Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotRotation
Declaration Syntax
C# Visual Basic Visual C++
public enum PlotRotation
Public Enumeration PlotRotation
public enum class PlotRotation
Members
Member | Description
Degrees270 |
Degrees180 |
Degrees090 |
Degrees000 |


PlotSettings Class

PlotSettings Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbPlotSettings")]
public class PlotSettings : DBObject
<WrapperAttribute("AcDbPlotSettings")> _
Public Class PlotSettings _
    Inherits DBObject
[WrapperAttribute(L"AcDbPlotSettings")]
public ref class PlotSettings : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlotSettings(Boolean) |
 | PlotSettings(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddToPlotSettingsDictionary(Database) |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CanonicalMediaName |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CurrentStyleSheet |
 | CustomPrintScale |
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DrawViewportsFirst |
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | ModelType |
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotAsRaster |
 | PlotCentered |
 | PlotConfigurationName |
 | PlotHidden |
 | PlotOrigin |
 | PlotPaperMargins |
 | PlotPaperSize |
 | PlotPaperUnits |
 | PlotPlotStyles |
 | PlotRotation |
 | PlotSettingsName |
 | PlotType |
 | PlotViewName |
 | PlotViewportBorders |
 | PlotWindowArea |
 | PlotWireframe |
 | PrintLineweights |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ScaleLineweights |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetShadePlot(PlotSettingsShadePlotType, ObjectId) |
 | ShadePlot |
 | ShadePlotCustomDpi |
 | ShadePlotId |
 | ShadePlotResLevel |
 | ShowPlotStyles |
 | StdScale |
 | StdScaleType |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UseStandardScale |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | PlotSettings
 |  |  |  |  |  |  | Layout


PlotSettings Constructor

PlotSettings Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotSettings()()()()
Members
Icon | Member | Description
 | PlotSettings(Boolean) |
 | PlotSettings(IntPtr, Boolean) |


PlotSettings Constructor (modelType)

PlotSettings Constructor (modelType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotSettings(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public PlotSettings(
    bool modelType
)
Public Sub New ( _
    modelType As Boolean _
)
public:
PlotSettings(
    bool modelType
)
Parameters
modelType(Boolean)


PlotSettings Constructor (unmanagedPointer, autoDelete)

PlotSettings Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotSettings(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal PlotSettings(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
PlotSettings(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AddToPlotSettingsDictionary Method (toWhichDatabase)

AddToPlotSettingsDictionary Method (toWhichDatabase)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »AddToPlotSettingsDictionary(Database)
Declaration Syntax
C# Visual Basic Visual C++
public void AddToPlotSettingsDictionary(
    Database toWhichDatabase
)
Public Sub AddToPlotSettingsDictionary ( _
    toWhichDatabase As Database _
)
public:
void AddToPlotSettingsDictionary(
    Database^ toWhichDatabase
)
Parameters
toWhichDatabase(Database)


CanonicalMediaName Property

CanonicalMediaName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »CanonicalMediaName
Declaration Syntax
C# Visual Basic Visual C++
public string CanonicalMediaName { get; }
Public ReadOnly Property CanonicalMediaName As String
    Get
public:
property String^ CanonicalMediaName {
    String^ get ();
}


CurrentStyleSheet Property

CurrentStyleSheet Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »CurrentStyleSheet
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentStyleSheet { get; }
Public ReadOnly Property CurrentStyleSheet As String
    Get
public:
property String^ CurrentStyleSheet {
    String^ get ();
}


CustomPrintScale Property

CustomPrintScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »CustomPrintScale
Declaration Syntax
C# Visual Basic Visual C++
public CustomScale CustomPrintScale { get; }
Public ReadOnly Property CustomPrintScale As CustomScale
    Get
public:
property CustomScale CustomPrintScale {
    CustomScale get ();
}


DrawViewportsFirst Property

DrawViewportsFirst Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »DrawViewportsFirst
Declaration Syntax
C# Visual Basic Visual C++
public bool DrawViewportsFirst { get; set; }
Public Property DrawViewportsFirst As Boolean
    Get
    Set
public:
property bool DrawViewportsFirst {
    bool get ();
    void set (bool value);
}


ModelType Property

ModelType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »ModelType
Declaration Syntax
C# Visual Basic Visual C++
public bool ModelType { get; }
Public ReadOnly Property ModelType As Boolean
    Get
public:
property bool ModelType {
    bool get ();
}


PlotAsRaster Property

PlotAsRaster Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotAsRaster
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotAsRaster { get; }
Public ReadOnly Property PlotAsRaster As Boolean
    Get
public:
property bool PlotAsRaster {
    bool get ();
}


PlotCentered Property

PlotCentered Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotCentered
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotCentered { get; }
Public ReadOnly Property PlotCentered As Boolean
    Get
public:
property bool PlotCentered {
    bool get ();
}


PlotConfigurationName Property

PlotConfigurationName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotConfigurationName
Declaration Syntax
C# Visual Basic Visual C++
public string PlotConfigurationName { get; }
Public ReadOnly Property PlotConfigurationName As String
    Get
public:
property String^ PlotConfigurationName {
    String^ get ();
}


PlotHidden Property

PlotHidden Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotHidden
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotHidden { get; set; }
Public Property PlotHidden As Boolean
    Get
    Set
public:
property bool PlotHidden {
    bool get ();
    void set (bool value);
}


PlotOrigin Property

PlotOrigin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotOrigin
Declaration Syntax
C# Visual Basic Visual C++
public Point2d PlotOrigin { get; }
Public ReadOnly Property PlotOrigin As Point2d
    Get
public:
property Point2d PlotOrigin {
    Point2d get ();
}


PlotPaperMargins Property

PlotPaperMargins Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotPaperMargins
Declaration Syntax
C# Visual Basic Visual C++
public Extents2d PlotPaperMargins { get; }
Public ReadOnly Property PlotPaperMargins As Extents2d
    Get
public:
property Extents2d PlotPaperMargins {
    Extents2d get ();
}


PlotPaperSize Property

PlotPaperSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotPaperSize
Declaration Syntax
C# Visual Basic Visual C++
public Point2d PlotPaperSize { get; }
Public ReadOnly Property PlotPaperSize As Point2d
    Get
public:
property Point2d PlotPaperSize {
    Point2d get ();
}


PlotPaperUnits Property

PlotPaperUnits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotPaperUnits
Declaration Syntax
C# Visual Basic Visual C++
public PlotPaperUnit PlotPaperUnits { get; }
Public ReadOnly Property PlotPaperUnits As PlotPaperUnit
    Get
public:
property PlotPaperUnit PlotPaperUnits {
    PlotPaperUnit get ();
}


PlotPlotStyles Property

PlotPlotStyles Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotPlotStyles
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotPlotStyles { get; set; }
Public Property PlotPlotStyles As Boolean
    Get
    Set
public:
property bool PlotPlotStyles {
    bool get ();
    void set (bool value);
}


PlotRotation Property

PlotRotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotRotation
Declaration Syntax
C# Visual Basic Visual C++
public PlotRotation PlotRotation { get; }
Public ReadOnly Property PlotRotation As PlotRotation
    Get
public:
property PlotRotation PlotRotation {
    PlotRotation get ();
}


PlotSettingsName Property

PlotSettingsName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotSettingsName
Declaration Syntax
C# Visual Basic Visual C++
public string PlotSettingsName { get; set; }
Public Property PlotSettingsName As String
    Get
    Set
public:
property String^ PlotSettingsName {
    String^ get ();
    void set (String^ value);
}


PlotType Property

PlotType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotType
Declaration Syntax
C# Visual Basic Visual C++
public PlotType PlotType { get; }
Public ReadOnly Property PlotType As PlotType
    Get
public:
property PlotType PlotType {
    PlotType get ();
}


PlotViewName Property

PlotViewName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotViewName
Declaration Syntax
C# Visual Basic Visual C++
public string PlotViewName { get; }
Public ReadOnly Property PlotViewName As String
    Get
public:
property String^ PlotViewName {
    String^ get ();
}


PlotViewportBorders Property

PlotViewportBorders Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotViewportBorders
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotViewportBorders { get; set; }
Public Property PlotViewportBorders As Boolean
    Get
    Set
public:
property bool PlotViewportBorders {
    bool get ();
    void set (bool value);
}


PlotWindowArea Property

PlotWindowArea Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotWindowArea
Declaration Syntax
C# Visual Basic Visual C++
public Extents2d PlotWindowArea { get; }
Public ReadOnly Property PlotWindowArea As Extents2d
    Get
public:
property Extents2d PlotWindowArea {
    Extents2d get ();
}


PlotWireframe Property

PlotWireframe Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PlotWireframe
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotWireframe { get; }
Public ReadOnly Property PlotWireframe As Boolean
    Get
public:
property bool PlotWireframe {
    bool get ();
}


PrintLineweights Property

PrintLineweights Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »PrintLineweights
Declaration Syntax
C# Visual Basic Visual C++
public bool PrintLineweights { get; set; }
Public Property PrintLineweights As Boolean
    Get
    Set
public:
property bool PrintLineweights {
    bool get ();
    void set (bool value);
}


ScaleLineweights Property

ScaleLineweights Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »ScaleLineweights
Declaration Syntax
C# Visual Basic Visual C++
public bool ScaleLineweights { get; set; }
Public Property ScaleLineweights As Boolean
    Get
    Set
public:
property bool ScaleLineweights {
    bool get ();
    void set (bool value);
}


SetShadePlot Method (type, shadePlotId)

SetShadePlot Method (type, shadePlotId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »SetShadePlot(PlotSettingsShadePlotType, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetShadePlot(
    PlotSettingsShadePlotType type,
    ObjectId shadePlotId
)
Public Sub SetShadePlot ( _
    type As PlotSettingsShadePlotType, _
    shadePlotId As ObjectId _
)
public:
void SetShadePlot(
    PlotSettingsShadePlotType type,
    ObjectId shadePlotId
)
Parameters
type(PlotSettingsShadePlotType)
shadePlotId(ObjectId)


ShadePlot Property

ShadePlot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »ShadePlot
Declaration Syntax
C# Visual Basic Visual C++
public PlotSettingsShadePlotType ShadePlot { get; set; }
Public Property ShadePlot As PlotSettingsShadePlotType
    Get
    Set
public:
property PlotSettingsShadePlotType ShadePlot {
    PlotSettingsShadePlotType get ();
    void set (PlotSettingsShadePlotType value);
}


ShadePlotCustomDpi Property

ShadePlotCustomDpi Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »ShadePlotCustomDpi
Declaration Syntax
C# Visual Basic Visual C++
public short ShadePlotCustomDpi { get; set; }
Public Property ShadePlotCustomDpi As Short
    Get
    Set
public:
property short ShadePlotCustomDpi {
    short get ();
    void set (short value);
}


ShadePlotId Property

ShadePlotId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »ShadePlotId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ShadePlotId { get; }
Public ReadOnly Property ShadePlotId As ObjectId
    Get
public:
property ObjectId ShadePlotId {
    ObjectId get ();
}


ShadePlotResLevel Property

ShadePlotResLevel Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »ShadePlotResLevel
Declaration Syntax
C# Visual Basic Visual C++
public ShadePlotResLevel ShadePlotResLevel { get; set; }
Public Property ShadePlotResLevel As ShadePlotResLevel
    Get
    Set
public:
property ShadePlotResLevel ShadePlotResLevel {
    ShadePlotResLevel get ();
    void set (ShadePlotResLevel value);
}


ShowPlotStyles Property

ShowPlotStyles Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »ShowPlotStyles
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowPlotStyles { get; set; }
Public Property ShowPlotStyles As Boolean
    Get
    Set
public:
property bool ShowPlotStyles {
    bool get ();
    void set (bool value);
}


StdScale Property

StdScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »StdScale
Declaration Syntax
C# Visual Basic Visual C++
public double StdScale { get; }
Public ReadOnly Property StdScale As Double
    Get
public:
property double StdScale {
    double get ();
}


StdScaleType Property

StdScaleType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »StdScaleType
Declaration Syntax
C# Visual Basic Visual C++
public StdScaleType StdScaleType { get; }
Public ReadOnly Property StdScaleType As StdScaleType
    Get
public:
property StdScaleType StdScaleType {
    StdScaleType get ();
}


UseStandardScale Property

UseStandardScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »UseStandardScale
Declaration Syntax
C# Visual Basic Visual C++
public bool UseStandardScale { get; }
Public ReadOnly Property UseStandardScale As Boolean
    Get
public:
property bool UseStandardScale {
    bool get ();
}


PlotSettingsShadePlotType Enumeration

PlotSettingsShadePlotType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsShadePlotType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbPlotSettings::ShadePlotType")]
public enum PlotSettingsShadePlotType
<WrapperAttribute("ZcDbPlotSettings::ShadePlotType")> _
Public Enumeration PlotSettingsShadePlotType
[WrapperAttribute(L"ZcDbPlotSettings::ShadePlotType")]
public enum class PlotSettingsShadePlotType
Members
Member | Description
RenderPreset |
VisualStyle |
Rendered |
Hidden |
AsDisplayed |
Wireframe |


PlotSettingsValidator Class

PlotSettingsValidator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbPlotSettingsValidator")]
public sealed class PlotSettingsValidator : DisposableWrapper
<WrapperAttribute("ZcDbPlotSettingsValidator")> _
Public NotInheritable Class PlotSettingsValidator _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcDbPlotSettingsValidator")]
public ref class PlotSettingsValidator sealed : public DisposableWrapper
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Current |
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetCanonicalMediaNameList(PlotSettings) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLocaleMediaName(PlotSettings, String) |
 | GetLocaleMediaName(PlotSettings, Int32) |
 | GetPlotDeviceList()()()() |
 | GetPlotStyleSheetList()()()() |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RefreshLists(PlotSettings) |
 | SetCanonicalMediaName(PlotSettings, String) |
 | SetClosestMediaName(PlotSettings, Double, Double, PlotPaperUnit, Boolean) |
 | SetCurrentStyleSheet(PlotSettings, String) |
 | SetCustomPrintScale(PlotSettings, CustomScale) |
 | SetDefaultPlotConfig(PlotSettings) |
 | SetPlotCentered(PlotSettings, Boolean) |
 | SetPlotConfigurationName(PlotSettings, String, String) |
 | SetPlotOrigin(PlotSettings, Point2d) |
 | SetPlotPaperUnits(PlotSettings, PlotPaperUnit) |
 | SetPlotRotation(PlotSettings, PlotRotation) |
 | SetPlotType(PlotSettings, PlotType) |
 | SetPlotViewName(PlotSettings, String) |
 | SetPlotWindowArea(PlotSettings, Extents2d) |
 | SetStdScale(PlotSettings, Double) |
 | SetStdScaleType(PlotSettings, StdScaleType) |
 | SetUseStandardScale(PlotSettings, Boolean) |
 | SetZoomToPaperOnUpdate(PlotSettings, Boolean) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | PlotSettingsValidator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »Current
Declaration Syntax
C# Visual Basic Visual C++
public static PlotSettingsValidator Current { get; }
Public Shared ReadOnly Property Current As PlotSettingsValidator
    Get
public:
static property PlotSettingsValidator^ Current {
    PlotSettingsValidator^ get ();
}


GetCanonicalMediaNameList Method (plotSet)

GetCanonicalMediaNameList Method (plotSet)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »GetCanonicalMediaNameList(PlotSettings)
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection GetCanonicalMediaNameList(
    PlotSettings plotSet
)
Public Function GetCanonicalMediaNameList ( _
    plotSet As PlotSettings _
) As StringCollection
public:
StringCollection^ GetCanonicalMediaNameList(
    PlotSettings^ plotSet
)
Parameters
plotSet(PlotSettings)


GetLocaleMediaName Method

GetLocaleMediaName Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »GetLocaleMediaName()()()()
Members
Icon | Member | Description
 | GetLocaleMediaName(PlotSettings, String) |
 | GetLocaleMediaName(PlotSettings, Int32) |


GetLocaleMediaName Method (plotSet, index)

GetLocaleMediaName Method (plotSet, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »GetLocaleMediaName(PlotSettings, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public string GetLocaleMediaName(
    PlotSettings plotSet,
    int index
)
Public Function GetLocaleMediaName ( _
    plotSet As PlotSettings, _
    index As Integer _
) As String
public:
String^ GetLocaleMediaName(
    PlotSettings^ plotSet,
    int index
)
Parameters
plotSet(PlotSettings)
index(Int32)


GetLocaleMediaName Method (plotSet, canonicalName)

GetLocaleMediaName Method (plotSet, canonicalName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »GetLocaleMediaName(PlotSettings, String)
Declaration Syntax
C# Visual Basic Visual C++
public string GetLocaleMediaName(
    PlotSettings plotSet,
    string canonicalName
)
Public Function GetLocaleMediaName ( _
    plotSet As PlotSettings, _
    canonicalName As String _
) As String
public:
String^ GetLocaleMediaName(
    PlotSettings^ plotSet,
    String^ canonicalName
)
Parameters
plotSet(PlotSettings)
canonicalName(String)


GetPlotDeviceList Method

GetPlotDeviceList Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »GetPlotDeviceList()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection GetPlotDeviceList()
Public Function GetPlotDeviceList As StringCollection
public:
StringCollection^ GetPlotDeviceList()


GetPlotStyleSheetList Method

GetPlotStyleSheetList Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »GetPlotStyleSheetList()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection GetPlotStyleSheetList()
Public Function GetPlotStyleSheetList As StringCollection
public:
StringCollection^ GetPlotStyleSheetList()


RefreshLists Method (plotSet)

RefreshLists Method (plotSet)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »RefreshLists(PlotSettings)
Declaration Syntax
C# Visual Basic Visual C++
public void RefreshLists(
    PlotSettings plotSet
)
Public Sub RefreshLists ( _
    plotSet As PlotSettings _
)
public:
void RefreshLists(
    PlotSettings^ plotSet
)
Parameters
plotSet(PlotSettings)


SetCanonicalMediaName Method (plotSet, mediaName)

SetCanonicalMediaName Method (plotSet, mediaName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetCanonicalMediaName(PlotSettings, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetCanonicalMediaName(
    PlotSettings plotSet,
    string mediaName
)
Public Sub SetCanonicalMediaName ( _
    plotSet As PlotSettings, _
    mediaName As String _
)
public:
void SetCanonicalMediaName(
    PlotSettings^ plotSet,
    String^ mediaName
)
Parameters
plotSet(PlotSettings)
mediaName(String)


SetClosestMediaName Method (plotSet, paperWidth, paperHeight, units, matchPrintableArea)

SetClosestMediaName Method (plotSet, paperWidth, paperHeight, units, matchPrintableArea)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetClosestMediaName(PlotSettings, Double, Double, PlotPaperUnit, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetClosestMediaName(
    PlotSettings plotSet,
    double paperWidth,
    double paperHeight,
    PlotPaperUnit units,
    bool matchPrintableArea
)
Public Sub SetClosestMediaName ( _
    plotSet As PlotSettings, _
    paperWidth As Double, _
    paperHeight As Double, _
    units As PlotPaperUnit, _
    matchPrintableArea As Boolean _
)
public:
void SetClosestMediaName(
    PlotSettings^ plotSet,
    double paperWidth,
    double paperHeight,
    PlotPaperUnit units,
    bool matchPrintableArea
)
Parameters
plotSet(PlotSettings)
paperWidth(Double)
paperHeight(Double)
units(PlotPaperUnit)
matchPrintableArea(Boolean)


SetCurrentStyleSheet Method (plotSet, styleSheetName)

SetCurrentStyleSheet Method (plotSet, styleSheetName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetCurrentStyleSheet(PlotSettings, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetCurrentStyleSheet(
    PlotSettings plotSet,
    string styleSheetName
)
Public Sub SetCurrentStyleSheet ( _
    plotSet As PlotSettings, _
    styleSheetName As String _
)
public:
void SetCurrentStyleSheet(
    PlotSettings^ plotSet,
    String^ styleSheetName
)
Parameters
plotSet(PlotSettings)
styleSheetName(String)


SetCustomPrintScale Method (plotSet, scale)

SetCustomPrintScale Method (plotSet, scale)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetCustomPrintScale(PlotSettings, CustomScale)
Declaration Syntax
C# Visual Basic Visual C++
public void SetCustomPrintScale(
    PlotSettings plotSet,
    CustomScale scale
)
Public Sub SetCustomPrintScale ( _
    plotSet As PlotSettings, _
    scale As CustomScale _
)
public:
void SetCustomPrintScale(
    PlotSettings^ plotSet,
    CustomScale scale
)
Parameters
plotSet(PlotSettings)
scale(CustomScale)


SetDefaultPlotConfig Method (plotSet)

SetDefaultPlotConfig Method (plotSet)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetDefaultPlotConfig(PlotSettings)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDefaultPlotConfig(
    PlotSettings plotSet
)
Public Sub SetDefaultPlotConfig ( _
    plotSet As PlotSettings _
)
public:
void SetDefaultPlotConfig(
    PlotSettings^ plotSet
)
Parameters
plotSet(PlotSettings)


SetPlotCentered Method (plotSet, isCentered)

SetPlotCentered Method (plotSet, isCentered)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetPlotCentered(PlotSettings, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPlotCentered(
    PlotSettings plotSet,
    bool isCentered
)
Public Sub SetPlotCentered ( _
    plotSet As PlotSettings, _
    isCentered As Boolean _
)
public:
void SetPlotCentered(
    PlotSettings^ plotSet,
    bool isCentered
)
Parameters
plotSet(PlotSettings)
isCentered(Boolean)


SetPlotConfigurationName Method (plotSet, plotDeviceName, mediaName)

SetPlotConfigurationName Method (plotSet, plotDeviceName, mediaName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetPlotConfigurationName(PlotSettings, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPlotConfigurationName(
    PlotSettings plotSet,
    string plotDeviceName,
    string mediaName
)
Public Sub SetPlotConfigurationName ( _
    plotSet As PlotSettings, _
    plotDeviceName As String, _
    mediaName As String _
)
public:
void SetPlotConfigurationName(
    PlotSettings^ plotSet,
    String^ plotDeviceName,
    String^ mediaName
)
Parameters
plotSet(PlotSettings)
plotDeviceName(String)
mediaName(String)


SetPlotOrigin Method (plotSet, origin)

SetPlotOrigin Method (plotSet, origin)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetPlotOrigin(PlotSettings, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPlotOrigin(
    PlotSettings plotSet,
    Point2d origin
)
Public Sub SetPlotOrigin ( _
    plotSet As PlotSettings, _
    origin As Point2d _
)
public:
void SetPlotOrigin(
    PlotSettings^ plotSet,
    Point2d origin
)
Parameters
plotSet(PlotSettings)
origin(Point2d)


SetPlotPaperUnits Method (plotSet, units)

SetPlotPaperUnits Method (plotSet, units)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetPlotPaperUnits(PlotSettings, PlotPaperUnit)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPlotPaperUnits(
    PlotSettings plotSet,
    PlotPaperUnit units
)
Public Sub SetPlotPaperUnits ( _
    plotSet As PlotSettings, _
    units As PlotPaperUnit _
)
public:
void SetPlotPaperUnits(
    PlotSettings^ plotSet,
    PlotPaperUnit units
)
Parameters
plotSet(PlotSettings)
units(PlotPaperUnit)


SetPlotRotation Method (plotSet, rotationType)

SetPlotRotation Method (plotSet, rotationType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetPlotRotation(PlotSettings, PlotRotation)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPlotRotation(
    PlotSettings plotSet,
    PlotRotation rotationType
)
Public Sub SetPlotRotation ( _
    plotSet As PlotSettings, _
    rotationType As PlotRotation _
)
public:
void SetPlotRotation(
    PlotSettings^ plotSet,
    PlotRotation rotationType
)
Parameters
plotSet(PlotSettings)
rotationType(PlotRotation)


SetPlotType Method (plotSet, plotAreaType)

SetPlotType Method (plotSet, plotAreaType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetPlotType(PlotSettings, PlotType)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPlotType(
    PlotSettings plotSet,
    PlotType plotAreaType
)
Public Sub SetPlotType ( _
    plotSet As PlotSettings, _
    plotAreaType As PlotType _
)
public:
void SetPlotType(
    PlotSettings^ plotSet,
    PlotType plotAreaType
)
Parameters
plotSet(PlotSettings)
plotAreaType(PlotType)


SetPlotViewName Method (plotSet, viewName)

SetPlotViewName Method (plotSet, viewName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetPlotViewName(PlotSettings, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPlotViewName(
    PlotSettings plotSet,
    string viewName
)
Public Sub SetPlotViewName ( _
    plotSet As PlotSettings, _
    viewName As String _
)
public:
void SetPlotViewName(
    PlotSettings^ plotSet,
    String^ viewName
)
Parameters
plotSet(PlotSettings)
viewName(String)


SetPlotWindowArea Method (plotSet, windowArea)

SetPlotWindowArea Method (plotSet, windowArea)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetPlotWindowArea(PlotSettings, Extents2d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPlotWindowArea(
    PlotSettings plotSet,
    Extents2d windowArea
)
Public Sub SetPlotWindowArea ( _
    plotSet As PlotSettings, _
    windowArea As Extents2d _
)
public:
void SetPlotWindowArea(
    PlotSettings^ plotSet,
    Extents2d windowArea
)
Parameters
plotSet(PlotSettings)
windowArea(Extents2d)


SetStdScale Method (plotSet, standardScale)

SetStdScale Method (plotSet, standardScale)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetStdScale(PlotSettings, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetStdScale(
    PlotSettings plotSet,
    double standardScale
)
Public Sub SetStdScale ( _
    plotSet As PlotSettings, _
    standardScale As Double _
)
public:
void SetStdScale(
    PlotSettings^ plotSet,
    double standardScale
)
Parameters
plotSet(PlotSettings)
standardScale(Double)


SetStdScaleType Method (plotSet, scaleType)

SetStdScaleType Method (plotSet, scaleType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetStdScaleType(PlotSettings, StdScaleType)
Declaration Syntax
C# Visual Basic Visual C++
public void SetStdScaleType(
    PlotSettings plotSet,
    StdScaleType scaleType
)
Public Sub SetStdScaleType ( _
    plotSet As PlotSettings, _
    scaleType As StdScaleType _
)
public:
void SetStdScaleType(
    PlotSettings^ plotSet,
    StdScaleType scaleType
)
Parameters
plotSet(PlotSettings)
scaleType(StdScaleType)


SetUseStandardScale Method (plotSet, useStandard)

SetUseStandardScale Method (plotSet, useStandard)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetUseStandardScale(PlotSettings, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUseStandardScale(
    PlotSettings plotSet,
    bool useStandard
)
Public Sub SetUseStandardScale ( _
    plotSet As PlotSettings, _
    useStandard As Boolean _
)
public:
void SetUseStandardScale(
    PlotSettings^ plotSet,
    bool useStandard
)
Parameters
plotSet(PlotSettings)
useStandard(Boolean)


SetZoomToPaperOnUpdate Method (plotSet, doZoom)

SetZoomToPaperOnUpdate Method (plotSet, doZoom)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »SetZoomToPaperOnUpdate(PlotSettings, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetZoomToPaperOnUpdate(
    PlotSettings plotSet,
    bool doZoom
)
Public Sub SetZoomToPaperOnUpdate ( _
    plotSet As PlotSettings, _
    doZoom As Boolean _
)
public:
void SetZoomToPaperOnUpdate(
    PlotSettings^ plotSet,
    bool doZoom
)
Parameters
plotSet(PlotSettings)
doZoom(Boolean)


PlotStyle Class

PlotStyle Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdPsPlotStyleData")]
public class PlotStyle : RXObject
<WrapperAttribute("OdPsPlotStyleData")> _
Public Class PlotStyle _
    Inherits RXObject
[WrapperAttribute(L"OdPsPlotStyleData")]
public ref class PlotStyle : public RXObject
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Data |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Description |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | LocalizedName |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | PlotStyle


Data Property

Data Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyle »Data
Declaration Syntax
C# Visual Basic Visual C++
public PlotStyleData Data { get; set; }
Public Property Data As PlotStyleData
    Get
    Set
public:
property PlotStyleData Data {
    PlotStyleData get ();
    void set (PlotStyleData value);
}


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyle »Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


LocalizedName Property

LocalizedName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyle »LocalizedName
Declaration Syntax
C# Visual Basic Visual C++
public string LocalizedName { get; set; }
Public Property LocalizedName As String
    Get
    Set
public:
property String^ LocalizedName {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyle »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


PlotStyleData Structure

PlotStyleData Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdPsPlotStyleData")]
public struct PlotStyleData
<WrapperAttribute("OdPsPlotStyleData")> _
Public Structure PlotStyleData
[WrapperAttribute(L"OdPsPlotStyleData")]
public value class PlotStyleData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AdaptiveLinetype |
 | Color |
 | ColorPolicy |
 | DitherOn |
 | Equality(PlotStyleData, PlotStyleData) |
 | Equals(Object) | (Inherited from ValueType.)
 | FillStyle |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | GrayScaleOn |
 | Inequality(PlotStyleData, PlotStyleData) |
 | LineEndStyle |
 | LineJoinStyle |
 | LinePatternSize |
 | LineType |
 | Lineweight |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PhysicalPenNumber |
 | Screening |
 | ToString()()()() | (Inherited from ValueType.)
 | VirtualPenNumber |


AdaptiveLinetype Property

AdaptiveLinetype Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »AdaptiveLinetype
Declaration Syntax
C# Visual Basic Visual C++
public bool AdaptiveLinetype { get; set; }
Public Property AdaptiveLinetype As Boolean
    Get
    Set
public:
property bool AdaptiveLinetype {
    bool get ();
    void set (bool value);
}


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »Color
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor Color { get; set; }
Public Property Color As EntityColor
    Get
    Set
public:
property EntityColor Color {
    EntityColor get ();
    void set (EntityColor value);
}


ColorPolicy Property

ColorPolicy Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »ColorPolicy
Declaration Syntax
C# Visual Basic Visual C++
public int ColorPolicy { get; set; }
Public Property ColorPolicy As Integer
    Get
    Set
public:
property int ColorPolicy {
    int get ();
    void set (int value);
}


DitherOn Property

DitherOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »DitherOn
Declaration Syntax
C# Visual Basic Visual C++
public bool DitherOn { get; set; }
Public Property DitherOn As Boolean
    Get
    Set
public:
property bool DitherOn {
    bool get ();
    void set (bool value);
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »Equality(PlotStyleData, PlotStyleData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    PlotStyleData a,
    PlotStyleData b
)
Public Shared Operator = ( _
    a As PlotStyleData, _
    b As PlotStyleData _
) As Boolean
public:
static bool operator ==(
    PlotStyleData a,
    PlotStyleData b
)
Parameters
a(PlotStyleData)
b(PlotStyleData)


FillStyle Property

FillStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »FillStyle
Declaration Syntax
C# Visual Basic Visual C++
public FillStyle FillStyle { get; set; }
Public Property FillStyle As FillStyle
    Get
    Set
public:
property FillStyle FillStyle {
    FillStyle get ();
    void set (FillStyle value);
}


GrayScaleOn Property

GrayScaleOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »GrayScaleOn
Declaration Syntax
C# Visual Basic Visual C++
public bool GrayScaleOn { get; set; }
Public Property GrayScaleOn As Boolean
    Get
    Set
public:
property bool GrayScaleOn {
    bool get ();
    void set (bool value);
}


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »Inequality(PlotStyleData, PlotStyleData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    PlotStyleData a,
    PlotStyleData b
)
Public Shared Operator <> ( _
    a As PlotStyleData, _
    b As PlotStyleData _
) As Boolean
public:
static bool operator !=(
    PlotStyleData a,
    PlotStyleData b
)
Parameters
a(PlotStyleData)
b(PlotStyleData)


LineEndStyle Property

LineEndStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »LineEndStyle
Declaration Syntax
C# Visual Basic Visual C++
public LineEndStyle LineEndStyle { get; set; }
Public Property LineEndStyle As LineEndStyle
    Get
    Set
public:
property LineEndStyle LineEndStyle {
    LineEndStyle get ();
    void set (LineEndStyle value);
}


LineJoinStyle Property

LineJoinStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »LineJoinStyle
Declaration Syntax
C# Visual Basic Visual C++
public LineJoinStyle LineJoinStyle { get; set; }
Public Property LineJoinStyle As LineJoinStyle
    Get
    Set
public:
property LineJoinStyle LineJoinStyle {
    LineJoinStyle get ();
    void set (LineJoinStyle value);
}


LinePatternSize Property

LinePatternSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »LinePatternSize
Declaration Syntax
C# Visual Basic Visual C++
public double LinePatternSize { get; set; }
Public Property LinePatternSize As Double
    Get
    Set
public:
property double LinePatternSize {
    double get ();
    void set (double value);
}


LineType Property

LineType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »LineType
Declaration Syntax
C# Visual Basic Visual C++
public LineType LineType { get; set; }
Public Property LineType As LineType
    Get
    Set
public:
property LineType LineType {
    LineType get ();
    void set (LineType value);
}


Lineweight Property

Lineweight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »Lineweight
Declaration Syntax
C# Visual Basic Visual C++
public double Lineweight { get; set; }
Public Property Lineweight As Double
    Get
    Set
public:
property double Lineweight {
    double get ();
    void set (double value);
}


PhysicalPenNumber Property

PhysicalPenNumber Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »PhysicalPenNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PhysicalPenNumber { get; set; }
Public Property PhysicalPenNumber As Integer
    Get
    Set
public:
property int PhysicalPenNumber {
    int get ();
    void set (int value);
}


Screening Property

Screening Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »Screening
Declaration Syntax
C# Visual Basic Visual C++
public int Screening { get; set; }
Public Property Screening As Integer
    Get
    Set
public:
property int Screening {
    int get ();
    void set (int value);
}


VirtualPenNumber Property

VirtualPenNumber Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleData »VirtualPenNumber
Declaration Syntax
C# Visual Basic Visual C++
public int VirtualPenNumber { get; set; }
Public Property VirtualPenNumber As Integer
    Get
    Set
public:
property int VirtualPenNumber {
    int get ();
    void set (int value);
}


PlotStyleDescriptor Structure

PlotStyleDescriptor Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor
Declaration Syntax
C# Visual Basic Visual C++
public struct PlotStyleDescriptor
Public Structure PlotStyleDescriptor
public value class PlotStyleDescriptor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlotStyleDescriptor(ObjectId, PlotStyleNameType) |
 | Equality(PlotStyleDescriptor, PlotStyleDescriptor) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | Inequality(PlotStyleDescriptor, PlotStyleDescriptor) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | Type |


PlotStyleDescriptor Constructor (id, type)

PlotStyleDescriptor Constructor (id, type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor »PlotStyleDescriptor(ObjectId, PlotStyleNameType)
Declaration Syntax
C# Visual Basic Visual C++
public PlotStyleDescriptor(
    ObjectId id,
    PlotStyleNameType type
)
Public Sub New ( _
    id As ObjectId, _
    type As PlotStyleNameType _
)
public:
PlotStyleDescriptor(
    ObjectId id,
    PlotStyleNameType type
)
Parameters
id(ObjectId)
type(PlotStyleNameType)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor »Equality(PlotStyleDescriptor, PlotStyleDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    PlotStyleDescriptor a,
    PlotStyleDescriptor b
)
Public Shared Operator = ( _
    a As PlotStyleDescriptor, _
    b As PlotStyleDescriptor _
) As Boolean
public:
static bool operator ==(
    PlotStyleDescriptor a,
    PlotStyleDescriptor b
)
Parameters
a(PlotStyleDescriptor)
b(PlotStyleDescriptor)


Equals Method (unmanagedObjPtr)

Equals Method (unmanagedObjPtr)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object unmanagedObjPtr
)
Public Overrides NotOverridable Function Equals ( _
    unmanagedObjPtr As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ unmanagedObjPtr
) override sealed
Parameters
unmanagedObjPtr(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor »Id
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Id { get; }
Public ReadOnly Property Id As ObjectId
    Get
public:
property ObjectId Id {
    ObjectId get ();
}


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor »Inequality(PlotStyleDescriptor, PlotStyleDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    PlotStyleDescriptor a,
    PlotStyleDescriptor b
)
Public Shared Operator <> ( _
    a As PlotStyleDescriptor, _
    b As PlotStyleDescriptor _
) As Boolean
public:
static bool operator !=(
    PlotStyleDescriptor a,
    PlotStyleDescriptor b
)
Parameters
a(PlotStyleDescriptor)
b(PlotStyleDescriptor)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


Type Property

Type Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleDescriptor »Type
Declaration Syntax
C# Visual Basic Visual C++
public PlotStyleNameType Type { get; }
Public ReadOnly Property Type As PlotStyleNameType
    Get
public:
property PlotStyleNameType Type {
    PlotStyleNameType get ();
}


PlotStyleNameType Enumeration

PlotStyleNameType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleNameType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("Oda::PlotStyleNameType")]
public enum PlotStyleNameType
<WrapperAttribute("Oda::PlotStyleNameType")> _
Public Enumeration PlotStyleNameType
[WrapperAttribute(L"Oda::PlotStyleNameType")]
public enum class PlotStyleNameType
Members
Member | Description
PlotStyleNameIsDictionaryDefault |
PlotStyleNameByLayer |
PlotStyleNameById |
PlotStyleNameByBlock |


PlotStyleTable Class

PlotStyleTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdPsPlotStyleTable")]
public class PlotStyleTable : RXObject
<WrapperAttribute("OdPsPlotStyleTable")> _
Public Class PlotStyleTable _
    Inherits RXObject
[WrapperAttribute(L"OdPsPlotStyleTable")]
public ref class PlotStyleTable : public RXObject
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddNewPlotStyle(String) |
 | AddPlotStyle(PlotStyle) |
 | ApplyScaleFactor |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DelPlotStyle(PlotStyle) |
 | Description |
 | DisplayCustomLineweightUnits |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLineweightAt(Int32) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Lineweights |
 | LineweightSize |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotStyleArr |
 | PlotStyleAt(Int32) |
 | PlotStyleAt(String) |
 | PlotStyleSize |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ScaleFactor |
 | SetLineweightAt(Double, Int32) |
 | SetOrdering(array<String>[]()[][]) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | PlotStyleTable


AddNewPlotStyle Method (styleName)

AddNewPlotStyle Method (styleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »AddNewPlotStyle(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual PlotStyle AddNewPlotStyle(
    string styleName
)
Public Overridable Function AddNewPlotStyle ( _
    styleName As String _
) As PlotStyle
public:
virtual PlotStyle^ AddNewPlotStyle(
    String^ styleName
)
Parameters
styleName(String)


AddPlotStyle Method (pPs)

AddPlotStyle Method (pPs)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »AddPlotStyle(PlotStyle)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddPlotStyle(
    PlotStyle pPs
)
Public Overridable Sub AddPlotStyle ( _
    pPs As PlotStyle _
)
public:
virtual void AddPlotStyle(
    PlotStyle^ pPs
)
Parameters
pPs(PlotStyle)


ApplyScaleFactor Property

ApplyScaleFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »ApplyScaleFactor
Declaration Syntax
C# Visual Basic Visual C++
public bool ApplyScaleFactor { get; set; }
Public Property ApplyScaleFactor As Boolean
    Get
    Set
public:
property bool ApplyScaleFactor {
    bool get ();
    void set (bool value);
}


DelPlotStyle Method (pPsPtr)

DelPlotStyle Method (pPsPtr)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »DelPlotStyle(PlotStyle)
Declaration Syntax
C# Visual Basic Visual C++
public virtual PlotStyle DelPlotStyle(
    PlotStyle pPsPtr
)
Public Overridable Function DelPlotStyle ( _
    pPsPtr As PlotStyle _
) As PlotStyle
public:
virtual PlotStyle^ DelPlotStyle(
    PlotStyle^ pPsPtr
)
Parameters
pPsPtr(PlotStyle)


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DisplayCustomLineweightUnits Property

DisplayCustomLineweightUnits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »DisplayCustomLineweightUnits
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayCustomLineweightUnits { get; set; }
Public Property DisplayCustomLineweightUnits As Boolean
    Get
    Set
public:
property bool DisplayCustomLineweightUnits {
    bool get ();
    void set (bool value);
}


GetLineweightAt Method (index)

GetLineweightAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »GetLineweightAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetLineweightAt(
    int index
)
Public Overridable Function GetLineweightAt ( _
    index As Integer _
) As Double
public:
virtual double GetLineweightAt(
    int index
)
Parameters
index(Int32)


Lineweights Property

Lineweights Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »Lineweights
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection Lineweights { set; }
Public WriteOnly Property Lineweights As DoubleCollection
    Set
public:
property DoubleCollection^ Lineweights {
    void set (DoubleCollection^ value);
}


LineweightSize Property

LineweightSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »LineweightSize
Declaration Syntax
C# Visual Basic Visual C++
public uint LineweightSize { get; }
Public ReadOnly Property LineweightSize As UInteger
    Get
public:
property unsigned int LineweightSize {
    unsigned int get ();
}


PlotStyleArr Property

PlotStyleArr Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »PlotStyleArr
Declaration Syntax
C# Visual Basic Visual C++
public PlotStyle[] PlotStyleArr { get; set; }
Public Property PlotStyleArr As PlotStyle()
    Get
    Set
public:
property array<PlotStyle^>^ PlotStyleArr {
    array<PlotStyle^>^ get ();
    void set (array<PlotStyle^>^ value);
}


PlotStyleAt Method

PlotStyleAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »PlotStyleAt()()()()
Members
Icon | Member | Description
 | PlotStyleAt(Int32) |
 | PlotStyleAt(String) |


PlotStyleAt Method (index)

PlotStyleAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »PlotStyleAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual PlotStyle PlotStyleAt(
    int index
)
Public Overridable Function PlotStyleAt ( _
    index As Integer _
) As PlotStyle
public:
virtual PlotStyle^ PlotStyleAt(
    int index
)
Parameters
index(Int32)


PlotStyleAt Method (name)

PlotStyleAt Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »PlotStyleAt(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual PlotStyle PlotStyleAt(
    string name
)
Public Overridable Function PlotStyleAt ( _
    name As String _
) As PlotStyle
public:
virtual PlotStyle^ PlotStyleAt(
    String^ name
)
Parameters
name(String)


PlotStyleSize Property

PlotStyleSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »PlotStyleSize
Declaration Syntax
C# Visual Basic Visual C++
public uint PlotStyleSize { get; }
Public ReadOnly Property PlotStyleSize As UInteger
    Get
public:
property unsigned int PlotStyleSize {
    unsigned int get ();
}


ScaleFactor Property

ScaleFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »ScaleFactor
Declaration Syntax
C# Visual Basic Visual C++
public double ScaleFactor { get; set; }
Public Property ScaleFactor As Double
    Get
    Set
public:
property double ScaleFactor {
    double get ();
    void set (double value);
}


SetLineweightAt Method (val, index)

SetLineweightAt Method (val, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »SetLineweightAt(Double, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetLineweightAt(
    double val,
    int index
)
Public Overridable Sub SetLineweightAt ( _
    val As Double, _
    index As Integer _
)
public:
virtual void SetLineweightAt(
    double val,
    int index
)
Parameters
val(Double)
index(Int32)


SetOrdering Method (order)

SetOrdering Method (order)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »SetOrdering(array<String>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetOrdering(
    string[] order
)
Public Overridable Sub SetOrdering ( _
    order As String() _
)
public:
virtual void SetOrdering(
    array<String^>^ order
)
Parameters
order(array<String>[]()[][])


PlotStyleTableChangedEventArgs Class

PlotStyleTableChangedEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTableChangedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PlotStyleTableChangedEventArgs : EventArgs
Public NotInheritable Class PlotStyleTableChangedEventArgs _
    Inherits EventArgs
public ref class PlotStyleTableChangedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewName |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PlotStyleTableChangedEventArgs


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTableChangedEventArgs »Id
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Id { get; }
Public ReadOnly Property Id As ObjectId
    Get
public:
property ObjectId Id {
    ObjectId get ();
}


NewName Property

NewName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTableChangedEventArgs »NewName
Declaration Syntax
C# Visual Basic Visual C++
public string NewName { get; }
Public ReadOnly Property NewName As String
    Get
public:
property String^ NewName {
    String^ get ();
}


PlotStyleTableChangedEventHandler Delegate

PlotStyleTableChangedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTableChangedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PlotStyleTableChangedEventHandler(
    Object sender,
    PlotStyleTableChangedEventArgs e
)
Public Delegate Sub PlotStyleTableChangedEventHandler ( _
    sender As Object, _
    e As PlotStyleTableChangedEventArgs _
)
public delegate void PlotStyleTableChangedEventHandler(
    Object^ sender,
    PlotStyleTableChangedEventArgs^ e
)
Parameters
sender(Object)
e(PlotStyleTableChangedEventArgs)


PlotType Enumeration

PlotType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotType
Declaration Syntax
C# Visual Basic Visual C++
public enum PlotType
Public Enumeration PlotType
public enum class PlotType
Members
Member | Description
View |
Limits |
Display |
Window |
Extents |
Layout |


Point3AngularDimension Class

Point3AngularDimension Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDb3PointAngularDimension")]
public class Point3AngularDimension : Dimension
<WrapperAttribute("AcDb3PointAngularDimension")> _
Public Class Point3AngularDimension _
    Inherits Dimension
[WrapperAttribute(L"AcDb3PointAngularDimension")]
public ref class Point3AngularDimension : public Dimension
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Point3AngularDimension(Point3d, Point3d, Point3d, Point3d, String, ObjectId) |
 | Point3AngularDimension(IntPtr, Boolean) |
 | Point3AngularDimension()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlternatePrefix | (Inherited from Dimension.)
 | AlternateSuffix | (Inherited from Dimension.)
 | AltSuppressLeadingZeros | (Inherited from Dimension.)
 | AltSuppressTrailingZeros | (Inherited from Dimension.)
 | AltSuppressZeroFeet | (Inherited from Dimension.)
 | AltSuppressZeroInches | (Inherited from Dimension.)
 | AltToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | AltToleranceSuppressZeroInches | (Inherited from Dimension.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | ArcPoint |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | CenterMarkSize | (Inherited from Dimension.)
 | CenterMarkType | (Inherited from Dimension.)
 | CenterPoint |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec | (Inherited from Dimension.)
 | Dimalt | (Inherited from Dimension.)
 | Dimaltd | (Inherited from Dimension.)
 | Dimaltf | (Inherited from Dimension.)
 | Dimaltrnd | (Inherited from Dimension.)
 | Dimalttd | (Inherited from Dimension.)
 | Dimalttz | (Inherited from Dimension.)
 | Dimaltu | (Inherited from Dimension.)
 | Dimaltz | (Inherited from Dimension.)
 | Dimapost | (Inherited from Dimension.)
 | Dimarcsym | (Inherited from Dimension.)
 | Dimasz | (Inherited from Dimension.)
 | Dimatfit | (Inherited from Dimension.)
 | Dimaunit | (Inherited from Dimension.)
 | Dimazin | (Inherited from Dimension.)
 | Dimblk | (Inherited from Dimension.)
 | Dimblk1 | (Inherited from Dimension.)
 | Dimblk1s | (Inherited from Dimension.)
 | Dimblk2 | (Inherited from Dimension.)
 | Dimblk2s | (Inherited from Dimension.)
 | Dimblks | (Inherited from Dimension.)
 | DimBlockId | (Inherited from Dimension.)
 | DimBlockPosition | (Inherited from Dimension.)
 | Dimcen | (Inherited from Dimension.)
 | Dimclrd | (Inherited from Dimension.)
 | Dimclre | (Inherited from Dimension.)
 | Dimclrt | (Inherited from Dimension.)
 | Dimdec | (Inherited from Dimension.)
 | Dimdle | (Inherited from Dimension.)
 | Dimdli | (Inherited from Dimension.)
 | Dimdsep | (Inherited from Dimension.)
 | DimensionStyle | (Inherited from Dimension.)
 | DimensionStyleName | (Inherited from Dimension.)
 | DimensionText | (Inherited from Dimension.)
 | Dimexe | (Inherited from Dimension.)
 | Dimexo | (Inherited from Dimension.)
 | Dimfrac | (Inherited from Dimension.)
 | Dimfxlen | (Inherited from Dimension.)
 | DimfxlenOn | (Inherited from Dimension.)
 | Dimgap | (Inherited from Dimension.)
 | Dimjogang | (Inherited from Dimension.)
 | Dimjust | (Inherited from Dimension.)
 | Dimldrblk | (Inherited from Dimension.)
 | Dimldrblks | (Inherited from Dimension.)
 | Dimlfac | (Inherited from Dimension.)
 | Dimlim | (Inherited from Dimension.)
 | Dimltex1 | (Inherited from Dimension.)
 | Dimltex2 | (Inherited from Dimension.)
 | Dimltype | (Inherited from Dimension.)
 | Dimlunit | (Inherited from Dimension.)
 | Dimlwd | (Inherited from Dimension.)
 | Dimlwe | (Inherited from Dimension.)
 | Dimpost | (Inherited from Dimension.)
 | Dimrnd | (Inherited from Dimension.)
 | Dimsah | (Inherited from Dimension.)
 | Dimscale | (Inherited from Dimension.)
 | Dimsd1 | (Inherited from Dimension.)
 | Dimsd2 | (Inherited from Dimension.)
 | Dimse1 | (Inherited from Dimension.)
 | Dimse2 | (Inherited from Dimension.)
 | Dimsoxd | (Inherited from Dimension.)
 | DimstyleData | (Inherited from Dimension.)
 | Dimtad | (Inherited from Dimension.)
 | Dimtdec | (Inherited from Dimension.)
 | Dimtfac | (Inherited from Dimension.)
 | Dimtfill | (Inherited from Dimension.)
 | Dimtfillclr | (Inherited from Dimension.)
 | Dimtih | (Inherited from Dimension.)
 | Dimtix | (Inherited from Dimension.)
 | Dimtm | (Inherited from Dimension.)
 | Dimtmove | (Inherited from Dimension.)
 | Dimtofl | (Inherited from Dimension.)
 | Dimtoh | (Inherited from Dimension.)
 | Dimtol | (Inherited from Dimension.)
 | Dimtolj | (Inherited from Dimension.)
 | Dimtp | (Inherited from Dimension.)
 | Dimtsz | (Inherited from Dimension.)
 | Dimtvp | (Inherited from Dimension.)
 | Dimtxsty | (Inherited from Dimension.)
 | Dimtxt | (Inherited from Dimension.)
 | Dimtzin | (Inherited from Dimension.)
 | Dimupt | (Inherited from Dimension.)
 | Dimzin | (Inherited from Dimension.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicDimension | (Inherited from Dimension.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation | (Inherited from Dimension.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldFromMText(MText) | (Inherited from Dimension.)
 | FieldToMText(MText) | (Inherited from Dimension.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FormatMeasurement(Double, String) | (Inherited from Dimension.)
 | GenerateLayout()()()() | (Inherited from Dimension.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetDimstyleData()()()() | (Inherited from Dimension.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalRotation | (Inherited from Dimension.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | Measurement | (Inherited from Dimension.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal | (Inherited from Dimension.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Prefix | (Inherited from Dimension.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeDimensionBlock(Boolean) | (Inherited from Dimension.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveTextField()()()() | (Inherited from Dimension.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) | (Inherited from Dimension.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | Suffix | (Inherited from Dimension.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressAngularLeadingZeros | (Inherited from Dimension.)
 | SuppressAngularTrailingZeros | (Inherited from Dimension.)
 | SuppressLeadingZeros | (Inherited from Dimension.)
 | SuppressTrailingZeros | (Inherited from Dimension.)
 | SuppressZeroFeet | (Inherited from Dimension.)
 | SuppressZeroInches | (Inherited from Dimension.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAttachment | (Inherited from Dimension.)
 | TextLineSpacingFactor | (Inherited from Dimension.)
 | TextLineSpacingStyle | (Inherited from Dimension.)
 | TextPosition | (Inherited from Dimension.)
 | TextRotation | (Inherited from Dimension.)
 | TextStyleId | (Inherited from Dimension.)
 | ToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | ToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | ToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | ToleranceSuppressZeroInches | (Inherited from Dimension.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UsingDefaultTextPosition | (Inherited from Dimension.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | XLine1Point |
 | XLine2Point |
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  |  | Point3AngularDimension


Point3AngularDimension Constructor

Point3AngularDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »Point3AngularDimension()()()()
Members
Icon | Member | Description
 | Point3AngularDimension(Point3d, Point3d, Point3d, Point3d, String, ObjectId) |
 | Point3AngularDimension(IntPtr, Boolean) |
 | Point3AngularDimension()()()() |


Point3AngularDimension Constructor

Point3AngularDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »Point3AngularDimension()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3AngularDimension()
Public Sub New
public:
Point3AngularDimension()


Point3AngularDimension Constructor (unmanagedObjPtr, autoDelete)

Point3AngularDimension Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »Point3AngularDimension(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Point3AngularDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Point3AngularDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Point3AngularDimension Constructor (centerPoint, line1Point, line2Point, arcPoint, dimensionText, dimensionStyle)

Point3AngularDimension Constructor (centerPoint, line1Point, line2Point, arcPoint, dimensionText, dimensionStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »Point3AngularDimension(Point3d, Point3d, Point3d, Point3d, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public Point3AngularDimension(
    Point3d centerPoint,
    Point3d line1Point,
    Point3d line2Point,
    Point3d arcPoint,
    string dimensionText,
    ObjectId dimensionStyle
)
Public Sub New ( _
    centerPoint As Point3d, _
    line1Point As Point3d, _
    line2Point As Point3d, _
    arcPoint As Point3d, _
    dimensionText As String, _
    dimensionStyle As ObjectId _
)
public:
Point3AngularDimension(
    Point3d centerPoint,
    Point3d line1Point,
    Point3d line2Point,
    Point3d arcPoint,
    String^ dimensionText,
    ObjectId dimensionStyle
)
Parameters
centerPoint(Point3d)
line1Point(Point3d)
line2Point(Point3d)
arcPoint(Point3d)
dimensionText(String)
dimensionStyle(ObjectId)


ArcPoint Property

ArcPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »ArcPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ArcPoint { get; set; }
Public Property ArcPoint As Point3d
    Get
    Set
public:
property Point3d ArcPoint {
    Point3d get ();
    void set (Point3d value);
}


CenterPoint Property

CenterPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »CenterPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d CenterPoint { get; set; }
Public Property CenterPoint As Point3d
    Get
    Set
public:
property Point3d CenterPoint {
    Point3d get ();
    void set (Point3d value);
}


XLine1Point Property

XLine1Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »XLine1Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine1Point { get; set; }
Public Property XLine1Point As Point3d
    Get
    Set
public:
property Point3d XLine1Point {
    Point3d get ();
    void set (Point3d value);
}


XLine2Point Property

XLine2Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »XLine2Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine2Point { get; set; }
Public Property XLine2Point As Point3d
    Get
    Set
public:
property Point3d XLine2Point {
    Point3d get ();
    void set (Point3d value);
}


PointRef Class

PointRef Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbPointRef")]
public abstract class PointRef : RXObject
<WrapperAttribute("AcDbPointRef")> _
Public MustInherit Class PointRef _
    Inherits RXObject
[WrapperAttribute(L"AcDbPointRef")]
public ref class PointRef abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PointRef(IntPtr, Boolean) |
 | PointRef()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvalPoint()()()() |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEntities(Boolean) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsGeomErased()()()() |
 | IsXrefObj(ObjectIdCollection, ObjectIdCollection, Boolean) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateDueToMirror(Boolean) |
 | UpdateSubentPath(IdMapping) |
 | UpdateXrefSubentPath()()()() |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | PointRef
 |  |  |  |  | OsnapPointRef


PointRef Constructor

PointRef Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »PointRef()()()()
Members
Icon | Member | Description
 | PointRef(IntPtr, Boolean) |
 | PointRef()()()() |


PointRef Constructor

PointRef Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »PointRef()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal PointRef()
Protected Friend Sub New
protected public:
PointRef()


PointRef Constructor (unmanagedObject, autoDelete)

PointRef Constructor (unmanagedObject, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »PointRef(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal PointRef(
    IntPtr unmanagedObject,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObject As IntPtr, _
    autoDelete As Boolean _
)
protected public:
PointRef(
    IntPtr unmanagedObject,
    bool autoDelete
)
Parameters
unmanagedObject(IntPtr)
autoDelete(Boolean)


EvalPoint Method

EvalPoint Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »EvalPoint()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d EvalPoint()
Public Overridable Function EvalPoint As Point3d
public:
virtual Point3d EvalPoint()


GetEntities Method (getLastPtRef)

GetEntities Method (getLastPtRef)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »GetEntities(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual FullSubentityPath[] GetEntities(
    bool getLastPtRef
)
Public Overridable Function GetEntities ( _
    getLastPtRef As Boolean _
) As FullSubentityPath()
public:
virtual array<FullSubentityPath>^ GetEntities(
    bool getLastPtRef
)
Parameters
getLastPtRef(Boolean)


IsGeomErased Method

IsGeomErased Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »IsGeomErased()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsGeomErased()
Public Overridable Function IsGeomErased As Boolean
public:
virtual bool IsGeomErased()


IsXrefObj Method (ids1, ids2, isMainObj)

IsXrefObj Method (ids1, ids2, isMainObj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »IsXrefObj(ObjectIdCollection, ObjectIdCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsXrefObj(
    ObjectIdCollection ids1,
    ObjectIdCollection ids2,
    bool isMainObj
)
Public Overridable Function IsXrefObj ( _
    ids1 As ObjectIdCollection, _
    ids2 As ObjectIdCollection, _
    isMainObj As Boolean _
) As Boolean
public:
virtual bool IsXrefObj(
    ObjectIdCollection^ ids1,
    ObjectIdCollection^ ids2,
    bool isMainObj
)
Parameters
ids1(ObjectIdCollection)
ids2(ObjectIdCollection)
isMainObj(Boolean)


UpdateDueToMirror Method (inMirror)

UpdateDueToMirror Method (inMirror)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »UpdateDueToMirror(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UpdateDueToMirror(
    bool inMirror
)
Public Overridable Sub UpdateDueToMirror ( _
    inMirror As Boolean _
)
public:
virtual void UpdateDueToMirror(
    bool inMirror
)
Parameters
inMirror(Boolean)


UpdateSubentPath Method (idMap)

UpdateSubentPath Method (idMap)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »UpdateSubentPath(IdMapping)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UpdateSubentPath(
    IdMapping idMap
)
Public Overridable Sub UpdateSubentPath ( _
    idMap As IdMapping _
)
public:
virtual void UpdateSubentPath(
    IdMapping^ idMap
)
Parameters
idMap(IdMapping)


UpdateXrefSubentPath Method

UpdateXrefSubentPath Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »UpdateXrefSubentPath()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UpdateXrefSubentPath()
Public Overridable Sub UpdateXrefSubentPath
public:
virtual void UpdateXrefSubentPath()


Poly2dType Enumeration

Poly2dType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Poly2dType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::Poly2dType")]
public enum Poly2dType
<WrapperAttribute("ZcDb::Poly2dType")> _
Public Enumeration Poly2dType
[WrapperAttribute(L"ZcDb::Poly2dType")]
public enum class Poly2dType
Members
Member | Description
CubicSplinePoly |
QuadSplinePoly |
FitCurvePoly |
SimplePoly |


Poly3dType Enumeration

Poly3dType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Poly3dType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::Poly3dType")]
public enum Poly3dType
<WrapperAttribute("ZcDb::Poly3dType")> _
Public Enumeration Poly3dType
[WrapperAttribute(L"ZcDb::Poly3dType")]
public enum class Poly3dType
Members
Member | Description
CubicSplinePoly |
QuadSplinePoly |
SimplePoly |


PolyFaceMesh Class

PolyFaceMesh Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbPolyFaceMesh")]
public class PolyFaceMesh : Entity,
    IEnumerable
<WrapperAttribute("AcDbPolyFaceMesh")> _
Public Class PolyFaceMesh _
    Inherits Entity _
    Implements IEnumerable
[WrapperAttribute(L"AcDbPolyFaceMesh")]
public ref class PolyFaceMesh : public Entity,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolyFaceMesh()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | AppendFaceRecord(FaceRecord) |
 | AppendVertex(PolyFaceMeshVertex) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEnumerator()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | NumFaces |
 | NumVertices |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | PolyFaceMesh


PolyFaceMesh Constructor

PolyFaceMesh Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »PolyFaceMesh()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolyFaceMesh()
Public Sub New
public:
PolyFaceMesh()


AppendFaceRecord Method (toAppend)

AppendFaceRecord Method (toAppend)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »AppendFaceRecord(FaceRecord)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AppendFaceRecord(
    FaceRecord toAppend
)
Public Function AppendFaceRecord ( _
    toAppend As FaceRecord _
) As ObjectId
public:
ObjectId AppendFaceRecord(
    FaceRecord^ toAppend
)
Parameters
toAppend(FaceRecord)


AppendVertex Method (toAppend)

AppendVertex Method (toAppend)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »AppendVertex(PolyFaceMeshVertex)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AppendVertex(
    PolyFaceMeshVertex toAppend
)
Public Function AppendVertex ( _
    toAppend As PolyFaceMeshVertex _
) As ObjectId
public:
ObjectId AppendVertex(
    PolyFaceMeshVertex^ toAppend
)
Parameters
toAppend(PolyFaceMeshVertex)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()


NumFaces Property

NumFaces Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »NumFaces
Declaration Syntax
C# Visual Basic Visual C++
public int NumFaces { get; }
Public ReadOnly Property NumFaces As Integer
    Get
public:
property int NumFaces {
    int get ();
}


NumVertices Property

NumVertices Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »NumVertices
Declaration Syntax
C# Visual Basic Visual C++
public int NumVertices { get; }
Public ReadOnly Property NumVertices As Integer
    Get
public:
property int NumVertices {
    int get ();
}


PolyFaceMeshVertex Class

PolyFaceMeshVertex Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbPolyFaceMeshVertex")]
public class PolyFaceMeshVertex : Vertex
<WrapperAttribute("AcDbPolyFaceMeshVertex")> _
Public Class PolyFaceMeshVertex _
    Inherits Vertex
[WrapperAttribute(L"AcDbPolyFaceMeshVertex")]
public ref class PolyFaceMeshVertex : public Vertex
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolyFaceMeshVertex(Point3d) |
 | PolyFaceMeshVertex()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Vertex
 |  |  |  |  |  |  |  | PolyFaceMeshVertex


PolyFaceMeshVertex Constructor

PolyFaceMeshVertex Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »PolyFaceMeshVertex()()()()
Members
Icon | Member | Description
 | PolyFaceMeshVertex(Point3d) |
 | PolyFaceMeshVertex()()()() |


PolyFaceMeshVertex Constructor

PolyFaceMeshVertex Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »PolyFaceMeshVertex()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolyFaceMeshVertex()
Public Sub New
public:
PolyFaceMeshVertex()


PolyFaceMeshVertex Constructor (point)

PolyFaceMeshVertex Constructor (point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »PolyFaceMeshVertex(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PolyFaceMeshVertex(
    Point3d point
)
Public Sub New ( _
    point As Point3d _
)
public:
PolyFaceMeshVertex(
    Point3d point
)
Parameters
point(Point3d)


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »Position
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Position { get; set; }
Public Property Position As Point3d
    Get
    Set
public:
property Point3d Position {
    Point3d get ();
    void set (Point3d value);
}


PolygonMesh Class

PolygonMesh Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbPolygonMesh")]
public class PolygonMesh : Entity,
    IEnumerable
<WrapperAttribute("AcDbPolygonMesh")> _
Public Class PolygonMesh _
    Inherits Entity _
    Implements IEnumerable
[WrapperAttribute(L"AcDbPolygonMesh")]
public ref class PolygonMesh : public Entity,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolygonMesh(PolyMeshType, Int32, Int32, Point3dCollection, Boolean, Boolean) |
 | PolygonMesh()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | AppendVertex(PolygonMeshVertex) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToPolyMeshType(PolyMeshType) |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEnumerator()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsMClosed |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNClosed |
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | MakeMClosed()()()() |
 | MakeMOpen()()()() |
 | MakeNClosed()()()() |
 | MakeNOpen()()()() |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MSize |
 | MSurfaceDensity |
 | NSize |
 | NSurfaceDensity |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | PolyMeshType |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Straighten()()()() |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SurfaceFit(PolyMeshType, Int32, Int32) |
 | SurfaceFit()()()() |
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | PolygonMesh


PolygonMesh Constructor

PolygonMesh Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »PolygonMesh()()()()
Members
Icon | Member | Description
 | PolygonMesh(PolyMeshType, Int32, Int32, Point3dCollection, Boolean, Boolean) |
 | PolygonMesh()()()() |


PolygonMesh Constructor

PolygonMesh Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »PolygonMesh()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolygonMesh()
Public Sub New
public:
PolygonMesh()


PolygonMesh Constructor (type, size, sizeValue, vertices, closedValue, closed)

PolygonMesh Constructor (type, size, sizeValue, vertices, closedValue, closed)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »PolygonMesh(PolyMeshType, Int32, Int32, Point3dCollection, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public PolygonMesh(
    PolyMeshType type,
    int size,
    int sizeValue,
    Point3dCollection vertices,
    bool closedValue,
    bool closed
)
Public Sub New ( _
    type As PolyMeshType, _
    size As Integer, _
    sizeValue As Integer, _
    vertices As Point3dCollection, _
    closedValue As Boolean, _
    closed As Boolean _
)
public:
PolygonMesh(
    PolyMeshType type,
    int size,
    int sizeValue,
    Point3dCollection^ vertices,
    bool closedValue,
    bool closed
)
Parameters
type(PolyMeshType)
size(Int32)
sizeValue(Int32)
vertices(Point3dCollection)
closedValue(Boolean)
closed(Boolean)


AppendVertex Method (toAppend)

AppendVertex Method (toAppend)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »AppendVertex(PolygonMeshVertex)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AppendVertex(
    PolygonMeshVertex toAppend
)
Public Function AppendVertex ( _
    toAppend As PolygonMeshVertex _
) As ObjectId
public:
ObjectId AppendVertex(
    PolygonMeshVertex^ toAppend
)
Parameters
toAppend(PolygonMeshVertex)


ConvertToPolyMeshType Method (newVal)

ConvertToPolyMeshType Method (newVal)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »ConvertToPolyMeshType(PolyMeshType)
Declaration Syntax
C# Visual Basic Visual C++
public void ConvertToPolyMeshType(
    PolyMeshType newVal
)
Public Sub ConvertToPolyMeshType ( _
    newVal As PolyMeshType _
)
public:
void ConvertToPolyMeshType(
    PolyMeshType newVal
)
Parameters
newVal(PolyMeshType)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


IsMClosed Property

IsMClosed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »IsMClosed
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMClosed { get; }
Public ReadOnly Property IsMClosed As Boolean
    Get
public:
property bool IsMClosed {
    bool get ();
}


IsNClosed Property

IsNClosed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »IsNClosed
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNClosed { get; }
Public ReadOnly Property IsNClosed As Boolean
    Get
public:
property bool IsNClosed {
    bool get ();
}


MakeMClosed Method

MakeMClosed Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »MakeMClosed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeMClosed()
Public Sub MakeMClosed
public:
void MakeMClosed()


MakeMOpen Method

MakeMOpen Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »MakeMOpen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeMOpen()
Public Sub MakeMOpen
public:
void MakeMOpen()


MakeNClosed Method

MakeNClosed Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »MakeNClosed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeNClosed()
Public Sub MakeNClosed
public:
void MakeNClosed()


MakeNOpen Method

MakeNOpen Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »MakeNOpen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeNOpen()
Public Sub MakeNOpen
public:
void MakeNOpen()


MSize Property

MSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »MSize
Declaration Syntax
C# Visual Basic Visual C++
public short MSize { get; set; }
Public Property MSize As Short
    Get
    Set
public:
property short MSize {
    short get ();
    void set (short value);
}


MSurfaceDensity Property

MSurfaceDensity Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »MSurfaceDensity
Declaration Syntax
C# Visual Basic Visual C++
public short MSurfaceDensity { get; set; }
Public Property MSurfaceDensity As Short
    Get
    Set
public:
property short MSurfaceDensity {
    short get ();
    void set (short value);
}


NSize Property

NSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »NSize
Declaration Syntax
C# Visual Basic Visual C++
public short NSize { get; set; }
Public Property NSize As Short
    Get
    Set
public:
property short NSize {
    short get ();
    void set (short value);
}


NSurfaceDensity Property

NSurfaceDensity Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »NSurfaceDensity
Declaration Syntax
C# Visual Basic Visual C++
public short NSurfaceDensity { get; set; }
Public Property NSurfaceDensity As Short
    Get
    Set
public:
property short NSurfaceDensity {
    short get ();
    void set (short value);
}


PolyMeshType Property

PolyMeshType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »PolyMeshType
Declaration Syntax
C# Visual Basic Visual C++
public PolyMeshType PolyMeshType { get; set; }
Public Property PolyMeshType As PolyMeshType
    Get
    Set
public:
property PolyMeshType PolyMeshType {
    PolyMeshType get ();
    void set (PolyMeshType value);
}


Straighten Method

Straighten Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »Straighten()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Straighten()
Public Sub Straighten
public:
void Straighten()


SurfaceFit Method

SurfaceFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »SurfaceFit()()()()
Members
Icon | Member | Description
 | SurfaceFit(PolyMeshType, Int32, Int32) |
 | SurfaceFit()()()() |


SurfaceFit Method

SurfaceFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »SurfaceFit()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SurfaceFit()
Public Sub SurfaceFit
public:
void SurfaceFit()


SurfaceFit Method (surfType, surfU, surfV)

SurfaceFit Method (surfType, surfU, surfV)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »SurfaceFit(PolyMeshType, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SurfaceFit(
    PolyMeshType surfType,
    int surfU,
    int surfV
)
Public Sub SurfaceFit ( _
    surfType As PolyMeshType, _
    surfU As Integer, _
    surfV As Integer _
)
public:
void SurfaceFit(
    PolyMeshType surfType,
    int surfU,
    int surfV
)
Parameters
surfType(PolyMeshType)
surfU(Int32)
surfV(Int32)


PolygonMeshVertex Class

PolygonMeshVertex Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbPolygonMeshVertex")]
public class PolygonMeshVertex : Vertex
<WrapperAttribute("AcDbPolygonMeshVertex")> _
Public Class PolygonMeshVertex _
    Inherits Vertex
[WrapperAttribute(L"AcDbPolygonMeshVertex")]
public ref class PolygonMeshVertex : public Vertex
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolygonMeshVertex(Point3d) |
 | PolygonMeshVertex()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VertexType |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Vertex
 |  |  |  |  |  |  |  | PolygonMeshVertex


PolygonMeshVertex Constructor

PolygonMeshVertex Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »PolygonMeshVertex()()()()
Members
Icon | Member | Description
 | PolygonMeshVertex(Point3d) |
 | PolygonMeshVertex()()()() |


PolygonMeshVertex Constructor

PolygonMeshVertex Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »PolygonMeshVertex()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolygonMeshVertex()
Public Sub New
public:
PolygonMeshVertex()


PolygonMeshVertex Constructor (point)

PolygonMeshVertex Constructor (point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »PolygonMeshVertex(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PolygonMeshVertex(
    Point3d point
)
Public Sub New ( _
    point As Point3d _
)
public:
PolygonMeshVertex(
    Point3d point
)
Parameters
point(Point3d)


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »Position
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Position { get; set; }
Public Property Position As Point3d
    Get
    Set
public:
property Point3d Position {
    Point3d get ();
    void set (Point3d value);
}


VertexType Property

VertexType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »VertexType
Declaration Syntax
C# Visual Basic Visual C++
public Vertex3dType VertexType { get; }
Public ReadOnly Property VertexType As Vertex3dType
    Get
public:
property Vertex3dType VertexType {
    Vertex3dType get ();
}


Polyline Class

Polyline Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbPolyline")]
public class Polyline : Curve
<WrapperAttribute("AcDbPolyline")> _
Public Class Polyline _
    Inherits Curve
[WrapperAttribute(L"AcDbPolyline")]
public ref class Polyline : public Curve
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Polyline(IntPtr, Boolean) |
 | Polyline(Int32) |
 | Polyline()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AddVertexAt(Int32, Point2d, Double, Double, Double) |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed |
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConstantWidth |
 | ConvertFrom(Entity, Boolean) |
 | ConvertTo(Boolean) |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation |
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetArcSegment2dAt(Int32) |
 | GetArcSegmentAt(Int32) |
 | GetBulgeAt(Int32) |
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEndWidthAt(Int32) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLineSegment2dAt(Int32) |
 | GetLineSegmentAt(Int32) |
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPoint2dAt(Int32) |
 | GetPoint3dAt(Int32) |
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSegmentType(Int32) |
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStartWidthAt(Int32) |
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasBulges |
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | HasWidth |
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsOnlyLines |
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Length |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MaximizeMemory()()()() |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | MinimizeMemory()()()() |
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | NumberOfVertices |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OnSegmentAt(Int32, Point2d, Double) |
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | Plinegen |
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveVertexAt(Int32) |
 | Reset(Boolean, Int32) |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetBulgeAt(Int32, Double) |
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetEndWidthAt(Int32, Double) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPointAt(Int32, Point2d) |
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetStartWidthAt(Int32, Double) |
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Spline | (Inherited from Curve.)
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Inherited from Curve.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Polyline


Polyline Constructor

Polyline Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Polyline()()()()
Members
Icon | Member | Description
 | Polyline(IntPtr, Boolean) |
 | Polyline(Int32) |
 | Polyline()()()() |


Polyline Constructor

Polyline Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Polyline()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Polyline()
Public Sub New
public:
Polyline()


Polyline Constructor (vertices)

Polyline Constructor (vertices)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Polyline(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Polyline(
    int vertices
)
Public Sub New ( _
    vertices As Integer _
)
public:
Polyline(
    int vertices
)
Parameters
vertices(Int32)


Polyline Constructor (unmanagedObjPtr, autoDelete)

Polyline Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Polyline(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Polyline(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Polyline(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AddVertexAt Method (index, pt, bulge, startWidth, endWidth)

AddVertexAt Method (index, pt, bulge, startWidth, endWidth)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »AddVertexAt(Int32, Point2d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void AddVertexAt(
    int index,
    Point2d pt,
    double bulge,
    double startWidth,
    double endWidth
)
Public Sub AddVertexAt ( _
    index As Integer, _
    pt As Point2d, _
    bulge As Double, _
    startWidth As Double, _
    endWidth As Double _
)
public:
void AddVertexAt(
    int index,
    Point2d pt,
    double bulge,
    double startWidth,
    double endWidth
)
Parameters
index(Int32)
pt(Point2d)
bulge(Double)
startWidth(Double)
endWidth(Double)


Closed Property

Closed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Closed
Declaration Syntax
C# Visual Basic Visual C++
public bool Closed { get; set; }
Public Property Closed As Boolean
    Get
    Set
public:
property bool Closed {
    bool get ();
    void set (bool value);
}


ConstantWidth Property

ConstantWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »ConstantWidth
Declaration Syntax
C# Visual Basic Visual C++
public double ConstantWidth { get; set; }
Public Property ConstantWidth As Double
    Get
    Set
public:
property double ConstantWidth {
    double get ();
    void set (double value);
}


ConvertFrom Method (entity, transferId)

ConvertFrom Method (entity, transferId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »ConvertFrom(Entity, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void ConvertFrom(
    Entity entity,
    bool transferId
)
Public Sub ConvertFrom ( _
    entity As Entity, _
    transferId As Boolean _
)
public:
void ConvertFrom(
    Entity^ entity,
    bool transferId
)
Parameters
entity(Entity)
transferId(Boolean)


ConvertTo Method (transferId)

ConvertTo Method (transferId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »ConvertTo(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Polyline2d ConvertTo(
    bool transferId
)
Public Function ConvertTo ( _
    transferId As Boolean _
) As Polyline2d
public:
Polyline2d^ ConvertTo(
    bool transferId
)
Parameters
transferId(Boolean)


Elevation Property

Elevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Elevation
Declaration Syntax
C# Visual Basic Visual C++
public double Elevation { get; set; }
Public Property Elevation As Double
    Get
    Set
public:
property double Elevation {
    double get ();
    void set (double value);
}


GetArcSegment2dAt Method (index)

GetArcSegment2dAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetArcSegment2dAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc2d GetArcSegment2dAt(
    int index
)
Public Function GetArcSegment2dAt ( _
    index As Integer _
) As CircularArc2d
public:
CircularArc2d^ GetArcSegment2dAt(
    int index
)
Parameters
index(Int32)


GetArcSegmentAt Method (index)

GetArcSegmentAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetArcSegmentAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc3d GetArcSegmentAt(
    int index
)
Public Function GetArcSegmentAt ( _
    index As Integer _
) As CircularArc3d
public:
CircularArc3d^ GetArcSegmentAt(
    int index
)
Parameters
index(Int32)


GetBulgeAt Method (index)

GetBulgeAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetBulgeAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetBulgeAt(
    int index
)
Public Function GetBulgeAt ( _
    index As Integer _
) As Double
public:
double GetBulgeAt(
    int index
)
Parameters
index(Int32)


GetEndWidthAt Method (index)

GetEndWidthAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetEndWidthAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetEndWidthAt(
    int index
)
Public Function GetEndWidthAt ( _
    index As Integer _
) As Double
public:
double GetEndWidthAt(
    int index
)
Parameters
index(Int32)


GetLineSegment2dAt Method (index)

GetLineSegment2dAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetLineSegment2dAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment2d GetLineSegment2dAt(
    int index
)
Public Function GetLineSegment2dAt ( _
    index As Integer _
) As LineSegment2d
public:
LineSegment2d^ GetLineSegment2dAt(
    int index
)
Parameters
index(Int32)


GetLineSegmentAt Method (index)

GetLineSegmentAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetLineSegmentAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment3d GetLineSegmentAt(
    int index
)
Public Function GetLineSegmentAt ( _
    index As Integer _
) As LineSegment3d
public:
LineSegment3d^ GetLineSegmentAt(
    int index
)
Parameters
index(Int32)


GetPoint2dAt Method (index)

GetPoint2dAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetPoint2dAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetPoint2dAt(
    int index
)
Public Function GetPoint2dAt ( _
    index As Integer _
) As Point2d
public:
Point2d GetPoint2dAt(
    int index
)
Parameters
index(Int32)


GetPoint3dAt Method (index)

GetPoint3dAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetPoint3dAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetPoint3dAt(
    int index
)
Public Function GetPoint3dAt ( _
    index As Integer _
) As Point3d
public:
Point3d GetPoint3dAt(
    int index
)
Parameters
index(Int32)


GetSegmentType Method (index)

GetSegmentType Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetSegmentType(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SegmentType GetSegmentType(
    int index
)
Public Function GetSegmentType ( _
    index As Integer _
) As SegmentType
public:
SegmentType GetSegmentType(
    int index
)
Parameters
index(Int32)


GetStartWidthAt Method (index)

GetStartWidthAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetStartWidthAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetStartWidthAt(
    int index
)
Public Function GetStartWidthAt ( _
    index As Integer _
) As Double
public:
double GetStartWidthAt(
    int index
)
Parameters
index(Int32)


HasBulges Property

HasBulges Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »HasBulges
Declaration Syntax
C# Visual Basic Visual C++
public bool HasBulges { get; }
Public ReadOnly Property HasBulges As Boolean
    Get
public:
property bool HasBulges {
    bool get ();
}


HasWidth Property

HasWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »HasWidth
Declaration Syntax
C# Visual Basic Visual C++
public bool HasWidth { get; }
Public ReadOnly Property HasWidth As Boolean
    Get
public:
property bool HasWidth {
    bool get ();
}


IsOnlyLines Property

IsOnlyLines Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »IsOnlyLines
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOnlyLines { get; }
Public ReadOnly Property IsOnlyLines As Boolean
    Get
public:
property bool IsOnlyLines {
    bool get ();
}


Length Property

Length Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Length
Declaration Syntax
C# Visual Basic Visual C++
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}


MaximizeMemory Method

MaximizeMemory Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »MaximizeMemory()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MaximizeMemory()
Public Sub MaximizeMemory
public:
void MaximizeMemory()


MinimizeMemory Method

MinimizeMemory Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »MinimizeMemory()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MinimizeMemory()
Public Sub MinimizeMemory
public:
void MinimizeMemory()


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


NumberOfVertices Property

NumberOfVertices Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »NumberOfVertices
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfVertices { get; }
Public ReadOnly Property NumberOfVertices As Integer
    Get
public:
property int NumberOfVertices {
    int get ();
}


OnSegmentAt Method (index, pt2d, value)

OnSegmentAt Method (index, pt2d, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »OnSegmentAt(Int32, Point2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool OnSegmentAt(
    int index,
    Point2d pt2d,
    double value
)
Public Overridable Function OnSegmentAt ( _
    index As Integer, _
    pt2d As Point2d, _
    value As Double _
) As Boolean
public:
virtual bool OnSegmentAt(
    int index,
    Point2d pt2d,
    double value
)
Parameters
index(Int32)
pt2d(Point2d)
value(Double)


Plinegen Property

Plinegen Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Plinegen
Declaration Syntax
C# Visual Basic Visual C++
public bool Plinegen { get; set; }
Public Property Plinegen As Boolean
    Get
    Set
public:
property bool Plinegen {
    bool get ();
    void set (bool value);
}


RemoveVertexAt Method (index)

RemoveVertexAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »RemoveVertexAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveVertexAt(
    int index
)
Public Sub RemoveVertexAt ( _
    index As Integer _
)
public:
void RemoveVertexAt(
    int index
)
Parameters
index(Int32)


Reset Method (reuse, vertices)

Reset Method (reuse, vertices)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Reset(Boolean, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Reset(
    bool reuse,
    int vertices
)
Public Sub Reset ( _
    reuse As Boolean, _
    vertices As Integer _
)
public:
void Reset(
    bool reuse,
    int vertices
)
Parameters
reuse(Boolean)
vertices(Int32)


SetBulgeAt Method (index, bulge)

SetBulgeAt Method (index, bulge)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »SetBulgeAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetBulgeAt(
    int index,
    double bulge
)
Public Sub SetBulgeAt ( _
    index As Integer, _
    bulge As Double _
)
public:
void SetBulgeAt(
    int index,
    double bulge
)
Parameters
index(Int32)
bulge(Double)


SetEndWidthAt Method (index, endWidth)

SetEndWidthAt Method (index, endWidth)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »SetEndWidthAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetEndWidthAt(
    int index,
    double endWidth
)
Public Sub SetEndWidthAt ( _
    index As Integer, _
    endWidth As Double _
)
public:
void SetEndWidthAt(
    int index,
    double endWidth
)
Parameters
index(Int32)
endWidth(Double)


SetPointAt Method (index, pt)

SetPointAt Method (index, pt)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »SetPointAt(Int32, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPointAt(
    int index,
    Point2d pt
)
Public Sub SetPointAt ( _
    index As Integer, _
    pt As Point2d _
)
public:
void SetPointAt(
    int index,
    Point2d pt
)
Parameters
index(Int32)
pt(Point2d)


SetStartWidthAt Method (index, startWidth)

SetStartWidthAt Method (index, startWidth)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »SetStartWidthAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetStartWidthAt(
    int index,
    double startWidth
)
Public Sub SetStartWidthAt ( _
    index As Integer, _
    startWidth As Double _
)
public:
void SetStartWidthAt(
    int index,
    double startWidth
)
Parameters
index(Int32)
startWidth(Double)


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}


Polyline2d Class

Polyline2d Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDb2dPolyline")]
public class Polyline2d : Curve, IEnumerable
<WrapperAttribute("AcDb2dPolyline")> _
Public Class Polyline2d _
    Inherits Curve _
    Implements IEnumerable
[WrapperAttribute(L"AcDb2dPolyline")]
public ref class Polyline2d : public Curve,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Polyline2d(Poly2dType, Point3dCollection, Double, Boolean, Double, Double, DoubleCollection) |
 | Polyline2d()()()() |
 | Polyline2d(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | AppendVertex(Vertex2d) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed |
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConstantWidth |
 | ConvertToPolyType(Poly2dType) |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CurveFit()()()() |
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DefaultEndWidth |
 | DefaultStartWidth |
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation |
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEnumerator()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertVertexAt(Vertex2d, Vertex2d) |
 | InsertVertexAt(ObjectId, Vertex2d) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Length |
 | Linetype | (Inherited from Entity.)
 | LinetypeGenerationOn |
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | MakeClosed()()()() |
 | MakeOpen()()()() |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | NonDBAppendVertex(Vertex2d) |
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | PolyType |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Spline | (Inherited from Curve.)
 | SplineFit(Poly2dType, Int32) |
 | SplineFit()()()() |
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Inherited from Curve.)
 | Straighten()()()() |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VertexPosition(Vertex2d) |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Polyline2d


Polyline2d Constructor

Polyline2d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Polyline2d()()()()
Members
Icon | Member | Description
 | Polyline2d(Poly2dType, Point3dCollection, Double, Boolean, Double, Double, DoubleCollection) |
 | Polyline2d()()()() |
 | Polyline2d(IntPtr, Boolean) |


Polyline2d Constructor

Polyline2d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Polyline2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Polyline2d()
Public Sub New
public:
Polyline2d()


Polyline2d Constructor (unmanagedObjPtr, autoDelete)

Polyline2d Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Polyline2d(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Polyline2d(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Polyline2d(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Polyline2d Constructor (type, vertices, elevation, closed, startWidth, endWidth, bulges)

Polyline2d Constructor (type, vertices, elevation, closed, startWidth, endWidth, bulges)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Polyline2d(Poly2dType, Point3dCollection, Double, Boolean, Double, Double, DoubleCollection)
Declaration Syntax
C# Visual Basic Visual C++
public Polyline2d(
    Poly2dType type,
    Point3dCollection vertices,
    double elevation,
    bool closed,
    double startWidth,
    double endWidth,
    DoubleCollection bulges
)
Public Sub New ( _
    type As Poly2dType, _
    vertices As Point3dCollection, _
    elevation As Double, _
    closed As Boolean, _
    startWidth As Double, _
    endWidth As Double, _
    bulges As DoubleCollection _
)
public:
Polyline2d(
    Poly2dType type,
    Point3dCollection^ vertices,
    double elevation,
    bool closed,
    double startWidth,
    double endWidth,
    DoubleCollection^ bulges
)
Parameters
type(Poly2dType)
vertices(Point3dCollection)
elevation(Double)
closed(Boolean)
startWidth(Double)
endWidth(Double)
bulges(DoubleCollection)


AppendVertex Method (vertexToAppend)

AppendVertex Method (vertexToAppend)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »AppendVertex(Vertex2d)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AppendVertex(
    Vertex2d vertexToAppend
)
Public Function AppendVertex ( _
    vertexToAppend As Vertex2d _
) As ObjectId
public:
ObjectId AppendVertex(
    Vertex2d^ vertexToAppend
)
Parameters
vertexToAppend(Vertex2d)


Closed Property

Closed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Closed
Declaration Syntax
C# Visual Basic Visual C++
public bool Closed { get; set; }
Public Property Closed As Boolean
    Get
    Set
public:
property bool Closed {
    bool get ();
    void set (bool value);
}


ConstantWidth Property

ConstantWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »ConstantWidth
Declaration Syntax
C# Visual Basic Visual C++
public double ConstantWidth { get; set; }
Public Property ConstantWidth As Double
    Get
    Set
public:
property double ConstantWidth {
    double get ();
    void set (double value);
}


ConvertToPolyType Method (newVal)

ConvertToPolyType Method (newVal)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »ConvertToPolyType(Poly2dType)
Declaration Syntax
C# Visual Basic Visual C++
public void ConvertToPolyType(
    Poly2dType newVal
)
Public Sub ConvertToPolyType ( _
    newVal As Poly2dType _
)
public:
void ConvertToPolyType(
    Poly2dType newVal
)
Parameters
newVal(Poly2dType)


CurveFit Method

CurveFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »CurveFit()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void CurveFit()
Public Sub CurveFit
public:
void CurveFit()


DefaultEndWidth Property

DefaultEndWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »DefaultEndWidth
Declaration Syntax
C# Visual Basic Visual C++
public double DefaultEndWidth { get; set; }
Public Property DefaultEndWidth As Double
    Get
    Set
public:
property double DefaultEndWidth {
    double get ();
    void set (double value);
}


DefaultStartWidth Property

DefaultStartWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »DefaultStartWidth
Declaration Syntax
C# Visual Basic Visual C++
public double DefaultStartWidth { get; set; }
Public Property DefaultStartWidth As Double
    Get
    Set
public:
property double DefaultStartWidth {
    double get ();
    void set (double value);
}


Elevation Property

Elevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Elevation
Declaration Syntax
C# Visual Basic Visual C++
public double Elevation { get; set; }
Public Property Elevation As Double
    Get
    Set
public:
property double Elevation {
    double get ();
    void set (double value);
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()


InsertVertexAt Method

InsertVertexAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »InsertVertexAt()()()()
Members
Icon | Member | Description
 | InsertVertexAt(Vertex2d, Vertex2d) |
 | InsertVertexAt(ObjectId, Vertex2d) |


InsertVertexAt Method (vertexId, newVertex)

InsertVertexAt Method (vertexId, newVertex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »InsertVertexAt(ObjectId, Vertex2d)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId InsertVertexAt(
    ObjectId vertexId,
    Vertex2d newVertex
)
Public Function InsertVertexAt ( _
    vertexId As ObjectId, _
    newVertex As Vertex2d _
) As ObjectId
public:
ObjectId InsertVertexAt(
    ObjectId vertexId,
    Vertex2d^ newVertex
)
Parameters
vertexId(ObjectId)
newVertex(Vertex2d)


InsertVertexAt Method (indexVertex, newVertex)

InsertVertexAt Method (indexVertex, newVertex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »InsertVertexAt(Vertex2d, Vertex2d)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertVertexAt(
    Vertex2d indexVertex,
    Vertex2d newVertex
)
Public Sub InsertVertexAt ( _
    indexVertex As Vertex2d, _
    newVertex As Vertex2d _
)
public:
void InsertVertexAt(
    Vertex2d^ indexVertex,
    Vertex2d^ newVertex
)
Parameters
indexVertex(Vertex2d)
newVertex(Vertex2d)


Length Property

Length Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Length
Declaration Syntax
C# Visual Basic Visual C++
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}


LinetypeGenerationOn Property

LinetypeGenerationOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »LinetypeGenerationOn
Declaration Syntax
C# Visual Basic Visual C++
public bool LinetypeGenerationOn { get; set; }
Public Property LinetypeGenerationOn As Boolean
    Get
    Set
public:
property bool LinetypeGenerationOn {
    bool get ();
    void set (bool value);
}


MakeClosed Method

MakeClosed Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »MakeClosed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeClosed()
Public Sub MakeClosed
public:
void MakeClosed()


MakeOpen Method

MakeOpen Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »MakeOpen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeOpen()
Public Sub MakeOpen
public:
void MakeOpen()


NonDBAppendVertex Method (vertexToAppend)

NonDBAppendVertex Method (vertexToAppend)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »NonDBAppendVertex(Vertex2d)
Declaration Syntax
C# Visual Basic Visual C++
public void NonDBAppendVertex(
    Vertex2d vertexToAppend
)
Public Sub NonDBAppendVertex ( _
    vertexToAppend As Vertex2d _
)
public:
void NonDBAppendVertex(
    Vertex2d^ vertexToAppend
)
Parameters
vertexToAppend(Vertex2d)


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


PolyType Property

PolyType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »PolyType
Declaration Syntax
C# Visual Basic Visual C++
public Poly2dType PolyType { get; set; }
Public Property PolyType As Poly2dType
    Get
    Set
public:
property Poly2dType PolyType {
    Poly2dType get ();
    void set (Poly2dType value);
}


SplineFit Method

SplineFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »SplineFit()()()()
Members
Icon | Member | Description
 | SplineFit(Poly2dType, Int32) |
 | SplineFit()()()() |


SplineFit Method

SplineFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »SplineFit()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SplineFit()
Public Sub SplineFit
public:
void SplineFit()


SplineFit Method (value, segments)

SplineFit Method (value, segments)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »SplineFit(Poly2dType, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SplineFit(
    Poly2dType value,
    int segments
)
Public Sub SplineFit ( _
    value As Poly2dType, _
    segments As Integer _
)
public:
void SplineFit(
    Poly2dType value,
    int segments
)
Parameters
value(Poly2dType)
segments(Int32)


Straighten Method

Straighten Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Straighten()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Straighten()
Public Sub Straighten
public:
void Straighten()


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}


VertexPosition Method (vertex)

VertexPosition Method (vertex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »VertexPosition(Vertex2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d VertexPosition(
    Vertex2d vertex
)
Public Function VertexPosition ( _
    vertex As Vertex2d _
) As Point3d
public:
Point3d VertexPosition(
    Vertex2d^ vertex
)
Parameters
vertex(Vertex2d)


Polyline3d Class

Polyline3d Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDb3dPolyline")]
public class Polyline3d : Curve, IEnumerable
<WrapperAttribute("AcDb3dPolyline")> _
Public Class Polyline3d _
    Inherits Curve _
    Implements IEnumerable
[WrapperAttribute(L"AcDb3dPolyline")]
public ref class Polyline3d : public Curve,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Polyline3d(Poly3dType, Point3dCollection, Boolean) |
 | Polyline3d()()()() |
 | Polyline3d(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | AppendVertex(PolylineVertex3d) |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed |
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToPolyType(Poly3dType) |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEnumerator()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertVertexAt(PolylineVertex3d, PolylineVertex3d) |
 | InsertVertexAt(ObjectId, PolylineVertex3d) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Length |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | PolyType |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Spline | (Inherited from Curve.)
 | SplineFit(Poly3dType, Int32) |
 | SplineFit()()()() |
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Inherited from Curve.)
 | Straighten()()()() |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Polyline3d


Polyline3d Constructor

Polyline3d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Polyline3d()()()()
Members
Icon | Member | Description
 | Polyline3d(Poly3dType, Point3dCollection, Boolean) |
 | Polyline3d()()()() |
 | Polyline3d(IntPtr, Boolean) |


Polyline3d Constructor

Polyline3d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Polyline3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Polyline3d()
Public Sub New
public:
Polyline3d()


Polyline3d Constructor (unmanagedObjPtr, autoDelete)

Polyline3d Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Polyline3d(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Polyline3d(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Polyline3d(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Polyline3d Constructor (type, vertices, closed)

Polyline3d Constructor (type, vertices, closed)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Polyline3d(Poly3dType, Point3dCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Polyline3d(
    Poly3dType type,
    Point3dCollection vertices,
    bool closed
)
Public Sub New ( _
    type As Poly3dType, _
    vertices As Point3dCollection, _
    closed As Boolean _
)
public:
Polyline3d(
    Poly3dType type,
    Point3dCollection^ vertices,
    bool closed
)
Parameters
type(Poly3dType)
vertices(Point3dCollection)
closed(Boolean)


AppendVertex Method (vertexToAppend)

AppendVertex Method (vertexToAppend)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »AppendVertex(PolylineVertex3d)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId AppendVertex(
    PolylineVertex3d vertexToAppend
)
Public Function AppendVertex ( _
    vertexToAppend As PolylineVertex3d _
) As ObjectId
public:
ObjectId AppendVertex(
    PolylineVertex3d^ vertexToAppend
)
Parameters
vertexToAppend(PolylineVertex3d)


Closed Property

Closed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Closed
Declaration Syntax
C# Visual Basic Visual C++
public bool Closed { get; set; }
Public Property Closed As Boolean
    Get
    Set
public:
property bool Closed {
    bool get ();
    void set (bool value);
}


ConvertToPolyType Method (newVal)

ConvertToPolyType Method (newVal)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »ConvertToPolyType(Poly3dType)
Declaration Syntax
C# Visual Basic Visual C++
public void ConvertToPolyType(
    Poly3dType newVal
)
Public Sub ConvertToPolyType ( _
    newVal As Poly3dType _
)
public:
void ConvertToPolyType(
    Poly3dType newVal
)
Parameters
newVal(Poly3dType)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()


InsertVertexAt Method

InsertVertexAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »InsertVertexAt()()()()
Members
Icon | Member | Description
 | InsertVertexAt(PolylineVertex3d, PolylineVertex3d) |
 | InsertVertexAt(ObjectId, PolylineVertex3d) |


InsertVertexAt Method (indexVertexId, newVertex)

InsertVertexAt Method (indexVertexId, newVertex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »InsertVertexAt(ObjectId, PolylineVertex3d)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId InsertVertexAt(
    ObjectId indexVertexId,
    PolylineVertex3d newVertex
)
Public Function InsertVertexAt ( _
    indexVertexId As ObjectId, _
    newVertex As PolylineVertex3d _
) As ObjectId
public:
ObjectId InsertVertexAt(
    ObjectId indexVertexId,
    PolylineVertex3d^ newVertex
)
Parameters
indexVertexId(ObjectId)
newVertex(PolylineVertex3d)


InsertVertexAt Method (indexVertex, newVertex)

InsertVertexAt Method (indexVertex, newVertex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »InsertVertexAt(PolylineVertex3d, PolylineVertex3d)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertVertexAt(
    PolylineVertex3d indexVertex,
    PolylineVertex3d newVertex
)
Public Sub InsertVertexAt ( _
    indexVertex As PolylineVertex3d, _
    newVertex As PolylineVertex3d _
)
public:
void InsertVertexAt(
    PolylineVertex3d^ indexVertex,
    PolylineVertex3d^ newVertex
)
Parameters
indexVertex(PolylineVertex3d)
newVertex(PolylineVertex3d)


Length Property

Length Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Length
Declaration Syntax
C# Visual Basic Visual C++
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}


PolyType Property

PolyType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »PolyType
Declaration Syntax
C# Visual Basic Visual C++
public Poly3dType PolyType { get; set; }
Public Property PolyType As Poly3dType
    Get
    Set
public:
property Poly3dType PolyType {
    Poly3dType get ();
    void set (Poly3dType value);
}


SplineFit Method

SplineFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »SplineFit()()()()
Members
Icon | Member | Description
 | SplineFit(Poly3dType, Int32) |
 | SplineFit()()()() |


SplineFit Method

SplineFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »SplineFit()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SplineFit()
Public Sub SplineFit
public:
void SplineFit()


SplineFit Method (value, segments)

SplineFit Method (value, segments)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »SplineFit(Poly3dType, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SplineFit(
    Poly3dType value,
    int segments
)
Public Sub SplineFit ( _
    value As Poly3dType, _
    segments As Integer _
)
public:
void SplineFit(
    Poly3dType value,
    int segments
)
Parameters
value(Poly3dType)
segments(Int32)


Straighten Method

Straighten Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Straighten()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Straighten()
Public Sub Straighten
public:
void Straighten()


PolylineVertex3d Class

PolylineVertex3d Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDb3dPolylineVertex")]
public class PolylineVertex3d : Vertex
<WrapperAttribute("AcDb3dPolylineVertex")> _
Public Class PolylineVertex3d _
    Inherits Vertex
[WrapperAttribute(L"AcDb3dPolylineVertex")]
public ref class PolylineVertex3d : public Vertex
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolylineVertex3d(Point3d) |
 | PolylineVertex3d()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VertexType |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Vertex
 |  |  |  |  |  |  |  | PolylineVertex3d


PolylineVertex3d Constructor

PolylineVertex3d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »PolylineVertex3d()()()()
Members
Icon | Member | Description
 | PolylineVertex3d(Point3d) |
 | PolylineVertex3d()()()() |


PolylineVertex3d Constructor

PolylineVertex3d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »PolylineVertex3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolylineVertex3d()
Public Sub New
public:
PolylineVertex3d()


PolylineVertex3d Constructor (param)

PolylineVertex3d Constructor (param)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »PolylineVertex3d(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PolylineVertex3d(
    Point3d param
)
Public Sub New ( _
    param As Point3d _
)
public:
PolylineVertex3d(
    Point3d param
)
Parameters
param(Point3d)


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »Position
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Position { get; set; }
Public Property Position As Point3d
    Get
    Set
public:
property Point3d Position {
    Point3d get ();
    void set (Point3d value);
}


VertexType Property

VertexType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »VertexType
Declaration Syntax
C# Visual Basic Visual C++
public Vertex3dType VertexType { get; }
Public ReadOnly Property VertexType As Vertex3dType
    Get
public:
property Vertex3dType VertexType {
    Vertex3dType get ();
}


PolyMeshType Enumeration

PolyMeshType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyMeshType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::PolyMeshType")]
public enum PolyMeshType
<WrapperAttribute("ZcDb::PolyMeshType")> _
Public Enumeration PolyMeshType
[WrapperAttribute(L"ZcDb::PolyMeshType")]
public enum class PolyMeshType
Members
Member | Description
SimpleMesh |
QuadSurfaceMesh |
CubicSurfaceMesh |
BezierSurfaceMesh |


ProxyEntity Class

ProxyEntity Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbProxyEntity")]
public sealed class ProxyEntity : Entity
<WrapperAttribute("AcDbProxyEntity")> _
Public NotInheritable Class ProxyEntity _
    Inherits Entity
[WrapperAttribute(L"AcDbProxyEntity")]
public ref class ProxyEntity sealed : public Entity
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplicationDescription |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetReferences()()()() |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | GraphicsMetafileType |
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OriginalClassName |
 | OriginalDxfName |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | ProxyFlags |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | ProxyEntity


ApplicationDescription Property

ApplicationDescription Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »ApplicationDescription
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationDescription { get; }
Public ReadOnly Property ApplicationDescription As String
    Get
public:
property String^ ApplicationDescription {
    String^ get ();
}


GetReferences Method

GetReferences Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »GetReferences()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DBObjectReferenceCollection GetReferences()
Public Function GetReferences As DBObjectReferenceCollection
public:
DBObjectReferenceCollection^ GetReferences()


GraphicsMetafileType Property

GraphicsMetafileType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »GraphicsMetafileType
Declaration Syntax
C# Visual Basic Visual C++
public GraphicsMetafileType GraphicsMetafileType { get; }
Public ReadOnly Property GraphicsMetafileType As GraphicsMetafileType
    Get
public:
property GraphicsMetafileType GraphicsMetafileType {
    GraphicsMetafileType get ();
}


OriginalClassName Property

OriginalClassName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »OriginalClassName
Declaration Syntax
C# Visual Basic Visual C++
public string OriginalClassName { get; }
Public ReadOnly Property OriginalClassName As String
    Get
public:
property String^ OriginalClassName {
    String^ get ();
}


OriginalDxfName Property

OriginalDxfName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »OriginalDxfName
Declaration Syntax
C# Visual Basic Visual C++
public string OriginalDxfName { get; }
Public ReadOnly Property OriginalDxfName As String
    Get
public:
property String^ OriginalDxfName {
    String^ get ();
}


ProxyFlags Property

ProxyFlags Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »ProxyFlags
Declaration Syntax
C# Visual Basic Visual C++
public int ProxyFlags { get; }
Public ReadOnly Property ProxyFlags As Integer
    Get
public:
property int ProxyFlags {
    int get ();
}


ProxyObject Class

ProxyObject Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbProxyObject")]
public class ProxyObject : DBObject
<WrapperAttribute("AcDbProxyObject")> _
Public Class ProxyObject _
    Inherits DBObject
[WrapperAttribute(L"AcDbProxyObject")]
public ref class ProxyObject : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProxyObject(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplicationDescription |
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetReferences()()()() |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OriginalClassName |
 | OriginalDxfName |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | ProxyFlags |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ResurrectMeNow(ObjectId) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | ProxyObject


ProxyObject Constructor (unmanagedPointer, autoDelete)

ProxyObject Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »ProxyObject(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal ProxyObject(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
ProxyObject(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ApplicationDescription Property

ApplicationDescription Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »ApplicationDescription
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationDescription { get; }
Public ReadOnly Property ApplicationDescription As String
    Get
public:
property String^ ApplicationDescription {
    String^ get ();
}


GetReferences Method

GetReferences Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »GetReferences()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DBObjectReferenceCollection GetReferences()
Public Function GetReferences As DBObjectReferenceCollection
public:
DBObjectReferenceCollection^ GetReferences()


OriginalClassName Property

OriginalClassName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »OriginalClassName
Declaration Syntax
C# Visual Basic Visual C++
public string OriginalClassName { get; }
Public ReadOnly Property OriginalClassName As String
    Get
public:
property String^ OriginalClassName {
    String^ get ();
}


OriginalDxfName Property

OriginalDxfName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »OriginalDxfName
Declaration Syntax
C# Visual Basic Visual C++
public string OriginalDxfName { get; }
Public ReadOnly Property OriginalDxfName As String
    Get
public:
property String^ OriginalDxfName {
    String^ get ();
}


ProxyFlags Property

ProxyFlags Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »ProxyFlags
Declaration Syntax
C# Visual Basic Visual C++
public int ProxyFlags { get; }
Public ReadOnly Property ProxyFlags As Integer
    Get
public:
property int ProxyFlags {
    int get ();
}


ResurrectMeNow Method (id)

ResurrectMeNow Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »ResurrectMeNow(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public static void ResurrectMeNow(
    ObjectId id
)
Public Shared Sub ResurrectMeNow ( _
    id As ObjectId _
)
public:
static void ResurrectMeNow(
    ObjectId id
)
Parameters
id(ObjectId)


ProxyResurrectionCompletedEventArgs Class

ProxyResurrectionCompletedEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyResurrectionCompletedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ProxyResurrectionCompletedEventArgs : EventArgs
Public NotInheritable Class ProxyResurrectionCompletedEventArgs _
    Inherits EventArgs
public ref class ProxyResurrectionCompletedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ApplicationName |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Ids |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ProxyResurrectionCompletedEventArgs


ApplicationName Property

ApplicationName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyResurrectionCompletedEventArgs »ApplicationName
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationName { get; }
Public ReadOnly Property ApplicationName As String
    Get
public:
property String^ ApplicationName {
    String^ get ();
}


Ids Property

Ids Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyResurrectionCompletedEventArgs »Ids
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection Ids { get; }
Public ReadOnly Property Ids As ObjectIdCollection
    Get
public:
property ObjectIdCollection^ Ids {
    ObjectIdCollection^ get ();
}


ProxyResurrectionCompletedEventHandler Delegate

ProxyResurrectionCompletedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyResurrectionCompletedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ProxyResurrectionCompletedEventHandler(
    Object sender,
    ProxyResurrectionCompletedEventArgs e
)
Public Delegate Sub ProxyResurrectionCompletedEventHandler ( _
    sender As Object, _
    e As ProxyResurrectionCompletedEventArgs _
)
public delegate void ProxyResurrectionCompletedEventHandler(
    Object^ sender,
    ProxyResurrectionCompletedEventArgs^ e
)
Parameters
sender(Object)
e(ProxyResurrectionCompletedEventArgs)


RadialDimension Class

RadialDimension Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbRadialDimension")]
public class RadialDimension : Dimension
<WrapperAttribute("AcDbRadialDimension")> _
Public Class RadialDimension _
    Inherits Dimension
[WrapperAttribute(L"AcDbRadialDimension")]
public ref class RadialDimension : public Dimension
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RadialDimension(Point3d, Point3d, Double, String, ObjectId) |
 | RadialDimension(IntPtr, Boolean) |
 | RadialDimension()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlternatePrefix | (Inherited from Dimension.)
 | AlternateSuffix | (Inherited from Dimension.)
 | AltSuppressLeadingZeros | (Inherited from Dimension.)
 | AltSuppressTrailingZeros | (Inherited from Dimension.)
 | AltSuppressZeroFeet | (Inherited from Dimension.)
 | AltSuppressZeroInches | (Inherited from Dimension.)
 | AltToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | AltToleranceSuppressZeroInches | (Inherited from Dimension.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | Center |
 | CenterMarkSize | (Inherited from Dimension.)
 | CenterMarkType | (Inherited from Dimension.)
 | ChordPoint |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec | (Inherited from Dimension.)
 | Dimalt | (Inherited from Dimension.)
 | Dimaltd | (Inherited from Dimension.)
 | Dimaltf | (Inherited from Dimension.)
 | Dimaltrnd | (Inherited from Dimension.)
 | Dimalttd | (Inherited from Dimension.)
 | Dimalttz | (Inherited from Dimension.)
 | Dimaltu | (Inherited from Dimension.)
 | Dimaltz | (Inherited from Dimension.)
 | Dimapost | (Inherited from Dimension.)
 | Dimarcsym | (Inherited from Dimension.)
 | Dimasz | (Inherited from Dimension.)
 | Dimatfit | (Inherited from Dimension.)
 | Dimaunit | (Inherited from Dimension.)
 | Dimazin | (Inherited from Dimension.)
 | Dimblk | (Inherited from Dimension.)
 | Dimblk1 | (Inherited from Dimension.)
 | Dimblk1s | (Inherited from Dimension.)
 | Dimblk2 | (Inherited from Dimension.)
 | Dimblk2s | (Inherited from Dimension.)
 | Dimblks | (Inherited from Dimension.)
 | DimBlockId | (Inherited from Dimension.)
 | DimBlockPosition | (Inherited from Dimension.)
 | Dimcen | (Inherited from Dimension.)
 | Dimclrd | (Inherited from Dimension.)
 | Dimclre | (Inherited from Dimension.)
 | Dimclrt | (Inherited from Dimension.)
 | Dimdec | (Inherited from Dimension.)
 | Dimdle | (Inherited from Dimension.)
 | Dimdli | (Inherited from Dimension.)
 | Dimdsep | (Inherited from Dimension.)
 | DimensionStyle | (Inherited from Dimension.)
 | DimensionStyleName | (Inherited from Dimension.)
 | DimensionText | (Inherited from Dimension.)
 | Dimexe | (Inherited from Dimension.)
 | Dimexo | (Inherited from Dimension.)
 | Dimfrac | (Inherited from Dimension.)
 | Dimfxlen | (Inherited from Dimension.)
 | DimfxlenOn | (Inherited from Dimension.)
 | Dimgap | (Inherited from Dimension.)
 | Dimjogang | (Inherited from Dimension.)
 | Dimjust | (Inherited from Dimension.)
 | Dimldrblk | (Inherited from Dimension.)
 | Dimldrblks | (Inherited from Dimension.)
 | Dimlfac | (Inherited from Dimension.)
 | Dimlim | (Inherited from Dimension.)
 | Dimltex1 | (Inherited from Dimension.)
 | Dimltex2 | (Inherited from Dimension.)
 | Dimltype | (Inherited from Dimension.)
 | Dimlunit | (Inherited from Dimension.)
 | Dimlwd | (Inherited from Dimension.)
 | Dimlwe | (Inherited from Dimension.)
 | Dimpost | (Inherited from Dimension.)
 | Dimrnd | (Inherited from Dimension.)
 | Dimsah | (Inherited from Dimension.)
 | Dimscale | (Inherited from Dimension.)
 | Dimsd1 | (Inherited from Dimension.)
 | Dimsd2 | (Inherited from Dimension.)
 | Dimse1 | (Inherited from Dimension.)
 | Dimse2 | (Inherited from Dimension.)
 | Dimsoxd | (Inherited from Dimension.)
 | DimstyleData | (Inherited from Dimension.)
 | Dimtad | (Inherited from Dimension.)
 | Dimtdec | (Inherited from Dimension.)
 | Dimtfac | (Inherited from Dimension.)
 | Dimtfill | (Inherited from Dimension.)
 | Dimtfillclr | (Inherited from Dimension.)
 | Dimtih | (Inherited from Dimension.)
 | Dimtix | (Inherited from Dimension.)
 | Dimtm | (Inherited from Dimension.)
 | Dimtmove | (Inherited from Dimension.)
 | Dimtofl | (Inherited from Dimension.)
 | Dimtoh | (Inherited from Dimension.)
 | Dimtol | (Inherited from Dimension.)
 | Dimtolj | (Inherited from Dimension.)
 | Dimtp | (Inherited from Dimension.)
 | Dimtsz | (Inherited from Dimension.)
 | Dimtvp | (Inherited from Dimension.)
 | Dimtxsty | (Inherited from Dimension.)
 | Dimtxt | (Inherited from Dimension.)
 | Dimtzin | (Inherited from Dimension.)
 | Dimupt | (Inherited from Dimension.)
 | Dimzin | (Inherited from Dimension.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicDimension | (Inherited from Dimension.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation | (Inherited from Dimension.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldFromMText(MText) | (Inherited from Dimension.)
 | FieldToMText(MText) | (Inherited from Dimension.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FormatMeasurement(Double, String) | (Inherited from Dimension.)
 | GenerateLayout()()()() | (Inherited from Dimension.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetDimstyleData()()()() | (Inherited from Dimension.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalRotation | (Inherited from Dimension.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | LeaderLength |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | Measurement | (Inherited from Dimension.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal | (Inherited from Dimension.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Prefix | (Inherited from Dimension.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeDimensionBlock(Boolean) | (Inherited from Dimension.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveTextField()()()() | (Inherited from Dimension.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) | (Inherited from Dimension.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | Suffix | (Inherited from Dimension.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressAngularLeadingZeros | (Inherited from Dimension.)
 | SuppressAngularTrailingZeros | (Inherited from Dimension.)
 | SuppressLeadingZeros | (Inherited from Dimension.)
 | SuppressTrailingZeros | (Inherited from Dimension.)
 | SuppressZeroFeet | (Inherited from Dimension.)
 | SuppressZeroInches | (Inherited from Dimension.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAttachment | (Inherited from Dimension.)
 | TextLineSpacingFactor | (Inherited from Dimension.)
 | TextLineSpacingStyle | (Inherited from Dimension.)
 | TextPosition | (Inherited from Dimension.)
 | TextRotation | (Inherited from Dimension.)
 | TextStyleId | (Inherited from Dimension.)
 | ToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | ToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | ToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | ToleranceSuppressZeroInches | (Inherited from Dimension.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UsingDefaultTextPosition | (Inherited from Dimension.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  |  | RadialDimension


RadialDimension Constructor

RadialDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »RadialDimension()()()()
Members
Icon | Member | Description
 | RadialDimension(Point3d, Point3d, Double, String, ObjectId) |
 | RadialDimension(IntPtr, Boolean) |
 | RadialDimension()()()() |


RadialDimension Constructor

RadialDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »RadialDimension()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RadialDimension()
Public Sub New
public:
RadialDimension()


RadialDimension Constructor (unmanagedObjPtr, autoDelete)

RadialDimension Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »RadialDimension(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal RadialDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
RadialDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


RadialDimension Constructor (center, chordPoint, leaderLength, dimensionText, dimensionStyle)

RadialDimension Constructor (center, chordPoint, leaderLength, dimensionText, dimensionStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »RadialDimension(Point3d, Point3d, Double, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public RadialDimension(
    Point3d center,
    Point3d chordPoint,
    double leaderLength,
    string dimensionText,
    ObjectId dimensionStyle
)
Public Sub New ( _
    center As Point3d, _
    chordPoint As Point3d, _
    leaderLength As Double, _
    dimensionText As String, _
    dimensionStyle As ObjectId _
)
public:
RadialDimension(
    Point3d center,
    Point3d chordPoint,
    double leaderLength,
    String^ dimensionText,
    ObjectId dimensionStyle
)
Parameters
center(Point3d)
chordPoint(Point3d)
leaderLength(Double)
dimensionText(String)
dimensionStyle(ObjectId)


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Center { get; set; }
Public Property Center As Point3d
    Get
    Set
public:
property Point3d Center {
    Point3d get ();
    void set (Point3d value);
}


ChordPoint Property

ChordPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »ChordPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ChordPoint { get; set; }
Public Property ChordPoint As Point3d
    Get
    Set
public:
property Point3d ChordPoint {
    Point3d get ();
    void set (Point3d value);
}


LeaderLength Property

LeaderLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »LeaderLength
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double LeaderLength { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property LeaderLength As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double LeaderLength {
    double get ();
    void set (double value);
}


RadialDimensionLarge Class

RadialDimensionLarge Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbRadialDimensionLarge")]
public class RadialDimensionLarge : Dimension
<WrapperAttribute("AcDbRadialDimensionLarge")> _
Public Class RadialDimensionLarge _
    Inherits Dimension
[WrapperAttribute(L"AcDbRadialDimensionLarge")]
public ref class RadialDimensionLarge : public Dimension
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RadialDimensionLarge(Point3d, Point3d, Point3d, Point3d, Double, String, ObjectId) |
 | RadialDimensionLarge(IntPtr, Boolean) |
 | RadialDimensionLarge()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlternatePrefix | (Inherited from Dimension.)
 | AlternateSuffix | (Inherited from Dimension.)
 | AltSuppressLeadingZeros | (Inherited from Dimension.)
 | AltSuppressTrailingZeros | (Inherited from Dimension.)
 | AltSuppressZeroFeet | (Inherited from Dimension.)
 | AltSuppressZeroInches | (Inherited from Dimension.)
 | AltToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | AltToleranceSuppressZeroInches | (Inherited from Dimension.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | Center |
 | CenterMarkSize | (Inherited from Dimension.)
 | CenterMarkType | (Inherited from Dimension.)
 | ChordPoint |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec | (Inherited from Dimension.)
 | Dimalt | (Inherited from Dimension.)
 | Dimaltd | (Inherited from Dimension.)
 | Dimaltf | (Inherited from Dimension.)
 | Dimaltrnd | (Inherited from Dimension.)
 | Dimalttd | (Inherited from Dimension.)
 | Dimalttz | (Inherited from Dimension.)
 | Dimaltu | (Inherited from Dimension.)
 | Dimaltz | (Inherited from Dimension.)
 | Dimapost | (Inherited from Dimension.)
 | Dimarcsym | (Inherited from Dimension.)
 | Dimasz | (Inherited from Dimension.)
 | Dimatfit | (Inherited from Dimension.)
 | Dimaunit | (Inherited from Dimension.)
 | Dimazin | (Inherited from Dimension.)
 | Dimblk | (Inherited from Dimension.)
 | Dimblk1 | (Inherited from Dimension.)
 | Dimblk1s | (Inherited from Dimension.)
 | Dimblk2 | (Inherited from Dimension.)
 | Dimblk2s | (Inherited from Dimension.)
 | Dimblks | (Inherited from Dimension.)
 | DimBlockId | (Inherited from Dimension.)
 | DimBlockPosition | (Inherited from Dimension.)
 | Dimcen | (Inherited from Dimension.)
 | Dimclrd | (Inherited from Dimension.)
 | Dimclre | (Inherited from Dimension.)
 | Dimclrt | (Inherited from Dimension.)
 | Dimdec | (Inherited from Dimension.)
 | Dimdle | (Inherited from Dimension.)
 | Dimdli | (Inherited from Dimension.)
 | Dimdsep | (Inherited from Dimension.)
 | DimensionStyle | (Inherited from Dimension.)
 | DimensionStyleName | (Inherited from Dimension.)
 | DimensionText | (Inherited from Dimension.)
 | Dimexe | (Inherited from Dimension.)
 | Dimexo | (Inherited from Dimension.)
 | Dimfrac | (Inherited from Dimension.)
 | Dimfxlen | (Inherited from Dimension.)
 | DimfxlenOn | (Inherited from Dimension.)
 | Dimgap | (Inherited from Dimension.)
 | Dimjogang | (Inherited from Dimension.)
 | Dimjust | (Inherited from Dimension.)
 | Dimldrblk | (Inherited from Dimension.)
 | Dimldrblks | (Inherited from Dimension.)
 | Dimlfac | (Inherited from Dimension.)
 | Dimlim | (Inherited from Dimension.)
 | Dimltex1 | (Inherited from Dimension.)
 | Dimltex2 | (Inherited from Dimension.)
 | Dimltype | (Inherited from Dimension.)
 | Dimlunit | (Inherited from Dimension.)
 | Dimlwd | (Inherited from Dimension.)
 | Dimlwe | (Inherited from Dimension.)
 | Dimpost | (Inherited from Dimension.)
 | Dimrnd | (Inherited from Dimension.)
 | Dimsah | (Inherited from Dimension.)
 | Dimscale | (Inherited from Dimension.)
 | Dimsd1 | (Inherited from Dimension.)
 | Dimsd2 | (Inherited from Dimension.)
 | Dimse1 | (Inherited from Dimension.)
 | Dimse2 | (Inherited from Dimension.)
 | Dimsoxd | (Inherited from Dimension.)
 | DimstyleData | (Inherited from Dimension.)
 | Dimtad | (Inherited from Dimension.)
 | Dimtdec | (Inherited from Dimension.)
 | Dimtfac | (Inherited from Dimension.)
 | Dimtfill | (Inherited from Dimension.)
 | Dimtfillclr | (Inherited from Dimension.)
 | Dimtih | (Inherited from Dimension.)
 | Dimtix | (Inherited from Dimension.)
 | Dimtm | (Inherited from Dimension.)
 | Dimtmove | (Inherited from Dimension.)
 | Dimtofl | (Inherited from Dimension.)
 | Dimtoh | (Inherited from Dimension.)
 | Dimtol | (Inherited from Dimension.)
 | Dimtolj | (Inherited from Dimension.)
 | Dimtp | (Inherited from Dimension.)
 | Dimtsz | (Inherited from Dimension.)
 | Dimtvp | (Inherited from Dimension.)
 | Dimtxsty | (Inherited from Dimension.)
 | Dimtxt | (Inherited from Dimension.)
 | Dimtzin | (Inherited from Dimension.)
 | Dimupt | (Inherited from Dimension.)
 | Dimzin | (Inherited from Dimension.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicDimension | (Inherited from Dimension.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation | (Inherited from Dimension.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldFromMText(MText) | (Inherited from Dimension.)
 | FieldToMText(MText) | (Inherited from Dimension.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FormatMeasurement(Double, String) | (Inherited from Dimension.)
 | GenerateLayout()()()() | (Inherited from Dimension.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetDimstyleData()()()() | (Inherited from Dimension.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalRotation | (Inherited from Dimension.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | JogAngle |
 | JogPoint |
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | Measurement | (Inherited from Dimension.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal | (Inherited from Dimension.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OverrideCenter |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Prefix | (Inherited from Dimension.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeDimensionBlock(Boolean) | (Inherited from Dimension.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveTextField()()()() | (Inherited from Dimension.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) | (Inherited from Dimension.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | Suffix | (Inherited from Dimension.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressAngularLeadingZeros | (Inherited from Dimension.)
 | SuppressAngularTrailingZeros | (Inherited from Dimension.)
 | SuppressLeadingZeros | (Inherited from Dimension.)
 | SuppressTrailingZeros | (Inherited from Dimension.)
 | SuppressZeroFeet | (Inherited from Dimension.)
 | SuppressZeroInches | (Inherited from Dimension.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAttachment | (Inherited from Dimension.)
 | TextLineSpacingFactor | (Inherited from Dimension.)
 | TextLineSpacingStyle | (Inherited from Dimension.)
 | TextPosition | (Inherited from Dimension.)
 | TextRotation | (Inherited from Dimension.)
 | TextStyleId | (Inherited from Dimension.)
 | ToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | ToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | ToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | ToleranceSuppressZeroInches | (Inherited from Dimension.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UsingDefaultTextPosition | (Inherited from Dimension.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  |  | RadialDimensionLarge


RadialDimensionLarge Constructor

RadialDimensionLarge Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »RadialDimensionLarge()()()()
Members
Icon | Member | Description
 | RadialDimensionLarge(Point3d, Point3d, Point3d, Point3d, Double, String, ObjectId) |
 | RadialDimensionLarge(IntPtr, Boolean) |
 | RadialDimensionLarge()()()() |


RadialDimensionLarge Constructor

RadialDimensionLarge Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »RadialDimensionLarge()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RadialDimensionLarge()
Public Sub New
public:
RadialDimensionLarge()


RadialDimensionLarge Constructor (unmanagedObjPtr, autoDelete)

RadialDimensionLarge Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »RadialDimensionLarge(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal RadialDimensionLarge(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
RadialDimensionLarge(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


RadialDimensionLarge Constructor (center, chordPoint, overrideCenter, jogPoint, jogAngle, dimensionText, dimensionStyle)

RadialDimensionLarge Constructor (center, chordPoint, overrideCenter, jogPoint, jogAngle, dimensionText, dimensionStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »RadialDimensionLarge(Point3d, Point3d, Point3d, Point3d, Double, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public RadialDimensionLarge(
    Point3d center,
    Point3d chordPoint,
    Point3d overrideCenter,
    Point3d jogPoint,
    double jogAngle,
    string dimensionText,
    ObjectId dimensionStyle
)
Public Sub New ( _
    center As Point3d, _
    chordPoint As Point3d, _
    overrideCenter As Point3d, _
    jogPoint As Point3d, _
    jogAngle As Double, _
    dimensionText As String, _
    dimensionStyle As ObjectId _
)
public:
RadialDimensionLarge(
    Point3d center,
    Point3d chordPoint,
    Point3d overrideCenter,
    Point3d jogPoint,
    double jogAngle,
    String^ dimensionText,
    ObjectId dimensionStyle
)
Parameters
center(Point3d)
chordPoint(Point3d)
overrideCenter(Point3d)
jogPoint(Point3d)
jogAngle(Double)
dimensionText(String)
dimensionStyle(ObjectId)


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Center { get; set; }
Public Property Center As Point3d
    Get
    Set
public:
property Point3d Center {
    Point3d get ();
    void set (Point3d value);
}


ChordPoint Property

ChordPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »ChordPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ChordPoint { get; set; }
Public Property ChordPoint As Point3d
    Get
    Set
public:
property Point3d ChordPoint {
    Point3d get ();
    void set (Point3d value);
}


JogAngle Property

JogAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »JogAngle
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.AngleNotTransformed)]
public double JogAngle { get; set; }
<UnitTypeAttribute(UnitType.AngleNotTransformed)> _
Public Property JogAngle As Double
    Get
    Set
[UnitTypeAttribute(UnitType::AngleNotTransformed)]
public:
property double JogAngle {
    double get ();
    void set (double value);
}


JogPoint Property

JogPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »JogPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d JogPoint { get; set; }
Public Property JogPoint As Point3d
    Get
    Set
public:
property Point3d JogPoint {
    Point3d get ();
    void set (Point3d value);
}


OverrideCenter Property

OverrideCenter Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »OverrideCenter
Declaration Syntax
C# Visual Basic Visual C++
public Point3d OverrideCenter { get; set; }
Public Property OverrideCenter As Point3d
    Get
    Set
public:
property Point3d OverrideCenter {
    Point3d get ();
    void set (Point3d value);
}


RasterImage Class

RasterImage Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbRasterImage")]
public class RasterImage : Image
<WrapperAttribute("AcDbRasterImage")> _
Public Class RasterImage _
    Inherits Image
[WrapperAttribute(L"AcDbRasterImage")]
public ref class RasterImage : public Image
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RasterImage()()()() |
 | RasterImage(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | AssociateRasterDef(RasterImageDef) |
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Brightness |
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | ClipBoundaryType |
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Contrast |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | DisplayOptions |
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EnableReactors(Boolean) |
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Fade |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClipBoundary()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetVertices()()()() |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height |
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | ImageDefId |
 | ImageHeight |
 | ImageSize(Boolean) |
 | ImageTransparency |
 | ImageWidth |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsClipped |
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsSetDisplayOptions(ImageDisplayOptions) |
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Name |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | Orientation |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | Path |
 | PixelToModelTransform |
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ReactorId |
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | Scale |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetClipBoundary(ClipBoundaryType, Point2dCollection) |
 | SetClipBoundary(Vector2d) |
 | SetClipBoundaryToWholeImage()()()() |
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDisplayOptions(ImageDisplayOptions, Boolean) |
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | ShowImage |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Image
 |  |  |  |  |  |  |  | RasterImage
 |  |  |  |  |  |  |  |  | Wipeout


RasterImage Constructor

RasterImage Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »RasterImage()()()()
Members
Icon | Member | Description
 | RasterImage()()()() |
 | RasterImage(IntPtr, Boolean) |


RasterImage Constructor

RasterImage Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »RasterImage()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RasterImage()
Public Sub New
public:
RasterImage()


RasterImage Constructor (unmanagedObjPtr, autoDelete)

RasterImage Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »RasterImage(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal RasterImage(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
RasterImage(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


AssociateRasterDef Method (definition)

AssociateRasterDef Method (definition)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »AssociateRasterDef(RasterImageDef)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AssociateRasterDef(
    RasterImageDef definition
)
Public Overridable Sub AssociateRasterDef ( _
    definition As RasterImageDef _
)
public:
virtual void AssociateRasterDef(
    RasterImageDef^ definition
)
Parameters
definition(RasterImageDef)


Brightness Property

Brightness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Brightness
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte Brightness { get; set; }
Public Overridable Property Brightness As Byte
    Get
    Set
public:
virtual property unsigned char Brightness {
    unsigned char get ();
    void set (unsigned char value);
}


ClipBoundaryType Property

ClipBoundaryType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »ClipBoundaryType
Declaration Syntax
C# Visual Basic Visual C++
public virtual ClipBoundaryType ClipBoundaryType { get; }
Public Overridable ReadOnly Property ClipBoundaryType As ClipBoundaryType
    Get
public:
virtual property ClipBoundaryType ClipBoundaryType {
    ClipBoundaryType get ();
}


Contrast Property

Contrast Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Contrast
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte Contrast { get; set; }
Public Overridable Property Contrast As Byte
    Get
    Set
public:
virtual property unsigned char Contrast {
    unsigned char get ();
    void set (unsigned char value);
}


DisplayOptions Property

DisplayOptions Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »DisplayOptions
Declaration Syntax
C# Visual Basic Visual C++
public virtual ImageDisplayOptions DisplayOptions { get; set; }
Public Overridable Property DisplayOptions As ImageDisplayOptions
    Get
    Set
public:
virtual property ImageDisplayOptions DisplayOptions {
    ImageDisplayOptions get ();
    void set (ImageDisplayOptions value);
}


EnableReactors Method (enable)

EnableReactors Method (enable)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »EnableReactors(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static void EnableReactors(
    bool enable
)
Public Shared Sub EnableReactors ( _
    enable As Boolean _
)
public:
static void EnableReactors(
    bool enable
)
Parameters
enable(Boolean)


Fade Property

Fade Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Fade
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte Fade { get; set; }
Public Overridable Property Fade As Byte
    Get
    Set
public:
virtual property unsigned char Fade {
    unsigned char get ();
    void set (unsigned char value);
}


GetClipBoundary Method

GetClipBoundary Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »GetClipBoundary()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point2dCollection GetClipBoundary()
Public Overridable Function GetClipBoundary As Point2dCollection
public:
virtual Point2dCollection^ GetClipBoundary()


GetVertices Method

GetVertices Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »GetVertices()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3dCollection GetVertices()
Public Overridable Function GetVertices As Point3dCollection
public:
virtual Point3dCollection^ GetVertices()


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Height
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Height { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property Height As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Height {
    double get ();
}


ImageDefId Property

ImageDefId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »ImageDefId
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId ImageDefId { get; set; }
Public Overridable Property ImageDefId As ObjectId
    Get
    Set
public:
virtual property ObjectId ImageDefId {
    ObjectId get ();
    void set (ObjectId value);
}


ImageHeight Property

ImageHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »ImageHeight
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double ImageHeight { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property ImageHeight As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double ImageHeight {
    double get ();
}


ImageSize Method (getCachedValue)

ImageSize Method (getCachedValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »ImageSize(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector2d ImageSize(
    bool getCachedValue
)
Public Overridable Function ImageSize ( _
    getCachedValue As Boolean _
) As Vector2d
public:
virtual Vector2d ImageSize(
    bool getCachedValue
)
Parameters
getCachedValue(Boolean)


ImageTransparency Property

ImageTransparency Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »ImageTransparency
Declaration Syntax
C# Visual Basic Visual C++
public bool ImageTransparency { get; set; }
Public Property ImageTransparency As Boolean
    Get
    Set
public:
property bool ImageTransparency {
    bool get ();
    void set (bool value);
}


ImageWidth Property

ImageWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »ImageWidth
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double ImageWidth { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property ImageWidth As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double ImageWidth {
    double get ();
}


IsClipped Property

IsClipped Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »IsClipped
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsClipped { get; set; }
Public Overridable Property IsClipped As Boolean
    Get
    Set
public:
virtual property bool IsClipped {
    bool get ();
    void set (bool value);
}


IsSetDisplayOptions Method (value)

IsSetDisplayOptions Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »IsSetDisplayOptions(ImageDisplayOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSetDisplayOptions(
    ImageDisplayOptions value
)
Public Overridable Function IsSetDisplayOptions ( _
    value As ImageDisplayOptions _
) As Boolean
public:
virtual bool IsSetDisplayOptions(
    ImageDisplayOptions value
)
Parameters
value(ImageDisplayOptions)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Orientation Property

Orientation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Orientation
Declaration Syntax
C# Visual Basic Visual C++
public virtual CoordinateSystem3d Orientation { get; set; }
Public Overridable Property Orientation As CoordinateSystem3d
    Get
    Set
public:
virtual property CoordinateSystem3d Orientation {
    CoordinateSystem3d get ();
    void set (CoordinateSystem3d value);
}


Path Property

Path Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Path
Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}


PixelToModelTransform Property

PixelToModelTransform Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »PixelToModelTransform
Declaration Syntax
C# Visual Basic Visual C++
public virtual Matrix3d PixelToModelTransform { get; }
Public Overridable ReadOnly Property PixelToModelTransform As Matrix3d
    Get
public:
virtual property Matrix3d PixelToModelTransform {
    Matrix3d get ();
}


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Position
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Position { get; }
Public ReadOnly Property Position As Point3d
    Get
public:
property Point3d Position {
    Point3d get ();
}


ReactorId Property

ReactorId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »ReactorId
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId ReactorId { get; set; }
Public Overridable Property ReactorId As ObjectId
    Get
    Set
public:
virtual property ObjectId ReactorId {
    ObjectId get ();
    void set (ObjectId value);
}


Rotation Property

Rotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Rotation
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Angle)]
public double Rotation { get; set; }
<UnitTypeAttribute(UnitType.Angle)> _
Public Property Rotation As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Angle)]
public:
property double Rotation {
    double get ();
    void set (double value);
}


Scale Property

Scale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Scale
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector2d Scale { get; }
Public Overridable ReadOnly Property Scale As Vector2d
    Get
public:
virtual property Vector2d Scale {
    Vector2d get ();
}


SetClipBoundary Method

SetClipBoundary Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »SetClipBoundary()()()()
Members
Icon | Member | Description
 | SetClipBoundary(ClipBoundaryType, Point2dCollection) |
 | SetClipBoundary(Vector2d) |


SetClipBoundary Method (type, clipBoundaryVertices)

SetClipBoundary Method (type, clipBoundaryVertices)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »SetClipBoundary(ClipBoundaryType, Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetClipBoundary(
    ClipBoundaryType type,
    Point2dCollection clipBoundaryVertices
)
Public Overridable Sub SetClipBoundary ( _
    type As ClipBoundaryType, _
    clipBoundaryVertices As Point2dCollection _
)
public:
virtual void SetClipBoundary(
    ClipBoundaryType type,
    Point2dCollection^ clipBoundaryVertices
)
Parameters
type(ClipBoundaryType)
clipBoundaryVertices(Point2dCollection)


SetClipBoundary Method (size)

SetClipBoundary Method (size)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »SetClipBoundary(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetClipBoundary(
    Vector2d size
)
Public Overridable Sub SetClipBoundary ( _
    size As Vector2d _
)
public:
virtual void SetClipBoundary(
    Vector2d size
)
Parameters
size(Vector2d)


SetClipBoundaryToWholeImage Method

SetClipBoundaryToWholeImage Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »SetClipBoundaryToWholeImage()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetClipBoundaryToWholeImage()
Public Overridable Sub SetClipBoundaryToWholeImage
public:
virtual void SetClipBoundaryToWholeImage()


SetDisplayOptions Method (display, value)

SetDisplayOptions Method (display, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »SetDisplayOptions(ImageDisplayOptions, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDisplayOptions(
    ImageDisplayOptions display,
    bool value
)
Public Overridable Sub SetDisplayOptions ( _
    display As ImageDisplayOptions, _
    value As Boolean _
)
public:
virtual void SetDisplayOptions(
    ImageDisplayOptions display,
    bool value
)
Parameters
display(ImageDisplayOptions)
value(Boolean)


ShowImage Property

ShowImage Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »ShowImage
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowImage { get; set; }
Public Property ShowImage As Boolean
    Get
    Set
public:
property bool ShowImage {
    bool get ();
    void set (bool value);
}


Width Property

Width Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Width
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Width { get; }
<UnitTypeAttribute(UnitType.Distance)> _
Public ReadOnly Property Width As Double
    Get
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Width {
    double get ();
}


RasterImageDef Class

RasterImageDef Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbImage")]
public class RasterImageDef : DBObject
<WrapperAttribute("AcDbImage")> _
Public Class RasterImageDef _
    Inherits DBObject
[WrapperAttribute(L"AcDbImage")]
public ref class RasterImageDef : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RasterImageDef()()()() |
 | RasterImageDef(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | ActiveFileName |
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CloseImage()()()() |
 | ColorDepth |
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateImageDictionary(Database) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Embed()()()() |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FileDescCopy |
 | FileType |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEntityCount(Boolean%) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetImageDictionary(Database) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | ImageCopy(Boolean) |
 | ImageModified |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEmbedded |
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsLoaded |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Load()()()() |
 | LocateActivePath()()()() |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OpenImage()()()() |
 | Organization |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ResolutionMMPerPixel |
 | ResolutionUnits |
 | SearchForActivePath | Obsolete.
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetImage(IntPtr, IntPtr, Boolean) |
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | Size |
 | SourceFileName |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SuggestName(DBDictionary, String) |
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UndoStoreSize |
 | Unload(Boolean) |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateEntities()()()() |
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | RasterImageDef


RasterImageDef Constructor

RasterImageDef Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »RasterImageDef()()()()
Members
Icon | Member | Description
 | RasterImageDef()()()() |
 | RasterImageDef(IntPtr, Boolean) |


RasterImageDef Constructor

RasterImageDef Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »RasterImageDef()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RasterImageDef()
Public Sub New
public:
RasterImageDef()


RasterImageDef Constructor (unmanagedPointer, autoDelete)

RasterImageDef Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »RasterImageDef(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal RasterImageDef(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
RasterImageDef(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ActiveFileName Property

ActiveFileName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »ActiveFileName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string ActiveFileName { get; set; }
Public Overridable Property ActiveFileName As String
    Get
    Set
public:
virtual property String^ ActiveFileName {
    String^ get ();
    void set (String^ value);
}


CloseImage Method

CloseImage Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »CloseImage()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CloseImage()
Public Overridable Sub CloseImage
public:
virtual void CloseImage()


ColorDepth Property

ColorDepth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »ColorDepth
Declaration Syntax
C# Visual Basic Visual C++
public virtual int ColorDepth { get; }
Public Overridable ReadOnly Property ColorDepth As Integer
    Get
public:
virtual property int ColorDepth {
    int get ();
}


CreateImageDictionary Method (database)

CreateImageDictionary Method (database)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »CreateImageDictionary(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId CreateImageDictionary(
    Database database
)
Public Shared Function CreateImageDictionary ( _
    database As Database _
) As ObjectId
public:
static ObjectId CreateImageDictionary(
    Database^ database
)
Parameters
database(Database)


Embed Method

Embed Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »Embed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Embed()
Public Overridable Sub Embed
public:
virtual void Embed()


FileDescCopy Property

FileDescCopy Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »FileDescCopy
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtr FileDescCopy { get; }
Public Overridable ReadOnly Property FileDescCopy As IntPtr
    Get
public:
virtual property IntPtr FileDescCopy {
    IntPtr get ();
}


FileType Property

FileType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »FileType
Declaration Syntax
C# Visual Basic Visual C++
public virtual string FileType { get; }
Public Overridable ReadOnly Property FileType As String
    Get
public:
virtual property String^ FileType {
    String^ get ();
}


GetEntityCount Method (locked)

GetEntityCount Method (locked)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »GetEntityCount(Boolean%)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int GetEntityCount(
    out bool locked
)
Public Overridable Function GetEntityCount ( _
    <OutAttribute> ByRef locked As Boolean _
) As Integer
public:
virtual int GetEntityCount(
    [OutAttribute] bool% locked
)
Parameters
locked(Boolean%)


GetImageDictionary Method (database)

GetImageDictionary Method (database)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »GetImageDictionary(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetImageDictionary(
    Database database
)
Public Shared Function GetImageDictionary ( _
    database As Database _
) As ObjectId
public:
static ObjectId GetImageDictionary(
    Database^ database
)
Parameters
database(Database)


ImageCopy Method (forceImageLoad)

ImageCopy Method (forceImageLoad)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »ImageCopy(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtr ImageCopy(
    bool forceImageLoad
)
Public Overridable Function ImageCopy ( _
    forceImageLoad As Boolean _
) As IntPtr
public:
virtual IntPtr ImageCopy(
    bool forceImageLoad
)
Parameters
forceImageLoad(Boolean)


ImageModified Property

ImageModified Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »ImageModified
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ImageModified { get; set; }
Public Overridable Property ImageModified As Boolean
    Get
    Set
public:
virtual property bool ImageModified {
    bool get ();
    void set (bool value);
}


IsEmbedded Property

IsEmbedded Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »IsEmbedded
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsEmbedded { get; }
Public Overridable ReadOnly Property IsEmbedded As Boolean
    Get
public:
virtual property bool IsEmbedded {
    bool get ();
}


IsLoaded Property

IsLoaded Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »IsLoaded
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsLoaded { get; }
Public Overridable ReadOnly Property IsLoaded As Boolean
    Get
public:
virtual property bool IsLoaded {
    bool get ();
}


Load Method

Load Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »Load()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Load()
Public Overridable Sub Load
public:
virtual void Load()


LocateActivePath Method

LocateActivePath Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »LocateActivePath()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string LocateActivePath()
Public Function LocateActivePath As String
public:
String^ LocateActivePath()


OpenImage Method

OpenImage Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »OpenImage()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtr OpenImage()
Public Overridable Function OpenImage As IntPtr
public:
virtual IntPtr OpenImage()


Organization Property

Organization Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »Organization
Declaration Syntax
C# Visual Basic Visual C++
public virtual ImageOrg Organization { get; }
Public Overridable ReadOnly Property Organization As ImageOrg
    Get
public:
virtual property ImageOrg Organization {
    ImageOrg get ();
}


ResolutionMMPerPixel Property

ResolutionMMPerPixel Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »ResolutionMMPerPixel
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector2d ResolutionMMPerPixel { get; set; }
Public Overridable Property ResolutionMMPerPixel As Vector2d
    Get
    Set
public:
virtual property Vector2d ResolutionMMPerPixel {
    Vector2d get ();
    void set (Vector2d value);
}


ResolutionUnits Property

ResolutionUnits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »ResolutionUnits
Declaration Syntax
C# Visual Basic Visual C++
public virtual Unit ResolutionUnits { get; set; }
Public Overridable Property ResolutionUnits As Unit
    Get
    Set
public:
virtual property Unit ResolutionUnits {
    Unit get ();
    void set (Unit value);
}


SearchForActivePath Property

SearchForActivePath Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »SearchForActivePath
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use LocateActivePath() instead")]
public virtual string SearchForActivePath { get; }
<ObsoleteAttribute("Use LocateActivePath() instead")> _
Public Overridable ReadOnly Property SearchForActivePath As String
    Get
[ObsoleteAttribute(L"Use LocateActivePath() instead")]
public:
virtual property String^ SearchForActivePath {
    String^ get ();
}


SetImage Method (image, fileDescription, modifyDatabase)

SetImage Method (image, fileDescription, modifyDatabase)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »SetImage(IntPtr, IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetImage(
    IntPtr image,
    IntPtr fileDescription,
    bool modifyDatabase
)
Public Overridable Sub SetImage ( _
    image As IntPtr, _
    fileDescription As IntPtr, _
    modifyDatabase As Boolean _
)
public:
virtual void SetImage(
    IntPtr image,
    IntPtr fileDescription,
    bool modifyDatabase
)
Parameters
image(IntPtr)
fileDescription(IntPtr)
modifyDatabase(Boolean)


Size Property

Size Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »Size
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector2d Size { get; }
Public Overridable ReadOnly Property Size As Vector2d
    Get
public:
virtual property Vector2d Size {
    Vector2d get ();
}


SourceFileName Property

SourceFileName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »SourceFileName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string SourceFileName { get; set; }
Public Overridable Property SourceFileName As String
    Get
    Set
public:
virtual property String^ SourceFileName {
    String^ get ();
    void set (String^ value);
}


SuggestName Method (imageDictionary, newImagePathName)

SuggestName Method (imageDictionary, newImagePathName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »SuggestName(DBDictionary, String)
Declaration Syntax
C# Visual Basic Visual C++
public static string SuggestName(
    DBDictionary imageDictionary,
    string newImagePathName
)
Public Shared Function SuggestName ( _
    imageDictionary As DBDictionary, _
    newImagePathName As String _
) As String
public:
static String^ SuggestName(
    DBDictionary^ imageDictionary,
    String^ newImagePathName
)
Parameters
imageDictionary(DBDictionary)
newImagePathName(String)


UndoStoreSize Property

UndoStoreSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »UndoStoreSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual int UndoStoreSize { get; set; }
Public Overridable Property UndoStoreSize As Integer
    Get
    Set
public:
virtual property int UndoStoreSize {
    int get ();
    void set (int value);
}


Unload Method (modifyDatabase)

Unload Method (modifyDatabase)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »Unload(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Unload(
    bool modifyDatabase
)
Public Overridable Sub Unload ( _
    modifyDatabase As Boolean _
)
public:
virtual void Unload(
    bool modifyDatabase
)
Parameters
modifyDatabase(Boolean)


UpdateEntities Method

UpdateEntities Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »UpdateEntities()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UpdateEntities()
Public Overridable Sub UpdateEntities
public:
virtual void UpdateEntities()


RasterVariables Class

RasterVariables Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbRasterVariables")]
public class RasterVariables : DBObject
<WrapperAttribute("AcDbRasterVariables")> _
Public Class RasterVariables _
    Inherits DBObject
[WrapperAttribute(L"AcDbRasterVariables")]
public ref class RasterVariables : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RasterVariables()()()() |
 | RasterVariables(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | ImageFrame |
 | ImageQuality |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UserScale |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | RasterVariables


RasterVariables Constructor

RasterVariables Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »RasterVariables()()()()
Members
Icon | Member | Description
 | RasterVariables()()()() |
 | RasterVariables(IntPtr, Boolean) |


RasterVariables Constructor

RasterVariables Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »RasterVariables()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RasterVariables()
Public Sub New
public:
RasterVariables()


RasterVariables Constructor (unmanagedPointer, autoDelete)

RasterVariables Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »RasterVariables(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal RasterVariables(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
RasterVariables(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ImageFrame Property

ImageFrame Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »ImageFrame
Declaration Syntax
C# Visual Basic Visual C++
public virtual FrameSetting ImageFrame { get; set; }
Public Overridable Property ImageFrame As FrameSetting
    Get
    Set
public:
virtual property FrameSetting ImageFrame {
    FrameSetting get ();
    void set (FrameSetting value);
}


ImageQuality Property

ImageQuality Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »ImageQuality
Declaration Syntax
C# Visual Basic Visual C++
public virtual ImageQuality ImageQuality { get; set; }
Public Overridable Property ImageQuality As ImageQuality
    Get
    Set
public:
virtual property ImageQuality ImageQuality {
    ImageQuality get ();
    void set (ImageQuality value);
}


UserScale Property

UserScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »UserScale
Declaration Syntax
C# Visual Basic Visual C++
public virtual Unit UserScale { get; set; }
Public Overridable Property UserScale As Unit
    Get
    Set
public:
virtual property Unit UserScale {
    Unit get ();
    void set (Unit value);
}


Ray Class

Ray Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbRay")]
public class Ray : Curve
<WrapperAttribute("AcDbRay")> _
Public Class Ray _
    Inherits Curve
[WrapperAttribute(L"AcDbRay")]
public ref class Ray : public Curve
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ray(IntPtr, Boolean) |
 | Ray()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BasePoint |
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed | (Inherited from Curve.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SecondPoint |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Spline | (Inherited from Curve.)
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Inherited from Curve.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnitDir |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Ray


Ray Constructor

Ray Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »Ray()()()()
Members
Icon | Member | Description
 | Ray(IntPtr, Boolean) |
 | Ray()()()() |


Ray Constructor

Ray Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »Ray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Ray()
Public Sub New
public:
Ray()


Ray Constructor (unmanagedObjPtr, autoDelete)

Ray Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »Ray(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Ray(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Ray(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


BasePoint Property

BasePoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »BasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BasePoint { get; set; }
Public Property BasePoint As Point3d
    Get
    Set
public:
property Point3d BasePoint {
    Point3d get ();
    void set (Point3d value);
}


SecondPoint Property

SecondPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »SecondPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d SecondPoint { get; set; }
Public Property SecondPoint As Point3d
    Get
    Set
public:
property Point3d SecondPoint {
    Point3d get ();
    void set (Point3d value);
}


UnitDir Property

UnitDir Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »UnitDir
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d UnitDir { get; set; }
Public Property UnitDir As Vector3d
    Get
    Set
public:
property Vector3d UnitDir {
    Vector3d get ();
    void set (Vector3d value);
}


Rectangle3d Structure

Rectangle3d Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Rectangle3d
Declaration Syntax
C# Visual Basic Visual C++
public struct Rectangle3d
Public Structure Rectangle3d
public value class Rectangle3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Rectangle3d(Point3d, Point3d, Point3d, Point3d) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | LowerLeft |
 | LowerRight |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | UpperLeft |
 | UpperRight |


Rectangle3d Constructor (upperLeft, upperRight, lowerLeft, lowerRight)

Rectangle3d Constructor (upperLeft, upperRight, lowerLeft, lowerRight)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Rectangle3d »Rectangle3d(Point3d, Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Rectangle3d(
    Point3d upperLeft,
    Point3d upperRight,
    Point3d lowerLeft,
    Point3d lowerRight
)
Public Sub New ( _
    upperLeft As Point3d, _
    upperRight As Point3d, _
    lowerLeft As Point3d, _
    lowerRight As Point3d _
)
public:
Rectangle3d(
    Point3d upperLeft,
    Point3d upperRight,
    Point3d lowerLeft,
    Point3d lowerRight
)
Parameters
upperLeft(Point3d)
upperRight(Point3d)
lowerLeft(Point3d)
lowerRight(Point3d)


LowerLeft Property

LowerLeft Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Rectangle3d »LowerLeft
Declaration Syntax
C# Visual Basic Visual C++
public Point3d LowerLeft { get; }
Public ReadOnly Property LowerLeft As Point3d
    Get
public:
property Point3d LowerLeft {
    Point3d get ();
}


LowerRight Property

LowerRight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Rectangle3d »LowerRight
Declaration Syntax
C# Visual Basic Visual C++
public Point3d LowerRight { get; }
Public ReadOnly Property LowerRight As Point3d
    Get
public:
property Point3d LowerRight {
    Point3d get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Rectangle3d »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Rectangle3d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Rectangle3d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


UpperLeft Property

UpperLeft Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Rectangle3d »UpperLeft
Declaration Syntax
C# Visual Basic Visual C++
public Point3d UpperLeft { get; }
Public ReadOnly Property UpperLeft As Point3d
    Get
public:
property Point3d UpperLeft {
    Point3d get ();
}


UpperRight Property

UpperRight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Rectangle3d »UpperRight
Declaration Syntax
C# Visual Basic Visual C++
public Point3d UpperRight { get; }
Public ReadOnly Property UpperRight As Point3d
    Get
public:
property Point3d UpperRight {
    Point3d get ();
}


RegAppTable Class

RegAppTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbRegAppTable")]
public sealed class RegAppTable : SymbolTable
<WrapperAttribute("AcDbRegAppTable")> _
Public NotInheritable Class RegAppTable _
    Inherits SymbolTable
[WrapperAttribute(L"AcDbRegAppTable")]
public ref class RegAppTable sealed : public SymbolTable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) | (Inherited from SymbolTable.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() | (Inherited from SymbolTable.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) | (Inherited from SymbolTable.)
 | Has(ObjectId) | (Inherited from SymbolTable.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from SymbolTable.)
 | IncludingErased | (Inherited from SymbolTable.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from SymbolTable.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | RegAppTable


RegAppTableRecord Class

RegAppTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbRegAppTableRecord")]
public class RegAppTableRecord : SymbolTableRecord
<WrapperAttribute("AcDbRegAppTableRecord")> _
Public Class RegAppTableRecord _
    Inherits SymbolTableRecord
[WrapperAttribute(L"AcDbRegAppTableRecord")]
public ref class RegAppTableRecord : public SymbolTableRecord
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegAppTableRecord(IntPtr, Boolean) |
 | RegAppTableRecord()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent | (Inherited from SymbolTableRecord.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsResolved | (Inherited from SymbolTableRecord.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from SymbolTableRecord.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | RegAppTableRecord


RegAppTableRecord Constructor

RegAppTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord »RegAppTableRecord()()()()
Members
Icon | Member | Description
 | RegAppTableRecord(IntPtr, Boolean) |
 | RegAppTableRecord()()()() |


RegAppTableRecord Constructor

RegAppTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord »RegAppTableRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RegAppTableRecord()
Public Sub New
public:
RegAppTableRecord()


RegAppTableRecord Constructor (obj, autoDelete)

RegAppTableRecord Constructor (obj, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord »RegAppTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal RegAppTableRecord(
    IntPtr obj,
    bool autoDelete
)
Protected Friend Sub New ( _
    obj As IntPtr, _
    autoDelete As Boolean _
)
protected public:
RegAppTableRecord(
    IntPtr obj,
    bool autoDelete
)
Parameters
obj(IntPtr)
autoDelete(Boolean)


Region Class

Region Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbRegion")]
public class Region : Entity
<WrapperAttribute("AcDbRegion")> _
Public Class Region _
    Inherits Entity
[WrapperAttribute(L"AcDbRegion")]
public ref class Region : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Region(IntPtr, Boolean) |
 | Region()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | Body |
 | BooleanOperation(BooleanOperationType, Region) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateFromCurves(DBObjectCollection) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsNull |
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | NumChanges |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | Perimeter |
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Region


Region Constructor

Region Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Region()()()()
Members
Icon | Member | Description
 | Region(IntPtr, Boolean) |
 | Region()()()() |


Region Constructor

Region Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Region()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Region()
Public Sub New
public:
Region()


Region Constructor (unmanagedObjPtr, autoDelete)

Region Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Region(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Region(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Region(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Area Property

Area Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Area
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Area { get; }
Public Overridable ReadOnly Property Area As Double
    Get
public:
virtual property double Area {
    double get ();
}


Body Property

Body Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Body
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtr Body { get; set; }
Public Overridable Property Body As IntPtr
    Get
    Set
public:
virtual property IntPtr Body {
    IntPtr get ();
    void set (IntPtr value);
}


BooleanOperation Method (operation, otherRegion)

BooleanOperation Method (operation, otherRegion)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »BooleanOperation(BooleanOperationType, Region)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void BooleanOperation(
    BooleanOperationType operation,
    Region otherRegion
)
Public Overridable Sub BooleanOperation ( _
    operation As BooleanOperationType, _
    otherRegion As Region _
)
public:
virtual void BooleanOperation(
    BooleanOperationType operation,
    Region^ otherRegion
)
Parameters
operation(BooleanOperationType)
otherRegion(Region)


CreateFromCurves Method (curveSegments)

CreateFromCurves Method (curveSegments)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »CreateFromCurves(DBObjectCollection)
Declaration Syntax
C# Visual Basic Visual C++
public static DBObjectCollection CreateFromCurves(
    DBObjectCollection curveSegments
)
Public Shared Function CreateFromCurves ( _
    curveSegments As DBObjectCollection _
) As DBObjectCollection
public:
static DBObjectCollection^ CreateFromCurves(
    DBObjectCollection^ curveSegments
)
Parameters
curveSegments(DBObjectCollection)


IsNull Property

IsNull Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »IsNull
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsNull { get; }
Public Overridable ReadOnly Property IsNull As Boolean
    Get
public:
virtual property bool IsNull {
    bool get ();
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Normal
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d Normal { get; }
Public Overridable ReadOnly Property Normal As Vector3d
    Get
public:
virtual property Vector3d Normal {
    Vector3d get ();
}


NumChanges Property

NumChanges Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »NumChanges
Declaration Syntax
C# Visual Basic Visual C++
public virtual int NumChanges { get; }
Public Overridable ReadOnly Property NumChanges As Integer
    Get
public:
virtual property int NumChanges {
    int get ();
}


Perimeter Property

Perimeter Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Perimeter
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Perimeter { get; }
Public Overridable ReadOnly Property Perimeter As Double
    Get
public:
virtual property double Perimeter {
    double get ();
}


RenderMode Enumeration

RenderMode Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RenderMode
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGsView::RenderMode")]
public enum RenderMode
<WrapperAttribute("ZcGsView::RenderMode")> _
Public Enumeration RenderMode
[WrapperAttribute(L"ZcGsView::RenderMode")]
public enum class RenderMode
Members
Member | Description
GouraudShadedWithWireframe |
FlatShadedWithWireframe |
GouraudShaded |
FlatShaded |
HiddenLine |
Wireframe |
Optimized2D |


ReservedStringEnumType Enumeration

ReservedStringEnumType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ReservedStringEnumType
Declaration Syntax
C# Visual Basic Visual C++
public enum ReservedStringEnumType
Public Enumeration ReservedStringEnumType
public enum class ReservedStringEnumType
Members
Member | Description
ByColor |
None |
ByBlock |
ByLayer |
VSShaded |
VSShadedWithEdges |
VSXRay |
VSSketchy |
VSShadesOfGray |
Header |
Title |
VSConceptual |
VSRealistic |
VS3DHidden |
VS3DWireframe |
VS2DWireframe |
Default |
DefPoints |
Normal |
Standard |
Continuous |
Data |
Global |
Model |
Missing |


ResultBuffer Class

ResultBuffer Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("resbuf")]
public sealed class ResultBuffer : DisposableWrapper,
    IEnumerable, IFormattable
<WrapperAttribute("resbuf")> _
Public NotInheritable Class ResultBuffer _
    Inherits DisposableWrapper _
    Implements IEnumerable, IFormattable
[WrapperAttribute(L"resbuf")]
public ref class ResultBuffer sealed : public DisposableWrapper,
    IEnumerable, IFormattable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResultBuffer(array<TypedValue>[]()[][]) |
 | ResultBuffer()()()() |
 | Add(TypedValue) |
 | Add(Object) |
 | AsArray()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equality(ResultBuffer, ResultBuffer) |
 | Equals(Object) | (Overrides DisposableWrapper.Equals(Object).)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Overrides DisposableWrapper.GetHashCode()()()().)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerable..::..GetEnumerator()()()() |
 | Inequality(ResultBuffer, ResultBuffer) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | ResultBuffer


ResultBuffer Constructor

ResultBuffer Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »ResultBuffer()()()()
Members
Icon | Member | Description
 | ResultBuffer(array<TypedValue>[]()[][]) |
 | ResultBuffer()()()() |


ResultBuffer Constructor

ResultBuffer Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »ResultBuffer()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ResultBuffer()
Public Sub New
public:
ResultBuffer()


ResultBuffer Constructor (values)

ResultBuffer Constructor (values)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »ResultBuffer(array<TypedValue>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ResultBuffer(
    params TypedValue[] values
)
Public Sub New ( _
    ParamArray values As TypedValue() _
)
public:
ResultBuffer(
    ... array<TypedValue>^ values
)
Parameters
values(array< TypedValue >[]()[][])


Add Method

Add Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »Add()()()()
Members
Icon | Member | Description
 | Add(TypedValue) |
 | Add(Object) |


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    Object value
)
Public Sub Add ( _
    value As Object _
)
public:
void Add(
    Object^ value
)
Parameters
value(Object)


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »Add(TypedValue)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    TypedValue value
)
Public Sub Add ( _
    value As TypedValue _
)
public:
void Add(
    TypedValue value
)
Parameters
value(TypedValue)


AsArray Method

AsArray Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »AsArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TypedValue[] AsArray()
Public Function AsArray As TypedValue()
public:
array<TypedValue>^ AsArray()


Create Method (buffer, autoDelete)

Create Method (buffer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static ResultBuffer Create(
    IntPtr buffer,
    bool autoDelete
)
Public Shared Function Create ( _
    buffer As IntPtr, _
    autoDelete As Boolean _
) As ResultBuffer
public:
static ResultBuffer^ Create(
    IntPtr buffer,
    bool autoDelete
)
Parameters
buffer(IntPtr)
autoDelete(Boolean)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »Equality(ResultBuffer, ResultBuffer)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    ResultBuffer a,
    ResultBuffer b
)
Public Shared Operator = ( _
    a As ResultBuffer, _
    b As ResultBuffer _
) As Boolean
public:
static bool operator ==(
    ResultBuffer^ a,
    ResultBuffer^ b
)
Parameters
a(ResultBuffer)
b(ResultBuffer)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ResultBufferEnumerator GetEnumerator()
Public Function GetEnumerator As ResultBufferEnumerator
public:
ResultBufferEnumerator^ GetEnumerator()


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


IEnumerableGetEnumerator Method

IEnumerableGetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »IEnumerable..::..GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
IEnumerator IEnumerable.GetEnumerator()
Private Function IEnumerableGetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ IEnumerableGetEnumerator() sealed = IEnumerable::GetEnumerator


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »Inequality(ResultBuffer, ResultBuffer)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    ResultBuffer a,
    ResultBuffer b
)
Public Shared Operator <> ( _
    a As ResultBuffer, _
    b As ResultBuffer _
) As Boolean
public:
static bool operator !=(
    ResultBuffer^ a,
    ResultBuffer^ b
)
Parameters
a(ResultBuffer)
b(ResultBuffer)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


ResultBufferEnumerator Class

ResultBufferEnumerator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBufferEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ResultBufferEnumerator : IEnumerator
Public NotInheritable Class ResultBufferEnumerator _
    Implements IEnumerator
public ref class ResultBufferEnumerator sealed : IEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumeratorCurrent |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ResultBufferEnumerator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBufferEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public TypedValue Current { get; }
Public ReadOnly Property Current As TypedValue
    Get
public:
property TypedValue Current {
    TypedValue get ();
}


IEnumeratorCurrent Property

IEnumeratorCurrent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBufferEnumerator »IEnumeratorCurrent
Declaration Syntax
C# Visual Basic Visual C++
internal virtual Object IEnumeratorCurrent { get; }
Friend Overridable ReadOnly Property IEnumeratorCurrent As Object
    Get
internal:
virtual property Object^ IEnumeratorCurrent {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBufferEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBufferEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


RevolvedSurface Class

RevolvedSurface Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbRevolvedSurface")]
public class RevolvedSurface : Surface
<WrapperAttribute("AcDbRevolvedSurface")> _
Public Class RevolvedSurface _
    Inherits Surface
[WrapperAttribute(L"AcDbRevolvedSurface")]
public ref class RevolvedSurface : public Surface
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RevolvedSurface()()()() |
 | RevolvedSurface(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | AxisDirection |
 | AxisPoint |
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BooleanIntersect(Surface) | (Inherited from Surface.)
 | BooleanIntersect(Solid3d) | (Inherited from Surface.)
 | BooleanSubtract(Surface) | (Inherited from Surface.)
 | BooleanSubtract(Solid3d) | (Inherited from Surface.)
 | BooleanUnion(Surface) | (Inherited from Surface.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ChamferEdges(array<SubentityId>[]()[][], SubentityId, Double, Double) | (Inherited from Surface.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToRegion()()()() | (Inherited from Surface.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateInterferenceObjects(Entity, Int32) | (Inherited from Surface.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateRevolvedSurface(Entity, Point3d, Vector3d, Double, Double, RevolveOptions) |
 | CreateSectionObjects(Plane) | (Inherited from Surface.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FilletEdges(array<SubentityId>[]()[][], DoubleCollection, DoubleCollection, DoubleCollection) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetArea()()()() | (Inherited from Surface.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityColor(SubentityId) | (Inherited from Surface.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityMaterial(SubentityId) | (Inherited from Surface.)
 | GetSubentityMaterialMapper(SubentityId) | (Inherited from Surface.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | ImprintEntity(Entity) | (Inherited from Surface.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | ProjectOnToSurface(Entity, Vector3d) | (Inherited from Surface.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RayTest(Point3d, Vector3d, Double, array<SubentityId>[]()[][]%, DoubleCollection%) | (Inherited from Surface.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | RevolveAngle |
 | RevolveEntity |
 | RevolveOptions |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetRevolve(Point3d, Vector3d, Double, RevolveOptions) |
 | SetSubentityColor(SubentityId, Color) | (Inherited from Surface.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetSubentityMaterial(SubentityId, ObjectId) | (Inherited from Surface.)
 | SetSubentityMaterialMapper(SubentityId, Mapper) | (Inherited from Surface.)
 | SliceByPlane(Plane) | (Inherited from Surface.)
 | SliceBySurface(Surface) | (Inherited from Surface.)
 | StartAngle |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thicken(Double, Boolean) | (Inherited from Surface.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | UIsoLineDensity | (Inherited from Surface.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VIsoLineDensity | (Inherited from Surface.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Surface
 |  |  |  |  |  |  |  | RevolvedSurface


RevolvedSurface Constructor

RevolvedSurface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »RevolvedSurface()()()()
Members
Icon | Member | Description
 | RevolvedSurface()()()() |
 | RevolvedSurface(IntPtr, Boolean) |


RevolvedSurface Constructor

RevolvedSurface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »RevolvedSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RevolvedSurface()
Public Sub New
public:
RevolvedSurface()


RevolvedSurface Constructor (unmanagedPointer, autoDelete)

RevolvedSurface Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »RevolvedSurface(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal RevolvedSurface(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
RevolvedSurface(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AxisDirection Property

AxisDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »AxisDirection
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d AxisDirection { get; set; }
Public Property AxisDirection As Vector3d
    Get
    Set
public:
property Vector3d AxisDirection {
    Vector3d get ();
    void set (Vector3d value);
}


AxisPoint Property

AxisPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »AxisPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d AxisPoint { get; set; }
Public Property AxisPoint As Point3d
    Get
    Set
public:
property Point3d AxisPoint {
    Point3d get ();
    void set (Point3d value);
}


CreateRevolvedSurface Method (revolveEntity, axisPoint, axisDirection, revolveAngle, startAngle, revolveOptions)

CreateRevolvedSurface Method (revolveEntity, axisPoint, axisDirection, revolveAngle, startAngle, revolveOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »CreateRevolvedSurface(Entity, Point3d, Vector3d, Double, Double, RevolveOptions)
Declaration Syntax
C# Visual Basic Visual C++
public void CreateRevolvedSurface(
    Entity revolveEntity,
    Point3d axisPoint,
    Vector3d axisDirection,
    double revolveAngle,
    double startAngle,
    RevolveOptions revolveOptions
)
Public Sub CreateRevolvedSurface ( _
    revolveEntity As Entity, _
    axisPoint As Point3d, _
    axisDirection As Vector3d, _
    revolveAngle As Double, _
    startAngle As Double, _
    revolveOptions As RevolveOptions _
)
public:
void CreateRevolvedSurface(
    Entity^ revolveEntity,
    Point3d axisPoint,
    Vector3d axisDirection,
    double revolveAngle,
    double startAngle,
    RevolveOptions^ revolveOptions
)
Parameters
revolveEntity(Entity)
axisPoint(Point3d)
axisDirection(Vector3d)
revolveAngle(Double)
startAngle(Double)
revolveOptions(RevolveOptions)


RevolveAngle Property

RevolveAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »RevolveAngle
Declaration Syntax
C# Visual Basic Visual C++
public double RevolveAngle { get; set; }
Public Property RevolveAngle As Double
    Get
    Set
public:
property double RevolveAngle {
    double get ();
    void set (double value);
}


RevolveEntity Property

RevolveEntity Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »RevolveEntity
Declaration Syntax
C# Visual Basic Visual C++
public Entity RevolveEntity { get; }
Public ReadOnly Property RevolveEntity As Entity
    Get
public:
property Entity^ RevolveEntity {
    Entity^ get ();
}


RevolveOptions Property

RevolveOptions Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »RevolveOptions
Declaration Syntax
C# Visual Basic Visual C++
public RevolveOptions RevolveOptions { get; set; }
Public Property RevolveOptions As RevolveOptions
    Get
    Set
public:
property RevolveOptions^ RevolveOptions {
    RevolveOptions^ get ();
    void set (RevolveOptions^ value);
}


SetRevolve Method (axisPoint, axisDirection, revolveAngle, revolveOptions)

SetRevolve Method (axisPoint, axisDirection, revolveAngle, revolveOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »SetRevolve(Point3d, Vector3d, Double, RevolveOptions)
Declaration Syntax
C# Visual Basic Visual C++
public void SetRevolve(
    Point3d axisPoint,
    Vector3d axisDirection,
    double revolveAngle,
    RevolveOptions revolveOptions
)
Public Sub SetRevolve ( _
    axisPoint As Point3d, _
    axisDirection As Vector3d, _
    revolveAngle As Double, _
    revolveOptions As RevolveOptions _
)
public:
void SetRevolve(
    Point3d axisPoint,
    Vector3d axisDirection,
    double revolveAngle,
    RevolveOptions^ revolveOptions
)
Parameters
axisPoint(Point3d)
axisDirection(Vector3d)
revolveAngle(Double)
revolveOptions(RevolveOptions)


StartAngle Property

StartAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »StartAngle
Declaration Syntax
C# Visual Basic Visual C++
public double StartAngle { get; }
Public ReadOnly Property StartAngle As Double
    Get
public:
property double StartAngle {
    double get ();
}


RevolveOptions Class

RevolveOptions Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbRevolveOptions")]
public class RevolveOptions : DisposableWrapper,
    ICloneable
<WrapperAttribute("ZcDbRevolveOptions")> _
Public Class RevolveOptions _
    Inherits DisposableWrapper _
    Implements ICloneable
[WrapperAttribute(L"ZcDbRevolveOptions")]
public ref class RevolveOptions : public DisposableWrapper,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RevolveOptions(RevolveOptions) |
 | RevolveOptions()()()() |
 | RevolveOptions(IntPtr, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CheckRevolveCurve(Entity, Point3d, Vector3d, Boolean) |
 | Clone()()()() |
 | CloseToAxis |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DraftAngle |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TwistAngle |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RevolveOptions


RevolveOptions Constructor

RevolveOptions Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »RevolveOptions()()()()
Members
Icon | Member | Description
 | RevolveOptions(RevolveOptions) |
 | RevolveOptions()()()() |
 | RevolveOptions(IntPtr, Boolean) |


RevolveOptions Constructor

RevolveOptions Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »RevolveOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RevolveOptions()
Public Sub New
public:
RevolveOptions()


RevolveOptions Constructor (unmanagedPointer, autoDelete)

RevolveOptions Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »RevolveOptions(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal RevolveOptions(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
RevolveOptions(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


RevolveOptions Constructor (opts)

RevolveOptions Constructor (opts)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »RevolveOptions(RevolveOptions)
Declaration Syntax
C# Visual Basic Visual C++
public RevolveOptions(
    RevolveOptions opts
)
Public Sub New ( _
    opts As RevolveOptions _
)
public:
RevolveOptions(
    RevolveOptions^ opts
)
Parameters
opts(RevolveOptions)


CheckRevolveCurve Method (ent, axisPnt, axisDir, displayErrorMessages)

CheckRevolveCurve Method (ent, axisPnt, axisDir, displayErrorMessages)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »CheckRevolveCurve(Entity, Point3d, Vector3d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public RevolveOptionsCheckRevolveCurveOut CheckRevolveCurve(
    Entity ent,
    Point3d axisPnt,
    Vector3d axisDir,
    bool displayErrorMessages
)
Public Function CheckRevolveCurve ( _
    ent As Entity, _
    axisPnt As Point3d, _
    axisDir As Vector3d, _
    displayErrorMessages As Boolean _
) As RevolveOptionsCheckRevolveCurveOut
public:
RevolveOptionsCheckRevolveCurveOut^ CheckRevolveCurve(
    Entity^ ent,
    Point3d axisPnt,
    Vector3d axisDir,
    bool displayErrorMessages
)
Parameters
ent(Entity)
axisPnt(Point3d)
axisDir(Vector3d)
displayErrorMessages(Boolean)


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed


CloseToAxis Property

CloseToAxis Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »CloseToAxis
Declaration Syntax
C# Visual Basic Visual C++
public bool CloseToAxis { get; }
Public ReadOnly Property CloseToAxis As Boolean
    Get
public:
property bool CloseToAxis {
    bool get ();
}


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override sealed void DeleteUnmanagedObject()
Protected Overrides NotOverridable Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override sealed


DraftAngle Property

DraftAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »DraftAngle
Declaration Syntax
C# Visual Basic Visual C++
public double DraftAngle { get; }
Public ReadOnly Property DraftAngle As Double
    Get
public:
property double DraftAngle {
    double get ();
}


TwistAngle Property

TwistAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »TwistAngle
Declaration Syntax
C# Visual Basic Visual C++
public double TwistAngle { get; }
Public ReadOnly Property TwistAngle As Double
    Get
public:
property double TwistAngle {
    double get ();
}


RevolveOptionsBuilder Class

RevolveOptionsBuilder Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsBuilder
Declaration Syntax
C# Visual Basic Visual C++
public class RevolveOptionsBuilder
Public Class RevolveOptionsBuilder
public ref class RevolveOptionsBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RevolveOptionsBuilder(RevolveOptions) |
 | RevolveOptionsBuilder()()()() |
 | CloseToAxis |
 | DraftAngle |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToRevolveOptions()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TwistAngle |
Inheritance Hierarchy
Object
RevolveOptionsBuilder


RevolveOptionsBuilder Constructor

RevolveOptionsBuilder Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsBuilder »RevolveOptionsBuilder()()()()
Members
Icon | Member | Description
 | RevolveOptionsBuilder(RevolveOptions) |
 | RevolveOptionsBuilder()()()() |


RevolveOptionsBuilder Constructor

RevolveOptionsBuilder Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsBuilder »RevolveOptionsBuilder()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RevolveOptionsBuilder()
Public Sub New
public:
RevolveOptionsBuilder()


RevolveOptionsBuilder Constructor (value)

RevolveOptionsBuilder Constructor (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsBuilder »RevolveOptionsBuilder(RevolveOptions)
Declaration Syntax
C# Visual Basic Visual C++
public RevolveOptionsBuilder(
    RevolveOptions value
)
Public Sub New ( _
    value As RevolveOptions _
)
public:
RevolveOptionsBuilder(
    RevolveOptions^ value
)
Parameters
value(RevolveOptions)


CloseToAxis Property

CloseToAxis Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsBuilder »CloseToAxis
Declaration Syntax
C# Visual Basic Visual C++
public bool CloseToAxis { get; set; }
Public Property CloseToAxis As Boolean
    Get
    Set
public:
property bool CloseToAxis {
    bool get ();
    void set (bool value);
}


DraftAngle Property

DraftAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsBuilder »DraftAngle
Declaration Syntax
C# Visual Basic Visual C++
public double DraftAngle { get; set; }
Public Property DraftAngle As Double
    Get
    Set
public:
property double DraftAngle {
    double get ();
    void set (double value);
}


ToRevolveOptions Method

ToRevolveOptions Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsBuilder »ToRevolveOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RevolveOptions ToRevolveOptions()
Public Function ToRevolveOptions As RevolveOptions
public:
RevolveOptions^ ToRevolveOptions()


TwistAngle Property

TwistAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsBuilder »TwistAngle
Declaration Syntax
C# Visual Basic Visual C++
public double TwistAngle { get; set; }
Public Property TwistAngle As Double
    Get
    Set
public:
property double TwistAngle {
    double get ();
    void set (double value);
}


RevolveOptionsCheckRevolveCurveOut Class

RevolveOptionsCheckRevolveCurveOut Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsCheckRevolveCurveOut
Declaration Syntax
C# Visual Basic Visual C++
public class RevolveOptionsCheckRevolveCurveOut
Public Class RevolveOptionsCheckRevolveCurveOut
public ref class RevolveOptionsCheckRevolveCurveOut
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RevolveOptionsCheckRevolveCurveOut()()()() |
 | Closed |
 | EndPointsOnAxis |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Planar |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
RevolveOptionsCheckRevolveCurveOut


RevolveOptionsCheckRevolveCurveOut Constructor

RevolveOptionsCheckRevolveCurveOut Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsCheckRevolveCurveOut »RevolveOptionsCheckRevolveCurveOut()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RevolveOptionsCheckRevolveCurveOut()
Public Sub New
public:
RevolveOptionsCheckRevolveCurveOut()


Closed Property

Closed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsCheckRevolveCurveOut »Closed
Declaration Syntax
C# Visual Basic Visual C++
public bool Closed { get; }
Public ReadOnly Property Closed As Boolean
    Get
public:
property bool Closed {
    bool get ();
}


EndPointsOnAxis Property

EndPointsOnAxis Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsCheckRevolveCurveOut »EndPointsOnAxis
Declaration Syntax
C# Visual Basic Visual C++
public bool EndPointsOnAxis { get; }
Public ReadOnly Property EndPointsOnAxis As Boolean
    Get
public:
property bool EndPointsOnAxis {
    bool get ();
}


Planar Property

Planar Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptionsCheckRevolveCurveOut »Planar
Declaration Syntax
C# Visual Basic Visual C++
public bool Planar { get; }
Public ReadOnly Property Planar As Boolean
    Get
public:
property bool Planar {
    bool get ();
}


RotatedDimension Class

RotatedDimension Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbRotatedDimension")]
public class RotatedDimension : Dimension
<WrapperAttribute("AcDbRotatedDimension")> _
Public Class RotatedDimension _
    Inherits Dimension
[WrapperAttribute(L"AcDbRotatedDimension")]
public ref class RotatedDimension : public Dimension
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RotatedDimension(Double, Point3d, Point3d, Point3d, String, ObjectId) |
 | RotatedDimension(IntPtr, Boolean) |
 | RotatedDimension()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AlternatePrefix | (Inherited from Dimension.)
 | AlternateSuffix | (Inherited from Dimension.)
 | AltSuppressLeadingZeros | (Inherited from Dimension.)
 | AltSuppressTrailingZeros | (Inherited from Dimension.)
 | AltSuppressZeroFeet | (Inherited from Dimension.)
 | AltSuppressZeroInches | (Inherited from Dimension.)
 | AltToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | AltToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | AltToleranceSuppressZeroInches | (Inherited from Dimension.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | CenterMarkSize | (Inherited from Dimension.)
 | CenterMarkType | (Inherited from Dimension.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Dimadec | (Inherited from Dimension.)
 | Dimalt | (Inherited from Dimension.)
 | Dimaltd | (Inherited from Dimension.)
 | Dimaltf | (Inherited from Dimension.)
 | Dimaltrnd | (Inherited from Dimension.)
 | Dimalttd | (Inherited from Dimension.)
 | Dimalttz | (Inherited from Dimension.)
 | Dimaltu | (Inherited from Dimension.)
 | Dimaltz | (Inherited from Dimension.)
 | Dimapost | (Inherited from Dimension.)
 | Dimarcsym | (Inherited from Dimension.)
 | Dimasz | (Inherited from Dimension.)
 | Dimatfit | (Inherited from Dimension.)
 | Dimaunit | (Inherited from Dimension.)
 | Dimazin | (Inherited from Dimension.)
 | Dimblk | (Inherited from Dimension.)
 | Dimblk1 | (Inherited from Dimension.)
 | Dimblk1s | (Inherited from Dimension.)
 | Dimblk2 | (Inherited from Dimension.)
 | Dimblk2s | (Inherited from Dimension.)
 | Dimblks | (Inherited from Dimension.)
 | DimBlockId | (Inherited from Dimension.)
 | DimBlockPosition | (Inherited from Dimension.)
 | Dimcen | (Inherited from Dimension.)
 | Dimclrd | (Inherited from Dimension.)
 | Dimclre | (Inherited from Dimension.)
 | Dimclrt | (Inherited from Dimension.)
 | Dimdec | (Inherited from Dimension.)
 | Dimdle | (Inherited from Dimension.)
 | Dimdli | (Inherited from Dimension.)
 | Dimdsep | (Inherited from Dimension.)
 | DimensionStyle | (Inherited from Dimension.)
 | DimensionStyleName | (Inherited from Dimension.)
 | DimensionText | (Inherited from Dimension.)
 | Dimexe | (Inherited from Dimension.)
 | Dimexo | (Inherited from Dimension.)
 | Dimfrac | (Inherited from Dimension.)
 | Dimfxlen | (Inherited from Dimension.)
 | DimfxlenOn | (Inherited from Dimension.)
 | Dimgap | (Inherited from Dimension.)
 | Dimjogang | (Inherited from Dimension.)
 | Dimjust | (Inherited from Dimension.)
 | Dimldrblk | (Inherited from Dimension.)
 | Dimldrblks | (Inherited from Dimension.)
 | Dimlfac | (Inherited from Dimension.)
 | Dimlim | (Inherited from Dimension.)
 | DimLinePoint |
 | Dimltex1 | (Inherited from Dimension.)
 | Dimltex2 | (Inherited from Dimension.)
 | Dimltype | (Inherited from Dimension.)
 | Dimlunit | (Inherited from Dimension.)
 | Dimlwd | (Inherited from Dimension.)
 | Dimlwe | (Inherited from Dimension.)
 | Dimpost | (Inherited from Dimension.)
 | Dimrnd | (Inherited from Dimension.)
 | Dimsah | (Inherited from Dimension.)
 | Dimscale | (Inherited from Dimension.)
 | Dimsd1 | (Inherited from Dimension.)
 | Dimsd2 | (Inherited from Dimension.)
 | Dimse1 | (Inherited from Dimension.)
 | Dimse2 | (Inherited from Dimension.)
 | Dimsoxd | (Inherited from Dimension.)
 | DimstyleData | (Inherited from Dimension.)
 | Dimtad | (Inherited from Dimension.)
 | Dimtdec | (Inherited from Dimension.)
 | Dimtfac | (Inherited from Dimension.)
 | Dimtfill | (Inherited from Dimension.)
 | Dimtfillclr | (Inherited from Dimension.)
 | Dimtih | (Inherited from Dimension.)
 | Dimtix | (Inherited from Dimension.)
 | Dimtm | (Inherited from Dimension.)
 | Dimtmove | (Inherited from Dimension.)
 | Dimtofl | (Inherited from Dimension.)
 | Dimtoh | (Inherited from Dimension.)
 | Dimtol | (Inherited from Dimension.)
 | Dimtolj | (Inherited from Dimension.)
 | Dimtp | (Inherited from Dimension.)
 | Dimtsz | (Inherited from Dimension.)
 | Dimtvp | (Inherited from Dimension.)
 | Dimtxsty | (Inherited from Dimension.)
 | Dimtxt | (Inherited from Dimension.)
 | Dimtzin | (Inherited from Dimension.)
 | Dimupt | (Inherited from Dimension.)
 | Dimzin | (Inherited from Dimension.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicDimension | (Inherited from Dimension.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation | (Inherited from Dimension.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldFromMText(MText) | (Inherited from Dimension.)
 | FieldToMText(MText) | (Inherited from Dimension.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FormatMeasurement(Double, String) | (Inherited from Dimension.)
 | GenerateLayout()()()() | (Inherited from Dimension.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetDimstyleData()()()() | (Inherited from Dimension.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HorizontalRotation | (Inherited from Dimension.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | Measurement | (Inherited from Dimension.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal | (Inherited from Dimension.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | Oblique |
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Prefix | (Inherited from Dimension.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeDimensionBlock(Boolean) | (Inherited from Dimension.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveTextField()()()() | (Inherited from Dimension.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDimstyleData(DimStyleTableRecord) | (Inherited from Dimension.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | Suffix | (Inherited from Dimension.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressAngularLeadingZeros | (Inherited from Dimension.)
 | SuppressAngularTrailingZeros | (Inherited from Dimension.)
 | SuppressLeadingZeros | (Inherited from Dimension.)
 | SuppressTrailingZeros | (Inherited from Dimension.)
 | SuppressZeroFeet | (Inherited from Dimension.)
 | SuppressZeroInches | (Inherited from Dimension.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextAttachment | (Inherited from Dimension.)
 | TextLineSpacingFactor | (Inherited from Dimension.)
 | TextLineSpacingStyle | (Inherited from Dimension.)
 | TextPosition | (Inherited from Dimension.)
 | TextRotation | (Inherited from Dimension.)
 | TextStyleId | (Inherited from Dimension.)
 | ToleranceSuppressLeadingZeros | (Inherited from Dimension.)
 | ToleranceSuppressTrailingZeros | (Inherited from Dimension.)
 | ToleranceSuppressZeroFeet | (Inherited from Dimension.)
 | ToleranceSuppressZeroInches | (Inherited from Dimension.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UsingDefaultTextPosition | (Inherited from Dimension.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | XLine1Point |
 | XLine2Point |
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Dimension
 |  |  |  |  |  |  |  | RotatedDimension


RotatedDimension Constructor

RotatedDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »RotatedDimension()()()()
Members
Icon | Member | Description
 | RotatedDimension(Double, Point3d, Point3d, Point3d, String, ObjectId) |
 | RotatedDimension(IntPtr, Boolean) |
 | RotatedDimension()()()() |


RotatedDimension Constructor

RotatedDimension Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »RotatedDimension()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RotatedDimension()
Public Sub New
public:
RotatedDimension()


RotatedDimension Constructor (rotation, line1Point, line2Point, dimensionLinePoint, dimensionText, dimensionStyle)

RotatedDimension Constructor (rotation, line1Point, line2Point, dimensionLinePoint, dimensionText, dimensionStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »RotatedDimension(Double, Point3d, Point3d, Point3d, String, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public RotatedDimension(
    double rotation,
    Point3d line1Point,
    Point3d line2Point,
    Point3d dimensionLinePoint,
    string dimensionText,
    ObjectId dimensionStyle
)
Public Sub New ( _
    rotation As Double, _
    line1Point As Point3d, _
    line2Point As Point3d, _
    dimensionLinePoint As Point3d, _
    dimensionText As String, _
    dimensionStyle As ObjectId _
)
public:
RotatedDimension(
    double rotation,
    Point3d line1Point,
    Point3d line2Point,
    Point3d dimensionLinePoint,
    String^ dimensionText,
    ObjectId dimensionStyle
)
Parameters
rotation(Double)
line1Point(Point3d)
line2Point(Point3d)
dimensionLinePoint(Point3d)
dimensionText(String)
dimensionStyle(ObjectId)


RotatedDimension Constructor (unmanagedObjPtr, autoDelete)

RotatedDimension Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »RotatedDimension(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal RotatedDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
RotatedDimension(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


DimLinePoint Property

DimLinePoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »DimLinePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d DimLinePoint { get; set; }
Public Property DimLinePoint As Point3d
    Get
    Set
public:
property Point3d DimLinePoint {
    Point3d get ();
    void set (Point3d value);
}


Oblique Property

Oblique Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »Oblique
Declaration Syntax
C# Visual Basic Visual C++
public double Oblique { get; set; }
Public Property Oblique As Double
    Get
    Set
public:
property double Oblique {
    double get ();
    void set (double value);
}


Rotation Property

Rotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »Rotation
Declaration Syntax
C# Visual Basic Visual C++
public double Rotation { get; set; }
Public Property Rotation As Double
    Get
    Set
public:
property double Rotation {
    double get ();
    void set (double value);
}


XLine1Point Property

XLine1Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »XLine1Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine1Point { get; set; }
Public Property XLine1Point As Point3d
    Get
    Set
public:
property Point3d XLine1Point {
    Point3d get ();
    void set (Point3d value);
}


XLine2Point Property

XLine2Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »XLine2Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d XLine2Point { get; set; }
Public Property XLine2Point As Point3d
    Get
    Set
public:
property Point3d XLine2Point {
    Point3d get ();
    void set (Point3d value);
}


RotatedDimType Enumeration

RotatedDimType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimType
Declaration Syntax
C# Visual Basic Visual C++
public enum RotatedDimType
Public Enumeration RotatedDimType
public enum class RotatedDimType
Members
Member | Description
Perpendicular |
Parallel |
Unknown |


RotationAngle Enumeration

RotationAngle Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotationAngle
Declaration Syntax
C# Visual Basic Visual C++
public enum RotationAngle
Public Enumeration RotationAngle
public enum class RotationAngle
Members
Member | Description
Degrees270 |
Degrees180 |
Degrees090 |
Degrees000 |
DegreesUnknown |


Row Class

Row Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Row
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Row : CellRange
Public NotInheritable Class Row _
    Inherits CellRange
public ref class Row sealed : public CellRange
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Alignment | (Inherited from CellRange.)
 | BackgroundColor | (Inherited from CellRange.)
 | Borders | (Inherited from CellRange.)
 | BottomRight | (Inherited from CellRange.)
 | BottomRightPlusOne | (Inherited from CellRange.)
 | BottomRow | (Inherited from CellRange.)
 | CanDeleteColumns | (Inherited from CellRange.)
 | CanDeleteRows | (Inherited from CellRange.)
 | CanInsertColumn | (Inherited from CellRange.)
 | CanInsertRow | (Inherited from CellRange.)
 | ClearStyleOverrides()()()() | (Inherited from CellRange.)
 | ContentColor | (Inherited from CellRange.)
 | ContentLayout | (Inherited from CellRange.)
 | DataFormat | (Inherited from CellRange.)
 | DataType | (Inherited from CellRange.)
 | DeleteContent()()()() | (Inherited from CellRange.)
 | Equals(Object) | (Inherited from CellRange.)
 | Finalize()()()() | (Inherited from Object.)
 | GetCustomData(String) | (Inherited from CellRange.)
 | GetDataLink()()()() | (Inherited from CellRange.)
 | GetEnumerator()()()() | (Inherited from CellRange.)
 | GetHashCode()()()() | (Inherited from CellRange.)
 | GetStyleOverrides()()()() | (Inherited from CellRange.)
 | GetType()()()() | (Inherited from Object.)
 | Height |
 | IEnumerableGetEnumerator()()()() | (Inherited from CellRange.)
 | IsBackgroundColorNone | (Inherited from CellRange.)
 | IsContentEditable | (Inherited from CellRange.)
 | IsEmpty | (Inherited from CellRange.)
 | IsFormatEditable | (Inherited from CellRange.)
 | IsLinked | (Inherited from CellRange.)
 | IsMergeAllEnabled | (Inherited from CellRange.)
 | IsMerged | (Inherited from CellRange.)
 | IsNull | (Inherited from CellRange.)
 | IsSingleCell | (Inherited from CellRange.)
 | Item[([( Int32, Int32])]) | (Inherited from CellRange.)
 | LeftColumn | (Inherited from CellRange.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumHeight |
 | Parent | (Inherited from CellRange.)
 | ParentTable | (Inherited from CellRange.)
 | RightColumn | (Inherited from CellRange.)
 | SetCustomData(String, Object) | (Inherited from CellRange.)
 | SetDataLink(ObjectId, Boolean) | (Inherited from CellRange.)
 | State | (Inherited from CellRange.)
 | Style | (Inherited from CellRange.)
 | TextHeight | (Inherited from CellRange.)
 | TextStyleId | (Inherited from CellRange.)
 | TopLeft | (Inherited from CellRange.)
 | TopRow | (Inherited from CellRange.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CellRange
 |  | Row


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Row »Height
Declaration Syntax
C# Visual Basic Visual C++
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}


MinimumHeight Property

MinimumHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Row »MinimumHeight
Declaration Syntax
C# Visual Basic Visual C++
public double MinimumHeight { get; }
Public ReadOnly Property MinimumHeight As Double
    Get
public:
property double MinimumHeight {
    double get ();
}


RowsCollection Class

RowsCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RowsCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class RowsCollection : IEnumerable<Row>
Public NotInheritable Class RowsCollection _
    Implements IEnumerable(Of Row)
public ref class RowsCollection sealed : IEnumerable<Row^>
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerableGetEnumerator()()()() |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
RowsCollection


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RowsCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RowsCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<Row> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Row)
public:
virtual IEnumerator<Row^>^ GetEnumerator() sealed


IEnumerableGetEnumerator Method

IEnumerableGetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RowsCollection »IEnumerableGetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
internal IEnumerator IEnumerableGetEnumerator()
Friend Function IEnumerableGetEnumerator As IEnumerator
internal:
virtual IEnumerator^ IEnumerableGetEnumerator() sealed


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RowsCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Row this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Row
    Get
public:
property Row^ default[int index] {
    Row^ get (int index);
}
Parameters
index(Int32)


RowType Enumeration

RowType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RowType
Declaration Syntax
C# Visual Basic Visual C++
public enum RowType
Public Enumeration RowType
public enum class RowType
Members
Member | Description
DataRow |
HeaderRow |
TitleRow |
UnknownRow |


SaveType Enumeration

SaveType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SaveType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::SaveType")]
public enum SaveType
<WrapperAttribute("ZcDb::SaveType")> _
Public Enumeration SaveType
[WrapperAttribute(L"ZcDb::SaveType")]
public enum class SaveType
Members
Member | Description
Save14 |
Save13 |
Save12 |
NoSave |


ScaleEstimationMethod Enumeration

ScaleEstimationMethod Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ScaleEstimationMethod
Declaration Syntax
C# Visual Basic Visual C++
public enum ScaleEstimationMethod
Public Enumeration ScaleEstimationMethod
public enum class ScaleEstimationMethod
Members
Member | Description
ScaleEstMethodUserDefined |
ScaleEstMethodUnity |
ScaleEstMethodReferencePoint |
ScaleEstMethodPrismoidal |


Section Class

Section Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbSection")]
public class Section : Entity
<WrapperAttribute("ZcDbSection")> _
Public Class Section _
    Inherits Entity
[WrapperAttribute(L"ZcDbSection")]
public ref class Section : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Section(Point3dCollection, Vector3d, Vector3d) |
 | Section(Point3dCollection, Vector3d) |
 | Section()()()() |
 | Section(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AddVertex(Int32, Point3d) | Obsolete.
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BottomPlane |
 | Boundary |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateJog(Point3d) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | Elevation |
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GenerateSectionGeometry(Entity, Array%, Array%, Array%, Array%, Array%) |
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetVertex(Int32) | Obsolete.
 | GetVertices(Point3dCollection) | Obsolete.
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height(SectionHeight) |
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HitTest(Point3d) |
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | IndicatorFillColor |
 | IndicatorTransparency |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsLiveSectionEnabled |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Name |
 | Normal |
 | NumVertices | Obsolete.
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RemoveVertex(Int32) | Obsolete.
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetHeight(SectionHeight, Double) |
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Settings |
 | SetVertex(Int32, Point3d) | Obsolete.
 | State |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TopPlane |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VerticalDirection |
 | Vertices | Obsolete.
 | ViewingDirection |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Section


Section Constructor

Section Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Section()()()()
Members
Icon | Member | Description
 | Section(Point3dCollection, Vector3d, Vector3d) |
 | Section(Point3dCollection, Vector3d) |
 | Section()()()() |
 | Section(IntPtr, Boolean) |


Section Constructor

Section Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Section()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Section()
Public Sub New
public:
Section()


Section Constructor (unmanagedPointer, autoDelete)

Section Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Section(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Section(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Section(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Section Constructor (pts, verticalDir)

Section Constructor (pts, verticalDir)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Section(Point3dCollection, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Section(
    Point3dCollection pts,
    Vector3d verticalDir
)
Public Sub New ( _
    pts As Point3dCollection, _
    verticalDir As Vector3d _
)
public:
Section(
    Point3dCollection^ pts,
    Vector3d verticalDir
)
Parameters
pts(Point3dCollection)
verticalDir(Vector3d)


Section Constructor (pts, verticalDir, vecViewingDir)

Section Constructor (pts, verticalDir, vecViewingDir)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Section(Point3dCollection, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Section(
    Point3dCollection pts,
    Vector3d verticalDir,
    Vector3d vecViewingDir
)
Public Sub New ( _
    pts As Point3dCollection, _
    verticalDir As Vector3d, _
    vecViewingDir As Vector3d _
)
public:
Section(
    Point3dCollection^ pts,
    Vector3d verticalDir,
    Vector3d vecViewingDir
)
Parameters
pts(Point3dCollection)
verticalDir(Vector3d)
vecViewingDir(Vector3d)


AddVertex Method (nInsertAt, pt)

AddVertex Method (nInsertAt, pt)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »AddVertex(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Boundary property instead")]
public void AddVertex(
    int nInsertAt,
    Point3d pt
)
<ObsoleteAttribute("Use Boundary property instead")> _
Public Sub AddVertex ( _
    nInsertAt As Integer, _
    pt As Point3d _
)
[ObsoleteAttribute(L"Use Boundary property instead")]
public:
void AddVertex(
    int nInsertAt,
    Point3d pt
)
Parameters
nInsertAt(Int32)
pt(Point3d)


BottomPlane Property

BottomPlane Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »BottomPlane
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double BottomPlane { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property BottomPlane As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double BottomPlane {
    double get ();
    void set (double value);
}


Boundary Property

Boundary Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Boundary
Declaration Syntax
C# Visual Basic Visual C++
public IList<Point3d> Boundary { get; }
Public ReadOnly Property Boundary As IList(Of Point3d)
    Get
public:
property IList<Point3d>^ Boundary {
    IList<Point3d>^ get ();
}


CreateJog Method (ptOnSection)

CreateJog Method (ptOnSection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »CreateJog(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void CreateJog(
    Point3d ptOnSection
)
Public Sub CreateJog ( _
    ptOnSection As Point3d _
)
public:
void CreateJog(
    Point3d ptOnSection
)
Parameters
ptOnSection(Point3d)


Elevation Property

Elevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Elevation
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Elevation { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Elevation As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Elevation {
    double get ();
    void set (double value);
}


GenerateSectionGeometry Method (pEnt, pIntFillEnts, pBackgroundEnts, pForegroundEnts, pFurveTangencyEnts, pCurveTangencyEnts)

GenerateSectionGeometry Method (pEnt, pIntFillEnts, pBackgroundEnts, pForegroundEnts, pFurveTangencyEnts, pCurveTangencyEnts)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »GenerateSectionGeometry(Entity, Array%, Array%, Array%, Array%, Array%)
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateSectionGeometry(
    Entity pEnt,
    out Array pIntFillEnts,
    out Array pBackgroundEnts,
    out Array pForegroundEnts,
    out Array pFurveTangencyEnts,
    out Array pCurveTangencyEnts
)
Public Sub GenerateSectionGeometry ( _
    pEnt As Entity, _
    <OutAttribute> ByRef pIntFillEnts As Array, _
    <OutAttribute> ByRef pBackgroundEnts As Array, _
    <OutAttribute> ByRef pForegroundEnts As Array, _
    <OutAttribute> ByRef pFurveTangencyEnts As Array, _
    <OutAttribute> ByRef pCurveTangencyEnts As Array _
)
public:
void GenerateSectionGeometry(
    Entity^ pEnt,
    [OutAttribute] Array^% pIntFillEnts,
    [OutAttribute] Array^% pBackgroundEnts,
    [OutAttribute] Array^% pForegroundEnts,
    [OutAttribute] Array^% pFurveTangencyEnts,
    [OutAttribute] Array^% pCurveTangencyEnts
)
Parameters
pEnt(Entity)
pIntFillEnts(Array%)
pBackgroundEnts(Array%)
pForegroundEnts(Array%)
pFurveTangencyEnts(Array%)
pCurveTangencyEnts(Array%)


GetVertex Method (nIndex)

GetVertex Method (nIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »GetVertex(Int32)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Boundary property instead")]
public Point3d GetVertex(
    int nIndex
)
<ObsoleteAttribute("Use Boundary property instead")> _
Public Function GetVertex ( _
    nIndex As Integer _
) As Point3d
[ObsoleteAttribute(L"Use Boundary property instead")]
public:
Point3d GetVertex(
    int nIndex
)
Parameters
nIndex(Int32)


GetVertices Method (pts)

GetVertices Method (pts)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »GetVertices(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Boundary property instead")]
public void GetVertices(
    Point3dCollection pts
)
<ObsoleteAttribute("Use Boundary property instead")> _
Public Sub GetVertices ( _
    pts As Point3dCollection _
)
[ObsoleteAttribute(L"Use Boundary property instead")]
public:
void GetVertices(
    Point3dCollection^ pts
)
Parameters
pts(Point3dCollection)


Height Method (nHeightType)

Height Method (nHeightType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Height(SectionHeight)
Declaration Syntax
C# Visual Basic Visual C++
public double Height(
    SectionHeight nHeightType
)
Public Function Height ( _
    nHeightType As SectionHeight _
) As Double
public:
double Height(
    SectionHeight nHeightType
)
Parameters
nHeightType(SectionHeight)


HitTest Method (ptHit)

HitTest Method (ptHit)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »HitTest(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public SectionHitTestInfo HitTest(
    Point3d ptHit
)
Public Function HitTest ( _
    ptHit As Point3d _
) As SectionHitTestInfo
public:
SectionHitTestInfo HitTest(
    Point3d ptHit
)
Parameters
ptHit(Point3d)


IndicatorFillColor Property

IndicatorFillColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »IndicatorFillColor
Declaration Syntax
C# Visual Basic Visual C++
public Color IndicatorFillColor { get; set; }
Public Property IndicatorFillColor As Color
    Get
    Set
public:
property Color^ IndicatorFillColor {
    Color^ get ();
    void set (Color^ value);
}


IndicatorTransparency Property

IndicatorTransparency Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »IndicatorTransparency
Declaration Syntax
C# Visual Basic Visual C++
public int IndicatorTransparency { get; set; }
Public Property IndicatorTransparency As Integer
    Get
    Set
public:
property int IndicatorTransparency {
    int get ();
    void set (int value);
}


IsLiveSectionEnabled Property

IsLiveSectionEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »IsLiveSectionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLiveSectionEnabled { get; set; }
Public Property IsLiveSectionEnabled As Boolean
    Get
    Set
public:
property bool IsLiveSectionEnabled {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; }
Public ReadOnly Property Normal As Vector3d
    Get
public:
property Vector3d Normal {
    Vector3d get ();
}


NumVertices Property

NumVertices Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »NumVertices
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Boundary property instead")]
public int NumVertices { get; }
<ObsoleteAttribute("Use Boundary property instead")> _
Public ReadOnly Property NumVertices As Integer
    Get
[ObsoleteAttribute(L"Use Boundary property instead")]
public:
property int NumVertices {
    int get ();
}


RemoveVertex Method (nIndex)

RemoveVertex Method (nIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »RemoveVertex(Int32)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Boundary property instead")]
public void RemoveVertex(
    int nIndex
)
<ObsoleteAttribute("Use Boundary property instead")> _
Public Sub RemoveVertex ( _
    nIndex As Integer _
)
[ObsoleteAttribute(L"Use Boundary property instead")]
public:
void RemoveVertex(
    int nIndex
)
Parameters
nIndex(Int32)


SetHeight Method (nHeightType, fHeight)

SetHeight Method (nHeightType, fHeight)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »SetHeight(SectionHeight, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHeight(
    SectionHeight nHeightType,
    double fHeight
)
Public Sub SetHeight ( _
    nHeightType As SectionHeight, _
    fHeight As Double _
)
public:
void SetHeight(
    SectionHeight nHeightType,
    double fHeight
)
Parameters
nHeightType(SectionHeight)
fHeight(Double)


Settings Property

Settings Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Settings
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Settings { get; }
Public ReadOnly Property Settings As ObjectId
    Get
public:
property ObjectId Settings {
    ObjectId get ();
}


SetVertex Method (nIndex, pt)

SetVertex Method (nIndex, pt)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »SetVertex(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Boundary property instead")]
public void SetVertex(
    int nIndex,
    Point3d pt
)
<ObsoleteAttribute("Use Boundary property instead")> _
Public Sub SetVertex ( _
    nIndex As Integer, _
    pt As Point3d _
)
[ObsoleteAttribute(L"Use Boundary property instead")]
public:
void SetVertex(
    int nIndex,
    Point3d pt
)
Parameters
nIndex(Int32)
pt(Point3d)


State Property

State Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »State
Declaration Syntax
C# Visual Basic Visual C++
public SectionState State { get; set; }
Public Property State As SectionState
    Get
    Set
public:
property SectionState State {
    SectionState get ();
    void set (SectionState value);
}


TopPlane Property

TopPlane Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »TopPlane
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double TopPlane { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property TopPlane As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double TopPlane {
    double get ();
    void set (double value);
}


VerticalDirection Property

VerticalDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »VerticalDirection
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d VerticalDirection { get; set; }
Public Property VerticalDirection As Vector3d
    Get
    Set
public:
property Vector3d VerticalDirection {
    Vector3d get ();
    void set (Vector3d value);
}


Vertices Property

Vertices Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Vertices
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Boundary property instead")]
public Point3dCollection Vertices { set; }
<ObsoleteAttribute("Use Boundary property instead")> _
Public WriteOnly Property Vertices As Point3dCollection
    Set
[ObsoleteAttribute(L"Use Boundary property instead")]
public:
property Point3dCollection^ Vertices {
    void set (Point3dCollection^ value);
}


ViewingDirection Property

ViewingDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »ViewingDirection
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d ViewingDirection { get; set; }
Public Property ViewingDirection As Vector3d
    Get
    Set
public:
property Vector3d ViewingDirection {
    Vector3d get ();
    void set (Vector3d value);
}


SectionGeneration Enumeration

SectionGeneration Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionGeneration
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbSectionSettings::Generation")]
[FlagsAttribute]
public enum SectionGeneration
<WrapperAttribute("ZcDbSectionSettings::Generation")> _
<FlagsAttribute> _
Public Enumeration SectionGeneration
[WrapperAttribute(L"ZcDbSectionSettings::Generation")]
[FlagsAttribute]
public enum class SectionGeneration
Members
Member | Description
DestinationFile |
DestinationReplaceBlock |
DestinationNewBlock |
SourceSelectedObjects |
SourceAllObjects |


SectionGeometry Enumeration

SectionGeometry Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionGeometry
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
[WrapperAttribute("ZcDbSectionSettings::Geometry")]
public enum SectionGeometry
<FlagsAttribute> _
<WrapperAttribute("ZcDbSectionSettings::Geometry")> _
Public Enumeration SectionGeometry
[FlagsAttribute]
[WrapperAttribute(L"ZcDbSectionSettings::Geometry")]
public enum class SectionGeometry
Members
Member | Description
CurveTangencyLines |
ForegroundGeometry |
BackgroundGeometry |
IntersectionFill |
IntersectionBoundary |


SectionHeight Enumeration

SectionHeight Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionHeight
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbSection::Height")]
public enum SectionHeight
<WrapperAttribute("ZcDbSection::Height")> _
Public Enumeration SectionHeight
[WrapperAttribute(L"ZcDbSection::Height")]
public enum class SectionHeight
Members
Member | Description
HeightBelowSectionLine |
HeightAboveSectionLine |


SectionHitTestInfo Structure

SectionHitTestInfo Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionHitTestInfo
Declaration Syntax
C# Visual Basic Visual C++
public struct SectionHitTestInfo
Public Structure SectionHitTestInfo
public value class SectionHitTestInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Index |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PtOnSegment |
 | SubItem |
 | ToString()()()() | (Inherited from ValueType.)


Index Property

Index Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionHitTestInfo »Index
Declaration Syntax
C# Visual Basic Visual C++
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}


PtOnSegment Property

PtOnSegment Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionHitTestInfo »PtOnSegment
Declaration Syntax
C# Visual Basic Visual C++
public Point3d PtOnSegment { get; }
Public ReadOnly Property PtOnSegment As Point3d
    Get
public:
property Point3d PtOnSegment {
    Point3d get ();
}


SubItem Property

SubItem Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionHitTestInfo »SubItem
Declaration Syntax
C# Visual Basic Visual C++
public SectionSubItem SubItem { get; }
Public ReadOnly Property SubItem As SectionSubItem
    Get
public:
property SectionSubItem SubItem {
    SectionSubItem get ();
}


SectionManager Class

SectionManager Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSectionManager")]
public class SectionManager : DBObject,
    IEnumerable
<WrapperAttribute("AcDbSectionManager")> _
Public Class SectionManager _
    Inherits DBObject _
    Implements IEnumerable
[WrapperAttribute(L"AcDbSectionManager")]
public ref class SectionManager : public DBObject,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SectionManager()()()() |
 | SectionManager(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSection(String) |
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetUniqueSectionName(String) |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | LiveSection |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | NumSections |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SectionManager


SectionManager Constructor

SectionManager Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »SectionManager()()()()
Members
Icon | Member | Description
 | SectionManager()()()() |
 | SectionManager(IntPtr, Boolean) |


SectionManager Constructor

SectionManager Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »SectionManager()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SectionManager()
Public Sub New
public:
SectionManager()


SectionManager Constructor (unmanagedPointer, autoDelete)

SectionManager Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »SectionManager(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal SectionManager(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
SectionManager(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


GetSection Method (pszName)

GetSection Method (pszName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »GetSection(String)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetSection(
    string pszName
)
Public Function GetSection ( _
    pszName As String _
) As ObjectId
public:
ObjectId GetSection(
    String^ pszName
)
Parameters
pszName(String)


GetUniqueSectionName Method (pszBaseName)

GetUniqueSectionName Method (pszBaseName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »GetUniqueSectionName(String)
Declaration Syntax
C# Visual Basic Visual C++
public string GetUniqueSectionName(
    string pszBaseName
)
Public Function GetUniqueSectionName ( _
    pszBaseName As String _
) As String
public:
String^ GetUniqueSectionName(
    String^ pszBaseName
)
Parameters
pszBaseName(String)


LiveSection Property

LiveSection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »LiveSection
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LiveSection { get; }
Public ReadOnly Property LiveSection As ObjectId
    Get
public:
property ObjectId LiveSection {
    ObjectId get ();
}


NumSections Property

NumSections Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »NumSections
Declaration Syntax
C# Visual Basic Visual C++
public int NumSections { get; }
Public ReadOnly Property NumSections As Integer
    Get
public:
property int NumSections {
    int get ();
}


SectionSettings Class

SectionSettings Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSectionSettings")]
public class SectionSettings : DBObject
<WrapperAttribute("AcDbSectionSettings")> _
Public Class SectionSettings _
    Inherits DBObject
[WrapperAttribute(L"AcDbSectionSettings")]
public ref class SectionSettings : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SectionSettings()()()() |
 | SectionSettings(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Color(SectionType, SectionGeometry) |
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CurrentSectionType |
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DestinationBlock(SectionType) |
 | DestinationFile(SectionType) |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DivisionLines(SectionType, SectionGeometry) |
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | EdgeTransparency(SectionType, SectionGeometry) |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceTransparency(SectionType, SectionGeometry) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GenerationOptions(SectionType) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetHatchPatternName(SectionType, SectionGeometry) |
 | GetHatchPatternType(SectionType, SectionGeometry) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSourceObjects(SectionType, ObjectIdCollection) |
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | HatchAngle(SectionType, SectionGeometry) |
 | HatchScale(SectionType, SectionGeometry) |
 | HatchSpacing(SectionType, SectionGeometry) |
 | HatchVisibility(SectionType, SectionGeometry) |
 | HiddenLine(SectionType, SectionGeometry) |
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer(SectionType, SectionGeometry) |
 | Linetype(SectionType, SectionGeometry) |
 | LinetypeScale(SectionType, SectionGeometry) |
 | LineWeight(SectionType, SectionGeometry) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName(SectionType, SectionGeometry) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Reset(SectionType) |
 | Reset()()()() |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetColor(SectionType, SectionGeometry, Color) |
 | SetDestinationBlock(SectionType, ObjectId) |
 | SetDestinationFile(SectionType, String) |
 | SetDivisionLines(SectionType, SectionGeometry, Boolean) |
 | SetEdgeTransparency(SectionType, SectionGeometry, Int32) |
 | SetFaceTransparency(SectionType, SectionGeometry, Int32) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGenerationOptions(SectionType, SectionGeneration) |
 | SetHatchAngle(SectionType, SectionGeometry, Double) |
 | SetHatchPatternName(SectionType, SectionGeometry, String) |
 | SetHatchPatternType(SectionType, SectionGeometry, HatchPatternType) |
 | SetHatchScale(SectionType, SectionGeometry, Double) |
 | SetHatchSpacing(SectionType, SectionGeometry, Double) |
 | SetHatchVisibility(SectionType, SectionGeometry, Boolean) |
 | SetHiddenLine(SectionType, SectionGeometry, Boolean) |
 | SetLayer(SectionType, SectionGeometry, String) |
 | SetLinetype(SectionType, SectionGeometry, String) |
 | SetLinetypeScale(SectionType, SectionGeometry, Double) |
 | SetLineWeight(SectionType, SectionGeometry, LineWeight) |
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPlotStyleName(SectionType, SectionGeometry, String) |
 | SetSourceObjects(SectionType, ObjectIdCollection) |
 | SetVisibility(SectionType, SectionGeometry, Boolean) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visibility(SectionType, SectionGeometry) |
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SectionSettings


SectionSettings Constructor

SectionSettings Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SectionSettings()()()()
Members
Icon | Member | Description
 | SectionSettings()()()() |
 | SectionSettings(IntPtr, Boolean) |


SectionSettings Constructor

SectionSettings Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SectionSettings()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SectionSettings()
Public Sub New
public:
SectionSettings()


SectionSettings Constructor (unmanagedPointer, autoDelete)

SectionSettings Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SectionSettings(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal SectionSettings(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
SectionSettings(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Color Method (nSecType, nGeometry)

Color Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »Color(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public Color Color(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function Color ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Color
public:
Color^ Color(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


CurrentSectionType Property

CurrentSectionType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »CurrentSectionType
Declaration Syntax
C# Visual Basic Visual C++
public SectionType CurrentSectionType { get; set; }
Public Property CurrentSectionType As SectionType
    Get
    Set
public:
property SectionType CurrentSectionType {
    SectionType get ();
    void set (SectionType value);
}


DestinationBlock Method (nSecType)

DestinationBlock Method (nSecType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »DestinationBlock(SectionType)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId DestinationBlock(
    SectionType nSecType
)
Public Function DestinationBlock ( _
    nSecType As SectionType _
) As ObjectId
public:
ObjectId DestinationBlock(
    SectionType nSecType
)
Parameters
nSecType(SectionType)


DestinationFile Method (nSecType)

DestinationFile Method (nSecType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »DestinationFile(SectionType)
Declaration Syntax
C# Visual Basic Visual C++
public string DestinationFile(
    SectionType nSecType
)
Public Function DestinationFile ( _
    nSecType As SectionType _
) As String
public:
String^ DestinationFile(
    SectionType nSecType
)
Parameters
nSecType(SectionType)


DivisionLines Method (nSecType, nGeometry)

DivisionLines Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »DivisionLines(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public bool DivisionLines(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function DivisionLines ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Boolean
public:
bool DivisionLines(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


EdgeTransparency Method (nSecType, nGeometry)

EdgeTransparency Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »EdgeTransparency(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public int EdgeTransparency(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function EdgeTransparency ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Integer
public:
int EdgeTransparency(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


FaceTransparency Method (nSecType, nGeometry)

FaceTransparency Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »FaceTransparency(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public int FaceTransparency(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function FaceTransparency ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Integer
public:
int FaceTransparency(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


GenerationOptions Method (nSecType)

GenerationOptions Method (nSecType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »GenerationOptions(SectionType)
Declaration Syntax
C# Visual Basic Visual C++
public SectionGeneration GenerationOptions(
    SectionType nSecType
)
Public Function GenerationOptions ( _
    nSecType As SectionType _
) As SectionGeneration
public:
SectionGeneration GenerationOptions(
    SectionType nSecType
)
Parameters
nSecType(SectionType)


GetHatchPatternName Method (nSecType, nGeometry)

GetHatchPatternName Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »GetHatchPatternName(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public string GetHatchPatternName(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function GetHatchPatternName ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As String
public:
String^ GetHatchPatternName(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


GetHatchPatternType Method (nSecType, nGeometry)

GetHatchPatternType Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »GetHatchPatternType(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public HatchPatternType GetHatchPatternType(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function GetHatchPatternType ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As HatchPatternType
public:
HatchPatternType GetHatchPatternType(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


GetSourceObjects Method (nSecType, ids)

GetSourceObjects Method (nSecType, ids)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »GetSourceObjects(SectionType, ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void GetSourceObjects(
    SectionType nSecType,
    ObjectIdCollection ids
)
Public Sub GetSourceObjects ( _
    nSecType As SectionType, _
    ids As ObjectIdCollection _
)
public:
void GetSourceObjects(
    SectionType nSecType,
    ObjectIdCollection^ ids
)
Parameters
nSecType(SectionType)
ids(ObjectIdCollection)


HatchAngle Method (nSecType, nGeometry)

HatchAngle Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »HatchAngle(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public double HatchAngle(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function HatchAngle ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Double
public:
double HatchAngle(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


HatchScale Method (nSecType, nGeometry)

HatchScale Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »HatchScale(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public double HatchScale(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function HatchScale ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Double
public:
double HatchScale(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


HatchSpacing Method (nSecType, nGeometry)

HatchSpacing Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »HatchSpacing(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public double HatchSpacing(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function HatchSpacing ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Double
public:
double HatchSpacing(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


HatchVisibility Method (nSecType, nGeometry)

HatchVisibility Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »HatchVisibility(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public bool HatchVisibility(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function HatchVisibility ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Boolean
public:
bool HatchVisibility(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


HiddenLine Method (nSecType, nGeometry)

HiddenLine Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »HiddenLine(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public bool HiddenLine(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function HiddenLine ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Boolean
public:
bool HiddenLine(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


Layer Method (nSecType, nGeometry)

Layer Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »Layer(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public string Layer(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function Layer ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As String
public:
String^ Layer(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


Linetype Method (nSecType, nGeometry)

Linetype Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »Linetype(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public string Linetype(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function Linetype ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As String
public:
String^ Linetype(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


LinetypeScale Method (nSecType, nGeometry)

LinetypeScale Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »LinetypeScale(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public double LinetypeScale(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function LinetypeScale ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Double
public:
double LinetypeScale(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


LineWeight Method (nSecType, nGeometry)

LineWeight Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »LineWeight(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight LineWeight(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function LineWeight ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As LineWeight
public:
LineWeight LineWeight(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


PlotStyleName Method (nSecType, nGeometry)

PlotStyleName Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »PlotStyleName(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public string PlotStyleName(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function PlotStyleName ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As String
public:
String^ PlotStyleName(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »Reset()()()()
Members
Icon | Member | Description
 | Reset(SectionType) |
 | Reset()()()() |


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
void Reset()


Reset Method (nSecType)

Reset Method (nSecType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »Reset(SectionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Reset(
    SectionType nSecType
)
Public Sub Reset ( _
    nSecType As SectionType _
)
public:
void Reset(
    SectionType nSecType
)
Parameters
nSecType(SectionType)


SetColor Method (nSecType, nGeometry, color)

SetColor Method (nSecType, nGeometry, color)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetColor(SectionType, SectionGeometry, Color)
Declaration Syntax
C# Visual Basic Visual C++
public void SetColor(
    SectionType nSecType,
    SectionGeometry nGeometry,
    Color color
)
Public Sub SetColor ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    color As Color _
)
public:
void SetColor(
    SectionType nSecType,
    SectionGeometry nGeometry,
    Color^ color
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
color(Color)


SetDestinationBlock Method (nSecType, id)

SetDestinationBlock Method (nSecType, id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetDestinationBlock(SectionType, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDestinationBlock(
    SectionType nSecType,
    ObjectId id
)
Public Sub SetDestinationBlock ( _
    nSecType As SectionType, _
    id As ObjectId _
)
public:
void SetDestinationBlock(
    SectionType nSecType,
    ObjectId id
)
Parameters
nSecType(SectionType)
id(ObjectId)


SetDestinationFile Method (nSecType, pszFileName)

SetDestinationFile Method (nSecType, pszFileName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetDestinationFile(SectionType, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDestinationFile(
    SectionType nSecType,
    string pszFileName
)
Public Sub SetDestinationFile ( _
    nSecType As SectionType, _
    pszFileName As String _
)
public:
void SetDestinationFile(
    SectionType nSecType,
    String^ pszFileName
)
Parameters
nSecType(SectionType)
pszFileName(String)


SetDivisionLines Method (nSecType, nGeometry, bShow)

SetDivisionLines Method (nSecType, nGeometry, bShow)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetDivisionLines(SectionType, SectionGeometry, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDivisionLines(
    SectionType nSecType,
    SectionGeometry nGeometry,
    bool bShow
)
Public Sub SetDivisionLines ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    bShow As Boolean _
)
public:
void SetDivisionLines(
    SectionType nSecType,
    SectionGeometry nGeometry,
    bool bShow
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
bShow(Boolean)


SetEdgeTransparency Method (nSecType, nGeometry, nTransparency)

SetEdgeTransparency Method (nSecType, nGeometry, nTransparency)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetEdgeTransparency(SectionType, SectionGeometry, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SetEdgeTransparency(
    SectionType nSecType,
    SectionGeometry nGeometry,
    int nTransparency
)
Public Sub SetEdgeTransparency ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    nTransparency As Integer _
)
public:
void SetEdgeTransparency(
    SectionType nSecType,
    SectionGeometry nGeometry,
    int nTransparency
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
nTransparency(Int32)


SetFaceTransparency Method (nSecType, nGeometry, nTransparency)

SetFaceTransparency Method (nSecType, nGeometry, nTransparency)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetFaceTransparency(SectionType, SectionGeometry, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFaceTransparency(
    SectionType nSecType,
    SectionGeometry nGeometry,
    int nTransparency
)
Public Sub SetFaceTransparency ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    nTransparency As Integer _
)
public:
void SetFaceTransparency(
    SectionType nSecType,
    SectionGeometry nGeometry,
    int nTransparency
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
nTransparency(Int32)


SetGenerationOptions Method (nSecType, nOptions)

SetGenerationOptions Method (nSecType, nOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetGenerationOptions(SectionType, SectionGeneration)
Declaration Syntax
C# Visual Basic Visual C++
public void SetGenerationOptions(
    SectionType nSecType,
    SectionGeneration nOptions
)
Public Sub SetGenerationOptions ( _
    nSecType As SectionType, _
    nOptions As SectionGeneration _
)
public:
void SetGenerationOptions(
    SectionType nSecType,
    SectionGeneration nOptions
)
Parameters
nSecType(SectionType)
nOptions(SectionGeneration)


SetHatchAngle Method (nSecType, nGeometry, fAngle)

SetHatchAngle Method (nSecType, nGeometry, fAngle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetHatchAngle(SectionType, SectionGeometry, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHatchAngle(
    SectionType nSecType,
    SectionGeometry nGeometry,
    double fAngle
)
Public Sub SetHatchAngle ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    fAngle As Double _
)
public:
void SetHatchAngle(
    SectionType nSecType,
    SectionGeometry nGeometry,
    double fAngle
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
fAngle(Double)


SetHatchPatternName Method (nSecType, nGeometry, sNewName)

SetHatchPatternName Method (nSecType, nGeometry, sNewName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetHatchPatternName(SectionType, SectionGeometry, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHatchPatternName(
    SectionType nSecType,
    SectionGeometry nGeometry,
    string sNewName
)
Public Sub SetHatchPatternName ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    sNewName As String _
)
public:
void SetHatchPatternName(
    SectionType nSecType,
    SectionGeometry nGeometry,
    String^ sNewName
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
sNewName(String)


SetHatchPatternType Method (nSecType, nGeometry, nPatternType)

SetHatchPatternType Method (nSecType, nGeometry, nPatternType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetHatchPatternType(SectionType, SectionGeometry, HatchPatternType)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHatchPatternType(
    SectionType nSecType,
    SectionGeometry nGeometry,
    HatchPatternType nPatternType
)
Public Sub SetHatchPatternType ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    nPatternType As HatchPatternType _
)
public:
void SetHatchPatternType(
    SectionType nSecType,
    SectionGeometry nGeometry,
    HatchPatternType nPatternType
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
nPatternType(HatchPatternType)


SetHatchScale Method (nSecType, nGeometry, fScale)

SetHatchScale Method (nSecType, nGeometry, fScale)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetHatchScale(SectionType, SectionGeometry, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHatchScale(
    SectionType nSecType,
    SectionGeometry nGeometry,
    double fScale
)
Public Sub SetHatchScale ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    fScale As Double _
)
public:
void SetHatchScale(
    SectionType nSecType,
    SectionGeometry nGeometry,
    double fScale
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
fScale(Double)


SetHatchSpacing Method (nSecType, nGeometry, fSpacing)

SetHatchSpacing Method (nSecType, nGeometry, fSpacing)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetHatchSpacing(SectionType, SectionGeometry, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHatchSpacing(
    SectionType nSecType,
    SectionGeometry nGeometry,
    double fSpacing
)
Public Sub SetHatchSpacing ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    fSpacing As Double _
)
public:
void SetHatchSpacing(
    SectionType nSecType,
    SectionGeometry nGeometry,
    double fSpacing
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
fSpacing(Double)


SetHatchVisibility Method (nSecType, nGeometry, bVisible)

SetHatchVisibility Method (nSecType, nGeometry, bVisible)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetHatchVisibility(SectionType, SectionGeometry, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHatchVisibility(
    SectionType nSecType,
    SectionGeometry nGeometry,
    bool bVisible
)
Public Sub SetHatchVisibility ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    bVisible As Boolean _
)
public:
void SetHatchVisibility(
    SectionType nSecType,
    SectionGeometry nGeometry,
    bool bVisible
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
bVisible(Boolean)


SetHiddenLine Method (nSecType, nGeometry, bHiddenLine)

SetHiddenLine Method (nSecType, nGeometry, bHiddenLine)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetHiddenLine(SectionType, SectionGeometry, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetHiddenLine(
    SectionType nSecType,
    SectionGeometry nGeometry,
    bool bHiddenLine
)
Public Sub SetHiddenLine ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    bHiddenLine As Boolean _
)
public:
void SetHiddenLine(
    SectionType nSecType,
    SectionGeometry nGeometry,
    bool bHiddenLine
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
bHiddenLine(Boolean)


SetLayer Method (nSecType, nGeometry, pszLayer)

SetLayer Method (nSecType, nGeometry, pszLayer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetLayer(SectionType, SectionGeometry, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayer(
    SectionType nSecType,
    SectionGeometry nGeometry,
    string pszLayer
)
Public Sub SetLayer ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    pszLayer As String _
)
public:
void SetLayer(
    SectionType nSecType,
    SectionGeometry nGeometry,
    String^ pszLayer
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
pszLayer(String)


SetLinetype Method (nSecType, nGeometry, pszLinetype)

SetLinetype Method (nSecType, nGeometry, pszLinetype)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetLinetype(SectionType, SectionGeometry, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLinetype(
    SectionType nSecType,
    SectionGeometry nGeometry,
    string pszLinetype
)
Public Sub SetLinetype ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    pszLinetype As String _
)
public:
void SetLinetype(
    SectionType nSecType,
    SectionGeometry nGeometry,
    String^ pszLinetype
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
pszLinetype(String)


SetLinetypeScale Method (nSecType, nGeometry, fScale)

SetLinetypeScale Method (nSecType, nGeometry, fScale)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetLinetypeScale(SectionType, SectionGeometry, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLinetypeScale(
    SectionType nSecType,
    SectionGeometry nGeometry,
    double fScale
)
Public Sub SetLinetypeScale ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    fScale As Double _
)
public:
void SetLinetypeScale(
    SectionType nSecType,
    SectionGeometry nGeometry,
    double fScale
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
fScale(Double)


SetLineWeight Method (nSecType, nGeometry, nLineWeight)

SetLineWeight Method (nSecType, nGeometry, nLineWeight)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetLineWeight(SectionType, SectionGeometry, LineWeight)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLineWeight(
    SectionType nSecType,
    SectionGeometry nGeometry,
    LineWeight nLineWeight
)
Public Sub SetLineWeight ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    nLineWeight As LineWeight _
)
public:
void SetLineWeight(
    SectionType nSecType,
    SectionGeometry nGeometry,
    LineWeight nLineWeight
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
nLineWeight(LineWeight)


SetPlotStyleName Method (nSecType, nGeometry, pszPlotStyleName)

SetPlotStyleName Method (nSecType, nGeometry, pszPlotStyleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetPlotStyleName(SectionType, SectionGeometry, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPlotStyleName(
    SectionType nSecType,
    SectionGeometry nGeometry,
    string pszPlotStyleName
)
Public Sub SetPlotStyleName ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    pszPlotStyleName As String _
)
public:
void SetPlotStyleName(
    SectionType nSecType,
    SectionGeometry nGeometry,
    String^ pszPlotStyleName
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
pszPlotStyleName(String)


SetSourceObjects Method (nSecType, ids)

SetSourceObjects Method (nSecType, ids)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetSourceObjects(SectionType, ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void SetSourceObjects(
    SectionType nSecType,
    ObjectIdCollection ids
)
Public Sub SetSourceObjects ( _
    nSecType As SectionType, _
    ids As ObjectIdCollection _
)
public:
void SetSourceObjects(
    SectionType nSecType,
    ObjectIdCollection^ ids
)
Parameters
nSecType(SectionType)
ids(ObjectIdCollection)


SetVisibility Method (nSecType, nGeometry, bVisible)

SetVisibility Method (nSecType, nGeometry, bVisible)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetVisibility(SectionType, SectionGeometry, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetVisibility(
    SectionType nSecType,
    SectionGeometry nGeometry,
    bool bVisible
)
Public Sub SetVisibility ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry, _
    bVisible As Boolean _
)
public:
void SetVisibility(
    SectionType nSecType,
    SectionGeometry nGeometry,
    bool bVisible
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)
bVisible(Boolean)


Visibility Method (nSecType, nGeometry)

Visibility Method (nSecType, nGeometry)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »Visibility(SectionType, SectionGeometry)
Declaration Syntax
C# Visual Basic Visual C++
public bool Visibility(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Public Function Visibility ( _
    nSecType As SectionType, _
    nGeometry As SectionGeometry _
) As Boolean
public:
bool Visibility(
    SectionType nSecType,
    SectionGeometry nGeometry
)
Parameters
nSecType(SectionType)
nGeometry(SectionGeometry)


SectionState Enumeration

SectionState Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionState
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbSection::State")]
public enum SectionState
<WrapperAttribute("ZcDbSection::State")> _
Public Enumeration SectionState
[WrapperAttribute(L"ZcDbSection::State")]
public enum class SectionState
Members
Member | Description
Volume |
Boundary |
Plane |


SectionSubItem Enumeration

SectionSubItem Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSubItem
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbSection::SubItem")]
public enum SectionSubItem
<WrapperAttribute("ZcDbSection::SubItem")> _
Public Enumeration SectionSubItem
[WrapperAttribute(L"ZcDbSection::SubItem")]
public enum class SectionSubItem
Members
Member | Description
VerticalLineBottom |
VerticalLineTop |
BackLineBottom |
BackLineTop |
BackLine |
SectionLineBottom |
SectionLineTop |
SectionLine |
SectionSubItemNone |


SectionType Enumeration

SectionType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbSectionSettings::SectionType")]
[FlagsAttribute]
public enum SectionType
<WrapperAttribute("ZcDbSectionSettings::SectionType")> _
<FlagsAttribute> _
Public Enumeration SectionType
[WrapperAttribute(L"ZcDbSectionSettings::SectionType")]
[FlagsAttribute]
public enum class SectionType
Members
Member | Description
Section3d |
Section2d |
LiveSection |


SecurityActions Enumeration

SecurityActions Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityActions
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum SecurityActions
<FlagsAttribute> _
Public Enumeration SecurityActions
[FlagsAttribute]
public enum class SecurityActions
Members
Member | Description
SignData |
EncryptProperties |
EncryptData |
AddTimeStamp |


SecurityAlgorithm Enumeration

SecurityAlgorithm Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityAlgorithm
Declaration Syntax
C# Visual Basic Visual C++
public enum SecurityAlgorithm
Public Enumeration SecurityAlgorithm
public enum class SecurityAlgorithm
Members
Member | Description
RC4 |


SecurityParameters Class

SecurityParameters Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("SecurityParams")]
public sealed class SecurityParameters
<WrapperAttribute("SecurityParams")> _
Public NotInheritable Class SecurityParameters
[WrapperAttribute(L"SecurityParams")]
public ref class SecurityParameters sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityParameters(String, String, String, String, String, String, String, SecurityActions, SecurityAlgorithm, UInt32, UInt32) |
 | SecurityParameters()()()() | Obsolete.
 | Action |
 | Algorithm |
 | Comment |
 | Equality(SecurityParameters, SecurityParameters) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides Object.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(SecurityParameters, SecurityParameters) |
 | Issuer |
 | KeyLength |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Password |
 | ProviderName |
 | ProviderType |
 | SerialNumber |
 | Subject |
 | TimeServer |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
SecurityParameters


SecurityParameters Constructor

SecurityParameters Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »SecurityParameters()()()()
Members
Icon | Member | Description
 | SecurityParameters(String, String, String, String, String, String, String, SecurityActions, SecurityAlgorithm, UInt32, UInt32) |
 | SecurityParameters()()()() | Obsolete.


SecurityParameters Constructor

SecurityParameters Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »SecurityParameters()()()()
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use other overloads.", true)]
public SecurityParameters()
<ObsoleteAttribute("Use other overloads.", True)> _
Public Sub New
[ObsoleteAttribute(L"Use other overloads.", true)]
public:
SecurityParameters()


SecurityParameters Constructor (password, providerName, subject, issuer, serialNumber, comment, timeServer, actions, algorithm, keyLength, providerType)

SecurityParameters Constructor (password, providerName, subject, issuer, serialNumber, comment, timeServer, actions, algorithm, keyLength, providerType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »SecurityParameters(String, String, String, String, String, String, String, SecurityActions, SecurityAlgorithm, UInt32, UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public SecurityParameters(
    string password,
    string providerName,
    string subject,
    string issuer,
    string serialNumber,
    string comment,
    string timeServer,
    SecurityActions actions,
    SecurityAlgorithm algorithm,
    uint keyLength,
    uint providerType
)
Public Sub New ( _
    password As String, _
    providerName As String, _
    subject As String, _
    issuer As String, _
    serialNumber As String, _
    comment As String, _
    timeServer As String, _
    actions As SecurityActions, _
    algorithm As SecurityAlgorithm, _
    keyLength As UInteger, _
    providerType As UInteger _
)
public:
SecurityParameters(
    String^ password,
    String^ providerName,
    String^ subject,
    String^ issuer,
    String^ serialNumber,
    String^ comment,
    String^ timeServer,
    SecurityActions actions,
    SecurityAlgorithm algorithm,
    unsigned int keyLength,
    unsigned int providerType
)
Parameters
password(String)
providerName(String)
subject(String)
issuer(String)
serialNumber(String)
comment(String)
timeServer(String)
actions(SecurityActions)
algorithm(SecurityAlgorithm)
keyLength(UInt32)
providerType(UInt32)


Action Property

Action Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »Action
Declaration Syntax
C# Visual Basic Visual C++
public SecurityActions Action { get; set; }
Public Property Action As SecurityActions
    Get
    Set
public:
property SecurityActions Action {
    SecurityActions get ();
    void set (SecurityActions value);
}


Algorithm Property

Algorithm Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »Algorithm
Declaration Syntax
C# Visual Basic Visual C++
public SecurityAlgorithm Algorithm { get; set; }
Public Property Algorithm As SecurityAlgorithm
    Get
    Set
public:
property SecurityAlgorithm Algorithm {
    SecurityAlgorithm get ();
    void set (SecurityAlgorithm value);
}


Comment Property

Comment Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »Comment
Declaration Syntax
C# Visual Basic Visual C++
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »Equality(SecurityParameters, SecurityParameters)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    SecurityParameters a,
    SecurityParameters b
)
Public Shared Operator = ( _
    a As SecurityParameters, _
    b As SecurityParameters _
) As Boolean
public:
static bool operator ==(
    SecurityParameters^ a,
    SecurityParameters^ b
)
Parameters
a(SecurityParameters)
b(SecurityParameters)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »Inequality(SecurityParameters, SecurityParameters)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    SecurityParameters a,
    SecurityParameters b
)
Public Shared Operator <> ( _
    a As SecurityParameters, _
    b As SecurityParameters _
) As Boolean
public:
static bool operator !=(
    SecurityParameters^ a,
    SecurityParameters^ b
)
Parameters
a(SecurityParameters)
b(SecurityParameters)


Issuer Property

Issuer Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »Issuer
Declaration Syntax
C# Visual Basic Visual C++
public string Issuer { get; set; }
Public Property Issuer As String
    Get
    Set
public:
property String^ Issuer {
    String^ get ();
    void set (String^ value);
}


KeyLength Property

KeyLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »KeyLength
Declaration Syntax
C# Visual Basic Visual C++
public int KeyLength { get; set; }
Public Property KeyLength As Integer
    Get
    Set
public:
property int KeyLength {
    int get ();
    void set (int value);
}


Password Property

Password Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »Password
Declaration Syntax
C# Visual Basic Visual C++
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}


ProviderName Property

ProviderName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »ProviderName
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderName { get; set; }
Public Property ProviderName As String
    Get
    Set
public:
property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}


ProviderType Property

ProviderType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »ProviderType
Declaration Syntax
C# Visual Basic Visual C++
public int ProviderType { get; set; }
Public Property ProviderType As Integer
    Get
    Set
public:
property int ProviderType {
    int get ();
    void set (int value);
}


SerialNumber Property

SerialNumber Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »SerialNumber
Declaration Syntax
C# Visual Basic Visual C++
public string SerialNumber { get; set; }
Public Property SerialNumber As String
    Get
    Set
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}


Subject Property

Subject Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »Subject
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}


TimeServer Property

TimeServer Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »TimeServer
Declaration Syntax
C# Visual Basic Visual C++
public string TimeServer { get; set; }
Public Property TimeServer As String
    Get
    Set
public:
property String^ TimeServer {
    String^ get ();
    void set (String^ value);
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SecurityParameters »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


SegmentType Enumeration

SegmentType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SegmentType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbPolyline::SegType")]
public enum SegmentType
<WrapperAttribute("ZcDbPolyline::SegType")> _
Public Enumeration SegmentType
[WrapperAttribute(L"ZcDbPolyline::SegType")]
public enum class SegmentType
Members
Member | Description
Arc |
Empty |
Point |
Coincident |
Line |


SelectType Enumeration

SelectType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SelectType
Declaration Syntax
C# Visual Basic Visual C++
public enum SelectType
Public Enumeration SelectType
public enum class SelectType
Members
Member | Description
Window |
Crossing |


SequenceEnd Class

SequenceEnd Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSequenceEnd")]
public class SequenceEnd : Entity
<WrapperAttribute("AcDbSequenceEnd")> _
Public Class SequenceEnd _
    Inherits Entity
[WrapperAttribute(L"AcDbSequenceEnd")]
public ref class SequenceEnd : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SequenceEnd()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | SequenceEnd


SequenceEnd Constructor

SequenceEnd Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »SequenceEnd()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SequenceEnd()
Public Sub New
public:
SequenceEnd()


ShadePlotResLevel Enumeration

ShadePlotResLevel Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ShadePlotResLevel
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbPlotSettings::ShadePlotResLevel")]
public enum ShadePlotResLevel
<WrapperAttribute("ZcDbPlotSettings::ShadePlotResLevel")> _
Public Enumeration ShadePlotResLevel
[WrapperAttribute(L"ZcDbPlotSettings::ShadePlotResLevel")]
public enum class ShadePlotResLevel
Members
Member | Description
Custom |
Maximum |
Presentation |
Normal |
Preview |
Draft |


ShadePlotType Enumeration

ShadePlotType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ShadePlotType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbViewport::ShadePlotType")]
public enum ShadePlotType
<WrapperAttribute("ZcDbViewport::ShadePlotType")> _
Public Enumeration ShadePlotType
[WrapperAttribute(L"ZcDbViewport::ShadePlotType")]
public enum class ShadePlotType
Members
Member | Description
VisualStyle |
RenderPreset |
Rendered |
Hidden |
AsDisplayed |
Wireframe |


Shape Class

Shape Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbShape")]
public class Shape : Entity
<WrapperAttribute("AcDbShape")> _
Public Class Shape _
    Inherits Entity
[WrapperAttribute(L"AcDbShape")]
public ref class Shape : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Shape(Point3d, Double, Double, Double) |
 | Shape()()()() |
 | Shape(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Name |
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | Oblique |
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | ShapeIndex |
 | ShapeNumber |
 | Size |
 | StyleId |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WidthFactor |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Shape


Shape Constructor

Shape Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Shape()()()()
Members
Icon | Member | Description
 | Shape(Point3d, Double, Double, Double) |
 | Shape()()()() |
 | Shape(IntPtr, Boolean) |


Shape Constructor

Shape Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Shape()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Shape()
Public Sub New
public:
Shape()


Shape Constructor (unmanagedPointer, autoDelete)

Shape Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Shape(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Shape(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Shape(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Shape Constructor (position, size, rotation, widthFactor)

Shape Constructor (position, size, rotation, widthFactor)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Shape(Point3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Shape(
    Point3d position,
    double size,
    double rotation,
    double widthFactor
)
Public Sub New ( _
    position As Point3d, _
    size As Double, _
    rotation As Double, _
    widthFactor As Double _
)
public:
Shape(
    Point3d position,
    double size,
    double rotation,
    double widthFactor
)
Parameters
position(Point3d)
size(Double)
rotation(Double)
widthFactor(Double)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


Oblique Property

Oblique Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Oblique
Declaration Syntax
C# Visual Basic Visual C++
public double Oblique { get; set; }
Public Property Oblique As Double
    Get
    Set
public:
property double Oblique {
    double get ();
    void set (double value);
}


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Position
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Position { get; set; }
Public Property Position As Point3d
    Get
    Set
public:
property Point3d Position {
    Point3d get ();
    void set (Point3d value);
}


Rotation Property

Rotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Rotation
Declaration Syntax
C# Visual Basic Visual C++
public double Rotation { get; set; }
Public Property Rotation As Double
    Get
    Set
public:
property double Rotation {
    double get ();
    void set (double value);
}


ShapeIndex Property

ShapeIndex Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »ShapeIndex
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ShapeIndex { get; set; }
Public Property ShapeIndex As ObjectId
    Get
    Set
public:
property ObjectId ShapeIndex {
    ObjectId get ();
    void set (ObjectId value);
}


ShapeNumber Property

ShapeNumber Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »ShapeNumber
Declaration Syntax
C# Visual Basic Visual C++
public short ShapeNumber { get; set; }
Public Property ShapeNumber As Short
    Get
    Set
public:
property short ShapeNumber {
    short get ();
    void set (short value);
}


Size Property

Size Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Size
Declaration Syntax
C# Visual Basic Visual C++
public double Size { get; set; }
Public Property Size As Double
    Get
    Set
public:
property double Size {
    double get ();
    void set (double value);
}


StyleId Property

StyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »StyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId StyleId { get; set; }
Public Property StyleId As ObjectId
    Get
    Set
public:
property ObjectId StyleId {
    ObjectId get ();
    void set (ObjectId value);
}


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}


WidthFactor Property

WidthFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »WidthFactor
Declaration Syntax
C# Visual Basic Visual C++
public double WidthFactor { get; set; }
Public Property WidthFactor As Double
    Get
    Set
public:
property double WidthFactor {
    double get ();
    void set (double value);
}


SkyBackground Class

SkyBackground Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSkyBackground")]
public class SkyBackground : Background
<WrapperAttribute("AcDbSkyBackground")> _
Public Class SkyBackground _
    Inherits Background
[WrapperAttribute(L"AcDbSkyBackground")]
public ref class SkyBackground : public Background
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkyBackground()()()() |
 | SkyBackground(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetDrawableType()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SunId |
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Background
 |  |  |  |  |  |  | SkyBackground


SkyBackground Constructor

SkyBackground Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »SkyBackground()()()()
Members
Icon | Member | Description
 | SkyBackground()()()() |
 | SkyBackground(IntPtr, Boolean) |


SkyBackground Constructor

SkyBackground Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »SkyBackground()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SkyBackground()
Public Sub New
public:
SkyBackground()


SkyBackground Constructor (unmanagedPointer, autoDelete)

SkyBackground Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »SkyBackground(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal SkyBackground(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
SkyBackground(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetDrawableType Method

GetDrawableType Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »GetDrawableType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DrawableType GetDrawableType()
Public Function GetDrawableType As DrawableType
public:
DrawableType GetDrawableType()


SunId Property

SunId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »SunId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId SunId { get; set; }
Public Property SunId As ObjectId
    Get
    Set
public:
property ObjectId SunId {
    ObjectId get ();
    void set (ObjectId value);
}


Solid Class

Solid Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSolid")]
public class Solid : Entity
<WrapperAttribute("AcDbSolid")> _
Public Class Solid _
    Inherits Entity
[WrapperAttribute(L"AcDbSolid")]
public ref class Solid : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Solid(Point3d, Point3d, Point3d, Point3d) |
 | Solid(Point3d, Point3d, Point3d) |
 | Solid()()()() |
 | Solid(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAt(Int16) |
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPointAt(Int16, Point3d) |
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Solid


Solid Constructor

Solid Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Solid()()()()
Members
Icon | Member | Description
 | Solid(Point3d, Point3d, Point3d, Point3d) |
 | Solid(Point3d, Point3d, Point3d) |
 | Solid()()()() |
 | Solid(IntPtr, Boolean) |


Solid Constructor

Solid Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Solid()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Solid()
Public Sub New
public:
Solid()


Solid Constructor (unmanagedPointer, autoDelete)

Solid Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Solid(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Solid(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Solid(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Solid Constructor (point1, point2, point3)

Solid Constructor (point1, point2, point3)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Solid(Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Solid(
    Point3d point1,
    Point3d point2,
    Point3d point3
)
Public Sub New ( _
    point1 As Point3d, _
    point2 As Point3d, _
    point3 As Point3d _
)
public:
Solid(
    Point3d point1,
    Point3d point2,
    Point3d point3
)
Parameters
point1(Point3d)
point2(Point3d)
point3(Point3d)


Solid Constructor (point1, point2, point3, point4)

Solid Constructor (point1, point2, point3, point4)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Solid(Point3d, Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Solid(
    Point3d point1,
    Point3d point2,
    Point3d point3,
    Point3d point4
)
Public Sub New ( _
    point1 As Point3d, _
    point2 As Point3d, _
    point3 As Point3d, _
    point4 As Point3d _
)
public:
Solid(
    Point3d point1,
    Point3d point2,
    Point3d point3,
    Point3d point4
)
Parameters
point1(Point3d)
point2(Point3d)
point3(Point3d)
point4(Point3d)


GetPointAt Method (index)

GetPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »GetPointAt(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetPointAt(
    short index
)
Public Function GetPointAt ( _
    index As Short _
) As Point3d
public:
Point3d GetPointAt(
    short index
)
Parameters
index(Int16)


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


SetPointAt Method (index, pointValue)

SetPointAt Method (index, pointValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »SetPointAt(Int16, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPointAt(
    short index,
    Point3d pointValue
)
Public Sub SetPointAt ( _
    index As Short, _
    pointValue As Point3d _
)
public:
void SetPointAt(
    short index,
    Point3d pointValue
)
Parameters
index(Int16)
pointValue(Point3d)


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}


Solid3d Class

Solid3d Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDb3dSolid")]
public class Solid3d : Entity
<WrapperAttribute("AcDb3dSolid")> _
Public Class Solid3d _
    Inherits Entity
[WrapperAttribute(L"AcDb3dSolid")]
public ref class Solid3d : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Solid3d(IntPtr, Boolean) |
 | Solid3d()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area |
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BooleanOperation(BooleanOperationType, Solid3d) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ChamferEdges(array<SubentityId>[]()[][], SubentityId, Double, Double) |
 | CheckInterference(Solid3d) |
 | ClassID | (Inherited from DBObject.)
 | CleanBody()()()() |
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToBrepAtSubentPaths(array<FullSubentityPath>[]()[][]) |
 | Copied | (Inherited from DBObject.)
 | CopyEdge(SubentityId) |
 | CopyFace(SubentityId) |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateBox(Double, Double, Double) |
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateExtrudedSolid(Entity, SubentityId, Double, SweepOptions) |
 | CreateExtrudedSolid(Entity, SubentityId, Vector3d, SweepOptions) |
 | CreateExtrudedSolid(Entity, Vector3d, SweepOptions) |
 | CreateFrom(Entity) |
 | CreateFrustum(Double, Double, Double, Double) |
 | CreateLoftedSolid(array<Entity>[]()[][], array<Entity>[]()[][], Entity, LoftOptions) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreatePyramid(Double, Int32, Double, Double) |
 | CreateRevolvedSolid(Entity, SubentityId, Point3d, Vector3d, Double, Double, RevolveOptions) |
 | CreateRevolvedSolid(Entity, Point3d, Vector3d, Double, Double, RevolveOptions) |
 | CreateSphere(Double) |
 | CreateSweptSolid(Entity, SubentityId, Entity, SweepOptions) |
 | CreateSweptSolid(Entity, Entity, SweepOptions) |
 | CreateTorus(Double, Double) |
 | CreateWedge(Double, Double, Double) |
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Extrude(Region, Double, Double) |
 | ExtrudeAlongPath(Region, Curve, Double) |
 | ExtrudeFaces(array<SubentityId>[]()[][], Double, Double) |
 | ExtrudeFacesAlongPath(array<SubentityId>[]()[][], Curve) |
 | FaceStyleId | (Inherited from Entity.)
 | FilletEdges(array<SubentityId>[]()[][], DoubleCollection, DoubleCollection, DoubleCollection) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSection(Plane) |
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityColor(SubentityId) |
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityMaterial(SubentityId) |
 | GetSubentityMaterialMapper(SubentityId) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | ImprintEntity(Entity) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsNull |
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | MassProperties |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | NumChanges |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OffsetBody(Double) |
 | OffsetFaces(array<SubentityId>[]()[][], Double) |
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | ProjectOnToSolid(Entity, Vector3d) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | RecordHistory |
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveFaces(array<SubentityId>[]()[][]) |
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Revolve(Region, Point3d, Vector3d, Double) |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SeparateBody()()()() |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityColor(SubentityId, Color) |
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetSubentityMaterial(SubentityId, ObjectId) |
 | SetSubentityMaterialMapper(SubentityId, Mapper) |
 | ShellBody(array<SubentityId>[]()[][], Double) |
 | ShowHistory |
 | Slice(Surface) |
 | Slice(Surface, Boolean) |
 | Slice(Plane) |
 | Slice(Plane, Boolean) |
 | StlOut(String, Boolean) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TaperFaces(array<SubentityId>[]()[][], Point3d, Vector3d, Double) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformFaces(array<SubentityId>[]()[][], Matrix3d) |
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Solid3d


Solid3d Constructor

Solid3d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Solid3d()()()()
Members
Icon | Member | Description
 | Solid3d(IntPtr, Boolean) |
 | Solid3d()()()() |


Solid3d Constructor

Solid3d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Solid3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Solid3d()
Public Sub New
public:
Solid3d()


Solid3d Constructor (unmanagedPointer, autoDelete)

Solid3d Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Solid3d(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Solid3d(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Solid3d(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Area Property

Area Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Area
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Area { get; }
Public Overridable ReadOnly Property Area As Double
    Get
public:
virtual property double Area {
    double get ();
}


BooleanOperation Method (operation, solid)

BooleanOperation Method (operation, solid)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »BooleanOperation(BooleanOperationType, Solid3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void BooleanOperation(
    BooleanOperationType operation,
    Solid3d solid
)
Public Overridable Sub BooleanOperation ( _
    operation As BooleanOperationType, _
    solid As Solid3d _
)
public:
virtual void BooleanOperation(
    BooleanOperationType operation,
    Solid3d^ solid
)
Parameters
operation(BooleanOperationType)
solid(Solid3d)


ChamferEdges Method (subentityIds, baseSubentityId, baseDist, otherDist)

ChamferEdges Method (subentityIds, baseSubentityId, baseDist, otherDist)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »ChamferEdges(array<SubentityId>[]()[][], SubentityId, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void ChamferEdges(
    SubentityId[] subentityIds,
    SubentityId baseSubentityId,
    double baseDist,
    double otherDist
)
Public Sub ChamferEdges ( _
    subentityIds As SubentityId(), _
    baseSubentityId As SubentityId, _
    baseDist As Double, _
    otherDist As Double _
)
public:
void ChamferEdges(
    array<SubentityId>^ subentityIds,
    SubentityId baseSubentityId,
    double baseDist,
    double otherDist
)
Parameters
subentityIds(array< SubentityId >[]()[][])
baseSubentityId(SubentityId)
baseDist(Double)
otherDist(Double)


CheckInterference Method (otherSolid)

CheckInterference Method (otherSolid)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CheckInterference(Solid3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool CheckInterference(
    Solid3d otherSolid
)
Public Overridable Function CheckInterference ( _
    otherSolid As Solid3d _
) As Boolean
public:
virtual bool CheckInterference(
    Solid3d^ otherSolid
)
Parameters
otherSolid(Solid3d)


CleanBody Method

CleanBody Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CleanBody()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CleanBody()
Public Overridable Sub CleanBody
public:
virtual void CleanBody()


ConvertToBrepAtSubentPaths Method (paths)

ConvertToBrepAtSubentPaths Method (paths)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »ConvertToBrepAtSubentPaths(array<FullSubentityPath>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void ConvertToBrepAtSubentPaths(
    FullSubentityPath[] paths
)
Public Sub ConvertToBrepAtSubentPaths ( _
    paths As FullSubentityPath() _
)
public:
void ConvertToBrepAtSubentPaths(
    array<FullSubentityPath>^ paths
)
Parameters
paths(array< FullSubentityPath >[]()[][])


CopyEdge Method (subEntityId)

CopyEdge Method (subEntityId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CopyEdge(SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Entity CopyEdge(
    SubentityId subEntityId
)
Public Overridable Function CopyEdge ( _
    subEntityId As SubentityId _
) As Entity
public:
virtual Entity^ CopyEdge(
    SubentityId subEntityId
)
Parameters
subEntityId(SubentityId)


CopyFace Method (subEntityId)

CopyFace Method (subEntityId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CopyFace(SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Entity CopyFace(
    SubentityId subEntityId
)
Public Overridable Function CopyFace ( _
    subEntityId As SubentityId _
) As Entity
public:
virtual Entity^ CopyFace(
    SubentityId subEntityId
)
Parameters
subEntityId(SubentityId)


CreateBox Method (lengthAlongX, lengthAlongY, lengthAlongZ)

CreateBox Method (lengthAlongX, lengthAlongY, lengthAlongZ)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateBox(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateBox(
    double lengthAlongX,
    double lengthAlongY,
    double lengthAlongZ
)
Public Overridable Sub CreateBox ( _
    lengthAlongX As Double, _
    lengthAlongY As Double, _
    lengthAlongZ As Double _
)
public:
virtual void CreateBox(
    double lengthAlongX,
    double lengthAlongY,
    double lengthAlongZ
)
Parameters
lengthAlongX(Double)
lengthAlongY(Double)
lengthAlongZ(Double)


CreateExtrudedSolid Method

CreateExtrudedSolid Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateExtrudedSolid()()()()
Members
Icon | Member | Description
 | CreateExtrudedSolid(Entity, SubentityId, Double, SweepOptions) |
 | CreateExtrudedSolid(Entity, SubentityId, Vector3d, SweepOptions) |
 | CreateExtrudedSolid(Entity, Vector3d, SweepOptions) |


CreateExtrudedSolid Method (sweepEntity, faceSubEntityId, height, sweepOptions)

CreateExtrudedSolid Method (sweepEntity, faceSubEntityId, height, sweepOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateExtrudedSolid(Entity, SubentityId, Double, SweepOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateExtrudedSolid(
    Entity sweepEntity,
    SubentityId faceSubEntityId,
    double height,
    SweepOptions sweepOptions
)
Public Overridable Sub CreateExtrudedSolid ( _
    sweepEntity As Entity, _
    faceSubEntityId As SubentityId, _
    height As Double, _
    sweepOptions As SweepOptions _
)
public:
virtual void CreateExtrudedSolid(
    Entity^ sweepEntity,
    SubentityId faceSubEntityId,
    double height,
    SweepOptions^ sweepOptions
)
Parameters
sweepEntity(Entity)
faceSubEntityId(SubentityId)
height(Double)
sweepOptions(SweepOptions)


CreateExtrudedSolid Method (sweepEntity, faceSubEntityId, directionVector, sweepOptions)

CreateExtrudedSolid Method (sweepEntity, faceSubEntityId, directionVector, sweepOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateExtrudedSolid(Entity, SubentityId, Vector3d, SweepOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateExtrudedSolid(
    Entity sweepEntity,
    SubentityId faceSubEntityId,
    Vector3d directionVector,
    SweepOptions sweepOptions
)
Public Overridable Sub CreateExtrudedSolid ( _
    sweepEntity As Entity, _
    faceSubEntityId As SubentityId, _
    directionVector As Vector3d, _
    sweepOptions As SweepOptions _
)
public:
virtual void CreateExtrudedSolid(
    Entity^ sweepEntity,
    SubentityId faceSubEntityId,
    Vector3d directionVector,
    SweepOptions^ sweepOptions
)
Parameters
sweepEntity(Entity)
faceSubEntityId(SubentityId)
directionVector(Vector3d)
sweepOptions(SweepOptions)


CreateExtrudedSolid Method (sweepEntity, directionVector, sweepOptions)

CreateExtrudedSolid Method (sweepEntity, directionVector, sweepOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateExtrudedSolid(Entity, Vector3d, SweepOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateExtrudedSolid(
    Entity sweepEntity,
    Vector3d directionVector,
    SweepOptions sweepOptions
)
Public Overridable Sub CreateExtrudedSolid ( _
    sweepEntity As Entity, _
    directionVector As Vector3d, _
    sweepOptions As SweepOptions _
)
public:
virtual void CreateExtrudedSolid(
    Entity^ sweepEntity,
    Vector3d directionVector,
    SweepOptions^ sweepOptions
)
Parameters
sweepEntity(Entity)
directionVector(Vector3d)
sweepOptions(SweepOptions)


CreateFrom Method (fromEntity)

CreateFrom Method (fromEntity)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateFrom(Entity)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateFrom(
    Entity fromEntity
)
Public Overridable Sub CreateFrom ( _
    fromEntity As Entity _
)
public:
virtual void CreateFrom(
    Entity^ fromEntity
)
Parameters
fromEntity(Entity)


CreateFrustum Method (height, radiusAlongX, radiusAlongY, topRadius)

CreateFrustum Method (height, radiusAlongX, radiusAlongY, topRadius)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateFrustum(Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateFrustum(
    double height,
    double radiusAlongX,
    double radiusAlongY,
    double topRadius
)
Public Overridable Sub CreateFrustum ( _
    height As Double, _
    radiusAlongX As Double, _
    radiusAlongY As Double, _
    topRadius As Double _
)
public:
virtual void CreateFrustum(
    double height,
    double radiusAlongX,
    double radiusAlongY,
    double topRadius
)
Parameters
height(Double)
radiusAlongX(Double)
radiusAlongY(Double)
topRadius(Double)


CreateLoftedSolid Method (crossSectionCurves, guideCurves, pathCurve, loftOptions)

CreateLoftedSolid Method (crossSectionCurves, guideCurves, pathCurve, loftOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateLoftedSolid(array<Entity>[]()[][], array<Entity>[]()[][], Entity, LoftOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateLoftedSolid(
    Entity[] crossSectionCurves,
    Entity[] guideCurves,
    Entity pathCurve,
    LoftOptions loftOptions
)
Public Overridable Sub CreateLoftedSolid ( _
    crossSectionCurves As Entity(), _
    guideCurves As Entity(), _
    pathCurve As Entity, _
    loftOptions As LoftOptions _
)
public:
virtual void CreateLoftedSolid(
    array<Entity^>^ crossSectionCurves,
    array<Entity^>^ guideCurves,
    Entity^ pathCurve,
    LoftOptions^ loftOptions
)
Parameters
crossSectionCurves(array< Entity >[]()[][])
guideCurves(array< Entity >[]()[][])
pathCurve(Entity)
loftOptions(LoftOptions)


CreatePyramid Method (height, sides, radius, topRadius)

CreatePyramid Method (height, sides, radius, topRadius)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreatePyramid(Double, Int32, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreatePyramid(
    double height,
    int sides,
    double radius,
    double topRadius
)
Public Overridable Sub CreatePyramid ( _
    height As Double, _
    sides As Integer, _
    radius As Double, _
    topRadius As Double _
)
public:
virtual void CreatePyramid(
    double height,
    int sides,
    double radius,
    double topRadius
)
Parameters
height(Double)
sides(Int32)
radius(Double)
topRadius(Double)


CreateRevolvedSolid Method

CreateRevolvedSolid Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateRevolvedSolid()()()()
Members
Icon | Member | Description
 | CreateRevolvedSolid(Entity, SubentityId, Point3d, Vector3d, Double, Double, RevolveOptions) |
 | CreateRevolvedSolid(Entity, Point3d, Vector3d, Double, Double, RevolveOptions) |


CreateRevolvedSolid Method (profileEntity, faceSubEntityId, axisPoint, axisDir, angleOfRevolution, startAngle, revolveOptions)

CreateRevolvedSolid Method (profileEntity, faceSubEntityId, axisPoint, axisDir, angleOfRevolution, startAngle, revolveOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateRevolvedSolid(Entity, SubentityId, Point3d, Vector3d, Double, Double, RevolveOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateRevolvedSolid(
    Entity profileEntity,
    SubentityId faceSubEntityId,
    Point3d axisPoint,
    Vector3d axisDir,
    double angleOfRevolution,
    double startAngle,
    RevolveOptions revolveOptions
)
Public Overridable Sub CreateRevolvedSolid ( _
    profileEntity As Entity, _
    faceSubEntityId As SubentityId, _
    axisPoint As Point3d, _
    axisDir As Vector3d, _
    angleOfRevolution As Double, _
    startAngle As Double, _
    revolveOptions As RevolveOptions _
)
public:
virtual void CreateRevolvedSolid(
    Entity^ profileEntity,
    SubentityId faceSubEntityId,
    Point3d axisPoint,
    Vector3d axisDir,
    double angleOfRevolution,
    double startAngle,
    RevolveOptions^ revolveOptions
)
Parameters
profileEntity(Entity)
faceSubEntityId(SubentityId)
axisPoint(Point3d)
axisDir(Vector3d)
angleOfRevolution(Double)
startAngle(Double)
revolveOptions(RevolveOptions)


CreateRevolvedSolid Method (profileEntity, axisPoint, axisDir, angleOfRevolution, startAngle, revolveOptions)

CreateRevolvedSolid Method (profileEntity, axisPoint, axisDir, angleOfRevolution, startAngle, revolveOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateRevolvedSolid(Entity, Point3d, Vector3d, Double, Double, RevolveOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateRevolvedSolid(
    Entity profileEntity,
    Point3d axisPoint,
    Vector3d axisDir,
    double angleOfRevolution,
    double startAngle,
    RevolveOptions revolveOptions
)
Public Overridable Sub CreateRevolvedSolid ( _
    profileEntity As Entity, _
    axisPoint As Point3d, _
    axisDir As Vector3d, _
    angleOfRevolution As Double, _
    startAngle As Double, _
    revolveOptions As RevolveOptions _
)
public:
virtual void CreateRevolvedSolid(
    Entity^ profileEntity,
    Point3d axisPoint,
    Vector3d axisDir,
    double angleOfRevolution,
    double startAngle,
    RevolveOptions^ revolveOptions
)
Parameters
profileEntity(Entity)
axisPoint(Point3d)
axisDir(Vector3d)
angleOfRevolution(Double)
startAngle(Double)
revolveOptions(RevolveOptions)


CreateSphere Method (radius)

CreateSphere Method (radius)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateSphere(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateSphere(
    double radius
)
Public Overridable Sub CreateSphere ( _
    radius As Double _
)
public:
virtual void CreateSphere(
    double radius
)
Parameters
radius(Double)


CreateSweptSolid Method

CreateSweptSolid Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateSweptSolid()()()()
Members
Icon | Member | Description
 | CreateSweptSolid(Entity, SubentityId, Entity, SweepOptions) |
 | CreateSweptSolid(Entity, Entity, SweepOptions) |


CreateSweptSolid Method (sweepEntity, pathEntity, sweepOptions)

CreateSweptSolid Method (sweepEntity, pathEntity, sweepOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateSweptSolid(Entity, Entity, SweepOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateSweptSolid(
    Entity sweepEntity,
    Entity pathEntity,
    SweepOptions sweepOptions
)
Public Overridable Sub CreateSweptSolid ( _
    sweepEntity As Entity, _
    pathEntity As Entity, _
    sweepOptions As SweepOptions _
)
public:
virtual void CreateSweptSolid(
    Entity^ sweepEntity,
    Entity^ pathEntity,
    SweepOptions^ sweepOptions
)
Parameters
sweepEntity(Entity)
pathEntity(Entity)
sweepOptions(SweepOptions)


CreateSweptSolid Method (sweepEntity, faceSubEntityId, pathEntity, sweepOptions)

CreateSweptSolid Method (sweepEntity, faceSubEntityId, pathEntity, sweepOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateSweptSolid(Entity, SubentityId, Entity, SweepOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateSweptSolid(
    Entity sweepEntity,
    SubentityId faceSubEntityId,
    Entity pathEntity,
    SweepOptions sweepOptions
)
Public Overridable Sub CreateSweptSolid ( _
    sweepEntity As Entity, _
    faceSubEntityId As SubentityId, _
    pathEntity As Entity, _
    sweepOptions As SweepOptions _
)
public:
virtual void CreateSweptSolid(
    Entity^ sweepEntity,
    SubentityId faceSubEntityId,
    Entity^ pathEntity,
    SweepOptions^ sweepOptions
)
Parameters
sweepEntity(Entity)
faceSubEntityId(SubentityId)
pathEntity(Entity)
sweepOptions(SweepOptions)


CreateTorus Method (majorRadius, minorRadius)

CreateTorus Method (majorRadius, minorRadius)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateTorus(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateTorus(
    double majorRadius,
    double minorRadius
)
Public Overridable Sub CreateTorus ( _
    majorRadius As Double, _
    minorRadius As Double _
)
public:
virtual void CreateTorus(
    double majorRadius,
    double minorRadius
)
Parameters
majorRadius(Double)
minorRadius(Double)


CreateWedge Method (lengthAlongX, lengthAlongY, lengthAlongZ)

CreateWedge Method (lengthAlongX, lengthAlongY, lengthAlongZ)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »CreateWedge(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CreateWedge(
    double lengthAlongX,
    double lengthAlongY,
    double lengthAlongZ
)
Public Overridable Sub CreateWedge ( _
    lengthAlongX As Double, _
    lengthAlongY As Double, _
    lengthAlongZ As Double _
)
public:
virtual void CreateWedge(
    double lengthAlongX,
    double lengthAlongY,
    double lengthAlongZ
)
Parameters
lengthAlongX(Double)
lengthAlongY(Double)
lengthAlongZ(Double)


Extrude Method (region, height, taperAngle)

Extrude Method (region, height, taperAngle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Extrude(Region, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Extrude(
    Region region,
    double height,
    double taperAngle
)
Public Overridable Sub Extrude ( _
    region As Region, _
    height As Double, _
    taperAngle As Double _
)
public:
virtual void Extrude(
    Region^ region,
    double height,
    double taperAngle
)
Parameters
region(Region)
height(Double)
taperAngle(Double)


ExtrudeAlongPath Method (region, path, taperAngle)

ExtrudeAlongPath Method (region, path, taperAngle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »ExtrudeAlongPath(Region, Curve, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ExtrudeAlongPath(
    Region region,
    Curve path,
    double taperAngle
)
Public Overridable Sub ExtrudeAlongPath ( _
    region As Region, _
    path As Curve, _
    taperAngle As Double _
)
public:
virtual void ExtrudeAlongPath(
    Region^ region,
    Curve^ path,
    double taperAngle
)
Parameters
region(Region)
path(Curve)
taperAngle(Double)


ExtrudeFaces Method (subentityIds, height, taper)

ExtrudeFaces Method (subentityIds, height, taper)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »ExtrudeFaces(array<SubentityId>[]()[][], Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ExtrudeFaces(
    SubentityId[] subentityIds,
    double height,
    double taper
)
Public Overridable Sub ExtrudeFaces ( _
    subentityIds As SubentityId(), _
    height As Double, _
    taper As Double _
)
public:
virtual void ExtrudeFaces(
    array<SubentityId>^ subentityIds,
    double height,
    double taper
)
Parameters
subentityIds(array< SubentityId >[]()[][])
height(Double)
taper(Double)


ExtrudeFacesAlongPath Method (subentityIds, path)

ExtrudeFacesAlongPath Method (subentityIds, path)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »ExtrudeFacesAlongPath(array<SubentityId>[]()[][], Curve)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ExtrudeFacesAlongPath(
    SubentityId[] subentityIds,
    Curve path
)
Public Overridable Sub ExtrudeFacesAlongPath ( _
    subentityIds As SubentityId(), _
    path As Curve _
)
public:
virtual void ExtrudeFacesAlongPath(
    array<SubentityId>^ subentityIds,
    Curve^ path
)
Parameters
subentityIds(array< SubentityId >[]()[][])
path(Curve)


FilletEdges Method (subentityIds, radius, startSetback, endSetback)

FilletEdges Method (subentityIds, radius, startSetback, endSetback)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »FilletEdges(array<SubentityId>[]()[][], DoubleCollection, DoubleCollection, DoubleCollection)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void FilletEdges(
    SubentityId[] subentityIds,
    DoubleCollection radius,
    DoubleCollection startSetback,
    DoubleCollection endSetback
)
Public Overridable Sub FilletEdges ( _
    subentityIds As SubentityId(), _
    radius As DoubleCollection, _
    startSetback As DoubleCollection, _
    endSetback As DoubleCollection _
)
public:
virtual void FilletEdges(
    array<SubentityId>^ subentityIds,
    DoubleCollection^ radius,
    DoubleCollection^ startSetback,
    DoubleCollection^ endSetback
)
Parameters
subentityIds(array< SubentityId >[]()[][])
radius(DoubleCollection)
startSetback(DoubleCollection)
endSetback(DoubleCollection)


GetSection Method (plane)

GetSection Method (plane)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »GetSection(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Region GetSection(
    Plane plane
)
Public Overridable Function GetSection ( _
    plane As Plane _
) As Region
public:
virtual Region^ GetSection(
    Plane^ plane
)
Parameters
plane(Plane)


GetSubentityColor Method (subEntityId)

GetSubentityColor Method (subEntityId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »GetSubentityColor(SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public Color GetSubentityColor(
    SubentityId subEntityId
)
Public Function GetSubentityColor ( _
    subEntityId As SubentityId _
) As Color
public:
Color^ GetSubentityColor(
    SubentityId subEntityId
)
Parameters
subEntityId(SubentityId)


GetSubentityMaterial Method (subEntityId)

GetSubentityMaterial Method (subEntityId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »GetSubentityMaterial(SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetSubentityMaterial(
    SubentityId subEntityId
)
Public Overridable Function GetSubentityMaterial ( _
    subEntityId As SubentityId _
) As ObjectId
public:
virtual ObjectId GetSubentityMaterial(
    SubentityId subEntityId
)
Parameters
subEntityId(SubentityId)


GetSubentityMaterialMapper Method (subEntityId)

GetSubentityMaterialMapper Method (subEntityId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »GetSubentityMaterialMapper(SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Mapper GetSubentityMaterialMapper(
    SubentityId subEntityId
)
Public Overridable Function GetSubentityMaterialMapper ( _
    subEntityId As SubentityId _
) As Mapper
public:
virtual Mapper^ GetSubentityMaterialMapper(
    SubentityId subEntityId
)
Parameters
subEntityId(SubentityId)


ImprintEntity Method (entity)

ImprintEntity Method (entity)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »ImprintEntity(Entity)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ImprintEntity(
    Entity entity
)
Public Overridable Sub ImprintEntity ( _
    entity As Entity _
)
public:
virtual void ImprintEntity(
    Entity^ entity
)
Parameters
entity(Entity)


IsNull Property

IsNull Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »IsNull
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsNull { get; }
Public Overridable ReadOnly Property IsNull As Boolean
    Get
public:
virtual property bool IsNull {
    bool get ();
}


MassProperties Property

MassProperties Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »MassProperties
Declaration Syntax
C# Visual Basic Visual C++
public virtual Solid3dMassProperties MassProperties { get; }
Public Overridable ReadOnly Property MassProperties As Solid3dMassProperties
    Get
public:
virtual property Solid3dMassProperties MassProperties {
    Solid3dMassProperties get ();
}


NumChanges Property

NumChanges Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »NumChanges
Declaration Syntax
C# Visual Basic Visual C++
public virtual int NumChanges { get; }
Public Overridable ReadOnly Property NumChanges As Integer
    Get
public:
virtual property int NumChanges {
    int get ();
}


OffsetBody Method (offsetDistance)

OffsetBody Method (offsetDistance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »OffsetBody(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OffsetBody(
    double offsetDistance
)
Public Overridable Sub OffsetBody ( _
    offsetDistance As Double _
)
public:
virtual void OffsetBody(
    double offsetDistance
)
Parameters
offsetDistance(Double)


OffsetFaces Method (subentityIds, offsetDistance)

OffsetFaces Method (subentityIds, offsetDistance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »OffsetFaces(array<SubentityId>[]()[][], Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OffsetFaces(
    SubentityId[] subentityIds,
    double offsetDistance
)
Public Overridable Sub OffsetFaces ( _
    subentityIds As SubentityId(), _
    offsetDistance As Double _
)
public:
virtual void OffsetFaces(
    array<SubentityId>^ subentityIds,
    double offsetDistance
)
Parameters
subentityIds(array< SubentityId >[]()[][])
offsetDistance(Double)


ProjectOnToSolid Method (entityToProject, projectionDirection)

ProjectOnToSolid Method (entityToProject, projectionDirection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »ProjectOnToSolid(Entity, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Entity[] ProjectOnToSolid(
    Entity entityToProject,
    Vector3d projectionDirection
)
Public Function ProjectOnToSolid ( _
    entityToProject As Entity, _
    projectionDirection As Vector3d _
) As Entity()
public:
array<Entity^>^ ProjectOnToSolid(
    Entity^ entityToProject,
    Vector3d projectionDirection
)
Parameters
entityToProject(Entity)
projectionDirection(Vector3d)


RecordHistory Property

RecordHistory Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »RecordHistory
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool RecordHistory { get; set; }
Public Overridable Property RecordHistory As Boolean
    Get
    Set
public:
virtual property bool RecordHistory {
    bool get ();
    void set (bool value);
}


RemoveFaces Method (subentityIds)

RemoveFaces Method (subentityIds)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »RemoveFaces(array<SubentityId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveFaces(
    SubentityId[] subentityIds
)
Public Overridable Sub RemoveFaces ( _
    subentityIds As SubentityId() _
)
public:
virtual void RemoveFaces(
    array<SubentityId>^ subentityIds
)
Parameters
subentityIds(array< SubentityId >[]()[][])


Revolve Method (region, axisPoint, axisDir, angleOfRevolution)

Revolve Method (region, axisPoint, axisDir, angleOfRevolution)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Revolve(Region, Point3d, Vector3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Revolve(
    Region region,
    Point3d axisPoint,
    Vector3d axisDir,
    double angleOfRevolution
)
Public Overridable Sub Revolve ( _
    region As Region, _
    axisPoint As Point3d, _
    axisDir As Vector3d, _
    angleOfRevolution As Double _
)
public:
virtual void Revolve(
    Region^ region,
    Point3d axisPoint,
    Vector3d axisDir,
    double angleOfRevolution
)
Parameters
region(Region)
axisPoint(Point3d)
axisDir(Vector3d)
angleOfRevolution(Double)


SeparateBody Method

SeparateBody Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »SeparateBody()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Solid3d[] SeparateBody()
Public Overridable Function SeparateBody As Solid3d()
public:
virtual array<Solid3d^>^ SeparateBody()


SetSubentityColor Method (subEntityId, color)

SetSubentityColor Method (subEntityId, color)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »SetSubentityColor(SubentityId, Color)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSubentityColor(
    SubentityId subEntityId,
    Color color
)
Public Overridable Sub SetSubentityColor ( _
    subEntityId As SubentityId, _
    color As Color _
)
public:
virtual void SetSubentityColor(
    SubentityId subEntityId,
    Color^ color
)
Parameters
subEntityId(SubentityId)
color(Color)


SetSubentityMaterial Method (subEntityId, materialId)

SetSubentityMaterial Method (subEntityId, materialId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »SetSubentityMaterial(SubentityId, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSubentityMaterial(
    SubentityId subEntityId,
    ObjectId materialId
)
Public Overridable Sub SetSubentityMaterial ( _
    subEntityId As SubentityId, _
    materialId As ObjectId _
)
public:
virtual void SetSubentityMaterial(
    SubentityId subEntityId,
    ObjectId materialId
)
Parameters
subEntityId(SubentityId)
materialId(ObjectId)


SetSubentityMaterialMapper Method (subEntityId, mapper)

SetSubentityMaterialMapper Method (subEntityId, mapper)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »SetSubentityMaterialMapper(SubentityId, Mapper)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSubentityMaterialMapper(
    SubentityId subEntityId,
    Mapper mapper
)
Public Overridable Sub SetSubentityMaterialMapper ( _
    subEntityId As SubentityId, _
    mapper As Mapper _
)
public:
virtual void SetSubentityMaterialMapper(
    SubentityId subEntityId,
    Mapper^ mapper
)
Parameters
subEntityId(SubentityId)
mapper(Mapper)


ShellBody Method (subentityIds, offsetDistance)

ShellBody Method (subentityIds, offsetDistance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »ShellBody(array<SubentityId>[]()[][], Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ShellBody(
    SubentityId[] subentityIds,
    double offsetDistance
)
Public Overridable Sub ShellBody ( _
    subentityIds As SubentityId(), _
    offsetDistance As Double _
)
public:
virtual void ShellBody(
    array<SubentityId>^ subentityIds,
    double offsetDistance
)
Parameters
subentityIds(array< SubentityId >[]()[][])
offsetDistance(Double)


ShowHistory Property

ShowHistory Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »ShowHistory
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ShowHistory { get; set; }
Public Overridable Property ShowHistory As Boolean
    Get
    Set
public:
virtual property bool ShowHistory {
    bool get ();
    void set (bool value);
}


Slice Method

Slice Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Slice()()()()
Members
Icon | Member | Description
 | Slice(Surface) |
 | Slice(Surface, Boolean) |
 | Slice(Plane) |
 | Slice(Plane, Boolean) |


Slice Method (surface)

Slice Method (surface)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Slice(Surface)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Slice(
    Surface surface
)
Public Overridable Sub Slice ( _
    surface As Surface _
)
public:
virtual void Slice(
    Surface^ surface
)
Parameters
surface(Surface)


Slice Method (surface, negativeHalfToo)

Slice Method (surface, negativeHalfToo)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Slice(Surface, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Solid3d Slice(
    Surface surface,
    bool negativeHalfToo
)
Public Overridable Function Slice ( _
    surface As Surface, _
    negativeHalfToo As Boolean _
) As Solid3d
public:
virtual Solid3d^ Slice(
    Surface^ surface,
    bool negativeHalfToo
)
Parameters
surface(Surface)
negativeHalfToo(Boolean)


Slice Method (plane)

Slice Method (plane)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Slice(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Slice(
    Plane plane
)
Public Overridable Sub Slice ( _
    plane As Plane _
)
public:
virtual void Slice(
    Plane^ plane
)
Parameters
plane(Plane)


Slice Method (plane, negativeHalfToo)

Slice Method (plane, negativeHalfToo)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Slice(Plane, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Solid3d Slice(
    Plane plane,
    bool negativeHalfToo
)
Public Overridable Function Slice ( _
    plane As Plane, _
    negativeHalfToo As Boolean _
) As Solid3d
public:
virtual Solid3d^ Slice(
    Plane^ plane,
    bool negativeHalfToo
)
Parameters
plane(Plane)
negativeHalfToo(Boolean)


StlOut Method (fileName, asciiFormat)

StlOut Method (fileName, asciiFormat)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »StlOut(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void StlOut(
    string fileName,
    bool asciiFormat
)
Public Overridable Sub StlOut ( _
    fileName As String, _
    asciiFormat As Boolean _
)
public:
virtual void StlOut(
    String^ fileName,
    bool asciiFormat
)
Parameters
fileName(String)
asciiFormat(Boolean)


TaperFaces Method (subentityIds, basePoint, draftVector, draftAngle)

TaperFaces Method (subentityIds, basePoint, draftVector, draftAngle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »TaperFaces(array<SubentityId>[]()[][], Point3d, Vector3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void TaperFaces(
    SubentityId[] subentityIds,
    Point3d basePoint,
    Vector3d draftVector,
    double draftAngle
)
Public Overridable Sub TaperFaces ( _
    subentityIds As SubentityId(), _
    basePoint As Point3d, _
    draftVector As Vector3d, _
    draftAngle As Double _
)
public:
virtual void TaperFaces(
    array<SubentityId>^ subentityIds,
    Point3d basePoint,
    Vector3d draftVector,
    double draftAngle
)
Parameters
subentityIds(array< SubentityId >[]()[][])
basePoint(Point3d)
draftVector(Vector3d)
draftAngle(Double)


TransformFaces Method (subentityIds, matrix)

TransformFaces Method (subentityIds, matrix)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »TransformFaces(array<SubentityId>[]()[][], Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void TransformFaces(
    SubentityId[] subentityIds,
    Matrix3d matrix
)
Public Overridable Sub TransformFaces ( _
    subentityIds As SubentityId(), _
    matrix As Matrix3d _
)
public:
virtual void TransformFaces(
    array<SubentityId>^ subentityIds,
    Matrix3d matrix
)
Parameters
subentityIds(array< SubentityId >[]()[][])
matrix(Matrix3d)


Solid3dMassProperties Structure

Solid3dMassProperties Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3dMassProperties
Declaration Syntax
C# Visual Basic Visual C++
public struct Solid3dMassProperties
Public Structure Solid3dMassProperties
public value class Solid3dMassProperties
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Solid3dMassProperties(Int32) |
 | Centroid |
 | Equals(Object) | (Inherited from ValueType.)
 | Extents |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MomentsOfIntertia |
 | PrincipalAxes[([( Int32])]) |
 | PrincipalMoments |
 | ProductsOfIntertia |
 | RadiiOfGyration |
 | ToString()()()() | (Inherited from ValueType.)
 | Volume |


Solid3dMassProperties Constructor (dummy)

Solid3dMassProperties Constructor (dummy)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3dMassProperties »Solid3dMassProperties(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Solid3dMassProperties(
    int dummy
)
Public Sub New ( _
    dummy As Integer _
)
public:
Solid3dMassProperties(
    int dummy
)
Parameters
dummy(Int32)


Centroid Property

Centroid Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3dMassProperties »Centroid
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Centroid { get; }
Public ReadOnly Property Centroid As Point3d
    Get
public:
property Point3d Centroid {
    Point3d get ();
}


Extents Property

Extents Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3dMassProperties »Extents
Declaration Syntax
C# Visual Basic Visual C++
public Extents3d Extents { get; }
Public ReadOnly Property Extents As Extents3d
    Get
public:
property Extents3d Extents {
    Extents3d get ();
}


MomentsOfIntertia Property

MomentsOfIntertia Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3dMassProperties »MomentsOfIntertia
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d MomentsOfIntertia { get; }
Public ReadOnly Property MomentsOfIntertia As Vector3d
    Get
public:
property Vector3d MomentsOfIntertia {
    Vector3d get ();
}


PrincipalAxes Property (index)

PrincipalAxes Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3dMassProperties »PrincipalAxes[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d this[
    int index
] { get; }
Public ReadOnly Default Property PrincipalAxes ( _
    index As Integer _
) As Vector3d
    Get
public:
property Vector3d default[int index] {
    Vector3d get (int index);
}
Parameters
index(Int32)


PrincipalMoments Property

PrincipalMoments Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3dMassProperties »PrincipalMoments
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d PrincipalMoments { get; }
Public ReadOnly Property PrincipalMoments As Vector3d
    Get
public:
property Vector3d PrincipalMoments {
    Vector3d get ();
}


ProductsOfIntertia Property

ProductsOfIntertia Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3dMassProperties »ProductsOfIntertia
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d ProductsOfIntertia { get; }
Public ReadOnly Property ProductsOfIntertia As Vector3d
    Get
public:
property Vector3d ProductsOfIntertia {
    Vector3d get ();
}


RadiiOfGyration Property

RadiiOfGyration Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3dMassProperties »RadiiOfGyration
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d RadiiOfGyration { get; }
Public ReadOnly Property RadiiOfGyration As Vector3d
    Get
public:
property Vector3d RadiiOfGyration {
    Vector3d get ();
}


Volume Property

Volume Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3dMassProperties »Volume
Declaration Syntax
C# Visual Basic Visual C++
public double Volume { get; }
Public ReadOnly Property Volume As Double
    Get
public:
property double Volume {
    double get ();
}


SolidBackground Class

SolidBackground Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSolidBackground")]
public class SolidBackground : Background
<WrapperAttribute("AcDbSolidBackground")> _
Public Class SolidBackground _
    Inherits Background
[WrapperAttribute(L"AcDbSolidBackground")]
public ref class SolidBackground : public Background
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SolidBackground()()()() |
 | SolidBackground(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Background
 |  |  |  |  |  |  | SolidBackground


SolidBackground Constructor

SolidBackground Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground »SolidBackground()()()()
Members
Icon | Member | Description
 | SolidBackground()()()() |
 | SolidBackground(IntPtr, Boolean) |


SolidBackground Constructor

SolidBackground Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground »SolidBackground()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SolidBackground()
Public Sub New
public:
SolidBackground()


SolidBackground Constructor (unmanagedPointer, autoDelete)

SolidBackground Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground »SolidBackground(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal SolidBackground(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
SolidBackground(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Spline Class

Spline Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSpline")]
public class Spline : Curve
<WrapperAttribute("AcDbSpline")> _
Public Class Spline _
    Inherits Curve
[WrapperAttribute(L"AcDbSpline")]
public ref class Spline : public Curve
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Spline(Int32, Boolean, Boolean, Boolean, Point3dCollection, DoubleCollection, DoubleCollection, Double, Double) |
 | Spline(Point3d, Vector3d, Vector3d, Double, Double, Double) |
 | Spline(Point3dCollection, Vector3d, Vector3d, Int32, Double) |
 | Spline(Point3dCollection, Int32, Double) |
 | Spline()()()() |
 | Spline(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed | (Inherited from Curve.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Degree |
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | ElevateDegree(Int32) |
 | EndFitTangent |
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FitData |
 | FitTolerance |
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetControlPointAt(Int32) |
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetFitPointAt(Int32) |
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasFitData |
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertFitPointAt(Int32, Point3d) |
 | InsertKnot(Double) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsNull |
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Overrides Entity.IsPlanar.)
 | IsRational |
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | NumControlPoints |
 | NumFitPoints |
 | NurbsData |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | PurgeFitData()()()() |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemoveFitPointAt(Int32) |
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetControlPointAt(Int32, Point3d) |
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFitPointAt(Int32, Point3d) |
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetWeightAt(Int32, Double) |
 | Spline | (Inherited from Curve.)
 | StartFitTangent |
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Inherited from Curve.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToPolyline(UInt32) |
 | ToPolyline()()()() |
 | ToPolylineWithPrecision(Int32) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateFitData()()()() |
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WeightAt(Int32) |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Spline
 |  |  |  |  |  |  |  |  | Helix


Spline Constructor

Spline Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Spline()()()()
Members
Icon | Member | Description
 | Spline(Int32, Boolean, Boolean, Boolean, Point3dCollection, DoubleCollection, DoubleCollection, Double, Double) |
 | Spline(Point3d, Vector3d, Vector3d, Double, Double, Double) |
 | Spline(Point3dCollection, Vector3d, Vector3d, Int32, Double) |
 | Spline(Point3dCollection, Int32, Double) |
 | Spline()()()() |
 | Spline(IntPtr, Boolean) |


Spline Constructor

Spline Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Spline()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Spline()
Public Sub New
public:
Spline()


Spline Constructor (degree, rational, closed, periodic, controlPoints, knots, weights, controlPointTolerance, knotTolerance)

Spline Constructor (degree, rational, closed, periodic, controlPoints, knots, weights, controlPointTolerance, knotTolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Spline(Int32, Boolean, Boolean, Boolean, Point3dCollection, DoubleCollection, DoubleCollection, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Spline(
    int degree,
    bool rational,
    bool closed,
    bool periodic,
    Point3dCollection controlPoints,
    DoubleCollection knots,
    DoubleCollection weights,
    double controlPointTolerance,
    double knotTolerance
)
Public Sub New ( _
    degree As Integer, _
    rational As Boolean, _
    closed As Boolean, _
    periodic As Boolean, _
    controlPoints As Point3dCollection, _
    knots As DoubleCollection, _
    weights As DoubleCollection, _
    controlPointTolerance As Double, _
    knotTolerance As Double _
)
public:
Spline(
    int degree,
    bool rational,
    bool closed,
    bool periodic,
    Point3dCollection^ controlPoints,
    DoubleCollection^ knots,
    DoubleCollection^ weights,
    double controlPointTolerance,
    double knotTolerance
)
Parameters
degree(Int32)
rational(Boolean)
closed(Boolean)
periodic(Boolean)
controlPoints(Point3dCollection)
knots(DoubleCollection)
weights(DoubleCollection)
controlPointTolerance(Double)
knotTolerance(Double)


Spline Constructor (unmanagedObjPtr, autoDelete)

Spline Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Spline(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Spline(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Spline(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Spline Constructor (center, unitNormal, majorAxis, radiusRatio, startAngle, endAngle)

Spline Constructor (center, unitNormal, majorAxis, radiusRatio, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Spline(Point3d, Vector3d, Vector3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Spline(
    Point3d center,
    Vector3d unitNormal,
    Vector3d majorAxis,
    double radiusRatio,
    double startAngle,
    double endAngle
)
Public Sub New ( _
    center As Point3d, _
    unitNormal As Vector3d, _
    majorAxis As Vector3d, _
    radiusRatio As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
Spline(
    Point3d center,
    Vector3d unitNormal,
    Vector3d majorAxis,
    double radiusRatio,
    double startAngle,
    double endAngle
)
Parameters
center(Point3d)
unitNormal(Vector3d)
majorAxis(Vector3d)
radiusRatio(Double)
startAngle(Double)
endAngle(Double)


Spline Constructor (point, order, fitTolerance)

Spline Constructor (point, order, fitTolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Spline(Point3dCollection, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Spline(
    Point3dCollection point,
    int order,
    double fitTolerance
)
Public Sub New ( _
    point As Point3dCollection, _
    order As Integer, _
    fitTolerance As Double _
)
public:
Spline(
    Point3dCollection^ point,
    int order,
    double fitTolerance
)
Parameters
point(Point3dCollection)
order(Int32)
fitTolerance(Double)


Spline Constructor (point, startTangent, endTangent, order, fitTolerance)

Spline Constructor (point, startTangent, endTangent, order, fitTolerance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Spline(Point3dCollection, Vector3d, Vector3d, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Spline(
    Point3dCollection point,
    Vector3d startTangent,
    Vector3d endTangent,
    int order,
    double fitTolerance
)
Public Sub New ( _
    point As Point3dCollection, _
    startTangent As Vector3d, _
    endTangent As Vector3d, _
    order As Integer, _
    fitTolerance As Double _
)
public:
Spline(
    Point3dCollection^ point,
    Vector3d startTangent,
    Vector3d endTangent,
    int order,
    double fitTolerance
)
Parameters
point(Point3dCollection)
startTangent(Vector3d)
endTangent(Vector3d)
order(Int32)
fitTolerance(Double)


Degree Property

Degree Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Degree
Declaration Syntax
C# Visual Basic Visual C++
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}


ElevateDegree Method (newDegree)

ElevateDegree Method (newDegree)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »ElevateDegree(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void ElevateDegree(
    int newDegree
)
Public Sub ElevateDegree ( _
    newDegree As Integer _
)
public:
void ElevateDegree(
    int newDegree
)
Parameters
newDegree(Int32)


EndFitTangent Property

EndFitTangent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »EndFitTangent
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d EndFitTangent { get; }
Public ReadOnly Property EndFitTangent As Vector3d
    Get
public:
property Vector3d EndFitTangent {
    Vector3d get ();
}


FitData Property

FitData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »FitData
Declaration Syntax
C# Visual Basic Visual C++
public FitData FitData { get; set; }
Public Property FitData As FitData
    Get
    Set
public:
property FitData FitData {
    FitData get ();
    void set (FitData value);
}


FitTolerance Property

FitTolerance Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »FitTolerance
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double FitTolerance { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property FitTolerance As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double FitTolerance {
    double get ();
    void set (double value);
}


GetControlPointAt Method (index)

GetControlPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetControlPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetControlPointAt(
    int index
)
Public Function GetControlPointAt ( _
    index As Integer _
) As Point3d
public:
Point3d GetControlPointAt(
    int index
)
Parameters
index(Int32)


GetFitPointAt Method (index)

GetFitPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetFitPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetFitPointAt(
    int index
)
Public Function GetFitPointAt ( _
    index As Integer _
) As Point3d
public:
Point3d GetFitPointAt(
    int index
)
Parameters
index(Int32)


HasFitData Property

HasFitData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »HasFitData
Declaration Syntax
C# Visual Basic Visual C++
public bool HasFitData { get; }
Public ReadOnly Property HasFitData As Boolean
    Get
public:
property bool HasFitData {
    bool get ();
}


InsertFitPointAt Method (index, point)

InsertFitPointAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »InsertFitPointAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertFitPointAt(
    int index,
    Point3d point
)
Public Sub InsertFitPointAt ( _
    index As Integer, _
    point As Point3d _
)
public:
void InsertFitPointAt(
    int index,
    Point3d point
)
Parameters
index(Int32)
point(Point3d)


InsertKnot Method (value)

InsertKnot Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »InsertKnot(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertKnot(
    double value
)
Public Sub InsertKnot ( _
    value As Double _
)
public:
void InsertKnot(
    double value
)
Parameters
value(Double)


IsNull Property

IsNull Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »IsNull
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNull { get; }
Public ReadOnly Property IsNull As Boolean
    Get
public:
property bool IsNull {
    bool get ();
}


IsPlanar Property

IsPlanar Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »IsPlanar
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsPlanar { get; }
Public Overrides ReadOnly Property IsPlanar As Boolean
    Get
public:
virtual property bool IsPlanar {
    bool get () override;
}


IsRational Property

IsRational Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »IsRational
Declaration Syntax
C# Visual Basic Visual C++
public bool IsRational { get; }
Public ReadOnly Property IsRational As Boolean
    Get
public:
property bool IsRational {
    bool get ();
}


NumControlPoints Property

NumControlPoints Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »NumControlPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumControlPoints { get; }
Public ReadOnly Property NumControlPoints As Integer
    Get
public:
property int NumControlPoints {
    int get ();
}


NumFitPoints Property

NumFitPoints Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »NumFitPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumFitPoints { get; }
Public ReadOnly Property NumFitPoints As Integer
    Get
public:
property int NumFitPoints {
    int get ();
}


NurbsData Property

NurbsData Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »NurbsData
Declaration Syntax
C# Visual Basic Visual C++
public NurbsData NurbsData { get; set; }
Public Property NurbsData As NurbsData
    Get
    Set
public:
property NurbsData NurbsData {
    NurbsData get ();
    void set (NurbsData value);
}


PurgeFitData Method

PurgeFitData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »PurgeFitData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void PurgeFitData()
Public Sub PurgeFitData
public:
void PurgeFitData()


RemoveFitPointAt Method (index)

RemoveFitPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »RemoveFitPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveFitPointAt(
    int index
)
Public Sub RemoveFitPointAt ( _
    index As Integer _
)
public:
void RemoveFitPointAt(
    int index
)
Parameters
index(Int32)


SetControlPointAt Method (index, point)

SetControlPointAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »SetControlPointAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetControlPointAt(
    int index,
    Point3d point
)
Public Sub SetControlPointAt ( _
    index As Integer, _
    point As Point3d _
)
public:
void SetControlPointAt(
    int index,
    Point3d point
)
Parameters
index(Int32)
point(Point3d)


SetFitPointAt Method (index, point)

SetFitPointAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »SetFitPointAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitPointAt(
    int index,
    Point3d point
)
Public Sub SetFitPointAt ( _
    index As Integer, _
    point As Point3d _
)
public:
void SetFitPointAt(
    int index,
    Point3d point
)
Parameters
index(Int32)
point(Point3d)


SetWeightAt Method (index, weight)

SetWeightAt Method (index, weight)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »SetWeightAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetWeightAt(
    int index,
    double weight
)
Public Sub SetWeightAt ( _
    index As Integer, _
    weight As Double _
)
public:
void SetWeightAt(
    int index,
    double weight
)
Parameters
index(Int32)
weight(Double)


StartFitTangent Property

StartFitTangent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »StartFitTangent
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d StartFitTangent { get; }
Public ReadOnly Property StartFitTangent As Vector3d
    Get
public:
property Vector3d StartFitTangent {
    Vector3d get ();
}


ToPolyline Method

ToPolyline Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »ToPolyline()()()()
Members
Icon | Member | Description
 | ToPolyline(UInt32) |
 | ToPolyline()()()() |


ToPolyline Method

ToPolyline Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »ToPolyline()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Curve ToPolyline()
Public Function ToPolyline As Curve
public:
Curve^ ToPolyline()


ToPolyline Method (numOfVertices)

ToPolyline Method (numOfVertices)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »ToPolyline(UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public Curve ToPolyline(
    uint numOfVertices
)
Public Function ToPolyline ( _
    numOfVertices As UInteger _
) As Curve
public:
Curve^ ToPolyline(
    unsigned int numOfVertices
)
Parameters
numOfVertices(UInt32)


ToPolylineWithPrecision Method (precision)

ToPolylineWithPrecision Method (precision)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »ToPolylineWithPrecision(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Curve ToPolylineWithPrecision(
    int precision
)
Public Function ToPolylineWithPrecision ( _
    precision As Integer _
) As Curve
public:
Curve^ ToPolylineWithPrecision(
    int precision
)
Parameters
precision(Int32)


UpdateFitData Method

UpdateFitData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »UpdateFitData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateFitData()
Public Sub UpdateFitData
public:
void UpdateFitData()


WeightAt Method (index)

WeightAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »WeightAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double WeightAt(
    int index
)
Public Function WeightAt ( _
    index As Integer _
) As Double
public:
double WeightAt(
    int index
)
Parameters
index(Int32)


StandardScaleType Enumeration

StandardScaleType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »StandardScaleType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbPlotSettings::StdScaleType")]
public enum StandardScaleType
<WrapperAttribute("ZcDbPlotSettings::StdScaleType")> _
Public Enumeration StandardScaleType
[WrapperAttribute(L"ZcDbPlotSettings::StdScaleType")]
public enum class StandardScaleType
Members
Member | Description
ScaleToFit |
Scale8To1 |
Scale6inAnd1ft |
Scale4To1 |
Scale3To8inchAnd1ft |
Scale3To4inchAnd1ft |
Scale3To32inchAnd1ft |
Scale3To16inchAnd1ft |
Scale3inAnd1ft |
Scale2To1 |
Scale1To8inchAnd1ft |
Scale1To8 |
Scale1To64inchAnd1ft |
Scale1To50 |
Scale1To5 |
Scale1To4inchAnd1ft |
Scale1To40 |
Scale1To4 |
Scale1To32inchAnd1ft |
Scale1To30 |
Scale1To2inchAnd1ft |
Scale1To20 |
Scale1To2 |
Scale1To16inchAnd1ft |
Scale1To16 |
Scale1To128inAnd1ft |
Scale1To100 |
Scale1To10 |
Scale1To1 |
Scale1inAnd1ft |
Scale1ftAnd1ft |
Scale10To1 |
Scale100To1 |
CustomScale |


StdScaleType Enumeration

StdScaleType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »StdScaleType
Declaration Syntax
C# Visual Basic Visual C++
public enum StdScaleType
Public Enumeration StdScaleType
public enum class StdScaleType
Members
Member | Description
StdScale1_2Inchis1ft |
StdScale1000To1 |
StdScale100To1 |
StdScale10To1 |
StdScale8To1 |
StdScale4To1 |
StdScale2To1 |
StdScale1To100 |
StdScale1To50 |
StdScale1To40 |
StdScale1To30 |
StdScale1To20 |
StdScale1To16 |
StdScale1To10 |
StdScale1To8 |
StdScale1To5 |
StdScale1To4 |
StdScale1To2 |
StdScale1To1 |
StdScale1ftIs1ft |
StdScale6InchIs1ft |
StdScale3InchIs1ft |
StdScale1InchIs1ft |
StdScale3To4InchIs1ft |
StdScale1To2InchIs1ft |
StdScale3To8InchIs1ft |
StdScale1To4InchIs1ft |
StdScale3To16InchIs1ft |
StdScale1To8InchIs1ft |
StdScale3To32InchIs1ft |
StdScale1To16InchIs1ft |
StdScale1To32InchIs1ft |
StdScale1To64InchIs1ft |
StdScale1To128InchIs1ft |
ScaleToFit |


SubentityId Structure

SubentityId Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbSubentId")]
public struct SubentityId
<WrapperAttribute("ZcDbSubentId")> _
Public Structure SubentityId
[WrapperAttribute(L"ZcDbSubentId")]
public value class SubentityId
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubentityId(SubentityType, IntPtr) |
 | SubentityId(RXClass, IntPtr) |
 | SubentityId(RXClass, Int64) | Obsolete.
 | SubentityId(SubentityType, Int64) | Obsolete.
 | Equality(SubentityId, SubentityId) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Index | Obsolete.
 | IndexPtr |
 | Inequality(SubentityId, SubentityId) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Null |
 | ToString()()()() | (Inherited from ValueType.)
 | Type |
 | TypeClass |


SubentityId Constructor

SubentityId Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »SubentityId()()()()
Members
Icon | Member | Description
 | SubentityId(SubentityType, IntPtr) |
 | SubentityId(RXClass, IntPtr) |
 | SubentityId(RXClass, Int64) | Obsolete.
 | SubentityId(SubentityType, Int64) | Obsolete.


SubentityId Constructor (type, i)

SubentityId Constructor (type, i)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »SubentityId(SubentityType, Int64)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use the overload taking IntPtr.")]
public SubentityId(
    SubentityType type,
    long i
)
<ObsoleteAttribute("Use the overload taking IntPtr.")> _
Public Sub New ( _
    type As SubentityType, _
    i As Long _
)
[ObsoleteAttribute(L"Use the overload taking IntPtr.")]
public:
SubentityId(
    SubentityType type,
    long long i
)
Parameters
type(SubentityType)
i(Int64)


SubentityId Constructor (type, i)

SubentityId Constructor (type, i)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »SubentityId(SubentityType, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public SubentityId(
    SubentityType type,
    IntPtr i
)
Public Sub New ( _
    type As SubentityType, _
    i As IntPtr _
)
public:
SubentityId(
    SubentityType type,
    IntPtr i
)
Parameters
type(SubentityType)
i(IntPtr)


SubentityId Constructor (classType, i)

SubentityId Constructor (classType, i)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »SubentityId(RXClass, Int64)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use the overload taking IntPtr.")]
public SubentityId(
    RXClass classType,
    long i
)
<ObsoleteAttribute("Use the overload taking IntPtr.")> _
Public Sub New ( _
    classType As RXClass, _
    i As Long _
)
[ObsoleteAttribute(L"Use the overload taking IntPtr.")]
public:
SubentityId(
    RXClass^ classType,
    long long i
)
Parameters
classType(RXClass)
i(Int64)


SubentityId Constructor (classType, i)

SubentityId Constructor (classType, i)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »SubentityId(RXClass, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public SubentityId(
    RXClass classType,
    IntPtr i
)
Public Sub New ( _
    classType As RXClass, _
    i As IntPtr _
)
public:
SubentityId(
    RXClass^ classType,
    IntPtr i
)
Parameters
classType(RXClass)
i(IntPtr)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »Equality(SubentityId, SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    SubentityId a,
    SubentityId b
)
Public Shared Operator = ( _
    a As SubentityId, _
    b As SubentityId _
) As Boolean
public:
static bool operator ==(
    SubentityId a,
    SubentityId b
)
Parameters
a(SubentityId)
b(SubentityId)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Index Property

Index Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »Index
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use the overload returning IntPtr.")]
public int Index { get; }
<ObsoleteAttribute("Use the overload returning IntPtr.")> _
Public ReadOnly Property Index As Integer
    Get
[ObsoleteAttribute(L"Use the overload returning IntPtr.")]
public:
property int Index {
    int get ();
}


IndexPtr Property

IndexPtr Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »IndexPtr
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr IndexPtr { get; }
Public ReadOnly Property IndexPtr As IntPtr
    Get
public:
property IntPtr IndexPtr {
    IntPtr get ();
}


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »Inequality(SubentityId, SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    SubentityId a,
    SubentityId b
)
Public Shared Operator <> ( _
    a As SubentityId, _
    b As SubentityId _
) As Boolean
public:
static bool operator !=(
    SubentityId a,
    SubentityId b
)
Parameters
a(SubentityId)
b(SubentityId)


Null Property

Null Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »Null
Declaration Syntax
C# Visual Basic Visual C++
public static SubentityId Null { get; }
Public Shared ReadOnly Property Null As SubentityId
    Get
public:
static property SubentityId Null {
    SubentityId get ();
}


Type Property

Type Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »Type
Declaration Syntax
C# Visual Basic Visual C++
public SubentityType Type { get; }
Public ReadOnly Property Type As SubentityType
    Get
public:
property SubentityType Type {
    SubentityType get ();
}


TypeClass Property

TypeClass Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityId »TypeClass
Declaration Syntax
C# Visual Basic Visual C++
public RXClass TypeClass { get; }
Public ReadOnly Property TypeClass As RXClass
    Get
public:
property RXClass^ TypeClass {
    RXClass^ get ();
}


SubentityType Enumeration

SubentityType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SubentityType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::SubentType")]
public enum SubentityType
<WrapperAttribute("ZcDb::SubentType")> _
Public Enumeration SubentityType
[WrapperAttribute(L"ZcDb::SubentType")]
public enum class SubentityType
Members
Member | Description
Null |
MlineCache |
Vertex |
Edge |
Face |
Class |


Sun Class

Sun Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSun")]
public class Sun : DBObject
<WrapperAttribute("AcDbSun")> _
Public Class Sun _
    Inherits DBObject
[WrapperAttribute(L"AcDbSun")]
public ref class Sun : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Sun(IntPtr, Boolean) |
 | Sun()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Altitude |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Azimuth |
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DateTime |
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Intensity |
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDaylightSavingsOn |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsOn |
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | ShadowParameters |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SunColor |
 | SunDirection |
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Sun


Sun Constructor

Sun Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »Sun()()()()
Members
Icon | Member | Description
 | Sun(IntPtr, Boolean) |
 | Sun()()()() |


Sun Constructor

Sun Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »Sun()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Sun()
Public Sub New
public:
Sun()


Sun Constructor (unmanagedPointer, autoDelete)

Sun Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »Sun(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Sun(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Sun(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Altitude Property

Altitude Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »Altitude
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Altitude { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Altitude As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Altitude {
    double get ();
    void set (double value);
}


Azimuth Property

Azimuth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »Azimuth
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double Azimuth { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property Azimuth As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double Azimuth {
    double get ();
    void set (double value);
}


DateTime Property

DateTime Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »DateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime { get; set; }
Public Property DateTime As DateTime
    Get
    Set
public:
property DateTime DateTime {
    DateTime get ();
    void set (DateTime value);
}


Intensity Property

Intensity Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »Intensity
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double Intensity { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property Intensity As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double Intensity {
    double get ();
    void set (double value);
}


IsDaylightSavingsOn Property

IsDaylightSavingsOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »IsDaylightSavingsOn
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDaylightSavingsOn { get; set; }
Public Property IsDaylightSavingsOn As Boolean
    Get
    Set
public:
property bool IsDaylightSavingsOn {
    bool get ();
    void set (bool value);
}


IsOn Property

IsOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »IsOn
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn { get; set; }
Public Property IsOn As Boolean
    Get
    Set
public:
property bool IsOn {
    bool get ();
    void set (bool value);
}


ShadowParameters Property

ShadowParameters Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »ShadowParameters
Declaration Syntax
C# Visual Basic Visual C++
public ShadowParameters ShadowParameters { get; set; }
Public Property ShadowParameters As ShadowParameters
    Get
    Set
public:
property ShadowParameters^ ShadowParameters {
    ShadowParameters^ get ();
    void set (ShadowParameters^ value);
}


SunColor Property

SunColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »SunColor
Declaration Syntax
C# Visual Basic Visual C++
public Color SunColor { get; set; }
Public Property SunColor As Color
    Get
    Set
public:
property Color^ SunColor {
    Color^ get ();
    void set (Color^ value);
}


SunDirection Property

SunDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »SunDirection
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d SunDirection { get; set; }
Public Property SunDirection As Vector3d
    Get
    Set
public:
property Vector3d SunDirection {
    Vector3d get ();
    void set (Vector3d value);
}


Surface Class

Surface Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSurface")]
public class Surface : Entity
<WrapperAttribute("AcDbSurface")> _
Public Class Surface _
    Inherits Entity
[WrapperAttribute(L"AcDbSurface")]
public ref class Surface : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Surface()()()() |
 | Surface(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BooleanIntersect(Surface) |
 | BooleanIntersect(Solid3d) |
 | BooleanSubtract(Surface) |
 | BooleanSubtract(Solid3d) |
 | BooleanUnion(Surface) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ChamferEdges(array<SubentityId>[]()[][], SubentityId, Double, Double) |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToRegion()()()() |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateFrom(Entity) |
 | CreateInterferenceObjects(Entity, Int32) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateOffsetSurface(Entity, Double, Boolean) |
 | CreateOffsetSurface(Entity, Double) |
 | CreateSectionObjects(Plane) |
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FilletEdges(array<SubentityId>[]()[][], DoubleCollection, DoubleCollection, DoubleCollection) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetArea()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityColor(SubentityId) |
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityMaterial(SubentityId) |
 | GetSubentityMaterialMapper(SubentityId) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | ImprintEntity(Entity) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | ProjectOnToSurface(Entity, Vector3d) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RayTest(Point3d, Vector3d, Double, array<SubentityId>[]()[][]%, DoubleCollection%) |
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityColor(SubentityId, Color) |
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetSubentityMaterial(SubentityId, ObjectId) |
 | SetSubentityMaterialMapper(SubentityId, Mapper) |
 | SliceByPlane(Plane) |
 | SliceBySurface(Surface) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thicken(Double, Boolean) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | TrimSurface(ObjectId, ObjectIdCollection, ObjectIdCollection, Vector3dCollection, Point3d, Vector3d, Boolean, Boolean) |
 | UIsoLineDensity |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VIsoLineDensity |
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Surface
 |  |  |  |  |  |  |  | ExtrudedSurface
 |  |  |  |  |  |  |  | LoftedSurface
 |  |  |  |  |  |  |  | PlaneSurface
 |  |  |  |  |  |  |  | RevolvedSurface
 |  |  |  |  |  |  |  | SweptSurface


Surface Constructor

Surface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »Surface()()()()
Members
Icon | Member | Description
 | Surface()()()() |
 | Surface(IntPtr, Boolean) |


Surface Constructor

Surface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »Surface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Surface()
Public Sub New
public:
Surface()


Surface Constructor (unmanagedPointer, autoDelete)

Surface Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »Surface(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Surface(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Surface(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


BooleanIntersect Method

BooleanIntersect Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »BooleanIntersect()()()()
Members
Icon | Member | Description
 | BooleanIntersect(Surface) |
 | BooleanIntersect(Solid3d) |


BooleanIntersect Method (solid)

BooleanIntersect Method (solid)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »BooleanIntersect(Solid3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Entity[] BooleanIntersect(
    Solid3d solid
)
Public Overridable Function BooleanIntersect ( _
    solid As Solid3d _
) As Entity()
public:
virtual array<Entity^>^ BooleanIntersect(
    Solid3d^ solid
)
Parameters
solid(Solid3d)


BooleanIntersect Method (surface2)

BooleanIntersect Method (surface2)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »BooleanIntersect(Surface)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Entity[] BooleanIntersect(
    Surface surface2
)
Public Overridable Function BooleanIntersect ( _
    surface2 As Surface _
) As Entity()
public:
virtual array<Entity^>^ BooleanIntersect(
    Surface^ surface2
)
Parameters
surface2(Surface)


BooleanSubtract Method

BooleanSubtract Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »BooleanSubtract()()()()
Members
Icon | Member | Description
 | BooleanSubtract(Surface) |
 | BooleanSubtract(Solid3d) |


BooleanSubtract Method (solid)

BooleanSubtract Method (solid)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »BooleanSubtract(Solid3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Surface BooleanSubtract(
    Solid3d solid
)
Public Overridable Function BooleanSubtract ( _
    solid As Solid3d _
) As Surface
public:
virtual Surface^ BooleanSubtract(
    Solid3d^ solid
)
Parameters
solid(Solid3d)


BooleanSubtract Method (surface2)

BooleanSubtract Method (surface2)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »BooleanSubtract(Surface)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Surface BooleanSubtract(
    Surface surface2
)
Public Overridable Function BooleanSubtract ( _
    surface2 As Surface _
) As Surface
public:
virtual Surface^ BooleanSubtract(
    Surface^ surface2
)
Parameters
surface2(Surface)


BooleanUnion Method (surface2)

BooleanUnion Method (surface2)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »BooleanUnion(Surface)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Surface BooleanUnion(
    Surface surface2
)
Public Overridable Function BooleanUnion ( _
    surface2 As Surface _
) As Surface
public:
virtual Surface^ BooleanUnion(
    Surface^ surface2
)
Parameters
surface2(Surface)


ChamferEdges Method (subentityIds, baseSubentityId, baseDist, otherDist)

ChamferEdges Method (subentityIds, baseSubentityId, baseDist, otherDist)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »ChamferEdges(array<SubentityId>[]()[][], SubentityId, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ChamferEdges(
    SubentityId[] subentityIds,
    SubentityId baseSubentityId,
    double baseDist,
    double otherDist
)
Public Overridable Sub ChamferEdges ( _
    subentityIds As SubentityId(), _
    baseSubentityId As SubentityId, _
    baseDist As Double, _
    otherDist As Double _
)
public:
virtual void ChamferEdges(
    array<SubentityId>^ subentityIds,
    SubentityId baseSubentityId,
    double baseDist,
    double otherDist
)
Parameters
subentityIds(array< SubentityId >[]()[][])
baseSubentityId(SubentityId)
baseDist(Double)
otherDist(Double)


ConvertToRegion Method

ConvertToRegion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »ConvertToRegion()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Entity[] ConvertToRegion()
Public Overridable Function ConvertToRegion As Entity()
public:
virtual array<Entity^>^ ConvertToRegion()


CreateFrom Method (fromEntity)

CreateFrom Method (fromEntity)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »CreateFrom(Entity)
Declaration Syntax
C# Visual Basic Visual C++
public static Surface CreateFrom(
    Entity fromEntity
)
Public Shared Function CreateFrom ( _
    fromEntity As Entity _
) As Surface
public:
static Surface^ CreateFrom(
    Entity^ fromEntity
)
Parameters
fromEntity(Entity)


CreateInterferenceObjects Method (ent, flags)

CreateInterferenceObjects Method (ent, flags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »CreateInterferenceObjects(Entity, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Entity[] CreateInterferenceObjects(
    Entity ent,
    int flags
)
Public Overridable Function CreateInterferenceObjects ( _
    ent As Entity, _
    flags As Integer _
) As Entity()
public:
virtual array<Entity^>^ CreateInterferenceObjects(
    Entity^ ent,
    int flags
)
Parameters
ent(Entity)
flags(Int32)


CreateOffsetSurface Method

CreateOffsetSurface Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »CreateOffsetSurface()()()()
Members
Icon | Member | Description
 | CreateOffsetSurface(Entity, Double, Boolean) |
 | CreateOffsetSurface(Entity, Double) |


CreateOffsetSurface Method (entity, offsetDistance)

CreateOffsetSurface Method (entity, offsetDistance)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »CreateOffsetSurface(Entity, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Entity CreateOffsetSurface(
    Entity entity,
    double offsetDistance
)
Public Shared Function CreateOffsetSurface ( _
    entity As Entity, _
    offsetDistance As Double _
) As Entity
public:
static Entity^ CreateOffsetSurface(
    Entity^ entity,
    double offsetDistance
)
Parameters
entity(Entity)
offsetDistance(Double)


CreateOffsetSurface Method (entity, offsetDistance, associativeEnabled)

CreateOffsetSurface Method (entity, offsetDistance, associativeEnabled)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »CreateOffsetSurface(Entity, Double, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId CreateOffsetSurface(
    Entity entity,
    double offsetDistance,
    bool associativeEnabled
)
Public Shared Function CreateOffsetSurface ( _
    entity As Entity, _
    offsetDistance As Double, _
    associativeEnabled As Boolean _
) As ObjectId
public:
static ObjectId CreateOffsetSurface(
    Entity^ entity,
    double offsetDistance,
    bool associativeEnabled
)
Parameters
entity(Entity)
offsetDistance(Double)
associativeEnabled(Boolean)


CreateSectionObjects Method (sectionPlane)

CreateSectionObjects Method (sectionPlane)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »CreateSectionObjects(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Entity[] CreateSectionObjects(
    Plane sectionPlane
)
Public Overridable Function CreateSectionObjects ( _
    sectionPlane As Plane _
) As Entity()
public:
virtual array<Entity^>^ CreateSectionObjects(
    Plane^ sectionPlane
)
Parameters
sectionPlane(Plane)


FilletEdges Method (subentityIds, radius, startSetback, endSetback)

FilletEdges Method (subentityIds, radius, startSetback, endSetback)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »FilletEdges(array<SubentityId>[]()[][], DoubleCollection, DoubleCollection, DoubleCollection)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void FilletEdges(
    SubentityId[] subentityIds,
    DoubleCollection radius,
    DoubleCollection startSetback,
    DoubleCollection endSetback
)
Public Overridable Sub FilletEdges ( _
    subentityIds As SubentityId(), _
    radius As DoubleCollection, _
    startSetback As DoubleCollection, _
    endSetback As DoubleCollection _
)
public:
virtual void FilletEdges(
    array<SubentityId>^ subentityIds,
    DoubleCollection^ radius,
    DoubleCollection^ startSetback,
    DoubleCollection^ endSetback
)
Parameters
subentityIds(array< SubentityId >[]()[][])
radius(DoubleCollection)
startSetback(DoubleCollection)
endSetback(DoubleCollection)


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »GetArea()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetArea()
Public Overridable Function GetArea As Double
public:
virtual double GetArea()


GetSubentityColor Method (subEntityId)

GetSubentityColor Method (subEntityId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »GetSubentityColor(SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color GetSubentityColor(
    SubentityId subEntityId
)
Public Overridable Function GetSubentityColor ( _
    subEntityId As SubentityId _
) As Color
public:
virtual Color^ GetSubentityColor(
    SubentityId subEntityId
)
Parameters
subEntityId(SubentityId)


GetSubentityMaterial Method (subEntityId)

GetSubentityMaterial Method (subEntityId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »GetSubentityMaterial(SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetSubentityMaterial(
    SubentityId subEntityId
)
Public Overridable Function GetSubentityMaterial ( _
    subEntityId As SubentityId _
) As ObjectId
public:
virtual ObjectId GetSubentityMaterial(
    SubentityId subEntityId
)
Parameters
subEntityId(SubentityId)


GetSubentityMaterialMapper Method (subEntityId)

GetSubentityMaterialMapper Method (subEntityId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »GetSubentityMaterialMapper(SubentityId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Mapper GetSubentityMaterialMapper(
    SubentityId subEntityId
)
Public Overridable Function GetSubentityMaterialMapper ( _
    subEntityId As SubentityId _
) As Mapper
public:
virtual Mapper^ GetSubentityMaterialMapper(
    SubentityId subEntityId
)
Parameters
subEntityId(SubentityId)


ImprintEntity Method (entityToImprint)

ImprintEntity Method (entityToImprint)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »ImprintEntity(Entity)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ImprintEntity(
    Entity entityToImprint
)
Public Overridable Sub ImprintEntity ( _
    entityToImprint As Entity _
)
public:
virtual void ImprintEntity(
    Entity^ entityToImprint
)
Parameters
entityToImprint(Entity)


ProjectOnToSurface Method (entityToProject, projectionDirection)

ProjectOnToSurface Method (entityToProject, projectionDirection)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »ProjectOnToSurface(Entity, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Entity[] ProjectOnToSurface(
    Entity entityToProject,
    Vector3d projectionDirection
)
Public Function ProjectOnToSurface ( _
    entityToProject As Entity, _
    projectionDirection As Vector3d _
) As Entity()
public:
array<Entity^>^ ProjectOnToSurface(
    Entity^ entityToProject,
    Vector3d projectionDirection
)
Parameters
entityToProject(Entity)
projectionDirection(Vector3d)


RayTest Method (rayBasePoint, rayDir, rayRadius, subEntIds, parameters)

RayTest Method (rayBasePoint, rayDir, rayRadius, subEntIds, parameters)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »RayTest(Point3d, Vector3d, Double, array<SubentityId>[]()[][]%, DoubleCollection%)
Declaration Syntax
C# Visual Basic Visual C++
public void RayTest(
    Point3d rayBasePoint,
    Vector3d rayDir,
    double rayRadius,
    out SubentityId[] subEntIds,
    out DoubleCollection parameters
)
Public Sub RayTest ( _
    rayBasePoint As Point3d, _
    rayDir As Vector3d, _
    rayRadius As Double, _
    <OutAttribute> ByRef subEntIds As SubentityId(), _
    <OutAttribute> ByRef parameters As DoubleCollection _
)
public:
void RayTest(
    Point3d rayBasePoint,
    Vector3d rayDir,
    double rayRadius,
    [OutAttribute] array<SubentityId>^% subEntIds,
    [OutAttribute] DoubleCollection^% parameters
)
Parameters
rayBasePoint(Point3d)
rayDir(Vector3d)
rayRadius(Double)
subEntIds(array< SubentityId >[]()[][]%)
parameters(DoubleCollection %)


SetSubentityColor Method (subEntityId, color)

SetSubentityColor Method (subEntityId, color)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »SetSubentityColor(SubentityId, Color)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSubentityColor(
    SubentityId subEntityId,
    Color color
)
Public Overridable Sub SetSubentityColor ( _
    subEntityId As SubentityId, _
    color As Color _
)
public:
virtual void SetSubentityColor(
    SubentityId subEntityId,
    Color^ color
)
Parameters
subEntityId(SubentityId)
color(Color)


SetSubentityMaterial Method (subEntityId, materialId)

SetSubentityMaterial Method (subEntityId, materialId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »SetSubentityMaterial(SubentityId, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSubentityMaterial(
    SubentityId subEntityId,
    ObjectId materialId
)
Public Overridable Sub SetSubentityMaterial ( _
    subEntityId As SubentityId, _
    materialId As ObjectId _
)
public:
virtual void SetSubentityMaterial(
    SubentityId subEntityId,
    ObjectId materialId
)
Parameters
subEntityId(SubentityId)
materialId(ObjectId)


SetSubentityMaterialMapper Method (subEntityId, mapper)

SetSubentityMaterialMapper Method (subEntityId, mapper)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »SetSubentityMaterialMapper(SubentityId, Mapper)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSubentityMaterialMapper(
    SubentityId subEntityId,
    Mapper mapper
)
Public Overridable Sub SetSubentityMaterialMapper ( _
    subEntityId As SubentityId, _
    mapper As Mapper _
)
public:
virtual void SetSubentityMaterialMapper(
    SubentityId subEntityId,
    Mapper^ mapper
)
Parameters
subEntityId(SubentityId)
mapper(Mapper)


SliceByPlane Method (slicePlane)

SliceByPlane Method (slicePlane)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »SliceByPlane(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public virtual SurfaceSliceResults SliceByPlane(
    Plane slicePlane
)
Public Overridable Function SliceByPlane ( _
    slicePlane As Plane _
) As SurfaceSliceResults
public:
virtual SurfaceSliceResults SliceByPlane(
    Plane^ slicePlane
)
Parameters
slicePlane(Plane)


SliceBySurface Method (slicingSurface)

SliceBySurface Method (slicingSurface)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »SliceBySurface(Surface)
Declaration Syntax
C# Visual Basic Visual C++
public virtual SurfaceSliceResults SliceBySurface(
    Surface slicingSurface
)
Public Overridable Function SliceBySurface ( _
    slicingSurface As Surface _
) As SurfaceSliceResults
public:
virtual SurfaceSliceResults SliceBySurface(
    Surface^ slicingSurface
)
Parameters
slicingSurface(Surface)


Thicken Method (thickness, bothSides)

Thicken Method (thickness, bothSides)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »Thicken(Double, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Solid3d Thicken(
    double thickness,
    bool bothSides
)
Public Overridable Function Thicken ( _
    thickness As Double, _
    bothSides As Boolean _
) As Solid3d
public:
virtual Solid3d^ Thicken(
    double thickness,
    bool bothSides
)
Parameters
thickness(Double)
bothSides(Boolean)


TrimSurface Method (blankSurfaceId, toolSurfaceIds, toolCurveIds, projVectors, pickPoint, viewVector, bAutoExtend, associativeEnabled)

TrimSurface Method (blankSurfaceId, toolSurfaceIds, toolCurveIds, projVectors, pickPoint, viewVector, bAutoExtend, associativeEnabled)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »TrimSurface(ObjectId, ObjectIdCollection, ObjectIdCollection, Vector3dCollection, Point3d, Vector3d, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static void TrimSurface(
    ObjectId blankSurfaceId,
    ObjectIdCollection toolSurfaceIds,
    ObjectIdCollection toolCurveIds,
    Vector3dCollection projVectors,
    Point3d pickPoint,
    Vector3d viewVector,
    bool bAutoExtend,
    bool associativeEnabled
)
Public Shared Sub TrimSurface ( _
    blankSurfaceId As ObjectId, _
    toolSurfaceIds As ObjectIdCollection, _
    toolCurveIds As ObjectIdCollection, _
    projVectors As Vector3dCollection, _
    pickPoint As Point3d, _
    viewVector As Vector3d, _
    bAutoExtend As Boolean, _
    associativeEnabled As Boolean _
)
public:
static void TrimSurface(
    ObjectId blankSurfaceId,
    ObjectIdCollection^ toolSurfaceIds,
    ObjectIdCollection^ toolCurveIds,
    Vector3dCollection^ projVectors,
    Point3d pickPoint,
    Vector3d viewVector,
    bool bAutoExtend,
    bool associativeEnabled
)
Parameters
blankSurfaceId(ObjectId)
toolSurfaceIds(ObjectIdCollection)
toolCurveIds(ObjectIdCollection)
projVectors(Vector3dCollection)
pickPoint(Point3d)
viewVector(Vector3d)
bAutoExtend(Boolean)
associativeEnabled(Boolean)


UIsoLineDensity Property

UIsoLineDensity Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »UIsoLineDensity
Declaration Syntax
C# Visual Basic Visual C++
public short UIsoLineDensity { get; set; }
Public Property UIsoLineDensity As Short
    Get
    Set
public:
property short UIsoLineDensity {
    short get ();
    void set (short value);
}


VIsoLineDensity Property

VIsoLineDensity Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »VIsoLineDensity
Declaration Syntax
C# Visual Basic Visual C++
public short VIsoLineDensity { get; set; }
Public Property VIsoLineDensity As Short
    Get
    Set
public:
property short VIsoLineDensity {
    short get ();
    void set (short value);
}


SurfaceSliceResults Structure

SurfaceSliceResults Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SurfaceSliceResults
Declaration Syntax
C# Visual Basic Visual C++
public struct SurfaceSliceResults
Public Structure SurfaceSliceResults
public value class SurfaceSliceResults
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SurfaceSliceResults(Surface, Surface) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NegativeHalfSurface |
 | NewSurface |
 | ToString()()()() | (Inherited from ValueType.)


SurfaceSliceResults Constructor (negativeHalfSurface, newSurface)

SurfaceSliceResults Constructor (negativeHalfSurface, newSurface)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SurfaceSliceResults »SurfaceSliceResults(Surface, Surface)
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSliceResults(
    Surface negativeHalfSurface,
    Surface newSurface
)
Public Sub New ( _
    negativeHalfSurface As Surface, _
    newSurface As Surface _
)
public:
SurfaceSliceResults(
    Surface^ negativeHalfSurface,
    Surface^ newSurface
)
Parameters
negativeHalfSurface(Surface)
newSurface(Surface)


NegativeHalfSurface Property

NegativeHalfSurface Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SurfaceSliceResults »NegativeHalfSurface
Declaration Syntax
C# Visual Basic Visual C++
public Surface NegativeHalfSurface { get; set; }
Public Property NegativeHalfSurface As Surface
    Get
    Set
public:
property Surface^ NegativeHalfSurface {
    Surface^ get ();
    void set (Surface^ value);
}


NewSurface Property

NewSurface Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SurfaceSliceResults »NewSurface
Declaration Syntax
C# Visual Basic Visual C++
public Surface NewSurface { get; set; }
Public Property NewSurface As Surface
    Get
    Set
public:
property Surface^ NewSurface {
    Surface^ get ();
    void set (Surface^ value);
}


SweepOptions Class

SweepOptions Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbSweepOptions")]
public class SweepOptions : DisposableWrapper,
    ICloneable
<WrapperAttribute("ZcDbSweepOptions")> _
Public Class SweepOptions _
    Inherits DisposableWrapper _
    Implements ICloneable
[WrapperAttribute(L"ZcDbSweepOptions")]
public ref class SweepOptions : public DisposableWrapper,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SweepOptions(SweepOptions) |
 | SweepOptions()()()() |
 | SweepOptions(IntPtr, Boolean) |
 | Align |
 | AlignAngle |
 | AlignStart |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bank |
 | BasePoint |
 | CheckIntersections |
 | CheckPathCurve(Entity, Boolean) |
 | CheckSweepCurve(Entity, Boolean) |
 | Clone()()()() |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DraftAngle |
 | EndDraftDist |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PathEntityTransform |
 | ScaleFactor |
 | StartDraftDist |
 | SweepEntityTransform |
 | ToString()()()() | (Inherited from Object.)
 | TwistAngle |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | SweepOptions


SweepOptions Constructor

SweepOptions Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »SweepOptions()()()()
Members
Icon | Member | Description
 | SweepOptions(SweepOptions) |
 | SweepOptions()()()() |
 | SweepOptions(IntPtr, Boolean) |


SweepOptions Constructor

SweepOptions Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »SweepOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptions()
Public Sub New
public:
SweepOptions()


SweepOptions Constructor (unmanagedPointer, autoDelete)

SweepOptions Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »SweepOptions(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal SweepOptions(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
SweepOptions(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


SweepOptions Constructor (opts)

SweepOptions Constructor (opts)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »SweepOptions(SweepOptions)
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptions(
    SweepOptions opts
)
Public Sub New ( _
    opts As SweepOptions _
)
public:
SweepOptions(
    SweepOptions^ opts
)
Parameters
opts(SweepOptions)


Align Property

Align Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »Align
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptionsAlignOption Align { get; }
Public ReadOnly Property Align As SweepOptionsAlignOption
    Get
public:
property SweepOptionsAlignOption Align {
    SweepOptionsAlignOption get ();
}


AlignAngle Property

AlignAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »AlignAngle
Declaration Syntax
C# Visual Basic Visual C++
public double AlignAngle { get; }
Public ReadOnly Property AlignAngle As Double
    Get
public:
property double AlignAngle {
    double get ();
}


AlignStart Property

AlignStart Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »AlignStart
Declaration Syntax
C# Visual Basic Visual C++
public bool AlignStart { get; }
Public ReadOnly Property AlignStart As Boolean
    Get
public:
property bool AlignStart {
    bool get ();
}


Bank Property

Bank Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »Bank
Declaration Syntax
C# Visual Basic Visual C++
public bool Bank { get; }
Public ReadOnly Property Bank As Boolean
    Get
public:
property bool Bank {
    bool get ();
}


BasePoint Property

BasePoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »BasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BasePoint { get; }
Public ReadOnly Property BasePoint As Point3d
    Get
public:
property Point3d BasePoint {
    Point3d get ();
}


CheckIntersections Property

CheckIntersections Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »CheckIntersections
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckIntersections { get; }
Public ReadOnly Property CheckIntersections As Boolean
    Get
public:
property bool CheckIntersections {
    bool get ();
}


CheckPathCurve Method (pathEnt, displayErrorMessages)

CheckPathCurve Method (pathEnt, displayErrorMessages)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »CheckPathCurve(Entity, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void CheckPathCurve(
    Entity pathEnt,
    bool displayErrorMessages
)
Public Sub CheckPathCurve ( _
    pathEnt As Entity, _
    displayErrorMessages As Boolean _
)
public:
void CheckPathCurve(
    Entity^ pathEnt,
    bool displayErrorMessages
)
Parameters
pathEnt(Entity)
displayErrorMessages(Boolean)


CheckSweepCurve Method (sweepEnt, displayErrorMessages)

CheckSweepCurve Method (sweepEnt, displayErrorMessages)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »CheckSweepCurve(Entity, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptionsCheckSweepCurveOut CheckSweepCurve(
    Entity sweepEnt,
    bool displayErrorMessages
)
Public Function CheckSweepCurve ( _
    sweepEnt As Entity, _
    displayErrorMessages As Boolean _
) As SweepOptionsCheckSweepCurveOut
public:
SweepOptionsCheckSweepCurveOut^ CheckSweepCurve(
    Entity^ sweepEnt,
    bool displayErrorMessages
)
Parameters
sweepEnt(Entity)
displayErrorMessages(Boolean)


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override sealed void DeleteUnmanagedObject()
Protected Overrides NotOverridable Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override sealed


DraftAngle Property

DraftAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »DraftAngle
Declaration Syntax
C# Visual Basic Visual C++
public double DraftAngle { get; }
Public ReadOnly Property DraftAngle As Double
    Get
public:
property double DraftAngle {
    double get ();
}


EndDraftDist Property

EndDraftDist Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »EndDraftDist
Declaration Syntax
C# Visual Basic Visual C++
public double EndDraftDist { get; }
Public ReadOnly Property EndDraftDist As Double
    Get
public:
property double EndDraftDist {
    double get ();
}


PathEntityTransform Property

PathEntityTransform Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »PathEntityTransform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d PathEntityTransform { get; }
Public ReadOnly Property PathEntityTransform As Matrix3d
    Get
public:
property Matrix3d PathEntityTransform {
    Matrix3d get ();
}


ScaleFactor Property

ScaleFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »ScaleFactor
Declaration Syntax
C# Visual Basic Visual C++
public double ScaleFactor { get; }
Public ReadOnly Property ScaleFactor As Double
    Get
public:
property double ScaleFactor {
    double get ();
}


StartDraftDist Property

StartDraftDist Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »StartDraftDist
Declaration Syntax
C# Visual Basic Visual C++
public double StartDraftDist { get; }
Public ReadOnly Property StartDraftDist As Double
    Get
public:
property double StartDraftDist {
    double get ();
}


SweepEntityTransform Property

SweepEntityTransform Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »SweepEntityTransform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d SweepEntityTransform { get; }
Public ReadOnly Property SweepEntityTransform As Matrix3d
    Get
public:
property Matrix3d SweepEntityTransform {
    Matrix3d get ();
}


TwistAngle Property

TwistAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »TwistAngle
Declaration Syntax
C# Visual Basic Visual C++
public double TwistAngle { get; }
Public ReadOnly Property TwistAngle As Double
    Get
public:
property double TwistAngle {
    double get ();
}


SweepOptionsAlignOption Enumeration

SweepOptionsAlignOption Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsAlignOption
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbSweepOptions::AlignOption")]
public enum SweepOptionsAlignOption
<WrapperAttribute("ZcDbSweepOptions::AlignOption")> _
Public Enumeration SweepOptionsAlignOption
[WrapperAttribute(L"ZcDbSweepOptions::AlignOption")]
public enum class SweepOptionsAlignOption
Members
Member | Description
TranslatePathToSweepEntity |
TranslateSweepEntityToPath |
AlignSweepEntityToPath |
NoAlignment |


SweepOptionsBuilder Class

SweepOptionsBuilder Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder
Declaration Syntax
C# Visual Basic Visual C++
public class SweepOptionsBuilder
Public Class SweepOptionsBuilder
public ref class SweepOptionsBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SweepOptionsBuilder(SweepOptions) |
 | SweepOptionsBuilder()()()() |
 | Align |
 | AlignAngle |
 | AlignStart |
 | Bank |
 | BasePoint |
 | CheckIntersections |
 | DraftAngle |
 | EndDraftDist |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PathEntityTransform |
 | ScaleFactor |
 | SetPathEntityTransform(Entity, Boolean) |
 | SetSweepEntityTransform(array<Entity>[]()[][], Boolean) |
 | StartDraftDist |
 | SweepEntityTransform |
 | ToString()()()() | (Inherited from Object.)
 | ToSweepOptions()()()() |
 | TwistAngle |
Inheritance Hierarchy
Object
SweepOptionsBuilder


SweepOptionsBuilder Constructor

SweepOptionsBuilder Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »SweepOptionsBuilder()()()()
Members
Icon | Member | Description
 | SweepOptionsBuilder(SweepOptions) |
 | SweepOptionsBuilder()()()() |


SweepOptionsBuilder Constructor

SweepOptionsBuilder Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »SweepOptionsBuilder()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptionsBuilder()
Public Sub New
public:
SweepOptionsBuilder()


SweepOptionsBuilder Constructor (value)

SweepOptionsBuilder Constructor (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »SweepOptionsBuilder(SweepOptions)
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptionsBuilder(
    SweepOptions value
)
Public Sub New ( _
    value As SweepOptions _
)
public:
SweepOptionsBuilder(
    SweepOptions^ value
)
Parameters
value(SweepOptions)


Align Property

Align Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »Align
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptionsAlignOption Align { get; set; }
Public Property Align As SweepOptionsAlignOption
    Get
    Set
public:
property SweepOptionsAlignOption Align {
    SweepOptionsAlignOption get ();
    void set (SweepOptionsAlignOption value);
}


AlignAngle Property

AlignAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »AlignAngle
Declaration Syntax
C# Visual Basic Visual C++
public double AlignAngle { get; set; }
Public Property AlignAngle As Double
    Get
    Set
public:
property double AlignAngle {
    double get ();
    void set (double value);
}


AlignStart Property

AlignStart Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »AlignStart
Declaration Syntax
C# Visual Basic Visual C++
public bool AlignStart { get; set; }
Public Property AlignStart As Boolean
    Get
    Set
public:
property bool AlignStart {
    bool get ();
    void set (bool value);
}


Bank Property

Bank Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »Bank
Declaration Syntax
C# Visual Basic Visual C++
public bool Bank { get; set; }
Public Property Bank As Boolean
    Get
    Set
public:
property bool Bank {
    bool get ();
    void set (bool value);
}


BasePoint Property

BasePoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »BasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BasePoint { get; set; }
Public Property BasePoint As Point3d
    Get
    Set
public:
property Point3d BasePoint {
    Point3d get ();
    void set (Point3d value);
}


CheckIntersections Property

CheckIntersections Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »CheckIntersections
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckIntersections { get; set; }
Public Property CheckIntersections As Boolean
    Get
    Set
public:
property bool CheckIntersections {
    bool get ();
    void set (bool value);
}


DraftAngle Property

DraftAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »DraftAngle
Declaration Syntax
C# Visual Basic Visual C++
public double DraftAngle { get; set; }
Public Property DraftAngle As Double
    Get
    Set
public:
property double DraftAngle {
    double get ();
    void set (double value);
}


EndDraftDist Property

EndDraftDist Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »EndDraftDist
Declaration Syntax
C# Visual Basic Visual C++
public double EndDraftDist { get; set; }
Public Property EndDraftDist As Double
    Get
    Set
public:
property double EndDraftDist {
    double get ();
    void set (double value);
}


PathEntityTransform Property

PathEntityTransform Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »PathEntityTransform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d PathEntityTransform { get; set; }
Public Property PathEntityTransform As Matrix3d
    Get
    Set
public:
property Matrix3d PathEntityTransform {
    Matrix3d get ();
    void set (Matrix3d value);
}


ScaleFactor Property

ScaleFactor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »ScaleFactor
Declaration Syntax
C# Visual Basic Visual C++
public double ScaleFactor { get; set; }
Public Property ScaleFactor As Double
    Get
    Set
public:
property double ScaleFactor {
    double get ();
    void set (double value);
}


SetPathEntityTransform Method (pathEnt, displayErrorMessages)

SetPathEntityTransform Method (pathEnt, displayErrorMessages)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »SetPathEntityTransform(Entity, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPathEntityTransform(
    Entity pathEnt,
    bool displayErrorMessages
)
Public Sub SetPathEntityTransform ( _
    pathEnt As Entity, _
    displayErrorMessages As Boolean _
)
public:
void SetPathEntityTransform(
    Entity^ pathEnt,
    bool displayErrorMessages
)
Parameters
pathEnt(Entity)
displayErrorMessages(Boolean)


SetSweepEntityTransform Method (sweepEntities, displayErrorMessages)

SetSweepEntityTransform Method (sweepEntities, displayErrorMessages)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »SetSweepEntityTransform(array<Entity>[]()[][], Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetSweepEntityTransform(
    Entity[] sweepEntities,
    bool displayErrorMessages
)
Public Sub SetSweepEntityTransform ( _
    sweepEntities As Entity(), _
    displayErrorMessages As Boolean _
)
public:
void SetSweepEntityTransform(
    array<Entity^>^ sweepEntities,
    bool displayErrorMessages
)
Parameters
sweepEntities(array< Entity >[]()[][])
displayErrorMessages(Boolean)


StartDraftDist Property

StartDraftDist Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »StartDraftDist
Declaration Syntax
C# Visual Basic Visual C++
public double StartDraftDist { get; set; }
Public Property StartDraftDist As Double
    Get
    Set
public:
property double StartDraftDist {
    double get ();
    void set (double value);
}


SweepEntityTransform Property

SweepEntityTransform Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »SweepEntityTransform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d SweepEntityTransform { get; set; }
Public Property SweepEntityTransform As Matrix3d
    Get
    Set
public:
property Matrix3d SweepEntityTransform {
    Matrix3d get ();
    void set (Matrix3d value);
}


ToSweepOptions Method

ToSweepOptions Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »ToSweepOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptions ToSweepOptions()
Public Function ToSweepOptions As SweepOptions
public:
SweepOptions^ ToSweepOptions()


TwistAngle Property

TwistAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsBuilder »TwistAngle
Declaration Syntax
C# Visual Basic Visual C++
public double TwistAngle { get; set; }
Public Property TwistAngle As Double
    Get
    Set
public:
property double TwistAngle {
    double get ();
    void set (double value);
}


SweepOptionsCheckSweepCurveOut Class

SweepOptionsCheckSweepCurveOut Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsCheckSweepCurveOut
Declaration Syntax
C# Visual Basic Visual C++
public class SweepOptionsCheckSweepCurveOut
Public Class SweepOptionsCheckSweepCurveOut
public ref class SweepOptionsCheckSweepCurveOut
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SweepOptionsCheckSweepCurveOut()()()() |
 | ApproximateArcLength |
 | Closed |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Planarity |
 | Point |
 | ToString()()()() | (Inherited from Object.)
 | Vector |
Inheritance Hierarchy
Object
SweepOptionsCheckSweepCurveOut


SweepOptionsCheckSweepCurveOut Constructor

SweepOptionsCheckSweepCurveOut Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsCheckSweepCurveOut »SweepOptionsCheckSweepCurveOut()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptionsCheckSweepCurveOut()
Public Sub New
public:
SweepOptionsCheckSweepCurveOut()


ApproximateArcLength Property

ApproximateArcLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsCheckSweepCurveOut »ApproximateArcLength
Declaration Syntax
C# Visual Basic Visual C++
public double ApproximateArcLength { get; }
Public ReadOnly Property ApproximateArcLength As Double
    Get
public:
property double ApproximateArcLength {
    double get ();
}


Closed Property

Closed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsCheckSweepCurveOut »Closed
Declaration Syntax
C# Visual Basic Visual C++
public bool Closed { get; }
Public ReadOnly Property Closed As Boolean
    Get
public:
property bool Closed {
    bool get ();
}


Planarity Property

Planarity Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsCheckSweepCurveOut »Planarity
Declaration Syntax
C# Visual Basic Visual C++
public Planarity Planarity { get; }
Public ReadOnly Property Planarity As Planarity
    Get
public:
property Planarity Planarity {
    Planarity get ();
}


Point Property

Point Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsCheckSweepCurveOut »Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Point { get; }
Public ReadOnly Property Point As Point3d
    Get
public:
property Point3d Point {
    Point3d get ();
}


Vector Property

Vector Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptionsCheckSweepCurveOut »Vector
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Vector { get; }
Public ReadOnly Property Vector As Vector3d
    Get
public:
property Vector3d Vector {
    Vector3d get ();
}


SweptSurface Class

SweptSurface Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSweptSurface")]
public class SweptSurface : Surface
<WrapperAttribute("AcDbSweptSurface")> _
Public Class SweptSurface _
    Inherits Surface
[WrapperAttribute(L"AcDbSweptSurface")]
public ref class SweptSurface : public Surface
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SweptSurface()()()() |
 | SweptSurface(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bank |
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BooleanIntersect(Surface) | (Inherited from Surface.)
 | BooleanIntersect(Solid3d) | (Inherited from Surface.)
 | BooleanSubtract(Surface) | (Inherited from Surface.)
 | BooleanSubtract(Solid3d) | (Inherited from Surface.)
 | BooleanUnion(Surface) | (Inherited from Surface.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ChamferEdges(array<SubentityId>[]()[][], SubentityId, Double, Double) | (Inherited from Surface.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ConvertToRegion()()()() | (Inherited from Surface.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateInterferenceObjects(Entity, Int32) | (Inherited from Surface.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateSectionObjects(Plane) | (Inherited from Surface.)
 | CreateSweptSurface(Entity, Entity, SweepOptions) |
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FilletEdges(array<SubentityId>[]()[][], DoubleCollection, DoubleCollection, DoubleCollection) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetArea()()()() | (Inherited from Surface.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityColor(SubentityId) | (Inherited from Surface.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityMaterial(SubentityId) | (Inherited from Surface.)
 | GetSubentityMaterialMapper(SubentityId) | (Inherited from Surface.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | ImprintEntity(Entity) | (Inherited from Surface.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PathEntity |
 | PathLength |
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | ProfileRotation |
 | ProjectOnToSurface(Entity, Vector3d) | (Inherited from Surface.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RayTest(Point3d, Vector3d, Double, array<SubentityId>[]()[][]%, DoubleCollection%) | (Inherited from Surface.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | ScaleAlongPath |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityColor(SubentityId, Color) | (Inherited from Surface.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetSubentityMaterial(SubentityId, ObjectId) | (Inherited from Surface.)
 | SetSubentityMaterialMapper(SubentityId, Mapper) | (Inherited from Surface.)
 | SliceByPlane(Plane) | (Inherited from Surface.)
 | SliceBySurface(Surface) | (Inherited from Surface.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | SweepEntity |
 | SweepOptions |
 | Thicken(Double, Boolean) | (Inherited from Surface.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | TwistAlongPath |
 | UIsoLineDensity | (Inherited from Surface.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VIsoLineDensity | (Inherited from Surface.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Surface
 |  |  |  |  |  |  |  | SweptSurface


SweptSurface Constructor

SweptSurface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »SweptSurface()()()()
Members
Icon | Member | Description
 | SweptSurface()()()() |
 | SweptSurface(IntPtr, Boolean) |


SweptSurface Constructor

SweptSurface Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »SweptSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SweptSurface()
Public Sub New
public:
SweptSurface()


SweptSurface Constructor (unmanagedPointer, autoDelete)

SweptSurface Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »SweptSurface(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal SweptSurface(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
SweptSurface(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Bank Property

Bank Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »Bank
Declaration Syntax
C# Visual Basic Visual C++
public bool Bank { get; set; }
Public Property Bank As Boolean
    Get
    Set
public:
property bool Bank {
    bool get ();
    void set (bool value);
}


CreateSweptSurface Method (sweepEnt, pathEnt, sweepOptions)

CreateSweptSurface Method (sweepEnt, pathEnt, sweepOptions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »CreateSweptSurface(Entity, Entity, SweepOptions)
Declaration Syntax
C# Visual Basic Visual C++
public void CreateSweptSurface(
    Entity sweepEnt,
    Entity pathEnt,
    SweepOptions sweepOptions
)
Public Sub CreateSweptSurface ( _
    sweepEnt As Entity, _
    pathEnt As Entity, _
    sweepOptions As SweepOptions _
)
public:
void CreateSweptSurface(
    Entity^ sweepEnt,
    Entity^ pathEnt,
    SweepOptions^ sweepOptions
)
Parameters
sweepEnt(Entity)
pathEnt(Entity)
sweepOptions(SweepOptions)


PathEntity Property

PathEntity Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »PathEntity
Declaration Syntax
C# Visual Basic Visual C++
public Entity PathEntity { get; }
Public ReadOnly Property PathEntity As Entity
    Get
public:
property Entity^ PathEntity {
    Entity^ get ();
}


PathLength Property

PathLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »PathLength
Declaration Syntax
C# Visual Basic Visual C++
public double PathLength { get; }
Public ReadOnly Property PathLength As Double
    Get
public:
property double PathLength {
    double get ();
}


ProfileRotation Property

ProfileRotation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »ProfileRotation
Declaration Syntax
C# Visual Basic Visual C++
public double ProfileRotation { get; set; }
Public Property ProfileRotation As Double
    Get
    Set
public:
property double ProfileRotation {
    double get ();
    void set (double value);
}


ScaleAlongPath Property

ScaleAlongPath Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »ScaleAlongPath
Declaration Syntax
C# Visual Basic Visual C++
public double ScaleAlongPath { get; set; }
Public Property ScaleAlongPath As Double
    Get
    Set
public:
property double ScaleAlongPath {
    double get ();
    void set (double value);
}


SweepEntity Property

SweepEntity Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »SweepEntity
Declaration Syntax
C# Visual Basic Visual C++
public Entity SweepEntity { get; }
Public ReadOnly Property SweepEntity As Entity
    Get
public:
property Entity^ SweepEntity {
    Entity^ get ();
}


SweepOptions Property

SweepOptions Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »SweepOptions
Declaration Syntax
C# Visual Basic Visual C++
public SweepOptions SweepOptions { get; set; }
Public Property SweepOptions As SweepOptions
    Get
    Set
public:
property SweepOptions^ SweepOptions {
    SweepOptions^ get ();
    void set (SweepOptions^ value);
}


TwistAlongPath Property

TwistAlongPath Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »TwistAlongPath
Declaration Syntax
C# Visual Basic Visual C++
public double TwistAlongPath { get; set; }
Public Property TwistAlongPath As Double
    Get
    Set
public:
property double TwistAlongPath {
    double get ();
    void set (double value);
}


SymbolTable Class

SymbolTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSymbolTable")]
public abstract class SymbolTable : DBObject,
    IEnumerable
<WrapperAttribute("AcDbSymbolTable")> _
Public MustInherit Class SymbolTable _
    Inherits DBObject _
    Implements IEnumerable
[WrapperAttribute(L"AcDbSymbolTable")]
public ref class SymbolTable abstract : public DBObject,
    IEnumerable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) |
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) |
 | Has(ObjectId) |
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() |
 | IncludingErased |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | AbstractViewTable
 |  |  |  |  |  |  | BlockTable
 |  |  |  |  |  |  | DimStyleTable
 |  |  |  |  |  |  | LayerTable
 |  |  |  |  |  |  | LinetypeTable
 |  |  |  |  |  |  | RegAppTable
 |  |  |  |  |  |  | TextStyleTable
 |  |  |  |  |  |  | UcsTable
 |  |  |  |  |  |  | ViewportTable
 |  |  |  |  |  |  | ViewTable


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »Add(SymbolTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Add(
    SymbolTableRecord value
)
Public Function Add ( _
    value As SymbolTableRecord _
) As ObjectId
public:
ObjectId Add(
    SymbolTableRecord^ value
)
Parameters
value(SymbolTableRecord)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual SymbolTableEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As SymbolTableEnumerator
public:
virtual SymbolTableEnumerator^ GetEnumerator()


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


Has Method (key)

Has Method (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »Has(String)
Declaration Syntax
C# Visual Basic Visual C++
public bool Has(
    string key
)
Public Function Has ( _
    key As String _
) As Boolean
public:
bool Has(
    String^ key
)
Parameters
key(String)


Has Method (id)

Has Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »Has(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool Has(
    ObjectId id
)
Public Function Has ( _
    id As ObjectId _
) As Boolean
public:
bool Has(
    ObjectId id
)
Parameters
id(ObjectId)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
 virtual IEnumerator IEnumerable_GetEnumerator()
Friend Overridable Function IEnumerable_GetEnumerator As IEnumerator
protected private:
virtual IEnumerator^ IEnumerable_GetEnumerator()


IncludingErased Property

IncludingErased Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »IncludingErased
Declaration Syntax
C# Visual Basic Visual C++
public SymbolTable IncludingErased { get; }
Public ReadOnly Property IncludingErased As SymbolTable
    Get
public:
property SymbolTable^ IncludingErased {
    SymbolTable^ get ();
}


Item Property (key)

Item Property (key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »Item[([( String])])
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId this[
    string key
] { get; }
Public ReadOnly Default Property Item ( _
    key As String _
) As ObjectId
    Get
public:
property ObjectId default[String^ key] {
    ObjectId get (String^ key);
}
Parameters
key(String)


SymbolTableEnumerator Class

SymbolTableEnumerator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableEnumerator
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSymbolTableIterator")]
public class SymbolTableEnumerator : DisposableWrapper,
    IEnumerator
<WrapperAttribute("AcDbSymbolTableIterator")> _
Public Class SymbolTableEnumerator _
    Inherits DisposableWrapper _
    Implements IEnumerator
[WrapperAttribute(L"AcDbSymbolTableIterator")]
public ref class SymbolTableEnumerator : public DisposableWrapper,
    IEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Current |
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumeratorCurrent |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | SymbolTableEnumerator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Current { get; }
Public ReadOnly Property Current As ObjectId
    Get
public:
property ObjectId Current {
    ObjectId get ();
}


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableEnumerator »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


IEnumeratorCurrent Property

IEnumeratorCurrent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableEnumerator »IEnumeratorCurrent
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object IEnumeratorCurrent { get; }
Public Overridable ReadOnly Property IEnumeratorCurrent As Object
    Get
public:
virtual property Object^ IEnumeratorCurrent {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()


SymbolTableRecord Class

SymbolTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSymbolTableRecord")]
public abstract class SymbolTableRecord : DBObject
<WrapperAttribute("AcDbSymbolTableRecord")> _
Public MustInherit Class SymbolTableRecord _
    Inherits DBObject
[WrapperAttribute(L"AcDbSymbolTableRecord")]
public ref class SymbolTableRecord abstract : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SymbolTableRecord(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsResolved |
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | AbstractViewTableRecord
 |  |  |  |  |  |  | BlockTableRecord
 |  |  |  |  |  |  | DimStyleTableRecord
 |  |  |  |  |  |  | LayerTableRecord
 |  |  |  |  |  |  | LinetypeTableRecord
 |  |  |  |  |  |  | RegAppTableRecord
 |  |  |  |  |  |  | TextStyleTableRecord
 |  |  |  |  |  |  | UcsTableRecord


SymbolTableRecord Constructor (unmanagedPointer, autoDelete)

SymbolTableRecord Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »SymbolTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal SymbolTableRecord(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
SymbolTableRecord(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


IsDependent Property

IsDependent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »IsDependent
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDependent { get; }
Public ReadOnly Property IsDependent As Boolean
    Get
public:
property bool IsDependent {
    bool get ();
}


IsResolved Property

IsResolved Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »IsResolved
Declaration Syntax
C# Visual Basic Visual C++
public bool IsResolved { get; }
Public ReadOnly Property IsResolved As Boolean
    Get
public:
property bool IsResolved {
    bool get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


SymbolUtilityServices Class

SymbolUtilityServices Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SymbolUtilityServices
Public NotInheritable Class SymbolUtilityServices
public ref class SymbolUtilityServices sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SymbolUtilityServices()()()() |
 | BlockModelSpaceName |
 | BlockPaperSpaceName |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBlockModelSpaceId(Database) |
 | GetBlockNameFromInsertPathName(String) |
 | GetBlockPaperSpaceId(Database) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetInsertPathNameFromBlockName(String) |
 | GetLayerDefpointsId(Database) |
 | GetLayerZeroId(Database) |
 | GetLinetypeByBlockId(Database) |
 | GetLinetypeByLayerId(Database) |
 | GetLinetypeContinuousId(Database) |
 | GetMaxSymbolNameLength(Boolean, Boolean) |
 | GetPathNameFromSymbolName(String, String) |
 | GetRegAppAcadId(Database) |
 | GetRegAppZcadId(Database) |
 | GetSymbolNameFromPathName(String, String) |
 | GetTextStyleStandardId(Database) |
 | GetType()()()() | (Inherited from Object.)
 | IsBlockLayoutName(String) |
 | IsBlockModelSpaceName(String) |
 | IsBlockPaperSpaceName(String) |
 | IsCompatibilityMode(Database) |
 | IsLayerDefpointsName(String) |
 | IsLayerZeroName(String) |
 | IsLinetypeByBlockName(String) |
 | IsLinetypeByLayerName(String) |
 | IsLinetypeContinuousName(String) |
 | IsRegAppAcadName(String) |
 | IsRegAppZcadName(String) |
 | IsTextStyleStandardName(String) |
 | IsViewportActiveName(String) |
 | LayerDefpointsName |
 | LayerZeroName |
 | LinetypeByBlockName |
 | LinetypeByLayerName |
 | LinetypeContinuousName |
 | MakeDependentName(String, String) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PreValidateSymbolName(String, Boolean) |
 | RegAppAcadName |
 | RegAppZcadName |
 | RepairPreExtendedSymbolName(String, Boolean) |
 | RepairSymbolName(String, Boolean) |
 | TextStyleStandardName |
 | ToString()()()() | (Inherited from Object.)
 | ValidateCompatibleSymbolName(String, Boolean, Boolean, Boolean) |
 | ValidatePreExtendedSymbolName(String, Boolean) |
 | ValidateSymbolName(String, Boolean) |
 | ViewportActiveName |
Inheritance Hierarchy
Object
SymbolUtilityServices


SymbolUtilityServices Constructor

SymbolUtilityServices Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »SymbolUtilityServices()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SymbolUtilityServices()
Public Sub New
public:
SymbolUtilityServices()


BlockModelSpaceName Property

BlockModelSpaceName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »BlockModelSpaceName
Declaration Syntax
C# Visual Basic Visual C++
public static string BlockModelSpaceName { get; }
Public Shared ReadOnly Property BlockModelSpaceName As String
    Get
public:
static property String^ BlockModelSpaceName {
    String^ get ();
}


BlockPaperSpaceName Property

BlockPaperSpaceName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »BlockPaperSpaceName
Declaration Syntax
C# Visual Basic Visual C++
public static string BlockPaperSpaceName { get; }
Public Shared ReadOnly Property BlockPaperSpaceName As String
    Get
public:
static property String^ BlockPaperSpaceName {
    String^ get ();
}


GetBlockModelSpaceId Method (databasePointer)

GetBlockModelSpaceId Method (databasePointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetBlockModelSpaceId(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetBlockModelSpaceId(
    Database databasePointer
)
Public Shared Function GetBlockModelSpaceId ( _
    databasePointer As Database _
) As ObjectId
public:
static ObjectId GetBlockModelSpaceId(
    Database^ databasePointer
)
Parameters
databasePointer(Database)


GetBlockNameFromInsertPathName Method (pathName)

GetBlockNameFromInsertPathName Method (pathName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetBlockNameFromInsertPathName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static string GetBlockNameFromInsertPathName(
    string pathName
)
Public Shared Function GetBlockNameFromInsertPathName ( _
    pathName As String _
) As String
public:
static String^ GetBlockNameFromInsertPathName(
    String^ pathName
)
Parameters
pathName(String)


GetBlockPaperSpaceId Method (databasePointer)

GetBlockPaperSpaceId Method (databasePointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetBlockPaperSpaceId(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetBlockPaperSpaceId(
    Database databasePointer
)
Public Shared Function GetBlockPaperSpaceId ( _
    databasePointer As Database _
) As ObjectId
public:
static ObjectId GetBlockPaperSpaceId(
    Database^ databasePointer
)
Parameters
databasePointer(Database)


GetInsertPathNameFromBlockName Method (blockName)

GetInsertPathNameFromBlockName Method (blockName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetInsertPathNameFromBlockName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static string GetInsertPathNameFromBlockName(
    string blockName
)
Public Shared Function GetInsertPathNameFromBlockName ( _
    blockName As String _
) As String
public:
static String^ GetInsertPathNameFromBlockName(
    String^ blockName
)
Parameters
blockName(String)


GetLayerDefpointsId Method (database)

GetLayerDefpointsId Method (database)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetLayerDefpointsId(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetLayerDefpointsId(
    Database database
)
Public Shared Function GetLayerDefpointsId ( _
    database As Database _
) As ObjectId
public:
static ObjectId GetLayerDefpointsId(
    Database^ database
)
Parameters
database(Database)


GetLayerZeroId Method (database)

GetLayerZeroId Method (database)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetLayerZeroId(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetLayerZeroId(
    Database database
)
Public Shared Function GetLayerZeroId ( _
    database As Database _
) As ObjectId
public:
static ObjectId GetLayerZeroId(
    Database^ database
)
Parameters
database(Database)


GetLinetypeByBlockId Method (databasePointer)

GetLinetypeByBlockId Method (databasePointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetLinetypeByBlockId(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetLinetypeByBlockId(
    Database databasePointer
)
Public Shared Function GetLinetypeByBlockId ( _
    databasePointer As Database _
) As ObjectId
public:
static ObjectId GetLinetypeByBlockId(
    Database^ databasePointer
)
Parameters
databasePointer(Database)


GetLinetypeByLayerId Method (databasePointer)

GetLinetypeByLayerId Method (databasePointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetLinetypeByLayerId(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetLinetypeByLayerId(
    Database databasePointer
)
Public Shared Function GetLinetypeByLayerId ( _
    databasePointer As Database _
) As ObjectId
public:
static ObjectId GetLinetypeByLayerId(
    Database^ databasePointer
)
Parameters
databasePointer(Database)


GetLinetypeContinuousId Method (databasePointer)

GetLinetypeContinuousId Method (databasePointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetLinetypeContinuousId(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetLinetypeContinuousId(
    Database databasePointer
)
Public Shared Function GetLinetypeContinuousId ( _
    databasePointer As Database _
) As ObjectId
public:
static ObjectId GetLinetypeContinuousId(
    Database^ databasePointer
)
Parameters
databasePointer(Database)


GetMaxSymbolNameLength Method (isNewName, compatibilityMode)

GetMaxSymbolNameLength Method (isNewName, compatibilityMode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetMaxSymbolNameLength(Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static int GetMaxSymbolNameLength(
    bool isNewName,
    bool compatibilityMode
)
Public Shared Function GetMaxSymbolNameLength ( _
    isNewName As Boolean, _
    compatibilityMode As Boolean _
) As Integer
public:
static int GetMaxSymbolNameLength(
    bool isNewName,
    bool compatibilityMode
)
Parameters
isNewName(Boolean)
compatibilityMode(Boolean)


GetPathNameFromSymbolName Method (symbolName, extensions)

GetPathNameFromSymbolName Method (symbolName, extensions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetPathNameFromSymbolName(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public static string GetPathNameFromSymbolName(
    string symbolName,
    string extensions
)
Public Shared Function GetPathNameFromSymbolName ( _
    symbolName As String, _
    extensions As String _
) As String
public:
static String^ GetPathNameFromSymbolName(
    String^ symbolName,
    String^ extensions
)
Parameters
symbolName(String)
extensions(String)


GetRegAppAcadId Method (databasePointer)

GetRegAppAcadId Method (databasePointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetRegAppAcadId(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetRegAppAcadId(
    Database databasePointer
)
Public Shared Function GetRegAppAcadId ( _
    databasePointer As Database _
) As ObjectId
public:
static ObjectId GetRegAppAcadId(
    Database^ databasePointer
)
Parameters
databasePointer(Database)


GetRegAppZcadId Method (databasePointer)

GetRegAppZcadId Method (databasePointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetRegAppZcadId(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetRegAppZcadId(
    Database databasePointer
)
Public Shared Function GetRegAppZcadId ( _
    databasePointer As Database _
) As ObjectId
public:
static ObjectId GetRegAppZcadId(
    Database^ databasePointer
)
Parameters
databasePointer(Database)


GetSymbolNameFromPathName Method (pathName, extensions)

GetSymbolNameFromPathName Method (pathName, extensions)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetSymbolNameFromPathName(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public static string GetSymbolNameFromPathName(
    string pathName,
    string extensions
)
Public Shared Function GetSymbolNameFromPathName ( _
    pathName As String, _
    extensions As String _
) As String
public:
static String^ GetSymbolNameFromPathName(
    String^ pathName,
    String^ extensions
)
Parameters
pathName(String)
extensions(String)


GetTextStyleStandardId Method (databasePointer)

GetTextStyleStandardId Method (databasePointer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »GetTextStyleStandardId(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static ObjectId GetTextStyleStandardId(
    Database databasePointer
)
Public Shared Function GetTextStyleStandardId ( _
    databasePointer As Database _
) As ObjectId
public:
static ObjectId GetTextStyleStandardId(
    Database^ databasePointer
)
Parameters
databasePointer(Database)


IsBlockLayoutName Method (name)

IsBlockLayoutName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsBlockLayoutName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBlockLayoutName(
    string name
)
Public Shared Function IsBlockLayoutName ( _
    name As String _
) As Boolean
public:
static bool IsBlockLayoutName(
    String^ name
)
Parameters
name(String)


IsBlockModelSpaceName Method (name)

IsBlockModelSpaceName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsBlockModelSpaceName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBlockModelSpaceName(
    string name
)
Public Shared Function IsBlockModelSpaceName ( _
    name As String _
) As Boolean
public:
static bool IsBlockModelSpaceName(
    String^ name
)
Parameters
name(String)


IsBlockPaperSpaceName Method (name)

IsBlockPaperSpaceName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsBlockPaperSpaceName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBlockPaperSpaceName(
    string name
)
Public Shared Function IsBlockPaperSpaceName ( _
    name As String _
) As Boolean
public:
static bool IsBlockPaperSpaceName(
    String^ name
)
Parameters
name(String)


IsCompatibilityMode Method (database)

IsCompatibilityMode Method (database)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsCompatibilityMode(Database)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsCompatibilityMode(
    Database database
)
Public Shared Function IsCompatibilityMode ( _
    database As Database _
) As Boolean
public:
static bool IsCompatibilityMode(
    Database^ database
)
Parameters
database(Database)


IsLayerDefpointsName Method (name)

IsLayerDefpointsName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsLayerDefpointsName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsLayerDefpointsName(
    string name
)
Public Shared Function IsLayerDefpointsName ( _
    name As String _
) As Boolean
public:
static bool IsLayerDefpointsName(
    String^ name
)
Parameters
name(String)


IsLayerZeroName Method (name)

IsLayerZeroName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsLayerZeroName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsLayerZeroName(
    string name
)
Public Shared Function IsLayerZeroName ( _
    name As String _
) As Boolean
public:
static bool IsLayerZeroName(
    String^ name
)
Parameters
name(String)


IsLinetypeByBlockName Method (name)

IsLinetypeByBlockName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsLinetypeByBlockName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsLinetypeByBlockName(
    string name
)
Public Shared Function IsLinetypeByBlockName ( _
    name As String _
) As Boolean
public:
static bool IsLinetypeByBlockName(
    String^ name
)
Parameters
name(String)


IsLinetypeByLayerName Method (name)

IsLinetypeByLayerName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsLinetypeByLayerName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsLinetypeByLayerName(
    string name
)
Public Shared Function IsLinetypeByLayerName ( _
    name As String _
) As Boolean
public:
static bool IsLinetypeByLayerName(
    String^ name
)
Parameters
name(String)


IsLinetypeContinuousName Method (name)

IsLinetypeContinuousName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsLinetypeContinuousName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsLinetypeContinuousName(
    string name
)
Public Shared Function IsLinetypeContinuousName ( _
    name As String _
) As Boolean
public:
static bool IsLinetypeContinuousName(
    String^ name
)
Parameters
name(String)


IsRegAppAcadName Method (name)

IsRegAppAcadName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsRegAppAcadName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsRegAppAcadName(
    string name
)
Public Shared Function IsRegAppAcadName ( _
    name As String _
) As Boolean
public:
static bool IsRegAppAcadName(
    String^ name
)
Parameters
name(String)


IsRegAppZcadName Method (name)

IsRegAppZcadName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsRegAppZcadName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsRegAppZcadName(
    string name
)
Public Shared Function IsRegAppZcadName ( _
    name As String _
) As Boolean
public:
static bool IsRegAppZcadName(
    String^ name
)
Parameters
name(String)


IsTextStyleStandardName Method (name)

IsTextStyleStandardName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsTextStyleStandardName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsTextStyleStandardName(
    string name
)
Public Shared Function IsTextStyleStandardName ( _
    name As String _
) As Boolean
public:
static bool IsTextStyleStandardName(
    String^ name
)
Parameters
name(String)


IsViewportActiveName Method (name)

IsViewportActiveName Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »IsViewportActiveName(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsViewportActiveName(
    string name
)
Public Shared Function IsViewportActiveName ( _
    name As String _
) As Boolean
public:
static bool IsViewportActiveName(
    String^ name
)
Parameters
name(String)


LayerDefpointsName Property

LayerDefpointsName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »LayerDefpointsName
Declaration Syntax
C# Visual Basic Visual C++
public static string LayerDefpointsName { get; }
Public Shared ReadOnly Property LayerDefpointsName As String
    Get
public:
static property String^ LayerDefpointsName {
    String^ get ();
}


LayerZeroName Property

LayerZeroName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »LayerZeroName
Declaration Syntax
C# Visual Basic Visual C++
public static string LayerZeroName { get; }
Public Shared ReadOnly Property LayerZeroName As String
    Get
public:
static property String^ LayerZeroName {
    String^ get ();
}


LinetypeByBlockName Property

LinetypeByBlockName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »LinetypeByBlockName
Declaration Syntax
C# Visual Basic Visual C++
public static string LinetypeByBlockName { get; }
Public Shared ReadOnly Property LinetypeByBlockName As String
    Get
public:
static property String^ LinetypeByBlockName {
    String^ get ();
}


LinetypeByLayerName Property

LinetypeByLayerName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »LinetypeByLayerName
Declaration Syntax
C# Visual Basic Visual C++
public static string LinetypeByLayerName { get; }
Public Shared ReadOnly Property LinetypeByLayerName As String
    Get
public:
static property String^ LinetypeByLayerName {
    String^ get ();
}


LinetypeContinuousName Property

LinetypeContinuousName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »LinetypeContinuousName
Declaration Syntax
C# Visual Basic Visual C++
public static string LinetypeContinuousName { get; }
Public Shared ReadOnly Property LinetypeContinuousName As String
    Get
public:
static property String^ LinetypeContinuousName {
    String^ get ();
}


MakeDependentName Method (dwgName, symbolName)

MakeDependentName Method (dwgName, symbolName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »MakeDependentName(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public static string MakeDependentName(
    string dwgName,
    string symbolName
)
Public Shared Function MakeDependentName ( _
    dwgName As String, _
    symbolName As String _
) As String
public:
static String^ MakeDependentName(
    String^ dwgName,
    String^ symbolName
)
Parameters
dwgName(String)
symbolName(String)


PreValidateSymbolName Method (symname, preserveCase)

PreValidateSymbolName Method (symname, preserveCase)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »PreValidateSymbolName(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static string PreValidateSymbolName(
    string symname,
    bool preserveCase
)
Public Shared Function PreValidateSymbolName ( _
    symname As String, _
    preserveCase As Boolean _
) As String
public:
static String^ PreValidateSymbolName(
    String^ symname,
    bool preserveCase
)
Parameters
symname(String)
preserveCase(Boolean)


RegAppAcadName Property

RegAppAcadName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »RegAppAcadName
Declaration Syntax
C# Visual Basic Visual C++
public static string RegAppAcadName { get; }
Public Shared ReadOnly Property RegAppAcadName As String
    Get
public:
static property String^ RegAppAcadName {
    String^ get ();
}


RegAppZcadName Property

RegAppZcadName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »RegAppZcadName
Declaration Syntax
C# Visual Basic Visual C++
public static string RegAppZcadName { get; }
Public Shared ReadOnly Property RegAppZcadName As String
    Get
public:
static property String^ RegAppZcadName {
    String^ get ();
}


RepairPreExtendedSymbolName Method (oldName, allowVerticalBar)

RepairPreExtendedSymbolName Method (oldName, allowVerticalBar)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »RepairPreExtendedSymbolName(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static string RepairPreExtendedSymbolName(
    string oldName,
    bool allowVerticalBar
)
Public Shared Function RepairPreExtendedSymbolName ( _
    oldName As String, _
    allowVerticalBar As Boolean _
) As String
public:
static String^ RepairPreExtendedSymbolName(
    String^ oldName,
    bool allowVerticalBar
)
Parameters
oldName(String)
allowVerticalBar(Boolean)


RepairSymbolName Method (oldName, allowVerticalBar)

RepairSymbolName Method (oldName, allowVerticalBar)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »RepairSymbolName(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static string RepairSymbolName(
    string oldName,
    bool allowVerticalBar
)
Public Shared Function RepairSymbolName ( _
    oldName As String, _
    allowVerticalBar As Boolean _
) As String
public:
static String^ RepairSymbolName(
    String^ oldName,
    bool allowVerticalBar
)
Parameters
oldName(String)
allowVerticalBar(Boolean)


TextStyleStandardName Property

TextStyleStandardName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »TextStyleStandardName
Declaration Syntax
C# Visual Basic Visual C++
public static string TextStyleStandardName { get; }
Public Shared ReadOnly Property TextStyleStandardName As String
    Get
public:
static property String^ TextStyleStandardName {
    String^ get ();
}


ValidateCompatibleSymbolName Method (name, isNewName, allowVerticalBar, compatibilityMode)

ValidateCompatibleSymbolName Method (name, isNewName, allowVerticalBar, compatibilityMode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »ValidateCompatibleSymbolName(String, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static ErrorStatus ValidateCompatibleSymbolName(
    string name,
    bool isNewName,
    bool allowVerticalBar,
    bool compatibilityMode
)
Public Shared Function ValidateCompatibleSymbolName ( _
    name As String, _
    isNewName As Boolean, _
    allowVerticalBar As Boolean, _
    compatibilityMode As Boolean _
) As ErrorStatus
public:
static ErrorStatus ValidateCompatibleSymbolName(
    String^ name,
    bool isNewName,
    bool allowVerticalBar,
    bool compatibilityMode
)
Parameters
name(String)
isNewName(Boolean)
allowVerticalBar(Boolean)
compatibilityMode(Boolean)


ValidatePreExtendedSymbolName Method (name, allowVerticalBar)

ValidatePreExtendedSymbolName Method (name, allowVerticalBar)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »ValidatePreExtendedSymbolName(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static void ValidatePreExtendedSymbolName(
    string name,
    bool allowVerticalBar
)
Public Shared Sub ValidatePreExtendedSymbolName ( _
    name As String, _
    allowVerticalBar As Boolean _
)
public:
static void ValidatePreExtendedSymbolName(
    String^ name,
    bool allowVerticalBar
)
Parameters
name(String)
allowVerticalBar(Boolean)


ValidateSymbolName Method (name, allowVerticalBar)

ValidateSymbolName Method (name, allowVerticalBar)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »ValidateSymbolName(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static void ValidateSymbolName(
    string name,
    bool allowVerticalBar
)
Public Shared Sub ValidateSymbolName ( _
    name As String, _
    allowVerticalBar As Boolean _
)
public:
static void ValidateSymbolName(
    String^ name,
    bool allowVerticalBar
)
Parameters
name(String)
allowVerticalBar(Boolean)


ViewportActiveName Property

ViewportActiveName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolUtilityServices »ViewportActiveName
Declaration Syntax
C# Visual Basic Visual C++
public static string ViewportActiveName { get; }
Public Shared ReadOnly Property ViewportActiveName As String
    Get
public:
static property String^ ViewportActiveName {
    String^ get ();
}


SystemVariableChangedEventArgs Class

SystemVariableChangedEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SystemVariableChangedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SystemVariableChangedEventArgs : EventArgs
Public NotInheritable Class SystemVariableChangedEventArgs _
    Inherits EventArgs
public ref class SystemVariableChangedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Changed |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SystemVariableChangedEventArgs


Changed Property

Changed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SystemVariableChangedEventArgs »Changed
Declaration Syntax
C# Visual Basic Visual C++
public bool Changed { get; }
Public ReadOnly Property Changed As Boolean
    Get
public:
property bool Changed {
    bool get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SystemVariableChangedEventArgs »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


SystemVariableChangedEventHandler Delegate

SystemVariableChangedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SystemVariableChangedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void SystemVariableChangedEventHandler(
    Object sender,
    SystemVariableChangedEventArgs e
)
Public Delegate Sub SystemVariableChangedEventHandler ( _
    sender As Object, _
    e As SystemVariableChangedEventArgs _
)
public delegate void SystemVariableChangedEventHandler(
    Object^ sender,
    SystemVariableChangedEventArgs^ e
)
Parameters
sender(Object)
e(SystemVariableChangedEventArgs)


SystemVariableChangingEventArgs Class

SystemVariableChangingEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SystemVariableChangingEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SystemVariableChangingEventArgs : EventArgs
Public NotInheritable Class SystemVariableChangingEventArgs _
    Inherits EventArgs
public ref class SystemVariableChangingEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SystemVariableChangingEventArgs


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SystemVariableChangingEventArgs »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


SystemVariableChangingEventHandler Delegate

SystemVariableChangingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SystemVariableChangingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void SystemVariableChangingEventHandler(
    Object sender,
    SystemVariableChangingEventArgs e
)
Public Delegate Sub SystemVariableChangingEventHandler ( _
    sender As Object, _
    e As SystemVariableChangingEventArgs _
)
public delegate void SystemVariableChangingEventHandler(
    Object^ sender,
    SystemVariableChangingEventArgs^ e
)
Parameters
sender(Object)
e(SystemVariableChangingEventArgs)


Table Class

Table Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbTable")]
public class Table : BlockReference
<WrapperAttribute("ZcDbTable")> _
Public Class Table _
    Inherits BlockReference
[WrapperAttribute(L"ZcDbTable")]
public ref class Table : public BlockReference
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Table(IntPtr, Boolean) |
 | Table()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Alignment(Int32, Int32) |
 | Alignment(RowType) |
 | Annotative | (Inherited from DBObject.)
 | AnonymousBlockTableRecord | (Inherited from BlockReference.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | AttachmentPoint(Int32, Int32) |
 | AttributeCollection | (Inherited from BlockReference.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackgroundColor(Int32, Int32) |
 | BackgroundColor(RowType) |
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BlockRotation(Int32, Int32) |
 | BlockScale(Int32, Int32) |
 | BlockTableRecord | (Inherited from BlockReference.)
 | BlockTableRecordId(Int32, Int32) |
 | BlockTransform | (Inherited from BlockReference.)
 | BlockUnit | (Inherited from BlockReference.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | BreakEnabled |
 | BreakFlowDirection |
 | BreakOptions |
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CanDeleteColumns(Int32, Int32) |
 | CanDeleteRows(Int32, Int32) |
 | CanInsertColumn(Int32) |
 | CanInsertRow(Int32) |
 | CastShadows | (Inherited from Entity.)
 | Cells |
 | CellStyleOverrides(Int32, Int32) |
 | CellType(Int32, Int32) |
 | ClassID | (Inherited from DBObject.)
 | ClearSubSelection()()()() |
 | ClearTableStyleOverrides(Int32) |
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | Columns |
 | ColumnWidth(Int32) |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ContentColor(Int32, Int32) |
 | ContentColor(RowType) |
 | ConvertToStaticBlock(String) | (Inherited from BlockReference.)
 | ConvertToStaticBlock()()()() | (Inherited from BlockReference.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(CellRange%, Table, TableCopyOptions, CellRange, CellRange) |
 | CopyFrom(CellRange%, LinkedTableData, TableCopyOptions, CellRange, CellRange) |
 | CopyFrom(LinkedTableData, TableCopyOptions) |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateContent(Int32, Int32, Int32) |
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DataType(Int32, Int32) |
 | DataType(RowType) |
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteCellContent(Int32, Int32) |
 | DeleteColumns(Int32, Int32) |
 | DeleteContent(Int32, Int32, Int32) |
 | DeleteContent(Int32, Int32) |
 | DeleteContent(CellRange) |
 | DeleteRows(Int32, Int32) |
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Direction |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from BlockReference.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | DynamicBlockReferencePropertyCollection | (Inherited from BlockReference.)
 | DynamicBlockTableRecord | (Inherited from BlockReference.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExplodeToOwnerSpace()()()() | (Inherited from BlockReference.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FieldId(Int32, Int32) |
 | Fill(CellRange, CellRange, TableFillOptions) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FlowDirection |
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | Format(Int32, Int32) |
 | Format(RowType) |
 | GenerateLayout()()()() |
 | GeometricExtents | (Inherited from Entity.)
 | GeometryExtentsBestFit(Matrix3d) | (Inherited from BlockReference.)
 | GeometryExtentsBestFit()()()() | (Inherited from BlockReference.)
 | GeomExtents | (Inherited from Entity.)
 | GetBlockAttributeValue(Int32, Int32, Int32, ObjectId) |
 | GetBlockAttributeValue(Int32, Int32, ObjectId) |
 | GetBlockTableRecordId(Int32, Int32, Int32) |
 | GetBreakHeight(Int32) |
 | GetBreakOffset(Int32) |
 | GetBreakSpacing()()()() |
 | GetCellExtents(Int32, Int32, Boolean, Point3dCollection) |
 | GetCellState(Int32, Int32) |
 | GetCellStyle(Int32, Int32) |
 | GetColumnName(Int32) |
 | GetContentColor(Int32, Int32, Int32) |
 | GetContentLayout(Int32, Int32) |
 | GetContentTypes(Int32, Int32, Int32) |
 | GetContentTypes(Int32, Int32) |
 | GetCustomData(Int32, Int32, String) |
 | GetCustomData(Int32, Int32) |
 | GetDataFormat(Int32, Int32, Int32) |
 | GetDataFormat(Int32, Int32) |
 | GetDataLink(Int32, Int32) |
 | GetDataLink(CellRange) |
 | GetDataLink()()()() |
 | GetDataLinkRange(Int32, Int32) |
 | GetDataType(Int32, Int32, Int32) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFieldId(Int32, Int32, Int32) |
 | GetFormula(Int32, Int32, Int32) |
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGridColor(Int32, Int32, GridLineType) |
 | GetGridDoubleLineSpacing(Int32, Int32, GridLineType) |
 | GetGridLineStyle(Int32, Int32, GridLineType) |
 | GetGridLinetype(Int32, Int32, GridLineType) |
 | GetGridLineWeight(Int32, Int32, GridLineType) |
 | GetGridProperty(Int32, Int32, GridLineType) |
 | GetGridVisibility(Int32, Int32, GridLineType) |
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetIsAutoScale(Int32, Int32, Int32) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetMargin(Int32, Int32, CellMargins) |
 | GetMergeAllEnabled(Int32, Int32) |
 | GetMergeRange(Int32, Int32) |
 | GetNumberOfContents(Int32, Int32) |
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOverrides(Int32, Int32, Int32) |
 | GetOverrides(Int32, Int32, GridLineType) |
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRotation(Int32, Int32, Int32) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetScale(Int32, Int32, Int32) |
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTextHeight(Int32, Int32, Int32) |
 | GetTextString(Int32, Int32, Int32, FormatOption) |
 | GetTextString(Int32, Int32, Int32) |
 | GetTextStyleId(Int32, Int32, Int32) |
 | GetToolTip(Int32, Int32) |
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetValue(Int32, Int32, Int32, FormatOption) |
 | GetValue(Int32, Int32, Int32) |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | GridColor(Int32, Int32, CellEdgeMasks) |
 | GridColor(GridLineType, RowType) |
 | GridLineWeight(Int32, Int32, CellEdgeMasks) |
 | GridLineWeight(GridLineType, RowType) |
 | GridVisibility(Int32, Int32, CellEdgeMasks) |
 | GridVisibility(GridLineType, RowType) |
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasFormula(Int32, Int32, Int32) |
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | HasSubSelection |
 | Height |
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | HitTest(Point3d, Vector3d) |
 | HorizontalCellMargin |
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertColumns(Int32, Double, Int32) |
 | InsertColumnsAndInherit(Int32, Int32, Int32) |
 | InsertRows(Int32, Double, Int32) |
 | InsertRowsAndInherit(Int32, Int32, Int32) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsAutoScale(Int32, Int32) |
 | IsBackgroundColorNone(Int32, Int32) |
 | IsBackgroundColorNone(RowType) |
 | IsCancelling | (Inherited from DBObject.)
 | IsContentEditable(Int32, Int32) |
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsDynamicBlock | (Inherited from BlockReference.)
 | IsEmpty(Int32, Int32) |
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsFormatEditable(Int32, Int32) |
 | IsHeaderSuppressed | Obsolete.
 | IsLinked(Int32, Int32) |
 | IsMergedCell(Int32, Int32, CellRange) |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTitleSuppressed | Obsolete.
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeCells(CellRange) |
 | MergeStyle | (Inherited from DBObject.)
 | MinimumColumnWidth(Int32) |
 | MinimumRowHeight(Int32) |
 | MinimumTableHeight |
 | MinimumTableWidth |
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveContent(Int32, Int32, Int32, Int32) |
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Name | (Inherited from BlockReference.)
 | Normal | (Inherited from BlockReference.)
 | NumColumns | Obsolete.
 | NumRows | Obsolete.
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position | (Inherited from BlockReference.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecomputeTableBlock(Boolean) |
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveAllOverrides(Int32, Int32) |
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveDataLink(Int32, Int32) |
 | RemoveDataLink()()()() |
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ReselectSubRegion(array<FullSubentityPath>[]()[][]) |
 | ResetBlock()()()() | (Inherited from BlockReference.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ResetValue(Int32, Int32) |
 | Rotation | (Inherited from BlockReference.)
 | RowHeight(Int32) |
 | Rows |
 | RowType(Int32) |
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | ScaleFactors | (Inherited from BlockReference.)
 | Select(Point3d, Vector3d, Vector3d, Boolean, Boolean, array<FullSubentityPath>[]()[][]) |
 | SelectSubRegion(Point3d, Point3d, Vector3d, Vector3d, SelectType, Boolean, Boolean, array<FullSubentityPath>[]()[][]) |
 | SetAlignment(Int32, Int32, CellAlignment) |
 | SetAlignment(CellAlignment, Int32) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetAutoScale(Int32, Int32, Boolean) |
 | SetBackgroundColor(Int32, Int32, Color) |
 | SetBackgroundColor(Color, Int32) |
 | SetBackgroundColorNone(Int32, Int32, Boolean) |
 | SetBackgroundColorNone(Boolean, Int32) |
 | SetBlockAttributeValue(Int32, Int32, Int32, ObjectId, String) |
 | SetBlockAttributeValue(Int32, Int32, ObjectId, String) |
 | SetBlockRotation(Int32, Int32, Double) |
 | SetBlockScale(Int32, Int32, Double) |
 | SetBlockTableRecordId(Int32, Int32, Int32, ObjectId, Boolean) |
 | SetBlockTableRecordId(Int32, Int32, ObjectId, Boolean) |
 | SetBreakHeight(Int32, Double) |
 | SetBreakOffset(Int32, Vector3d) |
 | SetBreakSpacing(Double) |
 | SetCellState(Int32, Int32, CellStates) |
 | SetCellStyle(Int32, Int32, String) |
 | SetCellType(Int32, Int32, TableCellType) |
 | SetColumnName(Int32, String) |
 | SetColumnWidth(Int32, Double) |
 | SetColumnWidth(Double) |
 | SetContentColor(Int32, Int32, Int32, Color) |
 | SetContentColor(Int32, Int32, Color) |
 | SetContentColor(Color, Int32) |
 | SetContentLayout(Int32, Int32, CellContentLayout) |
 | SetCustomData(Int32, Int32, String, Object) |
 | SetCustomData(Int32, Int32, Int32) |
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDataFormat(Int32, Int32, Int32, String) |
 | SetDataFormat(Int32, Int32, String) |
 | SetDataLink(Int32, Int32, ObjectId, Boolean) |
 | SetDataLink(CellRange, ObjectId, Boolean) |
 | SetDataType(Int32, Int32, Int32, DataTypeParameter) |
 | SetDataType(Int32, Int32, DataType, UnitType) |
 | SetDataType(DataType, UnitType, Int32) |
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFieldId(Int32, Int32, Int32, ObjectId, CellOption) |
 | SetFieldId(Int32, Int32, ObjectId) |
 | SetFormat(Int32, Int32, String) |
 | SetFormat(String, Int32) |
 | SetFormula(Int32, Int32, Int32, String) |
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGridColor(Int32, Int32, Int16, Color) |
 | SetGridColor(Int32, Int32, GridLineType, Color) |
 | SetGridColor(Color, Int32, Int32) |
 | SetGridDoubleLineSpacing(Int32, Int32, GridLineType, Double) |
 | SetGridLineStyle(Int32, Int32, GridLineType, GridLineStyle) |
 | SetGridLinetype(Int32, Int32, GridLineType, ObjectId) |
 | SetGridLineWeight(Int32, Int32, Int16, LineWeight) |
 | SetGridLineWeight(Int32, Int32, GridLineType, LineWeight) |
 | SetGridLineWeight(LineWeight, Int32, Int32) |
 | SetGridProperty(Int32, Int32, GridLineType, GridPropertyParameter) |
 | SetGridProperty(CellRange, GridLineType, GridPropertyParameter) |
 | SetGridVisibility(Int32, Int32, Int16, Boolean) |
 | SetGridVisibility(Int32, Int32, GridLineType, Visibility) |
 | SetGridVisibility(Boolean, Int32, Int32) |
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetIsAutoScale(Int32, Int32, Int32, Boolean) |
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetMargin(Int32, Int32, CellMargins, Double) |
 | SetMergeAllEnabled(Int32, Int32, Boolean) |
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetOverrides(Int32, Int32, Int32, CellProperties) |
 | SetOverrides(Int32, Int32, GridLineType, CellProperties) |
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetRotation(Int32, Int32, Int32, Double) |
 | SetRowHeight(Int32, Double) |
 | SetRowHeight(Double) |
 | SetScale(Int32, Int32, Int32, Double) |
 | SetSize(Int32, Int32) |
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetTextHeight(Int32, Int32, Int32, Double) |
 | SetTextHeight(Int32, Int32, Double) |
 | SetTextHeight(Double, Int32) |
 | SetTextRotation(Int32, Int32, RotationAngle) |
 | SetTextString(Int32, Int32, Int32, String) |
 | SetTextString(Int32, Int32, String) |
 | SetTextStyle(Int32, Int32, ObjectId) |
 | SetTextStyle(ObjectId, Int32) |
 | SetTextStyleId(Int32, Int32, Int32, ObjectId) |
 | SetToolTip(Int32, Int32, String) |
 | SetValue(Int32, Int32, Int32, String, ParseOption) |
 | SetValue(Int32, Int32, Int32, Object, ParseOption) |
 | SetValue(Int32, Int32, String, ParseOption) |
 | SetValue(Int32, Int32, Int32, Object) |
 | SetValue(Int32, Int32, Object) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSelection |
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SuppressRegenerateTable(Boolean) |
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TableStyle |
 | TableStyleOverrides()()()() |
 | TextHeight(Int32, Int32) |
 | TextHeight(RowType) |
 | TextRotation(Int32, Int32) |
 | TextString(Int32, Int32, FormatOption) |
 | TextString(Int32, Int32) |
 | TextStringConst(Int32, Int32) |
 | TextStyle(Int32, Int32) |
 | TextStyle(RowType) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | TreatAsBlockRefForExplode | (Inherited from BlockReference.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnitFactor | (Inherited from BlockReference.)
 | UnitType(Int32, Int32) |
 | UnitType(RowType) |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UnmergeCells(CellRange) |
 | UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) |
 | UpdateDataLink(UpdateDirection, UpdateOption) |
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | Value(Int32, Int32) |
 | VerticalCellMargin |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | BlockReference
 |  |  |  |  |  |  |  | Table


Table Constructor

Table Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Table()()()()
Members
Icon | Member | Description
 | Table(IntPtr, Boolean) |
 | Table()()()() |


Table Constructor

Table Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Table()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Table()
Public Sub New
public:
Table()


Table Constructor (unmanagedPointer, autoDelete)

Table Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Table(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Table(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Table(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Alignment Method

Alignment Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Alignment()()()()
Members
Icon | Member | Description
 | Alignment(Int32, Int32) |
 | Alignment(RowType) |


Alignment Method (row, col)

Alignment Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Alignment(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellAlignment Alignment(
    int row,
    int col
)
Public Overridable Function Alignment ( _
    row As Integer, _
    col As Integer _
) As CellAlignment
public:
virtual CellAlignment Alignment(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


Alignment Method (type)

Alignment Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Alignment(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellAlignment Alignment(
    RowType type
)
Public Overridable Function Alignment ( _
    type As RowType _
) As CellAlignment
public:
virtual CellAlignment Alignment(
    RowType type
)
Parameters
type(RowType)


AttachmentPoint Method (row, col)

AttachmentPoint Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »AttachmentPoint(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point3d AttachmentPoint(
    int row,
    int col
)
Public Overridable Function AttachmentPoint ( _
    row As Integer, _
    col As Integer _
) As Point3d
public:
virtual Point3d AttachmentPoint(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


BackgroundColor Method

BackgroundColor Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »BackgroundColor()()()()
Members
Icon | Member | Description
 | BackgroundColor(Int32, Int32) |
 | BackgroundColor(RowType) |


BackgroundColor Method (row, col)

BackgroundColor Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »BackgroundColor(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color BackgroundColor(
    int row,
    int col
)
Public Overridable Function BackgroundColor ( _
    row As Integer, _
    col As Integer _
) As Color
public:
virtual Color^ BackgroundColor(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


BackgroundColor Method (type)

BackgroundColor Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »BackgroundColor(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color BackgroundColor(
    RowType type
)
Public Overridable Function BackgroundColor ( _
    type As RowType _
) As Color
public:
virtual Color^ BackgroundColor(
    RowType type
)
Parameters
type(RowType)


BlockRotation Method (row, col)

BlockRotation Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »BlockRotation(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double BlockRotation(
    int row,
    int col
)
Public Overridable Function BlockRotation ( _
    row As Integer, _
    col As Integer _
) As Double
public:
virtual double BlockRotation(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


BlockScale Method (row, col)

BlockScale Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »BlockScale(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double BlockScale(
    int row,
    int col
)
Public Overridable Function BlockScale ( _
    row As Integer, _
    col As Integer _
) As Double
public:
virtual double BlockScale(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


BlockTableRecordId Method (row, col)

BlockTableRecordId Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »BlockTableRecordId(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId BlockTableRecordId(
    int row,
    int col
)
Public Overridable Function BlockTableRecordId ( _
    row As Integer, _
    col As Integer _
) As ObjectId
public:
virtual ObjectId BlockTableRecordId(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


BreakEnabled Property

BreakEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »BreakEnabled
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool BreakEnabled { get; set; }
Public Overridable Property BreakEnabled As Boolean
    Get
    Set
public:
virtual property bool BreakEnabled {
    bool get ();
    void set (bool value);
}


BreakFlowDirection Property

BreakFlowDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »BreakFlowDirection
Declaration Syntax
C# Visual Basic Visual C++
public virtual TableBreakFlowDirection BreakFlowDirection { get; set; }
Public Overridable Property BreakFlowDirection As TableBreakFlowDirection
    Get
    Set
public:
virtual property TableBreakFlowDirection BreakFlowDirection {
    TableBreakFlowDirection get ();
    void set (TableBreakFlowDirection value);
}


BreakOptions Property

BreakOptions Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »BreakOptions
Declaration Syntax
C# Visual Basic Visual C++
public virtual TableBreakOptions BreakOptions { get; set; }
Public Overridable Property BreakOptions As TableBreakOptions
    Get
    Set
public:
virtual property TableBreakOptions BreakOptions {
    TableBreakOptions get ();
    void set (TableBreakOptions value);
}


CanDeleteColumns Method (index, nCount)

CanDeleteColumns Method (index, nCount)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CanDeleteColumns(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool CanDeleteColumns(
    int index,
    int nCount
)
Public Overridable Function CanDeleteColumns ( _
    index As Integer, _
    nCount As Integer _
) As Boolean
public:
virtual bool CanDeleteColumns(
    int index,
    int nCount
)
Parameters
index(Int32)
nCount(Int32)


CanDeleteRows Method (index, nCount)

CanDeleteRows Method (index, nCount)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CanDeleteRows(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool CanDeleteRows(
    int index,
    int nCount
)
Public Overridable Function CanDeleteRows ( _
    index As Integer, _
    nCount As Integer _
) As Boolean
public:
virtual bool CanDeleteRows(
    int index,
    int nCount
)
Parameters
index(Int32)
nCount(Int32)


CanInsertColumn Method (index)

CanInsertColumn Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CanInsertColumn(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool CanInsertColumn(
    int index
)
Public Overridable Function CanInsertColumn ( _
    index As Integer _
) As Boolean
public:
virtual bool CanInsertColumn(
    int index
)
Parameters
index(Int32)


CanInsertRow Method (index)

CanInsertRow Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CanInsertRow(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool CanInsertRow(
    int index
)
Public Overridable Function CanInsertRow ( _
    index As Integer _
) As Boolean
public:
virtual bool CanInsertRow(
    int index
)
Parameters
index(Int32)


Cells Property

Cells Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Cells
Declaration Syntax
C# Visual Basic Visual C++
public CellRange Cells { get; }
Public ReadOnly Property Cells As CellRange
    Get
public:
property CellRange^ Cells {
    CellRange^ get ();
}


CellStyleOverrides Method (row, col)

CellStyleOverrides Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CellStyleOverrides(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual TableStyleOverride[] CellStyleOverrides(
    int row,
    int col
)
Public Overridable Function CellStyleOverrides ( _
    row As Integer, _
    col As Integer _
) As TableStyleOverride()
public:
virtual array<TableStyleOverride>^ CellStyleOverrides(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


CellType Method (row, col)

CellType Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CellType(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual TableCellType CellType(
    int row,
    int col
)
Public Overridable Function CellType ( _
    row As Integer, _
    col As Integer _
) As TableCellType
public:
virtual TableCellType CellType(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


ClearSubSelection Method

ClearSubSelection Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »ClearSubSelection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ClearSubSelection()
Public Overridable Sub ClearSubSelection
public:
virtual void ClearSubSelection()


ClearTableStyleOverrides Method (options)

ClearTableStyleOverrides Method (options)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »ClearTableStyleOverrides(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ClearTableStyleOverrides(
    int options
)
Public Overridable Sub ClearTableStyleOverrides ( _
    options As Integer _
)
public:
virtual void ClearTableStyleOverrides(
    int options
)
Parameters
options(Int32)


Columns Property

Columns Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Columns
Declaration Syntax
C# Visual Basic Visual C++
public ColumnsCollection Columns { get; }
Public ReadOnly Property Columns As ColumnsCollection
    Get
public:
property ColumnsCollection^ Columns {
    ColumnsCollection^ get ();
}


ColumnWidth Method (col)

ColumnWidth Method (col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »ColumnWidth(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double ColumnWidth(
    int col
)
Public Overridable Function ColumnWidth ( _
    col As Integer _
) As Double
public:
virtual double ColumnWidth(
    int col
)
Parameters
col(Int32)


ContentColor Method

ContentColor Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »ContentColor()()()()
Members
Icon | Member | Description
 | ContentColor(Int32, Int32) |
 | ContentColor(RowType) |


ContentColor Method (row, col)

ContentColor Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »ContentColor(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color ContentColor(
    int row,
    int col
)
Public Overridable Function ContentColor ( _
    row As Integer, _
    col As Integer _
) As Color
public:
virtual Color^ ContentColor(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


ContentColor Method (type)

ContentColor Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »ContentColor(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color ContentColor(
    RowType type
)
Public Overridable Function ContentColor ( _
    type As RowType _
) As Color
public:
virtual Color^ ContentColor(
    RowType type
)
Parameters
type(RowType)


CopyFrom Method

CopyFrom Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CopyFrom()()()()
Members
Icon | Member | Description
 | CopyFrom(CellRange%, Table, TableCopyOptions, CellRange, CellRange) |
 | CopyFrom(CellRange%, LinkedTableData, TableCopyOptions, CellRange, CellRange) |
 | CopyFrom(LinkedTableData, TableCopyOptions) |
 | CopyFrom(RXObject) |


CopyFrom Method (param0, source, options, sourceRange, targetRange)

CopyFrom Method (param0, source, options, sourceRange, targetRange)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CopyFrom(CellRange%, LinkedTableData, TableCopyOptions, CellRange, CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyFrom(
    ref CellRange param0,
    LinkedTableData source,
    TableCopyOptions options,
    CellRange sourceRange,
    CellRange targetRange
)
Public Overridable Function CopyFrom ( _
    ByRef param0 As CellRange, _
    source As LinkedTableData, _
    options As TableCopyOptions, _
    sourceRange As CellRange, _
    targetRange As CellRange _
) As Void
public:
virtual void CopyFrom(
    CellRange^% param0,
    LinkedTableData^ source,
    TableCopyOptions options,
    CellRange^ sourceRange,
    CellRange^ targetRange
)
Parameters
param0(CellRange %)
source(LinkedTableData)
options(TableCopyOptions)
sourceRange(CellRange)
targetRange(CellRange)


CopyFrom Method (param0, source, options, sourceRange, targetRange)

CopyFrom Method (param0, source, options, sourceRange, targetRange)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CopyFrom(CellRange%, Table, TableCopyOptions, CellRange, CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyFrom(
    ref CellRange param0,
    Table source,
    TableCopyOptions options,
    CellRange sourceRange,
    CellRange targetRange
)
Public Overridable Function CopyFrom ( _
    ByRef param0 As CellRange, _
    source As Table, _
    options As TableCopyOptions, _
    sourceRange As CellRange, _
    targetRange As CellRange _
) As Void
public:
virtual void CopyFrom(
    CellRange^% param0,
    Table^ source,
    TableCopyOptions options,
    CellRange^ sourceRange,
    CellRange^ targetRange
)
Parameters
param0(CellRange %)
source(Table)
options(TableCopyOptions)
sourceRange(CellRange)
targetRange(CellRange)


CopyFrom Method (source, options)

CopyFrom Method (source, options)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CopyFrom(LinkedTableData, TableCopyOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyFrom(
    LinkedTableData source,
    TableCopyOptions options
)
Public Overridable Sub CopyFrom ( _
    source As LinkedTableData, _
    options As TableCopyOptions _
)
public:
virtual void CopyFrom(
    LinkedTableData^ source,
    TableCopyOptions options
)
Parameters
source(LinkedTableData)
options(TableCopyOptions)


CreateContent Method (row, column, contentIndex)

CreateContent Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »CreateContent(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int CreateContent(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function CreateContent ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As Integer
public:
virtual int CreateContent(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


DataType Method

DataType Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »DataType()()()()
Members
Icon | Member | Description
 | DataType(Int32, Int32) |
 | DataType(RowType) |


DataType Method (row, col)

DataType Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »DataType(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataType DataType(
    int row,
    int col
)
Public Overridable Function DataType ( _
    row As Integer, _
    col As Integer _
) As DataType
public:
virtual DataType DataType(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


DataType Method (type)

DataType Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »DataType(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataType DataType(
    RowType type
)
Public Overridable Function DataType ( _
    type As RowType _
) As DataType
public:
virtual DataType DataType(
    RowType type
)
Parameters
type(RowType)


DeleteCellContent Method (row, col)

DeleteCellContent Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »DeleteCellContent(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DeleteCellContent(
    int row,
    int col
)
Public Overridable Sub DeleteCellContent ( _
    row As Integer, _
    col As Integer _
)
public:
virtual void DeleteCellContent(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


DeleteColumns Method (col, columns)

DeleteColumns Method (col, columns)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »DeleteColumns(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DeleteColumns(
    int col,
    int columns
)
Public Overridable Sub DeleteColumns ( _
    col As Integer, _
    columns As Integer _
)
public:
virtual void DeleteColumns(
    int col,
    int columns
)
Parameters
col(Int32)
columns(Int32)


DeleteContent Method

DeleteContent Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »DeleteContent()()()()
Members
Icon | Member | Description
 | DeleteContent(Int32, Int32, Int32) |
 | DeleteContent(Int32, Int32) |
 | DeleteContent(CellRange) |


DeleteContent Method (row, column)

DeleteContent Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »DeleteContent(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DeleteContent(
    int row,
    int column
)
Public Overridable Sub DeleteContent ( _
    row As Integer, _
    column As Integer _
)
public:
virtual void DeleteContent(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


DeleteContent Method (row, column, contentIndex)

DeleteContent Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »DeleteContent(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DeleteContent(
    int row,
    int column,
    int contentIndex
)
Public Overridable Sub DeleteContent ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
)
public:
virtual void DeleteContent(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


DeleteContent Method (range1)

DeleteContent Method (range1)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »DeleteContent(CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DeleteContent(
    CellRange range1
)
Public Overridable Sub DeleteContent ( _
    range1 As CellRange _
)
public:
virtual void DeleteContent(
    CellRange^ range1
)
Parameters
range1(CellRange)


DeleteRows Method (row, rows)

DeleteRows Method (row, rows)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »DeleteRows(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DeleteRows(
    int row,
    int rows
)
Public Overridable Sub DeleteRows ( _
    row As Integer, _
    rows As Integer _
)
public:
virtual void DeleteRows(
    int row,
    int rows
)
Parameters
row(Int32)
rows(Int32)


Direction Property

Direction Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Direction
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d Direction { get; set; }
Public Overridable Property Direction As Vector3d
    Get
    Set
public:
virtual property Vector3d Direction {
    Vector3d get ();
    void set (Vector3d value);
}


FieldId Method (row, col)

FieldId Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »FieldId(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId FieldId(
    int row,
    int col
)
Public Overridable Function FieldId ( _
    row As Integer, _
    col As Integer _
) As ObjectId
public:
virtual ObjectId FieldId(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


Fill Method (fillRange, sourceRange, options)

Fill Method (fillRange, sourceRange, options)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Fill(CellRange, CellRange, TableFillOptions)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Fill(
    CellRange fillRange,
    CellRange sourceRange,
    TableFillOptions options
)
Public Overridable Sub Fill ( _
    fillRange As CellRange, _
    sourceRange As CellRange, _
    options As TableFillOptions _
)
public:
virtual void Fill(
    CellRange^ fillRange,
    CellRange^ sourceRange,
    TableFillOptions options
)
Parameters
fillRange(CellRange)
sourceRange(CellRange)
options(TableFillOptions)


FlowDirection Property

FlowDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »FlowDirection
Declaration Syntax
C# Visual Basic Visual C++
public virtual FlowDirection FlowDirection { get; set; }
Public Overridable Property FlowDirection As FlowDirection
    Get
    Set
public:
virtual property FlowDirection FlowDirection {
    FlowDirection get ();
    void set (FlowDirection value);
}


Format Method

Format Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Format()()()()
Members
Icon | Member | Description
 | Format(Int32, Int32) |
 | Format(RowType) |


Format Method (row, col)

Format Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Format(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Format(
    int row,
    int col
)
Public Overridable Function Format ( _
    row As Integer, _
    col As Integer _
) As String
public:
virtual String^ Format(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


Format Method (type)

Format Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Format(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Format(
    RowType type
)
Public Overridable Function Format ( _
    type As RowType _
) As String
public:
virtual String^ Format(
    RowType type
)
Parameters
type(RowType)


GenerateLayout Method

GenerateLayout Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GenerateLayout()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GenerateLayout()
Public Overridable Sub GenerateLayout
public:
virtual void GenerateLayout()


GetBlockAttributeValue Method

GetBlockAttributeValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetBlockAttributeValue()()()()
Members
Icon | Member | Description
 | GetBlockAttributeValue(Int32, Int32, Int32, ObjectId) |
 | GetBlockAttributeValue(Int32, Int32, ObjectId) |


GetBlockAttributeValue Method (row, column, contentIndex, attDefId)

GetBlockAttributeValue Method (row, column, contentIndex, attDefId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetBlockAttributeValue(Int32, Int32, Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetBlockAttributeValue(
    int row,
    int column,
    int contentIndex,
    ObjectId attDefId
)
Public Overridable Function GetBlockAttributeValue ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    attDefId As ObjectId _
) As String
public:
virtual String^ GetBlockAttributeValue(
    int row,
    int column,
    int contentIndex,
    ObjectId attDefId
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
attDefId(ObjectId)


GetBlockAttributeValue Method (row, col, attributeDefinitionId)

GetBlockAttributeValue Method (row, col, attributeDefinitionId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetBlockAttributeValue(Int32, Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetBlockAttributeValue(
    int row,
    int col,
    ObjectId attributeDefinitionId
)
Public Overridable Function GetBlockAttributeValue ( _
    row As Integer, _
    col As Integer, _
    attributeDefinitionId As ObjectId _
) As String
public:
virtual String^ GetBlockAttributeValue(
    int row,
    int col,
    ObjectId attributeDefinitionId
)
Parameters
row(Int32)
col(Int32)
attributeDefinitionId(ObjectId)


GetBlockTableRecordId Method (row, column, contentIndex)

GetBlockTableRecordId Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetBlockTableRecordId(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetBlockTableRecordId(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetBlockTableRecordId ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As ObjectId
public:
virtual ObjectId GetBlockTableRecordId(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetBreakHeight Method (index)

GetBreakHeight Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetBreakHeight(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetBreakHeight(
    int index
)
Public Overridable Function GetBreakHeight ( _
    index As Integer _
) As Double
public:
virtual double GetBreakHeight(
    int index
)
Parameters
index(Int32)


GetBreakOffset Method (index)

GetBreakOffset Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetBreakOffset(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d GetBreakOffset(
    int index
)
Public Overridable Function GetBreakOffset ( _
    index As Integer _
) As Vector3d
public:
virtual Vector3d GetBreakOffset(
    int index
)
Parameters
index(Int32)


GetBreakSpacing Method

GetBreakSpacing Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetBreakSpacing()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetBreakSpacing()
Public Overridable Function GetBreakSpacing As Double
public:
virtual double GetBreakSpacing()


GetCellExtents Method (row, col, isOuterCell, pts)

GetCellExtents Method (row, col, isOuterCell, pts)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetCellExtents(Int32, Int32, Boolean, Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetCellExtents(
    int row,
    int col,
    bool isOuterCell,
    Point3dCollection pts
)
Public Overridable Sub GetCellExtents ( _
    row As Integer, _
    col As Integer, _
    isOuterCell As Boolean, _
    pts As Point3dCollection _
)
public:
virtual void GetCellExtents(
    int row,
    int col,
    bool isOuterCell,
    Point3dCollection^ pts
)
Parameters
row(Int32)
col(Int32)
isOuterCell(Boolean)
pts(Point3dCollection)


GetCellState Method (row, column)

GetCellState Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetCellState(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellStates GetCellState(
    int row,
    int column
)
Public Overridable Function GetCellState ( _
    row As Integer, _
    column As Integer _
) As CellStates
public:
virtual CellStates GetCellState(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetCellStyle Method (row, column)

GetCellStyle Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetCellStyle(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetCellStyle(
    int row,
    int column
)
Public Overridable Function GetCellStyle ( _
    row As Integer, _
    column As Integer _
) As String
public:
virtual String^ GetCellStyle(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetColumnName Method (index)

GetColumnName Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetColumnName(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetColumnName(
    int index
)
Public Overridable Function GetColumnName ( _
    index As Integer _
) As String
public:
virtual String^ GetColumnName(
    int index
)
Parameters
index(Int32)


GetContentColor Method (row, column, contentIndex)

GetContentColor Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetContentColor(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color GetContentColor(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetContentColor ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As Color
public:
virtual Color^ GetContentColor(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetContentLayout Method (row, column)

GetContentLayout Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetContentLayout(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellContentLayout GetContentLayout(
    int row,
    int column
)
Public Overridable Function GetContentLayout ( _
    row As Integer, _
    column As Integer _
) As CellContentLayout
public:
virtual CellContentLayout GetContentLayout(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetContentTypes Method

GetContentTypes Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetContentTypes()()()()
Members
Icon | Member | Description
 | GetContentTypes(Int32, Int32, Int32) |
 | GetContentTypes(Int32, Int32) |


GetContentTypes Method (row, column)

GetContentTypes Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetContentTypes(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellContentTypes GetContentTypes(
    int row,
    int column
)
Public Overridable Function GetContentTypes ( _
    row As Integer, _
    column As Integer _
) As CellContentTypes
public:
virtual CellContentTypes GetContentTypes(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetContentTypes Method (row, column, contentIndex)

GetContentTypes Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetContentTypes(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellContentTypes GetContentTypes(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetContentTypes ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As CellContentTypes
public:
virtual CellContentTypes GetContentTypes(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetCustomData Method

GetCustomData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetCustomData()()()()
Members
Icon | Member | Description
 | GetCustomData(Int32, Int32, String) |
 | GetCustomData(Int32, Int32) |


GetCustomData Method (row, column)

GetCustomData Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetCustomData(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int GetCustomData(
    int row,
    int column
)
Public Overridable Function GetCustomData ( _
    row As Integer, _
    column As Integer _
) As Integer
public:
virtual int GetCustomData(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetCustomData Method (row, column, key)

GetCustomData Method (row, column, key)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetCustomData(Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object GetCustomData(
    int row,
    int column,
    string key
)
Public Overridable Function GetCustomData ( _
    row As Integer, _
    column As Integer, _
    key As String _
) As Object
public:
virtual Object^ GetCustomData(
    int row,
    int column,
    String^ key
)
Parameters
row(Int32)
column(Int32)
key(String)


GetDataFormat Method

GetDataFormat Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetDataFormat()()()()
Members
Icon | Member | Description
 | GetDataFormat(Int32, Int32, Int32) |
 | GetDataFormat(Int32, Int32) |


GetDataFormat Method (row, column)

GetDataFormat Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetDataFormat(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetDataFormat(
    int row,
    int column
)
Public Overridable Function GetDataFormat ( _
    row As Integer, _
    column As Integer _
) As String
public:
virtual String^ GetDataFormat(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetDataFormat Method (row, column, contentIndex)

GetDataFormat Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetDataFormat(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetDataFormat(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetDataFormat ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As String
public:
virtual String^ GetDataFormat(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetDataLink Method

GetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetDataLink()()()()
Members
Icon | Member | Description
 | GetDataLink(Int32, Int32) |
 | GetDataLink(CellRange) |
 | GetDataLink()()()() |


GetDataLink Method

GetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetDataLink()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectIdCollection GetDataLink()
Public Overridable Function GetDataLink As ObjectIdCollection
public:
virtual ObjectIdCollection^ GetDataLink()


GetDataLink Method (row, column)

GetDataLink Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetDataLink(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetDataLink(
    int row,
    int column
)
Public Overridable Function GetDataLink ( _
    row As Integer, _
    column As Integer _
) As ObjectId
public:
virtual ObjectId GetDataLink(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetDataLink Method (range)

GetDataLink Method (range)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetDataLink(CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectIdCollection GetDataLink(
    CellRange range
)
Public Overridable Function GetDataLink ( _
    range As CellRange _
) As ObjectIdCollection
public:
virtual ObjectIdCollection^ GetDataLink(
    CellRange^ range
)
Parameters
range(CellRange)


GetDataLinkRange Method (row, column)

GetDataLinkRange Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetDataLinkRange(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellRange GetDataLinkRange(
    int row,
    int column
)
Public Overridable Function GetDataLinkRange ( _
    row As Integer, _
    column As Integer _
) As CellRange
public:
virtual CellRange^ GetDataLinkRange(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetDataType Method (row, column, contentIndex)

GetDataType Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetDataType(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataTypeParameter GetDataType(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetDataType ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As DataTypeParameter
public:
virtual DataTypeParameter GetDataType(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetFieldId Method (row, column, contentIndex)

GetFieldId Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetFieldId(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetFieldId(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetFieldId ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As ObjectId
public:
virtual ObjectId GetFieldId(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetFormula Method (row, column, contentIndex)

GetFormula Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetFormula(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetFormula(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetFormula ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As String
public:
virtual String^ GetFormula(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetGridColor Method (row, column, gridLineType)

GetGridColor Method (row, column, gridLineType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetGridColor(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color GetGridColor(
    int row,
    int column,
    GridLineType gridLineType
)
Public Overridable Function GetGridColor ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType _
) As Color
public:
virtual Color^ GetGridColor(
    int row,
    int column,
    GridLineType gridLineType
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)


GetGridDoubleLineSpacing Method (row, column, gridLineType)

GetGridDoubleLineSpacing Method (row, column, gridLineType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetGridDoubleLineSpacing(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetGridDoubleLineSpacing(
    int row,
    int column,
    GridLineType gridLineType
)
Public Overridable Function GetGridDoubleLineSpacing ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType _
) As Double
public:
virtual double GetGridDoubleLineSpacing(
    int row,
    int column,
    GridLineType gridLineType
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)


GetGridLineStyle Method (row, column, gridLineType)

GetGridLineStyle Method (row, column, gridLineType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetGridLineStyle(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual GridLineStyle GetGridLineStyle(
    int row,
    int column,
    GridLineType gridLineType
)
Public Overridable Function GetGridLineStyle ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType _
) As GridLineStyle
public:
virtual GridLineStyle GetGridLineStyle(
    int row,
    int column,
    GridLineType gridLineType
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)


GetGridLinetype Method (row, column, gridLineType)

GetGridLinetype Method (row, column, gridLineType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetGridLinetype(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetGridLinetype(
    int row,
    int column,
    GridLineType gridLineType
)
Public Overridable Function GetGridLinetype ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType _
) As ObjectId
public:
virtual ObjectId GetGridLinetype(
    int row,
    int column,
    GridLineType gridLineType
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)


GetGridLineWeight Method (row, column, gridLineType)

GetGridLineWeight Method (row, column, gridLineType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetGridLineWeight(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight GetGridLineWeight(
    int row,
    int column,
    GridLineType gridLineType
)
Public Overridable Function GetGridLineWeight ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType _
) As LineWeight
public:
virtual LineWeight GetGridLineWeight(
    int row,
    int column,
    GridLineType gridLineType
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)


GetGridProperty Method (row, column, gridLineType)

GetGridProperty Method (row, column, gridLineType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetGridProperty(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual GridPropertyParameter GetGridProperty(
    int row,
    int column,
    GridLineType gridLineType
)
Public Overridable Function GetGridProperty ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType _
) As GridPropertyParameter
public:
virtual GridPropertyParameter GetGridProperty(
    int row,
    int column,
    GridLineType gridLineType
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)


GetGridVisibility Method (row, column, gridLineType)

GetGridVisibility Method (row, column, gridLineType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetGridVisibility(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Visibility GetGridVisibility(
    int row,
    int column,
    GridLineType gridLineType
)
Public Overridable Function GetGridVisibility ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType _
) As Visibility
public:
virtual Visibility GetGridVisibility(
    int row,
    int column,
    GridLineType gridLineType
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)


GetIsAutoScale Method (row, column, contentIndex)

GetIsAutoScale Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetIsAutoScale(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool GetIsAutoScale(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetIsAutoScale ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As Boolean
public:
virtual bool GetIsAutoScale(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetMargin Method (row, column, margin)

GetMargin Method (row, column, margin)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetMargin(Int32, Int32, CellMargins)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetMargin(
    int row,
    int column,
    CellMargins margin
)
Public Overridable Function GetMargin ( _
    row As Integer, _
    column As Integer, _
    margin As CellMargins _
) As Double
public:
virtual double GetMargin(
    int row,
    int column,
    CellMargins margin
)
Parameters
row(Int32)
column(Int32)
margin(CellMargins)


GetMergeAllEnabled Method (row, column)

GetMergeAllEnabled Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetMergeAllEnabled(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool GetMergeAllEnabled(
    int row,
    int column
)
Public Overridable Function GetMergeAllEnabled ( _
    row As Integer, _
    column As Integer _
) As Boolean
public:
virtual bool GetMergeAllEnabled(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetMergeRange Method (row, column)

GetMergeRange Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetMergeRange(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellRange GetMergeRange(
    int row,
    int column
)
Public Overridable Function GetMergeRange ( _
    row As Integer, _
    column As Integer _
) As CellRange
public:
virtual CellRange^ GetMergeRange(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetNumberOfContents Method (row, column)

GetNumberOfContents Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetNumberOfContents(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int GetNumberOfContents(
    int row,
    int column
)
Public Overridable Function GetNumberOfContents ( _
    row As Integer, _
    column As Integer _
) As Integer
public:
virtual int GetNumberOfContents(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetOverrides Method

GetOverrides Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetOverrides()()()()
Members
Icon | Member | Description
 | GetOverrides(Int32, Int32, Int32) |
 | GetOverrides(Int32, Int32, GridLineType) |


GetOverrides Method (row, column, contentIndex)

GetOverrides Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetOverrides(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellProperties GetOverrides(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetOverrides ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As CellProperties
public:
virtual CellProperties GetOverrides(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetOverrides Method (row, column, gridLineType)

GetOverrides Method (row, column, gridLineType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetOverrides(Int32, Int32, GridLineType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellProperties GetOverrides(
    int row,
    int column,
    GridLineType gridLineType
)
Public Overridable Function GetOverrides ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType _
) As CellProperties
public:
virtual CellProperties GetOverrides(
    int row,
    int column,
    GridLineType gridLineType
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)


GetRotation Method (row, column, contentIndex)

GetRotation Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetRotation(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetRotation(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetRotation ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As Double
public:
virtual double GetRotation(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetScale Method (row, column, contentIndex)

GetScale Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetScale(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetScale(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetScale ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As Double
public:
virtual double GetScale(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetTextHeight Method (row, column, contentIndex)

GetTextHeight Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetTextHeight(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetTextHeight(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetTextHeight ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As Double
public:
virtual double GetTextHeight(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetTextString Method

GetTextString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetTextString()()()()
Members
Icon | Member | Description
 | GetTextString(Int32, Int32, Int32, FormatOption) |
 | GetTextString(Int32, Int32, Int32) |


GetTextString Method (row, column, contentIndex)

GetTextString Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetTextString(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetTextString(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetTextString ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As String
public:
virtual String^ GetTextString(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetTextString Method (row, column, contentIndex, formatOption)

GetTextString Method (row, column, contentIndex, formatOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetTextString(Int32, Int32, Int32, FormatOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetTextString(
    int row,
    int column,
    int contentIndex,
    FormatOption formatOption
)
Public Overridable Function GetTextString ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    formatOption As FormatOption _
) As String
public:
virtual String^ GetTextString(
    int row,
    int column,
    int contentIndex,
    FormatOption formatOption
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
formatOption(FormatOption)


GetTextStyleId Method (row, column, contentIndex)

GetTextStyleId Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetTextStyleId(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId GetTextStyleId(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetTextStyleId ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As ObjectId
public:
virtual ObjectId GetTextStyleId(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetToolTip Method (row, column)

GetToolTip Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetToolTip(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetToolTip(
    int row,
    int column
)
Public Overridable Function GetToolTip ( _
    row As Integer, _
    column As Integer _
) As String
public:
virtual String^ GetToolTip(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetValue Method

GetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetValue()()()()
Members
Icon | Member | Description
 | GetValue(Int32, Int32, Int32, FormatOption) |
 | GetValue(Int32, Int32, Int32) |


GetValue Method (row, column, contentIndex)

GetValue Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetValue(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object GetValue(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function GetValue ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As Object
public:
virtual Object^ GetValue(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


GetValue Method (row, column, contentIndex, formatOption)

GetValue Method (row, column, contentIndex, formatOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetValue(Int32, Int32, Int32, FormatOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object GetValue(
    int row,
    int column,
    int contentIndex,
    FormatOption formatOption
)
Public Overridable Function GetValue ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    formatOption As FormatOption _
) As Object
public:
virtual Object^ GetValue(
    int row,
    int column,
    int contentIndex,
    FormatOption formatOption
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
formatOption(FormatOption)


GridColor Method

GridColor Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GridColor()()()()
Members
Icon | Member | Description
 | GridColor(Int32, Int32, CellEdgeMasks) |
 | GridColor(GridLineType, RowType) |


GridColor Method (row, col, edge)

GridColor Method (row, col, edge)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GridColor(Int32, Int32, CellEdgeMasks)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color GridColor(
    int row,
    int col,
    CellEdgeMasks edge
)
Public Overridable Function GridColor ( _
    row As Integer, _
    col As Integer, _
    edge As CellEdgeMasks _
) As Color
public:
virtual Color^ GridColor(
    int row,
    int col,
    CellEdgeMasks edge
)
Parameters
row(Int32)
col(Int32)
edge(CellEdgeMasks)


GridColor Method (gridlineType, type)

GridColor Method (gridlineType, type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GridColor(GridLineType, RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color GridColor(
    GridLineType gridlineType,
    RowType type
)
Public Overridable Function GridColor ( _
    gridlineType As GridLineType, _
    type As RowType _
) As Color
public:
virtual Color^ GridColor(
    GridLineType gridlineType,
    RowType type
)
Parameters
gridlineType(GridLineType)
type(RowType)


GridLineWeight Method

GridLineWeight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GridLineWeight()()()()
Members
Icon | Member | Description
 | GridLineWeight(Int32, Int32, CellEdgeMasks) |
 | GridLineWeight(GridLineType, RowType) |


GridLineWeight Method (row, col, edge)

GridLineWeight Method (row, col, edge)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GridLineWeight(Int32, Int32, CellEdgeMasks)
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight GridLineWeight(
    int row,
    int col,
    CellEdgeMasks edge
)
Public Overridable Function GridLineWeight ( _
    row As Integer, _
    col As Integer, _
    edge As CellEdgeMasks _
) As LineWeight
public:
virtual LineWeight GridLineWeight(
    int row,
    int col,
    CellEdgeMasks edge
)
Parameters
row(Int32)
col(Int32)
edge(CellEdgeMasks)


GridLineWeight Method (gridlineType, type)

GridLineWeight Method (gridlineType, type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GridLineWeight(GridLineType, RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight GridLineWeight(
    GridLineType gridlineType,
    RowType type
)
Public Overridable Function GridLineWeight ( _
    gridlineType As GridLineType, _
    type As RowType _
) As LineWeight
public:
virtual LineWeight GridLineWeight(
    GridLineType gridlineType,
    RowType type
)
Parameters
gridlineType(GridLineType)
type(RowType)


GridVisibility Method

GridVisibility Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GridVisibility()()()()
Members
Icon | Member | Description
 | GridVisibility(Int32, Int32, CellEdgeMasks) |
 | GridVisibility(GridLineType, RowType) |


GridVisibility Method (row, col, edge)

GridVisibility Method (row, col, edge)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GridVisibility(Int32, Int32, CellEdgeMasks)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool GridVisibility(
    int row,
    int col,
    CellEdgeMasks edge
)
Public Overridable Function GridVisibility ( _
    row As Integer, _
    col As Integer, _
    edge As CellEdgeMasks _
) As Boolean
public:
virtual bool GridVisibility(
    int row,
    int col,
    CellEdgeMasks edge
)
Parameters
row(Int32)
col(Int32)
edge(CellEdgeMasks)


GridVisibility Method (gridlineType, type)

GridVisibility Method (gridlineType, type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GridVisibility(GridLineType, RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool GridVisibility(
    GridLineType gridlineType,
    RowType type
)
Public Overridable Function GridVisibility ( _
    gridlineType As GridLineType, _
    type As RowType _
) As Boolean
public:
virtual bool GridVisibility(
    GridLineType gridlineType,
    RowType type
)
Parameters
gridlineType(GridLineType)
type(RowType)


HasFormula Method (row, column, contentIndex)

HasFormula Method (row, column, contentIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »HasFormula(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool HasFormula(
    int row,
    int column,
    int contentIndex
)
Public Overridable Function HasFormula ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer _
) As Boolean
public:
virtual bool HasFormula(
    int row,
    int column,
    int contentIndex
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)


HasSubSelection Property

HasSubSelection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »HasSubSelection
Declaration Syntax
C# Visual Basic Visual C++
public bool HasSubSelection { get; }
Public ReadOnly Property HasSubSelection As Boolean
    Get
public:
property bool HasSubSelection {
    bool get ();
}


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Height
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Height { get; set; }
Public Overridable Property Height As Double
    Get
    Set
public:
virtual property double Height {
    double get ();
    void set (double value);
}


HitTest Method (point, viewVector)

HitTest Method (point, viewVector)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »HitTest(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual TableHitTestInfo HitTest(
    Point3d point,
    Vector3d viewVector
)
Public Overridable Function HitTest ( _
    point As Point3d, _
    viewVector As Vector3d _
) As TableHitTestInfo
public:
virtual TableHitTestInfo HitTest(
    Point3d point,
    Vector3d viewVector
)
Parameters
point(Point3d)
viewVector(Vector3d)


HorizontalCellMargin Property

HorizontalCellMargin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »HorizontalCellMargin
Declaration Syntax
C# Visual Basic Visual C++
public virtual double HorizontalCellMargin { get; set; }
Public Overridable Property HorizontalCellMargin As Double
    Get
    Set
public:
virtual property double HorizontalCellMargin {
    double get ();
    void set (double value);
}


InsertColumns Method (col, width, columns)

InsertColumns Method (col, width, columns)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »InsertColumns(Int32, Double, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void InsertColumns(
    int col,
    double width,
    int columns
)
Public Overridable Sub InsertColumns ( _
    col As Integer, _
    width As Double, _
    columns As Integer _
)
public:
virtual void InsertColumns(
    int col,
    double width,
    int columns
)
Parameters
col(Int32)
width(Double)
columns(Int32)


InsertColumnsAndInherit Method (col, inheritFrom, numCols)

InsertColumnsAndInherit Method (col, inheritFrom, numCols)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »InsertColumnsAndInherit(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void InsertColumnsAndInherit(
    int col,
    int inheritFrom,
    int numCols
)
Public Overridable Sub InsertColumnsAndInherit ( _
    col As Integer, _
    inheritFrom As Integer, _
    numCols As Integer _
)
public:
virtual void InsertColumnsAndInherit(
    int col,
    int inheritFrom,
    int numCols
)
Parameters
col(Int32)
inheritFrom(Int32)
numCols(Int32)


InsertRows Method (row, height, rows)

InsertRows Method (row, height, rows)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »InsertRows(Int32, Double, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void InsertRows(
    int row,
    double height,
    int rows
)
Public Overridable Sub InsertRows ( _
    row As Integer, _
    height As Double, _
    rows As Integer _
)
public:
virtual void InsertRows(
    int row,
    double height,
    int rows
)
Parameters
row(Int32)
height(Double)
rows(Int32)


InsertRowsAndInherit Method (index, inheritFrom, numRows)

InsertRowsAndInherit Method (index, inheritFrom, numRows)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »InsertRowsAndInherit(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void InsertRowsAndInherit(
    int index,
    int inheritFrom,
    int numRows
)
Public Overridable Sub InsertRowsAndInherit ( _
    index As Integer, _
    inheritFrom As Integer, _
    numRows As Integer _
)
public:
virtual void InsertRowsAndInherit(
    int index,
    int inheritFrom,
    int numRows
)
Parameters
index(Int32)
inheritFrom(Int32)
numRows(Int32)


IsAutoScale Method (row, col)

IsAutoScale Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsAutoScale(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsAutoScale(
    int row,
    int col
)
Public Overridable Function IsAutoScale ( _
    row As Integer, _
    col As Integer _
) As Boolean
public:
virtual bool IsAutoScale(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


IsBackgroundColorNone Method

IsBackgroundColorNone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsBackgroundColorNone()()()()
Members
Icon | Member | Description
 | IsBackgroundColorNone(Int32, Int32) |
 | IsBackgroundColorNone(RowType) |


IsBackgroundColorNone Method (row, col)

IsBackgroundColorNone Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsBackgroundColorNone(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsBackgroundColorNone(
    int row,
    int col
)
Public Overridable Function IsBackgroundColorNone ( _
    row As Integer, _
    col As Integer _
) As Boolean
public:
virtual bool IsBackgroundColorNone(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


IsBackgroundColorNone Method (type)

IsBackgroundColorNone Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsBackgroundColorNone(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsBackgroundColorNone(
    RowType type
)
Public Overridable Function IsBackgroundColorNone ( _
    type As RowType _
) As Boolean
public:
virtual bool IsBackgroundColorNone(
    RowType type
)
Parameters
type(RowType)


IsContentEditable Method (row, column)

IsContentEditable Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsContentEditable(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsContentEditable(
    int row,
    int column
)
Public Overridable Function IsContentEditable ( _
    row As Integer, _
    column As Integer _
) As Boolean
public:
virtual bool IsContentEditable(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


IsEmpty Method (row, column)

IsEmpty Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsEmpty(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsEmpty(
    int row,
    int column
)
Public Overridable Function IsEmpty ( _
    row As Integer, _
    column As Integer _
) As Boolean
public:
virtual bool IsEmpty(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


IsFormatEditable Method (row, column)

IsFormatEditable Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsFormatEditable(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFormatEditable(
    int row,
    int column
)
Public Overridable Function IsFormatEditable ( _
    row As Integer, _
    column As Integer _
) As Boolean
public:
virtual bool IsFormatEditable(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


IsHeaderSuppressed Property

IsHeaderSuppressed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsHeaderSuppressed
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Cell functionality instead.")]
public virtual bool IsHeaderSuppressed { get; set; }
<ObsoleteAttribute("Use Cell functionality instead.")> _
Public Overridable Property IsHeaderSuppressed As Boolean
    Get
    Set
[ObsoleteAttribute(L"Use Cell functionality instead.")]
public:
virtual property bool IsHeaderSuppressed {
    bool get ();
    void set (bool value);
}


IsLinked Method (row, column)

IsLinked Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsLinked(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsLinked(
    int row,
    int column
)
Public Overridable Function IsLinked ( _
    row As Integer, _
    column As Integer _
) As Boolean
public:
virtual bool IsLinked(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


IsMergedCell Method (row, col, range)

IsMergedCell Method (row, col, range)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsMergedCell(Int32, Int32, CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMergedCell(
    int row,
    int col,
    CellRange range
)
Public Function IsMergedCell ( _
    row As Integer, _
    col As Integer, _
    <OutAttribute> range As CellRange _
) As Boolean
public:
bool IsMergedCell(
    int row,
    int col,
    [OutAttribute] CellRange^ range
)
Parameters
row(Int32)
col(Int32)
range(CellRange)


IsTitleSuppressed Property

IsTitleSuppressed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IsTitleSuppressed
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Cell functionality instead.")]
public virtual bool IsTitleSuppressed { get; set; }
<ObsoleteAttribute("Use Cell functionality instead.")> _
Public Overridable Property IsTitleSuppressed As Boolean
    Get
    Set
[ObsoleteAttribute(L"Use Cell functionality instead.")]
public:
virtual property bool IsTitleSuppressed {
    bool get ();
    void set (bool value);
}


MergeCells Method (range)

MergeCells Method (range)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »MergeCells(CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void MergeCells(
    CellRange range
)
Public Overridable Sub MergeCells ( _
    range As CellRange _
)
public:
virtual void MergeCells(
    CellRange^ range
)
Parameters
range(CellRange)


MinimumColumnWidth Method (col)

MinimumColumnWidth Method (col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »MinimumColumnWidth(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double MinimumColumnWidth(
    int col
)
Public Overridable Function MinimumColumnWidth ( _
    col As Integer _
) As Double
public:
virtual double MinimumColumnWidth(
    int col
)
Parameters
col(Int32)


MinimumRowHeight Method (row)

MinimumRowHeight Method (row)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »MinimumRowHeight(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double MinimumRowHeight(
    int row
)
Public Overridable Function MinimumRowHeight ( _
    row As Integer _
) As Double
public:
virtual double MinimumRowHeight(
    int row
)
Parameters
row(Int32)


MinimumTableHeight Property

MinimumTableHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »MinimumTableHeight
Declaration Syntax
C# Visual Basic Visual C++
public virtual double MinimumTableHeight { get; }
Public Overridable ReadOnly Property MinimumTableHeight As Double
    Get
public:
virtual property double MinimumTableHeight {
    double get ();
}


MinimumTableWidth Property

MinimumTableWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »MinimumTableWidth
Declaration Syntax
C# Visual Basic Visual C++
public virtual double MinimumTableWidth { get; }
Public Overridable ReadOnly Property MinimumTableWidth As Double
    Get
public:
virtual property double MinimumTableWidth {
    double get ();
}


MoveContent Method (row, column, fromIndex, toIndex)

MoveContent Method (row, column, fromIndex, toIndex)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »MoveContent(Int32, Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void MoveContent(
    int row,
    int column,
    int fromIndex,
    int toIndex
)
Public Overridable Sub MoveContent ( _
    row As Integer, _
    column As Integer, _
    fromIndex As Integer, _
    toIndex As Integer _
)
public:
virtual void MoveContent(
    int row,
    int column,
    int fromIndex,
    int toIndex
)
Parameters
row(Int32)
column(Int32)
fromIndex(Int32)
toIndex(Int32)


NumColumns Property

NumColumns Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »NumColumns
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Table.Columns.Count instead.")]
public virtual int NumColumns { get; set; }
<ObsoleteAttribute("Use Table.Columns.Count instead.")> _
Public Overridable Property NumColumns As Integer
    Get
    Set
[ObsoleteAttribute(L"Use Table.Columns.Count instead.")]
public:
virtual property int NumColumns {
    int get ();
    void set (int value);
}


NumRows Property

NumRows Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »NumRows
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use Table.Rows.Count instead.")]
public virtual int NumRows { get; set; }
<ObsoleteAttribute("Use Table.Rows.Count instead.")> _
Public Overridable Property NumRows As Integer
    Get
    Set
[ObsoleteAttribute(L"Use Table.Rows.Count instead.")]
public:
virtual property int NumRows {
    int get ();
    void set (int value);
}


RecomputeTableBlock Method (forceUpdate)

RecomputeTableBlock Method (forceUpdate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »RecomputeTableBlock(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RecomputeTableBlock(
    bool forceUpdate
)
Public Overridable Sub RecomputeTableBlock ( _
    forceUpdate As Boolean _
)
public:
virtual void RecomputeTableBlock(
    bool forceUpdate
)
Parameters
forceUpdate(Boolean)


RemoveAllOverrides Method (row, column)

RemoveAllOverrides Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »RemoveAllOverrides(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveAllOverrides(
    int row,
    int column
)
Public Overridable Sub RemoveAllOverrides ( _
    row As Integer, _
    column As Integer _
)
public:
virtual void RemoveAllOverrides(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


RemoveDataLink Method

RemoveDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »RemoveDataLink()()()()
Members
Icon | Member | Description
 | RemoveDataLink(Int32, Int32) |
 | RemoveDataLink()()()() |


RemoveDataLink Method

RemoveDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »RemoveDataLink()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveDataLink()
Public Overridable Sub RemoveDataLink
public:
virtual void RemoveDataLink()


RemoveDataLink Method (row, column)

RemoveDataLink Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »RemoveDataLink(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveDataLink(
    int row,
    int column
)
Public Overridable Sub RemoveDataLink ( _
    row As Integer, _
    column As Integer _
)
public:
virtual void RemoveDataLink(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


ReselectSubRegion Method (paths)

ReselectSubRegion Method (paths)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »ReselectSubRegion(array<FullSubentityPath>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ReselectSubRegion(
    FullSubentityPath[] paths
)
Public Overridable Sub ReselectSubRegion ( _
    paths As FullSubentityPath() _
)
public:
virtual void ReselectSubRegion(
    array<FullSubentityPath>^ paths
)
Parameters
paths(array< FullSubentityPath >[]()[][])


ResetValue Method (row, col)

ResetValue Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »ResetValue(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ResetValue(
    int row,
    int col
)
Public Overridable Sub ResetValue ( _
    row As Integer, _
    col As Integer _
)
public:
virtual void ResetValue(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


RowHeight Method (row)

RowHeight Method (row)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »RowHeight(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double RowHeight(
    int row
)
Public Overridable Function RowHeight ( _
    row As Integer _
) As Double
public:
virtual double RowHeight(
    int row
)
Parameters
row(Int32)


Rows Property

Rows Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Rows
Declaration Syntax
C# Visual Basic Visual C++
public RowsCollection Rows { get; }
Public ReadOnly Property Rows As RowsCollection
    Get
public:
property RowsCollection^ Rows {
    RowsCollection^ get ();
}


RowType Method (row)

RowType Method (row)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »RowType(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual RowType RowType(
    int row
)
Public Overridable Function RowType ( _
    row As Integer _
) As RowType
public:
virtual RowType RowType(
    int row
)
Parameters
row(Int32)


Select Method (pickingPoint, hitTestViewDirection, hitTestViewOrientation, allowOutside, inPickFirst, paths)

Select Method (pickingPoint, hitTestViewDirection, hitTestViewOrientation, allowOutside, inPickFirst, paths)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Select(Point3d, Vector3d, Vector3d, Boolean, Boolean, array<FullSubentityPath>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual TableHitTestInfo Select(
    Point3d pickingPoint,
    Vector3d hitTestViewDirection,
    Vector3d hitTestViewOrientation,
    bool allowOutside,
    bool inPickFirst,
    FullSubentityPath[] paths
)
Public Overridable Function Select ( _
    pickingPoint As Point3d, _
    hitTestViewDirection As Vector3d, _
    hitTestViewOrientation As Vector3d, _
    allowOutside As Boolean, _
    inPickFirst As Boolean, _
    paths As FullSubentityPath() _
) As TableHitTestInfo
public:
virtual TableHitTestInfo Select(
    Point3d pickingPoint,
    Vector3d hitTestViewDirection,
    Vector3d hitTestViewOrientation,
    bool allowOutside,
    bool inPickFirst,
    array<FullSubentityPath>^ paths
)
Parameters
pickingPoint(Point3d)
hitTestViewDirection(Vector3d)
hitTestViewOrientation(Vector3d)
allowOutside(Boolean)
inPickFirst(Boolean)
paths(array< FullSubentityPath >[]()[][])


SelectSubRegion Method (cornerPoint1, cornerPoint2, selectionViewDirection, hitTestViewDirection, selectionType, includeCurrentSelection, inPickFirst, paths)

SelectSubRegion Method (cornerPoint1, cornerPoint2, selectionViewDirection, hitTestViewDirection, selectionType, includeCurrentSelection, inPickFirst, paths)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SelectSubRegion(Point3d, Point3d, Vector3d, Vector3d, SelectType, Boolean, Boolean, array<FullSubentityPath>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellRange SelectSubRegion(
    Point3d cornerPoint1,
    Point3d cornerPoint2,
    Vector3d selectionViewDirection,
    Vector3d hitTestViewDirection,
    SelectType selectionType,
    bool includeCurrentSelection,
    bool inPickFirst,
    FullSubentityPath[] paths
)
Public Overridable Function SelectSubRegion ( _
    cornerPoint1 As Point3d, _
    cornerPoint2 As Point3d, _
    selectionViewDirection As Vector3d, _
    hitTestViewDirection As Vector3d, _
    selectionType As SelectType, _
    includeCurrentSelection As Boolean, _
    inPickFirst As Boolean, _
    paths As FullSubentityPath() _
) As CellRange
public:
virtual CellRange^ SelectSubRegion(
    Point3d cornerPoint1,
    Point3d cornerPoint2,
    Vector3d selectionViewDirection,
    Vector3d hitTestViewDirection,
    SelectType selectionType,
    bool includeCurrentSelection,
    bool inPickFirst,
    array<FullSubentityPath>^ paths
)
Parameters
cornerPoint1(Point3d)
cornerPoint2(Point3d)
selectionViewDirection(Vector3d)
hitTestViewDirection(Vector3d)
selectionType(SelectType)
includeCurrentSelection(Boolean)
inPickFirst(Boolean)
paths(array< FullSubentityPath >[]()[][])


SetAlignment Method

SetAlignment Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetAlignment()()()()
Members
Icon | Member | Description
 | SetAlignment(Int32, Int32, CellAlignment) |
 | SetAlignment(CellAlignment, Int32) |


SetAlignment Method (row, col, align)

SetAlignment Method (row, col, align)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetAlignment(Int32, Int32, CellAlignment)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetAlignment(
    int row,
    int col,
    CellAlignment align
)
Public Overridable Sub SetAlignment ( _
    row As Integer, _
    col As Integer, _
    align As CellAlignment _
)
public:
virtual void SetAlignment(
    int row,
    int col,
    CellAlignment align
)
Parameters
row(Int32)
col(Int32)
align(CellAlignment)


SetAlignment Method (align, rowTypes)

SetAlignment Method (align, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetAlignment(CellAlignment, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetAlignment(
    CellAlignment align,
    int rowTypes
)
Public Overridable Sub SetAlignment ( _
    align As CellAlignment, _
    rowTypes As Integer _
)
public:
virtual void SetAlignment(
    CellAlignment align,
    int rowTypes
)
Parameters
align(CellAlignment)
rowTypes(Int32)


SetAutoScale Method (row, col, autoFit)

SetAutoScale Method (row, col, autoFit)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetAutoScale(Int32, Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetAutoScale(
    int row,
    int col,
    bool autoFit
)
Public Overridable Sub SetAutoScale ( _
    row As Integer, _
    col As Integer, _
    autoFit As Boolean _
)
public:
virtual void SetAutoScale(
    int row,
    int col,
    bool autoFit
)
Parameters
row(Int32)
col(Int32)
autoFit(Boolean)


SetBackgroundColor Method

SetBackgroundColor Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBackgroundColor()()()()
Members
Icon | Member | Description
 | SetBackgroundColor(Int32, Int32, Color) |
 | SetBackgroundColor(Color, Int32) |


SetBackgroundColor Method (row, col, color)

SetBackgroundColor Method (row, col, color)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBackgroundColor(Int32, Int32, Color)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBackgroundColor(
    int row,
    int col,
    Color color
)
Public Overridable Sub SetBackgroundColor ( _
    row As Integer, _
    col As Integer, _
    color As Color _
)
public:
virtual void SetBackgroundColor(
    int row,
    int col,
    Color^ color
)
Parameters
row(Int32)
col(Int32)
color(Color)


SetBackgroundColor Method (color, rowTypes)

SetBackgroundColor Method (color, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBackgroundColor(Color, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBackgroundColor(
    Color color,
    int rowTypes
)
Public Overridable Sub SetBackgroundColor ( _
    color As Color, _
    rowTypes As Integer _
)
public:
virtual void SetBackgroundColor(
    Color^ color,
    int rowTypes
)
Parameters
color(Color)
rowTypes(Int32)


SetBackgroundColorNone Method

SetBackgroundColorNone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBackgroundColorNone()()()()
Members
Icon | Member | Description
 | SetBackgroundColorNone(Int32, Int32, Boolean) |
 | SetBackgroundColorNone(Boolean, Int32) |


SetBackgroundColorNone Method (value, rowTypes)

SetBackgroundColorNone Method (value, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBackgroundColorNone(Boolean, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBackgroundColorNone(
    bool value,
    int rowTypes
)
Public Overridable Sub SetBackgroundColorNone ( _
    value As Boolean, _
    rowTypes As Integer _
)
public:
virtual void SetBackgroundColorNone(
    bool value,
    int rowTypes
)
Parameters
value(Boolean)
rowTypes(Int32)


SetBackgroundColorNone Method (row, col, value)

SetBackgroundColorNone Method (row, col, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBackgroundColorNone(Int32, Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBackgroundColorNone(
    int row,
    int col,
    bool value
)
Public Overridable Sub SetBackgroundColorNone ( _
    row As Integer, _
    col As Integer, _
    value As Boolean _
)
public:
virtual void SetBackgroundColorNone(
    int row,
    int col,
    bool value
)
Parameters
row(Int32)
col(Int32)
value(Boolean)


SetBlockAttributeValue Method

SetBlockAttributeValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBlockAttributeValue()()()()
Members
Icon | Member | Description
 | SetBlockAttributeValue(Int32, Int32, Int32, ObjectId, String) |
 | SetBlockAttributeValue(Int32, Int32, ObjectId, String) |


SetBlockAttributeValue Method (row, column, contentIndex, attDefId, value)

SetBlockAttributeValue Method (row, column, contentIndex, attDefId, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBlockAttributeValue(Int32, Int32, Int32, ObjectId, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBlockAttributeValue(
    int row,
    int column,
    int contentIndex,
    ObjectId attDefId,
    string value
)
Public Overridable Sub SetBlockAttributeValue ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    attDefId As ObjectId, _
    value As String _
)
public:
virtual void SetBlockAttributeValue(
    int row,
    int column,
    int contentIndex,
    ObjectId attDefId,
    String^ value
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
attDefId(ObjectId)
value(String)


SetBlockAttributeValue Method (row, col, attributeDefinitionId, value)

SetBlockAttributeValue Method (row, col, attributeDefinitionId, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBlockAttributeValue(Int32, Int32, ObjectId, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBlockAttributeValue(
    int row,
    int col,
    ObjectId attributeDefinitionId,
    string value
)
Public Overridable Sub SetBlockAttributeValue ( _
    row As Integer, _
    col As Integer, _
    attributeDefinitionId As ObjectId, _
    value As String _
)
public:
virtual void SetBlockAttributeValue(
    int row,
    int col,
    ObjectId attributeDefinitionId,
    String^ value
)
Parameters
row(Int32)
col(Int32)
attributeDefinitionId(ObjectId)
value(String)


SetBlockRotation Method (row, col, rotationalAngle)

SetBlockRotation Method (row, col, rotationalAngle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBlockRotation(Int32, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBlockRotation(
    int row,
    int col,
    double rotationalAngle
)
Public Overridable Sub SetBlockRotation ( _
    row As Integer, _
    col As Integer, _
    rotationalAngle As Double _
)
public:
virtual void SetBlockRotation(
    int row,
    int col,
    double rotationalAngle
)
Parameters
row(Int32)
col(Int32)
rotationalAngle(Double)


SetBlockScale Method (row, col, scale)

SetBlockScale Method (row, col, scale)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBlockScale(Int32, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBlockScale(
    int row,
    int col,
    double scale
)
Public Overridable Sub SetBlockScale ( _
    row As Integer, _
    col As Integer, _
    scale As Double _
)
public:
virtual void SetBlockScale(
    int row,
    int col,
    double scale
)
Parameters
row(Int32)
col(Int32)
scale(Double)


SetBlockTableRecordId Method

SetBlockTableRecordId Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBlockTableRecordId()()()()
Members
Icon | Member | Description
 | SetBlockTableRecordId(Int32, Int32, Int32, ObjectId, Boolean) |
 | SetBlockTableRecordId(Int32, Int32, ObjectId, Boolean) |


SetBlockTableRecordId Method (row, column, contentIndex, blockId, autoFit)

SetBlockTableRecordId Method (row, column, contentIndex, blockId, autoFit)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBlockTableRecordId(Int32, Int32, Int32, ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBlockTableRecordId(
    int row,
    int column,
    int contentIndex,
    ObjectId blockId,
    bool autoFit
)
Public Overridable Sub SetBlockTableRecordId ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    blockId As ObjectId, _
    autoFit As Boolean _
)
public:
virtual void SetBlockTableRecordId(
    int row,
    int column,
    int contentIndex,
    ObjectId blockId,
    bool autoFit
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
blockId(ObjectId)
autoFit(Boolean)


SetBlockTableRecordId Method (row, col, blockId, autoFit)

SetBlockTableRecordId Method (row, col, blockId, autoFit)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBlockTableRecordId(Int32, Int32, ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBlockTableRecordId(
    int row,
    int col,
    ObjectId blockId,
    bool autoFit
)
Public Overridable Sub SetBlockTableRecordId ( _
    row As Integer, _
    col As Integer, _
    blockId As ObjectId, _
    autoFit As Boolean _
)
public:
virtual void SetBlockTableRecordId(
    int row,
    int col,
    ObjectId blockId,
    bool autoFit
)
Parameters
row(Int32)
col(Int32)
blockId(ObjectId)
autoFit(Boolean)


SetBreakHeight Method (index, height)

SetBreakHeight Method (index, height)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBreakHeight(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBreakHeight(
    int index,
    double height
)
Public Overridable Sub SetBreakHeight ( _
    index As Integer, _
    height As Double _
)
public:
virtual void SetBreakHeight(
    int index,
    double height
)
Parameters
index(Int32)
height(Double)


SetBreakOffset Method (index, offset)

SetBreakOffset Method (index, offset)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBreakOffset(Int32, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBreakOffset(
    int index,
    Vector3d offset
)
Public Overridable Sub SetBreakOffset ( _
    index As Integer, _
    offset As Vector3d _
)
public:
virtual void SetBreakOffset(
    int index,
    Vector3d offset
)
Parameters
index(Int32)
offset(Vector3d)


SetBreakSpacing Method (spacing)

SetBreakSpacing Method (spacing)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetBreakSpacing(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBreakSpacing(
    double spacing
)
Public Overridable Sub SetBreakSpacing ( _
    spacing As Double _
)
public:
virtual void SetBreakSpacing(
    double spacing
)
Parameters
spacing(Double)


SetCellState Method (row, column, cellState)

SetCellState Method (row, column, cellState)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetCellState(Int32, Int32, CellStates)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCellState(
    int row,
    int column,
    CellStates cellState
)
Public Overridable Sub SetCellState ( _
    row As Integer, _
    column As Integer, _
    cellState As CellStates _
)
public:
virtual void SetCellState(
    int row,
    int column,
    CellStates cellState
)
Parameters
row(Int32)
column(Int32)
cellState(CellStates)


SetCellStyle Method (row, column, styleName)

SetCellStyle Method (row, column, styleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetCellStyle(Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCellStyle(
    int row,
    int column,
    string styleName
)
Public Overridable Sub SetCellStyle ( _
    row As Integer, _
    column As Integer, _
    styleName As String _
)
public:
virtual void SetCellStyle(
    int row,
    int column,
    String^ styleName
)
Parameters
row(Int32)
column(Int32)
styleName(String)


SetCellType Method (row, col, type)

SetCellType Method (row, col, type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetCellType(Int32, Int32, TableCellType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCellType(
    int row,
    int col,
    TableCellType type
)
Public Overridable Sub SetCellType ( _
    row As Integer, _
    col As Integer, _
    type As TableCellType _
)
public:
virtual void SetCellType(
    int row,
    int col,
    TableCellType type
)
Parameters
row(Int32)
col(Int32)
type(TableCellType)


SetColumnName Method (index, name)

SetColumnName Method (index, name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetColumnName(Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetColumnName(
    int index,
    string name
)
Public Overridable Sub SetColumnName ( _
    index As Integer, _
    name As String _
)
public:
virtual void SetColumnName(
    int index,
    String^ name
)
Parameters
index(Int32)
name(String)


SetColumnWidth Method

SetColumnWidth Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetColumnWidth()()()()
Members
Icon | Member | Description
 | SetColumnWidth(Int32, Double) |
 | SetColumnWidth(Double) |


SetColumnWidth Method (width)

SetColumnWidth Method (width)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetColumnWidth(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetColumnWidth(
    double width
)
Public Overridable Sub SetColumnWidth ( _
    width As Double _
)
public:
virtual void SetColumnWidth(
    double width
)
Parameters
width(Double)


SetColumnWidth Method (col, width)

SetColumnWidth Method (col, width)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetColumnWidth(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetColumnWidth(
    int col,
    double width
)
Public Overridable Sub SetColumnWidth ( _
    col As Integer, _
    width As Double _
)
public:
virtual void SetColumnWidth(
    int col,
    double width
)
Parameters
col(Int32)
width(Double)


SetContentColor Method

SetContentColor Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetContentColor()()()()
Members
Icon | Member | Description
 | SetContentColor(Int32, Int32, Int32, Color) |
 | SetContentColor(Int32, Int32, Color) |
 | SetContentColor(Color, Int32) |


SetContentColor Method (row, column, contentIndex, color)

SetContentColor Method (row, column, contentIndex, color)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetContentColor(Int32, Int32, Int32, Color)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetContentColor(
    int row,
    int column,
    int contentIndex,
    Color color
)
Public Overridable Sub SetContentColor ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    color As Color _
)
public:
virtual void SetContentColor(
    int row,
    int column,
    int contentIndex,
    Color^ color
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
color(Color)


SetContentColor Method (row, col, color)

SetContentColor Method (row, col, color)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetContentColor(Int32, Int32, Color)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetContentColor(
    int row,
    int col,
    Color color
)
Public Overridable Sub SetContentColor ( _
    row As Integer, _
    col As Integer, _
    color As Color _
)
public:
virtual void SetContentColor(
    int row,
    int col,
    Color^ color
)
Parameters
row(Int32)
col(Int32)
color(Color)


SetContentColor Method (color, rowType)

SetContentColor Method (color, rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetContentColor(Color, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetContentColor(
    Color color,
    int rowType
)
Public Overridable Sub SetContentColor ( _
    color As Color, _
    rowType As Integer _
)
public:
virtual void SetContentColor(
    Color^ color,
    int rowType
)
Parameters
color(Color)
rowType(Int32)


SetContentLayout Method (row, column, layout)

SetContentLayout Method (row, column, layout)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetContentLayout(Int32, Int32, CellContentLayout)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetContentLayout(
    int row,
    int column,
    CellContentLayout layout
)
Public Overridable Sub SetContentLayout ( _
    row As Integer, _
    column As Integer, _
    layout As CellContentLayout _
)
public:
virtual void SetContentLayout(
    int row,
    int column,
    CellContentLayout layout
)
Parameters
row(Int32)
column(Int32)
layout(CellContentLayout)


SetCustomData Method

SetCustomData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetCustomData()()()()
Members
Icon | Member | Description
 | SetCustomData(Int32, Int32, String, Object) |
 | SetCustomData(Int32, Int32, Int32) |


SetCustomData Method (row, column, data)

SetCustomData Method (row, column, data)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetCustomData(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCustomData(
    int row,
    int column,
    int data
)
Public Overridable Sub SetCustomData ( _
    row As Integer, _
    column As Integer, _
    data As Integer _
)
public:
virtual void SetCustomData(
    int row,
    int column,
    int data
)
Parameters
row(Int32)
column(Int32)
data(Int32)


SetCustomData Method (row, column, key, value)

SetCustomData Method (row, column, key, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetCustomData(Int32, Int32, String, Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCustomData(
    int row,
    int column,
    string key,
    Object value
)
Public Overridable Sub SetCustomData ( _
    row As Integer, _
    column As Integer, _
    key As String, _
    value As Object _
)
public:
virtual void SetCustomData(
    int row,
    int column,
    String^ key,
    Object^ value
)
Parameters
row(Int32)
column(Int32)
key(String)
value(Object)


SetDataFormat Method

SetDataFormat Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDataFormat()()()()
Members
Icon | Member | Description
 | SetDataFormat(Int32, Int32, Int32, String) |
 | SetDataFormat(Int32, Int32, String) |


SetDataFormat Method (row, column, contentIndex, format)

SetDataFormat Method (row, column, contentIndex, format)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDataFormat(Int32, Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataFormat(
    int row,
    int column,
    int contentIndex,
    string format
)
Public Overridable Sub SetDataFormat ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    format As String _
)
public:
virtual void SetDataFormat(
    int row,
    int column,
    int contentIndex,
    String^ format
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
format(String)


SetDataFormat Method (row, column, format)

SetDataFormat Method (row, column, format)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDataFormat(Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataFormat(
    int row,
    int column,
    string format
)
Public Overridable Sub SetDataFormat ( _
    row As Integer, _
    column As Integer, _
    format As String _
)
public:
virtual void SetDataFormat(
    int row,
    int column,
    String^ format
)
Parameters
row(Int32)
column(Int32)
format(String)


SetDataLink Method

SetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDataLink()()()()
Members
Icon | Member | Description
 | SetDataLink(Int32, Int32, ObjectId, Boolean) |
 | SetDataLink(CellRange, ObjectId, Boolean) |


SetDataLink Method (row, column, dataLinkId, bUpdate)

SetDataLink Method (row, column, dataLinkId, bUpdate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDataLink(Int32, Int32, ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataLink(
    int row,
    int column,
    ObjectId dataLinkId,
    bool bUpdate
)
Public Overridable Sub SetDataLink ( _
    row As Integer, _
    column As Integer, _
    dataLinkId As ObjectId, _
    bUpdate As Boolean _
)
public:
virtual void SetDataLink(
    int row,
    int column,
    ObjectId dataLinkId,
    bool bUpdate
)
Parameters
row(Int32)
column(Int32)
dataLinkId(ObjectId)
bUpdate(Boolean)


SetDataLink Method (range, dataLinkId, bUpdate)

SetDataLink Method (range, dataLinkId, bUpdate)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDataLink(CellRange, ObjectId, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataLink(
    CellRange range,
    ObjectId dataLinkId,
    bool bUpdate
)
Public Overridable Sub SetDataLink ( _
    range As CellRange, _
    dataLinkId As ObjectId, _
    bUpdate As Boolean _
)
public:
virtual void SetDataLink(
    CellRange^ range,
    ObjectId dataLinkId,
    bool bUpdate
)
Parameters
range(CellRange)
dataLinkId(ObjectId)
bUpdate(Boolean)


SetDataType Method

SetDataType Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDataType()()()()
Members
Icon | Member | Description
 | SetDataType(Int32, Int32, Int32, DataTypeParameter) |
 | SetDataType(Int32, Int32, DataType, UnitType) |
 | SetDataType(DataType, UnitType, Int32) |


SetDataType Method (row, column, contentIndex, dataType)

SetDataType Method (row, column, contentIndex, dataType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDataType(Int32, Int32, Int32, DataTypeParameter)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataType(
    int row,
    int column,
    int contentIndex,
    DataTypeParameter dataType
)
Public Overridable Sub SetDataType ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    dataType As DataTypeParameter _
)
public:
virtual void SetDataType(
    int row,
    int column,
    int contentIndex,
    DataTypeParameter dataType
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
dataType(DataTypeParameter)


SetDataType Method (row, col, nDataType, nUnitType)

SetDataType Method (row, col, nDataType, nUnitType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDataType(Int32, Int32, DataType, UnitType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataType(
    int row,
    int col,
    DataType nDataType,
    UnitType nUnitType
)
Public Overridable Sub SetDataType ( _
    row As Integer, _
    col As Integer, _
    nDataType As DataType, _
    nUnitType As UnitType _
)
public:
virtual void SetDataType(
    int row,
    int col,
    DataType nDataType,
    UnitType nUnitType
)
Parameters
row(Int32)
col(Int32)
nDataType(DataType)
nUnitType(UnitType)


SetDataType Method (nDataType, nUnitType, rowTypes)

SetDataType Method (nDataType, nUnitType, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDataType(DataType, UnitType, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataType(
    DataType nDataType,
    UnitType nUnitType,
    int rowTypes
)
Public Overridable Sub SetDataType ( _
    nDataType As DataType, _
    nUnitType As UnitType, _
    rowTypes As Integer _
)
public:
virtual void SetDataType(
    DataType nDataType,
    UnitType nUnitType,
    int rowTypes
)
Parameters
nDataType(DataType)
nUnitType(UnitType)
rowTypes(Int32)


SetFieldId Method

SetFieldId Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetFieldId()()()()
Members
Icon | Member | Description
 | SetFieldId(Int32, Int32, Int32, ObjectId, CellOption) |
 | SetFieldId(Int32, Int32, ObjectId) |


SetFieldId Method (row, column, contentIndex, fieldId, option)

SetFieldId Method (row, column, contentIndex, fieldId, option)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetFieldId(Int32, Int32, Int32, ObjectId, CellOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetFieldId(
    int row,
    int column,
    int contentIndex,
    ObjectId fieldId,
    CellOption option
)
Public Overridable Sub SetFieldId ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    fieldId As ObjectId, _
    option As CellOption _
)
public:
virtual void SetFieldId(
    int row,
    int column,
    int contentIndex,
    ObjectId fieldId,
    CellOption option
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
fieldId(ObjectId)
option(CellOption)


SetFieldId Method (row, col, fieldId)

SetFieldId Method (row, col, fieldId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetFieldId(Int32, Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetFieldId(
    int row,
    int col,
    ObjectId fieldId
)
Public Overridable Sub SetFieldId ( _
    row As Integer, _
    col As Integer, _
    fieldId As ObjectId _
)
public:
virtual void SetFieldId(
    int row,
    int col,
    ObjectId fieldId
)
Parameters
row(Int32)
col(Int32)
fieldId(ObjectId)


SetFormat Method

SetFormat Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetFormat()()()()
Members
Icon | Member | Description
 | SetFormat(Int32, Int32, String) |
 | SetFormat(String, Int32) |


SetFormat Method (row, col, pFormat)

SetFormat Method (row, col, pFormat)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetFormat(Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetFormat(
    int row,
    int col,
    string pFormat
)
Public Overridable Sub SetFormat ( _
    row As Integer, _
    col As Integer, _
    pFormat As String _
)
public:
virtual void SetFormat(
    int row,
    int col,
    String^ pFormat
)
Parameters
row(Int32)
col(Int32)
pFormat(String)


SetFormat Method (pFormat, rowTypes)

SetFormat Method (pFormat, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetFormat(String, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetFormat(
    string pFormat,
    int rowTypes
)
Public Overridable Sub SetFormat ( _
    pFormat As String, _
    rowTypes As Integer _
)
public:
virtual void SetFormat(
    String^ pFormat,
    int rowTypes
)
Parameters
pFormat(String)
rowTypes(Int32)


SetFormula Method (row, column, contentIndex, formula)

SetFormula Method (row, column, contentIndex, formula)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetFormula(Int32, Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetFormula(
    int row,
    int column,
    int contentIndex,
    string formula
)
Public Overridable Sub SetFormula ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    formula As String _
)
public:
virtual void SetFormula(
    int row,
    int column,
    int contentIndex,
    String^ formula
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
formula(String)


SetGridColor Method

SetGridColor Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridColor()()()()
Members
Icon | Member | Description
 | SetGridColor(Int32, Int32, Int16, Color) |
 | SetGridColor(Int32, Int32, GridLineType, Color) |
 | SetGridColor(Color, Int32, Int32) |


SetGridColor Method (row, col, edges, color)

SetGridColor Method (row, col, edges, color)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridColor(Int32, Int32, Int16, Color)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridColor(
    int row,
    int col,
    short edges,
    Color color
)
Public Overridable Sub SetGridColor ( _
    row As Integer, _
    col As Integer, _
    edges As Short, _
    color As Color _
)
public:
virtual void SetGridColor(
    int row,
    int col,
    short edges,
    Color^ color
)
Parameters
row(Int32)
col(Int32)
edges(Int16)
color(Color)


SetGridColor Method (row, column, gridLineType, color)

SetGridColor Method (row, column, gridLineType, color)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridColor(Int32, Int32, GridLineType, Color)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridColor(
    int row,
    int column,
    GridLineType gridLineType,
    Color color
)
Public Overridable Sub SetGridColor ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType, _
    color As Color _
)
public:
virtual void SetGridColor(
    int row,
    int column,
    GridLineType gridLineType,
    Color^ color
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)
color(Color)


SetGridColor Method (color, borders, rows)

SetGridColor Method (color, borders, rows)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridColor(Color, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridColor(
    Color color,
    int borders,
    int rows
)
Public Overridable Sub SetGridColor ( _
    color As Color, _
    borders As Integer, _
    rows As Integer _
)
public:
virtual void SetGridColor(
    Color^ color,
    int borders,
    int rows
)
Parameters
color(Color)
borders(Int32)
rows(Int32)


SetGridDoubleLineSpacing Method (row, column, gridLineType, spacing)

SetGridDoubleLineSpacing Method (row, column, gridLineType, spacing)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridDoubleLineSpacing(Int32, Int32, GridLineType, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridDoubleLineSpacing(
    int row,
    int column,
    GridLineType gridLineType,
    double spacing
)
Public Overridable Sub SetGridDoubleLineSpacing ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType, _
    spacing As Double _
)
public:
virtual void SetGridDoubleLineSpacing(
    int row,
    int column,
    GridLineType gridLineType,
    double spacing
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)
spacing(Double)


SetGridLineStyle Method (row, column, gridLineType, lineStyle)

SetGridLineStyle Method (row, column, gridLineType, lineStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridLineStyle(Int32, Int32, GridLineType, GridLineStyle)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridLineStyle(
    int row,
    int column,
    GridLineType gridLineType,
    GridLineStyle lineStyle
)
Public Overridable Sub SetGridLineStyle ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType, _
    lineStyle As GridLineStyle _
)
public:
virtual void SetGridLineStyle(
    int row,
    int column,
    GridLineType gridLineType,
    GridLineStyle lineStyle
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)
lineStyle(GridLineStyle)


SetGridLinetype Method (row, column, gridLineType, linetype)

SetGridLinetype Method (row, column, gridLineType, linetype)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridLinetype(Int32, Int32, GridLineType, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridLinetype(
    int row,
    int column,
    GridLineType gridLineType,
    ObjectId linetype
)
Public Overridable Sub SetGridLinetype ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType, _
    linetype As ObjectId _
)
public:
virtual void SetGridLinetype(
    int row,
    int column,
    GridLineType gridLineType,
    ObjectId linetype
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)
linetype(ObjectId)


SetGridLineWeight Method

SetGridLineWeight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridLineWeight()()()()
Members
Icon | Member | Description
 | SetGridLineWeight(Int32, Int32, Int16, LineWeight) |
 | SetGridLineWeight(Int32, Int32, GridLineType, LineWeight) |
 | SetGridLineWeight(LineWeight, Int32, Int32) |


SetGridLineWeight Method (row, col, edges, value)

SetGridLineWeight Method (row, col, edges, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridLineWeight(Int32, Int32, Int16, LineWeight)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridLineWeight(
    int row,
    int col,
    short edges,
    LineWeight value
)
Public Overridable Sub SetGridLineWeight ( _
    row As Integer, _
    col As Integer, _
    edges As Short, _
    value As LineWeight _
)
public:
virtual void SetGridLineWeight(
    int row,
    int col,
    short edges,
    LineWeight value
)
Parameters
row(Int32)
col(Int32)
edges(Int16)
value(LineWeight)


SetGridLineWeight Method (row, column, gridLineType, lineWeight)

SetGridLineWeight Method (row, column, gridLineType, lineWeight)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridLineWeight(Int32, Int32, GridLineType, LineWeight)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridLineWeight(
    int row,
    int column,
    GridLineType gridLineType,
    LineWeight lineWeight
)
Public Overridable Sub SetGridLineWeight ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType, _
    lineWeight As LineWeight _
)
public:
virtual void SetGridLineWeight(
    int row,
    int column,
    GridLineType gridLineType,
    LineWeight lineWeight
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)
lineWeight(LineWeight)


SetGridLineWeight Method (lineWeight, borders, rows)

SetGridLineWeight Method (lineWeight, borders, rows)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridLineWeight(LineWeight, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridLineWeight(
    LineWeight lineWeight,
    int borders,
    int rows
)
Public Overridable Sub SetGridLineWeight ( _
    lineWeight As LineWeight, _
    borders As Integer, _
    rows As Integer _
)
public:
virtual void SetGridLineWeight(
    LineWeight lineWeight,
    int borders,
    int rows
)
Parameters
lineWeight(LineWeight)
borders(Int32)
rows(Int32)


SetGridProperty Method

SetGridProperty Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridProperty()()()()
Members
Icon | Member | Description
 | SetGridProperty(Int32, Int32, GridLineType, GridPropertyParameter) |
 | SetGridProperty(CellRange, GridLineType, GridPropertyParameter) |


SetGridProperty Method (row, column, gridLineType, gridProperty)

SetGridProperty Method (row, column, gridLineType, gridProperty)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridProperty(Int32, Int32, GridLineType, GridPropertyParameter)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridProperty(
    int row,
    int column,
    GridLineType gridLineType,
    GridPropertyParameter gridProperty
)
Public Overridable Sub SetGridProperty ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType, _
    gridProperty As GridPropertyParameter _
)
public:
virtual void SetGridProperty(
    int row,
    int column,
    GridLineType gridLineType,
    GridPropertyParameter gridProperty
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)
gridProperty(GridPropertyParameter)


SetGridProperty Method (rangeIn, gridLineTypes, gridProp)

SetGridProperty Method (rangeIn, gridLineTypes, gridProp)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridProperty(CellRange, GridLineType, GridPropertyParameter)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridProperty(
    CellRange rangeIn,
    GridLineType gridLineTypes,
    GridPropertyParameter gridProp
)
Public Overridable Sub SetGridProperty ( _
    rangeIn As CellRange, _
    gridLineTypes As GridLineType, _
    gridProp As GridPropertyParameter _
)
public:
virtual void SetGridProperty(
    CellRange^ rangeIn,
    GridLineType gridLineTypes,
    GridPropertyParameter gridProp
)
Parameters
rangeIn(CellRange)
gridLineTypes(GridLineType)
gridProp(GridPropertyParameter)


SetGridVisibility Method

SetGridVisibility Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridVisibility()()()()
Members
Icon | Member | Description
 | SetGridVisibility(Int32, Int32, Int16, Boolean) |
 | SetGridVisibility(Int32, Int32, GridLineType, Visibility) |
 | SetGridVisibility(Boolean, Int32, Int32) |


SetGridVisibility Method (visible, borders, rows)

SetGridVisibility Method (visible, borders, rows)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridVisibility(Boolean, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridVisibility(
    bool visible,
    int borders,
    int rows
)
Public Overridable Sub SetGridVisibility ( _
    visible As Boolean, _
    borders As Integer, _
    rows As Integer _
)
public:
virtual void SetGridVisibility(
    bool visible,
    int borders,
    int rows
)
Parameters
visible(Boolean)
borders(Int32)
rows(Int32)


SetGridVisibility Method (row, col, edges, value)

SetGridVisibility Method (row, col, edges, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridVisibility(Int32, Int32, Int16, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridVisibility(
    int row,
    int col,
    short edges,
    bool value
)
Public Overridable Sub SetGridVisibility ( _
    row As Integer, _
    col As Integer, _
    edges As Short, _
    value As Boolean _
)
public:
virtual void SetGridVisibility(
    int row,
    int col,
    short edges,
    bool value
)
Parameters
row(Int32)
col(Int32)
edges(Int16)
value(Boolean)


SetGridVisibility Method (row, column, gridLineType, visibility)

SetGridVisibility Method (row, column, gridLineType, visibility)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetGridVisibility(Int32, Int32, GridLineType, Visibility)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridVisibility(
    int row,
    int column,
    GridLineType gridLineType,
    Visibility visibility
)
Public Overridable Sub SetGridVisibility ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType, _
    visibility As Visibility _
)
public:
virtual void SetGridVisibility(
    int row,
    int column,
    GridLineType gridLineType,
    Visibility visibility
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)
visibility(Visibility)


SetIsAutoScale Method (row, column, contentIndex, autoFit)

SetIsAutoScale Method (row, column, contentIndex, autoFit)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetIsAutoScale(Int32, Int32, Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetIsAutoScale(
    int row,
    int column,
    int contentIndex,
    bool autoFit
)
Public Overridable Sub SetIsAutoScale ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    autoFit As Boolean _
)
public:
virtual void SetIsAutoScale(
    int row,
    int column,
    int contentIndex,
    bool autoFit
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
autoFit(Boolean)


SetMargin Method (row, column, margin, value)

SetMargin Method (row, column, margin, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetMargin(Int32, Int32, CellMargins, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetMargin(
    int row,
    int column,
    CellMargins margin,
    double value
)
Public Overridable Sub SetMargin ( _
    row As Integer, _
    column As Integer, _
    margin As CellMargins, _
    value As Double _
)
public:
virtual void SetMargin(
    int row,
    int column,
    CellMargins margin,
    double value
)
Parameters
row(Int32)
column(Int32)
margin(CellMargins)
value(Double)


SetMergeAllEnabled Method (row, column, enable)

SetMergeAllEnabled Method (row, column, enable)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetMergeAllEnabled(Int32, Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetMergeAllEnabled(
    int row,
    int column,
    bool enable
)
Public Overridable Sub SetMergeAllEnabled ( _
    row As Integer, _
    column As Integer, _
    enable As Boolean _
)
public:
virtual void SetMergeAllEnabled(
    int row,
    int column,
    bool enable
)
Parameters
row(Int32)
column(Int32)
enable(Boolean)


SetOverrides Method

SetOverrides Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetOverrides()()()()
Members
Icon | Member | Description
 | SetOverrides(Int32, Int32, Int32, CellProperties) |
 | SetOverrides(Int32, Int32, GridLineType, CellProperties) |


SetOverrides Method (row, column, contentIndex, overrd)

SetOverrides Method (row, column, contentIndex, overrd)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetOverrides(Int32, Int32, Int32, CellProperties)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetOverrides(
    int row,
    int column,
    int contentIndex,
    CellProperties overrd
)
Public Overridable Sub SetOverrides ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    overrd As CellProperties _
)
public:
virtual void SetOverrides(
    int row,
    int column,
    int contentIndex,
    CellProperties overrd
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
overrd(CellProperties)


SetOverrides Method (row, column, gridLineType, overrd)

SetOverrides Method (row, column, gridLineType, overrd)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetOverrides(Int32, Int32, GridLineType, CellProperties)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetOverrides(
    int row,
    int column,
    GridLineType gridLineType,
    CellProperties overrd
)
Public Overridable Sub SetOverrides ( _
    row As Integer, _
    column As Integer, _
    gridLineType As GridLineType, _
    overrd As CellProperties _
)
public:
virtual void SetOverrides(
    int row,
    int column,
    GridLineType gridLineType,
    CellProperties overrd
)
Parameters
row(Int32)
column(Int32)
gridLineType(GridLineType)
overrd(CellProperties)


SetRotation Method (row, column, contentIndex, angle)

SetRotation Method (row, column, contentIndex, angle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetRotation(Int32, Int32, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetRotation(
    int row,
    int column,
    int contentIndex,
    double angle
)
Public Overridable Sub SetRotation ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    angle As Double _
)
public:
virtual void SetRotation(
    int row,
    int column,
    int contentIndex,
    double angle
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
angle(Double)


SetRowHeight Method

SetRowHeight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetRowHeight()()()()
Members
Icon | Member | Description
 | SetRowHeight(Int32, Double) |
 | SetRowHeight(Double) |


SetRowHeight Method (height)

SetRowHeight Method (height)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetRowHeight(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetRowHeight(
    double height
)
Public Overridable Sub SetRowHeight ( _
    height As Double _
)
public:
virtual void SetRowHeight(
    double height
)
Parameters
height(Double)


SetRowHeight Method (row, height)

SetRowHeight Method (row, height)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetRowHeight(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetRowHeight(
    int row,
    double height
)
Public Overridable Sub SetRowHeight ( _
    row As Integer, _
    height As Double _
)
public:
virtual void SetRowHeight(
    int row,
    double height
)
Parameters
row(Int32)
height(Double)


SetScale Method (row, column, contentIndex, scale)

SetScale Method (row, column, contentIndex, scale)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetScale(Int32, Int32, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetScale(
    int row,
    int column,
    int contentIndex,
    double scale
)
Public Overridable Sub SetScale ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    scale As Double _
)
public:
virtual void SetScale(
    int row,
    int column,
    int contentIndex,
    double scale
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
scale(Double)


SetSize Method (numRows, numCols)

SetSize Method (numRows, numCols)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetSize(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSize(
    int numRows,
    int numCols
)
Public Overridable Sub SetSize ( _
    numRows As Integer, _
    numCols As Integer _
)
public:
virtual void SetSize(
    int numRows,
    int numCols
)
Parameters
numRows(Int32)
numCols(Int32)


SetTextHeight Method

SetTextHeight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextHeight()()()()
Members
Icon | Member | Description
 | SetTextHeight(Int32, Int32, Int32, Double) |
 | SetTextHeight(Int32, Int32, Double) |
 | SetTextHeight(Double, Int32) |


SetTextHeight Method (height, rowTypes)

SetTextHeight Method (height, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextHeight(Double, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextHeight(
    double height,
    int rowTypes
)
Public Overridable Sub SetTextHeight ( _
    height As Double, _
    rowTypes As Integer _
)
public:
virtual void SetTextHeight(
    double height,
    int rowTypes
)
Parameters
height(Double)
rowTypes(Int32)


SetTextHeight Method (row, col, height)

SetTextHeight Method (row, col, height)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextHeight(Int32, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextHeight(
    int row,
    int col,
    double height
)
Public Overridable Sub SetTextHeight ( _
    row As Integer, _
    col As Integer, _
    height As Double _
)
public:
virtual void SetTextHeight(
    int row,
    int col,
    double height
)
Parameters
row(Int32)
col(Int32)
height(Double)


SetTextHeight Method (row, column, contentIndex, height)

SetTextHeight Method (row, column, contentIndex, height)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextHeight(Int32, Int32, Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextHeight(
    int row,
    int column,
    int contentIndex,
    double height
)
Public Overridable Sub SetTextHeight ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    height As Double _
)
public:
virtual void SetTextHeight(
    int row,
    int column,
    int contentIndex,
    double height
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
height(Double)


SetTextRotation Method (row, col, rot)

SetTextRotation Method (row, col, rot)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextRotation(Int32, Int32, RotationAngle)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextRotation(
    int row,
    int col,
    RotationAngle rot
)
Public Overridable Sub SetTextRotation ( _
    row As Integer, _
    col As Integer, _
    rot As RotationAngle _
)
public:
virtual void SetTextRotation(
    int row,
    int col,
    RotationAngle rot
)
Parameters
row(Int32)
col(Int32)
rot(RotationAngle)


SetTextString Method

SetTextString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextString()()()()
Members
Icon | Member | Description
 | SetTextString(Int32, Int32, Int32, String) |
 | SetTextString(Int32, Int32, String) |


SetTextString Method (row, column, contentIndex, text)

SetTextString Method (row, column, contentIndex, text)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextString(Int32, Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextString(
    int row,
    int column,
    int contentIndex,
    string text
)
Public Overridable Sub SetTextString ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    text As String _
)
public:
virtual void SetTextString(
    int row,
    int column,
    int contentIndex,
    String^ text
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
text(String)


SetTextString Method (row, col, value)

SetTextString Method (row, col, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextString(Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextString(
    int row,
    int col,
    string value
)
Public Overridable Sub SetTextString ( _
    row As Integer, _
    col As Integer, _
    value As String _
)
public:
virtual void SetTextString(
    int row,
    int col,
    String^ value
)
Parameters
row(Int32)
col(Int32)
value(String)


SetTextStyle Method

SetTextStyle Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextStyle()()()()
Members
Icon | Member | Description
 | SetTextStyle(Int32, Int32, ObjectId) |
 | SetTextStyle(ObjectId, Int32) |


SetTextStyle Method (row, col, id)

SetTextStyle Method (row, col, id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextStyle(Int32, Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextStyle(
    int row,
    int col,
    ObjectId id
)
Public Overridable Sub SetTextStyle ( _
    row As Integer, _
    col As Integer, _
    id As ObjectId _
)
public:
virtual void SetTextStyle(
    int row,
    int col,
    ObjectId id
)
Parameters
row(Int32)
col(Int32)
id(ObjectId)


SetTextStyle Method (id, rowTypes)

SetTextStyle Method (id, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextStyle(ObjectId, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextStyle(
    ObjectId id,
    int rowTypes
)
Public Overridable Sub SetTextStyle ( _
    id As ObjectId, _
    rowTypes As Integer _
)
public:
virtual void SetTextStyle(
    ObjectId id,
    int rowTypes
)
Parameters
id(ObjectId)
rowTypes(Int32)


SetTextStyleId Method (row, column, contentIndex, id)

SetTextStyleId Method (row, column, contentIndex, id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetTextStyleId(Int32, Int32, Int32, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextStyleId(
    int row,
    int column,
    int contentIndex,
    ObjectId id
)
Public Overridable Sub SetTextStyleId ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    id As ObjectId _
)
public:
virtual void SetTextStyleId(
    int row,
    int column,
    int contentIndex,
    ObjectId id
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
id(ObjectId)


SetToolTip Method (row, column, toolTip)

SetToolTip Method (row, column, toolTip)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetToolTip(Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetToolTip(
    int row,
    int column,
    string toolTip
)
Public Overridable Sub SetToolTip ( _
    row As Integer, _
    column As Integer, _
    toolTip As String _
)
public:
virtual void SetToolTip(
    int row,
    int column,
    String^ toolTip
)
Parameters
row(Int32)
column(Int32)
toolTip(String)


SetValue Method

SetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetValue()()()()
Members
Icon | Member | Description
 | SetValue(Int32, Int32, Int32, String, ParseOption) |
 | SetValue(Int32, Int32, Int32, Object, ParseOption) |
 | SetValue(Int32, Int32, String, ParseOption) |
 | SetValue(Int32, Int32, Int32, Object) |
 | SetValue(Int32, Int32, Object) |


SetValue Method (row, column, contentIndex, value)

SetValue Method (row, column, contentIndex, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetValue(Int32, Int32, Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetValue(
    int row,
    int column,
    int contentIndex,
    Object value
)
Public Overridable Sub SetValue ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    value As Object _
)
public:
virtual void SetValue(
    int row,
    int column,
    int contentIndex,
    Object^ value
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
value(Object)


SetValue Method (row, column, contentIndex, value, parseOption)

SetValue Method (row, column, contentIndex, value, parseOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetValue(Int32, Int32, Int32, Object, ParseOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetValue(
    int row,
    int column,
    int contentIndex,
    Object value,
    ParseOption parseOption
)
Public Overridable Sub SetValue ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    value As Object, _
    parseOption As ParseOption _
)
public:
virtual void SetValue(
    int row,
    int column,
    int contentIndex,
    Object^ value,
    ParseOption parseOption
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
value(Object)
parseOption(ParseOption)


SetValue Method (row, column, contentIndex, value, parseOption)

SetValue Method (row, column, contentIndex, value, parseOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetValue(Int32, Int32, Int32, String, ParseOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetValue(
    int row,
    int column,
    int contentIndex,
    string value,
    ParseOption parseOption
)
Public Overridable Sub SetValue ( _
    row As Integer, _
    column As Integer, _
    contentIndex As Integer, _
    value As String, _
    parseOption As ParseOption _
)
public:
virtual void SetValue(
    int row,
    int column,
    int contentIndex,
    String^ value,
    ParseOption parseOption
)
Parameters
row(Int32)
column(Int32)
contentIndex(Int32)
value(String)
parseOption(ParseOption)


SetValue Method (row, col, pValue)

SetValue Method (row, col, pValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetValue(Int32, Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetValue(
    int row,
    int col,
    Object pValue
)
Public Overridable Sub SetValue ( _
    row As Integer, _
    col As Integer, _
    pValue As Object _
)
public:
virtual void SetValue(
    int row,
    int col,
    Object^ pValue
)
Parameters
row(Int32)
col(Int32)
pValue(Object)


SetValue Method (row, col, pText, nOption)

SetValue Method (row, col, pText, nOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetValue(Int32, Int32, String, ParseOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetValue(
    int row,
    int col,
    string pText,
    ParseOption nOption
)
Public Overridable Sub SetValue ( _
    row As Integer, _
    col As Integer, _
    pText As String, _
    nOption As ParseOption _
)
public:
virtual void SetValue(
    int row,
    int col,
    String^ pText,
    ParseOption nOption
)
Parameters
row(Int32)
col(Int32)
pText(String)
nOption(ParseOption)


SubSelection Property

SubSelection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SubSelection
Declaration Syntax
C# Visual Basic Visual C++
public CellRange SubSelection { get; set; }
Public Property SubSelection As CellRange
    Get
    Set
public:
property CellRange^ SubSelection {
    CellRange^ get ();
    void set (CellRange^ value);
}


SuppressRegenerateTable Method (suppress)

SuppressRegenerateTable Method (suppress)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SuppressRegenerateTable(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SuppressRegenerateTable(
    bool suppress
)
Public Overridable Sub SuppressRegenerateTable ( _
    suppress As Boolean _
)
public:
virtual void SuppressRegenerateTable(
    bool suppress
)
Parameters
suppress(Boolean)


TableStyle Property

TableStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TableStyle
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId TableStyle { get; set; }
Public Overridable Property TableStyle As ObjectId
    Get
    Set
public:
virtual property ObjectId TableStyle {
    ObjectId get ();
    void set (ObjectId value);
}


TableStyleOverrides Method

TableStyleOverrides Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TableStyleOverrides()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual TableStyleOverride[] TableStyleOverrides()
Public Overridable Function TableStyleOverrides As TableStyleOverride()
public:
virtual array<TableStyleOverride>^ TableStyleOverrides()


TextHeight Method

TextHeight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextHeight()()()()
Members
Icon | Member | Description
 | TextHeight(Int32, Int32) |
 | TextHeight(RowType) |


TextHeight Method (row, col)

TextHeight Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextHeight(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double TextHeight(
    int row,
    int col
)
Public Overridable Function TextHeight ( _
    row As Integer, _
    col As Integer _
) As Double
public:
virtual double TextHeight(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


TextHeight Method (type)

TextHeight Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextHeight(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double TextHeight(
    RowType type
)
Public Overridable Function TextHeight ( _
    type As RowType _
) As Double
public:
virtual double TextHeight(
    RowType type
)
Parameters
type(RowType)


TextRotation Method (row, col)

TextRotation Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextRotation(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual RotationAngle TextRotation(
    int row,
    int col
)
Public Overridable Function TextRotation ( _
    row As Integer, _
    col As Integer _
) As RotationAngle
public:
virtual RotationAngle TextRotation(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


TextString Method

TextString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextString()()()()
Members
Icon | Member | Description
 | TextString(Int32, Int32, FormatOption) |
 | TextString(Int32, Int32) |


TextString Method (row, col)

TextString Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextString(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string TextString(
    int row,
    int col
)
Public Overridable Function TextString ( _
    row As Integer, _
    col As Integer _
) As String
public:
virtual String^ TextString(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


TextString Method (row, col, nOption)

TextString Method (row, col, nOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextString(Int32, Int32, FormatOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string TextString(
    int row,
    int col,
    FormatOption nOption
)
Public Overridable Function TextString ( _
    row As Integer, _
    col As Integer, _
    nOption As FormatOption _
) As String
public:
virtual String^ TextString(
    int row,
    int col,
    FormatOption nOption
)
Parameters
row(Int32)
col(Int32)
nOption(FormatOption)


TextStringConst Method (row, col)

TextStringConst Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextStringConst(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string TextStringConst(
    int row,
    int col
)
Public Overridable Function TextStringConst ( _
    row As Integer, _
    col As Integer _
) As String
public:
virtual String^ TextStringConst(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


TextStyle Method

TextStyle Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextStyle()()()()
Members
Icon | Member | Description
 | TextStyle(Int32, Int32) |
 | TextStyle(RowType) |


TextStyle Method (row, col)

TextStyle Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextStyle(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId TextStyle(
    int row,
    int col
)
Public Overridable Function TextStyle ( _
    row As Integer, _
    col As Integer _
) As ObjectId
public:
virtual ObjectId TextStyle(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


TextStyle Method (type)

TextStyle Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »TextStyle(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId TextStyle(
    RowType type
)
Public Overridable Function TextStyle ( _
    type As RowType _
) As ObjectId
public:
virtual ObjectId TextStyle(
    RowType type
)
Parameters
type(RowType)


UnitType Method

UnitType Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »UnitType()()()()
Members
Icon | Member | Description
 | UnitType(Int32, Int32) |
 | UnitType(RowType) |


UnitType Method (row, col)

UnitType Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »UnitType(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual UnitType UnitType(
    int row,
    int col
)
Public Overridable Function UnitType ( _
    row As Integer, _
    col As Integer _
) As UnitType
public:
virtual UnitType UnitType(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


UnitType Method (type)

UnitType Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »UnitType(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual UnitType UnitType(
    RowType type
)
Public Overridable Function UnitType ( _
    type As RowType _
) As UnitType
public:
virtual UnitType UnitType(
    RowType type
)
Parameters
type(RowType)


UnmergeCells Method (range)

UnmergeCells Method (range)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »UnmergeCells(CellRange)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UnmergeCells(
    CellRange range
)
Public Overridable Sub UnmergeCells ( _
    range As CellRange _
)
public:
virtual void UnmergeCells(
    CellRange^ range
)
Parameters
range(CellRange)


UpdateDataLink Method

UpdateDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »UpdateDataLink()()()()
Members
Icon | Member | Description
 | UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) |
 | UpdateDataLink(UpdateDirection, UpdateOption) |


UpdateDataLink Method (row, column, dir, option)

UpdateDataLink Method (row, column, dir, option)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UpdateDataLink(
    int row,
    int column,
    UpdateDirection dir,
    UpdateOption option
)
Public Overridable Sub UpdateDataLink ( _
    row As Integer, _
    column As Integer, _
    dir As UpdateDirection, _
    option As UpdateOption _
)
public:
virtual void UpdateDataLink(
    int row,
    int column,
    UpdateDirection dir,
    UpdateOption option
)
Parameters
row(Int32)
column(Int32)
dir(UpdateDirection)
option(UpdateOption)


UpdateDataLink Method (dir, option)

UpdateDataLink Method (dir, option)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »UpdateDataLink(UpdateDirection, UpdateOption)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void UpdateDataLink(
    UpdateDirection dir,
    UpdateOption option
)
Public Overridable Sub UpdateDataLink ( _
    dir As UpdateDirection, _
    option As UpdateOption _
)
public:
virtual void UpdateDataLink(
    UpdateDirection dir,
    UpdateOption option
)
Parameters
dir(UpdateDirection)
option(UpdateOption)


Value Method (row, col)

Value Method (row, col)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Value(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Value(
    int row,
    int col
)
Public Overridable Function Value ( _
    row As Integer, _
    col As Integer _
) As Object
public:
virtual Object^ Value(
    int row,
    int col
)
Parameters
row(Int32)
col(Int32)


VerticalCellMargin Property

VerticalCellMargin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »VerticalCellMargin
Declaration Syntax
C# Visual Basic Visual C++
public virtual double VerticalCellMargin { get; set; }
Public Overridable Property VerticalCellMargin As Double
    Get
    Set
public:
virtual property double VerticalCellMargin {
    double get ();
    void set (double value);
}


Width Property

Width Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Width
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Width { get; set; }
Public Overridable Property Width As Double
    Get
    Set
public:
virtual property double Width {
    double get ();
    void set (double value);
}


TableBreakFlowDirection Enumeration

TableBreakFlowDirection Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableBreakFlowDirection
Declaration Syntax
C# Visual Basic Visual C++
public enum TableBreakFlowDirection
Public Enumeration TableBreakFlowDirection
public enum class TableBreakFlowDirection
Members
Member | Description
DownOrUp |
Left |
Right |


TableBreakOptions Enumeration

TableBreakOptions Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableBreakOptions
Declaration Syntax
C# Visual Basic Visual C++
public enum TableBreakOptions
Public Enumeration TableBreakOptions
public enum class TableBreakOptions
Members
Member | Description
AllowManualHeights |
AllowManualPositions |
RepeatBottomLabels |
RepeatTopLabels |
EnableBreaking |
None |


TableCellType Enumeration

TableCellType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableCellType
Declaration Syntax
C# Visual Basic Visual C++
public enum TableCellType
Public Enumeration TableCellType
public enum class TableCellType
Members
Member | Description
MultipleContentCell |
BlockCell |
TextCell |
UnknownCell |


TableContent Class

TableContent Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbTableContent")]
public class TableContent : FormattedTableData
<WrapperAttribute("AcDbTableContent")> _
Public Class TableContent _
    Inherits FormattedTableData
[WrapperAttribute(L"AcDbTableContent")]
public ref class TableContent : public FormattedTableData
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TableContent()()()() |
 | TableContent(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | AppendColumn(Int32) | (Inherited from LinkedTableData.)
 | AppendRow(Int32) | (Inherited from LinkedTableData.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clear()()()() | (Inherited from LinkedData.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DataType(Int32, Int32) | (Inherited from LinkedTableData.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteColumn(Int32, Int32) | (Inherited from LinkedTableData.)
 | DeleteContent(Int32, Int32) | (Inherited from LinkedTableData.)
 | DeleteRow(Int32, Int32) | (Inherited from LinkedTableData.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAlignment(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetBackgroundColor(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetBlockAttributeValue(Int32, Int32, ObjectId) | (Inherited from LinkedTableData.)
 | GetBlockTableRecordId(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetCellState(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetCellStyle(Int32, Int32) |
 | GetColumnName(Int32) | (Inherited from LinkedTableData.)
 | GetColumnWidth(Int32) |
 | GetContentColor(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetContentTypes(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetCustomData(Int32, Int32, String) | (Inherited from LinkedTableData.)
 | GetDataFormat(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetDataLink(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetDataLink(CellRange) | (Inherited from LinkedTableData.)
 | GetDataLink()()()() | (Inherited from LinkedTableData.)
 | GetEnumerator(TableEnumeratorOption) | (Inherited from LinkedTableData.)
 | GetEnumerator()()()() | (Inherited from LinkedTableData.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFieldId(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetGridColor(Int32, Int32, GridLineType) | (Inherited from FormattedTableData.)
 | GetGridLinetype(Int32, Int32, GridLineType) | (Inherited from FormattedTableData.)
 | GetGridLineWeight(Int32, Int32, GridLineType) | (Inherited from FormattedTableData.)
 | GetGridVisibility(Int32, Int32, GridLineType) | (Inherited from FormattedTableData.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetMargin(Int32, Int32, CellMargins) | (Inherited from FormattedTableData.)
 | GetMergeRange(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetOverride(Int32, Int32, Int32) | (Inherited from FormattedTableData.)
 | GetOverride(Int32, Int32, GridLineType) | (Inherited from FormattedTableData.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRotation(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetRowHeight(Int32) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetScale(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetTextHeight(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetTextStyle(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetToolTip(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetValue(Int32, Int32, Int32, FormatOption) | (Inherited from LinkedTableData.)
 | GetValue(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertColumn(Int32, Int32) | (Inherited from LinkedTableData.)
 | InsertRow(Int32, Int32) | (Inherited from LinkedTableData.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentEditable(Int32, Int32) | (Inherited from LinkedTableData.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEmpty | (Inherited from LinkedData.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsFormatEditable(Int32, Int32) | (Inherited from FormattedTableData.)
 | IsLinked(Int32, Int32) | (Inherited from LinkedTableData.)
 | IsMerged(Int32, Int32) | (Inherited from FormattedTableData.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Merge(CellRange) | (Inherited from FormattedTableData.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from LinkedData.)
 | NumberOfColumns | (Inherited from LinkedTableData.)
 | NumberOfRows | (Inherited from LinkedTableData.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveAllOverrides(Int32, Int32) | (Inherited from FormattedTableData.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAlignment(Int32, Int32, CellAlignment) | (Inherited from FormattedTableData.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetBackgroundColor(Int32, Int32, Color) | (Inherited from FormattedTableData.)
 | SetBlockAttributeValue(Int32, Int32, ObjectId, String) | (Inherited from LinkedTableData.)
 | SetBlockTableRecordId(Int32, Int32, ObjectId) | (Inherited from LinkedTableData.)
 | SetCellState(Int32, Int32, CellStates) | (Inherited from LinkedTableData.)
 | SetCellStyle(Int32, Int32, String) |
 | SetColumnName(Int32, String) | (Inherited from LinkedTableData.)
 | SetColumnWidth(Int32, Double) |
 | SetContentColor(Int32, Int32, Color) | (Inherited from FormattedTableData.)
 | SetCustomData(Int32, Int32, String, Object) | (Inherited from LinkedTableData.)
 | SetDataFormat(Int32, Int32, String) | (Inherited from LinkedTableData.)
 | SetDataLink(Int32, Int32, ObjectId, Boolean) | (Inherited from LinkedTableData.)
 | SetDataLink(CellRange, ObjectId, Boolean) | (Inherited from LinkedTableData.)
 | SetDataType(Int32, Int32, DataType, UnitType) | (Inherited from LinkedTableData.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFieldId(Int32, Int32, ObjectId) | (Inherited from LinkedTableData.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGridColor(Int32, Int32, GridLineType, Color) | (Inherited from FormattedTableData.)
 | SetGridLinetype(Int32, Int32, GridLineType, ObjectId) | (Inherited from FormattedTableData.)
 | SetGridLineWeight(Int32, Int32, GridLineType, LineWeight) | (Inherited from FormattedTableData.)
 | SetGridVisibility(Int32, Int32, GridLineType, Visibility) | (Inherited from FormattedTableData.)
 | SetMargin(Int32, Int32, CellMargins, Double) | (Inherited from FormattedTableData.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetOverride(Int32, Int32, Int32, CellProperties) | (Inherited from FormattedTableData.)
 | SetOverride(Int32, Int32, GridLineType, GridProperties) | (Inherited from FormattedTableData.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetRotation(Int32, Int32, Double) | (Inherited from FormattedTableData.)
 | SetRowHeight(Int32, Double) |
 | SetScale(Int32, Int32, Double) | (Inherited from FormattedTableData.)
 | SetSize(Int32, Int32) | (Inherited from LinkedTableData.)
 | SetTextHeight(Int32, Int32, Double) | (Inherited from FormattedTableData.)
 | SetTextStyle(Int32, Int32, ObjectId) | (Inherited from FormattedTableData.)
 | SetToolTip(Int32, Int32, String) | (Inherited from LinkedTableData.)
 | SetValue(Int32, Int32, Int32, Object, ParseOption) | (Inherited from LinkedTableData.)
 | SetValue(Int32, Int32, Object) | (Inherited from LinkedTableData.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TableStyleId |
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnitType(Int32, Int32) | (Inherited from LinkedTableData.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Unmerge(CellRange) | (Inherited from FormattedTableData.)
 | UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) | (Inherited from LinkedTableData.)
 | UpdateDataLink(UpdateDirection, UpdateOption) | (Inherited from LinkedTableData.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | LinkedData
 |  |  |  |  |  |  | LinkedTableData
 |  |  |  |  |  |  |  | FormattedTableData
 |  |  |  |  |  |  |  |  | TableContent
 |  |  |  |  |  |  |  |  |  | TableTemplate


TableContent Constructor

TableContent Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »TableContent()()()()
Members
Icon | Member | Description
 | TableContent()()()() |
 | TableContent(IntPtr, Boolean) |


TableContent Constructor

TableContent Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »TableContent()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TableContent()
Public Sub New
public:
TableContent()


TableContent Constructor (unmanagedPointer, autoDelete)

TableContent Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »TableContent(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal TableContent(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
TableContent(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetCellStyle Method (row, column)

GetCellStyle Method (row, column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »GetCellStyle(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetCellStyle(
    int row,
    int column
)
Public Overridable Function GetCellStyle ( _
    row As Integer, _
    column As Integer _
) As String
public:
virtual String^ GetCellStyle(
    int row,
    int column
)
Parameters
row(Int32)
column(Int32)


GetColumnWidth Method (column)

GetColumnWidth Method (column)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »GetColumnWidth(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetColumnWidth(
    int column
)
Public Overridable Function GetColumnWidth ( _
    column As Integer _
) As Double
public:
virtual double GetColumnWidth(
    int column
)
Parameters
column(Int32)


GetRowHeight Method (row)

GetRowHeight Method (row)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »GetRowHeight(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double GetRowHeight(
    int row
)
Public Overridable Function GetRowHeight ( _
    row As Integer _
) As Double
public:
virtual double GetRowHeight(
    int row
)
Parameters
row(Int32)


SetCellStyle Method (row, column, cellStyle)

SetCellStyle Method (row, column, cellStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »SetCellStyle(Int32, Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCellStyle(
    int row,
    int column,
    string cellStyle
)
Public Overridable Sub SetCellStyle ( _
    row As Integer, _
    column As Integer, _
    cellStyle As String _
)
public:
virtual void SetCellStyle(
    int row,
    int column,
    String^ cellStyle
)
Parameters
row(Int32)
column(Int32)
cellStyle(String)


SetColumnWidth Method (column, width)

SetColumnWidth Method (column, width)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »SetColumnWidth(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetColumnWidth(
    int column,
    double width
)
Public Overridable Sub SetColumnWidth ( _
    column As Integer, _
    width As Double _
)
public:
virtual void SetColumnWidth(
    int column,
    double width
)
Parameters
column(Int32)
width(Double)


SetRowHeight Method (row, height)

SetRowHeight Method (row, height)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »SetRowHeight(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetRowHeight(
    int row,
    double height
)
Public Overridable Sub SetRowHeight ( _
    row As Integer, _
    height As Double _
)
public:
virtual void SetRowHeight(
    int row,
    double height
)
Parameters
row(Int32)
height(Double)


TableStyleId Property

TableStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »TableStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId TableStyleId { get; set; }
Public Property TableStyleId As ObjectId
    Get
    Set
public:
property ObjectId TableStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


TableCopyOptions Enumeration

TableCopyOptions Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableCopyOptions
Declaration Syntax
C# Visual Basic Visual C++
public enum TableCopyOptions
Public Enumeration TableCopyOptions
public enum class TableCopyOptions
Members
Member | Description
TableCopyColumnWidth |
TableCopyRowHeight |
OnlyFormatModifiedAfterUpdate |
OnlyContentModifiedAfterUpdate |
OverwriteFormatModifiedAfterUpdate |
OverwriteContentModifiedAfterUpdate |
OverwriteReadOnlyFormat |
OverwriteReadOnlyContent |
FillTarget |
SkipMerges |
SkipGeometry |
SkipDissimilarContentFormat |
SkipContentFormat |
SkipCellState |
ConvertFormatToOverrides |
SkipCellStyle |
SkipFormat |
SkipDataCell |
SkipLabelCell |
SkipDataLink |
SkipBlock |
SkipFormula |
SkipField |
SkipValue |
SkipContent |
ExpandOrContractTable |
None |


TableEnumerator Class

TableEnumerator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public abstract class TableEnumerator : IEnumerator
Public MustInherit Class TableEnumerator _
    Implements IEnumerator
public ref class TableEnumerator abstract : IEnumerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TableEnumerator()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumeratorCurrent |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | TableEnumerator
 |  | LinkedTableEnumerator


TableEnumerator Constructor

TableEnumerator Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableEnumerator »TableEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TableEnumerator()
Public Sub New
public:
TableEnumerator()


IEnumeratorCurrent Property

IEnumeratorCurrent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableEnumerator »IEnumeratorCurrent
Declaration Syntax
C# Visual Basic Visual C++
internal virtual Object IEnumeratorCurrent { get; }
Friend Overridable ReadOnly Property IEnumeratorCurrent As Object
    Get
internal:
virtual property Object^ IEnumeratorCurrent {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool MoveNext()
Public MustOverride Function MoveNext As Boolean
public:
virtual bool MoveNext() abstract


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Reset()
Public MustOverride Sub Reset
public:
virtual void Reset() abstract


TableEnumeratorOption Enumeration

TableEnumeratorOption Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableEnumeratorOption
Declaration Syntax
C# Visual Basic Visual C++
public enum TableEnumeratorOption
Public Enumeration TableEnumeratorOption
public enum class TableEnumeratorOption
Members
Member | Description
SkipMerged |
SkipReadOnlyFormat |
SkipReadOnlyContent |
IterateColumns |
IterateRows |
IterateSelection |
None |


TableFillOptions Enumeration

TableFillOptions Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableFillOptions
Declaration Syntax
C# Visual Basic Visual C++
public enum TableFillOptions
Public Enumeration TableFillOptions
public enum class TableFillOptions
Members
Member | Description
OverwriteReadOnlyFormat |
OverwriteReadOnlyContent |
CopyFormat |
CopyContent |
GenerateSeries |
Reverse |
Row |
None |


TableHitTestInfo Structure

TableHitTestInfo Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableHitTestInfo
Declaration Syntax
C# Visual Basic Visual C++
public struct TableHitTestInfo
Public Structure TableHitTestInfo
public value class TableHitTestInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Column |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Row |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | Type |


Column Property

Column Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableHitTestInfo »Column
Declaration Syntax
C# Visual Basic Visual C++
public int Column { get; }
Public ReadOnly Property Column As Integer
    Get
public:
property int Column {
    int get ();
}


Row Property

Row Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableHitTestInfo »Row
Declaration Syntax
C# Visual Basic Visual C++
public int Row { get; }
Public ReadOnly Property Row As Integer
    Get
public:
property int Row {
    int get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableHitTestInfo »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableHitTestInfo »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableHitTestInfo »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


Type Property

Type Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableHitTestInfo »Type
Declaration Syntax
C# Visual Basic Visual C++
public TableHitTestType Type { get; }
Public ReadOnly Property Type As TableHitTestType
    Get
public:
property TableHitTestType Type {
    TableHitTestType get ();
}


TableHitTestType Enumeration

TableHitTestType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableHitTestType
Declaration Syntax
C# Visual Basic Visual C++
public enum TableHitTestType
Public Enumeration TableHitTestType
public enum class TableHitTestType
Members
Member | Description
Cell |
None |


TableStyle Class

TableStyle Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbTableStyle")]
public class TableStyle : DBObject
<WrapperAttribute("AcDbTableStyle")> _
Public Class TableStyle _
    Inherits DBObject
[WrapperAttribute(L"AcDbTableStyle")]
public ref class TableStyle : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TableStyle()()()() |
 | TableStyle(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Alignment(RowType) |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackgroundColor(RowType) |
 | BitFlags |
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CellClass(String) |
 | CellStyles |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Color(RowType) |
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DataType(RowType) |
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | Description |
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FlowDirection |
 | Format(RowType) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | GridColor(GridLineType, RowType) |
 | GridLineWeight(GridLineType, RowType) |
 | GridVisibility(GridLineType, RowType) |
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | HorizontalCellMargin |
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsBackgroundColorNone(RowType) |
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsHeaderSuppressed |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTitleSuppressed |
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Margin(CellMargins, String) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PostTableStyleToDatabase(Database, String) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAlignment(CellAlignment, Int32) |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetBackgroundColor(Color, Int32) |
 | SetBackgroundColorNone(Boolean, Int32) |
 | SetCellClass(CellClass, String) |
 | SetColor(Color, Int32) |
 | SetDataType(DataType, UnitType, RowType) |
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFormat(String, RowType) |
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGridColor(Color, Int32, Int32) |
 | SetGridLineWeight(LineWeight, Int32, Int32) |
 | SetGridVisibility(Boolean, Int32, Int32) |
 | SetMargin(CellMargins, Double, String) |
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetTextHeight(Double, Int32) |
 | SetTextStyle(ObjectId, String) |
 | SetTextStyle(ObjectId, Int32) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Template |
 | TextHeight(String) |
 | TextHeight(RowType) |
 | TextStyle(String) |
 | TextStyle(RowType) |
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnitType(RowType) |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VerticalCellMargin |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | TableStyle


TableStyle Constructor

TableStyle Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »TableStyle()()()()
Members
Icon | Member | Description
 | TableStyle()()()() |
 | TableStyle(IntPtr, Boolean) |


TableStyle Constructor

TableStyle Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »TableStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TableStyle()
Public Sub New
public:
TableStyle()


TableStyle Constructor (unmanagedPointer, autoDelete)

TableStyle Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »TableStyle(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal TableStyle(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
TableStyle(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Alignment Method (rowType)

Alignment Method (rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »Alignment(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellAlignment Alignment(
    RowType rowType
)
Public Overridable Function Alignment ( _
    rowType As RowType _
) As CellAlignment
public:
virtual CellAlignment Alignment(
    RowType rowType
)
Parameters
rowType(RowType)


BackgroundColor Method (rowType)

BackgroundColor Method (rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »BackgroundColor(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color BackgroundColor(
    RowType rowType
)
Public Overridable Function BackgroundColor ( _
    rowType As RowType _
) As Color
public:
virtual Color^ BackgroundColor(
    RowType rowType
)
Parameters
rowType(RowType)


BitFlags Property

BitFlags Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »BitFlags
Declaration Syntax
C# Visual Basic Visual C++
public virtual int BitFlags { get; set; }
Public Overridable Property BitFlags As Integer
    Get
    Set
public:
virtual property int BitFlags {
    int get ();
    void set (int value);
}


CellClass Method (styleName)

CellClass Method (styleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »CellClass(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual CellClass CellClass(
    string styleName
)
Public Overridable Function CellClass ( _
    styleName As String _
) As CellClass
public:
virtual CellClass CellClass(
    String^ styleName
)
Parameters
styleName(String)


CellStyles Property

CellStyles Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »CellStyles
Declaration Syntax
C# Visual Basic Visual C++
public virtual ArrayList CellStyles { get; }
Public Overridable ReadOnly Property CellStyles As ArrayList
    Get
public:
virtual property ArrayList^ CellStyles {
    ArrayList^ get ();
}


Color Method (rowType)

Color Method (rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »Color(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color Color(
    RowType rowType
)
Public Overridable Function Color ( _
    rowType As RowType _
) As Color
public:
virtual Color^ Color(
    RowType rowType
)
Parameters
rowType(RowType)


DataType Method (rowType)

DataType Method (rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »DataType(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DataType DataType(
    RowType rowType
)
Public Overridable Function DataType ( _
    rowType As RowType _
) As DataType
public:
virtual DataType DataType(
    RowType rowType
)
Parameters
rowType(RowType)


Description Property

Description Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »Description
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}


FlowDirection Property

FlowDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »FlowDirection
Declaration Syntax
C# Visual Basic Visual C++
public virtual FlowDirection FlowDirection { get; set; }
Public Overridable Property FlowDirection As FlowDirection
    Get
    Set
public:
virtual property FlowDirection FlowDirection {
    FlowDirection get ();
    void set (FlowDirection value);
}


Format Method (rowType)

Format Method (rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »Format(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Format(
    RowType rowType
)
Public Overridable Function Format ( _
    rowType As RowType _
) As String
public:
virtual String^ Format(
    RowType rowType
)
Parameters
rowType(RowType)


GridColor Method (gridLineType, rowType)

GridColor Method (gridLineType, rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »GridColor(GridLineType, RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Color GridColor(
    GridLineType gridLineType,
    RowType rowType
)
Public Overridable Function GridColor ( _
    gridLineType As GridLineType, _
    rowType As RowType _
) As Color
public:
virtual Color^ GridColor(
    GridLineType gridLineType,
    RowType rowType
)
Parameters
gridLineType(GridLineType)
rowType(RowType)


GridLineWeight Method (gridLineType, rowType)

GridLineWeight Method (gridLineType, rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »GridLineWeight(GridLineType, RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight GridLineWeight(
    GridLineType gridLineType,
    RowType rowType
)
Public Overridable Function GridLineWeight ( _
    gridLineType As GridLineType, _
    rowType As RowType _
) As LineWeight
public:
virtual LineWeight GridLineWeight(
    GridLineType gridLineType,
    RowType rowType
)
Parameters
gridLineType(GridLineType)
rowType(RowType)


GridVisibility Method (gridLineType, rowType)

GridVisibility Method (gridLineType, rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »GridVisibility(GridLineType, RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool GridVisibility(
    GridLineType gridLineType,
    RowType rowType
)
Public Overridable Function GridVisibility ( _
    gridLineType As GridLineType, _
    rowType As RowType _
) As Boolean
public:
virtual bool GridVisibility(
    GridLineType gridLineType,
    RowType rowType
)
Parameters
gridLineType(GridLineType)
rowType(RowType)


HorizontalCellMargin Property

HorizontalCellMargin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »HorizontalCellMargin
Declaration Syntax
C# Visual Basic Visual C++
public virtual double HorizontalCellMargin { get; set; }
Public Overridable Property HorizontalCellMargin As Double
    Get
    Set
public:
virtual property double HorizontalCellMargin {
    double get ();
    void set (double value);
}


IsBackgroundColorNone Method (rowType)

IsBackgroundColorNone Method (rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »IsBackgroundColorNone(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsBackgroundColorNone(
    RowType rowType
)
Public Overridable Function IsBackgroundColorNone ( _
    rowType As RowType _
) As Boolean
public:
virtual bool IsBackgroundColorNone(
    RowType rowType
)
Parameters
rowType(RowType)


IsHeaderSuppressed Property

IsHeaderSuppressed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »IsHeaderSuppressed
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsHeaderSuppressed { get; set; }
Public Overridable Property IsHeaderSuppressed As Boolean
    Get
    Set
public:
virtual property bool IsHeaderSuppressed {
    bool get ();
    void set (bool value);
}


IsTitleSuppressed Property

IsTitleSuppressed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »IsTitleSuppressed
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsTitleSuppressed { get; set; }
Public Overridable Property IsTitleSuppressed As Boolean
    Get
    Set
public:
virtual property bool IsTitleSuppressed {
    bool get ();
    void set (bool value);
}


Margin Method (cellMargin, styleName)

Margin Method (cellMargin, styleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »Margin(CellMargins, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Margin(
    CellMargins cellMargin,
    string styleName
)
Public Overridable Function Margin ( _
    cellMargin As CellMargins, _
    styleName As String _
) As Double
public:
virtual double Margin(
    CellMargins cellMargin,
    String^ styleName
)
Parameters
cellMargin(CellMargins)
styleName(String)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »Name
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}


PostTableStyleToDatabase Method (databasePointer, styleName)

PostTableStyleToDatabase Method (databasePointer, styleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »PostTableStyleToDatabase(Database, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId PostTableStyleToDatabase(
    Database databasePointer,
    string styleName
)
Public Overridable Function PostTableStyleToDatabase ( _
    databasePointer As Database, _
    styleName As String _
) As ObjectId
public:
virtual ObjectId PostTableStyleToDatabase(
    Database^ databasePointer,
    String^ styleName
)
Parameters
databasePointer(Database)
styleName(String)


SetAlignment Method (alignment, rowTypes)

SetAlignment Method (alignment, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetAlignment(CellAlignment, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetAlignment(
    CellAlignment alignment,
    int rowTypes
)
Public Overridable Sub SetAlignment ( _
    alignment As CellAlignment, _
    rowTypes As Integer _
)
public:
virtual void SetAlignment(
    CellAlignment alignment,
    int rowTypes
)
Parameters
alignment(CellAlignment)
rowTypes(Int32)


SetBackgroundColor Method (color, rowTypes)

SetBackgroundColor Method (color, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetBackgroundColor(Color, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBackgroundColor(
    Color color,
    int rowTypes
)
Public Overridable Sub SetBackgroundColor ( _
    color As Color, _
    rowTypes As Integer _
)
public:
virtual void SetBackgroundColor(
    Color^ color,
    int rowTypes
)
Parameters
color(Color)
rowTypes(Int32)


SetBackgroundColorNone Method (value, rowTypes)

SetBackgroundColorNone Method (value, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetBackgroundColorNone(Boolean, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetBackgroundColorNone(
    bool value,
    int rowTypes
)
Public Overridable Sub SetBackgroundColorNone ( _
    value As Boolean, _
    rowTypes As Integer _
)
public:
virtual void SetBackgroundColorNone(
    bool value,
    int rowTypes
)
Parameters
value(Boolean)
rowTypes(Int32)


SetCellClass Method (cellClass, styleName)

SetCellClass Method (cellClass, styleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetCellClass(CellClass, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetCellClass(
    CellClass cellClass,
    string styleName
)
Public Overridable Sub SetCellClass ( _
    cellClass As CellClass, _
    styleName As String _
)
public:
virtual void SetCellClass(
    CellClass cellClass,
    String^ styleName
)
Parameters
cellClass(CellClass)
styleName(String)


SetColor Method (color, rowTypes)

SetColor Method (color, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetColor(Color, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetColor(
    Color color,
    int rowTypes
)
Public Overridable Sub SetColor ( _
    color As Color, _
    rowTypes As Integer _
)
public:
virtual void SetColor(
    Color^ color,
    int rowTypes
)
Parameters
color(Color)
rowTypes(Int32)


SetDataType Method (nDataType, nUnitType, rowTypes)

SetDataType Method (nDataType, nUnitType, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetDataType(DataType, UnitType, RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDataType(
    DataType nDataType,
    UnitType nUnitType,
    RowType rowTypes
)
Public Overridable Sub SetDataType ( _
    nDataType As DataType, _
    nUnitType As UnitType, _
    rowTypes As RowType _
)
public:
virtual void SetDataType(
    DataType nDataType,
    UnitType nUnitType,
    RowType rowTypes
)
Parameters
nDataType(DataType)
nUnitType(UnitType)
rowTypes(RowType)


SetFormat Method (pFormat, rowTypes)

SetFormat Method (pFormat, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetFormat(String, RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetFormat(
    string pFormat,
    RowType rowTypes
)
Public Overridable Sub SetFormat ( _
    pFormat As String, _
    rowTypes As RowType _
)
public:
virtual void SetFormat(
    String^ pFormat,
    RowType rowTypes
)
Parameters
pFormat(String)
rowTypes(RowType)


SetGridColor Method (color, gridLineTypes, rowTypes)

SetGridColor Method (color, gridLineTypes, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetGridColor(Color, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridColor(
    Color color,
    int gridLineTypes,
    int rowTypes
)
Public Overridable Sub SetGridColor ( _
    color As Color, _
    gridLineTypes As Integer, _
    rowTypes As Integer _
)
public:
virtual void SetGridColor(
    Color^ color,
    int gridLineTypes,
    int rowTypes
)
Parameters
color(Color)
gridLineTypes(Int32)
rowTypes(Int32)


SetGridLineWeight Method (lineWeight, gridLineTypes, rowTypes)

SetGridLineWeight Method (lineWeight, gridLineTypes, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetGridLineWeight(LineWeight, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridLineWeight(
    LineWeight lineWeight,
    int gridLineTypes,
    int rowTypes
)
Public Overridable Sub SetGridLineWeight ( _
    lineWeight As LineWeight, _
    gridLineTypes As Integer, _
    rowTypes As Integer _
)
public:
virtual void SetGridLineWeight(
    LineWeight lineWeight,
    int gridLineTypes,
    int rowTypes
)
Parameters
lineWeight(LineWeight)
gridLineTypes(Int32)
rowTypes(Int32)


SetGridVisibility Method (visible, gridLineTypes, rowTypes)

SetGridVisibility Method (visible, gridLineTypes, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetGridVisibility(Boolean, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetGridVisibility(
    bool visible,
    int gridLineTypes,
    int rowTypes
)
Public Overridable Sub SetGridVisibility ( _
    visible As Boolean, _
    gridLineTypes As Integer, _
    rowTypes As Integer _
)
public:
virtual void SetGridVisibility(
    bool visible,
    int gridLineTypes,
    int rowTypes
)
Parameters
visible(Boolean)
gridLineTypes(Int32)
rowTypes(Int32)


SetMargin Method (cellMargin, margin, styleName)

SetMargin Method (cellMargin, margin, styleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetMargin(CellMargins, Double, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetMargin(
    CellMargins cellMargin,
    double margin,
    string styleName
)
Public Overridable Sub SetMargin ( _
    cellMargin As CellMargins, _
    margin As Double, _
    styleName As String _
)
public:
virtual void SetMargin(
    CellMargins cellMargin,
    double margin,
    String^ styleName
)
Parameters
cellMargin(CellMargins)
margin(Double)
styleName(String)


SetTextHeight Method (height, rowTypes)

SetTextHeight Method (height, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetTextHeight(Double, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextHeight(
    double height,
    int rowTypes
)
Public Overridable Sub SetTextHeight ( _
    height As Double, _
    rowTypes As Integer _
)
public:
virtual void SetTextHeight(
    double height,
    int rowTypes
)
Parameters
height(Double)
rowTypes(Int32)


SetTextStyle Method

SetTextStyle Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetTextStyle()()()()
Members
Icon | Member | Description
 | SetTextStyle(ObjectId, String) |
 | SetTextStyle(ObjectId, Int32) |


SetTextStyle Method (id, rowTypes)

SetTextStyle Method (id, rowTypes)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetTextStyle(ObjectId, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextStyle(
    ObjectId id,
    int rowTypes
)
Public Overridable Sub SetTextStyle ( _
    id As ObjectId, _
    rowTypes As Integer _
)
public:
virtual void SetTextStyle(
    ObjectId id,
    int rowTypes
)
Parameters
id(ObjectId)
rowTypes(Int32)


SetTextStyle Method (id, styleName)

SetTextStyle Method (id, styleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetTextStyle(ObjectId, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextStyle(
    ObjectId id,
    string styleName
)
Public Overridable Sub SetTextStyle ( _
    id As ObjectId, _
    styleName As String _
)
public:
virtual void SetTextStyle(
    ObjectId id,
    String^ styleName
)
Parameters
id(ObjectId)
styleName(String)


Template Property

Template Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »Template
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId Template { get; }
Public Overridable ReadOnly Property Template As ObjectId
    Get
public:
virtual property ObjectId Template {
    ObjectId get ();
}


TextHeight Method

TextHeight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »TextHeight()()()()
Members
Icon | Member | Description
 | TextHeight(String) |
 | TextHeight(RowType) |


TextHeight Method (cellStyle)

TextHeight Method (cellStyle)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »TextHeight(String)
Declaration Syntax
C# Visual Basic Visual C++
public double TextHeight(
    string cellStyle
)
Public Function TextHeight ( _
    cellStyle As String _
) As Double
public:
double TextHeight(
    String^ cellStyle
)
Parameters
cellStyle(String)


TextHeight Method (rowType)

TextHeight Method (rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »TextHeight(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual double TextHeight(
    RowType rowType
)
Public Overridable Function TextHeight ( _
    rowType As RowType _
) As Double
public:
virtual double TextHeight(
    RowType rowType
)
Parameters
rowType(RowType)


TextStyle Method

TextStyle Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »TextStyle()()()()
Members
Icon | Member | Description
 | TextStyle(String) |
 | TextStyle(RowType) |


TextStyle Method (styleName)

TextStyle Method (styleName)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »TextStyle(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId TextStyle(
    string styleName
)
Public Overridable Function TextStyle ( _
    styleName As String _
) As ObjectId
public:
virtual ObjectId TextStyle(
    String^ styleName
)
Parameters
styleName(String)


TextStyle Method (rowType)

TextStyle Method (rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »TextStyle(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId TextStyle(
    RowType rowType
)
Public Overridable Function TextStyle ( _
    rowType As RowType _
) As ObjectId
public:
virtual ObjectId TextStyle(
    RowType rowType
)
Parameters
rowType(RowType)


UnitType Method (rowType)

UnitType Method (rowType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »UnitType(RowType)
Declaration Syntax
C# Visual Basic Visual C++
public virtual UnitType UnitType(
    RowType rowType
)
Public Overridable Function UnitType ( _
    rowType As RowType _
) As UnitType
public:
virtual UnitType UnitType(
    RowType rowType
)
Parameters
rowType(RowType)


VerticalCellMargin Property

VerticalCellMargin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »VerticalCellMargin
Declaration Syntax
C# Visual Basic Visual C++
public virtual double VerticalCellMargin { get; set; }
Public Overridable Property VerticalCellMargin As Double
    Get
    Set
public:
virtual property double VerticalCellMargin {
    double get ();
    void set (double value);
}


TableStyleFlags Enumeration

TableStyleFlags Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyleFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
[WrapperAttribute("AcDb::TableStyleFlags")]
public enum TableStyleFlags
<FlagsAttribute> _
<WrapperAttribute("AcDb::TableStyleFlags")> _
Public Enumeration TableStyleFlags
[FlagsAttribute]
[WrapperAttribute(L"AcDb::TableStyleFlags")]
public enum class TableStyleFlags
Members
Member | Description
TableStyleModified |
HorizontalInsideLineThird |
HorizontalInsideLineSecond |
HorizontalInsideLineFirst |


TableStyleOverride Enumeration

TableStyleOverride Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyleOverride
Declaration Syntax
C# Visual Basic Visual C++
public enum TableStyleOverride
Public Enumeration TableStyleOverride
public enum class TableStyleOverride
Members
Member | Description
CellAlignment |
FlowDirection |
CellDataType |
CellLeftVisibility |
CellBottomVisibility |
CellRightVisibility |
CellTopVisibility |
CellLeftGridLineWeight |
CellBottomGridLineWeight |
CellRightGridLineWeight |
CellTopGridLineWeight |
CellLeftGridColor |
CellBottomGridColor |
CellRightGridColor |
CellTopGridColor |
CellTextHeight |
CellTextStyle |
CellContentColor |
CellBackgroundColor |
CellBackgroundFillNone |
DataVerticalRightVisibility |
DataVerticalInsideVisibility |
DataVerticalLeftVisibility |
DataHorizontalBottomVisibility |
DataHorizontalInsideVisibility |
DataHorizontalTopVisibility |
HeaderVerticalRightVisibility |
HeaderVerticalInsideVisibility |
HeaderVerticalLeftVisibility |
HeaderHorizontalBottomVisibility |
HeaderHorizontalInsideVisibility |
HeaderHorizontalTopVisibility |
TitleVerticalRightVisibility |
TitleVerticalInsideVisibility |
TitleVerticalLeftVisibility |
TitleHorizontalBottomVisibility |
TitleHorizontalInsideVisibility |
TitleHorizontalTopVisibility |
DataVerticalRightLineWeight |
DataVerticalInsideLineWeight |
DataVerticalLeftLineWeight |
DataHorizontalBottomLineWeight |
DataHorizontalInsideLineWeight |
DataHorizontalTopLineWeight |
HeaderVerticalRightLineWeight |
HeaderVerticalInsideLineWeight |
HeaderVerticalLeftLineWeight |
HeaderHorizontalBottomLineWeight |
HeaderHorizontalInsideLineWeight |
HeaderHorizontalTopLineWeight |
TitleVerticalRightLineWeight |
TitleVerticalInsideLineWeight |
TitleVerticalLeftLineWeight |
TitleHorizontalBottomLineWeight |
TitleHorizontalInsideLineWeight |
TitleHorizontalTopLineWeight |
DataVerticalRightColor |
DataVerticalInsideColor |
DataVerticalLeftColor |
DataHorizontalBottomColor |
DataHorizontalInsideColor |
DataHorizontalTopColor |
HeaderVerticalRightColor |
HeaderVerticalInsideColor |
HeaderVerticalLeftColor |
HeaderHorizontalBottomColor |
HeaderHorizontalInsideColor |
HeaderHorizontalTopColor |
TitleVerticalRightColor |
TitleVerticalInsideColor |
TitleVerticalLeftColor |
TitleHorizontalBottomColor |
TitleHorizontalInsideColor |
TitleHorizontalTopColor |
DataRowDataType |
HeaderRowDataType |
TitleRowDataType |
DataRowTextHeight |
HeaderRowTextHeight |
TitleRowTextHeight |
DataRowTextStyle |
HeaderRowTextStyle |
TitleRowTextStyle |
DataRowAlignment |
HeaderRowAlignment |
TitleRowAlignment |
DataRowFillColor |
HeaderRowFillColor |
TitleRowFillColor |
DataRowFillNone |
HeaderRowFillNone |
TitleRowFillNone |
DataRowColor |
HeaderRowColor |
TitleRowColor |
VerticalCellMargin |
HorizontalCellMargin |
HeaderSuppressed |
TitleSuppressed |


TableTemplate Class

TableTemplate Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbTableTemplate")]
public class TableTemplate : TableContent
<WrapperAttribute("AcDbTableTemplate")> _
Public Class TableTemplate _
    Inherits TableContent
[WrapperAttribute(L"AcDbTableTemplate")]
public ref class TableTemplate : public TableContent
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TableTemplate(Table, TableCopyOptions) |
 | TableTemplate(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | AppendColumn(Int32) | (Inherited from LinkedTableData.)
 | AppendRow(Int32) | (Inherited from LinkedTableData.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | Capture(Table, TableCopyOptions) |
 | ClassID | (Inherited from DBObject.)
 | Clear()()()() | (Inherited from LinkedData.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateTable(TableCopyOptions) |
 | Database | (Inherited from DBObject.)
 | DataType(Int32, Int32) | (Inherited from LinkedTableData.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteColumn(Int32, Int32) | (Inherited from LinkedTableData.)
 | DeleteContent(Int32, Int32) | (Inherited from LinkedTableData.)
 | DeleteRow(Int32, Int32) | (Inherited from LinkedTableData.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAlignment(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetBackgroundColor(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetBlockAttributeValue(Int32, Int32, ObjectId) | (Inherited from LinkedTableData.)
 | GetBlockTableRecordId(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetCellState(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetCellStyle(Int32, Int32) | (Inherited from TableContent.)
 | GetColumnName(Int32) | (Inherited from LinkedTableData.)
 | GetColumnWidth(Int32) | (Inherited from TableContent.)
 | GetContentColor(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetContentTypes(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetCustomData(Int32, Int32, String) | (Inherited from LinkedTableData.)
 | GetDataFormat(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetDataLink(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetDataLink(CellRange) | (Inherited from LinkedTableData.)
 | GetDataLink()()()() | (Inherited from LinkedTableData.)
 | GetEnumerator(TableEnumeratorOption) | (Inherited from LinkedTableData.)
 | GetEnumerator()()()() | (Inherited from LinkedTableData.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFieldId(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetGridColor(Int32, Int32, GridLineType) | (Inherited from FormattedTableData.)
 | GetGridLinetype(Int32, Int32, GridLineType) | (Inherited from FormattedTableData.)
 | GetGridLineWeight(Int32, Int32, GridLineType) | (Inherited from FormattedTableData.)
 | GetGridVisibility(Int32, Int32, GridLineType) | (Inherited from FormattedTableData.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetMargin(Int32, Int32, CellMargins) | (Inherited from FormattedTableData.)
 | GetMergeRange(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetOverride(Int32, Int32, Int32) | (Inherited from FormattedTableData.)
 | GetOverride(Int32, Int32, GridLineType) | (Inherited from FormattedTableData.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRotation(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetRowHeight(Int32) | (Inherited from TableContent.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetScale(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetTextHeight(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetTextStyle(Int32, Int32) | (Inherited from FormattedTableData.)
 | GetToolTip(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetValue(Int32, Int32, Int32, FormatOption) | (Inherited from LinkedTableData.)
 | GetValue(Int32, Int32) | (Inherited from LinkedTableData.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertColumn(Int32, Int32) | (Inherited from LinkedTableData.)
 | InsertRow(Int32, Int32) | (Inherited from LinkedTableData.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentEditable(Int32, Int32) | (Inherited from LinkedTableData.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEmpty | (Inherited from LinkedData.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsFormatEditable(Int32, Int32) | (Inherited from FormattedTableData.)
 | IsLinked(Int32, Int32) | (Inherited from LinkedTableData.)
 | IsMerged(Int32, Int32) | (Inherited from FormattedTableData.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Merge(CellRange) | (Inherited from FormattedTableData.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from LinkedData.)
 | NumberOfColumns | (Inherited from LinkedTableData.)
 | NumberOfRows | (Inherited from LinkedTableData.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveAllOverrides(Int32, Int32) | (Inherited from FormattedTableData.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAlignment(Int32, Int32, CellAlignment) | (Inherited from FormattedTableData.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetBackgroundColor(Int32, Int32, Color) | (Inherited from FormattedTableData.)
 | SetBlockAttributeValue(Int32, Int32, ObjectId, String) | (Inherited from LinkedTableData.)
 | SetBlockTableRecordId(Int32, Int32, ObjectId) | (Inherited from LinkedTableData.)
 | SetCellState(Int32, Int32, CellStates) | (Inherited from LinkedTableData.)
 | SetCellStyle(Int32, Int32, String) | (Inherited from TableContent.)
 | SetColumnName(Int32, String) | (Inherited from LinkedTableData.)
 | SetColumnWidth(Int32, Double) | (Inherited from TableContent.)
 | SetContentColor(Int32, Int32, Color) | (Inherited from FormattedTableData.)
 | SetCustomData(Int32, Int32, String, Object) | (Inherited from LinkedTableData.)
 | SetDataFormat(Int32, Int32, String) | (Inherited from LinkedTableData.)
 | SetDataLink(Int32, Int32, ObjectId, Boolean) | (Inherited from LinkedTableData.)
 | SetDataLink(CellRange, ObjectId, Boolean) | (Inherited from LinkedTableData.)
 | SetDataType(Int32, Int32, DataType, UnitType) | (Inherited from LinkedTableData.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFieldId(Int32, Int32, ObjectId) | (Inherited from LinkedTableData.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGridColor(Int32, Int32, GridLineType, Color) | (Inherited from FormattedTableData.)
 | SetGridLinetype(Int32, Int32, GridLineType, ObjectId) | (Inherited from FormattedTableData.)
 | SetGridLineWeight(Int32, Int32, GridLineType, LineWeight) | (Inherited from FormattedTableData.)
 | SetGridVisibility(Int32, Int32, GridLineType, Visibility) | (Inherited from FormattedTableData.)
 | SetMargin(Int32, Int32, CellMargins, Double) | (Inherited from FormattedTableData.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetOverride(Int32, Int32, Int32, CellProperties) | (Inherited from FormattedTableData.)
 | SetOverride(Int32, Int32, GridLineType, GridProperties) | (Inherited from FormattedTableData.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetRotation(Int32, Int32, Double) | (Inherited from FormattedTableData.)
 | SetRowHeight(Int32, Double) | (Inherited from TableContent.)
 | SetScale(Int32, Int32, Double) | (Inherited from FormattedTableData.)
 | SetSize(Int32, Int32) | (Inherited from LinkedTableData.)
 | SetTextHeight(Int32, Int32, Double) | (Inherited from FormattedTableData.)
 | SetTextStyle(Int32, Int32, ObjectId) | (Inherited from FormattedTableData.)
 | SetToolTip(Int32, Int32, String) | (Inherited from LinkedTableData.)
 | SetValue(Int32, Int32, Int32, Object, ParseOption) | (Inherited from LinkedTableData.)
 | SetValue(Int32, Int32, Object) | (Inherited from LinkedTableData.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TableStyleId | (Inherited from TableContent.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnitType(Int32, Int32) | (Inherited from LinkedTableData.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Unmerge(CellRange) | (Inherited from FormattedTableData.)
 | UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) | (Inherited from LinkedTableData.)
 | UpdateDataLink(UpdateDirection, UpdateOption) | (Inherited from LinkedTableData.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | LinkedData
 |  |  |  |  |  |  | LinkedTableData
 |  |  |  |  |  |  |  | FormattedTableData
 |  |  |  |  |  |  |  |  | TableContent
 |  |  |  |  |  |  |  |  |  | TableTemplate


TableTemplate Constructor

TableTemplate Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »TableTemplate()()()()
Members
Icon | Member | Description
 | TableTemplate(Table, TableCopyOptions) |
 | TableTemplate(IntPtr, Boolean) |


TableTemplate Constructor (unmanagedPointer, autoDelete)

TableTemplate Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »TableTemplate(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal TableTemplate(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
TableTemplate(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


TableTemplate Constructor (table, copyOption)

TableTemplate Constructor (table, copyOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »TableTemplate(Table, TableCopyOptions)
Declaration Syntax
C# Visual Basic Visual C++
public TableTemplate(
    Table table,
    TableCopyOptions copyOption
)
Public Sub New ( _
    table As Table, _
    copyOption As TableCopyOptions _
)
public:
TableTemplate(
    Table^ table,
    TableCopyOptions copyOption
)
Parameters
table(Table)
copyOption(TableCopyOptions)


Capture Method (table, copyOption)

Capture Method (table, copyOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »Capture(Table, TableCopyOptions)
Declaration Syntax
C# Visual Basic Visual C++
public void Capture(
    Table table,
    TableCopyOptions copyOption
)
Public Sub Capture ( _
    table As Table, _
    copyOption As TableCopyOptions _
)
public:
void Capture(
    Table^ table,
    TableCopyOptions copyOption
)
Parameters
table(Table)
copyOption(TableCopyOptions)


CreateTable Method (copyOption)

CreateTable Method (copyOption)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »CreateTable(TableCopyOptions)
Declaration Syntax
C# Visual Basic Visual C++
public Table CreateTable(
    TableCopyOptions copyOption
)
Public Function CreateTable ( _
    copyOption As TableCopyOptions _
) As Table
public:
Table^ CreateTable(
    TableCopyOptions copyOption
)
Parameters
copyOption(TableCopyOptions)


TextAlignmentType Enumeration

TextAlignmentType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextAlignmentType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::TextAlignmentType")]
public enum TextAlignmentType
<WrapperAttribute("ZcDbMLeaderStyle::TextAlignmentType")> _
Public Enumeration TextAlignmentType
[WrapperAttribute(L"ZcDbMLeaderStyle::TextAlignmentType")]
public enum class TextAlignmentType
Members
Member | Description
RightAlignment |
CenterAlignment |
LeftAlignment |


TextAngleType Enumeration

TextAngleType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextAngleType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::TextAngleType")]
public enum TextAngleType
<WrapperAttribute("ZcDbMLeaderStyle::TextAngleType")> _
Public Enumeration TextAngleType
[WrapperAttribute(L"ZcDbMLeaderStyle::TextAngleType")]
public enum class TextAngleType
Members
Member | Description
AlwaysRightReadingAngle |
HorizontalAngle |
InsertAngle |


TextAttachmentDirection Enumeration

TextAttachmentDirection Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextAttachmentDirection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::TextAttachmentDirection")]
public enum TextAttachmentDirection
<WrapperAttribute("ZcDbMLeaderStyle::TextAttachmentDirection")> _
Public Enumeration TextAttachmentDirection
[WrapperAttribute(L"ZcDbMLeaderStyle::TextAttachmentDirection")]
public enum class TextAttachmentDirection
Members
Member | Description
AttachmentVertical |
AttachmentHorizontal |


TextAttachmentType Enumeration

TextAttachmentType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextAttachmentType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbMLeaderStyle::TextAttachmentType")]
public enum TextAttachmentType
<WrapperAttribute("ZcDbMLeaderStyle::TextAttachmentType")> _
Public Enumeration TextAttachmentType
[WrapperAttribute(L"ZcDbMLeaderStyle::TextAttachmentType")]
public enum class TextAttachmentType
Members
Member | Description
AttachmentAllLine |
AttachmentBottomOfTop |
AttachmentBottomOfTopLine |
AttachmentBottomLine |
AttachmentBottomOfBottom |
AttachmentMiddleOfBottom |
AttachmentMiddle |
AttachmentMiddleOfTop |
AttachmentTopOfTop |


TextHorizontalMode Enumeration

TextHorizontalMode Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextHorizontalMode
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::TextHorzMode")]
public enum TextHorizontalMode
<WrapperAttribute("ZcDb::TextHorzMode")> _
Public Enumeration TextHorizontalMode
[WrapperAttribute(L"ZcDb::TextHorzMode")]
public enum class TextHorizontalMode
Members
Member | Description
TextFit |
TextMid |
TextAlign |
TextRight |
TextCenter |
TextLeft |


TextStyleTable Class

TextStyleTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbTextStyleTable")]
public sealed class TextStyleTable : SymbolTable
<WrapperAttribute("AcDbTextStyleTable")> _
Public NotInheritable Class TextStyleTable _
    Inherits SymbolTable
[WrapperAttribute(L"AcDbTextStyleTable")]
public ref class TextStyleTable sealed : public SymbolTable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) | (Inherited from SymbolTable.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() | (Inherited from SymbolTable.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) | (Inherited from SymbolTable.)
 | Has(ObjectId) | (Inherited from SymbolTable.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from SymbolTable.)
 | IncludingErased | (Inherited from SymbolTable.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from SymbolTable.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | TextStyleTable


TextStyleTableRecord Class

TextStyleTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbTextStyleTableRecord")]
public class TextStyleTableRecord : SymbolTableRecord
<WrapperAttribute("AcDbTextStyleTableRecord")> _
Public Class TextStyleTableRecord _
    Inherits SymbolTableRecord
[WrapperAttribute(L"AcDbTextStyleTableRecord")]
public ref class TextStyleTableRecord : public SymbolTableRecord
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextStyleTableRecord(IntPtr, Boolean) |
 | TextStyleTableRecord()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BigFontFileName |
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FileName |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FlagBits |
 | Font |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent | (Inherited from SymbolTableRecord.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsResolved | (Inherited from SymbolTableRecord.)
 | IsShapeFile |
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsVertical |
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from SymbolTableRecord.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | ObliquingAngle |
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PriorSize |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | TextSize |
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | XScale |
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | TextStyleTableRecord


TextStyleTableRecord Constructor

TextStyleTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »TextStyleTableRecord()()()()
Members
Icon | Member | Description
 | TextStyleTableRecord(IntPtr, Boolean) |
 | TextStyleTableRecord()()()() |


TextStyleTableRecord Constructor

TextStyleTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »TextStyleTableRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TextStyleTableRecord()
Public Sub New
public:
TextStyleTableRecord()


TextStyleTableRecord Constructor (obj, autoDelete)

TextStyleTableRecord Constructor (obj, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »TextStyleTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal TextStyleTableRecord(
    IntPtr obj,
    bool autoDelete
)
Protected Friend Sub New ( _
    obj As IntPtr, _
    autoDelete As Boolean _
)
protected public:
TextStyleTableRecord(
    IntPtr obj,
    bool autoDelete
)
Parameters
obj(IntPtr)
autoDelete(Boolean)


BigFontFileName Property

BigFontFileName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »BigFontFileName
Declaration Syntax
C# Visual Basic Visual C++
public string BigFontFileName { get; set; }
Public Property BigFontFileName As String
    Get
    Set
public:
property String^ BigFontFileName {
    String^ get ();
    void set (String^ value);
}


FileName Property

FileName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »FileName
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}


FlagBits Property

FlagBits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »FlagBits
Declaration Syntax
C# Visual Basic Visual C++
public byte FlagBits { get; set; }
Public Property FlagBits As Byte
    Get
    Set
public:
property unsigned char FlagBits {
    unsigned char get ();
    void set (unsigned char value);
}


Font Property

Font Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »Font
Declaration Syntax
C# Visual Basic Visual C++
public FontDescriptor Font { get; set; }
Public Property Font As FontDescriptor
    Get
    Set
public:
property FontDescriptor Font {
    FontDescriptor get ();
    void set (FontDescriptor value);
}


IsShapeFile Property

IsShapeFile Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »IsShapeFile
Declaration Syntax
C# Visual Basic Visual C++
public bool IsShapeFile { get; set; }
Public Property IsShapeFile As Boolean
    Get
    Set
public:
property bool IsShapeFile {
    bool get ();
    void set (bool value);
}


IsVertical Property

IsVertical Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »IsVertical
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVertical { get; set; }
Public Property IsVertical As Boolean
    Get
    Set
public:
property bool IsVertical {
    bool get ();
    void set (bool value);
}


ObliquingAngle Property

ObliquingAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »ObliquingAngle
Declaration Syntax
C# Visual Basic Visual C++
public double ObliquingAngle { get; set; }
Public Property ObliquingAngle As Double
    Get
    Set
public:
property double ObliquingAngle {
    double get ();
    void set (double value);
}


PriorSize Property

PriorSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »PriorSize
Declaration Syntax
C# Visual Basic Visual C++
public double PriorSize { get; set; }
Public Property PriorSize As Double
    Get
    Set
public:
property double PriorSize {
    double get ();
    void set (double value);
}


TextSize Property

TextSize Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »TextSize
Declaration Syntax
C# Visual Basic Visual C++
public double TextSize { get; set; }
Public Property TextSize As Double
    Get
    Set
public:
property double TextSize {
    double get ();
    void set (double value);
}


XScale Property

XScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »XScale
Declaration Syntax
C# Visual Basic Visual C++
public double XScale { get; set; }
Public Property XScale As Double
    Get
    Set
public:
property double XScale {
    double get ();
    void set (double value);
}


TextVerticalMode Enumeration

TextVerticalMode Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextVerticalMode
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::TextVertMode")]
public enum TextVerticalMode
<WrapperAttribute("ZcDb::TextVertMode")> _
Public Enumeration TextVerticalMode
[WrapperAttribute(L"ZcDb::TextVertMode")]
public enum class TextVerticalMode
Members
Member | Description
TextTop |
TextVerticalMid |
TextBottom |
TextBase |


TimeZone Enumeration

TimeZone Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TimeZone
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::TimeZone")]
public enum TimeZone
<WrapperAttribute("ZcDb::TimeZone")> _
Public Enumeration TimeZone
[WrapperAttribute(L"ZcDb::TimeZone")]
public enum class TimeZone
Members
Member | Description
Tonga |
Fiji |
Wellington |
Magadan |
Vladivostock |
Hobart |
Brisbane |
Guam |
Sydney |
Darwin |
Adelaide |
Yakutsk |
Seoul |
Tokyo |
Perth |
Irkutsk |
Taipei |
Singapore |
Beijing |
Krasnoyarsk |
Bangkok |
Rangoon |
SriLanka |
Dhaka |
Almaty |
Kathmandu |
Kolkata |
Islamabad |
Ekaterinburg |
Kabul |
Caucasus |
AbuDhabi |
Tehran |
EastAfrica |
Baghdad |
Riyadh |
Moscow |
Jerusalem |
Helsinki |
Harare |
Cairo |
EasternEurope |
Athens |
WestCentralAfrica |
Sarajevo |
Prague |
Paris |
Berlin |
Monrovia |
GMT |
UTC |
CapeVerde |
Azores |
MidAtlantic |
Greenland |
BuenosAires |
Brasilia |
Newfoundland |
Santiago |
Caracas |
AtlanticCanada |
Bogota |
Indiana |
Eastern |
Saskatchewan |
MexicoCity |
CentralAmerica |
Central |
Mazatlan |
Arizona |
Mountain |
Pacific |
Alaska |
Hawaii |
MidwayIsland |
InternationalDateLine |


Trace Class

Trace Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbTrace")]
public class Trace : Entity
<WrapperAttribute("AcDbTrace")> _
Public Class Trace _
    Inherits Entity
[WrapperAttribute(L"AcDbTrace")]
public ref class Trace : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Trace(Point3d, Point3d, Point3d, Point3d) |
 | Trace()()()() |
 | Trace(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAt(Int16) |
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Normal |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPointAt(Int16, Point3d) |
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Trace


Trace Constructor

Trace Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »Trace()()()()
Members
Icon | Member | Description
 | Trace(Point3d, Point3d, Point3d, Point3d) |
 | Trace()()()() |
 | Trace(IntPtr, Boolean) |


Trace Constructor

Trace Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »Trace()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Trace()
Public Sub New
public:
Trace()


Trace Constructor (unmanagedObjPtr, autoDelete)

Trace Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »Trace(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Trace(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Trace(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Trace Constructor (pointer1, pointer2, pointer3, pointer4)

Trace Constructor (pointer1, pointer2, pointer3, pointer4)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »Trace(Point3d, Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Trace(
    Point3d pointer1,
    Point3d pointer2,
    Point3d pointer3,
    Point3d pointer4
)
Public Sub New ( _
    pointer1 As Point3d, _
    pointer2 As Point3d, _
    pointer3 As Point3d, _
    pointer4 As Point3d _
)
public:
Trace(
    Point3d pointer1,
    Point3d pointer2,
    Point3d pointer3,
    Point3d pointer4
)
Parameters
pointer1(Point3d)
pointer2(Point3d)
pointer3(Point3d)
pointer4(Point3d)


GetPointAt Method (index)

GetPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »GetPointAt(Int16)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetPointAt(
    short index
)
Public Function GetPointAt ( _
    index As Short _
) As Point3d
public:
Point3d GetPointAt(
    short index
)
Parameters
index(Int16)


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


SetPointAt Method (index, pointValue)

SetPointAt Method (index, pointValue)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »SetPointAt(Int16, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPointAt(
    short index,
    Point3d pointValue
)
Public Sub SetPointAt ( _
    index As Short, _
    pointValue As Point3d _
)
public:
void SetPointAt(
    short index,
    Point3d pointValue
)
Parameters
index(Int16)
pointValue(Point3d)


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}


Transaction Class

Transaction Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcTransaction")]
public class Transaction : RXObject
<WrapperAttribute("AcTransaction")> _
Public Class Transaction _
    Inherits RXObject
[WrapperAttribute(L"AcTransaction")]
public ref class Transaction : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Transaction(IntPtr, Boolean) |
 | Abort()()()() |
 | AddNewlyCreatedDBObject(DBObject, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | Commit()()()() |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides RXObject.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAllObjects()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObject(ObjectId, OpenMode, Boolean, Boolean) |
 | GetObject(ObjectId, OpenMode, Boolean) |
 | GetObject(ObjectId, OpenMode) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionManager |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Transaction


Transaction Constructor (unmanagedPointer, autoDelete)

Transaction Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »Transaction(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Transaction(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Transaction(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Abort Method

Abort Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »Abort()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Abort()
Public Overridable Sub Abort
public:
virtual void Abort()


AddNewlyCreatedDBObject Method (obj, add)

AddNewlyCreatedDBObject Method (obj, add)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »AddNewlyCreatedDBObject(DBObject, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddNewlyCreatedDBObject(
    DBObject obj,
    bool add
)
Public Overridable Sub AddNewlyCreatedDBObject ( _
    obj As DBObject, _
    add As Boolean _
)
public:
virtual void AddNewlyCreatedDBObject(
    DBObject^ obj,
    bool add
)
Parameters
obj(DBObject)
add(Boolean)


Commit Method

Commit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »Commit()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Commit()
Public Overridable Sub Commit
public:
virtual void Commit()


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


GetAllObjects Method

GetAllObjects Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »GetAllObjects()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DBObjectCollection GetAllObjects()
Public Function GetAllObjects As DBObjectCollection
public:
DBObjectCollection^ GetAllObjects()


GetObject Method

GetObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »GetObject()()()()
Members
Icon | Member | Description
 | GetObject(ObjectId, OpenMode, Boolean, Boolean) |
 | GetObject(ObjectId, OpenMode, Boolean) |
 | GetObject(ObjectId, OpenMode) |


GetObject Method (id, mode)

GetObject Method (id, mode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »GetObject(ObjectId, OpenMode)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObject GetObject(
    ObjectId id,
    OpenMode mode
)
Public Overridable Function GetObject ( _
    id As ObjectId, _
    mode As OpenMode _
) As DBObject
public:
virtual DBObject^ GetObject(
    ObjectId id,
    OpenMode mode
)
Parameters
id(ObjectId)
mode(OpenMode)


GetObject Method (id, mode, openErasedObject)

GetObject Method (id, mode, openErasedObject)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »GetObject(ObjectId, OpenMode, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObject GetObject(
    ObjectId id,
    OpenMode mode,
    bool openErasedObject
)
Public Overridable Function GetObject ( _
    id As ObjectId, _
    mode As OpenMode, _
    openErasedObject As Boolean _
) As DBObject
public:
virtual DBObject^ GetObject(
    ObjectId id,
    OpenMode mode,
    bool openErasedObject
)
Parameters
id(ObjectId)
mode(OpenMode)
openErasedObject(Boolean)


GetObject Method (id, mode, openErasedObject, forceOpenOnLockedLayer)

GetObject Method (id, mode, openErasedObject, forceOpenOnLockedLayer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »GetObject(ObjectId, OpenMode, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObject GetObject(
    ObjectId id,
    OpenMode mode,
    bool openErasedObject,
    bool forceOpenOnLockedLayer
)
Public Overridable Function GetObject ( _
    id As ObjectId, _
    mode As OpenMode, _
    openErasedObject As Boolean, _
    forceOpenOnLockedLayer As Boolean _
) As DBObject
public:
virtual DBObject^ GetObject(
    ObjectId id,
    OpenMode mode,
    bool openErasedObject,
    bool forceOpenOnLockedLayer
)
Parameters
id(ObjectId)
mode(OpenMode)
openErasedObject(Boolean)
forceOpenOnLockedLayer(Boolean)


TransactionManager Property

TransactionManager Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »TransactionManager
Declaration Syntax
C# Visual Basic Visual C++
public virtual TransactionManager TransactionManager { get; }
Public Overridable ReadOnly Property TransactionManager As TransactionManager
    Get
public:
virtual property TransactionManager^ TransactionManager {
    TransactionManager^ get ();
}


TransactionManager Class

TransactionManager Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbTransactionManager")]
public class TransactionManager : RXObject
<WrapperAttribute("AcDbTransactionManager")> _
Public Class TransactionManager _
    Inherits RXObject
[WrapperAttribute(L"AcDbTransactionManager")]
public ref class TransactionManager : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransactionManager(IntPtr, Boolean) |
 | AddNewlyCreatedDBObject(DBObject, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAllObjects()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObject(ObjectId, OpenMode, Boolean, Boolean) |
 | GetObject(ObjectId, OpenMode, Boolean) |
 | GetObject(ObjectId, OpenMode) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfActiveTransactions |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | QueueForGraphicsFlush()()()() |
 | StartTransaction()()()() |
 | TopTransaction |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | TransactionManager
 |  |  |  |  | TransactionManager


TransactionManager Constructor (unmanagedPointer, autoDelete)

TransactionManager Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »TransactionManager(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal TransactionManager(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
TransactionManager(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AddNewlyCreatedDBObject Method (obj, add)

AddNewlyCreatedDBObject Method (obj, add)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »AddNewlyCreatedDBObject(DBObject, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddNewlyCreatedDBObject(
    DBObject obj,
    bool add
)
Public Overridable Sub AddNewlyCreatedDBObject ( _
    obj As DBObject, _
    add As Boolean _
)
public:
virtual void AddNewlyCreatedDBObject(
    DBObject^ obj,
    bool add
)
Parameters
obj(DBObject)
add(Boolean)


GetAllObjects Method

GetAllObjects Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »GetAllObjects()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObjectCollection GetAllObjects()
Public Overridable Function GetAllObjects As DBObjectCollection
public:
virtual DBObjectCollection^ GetAllObjects()


GetObject Method

GetObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »GetObject()()()()
Members
Icon | Member | Description
 | GetObject(ObjectId, OpenMode, Boolean, Boolean) |
 | GetObject(ObjectId, OpenMode, Boolean) |
 | GetObject(ObjectId, OpenMode) |


GetObject Method (id, mode)

GetObject Method (id, mode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »GetObject(ObjectId, OpenMode)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObject GetObject(
    ObjectId id,
    OpenMode mode
)
Public Overridable Function GetObject ( _
    id As ObjectId, _
    mode As OpenMode _
) As DBObject
public:
virtual DBObject^ GetObject(
    ObjectId id,
    OpenMode mode
)
Parameters
id(ObjectId)
mode(OpenMode)


GetObject Method (id, mode, openErasedObject)

GetObject Method (id, mode, openErasedObject)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »GetObject(ObjectId, OpenMode, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObject GetObject(
    ObjectId id,
    OpenMode mode,
    bool openErasedObject
)
Public Overridable Function GetObject ( _
    id As ObjectId, _
    mode As OpenMode, _
    openErasedObject As Boolean _
) As DBObject
public:
virtual DBObject^ GetObject(
    ObjectId id,
    OpenMode mode,
    bool openErasedObject
)
Parameters
id(ObjectId)
mode(OpenMode)
openErasedObject(Boolean)


GetObject Method (id, mode, openErasedObject, forceOpenOnLockedLayer)

GetObject Method (id, mode, openErasedObject, forceOpenOnLockedLayer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »GetObject(ObjectId, OpenMode, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public virtual DBObject GetObject(
    ObjectId id,
    OpenMode mode,
    bool openErasedObject,
    bool forceOpenOnLockedLayer
)
Public Overridable Function GetObject ( _
    id As ObjectId, _
    mode As OpenMode, _
    openErasedObject As Boolean, _
    forceOpenOnLockedLayer As Boolean _
) As DBObject
public:
virtual DBObject^ GetObject(
    ObjectId id,
    OpenMode mode,
    bool openErasedObject,
    bool forceOpenOnLockedLayer
)
Parameters
id(ObjectId)
mode(OpenMode)
openErasedObject(Boolean)
forceOpenOnLockedLayer(Boolean)


NumberOfActiveTransactions Property

NumberOfActiveTransactions Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »NumberOfActiveTransactions
Declaration Syntax
C# Visual Basic Visual C++
public virtual int NumberOfActiveTransactions { get; }
Public Overridable ReadOnly Property NumberOfActiveTransactions As Integer
    Get
public:
virtual property int NumberOfActiveTransactions {
    int get ();
}


QueueForGraphicsFlush Method

QueueForGraphicsFlush Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »QueueForGraphicsFlush()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void QueueForGraphicsFlush()
Public Overridable Sub QueueForGraphicsFlush
public:
virtual void QueueForGraphicsFlush()


StartTransaction Method

StartTransaction Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »StartTransaction()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Transaction StartTransaction()
Public Overridable Function StartTransaction As Transaction
public:
virtual Transaction^ StartTransaction()


TopTransaction Property

TopTransaction Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »TopTransaction
Declaration Syntax
C# Visual Basic Visual C++
public virtual Transaction TopTransaction { get; }
Public Overridable ReadOnly Property TopTransaction As Transaction
    Get
public:
virtual property Transaction^ TopTransaction {
    Transaction^ get ();
}


TypedValue Structure

TypedValue Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue
Declaration Syntax
C# Visual Basic Visual C++
public struct TypedValue
Public Structure TypedValue
public value class TypedValue
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TypedValue(Int32) |
 | TypedValue(Int32, Object) |
 | Equality(TypedValue, TypedValue) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(TypedValue, TypedValue) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | ToString(IFormatProvider) |
 | TypeCode |
 | Value |


TypedValue Constructor

TypedValue Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »TypedValue()()()()
Members
Icon | Member | Description
 | TypedValue(Int32) |
 | TypedValue(Int32, Object) |


TypedValue Constructor (typeCode)

TypedValue Constructor (typeCode)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »TypedValue(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TypedValue(
    int typeCode
)
Public Sub New ( _
    typeCode As Integer _
)
public:
TypedValue(
    int typeCode
)
Parameters
typeCode(Int32)


TypedValue Constructor (typeCode, value)

TypedValue Constructor (typeCode, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »TypedValue(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
public TypedValue(
    int typeCode,
    Object value
)
Public Sub New ( _
    typeCode As Integer, _
    value As Object _
)
public:
TypedValue(
    int typeCode,
    Object^ value
)
Parameters
typeCode(Int32)
value(Object)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »Equality(TypedValue, TypedValue)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    TypedValue a,
    TypedValue b
)
Public Shared Operator = ( _
    a As TypedValue, _
    b As TypedValue _
) As Boolean
public:
static bool operator ==(
    TypedValue a,
    TypedValue b
)
Parameters
a(TypedValue)
b(TypedValue)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »Inequality(TypedValue, TypedValue)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    TypedValue a,
    TypedValue b
)
Public Shared Operator <> ( _
    a As TypedValue, _
    b As TypedValue _
) As Boolean
public:
static bool operator !=(
    TypedValue a,
    TypedValue b
)
Parameters
a(TypedValue)
b(TypedValue)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »ToString()()()()
Members
Icon | Member | Description
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | ToString(IFormatProvider) |


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


TypeCode Property

TypeCode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »TypeCode
Declaration Syntax
C# Visual Basic Visual C++
public short TypeCode { get; }
Public ReadOnly Property TypeCode As Short
    Get
public:
property short TypeCode {
    short get ();
}


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypedValue »Value
Declaration Syntax
C# Visual Basic Visual C++
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get
public:
property Object^ Value {
    Object^ get ();
}


TypeOfCoordinates Enumeration

TypeOfCoordinates Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TypeOfCoordinates
Declaration Syntax
C# Visual Basic Visual C++
public enum TypeOfCoordinates
Public Enumeration TypeOfCoordinates
public enum class TypeOfCoordinates
Members
Member | Description
CoordinateTypeUnknown |
CoordinateTypeLocal |
CoordinateTypeGrid |
CoordinateTypeGeographic |


UcsTable Class

UcsTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbUcsTable")]
public class UcsTable : SymbolTable
<WrapperAttribute("AcDbUcsTable")> _
Public Class UcsTable _
    Inherits SymbolTable
[WrapperAttribute(L"AcDbUcsTable")]
public ref class UcsTable : public SymbolTable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) | (Inherited from SymbolTable.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() | (Inherited from SymbolTable.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) | (Inherited from SymbolTable.)
 | Has(ObjectId) | (Inherited from SymbolTable.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from SymbolTable.)
 | IncludingErased | (Inherited from SymbolTable.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from SymbolTable.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | UcsTable


UcsTableRecord Class

UcsTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbUcsTableRecord")]
public class UcsTableRecord : SymbolTableRecord
<WrapperAttribute("AcDbUcsTableRecord")> _
Public Class UcsTableRecord _
    Inherits SymbolTableRecord
[WrapperAttribute(L"AcDbUcsTableRecord")]
public ref class UcsTableRecord : public SymbolTableRecord
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UcsTableRecord()()()() |
 | UcsTableRecord(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetUcsBaseOrigin(OrthographicView) |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent | (Inherited from SymbolTableRecord.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsResolved | (Inherited from SymbolTableRecord.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from SymbolTableRecord.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | Origin |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetUcsBaseOrigin(Point3d, OrthographicView) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XAxis |
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | YAxis |
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | UcsTableRecord


UcsTableRecord Constructor

UcsTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »UcsTableRecord()()()()
Members
Icon | Member | Description
 | UcsTableRecord()()()() |
 | UcsTableRecord(IntPtr, Boolean) |


UcsTableRecord Constructor

UcsTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »UcsTableRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UcsTableRecord()
Public Sub New
public:
UcsTableRecord()


UcsTableRecord Constructor (obj, autoDelete)

UcsTableRecord Constructor (obj, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »UcsTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal UcsTableRecord(
    IntPtr obj,
    bool autoDelete
)
Protected Friend Sub New ( _
    obj As IntPtr, _
    autoDelete As Boolean _
)
protected public:
UcsTableRecord(
    IntPtr obj,
    bool autoDelete
)
Parameters
obj(IntPtr)
autoDelete(Boolean)


GetUcsBaseOrigin Method (view)

GetUcsBaseOrigin Method (view)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »GetUcsBaseOrigin(OrthographicView)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetUcsBaseOrigin(
    OrthographicView view
)
Public Function GetUcsBaseOrigin ( _
    view As OrthographicView _
) As Point3d
public:
Point3d GetUcsBaseOrigin(
    OrthographicView view
)
Parameters
view(OrthographicView)


Origin Property

Origin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »Origin
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Origin { get; set; }
Public Property Origin As Point3d
    Get
    Set
public:
property Point3d Origin {
    Point3d get ();
    void set (Point3d value);
}


SetUcsBaseOrigin Method (origin, view)

SetUcsBaseOrigin Method (origin, view)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »SetUcsBaseOrigin(Point3d, OrthographicView)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUcsBaseOrigin(
    Point3d origin,
    OrthographicView view
)
Public Sub SetUcsBaseOrigin ( _
    origin As Point3d, _
    view As OrthographicView _
)
public:
void SetUcsBaseOrigin(
    Point3d origin,
    OrthographicView view
)
Parameters
origin(Point3d)
view(OrthographicView)


XAxis Property

XAxis Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »XAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d XAxis { get; set; }
Public Property XAxis As Vector3d
    Get
    Set
public:
property Vector3d XAxis {
    Vector3d get ();
    void set (Vector3d value);
}


YAxis Property

YAxis Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »YAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d YAxis { get; set; }
Public Property YAxis As Vector3d
    Get
    Set
public:
property Vector3d YAxis {
    Vector3d get ();
    void set (Vector3d value);
}


UnderlayDefinition Class

UnderlayDefinition Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbUnderlayDefinition")]
public abstract class UnderlayDefinition : DBObject
<WrapperAttribute("AcDbUnderlayDefinition")> _
Public MustInherit Class UnderlayDefinition _
    Inherits DBObject
[WrapperAttribute(L"AcDbUnderlayDefinition")]
public ref class UnderlayDefinition abstract : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnderlayDefinition(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetDictionaryKey(Type) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Load(String) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetUnderlayItem(String, String, UnderlayItem) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UnderlayItem |
 | UndoFiler | (Inherited from DBObject.)
 | Unload()()()() |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | UnderlayDefinition
 |  |  |  |  |  |  | DgnDefinition
 |  |  |  |  |  |  | DwfDefinition


UnderlayDefinition Constructor (unmanagedObjPtr, autoDelete)

UnderlayDefinition Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »UnderlayDefinition(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal UnderlayDefinition(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
UnderlayDefinition(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


GetDictionaryKey Method (underlayDefinitionType)

GetDictionaryKey Method (underlayDefinitionType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »GetDictionaryKey(Type)
Declaration Syntax
C# Visual Basic Visual C++
public static string GetDictionaryKey(
    Type underlayDefinitionType
)
Public Shared Function GetDictionaryKey ( _
    underlayDefinitionType As Type _
) As String
public:
static String^ GetDictionaryKey(
    Type^ underlayDefinitionType
)
Parameters
underlayDefinitionType(Type)


Load Method (password)

Load Method (password)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »Load(String)
Declaration Syntax
C# Visual Basic Visual C++
public void Load(
    string password
)
Public Sub Load ( _
    password As String _
)
public:
void Load(
    String^ password
)
Parameters
password(String)


SetUnderlayItem Method (sourceFileName, activeFileName, item)

SetUnderlayItem Method (sourceFileName, activeFileName, item)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »SetUnderlayItem(String, String, UnderlayItem)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUnderlayItem(
    string sourceFileName,
    string activeFileName,
    UnderlayItem item
)
Public Sub SetUnderlayItem ( _
    sourceFileName As String, _
    activeFileName As String, _
    item As UnderlayItem _
)
public:
void SetUnderlayItem(
    String^ sourceFileName,
    String^ activeFileName,
    UnderlayItem^ item
)
Parameters
sourceFileName(String)
activeFileName(String)
item(UnderlayItem)


UnderlayItem Property

UnderlayItem Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »UnderlayItem
Declaration Syntax
C# Visual Basic Visual C++
public UnderlayItem UnderlayItem { get; }
Public ReadOnly Property UnderlayItem As UnderlayItem
    Get
public:
property UnderlayItem^ UnderlayItem {
    UnderlayItem^ get ();
}


Unload Method

Unload Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »Unload()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Unload()
Public Sub Unload
public:
void Unload()


UnderlayFile Class

UnderlayFile Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayFile
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbUnderlayFile")]
public sealed class UnderlayFile : DisposableWrapper
<WrapperAttribute("ZcDbUnderlayFile")> _
Public NotInheritable Class UnderlayFile _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcDbUnderlayFile")]
public ref class UnderlayFile sealed : public DisposableWrapper
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Items |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | UnderlayFile


Items Property

Items Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayFile »Items
Declaration Syntax
C# Visual Basic Visual C++
public UnderlayItemCollection Items { get; }
Public ReadOnly Property Items As UnderlayItemCollection
    Get
public:
property UnderlayItemCollection^ Items {
    UnderlayItemCollection^ get ();
}


UnderlayHost Class

UnderlayHost Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayHost
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbUnderlayHostPE")]
public class UnderlayHost : RXObject
<WrapperAttribute("ZcDbUnderlayHostPE")> _
Public Class UnderlayHost _
    Inherits RXObject
[WrapperAttribute(L"ZcDbUnderlayHostPE")]
public ref class UnderlayHost : public RXObject
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetFile(String, String) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | UnderlayHost


GetFile Method (path, password)

GetFile Method (path, password)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayHost »GetFile(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public UnderlayFile GetFile(
    string path,
    string password
)
Public Function GetFile ( _
    path As String, _
    password As String _
) As UnderlayFile
public:
UnderlayFile^ GetFile(
    String^ path,
    String^ password
)
Parameters
path(String)
password(String)


UnderlayItem Class

UnderlayItem Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItem
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbUnderlayItem")]
public class UnderlayItem : DisposableWrapper
<WrapperAttribute("ZcDbUnderlayItem")> _
Public Class UnderlayItem _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcDbUnderlayItem")]
public ref class UnderlayItem : public DisposableWrapper
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Extents |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | Thumbnail |
 | ToString()()()() | (Inherited from Object.)
 | Units |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UsingPartialContent |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | UnderlayItem
 |  |  |  | DgnUnderlayItem


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItem »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


Extents Property

Extents Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItem »Extents
Declaration Syntax
C# Visual Basic Visual C++
public Extents2d Extents { get; }
Public ReadOnly Property Extents As Extents2d
    Get
public:
property Extents2d Extents {
    Extents2d get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItem »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


Thumbnail Property

Thumbnail Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItem »Thumbnail
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap Thumbnail { get; }
Public ReadOnly Property Thumbnail As Bitmap
    Get
public:
property Bitmap^ Thumbnail {
    Bitmap^ get ();
}


Units Property

Units Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItem »Units
Declaration Syntax
C# Visual Basic Visual C++
public UnitsValue Units { get; }
Public ReadOnly Property Units As UnitsValue
    Get
public:
property UnitsValue Units {
    UnitsValue get ();
}


UsingPartialContent Property

UsingPartialContent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItem »UsingPartialContent
Declaration Syntax
C# Visual Basic Visual C++
public bool UsingPartialContent { get; }
Public ReadOnly Property UsingPartialContent As Boolean
    Get
public:
property bool UsingPartialContent {
    bool get ();
}


UnderlayItemCollection Class

UnderlayItemCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItemCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class UnderlayItemCollection : ICollection
Public NotInheritable Class UnderlayItemCollection _
    Implements ICollection
public ref class UnderlayItemCollection sealed : ICollection
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CopyTo(array<UnderlayItem>[]()[][], Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
UnderlayItemCollection


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItemCollection »CopyTo(array<UnderlayItem>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    UnderlayItem[] arr,
    int index
)
Public Sub CopyTo ( _
    arr As UnderlayItem(), _
    index As Integer _
)
public:
void CopyTo(
    array<UnderlayItem^>^ arr,
    int index
)
Parameters
arr(array< UnderlayItem >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItemCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItemCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (array, index)

ICollectionCopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItemCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollectionCopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItemCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItemCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public UnderlayItem this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As UnderlayItem
    Get
public:
property UnderlayItem^ default[int index] {
    UnderlayItem^ get (int index);
}
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItemCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


UnderlayLayer Class

UnderlayLayer Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayer
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdUnderlayLayer")]
public class UnderlayLayer : DisposableWrapper
<WrapperAttribute("OdUnderlayLayer")> _
Public Class UnderlayLayer _
    Inherits DisposableWrapper
[WrapperAttribute(L"OdUnderlayLayer")]
public ref class UnderlayLayer : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnderlayLayer()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | UnderlayLayer


UnderlayLayer Constructor

UnderlayLayer Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayer »UnderlayLayer()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnderlayLayer()
Public Sub New
public:
UnderlayLayer()


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayer »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


UnderlayLayerCollection Class

UnderlayLayerCollection Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayerCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class UnderlayLayerCollection : ICollection
Public NotInheritable Class UnderlayLayerCollection _
    Implements ICollection
public ref class UnderlayLayerCollection sealed : ICollection
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CopyTo(array<UnderlayLayer>[]()[][], Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
UnderlayLayerCollection


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayerCollection »CopyTo(array<UnderlayLayer>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    UnderlayLayer[] arr,
    int index
)
Public Sub CopyTo ( _
    arr As UnderlayLayer(), _
    index As Integer _
)
public:
void CopyTo(
    array<UnderlayLayer^>^ arr,
    int index
)
Parameters
arr(array< UnderlayLayer >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayerCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayerCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (arr, index)

ICollectionCopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayerCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array arr,
    int index
)
Private Sub ICollectionCopyTo ( _
    arr As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ arr,
    int index
) sealed = ICollection::CopyTo
Parameters
arr(Array)
index(Int32)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayerCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayerCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public UnderlayLayer this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As UnderlayLayer
    Get
    Set
public:
property UnderlayLayer^ default[int index] {
    UnderlayLayer^ get (int index);
    void set (int index, UnderlayLayer^ value);
}
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayerCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


UnderlayLayerState Enumeration

UnderlayLayerState Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayerState
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdUnderlayLayer::State")]
public enum UnderlayLayerState
<WrapperAttribute("OdUnderlayLayer::State")> _
Public Enumeration UnderlayLayerState
[WrapperAttribute(L"OdUnderlayLayer::State")]
public enum class UnderlayLayerState
Members
Member | Description
Off |
On |


UnderlayReference Class

UnderlayReference Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbUnderlayReference")]
public abstract class UnderlayReference : Entity
<WrapperAttribute("AcDbUnderlayReference")> _
Public MustInherit Class UnderlayReference _
    Inherits Entity
[WrapperAttribute(L"AcDbUnderlayReference")]
public ref class UnderlayReference abstract : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnderlayReference(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | ContrastLowerLimit |
 | ContrastUpperLimit |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DefaultContrast |
 | DefaultFade |
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FadeLowerLimit |
 | FadeUpperLimit |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GenerateClipBoundaryFromPline(ObjectId) |
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClipBoundary()()()() |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height |
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Name |
 | NameOfSheet |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | Path |
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetClipBoundary(array<Point2d>[]()[][]) |
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UnderlayLayerCollection |
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | UnderlayReference
 |  |  |  |  |  |  |  | DgnReference
 |  |  |  |  |  |  |  | DwfReference


UnderlayReference Constructor (unmanagedObjPtr, autoDelete)

UnderlayReference Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »UnderlayReference(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal UnderlayReference(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
UnderlayReference(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


ContrastLowerLimit Property

ContrastLowerLimit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »ContrastLowerLimit
Declaration Syntax
C# Visual Basic Visual C++
public static int ContrastLowerLimit { get; }
Public Shared ReadOnly Property ContrastLowerLimit As Integer
    Get
public:
static property int ContrastLowerLimit {
    int get ();
}


ContrastUpperLimit Property

ContrastUpperLimit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »ContrastUpperLimit
Declaration Syntax
C# Visual Basic Visual C++
public static int ContrastUpperLimit { get; }
Public Shared ReadOnly Property ContrastUpperLimit As Integer
    Get
public:
static property int ContrastUpperLimit {
    int get ();
}


DefaultContrast Property

DefaultContrast Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »DefaultContrast
Declaration Syntax
C# Visual Basic Visual C++
public static int DefaultContrast { get; }
Public Shared ReadOnly Property DefaultContrast As Integer
    Get
public:
static property int DefaultContrast {
    int get ();
}


DefaultFade Property

DefaultFade Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »DefaultFade
Declaration Syntax
C# Visual Basic Visual C++
public static int DefaultFade { get; }
Public Shared ReadOnly Property DefaultFade As Integer
    Get
public:
static property int DefaultFade {
    int get ();
}


FadeLowerLimit Property

FadeLowerLimit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »FadeLowerLimit
Declaration Syntax
C# Visual Basic Visual C++
public static int FadeLowerLimit { get; }
Public Shared ReadOnly Property FadeLowerLimit As Integer
    Get
public:
static property int FadeLowerLimit {
    int get ();
}


FadeUpperLimit Property

FadeUpperLimit Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »FadeUpperLimit
Declaration Syntax
C# Visual Basic Visual C++
public static int FadeUpperLimit { get; }
Public Shared ReadOnly Property FadeUpperLimit As Integer
    Get
public:
static property int FadeUpperLimit {
    int get ();
}


GenerateClipBoundaryFromPline Method (polyId)

GenerateClipBoundaryFromPline Method (polyId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »GenerateClipBoundaryFromPline(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateClipBoundaryFromPline(
    ObjectId polyId
)
Public Sub GenerateClipBoundaryFromPline ( _
    polyId As ObjectId _
)
public:
void GenerateClipBoundaryFromPline(
    ObjectId polyId
)
Parameters
polyId(ObjectId)


GetClipBoundary Method

GetClipBoundary Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »GetClipBoundary()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] GetClipBoundary()
Public Function GetClipBoundary As Point2d()
public:
array<Point2d>^ GetClipBoundary()


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »Height
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Height { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Height As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Height {
    double get ();
    void set (double value);
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NameOfSheet Property

NameOfSheet Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »NameOfSheet
Declaration Syntax
C# Visual Basic Visual C++
public string NameOfSheet { get; set; }
Public Property NameOfSheet As String
    Get
    Set
public:
property String^ NameOfSheet {
    String^ get ();
    void set (String^ value);
}


Path Property

Path Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »Path
Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}


SetClipBoundary Method (points)

SetClipBoundary Method (points)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »SetClipBoundary(array<Point2d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetClipBoundary(
    Point2d[] points
)
Public Sub SetClipBoundary ( _
    points As Point2d() _
)
public:
void SetClipBoundary(
    array<Point2d>^ points
)
Parameters
points(array< Point2d >[]()[][])


UnderlayLayerCollection Property

UnderlayLayerCollection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »UnderlayLayerCollection
Declaration Syntax
C# Visual Basic Visual C++
public UnderlayLayerCollection UnderlayLayerCollection { get; }
Public ReadOnly Property UnderlayLayerCollection As UnderlayLayerCollection
    Get
public:
property UnderlayLayerCollection^ UnderlayLayerCollection {
    UnderlayLayerCollection^ get ();
}


Width Property

Width Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »Width
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Width { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Width As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Width {
    double get ();
    void set (double value);
}


Unit Enumeration

Unit Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Unit
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiRasterImage::Units")]
public enum Unit
<WrapperAttribute("ZcGiRasterImage::Units")> _
Public Enumeration Unit
[WrapperAttribute(L"ZcGiRasterImage::Units")]
public enum class Unit
Members
Member | Description
Yard |
None |
Millimeter |
Mile |
Microinches |
Meter |
Kilometer |
Inch |
GigaMeters |
Foot |
Centimeter |
Parsecs |
Nanometers |
Mils |
Microns |
LightYears |
Hectometers |
Dekameters |
Decimeters |
Astronomical |
Angstroms |


UnitsConverter Class

UnitsConverter Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter
Declaration Syntax
C# Visual Basic Visual C++
public class UnitsConverter : TypeConverter
Public Class UnitsConverter _
    Inherits TypeConverter
public ref class UnitsConverter : public TypeConverter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UnitsConverter()()()() |
 | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter.CanConvertFrom(ITypeDescriptorContext, Type).)
 | CanConvertFrom(Type) | (Inherited from TypeConverter.)
 | CanConvertTo(Type) | (Inherited from TypeConverter.)
 | CanConvertTo(ITypeDescriptorContext, Type) | (Inherited from TypeConverter.)
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
 | ConvertFrom(Object) | (Inherited from TypeConverter.)
 | ConvertFromInvariantString(String) | (Inherited from TypeConverter.)
 | ConvertFromInvariantString(ITypeDescriptorContext, String) | (Inherited from TypeConverter.)
 | ConvertFromString(String) | (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, String) | (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | (Inherited from TypeConverter.)
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) | (Inherited from TypeConverter.)
 | ConvertToInvariantString(Object) | (Inherited from TypeConverter.)
 | ConvertToInvariantString(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | ConvertToString(Object) | (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | (Inherited from TypeConverter.)
 | CreateInstance(IDictionary) | (Inherited from TypeConverter.)
 | CreateInstance(ITypeDescriptorContext, IDictionary) | (Inherited from TypeConverter.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetConversionFactor(UnitsValue, UnitsValue) |
 | GetConvertFromException(Object) | (Inherited from TypeConverter.)
 | GetConvertToException(Object, Type) | (Inherited from TypeConverter.)
 | GetCreateInstanceSupported()()()() | (Inherited from TypeConverter.)
 | GetCreateInstanceSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetProperties(Object) | (Inherited from TypeConverter.)
 | GetProperties(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | (Inherited from TypeConverter.)
 | GetPropertiesSupported()()()() | (Inherited from TypeConverter.)
 | GetPropertiesSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValues()()()() | (Inherited from TypeConverter.)
 | GetStandardValues(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValuesExclusive()()()() | (Inherited from TypeConverter.)
 | GetStandardValuesExclusive(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetStandardValuesSupported()()()() | (Inherited from TypeConverter.)
 | GetStandardValuesSupported(ITypeDescriptorContext) | (Inherited from TypeConverter.)
 | GetType()()()() | (Inherited from Object.)
 | IsValid(Object) | (Inherited from TypeConverter.)
 | IsValid(ITypeDescriptorContext, Object) | (Inherited from TypeConverter.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SortProperties(PropertyDescriptorCollection, array<String>[]()[][]) | (Inherited from TypeConverter.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeConverter
 |  | UnitsConverter


UnitsConverter Constructor

UnitsConverter Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »UnitsConverter()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnitsConverter()
Public Sub New
public:
UnitsConverter()


CanConvertFrom Method (context, sourceType)

CanConvertFrom Method (context, sourceType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »CanConvertFrom(ITypeDescriptorContext, Type)
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override
Parameters
context(ITypeDescriptorContext)
sourceType(Type)


ConvertFrom Method (context, culture, value)

ConvertFrom Method (context, culture, value)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »ConvertFrom(ITypeDescriptorContext, CultureInfo, Object)
Declaration Syntax
C# Visual Basic Visual C++
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override
Parameters
context(ITypeDescriptorContext)
culture(CultureInfo)
value(Object)


ConvertTo Method (context, culture, value, destinationType)

ConvertTo Method (context, culture, value, destinationType)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type)
Declaration Syntax
C# Visual Basic Visual C++
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
Parameters
context(ITypeDescriptorContext)
culture(CultureInfo)
value(Object)
destinationType(Type)


GetConversionFactor Method (from, to)

GetConversionFactor Method (from, to)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »GetConversionFactor(UnitsValue, UnitsValue)
Declaration Syntax
C# Visual Basic Visual C++
public static double GetConversionFactor(
    UnitsValue from,
    UnitsValue to
)
Public Shared Function GetConversionFactor ( _
    from As UnitsValue, _
    to As UnitsValue _
) As Double
public:
static double GetConversionFactor(
    UnitsValue from,
    UnitsValue to
)
Parameters
from(UnitsValue)
to(UnitsValue)


UnitsValue Enumeration

UnitsValue Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsValue
Declaration Syntax
C# Visual Basic Visual C++
public enum UnitsValue
Public Enumeration UnitsValue
public enum class UnitsValue
Members
Member | Description
Parsecs |
LightYears |
Astronomical |
Gigameters |
Hectometers |
Dekameters |
Decimeters |
Microns |
Nanometers |
Angstroms |
Yards |
Mils |
MicroInches |
Kilometers |
Meters |
Centimeters |
Millimeters |
Miles |
Feet |
Inches |
Undefined |


UnitType Enumeration

UnitType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitType
Declaration Syntax
C# Visual Basic Visual C++
public enum UnitType
Public Enumeration UnitType
public enum class UnitType
Members
Member | Description
Area |
Angle |
Currency |
Volume |
Unitless |
Percentage |
Distance |
AngleNotTransformed |


UnitTypeAttribute Class

UnitTypeAttribute Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitTypeAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field|AttributeTargets.Parameter|AttributeTargets.ReturnValue, AllowMultiple = false,
    Inherited = true)]
public sealed class UnitTypeAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.ReturnValue, AllowMultiple := False,  _
    Inherited := True)> _
Public NotInheritable Class UnitTypeAttribute _
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Property|AttributeTargets::Field|AttributeTargets::Parameter|AttributeTargets::ReturnValue, AllowMultiple = false,
    Inherited = true)]
public ref class UnitTypeAttribute sealed : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnitTypeAttribute(UnitType) |
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
 | UnitType |
Inheritance Hierarchy
Object
 | Attribute
 |  | UnitTypeAttribute


UnitTypeAttribute Constructor (flags)

UnitTypeAttribute Constructor (flags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitTypeAttribute »UnitTypeAttribute(UnitType)
Declaration Syntax
C# Visual Basic Visual C++
public UnitTypeAttribute(
    UnitType flags
)
Public Sub New ( _
    flags As UnitType _
)
public:
UnitTypeAttribute(
    UnitType flags
)
Parameters
flags(UnitType)


UnitType Property

UnitType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitTypeAttribute »UnitType
Declaration Syntax
C# Visual Basic Visual C++
public UnitType UnitType { get; }
Public ReadOnly Property UnitType As UnitType
    Get
public:
property UnitType UnitType {
    UnitType get ();
}


UpdateAction Enumeration

UpdateAction Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UpdateAction
Declaration Syntax
C# Visual Basic Visual C++
public enum UpdateAction
Public Enumeration UpdateAction
public enum class UpdateAction
Members
Member | Description
None |
UpdateRequired |
Ignore |


UpdateDirection Enumeration

UpdateDirection Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UpdateDirection
Declaration Syntax
C# Visual Basic Visual C++
public enum UpdateDirection
Public Enumeration UpdateDirection
public enum class UpdateDirection
Members
Member | Description
DataToSource |
SourceToData |


UpdateOption Enumeration

UpdateOption Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UpdateOption
Declaration Syntax
C# Visual Basic Visual C++
public enum UpdateOption
Public Enumeration UpdateOption
public enum class UpdateOption
Members
Member | Description
IncludeXrefs |
ForPreview |
OverwriteFormatModifiedAfterUpdate |
OverwriteContentModifiedAfterUpdate |
ForceFullSourceUpdate |
AllowSourceUpdate |
UpdateColumnWidth |
UpdateRowHeight |
SkipFormat |
None |


Vertex Class

Vertex Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbVertex")]
public class Vertex : Entity
<WrapperAttribute("AcDbVertex")> _
Public Class Vertex _
    Inherits Entity
[WrapperAttribute(L"AcDbVertex")]
public ref class Vertex : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Vertex(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Vertex
 |  |  |  |  |  |  |  | FaceRecord
 |  |  |  |  |  |  |  | PolyFaceMeshVertex
 |  |  |  |  |  |  |  | PolygonMeshVertex
 |  |  |  |  |  |  |  | PolylineVertex3d
 |  |  |  |  |  |  |  | Vertex2d


Vertex Constructor (unmanagedObjPtr, autoDelete)

Vertex Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »Vertex(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Vertex(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Vertex(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Vertex2d Class

Vertex2d Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDb2dVertex")]
public class Vertex2d : Vertex
<WrapperAttribute("AcDb2dVertex")> _
Public Class Vertex2d _
    Inherits Vertex
[WrapperAttribute(L"AcDb2dVertex")]
public ref class Vertex2d : public Vertex
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Vertex2d(Point3d, Double, Double, Double, Double) |
 | Vertex2d()()()() |
 | Vertex2d(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Bulge |
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EndWidth |
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | StartWidth |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Tangent |
 | TangentUsed |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | VertexType |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Vertex
 |  |  |  |  |  |  |  | Vertex2d


Vertex2d Constructor

Vertex2d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Vertex2d()()()()
Members
Icon | Member | Description
 | Vertex2d(Point3d, Double, Double, Double, Double) |
 | Vertex2d()()()() |
 | Vertex2d(IntPtr, Boolean) |


Vertex2d Constructor

Vertex2d Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Vertex2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vertex2d()
Public Sub New
public:
Vertex2d()


Vertex2d Constructor (unmanagedObjPtr, autoDelete)

Vertex2d Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Vertex2d(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Vertex2d(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Vertex2d(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


Vertex2d Constructor (position, bulge, startWidth, endWidth, tangent)

Vertex2d Constructor (position, bulge, startWidth, endWidth, tangent)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Vertex2d(Point3d, Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vertex2d(
    Point3d position,
    double bulge,
    double startWidth,
    double endWidth,
    double tangent
)
Public Sub New ( _
    position As Point3d, _
    bulge As Double, _
    startWidth As Double, _
    endWidth As Double, _
    tangent As Double _
)
public:
Vertex2d(
    Point3d position,
    double bulge,
    double startWidth,
    double endWidth,
    double tangent
)
Parameters
position(Point3d)
bulge(Double)
startWidth(Double)
endWidth(Double)
tangent(Double)


Bulge Property

Bulge Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Bulge
Declaration Syntax
C# Visual Basic Visual C++
public double Bulge { get; set; }
Public Property Bulge As Double
    Get
    Set
public:
property double Bulge {
    double get ();
    void set (double value);
}


EndWidth Property

EndWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »EndWidth
Declaration Syntax
C# Visual Basic Visual C++
public double EndWidth { get; set; }
Public Property EndWidth As Double
    Get
    Set
public:
property double EndWidth {
    double get ();
    void set (double value);
}


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Position
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Position { get; set; }
Public Property Position As Point3d
    Get
    Set
public:
property Point3d Position {
    Point3d get ();
    void set (Point3d value);
}


StartWidth Property

StartWidth Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »StartWidth
Declaration Syntax
C# Visual Basic Visual C++
public double StartWidth { get; set; }
Public Property StartWidth As Double
    Get
    Set
public:
property double StartWidth {
    double get ();
    void set (double value);
}


Tangent Property

Tangent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Tangent
Declaration Syntax
C# Visual Basic Visual C++
public double Tangent { get; set; }
Public Property Tangent As Double
    Get
    Set
public:
property double Tangent {
    double get ();
    void set (double value);
}


TangentUsed Property

TangentUsed Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »TangentUsed
Declaration Syntax
C# Visual Basic Visual C++
public bool TangentUsed { get; set; }
Public Property TangentUsed As Boolean
    Get
    Set
public:
property bool TangentUsed {
    bool get ();
    void set (bool value);
}


VertexType Property

VertexType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »VertexType
Declaration Syntax
C# Visual Basic Visual C++
public Vertex2dType VertexType { get; }
Public ReadOnly Property VertexType As Vertex2dType
    Get
public:
property Vertex2dType VertexType {
    Vertex2dType get ();
}


Vertex2dType Enumeration

Vertex2dType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2dType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::Vertex2dType")]
public enum Vertex2dType
<WrapperAttribute("ZcDb::Vertex2dType")> _
Public Enumeration Vertex2dType
[WrapperAttribute(L"ZcDb::Vertex2dType")]
public enum class Vertex2dType
Members
Member | Description
CurveFitVertex |
SplineFitVertex |
SplineControlVertex |
SimpleVertex |


Vertex3dType Enumeration

Vertex3dType Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex3dType
Declaration Syntax
C# Visual Basic Visual C++
public enum Vertex3dType
Public Enumeration Vertex3dType
public enum class Vertex3dType
Members
Member | Description
FitVertex |
ControlVertex |
SimpleVertex |


Viewport Class

Viewport Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbViewport")]
public class Viewport : Entity
<WrapperAttribute("AcDbViewport")> _
Public Class Viewport _
    Inherits Entity
[WrapperAttribute(L"AcDbViewport")]
public ref class Viewport : public Entity
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Viewport()()()() |
 | Viewport(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | AmbientLightColor |
 | AnnotationScale |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackClipDistance |
 | BackClipOn |
 | Background |
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Brightness |
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | CenterPoint |
 | CircleSides |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Contrast |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CustomScale |
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DefaultLightingOn |
 | DefaultLightingType |
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EffectivePlotStyleSheet |
 | Elevation |
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | FastZoomOn |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | FreezeLayersInViewport(IEnumerator) |
 | FrontClipAtEyeOn |
 | FrontClipDistance |
 | FrontClipOn |
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFrozenLayers()()()() |
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPreviousBackground(DrawableType) |
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetUcs(Point3d, Vector3d, Vector3d) |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | GridAdaptive |
 | GridBoundToLimits |
 | GridFollow |
 | GridIncrement |
 | GridMajor |
 | GridOn |
 | GridSubdivisionRestricted |
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height |
 | HiddenLinesRemoved |
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsLayerFrozenInViewport(ObjectId) |
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | LensLength |
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | LinkedToSheetView |
 | List()()()() | (Inherited from Entity.)
 | Locked |
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | NonRectClipEntityId |
 | NonRectClipOn |
 | Number |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | On |
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PerspectiveOn |
 | PlotAsRaster |
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | PlotStyleSheet |
 | PlotWireframe |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RenderMode |
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPreviousBackground(ObjectId, DrawableType) |
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetShadePlot(ShadePlotType, ObjectId) |
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | SetSun(DBObject) |
 | SetUcs(Point3d, Vector3d, Vector3d) |
 | SetUcs(OrthographicView) |
 | SetUcs(ObjectId) |
 | SetUcsToWorld()()()() |
 | SetViewDirection(OrthographicView) |
 | ShadePlot |
 | ShadePlotId |
 | SnapAngle |
 | SnapBasePoint |
 | SnapIncrement |
 | SnapIsometric |
 | SnapIsoPair |
 | SnapOn |
 | StandardScale |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SunId |
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ThawAllLayersInViewport()()()() |
 | ThawLayersInViewport(IEnumerator) |
 | Thumbnail |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Transparent |
 | TwistAngle |
 | UcsFollowModeOn |
 | UcsIconAtOrigin |
 | UcsIconVisible |
 | UcsName |
 | UcsOrthographic |
 | UcsPerViewport |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpdateDisplay()()()() |
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewCenter |
 | ViewDirection |
 | ViewHeight |
 | ViewOrthographic |
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | ViewTarget |
 | Visible | (Inherited from Entity.)
 | VisualStyleId |
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width |
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Viewport


Viewport Constructor

Viewport Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Viewport()()()()
Members
Icon | Member | Description
 | Viewport()()()() |
 | Viewport(IntPtr, Boolean) |


Viewport Constructor

Viewport Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Viewport()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Viewport()
Public Sub New
public:
Viewport()


Viewport Constructor (unmanagedPointer, autoDelete)

Viewport Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Viewport(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Viewport(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Viewport(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AmbientLightColor Property

AmbientLightColor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »AmbientLightColor
Declaration Syntax
C# Visual Basic Visual C++
public Color AmbientLightColor { get; set; }
Public Property AmbientLightColor As Color
    Get
    Set
public:
property Color^ AmbientLightColor {
    Color^ get ();
    void set (Color^ value);
}


AnnotationScale Property

AnnotationScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »AnnotationScale
Declaration Syntax
C# Visual Basic Visual C++
public AnnotationScale AnnotationScale { get; set; }
Public Property AnnotationScale As AnnotationScale
    Get
    Set
public:
property AnnotationScale^ AnnotationScale {
    AnnotationScale^ get ();
    void set (AnnotationScale^ value);
}


BackClipDistance Property

BackClipDistance Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »BackClipDistance
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double BackClipDistance { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property BackClipDistance As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double BackClipDistance {
    double get ();
    void set (double value);
}


BackClipOn Property

BackClipOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »BackClipOn
Declaration Syntax
C# Visual Basic Visual C++
public bool BackClipOn { get; set; }
Public Property BackClipOn As Boolean
    Get
    Set
public:
property bool BackClipOn {
    bool get ();
    void set (bool value);
}


Background Property

Background Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Background
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Background { get; set; }
Public Property Background As ObjectId
    Get
    Set
public:
property ObjectId Background {
    ObjectId get ();
    void set (ObjectId value);
}


Brightness Property

Brightness Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Brightness
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double Brightness { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property Brightness As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double Brightness {
    double get ();
    void set (double value);
}


CenterPoint Property

CenterPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »CenterPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d CenterPoint { get; set; }
Public Property CenterPoint As Point3d
    Get
    Set
public:
property Point3d CenterPoint {
    Point3d get ();
    void set (Point3d value);
}


CircleSides Property

CircleSides Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »CircleSides
Declaration Syntax
C# Visual Basic Visual C++
public int CircleSides { get; set; }
Public Property CircleSides As Integer
    Get
    Set
public:
property int CircleSides {
    int get ();
    void set (int value);
}


Contrast Property

Contrast Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Contrast
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double Contrast { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property Contrast As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double Contrast {
    double get ();
    void set (double value);
}


CustomScale Property

CustomScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »CustomScale
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Unitless)]
public double CustomScale { get; set; }
<UnitTypeAttribute(UnitType.Unitless)> _
Public Property CustomScale As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Unitless)]
public:
property double CustomScale {
    double get ();
    void set (double value);
}


DefaultLightingOn Property

DefaultLightingOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »DefaultLightingOn
Declaration Syntax
C# Visual Basic Visual C++
public bool DefaultLightingOn { get; set; }
Public Property DefaultLightingOn As Boolean
    Get
    Set
public:
property bool DefaultLightingOn {
    bool get ();
    void set (bool value);
}


DefaultLightingType Property

DefaultLightingType Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »DefaultLightingType
Declaration Syntax
C# Visual Basic Visual C++
public DefaultLightingType DefaultLightingType { get; set; }
Public Property DefaultLightingType As DefaultLightingType
    Get
    Set
public:
property DefaultLightingType DefaultLightingType {
    DefaultLightingType get ();
    void set (DefaultLightingType value);
}


EffectivePlotStyleSheet Property

EffectivePlotStyleSheet Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »EffectivePlotStyleSheet
Declaration Syntax
C# Visual Basic Visual C++
public string EffectivePlotStyleSheet { get; }
Public ReadOnly Property EffectivePlotStyleSheet As String
    Get
public:
property String^ EffectivePlotStyleSheet {
    String^ get ();
}


Elevation Property

Elevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Elevation
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Elevation { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Elevation As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Elevation {
    double get ();
    void set (double value);
}


FastZoomOn Property

FastZoomOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »FastZoomOn
Declaration Syntax
C# Visual Basic Visual C++
public bool FastZoomOn { get; set; }
Public Property FastZoomOn As Boolean
    Get
    Set
public:
property bool FastZoomOn {
    bool get ();
    void set (bool value);
}


FreezeLayersInViewport Method (layerIds)

FreezeLayersInViewport Method (layerIds)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »FreezeLayersInViewport(IEnumerator)
Declaration Syntax
C# Visual Basic Visual C++
public void FreezeLayersInViewport(
    IEnumerator layerIds
)
Public Sub FreezeLayersInViewport ( _
    layerIds As IEnumerator _
)
public:
void FreezeLayersInViewport(
    IEnumerator^ layerIds
)
Parameters
layerIds(IEnumerator)


FrontClipAtEyeOn Property

FrontClipAtEyeOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »FrontClipAtEyeOn
Declaration Syntax
C# Visual Basic Visual C++
public bool FrontClipAtEyeOn { get; set; }
Public Property FrontClipAtEyeOn As Boolean
    Get
    Set
public:
property bool FrontClipAtEyeOn {
    bool get ();
    void set (bool value);
}


FrontClipDistance Property

FrontClipDistance Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »FrontClipDistance
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double FrontClipDistance { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property FrontClipDistance As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double FrontClipDistance {
    double get ();
    void set (double value);
}


FrontClipOn Property

FrontClipOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »FrontClipOn
Declaration Syntax
C# Visual Basic Visual C++
public bool FrontClipOn { get; set; }
Public Property FrontClipOn As Boolean
    Get
    Set
public:
property bool FrontClipOn {
    bool get ();
    void set (bool value);
}


GetFrozenLayers Method

GetFrozenLayers Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GetFrozenLayers()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection GetFrozenLayers()
Public Function GetFrozenLayers As ObjectIdCollection
public:
ObjectIdCollection^ GetFrozenLayers()


GetPreviousBackground Method (type)

GetPreviousBackground Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GetPreviousBackground(DrawableType)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetPreviousBackground(
    DrawableType type
)
Public Function GetPreviousBackground ( _
    type As DrawableType _
) As ObjectId
public:
ObjectId GetPreviousBackground(
    DrawableType type
)
Parameters
type(DrawableType)


GetUcs Method (origin, x, y)

GetUcs Method (origin, x, y)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GetUcs(Point3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void GetUcs(
    Point3d origin,
    Vector3d x,
    Vector3d y
)
Public Sub GetUcs ( _
    origin As Point3d, _
    x As Vector3d, _
    y As Vector3d _
)
public:
void GetUcs(
    Point3d origin,
    Vector3d x,
    Vector3d y
)
Parameters
origin(Point3d)
x(Vector3d)
y(Vector3d)


GridAdaptive Property

GridAdaptive Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GridAdaptive
Declaration Syntax
C# Visual Basic Visual C++
public bool GridAdaptive { get; set; }
Public Property GridAdaptive As Boolean
    Get
    Set
public:
property bool GridAdaptive {
    bool get ();
    void set (bool value);
}


GridBoundToLimits Property

GridBoundToLimits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GridBoundToLimits
Declaration Syntax
C# Visual Basic Visual C++
public bool GridBoundToLimits { get; set; }
Public Property GridBoundToLimits As Boolean
    Get
    Set
public:
property bool GridBoundToLimits {
    bool get ();
    void set (bool value);
}


GridFollow Property

GridFollow Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GridFollow
Declaration Syntax
C# Visual Basic Visual C++
public bool GridFollow { get; set; }
Public Property GridFollow As Boolean
    Get
    Set
public:
property bool GridFollow {
    bool get ();
    void set (bool value);
}


GridIncrement Property

GridIncrement Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GridIncrement
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GridIncrement { get; set; }
Public Property GridIncrement As Vector2d
    Get
    Set
public:
property Vector2d GridIncrement {
    Vector2d get ();
    void set (Vector2d value);
}


GridMajor Property

GridMajor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GridMajor
Declaration Syntax
C# Visual Basic Visual C++
public short GridMajor { get; set; }
Public Property GridMajor As Short
    Get
    Set
public:
property short GridMajor {
    short get ();
    void set (short value);
}


GridOn Property

GridOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GridOn
Declaration Syntax
C# Visual Basic Visual C++
public bool GridOn { get; set; }
Public Property GridOn As Boolean
    Get
    Set
public:
property bool GridOn {
    bool get ();
    void set (bool value);
}


GridSubdivisionRestricted Property

GridSubdivisionRestricted Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GridSubdivisionRestricted
Declaration Syntax
C# Visual Basic Visual C++
public bool GridSubdivisionRestricted { get; set; }
Public Property GridSubdivisionRestricted As Boolean
    Get
    Set
public:
property bool GridSubdivisionRestricted {
    bool get ();
    void set (bool value);
}


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Height
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Height { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Height As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Height {
    double get ();
    void set (double value);
}


HiddenLinesRemoved Property

HiddenLinesRemoved Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »HiddenLinesRemoved
Declaration Syntax
C# Visual Basic Visual C++
public bool HiddenLinesRemoved { get; set; }
Public Property HiddenLinesRemoved As Boolean
    Get
    Set
public:
property bool HiddenLinesRemoved {
    bool get ();
    void set (bool value);
}


IsLayerFrozenInViewport Method (layerId)

IsLayerFrozenInViewport Method (layerId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »IsLayerFrozenInViewport(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLayerFrozenInViewport(
    ObjectId layerId
)
Public Function IsLayerFrozenInViewport ( _
    layerId As ObjectId _
) As Boolean
public:
bool IsLayerFrozenInViewport(
    ObjectId layerId
)
Parameters
layerId(ObjectId)


LensLength Property

LensLength Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »LensLength
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double LensLength { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property LensLength As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double LensLength {
    double get ();
    void set (double value);
}


LinkedToSheetView Property

LinkedToSheetView Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »LinkedToSheetView
Declaration Syntax
C# Visual Basic Visual C++
public bool LinkedToSheetView { get; }
Public ReadOnly Property LinkedToSheetView As Boolean
    Get
public:
property bool LinkedToSheetView {
    bool get ();
}


Locked Property

Locked Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Locked
Declaration Syntax
C# Visual Basic Visual C++
public bool Locked { get; set; }
Public Property Locked As Boolean
    Get
    Set
public:
property bool Locked {
    bool get ();
    void set (bool value);
}


NonRectClipEntityId Property

NonRectClipEntityId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »NonRectClipEntityId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId NonRectClipEntityId { get; set; }
Public Property NonRectClipEntityId As ObjectId
    Get
    Set
public:
property ObjectId NonRectClipEntityId {
    ObjectId get ();
    void set (ObjectId value);
}


NonRectClipOn Property

NonRectClipOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »NonRectClipOn
Declaration Syntax
C# Visual Basic Visual C++
public bool NonRectClipOn { get; set; }
Public Property NonRectClipOn As Boolean
    Get
    Set
public:
property bool NonRectClipOn {
    bool get ();
    void set (bool value);
}


Number Property

Number Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Number
Declaration Syntax
C# Visual Basic Visual C++
public int Number { get; }
Public ReadOnly Property Number As Integer
    Get
public:
property int Number {
    int get ();
}


On Property

On Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »On
Declaration Syntax
C# Visual Basic Visual C++
public bool On { get; set; }
Public Property On As Boolean
    Get
    Set
public:
property bool On {
    bool get ();
    void set (bool value);
}


PerspectiveOn Property

PerspectiveOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »PerspectiveOn
Declaration Syntax
C# Visual Basic Visual C++
public bool PerspectiveOn { get; set; }
Public Property PerspectiveOn As Boolean
    Get
    Set
public:
property bool PerspectiveOn {
    bool get ();
    void set (bool value);
}


PlotAsRaster Property

PlotAsRaster Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »PlotAsRaster
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotAsRaster { get; }
Public ReadOnly Property PlotAsRaster As Boolean
    Get
public:
property bool PlotAsRaster {
    bool get ();
}


PlotStyleSheet Property

PlotStyleSheet Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »PlotStyleSheet
Declaration Syntax
C# Visual Basic Visual C++
public string PlotStyleSheet { get; set; }
Public Property PlotStyleSheet As String
    Get
    Set
public:
property String^ PlotStyleSheet {
    String^ get ();
    void set (String^ value);
}


PlotWireframe Property

PlotWireframe Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »PlotWireframe
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotWireframe { get; }
Public ReadOnly Property PlotWireframe As Boolean
    Get
public:
property bool PlotWireframe {
    bool get ();
}


RenderMode Property

RenderMode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »RenderMode
Declaration Syntax
C# Visual Basic Visual C++
public RenderMode RenderMode { get; set; }
Public Property RenderMode As RenderMode
    Get
    Set
public:
property RenderMode RenderMode {
    RenderMode get ();
    void set (RenderMode value);
}


SetPreviousBackground Method (value, type)

SetPreviousBackground Method (value, type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetPreviousBackground(ObjectId, DrawableType)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPreviousBackground(
    ObjectId value,
    DrawableType type
)
Public Sub SetPreviousBackground ( _
    value As ObjectId, _
    type As DrawableType _
)
public:
void SetPreviousBackground(
    ObjectId value,
    DrawableType type
)
Parameters
value(ObjectId)
type(DrawableType)


SetShadePlot Method (type, shadePlotId)

SetShadePlot Method (type, shadePlotId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetShadePlot(ShadePlotType, ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetShadePlot(
    ShadePlotType type,
    ObjectId shadePlotId
)
Public Sub SetShadePlot ( _
    type As ShadePlotType, _
    shadePlotId As ObjectId _
)
public:
void SetShadePlot(
    ShadePlotType type,
    ObjectId shadePlotId
)
Parameters
type(ShadePlotType)
shadePlotId(ObjectId)


SetSun Method (sun)

SetSun Method (sun)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetSun(DBObject)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId SetSun(
    DBObject sun
)
Public Function SetSun ( _
    sun As DBObject _
) As ObjectId
public:
ObjectId SetSun(
    DBObject^ sun
)
Parameters
sun(DBObject)


SetUcs Method

SetUcs Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetUcs()()()()
Members
Icon | Member | Description
 | SetUcs(Point3d, Vector3d, Vector3d) |
 | SetUcs(OrthographicView) |
 | SetUcs(ObjectId) |


SetUcs Method (userCoordinateSystemId)

SetUcs Method (userCoordinateSystemId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetUcs(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUcs(
    ObjectId userCoordinateSystemId
)
Public Sub SetUcs ( _
    userCoordinateSystemId As ObjectId _
)
public:
void SetUcs(
    ObjectId userCoordinateSystemId
)
Parameters
userCoordinateSystemId(ObjectId)


SetUcs Method (view)

SetUcs Method (view)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetUcs(OrthographicView)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUcs(
    OrthographicView view
)
Public Sub SetUcs ( _
    view As OrthographicView _
)
public:
void SetUcs(
    OrthographicView view
)
Parameters
view(OrthographicView)


SetUcs Method (origin, x, y)

SetUcs Method (origin, x, y)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetUcs(Point3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUcs(
    Point3d origin,
    Vector3d x,
    Vector3d y
)
Public Sub SetUcs ( _
    origin As Point3d, _
    x As Vector3d, _
    y As Vector3d _
)
public:
void SetUcs(
    Point3d origin,
    Vector3d x,
    Vector3d y
)
Parameters
origin(Point3d)
x(Vector3d)
y(Vector3d)


SetUcsToWorld Method

SetUcsToWorld Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetUcsToWorld()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetUcsToWorld()
Public Sub SetUcsToWorld
public:
void SetUcsToWorld()


SetViewDirection Method (view)

SetViewDirection Method (view)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetViewDirection(OrthographicView)
Declaration Syntax
C# Visual Basic Visual C++
public void SetViewDirection(
    OrthographicView view
)
Public Sub SetViewDirection ( _
    view As OrthographicView _
)
public:
void SetViewDirection(
    OrthographicView view
)
Parameters
view(OrthographicView)


ShadePlot Property

ShadePlot Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »ShadePlot
Declaration Syntax
C# Visual Basic Visual C++
public ShadePlotType ShadePlot { get; set; }
Public Property ShadePlot As ShadePlotType
    Get
    Set
public:
property ShadePlotType ShadePlot {
    ShadePlotType get ();
    void set (ShadePlotType value);
}


ShadePlotId Property

ShadePlotId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »ShadePlotId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ShadePlotId { get; }
Public ReadOnly Property ShadePlotId As ObjectId
    Get
public:
property ObjectId ShadePlotId {
    ObjectId get ();
}


SnapAngle Property

SnapAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SnapAngle
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.AngleNotTransformed)]
public double SnapAngle { get; set; }
<UnitTypeAttribute(UnitType.AngleNotTransformed)> _
Public Property SnapAngle As Double
    Get
    Set
[UnitTypeAttribute(UnitType::AngleNotTransformed)]
public:
property double SnapAngle {
    double get ();
    void set (double value);
}


SnapBasePoint Property

SnapBasePoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SnapBasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d SnapBasePoint { get; set; }
Public Property SnapBasePoint As Point2d
    Get
    Set
public:
property Point2d SnapBasePoint {
    Point2d get ();
    void set (Point2d value);
}


SnapIncrement Property

SnapIncrement Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SnapIncrement
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d SnapIncrement { get; set; }
Public Property SnapIncrement As Vector2d
    Get
    Set
public:
property Vector2d SnapIncrement {
    Vector2d get ();
    void set (Vector2d value);
}


SnapIsometric Property

SnapIsometric Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SnapIsometric
Declaration Syntax
C# Visual Basic Visual C++
public bool SnapIsometric { get; set; }
Public Property SnapIsometric As Boolean
    Get
    Set
public:
property bool SnapIsometric {
    bool get ();
    void set (bool value);
}


SnapIsoPair Property

SnapIsoPair Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SnapIsoPair
Declaration Syntax
C# Visual Basic Visual C++
public int SnapIsoPair { get; set; }
Public Property SnapIsoPair As Integer
    Get
    Set
public:
property int SnapIsoPair {
    int get ();
    void set (int value);
}


SnapOn Property

SnapOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SnapOn
Declaration Syntax
C# Visual Basic Visual C++
public bool SnapOn { get; set; }
Public Property SnapOn As Boolean
    Get
    Set
public:
property bool SnapOn {
    bool get ();
    void set (bool value);
}


StandardScale Property

StandardScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »StandardScale
Declaration Syntax
C# Visual Basic Visual C++
public StandardScaleType StandardScale { get; set; }
Public Property StandardScale As StandardScaleType
    Get
    Set
public:
property StandardScaleType StandardScale {
    StandardScaleType get ();
    void set (StandardScaleType value);
}


SunId Property

SunId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SunId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId SunId { get; }
Public ReadOnly Property SunId As ObjectId
    Get
public:
property ObjectId SunId {
    ObjectId get ();
}


ThawAllLayersInViewport Method

ThawAllLayersInViewport Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »ThawAllLayersInViewport()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ThawAllLayersInViewport()
Public Sub ThawAllLayersInViewport
public:
void ThawAllLayersInViewport()


ThawLayersInViewport Method (layerIds)

ThawLayersInViewport Method (layerIds)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »ThawLayersInViewport(IEnumerator)
Declaration Syntax
C# Visual Basic Visual C++
public void ThawLayersInViewport(
    IEnumerator layerIds
)
Public Sub ThawLayersInViewport ( _
    layerIds As IEnumerator _
)
public:
void ThawLayersInViewport(
    IEnumerator^ layerIds
)
Parameters
layerIds(IEnumerator)


Thumbnail Property

Thumbnail Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Thumbnail
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap Thumbnail { get; set; }
Public Property Thumbnail As Bitmap
    Get
    Set
public:
property Bitmap^ Thumbnail {
    Bitmap^ get ();
    void set (Bitmap^ value);
}


Transparent Property

Transparent Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Transparent
Declaration Syntax
C# Visual Basic Visual C++
public bool Transparent { get; set; }
Public Property Transparent As Boolean
    Get
    Set
public:
property bool Transparent {
    bool get ();
    void set (bool value);
}


TwistAngle Property

TwistAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »TwistAngle
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.AngleNotTransformed)]
public double TwistAngle { get; set; }
<UnitTypeAttribute(UnitType.AngleNotTransformed)> _
Public Property TwistAngle As Double
    Get
    Set
[UnitTypeAttribute(UnitType::AngleNotTransformed)]
public:
property double TwistAngle {
    double get ();
    void set (double value);
}


UcsFollowModeOn Property

UcsFollowModeOn Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »UcsFollowModeOn
Declaration Syntax
C# Visual Basic Visual C++
public bool UcsFollowModeOn { get; set; }
Public Property UcsFollowModeOn As Boolean
    Get
    Set
public:
property bool UcsFollowModeOn {
    bool get ();
    void set (bool value);
}


UcsIconAtOrigin Property

UcsIconAtOrigin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »UcsIconAtOrigin
Declaration Syntax
C# Visual Basic Visual C++
public bool UcsIconAtOrigin { get; set; }
Public Property UcsIconAtOrigin As Boolean
    Get
    Set
public:
property bool UcsIconAtOrigin {
    bool get ();
    void set (bool value);
}


UcsIconVisible Property

UcsIconVisible Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »UcsIconVisible
Declaration Syntax
C# Visual Basic Visual C++
public bool UcsIconVisible { get; set; }
Public Property UcsIconVisible As Boolean
    Get
    Set
public:
property bool UcsIconVisible {
    bool get ();
    void set (bool value);
}


UcsName Property

UcsName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »UcsName
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId UcsName { get; }
Public ReadOnly Property UcsName As ObjectId
    Get
public:
property ObjectId UcsName {
    ObjectId get ();
}


UcsOrthographic Property

UcsOrthographic Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »UcsOrthographic
Declaration Syntax
C# Visual Basic Visual C++
public OrthographicView UcsOrthographic { get; }
Public ReadOnly Property UcsOrthographic As OrthographicView
    Get
public:
property OrthographicView UcsOrthographic {
    OrthographicView get ();
}


UcsPerViewport Property

UcsPerViewport Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »UcsPerViewport
Declaration Syntax
C# Visual Basic Visual C++
public bool UcsPerViewport { get; set; }
Public Property UcsPerViewport As Boolean
    Get
    Set
public:
property bool UcsPerViewport {
    bool get ();
    void set (bool value);
}


UpdateDisplay Method

UpdateDisplay Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »UpdateDisplay()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateDisplay()
Public Sub UpdateDisplay
public:
void UpdateDisplay()


ViewCenter Property

ViewCenter Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »ViewCenter
Declaration Syntax
C# Visual Basic Visual C++
public Point2d ViewCenter { get; set; }
Public Property ViewCenter As Point2d
    Get
    Set
public:
property Point2d ViewCenter {
    Point2d get ();
    void set (Point2d value);
}


ViewDirection Property

ViewDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »ViewDirection
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d ViewDirection { get; set; }
Public Property ViewDirection As Vector3d
    Get
    Set
public:
property Vector3d ViewDirection {
    Vector3d get ();
    void set (Vector3d value);
}


ViewHeight Property

ViewHeight Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »ViewHeight
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double ViewHeight { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property ViewHeight As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double ViewHeight {
    double get ();
    void set (double value);
}


ViewOrthographic Property

ViewOrthographic Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »ViewOrthographic
Declaration Syntax
C# Visual Basic Visual C++
public OrthographicView ViewOrthographic { get; }
Public ReadOnly Property ViewOrthographic As OrthographicView
    Get
public:
property OrthographicView ViewOrthographic {
    OrthographicView get ();
}


ViewTarget Property

ViewTarget Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »ViewTarget
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ViewTarget { get; set; }
Public Property ViewTarget As Point3d
    Get
    Set
public:
property Point3d ViewTarget {
    Point3d get ();
    void set (Point3d value);
}


VisualStyleId Property

VisualStyleId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »VisualStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId VisualStyleId { get; set; }
Public Property VisualStyleId As ObjectId
    Get
    Set
public:
property ObjectId VisualStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


Width Property

Width Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Width
Declaration Syntax
C# Visual Basic Visual C++
[UnitTypeAttribute(UnitType.Distance)]
public double Width { get; set; }
<UnitTypeAttribute(UnitType.Distance)> _
Public Property Width As Double
    Get
    Set
[UnitTypeAttribute(UnitType::Distance)]
public:
property double Width {
    double get ();
    void set (double value);
}


ViewportTable Class

ViewportTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbViewportTable")]
public class ViewportTable : SymbolTable
<WrapperAttribute("AcDbViewportTable")> _
Public Class ViewportTable _
    Inherits SymbolTable
[WrapperAttribute(L"AcDbViewportTable")]
public ref class ViewportTable : public SymbolTable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewportTable(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) | (Inherited from SymbolTable.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() | (Inherited from SymbolTable.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) | (Inherited from SymbolTable.)
 | Has(ObjectId) | (Inherited from SymbolTable.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from SymbolTable.)
 | IncludingErased | (Inherited from SymbolTable.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from SymbolTable.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | ViewportTable


ViewportTable Constructor (unmanagedPointer, autoDelete)

ViewportTable Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTable »ViewportTable(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal ViewportTable(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
ViewportTable(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ViewportTableRecord Class

ViewportTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbViewportTableRecord")]
public class ViewportTableRecord : AbstractViewTableRecord
<WrapperAttribute("AcDbViewportTableRecord")> _
Public Class ViewportTableRecord _
    Inherits AbstractViewTableRecord
[WrapperAttribute(L"AcDbViewportTableRecord")]
public ref class ViewportTableRecord : public AbstractViewTableRecord
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewportTableRecord()()()() |
 | ViewportTableRecord(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AmbientLightColor | (Inherited from AbstractViewTableRecord.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackClipDistance | (Inherited from AbstractViewTableRecord.)
 | BackClipEnabled | (Inherited from AbstractViewTableRecord.)
 | Background | (Inherited from AbstractViewTableRecord.)
 | Bounds | (Inherited from Drawable.)
 | Brightness | (Inherited from AbstractViewTableRecord.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CenterPoint | (Inherited from AbstractViewTableRecord.)
 | CircleSides |
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Contrast | (Inherited from AbstractViewTableRecord.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DefaultLightingOn | (Inherited from AbstractViewTableRecord.)
 | DefaultLightingType | (Inherited from AbstractViewTableRecord.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Elevation | (Inherited from AbstractViewTableRecord.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FastZoomsEnabled |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FrontClipAtEye | (Inherited from AbstractViewTableRecord.)
 | FrontClipDistance | (Inherited from AbstractViewTableRecord.)
 | FrontClipEnabled | (Inherited from AbstractViewTableRecord.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPreviousBackground(DrawableType) |
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | GridAdaptive |
 | GridBoundToLimits |
 | GridEnabled |
 | GridFollow |
 | GridIncrements |
 | GridMajor |
 | GridSubdivisionRestricted |
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height | (Inherited from AbstractViewTableRecord.)
 | IconAtOrigin |
 | IconEnabled |
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent | (Inherited from SymbolTableRecord.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsometricSnapEnabled |
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsResolved | (Inherited from SymbolTableRecord.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | LensLength | (Inherited from AbstractViewTableRecord.)
 | LowerLeftCorner |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from SymbolTableRecord.)
 | Number |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PerspectiveEnabled | (Inherited from AbstractViewTableRecord.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RenderMode | (Inherited from AbstractViewTableRecord.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPreviousBackground(ObjectId, DrawableType) |
 | SetSun(DBObject) | (Inherited from AbstractViewTableRecord.)
 | SetUcs(Point3d, Vector3d, Vector3d) | (Inherited from AbstractViewTableRecord.)
 | SetUcs(OrthographicView) | (Inherited from AbstractViewTableRecord.)
 | SetUcs(ObjectId) | (Inherited from AbstractViewTableRecord.)
 | SetUcsToWorld()()()() | (Inherited from AbstractViewTableRecord.)
 | SetViewDirection(OrthographicView) | (Inherited from AbstractViewTableRecord.)
 | SnapAngle |
 | SnapBase |
 | SnapEnabled |
 | SnapIncrements |
 | SnapPair |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SunId | (Inherited from AbstractViewTableRecord.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Target | (Inherited from AbstractViewTableRecord.)
 | ToString()()()() | (Inherited from Object.)
 | Ucs | (Inherited from AbstractViewTableRecord.)
 | UcsFollowMode |
 | UcsName | (Inherited from AbstractViewTableRecord.)
 | UcsOrthographic | (Inherited from AbstractViewTableRecord.)
 | UcsSavedWithViewport |
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | UpperRightCorner |
 | ViewDirection | (Inherited from AbstractViewTableRecord.)
 | ViewOrthographic | (Inherited from AbstractViewTableRecord.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | ViewTwist | (Inherited from AbstractViewTableRecord.)
 | VisualStyleId | (Inherited from AbstractViewTableRecord.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width | (Inherited from AbstractViewTableRecord.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | AbstractViewTableRecord
 |  |  |  |  |  |  |  | ViewportTableRecord


ViewportTableRecord Constructor

ViewportTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »ViewportTableRecord()()()()
Members
Icon | Member | Description
 | ViewportTableRecord()()()() |
 | ViewportTableRecord(IntPtr, Boolean) |


ViewportTableRecord Constructor

ViewportTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »ViewportTableRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ViewportTableRecord()
Public Sub New
public:
ViewportTableRecord()


ViewportTableRecord Constructor (obj, autoDelete)

ViewportTableRecord Constructor (obj, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »ViewportTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal ViewportTableRecord(
    IntPtr obj,
    bool autoDelete
)
Protected Friend Sub New ( _
    obj As IntPtr, _
    autoDelete As Boolean _
)
protected public:
ViewportTableRecord(
    IntPtr obj,
    bool autoDelete
)
Parameters
obj(IntPtr)
autoDelete(Boolean)


CircleSides Property

CircleSides Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »CircleSides
Declaration Syntax
C# Visual Basic Visual C++
public short CircleSides { get; set; }
Public Property CircleSides As Short
    Get
    Set
public:
property short CircleSides {
    short get ();
    void set (short value);
}


FastZoomsEnabled Property

FastZoomsEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »FastZoomsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool FastZoomsEnabled { get; set; }
Public Property FastZoomsEnabled As Boolean
    Get
    Set
public:
property bool FastZoomsEnabled {
    bool get ();
    void set (bool value);
}


GetPreviousBackground Method (type)

GetPreviousBackground Method (type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »GetPreviousBackground(DrawableType)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId GetPreviousBackground(
    DrawableType type
)
Public Function GetPreviousBackground ( _
    type As DrawableType _
) As ObjectId
public:
ObjectId GetPreviousBackground(
    DrawableType type
)
Parameters
type(DrawableType)


GridAdaptive Property

GridAdaptive Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »GridAdaptive
Declaration Syntax
C# Visual Basic Visual C++
public bool GridAdaptive { get; set; }
Public Property GridAdaptive As Boolean
    Get
    Set
public:
property bool GridAdaptive {
    bool get ();
    void set (bool value);
}


GridBoundToLimits Property

GridBoundToLimits Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »GridBoundToLimits
Declaration Syntax
C# Visual Basic Visual C++
public bool GridBoundToLimits { get; set; }
Public Property GridBoundToLimits As Boolean
    Get
    Set
public:
property bool GridBoundToLimits {
    bool get ();
    void set (bool value);
}


GridEnabled Property

GridEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »GridEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool GridEnabled { get; set; }
Public Property GridEnabled As Boolean
    Get
    Set
public:
property bool GridEnabled {
    bool get ();
    void set (bool value);
}


GridFollow Property

GridFollow Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »GridFollow
Declaration Syntax
C# Visual Basic Visual C++
public bool GridFollow { get; set; }
Public Property GridFollow As Boolean
    Get
    Set
public:
property bool GridFollow {
    bool get ();
    void set (bool value);
}


GridIncrements Property

GridIncrements Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »GridIncrements
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GridIncrements { get; set; }
Public Property GridIncrements As Point2d
    Get
    Set
public:
property Point2d GridIncrements {
    Point2d get ();
    void set (Point2d value);
}


GridMajor Property

GridMajor Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »GridMajor
Declaration Syntax
C# Visual Basic Visual C++
public short GridMajor { get; set; }
Public Property GridMajor As Short
    Get
    Set
public:
property short GridMajor {
    short get ();
    void set (short value);
}


GridSubdivisionRestricted Property

GridSubdivisionRestricted Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »GridSubdivisionRestricted
Declaration Syntax
C# Visual Basic Visual C++
public bool GridSubdivisionRestricted { get; set; }
Public Property GridSubdivisionRestricted As Boolean
    Get
    Set
public:
property bool GridSubdivisionRestricted {
    bool get ();
    void set (bool value);
}


IconAtOrigin Property

IconAtOrigin Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »IconAtOrigin
Declaration Syntax
C# Visual Basic Visual C++
public bool IconAtOrigin { get; set; }
Public Property IconAtOrigin As Boolean
    Get
    Set
public:
property bool IconAtOrigin {
    bool get ();
    void set (bool value);
}


IconEnabled Property

IconEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »IconEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IconEnabled { get; set; }
Public Property IconEnabled As Boolean
    Get
    Set
public:
property bool IconEnabled {
    bool get ();
    void set (bool value);
}


IsometricSnapEnabled Property

IsometricSnapEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »IsometricSnapEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsometricSnapEnabled { get; set; }
Public Property IsometricSnapEnabled As Boolean
    Get
    Set
public:
property bool IsometricSnapEnabled {
    bool get ();
    void set (bool value);
}


LowerLeftCorner Property

LowerLeftCorner Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »LowerLeftCorner
Declaration Syntax
C# Visual Basic Visual C++
public Point2d LowerLeftCorner { get; set; }
Public Property LowerLeftCorner As Point2d
    Get
    Set
public:
property Point2d LowerLeftCorner {
    Point2d get ();
    void set (Point2d value);
}


Number Property

Number Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »Number
Declaration Syntax
C# Visual Basic Visual C++
public int Number { get; }
Public ReadOnly Property Number As Integer
    Get
public:
property int Number {
    int get ();
}


SetPreviousBackground Method (value, type)

SetPreviousBackground Method (value, type)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »SetPreviousBackground(ObjectId, DrawableType)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPreviousBackground(
    ObjectId value,
    DrawableType type
)
Public Sub SetPreviousBackground ( _
    value As ObjectId, _
    type As DrawableType _
)
public:
void SetPreviousBackground(
    ObjectId value,
    DrawableType type
)
Parameters
value(ObjectId)
type(DrawableType)


SnapAngle Property

SnapAngle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »SnapAngle
Declaration Syntax
C# Visual Basic Visual C++
public double SnapAngle { get; set; }
Public Property SnapAngle As Double
    Get
    Set
public:
property double SnapAngle {
    double get ();
    void set (double value);
}


SnapBase Property

SnapBase Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »SnapBase
Declaration Syntax
C# Visual Basic Visual C++
public Point2d SnapBase { get; set; }
Public Property SnapBase As Point2d
    Get
    Set
public:
property Point2d SnapBase {
    Point2d get ();
    void set (Point2d value);
}


SnapEnabled Property

SnapEnabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »SnapEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SnapEnabled { get; set; }
Public Property SnapEnabled As Boolean
    Get
    Set
public:
property bool SnapEnabled {
    bool get ();
    void set (bool value);
}


SnapIncrements Property

SnapIncrements Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »SnapIncrements
Declaration Syntax
C# Visual Basic Visual C++
public Point2d SnapIncrements { get; set; }
Public Property SnapIncrements As Point2d
    Get
    Set
public:
property Point2d SnapIncrements {
    Point2d get ();
    void set (Point2d value);
}


SnapPair Property

SnapPair Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »SnapPair
Declaration Syntax
C# Visual Basic Visual C++
public short SnapPair { get; set; }
Public Property SnapPair As Short
    Get
    Set
public:
property short SnapPair {
    short get ();
    void set (short value);
}


UcsFollowMode Property

UcsFollowMode Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »UcsFollowMode
Declaration Syntax
C# Visual Basic Visual C++
public bool UcsFollowMode { get; set; }
Public Property UcsFollowMode As Boolean
    Get
    Set
public:
property bool UcsFollowMode {
    bool get ();
    void set (bool value);
}


UcsSavedWithViewport Property

UcsSavedWithViewport Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »UcsSavedWithViewport
Declaration Syntax
C# Visual Basic Visual C++
public bool UcsSavedWithViewport { get; set; }
Public Property UcsSavedWithViewport As Boolean
    Get
    Set
public:
property bool UcsSavedWithViewport {
    bool get ();
    void set (bool value);
}


UpperRightCorner Property

UpperRightCorner Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »UpperRightCorner
Declaration Syntax
C# Visual Basic Visual C++
public Point2d UpperRightCorner { get; set; }
Public Property UpperRightCorner As Point2d
    Get
    Set
public:
property Point2d UpperRightCorner {
    Point2d get ();
    void set (Point2d value);
}


ViewTable Class

ViewTable Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbViewTable")]
public class ViewTable : SymbolTable
<WrapperAttribute("AcDbViewTable")> _
Public Class ViewTable _
    Inherits SymbolTable
[WrapperAttribute(L"AcDbViewTable")]
public ref class ViewTable : public SymbolTable
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | Add(SymbolTableRecord) | (Inherited from SymbolTable.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() | (Inherited from SymbolTable.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | Has(String) | (Inherited from SymbolTable.)
 | Has(ObjectId) | (Inherited from SymbolTable.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IEnumerable_GetEnumerator()()()() | (Inherited from SymbolTable.)
 | IncludingErased | (Inherited from SymbolTable.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Item[([( String])]) | (Inherited from SymbolTable.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTable
 |  |  |  |  |  |  | ViewTable


ViewTableRecord Class

ViewTableRecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbViewTableRecord")]
public class ViewTableRecord : AbstractViewTableRecord
<WrapperAttribute("AcDbViewTableRecord")> _
Public Class ViewTableRecord _
    Inherits AbstractViewTableRecord
[WrapperAttribute(L"AcDbViewTableRecord")]
public ref class ViewTableRecord : public AbstractViewTableRecord
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewTableRecord()()()() |
 | ViewTableRecord(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AmbientLightColor | (Inherited from AbstractViewTableRecord.)
 | AnnotationScale |
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackClipDistance | (Inherited from AbstractViewTableRecord.)
 | BackClipEnabled | (Inherited from AbstractViewTableRecord.)
 | Background | (Inherited from AbstractViewTableRecord.)
 | Bounds | (Inherited from Drawable.)
 | Brightness | (Inherited from AbstractViewTableRecord.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CategoryName |
 | CenterPoint | (Inherited from AbstractViewTableRecord.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Contrast | (Inherited from AbstractViewTableRecord.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DefaultLightingOn | (Inherited from AbstractViewTableRecord.)
 | DefaultLightingType | (Inherited from AbstractViewTableRecord.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | DisassociateUcsFromView()()()() |
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Elevation | (Inherited from AbstractViewTableRecord.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FrontClipAtEye | (Inherited from AbstractViewTableRecord.)
 | FrontClipDistance | (Inherited from AbstractViewTableRecord.)
 | FrontClipEnabled | (Inherited from AbstractViewTableRecord.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height | (Inherited from AbstractViewTableRecord.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDependent | (Inherited from SymbolTableRecord.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPaperspaceView |
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsResolved | (Inherited from SymbolTableRecord.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUcsAssociatedToView |
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | LayerState |
 | Layout |
 | LensLength | (Inherited from AbstractViewTableRecord.)
 | LiveSection |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | Name | (Inherited from SymbolTableRecord.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PerspectiveEnabled | (Inherited from AbstractViewTableRecord.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | RenderMode | (Inherited from AbstractViewTableRecord.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetSun(DBObject) | (Inherited from AbstractViewTableRecord.)
 | SetUcs(Point3d, Vector3d, Vector3d) | (Inherited from AbstractViewTableRecord.)
 | SetUcs(OrthographicView) | (Inherited from AbstractViewTableRecord.)
 | SetUcs(ObjectId) | (Inherited from AbstractViewTableRecord.)
 | SetUcsToWorld()()()() | (Inherited from AbstractViewTableRecord.)
 | SetViewDirection(OrthographicView) | (Inherited from AbstractViewTableRecord.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SunId | (Inherited from AbstractViewTableRecord.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | Target | (Inherited from AbstractViewTableRecord.)
 | Thumbnail |
 | ToString()()()() | (Inherited from Object.)
 | Ucs | (Inherited from AbstractViewTableRecord.)
 | UcsName | (Inherited from AbstractViewTableRecord.)
 | UcsOrthographic | (Inherited from AbstractViewTableRecord.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewAssociatedToViewport |
 | ViewDirection | (Inherited from AbstractViewTableRecord.)
 | ViewOrthographic | (Inherited from AbstractViewTableRecord.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | ViewTwist | (Inherited from AbstractViewTableRecord.)
 | VisualStyleId | (Inherited from AbstractViewTableRecord.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width | (Inherited from AbstractViewTableRecord.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | SymbolTableRecord
 |  |  |  |  |  |  | AbstractViewTableRecord
 |  |  |  |  |  |  |  | ViewTableRecord


ViewTableRecord Constructor

ViewTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »ViewTableRecord()()()()
Members
Icon | Member | Description
 | ViewTableRecord()()()() |
 | ViewTableRecord(IntPtr, Boolean) |


ViewTableRecord Constructor

ViewTableRecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »ViewTableRecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ViewTableRecord()
Public Sub New
public:
ViewTableRecord()


ViewTableRecord Constructor (obj, autoDelete)

ViewTableRecord Constructor (obj, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »ViewTableRecord(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal ViewTableRecord(
    IntPtr obj,
    bool autoDelete
)
Protected Friend Sub New ( _
    obj As IntPtr, _
    autoDelete As Boolean _
)
protected public:
ViewTableRecord(
    IntPtr obj,
    bool autoDelete
)
Parameters
obj(IntPtr)
autoDelete(Boolean)


AnnotationScale Property

AnnotationScale Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »AnnotationScale
Declaration Syntax
C# Visual Basic Visual C++
public AnnotationScale AnnotationScale { get; set; }
Public Property AnnotationScale As AnnotationScale
    Get
    Set
public:
property AnnotationScale^ AnnotationScale {
    AnnotationScale^ get ();
    void set (AnnotationScale^ value);
}


CategoryName Property

CategoryName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »CategoryName
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryName { get; set; }
Public Property CategoryName As String
    Get
    Set
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}


DisassociateUcsFromView Method

DisassociateUcsFromView Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »DisassociateUcsFromView()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void DisassociateUcsFromView()
Public Sub DisassociateUcsFromView
public:
void DisassociateUcsFromView()


IsPaperspaceView Property

IsPaperspaceView Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »IsPaperspaceView
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPaperspaceView { get; set; }
Public Property IsPaperspaceView As Boolean
    Get
    Set
public:
property bool IsPaperspaceView {
    bool get ();
    void set (bool value);
}


IsUcsAssociatedToView Property

IsUcsAssociatedToView Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »IsUcsAssociatedToView
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUcsAssociatedToView { get; }
Public ReadOnly Property IsUcsAssociatedToView As Boolean
    Get
public:
property bool IsUcsAssociatedToView {
    bool get ();
}


LayerState Property

LayerState Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »LayerState
Declaration Syntax
C# Visual Basic Visual C++
public string LayerState { get; set; }
Public Property LayerState As String
    Get
    Set
public:
property String^ LayerState {
    String^ get ();
    void set (String^ value);
}


Layout Property

Layout Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »Layout
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Layout { get; set; }
Public Property Layout As ObjectId
    Get
    Set
public:
property ObjectId Layout {
    ObjectId get ();
    void set (ObjectId value);
}


LiveSection Property

LiveSection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »LiveSection
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId LiveSection { get; set; }
Public Property LiveSection As ObjectId
    Get
    Set
public:
property ObjectId LiveSection {
    ObjectId get ();
    void set (ObjectId value);
}


Thumbnail Property

Thumbnail Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »Thumbnail
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap Thumbnail { get; set; }
Public Property Thumbnail As Bitmap
    Get
    Set
public:
property Bitmap^ Thumbnail {
    Bitmap^ get ();
    void set (Bitmap^ value);
}


ViewAssociatedToViewport Property

ViewAssociatedToViewport Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »ViewAssociatedToViewport
Declaration Syntax
C# Visual Basic Visual C++
public bool ViewAssociatedToViewport { get; set; }
Public Property ViewAssociatedToViewport As Boolean
    Get
    Set
public:
property bool ViewAssociatedToViewport {
    bool get ();
    void set (bool value);
}


ViewTableRecordRenderMode Enumeration

ViewTableRecordRenderMode Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecordRenderMode
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDb::RenderMode")]
public enum ViewTableRecordRenderMode
<WrapperAttribute("ZcDb::RenderMode")> _
Public Enumeration ViewTableRecordRenderMode
[WrapperAttribute(L"ZcDb::RenderMode")]
public enum class ViewTableRecordRenderMode
Members
Member | Description
Wireframe |
Optimized2D |
HiddenLine |
GouraudShadedWithWireframe |
GouraudShaded |
FlatShadedWithWireframe |
FlatShaded |


Visibility Enumeration

Visibility Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Visibility
Declaration Syntax
C# Visual Basic Visual C++
public enum Visibility
Public Enumeration Visibility
public enum class Visibility
Members
Member | Description
Invisible |
Visible |


WblockNoticeEventArgs Class

WblockNoticeEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »WblockNoticeEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class WblockNoticeEventArgs : EventArgs
Public NotInheritable Class WblockNoticeEventArgs _
    Inherits EventArgs
public ref class WblockNoticeEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | To |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | WblockNoticeEventArgs


To Property

To Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »WblockNoticeEventArgs »To
Declaration Syntax
C# Visual Basic Visual C++
public Database To { get; }
Public ReadOnly Property To As Database
    Get
public:
property Database^ To {
    Database^ get ();
}


WblockNoticeEventHandler Delegate

WblockNoticeEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »WblockNoticeEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void WblockNoticeEventHandler(
    Object sender,
    WblockNoticeEventArgs e
)
Public Delegate Sub WblockNoticeEventHandler ( _
    sender As Object, _
    e As WblockNoticeEventArgs _
)
public delegate void WblockNoticeEventHandler(
    Object^ sender,
    WblockNoticeEventArgs^ e
)
Parameters
sender(Object)
e(WblockNoticeEventArgs)


Wipeout Class

Wipeout Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbWipeout")]
public class Wipeout : RasterImage
<WrapperAttribute("AcDbWipeout")> _
Public Class Wipeout _
    Inherits RasterImage
[WrapperAttribute(L"AcDbWipeout")]
public ref class Wipeout : public RasterImage
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Wipeout()()()() |
 | Wipeout(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | AssociateRasterDef(RasterImageDef) | (Inherited from RasterImage.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Brightness | (Inherited from RasterImage.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | ClipBoundaryType | (Inherited from RasterImage.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Contrast | (Inherited from RasterImage.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | DisplayOptions | (Inherited from RasterImage.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Fade | (Inherited from RasterImage.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClipBoundary()()()() | (Inherited from RasterImage.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetVertices()()()() | (Inherited from RasterImage.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasFrame |
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Height | (Inherited from RasterImage.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | ImageDefId | (Inherited from RasterImage.)
 | ImageHeight | (Inherited from RasterImage.)
 | ImageSize(Boolean) | (Inherited from RasterImage.)
 | ImageTransparency | (Inherited from RasterImage.)
 | ImageWidth | (Inherited from RasterImage.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsClipped | (Inherited from RasterImage.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsSetDisplayOptions(ImageDisplayOptions) | (Inherited from RasterImage.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | Name | (Inherited from RasterImage.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | Orientation | (Inherited from RasterImage.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | Path | (Inherited from RasterImage.)
 | PixelToModelTransform | (Inherited from RasterImage.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | Position | (Inherited from RasterImage.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ReactorId | (Inherited from RasterImage.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | Rotation | (Inherited from RasterImage.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | Scale | (Inherited from RasterImage.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetClipBoundary(ClipBoundaryType, Point2dCollection) | (Inherited from RasterImage.)
 | SetClipBoundary(Vector2d) | (Inherited from RasterImage.)
 | SetClipBoundaryToWholeImage()()()() | (Inherited from RasterImage.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDisplayOptions(ImageDisplayOptions, Boolean) | (Inherited from RasterImage.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFrom(Point2dCollection, Vector3d) |
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | ShowImage | (Inherited from RasterImage.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Width | (Inherited from RasterImage.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Image
 |  |  |  |  |  |  |  | RasterImage
 |  |  |  |  |  |  |  |  | Wipeout


Wipeout Constructor

Wipeout Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »Wipeout()()()()
Members
Icon | Member | Description
 | Wipeout()()()() |
 | Wipeout(IntPtr, Boolean) |


Wipeout Constructor

Wipeout Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »Wipeout()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Wipeout()
Public Sub New
public:
Wipeout()


Wipeout Constructor (unmanagedObjPtr, autoDelete)

Wipeout Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »Wipeout(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Wipeout(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Wipeout(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


HasFrame Property

HasFrame Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »HasFrame
Declaration Syntax
C# Visual Basic Visual C++
public bool HasFrame { get; set; }
Public Property HasFrame As Boolean
    Get
    Set
public:
property bool HasFrame {
    bool get ();
    void set (bool value);
}


SetFrom Method (points, normal)

SetFrom Method (points, normal)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »SetFrom(Point2dCollection, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFrom(
    Point2dCollection points,
    Vector3d normal
)
Public Sub SetFrom ( _
    points As Point2dCollection, _
    normal As Vector3d _
)
public:
void SetFrom(
    Point2dCollection^ points,
    Vector3d normal
)
Parameters
points(Point2dCollection)
normal(Vector3d)


Xline Class

Xline Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbXline")]
public class Xline : Curve
<WrapperAttribute("AcDbXline")> _
Public Class Xline _
    Inherits Curve
[WrapperAttribute(L"AcDbXline")]
public ref class Xline : public Curve
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Xline()()()() |
 | Xline(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | AddSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | Area | (Inherited from Curve.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BasePoint |
 | BlockId | (Inherited from Entity.)
 | BlockName | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | CastShadows | (Inherited from Entity.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | CloneMeForDragging | (Inherited from Entity.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | Closed | (Inherited from Curve.)
 | CollisionType | (Inherited from Entity.)
 | Color | (Inherited from Entity.)
 | ColorIndex | (Inherited from Entity.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CompoundObjectTransform | (Inherited from Entity.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteSubentityPaths(array<FullSubentityPath>[]()[][]) | (Inherited from Entity.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Draw()()()() | (Inherited from Entity.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Ecs | (Inherited from Entity.)
 | EdgeStyleId | (Inherited from Entity.)
 | EndParam | (Inherited from Curve.)
 | EndPoint | (Inherited from Curve.)
 | EntityColor | (Inherited from Entity.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | Explode(DBObjectCollection) | (Inherited from Entity.)
 | Extend(Boolean, Point3d) | (Inherited from Curve.)
 | Extend(Double) | (Inherited from Curve.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | FaceStyleId | (Inherited from Entity.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | ForceAnnoAllVisible | (Inherited from Entity.)
 | GeometricExtents | (Inherited from Entity.)
 | GeomExtents | (Inherited from Entity.)
 | GetClosestPointTo(Point3d, Vector3d, Boolean) | (Inherited from Curve.)
 | GetClosestPointTo(Point3d, Boolean) | (Inherited from Curve.)
 | GetDistanceAtParameter(Double) | (Inherited from Curve.)
 | GetDistAtPoint(Point3d) | (Inherited from Curve.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetFirstDerivative(Double) | (Inherited from Curve.)
 | GetFirstDerivative(Point3d) | (Inherited from Curve.)
 | GetGeCurve(Tolerance) | (Inherited from Curve.)
 | GetGeCurve()()()() | (Inherited from Curve.)
 | GetGraphicsMarkersAtSubentityPathIntPtr(FullSubentityPath) | (Inherited from Entity.)
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | (Inherited from Entity.)
 | GetGripPointsAtSubentityPath(FullSubentityPath, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | (Inherited from Entity.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | (Inherited from Entity.)
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | (Inherited from Entity.)
 | GetOffsetCurves(Double) | (Inherited from Curve.)
 | GetOffsetCurvesGivenPlaneNormal(Vector3d, Double) | (Inherited from Curve.)
 | GetOrthoProjectedCurve(Plane) | (Inherited from Curve.)
 | GetParameterAtDistance(Double) | (Inherited from Curve.)
 | GetParameterAtPoint(Point3d) | (Inherited from Curve.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetPlane()()()() | (Inherited from Entity.)
 | GetPointAtDist(Double) | (Inherited from Curve.)
 | GetPointAtParameter(Double) | (Inherited from Curve.)
 | GetProjectedCurve(Plane, Vector3d) | (Inherited from Curve.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetSecondDerivative(Double) | (Inherited from Curve.)
 | GetSecondDerivative(Point3d) | (Inherited from Curve.)
 | GetSplitCurves(Point3dCollection) | (Inherited from Curve.)
 | GetSplitCurves(DoubleCollection) | (Inherited from Curve.)
 | GetStretchPoints(Point3dCollection) | (Inherited from Entity.)
 | GetSubentity(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityGeometricExtents(FullSubentityPath) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) | (Inherited from Entity.)
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete. (Inherited from Entity.)
 | GetTransformedCopy(Matrix3d) | (Inherited from Entity.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Highlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Highlight()()()() | (Inherited from Entity.)
 | Hyperlinks | (Inherited from Entity.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. (Inherited from Entity.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsContentSnappable()()()() | (Inherited from Entity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPeriodic | (Inherited from Curve.)
 | IsPersistent | (Inherited from DBObject.)
 | IsPlanar | (Inherited from Entity.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | Layer | (Inherited from Entity.)
 | LayerId | (Inherited from Entity.)
 | Linetype | (Inherited from Entity.)
 | LinetypeId | (Inherited from Entity.)
 | LinetypeScale | (Inherited from Entity.)
 | LineWeight | (Inherited from Entity.)
 | List()()()() | (Inherited from Entity.)
 | Material | (Inherited from Entity.)
 | MaterialId | (Inherited from Entity.)
 | MaterialMapper | (Inherited from Entity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveGripPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | MoveGripPointsAtSubentityPaths(array<FullSubentityPath>[]()[][], array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) | (Inherited from Entity.)
 | MoveStretchPointsAt(IntegerCollection, Vector3d) | (Inherited from Entity.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | PlotStyleName | (Inherited from Entity.)
 | PlotStyleNameId | (Inherited from Entity.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReceiveShadows | (Inherited from Entity.)
 | RecordGraphicsModified(Boolean) | (Inherited from Entity.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | ReverseCurve()()()() | (Inherited from Curve.)
 | SaveAs(WorldDraw, SaveType) | (Inherited from Entity.)
 | SecondPoint |
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetDatabaseDefaults(Database) | (Inherited from Entity.)
 | SetDatabaseDefaults()()()() | (Inherited from Entity.)
 | SetDragStatus(DragStatus) | (Inherited from Entity.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Vector3d) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d, Tolerance) | (Inherited from Curve.)
 | SetFromGeCurve(Curve3d) | (Inherited from Curve.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetGripStatus(GripStatus) | (Inherited from Entity.)
 | SetLayerId(ObjectId, Boolean) | (Inherited from Entity.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPropertiesFrom(Entity) | (Inherited from Entity.)
 | SetSubentityGripStatus(GripStatus, FullSubentityPath) | (Inherited from Entity.)
 | Spline | (Inherited from Curve.)
 | StartParam | (Inherited from Curve.)
 | StartPoint | (Inherited from Curve.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity.)
 | TransformSubentityPathsBy(array<FullSubentityPath>[]()[][], Matrix3d) | (Inherited from Entity.)
 | Transparency | (Inherited from Entity.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | Unhighlight(FullSubentityPath, Boolean) | (Inherited from Entity.)
 | Unhighlight()()()() | (Inherited from Entity.)
 | UnitDir |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | Visible | (Inherited from Entity.)
 | VisualStyleId | (Inherited from Entity.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Entity
 |  |  |  |  |  |  | Curve
 |  |  |  |  |  |  |  | Xline


Xline Constructor

Xline Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »Xline()()()()
Members
Icon | Member | Description
 | Xline()()()() |
 | Xline(IntPtr, Boolean) |


Xline Constructor

Xline Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »Xline()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Xline()
Public Sub New
public:
Xline()


Xline Constructor (unmanagedObjPtr, autoDelete)

Xline Constructor (unmanagedObjPtr, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »Xline(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Xline(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedObjPtr As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Xline(
    IntPtr unmanagedObjPtr,
    bool autoDelete
)
Parameters
unmanagedObjPtr(IntPtr)
autoDelete(Boolean)


BasePoint Property

BasePoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »BasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BasePoint { get; set; }
Public Property BasePoint As Point3d
    Get
    Set
public:
property Point3d BasePoint {
    Point3d get ();
    void set (Point3d value);
}


SecondPoint Property

SecondPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »SecondPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d SecondPoint { get; set; }
Public Property SecondPoint As Point3d
    Get
    Set
public:
property Point3d SecondPoint {
    Point3d get ();
    void set (Point3d value);
}


UnitDir Property

UnitDir Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »UnitDir
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d UnitDir { get; set; }
Public Property UnitDir As Vector3d
    Get
    Set
public:
property Vector3d UnitDir {
    Vector3d get ();
    void set (Vector3d value);
}


Xrecord Class

Xrecord Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbXrecord")]
public sealed class Xrecord : DBObject
<WrapperAttribute("AcDbXrecord")> _
Public NotInheritable Class Xrecord _
    Inherits DBObject
[WrapperAttribute(L"AcDbXrecord")]
public ref class Xrecord sealed : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Xrecord()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Data |
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Overrides DBObject.MergeStyle.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | XlateReferences |
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Xrecord


Xrecord Constructor

Xrecord Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »Xrecord()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Xrecord()
Public Sub New
public:
Xrecord()


Data Property

Data Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »Data
Declaration Syntax
C# Visual Basic Visual C++
public ResultBuffer Data { get; set; }
Public Property Data As ResultBuffer
    Get
    Set
public:
property ResultBuffer^ Data {
    ResultBuffer^ get ();
    void set (ResultBuffer^ value);
}


MergeStyle Property

MergeStyle Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »MergeStyle
Declaration Syntax
C# Visual Basic Visual C++
public override DuplicateRecordCloning MergeStyle { get; set; }
Public Overrides Property MergeStyle As DuplicateRecordCloning
    Get
    Set
public:
virtual property DuplicateRecordCloning MergeStyle {
    DuplicateRecordCloning get () override;
    void set (DuplicateRecordCloning value) override;
}


XlateReferences Property

XlateReferences Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »XlateReferences
Declaration Syntax
C# Visual Basic Visual C++
public bool XlateReferences { get; set; }
Public Property XlateReferences As Boolean
    Get
    Set
public:
property bool XlateReferences {
    bool get ();
    void set (bool value);
}


XrefBeginOperationEventArgs Class

XrefBeginOperationEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefBeginOperationEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class XrefBeginOperationEventArgs : EventArgs
Public NotInheritable Class XrefBeginOperationEventArgs _
    Inherits EventArgs
public ref class XrefBeginOperationEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | FileName |
 | Finalize()()()() | (Inherited from Object.)
 | From |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | XrefBeginOperationEventArgs


FileName Property

FileName Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefBeginOperationEventArgs »FileName
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}


From Property

From Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefBeginOperationEventArgs »From
Declaration Syntax
C# Visual Basic Visual C++
public Database From { get; }
Public ReadOnly Property From As Database
    Get
public:
property Database^ From {
    Database^ get ();
}


XrefBeginOperationEventHandler Delegate

XrefBeginOperationEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefBeginOperationEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void XrefBeginOperationEventHandler(
    Object sender,
    XrefBeginOperationEventArgs e
)
Public Delegate Sub XrefBeginOperationEventHandler ( _
    sender As Object, _
    e As XrefBeginOperationEventArgs _
)
public delegate void XrefBeginOperationEventHandler(
    Object^ sender,
    XrefBeginOperationEventArgs^ e
)
Parameters
sender(Object)
e(XrefBeginOperationEventArgs)


XrefComandeeredEventArgs Class

XrefComandeeredEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefComandeeredEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class XrefComandeeredEventArgs : EventArgs
Public NotInheritable Class XrefComandeeredEventArgs _
    Inherits EventArgs
public ref class XrefComandeeredEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | From |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | XrefComandeeredEventArgs


From Property

From Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefComandeeredEventArgs »From
Declaration Syntax
C# Visual Basic Visual C++
public Database From { get; }
Public ReadOnly Property From As Database
    Get
public:
property Database^ From {
    Database^ get ();
}


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefComandeeredEventArgs »Id
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Id { get; }
Public ReadOnly Property Id As ObjectId
    Get
public:
property ObjectId Id {
    ObjectId get ();
}


XrefComandeeredEventHandler Delegate

XrefComandeeredEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefComandeeredEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void XrefComandeeredEventHandler(
    Object sender,
    XrefComandeeredEventArgs e
)
Public Delegate Sub XrefComandeeredEventHandler ( _
    sender As Object, _
    e As XrefComandeeredEventArgs _
)
public delegate void XrefComandeeredEventHandler(
    Object^ sender,
    XrefComandeeredEventArgs^ e
)
Parameters
sender(Object)
e(XrefComandeeredEventArgs)


XrefGraph Class

XrefGraph Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraph
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbXrefGraph")]
public class XrefGraph : Graph
<WrapperAttribute("ZcDbXrefGraph")> _
Public Class XrefGraph _
    Inherits Graph
[WrapperAttribute(L"ZcDbXrefGraph")]
public ref class XrefGraph : public Graph
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddEdge(GraphNode, GraphNode) | (Inherited from Graph.)
 | AddNode(GraphNode) | (Inherited from Graph.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BreakCycleEdge(GraphNode, GraphNode) | (Inherited from Graph.)
 | ClearAll(Byte) | (Inherited from Graph.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Graph.)
 | DelNode(GraphNode) | (Inherited from Graph.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FindCycles(GraphNode) | (Inherited from Graph.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetOutgoing()()()() | (Inherited from Graph.)
 | GetType()()()() | (Inherited from Object.)
 | GetXrefNode(String) |
 | GetXrefNode(Int32) |
 | GetXrefNode(ObjectId) |
 | GetXrefNode(Database) |
 | HostDrawing |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEmpty | (Inherited from Graph.)
 | MarkUnresolvedTrees()()()() |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Node(Int32) | (Inherited from Graph.)
 | NumNodes | (Inherited from Graph.)
 | Reset()()()() | (Inherited from Graph.)
 | RootNode | (Inherited from Graph.)
 | SetNodeGrowthRate(Int32) | (Inherited from Graph.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Graph
 |  |  |  | XrefGraph


GetXrefNode Method

GetXrefNode Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraph »GetXrefNode()()()()
Members
Icon | Member | Description
 | GetXrefNode(String) |
 | GetXrefNode(Int32) |
 | GetXrefNode(ObjectId) |
 | GetXrefNode(Database) |


GetXrefNode Method (idx)

GetXrefNode Method (idx)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraph »GetXrefNode(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public XrefGraphNode GetXrefNode(
    int idx
)
Public Function GetXrefNode ( _
    idx As Integer _
) As XrefGraphNode
public:
XrefGraphNode^ GetXrefNode(
    int idx
)
Parameters
idx(Int32)


GetXrefNode Method (name)

GetXrefNode Method (name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraph »GetXrefNode(String)
Declaration Syntax
C# Visual Basic Visual C++
public XrefGraphNode GetXrefNode(
    string name
)
Public Function GetXrefNode ( _
    name As String _
) As XrefGraphNode
public:
XrefGraphNode^ GetXrefNode(
    String^ name
)
Parameters
name(String)


GetXrefNode Method (db)

GetXrefNode Method (db)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraph »GetXrefNode(Database)
Declaration Syntax
C# Visual Basic Visual C++
public XrefGraphNode GetXrefNode(
    Database db
)
Public Function GetXrefNode ( _
    db As Database _
) As XrefGraphNode
public:
XrefGraphNode^ GetXrefNode(
    Database^ db
)
Parameters
db(Database)


GetXrefNode Method (btrId)

GetXrefNode Method (btrId)
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraph »GetXrefNode(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public XrefGraphNode GetXrefNode(
    ObjectId btrId
)
Public Function GetXrefNode ( _
    btrId As ObjectId _
) As XrefGraphNode
public:
XrefGraphNode^ GetXrefNode(
    ObjectId btrId
)
Parameters
btrId(ObjectId)


HostDrawing Property

HostDrawing Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraph »HostDrawing
Declaration Syntax
C# Visual Basic Visual C++
public XrefGraphNode HostDrawing { get; }
Public ReadOnly Property HostDrawing As XrefGraphNode
    Get
public:
property XrefGraphNode^ HostDrawing {
    XrefGraphNode^ get ();
}


MarkUnresolvedTrees Method

MarkUnresolvedTrees Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraph »MarkUnresolvedTrees()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MarkUnresolvedTrees()
Public Function MarkUnresolvedTrees As Boolean
public:
bool MarkUnresolvedTrees()


XrefGraphNode Class

XrefGraphNode Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraphNode
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcDbXrefGraphNode")]
public class XrefGraphNode : GraphNode
<WrapperAttribute("ZcDbXrefGraphNode")> _
Public Class XrefGraphNode _
    Inherits GraphNode
[WrapperAttribute(L"ZcDbXrefGraphNode")]
public ref class XrefGraphNode : public GraphNode
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddRefTo(GraphNode) | (Inherited from GraphNode.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BlockTableRecordId |
 | Clear(Byte) | (Inherited from GraphNode.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CycleIn(Int32) | (Inherited from GraphNode.)
 | CycleOut(Int32) | (Inherited from GraphNode.)
 | Data | (Inherited from GraphNode.)
 | Database |
 | DeleteUnmanagedObject()()()() | (Inherited from GraphNode.)
 | DisconnectAll()()()() | (Inherited from GraphNode.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | In(Int32) | (Inherited from GraphNode.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsCycleNode | (Inherited from GraphNode.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsMarkedAs(Int32) | (Inherited from GraphNode.)
 | IsNested |
 | MarkAs(Byte) | (Inherited from GraphNode.)
 | MarkTree(Byte, GraphNodeCollection) | (Inherited from GraphNode.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | NextCycleNode | (Inherited from GraphNode.)
 | NumCycleIn | (Inherited from GraphNode.)
 | NumCycleOut | (Inherited from GraphNode.)
 | NumIn | (Inherited from GraphNode.)
 | NumOut | (Inherited from GraphNode.)
 | Out(Int32) | (Inherited from GraphNode.)
 | Owner | (Inherited from GraphNode.)
 | RemoveRefTo(GraphNode) | (Inherited from GraphNode.)
 | SetEdgeGrowthRate(Int32, Int32) | (Inherited from GraphNode.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | XrefNotificationStatus |
 | XrefStatus |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | GraphNode
 |  |  |  | XrefGraphNode


BlockTableRecordId Property

BlockTableRecordId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraphNode »BlockTableRecordId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BlockTableRecordId { get; }
Public ReadOnly Property BlockTableRecordId As ObjectId
    Get
public:
property ObjectId BlockTableRecordId {
    ObjectId get ();
}


Database Property

Database Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraphNode »Database
Declaration Syntax
C# Visual Basic Visual C++
public Database Database { get; }
Public ReadOnly Property Database As Database
    Get
public:
property Database^ Database {
    Database^ get ();
}


IsNested Property

IsNested Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraphNode »IsNested
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNested { get; }
Public ReadOnly Property IsNested As Boolean
    Get
public:
property bool IsNested {
    bool get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraphNode »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


XrefNotificationStatus Property

XrefNotificationStatus Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraphNode »XrefNotificationStatus
Declaration Syntax
C# Visual Basic Visual C++
public XrefNotificationStatus XrefNotificationStatus { get; }
Public ReadOnly Property XrefNotificationStatus As XrefNotificationStatus
    Get
public:
property XrefNotificationStatus XrefNotificationStatus {
    XrefNotificationStatus get ();
}


XrefStatus Property

XrefStatus Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraphNode »XrefStatus
Declaration Syntax
C# Visual Basic Visual C++
public XrefStatus XrefStatus { get; }
Public ReadOnly Property XrefStatus As XrefStatus
    Get
public:
property XrefStatus XrefStatus {
    XrefStatus get ();
}


XrefNotificationStatus Enumeration

XrefNotificationStatus Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefNotificationStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum XrefNotificationStatus
Public Enumeration XrefNotificationStatus
public enum class XrefNotificationStatus
Members
Member | Description
ResolvedUpdateAvailable |
ResolvedWithUpdate |
ResolvedElsewhere |
ResolvedMatch |
None |


XrefOperation Enumeration

XrefOperation Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefOperation
Declaration Syntax
C# Visual Basic Visual C++
public enum XrefOperation
Public Enumeration XrefOperation
public enum class XrefOperation
Members
Member | Description
XrefXBindOperation |
XrefUnloadOperation |
XrefResolveOperation |
XrefReloadOperation |
XrefPathOperation |
XrefOverlayOperation |
XrefDetachOperation |
XrefBindOperation |
XrefAttachOperation |


XrefPreXrefLockFileEventArgs Class

XrefPreXrefLockFileEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefPreXrefLockFileEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class XrefPreXrefLockFileEventArgs : EventArgs
Public NotInheritable Class XrefPreXrefLockFileEventArgs _
    Inherits EventArgs
public ref class XrefPreXrefLockFileEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | btrId |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | XrefPreXrefLockFileEventArgs


btrId Property

btrId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefPreXrefLockFileEventArgs »btrId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId btrId { get; }
Public ReadOnly Property btrId As ObjectId
    Get
public:
property ObjectId btrId {
    ObjectId get ();
}


XrefPreXrefLockFileEventHandler Delegate

XrefPreXrefLockFileEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefPreXrefLockFileEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void XrefPreXrefLockFileEventHandler(
    Object sender,
    XrefPreXrefLockFileEventArgs e
)
Public Delegate Sub XrefPreXrefLockFileEventHandler ( _
    sender As Object, _
    e As XrefPreXrefLockFileEventArgs _
)
public delegate void XrefPreXrefLockFileEventHandler(
    Object^ sender,
    XrefPreXrefLockFileEventArgs^ e
)
Parameters
sender(Object)
e(XrefPreXrefLockFileEventArgs)


XrefRedirectedEventArgs Class

XrefRedirectedEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefRedirectedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class XrefRedirectedEventArgs : EventArgs
Public NotInheritable Class XrefRedirectedEventArgs _
    Inherits EventArgs
public ref class XrefRedirectedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewId |
 | OldId |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | XrefRedirectedEventArgs


NewId Property

NewId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefRedirectedEventArgs »NewId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId NewId { get; }
Public ReadOnly Property NewId As ObjectId
    Get
public:
property ObjectId NewId {
    ObjectId get ();
}


OldId Property

OldId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefRedirectedEventArgs »OldId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId OldId { get; }
Public ReadOnly Property OldId As ObjectId
    Get
public:
property ObjectId OldId {
    ObjectId get ();
}


XrefRedirectedEventHandler Delegate

XrefRedirectedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefRedirectedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void XrefRedirectedEventHandler(
    Object sender,
    XrefRedirectedEventArgs e
)
Public Delegate Sub XrefRedirectedEventHandler ( _
    sender As Object, _
    e As XrefRedirectedEventArgs _
)
public delegate void XrefRedirectedEventHandler(
    Object^ sender,
    XrefRedirectedEventArgs^ e
)
Parameters
sender(Object)
e(XrefRedirectedEventArgs)


XrefStatus Enumeration

XrefStatus Enumeration
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum XrefStatus
Public Enumeration XrefStatus
public enum class XrefStatus
Members
Member | Description
FileNotFound |
Unresolved |
Unreferenced |
Unloaded |
Resolved |
NotAnXref |


XrefSubCommandAbortedEventHandler Delegate

XrefSubCommandAbortedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefSubCommandAbortedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void XrefSubCommandAbortedEventHandler(
    Object sender,
    XrefSubCommandEventArgs e
)
Public Delegate Sub XrefSubCommandAbortedEventHandler ( _
    sender As Object, _
    e As XrefSubCommandEventArgs _
)
public delegate void XrefSubCommandAbortedEventHandler(
    Object^ sender,
    XrefSubCommandEventArgs^ e
)
Parameters
sender(Object)
e(XrefSubCommandEventArgs)


XrefSubCommandEventArgs Class

XrefSubCommandEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefSubCommandEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class XrefSubCommandEventArgs : EventArgs
Public Class XrefSubCommandEventArgs _
    Inherits EventArgs
public ref class XrefSubCommandEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | btrIds |
 | btrNames |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | paths |
 | ToString()()()() | (Inherited from Object.)
 | xrefOp |
Inheritance Hierarchy
Object
 | EventArgs
 |  | XrefSubCommandEventArgs
 |  |  | XrefVetoableSubCommandEventArgs


btrIds Property

btrIds Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefSubCommandEventArgs »btrIds
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection btrIds { get; }
Public ReadOnly Property btrIds As ObjectIdCollection
    Get
public:
property ObjectIdCollection^ btrIds {
    ObjectIdCollection^ get ();
}


btrNames Property

btrNames Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefSubCommandEventArgs »btrNames
Declaration Syntax
C# Visual Basic Visual C++
public string[] btrNames { get; }
Public ReadOnly Property btrNames As String()
    Get
public:
property array<String^>^ btrNames {
    array<String^>^ get ();
}


paths Property

paths Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefSubCommandEventArgs »paths
Declaration Syntax
C# Visual Basic Visual C++
public string[] paths { get; }
Public ReadOnly Property paths As String()
    Get
public:
property array<String^>^ paths {
    array<String^>^ get ();
}


xrefOp Property

xrefOp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefSubCommandEventArgs »xrefOp
Declaration Syntax
C# Visual Basic Visual C++
public XrefOperation xrefOp { get; }
Public ReadOnly Property xrefOp As XrefOperation
    Get
public:
property XrefOperation xrefOp {
    XrefOperation get ();
}


XrefSubCommandStartEventHandler Delegate

XrefSubCommandStartEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefSubCommandStartEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void XrefSubCommandStartEventHandler(
    Object sender,
    XrefVetoableSubCommandEventArgs e
)
Public Delegate Sub XrefSubCommandStartEventHandler ( _
    sender As Object, _
    e As XrefVetoableSubCommandEventArgs _
)
public delegate void XrefSubCommandStartEventHandler(
    Object^ sender,
    XrefVetoableSubCommandEventArgs^ e
)
Parameters
sender(Object)
e(XrefVetoableSubCommandEventArgs)


XrefVetoableSubCommandEventArgs Class

XrefVetoableSubCommandEventArgs Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefVetoableSubCommandEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class XrefVetoableSubCommandEventArgs : XrefSubCommandEventArgs
Public NotInheritable Class XrefVetoableSubCommandEventArgs _
    Inherits XrefSubCommandEventArgs
public ref class XrefVetoableSubCommandEventArgs sealed : public XrefSubCommandEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | abortOp |
 | btrIds | (Inherited from XrefSubCommandEventArgs.)
 | btrNames | (Inherited from XrefSubCommandEventArgs.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | paths | (Inherited from XrefSubCommandEventArgs.)
 | ToString()()()() | (Inherited from Object.)
 | xrefOp | (Inherited from XrefSubCommandEventArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | XrefSubCommandEventArgs
 |  |  | XrefVetoableSubCommandEventArgs


abortOp Property

abortOp Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefVetoableSubCommandEventArgs »abortOp
Declaration Syntax
C# Visual Basic Visual C++
public bool abortOp { get; set; }
Public Property abortOp As Boolean
    Get
    Set
public:
property bool abortOp {
    bool get ();
    void set (bool value);
}


ZwSoft.ZwCAD.DatabaseServices.Filters Namespace

ZwSoft.ZwCAD.DatabaseServices.Filters Namespace
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.DatabaseServices.Filters
Namespace ZwSoft.ZwCAD.DatabaseServices.Filters
namespace ZwSoft.ZwCAD.DatabaseServices.Filters
Types
All Types Classes Structures
Icon | Type | Description
 | Filter |
 | FilteredBlockIterator |
 | Index |
 | IndexUpdateData |
 | LayerFilter |
 | LayerIndex |
 | SpatialFilter |
 | SpatialFilterDefinition |
 | SpatialFilterVolume |
 | SpatialIndex |


Filter Class

Filter Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Filter
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbFilter")]
public abstract class Filter : DBObject
<WrapperAttribute("AcDbFilter")> _
Public MustInherit Class Filter _
    Inherits DBObject
[WrapperAttribute(L"AcDbFilter")]
public ref class Filter abstract : public DBObject
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Filter(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IndexClass |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Filter
 |  |  |  |  |  |  | LayerFilter
 |  |  |  |  |  |  | SpatialFilter


Filter Constructor (unmanagedPointer, autoDelete)

Filter Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Filter »Filter(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Filter(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Filter(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


IndexClass Property

IndexClass Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Filter »IndexClass
Declaration Syntax
C# Visual Basic Visual C++
public RXClass IndexClass { get; }
Public ReadOnly Property IndexClass As RXClass
    Get
public:
property RXClass^ IndexClass {
    RXClass^ get ();
}


FilteredBlockIterator Class

FilteredBlockIterator Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbFilteredBlockIterator")]
public sealed class FilteredBlockIterator : DisposableWrapper
<WrapperAttribute("AcDbFilteredBlockIterator")> _
Public NotInheritable Class FilteredBlockIterator _
    Inherits DisposableWrapper
[WrapperAttribute(L"AcDbFilteredBlockIterator")]
public ref class FilteredBlockIterator sealed : public DisposableWrapper
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Accepts(ObjectId) |
 | AddToBuffer(ObjectId) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BuffersForComposition |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EstimatedHitFraction |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Next |
 | Seek(ObjectId) |
 | Start()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | FilteredBlockIterator


Accepts Method (id)

Accepts Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator »Accepts(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool Accepts(
    ObjectId id
)
Public Function Accepts ( _
    id As ObjectId _
) As Boolean
public:
bool Accepts(
    ObjectId id
)
Parameters
id(ObjectId)


AddToBuffer Method (id)

AddToBuffer Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator »AddToBuffer(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void AddToBuffer(
    ObjectId id
)
Public Sub AddToBuffer ( _
    id As ObjectId _
)
public:
void AddToBuffer(
    ObjectId id
)
Parameters
id(ObjectId)


BuffersForComposition Property

BuffersForComposition Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator »BuffersForComposition
Declaration Syntax
C# Visual Basic Visual C++
public bool BuffersForComposition { get; }
Public ReadOnly Property BuffersForComposition As Boolean
    Get
public:
property bool BuffersForComposition {
    bool get ();
}


EstimatedHitFraction Property

EstimatedHitFraction Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator »EstimatedHitFraction
Declaration Syntax
C# Visual Basic Visual C++
public double EstimatedHitFraction { get; }
Public ReadOnly Property EstimatedHitFraction As Double
    Get
public:
property double EstimatedHitFraction {
    double get ();
}


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator »Id
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Id { get; }
Public ReadOnly Property Id As ObjectId
    Get
public:
property ObjectId Id {
    ObjectId get ();
}


Next Property

Next Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator »Next
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Next { get; }
Public ReadOnly Property Next As ObjectId
    Get
public:
property ObjectId Next {
    ObjectId get ();
}


Seek Method (id)

Seek Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator »Seek(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Seek(
    ObjectId id
)
Public Sub Seek ( _
    id As ObjectId _
)
public:
void Seek(
    ObjectId id
)
Parameters
id(ObjectId)


Start Method

Start Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator »Start()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Start()
Public Sub Start
public:
void Start()


Index Class

Index Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbIndex")]
public abstract class Index : DBObject
<WrapperAttribute("AcDbIndex")> _
Public MustInherit Class Index _
    Inherits DBObject
[WrapperAttribute(L"AcDbIndex")]
public ref class Index abstract : public DBObject
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetIterator(Filter) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsUptoDate |
 | IsWriteEnabled | (Inherited from DBObject.)
 | LastUpdatedAt |
 | LastUpdatedAtU |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBeingIndexedId |
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | RebuildFull(IndexUpdateData) |
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Index
 |  |  |  |  |  |  | LayerIndex
 |  |  |  |  |  |  | SpatialIndex


GetIterator Method (filter)

GetIterator Method (filter)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »GetIterator(Filter)
Declaration Syntax
C# Visual Basic Visual C++
public virtual FilteredBlockIterator GetIterator(
    Filter filter
)
Public Overridable Function GetIterator ( _
    filter As Filter _
) As FilteredBlockIterator
public:
virtual FilteredBlockIterator^ GetIterator(
    Filter^ filter
)
Parameters
filter(Filter)


IsUptoDate Property

IsUptoDate Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »IsUptoDate
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUptoDate { get; }
Public ReadOnly Property IsUptoDate As Boolean
    Get
public:
property bool IsUptoDate {
    bool get ();
}


LastUpdatedAt Property

LastUpdatedAt Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »LastUpdatedAt
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastUpdatedAt { get; set; }
Public Property LastUpdatedAt As DateTime
    Get
    Set
public:
property DateTime LastUpdatedAt {
    DateTime get ();
    void set (DateTime value);
}


LastUpdatedAtU Property

LastUpdatedAtU Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »LastUpdatedAtU
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastUpdatedAtU { get; set; }
Public Property LastUpdatedAtU As DateTime
    Get
    Set
public:
property DateTime LastUpdatedAtU {
    DateTime get ();
    void set (DateTime value);
}


ObjectBeingIndexedId Property

ObjectBeingIndexedId Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »ObjectBeingIndexedId
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId ObjectBeingIndexedId { get; }
Public Overridable ReadOnly Property ObjectBeingIndexedId As ObjectId
    Get
public:
virtual property ObjectId ObjectBeingIndexedId {
    ObjectId get ();
}


RebuildFull Method (indexData)

RebuildFull Method (indexData)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »RebuildFull(IndexUpdateData)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RebuildFull(
    IndexUpdateData indexData
)
Public Overridable Sub RebuildFull ( _
    indexData As IndexUpdateData _
)
public:
virtual void RebuildFull(
    IndexUpdateData^ indexData
)
Parameters
indexData(IndexUpdateData)


IndexUpdateData Class

IndexUpdateData Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbIndexUpdateData")]
public sealed class IndexUpdateData : DisposableWrapper
<WrapperAttribute("AcDbIndexUpdateData")> _
Public NotInheritable Class IndexUpdateData _
    Inherits DisposableWrapper
[WrapperAttribute(L"AcDbIndexUpdateData")]
public ref class IndexUpdateData sealed : public DisposableWrapper
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddId(ObjectId) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetIdData(ObjectId) | Obsolete.
 | GetIdDataPtr(ObjectId) |
 | GetIdFlags(ObjectId) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetIdData(ObjectId, IntPtr) |
 | SetIdData(ObjectId, Int32) | Obsolete.
 | SetIdFlags(ObjectId, Byte) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | IndexUpdateData


AddId Method (id)

AddId Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData »AddId(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void AddId(
    ObjectId id
)
Public Sub AddId ( _
    id As ObjectId _
)
public:
void AddId(
    ObjectId id
)
Parameters
id(ObjectId)


GetIdData Method (id)

GetIdData Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData »GetIdData(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use System::IntPtr GetIdDataPtr)")]
public long GetIdData(
    ObjectId id
)
<ObsoleteAttribute("Use System::IntPtr GetIdDataPtr)")> _
Public Function GetIdData ( _
    id As ObjectId _
) As Long
[ObsoleteAttribute(L"Use System::IntPtr GetIdDataPtr)")]
public:
long long GetIdData(
    ObjectId id
)
Parameters
id(ObjectId)


GetIdDataPtr Method (id)

GetIdDataPtr Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData »GetIdDataPtr(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr GetIdDataPtr(
    ObjectId id
)
Public Function GetIdDataPtr ( _
    id As ObjectId _
) As IntPtr
public:
IntPtr GetIdDataPtr(
    ObjectId id
)
Parameters
id(ObjectId)


GetIdFlags Method (id)

GetIdFlags Method (id)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData »GetIdFlags(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public byte GetIdFlags(
    ObjectId id
)
Public Function GetIdFlags ( _
    id As ObjectId _
) As Byte
public:
unsigned char GetIdFlags(
    ObjectId id
)
Parameters
id(ObjectId)


SetIdData Method

SetIdData Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData »SetIdData()()()()
Members
Icon | Member | Description
 | SetIdData(ObjectId, IntPtr) |
 | SetIdData(ObjectId, Int32) | Obsolete.


SetIdData Method (id, data)

SetIdData Method (id, data)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData »SetIdData(ObjectId, Int32)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use SetIdData(NAMESPACE_ACDB::ObjectId id, IntPtr data)")]
public void SetIdData(
    ObjectId id,
    int data
)
<ObsoleteAttribute("Use SetIdData(NAMESPACE_ACDB::ObjectId id, IntPtr data)")> _
Public Sub SetIdData ( _
    id As ObjectId, _
    data As Integer _
)
[ObsoleteAttribute(L"Use SetIdData(NAMESPACE_ACDB::ObjectId id, IntPtr data)")]
public:
void SetIdData(
    ObjectId id,
    int data
)
Parameters
id(ObjectId)
data(Int32)


SetIdData Method (id, data)

SetIdData Method (id, data)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData »SetIdData(ObjectId, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void SetIdData(
    ObjectId id,
    IntPtr data
)
Public Sub SetIdData ( _
    id As ObjectId, _
    data As IntPtr _
)
public:
void SetIdData(
    ObjectId id,
    IntPtr data
)
Parameters
id(ObjectId)
data(IntPtr)


SetIdFlags Method (id, flags)

SetIdFlags Method (id, flags)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData »SetIdFlags(ObjectId, Byte)
Declaration Syntax
C# Visual Basic Visual C++
public void SetIdFlags(
    ObjectId id,
    byte flags
)
Public Sub SetIdFlags ( _
    id As ObjectId, _
    flags As Byte _
)
public:
void SetIdFlags(
    ObjectId id,
    unsigned char flags
)
Parameters
id(ObjectId)
flags(Byte)


LayerFilter Class

LayerFilter Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbLayerFilter")]
public class LayerFilter : Filter
<WrapperAttribute("AcDbLayerFilter")> _
Public Class LayerFilter _
    Inherits Filter
[WrapperAttribute(L"AcDbLayerFilter")]
public ref class LayerFilter : public Filter
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayerFilter()()()() |
 | LayerFilter(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | Add(String) |
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAt(Int32, String%) |
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IndexClass | (Inherited from Filter.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsValid |
 | IsWriteEnabled | (Inherited from DBObject.)
 | LayerCount |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | Remove(String) |
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Filter
 |  |  |  |  |  |  | LayerFilter


LayerFilter Constructor

LayerFilter Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »LayerFilter()()()()
Members
Icon | Member | Description
 | LayerFilter()()()() |
 | LayerFilter(IntPtr, Boolean) |


LayerFilter Constructor

LayerFilter Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »LayerFilter()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LayerFilter()
Public Sub New
public:
LayerFilter()


LayerFilter Constructor (unmanagedPointer, autoDelete)

LayerFilter Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »LayerFilter(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LayerFilter(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
LayerFilter(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Add Method (layer)

Add Method (layer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »Add(String)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string layer
)
Public Sub Add ( _
    layer As String _
)
public:
void Add(
    String^ layer
)
Parameters
layer(String)


GetAt Method (index, name)

GetAt Method (index, name)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »GetAt(Int32, String%)
Declaration Syntax
C# Visual Basic Visual C++
public void GetAt(
    int index,
    ref string name
)
Public Sub GetAt ( _
    index As Integer, _
    ByRef name As String _
)
public:
void GetAt(
    int index,
    String^% name
)
Parameters
index(Int32)
name(String%)


IsValid Property

IsValid Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »IsValid
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsValid { get; }
Public Overridable ReadOnly Property IsValid As Boolean
    Get
public:
virtual property bool IsValid {
    bool get ();
}


LayerCount Property

LayerCount Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »LayerCount
Declaration Syntax
C# Visual Basic Visual C++
public int LayerCount { get; }
Public ReadOnly Property LayerCount As Integer
    Get
public:
property int LayerCount {
    int get ();
}


Remove Method (layer)

Remove Method (layer)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »Remove(String)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    string layer
)
Public Sub Remove ( _
    layer As String _
)
public:
void Remove(
    String^ layer
)
Parameters
layer(String)


LayerIndex Class

LayerIndex Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbLayerIndex")]
public class LayerIndex : Index
<WrapperAttribute("AcDbLayerIndex")> _
Public Class LayerIndex _
    Inherits Index
[WrapperAttribute(L"AcDbLayerIndex")]
public ref class LayerIndex : public Index
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayerIndex()()()() |
 | LayerIndex(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Compute(LayerTable, BlockTableRecord) |
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetIterator(Filter) | (Inherited from Index.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsUptoDate | (Inherited from Index.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | LastUpdatedAt | (Inherited from Index.)
 | LastUpdatedAtU | (Inherited from Index.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBeingIndexedId | (Inherited from Index.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | RebuildFull(IndexUpdateData) | (Inherited from Index.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Index
 |  |  |  |  |  |  | LayerIndex


LayerIndex Constructor

LayerIndex Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »LayerIndex()()()()
Members
Icon | Member | Description
 | LayerIndex()()()() |
 | LayerIndex(IntPtr, Boolean) |


LayerIndex Constructor

LayerIndex Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »LayerIndex()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LayerIndex()
Public Sub New
public:
LayerIndex()


LayerIndex Constructor (unmanagedPointer, autoDelete)

LayerIndex Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »LayerIndex(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LayerIndex(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
LayerIndex(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Compute Method (pLT, record)

Compute Method (pLT, record)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »Compute(LayerTable, BlockTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public void Compute(
    LayerTable pLT,
    BlockTableRecord record
)
Public Sub Compute ( _
    pLT As LayerTable, _
    record As BlockTableRecord _
)
public:
void Compute(
    LayerTable^ pLT,
    BlockTableRecord^ record
)
Parameters
pLT(LayerTable)
record(BlockTableRecord)


SpatialFilter Class

SpatialFilter Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSpatialFilter")]
public class SpatialFilter : Filter
<WrapperAttribute("AcDbSpatialFilter")> _
Public Class SpatialFilter _
    Inherits Filter
[WrapperAttribute(L"AcDbSpatialFilter")]
public ref class SpatialFilter : public Filter
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpatialFilter()()()() |
 | SpatialFilter(IntPtr, Boolean) |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | ClipSpaceToWorldCoordinateSystemTransform |
 | ClipVolumeIntersectsExtents(Extents3d) |
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | Definition |
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetQueryBounds(BlockReference) |
 | GetQueryBounds()()()() |
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetVolume()()()() |
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasPerspectiveCamera |
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | IndexClass | (Inherited from Filter.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OriginalInverseBlockTransform |
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SetPerspectiveCamera(Point3d) |
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Filter
 |  |  |  |  |  |  | SpatialFilter


SpatialFilter Constructor

SpatialFilter Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »SpatialFilter()()()()
Members
Icon | Member | Description
 | SpatialFilter()()()() |
 | SpatialFilter(IntPtr, Boolean) |


SpatialFilter Constructor

SpatialFilter Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »SpatialFilter()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SpatialFilter()
Public Sub New
public:
SpatialFilter()


SpatialFilter Constructor (unmanagedPointer, autoDelete)

SpatialFilter Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »SpatialFilter(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal SpatialFilter(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
SpatialFilter(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ClipSpaceToWorldCoordinateSystemTransform Property

ClipSpaceToWorldCoordinateSystemTransform Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »ClipSpaceToWorldCoordinateSystemTransform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d ClipSpaceToWorldCoordinateSystemTransform { get; }
Public ReadOnly Property ClipSpaceToWorldCoordinateSystemTransform As Matrix3d
    Get
public:
property Matrix3d ClipSpaceToWorldCoordinateSystemTransform {
    Matrix3d get ();
}


ClipVolumeIntersectsExtents Method (ext)

ClipVolumeIntersectsExtents Method (ext)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »ClipVolumeIntersectsExtents(Extents3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool ClipVolumeIntersectsExtents(
    Extents3d ext
)
Public Function ClipVolumeIntersectsExtents ( _
    ext As Extents3d _
) As Boolean
public:
bool ClipVolumeIntersectsExtents(
    Extents3d ext
)
Parameters
ext(Extents3d)


Definition Property

Definition Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »Definition
Declaration Syntax
C# Visual Basic Visual C++
public SpatialFilterDefinition Definition { get; set; }
Public Property Definition As SpatialFilterDefinition
    Get
    Set
public:
property SpatialFilterDefinition Definition {
    SpatialFilterDefinition get ();
    void set (SpatialFilterDefinition value);
}


GetQueryBounds Method

GetQueryBounds Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »GetQueryBounds()()()()
Members
Icon | Member | Description
 | GetQueryBounds(BlockReference) |
 | GetQueryBounds()()()() |


GetQueryBounds Method

GetQueryBounds Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »GetQueryBounds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Extents3d GetQueryBounds()
Public Function GetQueryBounds As Extents3d
public:
Extents3d GetQueryBounds()


GetQueryBounds Method (blockReference)

GetQueryBounds Method (blockReference)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »GetQueryBounds(BlockReference)
Declaration Syntax
C# Visual Basic Visual C++
public virtual Extents3d GetQueryBounds(
    BlockReference blockReference
)
Public Overridable Function GetQueryBounds ( _
    blockReference As BlockReference _
) As Extents3d
public:
virtual Extents3d GetQueryBounds(
    BlockReference^ blockReference
)
Parameters
blockReference(BlockReference)


GetVolume Method

GetVolume Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »GetVolume()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SpatialFilterVolume GetVolume()
Public Function GetVolume As SpatialFilterVolume
public:
SpatialFilterVolume GetVolume()


HasPerspectiveCamera Property

HasPerspectiveCamera Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »HasPerspectiveCamera
Declaration Syntax
C# Visual Basic Visual C++
public bool HasPerspectiveCamera { get; }
Public ReadOnly Property HasPerspectiveCamera As Boolean
    Get
public:
property bool HasPerspectiveCamera {
    bool get ();
}


OriginalInverseBlockTransform Property

OriginalInverseBlockTransform Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »OriginalInverseBlockTransform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d OriginalInverseBlockTransform { get; }
Public ReadOnly Property OriginalInverseBlockTransform As Matrix3d
    Get
public:
property Matrix3d OriginalInverseBlockTransform {
    Matrix3d get ();
}


SetPerspectiveCamera Method (fromPoint)

SetPerspectiveCamera Method (fromPoint)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »SetPerspectiveCamera(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPerspectiveCamera(
    Point3d fromPoint
)
Public Sub SetPerspectiveCamera ( _
    fromPoint As Point3d _
)
public:
void SetPerspectiveCamera(
    Point3d fromPoint
)
Parameters
fromPoint(Point3d)


SpatialFilterDefinition Structure

SpatialFilterDefinition Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterDefinition
Declaration Syntax
C# Visual Basic Visual C++
public struct SpatialFilterDefinition
Public Structure SpatialFilterDefinition
public value class SpatialFilterDefinition
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpatialFilterDefinition(Point2dCollection, Vector3d, Double, Double, Double, Boolean) |
 | BackClip |
 | Elevation |
 | Enabled |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | FrontClip |
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetPoints()()()() |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Normal |
 | ToString()()()() | (Inherited from ValueType.)


SpatialFilterDefinition Constructor (pts, normal, elevation, frontClip, backClip, enabled)

SpatialFilterDefinition Constructor (pts, normal, elevation, frontClip, backClip, enabled)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterDefinition »SpatialFilterDefinition(Point2dCollection, Vector3d, Double, Double, Double, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public SpatialFilterDefinition(
    Point2dCollection pts,
    Vector3d normal,
    double elevation,
    double frontClip,
    double backClip,
    bool enabled
)
Public Sub New ( _
    pts As Point2dCollection, _
    normal As Vector3d, _
    elevation As Double, _
    frontClip As Double, _
    backClip As Double, _
    enabled As Boolean _
)
public:
SpatialFilterDefinition(
    Point2dCollection^ pts,
    Vector3d normal,
    double elevation,
    double frontClip,
    double backClip,
    bool enabled
)
Parameters
pts(Point2dCollection)
normal(Vector3d)
elevation(Double)
frontClip(Double)
backClip(Double)
enabled(Boolean)


BackClip Property

BackClip Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterDefinition »BackClip
Declaration Syntax
C# Visual Basic Visual C++
public double BackClip { get; }
Public ReadOnly Property BackClip As Double
    Get
public:
property double BackClip {
    double get ();
}


Elevation Property

Elevation Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterDefinition »Elevation
Declaration Syntax
C# Visual Basic Visual C++
public double Elevation { get; }
Public ReadOnly Property Elevation As Double
    Get
public:
property double Elevation {
    double get ();
}


Enabled Property

Enabled Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterDefinition »Enabled
Declaration Syntax
C# Visual Basic Visual C++
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
public:
property bool Enabled {
    bool get ();
}


FrontClip Property

FrontClip Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterDefinition »FrontClip
Declaration Syntax
C# Visual Basic Visual C++
public double FrontClip { get; }
Public ReadOnly Property FrontClip As Double
    Get
public:
property double FrontClip {
    double get ();
}


GetPoints Method

GetPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterDefinition »GetPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point2dCollection GetPoints()
Public Function GetPoints As Point2dCollection
public:
Point2dCollection^ GetPoints()


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterDefinition »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; }
Public ReadOnly Property Normal As Vector3d
    Get
public:
property Vector3d Normal {
    Vector3d get ();
}


SpatialFilterVolume Structure

SpatialFilterVolume Structure
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterVolume
Declaration Syntax
C# Visual Basic Visual C++
public struct SpatialFilterVolume
Public Structure SpatialFilterVolume
public value class SpatialFilterVolume
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpatialFilterVolume(Point3d, Point3d, Vector3d, Vector2d) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | FromPoint |
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToPoint |
 | ToString()()()() | (Inherited from ValueType.)
 | UpDirection |
 | ViewField |


SpatialFilterVolume Constructor (fromPoint, toPoint, upDir, viewField)

SpatialFilterVolume Constructor (fromPoint, toPoint, upDir, viewField)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterVolume »SpatialFilterVolume(Point3d, Point3d, Vector3d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public SpatialFilterVolume(
    Point3d fromPoint,
    Point3d toPoint,
    Vector3d upDir,
    Vector2d viewField
)
Public Sub New ( _
    fromPoint As Point3d, _
    toPoint As Point3d, _
    upDir As Vector3d, _
    viewField As Vector2d _
)
public:
SpatialFilterVolume(
    Point3d fromPoint,
    Point3d toPoint,
    Vector3d upDir,
    Vector2d viewField
)
Parameters
fromPoint(Point3d)
toPoint(Point3d)
upDir(Vector3d)
viewField(Vector2d)


FromPoint Property

FromPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterVolume »FromPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d FromPoint { get; }
Public ReadOnly Property FromPoint As Point3d
    Get
public:
property Point3d FromPoint {
    Point3d get ();
}


ToPoint Property

ToPoint Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterVolume »ToPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ToPoint { get; }
Public ReadOnly Property ToPoint As Point3d
    Get
public:
property Point3d ToPoint {
    Point3d get ();
}


UpDirection Property

UpDirection Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterVolume »UpDirection
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d UpDirection { get; }
Public ReadOnly Property UpDirection As Vector3d
    Get
public:
property Vector3d UpDirection {
    Vector3d get ();
}


ViewField Property

ViewField Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilterVolume »ViewField
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d ViewField { get; }
Public ReadOnly Property ViewField As Vector2d
    Get
public:
property Vector2d ViewField {
    Vector2d get ();
}


SpatialIndex Class

SpatialIndex Class
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcDbSpatialIndex")]
public class SpatialIndex : Index
<WrapperAttribute("AcDbSpatialIndex")> _
Public Class SpatialIndex _
    Inherits Index
[WrapperAttribute(L"AcDbSpatialIndex")]
public ref class SpatialIndex : public Index
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpatialIndex(IntPtr, Boolean) |
 | SpatialIndex()()()() |
 | AcadObject | (Inherited from DBObject.)
 | AddContext(ObjectContext) | (Inherited from DBObject.)
 | AddPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | Annotative | (Inherited from DBObject.)
 | ApplyPartialUndo(DwgFiler, RXClass) | (Inherited from DBObject.)
 | AssertNotifyEnabled()()()() | (Inherited from DBObject.)
 | AssertReadEnabled()()()() | (Inherited from DBObject.)
 | AssertWriteEnabled(Boolean, Boolean) | (Inherited from DBObject.)
 | Audit(AuditInfo) | (Inherited from DBObject.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds | (Inherited from Drawable.)
 | Cancel()()()() | Obsolete. (Inherited from DBObject.)
 | Cancelled | (Inherited from DBObject.)
 | ClassID | (Inherited from DBObject.)
 | Clone()()()() | (Inherited from RXObject.)
 | Close()()()() | Obsolete. (Inherited from DBObject.)
 | CloseAndPage(Boolean) | Obsolete. (Inherited from DBObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copied | (Inherited from DBObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateExtensionDictionary()()()() | (Inherited from DBObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database | (Inherited from DBObject.)
 | DecomposeForSave(DwgVersion) | (Inherited from DBObject.)
 | DeepClone(DBObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DBObject.)
 | DisableUndoRecording(Boolean) | (Inherited from DBObject.)
 | Dispose(Boolean) | (Inherited from DBObject.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DowngradeOpen()()()() | (Inherited from DBObject.)
 | DowngradeToNotify(Boolean) | (Inherited from DBObject.)
 | Drawable | (Inherited from DBObject.)
 | drawableType | (Inherited from Drawable.)
 | DwgIn(DwgFiler) | (Inherited from DBObject.)
 | DwgInFields(DwgFiler) | (Inherited from DBObject.)
 | DwgOut(DwgFiler) | (Inherited from DBObject.)
 | DwgOutFields(DwgFiler) | (Inherited from DBObject.)
 | DxfIn(DxfFiler) | (Inherited from DBObject.)
 | DxfInFields(DxfFiler) | (Inherited from DBObject.)
 | DxfOut(DxfFiler) | (Inherited from DBObject.)
 | DxfOutFields(DxfFiler) | (Inherited from DBObject.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Boolean) | (Inherited from DBObject.)
 | Erase()()()() | (Inherited from DBObject.)
 | Erased | (Inherited from DBObject.)
 | ExtensionDictionary | (Inherited from DBObject.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEventExtender(Boolean) | (Inherited from DBObject.)
 | GetField(String) | (Inherited from DBObject.)
 | GetField()()()() | (Inherited from DBObject.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetIterator(Filter) | (Inherited from Index.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.)
 | GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.)
 | GetPersistentReactorIds()()()() | (Inherited from DBObject.)
 | GetReactors()()()() | Obsolete. (Inherited from DBObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetTransientReactors()()()() | (Inherited from DBObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetXDataForApplication(String) | (Inherited from DBObject.)
 | Goodbye | (Inherited from DBObject.)
 | Handle | (Inherited from DBObject.)
 | HandOverTo(DBObject, Boolean, Boolean) | (Inherited from DBObject.)
 | HasContext(ObjectContext) | (Inherited from DBObject.)
 | HasFields | (Inherited from DBObject.)
 | HasPersistentReactor(ObjectId) | (Inherited from DBObject.)
 | HasSaveVersionOverride | (Inherited from DBObject.)
 | Id | (Inherited from DBObject.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAProxy | (Inherited from DBObject.)
 | IsCancelling | (Inherited from DBObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsErased | (Inherited from DBObject.)
 | IsEraseStatusToggled | (Inherited from DBObject.)
 | IsModified | (Inherited from DBObject.)
 | IsModifiedGraphics | (Inherited from DBObject.)
 | IsModifiedXData | (Inherited from DBObject.)
 | IsNewObject | (Inherited from DBObject.)
 | IsNotifyEnabled | (Inherited from DBObject.)
 | IsNotifying | (Inherited from DBObject.)
 | IsObjectIdsInFlux | (Inherited from DBObject.)
 | IsPersistent | (Inherited from DBObject.)
 | IsReadEnabled | (Inherited from DBObject.)
 | IsReallyClosing | (Inherited from DBObject.)
 | IsTransactionResident | (Inherited from DBObject.)
 | IsUndoing | (Inherited from DBObject.)
 | IsUptoDate | (Inherited from Index.)
 | IsWriteEnabled | (Inherited from DBObject.)
 | LastUpdatedAt | (Inherited from Index.)
 | LastUpdatedAtU | (Inherited from Index.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStyle | (Inherited from DBObject.)
 | Modified | (Inherited from DBObject.)
 | ModifiedXData | (Inherited from DBObject.)
 | ModifyUndone | (Inherited from DBObject.)
 | ObjectBeingIndexedId | (Inherited from Index.)
 | ObjectBirthVersion | (Inherited from DBObject.)
 | ObjectClosed | (Inherited from DBObject.)
 | ObjectId | (Inherited from DBObject.)
 | OpenedForModify | (Inherited from DBObject.)
 | OwnerId | (Inherited from DBObject.)
 | PaperOrientation | (Inherited from DBObject.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reappended | (Inherited from DBObject.)
 | RebuildFull(IndexUpdateData) | (Inherited from Index.)
 | ReleaseExtensionDictionary()()()() | (Inherited from DBObject.)
 | RemoveContext(ObjectContext) | (Inherited from DBObject.)
 | RemoveField(String) | (Inherited from DBObject.)
 | RemoveField(ObjectId) | (Inherited from DBObject.)
 | RemoveField()()()() | (Inherited from DBObject.)
 | RemovePersistentReactor(ObjectId) | (Inherited from DBObject.)
 | ResetScaleDependentProperties()()()() | (Inherited from DBObject.)
 | SetAttributes(DrawableTraits) | (Inherited from Drawable.)
 | SetField(String, Field) | (Inherited from DBObject.)
 | SetField(Field) | (Inherited from DBObject.)
 | SetFromStyle()()()() | (Inherited from DBObject.)
 | SetObjectIdsInFlux()()()() | (Inherited from DBObject.)
 | SetPaperOrientation(Boolean) | (Inherited from DBObject.)
 | SubObjectModified | (Inherited from DBObject.)
 | SubSetAttributes(DrawableTraits) | (Inherited from DBObject.)
 | SubViewportDraw(ViewportDraw) | (Inherited from DBObject.)
 | SubViewportDrawLogicalFlags(ViewportDraw) | (Inherited from DBObject.)
 | SubWorldDraw(WorldDraw) | (Inherited from DBObject.)
 | SupportsCollection(String) | (Inherited from DBObject.)
 | SwapIdWith(ObjectId, Boolean, Boolean) | (Inherited from DBObject.)
 | SwapReferences(IdMapping) | (Inherited from DBObject.)
 | ToString()()()() | (Inherited from Object.)
 | Unappended | (Inherited from DBObject.)
 | UndoFiler | (Inherited from DBObject.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpgradeFromNotify()()()() | (Inherited from DBObject.)
 | UpgradeOpen()()()() | (Inherited from DBObject.)
 | ViewportDraw(ViewportDraw) | (Inherited from Drawable.)
 | ViewportDrawLogicalFlags(ViewportDraw) | (Inherited from Drawable.)
 | WblockClone(RXObject, IdMapping, Boolean) | (Inherited from DBObject.)
 | WorldDraw(WorldDraw) | (Inherited from Drawable.)
 | X(RXClass) | (Inherited from RXObject.)
 | XData | (Inherited from DBObject.)
 | XDataTransformBy(Matrix3d) | (Inherited from DBObject.)
 | ZcadObject | (Inherited from DBObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject
 |  |  |  |  |  | Index
 |  |  |  |  |  |  | SpatialIndex


SpatialIndex Constructor

SpatialIndex Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex »SpatialIndex()()()()
Members
Icon | Member | Description
 | SpatialIndex(IntPtr, Boolean) |
 | SpatialIndex()()()() |


SpatialIndex Constructor

SpatialIndex Constructor
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex »SpatialIndex()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SpatialIndex()
Public Sub New
public:
SpatialIndex()


SpatialIndex Constructor (unmanagedPointer, autoDelete)

SpatialIndex Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex »SpatialIndex(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal SpatialIndex(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
SpatialIndex(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ZwSoft.ZwCAD.EditorInput Namespace

ZwSoft.ZwCAD.EditorInput Namespace
Namespaces »ZwSoft.ZwCAD.EditorInput
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.EditorInput
Namespace ZwSoft.ZwCAD.EditorInput
namespace ZwSoft.ZwCAD.EditorInput
Types
All Types Classes Structures Enumerations Delegates
Icon | Type | Description
 | ConstraintUtilities |
 | CrossingOrWindowSelectedObject |
 | CrossingOrWindowSelectedSubObject |
 | CursorType |
 | DisposableSelectionSet |
 | DragCallback |
 | DragCursor |
 | DraggingEndedEventArgs |
 | DraggingEndedEventHandler |
 | DraggingEventArgs |
 | DraggingEventHandler |
 | DrawJig |
 | Editor |
 | EditorUserInteraction |
 | EditorVisualStyle |
 | EntityJig |
 | FenceSelectedObject |
 | FenceSelectedSubObject |
 | InputPointContext |
 | Jig |
 | JigPromptAngleOptions |
 | JigPromptDistanceOptions |
 | JigPromptGeometryOptions |
 | JigPromptOptions |
 | JigPromptPointOptions |
 | JigPrompts |
 | JigPromptStringOptions |
 | Keyword |
 | KeywordCollection |
 | ObjectSnapMasks |
 | PickPointDescriptor |
 | PickPointKind |
 | PickPointSelectedObject |
 | PickPointSelectedSubObject |
 | PointFilterEventArgs |
 | PointFilterEventHandler |
 | PointFilterResult |
 | PointHistoryBits |
 | PointMonitorEventArgs |
 | PointMonitorEventHandler |
 | PromptAngleOptions |
 | PromptAngleOptionsEventArgs |
 | PromptAngleOptionsEventHandler |
 | PromptCornerOptions |
 | PromptDistanceOptions |
 | PromptDistanceOptionsEventArgs |
 | PromptDistanceOptionsEventHandler |
 | PromptDoubleOptions |
 | PromptDoubleOptionsEventArgs |
 | PromptDoubleOptionsEventHandler |
 | PromptDoubleResult |
 | PromptDoubleResultEventArgs |
 | PromptDoubleResultEventHandler |
 | PromptDragOptions |
 | PromptEditorOptions |
 | PromptEntityOptions |
 | PromptEntityOptionsEventArgs |
 | PromptEntityOptionsEventHandler |
 | PromptEntityResult |
 | PromptEntityResultEventArgs |
 | PromptEntityResultEventHandler |
 | PromptFileNameResult |
 | PromptFileOptions |
 | PromptForEntityEndingEventArgs |
 | PromptForEntityEndingEventHandler |
 | PromptForSelectionEndingEventArgs |
 | PromptForSelectionEndingEventHandler |
 | PromptIntegerOptions |
 | PromptIntegerOptionsEventArgs |
 | PromptIntegerOptionsEventHandler |
 | PromptIntegerResult |
 | PromptIntegerResultEventArgs |
 | PromptIntegerResultEventHandler |
 | PromptKeywordOptions |
 | PromptKeywordOptionsEventArgs |
 | PromptKeywordOptionsEventHandler |
 | PromptNestedEntityOptions |
 | PromptNestedEntityOptionsEventArgs |
 | PromptNestedEntityOptionsEventHandler |
 | PromptNestedEntityResult |
 | PromptNestedEntityResultEventArgs |
 | PromptNestedEntityResultEventHandler |
 | PromptNumericalOptions |
 | PromptOpenFileOptions |
 | PromptOptions |
 | PromptPointOptions |
 | PromptPointOptionsEventArgs |
 | PromptPointOptionsEventHandler |
 | PromptPointResult |
 | PromptPointResultEventArgs |
 | PromptPointResultEventHandler |
 | PromptResult |
 | PromptSaveFileOptions |
 | PromptSelectionOptions |
 | PromptSelectionOptionsEventArgs |
 | PromptSelectionOptionsEventHandler |
 | PromptSelectionResult |
 | PromptSelectionResultEventArgs |
 | PromptSelectionResultEventHandler |
 | PromptStatus |
 | PromptStringOptions |
 | PromptStringOptionsEventArgs |
 | PromptStringOptionsEventHandler |
 | PromptStringResultEventArgs |
 | PromptStringResultEventHandler |
 | RolloverEventArgs |
 | RolloverEventHandler |
 | SamplerStatus |
 | SelectedObject |
 | SelectedSubObject |
 | SelectionAddedEventArgs |
 | SelectionAddedEventHandler |
 | SelectionDetails |
 | SelectionFilter |
 | SelectionFlags |
 | SelectionMethod |
 | SelectionRemovedEventArgs |
 | SelectionRemovedEventHandler |
 | SelectionSet |
 | SelectionSetDelayMarshalled |
 | SelectionTextInputEventArgs |
 | SelectionTextInputEventHandler |
 | UserInputControls |


ConstraintUtilities Class

ConstraintUtilities Class
Namespaces »ZwSoft.ZwCAD.EditorInput »ConstraintUtilities
Declaration Syntax
C# Visual Basic Visual C++
public class ConstraintUtilities
Public Class ConstraintUtilities
public ref class ConstraintUtilities
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConstraintUtilities()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShowConstraintBar(array<FullSubentityPath>[]()[][], Boolean) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ConstraintUtilities

Assembly: ZwManaged (Module: ZwManaged)


ConstraintUtilities Constructor

ConstraintUtilities Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »ConstraintUtilities »ConstraintUtilities()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConstraintUtilities()
Public Sub New
public:
ConstraintUtilities()

Assembly: ZwManaged (Module: ZwManaged)


ShowConstraintBar Method (subentityPaths, bToShow)

ShowConstraintBar Method (subentityPaths, bToShow)
Namespaces »ZwSoft.ZwCAD.EditorInput »ConstraintUtilities »ShowConstraintBar(array<FullSubentityPath>[]()[][], Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static bool ShowConstraintBar(
    FullSubentityPath[] subentityPaths,
    bool bToShow
)
Public Shared Function ShowConstraintBar ( _
    subentityPaths As FullSubentityPath(), _
    bToShow As Boolean _
) As Boolean
public:
static bool ShowConstraintBar(
    array<FullSubentityPath>^ subentityPaths,
    bool bToShow
)
Parameters
subentityPaths(array< FullSubentityPath >[]()[][])
bToShow(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


CrossingOrWindowSelectedObject Class

CrossingOrWindowSelectedObject Class
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedObject
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CrossingOrWindowSelectedObject : SelectedObject
Public NotInheritable Class CrossingOrWindowSelectedObject _
    Inherits SelectedObject
public ref class CrossingOrWindowSelectedObject sealed : public SelectedObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrossingOrWindowSelectedObject(ObjectId, SelectionMethod, IntPtr) |
 | CrossingOrWindowSelectedObject(ObjectId, SelectionMethod, Int32) | Obsolete.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetPickPoints()()()() |
 | GetSubentities()()()() | (Inherited from SelectedObject.)
 | GetType()()()() | (Inherited from Object.)
 | GraphicsSystemMarker | Obsolete. (Inherited from SelectedObject.)
 | GraphicsSystemMarkerPtr | (Inherited from SelectedObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObjectId | (Inherited from SelectedObject.)
 | OptionalDetails | (Inherited from SelectedObject.)
 | SelectionMethod | (Inherited from SelectedObject.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedObject.ToString()()()().)
Inheritance Hierarchy
Object
 | SelectedObject
 |  | CrossingOrWindowSelectedObject

Assembly: ZwManaged (Module: ZwManaged)


CrossingOrWindowSelectedObject Constructor

CrossingOrWindowSelectedObject Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedObject »CrossingOrWindowSelectedObject()()()()
Members
Icon | Member | Description
 | CrossingOrWindowSelectedObject(ObjectId, SelectionMethod, IntPtr) |
 | CrossingOrWindowSelectedObject(ObjectId, SelectionMethod, Int32) | Obsolete.

Assembly: ZwManaged (Module: ZwManaged)


CrossingOrWindowSelectedObject Constructor (id, method, gsMarker)

CrossingOrWindowSelectedObject Constructor (id, method, gsMarker)
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedObject »CrossingOrWindowSelectedObject(ObjectId, SelectionMethod, Int32)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use overload taking System::IntPtr instead.")]
public CrossingOrWindowSelectedObject(
    ObjectId id,
    SelectionMethod method,
    int gsMarker
)
<ObsoleteAttribute("Use overload taking System::IntPtr instead.")> _
Public Sub New ( _
    id As ObjectId, _
    method As SelectionMethod, _
    gsMarker As Integer _
)
[ObsoleteAttribute(L"Use overload taking System::IntPtr instead.")]
public:
CrossingOrWindowSelectedObject(
    ObjectId id,
    SelectionMethod method,
    int gsMarker
)
Parameters
id(ObjectId)
method(SelectionMethod)
gsMarker(Int32)

Assembly: ZwManaged (Module: ZwManaged)


CrossingOrWindowSelectedObject Constructor (id, method, gsMarker)

CrossingOrWindowSelectedObject Constructor (id, method, gsMarker)
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedObject »CrossingOrWindowSelectedObject(ObjectId, SelectionMethod, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public CrossingOrWindowSelectedObject(
    ObjectId id,
    SelectionMethod method,
    IntPtr gsMarker
)
Public Sub New ( _
    id As ObjectId, _
    method As SelectionMethod, _
    gsMarker As IntPtr _
)
public:
CrossingOrWindowSelectedObject(
    ObjectId id,
    SelectionMethod method,
    IntPtr gsMarker
)
Parameters
id(ObjectId)
method(SelectionMethod)
gsMarker(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


GetPickPoints Method

GetPickPoints Method
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedObject »GetPickPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickPointDescriptor[] GetPickPoints()
Public Function GetPickPoints As PickPointDescriptor()
public:
array<PickPointDescriptor>^ GetPickPoints()

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedObject »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedObject.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedObject »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedObject »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


CrossingOrWindowSelectedSubObject Class

CrossingOrWindowSelectedSubObject Class
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedSubObject
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CrossingOrWindowSelectedSubObject : SelectedSubObject
Public NotInheritable Class CrossingOrWindowSelectedSubObject _
    Inherits SelectedSubObject
public ref class CrossingOrWindowSelectedSubObject sealed : public SelectedSubObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrossingOrWindowSelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr) |
 | CrossingOrWindowSelectedSubObject(FullSubentityPath, SelectionMethod, Int32) | Obsolete.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FullSubentityPath | (Inherited from SelectedSubObject.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetPickPoints()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GraphicsSystemMarker | Obsolete. (Inherited from SelectedSubObject.)
 | GraphicsSystemMarkerPtr | (Inherited from SelectedSubObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OptionalDetails | (Inherited from SelectedSubObject.)
 | SelectionMethod | (Inherited from SelectedSubObject.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedSubObject.ToString()()()().)
Inheritance Hierarchy
Object
 | SelectedSubObject
 |  | CrossingOrWindowSelectedSubObject

Assembly: ZwManaged (Module: ZwManaged)


CrossingOrWindowSelectedSubObject Constructor

CrossingOrWindowSelectedSubObject Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedSubObject »CrossingOrWindowSelectedSubObject()()()()
Members
Icon | Member | Description
 | CrossingOrWindowSelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr) |
 | CrossingOrWindowSelectedSubObject(FullSubentityPath, SelectionMethod, Int32) | Obsolete.

Assembly: ZwManaged (Module: ZwManaged)


CrossingOrWindowSelectedSubObject Constructor (path, method, gsMarker)

CrossingOrWindowSelectedSubObject Constructor (path, method, gsMarker)
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedSubObject »CrossingOrWindowSelectedSubObject(FullSubentityPath, SelectionMethod, Int32)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use overload taking System::IntPtr instead.")]
public CrossingOrWindowSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    int gsMarker
)
<ObsoleteAttribute("Use overload taking System::IntPtr instead.")> _
Public Sub New ( _
    path As FullSubentityPath, _
    method As SelectionMethod, _
    gsMarker As Integer _
)
[ObsoleteAttribute(L"Use overload taking System::IntPtr instead.")]
public:
CrossingOrWindowSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    int gsMarker
)
Parameters
path(FullSubentityPath)
method(SelectionMethod)
gsMarker(Int32)

Assembly: ZwManaged (Module: ZwManaged)


CrossingOrWindowSelectedSubObject Constructor (path, method, gsMarker)

CrossingOrWindowSelectedSubObject Constructor (path, method, gsMarker)
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedSubObject »CrossingOrWindowSelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public CrossingOrWindowSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    IntPtr gsMarker
)
Public Sub New ( _
    path As FullSubentityPath, _
    method As SelectionMethod, _
    gsMarker As IntPtr _
)
public:
CrossingOrWindowSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    IntPtr gsMarker
)
Parameters
path(FullSubentityPath)
method(SelectionMethod)
gsMarker(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


GetPickPoints Method

GetPickPoints Method
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedSubObject »GetPickPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickPointDescriptor[] GetPickPoints()
Public Function GetPickPoints As PickPointDescriptor()
public:
array<PickPointDescriptor>^ GetPickPoints()

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedSubObject »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedSubObject.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedSubObject »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »CrossingOrWindowSelectedSubObject »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


CursorType Enumeration

CursorType Enumeration
Namespaces »ZwSoft.ZwCAD.EditorInput »CursorType
Declaration Syntax
C# Visual Basic Visual C++
public enum CursorType
Public Enumeration CursorType
public enum class CursorType
Members
Member | Description
PickfirstOrGrips |
EntitySelectNoPerspective |
Parallelogram |
EntitySelect |
Invisible |
CrosshairNoRotate |
RotatedCrosshair |
TargetBox |
NotRotated |
RubberBand |
RectangularCursor |
Crosshair |
NoSpecialCursor |

Assembly: ZwManaged (Module: ZwManaged)


DisposableSelectionSet Class

DisposableSelectionSet Class
Namespaces »ZwSoft.ZwCAD.EditorInput »DisposableSelectionSet
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DisposableSelectionSet : IDisposable
Public NotInheritable Class DisposableSelectionSet _
    Implements IDisposable
public ref class DisposableSelectionSet sealed : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DisposableSelectionSet(SelectionSetDelayMarshalled) |
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DisposableSelectionSet

Assembly: ZwManaged (Module: ZwManaged)


DisposableSelectionSet Constructor (selectionSet)

DisposableSelectionSet Constructor (selectionSet)
Namespaces »ZwSoft.ZwCAD.EditorInput »DisposableSelectionSet »DisposableSelectionSet(SelectionSetDelayMarshalled)
Declaration Syntax
C# Visual Basic Visual C++
public DisposableSelectionSet(
    SelectionSetDelayMarshalled selectionSet
)
Public Sub New ( _
    selectionSet As SelectionSetDelayMarshalled _
)
public:
DisposableSelectionSet(
    SelectionSetDelayMarshalled^ selectionSet
)
Parameters
selectionSet(SelectionSetDelayMarshalled)

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »DisposableSelectionSet »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


DragCallback Delegate

DragCallback Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »DragCallback
Declaration Syntax
C# Visual Basic Visual C++
public delegate SamplerStatus DragCallback(
    Point3d current,
    out Matrix3d xform
)
Public Delegate Function DragCallback ( _
    current As Point3d, _
    <OutAttribute> ByRef xform As Matrix3d _
) As SamplerStatus
public delegate SamplerStatus DragCallback(
    Point3d current,
    [InAttribute] [OutAttribute] Matrix3d% xform
)
Parameters
current(Point3d)
xform(Matrix3d %)

Assembly: ZwManaged (Module: ZwManaged)


DragCursor Enumeration

DragCursor Enumeration
Namespaces »ZwSoft.ZwCAD.EditorInput »DragCursor
Declaration Syntax
C# Visual Basic Visual C++
public enum DragCursor
Public Enumeration DragCursor
public enum class DragCursor
Members
Member | Description
None |
Normal |
Selection |

Assembly: ZwManaged (Module: ZwManaged)


DraggingEndedEventArgs Class

DraggingEndedEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »DraggingEndedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DraggingEndedEventArgs : EventArgs
Public NotInheritable Class DraggingEndedEventArgs _
    Inherits EventArgs
public ref class DraggingEndedEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Offset |
 | PickPoint |
 | Status |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DraggingEndedEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Offset Property

Offset Property
Namespaces »ZwSoft.ZwCAD.EditorInput »DraggingEndedEventArgs »Offset
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Offset { get; }
Public ReadOnly Property Offset As Vector3d
    Get
public:
property Vector3d Offset {
    Vector3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PickPoint Property

PickPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »DraggingEndedEventArgs »PickPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d PickPoint { get; }
Public ReadOnly Property PickPoint As Point3d
    Get
public:
property Point3d PickPoint {
    Point3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Status Property

Status Property
Namespaces »ZwSoft.ZwCAD.EditorInput »DraggingEndedEventArgs »Status
Declaration Syntax
C# Visual Basic Visual C++
public PromptStatus Status { get; }
Public ReadOnly Property Status As PromptStatus
    Get
public:
property PromptStatus Status {
    PromptStatus get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DraggingEndedEventHandler Delegate

DraggingEndedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »DraggingEndedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DraggingEndedEventHandler(
    Object sender,
    DraggingEndedEventArgs e
)
Public Delegate Sub DraggingEndedEventHandler ( _
    sender As Object, _
    e As DraggingEndedEventArgs _
)
public delegate void DraggingEndedEventHandler(
    Object^ sender,
    DraggingEndedEventArgs^ e
)
Parameters
sender(Object)
e(DraggingEndedEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


DraggingEventArgs Class

DraggingEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »DraggingEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DraggingEventArgs : EventArgs
Public NotInheritable Class DraggingEventArgs _
    Inherits EventArgs
public ref class DraggingEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DraggingEventArgs(String) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Prompt |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DraggingEventArgs

Assembly: ZwManaged (Module: ZwManaged)


DraggingEventArgs Constructor (prompt)

DraggingEventArgs Constructor (prompt)
Namespaces »ZwSoft.ZwCAD.EditorInput »DraggingEventArgs »DraggingEventArgs(String)
Declaration Syntax
C# Visual Basic Visual C++
public DraggingEventArgs(
    string prompt
)
Public Sub New ( _
    prompt As String _
)
public:
DraggingEventArgs(
    String^ prompt
)
Parameters
prompt(String)

Assembly: ZwManaged (Module: ZwManaged)


Prompt Property

Prompt Property
Namespaces »ZwSoft.ZwCAD.EditorInput »DraggingEventArgs »Prompt
Declaration Syntax
C# Visual Basic Visual C++
public string Prompt { get; }
Public ReadOnly Property Prompt As String
    Get
public:
property String^ Prompt {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DraggingEventHandler Delegate

DraggingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »DraggingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DraggingEventHandler(
    Object sender,
    DraggingEventArgs e
)
Public Delegate Sub DraggingEventHandler ( _
    sender As Object, _
    e As DraggingEventArgs _
)
public delegate void DraggingEventHandler(
    Object^ sender,
    DraggingEventArgs^ e
)
Parameters
sender(Object)
e(DraggingEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


DrawJig Class

DrawJig Class
Namespaces »ZwSoft.ZwCAD.EditorInput »DrawJig
Declaration Syntax
C# Visual Basic Visual C++
public abstract class DrawJig : Jig
Public MustInherit Class DrawJig _
    Inherits Jig
public ref class DrawJig abstract : public Jig
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DrawJig()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDynamicDimensionData(Double) | (Inherited from Jig.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnDimensionValueChanged(DynamicDimensionChangedEventArgs) | (Inherited from Jig.)
 | Sampler(JigPrompts) | (Inherited from Jig.)
 | ToString()()()() | (Inherited from Object.)
 | ViewportDraw(ViewportDraw) |
 | WorldDraw(WorldDraw) |
Inheritance Hierarchy
Object
 | Jig
 |  | DrawJig

Assembly: ZwManaged (Module: ZwManaged)


DrawJig Constructor

DrawJig Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »DrawJig »DrawJig()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal DrawJig()
Protected Friend Sub New
protected public:
DrawJig()

Assembly: ZwManaged (Module: ZwManaged)


ViewportDraw Method (draw)

ViewportDraw Method (draw)
Namespaces »ZwSoft.ZwCAD.EditorInput »DrawJig »ViewportDraw(ViewportDraw)
Declaration Syntax
C# Visual Basic Visual C++
protected internal virtual void ViewportDraw(
    ViewportDraw draw
)
Protected Friend Overridable Sub ViewportDraw ( _
    draw As ViewportDraw _
)
protected public:
virtual void ViewportDraw(
    ViewportDraw^ draw
)
Parameters
draw(ViewportDraw)

Assembly: ZwManaged (Module: ZwManaged)


WorldDraw Method (draw)

WorldDraw Method (draw)
Namespaces »ZwSoft.ZwCAD.EditorInput »DrawJig »WorldDraw(WorldDraw)
Declaration Syntax
C# Visual Basic Visual C++
protected internal abstract bool WorldDraw(
    WorldDraw draw
)
Protected Friend MustOverride Function WorldDraw ( _
    draw As WorldDraw _
) As Boolean
protected public:
virtual bool WorldDraw(
    WorldDraw^ draw
) abstract
Parameters
draw(WorldDraw)

Assembly: ZwManaged (Module: ZwManaged)


Editor Class

Editor Class
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcEditor")]
public sealed class Editor : MarshalByRefObject
<WrapperAttribute("AcEditor")> _
Public NotInheritable Class Editor _
    Inherits MarshalByRefObject
[WrapperAttribute(L"AcEditor")]
public ref class Editor sealed : public MarshalByRefObject
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ActiveViewportId |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CurrentUserCoordinateSystem |
 | CurrentViewportObjectId |
 | Document |
 | DoPrompt(PromptOptions) |
 | Drag(SelectionSet, String, DragCallback) |
 | Drag(PromptDragOptions) |
 | Drag(Jig) |
 | Dragging |
 | DraggingEnded |
 | DrawVector(Point3d, Point3d, Int32, Boolean) |
 | DrawVectors(ResultBuffer, Matrix3d) |
 | EnteringQuiescentState |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAngle(String) |
 | GetAngle(PromptAngleOptions) |
 | GetCommandVersion()()()() |
 | GetCorner(String, Point3d) |
 | GetCorner(PromptCornerOptions) |
 | GetCurrentView()()()() |
 | GetDistance(String) |
 | GetDistance(PromptDistanceOptions) |
 | GetDouble(String) |
 | GetDouble(PromptDoubleOptions) |
 | GetEntity(String) |
 | GetEntity(PromptEntityOptions) |
 | GetFileNameForOpen(PromptOpenFileOptions) |
 | GetFileNameForOpen(String) |
 | GetFileNameForSave(PromptSaveFileOptions) |
 | GetFileNameForSave(String) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetInteger(String) |
 | GetInteger(PromptIntegerOptions) |
 | GetKeywords(String, array<String>[]()[][]) |
 | GetKeywords(PromptKeywordOptions) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNestedEntity(String) |
 | GetNestedEntity(PromptNestedEntityOptions) |
 | GetPoint(String) |
 | GetPoint(PromptPointOptions) |
 | GetSelection(PromptSelectionOptions, SelectionFilter) |
 | GetSelection(SelectionFilter) |
 | GetSelection(PromptSelectionOptions) |
 | GetSelection()()()() |
 | GetString(String) |
 | GetString(PromptStringOptions) |
 | GetType()()()() | (Inherited from Object.)
 | GetViewportNumber(Point) |
 | InitCommandVersion(Int32) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDragging |
 | IsQuiescent |
 | IsQuiescentForTransparentCommand |
 | LeavingQuiescentState |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MouseHasMoved |
 | PointFilter |
 | PointMonitor |
 | PointToScreen(Point3d, Int32) |
 | PointToWorld(Point, Int32) |
 | PointToWorld(Point) |
 | PromptedForAngle |
 | PromptedForCorner |
 | PromptedForDistance |
 | PromptedForDouble |
 | PromptedForEntity |
 | PromptedForInteger |
 | PromptedForKeyword |
 | PromptedForNestedEntity |
 | PromptedForPoint |
 | PromptedForSelection |
 | PromptedForString |
 | PromptForEntityEnding |
 | PromptForSelectionEnding |
 | PromptingForAngle |
 | PromptingForCorner |
 | PromptingForDistance |
 | PromptingForDouble |
 | PromptingForEntity |
 | PromptingForInteger |
 | PromptingForKeyword |
 | PromptingForNestedEntity |
 | PromptingForPoint |
 | PromptingForSelection |
 | PromptingForString |
 | Regen()()()() |
 | Rollover |
 | SelectAll(SelectionFilter) |
 | SelectAll()()()() |
 | SelectCrossingPolygon(Point3dCollection, SelectionFilter) |
 | SelectCrossingPolygon(Point3dCollection) |
 | SelectCrossingWindow(Point3d, Point3d, SelectionFilter, Boolean) |
 | SelectCrossingWindow(Point3d, Point3d, SelectionFilter) |
 | SelectCrossingWindow(Point3d, Point3d) |
 | SelectFence(Point3dCollection, SelectionFilter) |
 | SelectFence(Point3dCollection) |
 | SelectImplied()()()() |
 | SelectionAdded |
 | SelectionRemoved |
 | SelectLast()()()() |
 | SelectPrevious()()()() |
 | SelectWindow(Point3d, Point3d, SelectionFilter) |
 | SelectWindow(Point3d, Point3d) |
 | SelectWindowPolygon(Point3dCollection, SelectionFilter) |
 | SelectWindowPolygon(Point3dCollection) |
 | SetCurrentView(ViewTableRecord) |
 | SetImpliedSelection(array<ObjectId>[]()[][]) |
 | SetImpliedSelection(SelectionSet) |
 | Snap(String, Point3d) |
 | StartUserInteraction(Window) |
 | StartUserInteraction(Control) |
 | SwitchToModelSpace()()()() |
 | SwitchToPaperSpace()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TraceBoundary(Point3d, Boolean) |
 | TurnForcedPickOff()()()() |
 | TurnForcedPickOn()()()() |
 | UpdateScreen()()()() |
 | UpdateTiledViewportsFromDatabase()()()() |
 | UpdateTiledViewportsInDatabase()()()() |
 | UseCommandLineInterface |
 | ViewportIdFromNumber(Int32) |
 | WriteMessage(String, array<Object>[]()[][]) |
 | WriteMessage(String) |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Editor

Assembly: ZwManaged (Module: ZwManaged)


ActiveViewportId Property

ActiveViewportId Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »ActiveViewportId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ActiveViewportId { get; }
Public ReadOnly Property ActiveViewportId As ObjectId
    Get
public:
property ObjectId ActiveViewportId {
    ObjectId get ();
}

Assembly: ZwManaged (Module: ZwManaged)


CurrentUserCoordinateSystem Property

CurrentUserCoordinateSystem Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »CurrentUserCoordinateSystem
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d CurrentUserCoordinateSystem { get; set; }
Public Property CurrentUserCoordinateSystem As Matrix3d
    Get
    Set
public:
property Matrix3d CurrentUserCoordinateSystem {
    Matrix3d get ();
    void set (Matrix3d value);
}

Assembly: ZwManaged (Module: ZwManaged)


CurrentViewportObjectId Property

CurrentViewportObjectId Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »CurrentViewportObjectId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId CurrentViewportObjectId { get; }
Public ReadOnly Property CurrentViewportObjectId As ObjectId
    Get
public:
property ObjectId CurrentViewportObjectId {
    ObjectId get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Document Property

Document Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »Document
Declaration Syntax
C# Visual Basic Visual C++
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
public:
property Document^ Document {
    Document^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DoPrompt Method (opt)

DoPrompt Method (opt)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »DoPrompt(PromptOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult DoPrompt(
    PromptOptions opt
)
Public Function DoPrompt ( _
    opt As PromptOptions _
) As PromptResult
public:
PromptResult^ DoPrompt(
    PromptOptions^ opt
)
Parameters
opt(PromptOptions)

Assembly: ZwManaged (Module: ZwManaged)


Drag Method

Drag Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »Drag()()()()
Members
Icon | Member | Description
 | Drag(SelectionSet, String, DragCallback) |
 | Drag(PromptDragOptions) |
 | Drag(Jig) |

Assembly: ZwManaged (Module: ZwManaged)


Drag Method (jig)

Drag Method (jig)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »Drag(Jig)
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult Drag(
    Jig jig
)
Public Function Drag ( _
    jig As Jig _
) As PromptResult
public:
PromptResult^ Drag(
    Jig^ jig
)
Parameters
jig(Jig)

Assembly: ZwManaged (Module: ZwManaged)


Drag Method (options)

Drag Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »Drag(PromptDragOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult Drag(
    PromptDragOptions options
)
Public Function Drag ( _
    options As PromptDragOptions _
) As PromptPointResult
public:
PromptPointResult^ Drag(
    PromptDragOptions^ options
)
Parameters
options(PromptDragOptions)

Assembly: ZwManaged (Module: ZwManaged)


Drag Method (selection, message, callback)

Drag Method (selection, message, callback)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »Drag(SelectionSet, String, DragCallback)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult Drag(
    SelectionSet selection,
    string message,
    DragCallback callback
)
Public Function Drag ( _
    selection As SelectionSet, _
    message As String, _
    callback As DragCallback _
) As PromptPointResult
public:
PromptPointResult^ Drag(
    SelectionSet^ selection,
    String^ message,
    DragCallback^ callback
)
Parameters
selection(SelectionSet)
message(String)
callback(DragCallback)

Assembly: ZwManaged (Module: ZwManaged)


Dragging Event

Dragging Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »Dragging
Declaration Syntax
C# Visual Basic Visual C++
public event DraggingEventHandler Dragging
Public Event Dragging As DraggingEventHandler
public:
 event DraggingEventHandler^ Dragging {
    void add (DraggingEventHandler^ value);
    void remove (DraggingEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DraggingEnded Event

DraggingEnded Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »DraggingEnded
Declaration Syntax
C# Visual Basic Visual C++
public event DraggingEndedEventHandler DraggingEnded
Public Event DraggingEnded As DraggingEndedEventHandler
public:
 event DraggingEndedEventHandler^ DraggingEnded {
    void add (DraggingEndedEventHandler^ value);
    void remove (DraggingEndedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DrawVector Method (from, to, color, drawHighlighted)

DrawVector Method (from, to, color, drawHighlighted)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »DrawVector(Point3d, Point3d, Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void DrawVector(
    Point3d from,
    Point3d to,
    int color,
    bool drawHighlighted
)
Public Sub DrawVector ( _
    from As Point3d, _
    to As Point3d, _
    color As Integer, _
    drawHighlighted As Boolean _
)
public:
void DrawVector(
    Point3d from,
    Point3d to,
    int color,
    bool drawHighlighted
)
Parameters
from(Point3d)
to(Point3d)
color(Int32)
drawHighlighted(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


DrawVectors Method (rb, transform)

DrawVectors Method (rb, transform)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »DrawVectors(ResultBuffer, Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public void DrawVectors(
    ResultBuffer rb,
    Matrix3d transform
)
Public Sub DrawVectors ( _
    rb As ResultBuffer, _
    transform As Matrix3d _
)
public:
void DrawVectors(
    ResultBuffer^ rb,
    Matrix3d transform
)
Parameters
rb(ResultBuffer)
transform(Matrix3d)

Assembly: ZwManaged (Module: ZwManaged)


EnteringQuiescentState Event

EnteringQuiescentState Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »EnteringQuiescentState
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler EnteringQuiescentState
Public Event EnteringQuiescentState As EventHandler
public:
 event EventHandler^ EnteringQuiescentState {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


GetAngle Method

GetAngle Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetAngle()()()()
Members
Icon | Member | Description
 | GetAngle(String) |
 | GetAngle(PromptAngleOptions) |

Assembly: ZwManaged (Module: ZwManaged)


GetAngle Method (message)

GetAngle Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetAngle(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult GetAngle(
    string message
)
Public Function GetAngle ( _
    message As String _
) As PromptDoubleResult
public:
PromptDoubleResult^ GetAngle(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


GetAngle Method (options)

GetAngle Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetAngle(PromptAngleOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult GetAngle(
    PromptAngleOptions options
)
Public Function GetAngle ( _
    options As PromptAngleOptions _
) As PromptDoubleResult
public:
PromptDoubleResult^ GetAngle(
    PromptAngleOptions^ options
)
Parameters
options(PromptAngleOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetCommandVersion Method

GetCommandVersion Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetCommandVersion()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int GetCommandVersion()
Public Function GetCommandVersion As Integer
public:
int GetCommandVersion()

Assembly: ZwManaged (Module: ZwManaged)


GetCorner Method

GetCorner Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetCorner()()()()
Members
Icon | Member | Description
 | GetCorner(String, Point3d) |
 | GetCorner(PromptCornerOptions) |

Assembly: ZwManaged (Module: ZwManaged)


GetCorner Method (message, basePoint)

GetCorner Method (message, basePoint)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetCorner(String, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult GetCorner(
    string message,
    Point3d basePoint
)
Public Function GetCorner ( _
    message As String, _
    basePoint As Point3d _
) As PromptPointResult
public:
PromptPointResult^ GetCorner(
    String^ message,
    Point3d basePoint
)
Parameters
message(String)
basePoint(Point3d)

Assembly: ZwManaged (Module: ZwManaged)


GetCorner Method (options)

GetCorner Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetCorner(PromptCornerOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult GetCorner(
    PromptCornerOptions options
)
Public Function GetCorner ( _
    options As PromptCornerOptions _
) As PromptPointResult
public:
PromptPointResult^ GetCorner(
    PromptCornerOptions^ options
)
Parameters
options(PromptCornerOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetCurrentView Method

GetCurrentView Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetCurrentView()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ViewTableRecord GetCurrentView()
Public Function GetCurrentView As ViewTableRecord
public:
ViewTableRecord^ GetCurrentView()

Assembly: ZwManaged (Module: ZwManaged)


GetDistance Method

GetDistance Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetDistance()()()()
Members
Icon | Member | Description
 | GetDistance(String) |
 | GetDistance(PromptDistanceOptions) |

Assembly: ZwManaged (Module: ZwManaged)


GetDistance Method (message)

GetDistance Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetDistance(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult GetDistance(
    string message
)
Public Function GetDistance ( _
    message As String _
) As PromptDoubleResult
public:
PromptDoubleResult^ GetDistance(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


GetDistance Method (options)

GetDistance Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetDistance(PromptDistanceOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult GetDistance(
    PromptDistanceOptions options
)
Public Function GetDistance ( _
    options As PromptDistanceOptions _
) As PromptDoubleResult
public:
PromptDoubleResult^ GetDistance(
    PromptDistanceOptions^ options
)
Parameters
options(PromptDistanceOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetDouble Method

GetDouble Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetDouble()()()()
Members
Icon | Member | Description
 | GetDouble(String) |
 | GetDouble(PromptDoubleOptions) |

Assembly: ZwManaged (Module: ZwManaged)


GetDouble Method (message)

GetDouble Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetDouble(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult GetDouble(
    string message
)
Public Function GetDouble ( _
    message As String _
) As PromptDoubleResult
public:
PromptDoubleResult^ GetDouble(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


GetDouble Method (options)

GetDouble Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetDouble(PromptDoubleOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult GetDouble(
    PromptDoubleOptions options
)
Public Function GetDouble ( _
    options As PromptDoubleOptions _
) As PromptDoubleResult
public:
PromptDoubleResult^ GetDouble(
    PromptDoubleOptions^ options
)
Parameters
options(PromptDoubleOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetEntity Method

GetEntity Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetEntity()()()()
Members
Icon | Member | Description
 | GetEntity(String) |
 | GetEntity(PromptEntityOptions) |

Assembly: ZwManaged (Module: ZwManaged)


GetEntity Method (message)

GetEntity Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetEntity(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptEntityResult GetEntity(
    string message
)
Public Function GetEntity ( _
    message As String _
) As PromptEntityResult
public:
PromptEntityResult^ GetEntity(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


GetEntity Method (options)

GetEntity Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetEntity(PromptEntityOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptEntityResult GetEntity(
    PromptEntityOptions options
)
Public Function GetEntity ( _
    options As PromptEntityOptions _
) As PromptEntityResult
public:
PromptEntityResult^ GetEntity(
    PromptEntityOptions^ options
)
Parameters
options(PromptEntityOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetFileNameForOpen Method

GetFileNameForOpen Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetFileNameForOpen()()()()
Members
Icon | Member | Description
 | GetFileNameForOpen(PromptOpenFileOptions) |
 | GetFileNameForOpen(String) |

Assembly: ZwManaged (Module: ZwManaged)


GetFileNameForOpen Method (message)

GetFileNameForOpen Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetFileNameForOpen(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptFileNameResult GetFileNameForOpen(
    string message
)
Public Function GetFileNameForOpen ( _
    message As String _
) As PromptFileNameResult
public:
PromptFileNameResult^ GetFileNameForOpen(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


GetFileNameForOpen Method (options)

GetFileNameForOpen Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetFileNameForOpen(PromptOpenFileOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptFileNameResult GetFileNameForOpen(
    PromptOpenFileOptions options
)
Public Function GetFileNameForOpen ( _
    options As PromptOpenFileOptions _
) As PromptFileNameResult
public:
PromptFileNameResult^ GetFileNameForOpen(
    PromptOpenFileOptions^ options
)
Parameters
options(PromptOpenFileOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetFileNameForSave Method

GetFileNameForSave Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetFileNameForSave()()()()
Members
Icon | Member | Description
 | GetFileNameForSave(PromptSaveFileOptions) |
 | GetFileNameForSave(String) |

Assembly: ZwManaged (Module: ZwManaged)


GetFileNameForSave Method (message)

GetFileNameForSave Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetFileNameForSave(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptFileNameResult GetFileNameForSave(
    string message
)
Public Function GetFileNameForSave ( _
    message As String _
) As PromptFileNameResult
public:
PromptFileNameResult^ GetFileNameForSave(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


GetFileNameForSave Method (options)

GetFileNameForSave Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetFileNameForSave(PromptSaveFileOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptFileNameResult GetFileNameForSave(
    PromptSaveFileOptions options
)
Public Function GetFileNameForSave ( _
    options As PromptSaveFileOptions _
) As PromptFileNameResult
public:
PromptFileNameResult^ GetFileNameForSave(
    PromptSaveFileOptions^ options
)
Parameters
options(PromptSaveFileOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetInteger Method

GetInteger Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetInteger()()()()
Members
Icon | Member | Description
 | GetInteger(String) |
 | GetInteger(PromptIntegerOptions) |

Assembly: ZwManaged (Module: ZwManaged)


GetInteger Method (message)

GetInteger Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetInteger(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptIntegerResult GetInteger(
    string message
)
Public Function GetInteger ( _
    message As String _
) As PromptIntegerResult
public:
PromptIntegerResult^ GetInteger(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


GetInteger Method (options)

GetInteger Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetInteger(PromptIntegerOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptIntegerResult GetInteger(
    PromptIntegerOptions options
)
Public Function GetInteger ( _
    options As PromptIntegerOptions _
) As PromptIntegerResult
public:
PromptIntegerResult^ GetInteger(
    PromptIntegerOptions^ options
)
Parameters
options(PromptIntegerOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetKeywords Method

GetKeywords Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetKeywords()()()()
Members
Icon | Member | Description
 | GetKeywords(String, array<String>[]()[][]) |
 | GetKeywords(PromptKeywordOptions) |

Assembly: ZwManaged (Module: ZwManaged)


GetKeywords Method (message, globalKeywords)

GetKeywords Method (message, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetKeywords(String, array<String>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult GetKeywords(
    string message,
    params string[] globalKeywords
)
Public Function GetKeywords ( _
    message As String, _
    ParamArray globalKeywords As String() _
) As PromptResult
public:
PromptResult^ GetKeywords(
    String^ message,
    ... array<String^>^ globalKeywords
)
Parameters
message(String)
globalKeywords(array<String>[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


GetKeywords Method (options)

GetKeywords Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetKeywords(PromptKeywordOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult GetKeywords(
    PromptKeywordOptions options
)
Public Function GetKeywords ( _
    options As PromptKeywordOptions _
) As PromptResult
public:
PromptResult^ GetKeywords(
    PromptKeywordOptions^ options
)
Parameters
options(PromptKeywordOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetNestedEntity Method

GetNestedEntity Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetNestedEntity()()()()
Members
Icon | Member | Description
 | GetNestedEntity(String) |
 | GetNestedEntity(PromptNestedEntityOptions) |

Assembly: ZwManaged (Module: ZwManaged)


GetNestedEntity Method (message)

GetNestedEntity Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetNestedEntity(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptNestedEntityResult GetNestedEntity(
    string message
)
Public Function GetNestedEntity ( _
    message As String _
) As PromptNestedEntityResult
public:
PromptNestedEntityResult^ GetNestedEntity(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


GetNestedEntity Method (options)

GetNestedEntity Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetNestedEntity(PromptNestedEntityOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptNestedEntityResult GetNestedEntity(
    PromptNestedEntityOptions options
)
Public Function GetNestedEntity ( _
    options As PromptNestedEntityOptions _
) As PromptNestedEntityResult
public:
PromptNestedEntityResult^ GetNestedEntity(
    PromptNestedEntityOptions^ options
)
Parameters
options(PromptNestedEntityOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetPoint Method

GetPoint Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetPoint()()()()
Members
Icon | Member | Description
 | GetPoint(String) |
 | GetPoint(PromptPointOptions) |

Assembly: ZwManaged (Module: ZwManaged)


GetPoint Method (message)

GetPoint Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetPoint(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult GetPoint(
    string message
)
Public Function GetPoint ( _
    message As String _
) As PromptPointResult
public:
PromptPointResult^ GetPoint(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


GetPoint Method (options)

GetPoint Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetPoint(PromptPointOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult GetPoint(
    PromptPointOptions options
)
Public Function GetPoint ( _
    options As PromptPointOptions _
) As PromptPointResult
public:
PromptPointResult^ GetPoint(
    PromptPointOptions^ options
)
Parameters
options(PromptPointOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetSelection Method

GetSelection Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetSelection()()()()
Members
Icon | Member | Description
 | GetSelection(PromptSelectionOptions, SelectionFilter) |
 | GetSelection(SelectionFilter) |
 | GetSelection(PromptSelectionOptions) |
 | GetSelection()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetSelection Method

GetSelection Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetSelection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult GetSelection()
Public Function GetSelection As PromptSelectionResult
public:
PromptSelectionResult^ GetSelection()

Assembly: ZwManaged (Module: ZwManaged)


GetSelection Method (options)

GetSelection Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetSelection(PromptSelectionOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult GetSelection(
    PromptSelectionOptions options
)
Public Function GetSelection ( _
    options As PromptSelectionOptions _
) As PromptSelectionResult
public:
PromptSelectionResult^ GetSelection(
    PromptSelectionOptions^ options
)
Parameters
options(PromptSelectionOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetSelection Method (options, filter)

GetSelection Method (options, filter)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetSelection(PromptSelectionOptions, SelectionFilter)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult GetSelection(
    PromptSelectionOptions options,
    SelectionFilter filter
)
Public Function GetSelection ( _
    options As PromptSelectionOptions, _
    filter As SelectionFilter _
) As PromptSelectionResult
public:
PromptSelectionResult^ GetSelection(
    PromptSelectionOptions^ options,
    SelectionFilter^ filter
)
Parameters
options(PromptSelectionOptions)
filter(SelectionFilter)

Assembly: ZwManaged (Module: ZwManaged)


GetSelection Method (filter)

GetSelection Method (filter)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetSelection(SelectionFilter)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult GetSelection(
    SelectionFilter filter
)
Public Function GetSelection ( _
    filter As SelectionFilter _
) As PromptSelectionResult
public:
PromptSelectionResult^ GetSelection(
    SelectionFilter^ filter
)
Parameters
filter(SelectionFilter)

Assembly: ZwManaged (Module: ZwManaged)


GetString Method

GetString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetString()()()()
Members
Icon | Member | Description
 | GetString(String) |
 | GetString(PromptStringOptions) |

Assembly: ZwManaged (Module: ZwManaged)


GetString Method (message)

GetString Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetString(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult GetString(
    string message
)
Public Function GetString ( _
    message As String _
) As PromptResult
public:
PromptResult^ GetString(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


GetString Method (options)

GetString Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetString(PromptStringOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult GetString(
    PromptStringOptions options
)
Public Function GetString ( _
    options As PromptStringOptions _
) As PromptResult
public:
PromptResult^ GetString(
    PromptStringOptions^ options
)
Parameters
options(PromptStringOptions)

Assembly: ZwManaged (Module: ZwManaged)


GetViewportNumber Method (point)

GetViewportNumber Method (point)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »GetViewportNumber(Point)
Declaration Syntax
C# Visual Basic Visual C++
public int GetViewportNumber(
    Point point
)
Public Function GetViewportNumber ( _
    point As Point _
) As Integer
public:
int GetViewportNumber(
    Point point
)
Parameters
point(Point)

Assembly: ZwManaged (Module: ZwManaged)


InitCommandVersion Method (nVersion)

InitCommandVersion Method (nVersion)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »InitCommandVersion(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int InitCommandVersion(
    int nVersion
)
Public Function InitCommandVersion ( _
    nVersion As Integer _
) As Integer
public:
int InitCommandVersion(
    int nVersion
)
Parameters
nVersion(Int32)

Assembly: ZwManaged (Module: ZwManaged)


IsDragging Property

IsDragging Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »IsDragging
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDragging { get; }
Public ReadOnly Property IsDragging As Boolean
    Get
public:
property bool IsDragging {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsQuiescent Property

IsQuiescent Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »IsQuiescent
Declaration Syntax
C# Visual Basic Visual C++
public bool IsQuiescent { get; }
Public ReadOnly Property IsQuiescent As Boolean
    Get
public:
property bool IsQuiescent {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsQuiescentForTransparentCommand Property

IsQuiescentForTransparentCommand Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »IsQuiescentForTransparentCommand
Declaration Syntax
C# Visual Basic Visual C++
public bool IsQuiescentForTransparentCommand { get; }
Public ReadOnly Property IsQuiescentForTransparentCommand As Boolean
    Get
public:
property bool IsQuiescentForTransparentCommand {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LeavingQuiescentState Event

LeavingQuiescentState Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »LeavingQuiescentState
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler LeavingQuiescentState
Public Event LeavingQuiescentState As EventHandler
public:
 event EventHandler^ LeavingQuiescentState {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


MouseHasMoved Property

MouseHasMoved Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »MouseHasMoved
Declaration Syntax
C# Visual Basic Visual C++
public bool MouseHasMoved { get; }
Public ReadOnly Property MouseHasMoved As Boolean
    Get
public:
property bool MouseHasMoved {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PointFilter Event

PointFilter Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PointFilter
Declaration Syntax
C# Visual Basic Visual C++
public event PointFilterEventHandler PointFilter
Public Event PointFilter As PointFilterEventHandler
public:
 event PointFilterEventHandler^ PointFilter {
    void add (PointFilterEventHandler^ value);
    void remove (PointFilterEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PointMonitor Event

PointMonitor Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PointMonitor
Declaration Syntax
C# Visual Basic Visual C++
public event PointMonitorEventHandler PointMonitor
Public Event PointMonitor As PointMonitorEventHandler
public:
 event PointMonitorEventHandler^ PointMonitor {
    void add (PointMonitorEventHandler^ value);
    void remove (PointMonitorEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PointToScreen Method (pt, viewportNumber)

PointToScreen Method (pt, viewportNumber)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PointToScreen(Point3d, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point PointToScreen(
    Point3d pt,
    int viewportNumber
)
Public Function PointToScreen ( _
    pt As Point3d, _
    viewportNumber As Integer _
) As Point
public:
Point PointToScreen(
    Point3d pt,
    int viewportNumber
)
Parameters
pt(Point3d)
viewportNumber(Int32)

Assembly: ZwManaged (Module: ZwManaged)


PointToWorld Method

PointToWorld Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PointToWorld()()()()
Members
Icon | Member | Description
 | PointToWorld(Point, Int32) |
 | PointToWorld(Point) |

Assembly: ZwManaged (Module: ZwManaged)


PointToWorld Method (pt)

PointToWorld Method (pt)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PointToWorld(Point)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d PointToWorld(
    Point pt
)
Public Function PointToWorld ( _
    pt As Point _
) As Point3d
public:
Point3d PointToWorld(
    Point pt
)
Parameters
pt(Point)

Assembly: ZwManaged (Module: ZwManaged)


PointToWorld Method (pt, viewportNumber)

PointToWorld Method (pt, viewportNumber)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PointToWorld(Point, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d PointToWorld(
    Point pt,
    int viewportNumber
)
Public Function PointToWorld ( _
    pt As Point, _
    viewportNumber As Integer _
) As Point3d
public:
Point3d PointToWorld(
    Point pt,
    int viewportNumber
)
Parameters
pt(Point)
viewportNumber(Int32)

Assembly: ZwManaged (Module: ZwManaged)


PromptedForAngle Event

PromptedForAngle Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForAngle
Declaration Syntax
C# Visual Basic Visual C++
public event PromptDoubleResultEventHandler PromptedForAngle
Public Event PromptedForAngle As PromptDoubleResultEventHandler
public:
 event PromptDoubleResultEventHandler^ PromptedForAngle {
    void add (PromptDoubleResultEventHandler^ value);
    void remove (PromptDoubleResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptedForCorner Event

PromptedForCorner Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForCorner
Declaration Syntax
C# Visual Basic Visual C++
public event PromptPointResultEventHandler PromptedForCorner
Public Event PromptedForCorner As PromptPointResultEventHandler
public:
 event PromptPointResultEventHandler^ PromptedForCorner {
    void add (PromptPointResultEventHandler^ value);
    void remove (PromptPointResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptedForDistance Event

PromptedForDistance Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForDistance
Declaration Syntax
C# Visual Basic Visual C++
public event PromptDoubleResultEventHandler PromptedForDistance
Public Event PromptedForDistance As PromptDoubleResultEventHandler
public:
 event PromptDoubleResultEventHandler^ PromptedForDistance {
    void add (PromptDoubleResultEventHandler^ value);
    void remove (PromptDoubleResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptedForDouble Event

PromptedForDouble Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForDouble
Declaration Syntax
C# Visual Basic Visual C++
public event PromptDoubleResultEventHandler PromptedForDouble
Public Event PromptedForDouble As PromptDoubleResultEventHandler
public:
 event PromptDoubleResultEventHandler^ PromptedForDouble {
    void add (PromptDoubleResultEventHandler^ value);
    void remove (PromptDoubleResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptedForEntity Event

PromptedForEntity Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForEntity
Declaration Syntax
C# Visual Basic Visual C++
public event PromptEntityResultEventHandler PromptedForEntity
Public Event PromptedForEntity As PromptEntityResultEventHandler
public:
 event PromptEntityResultEventHandler^ PromptedForEntity {
    void add (PromptEntityResultEventHandler^ value);
    void remove (PromptEntityResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptedForInteger Event

PromptedForInteger Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForInteger
Declaration Syntax
C# Visual Basic Visual C++
public event PromptIntegerResultEventHandler PromptedForInteger
Public Event PromptedForInteger As PromptIntegerResultEventHandler
public:
 event PromptIntegerResultEventHandler^ PromptedForInteger {
    void add (PromptIntegerResultEventHandler^ value);
    void remove (PromptIntegerResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptedForKeyword Event

PromptedForKeyword Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForKeyword
Declaration Syntax
C# Visual Basic Visual C++
public event PromptStringResultEventHandler PromptedForKeyword
Public Event PromptedForKeyword As PromptStringResultEventHandler
public:
 event PromptStringResultEventHandler^ PromptedForKeyword {
    void add (PromptStringResultEventHandler^ value);
    void remove (PromptStringResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptedForNestedEntity Event

PromptedForNestedEntity Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForNestedEntity
Declaration Syntax
C# Visual Basic Visual C++
public event PromptNestedEntityResultEventHandler PromptedForNestedEntity
Public Event PromptedForNestedEntity As PromptNestedEntityResultEventHandler
public:
 event PromptNestedEntityResultEventHandler^ PromptedForNestedEntity {
    void add (PromptNestedEntityResultEventHandler^ value);
    void remove (PromptNestedEntityResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptedForPoint Event

PromptedForPoint Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForPoint
Declaration Syntax
C# Visual Basic Visual C++
public event PromptPointResultEventHandler PromptedForPoint
Public Event PromptedForPoint As PromptPointResultEventHandler
public:
 event PromptPointResultEventHandler^ PromptedForPoint {
    void add (PromptPointResultEventHandler^ value);
    void remove (PromptPointResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptedForSelection Event

PromptedForSelection Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForSelection
Declaration Syntax
C# Visual Basic Visual C++
public event PromptSelectionResultEventHandler PromptedForSelection
Public Event PromptedForSelection As PromptSelectionResultEventHandler
public:
 event PromptSelectionResultEventHandler^ PromptedForSelection {
    void add (PromptSelectionResultEventHandler^ value);
    void remove (PromptSelectionResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptedForString Event

PromptedForString Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptedForString
Declaration Syntax
C# Visual Basic Visual C++
public event PromptStringResultEventHandler PromptedForString
Public Event PromptedForString As PromptStringResultEventHandler
public:
 event PromptStringResultEventHandler^ PromptedForString {
    void add (PromptStringResultEventHandler^ value);
    void remove (PromptStringResultEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptForEntityEnding Event

PromptForEntityEnding Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptForEntityEnding
Declaration Syntax
C# Visual Basic Visual C++
public event PromptForEntityEndingEventHandler PromptForEntityEnding
Public Event PromptForEntityEnding As PromptForEntityEndingEventHandler
public:
 event PromptForEntityEndingEventHandler^ PromptForEntityEnding {
    void add (PromptForEntityEndingEventHandler^ value);
    void remove (PromptForEntityEndingEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptForSelectionEnding Event

PromptForSelectionEnding Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptForSelectionEnding
Declaration Syntax
C# Visual Basic Visual C++
public event PromptForSelectionEndingEventHandler PromptForSelectionEnding
Public Event PromptForSelectionEnding As PromptForSelectionEndingEventHandler
public:
 event PromptForSelectionEndingEventHandler^ PromptForSelectionEnding {
    void add (PromptForSelectionEndingEventHandler^ value);
    void remove (PromptForSelectionEndingEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForAngle Event

PromptingForAngle Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForAngle
Declaration Syntax
C# Visual Basic Visual C++
public event PromptAngleOptionsEventHandler PromptingForAngle
Public Event PromptingForAngle As PromptAngleOptionsEventHandler
public:
 event PromptAngleOptionsEventHandler^ PromptingForAngle {
    void add (PromptAngleOptionsEventHandler^ value);
    void remove (PromptAngleOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForCorner Event

PromptingForCorner Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForCorner
Declaration Syntax
C# Visual Basic Visual C++
public event PromptPointOptionsEventHandler PromptingForCorner
Public Event PromptingForCorner As PromptPointOptionsEventHandler
public:
 event PromptPointOptionsEventHandler^ PromptingForCorner {
    void add (PromptPointOptionsEventHandler^ value);
    void remove (PromptPointOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForDistance Event

PromptingForDistance Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForDistance
Declaration Syntax
C# Visual Basic Visual C++
public event PromptDistanceOptionsEventHandler PromptingForDistance
Public Event PromptingForDistance As PromptDistanceOptionsEventHandler
public:
 event PromptDistanceOptionsEventHandler^ PromptingForDistance {
    void add (PromptDistanceOptionsEventHandler^ value);
    void remove (PromptDistanceOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForDouble Event

PromptingForDouble Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForDouble
Declaration Syntax
C# Visual Basic Visual C++
public event PromptDoubleOptionsEventHandler PromptingForDouble
Public Event PromptingForDouble As PromptDoubleOptionsEventHandler
public:
 event PromptDoubleOptionsEventHandler^ PromptingForDouble {
    void add (PromptDoubleOptionsEventHandler^ value);
    void remove (PromptDoubleOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForEntity Event

PromptingForEntity Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForEntity
Declaration Syntax
C# Visual Basic Visual C++
public event PromptEntityOptionsEventHandler PromptingForEntity
Public Event PromptingForEntity As PromptEntityOptionsEventHandler
public:
 event PromptEntityOptionsEventHandler^ PromptingForEntity {
    void add (PromptEntityOptionsEventHandler^ value);
    void remove (PromptEntityOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForInteger Event

PromptingForInteger Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForInteger
Declaration Syntax
C# Visual Basic Visual C++
public event PromptIntegerOptionsEventHandler PromptingForInteger
Public Event PromptingForInteger As PromptIntegerOptionsEventHandler
public:
 event PromptIntegerOptionsEventHandler^ PromptingForInteger {
    void add (PromptIntegerOptionsEventHandler^ value);
    void remove (PromptIntegerOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForKeyword Event

PromptingForKeyword Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForKeyword
Declaration Syntax
C# Visual Basic Visual C++
public event PromptKeywordOptionsEventHandler PromptingForKeyword
Public Event PromptingForKeyword As PromptKeywordOptionsEventHandler
public:
 event PromptKeywordOptionsEventHandler^ PromptingForKeyword {
    void add (PromptKeywordOptionsEventHandler^ value);
    void remove (PromptKeywordOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForNestedEntity Event

PromptingForNestedEntity Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForNestedEntity
Declaration Syntax
C# Visual Basic Visual C++
public event PromptNestedEntityOptionsEventHandler PromptingForNestedEntity
Public Event PromptingForNestedEntity As PromptNestedEntityOptionsEventHandler
public:
 event PromptNestedEntityOptionsEventHandler^ PromptingForNestedEntity {
    void add (PromptNestedEntityOptionsEventHandler^ value);
    void remove (PromptNestedEntityOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForPoint Event

PromptingForPoint Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForPoint
Declaration Syntax
C# Visual Basic Visual C++
public event PromptPointOptionsEventHandler PromptingForPoint
Public Event PromptingForPoint As PromptPointOptionsEventHandler
public:
 event PromptPointOptionsEventHandler^ PromptingForPoint {
    void add (PromptPointOptionsEventHandler^ value);
    void remove (PromptPointOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForSelection Event

PromptingForSelection Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForSelection
Declaration Syntax
C# Visual Basic Visual C++
public event PromptSelectionOptionsEventHandler PromptingForSelection
Public Event PromptingForSelection As PromptSelectionOptionsEventHandler
public:
 event PromptSelectionOptionsEventHandler^ PromptingForSelection {
    void add (PromptSelectionOptionsEventHandler^ value);
    void remove (PromptSelectionOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptingForString Event

PromptingForString Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »PromptingForString
Declaration Syntax
C# Visual Basic Visual C++
public event PromptStringOptionsEventHandler PromptingForString
Public Event PromptingForString As PromptStringOptionsEventHandler
public:
 event PromptStringOptionsEventHandler^ PromptingForString {
    void add (PromptStringOptionsEventHandler^ value);
    void remove (PromptStringOptionsEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Regen Method

Regen Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »Regen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Regen()
Public Sub Regen
public:
void Regen()

Assembly: ZwManaged (Module: ZwManaged)


Rollover Event

Rollover Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »Rollover
Declaration Syntax
C# Visual Basic Visual C++
public event RolloverEventHandler Rollover
Public Event Rollover As RolloverEventHandler
public:
 event RolloverEventHandler^ Rollover {
    void add (RolloverEventHandler^ value);
    void remove (RolloverEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


SelectAll Method

SelectAll Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectAll()()()()
Members
Icon | Member | Description
 | SelectAll(SelectionFilter) |
 | SelectAll()()()() |

Assembly: ZwManaged (Module: ZwManaged)


SelectAll Method

SelectAll Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectAll()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectAll()
Public Function SelectAll As PromptSelectionResult
public:
PromptSelectionResult^ SelectAll()

Assembly: ZwManaged (Module: ZwManaged)


SelectAll Method (filter)

SelectAll Method (filter)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectAll(SelectionFilter)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectAll(
    SelectionFilter filter
)
Public Function SelectAll ( _
    filter As SelectionFilter _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectAll(
    SelectionFilter^ filter
)
Parameters
filter(SelectionFilter)

Assembly: ZwManaged (Module: ZwManaged)


SelectCrossingPolygon Method

SelectCrossingPolygon Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectCrossingPolygon()()()()
Members
Icon | Member | Description
 | SelectCrossingPolygon(Point3dCollection, SelectionFilter) |
 | SelectCrossingPolygon(Point3dCollection) |

Assembly: ZwManaged (Module: ZwManaged)


SelectCrossingPolygon Method (polygon)

SelectCrossingPolygon Method (polygon)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectCrossingPolygon(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectCrossingPolygon(
    Point3dCollection polygon
)
Public Function SelectCrossingPolygon ( _
    polygon As Point3dCollection _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectCrossingPolygon(
    Point3dCollection^ polygon
)
Parameters
polygon(Point3dCollection)

Assembly: ZwManaged (Module: ZwManaged)


SelectCrossingPolygon Method (polygon, filter)

SelectCrossingPolygon Method (polygon, filter)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectCrossingPolygon(Point3dCollection, SelectionFilter)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectCrossingPolygon(
    Point3dCollection polygon,
    SelectionFilter filter
)
Public Function SelectCrossingPolygon ( _
    polygon As Point3dCollection, _
    filter As SelectionFilter _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectCrossingPolygon(
    Point3dCollection^ polygon,
    SelectionFilter^ filter
)
Parameters
polygon(Point3dCollection)
filter(SelectionFilter)

Assembly: ZwManaged (Module: ZwManaged)


SelectCrossingWindow Method

SelectCrossingWindow Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectCrossingWindow()()()()
Members
Icon | Member | Description
 | SelectCrossingWindow(Point3d, Point3d, SelectionFilter, Boolean) |
 | SelectCrossingWindow(Point3d, Point3d, SelectionFilter) |
 | SelectCrossingWindow(Point3d, Point3d) |

Assembly: ZwManaged (Module: ZwManaged)


SelectCrossingWindow Method (pt1, pt2)

SelectCrossingWindow Method (pt1, pt2)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectCrossingWindow(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectCrossingWindow(
    Point3d pt1,
    Point3d pt2
)
Public Function SelectCrossingWindow ( _
    pt1 As Point3d, _
    pt2 As Point3d _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectCrossingWindow(
    Point3d pt1,
    Point3d pt2
)
Parameters
pt1(Point3d)
pt2(Point3d)

Assembly: ZwManaged (Module: ZwManaged)


SelectCrossingWindow Method (pt1, pt2, filter)

SelectCrossingWindow Method (pt1, pt2, filter)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectCrossingWindow(Point3d, Point3d, SelectionFilter)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectCrossingWindow(
    Point3d pt1,
    Point3d pt2,
    SelectionFilter filter
)
Public Function SelectCrossingWindow ( _
    pt1 As Point3d, _
    pt2 As Point3d, _
    filter As SelectionFilter _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectCrossingWindow(
    Point3d pt1,
    Point3d pt2,
    SelectionFilter^ filter
)
Parameters
pt1(Point3d)
pt2(Point3d)
filter(SelectionFilter)

Assembly: ZwManaged (Module: ZwManaged)


SelectCrossingWindow Method (pt1, pt2, filter, forceSubEntitySelection)

SelectCrossingWindow Method (pt1, pt2, filter, forceSubEntitySelection)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectCrossingWindow(Point3d, Point3d, SelectionFilter, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectCrossingWindow(
    Point3d pt1,
    Point3d pt2,
    SelectionFilter filter,
    bool forceSubEntitySelection
)
Public Function SelectCrossingWindow ( _
    pt1 As Point3d, _
    pt2 As Point3d, _
    filter As SelectionFilter, _
    forceSubEntitySelection As Boolean _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectCrossingWindow(
    Point3d pt1,
    Point3d pt2,
    SelectionFilter^ filter,
    bool forceSubEntitySelection
)
Parameters
pt1(Point3d)
pt2(Point3d)
filter(SelectionFilter)
forceSubEntitySelection(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


SelectFence Method

SelectFence Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectFence()()()()
Members
Icon | Member | Description
 | SelectFence(Point3dCollection, SelectionFilter) |
 | SelectFence(Point3dCollection) |

Assembly: ZwManaged (Module: ZwManaged)


SelectFence Method (fence)

SelectFence Method (fence)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectFence(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectFence(
    Point3dCollection fence
)
Public Function SelectFence ( _
    fence As Point3dCollection _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectFence(
    Point3dCollection^ fence
)
Parameters
fence(Point3dCollection)

Assembly: ZwManaged (Module: ZwManaged)


SelectFence Method (fence, filter)

SelectFence Method (fence, filter)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectFence(Point3dCollection, SelectionFilter)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectFence(
    Point3dCollection fence,
    SelectionFilter filter
)
Public Function SelectFence ( _
    fence As Point3dCollection, _
    filter As SelectionFilter _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectFence(
    Point3dCollection^ fence,
    SelectionFilter^ filter
)
Parameters
fence(Point3dCollection)
filter(SelectionFilter)

Assembly: ZwManaged (Module: ZwManaged)


SelectImplied Method

SelectImplied Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectImplied()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectImplied()
Public Function SelectImplied As PromptSelectionResult
public:
PromptSelectionResult^ SelectImplied()

Assembly: ZwManaged (Module: ZwManaged)


SelectionAdded Event

SelectionAdded Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectionAdded
Declaration Syntax
C# Visual Basic Visual C++
public event SelectionAddedEventHandler SelectionAdded
Public Event SelectionAdded As SelectionAddedEventHandler
public:
 event SelectionAddedEventHandler^ SelectionAdded {
    void add (SelectionAddedEventHandler^ value);
    void remove (SelectionAddedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


SelectionRemoved Event

SelectionRemoved Event
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectionRemoved
Declaration Syntax
C# Visual Basic Visual C++
public event SelectionRemovedEventHandler SelectionRemoved
Public Event SelectionRemoved As SelectionRemovedEventHandler
public:
 event SelectionRemovedEventHandler^ SelectionRemoved {
    void add (SelectionRemovedEventHandler^ value);
    void remove (SelectionRemovedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


SelectLast Method

SelectLast Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectLast()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectLast()
Public Function SelectLast As PromptSelectionResult
public:
PromptSelectionResult^ SelectLast()

Assembly: ZwManaged (Module: ZwManaged)


SelectPrevious Method

SelectPrevious Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectPrevious()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectPrevious()
Public Function SelectPrevious As PromptSelectionResult
public:
PromptSelectionResult^ SelectPrevious()

Assembly: ZwManaged (Module: ZwManaged)


SelectWindow Method

SelectWindow Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectWindow()()()()
Members
Icon | Member | Description
 | SelectWindow(Point3d, Point3d, SelectionFilter) |
 | SelectWindow(Point3d, Point3d) |

Assembly: ZwManaged (Module: ZwManaged)


SelectWindow Method (pt1, pt2)

SelectWindow Method (pt1, pt2)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectWindow(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectWindow(
    Point3d pt1,
    Point3d pt2
)
Public Function SelectWindow ( _
    pt1 As Point3d, _
    pt2 As Point3d _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectWindow(
    Point3d pt1,
    Point3d pt2
)
Parameters
pt1(Point3d)
pt2(Point3d)

Assembly: ZwManaged (Module: ZwManaged)


SelectWindow Method (pt1, pt2, filter)

SelectWindow Method (pt1, pt2, filter)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectWindow(Point3d, Point3d, SelectionFilter)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectWindow(
    Point3d pt1,
    Point3d pt2,
    SelectionFilter filter
)
Public Function SelectWindow ( _
    pt1 As Point3d, _
    pt2 As Point3d, _
    filter As SelectionFilter _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectWindow(
    Point3d pt1,
    Point3d pt2,
    SelectionFilter^ filter
)
Parameters
pt1(Point3d)
pt2(Point3d)
filter(SelectionFilter)

Assembly: ZwManaged (Module: ZwManaged)


SelectWindowPolygon Method

SelectWindowPolygon Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectWindowPolygon()()()()
Members
Icon | Member | Description
 | SelectWindowPolygon(Point3dCollection, SelectionFilter) |
 | SelectWindowPolygon(Point3dCollection) |

Assembly: ZwManaged (Module: ZwManaged)


SelectWindowPolygon Method (polygon)

SelectWindowPolygon Method (polygon)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectWindowPolygon(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectWindowPolygon(
    Point3dCollection polygon
)
Public Function SelectWindowPolygon ( _
    polygon As Point3dCollection _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectWindowPolygon(
    Point3dCollection^ polygon
)
Parameters
polygon(Point3dCollection)

Assembly: ZwManaged (Module: ZwManaged)


SelectWindowPolygon Method (polygon, filter)

SelectWindowPolygon Method (polygon, filter)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SelectWindowPolygon(Point3dCollection, SelectionFilter)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult SelectWindowPolygon(
    Point3dCollection polygon,
    SelectionFilter filter
)
Public Function SelectWindowPolygon ( _
    polygon As Point3dCollection, _
    filter As SelectionFilter _
) As PromptSelectionResult
public:
PromptSelectionResult^ SelectWindowPolygon(
    Point3dCollection^ polygon,
    SelectionFilter^ filter
)
Parameters
polygon(Point3dCollection)
filter(SelectionFilter)

Assembly: ZwManaged (Module: ZwManaged)


SetCurrentView Method (value)

SetCurrentView Method (value)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SetCurrentView(ViewTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public void SetCurrentView(
    ViewTableRecord value
)
Public Sub SetCurrentView ( _
    value As ViewTableRecord _
)
public:
void SetCurrentView(
    ViewTableRecord^ value
)
Parameters
value(ViewTableRecord)

Assembly: ZwManaged (Module: ZwManaged)


SetImpliedSelection Method

SetImpliedSelection Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SetImpliedSelection()()()()
Members
Icon | Member | Description
 | SetImpliedSelection(array<ObjectId>[]()[][]) |
 | SetImpliedSelection(SelectionSet) |

Assembly: ZwManaged (Module: ZwManaged)


SetImpliedSelection Method (selectedObjects)

SetImpliedSelection Method (selectedObjects)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SetImpliedSelection(array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetImpliedSelection(
    ObjectId[] selectedObjects
)
Public Sub SetImpliedSelection ( _
    selectedObjects As ObjectId() _
)
public:
void SetImpliedSelection(
    array<ObjectId>^ selectedObjects
)
Parameters
selectedObjects(array< ObjectId >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


SetImpliedSelection Method (selectionSet)

SetImpliedSelection Method (selectionSet)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SetImpliedSelection(SelectionSet)
Declaration Syntax
C# Visual Basic Visual C++
public void SetImpliedSelection(
    SelectionSet selectionSet
)
Public Sub SetImpliedSelection ( _
    selectionSet As SelectionSet _
)
public:
void SetImpliedSelection(
    SelectionSet^ selectionSet
)
Parameters
selectionSet(SelectionSet)

Assembly: ZwManaged (Module: ZwManaged)


Snap Method (snapMode, input)

Snap Method (snapMode, input)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »Snap(String, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Snap(
    string snapMode,
    Point3d input
)
Public Function Snap ( _
    snapMode As String, _
    input As Point3d _
) As Point3d
public:
Point3d Snap(
    String^ snapMode,
    Point3d input
)
Parameters
snapMode(String)
input(Point3d)

Assembly: ZwManaged (Module: ZwManaged)


StartUserInteraction Method

StartUserInteraction Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »StartUserInteraction()()()()
Members
Icon | Member | Description
 | StartUserInteraction(Window) |
 | StartUserInteraction(Control) |

Assembly: ZwManaged (Module: ZwManaged)


StartUserInteraction Method (modalForm)

StartUserInteraction Method (modalForm)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »StartUserInteraction(Control)
Declaration Syntax
C# Visual Basic Visual C++
public EditorUserInteraction StartUserInteraction(
    Control modalForm
)
Public Function StartUserInteraction ( _
    modalForm As Control _
) As EditorUserInteraction
public:
EditorUserInteraction^ StartUserInteraction(
    Control^ modalForm
)
Parameters
modalForm(Control)

Assembly: ZwManaged (Module: ZwManaged)


StartUserInteraction Method (window)

StartUserInteraction Method (window)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »StartUserInteraction(Window)
Declaration Syntax
C# Visual Basic Visual C++
public EditorUserInteraction StartUserInteraction(
    Window window
)
Public Function StartUserInteraction ( _
    window As Window _
) As EditorUserInteraction
public:
EditorUserInteraction^ StartUserInteraction(
    Window^ window
)
Parameters
window(Window)

Assembly: ZwManaged (Module: ZwManaged)


SwitchToModelSpace Method

SwitchToModelSpace Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SwitchToModelSpace()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SwitchToModelSpace()
Public Sub SwitchToModelSpace
public:
void SwitchToModelSpace()

Assembly: ZwManaged (Module: ZwManaged)


SwitchToPaperSpace Method

SwitchToPaperSpace Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »SwitchToPaperSpace()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SwitchToPaperSpace()
Public Sub SwitchToPaperSpace
public:
void SwitchToPaperSpace()

Assembly: ZwManaged (Module: ZwManaged)


TraceBoundary Method (seedPoint, detectIslands)

TraceBoundary Method (seedPoint, detectIslands)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »TraceBoundary(Point3d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DBObjectCollection TraceBoundary(
    Point3d seedPoint,
    bool detectIslands
)
Public Function TraceBoundary ( _
    seedPoint As Point3d, _
    detectIslands As Boolean _
) As DBObjectCollection
public:
DBObjectCollection^ TraceBoundary(
    Point3d seedPoint,
    bool detectIslands
)
Parameters
seedPoint(Point3d)
detectIslands(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


TurnForcedPickOff Method

TurnForcedPickOff Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »TurnForcedPickOff()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int TurnForcedPickOff()
Public Function TurnForcedPickOff As Integer
public:
int TurnForcedPickOff()

Assembly: ZwManaged (Module: ZwManaged)


TurnForcedPickOn Method

TurnForcedPickOn Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »TurnForcedPickOn()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int TurnForcedPickOn()
Public Function TurnForcedPickOn As Integer
public:
int TurnForcedPickOn()

Assembly: ZwManaged (Module: ZwManaged)


UpdateScreen Method

UpdateScreen Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »UpdateScreen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateScreen()
Public Sub UpdateScreen
public:
void UpdateScreen()

Assembly: ZwManaged (Module: ZwManaged)


UpdateTiledViewportsFromDatabase Method

UpdateTiledViewportsFromDatabase Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »UpdateTiledViewportsFromDatabase()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateTiledViewportsFromDatabase()
Public Sub UpdateTiledViewportsFromDatabase
public:
void UpdateTiledViewportsFromDatabase()

Assembly: ZwManaged (Module: ZwManaged)


UpdateTiledViewportsInDatabase Method

UpdateTiledViewportsInDatabase Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »UpdateTiledViewportsInDatabase()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateTiledViewportsInDatabase()
Public Sub UpdateTiledViewportsInDatabase
public:
void UpdateTiledViewportsInDatabase()

Assembly: ZwManaged (Module: ZwManaged)


UseCommandLineInterface Property

UseCommandLineInterface Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »UseCommandLineInterface
Declaration Syntax
C# Visual Basic Visual C++
public bool UseCommandLineInterface { get; }
Public ReadOnly Property UseCommandLineInterface As Boolean
    Get
public:
property bool UseCommandLineInterface {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ViewportIdFromNumber Method (viewportNumber)

ViewportIdFromNumber Method (viewportNumber)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »ViewportIdFromNumber(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ViewportIdFromNumber(
    int viewportNumber
)
Public Function ViewportIdFromNumber ( _
    viewportNumber As Integer _
) As ObjectId
public:
ObjectId ViewportIdFromNumber(
    int viewportNumber
)
Parameters
viewportNumber(Int32)

Assembly: ZwManaged (Module: ZwManaged)


WriteMessage Method

WriteMessage Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »WriteMessage()()()()
Members
Icon | Member | Description
 | WriteMessage(String, array<Object>[]()[][]) |
 | WriteMessage(String) |

Assembly: ZwManaged (Module: ZwManaged)


WriteMessage Method (message)

WriteMessage Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »WriteMessage(String)
Declaration Syntax
C# Visual Basic Visual C++
public void WriteMessage(
    string message
)
Public Sub WriteMessage ( _
    message As String _
)
public:
void WriteMessage(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


WriteMessage Method (message, parameter)

WriteMessage Method (message, parameter)
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »WriteMessage(String, array<Object>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void WriteMessage(
    string message,
    params Object[] parameter
)
Public Sub WriteMessage ( _
    message As String, _
    ParamArray parameter As Object() _
)
public:
void WriteMessage(
    String^ message,
    ... array<Object^>^ parameter
)
Parameters
message(String)
parameter(array<Object>[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


EditorUserInteraction Class

EditorUserInteraction Class
Namespaces »ZwSoft.ZwCAD.EditorInput »EditorUserInteraction
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EditorUserInteraction : IDisposable
Public NotInheritable Class EditorUserInteraction _
    Implements IDisposable
public ref class EditorUserInteraction sealed : IDisposable
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Dispose()()()() |
 | End()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
EditorUserInteraction

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »EditorUserInteraction »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


End Method

End Method
Namespaces »ZwSoft.ZwCAD.EditorInput »EditorUserInteraction »End()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void End()
Public Sub End
public:
void End()

Assembly: ZwManaged (Module: ZwManaged)


EditorVisualStyle Class

EditorVisualStyle Class
Namespaces »ZwSoft.ZwCAD.EditorInput »EditorVisualStyle
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EditorVisualStyle
Public NotInheritable Class EditorVisualStyle
public ref class EditorVisualStyle sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditorVisualStyle()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsVS2dType |
 | IsVS3dType |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | setCvpVS2d()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
EditorVisualStyle

Assembly: ZwManaged (Module: ZwManaged)


EditorVisualStyle Constructor

EditorVisualStyle Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »EditorVisualStyle »EditorVisualStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EditorVisualStyle()
Public Sub New
public:
EditorVisualStyle()

Assembly: ZwManaged (Module: ZwManaged)


IsVS2dType Property

IsVS2dType Property
Namespaces »ZwSoft.ZwCAD.EditorInput »EditorVisualStyle »IsVS2dType
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVS2dType { get; }
Public Shared ReadOnly Property IsVS2dType As Boolean
    Get
public:
static property bool IsVS2dType {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsVS3dType Property

IsVS3dType Property
Namespaces »ZwSoft.ZwCAD.EditorInput »EditorVisualStyle »IsVS3dType
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVS3dType { get; }
Public Shared ReadOnly Property IsVS3dType As Boolean
    Get
public:
static property bool IsVS3dType {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


setCvpVS2d Method

setCvpVS2d Method
Namespaces »ZwSoft.ZwCAD.EditorInput »EditorVisualStyle »setCvpVS2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static void setCvpVS2d()
Public Shared Sub setCvpVS2d
public:
static void setCvpVS2d()

Assembly: ZwManaged (Module: ZwManaged)


EntityJig Class

EntityJig Class
Namespaces »ZwSoft.ZwCAD.EditorInput »EntityJig
Declaration Syntax
C# Visual Basic Visual C++
public abstract class EntityJig : Jig
Public MustInherit Class EntityJig _
    Inherits Jig
public ref class EntityJig abstract : public Jig
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EntityJig(Entity) |
 | Entity |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDynamicDimensionData(Double) | (Inherited from Jig.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnDimensionValueChanged(DynamicDimensionChangedEventArgs) | (Inherited from Jig.)
 | Sampler(JigPrompts) | (Inherited from Jig.)
 | ToString()()()() | (Inherited from Object.)
 | Update()()()() |
Inheritance Hierarchy
Object
 | Jig
 |  | EntityJig

Assembly: ZwManaged (Module: ZwManaged)


EntityJig Constructor (entity)

EntityJig Constructor (entity)
Namespaces »ZwSoft.ZwCAD.EditorInput »EntityJig »EntityJig(Entity)
Declaration Syntax
C# Visual Basic Visual C++
protected internal EntityJig(
    Entity entity
)
Protected Friend Sub New ( _
    entity As Entity _
)
protected public:
EntityJig(
    Entity^ entity
)
Parameters
entity(Entity)

Assembly: ZwManaged (Module: ZwManaged)


Entity Property

Entity Property
Namespaces »ZwSoft.ZwCAD.EditorInput »EntityJig »Entity
Declaration Syntax
C# Visual Basic Visual C++
protected internal Entity Entity { get; }
Protected Friend ReadOnly Property Entity As Entity
    Get
protected public:
property Entity^ Entity {
    Entity^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Update Method

Update Method
Namespaces »ZwSoft.ZwCAD.EditorInput »EntityJig »Update()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal abstract bool Update()
Protected Friend MustOverride Function Update As Boolean
protected public:
virtual bool Update() abstract

Assembly: ZwManaged (Module: ZwManaged)


FenceSelectedObject Class

FenceSelectedObject Class
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedObject
Declaration Syntax
C# Visual Basic Visual C++
public sealed class FenceSelectedObject : SelectedObject
Public NotInheritable Class FenceSelectedObject _
    Inherits SelectedObject
public ref class FenceSelectedObject sealed : public SelectedObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FenceSelectedObject(ObjectId, SelectionMethod, IntPtr, array<PickPointDescriptor>[]()[][]) |
 | FenceSelectedObject(ObjectId, SelectionMethod, Int32, array<PickPointDescriptor>[]()[][]) | Obsolete.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIntersectionPoints()()()() |
 | GetSubentities()()()() | (Inherited from SelectedObject.)
 | GetType()()()() | (Inherited from Object.)
 | GraphicsSystemMarker | Obsolete. (Inherited from SelectedObject.)
 | GraphicsSystemMarkerPtr | (Inherited from SelectedObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObjectId | (Inherited from SelectedObject.)
 | OptionalDetails | (Inherited from SelectedObject.)
 | SelectionMethod | (Inherited from SelectedObject.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedObject.ToString()()()().)
Inheritance Hierarchy
Object
 | SelectedObject
 |  | FenceSelectedObject

Assembly: ZwManaged (Module: ZwManaged)


FenceSelectedObject Constructor

FenceSelectedObject Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedObject »FenceSelectedObject()()()()
Members
Icon | Member | Description
 | FenceSelectedObject(ObjectId, SelectionMethod, IntPtr, array<PickPointDescriptor>[]()[][]) |
 | FenceSelectedObject(ObjectId, SelectionMethod, Int32, array<PickPointDescriptor>[]()[][]) | Obsolete.

Assembly: ZwManaged (Module: ZwManaged)


FenceSelectedObject Constructor (id, method, gsMarker, descriptors)

FenceSelectedObject Constructor (id, method, gsMarker, descriptors)
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedObject »FenceSelectedObject(ObjectId, SelectionMethod, Int32, array<PickPointDescriptor>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use overload taking System::IntPtr instead.")]
public FenceSelectedObject(
    ObjectId id,
    SelectionMethod method,
    int gsMarker,
    PickPointDescriptor[] descriptors
)
<ObsoleteAttribute("Use overload taking System::IntPtr instead.")> _
Public Sub New ( _
    id As ObjectId, _
    method As SelectionMethod, _
    gsMarker As Integer, _
    descriptors As PickPointDescriptor() _
)
[ObsoleteAttribute(L"Use overload taking System::IntPtr instead.")]
public:
FenceSelectedObject(
    ObjectId id,
    SelectionMethod method,
    int gsMarker,
    array<PickPointDescriptor>^ descriptors
)
Parameters
id(ObjectId)
method(SelectionMethod)
gsMarker(Int32)
descriptors(array< PickPointDescriptor >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


FenceSelectedObject Constructor (id, method, gsMarker, descriptors)

FenceSelectedObject Constructor (id, method, gsMarker, descriptors)
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedObject »FenceSelectedObject(ObjectId, SelectionMethod, IntPtr, array<PickPointDescriptor>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public FenceSelectedObject(
    ObjectId id,
    SelectionMethod method,
    IntPtr gsMarker,
    PickPointDescriptor[] descriptors
)
Public Sub New ( _
    id As ObjectId, _
    method As SelectionMethod, _
    gsMarker As IntPtr, _
    descriptors As PickPointDescriptor() _
)
public:
FenceSelectedObject(
    ObjectId id,
    SelectionMethod method,
    IntPtr gsMarker,
    array<PickPointDescriptor>^ descriptors
)
Parameters
id(ObjectId)
method(SelectionMethod)
gsMarker(IntPtr)
descriptors(array< PickPointDescriptor >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


GetIntersectionPoints Method

GetIntersectionPoints Method
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedObject »GetIntersectionPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickPointDescriptor[] GetIntersectionPoints()
Public Function GetIntersectionPoints As PickPointDescriptor()
public:
array<PickPointDescriptor>^ GetIntersectionPoints()

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedObject »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedObject.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedObject »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedObject »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


FenceSelectedSubObject Class

FenceSelectedSubObject Class
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedSubObject
Declaration Syntax
C# Visual Basic Visual C++
public sealed class FenceSelectedSubObject : SelectedSubObject
Public NotInheritable Class FenceSelectedSubObject _
    Inherits SelectedSubObject
public ref class FenceSelectedSubObject sealed : public SelectedSubObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FenceSelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr, array<PickPointDescriptor>[]()[][]) |
 | FenceSelectedSubObject(FullSubentityPath, SelectionMethod, Int32, array<PickPointDescriptor>[]()[][]) | Obsolete.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FullSubentityPath | (Inherited from SelectedSubObject.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetIntersectionPoints()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GraphicsSystemMarker | Obsolete. (Inherited from SelectedSubObject.)
 | GraphicsSystemMarkerPtr | (Inherited from SelectedSubObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OptionalDetails | (Inherited from SelectedSubObject.)
 | SelectionMethod | (Inherited from SelectedSubObject.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedSubObject.ToString()()()().)
Inheritance Hierarchy
Object
 | SelectedSubObject
 |  | FenceSelectedSubObject

Assembly: ZwManaged (Module: ZwManaged)


FenceSelectedSubObject Constructor

FenceSelectedSubObject Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedSubObject »FenceSelectedSubObject()()()()
Members
Icon | Member | Description
 | FenceSelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr, array<PickPointDescriptor>[]()[][]) |
 | FenceSelectedSubObject(FullSubentityPath, SelectionMethod, Int32, array<PickPointDescriptor>[]()[][]) | Obsolete.

Assembly: ZwManaged (Module: ZwManaged)


FenceSelectedSubObject Constructor (path, method, gsMarker, descriptors)

FenceSelectedSubObject Constructor (path, method, gsMarker, descriptors)
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedSubObject »FenceSelectedSubObject(FullSubentityPath, SelectionMethod, Int32, array<PickPointDescriptor>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use overload taking System::IntPtr instead.")]
public FenceSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    int gsMarker,
    PickPointDescriptor[] descriptors
)
<ObsoleteAttribute("Use overload taking System::IntPtr instead.")> _
Public Sub New ( _
    path As FullSubentityPath, _
    method As SelectionMethod, _
    gsMarker As Integer, _
    descriptors As PickPointDescriptor() _
)
[ObsoleteAttribute(L"Use overload taking System::IntPtr instead.")]
public:
FenceSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    int gsMarker,
    array<PickPointDescriptor>^ descriptors
)
Parameters
path(FullSubentityPath)
method(SelectionMethod)
gsMarker(Int32)
descriptors(array< PickPointDescriptor >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


FenceSelectedSubObject Constructor (path, method, gsMarker, descriptors)

FenceSelectedSubObject Constructor (path, method, gsMarker, descriptors)
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedSubObject »FenceSelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr, array<PickPointDescriptor>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public FenceSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    IntPtr gsMarker,
    PickPointDescriptor[] descriptors
)
Public Sub New ( _
    path As FullSubentityPath, _
    method As SelectionMethod, _
    gsMarker As IntPtr, _
    descriptors As PickPointDescriptor() _
)
public:
FenceSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    IntPtr gsMarker,
    array<PickPointDescriptor>^ descriptors
)
Parameters
path(FullSubentityPath)
method(SelectionMethod)
gsMarker(IntPtr)
descriptors(array< PickPointDescriptor >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


GetIntersectionPoints Method

GetIntersectionPoints Method
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedSubObject »GetIntersectionPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickPointDescriptor[] GetIntersectionPoints()
Public Function GetIntersectionPoints As PickPointDescriptor()
public:
array<PickPointDescriptor>^ GetIntersectionPoints()

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedSubObject »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedSubObject.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedSubObject »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »FenceSelectedSubObject »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


InputPointContext Class

InputPointContext Class
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext
Declaration Syntax
C# Visual Basic Visual C++
public sealed class InputPointContext : IDisposable
Public NotInheritable Class InputPointContext _
    Implements IDisposable
public ref class InputPointContext sealed : IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CartesianSnappedPoint |
 | ComputedPoint |
 | Dispose()()()() |
 | Document |
 | DrawContext |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAlignmentPaths()()()() |
 | GetCustomObjectSnapModes()()()() |
 | GetCustomObjectSnapOverrides()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetKeyPointEntities()()()() |
 | GetPickedEntities()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GrippedPoint |
 | History |
 | LastPoint |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObjectSnapMask |
 | ObjectSnapOverrides |
 | ObjectSnappedPoint |
 | PointComputed |
 | RawPoint |
 | ToolTipText |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
InputPointContext

Assembly: ZwManaged (Module: ZwManaged)


CartesianSnappedPoint Property

CartesianSnappedPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »CartesianSnappedPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d CartesianSnappedPoint { get; }
Public ReadOnly Property CartesianSnappedPoint As Point3d
    Get
public:
property Point3d CartesianSnappedPoint {
    Point3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ComputedPoint Property

ComputedPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »ComputedPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ComputedPoint { get; }
Public ReadOnly Property ComputedPoint As Point3d
    Get
public:
property Point3d ComputedPoint {
    Point3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


Document Property

Document Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »Document
Declaration Syntax
C# Visual Basic Visual C++
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
public:
property Document^ Document {
    Document^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DrawContext Property

DrawContext Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »DrawContext
Declaration Syntax
C# Visual Basic Visual C++
public ViewportDraw DrawContext { get; }
Public ReadOnly Property DrawContext As ViewportDraw
    Get
public:
property ViewportDraw^ DrawContext {
    ViewportDraw^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GetAlignmentPaths Method

GetAlignmentPaths Method
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »GetAlignmentPaths()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d[] GetAlignmentPaths()
Public Function GetAlignmentPaths As Curve3d()
public:
array<Curve3d^>^ GetAlignmentPaths()

Assembly: ZwManaged (Module: ZwManaged)


GetCustomObjectSnapModes Method

GetCustomObjectSnapModes Method
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »GetCustomObjectSnapModes()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CustomObjectSnapMode[] GetCustomObjectSnapModes()
Public Function GetCustomObjectSnapModes As CustomObjectSnapMode()
public:
array<CustomObjectSnapMode^>^ GetCustomObjectSnapModes()

Assembly: ZwManaged (Module: ZwManaged)


GetCustomObjectSnapOverrides Method

GetCustomObjectSnapOverrides Method
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »GetCustomObjectSnapOverrides()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CustomObjectSnapMode[] GetCustomObjectSnapOverrides()
Public Function GetCustomObjectSnapOverrides As CustomObjectSnapMode()
public:
array<CustomObjectSnapMode^>^ GetCustomObjectSnapOverrides()

Assembly: ZwManaged (Module: ZwManaged)


GetKeyPointEntities Method

GetKeyPointEntities Method
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »GetKeyPointEntities()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FullSubentityPath[] GetKeyPointEntities()
Public Function GetKeyPointEntities As FullSubentityPath()
public:
array<FullSubentityPath>^ GetKeyPointEntities()

Assembly: ZwManaged (Module: ZwManaged)


GetPickedEntities Method

GetPickedEntities Method
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »GetPickedEntities()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FullSubentityPath[] GetPickedEntities()
Public Function GetPickedEntities As FullSubentityPath()
public:
array<FullSubentityPath>^ GetPickedEntities()

Assembly: ZwManaged (Module: ZwManaged)


GrippedPoint Property

GrippedPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »GrippedPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GrippedPoint { get; }
Public ReadOnly Property GrippedPoint As Point3d
    Get
public:
property Point3d GrippedPoint {
    Point3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


History Property

History Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »History
Declaration Syntax
C# Visual Basic Visual C++
public PointHistoryBits History { get; }
Public ReadOnly Property History As PointHistoryBits
    Get
public:
property PointHistoryBits History {
    PointHistoryBits get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LastPoint Property

LastPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »LastPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d LastPoint { get; }
Public ReadOnly Property LastPoint As Point3d
    Get
public:
property Point3d LastPoint {
    Point3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ObjectSnapMask Property

ObjectSnapMask Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »ObjectSnapMask
Declaration Syntax
C# Visual Basic Visual C++
public ObjectSnapMasks ObjectSnapMask { get; }
Public ReadOnly Property ObjectSnapMask As ObjectSnapMasks
    Get
public:
property ObjectSnapMasks ObjectSnapMask {
    ObjectSnapMasks get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ObjectSnapOverrides Property

ObjectSnapOverrides Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »ObjectSnapOverrides
Declaration Syntax
C# Visual Basic Visual C++
public ObjectSnapMasks ObjectSnapOverrides { get; }
Public ReadOnly Property ObjectSnapOverrides As ObjectSnapMasks
    Get
public:
property ObjectSnapMasks ObjectSnapOverrides {
    ObjectSnapMasks get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ObjectSnappedPoint Property

ObjectSnappedPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »ObjectSnappedPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ObjectSnappedPoint { get; }
Public ReadOnly Property ObjectSnappedPoint As Point3d
    Get
public:
property Point3d ObjectSnappedPoint {
    Point3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PointComputed Property

PointComputed Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »PointComputed
Declaration Syntax
C# Visual Basic Visual C++
public bool PointComputed { get; }
Public ReadOnly Property PointComputed As Boolean
    Get
public:
property bool PointComputed {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


RawPoint Property

RawPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »RawPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d RawPoint { get; }
Public ReadOnly Property RawPoint As Point3d
    Get
public:
property Point3d RawPoint {
    Point3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToolTipText Property

ToolTipText Property
Namespaces »ZwSoft.ZwCAD.EditorInput »InputPointContext »ToolTipText
Declaration Syntax
C# Visual Basic Visual C++
public string ToolTipText { get; }
Public ReadOnly Property ToolTipText As String
    Get
public:
property String^ ToolTipText {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Jig Class

Jig Class
Namespaces »ZwSoft.ZwCAD.EditorInput »Jig
Declaration Syntax
C# Visual Basic Visual C++
public abstract class Jig
Public MustInherit Class Jig
public ref class Jig abstract
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDynamicDimensionData(Double) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnDimensionValueChanged(DynamicDimensionChangedEventArgs) |
 | Sampler(JigPrompts) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | Jig
 |  | DrawJig
 |  | EntityJig

Assembly: ZwManaged (Module: ZwManaged)


GetDynamicDimensionData Method (dimScale)

GetDynamicDimensionData Method (dimScale)
Namespaces »ZwSoft.ZwCAD.EditorInput »Jig »GetDynamicDimensionData(Double)
Declaration Syntax
C# Visual Basic Visual C++
protected internal virtual DynamicDimensionDataCollection GetDynamicDimensionData(
    double dimScale
)
Protected Friend Overridable Function GetDynamicDimensionData ( _
    dimScale As Double _
) As DynamicDimensionDataCollection
protected public:
virtual DynamicDimensionDataCollection^ GetDynamicDimensionData(
    double dimScale
)
Parameters
dimScale(Double)

Assembly: ZwManaged (Module: ZwManaged)


OnDimensionValueChanged Method (e)

OnDimensionValueChanged Method (e)
Namespaces »ZwSoft.ZwCAD.EditorInput »Jig »OnDimensionValueChanged(DynamicDimensionChangedEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
protected internal virtual void OnDimensionValueChanged(
    DynamicDimensionChangedEventArgs e
)
Protected Friend Overridable Sub OnDimensionValueChanged ( _
    e As DynamicDimensionChangedEventArgs _
)
protected public:
virtual void OnDimensionValueChanged(
    DynamicDimensionChangedEventArgs^ e
)
Parameters
e(DynamicDimensionChangedEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


Sampler Method (prompts)

Sampler Method (prompts)
Namespaces »ZwSoft.ZwCAD.EditorInput »Jig »Sampler(JigPrompts)
Declaration Syntax
C# Visual Basic Visual C++
protected internal abstract SamplerStatus Sampler(
    JigPrompts prompts
)
Protected Friend MustOverride Function Sampler ( _
    prompts As JigPrompts _
) As SamplerStatus
protected public:
virtual SamplerStatus Sampler(
    JigPrompts^ prompts
) abstract
Parameters
prompts(JigPrompts)

Assembly: ZwManaged (Module: ZwManaged)


JigPromptAngleOptions Class

JigPromptAngleOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptAngleOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class JigPromptAngleOptions : JigPromptGeometryOptions
Public NotInheritable Class JigPromptAngleOptions _
    Inherits JigPromptGeometryOptions
public ref class JigPromptAngleOptions sealed : public JigPromptGeometryOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JigPromptAngleOptions(String, String) |
 | JigPromptAngleOptions(String) |
 | JigPromptAngleOptions()()()() |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | BasePoint | (Inherited from JigPromptGeometryOptions.)
 | CalculateResult(DragStatus, PromptResult) | (Inherited from JigPromptOptions.)
 | CommonInit()()()() | (Inherited from JigPromptOptions.)
 | Cursor | (Inherited from JigPromptOptions.)
 | DefaultValue |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseBasePoint | (Inherited from JigPromptGeometryOptions.)
 | UserInputControls | (Inherited from JigPromptOptions.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | JigPromptOptions
 |  |  | JigPromptGeometryOptions
 |  |  |  | JigPromptAngleOptions

Assembly: ZwManaged (Module: ZwManaged)


JigPromptAngleOptions Constructor

JigPromptAngleOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptAngleOptions »JigPromptAngleOptions()()()()
Members
Icon | Member | Description
 | JigPromptAngleOptions(String, String) |
 | JigPromptAngleOptions(String) |
 | JigPromptAngleOptions()()()() |

Assembly: ZwManaged (Module: ZwManaged)


JigPromptAngleOptions Constructor

JigPromptAngleOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptAngleOptions »JigPromptAngleOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptAngleOptions()
Public Sub New
public:
JigPromptAngleOptions()

Assembly: ZwManaged (Module: ZwManaged)


JigPromptAngleOptions Constructor (message)

JigPromptAngleOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptAngleOptions »JigPromptAngleOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptAngleOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
JigPromptAngleOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


JigPromptAngleOptions Constructor (messageAndKeywords, globalKeywords)

JigPromptAngleOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptAngleOptions »JigPromptAngleOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptAngleOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
JigPromptAngleOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


DefaultValue Property

DefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptAngleOptions »DefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public double DefaultValue { get; set; }
Public Property DefaultValue As Double
    Get
    Set
public:
property double DefaultValue {
    double get ();
    void set (double value);
}

Assembly: ZwManaged (Module: ZwManaged)


JigPromptDistanceOptions Class

JigPromptDistanceOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptDistanceOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class JigPromptDistanceOptions : JigPromptGeometryOptions
Public NotInheritable Class JigPromptDistanceOptions _
    Inherits JigPromptGeometryOptions
public ref class JigPromptDistanceOptions sealed : public JigPromptGeometryOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JigPromptDistanceOptions(String, String) |
 | JigPromptDistanceOptions(String) |
 | JigPromptDistanceOptions()()()() |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | BasePoint | (Inherited from JigPromptGeometryOptions.)
 | CalculateResult(DragStatus, PromptResult) | (Inherited from JigPromptOptions.)
 | CommonInit()()()() | (Inherited from JigPromptOptions.)
 | Cursor | (Inherited from JigPromptOptions.)
 | DefaultValue |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseBasePoint | (Inherited from JigPromptGeometryOptions.)
 | UserInputControls | (Inherited from JigPromptOptions.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | JigPromptOptions
 |  |  | JigPromptGeometryOptions
 |  |  |  | JigPromptDistanceOptions

Assembly: ZwManaged (Module: ZwManaged)


JigPromptDistanceOptions Constructor

JigPromptDistanceOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptDistanceOptions »JigPromptDistanceOptions()()()()
Members
Icon | Member | Description
 | JigPromptDistanceOptions(String, String) |
 | JigPromptDistanceOptions(String) |
 | JigPromptDistanceOptions()()()() |

Assembly: ZwManaged (Module: ZwManaged)


JigPromptDistanceOptions Constructor

JigPromptDistanceOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptDistanceOptions »JigPromptDistanceOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptDistanceOptions()
Public Sub New
public:
JigPromptDistanceOptions()

Assembly: ZwManaged (Module: ZwManaged)


JigPromptDistanceOptions Constructor (message)

JigPromptDistanceOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptDistanceOptions »JigPromptDistanceOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptDistanceOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
JigPromptDistanceOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


JigPromptDistanceOptions Constructor (messageAndKeywords, globalKeywords)

JigPromptDistanceOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptDistanceOptions »JigPromptDistanceOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptDistanceOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
JigPromptDistanceOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


DefaultValue Property

DefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptDistanceOptions »DefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public double DefaultValue { get; set; }
Public Property DefaultValue As Double
    Get
    Set
public:
property double DefaultValue {
    double get ();
    void set (double value);
}

Assembly: ZwManaged (Module: ZwManaged)


JigPromptGeometryOptions Class

JigPromptGeometryOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptGeometryOptions
Declaration Syntax
C# Visual Basic Visual C++
public abstract class JigPromptGeometryOptions : JigPromptOptions
Public MustInherit Class JigPromptGeometryOptions _
    Inherits JigPromptOptions
public ref class JigPromptGeometryOptions abstract : public JigPromptOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JigPromptGeometryOptions(String, String) |
 | JigPromptGeometryOptions(String) |
 | JigPromptGeometryOptions()()()() |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | BasePoint |
 | CalculateResult(DragStatus, PromptResult) | (Inherited from JigPromptOptions.)
 | CommonInit()()()() | (Inherited from JigPromptOptions.)
 | Cursor | (Inherited from JigPromptOptions.)
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseBasePoint |
 | UserInputControls | (Inherited from JigPromptOptions.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | JigPromptOptions
 |  |  | JigPromptGeometryOptions
 |  |  |  | JigPromptAngleOptions
 |  |  |  | JigPromptDistanceOptions
 |  |  |  | JigPromptPointOptions

Assembly: ZwManaged (Module: ZwManaged)


JigPromptGeometryOptions Constructor

JigPromptGeometryOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptGeometryOptions »JigPromptGeometryOptions()()()()
Members
Icon | Member | Description
 | JigPromptGeometryOptions(String, String) |
 | JigPromptGeometryOptions(String) |
 | JigPromptGeometryOptions()()()() |

Assembly: ZwManaged (Module: ZwManaged)


JigPromptGeometryOptions Constructor

JigPromptGeometryOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptGeometryOptions »JigPromptGeometryOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptGeometryOptions()
Public Sub New
public:
JigPromptGeometryOptions()

Assembly: ZwManaged (Module: ZwManaged)


JigPromptGeometryOptions Constructor (message)

JigPromptGeometryOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptGeometryOptions »JigPromptGeometryOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptGeometryOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
JigPromptGeometryOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


JigPromptGeometryOptions Constructor (messageAndKeywords, globalKeywords)

JigPromptGeometryOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptGeometryOptions »JigPromptGeometryOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptGeometryOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
JigPromptGeometryOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


BasePoint Property

BasePoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptGeometryOptions »BasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BasePoint { get; set; }
Public Property BasePoint As Point3d
    Get
    Set
public:
property Point3d BasePoint {
    Point3d get ();
    void set (Point3d value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseBasePoint Property

UseBasePoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptGeometryOptions »UseBasePoint
Declaration Syntax
C# Visual Basic Visual C++
public bool UseBasePoint { get; set; }
Public Property UseBasePoint As Boolean
    Get
    Set
public:
property bool UseBasePoint {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


JigPromptOptions Class

JigPromptOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptOptions
Declaration Syntax
C# Visual Basic Visual C++
public abstract class JigPromptOptions : PromptOptions
Public MustInherit Class JigPromptOptions _
    Inherits PromptOptions
public ref class JigPromptOptions abstract : public PromptOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JigPromptOptions(String, String) |
 | JigPromptOptions(String) |
 | JigPromptOptions()()()() |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | CalculateResult(DragStatus, PromptResult) |
 | CommonInit()()()() |
 | Cursor |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UserInputControls |
Inheritance Hierarchy
Object
 | PromptOptions
 |  | JigPromptOptions
 |  |  | JigPromptGeometryOptions
 |  |  | JigPromptStringOptions

Assembly: ZwManaged (Module: ZwManaged)


JigPromptOptions Constructor

JigPromptOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptOptions »JigPromptOptions()()()()
Members
Icon | Member | Description
 | JigPromptOptions(String, String) |
 | JigPromptOptions(String) |
 | JigPromptOptions()()()() |

Assembly: ZwManaged (Module: ZwManaged)


JigPromptOptions Constructor

JigPromptOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptOptions »JigPromptOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal JigPromptOptions()
Protected Friend Sub New
protected public:
JigPromptOptions()

Assembly: ZwManaged (Module: ZwManaged)


JigPromptOptions Constructor (message)

JigPromptOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptOptions »JigPromptOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
protected internal JigPromptOptions(
    string message
)
Protected Friend Sub New ( _
    message As String _
)
protected public:
JigPromptOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


JigPromptOptions Constructor (messageAndKeywords, globalKeywords)

JigPromptOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptOptions »JigPromptOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
protected internal JigPromptOptions(
    string messageAndKeywords,
    string globalKeywords
)
Protected Friend Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
protected public:
JigPromptOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


CalculateResult Method (status, result)

CalculateResult Method (status, result)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptOptions »CalculateResult(DragStatus, PromptResult)
Declaration Syntax
C# Visual Basic Visual C++
protected internal void CalculateResult(
    DragStatus status,
    PromptResult result
)
Protected Friend Sub CalculateResult ( _
    status As DragStatus, _
    result As PromptResult _
)
protected public:
void CalculateResult(
    DragStatus status,
    PromptResult^ result
)
Parameters
status(DragStatus)
result(PromptResult)

Assembly: ZwManaged (Module: ZwManaged)


CommonInit Method

CommonInit Method
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptOptions »CommonInit()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal void CommonInit()
Protected Friend Sub CommonInit
protected public:
void CommonInit()

Assembly: ZwManaged (Module: ZwManaged)


Cursor Property

Cursor Property
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptOptions »Cursor
Declaration Syntax
C# Visual Basic Visual C++
public CursorType Cursor { get; set; }
Public Property Cursor As CursorType
    Get
    Set
public:
property CursorType Cursor {
    CursorType get ();
    void set (CursorType value);
}

Assembly: ZwManaged (Module: ZwManaged)


UserInputControls Property

UserInputControls Property
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptOptions »UserInputControls
Declaration Syntax
C# Visual Basic Visual C++
public UserInputControls UserInputControls { get; set; }
Public Property UserInputControls As UserInputControls
    Get
    Set
public:
property UserInputControls UserInputControls {
    UserInputControls get ();
    void set (UserInputControls value);
}

Assembly: ZwManaged (Module: ZwManaged)


JigPromptPointOptions Class

JigPromptPointOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptPointOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class JigPromptPointOptions : JigPromptGeometryOptions
Public NotInheritable Class JigPromptPointOptions _
    Inherits JigPromptGeometryOptions
public ref class JigPromptPointOptions sealed : public JigPromptGeometryOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JigPromptPointOptions(String, String) |
 | JigPromptPointOptions(String) |
 | JigPromptPointOptions()()()() |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | BasePoint | (Inherited from JigPromptGeometryOptions.)
 | CalculateResult(DragStatus, PromptResult) | (Inherited from JigPromptOptions.)
 | CommonInit()()()() | (Inherited from JigPromptOptions.)
 | Cursor | (Inherited from JigPromptOptions.)
 | DefaultValue |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseBasePoint | (Inherited from JigPromptGeometryOptions.)
 | UserInputControls | (Inherited from JigPromptOptions.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | JigPromptOptions
 |  |  | JigPromptGeometryOptions
 |  |  |  | JigPromptPointOptions

Assembly: ZwManaged (Module: ZwManaged)


JigPromptPointOptions Constructor

JigPromptPointOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptPointOptions »JigPromptPointOptions()()()()
Members
Icon | Member | Description
 | JigPromptPointOptions(String, String) |
 | JigPromptPointOptions(String) |
 | JigPromptPointOptions()()()() |

Assembly: ZwManaged (Module: ZwManaged)


JigPromptPointOptions Constructor

JigPromptPointOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptPointOptions »JigPromptPointOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptPointOptions()
Public Sub New
public:
JigPromptPointOptions()

Assembly: ZwManaged (Module: ZwManaged)


JigPromptPointOptions Constructor (message)

JigPromptPointOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptPointOptions »JigPromptPointOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptPointOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
JigPromptPointOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


JigPromptPointOptions Constructor (messageAndKeywords, globalKeywords)

JigPromptPointOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptPointOptions »JigPromptPointOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptPointOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
JigPromptPointOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


DefaultValue Property

DefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptPointOptions »DefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public Point3d DefaultValue { get; set; }
Public Property DefaultValue As Point3d
    Get
    Set
public:
property Point3d DefaultValue {
    Point3d get ();
    void set (Point3d value);
}

Assembly: ZwManaged (Module: ZwManaged)


JigPrompts Class

JigPrompts Class
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts
Declaration Syntax
C# Visual Basic Visual C++
public sealed class JigPrompts
Public NotInheritable Class JigPrompts
public ref class JigPrompts sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AcquireAngle(String, String) |
 | AcquireAngle(String) |
 | AcquireAngle(JigPromptAngleOptions) |
 | AcquireAngle()()()() |
 | AcquireDistance(String, String) |
 | AcquireDistance(String) |
 | AcquireDistance(JigPromptDistanceOptions) |
 | AcquireDistance()()()() |
 | AcquirePoint(String, String) |
 | AcquirePoint(String) |
 | AcquirePoint(JigPromptPointOptions) |
 | AcquirePoint()()()() |
 | AcquireString(String, String) |
 | AcquireString(String) |
 | AcquireString(JigPromptStringOptions) |
 | AcquireString()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
JigPrompts

Assembly: ZwManaged (Module: ZwManaged)


AcquireAngle Method

AcquireAngle Method
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireAngle()()()()
Members
Icon | Member | Description
 | AcquireAngle(String, String) |
 | AcquireAngle(String) |
 | AcquireAngle(JigPromptAngleOptions) |
 | AcquireAngle()()()() |

Assembly: ZwManaged (Module: ZwManaged)


AcquireAngle Method

AcquireAngle Method
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireAngle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult AcquireAngle()
Public Function AcquireAngle As PromptDoubleResult
public:
PromptDoubleResult^ AcquireAngle()

Assembly: ZwManaged (Module: ZwManaged)


AcquireAngle Method (message)

AcquireAngle Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireAngle(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult AcquireAngle(
    string message
)
Public Function AcquireAngle ( _
    message As String _
) As PromptDoubleResult
public:
PromptDoubleResult^ AcquireAngle(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


AcquireAngle Method (messageAndKeywords, globalKeywords)

AcquireAngle Method (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireAngle(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult AcquireAngle(
    string messageAndKeywords,
    string globalKeywords
)
Public Function AcquireAngle ( _
    messageAndKeywords As String, _
    globalKeywords As String _
) As PromptDoubleResult
public:
PromptDoubleResult^ AcquireAngle(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


AcquireAngle Method (options)

AcquireAngle Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireAngle(JigPromptAngleOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult AcquireAngle(
    JigPromptAngleOptions options
)
Public Function AcquireAngle ( _
    options As JigPromptAngleOptions _
) As PromptDoubleResult
public:
PromptDoubleResult^ AcquireAngle(
    JigPromptAngleOptions^ options
)
Parameters
options(JigPromptAngleOptions)

Assembly: ZwManaged (Module: ZwManaged)


AcquireDistance Method

AcquireDistance Method
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireDistance()()()()
Members
Icon | Member | Description
 | AcquireDistance(String, String) |
 | AcquireDistance(String) |
 | AcquireDistance(JigPromptDistanceOptions) |
 | AcquireDistance()()()() |

Assembly: ZwManaged (Module: ZwManaged)


AcquireDistance Method

AcquireDistance Method
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireDistance()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult AcquireDistance()
Public Function AcquireDistance As PromptDoubleResult
public:
PromptDoubleResult^ AcquireDistance()

Assembly: ZwManaged (Module: ZwManaged)


AcquireDistance Method (message)

AcquireDistance Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireDistance(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult AcquireDistance(
    string message
)
Public Function AcquireDistance ( _
    message As String _
) As PromptDoubleResult
public:
PromptDoubleResult^ AcquireDistance(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


AcquireDistance Method (messageAndKeywords, globalKeywords)

AcquireDistance Method (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireDistance(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult AcquireDistance(
    string messageAndKeywords,
    string globalKeywords
)
Public Function AcquireDistance ( _
    messageAndKeywords As String, _
    globalKeywords As String _
) As PromptDoubleResult
public:
PromptDoubleResult^ AcquireDistance(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


AcquireDistance Method (options)

AcquireDistance Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireDistance(JigPromptDistanceOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult AcquireDistance(
    JigPromptDistanceOptions options
)
Public Function AcquireDistance ( _
    options As JigPromptDistanceOptions _
) As PromptDoubleResult
public:
PromptDoubleResult^ AcquireDistance(
    JigPromptDistanceOptions^ options
)
Parameters
options(JigPromptDistanceOptions)

Assembly: ZwManaged (Module: ZwManaged)


AcquirePoint Method

AcquirePoint Method
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquirePoint()()()()
Members
Icon | Member | Description
 | AcquirePoint(String, String) |
 | AcquirePoint(String) |
 | AcquirePoint(JigPromptPointOptions) |
 | AcquirePoint()()()() |

Assembly: ZwManaged (Module: ZwManaged)


AcquirePoint Method

AcquirePoint Method
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquirePoint()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult AcquirePoint()
Public Function AcquirePoint As PromptPointResult
public:
PromptPointResult^ AcquirePoint()

Assembly: ZwManaged (Module: ZwManaged)


AcquirePoint Method (message)

AcquirePoint Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquirePoint(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult AcquirePoint(
    string message
)
Public Function AcquirePoint ( _
    message As String _
) As PromptPointResult
public:
PromptPointResult^ AcquirePoint(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


AcquirePoint Method (messageAndKeywords, globalKeywords)

AcquirePoint Method (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquirePoint(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult AcquirePoint(
    string messageAndKeywords,
    string globalKeywords
)
Public Function AcquirePoint ( _
    messageAndKeywords As String, _
    globalKeywords As String _
) As PromptPointResult
public:
PromptPointResult^ AcquirePoint(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


AcquirePoint Method (options)

AcquirePoint Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquirePoint(JigPromptPointOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult AcquirePoint(
    JigPromptPointOptions options
)
Public Function AcquirePoint ( _
    options As JigPromptPointOptions _
) As PromptPointResult
public:
PromptPointResult^ AcquirePoint(
    JigPromptPointOptions^ options
)
Parameters
options(JigPromptPointOptions)

Assembly: ZwManaged (Module: ZwManaged)


AcquireString Method

AcquireString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireString()()()()
Members
Icon | Member | Description
 | AcquireString(String, String) |
 | AcquireString(String) |
 | AcquireString(JigPromptStringOptions) |
 | AcquireString()()()() |

Assembly: ZwManaged (Module: ZwManaged)


AcquireString Method

AcquireString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult AcquireString()
Public Function AcquireString As PromptResult
public:
PromptResult^ AcquireString()

Assembly: ZwManaged (Module: ZwManaged)


AcquireString Method (message)

AcquireString Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireString(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult AcquireString(
    string message
)
Public Function AcquireString ( _
    message As String _
) As PromptResult
public:
PromptResult^ AcquireString(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


AcquireString Method (messageAndKeywords, globalKeywords)

AcquireString Method (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireString(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult AcquireString(
    string messageAndKeywords,
    string globalKeywords
)
Public Function AcquireString ( _
    messageAndKeywords As String, _
    globalKeywords As String _
) As PromptResult
public:
PromptResult^ AcquireString(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


AcquireString Method (options)

AcquireString Method (options)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPrompts »AcquireString(JigPromptStringOptions)
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult AcquireString(
    JigPromptStringOptions options
)
Public Function AcquireString ( _
    options As JigPromptStringOptions _
) As PromptResult
public:
PromptResult^ AcquireString(
    JigPromptStringOptions^ options
)
Parameters
options(JigPromptStringOptions)

Assembly: ZwManaged (Module: ZwManaged)


JigPromptStringOptions Class

JigPromptStringOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptStringOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class JigPromptStringOptions : JigPromptOptions
Public NotInheritable Class JigPromptStringOptions _
    Inherits JigPromptOptions
public ref class JigPromptStringOptions sealed : public JigPromptOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JigPromptStringOptions(String, String) |
 | JigPromptStringOptions(String) |
 | JigPromptStringOptions()()()() |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | CalculateResult(DragStatus, PromptResult) | (Inherited from JigPromptOptions.)
 | CommonInit()()()() | (Inherited from JigPromptOptions.)
 | Cursor | (Inherited from JigPromptOptions.)
 | DefaultValue |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UserInputControls | (Inherited from JigPromptOptions.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | JigPromptOptions
 |  |  | JigPromptStringOptions

Assembly: ZwManaged (Module: ZwManaged)


JigPromptStringOptions Constructor

JigPromptStringOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptStringOptions »JigPromptStringOptions()()()()
Members
Icon | Member | Description
 | JigPromptStringOptions(String, String) |
 | JigPromptStringOptions(String) |
 | JigPromptStringOptions()()()() |

Assembly: ZwManaged (Module: ZwManaged)


JigPromptStringOptions Constructor

JigPromptStringOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptStringOptions »JigPromptStringOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptStringOptions()
Public Sub New
public:
JigPromptStringOptions()

Assembly: ZwManaged (Module: ZwManaged)


JigPromptStringOptions Constructor (message)

JigPromptStringOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptStringOptions »JigPromptStringOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptStringOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
JigPromptStringOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


JigPromptStringOptions Constructor (messageAndKeywords, globalKeywords)

JigPromptStringOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptStringOptions »JigPromptStringOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public JigPromptStringOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
JigPromptStringOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


DefaultValue Property

DefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »JigPromptStringOptions »DefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public string DefaultValue { get; set; }
Public Property DefaultValue As String
    Get
    Set
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Keyword Class

Keyword Class
Namespaces »ZwSoft.ZwCAD.EditorInput »Keyword
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Keyword
Public NotInheritable Class Keyword
public ref class Keyword sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DisplayName |
 | Enabled |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalName |
 | IsReadOnly |
 | LocalName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Visible |
Inheritance Hierarchy
Object
Keyword

Assembly: ZwManaged (Module: ZwManaged)


DisplayName Property

DisplayName Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Keyword »DisplayName
Declaration Syntax
C# Visual Basic Visual C++
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Enabled Property

Enabled Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Keyword »Enabled
Declaration Syntax
C# Visual Basic Visual C++
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


GlobalName Property

GlobalName Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Keyword »GlobalName
Declaration Syntax
C# Visual Basic Visual C++
public string GlobalName { get; set; }
Public Property GlobalName As String
    Get
    Set
public:
property String^ GlobalName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Keyword »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; internal set; }
Public Property IsReadOnly As Boolean
    Get
    Friend Set
public:
property bool IsReadOnly {
    bool get ();
    internal: void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


LocalName Property

LocalName Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Keyword »LocalName
Declaration Syntax
C# Visual Basic Visual C++
public string LocalName { get; set; }
Public Property LocalName As String
    Get
    Set
public:
property String^ LocalName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Visible Property

Visible Property
Namespaces »ZwSoft.ZwCAD.EditorInput »Keyword »Visible
Declaration Syntax
C# Visual Basic Visual C++
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


KeywordCollection Class

KeywordCollection Class
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class KeywordCollection : ICollection
Public NotInheritable Class KeywordCollection _
    Implements ICollection
public ref class KeywordCollection sealed : ICollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeywordCollection()()()() |
 | Add(String, String, String, Boolean, Boolean) |
 | Add(String, String, String) |
 | Add(String, String) |
 | Add(String) |
 | Clear()()()() |
 | CopyTo(array<Keyword>[]()[][], Int32) |
 | CopyTo(Array, Int32) |
 | Count |
 | Default |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDisplayString(Boolean) |
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
KeywordCollection

Assembly: ZwManaged (Module: ZwManaged)


KeywordCollection Constructor

KeywordCollection Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »KeywordCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public KeywordCollection()
Public Sub New
public:
KeywordCollection()

Assembly: ZwManaged (Module: ZwManaged)


Add Method

Add Method
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »Add()()()()
Members
Icon | Member | Description
 | Add(String, String, String, Boolean, Boolean) |
 | Add(String, String, String) |
 | Add(String, String) |
 | Add(String) |

Assembly: ZwManaged (Module: ZwManaged)


Add Method (globalName)

Add Method (globalName)
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »Add(String)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string globalName
)
Public Sub Add ( _
    globalName As String _
)
public:
void Add(
    String^ globalName
)
Parameters
globalName(String)

Assembly: ZwManaged (Module: ZwManaged)


Add Method (globalName, localName)

Add Method (globalName, localName)
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »Add(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string globalName,
    string localName
)
Public Sub Add ( _
    globalName As String, _
    localName As String _
)
public:
void Add(
    String^ globalName,
    String^ localName
)
Parameters
globalName(String)
localName(String)

Assembly: ZwManaged (Module: ZwManaged)


Add Method (globalName, localName, displayName)

Add Method (globalName, localName, displayName)
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »Add(String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string globalName,
    string localName,
    string displayName
)
Public Sub Add ( _
    globalName As String, _
    localName As String, _
    displayName As String _
)
public:
void Add(
    String^ globalName,
    String^ localName,
    String^ displayName
)
Parameters
globalName(String)
localName(String)
displayName(String)

Assembly: ZwManaged (Module: ZwManaged)


Add Method (globalName, localName, displayName, visible, enabled)

Add Method (globalName, localName, displayName, visible, enabled)
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »Add(String, String, String, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string globalName,
    string localName,
    string displayName,
    bool visible,
    bool enabled
)
Public Sub Add ( _
    globalName As String, _
    localName As String, _
    displayName As String, _
    visible As Boolean, _
    enabled As Boolean _
)
public:
void Add(
    String^ globalName,
    String^ localName,
    String^ displayName,
    bool visible,
    bool enabled
)
Parameters
globalName(String)
localName(String)
displayName(String)
visible(Boolean)
enabled(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method

CopyTo Method
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<Keyword>[]()[][], Int32) |
 | CopyTo(Array, Int32) |

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed
Parameters
array(Array)
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »CopyTo(array<Keyword>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Keyword[] arr,
    int index
)
Public Sub CopyTo ( _
    arr As Keyword(), _
    index As Integer _
)
public:
void CopyTo(
    array<Keyword^>^ arr,
    int index
)
Parameters
arr(array< Keyword >[]()[][])
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Default Property

Default Property
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »Default
Declaration Syntax
C# Visual Basic Visual C++
public string Default { get; set; }
Public Property Default As String
    Get
    Set
public:
property String^ Default {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


GetDisplayString Method (showNoDefault)

GetDisplayString Method (showNoDefault)
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »GetDisplayString(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public string GetDisplayString(
    bool showNoDefault
)
Public Function GetDisplayString ( _
    showNoDefault As Boolean _
) As String
public:
String^ GetDisplayString(
    bool showNoDefault
)
Parameters
showNoDefault(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed

Assembly: ZwManaged (Module: ZwManaged)


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Keyword this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Keyword
    Get
public:
property Keyword^ default[int index] {
    Keyword^ get (int index);
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.EditorInput »KeywordCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ObjectSnapMasks Enumeration

ObjectSnapMasks Enumeration
Namespaces »ZwSoft.ZwCAD.EditorInput »ObjectSnapMasks
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum ObjectSnapMasks
<FlagsAttribute> _
Public Enumeration ObjectSnapMasks
[FlagsAttribute]
public enum class ObjectSnapMasks
Members
Member | Description
RelativeCartesian |
NoneOverride |
RelativePolar |
DisablePerpendicular |
AllowTangent |
ApparentIntersection |
Quick |
Near |
Tangent |
Perpendicular |
Insertion |
Intersection |
Quadrant |
Node |
Middle |
End |
Immediate |
Center |

Assembly: ZwManaged (Module: ZwManaged)


PickPointDescriptor Structure

PickPointDescriptor Structure
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor
Declaration Syntax
C# Visual Basic Visual C++
public struct PickPointDescriptor
Public Structure PickPointDescriptor
public value class PickPointDescriptor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PickPointDescriptor(PickPointKind, Point3d, Vector3d) |
 | Direction |
 | Equality(PickPointDescriptor, PickPointDescriptor) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(PickPointDescriptor, PickPointDescriptor) |
 | IsEqualTo(PickPointDescriptor, Tolerance) |
 | IsEqualTo(PickPointDescriptor) |
 | Kind |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PointOnLine |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | ToString(IFormatProvider) |

Assembly: ZwManaged (Module: ZwManaged)


PickPointDescriptor Constructor (kind, pointOnLine, direction)

PickPointDescriptor Constructor (kind, pointOnLine, direction)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »PickPointDescriptor(PickPointKind, Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public PickPointDescriptor(
    PickPointKind kind,
    Point3d pointOnLine,
    Vector3d direction
)
Public Sub New ( _
    kind As PickPointKind, _
    pointOnLine As Point3d, _
    direction As Vector3d _
)
public:
PickPointDescriptor(
    PickPointKind kind,
    Point3d pointOnLine,
    Vector3d direction
)
Parameters
kind(PickPointKind)
pointOnLine(Point3d)
direction(Vector3d)

Assembly: ZwManaged (Module: ZwManaged)


Direction Property

Direction Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »Direction
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Direction { get; }
Public ReadOnly Property Direction As Vector3d
    Get
public:
property Vector3d Direction {
    Vector3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »Equality(PickPointDescriptor, PickPointDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    PickPointDescriptor a,
    PickPointDescriptor b
)
Public Shared Operator = ( _
    a As PickPointDescriptor, _
    b As PickPointDescriptor _
) As Boolean
public:
static bool operator ==(
    PickPointDescriptor a,
    PickPointDescriptor b
)
Parameters
a(PickPointDescriptor)
b(PickPointDescriptor)

Assembly: ZwManaged (Module: ZwManaged)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)

Assembly: ZwManaged (Module: ZwManaged)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed

Assembly: ZwManaged (Module: ZwManaged)


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »Inequality(PickPointDescriptor, PickPointDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    PickPointDescriptor a,
    PickPointDescriptor b
)
Public Shared Operator <> ( _
    a As PickPointDescriptor, _
    b As PickPointDescriptor _
) As Boolean
public:
static bool operator !=(
    PickPointDescriptor a,
    PickPointDescriptor b
)
Parameters
a(PickPointDescriptor)
b(PickPointDescriptor)

Assembly: ZwManaged (Module: ZwManaged)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(PickPointDescriptor, Tolerance) |
 | IsEqualTo(PickPointDescriptor) |

Assembly: ZwManaged (Module: ZwManaged)


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »IsEqualTo(PickPointDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    PickPointDescriptor a
)
Public Function IsEqualTo ( _
    a As PickPointDescriptor _
) As Boolean
public:
bool IsEqualTo(
    PickPointDescriptor a
)
Parameters
a(PickPointDescriptor)

Assembly: ZwManaged (Module: ZwManaged)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »IsEqualTo(PickPointDescriptor, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    PickPointDescriptor a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As PickPointDescriptor, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    PickPointDescriptor a,
    Tolerance tolerance
)
Parameters
a(PickPointDescriptor)
tolerance(Tolerance)

Assembly: ZwManaged (Module: ZwManaged)


Kind Property

Kind Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »Kind
Declaration Syntax
C# Visual Basic Visual C++
public PickPointKind Kind { get; }
Public ReadOnly Property Kind As PickPointKind
    Get
public:
property PickPointKind Kind {
    PickPointKind get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PointOnLine Property

PointOnLine Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »PointOnLine
Declaration Syntax
C# Visual Basic Visual C++
public Point3d PointOnLine { get; }
Public ReadOnly Property PointOnLine As Point3d
    Get
public:
property Point3d PointOnLine {
    Point3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »ToString()()()()
Members
Icon | Member | Description
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | ToString(IFormatProvider) |

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointDescriptor »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


PickPointKind Enumeration

PickPointKind Enumeration
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointKind
Declaration Syntax
C# Visual Basic Visual C++
public enum PickPointKind
Public Enumeration PickPointKind
public enum class PickPointKind
Members
Member | Description
Ray |
InfiniteLine |
LineSegment |

Assembly: ZwManaged (Module: ZwManaged)


PickPointSelectedObject Class

PickPointSelectedObject Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedObject
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PickPointSelectedObject : SelectedObject
Public NotInheritable Class PickPointSelectedObject _
    Inherits SelectedObject
public ref class PickPointSelectedObject sealed : public SelectedObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PickPointSelectedObject(ObjectId, SelectionMethod, IntPtr, PickPointDescriptor) |
 | PickPointSelectedObject(ObjectId, SelectionMethod, Int32, PickPointDescriptor) | Obsolete.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSubentities()()()() | (Inherited from SelectedObject.)
 | GetType()()()() | (Inherited from Object.)
 | GraphicsSystemMarker | Obsolete. (Inherited from SelectedObject.)
 | GraphicsSystemMarkerPtr | (Inherited from SelectedObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObjectId | (Inherited from SelectedObject.)
 | OptionalDetails | (Inherited from SelectedObject.)
 | PickPoint |
 | SelectionMethod | (Inherited from SelectedObject.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedObject.ToString()()()().)
Inheritance Hierarchy
Object
 | SelectedObject
 |  | PickPointSelectedObject

Assembly: ZwManaged (Module: ZwManaged)


PickPointSelectedObject Constructor

PickPointSelectedObject Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedObject »PickPointSelectedObject()()()()
Members
Icon | Member | Description
 | PickPointSelectedObject(ObjectId, SelectionMethod, IntPtr, PickPointDescriptor) |
 | PickPointSelectedObject(ObjectId, SelectionMethod, Int32, PickPointDescriptor) | Obsolete.

Assembly: ZwManaged (Module: ZwManaged)


PickPointSelectedObject Constructor (id, method, gsMarker, descriptor)

PickPointSelectedObject Constructor (id, method, gsMarker, descriptor)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedObject »PickPointSelectedObject(ObjectId, SelectionMethod, Int32, PickPointDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use overload taking System::IntPtr instead.")]
public PickPointSelectedObject(
    ObjectId id,
    SelectionMethod method,
    int gsMarker,
    PickPointDescriptor descriptor
)
<ObsoleteAttribute("Use overload taking System::IntPtr instead.")> _
Public Sub New ( _
    id As ObjectId, _
    method As SelectionMethod, _
    gsMarker As Integer, _
    descriptor As PickPointDescriptor _
)
[ObsoleteAttribute(L"Use overload taking System::IntPtr instead.")]
public:
PickPointSelectedObject(
    ObjectId id,
    SelectionMethod method,
    int gsMarker,
    PickPointDescriptor descriptor
)
Parameters
id(ObjectId)
method(SelectionMethod)
gsMarker(Int32)
descriptor(PickPointDescriptor)

Assembly: ZwManaged (Module: ZwManaged)


PickPointSelectedObject Constructor (id, method, gsMarker, descriptor)

PickPointSelectedObject Constructor (id, method, gsMarker, descriptor)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedObject »PickPointSelectedObject(ObjectId, SelectionMethod, IntPtr, PickPointDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
public PickPointSelectedObject(
    ObjectId id,
    SelectionMethod method,
    IntPtr gsMarker,
    PickPointDescriptor descriptor
)
Public Sub New ( _
    id As ObjectId, _
    method As SelectionMethod, _
    gsMarker As IntPtr, _
    descriptor As PickPointDescriptor _
)
public:
PickPointSelectedObject(
    ObjectId id,
    SelectionMethod method,
    IntPtr gsMarker,
    PickPointDescriptor descriptor
)
Parameters
id(ObjectId)
method(SelectionMethod)
gsMarker(IntPtr)
descriptor(PickPointDescriptor)

Assembly: ZwManaged (Module: ZwManaged)


PickPoint Property

PickPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedObject »PickPoint
Declaration Syntax
C# Visual Basic Visual C++
public PickPointDescriptor PickPoint { get; }
Public ReadOnly Property PickPoint As PickPointDescriptor
    Get
public:
property PickPointDescriptor PickPoint {
    PickPointDescriptor get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedObject »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedObject.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedObject »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedObject »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


PickPointSelectedSubObject Class

PickPointSelectedSubObject Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedSubObject
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PickPointSelectedSubObject : SelectedSubObject
Public NotInheritable Class PickPointSelectedSubObject _
    Inherits SelectedSubObject
public ref class PickPointSelectedSubObject sealed : public SelectedSubObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PickPointSelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr, PickPointDescriptor) |
 | PickPointSelectedSubObject(FullSubentityPath, SelectionMethod, Int32, PickPointDescriptor) | Obsolete.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FullSubentityPath | (Inherited from SelectedSubObject.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GraphicsSystemMarker | Obsolete. (Inherited from SelectedSubObject.)
 | GraphicsSystemMarkerPtr | (Inherited from SelectedSubObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OptionalDetails | (Inherited from SelectedSubObject.)
 | PickPoint |
 | SelectionMethod | (Inherited from SelectedSubObject.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedSubObject.ToString()()()().)
Inheritance Hierarchy
Object
 | SelectedSubObject
 |  | PickPointSelectedSubObject

Assembly: ZwManaged (Module: ZwManaged)


PickPointSelectedSubObject Constructor

PickPointSelectedSubObject Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedSubObject »PickPointSelectedSubObject()()()()
Members
Icon | Member | Description
 | PickPointSelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr, PickPointDescriptor) |
 | PickPointSelectedSubObject(FullSubentityPath, SelectionMethod, Int32, PickPointDescriptor) | Obsolete.

Assembly: ZwManaged (Module: ZwManaged)


PickPointSelectedSubObject Constructor (path, method, gsMarker, descriptor)

PickPointSelectedSubObject Constructor (path, method, gsMarker, descriptor)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedSubObject »PickPointSelectedSubObject(FullSubentityPath, SelectionMethod, Int32, PickPointDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use overload taking System::IntPtr instead.")]
public PickPointSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    int gsMarker,
    PickPointDescriptor descriptor
)
<ObsoleteAttribute("Use overload taking System::IntPtr instead.")> _
Public Sub New ( _
    path As FullSubentityPath, _
    method As SelectionMethod, _
    gsMarker As Integer, _
    descriptor As PickPointDescriptor _
)
[ObsoleteAttribute(L"Use overload taking System::IntPtr instead.")]
public:
PickPointSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    int gsMarker,
    PickPointDescriptor descriptor
)
Parameters
path(FullSubentityPath)
method(SelectionMethod)
gsMarker(Int32)
descriptor(PickPointDescriptor)

Assembly: ZwManaged (Module: ZwManaged)


PickPointSelectedSubObject Constructor (path, method, gsMarker, descriptor)

PickPointSelectedSubObject Constructor (path, method, gsMarker, descriptor)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedSubObject »PickPointSelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr, PickPointDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
public PickPointSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    IntPtr gsMarker,
    PickPointDescriptor descriptor
)
Public Sub New ( _
    path As FullSubentityPath, _
    method As SelectionMethod, _
    gsMarker As IntPtr, _
    descriptor As PickPointDescriptor _
)
public:
PickPointSelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    IntPtr gsMarker,
    PickPointDescriptor descriptor
)
Parameters
path(FullSubentityPath)
method(SelectionMethod)
gsMarker(IntPtr)
descriptor(PickPointDescriptor)

Assembly: ZwManaged (Module: ZwManaged)


PickPoint Property

PickPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedSubObject »PickPoint
Declaration Syntax
C# Visual Basic Visual C++
public PickPointDescriptor PickPoint { get; }
Public ReadOnly Property PickPoint As PickPointDescriptor
    Get
public:
property PickPointDescriptor PickPoint {
    PickPointDescriptor get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedSubObject »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides SelectedSubObject.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedSubObject »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PickPointSelectedSubObject »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


PointFilterEventArgs Class

PointFilterEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PointFilterEventArgs : EventArgs,
    IDisposable
Public NotInheritable Class PointFilterEventArgs _
    Inherits EventArgs _
    Implements IDisposable
public ref class PointFilterEventArgs sealed : public EventArgs,
    IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CallNext |
 | Context |
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Result |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PointFilterEventArgs

Assembly: ZwManaged (Module: ZwManaged)


CallNext Property

CallNext Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterEventArgs »CallNext
Declaration Syntax
C# Visual Basic Visual C++
public bool CallNext { get; set; }
Public Property CallNext As Boolean
    Get
    Set
public:
property bool CallNext {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


Context Property

Context Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterEventArgs »Context
Declaration Syntax
C# Visual Basic Visual C++
public InputPointContext Context { get; }
Public ReadOnly Property Context As InputPointContext
    Get
public:
property InputPointContext^ Context {
    InputPointContext^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterEventArgs »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


Result Property

Result Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterEventArgs »Result
Declaration Syntax
C# Visual Basic Visual C++
public PointFilterResult Result { get; }
Public ReadOnly Property Result As PointFilterResult
    Get
public:
property PointFilterResult^ Result {
    PointFilterResult^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PointFilterEventHandler Delegate

PointFilterEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PointFilterEventHandler(
    Object sender,
    PointFilterEventArgs e
)
Public Delegate Sub PointFilterEventHandler ( _
    sender As Object, _
    e As PointFilterEventArgs _
)
public delegate void PointFilterEventHandler(
    Object^ sender,
    PointFilterEventArgs^ e
)
Parameters
sender(Object)
e(PointFilterEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PointFilterResult Class

PointFilterResult Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterResult
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PointFilterResult : IDisposable
Public NotInheritable Class PointFilterResult _
    Implements IDisposable
public ref class PointFilterResult sealed : IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DisplayObjectSnapGlyph |
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewPoint |
 | Retry |
 | ToolTipText |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PointFilterResult

Assembly: ZwManaged (Module: ZwManaged)


DisplayObjectSnapGlyph Property

DisplayObjectSnapGlyph Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterResult »DisplayObjectSnapGlyph
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayObjectSnapGlyph { get; set; }
Public Property DisplayObjectSnapGlyph As Boolean
    Get
    Set
public:
property bool DisplayObjectSnapGlyph {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterResult »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


NewPoint Property

NewPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterResult »NewPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d NewPoint { get; set; }
Public Property NewPoint As Point3d
    Get
    Set
public:
property Point3d NewPoint {
    Point3d get ();
    void set (Point3d value);
}

Assembly: ZwManaged (Module: ZwManaged)


Retry Property

Retry Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterResult »Retry
Declaration Syntax
C# Visual Basic Visual C++
public bool Retry { get; set; }
Public Property Retry As Boolean
    Get
    Set
public:
property bool Retry {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


ToolTipText Property

ToolTipText Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PointFilterResult »ToolTipText
Declaration Syntax
C# Visual Basic Visual C++
public string ToolTipText { get; set; }
Public Property ToolTipText As String
    Get
    Set
public:
property String^ ToolTipText {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PointHistoryBits Enumeration

PointHistoryBits Enumeration
Namespaces »ZwSoft.ZwCAD.EditorInput »PointHistoryBits
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum PointHistoryBits
<FlagsAttribute> _
Public Enumeration PointHistoryBits
[FlagsAttribute]
public enum class PointHistoryBits
Members
Member | Description
NotInteractive |
FromKeyboard |
CoordinatePending |
ZPending |
YPending |
XPending |
PickMask |
PickAborted |
UsedObjectSnapBox |
UsedPickBox |
ForcedPick |
AppFiltered |
Aligned |
PolarAngle |
ObjectSnapped |
CyclingPoint |
Ortho |
CartSnapped |
Gripped |
LastPoint |
NotDigitizer |
Tablet |
DidNotPick |

Assembly: ZwManaged (Module: ZwManaged)


PointMonitorEventArgs Class

PointMonitorEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PointMonitorEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PointMonitorEventArgs : EventArgs,
    IDisposable
Public NotInheritable Class PointMonitorEventArgs _
    Inherits EventArgs _
    Implements IDisposable
public ref class PointMonitorEventArgs sealed : public EventArgs,
    IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AppendToolTipText(String) |
 | Context |
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PointMonitorEventArgs

Assembly: ZwManaged (Module: ZwManaged)


AppendToolTipText Method (value)

AppendToolTipText Method (value)
Namespaces »ZwSoft.ZwCAD.EditorInput »PointMonitorEventArgs »AppendToolTipText(String)
Declaration Syntax
C# Visual Basic Visual C++
public void AppendToolTipText(
    string value
)
Public Sub AppendToolTipText ( _
    value As String _
)
public:
void AppendToolTipText(
    String^ value
)
Parameters
value(String)

Assembly: ZwManaged (Module: ZwManaged)


Context Property

Context Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PointMonitorEventArgs »Context
Declaration Syntax
C# Visual Basic Visual C++
public InputPointContext Context { get; }
Public ReadOnly Property Context As InputPointContext
    Get
public:
property InputPointContext^ Context {
    InputPointContext^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PointMonitorEventArgs »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


PointMonitorEventHandler Delegate

PointMonitorEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PointMonitorEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PointMonitorEventHandler(
    Object sender,
    PointMonitorEventArgs e
)
Public Delegate Sub PointMonitorEventHandler ( _
    sender As Object, _
    e As PointMonitorEventArgs _
)
public delegate void PointMonitorEventHandler(
    Object^ sender,
    PointMonitorEventArgs^ e
)
Parameters
sender(Object)
e(PointMonitorEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptAngleOptions Class

PromptAngleOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptAngleOptions : PromptEditorOptions
Public NotInheritable Class PromptAngleOptions _
    Inherits PromptEditorOptions
public ref class PromptAngleOptions sealed : public PromptEditorOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptAngleOptions(String, String) |
 | PromptAngleOptions(String) |
 | AllowArbitraryInput |
 | AllowNone |
 | AllowZero |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | BasePoint |
 | DefaultValue |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseAngleBase |
 | UseBasePoint |
 | UseDashedLine |
 | UseDefaultValue |
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptAngleOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptAngleOptions Constructor

PromptAngleOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »PromptAngleOptions()()()()
Members
Icon | Member | Description
 | PromptAngleOptions(String, String) |
 | PromptAngleOptions(String) |

Assembly: ZwManaged (Module: ZwManaged)


PromptAngleOptions Constructor (message)

PromptAngleOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »PromptAngleOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptAngleOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptAngleOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptAngleOptions Constructor (messageAndKeywords, globalKeywords)

PromptAngleOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »PromptAngleOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptAngleOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
PromptAngleOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


AllowArbitraryInput Property

AllowArbitraryInput Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »AllowArbitraryInput
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowArbitraryInput { get; set; }
Public Property AllowArbitraryInput As Boolean
    Get
    Set
public:
property bool AllowArbitraryInput {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


AllowNone Property

AllowNone Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »AllowNone
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowNone { get; set; }
Public Property AllowNone As Boolean
    Get
    Set
public:
property bool AllowNone {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


AllowZero Property

AllowZero Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »AllowZero
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowZero { get; set; }
Public Property AllowZero As Boolean
    Get
    Set
public:
property bool AllowZero {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


BasePoint Property

BasePoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »BasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BasePoint { get; set; }
Public Property BasePoint As Point3d
    Get
    Set
public:
property Point3d BasePoint {
    Point3d get ();
    void set (Point3d value);
}

Assembly: ZwManaged (Module: ZwManaged)


DefaultValue Property

DefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »DefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public double DefaultValue { get; set; }
Public Property DefaultValue As Double
    Get
    Set
public:
property double DefaultValue {
    double get ();
    void set (double value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseAngleBase Property

UseAngleBase Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »UseAngleBase
Declaration Syntax
C# Visual Basic Visual C++
public bool UseAngleBase { get; set; }
Public Property UseAngleBase As Boolean
    Get
    Set
public:
property bool UseAngleBase {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseBasePoint Property

UseBasePoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »UseBasePoint
Declaration Syntax
C# Visual Basic Visual C++
public bool UseBasePoint { get; set; }
Public Property UseBasePoint As Boolean
    Get
    Set
public:
property bool UseBasePoint {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseDashedLine Property

UseDashedLine Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »UseDashedLine
Declaration Syntax
C# Visual Basic Visual C++
public bool UseDashedLine { get; set; }
Public Property UseDashedLine As Boolean
    Get
    Set
public:
property bool UseDashedLine {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseDefaultValue Property

UseDefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptions »UseDefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public bool UseDefaultValue { get; set; }
Public Property UseDefaultValue As Boolean
    Get
    Set
public:
property bool UseDefaultValue {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptAngleOptionsEventArgs Class

PromptAngleOptionsEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptionsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptAngleOptionsEventArgs : EventArgs
Public NotInheritable Class PromptAngleOptionsEventArgs _
    Inherits EventArgs
public ref class PromptAngleOptionsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Options |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptAngleOptionsEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Options Property

Options Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptionsEventArgs »Options
Declaration Syntax
C# Visual Basic Visual C++
public PromptAngleOptions Options { get; }
Public ReadOnly Property Options As PromptAngleOptions
    Get
public:
property PromptAngleOptions^ Options {
    PromptAngleOptions^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptAngleOptionsEventHandler Delegate

PromptAngleOptionsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptAngleOptionsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptAngleOptionsEventHandler(
    Object sender,
    PromptAngleOptionsEventArgs e
)
Public Delegate Sub PromptAngleOptionsEventHandler ( _
    sender As Object, _
    e As PromptAngleOptionsEventArgs _
)
public delegate void PromptAngleOptionsEventHandler(
    Object^ sender,
    PromptAngleOptionsEventArgs^ e
)
Parameters
sender(Object)
e(PromptAngleOptionsEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptCornerOptions Class

PromptCornerOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptCornerOptions
Declaration Syntax
C# Visual Basic Visual C++
public class PromptCornerOptions : PromptEditorOptions
Public Class PromptCornerOptions _
    Inherits PromptEditorOptions
public ref class PromptCornerOptions : public PromptEditorOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptCornerOptions(String, String, Point3d) |
 | PromptCornerOptions(String, Point3d) |
 | AllowArbitraryInput |
 | AllowNone |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | BasePoint |
 | DoIt()()()() | (Overrides PromptOptions.DoIt()()()().)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | LimitsChecked |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseDashedLine |
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptCornerOptions
 |  |  |  | PromptPointOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptCornerOptions Constructor

PromptCornerOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptCornerOptions »PromptCornerOptions()()()()
Members
Icon | Member | Description
 | PromptCornerOptions(String, String, Point3d) |
 | PromptCornerOptions(String, Point3d) |

Assembly: ZwManaged (Module: ZwManaged)


PromptCornerOptions Constructor (messageAndKeywords, globalKeywords, basePoint)

PromptCornerOptions Constructor (messageAndKeywords, globalKeywords, basePoint)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptCornerOptions »PromptCornerOptions(String, String, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PromptCornerOptions(
    string messageAndKeywords,
    string globalKeywords,
    Point3d basePoint
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String, _
    basePoint As Point3d _
)
public:
PromptCornerOptions(
    String^ messageAndKeywords,
    String^ globalKeywords,
    Point3d basePoint
)
Parameters
messageAndKeywords(String)
globalKeywords(String)
basePoint(Point3d)

Assembly: ZwManaged (Module: ZwManaged)


PromptCornerOptions Constructor (message, basePoint)

PromptCornerOptions Constructor (message, basePoint)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptCornerOptions »PromptCornerOptions(String, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PromptCornerOptions(
    string message,
    Point3d basePoint
)
Public Sub New ( _
    message As String, _
    basePoint As Point3d _
)
public:
PromptCornerOptions(
    String^ message,
    Point3d basePoint
)
Parameters
message(String)
basePoint(Point3d)

Assembly: ZwManaged (Module: ZwManaged)


AllowArbitraryInput Property

AllowArbitraryInput Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptCornerOptions »AllowArbitraryInput
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowArbitraryInput { get; set; }
Public Property AllowArbitraryInput As Boolean
    Get
    Set
public:
property bool AllowArbitraryInput {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


AllowNone Property

AllowNone Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptCornerOptions »AllowNone
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowNone { get; set; }
Public Property AllowNone As Boolean
    Get
    Set
public:
property bool AllowNone {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


BasePoint Property

BasePoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptCornerOptions »BasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BasePoint { get; set; }
Public Property BasePoint As Point3d
    Get
    Set
public:
property Point3d BasePoint {
    Point3d get ();
    void set (Point3d value);
}

Assembly: ZwManaged (Module: ZwManaged)


DoIt Method

DoIt Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptCornerOptions »DoIt()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal override PromptResult DoIt()
Protected Friend Overrides Function DoIt As PromptResult
protected public:
virtual PromptResult^ DoIt() override

Assembly: ZwManaged (Module: ZwManaged)


LimitsChecked Property

LimitsChecked Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptCornerOptions »LimitsChecked
Declaration Syntax
C# Visual Basic Visual C++
public bool LimitsChecked { get; set; }
Public Property LimitsChecked As Boolean
    Get
    Set
public:
property bool LimitsChecked {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseDashedLine Property

UseDashedLine Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptCornerOptions »UseDashedLine
Declaration Syntax
C# Visual Basic Visual C++
public bool UseDashedLine { get; set; }
Public Property UseDashedLine As Boolean
    Get
    Set
public:
property bool UseDashedLine {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptDistanceOptions Class

PromptDistanceOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptDistanceOptions : PromptNumericalOptions
Public NotInheritable Class PromptDistanceOptions _
    Inherits PromptNumericalOptions
public ref class PromptDistanceOptions sealed : public PromptNumericalOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptDistanceOptions(String, String) |
 | PromptDistanceOptions(String) |
 | AllowArbitraryInput | (Inherited from PromptNumericalOptions.)
 | AllowNegative | (Inherited from PromptNumericalOptions.)
 | AllowNone | (Inherited from PromptNumericalOptions.)
 | AllowZero | (Inherited from PromptNumericalOptions.)
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | BasePoint |
 | DefaultValue |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | Only2d |
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseBasePoint |
 | UseDashedLine |
 | UseDefaultValue | (Inherited from PromptNumericalOptions.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptNumericalOptions
 |  |  |  | PromptDistanceOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptDistanceOptions Constructor

PromptDistanceOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptions »PromptDistanceOptions()()()()
Members
Icon | Member | Description
 | PromptDistanceOptions(String, String) |
 | PromptDistanceOptions(String) |

Assembly: ZwManaged (Module: ZwManaged)


PromptDistanceOptions Constructor (message)

PromptDistanceOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptions »PromptDistanceOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDistanceOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptDistanceOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptDistanceOptions Constructor (messageAndKeywords, globalKeywords)

PromptDistanceOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptions »PromptDistanceOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDistanceOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
PromptDistanceOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


BasePoint Property

BasePoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptions »BasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BasePoint { get; set; }
Public Property BasePoint As Point3d
    Get
    Set
public:
property Point3d BasePoint {
    Point3d get ();
    void set (Point3d value);
}

Assembly: ZwManaged (Module: ZwManaged)


DefaultValue Property

DefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptions »DefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public double DefaultValue { get; set; }
Public Property DefaultValue As Double
    Get
    Set
public:
property double DefaultValue {
    double get ();
    void set (double value);
}

Assembly: ZwManaged (Module: ZwManaged)


Only2d Property

Only2d Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptions »Only2d
Declaration Syntax
C# Visual Basic Visual C++
public bool Only2d { get; set; }
Public Property Only2d As Boolean
    Get
    Set
public:
property bool Only2d {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseBasePoint Property

UseBasePoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptions »UseBasePoint
Declaration Syntax
C# Visual Basic Visual C++
public bool UseBasePoint { get; set; }
Public Property UseBasePoint As Boolean
    Get
    Set
public:
property bool UseBasePoint {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseDashedLine Property

UseDashedLine Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptions »UseDashedLine
Declaration Syntax
C# Visual Basic Visual C++
public bool UseDashedLine { get; set; }
Public Property UseDashedLine As Boolean
    Get
    Set
public:
property bool UseDashedLine {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptDistanceOptionsEventArgs Class

PromptDistanceOptionsEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptionsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptDistanceOptionsEventArgs : EventArgs
Public NotInheritable Class PromptDistanceOptionsEventArgs _
    Inherits EventArgs
public ref class PromptDistanceOptionsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Options |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptDistanceOptionsEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Options Property

Options Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptionsEventArgs »Options
Declaration Syntax
C# Visual Basic Visual C++
public PromptDistanceOptions Options { get; }
Public ReadOnly Property Options As PromptDistanceOptions
    Get
public:
property PromptDistanceOptions^ Options {
    PromptDistanceOptions^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptDistanceOptionsEventHandler Delegate

PromptDistanceOptionsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDistanceOptionsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptDistanceOptionsEventHandler(
    Object sender,
    PromptDistanceOptionsEventArgs e
)
Public Delegate Sub PromptDistanceOptionsEventHandler ( _
    sender As Object, _
    e As PromptDistanceOptionsEventArgs _
)
public delegate void PromptDistanceOptionsEventHandler(
    Object^ sender,
    PromptDistanceOptionsEventArgs^ e
)
Parameters
sender(Object)
e(PromptDistanceOptionsEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptDoubleOptions Class

PromptDoubleOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptDoubleOptions : PromptNumericalOptions
Public NotInheritable Class PromptDoubleOptions _
    Inherits PromptNumericalOptions
public ref class PromptDoubleOptions sealed : public PromptNumericalOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptDoubleOptions(String, String) |
 | PromptDoubleOptions(String) |
 | AllowArbitraryInput | (Inherited from PromptNumericalOptions.)
 | AllowNegative | (Inherited from PromptNumericalOptions.)
 | AllowNone | (Inherited from PromptNumericalOptions.)
 | AllowZero | (Inherited from PromptNumericalOptions.)
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | DefaultValue |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseDefaultValue | (Inherited from PromptNumericalOptions.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptNumericalOptions
 |  |  |  | PromptDoubleOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptDoubleOptions Constructor

PromptDoubleOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleOptions »PromptDoubleOptions()()()()
Members
Icon | Member | Description
 | PromptDoubleOptions(String, String) |
 | PromptDoubleOptions(String) |

Assembly: ZwManaged (Module: ZwManaged)


PromptDoubleOptions Constructor (message)

PromptDoubleOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleOptions »PromptDoubleOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptDoubleOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptDoubleOptions Constructor (messageAndKeywords, globalKeywords)

PromptDoubleOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleOptions »PromptDoubleOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
PromptDoubleOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


DefaultValue Property

DefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleOptions »DefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public double DefaultValue { get; set; }
Public Property DefaultValue As Double
    Get
    Set
public:
property double DefaultValue {
    double get ();
    void set (double value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptDoubleOptionsEventArgs Class

PromptDoubleOptionsEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleOptionsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptDoubleOptionsEventArgs : EventArgs
Public NotInheritable Class PromptDoubleOptionsEventArgs _
    Inherits EventArgs
public ref class PromptDoubleOptionsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Options |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptDoubleOptionsEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Options Property

Options Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleOptionsEventArgs »Options
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleOptions Options { get; }
Public ReadOnly Property Options As PromptDoubleOptions
    Get
public:
property PromptDoubleOptions^ Options {
    PromptDoubleOptions^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptDoubleOptionsEventHandler Delegate

PromptDoubleOptionsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleOptionsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptDoubleOptionsEventHandler(
    Object sender,
    PromptDoubleOptionsEventArgs e
)
Public Delegate Sub PromptDoubleOptionsEventHandler ( _
    sender As Object, _
    e As PromptDoubleOptionsEventArgs _
)
public delegate void PromptDoubleOptionsEventHandler(
    Object^ sender,
    PromptDoubleOptionsEventArgs^ e
)
Parameters
sender(Object)
e(PromptDoubleOptionsEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptDoubleResult Class

PromptDoubleResult Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleResult
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptDoubleResult : PromptResult
Public NotInheritable Class PromptDoubleResult _
    Inherits PromptResult
public ref class PromptDoubleResult sealed : public PromptResult
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status | (Inherited from PromptResult.)
 | StringResult | (Inherited from PromptResult.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptResult.ToString()()()().)
 | Value |
Inheritance Hierarchy
Object
 | PromptResult
 |  | PromptDoubleResult

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleResult »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptResult.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleResult »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleResult »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleResult »Value
Declaration Syntax
C# Visual Basic Visual C++
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
public:
property double Value {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptDoubleResultEventArgs Class

PromptDoubleResultEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleResultEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptDoubleResultEventArgs : EventArgs
Public NotInheritable Class PromptDoubleResultEventArgs _
    Inherits EventArgs
public ref class PromptDoubleResultEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Result |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptDoubleResultEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Result Property

Result Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleResultEventArgs »Result
Declaration Syntax
C# Visual Basic Visual C++
public PromptDoubleResult Result { get; }
Public ReadOnly Property Result As PromptDoubleResult
    Get
public:
property PromptDoubleResult^ Result {
    PromptDoubleResult^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptDoubleResultEventHandler Delegate

PromptDoubleResultEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDoubleResultEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptDoubleResultEventHandler(
    Object sender,
    PromptDoubleResultEventArgs e
)
Public Delegate Sub PromptDoubleResultEventHandler ( _
    sender As Object, _
    e As PromptDoubleResultEventArgs _
)
public delegate void PromptDoubleResultEventHandler(
    Object^ sender,
    PromptDoubleResultEventArgs^ e
)
Parameters
sender(Object)
e(PromptDoubleResultEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptDragOptions Class

PromptDragOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDragOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptDragOptions : PromptEditorOptions
Public NotInheritable Class PromptDragOptions _
    Inherits PromptEditorOptions
public ref class PromptDragOptions sealed : public PromptEditorOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptDragOptions(SelectionSet, String, String, DragCallback) |
 | PromptDragOptions(SelectionSet, String, DragCallback) |
 | AllowArbitraryInput |
 | AllowNone |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | Callback |
 | Cursor |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | Selection |
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptDragOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptDragOptions Constructor

PromptDragOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDragOptions »PromptDragOptions()()()()
Members
Icon | Member | Description
 | PromptDragOptions(SelectionSet, String, String, DragCallback) |
 | PromptDragOptions(SelectionSet, String, DragCallback) |

Assembly: ZwManaged (Module: ZwManaged)


PromptDragOptions Constructor (selection, messageAndKeywords, globalKeywords, callback)

PromptDragOptions Constructor (selection, messageAndKeywords, globalKeywords, callback)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDragOptions »PromptDragOptions(SelectionSet, String, String, DragCallback)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDragOptions(
    SelectionSet selection,
    string messageAndKeywords,
    string globalKeywords,
    DragCallback callback
)
Public Sub New ( _
    selection As SelectionSet, _
    messageAndKeywords As String, _
    globalKeywords As String, _
    callback As DragCallback _
)
public:
PromptDragOptions(
    SelectionSet^ selection,
    String^ messageAndKeywords,
    String^ globalKeywords,
    DragCallback^ callback
)
Parameters
selection(SelectionSet)
messageAndKeywords(String)
globalKeywords(String)
callback(DragCallback)

Assembly: ZwManaged (Module: ZwManaged)


PromptDragOptions Constructor (selection, message, callback)

PromptDragOptions Constructor (selection, message, callback)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDragOptions »PromptDragOptions(SelectionSet, String, DragCallback)
Declaration Syntax
C# Visual Basic Visual C++
public PromptDragOptions(
    SelectionSet selection,
    string message,
    DragCallback callback
)
Public Sub New ( _
    selection As SelectionSet, _
    message As String, _
    callback As DragCallback _
)
public:
PromptDragOptions(
    SelectionSet^ selection,
    String^ message,
    DragCallback^ callback
)
Parameters
selection(SelectionSet)
message(String)
callback(DragCallback)

Assembly: ZwManaged (Module: ZwManaged)


AllowArbitraryInput Property

AllowArbitraryInput Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDragOptions »AllowArbitraryInput
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowArbitraryInput { get; set; }
Public Property AllowArbitraryInput As Boolean
    Get
    Set
public:
property bool AllowArbitraryInput {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


AllowNone Property

AllowNone Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDragOptions »AllowNone
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowNone { get; set; }
Public Property AllowNone As Boolean
    Get
    Set
public:
property bool AllowNone {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


Callback Property

Callback Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDragOptions »Callback
Declaration Syntax
C# Visual Basic Visual C++
public DragCallback Callback { get; set; }
Public Property Callback As DragCallback
    Get
    Set
public:
property DragCallback^ Callback {
    DragCallback^ get ();
    void set (DragCallback^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Cursor Property

Cursor Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDragOptions »Cursor
Declaration Syntax
C# Visual Basic Visual C++
public DragCursor Cursor { get; set; }
Public Property Cursor As DragCursor
    Get
    Set
public:
property DragCursor Cursor {
    DragCursor get ();
    void set (DragCursor value);
}

Assembly: ZwManaged (Module: ZwManaged)


Selection Property

Selection Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptDragOptions »Selection
Declaration Syntax
C# Visual Basic Visual C++
public SelectionSet Selection { get; }
Public ReadOnly Property Selection As SelectionSet
    Get
public:
property SelectionSet^ Selection {
    SelectionSet^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptEditorOptions Class

PromptEditorOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEditorOptions
Declaration Syntax
C# Visual Basic Visual C++
public abstract class PromptEditorOptions : PromptOptions
Public MustInherit Class PromptEditorOptions _
    Inherits PromptOptions
public ref class PromptEditorOptions abstract : public PromptOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptEditorOptions(String, String) |
 | PromptEditorOptions(String) |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptAngleOptions
 |  |  | PromptCornerOptions
 |  |  | PromptDragOptions
 |  |  | PromptEntityOptions
 |  |  | PromptKeywordOptions
 |  |  | PromptNestedEntityOptions
 |  |  | PromptNumericalOptions
 |  |  | PromptStringOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptEditorOptions Constructor

PromptEditorOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEditorOptions »PromptEditorOptions()()()()
Members
Icon | Member | Description
 | PromptEditorOptions(String, String) |
 | PromptEditorOptions(String) |

Assembly: ZwManaged (Module: ZwManaged)


PromptEditorOptions Constructor (message)

PromptEditorOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEditorOptions »PromptEditorOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
protected internal PromptEditorOptions(
    string message
)
Protected Friend Sub New ( _
    message As String _
)
protected public:
PromptEditorOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptEditorOptions Constructor (messageAndKeywords, globalKeywords)

PromptEditorOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEditorOptions »PromptEditorOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
protected internal PromptEditorOptions(
    string messageAndKeywords,
    string globalKeywords
)
Protected Friend Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
protected public:
PromptEditorOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptEntityOptions Class

PromptEntityOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptEntityOptions : PromptEditorOptions
Public NotInheritable Class PromptEntityOptions _
    Inherits PromptEditorOptions
public ref class PromptEntityOptions sealed : public PromptEditorOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptEntityOptions(String, String) |
 | PromptEntityOptions(String) |
 | AddAllowedClass(Type, Boolean) |
 | AllowNone |
 | AllowObjectOnLockedLayer |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | RemoveAllowedClass(Type) |
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | SetRejectMessage(String) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptEntityOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptEntityOptions Constructor

PromptEntityOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptions »PromptEntityOptions()()()()
Members
Icon | Member | Description
 | PromptEntityOptions(String, String) |
 | PromptEntityOptions(String) |

Assembly: ZwManaged (Module: ZwManaged)


PromptEntityOptions Constructor (message)

PromptEntityOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptions »PromptEntityOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptEntityOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptEntityOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptEntityOptions Constructor (messageAndKeywords, globalKeywords)

PromptEntityOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptions »PromptEntityOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptEntityOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
PromptEntityOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


AddAllowedClass Method (type, exactMatch)

AddAllowedClass Method (type, exactMatch)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptions »AddAllowedClass(Type, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void AddAllowedClass(
    Type type,
    bool exactMatch
)
Public Sub AddAllowedClass ( _
    type As Type, _
    exactMatch As Boolean _
)
public:
void AddAllowedClass(
    Type^ type,
    bool exactMatch
)
Parameters
type(Type)
exactMatch(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


AllowNone Property

AllowNone Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptions »AllowNone
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowNone { get; set; }
Public Property AllowNone As Boolean
    Get
    Set
public:
property bool AllowNone {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


AllowObjectOnLockedLayer Property

AllowObjectOnLockedLayer Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptions »AllowObjectOnLockedLayer
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowObjectOnLockedLayer { get; set; }
Public Property AllowObjectOnLockedLayer As Boolean
    Get
    Set
public:
property bool AllowObjectOnLockedLayer {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


RemoveAllowedClass Method (type)

RemoveAllowedClass Method (type)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptions »RemoveAllowedClass(Type)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAllowedClass(
    Type type
)
Public Sub RemoveAllowedClass ( _
    type As Type _
)
public:
void RemoveAllowedClass(
    Type^ type
)
Parameters
type(Type)

Assembly: ZwManaged (Module: ZwManaged)


SetRejectMessage Method (message)

SetRejectMessage Method (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptions »SetRejectMessage(String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetRejectMessage(
    string message
)
Public Sub SetRejectMessage ( _
    message As String _
)
public:
void SetRejectMessage(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptEntityOptionsEventArgs Class

PromptEntityOptionsEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptionsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptEntityOptionsEventArgs : EventArgs
Public NotInheritable Class PromptEntityOptionsEventArgs _
    Inherits EventArgs
public ref class PromptEntityOptionsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Options |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptEntityOptionsEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Options Property

Options Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptionsEventArgs »Options
Declaration Syntax
C# Visual Basic Visual C++
public PromptEntityOptions Options { get; }
Public ReadOnly Property Options As PromptEntityOptions
    Get
public:
property PromptEntityOptions^ Options {
    PromptEntityOptions^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptEntityOptionsEventHandler Delegate

PromptEntityOptionsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityOptionsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptEntityOptionsEventHandler(
    Object sender,
    PromptEntityOptionsEventArgs e
)
Public Delegate Sub PromptEntityOptionsEventHandler ( _
    sender As Object, _
    e As PromptEntityOptionsEventArgs _
)
public delegate void PromptEntityOptionsEventHandler(
    Object^ sender,
    PromptEntityOptionsEventArgs^ e
)
Parameters
sender(Object)
e(PromptEntityOptionsEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptEntityResult Class

PromptEntityResult Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityResult
Declaration Syntax
C# Visual Basic Visual C++
public class PromptEntityResult : PromptResult
Public Class PromptEntityResult _
    Inherits PromptResult
public ref class PromptEntityResult : public PromptResult
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObjectId |
 | PickedPoint |
 | Status | (Inherited from PromptResult.)
 | StringResult | (Inherited from PromptResult.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptResult.ToString()()()().)
Inheritance Hierarchy
Object
 | PromptResult
 |  | PromptEntityResult
 |  |  | PromptNestedEntityResult

Assembly: ZwManaged (Module: ZwManaged)


ObjectId Property

ObjectId Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityResult »ObjectId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ObjectId { get; }
Public ReadOnly Property ObjectId As ObjectId
    Get
public:
property ObjectId ObjectId {
    ObjectId get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PickedPoint Property

PickedPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityResult »PickedPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d PickedPoint { get; }
Public ReadOnly Property PickedPoint As Point3d
    Get
public:
property Point3d PickedPoint {
    Point3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityResult »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptResult.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityResult »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityResult »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


PromptEntityResultEventArgs Class

PromptEntityResultEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityResultEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptEntityResultEventArgs : EventArgs
Public NotInheritable Class PromptEntityResultEventArgs _
    Inherits EventArgs
public ref class PromptEntityResultEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Result |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptEntityResultEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Result Property

Result Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityResultEventArgs »Result
Declaration Syntax
C# Visual Basic Visual C++
public PromptEntityResult Result { get; }
Public ReadOnly Property Result As PromptEntityResult
    Get
public:
property PromptEntityResult^ Result {
    PromptEntityResult^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptEntityResultEventHandler Delegate

PromptEntityResultEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptEntityResultEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptEntityResultEventHandler(
    Object sender,
    PromptEntityResultEventArgs e
)
Public Delegate Sub PromptEntityResultEventHandler ( _
    sender As Object, _
    e As PromptEntityResultEventArgs _
)
public delegate void PromptEntityResultEventHandler(
    Object^ sender,
    PromptEntityResultEventArgs^ e
)
Parameters
sender(Object)
e(PromptEntityResultEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptFileNameResult Class

PromptFileNameResult Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileNameResult
Declaration Syntax
C# Visual Basic Visual C++
public class PromptFileNameResult : PromptResult
Public Class PromptFileNameResult _
    Inherits PromptResult
public ref class PromptFileNameResult : public PromptResult
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReadOnly |
 | Status | (Inherited from PromptResult.)
 | StringResult | (Inherited from PromptResult.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptResult.ToString()()()().)
Inheritance Hierarchy
Object
 | PromptResult
 |  | PromptFileNameResult

Assembly: ZwManaged (Module: ZwManaged)


ReadOnly Property

ReadOnly Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileNameResult »ReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
property bool ReadOnly {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileNameResult »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptResult.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileNameResult »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileNameResult »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


PromptFileOptions Class

PromptFileOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions
Declaration Syntax
C# Visual Basic Visual C++
public abstract class PromptFileOptions
Public MustInherit Class PromptFileOptions
public ref class PromptFileOptions abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptFileOptions(String) |
 | AllowUrls |
 | DialogCaption |
 | DialogName |
 | DoIt()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Filter |
 | FilterIndex |
 | Finalize()()()() | (Inherited from Object.)
 | Flags |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InitialDirectory |
 | InitialFileName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message |
 | PreferCommandLine |
 | ShowReadOnlyCore |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | PromptFileOptions
 |  | PromptOpenFileOptions
 |  | PromptSaveFileOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptFileOptions Constructor (message)

PromptFileOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »PromptFileOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
protected PromptFileOptions(
    string message
)
Protected Sub New ( _
    message As String _
)
protected:
PromptFileOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


AllowUrls Property

AllowUrls Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »AllowUrls
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowUrls { get; set; }
Public Property AllowUrls As Boolean
    Get
    Set
public:
property bool AllowUrls {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


DialogCaption Property

DialogCaption Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »DialogCaption
Declaration Syntax
C# Visual Basic Visual C++
public string DialogCaption { get; set; }
Public Property DialogCaption As String
    Get
    Set
public:
property String^ DialogCaption {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DialogName Property

DialogName Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »DialogName
Declaration Syntax
C# Visual Basic Visual C++
public string DialogName { get; set; }
Public Property DialogName As String
    Get
    Set
public:
property String^ DialogName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DoIt Method

DoIt Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »DoIt()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal PromptFileNameResult DoIt()
Protected Friend Function DoIt As PromptFileNameResult
protected public:
PromptFileNameResult^ DoIt()

Assembly: ZwManaged (Module: ZwManaged)


Filter Property

Filter Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »Filter
Declaration Syntax
C# Visual Basic Visual C++
public string Filter { get; set; }
Public Property Filter As String
    Get
    Set
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


FilterIndex Property

FilterIndex Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »FilterIndex
Declaration Syntax
C# Visual Basic Visual C++
public int FilterIndex { get; set; }
Public Property FilterIndex As Integer
    Get
    Set
public:
property int FilterIndex {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


Flags Property

Flags Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »Flags
Declaration Syntax
C# Visual Basic Visual C++
protected int Flags { get; set; }
Protected Property Flags As Integer
    Get
    Set
protected:
property int Flags {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


InitialDirectory Property

InitialDirectory Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »InitialDirectory
Declaration Syntax
C# Visual Basic Visual C++
public string InitialDirectory { get; set; }
Public Property InitialDirectory As String
    Get
    Set
public:
property String^ InitialDirectory {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


InitialFileName Property

InitialFileName Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »InitialFileName
Declaration Syntax
C# Visual Basic Visual C++
public string InitialFileName { get; set; }
Public Property InitialFileName As String
    Get
    Set
public:
property String^ InitialFileName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Message Property

Message Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »Message
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PreferCommandLine Property

PreferCommandLine Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »PreferCommandLine
Declaration Syntax
C# Visual Basic Visual C++
public bool PreferCommandLine { get; set; }
Public Property PreferCommandLine As Boolean
    Get
    Set
public:
property bool PreferCommandLine {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


ShowReadOnlyCore Property

ShowReadOnlyCore Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptFileOptions »ShowReadOnlyCore
Declaration Syntax
C# Visual Basic Visual C++
protected bool ShowReadOnlyCore { get; set; }
Protected Property ShowReadOnlyCore As Boolean
    Get
    Set
protected:
property bool ShowReadOnlyCore {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptForEntityEndingEventArgs Class

PromptForEntityEndingEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForEntityEndingEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptForEntityEndingEventArgs : EventArgs,
    IDisposable
Public NotInheritable Class PromptForEntityEndingEventArgs _
    Inherits EventArgs _
    Implements IDisposable
public ref class PromptForEntityEndingEventArgs sealed : public EventArgs,
    IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RemoveSelectedObject()()()() |
 | ReplaceSelectedObject(SelectedObject) |
 | Result |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptForEntityEndingEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForEntityEndingEventArgs »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


RemoveSelectedObject Method

RemoveSelectedObject Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForEntityEndingEventArgs »RemoveSelectedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveSelectedObject()
Public Sub RemoveSelectedObject
public:
void RemoveSelectedObject()

Assembly: ZwManaged (Module: ZwManaged)


ReplaceSelectedObject Method (newValue)

ReplaceSelectedObject Method (newValue)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForEntityEndingEventArgs »ReplaceSelectedObject(SelectedObject)
Declaration Syntax
C# Visual Basic Visual C++
public void ReplaceSelectedObject(
    SelectedObject newValue
)
Public Sub ReplaceSelectedObject ( _
    newValue As SelectedObject _
)
public:
void ReplaceSelectedObject(
    SelectedObject^ newValue
)
Parameters
newValue(SelectedObject)

Assembly: ZwManaged (Module: ZwManaged)


Result Property

Result Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForEntityEndingEventArgs »Result
Declaration Syntax
C# Visual Basic Visual C++
public PromptEntityResult Result { get; }
Public ReadOnly Property Result As PromptEntityResult
    Get
public:
property PromptEntityResult^ Result {
    PromptEntityResult^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptForEntityEndingEventHandler Delegate

PromptForEntityEndingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForEntityEndingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptForEntityEndingEventHandler(
    Object sender,
    PromptForEntityEndingEventArgs e
)
Public Delegate Sub PromptForEntityEndingEventHandler ( _
    sender As Object, _
    e As PromptForEntityEndingEventArgs _
)
public delegate void PromptForEntityEndingEventHandler(
    Object^ sender,
    PromptForEntityEndingEventArgs^ e
)
Parameters
sender(Object)
e(PromptForEntityEndingEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptForSelectionEndingEventArgs Class

PromptForSelectionEndingEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForSelectionEndingEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptForSelectionEndingEventArgs : EventArgs,
    IDisposable
Public NotInheritable Class PromptForSelectionEndingEventArgs _
    Inherits EventArgs _
    Implements IDisposable
public ref class PromptForSelectionEndingEventArgs sealed : public EventArgs,
    IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(SelectedObject) |
 | AddSubEntity(SelectedSubObject) |
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | Flags |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Int32) |
 | RemoveSubEntity(Int32, Int32) |
 | Selection |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptForSelectionEndingEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForSelectionEndingEventArgs »Add(SelectedObject)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    SelectedObject value
)
Public Sub Add ( _
    value As SelectedObject _
)
public:
void Add(
    SelectedObject^ value
)
Parameters
value(SelectedObject)

Assembly: ZwManaged (Module: ZwManaged)


AddSubEntity Method (value)

AddSubEntity Method (value)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForSelectionEndingEventArgs »AddSubEntity(SelectedSubObject)
Declaration Syntax
C# Visual Basic Visual C++
public void AddSubEntity(
    SelectedSubObject value
)
Public Sub AddSubEntity ( _
    value As SelectedSubObject _
)
public:
void AddSubEntity(
    SelectedSubObject^ value
)
Parameters
value(SelectedSubObject)

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForSelectionEndingEventArgs »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


Flags Property

Flags Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForSelectionEndingEventArgs »Flags
Declaration Syntax
C# Visual Basic Visual C++
public SelectionFlags Flags { get; }
Public ReadOnly Property Flags As SelectionFlags
    Get
public:
property SelectionFlags Flags {
    SelectionFlags get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Remove Method (index)

Remove Method (index)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForSelectionEndingEventArgs »Remove(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    int index
)
Public Sub Remove ( _
    index As Integer _
)
public:
void Remove(
    int index
)
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


RemoveSubEntity Method (entityIndex, subEntityIndex)

RemoveSubEntity Method (entityIndex, subEntityIndex)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForSelectionEndingEventArgs »RemoveSubEntity(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveSubEntity(
    int entityIndex,
    int subEntityIndex
)
Public Sub RemoveSubEntity ( _
    entityIndex As Integer, _
    subEntityIndex As Integer _
)
public:
void RemoveSubEntity(
    int entityIndex,
    int subEntityIndex
)
Parameters
entityIndex(Int32)
subEntityIndex(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Selection Property

Selection Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForSelectionEndingEventArgs »Selection
Declaration Syntax
C# Visual Basic Visual C++
public SelectionSet Selection { get; }
Public ReadOnly Property Selection As SelectionSet
    Get
public:
property SelectionSet^ Selection {
    SelectionSet^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptForSelectionEndingEventHandler Delegate

PromptForSelectionEndingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptForSelectionEndingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptForSelectionEndingEventHandler(
    Object sender,
    PromptForSelectionEndingEventArgs e
)
Public Delegate Sub PromptForSelectionEndingEventHandler ( _
    sender As Object, _
    e As PromptForSelectionEndingEventArgs _
)
public delegate void PromptForSelectionEndingEventHandler(
    Object^ sender,
    PromptForSelectionEndingEventArgs^ e
)
Parameters
sender(Object)
e(PromptForSelectionEndingEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptIntegerOptions Class

PromptIntegerOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptIntegerOptions : PromptNumericalOptions
Public NotInheritable Class PromptIntegerOptions _
    Inherits PromptNumericalOptions
public ref class PromptIntegerOptions sealed : public PromptNumericalOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptIntegerOptions(String, String, Int32, Int32) |
 | PromptIntegerOptions(String, String) |
 | PromptIntegerOptions(String) |
 | AllowArbitraryInput | (Inherited from PromptNumericalOptions.)
 | AllowNegative | (Inherited from PromptNumericalOptions.)
 | AllowNone | (Inherited from PromptNumericalOptions.)
 | AllowZero | (Inherited from PromptNumericalOptions.)
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | DefaultValue |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | LowerLimit |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UpperLimit |
 | UseDefaultValue | (Inherited from PromptNumericalOptions.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptNumericalOptions
 |  |  |  | PromptIntegerOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptIntegerOptions Constructor

PromptIntegerOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptions »PromptIntegerOptions()()()()
Members
Icon | Member | Description
 | PromptIntegerOptions(String, String, Int32, Int32) |
 | PromptIntegerOptions(String, String) |
 | PromptIntegerOptions(String) |

Assembly: ZwManaged (Module: ZwManaged)


PromptIntegerOptions Constructor (message)

PromptIntegerOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptions »PromptIntegerOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptIntegerOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptIntegerOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptIntegerOptions Constructor (messageAndKeywords, globalKeywords)

PromptIntegerOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptions »PromptIntegerOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptIntegerOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
PromptIntegerOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptIntegerOptions Constructor (messageAndKeywords, globalKeywords, lowerLimit, upperLimit)

PromptIntegerOptions Constructor (messageAndKeywords, globalKeywords, lowerLimit, upperLimit)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptions »PromptIntegerOptions(String, String, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PromptIntegerOptions(
    string messageAndKeywords,
    string globalKeywords,
    int lowerLimit,
    int upperLimit
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String, _
    lowerLimit As Integer, _
    upperLimit As Integer _
)
public:
PromptIntegerOptions(
    String^ messageAndKeywords,
    String^ globalKeywords,
    int lowerLimit,
    int upperLimit
)
Parameters
messageAndKeywords(String)
globalKeywords(String)
lowerLimit(Int32)
upperLimit(Int32)

Assembly: ZwManaged (Module: ZwManaged)


DefaultValue Property

DefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptions »DefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public int DefaultValue { get; set; }
Public Property DefaultValue As Integer
    Get
    Set
public:
property int DefaultValue {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


LowerLimit Property

LowerLimit Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptions »LowerLimit
Declaration Syntax
C# Visual Basic Visual C++
public int LowerLimit { get; set; }
Public Property LowerLimit As Integer
    Get
    Set
public:
property int LowerLimit {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


UpperLimit Property

UpperLimit Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptions »UpperLimit
Declaration Syntax
C# Visual Basic Visual C++
public int UpperLimit { get; set; }
Public Property UpperLimit As Integer
    Get
    Set
public:
property int UpperLimit {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptIntegerOptionsEventArgs Class

PromptIntegerOptionsEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptionsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptIntegerOptionsEventArgs : EventArgs
Public NotInheritable Class PromptIntegerOptionsEventArgs _
    Inherits EventArgs
public ref class PromptIntegerOptionsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Options |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptIntegerOptionsEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Options Property

Options Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptionsEventArgs »Options
Declaration Syntax
C# Visual Basic Visual C++
public PromptIntegerOptions Options { get; }
Public ReadOnly Property Options As PromptIntegerOptions
    Get
public:
property PromptIntegerOptions^ Options {
    PromptIntegerOptions^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptIntegerOptionsEventHandler Delegate

PromptIntegerOptionsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerOptionsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptIntegerOptionsEventHandler(
    Object sender,
    PromptIntegerOptionsEventArgs e
)
Public Delegate Sub PromptIntegerOptionsEventHandler ( _
    sender As Object, _
    e As PromptIntegerOptionsEventArgs _
)
public delegate void PromptIntegerOptionsEventHandler(
    Object^ sender,
    PromptIntegerOptionsEventArgs^ e
)
Parameters
sender(Object)
e(PromptIntegerOptionsEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptIntegerResult Class

PromptIntegerResult Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerResult
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptIntegerResult : PromptResult
Public NotInheritable Class PromptIntegerResult _
    Inherits PromptResult
public ref class PromptIntegerResult sealed : public PromptResult
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status | (Inherited from PromptResult.)
 | StringResult | (Inherited from PromptResult.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptResult.ToString()()()().)
 | Value |
Inheritance Hierarchy
Object
 | PromptResult
 |  | PromptIntegerResult

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerResult »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptResult.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerResult »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerResult »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerResult »Value
Declaration Syntax
C# Visual Basic Visual C++
public int Value { get; }
Public ReadOnly Property Value As Integer
    Get
public:
property int Value {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptIntegerResultEventArgs Class

PromptIntegerResultEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerResultEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptIntegerResultEventArgs : EventArgs
Public NotInheritable Class PromptIntegerResultEventArgs _
    Inherits EventArgs
public ref class PromptIntegerResultEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Result |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptIntegerResultEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Result Property

Result Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerResultEventArgs »Result
Declaration Syntax
C# Visual Basic Visual C++
public PromptIntegerResult Result { get; }
Public ReadOnly Property Result As PromptIntegerResult
    Get
public:
property PromptIntegerResult^ Result {
    PromptIntegerResult^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptIntegerResultEventHandler Delegate

PromptIntegerResultEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptIntegerResultEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptIntegerResultEventHandler(
    Object sender,
    PromptIntegerResultEventArgs e
)
Public Delegate Sub PromptIntegerResultEventHandler ( _
    sender As Object, _
    e As PromptIntegerResultEventArgs _
)
public delegate void PromptIntegerResultEventHandler(
    Object^ sender,
    PromptIntegerResultEventArgs^ e
)
Parameters
sender(Object)
e(PromptIntegerResultEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptKeywordOptions Class

PromptKeywordOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptKeywordOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptKeywordOptions : PromptEditorOptions
Public NotInheritable Class PromptKeywordOptions _
    Inherits PromptEditorOptions
public ref class PromptKeywordOptions sealed : public PromptEditorOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptKeywordOptions(String, String) |
 | PromptKeywordOptions(String) |
 | AllowArbitraryInput |
 | AllowNone |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptKeywordOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptKeywordOptions Constructor

PromptKeywordOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptKeywordOptions »PromptKeywordOptions()()()()
Members
Icon | Member | Description
 | PromptKeywordOptions(String, String) |
 | PromptKeywordOptions(String) |

Assembly: ZwManaged (Module: ZwManaged)


PromptKeywordOptions Constructor (message)

PromptKeywordOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptKeywordOptions »PromptKeywordOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptKeywordOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptKeywordOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptKeywordOptions Constructor (messageAndKeywords, globalKeywords)

PromptKeywordOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptKeywordOptions »PromptKeywordOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptKeywordOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
PromptKeywordOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


AllowArbitraryInput Property

AllowArbitraryInput Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptKeywordOptions »AllowArbitraryInput
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowArbitraryInput { get; set; }
Public Property AllowArbitraryInput As Boolean
    Get
    Set
public:
property bool AllowArbitraryInput {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


AllowNone Property

AllowNone Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptKeywordOptions »AllowNone
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowNone { get; set; }
Public Property AllowNone As Boolean
    Get
    Set
public:
property bool AllowNone {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptKeywordOptionsEventArgs Class

PromptKeywordOptionsEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptKeywordOptionsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptKeywordOptionsEventArgs : EventArgs
Public NotInheritable Class PromptKeywordOptionsEventArgs _
    Inherits EventArgs
public ref class PromptKeywordOptionsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Options |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptKeywordOptionsEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Options Property

Options Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptKeywordOptionsEventArgs »Options
Declaration Syntax
C# Visual Basic Visual C++
public PromptKeywordOptions Options { get; }
Public ReadOnly Property Options As PromptKeywordOptions
    Get
public:
property PromptKeywordOptions^ Options {
    PromptKeywordOptions^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptKeywordOptionsEventHandler Delegate

PromptKeywordOptionsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptKeywordOptionsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptKeywordOptionsEventHandler(
    Object sender,
    PromptKeywordOptionsEventArgs e
)
Public Delegate Sub PromptKeywordOptionsEventHandler ( _
    sender As Object, _
    e As PromptKeywordOptionsEventArgs _
)
public delegate void PromptKeywordOptionsEventHandler(
    Object^ sender,
    PromptKeywordOptionsEventArgs^ e
)
Parameters
sender(Object)
e(PromptKeywordOptionsEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptNestedEntityOptions Class

PromptNestedEntityOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptNestedEntityOptions : PromptEditorOptions
Public NotInheritable Class PromptNestedEntityOptions _
    Inherits PromptEditorOptions
public ref class PromptNestedEntityOptions sealed : public PromptEditorOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptNestedEntityOptions(String, String) |
 | PromptNestedEntityOptions(String) |
 | AllowNone |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | NonInteractivePickPoint |
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseNonInteractivePickPoint |
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptNestedEntityOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptNestedEntityOptions Constructor

PromptNestedEntityOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityOptions »PromptNestedEntityOptions()()()()
Members
Icon | Member | Description
 | PromptNestedEntityOptions(String, String) |
 | PromptNestedEntityOptions(String) |

Assembly: ZwManaged (Module: ZwManaged)


PromptNestedEntityOptions Constructor (message)

PromptNestedEntityOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityOptions »PromptNestedEntityOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptNestedEntityOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptNestedEntityOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptNestedEntityOptions Constructor (messageAndKeywords, globalKeywords)

PromptNestedEntityOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityOptions »PromptNestedEntityOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptNestedEntityOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
PromptNestedEntityOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


AllowNone Property

AllowNone Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityOptions »AllowNone
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowNone { get; set; }
Public Property AllowNone As Boolean
    Get
    Set
public:
property bool AllowNone {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


NonInteractivePickPoint Property

NonInteractivePickPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityOptions »NonInteractivePickPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d NonInteractivePickPoint { get; set; }
Public Property NonInteractivePickPoint As Point3d
    Get
    Set
public:
property Point3d NonInteractivePickPoint {
    Point3d get ();
    void set (Point3d value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseNonInteractivePickPoint Property

UseNonInteractivePickPoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityOptions »UseNonInteractivePickPoint
Declaration Syntax
C# Visual Basic Visual C++
public bool UseNonInteractivePickPoint { get; set; }
Public Property UseNonInteractivePickPoint As Boolean
    Get
    Set
public:
property bool UseNonInteractivePickPoint {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptNestedEntityOptionsEventArgs Class

PromptNestedEntityOptionsEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityOptionsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptNestedEntityOptionsEventArgs : EventArgs
Public NotInheritable Class PromptNestedEntityOptionsEventArgs _
    Inherits EventArgs
public ref class PromptNestedEntityOptionsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Options |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptNestedEntityOptionsEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Options Property

Options Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityOptionsEventArgs »Options
Declaration Syntax
C# Visual Basic Visual C++
public PromptNestedEntityOptions Options { get; }
Public ReadOnly Property Options As PromptNestedEntityOptions
    Get
public:
property PromptNestedEntityOptions^ Options {
    PromptNestedEntityOptions^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptNestedEntityOptionsEventHandler Delegate

PromptNestedEntityOptionsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityOptionsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptNestedEntityOptionsEventHandler(
    Object sender,
    PromptNestedEntityOptionsEventArgs e
)
Public Delegate Sub PromptNestedEntityOptionsEventHandler ( _
    sender As Object, _
    e As PromptNestedEntityOptionsEventArgs _
)
public delegate void PromptNestedEntityOptionsEventHandler(
    Object^ sender,
    PromptNestedEntityOptionsEventArgs^ e
)
Parameters
sender(Object)
e(PromptNestedEntityOptionsEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptNestedEntityResult Class

PromptNestedEntityResult Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityResult
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptNestedEntityResult : PromptEntityResult
Public NotInheritable Class PromptNestedEntityResult _
    Inherits PromptEntityResult
public ref class PromptNestedEntityResult sealed : public PromptEntityResult
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetContainers()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObjectId | (Inherited from PromptEntityResult.)
 | PickedPoint | (Inherited from PromptEntityResult.)
 | Status | (Inherited from PromptResult.)
 | StringResult | (Inherited from PromptResult.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptEntityResult.ToString()()()().)
 | Transform |
Inheritance Hierarchy
Object
 | PromptResult
 |  | PromptEntityResult
 |  |  | PromptNestedEntityResult

Assembly: ZwManaged (Module: ZwManaged)


GetContainers Method

GetContainers Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityResult »GetContainers()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId[] GetContainers()
Public Function GetContainers As ObjectId()
public:
array<ObjectId>^ GetContainers()

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityResult »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptEntityResult.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityResult »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityResult »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


Transform Property

Transform Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityResult »Transform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d Transform { get; }
Public ReadOnly Property Transform As Matrix3d
    Get
public:
property Matrix3d Transform {
    Matrix3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptNestedEntityResultEventArgs Class

PromptNestedEntityResultEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityResultEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptNestedEntityResultEventArgs : EventArgs
Public NotInheritable Class PromptNestedEntityResultEventArgs _
    Inherits EventArgs
public ref class PromptNestedEntityResultEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Result |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptNestedEntityResultEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Result Property

Result Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityResultEventArgs »Result
Declaration Syntax
C# Visual Basic Visual C++
public PromptNestedEntityResult Result { get; }
Public ReadOnly Property Result As PromptNestedEntityResult
    Get
public:
property PromptNestedEntityResult^ Result {
    PromptNestedEntityResult^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptNestedEntityResultEventHandler Delegate

PromptNestedEntityResultEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNestedEntityResultEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptNestedEntityResultEventHandler(
    Object sender,
    PromptNestedEntityResultEventArgs e
)
Public Delegate Sub PromptNestedEntityResultEventHandler ( _
    sender As Object, _
    e As PromptNestedEntityResultEventArgs _
)
public delegate void PromptNestedEntityResultEventHandler(
    Object^ sender,
    PromptNestedEntityResultEventArgs^ e
)
Parameters
sender(Object)
e(PromptNestedEntityResultEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptNumericalOptions Class

PromptNumericalOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNumericalOptions
Declaration Syntax
C# Visual Basic Visual C++
public class PromptNumericalOptions : PromptEditorOptions
Public Class PromptNumericalOptions _
    Inherits PromptEditorOptions
public ref class PromptNumericalOptions : public PromptEditorOptions
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AllowArbitraryInput |
 | AllowNegative |
 | AllowNone |
 | AllowZero |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseDefaultValue |
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptNumericalOptions
 |  |  |  | PromptDistanceOptions
 |  |  |  | PromptDoubleOptions
 |  |  |  | PromptIntegerOptions

Assembly: ZwManaged (Module: ZwManaged)


AllowArbitraryInput Property

AllowArbitraryInput Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNumericalOptions »AllowArbitraryInput
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowArbitraryInput { get; set; }
Public Property AllowArbitraryInput As Boolean
    Get
    Set
public:
property bool AllowArbitraryInput {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


AllowNegative Property

AllowNegative Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNumericalOptions »AllowNegative
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowNegative { get; set; }
Public Property AllowNegative As Boolean
    Get
    Set
public:
property bool AllowNegative {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


AllowNone Property

AllowNone Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNumericalOptions »AllowNone
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowNone { get; set; }
Public Property AllowNone As Boolean
    Get
    Set
public:
property bool AllowNone {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


AllowZero Property

AllowZero Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNumericalOptions »AllowZero
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowZero { get; set; }
Public Property AllowZero As Boolean
    Get
    Set
public:
property bool AllowZero {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseDefaultValue Property

UseDefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptNumericalOptions »UseDefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public bool UseDefaultValue { get; set; }
Public Property UseDefaultValue As Boolean
    Get
    Set
public:
property bool UseDefaultValue {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptOpenFileOptions Class

PromptOpenFileOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOpenFileOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptOpenFileOptions : PromptFileOptions
Public NotInheritable Class PromptOpenFileOptions _
    Inherits PromptFileOptions
public ref class PromptOpenFileOptions sealed : public PromptFileOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptOpenFileOptions(String) |
 | AllowUrls | (Inherited from PromptFileOptions.)
 | DialogCaption | (Inherited from PromptFileOptions.)
 | DialogName | (Inherited from PromptFileOptions.)
 | DoIt()()()() | (Inherited from PromptFileOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Filter | (Inherited from PromptFileOptions.)
 | FilterIndex | (Inherited from PromptFileOptions.)
 | Finalize()()()() | (Inherited from Object.)
 | Flags | (Inherited from PromptFileOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InitialDirectory | (Inherited from PromptFileOptions.)
 | InitialFileName | (Inherited from PromptFileOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptFileOptions.)
 | PreferCommandLine | (Inherited from PromptFileOptions.)
 | SearchPathW |
 | ShowReadOnlyCore | (Inherited from PromptFileOptions.)
 | ToString()()()() | (Inherited from Object.)
 | TransferRemoteFiles |
Inheritance Hierarchy
Object
 | PromptFileOptions
 |  | PromptOpenFileOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptOpenFileOptions Constructor (message)

PromptOpenFileOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOpenFileOptions »PromptOpenFileOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptOpenFileOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptOpenFileOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


SearchPathW Property

SearchPathW Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOpenFileOptions »SearchPathW
Declaration Syntax
C# Visual Basic Visual C++
public bool SearchPathW { get; set; }
Public Property SearchPathW As Boolean
    Get
    Set
public:
property bool SearchPathW {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


TransferRemoteFiles Property

TransferRemoteFiles Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOpenFileOptions »TransferRemoteFiles
Declaration Syntax
C# Visual Basic Visual C++
public bool TransferRemoteFiles { get; set; }
Public Property TransferRemoteFiles As Boolean
    Get
    Set
public:
property bool TransferRemoteFiles {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptOptions Class

PromptOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions
Declaration Syntax
C# Visual Basic Visual C++
public abstract class PromptOptions
Public MustInherit Class PromptOptions
public ref class PromptOptions abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptOptions(String, String) |
 | PromptOptions(String) |
 | AppendKeywordsToMessage |
 | DoIt()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() |
 | GetDefaultValueString()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly |
 | Keywords |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message |
 | SetMessageAndKeywords(String, String) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | JigPromptOptions
 |  | PromptEditorOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptOptions Constructor

PromptOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »PromptOptions()()()()
Members
Icon | Member | Description
 | PromptOptions(String, String) |
 | PromptOptions(String) |

Assembly: ZwManaged (Module: ZwManaged)


PromptOptions Constructor (message)

PromptOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »PromptOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
protected internal PromptOptions(
    string message
)
Protected Friend Sub New ( _
    message As String _
)
protected public:
PromptOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptOptions Constructor (messageAndKeywords, globalKeywords)

PromptOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »PromptOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
protected internal PromptOptions(
    string messageAndKeywords,
    string globalKeywords
)
Protected Friend Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
protected public:
PromptOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


AppendKeywordsToMessage Property

AppendKeywordsToMessage Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »AppendKeywordsToMessage
Declaration Syntax
C# Visual Basic Visual C++
public bool AppendKeywordsToMessage { get; set; }
Public Property AppendKeywordsToMessage As Boolean
    Get
    Set
public:
property bool AppendKeywordsToMessage {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


DoIt Method

DoIt Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »DoIt()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal virtual PromptResult DoIt()
Protected Friend Overridable Function DoIt As PromptResult
protected public:
virtual PromptResult^ DoIt()

Assembly: ZwManaged (Module: ZwManaged)


FormatPrompt Method

FormatPrompt Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »FormatPrompt()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal string FormatPrompt()
Protected Friend Function FormatPrompt As String
protected public:
String^ FormatPrompt()

Assembly: ZwManaged (Module: ZwManaged)


GetDefaultValueString Method

GetDefaultValueString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »GetDefaultValueString()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal virtual string GetDefaultValueString()
Protected Friend Overridable Function GetDefaultValueString As String
protected public:
virtual String^ GetDefaultValueString()

Assembly: ZwManaged (Module: ZwManaged)


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Keywords Property

Keywords Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »Keywords
Declaration Syntax
C# Visual Basic Visual C++
public KeywordCollection Keywords { get; }
Public ReadOnly Property Keywords As KeywordCollection
    Get
public:
property KeywordCollection^ Keywords {
    KeywordCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Message Property

Message Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »Message
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


SetMessageAndKeywords Method (messageAndKeywords, globalKeywords)

SetMessageAndKeywords Method (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptOptions »SetMessageAndKeywords(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetMessageAndKeywords(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub SetMessageAndKeywords ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
void SetMessageAndKeywords(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptPointOptions Class

PromptPointOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointOptions
Declaration Syntax
C# Visual Basic Visual C++
public class PromptPointOptions : PromptCornerOptions
Public Class PromptPointOptions _
    Inherits PromptCornerOptions
public ref class PromptPointOptions : public PromptCornerOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptPointOptions(String, String) |
 | PromptPointOptions(String) |
 | AllowArbitraryInput | (Inherited from PromptCornerOptions.)
 | AllowNone | (Inherited from PromptCornerOptions.)
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | BasePoint | (Inherited from PromptCornerOptions.)
 | DoIt()()()() | (Overrides PromptCornerOptions.DoIt()()()().)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | LimitsChecked | (Inherited from PromptCornerOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseBasePoint |
 | UseDashedLine | (Inherited from PromptCornerOptions.)
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptCornerOptions
 |  |  |  | PromptPointOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptPointOptions Constructor

PromptPointOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointOptions »PromptPointOptions()()()()
Members
Icon | Member | Description
 | PromptPointOptions(String, String) |
 | PromptPointOptions(String) |

Assembly: ZwManaged (Module: ZwManaged)


PromptPointOptions Constructor (message)

PromptPointOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointOptions »PromptPointOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptPointOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


PromptPointOptions Constructor (messageAndKeywords, globalKeywords)

PromptPointOptions Constructor (messageAndKeywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointOptions »PromptPointOptions(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointOptions(
    string messageAndKeywords,
    string globalKeywords
)
Public Sub New ( _
    messageAndKeywords As String, _
    globalKeywords As String _
)
public:
PromptPointOptions(
    String^ messageAndKeywords,
    String^ globalKeywords
)
Parameters
messageAndKeywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


DoIt Method

DoIt Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointOptions »DoIt()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal override PromptResult DoIt()
Protected Friend Overrides Function DoIt As PromptResult
protected public:
virtual PromptResult^ DoIt() override

Assembly: ZwManaged (Module: ZwManaged)


UseBasePoint Property

UseBasePoint Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointOptions »UseBasePoint
Declaration Syntax
C# Visual Basic Visual C++
public bool UseBasePoint { get; set; }
Public Property UseBasePoint As Boolean
    Get
    Set
public:
property bool UseBasePoint {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptPointOptionsEventArgs Class

PromptPointOptionsEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointOptionsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptPointOptionsEventArgs : EventArgs
Public NotInheritable Class PromptPointOptionsEventArgs _
    Inherits EventArgs
public ref class PromptPointOptionsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Options |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptPointOptionsEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Options Property

Options Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointOptionsEventArgs »Options
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointOptions Options { get; }
Public ReadOnly Property Options As PromptPointOptions
    Get
public:
property PromptPointOptions^ Options {
    PromptPointOptions^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptPointOptionsEventHandler Delegate

PromptPointOptionsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointOptionsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptPointOptionsEventHandler(
    Object sender,
    PromptPointOptionsEventArgs e
)
Public Delegate Sub PromptPointOptionsEventHandler ( _
    sender As Object, _
    e As PromptPointOptionsEventArgs _
)
public delegate void PromptPointOptionsEventHandler(
    Object^ sender,
    PromptPointOptionsEventArgs^ e
)
Parameters
sender(Object)
e(PromptPointOptionsEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptPointResult Class

PromptPointResult Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointResult
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptPointResult : PromptResult
Public NotInheritable Class PromptPointResult _
    Inherits PromptResult
public ref class PromptPointResult sealed : public PromptResult
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status | (Inherited from PromptResult.)
 | StringResult | (Inherited from PromptResult.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptResult.ToString()()()().)
 | Value |
Inheritance Hierarchy
Object
 | PromptResult
 |  | PromptPointResult

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointResult »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides PromptResult.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointResult »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointResult »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointResult »Value
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Value { get; }
Public ReadOnly Property Value As Point3d
    Get
public:
property Point3d Value {
    Point3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptPointResultEventArgs Class

PromptPointResultEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointResultEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptPointResultEventArgs : EventArgs
Public NotInheritable Class PromptPointResultEventArgs _
    Inherits EventArgs
public ref class PromptPointResultEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Result |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptPointResultEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Result Property

Result Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointResultEventArgs »Result
Declaration Syntax
C# Visual Basic Visual C++
public PromptPointResult Result { get; }
Public ReadOnly Property Result As PromptPointResult
    Get
public:
property PromptPointResult^ Result {
    PromptPointResult^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptPointResultEventHandler Delegate

PromptPointResultEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptPointResultEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptPointResultEventHandler(
    Object sender,
    PromptPointResultEventArgs e
)
Public Delegate Sub PromptPointResultEventHandler ( _
    sender As Object, _
    e As PromptPointResultEventArgs _
)
public delegate void PromptPointResultEventHandler(
    Object^ sender,
    PromptPointResultEventArgs^ e
)
Parameters
sender(Object)
e(PromptPointResultEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptResult Class

PromptResult Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptResult
Declaration Syntax
C# Visual Basic Visual C++
public class PromptResult
Public Class PromptResult
public ref class PromptResult
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | StringResult |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | PromptResult
 |  | PromptDoubleResult
 |  | PromptEntityResult
 |  | PromptFileNameResult
 |  | PromptIntegerResult
 |  | PromptPointResult

Assembly: ZwManaged (Module: ZwManaged)


Status Property

Status Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptResult »Status
Declaration Syntax
C# Visual Basic Visual C++
public PromptStatus Status { get; }
Public ReadOnly Property Status As PromptStatus
    Get
public:
property PromptStatus Status {
    PromptStatus get ();
}

Assembly: ZwManaged (Module: ZwManaged)


StringResult Property

StringResult Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptResult »StringResult
Declaration Syntax
C# Visual Basic Visual C++
public string StringResult { get; }
Public ReadOnly Property StringResult As String
    Get
public:
property String^ StringResult {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptResult »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptResult »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptResult »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


PromptSaveFileOptions Class

PromptSaveFileOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSaveFileOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptSaveFileOptions : PromptFileOptions
Public NotInheritable Class PromptSaveFileOptions _
    Inherits PromptFileOptions
public ref class PromptSaveFileOptions sealed : public PromptFileOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptSaveFileOptions(String) |
 | AllowUrls | (Inherited from PromptFileOptions.)
 | DeriveInitialFilenameFromDrawingName |
 | DialogCaption | (Inherited from PromptFileOptions.)
 | DialogName | (Inherited from PromptFileOptions.)
 | DisplaySaveOptionsMenuItem |
 | DoIt()()()() | (Inherited from PromptFileOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Filter | (Inherited from PromptFileOptions.)
 | FilterIndex | (Inherited from PromptFileOptions.)
 | Finalize()()()() | (Inherited from Object.)
 | Flags | (Inherited from PromptFileOptions.)
 | ForceOverwriteWarningForScriptsAndLisp |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InitialDirectory | (Inherited from PromptFileOptions.)
 | InitialFileName | (Inherited from PromptFileOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptFileOptions.)
 | PreferCommandLine | (Inherited from PromptFileOptions.)
 | ShowReadOnlyCore | (Inherited from PromptFileOptions.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | PromptFileOptions
 |  | PromptSaveFileOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptSaveFileOptions Constructor (message)

PromptSaveFileOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSaveFileOptions »PromptSaveFileOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptSaveFileOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptSaveFileOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


DeriveInitialFilenameFromDrawingName Property

DeriveInitialFilenameFromDrawingName Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSaveFileOptions »DeriveInitialFilenameFromDrawingName
Declaration Syntax
C# Visual Basic Visual C++
public bool DeriveInitialFilenameFromDrawingName { get; set; }
Public Property DeriveInitialFilenameFromDrawingName As Boolean
    Get
    Set
public:
property bool DeriveInitialFilenameFromDrawingName {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


DisplaySaveOptionsMenuItem Property

DisplaySaveOptionsMenuItem Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSaveFileOptions »DisplaySaveOptionsMenuItem
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplaySaveOptionsMenuItem { get; set; }
Public Property DisplaySaveOptionsMenuItem As Boolean
    Get
    Set
public:
property bool DisplaySaveOptionsMenuItem {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


ForceOverwriteWarningForScriptsAndLisp Property

ForceOverwriteWarningForScriptsAndLisp Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSaveFileOptions »ForceOverwriteWarningForScriptsAndLisp
Declaration Syntax
C# Visual Basic Visual C++
public bool ForceOverwriteWarningForScriptsAndLisp { get; set; }
Public Property ForceOverwriteWarningForScriptsAndLisp As Boolean
    Get
    Set
public:
property bool ForceOverwriteWarningForScriptsAndLisp {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptSelectionOptions Class

PromptSelectionOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptSelectionOptions
Public NotInheritable Class PromptSelectionOptions
public ref class PromptSelectionOptions sealed
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptSelectionOptions()()()() |
 | AllowDuplicates |
 | AllowSubSelections |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | ForceSubSelections |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | KeywordInput |
 | Keywords |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageForAdding |
 | MessageForRemoval |
 | PrepareOptionalDetails |
 | RejectObjectsFromNonCurrentSpace |
 | RejectObjectsOnLockedLayers |
 | RejectPaperspaceViewport |
 | SelectEverythingInAperture |
 | SetKeywords(String, String) |
 | SingleOnly |
 | SinglePickInSpace |
 | ToString()()()() | (Inherited from Object.)
 | UnknownInput |
Inheritance Hierarchy
Object
PromptSelectionOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptSelectionOptions Constructor

PromptSelectionOptions Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »PromptSelectionOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionOptions()
Public Sub New
public:
PromptSelectionOptions()

Assembly: ZwManaged (Module: ZwManaged)


AllowDuplicates Property

AllowDuplicates Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »AllowDuplicates
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowDuplicates { get; set; }
Public Property AllowDuplicates As Boolean
    Get
    Set
public:
property bool AllowDuplicates {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


AllowSubSelections Property

AllowSubSelections Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »AllowSubSelections
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowSubSelections { get; set; }
Public Property AllowSubSelections As Boolean
    Get
    Set
public:
property bool AllowSubSelections {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


ForceSubSelections Property

ForceSubSelections Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »ForceSubSelections
Declaration Syntax
C# Visual Basic Visual C++
public bool ForceSubSelections { get; set; }
Public Property ForceSubSelections As Boolean
    Get
    Set
public:
property bool ForceSubSelections {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


KeywordInput Event

KeywordInput Event
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »KeywordInput
Declaration Syntax
C# Visual Basic Visual C++
public event SelectionTextInputEventHandler KeywordInput
Public Event KeywordInput As SelectionTextInputEventHandler
public:
 event SelectionTextInputEventHandler^ KeywordInput {
    void add (SelectionTextInputEventHandler^ value);
    void remove (SelectionTextInputEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Keywords Property

Keywords Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »Keywords
Declaration Syntax
C# Visual Basic Visual C++
public KeywordCollection Keywords { get; }
Public ReadOnly Property Keywords As KeywordCollection
    Get
public:
property KeywordCollection^ Keywords {
    KeywordCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MessageForAdding Property

MessageForAdding Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »MessageForAdding
Declaration Syntax
C# Visual Basic Visual C++
public string MessageForAdding { get; set; }
Public Property MessageForAdding As String
    Get
    Set
public:
property String^ MessageForAdding {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


MessageForRemoval Property

MessageForRemoval Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »MessageForRemoval
Declaration Syntax
C# Visual Basic Visual C++
public string MessageForRemoval { get; set; }
Public Property MessageForRemoval As String
    Get
    Set
public:
property String^ MessageForRemoval {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PrepareOptionalDetails Property

PrepareOptionalDetails Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »PrepareOptionalDetails
Declaration Syntax
C# Visual Basic Visual C++
public bool PrepareOptionalDetails { get; set; }
Public Property PrepareOptionalDetails As Boolean
    Get
    Set
public:
property bool PrepareOptionalDetails {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


RejectObjectsFromNonCurrentSpace Property

RejectObjectsFromNonCurrentSpace Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »RejectObjectsFromNonCurrentSpace
Declaration Syntax
C# Visual Basic Visual C++
public bool RejectObjectsFromNonCurrentSpace { get; set; }
Public Property RejectObjectsFromNonCurrentSpace As Boolean
    Get
    Set
public:
property bool RejectObjectsFromNonCurrentSpace {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


RejectObjectsOnLockedLayers Property

RejectObjectsOnLockedLayers Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »RejectObjectsOnLockedLayers
Declaration Syntax
C# Visual Basic Visual C++
public bool RejectObjectsOnLockedLayers { get; set; }
Public Property RejectObjectsOnLockedLayers As Boolean
    Get
    Set
public:
property bool RejectObjectsOnLockedLayers {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


RejectPaperspaceViewport Property

RejectPaperspaceViewport Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »RejectPaperspaceViewport
Declaration Syntax
C# Visual Basic Visual C++
public bool RejectPaperspaceViewport { get; set; }
Public Property RejectPaperspaceViewport As Boolean
    Get
    Set
public:
property bool RejectPaperspaceViewport {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


SelectEverythingInAperture Property

SelectEverythingInAperture Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »SelectEverythingInAperture
Declaration Syntax
C# Visual Basic Visual C++
public bool SelectEverythingInAperture { get; set; }
Public Property SelectEverythingInAperture As Boolean
    Get
    Set
public:
property bool SelectEverythingInAperture {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


SetKeywords Method (keywords, globalKeywords)

SetKeywords Method (keywords, globalKeywords)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »SetKeywords(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetKeywords(
    string keywords,
    string globalKeywords
)
Public Sub SetKeywords ( _
    keywords As String, _
    globalKeywords As String _
)
public:
void SetKeywords(
    String^ keywords,
    String^ globalKeywords
)
Parameters
keywords(String)
globalKeywords(String)

Assembly: ZwManaged (Module: ZwManaged)


SingleOnly Property

SingleOnly Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »SingleOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool SingleOnly { get; set; }
Public Property SingleOnly As Boolean
    Get
    Set
public:
property bool SingleOnly {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


SinglePickInSpace Property

SinglePickInSpace Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »SinglePickInSpace
Declaration Syntax
C# Visual Basic Visual C++
public bool SinglePickInSpace { get; set; }
Public Property SinglePickInSpace As Boolean
    Get
    Set
public:
property bool SinglePickInSpace {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


UnknownInput Event

UnknownInput Event
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptions »UnknownInput
Declaration Syntax
C# Visual Basic Visual C++
public event SelectionTextInputEventHandler UnknownInput
Public Event UnknownInput As SelectionTextInputEventHandler
public:
 event SelectionTextInputEventHandler^ UnknownInput {
    void add (SelectionTextInputEventHandler^ value);
    void remove (SelectionTextInputEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptSelectionOptionsEventArgs Class

PromptSelectionOptionsEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptionsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptSelectionOptionsEventArgs : EventArgs
Public NotInheritable Class PromptSelectionOptionsEventArgs _
    Inherits EventArgs
public ref class PromptSelectionOptionsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Filter |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetPoints()()()() |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Options |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptSelectionOptionsEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Filter Property

Filter Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptionsEventArgs »Filter
Declaration Syntax
C# Visual Basic Visual C++
public SelectionFilter Filter { get; }
Public ReadOnly Property Filter As SelectionFilter
    Get
public:
property SelectionFilter^ Filter {
    SelectionFilter^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GetPoints Method

GetPoints Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptionsEventArgs »GetPoints()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] GetPoints()
Public Function GetPoints As Point3d()
public:
array<Point3d>^ GetPoints()

Assembly: ZwManaged (Module: ZwManaged)


Options Property

Options Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptionsEventArgs »Options
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionOptions Options { get; }
Public ReadOnly Property Options As PromptSelectionOptions
    Get
public:
property PromptSelectionOptions^ Options {
    PromptSelectionOptions^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptSelectionOptionsEventHandler Delegate

PromptSelectionOptionsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionOptionsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptSelectionOptionsEventHandler(
    Object sender,
    PromptSelectionOptionsEventArgs e
)
Public Delegate Sub PromptSelectionOptionsEventHandler ( _
    sender As Object, _
    e As PromptSelectionOptionsEventArgs _
)
public delegate void PromptSelectionOptionsEventHandler(
    Object^ sender,
    PromptSelectionOptionsEventArgs^ e
)
Parameters
sender(Object)
e(PromptSelectionOptionsEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptSelectionResult Class

PromptSelectionResult Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionResult
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptSelectionResult
Public NotInheritable Class PromptSelectionResult
public ref class PromptSelectionResult sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)
 | Value |
Inheritance Hierarchy
Object
PromptSelectionResult

Assembly: ZwManaged (Module: ZwManaged)


Status Property

Status Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionResult »Status
Declaration Syntax
C# Visual Basic Visual C++
public PromptStatus Status { get; }
Public ReadOnly Property Status As PromptStatus
    Get
public:
property PromptStatus Status {
    PromptStatus get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionResult »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionResult »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionResult »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionResult »Value
Declaration Syntax
C# Visual Basic Visual C++
public SelectionSet Value { get; }
Public ReadOnly Property Value As SelectionSet
    Get
public:
property SelectionSet^ Value {
    SelectionSet^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptSelectionResultEventArgs Class

PromptSelectionResultEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionResultEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptSelectionResultEventArgs : EventArgs
Public NotInheritable Class PromptSelectionResultEventArgs _
    Inherits EventArgs
public ref class PromptSelectionResultEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Result |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptSelectionResultEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Result Property

Result Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionResultEventArgs »Result
Declaration Syntax
C# Visual Basic Visual C++
public PromptSelectionResult Result { get; }
Public ReadOnly Property Result As PromptSelectionResult
    Get
public:
property PromptSelectionResult^ Result {
    PromptSelectionResult^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptSelectionResultEventHandler Delegate

PromptSelectionResultEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptSelectionResultEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptSelectionResultEventHandler(
    Object sender,
    PromptSelectionResultEventArgs e
)
Public Delegate Sub PromptSelectionResultEventHandler ( _
    sender As Object, _
    e As PromptSelectionResultEventArgs _
)
public delegate void PromptSelectionResultEventHandler(
    Object^ sender,
    PromptSelectionResultEventArgs^ e
)
Parameters
sender(Object)
e(PromptSelectionResultEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptStatus Enumeration

PromptStatus Enumeration
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum PromptStatus
Public Enumeration PromptStatus
public enum class PromptStatus
Members
Member | Description
Other |
OK |
None |
Modeless |
Error |
Cancel |
Keyword |

Assembly: ZwManaged (Module: ZwManaged)


PromptStringOptions Class

PromptStringOptions Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringOptions
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptStringOptions : PromptEditorOptions
Public NotInheritable Class PromptStringOptions _
    Inherits PromptEditorOptions
public ref class PromptStringOptions sealed : public PromptEditorOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromptStringOptions(String) |
 | AllowSpaces |
 | AppendKeywordsToMessage | (Inherited from PromptOptions.)
 | DefaultValue |
 | DoIt()()()() | (Inherited from PromptOptions.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatPrompt()()()() | (Inherited from PromptOptions.)
 | GetDefaultValueString()()()() | (Inherited from PromptOptions.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsReadOnly | (Inherited from PromptOptions.)
 | Keywords | (Inherited from PromptOptions.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from PromptOptions.)
 | SetMessageAndKeywords(String, String) | (Inherited from PromptOptions.)
 | ToString()()()() | (Inherited from Object.)
 | UseDefaultValue |
Inheritance Hierarchy
Object
 | PromptOptions
 |  | PromptEditorOptions
 |  |  | PromptStringOptions

Assembly: ZwManaged (Module: ZwManaged)


PromptStringOptions Constructor (message)

PromptStringOptions Constructor (message)
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringOptions »PromptStringOptions(String)
Declaration Syntax
C# Visual Basic Visual C++
public PromptStringOptions(
    string message
)
Public Sub New ( _
    message As String _
)
public:
PromptStringOptions(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


AllowSpaces Property

AllowSpaces Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringOptions »AllowSpaces
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowSpaces { get; set; }
Public Property AllowSpaces As Boolean
    Get
    Set
public:
property bool AllowSpaces {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


DefaultValue Property

DefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringOptions »DefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public string DefaultValue { get; set; }
Public Property DefaultValue As String
    Get
    Set
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


UseDefaultValue Property

UseDefaultValue Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringOptions »UseDefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public bool UseDefaultValue { get; set; }
Public Property UseDefaultValue As Boolean
    Get
    Set
public:
property bool UseDefaultValue {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptStringOptionsEventArgs Class

PromptStringOptionsEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringOptionsEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptStringOptionsEventArgs : EventArgs
Public NotInheritable Class PromptStringOptionsEventArgs _
    Inherits EventArgs
public ref class PromptStringOptionsEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Options |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptStringOptionsEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Options Property

Options Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringOptionsEventArgs »Options
Declaration Syntax
C# Visual Basic Visual C++
public PromptStringOptions Options { get; }
Public ReadOnly Property Options As PromptStringOptions
    Get
public:
property PromptStringOptions^ Options {
    PromptStringOptions^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptStringOptionsEventHandler Delegate

PromptStringOptionsEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringOptionsEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptStringOptionsEventHandler(
    Object sender,
    PromptStringOptionsEventArgs e
)
Public Delegate Sub PromptStringOptionsEventHandler ( _
    sender As Object, _
    e As PromptStringOptionsEventArgs _
)
public delegate void PromptStringOptionsEventHandler(
    Object^ sender,
    PromptStringOptionsEventArgs^ e
)
Parameters
sender(Object)
e(PromptStringOptionsEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PromptStringResultEventArgs Class

PromptStringResultEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringResultEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PromptStringResultEventArgs : EventArgs
Public NotInheritable Class PromptStringResultEventArgs _
    Inherits EventArgs
public ref class PromptStringResultEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Result |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PromptStringResultEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Result Property

Result Property
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringResultEventArgs »Result
Declaration Syntax
C# Visual Basic Visual C++
public PromptResult Result { get; }
Public ReadOnly Property Result As PromptResult
    Get
public:
property PromptResult^ Result {
    PromptResult^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PromptStringResultEventHandler Delegate

PromptStringResultEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »PromptStringResultEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PromptStringResultEventHandler(
    Object sender,
    PromptStringResultEventArgs e
)
Public Delegate Sub PromptStringResultEventHandler ( _
    sender As Object, _
    e As PromptStringResultEventArgs _
)
public delegate void PromptStringResultEventHandler(
    Object^ sender,
    PromptStringResultEventArgs^ e
)
Parameters
sender(Object)
e(PromptStringResultEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


RolloverEventArgs Class

RolloverEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »RolloverEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class RolloverEventArgs : EventArgs
Public NotInheritable Class RolloverEventArgs _
    Inherits EventArgs
public ref class RolloverEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Highlighted |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Picked |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | RolloverEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Highlighted Property

Highlighted Property
Namespaces »ZwSoft.ZwCAD.EditorInput »RolloverEventArgs »Highlighted
Declaration Syntax
C# Visual Basic Visual C++
public FullSubentityPath Highlighted { get; set; }
Public Property Highlighted As FullSubentityPath
    Get
    Set
public:
property FullSubentityPath Highlighted {
    FullSubentityPath get ();
    void set (FullSubentityPath value);
}

Assembly: ZwManaged (Module: ZwManaged)


Picked Property

Picked Property
Namespaces »ZwSoft.ZwCAD.EditorInput »RolloverEventArgs »Picked
Declaration Syntax
C# Visual Basic Visual C++
public FullSubentityPath Picked { get; }
Public ReadOnly Property Picked As FullSubentityPath
    Get
public:
property FullSubentityPath Picked {
    FullSubentityPath get ();
}

Assembly: ZwManaged (Module: ZwManaged)


RolloverEventHandler Delegate

RolloverEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »RolloverEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void RolloverEventHandler(
    Object sender,
    RolloverEventArgs e
)
Public Delegate Sub RolloverEventHandler ( _
    sender As Object, _
    e As RolloverEventArgs _
)
public delegate void RolloverEventHandler(
    Object^ sender,
    RolloverEventArgs^ e
)
Parameters
sender(Object)
e(RolloverEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


SamplerStatus Enumeration

SamplerStatus Enumeration
Namespaces »ZwSoft.ZwCAD.EditorInput »SamplerStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum SamplerStatus
Public Enumeration SamplerStatus
public enum class SamplerStatus
Members
Member | Description
Cancel |
NoChange |
OK |

Assembly: ZwManaged (Module: ZwManaged)


SelectedObject Class

SelectedObject Class
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject
Declaration Syntax
C# Visual Basic Visual C++
public class SelectedObject
Public Class SelectedObject
public ref class SelectedObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectedObject(ObjectId, SelectionMethod, IntPtr) |
 | SelectedObject(ObjectId, SelectionMethod, Int64) | Obsolete.
 | SelectedObject(ObjectId, array<SelectedSubObject>[]()[][]) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSubentities()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GraphicsSystemMarker | Obsolete.
 | GraphicsSystemMarkerPtr |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObjectId |
 | OptionalDetails |
 | SelectionMethod |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | SelectedObject
 |  | CrossingOrWindowSelectedObject
 |  | FenceSelectedObject
 |  | PickPointSelectedObject

Assembly: ZwManaged (Module: ZwManaged)


SelectedObject Constructor

SelectedObject Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »SelectedObject()()()()
Members
Icon | Member | Description
 | SelectedObject(ObjectId, SelectionMethod, IntPtr) |
 | SelectedObject(ObjectId, SelectionMethod, Int64) | Obsolete.
 | SelectedObject(ObjectId, array<SelectedSubObject>[]()[][]) |

Assembly: ZwManaged (Module: ZwManaged)


SelectedObject Constructor (id, subSelections)

SelectedObject Constructor (id, subSelections)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »SelectedObject(ObjectId, array<SelectedSubObject>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SelectedObject(
    ObjectId id,
    SelectedSubObject[] subSelections
)
Public Sub New ( _
    id As ObjectId, _
    subSelections As SelectedSubObject() _
)
public:
SelectedObject(
    ObjectId id,
    array<SelectedSubObject^>^ subSelections
)
Parameters
id(ObjectId)
subSelections(array< SelectedSubObject >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


SelectedObject Constructor (id, method, gsMarker)

SelectedObject Constructor (id, method, gsMarker)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »SelectedObject(ObjectId, SelectionMethod, Int64)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use overload taking System::IntPtr instead.")]
public SelectedObject(
    ObjectId id,
    SelectionMethod method,
    long gsMarker
)
<ObsoleteAttribute("Use overload taking System::IntPtr instead.")> _
Public Sub New ( _
    id As ObjectId, _
    method As SelectionMethod, _
    gsMarker As Long _
)
[ObsoleteAttribute(L"Use overload taking System::IntPtr instead.")]
public:
SelectedObject(
    ObjectId id,
    SelectionMethod method,
    long long gsMarker
)
Parameters
id(ObjectId)
method(SelectionMethod)
gsMarker(Int64)

Assembly: ZwManaged (Module: ZwManaged)


SelectedObject Constructor (id, method, gsMarker)

SelectedObject Constructor (id, method, gsMarker)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »SelectedObject(ObjectId, SelectionMethod, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public SelectedObject(
    ObjectId id,
    SelectionMethod method,
    IntPtr gsMarker
)
Public Sub New ( _
    id As ObjectId, _
    method As SelectionMethod, _
    gsMarker As IntPtr _
)
public:
SelectedObject(
    ObjectId id,
    SelectionMethod method,
    IntPtr gsMarker
)
Parameters
id(ObjectId)
method(SelectionMethod)
gsMarker(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


GetSubentities Method

GetSubentities Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »GetSubentities()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SelectedSubObject[] GetSubentities()
Public Function GetSubentities As SelectedSubObject()
public:
array<SelectedSubObject^>^ GetSubentities()

Assembly: ZwManaged (Module: ZwManaged)


GraphicsSystemMarker Property

GraphicsSystemMarker Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »GraphicsSystemMarker
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use GraphicsSystemMarkerPtr instead.")]
public long GraphicsSystemMarker { get; }
<ObsoleteAttribute("Use GraphicsSystemMarkerPtr instead.")> _
Public ReadOnly Property GraphicsSystemMarker As Long
    Get
[ObsoleteAttribute(L"Use GraphicsSystemMarkerPtr instead.")]
public:
property long long GraphicsSystemMarker {
    long long get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GraphicsSystemMarkerPtr Property

GraphicsSystemMarkerPtr Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »GraphicsSystemMarkerPtr
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr GraphicsSystemMarkerPtr { get; }
Public ReadOnly Property GraphicsSystemMarkerPtr As IntPtr
    Get
public:
property IntPtr GraphicsSystemMarkerPtr {
    IntPtr get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ObjectId Property

ObjectId Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »ObjectId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId ObjectId { get; }
Public ReadOnly Property ObjectId As ObjectId
    Get
public:
property ObjectId ObjectId {
    ObjectId get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OptionalDetails Property

OptionalDetails Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »OptionalDetails
Declaration Syntax
C# Visual Basic Visual C++
public SelectionDetails OptionalDetails { get; internal set; }
Public Property OptionalDetails As SelectionDetails
    Get
    Friend Set
public:
property SelectionDetails^ OptionalDetails {
    SelectionDetails^ get ();
    internal: void set (SelectionDetails^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


SelectionMethod Property

SelectionMethod Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »SelectionMethod
Declaration Syntax
C# Visual Basic Visual C++
public SelectionMethod SelectionMethod { get; }
Public ReadOnly Property SelectionMethod As SelectionMethod
    Get
public:
property SelectionMethod SelectionMethod {
    SelectionMethod get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedObject »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


SelectedSubObject Class

SelectedSubObject Class
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject
Declaration Syntax
C# Visual Basic Visual C++
public class SelectedSubObject
Public Class SelectedSubObject
public ref class SelectedSubObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr) |
 | SelectedSubObject(FullSubentityPath, SelectionMethod, Int32) | Obsolete.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FullSubentityPath |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GraphicsSystemMarker | Obsolete.
 | GraphicsSystemMarkerPtr |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OptionalDetails |
 | SelectionMethod |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | SelectedSubObject
 |  | CrossingOrWindowSelectedSubObject
 |  | FenceSelectedSubObject
 |  | PickPointSelectedSubObject

Assembly: ZwManaged (Module: ZwManaged)


SelectedSubObject Constructor

SelectedSubObject Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »SelectedSubObject()()()()
Members
Icon | Member | Description
 | SelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr) |
 | SelectedSubObject(FullSubentityPath, SelectionMethod, Int32) | Obsolete.

Assembly: ZwManaged (Module: ZwManaged)


SelectedSubObject Constructor (path, method, gsMarker)

SelectedSubObject Constructor (path, method, gsMarker)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »SelectedSubObject(FullSubentityPath, SelectionMethod, Int32)
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use overload taking System::IntPtr instead.")]
public SelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    int gsMarker
)
<ObsoleteAttribute("Use overload taking System::IntPtr instead.")> _
Public Sub New ( _
    path As FullSubentityPath, _
    method As SelectionMethod, _
    gsMarker As Integer _
)
[ObsoleteAttribute(L"Use overload taking System::IntPtr instead.")]
public:
SelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    int gsMarker
)
Parameters
path(FullSubentityPath)
method(SelectionMethod)
gsMarker(Int32)

Assembly: ZwManaged (Module: ZwManaged)


SelectedSubObject Constructor (path, method, gsMarker)

SelectedSubObject Constructor (path, method, gsMarker)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »SelectedSubObject(FullSubentityPath, SelectionMethod, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public SelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    IntPtr gsMarker
)
Public Sub New ( _
    path As FullSubentityPath, _
    method As SelectionMethod, _
    gsMarker As IntPtr _
)
public:
SelectedSubObject(
    FullSubentityPath path,
    SelectionMethod method,
    IntPtr gsMarker
)
Parameters
path(FullSubentityPath)
method(SelectionMethod)
gsMarker(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


FullSubentityPath Property

FullSubentityPath Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »FullSubentityPath
Declaration Syntax
C# Visual Basic Visual C++
public FullSubentityPath FullSubentityPath { get; }
Public ReadOnly Property FullSubentityPath As FullSubentityPath
    Get
public:
property FullSubentityPath FullSubentityPath {
    FullSubentityPath get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GraphicsSystemMarker Property

GraphicsSystemMarker Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »GraphicsSystemMarker
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use GraphicsSystemMarkerPtr instead.")]
public long GraphicsSystemMarker { get; }
<ObsoleteAttribute("Use GraphicsSystemMarkerPtr instead.")> _
Public ReadOnly Property GraphicsSystemMarker As Long
    Get
[ObsoleteAttribute(L"Use GraphicsSystemMarkerPtr instead.")]
public:
property long long GraphicsSystemMarker {
    long long get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GraphicsSystemMarkerPtr Property

GraphicsSystemMarkerPtr Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »GraphicsSystemMarkerPtr
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr GraphicsSystemMarkerPtr { get; }
Public ReadOnly Property GraphicsSystemMarkerPtr As IntPtr
    Get
public:
property IntPtr GraphicsSystemMarkerPtr {
    IntPtr get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OptionalDetails Property

OptionalDetails Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »OptionalDetails
Declaration Syntax
C# Visual Basic Visual C++
public SelectionDetails OptionalDetails { get; }
Public ReadOnly Property OptionalDetails As SelectionDetails
    Get
public:
property SelectionDetails^ OptionalDetails {
    SelectionDetails^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


SelectionMethod Property

SelectionMethod Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »SelectionMethod
Declaration Syntax
C# Visual Basic Visual C++
public SelectionMethod SelectionMethod { get; }
Public ReadOnly Property SelectionMethod As SelectionMethod
    Get
public:
property SelectionMethod SelectionMethod {
    SelectionMethod get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectedSubObject »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


SelectionAddedEventArgs Class

SelectionAddedEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SelectionAddedEventArgs : EventArgs,
    IDisposable
Public NotInheritable Class SelectionAddedEventArgs _
    Inherits EventArgs _
    Implements IDisposable
public ref class SelectionAddedEventArgs sealed : public EventArgs,
    IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(SelectedObject) |
 | AddedObjects |
 | AddSubEntity(SelectedSubObject) |
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | Flags |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Highlight(Int32, FullSubentityPath) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Int32) |
 | RemoveSubEntity(Int32, Int32) |
 | Selection |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SelectionAddedEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventArgs »Add(SelectedObject)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    SelectedObject value
)
Public Sub Add ( _
    value As SelectedObject _
)
public:
void Add(
    SelectedObject^ value
)
Parameters
value(SelectedObject)

Assembly: ZwManaged (Module: ZwManaged)


AddedObjects Property

AddedObjects Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventArgs »AddedObjects
Declaration Syntax
C# Visual Basic Visual C++
public SelectionSet AddedObjects { get; }
Public ReadOnly Property AddedObjects As SelectionSet
    Get
public:
property SelectionSet^ AddedObjects {
    SelectionSet^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


AddSubEntity Method (value)

AddSubEntity Method (value)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventArgs »AddSubEntity(SelectedSubObject)
Declaration Syntax
C# Visual Basic Visual C++
public void AddSubEntity(
    SelectedSubObject value
)
Public Sub AddSubEntity ( _
    value As SelectedSubObject _
)
public:
void AddSubEntity(
    SelectedSubObject^ value
)
Parameters
value(SelectedSubObject)

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventArgs »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


Flags Property

Flags Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventArgs »Flags
Declaration Syntax
C# Visual Basic Visual C++
public SelectionFlags Flags { get; }
Public ReadOnly Property Flags As SelectionFlags
    Get
public:
property SelectionFlags Flags {
    SelectionFlags get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Highlight Method (subSelectionIndex, path)

Highlight Method (subSelectionIndex, path)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventArgs »Highlight(Int32, FullSubentityPath)
Declaration Syntax
C# Visual Basic Visual C++
public void Highlight(
    int subSelectionIndex,
    FullSubentityPath path
)
Public Sub Highlight ( _
    subSelectionIndex As Integer, _
    path As FullSubentityPath _
)
public:
void Highlight(
    int subSelectionIndex,
    FullSubentityPath path
)
Parameters
subSelectionIndex(Int32)
path(FullSubentityPath)

Assembly: ZwManaged (Module: ZwManaged)


Remove Method (index)

Remove Method (index)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventArgs »Remove(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    int index
)
Public Sub Remove ( _
    index As Integer _
)
public:
void Remove(
    int index
)
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


RemoveSubEntity Method (entityIndex, subEntityIndex)

RemoveSubEntity Method (entityIndex, subEntityIndex)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventArgs »RemoveSubEntity(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveSubEntity(
    int entityIndex,
    int subEntityIndex
)
Public Sub RemoveSubEntity ( _
    entityIndex As Integer, _
    subEntityIndex As Integer _
)
public:
void RemoveSubEntity(
    int entityIndex,
    int subEntityIndex
)
Parameters
entityIndex(Int32)
subEntityIndex(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Selection Property

Selection Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventArgs »Selection
Declaration Syntax
C# Visual Basic Visual C++
public SelectionSet Selection { get; }
Public ReadOnly Property Selection As SelectionSet
    Get
public:
property SelectionSet^ Selection {
    SelectionSet^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


SelectionAddedEventHandler Delegate

SelectionAddedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionAddedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void SelectionAddedEventHandler(
    Object sender,
    SelectionAddedEventArgs e
)
Public Delegate Sub SelectionAddedEventHandler ( _
    sender As Object, _
    e As SelectionAddedEventArgs _
)
public delegate void SelectionAddedEventHandler(
    Object^ sender,
    SelectionAddedEventArgs^ e
)
Parameters
sender(Object)
e(SelectionAddedEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


SelectionDetails Class

SelectionDetails Class
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionDetails
Declaration Syntax
C# Visual Basic Visual C++
public class SelectionDetails
Public Class SelectionDetails
public ref class SelectionDetails
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetContainers()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)
 | Transform |
Inheritance Hierarchy
Object
SelectionDetails

Assembly: ZwManaged (Module: ZwManaged)


GetContainers Method

GetContainers Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionDetails »GetContainers()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId[] GetContainers()
Public Function GetContainers As ObjectId()
public:
array<ObjectId>^ GetContainers()

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionDetails »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionDetails »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionDetails »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


Transform Property

Transform Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionDetails »Transform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d Transform { get; }
Public ReadOnly Property Transform As Matrix3d
    Get
public:
property Matrix3d Transform {
    Matrix3d get ();
}

Assembly: ZwManaged (Module: ZwManaged)


SelectionFilter Class

SelectionFilter Class
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionFilter
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SelectionFilter
Public NotInheritable Class SelectionFilter
public ref class SelectionFilter sealed
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SelectionFilter(array<TypedValue>[]()[][]) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetFilter()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SelectionFilter

Assembly: ZwManaged (Module: ZwManaged)


SelectionFilter Constructor (value)

SelectionFilter Constructor (value)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionFilter »SelectionFilter(array<TypedValue>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SelectionFilter(
    TypedValue[] value
)
Public Sub New ( _
    value As TypedValue() _
)
public:
SelectionFilter(
    array<TypedValue>^ value
)
Parameters
value(array< TypedValue >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


GetFilter Method

GetFilter Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionFilter »GetFilter()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TypedValue[] GetFilter()
Public Function GetFilter As TypedValue()
public:
array<TypedValue>^ GetFilter()

Assembly: ZwManaged (Module: ZwManaged)


SelectionFlags Enumeration

SelectionFlags Enumeration
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum SelectionFlags
<FlagsAttribute> _
Public Enumeration SelectionFlags
[FlagsAttribute]
public enum class SelectionFlags
Members
Member | Description
FailedPickAuto |
Undo |
SubSelection |
PreviousSet |
PickfirstSet |
SinglePick |
SubEntities |
NestedEntities |
Duplicates |
PickPoints |
Normal |

Assembly: ZwManaged (Module: ZwManaged)


SelectionMethod Enumeration

SelectionMethod Enumeration
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionMethod
Declaration Syntax
C# Visual Basic Visual C++
public enum SelectionMethod
Public Enumeration SelectionMethod
public enum class SelectionMethod
Members
Member | Description
SubEntity |
Fence |
Crossing |
Window |
PickPoint |
NonGraphical |
Unavailable |

Assembly: ZwManaged (Module: ZwManaged)


SelectionRemovedEventArgs Class

SelectionRemovedEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionRemovedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SelectionRemovedEventArgs : EventArgs,
    IDisposable
Public NotInheritable Class SelectionRemovedEventArgs _
    Inherits EventArgs _
    Implements IDisposable
public ref class SelectionRemovedEventArgs sealed : public EventArgs,
    IDisposable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | Flags |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Int32) |
 | RemovedObjects |
 | RemoveSubentity(Int32, Int32) |
 | Selection |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SelectionRemovedEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionRemovedEventArgs »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


Flags Property

Flags Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionRemovedEventArgs »Flags
Declaration Syntax
C# Visual Basic Visual C++
public SelectionFlags Flags { get; }
Public ReadOnly Property Flags As SelectionFlags
    Get
public:
property SelectionFlags Flags {
    SelectionFlags get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Remove Method (index)

Remove Method (index)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionRemovedEventArgs »Remove(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    int index
)
Public Sub Remove ( _
    index As Integer _
)
public:
void Remove(
    int index
)
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


RemovedObjects Property

RemovedObjects Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionRemovedEventArgs »RemovedObjects
Declaration Syntax
C# Visual Basic Visual C++
public SelectionSet RemovedObjects { get; }
Public ReadOnly Property RemovedObjects As SelectionSet
    Get
public:
property SelectionSet^ RemovedObjects {
    SelectionSet^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


RemoveSubentity Method (index, subentityIndex)

RemoveSubentity Method (index, subentityIndex)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionRemovedEventArgs »RemoveSubentity(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveSubentity(
    int index,
    int subentityIndex
)
Public Sub RemoveSubentity ( _
    index As Integer, _
    subentityIndex As Integer _
)
public:
void RemoveSubentity(
    int index,
    int subentityIndex
)
Parameters
index(Int32)
subentityIndex(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Selection Property

Selection Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionRemovedEventArgs »Selection
Declaration Syntax
C# Visual Basic Visual C++
public SelectionSet Selection { get; }
Public ReadOnly Property Selection As SelectionSet
    Get
public:
property SelectionSet^ Selection {
    SelectionSet^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


SelectionRemovedEventHandler Delegate

SelectionRemovedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionRemovedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void SelectionRemovedEventHandler(
    Object sender,
    SelectionRemovedEventArgs e
)
Public Delegate Sub SelectionRemovedEventHandler ( _
    sender As Object, _
    e As SelectionRemovedEventArgs _
)
public delegate void SelectionRemovedEventHandler(
    Object^ sender,
    SelectionRemovedEventArgs^ e
)
Parameters
sender(Object)
e(SelectionRemovedEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


SelectionSet Class

SelectionSet Class
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet
Declaration Syntax
C# Visual Basic Visual C++
public abstract class SelectionSet : ICollection,
    IDisposable
Public MustInherit Class SelectionSet _
    Implements ICollection, IDisposable
public ref class SelectionSet abstract : ICollection,
    IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectionSet()()()() |
 | CopyTo(array<SelectedObject>[]()[][], Int32) |
 | CopyTo(Array, Int32) |
 | Count |
 | Dispose(Boolean) |
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FromObjectIds(array<ObjectId>[]()[][]) |
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectIds()()()() |
 | GetType()()()() | (Inherited from Object.)
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SyncRoot |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | SelectionSet
 |  | SelectionSetDelayMarshalled

Assembly: ZwManaged (Module: ZwManaged)


SelectionSet Constructor

SelectionSet Constructor
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »SelectionSet()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected SelectionSet()
Protected Sub New
protected:
SelectionSet()

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method

CopyTo Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SelectedObject>[]()[][], Int32) |
 | CopyTo(Array, Int32) |

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyTo(
    Array arr,
    int index
)
Public Overridable Sub CopyTo ( _
    arr As Array, _
    index As Integer _
)
public:
virtual void CopyTo(
    Array^ arr,
    int index
)
Parameters
arr(Array)
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »CopyTo(array<SelectedObject>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyTo(
    SelectedObject[] arr,
    int index
)
Public Overridable Sub CopyTo ( _
    arr As SelectedObject(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<SelectedObject^>^ arr,
    int index
)
Parameters
arr(array< SelectedObject >[]()[][])
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »Count
Declaration Syntax
C# Visual Basic Visual C++
public abstract int Count { get; }
Public MustOverride ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () abstract;
}

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method ()

Dispose Method ()
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »Dispose(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool
)
Protected Overridable Sub Dispose ( _
     As Boolean _
)
protected:
virtual void Dispose(
    bool
)
Parameters
(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


FromObjectIds Method (ids)

FromObjectIds Method (ids)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »FromObjectIds(array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public static SelectionSet FromObjectIds(
    ObjectId[] ids
)
Public Shared Function FromObjectIds ( _
    ids As ObjectId() _
) As SelectionSet
public:
static SelectionSet^ FromObjectIds(
    array<ObjectId>^ ids
)
Parameters
ids(array< ObjectId >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract IEnumerator GetEnumerator()
Public MustOverride Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() abstract

Assembly: ZwManaged (Module: ZwManaged)


GetObjectIds Method

GetObjectIds Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »GetObjectIds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId[] GetObjectIds()
Public MustOverride Function GetObjectIds As ObjectId()
public:
virtual array<ObjectId>^ GetObjectIds() abstract

Assembly: ZwManaged (Module: ZwManaged)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public abstract SelectedObject this[
    int index
] { get; }
Public MustOverride ReadOnly Default Property Item ( _
    index As Integer _
) As SelectedObject
    Get
public:
virtual property SelectedObject^ default[int index] {
    SelectedObject^ get (int index) abstract;
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSet »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


SelectionSetDelayMarshalled Class

SelectionSetDelayMarshalled Class
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSetDelayMarshalled
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SelectionSetDelayMarshalled : SelectionSet
Public NotInheritable Class SelectionSetDelayMarshalled _
    Inherits SelectionSet
public ref class SelectionSetDelayMarshalled sealed : public SelectionSet
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CopyTo(array<SelectedObject>[]()[][], Int32) | (Inherited from SelectionSet.)
 | CopyTo(Array, Int32) | (Inherited from SelectionSet.)
 | Count | (Overrides SelectionSet.Count.)
 | Dispose(Boolean) | (Inherited from SelectionSet.)
 | Dispose()()()() | (Inherited from SelectionSet.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Overrides SelectionSet.GetEnumerator()()()().)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectIds()()()() | (Overrides SelectionSet.GetObjectIds()()()().)
 | GetType()()()() | (Inherited from Object.)
 | IsSynchronized | (Inherited from SelectionSet.)
 | Item[([( Int32])]) | (Overrides SelectionSet.Item[([( Int32])]) .)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | SyncRoot | (Inherited from SelectionSet.)
 | ToString(IFormatProvider) | (Inherited from SelectionSet.)
 | ToString()()()() | (Inherited from SelectionSet.)
Inheritance Hierarchy
Object
 | SelectionSet
 |  | SelectionSetDelayMarshalled

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSetDelayMarshalled »Count
Declaration Syntax
C# Visual Basic Visual C++
public override int Count { get; }
Public Overrides ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () override;
}

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSetDelayMarshalled »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed IEnumerator GetEnumerator()
Public Overrides NotOverridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() override sealed

Assembly: ZwManaged (Module: ZwManaged)


GetObjectIds Method

GetObjectIds Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSetDelayMarshalled »GetObjectIds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed ObjectId[] GetObjectIds()
Public Overrides NotOverridable Function GetObjectIds As ObjectId()
public:
virtual array<ObjectId>^ GetObjectIds() override sealed

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSetDelayMarshalled »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public override SelectedObject this[
    int index
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    index As Integer _
) As SelectedObject
    Get
public:
virtual property SelectedObject^ default[int index] {
    SelectedObject^ get (int index) override;
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSetDelayMarshalled »Name
Declaration Syntax
C# Visual Basic Visual C++
public ZdsName Name { get; }
Public ReadOnly Property Name As ZdsName
    Get
public:
property ZdsName Name {
    ZdsName get ();
}

Assembly: ZwManaged (Module: ZwManaged)


SelectionTextInputEventArgs Class

SelectionTextInputEventArgs Class
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionTextInputEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SelectionTextInputEventArgs : EventArgs
Public NotInheritable Class SelectionTextInputEventArgs _
    Inherits EventArgs
public ref class SelectionTextInputEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddObjects(array<ObjectId>[]()[][]) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Input |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetErrorMessage(String) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SelectionTextInputEventArgs

Assembly: ZwManaged (Module: ZwManaged)


AddObjects Method (ids)

AddObjects Method (ids)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionTextInputEventArgs »AddObjects(array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddObjects(
    ObjectId[] ids
)
Public Sub AddObjects ( _
    ids As ObjectId() _
)
public:
void AddObjects(
    array<ObjectId>^ ids
)
Parameters
ids(array< ObjectId >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


Input Property

Input Property
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionTextInputEventArgs »Input
Declaration Syntax
C# Visual Basic Visual C++
public string Input { get; }
Public ReadOnly Property Input As String
    Get
public:
property String^ Input {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


SetErrorMessage Method (errorMessage)

SetErrorMessage Method (errorMessage)
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionTextInputEventArgs »SetErrorMessage(String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetErrorMessage(
    string errorMessage
)
Public Sub SetErrorMessage ( _
    errorMessage As String _
)
public:
void SetErrorMessage(
    String^ errorMessage
)
Parameters
errorMessage(String)

Assembly: ZwManaged (Module: ZwManaged)


SelectionTextInputEventHandler Delegate

SelectionTextInputEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionTextInputEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void SelectionTextInputEventHandler(
    Object sender,
    SelectionTextInputEventArgs e
)
Public Delegate Sub SelectionTextInputEventHandler ( _
    sender As Object, _
    e As SelectionTextInputEventArgs _
)
public delegate void SelectionTextInputEventHandler(
    Object^ sender,
    SelectionTextInputEventArgs^ e
)
Parameters
sender(Object)
e(SelectionTextInputEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


UserInputControls Enumeration

UserInputControls Enumeration
Namespaces »ZwSoft.ZwCAD.EditorInput »UserInputControls
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum UserInputControls
<FlagsAttribute> _
Public Enumeration UserInputControls
[FlagsAttribute]
public enum class UserInputControls
Members
Member | Description
AcceptOtherInputString |
InitialBlankTerminatesInput |
AnyBlankTerminatesInput |
AcceptMouseUpAsPoint |
Accept3dCoordinates |
NoNegativeResponseAccepted |
NoZeroResponseAccepted |
NoDwgLimitsChecking |
DoNotUpdateLastPoint |
DoNotEchoCancelForCtrlC |
NullResponseAccepted |
GovernedByOrthoMode |

Assembly: ZwManaged (Module: ZwManaged)


ZwSoft.ZwCAD.Geometry Namespace

ZwSoft.ZwCAD.Geometry Namespace
Namespaces »ZwSoft.ZwCAD.Geometry
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.Geometry
Namespace ZwSoft.ZwCAD.Geometry
namespace ZwSoft.ZwCAD.Geometry
Types
All Types Classes Structures Enumerations
Icon | Type | Description
 | AugmentedPolylineCurve3d |
 | BoundBlock2d |
 | BoundBlock3d |
 | BoundedPlane |
 | CircularArc2d |
 | CircularArc3d |
 | ClipBoundary2d |
 | ClipBoundary2dData |
 | ClipCondition |
 | ClipError |
 | CompositeCurve2d |
 | CompositeCurve3d |
 | CompositeParameter |
 | Cone |
 | CoordinateSystem2d |
 | CoordinateSystem3d |
 | CubicSplineCurve2d |
 | CubicSplineCurve3d |
 | Curve2d |
 | Curve2dCollection |
 | Curve3d |
 | Curve3dCollection |
 | CurveBoundary |
 | CurveBoundaryData |
 | CurveCurveIntersector2d |
 | CurveCurveIntersector3d |
 | Cylinder |
 | DoubleCollection |
 | DoubleCollectionEnumerator |
 | EllipticalArc2d |
 | EllipticalArc3d |
 | Entity2d |
 | Entity3d |
 | ExternalBoundedSurface |
 | ExternalEntityKind |
 | ExternalSurface |
 | GeoDataLonLatAltInfo |
 | Int32Collection |
 | Int32CollectionEnumerator |
 | IntegerCollection |
 | IntegerCollectionEnumerator |
 | Interval |
 | IntPtrCollection |
 | IntPtrCollectionEnumerator |
 | KnotCollection |
 | KnotParameterizationEnum |
 | Line2d |
 | Line2dCollection |
 | Line3d |
 | LinearEntity2d |
 | LinearEntity3d |
 | LineSegment2d |
 | LineSegment3d |
 | Matrix2d |
 | Matrix2dBuilder |
 | Matrix2dInfo |
 | Matrix3d |
 | Matrix3dBuilder |
 | NurbCurve2d |
 | NurbCurve2dData |
 | NurbCurve2dFitData |
 | NurbCurve3d |
 | NurbCurve3dData |
 | NurbCurve3dFitData |
 | NurbSurface |
 | NurbSurfaceDefinition |
 | OffsetCurve2d |
 | OffsetCurve3d |
 | OffsetCurveExtensionType |
 | OffsetSurface |
 | PlanarEntity |
 | PlanarEquationCoefficients |
 | Plane |
 | Point2d |
 | Point2dCollection |
 | Point3d |
 | Point3dCollection |
 | PointEntity2d |
 | PointEntity3d |
 | PointOnCurve2d |
 | PointOnCurve3d |
 | PointOnSurface |
 | PolylineCurve2d |
 | PolylineCurve3d |
 | Position2d |
 | Position3d |
 | Ray2d |
 | Ray3d |
 | Scale2d |
 | Scale3d |
 | Sphere |
 | SplineEntity2d |
 | SplineEntity3d |
 | Surface |
 | SurfaceSurfaceIntersector |
 | SurfaceSurfaceIntersectorConfiguration |
 | SurfaceSurfaceIntersectorConfigurations |
 | SurfaceSurfaceIntersectorType |
 | Tolerance |
 | Torus |
 | UInt32Collection |
 | UInt32CollectionEnumerator |
 | Vector2d |
 | Vector2dCollection |
 | Vector2dCollectionEnumerator |
 | Vector3d |
 | Vector3dCollection |
 | Vector3dCollectionEnumerator |


AugmentedPolylineCurve3d Class

AugmentedPolylineCurve3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeAugPolyline3d")]
public sealed class AugmentedPolylineCurve3d : PolylineCurve3d
<WrapperAttribute("ZcGeAugPolyline3d")> _
Public NotInheritable Class AugmentedPolylineCurve3d _
    Inherits PolylineCurve3d
[WrapperAttribute(L"ZcGeAugPolyline3d")]
public ref class AugmentedPolylineCurve3d sealed : public PolylineCurve3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AugmentedPolylineCurve3d(Curve3d, Double, Double, Double) |
 | AugmentedPolylineCurve3d(KnotCollection, Point3dCollection, Vector3dCollection) |
 | AugmentedPolylineCurve3d(Point3dCollection, Vector3dCollection) |
 | AugmentedPolylineCurve3d()()()() |
 | ApproximateTolerance |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ControlPointAt(Int32) | (Inherited from SplineEntity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | D1Vectors |
 | D2Vectors |
 | Degree | (Inherited from SplineEntity3d.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndParameter | (Inherited from SplineEntity3d.)
 | EndPoint | (Inherited from SplineEntity3d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FitPointAt(Int32) | (Inherited from PolylineCurve3d.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetContinuityAtKnot(Int32, Tolerance) | (Inherited from SplineEntity3d.)
 | GetContinuityAtKnot(Int32) | (Inherited from SplineEntity3d.)
 | GetD2VectorAt(Int32) |
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetPointAt(Int32) |
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | GetVectorAt(Int32) |
 | HasEndPoint | (Inherited from Curve3d.)
 | HasFitData | (Inherited from SplineEntity3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | IsRational | (Inherited from SplineEntity3d.)
 | KnotAt(Int32) | (Inherited from SplineEntity3d.)
 | Knots | (Inherited from SplineEntity3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | NumberOfControlPoints | (Inherited from SplineEntity3d.)
 | NumberOfFitPoints | (Inherited from PolylineCurve3d.)
 | NumberOfKnots | (Inherited from SplineEntity3d.)
 | Order | (Inherited from SplineEntity3d.)
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | Points |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | SetControlPointAt(Int32, Point3d) | (Inherited from SplineEntity3d.)
 | SetD2VectorAt(Int32, Vector3d) |
 | SetFitPointAt(Int32, Point3d) | (Inherited from PolylineCurve3d.)
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | SetKnotAt(Int32, Double) | (Inherited from SplineEntity3d.)
 | SetPointAt(Int32, Point3d) |
 | SetVectorAt(Int32, Vector3d) |
 | StartParameter | (Inherited from SplineEntity3d.)
 | StartPoint | (Inherited from SplineEntity3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | SplineEntity3d
 |  |  |  |  |  | PolylineCurve3d
 |  |  |  |  |  |  | AugmentedPolylineCurve3d


AugmentedPolylineCurve3d Constructor

AugmentedPolylineCurve3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »AugmentedPolylineCurve3d()()()()
Members
Icon | Member | Description
 | AugmentedPolylineCurve3d(Curve3d, Double, Double, Double) |
 | AugmentedPolylineCurve3d(KnotCollection, Point3dCollection, Vector3dCollection) |
 | AugmentedPolylineCurve3d(Point3dCollection, Vector3dCollection) |
 | AugmentedPolylineCurve3d()()()() |


AugmentedPolylineCurve3d Constructor

AugmentedPolylineCurve3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »AugmentedPolylineCurve3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AugmentedPolylineCurve3d()
Public Sub New
public:
AugmentedPolylineCurve3d()


AugmentedPolylineCurve3d Constructor (curve, fromParameter, toParameter, eps)

AugmentedPolylineCurve3d Constructor (curve, fromParameter, toParameter, eps)
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »AugmentedPolylineCurve3d(Curve3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public AugmentedPolylineCurve3d(
    Curve3d curve,
    double fromParameter,
    double toParameter,
    double eps
)
Public Sub New ( _
    curve As Curve3d, _
    fromParameter As Double, _
    toParameter As Double, _
    eps As Double _
)
public:
AugmentedPolylineCurve3d(
    Curve3d^ curve,
    double fromParameter,
    double toParameter,
    double eps
)
Parameters
curve(Curve3d)
fromParameter(Double)
toParameter(Double)
eps(Double)


AugmentedPolylineCurve3d Constructor (knots, controlPoints, vectorBundle)

AugmentedPolylineCurve3d Constructor (knots, controlPoints, vectorBundle)
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »AugmentedPolylineCurve3d(KnotCollection, Point3dCollection, Vector3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AugmentedPolylineCurve3d(
    KnotCollection knots,
    Point3dCollection controlPoints,
    Vector3dCollection vectorBundle
)
Public Sub New ( _
    knots As KnotCollection, _
    controlPoints As Point3dCollection, _
    vectorBundle As Vector3dCollection _
)
public:
AugmentedPolylineCurve3d(
    KnotCollection^ knots,
    Point3dCollection^ controlPoints,
    Vector3dCollection^ vectorBundle
)
Parameters
knots(KnotCollection)
controlPoints(Point3dCollection)
vectorBundle(Vector3dCollection)


AugmentedPolylineCurve3d Constructor (controlPoints, vectorBundle)

AugmentedPolylineCurve3d Constructor (controlPoints, vectorBundle)
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »AugmentedPolylineCurve3d(Point3dCollection, Vector3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AugmentedPolylineCurve3d(
    Point3dCollection controlPoints,
    Vector3dCollection vectorBundle
)
Public Sub New ( _
    controlPoints As Point3dCollection, _
    vectorBundle As Vector3dCollection _
)
public:
AugmentedPolylineCurve3d(
    Point3dCollection^ controlPoints,
    Vector3dCollection^ vectorBundle
)
Parameters
controlPoints(Point3dCollection)
vectorBundle(Vector3dCollection)


ApproximateTolerance Property

ApproximateTolerance Property
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »ApproximateTolerance
Declaration Syntax
C# Visual Basic Visual C++
public double ApproximateTolerance { get; set; }
Public Property ApproximateTolerance As Double
    Get
    Set
public:
property double ApproximateTolerance {
    double get ();
    void set (double value);
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static AugmentedPolylineCurve3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As AugmentedPolylineCurve3d
public:
static AugmentedPolylineCurve3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


D1Vectors Property

D1Vectors Property
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »D1Vectors
Declaration Syntax
C# Visual Basic Visual C++
public Vector3dCollection D1Vectors { get; }
Public ReadOnly Property D1Vectors As Vector3dCollection
    Get
public:
property Vector3dCollection^ D1Vectors {
    Vector3dCollection^ get ();
}


D2Vectors Property

D2Vectors Property
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »D2Vectors
Declaration Syntax
C# Visual Basic Visual C++
public Vector3dCollection D2Vectors { get; }
Public ReadOnly Property D2Vectors As Vector3dCollection
    Get
public:
property Vector3dCollection^ D2Vectors {
    Vector3dCollection^ get ();
}


GetD2VectorAt Method (index)

GetD2VectorAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetD2VectorAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetD2VectorAt(
    int index
)
Public Function GetD2VectorAt ( _
    index As Integer _
) As Vector3d
public:
Vector3d GetD2VectorAt(
    int index
)
Parameters
index(Int32)


GetPointAt Method (index)

GetPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetPointAt(
    int index
)
Public Function GetPointAt ( _
    index As Integer _
) As Point3d
public:
Point3d GetPointAt(
    int index
)
Parameters
index(Int32)


GetVectorAt Method (index)

GetVectorAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetVectorAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetVectorAt(
    int index
)
Public Function GetVectorAt ( _
    index As Integer _
) As Vector3d
public:
Vector3d GetVectorAt(
    int index
)
Parameters
index(Int32)


Points Property

Points Property
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »Points
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection Points { get; }
Public ReadOnly Property Points As Point3dCollection
    Get
public:
property Point3dCollection^ Points {
    Point3dCollection^ get ();
}


SetD2VectorAt Method (index, point)

SetD2VectorAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »SetD2VectorAt(Int32, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetD2VectorAt(
    int index,
    Vector3d point
)
Public Sub SetD2VectorAt ( _
    index As Integer, _
    point As Vector3d _
)
public:
void SetD2VectorAt(
    int index,
    Vector3d point
)
Parameters
index(Int32)
point(Vector3d)


SetPointAt Method (index, point)

SetPointAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »SetPointAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetPointAt(
    int index,
    Point3d point
)
Public Sub SetPointAt ( _
    index As Integer, _
    point As Point3d _
)
public:
void SetPointAt(
    int index,
    Point3d point
)
Parameters
index(Int32)
point(Point3d)


SetVectorAt Method (index, point)

SetVectorAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »SetVectorAt(Int32, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetVectorAt(
    int index,
    Vector3d point
)
Public Sub SetVectorAt ( _
    index As Integer, _
    point As Vector3d _
)
public:
void SetVectorAt(
    int index,
    Vector3d point
)
Parameters
index(Int32)
point(Vector3d)


BoundBlock2d Class

BoundBlock2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeBoundBlock2d")]
public sealed class BoundBlock2d : Entity2d
<WrapperAttribute("ZcGeBoundBlock2d")> _
Public NotInheritable Class BoundBlock2d _
    Inherits Entity2d
[WrapperAttribute(L"ZcGeBoundBlock2d")]
public ref class BoundBlock2d sealed : public Entity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BoundBlock2d(Point2d, Vector2d, Vector2d) |
 | BoundBlock2d(Point2d, Point2d) |
 | BoundBlock2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BasePoint |
 | Clone()()()() | (Inherited from Entity2d.)
 | Contains(Point2d) |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Direction1 |
 | Direction2 |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Extend(Point2d) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetMaximumPoint()()()() |
 | GetMinimumPoint()()()() |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsBox |
 | IsDisjoint(BoundBlock2d) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Entity2d.)
 | IsOn(Point2d) | (Inherited from Entity2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | Set(Point2d, Vector2d, Vector2d) |
 | Set(Point2d, Point2d) |
 | Swell(Double) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | BoundBlock2d


BoundBlock2d Constructor

BoundBlock2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »BoundBlock2d()()()()
Members
Icon | Member | Description
 | BoundBlock2d(Point2d, Vector2d, Vector2d) |
 | BoundBlock2d(Point2d, Point2d) |
 | BoundBlock2d()()()() |


BoundBlock2d Constructor

BoundBlock2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »BoundBlock2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock2d()
Public Sub New
public:
BoundBlock2d()


BoundBlock2d Constructor (point1, point2)

BoundBlock2d Constructor (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »BoundBlock2d(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock2d(
    Point2d point1,
    Point2d point2
)
Public Sub New ( _
    point1 As Point2d, _
    point2 As Point2d _
)
public:
BoundBlock2d(
    Point2d point1,
    Point2d point2
)
Parameters
point1(Point2d)
point2(Point2d)


BoundBlock2d Constructor (basePoint, direction1, direction2)

BoundBlock2d Constructor (basePoint, direction1, direction2)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »BoundBlock2d(Point2d, Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock2d(
    Point2d basePoint,
    Vector2d direction1,
    Vector2d direction2
)
Public Sub New ( _
    basePoint As Point2d, _
    direction1 As Vector2d, _
    direction2 As Vector2d _
)
public:
BoundBlock2d(
    Point2d basePoint,
    Vector2d direction1,
    Vector2d direction2
)
Parameters
basePoint(Point2d)
direction1(Vector2d)
direction2(Vector2d)


BasePoint Property

BasePoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »BasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d BasePoint { get; }
Public ReadOnly Property BasePoint As Point2d
    Get
public:
property Point2d BasePoint {
    Point2d get ();
}


Contains Method (point)

Contains Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »Contains(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Point2d point
)
Public Function Contains ( _
    point As Point2d _
) As Boolean
public:
bool Contains(
    Point2d point
)
Parameters
point(Point2d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static BoundBlock2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As BoundBlock2d
public:
static BoundBlock2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Direction1 Property

Direction1 Property
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »Direction1
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Direction1 { get; }
Public ReadOnly Property Direction1 As Vector2d
    Get
public:
property Vector2d Direction1 {
    Vector2d get ();
}


Direction2 Property

Direction2 Property
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »Direction2
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Direction2 { get; }
Public ReadOnly Property Direction2 As Vector2d
    Get
public:
property Vector2d Direction2 {
    Vector2d get ();
}


Extend Method (point)

Extend Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »Extend(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Extend(
    Point2d point
)
Public Sub Extend ( _
    point As Point2d _
)
public:
void Extend(
    Point2d point
)
Parameters
point(Point2d)


GetMaximumPoint Method

GetMaximumPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »GetMaximumPoint()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetMaximumPoint()
Public Function GetMaximumPoint As Point2d
public:
Point2d GetMaximumPoint()


GetMinimumPoint Method

GetMinimumPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »GetMinimumPoint()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetMinimumPoint()
Public Function GetMinimumPoint As Point2d
public:
Point2d GetMinimumPoint()


IsBox Property

IsBox Property
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »IsBox
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBox { get; set; }
Public Property IsBox As Boolean
    Get
    Set
public:
property bool IsBox {
    bool get ();
    void set (bool value);
}


IsDisjoint Method (block)

IsDisjoint Method (block)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »IsDisjoint(BoundBlock2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDisjoint(
    BoundBlock2d block
)
Public Function IsDisjoint ( _
    block As BoundBlock2d _
) As Boolean
public:
bool IsDisjoint(
    BoundBlock2d^ block
)
Parameters
block(BoundBlock2d)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »Set()()()()
Members
Icon | Member | Description
 | Set(Point2d, Vector2d, Vector2d) |
 | Set(Point2d, Point2d) |


Set Method (firstPoint, secondPoint)

Set Method (firstPoint, secondPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »Set(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d firstPoint,
    Point2d secondPoint
)
Public Sub Set ( _
    firstPoint As Point2d, _
    secondPoint As Point2d _
)
public:
void Set(
    Point2d firstPoint,
    Point2d secondPoint
)
Parameters
firstPoint(Point2d)
secondPoint(Point2d)


Set Method (basePoint, direction1, direction2)

Set Method (basePoint, direction1, direction2)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »Set(Point2d, Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d basePoint,
    Vector2d direction1,
    Vector2d direction2
)
Public Sub Set ( _
    basePoint As Point2d, _
    direction1 As Vector2d, _
    direction2 As Vector2d _
)
public:
void Set(
    Point2d basePoint,
    Vector2d direction1,
    Vector2d direction2
)
Parameters
basePoint(Point2d)
direction1(Vector2d)
direction2(Vector2d)


Swell Method (distance)

Swell Method (distance)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »Swell(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Swell(
    double distance
)
Public Sub Swell ( _
    distance As Double _
)
public:
void Swell(
    double distance
)
Parameters
distance(Double)


BoundBlock3d Class

BoundBlock3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeBoundBlock3d")]
public sealed class BoundBlock3d : Entity3d
<WrapperAttribute("ZcGeBoundBlock3d")> _
Public NotInheritable Class BoundBlock3d _
    Inherits Entity3d
[WrapperAttribute(L"ZcGeBoundBlock3d")]
public ref class BoundBlock3d sealed : public Entity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BoundBlock3d(Point3d, Vector3d, Vector3d, Vector3d) |
 | BoundBlock3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BasePoint |
 | Clone()()()() | (Inherited from Entity3d.)
 | Contains(Point3d) |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Direction1 |
 | Direction2 |
 | Direction3 |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Extend(Point3d) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetMaximumPoint()()()() |
 | GetMinimumPoint()()()() |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsBox |
 | IsDisjoint(BoundBlock3d) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Point3d, Vector3d, Vector3d, Vector3d) |
 | Set(Point3d, Point3d) |
 | Swell(Double) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) |
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | BoundBlock3d


BoundBlock3d Constructor

BoundBlock3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »BoundBlock3d()()()()
Members
Icon | Member | Description
 | BoundBlock3d(Point3d, Vector3d, Vector3d, Vector3d) |
 | BoundBlock3d()()()() |


BoundBlock3d Constructor

BoundBlock3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »BoundBlock3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock3d()
Public Sub New
public:
BoundBlock3d()


BoundBlock3d Constructor (point1, dir1, dir2, dir3)

BoundBlock3d Constructor (point1, dir1, dir2, dir3)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »BoundBlock3d(Point3d, Vector3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock3d(
    Point3d point1,
    Vector3d dir1,
    Vector3d dir2,
    Vector3d dir3
)
Public Sub New ( _
    point1 As Point3d, _
    dir1 As Vector3d, _
    dir2 As Vector3d, _
    dir3 As Vector3d _
)
public:
BoundBlock3d(
    Point3d point1,
    Vector3d dir1,
    Vector3d dir2,
    Vector3d dir3
)
Parameters
point1(Point3d)
dir1(Vector3d)
dir2(Vector3d)
dir3(Vector3d)


BasePoint Property

BasePoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »BasePoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BasePoint { get; }
Public ReadOnly Property BasePoint As Point3d
    Get
public:
property Point3d BasePoint {
    Point3d get ();
}


Contains Method (pointToTest)

Contains Method (pointToTest)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Contains(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Point3d pointToTest
)
Public Function Contains ( _
    pointToTest As Point3d _
) As Boolean
public:
bool Contains(
    Point3d pointToTest
)
Parameters
pointToTest(Point3d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static BoundBlock3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As BoundBlock3d
public:
static BoundBlock3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Direction1 Property

Direction1 Property
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Direction1
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Direction1 { get; }
Public ReadOnly Property Direction1 As Vector3d
    Get
public:
property Vector3d Direction1 {
    Vector3d get ();
}


Direction2 Property

Direction2 Property
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Direction2
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Direction2 { get; }
Public ReadOnly Property Direction2 As Vector3d
    Get
public:
property Vector3d Direction2 {
    Vector3d get ();
}


Direction3 Property

Direction3 Property
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Direction3
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Direction3 { get; }
Public ReadOnly Property Direction3 As Vector3d
    Get
public:
property Vector3d Direction3 {
    Vector3d get ();
}


Extend Method (pointToInclude)

Extend Method (pointToInclude)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Extend(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Extend(
    Point3d pointToInclude
)
Public Sub Extend ( _
    pointToInclude As Point3d _
)
public:
void Extend(
    Point3d pointToInclude
)
Parameters
pointToInclude(Point3d)


GetMaximumPoint Method

GetMaximumPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »GetMaximumPoint()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetMaximumPoint()
Public Function GetMaximumPoint As Point3d
public:
Point3d GetMaximumPoint()


GetMinimumPoint Method

GetMinimumPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »GetMinimumPoint()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetMinimumPoint()
Public Function GetMinimumPoint As Point3d
public:
Point3d GetMinimumPoint()


IsBox Property

IsBox Property
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »IsBox
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBox { get; set; }
Public Property IsBox As Boolean
    Get
    Set
public:
property bool IsBox {
    bool get ();
    void set (bool value);
}


IsDisjoint Method (block)

IsDisjoint Method (block)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »IsDisjoint(BoundBlock3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDisjoint(
    BoundBlock3d block
)
Public Function IsDisjoint ( _
    block As BoundBlock3d _
) As Boolean
public:
bool IsDisjoint(
    BoundBlock3d^ block
)
Parameters
block(BoundBlock3d)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Set()()()()
Members
Icon | Member | Description
 | Set(Point3d, Vector3d, Vector3d, Vector3d) |
 | Set(Point3d, Point3d) |


Set Method (basePoint, maximumPoint)

Set Method (basePoint, maximumPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Set(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d basePoint,
    Point3d maximumPoint
)
Public Sub Set ( _
    basePoint As Point3d, _
    maximumPoint As Point3d _
)
public:
void Set(
    Point3d basePoint,
    Point3d maximumPoint
)
Parameters
basePoint(Point3d)
maximumPoint(Point3d)


Set Method (basePoint, dir1, dir2, dir3)

Set Method (basePoint, dir1, dir2, dir3)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Set(Point3d, Vector3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d basePoint,
    Vector3d dir1,
    Vector3d dir2,
    Vector3d dir3
)
Public Sub Set ( _
    basePoint As Point3d, _
    dir1 As Vector3d, _
    dir2 As Vector3d, _
    dir3 As Vector3d _
)
public:
void Set(
    Point3d basePoint,
    Vector3d dir1,
    Vector3d dir2,
    Vector3d dir3
)
Parameters
basePoint(Point3d)
dir1(Vector3d)
dir2(Vector3d)
dir3(Vector3d)


Swell Method (distance)

Swell Method (distance)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Swell(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Swell(
    double distance
)
Public Sub Swell ( _
    distance As Double _
)
public:
void Swell(
    double distance
)
Parameters
distance(Double)


TransformBy Method ()

TransformBy Method ()
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »TransformBy(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public void TransformBy(
    Matrix3d
)
Public Sub TransformBy ( _
     As Matrix3d _
)
public:
void TransformBy(
    Matrix3d
)
Parameters
(Matrix3d)


BoundedPlane Class

BoundedPlane Class
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeBoundedPlane")]
public sealed class BoundedPlane : PlanarEntity
<WrapperAttribute("ZcGeBoundedPlane")> _
Public NotInheritable Class BoundedPlane _
    Inherits PlanarEntity
[WrapperAttribute(L"ZcGeBoundedPlane")]
public ref class BoundedPlane sealed : public PlanarEntity
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BoundedPlane(Point3d, Vector3d, Vector3d) |
 | BoundedPlane(Point3d, Point3d, Point3d) |
 | BoundedPlane()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | ClosestPointToLinearEntity(LinearEntity3d, Tolerance) | (Inherited from PlanarEntity.)
 | ClosestPointToLinearEntity(LinearEntity3d) | (Inherited from PlanarEntity.)
 | ClosestPointToPlanarEntity(PlanarEntity, Tolerance) | (Inherited from PlanarEntity.)
 | ClosestPointToPlanarEntity(PlanarEntity) | (Inherited from PlanarEntity.)
 | Coefficients | (Inherited from PlanarEntity.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetCoordinateSystem()()()() | (Inherited from PlanarEntity.)
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Plane, Tolerance) |
 | IntersectWith(BoundedPlane, Tolerance) |
 | IntersectWith(Plane) |
 | IntersectWith(BoundedPlane) |
 | IntersectWith(LinearEntity3d, Tolerance) | (Inherited from PlanarEntity.)
 | IntersectWith(LinearEntity3d) | (Inherited from PlanarEntity.)
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsCoplanarTo(PlanarEntity, Tolerance) | (Inherited from PlanarEntity.)
 | IsCoplanarTo(PlanarEntity) | (Inherited from PlanarEntity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsNormalReversed | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsParallelTo(PlanarEntity, Tolerance) | (Inherited from PlanarEntity.)
 | IsParallelTo(LinearEntity3d, Tolerance) | (Inherited from PlanarEntity.)
 | IsParallelTo(PlanarEntity) | (Inherited from PlanarEntity.)
 | IsParallelTo(LinearEntity3d) | (Inherited from PlanarEntity.)
 | IsPerpendicularTo(PlanarEntity, Tolerance) | (Inherited from PlanarEntity.)
 | IsPerpendicularTo(LinearEntity3d, Tolerance) | (Inherited from PlanarEntity.)
 | IsPerpendicularTo(PlanarEntity) | (Inherited from PlanarEntity.)
 | IsPerpendicularTo(LinearEntity3d) | (Inherited from PlanarEntity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | Normal | (Inherited from PlanarEntity.)
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | PointOnPlane | (Inherited from PlanarEntity.)
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Point3d, Vector3d, Vector3d) |
 | Set(Point3d, Point3d, Point3d) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | PlanarEntity
 |  |  |  |  |  | BoundedPlane


BoundedPlane Constructor

BoundedPlane Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »BoundedPlane()()()()
Members
Icon | Member | Description
 | BoundedPlane(Point3d, Vector3d, Vector3d) |
 | BoundedPlane(Point3d, Point3d, Point3d) |
 | BoundedPlane()()()() |


BoundedPlane Constructor

BoundedPlane Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »BoundedPlane()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BoundedPlane()
Public Sub New
public:
BoundedPlane()


BoundedPlane Constructor (p1, origin, p2)

BoundedPlane Constructor (p1, origin, p2)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »BoundedPlane(Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public BoundedPlane(
    Point3d p1,
    Point3d origin,
    Point3d p2
)
Public Sub New ( _
    p1 As Point3d, _
    origin As Point3d, _
    p2 As Point3d _
)
public:
BoundedPlane(
    Point3d p1,
    Point3d origin,
    Point3d p2
)
Parameters
p1(Point3d)
origin(Point3d)
p2(Point3d)


BoundedPlane Constructor (origin, u, v)

BoundedPlane Constructor (origin, u, v)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »BoundedPlane(Point3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public BoundedPlane(
    Point3d origin,
    Vector3d u,
    Vector3d v
)
Public Sub New ( _
    origin As Point3d, _
    u As Vector3d, _
    v As Vector3d _
)
public:
BoundedPlane(
    Point3d origin,
    Vector3d u,
    Vector3d v
)
Parameters
origin(Point3d)
u(Vector3d)
v(Vector3d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static BoundedPlane Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As BoundedPlane
public:
static BoundedPlane^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Plane, Tolerance) |
 | IntersectWith(BoundedPlane, Tolerance) |
 | IntersectWith(Plane) |
 | IntersectWith(BoundedPlane) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |


IntersectWith Method (plane)

IntersectWith Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IntersectWith(BoundedPlane)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment3d IntersectWith(
    BoundedPlane plane
)
Public Function IntersectWith ( _
    plane As BoundedPlane _
) As LineSegment3d
public:
LineSegment3d^ IntersectWith(
    BoundedPlane^ plane
)
Parameters
plane(BoundedPlane)


IntersectWith Method (plane, tolerance)

IntersectWith Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IntersectWith(BoundedPlane, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment3d IntersectWith(
    BoundedPlane plane,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    plane As BoundedPlane, _
    tolerance As Tolerance _
) As LineSegment3d
public:
LineSegment3d^ IntersectWith(
    BoundedPlane^ plane,
    Tolerance tolerance
)
Parameters
plane(BoundedPlane)
tolerance(Tolerance)


IntersectWith Method (plane)

IntersectWith Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IntersectWith(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment3d IntersectWith(
    Plane plane
)
Public Function IntersectWith ( _
    plane As Plane _
) As LineSegment3d
public:
LineSegment3d^ IntersectWith(
    Plane^ plane
)
Parameters
plane(Plane)


IntersectWith Method (plane, tolerance)

IntersectWith Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IntersectWith(Plane, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment3d IntersectWith(
    Plane plane,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    plane As Plane, _
    tolerance As Tolerance _
) As LineSegment3d
public:
LineSegment3d^ IntersectWith(
    Plane^ plane,
    Tolerance tolerance
)
Parameters
plane(Plane)
tolerance(Tolerance)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »Set()()()()
Members
Icon | Member | Description
 | Set(Point3d, Vector3d, Vector3d) |
 | Set(Point3d, Point3d, Point3d) |


Set Method (p1, origin, p2)

Set Method (p1, origin, p2)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »Set(Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d p1,
    Point3d origin,
    Point3d p2
)
Public Sub Set ( _
    p1 As Point3d, _
    origin As Point3d, _
    p2 As Point3d _
)
public:
void Set(
    Point3d p1,
    Point3d origin,
    Point3d p2
)
Parameters
p1(Point3d)
origin(Point3d)
p2(Point3d)


Set Method (origin, u, v)

Set Method (origin, u, v)
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »Set(Point3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d origin,
    Vector3d u,
    Vector3d v
)
Public Sub Set ( _
    origin As Point3d, _
    u As Vector3d, _
    v As Vector3d _
)
public:
void Set(
    Point3d origin,
    Vector3d u,
    Vector3d v
)
Parameters
origin(Point3d)
u(Vector3d)
v(Vector3d)


CircularArc2d Class

CircularArc2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCircArc2d")]
public sealed class CircularArc2d : Curve2d
<WrapperAttribute("ZcGeCircArc2d")> _
Public NotInheritable Class CircularArc2d _
    Inherits Curve2d
[WrapperAttribute(L"ZcGeCircArc2d")]
public ref class CircularArc2d sealed : public Curve2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CircularArc2d(Point2d, Double, Double, Double, Vector2d, Boolean) |
 | CircularArc2d(Point2d, Point2d, Double, Boolean) |
 | CircularArc2d(Point2d, Point2d, Point2d) |
 | CircularArc2d(Point2d, Double) |
 | CircularArc2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Center |
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndAngle |
 | EndPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTangent(Point2d, Tolerance) |
 | GetTangent(Point2d) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity2d, Tolerance) |
 | IntersectWith(CircularArc2d, Tolerance) |
 | IntersectWith(LinearEntity2d) |
 | IntersectWith(CircularArc2d) |
 | IsClockWise |
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsInside(Point2d, Tolerance) |
 | IsInside(Point2d) |
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | Radius |
 | ReferenceVector |
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | Set(Point2d, Double, Double, Double, Vector2d, Boolean) |
 | Set(Curve2d, Curve2d, Curve2d, Double, Double, Double) |
 | Set(Curve2d, Curve2d, Double, Double, Double) |
 | Set(Point2d, Point2d, Double, Boolean) |
 | Set(Point2d, Point2d, Point2d) |
 | Set(Point2d, Double) |
 | SetAngles(Double, Double) |
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | SetToComplement()()()() |
 | StartAngle |
 | StartPoint |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | CircularArc2d


CircularArc2d Constructor

CircularArc2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »CircularArc2d()()()()
Members
Icon | Member | Description
 | CircularArc2d(Point2d, Double, Double, Double, Vector2d, Boolean) |
 | CircularArc2d(Point2d, Point2d, Double, Boolean) |
 | CircularArc2d(Point2d, Point2d, Point2d) |
 | CircularArc2d(Point2d, Double) |
 | CircularArc2d()()()() |


CircularArc2d Constructor

CircularArc2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »CircularArc2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc2d()
Public Sub New
public:
CircularArc2d()


CircularArc2d Constructor (center, radius)

CircularArc2d Constructor (center, radius)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »CircularArc2d(Point2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc2d(
    Point2d center,
    double radius
)
Public Sub New ( _
    center As Point2d, _
    radius As Double _
)
public:
CircularArc2d(
    Point2d center,
    double radius
)
Parameters
center(Point2d)
radius(Double)


CircularArc2d Constructor (center, radius, startAngle, endAngle, referenceVector, isClockWise)

CircularArc2d Constructor (center, radius, startAngle, endAngle, referenceVector, isClockWise)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »CircularArc2d(Point2d, Double, Double, Double, Vector2d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc2d(
    Point2d center,
    double radius,
    double startAngle,
    double endAngle,
    Vector2d referenceVector,
    bool isClockWise
)
Public Sub New ( _
    center As Point2d, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double, _
    referenceVector As Vector2d, _
    isClockWise As Boolean _
)
public:
CircularArc2d(
    Point2d center,
    double radius,
    double startAngle,
    double endAngle,
    Vector2d referenceVector,
    bool isClockWise
)
Parameters
center(Point2d)
radius(Double)
startAngle(Double)
endAngle(Double)
referenceVector(Vector2d)
isClockWise(Boolean)


CircularArc2d Constructor (startPoint, endPoint, bulge, bulgeFlag)

CircularArc2d Constructor (startPoint, endPoint, bulge, bulgeFlag)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »CircularArc2d(Point2d, Point2d, Double, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc2d(
    Point2d startPoint,
    Point2d endPoint,
    double bulge,
    bool bulgeFlag
)
Public Sub New ( _
    startPoint As Point2d, _
    endPoint As Point2d, _
    bulge As Double, _
    bulgeFlag As Boolean _
)
public:
CircularArc2d(
    Point2d startPoint,
    Point2d endPoint,
    double bulge,
    bool bulgeFlag
)
Parameters
startPoint(Point2d)
endPoint(Point2d)
bulge(Double)
bulgeFlag(Boolean)


CircularArc2d Constructor (startPoint, point, endPoint)

CircularArc2d Constructor (startPoint, point, endPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »CircularArc2d(Point2d, Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc2d(
    Point2d startPoint,
    Point2d point,
    Point2d endPoint
)
Public Sub New ( _
    startPoint As Point2d, _
    point As Point2d, _
    endPoint As Point2d _
)
public:
CircularArc2d(
    Point2d startPoint,
    Point2d point,
    Point2d endPoint
)
Parameters
startPoint(Point2d)
point(Point2d)
endPoint(Point2d)


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Center { get; set; }
Public Property Center As Point2d
    Get
    Set
public:
property Point2d Center {
    Point2d get ();
    void set (Point2d value);
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static CircularArc2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As CircularArc2d
public:
static CircularArc2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


EndAngle Property

EndAngle Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »EndAngle
Declaration Syntax
C# Visual Basic Visual C++
public double EndAngle { get; }
Public ReadOnly Property EndAngle As Double
    Get
public:
property double EndAngle {
    double get ();
}


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d EndPoint { get; }
Public ReadOnly Property EndPoint As Point2d
    Get
public:
property Point2d EndPoint {
    Point2d get ();
}


GetTangent Method

GetTangent Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetTangent()()()()
Members
Icon | Member | Description
 | GetTangent(Point2d, Tolerance) |
 | GetTangent(Point2d) |


GetTangent Method (point)

GetTangent Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetTangent(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Line2d GetTangent(
    Point2d point
)
Public Function GetTangent ( _
    point As Point2d _
) As Line2d
public:
Line2d^ GetTangent(
    Point2d point
)
Parameters
point(Point2d)


GetTangent Method (point, tolerance)

GetTangent Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetTangent(Point2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Line2d GetTangent(
    Point2d point,
    Tolerance tolerance
)
Public Function GetTangent ( _
    point As Point2d, _
    tolerance As Tolerance _
) As Line2d
public:
Line2d^ GetTangent(
    Point2d point,
    Tolerance tolerance
)
Parameters
point(Point2d)
tolerance(Tolerance)


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity2d, Tolerance) |
 | IntersectWith(CircularArc2d, Tolerance) |
 | IntersectWith(LinearEntity2d) |
 | IntersectWith(CircularArc2d) |


IntersectWith Method (arc)

IntersectWith Method (arc)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IntersectWith(CircularArc2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] IntersectWith(
    CircularArc2d arc
)
Public Function IntersectWith ( _
    arc As CircularArc2d _
) As Point2d()
public:
array<Point2d>^ IntersectWith(
    CircularArc2d^ arc
)
Parameters
arc(CircularArc2d)


IntersectWith Method (arc, tolerance)

IntersectWith Method (arc, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IntersectWith(CircularArc2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] IntersectWith(
    CircularArc2d arc,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    arc As CircularArc2d, _
    tolerance As Tolerance _
) As Point2d()
public:
array<Point2d>^ IntersectWith(
    CircularArc2d^ arc,
    Tolerance tolerance
)
Parameters
arc(CircularArc2d)
tolerance(Tolerance)


IntersectWith Method (line)

IntersectWith Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IntersectWith(LinearEntity2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] IntersectWith(
    LinearEntity2d line
)
Public Function IntersectWith ( _
    line As LinearEntity2d _
) As Point2d()
public:
array<Point2d>^ IntersectWith(
    LinearEntity2d^ line
)
Parameters
line(LinearEntity2d)


IntersectWith Method (line, tolerance)

IntersectWith Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IntersectWith(LinearEntity2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] IntersectWith(
    LinearEntity2d line,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    line As LinearEntity2d, _
    tolerance As Tolerance _
) As Point2d()
public:
array<Point2d>^ IntersectWith(
    LinearEntity2d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity2d)
tolerance(Tolerance)


IsClockWise Property

IsClockWise Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IsClockWise
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClockWise { get; }
Public ReadOnly Property IsClockWise As Boolean
    Get
public:
property bool IsClockWise {
    bool get ();
}


IsInside Method

IsInside Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IsInside()()()()
Members
Icon | Member | Description
 | IsInside(Point2d, Tolerance) |
 | IsInside(Point2d) |


IsInside Method (point)

IsInside Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IsInside(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInside(
    Point2d point
)
Public Function IsInside ( _
    point As Point2d _
) As Boolean
public:
bool IsInside(
    Point2d point
)
Parameters
point(Point2d)


IsInside Method (point, tolerance)

IsInside Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IsInside(Point2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInside(
    Point2d point,
    Tolerance tolerance
)
Public Function IsInside ( _
    point As Point2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsInside(
    Point2d point,
    Tolerance tolerance
)
Parameters
point(Point2d)
tolerance(Tolerance)


Radius Property

Radius Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Radius
Declaration Syntax
C# Visual Basic Visual C++
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set
public:
property double Radius {
    double get ();
    void set (double value);
}


ReferenceVector Property

ReferenceVector Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »ReferenceVector
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d ReferenceVector { get; set; }
Public Property ReferenceVector As Vector2d
    Get
    Set
public:
property Vector2d ReferenceVector {
    Vector2d get ();
    void set (Vector2d value);
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Set()()()()
Members
Icon | Member | Description
 | Set(Point2d, Double, Double, Double, Vector2d, Boolean) |
 | Set(Curve2d, Curve2d, Curve2d, Double, Double, Double) |
 | Set(Curve2d, Curve2d, Double, Double, Double) |
 | Set(Point2d, Point2d, Double, Boolean) |
 | Set(Point2d, Point2d, Point2d) |
 | Set(Point2d, Double) |


Set Method (curve1, curve2, radius, parameter1, parameter2)

Set Method (curve1, curve2, radius, parameter1, parameter2)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Set(Curve2d, Curve2d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve2d curve1,
    Curve2d curve2,
    double radius,
    double parameter1,
    double parameter2
)
Public Sub Set ( _
    curve1 As Curve2d, _
    curve2 As Curve2d, _
    radius As Double, _
    parameter1 As Double, _
    parameter2 As Double _
)
public:
void Set(
    Curve2d^ curve1,
    Curve2d^ curve2,
    double radius,
    double parameter1,
    double parameter2
)
Parameters
curve1(Curve2d)
curve2(Curve2d)
radius(Double)
parameter1(Double)
parameter2(Double)


Set Method (curve1, curve2, curve3, parameter1, parameter2, parameter3)

Set Method (curve1, curve2, curve3, parameter1, parameter2, parameter3)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Set(Curve2d, Curve2d, Curve2d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve2d curve1,
    Curve2d curve2,
    Curve2d curve3,
    double parameter1,
    double parameter2,
    double parameter3
)
Public Sub Set ( _
    curve1 As Curve2d, _
    curve2 As Curve2d, _
    curve3 As Curve2d, _
    parameter1 As Double, _
    parameter2 As Double, _
    parameter3 As Double _
)
public:
void Set(
    Curve2d^ curve1,
    Curve2d^ curve2,
    Curve2d^ curve3,
    double parameter1,
    double parameter2,
    double parameter3
)
Parameters
curve1(Curve2d)
curve2(Curve2d)
curve3(Curve2d)
parameter1(Double)
parameter2(Double)
parameter3(Double)


Set Method (center, radius)

Set Method (center, radius)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Set(Point2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d center,
    double radius
)
Public Sub Set ( _
    center As Point2d, _
    radius As Double _
)
public:
void Set(
    Point2d center,
    double radius
)
Parameters
center(Point2d)
radius(Double)


Set Method (center, radius, angle1, angle2, referenceVector, isClockWise)

Set Method (center, radius, angle1, angle2, referenceVector, isClockWise)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Set(Point2d, Double, Double, Double, Vector2d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d center,
    double radius,
    double angle1,
    double angle2,
    Vector2d referenceVector,
    bool isClockWise
)
Public Sub Set ( _
    center As Point2d, _
    radius As Double, _
    angle1 As Double, _
    angle2 As Double, _
    referenceVector As Vector2d, _
    isClockWise As Boolean _
)
public:
void Set(
    Point2d center,
    double radius,
    double angle1,
    double angle2,
    Vector2d referenceVector,
    bool isClockWise
)
Parameters
center(Point2d)
radius(Double)
angle1(Double)
angle2(Double)
referenceVector(Vector2d)
isClockWise(Boolean)


Set Method (startPoint, endPoint, bulge, bulgeFlag)

Set Method (startPoint, endPoint, bulge, bulgeFlag)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Set(Point2d, Point2d, Double, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d startPoint,
    Point2d endPoint,
    double bulge,
    bool bulgeFlag
)
Public Sub Set ( _
    startPoint As Point2d, _
    endPoint As Point2d, _
    bulge As Double, _
    bulgeFlag As Boolean _
)
public:
void Set(
    Point2d startPoint,
    Point2d endPoint,
    double bulge,
    bool bulgeFlag
)
Parameters
startPoint(Point2d)
endPoint(Point2d)
bulge(Double)
bulgeFlag(Boolean)


Set Method (startPoint, point, endPoint)

Set Method (startPoint, point, endPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Set(Point2d, Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d startPoint,
    Point2d point,
    Point2d endPoint
)
Public Sub Set ( _
    startPoint As Point2d, _
    point As Point2d, _
    endPoint As Point2d _
)
public:
void Set(
    Point2d startPoint,
    Point2d point,
    Point2d endPoint
)
Parameters
startPoint(Point2d)
point(Point2d)
endPoint(Point2d)


SetAngles Method (startAngle, endAngle)

SetAngles Method (startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »SetAngles(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAngles(
    double startAngle,
    double endAngle
)
Public Sub SetAngles ( _
    startAngle As Double, _
    endAngle As Double _
)
public:
void SetAngles(
    double startAngle,
    double endAngle
)
Parameters
startAngle(Double)
endAngle(Double)


SetToComplement Method

SetToComplement Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »SetToComplement()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetToComplement()
Public Sub SetToComplement
public:
void SetToComplement()


StartAngle Property

StartAngle Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »StartAngle
Declaration Syntax
C# Visual Basic Visual C++
public double StartAngle { get; }
Public ReadOnly Property StartAngle As Double
    Get
public:
property double StartAngle {
    double get ();
}


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d StartPoint { get; }
Public ReadOnly Property StartPoint As Point2d
    Get
public:
property Point2d StartPoint {
    Point2d get ();
}


CircularArc3d Class

CircularArc3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCircArc3d")]
public sealed class CircularArc3d : Curve3d
<WrapperAttribute("ZcGeCircArc3d")> _
Public NotInheritable Class CircularArc3d _
    Inherits Curve3d
[WrapperAttribute(L"ZcGeCircArc3d")]
public ref class CircularArc3d sealed : public Curve3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CircularArc3d(Point3d, Vector3d, Vector3d, Double, Double, Double) |
 | CircularArc3d(Point3d, Vector3d, Double) |
 | CircularArc3d(Point3d, Point3d, Point3d) |
 | CircularArc3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Center |
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointToPlane(PlanarEntity, Tolerance) |
 | ClosestPointToPlane(PlanarEntity) |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndAngle |
 | EndPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetPlane()()()() |
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTangent(Point3d, Tolerance) |
 | GetTangent(Point3d) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(PlanarEntity, Tolerance) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(CircularArc3d, Tolerance) |
 | IntersectWith(PlanarEntity) |
 | IntersectWith(LinearEntity3d) |
 | IntersectWith(CircularArc3d) |
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsInside(Point3d, Tolerance) |
 | IsInside(Point3d) |
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | Normal |
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) |
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) |
 | Radius |
 | ReferenceVector |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Point3d, Vector3d, Vector3d, Double, Double, Double) |
 | Set(Curve3d, Curve3d, Curve3d, Double, Double, Double) |
 | Set(Curve3d, Curve3d, Double, Double, Double) |
 | Set(Point3d, Vector3d, Double) |
 | Set(Point3d, Point3d, Point3d) |
 | SetAngles(Double, Double) |
 | SetAxes(Vector3d, Vector3d) |
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | StartAngle |
 | StartPoint |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | CircularArc3d


CircularArc3d Constructor

CircularArc3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »CircularArc3d()()()()
Members
Icon | Member | Description
 | CircularArc3d(Point3d, Vector3d, Vector3d, Double, Double, Double) |
 | CircularArc3d(Point3d, Vector3d, Double) |
 | CircularArc3d(Point3d, Point3d, Point3d) |
 | CircularArc3d()()()() |


CircularArc3d Constructor

CircularArc3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »CircularArc3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc3d()
Public Sub New
public:
CircularArc3d()


CircularArc3d Constructor (startPoint, point, endPoint)

CircularArc3d Constructor (startPoint, point, endPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »CircularArc3d(Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc3d(
    Point3d startPoint,
    Point3d point,
    Point3d endPoint
)
Public Sub New ( _
    startPoint As Point3d, _
    point As Point3d, _
    endPoint As Point3d _
)
public:
CircularArc3d(
    Point3d startPoint,
    Point3d point,
    Point3d endPoint
)
Parameters
startPoint(Point3d)
point(Point3d)
endPoint(Point3d)


CircularArc3d Constructor (center, normal, radius)

CircularArc3d Constructor (center, normal, radius)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »CircularArc3d(Point3d, Vector3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc3d(
    Point3d center,
    Vector3d normal,
    double radius
)
Public Sub New ( _
    center As Point3d, _
    normal As Vector3d, _
    radius As Double _
)
public:
CircularArc3d(
    Point3d center,
    Vector3d normal,
    double radius
)
Parameters
center(Point3d)
normal(Vector3d)
radius(Double)


CircularArc3d Constructor (center, normal, referenceVector, radius, startAngle, endAngle)

CircularArc3d Constructor (center, normal, referenceVector, radius, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »CircularArc3d(Point3d, Vector3d, Vector3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public CircularArc3d(
    Point3d center,
    Vector3d normal,
    Vector3d referenceVector,
    double radius,
    double startAngle,
    double endAngle
)
Public Sub New ( _
    center As Point3d, _
    normal As Vector3d, _
    referenceVector As Vector3d, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
CircularArc3d(
    Point3d center,
    Vector3d normal,
    Vector3d referenceVector,
    double radius,
    double startAngle,
    double endAngle
)
Parameters
center(Point3d)
normal(Vector3d)
referenceVector(Vector3d)
radius(Double)
startAngle(Double)
endAngle(Double)


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Center { get; set; }
Public Property Center As Point3d
    Get
    Set
public:
property Point3d Center {
    Point3d get ();
    void set (Point3d value);
}


ClosestPointToPlane Method

ClosestPointToPlane Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »ClosestPointToPlane()()()()
Members
Icon | Member | Description
 | ClosestPointToPlane(PlanarEntity, Tolerance) |
 | ClosestPointToPlane(PlanarEntity) |


ClosestPointToPlane Method (plane)

ClosestPointToPlane Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »ClosestPointToPlane(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ClosestPointToPlane(
    PlanarEntity plane
)
Public Function ClosestPointToPlane ( _
    plane As PlanarEntity _
) As Point3d()
public:
array<Point3d>^ ClosestPointToPlane(
    PlanarEntity^ plane
)
Parameters
plane(PlanarEntity)


ClosestPointToPlane Method (plane, tolerance)

ClosestPointToPlane Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »ClosestPointToPlane(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ClosestPointToPlane(
    PlanarEntity plane,
    Tolerance tolerance
)
Public Function ClosestPointToPlane ( _
    plane As PlanarEntity, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ ClosestPointToPlane(
    PlanarEntity^ plane,
    Tolerance tolerance
)
Parameters
plane(PlanarEntity)
tolerance(Tolerance)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static CircularArc3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As CircularArc3d
public:
static CircularArc3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


EndAngle Property

EndAngle Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »EndAngle
Declaration Syntax
C# Visual Basic Visual C++
public double EndAngle { get; }
Public ReadOnly Property EndAngle As Double
    Get
public:
property double EndAngle {
    double get ();
}


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d EndPoint { get; }
Public ReadOnly Property EndPoint As Point3d
    Get
public:
property Point3d EndPoint {
    Point3d get ();
}


GetPlane Method

GetPlane Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetPlane()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Plane GetPlane()
Public Function GetPlane As Plane
public:
Plane^ GetPlane()


GetTangent Method

GetTangent Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetTangent()()()()
Members
Icon | Member | Description
 | GetTangent(Point3d, Tolerance) |
 | GetTangent(Point3d) |


GetTangent Method (pointValue)

GetTangent Method (pointValue)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetTangent(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Line3d GetTangent(
    Point3d pointValue
)
Public Function GetTangent ( _
    pointValue As Point3d _
) As Line3d
public:
Line3d^ GetTangent(
    Point3d pointValue
)
Parameters
pointValue(Point3d)


GetTangent Method (pointValue, tolerance)

GetTangent Method (pointValue, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetTangent(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Line3d GetTangent(
    Point3d pointValue,
    Tolerance tolerance
)
Public Function GetTangent ( _
    pointValue As Point3d, _
    tolerance As Tolerance _
) As Line3d
public:
Line3d^ GetTangent(
    Point3d pointValue,
    Tolerance tolerance
)
Parameters
pointValue(Point3d)
tolerance(Tolerance)


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(PlanarEntity, Tolerance) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(CircularArc3d, Tolerance) |
 | IntersectWith(PlanarEntity) |
 | IntersectWith(LinearEntity3d) |
 | IntersectWith(CircularArc3d) |


IntersectWith Method (arc)

IntersectWith Method (arc)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IntersectWith(CircularArc3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    CircularArc3d arc
)
Public Function IntersectWith ( _
    arc As CircularArc3d _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    CircularArc3d^ arc
)
Parameters
arc(CircularArc3d)


IntersectWith Method (arc, tolerance)

IntersectWith Method (arc, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IntersectWith(CircularArc3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    CircularArc3d arc,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    arc As CircularArc3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    CircularArc3d^ arc,
    Tolerance tolerance
)
Parameters
arc(CircularArc3d)
tolerance(Tolerance)


IntersectWith Method (line)

IntersectWith Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IntersectWith(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d line
)
Public Function IntersectWith ( _
    line As LinearEntity3d _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ line
)
Parameters
line(LinearEntity3d)


IntersectWith Method (line, tolerance)

IntersectWith Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IntersectWith(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d line,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    line As LinearEntity3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
tolerance(Tolerance)


IntersectWith Method (plane)

IntersectWith Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IntersectWith(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    PlanarEntity plane
)
Public Function IntersectWith ( _
    plane As PlanarEntity _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    PlanarEntity^ plane
)
Parameters
plane(PlanarEntity)


IntersectWith Method (plane, tolerance)

IntersectWith Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IntersectWith(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    PlanarEntity plane,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    plane As PlanarEntity, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    PlanarEntity^ plane,
    Tolerance tolerance
)
Parameters
plane(PlanarEntity)
tolerance(Tolerance)


IsInside Method

IsInside Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IsInside()()()()
Members
Icon | Member | Description
 | IsInside(Point3d, Tolerance) |
 | IsInside(Point3d) |


IsInside Method (pointValue)

IsInside Method (pointValue)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IsInside(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInside(
    Point3d pointValue
)
Public Function IsInside ( _
    pointValue As Point3d _
) As Boolean
public:
bool IsInside(
    Point3d pointValue
)
Parameters
pointValue(Point3d)


IsInside Method (pointValue, tolerance)

IsInside Method (pointValue, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IsInside(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInside(
    Point3d pointValue,
    Tolerance tolerance
)
Public Function IsInside ( _
    pointValue As Point3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsInside(
    Point3d pointValue,
    Tolerance tolerance
)
Parameters
pointValue(Point3d)
tolerance(Tolerance)


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; }
Public ReadOnly Property Normal As Vector3d
    Get
public:
property Vector3d Normal {
    Vector3d get ();
}


ProjectedIntersectWith Method

ProjectedIntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »ProjectedIntersectWith()()()()
Members
Icon | Member | Description
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) |
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) |


ProjectedIntersectWith Method (line, projectionDirection)

ProjectedIntersectWith Method (line, projectionDirection)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »ProjectedIntersectWith(LinearEntity3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ProjectedIntersectWith(
    LinearEntity3d line,
    Vector3d projectionDirection
)
Public Function ProjectedIntersectWith ( _
    line As LinearEntity3d, _
    projectionDirection As Vector3d _
) As Point3d()
public:
array<Point3d>^ ProjectedIntersectWith(
    LinearEntity3d^ line,
    Vector3d projectionDirection
)
Parameters
line(LinearEntity3d)
projectionDirection(Vector3d)


ProjectedIntersectWith Method (line, projectionDirection, tolerance)

ProjectedIntersectWith Method (line, projectionDirection, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ProjectedIntersectWith(
    LinearEntity3d line,
    Vector3d projectionDirection,
    Tolerance tolerance
)
Public Function ProjectedIntersectWith ( _
    line As LinearEntity3d, _
    projectionDirection As Vector3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ ProjectedIntersectWith(
    LinearEntity3d^ line,
    Vector3d projectionDirection,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
projectionDirection(Vector3d)
tolerance(Tolerance)


Radius Property

Radius Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Radius
Declaration Syntax
C# Visual Basic Visual C++
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set
public:
property double Radius {
    double get ();
    void set (double value);
}


ReferenceVector Property

ReferenceVector Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »ReferenceVector
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d ReferenceVector { get; }
Public ReadOnly Property ReferenceVector As Vector3d
    Get
public:
property Vector3d ReferenceVector {
    Vector3d get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Set()()()()
Members
Icon | Member | Description
 | Set(Point3d, Vector3d, Vector3d, Double, Double, Double) |
 | Set(Curve3d, Curve3d, Curve3d, Double, Double, Double) |
 | Set(Curve3d, Curve3d, Double, Double, Double) |
 | Set(Point3d, Vector3d, Double) |
 | Set(Point3d, Point3d, Point3d) |


Set Method (curve1, curve2, radius, param1, param2)

Set Method (curve1, curve2, radius, param1, param2)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Set(Curve3d, Curve3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve3d curve1,
    Curve3d curve2,
    double radius,
    double param1,
    double param2
)
Public Sub Set ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    radius As Double, _
    param1 As Double, _
    param2 As Double _
)
public:
void Set(
    Curve3d^ curve1,
    Curve3d^ curve2,
    double radius,
    double param1,
    double param2
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
radius(Double)
param1(Double)
param2(Double)


Set Method (curve1, curve2, curve3, param1, param2, param3)

Set Method (curve1, curve2, curve3, param1, param2, param3)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Set(Curve3d, Curve3d, Curve3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve3d curve1,
    Curve3d curve2,
    Curve3d curve3,
    double param1,
    double param2,
    double param3
)
Public Sub Set ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    curve3 As Curve3d, _
    param1 As Double, _
    param2 As Double, _
    param3 As Double _
)
public:
void Set(
    Curve3d^ curve1,
    Curve3d^ curve2,
    Curve3d^ curve3,
    double param1,
    double param2,
    double param3
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
curve3(Curve3d)
param1(Double)
param2(Double)
param3(Double)


Set Method (startPoint, pointOnArc, endPoint)

Set Method (startPoint, pointOnArc, endPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Set(Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d startPoint,
    Point3d pointOnArc,
    Point3d endPoint
)
Public Sub Set ( _
    startPoint As Point3d, _
    pointOnArc As Point3d, _
    endPoint As Point3d _
)
public:
void Set(
    Point3d startPoint,
    Point3d pointOnArc,
    Point3d endPoint
)
Parameters
startPoint(Point3d)
pointOnArc(Point3d)
endPoint(Point3d)


Set Method (center, normal, radius)

Set Method (center, normal, radius)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Set(Point3d, Vector3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d center,
    Vector3d normal,
    double radius
)
Public Sub Set ( _
    center As Point3d, _
    normal As Vector3d, _
    radius As Double _
)
public:
void Set(
    Point3d center,
    Vector3d normal,
    double radius
)
Parameters
center(Point3d)
normal(Vector3d)
radius(Double)


Set Method (center, normal, referenceVector, radius, startAngle, endAngle)

Set Method (center, normal, referenceVector, radius, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Set(Point3d, Vector3d, Vector3d, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d center,
    Vector3d normal,
    Vector3d referenceVector,
    double radius,
    double startAngle,
    double endAngle
)
Public Sub Set ( _
    center As Point3d, _
    normal As Vector3d, _
    referenceVector As Vector3d, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
void Set(
    Point3d center,
    Vector3d normal,
    Vector3d referenceVector,
    double radius,
    double startAngle,
    double endAngle
)
Parameters
center(Point3d)
normal(Vector3d)
referenceVector(Vector3d)
radius(Double)
startAngle(Double)
endAngle(Double)


SetAngles Method (startAngle, endAngle)

SetAngles Method (startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »SetAngles(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAngles(
    double startAngle,
    double endAngle
)
Public Sub SetAngles ( _
    startAngle As Double, _
    endAngle As Double _
)
public:
void SetAngles(
    double startAngle,
    double endAngle
)
Parameters
startAngle(Double)
endAngle(Double)


SetAxes Method (normal, referenceVector)

SetAxes Method (normal, referenceVector)
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »SetAxes(Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAxes(
    Vector3d normal,
    Vector3d referenceVector
)
Public Sub SetAxes ( _
    normal As Vector3d, _
    referenceVector As Vector3d _
)
public:
void SetAxes(
    Vector3d normal,
    Vector3d referenceVector
)
Parameters
normal(Vector3d)
referenceVector(Vector3d)


StartAngle Property

StartAngle Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »StartAngle
Declaration Syntax
C# Visual Basic Visual C++
public double StartAngle { get; }
Public ReadOnly Property StartAngle As Double
    Get
public:
property double StartAngle {
    double get ();
}


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d StartPoint { get; }
Public ReadOnly Property StartPoint As Point3d
    Get
public:
property Point3d StartPoint {
    Point3d get ();
}


ClipBoundary2d Class

ClipBoundary2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeClipBoundary2d")]
public sealed class ClipBoundary2d : Entity2d
<WrapperAttribute("ZcGeClipBoundary2d")> _
Public NotInheritable Class ClipBoundary2d _
    Inherits Entity2d
[WrapperAttribute(L"ZcGeClipBoundary2d")]
public ref class ClipBoundary2d sealed : public Entity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClipBoundary2d(Point2d, Point2d) |
 | ClipBoundary2d(Point2dCollection) |
 | ClipBoundary2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | ClipPolygon(Point2dCollection) |
 | ClipPolyline(Point2dCollection) |
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Entity2d.)
 | IsOn(Point2d) | (Inherited from Entity2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | Set(Point2d, Point2d) |
 | Set(Point2dCollection) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | ClipBoundary2d


ClipBoundary2d Constructor

ClipBoundary2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »ClipBoundary2d()()()()
Members
Icon | Member | Description
 | ClipBoundary2d(Point2d, Point2d) |
 | ClipBoundary2d(Point2dCollection) |
 | ClipBoundary2d()()()() |


ClipBoundary2d Constructor

ClipBoundary2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »ClipBoundary2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClipBoundary2d()
Public Sub New
public:
ClipBoundary2d()


ClipBoundary2d Constructor (firstCorner, secondCorner)

ClipBoundary2d Constructor (firstCorner, secondCorner)
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »ClipBoundary2d(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public ClipBoundary2d(
    Point2d firstCorner,
    Point2d secondCorner
)
Public Sub New ( _
    firstCorner As Point2d, _
    secondCorner As Point2d _
)
public:
ClipBoundary2d(
    Point2d firstCorner,
    Point2d secondCorner
)
Parameters
firstCorner(Point2d)
secondCorner(Point2d)


ClipBoundary2d Constructor (clipBoundary)

ClipBoundary2d Constructor (clipBoundary)
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »ClipBoundary2d(Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ClipBoundary2d(
    Point2dCollection clipBoundary
)
Public Sub New ( _
    clipBoundary As Point2dCollection _
)
public:
ClipBoundary2d(
    Point2dCollection^ clipBoundary
)
Parameters
clipBoundary(Point2dCollection)


ClipPolygon Method (rawVertices)

ClipPolygon Method (rawVertices)
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »ClipPolygon(Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ClipBoundary2dData ClipPolygon(
    Point2dCollection rawVertices
)
Public Function ClipPolygon ( _
    rawVertices As Point2dCollection _
) As ClipBoundary2dData
public:
ClipBoundary2dData ClipPolygon(
    Point2dCollection^ rawVertices
)
Parameters
rawVertices(Point2dCollection)


ClipPolyline Method (rawVertices)

ClipPolyline Method (rawVertices)
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »ClipPolyline(Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ClipBoundary2dData ClipPolyline(
    Point2dCollection rawVertices
)
Public Function ClipPolyline ( _
    rawVertices As Point2dCollection _
) As ClipBoundary2dData
public:
ClipBoundary2dData ClipPolyline(
    Point2dCollection^ rawVertices
)
Parameters
rawVertices(Point2dCollection)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static ClipBoundary2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As ClipBoundary2d
public:
static ClipBoundary2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »Set()()()()
Members
Icon | Member | Description
 | Set(Point2d, Point2d) |
 | Set(Point2dCollection) |


Set Method (firstCorner, secondCorner)

Set Method (firstCorner, secondCorner)
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »Set(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public ClipError Set(
    Point2d firstCorner,
    Point2d secondCorner
)
Public Function Set ( _
    firstCorner As Point2d, _
    secondCorner As Point2d _
) As ClipError
public:
ClipError Set(
    Point2d firstCorner,
    Point2d secondCorner
)
Parameters
firstCorner(Point2d)
secondCorner(Point2d)


Set Method (clipBoundary)

Set Method (clipBoundary)
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »Set(Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ClipError Set(
    Point2dCollection clipBoundary
)
Public Function Set ( _
    clipBoundary As Point2dCollection _
) As ClipError
public:
ClipError Set(
    Point2dCollection^ clipBoundary
)
Parameters
clipBoundary(Point2dCollection)


ClipBoundary2dData Structure

ClipBoundary2dData Structure
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2dData
Declaration Syntax
C# Visual Basic Visual C++
public struct ClipBoundary2dData
Public Structure ClipBoundary2dData
public value class ClipBoundary2dData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClipCondition |
 | ClippedSegmentSourceLabel |
 | ClippedVertices |
 | Equality(ClipBoundary2dData, ClipBoundary2dData) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(ClipBoundary2dData, ClipBoundary2dData) |
 | IsEqualTo(ClipBoundary2dData) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)


ClipCondition Property

ClipCondition Property
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2dData »ClipCondition
Declaration Syntax
C# Visual Basic Visual C++
public ClipCondition ClipCondition { get; }
Public ReadOnly Property ClipCondition As ClipCondition
    Get
public:
property ClipCondition ClipCondition {
    ClipCondition get ();
}


ClippedSegmentSourceLabel Property

ClippedSegmentSourceLabel Property
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2dData »ClippedSegmentSourceLabel
Declaration Syntax
C# Visual Basic Visual C++
public IntegerCollection ClippedSegmentSourceLabel { get; }
Public ReadOnly Property ClippedSegmentSourceLabel As IntegerCollection
    Get
public:
property IntegerCollection^ ClippedSegmentSourceLabel {
    IntegerCollection^ get ();
}


ClippedVertices Property

ClippedVertices Property
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2dData »ClippedVertices
Declaration Syntax
C# Visual Basic Visual C++
public Point2dCollection ClippedVertices { get; }
Public ReadOnly Property ClippedVertices As Point2dCollection
    Get
public:
property Point2dCollection^ ClippedVertices {
    Point2dCollection^ get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2dData »Equality(ClipBoundary2dData, ClipBoundary2dData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    ClipBoundary2dData a,
    ClipBoundary2dData b
)
Public Shared Operator = ( _
    a As ClipBoundary2dData, _
    b As ClipBoundary2dData _
) As Boolean
public:
static bool operator ==(
    ClipBoundary2dData a,
    ClipBoundary2dData b
)
Parameters
a(ClipBoundary2dData)
b(ClipBoundary2dData)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2dData »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2dData »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2dData »Inequality(ClipBoundary2dData, ClipBoundary2dData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    ClipBoundary2dData a,
    ClipBoundary2dData b
)
Public Shared Operator <> ( _
    a As ClipBoundary2dData, _
    b As ClipBoundary2dData _
) As Boolean
public:
static bool operator !=(
    ClipBoundary2dData a,
    ClipBoundary2dData b
)
Parameters
a(ClipBoundary2dData)
b(ClipBoundary2dData)


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2dData »IsEqualTo(ClipBoundary2dData)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    ClipBoundary2dData a
)
Public Function IsEqualTo ( _
    a As ClipBoundary2dData _
) As Boolean
public:
bool IsEqualTo(
    ClipBoundary2dData a
)
Parameters
a(ClipBoundary2dData)


ClipCondition Enumeration

ClipCondition Enumeration
Namespaces »ZwSoft.ZwCAD.Geometry »ClipCondition
Declaration Syntax
C# Visual Basic Visual C++
public enum ClipCondition
Public Enumeration ClipCondition
public enum class ClipCondition
Members
Member | Description
AllSegmentsOutsideEvenWinds |
AllSegmentsOutsideOddWinds |
AllSegmentsOutsideZeroWinds |
SegmentsIntersect |
AllSegmentsInside |
Invalid |


ClipError Enumeration

ClipError Enumeration
Namespaces »ZwSoft.ZwCAD.Geometry »ClipError
Declaration Syntax
C# Visual Basic Visual C++
public enum ClipError
Public Enumeration ClipError
public enum class ClipError
Members
Member | Description
NotInitialized |
InvalidClipBoundary |
OK |


CompositeCurve2d Class

CompositeCurve2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCompositeCurve2d")]
public sealed class CompositeCurve2d : Curve2d
<WrapperAttribute("ZcGeCompositeCurve2d")> _
Public NotInheritable Class CompositeCurve2d _
    Inherits Curve2d
[WrapperAttribute(L"ZcGeCompositeCurve2d")]
public ref class CompositeCurve2d sealed : public Curve2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeCurve2d(array<Curve2d>[]()[][]) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint | (Inherited from Curve2d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetCurves()()()() |
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalToLocalParameter(Double) |
 | HasEndPoint | (Inherited from Curve2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | LocalToGlobalParameter(CompositeParameter) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | SetCurves(array<Curve2d>[]()[][]) |
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | StartPoint | (Inherited from Curve2d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | CompositeCurve2d


CompositeCurve2d Constructor (curves)

CompositeCurve2d Constructor (curves)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »CompositeCurve2d(array<Curve2d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CompositeCurve2d(
    Curve2d[] curves
)
Public Sub New ( _
    curves As Curve2d() _
)
public:
CompositeCurve2d(
    array<Curve2d^>^ curves
)
Parameters
curves(array< Curve2d >[]()[][])


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static CompositeCurve2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As CompositeCurve2d
public:
static CompositeCurve2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetCurves Method

GetCurves Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GetCurves()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d[] GetCurves()
Public Function GetCurves As Curve2d()
public:
array<Curve2d^>^ GetCurves()


GlobalToLocalParameter Method (value)

GlobalToLocalParameter Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GlobalToLocalParameter(Double)
Declaration Syntax
C# Visual Basic Visual C++
public CompositeParameter GlobalToLocalParameter(
    double value
)
Public Function GlobalToLocalParameter ( _
    value As Double _
) As CompositeParameter
public:
CompositeParameter GlobalToLocalParameter(
    double value
)
Parameters
value(Double)


LocalToGlobalParameter Method (value)

LocalToGlobalParameter Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »LocalToGlobalParameter(CompositeParameter)
Declaration Syntax
C# Visual Basic Visual C++
public double LocalToGlobalParameter(
    CompositeParameter value
)
Public Function LocalToGlobalParameter ( _
    value As CompositeParameter _
) As Double
public:
double LocalToGlobalParameter(
    CompositeParameter value
)
Parameters
value(CompositeParameter)


SetCurves Method (curves)

SetCurves Method (curves)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »SetCurves(array<Curve2d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetCurves(
    Curve2d[] curves
)
Public Sub SetCurves ( _
    curves As Curve2d() _
)
public:
void SetCurves(
    array<Curve2d^>^ curves
)
Parameters
curves(array< Curve2d >[]()[][])


CompositeCurve3d Class

CompositeCurve3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCompositeCurve3d")]
public sealed class CompositeCurve3d : Curve3d
<WrapperAttribute("ZcGeCompositeCurve3d")> _
Public NotInheritable Class CompositeCurve3d _
    Inherits Curve3d
[WrapperAttribute(L"ZcGeCompositeCurve3d")]
public ref class CompositeCurve3d sealed : public Curve3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeCurve3d(array<Curve3d>[]()[][]) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint | (Inherited from Curve3d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetCurves()()()() |
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalToLocalParameter(Double) |
 | HasEndPoint | (Inherited from Curve3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | LocalToGlobalParameter(CompositeParameter) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | StartPoint | (Inherited from Curve3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | CompositeCurve3d


CompositeCurve3d Constructor (curves)

CompositeCurve3d Constructor (curves)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »CompositeCurve3d(array<Curve3d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CompositeCurve3d(
    Curve3d[] curves
)
Public Sub New ( _
    curves As Curve3d() _
)
public:
CompositeCurve3d(
    array<Curve3d^>^ curves
)
Parameters
curves(array< Curve3d >[]()[][])


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static CompositeCurve3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As CompositeCurve3d
public:
static CompositeCurve3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetCurves Method

GetCurves Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetCurves()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d[] GetCurves()
Public Function GetCurves As Curve3d()
public:
array<Curve3d^>^ GetCurves()


GlobalToLocalParameter Method (value)

GlobalToLocalParameter Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GlobalToLocalParameter(Double)
Declaration Syntax
C# Visual Basic Visual C++
public CompositeParameter GlobalToLocalParameter(
    double value
)
Public Function GlobalToLocalParameter ( _
    value As Double _
) As CompositeParameter
public:
CompositeParameter GlobalToLocalParameter(
    double value
)
Parameters
value(Double)


LocalToGlobalParameter Method (value)

LocalToGlobalParameter Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »LocalToGlobalParameter(CompositeParameter)
Declaration Syntax
C# Visual Basic Visual C++
public double LocalToGlobalParameter(
    CompositeParameter value
)
Public Function LocalToGlobalParameter ( _
    value As CompositeParameter _
) As Double
public:
double LocalToGlobalParameter(
    CompositeParameter value
)
Parameters
value(CompositeParameter)


CompositeParameter Structure

CompositeParameter Structure
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter
Declaration Syntax
C# Visual Basic Visual C++
public struct CompositeParameter
Public Structure CompositeParameter
public value class CompositeParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeParameter(Int32, Double) |
 | Equality(CompositeParameter, CompositeParameter) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(CompositeParameter, CompositeParameter) |
 | IsEqualTo(CompositeParameter, Tolerance) |
 | IsEqualTo(CompositeParameter) |
 | LocalParameter |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SegmentIndex |
 | ToString()()()() | (Inherited from ValueType.)


CompositeParameter Constructor (segmentIndex, localParameter)

CompositeParameter Constructor (segmentIndex, localParameter)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter »CompositeParameter(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public CompositeParameter(
    int segmentIndex,
    double localParameter
)
Public Sub New ( _
    segmentIndex As Integer, _
    localParameter As Double _
)
public:
CompositeParameter(
    int segmentIndex,
    double localParameter
)
Parameters
segmentIndex(Int32)
localParameter(Double)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter »Equality(CompositeParameter, CompositeParameter)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    CompositeParameter a,
    CompositeParameter b
)
Public Shared Operator = ( _
    a As CompositeParameter, _
    b As CompositeParameter _
) As Boolean
public:
static bool operator ==(
    CompositeParameter a,
    CompositeParameter b
)
Parameters
a(CompositeParameter)
b(CompositeParameter)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter »Inequality(CompositeParameter, CompositeParameter)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    CompositeParameter a,
    CompositeParameter b
)
Public Shared Operator <> ( _
    a As CompositeParameter, _
    b As CompositeParameter _
) As Boolean
public:
static bool operator !=(
    CompositeParameter a,
    CompositeParameter b
)
Parameters
a(CompositeParameter)
b(CompositeParameter)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(CompositeParameter, Tolerance) |
 | IsEqualTo(CompositeParameter) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter »IsEqualTo(CompositeParameter)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    CompositeParameter a
)
Public Function IsEqualTo ( _
    a As CompositeParameter _
) As Boolean
public:
bool IsEqualTo(
    CompositeParameter a
)
Parameters
a(CompositeParameter)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter »IsEqualTo(CompositeParameter, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    CompositeParameter a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As CompositeParameter, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    CompositeParameter a,
    Tolerance tolerance
)
Parameters
a(CompositeParameter)
tolerance(Tolerance)


LocalParameter Property

LocalParameter Property
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter »LocalParameter
Declaration Syntax
C# Visual Basic Visual C++
public double LocalParameter { get; }
Public ReadOnly Property LocalParameter As Double
    Get
public:
property double LocalParameter {
    double get ();
}


SegmentIndex Property

SegmentIndex Property
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeParameter »SegmentIndex
Declaration Syntax
C# Visual Basic Visual C++
public int SegmentIndex { get; }
Public ReadOnly Property SegmentIndex As Integer
    Get
public:
property int SegmentIndex {
    int get ();
}


Cone Class

Cone Class
Namespaces »ZwSoft.ZwCAD.Geometry »Cone
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCone")]
public sealed class Cone : Surface
<WrapperAttribute("ZcGeCone")> _
Public NotInheritable Class Cone _
    Inherits Surface
[WrapperAttribute(L"ZcGeCone")]
public ref class Cone sealed : public Surface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Cone(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double) |
 | Cone(Double, Double, Point3d, Double, Vector3d) |
 | Cone()()()() |
 | Apex |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | AxisOfSymmetry |
 | BaseCenter |
 | BaseRadius |
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAngles()()()() |
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHalfAngles()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetHeightAt(Double) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | HalfAngle |
 | Height |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |
 | IsClosed(Tolerance) |
 | IsClosed()()()() |
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsNormalReversed | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsOuterNormal |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | ReferenceAxis |
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double) |
 | Set(Double, Double, Point3d, Double, Vector3d) |
 | SetAngles(Double, Double) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | Cone


Cone Constructor

Cone Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Cone()()()()
Members
Icon | Member | Description
 | Cone(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double) |
 | Cone(Double, Double, Point3d, Double, Vector3d) |
 | Cone()()()() |


Cone Constructor

Cone Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Cone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Cone()
Public Sub New
public:
Cone()


Cone Constructor (cosineAngle, sineAngle, baseOrigin, baseRadius, axisOfSymmetry)

Cone Constructor (cosineAngle, sineAngle, baseOrigin, baseRadius, axisOfSymmetry)
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Cone(Double, Double, Point3d, Double, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Cone(
    double cosineAngle,
    double sineAngle,
    Point3d baseOrigin,
    double baseRadius,
    Vector3d axisOfSymmetry
)
Public Sub New ( _
    cosineAngle As Double, _
    sineAngle As Double, _
    baseOrigin As Point3d, _
    baseRadius As Double, _
    axisOfSymmetry As Vector3d _
)
public:
Cone(
    double cosineAngle,
    double sineAngle,
    Point3d baseOrigin,
    double baseRadius,
    Vector3d axisOfSymmetry
)
Parameters
cosineAngle(Double)
sineAngle(Double)
baseOrigin(Point3d)
baseRadius(Double)
axisOfSymmetry(Vector3d)


Cone Constructor (cosineAngle, sineAngle, baseOrigin, baseRadius, axisOfSymmetry, referenceAxis, height, startAngle, endAngle)

Cone Constructor (cosineAngle, sineAngle, baseOrigin, baseRadius, axisOfSymmetry, referenceAxis, height, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Cone(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Cone(
    double cosineAngle,
    double sineAngle,
    Point3d baseOrigin,
    double baseRadius,
    Vector3d axisOfSymmetry,
    Vector3d referenceAxis,
    Interval height,
    double startAngle,
    double endAngle
)
Public Sub New ( _
    cosineAngle As Double, _
    sineAngle As Double, _
    baseOrigin As Point3d, _
    baseRadius As Double, _
    axisOfSymmetry As Vector3d, _
    referenceAxis As Vector3d, _
    height As Interval, _
    startAngle As Double, _
    endAngle As Double _
)
public:
Cone(
    double cosineAngle,
    double sineAngle,
    Point3d baseOrigin,
    double baseRadius,
    Vector3d axisOfSymmetry,
    Vector3d referenceAxis,
    Interval^ height,
    double startAngle,
    double endAngle
)
Parameters
cosineAngle(Double)
sineAngle(Double)
baseOrigin(Point3d)
baseRadius(Double)
axisOfSymmetry(Vector3d)
referenceAxis(Vector3d)
height(Interval)
startAngle(Double)
endAngle(Double)


Apex Property

Apex Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Apex
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Apex { get; }
Public ReadOnly Property Apex As Point3d
    Get
public:
property Point3d Apex {
    Point3d get ();
}


AxisOfSymmetry Property

AxisOfSymmetry Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »AxisOfSymmetry
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d AxisOfSymmetry { get; }
Public ReadOnly Property AxisOfSymmetry As Vector3d
    Get
public:
property Vector3d AxisOfSymmetry {
    Vector3d get ();
}


BaseCenter Property

BaseCenter Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »BaseCenter
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BaseCenter { get; }
Public ReadOnly Property BaseCenter As Point3d
    Get
public:
property Point3d BaseCenter {
    Point3d get ();
}


BaseRadius Property

BaseRadius Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »BaseRadius
Declaration Syntax
C# Visual Basic Visual C++
public double BaseRadius { get; set; }
Public Property BaseRadius As Double
    Get
    Set
public:
property double BaseRadius {
    double get ();
    void set (double value);
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Cone Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Cone
public:
static Cone^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetAngles Method

GetAngles Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »GetAngles()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] GetAngles()
Public Function GetAngles As Double()
public:
array<double>^ GetAngles()


GetHalfAngles Method

GetHalfAngles Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »GetHalfAngles()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] GetHalfAngles()
Public Function GetHalfAngles As Double()
public:
array<double>^ GetHalfAngles()


GetHeightAt Method (parameter)

GetHeightAt Method (parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »GetHeightAt(Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetHeightAt(
    double parameter
)
Public Function GetHeightAt ( _
    parameter As Double _
) As Double
public:
double GetHeightAt(
    double parameter
)
Parameters
parameter(Double)


HalfAngle Property

HalfAngle Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »HalfAngle
Declaration Syntax
C# Visual Basic Visual C++
public double HalfAngle { get; }
Public ReadOnly Property HalfAngle As Double
    Get
public:
property double HalfAngle {
    double get ();
}


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Height
Declaration Syntax
C# Visual Basic Visual C++
public Interval Height { get; set; }
Public Property Height As Interval
    Get
    Set
public:
property Interval^ Height {
    Interval^ get ();
    void set (Interval^ value);
}


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |


IntersectWith Method (linearEntity)

IntersectWith Method (linearEntity)
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IntersectWith(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d linearEntity
)
Public Function IntersectWith ( _
    linearEntity As LinearEntity3d _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ linearEntity
)
Parameters
linearEntity(LinearEntity3d)


IntersectWith Method (linearEntity, tolerance)

IntersectWith Method (linearEntity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IntersectWith(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d linearEntity,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    linearEntity As LinearEntity3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ linearEntity,
    Tolerance tolerance
)
Parameters
linearEntity(LinearEntity3d)
tolerance(Tolerance)


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IsClosed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed()
Public Function IsClosed As Boolean
public:
bool IsClosed()


IsClosed Method (tolerance)

IsClosed Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IsClosed(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed(
    Tolerance tolerance
)
Public Function IsClosed ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsClosed(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsOuterNormal Property

IsOuterNormal Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IsOuterNormal
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOuterNormal { get; }
Public ReadOnly Property IsOuterNormal As Boolean
    Get
public:
property bool IsOuterNormal {
    bool get ();
}


ReferenceAxis Property

ReferenceAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »ReferenceAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d ReferenceAxis { get; }
Public ReadOnly Property ReferenceAxis As Vector3d
    Get
public:
property Vector3d ReferenceAxis {
    Vector3d get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Set()()()()
Members
Icon | Member | Description
 | Set(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double) |
 | Set(Double, Double, Point3d, Double, Vector3d) |


Set Method (cosineAngle, sineAngle, baseCenter, baseRadius, axisOfSymmetry)

Set Method (cosineAngle, sineAngle, baseCenter, baseRadius, axisOfSymmetry)
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Set(Double, Double, Point3d, Double, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double cosineAngle,
    double sineAngle,
    Point3d baseCenter,
    double baseRadius,
    Vector3d axisOfSymmetry
)
Public Sub Set ( _
    cosineAngle As Double, _
    sineAngle As Double, _
    baseCenter As Point3d, _
    baseRadius As Double, _
    axisOfSymmetry As Vector3d _
)
public:
void Set(
    double cosineAngle,
    double sineAngle,
    Point3d baseCenter,
    double baseRadius,
    Vector3d axisOfSymmetry
)
Parameters
cosineAngle(Double)
sineAngle(Double)
baseCenter(Point3d)
baseRadius(Double)
axisOfSymmetry(Vector3d)


Set Method (cosineAngle, sineAngle, baseCenter, baseRadius, axisOfSymmetry, refAxis, height, startAngle, endAngle)

Set Method (cosineAngle, sineAngle, baseCenter, baseRadius, axisOfSymmetry, refAxis, height, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Set(Double, Double, Point3d, Double, Vector3d, Vector3d, Interval, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double cosineAngle,
    double sineAngle,
    Point3d baseCenter,
    double baseRadius,
    Vector3d axisOfSymmetry,
    Vector3d refAxis,
    Interval height,
    double startAngle,
    double endAngle
)
Public Sub Set ( _
    cosineAngle As Double, _
    sineAngle As Double, _
    baseCenter As Point3d, _
    baseRadius As Double, _
    axisOfSymmetry As Vector3d, _
    refAxis As Vector3d, _
    height As Interval, _
    startAngle As Double, _
    endAngle As Double _
)
public:
void Set(
    double cosineAngle,
    double sineAngle,
    Point3d baseCenter,
    double baseRadius,
    Vector3d axisOfSymmetry,
    Vector3d refAxis,
    Interval^ height,
    double startAngle,
    double endAngle
)
Parameters
cosineAngle(Double)
sineAngle(Double)
baseCenter(Point3d)
baseRadius(Double)
axisOfSymmetry(Vector3d)
refAxis(Vector3d)
height(Interval)
startAngle(Double)
endAngle(Double)


SetAngles Method (startAngle, endAngle)

SetAngles Method (startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »SetAngles(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAngles(
    double startAngle,
    double endAngle
)
Public Sub SetAngles ( _
    startAngle As Double, _
    endAngle As Double _
)
public:
void SetAngles(
    double startAngle,
    double endAngle
)
Parameters
startAngle(Double)
endAngle(Double)


CoordinateSystem2d Structure

CoordinateSystem2d Structure
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d
Declaration Syntax
C# Visual Basic Visual C++
public struct CoordinateSystem2d : IFormattable
Public Structure CoordinateSystem2d _
    Implements IFormattable
public value class CoordinateSystem2d : IFormattable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CoordinateSystem2d(Point2d, Vector2d, Vector2d) |
 | Equality(CoordinateSystem2d, CoordinateSystem2d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(CoordinateSystem2d, CoordinateSystem2d) |
 | IsEqualTo(CoordinateSystem2d, Tolerance) |
 | IsEqualTo(CoordinateSystem2d) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Origin |
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | Xaxis |
 | Yaxis |


CoordinateSystem2d Constructor (o, x, y)

CoordinateSystem2d Constructor (o, x, y)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »CoordinateSystem2d(Point2d, Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public CoordinateSystem2d(
    Point2d o,
    Vector2d x,
    Vector2d y
)
Public Sub New ( _
    o As Point2d, _
    x As Vector2d, _
    y As Vector2d _
)
public:
CoordinateSystem2d(
    Point2d o,
    Vector2d x,
    Vector2d y
)
Parameters
o(Point2d)
x(Vector2d)
y(Vector2d)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »Equality(CoordinateSystem2d, CoordinateSystem2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    CoordinateSystem2d a,
    CoordinateSystem2d b
)
Public Shared Operator = ( _
    a As CoordinateSystem2d, _
    b As CoordinateSystem2d _
) As Boolean
public:
static bool operator ==(
    CoordinateSystem2d a,
    CoordinateSystem2d b
)
Parameters
a(CoordinateSystem2d)
b(CoordinateSystem2d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »Inequality(CoordinateSystem2d, CoordinateSystem2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    CoordinateSystem2d a,
    CoordinateSystem2d b
)
Public Shared Operator <> ( _
    a As CoordinateSystem2d, _
    b As CoordinateSystem2d _
) As Boolean
public:
static bool operator !=(
    CoordinateSystem2d a,
    CoordinateSystem2d b
)
Parameters
a(CoordinateSystem2d)
b(CoordinateSystem2d)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(CoordinateSystem2d, Tolerance) |
 | IsEqualTo(CoordinateSystem2d) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »IsEqualTo(CoordinateSystem2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    CoordinateSystem2d a
)
Public Function IsEqualTo ( _
    a As CoordinateSystem2d _
) As Boolean
public:
bool IsEqualTo(
    CoordinateSystem2d a
)
Parameters
a(CoordinateSystem2d)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »IsEqualTo(CoordinateSystem2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    CoordinateSystem2d a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As CoordinateSystem2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    CoordinateSystem2d a,
    Tolerance tolerance
)
Parameters
a(CoordinateSystem2d)
tolerance(Tolerance)


Origin Property

Origin Property
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »Origin
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Origin { get; }
Public ReadOnly Property Origin As Point2d
    Get
public:
property Point2d Origin {
    Point2d get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


Xaxis Property

Xaxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »Xaxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Xaxis { get; }
Public ReadOnly Property Xaxis As Vector2d
    Get
public:
property Vector2d Xaxis {
    Vector2d get ();
}


Yaxis Property

Yaxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem2d »Yaxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Yaxis { get; }
Public ReadOnly Property Yaxis As Vector2d
    Get
public:
property Vector2d Yaxis {
    Vector2d get ();
}


CoordinateSystem3d Structure

CoordinateSystem3d Structure
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d
Declaration Syntax
C# Visual Basic Visual C++
public struct CoordinateSystem3d : IFormattable
Public Structure CoordinateSystem3d _
    Implements IFormattable
public value class CoordinateSystem3d : IFormattable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CoordinateSystem3d(Point3d, Vector3d, Vector3d) |
 | Equality(CoordinateSystem3d, CoordinateSystem3d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(CoordinateSystem3d, CoordinateSystem3d) |
 | IsEqualTo(CoordinateSystem3d, Tolerance) |
 | IsEqualTo(CoordinateSystem3d) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Origin |
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | Xaxis |
 | Yaxis |
 | Zaxis |


CoordinateSystem3d Constructor (o, x, y)

CoordinateSystem3d Constructor (o, x, y)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »CoordinateSystem3d(Point3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public CoordinateSystem3d(
    Point3d o,
    Vector3d x,
    Vector3d y
)
Public Sub New ( _
    o As Point3d, _
    x As Vector3d, _
    y As Vector3d _
)
public:
CoordinateSystem3d(
    Point3d o,
    Vector3d x,
    Vector3d y
)
Parameters
o(Point3d)
x(Vector3d)
y(Vector3d)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »Equality(CoordinateSystem3d, CoordinateSystem3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    CoordinateSystem3d a,
    CoordinateSystem3d b
)
Public Shared Operator = ( _
    a As CoordinateSystem3d, _
    b As CoordinateSystem3d _
) As Boolean
public:
static bool operator ==(
    CoordinateSystem3d a,
    CoordinateSystem3d b
)
Parameters
a(CoordinateSystem3d)
b(CoordinateSystem3d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »Inequality(CoordinateSystem3d, CoordinateSystem3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    CoordinateSystem3d a,
    CoordinateSystem3d b
)
Public Shared Operator <> ( _
    a As CoordinateSystem3d, _
    b As CoordinateSystem3d _
) As Boolean
public:
static bool operator !=(
    CoordinateSystem3d a,
    CoordinateSystem3d b
)
Parameters
a(CoordinateSystem3d)
b(CoordinateSystem3d)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(CoordinateSystem3d, Tolerance) |
 | IsEqualTo(CoordinateSystem3d) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »IsEqualTo(CoordinateSystem3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    CoordinateSystem3d a
)
Public Function IsEqualTo ( _
    a As CoordinateSystem3d _
) As Boolean
public:
bool IsEqualTo(
    CoordinateSystem3d a
)
Parameters
a(CoordinateSystem3d)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »IsEqualTo(CoordinateSystem3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    CoordinateSystem3d a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As CoordinateSystem3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    CoordinateSystem3d a,
    Tolerance tolerance
)
Parameters
a(CoordinateSystem3d)
tolerance(Tolerance)


Origin Property

Origin Property
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »Origin
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Origin { get; }
Public ReadOnly Property Origin As Point3d
    Get
public:
property Point3d Origin {
    Point3d get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


Xaxis Property

Xaxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »Xaxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Xaxis { get; }
Public ReadOnly Property Xaxis As Vector3d
    Get
public:
property Vector3d Xaxis {
    Vector3d get ();
}


Yaxis Property

Yaxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »Yaxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Yaxis { get; }
Public ReadOnly Property Yaxis As Vector3d
    Get
public:
property Vector3d Yaxis {
    Vector3d get ();
}


Zaxis Property

Zaxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »CoordinateSystem3d »Zaxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Zaxis { get; }
Public ReadOnly Property Zaxis As Vector3d
    Get
public:
property Vector3d Zaxis {
    Vector3d get ();
}


CubicSplineCurve2d Class

CubicSplineCurve2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCubicSplineCurve2d")]
public sealed class CubicSplineCurve2d : SplineEntity2d
<WrapperAttribute("ZcGeCubicSplineCurve2d")> _
Public NotInheritable Class CubicSplineCurve2d _
    Inherits SplineEntity2d
[WrapperAttribute(L"ZcGeCubicSplineCurve2d")]
public ref class CubicSplineCurve2d sealed : public SplineEntity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CubicSplineCurve2d(Point2dCollection, Vector2d, Vector2d, Tolerance) |
 | CubicSplineCurve2d(KnotCollection, Point2dCollection, Vector2dCollection, Boolean) |
 | CubicSplineCurve2d(Point2dCollection, Vector2d, Vector2d) |
 | CubicSplineCurve2d(Point2dCollection, Tolerance) |
 | CubicSplineCurve2d(Curve2d, Double) |
 | CubicSplineCurve2d(Point2dCollection) |
 | CubicSplineCurve2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Degree | (Inherited from SplineEntity2d.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndParameter | (Inherited from SplineEntity2d.)
 | EndPoint | (Inherited from SplineEntity2d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetContinuityAtKnot(Int32, Tolerance) | (Inherited from SplineEntity2d.)
 | GetContinuityAtKnot(Int32) | (Inherited from SplineEntity2d.)
 | GetControlPointAt(Int32) | (Inherited from SplineEntity2d.)
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetFirstDerivativeAt(Int32) |
 | GetFitPointAt(Int32) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetKnotAt(Int32) | (Inherited from SplineEntity2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve2d.)
 | HasFitData | (Inherited from SplineEntity2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | IsRational | (Inherited from SplineEntity2d.)
 | Knots | (Inherited from SplineEntity2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | NumControlPoints | (Inherited from SplineEntity2d.)
 | NumFitPoints |
 | NumKnots | (Inherited from SplineEntity2d.)
 | Order | (Inherited from SplineEntity2d.)
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | SetControlPointAt(Int32, Point2d) | (Inherited from SplineEntity2d.)
 | SetFirstDerivativeAt(Int32, Vector2d) |
 | SetFitPointAt(Int32, Point2d) |
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | SetKnotAt(Int32, Double) | (Inherited from SplineEntity2d.)
 | StartParameter | (Inherited from SplineEntity2d.)
 | StartPoint | (Inherited from SplineEntity2d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | SplineEntity2d
 |  |  |  |  |  | CubicSplineCurve2d


CubicSplineCurve2d Constructor

CubicSplineCurve2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »CubicSplineCurve2d()()()()
Members
Icon | Member | Description
 | CubicSplineCurve2d(Point2dCollection, Vector2d, Vector2d, Tolerance) |
 | CubicSplineCurve2d(KnotCollection, Point2dCollection, Vector2dCollection, Boolean) |
 | CubicSplineCurve2d(Point2dCollection, Vector2d, Vector2d) |
 | CubicSplineCurve2d(Point2dCollection, Tolerance) |
 | CubicSplineCurve2d(Curve2d, Double) |
 | CubicSplineCurve2d(Point2dCollection) |
 | CubicSplineCurve2d()()()() |


CubicSplineCurve2d Constructor

CubicSplineCurve2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »CubicSplineCurve2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve2d()
Public Sub New
public:
CubicSplineCurve2d()


CubicSplineCurve2d Constructor (curve, epsilon)

CubicSplineCurve2d Constructor (curve, epsilon)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »CubicSplineCurve2d(Curve2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve2d(
    Curve2d curve,
    double epsilon
)
Public Sub New ( _
    curve As Curve2d, _
    epsilon As Double _
)
public:
CubicSplineCurve2d(
    Curve2d^ curve,
    double epsilon
)
Parameters
curve(Curve2d)
epsilon(Double)


CubicSplineCurve2d Constructor (knots, fitPoints, firstDerivatives, periodic)

CubicSplineCurve2d Constructor (knots, fitPoints, firstDerivatives, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »CubicSplineCurve2d(KnotCollection, Point2dCollection, Vector2dCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve2d(
    KnotCollection knots,
    Point2dCollection fitPoints,
    Vector2dCollection firstDerivatives,
    bool periodic
)
Public Sub New ( _
    knots As KnotCollection, _
    fitPoints As Point2dCollection, _
    firstDerivatives As Vector2dCollection, _
    periodic As Boolean _
)
public:
CubicSplineCurve2d(
    KnotCollection^ knots,
    Point2dCollection^ fitPoints,
    Vector2dCollection^ firstDerivatives,
    bool periodic
)
Parameters
knots(KnotCollection)
fitPoints(Point2dCollection)
firstDerivatives(Vector2dCollection)
periodic(Boolean)


CubicSplineCurve2d Constructor (fitPoints)

CubicSplineCurve2d Constructor (fitPoints)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »CubicSplineCurve2d(Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve2d(
    Point2dCollection fitPoints
)
Public Sub New ( _
    fitPoints As Point2dCollection _
)
public:
CubicSplineCurve2d(
    Point2dCollection^ fitPoints
)
Parameters
fitPoints(Point2dCollection)


CubicSplineCurve2d Constructor (fitPoints, tolerance)

CubicSplineCurve2d Constructor (fitPoints, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »CubicSplineCurve2d(Point2dCollection, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve2d(
    Point2dCollection fitPoints,
    Tolerance tolerance
)
Public Sub New ( _
    fitPoints As Point2dCollection, _
    tolerance As Tolerance _
)
public:
CubicSplineCurve2d(
    Point2dCollection^ fitPoints,
    Tolerance tolerance
)
Parameters
fitPoints(Point2dCollection)
tolerance(Tolerance)


CubicSplineCurve2d Constructor (fitPoints, startDerivative, endDerivative)

CubicSplineCurve2d Constructor (fitPoints, startDerivative, endDerivative)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »CubicSplineCurve2d(Point2dCollection, Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve2d(
    Point2dCollection fitPoints,
    Vector2d startDerivative,
    Vector2d endDerivative
)
Public Sub New ( _
    fitPoints As Point2dCollection, _
    startDerivative As Vector2d, _
    endDerivative As Vector2d _
)
public:
CubicSplineCurve2d(
    Point2dCollection^ fitPoints,
    Vector2d startDerivative,
    Vector2d endDerivative
)
Parameters
fitPoints(Point2dCollection)
startDerivative(Vector2d)
endDerivative(Vector2d)


CubicSplineCurve2d Constructor (fitPoints, startDerivative, endDerivative, tolerance)

CubicSplineCurve2d Constructor (fitPoints, startDerivative, endDerivative, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »CubicSplineCurve2d(Point2dCollection, Vector2d, Vector2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve2d(
    Point2dCollection fitPoints,
    Vector2d startDerivative,
    Vector2d endDerivative,
    Tolerance tolerance
)
Public Sub New ( _
    fitPoints As Point2dCollection, _
    startDerivative As Vector2d, _
    endDerivative As Vector2d, _
    tolerance As Tolerance _
)
public:
CubicSplineCurve2d(
    Point2dCollection^ fitPoints,
    Vector2d startDerivative,
    Vector2d endDerivative,
    Tolerance tolerance
)
Parameters
fitPoints(Point2dCollection)
startDerivative(Vector2d)
endDerivative(Vector2d)
tolerance(Tolerance)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static CubicSplineCurve2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As CubicSplineCurve2d
public:
static CubicSplineCurve2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetFirstDerivativeAt Method (index)

GetFirstDerivativeAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetFirstDerivativeAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetFirstDerivativeAt(
    int index
)
Public Function GetFirstDerivativeAt ( _
    index As Integer _
) As Vector2d
public:
Vector2d GetFirstDerivativeAt(
    int index
)
Parameters
index(Int32)


GetFitPointAt Method (index)

GetFitPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetFitPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetFitPointAt(
    int index
)
Public Function GetFitPointAt ( _
    index As Integer _
) As Point2d
public:
Point2d GetFitPointAt(
    int index
)
Parameters
index(Int32)


NumFitPoints Property

NumFitPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »NumFitPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumFitPoints { get; }
Public ReadOnly Property NumFitPoints As Integer
    Get
public:
property int NumFitPoints {
    int get ();
}


SetFirstDerivativeAt Method (index, derivative)

SetFirstDerivativeAt Method (index, derivative)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »SetFirstDerivativeAt(Int32, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFirstDerivativeAt(
    int index,
    Vector2d derivative
)
Public Sub SetFirstDerivativeAt ( _
    index As Integer, _
    derivative As Vector2d _
)
public:
void SetFirstDerivativeAt(
    int index,
    Vector2d derivative
)
Parameters
index(Int32)
derivative(Vector2d)


SetFitPointAt Method (index, point)

SetFitPointAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »SetFitPointAt(Int32, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitPointAt(
    int index,
    Point2d point
)
Public Sub SetFitPointAt ( _
    index As Integer, _
    point As Point2d _
)
public:
void SetFitPointAt(
    int index,
    Point2d point
)
Parameters
index(Int32)
point(Point2d)


CubicSplineCurve3d Class

CubicSplineCurve3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCubicSplineCurve3d")]
public sealed class CubicSplineCurve3d : SplineEntity3d
<WrapperAttribute("ZcGeCubicSplineCurve3d")> _
Public NotInheritable Class CubicSplineCurve3d _
    Inherits SplineEntity3d
[WrapperAttribute(L"ZcGeCubicSplineCurve3d")]
public ref class CubicSplineCurve3d sealed : public SplineEntity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CubicSplineCurve3d(Point3dCollection, Vector3d, Vector3d, Tolerance) |
 | CubicSplineCurve3d(KnotCollection, Point3dCollection, Vector3dCollection, Boolean) |
 | CubicSplineCurve3d(Point3dCollection, Vector3d, Vector3d) |
 | CubicSplineCurve3d(Point3dCollection, Tolerance) |
 | CubicSplineCurve3d(Curve3d, Double) |
 | CubicSplineCurve3d(Point3dCollection) |
 | CubicSplineCurve3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ControlPointAt(Int32) | (Inherited from SplineEntity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Degree | (Inherited from SplineEntity3d.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndParameter | (Inherited from SplineEntity3d.)
 | EndPoint | (Inherited from SplineEntity3d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FirstDerivativeAt(Int32) |
 | FitPointAt(Int32) |
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetContinuityAtKnot(Int32, Tolerance) | (Inherited from SplineEntity3d.)
 | GetContinuityAtKnot(Int32) | (Inherited from SplineEntity3d.)
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve3d.)
 | HasFitData | (Inherited from SplineEntity3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | IsRational | (Inherited from SplineEntity3d.)
 | KnotAt(Int32) | (Inherited from SplineEntity3d.)
 | Knots | (Inherited from SplineEntity3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | NumberOfControlPoints | (Inherited from SplineEntity3d.)
 | NumberOfFitPoints |
 | NumberOfKnots | (Inherited from SplineEntity3d.)
 | Order | (Inherited from SplineEntity3d.)
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | SetControlPointAt(Int32, Point3d) | (Inherited from SplineEntity3d.)
 | SetFirstDerivativeAt(Int32, Vector3d) |
 | SetFitPointAt(Int32, Point3d) |
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | SetKnotAt(Int32, Double) | (Inherited from SplineEntity3d.)
 | StartParameter | (Inherited from SplineEntity3d.)
 | StartPoint | (Inherited from SplineEntity3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | SplineEntity3d
 |  |  |  |  |  | CubicSplineCurve3d


CubicSplineCurve3d Constructor

CubicSplineCurve3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »CubicSplineCurve3d()()()()
Members
Icon | Member | Description
 | CubicSplineCurve3d(Point3dCollection, Vector3d, Vector3d, Tolerance) |
 | CubicSplineCurve3d(KnotCollection, Point3dCollection, Vector3dCollection, Boolean) |
 | CubicSplineCurve3d(Point3dCollection, Vector3d, Vector3d) |
 | CubicSplineCurve3d(Point3dCollection, Tolerance) |
 | CubicSplineCurve3d(Curve3d, Double) |
 | CubicSplineCurve3d(Point3dCollection) |
 | CubicSplineCurve3d()()()() |


CubicSplineCurve3d Constructor

CubicSplineCurve3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »CubicSplineCurve3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve3d()
Public Sub New
public:
CubicSplineCurve3d()


CubicSplineCurve3d Constructor (curve, epsilon)

CubicSplineCurve3d Constructor (curve, epsilon)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »CubicSplineCurve3d(Curve3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve3d(
    Curve3d curve,
    double epsilon
)
Public Sub New ( _
    curve As Curve3d, _
    epsilon As Double _
)
public:
CubicSplineCurve3d(
    Curve3d^ curve,
    double epsilon
)
Parameters
curve(Curve3d)
epsilon(Double)


CubicSplineCurve3d Constructor (knots, fitPoints, firstDerivatives, periodic)

CubicSplineCurve3d Constructor (knots, fitPoints, firstDerivatives, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »CubicSplineCurve3d(KnotCollection, Point3dCollection, Vector3dCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve3d(
    KnotCollection knots,
    Point3dCollection fitPoints,
    Vector3dCollection firstDerivatives,
    bool periodic
)
Public Sub New ( _
    knots As KnotCollection, _
    fitPoints As Point3dCollection, _
    firstDerivatives As Vector3dCollection, _
    periodic As Boolean _
)
public:
CubicSplineCurve3d(
    KnotCollection^ knots,
    Point3dCollection^ fitPoints,
    Vector3dCollection^ firstDerivatives,
    bool periodic
)
Parameters
knots(KnotCollection)
fitPoints(Point3dCollection)
firstDerivatives(Vector3dCollection)
periodic(Boolean)


CubicSplineCurve3d Constructor (points)

CubicSplineCurve3d Constructor (points)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »CubicSplineCurve3d(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve3d(
    Point3dCollection points
)
Public Sub New ( _
    points As Point3dCollection _
)
public:
CubicSplineCurve3d(
    Point3dCollection^ points
)
Parameters
points(Point3dCollection)


CubicSplineCurve3d Constructor (points, tolerance)

CubicSplineCurve3d Constructor (points, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »CubicSplineCurve3d(Point3dCollection, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve3d(
    Point3dCollection points,
    Tolerance tolerance
)
Public Sub New ( _
    points As Point3dCollection, _
    tolerance As Tolerance _
)
public:
CubicSplineCurve3d(
    Point3dCollection^ points,
    Tolerance tolerance
)
Parameters
points(Point3dCollection)
tolerance(Tolerance)


CubicSplineCurve3d Constructor (points, startDerivative, endDerivative)

CubicSplineCurve3d Constructor (points, startDerivative, endDerivative)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »CubicSplineCurve3d(Point3dCollection, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve3d(
    Point3dCollection points,
    Vector3d startDerivative,
    Vector3d endDerivative
)
Public Sub New ( _
    points As Point3dCollection, _
    startDerivative As Vector3d, _
    endDerivative As Vector3d _
)
public:
CubicSplineCurve3d(
    Point3dCollection^ points,
    Vector3d startDerivative,
    Vector3d endDerivative
)
Parameters
points(Point3dCollection)
startDerivative(Vector3d)
endDerivative(Vector3d)


CubicSplineCurve3d Constructor (points, startDerivative, endDerivative, tolerance)

CubicSplineCurve3d Constructor (points, startDerivative, endDerivative, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »CubicSplineCurve3d(Point3dCollection, Vector3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public CubicSplineCurve3d(
    Point3dCollection points,
    Vector3d startDerivative,
    Vector3d endDerivative,
    Tolerance tolerance
)
Public Sub New ( _
    points As Point3dCollection, _
    startDerivative As Vector3d, _
    endDerivative As Vector3d, _
    tolerance As Tolerance _
)
public:
CubicSplineCurve3d(
    Point3dCollection^ points,
    Vector3d startDerivative,
    Vector3d endDerivative,
    Tolerance tolerance
)
Parameters
points(Point3dCollection)
startDerivative(Vector3d)
endDerivative(Vector3d)
tolerance(Tolerance)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static CubicSplineCurve3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As CubicSplineCurve3d
public:
static CubicSplineCurve3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


FirstDerivativeAt Method (i)

FirstDerivativeAt Method (i)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »FirstDerivativeAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d FirstDerivativeAt(
    int i
)
Public Function FirstDerivativeAt ( _
    i As Integer _
) As Vector3d
public:
Vector3d FirstDerivativeAt(
    int i
)
Parameters
i(Int32)


FitPointAt Method (i)

FitPointAt Method (i)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »FitPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d FitPointAt(
    int i
)
Public Function FitPointAt ( _
    i As Integer _
) As Point3d
public:
Point3d FitPointAt(
    int i
)
Parameters
i(Int32)


NumberOfFitPoints Property

NumberOfFitPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »NumberOfFitPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfFitPoints { get; }
Public ReadOnly Property NumberOfFitPoints As Integer
    Get
public:
property int NumberOfFitPoints {
    int get ();
}


SetFirstDerivativeAt Method (i, derivative)

SetFirstDerivativeAt Method (i, derivative)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »SetFirstDerivativeAt(Int32, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFirstDerivativeAt(
    int i,
    Vector3d derivative
)
Public Sub SetFirstDerivativeAt ( _
    i As Integer, _
    derivative As Vector3d _
)
public:
void SetFirstDerivativeAt(
    int i,
    Vector3d derivative
)
Parameters
i(Int32)
derivative(Vector3d)


SetFitPointAt Method (i, point)

SetFitPointAt Method (i, point)
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »SetFitPointAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitPointAt(
    int i,
    Point3d point
)
Public Sub SetFitPointAt ( _
    i As Integer, _
    point As Point3d _
)
public:
void SetFitPointAt(
    int i,
    Point3d point
)
Parameters
i(Int32)
point(Point3d)


Curve2d Class

Curve2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCurve2d")]
public abstract class Curve2d : Entity2d
<WrapperAttribute("ZcGeCurve2d")> _
Public MustInherit Class Curve2d _
    Inherits Entity2d
[WrapperAttribute(L"ZcGeCurve2d")]
public ref class Curve2d abstract : public Entity2d
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock |
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) |
 | Explode(Interval) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |
 | GetBoundBlockOf(Interval) |
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() |
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |
 | GetOrthoBoundBlockOf(Interval) |
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |
 | GetReverseParameterCurve()()()() |
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |
 | GetSplitCurves(Double) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint |
 | HasStartPoint |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) |
 | IsClosed()()()() |
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |
 | IsPeriodic(Double%) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | OrthoBoundBlock |
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | SetInterval(Interval) |
 | StartPoint |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | CircularArc2d
 |  |  |  |  | CompositeCurve2d
 |  |  |  |  | EllipticalArc2d
 |  |  |  |  | LinearEntity2d
 |  |  |  |  | OffsetCurve2d
 |  |  |  |  | SplineEntity2d


BoundBlock Property

BoundBlock Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »BoundBlock
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock2d BoundBlock { get; }
Public ReadOnly Property BoundBlock As BoundBlock2d
    Get
public:
property BoundBlock2d^ BoundBlock {
    BoundBlock2d^ get ();
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Curve2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Curve2d
public:
static Curve2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d EndPoint { get; }
Public ReadOnly Property EndPoint As Point2d
    Get
public:
property Point2d EndPoint {
    Point2d get ();
}


EvaluatePoint Method (parameter)

EvaluatePoint Method (parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »EvaluatePoint(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d EvaluatePoint(
    double parameter
)
Public Function EvaluatePoint ( _
    parameter As Double _
) As Point2d
public:
Point2d EvaluatePoint(
    double parameter
)
Parameters
parameter(Double)


Explode Method (interval)

Explode Method (interval)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »Explode(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d[] Explode(
    Interval interval
)
Public Function Explode ( _
    interval As Interval _
) As Curve2d()
public:
array<Curve2d^>^ Explode(
    Interval^ interval
)
Parameters
interval(Interval)


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


GetArea Method (startParameter, endParameter)

GetArea Method (startParameter, endParameter)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetArea(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetArea(
    double startParameter,
    double endParameter
)
Public Function GetArea ( _
    startParameter As Double, _
    endParameter As Double _
) As Double
public:
double GetArea(
    double startParameter,
    double endParameter
)
Parameters
startParameter(Double)
endParameter(Double)


GetArea Method (startParameter, endParameter, tolerance)

GetArea Method (startParameter, endParameter, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetArea(Double, Double, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetArea(
    double startParameter,
    double endParameter,
    Tolerance tolerance
)
Public Function GetArea ( _
    startParameter As Double, _
    endParameter As Double, _
    tolerance As Tolerance _
) As Double
public:
double GetArea(
    double startParameter,
    double endParameter,
    Tolerance tolerance
)
Parameters
startParameter(Double)
endParameter(Double)
tolerance(Tolerance)


GetBoundBlockOf Method (range)

GetBoundBlockOf Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetBoundBlockOf(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock2d GetBoundBlockOf(
    Interval range
)
Public Function GetBoundBlockOf ( _
    range As Interval _
) As BoundBlock2d
public:
BoundBlock2d^ GetBoundBlockOf(
    Interval^ range
)
Parameters
range(Interval)


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


GetClosestPointTo Method (curve)

GetClosestPointTo Method (curve)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetClosestPointTo(Curve2d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d[] GetClosestPointTo(
    Curve2d curve
)
Public Function GetClosestPointTo ( _
    curve As Curve2d _
) As PointOnCurve2d()
public:
array<PointOnCurve2d^>^ GetClosestPointTo(
    Curve2d^ curve
)
Parameters
curve(Curve2d)


GetClosestPointTo Method (curve, tolerance)

GetClosestPointTo Method (curve, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetClosestPointTo(Curve2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d[] GetClosestPointTo(
    Curve2d curve,
    Tolerance tolerance
)
Public Function GetClosestPointTo ( _
    curve As Curve2d, _
    tolerance As Tolerance _
) As PointOnCurve2d()
public:
array<PointOnCurve2d^>^ GetClosestPointTo(
    Curve2d^ curve,
    Tolerance tolerance
)
Parameters
curve(Curve2d)
tolerance(Tolerance)


GetClosestPointTo Method (point)

GetClosestPointTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetClosestPointTo(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d GetClosestPointTo(
    Point2d point
)
Public Function GetClosestPointTo ( _
    point As Point2d _
) As PointOnCurve2d
public:
PointOnCurve2d^ GetClosestPointTo(
    Point2d point
)
Parameters
point(Point2d)


GetClosestPointTo Method (point, tolerance)

GetClosestPointTo Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetClosestPointTo(Point2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d GetClosestPointTo(
    Point2d point,
    Tolerance tolerance
)
Public Function GetClosestPointTo ( _
    point As Point2d, _
    tolerance As Tolerance _
) As PointOnCurve2d
public:
PointOnCurve2d^ GetClosestPointTo(
    Point2d point,
    Tolerance tolerance
)
Parameters
point(Point2d)
tolerance(Tolerance)


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


GetDistanceTo Method (curve)

GetDistanceTo Method (curve)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetDistanceTo(Curve2d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetDistanceTo(
    Curve2d curve
)
Public Function GetDistanceTo ( _
    curve As Curve2d _
) As Double
public:
double GetDistanceTo(
    Curve2d^ curve
)
Parameters
curve(Curve2d)


GetDistanceTo Method (curve, tolerance)

GetDistanceTo Method (curve, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetDistanceTo(Curve2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetDistanceTo(
    Curve2d curve,
    Tolerance tolerance
)
Public Function GetDistanceTo ( _
    curve As Curve2d, _
    tolerance As Tolerance _
) As Double
public:
double GetDistanceTo(
    Curve2d^ curve,
    Tolerance tolerance
)
Parameters
curve(Curve2d)
tolerance(Tolerance)


GetDistanceTo Method (point)

GetDistanceTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetDistanceTo(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetDistanceTo(
    Point2d point
)
Public Function GetDistanceTo ( _
    point As Point2d _
) As Double
public:
double GetDistanceTo(
    Point2d point
)
Parameters
point(Point2d)


GetDistanceTo Method (point, tolerance)

GetDistanceTo Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetDistanceTo(Point2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetDistanceTo(
    Point2d point,
    Tolerance tolerance
)
Public Function GetDistanceTo ( _
    point As Point2d, _
    tolerance As Tolerance _
) As Double
public:
double GetDistanceTo(
    Point2d point,
    Tolerance tolerance
)
Parameters
point(Point2d)
tolerance(Tolerance)


GetInterval Method

GetInterval Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetInterval()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Interval GetInterval()
Public Function GetInterval As Interval
public:
Interval^ GetInterval()


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


GetLength Method (fromParameter, toParameter)

GetLength Method (fromParameter, toParameter)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetLength(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetLength(
    double fromParameter,
    double toParameter
)
Public Function GetLength ( _
    fromParameter As Double, _
    toParameter As Double _
) As Double
public:
double GetLength(
    double fromParameter,
    double toParameter
)
Parameters
fromParameter(Double)
toParameter(Double)


GetLength Method (fromParameter, toParameter, tolerance)

GetLength Method (fromParameter, toParameter, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetLength(Double, Double, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetLength(
    double fromParameter,
    double toParameter,
    Tolerance tolerance
)
Public Function GetLength ( _
    fromParameter As Double, _
    toParameter As Double, _
    tolerance As Tolerance _
) As Double
public:
double GetLength(
    double fromParameter,
    double toParameter,
    Tolerance tolerance
)
Parameters
fromParameter(Double)
toParameter(Double)
tolerance(Tolerance)


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


GetNormalPoint Method (point)

GetNormalPoint Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetNormalPoint(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d GetNormalPoint(
    Point2d point
)
Public Function GetNormalPoint ( _
    point As Point2d _
) As PointOnCurve2d
public:
PointOnCurve2d^ GetNormalPoint(
    Point2d point
)
Parameters
point(Point2d)


GetNormalPoint Method (point, tolerance)

GetNormalPoint Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetNormalPoint(Point2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d GetNormalPoint(
    Point2d point,
    Tolerance tolerance
)
Public Function GetNormalPoint ( _
    point As Point2d, _
    tolerance As Tolerance _
) As PointOnCurve2d
public:
PointOnCurve2d^ GetNormalPoint(
    Point2d point,
    Tolerance tolerance
)
Parameters
point(Point2d)
tolerance(Tolerance)


GetOrthoBoundBlockOf Method (range)

GetOrthoBoundBlockOf Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetOrthoBoundBlockOf(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock2d GetOrthoBoundBlockOf(
    Interval range
)
Public Function GetOrthoBoundBlockOf ( _
    range As Interval _
) As BoundBlock2d
public:
BoundBlock2d^ GetOrthoBoundBlockOf(
    Interval^ range
)
Parameters
range(Interval)


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


GetParameterAtLength Method (datumParameter, length, parameterDirection)

GetParameterAtLength Method (datumParameter, length, parameterDirection)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetParameterAtLength(Double, Double, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public double GetParameterAtLength(
    double datumParameter,
    double length,
    bool parameterDirection
)
Public Function GetParameterAtLength ( _
    datumParameter As Double, _
    length As Double, _
    parameterDirection As Boolean _
) As Double
public:
double GetParameterAtLength(
    double datumParameter,
    double length,
    bool parameterDirection
)
Parameters
datumParameter(Double)
length(Double)
parameterDirection(Boolean)


GetParameterAtLength Method (datumParameter, length, parameterDirection, tolerance)

GetParameterAtLength Method (datumParameter, length, parameterDirection, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetParameterAtLength(Double, Double, Boolean, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetParameterAtLength(
    double datumParameter,
    double length,
    bool parameterDirection,
    Tolerance tolerance
)
Public Function GetParameterAtLength ( _
    datumParameter As Double, _
    length As Double, _
    parameterDirection As Boolean, _
    tolerance As Tolerance _
) As Double
public:
double GetParameterAtLength(
    double datumParameter,
    double length,
    bool parameterDirection,
    Tolerance tolerance
)
Parameters
datumParameter(Double)
length(Double)
parameterDirection(Boolean)
tolerance(Tolerance)


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


GetParameterOf Method (point)

GetParameterOf Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetParameterOf(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetParameterOf(
    Point2d point
)
Public Function GetParameterOf ( _
    point As Point2d _
) As Double
public:
double GetParameterOf(
    Point2d point
)
Parameters
point(Point2d)


GetParameterOf Method (point, tolerance)

GetParameterOf Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetParameterOf(Point2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetParameterOf(
    Point2d point,
    Tolerance tolerance
)
Public Function GetParameterOf ( _
    point As Point2d, _
    tolerance As Tolerance _
) As Double
public:
double GetParameterOf(
    Point2d point,
    Tolerance tolerance
)
Parameters
point(Point2d)
tolerance(Tolerance)


GetReverseParameterCurve Method

GetReverseParameterCurve Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetReverseParameterCurve()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d GetReverseParameterCurve()
Public Function GetReverseParameterCurve As Curve2d
public:
Curve2d^ GetReverseParameterCurve()


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


GetSamplePoints Method (fromParameter, toParameter, approxEps)

GetSamplePoints Method (fromParameter, toParameter, approxEps)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetSamplePoints(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d[] GetSamplePoints(
    double fromParameter,
    double toParameter,
    double approxEps
)
Public Function GetSamplePoints ( _
    fromParameter As Double, _
    toParameter As Double, _
    approxEps As Double _
) As PointOnCurve2d()
public:
array<PointOnCurve2d^>^ GetSamplePoints(
    double fromParameter,
    double toParameter,
    double approxEps
)
Parameters
fromParameter(Double)
toParameter(Double)
approxEps(Double)


GetSamplePoints Method (numSample)

GetSamplePoints Method (numSample)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetSamplePoints(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] GetSamplePoints(
    int numSample
)
Public Function GetSamplePoints ( _
    numSample As Integer _
) As Point2d()
public:
array<Point2d>^ GetSamplePoints(
    int numSample
)
Parameters
numSample(Int32)


GetSplitCurves Method (value)

GetSplitCurves Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetSplitCurves(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d[] GetSplitCurves(
    double value
)
Public Function GetSplitCurves ( _
    value As Double _
) As Curve2d()
public:
array<Curve2d^>^ GetSplitCurves(
    double value
)
Parameters
value(Double)


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


GetTrimmedOffset Method (distance, extensionType)

GetTrimmedOffset Method (distance, extensionType)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetTrimmedOffset(Double, OffsetCurveExtensionType)
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d[] GetTrimmedOffset(
    double distance,
    OffsetCurveExtensionType extensionType
)
Public Function GetTrimmedOffset ( _
    distance As Double, _
    extensionType As OffsetCurveExtensionType _
) As Curve2d()
public:
array<Curve2d^>^ GetTrimmedOffset(
    double distance,
    OffsetCurveExtensionType extensionType
)
Parameters
distance(Double)
extensionType(OffsetCurveExtensionType)


GetTrimmedOffset Method (distance, extensionType, tolerance)

GetTrimmedOffset Method (distance, extensionType, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d[] GetTrimmedOffset(
    double distance,
    OffsetCurveExtensionType extensionType,
    Tolerance tolerance
)
Public Function GetTrimmedOffset ( _
    distance As Double, _
    extensionType As OffsetCurveExtensionType, _
    tolerance As Tolerance _
) As Curve2d()
public:
array<Curve2d^>^ GetTrimmedOffset(
    double distance,
    OffsetCurveExtensionType extensionType,
    Tolerance tolerance
)
Parameters
distance(Double)
extensionType(OffsetCurveExtensionType)
tolerance(Tolerance)


HasEndPoint Property

HasEndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »HasEndPoint
Declaration Syntax
C# Visual Basic Visual C++
public bool HasEndPoint { get; }
Public ReadOnly Property HasEndPoint As Boolean
    Get
public:
property bool HasEndPoint {
    bool get ();
}


HasStartPoint Property

HasStartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »HasStartPoint
Declaration Syntax
C# Visual Basic Visual C++
public bool HasStartPoint { get; }
Public ReadOnly Property HasStartPoint As Boolean
    Get
public:
property bool HasStartPoint {
    bool get ();
}


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsClosed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed()
Public Function IsClosed As Boolean
public:
bool IsClosed()


IsClosed Method (tolerance)

IsClosed Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsClosed(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed(
    Tolerance tolerance
)
Public Function IsClosed ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsClosed(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


IsDegenerate Method (result)

IsDegenerate Method (result)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsDegenerate(Entity2d%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDegenerate(
    out Entity2d result
)
Public Function IsDegenerate ( _
    <OutAttribute> ByRef result As Entity2d _
) As Boolean
public:
bool IsDegenerate(
    [OutAttribute] Entity2d^% result
)
Parameters
result(Entity2d %)


IsDegenerate Method (result, tolerance)

IsDegenerate Method (result, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsDegenerate(Entity2d%, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDegenerate(
    out Entity2d result,
    Tolerance tolerance
)
Public Function IsDegenerate ( _
    <OutAttribute> ByRef result As Entity2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsDegenerate(
    [OutAttribute] Entity2d^% result,
    Tolerance tolerance
)
Parameters
result(Entity2d %)
tolerance(Tolerance)


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


IsLinear Method (line)

IsLinear Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsLinear(Line2d%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLinear(
    out Line2d line
)
Public Function IsLinear ( _
    <OutAttribute> ByRef line As Line2d _
) As Boolean
public:
bool IsLinear(
    [OutAttribute] Line2d^% line
)
Parameters
line(Line2d %)


IsLinear Method (line, tolerance)

IsLinear Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsLinear(Line2d%, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLinear(
    out Line2d line,
    Tolerance tolerance
)
Public Function IsLinear ( _
    <OutAttribute> ByRef line As Line2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsLinear(
    [OutAttribute] Line2d^% line,
    Tolerance tolerance
)
Parameters
line(Line2d %)
tolerance(Tolerance)


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


IsOn Method (parameter)

IsOn Method (parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsOn(Double)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    double parameter
)
Public Function IsOn ( _
    parameter As Double _
) As Boolean
public:
bool IsOn(
    double parameter
)
Parameters
parameter(Double)


IsOn Method (parameter, tolerance)

IsOn Method (parameter, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsOn(Double, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    double parameter,
    Tolerance tolerance
)
Public Function IsOn ( _
    parameter As Double, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsOn(
    double parameter,
    Tolerance tolerance
)
Parameters
parameter(Double)
tolerance(Tolerance)


IsOn Method (point)

IsOn Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsOn(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point2d point
)
Public Function IsOn ( _
    point As Point2d _
) As Boolean
public:
bool IsOn(
    Point2d point
)
Parameters
point(Point2d)


IsOn Method (point, value)

IsOn Method (point, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsOn(Point2d, Double%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point2d point,
    out double value
)
Public Function IsOn ( _
    point As Point2d, _
    <OutAttribute> ByRef value As Double _
) As Boolean
public:
bool IsOn(
    Point2d point,
    [OutAttribute] double% value
)
Parameters
point(Point2d)
value(Double%)


IsOn Method (point, value, tolerance)

IsOn Method (point, value, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsOn(Point2d, Double%, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point2d point,
    out double value,
    Tolerance tolerance
)
Public Function IsOn ( _
    point As Point2d, _
    <OutAttribute> ByRef value As Double, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsOn(
    Point2d point,
    [OutAttribute] double% value,
    Tolerance tolerance
)
Parameters
point(Point2d)
value(Double%)
tolerance(Tolerance)


IsOn Method (point, tolerance)

IsOn Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsOn(Point2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point2d point,
    Tolerance tolerance
)
Public Function IsOn ( _
    point As Point2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsOn(
    Point2d point,
    Tolerance tolerance
)
Parameters
point(Point2d)
tolerance(Tolerance)


IsPeriodic Method (period)

IsPeriodic Method (period)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsPeriodic(Double%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPeriodic(
    out double period
)
Public Function IsPeriodic ( _
    <OutAttribute> ByRef period As Double _
) As Boolean
public:
bool IsPeriodic(
    [OutAttribute] double% period
)
Parameters
period(Double%)


OrthoBoundBlock Property

OrthoBoundBlock Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »OrthoBoundBlock
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock2d OrthoBoundBlock { get; }
Public ReadOnly Property OrthoBoundBlock As BoundBlock2d
    Get
public:
property BoundBlock2d^ OrthoBoundBlock {
    BoundBlock2d^ get ();
}


SetInterval Method (value)

SetInterval Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »SetInterval(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public void SetInterval(
    Interval value
)
Public Sub SetInterval ( _
    value As Interval _
)
public:
void SetInterval(
    Interval^ value
)
Parameters
value(Interval)


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d StartPoint { get; }
Public ReadOnly Property StartPoint As Point2d
    Get
public:
property Point2d StartPoint {
    Point2d get ();
}


Curve2dCollection Class

Curve2dCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Curve2dCollection : DisposableWrapper,
    IList
Public NotInheritable Class Curve2dCollection _
    Inherits DisposableWrapper _
    Implements IList
public ref class Curve2dCollection sealed : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Curve2dCollection()()()() |
 | Add(Curve2d) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(Curve2d) |
 | CopyTo(array<Curve2d>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Remove(Object) |
 | IndexOf(Curve2d) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, Curve2d) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsFixedSize |
 | IsReadOnly |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Curve2d) |
 | RemoveAt(Int32) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Curve2dCollection


Curve2dCollection Constructor

Curve2dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »Curve2dCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Curve2dCollection()
Public Sub New
public:
Curve2dCollection()


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »Add(Curve2d)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Curve2d value
)
Public Function Add ( _
    value As Curve2d _
) As Integer
public:
int Add(
    Curve2d^ value
)
Parameters
value(Curve2d)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »Contains(Curve2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Curve2d value
)
Public Function Contains ( _
    value As Curve2d _
) As Boolean
public:
bool Contains(
    Curve2d^ value
)
Parameters
value(Curve2d)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »CopyTo(array<Curve2d>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Curve2d[] array,
    int index
)
Public Sub CopyTo ( _
    array As Curve2d(), _
    index As Integer _
)
public:
void CopyTo(
    array<Curve2d^>^ array,
    int index
)
Parameters
array(array< Curve2d >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (array, index)

ICollectionCopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollectionCopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


Ilist_Item Property (index)

Ilist_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property Ilist_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ Ilist_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IListAdd Method (value)

IListAdd Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IListAdd ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IListAdd(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IListContains Method (value)

IListContains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IListContains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IListContains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IListIndexOf Method (value)

IListIndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IListIndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IListIndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IListInsert Method (index, value)

IListInsert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IListInsert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IListInsert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IListRemove Method (value)

IListRemove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IListRemove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IListRemove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »IndexOf(Curve2d)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Curve2d value
)
Public Function IndexOf ( _
    value As Curve2d _
) As Integer
public:
int IndexOf(
    Curve2d^ value
)
Parameters
value(Curve2d)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »Insert(Int32, Curve2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Curve2d value
)
Public Sub Insert ( _
    index As Integer, _
    value As Curve2d _
)
public:
void Insert(
    int index,
    Curve2d^ value
)
Parameters
index(Int32)
value(Curve2d)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property ()

Item Property ()
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d this[
    int
] { get; set; }
Public Default Property Item ( _
     As Integer _
) As Curve2d
    Get
    Set
public:
property Curve2d^ default[int ] {
    Curve2d^ get (int );
    void set (int , Curve2d^ value);
}
Parameters
(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »Remove(Curve2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Curve2d value
)
Public Sub Remove ( _
    value As Curve2d _
)
public:
void Remove(
    Curve2d^ value
)
Parameters
value(Curve2d)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


Curve3d Class

Curve3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCurve3d")]
public abstract class Curve3d : Entity3d
<WrapperAttribute("ZcGeCurve3d")> _
Public MustInherit Class Curve3d _
    Inherits Entity3d
[WrapperAttribute(L"ZcGeCurve3d")]
public ref class Curve3d abstract : public Entity3d
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock |
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) |
 | Explode(Interval) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |
 | GetBoundBlockOf(Interval) |
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() |
 | GetLength(Double, Double, Double) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |
 | GetOrthoBoundBlockOf(Interval) |
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |
 | GetParameterAtLength(Double, Double, Boolean, Double) |
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |
 | GetReverseParameterCurve()()()() |
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |
 | GetSplitCurves(Double) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint |
 | HasStartPoint |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) |
 | IsClosed()()()() |
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |
 | IsPeriodic(Double%) |
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | OrthoBoundBlock |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | SetInterval(Interval) |
 | StartPoint |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | CircularArc3d
 |  |  |  |  | CompositeCurve3d
 |  |  |  |  | EllipticalArc3d
 |  |  |  |  | LinearEntity3d
 |  |  |  |  | OffsetCurve3d
 |  |  |  |  | SplineEntity3d


BoundBlock Property

BoundBlock Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »BoundBlock
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock3d BoundBlock { get; }
Public ReadOnly Property BoundBlock As BoundBlock3d
    Get
public:
property BoundBlock3d^ BoundBlock {
    BoundBlock3d^ get ();
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Curve3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Curve3d
public:
static Curve3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d EndPoint { get; }
Public ReadOnly Property EndPoint As Point3d
    Get
public:
property Point3d EndPoint {
    Point3d get ();
}


EvaluatePoint Method (value)

EvaluatePoint Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »EvaluatePoint(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d EvaluatePoint(
    double value
)
Public Function EvaluatePoint ( _
    value As Double _
) As Point3d
public:
Point3d EvaluatePoint(
    double value
)
Parameters
value(Double)


Explode Method (interval)

Explode Method (interval)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »Explode(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d[] Explode(
    Interval interval
)
Public Function Explode ( _
    interval As Interval _
) As Curve3d()
public:
array<Curve3d^>^ Explode(
    Interval^ interval
)
Parameters
interval(Interval)


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


GetArea Method (startingParameter, endingParameter)

GetArea Method (startingParameter, endingParameter)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetArea(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetArea(
    double startingParameter,
    double endingParameter
)
Public Function GetArea ( _
    startingParameter As Double, _
    endingParameter As Double _
) As Double
public:
double GetArea(
    double startingParameter,
    double endingParameter
)
Parameters
startingParameter(Double)
endingParameter(Double)


GetArea Method (startingParameter, endingParameter, tolerance)

GetArea Method (startingParameter, endingParameter, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetArea(Double, Double, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetArea(
    double startingParameter,
    double endingParameter,
    Tolerance tolerance
)
Public Function GetArea ( _
    startingParameter As Double, _
    endingParameter As Double, _
    tolerance As Tolerance _
) As Double
public:
double GetArea(
    double startingParameter,
    double endingParameter,
    Tolerance tolerance
)
Parameters
startingParameter(Double)
endingParameter(Double)
tolerance(Tolerance)


GetBoundBlockOf Method (range)

GetBoundBlockOf Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetBoundBlockOf(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock3d GetBoundBlockOf(
    Interval range
)
Public Function GetBoundBlockOf ( _
    range As Interval _
) As BoundBlock3d
public:
BoundBlock3d^ GetBoundBlockOf(
    Interval^ range
)
Parameters
range(Interval)


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


GetClosestPointTo Method (curve3d)

GetClosestPointTo Method (curve3d)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetClosestPointTo(Curve3d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d[] GetClosestPointTo(
    Curve3d curve3d
)
Public Function GetClosestPointTo ( _
    curve3d As Curve3d _
) As PointOnCurve3d()
public:
array<PointOnCurve3d^>^ GetClosestPointTo(
    Curve3d^ curve3d
)
Parameters
curve3d(Curve3d)


GetClosestPointTo Method (curve3d, tolerance)

GetClosestPointTo Method (curve3d, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetClosestPointTo(Curve3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d[] GetClosestPointTo(
    Curve3d curve3d,
    Tolerance tolerance
)
Public Function GetClosestPointTo ( _
    curve3d As Curve3d, _
    tolerance As Tolerance _
) As PointOnCurve3d()
public:
array<PointOnCurve3d^>^ GetClosestPointTo(
    Curve3d^ curve3d,
    Tolerance tolerance
)
Parameters
curve3d(Curve3d)
tolerance(Tolerance)


GetClosestPointTo Method (point)

GetClosestPointTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetClosestPointTo(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d GetClosestPointTo(
    Point3d point
)
Public Function GetClosestPointTo ( _
    point As Point3d _
) As PointOnCurve3d
public:
PointOnCurve3d^ GetClosestPointTo(
    Point3d point
)
Parameters
point(Point3d)


GetClosestPointTo Method (point, tolerance)

GetClosestPointTo Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetClosestPointTo(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d GetClosestPointTo(
    Point3d point,
    Tolerance tolerance
)
Public Function GetClosestPointTo ( _
    point As Point3d, _
    tolerance As Tolerance _
) As PointOnCurve3d
public:
PointOnCurve3d^ GetClosestPointTo(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


GetDistanceTo Method (curve)

GetDistanceTo Method (curve)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetDistanceTo(Curve3d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetDistanceTo(
    Curve3d curve
)
Public Function GetDistanceTo ( _
    curve As Curve3d _
) As Double
public:
double GetDistanceTo(
    Curve3d^ curve
)
Parameters
curve(Curve3d)


GetDistanceTo Method (curve, tolerance)

GetDistanceTo Method (curve, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetDistanceTo(Curve3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetDistanceTo(
    Curve3d curve,
    Tolerance tolerance
)
Public Function GetDistanceTo ( _
    curve As Curve3d, _
    tolerance As Tolerance _
) As Double
public:
double GetDistanceTo(
    Curve3d^ curve,
    Tolerance tolerance
)
Parameters
curve(Curve3d)
tolerance(Tolerance)


GetDistanceTo Method (point)

GetDistanceTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetDistanceTo(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetDistanceTo(
    Point3d point
)
Public Function GetDistanceTo ( _
    point As Point3d _
) As Double
public:
double GetDistanceTo(
    Point3d point
)
Parameters
point(Point3d)


GetDistanceTo Method (point, tolerance)

GetDistanceTo Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetDistanceTo(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetDistanceTo(
    Point3d point,
    Tolerance tolerance
)
Public Function GetDistanceTo ( _
    point As Point3d, _
    tolerance As Tolerance _
) As Double
public:
double GetDistanceTo(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


GetInterval Method

GetInterval Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetInterval()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Interval GetInterval()
Public Function GetInterval As Interval
public:
Interval^ GetInterval()


GetLength Method (fromParameter, toParameter, tolerance)

GetLength Method (fromParameter, toParameter, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetLength(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetLength(
    double fromParameter,
    double toParameter,
    double tolerance
)
Public Function GetLength ( _
    fromParameter As Double, _
    toParameter As Double, _
    tolerance As Double _
) As Double
public:
double GetLength(
    double fromParameter,
    double toParameter,
    double tolerance
)
Parameters
fromParameter(Double)
toParameter(Double)
tolerance(Double)


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


GetNormalPoint Method (point)

GetNormalPoint Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetNormalPoint(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d GetNormalPoint(
    Point3d point
)
Public Function GetNormalPoint ( _
    point As Point3d _
) As PointOnCurve3d
public:
PointOnCurve3d^ GetNormalPoint(
    Point3d point
)
Parameters
point(Point3d)


GetNormalPoint Method (point, tolerance)

GetNormalPoint Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetNormalPoint(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d GetNormalPoint(
    Point3d point,
    Tolerance tolerance
)
Public Function GetNormalPoint ( _
    point As Point3d, _
    tolerance As Tolerance _
) As PointOnCurve3d
public:
PointOnCurve3d^ GetNormalPoint(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


GetOrthoBoundBlockOf Method (range)

GetOrthoBoundBlockOf Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetOrthoBoundBlockOf(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock3d GetOrthoBoundBlockOf(
    Interval range
)
Public Function GetOrthoBoundBlockOf ( _
    range As Interval _
) As BoundBlock3d
public:
BoundBlock3d^ GetOrthoBoundBlockOf(
    Interval^ range
)
Parameters
range(Interval)


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


GetOrthoProjectEntity Method (projectionPlane)

GetOrthoProjectEntity Method (projectionPlane)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetOrthoProjectEntity(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public Entity3d GetOrthoProjectEntity(
    Plane projectionPlane
)
Public Function GetOrthoProjectEntity ( _
    projectionPlane As Plane _
) As Entity3d
public:
Entity3d^ GetOrthoProjectEntity(
    Plane^ projectionPlane
)
Parameters
projectionPlane(Plane)


GetOrthoProjectEntity Method (projectionPlane, tolerance)

GetOrthoProjectEntity Method (projectionPlane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetOrthoProjectEntity(Plane, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Entity3d GetOrthoProjectEntity(
    Plane projectionPlane,
    Tolerance tolerance
)
Public Function GetOrthoProjectEntity ( _
    projectionPlane As Plane, _
    tolerance As Tolerance _
) As Entity3d
public:
Entity3d^ GetOrthoProjectEntity(
    Plane^ projectionPlane,
    Tolerance tolerance
)
Parameters
projectionPlane(Plane)
tolerance(Tolerance)


GetParameterAtLength Method (datumParameter, length, direction, tolerance)

GetParameterAtLength Method (datumParameter, length, direction, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetParameterAtLength(Double, Double, Boolean, Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetParameterAtLength(
    double datumParameter,
    double length,
    bool direction,
    double tolerance
)
Public Function GetParameterAtLength ( _
    datumParameter As Double, _
    length As Double, _
    direction As Boolean, _
    tolerance As Double _
) As Double
public:
double GetParameterAtLength(
    double datumParameter,
    double length,
    bool direction,
    double tolerance
)
Parameters
datumParameter(Double)
length(Double)
direction(Boolean)
tolerance(Double)


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


GetParameterOf Method (point)

GetParameterOf Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetParameterOf(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetParameterOf(
    Point3d point
)
Public Function GetParameterOf ( _
    point As Point3d _
) As Double
public:
double GetParameterOf(
    Point3d point
)
Parameters
point(Point3d)


GetParameterOf Method (point, tolerance)

GetParameterOf Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetParameterOf(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetParameterOf(
    Point3d point,
    Tolerance tolerance
)
Public Function GetParameterOf ( _
    point As Point3d, _
    tolerance As Tolerance _
) As Double
public:
double GetParameterOf(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


GetProjectedClosestPointTo Method (curve3d, projectDirection)

GetProjectedClosestPointTo Method (curve3d, projectDirection)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetProjectedClosestPointTo(Curve3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d[] GetProjectedClosestPointTo(
    Curve3d curve3d,
    Vector3d projectDirection
)
Public Function GetProjectedClosestPointTo ( _
    curve3d As Curve3d, _
    projectDirection As Vector3d _
) As PointOnCurve3d()
public:
array<PointOnCurve3d^>^ GetProjectedClosestPointTo(
    Curve3d^ curve3d,
    Vector3d projectDirection
)
Parameters
curve3d(Curve3d)
projectDirection(Vector3d)


GetProjectedClosestPointTo Method (curve3d, projectDirection, tolerance)

GetProjectedClosestPointTo Method (curve3d, projectDirection, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d[] GetProjectedClosestPointTo(
    Curve3d curve3d,
    Vector3d projectDirection,
    Tolerance tolerance
)
Public Function GetProjectedClosestPointTo ( _
    curve3d As Curve3d, _
    projectDirection As Vector3d, _
    tolerance As Tolerance _
) As PointOnCurve3d()
public:
array<PointOnCurve3d^>^ GetProjectedClosestPointTo(
    Curve3d^ curve3d,
    Vector3d projectDirection,
    Tolerance tolerance
)
Parameters
curve3d(Curve3d)
projectDirection(Vector3d)
tolerance(Tolerance)


GetProjectedClosestPointTo Method (point, projectDirection)

GetProjectedClosestPointTo Method (point, projectDirection)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetProjectedClosestPointTo(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d GetProjectedClosestPointTo(
    Point3d point,
    Vector3d projectDirection
)
Public Function GetProjectedClosestPointTo ( _
    point As Point3d, _
    projectDirection As Vector3d _
) As PointOnCurve3d
public:
PointOnCurve3d^ GetProjectedClosestPointTo(
    Point3d point,
    Vector3d projectDirection
)
Parameters
point(Point3d)
projectDirection(Vector3d)


GetProjectedClosestPointTo Method (point, projectDirection, tolerance)

GetProjectedClosestPointTo Method (point, projectDirection, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d GetProjectedClosestPointTo(
    Point3d point,
    Vector3d projectDirection,
    Tolerance tolerance
)
Public Function GetProjectedClosestPointTo ( _
    point As Point3d, _
    projectDirection As Vector3d, _
    tolerance As Tolerance _
) As PointOnCurve3d
public:
PointOnCurve3d^ GetProjectedClosestPointTo(
    Point3d point,
    Vector3d projectDirection,
    Tolerance tolerance
)
Parameters
point(Point3d)
projectDirection(Vector3d)
tolerance(Tolerance)


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


GetProjectedEntity Method (projectionPlane, projectDirection)

GetProjectedEntity Method (projectionPlane, projectDirection)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetProjectedEntity(Plane, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Entity3d GetProjectedEntity(
    Plane projectionPlane,
    Vector3d projectDirection
)
Public Function GetProjectedEntity ( _
    projectionPlane As Plane, _
    projectDirection As Vector3d _
) As Entity3d
public:
Entity3d^ GetProjectedEntity(
    Plane^ projectionPlane,
    Vector3d projectDirection
)
Parameters
projectionPlane(Plane)
projectDirection(Vector3d)


GetProjectedEntity Method (projectionPlane, projectDirection, tolerance)

GetProjectedEntity Method (projectionPlane, projectDirection, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetProjectedEntity(Plane, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Entity3d GetProjectedEntity(
    Plane projectionPlane,
    Vector3d projectDirection,
    Tolerance tolerance
)
Public Function GetProjectedEntity ( _
    projectionPlane As Plane, _
    projectDirection As Vector3d, _
    tolerance As Tolerance _
) As Entity3d
public:
Entity3d^ GetProjectedEntity(
    Plane^ projectionPlane,
    Vector3d projectDirection,
    Tolerance tolerance
)
Parameters
projectionPlane(Plane)
projectDirection(Vector3d)
tolerance(Tolerance)


GetReverseParameterCurve Method

GetReverseParameterCurve Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetReverseParameterCurve()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d GetReverseParameterCurve()
Public Function GetReverseParameterCurve As Curve3d
public:
Curve3d^ GetReverseParameterCurve()


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


GetSamplePoints Method (fromParameter, toParameter, chordHeight)

GetSamplePoints Method (fromParameter, toParameter, chordHeight)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetSamplePoints(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d[] GetSamplePoints(
    double fromParameter,
    double toParameter,
    double chordHeight
)
Public Function GetSamplePoints ( _
    fromParameter As Double, _
    toParameter As Double, _
    chordHeight As Double _
) As PointOnCurve3d()
public:
array<PointOnCurve3d^>^ GetSamplePoints(
    double fromParameter,
    double toParameter,
    double chordHeight
)
Parameters
fromParameter(Double)
toParameter(Double)
chordHeight(Double)


GetSamplePoints Method (numSample)

GetSamplePoints Method (numSample)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetSamplePoints(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d[] GetSamplePoints(
    int numSample
)
Public Function GetSamplePoints ( _
    numSample As Integer _
) As PointOnCurve3d()
public:
array<PointOnCurve3d^>^ GetSamplePoints(
    int numSample
)
Parameters
numSample(Int32)


GetSplitCurves Method (value)

GetSplitCurves Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetSplitCurves(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d[] GetSplitCurves(
    double value
)
Public Function GetSplitCurves ( _
    value As Double _
) As Curve3d()
public:
array<Curve3d^>^ GetSplitCurves(
    double value
)
Parameters
value(Double)


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


GetTrimmedOffset Method (distance, planeNormal, extensionType)

GetTrimmedOffset Method (distance, planeNormal, extensionType)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType)
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d[] GetTrimmedOffset(
    double distance,
    Vector3d planeNormal,
    OffsetCurveExtensionType extensionType
)
Public Function GetTrimmedOffset ( _
    distance As Double, _
    planeNormal As Vector3d, _
    extensionType As OffsetCurveExtensionType _
) As Curve3d()
public:
array<Curve3d^>^ GetTrimmedOffset(
    double distance,
    Vector3d planeNormal,
    OffsetCurveExtensionType extensionType
)
Parameters
distance(Double)
planeNormal(Vector3d)
extensionType(OffsetCurveExtensionType)


GetTrimmedOffset Method (distance, planeNormal, extensionType, tolerance)

GetTrimmedOffset Method (distance, planeNormal, extensionType, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d[] GetTrimmedOffset(
    double distance,
    Vector3d planeNormal,
    OffsetCurveExtensionType extensionType,
    Tolerance tolerance
)
Public Function GetTrimmedOffset ( _
    distance As Double, _
    planeNormal As Vector3d, _
    extensionType As OffsetCurveExtensionType, _
    tolerance As Tolerance _
) As Curve3d()
public:
array<Curve3d^>^ GetTrimmedOffset(
    double distance,
    Vector3d planeNormal,
    OffsetCurveExtensionType extensionType,
    Tolerance tolerance
)
Parameters
distance(Double)
planeNormal(Vector3d)
extensionType(OffsetCurveExtensionType)
tolerance(Tolerance)


HasEndPoint Property

HasEndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »HasEndPoint
Declaration Syntax
C# Visual Basic Visual C++
public bool HasEndPoint { get; }
Public ReadOnly Property HasEndPoint As Boolean
    Get
public:
property bool HasEndPoint {
    bool get ();
}


HasStartPoint Property

HasStartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »HasStartPoint
Declaration Syntax
C# Visual Basic Visual C++
public bool HasStartPoint { get; }
Public ReadOnly Property HasStartPoint As Boolean
    Get
public:
property bool HasStartPoint {
    bool get ();
}


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsClosed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed()
Public Function IsClosed As Boolean
public:
bool IsClosed()


IsClosed Method (tolerance)

IsClosed Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsClosed(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed(
    Tolerance tolerance
)
Public Function IsClosed ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsClosed(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


IsCoplanarWith Method (curve3d, plane)

IsCoplanarWith Method (curve3d, plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsCoplanarWith(Curve3d, Plane%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCoplanarWith(
    Curve3d curve3d,
    out Plane plane
)
Public Function IsCoplanarWith ( _
    curve3d As Curve3d, _
    <OutAttribute> ByRef plane As Plane _
) As Boolean
public:
bool IsCoplanarWith(
    Curve3d^ curve3d,
    [OutAttribute] Plane^% plane
)
Parameters
curve3d(Curve3d)
plane(Plane %)


IsCoplanarWith Method (curve3d, plane, tolerance)

IsCoplanarWith Method (curve3d, plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsCoplanarWith(Curve3d, Plane%, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCoplanarWith(
    Curve3d curve3d,
    out Plane plane,
    Tolerance tolerance
)
Public Function IsCoplanarWith ( _
    curve3d As Curve3d, _
    <OutAttribute> ByRef plane As Plane, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsCoplanarWith(
    Curve3d^ curve3d,
    [OutAttribute] Plane^% plane,
    Tolerance tolerance
)
Parameters
curve3d(Curve3d)
plane(Plane %)
tolerance(Tolerance)


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


IsDegenerate Method (result)

IsDegenerate Method (result)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsDegenerate(Entity3d%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDegenerate(
    out Entity3d result
)
Public Function IsDegenerate ( _
    <OutAttribute> ByRef result As Entity3d _
) As Boolean
public:
bool IsDegenerate(
    [OutAttribute] Entity3d^% result
)
Parameters
result(Entity3d %)


IsDegenerate Method (result, tolerance)

IsDegenerate Method (result, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsDegenerate(Entity3d%, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDegenerate(
    out Entity3d result,
    Tolerance tolerance
)
Public Function IsDegenerate ( _
    <OutAttribute> ByRef result As Entity3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsDegenerate(
    [OutAttribute] Entity3d^% result,
    Tolerance tolerance
)
Parameters
result(Entity3d %)
tolerance(Tolerance)


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


IsLinear Method (line)

IsLinear Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsLinear(Line3d%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLinear(
    out Line3d line
)
Public Function IsLinear ( _
    <OutAttribute> ByRef line As Line3d _
) As Boolean
public:
bool IsLinear(
    [OutAttribute] Line3d^% line
)
Parameters
line(Line3d %)


IsLinear Method (line, tolerance)

IsLinear Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsLinear(Line3d%, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLinear(
    out Line3d line,
    Tolerance tolerance
)
Public Function IsLinear ( _
    <OutAttribute> ByRef line As Line3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsLinear(
    [OutAttribute] Line3d^% line,
    Tolerance tolerance
)
Parameters
line(Line3d %)
tolerance(Tolerance)


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


IsOn Method (value)

IsOn Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsOn(Double)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    double value
)
Public Function IsOn ( _
    value As Double _
) As Boolean
public:
bool IsOn(
    double value
)
Parameters
value(Double)


IsOn Method (value, tolerance)

IsOn Method (value, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsOn(Double, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    double value,
    Tolerance tolerance
)
Public Function IsOn ( _
    value As Double, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsOn(
    double value,
    Tolerance tolerance
)
Parameters
value(Double)
tolerance(Tolerance)


IsOn Method (point)

IsOn Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsOn(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point3d point
)
Public Function IsOn ( _
    point As Point3d _
) As Boolean
public:
bool IsOn(
    Point3d point
)
Parameters
point(Point3d)


IsOn Method (point, value)

IsOn Method (point, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsOn(Point3d, Double%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point3d point,
    out double value
)
Public Function IsOn ( _
    point As Point3d, _
    <OutAttribute> ByRef value As Double _
) As Boolean
public:
bool IsOn(
    Point3d point,
    [OutAttribute] double% value
)
Parameters
point(Point3d)
value(Double%)


IsOn Method (point, value, tolerance)

IsOn Method (point, value, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsOn(Point3d, Double%, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point3d point,
    out double value,
    Tolerance tolerance
)
Public Function IsOn ( _
    point As Point3d, _
    <OutAttribute> ByRef value As Double, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsOn(
    Point3d point,
    [OutAttribute] double% value,
    Tolerance tolerance
)
Parameters
point(Point3d)
value(Double%)
tolerance(Tolerance)


IsOn Method (point, tolerance)

IsOn Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsOn(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point3d point,
    Tolerance tolerance
)
Public Function IsOn ( _
    point As Point3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsOn(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


IsPeriodic Method (period)

IsPeriodic Method (period)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsPeriodic(Double%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPeriodic(
    out double period
)
Public Function IsPeriodic ( _
    <OutAttribute> ByRef period As Double _
) As Boolean
public:
bool IsPeriodic(
    [OutAttribute] double% period
)
Parameters
period(Double%)


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


IsPlanar Method (plane)

IsPlanar Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsPlanar(Plane%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPlanar(
    out Plane plane
)
Public Function IsPlanar ( _
    <OutAttribute> ByRef plane As Plane _
) As Boolean
public:
bool IsPlanar(
    [OutAttribute] Plane^% plane
)
Parameters
plane(Plane %)


IsPlanar Method (plane, tolerance)

IsPlanar Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsPlanar(Plane%, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPlanar(
    out Plane plane,
    Tolerance tolerance
)
Public Function IsPlanar ( _
    <OutAttribute> ByRef plane As Plane, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsPlanar(
    [OutAttribute] Plane^% plane,
    Tolerance tolerance
)
Parameters
plane(Plane %)
tolerance(Tolerance)


OrthoBoundBlock Property

OrthoBoundBlock Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »OrthoBoundBlock
Declaration Syntax
C# Visual Basic Visual C++
public BoundBlock3d OrthoBoundBlock { get; }
Public ReadOnly Property OrthoBoundBlock As BoundBlock3d
    Get
public:
property BoundBlock3d^ OrthoBoundBlock {
    BoundBlock3d^ get ();
}


SetInterval Method (value)

SetInterval Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »SetInterval(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public void SetInterval(
    Interval value
)
Public Sub SetInterval ( _
    value As Interval _
)
public:
void SetInterval(
    Interval^ value
)
Parameters
value(Interval)


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d StartPoint { get; }
Public ReadOnly Property StartPoint As Point3d
    Get
public:
property Point3d StartPoint {
    Point3d get ();
}


Curve3dCollection Class

Curve3dCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Curve3dCollection : DisposableWrapper,
    IList
Public NotInheritable Class Curve3dCollection _
    Inherits DisposableWrapper _
    Implements IList
public ref class Curve3dCollection sealed : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Curve3dCollection()()()() |
 | Add(Curve3d) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(Curve3d) |
 | CopyTo(array<Curve3d>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Remove(Object) |
 | IndexOf(Curve3d) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, Curve3d) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsFixedSize |
 | IsReadOnly |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Curve3d) |
 | RemoveAt(Int32) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Curve3dCollection


Curve3dCollection Constructor

Curve3dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »Curve3dCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Curve3dCollection()
Public Sub New
public:
Curve3dCollection()


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »Add(Curve3d)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Curve3d value
)
Public Function Add ( _
    value As Curve3d _
) As Integer
public:
int Add(
    Curve3d^ value
)
Parameters
value(Curve3d)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »Contains(Curve3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Curve3d value
)
Public Function Contains ( _
    value As Curve3d _
) As Boolean
public:
bool Contains(
    Curve3d^ value
)
Parameters
value(Curve3d)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »CopyTo(array<Curve3d>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Curve3d[] array,
    int index
)
Public Sub CopyTo ( _
    array As Curve3d(), _
    index As Integer _
)
public:
void CopyTo(
    array<Curve3d^>^ array,
    int index
)
Parameters
array(array< Curve3d >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (array, index)

ICollectionCopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollectionCopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


Ilist_Item Property (index)

Ilist_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property Ilist_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ Ilist_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IListAdd Method (value)

IListAdd Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IListAdd ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IListAdd(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IListContains Method (value)

IListContains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IListContains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IListContains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IListIndexOf Method (value)

IListIndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IListIndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IListIndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IListInsert Method (index, value)

IListInsert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IListInsert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IListInsert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IListRemove Method (value)

IListRemove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IListRemove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IListRemove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »IndexOf(Curve3d)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Curve3d value
)
Public Function IndexOf ( _
    value As Curve3d _
) As Integer
public:
int IndexOf(
    Curve3d^ value
)
Parameters
value(Curve3d)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »Insert(Int32, Curve3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Curve3d value
)
Public Sub Insert ( _
    index As Integer, _
    value As Curve3d _
)
public:
void Insert(
    int index,
    Curve3d^ value
)
Parameters
index(Int32)
value(Curve3d)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property ()

Item Property ()
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d this[
    int
] { get; set; }
Public Default Property Item ( _
     As Integer _
) As Curve3d
    Get
    Set
public:
property Curve3d^ default[int ] {
    Curve3d^ get (int );
    void set (int , Curve3d^ value);
}
Parameters
(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »Remove(Curve3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Curve3d value
)
Public Sub Remove ( _
    value As Curve3d _
)
public:
void Remove(
    Curve3d^ value
)
Parameters
value(Curve3d)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


CurveBoundary Class

CurveBoundary Class
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCurveBoundary")]
public sealed class CurveBoundary : DisposableWrapper,
    ICloneable
<WrapperAttribute("ZcGeCurveBoundary")> _
Public NotInheritable Class CurveBoundary _
    Inherits DisposableWrapper _
    Implements ICloneable
[WrapperAttribute(L"ZcGeCurveBoundary")]
public ref class CurveBoundary sealed : public DisposableWrapper,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CurveBoundary(Int32, array<Curve3d>[]()[][], array<Curve2d>[]()[][], Boolean, Boolean) |
 | CurveBoundary()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() |
 | Contour |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DegenerateCurve |
 | DegeneratePosition |
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDegenerate |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsOwnerOfCurves |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumElements |
 | Set(Int32, array<Entity3d>[]()[][], array<Curve2d>[]()[][], Boolean, Boolean) |
 | SetToOwnCurves()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | CurveBoundary


CurveBoundary Constructor

CurveBoundary Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »CurveBoundary()()()()
Members
Icon | Member | Description
 | CurveBoundary(Int32, array<Curve3d>[]()[][], array<Curve2d>[]()[][], Boolean, Boolean) |
 | CurveBoundary()()()() |


CurveBoundary Constructor

CurveBoundary Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »CurveBoundary()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CurveBoundary()
Public Sub New
public:
CurveBoundary()


CurveBoundary Constructor (numberOfCurves, curve3d, curve2d, orientation3d, orientation2d)

CurveBoundary Constructor (numberOfCurves, curve3d, curve2d, orientation3d, orientation2d)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »CurveBoundary(Int32, array<Curve3d>[]()[][], array<Curve2d>[]()[][], Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public CurveBoundary(
    int numberOfCurves,
    Curve3d[] curve3d,
    Curve2d[] curve2d,
    bool orientation3d,
    bool orientation2d
)
Public Sub New ( _
    numberOfCurves As Integer, _
    curve3d As Curve3d(), _
    curve2d As Curve2d(), _
    orientation3d As Boolean, _
    orientation2d As Boolean _
)
public:
CurveBoundary(
    int numberOfCurves,
    array<Curve3d^>^ curve3d,
    array<Curve2d^>^ curve2d,
    bool orientation3d,
    bool orientation2d
)
Parameters
numberOfCurves(Int32)
curve3d(array< Curve3d >[]()[][])
curve2d(array< Curve2d >[]()[][])
orientation3d(Boolean)
orientation2d(Boolean)


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed


Contour Property

Contour Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »Contour
Declaration Syntax
C# Visual Basic Visual C++
public CurveBoundaryData Contour { get; set; }
Public Property Contour As CurveBoundaryData
    Get
    Set
public:
property CurveBoundaryData Contour {
    CurveBoundaryData get ();
    void set (CurveBoundaryData value);
}


DegenerateCurve Property

DegenerateCurve Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »DegenerateCurve
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d DegenerateCurve { get; }
Public ReadOnly Property DegenerateCurve As Curve2d
    Get
public:
property Curve2d^ DegenerateCurve {
    Curve2d^ get ();
}


DegeneratePosition Property

DegeneratePosition Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »DegeneratePosition
Declaration Syntax
C# Visual Basic Visual C++
public Position3d DegeneratePosition { get; }
Public ReadOnly Property DegeneratePosition As Position3d
    Get
public:
property Position3d^ DegeneratePosition {
    Position3d^ get ();
}


IsDegenerate Property

IsDegenerate Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »IsDegenerate
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDegenerate { get; }
Public ReadOnly Property IsDegenerate As Boolean
    Get
public:
property bool IsDegenerate {
    bool get ();
}


IsOwnerOfCurves Property

IsOwnerOfCurves Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »IsOwnerOfCurves
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOwnerOfCurves { get; }
Public ReadOnly Property IsOwnerOfCurves As Boolean
    Get
public:
property bool IsOwnerOfCurves {
    bool get ();
}


NumElements Property

NumElements Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »NumElements
Declaration Syntax
C# Visual Basic Visual C++
public int NumElements { get; }
Public ReadOnly Property NumElements As Integer
    Get
public:
property int NumElements {
    int get ();
}


Set Method (numElements, curve3ds, curve2ds, orientation3d, orientation2d)

Set Method (numElements, curve3ds, curve2ds, orientation3d, orientation2d)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »Set(Int32, array<Entity3d>[]()[][], array<Curve2d>[]()[][], Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    int numElements,
    Entity3d[] curve3ds,
    Curve2d[] curve2ds,
    bool orientation3d,
    bool orientation2d
)
Public Sub Set ( _
    numElements As Integer, _
    curve3ds As Entity3d(), _
    curve2ds As Curve2d(), _
    orientation3d As Boolean, _
    orientation2d As Boolean _
)
public:
void Set(
    int numElements,
    array<Entity3d^>^ curve3ds,
    array<Curve2d^>^ curve2ds,
    bool orientation3d,
    bool orientation2d
)
Parameters
numElements(Int32)
curve3ds(array< Entity3d >[]()[][])
curve2ds(array< Curve2d >[]()[][])
orientation3d(Boolean)
orientation2d(Boolean)


SetToOwnCurves Method

SetToOwnCurves Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »SetToOwnCurves()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetToOwnCurves()
Public Sub SetToOwnCurves
public:
void SetToOwnCurves()


CurveBoundaryData Structure

CurveBoundaryData Structure
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundaryData
Declaration Syntax
C# Visual Basic Visual C++
public struct CurveBoundaryData
Public Structure CurveBoundaryData
public value class CurveBoundaryData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equality(CurveBoundaryData, CurveBoundaryData) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetCurve2ds()()()() |
 | GetCurve3ds()()()() |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(CurveBoundaryData, CurveBoundaryData) |
 | IsEqualTo(CurveBoundaryData) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Orientation2d |
 | Orientation3d |
 | ToString()()()() | (Inherited from ValueType.)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundaryData »Equality(CurveBoundaryData, CurveBoundaryData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    CurveBoundaryData a,
    CurveBoundaryData b
)
Public Shared Operator = ( _
    a As CurveBoundaryData, _
    b As CurveBoundaryData _
) As Boolean
public:
static bool operator ==(
    CurveBoundaryData a,
    CurveBoundaryData b
)
Parameters
a(CurveBoundaryData)
b(CurveBoundaryData)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundaryData »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetCurve2ds Method

GetCurve2ds Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundaryData »GetCurve2ds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d[] GetCurve2ds()
Public Function GetCurve2ds As Curve2d()
public:
array<Curve2d^>^ GetCurve2ds()


GetCurve3ds Method

GetCurve3ds Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundaryData »GetCurve3ds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Entity3d[] GetCurve3ds()
Public Function GetCurve3ds As Entity3d()
public:
array<Entity3d^>^ GetCurve3ds()


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundaryData »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundaryData »Inequality(CurveBoundaryData, CurveBoundaryData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    CurveBoundaryData a,
    CurveBoundaryData b
)
Public Shared Operator <> ( _
    a As CurveBoundaryData, _
    b As CurveBoundaryData _
) As Boolean
public:
static bool operator !=(
    CurveBoundaryData a,
    CurveBoundaryData b
)
Parameters
a(CurveBoundaryData)
b(CurveBoundaryData)


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundaryData »IsEqualTo(CurveBoundaryData)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    CurveBoundaryData a
)
Public Function IsEqualTo ( _
    a As CurveBoundaryData _
) As Boolean
public:
bool IsEqualTo(
    CurveBoundaryData a
)
Parameters
a(CurveBoundaryData)


Orientation2d Property

Orientation2d Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundaryData »Orientation2d
Declaration Syntax
C# Visual Basic Visual C++
public bool Orientation2d { get; }
Public ReadOnly Property Orientation2d As Boolean
    Get
public:
property bool Orientation2d {
    bool get ();
}


Orientation3d Property

Orientation3d Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundaryData »Orientation3d
Declaration Syntax
C# Visual Basic Visual C++
public bool Orientation3d { get; }
Public ReadOnly Property Orientation3d As Boolean
    Get
public:
property bool Orientation3d {
    bool get ();
}


CurveCurveIntersector2d Class

CurveCurveIntersector2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCurveCurveInt2d")]
public sealed class CurveCurveIntersector2d : Entity2d
<WrapperAttribute("ZcGeCurveCurveInt2d")> _
Public NotInheritable Class CurveCurveIntersector2d _
    Inherits Entity2d
[WrapperAttribute(L"ZcGeCurveCurveInt2d")]
public ref class CurveCurveIntersector2d sealed : public Entity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CurveCurveIntersector2d(Curve2d, Curve2d, Interval, Interval, Tolerance) |
 | CurveCurveIntersector2d(Curve2d, Curve2d, Interval, Interval) |
 | CurveCurveIntersector2d(Curve2d, Curve2d, Tolerance) |
 | CurveCurveIntersector2d(IntPtr, Boolean) |
 | CurveCurveIntersector2d(Curve2d, Curve2d) |
 | CurveCurveIntersector2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | ChangeCurveOrder()()()() |
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Curve1 |
 | Curve2 |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetIntersectionParameters(Int32) |
 | GetIntersectionPoint(Int32) |
 | GetIntersectionPointTolerance(Int32) |
 | GetIntersectionRanges()()()() |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetOverlapRanges(Int32) |
 | GetPointOnCurve1(Int32) |
 | GetPointOnCurve2(Int32) |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Entity2d.)
 | IsOn(Point2d) | (Inherited from Entity2d.)
 | IsTangential(Int32) |
 | IsTransversal(Int32) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | NumberOfIntersectionPoints |
 | OrderWithRegardsTo1()()()() |
 | OrderWithRegardsTo2()()()() |
 | OverlapCount |
 | OverlapDirection |
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | Set(Curve2d, Curve2d, Interval, Interval, Tolerance) |
 | Set(Curve2d, Curve2d, Interval, Interval) |
 | Set(Curve2d, Curve2d, Tolerance) |
 | Set(Curve2d, Curve2d) |
 | Tolerance |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | CurveCurveIntersector2d


CurveCurveIntersector2d Constructor

CurveCurveIntersector2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »CurveCurveIntersector2d()()()()
Members
Icon | Member | Description
 | CurveCurveIntersector2d(Curve2d, Curve2d, Interval, Interval, Tolerance) |
 | CurveCurveIntersector2d(Curve2d, Curve2d, Interval, Interval) |
 | CurveCurveIntersector2d(Curve2d, Curve2d, Tolerance) |
 | CurveCurveIntersector2d(IntPtr, Boolean) |
 | CurveCurveIntersector2d(Curve2d, Curve2d) |
 | CurveCurveIntersector2d()()()() |


CurveCurveIntersector2d Constructor

CurveCurveIntersector2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »CurveCurveIntersector2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector2d()
Public Sub New
public:
CurveCurveIntersector2d()


CurveCurveIntersector2d Constructor (unmanagedPointer, autoDelete)

CurveCurveIntersector2d Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »CurveCurveIntersector2d(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector2d(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
public:
CurveCurveIntersector2d(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


CurveCurveIntersector2d Constructor (curve1, curve2)

CurveCurveIntersector2d Constructor (curve1, curve2)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »CurveCurveIntersector2d(Curve2d, Curve2d)
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector2d(
    Curve2d curve1,
    Curve2d curve2
)
Public Sub New ( _
    curve1 As Curve2d, _
    curve2 As Curve2d _
)
public:
CurveCurveIntersector2d(
    Curve2d^ curve1,
    Curve2d^ curve2
)
Parameters
curve1(Curve2d)
curve2(Curve2d)


CurveCurveIntersector2d Constructor (curve1, curve2, range1, range2)

CurveCurveIntersector2d Constructor (curve1, curve2, range1, range2)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »CurveCurveIntersector2d(Curve2d, Curve2d, Interval, Interval)
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector2d(
    Curve2d curve1,
    Curve2d curve2,
    Interval range1,
    Interval range2
)
Public Sub New ( _
    curve1 As Curve2d, _
    curve2 As Curve2d, _
    range1 As Interval, _
    range2 As Interval _
)
public:
CurveCurveIntersector2d(
    Curve2d^ curve1,
    Curve2d^ curve2,
    Interval^ range1,
    Interval^ range2
)
Parameters
curve1(Curve2d)
curve2(Curve2d)
range1(Interval)
range2(Interval)


CurveCurveIntersector2d Constructor (curve1, curve2, range1, range2, tolerance)

CurveCurveIntersector2d Constructor (curve1, curve2, range1, range2, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »CurveCurveIntersector2d(Curve2d, Curve2d, Interval, Interval, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector2d(
    Curve2d curve1,
    Curve2d curve2,
    Interval range1,
    Interval range2,
    Tolerance tolerance
)
Public Sub New ( _
    curve1 As Curve2d, _
    curve2 As Curve2d, _
    range1 As Interval, _
    range2 As Interval, _
    tolerance As Tolerance _
)
public:
CurveCurveIntersector2d(
    Curve2d^ curve1,
    Curve2d^ curve2,
    Interval^ range1,
    Interval^ range2,
    Tolerance tolerance
)
Parameters
curve1(Curve2d)
curve2(Curve2d)
range1(Interval)
range2(Interval)
tolerance(Tolerance)


CurveCurveIntersector2d Constructor (curve1, curve2, tolerance)

CurveCurveIntersector2d Constructor (curve1, curve2, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »CurveCurveIntersector2d(Curve2d, Curve2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector2d(
    Curve2d curve1,
    Curve2d curve2,
    Tolerance tolerance
)
Public Sub New ( _
    curve1 As Curve2d, _
    curve2 As Curve2d, _
    tolerance As Tolerance _
)
public:
CurveCurveIntersector2d(
    Curve2d^ curve1,
    Curve2d^ curve2,
    Tolerance tolerance
)
Parameters
curve1(Curve2d)
curve2(Curve2d)
tolerance(Tolerance)


ChangeCurveOrder Method

ChangeCurveOrder Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »ChangeCurveOrder()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ChangeCurveOrder()
Public Sub ChangeCurveOrder
public:
void ChangeCurveOrder()


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static CurveCurveIntersector2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As CurveCurveIntersector2d
public:
static CurveCurveIntersector2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Curve1 Property

Curve1 Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »Curve1
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d Curve1 { get; }
Public ReadOnly Property Curve1 As Curve2d
    Get
public:
property Curve2d^ Curve1 {
    Curve2d^ get ();
}


Curve2 Property

Curve2 Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »Curve2
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d Curve2 { get; }
Public ReadOnly Property Curve2 As Curve2d
    Get
public:
property Curve2d^ Curve2 {
    Curve2d^ get ();
}


GetIntersectionParameters Method (intersection)

GetIntersectionParameters Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »GetIntersectionParameters(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double[] GetIntersectionParameters(
    int intersection
)
Public Function GetIntersectionParameters ( _
    intersection As Integer _
) As Double()
public:
array<double>^ GetIntersectionParameters(
    int intersection
)
Parameters
intersection(Int32)


GetIntersectionPoint Method (number)

GetIntersectionPoint Method (number)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »GetIntersectionPoint(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetIntersectionPoint(
    int number
)
Public Function GetIntersectionPoint ( _
    number As Integer _
) As Point2d
public:
Point2d GetIntersectionPoint(
    int number
)
Parameters
number(Int32)


GetIntersectionPointTolerance Method (intersection)

GetIntersectionPointTolerance Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »GetIntersectionPointTolerance(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetIntersectionPointTolerance(
    int intersection
)
Public Function GetIntersectionPointTolerance ( _
    intersection As Integer _
) As Double
public:
double GetIntersectionPointTolerance(
    int intersection
)
Parameters
intersection(Int32)


GetIntersectionRanges Method

GetIntersectionRanges Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »GetIntersectionRanges()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Interval[] GetIntersectionRanges()
Public Function GetIntersectionRanges As Interval()
public:
array<Interval^>^ GetIntersectionRanges()


GetOverlapRanges Method (overlapNumber)

GetOverlapRanges Method (overlapNumber)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »GetOverlapRanges(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Interval[] GetOverlapRanges(
    int overlapNumber
)
Public Function GetOverlapRanges ( _
    overlapNumber As Integer _
) As Interval()
public:
array<Interval^>^ GetOverlapRanges(
    int overlapNumber
)
Parameters
overlapNumber(Int32)


GetPointOnCurve1 Method (intersection)

GetPointOnCurve1 Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »GetPointOnCurve1(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d GetPointOnCurve1(
    int intersection
)
Public Function GetPointOnCurve1 ( _
    intersection As Integer _
) As PointOnCurve2d
public:
PointOnCurve2d^ GetPointOnCurve1(
    int intersection
)
Parameters
intersection(Int32)


GetPointOnCurve2 Method (intersection)

GetPointOnCurve2 Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »GetPointOnCurve2(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d GetPointOnCurve2(
    int intersection
)
Public Function GetPointOnCurve2 ( _
    intersection As Integer _
) As PointOnCurve2d
public:
PointOnCurve2d^ GetPointOnCurve2(
    int intersection
)
Parameters
intersection(Int32)


IsTangential Method (intersection)

IsTangential Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »IsTangential(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTangential(
    int intersection
)
Public Function IsTangential ( _
    intersection As Integer _
) As Boolean
public:
bool IsTangential(
    int intersection
)
Parameters
intersection(Int32)


IsTransversal Method (intersection)

IsTransversal Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »IsTransversal(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTransversal(
    int intersection
)
Public Function IsTransversal ( _
    intersection As Integer _
) As Boolean
public:
bool IsTransversal(
    int intersection
)
Parameters
intersection(Int32)


NumberOfIntersectionPoints Property

NumberOfIntersectionPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »NumberOfIntersectionPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfIntersectionPoints { get; }
Public ReadOnly Property NumberOfIntersectionPoints As Integer
    Get
public:
property int NumberOfIntersectionPoints {
    int get ();
}


OrderWithRegardsTo1 Method

OrderWithRegardsTo1 Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »OrderWithRegardsTo1()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void OrderWithRegardsTo1()
Public Sub OrderWithRegardsTo1
public:
void OrderWithRegardsTo1()


OrderWithRegardsTo2 Method

OrderWithRegardsTo2 Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »OrderWithRegardsTo2()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void OrderWithRegardsTo2()
Public Sub OrderWithRegardsTo2
public:
void OrderWithRegardsTo2()


OverlapCount Property

OverlapCount Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »OverlapCount
Declaration Syntax
C# Visual Basic Visual C++
public int OverlapCount { get; }
Public ReadOnly Property OverlapCount As Integer
    Get
public:
property int OverlapCount {
    int get ();
}


OverlapDirection Property

OverlapDirection Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »OverlapDirection
Declaration Syntax
C# Visual Basic Visual C++
public bool OverlapDirection { get; }
Public ReadOnly Property OverlapDirection As Boolean
    Get
public:
property bool OverlapDirection {
    bool get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »Set()()()()
Members
Icon | Member | Description
 | Set(Curve2d, Curve2d, Interval, Interval, Tolerance) |
 | Set(Curve2d, Curve2d, Interval, Interval) |
 | Set(Curve2d, Curve2d, Tolerance) |
 | Set(Curve2d, Curve2d) |


Set Method (curve1, curve2)

Set Method (curve1, curve2)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »Set(Curve2d, Curve2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve2d curve1,
    Curve2d curve2
)
Public Sub Set ( _
    curve1 As Curve2d, _
    curve2 As Curve2d _
)
public:
void Set(
    Curve2d^ curve1,
    Curve2d^ curve2
)
Parameters
curve1(Curve2d)
curve2(Curve2d)


Set Method (curve1, curve2, range1, range2)

Set Method (curve1, curve2, range1, range2)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »Set(Curve2d, Curve2d, Interval, Interval)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve2d curve1,
    Curve2d curve2,
    Interval range1,
    Interval range2
)
Public Sub Set ( _
    curve1 As Curve2d, _
    curve2 As Curve2d, _
    range1 As Interval, _
    range2 As Interval _
)
public:
void Set(
    Curve2d^ curve1,
    Curve2d^ curve2,
    Interval^ range1,
    Interval^ range2
)
Parameters
curve1(Curve2d)
curve2(Curve2d)
range1(Interval)
range2(Interval)


Set Method (curve1, curve2, range1, range2, tolerance)

Set Method (curve1, curve2, range1, range2, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »Set(Curve2d, Curve2d, Interval, Interval, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve2d curve1,
    Curve2d curve2,
    Interval range1,
    Interval range2,
    Tolerance tolerance
)
Public Sub Set ( _
    curve1 As Curve2d, _
    curve2 As Curve2d, _
    range1 As Interval, _
    range2 As Interval, _
    tolerance As Tolerance _
)
public:
void Set(
    Curve2d^ curve1,
    Curve2d^ curve2,
    Interval^ range1,
    Interval^ range2,
    Tolerance tolerance
)
Parameters
curve1(Curve2d)
curve2(Curve2d)
range1(Interval)
range2(Interval)
tolerance(Tolerance)


Set Method (curve1, curve2, tolerance)

Set Method (curve1, curve2, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »Set(Curve2d, Curve2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve2d curve1,
    Curve2d curve2,
    Tolerance tolerance
)
Public Sub Set ( _
    curve1 As Curve2d, _
    curve2 As Curve2d, _
    tolerance As Tolerance _
)
public:
void Set(
    Curve2d^ curve1,
    Curve2d^ curve2,
    Tolerance tolerance
)
Parameters
curve1(Curve2d)
curve2(Curve2d)
tolerance(Tolerance)


Tolerance Property

Tolerance Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »Tolerance
Declaration Syntax
C# Visual Basic Visual C++
public Tolerance Tolerance { get; }
Public ReadOnly Property Tolerance As Tolerance
    Get
public:
property Tolerance Tolerance {
    Tolerance get ();
}


CurveCurveIntersector3d Class

CurveCurveIntersector3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCurveCurveInt3d")]
public sealed class CurveCurveIntersector3d : Entity3d
<WrapperAttribute("ZcGeCurveCurveInt3d")> _
Public NotInheritable Class CurveCurveIntersector3d _
    Inherits Entity3d
[WrapperAttribute(L"ZcGeCurveCurveInt3d")]
public ref class CurveCurveIntersector3d sealed : public Entity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d, Tolerance) |
 | CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d) |
 | CurveCurveIntersector3d(Curve3d, Curve3d, Vector3d, Tolerance) |
 | CurveCurveIntersector3d(Curve3d, Curve3d, Vector3d) |
 | CurveCurveIntersector3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | ChangeCurveOrder()()()() |
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Curve1 |
 | Curve2 |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetIntersectionParameters(Int32) |
 | GetIntersectionPoint(Int32) |
 | GetIntersectionPointTolerance(Int32) |
 | GetIntersectionRanges()()()() |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetOverlapRanges(Int32) |
 | GetPointOnCurve1(Int32) |
 | GetPointOnCurve2(Int32) |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsTangential(Int32) |
 | IsTransversal(Int32) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | NumberOfIntersectionPoints |
 | OrderWithRegardsTo1()()()() |
 | OrderWithRegardsTo2()()()() |
 | OverlapCount()()()() |
 | OverlapDirection()()()() |
 | PlaneNormal |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Curve3d, Curve3d, Interval, Interval, Vector3d, Tolerance) |
 | Set(Curve3d, Curve3d, Interval, Interval, Vector3d) |
 | Set(Curve3d, Curve3d, Vector3d, Tolerance) |
 | Set(Curve3d, Curve3d, Vector3d) |
 | Tolerance |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | CurveCurveIntersector3d


CurveCurveIntersector3d Constructor

CurveCurveIntersector3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »CurveCurveIntersector3d()()()()
Members
Icon | Member | Description
 | CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d, Tolerance) |
 | CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d) |
 | CurveCurveIntersector3d(Curve3d, Curve3d, Vector3d, Tolerance) |
 | CurveCurveIntersector3d(Curve3d, Curve3d, Vector3d) |
 | CurveCurveIntersector3d()()()() |


CurveCurveIntersector3d Constructor

CurveCurveIntersector3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »CurveCurveIntersector3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector3d()
Public Sub New
public:
CurveCurveIntersector3d()


CurveCurveIntersector3d Constructor (curve1, curve2, range1, range2, planeNormal)

CurveCurveIntersector3d Constructor (curve1, curve2, range1, range2, planeNormal)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector3d(
    Curve3d curve1,
    Curve3d curve2,
    Interval range1,
    Interval range2,
    Vector3d planeNormal
)
Public Sub New ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    range1 As Interval, _
    range2 As Interval, _
    planeNormal As Vector3d _
)
public:
CurveCurveIntersector3d(
    Curve3d^ curve1,
    Curve3d^ curve2,
    Interval^ range1,
    Interval^ range2,
    Vector3d planeNormal
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
range1(Interval)
range2(Interval)
planeNormal(Vector3d)


CurveCurveIntersector3d Constructor (curve1, curve2, range1, range2, planeNormal, tolerance)

CurveCurveIntersector3d Constructor (curve1, curve2, range1, range2, planeNormal, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector3d(
    Curve3d curve1,
    Curve3d curve2,
    Interval range1,
    Interval range2,
    Vector3d planeNormal,
    Tolerance tolerance
)
Public Sub New ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    range1 As Interval, _
    range2 As Interval, _
    planeNormal As Vector3d, _
    tolerance As Tolerance _
)
public:
CurveCurveIntersector3d(
    Curve3d^ curve1,
    Curve3d^ curve2,
    Interval^ range1,
    Interval^ range2,
    Vector3d planeNormal,
    Tolerance tolerance
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
range1(Interval)
range2(Interval)
planeNormal(Vector3d)
tolerance(Tolerance)


CurveCurveIntersector3d Constructor (curve1, curve2, planeNormal)

CurveCurveIntersector3d Constructor (curve1, curve2, planeNormal)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »CurveCurveIntersector3d(Curve3d, Curve3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector3d(
    Curve3d curve1,
    Curve3d curve2,
    Vector3d planeNormal
)
Public Sub New ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    planeNormal As Vector3d _
)
public:
CurveCurveIntersector3d(
    Curve3d^ curve1,
    Curve3d^ curve2,
    Vector3d planeNormal
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
planeNormal(Vector3d)


CurveCurveIntersector3d Constructor (curve1, curve2, planeNormal, tolerance)

CurveCurveIntersector3d Constructor (curve1, curve2, planeNormal, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »CurveCurveIntersector3d(Curve3d, Curve3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public CurveCurveIntersector3d(
    Curve3d curve1,
    Curve3d curve2,
    Vector3d planeNormal,
    Tolerance tolerance
)
Public Sub New ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    planeNormal As Vector3d, _
    tolerance As Tolerance _
)
public:
CurveCurveIntersector3d(
    Curve3d^ curve1,
    Curve3d^ curve2,
    Vector3d planeNormal,
    Tolerance tolerance
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
planeNormal(Vector3d)
tolerance(Tolerance)


ChangeCurveOrder Method

ChangeCurveOrder Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »ChangeCurveOrder()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ChangeCurveOrder()
Public Sub ChangeCurveOrder
public:
void ChangeCurveOrder()


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static CurveCurveIntersector3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As CurveCurveIntersector3d
public:
static CurveCurveIntersector3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Curve1 Property

Curve1 Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »Curve1
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d Curve1 { get; }
Public ReadOnly Property Curve1 As Curve3d
    Get
public:
property Curve3d^ Curve1 {
    Curve3d^ get ();
}


Curve2 Property

Curve2 Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »Curve2
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d Curve2 { get; }
Public ReadOnly Property Curve2 As Curve3d
    Get
public:
property Curve3d^ Curve2 {
    Curve3d^ get ();
}


GetIntersectionParameters Method (intersection)

GetIntersectionParameters Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »GetIntersectionParameters(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double[] GetIntersectionParameters(
    int intersection
)
Public Function GetIntersectionParameters ( _
    intersection As Integer _
) As Double()
public:
array<double>^ GetIntersectionParameters(
    int intersection
)
Parameters
intersection(Int32)


GetIntersectionPoint Method (intersection)

GetIntersectionPoint Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »GetIntersectionPoint(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetIntersectionPoint(
    int intersection
)
Public Function GetIntersectionPoint ( _
    intersection As Integer _
) As Point3d
public:
Point3d GetIntersectionPoint(
    int intersection
)
Parameters
intersection(Int32)


GetIntersectionPointTolerance Method (intersection)

GetIntersectionPointTolerance Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »GetIntersectionPointTolerance(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetIntersectionPointTolerance(
    int intersection
)
Public Function GetIntersectionPointTolerance ( _
    intersection As Integer _
) As Double
public:
double GetIntersectionPointTolerance(
    int intersection
)
Parameters
intersection(Int32)


GetIntersectionRanges Method

GetIntersectionRanges Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »GetIntersectionRanges()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Interval[] GetIntersectionRanges()
Public Function GetIntersectionRanges As Interval()
public:
array<Interval^>^ GetIntersectionRanges()


GetOverlapRanges Method (overlap)

GetOverlapRanges Method (overlap)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »GetOverlapRanges(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Interval[] GetOverlapRanges(
    int overlap
)
Public Function GetOverlapRanges ( _
    overlap As Integer _
) As Interval()
public:
array<Interval^>^ GetOverlapRanges(
    int overlap
)
Parameters
overlap(Int32)


GetPointOnCurve1 Method (intersection)

GetPointOnCurve1 Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »GetPointOnCurve1(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d GetPointOnCurve1(
    int intersection
)
Public Function GetPointOnCurve1 ( _
    intersection As Integer _
) As PointOnCurve3d
public:
PointOnCurve3d^ GetPointOnCurve1(
    int intersection
)
Parameters
intersection(Int32)


GetPointOnCurve2 Method (intersection)

GetPointOnCurve2 Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »GetPointOnCurve2(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d GetPointOnCurve2(
    int intersection
)
Public Function GetPointOnCurve2 ( _
    intersection As Integer _
) As PointOnCurve3d
public:
PointOnCurve3d^ GetPointOnCurve2(
    int intersection
)
Parameters
intersection(Int32)


IsTangential Method (intersection)

IsTangential Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »IsTangential(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTangential(
    int intersection
)
Public Function IsTangential ( _
    intersection As Integer _
) As Boolean
public:
bool IsTangential(
    int intersection
)
Parameters
intersection(Int32)


IsTransversal Method (intersection)

IsTransversal Method (intersection)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »IsTransversal(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTransversal(
    int intersection
)
Public Function IsTransversal ( _
    intersection As Integer _
) As Boolean
public:
bool IsTransversal(
    int intersection
)
Parameters
intersection(Int32)


NumberOfIntersectionPoints Property

NumberOfIntersectionPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »NumberOfIntersectionPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfIntersectionPoints { get; }
Public ReadOnly Property NumberOfIntersectionPoints As Integer
    Get
public:
property int NumberOfIntersectionPoints {
    int get ();
}


OrderWithRegardsTo1 Method

OrderWithRegardsTo1 Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »OrderWithRegardsTo1()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void OrderWithRegardsTo1()
Public Sub OrderWithRegardsTo1
public:
void OrderWithRegardsTo1()


OrderWithRegardsTo2 Method

OrderWithRegardsTo2 Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »OrderWithRegardsTo2()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void OrderWithRegardsTo2()
Public Sub OrderWithRegardsTo2
public:
void OrderWithRegardsTo2()


OverlapCount Method

OverlapCount Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »OverlapCount()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int OverlapCount()
Public Function OverlapCount As Integer
public:
int OverlapCount()


OverlapDirection Method

OverlapDirection Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »OverlapDirection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool OverlapDirection()
Public Function OverlapDirection As Boolean
public:
bool OverlapDirection()


PlaneNormal Property

PlaneNormal Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »PlaneNormal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d PlaneNormal { get; }
Public ReadOnly Property PlaneNormal As Vector3d
    Get
public:
property Vector3d PlaneNormal {
    Vector3d get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »Set()()()()
Members
Icon | Member | Description
 | Set(Curve3d, Curve3d, Interval, Interval, Vector3d, Tolerance) |
 | Set(Curve3d, Curve3d, Interval, Interval, Vector3d) |
 | Set(Curve3d, Curve3d, Vector3d, Tolerance) |
 | Set(Curve3d, Curve3d, Vector3d) |


Set Method (curve1, curve2, range1, range2, planeNormal)

Set Method (curve1, curve2, range1, range2, planeNormal)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »Set(Curve3d, Curve3d, Interval, Interval, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve3d curve1,
    Curve3d curve2,
    Interval range1,
    Interval range2,
    Vector3d planeNormal
)
Public Sub Set ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    range1 As Interval, _
    range2 As Interval, _
    planeNormal As Vector3d _
)
public:
void Set(
    Curve3d^ curve1,
    Curve3d^ curve2,
    Interval^ range1,
    Interval^ range2,
    Vector3d planeNormal
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
range1(Interval)
range2(Interval)
planeNormal(Vector3d)


Set Method (curve1, curve2, range1, range2, planeNormal, tolerance)

Set Method (curve1, curve2, range1, range2, planeNormal, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »Set(Curve3d, Curve3d, Interval, Interval, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve3d curve1,
    Curve3d curve2,
    Interval range1,
    Interval range2,
    Vector3d planeNormal,
    Tolerance tolerance
)
Public Sub Set ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    range1 As Interval, _
    range2 As Interval, _
    planeNormal As Vector3d, _
    tolerance As Tolerance _
)
public:
void Set(
    Curve3d^ curve1,
    Curve3d^ curve2,
    Interval^ range1,
    Interval^ range2,
    Vector3d planeNormal,
    Tolerance tolerance
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
range1(Interval)
range2(Interval)
planeNormal(Vector3d)
tolerance(Tolerance)


Set Method (curve1, curve2, planeNormal)

Set Method (curve1, curve2, planeNormal)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »Set(Curve3d, Curve3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve3d curve1,
    Curve3d curve2,
    Vector3d planeNormal
)
Public Sub Set ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    planeNormal As Vector3d _
)
public:
void Set(
    Curve3d^ curve1,
    Curve3d^ curve2,
    Vector3d planeNormal
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
planeNormal(Vector3d)


Set Method (curve1, curve2, planeNormal, tolerance)

Set Method (curve1, curve2, planeNormal, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »Set(Curve3d, Curve3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve3d curve1,
    Curve3d curve2,
    Vector3d planeNormal,
    Tolerance tolerance
)
Public Sub Set ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    planeNormal As Vector3d, _
    tolerance As Tolerance _
)
public:
void Set(
    Curve3d^ curve1,
    Curve3d^ curve2,
    Vector3d planeNormal,
    Tolerance tolerance
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
planeNormal(Vector3d)
tolerance(Tolerance)


Tolerance Property

Tolerance Property
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »Tolerance
Declaration Syntax
C# Visual Basic Visual C++
public Tolerance Tolerance { get; }
Public ReadOnly Property Tolerance As Tolerance
    Get
public:
property Tolerance Tolerance {
    Tolerance get ();
}


Cylinder Class

Cylinder Class
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeCylinder")]
public sealed class Cylinder : Surface
<WrapperAttribute("ZcGeCylinder")> _
Public NotInheritable Class Cylinder _
    Inherits Surface
[WrapperAttribute(L"ZcGeCylinder")]
public ref class Cylinder sealed : public Surface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Cylinder(Double, Point3d, Vector3d, Vector3d, Interval, Double, Double) |
 | Cylinder(Double, Point3d, Vector3d) |
 | Cylinder()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | AxisOfSymmetry |
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAngles()()()() |
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetHeightAt(Double) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Height |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |
 | IsClosed(Tolerance) |
 | IsClosed()()()() |
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsNormalReversed | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsOuterNormal |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | Origin |
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | Radius |
 | ReferenceAxis |
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Double, Point3d, Vector3d, Vector3d, Interval, Double, Double) |
 | Set(Double, Point3d, Vector3d) |
 | SetAngles(Double, Double) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | Cylinder


Cylinder Constructor

Cylinder Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Cylinder()()()()
Members
Icon | Member | Description
 | Cylinder(Double, Point3d, Vector3d, Vector3d, Interval, Double, Double) |
 | Cylinder(Double, Point3d, Vector3d) |
 | Cylinder()()()() |


Cylinder Constructor

Cylinder Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Cylinder()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Cylinder()
Public Sub New
public:
Cylinder()


Cylinder Constructor (radius, origin, axisOfSymmetry)

Cylinder Constructor (radius, origin, axisOfSymmetry)
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Cylinder(Double, Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Cylinder(
    double radius,
    Point3d origin,
    Vector3d axisOfSymmetry
)
Public Sub New ( _
    radius As Double, _
    origin As Point3d, _
    axisOfSymmetry As Vector3d _
)
public:
Cylinder(
    double radius,
    Point3d origin,
    Vector3d axisOfSymmetry
)
Parameters
radius(Double)
origin(Point3d)
axisOfSymmetry(Vector3d)


Cylinder Constructor (radius, origin, axisOfSymmetry, referenceAxis, height, startAngle, endAngle)

Cylinder Constructor (radius, origin, axisOfSymmetry, referenceAxis, height, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Cylinder(Double, Point3d, Vector3d, Vector3d, Interval, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Cylinder(
    double radius,
    Point3d origin,
    Vector3d axisOfSymmetry,
    Vector3d referenceAxis,
    Interval height,
    double startAngle,
    double endAngle
)
Public Sub New ( _
    radius As Double, _
    origin As Point3d, _
    axisOfSymmetry As Vector3d, _
    referenceAxis As Vector3d, _
    height As Interval, _
    startAngle As Double, _
    endAngle As Double _
)
public:
Cylinder(
    double radius,
    Point3d origin,
    Vector3d axisOfSymmetry,
    Vector3d referenceAxis,
    Interval^ height,
    double startAngle,
    double endAngle
)
Parameters
radius(Double)
origin(Point3d)
axisOfSymmetry(Vector3d)
referenceAxis(Vector3d)
height(Interval)
startAngle(Double)
endAngle(Double)


AxisOfSymmetry Property

AxisOfSymmetry Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »AxisOfSymmetry
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d AxisOfSymmetry { get; }
Public ReadOnly Property AxisOfSymmetry As Vector3d
    Get
public:
property Vector3d AxisOfSymmetry {
    Vector3d get ();
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Cylinder Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Cylinder
public:
static Cylinder^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetAngles Method

GetAngles Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »GetAngles()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] GetAngles()
Public Function GetAngles As Double()
public:
array<double>^ GetAngles()


GetHeightAt Method (parameter)

GetHeightAt Method (parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »GetHeightAt(Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetHeightAt(
    double parameter
)
Public Function GetHeightAt ( _
    parameter As Double _
) As Double
public:
double GetHeightAt(
    double parameter
)
Parameters
parameter(Double)


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Height
Declaration Syntax
C# Visual Basic Visual C++
public Interval Height { get; set; }
Public Property Height As Interval
    Get
    Set
public:
property Interval^ Height {
    Interval^ get ();
    void set (Interval^ value);
}


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |


IntersectWith Method (linearEntity)

IntersectWith Method (linearEntity)
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IntersectWith(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d linearEntity
)
Public Function IntersectWith ( _
    linearEntity As LinearEntity3d _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ linearEntity
)
Parameters
linearEntity(LinearEntity3d)


IntersectWith Method (linearEntity, tolerance)

IntersectWith Method (linearEntity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IntersectWith(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d linearEntity,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    linearEntity As LinearEntity3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ linearEntity,
    Tolerance tolerance
)
Parameters
linearEntity(LinearEntity3d)
tolerance(Tolerance)


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IsClosed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed()
Public Function IsClosed As Boolean
public:
bool IsClosed()


IsClosed Method (tolerance)

IsClosed Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IsClosed(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed(
    Tolerance tolerance
)
Public Function IsClosed ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsClosed(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsOuterNormal Property

IsOuterNormal Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IsOuterNormal
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOuterNormal { get; }
Public ReadOnly Property IsOuterNormal As Boolean
    Get
public:
property bool IsOuterNormal {
    bool get ();
}


Origin Property

Origin Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Origin
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Origin { get; }
Public ReadOnly Property Origin As Point3d
    Get
public:
property Point3d Origin {
    Point3d get ();
}


Radius Property

Radius Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Radius
Declaration Syntax
C# Visual Basic Visual C++
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set
public:
property double Radius {
    double get ();
    void set (double value);
}


ReferenceAxis Property

ReferenceAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »ReferenceAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d ReferenceAxis { get; }
Public ReadOnly Property ReferenceAxis As Vector3d
    Get
public:
property Vector3d ReferenceAxis {
    Vector3d get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Set()()()()
Members
Icon | Member | Description
 | Set(Double, Point3d, Vector3d, Vector3d, Interval, Double, Double) |
 | Set(Double, Point3d, Vector3d) |


Set Method (radius, origin, axisOfSymmetry)

Set Method (radius, origin, axisOfSymmetry)
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Set(Double, Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double radius,
    Point3d origin,
    Vector3d axisOfSymmetry
)
Public Sub Set ( _
    radius As Double, _
    origin As Point3d, _
    axisOfSymmetry As Vector3d _
)
public:
void Set(
    double radius,
    Point3d origin,
    Vector3d axisOfSymmetry
)
Parameters
radius(Double)
origin(Point3d)
axisOfSymmetry(Vector3d)


Set Method (radius, origin, axisOfSymmetry, referenceAxis, height, startAngle, endAngle)

Set Method (radius, origin, axisOfSymmetry, referenceAxis, height, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Set(Double, Point3d, Vector3d, Vector3d, Interval, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double radius,
    Point3d origin,
    Vector3d axisOfSymmetry,
    Vector3d referenceAxis,
    Interval height,
    double startAngle,
    double endAngle
)
Public Sub Set ( _
    radius As Double, _
    origin As Point3d, _
    axisOfSymmetry As Vector3d, _
    referenceAxis As Vector3d, _
    height As Interval, _
    startAngle As Double, _
    endAngle As Double _
)
public:
void Set(
    double radius,
    Point3d origin,
    Vector3d axisOfSymmetry,
    Vector3d referenceAxis,
    Interval^ height,
    double startAngle,
    double endAngle
)
Parameters
radius(Double)
origin(Point3d)
axisOfSymmetry(Vector3d)
referenceAxis(Vector3d)
height(Interval)
startAngle(Double)
endAngle(Double)


SetAngles Method (startAngle, endAngle)

SetAngles Method (startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »SetAngles(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAngles(
    double startAngle,
    double endAngle
)
Public Sub SetAngles ( _
    startAngle As Double, _
    endAngle As Double _
)
public:
void SetAngles(
    double startAngle,
    double endAngle
)
Parameters
startAngle(Double)
endAngle(Double)


DoubleCollection Class

DoubleCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeDoubleArray")]
public class DoubleCollection : IList
<WrapperAttribute("ZcGeDoubleArray")> _
Public Class DoubleCollection _
    Implements IList
[WrapperAttribute(L"ZcGeDoubleArray")]
public ref class DoubleCollection : IList
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DoubleCollection(Int32) |
 | DoubleCollection(array<Double>[]()[][]) |
 | DoubleCollection()()()() |
 | Add(Double) |
 | AddRange(array<Double>[]()[][]) |
 | Capacity |
 | Clear()()()() |
 | Contains(Double) |
 | CopyTo(array<Double>[]()[][], Int32) |
 | Count |
 | DefaultSize |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IEnumerable_GetEnumerator()()()() |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(Double) |
 | Insert(Int32, Double) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Double) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() |
Inheritance Hierarchy
Object
DoubleCollection


DoubleCollection Constructor

DoubleCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »DoubleCollection()()()()
Members
Icon | Member | Description
 | DoubleCollection(Int32) |
 | DoubleCollection(array<Double>[]()[][]) |
 | DoubleCollection()()()() |


DoubleCollection Constructor

DoubleCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »DoubleCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection()
Public Sub New
public:
DoubleCollection()


DoubleCollection Constructor (values)

DoubleCollection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »DoubleCollection(array<Double>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection(
    double[] values
)
Public Sub New ( _
    values As Double() _
)
public:
DoubleCollection(
    array<double>^ values
)
Parameters
values(array<Double>[]()[][])


DoubleCollection Constructor (capacity)

DoubleCollection Constructor (capacity)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »DoubleCollection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
DoubleCollection(
    int capacity
)
Parameters
capacity(Int32)


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »Add(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Add(
    double value
)
Public Overridable Function Add ( _
    value As Double _
) As Integer
public:
virtual int Add(
    double value
)
Parameters
value(Double)


AddRange Method (range)

AddRange Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »AddRange(array<Double>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddRange(
    double[] range
)
Public Overridable Sub AddRange ( _
    range As Double() _
)
public:
virtual void AddRange(
    array<double>^ range
)
Parameters
range(array<Double>[]()[][])


Capacity Property

Capacity Property
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »Capacity
Declaration Syntax
C# Visual Basic Visual C++
public int Capacity { get; set; }
Public Property Capacity As Integer
    Get
    Set
public:
property int Capacity {
    int get ();
    void set (int value);
}


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »Contains(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Contains(
    double value
)
Public Overridable Function Contains ( _
    value As Double _
) As Boolean
public:
virtual bool Contains(
    double value
)
Parameters
value(Double)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »CopyTo(array<Double>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyTo(
    double[] array,
    int index
)
Public Overridable Sub CopyTo ( _
    array As Double(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<double>^ array,
    int index
)
Parameters
array(array<Double>[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DefaultSize Field

DefaultSize Field
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »DefaultSize
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultSize
Public Const DefaultSize As Integer
public:
literal int DefaultSize


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual DoubleCollectionEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As DoubleCollectionEnumerator
public:
virtual DoubleCollectionEnumerator^ GetEnumerator()


ICollection_CopyTo Method (array, index)

ICollection_CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollection_CopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator IEnumerable_GetEnumerator()
Public Overridable Function IEnumerable_GetEnumerator As IEnumerator
public:
virtual IEnumerator^ IEnumerable_GetEnumerator()


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IList_IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IList_IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IList_Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IList_Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IndexOf(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IndexOf(
    double value
)
Public Overridable Function IndexOf ( _
    value As Double _
) As Integer
public:
virtual int IndexOf(
    double value
)
Parameters
value(Double)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »Insert(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Insert(
    int index,
    double value
)
Public Overridable Sub Insert ( _
    index As Integer, _
    value As Double _
)
public:
virtual void Insert(
    int index,
    double value
)
Parameters
index(Int32)
value(Double)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Double
    Get
    Set
public:
property double default[int index] {
    double get (int index);
    void set (int index, double value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »Remove(Double)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Remove(
    double value
)
Public Overridable Sub Remove ( _
    value As Double _
)
public:
virtual void Remove(
    double value
)
Parameters
value(Double)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual double[] ToArray()
Public Overridable Function ToArray As Double()
public:
virtual array<double>^ ToArray()


TrimToSize Method

TrimToSize Method
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollection »TrimToSize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void TrimToSize()
Public Overridable Sub TrimToSize
public:
virtual void TrimToSize()


DoubleCollectionEnumerator Class

DoubleCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public class DoubleCollectionEnumerator : IEnumerator
Public Class DoubleCollectionEnumerator _
    Implements IEnumerator
public ref class DoubleCollectionEnumerator : IEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerator_Current |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DoubleCollectionEnumerator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public double Current { get; }
Public ReadOnly Property Current As Double
    Get
public:
property double Current {
    double get ();
}


IEnumerator_Current Property

IEnumerator_Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollectionEnumerator »IEnumerator_Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object IEnumerator_Current { get; }
Public Overridable ReadOnly Property IEnumerator_Current As Object
    Get
public:
virtual property Object^ IEnumerator_Current {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.Geometry »DoubleCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


EllipticalArc2d Class

EllipticalArc2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeEllipArc2d")]
public sealed class EllipticalArc2d : Curve2d
<WrapperAttribute("ZcGeEllipArc2d")> _
Public NotInheritable Class EllipticalArc2d _
    Inherits Curve2d
[WrapperAttribute(L"ZcGeEllipArc2d")]
public ref class EllipticalArc2d sealed : public Curve2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EllipticalArc2d(Point2d, Vector2d, Vector2d, Double, Double, Double, Double) |
 | EllipticalArc2d(Point2d, Vector2d, Vector2d, Double, Double) |
 | EllipticalArc2d(CircularArc2d) |
 | EllipticalArc2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Center |
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndAngle |
 | EndPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity2d, Tolerance) |
 | IntersectWith(LinearEntity2d) |
 | IsCircular(Tolerance) |
 | IsCircular()()()() |
 | IsClockWise |
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsInside(Point2d, Tolerance) |
 | IsInside(Point2d) |
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | MajorAxis |
 | MajorRadius |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinorAxis |
 | MinorRadius |
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | Set(Point2d, Vector2d, Vector2d, Double, Double, Double, Double) |
 | Set(Point2d, Vector2d, Vector2d, Double, Double) |
 | Set(CircularArc2d) |
 | SetAngles(Double, Double) |
 | SetAxes(Vector2d, Vector2d) |
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | StartAngle |
 | StartPoint |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | EllipticalArc2d


EllipticalArc2d Constructor

EllipticalArc2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »EllipticalArc2d()()()()
Members
Icon | Member | Description
 | EllipticalArc2d(Point2d, Vector2d, Vector2d, Double, Double, Double, Double) |
 | EllipticalArc2d(Point2d, Vector2d, Vector2d, Double, Double) |
 | EllipticalArc2d(CircularArc2d) |
 | EllipticalArc2d()()()() |


EllipticalArc2d Constructor

EllipticalArc2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »EllipticalArc2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EllipticalArc2d()
Public Sub New
public:
EllipticalArc2d()


EllipticalArc2d Constructor (arc)

EllipticalArc2d Constructor (arc)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »EllipticalArc2d(CircularArc2d)
Declaration Syntax
C# Visual Basic Visual C++
public EllipticalArc2d(
    CircularArc2d arc
)
Public Sub New ( _
    arc As CircularArc2d _
)
public:
EllipticalArc2d(
    CircularArc2d^ arc
)
Parameters
arc(CircularArc2d)


EllipticalArc2d Constructor (center, majorAxis, minorAxis, majorRadius, minorRadius)

EllipticalArc2d Constructor (center, majorAxis, minorAxis, majorRadius, minorRadius)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »EllipticalArc2d(Point2d, Vector2d, Vector2d, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public EllipticalArc2d(
    Point2d center,
    Vector2d majorAxis,
    Vector2d minorAxis,
    double majorRadius,
    double minorRadius
)
Public Sub New ( _
    center As Point2d, _
    majorAxis As Vector2d, _
    minorAxis As Vector2d, _
    majorRadius As Double, _
    minorRadius As Double _
)
public:
EllipticalArc2d(
    Point2d center,
    Vector2d majorAxis,
    Vector2d minorAxis,
    double majorRadius,
    double minorRadius
)
Parameters
center(Point2d)
majorAxis(Vector2d)
minorAxis(Vector2d)
majorRadius(Double)
minorRadius(Double)


EllipticalArc2d Constructor (center, majorAxis, minorAxis, majorRadius, minorRadius, startAngle, endAngle)

EllipticalArc2d Constructor (center, majorAxis, minorAxis, majorRadius, minorRadius, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »EllipticalArc2d(Point2d, Vector2d, Vector2d, Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public EllipticalArc2d(
    Point2d center,
    Vector2d majorAxis,
    Vector2d minorAxis,
    double majorRadius,
    double minorRadius,
    double startAngle,
    double endAngle
)
Public Sub New ( _
    center As Point2d, _
    majorAxis As Vector2d, _
    minorAxis As Vector2d, _
    majorRadius As Double, _
    minorRadius As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
EllipticalArc2d(
    Point2d center,
    Vector2d majorAxis,
    Vector2d minorAxis,
    double majorRadius,
    double minorRadius,
    double startAngle,
    double endAngle
)
Parameters
center(Point2d)
majorAxis(Vector2d)
minorAxis(Vector2d)
majorRadius(Double)
minorRadius(Double)
startAngle(Double)
endAngle(Double)


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Center { get; set; }
Public Property Center As Point2d
    Get
    Set
public:
property Point2d Center {
    Point2d get ();
    void set (Point2d value);
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static EllipticalArc2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As EllipticalArc2d
public:
static EllipticalArc2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


EndAngle Property

EndAngle Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »EndAngle
Declaration Syntax
C# Visual Basic Visual C++
public double EndAngle { get; }
Public ReadOnly Property EndAngle As Double
    Get
public:
property double EndAngle {
    double get ();
}


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d EndPoint { get; }
Public ReadOnly Property EndPoint As Point2d
    Get
public:
property Point2d EndPoint {
    Point2d get ();
}


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity2d, Tolerance) |
 | IntersectWith(LinearEntity2d) |


IntersectWith Method (line)

IntersectWith Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IntersectWith(LinearEntity2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] IntersectWith(
    LinearEntity2d line
)
Public Function IntersectWith ( _
    line As LinearEntity2d _
) As Point2d()
public:
array<Point2d>^ IntersectWith(
    LinearEntity2d^ line
)
Parameters
line(LinearEntity2d)


IntersectWith Method (line, tolerance)

IntersectWith Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IntersectWith(LinearEntity2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] IntersectWith(
    LinearEntity2d line,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    line As LinearEntity2d, _
    tolerance As Tolerance _
) As Point2d()
public:
array<Point2d>^ IntersectWith(
    LinearEntity2d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity2d)
tolerance(Tolerance)


IsCircular Method

IsCircular Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsCircular()()()()
Members
Icon | Member | Description
 | IsCircular(Tolerance) |
 | IsCircular()()()() |


IsCircular Method

IsCircular Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsCircular()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCircular()
Public Function IsCircular As Boolean
public:
bool IsCircular()


IsCircular Method (tolerance)

IsCircular Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsCircular(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCircular(
    Tolerance tolerance
)
Public Function IsCircular ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsCircular(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsClockWise Property

IsClockWise Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsClockWise
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClockWise { get; }
Public ReadOnly Property IsClockWise As Boolean
    Get
public:
property bool IsClockWise {
    bool get ();
}


IsInside Method

IsInside Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsInside()()()()
Members
Icon | Member | Description
 | IsInside(Point2d, Tolerance) |
 | IsInside(Point2d) |


IsInside Method (point)

IsInside Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsInside(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInside(
    Point2d point
)
Public Function IsInside ( _
    point As Point2d _
) As Boolean
public:
bool IsInside(
    Point2d point
)
Parameters
point(Point2d)


IsInside Method (point, tolerance)

IsInside Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsInside(Point2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInside(
    Point2d point,
    Tolerance tolerance
)
Public Function IsInside ( _
    point As Point2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsInside(
    Point2d point,
    Tolerance tolerance
)
Parameters
point(Point2d)
tolerance(Tolerance)


MajorAxis Property

MajorAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »MajorAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d MajorAxis { get; }
Public ReadOnly Property MajorAxis As Vector2d
    Get
public:
property Vector2d MajorAxis {
    Vector2d get ();
}


MajorRadius Property

MajorRadius Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »MajorRadius
Declaration Syntax
C# Visual Basic Visual C++
public double MajorRadius { get; set; }
Public Property MajorRadius As Double
    Get
    Set
public:
property double MajorRadius {
    double get ();
    void set (double value);
}


MinorAxis Property

MinorAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »MinorAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d MinorAxis { get; }
Public ReadOnly Property MinorAxis As Vector2d
    Get
public:
property Vector2d MinorAxis {
    Vector2d get ();
}


MinorRadius Property

MinorRadius Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »MinorRadius
Declaration Syntax
C# Visual Basic Visual C++
public double MinorRadius { get; set; }
Public Property MinorRadius As Double
    Get
    Set
public:
property double MinorRadius {
    double get ();
    void set (double value);
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »Set()()()()
Members
Icon | Member | Description
 | Set(Point2d, Vector2d, Vector2d, Double, Double, Double, Double) |
 | Set(Point2d, Vector2d, Vector2d, Double, Double) |
 | Set(CircularArc2d) |


Set Method (arc)

Set Method (arc)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »Set(CircularArc2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    CircularArc2d arc
)
Public Sub Set ( _
    arc As CircularArc2d _
)
public:
void Set(
    CircularArc2d^ arc
)
Parameters
arc(CircularArc2d)


Set Method (center, majorAxis, minorAxis, majorRadius, minorRadius)

Set Method (center, majorAxis, minorAxis, majorRadius, minorRadius)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »Set(Point2d, Vector2d, Vector2d, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d center,
    Vector2d majorAxis,
    Vector2d minorAxis,
    double majorRadius,
    double minorRadius
)
Public Sub Set ( _
    center As Point2d, _
    majorAxis As Vector2d, _
    minorAxis As Vector2d, _
    majorRadius As Double, _
    minorRadius As Double _
)
public:
void Set(
    Point2d center,
    Vector2d majorAxis,
    Vector2d minorAxis,
    double majorRadius,
    double minorRadius
)
Parameters
center(Point2d)
majorAxis(Vector2d)
minorAxis(Vector2d)
majorRadius(Double)
minorRadius(Double)


Set Method (center, majorAxis, minorAxis, majorRadius, minorRadius, startAngle, endAngle)

Set Method (center, majorAxis, minorAxis, majorRadius, minorRadius, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »Set(Point2d, Vector2d, Vector2d, Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d center,
    Vector2d majorAxis,
    Vector2d minorAxis,
    double majorRadius,
    double minorRadius,
    double startAngle,
    double endAngle
)
Public Sub Set ( _
    center As Point2d, _
    majorAxis As Vector2d, _
    minorAxis As Vector2d, _
    majorRadius As Double, _
    minorRadius As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
void Set(
    Point2d center,
    Vector2d majorAxis,
    Vector2d minorAxis,
    double majorRadius,
    double minorRadius,
    double startAngle,
    double endAngle
)
Parameters
center(Point2d)
majorAxis(Vector2d)
minorAxis(Vector2d)
majorRadius(Double)
minorRadius(Double)
startAngle(Double)
endAngle(Double)


SetAngles Method (startAngle, endAngle)

SetAngles Method (startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »SetAngles(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAngles(
    double startAngle,
    double endAngle
)
Public Sub SetAngles ( _
    startAngle As Double, _
    endAngle As Double _
)
public:
void SetAngles(
    double startAngle,
    double endAngle
)
Parameters
startAngle(Double)
endAngle(Double)


SetAxes Method (majorAxis, minorAxis)

SetAxes Method (majorAxis, minorAxis)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »SetAxes(Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAxes(
    Vector2d majorAxis,
    Vector2d minorAxis
)
Public Sub SetAxes ( _
    majorAxis As Vector2d, _
    minorAxis As Vector2d _
)
public:
void SetAxes(
    Vector2d majorAxis,
    Vector2d minorAxis
)
Parameters
majorAxis(Vector2d)
minorAxis(Vector2d)


StartAngle Property

StartAngle Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »StartAngle
Declaration Syntax
C# Visual Basic Visual C++
public double StartAngle { get; }
Public ReadOnly Property StartAngle As Double
    Get
public:
property double StartAngle {
    double get ();
}


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d StartPoint { get; }
Public ReadOnly Property StartPoint As Point2d
    Get
public:
property Point2d StartPoint {
    Point2d get ();
}


EllipticalArc3d Class

EllipticalArc3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeEllipArc3d")]
public sealed class EllipticalArc3d : Curve3d
<WrapperAttribute("ZcGeEllipArc3d")> _
Public NotInheritable Class EllipticalArc3d _
    Inherits Curve3d
[WrapperAttribute(L"ZcGeEllipArc3d")]
public ref class EllipticalArc3d sealed : public Curve3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EllipticalArc3d(Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | EllipticalArc3d(Point3d, Vector3d, Vector3d, Double, Double) |
 | EllipticalArc3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Center |
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointToPlane(PlanarEntity, Tolerance) |
 | ClosestPointToPlane(PlanarEntity) |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndAngle |
 | EndPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetPlane()()()() |
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(PlanarEntity, Tolerance) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(PlanarEntity) |
 | IntersectWith(LinearEntity3d) |
 | IsCircular(Tolerance) |
 | IsCircular()()()() |
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsInside(Point3d, Tolerance) |
 | IsInside(Point3d) |
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | MajorAxis |
 | MajorRadius |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinorAxis |
 | MinorRadius |
 | Mirror(Plane) | (Inherited from Entity3d.)
 | Normal |
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) |
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | Set(Point3d, Vector3d, Vector3d, Double, Double) |
 | SetAngles(Double, Double) |
 | SetAxes(Vector3d, Vector3d) |
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | StartAngle |
 | StartPoint |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | EllipticalArc3d


EllipticalArc3d Constructor

EllipticalArc3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »EllipticalArc3d()()()()
Members
Icon | Member | Description
 | EllipticalArc3d(Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | EllipticalArc3d(Point3d, Vector3d, Vector3d, Double, Double) |
 | EllipticalArc3d()()()() |


EllipticalArc3d Constructor

EllipticalArc3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »EllipticalArc3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EllipticalArc3d()
Public Sub New
public:
EllipticalArc3d()


EllipticalArc3d Constructor (center, majorAxis, minorAxis, majorRadius, minorRadius)

EllipticalArc3d Constructor (center, majorAxis, minorAxis, majorRadius, minorRadius)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »EllipticalArc3d(Point3d, Vector3d, Vector3d, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public EllipticalArc3d(
    Point3d center,
    Vector3d majorAxis,
    Vector3d minorAxis,
    double majorRadius,
    double minorRadius
)
Public Sub New ( _
    center As Point3d, _
    majorAxis As Vector3d, _
    minorAxis As Vector3d, _
    majorRadius As Double, _
    minorRadius As Double _
)
public:
EllipticalArc3d(
    Point3d center,
    Vector3d majorAxis,
    Vector3d minorAxis,
    double majorRadius,
    double minorRadius
)
Parameters
center(Point3d)
majorAxis(Vector3d)
minorAxis(Vector3d)
majorRadius(Double)
minorRadius(Double)


EllipticalArc3d Constructor (center, majorAxis, minorAxis, majorRadius, minorRadius, startAngle, endAngle)

EllipticalArc3d Constructor (center, majorAxis, minorAxis, majorRadius, minorRadius, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »EllipticalArc3d(Point3d, Vector3d, Vector3d, Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public EllipticalArc3d(
    Point3d center,
    Vector3d majorAxis,
    Vector3d minorAxis,
    double majorRadius,
    double minorRadius,
    double startAngle,
    double endAngle
)
Public Sub New ( _
    center As Point3d, _
    majorAxis As Vector3d, _
    minorAxis As Vector3d, _
    majorRadius As Double, _
    minorRadius As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
EllipticalArc3d(
    Point3d center,
    Vector3d majorAxis,
    Vector3d minorAxis,
    double majorRadius,
    double minorRadius,
    double startAngle,
    double endAngle
)
Parameters
center(Point3d)
majorAxis(Vector3d)
minorAxis(Vector3d)
majorRadius(Double)
minorRadius(Double)
startAngle(Double)
endAngle(Double)


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Center { get; set; }
Public Property Center As Point3d
    Get
    Set
public:
property Point3d Center {
    Point3d get ();
    void set (Point3d value);
}


ClosestPointToPlane Method

ClosestPointToPlane Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »ClosestPointToPlane()()()()
Members
Icon | Member | Description
 | ClosestPointToPlane(PlanarEntity, Tolerance) |
 | ClosestPointToPlane(PlanarEntity) |


ClosestPointToPlane Method (plane)

ClosestPointToPlane Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »ClosestPointToPlane(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ClosestPointToPlane(
    PlanarEntity plane
)
Public Function ClosestPointToPlane ( _
    plane As PlanarEntity _
) As Point3d()
public:
array<Point3d>^ ClosestPointToPlane(
    PlanarEntity^ plane
)
Parameters
plane(PlanarEntity)


ClosestPointToPlane Method (plane, tolerance)

ClosestPointToPlane Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »ClosestPointToPlane(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ClosestPointToPlane(
    PlanarEntity plane,
    Tolerance tolerance
)
Public Function ClosestPointToPlane ( _
    plane As PlanarEntity, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ ClosestPointToPlane(
    PlanarEntity^ plane,
    Tolerance tolerance
)
Parameters
plane(PlanarEntity)
tolerance(Tolerance)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static EllipticalArc3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As EllipticalArc3d
public:
static EllipticalArc3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


EndAngle Property

EndAngle Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »EndAngle
Declaration Syntax
C# Visual Basic Visual C++
public double EndAngle { get; }
Public ReadOnly Property EndAngle As Double
    Get
public:
property double EndAngle {
    double get ();
}


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d EndPoint { get; }
Public ReadOnly Property EndPoint As Point3d
    Get
public:
property Point3d EndPoint {
    Point3d get ();
}


GetPlane Method

GetPlane Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetPlane()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Plane GetPlane()
Public Function GetPlane As Plane
public:
Plane^ GetPlane()


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(PlanarEntity, Tolerance) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(PlanarEntity) |
 | IntersectWith(LinearEntity3d) |


IntersectWith Method (line)

IntersectWith Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IntersectWith(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d line
)
Public Function IntersectWith ( _
    line As LinearEntity3d _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ line
)
Parameters
line(LinearEntity3d)


IntersectWith Method (line, tolerance)

IntersectWith Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IntersectWith(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d line,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    line As LinearEntity3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
tolerance(Tolerance)


IntersectWith Method (plane)

IntersectWith Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IntersectWith(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    PlanarEntity plane
)
Public Function IntersectWith ( _
    plane As PlanarEntity _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    PlanarEntity^ plane
)
Parameters
plane(PlanarEntity)


IntersectWith Method (plane, tolerance)

IntersectWith Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IntersectWith(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    PlanarEntity plane,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    plane As PlanarEntity, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    PlanarEntity^ plane,
    Tolerance tolerance
)
Parameters
plane(PlanarEntity)
tolerance(Tolerance)


IsCircular Method

IsCircular Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsCircular()()()()
Members
Icon | Member | Description
 | IsCircular(Tolerance) |
 | IsCircular()()()() |


IsCircular Method

IsCircular Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsCircular()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCircular()
Public Function IsCircular As Boolean
public:
bool IsCircular()


IsCircular Method (tolerance)

IsCircular Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsCircular(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCircular(
    Tolerance tolerance
)
Public Function IsCircular ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsCircular(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsInside Method

IsInside Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsInside()()()()
Members
Icon | Member | Description
 | IsInside(Point3d, Tolerance) |
 | IsInside(Point3d) |


IsInside Method (pointValue)

IsInside Method (pointValue)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsInside(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInside(
    Point3d pointValue
)
Public Function IsInside ( _
    pointValue As Point3d _
) As Boolean
public:
bool IsInside(
    Point3d pointValue
)
Parameters
pointValue(Point3d)


IsInside Method (pointValue, tolerance)

IsInside Method (pointValue, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsInside(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInside(
    Point3d pointValue,
    Tolerance tolerance
)
Public Function IsInside ( _
    pointValue As Point3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsInside(
    Point3d pointValue,
    Tolerance tolerance
)
Parameters
pointValue(Point3d)
tolerance(Tolerance)


MajorAxis Property

MajorAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »MajorAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d MajorAxis { get; }
Public ReadOnly Property MajorAxis As Vector3d
    Get
public:
property Vector3d MajorAxis {
    Vector3d get ();
}


MajorRadius Property

MajorRadius Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »MajorRadius
Declaration Syntax
C# Visual Basic Visual C++
public double MajorRadius { get; set; }
Public Property MajorRadius As Double
    Get
    Set
public:
property double MajorRadius {
    double get ();
    void set (double value);
}


MinorAxis Property

MinorAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »MinorAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d MinorAxis { get; }
Public ReadOnly Property MinorAxis As Vector3d
    Get
public:
property Vector3d MinorAxis {
    Vector3d get ();
}


MinorRadius Property

MinorRadius Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »MinorRadius
Declaration Syntax
C# Visual Basic Visual C++
public double MinorRadius { get; set; }
Public Property MinorRadius As Double
    Get
    Set
public:
property double MinorRadius {
    double get ();
    void set (double value);
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; }
Public ReadOnly Property Normal As Vector3d
    Get
public:
property Vector3d Normal {
    Vector3d get ();
}


ProjectedIntersectWith Method

ProjectedIntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »ProjectedIntersectWith()()()()
Members
Icon | Member | Description
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) |
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) |


ProjectedIntersectWith Method (line, projectionDirection)

ProjectedIntersectWith Method (line, projectionDirection)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »ProjectedIntersectWith(LinearEntity3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ProjectedIntersectWith(
    LinearEntity3d line,
    Vector3d projectionDirection
)
Public Function ProjectedIntersectWith ( _
    line As LinearEntity3d, _
    projectionDirection As Vector3d _
) As Point3d()
public:
array<Point3d>^ ProjectedIntersectWith(
    LinearEntity3d^ line,
    Vector3d projectionDirection
)
Parameters
line(LinearEntity3d)
projectionDirection(Vector3d)


ProjectedIntersectWith Method (line, projectionDirection, tolerance)

ProjectedIntersectWith Method (line, projectionDirection, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ProjectedIntersectWith(
    LinearEntity3d line,
    Vector3d projectionDirection,
    Tolerance tolerance
)
Public Function ProjectedIntersectWith ( _
    line As LinearEntity3d, _
    projectionDirection As Vector3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ ProjectedIntersectWith(
    LinearEntity3d^ line,
    Vector3d projectionDirection,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
projectionDirection(Vector3d)
tolerance(Tolerance)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »Set()()()()
Members
Icon | Member | Description
 | Set(Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | Set(Point3d, Vector3d, Vector3d, Double, Double) |


Set Method (center, majorAxis, minorAxis, majorRadius, minorRadius)

Set Method (center, majorAxis, minorAxis, majorRadius, minorRadius)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »Set(Point3d, Vector3d, Vector3d, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d center,
    Vector3d majorAxis,
    Vector3d minorAxis,
    double majorRadius,
    double minorRadius
)
Public Sub Set ( _
    center As Point3d, _
    majorAxis As Vector3d, _
    minorAxis As Vector3d, _
    majorRadius As Double, _
    minorRadius As Double _
)
public:
void Set(
    Point3d center,
    Vector3d majorAxis,
    Vector3d minorAxis,
    double majorRadius,
    double minorRadius
)
Parameters
center(Point3d)
majorAxis(Vector3d)
minorAxis(Vector3d)
majorRadius(Double)
minorRadius(Double)


Set Method (center, majorAxis, minorAxis, majorRadius, minorRadius, startAngle, endAngle)

Set Method (center, majorAxis, minorAxis, majorRadius, minorRadius, startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »Set(Point3d, Vector3d, Vector3d, Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d center,
    Vector3d majorAxis,
    Vector3d minorAxis,
    double majorRadius,
    double minorRadius,
    double startAngle,
    double endAngle
)
Public Sub Set ( _
    center As Point3d, _
    majorAxis As Vector3d, _
    minorAxis As Vector3d, _
    majorRadius As Double, _
    minorRadius As Double, _
    startAngle As Double, _
    endAngle As Double _
)
public:
void Set(
    Point3d center,
    Vector3d majorAxis,
    Vector3d minorAxis,
    double majorRadius,
    double minorRadius,
    double startAngle,
    double endAngle
)
Parameters
center(Point3d)
majorAxis(Vector3d)
minorAxis(Vector3d)
majorRadius(Double)
minorRadius(Double)
startAngle(Double)
endAngle(Double)


SetAngles Method (startAngle, endAngle)

SetAngles Method (startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »SetAngles(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAngles(
    double startAngle,
    double endAngle
)
Public Sub SetAngles ( _
    startAngle As Double, _
    endAngle As Double _
)
public:
void SetAngles(
    double startAngle,
    double endAngle
)
Parameters
startAngle(Double)
endAngle(Double)


SetAxes Method (majorAxis, minorAxis)

SetAxes Method (majorAxis, minorAxis)
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »SetAxes(Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAxes(
    Vector3d majorAxis,
    Vector3d minorAxis
)
Public Sub SetAxes ( _
    majorAxis As Vector3d, _
    minorAxis As Vector3d _
)
public:
void SetAxes(
    Vector3d majorAxis,
    Vector3d minorAxis
)
Parameters
majorAxis(Vector3d)
minorAxis(Vector3d)


StartAngle Property

StartAngle Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »StartAngle
Declaration Syntax
C# Visual Basic Visual C++
public double StartAngle { get; }
Public ReadOnly Property StartAngle As Double
    Get
public:
property double StartAngle {
    double get ();
}


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d StartPoint { get; }
Public ReadOnly Property StartPoint As Point3d
    Get
public:
property Point3d StartPoint {
    Point3d get ();
}


Entity2d Class

Entity2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeEntity2d")]
public abstract class Entity2d : DisposableWrapper,
    ICloneable
<WrapperAttribute("ZcGeEntity2d")> _
Public MustInherit Class Entity2d _
    Inherits DisposableWrapper _
    Implements ICloneable
[WrapperAttribute(L"ZcGeEntity2d")]
public ref class Entity2d abstract : public DisposableWrapper,
    ICloneable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Point2d) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) |
 | RotateBy(Double, Point2d) |
 | ScaleBy(Double, Point2d) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) |
 | TranslateBy(Vector2d) |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | BoundBlock2d
 |  |  |  | ClipBoundary2d
 |  |  |  | Curve2d
 |  |  |  | CurveCurveIntersector2d
 |  |  |  | PointEntity2d


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Entity2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Entity2d
public:
static Entity2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


IsEqualTo Method (entity)

IsEqualTo Method (entity)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »IsEqualTo(Entity2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Entity2d entity
)
Public Function IsEqualTo ( _
    entity As Entity2d _
) As Boolean
public:
bool IsEqualTo(
    Entity2d^ entity
)
Parameters
entity(Entity2d)


IsEqualTo Method (entity, tolerance)

IsEqualTo Method (entity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »IsEqualTo(Entity2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Entity2d entity,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    entity As Entity2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Entity2d^ entity,
    Tolerance tolerance
)
Parameters
entity(Entity2d)
tolerance(Tolerance)


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Tolerance) |
 | IsOn(Point2d) |


IsOn Method (point)

IsOn Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »IsOn(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point2d point
)
Public Function IsOn ( _
    point As Point2d _
) As Boolean
public:
bool IsOn(
    Point2d point
)
Parameters
point(Point2d)


IsOn Method (point, tolerance)

IsOn Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »IsOn(Point2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point2d point,
    Tolerance tolerance
)
Public Function IsOn ( _
    point As Point2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsOn(
    Point2d point,
    Tolerance tolerance
)
Parameters
point(Point2d)
tolerance(Tolerance)


Mirror Method (line)

Mirror Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »Mirror(Line2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Mirror(
    Line2d line
)
Public Sub Mirror ( _
    line As Line2d _
)
public:
void Mirror(
    Line2d^ line
)
Parameters
line(Line2d)


RotateBy Method (angle, point)

RotateBy Method (angle, point)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »RotateBy(Double, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void RotateBy(
    double angle,
    Point2d point
)
Public Sub RotateBy ( _
    angle As Double, _
    point As Point2d _
)
public:
void RotateBy(
    double angle,
    Point2d point
)
Parameters
angle(Double)
point(Point2d)


ScaleBy Method (scaleFactor, point)

ScaleBy Method (scaleFactor, point)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »ScaleBy(Double, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void ScaleBy(
    double scaleFactor,
    Point2d point
)
Public Sub ScaleBy ( _
    scaleFactor As Double, _
    point As Point2d _
)
public:
void ScaleBy(
    double scaleFactor,
    Point2d point
)
Parameters
scaleFactor(Double)
point(Point2d)


TransformBy Method (transform)

TransformBy Method (transform)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »TransformBy(Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public void TransformBy(
    Matrix2d transform
)
Public Sub TransformBy ( _
    transform As Matrix2d _
)
public:
void TransformBy(
    Matrix2d transform
)
Parameters
transform(Matrix2d)


TranslateBy Method (translateVector)

TranslateBy Method (translateVector)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »TranslateBy(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void TranslateBy(
    Vector2d translateVector
)
Public Sub TranslateBy ( _
    translateVector As Vector2d _
)
public:
void TranslateBy(
    Vector2d translateVector
)
Parameters
translateVector(Vector2d)


Entity3d Class

Entity3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeEntity3d")]
public abstract class Entity3d : DisposableWrapper,
    ICloneable
<WrapperAttribute("ZcGeEntity3d")> _
Public MustInherit Class Entity3d _
    Inherits DisposableWrapper _
    Implements ICloneable
[WrapperAttribute(L"ZcGeEntity3d")]
public ref class Entity3d abstract : public DisposableWrapper,
    ICloneable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) |
 | RotateBy(Double, Vector3d, Point3d) |
 | ScaleBy(Double, Point3d) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) |
 | TranslateBy(Vector3d) |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | BoundBlock3d
 |  |  |  | Curve3d
 |  |  |  | CurveCurveIntersector3d
 |  |  |  | PointEntity3d
 |  |  |  | Surface
 |  |  |  | SurfaceSurfaceIntersector


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Entity3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Entity3d
public:
static Entity3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


IsEqualTo Method (entity)

IsEqualTo Method (entity)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »IsEqualTo(Entity3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Entity3d entity
)
Public Function IsEqualTo ( _
    entity As Entity3d _
) As Boolean
public:
bool IsEqualTo(
    Entity3d^ entity
)
Parameters
entity(Entity3d)


IsEqualTo Method (entity, tolerance)

IsEqualTo Method (entity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »IsEqualTo(Entity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Entity3d entity,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    entity As Entity3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Entity3d^ entity,
    Tolerance tolerance
)
Parameters
entity(Entity3d)
tolerance(Tolerance)


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


IsOn Method (point)

IsOn Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »IsOn(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point3d point
)
Public Function IsOn ( _
    point As Point3d _
) As Boolean
public:
bool IsOn(
    Point3d point
)
Parameters
point(Point3d)


IsOn Method (point, tolerance)

IsOn Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »IsOn(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point3d point,
    Tolerance tolerance
)
Public Function IsOn ( _
    point As Point3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsOn(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


Mirror Method (plane)

Mirror Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »Mirror(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public void Mirror(
    Plane plane
)
Public Sub Mirror ( _
    plane As Plane _
)
public:
void Mirror(
    Plane^ plane
)
Parameters
plane(Plane)


RotateBy Method (angle, vector, point)

RotateBy Method (angle, vector, point)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »RotateBy(Double, Vector3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void RotateBy(
    double angle,
    Vector3d vector,
    Point3d point
)
Public Sub RotateBy ( _
    angle As Double, _
    vector As Vector3d, _
    point As Point3d _
)
public:
void RotateBy(
    double angle,
    Vector3d vector,
    Point3d point
)
Parameters
angle(Double)
vector(Vector3d)
point(Point3d)


ScaleBy Method (scaleFactor, point)

ScaleBy Method (scaleFactor, point)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »ScaleBy(Double, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void ScaleBy(
    double scaleFactor,
    Point3d point
)
Public Sub ScaleBy ( _
    scaleFactor As Double, _
    point As Point3d _
)
public:
void ScaleBy(
    double scaleFactor,
    Point3d point
)
Parameters
scaleFactor(Double)
point(Point3d)


TransformBy Method (transform)

TransformBy Method (transform)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »TransformBy(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public void TransformBy(
    Matrix3d transform
)
Public Sub TransformBy ( _
    transform As Matrix3d _
)
public:
void TransformBy(
    Matrix3d transform
)
Parameters
transform(Matrix3d)


TranslateBy Method (translateVector)

TranslateBy Method (translateVector)
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »TranslateBy(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void TranslateBy(
    Vector3d translateVector
)
Public Sub TranslateBy ( _
    translateVector As Vector3d _
)
public:
void TranslateBy(
    Vector3d translateVector
)
Parameters
translateVector(Vector3d)


ExternalBoundedSurface Class

ExternalBoundedSurface Class
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeExternalBoundedSurface")]
public sealed class ExternalBoundedSurface : Surface
<WrapperAttribute("ZcGeExternalBoundedSurface")> _
Public NotInheritable Class ExternalBoundedSurface _
    Inherits Surface
[WrapperAttribute(L"ZcGeExternalBoundedSurface")]
public ref class ExternalBoundedSurface sealed : public Surface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExternalBoundedSurface(IntPtr, ExternalEntityKind) |
 | ExternalBoundedSurface()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BaseSurface |
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | ExternalBaseSurface |
 | ExternalSurfaceDefinition |
 | ExternalSurfaceKind |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetContours()()()() |
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsCone |
 | IsCylinder |
 | IsDefined |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsExternalSurface |
 | IsNormalReversed | (Inherited from Surface.)
 | IsNurbs |
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsOwnerOfSurface |
 | IsPlane |
 | IsSphere |
 | IsTorus |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | NumContours |
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(IntPtr, ExternalEntityKind) |
 | SetToOwnSurface()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | ExternalBoundedSurface


ExternalBoundedSurface Constructor

ExternalBoundedSurface Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »ExternalBoundedSurface()()()()
Members
Icon | Member | Description
 | ExternalBoundedSurface(IntPtr, ExternalEntityKind) |
 | ExternalBoundedSurface()()()() |


ExternalBoundedSurface Constructor

ExternalBoundedSurface Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »ExternalBoundedSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExternalBoundedSurface()
Public Sub New
public:
ExternalBoundedSurface()


ExternalBoundedSurface Constructor (surfaceDefinition, surfaceKind)

ExternalBoundedSurface Constructor (surfaceDefinition, surfaceKind)
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »ExternalBoundedSurface(IntPtr, ExternalEntityKind)
Declaration Syntax
C# Visual Basic Visual C++
public ExternalBoundedSurface(
    IntPtr surfaceDefinition,
    ExternalEntityKind surfaceKind
)
Public Sub New ( _
    surfaceDefinition As IntPtr, _
    surfaceKind As ExternalEntityKind _
)
public:
ExternalBoundedSurface(
    IntPtr surfaceDefinition,
    ExternalEntityKind surfaceKind
)
Parameters
surfaceDefinition(IntPtr)
surfaceKind(ExternalEntityKind)


BaseSurface Property

BaseSurface Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »BaseSurface
Declaration Syntax
C# Visual Basic Visual C++
public Surface BaseSurface { get; }
Public ReadOnly Property BaseSurface As Surface
    Get
public:
property Surface^ BaseSurface {
    Surface^ get ();
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static ExternalBoundedSurface Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As ExternalBoundedSurface
public:
static ExternalBoundedSurface^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ExternalBaseSurface Property

ExternalBaseSurface Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »ExternalBaseSurface
Declaration Syntax
C# Visual Basic Visual C++
public Surface ExternalBaseSurface { get; }
Public ReadOnly Property ExternalBaseSurface As Surface
    Get
public:
property Surface^ ExternalBaseSurface {
    Surface^ get ();
}


ExternalSurfaceDefinition Property

ExternalSurfaceDefinition Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »ExternalSurfaceDefinition
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr ExternalSurfaceDefinition { get; }
Public ReadOnly Property ExternalSurfaceDefinition As IntPtr
    Get
public:
property IntPtr ExternalSurfaceDefinition {
    IntPtr get ();
}


ExternalSurfaceKind Property

ExternalSurfaceKind Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »ExternalSurfaceKind
Declaration Syntax
C# Visual Basic Visual C++
public ExternalEntityKind ExternalSurfaceKind { get; }
Public ReadOnly Property ExternalSurfaceKind As ExternalEntityKind
    Get
public:
property ExternalEntityKind ExternalSurfaceKind {
    ExternalEntityKind get ();
}


GetContours Method

GetContours Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »GetContours()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CurveBoundary[] GetContours()
Public Function GetContours As CurveBoundary()
public:
array<CurveBoundary^>^ GetContours()


IsCone Property

IsCone Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsCone
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCone { get; }
Public ReadOnly Property IsCone As Boolean
    Get
public:
property bool IsCone {
    bool get ();
}


IsCylinder Property

IsCylinder Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsCylinder
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCylinder { get; }
Public ReadOnly Property IsCylinder As Boolean
    Get
public:
property bool IsCylinder {
    bool get ();
}


IsDefined Property

IsDefined Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsDefined
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDefined { get; }
Public ReadOnly Property IsDefined As Boolean
    Get
public:
property bool IsDefined {
    bool get ();
}


IsExternalSurface Property

IsExternalSurface Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsExternalSurface
Declaration Syntax
C# Visual Basic Visual C++
public bool IsExternalSurface { get; }
Public ReadOnly Property IsExternalSurface As Boolean
    Get
public:
property bool IsExternalSurface {
    bool get ();
}


IsNurbs Property

IsNurbs Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsNurbs
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNurbs { get; }
Public ReadOnly Property IsNurbs As Boolean
    Get
public:
property bool IsNurbs {
    bool get ();
}


IsOwnerOfSurface Property

IsOwnerOfSurface Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsOwnerOfSurface
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOwnerOfSurface { get; }
Public ReadOnly Property IsOwnerOfSurface As Boolean
    Get
public:
property bool IsOwnerOfSurface {
    bool get ();
}


IsPlane Property

IsPlane Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsPlane
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPlane { get; }
Public ReadOnly Property IsPlane As Boolean
    Get
public:
property bool IsPlane {
    bool get ();
}


IsSphere Property

IsSphere Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsSphere
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSphere { get; }
Public ReadOnly Property IsSphere As Boolean
    Get
public:
property bool IsSphere {
    bool get ();
}


IsTorus Property

IsTorus Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsTorus
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTorus { get; }
Public ReadOnly Property IsTorus As Boolean
    Get
public:
property bool IsTorus {
    bool get ();
}


NumContours Property

NumContours Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »NumContours
Declaration Syntax
C# Visual Basic Visual C++
public int NumContours { get; }
Public ReadOnly Property NumContours As Integer
    Get
public:
property int NumContours {
    int get ();
}


Set Method (surfaceDef, surfaceKind)

Set Method (surfaceDef, surfaceKind)
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »Set(IntPtr, ExternalEntityKind)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    IntPtr surfaceDef,
    ExternalEntityKind surfaceKind
)
Public Sub Set ( _
    surfaceDef As IntPtr, _
    surfaceKind As ExternalEntityKind _
)
public:
void Set(
    IntPtr surfaceDef,
    ExternalEntityKind surfaceKind
)
Parameters
surfaceDef(IntPtr)
surfaceKind(ExternalEntityKind)


SetToOwnSurface Method

SetToOwnSurface Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »SetToOwnSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetToOwnSurface()
Public Sub SetToOwnSurface
public:
void SetToOwnSurface()


ExternalEntityKind Enumeration

ExternalEntityKind Enumeration
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalEntityKind
Declaration Syntax
C# Visual Basic Visual C++
public enum ExternalEntityKind
Public Enumeration ExternalEntityKind
public enum class ExternalEntityKind
Members
Member | Description
ExternalEntityUndefined |
AcisEntity |


ExternalSurface Class

ExternalSurface Class
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeExternalSurface")]
public sealed class ExternalSurface : Surface
<WrapperAttribute("ZcGeExternalSurface")> _
Public NotInheritable Class ExternalSurface _
    Inherits Surface
[WrapperAttribute(L"ZcGeExternalSurface")]
public ref class ExternalSurface sealed : public Surface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExternalSurface(IntPtr, ExternalEntityKind) |
 | ExternalSurface()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | ExternalSurfaceDefiniton |
 | ExternalSurfaceKind |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsCone |
 | IsCylinder |
 | IsDefined |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsNativeSurface |
 | IsNormalReversed | (Inherited from Surface.)
 | IsNurbSurface |
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsOwnerOfSurface |
 | IsPlane |
 | IsSphere |
 | IsTorus |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | nativeSurface |
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(IntPtr, ExternalEntityKind) |
 | SetToOwnSurface()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | ExternalSurface


ExternalSurface Constructor

ExternalSurface Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »ExternalSurface()()()()
Members
Icon | Member | Description
 | ExternalSurface(IntPtr, ExternalEntityKind) |
 | ExternalSurface()()()() |


ExternalSurface Constructor

ExternalSurface Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »ExternalSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExternalSurface()
Public Sub New
public:
ExternalSurface()


ExternalSurface Constructor (surfaceDefinition, surfaceKind)

ExternalSurface Constructor (surfaceDefinition, surfaceKind)
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »ExternalSurface(IntPtr, ExternalEntityKind)
Declaration Syntax
C# Visual Basic Visual C++
public ExternalSurface(
    IntPtr surfaceDefinition,
    ExternalEntityKind surfaceKind
)
Public Sub New ( _
    surfaceDefinition As IntPtr, _
    surfaceKind As ExternalEntityKind _
)
public:
ExternalSurface(
    IntPtr surfaceDefinition,
    ExternalEntityKind surfaceKind
)
Parameters
surfaceDefinition(IntPtr)
surfaceKind(ExternalEntityKind)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static ExternalSurface Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As ExternalSurface
public:
static ExternalSurface^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ExternalSurfaceDefiniton Property

ExternalSurfaceDefiniton Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »ExternalSurfaceDefiniton
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr ExternalSurfaceDefiniton { get; }
Public ReadOnly Property ExternalSurfaceDefiniton As IntPtr
    Get
public:
property IntPtr ExternalSurfaceDefiniton {
    IntPtr get ();
}


ExternalSurfaceKind Property

ExternalSurfaceKind Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »ExternalSurfaceKind
Declaration Syntax
C# Visual Basic Visual C++
public ExternalEntityKind ExternalSurfaceKind { get; }
Public ReadOnly Property ExternalSurfaceKind As ExternalEntityKind
    Get
public:
property ExternalEntityKind ExternalSurfaceKind {
    ExternalEntityKind get ();
}


IsCone Property

IsCone Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsCone
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCone { get; }
Public ReadOnly Property IsCone As Boolean
    Get
public:
property bool IsCone {
    bool get ();
}


IsCylinder Property

IsCylinder Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsCylinder
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCylinder { get; }
Public ReadOnly Property IsCylinder As Boolean
    Get
public:
property bool IsCylinder {
    bool get ();
}


IsDefined Property

IsDefined Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsDefined
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDefined { get; }
Public ReadOnly Property IsDefined As Boolean
    Get
public:
property bool IsDefined {
    bool get ();
}


IsNativeSurface Property

IsNativeSurface Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsNativeSurface
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNativeSurface { get; }
Public ReadOnly Property IsNativeSurface As Boolean
    Get
public:
property bool IsNativeSurface {
    bool get ();
}


IsNurbSurface Property

IsNurbSurface Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsNurbSurface
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNurbSurface { get; }
Public ReadOnly Property IsNurbSurface As Boolean
    Get
public:
property bool IsNurbSurface {
    bool get ();
}


IsOwnerOfSurface Property

IsOwnerOfSurface Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsOwnerOfSurface
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOwnerOfSurface { get; }
Public ReadOnly Property IsOwnerOfSurface As Boolean
    Get
public:
property bool IsOwnerOfSurface {
    bool get ();
}


IsPlane Property

IsPlane Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsPlane
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPlane { get; }
Public ReadOnly Property IsPlane As Boolean
    Get
public:
property bool IsPlane {
    bool get ();
}


IsSphere Property

IsSphere Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsSphere
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSphere { get; }
Public ReadOnly Property IsSphere As Boolean
    Get
public:
property bool IsSphere {
    bool get ();
}


IsTorus Property

IsTorus Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsTorus
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTorus { get; }
Public ReadOnly Property IsTorus As Boolean
    Get
public:
property bool IsTorus {
    bool get ();
}


nativeSurface Property

nativeSurface Property
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »nativeSurface
Declaration Syntax
C# Visual Basic Visual C++
public Surface nativeSurface { get; }
Public ReadOnly Property nativeSurface As Surface
    Get
public:
property Surface^ nativeSurface {
    Surface^ get ();
}


Set Method (surfaceDef, surfaceKind)

Set Method (surfaceDef, surfaceKind)
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »Set(IntPtr, ExternalEntityKind)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    IntPtr surfaceDef,
    ExternalEntityKind surfaceKind
)
Public Sub Set ( _
    surfaceDef As IntPtr, _
    surfaceKind As ExternalEntityKind _
)
public:
void Set(
    IntPtr surfaceDef,
    ExternalEntityKind surfaceKind
)
Parameters
surfaceDef(IntPtr)
surfaceKind(ExternalEntityKind)


SetToOwnSurface Method

SetToOwnSurface Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »SetToOwnSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetToOwnSurface()
Public Sub SetToOwnSurface
public:
void SetToOwnSurface()


GeoDataLonLatAltInfo Structure

GeoDataLonLatAltInfo Structure
Namespaces »ZwSoft.ZwCAD.Geometry »GeoDataLonLatAltInfo
Declaration Syntax
C# Visual Basic Visual C++
public struct GeoDataLonLatAltInfo
Public Structure GeoDataLonLatAltInfo
public value class GeoDataLonLatAltInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeoDataLonLatAltInfo(Double, Double, Double) |
 | Altitude |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Latitude |
 | Longitude |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)


GeoDataLonLatAltInfo Constructor (dbLong, dbLat, dbAlt)

GeoDataLonLatAltInfo Constructor (dbLong, dbLat, dbAlt)
Namespaces »ZwSoft.ZwCAD.Geometry »GeoDataLonLatAltInfo »GeoDataLonLatAltInfo(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public GeoDataLonLatAltInfo(
    double dbLong,
    double dbLat,
    double dbAlt
)
Public Sub New ( _
    dbLong As Double, _
    dbLat As Double, _
    dbAlt As Double _
)
public:
GeoDataLonLatAltInfo(
    double dbLong,
    double dbLat,
    double dbAlt
)
Parameters
dbLong(Double)
dbLat(Double)
dbAlt(Double)


Altitude Property

Altitude Property
Namespaces »ZwSoft.ZwCAD.Geometry »GeoDataLonLatAltInfo »Altitude
Declaration Syntax
C# Visual Basic Visual C++
public double Altitude { get; set; }
Public Property Altitude As Double
    Get
    Set
public:
property double Altitude {
    double get ();
    void set (double value);
}


Latitude Property

Latitude Property
Namespaces »ZwSoft.ZwCAD.Geometry »GeoDataLonLatAltInfo »Latitude
Declaration Syntax
C# Visual Basic Visual C++
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}


Longitude Property

Longitude Property
Namespaces »ZwSoft.ZwCAD.Geometry »GeoDataLonLatAltInfo »Longitude
Declaration Syntax
C# Visual Basic Visual C++
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}


Int32Collection Class

Int32Collection Class
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeInt32Array")]
public class Int32Collection : IList
<WrapperAttribute("ZcGeInt32Array")> _
Public Class Int32Collection _
    Implements IList
[WrapperAttribute(L"ZcGeInt32Array")]
public ref class Int32Collection : IList
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Int32Collection(Int32) |
 | Int32Collection(array<Int32>[]()[][]) |
 | Int32Collection()()()() |
 | Add(Int32) |
 | AddRange(array<Int32>[]()[][]) |
 | Capacity |
 | Clear()()()() |
 | Contains(Int32) |
 | CopyTo(array<Int32>[]()[][], Int32) |
 | Count |
 | DefaultSize |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IEnumerable_GetEnumerator()()()() |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(Int32) |
 | Insert(Int32, Int32) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Int32) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() |
Inheritance Hierarchy
Object
Int32Collection


Int32Collection Constructor

Int32Collection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Int32Collection()()()()
Members
Icon | Member | Description
 | Int32Collection(Int32) |
 | Int32Collection(array<Int32>[]()[][]) |
 | Int32Collection()()()() |


Int32Collection Constructor

Int32Collection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Int32Collection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection()
Public Sub New
public:
Int32Collection()


Int32Collection Constructor (capacity)

Int32Collection Constructor (capacity)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Int32Collection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
Int32Collection(
    int capacity
)
Parameters
capacity(Int32)


Int32Collection Constructor (values)

Int32Collection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Int32Collection(array<Int32>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection(
    int[] values
)
Public Sub New ( _
    values As Integer() _
)
public:
Int32Collection(
    array<int>^ values
)
Parameters
values(array<Int32>[]()[][])


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Add(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Add(
    int value
)
Public Overridable Function Add ( _
    value As Integer _
) As Integer
public:
virtual int Add(
    int value
)
Parameters
value(Int32)


AddRange Method (range)

AddRange Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »AddRange(array<Int32>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddRange(
    int[] range
)
Public Overridable Sub AddRange ( _
    range As Integer() _
)
public:
virtual void AddRange(
    array<int>^ range
)
Parameters
range(array<Int32>[]()[][])


Capacity Property

Capacity Property
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Capacity
Declaration Syntax
C# Visual Basic Visual C++
public int Capacity { get; set; }
Public Property Capacity As Integer
    Get
    Set
public:
property int Capacity {
    int get ();
    void set (int value);
}


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Contains(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Contains(
    int value
)
Public Overridable Function Contains ( _
    value As Integer _
) As Boolean
public:
virtual bool Contains(
    int value
)
Parameters
value(Int32)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »CopyTo(array<Int32>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyTo(
    int[] array,
    int index
)
Public Overridable Sub CopyTo ( _
    array As Integer(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<int>^ array,
    int index
)
Parameters
array(array<Int32>[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DefaultSize Field

DefaultSize Field
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »DefaultSize
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultSize
Public Const DefaultSize As Integer
public:
literal int DefaultSize


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Int32CollectionEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As Int32CollectionEnumerator
public:
virtual Int32CollectionEnumerator^ GetEnumerator()


ICollection_CopyTo Method (array, index)

ICollection_CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollection_CopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator IEnumerable_GetEnumerator()
Public Overridable Function IEnumerable_GetEnumerator As IEnumerator
public:
virtual IEnumerator^ IEnumerable_GetEnumerator()


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IList_IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IList_IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IList_Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IList_Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IndexOf(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IndexOf(
    int value
)
Public Overridable Function IndexOf ( _
    value As Integer _
) As Integer
public:
virtual int IndexOf(
    int value
)
Parameters
value(Int32)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Insert(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Insert(
    int index,
    int value
)
Public Overridable Sub Insert ( _
    index As Integer, _
    value As Integer _
)
public:
virtual void Insert(
    int index,
    int value
)
Parameters
index(Int32)
value(Int32)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public int this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Integer
    Get
    Set
public:
property int default[int index] {
    int get (int index);
    void set (int index, int value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »Remove(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Remove(
    int value
)
Public Overridable Sub Remove ( _
    value As Integer _
)
public:
virtual void Remove(
    int value
)
Parameters
value(Int32)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual int[] ToArray()
Public Overridable Function ToArray As Integer()
public:
virtual array<int>^ ToArray()


TrimToSize Method

TrimToSize Method
Namespaces »ZwSoft.ZwCAD.Geometry »Int32Collection »TrimToSize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void TrimToSize()
Public Overridable Sub TrimToSize
public:
virtual void TrimToSize()


Int32CollectionEnumerator Class

Int32CollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.Geometry »Int32CollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public class Int32CollectionEnumerator : IEnumerator
Public Class Int32CollectionEnumerator _
    Implements IEnumerator
public ref class Int32CollectionEnumerator : IEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerator_Current |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Int32CollectionEnumerator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »Int32CollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public int Current { get; }
Public ReadOnly Property Current As Integer
    Get
public:
property int Current {
    int get ();
}


IEnumerator_Current Property

IEnumerator_Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »Int32CollectionEnumerator »IEnumerator_Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object IEnumerator_Current { get; }
Public Overridable ReadOnly Property IEnumerator_Current As Object
    Get
public:
virtual property Object^ IEnumerator_Current {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.Geometry »Int32CollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.Geometry »Int32CollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


IntegerCollection Class

IntegerCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeIntArray")]
public class IntegerCollection : DisposableWrapper,
    IList
<WrapperAttribute("ZcGeIntArray")> _
Public Class IntegerCollection _
    Inherits DisposableWrapper _
    Implements IList
[WrapperAttribute(L"ZcGeIntArray")]
public ref class IntegerCollection : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntegerCollection(Int32) |
 | IntegerCollection(array<Int32>[]()[][]) |
 | IntegerCollection()()()() |
 | Add(Int32) |
 | AddRange(array<Int32>[]()[][]) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Capacity |
 | Clear()()()() |
 | Contains(Int32) |
 | CopyTo(array<Int32>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DefaultSize |
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IEnumerable..::..GetEnumerator()()()() |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(Int32) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, Int32) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Int32) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | IntegerCollection


IntegerCollection Constructor

IntegerCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IntegerCollection()()()()
Members
Icon | Member | Description
 | IntegerCollection(Int32) |
 | IntegerCollection(array<Int32>[]()[][]) |
 | IntegerCollection()()()() |


IntegerCollection Constructor

IntegerCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IntegerCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IntegerCollection()
Public Sub New
public:
IntegerCollection()


IntegerCollection Constructor (capacity)

IntegerCollection Constructor (capacity)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IntegerCollection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public IntegerCollection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
IntegerCollection(
    int capacity
)
Parameters
capacity(Int32)


IntegerCollection Constructor (values)

IntegerCollection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IntegerCollection(array<Int32>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public IntegerCollection(
    int[] values
)
Public Sub New ( _
    values As Integer() _
)
public:
IntegerCollection(
    array<int>^ values
)
Parameters
values(array<Int32>[]()[][])


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »Add(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Add(
    int value
)
Public Overridable Function Add ( _
    value As Integer _
) As Integer
public:
virtual int Add(
    int value
)
Parameters
value(Int32)


AddRange Method (range)

AddRange Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »AddRange(array<Int32>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddRange(
    int[] range
)
Public Overridable Sub AddRange ( _
    range As Integer() _
)
public:
virtual void AddRange(
    array<int>^ range
)
Parameters
range(array<Int32>[]()[][])


Capacity Property

Capacity Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »Capacity
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »Contains(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Contains(
    int value
)
Public Overridable Function Contains ( _
    value As Integer _
) As Boolean
public:
virtual bool Contains(
    int value
)
Parameters
value(Int32)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »CopyTo(array<Int32>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyTo(
    int[] array,
    int index
)
Public Overridable Sub CopyTo ( _
    array As Integer(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<int>^ array,
    int index
)
Parameters
array(array<Int32>[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DefaultSize Field

DefaultSize Field
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »DefaultSize
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultSize
Public Const DefaultSize As Integer
public:
literal int DefaultSize


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override sealed void DeleteUnmanagedObject()
Protected Overrides NotOverridable Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override sealed


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntegerCollectionEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IntegerCollectionEnumerator
public:
virtual IntegerCollectionEnumerator^ GetEnumerator()


ICollection_CopyTo Method (array, index)

ICollection_CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollection_CopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IEnumerable..::..GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
IEnumerator IEnumerable.GetEnumerator()
Private Function IEnumerable_GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ IEnumerable_GetEnumerator() sealed = IEnumerable::GetEnumerator


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IList_IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IList_IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IList_Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IList_Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IndexOf(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IndexOf(
    int value
)
Public Overridable Function IndexOf ( _
    value As Integer _
) As Integer
public:
virtual int IndexOf(
    int value
)
Parameters
value(Int32)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »Insert(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Insert(
    int index,
    int value
)
Public Overridable Sub Insert ( _
    index As Integer, _
    value As Integer _
)
public:
virtual void Insert(
    int index,
    int value
)
Parameters
index(Int32)
value(Int32)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public virtual int this[
    int index
] { get; set; }
Public Overridable Default Property Item ( _
    index As Integer _
) As Integer
    Get
    Set
public:
virtual property int default[int index] {
    int get (int index);
    void set (int index, int value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »Remove(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Remove(
    int value
)
Public Overridable Sub Remove ( _
    value As Integer _
)
public:
virtual void Remove(
    int value
)
Parameters
value(Int32)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual int[] ToArray()
Public Overridable Function ToArray As Integer()
public:
virtual array<int>^ ToArray()


TrimToSize Method

TrimToSize Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »TrimToSize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void TrimToSize()
Public Overridable Sub TrimToSize
public:
virtual void TrimToSize()


IntegerCollectionEnumerator Class

IntegerCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public sealed class IntegerCollectionEnumerator : IEnumerator
Public NotInheritable Class IntegerCollectionEnumerator _
    Implements IEnumerator
public ref class IntegerCollectionEnumerator sealed : IEnumerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntegerCollectionEnumerator(IntegerCollection) |
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerator_Current |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
IntegerCollectionEnumerator


IntegerCollectionEnumerator Constructor (col)

IntegerCollectionEnumerator Constructor (col)
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollectionEnumerator »IntegerCollectionEnumerator(IntegerCollection)
Declaration Syntax
C# Visual Basic Visual C++
public IntegerCollectionEnumerator(
    IntegerCollection col
)
Public Sub New ( _
    col As IntegerCollection _
)
public:
IntegerCollectionEnumerator(
    IntegerCollection^ col
)
Parameters
col(IntegerCollection)


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public int Current { get; }
Public ReadOnly Property Current As Integer
    Get
public:
property int Current {
    int get ();
}


IEnumerator_Current Property

IEnumerator_Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollectionEnumerator »IEnumerator_Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object IEnumerator_Current { get; }
Public Overridable ReadOnly Property IEnumerator_Current As Object
    Get
public:
virtual property Object^ IEnumerator_Current {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


Interval Class

Interval Class
Namespaces »ZwSoft.ZwCAD.Geometry »Interval
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeInterval")]
public sealed class Interval : DisposableWrapper
<WrapperAttribute("ZcGeInterval")> _
Public NotInheritable Class Interval _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcGeInterval")]
public ref class Interval sealed : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Interval(Int32, Double, Double) |
 | Interval(Double, Double, Double) |
 | Interval(Double) |
 | Interval(Interval) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Contains(Double) |
 | Contains(Interval) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Element |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetBounds()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetMerge(Interval) |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Interval) |
 | IsBounded |
 | IsBoundedAbove |
 | IsBoundedBelow |
 | IsContinuousAtUpper(Interval) |
 | IsDisjoint(Interval) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualAtLower(Double) |
 | IsEqualAtLower(Interval) |
 | IsEqualAtUpper(Double) |
 | IsEqualAtUpper(Interval) |
 | IsOverlapAtUpper(Interval, Interval) |
 | IsPeriodicallyOn(Double, Double%) |
 | IsSingleton |
 | IsUnbounded |
 | Length |
 | LowerBound |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Subtract(Interval) |
 | Tolerance |
 | ToString()()()() | (Inherited from Object.)
 | Unbounded |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpperBound |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Interval


Interval Constructor

Interval Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Interval()()()()
Members
Icon | Member | Description
 | Interval(Int32, Double, Double) |
 | Interval(Double, Double, Double) |
 | Interval(Double) |
 | Interval(Interval) |


Interval Constructor (tolerance)

Interval Constructor (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Interval(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Interval(
    double tolerance
)
Public Sub New ( _
    tolerance As Double _
)
public:
Interval(
    double tolerance
)
Parameters
tolerance(Double)


Interval Constructor (lower, upper, tolerance)

Interval Constructor (lower, upper, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Interval(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Interval(
    double lower,
    double upper,
    double tolerance
)
Public Sub New ( _
    lower As Double, _
    upper As Double, _
    tolerance As Double _
)
public:
Interval(
    double lower,
    double upper,
    double tolerance
)
Parameters
lower(Double)
upper(Double)
tolerance(Double)


Interval Constructor (boundedBelow, bound, tolerance)

Interval Constructor (boundedBelow, bound, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Interval(Int32, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Interval(
    int boundedBelow,
    double bound,
    double tolerance
)
Public Sub New ( _
    boundedBelow As Integer, _
    bound As Double, _
    tolerance As Double _
)
public:
Interval(
    int boundedBelow,
    double bound,
    double tolerance
)
Parameters
boundedBelow(Int32)
bound(Double)
tolerance(Double)


Interval Constructor (other)

Interval Constructor (other)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Interval(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public Interval(
    Interval other
)
Public Sub New ( _
    other As Interval _
)
public:
Interval(
    Interval^ other
)
Parameters
other(Interval)


Contains Method

Contains Method
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Contains()()()()
Members
Icon | Member | Description
 | Contains(Double) |
 | Contains(Interval) |


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Contains(Double)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    double value
)
Public Function Contains ( _
    value As Double _
) As Boolean
public:
bool Contains(
    double value
)
Parameters
value(Double)


Contains Method (otherInterval)

Contains Method (otherInterval)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Contains(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Interval otherInterval
)
Public Function Contains ( _
    otherInterval As Interval _
) As Boolean
public:
bool Contains(
    Interval^ otherInterval
)
Parameters
otherInterval(Interval)


Element Property

Element Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Element
Declaration Syntax
C# Visual Basic Visual C++
public double Element { get; }
Public ReadOnly Property Element As Double
    Get
public:
property double Element {
    double get ();
}


GetBounds Method

GetBounds Method
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »GetBounds()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] GetBounds()
Public Function GetBounds As Double()
public:
array<double>^ GetBounds()


GetMerge Method (otherInterval)

GetMerge Method (otherInterval)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »GetMerge(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public Interval GetMerge(
    Interval otherInterval
)
Public Function GetMerge ( _
    otherInterval As Interval _
) As Interval
public:
Interval^ GetMerge(
    Interval^ otherInterval
)
Parameters
otherInterval(Interval)


IntersectWith Method (otherInterval)

IntersectWith Method (otherInterval)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IntersectWith(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public Interval IntersectWith(
    Interval otherInterval
)
Public Function IntersectWith ( _
    otherInterval As Interval _
) As Interval
public:
Interval^ IntersectWith(
    Interval^ otherInterval
)
Parameters
otherInterval(Interval)


IsBounded Property

IsBounded Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsBounded
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBounded { get; }
Public ReadOnly Property IsBounded As Boolean
    Get
public:
property bool IsBounded {
    bool get ();
}


IsBoundedAbove Property

IsBoundedAbove Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsBoundedAbove
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBoundedAbove { get; }
Public ReadOnly Property IsBoundedAbove As Boolean
    Get
public:
property bool IsBoundedAbove {
    bool get ();
}


IsBoundedBelow Property

IsBoundedBelow Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsBoundedBelow
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBoundedBelow { get; }
Public ReadOnly Property IsBoundedBelow As Boolean
    Get
public:
property bool IsBoundedBelow {
    bool get ();
}


IsContinuousAtUpper Method (otherInterval)

IsContinuousAtUpper Method (otherInterval)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsContinuousAtUpper(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsContinuousAtUpper(
    Interval otherInterval
)
Public Function IsContinuousAtUpper ( _
    otherInterval As Interval _
) As Boolean
public:
bool IsContinuousAtUpper(
    Interval^ otherInterval
)
Parameters
otherInterval(Interval)


IsDisjoint Method (otherInterval)

IsDisjoint Method (otherInterval)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsDisjoint(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDisjoint(
    Interval otherInterval
)
Public Function IsDisjoint ( _
    otherInterval As Interval _
) As Boolean
public:
bool IsDisjoint(
    Interval^ otherInterval
)
Parameters
otherInterval(Interval)


IsEqualAtLower Method

IsEqualAtLower Method
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsEqualAtLower()()()()
Members
Icon | Member | Description
 | IsEqualAtLower(Double) |
 | IsEqualAtLower(Interval) |


IsEqualAtLower Method (value)

IsEqualAtLower Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsEqualAtLower(Double)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualAtLower(
    double value
)
Public Function IsEqualAtLower ( _
    value As Double _
) As Boolean
public:
bool IsEqualAtLower(
    double value
)
Parameters
value(Double)


IsEqualAtLower Method (otherInterval)

IsEqualAtLower Method (otherInterval)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsEqualAtLower(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualAtLower(
    Interval otherInterval
)
Public Function IsEqualAtLower ( _
    otherInterval As Interval _
) As Boolean
public:
bool IsEqualAtLower(
    Interval^ otherInterval
)
Parameters
otherInterval(Interval)


IsEqualAtUpper Method

IsEqualAtUpper Method
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsEqualAtUpper()()()()
Members
Icon | Member | Description
 | IsEqualAtUpper(Double) |
 | IsEqualAtUpper(Interval) |


IsEqualAtUpper Method (value)

IsEqualAtUpper Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsEqualAtUpper(Double)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualAtUpper(
    double value
)
Public Function IsEqualAtUpper ( _
    value As Double _
) As Boolean
public:
bool IsEqualAtUpper(
    double value
)
Parameters
value(Double)


IsEqualAtUpper Method (otherInterval)

IsEqualAtUpper Method (otherInterval)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsEqualAtUpper(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualAtUpper(
    Interval otherInterval
)
Public Function IsEqualAtUpper ( _
    otherInterval As Interval _
) As Boolean
public:
bool IsEqualAtUpper(
    Interval^ otherInterval
)
Parameters
otherInterval(Interval)


IsOverlapAtUpper Method (otherInterval, overlap)

IsOverlapAtUpper Method (otherInterval, overlap)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsOverlapAtUpper(Interval, Interval)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOverlapAtUpper(
    Interval otherInterval,
    Interval overlap
)
Public Function IsOverlapAtUpper ( _
    otherInterval As Interval, _
    overlap As Interval _
) As Boolean
public:
bool IsOverlapAtUpper(
    Interval^ otherInterval,
    Interval^ overlap
)
Parameters
otherInterval(Interval)
overlap(Interval)


IsPeriodicallyOn Method (period, value)

IsPeriodicallyOn Method (period, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsPeriodicallyOn(Double, Double%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPeriodicallyOn(
    double period,
    out double value
)
Public Function IsPeriodicallyOn ( _
    period As Double, _
    <OutAttribute> ByRef value As Double _
) As Boolean
public:
bool IsPeriodicallyOn(
    double period,
    [OutAttribute] double% value
)
Parameters
period(Double)
value(Double%)


IsSingleton Property

IsSingleton Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsSingleton
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSingleton { get; }
Public ReadOnly Property IsSingleton As Boolean
    Get
public:
property bool IsSingleton {
    bool get ();
}


IsUnbounded Property

IsUnbounded Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »IsUnbounded
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUnbounded { get; }
Public ReadOnly Property IsUnbounded As Boolean
    Get
public:
property bool IsUnbounded {
    bool get ();
}


Length Property

Length Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Length
Declaration Syntax
C# Visual Basic Visual C++
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}


LowerBound Property

LowerBound Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »LowerBound
Declaration Syntax
C# Visual Basic Visual C++
public double LowerBound { get; }
Public ReadOnly Property LowerBound As Double
    Get
public:
property double LowerBound {
    double get ();
}


Subtract Method (otherInterval)

Subtract Method (otherInterval)
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Subtract(Interval)
Declaration Syntax
C# Visual Basic Visual C++
public Interval[] Subtract(
    Interval otherInterval
)
Public Function Subtract ( _
    otherInterval As Interval _
) As Interval()
public:
array<Interval^>^ Subtract(
    Interval^ otherInterval
)
Parameters
otherInterval(Interval)


Tolerance Property

Tolerance Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Tolerance
Declaration Syntax
C# Visual Basic Visual C++
public double Tolerance { get; }
Public ReadOnly Property Tolerance As Double
    Get
public:
property double Tolerance {
    double get ();
}


Unbounded Property

Unbounded Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Unbounded
Declaration Syntax
C# Visual Basic Visual C++
public static Interval Unbounded { get; }
Public Shared ReadOnly Property Unbounded As Interval
    Get
public:
static property Interval^ Unbounded {
    Interval^ get ();
}


UpperBound Property

UpperBound Property
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »UpperBound
Declaration Syntax
C# Visual Basic Visual C++
public double UpperBound { get; }
Public ReadOnly Property UpperBound As Double
    Get
public:
property double UpperBound {
    double get ();
}


IntPtrCollection Class

IntPtrCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeIntPtrArray")]
public class IntPtrCollection : IList
<WrapperAttribute("ZcGeIntPtrArray")> _
Public Class IntPtrCollection _
    Implements IList
[WrapperAttribute(L"ZcGeIntPtrArray")]
public ref class IntPtrCollection : IList
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntPtrCollection(Int32) |
 | IntPtrCollection(array<IntPtr>[]()[][]) |
 | IntPtrCollection()()()() |
 | Add(IntPtr) |
 | AddRange(array<IntPtr>[]()[][]) |
 | Capacity |
 | Clear()()()() |
 | Contains(IntPtr) |
 | CopyTo(array<IntPtr>[]()[][], Int32) |
 | Count |
 | DefaultSize |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IEnumerable_GetEnumerator()()()() |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(IntPtr) |
 | Insert(Int32, IntPtr) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(IntPtr) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() |
Inheritance Hierarchy
Object
IntPtrCollection


IntPtrCollection Constructor

IntPtrCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IntPtrCollection()()()()
Members
Icon | Member | Description
 | IntPtrCollection(Int32) |
 | IntPtrCollection(array<IntPtr>[]()[][]) |
 | IntPtrCollection()()()() |


IntPtrCollection Constructor

IntPtrCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IntPtrCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IntPtrCollection()
Public Sub New
public:
IntPtrCollection()


IntPtrCollection Constructor (capacity)

IntPtrCollection Constructor (capacity)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IntPtrCollection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public IntPtrCollection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
IntPtrCollection(
    int capacity
)
Parameters
capacity(Int32)


IntPtrCollection Constructor (values)

IntPtrCollection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IntPtrCollection(array<IntPtr>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public IntPtrCollection(
    IntPtr[] values
)
Public Sub New ( _
    values As IntPtr() _
)
public:
IntPtrCollection(
    array<IntPtr>^ values
)
Parameters
values(array<IntPtr>[]()[][])


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »Add(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Add(
    IntPtr value
)
Public Overridable Function Add ( _
    value As IntPtr _
) As Integer
public:
virtual int Add(
    IntPtr value
)
Parameters
value(IntPtr)


AddRange Method (range)

AddRange Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »AddRange(array<IntPtr>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddRange(
    IntPtr[] range
)
Public Overridable Sub AddRange ( _
    range As IntPtr() _
)
public:
virtual void AddRange(
    array<IntPtr>^ range
)
Parameters
range(array<IntPtr>[]()[][])


Capacity Property

Capacity Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »Capacity
Declaration Syntax
C# Visual Basic Visual C++
public int Capacity { get; set; }
Public Property Capacity As Integer
    Get
    Set
public:
property int Capacity {
    int get ();
    void set (int value);
}


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »Contains(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Contains(
    IntPtr value
)
Public Overridable Function Contains ( _
    value As IntPtr _
) As Boolean
public:
virtual bool Contains(
    IntPtr value
)
Parameters
value(IntPtr)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »CopyTo(array<IntPtr>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyTo(
    IntPtr[] array,
    int index
)
Public Overridable Sub CopyTo ( _
    array As IntPtr(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<IntPtr>^ array,
    int index
)
Parameters
array(array<IntPtr>[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DefaultSize Field

DefaultSize Field
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »DefaultSize
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultSize
Public Const DefaultSize As Integer
public:
literal int DefaultSize


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtrCollectionEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IntPtrCollectionEnumerator
public:
virtual IntPtrCollectionEnumerator^ GetEnumerator()


ICollection_CopyTo Method (array, index)

ICollection_CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollection_CopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator IEnumerable_GetEnumerator()
Public Overridable Function IEnumerable_GetEnumerator As IEnumerator
public:
virtual IEnumerator^ IEnumerable_GetEnumerator()


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IList_IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IList_IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IList_Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IList_Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IndexOf(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IndexOf(
    IntPtr value
)
Public Overridable Function IndexOf ( _
    value As IntPtr _
) As Integer
public:
virtual int IndexOf(
    IntPtr value
)
Parameters
value(IntPtr)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »Insert(Int32, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Insert(
    int index,
    IntPtr value
)
Public Overridable Sub Insert ( _
    index As Integer, _
    value As IntPtr _
)
public:
virtual void Insert(
    int index,
    IntPtr value
)
Parameters
index(Int32)
value(IntPtr)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As IntPtr
    Get
    Set
public:
property IntPtr default[int index] {
    IntPtr get (int index);
    void set (int index, IntPtr value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »Remove(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Remove(
    IntPtr value
)
Public Overridable Sub Remove ( _
    value As IntPtr _
)
public:
virtual void Remove(
    IntPtr value
)
Parameters
value(IntPtr)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtr[] ToArray()
Public Overridable Function ToArray As IntPtr()
public:
virtual array<IntPtr>^ ToArray()


TrimToSize Method

TrimToSize Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollection »TrimToSize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void TrimToSize()
Public Overridable Sub TrimToSize
public:
virtual void TrimToSize()


IntPtrCollectionEnumerator Class

IntPtrCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public class IntPtrCollectionEnumerator : IEnumerator
Public Class IntPtrCollectionEnumerator _
    Implements IEnumerator
public ref class IntPtrCollectionEnumerator : IEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerator_Current |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
IntPtrCollectionEnumerator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr Current { get; }
Public ReadOnly Property Current As IntPtr
    Get
public:
property IntPtr Current {
    IntPtr get ();
}


IEnumerator_Current Property

IEnumerator_Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollectionEnumerator »IEnumerator_Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object IEnumerator_Current { get; }
Public Overridable ReadOnly Property IEnumerator_Current As Object
    Get
public:
virtual property Object^ IEnumerator_Current {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntPtrCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


KnotCollection Class

KnotCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcGeKnotVector")]
public sealed class KnotCollection : DisposableWrapper,
    IList
<WrapperAttribute("AcGeKnotVector")> _
Public NotInheritable Class KnotCollection _
    Inherits DisposableWrapper _
    Implements IList
[WrapperAttribute(L"AcGeKnotVector")]
public ref class KnotCollection sealed : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KnotCollection()()()() |
 | Add(Double) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(Double) |
 | CopyTo(array<Double>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndParameter |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetDistinctKnots()()()() |
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval(Int32, Double, Interval%) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetMultiplicityAt(Int32) |
 | GetType()()()() | (Inherited from Object.)
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..IndexOf(Object) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, Double) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsFixedSize |
 | IsOn(Double) |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfIntervals |
 | IList..::..Remove(Object) |
 | RemoveAt(Int32) |
 | Reverse()()()() |
 | SetRange(Double, Double) |
 | Split(Double, Int32, Int32) |
 | StartParameter |
 | SyncRoot |
 | Tolerance |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | KnotCollection


KnotCollection Constructor

KnotCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »KnotCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public KnotCollection()
Public Sub New
public:
KnotCollection()


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »Add(Double)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    double value
)
Public Function Add ( _
    value As Double _
) As Integer
public:
int Add(
    double value
)
Parameters
value(Double)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »Contains(Double)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    double value
)
Public Function Contains ( _
    value As Double _
) As Boolean
public:
bool Contains(
    double value
)
Parameters
value(Double)


CopyTo Method (a, index)

CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »CopyTo(array<Double>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    double[] a,
    int index
)
Public Sub CopyTo ( _
    a As Double(), _
    index As Integer _
)
public:
void CopyTo(
    array<double>^ a,
    int index
)
Parameters
a(array<Double>[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


EndParameter Property

EndParameter Property
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »EndParameter
Declaration Syntax
C# Visual Basic Visual C++
public double EndParameter { get; }
Public ReadOnly Property EndParameter As Double
    Get
public:
property double EndParameter {
    double get ();
}


GetDistinctKnots Method

GetDistinctKnots Method
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »GetDistinctKnots()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetDistinctKnots()
Public Function GetDistinctKnots As DoubleCollection
public:
DoubleCollection^ GetDistinctKnots()


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


GetInterval Method (order, parameter, interval)

GetInterval Method (order, parameter, interval)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »GetInterval(Int32, Double, Interval%)
Declaration Syntax
C# Visual Basic Visual C++
public int GetInterval(
    int order,
    double parameter,
    out Interval interval
)
Public Function GetInterval ( _
    order As Integer, _
    parameter As Double, _
    <OutAttribute> ByRef interval As Interval _
) As Integer
public:
int GetInterval(
    int order,
    double parameter,
    [OutAttribute] Interval^% interval
)
Parameters
order(Int32)
parameter(Double)
interval(Interval %)


GetMultiplicityAt Method (i)

GetMultiplicityAt Method (i)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »GetMultiplicityAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int GetMultiplicityAt(
    int i
)
Public Function GetMultiplicityAt ( _
    i As Integer _
) As Integer
public:
int GetMultiplicityAt(
    int i
)
Parameters
i(Int32)


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IList_CopyTo Method (a, index)

IList_CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array a,
    int index
)
Private Sub IList_CopyTo ( _
    a As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void IList_CopyTo(
    Array^ a,
    int index
) sealed = ICollection::CopyTo
Parameters
a(Array)
index(Int32)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »Insert(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    double value
)
Public Sub Insert ( _
    index As Integer, _
    value As Double _
)
public:
void Insert(
    int index,
    double value
)
Parameters
index(Int32)
value(Double)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsOn Method (knot)

IsOn Method (knot)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »IsOn(Double)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    double knot
)
Public Function IsOn ( _
    knot As Double _
) As Boolean
public:
bool IsOn(
    double knot
)
Parameters
knot(Double)


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property ()

Item Property ()
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int
] { get; set; }
Public Default Property Item ( _
     As Integer _
) As Double
    Get
    Set
public:
property double default[int ] {
    double get (int );
    void set (int , double value);
}
Parameters
(Int32)


NumberOfIntervals Property

NumberOfIntervals Property
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »NumberOfIntervals
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfIntervals { get; }
Public ReadOnly Property NumberOfIntervals As Integer
    Get
public:
property int NumberOfIntervals {
    int get ();
}


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


Reverse Method

Reverse Method
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »Reverse()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reverse()
Public Sub Reverse
public:
void Reverse()


SetRange Method (lower, upper)

SetRange Method (lower, upper)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »SetRange(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetRange(
    double lower,
    double upper
)
Public Sub SetRange ( _
    lower As Double, _
    upper As Double _
)
public:
void SetRange(
    double lower,
    double upper
)
Parameters
lower(Double)
upper(Double)


Split Method (parameter, multiplicityLast, multiplicityFirst)

Split Method (parameter, multiplicityLast, multiplicityFirst)
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »Split(Double, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public KnotCollection[] Split(
    double parameter,
    int multiplicityLast,
    int multiplicityFirst
)
Public Function Split ( _
    parameter As Double, _
    multiplicityLast As Integer, _
    multiplicityFirst As Integer _
) As KnotCollection()
public:
array<KnotCollection^>^ Split(
    double parameter,
    int multiplicityLast,
    int multiplicityFirst
)
Parameters
parameter(Double)
multiplicityLast(Int32)
multiplicityFirst(Int32)


StartParameter Property

StartParameter Property
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »StartParameter
Declaration Syntax
C# Visual Basic Visual C++
public double StartParameter { get; }
Public ReadOnly Property StartParameter As Double
    Get
public:
property double StartParameter {
    double get ();
}


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


Tolerance Property

Tolerance Property
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »Tolerance
Declaration Syntax
C# Visual Basic Visual C++
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set
public:
property double Tolerance {
    double get ();
    void set (double value);
}


KnotParameterizationEnum Enumeration

KnotParameterizationEnum Enumeration
Namespaces »ZwSoft.ZwCAD.Geometry »KnotParameterizationEnum
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGe::SubentType")]
public enum KnotParameterizationEnum
<WrapperAttribute("ZcGe::SubentType")> _
Public Enumeration KnotParameterizationEnum
[WrapperAttribute(L"ZcGe::SubentType")]
public enum class KnotParameterizationEnum
Members
Member | Description
Uniform |
SqrtChord |
CustomParameterization |
Chord |


Line2d Class

Line2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeLine2d")]
public sealed class Line2d : LinearEntity2d
<WrapperAttribute("ZcGeLine2d")> _
Public NotInheritable Class Line2d _
    Inherits LinearEntity2d
[WrapperAttribute(L"ZcGeLine2d")]
public ref class Line2d sealed : public LinearEntity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Line2d(Point2d, Vector2d) |
 | Line2d(Point2d, Point2d) |
 | Line2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Direction | (Inherited from LinearEntity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint | (Inherited from Curve2d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLine()()()() | (Inherited from LinearEntity2d.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetPerpendicularLine(Point2d) | (Inherited from LinearEntity2d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IntersectWith(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsColinearTo(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IsColinearTo(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsParallelTo(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IsParallelTo(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | IsPerpendicularTo(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IsPerpendicularTo(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | Overlap(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | Overlap(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | PointOnLine | (Inherited from LinearEntity2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | Set(Point2d, Vector2d) |
 | Set(Point2d, Point2d) |
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | StartPoint | (Inherited from Curve2d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | LinearEntity2d
 |  |  |  |  |  | Line2d


Line2d Constructor

Line2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »Line2d()()()()
Members
Icon | Member | Description
 | Line2d(Point2d, Vector2d) |
 | Line2d(Point2d, Point2d) |
 | Line2d()()()() |


Line2d Constructor

Line2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »Line2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Line2d()
Public Sub New
public:
Line2d()


Line2d Constructor (point1, point2)

Line2d Constructor (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »Line2d(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Line2d(
    Point2d point1,
    Point2d point2
)
Public Sub New ( _
    point1 As Point2d, _
    point2 As Point2d _
)
public:
Line2d(
    Point2d point1,
    Point2d point2
)
Parameters
point1(Point2d)
point2(Point2d)


Line2d Constructor (point, vector)

Line2d Constructor (point, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »Line2d(Point2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public Line2d(
    Point2d point,
    Vector2d vector
)
Public Sub New ( _
    point As Point2d, _
    vector As Vector2d _
)
public:
Line2d(
    Point2d point,
    Vector2d vector
)
Parameters
point(Point2d)
vector(Vector2d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Line2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Line2d
public:
static Line2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »Set()()()()
Members
Icon | Member | Description
 | Set(Point2d, Vector2d) |
 | Set(Point2d, Point2d) |


Set Method (point1, point2)

Set Method (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »Set(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d point1,
    Point2d point2
)
Public Sub Set ( _
    point1 As Point2d, _
    point2 As Point2d _
)
public:
void Set(
    Point2d point1,
    Point2d point2
)
Parameters
point1(Point2d)
point2(Point2d)


Set Method (point, vector)

Set Method (point, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »Set(Point2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d point,
    Vector2d vector
)
Public Sub Set ( _
    point As Point2d, _
    vector As Vector2d _
)
public:
void Set(
    Point2d point,
    Vector2d vector
)
Parameters
point(Point2d)
vector(Vector2d)


Line2dCollection Class

Line2dCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Line2dCollection : IList
Public NotInheritable Class Line2dCollection _
    Implements IList
public ref class Line2dCollection sealed : IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Line2dCollection()()()() |
 | IList..::..Add(Object) |
 | Add(Line2d) |
 | Clear()()()() |
 | IList..::..Contains(Object) |
 | Contains(Line2d) |
 | CopyTo(array<Line2d>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IList..::..Item[([( Int32])]) |
 | IList..::..IndexOf(Object) |
 | IndexOf(Line2d) |
 | IList..::..Insert(Int32, Object) |
 | Insert(Int32, Line2d) |
 | IList..::..IsFixedSize |
 | IList..::..IsReadOnly |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | IList..::..Remove(Object) |
 | Remove(Line2d) |
 | RemoveAt(Int32) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Line2dCollection


Line2dCollection Constructor

Line2dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Line2dCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Line2dCollection()
Public Sub New
public:
Line2dCollection()


Add Method

Add Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Add()()()()
Members
Icon | Member | Description
 | IList..::..Add(Object) |
 | Add(Line2d) |


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Add(Line2d)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Line2d value
)
Public Function Add ( _
    value As Line2d _
) As Integer
public:
int Add(
    Line2d^ value
)
Parameters
value(Line2d)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method

Contains Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Contains()()()()
Members
Icon | Member | Description
 | IList..::..Contains(Object) |
 | Contains(Line2d) |


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Contains(Line2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Line2d value
)
Public Function Contains ( _
    value As Line2d _
) As Boolean
public:
bool Contains(
    Line2d^ value
)
Parameters
value(Line2d)


CopyTo Method

CopyTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<Line2d>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub CopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void CopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »CopyTo(array<Line2d>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Line2d[] array,
    int index
)
Public Sub CopyTo ( _
    array As Line2d(), _
    index As Integer _
)
public:
void CopyTo(
    array<Line2d^>^ array,
    int index
)
Parameters
array(array< Line2d >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


Ilist_Item Property (index)

Ilist_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property Ilist_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ Ilist_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IndexOf Method

IndexOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »IndexOf()()()()
Members
Icon | Member | Description
 | IList..::..IndexOf(Object) |
 | IndexOf(Line2d) |


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »IndexOf(Line2d)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Line2d value
)
Public Function IndexOf ( _
    value As Line2d _
) As Integer
public:
int IndexOf(
    Line2d^ value
)
Parameters
value(Line2d)


Insert Method

Insert Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Insert()()()()
Members
Icon | Member | Description
 | IList..::..Insert(Int32, Object) |
 | Insert(Int32, Line2d) |


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Insert(Int32, Line2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Line2d value
)
Public Sub Insert ( _
    index As Integer, _
    value As Line2d _
)
public:
void Insert(
    int index,
    Line2d^ value
)
Parameters
index(Int32)
value(Line2d)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »IList..::..IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
bool IList.IsFixedSize { get; }
Private ReadOnly Property IsFixedSize As Boolean
    Implements IList.IsFixedSize
    Get
private:
virtual property bool IsFixedSize {
    bool get () sealed = IList::IsFixedSize::get;
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »IList..::..IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
bool IList.IsReadOnly { get; }
Private ReadOnly Property IsReadOnly As Boolean
    Implements IList.IsReadOnly
    Get
private:
virtual property bool IsReadOnly {
    bool get () sealed = IList::IsReadOnly::get;
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Line2d this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Line2d
    Get
    Set
public:
property Line2d^ default[int index] {
    Line2d^ get (int index);
    void set (int index, Line2d^ value);
}
Parameters
index(Int32)


Remove Method

Remove Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Remove()()()()
Members
Icon | Member | Description
 | IList..::..Remove(Object) |
 | Remove(Line2d) |


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »Remove(Line2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Line2d value
)
Public Sub Remove ( _
    value As Line2d _
)
public:
void Remove(
    Line2d^ value
)
Parameters
value(Line2d)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »Line2dCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


Line3d Class

Line3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeLine3d")]
public sealed class Line3d : LinearEntity3d
<WrapperAttribute("ZcGeLine3d")> _
Public NotInheritable Class Line3d _
    Inherits LinearEntity3d
[WrapperAttribute(L"ZcGeLine3d")]
public ref class Line3d sealed : public LinearEntity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Line3d(Point3d, Vector3d) |
 | Line3d(Point3d, Point3d) |
 | Line3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Direction | (Inherited from LinearEntity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint | (Inherited from Curve3d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLine()()()() | (Inherited from LinearEntity3d.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetPerpendicularPlane(Point3d) | (Inherited from LinearEntity3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.)
 | IntersectWith(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IntersectWith(PlanarEntity) | (Inherited from LinearEntity3d.)
 | IntersectWith(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsColinearTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IsColinearTo(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Plane, Tolerance) | (Inherited from LinearEntity3d.)
 | IsOn(Plane) | (Inherited from LinearEntity3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsParallelTo(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.)
 | IsParallelTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IsParallelTo(PlanarEntity) | (Inherited from LinearEntity3d.)
 | IsParallelTo(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPerpendicularTo(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.)
 | IsPerpendicularTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IsPerpendicularTo(PlanarEntity) | (Inherited from LinearEntity3d.)
 | IsPerpendicularTo(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | Overlap(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | Overlap(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | PointOnLine | (Inherited from LinearEntity3d.)
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) | (Inherited from LinearEntity3d.)
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) | (Inherited from LinearEntity3d.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Point3d, Vector3d) |
 | Set(Point3d, Point3d) |
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | StartPoint | (Inherited from Curve3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | LinearEntity3d
 |  |  |  |  |  | Line3d


Line3d Constructor

Line3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »Line3d()()()()
Members
Icon | Member | Description
 | Line3d(Point3d, Vector3d) |
 | Line3d(Point3d, Point3d) |
 | Line3d()()()() |


Line3d Constructor

Line3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »Line3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Line3d()
Public Sub New
public:
Line3d()


Line3d Constructor (point1, point2)

Line3d Constructor (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »Line3d(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Line3d(
    Point3d point1,
    Point3d point2
)
Public Sub New ( _
    point1 As Point3d, _
    point2 As Point3d _
)
public:
Line3d(
    Point3d point1,
    Point3d point2
)
Parameters
point1(Point3d)
point2(Point3d)


Line3d Constructor (point, vec)

Line3d Constructor (point, vec)
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »Line3d(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Line3d(
    Point3d point,
    Vector3d vec
)
Public Sub New ( _
    point As Point3d, _
    vec As Vector3d _
)
public:
Line3d(
    Point3d point,
    Vector3d vec
)
Parameters
point(Point3d)
vec(Vector3d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Line3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Line3d
public:
static Line3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »Set()()()()
Members
Icon | Member | Description
 | Set(Point3d, Vector3d) |
 | Set(Point3d, Point3d) |


Set Method (point1, point2)

Set Method (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »Set(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d point1,
    Point3d point2
)
Public Sub Set ( _
    point1 As Point3d, _
    point2 As Point3d _
)
public:
void Set(
    Point3d point1,
    Point3d point2
)
Parameters
point1(Point3d)
point2(Point3d)


Set Method (point, vector)

Set Method (point, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »Set(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d point,
    Vector3d vector
)
Public Sub Set ( _
    point As Point3d, _
    vector As Vector3d _
)
public:
void Set(
    Point3d point,
    Vector3d vector
)
Parameters
point(Point3d)
vector(Vector3d)


LinearEntity2d Class

LinearEntity2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeLinearEntity2d")]
public abstract class LinearEntity2d : Curve2d
<WrapperAttribute("ZcGeLinearEntity2d")> _
Public MustInherit Class LinearEntity2d _
    Inherits Curve2d
[WrapperAttribute(L"ZcGeLinearEntity2d")]
public ref class LinearEntity2d abstract : public Curve2d
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Direction |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint | (Inherited from Curve2d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLine()()()() |
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetPerpendicularLine(Point2d) |
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity2d, Tolerance) |
 | IntersectWith(LinearEntity2d) |
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsColinearTo(LinearEntity2d, Tolerance) |
 | IsColinearTo(LinearEntity2d) |
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsParallelTo(LinearEntity2d, Tolerance) |
 | IsParallelTo(LinearEntity2d) |
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | IsPerpendicularTo(LinearEntity2d, Tolerance) |
 | IsPerpendicularTo(LinearEntity2d) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | Overlap(LinearEntity2d, Tolerance) |
 | Overlap(LinearEntity2d) |
 | PointOnLine |
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | StartPoint | (Inherited from Curve2d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | LinearEntity2d
 |  |  |  |  |  | Line2d
 |  |  |  |  |  | LineSegment2d
 |  |  |  |  |  | Ray2d


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static LinearEntity2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As LinearEntity2d
public:
static LinearEntity2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Direction Property

Direction Property
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »Direction
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Direction { get; }
Public ReadOnly Property Direction As Vector2d
    Get
public:
property Vector2d Direction {
    Vector2d get ();
}


GetLine Method

GetLine Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetLine()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Line2d GetLine()
Public Function GetLine As Line2d
public:
Line2d^ GetLine()


GetPerpendicularLine Method (point)

GetPerpendicularLine Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetPerpendicularLine(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Line2d GetPerpendicularLine(
    Point2d point
)
Public Function GetPerpendicularLine ( _
    point As Point2d _
) As Line2d
public:
Line2d^ GetPerpendicularLine(
    Point2d point
)
Parameters
point(Point2d)


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity2d, Tolerance) |
 | IntersectWith(LinearEntity2d) |


IntersectWith Method (line)

IntersectWith Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IntersectWith(LinearEntity2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] IntersectWith(
    LinearEntity2d line
)
Public Function IntersectWith ( _
    line As LinearEntity2d _
) As Point2d()
public:
array<Point2d>^ IntersectWith(
    LinearEntity2d^ line
)
Parameters
line(LinearEntity2d)


IntersectWith Method (line, tolerance)

IntersectWith Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IntersectWith(LinearEntity2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] IntersectWith(
    LinearEntity2d line,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    line As LinearEntity2d, _
    tolerance As Tolerance _
) As Point2d()
public:
array<Point2d>^ IntersectWith(
    LinearEntity2d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity2d)
tolerance(Tolerance)


IsColinearTo Method

IsColinearTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsColinearTo()()()()
Members
Icon | Member | Description
 | IsColinearTo(LinearEntity2d, Tolerance) |
 | IsColinearTo(LinearEntity2d) |


IsColinearTo Method (line)

IsColinearTo Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsColinearTo(LinearEntity2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsColinearTo(
    LinearEntity2d line
)
Public Function IsColinearTo ( _
    line As LinearEntity2d _
) As Boolean
public:
bool IsColinearTo(
    LinearEntity2d^ line
)
Parameters
line(LinearEntity2d)


IsColinearTo Method (line, tolerance)

IsColinearTo Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsColinearTo(LinearEntity2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsColinearTo(
    LinearEntity2d line,
    Tolerance tolerance
)
Public Function IsColinearTo ( _
    line As LinearEntity2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsColinearTo(
    LinearEntity2d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity2d)
tolerance(Tolerance)


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(LinearEntity2d, Tolerance) |
 | IsParallelTo(LinearEntity2d) |


IsParallelTo Method (line)

IsParallelTo Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsParallelTo(LinearEntity2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    LinearEntity2d line
)
Public Function IsParallelTo ( _
    line As LinearEntity2d _
) As Boolean
public:
bool IsParallelTo(
    LinearEntity2d^ line
)
Parameters
line(LinearEntity2d)


IsParallelTo Method (line, tolerance)

IsParallelTo Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsParallelTo(LinearEntity2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    LinearEntity2d line,
    Tolerance tolerance
)
Public Function IsParallelTo ( _
    line As LinearEntity2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsParallelTo(
    LinearEntity2d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity2d)
tolerance(Tolerance)


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(LinearEntity2d, Tolerance) |
 | IsPerpendicularTo(LinearEntity2d) |


IsPerpendicularTo Method (line)

IsPerpendicularTo Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsPerpendicularTo(LinearEntity2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    LinearEntity2d line
)
Public Function IsPerpendicularTo ( _
    line As LinearEntity2d _
) As Boolean
public:
bool IsPerpendicularTo(
    LinearEntity2d^ line
)
Parameters
line(LinearEntity2d)


IsPerpendicularTo Method (line, tolerance)

IsPerpendicularTo Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsPerpendicularTo(LinearEntity2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    LinearEntity2d line,
    Tolerance tolerance
)
Public Function IsPerpendicularTo ( _
    line As LinearEntity2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsPerpendicularTo(
    LinearEntity2d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity2d)
tolerance(Tolerance)


Overlap Method

Overlap Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »Overlap()()()()
Members
Icon | Member | Description
 | Overlap(LinearEntity2d, Tolerance) |
 | Overlap(LinearEntity2d) |


Overlap Method (line)

Overlap Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »Overlap(LinearEntity2d)
Declaration Syntax
C# Visual Basic Visual C++
public LinearEntity2d Overlap(
    LinearEntity2d line
)
Public Function Overlap ( _
    line As LinearEntity2d _
) As LinearEntity2d
public:
LinearEntity2d^ Overlap(
    LinearEntity2d^ line
)
Parameters
line(LinearEntity2d)


Overlap Method (line, tolerance)

Overlap Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »Overlap(LinearEntity2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public LinearEntity2d Overlap(
    LinearEntity2d line,
    Tolerance tolerance
)
Public Function Overlap ( _
    line As LinearEntity2d, _
    tolerance As Tolerance _
) As LinearEntity2d
public:
LinearEntity2d^ Overlap(
    LinearEntity2d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity2d)
tolerance(Tolerance)


PointOnLine Property

PointOnLine Property
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »PointOnLine
Declaration Syntax
C# Visual Basic Visual C++
public Point2d PointOnLine { get; }
Public ReadOnly Property PointOnLine As Point2d
    Get
public:
property Point2d PointOnLine {
    Point2d get ();
}


LinearEntity3d Class

LinearEntity3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeLinearEnt3d")]
public abstract class LinearEntity3d : Curve3d
<WrapperAttribute("ZcGeLinearEnt3d")> _
Public MustInherit Class LinearEntity3d _
    Inherits Curve3d
[WrapperAttribute(L"ZcGeLinearEnt3d")]
public ref class LinearEntity3d abstract : public Curve3d
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Direction |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint | (Inherited from Curve3d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLine()()()() |
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetPerpendicularPlane(Point3d) |
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(PlanarEntity, Tolerance) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(PlanarEntity) |
 | IntersectWith(LinearEntity3d) |
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsColinearTo(LinearEntity3d, Tolerance) |
 | IsColinearTo(LinearEntity3d) |
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Plane, Tolerance) |
 | IsOn(Plane) |
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsParallelTo(PlanarEntity, Tolerance) |
 | IsParallelTo(LinearEntity3d, Tolerance) |
 | IsParallelTo(PlanarEntity) |
 | IsParallelTo(LinearEntity3d) |
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPerpendicularTo(PlanarEntity, Tolerance) |
 | IsPerpendicularTo(LinearEntity3d, Tolerance) |
 | IsPerpendicularTo(PlanarEntity) |
 | IsPerpendicularTo(LinearEntity3d) |
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | Overlap(LinearEntity3d, Tolerance) |
 | Overlap(LinearEntity3d) |
 | PointOnLine |
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) |
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | StartPoint | (Inherited from Curve3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | LinearEntity3d
 |  |  |  |  |  | Line3d
 |  |  |  |  |  | LineSegment3d
 |  |  |  |  |  | Ray3d


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static LinearEntity3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As LinearEntity3d
public:
static LinearEntity3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Direction Property

Direction Property
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »Direction
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Direction { get; }
Public ReadOnly Property Direction As Vector3d
    Get
public:
property Vector3d Direction {
    Vector3d get ();
}


GetLine Method

GetLine Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetLine()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Line3d GetLine()
Public Function GetLine As Line3d
public:
Line3d^ GetLine()


GetPerpendicularPlane Method (intersectionPoint)

GetPerpendicularPlane Method (intersectionPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetPerpendicularPlane(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Plane GetPerpendicularPlane(
    Point3d intersectionPoint
)
Public Function GetPerpendicularPlane ( _
    intersectionPoint As Point3d _
) As Plane
public:
Plane^ GetPerpendicularPlane(
    Point3d intersectionPoint
)
Parameters
intersectionPoint(Point3d)


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(PlanarEntity, Tolerance) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(PlanarEntity) |
 | IntersectWith(LinearEntity3d) |


IntersectWith Method (line)

IntersectWith Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IntersectWith(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d line
)
Public Function IntersectWith ( _
    line As LinearEntity3d _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ line
)
Parameters
line(LinearEntity3d)


IntersectWith Method (line, tolerance)

IntersectWith Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IntersectWith(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d line,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    line As LinearEntity3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
tolerance(Tolerance)


IntersectWith Method (plane)

IntersectWith Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IntersectWith(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    PlanarEntity plane
)
Public Function IntersectWith ( _
    plane As PlanarEntity _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    PlanarEntity^ plane
)
Parameters
plane(PlanarEntity)


IntersectWith Method (plane, tolerance)

IntersectWith Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IntersectWith(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    PlanarEntity plane,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    plane As PlanarEntity, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    PlanarEntity^ plane,
    Tolerance tolerance
)
Parameters
plane(PlanarEntity)
tolerance(Tolerance)


IsColinearTo Method

IsColinearTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsColinearTo()()()()
Members
Icon | Member | Description
 | IsColinearTo(LinearEntity3d, Tolerance) |
 | IsColinearTo(LinearEntity3d) |


IsColinearTo Method (line)

IsColinearTo Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsColinearTo(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsColinearTo(
    LinearEntity3d line
)
Public Function IsColinearTo ( _
    line As LinearEntity3d _
) As Boolean
public:
bool IsColinearTo(
    LinearEntity3d^ line
)
Parameters
line(LinearEntity3d)


IsColinearTo Method (line, tolerance)

IsColinearTo Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsColinearTo(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsColinearTo(
    LinearEntity3d line,
    Tolerance tolerance
)
Public Function IsColinearTo ( _
    line As LinearEntity3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsColinearTo(
    LinearEntity3d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
tolerance(Tolerance)


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Plane, Tolerance) |
 | IsOn(Plane) |
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


IsOn Method (plane)

IsOn Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsOn(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Plane plane
)
Public Function IsOn ( _
    plane As Plane _
) As Boolean
public:
bool IsOn(
    Plane^ plane
)
Parameters
plane(Plane)


IsOn Method (plane, tolerance)

IsOn Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsOn(Plane, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Plane plane,
    Tolerance tolerance
)
Public Function IsOn ( _
    plane As Plane, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsOn(
    Plane^ plane,
    Tolerance tolerance
)
Parameters
plane(Plane)
tolerance(Tolerance)


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(PlanarEntity, Tolerance) |
 | IsParallelTo(LinearEntity3d, Tolerance) |
 | IsParallelTo(PlanarEntity) |
 | IsParallelTo(LinearEntity3d) |


IsParallelTo Method (line)

IsParallelTo Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsParallelTo(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    LinearEntity3d line
)
Public Function IsParallelTo ( _
    line As LinearEntity3d _
) As Boolean
public:
bool IsParallelTo(
    LinearEntity3d^ line
)
Parameters
line(LinearEntity3d)


IsParallelTo Method (line, tolerance)

IsParallelTo Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsParallelTo(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    LinearEntity3d line,
    Tolerance tolerance
)
Public Function IsParallelTo ( _
    line As LinearEntity3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsParallelTo(
    LinearEntity3d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
tolerance(Tolerance)


IsParallelTo Method (plane)

IsParallelTo Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsParallelTo(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    PlanarEntity plane
)
Public Function IsParallelTo ( _
    plane As PlanarEntity _
) As Boolean
public:
bool IsParallelTo(
    PlanarEntity^ plane
)
Parameters
plane(PlanarEntity)


IsParallelTo Method (plane, tolerance)

IsParallelTo Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsParallelTo(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    PlanarEntity plane,
    Tolerance tolerance
)
Public Function IsParallelTo ( _
    plane As PlanarEntity, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsParallelTo(
    PlanarEntity^ plane,
    Tolerance tolerance
)
Parameters
plane(PlanarEntity)
tolerance(Tolerance)


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(PlanarEntity, Tolerance) |
 | IsPerpendicularTo(LinearEntity3d, Tolerance) |
 | IsPerpendicularTo(PlanarEntity) |
 | IsPerpendicularTo(LinearEntity3d) |


IsPerpendicularTo Method (line)

IsPerpendicularTo Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsPerpendicularTo(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    LinearEntity3d line
)
Public Function IsPerpendicularTo ( _
    line As LinearEntity3d _
) As Boolean
public:
bool IsPerpendicularTo(
    LinearEntity3d^ line
)
Parameters
line(LinearEntity3d)


IsPerpendicularTo Method (line, tolerance)

IsPerpendicularTo Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsPerpendicularTo(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    LinearEntity3d line,
    Tolerance tolerance
)
Public Function IsPerpendicularTo ( _
    line As LinearEntity3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsPerpendicularTo(
    LinearEntity3d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
tolerance(Tolerance)


IsPerpendicularTo Method (plane)

IsPerpendicularTo Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsPerpendicularTo(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    PlanarEntity plane
)
Public Function IsPerpendicularTo ( _
    plane As PlanarEntity _
) As Boolean
public:
bool IsPerpendicularTo(
    PlanarEntity^ plane
)
Parameters
plane(PlanarEntity)


IsPerpendicularTo Method (plane, tolerance)

IsPerpendicularTo Method (plane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsPerpendicularTo(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    PlanarEntity plane,
    Tolerance tolerance
)
Public Function IsPerpendicularTo ( _
    plane As PlanarEntity, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsPerpendicularTo(
    PlanarEntity^ plane,
    Tolerance tolerance
)
Parameters
plane(PlanarEntity)
tolerance(Tolerance)


Overlap Method

Overlap Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »Overlap()()()()
Members
Icon | Member | Description
 | Overlap(LinearEntity3d, Tolerance) |
 | Overlap(LinearEntity3d) |


Overlap Method (line)

Overlap Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »Overlap(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public LinearEntity3d Overlap(
    LinearEntity3d line
)
Public Function Overlap ( _
    line As LinearEntity3d _
) As LinearEntity3d
public:
LinearEntity3d^ Overlap(
    LinearEntity3d^ line
)
Parameters
line(LinearEntity3d)


Overlap Method (line, tolerance)

Overlap Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »Overlap(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public LinearEntity3d Overlap(
    LinearEntity3d line,
    Tolerance tolerance
)
Public Function Overlap ( _
    line As LinearEntity3d, _
    tolerance As Tolerance _
) As LinearEntity3d
public:
LinearEntity3d^ Overlap(
    LinearEntity3d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
tolerance(Tolerance)


PointOnLine Property

PointOnLine Property
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »PointOnLine
Declaration Syntax
C# Visual Basic Visual C++
public Point3d PointOnLine { get; }
Public ReadOnly Property PointOnLine As Point3d
    Get
public:
property Point3d PointOnLine {
    Point3d get ();
}


ProjectedIntersectWith Method

ProjectedIntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »ProjectedIntersectWith()()()()
Members
Icon | Member | Description
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) |
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) |


ProjectedIntersectWith Method (line, projectionDirection)

ProjectedIntersectWith Method (line, projectionDirection)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »ProjectedIntersectWith(LinearEntity3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ProjectedIntersectWith(
    LinearEntity3d line,
    Vector3d projectionDirection
)
Public Function ProjectedIntersectWith ( _
    line As LinearEntity3d, _
    projectionDirection As Vector3d _
) As Point3d()
public:
array<Point3d>^ ProjectedIntersectWith(
    LinearEntity3d^ line,
    Vector3d projectionDirection
)
Parameters
line(LinearEntity3d)
projectionDirection(Vector3d)


ProjectedIntersectWith Method (line, projectionDirection, tolerance)

ProjectedIntersectWith Method (line, projectionDirection, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ProjectedIntersectWith(
    LinearEntity3d line,
    Vector3d projectionDirection,
    Tolerance tolerance
)
Public Function ProjectedIntersectWith ( _
    line As LinearEntity3d, _
    projectionDirection As Vector3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ ProjectedIntersectWith(
    LinearEntity3d^ line,
    Vector3d projectionDirection,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
projectionDirection(Vector3d)
tolerance(Tolerance)


LineSegment2d Class

LineSegment2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeLineSeg2d")]
public sealed class LineSegment2d : LinearEntity2d
<WrapperAttribute("ZcGeLineSeg2d")> _
Public NotInheritable Class LineSegment2d _
    Inherits LinearEntity2d
[WrapperAttribute(L"ZcGeLineSeg2d")]
public ref class LineSegment2d sealed : public LinearEntity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LineSegment2d(Point2d, Vector2d) |
 | LineSegment2d(Point2d, Point2d) |
 | LineSegment2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BaryComb(Double) |
 | BoundBlock | (Inherited from Curve2d.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Direction | (Inherited from LinearEntity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBisector()()()() |
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLine()()()() | (Inherited from LinearEntity2d.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetPerpendicularLine(Point2d) | (Inherited from LinearEntity2d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSegmentLength(Double, Double, Tolerance) |
 | GetSegmentLength(Double, Double) |
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IntersectWith(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsColinearTo(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IsColinearTo(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsParallelTo(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IsParallelTo(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | IsPerpendicularTo(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IsPerpendicularTo(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | Length |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MidPoint |
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | Overlap(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | Overlap(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | PointOnLine | (Inherited from LinearEntity2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | Set(Curve2d, Curve2d, Double, Double) |
 | Set(Curve2d, Point2d, Double) |
 | Set(Point2d, Vector2d) |
 | Set(Point2d, Point2d) |
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | StartPoint |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | LinearEntity2d
 |  |  |  |  |  | LineSegment2d


LineSegment2d Constructor

LineSegment2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »LineSegment2d()()()()
Members
Icon | Member | Description
 | LineSegment2d(Point2d, Vector2d) |
 | LineSegment2d(Point2d, Point2d) |
 | LineSegment2d()()()() |


LineSegment2d Constructor

LineSegment2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »LineSegment2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment2d()
Public Sub New
public:
LineSegment2d()


LineSegment2d Constructor (point1, point2)

LineSegment2d Constructor (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »LineSegment2d(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment2d(
    Point2d point1,
    Point2d point2
)
Public Sub New ( _
    point1 As Point2d, _
    point2 As Point2d _
)
public:
LineSegment2d(
    Point2d point1,
    Point2d point2
)
Parameters
point1(Point2d)
point2(Point2d)


LineSegment2d Constructor (point1, vector)

LineSegment2d Constructor (point1, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »LineSegment2d(Point2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment2d(
    Point2d point1,
    Vector2d vector
)
Public Sub New ( _
    point1 As Point2d, _
    vector As Vector2d _
)
public:
LineSegment2d(
    Point2d point1,
    Vector2d vector
)
Parameters
point1(Point2d)
vector(Vector2d)


BaryComb Method (blendCoefficient)

BaryComb Method (blendCoefficient)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »BaryComb(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d BaryComb(
    double blendCoefficient
)
Public Function BaryComb ( _
    blendCoefficient As Double _
) As Point2d
public:
Point2d BaryComb(
    double blendCoefficient
)
Parameters
blendCoefficient(Double)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static LineSegment2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As LineSegment2d
public:
static LineSegment2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d EndPoint { get; }
Public ReadOnly Property EndPoint As Point2d
    Get
public:
property Point2d EndPoint {
    Point2d get ();
}


GetBisector Method

GetBisector Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetBisector()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Line2d GetBisector()
Public Function GetBisector As Line2d
public:
Line2d^ GetBisector()


GetSegmentLength Method

GetSegmentLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetSegmentLength()()()()
Members
Icon | Member | Description
 | GetSegmentLength(Double, Double, Tolerance) |
 | GetSegmentLength(Double, Double) |


GetSegmentLength Method (fromParameter, toParameter)

GetSegmentLength Method (fromParameter, toParameter)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetSegmentLength(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetSegmentLength(
    double fromParameter,
    double toParameter
)
Public Function GetSegmentLength ( _
    fromParameter As Double, _
    toParameter As Double _
) As Double
public:
double GetSegmentLength(
    double fromParameter,
    double toParameter
)
Parameters
fromParameter(Double)
toParameter(Double)


GetSegmentLength Method (fromParameter, toParameter, tolerance)

GetSegmentLength Method (fromParameter, toParameter, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetSegmentLength(Double, Double, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double GetSegmentLength(
    double fromParameter,
    double toParameter,
    Tolerance tolerance
)
Public Function GetSegmentLength ( _
    fromParameter As Double, _
    toParameter As Double, _
    tolerance As Tolerance _
) As Double
public:
double GetSegmentLength(
    double fromParameter,
    double toParameter,
    Tolerance tolerance
)
Parameters
fromParameter(Double)
toParameter(Double)
tolerance(Tolerance)


Length Property

Length Property
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »Length
Declaration Syntax
C# Visual Basic Visual C++
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}


MidPoint Property

MidPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »MidPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d MidPoint { get; }
Public ReadOnly Property MidPoint As Point2d
    Get
public:
property Point2d MidPoint {
    Point2d get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »Set()()()()
Members
Icon | Member | Description
 | Set(Curve2d, Curve2d, Double, Double) |
 | Set(Curve2d, Point2d, Double) |
 | Set(Point2d, Vector2d) |
 | Set(Point2d, Point2d) |


Set Method (curve1, curve2, parameter1, parameter2)

Set Method (curve1, curve2, parameter1, parameter2)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »Set(Curve2d, Curve2d, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve2d curve1,
    Curve2d curve2,
    double parameter1,
    double parameter2
)
Public Sub Set ( _
    curve1 As Curve2d, _
    curve2 As Curve2d, _
    parameter1 As Double, _
    parameter2 As Double _
)
public:
void Set(
    Curve2d^ curve1,
    Curve2d^ curve2,
    double parameter1,
    double parameter2
)
Parameters
curve1(Curve2d)
curve2(Curve2d)
parameter1(Double)
parameter2(Double)


Set Method (curve, point, parameter)

Set Method (curve, point, parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »Set(Curve2d, Point2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve2d curve,
    Point2d point,
    double parameter
)
Public Sub Set ( _
    curve As Curve2d, _
    point As Point2d, _
    parameter As Double _
)
public:
void Set(
    Curve2d^ curve,
    Point2d point,
    double parameter
)
Parameters
curve(Curve2d)
point(Point2d)
parameter(Double)


Set Method (point1, point2)

Set Method (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »Set(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d point1,
    Point2d point2
)
Public Sub Set ( _
    point1 As Point2d, _
    point2 As Point2d _
)
public:
void Set(
    Point2d point1,
    Point2d point2
)
Parameters
point1(Point2d)
point2(Point2d)


Set Method (point, vector)

Set Method (point, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »Set(Point2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d point,
    Vector2d vector
)
Public Sub Set ( _
    point As Point2d, _
    vector As Vector2d _
)
public:
void Set(
    Point2d point,
    Vector2d vector
)
Parameters
point(Point2d)
vector(Vector2d)


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d StartPoint { get; }
Public ReadOnly Property StartPoint As Point2d
    Get
public:
property Point2d StartPoint {
    Point2d get ();
}


LineSegment3d Class

LineSegment3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeLineSeg3d")]
public sealed class LineSegment3d : LinearEntity3d
<WrapperAttribute("ZcGeLineSeg3d")> _
Public NotInheritable Class LineSegment3d _
    Inherits LinearEntity3d
[WrapperAttribute(L"ZcGeLineSeg3d")]
public ref class LineSegment3d sealed : public LinearEntity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LineSegment3d(Point3d, Vector3d) |
 | LineSegment3d(Point3d, Point3d) |
 | LineSegment3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BaryComb(Double) |
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Direction | (Inherited from LinearEntity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBisector()()()() |
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLine()()()() | (Inherited from LinearEntity3d.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetPerpendicularPlane(Point3d) | (Inherited from LinearEntity3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.)
 | IntersectWith(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IntersectWith(PlanarEntity) | (Inherited from LinearEntity3d.)
 | IntersectWith(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsColinearTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IsColinearTo(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Plane, Tolerance) | (Inherited from LinearEntity3d.)
 | IsOn(Plane) | (Inherited from LinearEntity3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsParallelTo(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.)
 | IsParallelTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IsParallelTo(PlanarEntity) | (Inherited from LinearEntity3d.)
 | IsParallelTo(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPerpendicularTo(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.)
 | IsPerpendicularTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IsPerpendicularTo(PlanarEntity) | (Inherited from LinearEntity3d.)
 | IsPerpendicularTo(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | Length |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MidPoint |
 | Mirror(Plane) | (Inherited from Entity3d.)
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | Overlap(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | Overlap(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | PointOnLine | (Inherited from LinearEntity3d.)
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) | (Inherited from LinearEntity3d.)
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) | (Inherited from LinearEntity3d.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Curve3d, Curve3d, Double, Double) |
 | Set(Curve3d, Point3d, Double) |
 | Set(Point3d, Vector3d) |
 | Set(Point3d, Point3d) |
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | StartPoint |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | LinearEntity3d
 |  |  |  |  |  | LineSegment3d


LineSegment3d Constructor

LineSegment3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »LineSegment3d()()()()
Members
Icon | Member | Description
 | LineSegment3d(Point3d, Vector3d) |
 | LineSegment3d(Point3d, Point3d) |
 | LineSegment3d()()()() |


LineSegment3d Constructor

LineSegment3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »LineSegment3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment3d()
Public Sub New
public:
LineSegment3d()


LineSegment3d Constructor (point1, point2)

LineSegment3d Constructor (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »LineSegment3d(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment3d(
    Point3d point1,
    Point3d point2
)
Public Sub New ( _
    point1 As Point3d, _
    point2 As Point3d _
)
public:
LineSegment3d(
    Point3d point1,
    Point3d point2
)
Parameters
point1(Point3d)
point2(Point3d)


LineSegment3d Constructor (point1, vector)

LineSegment3d Constructor (point1, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »LineSegment3d(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment3d(
    Point3d point1,
    Vector3d vector
)
Public Sub New ( _
    point1 As Point3d, _
    vector As Vector3d _
)
public:
LineSegment3d(
    Point3d point1,
    Vector3d vector
)
Parameters
point1(Point3d)
vector(Vector3d)


BaryComb Method (blendCoefficient)

BaryComb Method (blendCoefficient)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »BaryComb(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d BaryComb(
    double blendCoefficient
)
Public Function BaryComb ( _
    blendCoefficient As Double _
) As Point3d
public:
Point3d BaryComb(
    double blendCoefficient
)
Parameters
blendCoefficient(Double)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static LineSegment3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As LineSegment3d
public:
static LineSegment3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d EndPoint { get; }
Public ReadOnly Property EndPoint As Point3d
    Get
public:
property Point3d EndPoint {
    Point3d get ();
}


GetBisector Method

GetBisector Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetBisector()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Plane GetBisector()
Public Function GetBisector As Plane
public:
Plane^ GetBisector()


Length Property

Length Property
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »Length
Declaration Syntax
C# Visual Basic Visual C++
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}


MidPoint Property

MidPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »MidPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d MidPoint { get; }
Public ReadOnly Property MidPoint As Point3d
    Get
public:
property Point3d MidPoint {
    Point3d get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »Set()()()()
Members
Icon | Member | Description
 | Set(Curve3d, Curve3d, Double, Double) |
 | Set(Curve3d, Point3d, Double) |
 | Set(Point3d, Vector3d) |
 | Set(Point3d, Point3d) |


Set Method (curve1, curve2, parameter1, parameter2)

Set Method (curve1, curve2, parameter1, parameter2)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »Set(Curve3d, Curve3d, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve3d curve1,
    Curve3d curve2,
    double parameter1,
    double parameter2
)
Public Sub Set ( _
    curve1 As Curve3d, _
    curve2 As Curve3d, _
    parameter1 As Double, _
    parameter2 As Double _
)
public:
void Set(
    Curve3d^ curve1,
    Curve3d^ curve2,
    double parameter1,
    double parameter2
)
Parameters
curve1(Curve3d)
curve2(Curve3d)
parameter1(Double)
parameter2(Double)


Set Method (curve, point, parameter)

Set Method (curve, point, parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »Set(Curve3d, Point3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Curve3d curve,
    Point3d point,
    double parameter
)
Public Sub Set ( _
    curve As Curve3d, _
    point As Point3d, _
    parameter As Double _
)
public:
void Set(
    Curve3d^ curve,
    Point3d point,
    double parameter
)
Parameters
curve(Curve3d)
point(Point3d)
parameter(Double)


Set Method (point1, point2)

Set Method (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »Set(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d point1,
    Point3d point2
)
Public Sub Set ( _
    point1 As Point3d, _
    point2 As Point3d _
)
public:
void Set(
    Point3d point1,
    Point3d point2
)
Parameters
point1(Point3d)
point2(Point3d)


Set Method (point, vector)

Set Method (point, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »Set(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d point,
    Vector3d vector
)
Public Sub Set ( _
    point As Point3d, _
    vector As Vector3d _
)
public:
void Set(
    Point3d point,
    Vector3d vector
)
Parameters
point(Point3d)
vector(Vector3d)


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d StartPoint { get; }
Public ReadOnly Property StartPoint As Point3d
    Get
public:
property Point3d StartPoint {
    Point3d get ();
}


Matrix2d Structure

Matrix2d Structure
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeMatrix2d")]
public struct Matrix2d : IFormattable
<WrapperAttribute("ZcGeMatrix2d")> _
Public Structure Matrix2d _
    Implements IFormattable
[WrapperAttribute(L"ZcGeMatrix2d")]
public value class Matrix2d : IFormattable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Matrix2d(array<Double>[]()[][]) |
 | AlignCoordinateSystem(Point2d, Vector2d, Vector2d, Point2d, Vector2d, Vector2d) |
 | CoordinateSystem2d |
 | Displacement(Vector2d) |
 | ElementAt[([( Int32, Int32])]) |
 | Equality(Matrix2d, Matrix2d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetDeterminant()()()() |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetScale()()()() |
 | GetType()()()() | (Inherited from Object.)
 | Inequality(Matrix2d, Matrix2d) |
 | Inverse()()()() |
 | IsConformal(Matrix2dInfo) |
 | IsEqualTo(Matrix2d, Tolerance) |
 | IsEqualTo(Matrix2d) |
 | IsScaledOrtho(Tolerance) |
 | IsScaledOrtho()()()() |
 | IsSingular(Tolerance) |
 | IsSingular()()()() |
 | IsUniscaledOrtho(Tolerance) |
 | IsUniscaledOrtho()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirroring(Point2d) |
 | Mirroring(Line2d) |
 | Multiply(Matrix2d) |
 | Multiply(Matrix2d, Matrix2d) |
 | PostMultiplyBy(Matrix2d) |
 | PreMultiplyBy(Matrix2d) |
 | Rotation(Double, Point2d) |
 | Scaling(Double, Point2d) |
 | ToArray()()()() |
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | Translation |
 | Transpose()()()() |


Matrix2d Constructor (data)

Matrix2d Constructor (data)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Matrix2d(array<Double>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2d(
    double[] data
)
Public Sub New ( _
    data As Double() _
)
public:
Matrix2d(
    array<double>^ data
)
Parameters
data(array<Double>[]()[][])


AlignCoordinateSystem Method (fromOrigin, fromE0, fromE1, toOrigin, toE0, toE1)

AlignCoordinateSystem Method (fromOrigin, fromE0, fromE1, toOrigin, toE0, toE1)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »AlignCoordinateSystem(Point2d, Vector2d, Vector2d, Point2d, Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix2d AlignCoordinateSystem(
    Point2d fromOrigin,
    Vector2d fromE0,
    Vector2d fromE1,
    Point2d toOrigin,
    Vector2d toE0,
    Vector2d toE1
)
Public Shared Function AlignCoordinateSystem ( _
    fromOrigin As Point2d, _
    fromE0 As Vector2d, _
    fromE1 As Vector2d, _
    toOrigin As Point2d, _
    toE0 As Vector2d, _
    toE1 As Vector2d _
) As Matrix2d
public:
static Matrix2d AlignCoordinateSystem(
    Point2d fromOrigin,
    Vector2d fromE0,
    Vector2d fromE1,
    Point2d toOrigin,
    Vector2d toE0,
    Vector2d toE1
)
Parameters
fromOrigin(Point2d)
fromE0(Vector2d)
fromE1(Vector2d)
toOrigin(Point2d)
toE0(Vector2d)
toE1(Vector2d)


CoordinateSystem2d Property

CoordinateSystem2d Property
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »CoordinateSystem2d
Declaration Syntax
C# Visual Basic Visual C++
public CoordinateSystem2d CoordinateSystem2d { get; }
Public ReadOnly Property CoordinateSystem2d As CoordinateSystem2d
    Get
public:
property CoordinateSystem2d CoordinateSystem2d {
    CoordinateSystem2d get ();
}


Displacement Method (vector)

Displacement Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Displacement(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix2d Displacement(
    Vector2d vector
)
Public Shared Function Displacement ( _
    vector As Vector2d _
) As Matrix2d
public:
static Matrix2d Displacement(
    Vector2d vector
)
Parameters
vector(Vector2d)


ElementAt Property (i, j)

ElementAt Property (i, j)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »ElementAt[([( Int32, Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int i,
    int j
] { get; }
Public ReadOnly Default Property ElementAt ( _
    i As Integer, _
    j As Integer _
) As Double
    Get
public:
property double default[int i, int j] {
    double get (int i, int j);
}
Parameters
i(Int32)
j(Int32)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Equality(Matrix2d, Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Matrix2d a,
    Matrix2d b
)
Public Shared Operator = ( _
    a As Matrix2d, _
    b As Matrix2d _
) As Boolean
public:
static bool operator ==(
    Matrix2d a,
    Matrix2d b
)
Parameters
a(Matrix2d)
b(Matrix2d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetDeterminant Method

GetDeterminant Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »GetDeterminant()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double GetDeterminant()
Public Function GetDeterminant As Double
public:
double GetDeterminant()


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetScale Method

GetScale Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »GetScale()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double GetScale()
Public Function GetScale As Double
public:
double GetScale()


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Inequality(Matrix2d, Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Matrix2d a,
    Matrix2d b
)
Public Shared Operator <> ( _
    a As Matrix2d, _
    b As Matrix2d _
) As Boolean
public:
static bool operator !=(
    Matrix2d a,
    Matrix2d b
)
Parameters
a(Matrix2d)
b(Matrix2d)


Inverse Method

Inverse Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Inverse()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2d Inverse()
Public Function Inverse As Matrix2d
public:
Matrix2d Inverse()


IsConformal Method (info)

IsConformal Method (info)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsConformal(Matrix2dInfo)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsConformal(
    Matrix2dInfo info
)
Public Function IsConformal ( _
    info As Matrix2dInfo _
) As Boolean
public:
bool IsConformal(
    Matrix2dInfo info
)
Parameters
info(Matrix2dInfo)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Matrix2d, Tolerance) |
 | IsEqualTo(Matrix2d) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsEqualTo(Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Matrix2d a
)
Public Function IsEqualTo ( _
    a As Matrix2d _
) As Boolean
public:
bool IsEqualTo(
    Matrix2d a
)
Parameters
a(Matrix2d)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsEqualTo(Matrix2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Matrix2d a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As Matrix2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Matrix2d a,
    Tolerance tolerance
)
Parameters
a(Matrix2d)
tolerance(Tolerance)


IsScaledOrtho Method

IsScaledOrtho Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsScaledOrtho()()()()
Members
Icon | Member | Description
 | IsScaledOrtho(Tolerance) |
 | IsScaledOrtho()()()() |


IsScaledOrtho Method

IsScaledOrtho Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsScaledOrtho()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScaledOrtho()
Public Function IsScaledOrtho As Boolean
public:
bool IsScaledOrtho()


IsScaledOrtho Method (tolerance)

IsScaledOrtho Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsScaledOrtho(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScaledOrtho(
    Tolerance tolerance
)
Public Function IsScaledOrtho ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsScaledOrtho(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsSingular Method

IsSingular Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsSingular()()()()
Members
Icon | Member | Description
 | IsSingular(Tolerance) |
 | IsSingular()()()() |


IsSingular Method

IsSingular Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsSingular()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSingular()
Public Function IsSingular As Boolean
public:
bool IsSingular()


IsSingular Method (tolerance)

IsSingular Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsSingular(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSingular(
    Tolerance tolerance
)
Public Function IsSingular ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsSingular(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsUniscaledOrtho Method

IsUniscaledOrtho Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsUniscaledOrtho()()()()
Members
Icon | Member | Description
 | IsUniscaledOrtho(Tolerance) |
 | IsUniscaledOrtho()()()() |


IsUniscaledOrtho Method

IsUniscaledOrtho Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsUniscaledOrtho()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUniscaledOrtho()
Public Function IsUniscaledOrtho As Boolean
public:
bool IsUniscaledOrtho()


IsUniscaledOrtho Method (tolerance)

IsUniscaledOrtho Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »IsUniscaledOrtho(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUniscaledOrtho(
    Tolerance tolerance
)
Public Function IsUniscaledOrtho ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsUniscaledOrtho(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


Mirroring Method

Mirroring Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Mirroring()()()()
Members
Icon | Member | Description
 | Mirroring(Point2d) |
 | Mirroring(Line2d) |


Mirroring Method (line)

Mirroring Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Mirroring(Line2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix2d Mirroring(
    Line2d line
)
Public Shared Function Mirroring ( _
    line As Line2d _
) As Matrix2d
public:
static Matrix2d Mirroring(
    Line2d^ line
)
Parameters
line(Line2d)


Mirroring Method (point)

Mirroring Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Mirroring(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix2d Mirroring(
    Point2d point
)
Public Shared Function Mirroring ( _
    point As Point2d _
) As Matrix2d
public:
static Matrix2d Mirroring(
    Point2d point
)
Parameters
point(Point2d)


Multiply Method

Multiply Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Multiply()()()()
Members
Icon | Member | Description
 | Multiply(Matrix2d) |
 | Multiply(Matrix2d, Matrix2d) |


Multiply Method (matrix)

Multiply Method (matrix)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Multiply(Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2d Multiply(
    Matrix2d matrix
)
Public Function Multiply ( _
    matrix As Matrix2d _
) As Matrix2d
public:
Matrix2d Multiply(
    Matrix2d matrix
)
Parameters
matrix(Matrix2d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Multiply(Matrix2d, Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix2d operator *(
    Matrix2d a,
    Matrix2d b
)
Public Shared Operator * ( _
    a As Matrix2d, _
    b As Matrix2d _
) As Matrix2d
public:
static Matrix2d operator *(
    Matrix2d a,
    Matrix2d b
)
Parameters
a(Matrix2d)
b(Matrix2d)


PostMultiplyBy Method (rightSide)

PostMultiplyBy Method (rightSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »PostMultiplyBy(Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2d PostMultiplyBy(
    Matrix2d rightSide
)
Public Function PostMultiplyBy ( _
    rightSide As Matrix2d _
) As Matrix2d
public:
Matrix2d PostMultiplyBy(
    Matrix2d rightSide
)
Parameters
rightSide(Matrix2d)


PreMultiplyBy Method (leftSide)

PreMultiplyBy Method (leftSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »PreMultiplyBy(Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2d PreMultiplyBy(
    Matrix2d leftSide
)
Public Function PreMultiplyBy ( _
    leftSide As Matrix2d _
) As Matrix2d
public:
Matrix2d PreMultiplyBy(
    Matrix2d leftSide
)
Parameters
leftSide(Matrix2d)


Rotation Method (angle, center)

Rotation Method (angle, center)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Rotation(Double, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix2d Rotation(
    double angle,
    Point2d center
)
Public Shared Function Rotation ( _
    angle As Double, _
    center As Point2d _
) As Matrix2d
public:
static Matrix2d Rotation(
    double angle,
    Point2d center
)
Parameters
angle(Double)
center(Point2d)


Scaling Method (scaleAll, center)

Scaling Method (scaleAll, center)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Scaling(Double, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix2d Scaling(
    double scaleAll,
    Point2d center
)
Public Shared Function Scaling ( _
    scaleAll As Double, _
    center As Point2d _
) As Matrix2d
public:
static Matrix2d Scaling(
    double scaleAll,
    Point2d center
)
Parameters
scaleAll(Double)
center(Point2d)


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] ToArray()
Public Function ToArray As Double()
public:
array<double>^ ToArray()


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


Translation Property

Translation Property
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Translation
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Translation { get; }
Public ReadOnly Property Translation As Vector2d
    Get
public:
property Vector2d Translation {
    Vector2d get ();
}


Transpose Method

Transpose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2d »Transpose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2d Transpose()
Public Function Transpose As Matrix2d
public:
Matrix2d Transpose()


Matrix2dBuilder Class

Matrix2dBuilder Class
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dBuilder
Declaration Syntax
C# Visual Basic Visual C++
public class Matrix2dBuilder
Public Class Matrix2dBuilder
public ref class Matrix2dBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Matrix2dBuilder(Matrix2d) |
 | Matrix2dBuilder()()()() |
 | ElementAt[([( Int32, Int32])]) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToMatrix2d()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Matrix2dBuilder


Matrix2dBuilder Constructor

Matrix2dBuilder Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dBuilder »Matrix2dBuilder()()()()
Members
Icon | Member | Description
 | Matrix2dBuilder(Matrix2d) |
 | Matrix2dBuilder()()()() |


Matrix2dBuilder Constructor

Matrix2dBuilder Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dBuilder »Matrix2dBuilder()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2dBuilder()
Public Sub New
public:
Matrix2dBuilder()


Matrix2dBuilder Constructor (value)

Matrix2dBuilder Constructor (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dBuilder »Matrix2dBuilder(Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2dBuilder(
    Matrix2d value
)
Public Sub New ( _
    value As Matrix2d _
)
public:
Matrix2dBuilder(
    Matrix2d value
)
Parameters
value(Matrix2d)


ElementAt Property (i, j)

ElementAt Property (i, j)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dBuilder »ElementAt[([( Int32, Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int i,
    int j
] { get; set; }
Public Default Property ElementAt ( _
    i As Integer, _
    j As Integer _
) As Double
    Get
    Set
public:
property double default[int i, int j] {
    double get (int i, int j);
    void set (int i, int j, double value);
}
Parameters
i(Int32)
j(Int32)


ToMatrix2d Method

ToMatrix2d Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dBuilder »ToMatrix2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2d ToMatrix2d()
Public Function ToMatrix2d As Matrix2d
public:
Matrix2d ToMatrix2d()


Matrix2dInfo Structure

Matrix2dInfo Structure
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo
Declaration Syntax
C# Visual Basic Visual C++
public struct Matrix2dInfo
Public Structure Matrix2dInfo
public value class Matrix2dInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Angle |
 | Equality(Matrix2dInfo, Matrix2dInfo) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(Matrix2dInfo, Matrix2dInfo) |
 | IsEqualTo(Matrix2dInfo, Tolerance) |
 | IsEqualTo(Matrix2dInfo) |
 | IsMirror |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Reflex |
 | Scale |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


Angle Property

Angle Property
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »Angle
Declaration Syntax
C# Visual Basic Visual C++
public double Angle { get; }
Public ReadOnly Property Angle As Double
    Get
public:
property double Angle {
    double get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »Equality(Matrix2dInfo, Matrix2dInfo)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Matrix2dInfo a,
    Matrix2dInfo b
)
Public Shared Operator = ( _
    a As Matrix2dInfo, _
    b As Matrix2dInfo _
) As Boolean
public:
static bool operator ==(
    Matrix2dInfo a,
    Matrix2dInfo b
)
Parameters
a(Matrix2dInfo)
b(Matrix2dInfo)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »Inequality(Matrix2dInfo, Matrix2dInfo)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Matrix2dInfo a,
    Matrix2dInfo b
)
Public Shared Operator <> ( _
    a As Matrix2dInfo, _
    b As Matrix2dInfo _
) As Boolean
public:
static bool operator !=(
    Matrix2dInfo a,
    Matrix2dInfo b
)
Parameters
a(Matrix2dInfo)
b(Matrix2dInfo)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Matrix2dInfo, Tolerance) |
 | IsEqualTo(Matrix2dInfo) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »IsEqualTo(Matrix2dInfo)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Matrix2dInfo a
)
Public Function IsEqualTo ( _
    a As Matrix2dInfo _
) As Boolean
public:
bool IsEqualTo(
    Matrix2dInfo a
)
Parameters
a(Matrix2dInfo)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »IsEqualTo(Matrix2dInfo, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Matrix2dInfo a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As Matrix2dInfo, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Matrix2dInfo a,
    Tolerance tolerance
)
Parameters
a(Matrix2dInfo)
tolerance(Tolerance)


IsMirror Property

IsMirror Property
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »IsMirror
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMirror { get; }
Public ReadOnly Property IsMirror As Boolean
    Get
public:
property bool IsMirror {
    bool get ();
}


Reflex Property

Reflex Property
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »Reflex
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Reflex { get; }
Public ReadOnly Property Reflex As Vector2d
    Get
public:
property Vector2d Reflex {
    Vector2d get ();
}


Scale Property

Scale Property
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »Scale
Declaration Syntax
C# Visual Basic Visual C++
public double Scale { get; }
Public ReadOnly Property Scale As Double
    Get
public:
property double Scale {
    double get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix2dInfo »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


Matrix3d Structure

Matrix3d Structure
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeMatrix3d")]
public struct Matrix3d : IFormattable
<WrapperAttribute("ZcGeMatrix3d")> _
Public Structure Matrix3d _
    Implements IFormattable
[WrapperAttribute(L"ZcGeMatrix3d")]
public value class Matrix3d : IFormattable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Matrix3d(array<Double>[]()[][]) |
 | AlignCoordinateSystem(Point3d, Vector3d, Vector3d, Vector3d, Point3d, Vector3d, Vector3d, Vector3d) |
 | CoordinateSystem3d |
 | Displacement(Vector3d) |
 | ElementAt[([( Int32, Int32])]) |
 | Equality(Matrix3d, Matrix3d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetDeterminant()()()() |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetScale()()()() |
 | GetType()()()() | (Inherited from Object.)
 | Identity |
 | Inequality(Matrix3d, Matrix3d) |
 | Inverse()()()() |
 | IsEqualTo(Matrix3d, Tolerance) |
 | IsEqualTo(Matrix3d) |
 | IsInverse(Matrix3d, Tolerance) |
 | IsInverse(Matrix3d) |
 | IsScaledOrtho(Tolerance) |
 | IsScaledOrtho()()()() |
 | IsSingular(Tolerance) |
 | IsSingular()()()() |
 | IsUniscaledOrtho(Tolerance) |
 | IsUniscaledOrtho()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirroring(Point3d) |
 | Mirroring(Plane) |
 | Mirroring(Line3d) |
 | Multiply(Matrix3d, Matrix3d) |
 | Normal |
 | PlaneToWorld(Vector3d) |
 | PlaneToWorld(Plane) |
 | PostMultiplyBy(Matrix3d) |
 | PreMultiplyBy(Matrix3d) |
 | Projection(Plane, Vector3d) |
 | Rotation(Double, Vector3d, Point3d) |
 | Scaling(Double, Point3d) |
 | ToArray()()()() |
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | Translation |
 | Transpose()()()() |
 | WorldToPlane(Vector3d) |
 | WorldToPlane(Plane) |


Matrix3d Constructor (data)

Matrix3d Constructor (data)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Matrix3d(array<Double>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d(
    double[] data
)
Public Sub New ( _
    data As Double() _
)
public:
Matrix3d(
    array<double>^ data
)
Parameters
data(array<Double>[]()[][])


AlignCoordinateSystem Method (fromOrigin, fromXAxis, fromYAxis, fromZAxis, toOrigin, toXAxis, toYAxis, toZAxis)

AlignCoordinateSystem Method (fromOrigin, fromXAxis, fromYAxis, fromZAxis, toOrigin, toXAxis, toYAxis, toZAxis)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »AlignCoordinateSystem(Point3d, Vector3d, Vector3d, Vector3d, Point3d, Vector3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d AlignCoordinateSystem(
    Point3d fromOrigin,
    Vector3d fromXAxis,
    Vector3d fromYAxis,
    Vector3d fromZAxis,
    Point3d toOrigin,
    Vector3d toXAxis,
    Vector3d toYAxis,
    Vector3d toZAxis
)
Public Shared Function AlignCoordinateSystem ( _
    fromOrigin As Point3d, _
    fromXAxis As Vector3d, _
    fromYAxis As Vector3d, _
    fromZAxis As Vector3d, _
    toOrigin As Point3d, _
    toXAxis As Vector3d, _
    toYAxis As Vector3d, _
    toZAxis As Vector3d _
) As Matrix3d
public:
static Matrix3d AlignCoordinateSystem(
    Point3d fromOrigin,
    Vector3d fromXAxis,
    Vector3d fromYAxis,
    Vector3d fromZAxis,
    Point3d toOrigin,
    Vector3d toXAxis,
    Vector3d toYAxis,
    Vector3d toZAxis
)
Parameters
fromOrigin(Point3d)
fromXAxis(Vector3d)
fromYAxis(Vector3d)
fromZAxis(Vector3d)
toOrigin(Point3d)
toXAxis(Vector3d)
toYAxis(Vector3d)
toZAxis(Vector3d)


CoordinateSystem3d Property

CoordinateSystem3d Property
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »CoordinateSystem3d
Declaration Syntax
C# Visual Basic Visual C++
public CoordinateSystem3d CoordinateSystem3d { get; }
Public ReadOnly Property CoordinateSystem3d As CoordinateSystem3d
    Get
public:
property CoordinateSystem3d CoordinateSystem3d {
    CoordinateSystem3d get ();
}


Displacement Method (vector)

Displacement Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Displacement(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d Displacement(
    Vector3d vector
)
Public Shared Function Displacement ( _
    vector As Vector3d _
) As Matrix3d
public:
static Matrix3d Displacement(
    Vector3d vector
)
Parameters
vector(Vector3d)


ElementAt Property (i, j)

ElementAt Property (i, j)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »ElementAt[([( Int32, Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int i,
    int j
] { get; }
Public ReadOnly Default Property ElementAt ( _
    i As Integer, _
    j As Integer _
) As Double
    Get
public:
property double default[int i, int j] {
    double get (int i, int j);
}
Parameters
i(Int32)
j(Int32)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Equality(Matrix3d, Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Matrix3d a,
    Matrix3d b
)
Public Shared Operator = ( _
    a As Matrix3d, _
    b As Matrix3d _
) As Boolean
public:
static bool operator ==(
    Matrix3d a,
    Matrix3d b
)
Parameters
a(Matrix3d)
b(Matrix3d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetDeterminant Method

GetDeterminant Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »GetDeterminant()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double GetDeterminant()
Public Function GetDeterminant As Double
public:
double GetDeterminant()


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetScale Method

GetScale Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »GetScale()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double GetScale()
Public Function GetScale As Double
public:
double GetScale()


Identity Property

Identity Property
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Identity
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d Identity { get; }
Public Shared ReadOnly Property Identity As Matrix3d
    Get
public:
static property Matrix3d Identity {
    Matrix3d get ();
}


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Inequality(Matrix3d, Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Matrix3d a,
    Matrix3d b
)
Public Shared Operator <> ( _
    a As Matrix3d, _
    b As Matrix3d _
) As Boolean
public:
static bool operator !=(
    Matrix3d a,
    Matrix3d b
)
Parameters
a(Matrix3d)
b(Matrix3d)


Inverse Method

Inverse Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Inverse()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d Inverse()
Public Function Inverse As Matrix3d
public:
Matrix3d Inverse()


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Matrix3d, Tolerance) |
 | IsEqualTo(Matrix3d) |


IsEqualTo Method (mat)

IsEqualTo Method (mat)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsEqualTo(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Matrix3d mat
)
Public Function IsEqualTo ( _
    mat As Matrix3d _
) As Boolean
public:
bool IsEqualTo(
    Matrix3d mat
)
Parameters
mat(Matrix3d)


IsEqualTo Method (mat, tolerance)

IsEqualTo Method (mat, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsEqualTo(Matrix3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Matrix3d mat,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    mat As Matrix3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Matrix3d mat,
    Tolerance tolerance
)
Parameters
mat(Matrix3d)
tolerance(Tolerance)


IsInverse Method

IsInverse Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsInverse()()()()
Members
Icon | Member | Description
 | IsInverse(Matrix3d, Tolerance) |
 | IsInverse(Matrix3d) |


IsInverse Method (inv)

IsInverse Method (inv)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsInverse(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInverse(
    Matrix3d inv
)
Public Function IsInverse ( _
    inv As Matrix3d _
) As Boolean
public:
bool IsInverse(
    Matrix3d inv
)
Parameters
inv(Matrix3d)


IsInverse Method (inv, tolerance)

IsInverse Method (inv, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsInverse(Matrix3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInverse(
    Matrix3d inv,
    Tolerance tolerance
)
Public Function IsInverse ( _
    inv As Matrix3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsInverse(
    Matrix3d inv,
    Tolerance tolerance
)
Parameters
inv(Matrix3d)
tolerance(Tolerance)


IsScaledOrtho Method

IsScaledOrtho Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsScaledOrtho()()()()
Members
Icon | Member | Description
 | IsScaledOrtho(Tolerance) |
 | IsScaledOrtho()()()() |


IsScaledOrtho Method

IsScaledOrtho Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsScaledOrtho()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScaledOrtho()
Public Function IsScaledOrtho As Boolean
public:
bool IsScaledOrtho()


IsScaledOrtho Method (tolerance)

IsScaledOrtho Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsScaledOrtho(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScaledOrtho(
    Tolerance tolerance
)
Public Function IsScaledOrtho ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsScaledOrtho(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsSingular Method

IsSingular Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsSingular()()()()
Members
Icon | Member | Description
 | IsSingular(Tolerance) |
 | IsSingular()()()() |


IsSingular Method

IsSingular Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsSingular()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSingular()
Public Function IsSingular As Boolean
public:
bool IsSingular()


IsSingular Method (tolerance)

IsSingular Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsSingular(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSingular(
    Tolerance tolerance
)
Public Function IsSingular ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsSingular(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsUniscaledOrtho Method

IsUniscaledOrtho Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsUniscaledOrtho()()()()
Members
Icon | Member | Description
 | IsUniscaledOrtho(Tolerance) |
 | IsUniscaledOrtho()()()() |


IsUniscaledOrtho Method

IsUniscaledOrtho Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsUniscaledOrtho()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUniscaledOrtho()
Public Function IsUniscaledOrtho As Boolean
public:
bool IsUniscaledOrtho()


IsUniscaledOrtho Method (tolerance)

IsUniscaledOrtho Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »IsUniscaledOrtho(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUniscaledOrtho(
    Tolerance tolerance
)
Public Function IsUniscaledOrtho ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsUniscaledOrtho(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


Mirroring Method

Mirroring Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Mirroring()()()()
Members
Icon | Member | Description
 | Mirroring(Point3d) |
 | Mirroring(Plane) |
 | Mirroring(Line3d) |


Mirroring Method (line)

Mirroring Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Mirroring(Line3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d Mirroring(
    Line3d line
)
Public Shared Function Mirroring ( _
    line As Line3d _
) As Matrix3d
public:
static Matrix3d Mirroring(
    Line3d^ line
)
Parameters
line(Line3d)


Mirroring Method (plane)

Mirroring Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Mirroring(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d Mirroring(
    Plane plane
)
Public Shared Function Mirroring ( _
    plane As Plane _
) As Matrix3d
public:
static Matrix3d Mirroring(
    Plane^ plane
)
Parameters
plane(Plane)


Mirroring Method (pointValue)

Mirroring Method (pointValue)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Mirroring(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d Mirroring(
    Point3d pointValue
)
Public Shared Function Mirroring ( _
    pointValue As Point3d _
) As Matrix3d
public:
static Matrix3d Mirroring(
    Point3d pointValue
)
Parameters
pointValue(Point3d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Multiply(Matrix3d, Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d operator *(
    Matrix3d a,
    Matrix3d b
)
Public Shared Operator * ( _
    a As Matrix3d, _
    b As Matrix3d _
) As Matrix3d
public:
static Matrix3d operator *(
    Matrix3d a,
    Matrix3d b
)
Parameters
a(Matrix3d)
b(Matrix3d)


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Normal
Declaration Syntax
C# Visual Basic Visual C++
public double Normal { get; }
Public ReadOnly Property Normal As Double
    Get
public:
property double Normal {
    double get ();
}


PlaneToWorld Method

PlaneToWorld Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »PlaneToWorld()()()()
Members
Icon | Member | Description
 | PlaneToWorld(Vector3d) |
 | PlaneToWorld(Plane) |


PlaneToWorld Method (plane)

PlaneToWorld Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »PlaneToWorld(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d PlaneToWorld(
    Plane plane
)
Public Shared Function PlaneToWorld ( _
    plane As Plane _
) As Matrix3d
public:
static Matrix3d PlaneToWorld(
    Plane^ plane
)
Parameters
plane(Plane)


PlaneToWorld Method (normal)

PlaneToWorld Method (normal)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »PlaneToWorld(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d PlaneToWorld(
    Vector3d normal
)
Public Shared Function PlaneToWorld ( _
    normal As Vector3d _
) As Matrix3d
public:
static Matrix3d PlaneToWorld(
    Vector3d normal
)
Parameters
normal(Vector3d)


PostMultiplyBy Method (rightSide)

PostMultiplyBy Method (rightSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »PostMultiplyBy(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d PostMultiplyBy(
    Matrix3d rightSide
)
Public Function PostMultiplyBy ( _
    rightSide As Matrix3d _
) As Matrix3d
public:
Matrix3d PostMultiplyBy(
    Matrix3d rightSide
)
Parameters
rightSide(Matrix3d)


PreMultiplyBy Method (leftSide)

PreMultiplyBy Method (leftSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »PreMultiplyBy(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d PreMultiplyBy(
    Matrix3d leftSide
)
Public Function PreMultiplyBy ( _
    leftSide As Matrix3d _
) As Matrix3d
public:
Matrix3d PreMultiplyBy(
    Matrix3d leftSide
)
Parameters
leftSide(Matrix3d)


Projection Method (projectionPlane, projectDir)

Projection Method (projectionPlane, projectDir)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Projection(Plane, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d Projection(
    Plane projectionPlane,
    Vector3d projectDir
)
Public Shared Function Projection ( _
    projectionPlane As Plane, _
    projectDir As Vector3d _
) As Matrix3d
public:
static Matrix3d Projection(
    Plane^ projectionPlane,
    Vector3d projectDir
)
Parameters
projectionPlane(Plane)
projectDir(Vector3d)


Rotation Method (angle, axis, center)

Rotation Method (angle, axis, center)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Rotation(Double, Vector3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d Rotation(
    double angle,
    Vector3d axis,
    Point3d center
)
Public Shared Function Rotation ( _
    angle As Double, _
    axis As Vector3d, _
    center As Point3d _
) As Matrix3d
public:
static Matrix3d Rotation(
    double angle,
    Vector3d axis,
    Point3d center
)
Parameters
angle(Double)
axis(Vector3d)
center(Point3d)


Scaling Method (scaleAll, center)

Scaling Method (scaleAll, center)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Scaling(Double, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d Scaling(
    double scaleAll,
    Point3d center
)
Public Shared Function Scaling ( _
    scaleAll As Double, _
    center As Point3d _
) As Matrix3d
public:
static Matrix3d Scaling(
    double scaleAll,
    Point3d center
)
Parameters
scaleAll(Double)
center(Point3d)


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] ToArray()
Public Function ToArray As Double()
public:
array<double>^ ToArray()


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


Translation Property

Translation Property
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Translation
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Translation { get; }
Public ReadOnly Property Translation As Vector3d
    Get
public:
property Vector3d Translation {
    Vector3d get ();
}


Transpose Method

Transpose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »Transpose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d Transpose()
Public Function Transpose As Matrix3d
public:
Matrix3d Transpose()


WorldToPlane Method

WorldToPlane Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »WorldToPlane()()()()
Members
Icon | Member | Description
 | WorldToPlane(Vector3d) |
 | WorldToPlane(Plane) |


WorldToPlane Method (plane)

WorldToPlane Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »WorldToPlane(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d WorldToPlane(
    Plane plane
)
Public Shared Function WorldToPlane ( _
    plane As Plane _
) As Matrix3d
public:
static Matrix3d WorldToPlane(
    Plane^ plane
)
Parameters
plane(Plane)


WorldToPlane Method (normal)

WorldToPlane Method (normal)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3d »WorldToPlane(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Matrix3d WorldToPlane(
    Vector3d normal
)
Public Shared Function WorldToPlane ( _
    normal As Vector3d _
) As Matrix3d
public:
static Matrix3d WorldToPlane(
    Vector3d normal
)
Parameters
normal(Vector3d)


Matrix3dBuilder Class

Matrix3dBuilder Class
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3dBuilder
Declaration Syntax
C# Visual Basic Visual C++
public class Matrix3dBuilder
Public Class Matrix3dBuilder
public ref class Matrix3dBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Matrix3dBuilder(Matrix3d) |
 | Matrix3dBuilder()()()() |
 | ElementAt[([( Int32, Int32])]) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToMatrix3d()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Matrix3dBuilder


Matrix3dBuilder Constructor

Matrix3dBuilder Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3dBuilder »Matrix3dBuilder()()()()
Members
Icon | Member | Description
 | Matrix3dBuilder(Matrix3d) |
 | Matrix3dBuilder()()()() |


Matrix3dBuilder Constructor

Matrix3dBuilder Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3dBuilder »Matrix3dBuilder()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3dBuilder()
Public Sub New
public:
Matrix3dBuilder()


Matrix3dBuilder Constructor (value)

Matrix3dBuilder Constructor (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3dBuilder »Matrix3dBuilder(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3dBuilder(
    Matrix3d value
)
Public Sub New ( _
    value As Matrix3d _
)
public:
Matrix3dBuilder(
    Matrix3d value
)
Parameters
value(Matrix3d)


ElementAt Property (i, j)

ElementAt Property (i, j)
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3dBuilder »ElementAt[([( Int32, Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int i,
    int j
] { get; set; }
Public Default Property ElementAt ( _
    i As Integer, _
    j As Integer _
) As Double
    Get
    Set
public:
property double default[int i, int j] {
    double get (int i, int j);
    void set (int i, int j, double value);
}
Parameters
i(Int32)
j(Int32)


ToMatrix3d Method

ToMatrix3d Method
Namespaces »ZwSoft.ZwCAD.Geometry »Matrix3dBuilder »ToMatrix3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d ToMatrix3d()
Public Function ToMatrix3d As Matrix3d
public:
Matrix3d ToMatrix3d()


NurbCurve2d Class

NurbCurve2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeNurbCurve2d")]
public sealed class NurbCurve2d : SplineEntity2d
<WrapperAttribute("ZcGeNurbCurve2d")> _
Public NotInheritable Class NurbCurve2d _
    Inherits SplineEntity2d
[WrapperAttribute(L"ZcGeNurbCurve2d")]
public ref class NurbCurve2d sealed : public SplineEntity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum, Tolerance) |
 | NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum) |
 | NurbCurve2d(Int32, KnotCollection, Point2dCollection, DoubleCollection, Boolean) |
 | NurbCurve2d(Int32, KnotCollection, Point2dCollection, Boolean) |
 | NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, Tolerance) |
 | NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean) |
 | NurbCurve2d(Point2dCollection, Vector2dCollection, Tolerance, Boolean) |
 | NurbCurve2d(Point2dCollection, Vector2dCollection, Boolean) |
 | NurbCurve2d(Int32, PolylineCurve2d, Boolean) |
 | NurbCurve2d(Point2dCollection, Tolerance) |
 | NurbCurve2d(Point2dCollection) |
 | NurbCurve2d(LineSegment2d) |
 | NurbCurve2d(EllipticalArc2d) |
 | NurbCurve2d()()()() |
 | AddControlPointAt(Double, Point2d, Double) |
 | AddFitPointAt(Int32, Point2d) |
 | AddKnot(Double) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DefinitionData |
 | Degree | (Inherited from SplineEntity2d.)
 | DeleteControlPointAt(Int32) |
 | DeleteFitPointAt(Int32) |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | ElevateDegree(Int32) |
 | EndParameter | (Inherited from SplineEntity2d.)
 | EndPoint | (Inherited from SplineEntity2d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvalMode |
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FitData |
 | FitKnotParameterization |
 | FitTolerance |
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetContinuityAtKnot(Int32, Tolerance) | (Inherited from SplineEntity2d.)
 | GetContinuityAtKnot(Int32) | (Inherited from SplineEntity2d.)
 | GetControlPointAt(Int32) | (Inherited from SplineEntity2d.)
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetFitPointAt(Int32) |
 | GetFitTangents()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetKnotAt(Int32) | (Inherited from SplineEntity2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetParametersOfC1Discontinuity(Tolerance) |
 | GetParametersOfC1Discontinuity()()()() |
 | GetParametersOfG1Discontinuity(Tolerance) |
 | GetParametersOfG1Discontinuity()()()() |
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | GetWeightAt(Int32) |
 | HardTrimByParams(Double, Double) |
 | HasEndPoint | (Inherited from Curve2d.)
 | HasFitData | (Inherited from SplineEntity2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertKnot(Double) |
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | IsRational | (Inherited from SplineEntity2d.)
 | JoinWith(NurbCurve2d) |
 | Knots | (Inherited from SplineEntity2d.)
 | MakeClosed()()()() |
 | MakeNonPeriodic()()()() |
 | MakeOpen()()()() |
 | MakePeriodic()()()() |
 | MakeRational(Double) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | NumControlPoints | (Inherited from SplineEntity2d.)
 | NumFitPoints |
 | NumKnots | (Inherited from SplineEntity2d.)
 | NumWeights |
 | Order | (Inherited from SplineEntity2d.)
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | PurgeFitData()()()() |
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | SetControlPointAt(Int32, Point2d) | (Inherited from SplineEntity2d.)
 | SetEvaluateMode(Boolean) |
 | SetFitData(Point2dCollection, Vector2d, Vector2d, KnotParameterizationEnum, Tolerance) |
 | SetFitData(KnotCollection, Point2dCollection, Vector2d, Vector2d, Tolerance, Boolean) |
 | SetFitData(KnotCollection, Point2dCollection, Vector2d, Vector2d, Boolean) |
 | SetFitData(Point2dCollection, Vector2d, Vector2d, Tolerance) |
 | SetFitData(Int32, Point2dCollection, Tolerance) |
 | SetFitData(Point2dCollection, Vector2d, Vector2d) |
 | SetFitData(Int32, Point2dCollection) |
 | SetFitPointAt(Int32, Point2d) |
 | SetFitTangents(Vector2d, Vector2d) |
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | SetKnotAt(Int32, Double) | (Inherited from SplineEntity2d.)
 | SetWeightAt(Int32, Double) |
 | StartParameter | (Inherited from SplineEntity2d.)
 | StartPoint | (Inherited from SplineEntity2d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | SplineEntity2d
 |  |  |  |  |  | NurbCurve2d


NurbCurve2d Constructor

NurbCurve2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d()()()()
Members
Icon | Member | Description
 | NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum, Tolerance) |
 | NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum) |
 | NurbCurve2d(Int32, KnotCollection, Point2dCollection, DoubleCollection, Boolean) |
 | NurbCurve2d(Int32, KnotCollection, Point2dCollection, Boolean) |
 | NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, Tolerance) |
 | NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean) |
 | NurbCurve2d(Point2dCollection, Vector2dCollection, Tolerance, Boolean) |
 | NurbCurve2d(Point2dCollection, Vector2dCollection, Boolean) |
 | NurbCurve2d(Int32, PolylineCurve2d, Boolean) |
 | NurbCurve2d(Point2dCollection, Tolerance) |
 | NurbCurve2d(Point2dCollection) |
 | NurbCurve2d(LineSegment2d) |
 | NurbCurve2d(EllipticalArc2d) |
 | NurbCurve2d()()()() |


NurbCurve2d Constructor

NurbCurve2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d()
Public Sub New
public:
NurbCurve2d()


NurbCurve2d Constructor (degree, knots, controlPoints, periodic)

NurbCurve2d Constructor (degree, knots, controlPoints, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Int32, KnotCollection, Point2dCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    int degree,
    KnotCollection knots,
    Point2dCollection controlPoints,
    bool periodic
)
Public Sub New ( _
    degree As Integer, _
    knots As KnotCollection, _
    controlPoints As Point2dCollection, _
    periodic As Boolean _
)
public:
NurbCurve2d(
    int degree,
    KnotCollection^ knots,
    Point2dCollection^ controlPoints,
    bool periodic
)
Parameters
degree(Int32)
knots(KnotCollection)
controlPoints(Point2dCollection)
periodic(Boolean)


NurbCurve2d Constructor (degree, knots, controlPoints, weights, periodic)

NurbCurve2d Constructor (degree, knots, controlPoints, weights, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Int32, KnotCollection, Point2dCollection, DoubleCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    int degree,
    KnotCollection knots,
    Point2dCollection controlPoints,
    DoubleCollection weights,
    bool periodic
)
Public Sub New ( _
    degree As Integer, _
    knots As KnotCollection, _
    controlPoints As Point2dCollection, _
    weights As DoubleCollection, _
    periodic As Boolean _
)
public:
NurbCurve2d(
    int degree,
    KnotCollection^ knots,
    Point2dCollection^ controlPoints,
    DoubleCollection^ weights,
    bool periodic
)
Parameters
degree(Int32)
knots(KnotCollection)
controlPoints(Point2dCollection)
weights(DoubleCollection)
periodic(Boolean)


NurbCurve2d Constructor (degree, fitPolyline, periodic)

NurbCurve2d Constructor (degree, fitPolyline, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Int32, PolylineCurve2d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    int degree,
    PolylineCurve2d fitPolyline,
    bool periodic
)
Public Sub New ( _
    degree As Integer, _
    fitPolyline As PolylineCurve2d, _
    periodic As Boolean _
)
public:
NurbCurve2d(
    int degree,
    PolylineCurve2d^ fitPolyline,
    bool periodic
)
Parameters
degree(Int32)
fitPolyline(PolylineCurve2d)
periodic(Boolean)


NurbCurve2d Constructor (ellipse)

NurbCurve2d Constructor (ellipse)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(EllipticalArc2d)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    EllipticalArc2d ellipse
)
Public Sub New ( _
    ellipse As EllipticalArc2d _
)
public:
NurbCurve2d(
    EllipticalArc2d^ ellipse
)
Parameters
ellipse(EllipticalArc2d)


NurbCurve2d Constructor (linSegment)

NurbCurve2d Constructor (linSegment)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(LineSegment2d)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    LineSegment2d linSegment
)
Public Sub New ( _
    linSegment As LineSegment2d _
)
public:
NurbCurve2d(
    LineSegment2d^ linSegment
)
Parameters
linSegment(LineSegment2d)


NurbCurve2d Constructor (fitPoints)

NurbCurve2d Constructor (fitPoints)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    Point2dCollection fitPoints
)
Public Sub New ( _
    fitPoints As Point2dCollection _
)
public:
NurbCurve2d(
    Point2dCollection^ fitPoints
)
Parameters
fitPoints(Point2dCollection)


NurbCurve2d Constructor (fitPoints, fitTolerance)

NurbCurve2d Constructor (fitPoints, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Point2dCollection, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    Point2dCollection fitPoints,
    Tolerance fitTolerance
)
Public Sub New ( _
    fitPoints As Point2dCollection, _
    fitTolerance As Tolerance _
)
public:
NurbCurve2d(
    Point2dCollection^ fitPoints,
    Tolerance fitTolerance
)
Parameters
fitPoints(Point2dCollection)
fitTolerance(Tolerance)


NurbCurve2d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined)

NurbCurve2d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    Point2dCollection fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    bool startTangentDefined,
    bool endTangentDefined
)
Public Sub New ( _
    fitPoints As Point2dCollection, _
    startTangent As Vector2d, _
    endTangent As Vector2d, _
    startTangentDefined As Boolean, _
    endTangentDefined As Boolean _
)
public:
NurbCurve2d(
    Point2dCollection^ fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    bool startTangentDefined,
    bool endTangentDefined
)
Parameters
fitPoints(Point2dCollection)
startTangent(Vector2d)
endTangent(Vector2d)
startTangentDefined(Boolean)
endTangentDefined(Boolean)


NurbCurve2d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, knotParam)

NurbCurve2d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, knotParam)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    Point2dCollection fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    KnotParameterizationEnum knotParam
)
Public Sub New ( _
    fitPoints As Point2dCollection, _
    startTangent As Vector2d, _
    endTangent As Vector2d, _
    startTangentDefined As Boolean, _
    endTangentDefined As Boolean, _
    knotParam As KnotParameterizationEnum _
)
public:
NurbCurve2d(
    Point2dCollection^ fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    KnotParameterizationEnum knotParam
)
Parameters
fitPoints(Point2dCollection)
startTangent(Vector2d)
endTangent(Vector2d)
startTangentDefined(Boolean)
endTangentDefined(Boolean)
knotParam(KnotParameterizationEnum)


NurbCurve2d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, knotParam, fitTolerance)

NurbCurve2d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, knotParam, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    Point2dCollection fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    KnotParameterizationEnum knotParam,
    Tolerance fitTolerance
)
Public Sub New ( _
    fitPoints As Point2dCollection, _
    startTangent As Vector2d, _
    endTangent As Vector2d, _
    startTangentDefined As Boolean, _
    endTangentDefined As Boolean, _
    knotParam As KnotParameterizationEnum, _
    fitTolerance As Tolerance _
)
public:
NurbCurve2d(
    Point2dCollection^ fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    KnotParameterizationEnum knotParam,
    Tolerance fitTolerance
)
Parameters
fitPoints(Point2dCollection)
startTangent(Vector2d)
endTangent(Vector2d)
startTangentDefined(Boolean)
endTangentDefined(Boolean)
knotParam(KnotParameterizationEnum)
fitTolerance(Tolerance)


NurbCurve2d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, fitTolerance)

NurbCurve2d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    Point2dCollection fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    Tolerance fitTolerance
)
Public Sub New ( _
    fitPoints As Point2dCollection, _
    startTangent As Vector2d, _
    endTangent As Vector2d, _
    startTangentDefined As Boolean, _
    endTangentDefined As Boolean, _
    fitTolerance As Tolerance _
)
public:
NurbCurve2d(
    Point2dCollection^ fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    Tolerance fitTolerance
)
Parameters
fitPoints(Point2dCollection)
startTangent(Vector2d)
endTangent(Vector2d)
startTangentDefined(Boolean)
endTangentDefined(Boolean)
fitTolerance(Tolerance)


NurbCurve2d Constructor (fitPoints, fitTangents, periodic)

NurbCurve2d Constructor (fitPoints, fitTangents, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Point2dCollection, Vector2dCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    Point2dCollection fitPoints,
    Vector2dCollection fitTangents,
    bool periodic
)
Public Sub New ( _
    fitPoints As Point2dCollection, _
    fitTangents As Vector2dCollection, _
    periodic As Boolean _
)
public:
NurbCurve2d(
    Point2dCollection^ fitPoints,
    Vector2dCollection^ fitTangents,
    bool periodic
)
Parameters
fitPoints(Point2dCollection)
fitTangents(Vector2dCollection)
periodic(Boolean)


NurbCurve2d Constructor (fitPoints, fitTangents, fitTolerance, periodic)

NurbCurve2d Constructor (fitPoints, fitTangents, fitTolerance, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NurbCurve2d(Point2dCollection, Vector2dCollection, Tolerance, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2d(
    Point2dCollection fitPoints,
    Vector2dCollection fitTangents,
    Tolerance fitTolerance,
    bool periodic
)
Public Sub New ( _
    fitPoints As Point2dCollection, _
    fitTangents As Vector2dCollection, _
    fitTolerance As Tolerance, _
    periodic As Boolean _
)
public:
NurbCurve2d(
    Point2dCollection^ fitPoints,
    Vector2dCollection^ fitTangents,
    Tolerance fitTolerance,
    bool periodic
)
Parameters
fitPoints(Point2dCollection)
fitTangents(Vector2dCollection)
fitTolerance(Tolerance)
periodic(Boolean)


AddControlPointAt Method (newKnot, point, weight)

AddControlPointAt Method (newKnot, point, weight)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »AddControlPointAt(Double, Point2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void AddControlPointAt(
    double newKnot,
    Point2d point,
    double weight
)
Public Sub AddControlPointAt ( _
    newKnot As Double, _
    point As Point2d, _
    weight As Double _
)
public:
void AddControlPointAt(
    double newKnot,
    Point2d point,
    double weight
)
Parameters
newKnot(Double)
point(Point2d)
weight(Double)


AddFitPointAt Method (index, point)

AddFitPointAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »AddFitPointAt(Int32, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool AddFitPointAt(
    int index,
    Point2d point
)
Public Function AddFitPointAt ( _
    index As Integer, _
    point As Point2d _
) As Boolean
public:
bool AddFitPointAt(
    int index,
    Point2d point
)
Parameters
index(Int32)
point(Point2d)


AddKnot Method (newKnot)

AddKnot Method (newKnot)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »AddKnot(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void AddKnot(
    double newKnot
)
Public Sub AddKnot ( _
    newKnot As Double _
)
public:
void AddKnot(
    double newKnot
)
Parameters
newKnot(Double)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static NurbCurve2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As NurbCurve2d
public:
static NurbCurve2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DefinitionData Property

DefinitionData Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »DefinitionData
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2dData DefinitionData { get; }
Public ReadOnly Property DefinitionData As NurbCurve2dData
    Get
public:
property NurbCurve2dData DefinitionData {
    NurbCurve2dData get ();
}


DeleteControlPointAt Method (index)

DeleteControlPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »DeleteControlPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteControlPointAt(
    int index
)
Public Sub DeleteControlPointAt ( _
    index As Integer _
)
public:
void DeleteControlPointAt(
    int index
)
Parameters
index(Int32)


DeleteFitPointAt Method (index)

DeleteFitPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »DeleteFitPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteFitPointAt(
    int index
)
Public Function DeleteFitPointAt ( _
    index As Integer _
) As Boolean
public:
bool DeleteFitPointAt(
    int index
)
Parameters
index(Int32)


ElevateDegree Method (plusDegree)

ElevateDegree Method (plusDegree)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »ElevateDegree(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void ElevateDegree(
    int plusDegree
)
Public Sub ElevateDegree ( _
    plusDegree As Integer _
)
public:
void ElevateDegree(
    int plusDegree
)
Parameters
plusDegree(Int32)


EvalMode Property

EvalMode Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »EvalMode
Declaration Syntax
C# Visual Basic Visual C++
public bool EvalMode { get; }
Public ReadOnly Property EvalMode As Boolean
    Get
public:
property bool EvalMode {
    bool get ();
}


FitData Property

FitData Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »FitData
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve2dFitData FitData { get; }
Public ReadOnly Property FitData As NurbCurve2dFitData
    Get
public:
property NurbCurve2dFitData FitData {
    NurbCurve2dFitData get ();
}


FitKnotParameterization Property

FitKnotParameterization Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »FitKnotParameterization
Declaration Syntax
C# Visual Basic Visual C++
public KnotParameterizationEnum FitKnotParameterization { get; set; }
Public Property FitKnotParameterization As KnotParameterizationEnum
    Get
    Set
public:
property KnotParameterizationEnum FitKnotParameterization {
    KnotParameterizationEnum get ();
    void set (KnotParameterizationEnum value);
}


FitTolerance Property

FitTolerance Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »FitTolerance
Declaration Syntax
C# Visual Basic Visual C++
public Tolerance FitTolerance { get; set; }
Public Property FitTolerance As Tolerance
    Get
    Set
public:
property Tolerance FitTolerance {
    Tolerance get ();
    void set (Tolerance value);
}


GetFitPointAt Method (index)

GetFitPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetFitPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetFitPointAt(
    int index
)
Public Function GetFitPointAt ( _
    index As Integer _
) As Point2d
public:
Point2d GetFitPointAt(
    int index
)
Parameters
index(Int32)


GetFitTangents Method

GetFitTangents Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetFitTangents()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d[] GetFitTangents()
Public Function GetFitTangents As Vector2d()
public:
array<Vector2d>^ GetFitTangents()


GetParametersOfC1Discontinuity Method

GetParametersOfC1Discontinuity Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetParametersOfC1Discontinuity()()()()
Members
Icon | Member | Description
 | GetParametersOfC1Discontinuity(Tolerance) |
 | GetParametersOfC1Discontinuity()()()() |


GetParametersOfC1Discontinuity Method

GetParametersOfC1Discontinuity Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetParametersOfC1Discontinuity()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetParametersOfC1Discontinuity()
Public Function GetParametersOfC1Discontinuity As DoubleCollection
public:
DoubleCollection^ GetParametersOfC1Discontinuity()


GetParametersOfC1Discontinuity Method (tolerance)

GetParametersOfC1Discontinuity Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetParametersOfC1Discontinuity(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetParametersOfC1Discontinuity(
    Tolerance tolerance
)
Public Function GetParametersOfC1Discontinuity ( _
    tolerance As Tolerance _
) As DoubleCollection
public:
DoubleCollection^ GetParametersOfC1Discontinuity(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


GetParametersOfG1Discontinuity Method

GetParametersOfG1Discontinuity Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetParametersOfG1Discontinuity()()()()
Members
Icon | Member | Description
 | GetParametersOfG1Discontinuity(Tolerance) |
 | GetParametersOfG1Discontinuity()()()() |


GetParametersOfG1Discontinuity Method

GetParametersOfG1Discontinuity Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetParametersOfG1Discontinuity()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetParametersOfG1Discontinuity()
Public Function GetParametersOfG1Discontinuity As DoubleCollection
public:
DoubleCollection^ GetParametersOfG1Discontinuity()


GetParametersOfG1Discontinuity Method (tolerance)

GetParametersOfG1Discontinuity Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetParametersOfG1Discontinuity(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetParametersOfG1Discontinuity(
    Tolerance tolerance
)
Public Function GetParametersOfG1Discontinuity ( _
    tolerance As Tolerance _
) As DoubleCollection
public:
DoubleCollection^ GetParametersOfG1Discontinuity(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


GetWeightAt Method (index)

GetWeightAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetWeightAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetWeightAt(
    int index
)
Public Function GetWeightAt ( _
    index As Integer _
) As Double
public:
double GetWeightAt(
    int index
)
Parameters
index(Int32)


HardTrimByParams Method (newStartParameter, newEndParameter)

HardTrimByParams Method (newStartParameter, newEndParameter)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »HardTrimByParams(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void HardTrimByParams(
    double newStartParameter,
    double newEndParameter
)
Public Sub HardTrimByParams ( _
    newStartParameter As Double, _
    newEndParameter As Double _
)
public:
void HardTrimByParams(
    double newStartParameter,
    double newEndParameter
)
Parameters
newStartParameter(Double)
newEndParameter(Double)


InsertKnot Method (newKnot)

InsertKnot Method (newKnot)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »InsertKnot(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertKnot(
    double newKnot
)
Public Sub InsertKnot ( _
    newKnot As Double _
)
public:
void InsertKnot(
    double newKnot
)
Parameters
newKnot(Double)


JoinWith Method (curve)

JoinWith Method (curve)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »JoinWith(NurbCurve2d)
Declaration Syntax
C# Visual Basic Visual C++
public void JoinWith(
    NurbCurve2d curve
)
Public Sub JoinWith ( _
    curve As NurbCurve2d _
)
public:
void JoinWith(
    NurbCurve2d^ curve
)
Parameters
curve(NurbCurve2d)


MakeClosed Method

MakeClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »MakeClosed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeClosed()
Public Sub MakeClosed
public:
void MakeClosed()


MakeNonPeriodic Method

MakeNonPeriodic Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »MakeNonPeriodic()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeNonPeriodic()
Public Sub MakeNonPeriodic
public:
void MakeNonPeriodic()


MakeOpen Method

MakeOpen Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »MakeOpen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeOpen()
Public Sub MakeOpen
public:
void MakeOpen()


MakePeriodic Method

MakePeriodic Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »MakePeriodic()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakePeriodic()
Public Sub MakePeriodic
public:
void MakePeriodic()


MakeRational Method (weight)

MakeRational Method (weight)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »MakeRational(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void MakeRational(
    double weight
)
Public Sub MakeRational ( _
    weight As Double _
)
public:
void MakeRational(
    double weight
)
Parameters
weight(Double)


NumFitPoints Property

NumFitPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NumFitPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumFitPoints { get; }
Public ReadOnly Property NumFitPoints As Integer
    Get
public:
property int NumFitPoints {
    int get ();
}


NumWeights Property

NumWeights Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »NumWeights
Declaration Syntax
C# Visual Basic Visual C++
public int NumWeights { get; }
Public ReadOnly Property NumWeights As Integer
    Get
public:
property int NumWeights {
    int get ();
}


PurgeFitData Method

PurgeFitData Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »PurgeFitData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool PurgeFitData()
Public Function PurgeFitData As Boolean
public:
bool PurgeFitData()


SetEvaluateMode Method (evaluateMode)

SetEvaluateMode Method (evaluateMode)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetEvaluateMode(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetEvaluateMode(
    bool evaluateMode
)
Public Sub SetEvaluateMode ( _
    evaluateMode As Boolean _
)
public:
void SetEvaluateMode(
    bool evaluateMode
)
Parameters
evaluateMode(Boolean)


SetFitData Method

SetFitData Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetFitData()()()()
Members
Icon | Member | Description
 | SetFitData(Point2dCollection, Vector2d, Vector2d, KnotParameterizationEnum, Tolerance) |
 | SetFitData(KnotCollection, Point2dCollection, Vector2d, Vector2d, Tolerance, Boolean) |
 | SetFitData(KnotCollection, Point2dCollection, Vector2d, Vector2d, Boolean) |
 | SetFitData(Point2dCollection, Vector2d, Vector2d, Tolerance) |
 | SetFitData(Int32, Point2dCollection, Tolerance) |
 | SetFitData(Point2dCollection, Vector2d, Vector2d) |
 | SetFitData(Int32, Point2dCollection) |


SetFitData Method (degree, fitPoints)

SetFitData Method (degree, fitPoints)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetFitData(Int32, Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    int degree,
    Point2dCollection fitPoints
)
Public Sub SetFitData ( _
    degree As Integer, _
    fitPoints As Point2dCollection _
)
public:
void SetFitData(
    int degree,
    Point2dCollection^ fitPoints
)
Parameters
degree(Int32)
fitPoints(Point2dCollection)


SetFitData Method (degree, fitPoints, fitTolerance)

SetFitData Method (degree, fitPoints, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetFitData(Int32, Point2dCollection, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    int degree,
    Point2dCollection fitPoints,
    Tolerance fitTolerance
)
Public Sub SetFitData ( _
    degree As Integer, _
    fitPoints As Point2dCollection, _
    fitTolerance As Tolerance _
)
public:
void SetFitData(
    int degree,
    Point2dCollection^ fitPoints,
    Tolerance fitTolerance
)
Parameters
degree(Int32)
fitPoints(Point2dCollection)
fitTolerance(Tolerance)


SetFitData Method (fitKnots, fitPoints, startTangent, endTangent, periodic)

SetFitData Method (fitKnots, fitPoints, startTangent, endTangent, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetFitData(KnotCollection, Point2dCollection, Vector2d, Vector2d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    KnotCollection fitKnots,
    Point2dCollection fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    bool periodic
)
Public Sub SetFitData ( _
    fitKnots As KnotCollection, _
    fitPoints As Point2dCollection, _
    startTangent As Vector2d, _
    endTangent As Vector2d, _
    periodic As Boolean _
)
public:
void SetFitData(
    KnotCollection^ fitKnots,
    Point2dCollection^ fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    bool periodic
)
Parameters
fitKnots(KnotCollection)
fitPoints(Point2dCollection)
startTangent(Vector2d)
endTangent(Vector2d)
periodic(Boolean)


SetFitData Method (fitKnots, fitPoints, startTangent, endTangent, fitTolerance, periodic)

SetFitData Method (fitKnots, fitPoints, startTangent, endTangent, fitTolerance, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetFitData(KnotCollection, Point2dCollection, Vector2d, Vector2d, Tolerance, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    KnotCollection fitKnots,
    Point2dCollection fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    Tolerance fitTolerance,
    bool periodic
)
Public Sub SetFitData ( _
    fitKnots As KnotCollection, _
    fitPoints As Point2dCollection, _
    startTangent As Vector2d, _
    endTangent As Vector2d, _
    fitTolerance As Tolerance, _
    periodic As Boolean _
)
public:
void SetFitData(
    KnotCollection^ fitKnots,
    Point2dCollection^ fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    Tolerance fitTolerance,
    bool periodic
)
Parameters
fitKnots(KnotCollection)
fitPoints(Point2dCollection)
startTangent(Vector2d)
endTangent(Vector2d)
fitTolerance(Tolerance)
periodic(Boolean)


SetFitData Method (fitPoints, startTangent, endTangent)

SetFitData Method (fitPoints, startTangent, endTangent)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetFitData(Point2dCollection, Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    Point2dCollection fitPoints,
    Vector2d startTangent,
    Vector2d endTangent
)
Public Sub SetFitData ( _
    fitPoints As Point2dCollection, _
    startTangent As Vector2d, _
    endTangent As Vector2d _
)
public:
void SetFitData(
    Point2dCollection^ fitPoints,
    Vector2d startTangent,
    Vector2d endTangent
)
Parameters
fitPoints(Point2dCollection)
startTangent(Vector2d)
endTangent(Vector2d)


SetFitData Method (fitPoints, startTangent, endTangent, knotParam, fitTolerance)

SetFitData Method (fitPoints, startTangent, endTangent, knotParam, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetFitData(Point2dCollection, Vector2d, Vector2d, KnotParameterizationEnum, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    Point2dCollection fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    KnotParameterizationEnum knotParam,
    Tolerance fitTolerance
)
Public Sub SetFitData ( _
    fitPoints As Point2dCollection, _
    startTangent As Vector2d, _
    endTangent As Vector2d, _
    knotParam As KnotParameterizationEnum, _
    fitTolerance As Tolerance _
)
public:
void SetFitData(
    Point2dCollection^ fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    KnotParameterizationEnum knotParam,
    Tolerance fitTolerance
)
Parameters
fitPoints(Point2dCollection)
startTangent(Vector2d)
endTangent(Vector2d)
knotParam(KnotParameterizationEnum)
fitTolerance(Tolerance)


SetFitData Method (fitPoints, startTangent, endTangent, fitTolerance)

SetFitData Method (fitPoints, startTangent, endTangent, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetFitData(Point2dCollection, Vector2d, Vector2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    Point2dCollection fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    Tolerance fitTolerance
)
Public Sub SetFitData ( _
    fitPoints As Point2dCollection, _
    startTangent As Vector2d, _
    endTangent As Vector2d, _
    fitTolerance As Tolerance _
)
public:
void SetFitData(
    Point2dCollection^ fitPoints,
    Vector2d startTangent,
    Vector2d endTangent,
    Tolerance fitTolerance
)
Parameters
fitPoints(Point2dCollection)
startTangent(Vector2d)
endTangent(Vector2d)
fitTolerance(Tolerance)


SetFitPointAt Method (index, point)

SetFitPointAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetFitPointAt(Int32, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool SetFitPointAt(
    int index,
    Point2d point
)
Public Function SetFitPointAt ( _
    index As Integer, _
    point As Point2d _
) As Boolean
public:
bool SetFitPointAt(
    int index,
    Point2d point
)
Parameters
index(Int32)
point(Point2d)


SetFitTangents Method (startTangent, endTangent)

SetFitTangents Method (startTangent, endTangent)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetFitTangents(Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool SetFitTangents(
    Vector2d startTangent,
    Vector2d endTangent
)
Public Function SetFitTangents ( _
    startTangent As Vector2d, _
    endTangent As Vector2d _
) As Boolean
public:
bool SetFitTangents(
    Vector2d startTangent,
    Vector2d endTangent
)
Parameters
startTangent(Vector2d)
endTangent(Vector2d)


SetWeightAt Method (index, value)

SetWeightAt Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »SetWeightAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetWeightAt(
    int index,
    double value
)
Public Sub SetWeightAt ( _
    index As Integer, _
    value As Double _
)
public:
void SetWeightAt(
    int index,
    double value
)
Parameters
index(Int32)
value(Double)


NurbCurve2dData Structure

NurbCurve2dData Structure
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData
Declaration Syntax
C# Visual Basic Visual C++
public struct NurbCurve2dData
Public Structure NurbCurve2dData
public value class NurbCurve2dData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ControlPoints |
 | Degree |
 | Equality(NurbCurve2dData, NurbCurve2dData) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(NurbCurve2dData, NurbCurve2dData) |
 | IsEqualTo(NurbCurve2dData) |
 | Knots |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Periodic |
 | Rational |
 | ToString()()()() | (Inherited from ValueType.)
 | Weights |


ControlPoints Property

ControlPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »ControlPoints
Declaration Syntax
C# Visual Basic Visual C++
public Point2dCollection ControlPoints { get; }
Public ReadOnly Property ControlPoints As Point2dCollection
    Get
public:
property Point2dCollection^ ControlPoints {
    Point2dCollection^ get ();
}


Degree Property

Degree Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »Degree
Declaration Syntax
C# Visual Basic Visual C++
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »Equality(NurbCurve2dData, NurbCurve2dData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    NurbCurve2dData a,
    NurbCurve2dData b
)
Public Shared Operator = ( _
    a As NurbCurve2dData, _
    b As NurbCurve2dData _
) As Boolean
public:
static bool operator ==(
    NurbCurve2dData a,
    NurbCurve2dData b
)
Parameters
a(NurbCurve2dData)
b(NurbCurve2dData)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »Inequality(NurbCurve2dData, NurbCurve2dData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    NurbCurve2dData a,
    NurbCurve2dData b
)
Public Shared Operator <> ( _
    a As NurbCurve2dData, _
    b As NurbCurve2dData _
) As Boolean
public:
static bool operator !=(
    NurbCurve2dData a,
    NurbCurve2dData b
)
Parameters
a(NurbCurve2dData)
b(NurbCurve2dData)


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »IsEqualTo(NurbCurve2dData)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    NurbCurve2dData a
)
Public Function IsEqualTo ( _
    a As NurbCurve2dData _
) As Boolean
public:
bool IsEqualTo(
    NurbCurve2dData a
)
Parameters
a(NurbCurve2dData)


Knots Property

Knots Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »Knots
Declaration Syntax
C# Visual Basic Visual C++
public KnotCollection Knots { get; }
Public ReadOnly Property Knots As KnotCollection
    Get
public:
property KnotCollection^ Knots {
    KnotCollection^ get ();
}


Periodic Property

Periodic Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »Periodic
Declaration Syntax
C# Visual Basic Visual C++
public bool Periodic { get; }
Public ReadOnly Property Periodic As Boolean
    Get
public:
property bool Periodic {
    bool get ();
}


Rational Property

Rational Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »Rational
Declaration Syntax
C# Visual Basic Visual C++
public bool Rational { get; }
Public ReadOnly Property Rational As Boolean
    Get
public:
property bool Rational {
    bool get ();
}


Weights Property

Weights Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dData »Weights
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection Weights { get; }
Public ReadOnly Property Weights As DoubleCollection
    Get
public:
property DoubleCollection^ Weights {
    DoubleCollection^ get ();
}


NurbCurve2dFitData Structure

NurbCurve2dFitData Structure
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData
Declaration Syntax
C# Visual Basic Visual C++
public struct NurbCurve2dFitData
Public Structure NurbCurve2dFitData
public value class NurbCurve2dFitData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Degree |
 | EndTangent |
 | Equality(NurbCurve2dFitData, NurbCurve2dFitData) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | FitPoints |
 | FitTolerance |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(NurbCurve2dFitData, NurbCurve2dFitData) |
 | IsEqualTo(NurbCurve2dFitData) |
 | KnotParam |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | StartTangent |
 | TangentsExist |
 | ToString()()()() | (Inherited from ValueType.)


Degree Property

Degree Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »Degree
Declaration Syntax
C# Visual Basic Visual C++
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}


EndTangent Property

EndTangent Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »EndTangent
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d EndTangent { get; }
Public ReadOnly Property EndTangent As Vector2d
    Get
public:
property Vector2d EndTangent {
    Vector2d get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »Equality(NurbCurve2dFitData, NurbCurve2dFitData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    NurbCurve2dFitData a,
    NurbCurve2dFitData b
)
Public Shared Operator = ( _
    a As NurbCurve2dFitData, _
    b As NurbCurve2dFitData _
) As Boolean
public:
static bool operator ==(
    NurbCurve2dFitData a,
    NurbCurve2dFitData b
)
Parameters
a(NurbCurve2dFitData)
b(NurbCurve2dFitData)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


FitPoints Property

FitPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »FitPoints
Declaration Syntax
C# Visual Basic Visual C++
public Point2dCollection FitPoints { get; }
Public ReadOnly Property FitPoints As Point2dCollection
    Get
public:
property Point2dCollection^ FitPoints {
    Point2dCollection^ get ();
}


FitTolerance Property

FitTolerance Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »FitTolerance
Declaration Syntax
C# Visual Basic Visual C++
public Tolerance FitTolerance { get; }
Public ReadOnly Property FitTolerance As Tolerance
    Get
public:
property Tolerance FitTolerance {
    Tolerance get ();
}


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »Inequality(NurbCurve2dFitData, NurbCurve2dFitData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    NurbCurve2dFitData a,
    NurbCurve2dFitData b
)
Public Shared Operator <> ( _
    a As NurbCurve2dFitData, _
    b As NurbCurve2dFitData _
) As Boolean
public:
static bool operator !=(
    NurbCurve2dFitData a,
    NurbCurve2dFitData b
)
Parameters
a(NurbCurve2dFitData)
b(NurbCurve2dFitData)


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »IsEqualTo(NurbCurve2dFitData)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    NurbCurve2dFitData a
)
Public Function IsEqualTo ( _
    a As NurbCurve2dFitData _
) As Boolean
public:
bool IsEqualTo(
    NurbCurve2dFitData a
)
Parameters
a(NurbCurve2dFitData)


KnotParam Property

KnotParam Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »KnotParam
Declaration Syntax
C# Visual Basic Visual C++
public KnotParameterizationEnum KnotParam { get; }
Public ReadOnly Property KnotParam As KnotParameterizationEnum
    Get
public:
property KnotParameterizationEnum KnotParam {
    KnotParameterizationEnum get ();
}


StartTangent Property

StartTangent Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »StartTangent
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d StartTangent { get; }
Public ReadOnly Property StartTangent As Vector2d
    Get
public:
property Vector2d StartTangent {
    Vector2d get ();
}


TangentsExist Property

TangentsExist Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2dFitData »TangentsExist
Declaration Syntax
C# Visual Basic Visual C++
public bool TangentsExist { get; }
Public ReadOnly Property TangentsExist As Boolean
    Get
public:
property bool TangentsExist {
    bool get ();
}


NurbCurve3d Class

NurbCurve3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeNurbCurve3d")]
public sealed class NurbCurve3d : SplineEntity3d
<WrapperAttribute("ZcGeNurbCurve3d")> _
Public NotInheritable Class NurbCurve3d _
    Inherits SplineEntity3d
[WrapperAttribute(L"ZcGeNurbCurve3d")]
public ref class NurbCurve3d sealed : public SplineEntity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, KnotParameterizationEnum, Tolerance) |
 | NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, KnotParameterizationEnum) |
 | NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, Tolerance) |
 | NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean) |
 | NurbCurve3d(Int32, KnotCollection, Point3dCollection, DoubleCollection, Boolean) |
 | NurbCurve3d(Int32, KnotCollection, Point3dCollection, Boolean) |
 | NurbCurve3d(Int32, PolylineCurve3d, Boolean) |
 | NurbCurve3d(Point3dCollection, Vector3dCollection, Tolerance, Boolean) |
 | NurbCurve3d(Point3dCollection, Vector3dCollection, Boolean) |
 | NurbCurve3d(Point3dCollection, Tolerance) |
 | NurbCurve3d(Point3dCollection) |
 | NurbCurve3d(LineSegment3d) |
 | NurbCurve3d(EllipticalArc3d) |
 | NurbCurve3d()()()() |
 | AddControlPointAt(Double, Point3d, Double) |
 | AddFitPointAt(Int32, Point3d) |
 | AddKnot(Double) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ControlPointAt(Int32) | (Inherited from SplineEntity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DefinitionData |
 | Degree | (Inherited from SplineEntity3d.)
 | DeleteControlPointAt(Int32) |
 | DeleteFitPointAt(Int32) |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | ElevateDegree(Int32) |
 | EndParameter | (Inherited from SplineEntity3d.)
 | EndPoint | (Inherited from SplineEntity3d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvalMode |
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FitData |
 | FitKnotParameterization |
 | FitTolerance |
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetContinuityAtKnot(Int32, Tolerance) | (Inherited from SplineEntity3d.)
 | GetContinuityAtKnot(Int32) | (Inherited from SplineEntity3d.)
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetFitPointAt(Int32) |
 | GetFitTangents()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetParametersOfC1Discontinuity(Tolerance) |
 | GetParametersOfC1Discontinuity()()()() |
 | GetParametersOfG1Discontinuity(Tolerance) |
 | GetParametersOfG1Discontinuity()()()() |
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | GetWeightAt(Int32) |
 | HardTrimByParams(Double, Double) |
 | HasEndPoint | (Inherited from Curve3d.)
 | HasFitData | (Inherited from SplineEntity3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertKnot(Double) |
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | IsRational | (Inherited from SplineEntity3d.)
 | JoinWith(NurbCurve3d) |
 | KnotAt(Int32) | (Inherited from SplineEntity3d.)
 | Knots | (Inherited from SplineEntity3d.)
 | MakeClosed()()()() |
 | MakeNonPeriodic()()()() |
 | MakeOpen()()()() |
 | MakePeriodic()()()() |
 | MakeRational(Double) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | NumberOfControlPoints | (Inherited from SplineEntity3d.)
 | NumberOfKnots | (Inherited from SplineEntity3d.)
 | NumFitPoints |
 | NumWeights |
 | Order | (Inherited from SplineEntity3d.)
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | PurgeFitData()()()() |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | SetControlPointAt(Int32, Point3d) | (Inherited from SplineEntity3d.)
 | SetEvaluateMode(Boolean) |
 | SetFitData(Point3dCollection, Vector3d, Vector3d, KnotParameterizationEnum, Tolerance) |
 | SetFitData(KnotCollection, Point3dCollection, Vector3d, Vector3d, Tolerance, Boolean) |
 | SetFitData(KnotCollection, Point3dCollection, Vector3d, Vector3d, Boolean) |
 | SetFitData(Point3dCollection, Vector3d, Vector3d, Tolerance) |
 | SetFitData(Int32, Point3dCollection, Tolerance) |
 | SetFitData(Point3dCollection, Vector3d, Vector3d) |
 | SetFitData(Int32, Point3dCollection) |
 | SetFitPointAt(Int32, Point3d) |
 | SetFitTangents(Vector3d, Vector3d) |
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | SetKnotAt(Int32, Double) | (Inherited from SplineEntity3d.)
 | SetWeightAt(Int32, Double) |
 | StartParameter | (Inherited from SplineEntity3d.)
 | StartPoint | (Inherited from SplineEntity3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | SplineEntity3d
 |  |  |  |  |  | NurbCurve3d


NurbCurve3d Constructor

NurbCurve3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d()()()()
Members
Icon | Member | Description
 | NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, KnotParameterizationEnum, Tolerance) |
 | NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, KnotParameterizationEnum) |
 | NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, Tolerance) |
 | NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean) |
 | NurbCurve3d(Int32, KnotCollection, Point3dCollection, DoubleCollection, Boolean) |
 | NurbCurve3d(Int32, KnotCollection, Point3dCollection, Boolean) |
 | NurbCurve3d(Int32, PolylineCurve3d, Boolean) |
 | NurbCurve3d(Point3dCollection, Vector3dCollection, Tolerance, Boolean) |
 | NurbCurve3d(Point3dCollection, Vector3dCollection, Boolean) |
 | NurbCurve3d(Point3dCollection, Tolerance) |
 | NurbCurve3d(Point3dCollection) |
 | NurbCurve3d(LineSegment3d) |
 | NurbCurve3d(EllipticalArc3d) |
 | NurbCurve3d()()()() |


NurbCurve3d Constructor

NurbCurve3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d()
Public Sub New
public:
NurbCurve3d()


NurbCurve3d Constructor (degree, knots, controlPoints, periodic)

NurbCurve3d Constructor (degree, knots, controlPoints, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Int32, KnotCollection, Point3dCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    int degree,
    KnotCollection knots,
    Point3dCollection controlPoints,
    bool periodic
)
Public Sub New ( _
    degree As Integer, _
    knots As KnotCollection, _
    controlPoints As Point3dCollection, _
    periodic As Boolean _
)
public:
NurbCurve3d(
    int degree,
    KnotCollection^ knots,
    Point3dCollection^ controlPoints,
    bool periodic
)
Parameters
degree(Int32)
knots(KnotCollection)
controlPoints(Point3dCollection)
periodic(Boolean)


NurbCurve3d Constructor (degree, knots, controlPoints, weights, periodic)

NurbCurve3d Constructor (degree, knots, controlPoints, weights, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Int32, KnotCollection, Point3dCollection, DoubleCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    int degree,
    KnotCollection knots,
    Point3dCollection controlPoints,
    DoubleCollection weights,
    bool periodic
)
Public Sub New ( _
    degree As Integer, _
    knots As KnotCollection, _
    controlPoints As Point3dCollection, _
    weights As DoubleCollection, _
    periodic As Boolean _
)
public:
NurbCurve3d(
    int degree,
    KnotCollection^ knots,
    Point3dCollection^ controlPoints,
    DoubleCollection^ weights,
    bool periodic
)
Parameters
degree(Int32)
knots(KnotCollection)
controlPoints(Point3dCollection)
weights(DoubleCollection)
periodic(Boolean)


NurbCurve3d Constructor (degree, fitPolyline, periodic)

NurbCurve3d Constructor (degree, fitPolyline, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Int32, PolylineCurve3d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    int degree,
    PolylineCurve3d fitPolyline,
    bool periodic
)
Public Sub New ( _
    degree As Integer, _
    fitPolyline As PolylineCurve3d, _
    periodic As Boolean _
)
public:
NurbCurve3d(
    int degree,
    PolylineCurve3d^ fitPolyline,
    bool periodic
)
Parameters
degree(Int32)
fitPolyline(PolylineCurve3d)
periodic(Boolean)


NurbCurve3d Constructor (ellipse)

NurbCurve3d Constructor (ellipse)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(EllipticalArc3d)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    EllipticalArc3d ellipse
)
Public Sub New ( _
    ellipse As EllipticalArc3d _
)
public:
NurbCurve3d(
    EllipticalArc3d^ ellipse
)
Parameters
ellipse(EllipticalArc3d)


NurbCurve3d Constructor (lineSegment)

NurbCurve3d Constructor (lineSegment)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(LineSegment3d)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    LineSegment3d lineSegment
)
Public Sub New ( _
    lineSegment As LineSegment3d _
)
public:
NurbCurve3d(
    LineSegment3d^ lineSegment
)
Parameters
lineSegment(LineSegment3d)


NurbCurve3d Constructor (fitPoints)

NurbCurve3d Constructor (fitPoints)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    Point3dCollection fitPoints
)
Public Sub New ( _
    fitPoints As Point3dCollection _
)
public:
NurbCurve3d(
    Point3dCollection^ fitPoints
)
Parameters
fitPoints(Point3dCollection)


NurbCurve3d Constructor (fitPoints, fitTolerance)

NurbCurve3d Constructor (fitPoints, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Point3dCollection, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    Point3dCollection fitPoints,
    Tolerance fitTolerance
)
Public Sub New ( _
    fitPoints As Point3dCollection, _
    fitTolerance As Tolerance _
)
public:
NurbCurve3d(
    Point3dCollection^ fitPoints,
    Tolerance fitTolerance
)
Parameters
fitPoints(Point3dCollection)
fitTolerance(Tolerance)


NurbCurve3d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined)

NurbCurve3d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    Point3dCollection fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    bool startTangentDefined,
    bool endTangentDefined
)
Public Sub New ( _
    fitPoints As Point3dCollection, _
    startTangent As Vector3d, _
    endTangent As Vector3d, _
    startTangentDefined As Boolean, _
    endTangentDefined As Boolean _
)
public:
NurbCurve3d(
    Point3dCollection^ fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    bool startTangentDefined,
    bool endTangentDefined
)
Parameters
fitPoints(Point3dCollection)
startTangent(Vector3d)
endTangent(Vector3d)
startTangentDefined(Boolean)
endTangentDefined(Boolean)


NurbCurve3d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, knotParam)

NurbCurve3d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, knotParam)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, KnotParameterizationEnum)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    Point3dCollection fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    KnotParameterizationEnum knotParam
)
Public Sub New ( _
    fitPoints As Point3dCollection, _
    startTangent As Vector3d, _
    endTangent As Vector3d, _
    startTangentDefined As Boolean, _
    endTangentDefined As Boolean, _
    knotParam As KnotParameterizationEnum _
)
public:
NurbCurve3d(
    Point3dCollection^ fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    KnotParameterizationEnum knotParam
)
Parameters
fitPoints(Point3dCollection)
startTangent(Vector3d)
endTangent(Vector3d)
startTangentDefined(Boolean)
endTangentDefined(Boolean)
knotParam(KnotParameterizationEnum)


NurbCurve3d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, knotParam, fitTolerance)

NurbCurve3d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, knotParam, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, KnotParameterizationEnum, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    Point3dCollection fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    KnotParameterizationEnum knotParam,
    Tolerance fitTolerance
)
Public Sub New ( _
    fitPoints As Point3dCollection, _
    startTangent As Vector3d, _
    endTangent As Vector3d, _
    startTangentDefined As Boolean, _
    endTangentDefined As Boolean, _
    knotParam As KnotParameterizationEnum, _
    fitTolerance As Tolerance _
)
public:
NurbCurve3d(
    Point3dCollection^ fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    KnotParameterizationEnum knotParam,
    Tolerance fitTolerance
)
Parameters
fitPoints(Point3dCollection)
startTangent(Vector3d)
endTangent(Vector3d)
startTangentDefined(Boolean)
endTangentDefined(Boolean)
knotParam(KnotParameterizationEnum)
fitTolerance(Tolerance)


NurbCurve3d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, fitTolerance)

NurbCurve3d Constructor (fitPoints, startTangent, endTangent, startTangentDefined, endTangentDefined, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    Point3dCollection fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    Tolerance fitTolerance
)
Public Sub New ( _
    fitPoints As Point3dCollection, _
    startTangent As Vector3d, _
    endTangent As Vector3d, _
    startTangentDefined As Boolean, _
    endTangentDefined As Boolean, _
    fitTolerance As Tolerance _
)
public:
NurbCurve3d(
    Point3dCollection^ fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    bool startTangentDefined,
    bool endTangentDefined,
    Tolerance fitTolerance
)
Parameters
fitPoints(Point3dCollection)
startTangent(Vector3d)
endTangent(Vector3d)
startTangentDefined(Boolean)
endTangentDefined(Boolean)
fitTolerance(Tolerance)


NurbCurve3d Constructor (fitPoints, fitTangents, periodic)

NurbCurve3d Constructor (fitPoints, fitTangents, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Point3dCollection, Vector3dCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    Point3dCollection fitPoints,
    Vector3dCollection fitTangents,
    bool periodic
)
Public Sub New ( _
    fitPoints As Point3dCollection, _
    fitTangents As Vector3dCollection, _
    periodic As Boolean _
)
public:
NurbCurve3d(
    Point3dCollection^ fitPoints,
    Vector3dCollection^ fitTangents,
    bool periodic
)
Parameters
fitPoints(Point3dCollection)
fitTangents(Vector3dCollection)
periodic(Boolean)


NurbCurve3d Constructor (fitPoints, fitTangents, fitTolerance, periodic)

NurbCurve3d Constructor (fitPoints, fitTangents, fitTolerance, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NurbCurve3d(Point3dCollection, Vector3dCollection, Tolerance, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3d(
    Point3dCollection fitPoints,
    Vector3dCollection fitTangents,
    Tolerance fitTolerance,
    bool periodic
)
Public Sub New ( _
    fitPoints As Point3dCollection, _
    fitTangents As Vector3dCollection, _
    fitTolerance As Tolerance, _
    periodic As Boolean _
)
public:
NurbCurve3d(
    Point3dCollection^ fitPoints,
    Vector3dCollection^ fitTangents,
    Tolerance fitTolerance,
    bool periodic
)
Parameters
fitPoints(Point3dCollection)
fitTangents(Vector3dCollection)
fitTolerance(Tolerance)
periodic(Boolean)


AddControlPointAt Method (newKnot, point, weight)

AddControlPointAt Method (newKnot, point, weight)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »AddControlPointAt(Double, Point3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void AddControlPointAt(
    double newKnot,
    Point3d point,
    double weight
)
Public Sub AddControlPointAt ( _
    newKnot As Double, _
    point As Point3d, _
    weight As Double _
)
public:
void AddControlPointAt(
    double newKnot,
    Point3d point,
    double weight
)
Parameters
newKnot(Double)
point(Point3d)
weight(Double)


AddFitPointAt Method (index, point)

AddFitPointAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »AddFitPointAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool AddFitPointAt(
    int index,
    Point3d point
)
Public Function AddFitPointAt ( _
    index As Integer, _
    point As Point3d _
) As Boolean
public:
bool AddFitPointAt(
    int index,
    Point3d point
)
Parameters
index(Int32)
point(Point3d)


AddKnot Method (newKnot)

AddKnot Method (newKnot)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »AddKnot(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void AddKnot(
    double newKnot
)
Public Sub AddKnot ( _
    newKnot As Double _
)
public:
void AddKnot(
    double newKnot
)
Parameters
newKnot(Double)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static NurbCurve3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As NurbCurve3d
public:
static NurbCurve3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DefinitionData Property

DefinitionData Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »DefinitionData
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3dData DefinitionData { get; }
Public ReadOnly Property DefinitionData As NurbCurve3dData
    Get
public:
property NurbCurve3dData DefinitionData {
    NurbCurve3dData get ();
}


DeleteControlPointAt Method (index)

DeleteControlPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »DeleteControlPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteControlPointAt(
    int index
)
Public Sub DeleteControlPointAt ( _
    index As Integer _
)
public:
void DeleteControlPointAt(
    int index
)
Parameters
index(Int32)


DeleteFitPointAt Method (index)

DeleteFitPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »DeleteFitPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteFitPointAt(
    int index
)
Public Function DeleteFitPointAt ( _
    index As Integer _
) As Boolean
public:
bool DeleteFitPointAt(
    int index
)
Parameters
index(Int32)


ElevateDegree Method (plusDegree)

ElevateDegree Method (plusDegree)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »ElevateDegree(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void ElevateDegree(
    int plusDegree
)
Public Sub ElevateDegree ( _
    plusDegree As Integer _
)
public:
void ElevateDegree(
    int plusDegree
)
Parameters
plusDegree(Int32)


EvalMode Property

EvalMode Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »EvalMode
Declaration Syntax
C# Visual Basic Visual C++
public bool EvalMode { get; }
Public ReadOnly Property EvalMode As Boolean
    Get
public:
property bool EvalMode {
    bool get ();
}


FitData Property

FitData Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »FitData
Declaration Syntax
C# Visual Basic Visual C++
public NurbCurve3dFitData FitData { get; }
Public ReadOnly Property FitData As NurbCurve3dFitData
    Get
public:
property NurbCurve3dFitData FitData {
    NurbCurve3dFitData get ();
}


FitKnotParameterization Property

FitKnotParameterization Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »FitKnotParameterization
Declaration Syntax
C# Visual Basic Visual C++
public KnotParameterizationEnum FitKnotParameterization { get; set; }
Public Property FitKnotParameterization As KnotParameterizationEnum
    Get
    Set
public:
property KnotParameterizationEnum FitKnotParameterization {
    KnotParameterizationEnum get ();
    void set (KnotParameterizationEnum value);
}


FitTolerance Property

FitTolerance Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »FitTolerance
Declaration Syntax
C# Visual Basic Visual C++
public Tolerance FitTolerance { get; set; }
Public Property FitTolerance As Tolerance
    Get
    Set
public:
property Tolerance FitTolerance {
    Tolerance get ();
    void set (Tolerance value);
}


GetFitPointAt Method (index)

GetFitPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetFitPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetFitPointAt(
    int index
)
Public Function GetFitPointAt ( _
    index As Integer _
) As Point3d
public:
Point3d GetFitPointAt(
    int index
)
Parameters
index(Int32)


GetFitTangents Method

GetFitTangents Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetFitTangents()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d[] GetFitTangents()
Public Function GetFitTangents As Vector3d()
public:
array<Vector3d>^ GetFitTangents()


GetParametersOfC1Discontinuity Method

GetParametersOfC1Discontinuity Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetParametersOfC1Discontinuity()()()()
Members
Icon | Member | Description
 | GetParametersOfC1Discontinuity(Tolerance) |
 | GetParametersOfC1Discontinuity()()()() |


GetParametersOfC1Discontinuity Method

GetParametersOfC1Discontinuity Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetParametersOfC1Discontinuity()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetParametersOfC1Discontinuity()
Public Function GetParametersOfC1Discontinuity As DoubleCollection
public:
DoubleCollection^ GetParametersOfC1Discontinuity()


GetParametersOfC1Discontinuity Method (tolerance)

GetParametersOfC1Discontinuity Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetParametersOfC1Discontinuity(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetParametersOfC1Discontinuity(
    Tolerance tolerance
)
Public Function GetParametersOfC1Discontinuity ( _
    tolerance As Tolerance _
) As DoubleCollection
public:
DoubleCollection^ GetParametersOfC1Discontinuity(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


GetParametersOfG1Discontinuity Method

GetParametersOfG1Discontinuity Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetParametersOfG1Discontinuity()()()()
Members
Icon | Member | Description
 | GetParametersOfG1Discontinuity(Tolerance) |
 | GetParametersOfG1Discontinuity()()()() |


GetParametersOfG1Discontinuity Method

GetParametersOfG1Discontinuity Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetParametersOfG1Discontinuity()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetParametersOfG1Discontinuity()
Public Function GetParametersOfG1Discontinuity As DoubleCollection
public:
DoubleCollection^ GetParametersOfG1Discontinuity()


GetParametersOfG1Discontinuity Method (tolerance)

GetParametersOfG1Discontinuity Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetParametersOfG1Discontinuity(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection GetParametersOfG1Discontinuity(
    Tolerance tolerance
)
Public Function GetParametersOfG1Discontinuity ( _
    tolerance As Tolerance _
) As DoubleCollection
public:
DoubleCollection^ GetParametersOfG1Discontinuity(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


GetWeightAt Method (index)

GetWeightAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetWeightAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetWeightAt(
    int index
)
Public Function GetWeightAt ( _
    index As Integer _
) As Double
public:
double GetWeightAt(
    int index
)
Parameters
index(Int32)


HardTrimByParams Method (newStartParameter, newEndParameter)

HardTrimByParams Method (newStartParameter, newEndParameter)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »HardTrimByParams(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void HardTrimByParams(
    double newStartParameter,
    double newEndParameter
)
Public Sub HardTrimByParams ( _
    newStartParameter As Double, _
    newEndParameter As Double _
)
public:
void HardTrimByParams(
    double newStartParameter,
    double newEndParameter
)
Parameters
newStartParameter(Double)
newEndParameter(Double)


InsertKnot Method (newKnot)

InsertKnot Method (newKnot)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »InsertKnot(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void InsertKnot(
    double newKnot
)
Public Sub InsertKnot ( _
    newKnot As Double _
)
public:
void InsertKnot(
    double newKnot
)
Parameters
newKnot(Double)


JoinWith Method (curve)

JoinWith Method (curve)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »JoinWith(NurbCurve3d)
Declaration Syntax
C# Visual Basic Visual C++
public void JoinWith(
    NurbCurve3d curve
)
Public Sub JoinWith ( _
    curve As NurbCurve3d _
)
public:
void JoinWith(
    NurbCurve3d^ curve
)
Parameters
curve(NurbCurve3d)


MakeClosed Method

MakeClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »MakeClosed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeClosed()
Public Sub MakeClosed
public:
void MakeClosed()


MakeNonPeriodic Method

MakeNonPeriodic Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »MakeNonPeriodic()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeNonPeriodic()
Public Sub MakeNonPeriodic
public:
void MakeNonPeriodic()


MakeOpen Method

MakeOpen Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »MakeOpen()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakeOpen()
Public Sub MakeOpen
public:
void MakeOpen()


MakePeriodic Method

MakePeriodic Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »MakePeriodic()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void MakePeriodic()
Public Sub MakePeriodic
public:
void MakePeriodic()


MakeRational Method (weight)

MakeRational Method (weight)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »MakeRational(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void MakeRational(
    double weight
)
Public Sub MakeRational ( _
    weight As Double _
)
public:
void MakeRational(
    double weight
)
Parameters
weight(Double)


NumFitPoints Property

NumFitPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NumFitPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumFitPoints { get; }
Public ReadOnly Property NumFitPoints As Integer
    Get
public:
property int NumFitPoints {
    int get ();
}


NumWeights Property

NumWeights Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »NumWeights
Declaration Syntax
C# Visual Basic Visual C++
public int NumWeights { get; }
Public ReadOnly Property NumWeights As Integer
    Get
public:
property int NumWeights {
    int get ();
}


PurgeFitData Method

PurgeFitData Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »PurgeFitData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool PurgeFitData()
Public Function PurgeFitData As Boolean
public:
bool PurgeFitData()


SetEvaluateMode Method (evaluateMode)

SetEvaluateMode Method (evaluateMode)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetEvaluateMode(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetEvaluateMode(
    bool evaluateMode
)
Public Sub SetEvaluateMode ( _
    evaluateMode As Boolean _
)
public:
void SetEvaluateMode(
    bool evaluateMode
)
Parameters
evaluateMode(Boolean)


SetFitData Method

SetFitData Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetFitData()()()()
Members
Icon | Member | Description
 | SetFitData(Point3dCollection, Vector3d, Vector3d, KnotParameterizationEnum, Tolerance) |
 | SetFitData(KnotCollection, Point3dCollection, Vector3d, Vector3d, Tolerance, Boolean) |
 | SetFitData(KnotCollection, Point3dCollection, Vector3d, Vector3d, Boolean) |
 | SetFitData(Point3dCollection, Vector3d, Vector3d, Tolerance) |
 | SetFitData(Int32, Point3dCollection, Tolerance) |
 | SetFitData(Point3dCollection, Vector3d, Vector3d) |
 | SetFitData(Int32, Point3dCollection) |


SetFitData Method (degree, fitPoints)

SetFitData Method (degree, fitPoints)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetFitData(Int32, Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    int degree,
    Point3dCollection fitPoints
)
Public Sub SetFitData ( _
    degree As Integer, _
    fitPoints As Point3dCollection _
)
public:
void SetFitData(
    int degree,
    Point3dCollection^ fitPoints
)
Parameters
degree(Int32)
fitPoints(Point3dCollection)


SetFitData Method (degree, fitPoints, fitTolerance)

SetFitData Method (degree, fitPoints, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetFitData(Int32, Point3dCollection, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    int degree,
    Point3dCollection fitPoints,
    Tolerance fitTolerance
)
Public Sub SetFitData ( _
    degree As Integer, _
    fitPoints As Point3dCollection, _
    fitTolerance As Tolerance _
)
public:
void SetFitData(
    int degree,
    Point3dCollection^ fitPoints,
    Tolerance fitTolerance
)
Parameters
degree(Int32)
fitPoints(Point3dCollection)
fitTolerance(Tolerance)


SetFitData Method (fitKnots, fitPoints, startTangent, endTangent, periodic)

SetFitData Method (fitKnots, fitPoints, startTangent, endTangent, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetFitData(KnotCollection, Point3dCollection, Vector3d, Vector3d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    KnotCollection fitKnots,
    Point3dCollection fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    bool periodic
)
Public Sub SetFitData ( _
    fitKnots As KnotCollection, _
    fitPoints As Point3dCollection, _
    startTangent As Vector3d, _
    endTangent As Vector3d, _
    periodic As Boolean _
)
public:
void SetFitData(
    KnotCollection^ fitKnots,
    Point3dCollection^ fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    bool periodic
)
Parameters
fitKnots(KnotCollection)
fitPoints(Point3dCollection)
startTangent(Vector3d)
endTangent(Vector3d)
periodic(Boolean)


SetFitData Method (fitKnots, fitPoints, startTangent, endTangent, fitTolerance, periodic)

SetFitData Method (fitKnots, fitPoints, startTangent, endTangent, fitTolerance, periodic)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetFitData(KnotCollection, Point3dCollection, Vector3d, Vector3d, Tolerance, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    KnotCollection fitKnots,
    Point3dCollection fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    Tolerance fitTolerance,
    bool periodic
)
Public Sub SetFitData ( _
    fitKnots As KnotCollection, _
    fitPoints As Point3dCollection, _
    startTangent As Vector3d, _
    endTangent As Vector3d, _
    fitTolerance As Tolerance, _
    periodic As Boolean _
)
public:
void SetFitData(
    KnotCollection^ fitKnots,
    Point3dCollection^ fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    Tolerance fitTolerance,
    bool periodic
)
Parameters
fitKnots(KnotCollection)
fitPoints(Point3dCollection)
startTangent(Vector3d)
endTangent(Vector3d)
fitTolerance(Tolerance)
periodic(Boolean)


SetFitData Method (fitPoints, startTangent, endTangent)

SetFitData Method (fitPoints, startTangent, endTangent)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetFitData(Point3dCollection, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    Point3dCollection fitPoints,
    Vector3d startTangent,
    Vector3d endTangent
)
Public Sub SetFitData ( _
    fitPoints As Point3dCollection, _
    startTangent As Vector3d, _
    endTangent As Vector3d _
)
public:
void SetFitData(
    Point3dCollection^ fitPoints,
    Vector3d startTangent,
    Vector3d endTangent
)
Parameters
fitPoints(Point3dCollection)
startTangent(Vector3d)
endTangent(Vector3d)


SetFitData Method (fitPoints, startTangent, endTangent, knotParam, fitTolerance)

SetFitData Method (fitPoints, startTangent, endTangent, knotParam, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetFitData(Point3dCollection, Vector3d, Vector3d, KnotParameterizationEnum, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    Point3dCollection fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    KnotParameterizationEnum knotParam,
    Tolerance fitTolerance
)
Public Sub SetFitData ( _
    fitPoints As Point3dCollection, _
    startTangent As Vector3d, _
    endTangent As Vector3d, _
    knotParam As KnotParameterizationEnum, _
    fitTolerance As Tolerance _
)
public:
void SetFitData(
    Point3dCollection^ fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    KnotParameterizationEnum knotParam,
    Tolerance fitTolerance
)
Parameters
fitPoints(Point3dCollection)
startTangent(Vector3d)
endTangent(Vector3d)
knotParam(KnotParameterizationEnum)
fitTolerance(Tolerance)


SetFitData Method (fitPoints, startTangent, endTangent, fitTolerance)

SetFitData Method (fitPoints, startTangent, endTangent, fitTolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetFitData(Point3dCollection, Vector3d, Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitData(
    Point3dCollection fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    Tolerance fitTolerance
)
Public Sub SetFitData ( _
    fitPoints As Point3dCollection, _
    startTangent As Vector3d, _
    endTangent As Vector3d, _
    fitTolerance As Tolerance _
)
public:
void SetFitData(
    Point3dCollection^ fitPoints,
    Vector3d startTangent,
    Vector3d endTangent,
    Tolerance fitTolerance
)
Parameters
fitPoints(Point3dCollection)
startTangent(Vector3d)
endTangent(Vector3d)
fitTolerance(Tolerance)


SetFitPointAt Method (index, point)

SetFitPointAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetFitPointAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool SetFitPointAt(
    int index,
    Point3d point
)
Public Function SetFitPointAt ( _
    index As Integer, _
    point As Point3d _
) As Boolean
public:
bool SetFitPointAt(
    int index,
    Point3d point
)
Parameters
index(Int32)
point(Point3d)


SetFitTangents Method (startTangent, endTangent)

SetFitTangents Method (startTangent, endTangent)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetFitTangents(Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool SetFitTangents(
    Vector3d startTangent,
    Vector3d endTangent
)
Public Function SetFitTangents ( _
    startTangent As Vector3d, _
    endTangent As Vector3d _
) As Boolean
public:
bool SetFitTangents(
    Vector3d startTangent,
    Vector3d endTangent
)
Parameters
startTangent(Vector3d)
endTangent(Vector3d)


SetWeightAt Method (index, value)

SetWeightAt Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »SetWeightAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetWeightAt(
    int index,
    double value
)
Public Sub SetWeightAt ( _
    index As Integer, _
    value As Double _
)
public:
void SetWeightAt(
    int index,
    double value
)
Parameters
index(Int32)
value(Double)


NurbCurve3dData Structure

NurbCurve3dData Structure
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData
Declaration Syntax
C# Visual Basic Visual C++
public struct NurbCurve3dData
Public Structure NurbCurve3dData
public value class NurbCurve3dData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ControlPoints |
 | Degree |
 | Equality(NurbCurve3dData, NurbCurve3dData) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(NurbCurve3dData, NurbCurve3dData) |
 | IsEqualTo(NurbCurve3dData) |
 | Knots |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Periodic |
 | Rational |
 | ToString()()()() | (Inherited from ValueType.)
 | Weights |


ControlPoints Property

ControlPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »ControlPoints
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection ControlPoints { get; }
Public ReadOnly Property ControlPoints As Point3dCollection
    Get
public:
property Point3dCollection^ ControlPoints {
    Point3dCollection^ get ();
}


Degree Property

Degree Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »Degree
Declaration Syntax
C# Visual Basic Visual C++
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »Equality(NurbCurve3dData, NurbCurve3dData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    NurbCurve3dData a,
    NurbCurve3dData b
)
Public Shared Operator = ( _
    a As NurbCurve3dData, _
    b As NurbCurve3dData _
) As Boolean
public:
static bool operator ==(
    NurbCurve3dData a,
    NurbCurve3dData b
)
Parameters
a(NurbCurve3dData)
b(NurbCurve3dData)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »Inequality(NurbCurve3dData, NurbCurve3dData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    NurbCurve3dData a,
    NurbCurve3dData b
)
Public Shared Operator <> ( _
    a As NurbCurve3dData, _
    b As NurbCurve3dData _
) As Boolean
public:
static bool operator !=(
    NurbCurve3dData a,
    NurbCurve3dData b
)
Parameters
a(NurbCurve3dData)
b(NurbCurve3dData)


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »IsEqualTo(NurbCurve3dData)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    NurbCurve3dData a
)
Public Function IsEqualTo ( _
    a As NurbCurve3dData _
) As Boolean
public:
bool IsEqualTo(
    NurbCurve3dData a
)
Parameters
a(NurbCurve3dData)


Knots Property

Knots Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »Knots
Declaration Syntax
C# Visual Basic Visual C++
public KnotCollection Knots { get; }
Public ReadOnly Property Knots As KnotCollection
    Get
public:
property KnotCollection^ Knots {
    KnotCollection^ get ();
}


Periodic Property

Periodic Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »Periodic
Declaration Syntax
C# Visual Basic Visual C++
public bool Periodic { get; }
Public ReadOnly Property Periodic As Boolean
    Get
public:
property bool Periodic {
    bool get ();
}


Rational Property

Rational Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »Rational
Declaration Syntax
C# Visual Basic Visual C++
public bool Rational { get; }
Public ReadOnly Property Rational As Boolean
    Get
public:
property bool Rational {
    bool get ();
}


Weights Property

Weights Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dData »Weights
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection Weights { get; }
Public ReadOnly Property Weights As DoubleCollection
    Get
public:
property DoubleCollection^ Weights {
    DoubleCollection^ get ();
}


NurbCurve3dFitData Structure

NurbCurve3dFitData Structure
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData
Declaration Syntax
C# Visual Basic Visual C++
public struct NurbCurve3dFitData
Public Structure NurbCurve3dFitData
public value class NurbCurve3dFitData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Degree |
 | EndTangent |
 | Equality(NurbCurve3dFitData, NurbCurve3dFitData) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | FitPoints |
 | FitTolerance |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(NurbCurve3dFitData, NurbCurve3dFitData) |
 | IsEqualTo(NurbCurve3dFitData) |
 | KnotParam |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | StartTangent |
 | TangentsExist |
 | ToString()()()() | (Inherited from ValueType.)


Degree Property

Degree Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »Degree
Declaration Syntax
C# Visual Basic Visual C++
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}


EndTangent Property

EndTangent Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »EndTangent
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d EndTangent { get; }
Public ReadOnly Property EndTangent As Vector3d
    Get
public:
property Vector3d EndTangent {
    Vector3d get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »Equality(NurbCurve3dFitData, NurbCurve3dFitData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    NurbCurve3dFitData a,
    NurbCurve3dFitData b
)
Public Shared Operator = ( _
    a As NurbCurve3dFitData, _
    b As NurbCurve3dFitData _
) As Boolean
public:
static bool operator ==(
    NurbCurve3dFitData a,
    NurbCurve3dFitData b
)
Parameters
a(NurbCurve3dFitData)
b(NurbCurve3dFitData)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


FitPoints Property

FitPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »FitPoints
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection FitPoints { get; }
Public ReadOnly Property FitPoints As Point3dCollection
    Get
public:
property Point3dCollection^ FitPoints {
    Point3dCollection^ get ();
}


FitTolerance Property

FitTolerance Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »FitTolerance
Declaration Syntax
C# Visual Basic Visual C++
public Tolerance FitTolerance { get; }
Public ReadOnly Property FitTolerance As Tolerance
    Get
public:
property Tolerance FitTolerance {
    Tolerance get ();
}


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »Inequality(NurbCurve3dFitData, NurbCurve3dFitData)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    NurbCurve3dFitData a,
    NurbCurve3dFitData b
)
Public Shared Operator <> ( _
    a As NurbCurve3dFitData, _
    b As NurbCurve3dFitData _
) As Boolean
public:
static bool operator !=(
    NurbCurve3dFitData a,
    NurbCurve3dFitData b
)
Parameters
a(NurbCurve3dFitData)
b(NurbCurve3dFitData)


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »IsEqualTo(NurbCurve3dFitData)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    NurbCurve3dFitData a
)
Public Function IsEqualTo ( _
    a As NurbCurve3dFitData _
) As Boolean
public:
bool IsEqualTo(
    NurbCurve3dFitData a
)
Parameters
a(NurbCurve3dFitData)


KnotParam Property

KnotParam Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »KnotParam
Declaration Syntax
C# Visual Basic Visual C++
public KnotParameterizationEnum KnotParam { get; }
Public ReadOnly Property KnotParam As KnotParameterizationEnum
    Get
public:
property KnotParameterizationEnum KnotParam {
    KnotParameterizationEnum get ();
}


StartTangent Property

StartTangent Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »StartTangent
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d StartTangent { get; }
Public ReadOnly Property StartTangent As Vector3d
    Get
public:
property Vector3d StartTangent {
    Vector3d get ();
}


TangentsExist Property

TangentsExist Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3dFitData »TangentsExist
Declaration Syntax
C# Visual Basic Visual C++
public bool TangentsExist { get; }
Public ReadOnly Property TangentsExist As Boolean
    Get
public:
property bool TangentsExist {
    bool get ();
}


NurbSurface Class

NurbSurface Class
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeNurbSurface")]
public sealed class NurbSurface : Surface
<WrapperAttribute("ZcGeNurbSurface")> _
Public NotInheritable Class NurbSurface _
    Inherits Surface
[WrapperAttribute(L"ZcGeNurbSurface")]
public ref class NurbSurface sealed : public Surface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NurbSurface(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection, Tolerance) |
 | NurbSurface(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection) |
 | NurbSurface()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | ControlPoints |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DegreeInU |
 | DegreeInV |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetDefinition()()()() |
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsNormalReversed | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsPeriodicInU |
 | IsPeriodicInV |
 | IsRationalInU |
 | IsRationalInV |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | NumControlPointsInU |
 | NumControlPointsInV |
 | NumKnotsInU |
 | NumKnotsInV |
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | PeriodicInU |
 | PeriodicInV |
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection, Tolerance) |
 | Set(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection) |
 | SingularityInU |
 | SingularityInV |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UKnots |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | VKnots |
 | Weights |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | NurbSurface


NurbSurface Constructor

NurbSurface Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »NurbSurface()()()()
Members
Icon | Member | Description
 | NurbSurface(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection, Tolerance) |
 | NurbSurface(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection) |
 | NurbSurface()()()() |


NurbSurface Constructor

NurbSurface Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »NurbSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NurbSurface()
Public Sub New
public:
NurbSurface()


NurbSurface Constructor (degreeU, degreeV, propsInU, propertiesInV, numberControlPointsInU, numberControlPointsInV, controlPoints, weights, knotsInU, knotsInV)

NurbSurface Constructor (degreeU, degreeV, propsInU, propertiesInV, numberControlPointsInU, numberControlPointsInV, controlPoints, weights, knotsInU, knotsInV)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »NurbSurface(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NurbSurface(
    int degreeU,
    int degreeV,
    int propsInU,
    int propertiesInV,
    int numberControlPointsInU,
    int numberControlPointsInV,
    Point3dCollection controlPoints,
    DoubleCollection weights,
    KnotCollection knotsInU,
    KnotCollection knotsInV
)
Public Sub New ( _
    degreeU As Integer, _
    degreeV As Integer, _
    propsInU As Integer, _
    propertiesInV As Integer, _
    numberControlPointsInU As Integer, _
    numberControlPointsInV As Integer, _
    controlPoints As Point3dCollection, _
    weights As DoubleCollection, _
    knotsInU As KnotCollection, _
    knotsInV As KnotCollection _
)
public:
NurbSurface(
    int degreeU,
    int degreeV,
    int propsInU,
    int propertiesInV,
    int numberControlPointsInU,
    int numberControlPointsInV,
    Point3dCollection^ controlPoints,
    DoubleCollection^ weights,
    KnotCollection^ knotsInU,
    KnotCollection^ knotsInV
)
Parameters
degreeU(Int32)
degreeV(Int32)
propsInU(Int32)
propertiesInV(Int32)
numberControlPointsInU(Int32)
numberControlPointsInV(Int32)
controlPoints(Point3dCollection)
weights(DoubleCollection)
knotsInU(KnotCollection)
knotsInV(KnotCollection)


NurbSurface Constructor (degreeU, degreeV, propsInU, propertiesInV, numberControlPointsInU, numberControlPointsInV, controlPoints, weights, knotsInU, knotsInV, tolerance)

NurbSurface Constructor (degreeU, degreeV, propsInU, propertiesInV, numberControlPointsInU, numberControlPointsInV, controlPoints, weights, knotsInU, knotsInV, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »NurbSurface(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public NurbSurface(
    int degreeU,
    int degreeV,
    int propsInU,
    int propertiesInV,
    int numberControlPointsInU,
    int numberControlPointsInV,
    Point3dCollection controlPoints,
    DoubleCollection weights,
    KnotCollection knotsInU,
    KnotCollection knotsInV,
    Tolerance tolerance
)
Public Sub New ( _
    degreeU As Integer, _
    degreeV As Integer, _
    propsInU As Integer, _
    propertiesInV As Integer, _
    numberControlPointsInU As Integer, _
    numberControlPointsInV As Integer, _
    controlPoints As Point3dCollection, _
    weights As DoubleCollection, _
    knotsInU As KnotCollection, _
    knotsInV As KnotCollection, _
    tolerance As Tolerance _
)
public:
NurbSurface(
    int degreeU,
    int degreeV,
    int propsInU,
    int propertiesInV,
    int numberControlPointsInU,
    int numberControlPointsInV,
    Point3dCollection^ controlPoints,
    DoubleCollection^ weights,
    KnotCollection^ knotsInU,
    KnotCollection^ knotsInV,
    Tolerance tolerance
)
Parameters
degreeU(Int32)
degreeV(Int32)
propsInU(Int32)
propertiesInV(Int32)
numberControlPointsInU(Int32)
numberControlPointsInV(Int32)
controlPoints(Point3dCollection)
weights(DoubleCollection)
knotsInU(KnotCollection)
knotsInV(KnotCollection)
tolerance(Tolerance)


ControlPoints Property

ControlPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »ControlPoints
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection ControlPoints { get; }
Public ReadOnly Property ControlPoints As Point3dCollection
    Get
public:
property Point3dCollection^ ControlPoints {
    Point3dCollection^ get ();
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static NurbSurface Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As NurbSurface
public:
static NurbSurface^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DegreeInU Property

DegreeInU Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »DegreeInU
Declaration Syntax
C# Visual Basic Visual C++
public int DegreeInU { get; }
Public ReadOnly Property DegreeInU As Integer
    Get
public:
property int DegreeInU {
    int get ();
}


DegreeInV Property

DegreeInV Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »DegreeInV
Declaration Syntax
C# Visual Basic Visual C++
public int DegreeInV { get; }
Public ReadOnly Property DegreeInV As Integer
    Get
public:
property int DegreeInV {
    int get ();
}


GetDefinition Method

GetDefinition Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »GetDefinition()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NurbSurfaceDefinition GetDefinition()
Public Function GetDefinition As NurbSurfaceDefinition
public:
NurbSurfaceDefinition GetDefinition()


IsPeriodicInU Property

IsPeriodicInU Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »IsPeriodicInU
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPeriodicInU { get; }
Public ReadOnly Property IsPeriodicInU As Boolean
    Get
public:
property bool IsPeriodicInU {
    bool get ();
}


IsPeriodicInV Property

IsPeriodicInV Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »IsPeriodicInV
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPeriodicInV { get; }
Public ReadOnly Property IsPeriodicInV As Boolean
    Get
public:
property bool IsPeriodicInV {
    bool get ();
}


IsRationalInU Property

IsRationalInU Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »IsRationalInU
Declaration Syntax
C# Visual Basic Visual C++
public bool IsRationalInU { get; }
Public ReadOnly Property IsRationalInU As Boolean
    Get
public:
property bool IsRationalInU {
    bool get ();
}


IsRationalInV Property

IsRationalInV Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »IsRationalInV
Declaration Syntax
C# Visual Basic Visual C++
public bool IsRationalInV { get; }
Public ReadOnly Property IsRationalInV As Boolean
    Get
public:
property bool IsRationalInV {
    bool get ();
}


NumControlPointsInU Property

NumControlPointsInU Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »NumControlPointsInU
Declaration Syntax
C# Visual Basic Visual C++
public int NumControlPointsInU { get; }
Public ReadOnly Property NumControlPointsInU As Integer
    Get
public:
property int NumControlPointsInU {
    int get ();
}


NumControlPointsInV Property

NumControlPointsInV Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »NumControlPointsInV
Declaration Syntax
C# Visual Basic Visual C++
public int NumControlPointsInV { get; }
Public ReadOnly Property NumControlPointsInV As Integer
    Get
public:
property int NumControlPointsInV {
    int get ();
}


NumKnotsInU Property

NumKnotsInU Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »NumKnotsInU
Declaration Syntax
C# Visual Basic Visual C++
public int NumKnotsInU { get; }
Public ReadOnly Property NumKnotsInU As Integer
    Get
public:
property int NumKnotsInU {
    int get ();
}


NumKnotsInV Property

NumKnotsInV Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »NumKnotsInV
Declaration Syntax
C# Visual Basic Visual C++
public int NumKnotsInV { get; }
Public ReadOnly Property NumKnotsInV As Integer
    Get
public:
property int NumKnotsInV {
    int get ();
}


PeriodicInU Property

PeriodicInU Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »PeriodicInU
Declaration Syntax
C# Visual Basic Visual C++
public double PeriodicInU { get; }
Public ReadOnly Property PeriodicInU As Double
    Get
public:
property double PeriodicInU {
    double get ();
}


PeriodicInV Property

PeriodicInV Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »PeriodicInV
Declaration Syntax
C# Visual Basic Visual C++
public double PeriodicInV { get; }
Public ReadOnly Property PeriodicInV As Double
    Get
public:
property double PeriodicInV {
    double get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »Set()()()()
Members
Icon | Member | Description
 | Set(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection, Tolerance) |
 | Set(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection) |


Set Method (degreeU, degreeV, propsInU, propsInV, numControlPointsInU, numControlPointsInV, controlPoints, weights, knotsInU, knotsInV)

Set Method (degreeU, degreeV, propsInU, propsInV, numControlPointsInU, numControlPointsInV, controlPoints, weights, knotsInU, knotsInV)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »Set(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    int degreeU,
    int degreeV,
    int propsInU,
    int propsInV,
    int numControlPointsInU,
    int numControlPointsInV,
    Point3dCollection controlPoints,
    DoubleCollection weights,
    KnotCollection knotsInU,
    KnotCollection knotsInV
)
Public Sub Set ( _
    degreeU As Integer, _
    degreeV As Integer, _
    propsInU As Integer, _
    propsInV As Integer, _
    numControlPointsInU As Integer, _
    numControlPointsInV As Integer, _
    controlPoints As Point3dCollection, _
    weights As DoubleCollection, _
    knotsInU As KnotCollection, _
    knotsInV As KnotCollection _
)
public:
void Set(
    int degreeU,
    int degreeV,
    int propsInU,
    int propsInV,
    int numControlPointsInU,
    int numControlPointsInV,
    Point3dCollection^ controlPoints,
    DoubleCollection^ weights,
    KnotCollection^ knotsInU,
    KnotCollection^ knotsInV
)
Parameters
degreeU(Int32)
degreeV(Int32)
propsInU(Int32)
propsInV(Int32)
numControlPointsInU(Int32)
numControlPointsInV(Int32)
controlPoints(Point3dCollection)
weights(DoubleCollection)
knotsInU(KnotCollection)
knotsInV(KnotCollection)


Set Method (degreeU, degreeV, propsInU, propsInV, numControlPointsInU, numControlPointsInV, controlPoints, weights, knotsInU, knotsInV, tolerance)

Set Method (degreeU, degreeV, propsInU, propsInV, numControlPointsInU, numControlPointsInV, controlPoints, weights, knotsInU, knotsInV, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »Set(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    int degreeU,
    int degreeV,
    int propsInU,
    int propsInV,
    int numControlPointsInU,
    int numControlPointsInV,
    Point3dCollection controlPoints,
    DoubleCollection weights,
    KnotCollection knotsInU,
    KnotCollection knotsInV,
    Tolerance tolerance
)
Public Sub Set ( _
    degreeU As Integer, _
    degreeV As Integer, _
    propsInU As Integer, _
    propsInV As Integer, _
    numControlPointsInU As Integer, _
    numControlPointsInV As Integer, _
    controlPoints As Point3dCollection, _
    weights As DoubleCollection, _
    knotsInU As KnotCollection, _
    knotsInV As KnotCollection, _
    tolerance As Tolerance _
)
public:
void Set(
    int degreeU,
    int degreeV,
    int propsInU,
    int propsInV,
    int numControlPointsInU,
    int numControlPointsInV,
    Point3dCollection^ controlPoints,
    DoubleCollection^ weights,
    KnotCollection^ knotsInU,
    KnotCollection^ knotsInV,
    Tolerance tolerance
)
Parameters
degreeU(Int32)
degreeV(Int32)
propsInU(Int32)
propsInV(Int32)
numControlPointsInU(Int32)
numControlPointsInV(Int32)
controlPoints(Point3dCollection)
weights(DoubleCollection)
knotsInU(KnotCollection)
knotsInV(KnotCollection)
tolerance(Tolerance)


SingularityInU Property

SingularityInU Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »SingularityInU
Declaration Syntax
C# Visual Basic Visual C++
public int SingularityInU { get; }
Public ReadOnly Property SingularityInU As Integer
    Get
public:
property int SingularityInU {
    int get ();
}


SingularityInV Property

SingularityInV Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »SingularityInV
Declaration Syntax
C# Visual Basic Visual C++
public int SingularityInV { get; }
Public ReadOnly Property SingularityInV As Integer
    Get
public:
property int SingularityInV {
    int get ();
}


UKnots Property

UKnots Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »UKnots
Declaration Syntax
C# Visual Basic Visual C++
public KnotCollection UKnots { get; }
Public ReadOnly Property UKnots As KnotCollection
    Get
public:
property KnotCollection^ UKnots {
    KnotCollection^ get ();
}


VKnots Property

VKnots Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »VKnots
Declaration Syntax
C# Visual Basic Visual C++
public KnotCollection VKnots { get; }
Public ReadOnly Property VKnots As KnotCollection
    Get
public:
property KnotCollection^ VKnots {
    KnotCollection^ get ();
}


Weights Property

Weights Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »Weights
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection Weights { get; }
Public ReadOnly Property Weights As DoubleCollection
    Get
public:
property DoubleCollection^ Weights {
    DoubleCollection^ get ();
}


NurbSurfaceDefinition Structure

NurbSurfaceDefinition Structure
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition
Declaration Syntax
C# Visual Basic Visual C++
public struct NurbSurfaceDefinition
Public Structure NurbSurfaceDefinition
public value class NurbSurfaceDefinition
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ControlPoints |
 | DegreeInU |
 | DegreeInV |
 | Equality(NurbSurfaceDefinition, NurbSurfaceDefinition) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(NurbSurfaceDefinition, NurbSurfaceDefinition) |
 | IsEqualTo(NurbSurfaceDefinition) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfControlPointsInU |
 | NumberOfControlPointsInV |
 | PropertiesInU |
 | PropertiesInV |
 | ToString()()()() | (Inherited from ValueType.)
 | UKnots |
 | VKnots |
 | Weights |


ControlPoints Property

ControlPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »ControlPoints
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection ControlPoints { get; }
Public ReadOnly Property ControlPoints As Point3dCollection
    Get
public:
property Point3dCollection^ ControlPoints {
    Point3dCollection^ get ();
}


DegreeInU Property

DegreeInU Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »DegreeInU
Declaration Syntax
C# Visual Basic Visual C++
public int DegreeInU { get; }
Public ReadOnly Property DegreeInU As Integer
    Get
public:
property int DegreeInU {
    int get ();
}


DegreeInV Property

DegreeInV Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »DegreeInV
Declaration Syntax
C# Visual Basic Visual C++
public int DegreeInV { get; }
Public ReadOnly Property DegreeInV As Integer
    Get
public:
property int DegreeInV {
    int get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »Equality(NurbSurfaceDefinition, NurbSurfaceDefinition)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    NurbSurfaceDefinition a,
    NurbSurfaceDefinition b
)
Public Shared Operator = ( _
    a As NurbSurfaceDefinition, _
    b As NurbSurfaceDefinition _
) As Boolean
public:
static bool operator ==(
    NurbSurfaceDefinition a,
    NurbSurfaceDefinition b
)
Parameters
a(NurbSurfaceDefinition)
b(NurbSurfaceDefinition)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »Inequality(NurbSurfaceDefinition, NurbSurfaceDefinition)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    NurbSurfaceDefinition a,
    NurbSurfaceDefinition b
)
Public Shared Operator <> ( _
    a As NurbSurfaceDefinition, _
    b As NurbSurfaceDefinition _
) As Boolean
public:
static bool operator !=(
    NurbSurfaceDefinition a,
    NurbSurfaceDefinition b
)
Parameters
a(NurbSurfaceDefinition)
b(NurbSurfaceDefinition)


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »IsEqualTo(NurbSurfaceDefinition)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    NurbSurfaceDefinition a
)
Public Function IsEqualTo ( _
    a As NurbSurfaceDefinition _
) As Boolean
public:
bool IsEqualTo(
    NurbSurfaceDefinition a
)
Parameters
a(NurbSurfaceDefinition)


NumberOfControlPointsInU Property

NumberOfControlPointsInU Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »NumberOfControlPointsInU
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfControlPointsInU { get; }
Public ReadOnly Property NumberOfControlPointsInU As Integer
    Get
public:
property int NumberOfControlPointsInU {
    int get ();
}


NumberOfControlPointsInV Property

NumberOfControlPointsInV Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »NumberOfControlPointsInV
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfControlPointsInV { get; }
Public ReadOnly Property NumberOfControlPointsInV As Integer
    Get
public:
property int NumberOfControlPointsInV {
    int get ();
}


PropertiesInU Property

PropertiesInU Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »PropertiesInU
Declaration Syntax
C# Visual Basic Visual C++
public int PropertiesInU { get; }
Public ReadOnly Property PropertiesInU As Integer
    Get
public:
property int PropertiesInU {
    int get ();
}


PropertiesInV Property

PropertiesInV Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »PropertiesInV
Declaration Syntax
C# Visual Basic Visual C++
public int PropertiesInV { get; }
Public ReadOnly Property PropertiesInV As Integer
    Get
public:
property int PropertiesInV {
    int get ();
}


UKnots Property

UKnots Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »UKnots
Declaration Syntax
C# Visual Basic Visual C++
public KnotCollection UKnots { get; }
Public ReadOnly Property UKnots As KnotCollection
    Get
public:
property KnotCollection^ UKnots {
    KnotCollection^ get ();
}


VKnots Property

VKnots Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »VKnots
Declaration Syntax
C# Visual Basic Visual C++
public KnotCollection VKnots { get; }
Public ReadOnly Property VKnots As KnotCollection
    Get
public:
property KnotCollection^ VKnots {
    KnotCollection^ get ();
}


Weights Property

Weights Property
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurfaceDefinition »Weights
Declaration Syntax
C# Visual Basic Visual C++
public DoubleCollection Weights { get; }
Public ReadOnly Property Weights As DoubleCollection
    Get
public:
property DoubleCollection^ Weights {
    DoubleCollection^ get ();
}


OffsetCurve2d Class

OffsetCurve2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeOffsetCurve2d")]
public sealed class OffsetCurve2d : Curve2d
<WrapperAttribute("ZcGeOffsetCurve2d")> _
Public NotInheritable Class OffsetCurve2d _
    Inherits Curve2d
[WrapperAttribute(L"ZcGeOffsetCurve2d")]
public ref class OffsetCurve2d sealed : public Curve2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OffsetCurve2d(Curve2d, Double) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Curve |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint | (Inherited from Curve2d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | OffsetDistance |
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | ParameterDirection |
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | StartPoint | (Inherited from Curve2d.)
 | ToString()()()() | (Inherited from Object.)
 | Transformation |
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | OffsetCurve2d


OffsetCurve2d Constructor (baseCurve, offsetDistance)

OffsetCurve2d Constructor (baseCurve, offsetDistance)
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »OffsetCurve2d(Curve2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public OffsetCurve2d(
    Curve2d baseCurve,
    double offsetDistance
)
Public Sub New ( _
    baseCurve As Curve2d, _
    offsetDistance As Double _
)
public:
OffsetCurve2d(
    Curve2d^ baseCurve,
    double offsetDistance
)
Parameters
baseCurve(Curve2d)
offsetDistance(Double)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static OffsetCurve2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As OffsetCurve2d
public:
static OffsetCurve2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Curve Property

Curve Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »Curve
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d Curve { get; set; }
Public Property Curve As Curve2d
    Get
    Set
public:
property Curve2d^ Curve {
    Curve2d^ get ();
    void set (Curve2d^ value);
}


OffsetDistance Property

OffsetDistance Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »OffsetDistance
Declaration Syntax
C# Visual Basic Visual C++
public double OffsetDistance { get; set; }
Public Property OffsetDistance As Double
    Get
    Set
public:
property double OffsetDistance {
    double get ();
    void set (double value);
}


ParameterDirection Property

ParameterDirection Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »ParameterDirection
Declaration Syntax
C# Visual Basic Visual C++
public bool ParameterDirection { get; }
Public ReadOnly Property ParameterDirection As Boolean
    Get
public:
property bool ParameterDirection {
    bool get ();
}


Transformation Property

Transformation Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »Transformation
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2d Transformation { get; }
Public ReadOnly Property Transformation As Matrix2d
    Get
public:
property Matrix2d Transformation {
    Matrix2d get ();
}


OffsetCurve3d Class

OffsetCurve3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeOffsetCurve3d")]
public sealed class OffsetCurve3d : Curve3d
<WrapperAttribute("ZcGeOffsetCurve3d")> _
Public NotInheritable Class OffsetCurve3d _
    Inherits Curve3d
[WrapperAttribute(L"ZcGeOffsetCurve3d")]
public ref class OffsetCurve3d sealed : public Curve3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OffsetCurve3d(Curve3d, Vector3d, Double) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Curve |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint | (Inherited from Curve3d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | Normal |
 | OffsetDistance |
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | ParameterDirection |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | StartPoint | (Inherited from Curve3d.)
 | ToString()()()() | (Inherited from Object.)
 | Transformation |
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | OffsetCurve3d


OffsetCurve3d Constructor (baseCurve, planeNormal, offsetDistance)

OffsetCurve3d Constructor (baseCurve, planeNormal, offsetDistance)
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »OffsetCurve3d(Curve3d, Vector3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public OffsetCurve3d(
    Curve3d baseCurve,
    Vector3d planeNormal,
    double offsetDistance
)
Public Sub New ( _
    baseCurve As Curve3d, _
    planeNormal As Vector3d, _
    offsetDistance As Double _
)
public:
OffsetCurve3d(
    Curve3d^ baseCurve,
    Vector3d planeNormal,
    double offsetDistance
)
Parameters
baseCurve(Curve3d)
planeNormal(Vector3d)
offsetDistance(Double)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static OffsetCurve3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As OffsetCurve3d
public:
static OffsetCurve3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Curve Property

Curve Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »Curve
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d Curve { get; set; }
Public Property Curve As Curve3d
    Get
    Set
public:
property Curve3d^ Curve {
    Curve3d^ get ();
    void set (Curve3d^ value);
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


OffsetDistance Property

OffsetDistance Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »OffsetDistance
Declaration Syntax
C# Visual Basic Visual C++
public double OffsetDistance { get; set; }
Public Property OffsetDistance As Double
    Get
    Set
public:
property double OffsetDistance {
    double get ();
    void set (double value);
}


ParameterDirection Property

ParameterDirection Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »ParameterDirection
Declaration Syntax
C# Visual Basic Visual C++
public bool ParameterDirection { get; }
Public ReadOnly Property ParameterDirection As Boolean
    Get
public:
property bool ParameterDirection {
    bool get ();
}


Transformation Property

Transformation Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »Transformation
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d Transformation { get; }
Public ReadOnly Property Transformation As Matrix3d
    Get
public:
property Matrix3d Transformation {
    Matrix3d get ();
}


OffsetCurveExtensionType Enumeration

OffsetCurveExtensionType Enumeration
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurveExtensionType
Declaration Syntax
C# Visual Basic Visual C++
public enum OffsetCurveExtensionType
Public Enumeration OffsetCurveExtensionType
public enum class OffsetCurveExtensionType
Members
Member | Description
Extend |
Chamfer |
Fillet |


OffsetSurface Class

OffsetSurface Class
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeOffsetSurface")]
public sealed class OffsetSurface : Surface
<WrapperAttribute("ZcGeOffsetSurface")> _
Public NotInheritable Class OffsetSurface _
    Inherits Surface
[WrapperAttribute(L"ZcGeOffsetSurface")]
public ref class OffsetSurface sealed : public Surface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OffsetSurface(Surface, Double) |
 | OffsetSurface()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | ConstructionSurface |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsBoundedPlane |
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsCone |
 | IsCylinder |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsNormalReversed | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsPlane |
 | IsSphere |
 | IsTorus |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | OffsetDist |
 | OriginalSurface |
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Surface, Double) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | OffsetSurface


OffsetSurface Constructor

OffsetSurface Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »OffsetSurface()()()()
Members
Icon | Member | Description
 | OffsetSurface(Surface, Double) |
 | OffsetSurface()()()() |


OffsetSurface Constructor

OffsetSurface Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »OffsetSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OffsetSurface()
Public Sub New
public:
OffsetSurface()


OffsetSurface Constructor (baseSurface, offsetDistance)

OffsetSurface Constructor (baseSurface, offsetDistance)
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »OffsetSurface(Surface, Double)
Declaration Syntax
C# Visual Basic Visual C++
public OffsetSurface(
    Surface baseSurface,
    double offsetDistance
)
Public Sub New ( _
    baseSurface As Surface, _
    offsetDistance As Double _
)
public:
OffsetSurface(
    Surface^ baseSurface,
    double offsetDistance
)
Parameters
baseSurface(Surface)
offsetDistance(Double)


ConstructionSurface Property

ConstructionSurface Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »ConstructionSurface
Declaration Syntax
C# Visual Basic Visual C++
public Surface ConstructionSurface { get; }
Public ReadOnly Property ConstructionSurface As Surface
    Get
public:
property Surface^ ConstructionSurface {
    Surface^ get ();
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static OffsetSurface Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As OffsetSurface
public:
static OffsetSurface^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


IsBoundedPlane Property

IsBoundedPlane Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »IsBoundedPlane
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBoundedPlane { get; }
Public ReadOnly Property IsBoundedPlane As Boolean
    Get
public:
property bool IsBoundedPlane {
    bool get ();
}


IsCone Property

IsCone Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »IsCone
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCone { get; }
Public ReadOnly Property IsCone As Boolean
    Get
public:
property bool IsCone {
    bool get ();
}


IsCylinder Property

IsCylinder Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »IsCylinder
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCylinder { get; }
Public ReadOnly Property IsCylinder As Boolean
    Get
public:
property bool IsCylinder {
    bool get ();
}


IsPlane Property

IsPlane Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »IsPlane
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPlane { get; }
Public ReadOnly Property IsPlane As Boolean
    Get
public:
property bool IsPlane {
    bool get ();
}


IsSphere Property

IsSphere Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »IsSphere
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSphere { get; }
Public ReadOnly Property IsSphere As Boolean
    Get
public:
property bool IsSphere {
    bool get ();
}


IsTorus Property

IsTorus Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »IsTorus
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTorus { get; }
Public ReadOnly Property IsTorus As Boolean
    Get
public:
property bool IsTorus {
    bool get ();
}


OffsetDist Property

OffsetDist Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »OffsetDist
Declaration Syntax
C# Visual Basic Visual C++
public double OffsetDist { get; }
Public ReadOnly Property OffsetDist As Double
    Get
public:
property double OffsetDist {
    double get ();
}


OriginalSurface Property

OriginalSurface Property
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »OriginalSurface
Declaration Syntax
C# Visual Basic Visual C++
public Surface OriginalSurface { get; }
Public ReadOnly Property OriginalSurface As Surface
    Get
public:
property Surface^ OriginalSurface {
    Surface^ get ();
}


Set Method (surface, offsetDistance)

Set Method (surface, offsetDistance)
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »Set(Surface, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Surface surface,
    double offsetDistance
)
Public Sub Set ( _
    surface As Surface, _
    offsetDistance As Double _
)
public:
void Set(
    Surface^ surface,
    double offsetDistance
)
Parameters
surface(Surface)
offsetDistance(Double)


PlanarEntity Class

PlanarEntity Class
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePlanarEnt")]
public abstract class PlanarEntity : Surface
<WrapperAttribute("ZcGePlanarEnt")> _
Public MustInherit Class PlanarEntity _
    Inherits Surface
[WrapperAttribute(L"ZcGePlanarEnt")]
public ref class PlanarEntity abstract : public Surface
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | ClosestPointToLinearEntity(LinearEntity3d, Tolerance) |
 | ClosestPointToLinearEntity(LinearEntity3d) |
 | ClosestPointToPlanarEntity(PlanarEntity, Tolerance) |
 | ClosestPointToPlanarEntity(PlanarEntity) |
 | Coefficients |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetCoordinateSystem()()()() |
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsCoplanarTo(PlanarEntity, Tolerance) |
 | IsCoplanarTo(PlanarEntity) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsNormalReversed | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsParallelTo(PlanarEntity, Tolerance) |
 | IsParallelTo(LinearEntity3d, Tolerance) |
 | IsParallelTo(PlanarEntity) |
 | IsParallelTo(LinearEntity3d) |
 | IsPerpendicularTo(PlanarEntity, Tolerance) |
 | IsPerpendicularTo(LinearEntity3d, Tolerance) |
 | IsPerpendicularTo(PlanarEntity) |
 | IsPerpendicularTo(LinearEntity3d) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | Normal |
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | PointOnPlane |
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | PlanarEntity
 |  |  |  |  |  | BoundedPlane
 |  |  |  |  |  | Plane


ClosestPointToLinearEntity Method

ClosestPointToLinearEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »ClosestPointToLinearEntity()()()()
Members
Icon | Member | Description
 | ClosestPointToLinearEntity(LinearEntity3d, Tolerance) |
 | ClosestPointToLinearEntity(LinearEntity3d) |


ClosestPointToLinearEntity Method (line)

ClosestPointToLinearEntity Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »ClosestPointToLinearEntity(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ClosestPointToLinearEntity(
    LinearEntity3d line
)
Public Function ClosestPointToLinearEntity ( _
    line As LinearEntity3d _
) As Point3d()
public:
array<Point3d>^ ClosestPointToLinearEntity(
    LinearEntity3d^ line
)
Parameters
line(LinearEntity3d)


ClosestPointToLinearEntity Method (line, tolerance)

ClosestPointToLinearEntity Method (line, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »ClosestPointToLinearEntity(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ClosestPointToLinearEntity(
    LinearEntity3d line,
    Tolerance tolerance
)
Public Function ClosestPointToLinearEntity ( _
    line As LinearEntity3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ ClosestPointToLinearEntity(
    LinearEntity3d^ line,
    Tolerance tolerance
)
Parameters
line(LinearEntity3d)
tolerance(Tolerance)


ClosestPointToPlanarEntity Method

ClosestPointToPlanarEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »ClosestPointToPlanarEntity()()()()
Members
Icon | Member | Description
 | ClosestPointToPlanarEntity(PlanarEntity, Tolerance) |
 | ClosestPointToPlanarEntity(PlanarEntity) |


ClosestPointToPlanarEntity Method (otherPlane)

ClosestPointToPlanarEntity Method (otherPlane)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »ClosestPointToPlanarEntity(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ClosestPointToPlanarEntity(
    PlanarEntity otherPlane
)
Public Function ClosestPointToPlanarEntity ( _
    otherPlane As PlanarEntity _
) As Point3d()
public:
array<Point3d>^ ClosestPointToPlanarEntity(
    PlanarEntity^ otherPlane
)
Parameters
otherPlane(PlanarEntity)


ClosestPointToPlanarEntity Method (otherPlane, tolerance)

ClosestPointToPlanarEntity Method (otherPlane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »ClosestPointToPlanarEntity(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] ClosestPointToPlanarEntity(
    PlanarEntity otherPlane,
    Tolerance tolerance
)
Public Function ClosestPointToPlanarEntity ( _
    otherPlane As PlanarEntity, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ ClosestPointToPlanarEntity(
    PlanarEntity^ otherPlane,
    Tolerance tolerance
)
Parameters
otherPlane(PlanarEntity)
tolerance(Tolerance)


Coefficients Property

Coefficients Property
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »Coefficients
Declaration Syntax
C# Visual Basic Visual C++
public PlanarEquationCoefficients Coefficients { get; }
Public ReadOnly Property Coefficients As PlanarEquationCoefficients
    Get
public:
property PlanarEquationCoefficients Coefficients {
    PlanarEquationCoefficients get ();
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static PlanarEntity Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As PlanarEntity
public:
static PlanarEntity^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetCoordinateSystem Method

GetCoordinateSystem Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »GetCoordinateSystem()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CoordinateSystem3d GetCoordinateSystem()
Public Function GetCoordinateSystem As CoordinateSystem3d
public:
CoordinateSystem3d GetCoordinateSystem()


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |


IntersectWith Method (linearEntity)

IntersectWith Method (linearEntity)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IntersectWith(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d linearEntity
)
Public Function IntersectWith ( _
    linearEntity As LinearEntity3d _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ linearEntity
)
Parameters
linearEntity(LinearEntity3d)


IntersectWith Method (linearEntity, tolerance)

IntersectWith Method (linearEntity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IntersectWith(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d linearEntity,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    linearEntity As LinearEntity3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ linearEntity,
    Tolerance tolerance
)
Parameters
linearEntity(LinearEntity3d)
tolerance(Tolerance)


IsCoplanarTo Method

IsCoplanarTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsCoplanarTo()()()()
Members
Icon | Member | Description
 | IsCoplanarTo(PlanarEntity, Tolerance) |
 | IsCoplanarTo(PlanarEntity) |


IsCoplanarTo Method (otherPlanarEntity)

IsCoplanarTo Method (otherPlanarEntity)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsCoplanarTo(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCoplanarTo(
    PlanarEntity otherPlanarEntity
)
Public Function IsCoplanarTo ( _
    otherPlanarEntity As PlanarEntity _
) As Boolean
public:
bool IsCoplanarTo(
    PlanarEntity^ otherPlanarEntity
)
Parameters
otherPlanarEntity(PlanarEntity)


IsCoplanarTo Method (otherPlanarEntity, tolerance)

IsCoplanarTo Method (otherPlanarEntity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsCoplanarTo(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCoplanarTo(
    PlanarEntity otherPlanarEntity,
    Tolerance tolerance
)
Public Function IsCoplanarTo ( _
    otherPlanarEntity As PlanarEntity, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsCoplanarTo(
    PlanarEntity^ otherPlanarEntity,
    Tolerance tolerance
)
Parameters
otherPlanarEntity(PlanarEntity)
tolerance(Tolerance)


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(PlanarEntity, Tolerance) |
 | IsParallelTo(LinearEntity3d, Tolerance) |
 | IsParallelTo(PlanarEntity) |
 | IsParallelTo(LinearEntity3d) |


IsParallelTo Method (linearEntity)

IsParallelTo Method (linearEntity)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsParallelTo(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    LinearEntity3d linearEntity
)
Public Function IsParallelTo ( _
    linearEntity As LinearEntity3d _
) As Boolean
public:
bool IsParallelTo(
    LinearEntity3d^ linearEntity
)
Parameters
linearEntity(LinearEntity3d)


IsParallelTo Method (linearEntity, tolerance)

IsParallelTo Method (linearEntity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsParallelTo(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    LinearEntity3d linearEntity,
    Tolerance tolerance
)
Public Function IsParallelTo ( _
    linearEntity As LinearEntity3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsParallelTo(
    LinearEntity3d^ linearEntity,
    Tolerance tolerance
)
Parameters
linearEntity(LinearEntity3d)
tolerance(Tolerance)


IsParallelTo Method (otherPlanarEntity)

IsParallelTo Method (otherPlanarEntity)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsParallelTo(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    PlanarEntity otherPlanarEntity
)
Public Function IsParallelTo ( _
    otherPlanarEntity As PlanarEntity _
) As Boolean
public:
bool IsParallelTo(
    PlanarEntity^ otherPlanarEntity
)
Parameters
otherPlanarEntity(PlanarEntity)


IsParallelTo Method (otherPlanarEntity, tolerance)

IsParallelTo Method (otherPlanarEntity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsParallelTo(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    PlanarEntity otherPlanarEntity,
    Tolerance tolerance
)
Public Function IsParallelTo ( _
    otherPlanarEntity As PlanarEntity, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsParallelTo(
    PlanarEntity^ otherPlanarEntity,
    Tolerance tolerance
)
Parameters
otherPlanarEntity(PlanarEntity)
tolerance(Tolerance)


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(PlanarEntity, Tolerance) |
 | IsPerpendicularTo(LinearEntity3d, Tolerance) |
 | IsPerpendicularTo(PlanarEntity) |
 | IsPerpendicularTo(LinearEntity3d) |


IsPerpendicularTo Method (linearEntity)

IsPerpendicularTo Method (linearEntity)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsPerpendicularTo(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    LinearEntity3d linearEntity
)
Public Function IsPerpendicularTo ( _
    linearEntity As LinearEntity3d _
) As Boolean
public:
bool IsPerpendicularTo(
    LinearEntity3d^ linearEntity
)
Parameters
linearEntity(LinearEntity3d)


IsPerpendicularTo Method (linearEntity, tolerance)

IsPerpendicularTo Method (linearEntity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsPerpendicularTo(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    LinearEntity3d linearEntity,
    Tolerance tolerance
)
Public Function IsPerpendicularTo ( _
    linearEntity As LinearEntity3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsPerpendicularTo(
    LinearEntity3d^ linearEntity,
    Tolerance tolerance
)
Parameters
linearEntity(LinearEntity3d)
tolerance(Tolerance)


IsPerpendicularTo Method (linearEntity)

IsPerpendicularTo Method (linearEntity)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsPerpendicularTo(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    PlanarEntity linearEntity
)
Public Function IsPerpendicularTo ( _
    linearEntity As PlanarEntity _
) As Boolean
public:
bool IsPerpendicularTo(
    PlanarEntity^ linearEntity
)
Parameters
linearEntity(PlanarEntity)


IsPerpendicularTo Method (linearEntity, tolerance)

IsPerpendicularTo Method (linearEntity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsPerpendicularTo(PlanarEntity, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    PlanarEntity linearEntity,
    Tolerance tolerance
)
Public Function IsPerpendicularTo ( _
    linearEntity As PlanarEntity, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsPerpendicularTo(
    PlanarEntity^ linearEntity,
    Tolerance tolerance
)
Parameters
linearEntity(PlanarEntity)
tolerance(Tolerance)


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; }
Public ReadOnly Property Normal As Vector3d
    Get
public:
property Vector3d Normal {
    Vector3d get ();
}


PointOnPlane Property

PointOnPlane Property
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »PointOnPlane
Declaration Syntax
C# Visual Basic Visual C++
public Point3d PointOnPlane { get; }
Public ReadOnly Property PointOnPlane As Point3d
    Get
public:
property Point3d PointOnPlane {
    Point3d get ();
}


PlanarEquationCoefficients Structure

PlanarEquationCoefficients Structure
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEquationCoefficients
Declaration Syntax
C# Visual Basic Visual C++
public struct PlanarEquationCoefficients
Public Structure PlanarEquationCoefficients
public value class PlanarEquationCoefficients
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlanarEquationCoefficients(Double, Double, Double, Double) |
 | A |
 | B |
 | C |
 | D |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)


PlanarEquationCoefficients Constructor (a, b, c, d)

PlanarEquationCoefficients Constructor (a, b, c, d)
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEquationCoefficients »PlanarEquationCoefficients(Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public PlanarEquationCoefficients(
    double a,
    double b,
    double c,
    double d
)
Public Sub New ( _
    a As Double, _
    b As Double, _
    c As Double, _
    d As Double _
)
public:
PlanarEquationCoefficients(
    double a,
    double b,
    double c,
    double d
)
Parameters
a(Double)
b(Double)
c(Double)
d(Double)


A Property

A Property
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEquationCoefficients »A
Declaration Syntax
C# Visual Basic Visual C++
public double A { get; }
Public ReadOnly Property A As Double
    Get
public:
property double A {
    double get ();
}


B Property

B Property
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEquationCoefficients »B
Declaration Syntax
C# Visual Basic Visual C++
public double B { get; }
Public ReadOnly Property B As Double
    Get
public:
property double B {
    double get ();
}


C Property

C Property
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEquationCoefficients »C
Declaration Syntax
C# Visual Basic Visual C++
public double C { get; }
Public ReadOnly Property C As Double
    Get
public:
property double C {
    double get ();
}


D Property

D Property
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEquationCoefficients »D
Declaration Syntax
C# Visual Basic Visual C++
public double D { get; }
Public ReadOnly Property D As Double
    Get
public:
property double D {
    double get ();
}


Plane Class

Plane Class
Namespaces »ZwSoft.ZwCAD.Geometry »Plane
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePlane")]
public sealed class Plane : PlanarEntity
<WrapperAttribute("ZcGePlane")> _
Public NotInheritable Class Plane _
    Inherits PlanarEntity
[WrapperAttribute(L"ZcGePlane")]
public ref class Plane sealed : public PlanarEntity
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Plane(Double, Double, Double, Double) |
 | Plane(Point3d, Vector3d, Vector3d) |
 | Plane(Point3d, Point3d, Point3d) |
 | Plane(Point3d, Vector3d) |
 | Plane(Plane) |
 | Plane()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | ClosestPointToLinearEntity(LinearEntity3d, Tolerance) | (Inherited from PlanarEntity.)
 | ClosestPointToLinearEntity(LinearEntity3d) | (Inherited from PlanarEntity.)
 | ClosestPointToPlanarEntity(PlanarEntity, Tolerance) | (Inherited from PlanarEntity.)
 | ClosestPointToPlanarEntity(PlanarEntity) | (Inherited from PlanarEntity.)
 | Coefficients | (Inherited from PlanarEntity.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetCoordinateSystem()()()() | (Inherited from PlanarEntity.)
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetSignedDistanceTo(Point3d) |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(Plane, Tolerance) |
 | IntersectWith(BoundedPlane, Tolerance) |
 | IntersectWith(Plane) |
 | IntersectWith(BoundedPlane) |
 | IntersectWith(LinearEntity3d, Tolerance) | (Inherited from PlanarEntity.)
 | IntersectWith(LinearEntity3d) | (Inherited from PlanarEntity.)
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsCoplanarTo(PlanarEntity, Tolerance) | (Inherited from PlanarEntity.)
 | IsCoplanarTo(PlanarEntity) | (Inherited from PlanarEntity.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsNormalReversed | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsParallelTo(PlanarEntity, Tolerance) | (Inherited from PlanarEntity.)
 | IsParallelTo(LinearEntity3d, Tolerance) | (Inherited from PlanarEntity.)
 | IsParallelTo(PlanarEntity) | (Inherited from PlanarEntity.)
 | IsParallelTo(LinearEntity3d) | (Inherited from PlanarEntity.)
 | IsPerpendicularTo(PlanarEntity, Tolerance) | (Inherited from PlanarEntity.)
 | IsPerpendicularTo(LinearEntity3d, Tolerance) | (Inherited from PlanarEntity.)
 | IsPerpendicularTo(PlanarEntity) | (Inherited from PlanarEntity.)
 | IsPerpendicularTo(LinearEntity3d) | (Inherited from PlanarEntity.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | Normal | (Inherited from PlanarEntity.)
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | PointOnPlane | (Inherited from PlanarEntity.)
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Double, Double, Double, Double) |
 | Set(Point3d, Vector3d, Vector3d) |
 | Set(Point3d, Point3d, Point3d) |
 | Set(Point3d, Vector3d) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | PlanarEntity
 |  |  |  |  |  | Plane


Plane Constructor

Plane Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Plane()()()()
Members
Icon | Member | Description
 | Plane(Double, Double, Double, Double) |
 | Plane(Point3d, Vector3d, Vector3d) |
 | Plane(Point3d, Point3d, Point3d) |
 | Plane(Point3d, Vector3d) |
 | Plane(Plane) |
 | Plane()()()() |


Plane Constructor

Plane Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Plane()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Plane()
Public Sub New
public:
Plane()


Plane Constructor (a, b, c, d)

Plane Constructor (a, b, c, d)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Plane(Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Plane(
    double a,
    double b,
    double c,
    double d
)
Public Sub New ( _
    a As Double, _
    b As Double, _
    c As Double, _
    d As Double _
)
public:
Plane(
    double a,
    double b,
    double c,
    double d
)
Parameters
a(Double)
b(Double)
c(Double)
d(Double)


Plane Constructor (source)

Plane Constructor (source)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Plane(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public Plane(
    Plane source
)
Public Sub New ( _
    source As Plane _
)
public:
Plane(
    Plane^ source
)
Parameters
source(Plane)


Plane Constructor (u, origin, v)

Plane Constructor (u, origin, v)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Plane(Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Plane(
    Point3d u,
    Point3d origin,
    Point3d v
)
Public Sub New ( _
    u As Point3d, _
    origin As Point3d, _
    v As Point3d _
)
public:
Plane(
    Point3d u,
    Point3d origin,
    Point3d v
)
Parameters
u(Point3d)
origin(Point3d)
v(Point3d)


Plane Constructor (origin, normal)

Plane Constructor (origin, normal)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Plane(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Plane(
    Point3d origin,
    Vector3d normal
)
Public Sub New ( _
    origin As Point3d, _
    normal As Vector3d _
)
public:
Plane(
    Point3d origin,
    Vector3d normal
)
Parameters
origin(Point3d)
normal(Vector3d)


Plane Constructor (origin, u, v)

Plane Constructor (origin, u, v)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Plane(Point3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Plane(
    Point3d origin,
    Vector3d u,
    Vector3d v
)
Public Sub New ( _
    origin As Point3d, _
    u As Vector3d, _
    v As Vector3d _
)
public:
Plane(
    Point3d origin,
    Vector3d u,
    Vector3d v
)
Parameters
origin(Point3d)
u(Vector3d)
v(Vector3d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Plane Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Plane
public:
static Plane^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetSignedDistanceTo Method (pointValue)

GetSignedDistanceTo Method (pointValue)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »GetSignedDistanceTo(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetSignedDistanceTo(
    Point3d pointValue
)
Public Function GetSignedDistanceTo ( _
    pointValue As Point3d _
) As Double
public:
double GetSignedDistanceTo(
    Point3d pointValue
)
Parameters
pointValue(Point3d)


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Plane, Tolerance) |
 | IntersectWith(BoundedPlane, Tolerance) |
 | IntersectWith(Plane) |
 | IntersectWith(BoundedPlane) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |


IntersectWith Method (boundPlane)

IntersectWith Method (boundPlane)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IntersectWith(BoundedPlane)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment3d IntersectWith(
    BoundedPlane boundPlane
)
Public Function IntersectWith ( _
    boundPlane As BoundedPlane _
) As LineSegment3d
public:
LineSegment3d^ IntersectWith(
    BoundedPlane^ boundPlane
)
Parameters
boundPlane(BoundedPlane)


IntersectWith Method (boundPlane, tolerance)

IntersectWith Method (boundPlane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IntersectWith(BoundedPlane, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public LineSegment3d IntersectWith(
    BoundedPlane boundPlane,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    boundPlane As BoundedPlane, _
    tolerance As Tolerance _
) As LineSegment3d
public:
LineSegment3d^ IntersectWith(
    BoundedPlane^ boundPlane,
    Tolerance tolerance
)
Parameters
boundPlane(BoundedPlane)
tolerance(Tolerance)


IntersectWith Method (otherPlane)

IntersectWith Method (otherPlane)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IntersectWith(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public Line3d IntersectWith(
    Plane otherPlane
)
Public Function IntersectWith ( _
    otherPlane As Plane _
) As Line3d
public:
Line3d^ IntersectWith(
    Plane^ otherPlane
)
Parameters
otherPlane(Plane)


IntersectWith Method (otherPlane, tolerance)

IntersectWith Method (otherPlane, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IntersectWith(Plane, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Line3d IntersectWith(
    Plane otherPlane,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    otherPlane As Plane, _
    tolerance As Tolerance _
) As Line3d
public:
Line3d^ IntersectWith(
    Plane^ otherPlane,
    Tolerance tolerance
)
Parameters
otherPlane(Plane)
tolerance(Tolerance)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Set()()()()
Members
Icon | Member | Description
 | Set(Double, Double, Double, Double) |
 | Set(Point3d, Vector3d, Vector3d) |
 | Set(Point3d, Point3d, Point3d) |
 | Set(Point3d, Vector3d) |


Set Method (a, b, c, d)

Set Method (a, b, c, d)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Set(Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double a,
    double b,
    double c,
    double d
)
Public Sub Set ( _
    a As Double, _
    b As Double, _
    c As Double, _
    d As Double _
)
public:
void Set(
    double a,
    double b,
    double c,
    double d
)
Parameters
a(Double)
b(Double)
c(Double)
d(Double)


Set Method (u, origin, v)

Set Method (u, origin, v)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Set(Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d u,
    Point3d origin,
    Point3d v
)
Public Sub Set ( _
    u As Point3d, _
    origin As Point3d, _
    v As Point3d _
)
public:
void Set(
    Point3d u,
    Point3d origin,
    Point3d v
)
Parameters
u(Point3d)
origin(Point3d)
v(Point3d)


Set Method (pointValue, normal)

Set Method (pointValue, normal)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Set(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d pointValue,
    Vector3d normal
)
Public Sub Set ( _
    pointValue As Point3d, _
    normal As Vector3d _
)
public:
void Set(
    Point3d pointValue,
    Vector3d normal
)
Parameters
pointValue(Point3d)
normal(Vector3d)


Set Method (origin, u, v)

Set Method (origin, u, v)
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Set(Point3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d origin,
    Vector3d u,
    Vector3d v
)
Public Sub Set ( _
    origin As Point3d, _
    u As Vector3d, _
    v As Vector3d _
)
public:
void Set(
    Point3d origin,
    Vector3d u,
    Vector3d v
)
Parameters
origin(Point3d)
u(Vector3d)
v(Vector3d)


Point2d Structure

Point2d Structure
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePoint2d")]
public struct Point2d : IFormattable
<WrapperAttribute("ZcGePoint2d")> _
Public Structure Point2d _
    Implements IFormattable
[WrapperAttribute(L"ZcGePoint2d")]
public value class Point2d : IFormattable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Point2d(Double, Double) |
 | Point2d(array<Double>[]()[][]) |
 | Add(Vector2d) |
 | Addition(Point2d, Vector2d) |
 | Coordinate[([( Int32])]) |
 | DivideBy(Double) |
 | Division(Point2d, Double) |
 | Equality(Point2d, Point2d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetAsVector()()()() |
 | GetDistanceTo(Point2d) |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | GetVectorTo(Point2d) |
 | Inequality(Point2d, Point2d) |
 | IsEqualTo(Point2d, Tolerance) |
 | IsEqualTo(Point2d) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) |
 | Multiply(Double, Point2d) |
 | Multiply(Point2d, Double) |
 | Multiply(Matrix2d, Point2d) |
 | MultiplyBy(Double) |
 | Origin |
 | RotateBy(Double, Point2d) |
 | ScaleBy(Double, Point2d) |
 | Subtract(Vector2d) |
 | Subtraction(Point2d, Vector2d) |
 | Subtraction(Point2d, Point2d) |
 | ToArray()()()() |
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | TransformBy(Matrix2d) |
 | X |
 | Y |


Point2d Constructor

Point2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Point2d()()()()
Members
Icon | Member | Description
 | Point2d(Double, Double) |
 | Point2d(array<Double>[]()[][]) |


Point2d Constructor (x, y)

Point2d Constructor (x, y)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Point2d(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d(
    double x,
    double y
)
Public Sub New ( _
    x As Double, _
    y As Double _
)
public:
Point2d(
    double x,
    double y
)
Parameters
x(Double)
y(Double)


Point2d Constructor (xy)

Point2d Constructor (xy)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Point2d(array<Double>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Point2d(
    double[] xy
)
Public Sub New ( _
    xy As Double() _
)
public:
Point2d(
    array<double>^ xy
)
Parameters
xy(array<Double>[]()[][])


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Add(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Add(
    Vector2d value
)
Public Function Add ( _
    value As Vector2d _
) As Point2d
public:
Point2d Add(
    Vector2d value
)
Parameters
value(Vector2d)


Addition Operator

Addition Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Addition(Point2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Point2d operator +(
    Point2d a,
    Vector2d vector
)
Public Shared Operator + ( _
    a As Point2d, _
    vector As Vector2d _
) As Point2d
public:
static Point2d operator +(
    Point2d a,
    Vector2d vector
)
Parameters
a(Point2d)
vector(Vector2d)


Coordinate Property (i)

Coordinate Property (i)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Coordinate[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int i
] { get; }
Public ReadOnly Default Property Coordinate ( _
    i As Integer _
) As Double
    Get
public:
property double default[int i] {
    double get (int i);
}
Parameters
i(Int32)


DivideBy Method (value)

DivideBy Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »DivideBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d DivideBy(
    double value
)
Public Function DivideBy ( _
    value As Double _
) As Point2d
public:
Point2d DivideBy(
    double value
)
Parameters
value(Double)


Division Operator

Division Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Division(Point2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Point2d operator /(
    Point2d a,
    double value
)
Public Shared Operator / ( _
    a As Point2d, _
    value As Double _
) As Point2d
public:
static Point2d operator /(
    Point2d a,
    double value
)
Parameters
a(Point2d)
value(Double)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Equality(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Point2d a,
    Point2d b
)
Public Shared Operator = ( _
    a As Point2d, _
    b As Point2d _
) As Boolean
public:
static bool operator ==(
    Point2d a,
    Point2d b
)
Parameters
a(Point2d)
b(Point2d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetAsVector Method

GetAsVector Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »GetAsVector()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetAsVector()
Public Function GetAsVector As Vector2d
public:
Vector2d GetAsVector()


GetDistanceTo Method (point)

GetDistanceTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »GetDistanceTo(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetDistanceTo(
    Point2d point
)
Public Function GetDistanceTo ( _
    point As Point2d _
) As Double
public:
double GetDistanceTo(
    Point2d point
)
Parameters
point(Point2d)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetVectorTo Method (point)

GetVectorTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »GetVectorTo(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetVectorTo(
    Point2d point
)
Public Function GetVectorTo ( _
    point As Point2d _
) As Vector2d
public:
Vector2d GetVectorTo(
    Point2d point
)
Parameters
point(Point2d)


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Inequality(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Point2d a,
    Point2d b
)
Public Shared Operator <> ( _
    a As Point2d, _
    b As Point2d _
) As Boolean
public:
static bool operator !=(
    Point2d a,
    Point2d b
)
Parameters
a(Point2d)
b(Point2d)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Point2d, Tolerance) |
 | IsEqualTo(Point2d) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »IsEqualTo(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Point2d a
)
Public Function IsEqualTo ( _
    a As Point2d _
) As Boolean
public:
bool IsEqualTo(
    Point2d a
)
Parameters
a(Point2d)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »IsEqualTo(Point2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Point2d a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As Point2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Point2d a,
    Tolerance tolerance
)
Parameters
a(Point2d)
tolerance(Tolerance)


Mirror Method (line)

Mirror Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Mirror(Line2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Mirror(
    Line2d line
)
Public Function Mirror ( _
    line As Line2d _
) As Point2d
public:
Point2d Mirror(
    Line2d^ line
)
Parameters
line(Line2d)


Multiply Method

Multiply Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Multiply()()()()
Members
Icon | Member | Description
 | Multiply(Double, Point2d) |
 | Multiply(Point2d, Double) |
 | Multiply(Matrix2d, Point2d) |


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Multiply(Double, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Point2d operator *(
    double value,
    Point2d a
)
Public Shared Operator * ( _
    value As Double, _
    a As Point2d _
) As Point2d
public:
static Point2d operator *(
    double value,
    Point2d a
)
Parameters
value(Double)
a(Point2d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Multiply(Matrix2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Point2d operator *(
    Matrix2d mat,
    Point2d a
)
Public Shared Operator * ( _
    mat As Matrix2d, _
    a As Point2d _
) As Point2d
public:
static Point2d operator *(
    Matrix2d mat,
    Point2d a
)
Parameters
mat(Matrix2d)
a(Point2d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Multiply(Point2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Point2d operator *(
    Point2d a,
    double value
)
Public Shared Operator * ( _
    a As Point2d, _
    value As Double _
) As Point2d
public:
static Point2d operator *(
    Point2d a,
    double value
)
Parameters
a(Point2d)
value(Double)


MultiplyBy Method (value)

MultiplyBy Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »MultiplyBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d MultiplyBy(
    double value
)
Public Function MultiplyBy ( _
    value As Double _
) As Point2d
public:
Point2d MultiplyBy(
    double value
)
Parameters
value(Double)


Origin Property

Origin Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Origin
Declaration Syntax
C# Visual Basic Visual C++
public static Point2d Origin { get; }
Public Shared ReadOnly Property Origin As Point2d
    Get
public:
static property Point2d Origin {
    Point2d get ();
}


RotateBy Method (angle, origin)

RotateBy Method (angle, origin)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »RotateBy(Double, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d RotateBy(
    double angle,
    Point2d origin
)
Public Function RotateBy ( _
    angle As Double, _
    origin As Point2d _
) As Point2d
public:
Point2d RotateBy(
    double angle,
    Point2d origin
)
Parameters
angle(Double)
origin(Point2d)


ScaleBy Method (scaleFactor, origin)

ScaleBy Method (scaleFactor, origin)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »ScaleBy(Double, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d ScaleBy(
    double scaleFactor,
    Point2d origin
)
Public Function ScaleBy ( _
    scaleFactor As Double, _
    origin As Point2d _
) As Point2d
public:
Point2d ScaleBy(
    double scaleFactor,
    Point2d origin
)
Parameters
scaleFactor(Double)
origin(Point2d)


Subtract Method (value)

Subtract Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Subtract(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Subtract(
    Vector2d value
)
Public Function Subtract ( _
    value As Vector2d _
) As Point2d
public:
Point2d Subtract(
    Vector2d value
)
Parameters
value(Vector2d)


Subtraction Method

Subtraction Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Subtraction()()()()
Members
Icon | Member | Description
 | Subtraction(Point2d, Vector2d) |
 | Subtraction(Point2d, Point2d) |


Subtraction Operator

Subtraction Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Subtraction(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d operator -(
    Point2d a,
    Point2d b
)
Public Shared Operator - ( _
    a As Point2d, _
    b As Point2d _
) As Vector2d
public:
static Vector2d operator -(
    Point2d a,
    Point2d b
)
Parameters
a(Point2d)
b(Point2d)


Subtraction Operator

Subtraction Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Subtraction(Point2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Point2d operator -(
    Point2d a,
    Vector2d b
)
Public Shared Operator - ( _
    a As Point2d, _
    b As Vector2d _
) As Point2d
public:
static Point2d operator -(
    Point2d a,
    Vector2d b
)
Parameters
a(Point2d)
b(Vector2d)


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] ToArray()
Public Function ToArray As Double()
public:
array<double>^ ToArray()


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


TransformBy Method (leftSide)

TransformBy Method (leftSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »TransformBy(Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d TransformBy(
    Matrix2d leftSide
)
Public Function TransformBy ( _
    leftSide As Matrix2d _
) As Point2d
public:
Point2d TransformBy(
    Matrix2d leftSide
)
Parameters
leftSide(Matrix2d)


X Property

X Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »X
Declaration Syntax
C# Visual Basic Visual C++
public double X { get; }
Public ReadOnly Property X As Double
    Get
public:
property double X {
    double get ();
}


Y Property

Y Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point2d »Y
Declaration Syntax
C# Visual Basic Visual C++
public double Y { get; }
Public ReadOnly Property Y As Double
    Get
public:
property double Y {
    double get ();
}


Point2dCollection Class

Point2dCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePoint2dArray")]
public sealed class Point2dCollection : DisposableWrapper,
    IList
<WrapperAttribute("ZcGePoint2dArray")> _
Public NotInheritable Class Point2dCollection _
    Inherits DisposableWrapper _
    Implements IList
[WrapperAttribute(L"ZcGePoint2dArray")]
public ref class Point2dCollection sealed : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Point2dCollection(array<Point2d>[]()[][]) |
 | Point2dCollection(Int32) |
 | Point2dCollection()()()() |
 | Add(Point2d) |
 | AddRange(array<Point2d>[]()[][]) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Capacity |
 | Clear()()()() |
 | Contains(Point2d) |
 | CopyTo(array<Point2d>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DefaultSize |
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(Point2d) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, Point2d) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Point2d) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Point2dCollection


Point2dCollection Constructor

Point2dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Point2dCollection()()()()
Members
Icon | Member | Description
 | Point2dCollection(array<Point2d>[]()[][]) |
 | Point2dCollection(Int32) |
 | Point2dCollection()()()() |


Point2dCollection Constructor

Point2dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Point2dCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point2dCollection()
Public Sub New
public:
Point2dCollection()


Point2dCollection Constructor (capacity)

Point2dCollection Constructor (capacity)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Point2dCollection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point2dCollection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
Point2dCollection(
    int capacity
)
Parameters
capacity(Int32)


Point2dCollection Constructor (values)

Point2dCollection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Point2dCollection(array<Point2d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Point2dCollection(
    Point2d[] values
)
Public Sub New ( _
    values As Point2d() _
)
public:
Point2dCollection(
    array<Point2d>^ values
)
Parameters
values(array< Point2d >[]()[][])


Add Method (p)

Add Method (p)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Add(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Point2d p
)
Public Function Add ( _
    p As Point2d _
) As Integer
public:
int Add(
    Point2d p
)
Parameters
p(Point2d)


AddRange Method (range)

AddRange Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »AddRange(array<Point2d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    Point2d[] range
)
Public Sub AddRange ( _
    range As Point2d() _
)
public:
virtual void AddRange(
    array<Point2d>^ range
) sealed
Parameters
range(array< Point2d >[]()[][])


Capacity Property

Capacity Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Capacity
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (p)

Contains Method (p)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Contains(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Point2d p
)
Public Function Contains ( _
    p As Point2d _
) As Boolean
public:
bool Contains(
    Point2d p
)
Parameters
p(Point2d)


CopyTo Method (a, index)

CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »CopyTo(array<Point2d>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Point2d[] a,
    int index
)
Public Sub CopyTo ( _
    a As Point2d(), _
    index As Integer _
)
public:
void CopyTo(
    array<Point2d>^ a,
    int index
)
Parameters
a(array< Point2d >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DefaultSize Field

DefaultSize Field
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »DefaultSize
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultSize
Public Const DefaultSize As Integer
public:
literal int DefaultSize


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollection_CopyTo Method (a, index)

ICollection_CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array a,
    int index
)
Private Sub ICollection_CopyTo ( _
    a As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ a,
    int index
) sealed = ICollection::CopyTo
Parameters
a(Array)
index(Int32)


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IList_IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IList_IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IList_Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IList_Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (p)

IndexOf Method (p)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »IndexOf(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Point2d p
)
Public Function IndexOf ( _
    p As Point2d _
) As Integer
public:
int IndexOf(
    Point2d p
)
Parameters
p(Point2d)


Insert Method (index, p)

Insert Method (index, p)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Insert(Int32, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Point2d p
)
Public Sub Insert ( _
    index As Integer, _
    p As Point2d _
)
public:
void Insert(
    int index,
    Point2d p
)
Parameters
index(Int32)
p(Point2d)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Point2d this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Point2d
    Get
    Set
public:
property Point2d default[int index] {
    Point2d get (int index);
    void set (int index, Point2d value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Remove(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Point2d value
)
Public Sub Remove ( _
    value As Point2d _
)
public:
void Remove(
    Point2d value
)
Parameters
value(Point2d)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] ToArray()
Public Function ToArray As Point2d()
public:
virtual array<Point2d>^ ToArray() sealed


TrimToSize Method

TrimToSize Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »TrimToSize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void TrimToSize()
Public Sub TrimToSize
public:
virtual void TrimToSize() sealed


Point3d Structure

Point3d Structure
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePoint3d")]
public struct Point3d : IFormattable
<WrapperAttribute("ZcGePoint3d")> _
Public Structure Point3d _
    Implements IFormattable
[WrapperAttribute(L"ZcGePoint3d")]
public value class Point3d : IFormattable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Point3d(Double, Double, Double) |
 | Point3d(PlanarEntity, Point2d) |
 | Point3d(array<Double>[]()[][]) |
 | Add(Vector3d) |
 | Addition(Point3d, Vector3d) |
 | Convert2d(PlanarEntity) |
 | Coordinate[([( Int32])]) |
 | DistanceTo(Point3d) |
 | DivideBy(Double) |
 | Division(Point3d, Double) |
 | Equality(Point3d, Point3d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetAsVector()()()() |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | GetVectorTo(Point3d) |
 | Inequality(Point3d, Point3d) |
 | IsEqualTo(Point3d, Tolerance) |
 | IsEqualTo(Point3d) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) |
 | Multiply(Double, Point3d) |
 | Multiply(Point3d, Double) |
 | Multiply(Matrix3d, Point3d) |
 | MultiplyBy(Double) |
 | Origin |
 | OrthoProject(Plane) |
 | Project(Plane, Vector3d) |
 | RotateBy(Double, Vector3d, Point3d) |
 | ScaleBy(Double, Point3d) |
 | Subtract(Vector3d) |
 | Subtraction(Point3d, Vector3d) |
 | Subtraction(Point3d, Point3d) |
 | ToArray()()()() |
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | TransformBy(Matrix3d) |
 | X |
 | Y |
 | Z |


Point3d Constructor

Point3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Point3d()()()()
Members
Icon | Member | Description
 | Point3d(Double, Double, Double) |
 | Point3d(PlanarEntity, Point2d) |
 | Point3d(array<Double>[]()[][]) |


Point3d Constructor (x, y, z)

Point3d Constructor (x, y, z)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Point3d(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d(
    double x,
    double y,
    double z
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
Point3d(
    double x,
    double y,
    double z
)
Parameters
x(Double)
y(Double)
z(Double)


Point3d Constructor (xyz)

Point3d Constructor (xyz)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Point3d(array<Double>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Point3d(
    double[] xyz
)
Public Sub New ( _
    xyz As Double() _
)
public:
Point3d(
    array<double>^ xyz
)
Parameters
xyz(array<Double>[]()[][])


Point3d Constructor (plane, point)

Point3d Constructor (plane, point)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Point3d(PlanarEntity, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d(
    PlanarEntity plane,
    Point2d point
)
Public Sub New ( _
    plane As PlanarEntity, _
    point As Point2d _
)
public:
Point3d(
    PlanarEntity^ plane,
    Point2d point
)
Parameters
plane(PlanarEntity)
point(Point2d)


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Add(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Add(
    Vector3d value
)
Public Function Add ( _
    value As Vector3d _
) As Point3d
public:
Point3d Add(
    Vector3d value
)
Parameters
value(Vector3d)


Addition Operator

Addition Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Addition(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Point3d operator +(
    Point3d a,
    Vector3d vector
)
Public Shared Operator + ( _
    a As Point3d, _
    vector As Vector3d _
) As Point3d
public:
static Point3d operator +(
    Point3d a,
    Vector3d vector
)
Parameters
a(Point3d)
vector(Vector3d)


Convert2d Method (plane)

Convert2d Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Convert2d(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Convert2d(
    PlanarEntity plane
)
Public Function Convert2d ( _
    plane As PlanarEntity _
) As Point2d
public:
Point2d Convert2d(
    PlanarEntity^ plane
)
Parameters
plane(PlanarEntity)


Coordinate Property (i)

Coordinate Property (i)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Coordinate[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int i
] { get; }
Public ReadOnly Default Property Coordinate ( _
    i As Integer _
) As Double
    Get
public:
property double default[int i] {
    double get (int i);
}
Parameters
i(Int32)


DistanceTo Method (point)

DistanceTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »DistanceTo(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public double DistanceTo(
    Point3d point
)
Public Function DistanceTo ( _
    point As Point3d _
) As Double
public:
double DistanceTo(
    Point3d point
)
Parameters
point(Point3d)


DivideBy Method (value)

DivideBy Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »DivideBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d DivideBy(
    double value
)
Public Function DivideBy ( _
    value As Double _
) As Point3d
public:
Point3d DivideBy(
    double value
)
Parameters
value(Double)


Division Operator

Division Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Division(Point3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Point3d operator /(
    Point3d a,
    double value
)
Public Shared Operator / ( _
    a As Point3d, _
    value As Double _
) As Point3d
public:
static Point3d operator /(
    Point3d a,
    double value
)
Parameters
a(Point3d)
value(Double)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Equality(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Point3d a,
    Point3d b
)
Public Shared Operator = ( _
    a As Point3d, _
    b As Point3d _
) As Boolean
public:
static bool operator ==(
    Point3d a,
    Point3d b
)
Parameters
a(Point3d)
b(Point3d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetAsVector Method

GetAsVector Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »GetAsVector()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetAsVector()
Public Function GetAsVector As Vector3d
public:
Vector3d GetAsVector()


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetVectorTo Method (point)

GetVectorTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »GetVectorTo(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetVectorTo(
    Point3d point
)
Public Function GetVectorTo ( _
    point As Point3d _
) As Vector3d
public:
Vector3d GetVectorTo(
    Point3d point
)
Parameters
point(Point3d)


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Inequality(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Point3d a,
    Point3d b
)
Public Shared Operator <> ( _
    a As Point3d, _
    b As Point3d _
) As Boolean
public:
static bool operator !=(
    Point3d a,
    Point3d b
)
Parameters
a(Point3d)
b(Point3d)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Point3d, Tolerance) |
 | IsEqualTo(Point3d) |


IsEqualTo Method (point)

IsEqualTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »IsEqualTo(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Point3d point
)
Public Function IsEqualTo ( _
    point As Point3d _
) As Boolean
public:
bool IsEqualTo(
    Point3d point
)
Parameters
point(Point3d)


IsEqualTo Method (point, tolerance)

IsEqualTo Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »IsEqualTo(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Point3d point,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    point As Point3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


Mirror Method (plane)

Mirror Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Mirror(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Mirror(
    Plane plane
)
Public Function Mirror ( _
    plane As Plane _
) As Point3d
public:
Point3d Mirror(
    Plane^ plane
)
Parameters
plane(Plane)


Multiply Method

Multiply Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Multiply()()()()
Members
Icon | Member | Description
 | Multiply(Double, Point3d) |
 | Multiply(Point3d, Double) |
 | Multiply(Matrix3d, Point3d) |


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Multiply(Double, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Point3d operator *(
    double value,
    Point3d a
)
Public Shared Operator * ( _
    value As Double, _
    a As Point3d _
) As Point3d
public:
static Point3d operator *(
    double value,
    Point3d a
)
Parameters
value(Double)
a(Point3d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Multiply(Matrix3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Point3d operator *(
    Matrix3d mat,
    Point3d a
)
Public Shared Operator * ( _
    mat As Matrix3d, _
    a As Point3d _
) As Point3d
public:
static Point3d operator *(
    Matrix3d mat,
    Point3d a
)
Parameters
mat(Matrix3d)
a(Point3d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Multiply(Point3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Point3d operator *(
    Point3d a,
    double value
)
Public Shared Operator * ( _
    a As Point3d, _
    value As Double _
) As Point3d
public:
static Point3d operator *(
    Point3d a,
    double value
)
Parameters
a(Point3d)
value(Double)


MultiplyBy Method (value)

MultiplyBy Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »MultiplyBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d MultiplyBy(
    double value
)
Public Function MultiplyBy ( _
    value As Double _
) As Point3d
public:
Point3d MultiplyBy(
    double value
)
Parameters
value(Double)


Origin Property

Origin Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Origin
Declaration Syntax
C# Visual Basic Visual C++
public static Point3d Origin { get; }
Public Shared ReadOnly Property Origin As Point3d
    Get
public:
static property Point3d Origin {
    Point3d get ();
}


OrthoProject Method (plane)

OrthoProject Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »OrthoProject(Plane)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d OrthoProject(
    Plane plane
)
Public Function OrthoProject ( _
    plane As Plane _
) As Point3d
public:
Point3d OrthoProject(
    Plane^ plane
)
Parameters
plane(Plane)


Project Method (plane, vector)

Project Method (plane, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Project(Plane, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Project(
    Plane plane,
    Vector3d vector
)
Public Function Project ( _
    plane As Plane, _
    vector As Vector3d _
) As Point3d
public:
Point3d Project(
    Plane^ plane,
    Vector3d vector
)
Parameters
plane(Plane)
vector(Vector3d)


RotateBy Method (angle, vector, centerPoint)

RotateBy Method (angle, vector, centerPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »RotateBy(Double, Vector3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d RotateBy(
    double angle,
    Vector3d vector,
    Point3d centerPoint
)
Public Function RotateBy ( _
    angle As Double, _
    vector As Vector3d, _
    centerPoint As Point3d _
) As Point3d
public:
Point3d RotateBy(
    double angle,
    Vector3d vector,
    Point3d centerPoint
)
Parameters
angle(Double)
vector(Vector3d)
centerPoint(Point3d)


ScaleBy Method (scaleFactor, centerPoint)

ScaleBy Method (scaleFactor, centerPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »ScaleBy(Double, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ScaleBy(
    double scaleFactor,
    Point3d centerPoint
)
Public Function ScaleBy ( _
    scaleFactor As Double, _
    centerPoint As Point3d _
) As Point3d
public:
Point3d ScaleBy(
    double scaleFactor,
    Point3d centerPoint
)
Parameters
scaleFactor(Double)
centerPoint(Point3d)


Subtract Method (value)

Subtract Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Subtract(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Subtract(
    Vector3d value
)
Public Function Subtract ( _
    value As Vector3d _
) As Point3d
public:
Point3d Subtract(
    Vector3d value
)
Parameters
value(Vector3d)


Subtraction Method

Subtraction Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Subtraction()()()()
Members
Icon | Member | Description
 | Subtraction(Point3d, Vector3d) |
 | Subtraction(Point3d, Point3d) |


Subtraction Operator

Subtraction Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Subtraction(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d operator -(
    Point3d a,
    Point3d b
)
Public Shared Operator - ( _
    a As Point3d, _
    b As Point3d _
) As Vector3d
public:
static Vector3d operator -(
    Point3d a,
    Point3d b
)
Parameters
a(Point3d)
b(Point3d)


Subtraction Operator

Subtraction Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Subtraction(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Point3d operator -(
    Point3d a,
    Vector3d b
)
Public Shared Operator - ( _
    a As Point3d, _
    b As Vector3d _
) As Point3d
public:
static Point3d operator -(
    Point3d a,
    Vector3d b
)
Parameters
a(Point3d)
b(Vector3d)


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] ToArray()
Public Function ToArray As Double()
public:
array<double>^ ToArray()


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


TransformBy Method (leftSide)

TransformBy Method (leftSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »TransformBy(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d TransformBy(
    Matrix3d leftSide
)
Public Function TransformBy ( _
    leftSide As Matrix3d _
) As Point3d
public:
Point3d TransformBy(
    Matrix3d leftSide
)
Parameters
leftSide(Matrix3d)


X Property

X Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »X
Declaration Syntax
C# Visual Basic Visual C++
public double X { get; }
Public ReadOnly Property X As Double
    Get
public:
property double X {
    double get ();
}


Y Property

Y Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Y
Declaration Syntax
C# Visual Basic Visual C++
public double Y { get; }
Public ReadOnly Property Y As Double
    Get
public:
property double Y {
    double get ();
}


Z Property

Z Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point3d »Z
Declaration Syntax
C# Visual Basic Visual C++
public double Z { get; }
Public ReadOnly Property Z As Double
    Get
public:
property double Z {
    double get ();
}


Point3dCollection Class

Point3dCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePoint3dArray")]
public sealed class Point3dCollection : DisposableWrapper,
    IList
<WrapperAttribute("ZcGePoint3dArray")> _
Public NotInheritable Class Point3dCollection _
    Inherits DisposableWrapper _
    Implements IList
[WrapperAttribute(L"ZcGePoint3dArray")]
public ref class Point3dCollection sealed : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Point3dCollection(array<Point3d>[]()[][]) |
 | Point3dCollection()()()() |
 | Add(Point3d) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(Point3d) |
 | CopyTo(array<Point3d>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(Point3d) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, Point3d) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Point3d) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Point3dCollection


Point3dCollection Constructor

Point3dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Point3dCollection()()()()
Members
Icon | Member | Description
 | Point3dCollection(array<Point3d>[]()[][]) |
 | Point3dCollection()()()() |


Point3dCollection Constructor

Point3dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Point3dCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection()
Public Sub New
public:
Point3dCollection()


Point3dCollection Constructor (values)

Point3dCollection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Point3dCollection(array<Point3d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection(
    Point3d[] values
)
Public Sub New ( _
    values As Point3d() _
)
public:
Point3dCollection(
    array<Point3d>^ values
)
Parameters
values(array< Point3d >[]()[][])


Add Method (p)

Add Method (p)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Add(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Point3d p
)
Public Function Add ( _
    p As Point3d _
) As Integer
public:
int Add(
    Point3d p
)
Parameters
p(Point3d)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (p)

Contains Method (p)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Contains(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Point3d p
)
Public Function Contains ( _
    p As Point3d _
) As Boolean
public:
bool Contains(
    Point3d p
)
Parameters
p(Point3d)


CopyTo Method (a, index)

CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »CopyTo(array<Point3d>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Point3d[] a,
    int index
)
Public Sub CopyTo ( _
    a As Point3d(), _
    index As Integer _
)
public:
void CopyTo(
    array<Point3d>^ a,
    int index
)
Parameters
a(array< Point3d >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollection_CopyTo Method (a, index)

ICollection_CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array a,
    int index
)
Private Sub ICollection_CopyTo ( _
    a As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ a,
    int index
) sealed = ICollection::CopyTo
Parameters
a(Array)
index(Int32)


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IList_IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IList_IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IList_Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IList_Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (p)

IndexOf Method (p)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »IndexOf(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Point3d p
)
Public Function IndexOf ( _
    p As Point3d _
) As Integer
public:
int IndexOf(
    Point3d p
)
Parameters
p(Point3d)


Insert Method (index, p)

Insert Method (index, p)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Insert(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Point3d p
)
Public Sub Insert ( _
    index As Integer, _
    p As Point3d _
)
public:
void Insert(
    int index,
    Point3d p
)
Parameters
index(Int32)
p(Point3d)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Point3d this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Point3d
    Get
    Set
public:
property Point3d default[int index] {
    Point3d get (int index);
    void set (int index, Point3d value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Remove(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Point3d value
)
Public Sub Remove ( _
    value As Point3d _
)
public:
void Remove(
    Point3d value
)
Parameters
value(Point3d)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


PointEntity2d Class

PointEntity2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePointEnt2d")]
public abstract class PointEntity2d : Entity2d
<WrapperAttribute("ZcGePointEnt2d")> _
Public MustInherit Class PointEntity2d _
    Inherits Entity2d
[WrapperAttribute(L"ZcGePointEnt2d")]
public ref class PointEntity2d abstract : public Entity2d
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Entity2d.)
 | IsOn(Point2d) | (Inherited from Entity2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | Point |
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | PointEntity2d
 |  |  |  |  | PointOnCurve2d
 |  |  |  |  | Position2d


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static PointEntity2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As PointEntity2d
public:
static PointEntity2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Point Property

Point Property
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity2d »Point
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Point { get; }
Public ReadOnly Property Point As Point2d
    Get
public:
property Point2d Point {
    Point2d get ();
}


PointEntity3d Class

PointEntity3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePointEnt3d")]
public abstract class PointEntity3d : Entity3d
<WrapperAttribute("ZcGePointEnt3d")> _
Public MustInherit Class PointEntity3d _
    Inherits Entity3d
[WrapperAttribute(L"ZcGePointEnt3d")]
public ref class PointEntity3d abstract : public Entity3d
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetPoint()()()() |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | PointEntity3d
 |  |  |  |  | PointOnCurve3d
 |  |  |  |  | PointOnSurface
 |  |  |  |  | Position3d


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static PointEntity3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As PointEntity3d
public:
static PointEntity3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetPoint Method

GetPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity3d »GetPoint()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetPoint()
Public Function GetPoint As Point3d
public:
Point3d GetPoint()


PointOnCurve2d Class

PointOnCurve2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePointOnCurve2d")]
public sealed class PointOnCurve2d : PointEntity2d
<WrapperAttribute("ZcGePointOnCurve2d")> _
Public NotInheritable Class PointOnCurve2d _
    Inherits PointEntity2d
[WrapperAttribute(L"ZcGePointOnCurve2d")]
public ref class PointOnCurve2d sealed : public PointEntity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PointOnCurve2d(Curve2d, Double) |
 | PointOnCurve2d(Curve2d) |
 | PointOnCurve2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Curve |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetDerivative(Int32, Curve2d, Double) |
 | GetDerivative(Int32, Double) |
 | GetDerivative(Int32) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetPointAtParameter(Double) |
 | GetPointOnCurve(Curve2d, Double) |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Entity2d.)
 | IsOn(Point2d) | (Inherited from Entity2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | Parameter |
 | Point |
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | PointEntity2d
 |  |  |  |  | PointOnCurve2d


PointOnCurve2d Constructor

PointOnCurve2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »PointOnCurve2d()()()()
Members
Icon | Member | Description
 | PointOnCurve2d(Curve2d, Double) |
 | PointOnCurve2d(Curve2d) |
 | PointOnCurve2d()()()() |


PointOnCurve2d Constructor

PointOnCurve2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »PointOnCurve2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d()
Public Sub New
public:
PointOnCurve2d()


PointOnCurve2d Constructor (curve)

PointOnCurve2d Constructor (curve)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »PointOnCurve2d(Curve2d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d(
    Curve2d curve
)
Public Sub New ( _
    curve As Curve2d _
)
public:
PointOnCurve2d(
    Curve2d^ curve
)
Parameters
curve(Curve2d)


PointOnCurve2d Constructor (curve, parameter)

PointOnCurve2d Constructor (curve, parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »PointOnCurve2d(Curve2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve2d(
    Curve2d curve,
    double parameter
)
Public Sub New ( _
    curve As Curve2d, _
    parameter As Double _
)
public:
PointOnCurve2d(
    Curve2d^ curve,
    double parameter
)
Parameters
curve(Curve2d)
parameter(Double)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static PointOnCurve2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As PointOnCurve2d
public:
static PointOnCurve2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Curve Property

Curve Property
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »Curve
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d Curve { get; set; }
Public Property Curve As Curve2d
    Get
    Set
public:
property Curve2d^ Curve {
    Curve2d^ get ();
    void set (Curve2d^ value);
}


GetDerivative Method

GetDerivative Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »GetDerivative()()()()
Members
Icon | Member | Description
 | GetDerivative(Int32, Curve2d, Double) |
 | GetDerivative(Int32, Double) |
 | GetDerivative(Int32) |


GetDerivative Method (order)

GetDerivative Method (order)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »GetDerivative(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetDerivative(
    int order
)
Public Function GetDerivative ( _
    order As Integer _
) As Vector2d
public:
Vector2d GetDerivative(
    int order
)
Parameters
order(Int32)


GetDerivative Method (order, parameter)

GetDerivative Method (order, parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »GetDerivative(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetDerivative(
    int order,
    double parameter
)
Public Function GetDerivative ( _
    order As Integer, _
    parameter As Double _
) As Vector2d
public:
Vector2d GetDerivative(
    int order,
    double parameter
)
Parameters
order(Int32)
parameter(Double)


GetDerivative Method (order, curve, parameter)

GetDerivative Method (order, curve, parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »GetDerivative(Int32, Curve2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetDerivative(
    int order,
    Curve2d curve,
    double parameter
)
Public Function GetDerivative ( _
    order As Integer, _
    curve As Curve2d, _
    parameter As Double _
) As Vector2d
public:
Vector2d GetDerivative(
    int order,
    Curve2d^ curve,
    double parameter
)
Parameters
order(Int32)
curve(Curve2d)
parameter(Double)


GetPointAtParameter Method (parameter)

GetPointAtParameter Method (parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »GetPointAtParameter(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetPointAtParameter(
    double parameter
)
Public Function GetPointAtParameter ( _
    parameter As Double _
) As Point2d
public:
Point2d GetPointAtParameter(
    double parameter
)
Parameters
parameter(Double)


GetPointOnCurve Method (curve, parameter)

GetPointOnCurve Method (curve, parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »GetPointOnCurve(Curve2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetPointOnCurve(
    Curve2d curve,
    double parameter
)
Public Function GetPointOnCurve ( _
    curve As Curve2d, _
    parameter As Double _
) As Point2d
public:
Point2d GetPointOnCurve(
    Curve2d^ curve,
    double parameter
)
Parameters
curve(Curve2d)
parameter(Double)


Parameter Property

Parameter Property
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »Parameter
Declaration Syntax
C# Visual Basic Visual C++
public double Parameter { get; set; }
Public Property Parameter As Double
    Get
    Set
public:
property double Parameter {
    double get ();
    void set (double value);
}


Point Property

Point Property
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »Point
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Point { get; }
Public ReadOnly Property Point As Point2d
    Get
public:
property Point2d Point {
    Point2d get ();
}


PointOnCurve3d Class

PointOnCurve3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePointOnCurve3d")]
public sealed class PointOnCurve3d : PointEntity3d
<WrapperAttribute("ZcGePointOnCurve3d")> _
Public NotInheritable Class PointOnCurve3d _
    Inherits PointEntity3d
[WrapperAttribute(L"ZcGePointOnCurve3d")]
public ref class PointOnCurve3d sealed : public PointEntity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PointOnCurve3d(Curve3d, Double) |
 | PointOnCurve3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Curve |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetCurvature(Double) |
 | GetCurvature()()()() |
 | GetDerivative(Int32, Curve3d, Double) |
 | GetDerivative(Int32, Double) |
 | GetDerivative(Int32) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetPoint()()()() | (Inherited from PointEntity3d.)
 | GetPointAtParameter(Double) |
 | GetPointOnCurve(Curve3d, Double) |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsSingular(Tolerance) |
 | IsSingular()()()() |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | Parameter |
 | Point |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | PointEntity3d
 |  |  |  |  | PointOnCurve3d


PointOnCurve3d Constructor

PointOnCurve3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »PointOnCurve3d()()()()
Members
Icon | Member | Description
 | PointOnCurve3d(Curve3d, Double) |
 | PointOnCurve3d()()()() |


PointOnCurve3d Constructor

PointOnCurve3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »PointOnCurve3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d()
Public Sub New
public:
PointOnCurve3d()


PointOnCurve3d Constructor (curve, parameter)

PointOnCurve3d Constructor (curve, parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »PointOnCurve3d(Curve3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnCurve3d(
    Curve3d curve,
    double parameter
)
Public Sub New ( _
    curve As Curve3d, _
    parameter As Double _
)
public:
PointOnCurve3d(
    Curve3d^ curve,
    double parameter
)
Parameters
curve(Curve3d)
parameter(Double)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static PointOnCurve3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As PointOnCurve3d
public:
static PointOnCurve3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Curve Property

Curve Property
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »Curve
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d Curve { get; set; }
Public Property Curve As Curve3d
    Get
    Set
public:
property Curve3d^ Curve {
    Curve3d^ get ();
    void set (Curve3d^ value);
}


GetCurvature Method

GetCurvature Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »GetCurvature()()()()
Members
Icon | Member | Description
 | GetCurvature(Double) |
 | GetCurvature()()()() |


GetCurvature Method

GetCurvature Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »GetCurvature()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double GetCurvature()
Public Function GetCurvature As Double
public:
double GetCurvature()


GetCurvature Method (parameter)

GetCurvature Method (parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »GetCurvature(Double)
Declaration Syntax
C# Visual Basic Visual C++
public double GetCurvature(
    double parameter
)
Public Function GetCurvature ( _
    parameter As Double _
) As Double
public:
double GetCurvature(
    double parameter
)
Parameters
parameter(Double)


GetDerivative Method

GetDerivative Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »GetDerivative()()()()
Members
Icon | Member | Description
 | GetDerivative(Int32, Curve3d, Double) |
 | GetDerivative(Int32, Double) |
 | GetDerivative(Int32) |


GetDerivative Method (order)

GetDerivative Method (order)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »GetDerivative(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetDerivative(
    int order
)
Public Function GetDerivative ( _
    order As Integer _
) As Vector3d
public:
Vector3d GetDerivative(
    int order
)
Parameters
order(Int32)


GetDerivative Method (order, parameter)

GetDerivative Method (order, parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »GetDerivative(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetDerivative(
    int order,
    double parameter
)
Public Function GetDerivative ( _
    order As Integer, _
    parameter As Double _
) As Vector3d
public:
Vector3d GetDerivative(
    int order,
    double parameter
)
Parameters
order(Int32)
parameter(Double)


GetDerivative Method (order, curve, parameter)

GetDerivative Method (order, curve, parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »GetDerivative(Int32, Curve3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d GetDerivative(
    int order,
    Curve3d curve,
    double parameter
)
Public Shared Function GetDerivative ( _
    order As Integer, _
    curve As Curve3d, _
    parameter As Double _
) As Vector3d
public:
static Vector3d GetDerivative(
    int order,
    Curve3d^ curve,
    double parameter
)
Parameters
order(Int32)
curve(Curve3d)
parameter(Double)


GetPointAtParameter Method (parameter)

GetPointAtParameter Method (parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »GetPointAtParameter(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetPointAtParameter(
    double parameter
)
Public Function GetPointAtParameter ( _
    parameter As Double _
) As Point3d
public:
Point3d GetPointAtParameter(
    double parameter
)
Parameters
parameter(Double)


GetPointOnCurve Method (curve, parameter)

GetPointOnCurve Method (curve, parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »GetPointOnCurve(Curve3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Point3d GetPointOnCurve(
    Curve3d curve,
    double parameter
)
Public Shared Function GetPointOnCurve ( _
    curve As Curve3d, _
    parameter As Double _
) As Point3d
public:
static Point3d GetPointOnCurve(
    Curve3d^ curve,
    double parameter
)
Parameters
curve(Curve3d)
parameter(Double)


IsSingular Method

IsSingular Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »IsSingular()()()()
Members
Icon | Member | Description
 | IsSingular(Tolerance) |
 | IsSingular()()()() |


IsSingular Method

IsSingular Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »IsSingular()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSingular()
Public Function IsSingular As Boolean
public:
bool IsSingular()


IsSingular Method (tolerance)

IsSingular Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »IsSingular(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSingular(
    Tolerance tolerance
)
Public Function IsSingular ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsSingular(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


Parameter Property

Parameter Property
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »Parameter
Declaration Syntax
C# Visual Basic Visual C++
public double Parameter { get; set; }
Public Property Parameter As Double
    Get
    Set
public:
property double Parameter {
    double get ();
    void set (double value);
}


Point Property

Point Property
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Point { get; }
Public ReadOnly Property Point As Point3d
    Get
public:
property Point3d Point {
    Point3d get ();
}


PointOnSurface Class

PointOnSurface Class
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePointOnSurface")]
public sealed class PointOnSurface : PointEntity3d
<WrapperAttribute("ZcGePointOnSurface")> _
Public NotInheritable Class PointOnSurface _
    Inherits PointEntity3d
[WrapperAttribute(L"ZcGePointOnSurface")]
public ref class PointOnSurface sealed : public PointEntity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PointOnSurface(Surface, Point2d) |
 | PointOnSurface()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInverseTangentVector(Vector3d, Surface, Point2d) |
 | GetInverseTangentVector(Vector3d, Point2d) |
 | GetInverseTangentVector(Vector3d) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetMixedPartial(Surface, Point2d) |
 | GetMixedPartial(Point2d) |
 | GetMixedPartial()()()() |
 | GetNormal(Surface, Point2d) |
 | GetNormal(Point2d) |
 | GetNormal()()()() |
 | GetPoint(Surface, Point2d) |
 | GetPoint(Point2d) |
 | GetPoint()()()() | (Inherited from PointEntity3d.)
 | GetTangentVector(Vector2d, Surface, Point2d) |
 | GetTangentVector(Vector2d, Point2d) |
 | GetTangentVector(Vector2d) |
 | GetType()()()() | (Inherited from Object.)
 | GetUDerivative(Int32, Surface, Point2d) |
 | GetUDerivative(Int32, Point2d) |
 | GetUDerivative(Int32) |
 | GetVDerivative(Int32, Surface, Point2d) |
 | GetVDerivative(Int32, Point2d) |
 | GetVDerivative(Int32) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | Parameter |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Surface |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | PointEntity3d
 |  |  |  |  | PointOnSurface


PointOnSurface Constructor

PointOnSurface Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »PointOnSurface()()()()
Members
Icon | Member | Description
 | PointOnSurface(Surface, Point2d) |
 | PointOnSurface()()()() |


PointOnSurface Constructor

PointOnSurface Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »PointOnSurface()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PointOnSurface()
Public Sub New
public:
PointOnSurface()


PointOnSurface Constructor (surf, point)

PointOnSurface Constructor (surf, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »PointOnSurface(Surface, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnSurface(
    Surface surf,
    Point2d point
)
Public Sub New ( _
    surf As Surface, _
    point As Point2d _
)
public:
PointOnSurface(
    Surface^ surf,
    Point2d point
)
Parameters
surf(Surface)
point(Point2d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static PointOnSurface Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As PointOnSurface
public:
static PointOnSurface^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetInverseTangentVector Method

GetInverseTangentVector Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetInverseTangentVector()()()()
Members
Icon | Member | Description
 | GetInverseTangentVector(Vector3d, Surface, Point2d) |
 | GetInverseTangentVector(Vector3d, Point2d) |
 | GetInverseTangentVector(Vector3d) |


GetInverseTangentVector Method (vector)

GetInverseTangentVector Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetInverseTangentVector(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetInverseTangentVector(
    Vector3d vector
)
Public Function GetInverseTangentVector ( _
    vector As Vector3d _
) As Vector2d
public:
Vector2d GetInverseTangentVector(
    Vector3d vector
)
Parameters
vector(Vector3d)


GetInverseTangentVector Method (vector, point)

GetInverseTangentVector Method (vector, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetInverseTangentVector(Vector3d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetInverseTangentVector(
    Vector3d vector,
    Point2d point
)
Public Function GetInverseTangentVector ( _
    vector As Vector3d, _
    point As Point2d _
) As Vector2d
public:
Vector2d GetInverseTangentVector(
    Vector3d vector,
    Point2d point
)
Parameters
vector(Vector3d)
point(Point2d)


GetInverseTangentVector Method (vector, surf, point)

GetInverseTangentVector Method (vector, surf, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetInverseTangentVector(Vector3d, Surface, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d GetInverseTangentVector(
    Vector3d vector,
    Surface surf,
    Point2d point
)
Public Shared Function GetInverseTangentVector ( _
    vector As Vector3d, _
    surf As Surface, _
    point As Point2d _
) As Vector2d
public:
static Vector2d GetInverseTangentVector(
    Vector3d vector,
    Surface^ surf,
    Point2d point
)
Parameters
vector(Vector3d)
surf(Surface)
point(Point2d)


GetMixedPartial Method

GetMixedPartial Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetMixedPartial()()()()
Members
Icon | Member | Description
 | GetMixedPartial(Surface, Point2d) |
 | GetMixedPartial(Point2d) |
 | GetMixedPartial()()()() |


GetMixedPartial Method

GetMixedPartial Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetMixedPartial()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetMixedPartial()
Public Function GetMixedPartial As Vector3d
public:
Vector3d GetMixedPartial()


GetMixedPartial Method (point)

GetMixedPartial Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetMixedPartial(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetMixedPartial(
    Point2d point
)
Public Function GetMixedPartial ( _
    point As Point2d _
) As Vector3d
public:
Vector3d GetMixedPartial(
    Point2d point
)
Parameters
point(Point2d)


GetMixedPartial Method (surf, point)

GetMixedPartial Method (surf, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetMixedPartial(Surface, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d GetMixedPartial(
    Surface surf,
    Point2d point
)
Public Shared Function GetMixedPartial ( _
    surf As Surface, _
    point As Point2d _
) As Vector3d
public:
static Vector3d GetMixedPartial(
    Surface^ surf,
    Point2d point
)
Parameters
surf(Surface)
point(Point2d)


GetNormal Method

GetNormal Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetNormal()()()()
Members
Icon | Member | Description
 | GetNormal(Surface, Point2d) |
 | GetNormal(Point2d) |
 | GetNormal()()()() |


GetNormal Method

GetNormal Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetNormal()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetNormal()
Public Function GetNormal As Vector3d
public:
Vector3d GetNormal()


GetNormal Method (point)

GetNormal Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetNormal(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetNormal(
    Point2d point
)
Public Function GetNormal ( _
    point As Point2d _
) As Vector3d
public:
Vector3d GetNormal(
    Point2d point
)
Parameters
point(Point2d)


GetNormal Method (surf, point)

GetNormal Method (surf, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetNormal(Surface, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d GetNormal(
    Surface surf,
    Point2d point
)
Public Shared Function GetNormal ( _
    surf As Surface, _
    point As Point2d _
) As Vector3d
public:
static Vector3d GetNormal(
    Surface^ surf,
    Point2d point
)
Parameters
surf(Surface)
point(Point2d)


GetPoint Method

GetPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetPoint()()()()
Members
Icon | Member | Description
 | GetPoint(Surface, Point2d) |
 | GetPoint(Point2d) |
 | GetPoint()()()() |


GetPoint Method (point)

GetPoint Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetPoint(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d GetPoint(
    Point2d point
)
Public Function GetPoint ( _
    point As Point2d _
) As Point3d
public:
Point3d GetPoint(
    Point2d point
)
Parameters
point(Point2d)


GetPoint Method (surface, point)

GetPoint Method (surface, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetPoint(Surface, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Point3d GetPoint(
    Surface surface,
    Point2d point
)
Public Shared Function GetPoint ( _
    surface As Surface, _
    point As Point2d _
) As Point3d
public:
static Point3d GetPoint(
    Surface^ surface,
    Point2d point
)
Parameters
surface(Surface)
point(Point2d)


GetTangentVector Method

GetTangentVector Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetTangentVector()()()()
Members
Icon | Member | Description
 | GetTangentVector(Vector2d, Surface, Point2d) |
 | GetTangentVector(Vector2d, Point2d) |
 | GetTangentVector(Vector2d) |


GetTangentVector Method (vector)

GetTangentVector Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetTangentVector(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetTangentVector(
    Vector2d vector
)
Public Function GetTangentVector ( _
    vector As Vector2d _
) As Vector3d
public:
Vector3d GetTangentVector(
    Vector2d vector
)
Parameters
vector(Vector2d)


GetTangentVector Method (vector, point)

GetTangentVector Method (vector, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetTangentVector(Vector2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetTangentVector(
    Vector2d vector,
    Point2d point
)
Public Function GetTangentVector ( _
    vector As Vector2d, _
    point As Point2d _
) As Vector3d
public:
Vector3d GetTangentVector(
    Vector2d vector,
    Point2d point
)
Parameters
vector(Vector2d)
point(Point2d)


GetTangentVector Method (vector, vectorSurface, pointer)

GetTangentVector Method (vector, vectorSurface, pointer)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetTangentVector(Vector2d, Surface, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d GetTangentVector(
    Vector2d vector,
    Surface vectorSurface,
    Point2d pointer
)
Public Shared Function GetTangentVector ( _
    vector As Vector2d, _
    vectorSurface As Surface, _
    pointer As Point2d _
) As Vector3d
public:
static Vector3d GetTangentVector(
    Vector2d vector,
    Surface^ vectorSurface,
    Point2d pointer
)
Parameters
vector(Vector2d)
vectorSurface(Surface)
pointer(Point2d)


GetUDerivative Method

GetUDerivative Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetUDerivative()()()()
Members
Icon | Member | Description
 | GetUDerivative(Int32, Surface, Point2d) |
 | GetUDerivative(Int32, Point2d) |
 | GetUDerivative(Int32) |


GetUDerivative Method (order)

GetUDerivative Method (order)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetUDerivative(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetUDerivative(
    int order
)
Public Function GetUDerivative ( _
    order As Integer _
) As Vector3d
public:
Vector3d GetUDerivative(
    int order
)
Parameters
order(Int32)


GetUDerivative Method (order, point)

GetUDerivative Method (order, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetUDerivative(Int32, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetUDerivative(
    int order,
    Point2d point
)
Public Function GetUDerivative ( _
    order As Integer, _
    point As Point2d _
) As Vector3d
public:
Vector3d GetUDerivative(
    int order,
    Point2d point
)
Parameters
order(Int32)
point(Point2d)


GetUDerivative Method (order, surface, point)

GetUDerivative Method (order, surface, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetUDerivative(Int32, Surface, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d GetUDerivative(
    int order,
    Surface surface,
    Point2d point
)
Public Shared Function GetUDerivative ( _
    order As Integer, _
    surface As Surface, _
    point As Point2d _
) As Vector3d
public:
static Vector3d GetUDerivative(
    int order,
    Surface^ surface,
    Point2d point
)
Parameters
order(Int32)
surface(Surface)
point(Point2d)


GetVDerivative Method

GetVDerivative Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetVDerivative()()()()
Members
Icon | Member | Description
 | GetVDerivative(Int32, Surface, Point2d) |
 | GetVDerivative(Int32, Point2d) |
 | GetVDerivative(Int32) |


GetVDerivative Method (order)

GetVDerivative Method (order)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetVDerivative(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetVDerivative(
    int order
)
Public Function GetVDerivative ( _
    order As Integer _
) As Vector3d
public:
Vector3d GetVDerivative(
    int order
)
Parameters
order(Int32)


GetVDerivative Method (order, point)

GetVDerivative Method (order, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetVDerivative(Int32, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetVDerivative(
    int order,
    Point2d point
)
Public Function GetVDerivative ( _
    order As Integer, _
    point As Point2d _
) As Vector3d
public:
Vector3d GetVDerivative(
    int order,
    Point2d point
)
Parameters
order(Int32)
point(Point2d)


GetVDerivative Method (order, surface, point)

GetVDerivative Method (order, surface, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »GetVDerivative(Int32, Surface, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d GetVDerivative(
    int order,
    Surface surface,
    Point2d point
)
Public Shared Function GetVDerivative ( _
    order As Integer, _
    surface As Surface, _
    point As Point2d _
) As Vector3d
public:
static Vector3d GetVDerivative(
    int order,
    Surface^ surface,
    Point2d point
)
Parameters
order(Int32)
surface(Surface)
point(Point2d)


Parameter Property

Parameter Property
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »Parameter
Declaration Syntax
C# Visual Basic Visual C++
public Point2d Parameter { get; set; }
Public Property Parameter As Point2d
    Get
    Set
public:
property Point2d Parameter {
    Point2d get ();
    void set (Point2d value);
}


Surface Property

Surface Property
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »Surface
Declaration Syntax
C# Visual Basic Visual C++
public Surface Surface { get; set; }
Public Property Surface As Surface
    Get
    Set
public:
property Surface^ Surface {
    Surface^ get ();
    void set (Surface^ value);
}


PolylineCurve2d Class

PolylineCurve2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePolyline2d")]
public sealed class PolylineCurve2d : SplineEntity2d
<WrapperAttribute("ZcGePolyline2d")> _
Public NotInheritable Class PolylineCurve2d _
    Inherits SplineEntity2d
[WrapperAttribute(L"ZcGePolyline2d")]
public ref class PolylineCurve2d sealed : public SplineEntity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolylineCurve2d(KnotCollection, Point2dCollection) |
 | PolylineCurve2d(Curve2d, Double) |
 | PolylineCurve2d(Point2dCollection) |
 | PolylineCurve2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Degree | (Inherited from SplineEntity2d.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndParameter | (Inherited from SplineEntity2d.)
 | EndPoint | (Inherited from SplineEntity2d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FitPointAt(Int32) |
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetContinuityAtKnot(Int32, Tolerance) | (Inherited from SplineEntity2d.)
 | GetContinuityAtKnot(Int32) | (Inherited from SplineEntity2d.)
 | GetControlPointAt(Int32) | (Inherited from SplineEntity2d.)
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetKnotAt(Int32) | (Inherited from SplineEntity2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve2d.)
 | HasFitData | (Inherited from SplineEntity2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | IsRational | (Inherited from SplineEntity2d.)
 | Knots | (Inherited from SplineEntity2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | NumberOfFitPoints |
 | NumControlPoints | (Inherited from SplineEntity2d.)
 | NumKnots | (Inherited from SplineEntity2d.)
 | Order | (Inherited from SplineEntity2d.)
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | SetControlPointAt(Int32, Point2d) | (Inherited from SplineEntity2d.)
 | SetFitPointAt(Int32, Point2d) |
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | SetKnotAt(Int32, Double) | (Inherited from SplineEntity2d.)
 | StartParameter | (Inherited from SplineEntity2d.)
 | StartPoint | (Inherited from SplineEntity2d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | SplineEntity2d
 |  |  |  |  |  | PolylineCurve2d


PolylineCurve2d Constructor

PolylineCurve2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »PolylineCurve2d()()()()
Members
Icon | Member | Description
 | PolylineCurve2d(KnotCollection, Point2dCollection) |
 | PolylineCurve2d(Curve2d, Double) |
 | PolylineCurve2d(Point2dCollection) |
 | PolylineCurve2d()()()() |


PolylineCurve2d Constructor

PolylineCurve2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »PolylineCurve2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolylineCurve2d()
Public Sub New
public:
PolylineCurve2d()


PolylineCurve2d Constructor (curve, epsilon)

PolylineCurve2d Constructor (curve, epsilon)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »PolylineCurve2d(Curve2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public PolylineCurve2d(
    Curve2d curve,
    double epsilon
)
Public Sub New ( _
    curve As Curve2d, _
    epsilon As Double _
)
public:
PolylineCurve2d(
    Curve2d^ curve,
    double epsilon
)
Parameters
curve(Curve2d)
epsilon(Double)


PolylineCurve2d Constructor (knots, controlPoints)

PolylineCurve2d Constructor (knots, controlPoints)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »PolylineCurve2d(KnotCollection, Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PolylineCurve2d(
    KnotCollection knots,
    Point2dCollection controlPoints
)
Public Sub New ( _
    knots As KnotCollection, _
    controlPoints As Point2dCollection _
)
public:
PolylineCurve2d(
    KnotCollection^ knots,
    Point2dCollection^ controlPoints
)
Parameters
knots(KnotCollection)
controlPoints(Point2dCollection)


PolylineCurve2d Constructor (points)

PolylineCurve2d Constructor (points)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »PolylineCurve2d(Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PolylineCurve2d(
    Point2dCollection points
)
Public Sub New ( _
    points As Point2dCollection _
)
public:
PolylineCurve2d(
    Point2dCollection^ points
)
Parameters
points(Point2dCollection)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static PolylineCurve2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As PolylineCurve2d
public:
static PolylineCurve2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


FitPointAt Method (i)

FitPointAt Method (i)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »FitPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d FitPointAt(
    int i
)
Public Function FitPointAt ( _
    i As Integer _
) As Point2d
public:
Point2d FitPointAt(
    int i
)
Parameters
i(Int32)


NumberOfFitPoints Property

NumberOfFitPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »NumberOfFitPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfFitPoints { get; }
Public ReadOnly Property NumberOfFitPoints As Integer
    Get
public:
property int NumberOfFitPoints {
    int get ();
}


SetFitPointAt Method (i, point)

SetFitPointAt Method (i, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »SetFitPointAt(Int32, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitPointAt(
    int i,
    Point2d point
)
Public Sub SetFitPointAt ( _
    i As Integer, _
    point As Point2d _
)
public:
void SetFitPointAt(
    int i,
    Point2d point
)
Parameters
i(Int32)
point(Point2d)


PolylineCurve3d Class

PolylineCurve3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePolyline3d")]
public class PolylineCurve3d : SplineEntity3d
<WrapperAttribute("ZcGePolyline3d")> _
Public Class PolylineCurve3d _
    Inherits SplineEntity3d
[WrapperAttribute(L"ZcGePolyline3d")]
public ref class PolylineCurve3d : public SplineEntity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolylineCurve3d(KnotCollection, Point3dCollection) |
 | PolylineCurve3d(Curve3d, Double) |
 | PolylineCurve3d(Point3dCollection) |
 | PolylineCurve3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ControlPointAt(Int32) | (Inherited from SplineEntity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Degree | (Inherited from SplineEntity3d.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndParameter | (Inherited from SplineEntity3d.)
 | EndPoint | (Inherited from SplineEntity3d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FitPointAt(Int32) |
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetContinuityAtKnot(Int32, Tolerance) | (Inherited from SplineEntity3d.)
 | GetContinuityAtKnot(Int32) | (Inherited from SplineEntity3d.)
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve3d.)
 | HasFitData | (Inherited from SplineEntity3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | IsRational | (Inherited from SplineEntity3d.)
 | KnotAt(Int32) | (Inherited from SplineEntity3d.)
 | Knots | (Inherited from SplineEntity3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | NumberOfControlPoints | (Inherited from SplineEntity3d.)
 | NumberOfFitPoints |
 | NumberOfKnots | (Inherited from SplineEntity3d.)
 | Order | (Inherited from SplineEntity3d.)
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | SetControlPointAt(Int32, Point3d) | (Inherited from SplineEntity3d.)
 | SetFitPointAt(Int32, Point3d) |
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | SetKnotAt(Int32, Double) | (Inherited from SplineEntity3d.)
 | StartParameter | (Inherited from SplineEntity3d.)
 | StartPoint | (Inherited from SplineEntity3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | SplineEntity3d
 |  |  |  |  |  | PolylineCurve3d
 |  |  |  |  |  |  | AugmentedPolylineCurve3d


PolylineCurve3d Constructor

PolylineCurve3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »PolylineCurve3d()()()()
Members
Icon | Member | Description
 | PolylineCurve3d(KnotCollection, Point3dCollection) |
 | PolylineCurve3d(Curve3d, Double) |
 | PolylineCurve3d(Point3dCollection) |
 | PolylineCurve3d()()()() |


PolylineCurve3d Constructor

PolylineCurve3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »PolylineCurve3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolylineCurve3d()
Public Sub New
public:
PolylineCurve3d()


PolylineCurve3d Constructor (curve, epsilon)

PolylineCurve3d Constructor (curve, epsilon)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »PolylineCurve3d(Curve3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public PolylineCurve3d(
    Curve3d curve,
    double epsilon
)
Public Sub New ( _
    curve As Curve3d, _
    epsilon As Double _
)
public:
PolylineCurve3d(
    Curve3d^ curve,
    double epsilon
)
Parameters
curve(Curve3d)
epsilon(Double)


PolylineCurve3d Constructor (knots, controlPoints)

PolylineCurve3d Constructor (knots, controlPoints)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »PolylineCurve3d(KnotCollection, Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PolylineCurve3d(
    KnotCollection knots,
    Point3dCollection controlPoints
)
Public Sub New ( _
    knots As KnotCollection, _
    controlPoints As Point3dCollection _
)
public:
PolylineCurve3d(
    KnotCollection^ knots,
    Point3dCollection^ controlPoints
)
Parameters
knots(KnotCollection)
controlPoints(Point3dCollection)


PolylineCurve3d Constructor (points)

PolylineCurve3d Constructor (points)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »PolylineCurve3d(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PolylineCurve3d(
    Point3dCollection points
)
Public Sub New ( _
    points As Point3dCollection _
)
public:
PolylineCurve3d(
    Point3dCollection^ points
)
Parameters
points(Point3dCollection)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static PolylineCurve3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As PolylineCurve3d
public:
static PolylineCurve3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


FitPointAt Method (i)

FitPointAt Method (i)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »FitPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d FitPointAt(
    int i
)
Public Function FitPointAt ( _
    i As Integer _
) As Point3d
public:
Point3d FitPointAt(
    int i
)
Parameters
i(Int32)


NumberOfFitPoints Property

NumberOfFitPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »NumberOfFitPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfFitPoints { get; }
Public ReadOnly Property NumberOfFitPoints As Integer
    Get
public:
property int NumberOfFitPoints {
    int get ();
}


SetFitPointAt Method (i, point)

SetFitPointAt Method (i, point)
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »SetFitPointAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetFitPointAt(
    int i,
    Point3d point
)
Public Sub SetFitPointAt ( _
    i As Integer, _
    point As Point3d _
)
public:
void SetFitPointAt(
    int i,
    Point3d point
)
Parameters
i(Int32)
point(Point3d)


Position2d Class

Position2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePosition2d")]
public sealed class Position2d : PointEntity2d
<WrapperAttribute("ZcGePosition2d")> _
Public NotInheritable Class Position2d _
    Inherits PointEntity2d
[WrapperAttribute(L"ZcGePosition2d")]
public ref class Position2d sealed : public PointEntity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Position2d(Double, Double) |
 | Position2d(Point2d) |
 | Position2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Entity2d.)
 | IsOn(Point2d) | (Inherited from Entity2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | Point | (Inherited from PointEntity2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | Set(Double, Double) |
 | Set(Point2d) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | PointEntity2d
 |  |  |  |  | Position2d


Position2d Constructor

Position2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »Position2d()()()()
Members
Icon | Member | Description
 | Position2d(Double, Double) |
 | Position2d(Point2d) |
 | Position2d()()()() |


Position2d Constructor

Position2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »Position2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Position2d()
Public Sub New
public:
Position2d()


Position2d Constructor (x, y)

Position2d Constructor (x, y)
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »Position2d(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Position2d(
    double x,
    double y
)
Public Sub New ( _
    x As Double, _
    y As Double _
)
public:
Position2d(
    double x,
    double y
)
Parameters
x(Double)
y(Double)


Position2d Constructor (point)

Position2d Constructor (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »Position2d(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Position2d(
    Point2d point
)
Public Sub New ( _
    point As Point2d _
)
public:
Position2d(
    Point2d point
)
Parameters
point(Point2d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Position2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Position2d
public:
static Position2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »Set()()()()
Members
Icon | Member | Description
 | Set(Double, Double) |
 | Set(Point2d) |


Set Method (x, y)

Set Method (x, y)
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »Set(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double x,
    double y
)
Public Sub Set ( _
    x As Double, _
    y As Double _
)
public:
void Set(
    double x,
    double y
)
Parameters
x(Double)
y(Double)


Set Method (point)

Set Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »Set(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d point
)
Public Sub Set ( _
    point As Point2d _
)
public:
void Set(
    Point2d point
)
Parameters
point(Point2d)


Position3d Class

Position3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGePosition3d")]
public sealed class Position3d : PointEntity3d
<WrapperAttribute("ZcGePosition3d")> _
Public NotInheritable Class Position3d _
    Inherits PointEntity3d
[WrapperAttribute(L"ZcGePosition3d")]
public ref class Position3d sealed : public PointEntity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Position3d(Double, Double, Double) |
 | Position3d(Point3d) |
 | Position3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetPoint()()()() | (Inherited from PointEntity3d.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Double, Double, Double) |
 | Set(Point3d) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | PointEntity3d
 |  |  |  |  | Position3d


Position3d Constructor

Position3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »Position3d()()()()
Members
Icon | Member | Description
 | Position3d(Double, Double, Double) |
 | Position3d(Point3d) |
 | Position3d()()()() |


Position3d Constructor

Position3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »Position3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Position3d()
Public Sub New
public:
Position3d()


Position3d Constructor (x, y, z)

Position3d Constructor (x, y, z)
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »Position3d(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Position3d(
    double x,
    double y,
    double z
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
Position3d(
    double x,
    double y,
    double z
)
Parameters
x(Double)
y(Double)
z(Double)


Position3d Constructor (point)

Position3d Constructor (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »Position3d(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Position3d(
    Point3d point
)
Public Sub New ( _
    point As Point3d _
)
public:
Position3d(
    Point3d point
)
Parameters
point(Point3d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Position3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Position3d
public:
static Position3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »Set()()()()
Members
Icon | Member | Description
 | Set(Double, Double, Double) |
 | Set(Point3d) |


Set Method (x, y, z)

Set Method (x, y, z)
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »Set(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double x,
    double y,
    double z
)
Public Sub Set ( _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
void Set(
    double x,
    double y,
    double z
)
Parameters
x(Double)
y(Double)
z(Double)


Set Method (point)

Set Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »Set(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d point
)
Public Sub Set ( _
    point As Point3d _
)
public:
void Set(
    Point3d point
)
Parameters
point(Point3d)


Ray2d Class

Ray2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeRay2d")]
public sealed class Ray2d : LinearEntity2d
<WrapperAttribute("ZcGeRay2d")> _
Public NotInheritable Class Ray2d _
    Inherits LinearEntity2d
[WrapperAttribute(L"ZcGeRay2d")]
public ref class Ray2d sealed : public LinearEntity2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ray2d(Point2d, Vector2d) |
 | Ray2d(Point2d, Point2d) |
 | Ray2d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Direction | (Inherited from LinearEntity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint | (Inherited from Curve2d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLine()()()() | (Inherited from LinearEntity2d.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetPerpendicularLine(Point2d) | (Inherited from LinearEntity2d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve2d.)
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IntersectWith(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsColinearTo(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IsColinearTo(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsParallelTo(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IsParallelTo(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | IsPerpendicularTo(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | IsPerpendicularTo(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | Overlap(LinearEntity2d, Tolerance) | (Inherited from LinearEntity2d.)
 | Overlap(LinearEntity2d) | (Inherited from LinearEntity2d.)
 | PointOnLine | (Inherited from LinearEntity2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | Set(Point2d, Vector2d) |
 | Set(Point2d, Point2d) |
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | StartPoint | (Inherited from Curve2d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | LinearEntity2d
 |  |  |  |  |  | Ray2d


Ray2d Constructor

Ray2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »Ray2d()()()()
Members
Icon | Member | Description
 | Ray2d(Point2d, Vector2d) |
 | Ray2d(Point2d, Point2d) |
 | Ray2d()()()() |


Ray2d Constructor

Ray2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »Ray2d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Ray2d()
Public Sub New
public:
Ray2d()


Ray2d Constructor (point1, point2)

Ray2d Constructor (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »Ray2d(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Ray2d(
    Point2d point1,
    Point2d point2
)
Public Sub New ( _
    point1 As Point2d, _
    point2 As Point2d _
)
public:
Ray2d(
    Point2d point1,
    Point2d point2
)
Parameters
point1(Point2d)
point2(Point2d)


Ray2d Constructor (point, vector)

Ray2d Constructor (point, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »Ray2d(Point2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public Ray2d(
    Point2d point,
    Vector2d vector
)
Public Sub New ( _
    point As Point2d, _
    vector As Vector2d _
)
public:
Ray2d(
    Point2d point,
    Vector2d vector
)
Parameters
point(Point2d)
vector(Vector2d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Ray2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Ray2d
public:
static Ray2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »Set()()()()
Members
Icon | Member | Description
 | Set(Point2d, Vector2d) |
 | Set(Point2d, Point2d) |


Set Method (point1, point2)

Set Method (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »Set(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d point1,
    Point2d point2
)
Public Sub Set ( _
    point1 As Point2d, _
    point2 As Point2d _
)
public:
void Set(
    Point2d point1,
    Point2d point2
)
Parameters
point1(Point2d)
point2(Point2d)


Set Method (point, vector)

Set Method (point, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »Set(Point2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point2d point,
    Vector2d vector
)
Public Sub Set ( _
    point As Point2d, _
    vector As Vector2d _
)
public:
void Set(
    Point2d point,
    Vector2d vector
)
Parameters
point(Point2d)
vector(Vector2d)


Ray3d Class

Ray3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeRay3d")]
public sealed class Ray3d : LinearEntity3d
<WrapperAttribute("ZcGeRay3d")> _
Public NotInheritable Class Ray3d _
    Inherits LinearEntity3d
[WrapperAttribute(L"ZcGeRay3d")]
public ref class Ray3d sealed : public LinearEntity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ray3d(Point3d, Vector3d) |
 | Ray3d(Point3d, Point3d) |
 | Ray3d()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Direction | (Inherited from LinearEntity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndPoint | (Inherited from Curve3d.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLine()()()() | (Inherited from LinearEntity3d.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetPerpendicularPlane(Point3d) | (Inherited from LinearEntity3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve3d.)
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.)
 | IntersectWith(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IntersectWith(PlanarEntity) | (Inherited from LinearEntity3d.)
 | IntersectWith(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsColinearTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IsColinearTo(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Plane, Tolerance) | (Inherited from LinearEntity3d.)
 | IsOn(Plane) | (Inherited from LinearEntity3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsParallelTo(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.)
 | IsParallelTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IsParallelTo(PlanarEntity) | (Inherited from LinearEntity3d.)
 | IsParallelTo(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPerpendicularTo(PlanarEntity, Tolerance) | (Inherited from LinearEntity3d.)
 | IsPerpendicularTo(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | IsPerpendicularTo(PlanarEntity) | (Inherited from LinearEntity3d.)
 | IsPerpendicularTo(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | Overlap(LinearEntity3d, Tolerance) | (Inherited from LinearEntity3d.)
 | Overlap(LinearEntity3d) | (Inherited from LinearEntity3d.)
 | PointOnLine | (Inherited from LinearEntity3d.)
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) | (Inherited from LinearEntity3d.)
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) | (Inherited from LinearEntity3d.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Point3d, Vector3d) |
 | Set(Point3d, Point3d) |
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | StartPoint | (Inherited from Curve3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | LinearEntity3d
 |  |  |  |  |  | Ray3d


Ray3d Constructor

Ray3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »Ray3d()()()()
Members
Icon | Member | Description
 | Ray3d(Point3d, Vector3d) |
 | Ray3d(Point3d, Point3d) |
 | Ray3d()()()() |


Ray3d Constructor

Ray3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »Ray3d()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Ray3d()
Public Sub New
public:
Ray3d()


Ray3d Constructor (point1, point2)

Ray3d Constructor (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »Ray3d(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Ray3d(
    Point3d point1,
    Point3d point2
)
Public Sub New ( _
    point1 As Point3d, _
    point2 As Point3d _
)
public:
Ray3d(
    Point3d point1,
    Point3d point2
)
Parameters
point1(Point3d)
point2(Point3d)


Ray3d Constructor (point, vec)

Ray3d Constructor (point, vec)
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »Ray3d(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Ray3d(
    Point3d point,
    Vector3d vec
)
Public Sub New ( _
    point As Point3d, _
    vec As Vector3d _
)
public:
Ray3d(
    Point3d point,
    Vector3d vec
)
Parameters
point(Point3d)
vec(Vector3d)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Ray3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Ray3d
public:
static Ray3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »Set()()()()
Members
Icon | Member | Description
 | Set(Point3d, Vector3d) |
 | Set(Point3d, Point3d) |


Set Method (point1, point2)

Set Method (point1, point2)
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »Set(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d point1,
    Point3d point2
)
Public Sub Set ( _
    point1 As Point3d, _
    point2 As Point3d _
)
public:
void Set(
    Point3d point1,
    Point3d point2
)
Parameters
point1(Point3d)
point2(Point3d)


Set Method (point, vector)

Set Method (point, vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »Set(Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Point3d point,
    Vector3d vector
)
Public Sub Set ( _
    point As Point3d, _
    vector As Vector3d _
)
public:
void Set(
    Point3d point,
    Vector3d vector
)
Parameters
point(Point3d)
vector(Vector3d)


Scale2d Structure

Scale2d Structure
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeScale2d")]
public struct Scale2d
<WrapperAttribute("ZcGeScale2d")> _
Public Structure Scale2d
[WrapperAttribute(L"ZcGeScale2d")]
public value class Scale2d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Scale2d(Double, Double) |
 | Scale2d(Double) |
 | Scale2d(array<Double>[]()[][]) |
 | Coordinate[([( Int32])]) |
 | Equality(Scale2d, Scale2d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | ExtractScale(Matrix2d) |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetMatrix()()()() |
 | GetType()()()() | (Inherited from Object.)
 | Inequality(Scale2d, Scale2d) |
 | Inverse()()()() |
 | IsEqualTo(Scale2d, Tolerance) |
 | IsEqualTo(Scale2d) |
 | IsProportional(Tolerance) |
 | IsProportional()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Multiply(Double, Scale2d) |
 | Multiply(Scale2d, Double) |
 | Multiply(Scale2d, Scale2d) |
 | MultiplyBy(Double) |
 | PostMultiplyBy(Scale2d) |
 | PreMultiplyBy(Scale2d) |
 | RemoveScale(Matrix2d) |
 | ToArray()()()() |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | X |
 | Y |


Scale2d Constructor

Scale2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Scale2d()()()()
Members
Icon | Member | Description
 | Scale2d(Double, Double) |
 | Scale2d(Double) |
 | Scale2d(array<Double>[]()[][]) |


Scale2d Constructor (factor)

Scale2d Constructor (factor)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Scale2d(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Scale2d(
    double factor
)
Public Sub New ( _
    factor As Double _
)
public:
Scale2d(
    double factor
)
Parameters
factor(Double)


Scale2d Constructor (x, y)

Scale2d Constructor (x, y)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Scale2d(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Scale2d(
    double x,
    double y
)
Public Sub New ( _
    x As Double, _
    y As Double _
)
public:
Scale2d(
    double x,
    double y
)
Parameters
x(Double)
y(Double)


Scale2d Constructor (xy)

Scale2d Constructor (xy)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Scale2d(array<Double>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Scale2d(
    double[] xy
)
Public Sub New ( _
    xy As Double() _
)
public:
Scale2d(
    array<double>^ xy
)
Parameters
xy(array<Double>[]()[][])


Coordinate Property (index)

Coordinate Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Coordinate[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int index
] { get; }
Public ReadOnly Default Property Coordinate ( _
    index As Integer _
) As Double
    Get
public:
property double default[int index] {
    double get (int index);
}
Parameters
index(Int32)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Equality(Scale2d, Scale2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Scale2d a,
    Scale2d b
)
Public Shared Operator = ( _
    a As Scale2d, _
    b As Scale2d _
) As Boolean
public:
static bool operator ==(
    Scale2d a,
    Scale2d b
)
Parameters
a(Scale2d)
b(Scale2d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


ExtractScale Method (mat)

ExtractScale Method (mat)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »ExtractScale(Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Scale2d ExtractScale(
    Matrix2d mat
)
Public Shared Function ExtractScale ( _
    mat As Matrix2d _
) As Scale2d
public:
static Scale2d ExtractScale(
    Matrix2d mat
)
Parameters
mat(Matrix2d)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetMatrix Method

GetMatrix Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »GetMatrix()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Matrix2d GetMatrix()
Public Function GetMatrix As Matrix2d
public:
Matrix2d GetMatrix()


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Inequality(Scale2d, Scale2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Scale2d a,
    Scale2d b
)
Public Shared Operator <> ( _
    a As Scale2d, _
    b As Scale2d _
) As Boolean
public:
static bool operator !=(
    Scale2d a,
    Scale2d b
)
Parameters
a(Scale2d)
b(Scale2d)


Inverse Method

Inverse Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Inverse()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Scale2d Inverse()
Public Function Inverse As Scale2d
public:
Scale2d Inverse()


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Scale2d, Tolerance) |
 | IsEqualTo(Scale2d) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »IsEqualTo(Scale2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Scale2d a
)
Public Function IsEqualTo ( _
    a As Scale2d _
) As Boolean
public:
bool IsEqualTo(
    Scale2d a
)
Parameters
a(Scale2d)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »IsEqualTo(Scale2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Scale2d a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As Scale2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Scale2d a,
    Tolerance tolerance
)
Parameters
a(Scale2d)
tolerance(Tolerance)


IsProportional Method

IsProportional Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »IsProportional()()()()
Members
Icon | Member | Description
 | IsProportional(Tolerance) |
 | IsProportional()()()() |


IsProportional Method

IsProportional Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »IsProportional()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsProportional()
Public Function IsProportional As Boolean
public:
bool IsProportional()


IsProportional Method (tolerance)

IsProportional Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »IsProportional(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsProportional(
    Tolerance tolerance
)
Public Function IsProportional ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsProportional(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


Multiply Method

Multiply Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Multiply()()()()
Members
Icon | Member | Description
 | Multiply(Double, Scale2d) |
 | Multiply(Scale2d, Double) |
 | Multiply(Scale2d, Scale2d) |


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Multiply(Double, Scale2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Scale2d operator *(
    double factor,
    Scale2d a
)
Public Shared Operator * ( _
    factor As Double, _
    a As Scale2d _
) As Scale2d
public:
static Scale2d operator *(
    double factor,
    Scale2d a
)
Parameters
factor(Double)
a(Scale2d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Multiply(Scale2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Scale2d operator *(
    Scale2d a,
    double factor
)
Public Shared Operator * ( _
    a As Scale2d, _
    factor As Double _
) As Scale2d
public:
static Scale2d operator *(
    Scale2d a,
    double factor
)
Parameters
a(Scale2d)
factor(Double)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Multiply(Scale2d, Scale2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Scale2d operator *(
    Scale2d a,
    Scale2d b
)
Public Shared Operator * ( _
    a As Scale2d, _
    b As Scale2d _
) As Scale2d
public:
static Scale2d operator *(
    Scale2d a,
    Scale2d b
)
Parameters
a(Scale2d)
b(Scale2d)


MultiplyBy Method (factor)

MultiplyBy Method (factor)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »MultiplyBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Scale2d MultiplyBy(
    double factor
)
Public Function MultiplyBy ( _
    factor As Double _
) As Scale2d
public:
Scale2d MultiplyBy(
    double factor
)
Parameters
factor(Double)


PostMultiplyBy Method (rightSide)

PostMultiplyBy Method (rightSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »PostMultiplyBy(Scale2d)
Declaration Syntax
C# Visual Basic Visual C++
public Scale2d PostMultiplyBy(
    Scale2d rightSide
)
Public Function PostMultiplyBy ( _
    rightSide As Scale2d _
) As Scale2d
public:
Scale2d PostMultiplyBy(
    Scale2d rightSide
)
Parameters
rightSide(Scale2d)


PreMultiplyBy Method (leftSide)

PreMultiplyBy Method (leftSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »PreMultiplyBy(Scale2d)
Declaration Syntax
C# Visual Basic Visual C++
public Scale2d PreMultiplyBy(
    Scale2d leftSide
)
Public Function PreMultiplyBy ( _
    leftSide As Scale2d _
) As Scale2d
public:
Scale2d PreMultiplyBy(
    Scale2d leftSide
)
Parameters
leftSide(Scale2d)


RemoveScale Method (mat)

RemoveScale Method (mat)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »RemoveScale(Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Scale2d RemoveScale(
    Matrix2d mat
)
Public Shared Function RemoveScale ( _
    mat As Matrix2d _
) As Scale2d
public:
static Scale2d RemoveScale(
    Matrix2d mat
)
Parameters
mat(Matrix2d)


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] ToArray()
Public Function ToArray As Double()
public:
array<double>^ ToArray()


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


X Property

X Property
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »X
Declaration Syntax
C# Visual Basic Visual C++
public double X { get; }
Public ReadOnly Property X As Double
    Get
public:
property double X {
    double get ();
}


Y Property

Y Property
Namespaces »ZwSoft.ZwCAD.Geometry »Scale2d »Y
Declaration Syntax
C# Visual Basic Visual C++
public double Y { get; }
Public ReadOnly Property Y As Double
    Get
public:
property double Y {
    double get ();
}


Scale3d Structure

Scale3d Structure
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeScale3d")]
public struct Scale3d
<WrapperAttribute("ZcGeScale3d")> _
Public Structure Scale3d
[WrapperAttribute(L"ZcGeScale3d")]
public value class Scale3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Scale3d(Double, Double, Double) |
 | Scale3d(Double) |
 | Scale3d(array<Double>[]()[][]) |
 | Coordinate[([( Int32])]) |
 | Equality(Scale3d, Scale3d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | ExtractScale(Matrix3d) |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetMatrix()()()() |
 | GetType()()()() | (Inherited from Object.)
 | Inequality(Scale3d, Scale3d) |
 | Inverse()()()() |
 | IsEqualTo(Scale3d, Tolerance) |
 | IsEqualTo(Scale3d) |
 | IsProportional(Tolerance) |
 | IsProportional()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Multiply(Double, Scale3d) |
 | Multiply(Scale3d, Double) |
 | Multiply(Scale3d, Scale3d) |
 | MultiplyBy(Double) |
 | PostMultiplyBy(Scale3d) |
 | PreMultiplyBy(Scale3d) |
 | RemoveScale(Matrix3d) |
 | ToArray()()()() |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | X |
 | Y |
 | Z |


Scale3d Constructor

Scale3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Scale3d()()()()
Members
Icon | Member | Description
 | Scale3d(Double, Double, Double) |
 | Scale3d(Double) |
 | Scale3d(array<Double>[]()[][]) |


Scale3d Constructor (factor)

Scale3d Constructor (factor)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Scale3d(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Scale3d(
    double factor
)
Public Sub New ( _
    factor As Double _
)
public:
Scale3d(
    double factor
)
Parameters
factor(Double)


Scale3d Constructor (x, y, z)

Scale3d Constructor (x, y, z)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Scale3d(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Scale3d(
    double x,
    double y,
    double z
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
Scale3d(
    double x,
    double y,
    double z
)
Parameters
x(Double)
y(Double)
z(Double)


Scale3d Constructor (xyz)

Scale3d Constructor (xyz)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Scale3d(array<Double>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Scale3d(
    double[] xyz
)
Public Sub New ( _
    xyz As Double() _
)
public:
Scale3d(
    array<double>^ xyz
)
Parameters
xyz(array<Double>[]()[][])


Coordinate Property (index)

Coordinate Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Coordinate[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int index
] { get; }
Public ReadOnly Default Property Coordinate ( _
    index As Integer _
) As Double
    Get
public:
property double default[int index] {
    double get (int index);
}
Parameters
index(Int32)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Equality(Scale3d, Scale3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Scale3d a,
    Scale3d b
)
Public Shared Operator = ( _
    a As Scale3d, _
    b As Scale3d _
) As Boolean
public:
static bool operator ==(
    Scale3d a,
    Scale3d b
)
Parameters
a(Scale3d)
b(Scale3d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


ExtractScale Method (mat)

ExtractScale Method (mat)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »ExtractScale(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Scale3d ExtractScale(
    Matrix3d mat
)
Public Shared Function ExtractScale ( _
    mat As Matrix3d _
) As Scale3d
public:
static Scale3d ExtractScale(
    Matrix3d mat
)
Parameters
mat(Matrix3d)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetMatrix Method

GetMatrix Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »GetMatrix()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d GetMatrix()
Public Function GetMatrix As Matrix3d
public:
Matrix3d GetMatrix()


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Inequality(Scale3d, Scale3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Scale3d a,
    Scale3d b
)
Public Shared Operator <> ( _
    a As Scale3d, _
    b As Scale3d _
) As Boolean
public:
static bool operator !=(
    Scale3d a,
    Scale3d b
)
Parameters
a(Scale3d)
b(Scale3d)


Inverse Method

Inverse Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Inverse()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Scale3d Inverse()
Public Function Inverse As Scale3d
public:
Scale3d Inverse()


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Scale3d, Tolerance) |
 | IsEqualTo(Scale3d) |


IsEqualTo Method (scaleVector)

IsEqualTo Method (scaleVector)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »IsEqualTo(Scale3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Scale3d scaleVector
)
Public Function IsEqualTo ( _
    scaleVector As Scale3d _
) As Boolean
public:
bool IsEqualTo(
    Scale3d scaleVector
)
Parameters
scaleVector(Scale3d)


IsEqualTo Method (scaleVector, tolerance)

IsEqualTo Method (scaleVector, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »IsEqualTo(Scale3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Scale3d scaleVector,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    scaleVector As Scale3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Scale3d scaleVector,
    Tolerance tolerance
)
Parameters
scaleVector(Scale3d)
tolerance(Tolerance)


IsProportional Method

IsProportional Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »IsProportional()()()()
Members
Icon | Member | Description
 | IsProportional(Tolerance) |
 | IsProportional()()()() |


IsProportional Method

IsProportional Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »IsProportional()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsProportional()
Public Function IsProportional As Boolean
public:
bool IsProportional()


IsProportional Method (tolerance)

IsProportional Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »IsProportional(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsProportional(
    Tolerance tolerance
)
Public Function IsProportional ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsProportional(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


Multiply Method

Multiply Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Multiply()()()()
Members
Icon | Member | Description
 | Multiply(Double, Scale3d) |
 | Multiply(Scale3d, Double) |
 | Multiply(Scale3d, Scale3d) |


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Multiply(Double, Scale3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Scale3d operator *(
    double factor,
    Scale3d a
)
Public Shared Operator * ( _
    factor As Double, _
    a As Scale3d _
) As Scale3d
public:
static Scale3d operator *(
    double factor,
    Scale3d a
)
Parameters
factor(Double)
a(Scale3d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Multiply(Scale3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Scale3d operator *(
    Scale3d a,
    double factor
)
Public Shared Operator * ( _
    a As Scale3d, _
    factor As Double _
) As Scale3d
public:
static Scale3d operator *(
    Scale3d a,
    double factor
)
Parameters
a(Scale3d)
factor(Double)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Multiply(Scale3d, Scale3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Scale3d operator *(
    Scale3d a,
    Scale3d b
)
Public Shared Operator * ( _
    a As Scale3d, _
    b As Scale3d _
) As Scale3d
public:
static Scale3d operator *(
    Scale3d a,
    Scale3d b
)
Parameters
a(Scale3d)
b(Scale3d)


MultiplyBy Method (s)

MultiplyBy Method (s)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »MultiplyBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Scale3d MultiplyBy(
    double s
)
Public Function MultiplyBy ( _
    s As Double _
) As Scale3d
public:
Scale3d MultiplyBy(
    double s
)
Parameters
s(Double)


PostMultiplyBy Method (rightSide)

PostMultiplyBy Method (rightSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »PostMultiplyBy(Scale3d)
Declaration Syntax
C# Visual Basic Visual C++
public Scale3d PostMultiplyBy(
    Scale3d rightSide
)
Public Function PostMultiplyBy ( _
    rightSide As Scale3d _
) As Scale3d
public:
Scale3d PostMultiplyBy(
    Scale3d rightSide
)
Parameters
rightSide(Scale3d)


PreMultiplyBy Method (leftSide)

PreMultiplyBy Method (leftSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »PreMultiplyBy(Scale3d)
Declaration Syntax
C# Visual Basic Visual C++
public Scale3d PreMultiplyBy(
    Scale3d leftSide
)
Public Function PreMultiplyBy ( _
    leftSide As Scale3d _
) As Scale3d
public:
Scale3d PreMultiplyBy(
    Scale3d leftSide
)
Parameters
leftSide(Scale3d)


RemoveScale Method (mat)

RemoveScale Method (mat)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »RemoveScale(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Scale3d RemoveScale(
    Matrix3d mat
)
Public Shared Function RemoveScale ( _
    mat As Matrix3d _
) As Scale3d
public:
static Scale3d RemoveScale(
    Matrix3d mat
)
Parameters
mat(Matrix3d)


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] ToArray()
Public Function ToArray As Double()
public:
array<double>^ ToArray()


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


X Property

X Property
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »X
Declaration Syntax
C# Visual Basic Visual C++
public double X { get; }
Public ReadOnly Property X As Double
    Get
public:
property double X {
    double get ();
}


Y Property

Y Property
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Y
Declaration Syntax
C# Visual Basic Visual C++
public double Y { get; }
Public ReadOnly Property Y As Double
    Get
public:
property double Y {
    double get ();
}


Z Property

Z Property
Namespaces »ZwSoft.ZwCAD.Geometry »Scale3d »Z
Declaration Syntax
C# Visual Basic Visual C++
public double Z { get; }
Public ReadOnly Property Z As Double
    Get
public:
property double Z {
    double get ();
}


Sphere Class

Sphere Class
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeSphere")]
public sealed class Sphere : Surface
<WrapperAttribute("ZcGeSphere")> _
Public NotInheritable Class Sphere _
    Inherits Surface
[WrapperAttribute(L"ZcGeSphere")]
public ref class Sphere sealed : public Surface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Sphere(Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | Sphere(Double, Point3d) |
 | Sphere()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Center |
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAnglesInU()()()() |
 | GetAnglesInV()()()() |
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |
 | IsClosed(Tolerance) |
 | IsClosed()()()() |
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsNormalReversed | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsOuterNormal |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | NorthAxis |
 | NorthPole |
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | Radius |
 | ReferenceAxis |
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | Set(Double, Point3d) |
 | SetAnglesInU(Double, Double) |
 | SetAnglesInV(Double, Double) |
 | SouthPole |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | Sphere


Sphere Constructor

Sphere Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Sphere()()()()
Members
Icon | Member | Description
 | Sphere(Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | Sphere(Double, Point3d) |
 | Sphere()()()() |


Sphere Constructor

Sphere Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Sphere()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Sphere()
Public Sub New
public:
Sphere()


Sphere Constructor (radius, center)

Sphere Constructor (radius, center)
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Sphere(Double, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Sphere(
    double radius,
    Point3d center
)
Public Sub New ( _
    radius As Double, _
    center As Point3d _
)
public:
Sphere(
    double radius,
    Point3d center
)
Parameters
radius(Double)
center(Point3d)


Sphere Constructor (radius, center, northAxis, referenceAxis, startAngleU, endAngleU, startAngleV, endAngleV)

Sphere Constructor (radius, center, northAxis, referenceAxis, startAngleU, endAngleU, startAngleV, endAngleV)
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Sphere(Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Sphere(
    double radius,
    Point3d center,
    Vector3d northAxis,
    Vector3d referenceAxis,
    double startAngleU,
    double endAngleU,
    double startAngleV,
    double endAngleV
)
Public Sub New ( _
    radius As Double, _
    center As Point3d, _
    northAxis As Vector3d, _
    referenceAxis As Vector3d, _
    startAngleU As Double, _
    endAngleU As Double, _
    startAngleV As Double, _
    endAngleV As Double _
)
public:
Sphere(
    double radius,
    Point3d center,
    Vector3d northAxis,
    Vector3d referenceAxis,
    double startAngleU,
    double endAngleU,
    double startAngleV,
    double endAngleV
)
Parameters
radius(Double)
center(Point3d)
northAxis(Vector3d)
referenceAxis(Vector3d)
startAngleU(Double)
endAngleU(Double)
startAngleV(Double)
endAngleV(Double)


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Center { get; }
Public ReadOnly Property Center As Point3d
    Get
public:
property Point3d Center {
    Point3d get ();
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Sphere Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Sphere
public:
static Sphere^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetAnglesInU Method

GetAnglesInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »GetAnglesInU()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] GetAnglesInU()
Public Function GetAnglesInU As Double()
public:
array<double>^ GetAnglesInU()


GetAnglesInV Method

GetAnglesInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »GetAnglesInV()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] GetAnglesInV()
Public Function GetAnglesInV As Double()
public:
array<double>^ GetAnglesInV()


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |


IntersectWith Method (linearEntity)

IntersectWith Method (linearEntity)
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IntersectWith(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d linearEntity
)
Public Function IntersectWith ( _
    linearEntity As LinearEntity3d _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ linearEntity
)
Parameters
linearEntity(LinearEntity3d)


IntersectWith Method (linearEntity, tolerance)

IntersectWith Method (linearEntity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IntersectWith(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d linearEntity,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    linearEntity As LinearEntity3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ linearEntity,
    Tolerance tolerance
)
Parameters
linearEntity(LinearEntity3d)
tolerance(Tolerance)


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IsClosed()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed()
Public Function IsClosed As Boolean
public:
bool IsClosed()


IsClosed Method (tolerance)

IsClosed Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IsClosed(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed(
    Tolerance tolerance
)
Public Function IsClosed ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsClosed(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsOuterNormal Property

IsOuterNormal Property
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IsOuterNormal
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOuterNormal { get; }
Public ReadOnly Property IsOuterNormal As Boolean
    Get
public:
property bool IsOuterNormal {
    bool get ();
}


NorthAxis Property

NorthAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »NorthAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d NorthAxis { get; }
Public ReadOnly Property NorthAxis As Vector3d
    Get
public:
property Vector3d NorthAxis {
    Vector3d get ();
}


NorthPole Property

NorthPole Property
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »NorthPole
Declaration Syntax
C# Visual Basic Visual C++
public Point3d NorthPole { get; }
Public ReadOnly Property NorthPole As Point3d
    Get
public:
property Point3d NorthPole {
    Point3d get ();
}


Radius Property

Radius Property
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Radius
Declaration Syntax
C# Visual Basic Visual C++
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set
public:
property double Radius {
    double get ();
    void set (double value);
}


ReferenceAxis Property

ReferenceAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »ReferenceAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d ReferenceAxis { get; }
Public ReadOnly Property ReferenceAxis As Vector3d
    Get
public:
property Vector3d ReferenceAxis {
    Vector3d get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Set()()()()
Members
Icon | Member | Description
 | Set(Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | Set(Double, Point3d) |


Set Method (radius, center)

Set Method (radius, center)
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Set(Double, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double radius,
    Point3d center
)
Public Sub Set ( _
    radius As Double, _
    center As Point3d _
)
public:
void Set(
    double radius,
    Point3d center
)
Parameters
radius(Double)
center(Point3d)


Set Method (radius, center, northAxis, referenceAxis, startAngleU, endAngleU, startAngleV, endAngleV)

Set Method (radius, center, northAxis, referenceAxis, startAngleU, endAngleU, startAngleV, endAngleV)
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Set(Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double radius,
    Point3d center,
    Vector3d northAxis,
    Vector3d referenceAxis,
    double startAngleU,
    double endAngleU,
    double startAngleV,
    double endAngleV
)
Public Sub Set ( _
    radius As Double, _
    center As Point3d, _
    northAxis As Vector3d, _
    referenceAxis As Vector3d, _
    startAngleU As Double, _
    endAngleU As Double, _
    startAngleV As Double, _
    endAngleV As Double _
)
public:
void Set(
    double radius,
    Point3d center,
    Vector3d northAxis,
    Vector3d referenceAxis,
    double startAngleU,
    double endAngleU,
    double startAngleV,
    double endAngleV
)
Parameters
radius(Double)
center(Point3d)
northAxis(Vector3d)
referenceAxis(Vector3d)
startAngleU(Double)
endAngleU(Double)
startAngleV(Double)
endAngleV(Double)


SetAnglesInU Method (startAngle, endAngle)

SetAnglesInU Method (startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »SetAnglesInU(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAnglesInU(
    double startAngle,
    double endAngle
)
Public Sub SetAnglesInU ( _
    startAngle As Double, _
    endAngle As Double _
)
public:
void SetAnglesInU(
    double startAngle,
    double endAngle
)
Parameters
startAngle(Double)
endAngle(Double)


SetAnglesInV Method (startAngle, endAngle)

SetAnglesInV Method (startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »SetAnglesInV(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAnglesInV(
    double startAngle,
    double endAngle
)
Public Sub SetAnglesInV ( _
    startAngle As Double, _
    endAngle As Double _
)
public:
void SetAnglesInV(
    double startAngle,
    double endAngle
)
Parameters
startAngle(Double)
endAngle(Double)


SouthPole Property

SouthPole Property
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »SouthPole
Declaration Syntax
C# Visual Basic Visual C++
public Point3d SouthPole { get; }
Public ReadOnly Property SouthPole As Point3d
    Get
public:
property Point3d SouthPole {
    Point3d get ();
}


SplineEntity2d Class

SplineEntity2d Class
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeSplineEnt2d")]
public abstract class SplineEntity2d : Curve2d
<WrapperAttribute("ZcGeSplineEnt2d")> _
Public MustInherit Class SplineEntity2d _
    Inherits Curve2d
[WrapperAttribute(L"ZcGeSplineEnt2d")]
public ref class SplineEntity2d abstract : public Curve2d
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve2d.)
 | Clone()()()() | (Inherited from Entity2d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Degree |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity2d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndParameter |
 | EndPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve2d.)
 | Explode(Interval) | (Inherited from Curve2d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetArea(Double, Double) | (Inherited from Curve2d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetClosestPointTo(Point2d) | (Inherited from Curve2d.)
 | GetClosestPointTo(Curve2d) | (Inherited from Curve2d.)
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |
 | GetControlPointAt(Int32) |
 | GetDistanceTo(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d, Tolerance) | (Inherited from Curve2d.)
 | GetDistanceTo(Point2d) | (Inherited from Curve2d.)
 | GetDistanceTo(Curve2d) | (Inherited from Curve2d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve2d.)
 | GetKnotAt(Int32) |
 | GetLength(Double, Double, Tolerance) | (Inherited from Curve2d.)
 | GetLength(Double, Double) | (Inherited from Curve2d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetNormalPoint(Point2d) | (Inherited from Curve2d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) | (Inherited from Curve2d.)
 | GetParameterAtLength(Double, Double, Boolean) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d, Tolerance) | (Inherited from Curve2d.)
 | GetParameterOf(Point2d) | (Inherited from Curve2d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve2d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve2d.)
 | GetSamplePoints(Int32) | (Inherited from Curve2d.)
 | GetSplitCurves(Double) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve2d.)
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) | (Inherited from Curve2d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve2d.)
 | HasFitData |
 | HasStartPoint | (Inherited from Curve2d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve2d.)
 | IsClosed()()()() | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%, Tolerance) | (Inherited from Curve2d.)
 | IsDegenerate(Entity2d%) | (Inherited from Curve2d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity2d, Tolerance) | (Inherited from Entity2d.)
 | IsEqualTo(Entity2d) | (Inherited from Entity2d.)
 | IsLinear(Line2d%, Tolerance) | (Inherited from Curve2d.)
 | IsLinear(Line2d%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Point2d, Double%) | (Inherited from Curve2d.)
 | IsOn(Point2d, Tolerance) | (Inherited from Curve2d.)
 | IsOn(Double) | (Inherited from Curve2d.)
 | IsOn(Point2d) | (Inherited from Curve2d.)
 | IsPeriodic(Double%) | (Inherited from Curve2d.)
 | IsRational |
 | Knots |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Line2d) | (Inherited from Entity2d.)
 | NumControlPoints |
 | NumKnots |
 | Order |
 | OrthoBoundBlock | (Inherited from Curve2d.)
 | RotateBy(Double, Point2d) | (Inherited from Entity2d.)
 | ScaleBy(Double, Point2d) | (Inherited from Entity2d.)
 | SetControlPointAt(Int32, Point2d) |
 | SetInterval(Interval) | (Inherited from Curve2d.)
 | SetKnotAt(Int32, Double) |
 | StartParameter |
 | StartPoint |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix2d) | (Inherited from Entity2d.)
 | TranslateBy(Vector2d) | (Inherited from Entity2d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity2d
 |  |  |  | Curve2d
 |  |  |  |  | SplineEntity2d
 |  |  |  |  |  | CubicSplineCurve2d
 |  |  |  |  |  | NurbCurve2d
 |  |  |  |  |  | PolylineCurve2d


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static SplineEntity2d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As SplineEntity2d
public:
static SplineEntity2d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Degree Property

Degree Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »Degree
Declaration Syntax
C# Visual Basic Visual C++
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}


EndParameter Property

EndParameter Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »EndParameter
Declaration Syntax
C# Visual Basic Visual C++
public double EndParameter { get; }
Public ReadOnly Property EndParameter As Double
    Get
public:
property double EndParameter {
    double get ();
}


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d EndPoint { get; }
Public ReadOnly Property EndPoint As Point2d
    Get
public:
property Point2d EndPoint {
    Point2d get ();
}


GetContinuityAtKnot Method

GetContinuityAtKnot Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetContinuityAtKnot()()()()
Members
Icon | Member | Description
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |


GetContinuityAtKnot Method (index)

GetContinuityAtKnot Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetContinuityAtKnot(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int GetContinuityAtKnot(
    int index
)
Public Function GetContinuityAtKnot ( _
    index As Integer _
) As Integer
public:
int GetContinuityAtKnot(
    int index
)
Parameters
index(Int32)


GetContinuityAtKnot Method (index, tolerance)

GetContinuityAtKnot Method (index, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetContinuityAtKnot(Int32, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public int GetContinuityAtKnot(
    int index,
    Tolerance tolerance
)
Public Function GetContinuityAtKnot ( _
    index As Integer, _
    tolerance As Tolerance _
) As Integer
public:
int GetContinuityAtKnot(
    int index,
    Tolerance tolerance
)
Parameters
index(Int32)
tolerance(Tolerance)


GetControlPointAt Method (index)

GetControlPointAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetControlPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetControlPointAt(
    int index
)
Public Function GetControlPointAt ( _
    index As Integer _
) As Point2d
public:
Point2d GetControlPointAt(
    int index
)
Parameters
index(Int32)


GetKnotAt Method (index)

GetKnotAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetKnotAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double GetKnotAt(
    int index
)
Public Function GetKnotAt ( _
    index As Integer _
) As Double
public:
double GetKnotAt(
    int index
)
Parameters
index(Int32)


HasFitData Property

HasFitData Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »HasFitData
Declaration Syntax
C# Visual Basic Visual C++
public bool HasFitData { get; }
Public ReadOnly Property HasFitData As Boolean
    Get
public:
property bool HasFitData {
    bool get ();
}


IsRational Property

IsRational Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »IsRational
Declaration Syntax
C# Visual Basic Visual C++
public bool IsRational { get; }
Public ReadOnly Property IsRational As Boolean
    Get
public:
property bool IsRational {
    bool get ();
}


Knots Property

Knots Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »Knots
Declaration Syntax
C# Visual Basic Visual C++
public KnotCollection Knots { get; }
Public ReadOnly Property Knots As KnotCollection
    Get
public:
property KnotCollection^ Knots {
    KnotCollection^ get ();
}


NumControlPoints Property

NumControlPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »NumControlPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumControlPoints { get; }
Public ReadOnly Property NumControlPoints As Integer
    Get
public:
property int NumControlPoints {
    int get ();
}


NumKnots Property

NumKnots Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »NumKnots
Declaration Syntax
C# Visual Basic Visual C++
public int NumKnots { get; }
Public ReadOnly Property NumKnots As Integer
    Get
public:
property int NumKnots {
    int get ();
}


Order Property

Order Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »Order
Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
public:
property int Order {
    int get ();
}


SetControlPointAt Method (index, point)

SetControlPointAt Method (index, point)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »SetControlPointAt(Int32, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetControlPointAt(
    int index,
    Point2d point
)
Public Sub SetControlPointAt ( _
    index As Integer, _
    point As Point2d _
)
public:
void SetControlPointAt(
    int index,
    Point2d point
)
Parameters
index(Int32)
point(Point2d)


SetKnotAt Method (index, value)

SetKnotAt Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »SetKnotAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetKnotAt(
    int index,
    double value
)
Public Sub SetKnotAt ( _
    index As Integer, _
    value As Double _
)
public:
void SetKnotAt(
    int index,
    double value
)
Parameters
index(Int32)
value(Double)


StartParameter Property

StartParameter Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »StartParameter
Declaration Syntax
C# Visual Basic Visual C++
public double StartParameter { get; }
Public ReadOnly Property StartParameter As Double
    Get
public:
property double StartParameter {
    double get ();
}


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point2d StartPoint { get; }
Public ReadOnly Property StartPoint As Point2d
    Get
public:
property Point2d StartPoint {
    Point2d get ();
}


SplineEntity3d Class

SplineEntity3d Class
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeSplineEnt3d")]
public abstract class SplineEntity3d : Curve3d
<WrapperAttribute("ZcGeSplineEnt3d")> _
Public MustInherit Class SplineEntity3d _
    Inherits Curve3d
[WrapperAttribute(L"ZcGeSplineEnt3d")]
public ref class SplineEntity3d abstract : public Curve3d
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BoundBlock | (Inherited from Curve3d.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ControlPointAt(Int32) |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Degree |
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndParameter |
 | EndPoint |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Double) | (Inherited from Curve3d.)
 | Explode(Interval) | (Inherited from Curve3d.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetArea(Double, Double, Tolerance) | (Inherited from Curve3d.)
 | GetArea(Double, Double) | (Inherited from Curve3d.)
 | GetBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetClosestPointTo(Point3d) | (Inherited from Curve3d.)
 | GetClosestPointTo(Curve3d) | (Inherited from Curve3d.)
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |
 | GetDistanceTo(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d, Tolerance) | (Inherited from Curve3d.)
 | GetDistanceTo(Point3d) | (Inherited from Curve3d.)
 | GetDistanceTo(Curve3d) | (Inherited from Curve3d.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetInterval()()()() | (Inherited from Curve3d.)
 | GetLength(Double, Double, Double) | (Inherited from Curve3d.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNormalPoint(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetNormalPoint(Point3d) | (Inherited from Curve3d.)
 | GetOrthoBoundBlockOf(Interval) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane, Tolerance) | (Inherited from Curve3d.)
 | GetOrthoProjectEntity(Plane) | (Inherited from Curve3d.)
 | GetParameterAtLength(Double, Double, Boolean, Double) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d, Tolerance) | (Inherited from Curve3d.)
 | GetParameterOf(Point3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Point3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedClosestPointTo(Curve3d, Vector3d) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d, Tolerance) | (Inherited from Curve3d.)
 | GetProjectedEntity(Plane, Vector3d) | (Inherited from Curve3d.)
 | GetReverseParameterCurve()()()() | (Inherited from Curve3d.)
 | GetSamplePoints(Double, Double, Double) | (Inherited from Curve3d.)
 | GetSamplePoints(Int32) | (Inherited from Curve3d.)
 | GetSplitCurves(Double) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) | (Inherited from Curve3d.)
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) | (Inherited from Curve3d.)
 | GetType()()()() | (Inherited from Object.)
 | HasEndPoint | (Inherited from Curve3d.)
 | HasFitData |
 | HasStartPoint | (Inherited from Curve3d.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosed(Tolerance) | (Inherited from Curve3d.)
 | IsClosed()()()() | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsCoplanarWith(Curve3d, Plane%) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%, Tolerance) | (Inherited from Curve3d.)
 | IsDegenerate(Entity3d%) | (Inherited from Curve3d.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsLinear(Line3d%, Tolerance) | (Inherited from Curve3d.)
 | IsLinear(Line3d%) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Double, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Curve3d.)
 | IsOn(Point3d, Double%) | (Inherited from Curve3d.)
 | IsOn(Double) | (Inherited from Curve3d.)
 | IsOn(Point3d) | (Inherited from Curve3d.)
 | IsPeriodic(Double%) | (Inherited from Curve3d.)
 | IsPlanar(Plane%, Tolerance) | (Inherited from Curve3d.)
 | IsPlanar(Plane%) | (Inherited from Curve3d.)
 | IsRational |
 | KnotAt(Int32) |
 | Knots |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | NumberOfControlPoints |
 | NumberOfKnots |
 | Order |
 | OrthoBoundBlock | (Inherited from Curve3d.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | SetControlPointAt(Int32, Point3d) |
 | SetInterval(Interval) | (Inherited from Curve3d.)
 | SetKnotAt(Int32, Double) |
 | StartParameter |
 | StartPoint |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Curve3d
 |  |  |  |  | SplineEntity3d
 |  |  |  |  |  | CubicSplineCurve3d
 |  |  |  |  |  | NurbCurve3d
 |  |  |  |  |  | PolylineCurve3d


ControlPointAt Method (i)

ControlPointAt Method (i)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »ControlPointAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ControlPointAt(
    int i
)
Public Function ControlPointAt ( _
    i As Integer _
) As Point3d
public:
Point3d ControlPointAt(
    int i
)
Parameters
i(Int32)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static SplineEntity3d Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As SplineEntity3d
public:
static SplineEntity3d^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Degree Property

Degree Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »Degree
Declaration Syntax
C# Visual Basic Visual C++
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}


EndParameter Property

EndParameter Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »EndParameter
Declaration Syntax
C# Visual Basic Visual C++
public double EndParameter { get; }
Public ReadOnly Property EndParameter As Double
    Get
public:
property double EndParameter {
    double get ();
}


EndPoint Property

EndPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »EndPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d EndPoint { get; }
Public ReadOnly Property EndPoint As Point3d
    Get
public:
property Point3d EndPoint {
    Point3d get ();
}


GetContinuityAtKnot Method

GetContinuityAtKnot Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetContinuityAtKnot()()()()
Members
Icon | Member | Description
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |


GetContinuityAtKnot Method (i)

GetContinuityAtKnot Method (i)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetContinuityAtKnot(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int GetContinuityAtKnot(
    int i
)
Public Function GetContinuityAtKnot ( _
    i As Integer _
) As Integer
public:
int GetContinuityAtKnot(
    int i
)
Parameters
i(Int32)


GetContinuityAtKnot Method (i, tolerance)

GetContinuityAtKnot Method (i, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetContinuityAtKnot(Int32, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public int GetContinuityAtKnot(
    int i,
    Tolerance tolerance
)
Public Function GetContinuityAtKnot ( _
    i As Integer, _
    tolerance As Tolerance _
) As Integer
public:
int GetContinuityAtKnot(
    int i,
    Tolerance tolerance
)
Parameters
i(Int32)
tolerance(Tolerance)


HasFitData Property

HasFitData Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »HasFitData
Declaration Syntax
C# Visual Basic Visual C++
public bool HasFitData { get; }
Public ReadOnly Property HasFitData As Boolean
    Get
public:
property bool HasFitData {
    bool get ();
}


IsRational Property

IsRational Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »IsRational
Declaration Syntax
C# Visual Basic Visual C++
public bool IsRational { get; }
Public ReadOnly Property IsRational As Boolean
    Get
public:
property bool IsRational {
    bool get ();
}


KnotAt Method (i)

KnotAt Method (i)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »KnotAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public double KnotAt(
    int i
)
Public Function KnotAt ( _
    i As Integer _
) As Double
public:
double KnotAt(
    int i
)
Parameters
i(Int32)


Knots Property

Knots Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »Knots
Declaration Syntax
C# Visual Basic Visual C++
public KnotCollection Knots { get; }
Public ReadOnly Property Knots As KnotCollection
    Get
public:
property KnotCollection^ Knots {
    KnotCollection^ get ();
}


NumberOfControlPoints Property

NumberOfControlPoints Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »NumberOfControlPoints
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfControlPoints { get; }
Public ReadOnly Property NumberOfControlPoints As Integer
    Get
public:
property int NumberOfControlPoints {
    int get ();
}


NumberOfKnots Property

NumberOfKnots Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »NumberOfKnots
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfKnots { get; }
Public ReadOnly Property NumberOfKnots As Integer
    Get
public:
property int NumberOfKnots {
    int get ();
}


Order Property

Order Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »Order
Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
public:
property int Order {
    int get ();
}


SetControlPointAt Method (i, point)

SetControlPointAt Method (i, point)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »SetControlPointAt(Int32, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void SetControlPointAt(
    int i,
    Point3d point
)
Public Sub SetControlPointAt ( _
    i As Integer, _
    point As Point3d _
)
public:
void SetControlPointAt(
    int i,
    Point3d point
)
Parameters
i(Int32)
point(Point3d)


SetKnotAt Method (i, value)

SetKnotAt Method (i, value)
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »SetKnotAt(Int32, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetKnotAt(
    int i,
    double value
)
Public Sub SetKnotAt ( _
    i As Integer, _
    value As Double _
)
public:
void SetKnotAt(
    int i,
    double value
)
Parameters
i(Int32)
value(Double)


StartParameter Property

StartParameter Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »StartParameter
Declaration Syntax
C# Visual Basic Visual C++
public double StartParameter { get; }
Public ReadOnly Property StartParameter As Double
    Get
public:
property double StartParameter {
    double get ();
}


StartPoint Property

StartPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »StartPoint
Declaration Syntax
C# Visual Basic Visual C++
public Point3d StartPoint { get; }
Public ReadOnly Property StartPoint As Point3d
    Get
public:
property Point3d StartPoint {
    Point3d get ();
}


Surface Class

Surface Class
Namespaces »ZwSoft.ZwCAD.Geometry »Surface
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeSurface")]
public abstract class Surface : Entity3d
<WrapperAttribute("ZcGeSurface")> _
Public MustInherit Class Surface _
    Inherits Entity3d
[WrapperAttribute(L"ZcGeSurface")]
public ref class Surface abstract : public Entity3d
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetEnvelope()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsNormalReversed |
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |
 | ReverseNormal |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | Cone
 |  |  |  |  | Cylinder
 |  |  |  |  | ExternalBoundedSurface
 |  |  |  |  | ExternalSurface
 |  |  |  |  | NurbSurface
 |  |  |  |  | OffsetSurface
 |  |  |  |  | PlanarEntity
 |  |  |  |  | Sphere
 |  |  |  |  | Torus


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


ClosestPointTo Method (point)

ClosestPointTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »ClosestPointTo(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ClosestPointTo(
    Point3d point
)
Public Function ClosestPointTo ( _
    point As Point3d _
) As Point3d
public:
Point3d ClosestPointTo(
    Point3d point
)
Parameters
point(Point3d)


ClosestPointTo Method (point, tolerance)

ClosestPointTo Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »ClosestPointTo(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d ClosestPointTo(
    Point3d point,
    Tolerance tolerance
)
Public Function ClosestPointTo ( _
    point As Point3d, _
    tolerance As Tolerance _
) As Point3d
public:
Point3d ClosestPointTo(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Surface Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Surface
public:
static Surface^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


DistanceTo Method (point)

DistanceTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »DistanceTo(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public double DistanceTo(
    Point3d point
)
Public Function DistanceTo ( _
    point As Point3d _
) As Double
public:
double DistanceTo(
    Point3d point
)
Parameters
point(Point3d)


DistanceTo Method (point, tolerance)

DistanceTo Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »DistanceTo(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public double DistanceTo(
    Point3d point,
    Tolerance tolerance
)
Public Function DistanceTo ( _
    point As Point3d, _
    tolerance As Tolerance _
) As Double
public:
double DistanceTo(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


EvaluatePoint Method (parameter)

EvaluatePoint Method (parameter)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »EvaluatePoint(Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d EvaluatePoint(
    Point2d parameter
)
Public Function EvaluatePoint ( _
    parameter As Point2d _
) As Point3d
public:
Point3d EvaluatePoint(
    Point2d parameter
)
Parameters
parameter(Point2d)


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


GetClosestPointTo Method (point)

GetClosestPointTo Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »GetClosestPointTo(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnSurface GetClosestPointTo(
    Point3d point
)
Public Function GetClosestPointTo ( _
    point As Point3d _
) As PointOnSurface
public:
PointOnSurface^ GetClosestPointTo(
    Point3d point
)
Parameters
point(Point3d)


GetClosestPointTo Method (point, tolerance)

GetClosestPointTo Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »GetClosestPointTo(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public PointOnSurface GetClosestPointTo(
    Point3d point,
    Tolerance tolerance
)
Public Function GetClosestPointTo ( _
    point As Point3d, _
    tolerance As Tolerance _
) As PointOnSurface
public:
PointOnSurface^ GetClosestPointTo(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


GetEnvelope Method

GetEnvelope Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »GetEnvelope()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Interval[] GetEnvelope()
Public Function GetEnvelope As Interval()
public:
array<Interval^>^ GetEnvelope()


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsClosedInU()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosedInU()
Public Function IsClosedInU As Boolean
public:
bool IsClosedInU()


IsClosedInU Method (tolerance)

IsClosedInU Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsClosedInU(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosedInU(
    Tolerance tolerance
)
Public Function IsClosedInU ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsClosedInU(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsClosedInV()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosedInV()
Public Function IsClosedInV As Boolean
public:
bool IsClosedInV()


IsClosedInV Method (tolerance)

IsClosedInV Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsClosedInV(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosedInV(
    Tolerance tolerance
)
Public Function IsClosedInV ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsClosedInV(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsNormalReversed Property

IsNormalReversed Property
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsNormalReversed
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNormalReversed { get; }
Public ReadOnly Property IsNormalReversed As Boolean
    Get
public:
property bool IsNormalReversed {
    bool get ();
}


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


IsOn Method (point, parameterPoint)

IsOn Method (point, parameterPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsOn(Point3d, Point2d%)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point3d point,
    out Point2d parameterPoint
)
Public Function IsOn ( _
    point As Point3d, _
    <OutAttribute> ByRef parameterPoint As Point2d _
) As Boolean
public:
bool IsOn(
    Point3d point,
    [OutAttribute] Point2d% parameterPoint
)
Parameters
point(Point3d)
parameterPoint(Point2d %)


IsOn Method (point, parameterPoint, tolerance)

IsOn Method (point, parameterPoint, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsOn(Point3d, Point2d%, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOn(
    Point3d point,
    out Point2d parameterPoint,
    Tolerance tolerance
)
Public Function IsOn ( _
    point As Point3d, _
    <OutAttribute> ByRef parameterPoint As Point2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsOn(
    Point3d point,
    [OutAttribute] Point2d% parameterPoint,
    Tolerance tolerance
)
Parameters
point(Point3d)
parameterPoint(Point2d %)
tolerance(Tolerance)


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


ParameterOf Method (point)

ParameterOf Method (point)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »ParameterOf(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d ParameterOf(
    Point3d point
)
Public Function ParameterOf ( _
    point As Point3d _
) As Point2d
public:
Point2d ParameterOf(
    Point3d point
)
Parameters
point(Point3d)


ParameterOf Method (point, tolerance)

ParameterOf Method (point, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »ParameterOf(Point3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d ParameterOf(
    Point3d point,
    Tolerance tolerance
)
Public Function ParameterOf ( _
    point As Point3d, _
    tolerance As Tolerance _
) As Point2d
public:
Point2d ParameterOf(
    Point3d point,
    Tolerance tolerance
)
Parameters
point(Point3d)
tolerance(Tolerance)


ReverseNormal Property

ReverseNormal Property
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »ReverseNormal
Declaration Syntax
C# Visual Basic Visual C++
public Surface ReverseNormal { get; }
Public ReadOnly Property ReverseNormal As Surface
    Get
public:
property Surface^ ReverseNormal {
    Surface^ get ();
}


SurfaceSurfaceIntersector Class

SurfaceSurfaceIntersector Class
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ODGeSurfSurfInt")]
public class SurfaceSurfaceIntersector : Entity3d
<WrapperAttribute("ODGeSurfSurfInt")> _
Public Class SurfaceSurfaceIntersector _
    Inherits Entity3d
[WrapperAttribute(L"ODGeSurfSurfInt")]
public ref class SurfaceSurfaceIntersector : public Entity3d
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SurfaceSurfaceIntersector(Surface, Surface) |
 | SurfaceSurfaceIntersector()()()() |
 | SurfaceSurfaceIntersector(Surface, Surface, Tolerance) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from Entity3d.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetDimension(Int32) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetIntersectionConfigurations(Int32) |
 | GetIntersectPointParameters(Int32) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType(Int32) |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectCurve(Int32, Boolean) |
 | IntersectParameterCurve(Int32, Boolean, Boolean) |
 | IntersectPoint(Int32) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Plane) | (Inherited from Entity3d.)
 | NumResults |
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Surface, Surface, Tolerance) |
 | Set(Surface, Surface) |
 | Surface1 |
 | Surface2 |
 | Tolerance |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | SurfaceSurfaceIntersector


SurfaceSurfaceIntersector Constructor

SurfaceSurfaceIntersector Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »SurfaceSurfaceIntersector()()()()
Members
Icon | Member | Description
 | SurfaceSurfaceIntersector(Surface, Surface) |
 | SurfaceSurfaceIntersector()()()() |
 | SurfaceSurfaceIntersector(Surface, Surface, Tolerance) |


SurfaceSurfaceIntersector Constructor

SurfaceSurfaceIntersector Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »SurfaceSurfaceIntersector()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSurfaceIntersector()
Public Sub New
public:
SurfaceSurfaceIntersector()


SurfaceSurfaceIntersector Constructor (surface2, surface1)

SurfaceSurfaceIntersector Constructor (surface2, surface1)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »SurfaceSurfaceIntersector(Surface, Surface)
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSurfaceIntersector(
    Surface surface2,
    Surface surface1
)
Public Sub New ( _
    surface2 As Surface, _
    surface1 As Surface _
)
public:
SurfaceSurfaceIntersector(
    Surface^ surface2,
    Surface^ surface1
)
Parameters
surface2(Surface)
surface1(Surface)


SurfaceSurfaceIntersector Constructor (surface2, surface1, tolerance)

SurfaceSurfaceIntersector Constructor (surface2, surface1, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »SurfaceSurfaceIntersector(Surface, Surface, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSurfaceIntersector(
    Surface surface2,
    Surface surface1,
    Tolerance tolerance
)
Public Sub New ( _
    surface2 As Surface, _
    surface1 As Surface, _
    tolerance As Tolerance _
)
public:
SurfaceSurfaceIntersector(
    Surface^ surface2,
    Surface^ surface1,
    Tolerance tolerance
)
Parameters
surface2(Surface)
surface1(Surface)
tolerance(Tolerance)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static SurfaceSurfaceIntersector Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As SurfaceSurfaceIntersector
public:
static SurfaceSurfaceIntersector^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetDimension Method (number)

GetDimension Method (number)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »GetDimension(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int GetDimension(
    int number
)
Public Function GetDimension ( _
    number As Integer _
) As Integer
public:
int GetDimension(
    int number
)
Parameters
number(Int32)


GetIntersectionConfigurations Method (number)

GetIntersectionConfigurations Method (number)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »GetIntersectionConfigurations(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSurfaceIntersectorConfigurations GetIntersectionConfigurations(
    int number
)
Public Function GetIntersectionConfigurations ( _
    number As Integer _
) As SurfaceSurfaceIntersectorConfigurations
public:
SurfaceSurfaceIntersectorConfigurations GetIntersectionConfigurations(
    int number
)
Parameters
number(Int32)


GetIntersectPointParameters Method (number)

GetIntersectPointParameters Method (number)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »GetIntersectPointParameters(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d[] GetIntersectPointParameters(
    int number
)
Public Function GetIntersectPointParameters ( _
    number As Integer _
) As Point2d()
public:
array<Point2d>^ GetIntersectPointParameters(
    int number
)
Parameters
number(Int32)


GetType Method (number)

GetType Method (number)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »GetType(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSurfaceIntersectorType GetType(
    int number
)
Public Function GetType ( _
    number As Integer _
) As SurfaceSurfaceIntersectorType
public:
SurfaceSurfaceIntersectorType GetType(
    int number
)
Parameters
number(Int32)


IntersectCurve Method (number, isExternal)

IntersectCurve Method (number, isExternal)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »IntersectCurve(Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Curve3d IntersectCurve(
    int number,
    bool isExternal
)
Public Function IntersectCurve ( _
    number As Integer, _
    isExternal As Boolean _
) As Curve3d
public:
Curve3d^ IntersectCurve(
    int number,
    bool isExternal
)
Parameters
number(Int32)
isExternal(Boolean)


IntersectParameterCurve Method (number, isExternal, isFirst)

IntersectParameterCurve Method (number, isExternal, isFirst)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »IntersectParameterCurve(Int32, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Curve2d IntersectParameterCurve(
    int number,
    bool isExternal,
    bool isFirst
)
Public Function IntersectParameterCurve ( _
    number As Integer, _
    isExternal As Boolean, _
    isFirst As Boolean _
) As Curve2d
public:
Curve2d^ IntersectParameterCurve(
    int number,
    bool isExternal,
    bool isFirst
)
Parameters
number(Int32)
isExternal(Boolean)
isFirst(Boolean)


IntersectPoint Method (number)

IntersectPoint Method (number)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »IntersectPoint(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d IntersectPoint(
    int number
)
Public Function IntersectPoint ( _
    number As Integer _
) As Point3d
public:
Point3d IntersectPoint(
    int number
)
Parameters
number(Int32)


NumResults Property

NumResults Property
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »NumResults
Declaration Syntax
C# Visual Basic Visual C++
public int NumResults { get; }
Public ReadOnly Property NumResults As Integer
    Get
public:
property int NumResults {
    int get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »Set()()()()
Members
Icon | Member | Description
 | Set(Surface, Surface, Tolerance) |
 | Set(Surface, Surface) |


Set Method (surface1, surface2)

Set Method (surface1, surface2)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »Set(Surface, Surface)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Surface surface1,
    Surface surface2
)
Public Sub Set ( _
    surface1 As Surface, _
    surface2 As Surface _
)
public:
void Set(
    Surface^ surface1,
    Surface^ surface2
)
Parameters
surface1(Surface)
surface2(Surface)


Set Method (surface1, surface2, tolerance)

Set Method (surface1, surface2, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »Set(Surface, Surface, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    Surface surface1,
    Surface surface2,
    Tolerance tolerance
)
Public Sub Set ( _
    surface1 As Surface, _
    surface2 As Surface, _
    tolerance As Tolerance _
)
public:
void Set(
    Surface^ surface1,
    Surface^ surface2,
    Tolerance tolerance
)
Parameters
surface1(Surface)
surface2(Surface)
tolerance(Tolerance)


Surface1 Property

Surface1 Property
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »Surface1
Declaration Syntax
C# Visual Basic Visual C++
public Surface Surface1 { get; }
Public ReadOnly Property Surface1 As Surface
    Get
public:
property Surface^ Surface1 {
    Surface^ get ();
}


Surface2 Property

Surface2 Property
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »Surface2
Declaration Syntax
C# Visual Basic Visual C++
public Surface Surface2 { get; }
Public ReadOnly Property Surface2 As Surface
    Get
public:
property Surface^ Surface2 {
    Surface^ get ();
}


Tolerance Property

Tolerance Property
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »Tolerance
Declaration Syntax
C# Visual Basic Visual C++
public Tolerance Tolerance { get; }
Public ReadOnly Property Tolerance As Tolerance
    Get
public:
property Tolerance Tolerance {
    Tolerance get ();
}


SurfaceSurfaceIntersectorConfiguration Enumeration

SurfaceSurfaceIntersectorConfiguration Enumeration
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfiguration
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGe::ssiConfig")]
public enum SurfaceSurfaceIntersectorConfiguration
<WrapperAttribute("ZcGe::ssiConfig")> _
Public Enumeration SurfaceSurfaceIntersectorConfiguration
[WrapperAttribute(L"ZcGe::ssiConfig")]
public enum class SurfaceSurfaceIntersectorConfiguration
Members
Member | Description
Unknown |
Coincident |
In |
Out |


SurfaceSurfaceIntersectorConfigurations Structure

SurfaceSurfaceIntersectorConfigurations Structure
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations
Declaration Syntax
C# Visual Basic Visual C++
public struct SurfaceSurfaceIntersectorConfigurations
Public Structure SurfaceSurfaceIntersectorConfigurations
public value class SurfaceSurfaceIntersectorConfigurations
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Dimension |
 | Equality(SurfaceSurfaceIntersectorConfigurations, SurfaceSurfaceIntersectorConfigurations) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(SurfaceSurfaceIntersectorConfigurations, SurfaceSurfaceIntersectorConfigurations) |
 | IntersectionType |
 | IsEqualTo(SurfaceSurfaceIntersectorConfigurations) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Surface1Left |
 | Surface1Right |
 | Surface2Left |
 | Surface2Right |
 | ToString()()()() | (Inherited from ValueType.)


Dimension Property

Dimension Property
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »Dimension
Declaration Syntax
C# Visual Basic Visual C++
public int Dimension { get; }
Public ReadOnly Property Dimension As Integer
    Get
public:
property int Dimension {
    int get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »Equality(SurfaceSurfaceIntersectorConfigurations, SurfaceSurfaceIntersectorConfigurations)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    SurfaceSurfaceIntersectorConfigurations a,
    SurfaceSurfaceIntersectorConfigurations b
)
Public Shared Operator = ( _
    a As SurfaceSurfaceIntersectorConfigurations, _
    b As SurfaceSurfaceIntersectorConfigurations _
) As Boolean
public:
static bool operator ==(
    SurfaceSurfaceIntersectorConfigurations a,
    SurfaceSurfaceIntersectorConfigurations b
)
Parameters
a(SurfaceSurfaceIntersectorConfigurations)
b(SurfaceSurfaceIntersectorConfigurations)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »Inequality(SurfaceSurfaceIntersectorConfigurations, SurfaceSurfaceIntersectorConfigurations)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    SurfaceSurfaceIntersectorConfigurations a,
    SurfaceSurfaceIntersectorConfigurations b
)
Public Shared Operator <> ( _
    a As SurfaceSurfaceIntersectorConfigurations, _
    b As SurfaceSurfaceIntersectorConfigurations _
) As Boolean
public:
static bool operator !=(
    SurfaceSurfaceIntersectorConfigurations a,
    SurfaceSurfaceIntersectorConfigurations b
)
Parameters
a(SurfaceSurfaceIntersectorConfigurations)
b(SurfaceSurfaceIntersectorConfigurations)


IntersectionType Property

IntersectionType Property
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »IntersectionType
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSurfaceIntersectorType IntersectionType { get; }
Public ReadOnly Property IntersectionType As SurfaceSurfaceIntersectorType
    Get
public:
property SurfaceSurfaceIntersectorType IntersectionType {
    SurfaceSurfaceIntersectorType get ();
}


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »IsEqualTo(SurfaceSurfaceIntersectorConfigurations)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    SurfaceSurfaceIntersectorConfigurations a
)
Public Function IsEqualTo ( _
    a As SurfaceSurfaceIntersectorConfigurations _
) As Boolean
public:
bool IsEqualTo(
    SurfaceSurfaceIntersectorConfigurations a
)
Parameters
a(SurfaceSurfaceIntersectorConfigurations)


Surface1Left Property

Surface1Left Property
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »Surface1Left
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSurfaceIntersectorConfiguration Surface1Left { get; }
Public ReadOnly Property Surface1Left As SurfaceSurfaceIntersectorConfiguration
    Get
public:
property SurfaceSurfaceIntersectorConfiguration Surface1Left {
    SurfaceSurfaceIntersectorConfiguration get ();
}


Surface1Right Property

Surface1Right Property
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »Surface1Right
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSurfaceIntersectorConfiguration Surface1Right { get; }
Public ReadOnly Property Surface1Right As SurfaceSurfaceIntersectorConfiguration
    Get
public:
property SurfaceSurfaceIntersectorConfiguration Surface1Right {
    SurfaceSurfaceIntersectorConfiguration get ();
}


Surface2Left Property

Surface2Left Property
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »Surface2Left
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSurfaceIntersectorConfiguration Surface2Left { get; }
Public ReadOnly Property Surface2Left As SurfaceSurfaceIntersectorConfiguration
    Get
public:
property SurfaceSurfaceIntersectorConfiguration Surface2Left {
    SurfaceSurfaceIntersectorConfiguration get ();
}


Surface2Right Property

Surface2Right Property
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorConfigurations »Surface2Right
Declaration Syntax
C# Visual Basic Visual C++
public SurfaceSurfaceIntersectorConfiguration Surface2Right { get; }
Public ReadOnly Property Surface2Right As SurfaceSurfaceIntersectorConfiguration
    Get
public:
property SurfaceSurfaceIntersectorConfiguration Surface2Right {
    SurfaceSurfaceIntersectorConfiguration get ();
}


SurfaceSurfaceIntersectorType Enumeration

SurfaceSurfaceIntersectorType Enumeration
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersectorType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGe::ssiType")]
public enum SurfaceSurfaceIntersectorType
<WrapperAttribute("ZcGe::ssiType")> _
Public Enumeration SurfaceSurfaceIntersectorType
[WrapperAttribute(L"ZcGe::ssiType")]
public enum class SurfaceSurfaceIntersectorType
Members
Member | Description
AntiTangent |
Tangent |
Transverse |


Tolerance Structure

Tolerance Structure
Namespaces »ZwSoft.ZwCAD.Geometry »Tolerance
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeTol")]
public struct Tolerance
<WrapperAttribute("ZcGeTol")> _
Public Structure Tolerance
[WrapperAttribute(L"ZcGeTol")]
public value class Tolerance
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Tolerance(Double, Double) |
 | EqualPoint |
 | Equals(Object) | (Inherited from ValueType.)
 | EqualVector |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Global |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)


Tolerance Constructor (equalVector, equalPoint)

Tolerance Constructor (equalVector, equalPoint)
Namespaces »ZwSoft.ZwCAD.Geometry »Tolerance »Tolerance(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Tolerance(
    double equalVector,
    double equalPoint
)
Public Sub New ( _
    equalVector As Double, _
    equalPoint As Double _
)
public:
Tolerance(
    double equalVector,
    double equalPoint
)
Parameters
equalVector(Double)
equalPoint(Double)


EqualPoint Property

EqualPoint Property
Namespaces »ZwSoft.ZwCAD.Geometry »Tolerance »EqualPoint
Declaration Syntax
C# Visual Basic Visual C++
public double EqualPoint { get; }
Public ReadOnly Property EqualPoint As Double
    Get
public:
property double EqualPoint {
    double get ();
}


EqualVector Property

EqualVector Property
Namespaces »ZwSoft.ZwCAD.Geometry »Tolerance »EqualVector
Declaration Syntax
C# Visual Basic Visual C++
public double EqualVector { get; }
Public ReadOnly Property EqualVector As Double
    Get
public:
property double EqualVector {
    double get ();
}


Global Property

Global Property
Namespaces »ZwSoft.ZwCAD.Geometry »Tolerance »Global
Declaration Syntax
C# Visual Basic Visual C++
public static Tolerance Global { get; }
Public Shared ReadOnly Property Global As Tolerance
    Get
public:
static property Tolerance Global {
    Tolerance get ();
}


Torus Class

Torus Class
Namespaces »ZwSoft.ZwCAD.Geometry »Torus
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeTorus")]
public sealed class Torus : Surface
<WrapperAttribute("ZcGeTorus")> _
Public NotInheritable Class Torus _
    Inherits Surface
[WrapperAttribute(L"ZcGeTorus")]
public ref class Torus sealed : public Surface
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Torus(Double, Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | Torus(Double, Double, Point3d, Vector3d) |
 | Torus()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | AxisOfSymmetry |
 | Center |
 | Clone()()()() | (Inherited from Entity3d.)
 | ClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | ClosestPointTo(Point3d) | (Inherited from Surface.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Entity3d.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DistanceTo(Point3d, Tolerance) | (Inherited from Surface.)
 | DistanceTo(Point3d) | (Inherited from Surface.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EvaluatePoint(Point2d) | (Inherited from Surface.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetAnglesInU()()()() |
 | GetAnglesInV()()()() |
 | GetClosestPointTo(Point3d, Tolerance) | (Inherited from Surface.)
 | GetClosestPointTo(Point3d) | (Inherited from Surface.)
 | GetEnvelope()()()() | (Inherited from Surface.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |
 | IsApple |
 | IsClosedInU(Tolerance) | (Inherited from Surface.)
 | IsClosedInU()()()() | (Inherited from Surface.)
 | IsClosedInV(Tolerance) | (Inherited from Surface.)
 | IsClosedInV()()()() | (Inherited from Surface.)
 | IsDegenerate |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsDoughnut |
 | IsEqualTo(Entity3d, Tolerance) | (Inherited from Entity3d.)
 | IsEqualTo(Entity3d) | (Inherited from Entity3d.)
 | IsHollow |
 | IsLemon |
 | IsNormalReversed | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%, Tolerance) | (Inherited from Surface.)
 | IsOn(Point3d, Point2d%) | (Inherited from Surface.)
 | IsOn(Point3d, Tolerance) | (Inherited from Entity3d.)
 | IsOn(Point3d) | (Inherited from Entity3d.)
 | IsOuterNormal |
 | IsVortex |
 | MajorRadius |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinorRadius |
 | Mirror(Plane) | (Inherited from Entity3d.)
 | ParameterOf(Point3d, Tolerance) | (Inherited from Surface.)
 | ParameterOf(Point3d) | (Inherited from Surface.)
 | ReferenceAxis |
 | ReverseNormal | (Inherited from Surface.)
 | RotateBy(Double, Vector3d, Point3d) | (Inherited from Entity3d.)
 | ScaleBy(Double, Point3d) | (Inherited from Entity3d.)
 | Set(Double, Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | Set(Double, Double, Point3d, Vector3d) |
 | SetAnglesInU(Double, Double) |
 | SetAnglesInV(Double, Double) |
 | ToString()()()() | (Inherited from Object.)
 | TransformBy(Matrix3d) | (Inherited from Entity3d.)
 | TranslateBy(Vector3d) | (Inherited from Entity3d.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Entity3d
 |  |  |  | Surface
 |  |  |  |  | Torus


Torus Constructor

Torus Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »Torus()()()()
Members
Icon | Member | Description
 | Torus(Double, Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | Torus(Double, Double, Point3d, Vector3d) |
 | Torus()()()() |


Torus Constructor

Torus Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »Torus()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Torus()
Public Sub New
public:
Torus()


Torus Constructor (majorRadius, minorRadius, origin, axisOfSymmetry)

Torus Constructor (majorRadius, minorRadius, origin, axisOfSymmetry)
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »Torus(Double, Double, Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Torus(
    double majorRadius,
    double minorRadius,
    Point3d origin,
    Vector3d axisOfSymmetry
)
Public Sub New ( _
    majorRadius As Double, _
    minorRadius As Double, _
    origin As Point3d, _
    axisOfSymmetry As Vector3d _
)
public:
Torus(
    double majorRadius,
    double minorRadius,
    Point3d origin,
    Vector3d axisOfSymmetry
)
Parameters
majorRadius(Double)
minorRadius(Double)
origin(Point3d)
axisOfSymmetry(Vector3d)


Torus Constructor (majorRadius, minorRadius, origin, axisOfSymmetry, referenceAxis, startAngleU, endAngleU, startAngleV, endAngleV)

Torus Constructor (majorRadius, minorRadius, origin, axisOfSymmetry, referenceAxis, startAngleU, endAngleU, startAngleV, endAngleV)
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »Torus(Double, Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Torus(
    double majorRadius,
    double minorRadius,
    Point3d origin,
    Vector3d axisOfSymmetry,
    Vector3d referenceAxis,
    double startAngleU,
    double endAngleU,
    double startAngleV,
    double endAngleV
)
Public Sub New ( _
    majorRadius As Double, _
    minorRadius As Double, _
    origin As Point3d, _
    axisOfSymmetry As Vector3d, _
    referenceAxis As Vector3d, _
    startAngleU As Double, _
    endAngleU As Double, _
    startAngleV As Double, _
    endAngleV As Double _
)
public:
Torus(
    double majorRadius,
    double minorRadius,
    Point3d origin,
    Vector3d axisOfSymmetry,
    Vector3d referenceAxis,
    double startAngleU,
    double endAngleU,
    double startAngleV,
    double endAngleV
)
Parameters
majorRadius(Double)
minorRadius(Double)
origin(Point3d)
axisOfSymmetry(Vector3d)
referenceAxis(Vector3d)
startAngleU(Double)
endAngleU(Double)
startAngleV(Double)
endAngleV(Double)


AxisOfSymmetry Property

AxisOfSymmetry Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »AxisOfSymmetry
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d AxisOfSymmetry { get; }
Public ReadOnly Property AxisOfSymmetry As Vector3d
    Get
public:
property Vector3d AxisOfSymmetry {
    Vector3d get ();
}


Center Property

Center Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »Center
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Center { get; }
Public ReadOnly Property Center As Point3d
    Get
public:
property Point3d Center {
    Point3d get ();
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static Torus Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As Torus
public:
static Torus^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


GetAnglesInU Method

GetAnglesInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »GetAnglesInU()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] GetAnglesInU()
Public Function GetAnglesInU As Double()
public:
array<double>^ GetAnglesInU()


GetAnglesInV Method

GetAnglesInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »GetAnglesInV()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] GetAnglesInV()
Public Function GetAnglesInV As Double()
public:
array<double>^ GetAnglesInV()


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(LinearEntity3d) |


IntersectWith Method (linearEntity)

IntersectWith Method (linearEntity)
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IntersectWith(LinearEntity3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d linearEntity
)
Public Function IntersectWith ( _
    linearEntity As LinearEntity3d _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ linearEntity
)
Parameters
linearEntity(LinearEntity3d)


IntersectWith Method (linearEntity, tolerance)

IntersectWith Method (linearEntity, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IntersectWith(LinearEntity3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] IntersectWith(
    LinearEntity3d linearEntity,
    Tolerance tolerance
)
Public Function IntersectWith ( _
    linearEntity As LinearEntity3d, _
    tolerance As Tolerance _
) As Point3d()
public:
array<Point3d>^ IntersectWith(
    LinearEntity3d^ linearEntity,
    Tolerance tolerance
)
Parameters
linearEntity(LinearEntity3d)
tolerance(Tolerance)


IsApple Property

IsApple Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsApple
Declaration Syntax
C# Visual Basic Visual C++
public bool IsApple { get; }
Public ReadOnly Property IsApple As Boolean
    Get
public:
property bool IsApple {
    bool get ();
}


IsDegenerate Property

IsDegenerate Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsDegenerate
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDegenerate { get; }
Public ReadOnly Property IsDegenerate As Boolean
    Get
public:
property bool IsDegenerate {
    bool get ();
}


IsDoughnut Property

IsDoughnut Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsDoughnut
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDoughnut { get; }
Public ReadOnly Property IsDoughnut As Boolean
    Get
public:
property bool IsDoughnut {
    bool get ();
}


IsHollow Property

IsHollow Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsHollow
Declaration Syntax
C# Visual Basic Visual C++
public bool IsHollow { get; }
Public ReadOnly Property IsHollow As Boolean
    Get
public:
property bool IsHollow {
    bool get ();
}


IsLemon Property

IsLemon Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsLemon
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLemon { get; }
Public ReadOnly Property IsLemon As Boolean
    Get
public:
property bool IsLemon {
    bool get ();
}


IsOuterNormal Property

IsOuterNormal Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsOuterNormal
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOuterNormal { get; }
Public ReadOnly Property IsOuterNormal As Boolean
    Get
public:
property bool IsOuterNormal {
    bool get ();
}


IsVortex Property

IsVortex Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsVortex
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVortex { get; }
Public ReadOnly Property IsVortex As Boolean
    Get
public:
property bool IsVortex {
    bool get ();
}


MajorRadius Property

MajorRadius Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »MajorRadius
Declaration Syntax
C# Visual Basic Visual C++
public double MajorRadius { get; set; }
Public Property MajorRadius As Double
    Get
    Set
public:
property double MajorRadius {
    double get ();
    void set (double value);
}


MinorRadius Property

MinorRadius Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »MinorRadius
Declaration Syntax
C# Visual Basic Visual C++
public double MinorRadius { get; set; }
Public Property MinorRadius As Double
    Get
    Set
public:
property double MinorRadius {
    double get ();
    void set (double value);
}


ReferenceAxis Property

ReferenceAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »ReferenceAxis
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d ReferenceAxis { get; }
Public ReadOnly Property ReferenceAxis As Vector3d
    Get
public:
property Vector3d ReferenceAxis {
    Vector3d get ();
}


Set Method

Set Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »Set()()()()
Members
Icon | Member | Description
 | Set(Double, Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) |
 | Set(Double, Double, Point3d, Vector3d) |


Set Method (majorRadius, minorRadius, origin, axisOfSymmetry)

Set Method (majorRadius, minorRadius, origin, axisOfSymmetry)
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »Set(Double, Double, Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double majorRadius,
    double minorRadius,
    Point3d origin,
    Vector3d axisOfSymmetry
)
Public Sub Set ( _
    majorRadius As Double, _
    minorRadius As Double, _
    origin As Point3d, _
    axisOfSymmetry As Vector3d _
)
public:
void Set(
    double majorRadius,
    double minorRadius,
    Point3d origin,
    Vector3d axisOfSymmetry
)
Parameters
majorRadius(Double)
minorRadius(Double)
origin(Point3d)
axisOfSymmetry(Vector3d)


Set Method (majorRadius, minorRadius, origin, axisOfSymmetry, refAxis, startAngleU, endAngleU, startAngleV, endAngleV)

Set Method (majorRadius, minorRadius, origin, axisOfSymmetry, refAxis, startAngleU, endAngleU, startAngleV, endAngleV)
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »Set(Double, Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    double majorRadius,
    double minorRadius,
    Point3d origin,
    Vector3d axisOfSymmetry,
    Vector3d refAxis,
    double startAngleU,
    double endAngleU,
    double startAngleV,
    double endAngleV
)
Public Sub Set ( _
    majorRadius As Double, _
    minorRadius As Double, _
    origin As Point3d, _
    axisOfSymmetry As Vector3d, _
    refAxis As Vector3d, _
    startAngleU As Double, _
    endAngleU As Double, _
    startAngleV As Double, _
    endAngleV As Double _
)
public:
void Set(
    double majorRadius,
    double minorRadius,
    Point3d origin,
    Vector3d axisOfSymmetry,
    Vector3d refAxis,
    double startAngleU,
    double endAngleU,
    double startAngleV,
    double endAngleV
)
Parameters
majorRadius(Double)
minorRadius(Double)
origin(Point3d)
axisOfSymmetry(Vector3d)
refAxis(Vector3d)
startAngleU(Double)
endAngleU(Double)
startAngleV(Double)
endAngleV(Double)


SetAnglesInU Method (startAngle, endAngle)

SetAnglesInU Method (startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »SetAnglesInU(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAnglesInU(
    double startAngle,
    double endAngle
)
Public Sub SetAnglesInU ( _
    startAngle As Double, _
    endAngle As Double _
)
public:
void SetAnglesInU(
    double startAngle,
    double endAngle
)
Parameters
startAngle(Double)
endAngle(Double)


SetAnglesInV Method (startAngle, endAngle)

SetAnglesInV Method (startAngle, endAngle)
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »SetAnglesInV(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAnglesInV(
    double startAngle,
    double endAngle
)
Public Sub SetAnglesInV ( _
    startAngle As Double, _
    endAngle As Double _
)
public:
void SetAnglesInV(
    double startAngle,
    double endAngle
)
Parameters
startAngle(Double)
endAngle(Double)


UInt32Collection Class

UInt32Collection Class
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeUInt32Array")]
public class UInt32Collection : IList
<WrapperAttribute("ZcGeUInt32Array")> _
Public Class UInt32Collection _
    Implements IList
[WrapperAttribute(L"ZcGeUInt32Array")]
public ref class UInt32Collection : IList
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UInt32Collection(Int32) |
 | UInt32Collection(array<UInt32>[]()[][]) |
 | UInt32Collection()()()() |
 | Add(UInt32) |
 | AddRange(array<UInt32>[]()[][]) |
 | Capacity |
 | Clear()()()() |
 | Contains(UInt32) |
 | CopyTo(array<UInt32>[]()[][], Int32) |
 | Count |
 | DefaultSize |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IEnumerable_GetEnumerator()()()() |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(UInt32) |
 | Insert(Int32, UInt32) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(UInt32) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() |
Inheritance Hierarchy
Object
UInt32Collection


UInt32Collection Constructor

UInt32Collection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »UInt32Collection()()()()
Members
Icon | Member | Description
 | UInt32Collection(Int32) |
 | UInt32Collection(array<UInt32>[]()[][]) |
 | UInt32Collection()()()() |


UInt32Collection Constructor

UInt32Collection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »UInt32Collection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UInt32Collection()
Public Sub New
public:
UInt32Collection()


UInt32Collection Constructor (capacity)

UInt32Collection Constructor (capacity)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »UInt32Collection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public UInt32Collection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
UInt32Collection(
    int capacity
)
Parameters
capacity(Int32)


UInt32Collection Constructor (values)

UInt32Collection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »UInt32Collection(array<UInt32>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public UInt32Collection(
    uint[] values
)
Public Sub New ( _
    values As UInteger() _
)
public:
UInt32Collection(
    array<unsigned int>^ values
)
Parameters
values(array<UInt32>[]()[][])


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »Add(UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Add(
    uint value
)
Public Overridable Function Add ( _
    value As UInteger _
) As Integer
public:
virtual int Add(
    unsigned int value
)
Parameters
value(UInt32)


AddRange Method (range)

AddRange Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »AddRange(array<UInt32>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddRange(
    uint[] range
)
Public Overridable Sub AddRange ( _
    range As UInteger() _
)
public:
virtual void AddRange(
    array<unsigned int>^ range
)
Parameters
range(array<UInt32>[]()[][])


Capacity Property

Capacity Property
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »Capacity
Declaration Syntax
C# Visual Basic Visual C++
public int Capacity { get; set; }
Public Property Capacity As Integer
    Get
    Set
public:
property int Capacity {
    int get ();
    void set (int value);
}


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »Contains(UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Contains(
    uint value
)
Public Overridable Function Contains ( _
    value As UInteger _
) As Boolean
public:
virtual bool Contains(
    unsigned int value
)
Parameters
value(UInt32)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »CopyTo(array<UInt32>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyTo(
    uint[] array,
    int index
)
Public Overridable Sub CopyTo ( _
    array As UInteger(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<unsigned int>^ array,
    int index
)
Parameters
array(array<UInt32>[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DefaultSize Field

DefaultSize Field
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »DefaultSize
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultSize
Public Const DefaultSize As Integer
public:
literal int DefaultSize


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual UInt32CollectionEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As UInt32CollectionEnumerator
public:
virtual UInt32CollectionEnumerator^ GetEnumerator()


ICollection_CopyTo Method (array, index)

ICollection_CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollection_CopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator IEnumerable_GetEnumerator()
Public Overridable Function IEnumerable_GetEnumerator As IEnumerator
public:
virtual IEnumerator^ IEnumerable_GetEnumerator()


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IList_IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IList_IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IList_Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IList_Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IndexOf(UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IndexOf(
    uint value
)
Public Overridable Function IndexOf ( _
    value As UInteger _
) As Integer
public:
virtual int IndexOf(
    unsigned int value
)
Parameters
value(UInt32)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »Insert(Int32, UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Insert(
    int index,
    uint value
)
Public Overridable Sub Insert ( _
    index As Integer, _
    value As UInteger _
)
public:
virtual void Insert(
    int index,
    unsigned int value
)
Parameters
index(Int32)
value(UInt32)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public uint this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As UInteger
    Get
    Set
public:
property unsigned int default[int index] {
    unsigned int get (int index);
    void set (int index, unsigned int value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »Remove(UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Remove(
    uint value
)
Public Overridable Sub Remove ( _
    value As UInteger _
)
public:
virtual void Remove(
    unsigned int value
)
Parameters
value(UInt32)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual uint[] ToArray()
Public Overridable Function ToArray As UInteger()
public:
virtual array<unsigned int>^ ToArray()


TrimToSize Method

TrimToSize Method
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32Collection »TrimToSize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void TrimToSize()
Public Overridable Sub TrimToSize
public:
virtual void TrimToSize()


UInt32CollectionEnumerator Class

UInt32CollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32CollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public class UInt32CollectionEnumerator : IEnumerator
Public Class UInt32CollectionEnumerator _
    Implements IEnumerator
public ref class UInt32CollectionEnumerator : IEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerator_Current |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
UInt32CollectionEnumerator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32CollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public uint Current { get; }
Public ReadOnly Property Current As UInteger
    Get
public:
property unsigned int Current {
    unsigned int get ();
}


IEnumerator_Current Property

IEnumerator_Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32CollectionEnumerator »IEnumerator_Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object IEnumerator_Current { get; }
Public Overridable ReadOnly Property IEnumerator_Current As Object
    Get
public:
virtual property Object^ IEnumerator_Current {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32CollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool MoveNext()
Public Function MoveNext As Boolean
public:
virtual bool MoveNext() sealed


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.Geometry »UInt32CollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
virtual void Reset() sealed


Vector2d Structure

Vector2d Structure
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeVector2d")]
public struct Vector2d : IFormattable
<WrapperAttribute("ZcGeVector2d")> _
Public Structure Vector2d _
    Implements IFormattable
[WrapperAttribute(L"ZcGeVector2d")]
public value class Vector2d : IFormattable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Vector2d(Double, Double) |
 | Vector2d(array<Double>[]()[][]) |
 | Add(Vector2d) |
 | Addition(Vector2d, Vector2d) |
 | Angle |
 | Coordinate[([( Int32])]) |
 | DivideBy(Double) |
 | Division(Vector2d, Double) |
 | DotProduct(Vector2d) |
 | Equality(Vector2d, Vector2d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetAngleTo(Vector2d) |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetNormal(Tolerance) |
 | GetNormal()()()() |
 | GetPerpendicularVector()()()() |
 | GetType()()()() | (Inherited from Object.)
 | Inequality(Vector2d, Vector2d) |
 | IsCodirectionalTo(Vector2d, Tolerance) |
 | IsCodirectionalTo(Vector2d) |
 | IsEqualTo(Vector2d, Tolerance) |
 | IsEqualTo(Vector2d) |
 | IsParallelTo(Vector2d, Tolerance) |
 | IsParallelTo(Vector2d) |
 | IsPerpendicularTo(Vector2d, Tolerance) |
 | IsPerpendicularTo(Vector2d) |
 | IsUnitLength(Tolerance) |
 | IsUnitLength()()()() |
 | IsZeroLength(Tolerance) |
 | IsZeroLength()()()() |
 | Length |
 | LengthSqrd |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Vector2d) |
 | Multiply(Double, Vector2d) |
 | Multiply(Vector2d, Double) |
 | Multiply(Matrix2d, Vector2d) |
 | MultiplyBy(Double) |
 | Negate()()()() |
 | RotateBy(Double) |
 | Subtract(Vector2d) |
 | Subtraction(Vector2d, Vector2d) |
 | ToArray()()()() |
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | TransformBy(Matrix2d) |
 | UnaryNegation(Vector2d) |
 | X |
 | XAxis |
 | Y |
 | YAxis |


Vector2d Constructor

Vector2d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Vector2d()()()()
Members
Icon | Member | Description
 | Vector2d(Double, Double) |
 | Vector2d(array<Double>[]()[][]) |


Vector2d Constructor (x, y)

Vector2d Constructor (x, y)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Vector2d(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d(
    double x,
    double y
)
Public Sub New ( _
    x As Double, _
    y As Double _
)
public:
Vector2d(
    double x,
    double y
)
Parameters
x(Double)
y(Double)


Vector2d Constructor (xy)

Vector2d Constructor (xy)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Vector2d(array<Double>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d(
    double[] xy
)
Public Sub New ( _
    xy As Double() _
)
public:
Vector2d(
    array<double>^ xy
)
Parameters
xy(array<Double>[]()[][])


Add Method (v)

Add Method (v)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Add(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Add(
    Vector2d v
)
Public Function Add ( _
    v As Vector2d _
) As Vector2d
public:
Vector2d Add(
    Vector2d v
)
Parameters
v(Vector2d)


Addition Operator

Addition Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Addition(Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d operator +(
    Vector2d a,
    Vector2d b
)
Public Shared Operator + ( _
    a As Vector2d, _
    b As Vector2d _
) As Vector2d
public:
static Vector2d operator +(
    Vector2d a,
    Vector2d b
)
Parameters
a(Vector2d)
b(Vector2d)


Angle Property

Angle Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Angle
Declaration Syntax
C# Visual Basic Visual C++
public double Angle { get; }
Public ReadOnly Property Angle As Double
    Get
public:
property double Angle {
    double get ();
}


Coordinate Property (index)

Coordinate Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Coordinate[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int index
] { get; }
Public ReadOnly Default Property Coordinate ( _
    index As Integer _
) As Double
    Get
public:
property double default[int index] {
    double get (int index);
}
Parameters
index(Int32)


DivideBy Method (value)

DivideBy Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »DivideBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d DivideBy(
    double value
)
Public Function DivideBy ( _
    value As Double _
) As Vector2d
public:
Vector2d DivideBy(
    double value
)
Parameters
value(Double)


Division Operator

Division Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Division(Vector2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d operator /(
    Vector2d a,
    double factor
)
Public Shared Operator / ( _
    a As Vector2d, _
    factor As Double _
) As Vector2d
public:
static Vector2d operator /(
    Vector2d a,
    double factor
)
Parameters
a(Vector2d)
factor(Double)


DotProduct Method (v)

DotProduct Method (v)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »DotProduct(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public double DotProduct(
    Vector2d v
)
Public Function DotProduct ( _
    v As Vector2d _
) As Double
public:
double DotProduct(
    Vector2d v
)
Parameters
v(Vector2d)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Equality(Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Vector2d a,
    Vector2d b
)
Public Shared Operator = ( _
    a As Vector2d, _
    b As Vector2d _
) As Boolean
public:
static bool operator ==(
    Vector2d a,
    Vector2d b
)
Parameters
a(Vector2d)
b(Vector2d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetAngleTo Method (vector)

GetAngleTo Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »GetAngleTo(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetAngleTo(
    Vector2d vector
)
Public Function GetAngleTo ( _
    vector As Vector2d _
) As Double
public:
double GetAngleTo(
    Vector2d vector
)
Parameters
vector(Vector2d)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetNormal Method

GetNormal Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »GetNormal()()()()
Members
Icon | Member | Description
 | GetNormal(Tolerance) |
 | GetNormal()()()() |


GetNormal Method

GetNormal Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »GetNormal()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetNormal()
Public Function GetNormal As Vector2d
public:
Vector2d GetNormal()


GetNormal Method (tolerance)

GetNormal Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »GetNormal(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetNormal(
    Tolerance tolerance
)
Public Function GetNormal ( _
    tolerance As Tolerance _
) As Vector2d
public:
Vector2d GetNormal(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


GetPerpendicularVector Method

GetPerpendicularVector Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »GetPerpendicularVector()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d GetPerpendicularVector()
Public Function GetPerpendicularVector As Vector2d
public:
Vector2d GetPerpendicularVector()


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Inequality(Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Vector2d a,
    Vector2d b
)
Public Shared Operator <> ( _
    a As Vector2d, _
    b As Vector2d _
) As Boolean
public:
static bool operator !=(
    Vector2d a,
    Vector2d b
)
Parameters
a(Vector2d)
b(Vector2d)


IsCodirectionalTo Method

IsCodirectionalTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsCodirectionalTo()()()()
Members
Icon | Member | Description
 | IsCodirectionalTo(Vector2d, Tolerance) |
 | IsCodirectionalTo(Vector2d) |


IsCodirectionalTo Method (vector)

IsCodirectionalTo Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsCodirectionalTo(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCodirectionalTo(
    Vector2d vector
)
Public Function IsCodirectionalTo ( _
    vector As Vector2d _
) As Boolean
public:
bool IsCodirectionalTo(
    Vector2d vector
)
Parameters
vector(Vector2d)


IsCodirectionalTo Method (vector, tolerance)

IsCodirectionalTo Method (vector, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsCodirectionalTo(Vector2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCodirectionalTo(
    Vector2d vector,
    Tolerance tolerance
)
Public Function IsCodirectionalTo ( _
    vector As Vector2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsCodirectionalTo(
    Vector2d vector,
    Tolerance tolerance
)
Parameters
vector(Vector2d)
tolerance(Tolerance)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Vector2d, Tolerance) |
 | IsEqualTo(Vector2d) |


IsEqualTo Method (vector)

IsEqualTo Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsEqualTo(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Vector2d vector
)
Public Function IsEqualTo ( _
    vector As Vector2d _
) As Boolean
public:
bool IsEqualTo(
    Vector2d vector
)
Parameters
vector(Vector2d)


IsEqualTo Method (vector, tolerance)

IsEqualTo Method (vector, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsEqualTo(Vector2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Vector2d vector,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    vector As Vector2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Vector2d vector,
    Tolerance tolerance
)
Parameters
vector(Vector2d)
tolerance(Tolerance)


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(Vector2d, Tolerance) |
 | IsParallelTo(Vector2d) |


IsParallelTo Method (vector)

IsParallelTo Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsParallelTo(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    Vector2d vector
)
Public Function IsParallelTo ( _
    vector As Vector2d _
) As Boolean
public:
bool IsParallelTo(
    Vector2d vector
)
Parameters
vector(Vector2d)


IsParallelTo Method (vector, tolerance)

IsParallelTo Method (vector, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsParallelTo(Vector2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    Vector2d vector,
    Tolerance tolerance
)
Public Function IsParallelTo ( _
    vector As Vector2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsParallelTo(
    Vector2d vector,
    Tolerance tolerance
)
Parameters
vector(Vector2d)
tolerance(Tolerance)


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(Vector2d, Tolerance) |
 | IsPerpendicularTo(Vector2d) |


IsPerpendicularTo Method (vector)

IsPerpendicularTo Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsPerpendicularTo(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    Vector2d vector
)
Public Function IsPerpendicularTo ( _
    vector As Vector2d _
) As Boolean
public:
bool IsPerpendicularTo(
    Vector2d vector
)
Parameters
vector(Vector2d)


IsPerpendicularTo Method (vector, tolerance)

IsPerpendicularTo Method (vector, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsPerpendicularTo(Vector2d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    Vector2d vector,
    Tolerance tolerance
)
Public Function IsPerpendicularTo ( _
    vector As Vector2d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsPerpendicularTo(
    Vector2d vector,
    Tolerance tolerance
)
Parameters
vector(Vector2d)
tolerance(Tolerance)


IsUnitLength Method

IsUnitLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsUnitLength()()()()
Members
Icon | Member | Description
 | IsUnitLength(Tolerance) |
 | IsUnitLength()()()() |


IsUnitLength Method

IsUnitLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsUnitLength()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUnitLength()
Public Function IsUnitLength As Boolean
public:
bool IsUnitLength()


IsUnitLength Method (tolerance)

IsUnitLength Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsUnitLength(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUnitLength(
    Tolerance tolerance
)
Public Function IsUnitLength ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsUnitLength(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsZeroLength Method

IsZeroLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsZeroLength()()()()
Members
Icon | Member | Description
 | IsZeroLength(Tolerance) |
 | IsZeroLength()()()() |


IsZeroLength Method

IsZeroLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsZeroLength()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsZeroLength()
Public Function IsZeroLength As Boolean
public:
bool IsZeroLength()


IsZeroLength Method (tolerance)

IsZeroLength Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »IsZeroLength(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsZeroLength(
    Tolerance tolerance
)
Public Function IsZeroLength ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsZeroLength(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


Length Property

Length Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Length
Declaration Syntax
C# Visual Basic Visual C++
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}


LengthSqrd Property

LengthSqrd Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »LengthSqrd
Declaration Syntax
C# Visual Basic Visual C++
public double LengthSqrd { get; }
Public ReadOnly Property LengthSqrd As Double
    Get
public:
property double LengthSqrd {
    double get ();
}


Mirror Method (line)

Mirror Method (line)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Mirror(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Mirror(
    Vector2d line
)
Public Function Mirror ( _
    line As Vector2d _
) As Vector2d
public:
Vector2d Mirror(
    Vector2d line
)
Parameters
line(Vector2d)


Multiply Method

Multiply Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Multiply()()()()
Members
Icon | Member | Description
 | Multiply(Double, Vector2d) |
 | Multiply(Vector2d, Double) |
 | Multiply(Matrix2d, Vector2d) |


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Multiply(Double, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d operator *(
    double factor,
    Vector2d a
)
Public Shared Operator * ( _
    factor As Double, _
    a As Vector2d _
) As Vector2d
public:
static Vector2d operator *(
    double factor,
    Vector2d a
)
Parameters
factor(Double)
a(Vector2d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Multiply(Matrix2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d operator *(
    Matrix2d a,
    Vector2d b
)
Public Shared Operator * ( _
    a As Matrix2d, _
    b As Vector2d _
) As Vector2d
public:
static Vector2d operator *(
    Matrix2d a,
    Vector2d b
)
Parameters
a(Matrix2d)
b(Vector2d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Multiply(Vector2d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d operator *(
    Vector2d a,
    double factor
)
Public Shared Operator * ( _
    a As Vector2d, _
    factor As Double _
) As Vector2d
public:
static Vector2d operator *(
    Vector2d a,
    double factor
)
Parameters
a(Vector2d)
factor(Double)


MultiplyBy Method (value)

MultiplyBy Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »MultiplyBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d MultiplyBy(
    double value
)
Public Function MultiplyBy ( _
    value As Double _
) As Vector2d
public:
Vector2d MultiplyBy(
    double value
)
Parameters
value(Double)


Negate Method

Negate Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Negate()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Negate()
Public Function Negate As Vector2d
public:
Vector2d Negate()


RotateBy Method (angle)

RotateBy Method (angle)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »RotateBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d RotateBy(
    double angle
)
Public Function RotateBy ( _
    angle As Double _
) As Vector2d
public:
Vector2d RotateBy(
    double angle
)
Parameters
angle(Double)


Subtract Method (v)

Subtract Method (v)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Subtract(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Subtract(
    Vector2d v
)
Public Function Subtract ( _
    v As Vector2d _
) As Vector2d
public:
Vector2d Subtract(
    Vector2d v
)
Parameters
v(Vector2d)


Subtraction Operator

Subtraction Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Subtraction(Vector2d, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d operator -(
    Vector2d a,
    Vector2d b
)
Public Shared Operator - ( _
    a As Vector2d, _
    b As Vector2d _
) As Vector2d
public:
static Vector2d operator -(
    Vector2d a,
    Vector2d b
)
Parameters
a(Vector2d)
b(Vector2d)


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] ToArray()
Public Function ToArray As Double()
public:
array<double>^ ToArray()


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


TransformBy Method (leftSide)

TransformBy Method (leftSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »TransformBy(Matrix2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d TransformBy(
    Matrix2d leftSide
)
Public Function TransformBy ( _
    leftSide As Matrix2d _
) As Vector2d
public:
Vector2d TransformBy(
    Matrix2d leftSide
)
Parameters
leftSide(Matrix2d)


UnaryNegation Operator

UnaryNegation Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »UnaryNegation(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d operator -(
    Vector2d a
)
Public Shared Operator - ( _
    a As Vector2d _
) As Vector2d
public:
static Vector2d operator -(
    Vector2d a
)
Parameters
a(Vector2d)


X Property

X Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »X
Declaration Syntax
C# Visual Basic Visual C++
public double X { get; }
Public ReadOnly Property X As Double
    Get
public:
property double X {
    double get ();
}


XAxis Property

XAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »XAxis
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d XAxis { get; }
Public Shared ReadOnly Property XAxis As Vector2d
    Get
public:
static property Vector2d XAxis {
    Vector2d get ();
}


Y Property

Y Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »Y
Declaration Syntax
C# Visual Basic Visual C++
public double Y { get; }
Public ReadOnly Property Y As Double
    Get
public:
property double Y {
    double get ();
}


YAxis Property

YAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2d »YAxis
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d YAxis { get; }
Public Shared ReadOnly Property YAxis As Vector2d
    Get
public:
static property Vector2d YAxis {
    Vector2d get ();
}


Vector2dCollection Class

Vector2dCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeVector2dArray")]
public sealed class Vector2dCollection : IList
<WrapperAttribute("ZcGeVector2dArray")> _
Public NotInheritable Class Vector2dCollection _
    Implements IList
[WrapperAttribute(L"ZcGeVector2dArray")]
public ref class Vector2dCollection sealed : IList
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Vector2dCollection(Int32) |
 | Vector2dCollection(array<Vector2d>[]()[][]) |
 | Vector2dCollection()()()() |
 | Add(Vector2d) |
 | AddRange(array<Vector2d>[]()[][]) |
 | Capacity |
 | Clear()()()() |
 | Contains(Vector2d) |
 | CopyTo(array<Vector2d>[]()[][], Int32) |
 | Count |
 | DefaultSize |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection_CopyTo(Array, Int32) |
 | IEnumerable_GetEnumerator()()()() |
 | IList_Add(Object) |
 | IList_Contains(Object) |
 | IList_IndexOf(Object) |
 | IList_Insert(Int32, Object) |
 | IList_Item[([( Int32])]) |
 | IList_Remove(Object) |
 | IndexOf(Vector2d) |
 | Insert(Int32, Vector2d) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Vector2d) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() |
Inheritance Hierarchy
Object
Vector2dCollection


Vector2dCollection Constructor

Vector2dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Vector2dCollection()()()()
Members
Icon | Member | Description
 | Vector2dCollection(Int32) |
 | Vector2dCollection(array<Vector2d>[]()[][]) |
 | Vector2dCollection()()()() |


Vector2dCollection Constructor

Vector2dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Vector2dCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector2dCollection()
Public Sub New
public:
Vector2dCollection()


Vector2dCollection Constructor (capacity)

Vector2dCollection Constructor (capacity)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Vector2dCollection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2dCollection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
Vector2dCollection(
    int capacity
)
Parameters
capacity(Int32)


Vector2dCollection Constructor (values)

Vector2dCollection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Vector2dCollection(array<Vector2d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Vector2dCollection(
    Vector2d[] values
)
Public Sub New ( _
    values As Vector2d() _
)
public:
Vector2dCollection(
    array<Vector2d>^ values
)
Parameters
values(array< Vector2d >[]()[][])


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Add(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Vector2d value
)
Public Function Add ( _
    value As Vector2d _
) As Integer
public:
virtual int Add(
    Vector2d value
) sealed
Parameters
value(Vector2d)


AddRange Method (range)

AddRange Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »AddRange(array<Vector2d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    Vector2d[] range
)
Public Sub AddRange ( _
    range As Vector2d() _
)
public:
virtual void AddRange(
    array<Vector2d>^ range
) sealed
Parameters
range(array< Vector2d >[]()[][])


Capacity Property

Capacity Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Capacity
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Contains(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Vector2d value
)
Public Function Contains ( _
    value As Vector2d _
) As Boolean
public:
virtual bool Contains(
    Vector2d value
) sealed
Parameters
value(Vector2d)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »CopyTo(array<Vector2d>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Vector2d[] array,
    int index
)
Public Sub CopyTo ( _
    array As Vector2d(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<Vector2d>^ array,
    int index
) sealed
Parameters
array(array< Vector2d >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DefaultSize Field

DefaultSize Field
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »DefaultSize
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultSize
Public Const DefaultSize As Integer
public:
literal int DefaultSize


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector2dCollectionEnumerator GetEnumerator()
Public Function GetEnumerator As Vector2dCollectionEnumerator
public:
virtual Vector2dCollectionEnumerator^ GetEnumerator() sealed


ICollection_CopyTo Method (array, index)

ICollection_CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »ICollection_CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
internal void ICollection_CopyTo(
    Array array,
    int index
)
Friend Sub ICollection_CopyTo ( _
    array As Array, _
    index As Integer _
)
internal:
virtual void ICollection_CopyTo(
    Array^ array,
    int index
) sealed
Parameters
array(Array)
index(Int32)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
internal IEnumerator IEnumerable_GetEnumerator()
Friend Function IEnumerable_GetEnumerator As IEnumerator
internal:
virtual IEnumerator^ IEnumerable_GetEnumerator() sealed


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IList_Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
internal int IList_Add(
    Object value
)
Friend Function IList_Add ( _
    value As Object _
) As Integer
internal:
virtual int IList_Add(
    Object^ value
) sealed
Parameters
value(Object)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IList_Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
internal bool IList_Contains(
    Object value
)
Friend Function IList_Contains ( _
    value As Object _
) As Boolean
internal:
virtual bool IList_Contains(
    Object^ value
) sealed
Parameters
value(Object)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IList_IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
internal int IList_IndexOf(
    Object value
)
Friend Function IList_IndexOf ( _
    value As Object _
) As Integer
internal:
virtual int IList_IndexOf(
    Object^ value
) sealed
Parameters
value(Object)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IList_Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
internal void IList_Insert(
    int index,
    Object value
)
Friend Sub IList_Insert ( _
    index As Integer, _
    value As Object _
)
internal:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed
Parameters
index(Int32)
value(Object)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IList_Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
internal Object this[
    int index
] { get; set; }
Friend Property IList_Item ( _
    index As Integer _
) As Object
    Get
    Set
internal:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed;
    void set (int index, Object^ value) sealed;
}
Parameters
index(Int32)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IList_Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
internal void IList_Remove(
    Object value
)
Friend Sub IList_Remove ( _
    value As Object _
)
internal:
virtual void IList_Remove(
    Object^ value
) sealed
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IndexOf(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Vector2d value
)
Public Function IndexOf ( _
    value As Vector2d _
) As Integer
public:
virtual int IndexOf(
    Vector2d value
) sealed
Parameters
value(Vector2d)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Insert(Int32, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Vector2d value
)
Public Sub Insert ( _
    index As Integer, _
    value As Vector2d _
)
public:
virtual void Insert(
    int index,
    Vector2d value
) sealed
Parameters
index(Int32)
value(Vector2d)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector2d this[
    int index
] { get; set; }
Public Overridable Default Property Item ( _
    index As Integer _
) As Vector2d
    Get
    Set
public:
virtual property Vector2d default[int index] {
    Vector2d get (int index);
    void set (int index, Vector2d value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »Remove(Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Vector2d value
)
Public Sub Remove ( _
    value As Vector2d _
)
public:
virtual void Remove(
    Vector2d value
) sealed
Parameters
value(Vector2d)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d[] ToArray()
Public Function ToArray As Vector2d()
public:
virtual array<Vector2d>^ ToArray() sealed


TrimToSize Method

TrimToSize Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollection »TrimToSize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void TrimToSize()
Public Sub TrimToSize
public:
virtual void TrimToSize() sealed


Vector2dCollectionEnumerator Class

Vector2dCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public class Vector2dCollectionEnumerator : IEnumerator
Public Class Vector2dCollectionEnumerator _
    Implements IEnumerator
public ref class Vector2dCollectionEnumerator : IEnumerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Vector2dCollectionEnumerator(Vector2dCollection) |
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IEnumerator..::..Current |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Vector2dCollectionEnumerator


Vector2dCollectionEnumerator Constructor (collection)

Vector2dCollectionEnumerator Constructor (collection)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollectionEnumerator »Vector2dCollectionEnumerator(Vector2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Vector2dCollectionEnumerator(
    Vector2dCollection collection
)
Protected Friend Sub New ( _
    collection As Vector2dCollection _
)
protected public:
Vector2dCollectionEnumerator(
    Vector2dCollection^ collection
)
Parameters
collection(Vector2dCollection)


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector2d Current { get; }
Public Overridable ReadOnly Property Current As Vector2d
    Get
public:
virtual property Vector2d Current {
    Vector2d get ();
}


IEnumeratorCurrent Property

IEnumeratorCurrent Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollectionEnumerator »IEnumerator..::..Current
Declaration Syntax
C# Visual Basic Visual C++
Object IEnumerator.Current { get; }
Private ReadOnly Property IEnumeratorCurrent As Object
    Implements IEnumerator.Current
    Get
private:
virtual property Object^ IEnumeratorCurrent {
    Object^ get () sealed = IEnumerator::Current::get;
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector2dCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()


Vector3d Structure

Vector3d Structure
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeVector3d")]
public struct Vector3d : IFormattable
<WrapperAttribute("ZcGeVector3d")> _
Public Structure Vector3d _
    Implements IFormattable
[WrapperAttribute(L"ZcGeVector3d")]
public value class Vector3d : IFormattable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Vector3d(Double, Double, Double) |
 | Vector3d(PlanarEntity, Vector2d) |
 | Vector3d(array<Double>[]()[][]) |
 | Add(Vector3d) |
 | Addition(Vector3d, Vector3d) |
 | AngleOnPlane(PlanarEntity) |
 | Convert2d(PlanarEntity) |
 | Coordinate[([( Int32])]) |
 | CrossProduct(Vector3d) |
 | DivideBy(Double) |
 | Division(Vector3d, Double) |
 | DotProduct(Vector3d) |
 | Equality(Vector3d, Vector3d) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetAngleTo(Vector3d, Vector3d) |
 | GetAngleTo(Vector3d) |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetNormal(Tolerance) |
 | GetNormal()()()() |
 | GetPerpendicularVector()()()() |
 | GetType()()()() | (Inherited from Object.)
 | Inequality(Vector3d, Vector3d) |
 | IsCodirectionalTo(Vector3d, Tolerance) |
 | IsCodirectionalTo(Vector3d) |
 | IsEqualTo(Vector3d, Tolerance) |
 | IsEqualTo(Vector3d) |
 | IsParallelTo(Vector3d, Tolerance) |
 | IsParallelTo(Vector3d) |
 | IsPerpendicularTo(Vector3d, Tolerance) |
 | IsPerpendicularTo(Vector3d) |
 | IsUnitLength(Tolerance) |
 | IsUnitLength()()()() |
 | IsZeroLength(Tolerance) |
 | IsZeroLength()()()() |
 | LargestElement |
 | Length |
 | LengthSqrd |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mirror(Vector3d) |
 | Multiply(Double, Vector3d) |
 | Multiply(Vector3d, Double) |
 | Multiply(Matrix3d, Vector3d) |
 | MultiplyBy(Double) |
 | Negate()()()() |
 | OrthoProjectTo(Vector3d) |
 | ProjectTo(Vector3d, Vector3d) |
 | RotateBy(Double, Vector3d) |
 | Subtract(Vector3d) |
 | Subtraction(Vector3d, Vector3d) |
 | ToArray()()()() |
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | TransformBy(Matrix3d) |
 | UnaryNegation(Vector3d) |
 | X |
 | XAxis |
 | Y |
 | YAxis |
 | Z |
 | ZAxis |


Vector3d Constructor

Vector3d Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Vector3d()()()()
Members
Icon | Member | Description
 | Vector3d(Double, Double, Double) |
 | Vector3d(PlanarEntity, Vector2d) |
 | Vector3d(array<Double>[]()[][]) |


Vector3d Constructor (x, y, z)

Vector3d Constructor (x, y, z)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Vector3d(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d(
    double x,
    double y,
    double z
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
Vector3d(
    double x,
    double y,
    double z
)
Parameters
x(Double)
y(Double)
z(Double)


Vector3d Constructor (xyz)

Vector3d Constructor (xyz)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Vector3d(array<Double>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d(
    double[] xyz
)
Public Sub New ( _
    xyz As Double() _
)
public:
Vector3d(
    array<double>^ xyz
)
Parameters
xyz(array<Double>[]()[][])


Vector3d Constructor (plane, vector2d)

Vector3d Constructor (plane, vector2d)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Vector3d(PlanarEntity, Vector2d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d(
    PlanarEntity plane,
    Vector2d vector2d
)
Public Sub New ( _
    plane As PlanarEntity, _
    vector2d As Vector2d _
)
public:
Vector3d(
    PlanarEntity^ plane,
    Vector2d vector2d
)
Parameters
plane(PlanarEntity)
vector2d(Vector2d)


Add Method (v)

Add Method (v)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Add(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Add(
    Vector3d v
)
Public Function Add ( _
    v As Vector3d _
) As Vector3d
public:
Vector3d Add(
    Vector3d v
)
Parameters
v(Vector3d)


Addition Operator

Addition Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Addition(Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d operator +(
    Vector3d a,
    Vector3d b
)
Public Shared Operator + ( _
    a As Vector3d, _
    b As Vector3d _
) As Vector3d
public:
static Vector3d operator +(
    Vector3d a,
    Vector3d b
)
Parameters
a(Vector3d)
b(Vector3d)


AngleOnPlane Method (plane)

AngleOnPlane Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »AngleOnPlane(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public double AngleOnPlane(
    PlanarEntity plane
)
Public Function AngleOnPlane ( _
    plane As PlanarEntity _
) As Double
public:
double AngleOnPlane(
    PlanarEntity^ plane
)
Parameters
plane(PlanarEntity)


Convert2d Method (plane)

Convert2d Method (plane)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Convert2d(PlanarEntity)
Declaration Syntax
C# Visual Basic Visual C++
public Vector2d Convert2d(
    PlanarEntity plane
)
Public Function Convert2d ( _
    plane As PlanarEntity _
) As Vector2d
public:
Vector2d Convert2d(
    PlanarEntity^ plane
)
Parameters
plane(PlanarEntity)


Coordinate Property (index)

Coordinate Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Coordinate[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    int index
] { get; }
Public ReadOnly Default Property Coordinate ( _
    index As Integer _
) As Double
    Get
public:
property double default[int index] {
    double get (int index);
}
Parameters
index(Int32)


CrossProduct Method (vector)

CrossProduct Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »CrossProduct(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d CrossProduct(
    Vector3d vector
)
Public Function CrossProduct ( _
    vector As Vector3d _
) As Vector3d
public:
Vector3d CrossProduct(
    Vector3d vector
)
Parameters
vector(Vector3d)


DivideBy Method (value)

DivideBy Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »DivideBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d DivideBy(
    double value
)
Public Function DivideBy ( _
    value As Double _
) As Vector3d
public:
Vector3d DivideBy(
    double value
)
Parameters
value(Double)


Division Operator

Division Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Division(Vector3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d operator /(
    Vector3d a,
    double factor
)
Public Shared Operator / ( _
    a As Vector3d, _
    factor As Double _
) As Vector3d
public:
static Vector3d operator /(
    Vector3d a,
    double factor
)
Parameters
a(Vector3d)
factor(Double)


DotProduct Method (v)

DotProduct Method (v)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »DotProduct(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public double DotProduct(
    Vector3d v
)
Public Function DotProduct ( _
    v As Vector3d _
) As Double
public:
double DotProduct(
    Vector3d v
)
Parameters
v(Vector3d)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Equality(Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    Vector3d a,
    Vector3d b
)
Public Shared Operator = ( _
    a As Vector3d, _
    b As Vector3d _
) As Boolean
public:
static bool operator ==(
    Vector3d a,
    Vector3d b
)
Parameters
a(Vector3d)
b(Vector3d)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetAngleTo Method

GetAngleTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »GetAngleTo()()()()
Members
Icon | Member | Description
 | GetAngleTo(Vector3d, Vector3d) |
 | GetAngleTo(Vector3d) |


GetAngleTo Method (vector)

GetAngleTo Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »GetAngleTo(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetAngleTo(
    Vector3d vector
)
Public Function GetAngleTo ( _
    vector As Vector3d _
) As Double
public:
double GetAngleTo(
    Vector3d vector
)
Parameters
vector(Vector3d)


GetAngleTo Method (vector, referenceVector)

GetAngleTo Method (vector, referenceVector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »GetAngleTo(Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public double GetAngleTo(
    Vector3d vector,
    Vector3d referenceVector
)
Public Function GetAngleTo ( _
    vector As Vector3d, _
    referenceVector As Vector3d _
) As Double
public:
double GetAngleTo(
    Vector3d vector,
    Vector3d referenceVector
)
Parameters
vector(Vector3d)
referenceVector(Vector3d)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


GetNormal Method

GetNormal Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »GetNormal()()()()
Members
Icon | Member | Description
 | GetNormal(Tolerance) |
 | GetNormal()()()() |


GetNormal Method

GetNormal Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »GetNormal()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetNormal()
Public Function GetNormal As Vector3d
public:
Vector3d GetNormal()


GetNormal Method (tolerance)

GetNormal Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »GetNormal(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetNormal(
    Tolerance tolerance
)
Public Function GetNormal ( _
    tolerance As Tolerance _
) As Vector3d
public:
Vector3d GetNormal(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


GetPerpendicularVector Method

GetPerpendicularVector Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »GetPerpendicularVector()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d GetPerpendicularVector()
Public Function GetPerpendicularVector As Vector3d
public:
Vector3d GetPerpendicularVector()


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Inequality(Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    Vector3d a,
    Vector3d b
)
Public Shared Operator <> ( _
    a As Vector3d, _
    b As Vector3d _
) As Boolean
public:
static bool operator !=(
    Vector3d a,
    Vector3d b
)
Parameters
a(Vector3d)
b(Vector3d)


IsCodirectionalTo Method

IsCodirectionalTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsCodirectionalTo()()()()
Members
Icon | Member | Description
 | IsCodirectionalTo(Vector3d, Tolerance) |
 | IsCodirectionalTo(Vector3d) |


IsCodirectionalTo Method (vector)

IsCodirectionalTo Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsCodirectionalTo(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCodirectionalTo(
    Vector3d vector
)
Public Function IsCodirectionalTo ( _
    vector As Vector3d _
) As Boolean
public:
bool IsCodirectionalTo(
    Vector3d vector
)
Parameters
vector(Vector3d)


IsCodirectionalTo Method (vector, tolerance)

IsCodirectionalTo Method (vector, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsCodirectionalTo(Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCodirectionalTo(
    Vector3d vector,
    Tolerance tolerance
)
Public Function IsCodirectionalTo ( _
    vector As Vector3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsCodirectionalTo(
    Vector3d vector,
    Tolerance tolerance
)
Parameters
vector(Vector3d)
tolerance(Tolerance)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Vector3d, Tolerance) |
 | IsEqualTo(Vector3d) |


IsEqualTo Method (vector)

IsEqualTo Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsEqualTo(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Vector3d vector
)
Public Function IsEqualTo ( _
    vector As Vector3d _
) As Boolean
public:
bool IsEqualTo(
    Vector3d vector
)
Parameters
vector(Vector3d)


IsEqualTo Method (vector, tolerance)

IsEqualTo Method (vector, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsEqualTo(Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    Vector3d vector,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    vector As Vector3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    Vector3d vector,
    Tolerance tolerance
)
Parameters
vector(Vector3d)
tolerance(Tolerance)


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(Vector3d, Tolerance) |
 | IsParallelTo(Vector3d) |


IsParallelTo Method (vector)

IsParallelTo Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsParallelTo(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    Vector3d vector
)
Public Function IsParallelTo ( _
    vector As Vector3d _
) As Boolean
public:
bool IsParallelTo(
    Vector3d vector
)
Parameters
vector(Vector3d)


IsParallelTo Method (vector, tolerance)

IsParallelTo Method (vector, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsParallelTo(Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsParallelTo(
    Vector3d vector,
    Tolerance tolerance
)
Public Function IsParallelTo ( _
    vector As Vector3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsParallelTo(
    Vector3d vector,
    Tolerance tolerance
)
Parameters
vector(Vector3d)
tolerance(Tolerance)


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(Vector3d, Tolerance) |
 | IsPerpendicularTo(Vector3d) |


IsPerpendicularTo Method (vector)

IsPerpendicularTo Method (vector)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsPerpendicularTo(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    Vector3d vector
)
Public Function IsPerpendicularTo ( _
    vector As Vector3d _
) As Boolean
public:
bool IsPerpendicularTo(
    Vector3d vector
)
Parameters
vector(Vector3d)


IsPerpendicularTo Method (vector, tolerance)

IsPerpendicularTo Method (vector, tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsPerpendicularTo(Vector3d, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerpendicularTo(
    Vector3d vector,
    Tolerance tolerance
)
Public Function IsPerpendicularTo ( _
    vector As Vector3d, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsPerpendicularTo(
    Vector3d vector,
    Tolerance tolerance
)
Parameters
vector(Vector3d)
tolerance(Tolerance)


IsUnitLength Method

IsUnitLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsUnitLength()()()()
Members
Icon | Member | Description
 | IsUnitLength(Tolerance) |
 | IsUnitLength()()()() |


IsUnitLength Method

IsUnitLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsUnitLength()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUnitLength()
Public Function IsUnitLength As Boolean
public:
bool IsUnitLength()


IsUnitLength Method (tolerance)

IsUnitLength Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsUnitLength(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUnitLength(
    Tolerance tolerance
)
Public Function IsUnitLength ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsUnitLength(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


IsZeroLength Method

IsZeroLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsZeroLength()()()()
Members
Icon | Member | Description
 | IsZeroLength(Tolerance) |
 | IsZeroLength()()()() |


IsZeroLength Method

IsZeroLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsZeroLength()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsZeroLength()
Public Function IsZeroLength As Boolean
public:
bool IsZeroLength()


IsZeroLength Method (tolerance)

IsZeroLength Method (tolerance)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »IsZeroLength(Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsZeroLength(
    Tolerance tolerance
)
Public Function IsZeroLength ( _
    tolerance As Tolerance _
) As Boolean
public:
bool IsZeroLength(
    Tolerance tolerance
)
Parameters
tolerance(Tolerance)


LargestElement Property

LargestElement Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »LargestElement
Declaration Syntax
C# Visual Basic Visual C++
public double LargestElement { get; }
Public ReadOnly Property LargestElement As Double
    Get
public:
property double LargestElement {
    double get ();
}


Length Property

Length Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Length
Declaration Syntax
C# Visual Basic Visual C++
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}


LengthSqrd Property

LengthSqrd Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »LengthSqrd
Declaration Syntax
C# Visual Basic Visual C++
public double LengthSqrd { get; }
Public ReadOnly Property LengthSqrd As Double
    Get
public:
property double LengthSqrd {
    double get ();
}


Mirror Method (normalToPlane)

Mirror Method (normalToPlane)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Mirror(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Mirror(
    Vector3d normalToPlane
)
Public Function Mirror ( _
    normalToPlane As Vector3d _
) As Vector3d
public:
Vector3d Mirror(
    Vector3d normalToPlane
)
Parameters
normalToPlane(Vector3d)


Multiply Method

Multiply Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Multiply()()()()
Members
Icon | Member | Description
 | Multiply(Double, Vector3d) |
 | Multiply(Vector3d, Double) |
 | Multiply(Matrix3d, Vector3d) |


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Multiply(Double, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d operator *(
    double factor,
    Vector3d a
)
Public Shared Operator * ( _
    factor As Double, _
    a As Vector3d _
) As Vector3d
public:
static Vector3d operator *(
    double factor,
    Vector3d a
)
Parameters
factor(Double)
a(Vector3d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Multiply(Matrix3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d operator *(
    Matrix3d a,
    Vector3d b
)
Public Shared Operator * ( _
    a As Matrix3d, _
    b As Vector3d _
) As Vector3d
public:
static Vector3d operator *(
    Matrix3d a,
    Vector3d b
)
Parameters
a(Matrix3d)
b(Vector3d)


Multiply Operator

Multiply Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Multiply(Vector3d, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d operator *(
    Vector3d a,
    double factor
)
Public Shared Operator * ( _
    a As Vector3d, _
    factor As Double _
) As Vector3d
public:
static Vector3d operator *(
    Vector3d a,
    double factor
)
Parameters
a(Vector3d)
factor(Double)


MultiplyBy Method (value)

MultiplyBy Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »MultiplyBy(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d MultiplyBy(
    double value
)
Public Function MultiplyBy ( _
    value As Double _
) As Vector3d
public:
Vector3d MultiplyBy(
    double value
)
Parameters
value(Double)


Negate Method

Negate Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Negate()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Negate()
Public Function Negate As Vector3d
public:
Vector3d Negate()


OrthoProjectTo Method (planeNormal)

OrthoProjectTo Method (planeNormal)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »OrthoProjectTo(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d OrthoProjectTo(
    Vector3d planeNormal
)
Public Function OrthoProjectTo ( _
    planeNormal As Vector3d _
) As Vector3d
public:
Vector3d OrthoProjectTo(
    Vector3d planeNormal
)
Parameters
planeNormal(Vector3d)


ProjectTo Method (planeNormal, projectDirection)

ProjectTo Method (planeNormal, projectDirection)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »ProjectTo(Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d ProjectTo(
    Vector3d planeNormal,
    Vector3d projectDirection
)
Public Function ProjectTo ( _
    planeNormal As Vector3d, _
    projectDirection As Vector3d _
) As Vector3d
public:
Vector3d ProjectTo(
    Vector3d planeNormal,
    Vector3d projectDirection
)
Parameters
planeNormal(Vector3d)
projectDirection(Vector3d)


RotateBy Method (angle, axis)

RotateBy Method (angle, axis)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »RotateBy(Double, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d RotateBy(
    double angle,
    Vector3d axis
)
Public Function RotateBy ( _
    angle As Double, _
    axis As Vector3d _
) As Vector3d
public:
Vector3d RotateBy(
    double angle,
    Vector3d axis
)
Parameters
angle(Double)
axis(Vector3d)


Subtract Method (v)

Subtract Method (v)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Subtract(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Subtract(
    Vector3d v
)
Public Function Subtract ( _
    v As Vector3d _
) As Vector3d
public:
Vector3d Subtract(
    Vector3d v
)
Parameters
v(Vector3d)


Subtraction Operator

Subtraction Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Subtraction(Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d operator -(
    Vector3d a,
    Vector3d b
)
Public Shared Operator - ( _
    a As Vector3d, _
    b As Vector3d _
) As Vector3d
public:
static Vector3d operator -(
    Vector3d a,
    Vector3d b
)
Parameters
a(Vector3d)
b(Vector3d)


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public double[] ToArray()
Public Function ToArray As Double()
public:
array<double>^ ToArray()


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »ToString()()()()
Members
Icon | Member | Description
 | ToString(String, IFormatProvider) |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


ToString Method (format, provider)

ToString Method (format, provider)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »ToString(String, IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed
Parameters
format(String)
provider(IFormatProvider)


TransformBy Method (leftSide)

TransformBy Method (leftSide)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »TransformBy(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d TransformBy(
    Matrix3d leftSide
)
Public Function TransformBy ( _
    leftSide As Matrix3d _
) As Vector3d
public:
Vector3d TransformBy(
    Matrix3d leftSide
)
Parameters
leftSide(Matrix3d)


UnaryNegation Operator

UnaryNegation Operator
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »UnaryNegation(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d operator -(
    Vector3d a
)
Public Shared Operator - ( _
    a As Vector3d _
) As Vector3d
public:
static Vector3d operator -(
    Vector3d a
)
Parameters
a(Vector3d)


X Property

X Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »X
Declaration Syntax
C# Visual Basic Visual C++
public double X { get; }
Public ReadOnly Property X As Double
    Get
public:
property double X {
    double get ();
}


XAxis Property

XAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »XAxis
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d XAxis { get; }
Public Shared ReadOnly Property XAxis As Vector3d
    Get
public:
static property Vector3d XAxis {
    Vector3d get ();
}


Y Property

Y Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Y
Declaration Syntax
C# Visual Basic Visual C++
public double Y { get; }
Public ReadOnly Property Y As Double
    Get
public:
property double Y {
    double get ();
}


YAxis Property

YAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »YAxis
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d YAxis { get; }
Public Shared ReadOnly Property YAxis As Vector3d
    Get
public:
static property Vector3d YAxis {
    Vector3d get ();
}


Z Property

Z Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »Z
Declaration Syntax
C# Visual Basic Visual C++
public double Z { get; }
Public ReadOnly Property Z As Double
    Get
public:
property double Z {
    double get ();
}


ZAxis Property

ZAxis Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3d »ZAxis
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d ZAxis { get; }
Public Shared ReadOnly Property ZAxis As Vector3d
    Get
public:
static property Vector3d ZAxis {
    Vector3d get ();
}


Vector3dCollection Class

Vector3dCollection Class
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGeVector3dArray")]
public sealed class Vector3dCollection : IList
<WrapperAttribute("ZcGeVector3dArray")> _
Public NotInheritable Class Vector3dCollection _
    Implements IList
[WrapperAttribute(L"ZcGeVector3dArray")]
public ref class Vector3dCollection sealed : IList
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Vector3dCollection(Int32) |
 | Vector3dCollection(array<Vector3d>[]()[][]) |
 | Vector3dCollection()()()() |
 | Add(Vector3d) |
 | AddRange(array<Vector3d>[]()[][]) |
 | Capacity |
 | Clear()()()() |
 | Contains(Vector3d) |
 | CopyTo(array<Vector3d>[]()[][], Int32) |
 | Count |
 | DefaultSize |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection_CopyTo(Array, Int32) |
 | IEnumerable_GetEnumerator()()()() |
 | IList_Add(Object) |
 | IList_Contains(Object) |
 | IList_IndexOf(Object) |
 | IList_Insert(Int32, Object) |
 | IList_Item[([( Int32])]) |
 | IList_Remove(Object) |
 | IndexOf(Vector3d) |
 | Insert(Int32, Vector3d) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Vector3d) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
 | TrimToSize()()()() |
Inheritance Hierarchy
Object
Vector3dCollection


Vector3dCollection Constructor

Vector3dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Vector3dCollection()()()()
Members
Icon | Member | Description
 | Vector3dCollection(Int32) |
 | Vector3dCollection(array<Vector3d>[]()[][]) |
 | Vector3dCollection()()()() |


Vector3dCollection Constructor

Vector3dCollection Constructor
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Vector3dCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3dCollection()
Public Sub New
public:
Vector3dCollection()


Vector3dCollection Constructor (capacity)

Vector3dCollection Constructor (capacity)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Vector3dCollection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Vector3dCollection(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
Vector3dCollection(
    int capacity
)
Parameters
capacity(Int32)


Vector3dCollection Constructor (values)

Vector3dCollection Constructor (values)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Vector3dCollection(array<Vector3d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Vector3dCollection(
    Vector3d[] values
)
Public Sub New ( _
    values As Vector3d() _
)
public:
Vector3dCollection(
    array<Vector3d>^ values
)
Parameters
values(array< Vector3d >[]()[][])


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Add(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Vector3d value
)
Public Function Add ( _
    value As Vector3d _
) As Integer
public:
virtual int Add(
    Vector3d value
) sealed
Parameters
value(Vector3d)


AddRange Method (range)

AddRange Method (range)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »AddRange(array<Vector3d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    Vector3d[] range
)
Public Sub AddRange ( _
    range As Vector3d() _
)
public:
virtual void AddRange(
    array<Vector3d>^ range
) sealed
Parameters
range(array< Vector3d >[]()[][])


Capacity Property

Capacity Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Capacity
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set
public:
virtual property int Capacity {
    int get ();
    void set (int value);
}


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Contains(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Vector3d value
)
Public Function Contains ( _
    value As Vector3d _
) As Boolean
public:
virtual bool Contains(
    Vector3d value
) sealed
Parameters
value(Vector3d)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »CopyTo(array<Vector3d>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Vector3d[] array,
    int index
)
Public Sub CopyTo ( _
    array As Vector3d(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<Vector3d>^ array,
    int index
) sealed
Parameters
array(array< Vector3d >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DefaultSize Field

DefaultSize Field
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »DefaultSize
Declaration Syntax
C# Visual Basic Visual C++
public const int DefaultSize
Public Const DefaultSize As Integer
public:
literal int DefaultSize


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3dCollectionEnumerator GetEnumerator()
Public Function GetEnumerator As Vector3dCollectionEnumerator
public:
virtual Vector3dCollectionEnumerator^ GetEnumerator() sealed


ICollection_CopyTo Method (array, index)

ICollection_CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »ICollection_CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
internal void ICollection_CopyTo(
    Array array,
    int index
)
Friend Sub ICollection_CopyTo ( _
    array As Array, _
    index As Integer _
)
internal:
virtual void ICollection_CopyTo(
    Array^ array,
    int index
) sealed
Parameters
array(Array)
index(Int32)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
internal IEnumerator IEnumerable_GetEnumerator()
Friend Function IEnumerable_GetEnumerator As IEnumerator
internal:
virtual IEnumerator^ IEnumerable_GetEnumerator() sealed


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IList_Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
internal int IList_Add(
    Object value
)
Friend Function IList_Add ( _
    value As Object _
) As Integer
internal:
virtual int IList_Add(
    Object^ value
) sealed
Parameters
value(Object)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IList_Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
internal bool IList_Contains(
    Object value
)
Friend Function IList_Contains ( _
    value As Object _
) As Boolean
internal:
virtual bool IList_Contains(
    Object^ value
) sealed
Parameters
value(Object)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IList_IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
internal int IList_IndexOf(
    Object value
)
Friend Function IList_IndexOf ( _
    value As Object _
) As Integer
internal:
virtual int IList_IndexOf(
    Object^ value
) sealed
Parameters
value(Object)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IList_Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
internal void IList_Insert(
    int index,
    Object value
)
Friend Sub IList_Insert ( _
    index As Integer, _
    value As Object _
)
internal:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed
Parameters
index(Int32)
value(Object)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IList_Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
internal Object this[
    int index
] { get; set; }
Friend Property IList_Item ( _
    index As Integer _
) As Object
    Get
    Set
internal:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed;
    void set (int index, Object^ value) sealed;
}
Parameters
index(Int32)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IList_Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
internal void IList_Remove(
    Object value
)
Friend Sub IList_Remove ( _
    value As Object _
)
internal:
virtual void IList_Remove(
    Object^ value
) sealed
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IndexOf(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Vector3d value
)
Public Function IndexOf ( _
    value As Vector3d _
) As Integer
public:
virtual int IndexOf(
    Vector3d value
) sealed
Parameters
value(Vector3d)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Insert(Int32, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Vector3d value
)
Public Sub Insert ( _
    index As Integer, _
    value As Vector3d _
)
public:
virtual void Insert(
    int index,
    Vector3d value
) sealed
Parameters
index(Int32)
value(Vector3d)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d this[
    int index
] { get; set; }
Public Overridable Default Property Item ( _
    index As Integer _
) As Vector3d
    Get
    Set
public:
virtual property Vector3d default[int index] {
    Vector3d get (int index);
    void set (int index, Vector3d value);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »Remove(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Vector3d value
)
Public Sub Remove ( _
    value As Vector3d _
)
public:
virtual void Remove(
    Vector3d value
) sealed
Parameters
value(Vector3d)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d[] ToArray()
Public Function ToArray As Vector3d()
public:
virtual array<Vector3d>^ ToArray() sealed


TrimToSize Method

TrimToSize Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollection »TrimToSize()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void TrimToSize()
Public Sub TrimToSize
public:
virtual void TrimToSize() sealed


Vector3dCollectionEnumerator Class

Vector3dCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public class Vector3dCollectionEnumerator : IEnumerator
Public Class Vector3dCollectionEnumerator _
    Implements IEnumerator
public ref class Vector3dCollectionEnumerator : IEnumerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Vector3dCollectionEnumerator(Vector3dCollection) |
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Vector3dCollectionEnumerator


Vector3dCollectionEnumerator Constructor (collection)

Vector3dCollectionEnumerator Constructor (collection)
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollectionEnumerator »Vector3dCollectionEnumerator(Vector3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Vector3dCollectionEnumerator(
    Vector3dCollection collection
)
Protected Friend Sub New ( _
    collection As Vector3dCollection _
)
protected public:
Vector3dCollectionEnumerator(
    Vector3dCollection^ collection
)
Parameters
collection(Vector3dCollection)


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.Geometry »Vector3dCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()


ZwSoft.ZwCAD.GraphicsInterface Namespace

ZwSoft.ZwCAD.GraphicsInterface Namespace
Namespaces »ZwSoft.ZwCAD.GraphicsInterface
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.GraphicsInterface
Namespace ZwSoft.ZwCAD.GraphicsInterface
namespace ZwSoft.ZwCAD.GraphicsInterface
Types
All Types Classes Structures Enumerations
Icon | Type | Description
 | ArcType |
 | AttenuationType |
 | AttributesFlags |
 | AutoTransform |
 | ChannelFlags |
 | ClipBoundary |
 | CommonDraw |
 | Context |
 | DeviationType |
 | DiagnosticBSPMode |
 | DiagnosticGridMode |
 | DiagnosticMode |
 | DiagnosticPhotonMode |
 | DisplaySettings |
 | DisplayStyle |
 | Drawable |
 | DrawableTraits |
 | DrawableType |
 | EdgeData |
 | EdgeModel |
 | EdgeModifiers |
 | EdgeStyle |
 | EdgeStyleApply |
 | EdgeVisibilityModes |
 | ExposureType |
 | ExtendedLightShape |
 | FaceColorMode |
 | FaceData |
 | FaceModifiers |
 | FaceStyle |
 | FillType |
 | Filter |
 | FinalGatheringMode |
 | FinalGatherMode |
 | FontDescriptor |
 | FrontAndBackClipping |
 | GdiDrawObject |
 | Geometry |
 | GIRasterImage |
 | GlobalIlluminationMode |
 | IlluminationModel |
 | ImageOrg |
 | ImageSource |
 | JitterAmount |
 | DrawableTraits..::..LayerFlags |
 | LightAttenuation |
 | LightingModel |
 | LightingQuality |
 | LightTraits |
 | Linetype |
 | LinetypeCollection |
 | LuminanceMode |
 | MapChannel |
 | MapFilter |
 | Mapper |
 | MentalRayRenderSettingsTraits |
 | MentalRayRenderSettingsTraits2 |
 | MentalRayRenderSettingsTraitsBoolParameter |
 | MentalRayRenderSettingsTraitsDiagnosticGridModeParameter |
 | MentalRayRenderSettingsTraitsDoubleRangeParameter |
 | MentalRayRenderSettingsTraitsFloatParameter |
 | MentalRayRenderSettingsTraitsIntegerRangeParameter |
 | MentalRayRenderSettingsTraitsSamplingParameter |
 | MentalRayRenderSettingsTraitsTraceParameter |
 | Mode |
 | NonEntityTraits |
 | NormalMapMethod |
 | OrientationBehavior |
 | OrientationType |
 | PixelBGRA32 |
 | PixelFormatInfo |
 | Polyline |
 | PolylineCollection |
 | PositionBehavior |
 | Projection |
 | RasterImageSource |
 | RegenType |
 | RenderSettingsTraits |
 | ScaleBehavior |
 | ShadowDisplayType |
 | ShadowFlags |
 | ShadowMode |
 | ShadowParameters |
 | ShadowType |
 | SubEntityTraits |
 | TextStyle |
 | TileOrder |
 | Tiling |
 | TransparencyMode |
 | Units |
 | Variant |
 | VariantType |
 | VertexData |
 | Viewport |
 | ViewportDraw |
 | ViewportGeometry |
 | VisualStyle |
 | VisualStyleOperation |
 | VisualStyleProperty |
 | VisualStyleType |
 | WorldDraw |
 | WorldGeometry |


ArcType Enumeration

ArcType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ArcType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiArcType")]
public enum ArcType
<WrapperAttribute("ZcGiArcType")> _
Public Enumeration ArcType
[WrapperAttribute(L"ZcGiArcType")]
public enum class ArcType
Members
Member | Description
ArcSimple |
ArcSector |
ArcChord |


AttenuationType Enumeration

AttenuationType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »AttenuationType
Declaration Syntax
C# Visual Basic Visual C++
public enum AttenuationType
Public Enumeration AttenuationType
public enum class AttenuationType
Members
Member | Description
InverseSquare |
InverseLinear |
None |


AttributesFlags Enumeration

AttributesFlags Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »AttributesFlags
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("SetAttributesFlags")]
public enum AttributesFlags
<WrapperAttribute("SetAttributesFlags")> _
Public Enumeration AttributesFlags
[WrapperAttribute(L"SetAttributesFlags")]
public enum class AttributesFlags
Members
Member | Description
DrawableViewIndependentViewportDraw |
DrawableIsCompoundObject |
DrawableUsesNesting |
DrawableIsAnEntity |
DrawableNone |
DrawableRegenDraw |
DrawableIsDimension |
DrawableRegenTypeDependantGeometry |
DrawableHasAttributes |
DrawableIsInvisible |


AutoTransform Enumeration

AutoTransform Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »AutoTransform
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiMapper::AutoTransform")]
public enum AutoTransform
<WrapperAttribute("ZcGiMapper::AutoTransform")> _
Public Enumeration AutoTransform
[WrapperAttribute(L"ZcGiMapper::AutoTransform")]
public enum class AutoTransform
Members
Member | Description
None |
TransformObject |
Model |
InheritAutoTransform |


ChannelFlags Enumeration

ChannelFlags Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ChannelFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum ChannelFlags
<FlagsAttribute> _
Public Enumeration ChannelFlags
[FlagsAttribute]
public enum class ChannelFlags
Members
Member | Description
UseAll |
UseNormalMap |
UseRefraction |
UseBump |
UseOpacity |
UseReflection |
UseSpecular |
UseDiffuse |
None |


ClipBoundary Class

ClipBoundary Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiClipBoundary")]
public sealed class ClipBoundary : DisposableWrapper
<WrapperAttribute("ZcGiClipBoundary")> _
Public NotInheritable Class ClipBoundary _
    Inherits DisposableWrapper
[WrapperAttribute(L"ZcGiClipBoundary")]
public ref class ClipBoundary sealed : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClipBoundary()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackClipZ |
 | ClippingBack |
 | ClippingFront |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DrawBoundary |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FrontClipZ |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NormalVector |
 | Point |
 | ToString()()()() | (Inherited from Object.)
 | TransformInverseBlockRefXForm |
 | TransformToClipSpace |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | ClipBoundary


ClipBoundary Constructor

ClipBoundary Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »ClipBoundary()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClipBoundary()
Public Sub New
public:
ClipBoundary()


BackClipZ Property

BackClipZ Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »BackClipZ
Declaration Syntax
C# Visual Basic Visual C++
public double BackClipZ { get; set; }
Public Property BackClipZ As Double
    Get
    Set
public:
property double BackClipZ {
    double get ();
    void set (double value);
}


ClippingBack Property

ClippingBack Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »ClippingBack
Declaration Syntax
C# Visual Basic Visual C++
public bool ClippingBack { get; set; }
Public Property ClippingBack As Boolean
    Get
    Set
public:
property bool ClippingBack {
    bool get ();
    void set (bool value);
}


ClippingFront Property

ClippingFront Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »ClippingFront
Declaration Syntax
C# Visual Basic Visual C++
public bool ClippingFront { get; set; }
Public Property ClippingFront As Boolean
    Get
    Set
public:
property bool ClippingFront {
    bool get ();
    void set (bool value);
}


DrawBoundary Property

DrawBoundary Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »DrawBoundary
Declaration Syntax
C# Visual Basic Visual C++
public bool DrawBoundary { get; set; }
Public Property DrawBoundary As Boolean
    Get
    Set
public:
property bool DrawBoundary {
    bool get ();
    void set (bool value);
}


FrontClipZ Property

FrontClipZ Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »FrontClipZ
Declaration Syntax
C# Visual Basic Visual C++
public double FrontClipZ { get; set; }
Public Property FrontClipZ As Double
    Get
    Set
public:
property double FrontClipZ {
    double get ();
    void set (double value);
}


NormalVector Property

NormalVector Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »NormalVector
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d NormalVector { get; set; }
Public Property NormalVector As Vector3d
    Get
    Set
public:
property Vector3d NormalVector {
    Vector3d get ();
    void set (Vector3d value);
}


Point Property

Point Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »Point
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Point { get; set; }
Public Property Point As Point3d
    Get
    Set
public:
property Point3d Point {
    Point3d get ();
    void set (Point3d value);
}


TransformInverseBlockRefXForm Property

TransformInverseBlockRefXForm Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »TransformInverseBlockRefXForm
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d TransformInverseBlockRefXForm { get; set; }
Public Property TransformInverseBlockRefXForm As Matrix3d
    Get
    Set
public:
property Matrix3d TransformInverseBlockRefXForm {
    Matrix3d get ();
    void set (Matrix3d value);
}


TransformToClipSpace Property

TransformToClipSpace Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »TransformToClipSpace
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d TransformToClipSpace { get; set; }
Public Property TransformToClipSpace As Matrix3d
    Get
    Set
public:
property Matrix3d TransformToClipSpace {
    Matrix3d get ();
    void set (Matrix3d value);
}


CommonDraw Class

CommonDraw Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiCommonDraw")]
public abstract class CommonDraw : RXObject
<WrapperAttribute("ZcGiCommonDraw")> _
Public MustInherit Class CommonDraw _
    Inherits RXObject
[WrapperAttribute(L"ZcGiCommonDraw")]
public ref class CommonDraw abstract : public RXObject
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Context |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Deviation(DeviationType, Point3d) |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsDragging |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfIsolines |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RawGeometry |
 | RegenAbort |
 | RegenType |
 | SubEntityTraits |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | CommonDraw
 |  |  |  |  | ViewportDraw
 |  |  |  |  | WorldDraw


Context Property

Context Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw »Context
Declaration Syntax
C# Visual Basic Visual C++
public abstract Context Context { get; }
Public MustOverride ReadOnly Property Context As Context
    Get
public:
virtual property Context^ Context {
    Context^ get () abstract;
}


Deviation Method (deviationType, pointOnCurve)

Deviation Method (deviationType, pointOnCurve)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw »Deviation(DeviationType, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract double Deviation(
    DeviationType deviationType,
    Point3d pointOnCurve
)
Public MustOverride Function Deviation ( _
    deviationType As DeviationType, _
    pointOnCurve As Point3d _
) As Double
public:
virtual double Deviation(
    DeviationType deviationType,
    Point3d pointOnCurve
) abstract
Parameters
deviationType(DeviationType)
pointOnCurve(Point3d)


IsDragging Property

IsDragging Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw »IsDragging
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsDragging { get; }
Public MustOverride ReadOnly Property IsDragging As Boolean
    Get
public:
virtual property bool IsDragging {
    bool get () abstract;
}


NumberOfIsolines Property

NumberOfIsolines Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw »NumberOfIsolines
Declaration Syntax
C# Visual Basic Visual C++
public abstract int NumberOfIsolines { get; }
Public MustOverride ReadOnly Property NumberOfIsolines As Integer
    Get
public:
virtual property int NumberOfIsolines {
    int get () abstract;
}


RawGeometry Property

RawGeometry Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw »RawGeometry
Declaration Syntax
C# Visual Basic Visual C++
public abstract Geometry RawGeometry { get; }
Public MustOverride ReadOnly Property RawGeometry As Geometry
    Get
public:
virtual property Geometry^ RawGeometry {
    Geometry^ get () abstract;
}


RegenAbort Property

RegenAbort Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw »RegenAbort
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool RegenAbort { get; }
Public MustOverride ReadOnly Property RegenAbort As Boolean
    Get
public:
virtual property bool RegenAbort {
    bool get () abstract;
}


RegenType Property

RegenType Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw »RegenType
Declaration Syntax
C# Visual Basic Visual C++
public abstract RegenType RegenType { get; }
Public MustOverride ReadOnly Property RegenType As RegenType
    Get
public:
virtual property RegenType RegenType {
    RegenType get () abstract;
}


SubEntityTraits Property

SubEntityTraits Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw »SubEntityTraits
Declaration Syntax
C# Visual Basic Visual C++
public abstract SubEntityTraits SubEntityTraits { get; }
Public MustOverride ReadOnly Property SubEntityTraits As SubEntityTraits
    Get
public:
virtual property SubEntityTraits^ SubEntityTraits {
    SubEntityTraits^ get () abstract;
}


Context Class

Context Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiContext")]
public abstract class Context : RXObject
<WrapperAttribute("ZcGiContext")> _
Public MustInherit Class Context _
    Inherits RXObject
[WrapperAttribute(L"ZcGiContext")]
public ref class Context abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Context(IntPtr, Boolean) |
 | Context()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | ByBlockLineWeight |
 | ByBlockPlotStyleNameId |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Database |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DisableFastMoveDrag()()()() |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EffectiveColor |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsBoundaryClipping |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsNesting |
 | IsPlotGeneration |
 | IsPostScriptOut |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SupportsTrueTypeText |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Context


Context Constructor

Context Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »Context()()()()
Members
Icon | Member | Description
 | Context(IntPtr, Boolean) |
 | Context()()()() |


Context Constructor

Context Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »Context()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected Context()
Protected Sub New
protected:
Context()


Context Constructor (unmanagedPointer, autoDelete)

Context Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »Context(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected Context(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
Context(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ByBlockLineWeight Property

ByBlockLineWeight Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »ByBlockLineWeight
Declaration Syntax
C# Visual Basic Visual C++
public virtual LineWeight ByBlockLineWeight { get; }
Public Overridable ReadOnly Property ByBlockLineWeight As LineWeight
    Get
public:
virtual property LineWeight ByBlockLineWeight {
    LineWeight get ();
}


ByBlockPlotStyleNameId Property

ByBlockPlotStyleNameId Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »ByBlockPlotStyleNameId
Declaration Syntax
C# Visual Basic Visual C++
public virtual ObjectId ByBlockPlotStyleNameId { get; }
Public Overridable ReadOnly Property ByBlockPlotStyleNameId As ObjectId
    Get
public:
virtual property ObjectId ByBlockPlotStyleNameId {
    ObjectId get ();
}


Database Property

Database Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »Database
Declaration Syntax
C# Visual Basic Visual C++
public abstract Database Database { get; }
Public MustOverride ReadOnly Property Database As Database
    Get
public:
virtual property Database^ Database {
    Database^ get () abstract;
}


DisableFastMoveDrag Method

DisableFastMoveDrag Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »DisableFastMoveDrag()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DisableFastMoveDrag()
Public Overridable Sub DisableFastMoveDrag
public:
virtual void DisableFastMoveDrag()


EffectiveColor Property

EffectiveColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »EffectiveColor
Declaration Syntax
C# Visual Basic Visual C++
public virtual EntityColor EffectiveColor { get; }
Public Overridable ReadOnly Property EffectiveColor As EntityColor
    Get
public:
virtual property EntityColor EffectiveColor {
    EntityColor get ();
}


IsBoundaryClipping Property

IsBoundaryClipping Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »IsBoundaryClipping
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsBoundaryClipping { get; }
Public MustOverride ReadOnly Property IsBoundaryClipping As Boolean
    Get
public:
virtual property bool IsBoundaryClipping {
    bool get () abstract;
}


IsNesting Property

IsNesting Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »IsNesting
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsNesting { get; }
Public Overridable ReadOnly Property IsNesting As Boolean
    Get
public:
virtual property bool IsNesting {
    bool get ();
}


IsPlotGeneration Property

IsPlotGeneration Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »IsPlotGeneration
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsPlotGeneration { get; }
Public MustOverride ReadOnly Property IsPlotGeneration As Boolean
    Get
public:
virtual property bool IsPlotGeneration {
    bool get () abstract;
}


IsPostScriptOut Property

IsPostScriptOut Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »IsPostScriptOut
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsPostScriptOut { get; }
Public MustOverride ReadOnly Property IsPostScriptOut As Boolean
    Get
public:
virtual property bool IsPostScriptOut {
    bool get () abstract;
}


SupportsTrueTypeText Property

SupportsTrueTypeText Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »SupportsTrueTypeText
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool SupportsTrueTypeText { get; }
Public Overridable ReadOnly Property SupportsTrueTypeText As Boolean
    Get
public:
virtual property bool SupportsTrueTypeText {
    bool get ();
}


DeviationType Enumeration

DeviationType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DeviationType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiDeviationType")]
public enum DeviationType
<WrapperAttribute("ZcGiDeviationType")> _
Public Enumeration DeviationType
[WrapperAttribute(L"ZcGiDeviationType")]
public enum class DeviationType
Members
Member | Description
MaxDevForIsoline |
MaxDevForFacet |
MaxDevForCurve |
MaxDevForCircle |
MaxDevForBoundary |


DiagnosticBSPMode Enumeration

DiagnosticBSPMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DiagnosticBSPMode
Declaration Syntax
C# Visual Basic Visual C++
public enum DiagnosticBSPMode
Public Enumeration DiagnosticBSPMode
public enum class DiagnosticBSPMode
Members
Member | Description
Depth |
Size |


DiagnosticGridMode Enumeration

DiagnosticGridMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DiagnosticGridMode
Declaration Syntax
C# Visual Basic Visual C++
public enum DiagnosticGridMode
Public Enumeration DiagnosticGridMode
public enum class DiagnosticGridMode
Members
Member | Description
Camera |
World |
Object |


DiagnosticMode Enumeration

DiagnosticMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DiagnosticMode
Declaration Syntax
C# Visual Basic Visual C++
public enum DiagnosticMode
Public Enumeration DiagnosticMode
public enum class DiagnosticMode
Members
Member | Description
BSP |
Samples |
Photon |
Grid |
Off |


DiagnosticPhotonMode Enumeration

DiagnosticPhotonMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DiagnosticPhotonMode
Declaration Syntax
C# Visual Basic Visual C++
public enum DiagnosticPhotonMode
Public Enumeration DiagnosticPhotonMode
public enum class DiagnosticPhotonMode
Members
Member | Description
Irradiance |
Density |


DisplaySettings Enumeration

DisplaySettings Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplaySettings
Declaration Syntax
C# Visual Basic Visual C++
public enum DisplaySettings
Public Enumeration DisplaySettings
public enum class DisplaySettings
Members
Member | Description
Textures |
Materials |
Lighting |
Backgrounds |
None |


DisplayStyle Class

DisplayStyle Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplayStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiDisplayStyle")]
public sealed class DisplayStyle : RXObject,
    ICloneable
<WrapperAttribute("ZcGiDisplayStyle")> _
Public NotInheritable Class DisplayStyle _
    Inherits RXObject _
    Implements ICloneable
[WrapperAttribute(L"ZcGiDisplayStyle")]
public ref class DisplayStyle sealed : public RXObject,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisplayStyle()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Brightness |
 | Clone()()()() |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DisplaySettings |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICloneable..::..Clone()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Set(DisplayStyle) |
 | ShadowType |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DisplayStyle


DisplayStyle Constructor

DisplayStyle Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplayStyle »DisplayStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisplayStyle()
Public Sub New
public:
DisplayStyle()


Brightness Property

Brightness Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplayStyle »Brightness
Declaration Syntax
C# Visual Basic Visual C++
public double Brightness { get; set; }
Public Property Brightness As Double
    Get
    Set
public:
property double Brightness {
    double get ();
    void set (double value);
}


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplayStyle »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisplayStyle Clone()
Public Function Clone As DisplayStyle
public:
DisplayStyle^ Clone()


DisplaySettings Property

DisplaySettings Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplayStyle »DisplaySettings
Declaration Syntax
C# Visual Basic Visual C++
public DisplaySettings DisplaySettings { get; set; }
Public Property DisplaySettings As DisplaySettings
    Get
    Set
public:
property DisplaySettings DisplaySettings {
    DisplaySettings get ();
    void set (DisplaySettings value);
}


ICloneable_Clone Method

ICloneable_Clone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplayStyle »ICloneable..::..Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
Object ICloneable.Clone()
Private Function ICloneable_Clone As Object
    Implements ICloneable.Clone
private:
virtual Object^ ICloneable_Clone() sealed = ICloneable::Clone


Set Method (style)

Set Method (style)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplayStyle »Set(DisplayStyle)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    DisplayStyle style
)
Public Sub Set ( _
    style As DisplayStyle _
)
public:
void Set(
    DisplayStyle^ style
)
Parameters
style(DisplayStyle)


ShadowType Property

ShadowType Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplayStyle »ShadowType
Declaration Syntax
C# Visual Basic Visual C++
public ShadowDisplayType ShadowType { get; set; }
Public Property ShadowType As ShadowDisplayType
    Get
    Set
public:
property ShadowDisplayType ShadowType {
    ShadowDisplayType get ();
    void set (ShadowDisplayType value);
}


Drawable Class

Drawable Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcGiDrawable")]
public abstract class Drawable : RXObject
<WrapperAttribute("AcGiDrawable")> _
Public MustInherit Class Drawable _
    Inherits RXObject
[WrapperAttribute(L"AcGiDrawable")]
public ref class Drawable abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Drawable(IntPtr, Boolean) |
 | Drawable()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Bounds |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | drawableType |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsPersistent |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SetAttributes(DrawableTraits) |
 | SubSetAttributes(DrawableTraits) |
 | SubViewportDraw(ViewportDraw) |
 | SubViewportDrawLogicalFlags(ViewportDraw) |
 | SubWorldDraw(WorldDraw) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | ViewportDraw(ViewportDraw) |
 | ViewportDrawLogicalFlags(ViewportDraw) |
 | WorldDraw(WorldDraw) |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Drawable
 |  |  |  |  | DBObject


Drawable Constructor

Drawable Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »Drawable()()()()
Members
Icon | Member | Description
 | Drawable(IntPtr, Boolean) |
 | Drawable()()()() |


Drawable Constructor

Drawable Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »Drawable()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal Drawable()
Protected Friend Sub New
protected public:
Drawable()


Drawable Constructor (unmanagedPointer, autoDelete)

Drawable Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »Drawable(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Drawable(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Drawable(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Bounds Property

Bounds Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »Bounds
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<Extents3d> Bounds { get; }
Public ReadOnly Property Bounds As Nullable(Of Extents3d)
    Get
public:
property Nullable<Extents3d> Bounds {
    Nullable<Extents3d> get ();
}


drawableType Property

drawableType Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »drawableType
Declaration Syntax
C# Visual Basic Visual C++
public DrawableType drawableType { get; }
Public ReadOnly Property drawableType As DrawableType
    Get
public:
property DrawableType drawableType {
    DrawableType get ();
}


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »Id
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId Id { get; }
Public MustOverride ReadOnly Property Id As ObjectId
    Get
public:
virtual property ObjectId Id {
    ObjectId get () abstract;
}


IsPersistent Property

IsPersistent Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »IsPersistent
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsPersistent { get; }
Public MustOverride ReadOnly Property IsPersistent As Boolean
    Get
public:
virtual property bool IsPersistent {
    bool get () abstract;
}


SetAttributes Method (traits)

SetAttributes Method (traits)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »SetAttributes(DrawableTraits)
Declaration Syntax
C# Visual Basic Visual C++
public int SetAttributes(
    DrawableTraits traits
)
Public Function SetAttributes ( _
    traits As DrawableTraits _
) As Integer
public:
int SetAttributes(
    DrawableTraits^ traits
)
Parameters
traits(DrawableTraits)


SubSetAttributes Method (traits)

SubSetAttributes Method (traits)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »SubSetAttributes(DrawableTraits)
Declaration Syntax
C# Visual Basic Visual C++
protected internal abstract int SubSetAttributes(
    DrawableTraits traits
)
Protected Friend MustOverride Function SubSetAttributes ( _
    traits As DrawableTraits _
) As Integer
protected public:
virtual int SubSetAttributes(
    DrawableTraits^ traits
) abstract
Parameters
traits(DrawableTraits)


SubViewportDraw Method (vd)

SubViewportDraw Method (vd)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »SubViewportDraw(ViewportDraw)
Declaration Syntax
C# Visual Basic Visual C++
protected internal abstract void SubViewportDraw(
    ViewportDraw vd
)
Protected Friend MustOverride Sub SubViewportDraw ( _
    vd As ViewportDraw _
)
protected public:
virtual void SubViewportDraw(
    ViewportDraw^ vd
) abstract
Parameters
vd(ViewportDraw)


SubViewportDrawLogicalFlags Method (vd)

SubViewportDrawLogicalFlags Method (vd)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »SubViewportDrawLogicalFlags(ViewportDraw)
Declaration Syntax
C# Visual Basic Visual C++
protected internal abstract int SubViewportDrawLogicalFlags(
    ViewportDraw vd
)
Protected Friend MustOverride Function SubViewportDrawLogicalFlags ( _
    vd As ViewportDraw _
) As Integer
protected public:
virtual int SubViewportDrawLogicalFlags(
    ViewportDraw^ vd
) abstract
Parameters
vd(ViewportDraw)


SubWorldDraw Method (wd)

SubWorldDraw Method (wd)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »SubWorldDraw(WorldDraw)
Declaration Syntax
C# Visual Basic Visual C++
protected internal abstract bool SubWorldDraw(
    WorldDraw wd
)
Protected Friend MustOverride Function SubWorldDraw ( _
    wd As WorldDraw _
) As Boolean
protected public:
virtual bool SubWorldDraw(
    WorldDraw^ wd
) abstract
Parameters
wd(WorldDraw)


ViewportDraw Method (vd)

ViewportDraw Method (vd)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »ViewportDraw(ViewportDraw)
Declaration Syntax
C# Visual Basic Visual C++
public void ViewportDraw(
    ViewportDraw vd
)
Public Sub ViewportDraw ( _
    vd As ViewportDraw _
)
public:
void ViewportDraw(
    ViewportDraw^ vd
)
Parameters
vd(ViewportDraw)


ViewportDrawLogicalFlags Method (vd)

ViewportDrawLogicalFlags Method (vd)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »ViewportDrawLogicalFlags(ViewportDraw)
Declaration Syntax
C# Visual Basic Visual C++
public int ViewportDrawLogicalFlags(
    ViewportDraw vd
)
Public Function ViewportDrawLogicalFlags ( _
    vd As ViewportDraw _
) As Integer
public:
int ViewportDrawLogicalFlags(
    ViewportDraw^ vd
)
Parameters
vd(ViewportDraw)


WorldDraw Method (wd)

WorldDraw Method (wd)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »WorldDraw(WorldDraw)
Declaration Syntax
C# Visual Basic Visual C++
public bool WorldDraw(
    WorldDraw wd
)
Public Function WorldDraw ( _
    wd As WorldDraw _
) As Boolean
public:
bool WorldDraw(
    WorldDraw^ wd
)
Parameters
wd(WorldDraw)


DrawableTraits Class

DrawableTraits Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableTraits
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcGiDrawableTraits")]
public abstract class DrawableTraits : RXObject
<WrapperAttribute("AcGiDrawableTraits")> _
Public MustInherit Class DrawableTraits _
    Inherits RXObject
[WrapperAttribute(L"AcGiDrawableTraits")]
public ref class DrawableTraits abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DrawableTraits(IntPtr, Boolean) |
 | DrawableTraits()()()() |
 | AddLight(ObjectId) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SetLayerFlags(DrawableTraits..::..LayerFlags) |
 | SetupForEntity(Entity) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DrawableTraits
 |  |  |  |  | SubEntityTraits


DrawableTraits Constructor

DrawableTraits Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableTraits »DrawableTraits()()()()
Members
Icon | Member | Description
 | DrawableTraits(IntPtr, Boolean) |
 | DrawableTraits()()()() |


DrawableTraits Constructor

DrawableTraits Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableTraits »DrawableTraits()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected DrawableTraits()
Protected Sub New
protected:
DrawableTraits()


DrawableTraits Constructor (unmanagedPointer, autoDelete)

DrawableTraits Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableTraits »DrawableTraits(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected DrawableTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
DrawableTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AddLight Method (lightId)

AddLight Method (lightId)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableTraits »AddLight(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void AddLight(
    ObjectId lightId
)
Public MustOverride Sub AddLight ( _
    lightId As ObjectId _
)
public:
virtual void AddLight(
    ObjectId lightId
) abstract
Parameters
lightId(ObjectId)


SetLayerFlags Method (flags)

SetLayerFlags Method (flags)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableTraits »SetLayerFlags(DrawableTraits..::..LayerFlags)
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void SetLayerFlags(
    DrawableTraits..::..LayerFlags flags
)
Protected MustOverride Sub SetLayerFlags ( _
    flags As DrawableTraits..::..LayerFlags _
)
protected:
virtual void SetLayerFlags(
    DrawableTraits..::..LayerFlags flags
) abstract
Parameters
flags(DrawableTraits..::..LayerFlags)


SetupForEntity Method (entity)

SetupForEntity Method (entity)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableTraits »SetupForEntity(Entity)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void SetupForEntity(
    Entity entity
)
Public MustOverride Sub SetupForEntity ( _
    entity As Entity _
)
public:
virtual void SetupForEntity(
    Entity^ entity
) abstract
Parameters
entity(Entity)


DrawableTraits.LayerFlags Enumeration

DrawableTraits..::..LayerFlags Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableTraits »DrawableTraits..::..LayerFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
[WrapperAttribute("ZcGiDrawableTraits::LayerFlags")]
protected enum LayerFlags
<FlagsAttribute> _
<WrapperAttribute("ZcGiDrawableTraits::LayerFlags")> _
Protected Enumeration LayerFlags
[FlagsAttribute]
[WrapperAttribute(L"ZcGiDrawableTraits::LayerFlags")]
protected enum class LayerFlags
Members
Member | Description
Off |
None |
Frozen |
Zero |


DrawableType Enumeration

DrawableType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("DrawableType")]
public enum DrawableType
<WrapperAttribute("DrawableType")> _
Public Enumeration DrawableType
[WrapperAttribute(L"DrawableType")]
public enum class DrawableType
Members
Member | Description
SkyBackground |
WebLight |
Viewport |
GroundPlaneBackground |
ImageBackground |
GradientBackground |
SolidBackground |
AmbientLight |
SpotLight |
PointLight |
DistantLight |
Geometry |


EdgeData Class

EdgeData Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiEdgeData")]
public class EdgeData
<WrapperAttribute("ZcGiEdgeData")> _
Public Class EdgeData
[WrapperAttribute(L"ZcGiEdgeData")]
public ref class EdgeData
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetColors()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLayers()()()() |
 | GetLineTypes()()()() |
 | GetSelectionMarkers()()()() |
 | GetTrueColors()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GetVisibility()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetColors(array<Int16>[]()[][]) |
 | SetLayers(array<ObjectId>[]()[][]) |
 | SetLineTypes(array<ObjectId>[]()[][]) |
 | SetSelectionMarkers(array<IntPtr>[]()[][]) |
 | SetTrueColors(array<EntityColor>[]()[][]) |
 | SetVisibility(array<Byte>[]()[][]) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
EdgeData


GetColors Method

GetColors Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »GetColors()()()()
Declaration Syntax
C# Visual Basic Visual C++
public short[] GetColors()
Public Function GetColors As Short()
public:
array<short>^ GetColors()


GetLayers Method

GetLayers Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »GetLayers()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId[] GetLayers()
Public Function GetLayers As ObjectId()
public:
array<ObjectId>^ GetLayers()


GetLineTypes Method

GetLineTypes Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »GetLineTypes()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId[] GetLineTypes()
Public Function GetLineTypes As ObjectId()
public:
array<ObjectId>^ GetLineTypes()


GetSelectionMarkers Method

GetSelectionMarkers Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »GetSelectionMarkers()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr[] GetSelectionMarkers()
Public Function GetSelectionMarkers As IntPtr()
public:
array<IntPtr>^ GetSelectionMarkers()


GetTrueColors Method

GetTrueColors Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »GetTrueColors()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor[] GetTrueColors()
Public Function GetTrueColors As EntityColor()
public:
array<EntityColor>^ GetTrueColors()


GetVisibility Method

GetVisibility Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »GetVisibility()()()()
Declaration Syntax
C# Visual Basic Visual C++
public byte[] GetVisibility()
Public Function GetVisibility As Byte()
public:
array<unsigned char>^ GetVisibility()


SetColors Method (colors)

SetColors Method (colors)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »SetColors(array<Int16>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetColors(
    short[] colors
)
Public Sub SetColors ( _
    colors As Short() _
)
public:
void SetColors(
    array<short>^ colors
)
Parameters
colors(array<Int16>[]()[][])


SetLayers Method (layers)

SetLayers Method (layers)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »SetLayers(array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayers(
    ObjectId[] layers
)
Public Sub SetLayers ( _
    layers As ObjectId() _
)
public:
void SetLayers(
    array<ObjectId>^ layers
)
Parameters
layers(array< ObjectId >[]()[][])


SetLineTypes Method (lineTypes)

SetLineTypes Method (lineTypes)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »SetLineTypes(array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetLineTypes(
    ObjectId[] lineTypes
)
Public Sub SetLineTypes ( _
    lineTypes As ObjectId() _
)
public:
void SetLineTypes(
    array<ObjectId>^ lineTypes
)
Parameters
lineTypes(array< ObjectId >[]()[][])


SetSelectionMarkers Method (selectionMarkers)

SetSelectionMarkers Method (selectionMarkers)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »SetSelectionMarkers(array<IntPtr>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetSelectionMarkers(
    IntPtr[] selectionMarkers
)
Public Sub SetSelectionMarkers ( _
    selectionMarkers As IntPtr() _
)
public:
void SetSelectionMarkers(
    array<IntPtr>^ selectionMarkers
)
Parameters
selectionMarkers(array<IntPtr>[]()[][])


SetTrueColors Method (colors)

SetTrueColors Method (colors)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »SetTrueColors(array<EntityColor>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrueColors(
    EntityColor[] colors
)
Public Sub SetTrueColors ( _
    colors As EntityColor() _
)
public:
void SetTrueColors(
    array<EntityColor>^ colors
)
Parameters
colors(array< EntityColor >[]()[][])


SetVisibility Method (visibility)

SetVisibility Method (visibility)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeData »SetVisibility(array<Byte>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetVisibility(
    byte[] visibility
)
Public Sub SetVisibility ( _
    visibility As Byte() _
)
public:
void SetVisibility(
    array<unsigned char>^ visibility
)
Parameters
visibility(array<Byte>[]()[][])


EdgeModel Enumeration

EdgeModel Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeModel
Declaration Syntax
C# Visual Basic Visual C++
public enum EdgeModel
Public Enumeration EdgeModel
public enum class EdgeModel
Members
Member | Description
FacetEdges |
Isolines |
NoEdges |


EdgeModifiers Enumeration

EdgeModifiers Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeModifiers
Declaration Syntax
C# Visual Basic Visual C++
public enum EdgeModifiers
Public Enumeration EdgeModifiers
public enum class EdgeModifiers
Members
Member | Description
Opacity |
AlwaysOnTop |
HaloGap |
Width |
Jitter |
Overhang |
None |
Color |


EdgeStyle Class

EdgeStyle Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiEdgeStyle")]
public sealed class EdgeStyle : RXObject,
    ICloneable
<WrapperAttribute("ZcGiEdgeStyle")> _
Public NotInheritable Class EdgeStyle _
    Inherits RXObject _
    Implements ICloneable
[WrapperAttribute(L"ZcGiEdgeStyle")]
public ref class EdgeStyle sealed : public RXObject,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EdgeStyle()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreaseAngle |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EdgeColor |
 | EdgeModel |
 | EdgeModifiers |
 | EdgeStyleApply |
 | EdgeVisibility |
 | EdgeWidth |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | HaloGap |
 | HidePrecision |
 | ICloneable..::..Clone()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IntersectionColor |
 | IntersectionLinetype |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Isolines |
 | Jitter |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObscuredColor |
 | ObscuredLinetype |
 | Opacity |
 | Overhang |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Set(EdgeStyle) |
 | SilhouetteColor |
 | SilhouetteWidth |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | EdgeStyle


EdgeStyle Constructor

EdgeStyle Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »EdgeStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EdgeStyle()
Public Sub New
public:
EdgeStyle()


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EdgeStyle Clone()
Public Function Clone As EdgeStyle
public:
EdgeStyle^ Clone()


CreaseAngle Property

CreaseAngle Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »CreaseAngle
Declaration Syntax
C# Visual Basic Visual C++
public double CreaseAngle { get; set; }
Public Property CreaseAngle As Double
    Get
    Set
public:
property double CreaseAngle {
    double get ();
    void set (double value);
}


EdgeColor Property

EdgeColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »EdgeColor
Declaration Syntax
C# Visual Basic Visual C++
public Color EdgeColor { get; set; }
Public Property EdgeColor As Color
    Get
    Set
public:
property Color^ EdgeColor {
    Color^ get ();
    void set (Color^ value);
}


EdgeModel Property

EdgeModel Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »EdgeModel
Declaration Syntax
C# Visual Basic Visual C++
public EdgeModel EdgeModel { get; set; }
Public Property EdgeModel As EdgeModel
    Get
    Set
public:
property EdgeModel EdgeModel {
    EdgeModel get ();
    void set (EdgeModel value);
}


EdgeModifiers Property

EdgeModifiers Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »EdgeModifiers
Declaration Syntax
C# Visual Basic Visual C++
public EdgeModifiers EdgeModifiers { get; set; }
Public Property EdgeModifiers As EdgeModifiers
    Get
    Set
public:
property EdgeModifiers EdgeModifiers {
    EdgeModifiers get ();
    void set (EdgeModifiers value);
}


EdgeStyleApply Property

EdgeStyleApply Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »EdgeStyleApply
Declaration Syntax
C# Visual Basic Visual C++
public EdgeStyleApply EdgeStyleApply { get; set; }
Public Property EdgeStyleApply As EdgeStyleApply
    Get
    Set
public:
property EdgeStyleApply EdgeStyleApply {
    EdgeStyleApply get ();
    void set (EdgeStyleApply value);
}


EdgeVisibility Property

EdgeVisibility Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »EdgeVisibility
Declaration Syntax
C# Visual Basic Visual C++
public EdgeVisibilityModes EdgeVisibility { get; set; }
Public Property EdgeVisibility As EdgeVisibilityModes
    Get
    Set
public:
property EdgeVisibilityModes EdgeVisibility {
    EdgeVisibilityModes get ();
    void set (EdgeVisibilityModes value);
}


EdgeWidth Property

EdgeWidth Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »EdgeWidth
Declaration Syntax
C# Visual Basic Visual C++
public int EdgeWidth { get; set; }
Public Property EdgeWidth As Integer
    Get
    Set
public:
property int EdgeWidth {
    int get ();
    void set (int value);
}


HaloGap Property

HaloGap Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »HaloGap
Declaration Syntax
C# Visual Basic Visual C++
public int HaloGap { get; set; }
Public Property HaloGap As Integer
    Get
    Set
public:
property int HaloGap {
    int get ();
    void set (int value);
}


HidePrecision Property

HidePrecision Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »HidePrecision
Declaration Syntax
C# Visual Basic Visual C++
public bool HidePrecision { get; set; }
Public Property HidePrecision As Boolean
    Get
    Set
public:
property bool HidePrecision {
    bool get ();
    void set (bool value);
}


ICloneable_Clone Method

ICloneable_Clone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »ICloneable..::..Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
Object ICloneable.Clone()
Private Function ICloneable_Clone As Object
    Implements ICloneable.Clone
private:
virtual Object^ ICloneable_Clone() sealed = ICloneable::Clone


IntersectionColor Property

IntersectionColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »IntersectionColor
Declaration Syntax
C# Visual Basic Visual C++
public Color IntersectionColor { get; set; }
Public Property IntersectionColor As Color
    Get
    Set
public:
property Color^ IntersectionColor {
    Color^ get ();
    void set (Color^ value);
}


IntersectionLinetype Property

IntersectionLinetype Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »IntersectionLinetype
Declaration Syntax
C# Visual Basic Visual C++
public Linetype IntersectionLinetype { get; set; }
Public Property IntersectionLinetype As Linetype
    Get
    Set
public:
property Linetype IntersectionLinetype {
    Linetype get ();
    void set (Linetype value);
}


Isolines Property

Isolines Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »Isolines
Declaration Syntax
C# Visual Basic Visual C++
public short Isolines { get; set; }
Public Property Isolines As Short
    Get
    Set
public:
property short Isolines {
    short get ();
    void set (short value);
}


Jitter Property

Jitter Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »Jitter
Declaration Syntax
C# Visual Basic Visual C++
public JitterAmount Jitter { get; set; }
Public Property Jitter As JitterAmount
    Get
    Set
public:
property JitterAmount Jitter {
    JitterAmount get ();
    void set (JitterAmount value);
}


ObscuredColor Property

ObscuredColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »ObscuredColor
Declaration Syntax
C# Visual Basic Visual C++
public Color ObscuredColor { get; set; }
Public Property ObscuredColor As Color
    Get
    Set
public:
property Color^ ObscuredColor {
    Color^ get ();
    void set (Color^ value);
}


ObscuredLinetype Property

ObscuredLinetype Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »ObscuredLinetype
Declaration Syntax
C# Visual Basic Visual C++
public Linetype ObscuredLinetype { get; set; }
Public Property ObscuredLinetype As Linetype
    Get
    Set
public:
property Linetype ObscuredLinetype {
    Linetype get ();
    void set (Linetype value);
}


Opacity Property

Opacity Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »Opacity
Declaration Syntax
C# Visual Basic Visual C++
public double Opacity { get; set; }
Public Property Opacity As Double
    Get
    Set
public:
property double Opacity {
    double get ();
    void set (double value);
}


Overhang Property

Overhang Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »Overhang
Declaration Syntax
C# Visual Basic Visual C++
public int Overhang { get; set; }
Public Property Overhang As Integer
    Get
    Set
public:
property int Overhang {
    int get ();
    void set (int value);
}


Set Method (style)

Set Method (style)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »Set(EdgeStyle)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    EdgeStyle style
)
Public Sub Set ( _
    style As EdgeStyle _
)
public:
void Set(
    EdgeStyle^ style
)
Parameters
style(EdgeStyle)


SilhouetteColor Property

SilhouetteColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »SilhouetteColor
Declaration Syntax
C# Visual Basic Visual C++
public Color SilhouetteColor { get; set; }
Public Property SilhouetteColor As Color
    Get
    Set
public:
property Color^ SilhouetteColor {
    Color^ get ();
    void set (Color^ value);
}


SilhouetteWidth Property

SilhouetteWidth Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »SilhouetteWidth
Declaration Syntax
C# Visual Basic Visual C++
public int SilhouetteWidth { get; set; }
Public Property SilhouetteWidth As Integer
    Get
    Set
public:
property int SilhouetteWidth {
    int get ();
    void set (int value);
}


EdgeStyleApply Enumeration

EdgeStyleApply Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyleApply
Declaration Syntax
C# Visual Basic Visual C++
public enum EdgeStyleApply
Public Enumeration EdgeStyleApply
public enum class EdgeStyleApply
Members
Member | Description
ApplyToAll |
ApplyToDefault |


EdgeVisibilityModes Enumeration

EdgeVisibilityModes Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeVisibilityModes
Declaration Syntax
C# Visual Basic Visual C++
public enum EdgeVisibilityModes
Public Enumeration EdgeVisibilityModes
public enum class EdgeVisibilityModes
Members
Member | Description
Intersection |
Obscured |
Silhouette |
Visible |
None |


ExposureType Enumeration

ExposureType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ExposureType
Declaration Syntax
C# Visual Basic Visual C++
public enum ExposureType
Public Enumeration ExposureType
public enum class ExposureType
Members
Member | Description
Logarithmic |
Automatic |


ExtendedLightShape Enumeration

ExtendedLightShape Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ExtendedLightShape
Declaration Syntax
C# Visual Basic Visual C++
public enum ExtendedLightShape
Public Enumeration ExtendedLightShape
public enum class ExtendedLightShape
Members
Member | Description
Sphere |
Cylinder |
Disk |
Linear |
Rectangle |


FaceColorMode Enumeration

FaceColorMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceColorMode
Declaration Syntax
C# Visual Basic Visual C++
public enum FaceColorMode
Public Enumeration FaceColorMode
public enum class FaceColorMode
Members
Member | Description
Desaturate |
Tint |
Mono |
BackgroundColor |
ObjectColor |
None |


FaceData Class

FaceData Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiFaceData")]
public sealed class FaceData
<WrapperAttribute("ZcGiFaceData")> _
Public NotInheritable Class FaceData
[WrapperAttribute(L"ZcGiFaceData")]
public ref class FaceData sealed
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FaceData()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetColors()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLayers()()()() |
 | GetMappers()()()() |
 | GetMaterials()()()() |
 | GetNormalVectors()()()() |
 | GetSelectionMarkers()()()() |
 | GetTransparency()()()() |
 | GetTrueColors()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GetVisibility()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetColors(array<Int16>[]()[][]) |
 | SetLayers(array<ObjectId>[]()[][]) |
 | SetMappers(array<Mapper>[]()[][]) |
 | SetMaterials(array<ObjectId>[]()[][]) |
 | SetNormalVectors(array<Vector3d>[]()[][]) |
 | SetSelectionMarkers(array<IntPtr>[]()[][]) |
 | SetTransparency(array<Transparency>[]()[][]) |
 | SetTrueColors(array<EntityColor>[]()[][]) |
 | SetVisibility(array<Byte>[]()[][]) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
FaceData


FaceData Constructor

FaceData Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »FaceData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FaceData()
Public Sub New
public:
FaceData()


GetColors Method

GetColors Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »GetColors()()()()
Declaration Syntax
C# Visual Basic Visual C++
public short[] GetColors()
Public Function GetColors As Short()
public:
array<short>^ GetColors()


GetLayers Method

GetLayers Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »GetLayers()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId[] GetLayers()
Public Function GetLayers As ObjectId()
public:
array<ObjectId>^ GetLayers()


GetMappers Method

GetMappers Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »GetMappers()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Mapper[] GetMappers()
Public Function GetMappers As Mapper()
public:
array<Mapper^>^ GetMappers()


GetMaterials Method

GetMaterials Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »GetMaterials()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId[] GetMaterials()
Public Function GetMaterials As ObjectId()
public:
array<ObjectId>^ GetMaterials()


GetNormalVectors Method

GetNormalVectors Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »GetNormalVectors()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d[] GetNormalVectors()
Public Function GetNormalVectors As Vector3d()
public:
array<Vector3d>^ GetNormalVectors()


GetSelectionMarkers Method

GetSelectionMarkers Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »GetSelectionMarkers()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr[] GetSelectionMarkers()
Public Function GetSelectionMarkers As IntPtr()
public:
array<IntPtr>^ GetSelectionMarkers()


GetTransparency Method

GetTransparency Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »GetTransparency()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Transparency[] GetTransparency()
Public Function GetTransparency As Transparency()
public:
array<Transparency>^ GetTransparency()


GetTrueColors Method

GetTrueColors Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »GetTrueColors()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor[] GetTrueColors()
Public Function GetTrueColors As EntityColor()
public:
array<EntityColor>^ GetTrueColors()


GetVisibility Method

GetVisibility Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »GetVisibility()()()()
Declaration Syntax
C# Visual Basic Visual C++
public byte[] GetVisibility()
Public Function GetVisibility As Byte()
public:
array<unsigned char>^ GetVisibility()


SetColors Method (colors)

SetColors Method (colors)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »SetColors(array<Int16>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetColors(
    short[] colors
)
Public Sub SetColors ( _
    colors As Short() _
)
public:
void SetColors(
    array<short>^ colors
)
Parameters
colors(array<Int16>[]()[][])


SetLayers Method (layers)

SetLayers Method (layers)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »SetLayers(array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayers(
    ObjectId[] layers
)
Public Sub SetLayers ( _
    layers As ObjectId() _
)
public:
void SetLayers(
    array<ObjectId>^ layers
)
Parameters
layers(array< ObjectId >[]()[][])


SetMappers Method (mappers)

SetMappers Method (mappers)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »SetMappers(array<Mapper>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetMappers(
    Mapper[] mappers
)
Public Sub SetMappers ( _
    mappers As Mapper() _
)
public:
void SetMappers(
    array<Mapper^>^ mappers
)
Parameters
mappers(array< Mapper >[]()[][])


SetMaterials Method (materials)

SetMaterials Method (materials)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »SetMaterials(array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetMaterials(
    ObjectId[] materials
)
Public Sub SetMaterials ( _
    materials As ObjectId() _
)
public:
void SetMaterials(
    array<ObjectId>^ materials
)
Parameters
materials(array< ObjectId >[]()[][])


SetNormalVectors Method (normal)

SetNormalVectors Method (normal)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »SetNormalVectors(array<Vector3d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetNormalVectors(
    Vector3d[] normal
)
Public Sub SetNormalVectors ( _
    normal As Vector3d() _
)
public:
void SetNormalVectors(
    array<Vector3d>^ normal
)
Parameters
normal(array< Vector3d >[]()[][])


SetSelectionMarkers Method (selectionMarker)

SetSelectionMarkers Method (selectionMarker)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »SetSelectionMarkers(array<IntPtr>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetSelectionMarkers(
    IntPtr[] selectionMarker
)
Public Sub SetSelectionMarkers ( _
    selectionMarker As IntPtr() _
)
public:
void SetSelectionMarkers(
    array<IntPtr>^ selectionMarker
)
Parameters
selectionMarker(array<IntPtr>[]()[][])


SetTransparency Method (transparency)

SetTransparency Method (transparency)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »SetTransparency(array<Transparency>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetTransparency(
    Transparency[] transparency
)
Public Sub SetTransparency ( _
    transparency As Transparency() _
)
public:
void SetTransparency(
    array<Transparency>^ transparency
)
Parameters
transparency(array< Transparency >[]()[][])


SetTrueColors Method (colors)

SetTrueColors Method (colors)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »SetTrueColors(array<EntityColor>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrueColors(
    EntityColor[] colors
)
Public Sub SetTrueColors ( _
    colors As EntityColor() _
)
public:
void SetTrueColors(
    array<EntityColor>^ colors
)
Parameters
colors(array< EntityColor >[]()[][])


SetVisibility Method (visibility)

SetVisibility Method (visibility)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceData »SetVisibility(array<Byte>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetVisibility(
    byte[] visibility
)
Public Sub SetVisibility ( _
    visibility As Byte() _
)
public:
void SetVisibility(
    array<unsigned char>^ visibility
)
Parameters
visibility(array<Byte>[]()[][])


FaceModifiers Enumeration

FaceModifiers Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceModifiers
Declaration Syntax
C# Visual Basic Visual C++
public enum FaceModifiers
Public Enumeration FaceModifiers
public enum class FaceModifiers
Members
Member | Description
Specular |
Opacity |
None |


FaceStyle Class

FaceStyle Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiFaceStyle")]
public sealed class FaceStyle : RXObject,
    ICloneable
<WrapperAttribute("ZcGiFaceStyle")> _
Public NotInheritable Class FaceStyle _
    Inherits RXObject _
    Implements ICloneable
[WrapperAttribute(L"ZcGiFaceStyle")]
public ref class FaceStyle sealed : public RXObject,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FaceStyle()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | FaceColorMode |
 | FaceModifiers |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICloneable..::..Clone()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | LightingModel |
 | LightingQuality |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MonoColor |
 | Opacity |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Set(FaceStyle) |
 | SpecularHighlight |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | FaceStyle


FaceStyle Constructor

FaceStyle Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »FaceStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FaceStyle()
Public Sub New
public:
FaceStyle()


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FaceStyle Clone()
Public Function Clone As FaceStyle
public:
FaceStyle^ Clone()


FaceColorMode Property

FaceColorMode Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »FaceColorMode
Declaration Syntax
C# Visual Basic Visual C++
public FaceColorMode FaceColorMode { get; set; }
Public Property FaceColorMode As FaceColorMode
    Get
    Set
public:
property FaceColorMode FaceColorMode {
    FaceColorMode get ();
    void set (FaceColorMode value);
}


FaceModifiers Property

FaceModifiers Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »FaceModifiers
Declaration Syntax
C# Visual Basic Visual C++
public FaceModifiers FaceModifiers { get; set; }
Public Property FaceModifiers As FaceModifiers
    Get
    Set
public:
property FaceModifiers FaceModifiers {
    FaceModifiers get ();
    void set (FaceModifiers value);
}


ICloneable_Clone Method

ICloneable_Clone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »ICloneable..::..Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
Object ICloneable.Clone()
Private Function ICloneable_Clone As Object
    Implements ICloneable.Clone
private:
virtual Object^ ICloneable_Clone() sealed = ICloneable::Clone


LightingModel Property

LightingModel Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »LightingModel
Declaration Syntax
C# Visual Basic Visual C++
public LightingModel LightingModel { get; set; }
Public Property LightingModel As LightingModel
    Get
    Set
public:
property LightingModel LightingModel {
    LightingModel get ();
    void set (LightingModel value);
}


LightingQuality Property

LightingQuality Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »LightingQuality
Declaration Syntax
C# Visual Basic Visual C++
public LightingQuality LightingQuality { get; set; }
Public Property LightingQuality As LightingQuality
    Get
    Set
public:
property LightingQuality LightingQuality {
    LightingQuality get ();
    void set (LightingQuality value);
}


MonoColor Property

MonoColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »MonoColor
Declaration Syntax
C# Visual Basic Visual C++
public Color MonoColor { get; set; }
Public Property MonoColor As Color
    Get
    Set
public:
property Color^ MonoColor {
    Color^ get ();
    void set (Color^ value);
}


Opacity Property

Opacity Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »Opacity
Declaration Syntax
C# Visual Basic Visual C++
public double Opacity { get; set; }
Public Property Opacity As Double
    Get
    Set
public:
property double Opacity {
    double get ();
    void set (double value);
}


Set Method (value)

Set Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »Set(FaceStyle)
Declaration Syntax
C# Visual Basic Visual C++
public void Set(
    FaceStyle value
)
Public Sub Set ( _
    value As FaceStyle _
)
public:
void Set(
    FaceStyle^ value
)
Parameters
value(FaceStyle)


SpecularHighlight Property

SpecularHighlight Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »SpecularHighlight
Declaration Syntax
C# Visual Basic Visual C++
public double SpecularHighlight { get; set; }
Public Property SpecularHighlight As Double
    Get
    Set
public:
property double SpecularHighlight {
    double get ();
    void set (double value);
}


FillType Enumeration

FillType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FillType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiFillType")]
public enum FillType
<WrapperAttribute("ZcGiFillType")> _
Public Enumeration FillType
[WrapperAttribute(L"ZcGiFillType")]
public enum class FillType
Members
Member | Description
FillNever |
FillAlways |


Filter Enumeration

Filter Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Filter
Declaration Syntax
C# Visual Basic Visual C++
public enum Filter
Public Enumeration Filter
public enum class Filter
Members
Member | Description
Lanczos |
Mitchell |
Gauss |
Triangle |
Box |


FinalGatheringMode Enumeration

FinalGatheringMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FinalGatheringMode
Declaration Syntax
C# Visual Basic Visual C++
public enum FinalGatheringMode
Public Enumeration FinalGatheringMode
public enum class FinalGatheringMode
Members
Member | Description
FinalGatherAuto |
FinalGatherOn |
FinalGatherOff |


FinalGatherMode Enumeration

FinalGatherMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FinalGatherMode
Declaration Syntax
C# Visual Basic Visual C++
public enum FinalGatherMode
Public Enumeration FinalGatherMode
public enum class FinalGatherMode
Members
Member | Description
FinalGatherCastAndReceive |
FinalGatherReceive |
FinalGatherCast |
FinalGatherNone |


FontDescriptor Structure

FontDescriptor Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor
Declaration Syntax
C# Visual Basic Visual C++
public struct FontDescriptor
Public Structure FontDescriptor
public value class FontDescriptor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FontDescriptor(String, Boolean, Boolean, Int32, Int32) |
 | Bold |
 | CharacterSet |
 | Equality(FontDescriptor, FontDescriptor) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(FontDescriptor, FontDescriptor) |
 | Italic |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PitchAndFamily |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | TypeFace |


FontDescriptor Constructor (typeFace, bold, italic, characters, pitchAndFamily)

FontDescriptor Constructor (typeFace, bold, italic, characters, pitchAndFamily)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »FontDescriptor(String, Boolean, Boolean, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public FontDescriptor(
    string typeFace,
    bool bold,
    bool italic,
    int characters,
    int pitchAndFamily
)
Public Sub New ( _
    typeFace As String, _
    bold As Boolean, _
    italic As Boolean, _
    characters As Integer, _
    pitchAndFamily As Integer _
)
public:
FontDescriptor(
    String^ typeFace,
    bool bold,
    bool italic,
    int characters,
    int pitchAndFamily
)
Parameters
typeFace(String)
bold(Boolean)
italic(Boolean)
characters(Int32)
pitchAndFamily(Int32)


Bold Property

Bold Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »Bold
Declaration Syntax
C# Visual Basic Visual C++
public bool Bold { get; }
Public ReadOnly Property Bold As Boolean
    Get
public:
property bool Bold {
    bool get ();
}


CharacterSet Property

CharacterSet Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »CharacterSet
Declaration Syntax
C# Visual Basic Visual C++
public int CharacterSet { get; }
Public ReadOnly Property CharacterSet As Integer
    Get
public:
property int CharacterSet {
    int get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »Equality(FontDescriptor, FontDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    FontDescriptor a,
    FontDescriptor b
)
Public Shared Operator = ( _
    a As FontDescriptor, _
    b As FontDescriptor _
) As Boolean
public:
static bool operator ==(
    FontDescriptor a,
    FontDescriptor b
)
Parameters
a(FontDescriptor)
b(FontDescriptor)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »Inequality(FontDescriptor, FontDescriptor)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    FontDescriptor a,
    FontDescriptor b
)
Public Shared Operator <> ( _
    a As FontDescriptor, _
    b As FontDescriptor _
) As Boolean
public:
static bool operator !=(
    FontDescriptor a,
    FontDescriptor b
)
Parameters
a(FontDescriptor)
b(FontDescriptor)


Italic Property

Italic Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »Italic
Declaration Syntax
C# Visual Basic Visual C++
public bool Italic { get; }
Public ReadOnly Property Italic As Boolean
    Get
public:
property bool Italic {
    bool get ();
}


PitchAndFamily Property

PitchAndFamily Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »PitchAndFamily
Declaration Syntax
C# Visual Basic Visual C++
public int PitchAndFamily { get; }
Public ReadOnly Property PitchAndFamily As Integer
    Get
public:
property int PitchAndFamily {
    int get ();
}


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)


TypeFace Property

TypeFace Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FontDescriptor »TypeFace
Declaration Syntax
C# Visual Basic Visual C++
public string TypeFace { get; }
Public ReadOnly Property TypeFace As String
    Get
public:
property String^ TypeFace {
    String^ get ();
}


FrontAndBackClipping Structure

FrontAndBackClipping Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping
Declaration Syntax
C# Visual Basic Visual C++
public struct FrontAndBackClipping
Public Structure FrontAndBackClipping
public value class FrontAndBackClipping
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrontAndBackClipping(Boolean, Boolean, Double, Double) |
 | Back |
 | ClipBack |
 | ClipFront |
 | Equality(FrontAndBackClipping, FrontAndBackClipping) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | Front |
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(FrontAndBackClipping, FrontAndBackClipping) |
 | IsEqualTo(FrontAndBackClipping, Tolerance) |
 | IsEqualTo(FrontAndBackClipping) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)


FrontAndBackClipping Constructor (clipFront, clipBack, front, back)

FrontAndBackClipping Constructor (clipFront, clipBack, front, back)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »FrontAndBackClipping(Boolean, Boolean, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public FrontAndBackClipping(
    bool clipFront,
    bool clipBack,
    double front,
    double back
)
Public Sub New ( _
    clipFront As Boolean, _
    clipBack As Boolean, _
    front As Double, _
    back As Double _
)
public:
FrontAndBackClipping(
    bool clipFront,
    bool clipBack,
    double front,
    double back
)
Parameters
clipFront(Boolean)
clipBack(Boolean)
front(Double)
back(Double)


Back Property

Back Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »Back
Declaration Syntax
C# Visual Basic Visual C++
public double Back { get; }
Public ReadOnly Property Back As Double
    Get
public:
property double Back {
    double get ();
}


ClipBack Property

ClipBack Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »ClipBack
Declaration Syntax
C# Visual Basic Visual C++
public bool ClipBack { get; }
Public ReadOnly Property ClipBack As Boolean
    Get
public:
property bool ClipBack {
    bool get ();
}


ClipFront Property

ClipFront Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »ClipFront
Declaration Syntax
C# Visual Basic Visual C++
public bool ClipFront { get; }
Public ReadOnly Property ClipFront As Boolean
    Get
public:
property bool ClipFront {
    bool get ();
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »Equality(FrontAndBackClipping, FrontAndBackClipping)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    FrontAndBackClipping a,
    FrontAndBackClipping b
)
Public Shared Operator = ( _
    a As FrontAndBackClipping, _
    b As FrontAndBackClipping _
) As Boolean
public:
static bool operator ==(
    FrontAndBackClipping a,
    FrontAndBackClipping b
)
Parameters
a(FrontAndBackClipping)
b(FrontAndBackClipping)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


Front Property

Front Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »Front
Declaration Syntax
C# Visual Basic Visual C++
public double Front { get; }
Public ReadOnly Property Front As Double
    Get
public:
property double Front {
    double get ();
}


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »Inequality(FrontAndBackClipping, FrontAndBackClipping)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    FrontAndBackClipping a,
    FrontAndBackClipping b
)
Public Shared Operator <> ( _
    a As FrontAndBackClipping, _
    b As FrontAndBackClipping _
) As Boolean
public:
static bool operator !=(
    FrontAndBackClipping a,
    FrontAndBackClipping b
)
Parameters
a(FrontAndBackClipping)
b(FrontAndBackClipping)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(FrontAndBackClipping, Tolerance) |
 | IsEqualTo(FrontAndBackClipping) |


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »IsEqualTo(FrontAndBackClipping)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    FrontAndBackClipping a
)
Public Function IsEqualTo ( _
    a As FrontAndBackClipping _
) As Boolean
public:
bool IsEqualTo(
    FrontAndBackClipping a
)
Parameters
a(FrontAndBackClipping)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FrontAndBackClipping »IsEqualTo(FrontAndBackClipping, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    FrontAndBackClipping a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As FrontAndBackClipping, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    FrontAndBackClipping a,
    Tolerance tolerance
)
Parameters
a(FrontAndBackClipping)
tolerance(Tolerance)


GdiDrawObject Class

GdiDrawObject Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GdiDrawObject
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiGdiDrawObject")]
public abstract class GdiDrawObject
<WrapperAttribute("ZcGiGdiDrawObject")> _
Public MustInherit Class GdiDrawObject
[WrapperAttribute(L"ZcGiGdiDrawObject")]
public ref class GdiDrawObject abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GdiDrawObject(IntPtr, Boolean) |
 | GdiDrawObject()()()() |
 | DeleteUnmanagedObject()()()() |
 | Draw(IntPtr, Rectangle) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Height |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Width |
Inheritance Hierarchy
Object
GdiDrawObject


GdiDrawObject Constructor

GdiDrawObject Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GdiDrawObject »GdiDrawObject()()()()
Members
Icon | Member | Description
 | GdiDrawObject(IntPtr, Boolean) |
 | GdiDrawObject()()()() |


GdiDrawObject Constructor

GdiDrawObject Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GdiDrawObject »GdiDrawObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected GdiDrawObject()
Protected Sub New
protected:
GdiDrawObject()


GdiDrawObject Constructor (unmanagedPointer, autoDelete)

GdiDrawObject Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GdiDrawObject »GdiDrawObject(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected GdiDrawObject(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
GdiDrawObject(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GdiDrawObject »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void DeleteUnmanagedObject()
Protected Overridable Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject()


Draw Method (hDC, bounds)

Draw Method (hDC, bounds)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GdiDrawObject »Draw(IntPtr, Rectangle)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Draw(
    IntPtr hDC,
    Rectangle bounds
)
Public MustOverride Function Draw ( _
    hDC As IntPtr, _
    bounds As Rectangle _
) As Boolean
public:
virtual bool Draw(
    IntPtr hDC,
    Rectangle bounds
) abstract
Parameters
hDC(IntPtr)
bounds(Rectangle)


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GdiDrawObject »Height
Declaration Syntax
C# Visual Basic Visual C++
public abstract int Height { get; set; }
Public MustOverride Property Height As Integer
    Get
    Set
public:
virtual property int Height {
    int get () abstract;
    void set (int value) abstract;
}


Width Property

Width Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GdiDrawObject »Width
Declaration Syntax
C# Visual Basic Visual C++
public abstract int Width { get; set; }
Public MustOverride Property Width As Integer
    Get
    Set
public:
virtual property int Width {
    int get () abstract;
    void set (int value) abstract;
}


Geometry Class

Geometry Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiGeometry")]
public abstract class Geometry : RXObject
<WrapperAttribute("ZcGiGeometry")> _
Public MustInherit Class Geometry _
    Inherits RXObject
[WrapperAttribute(L"ZcGiGeometry")]
public ref class Geometry abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Geometry(IntPtr, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Circle(Point3d, Double, Vector3d) |
 | Circle(Point3d, Point3d, Point3d) |
 | CircularArc(Point3d, Double, Vector3d, Vector3d, Double, ArcType) |
 | CircularArc(Point3d, Point3d, Point3d, ArcType) |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Draw(Drawable) |
 | EllipticalArc(Point3d, Vector3d, Double, Double, Double, Double, Double, ArcType) |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mesh(Int32, Int32, Point3dCollection, EdgeData, FaceData, VertexData, Boolean) |
 | ModelToWorldTransform |
 | OwnerDraw(GdiDrawObject, Point3d, Vector3d, Vector3d) |
 | Polygon(Point3dCollection) |
 | Polyline(Point3dCollection, Vector3d, IntPtr) |
 | Polyline(Polyline, Int32, Int32) |
 | Polyline(Polyline) |
 | Polypoint(Point3dCollection, EntityColorCollection, Vector3dCollection, IntPtrCollection) |
 | Polypoint(Point3dCollection, Vector3dCollection, IntPtrCollection) |
 | PolyPolygon(UInt32Collection, Point3dCollection, UInt32Collection, Point3dCollection, EntityColorCollection, LinetypeCollection, EntityColorCollection, TransparencyCollection) |
 | PolyPolyline(PolylineCollection) |
 | PopClipBoundary()()()() |
 | PopModelTransform()()()() |
 | PushClipBoundary(ClipBoundary) |
 | PushModelTransform(Vector3d) |
 | PushModelTransform(Matrix3d) |
 | PushOrientationTransform(OrientationBehavior) |
 | PushPositionTransform(PositionBehavior, Point3d) |
 | PushPositionTransform(PositionBehavior, Point2d) |
 | PushScaleTransform(ScaleBehavior, Point3d) |
 | PushScaleTransform(ScaleBehavior, Point2d) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Ray(Point3d, Point3d) |
 | RowOfDots(Int32, Point3d, Vector3d) |
 | Shell(Point3dCollection, IntegerCollection, EdgeData, FaceData, VertexData, Boolean) |
 | Text(Point3d, Vector3d, Vector3d, Double, Double, Double, String) |
 | Text(Point3d, Vector3d, Vector3d, String, Boolean, TextStyle) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | WorldLine(Point3d, Point3d) |
 | WorldToModelTransform |
 | X(RXClass) | (Inherited from RXObject.)
 | Xline(Point3d, Point3d) |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Geometry
 |  |  |  |  | ViewportGeometry
 |  |  |  |  | WorldGeometry


Geometry Constructor (unmanagedPointer, autoDelete)

Geometry Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Geometry(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected Geometry(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
Geometry(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Circle Method

Circle Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Circle()()()()
Members
Icon | Member | Description
 | Circle(Point3d, Double, Vector3d) |
 | Circle(Point3d, Point3d, Point3d) |


Circle Method (center, radius, normal)

Circle Method (center, radius, normal)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Circle(Point3d, Double, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Circle(
    Point3d center,
    double radius,
    Vector3d normal
)
Public MustOverride Function Circle ( _
    center As Point3d, _
    radius As Double, _
    normal As Vector3d _
) As Boolean
public:
virtual bool Circle(
    Point3d center,
    double radius,
    Vector3d normal
) abstract
Parameters
center(Point3d)
radius(Double)
normal(Vector3d)


Circle Method (firstPoint, secondPoint, thirdPoint)

Circle Method (firstPoint, secondPoint, thirdPoint)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Circle(Point3d, Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Circle(
    Point3d firstPoint,
    Point3d secondPoint,
    Point3d thirdPoint
)
Public MustOverride Function Circle ( _
    firstPoint As Point3d, _
    secondPoint As Point3d, _
    thirdPoint As Point3d _
) As Boolean
public:
virtual bool Circle(
    Point3d firstPoint,
    Point3d secondPoint,
    Point3d thirdPoint
) abstract
Parameters
firstPoint(Point3d)
secondPoint(Point3d)
thirdPoint(Point3d)


CircularArc Method

CircularArc Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »CircularArc()()()()
Members
Icon | Member | Description
 | CircularArc(Point3d, Double, Vector3d, Vector3d, Double, ArcType) |
 | CircularArc(Point3d, Point3d, Point3d, ArcType) |


CircularArc Method (center, radius, normal, startVector, sweepAngle, arcType)

CircularArc Method (center, radius, normal, startVector, sweepAngle, arcType)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »CircularArc(Point3d, Double, Vector3d, Vector3d, Double, ArcType)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool CircularArc(
    Point3d center,
    double radius,
    Vector3d normal,
    Vector3d startVector,
    double sweepAngle,
    ArcType arcType
)
Public MustOverride Function CircularArc ( _
    center As Point3d, _
    radius As Double, _
    normal As Vector3d, _
    startVector As Vector3d, _
    sweepAngle As Double, _
    arcType As ArcType _
) As Boolean
public:
virtual bool CircularArc(
    Point3d center,
    double radius,
    Vector3d normal,
    Vector3d startVector,
    double sweepAngle,
    ArcType arcType
) abstract
Parameters
center(Point3d)
radius(Double)
normal(Vector3d)
startVector(Vector3d)
sweepAngle(Double)
arcType(ArcType)


CircularArc Method (start, point, endingPoint, arcType)

CircularArc Method (start, point, endingPoint, arcType)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »CircularArc(Point3d, Point3d, Point3d, ArcType)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool CircularArc(
    Point3d start,
    Point3d point,
    Point3d endingPoint,
    ArcType arcType
)
Public MustOverride Function CircularArc ( _
    start As Point3d, _
    point As Point3d, _
    endingPoint As Point3d, _
    arcType As ArcType _
) As Boolean
public:
virtual bool CircularArc(
    Point3d start,
    Point3d point,
    Point3d endingPoint,
    ArcType arcType
) abstract
Parameters
start(Point3d)
point(Point3d)
endingPoint(Point3d)
arcType(ArcType)


Draw Method (value)

Draw Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Draw(Drawable)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Draw(
    Drawable value
)
Public MustOverride Function Draw ( _
    value As Drawable _
) As Boolean
public:
virtual bool Draw(
    Drawable^ value
) abstract
Parameters
value(Drawable)


EllipticalArc Method (center, normal, majorAxisLength, minorAxisLength, startDegreeInRads, endDegreeInRads, tiltDegreeInRads, arType)

EllipticalArc Method (center, normal, majorAxisLength, minorAxisLength, startDegreeInRads, endDegreeInRads, tiltDegreeInRads, arType)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »EllipticalArc(Point3d, Vector3d, Double, Double, Double, Double, Double, ArcType)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool EllipticalArc(
    Point3d center,
    Vector3d normal,
    double majorAxisLength,
    double minorAxisLength,
    double startDegreeInRads,
    double endDegreeInRads,
    double tiltDegreeInRads,
    ArcType arType
)
Public MustOverride Function EllipticalArc ( _
    center As Point3d, _
    normal As Vector3d, _
    majorAxisLength As Double, _
    minorAxisLength As Double, _
    startDegreeInRads As Double, _
    endDegreeInRads As Double, _
    tiltDegreeInRads As Double, _
    arType As ArcType _
) As Boolean
public:
virtual bool EllipticalArc(
    Point3d center,
    Vector3d normal,
    double majorAxisLength,
    double minorAxisLength,
    double startDegreeInRads,
    double endDegreeInRads,
    double tiltDegreeInRads,
    ArcType arType
) abstract
Parameters
center(Point3d)
normal(Vector3d)
majorAxisLength(Double)
minorAxisLength(Double)
startDegreeInRads(Double)
endDegreeInRads(Double)
tiltDegreeInRads(Double)
arType(ArcType)


Mesh Method (rows, columns, points, edgeData, faceData, vertexData, bAutoGenerateNormals)

Mesh Method (rows, columns, points, edgeData, faceData, vertexData, bAutoGenerateNormals)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Mesh(Int32, Int32, Point3dCollection, EdgeData, FaceData, VertexData, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Mesh(
    int rows,
    int columns,
    Point3dCollection points,
    EdgeData edgeData,
    FaceData faceData,
    VertexData vertexData,
    bool bAutoGenerateNormals
)
Public MustOverride Function Mesh ( _
    rows As Integer, _
    columns As Integer, _
    points As Point3dCollection, _
    edgeData As EdgeData, _
    faceData As FaceData, _
    vertexData As VertexData, _
    bAutoGenerateNormals As Boolean _
) As Boolean
public:
virtual bool Mesh(
    int rows,
    int columns,
    Point3dCollection^ points,
    EdgeData^ edgeData,
    FaceData^ faceData,
    VertexData^ vertexData,
    bool bAutoGenerateNormals
) abstract
Parameters
rows(Int32)
columns(Int32)
points(Point3dCollection)
edgeData(EdgeData)
faceData(FaceData)
vertexData(VertexData)
bAutoGenerateNormals(Boolean)


ModelToWorldTransform Property

ModelToWorldTransform Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »ModelToWorldTransform
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d ModelToWorldTransform { get; }
Public MustOverride ReadOnly Property ModelToWorldTransform As Matrix3d
    Get
public:
virtual property Matrix3d ModelToWorldTransform {
    Matrix3d get () abstract;
}


OwnerDraw Method (gdiDrawObject, position, u, v)

OwnerDraw Method (gdiDrawObject, position, u, v)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »OwnerDraw(GdiDrawObject, Point3d, Vector3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool OwnerDraw(
    GdiDrawObject gdiDrawObject,
    Point3d position,
    Vector3d u,
    Vector3d v
)
Public MustOverride Function OwnerDraw ( _
    gdiDrawObject As GdiDrawObject, _
    position As Point3d, _
    u As Vector3d, _
    v As Vector3d _
) As Boolean
public:
virtual bool OwnerDraw(
    GdiDrawObject^ gdiDrawObject,
    Point3d position,
    Vector3d u,
    Vector3d v
) abstract
Parameters
gdiDrawObject(GdiDrawObject)
position(Point3d)
u(Vector3d)
v(Vector3d)


Polygon Method (points)

Polygon Method (points)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Polygon(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Polygon(
    Point3dCollection points
)
Public MustOverride Function Polygon ( _
    points As Point3dCollection _
) As Boolean
public:
virtual bool Polygon(
    Point3dCollection^ points
) abstract
Parameters
points(Point3dCollection)


Polyline Method

Polyline Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Polyline()()()()
Members
Icon | Member | Description
 | Polyline(Point3dCollection, Vector3d, IntPtr) |
 | Polyline(Polyline, Int32, Int32) |
 | Polyline(Polyline) |


Polyline Method (value, fromIndex, segments)

Polyline Method (value, fromIndex, segments)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Polyline(Polyline, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Polyline(
    Polyline value,
    int fromIndex,
    int segments
)
Public MustOverride Function Polyline ( _
    value As Polyline, _
    fromIndex As Integer, _
    segments As Integer _
) As Boolean
public:
virtual bool Polyline(
    Polyline^ value,
    int fromIndex,
    int segments
) abstract
Parameters
value(Polyline)
fromIndex(Int32)
segments(Int32)


Polyline Method (points, normal, subEntityMarker)

Polyline Method (points, normal, subEntityMarker)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Polyline(Point3dCollection, Vector3d, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Polyline(
    Point3dCollection points,
    Vector3d normal,
    IntPtr subEntityMarker
)
Public MustOverride Function Polyline ( _
    points As Point3dCollection, _
    normal As Vector3d, _
    subEntityMarker As IntPtr _
) As Boolean
public:
virtual bool Polyline(
    Point3dCollection^ points,
    Vector3d normal,
    IntPtr subEntityMarker
) abstract
Parameters
points(Point3dCollection)
normal(Vector3d)
subEntityMarker(IntPtr)


Polyline Method (polylineObj)

Polyline Method (polylineObj)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Polyline(Polyline)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Polyline(
    Polyline polylineObj
)
Public MustOverride Function Polyline ( _
    polylineObj As Polyline _
) As Boolean
public:
virtual bool Polyline(
    Polyline^ polylineObj
) abstract
Parameters
polylineObj(Polyline)


Polypoint Method

Polypoint Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Polypoint()()()()
Members
Icon | Member | Description
 | Polypoint(Point3dCollection, EntityColorCollection, Vector3dCollection, IntPtrCollection) |
 | Polypoint(Point3dCollection, Vector3dCollection, IntPtrCollection) |


Polypoint Method (points, colors, normals, subentityMarkers)

Polypoint Method (points, colors, normals, subentityMarkers)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Polypoint(Point3dCollection, EntityColorCollection, Vector3dCollection, IntPtrCollection)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Polypoint(
    Point3dCollection points,
    EntityColorCollection colors,
    Vector3dCollection normals,
    IntPtrCollection subentityMarkers
)
Public MustOverride Function Polypoint ( _
    points As Point3dCollection, _
    colors As EntityColorCollection, _
    normals As Vector3dCollection, _
    subentityMarkers As IntPtrCollection _
) As Boolean
public:
virtual bool Polypoint(
    Point3dCollection^ points,
    EntityColorCollection^ colors,
    Vector3dCollection^ normals,
    IntPtrCollection^ subentityMarkers
) abstract
Parameters
points(Point3dCollection)
colors(EntityColorCollection)
normals(Vector3dCollection)
subentityMarkers(IntPtrCollection)


Polypoint Method (points, normals, subentityMarkers)

Polypoint Method (points, normals, subentityMarkers)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Polypoint(Point3dCollection, Vector3dCollection, IntPtrCollection)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Polypoint(
    Point3dCollection points,
    Vector3dCollection normals,
    IntPtrCollection subentityMarkers
)
Public MustOverride Function Polypoint ( _
    points As Point3dCollection, _
    normals As Vector3dCollection, _
    subentityMarkers As IntPtrCollection _
) As Boolean
public:
virtual bool Polypoint(
    Point3dCollection^ points,
    Vector3dCollection^ normals,
    IntPtrCollection^ subentityMarkers
) abstract
Parameters
points(Point3dCollection)
normals(Vector3dCollection)
subentityMarkers(IntPtrCollection)


PolyPolygon Method (numPolygonPositions, polygonPositions, numPolygonPoints, polygonPoints, outlineColors, outlineTypes, fillColors, fillOpacities)

PolyPolygon Method (numPolygonPositions, polygonPositions, numPolygonPoints, polygonPoints, outlineColors, outlineTypes, fillColors, fillOpacities)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PolyPolygon(UInt32Collection, Point3dCollection, UInt32Collection, Point3dCollection, EntityColorCollection, LinetypeCollection, EntityColorCollection, TransparencyCollection)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool PolyPolygon(
    UInt32Collection numPolygonPositions,
    Point3dCollection polygonPositions,
    UInt32Collection numPolygonPoints,
    Point3dCollection polygonPoints,
    EntityColorCollection outlineColors,
    LinetypeCollection outlineTypes,
    EntityColorCollection fillColors,
    TransparencyCollection fillOpacities
)
Public MustOverride Function PolyPolygon ( _
    numPolygonPositions As UInt32Collection, _
    polygonPositions As Point3dCollection, _
    numPolygonPoints As UInt32Collection, _
    polygonPoints As Point3dCollection, _
    outlineColors As EntityColorCollection, _
    outlineTypes As LinetypeCollection, _
    fillColors As EntityColorCollection, _
    fillOpacities As TransparencyCollection _
) As Boolean
public:
virtual bool PolyPolygon(
    UInt32Collection^ numPolygonPositions,
    Point3dCollection^ polygonPositions,
    UInt32Collection^ numPolygonPoints,
    Point3dCollection^ polygonPoints,
    EntityColorCollection^ outlineColors,
    LinetypeCollection^ outlineTypes,
    EntityColorCollection^ fillColors,
    TransparencyCollection^ fillOpacities
) abstract
Parameters
numPolygonPositions(UInt32Collection)
polygonPositions(Point3dCollection)
numPolygonPoints(UInt32Collection)
polygonPoints(Point3dCollection)
outlineColors(EntityColorCollection)
outlineTypes(LinetypeCollection)
fillColors(EntityColorCollection)
fillOpacities(TransparencyCollection)


PolyPolyline Method (polylineCollection)

PolyPolyline Method (polylineCollection)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PolyPolyline(PolylineCollection)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool PolyPolyline(
    PolylineCollection polylineCollection
)
Public MustOverride Function PolyPolyline ( _
    polylineCollection As PolylineCollection _
) As Boolean
public:
virtual bool PolyPolyline(
    PolylineCollection^ polylineCollection
) abstract
Parameters
polylineCollection(PolylineCollection)


PopClipBoundary Method

PopClipBoundary Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PopClipBoundary()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void PopClipBoundary()
Public MustOverride Sub PopClipBoundary
public:
virtual void PopClipBoundary() abstract


PopModelTransform Method

PopModelTransform Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PopModelTransform()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool PopModelTransform()
Public MustOverride Function PopModelTransform As Boolean
public:
virtual bool PopModelTransform() abstract


PushClipBoundary Method (boundary)

PushClipBoundary Method (boundary)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushClipBoundary(ClipBoundary)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool PushClipBoundary(
    ClipBoundary boundary
)
Public MustOverride Function PushClipBoundary ( _
    boundary As ClipBoundary _
) As Boolean
public:
virtual bool PushClipBoundary(
    ClipBoundary^ boundary
) abstract
Parameters
boundary(ClipBoundary)


PushModelTransform Method

PushModelTransform Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushModelTransform()()()()
Members
Icon | Member | Description
 | PushModelTransform(Vector3d) |
 | PushModelTransform(Matrix3d) |


PushModelTransform Method (matrix)

PushModelTransform Method (matrix)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushModelTransform(Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool PushModelTransform(
    Matrix3d matrix
)
Public MustOverride Function PushModelTransform ( _
    matrix As Matrix3d _
) As Boolean
public:
virtual bool PushModelTransform(
    Matrix3d matrix
) abstract
Parameters
matrix(Matrix3d)


PushModelTransform Method (normal)

PushModelTransform Method (normal)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushModelTransform(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool PushModelTransform(
    Vector3d normal
)
Public MustOverride Function PushModelTransform ( _
    normal As Vector3d _
) As Boolean
public:
virtual bool PushModelTransform(
    Vector3d normal
) abstract
Parameters
normal(Vector3d)


PushOrientationTransform Method (behavior)

PushOrientationTransform Method (behavior)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushOrientationTransform(OrientationBehavior)
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d PushOrientationTransform(
    OrientationBehavior behavior
)
Public MustOverride Function PushOrientationTransform ( _
    behavior As OrientationBehavior _
) As Matrix3d
public:
virtual Matrix3d PushOrientationTransform(
    OrientationBehavior behavior
) abstract
Parameters
behavior(OrientationBehavior)


PushPositionTransform Method

PushPositionTransform Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushPositionTransform()()()()
Members
Icon | Member | Description
 | PushPositionTransform(PositionBehavior, Point3d) |
 | PushPositionTransform(PositionBehavior, Point2d) |


PushPositionTransform Method (behavior, offset)

PushPositionTransform Method (behavior, offset)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushPositionTransform(PositionBehavior, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d PushPositionTransform(
    PositionBehavior behavior,
    Point2d offset
)
Public MustOverride Function PushPositionTransform ( _
    behavior As PositionBehavior, _
    offset As Point2d _
) As Matrix3d
public:
virtual Matrix3d PushPositionTransform(
    PositionBehavior behavior,
    Point2d offset
) abstract
Parameters
behavior(PositionBehavior)
offset(Point2d)


PushPositionTransform Method (behavior, offset)

PushPositionTransform Method (behavior, offset)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushPositionTransform(PositionBehavior, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d PushPositionTransform(
    PositionBehavior behavior,
    Point3d offset
)
Public MustOverride Function PushPositionTransform ( _
    behavior As PositionBehavior, _
    offset As Point3d _
) As Matrix3d
public:
virtual Matrix3d PushPositionTransform(
    PositionBehavior behavior,
    Point3d offset
) abstract
Parameters
behavior(PositionBehavior)
offset(Point3d)


PushScaleTransform Method

PushScaleTransform Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushScaleTransform()()()()
Members
Icon | Member | Description
 | PushScaleTransform(ScaleBehavior, Point3d) |
 | PushScaleTransform(ScaleBehavior, Point2d) |


PushScaleTransform Method (behavior, extents)

PushScaleTransform Method (behavior, extents)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushScaleTransform(ScaleBehavior, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d PushScaleTransform(
    ScaleBehavior behavior,
    Point2d extents
)
Public MustOverride Function PushScaleTransform ( _
    behavior As ScaleBehavior, _
    extents As Point2d _
) As Matrix3d
public:
virtual Matrix3d PushScaleTransform(
    ScaleBehavior behavior,
    Point2d extents
) abstract
Parameters
behavior(ScaleBehavior)
extents(Point2d)


PushScaleTransform Method (behavior, extents)

PushScaleTransform Method (behavior, extents)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »PushScaleTransform(ScaleBehavior, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d PushScaleTransform(
    ScaleBehavior behavior,
    Point3d extents
)
Public MustOverride Function PushScaleTransform ( _
    behavior As ScaleBehavior, _
    extents As Point3d _
) As Matrix3d
public:
virtual Matrix3d PushScaleTransform(
    ScaleBehavior behavior,
    Point3d extents
) abstract
Parameters
behavior(ScaleBehavior)
extents(Point3d)


Ray Method (point1, point2)

Ray Method (point1, point2)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Ray(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Ray(
    Point3d point1,
    Point3d point2
)
Public MustOverride Function Ray ( _
    point1 As Point3d, _
    point2 As Point3d _
) As Boolean
public:
virtual bool Ray(
    Point3d point1,
    Point3d point2
) abstract
Parameters
point1(Point3d)
point2(Point3d)


RowOfDots Method (count, start, step)

RowOfDots Method (count, start, step)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »RowOfDots(Int32, Point3d, Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool RowOfDots(
    int count,
    Point3d start,
    Vector3d step
)
Public MustOverride Function RowOfDots ( _
    count As Integer, _
    start As Point3d, _
    step As Vector3d _
) As Boolean
public:
virtual bool RowOfDots(
    int count,
    Point3d start,
    Vector3d step
) abstract
Parameters
count(Int32)
start(Point3d)
step(Vector3d)


Shell Method (points, faces, edgeData, faceData, vertexData, bAutoGenerateNormals)

Shell Method (points, faces, edgeData, faceData, vertexData, bAutoGenerateNormals)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Shell(Point3dCollection, IntegerCollection, EdgeData, FaceData, VertexData, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Shell(
    Point3dCollection points,
    IntegerCollection faces,
    EdgeData edgeData,
    FaceData faceData,
    VertexData vertexData,
    bool bAutoGenerateNormals
)
Public MustOverride Function Shell ( _
    points As Point3dCollection, _
    faces As IntegerCollection, _
    edgeData As EdgeData, _
    faceData As FaceData, _
    vertexData As VertexData, _
    bAutoGenerateNormals As Boolean _
) As Boolean
public:
virtual bool Shell(
    Point3dCollection^ points,
    IntegerCollection^ faces,
    EdgeData^ edgeData,
    FaceData^ faceData,
    VertexData^ vertexData,
    bool bAutoGenerateNormals
) abstract
Parameters
points(Point3dCollection)
faces(IntegerCollection)
edgeData(EdgeData)
faceData(FaceData)
vertexData(VertexData)
bAutoGenerateNormals(Boolean)


Text Method

Text Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Text()()()()
Members
Icon | Member | Description
 | Text(Point3d, Vector3d, Vector3d, Double, Double, Double, String) |
 | Text(Point3d, Vector3d, Vector3d, String, Boolean, TextStyle) |


Text Method (position, normal, direction, height, width, oblique, message)

Text Method (position, normal, direction, height, width, oblique, message)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Text(Point3d, Vector3d, Vector3d, Double, Double, Double, String)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Text(
    Point3d position,
    Vector3d normal,
    Vector3d direction,
    double height,
    double width,
    double oblique,
    string message
)
Public MustOverride Function Text ( _
    position As Point3d, _
    normal As Vector3d, _
    direction As Vector3d, _
    height As Double, _
    width As Double, _
    oblique As Double, _
    message As String _
) As Boolean
public:
virtual bool Text(
    Point3d position,
    Vector3d normal,
    Vector3d direction,
    double height,
    double width,
    double oblique,
    String^ message
) abstract
Parameters
position(Point3d)
normal(Vector3d)
direction(Vector3d)
height(Double)
width(Double)
oblique(Double)
message(String)


Text Method (position, normal, direction, message, raw, textStyle)

Text Method (position, normal, direction, message, raw, textStyle)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Text(Point3d, Vector3d, Vector3d, String, Boolean, TextStyle)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Text(
    Point3d position,
    Vector3d normal,
    Vector3d direction,
    string message,
    bool raw,
    TextStyle textStyle
)
Public MustOverride Function Text ( _
    position As Point3d, _
    normal As Vector3d, _
    direction As Vector3d, _
    message As String, _
    raw As Boolean, _
    textStyle As TextStyle _
) As Boolean
public:
virtual bool Text(
    Point3d position,
    Vector3d normal,
    Vector3d direction,
    String^ message,
    bool raw,
    TextStyle^ textStyle
) abstract
Parameters
position(Point3d)
normal(Vector3d)
direction(Vector3d)
message(String)
raw(Boolean)
textStyle(TextStyle)


WorldLine Method (startPoint, endPoint)

WorldLine Method (startPoint, endPoint)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »WorldLine(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool WorldLine(
    Point3d startPoint,
    Point3d endPoint
)
Public MustOverride Function WorldLine ( _
    startPoint As Point3d, _
    endPoint As Point3d _
) As Boolean
public:
virtual bool WorldLine(
    Point3d startPoint,
    Point3d endPoint
) abstract
Parameters
startPoint(Point3d)
endPoint(Point3d)


WorldToModelTransform Property

WorldToModelTransform Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »WorldToModelTransform
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d WorldToModelTransform { get; }
Public MustOverride ReadOnly Property WorldToModelTransform As Matrix3d
    Get
public:
virtual property Matrix3d WorldToModelTransform {
    Matrix3d get () abstract;
}


Xline Method (point1, point2)

Xline Method (point1, point2)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Xline(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Xline(
    Point3d point1,
    Point3d point2
)
Public MustOverride Function Xline ( _
    point1 As Point3d, _
    point2 As Point3d _
) As Boolean
public:
virtual bool Xline(
    Point3d point1,
    Point3d point2
) abstract
Parameters
point1(Point3d)
point2(Point3d)


GIRasterImage Class

GIRasterImage Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiRasterImage")]
public class GIRasterImage : RXObject
<WrapperAttribute("ZcGiRasterImage")> _
Public Class GIRasterImage _
    Inherits RXObject
[WrapperAttribute(L"ZcGiRasterImage")]
public ref class GIRasterImage : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GIRasterImage(IntPtr, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CalcBMPScanLineSize(UInt32, UInt32) |
 | ChangeImageSource(RasterImageSource) |
 | ChangeTransparencyMode(TransparencyMode) |
 | Clone()()()() | (Inherited from RXObject.)
 | ColorDepth |
 | CompareTo(Object) | (Inherited from RXObject.)
 | Convert(Boolean) |
 | Convert(Boolean, Double) |
 | Convert(Boolean, Double, Double) |
 | Convert(Boolean, Double, Double, Double) |
 | Convert(Boolean, Double, Double, Double, Color) |
 | Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean) |
 | Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean, Boolean) |
 | Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean, Boolean, GIRasterImage) |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Crop(UInt32, UInt32, UInt32, UInt32) |
 | DefaultResolution(Double, Double) |
 | DeleteUnmanagedObject()()()() | (Overrides RXObject.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | getColor(UInt32) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | imageSource |
 | ImgTransparencyMode |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumColors |
 | PaletteData()()()() |
 | PaletteDataSize |
 | pixelFormat()()()() |
 | PixelHeight |
 | PixelWidth |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ScanLines()()()() |
 | ScanLines(Int32, Int32) |
 | ScanLinesAlignment |
 | ScanLineSize |
 | ToString()()()() | (Inherited from Object.)
 | TransparentColor |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | GIRasterImage


GIRasterImage Constructor (unmanagedPointer, autoDelete)

GIRasterImage Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »GIRasterImage(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal GIRasterImage(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
GIRasterImage(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


CalcBMPScanLineSize Method (pixelWidth, colorDepth)

CalcBMPScanLineSize Method (pixelWidth, colorDepth)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »CalcBMPScanLineSize(UInt32, UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public static int CalcBMPScanLineSize(
    uint pixelWidth,
    uint colorDepth
)
Public Shared Function CalcBMPScanLineSize ( _
    pixelWidth As UInteger, _
    colorDepth As UInteger _
) As Integer
public:
static int CalcBMPScanLineSize(
    unsigned int pixelWidth,
    unsigned int colorDepth
)
Parameters
pixelWidth(UInt32)
colorDepth(UInt32)


ChangeImageSource Method (source)

ChangeImageSource Method (source)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »ChangeImageSource(RasterImageSource)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage ChangeImageSource(
    RasterImageSource source
)
Public Function ChangeImageSource ( _
    source As RasterImageSource _
) As GIRasterImage
public:
GIRasterImage^ ChangeImageSource(
    RasterImageSource source
)
Parameters
source(RasterImageSource)


ChangeTransparencyMode Method (mode)

ChangeTransparencyMode Method (mode)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »ChangeTransparencyMode(TransparencyMode)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage ChangeTransparencyMode(
    TransparencyMode mode
)
Public Function ChangeTransparencyMode ( _
    mode As TransparencyMode _
) As GIRasterImage
public:
GIRasterImage^ ChangeTransparencyMode(
    TransparencyMode mode
)
Parameters
mode(TransparencyMode)


ColorDepth Property

ColorDepth Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »ColorDepth
Declaration Syntax
C# Visual Basic Visual C++
public uint ColorDepth { get; }
Public ReadOnly Property ColorDepth As UInteger
    Get
public:
property unsigned int ColorDepth {
    unsigned int get ();
}


Convert Method

Convert Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Convert()()()()
Members
Icon | Member | Description
 | Convert(Boolean) |
 | Convert(Boolean, Double) |
 | Convert(Boolean, Double, Double) |
 | Convert(Boolean, Double, Double, Double) |
 | Convert(Boolean, Double, Double, Double, Color) |
 | Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean) |
 | Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean, Boolean) |
 | Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean, Boolean, GIRasterImage) |


Convert Method (convertPaletteToRGB)

Convert Method (convertPaletteToRGB)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Convert(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage Convert(
    bool convertPaletteToRGB
)
Public Function Convert ( _
    convertPaletteToRGB As Boolean _
) As GIRasterImage
public:
GIRasterImage^ Convert(
    bool convertPaletteToRGB
)
Parameters
convertPaletteToRGB(Boolean)


Convert Method (convertPaletteToRGB, brightness)

Convert Method (convertPaletteToRGB, brightness)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Convert(Boolean, Double)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage Convert(
    bool convertPaletteToRGB,
    double brightness
)
Public Function Convert ( _
    convertPaletteToRGB As Boolean, _
    brightness As Double _
) As GIRasterImage
public:
GIRasterImage^ Convert(
    bool convertPaletteToRGB,
    double brightness
)
Parameters
convertPaletteToRGB(Boolean)
brightness(Double)


Convert Method (convertPaletteToRGB, brightness, contrast)

Convert Method (convertPaletteToRGB, brightness, contrast)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Convert(Boolean, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast
)
Public Function Convert ( _
    convertPaletteToRGB As Boolean, _
    brightness As Double, _
    contrast As Double _
) As GIRasterImage
public:
GIRasterImage^ Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast
)
Parameters
convertPaletteToRGB(Boolean)
brightness(Double)
contrast(Double)


Convert Method (convertPaletteToRGB, brightness, contrast, fade)

Convert Method (convertPaletteToRGB, brightness, contrast, fade)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Convert(Boolean, Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast,
    double fade
)
Public Function Convert ( _
    convertPaletteToRGB As Boolean, _
    brightness As Double, _
    contrast As Double, _
    fade As Double _
) As GIRasterImage
public:
GIRasterImage^ Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast,
    double fade
)
Parameters
convertPaletteToRGB(Boolean)
brightness(Double)
contrast(Double)
fade(Double)


Convert Method (convertPaletteToRGB, brightness, contrast, fade, backgroundColor)

Convert Method (convertPaletteToRGB, brightness, contrast, fade, backgroundColor)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Convert(Boolean, Double, Double, Double, Color)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast,
    double fade,
    Color backgroundColor
)
Public Function Convert ( _
    convertPaletteToRGB As Boolean, _
    brightness As Double, _
    contrast As Double, _
    fade As Double, _
    backgroundColor As Color _
) As GIRasterImage
public:
GIRasterImage^ Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast,
    double fade,
    Color backgroundColor
)
Parameters
convertPaletteToRGB(Boolean)
brightness(Double)
contrast(Double)
fade(Double)
backgroundColor(Color)


Convert Method (convertPaletteToRGB, brightness, contrast, fade, backgroundColor, flipX, flipY)

Convert Method (convertPaletteToRGB, brightness, contrast, fade, backgroundColor, flipX, flipY)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast,
    double fade,
    Color backgroundColor,
    bool flipX,
    bool flipY
)
Public Function Convert ( _
    convertPaletteToRGB As Boolean, _
    brightness As Double, _
    contrast As Double, _
    fade As Double, _
    backgroundColor As Color, _
    flipX As Boolean, _
    flipY As Boolean _
) As GIRasterImage
public:
GIRasterImage^ Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast,
    double fade,
    Color backgroundColor,
    bool flipX,
    bool flipY
)
Parameters
convertPaletteToRGB(Boolean)
brightness(Double)
contrast(Double)
fade(Double)
backgroundColor(Color)
flipX(Boolean)
flipY(Boolean)


Convert Method (convertPaletteToRGB, brightness, contrast, fade, backgroundColor, flipX, flipY, rotate90)

Convert Method (convertPaletteToRGB, brightness, contrast, fade, backgroundColor, flipX, flipY, rotate90)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast,
    double fade,
    Color backgroundColor,
    bool flipX,
    bool flipY,
    bool rotate90
)
Public Function Convert ( _
    convertPaletteToRGB As Boolean, _
    brightness As Double, _
    contrast As Double, _
    fade As Double, _
    backgroundColor As Color, _
    flipX As Boolean, _
    flipY As Boolean, _
    rotate90 As Boolean _
) As GIRasterImage
public:
GIRasterImage^ Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast,
    double fade,
    Color backgroundColor,
    bool flipX,
    bool flipY,
    bool rotate90
)
Parameters
convertPaletteToRGB(Boolean)
brightness(Double)
contrast(Double)
fade(Double)
backgroundColor(Color)
flipX(Boolean)
flipY(Boolean)
rotate90(Boolean)


Convert Method (convertPaletteToRGB, brightness, contrast, fade, backgroundColor, flipX, flipY, rotate90, image)

Convert Method (convertPaletteToRGB, brightness, contrast, fade, backgroundColor, flipX, flipY, rotate90, image)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean, Boolean, GIRasterImage)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast,
    double fade,
    Color backgroundColor,
    bool flipX,
    bool flipY,
    bool rotate90,
    GIRasterImage image
)
Public Function Convert ( _
    convertPaletteToRGB As Boolean, _
    brightness As Double, _
    contrast As Double, _
    fade As Double, _
    backgroundColor As Color, _
    flipX As Boolean, _
    flipY As Boolean, _
    rotate90 As Boolean, _
    image As GIRasterImage _
) As GIRasterImage
public:
GIRasterImage^ Convert(
    bool convertPaletteToRGB,
    double brightness,
    double contrast,
    double fade,
    Color backgroundColor,
    bool flipX,
    bool flipY,
    bool rotate90,
    GIRasterImage^ image
)
Parameters
convertPaletteToRGB(Boolean)
brightness(Double)
contrast(Double)
fade(Double)
backgroundColor(Color)
flipX(Boolean)
flipY(Boolean)
rotate90(Boolean)
image(GIRasterImage)


Crop Method (x, y, width, height)

Crop Method (x, y, width, height)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Crop(UInt32, UInt32, UInt32, UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public GIRasterImage Crop(
    uint x,
    uint y,
    uint width,
    uint height
)
Public Function Crop ( _
    x As UInteger, _
    y As UInteger, _
    width As UInteger, _
    height As UInteger _
) As GIRasterImage
public:
GIRasterImage^ Crop(
    unsigned int x,
    unsigned int y,
    unsigned int width,
    unsigned int height
)
Parameters
x(UInt32)
y(UInt32)
width(UInt32)
height(UInt32)


DefaultResolution Method (xPelsPerUnit, yPelsPerUnit)

DefaultResolution Method (xPelsPerUnit, yPelsPerUnit)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »DefaultResolution(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public Units DefaultResolution(
    double xPelsPerUnit,
    double yPelsPerUnit
)
Public Function DefaultResolution ( _
    <OutAttribute> xPelsPerUnit As Double, _
    <OutAttribute> yPelsPerUnit As Double _
) As Units
public:
Units DefaultResolution(
    [OutAttribute] double xPelsPerUnit,
    [OutAttribute] double yPelsPerUnit
)
Parameters
xPelsPerUnit(Double)
yPelsPerUnit(Double)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


getColor Method (colorIndex)

getColor Method (colorIndex)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »getColor(UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public Color getColor(
    uint colorIndex
)
Public Function getColor ( _
    colorIndex As UInteger _
) As Color
public:
Color getColor(
    unsigned int colorIndex
)
Parameters
colorIndex(UInt32)


imageSource Property

imageSource Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »imageSource
Declaration Syntax
C# Visual Basic Visual C++
public RasterImageSource imageSource { get; }
Public ReadOnly Property imageSource As RasterImageSource
    Get
public:
property RasterImageSource imageSource {
    RasterImageSource get ();
}


ImgTransparencyMode Property

ImgTransparencyMode Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »ImgTransparencyMode
Declaration Syntax
C# Visual Basic Visual C++
public TransparencyMode ImgTransparencyMode { get; }
Public ReadOnly Property ImgTransparencyMode As TransparencyMode
    Get
public:
property TransparencyMode ImgTransparencyMode {
    TransparencyMode get ();
}


NumColors Property

NumColors Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »NumColors
Declaration Syntax
C# Visual Basic Visual C++
public uint NumColors { get; }
Public ReadOnly Property NumColors As UInteger
    Get
public:
property unsigned int NumColors {
    unsigned int get ();
}


PaletteData Method

PaletteData Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »PaletteData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public byte[] PaletteData()
Public Function PaletteData As Byte()
public:
array<unsigned char>^ PaletteData()


PaletteDataSize Property

PaletteDataSize Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »PaletteDataSize
Declaration Syntax
C# Visual Basic Visual C++
public int PaletteDataSize { get; }
Public ReadOnly Property PaletteDataSize As Integer
    Get
public:
property int PaletteDataSize {
    int get ();
}


pixelFormat Method

pixelFormat Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »pixelFormat()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PixelFormatInfo pixelFormat()
Public Function pixelFormat As PixelFormatInfo
public:
PixelFormatInfo pixelFormat()


PixelHeight Property

PixelHeight Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »PixelHeight
Declaration Syntax
C# Visual Basic Visual C++
public uint PixelHeight { get; }
Public ReadOnly Property PixelHeight As UInteger
    Get
public:
property unsigned int PixelHeight {
    unsigned int get ();
}


PixelWidth Property

PixelWidth Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »PixelWidth
Declaration Syntax
C# Visual Basic Visual C++
public uint PixelWidth { get; }
Public ReadOnly Property PixelWidth As UInteger
    Get
public:
property unsigned int PixelWidth {
    unsigned int get ();
}


ScanLines Method

ScanLines Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »ScanLines()()()()
Members
Icon | Member | Description
 | ScanLines()()()() |
 | ScanLines(Int32, Int32) |


ScanLines Method

ScanLines Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »ScanLines()()()()
Declaration Syntax
C# Visual Basic Visual C++
public byte[] ScanLines()
Public Function ScanLines As Byte()
public:
array<unsigned char>^ ScanLines()


ScanLines Method (firstScanline, numLines)

ScanLines Method (firstScanline, numLines)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »ScanLines(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public byte[] ScanLines(
    int firstScanline,
    int numLines
)
Public Function ScanLines ( _
    firstScanline As Integer, _
    numLines As Integer _
) As Byte()
public:
array<unsigned char>^ ScanLines(
    int firstScanline,
    int numLines
)
Parameters
firstScanline(Int32)
numLines(Int32)


ScanLinesAlignment Property

ScanLinesAlignment Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »ScanLinesAlignment
Declaration Syntax
C# Visual Basic Visual C++
public uint ScanLinesAlignment { get; }
Public ReadOnly Property ScanLinesAlignment As UInteger
    Get
public:
property unsigned int ScanLinesAlignment {
    unsigned int get ();
}


ScanLineSize Property

ScanLineSize Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »ScanLineSize
Declaration Syntax
C# Visual Basic Visual C++
public uint ScanLineSize { get; }
Public ReadOnly Property ScanLineSize As UInteger
    Get
public:
property unsigned int ScanLineSize {
    unsigned int get ();
}


TransparentColor Property

TransparentColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »TransparentColor
Declaration Syntax
C# Visual Basic Visual C++
public int TransparentColor { get; }
Public ReadOnly Property TransparentColor As Integer
    Get
public:
property int TransparentColor {
    int get ();
}


GlobalIlluminationMode Enumeration

GlobalIlluminationMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GlobalIlluminationMode
Declaration Syntax
C# Visual Basic Visual C++
public enum GlobalIlluminationMode
Public Enumeration GlobalIlluminationMode
public enum class GlobalIlluminationMode
Members
Member | Description
GlobalIlluminationCastAndReceive |
GlobalIlluminationReceive |
GlobalIlluminationCast |
GlobalIlluminationNone |


IlluminationModel Enumeration

IlluminationModel Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »IlluminationModel
Declaration Syntax
C# Visual Basic Visual C++
public enum IlluminationModel
Public Enumeration IlluminationModel
public enum class IlluminationModel
Members
Member | Description
MetalShader |
BlinnShader |


ImageOrg Enumeration

ImageOrg Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ImageOrg
Declaration Syntax
C# Visual Basic Visual C++
public enum ImageOrg
Public Enumeration ImageOrg
public enum class ImageOrg
Members
Member | Description
RGB |
BGR |
ABGR |
ARGB |
BGRA |
RGBA |
Palette |
Bitonal |
Gray |


ImageSource Enumeration

ImageSource Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ImageSource
Declaration Syntax
C# Visual Basic Visual C++
public enum ImageSource
Public Enumeration ImageSource
public enum class ImageSource
Members
Member | Description
FromRender |
FromOleObject |
FromDwg |


JitterAmount Enumeration

JitterAmount Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »JitterAmount
Declaration Syntax
C# Visual Basic Visual C++
public enum JitterAmount
Public Enumeration JitterAmount
public enum class JitterAmount
Members
Member | Description
JitterHigh |
JitterMedium |
JitterLow |


LightAttenuation Class

LightAttenuation Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiLightAttenuation")]
public sealed class LightAttenuation : RXObject
<WrapperAttribute("ZcGiLightAttenuation")> _
Public NotInheritable Class LightAttenuation _
    Inherits RXObject
[WrapperAttribute(L"ZcGiLightAttenuation")]
public ref class LightAttenuation sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightAttenuation()()()() |
 | AttenuationType |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndLimit |
 | Equals(Object) | (Overrides DisposableWrapper.Equals(Object).)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Overrides DisposableWrapper.GetHashCode()()()().)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SetLimits(Double, Double) |
 | StartLimit |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UseLimits |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | LightAttenuation


LightAttenuation Constructor

LightAttenuation Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation »LightAttenuation()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LightAttenuation()
Public Sub New
public:
LightAttenuation()


AttenuationType Property

AttenuationType Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation »AttenuationType
Declaration Syntax
C# Visual Basic Visual C++
public AttenuationType AttenuationType { get; set; }
Public Property AttenuationType As AttenuationType
    Get
    Set
public:
property AttenuationType AttenuationType {
    AttenuationType get ();
    void set (AttenuationType value);
}


EndLimit Property

EndLimit Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation »EndLimit
Declaration Syntax
C# Visual Basic Visual C++
public double EndLimit { get; }
Public ReadOnly Property EndLimit As Double
    Get
public:
property double EndLimit {
    double get ();
}


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


SetLimits Method (startLimit, endLimit)

SetLimits Method (startLimit, endLimit)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation »SetLimits(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetLimits(
    double startLimit,
    double endLimit
)
Public Sub SetLimits ( _
    startLimit As Double, _
    endLimit As Double _
)
public:
void SetLimits(
    double startLimit,
    double endLimit
)
Parameters
startLimit(Double)
endLimit(Double)


StartLimit Property

StartLimit Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation »StartLimit
Declaration Syntax
C# Visual Basic Visual C++
public double StartLimit { get; }
Public ReadOnly Property StartLimit As Double
    Get
public:
property double StartLimit {
    double get ();
}


UseLimits Property

UseLimits Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation »UseLimits
Declaration Syntax
C# Visual Basic Visual C++
public bool UseLimits { get; set; }
Public Property UseLimits As Boolean
    Get
    Set
public:
property bool UseLimits {
    bool get ();
    void set (bool value);
}


LightingModel Enumeration

LightingModel Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightingModel
Declaration Syntax
C# Visual Basic Visual C++
public enum LightingModel
Public Enumeration LightingModel
public enum class LightingModel
Members
Member | Description
Gooch |
Phong |
Constant |
Invisible |


LightingQuality Enumeration

LightingQuality Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightingQuality
Declaration Syntax
C# Visual Basic Visual C++
public enum LightingQuality
Public Enumeration LightingQuality
public enum class LightingQuality
Members
Member | Description
PerVertexLighting |
PerFaceLighting |
NoLighting |


LightTraits Class

LightTraits Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightTraits
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiLightTraits")]
public abstract class LightTraits : NonEntityTraits
<WrapperAttribute("ZcGiLightTraits")> _
Public MustInherit Class LightTraits _
    Inherits NonEntityTraits
[WrapperAttribute(L"ZcGiLightTraits")]
public ref class LightTraits abstract : public NonEntityTraits
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightTraits(IntPtr, Boolean) |
 | LightTraits()()()() |
 | AddLight(ObjectId) | (Inherited from NonEntityTraits.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | Color | (Inherited from NonEntityTraits.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DrawFlags | (Inherited from NonEntityTraits.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | FillType | (Inherited from NonEntityTraits.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Layer | (Inherited from NonEntityTraits.)
 | LineType | (Inherited from NonEntityTraits.)
 | LineTypeScale | (Inherited from NonEntityTraits.)
 | LineWeight | (Inherited from NonEntityTraits.)
 | Mapper | (Inherited from NonEntityTraits.)
 | Material | (Inherited from NonEntityTraits.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | On |
 | PlotStyleDescriptor | (Inherited from NonEntityTraits.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Sectionable | (Inherited from NonEntityTraits.)
 | SelectionOnlyGeometry | (Inherited from NonEntityTraits.)
 | SetLayerFlags(DrawableTraits..::..LayerFlags) | (Inherited from NonEntityTraits.)
 | SetSelectionMarker(IntPtr) | (Inherited from NonEntityTraits.)
 | SetupForEntity(Entity) | (Inherited from NonEntityTraits.)
 | ShadowFlags | (Inherited from NonEntityTraits.)
 | Thickness | (Inherited from NonEntityTraits.)
 | ToString()()()() | (Inherited from Object.)
 | Transparency | (Inherited from NonEntityTraits.)
 | TrueColor | (Inherited from NonEntityTraits.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | VisualStyle | (Inherited from NonEntityTraits.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DrawableTraits
 |  |  |  |  | SubEntityTraits
 |  |  |  |  |  | NonEntityTraits
 |  |  |  |  |  |  | LightTraits


LightTraits Constructor

LightTraits Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightTraits »LightTraits()()()()
Members
Icon | Member | Description
 | LightTraits(IntPtr, Boolean) |
 | LightTraits()()()() |


LightTraits Constructor

LightTraits Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightTraits »LightTraits()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LightTraits()
Public Sub New
public:
LightTraits()


LightTraits Constructor (unmanagedPointer, autoDelete)

LightTraits Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightTraits »LightTraits(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal LightTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
LightTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


On Property

On Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightTraits »On
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool On { get; set; }
Public MustOverride Property On As Boolean
    Get
    Set
public:
virtual property bool On {
    bool get () abstract;
    void set (bool value) abstract;
}


Linetype Enumeration

Linetype Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Linetype
Declaration Syntax
C# Visual Basic Visual C++
public enum Linetype
Public Enumeration Linetype
public enum class Linetype
Members
Member | Description
Solid |
SparseDot |
MediumLongDash |
DoubleLongDash |
DoubleMediumDash |
DoubleShortDash |
LongDash |
MediumDash |
ShortDash |
Dotted |
Dashed |


LinetypeCollection Class

LinetypeCollection Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcArray<ZcGiLineType>")]
public sealed class LinetypeCollection : DisposableWrapper,
    IList
<WrapperAttribute("ZcArray<ZcGiLineType>")> _
Public NotInheritable Class LinetypeCollection _
    Inherits DisposableWrapper _
    Implements IList
[WrapperAttribute(L"ZcArray<ZcGiLineType>")]
public ref class LinetypeCollection sealed : public DisposableWrapper,
    IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinetypeCollection()()()() |
 | Add(Linetype) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(Linetype) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Remove(Object) |
 | IndexOf(Linetype) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, Linetype) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsFixedSize |
 | IsReadOnly |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Linetype) |
 | RemoveAt(Int32) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | LinetypeCollection


LinetypeCollection Constructor

LinetypeCollection Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »LinetypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LinetypeCollection()
Public Sub New
public:
LinetypeCollection()


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »Add(Linetype)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Linetype value
)
Public Function Add ( _
    value As Linetype _
) As Integer
public:
int Add(
    Linetype value
)
Parameters
value(Linetype)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »Contains(Linetype)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Linetype value
)
Public Function Contains ( _
    value As Linetype _
) As Boolean
public:
bool Contains(
    Linetype value
)
Parameters
value(Linetype)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (array, index)

ICollectionCopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array array,
    int index
)
Private Sub ICollectionCopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ array,
    int index
) sealed = ICollection::CopyTo
Parameters
array(Array)
index(Int32)


Ilist_Item Property (index)

Ilist_Item Property (index)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property Ilist_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ Ilist_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)


IListAdd Method (value)

IListAdd Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IListAdd ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IListAdd(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)


IListContains Method (value)

IListContains Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IListContains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IListContains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)


IListIndexOf Method (value)

IListIndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IListIndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IListIndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)


IListInsert Method (index, value)

IListInsert Method (index, value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IListInsert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IListInsert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)


IListRemove Method (value)

IListRemove Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IListRemove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IListRemove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »IndexOf(Linetype)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Linetype value
)
Public Function IndexOf ( _
    value As Linetype _
) As Integer
public:
int IndexOf(
    Linetype value
)
Parameters
value(Linetype)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »Insert(Int32, Linetype)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Linetype value
)
Public Sub Insert ( _
    index As Integer, _
    value As Linetype _
)
public:
void Insert(
    int index,
    Linetype value
)
Parameters
index(Int32)
value(Linetype)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property ()

Item Property ()
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Linetype this[
    int
] { get; set; }
Public Default Property Item ( _
     As Integer _
) As Linetype
    Get
    Set
public:
property Linetype default[int ] {
    Linetype get (int );
    void set (int , Linetype value);
}
Parameters
(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »Remove(Linetype)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Linetype value
)
Public Sub Remove ( _
    value As Linetype _
)
public:
void Remove(
    Linetype value
)
Parameters
value(Linetype)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


LuminanceMode Enumeration

LuminanceMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LuminanceMode
Declaration Syntax
C# Visual Basic Visual C++
public enum LuminanceMode
Public Enumeration LuminanceMode
public enum class LuminanceMode
Members
Member | Description
Luminance |
SelfIllumination |


MapChannel Enumeration

MapChannel Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MapChannel
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiVertexData::MapChannel")]
public enum MapChannel
<WrapperAttribute("ZcGiVertexData::MapChannel")> _
Public Enumeration MapChannel
[WrapperAttribute(L"ZcGiVertexData::MapChannel")]
public enum class MapChannel
Members
Member | Description
MapChannels |
AllChannels |


MapFilter Enumeration

MapFilter Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MapFilter
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiMaterialMap::Filter")]
public enum MapFilter
<WrapperAttribute("ZcGiMaterialMap::Filter")> _
Public Enumeration MapFilter
[WrapperAttribute(L"ZcGiMaterialMap::Filter")]
public enum class MapFilter
Members
Member | Description
Default |
None |


Mapper Class

Mapper Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiMapper")]
public sealed class Mapper : RXObject
<WrapperAttribute("ZcGiMapper")> _
Public NotInheritable Class Mapper _
    Inherits RXObject
[WrapperAttribute(L"ZcGiMapper")]
public ref class Mapper sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Mapper(Projection, Tiling, Tiling, AutoTransform, Matrix3d) |
 | Mapper()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | AutoTransform |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Overrides DisposableWrapper.Equals(Object).)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Overrides DisposableWrapper.GetHashCode()()()().)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Projection |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | Transform |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UTiling |
 | VTiling |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Mapper


Mapper Constructor

Mapper Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »Mapper()()()()
Members
Icon | Member | Description
 | Mapper(Projection, Tiling, Tiling, AutoTransform, Matrix3d) |
 | Mapper()()()() |


Mapper Constructor

Mapper Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »Mapper()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Mapper()
Public Sub New
public:
Mapper()


Mapper Constructor (projection, Utiling, Vtiling, autoTransform, transform)

Mapper Constructor (projection, Utiling, Vtiling, autoTransform, transform)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »Mapper(Projection, Tiling, Tiling, AutoTransform, Matrix3d)
Declaration Syntax
C# Visual Basic Visual C++
public Mapper(
    Projection projection,
    Tiling Utiling,
    Tiling Vtiling,
    AutoTransform autoTransform,
    Matrix3d transform
)
Public Sub New ( _
    projection As Projection, _
    Utiling As Tiling, _
    Vtiling As Tiling, _
    autoTransform As AutoTransform, _
    transform As Matrix3d _
)
public:
Mapper(
    Projection projection,
    Tiling Utiling,
    Tiling Vtiling,
    AutoTransform autoTransform,
    Matrix3d transform
)
Parameters
projection(Projection)
Utiling(Tiling)
Vtiling(Tiling)
autoTransform(AutoTransform)
transform(Matrix3d)


AutoTransform Property

AutoTransform Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »AutoTransform
Declaration Syntax
C# Visual Basic Visual C++
public AutoTransform AutoTransform { get; set; }
Public Property AutoTransform As AutoTransform
    Get
    Set
public:
property AutoTransform AutoTransform {
    AutoTransform get ();
    void set (AutoTransform value);
}


Equals Method (other)

Equals Method (other)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object other
)
Public Overrides NotOverridable Function Equals ( _
    other As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override sealed
Parameters
other(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed


Projection Property

Projection Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »Projection
Declaration Syntax
C# Visual Basic Visual C++
public Projection Projection { get; set; }
Public Property Projection As Projection
    Get
    Set
public:
property Projection Projection {
    Projection get ();
    void set (Projection value);
}


Transform Property

Transform Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »Transform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d Transform { get; set; }
Public Property Transform As Matrix3d
    Get
    Set
public:
property Matrix3d Transform {
    Matrix3d get ();
    void set (Matrix3d value);
}


UTiling Property

UTiling Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »UTiling
Declaration Syntax
C# Visual Basic Visual C++
public Tiling UTiling { get; set; }
Public Property UTiling As Tiling
    Get
    Set
public:
property Tiling UTiling {
    Tiling get ();
    void set (Tiling value);
}


VTiling Property

VTiling Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »VTiling
Declaration Syntax
C# Visual Basic Visual C++
public Tiling VTiling { get; set; }
Public Property VTiling As Tiling
    Get
    Set
public:
property Tiling VTiling {
    Tiling get ();
    void set (Tiling value);
}


MentalRayRenderSettingsTraits Class

MentalRayRenderSettingsTraits Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiMentalRayRenderSettingsTraits")]
public abstract class MentalRayRenderSettingsTraits : RenderSettingsTraits
<WrapperAttribute("ZcGiMentalRayRenderSettingsTraits")> _
Public MustInherit Class MentalRayRenderSettingsTraits _
    Inherits RenderSettingsTraits
[WrapperAttribute(L"ZcGiMentalRayRenderSettingsTraits")]
public ref class MentalRayRenderSettingsTraits abstract : public RenderSettingsTraits
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MentalRayRenderSettingsTraits(IntPtr, Boolean) |
 | AddLight(ObjectId) | (Inherited from NonEntityTraits.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackFacesEnabled | (Inherited from RenderSettingsTraits.)
 | Clone()()()() | (Inherited from RXObject.)
 | Color | (Inherited from NonEntityTraits.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DiagnosticBackgroundEnabled | (Inherited from RenderSettingsTraits.)
 | DiagnosticBSPMode |
 | DiagnosticGridMode |
 | DiagnosticMode |
 | DiagnosticPhotonMode |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DrawFlags | (Inherited from NonEntityTraits.)
 | EnergyMultiplier |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | ExportMIEnabled |
 | ExportMIFileName |
 | FGRayCount |
 | FGSampleRadius |
 | FGSampleRadiusState |
 | FillType | (Inherited from NonEntityTraits.)
 | FinalGatheringEnabled |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | GIPhotonsPerLight |
 | GISampleCount |
 | GISampleRadius |
 | GISampleRadiusEnabled |
 | GlobalIlluminationEnabled |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Layer | (Inherited from NonEntityTraits.)
 | LightLuminanceScale |
 | LineType | (Inherited from NonEntityTraits.)
 | LineTypeScale | (Inherited from NonEntityTraits.)
 | LineWeight | (Inherited from NonEntityTraits.)
 | Mapper | (Inherited from NonEntityTraits.)
 | Material | (Inherited from NonEntityTraits.)
 | MaterialEnabled | (Inherited from RenderSettingsTraits.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MemoryLimit |
 | ModelScaleFactor | (Inherited from RenderSettingsTraits.)
 | PhotonTraceDepth |
 | PlotStyleDescriptor | (Inherited from NonEntityTraits.)
 | ProgressMonitor |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RayTraceDepth |
 | RayTraceEnabled |
 | Sampling |
 | SamplingContrastColor |
 | SamplingFilter |
 | Sectionable | (Inherited from NonEntityTraits.)
 | SelectionOnlyGeometry | (Inherited from NonEntityTraits.)
 | SetLayerFlags(DrawableTraits..::..LayerFlags) | (Inherited from NonEntityTraits.)
 | SetSelectionMarker(IntPtr) | (Inherited from NonEntityTraits.)
 | SetupForEntity(Entity) | (Inherited from NonEntityTraits.)
 | ShadowFlags | (Inherited from NonEntityTraits.)
 | ShadowMapEnabled |
 | ShadowMode |
 | ShadowsEnabled | (Inherited from RenderSettingsTraits.)
 | TextureSampling | (Inherited from RenderSettingsTraits.)
 | Thickness | (Inherited from NonEntityTraits.)
 | TileOrder |
 | TileSize |
 | ToString()()()() | (Inherited from Object.)
 | Transparency | (Inherited from NonEntityTraits.)
 | TrueColor | (Inherited from NonEntityTraits.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | VisualStyle | (Inherited from NonEntityTraits.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DrawableTraits
 |  |  |  |  | SubEntityTraits
 |  |  |  |  |  | NonEntityTraits
 |  |  |  |  |  |  | RenderSettingsTraits
 |  |  |  |  |  |  |  | MentalRayRenderSettingsTraits
 |  |  |  |  |  |  |  |  | MentalRayRenderSettingsTraits2


MentalRayRenderSettingsTraits Constructor (unmanagedPointer, autoDelete)

MentalRayRenderSettingsTraits Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »MentalRayRenderSettingsTraits(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal MentalRayRenderSettingsTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
MentalRayRenderSettingsTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DiagnosticBSPMode Property

DiagnosticBSPMode Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »DiagnosticBSPMode
Declaration Syntax
C# Visual Basic Visual C++
public abstract DiagnosticBSPMode DiagnosticBSPMode { get; set; }
Public MustOverride Property DiagnosticBSPMode As DiagnosticBSPMode
    Get
    Set
public:
virtual property DiagnosticBSPMode DiagnosticBSPMode {
    DiagnosticBSPMode get () abstract;
    void set (DiagnosticBSPMode value) abstract;
}


DiagnosticGridMode Property

DiagnosticGridMode Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »DiagnosticGridMode
Declaration Syntax
C# Visual Basic Visual C++
public abstract MentalRayRenderSettingsTraitsDiagnosticGridModeParameter DiagnosticGridMode { get; set; }
Public MustOverride Property DiagnosticGridMode As MentalRayRenderSettingsTraitsDiagnosticGridModeParameter
    Get
    Set
public:
virtual property MentalRayRenderSettingsTraitsDiagnosticGridModeParameter DiagnosticGridMode {
    MentalRayRenderSettingsTraitsDiagnosticGridModeParameter get () abstract;
    void set (MentalRayRenderSettingsTraitsDiagnosticGridModeParameter value) abstract;
}


DiagnosticMode Property

DiagnosticMode Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »DiagnosticMode
Declaration Syntax
C# Visual Basic Visual C++
public abstract DiagnosticMode DiagnosticMode { get; set; }
Public MustOverride Property DiagnosticMode As DiagnosticMode
    Get
    Set
public:
virtual property DiagnosticMode DiagnosticMode {
    DiagnosticMode get () abstract;
    void set (DiagnosticMode value) abstract;
}


DiagnosticPhotonMode Property

DiagnosticPhotonMode Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »DiagnosticPhotonMode
Declaration Syntax
C# Visual Basic Visual C++
public abstract DiagnosticPhotonMode DiagnosticPhotonMode { get; set; }
Public MustOverride Property DiagnosticPhotonMode As DiagnosticPhotonMode
    Get
    Set
public:
virtual property DiagnosticPhotonMode DiagnosticPhotonMode {
    DiagnosticPhotonMode get () abstract;
    void set (DiagnosticPhotonMode value) abstract;
}


EnergyMultiplier Property

EnergyMultiplier Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »EnergyMultiplier
Declaration Syntax
C# Visual Basic Visual C++
public abstract float EnergyMultiplier { get; set; }
Public MustOverride Property EnergyMultiplier As Single
    Get
    Set
public:
virtual property float EnergyMultiplier {
    float get () abstract;
    void set (float value) abstract;
}


ExportMIEnabled Property

ExportMIEnabled Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »ExportMIEnabled
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool ExportMIEnabled { get; set; }
Public MustOverride Property ExportMIEnabled As Boolean
    Get
    Set
public:
virtual property bool ExportMIEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}


ExportMIFileName Property

ExportMIFileName Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »ExportMIFileName
Declaration Syntax
C# Visual Basic Visual C++
public abstract string ExportMIFileName { get; set; }
Public MustOverride Property ExportMIFileName As String
    Get
    Set
public:
virtual property String^ ExportMIFileName {
    String^ get () abstract;
    void set (String^ value) abstract;
}


FGRayCount Property

FGRayCount Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »FGRayCount
Declaration Syntax
C# Visual Basic Visual C++
public abstract int FGRayCount { get; set; }
Public MustOverride Property FGRayCount As Integer
    Get
    Set
public:
virtual property int FGRayCount {
    int get () abstract;
    void set (int value) abstract;
}


FGSampleRadius Property

FGSampleRadius Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »FGSampleRadius
Declaration Syntax
C# Visual Basic Visual C++
public abstract MentalRayRenderSettingsTraitsDoubleRangeParameter FGSampleRadius { get; set; }
Public MustOverride Property FGSampleRadius As MentalRayRenderSettingsTraitsDoubleRangeParameter
    Get
    Set
public:
virtual property MentalRayRenderSettingsTraitsDoubleRangeParameter FGSampleRadius {
    MentalRayRenderSettingsTraitsDoubleRangeParameter get () abstract;
    void set (MentalRayRenderSettingsTraitsDoubleRangeParameter value) abstract;
}


FGSampleRadiusState Property

FGSampleRadiusState Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »FGSampleRadiusState
Declaration Syntax
C# Visual Basic Visual C++
public abstract MentalRayRenderSettingsTraitsBoolParameter FGSampleRadiusState { get; set; }
Public MustOverride Property FGSampleRadiusState As MentalRayRenderSettingsTraitsBoolParameter
    Get
    Set
public:
virtual property MentalRayRenderSettingsTraitsBoolParameter FGSampleRadiusState {
    MentalRayRenderSettingsTraitsBoolParameter get () abstract;
    void set (MentalRayRenderSettingsTraitsBoolParameter value) abstract;
}


FinalGatheringEnabled Property

FinalGatheringEnabled Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »FinalGatheringEnabled
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool FinalGatheringEnabled { get; set; }
Public MustOverride Property FinalGatheringEnabled As Boolean
    Get
    Set
public:
virtual property bool FinalGatheringEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}


GIPhotonsPerLight Property

GIPhotonsPerLight Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »GIPhotonsPerLight
Declaration Syntax
C# Visual Basic Visual C++
public abstract int GIPhotonsPerLight { get; set; }
Public MustOverride Property GIPhotonsPerLight As Integer
    Get
    Set
public:
virtual property int GIPhotonsPerLight {
    int get () abstract;
    void set (int value) abstract;
}


GISampleCount Property

GISampleCount Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »GISampleCount
Declaration Syntax
C# Visual Basic Visual C++
public abstract int GISampleCount { get; set; }
Public MustOverride Property GISampleCount As Integer
    Get
    Set
public:
virtual property int GISampleCount {
    int get () abstract;
    void set (int value) abstract;
}


GISampleRadius Property

GISampleRadius Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »GISampleRadius
Declaration Syntax
C# Visual Basic Visual C++
public abstract double GISampleRadius { get; set; }
Public MustOverride Property GISampleRadius As Double
    Get
    Set
public:
virtual property double GISampleRadius {
    double get () abstract;
    void set (double value) abstract;
}


GISampleRadiusEnabled Property

GISampleRadiusEnabled Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »GISampleRadiusEnabled
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool GISampleRadiusEnabled { get; set; }
Public MustOverride Property GISampleRadiusEnabled As Boolean
    Get
    Set
public:
virtual property bool GISampleRadiusEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}


GlobalIlluminationEnabled Property

GlobalIlluminationEnabled Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »GlobalIlluminationEnabled
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool GlobalIlluminationEnabled { get; set; }
Public MustOverride Property GlobalIlluminationEnabled As Boolean
    Get
    Set
public:
virtual property bool GlobalIlluminationEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}


LightLuminanceScale Property

LightLuminanceScale Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »LightLuminanceScale
Declaration Syntax
C# Visual Basic Visual C++
public abstract double LightLuminanceScale { get; set; }
Public MustOverride Property LightLuminanceScale As Double
    Get
    Set
public:
virtual property double LightLuminanceScale {
    double get () abstract;
    void set (double value) abstract;
}


MemoryLimit Property

MemoryLimit Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »MemoryLimit
Declaration Syntax
C# Visual Basic Visual C++
public abstract int MemoryLimit { get; set; }
Public MustOverride Property MemoryLimit As Integer
    Get
    Set
public:
virtual property int MemoryLimit {
    int get () abstract;
    void set (int value) abstract;
}


PhotonTraceDepth Property

PhotonTraceDepth Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »PhotonTraceDepth
Declaration Syntax
C# Visual Basic Visual C++
public abstract MentalRayRenderSettingsTraitsTraceParameter PhotonTraceDepth { get; set; }
Public MustOverride Property PhotonTraceDepth As MentalRayRenderSettingsTraitsTraceParameter
    Get
    Set
public:
virtual property MentalRayRenderSettingsTraitsTraceParameter PhotonTraceDepth {
    MentalRayRenderSettingsTraitsTraceParameter get () abstract;
    void set (MentalRayRenderSettingsTraitsTraceParameter value) abstract;
}


ProgressMonitor Property

ProgressMonitor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »ProgressMonitor
Declaration Syntax
C# Visual Basic Visual C++
public abstract IntPtr ProgressMonitor { get; set; }
Public MustOverride Property ProgressMonitor As IntPtr
    Get
    Set
public:
virtual property IntPtr ProgressMonitor {
    IntPtr get () abstract;
    void set (IntPtr value) abstract;
}


RayTraceDepth Property

RayTraceDepth Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »RayTraceDepth
Declaration Syntax
C# Visual Basic Visual C++
public abstract MentalRayRenderSettingsTraitsTraceParameter RayTraceDepth { get; set; }
Public MustOverride Property RayTraceDepth As MentalRayRenderSettingsTraitsTraceParameter
    Get
    Set
public:
virtual property MentalRayRenderSettingsTraitsTraceParameter RayTraceDepth {
    MentalRayRenderSettingsTraitsTraceParameter get () abstract;
    void set (MentalRayRenderSettingsTraitsTraceParameter value) abstract;
}


RayTraceEnabled Property

RayTraceEnabled Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »RayTraceEnabled
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool RayTraceEnabled { get; set; }
Public MustOverride Property RayTraceEnabled As Boolean
    Get
    Set
public:
virtual property bool RayTraceEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}


Sampling Property

Sampling Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »Sampling
Declaration Syntax
C# Visual Basic Visual C++
public abstract MentalRayRenderSettingsTraitsIntegerRangeParameter Sampling { get; set; }
Public MustOverride Property Sampling As MentalRayRenderSettingsTraitsIntegerRangeParameter
    Get
    Set
public:
virtual property MentalRayRenderSettingsTraitsIntegerRangeParameter Sampling {
    MentalRayRenderSettingsTraitsIntegerRangeParameter get () abstract;
    void set (MentalRayRenderSettingsTraitsIntegerRangeParameter value) abstract;
}


SamplingContrastColor Property

SamplingContrastColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »SamplingContrastColor
Declaration Syntax
C# Visual Basic Visual C++
public abstract MentalRayRenderSettingsTraitsFloatParameter SamplingContrastColor { get; set; }
Public MustOverride Property SamplingContrastColor As MentalRayRenderSettingsTraitsFloatParameter
    Get
    Set
public:
virtual property MentalRayRenderSettingsTraitsFloatParameter SamplingContrastColor {
    MentalRayRenderSettingsTraitsFloatParameter get () abstract;
    void set (MentalRayRenderSettingsTraitsFloatParameter value) abstract;
}


SamplingFilter Property

SamplingFilter Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »SamplingFilter
Declaration Syntax
C# Visual Basic Visual C++
public abstract MentalRayRenderSettingsTraitsSamplingParameter SamplingFilter { get; set; }
Public MustOverride Property SamplingFilter As MentalRayRenderSettingsTraitsSamplingParameter
    Get
    Set
public:
virtual property MentalRayRenderSettingsTraitsSamplingParameter SamplingFilter {
    MentalRayRenderSettingsTraitsSamplingParameter get () abstract;
    void set (MentalRayRenderSettingsTraitsSamplingParameter value) abstract;
}


ShadowMapEnabled Property

ShadowMapEnabled Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »ShadowMapEnabled
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool ShadowMapEnabled { get; set; }
Public MustOverride Property ShadowMapEnabled As Boolean
    Get
    Set
public:
virtual property bool ShadowMapEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}


ShadowMode Property

ShadowMode Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »ShadowMode
Declaration Syntax
C# Visual Basic Visual C++
public abstract ShadowMode ShadowMode { get; set; }
Public MustOverride Property ShadowMode As ShadowMode
    Get
    Set
public:
virtual property ShadowMode ShadowMode {
    ShadowMode get () abstract;
    void set (ShadowMode value) abstract;
}


TileOrder Property

TileOrder Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »TileOrder
Declaration Syntax
C# Visual Basic Visual C++
public abstract TileOrder TileOrder { get; set; }
Public MustOverride Property TileOrder As TileOrder
    Get
    Set
public:
virtual property TileOrder TileOrder {
    TileOrder get () abstract;
    void set (TileOrder value) abstract;
}


TileSize Property

TileSize Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »TileSize
Declaration Syntax
C# Visual Basic Visual C++
public abstract int TileSize { get; set; }
Public MustOverride Property TileSize As Integer
    Get
    Set
public:
virtual property int TileSize {
    int get () abstract;
    void set (int value) abstract;
}


MentalRayRenderSettingsTraits2 Class

MentalRayRenderSettingsTraits2 Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits2
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiMentalRayRenderSettingsTraits2")]
public abstract class MentalRayRenderSettingsTraits2 : MentalRayRenderSettingsTraits
<WrapperAttribute("ZcGiMentalRayRenderSettingsTraits2")> _
Public MustInherit Class MentalRayRenderSettingsTraits2 _
    Inherits MentalRayRenderSettingsTraits
[WrapperAttribute(L"ZcGiMentalRayRenderSettingsTraits2")]
public ref class MentalRayRenderSettingsTraits2 abstract : public MentalRayRenderSettingsTraits
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MentalRayRenderSettingsTraits2(IntPtr, Boolean) |
 | AddLight(ObjectId) | (Inherited from NonEntityTraits.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackFacesEnabled | (Inherited from RenderSettingsTraits.)
 | Clone()()()() | (Inherited from RXObject.)
 | Color | (Inherited from NonEntityTraits.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DiagnosticBackgroundEnabled | (Inherited from RenderSettingsTraits.)
 | DiagnosticBSPMode | (Inherited from MentalRayRenderSettingsTraits.)
 | DiagnosticGridMode | (Inherited from MentalRayRenderSettingsTraits.)
 | DiagnosticMode | (Inherited from MentalRayRenderSettingsTraits.)
 | DiagnosticPhotonMode | (Inherited from MentalRayRenderSettingsTraits.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DrawFlags | (Inherited from NonEntityTraits.)
 | EnergyMultiplier | (Inherited from MentalRayRenderSettingsTraits.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | ExportMIEnabled | (Inherited from MentalRayRenderSettingsTraits.)
 | ExportMIFileName | (Inherited from MentalRayRenderSettingsTraits.)
 | ExposureType |
 | FGRayCount | (Inherited from MentalRayRenderSettingsTraits.)
 | FGSampleRadius | (Inherited from MentalRayRenderSettingsTraits.)
 | FGSampleRadiusState | (Inherited from MentalRayRenderSettingsTraits.)
 | FillType | (Inherited from NonEntityTraits.)
 | FinalGatheringEnabled | (Inherited from MentalRayRenderSettingsTraits.)
 | FinalGatheringMode |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | GIPhotonsPerLight | (Inherited from MentalRayRenderSettingsTraits.)
 | GISampleCount | (Inherited from MentalRayRenderSettingsTraits.)
 | GISampleRadius | (Inherited from MentalRayRenderSettingsTraits.)
 | GISampleRadiusEnabled | (Inherited from MentalRayRenderSettingsTraits.)
 | GlobalIlluminationEnabled | (Inherited from MentalRayRenderSettingsTraits.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Layer | (Inherited from NonEntityTraits.)
 | LightLuminanceScale | (Inherited from MentalRayRenderSettingsTraits.)
 | LineType | (Inherited from NonEntityTraits.)
 | LineTypeScale | (Inherited from NonEntityTraits.)
 | LineWeight | (Inherited from NonEntityTraits.)
 | Mapper | (Inherited from NonEntityTraits.)
 | Material | (Inherited from NonEntityTraits.)
 | MaterialEnabled | (Inherited from RenderSettingsTraits.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MemoryLimit | (Inherited from MentalRayRenderSettingsTraits.)
 | ModelScaleFactor | (Inherited from RenderSettingsTraits.)
 | PhotonTraceDepth | (Inherited from MentalRayRenderSettingsTraits.)
 | PlotStyleDescriptor | (Inherited from NonEntityTraits.)
 | ProgressMonitor | (Inherited from MentalRayRenderSettingsTraits.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RayTraceDepth | (Inherited from MentalRayRenderSettingsTraits.)
 | RayTraceEnabled | (Inherited from MentalRayRenderSettingsTraits.)
 | Sampling | (Inherited from MentalRayRenderSettingsTraits.)
 | SamplingContrastColor | (Inherited from MentalRayRenderSettingsTraits.)
 | SamplingFilter | (Inherited from MentalRayRenderSettingsTraits.)
 | Sectionable | (Inherited from NonEntityTraits.)
 | SelectionOnlyGeometry | (Inherited from NonEntityTraits.)
 | SetLayerFlags(DrawableTraits..::..LayerFlags) | (Inherited from NonEntityTraits.)
 | SetSelectionMarker(IntPtr) | (Inherited from NonEntityTraits.)
 | SetupForEntity(Entity) | (Inherited from NonEntityTraits.)
 | ShadowFlags | (Inherited from NonEntityTraits.)
 | ShadowMapEnabled | (Inherited from MentalRayRenderSettingsTraits.)
 | ShadowMode | (Inherited from MentalRayRenderSettingsTraits.)
 | ShadowSamplingMultiplier |
 | ShadowsEnabled | (Inherited from RenderSettingsTraits.)
 | TextureSampling | (Inherited from RenderSettingsTraits.)
 | Thickness | (Inherited from NonEntityTraits.)
 | TileOrder | (Inherited from MentalRayRenderSettingsTraits.)
 | TileSize | (Inherited from MentalRayRenderSettingsTraits.)
 | ToString()()()() | (Inherited from Object.)
 | Transparency | (Inherited from NonEntityTraits.)
 | TrueColor | (Inherited from NonEntityTraits.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | VisualStyle | (Inherited from NonEntityTraits.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DrawableTraits
 |  |  |  |  | SubEntityTraits
 |  |  |  |  |  | NonEntityTraits
 |  |  |  |  |  |  | RenderSettingsTraits
 |  |  |  |  |  |  |  | MentalRayRenderSettingsTraits
 |  |  |  |  |  |  |  |  | MentalRayRenderSettingsTraits2


MentalRayRenderSettingsTraits2 Constructor (unmanagedPointer, autoDelete)

MentalRayRenderSettingsTraits2 Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits2 »MentalRayRenderSettingsTraits2(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal MentalRayRenderSettingsTraits2(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
MentalRayRenderSettingsTraits2(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ExposureType Property

ExposureType Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits2 »ExposureType
Declaration Syntax
C# Visual Basic Visual C++
public abstract ExposureType ExposureType { get; set; }
Public MustOverride Property ExposureType As ExposureType
    Get
    Set
public:
virtual property ExposureType ExposureType {
    ExposureType get () abstract;
    void set (ExposureType value) abstract;
}


FinalGatheringMode Property

FinalGatheringMode Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits2 »FinalGatheringMode
Declaration Syntax
C# Visual Basic Visual C++
public abstract FinalGatheringMode FinalGatheringMode { get; set; }
Public MustOverride Property FinalGatheringMode As FinalGatheringMode
    Get
    Set
public:
virtual property FinalGatheringMode FinalGatheringMode {
    FinalGatheringMode get () abstract;
    void set (FinalGatheringMode value) abstract;
}


ShadowSamplingMultiplier Property

ShadowSamplingMultiplier Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits2 »ShadowSamplingMultiplier
Declaration Syntax
C# Visual Basic Visual C++
public abstract double ShadowSamplingMultiplier { get; set; }
Public MustOverride Property ShadowSamplingMultiplier As Double
    Get
    Set
public:
virtual property double ShadowSamplingMultiplier {
    double get () abstract;
    void set (double value) abstract;
}


MentalRayRenderSettingsTraitsBoolParameter Structure

MentalRayRenderSettingsTraitsBoolParameter Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsBoolParameter
Declaration Syntax
C# Visual Basic Visual C++
public struct MentalRayRenderSettingsTraitsBoolParameter
Public Structure MentalRayRenderSettingsTraitsBoolParameter
public value class MentalRayRenderSettingsTraitsBoolParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MentalRayRenderSettingsTraitsBoolParameter(Boolean, Boolean, Boolean) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Max |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Min |
 | Pixels |
 | ToString()()()() | (Inherited from ValueType.)


MentalRayRenderSettingsTraitsBoolParameter Constructor (a, b, pix)

MentalRayRenderSettingsTraitsBoolParameter Constructor (a, b, pix)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsBoolParameter »MentalRayRenderSettingsTraitsBoolParameter(Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public MentalRayRenderSettingsTraitsBoolParameter(
    bool a,
    bool b,
    bool pix
)
Public Sub New ( _
    a As Boolean, _
    b As Boolean, _
    pix As Boolean _
)
public:
MentalRayRenderSettingsTraitsBoolParameter(
    bool a,
    bool b,
    bool pix
)
Parameters
a(Boolean)
b(Boolean)
pix(Boolean)


Max Property

Max Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsBoolParameter »Max
Declaration Syntax
C# Visual Basic Visual C++
public bool Max { get; }
Public ReadOnly Property Max As Boolean
    Get
public:
property bool Max {
    bool get ();
}


Min Property

Min Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsBoolParameter »Min
Declaration Syntax
C# Visual Basic Visual C++
public bool Min { get; }
Public ReadOnly Property Min As Boolean
    Get
public:
property bool Min {
    bool get ();
}


Pixels Property

Pixels Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsBoolParameter »Pixels
Declaration Syntax
C# Visual Basic Visual C++
public bool Pixels { get; }
Public ReadOnly Property Pixels As Boolean
    Get
public:
property bool Pixels {
    bool get ();
}


MentalRayRenderSettingsTraitsDiagnosticGridModeParameter Structure

MentalRayRenderSettingsTraitsDiagnosticGridModeParameter Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsDiagnosticGridModeParameter
Declaration Syntax
C# Visual Basic Visual C++
public struct MentalRayRenderSettingsTraitsDiagnosticGridModeParameter
Public Structure MentalRayRenderSettingsTraitsDiagnosticGridModeParameter
public value class MentalRayRenderSettingsTraitsDiagnosticGridModeParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MentalRayRenderSettingsTraitsDiagnosticGridModeParameter(DiagnosticGridMode, Single) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mode |
 | Size |
 | ToString()()()() | (Inherited from ValueType.)


MentalRayRenderSettingsTraitsDiagnosticGridModeParameter Constructor (m, s)

MentalRayRenderSettingsTraitsDiagnosticGridModeParameter Constructor (m, s)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsDiagnosticGridModeParameter »MentalRayRenderSettingsTraitsDiagnosticGridModeParameter(DiagnosticGridMode, Single)
Declaration Syntax
C# Visual Basic Visual C++
public MentalRayRenderSettingsTraitsDiagnosticGridModeParameter(
    DiagnosticGridMode m,
    float s
)
Public Sub New ( _
    m As DiagnosticGridMode, _
    s As Single _
)
public:
MentalRayRenderSettingsTraitsDiagnosticGridModeParameter(
    DiagnosticGridMode m,
    float s
)
Parameters
m(DiagnosticGridMode)
s(Single)


Mode Property

Mode Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsDiagnosticGridModeParameter »Mode
Declaration Syntax
C# Visual Basic Visual C++
public DiagnosticGridMode Mode { get; }
Public ReadOnly Property Mode As DiagnosticGridMode
    Get
public:
property DiagnosticGridMode Mode {
    DiagnosticGridMode get ();
}


Size Property

Size Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsDiagnosticGridModeParameter »Size
Declaration Syntax
C# Visual Basic Visual C++
public float Size { get; }
Public ReadOnly Property Size As Single
    Get
public:
property float Size {
    float get ();
}


MentalRayRenderSettingsTraitsDoubleRangeParameter Structure

MentalRayRenderSettingsTraitsDoubleRangeParameter Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsDoubleRangeParameter
Declaration Syntax
C# Visual Basic Visual C++
public struct MentalRayRenderSettingsTraitsDoubleRangeParameter
Public Structure MentalRayRenderSettingsTraitsDoubleRangeParameter
public value class MentalRayRenderSettingsTraitsDoubleRangeParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MentalRayRenderSettingsTraitsDoubleRangeParameter(Double, Double) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Max |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Min |
 | ToString()()()() | (Inherited from ValueType.)


MentalRayRenderSettingsTraitsDoubleRangeParameter Constructor (a, b)

MentalRayRenderSettingsTraitsDoubleRangeParameter Constructor (a, b)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsDoubleRangeParameter »MentalRayRenderSettingsTraitsDoubleRangeParameter(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public MentalRayRenderSettingsTraitsDoubleRangeParameter(
    double a,
    double b
)
Public Sub New ( _
    a As Double, _
    b As Double _
)
public:
MentalRayRenderSettingsTraitsDoubleRangeParameter(
    double a,
    double b
)
Parameters
a(Double)
b(Double)


Max Property

Max Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsDoubleRangeParameter »Max
Declaration Syntax
C# Visual Basic Visual C++
public double Max { get; }
Public ReadOnly Property Max As Double
    Get
public:
property double Max {
    double get ();
}


Min Property

Min Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsDoubleRangeParameter »Min
Declaration Syntax
C# Visual Basic Visual C++
public double Min { get; }
Public ReadOnly Property Min As Double
    Get
public:
property double Min {
    double get ();
}


MentalRayRenderSettingsTraitsFloatParameter Structure

MentalRayRenderSettingsTraitsFloatParameter Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsFloatParameter
Declaration Syntax
C# Visual Basic Visual C++
public struct MentalRayRenderSettingsTraitsFloatParameter
Public Structure MentalRayRenderSettingsTraitsFloatParameter
public value class MentalRayRenderSettingsTraitsFloatParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MentalRayRenderSettingsTraitsFloatParameter(Single, Single, Single, Single) |
 | A |
 | B |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | G |
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | R |
 | ToString()()()() | (Inherited from ValueType.)


MentalRayRenderSettingsTraitsFloatParameter Constructor (red, green, blue, alpha)

MentalRayRenderSettingsTraitsFloatParameter Constructor (red, green, blue, alpha)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsFloatParameter »MentalRayRenderSettingsTraitsFloatParameter(Single, Single, Single, Single)
Declaration Syntax
C# Visual Basic Visual C++
public MentalRayRenderSettingsTraitsFloatParameter(
    float red,
    float green,
    float blue,
    float alpha
)
Public Sub New ( _
    red As Single, _
    green As Single, _
    blue As Single, _
    alpha As Single _
)
public:
MentalRayRenderSettingsTraitsFloatParameter(
    float red,
    float green,
    float blue,
    float alpha
)
Parameters
red(Single)
green(Single)
blue(Single)
alpha(Single)


A Property

A Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsFloatParameter »A
Declaration Syntax
C# Visual Basic Visual C++
public float A { get; }
Public ReadOnly Property A As Single
    Get
public:
property float A {
    float get ();
}


B Property

B Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsFloatParameter »B
Declaration Syntax
C# Visual Basic Visual C++
public float B { get; }
Public ReadOnly Property B As Single
    Get
public:
property float B {
    float get ();
}


G Property

G Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsFloatParameter »G
Declaration Syntax
C# Visual Basic Visual C++
public float G { get; }
Public ReadOnly Property G As Single
    Get
public:
property float G {
    float get ();
}


R Property

R Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsFloatParameter »R
Declaration Syntax
C# Visual Basic Visual C++
public float R { get; }
Public ReadOnly Property R As Single
    Get
public:
property float R {
    float get ();
}


MentalRayRenderSettingsTraitsIntegerRangeParameter Structure

MentalRayRenderSettingsTraitsIntegerRangeParameter Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsIntegerRangeParameter
Declaration Syntax
C# Visual Basic Visual C++
public struct MentalRayRenderSettingsTraitsIntegerRangeParameter
Public Structure MentalRayRenderSettingsTraitsIntegerRangeParameter
public value class MentalRayRenderSettingsTraitsIntegerRangeParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MentalRayRenderSettingsTraitsIntegerRangeParameter(Int32, Int32) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Max |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Min |
 | ToString()()()() | (Inherited from ValueType.)


MentalRayRenderSettingsTraitsIntegerRangeParameter Constructor (a, b)

MentalRayRenderSettingsTraitsIntegerRangeParameter Constructor (a, b)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsIntegerRangeParameter »MentalRayRenderSettingsTraitsIntegerRangeParameter(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MentalRayRenderSettingsTraitsIntegerRangeParameter(
    int a,
    int b
)
Public Sub New ( _
    a As Integer, _
    b As Integer _
)
public:
MentalRayRenderSettingsTraitsIntegerRangeParameter(
    int a,
    int b
)
Parameters
a(Int32)
b(Int32)


Max Property

Max Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsIntegerRangeParameter »Max
Declaration Syntax
C# Visual Basic Visual C++
public int Max { get; }
Public ReadOnly Property Max As Integer
    Get
public:
property int Max {
    int get ();
}


Min Property

Min Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsIntegerRangeParameter »Min
Declaration Syntax
C# Visual Basic Visual C++
public int Min { get; }
Public ReadOnly Property Min As Integer
    Get
public:
property int Min {
    int get ();
}


MentalRayRenderSettingsTraitsSamplingParameter Structure

MentalRayRenderSettingsTraitsSamplingParameter Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsSamplingParameter
Declaration Syntax
C# Visual Basic Visual C++
public struct MentalRayRenderSettingsTraitsSamplingParameter
Public Structure MentalRayRenderSettingsTraitsSamplingParameter
public value class MentalRayRenderSettingsTraitsSamplingParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MentalRayRenderSettingsTraitsSamplingParameter(Filter, Double, Double) |
 | Equals(Object) | (Inherited from ValueType.)
 | Filter |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Height |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)
 | Width |


MentalRayRenderSettingsTraitsSamplingParameter Constructor (f, w, h)

MentalRayRenderSettingsTraitsSamplingParameter Constructor (f, w, h)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsSamplingParameter »MentalRayRenderSettingsTraitsSamplingParameter(Filter, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public MentalRayRenderSettingsTraitsSamplingParameter(
    Filter f,
    double w,
    double h
)
Public Sub New ( _
    f As Filter, _
    w As Double, _
    h As Double _
)
public:
MentalRayRenderSettingsTraitsSamplingParameter(
    Filter f,
    double w,
    double h
)
Parameters
f(Filter)
w(Double)
h(Double)


Filter Property

Filter Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsSamplingParameter »Filter
Declaration Syntax
C# Visual Basic Visual C++
public Filter Filter { get; }
Public ReadOnly Property Filter As Filter
    Get
public:
property Filter Filter {
    Filter get ();
}


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsSamplingParameter »Height
Declaration Syntax
C# Visual Basic Visual C++
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}


Width Property

Width Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsSamplingParameter »Width
Declaration Syntax
C# Visual Basic Visual C++
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}


MentalRayRenderSettingsTraitsTraceParameter Structure

MentalRayRenderSettingsTraitsTraceParameter Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsTraceParameter
Declaration Syntax
C# Visual Basic Visual C++
public struct MentalRayRenderSettingsTraitsTraceParameter
Public Structure MentalRayRenderSettingsTraitsTraceParameter
public value class MentalRayRenderSettingsTraitsTraceParameter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MentalRayRenderSettingsTraitsTraceParameter(Int32, Int32, Int32) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Reflection |
 | Refraction |
 | Sum |
 | ToString()()()() | (Inherited from ValueType.)


MentalRayRenderSettingsTraitsTraceParameter Constructor (reflect, refract, s)

MentalRayRenderSettingsTraitsTraceParameter Constructor (reflect, refract, s)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsTraceParameter »MentalRayRenderSettingsTraitsTraceParameter(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MentalRayRenderSettingsTraitsTraceParameter(
    int reflect,
    int refract,
    int s
)
Public Sub New ( _
    reflect As Integer, _
    refract As Integer, _
    s As Integer _
)
public:
MentalRayRenderSettingsTraitsTraceParameter(
    int reflect,
    int refract,
    int s
)
Parameters
reflect(Int32)
refract(Int32)
s(Int32)


Reflection Property

Reflection Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsTraceParameter »Reflection
Declaration Syntax
C# Visual Basic Visual C++
public int Reflection { get; }
Public ReadOnly Property Reflection As Integer
    Get
public:
property int Reflection {
    int get ();
}


Refraction Property

Refraction Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsTraceParameter »Refraction
Declaration Syntax
C# Visual Basic Visual C++
public int Refraction { get; }
Public ReadOnly Property Refraction As Integer
    Get
public:
property int Refraction {
    int get ();
}


Sum Property

Sum Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraitsTraceParameter »Sum
Declaration Syntax
C# Visual Basic Visual C++
public int Sum { get; }
Public ReadOnly Property Sum As Integer
    Get
public:
property int Sum {
    int get ();
}


Mode Enumeration

Mode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mode
Declaration Syntax
C# Visual Basic Visual C++
public enum Mode
Public Enumeration Mode
public enum class Mode
Members
Member | Description
Advanced |
Realistic |


NonEntityTraits Class

NonEntityTraits Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcGiNonEntityTraits")]
public class NonEntityTraits : SubEntityTraits
<WrapperAttribute("AcGiNonEntityTraits")> _
Public Class NonEntityTraits _
    Inherits SubEntityTraits
[WrapperAttribute(L"AcGiNonEntityTraits")]
public ref class NonEntityTraits : public SubEntityTraits
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NonEntityTraits(IntPtr, Boolean) |
 | AddLight(ObjectId) | (Overrides DrawableTraits.AddLight(ObjectId).)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | Color | (Overrides SubEntityTraits.Color.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DrawFlags | (Overrides SubEntityTraits.DrawFlags.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | FillType | (Overrides SubEntityTraits.FillType.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Layer | (Overrides SubEntityTraits.Layer.)
 | LineType | (Overrides SubEntityTraits.LineType.)
 | LineTypeScale | (Overrides SubEntityTraits.LineTypeScale.)
 | LineWeight | (Overrides SubEntityTraits.LineWeight.)
 | Mapper | (Overrides SubEntityTraits.Mapper.)
 | Material | (Overrides SubEntityTraits.Material.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotStyleDescriptor | (Overrides SubEntityTraits.PlotStyleDescriptor.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Sectionable | (Overrides SubEntityTraits.Sectionable.)
 | SelectionOnlyGeometry | (Overrides SubEntityTraits.SelectionOnlyGeometry.)
 | SetLayerFlags(DrawableTraits..::..LayerFlags) | (Overrides DrawableTraits.SetLayerFlags(DrawableTraits..::..LayerFlags).)
 | SetSelectionMarker(IntPtr) | (Overrides SubEntityTraits.SetSelectionMarker(IntPtr).)
 | SetupForEntity(Entity) | (Overrides DrawableTraits.SetupForEntity(Entity).)
 | ShadowFlags | (Overrides SubEntityTraits.ShadowFlags.)
 | Thickness | (Overrides SubEntityTraits.Thickness.)
 | ToString()()()() | (Inherited from Object.)
 | Transparency | (Overrides SubEntityTraits.Transparency.)
 | TrueColor | (Overrides SubEntityTraits.TrueColor.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | VisualStyle | (Overrides SubEntityTraits.VisualStyle.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DrawableTraits
 |  |  |  |  | SubEntityTraits
 |  |  |  |  |  | NonEntityTraits
 |  |  |  |  |  |  | LightTraits
 |  |  |  |  |  |  | RenderSettingsTraits


NonEntityTraits Constructor (unmanagedPointer, autoDelete)

NonEntityTraits Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »NonEntityTraits(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal NonEntityTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
NonEntityTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AddLight Method (lightId)

AddLight Method (lightId)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »AddLight(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed void AddLight(
    ObjectId lightId
)
Public Overrides NotOverridable Sub AddLight ( _
    lightId As ObjectId _
)
public:
virtual void AddLight(
    ObjectId lightId
) override sealed
Parameters
lightId(ObjectId)


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »Color
Declaration Syntax
C# Visual Basic Visual C++
public override sealed short Color { get; set; }
Public Overrides NotOverridable Property Color As Short
    Get
    Set
public:
virtual property short Color {
    short get () override sealed;
    void set (short value) override sealed;
}


DrawFlags Property

DrawFlags Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »DrawFlags
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int DrawFlags { get; set; }
Public Overrides NotOverridable Property DrawFlags As Integer
    Get
    Set
public:
virtual property int DrawFlags {
    int get () override sealed;
    void set (int value) override sealed;
}


FillType Property

FillType Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »FillType
Declaration Syntax
C# Visual Basic Visual C++
public override sealed FillType FillType { get; set; }
Public Overrides NotOverridable Property FillType As FillType
    Get
    Set
public:
virtual property FillType FillType {
    FillType get () override sealed;
    void set (FillType value) override sealed;
}


Layer Property

Layer Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »Layer
Declaration Syntax
C# Visual Basic Visual C++
public override sealed ObjectId Layer { get; set; }
Public Overrides NotOverridable Property Layer As ObjectId
    Get
    Set
public:
virtual property ObjectId Layer {
    ObjectId get () override sealed;
    void set (ObjectId value) override sealed;
}


LineType Property

LineType Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »LineType
Declaration Syntax
C# Visual Basic Visual C++
public override sealed ObjectId LineType { get; set; }
Public Overrides NotOverridable Property LineType As ObjectId
    Get
    Set
public:
virtual property ObjectId LineType {
    ObjectId get () override sealed;
    void set (ObjectId value) override sealed;
}


LineTypeScale Property

LineTypeScale Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »LineTypeScale
Declaration Syntax
C# Visual Basic Visual C++
public override sealed double LineTypeScale { get; set; }
Public Overrides NotOverridable Property LineTypeScale As Double
    Get
    Set
public:
virtual property double LineTypeScale {
    double get () override sealed;
    void set (double value) override sealed;
}


LineWeight Property

LineWeight Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »LineWeight
Declaration Syntax
C# Visual Basic Visual C++
public override sealed LineWeight LineWeight { get; set; }
Public Overrides NotOverridable Property LineWeight As LineWeight
    Get
    Set
public:
virtual property LineWeight LineWeight {
    LineWeight get () override sealed;
    void set (LineWeight value) override sealed;
}


Mapper Property

Mapper Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »Mapper
Declaration Syntax
C# Visual Basic Visual C++
public override sealed Mapper Mapper { get; set; }
Public Overrides NotOverridable Property Mapper As Mapper
    Get
    Set
public:
virtual property Mapper^ Mapper {
    Mapper^ get () override sealed;
    void set (Mapper^ value) override sealed;
}


Material Property

Material Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »Material
Declaration Syntax
C# Visual Basic Visual C++
public override sealed ObjectId Material { get; set; }
Public Overrides NotOverridable Property Material As ObjectId
    Get
    Set
public:
virtual property ObjectId Material {
    ObjectId get () override sealed;
    void set (ObjectId value) override sealed;
}


PlotStyleDescriptor Property

PlotStyleDescriptor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »PlotStyleDescriptor
Declaration Syntax
C# Visual Basic Visual C++
public override sealed PlotStyleDescriptor PlotStyleDescriptor { get; set; }
Public Overrides NotOverridable Property PlotStyleDescriptor As PlotStyleDescriptor
    Get
    Set
public:
virtual property PlotStyleDescriptor PlotStyleDescriptor {
    PlotStyleDescriptor get () override sealed;
    void set (PlotStyleDescriptor value) override sealed;
}


Sectionable Property

Sectionable Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »Sectionable
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Sectionable { get; set; }
Public Overrides NotOverridable Property Sectionable As Boolean
    Get
    Set
public:
virtual property bool Sectionable {
    bool get () override sealed;
    void set (bool value) override sealed;
}


SelectionOnlyGeometry Property

SelectionOnlyGeometry Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »SelectionOnlyGeometry
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool SelectionOnlyGeometry { get; set; }
Public Overrides NotOverridable Property SelectionOnlyGeometry As Boolean
    Get
    Set
public:
virtual property bool SelectionOnlyGeometry {
    bool get () override sealed;
    void set (bool value) override sealed;
}


SetLayerFlags Method (flags)

SetLayerFlags Method (flags)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »SetLayerFlags(DrawableTraits..::..LayerFlags)
Declaration Syntax
C# Visual Basic Visual C++
protected override sealed void SetLayerFlags(
    DrawableTraits..::..LayerFlags flags
)
Protected Overrides NotOverridable Sub SetLayerFlags ( _
    flags As DrawableTraits..::..LayerFlags _
)
protected:
virtual void SetLayerFlags(
    DrawableTraits..::..LayerFlags flags
) override sealed
Parameters
flags(DrawableTraits..::..LayerFlags)


SetSelectionMarker Method (markerId)

SetSelectionMarker Method (markerId)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »SetSelectionMarker(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed void SetSelectionMarker(
    IntPtr markerId
)
Public Overrides NotOverridable Sub SetSelectionMarker ( _
    markerId As IntPtr _
)
public:
virtual void SetSelectionMarker(
    IntPtr markerId
) override sealed
Parameters
markerId(IntPtr)


SetupForEntity Method (entity)

SetupForEntity Method (entity)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »SetupForEntity(Entity)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed void SetupForEntity(
    Entity entity
)
Public Overrides NotOverridable Sub SetupForEntity ( _
    entity As Entity _
)
public:
virtual void SetupForEntity(
    Entity^ entity
) override sealed
Parameters
entity(Entity)


ShadowFlags Property

ShadowFlags Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »ShadowFlags
Declaration Syntax
C# Visual Basic Visual C++
public override sealed ShadowFlags ShadowFlags { get; set; }
Public Overrides NotOverridable Property ShadowFlags As ShadowFlags
    Get
    Set
public:
virtual property ShadowFlags ShadowFlags {
    ShadowFlags get () override sealed;
    void set (ShadowFlags value) override sealed;
}


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public override sealed double Thickness { get; set; }
Public Overrides NotOverridable Property Thickness As Double
    Get
    Set
public:
virtual property double Thickness {
    double get () override sealed;
    void set (double value) override sealed;
}


Transparency Property

Transparency Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »Transparency
Declaration Syntax
C# Visual Basic Visual C++
public override sealed Transparency Transparency { get; set; }
Public Overrides NotOverridable Property Transparency As Transparency
    Get
    Set
public:
virtual property Transparency Transparency {
    Transparency get () override sealed;
    void set (Transparency value) override sealed;
}


TrueColor Property

TrueColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »TrueColor
Declaration Syntax
C# Visual Basic Visual C++
public override sealed EntityColor TrueColor { get; set; }
Public Overrides NotOverridable Property TrueColor As EntityColor
    Get
    Set
public:
virtual property EntityColor TrueColor {
    EntityColor get () override sealed;
    void set (EntityColor value) override sealed;
}


VisualStyle Property

VisualStyle Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »VisualStyle
Declaration Syntax
C# Visual Basic Visual C++
public override sealed ObjectId VisualStyle { get; set; }
Public Overrides NotOverridable Property VisualStyle As ObjectId
    Get
    Set
public:
virtual property ObjectId VisualStyle {
    ObjectId get () override sealed;
    void set (ObjectId value) override sealed;
}


NormalMapMethod Enumeration

NormalMapMethod Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NormalMapMethod
Declaration Syntax
C# Visual Basic Visual C++
public enum NormalMapMethod
Public Enumeration NormalMapMethod
public enum class NormalMapMethod
Members
Member | Description
TangentSpaceNormalMap |


OrientationBehavior Enumeration

OrientationBehavior Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »OrientationBehavior
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OrientationTransformBehavior")]
public enum OrientationBehavior
<WrapperAttribute("OrientationTransformBehavior")> _
Public Enumeration OrientationBehavior
[WrapperAttribute(L"OrientationTransformBehavior")]
public enum class OrientationBehavior
Members
Member | Description
ZAxis |
World |
Screen |


OrientationType Enumeration

OrientationType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »OrientationType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiOrientationType")]
public enum OrientationType
<WrapperAttribute("ZcGiOrientationType")> _
Public Enumeration OrientationType
[WrapperAttribute(L"ZcGiOrientationType")]
public enum class OrientationType
Members
Member | Description
NoOrientation |
CounterClockwise |
Clockwise |


PixelBGRA32 Structure

PixelBGRA32 Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelBGRA32
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiPixelBGRA32")]
public struct PixelBGRA32
<WrapperAttribute("ZcGiPixelBGRA32")> _
Public Structure PixelBGRA32
[WrapperAttribute(L"ZcGiPixelBGRA32")]
public value class PixelBGRA32
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PixelBGRA32(Byte, Byte, Byte, Byte) |
 | PixelBGRA32(UInt32) |
 | PixelBGRA32(IntPtr) |
 | Alpha |
 | Blue |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Green |
 | init()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Red |
 | ToString()()()() | (Inherited from ValueType.)


PixelBGRA32 Constructor

PixelBGRA32 Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelBGRA32 »PixelBGRA32()()()()
Members
Icon | Member | Description
 | PixelBGRA32(Byte, Byte, Byte, Byte) |
 | PixelBGRA32(UInt32) |
 | PixelBGRA32(IntPtr) |


PixelBGRA32 Constructor (blue, green, red, alpha)

PixelBGRA32 Constructor (blue, green, red, alpha)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelBGRA32 »PixelBGRA32(Byte, Byte, Byte, Byte)
Declaration Syntax
C# Visual Basic Visual C++
public PixelBGRA32(
    byte blue,
    byte green,
    byte red,
    byte alpha
)
Public Sub New ( _
    blue As Byte, _
    green As Byte, _
    red As Byte, _
    alpha As Byte _
)
public:
PixelBGRA32(
    unsigned char blue,
    unsigned char green,
    unsigned char red,
    unsigned char alpha
)
Parameters
blue(Byte)
green(Byte)
red(Byte)
alpha(Byte)


PixelBGRA32 Constructor (unmanagedObjPtr)

PixelBGRA32 Constructor (unmanagedObjPtr)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelBGRA32 »PixelBGRA32(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public PixelBGRA32(
    IntPtr unmanagedObjPtr
)
Public Sub New ( _
    unmanagedObjPtr As IntPtr _
)
public:
PixelBGRA32(
    IntPtr unmanagedObjPtr
)
Parameters
unmanagedObjPtr(IntPtr)


PixelBGRA32 Constructor (bgra)

PixelBGRA32 Constructor (bgra)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelBGRA32 »PixelBGRA32(UInt32)
Declaration Syntax
C# Visual Basic Visual C++
public PixelBGRA32(
    uint bgra
)
Public Sub New ( _
    bgra As UInteger _
)
public:
PixelBGRA32(
    unsigned int bgra
)
Parameters
bgra(UInt32)


Alpha Property

Alpha Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelBGRA32 »Alpha
Declaration Syntax
C# Visual Basic Visual C++
public byte Alpha { get; set; }
Public Property Alpha As Byte
    Get
    Set
public:
property unsigned char Alpha {
    unsigned char get ();
    void set (unsigned char value);
}


Blue Property

Blue Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelBGRA32 »Blue
Declaration Syntax
C# Visual Basic Visual C++
public byte Blue { get; set; }
Public Property Blue As Byte
    Get
    Set
public:
property unsigned char Blue {
    unsigned char get ();
    void set (unsigned char value);
}


Green Property

Green Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelBGRA32 »Green
Declaration Syntax
C# Visual Basic Visual C++
public byte Green { get; set; }
Public Property Green As Byte
    Get
    Set
public:
property unsigned char Green {
    unsigned char get ();
    void set (unsigned char value);
}


init Method

init Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelBGRA32 »init()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void init()
Public Sub init
public:
void init()


Red Property

Red Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelBGRA32 »Red
Declaration Syntax
C# Visual Basic Visual C++
public byte Red { get; set; }
Public Property Red As Byte
    Get
    Set
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}


PixelFormatInfo Structure

PixelFormatInfo Structure
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("tagPixelFormatInfo")]
public struct PixelFormatInfo
<WrapperAttribute("tagPixelFormatInfo")> _
Public Structure PixelFormatInfo
[WrapperAttribute(L"tagPixelFormatInfo")]
public value class PixelFormatInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AlphaOffset |
 | BitsPerPixel |
 | BlueOffset |
 | Equality(PixelFormatInfo, PixelFormatInfo) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | GreenOffset |
 | is16bitBGR()()()() |
 | isBGR()()()() |
 | isBGRA()()()() |
 | isRGB()()()() |
 | isRGBA()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumAlphaBits |
 | NumBlueBits |
 | NumGreenBits |
 | NumRedBits |
 | RedOffset |
 | set16bitBGR()()()() |
 | setBGR()()()() |
 | setBGRA()()()() |
 | setRGB()()()() |
 | setRGBA()()()() |
 | ToString()()()() | (Inherited from ValueType.)


AlphaOffset Property

AlphaOffset Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »AlphaOffset
Declaration Syntax
C# Visual Basic Visual C++
public short AlphaOffset { get; set; }
Public Property AlphaOffset As Short
    Get
    Set
public:
property short AlphaOffset {
    short get ();
    void set (short value);
}


BitsPerPixel Property

BitsPerPixel Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »BitsPerPixel
Declaration Syntax
C# Visual Basic Visual C++
public short BitsPerPixel { get; set; }
Public Property BitsPerPixel As Short
    Get
    Set
public:
property short BitsPerPixel {
    short get ();
    void set (short value);
}


BlueOffset Property

BlueOffset Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »BlueOffset
Declaration Syntax
C# Visual Basic Visual C++
public short BlueOffset { get; set; }
Public Property BlueOffset As Short
    Get
    Set
public:
property short BlueOffset {
    short get ();
    void set (short value);
}


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »Equality(PixelFormatInfo, PixelFormatInfo)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    PixelFormatInfo inf,
    PixelFormatInfo inf2
)
Public Shared Operator = ( _
    inf As PixelFormatInfo, _
    inf2 As PixelFormatInfo _
) As Boolean
public:
static bool operator ==(
    PixelFormatInfo inf,
    PixelFormatInfo inf2
)
Parameters
inf(PixelFormatInfo)
inf2(PixelFormatInfo)


GreenOffset Property

GreenOffset Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »GreenOffset
Declaration Syntax
C# Visual Basic Visual C++
public short GreenOffset { get; set; }
Public Property GreenOffset As Short
    Get
    Set
public:
property short GreenOffset {
    short get ();
    void set (short value);
}


is16bitBGR Method

is16bitBGR Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »is16bitBGR()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool is16bitBGR()
Public Function is16bitBGR As Boolean
public:
bool is16bitBGR()


isBGR Method

isBGR Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »isBGR()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool isBGR()
Public Function isBGR As Boolean
public:
bool isBGR()


isBGRA Method

isBGRA Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »isBGRA()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool isBGRA()
Public Function isBGRA As Boolean
public:
bool isBGRA()


isRGB Method

isRGB Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »isRGB()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool isRGB()
Public Function isRGB As Boolean
public:
bool isRGB()


isRGBA Method

isRGBA Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »isRGBA()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool isRGBA()
Public Function isRGBA As Boolean
public:
bool isRGBA()


NumAlphaBits Property

NumAlphaBits Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »NumAlphaBits
Declaration Syntax
C# Visual Basic Visual C++
public short NumAlphaBits { get; set; }
Public Property NumAlphaBits As Short
    Get
    Set
public:
property short NumAlphaBits {
    short get ();
    void set (short value);
}


NumBlueBits Property

NumBlueBits Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »NumBlueBits
Declaration Syntax
C# Visual Basic Visual C++
public short NumBlueBits { get; set; }
Public Property NumBlueBits As Short
    Get
    Set
public:
property short NumBlueBits {
    short get ();
    void set (short value);
}


NumGreenBits Property

NumGreenBits Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »NumGreenBits
Declaration Syntax
C# Visual Basic Visual C++
public short NumGreenBits { get; set; }
Public Property NumGreenBits As Short
    Get
    Set
public:
property short NumGreenBits {
    short get ();
    void set (short value);
}


NumRedBits Property

NumRedBits Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »NumRedBits
Declaration Syntax
C# Visual Basic Visual C++
public short NumRedBits { get; set; }
Public Property NumRedBits As Short
    Get
    Set
public:
property short NumRedBits {
    short get ();
    void set (short value);
}


RedOffset Property

RedOffset Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »RedOffset
Declaration Syntax
C# Visual Basic Visual C++
public short RedOffset { get; set; }
Public Property RedOffset As Short
    Get
    Set
public:
property short RedOffset {
    short get ();
    void set (short value);
}


set16bitBGR Method

set16bitBGR Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »set16bitBGR()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void set16bitBGR()
Public Sub set16bitBGR
public:
void set16bitBGR()


setBGR Method

setBGR Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »setBGR()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void setBGR()
Public Sub setBGR
public:
void setBGR()


setBGRA Method

setBGRA Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »setBGRA()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void setBGRA()
Public Sub setBGRA
public:
void setBGRA()


setRGB Method

setRGB Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »setRGB()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void setRGB()
Public Sub setRGB
public:
void setRGB()


setRGBA Method

setRGBA Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PixelFormatInfo »setRGBA()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void setRGBA()
Public Sub setRGBA
public:
void setRGBA()


Polyline Class

Polyline Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Polyline
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiPolyline")]
public class Polyline
<WrapperAttribute("ZcGiPolyline")> _
Public Class Polyline
[WrapperAttribute(L"ZcGiPolyline")]
public ref class Polyline
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Polyline(Point3dCollection, Vector3d, IntPtr) |
 | Polyline()()()() |
 | BaseSubEntMarker |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Normal |
 | Points |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Polyline


Polyline Constructor

Polyline Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Polyline »Polyline()()()()
Members
Icon | Member | Description
 | Polyline(Point3dCollection, Vector3d, IntPtr) |
 | Polyline()()()() |


Polyline Constructor

Polyline Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Polyline »Polyline()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Polyline()
Public Sub New
public:
Polyline()


Polyline Constructor (pPoints, normal, pBaseSubEntMarker)

Polyline Constructor (pPoints, normal, pBaseSubEntMarker)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Polyline »Polyline(Point3dCollection, Vector3d, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public Polyline(
    Point3dCollection pPoints,
    Vector3d normal,
    IntPtr pBaseSubEntMarker
)
Public Sub New ( _
    pPoints As Point3dCollection, _
    normal As Vector3d, _
    pBaseSubEntMarker As IntPtr _
)
public:
Polyline(
    Point3dCollection^ pPoints,
    Vector3d normal,
    IntPtr pBaseSubEntMarker
)
Parameters
pPoints(Point3dCollection)
normal(Vector3d)
pBaseSubEntMarker(IntPtr)


BaseSubEntMarker Property

BaseSubEntMarker Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Polyline »BaseSubEntMarker
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr BaseSubEntMarker { get; set; }
Public Property BaseSubEntMarker As IntPtr
    Get
    Set
public:
property IntPtr BaseSubEntMarker {
    IntPtr get ();
    void set (IntPtr value);
}


Normal Property

Normal Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Polyline »Normal
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d Normal { get; set; }
Public Property Normal As Vector3d
    Get
    Set
public:
property Vector3d Normal {
    Vector3d get ();
    void set (Vector3d value);
}


Points Property

Points Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Polyline »Points
Declaration Syntax
C# Visual Basic Visual C++
public Point3dCollection Points { get; set; }
Public Property Points As Point3dCollection
    Get
    Set
public:
property Point3dCollection^ Points {
    Point3dCollection^ get ();
    void set (Point3dCollection^ value);
}


PolylineCollection Class

PolylineCollection Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PolylineCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiPolylineArray")]
public class PolylineCollection
<WrapperAttribute("ZcGiPolylineArray")> _
Public Class PolylineCollection
[WrapperAttribute(L"ZcGiPolylineArray")]
public ref class PolylineCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolylineCollection(Int32) |
 | PolylineCollection()()()() |
 | Add(Polyline) |
 | Clear()()()() |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RemoveAt(Int32) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PolylineCollection


PolylineCollection Constructor

PolylineCollection Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PolylineCollection »PolylineCollection()()()()
Members
Icon | Member | Description
 | PolylineCollection(Int32) |
 | PolylineCollection()()()() |


PolylineCollection Constructor

PolylineCollection Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PolylineCollection »PolylineCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolylineCollection()
Public Sub New
public:
PolylineCollection()


PolylineCollection Constructor (size)

PolylineCollection Constructor (size)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PolylineCollection »PolylineCollection(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PolylineCollection(
    int size
)
Public Sub New ( _
    size As Integer _
)
public:
PolylineCollection(
    int size
)
Parameters
size(Int32)


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PolylineCollection »Add(Polyline)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Add(
    Polyline value
)
Public Overridable Function Add ( _
    value As Polyline _
) As Integer
public:
virtual int Add(
    Polyline^ value
)
Parameters
value(Polyline)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PolylineCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PolylineCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PolylineCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Polyline this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Polyline
    Get
    Set
public:
property Polyline^ default[int index] {
    Polyline^ get (int index);
    void set (int index, Polyline^ value);
}
Parameters
index(Int32)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PolylineCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index(Int32)


PositionBehavior Enumeration

PositionBehavior Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »PositionBehavior
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("PositionTransformBehavior")]
public enum PositionBehavior
<WrapperAttribute("PositionTransformBehavior")> _
Public Enumeration PositionBehavior
[WrapperAttribute(L"PositionTransformBehavior")]
public enum class PositionBehavior
Members
Member | Description
Viewport |
WorldWithScreenOffset |
World |
ScreenLocalOrigin |
Screen |


Projection Enumeration

Projection Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Projection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiMapper::Projection")]
public enum Projection
<WrapperAttribute("ZcGiMapper::Projection")> _
Public Enumeration Projection
[WrapperAttribute(L"ZcGiMapper::Projection")]
public enum class Projection
Members
Member | Description
Sphere |
Planar |
InheritProjection |
Cylinder |
Box |


RasterImageSource Enumeration

RasterImageSource Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RasterImageSource
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiRasterImage::ImageSource")]
public enum RasterImageSource
<WrapperAttribute("ZcGiRasterImage::ImageSource")> _
Public Enumeration RasterImageSource
[WrapperAttribute(L"ZcGiRasterImage::ImageSource")]
public enum class RasterImageSource
Members
Member | Description
FromFile |
FromPdfUnderlay |
FromImageBGRA32 |
FromUnderlay |
FromRender |
FromOleObject |
FromDwg |
UndefinedSource |


RegenType Enumeration

RegenType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RegenType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiRegenType")]
public enum RegenType
<WrapperAttribute("ZcGiRegenType")> _
Public Enumeration RegenType
[WrapperAttribute(L"ZcGiRegenType")]
public enum class RegenType
Members
Member | Description
StandardDisplay |
SaveWorldDrawForProxy |
RenderCommand |
HideOrShadeCommand |
ForExplode |
Invalid |


RenderSettingsTraits Class

RenderSettingsTraits Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RenderSettingsTraits
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiRenderSettingsTraits")]
public abstract class RenderSettingsTraits : NonEntityTraits
<WrapperAttribute("ZcGiRenderSettingsTraits")> _
Public MustInherit Class RenderSettingsTraits _
    Inherits NonEntityTraits
[WrapperAttribute(L"ZcGiRenderSettingsTraits")]
public ref class RenderSettingsTraits abstract : public NonEntityTraits
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RenderSettingsTraits(IntPtr, Boolean) |
 | AddLight(ObjectId) | (Inherited from NonEntityTraits.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackFacesEnabled |
 | Clone()()()() | (Inherited from RXObject.)
 | Color | (Inherited from NonEntityTraits.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DiagnosticBackgroundEnabled |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DrawFlags | (Inherited from NonEntityTraits.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | FillType | (Inherited from NonEntityTraits.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Layer | (Inherited from NonEntityTraits.)
 | LineType | (Inherited from NonEntityTraits.)
 | LineTypeScale | (Inherited from NonEntityTraits.)
 | LineWeight | (Inherited from NonEntityTraits.)
 | Mapper | (Inherited from NonEntityTraits.)
 | Material | (Inherited from NonEntityTraits.)
 | MaterialEnabled |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModelScaleFactor |
 | PlotStyleDescriptor | (Inherited from NonEntityTraits.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Sectionable | (Inherited from NonEntityTraits.)
 | SelectionOnlyGeometry | (Inherited from NonEntityTraits.)
 | SetLayerFlags(DrawableTraits..::..LayerFlags) | (Inherited from NonEntityTraits.)
 | SetSelectionMarker(IntPtr) | (Inherited from NonEntityTraits.)
 | SetupForEntity(Entity) | (Inherited from NonEntityTraits.)
 | ShadowFlags | (Inherited from NonEntityTraits.)
 | ShadowsEnabled |
 | TextureSampling |
 | Thickness | (Inherited from NonEntityTraits.)
 | ToString()()()() | (Inherited from Object.)
 | Transparency | (Inherited from NonEntityTraits.)
 | TrueColor | (Inherited from NonEntityTraits.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | VisualStyle | (Inherited from NonEntityTraits.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DrawableTraits
 |  |  |  |  | SubEntityTraits
 |  |  |  |  |  | NonEntityTraits
 |  |  |  |  |  |  | RenderSettingsTraits
 |  |  |  |  |  |  |  | MentalRayRenderSettingsTraits


RenderSettingsTraits Constructor (unmanagedPointer, autoDelete)

RenderSettingsTraits Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RenderSettingsTraits »RenderSettingsTraits(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal RenderSettingsTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
RenderSettingsTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


BackFacesEnabled Property

BackFacesEnabled Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RenderSettingsTraits »BackFacesEnabled
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool BackFacesEnabled { get; set; }
Public MustOverride Property BackFacesEnabled As Boolean
    Get
    Set
public:
virtual property bool BackFacesEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}


DiagnosticBackgroundEnabled Property

DiagnosticBackgroundEnabled Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RenderSettingsTraits »DiagnosticBackgroundEnabled
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool DiagnosticBackgroundEnabled { get; set; }
Public MustOverride Property DiagnosticBackgroundEnabled As Boolean
    Get
    Set
public:
virtual property bool DiagnosticBackgroundEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}


MaterialEnabled Property

MaterialEnabled Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RenderSettingsTraits »MaterialEnabled
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool MaterialEnabled { get; set; }
Public MustOverride Property MaterialEnabled As Boolean
    Get
    Set
public:
virtual property bool MaterialEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}


ModelScaleFactor Property

ModelScaleFactor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RenderSettingsTraits »ModelScaleFactor
Declaration Syntax
C# Visual Basic Visual C++
public abstract double ModelScaleFactor { get; set; }
Public MustOverride Property ModelScaleFactor As Double
    Get
    Set
public:
virtual property double ModelScaleFactor {
    double get () abstract;
    void set (double value) abstract;
}


ShadowsEnabled Property

ShadowsEnabled Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RenderSettingsTraits »ShadowsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool ShadowsEnabled { get; set; }
Public MustOverride Property ShadowsEnabled As Boolean
    Get
    Set
public:
virtual property bool ShadowsEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}


TextureSampling Property

TextureSampling Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RenderSettingsTraits »TextureSampling
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool TextureSampling { get; set; }
Public MustOverride Property TextureSampling As Boolean
    Get
    Set
public:
virtual property bool TextureSampling {
    bool get () abstract;
    void set (bool value) abstract;
}


ScaleBehavior Enumeration

ScaleBehavior Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ScaleBehavior
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ScaleTransformBehavior")]
public enum ScaleBehavior
<WrapperAttribute("ScaleTransformBehavior")> _
Public Enumeration ScaleBehavior
[WrapperAttribute(L"ScaleTransformBehavior")]
public enum class ScaleBehavior
Members
Member | Description
Viewport |
World |
ViewportLocalOrigin |
ScreenLocalOrigin |
Screen |


ShadowDisplayType Enumeration

ShadowDisplayType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowDisplayType
Declaration Syntax
C# Visual Basic Visual C++
public enum ShadowDisplayType
Public Enumeration ShadowDisplayType
public enum class ShadowDisplayType
Members
Member | Description
FullAndGround |
Full |
GroundPlane |
None |


ShadowFlags Enumeration

ShadowFlags Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowFlags
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiSubEntityTraits::ShadowFlags")]
[FlagsAttribute]
public enum ShadowFlags
<WrapperAttribute("ZcGiSubEntityTraits::ShadowFlags")> _
<FlagsAttribute> _
Public Enumeration ShadowFlags
[WrapperAttribute(L"ZcGiSubEntityTraits::ShadowFlags")]
[FlagsAttribute]
public enum class ShadowFlags
Members
Member | Description
ShadowsIgnore |
ShadowsDoesNotReceive |
ShadowsDoesNotCast |
ShadowsCastAndReceive |


ShadowMode Enumeration

ShadowMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowMode
Declaration Syntax
C# Visual Basic Visual C++
public enum ShadowMode
Public Enumeration ShadowMode
public enum class ShadowMode
Members
Member | Description
Simple |
Segments |
Sorted |


ShadowParameters Class

ShadowParameters Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiShadowParameters")]
public class ShadowParameters : RXObject
<WrapperAttribute("ZcGiShadowParameters")> _
Public Class ShadowParameters _
    Inherits RXObject
[WrapperAttribute(L"ZcGiShadowParameters")]
public ref class ShadowParameters : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShadowParameters(IntPtr, Boolean) |
 | ShadowParameters()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Overrides DisposableWrapper.Equals(Object).)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Overrides DisposableWrapper.GetHashCode()()()().)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ShadowMapSize |
 | ShadowMapSoftness |
 | ShadowsOn |
 | ShadowType |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | ShadowParameters


ShadowParameters Constructor

ShadowParameters Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »ShadowParameters()()()()
Members
Icon | Member | Description
 | ShadowParameters(IntPtr, Boolean) |
 | ShadowParameters()()()() |


ShadowParameters Constructor

ShadowParameters Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »ShadowParameters()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShadowParameters()
Public Sub New
public:
ShadowParameters()


ShadowParameters Constructor (unmanagedPointer, autoDelete)

ShadowParameters Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »ShadowParameters(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal ShadowParameters(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
ShadowParameters(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj(Object)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override


ShadowMapSize Property

ShadowMapSize Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »ShadowMapSize
Declaration Syntax
C# Visual Basic Visual C++
public short ShadowMapSize { get; set; }
Public Property ShadowMapSize As Short
    Get
    Set
public:
property short ShadowMapSize {
    short get ();
    void set (short value);
}


ShadowMapSoftness Property

ShadowMapSoftness Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »ShadowMapSoftness
Declaration Syntax
C# Visual Basic Visual C++
public byte ShadowMapSoftness { get; set; }
Public Property ShadowMapSoftness As Byte
    Get
    Set
public:
property unsigned char ShadowMapSoftness {
    unsigned char get ();
    void set (unsigned char value);
}


ShadowsOn Property

ShadowsOn Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »ShadowsOn
Declaration Syntax
C# Visual Basic Visual C++
public bool ShadowsOn { get; set; }
Public Property ShadowsOn As Boolean
    Get
    Set
public:
property bool ShadowsOn {
    bool get ();
    void set (bool value);
}


ShadowType Property

ShadowType Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »ShadowType
Declaration Syntax
C# Visual Basic Visual C++
public ShadowType ShadowType { get; set; }
Public Property ShadowType As ShadowType
    Get
    Set
public:
property ShadowType ShadowType {
    ShadowType get ();
    void set (ShadowType value);
}


ShadowType Enumeration

ShadowType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowType
Declaration Syntax
C# Visual Basic Visual C++
public enum ShadowType
Public Enumeration ShadowType
public enum class ShadowType
Members
Member | Description
Sampled |
Maps |
RayTraced |


SubEntityTraits Class

SubEntityTraits Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcGiSubEntityTraits")]
public abstract class SubEntityTraits : DrawableTraits
<WrapperAttribute("AcGiSubEntityTraits")> _
Public MustInherit Class SubEntityTraits _
    Inherits DrawableTraits
[WrapperAttribute(L"AcGiSubEntityTraits")]
public ref class SubEntityTraits abstract : public DrawableTraits
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SubEntityTraits(IntPtr, Boolean) |
 | SubEntityTraits()()()() |
 | AddLight(ObjectId) | (Inherited from DrawableTraits.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | Color |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DrawFlags |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | FillType |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Layer |
 | LineType |
 | LineTypeScale |
 | LineWeight |
 | Mapper |
 | Material |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotStyleDescriptor |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Sectionable |
 | SelectionOnlyGeometry |
 | SetLayerFlags(DrawableTraits..::..LayerFlags) | (Inherited from DrawableTraits.)
 | SetSelectionMarker(IntPtr) |
 | SetupForEntity(Entity) | (Inherited from DrawableTraits.)
 | ShadowFlags |
 | Thickness |
 | ToString()()()() | (Inherited from Object.)
 | Transparency |
 | TrueColor |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | VisualStyle |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DrawableTraits
 |  |  |  |  | SubEntityTraits
 |  |  |  |  |  | NonEntityTraits


SubEntityTraits Constructor

SubEntityTraits Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »SubEntityTraits()()()()
Members
Icon | Member | Description
 | SubEntityTraits(IntPtr, Boolean) |
 | SubEntityTraits()()()() |


SubEntityTraits Constructor

SubEntityTraits Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »SubEntityTraits()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected SubEntityTraits()
Protected Sub New
protected:
SubEntityTraits()


SubEntityTraits Constructor (unmanagedPointer, autoDelete)

SubEntityTraits Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »SubEntityTraits(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected SubEntityTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
SubEntityTraits(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »Color
Declaration Syntax
C# Visual Basic Visual C++
public abstract short Color { get; set; }
Public MustOverride Property Color As Short
    Get
    Set
public:
virtual property short Color {
    short get () abstract;
    void set (short value) abstract;
}


DrawFlags Property

DrawFlags Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »DrawFlags
Declaration Syntax
C# Visual Basic Visual C++
public abstract int DrawFlags { get; set; }
Public MustOverride Property DrawFlags As Integer
    Get
    Set
public:
virtual property int DrawFlags {
    int get () abstract;
    void set (int value) abstract;
}


FillType Property

FillType Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »FillType
Declaration Syntax
C# Visual Basic Visual C++
public abstract FillType FillType { get; set; }
Public MustOverride Property FillType As FillType
    Get
    Set
public:
virtual property FillType FillType {
    FillType get () abstract;
    void set (FillType value) abstract;
}


Layer Property

Layer Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »Layer
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId Layer { get; set; }
Public MustOverride Property Layer As ObjectId
    Get
    Set
public:
virtual property ObjectId Layer {
    ObjectId get () abstract;
    void set (ObjectId value) abstract;
}


LineType Property

LineType Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »LineType
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId LineType { get; set; }
Public MustOverride Property LineType As ObjectId
    Get
    Set
public:
virtual property ObjectId LineType {
    ObjectId get () abstract;
    void set (ObjectId value) abstract;
}


LineTypeScale Property

LineTypeScale Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »LineTypeScale
Declaration Syntax
C# Visual Basic Visual C++
public abstract double LineTypeScale { get; set; }
Public MustOverride Property LineTypeScale As Double
    Get
    Set
public:
virtual property double LineTypeScale {
    double get () abstract;
    void set (double value) abstract;
}


LineWeight Property

LineWeight Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »LineWeight
Declaration Syntax
C# Visual Basic Visual C++
public abstract LineWeight LineWeight { get; set; }
Public MustOverride Property LineWeight As LineWeight
    Get
    Set
public:
virtual property LineWeight LineWeight {
    LineWeight get () abstract;
    void set (LineWeight value) abstract;
}


Mapper Property

Mapper Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »Mapper
Declaration Syntax
C# Visual Basic Visual C++
public abstract Mapper Mapper { get; set; }
Public MustOverride Property Mapper As Mapper
    Get
    Set
public:
virtual property Mapper^ Mapper {
    Mapper^ get () abstract;
    void set (Mapper^ value) abstract;
}


Material Property

Material Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »Material
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId Material { get; set; }
Public MustOverride Property Material As ObjectId
    Get
    Set
public:
virtual property ObjectId Material {
    ObjectId get () abstract;
    void set (ObjectId value) abstract;
}


PlotStyleDescriptor Property

PlotStyleDescriptor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »PlotStyleDescriptor
Declaration Syntax
C# Visual Basic Visual C++
public abstract PlotStyleDescriptor PlotStyleDescriptor { get; set; }
Public MustOverride Property PlotStyleDescriptor As PlotStyleDescriptor
    Get
    Set
public:
virtual property PlotStyleDescriptor PlotStyleDescriptor {
    PlotStyleDescriptor get () abstract;
    void set (PlotStyleDescriptor value) abstract;
}


Sectionable Property

Sectionable Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »Sectionable
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Sectionable { get; set; }
Public MustOverride Property Sectionable As Boolean
    Get
    Set
public:
virtual property bool Sectionable {
    bool get () abstract;
    void set (bool value) abstract;
}


SelectionOnlyGeometry Property

SelectionOnlyGeometry Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »SelectionOnlyGeometry
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool SelectionOnlyGeometry { get; set; }
Public MustOverride Property SelectionOnlyGeometry As Boolean
    Get
    Set
public:
virtual property bool SelectionOnlyGeometry {
    bool get () abstract;
    void set (bool value) abstract;
}


SetSelectionMarker Method (markerId)

SetSelectionMarker Method (markerId)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »SetSelectionMarker(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSelectionMarker(
    IntPtr markerId
)
Public Overridable Sub SetSelectionMarker ( _
    markerId As IntPtr _
)
public:
virtual void SetSelectionMarker(
    IntPtr markerId
)
Parameters
markerId(IntPtr)


ShadowFlags Property

ShadowFlags Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »ShadowFlags
Declaration Syntax
C# Visual Basic Visual C++
public virtual ShadowFlags ShadowFlags { get; set; }
Public Overridable Property ShadowFlags As ShadowFlags
    Get
    Set
public:
virtual property ShadowFlags ShadowFlags {
    ShadowFlags get ();
    void set (ShadowFlags value);
}


Thickness Property

Thickness Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »Thickness
Declaration Syntax
C# Visual Basic Visual C++
public abstract double Thickness { get; set; }
Public MustOverride Property Thickness As Double
    Get
    Set
public:
virtual property double Thickness {
    double get () abstract;
    void set (double value) abstract;
}


Transparency Property

Transparency Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »Transparency
Declaration Syntax
C# Visual Basic Visual C++
public abstract Transparency Transparency { get; set; }
Public MustOverride Property Transparency As Transparency
    Get
    Set
public:
virtual property Transparency Transparency {
    Transparency get () abstract;
    void set (Transparency value) abstract;
}


TrueColor Property

TrueColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »TrueColor
Declaration Syntax
C# Visual Basic Visual C++
public abstract EntityColor TrueColor { get; set; }
Public MustOverride Property TrueColor As EntityColor
    Get
    Set
public:
virtual property EntityColor TrueColor {
    EntityColor get () abstract;
    void set (EntityColor value) abstract;
}


VisualStyle Property

VisualStyle Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »VisualStyle
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId VisualStyle { get; set; }
Public MustOverride Property VisualStyle As ObjectId
    Get
    Set
public:
virtual property ObjectId VisualStyle {
    ObjectId get () abstract;
    void set (ObjectId value) abstract;
}


TextStyle Class

TextStyle Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiTextStyle")]
public sealed class TextStyle : RXObject
<WrapperAttribute("ZcGiTextStyle")> _
Public NotInheritable Class TextStyle _
    Inherits RXObject
[WrapperAttribute(L"ZcGiTextStyle")]
public ref class TextStyle sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextStyle(String, String, Double, Double, Double, Double, Boolean, Boolean, Boolean, Boolean, Boolean, String) |
 | TextStyle()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Backward |
 | BigFontFileName |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | FileName |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | Font |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | LoadStyleRec |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ObliquingAngle |
 | Overlined |
 | PreLoaded |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SetTrackKerning(Double) |
 | StyleName |
 | TextSize |
 | ToString()()()() | (Inherited from Object.)
 | TrackingPercent |
 | Underlined |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpsideDown |
 | Vertical |
 | X(RXClass) | (Inherited from RXObject.)
 | XScale |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | TextStyle


TextStyle Constructor

TextStyle Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »TextStyle()()()()
Members
Icon | Member | Description
 | TextStyle(String, String, Double, Double, Double, Double, Boolean, Boolean, Boolean, Boolean, Boolean, String) |
 | TextStyle()()()() |


TextStyle Constructor

TextStyle Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »TextStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TextStyle()
Public Sub New
public:
TextStyle()


TextStyle Constructor (fontName, bigFontName, textSize, x, obliqueAngle, trackingPercent, isBackward, isUpsideDown, isVertical, isOverLined, isUnderlined, styleName)

TextStyle Constructor (fontName, bigFontName, textSize, x, obliqueAngle, trackingPercent, isBackward, isUpsideDown, isVertical, isOverLined, isUnderlined, styleName)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »TextStyle(String, String, Double, Double, Double, Double, Boolean, Boolean, Boolean, Boolean, Boolean, String)
Declaration Syntax
C# Visual Basic Visual C++
public TextStyle(
    string fontName,
    string bigFontName,
    double textSize,
    double x,
    double obliqueAngle,
    double trackingPercent,
    bool isBackward,
    bool isUpsideDown,
    bool isVertical,
    bool isOverLined,
    bool isUnderlined,
    string styleName
)
Public Sub New ( _
    fontName As String, _
    bigFontName As String, _
    textSize As Double, _
    x As Double, _
    obliqueAngle As Double, _
    trackingPercent As Double, _
    isBackward As Boolean, _
    isUpsideDown As Boolean, _
    isVertical As Boolean, _
    isOverLined As Boolean, _
    isUnderlined As Boolean, _
    styleName As String _
)
public:
TextStyle(
    String^ fontName,
    String^ bigFontName,
    double textSize,
    double x,
    double obliqueAngle,
    double trackingPercent,
    bool isBackward,
    bool isUpsideDown,
    bool isVertical,
    bool isOverLined,
    bool isUnderlined,
    String^ styleName
)
Parameters
fontName(String)
bigFontName(String)
textSize(Double)
x(Double)
obliqueAngle(Double)
trackingPercent(Double)
isBackward(Boolean)
isUpsideDown(Boolean)
isVertical(Boolean)
isOverLined(Boolean)
isUnderlined(Boolean)
styleName(String)


Backward Property

Backward Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »Backward
Declaration Syntax
C# Visual Basic Visual C++
public bool Backward { get; set; }
Public Property Backward As Boolean
    Get
    Set
public:
property bool Backward {
    bool get ();
    void set (bool value);
}


BigFontFileName Property

BigFontFileName Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »BigFontFileName
Declaration Syntax
C# Visual Basic Visual C++
public string BigFontFileName { get; set; }
Public Property BigFontFileName As String
    Get
    Set
public:
property String^ BigFontFileName {
    String^ get ();
    void set (String^ value);
}


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static TextStyle Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As TextStyle
public:
static TextStyle^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


FileName Property

FileName Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »FileName
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}


Font Property

Font Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »Font
Declaration Syntax
C# Visual Basic Visual C++
public FontDescriptor Font { get; set; }
Public Property Font As FontDescriptor
    Get
    Set
public:
property FontDescriptor Font {
    FontDescriptor get ();
    void set (FontDescriptor value);
}


LoadStyleRec Property

LoadStyleRec Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »LoadStyleRec
Declaration Syntax
C# Visual Basic Visual C++
public byte LoadStyleRec { get; }
Public ReadOnly Property LoadStyleRec As Byte
    Get
public:
property unsigned char LoadStyleRec {
    unsigned char get ();
}


ObliquingAngle Property

ObliquingAngle Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »ObliquingAngle
Declaration Syntax
C# Visual Basic Visual C++
public double ObliquingAngle { get; set; }
Public Property ObliquingAngle As Double
    Get
    Set
public:
property double ObliquingAngle {
    double get ();
    void set (double value);
}


Overlined Property

Overlined Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »Overlined
Declaration Syntax
C# Visual Basic Visual C++
public bool Overlined { get; set; }
Public Property Overlined As Boolean
    Get
    Set
public:
property bool Overlined {
    bool get ();
    void set (bool value);
}


PreLoaded Property

PreLoaded Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »PreLoaded
Declaration Syntax
C# Visual Basic Visual C++
public bool PreLoaded { get; set; }
Public Property PreLoaded As Boolean
    Get
    Set
public:
property bool PreLoaded {
    bool get ();
    void set (bool value);
}


SetTrackKerning Method (trackPercent)

SetTrackKerning Method (trackPercent)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »SetTrackKerning(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrackKerning(
    double trackPercent
)
Public Sub SetTrackKerning ( _
    trackPercent As Double _
)
public:
void SetTrackKerning(
    double trackPercent
)
Parameters
trackPercent(Double)


StyleName Property

StyleName Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »StyleName
Declaration Syntax
C# Visual Basic Visual C++
public string StyleName { get; set; }
Public Property StyleName As String
    Get
    Set
public:
property String^ StyleName {
    String^ get ();
    void set (String^ value);
}


TextSize Property

TextSize Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »TextSize
Declaration Syntax
C# Visual Basic Visual C++
public double TextSize { get; set; }
Public Property TextSize As Double
    Get
    Set
public:
property double TextSize {
    double get ();
    void set (double value);
}


TrackingPercent Property

TrackingPercent Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »TrackingPercent
Declaration Syntax
C# Visual Basic Visual C++
public double TrackingPercent { get; set; }
Public Property TrackingPercent As Double
    Get
    Set
public:
property double TrackingPercent {
    double get ();
    void set (double value);
}


Underlined Property

Underlined Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »Underlined
Declaration Syntax
C# Visual Basic Visual C++
public bool Underlined { get; set; }
Public Property Underlined As Boolean
    Get
    Set
public:
property bool Underlined {
    bool get ();
    void set (bool value);
}


UpsideDown Property

UpsideDown Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »UpsideDown
Declaration Syntax
C# Visual Basic Visual C++
public bool UpsideDown { get; set; }
Public Property UpsideDown As Boolean
    Get
    Set
public:
property bool UpsideDown {
    bool get ();
    void set (bool value);
}


Vertical Property

Vertical Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »Vertical
Declaration Syntax
C# Visual Basic Visual C++
public bool Vertical { get; set; }
Public Property Vertical As Boolean
    Get
    Set
public:
property bool Vertical {
    bool get ();
    void set (bool value);
}


XScale Property

XScale Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »XScale
Declaration Syntax
C# Visual Basic Visual C++
public double XScale { get; set; }
Public Property XScale As Double
    Get
    Set
public:
property double XScale {
    double get ();
    void set (double value);
}


TileOrder Enumeration

TileOrder Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TileOrder
Declaration Syntax
C# Visual Basic Visual C++
public enum TileOrder
Public Enumeration TileOrder
public enum class TileOrder
Members
Member | Description
BottomToTop |
TopToBottom |
RightToLeft |
LeftToRight |
Spiral |
Hilbert |


Tiling Enumeration

Tiling Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Tiling
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiMapper::Tiling")]
public enum Tiling
<WrapperAttribute("ZcGiMapper::Tiling")> _
Public Enumeration Tiling
[WrapperAttribute(L"ZcGiMapper::Tiling")]
public enum class Tiling
Members
Member | Description
Tile |
Mirror |
InheritTiling |
Crop |
Clamp |


TransparencyMode Enumeration

TransparencyMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TransparencyMode
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiRasterImage::TransparencyMode")]
public enum TransparencyMode
<WrapperAttribute("ZcGiRasterImage::TransparencyMode")> _
Public Enumeration TransparencyMode
[WrapperAttribute(L"ZcGiRasterImage::TransparencyMode")]
public enum class TransparencyMode
Members
Member | Description
TransparencyDef |
TransparencyOff |
Transparency8Bit |
Transparency1Bit |


Units Enumeration

Units Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Units
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiRasterImage::Units")]
public enum Units
<WrapperAttribute("ZcGiRasterImage::Units")> _
Public Enumeration Units
[WrapperAttribute(L"ZcGiRasterImage::Units")]
public enum class Units
Members
Member | Description
Parsecs |
LightYears |
Astronomical |
Gigameters |
Hectometers |
Dekameters |
Decimeters |
Microns |
Nanometers |
Angstroms |
Mils |
Microinches |
Mile |
Yard |
Foot |
Inch |
Kilometer |
Meter |
Centimeter |
Millimeter |
None |


Variant Class

Variant Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiVariant")]
public sealed class Variant : RXObject
<WrapperAttribute("ZcGiVariant")> _
Public NotInheritable Class Variant _
    Inherits RXObject
[WrapperAttribute(L"ZcGiVariant")]
public ref class Variant sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Variant(String) |
 | Variant(Color) |
 | Variant(Int32) |
 | Variant(Double) |
 | Variant(Boolean) |
 | Variant()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Boolean |
 | Char |
 | Clone()()()() | (Inherited from RXObject.)
 | Color |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(Variant) |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteElem(String) |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Double |
 | ElemAt(Int32, String%, Variant) |
 | ElemCount()()()() |
 | Equals(Object) | (Overrides DisposableWrapper.Equals(Object).)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | Float |
 | get_Elem(String, Variant) |
 | get_Elem(String) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Int |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Long |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | set_Elem(String, Variant) |
 | Short |
 | String |
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | Uchar |
 | Uint |
 | Ulong |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Ushort |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Variant


Variant Constructor

Variant Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Variant()()()()
Members
Icon | Member | Description
 | Variant(String) |
 | Variant(Color) |
 | Variant(Int32) |
 | Variant(Double) |
 | Variant(Boolean) |
 | Variant()()()() |


Variant Constructor

Variant Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Variant()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Variant()
Public Sub New
public:
Variant()


Variant Constructor (val)

Variant Constructor (val)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Variant(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Variant(
    int val
)
Public Sub New ( _
    val As Integer _
)
public:
Variant(
    int val
)
Parameters
val(Int32)


Variant Constructor (val)

Variant Constructor (val)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Variant(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Variant(
    bool val
)
Public Sub New ( _
    val As Boolean _
)
public:
Variant(
    bool val
)
Parameters
val(Boolean)


Variant Constructor (val)

Variant Constructor (val)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Variant(Double)
Declaration Syntax
C# Visual Basic Visual C++
public Variant(
    double val
)
Public Sub New ( _
    val As Double _
)
public:
Variant(
    double val
)
Parameters
val(Double)


Variant Constructor (value)

Variant Constructor (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Variant(String)
Declaration Syntax
C# Visual Basic Visual C++
public Variant(
    string value
)
Public Sub New ( _
    value As String _
)
public:
Variant(
    String^ value
)
Parameters
value(String)


Variant Constructor (value)

Variant Constructor (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Variant(Color)
Declaration Syntax
C# Visual Basic Visual C++
public Variant(
    Color value
)
Public Sub New ( _
    value As Color _
)
public:
Variant(
    Color^ value
)
Parameters
value(Color)


Boolean Property

Boolean Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Boolean
Declaration Syntax
C# Visual Basic Visual C++
public bool Boolean { get; set; }
Public Property Boolean As Boolean
    Get
    Set
public:
property bool Boolean {
    bool get ();
    void set (bool value);
}


Char Property

Char Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Char
Declaration Syntax
C# Visual Basic Visual C++
public sbyte Char { get; set; }
Public Property Char As SByte
    Get
    Set
public:
property signed char Char {
    signed char get ();
    void set (signed char value);
}


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Color
Declaration Syntax
C# Visual Basic Visual C++
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}


CopyFrom Method (pSrc)

CopyFrom Method (pSrc)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »CopyFrom(Variant)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyFrom(
    Variant pSrc
)
Public Sub CopyFrom ( _
    pSrc As Variant _
)
public:
void CopyFrom(
    Variant^ pSrc
)
Parameters
pSrc(Variant)


DeleteElem Method (key)

DeleteElem Method (key)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »DeleteElem(String)
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteElem(
    string key
)
Public Sub DeleteElem ( _
    key As String _
)
public:
void DeleteElem(
    String^ key
)
Parameters
key(String)


Double Property

Double Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Double
Declaration Syntax
C# Visual Basic Visual C++
public double Double { get; set; }
Public Property Double As Double
    Get
    Set
public:
property double Double {
    double get ();
    void set (double value);
}


ElemAt Method (pos, key, value)

ElemAt Method (pos, key, value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »ElemAt(Int32, String%, Variant)
Declaration Syntax
C# Visual Basic Visual C++
public void ElemAt(
    int pos,
    ref string key,
    Variant value
)
Public Sub ElemAt ( _
    pos As Integer, _
    ByRef key As String, _
    value As Variant _
)
public:
void ElemAt(
    int pos,
    String^% key,
    Variant^ value
)
Parameters
pos(Int32)
key(String%)
value(Variant)


ElemCount Method

ElemCount Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »ElemCount()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int ElemCount()
Public Function ElemCount As Integer
public:
int ElemCount()


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)


Float Property

Float Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Float
Declaration Syntax
C# Visual Basic Visual C++
public float Float { get; set; }
Public Property Float As Single
    Get
    Set
public:
property float Float {
    float get ();
    void set (float value);
}


get_Elem Method

get_Elem Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »get_Elem()()()()
Members
Icon | Member | Description
 | get_Elem(String, Variant) |
 | get_Elem(String) |


get_Elem Method (key)

get_Elem Method (key)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »get_Elem(String)
Declaration Syntax
C# Visual Basic Visual C++
public Variant get_Elem(
    string key
)
Public Function get_Elem ( _
    key As String _
) As Variant
public:
Variant^ get_Elem(
    String^ key
)
Parameters
key(String)


get_Elem Method (key, value)

get_Elem Method (key, value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »get_Elem(String, Variant)
Declaration Syntax
C# Visual Basic Visual C++
public void get_Elem(
    string key,
    Variant value
)
Public Sub get_Elem ( _
    key As String, _
    value As Variant _
)
public:
void get_Elem(
    String^ key,
    Variant^ value
)
Parameters
key(String)
value(Variant)


Int Property

Int Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Int
Declaration Syntax
C# Visual Basic Visual C++
public int Int { get; set; }
Public Property Int As Integer
    Get
    Set
public:
property int Int {
    int get ();
    void set (int value);
}


Long Property

Long Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Long
Declaration Syntax
C# Visual Basic Visual C++
public int Long { get; set; }
Public Property Long As Integer
    Get
    Set
public:
property int Long {
    int get ();
    void set (int value);
}


set_Elem Method (key, value)

set_Elem Method (key, value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »set_Elem(String, Variant)
Declaration Syntax
C# Visual Basic Visual C++
public void set_Elem(
    string key,
    Variant value
)
Public Sub set_Elem ( _
    key As String, _
    value As Variant _
)
public:
void set_Elem(
    String^ key,
    Variant^ value
)
Parameters
key(String)
value(Variant)


Short Property

Short Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Short
Declaration Syntax
C# Visual Basic Visual C++
public short Short { get; set; }
Public Property Short As Short
    Get
    Set
public:
property short Short {
    short get ();
    void set (short value);
}


String Property

String Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »String
Declaration Syntax
C# Visual Basic Visual C++
public string String { get; set; }
Public Property String As String
    Get
    Set
public:
property String^ String {
    String^ get ();
    void set (String^ value);
}


Type Property

Type Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Type
Declaration Syntax
C# Visual Basic Visual C++
public VariantType Type { get; }
Public ReadOnly Property Type As VariantType
    Get
public:
property VariantType Type {
    VariantType get ();
}


Uchar Property

Uchar Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Uchar
Declaration Syntax
C# Visual Basic Visual C++
public byte Uchar { get; set; }
Public Property Uchar As Byte
    Get
    Set
public:
property unsigned char Uchar {
    unsigned char get ();
    void set (unsigned char value);
}


Uint Property

Uint Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Uint
Declaration Syntax
C# Visual Basic Visual C++
public uint Uint { get; set; }
Public Property Uint As UInteger
    Get
    Set
public:
property unsigned int Uint {
    unsigned int get ();
    void set (unsigned int value);
}


Ulong Property

Ulong Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Ulong
Declaration Syntax
C# Visual Basic Visual C++
public uint Ulong { get; set; }
Public Property Ulong As UInteger
    Get
    Set
public:
property unsigned int Ulong {
    unsigned int get ();
    void set (unsigned int value);
}


Ushort Property

Ushort Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Ushort
Declaration Syntax
C# Visual Basic Visual C++
public ushort Ushort { get; set; }
Public Property Ushort As UShort
    Get
    Set
public:
property unsigned short Ushort {
    unsigned short get ();
    void set (unsigned short value);
}


VariantType Enumeration

VariantType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VariantType
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiVariant::VariantType")]
public enum VariantType
<WrapperAttribute("ZcGiVariant::VariantType")> _
Public Enumeration VariantType
[WrapperAttribute(L"ZcGiVariant::VariantType")]
public enum class VariantType
Members
Member | Description
Undefined |
Table |
Int |
String |
Double |
Color |
Boolean |


VertexData Class

VertexData Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VertexData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiVertexData")]
public sealed class VertexData
<WrapperAttribute("ZcGiVertexData")> _
Public NotInheritable Class VertexData
[WrapperAttribute(L"ZcGiVertexData")]
public ref class VertexData sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VertexData()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | get_MappingCoords(MapChannel) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNormalVectors()()()() |
 | GetTrueColors()()()() |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrientationFlag |
 | set_MappingCoords(MapChannel, array<Point3d>[]()[][]) |
 | SetNormalVectors(array<Vector3d>[]()[][]) |
 | SetTrueColors(array<EntityColor>[]()[][]) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
VertexData


VertexData Constructor

VertexData Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VertexData »VertexData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VertexData()
Public Sub New
public:
VertexData()


get_MappingCoords Method (mapChannel)

get_MappingCoords Method (mapChannel)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VertexData »get_MappingCoords(MapChannel)
Declaration Syntax
C# Visual Basic Visual C++
public Point3d[] get_MappingCoords(
    MapChannel mapChannel
)
Public Function get_MappingCoords ( _
    mapChannel As MapChannel _
) As Point3d()
public:
array<Point3d>^ get_MappingCoords(
    MapChannel mapChannel
)
Parameters
mapChannel(MapChannel)


GetNormalVectors Method

GetNormalVectors Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VertexData »GetNormalVectors()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d[] GetNormalVectors()
Public Function GetNormalVectors As Vector3d()
public:
array<Vector3d>^ GetNormalVectors()


GetTrueColors Method

GetTrueColors Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VertexData »GetTrueColors()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EntityColor[] GetTrueColors()
Public Function GetTrueColors As EntityColor()
public:
array<EntityColor>^ GetTrueColors()


OrientationFlag Property

OrientationFlag Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VertexData »OrientationFlag
Declaration Syntax
C# Visual Basic Visual C++
public OrientationType OrientationFlag { get; set; }
Public Property OrientationFlag As OrientationType
    Get
    Set
public:
property OrientationType OrientationFlag {
    OrientationType get ();
    void set (OrientationType value);
}


set_MappingCoords Method (mapChannel, coords)

set_MappingCoords Method (mapChannel, coords)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VertexData »set_MappingCoords(MapChannel, array<Point3d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void set_MappingCoords(
    MapChannel mapChannel,
    Point3d[] coords
)
Public Sub set_MappingCoords ( _
    mapChannel As MapChannel, _
    coords As Point3d() _
)
public:
void set_MappingCoords(
    MapChannel mapChannel,
    array<Point3d>^ coords
)
Parameters
mapChannel(MapChannel)
coords(array< Point3d >[]()[][])


SetNormalVectors Method (normal)

SetNormalVectors Method (normal)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VertexData »SetNormalVectors(array<Vector3d>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetNormalVectors(
    Vector3d[] normal
)
Public Sub SetNormalVectors ( _
    normal As Vector3d() _
)
public:
void SetNormalVectors(
    array<Vector3d>^ normal
)
Parameters
normal(array< Vector3d >[]()[][])


SetTrueColors Method (colors)

SetTrueColors Method (colors)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VertexData »SetTrueColors(array<EntityColor>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetTrueColors(
    EntityColor[] colors
)
Public Sub SetTrueColors ( _
    colors As EntityColor() _
)
public:
void SetTrueColors(
    array<EntityColor>^ colors
)
Parameters
colors(array< EntityColor >[]()[][])


Viewport Class

Viewport Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiViewport")]
public abstract class Viewport : RXObject
<WrapperAttribute("ZcGiViewport")> _
Public MustInherit Class Viewport _
    Inherits RXObject
[WrapperAttribute(L"ZcGiViewport")]
public ref class Viewport abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Viewport()()()() |
 | AcadWindowId |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CameraLocation |
 | CameraTarget |
 | CameraUpVector |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DeviceContextViewportCorners |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DoInversePerspective(Point3d) |
 | DoPerspective(Point3d) |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | EyeToModelTransform |
 | EyeToWorldTransform |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FrontAndBackClipping |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNumPixelsInUnitSquare(Point3d) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsPerspective |
 | LayerVisible(ObjectId) |
 | LinetypeGenerationCriteria |
 | LinetypeScaleMultiplier |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModelToEyeTransform |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | ViewDirection |
 | ViewportId |
 | WorldToEyeTransform |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Viewport


Viewport Constructor

Viewport Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »Viewport()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected Viewport()
Protected Sub New
protected:
Viewport()


AcadWindowId Property

AcadWindowId Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »AcadWindowId
Declaration Syntax
C# Visual Basic Visual C++
public abstract int AcadWindowId { get; }
Public MustOverride ReadOnly Property AcadWindowId As Integer
    Get
public:
virtual property int AcadWindowId {
    int get () abstract;
}


CameraLocation Property

CameraLocation Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »CameraLocation
Declaration Syntax
C# Visual Basic Visual C++
public abstract Point3d CameraLocation { get; }
Public MustOverride ReadOnly Property CameraLocation As Point3d
    Get
public:
virtual property Point3d CameraLocation {
    Point3d get () abstract;
}


CameraTarget Property

CameraTarget Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »CameraTarget
Declaration Syntax
C# Visual Basic Visual C++
public abstract Point3d CameraTarget { get; }
Public MustOverride ReadOnly Property CameraTarget As Point3d
    Get
public:
virtual property Point3d CameraTarget {
    Point3d get () abstract;
}


CameraUpVector Property

CameraUpVector Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »CameraUpVector
Declaration Syntax
C# Visual Basic Visual C++
public abstract Vector3d CameraUpVector { get; }
Public MustOverride ReadOnly Property CameraUpVector As Vector3d
    Get
public:
virtual property Vector3d CameraUpVector {
    Vector3d get () abstract;
}


DeviceContextViewportCorners Property

DeviceContextViewportCorners Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »DeviceContextViewportCorners
Declaration Syntax
C# Visual Basic Visual C++
public abstract Extents2d DeviceContextViewportCorners { get; }
Public MustOverride ReadOnly Property DeviceContextViewportCorners As Extents2d
    Get
public:
virtual property Extents2d DeviceContextViewportCorners {
    Extents2d get () abstract;
}


DoInversePerspective Method (value)

DoInversePerspective Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »DoInversePerspective(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract Point3d DoInversePerspective(
    Point3d value
)
Public MustOverride Function DoInversePerspective ( _
    value As Point3d _
) As Point3d
public:
virtual Point3d DoInversePerspective(
    Point3d value
) abstract
Parameters
value(Point3d)


DoPerspective Method (value)

DoPerspective Method (value)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »DoPerspective(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract Point3d DoPerspective(
    Point3d value
)
Public MustOverride Function DoPerspective ( _
    value As Point3d _
) As Point3d
public:
virtual Point3d DoPerspective(
    Point3d value
) abstract
Parameters
value(Point3d)


EyeToModelTransform Property

EyeToModelTransform Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »EyeToModelTransform
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d EyeToModelTransform { get; }
Public MustOverride ReadOnly Property EyeToModelTransform As Matrix3d
    Get
public:
virtual property Matrix3d EyeToModelTransform {
    Matrix3d get () abstract;
}


EyeToWorldTransform Property

EyeToWorldTransform Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »EyeToWorldTransform
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d EyeToWorldTransform { get; }
Public MustOverride ReadOnly Property EyeToWorldTransform As Matrix3d
    Get
public:
virtual property Matrix3d EyeToWorldTransform {
    Matrix3d get () abstract;
}


FrontAndBackClipping Property

FrontAndBackClipping Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »FrontAndBackClipping
Declaration Syntax
C# Visual Basic Visual C++
public abstract FrontAndBackClipping FrontAndBackClipping { get; }
Public MustOverride ReadOnly Property FrontAndBackClipping As FrontAndBackClipping
    Get
public:
virtual property FrontAndBackClipping FrontAndBackClipping {
    FrontAndBackClipping get () abstract;
}


GetNumPixelsInUnitSquare Method (givenWorldPoint)

GetNumPixelsInUnitSquare Method (givenWorldPoint)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »GetNumPixelsInUnitSquare(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract Point2d GetNumPixelsInUnitSquare(
    Point3d givenWorldPoint
)
Public MustOverride Function GetNumPixelsInUnitSquare ( _
    givenWorldPoint As Point3d _
) As Point2d
public:
virtual Point2d GetNumPixelsInUnitSquare(
    Point3d givenWorldPoint
) abstract
Parameters
givenWorldPoint(Point3d)


IsPerspective Property

IsPerspective Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »IsPerspective
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsPerspective { get; }
Public MustOverride ReadOnly Property IsPerspective As Boolean
    Get
public:
virtual property bool IsPerspective {
    bool get () abstract;
}


LayerVisible Method (idLayer)

LayerVisible Method (idLayer)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »LayerVisible(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool LayerVisible(
    ObjectId idLayer
)
Public Overridable Function LayerVisible ( _
    idLayer As ObjectId _
) As Boolean
public:
virtual bool LayerVisible(
    ObjectId idLayer
)
Parameters
idLayer(ObjectId)


LinetypeGenerationCriteria Property

LinetypeGenerationCriteria Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »LinetypeGenerationCriteria
Declaration Syntax
C# Visual Basic Visual C++
public abstract double LinetypeGenerationCriteria { get; }
Public MustOverride ReadOnly Property LinetypeGenerationCriteria As Double
    Get
public:
virtual property double LinetypeGenerationCriteria {
    double get () abstract;
}


LinetypeScaleMultiplier Property

LinetypeScaleMultiplier Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »LinetypeScaleMultiplier
Declaration Syntax
C# Visual Basic Visual C++
public abstract double LinetypeScaleMultiplier { get; }
Public MustOverride ReadOnly Property LinetypeScaleMultiplier As Double
    Get
public:
virtual property double LinetypeScaleMultiplier {
    double get () abstract;
}


ModelToEyeTransform Property

ModelToEyeTransform Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »ModelToEyeTransform
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d ModelToEyeTransform { get; }
Public MustOverride ReadOnly Property ModelToEyeTransform As Matrix3d
    Get
public:
virtual property Matrix3d ModelToEyeTransform {
    Matrix3d get () abstract;
}


ViewDirection Property

ViewDirection Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »ViewDirection
Declaration Syntax
C# Visual Basic Visual C++
public virtual Vector3d ViewDirection { get; }
Public Overridable ReadOnly Property ViewDirection As Vector3d
    Get
public:
virtual property Vector3d ViewDirection {
    Vector3d get ();
}


ViewportId Property

ViewportId Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »ViewportId
Declaration Syntax
C# Visual Basic Visual C++
public abstract IntPtr ViewportId { get; }
Public MustOverride ReadOnly Property ViewportId As IntPtr
    Get
public:
virtual property IntPtr ViewportId {
    IntPtr get () abstract;
}


WorldToEyeTransform Property

WorldToEyeTransform Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »WorldToEyeTransform
Declaration Syntax
C# Visual Basic Visual C++
public abstract Matrix3d WorldToEyeTransform { get; }
Public MustOverride ReadOnly Property WorldToEyeTransform As Matrix3d
    Get
public:
virtual property Matrix3d WorldToEyeTransform {
    Matrix3d get () abstract;
}


ViewportDraw Class

ViewportDraw Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportDraw
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiViewportDraw")]
public abstract class ViewportDraw : CommonDraw
<WrapperAttribute("ZcGiViewportDraw")> _
Public MustInherit Class ViewportDraw _
    Inherits CommonDraw
[WrapperAttribute(L"ZcGiViewportDraw")]
public ref class ViewportDraw abstract : public CommonDraw
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewportDraw()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Context | (Inherited from CommonDraw.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Deviation(DeviationType, Point3d) | (Inherited from CommonDraw.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | Geometry |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsDragging | (Inherited from CommonDraw.)
 | IsValidId(IntPtr) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfIsolines | (Inherited from CommonDraw.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RawGeometry | (Inherited from CommonDraw.)
 | RegenAbort | (Inherited from CommonDraw.)
 | RegenType | (Inherited from CommonDraw.)
 | SequenceNumber |
 | SubEntityTraits | (Inherited from CommonDraw.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Viewport |
 | ViewportObjectId |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | CommonDraw
 |  |  |  |  | ViewportDraw


ViewportDraw Constructor

ViewportDraw Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportDraw »ViewportDraw()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected ViewportDraw()
Protected Sub New
protected:
ViewportDraw()


Geometry Property

Geometry Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportDraw »Geometry
Declaration Syntax
C# Visual Basic Visual C++
public abstract ViewportGeometry Geometry { get; }
Public MustOverride ReadOnly Property Geometry As ViewportGeometry
    Get
public:
virtual property ViewportGeometry^ Geometry {
    ViewportGeometry^ get () abstract;
}


IsValidId Method (id)

IsValidId Method (id)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportDraw »IsValidId(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsValidId(
    IntPtr id
)
Public Overridable Function IsValidId ( _
    id As IntPtr _
) As Boolean
public:
virtual bool IsValidId(
    IntPtr id
)
Parameters
id(IntPtr)


SequenceNumber Property

SequenceNumber Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportDraw »SequenceNumber
Declaration Syntax
C# Visual Basic Visual C++
public abstract int SequenceNumber { get; }
Public MustOverride ReadOnly Property SequenceNumber As Integer
    Get
public:
virtual property int SequenceNumber {
    int get () abstract;
}


Viewport Property

Viewport Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportDraw »Viewport
Declaration Syntax
C# Visual Basic Visual C++
public abstract Viewport Viewport { get; }
Public MustOverride ReadOnly Property Viewport As Viewport
    Get
public:
virtual property Viewport^ Viewport {
    Viewport^ get () abstract;
}


ViewportObjectId Property

ViewportObjectId Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportDraw »ViewportObjectId
Declaration Syntax
C# Visual Basic Visual C++
public abstract ObjectId ViewportObjectId { get; }
Public MustOverride ReadOnly Property ViewportObjectId As ObjectId
    Get
public:
virtual property ObjectId ViewportObjectId {
    ObjectId get () abstract;
}


ViewportGeometry Class

ViewportGeometry Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiViewportGeometry")]
public abstract class ViewportGeometry : Geometry
<WrapperAttribute("ZcGiViewportGeometry")> _
Public MustInherit Class ViewportGeometry _
    Inherits Geometry
[WrapperAttribute(L"ZcGiViewportGeometry")]
public ref class ViewportGeometry abstract : public Geometry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewportGeometry(IntPtr, Boolean) |
 | ViewportGeometry()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Circle(Point3d, Double, Vector3d) | (Inherited from Geometry.)
 | Circle(Point3d, Point3d, Point3d) | (Inherited from Geometry.)
 | CircularArc(Point3d, Double, Vector3d, Vector3d, Double, ArcType) | (Inherited from Geometry.)
 | CircularArc(Point3d, Point3d, Point3d, ArcType) | (Inherited from Geometry.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DeviceContextPolygon(Point3dCollection) |
 | DeviceContextPolyline(Point3dCollection) |
 | DeviceContextRasterImage(Point3d, Vector3d, Vector3d, Matrix2d, ObjectId, ImageOrg, Int32, Int32, Int16, Boolean, ImageSource, Vector3d, ImageOrg, Matrix2d, Int32, Int32) |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Draw(Drawable) | (Inherited from Geometry.)
 | EllipticalArc(Point3d, Vector3d, Double, Double, Double, Double, Double, ArcType) | (Inherited from Geometry.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mesh(Int32, Int32, Point3dCollection, EdgeData, FaceData, VertexData, Boolean) | (Inherited from Geometry.)
 | ModelToWorldTransform | (Inherited from Geometry.)
 | OwnerDraw(GdiDrawObject, Point3d, Vector3d, Vector3d) | (Inherited from Geometry.)
 | Polygon(Point3dCollection) | (Inherited from Geometry.)
 | PolygonEye(Point3dCollection) |
 | Polyline(Point3dCollection, Vector3d, IntPtr) | (Inherited from Geometry.)
 | Polyline(Polyline, Int32, Int32) | (Inherited from Geometry.)
 | Polyline(Polyline) | (Inherited from Geometry.)
 | PolylineEye(Point3dCollection) |
 | Polypoint(Point3dCollection, EntityColorCollection, Vector3dCollection, IntPtrCollection) | (Inherited from Geometry.)
 | Polypoint(Point3dCollection, Vector3dCollection, IntPtrCollection) | (Inherited from Geometry.)
 | PolyPolygon(UInt32Collection, Point3dCollection, UInt32Collection, Point3dCollection, EntityColorCollection, LinetypeCollection, EntityColorCollection, TransparencyCollection) | (Inherited from Geometry.)
 | PolyPolyline(PolylineCollection) | (Inherited from Geometry.)
 | PopClipBoundary()()()() | (Inherited from Geometry.)
 | PopModelTransform()()()() | (Inherited from Geometry.)
 | PushClipBoundary(ClipBoundary) | (Inherited from Geometry.)
 | PushModelTransform(Vector3d) | (Inherited from Geometry.)
 | PushModelTransform(Matrix3d) | (Inherited from Geometry.)
 | PushOrientationTransform(OrientationBehavior) | (Inherited from Geometry.)
 | PushPositionTransform(PositionBehavior, Point3d) | (Inherited from Geometry.)
 | PushPositionTransform(PositionBehavior, Point2d) | (Inherited from Geometry.)
 | PushScaleTransform(ScaleBehavior, Point3d) | (Inherited from Geometry.)
 | PushScaleTransform(ScaleBehavior, Point2d) | (Inherited from Geometry.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Ray(Point3d, Point3d) | (Inherited from Geometry.)
 | RowOfDots(Int32, Point3d, Vector3d) | (Inherited from Geometry.)
 | Shell(Point3dCollection, IntegerCollection, EdgeData, FaceData, VertexData, Boolean) | (Inherited from Geometry.)
 | Text(Point3d, Vector3d, Vector3d, Double, Double, Double, String) | (Inherited from Geometry.)
 | Text(Point3d, Vector3d, Vector3d, String, Boolean, TextStyle) | (Inherited from Geometry.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | WorldLine(Point3d, Point3d) | (Inherited from Geometry.)
 | WorldToModelTransform | (Inherited from Geometry.)
 | X(RXClass) | (Inherited from RXObject.)
 | Xline(Point3d, Point3d) | (Inherited from Geometry.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Geometry
 |  |  |  |  | ViewportGeometry


ViewportGeometry Constructor

ViewportGeometry Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »ViewportGeometry()()()()
Members
Icon | Member | Description
 | ViewportGeometry(IntPtr, Boolean) |
 | ViewportGeometry()()()() |


ViewportGeometry Constructor

ViewportGeometry Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »ViewportGeometry()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected ViewportGeometry()
Protected Sub New
protected:
ViewportGeometry()


ViewportGeometry Constructor (unmanagedPointer, autoDelete)

ViewportGeometry Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »ViewportGeometry(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected ViewportGeometry(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
ViewportGeometry(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DeviceContextPolygon Method (points)

DeviceContextPolygon Method (points)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »DeviceContextPolygon(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool DeviceContextPolygon(
    Point3dCollection points
)
Public MustOverride Function DeviceContextPolygon ( _
    points As Point3dCollection _
) As Boolean
public:
virtual bool DeviceContextPolygon(
    Point3dCollection^ points
) abstract
Parameters
points(Point3dCollection)


DeviceContextPolyline Method (points)

DeviceContextPolyline Method (points)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »DeviceContextPolyline(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool DeviceContextPolyline(
    Point3dCollection points
)
Public MustOverride Function DeviceContextPolyline ( _
    points As Point3dCollection _
) As Boolean
public:
virtual bool DeviceContextPolyline(
    Point3dCollection^ points
) abstract
Parameters
points(Point3dCollection)


DeviceContextRasterImage Method (origin, u, v, pixel, entityId, imageOrg, imageWidth, imageHeight, imageColorDepth, transparency, source, unRotated, originalImage, unRotatedPixel, unRotatedImageWidth, unRotatedImageHeight)

DeviceContextRasterImage Method (origin, u, v, pixel, entityId, imageOrg, imageWidth, imageHeight, imageColorDepth, transparency, source, unRotated, originalImage, unRotatedPixel, unRotatedImageWidth, unRotatedImageHeight)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »DeviceContextRasterImage(Point3d, Vector3d, Vector3d, Matrix2d, ObjectId, ImageOrg, Int32, Int32, Int16, Boolean, ImageSource, Vector3d, ImageOrg, Matrix2d, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool DeviceContextRasterImage(
    Point3d origin,
    Vector3d u,
    Vector3d v,
    Matrix2d pixel,
    ObjectId entityId,
    ImageOrg imageOrg,
    int imageWidth,
    int imageHeight,
    short imageColorDepth,
    bool transparency,
    ImageSource source,
    Vector3d unRotated,
    ImageOrg originalImage,
    Matrix2d unRotatedPixel,
    int unRotatedImageWidth,
    int unRotatedImageHeight
)
Public MustOverride Function DeviceContextRasterImage ( _
    origin As Point3d, _
    u As Vector3d, _
    v As Vector3d, _
    pixel As Matrix2d, _
    entityId As ObjectId, _
    imageOrg As ImageOrg, _
    imageWidth As Integer, _
    imageHeight As Integer, _
    imageColorDepth As Short, _
    transparency As Boolean, _
    source As ImageSource, _
    unRotated As Vector3d, _
    originalImage As ImageOrg, _
    unRotatedPixel As Matrix2d, _
    unRotatedImageWidth As Integer, _
    unRotatedImageHeight As Integer _
) As Boolean
public:
virtual bool DeviceContextRasterImage(
    Point3d origin,
    Vector3d u,
    Vector3d v,
    Matrix2d pixel,
    ObjectId entityId,
    ImageOrg imageOrg,
    int imageWidth,
    int imageHeight,
    short imageColorDepth,
    bool transparency,
    ImageSource source,
    Vector3d unRotated,
    ImageOrg originalImage,
    Matrix2d unRotatedPixel,
    int unRotatedImageWidth,
    int unRotatedImageHeight
) abstract
Parameters
origin(Point3d)
u(Vector3d)
v(Vector3d)
pixel(Matrix2d)
entityId(ObjectId)
imageOrg(ImageOrg)
imageWidth(Int32)
imageHeight(Int32)
imageColorDepth(Int16)
transparency(Boolean)
source(ImageSource)
unRotated(Vector3d)
originalImage(ImageOrg)
unRotatedPixel(Matrix2d)
unRotatedImageWidth(Int32)
unRotatedImageHeight(Int32)


PolygonEye Method (points)

PolygonEye Method (points)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »PolygonEye(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool PolygonEye(
    Point3dCollection points
)
Public MustOverride Function PolygonEye ( _
    points As Point3dCollection _
) As Boolean
public:
virtual bool PolygonEye(
    Point3dCollection^ points
) abstract
Parameters
points(Point3dCollection)


PolylineEye Method (points)

PolylineEye Method (points)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »PolylineEye(Point3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool PolylineEye(
    Point3dCollection points
)
Public MustOverride Function PolylineEye ( _
    points As Point3dCollection _
) As Boolean
public:
virtual bool PolylineEye(
    Point3dCollection^ points
) abstract
Parameters
points(Point3dCollection)


VisualStyle Class

VisualStyle Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiVisualStyle")]
public class VisualStyle : RXObject
<WrapperAttribute("ZcGiVisualStyle")> _
Public Class VisualStyle _
    Inherits RXObject
[WrapperAttribute(L"ZcGiVisualStyle")]
public ref class VisualStyle : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VisualStyle(IntPtr, Boolean) |
 | VisualStyle(VisualStyleType) |
 | VisualStyle()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | ConfigureForType(VisualStyleType) |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DisplayStyle |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EdgeStyle |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | FaceStyle |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | VisualStyle


VisualStyle Constructor

VisualStyle Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle »VisualStyle()()()()
Members
Icon | Member | Description
 | VisualStyle(IntPtr, Boolean) |
 | VisualStyle(VisualStyleType) |
 | VisualStyle()()()() |


VisualStyle Constructor

VisualStyle Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle »VisualStyle()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VisualStyle()
Public Sub New
public:
VisualStyle()


VisualStyle Constructor (unmanagedPointer, autoDelete)

VisualStyle Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle »VisualStyle(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal VisualStyle(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
VisualStyle(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


VisualStyle Constructor (type)

VisualStyle Constructor (type)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle »VisualStyle(VisualStyleType)
Declaration Syntax
C# Visual Basic Visual C++
public VisualStyle(
    VisualStyleType type
)
Public Sub New ( _
    type As VisualStyleType _
)
public:
VisualStyle(
    VisualStyleType type
)
Parameters
type(VisualStyleType)


ConfigureForType Method (type)

ConfigureForType Method (type)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle »ConfigureForType(VisualStyleType)
Declaration Syntax
C# Visual Basic Visual C++
public void ConfigureForType(
    VisualStyleType type
)
Public Sub ConfigureForType ( _
    type As VisualStyleType _
)
public:
void ConfigureForType(
    VisualStyleType type
)
Parameters
type(VisualStyleType)


DisplayStyle Property

DisplayStyle Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle »DisplayStyle
Declaration Syntax
C# Visual Basic Visual C++
public DisplayStyle DisplayStyle { get; set; }
Public Property DisplayStyle As DisplayStyle
    Get
    Set
public:
property DisplayStyle^ DisplayStyle {
    DisplayStyle^ get ();
    void set (DisplayStyle^ value);
}


EdgeStyle Property

EdgeStyle Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle »EdgeStyle
Declaration Syntax
C# Visual Basic Visual C++
public EdgeStyle EdgeStyle { get; set; }
Public Property EdgeStyle As EdgeStyle
    Get
    Set
public:
property EdgeStyle^ EdgeStyle {
    EdgeStyle^ get ();
    void set (EdgeStyle^ value);
}


FaceStyle Property

FaceStyle Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle »FaceStyle
Declaration Syntax
C# Visual Basic Visual C++
public FaceStyle FaceStyle { get; set; }
Public Property FaceStyle As FaceStyle
    Get
    Set
public:
property FaceStyle^ FaceStyle {
    FaceStyle^ get ();
    void set (FaceStyle^ value);
}


VisualStyleOperation Enumeration

VisualStyleOperation Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyleOperation
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiVisualStyleOperations::Operation")]
public enum VisualStyleOperation
<WrapperAttribute("ZcGiVisualStyleOperations::Operation")> _
Public Enumeration VisualStyleOperation
[WrapperAttribute(L"ZcGiVisualStyleOperations::Operation")]
public enum class VisualStyleOperation
Members
Member | Description
InvalidOperation |
Inherit |
Enable |
Set |
Disable |


VisualStyleProperty Enumeration

VisualStyleProperty Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyleProperty
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcGiVisualStyleProperties::Property")]
public enum VisualStyleProperty
<WrapperAttribute("AcGiVisualStyleProperties::Property")> _
Public Enumeration VisualStyleProperty
[WrapperAttribute(L"AcGiVisualStyleProperties::Property")]
public enum class VisualStyleProperty
Members
Member | Description
ViewportTransparency |
UseDrawOrder |
TintEffect |
TintColor |
PropertyCount |
PostPower |
PosterizeEffect |
PostContrast |
PostBrightness |
PencilScale |
PencilPattern |
PencilEffect |
PencilColor |
PencilAngle |
PastelEffect |
MonoEffect |
LightingEnabled |
InvalidProperty |
FocusWidth |
FocusDistance |
FaceSpecular |
FaceOpacity |
FaceMonoColor |
FaceAdjustment |
EdgeWiggleAmount |
EdgeTexturePath |
EdgeSilhouetteWidth |
EdgeSilhouetteColor |
EdgeOverhang |
EdgeOpacity |
EdgeObscuredLinePattern |
EdgeObscuredColor |
EdgeIsolines |
EdgeIntersectionLinePattern |
EdgeIntersectionColor |
EdgeHidePrecision |
EdgeHaloGap |
EdgeCreaseAngle |
DisplayBrightness |
DepthOfField |
BlurEffect |
BlurAmount |
BloomThreshold |
BloomRadius |
BloomIntensity |
BloomEffect |
EdgeWidth |
EdgeColor |
DisplayStyle |
FaceModifier |
FaceLightingQuality |
FaceLightingModel |
FaceColorMode |
EdgeStyle |
EdgeModifier |
EdgeModel |
EdgeJitterAmount |
DisplayShadowType |
Transparency |
Color |


VisualStyleType Enumeration

VisualStyleType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyleType
Declaration Syntax
C# Visual Basic Visual C++
public enum VisualStyleType
Public Enumeration VisualStyleType
public enum class VisualStyleType
Members
Member | Description
ColorChange |
FacePattern |
LinePattern |
Thicken |
Brighten |
Dim |
Custom |
Conceptual |
Realistic |
Basic |
Hidden |
Wireframe3D |
Wireframe2D |
GouraudWithEdges |
Gouraud |
FlatWithEdges |
Flat |


WorldDraw Class

WorldDraw Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldDraw
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiWorldDraw")]
public abstract class WorldDraw : CommonDraw
<WrapperAttribute("ZcGiWorldDraw")> _
Public MustInherit Class WorldDraw _
    Inherits CommonDraw
[WrapperAttribute(L"ZcGiWorldDraw")]
public ref class WorldDraw abstract : public CommonDraw
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WorldDraw(IntPtr, Boolean) |
 | WorldDraw()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Context | (Inherited from CommonDraw.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Deviation(DeviationType, Point3d) | (Inherited from CommonDraw.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | Geometry |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsDragging | (Inherited from CommonDraw.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfIsolines | (Inherited from CommonDraw.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RawGeometry | (Inherited from CommonDraw.)
 | RegenAbort | (Inherited from CommonDraw.)
 | RegenType | (Inherited from CommonDraw.)
 | SubEntityTraits | (Inherited from CommonDraw.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | CommonDraw
 |  |  |  |  | WorldDraw


WorldDraw Constructor

WorldDraw Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldDraw »WorldDraw()()()()
Members
Icon | Member | Description
 | WorldDraw(IntPtr, Boolean) |
 | WorldDraw()()()() |


WorldDraw Constructor

WorldDraw Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldDraw »WorldDraw()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected WorldDraw()
Protected Sub New
protected:
WorldDraw()


WorldDraw Constructor (unmanagedPointer, autoDelete)

WorldDraw Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldDraw »WorldDraw(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected WorldDraw(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
WorldDraw(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Geometry Property

Geometry Property
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldDraw »Geometry
Declaration Syntax
C# Visual Basic Visual C++
public abstract WorldGeometry Geometry { get; }
Public MustOverride ReadOnly Property Geometry As WorldGeometry
    Get
public:
virtual property WorldGeometry^ Geometry {
    WorldGeometry^ get () abstract;
}


WorldGeometry Class

WorldGeometry Class
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGiWorldGeometry")]
public abstract class WorldGeometry : Geometry
<WrapperAttribute("ZcGiWorldGeometry")> _
Public MustInherit Class WorldGeometry _
    Inherits Geometry
[WrapperAttribute(L"ZcGiWorldGeometry")]
public ref class WorldGeometry abstract : public Geometry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WorldGeometry(IntPtr, Boolean) |
 | WorldGeometry()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Circle(Point3d, Double, Vector3d) | (Inherited from Geometry.)
 | Circle(Point3d, Point3d, Point3d) | (Inherited from Geometry.)
 | CircularArc(Point3d, Double, Vector3d, Vector3d, Double, ArcType) | (Inherited from Geometry.)
 | CircularArc(Point3d, Point3d, Point3d, ArcType) | (Inherited from Geometry.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Draw(Drawable) | (Inherited from Geometry.)
 | EllipticalArc(Point3d, Vector3d, Double, Double, Double, Double, Double, ArcType) | (Inherited from Geometry.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mesh(Int32, Int32, Point3dCollection, EdgeData, FaceData, VertexData, Boolean) | (Inherited from Geometry.)
 | ModelToWorldTransform | (Inherited from Geometry.)
 | OwnerDraw(GdiDrawObject, Point3d, Vector3d, Vector3d) | (Inherited from Geometry.)
 | Polygon(Point3dCollection) | (Inherited from Geometry.)
 | Polyline(Point3dCollection, Vector3d, IntPtr) | (Inherited from Geometry.)
 | Polyline(Polyline, Int32, Int32) | (Inherited from Geometry.)
 | Polyline(Polyline) | (Inherited from Geometry.)
 | Polypoint(Point3dCollection, EntityColorCollection, Vector3dCollection, IntPtrCollection) | (Inherited from Geometry.)
 | Polypoint(Point3dCollection, Vector3dCollection, IntPtrCollection) | (Inherited from Geometry.)
 | PolyPolygon(UInt32Collection, Point3dCollection, UInt32Collection, Point3dCollection, EntityColorCollection, LinetypeCollection, EntityColorCollection, TransparencyCollection) | (Inherited from Geometry.)
 | PolyPolyline(PolylineCollection) | (Inherited from Geometry.)
 | PopClipBoundary()()()() | (Inherited from Geometry.)
 | PopModelTransform()()()() | (Inherited from Geometry.)
 | PushClipBoundary(ClipBoundary) | (Inherited from Geometry.)
 | PushModelTransform(Vector3d) | (Inherited from Geometry.)
 | PushModelTransform(Matrix3d) | (Inherited from Geometry.)
 | PushOrientationTransform(OrientationBehavior) | (Inherited from Geometry.)
 | PushPositionTransform(PositionBehavior, Point3d) | (Inherited from Geometry.)
 | PushPositionTransform(PositionBehavior, Point2d) | (Inherited from Geometry.)
 | PushScaleTransform(ScaleBehavior, Point3d) | (Inherited from Geometry.)
 | PushScaleTransform(ScaleBehavior, Point2d) | (Inherited from Geometry.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Ray(Point3d, Point3d) | (Inherited from Geometry.)
 | RowOfDots(Int32, Point3d, Vector3d) | (Inherited from Geometry.)
 | SetExtents(Extents3d) |
 | Shell(Point3dCollection, IntegerCollection, EdgeData, FaceData, VertexData, Boolean) | (Inherited from Geometry.)
 | StartAttributesSegment()()()() |
 | Text(Point3d, Vector3d, Vector3d, Double, Double, Double, String) | (Inherited from Geometry.)
 | Text(Point3d, Vector3d, Vector3d, String, Boolean, TextStyle) | (Inherited from Geometry.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | WorldLine(Point3d, Point3d) | (Inherited from Geometry.)
 | WorldToModelTransform | (Inherited from Geometry.)
 | X(RXClass) | (Inherited from RXObject.)
 | Xline(Point3d, Point3d) | (Inherited from Geometry.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Geometry
 |  |  |  |  | WorldGeometry


WorldGeometry Constructor

WorldGeometry Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »WorldGeometry()()()()
Members
Icon | Member | Description
 | WorldGeometry(IntPtr, Boolean) |
 | WorldGeometry()()()() |


WorldGeometry Constructor

WorldGeometry Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »WorldGeometry()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected WorldGeometry()
Protected Sub New
protected:
WorldGeometry()


WorldGeometry Constructor (unmanagedPointer, autoDelete)

WorldGeometry Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »WorldGeometry(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected WorldGeometry(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
WorldGeometry(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


SetExtents Method (extents)

SetExtents Method (extents)
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »SetExtents(Extents3d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void SetExtents(
    Extents3d extents
)
Public MustOverride Sub SetExtents ( _
    extents As Extents3d _
)
public:
virtual void SetExtents(
    Extents3d extents
) abstract
Parameters
extents(Extents3d)


StartAttributesSegment Method

StartAttributesSegment Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »StartAttributesSegment()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void StartAttributesSegment()
Public MustOverride Sub StartAttributesSegment
public:
virtual void StartAttributesSegment() abstract


ZwSoft.ZwCAD.GraphicsSystem Namespace

ZwSoft.ZwCAD.GraphicsSystem Namespace
Namespaces »ZwSoft.ZwCAD.GraphicsSystem
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.GraphicsSystem
Namespace ZwSoft.ZwCAD.GraphicsSystem
namespace ZwSoft.ZwCAD.GraphicsSystem
Types
All Types Classes Structures Enumerations Delegates
Icon | Type | Description
 | AdditionMode |
 | ClearColor |
 | ClientViewInfo |
 | ConfigWasModifiedEventHandler |
 | DefaultLightingType |
 | Device |
 | DrawableDescFlags |
 | GsToBeUnloadedEventHandler |
 | ImpDevice |
 | InvalidationHint |
 | Manager |
 | Model |
 | Projection |
 | RenderMode |
 | RenderType |
 | SelectionMode |
 | StereoParameters |
 | View |
 | ViewEventArgs |
 | ViewportBorderProperties |
 | ViewportFlags |
 | ViewToBeDestroyedEventHandler |
 | ViewWasCreatedEventHandler |


AdditionMode Enumeration

AdditionMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »AdditionMode
Declaration Syntax
C# Visual Basic Visual C++
public enum AdditionMode
Public Enumeration AdditionMode
public enum class AdditionMode
Members
Member | Description
UneraseDrawable |
AddDrawable |


ClearColor Enumeration

ClearColor Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ClearColor
Declaration Syntax
C# Visual Basic Visual C++
public enum ClearColor
Public Enumeration ClearColor
public enum class ClearColor
Members
Member | Description
PaletteBackground |
DeviceBackground |
Transparent |


ClientViewInfo Structure

ClientViewInfo Structure
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ClientViewInfo
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcGsClientViewInfo")]
public struct ClientViewInfo
<WrapperAttribute("AcGsClientViewInfo")> _
Public Structure ClientViewInfo
[WrapperAttribute(L"AcGsClientViewInfo")]
public value class ClientViewInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AcadWindowId |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)
 | ViewportId |
 | ViewportObjectId |


AcadWindowId Property

AcadWindowId Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ClientViewInfo »AcadWindowId
Declaration Syntax
C# Visual Basic Visual C++
public long AcadWindowId { get; }
Public ReadOnly Property AcadWindowId As Long
    Get
public:
property long long AcadWindowId {
    long long get ();
}


ViewportId Property

ViewportId Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ClientViewInfo »ViewportId
Declaration Syntax
C# Visual Basic Visual C++
public long ViewportId { get; }
Public ReadOnly Property ViewportId As Long
    Get
public:
property long long ViewportId {
    long long get ();
}


ViewportObjectId Property

ViewportObjectId Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ClientViewInfo »ViewportObjectId
Declaration Syntax
C# Visual Basic Visual C++
public long ViewportObjectId { get; }
Public ReadOnly Property ViewportObjectId As Long
    Get
public:
property long long ViewportObjectId {
    long long get ();
}


ConfigWasModifiedEventHandler Delegate

ConfigWasModifiedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ConfigWasModifiedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ConfigWasModifiedEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub ConfigWasModifiedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
public delegate void ConfigWasModifiedEventHandler(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender(Object)
e(EventArgs)

Assembly: ZwManaged (Module: ZwManaged)


DefaultLightingType Enumeration

DefaultLightingType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »DefaultLightingType
Declaration Syntax
C# Visual Basic Visual C++
public enum DefaultLightingType
Public Enumeration DefaultLightingType
public enum class DefaultLightingType
Members
Member | Description
TwoLights |
OneLight |


Device Class

Device Class
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcGsDevice")]
public abstract class Device : RXObject
<WrapperAttribute("ZcGsDevice")> _
Public MustInherit Class Device _
    Inherits RXObject
[WrapperAttribute(L"ZcGsDevice")]
public ref class Device abstract : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Device()()()() |
 | Device(IntPtr, Boolean) |
 | Add(View) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackgroundColor |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateModel()()()() |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateView(ClientViewInfo, Boolean) |
 | CreateView(ClientViewInfo) |
 | CreateView()()()() |
 | DarkPalette |
 | DeleteUnmanagedObject()()()() | (Overrides RXObject.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Int32) |
 | Erase(View) |
 | EraseAll()()()() |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetUnmanagedObject()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertView(Int32, View) |
 | Invalidate(Rectangle) |
 | Invalidate()()()() |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsValid |
 | LightPalette |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumViews |
 | OnDisplayChange(Int32, Int32, Int32) |
 | OnRealizeBackgroundPalette()()()() |
 | OnRealizeForegroundPalette()()()() |
 | OnSize(Extents2d) |
 | OnSize(Rectangle) |
 | OnSize(Size) |
 | Properties |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SetLogicalPalette(array<Color>[]()[][]) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Update(Rectangle) |
 | Update()()()() |
 | UserGiContext |
 | ViewAt(Int32) |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Device
 |  |  |  |  | ImpDevice


Device Constructor

Device Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Device()()()()
Members
Icon | Member | Description
 | Device()()()() |
 | Device(IntPtr, Boolean) |


Device Constructor

Device Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Device()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Device()
Public Sub New
public:
Device()


Device Constructor (unmanagedPointer, autoDelete)

Device Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Device(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Device(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Device(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Add Method (pView)

Add Method (pView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Add(View)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Add(
    View pView
)
Public MustOverride Sub Add ( _
    pView As View _
)
public:
virtual void Add(
    View^ pView
) abstract
Parameters
pView(View)


BackgroundColor Property

BackgroundColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »BackgroundColor
Declaration Syntax
C# Visual Basic Visual C++
public abstract Color BackgroundColor { get; set; }
Public MustOverride Property BackgroundColor As Color
    Get
    Set
public:
virtual property Color BackgroundColor {
    Color get () abstract;
    void set (Color value) abstract;
}


CreateModel Method

CreateModel Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »CreateModel()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract Model CreateModel()
Public MustOverride Function CreateModel As Model
public:
virtual Model^ CreateModel() abstract


CreateView Method

CreateView Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »CreateView()()()()
Members
Icon | Member | Description
 | CreateView(ClientViewInfo, Boolean) |
 | CreateView(ClientViewInfo) |
 | CreateView()()()() |


CreateView Method

CreateView Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »CreateView()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract View CreateView()
Public MustOverride Function CreateView As View
public:
virtual View^ CreateView() abstract


CreateView Method (pViewInfo)

CreateView Method (pViewInfo)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »CreateView(ClientViewInfo)
Declaration Syntax
C# Visual Basic Visual C++
public abstract View CreateView(
    ClientViewInfo pViewInfo
)
Public MustOverride Function CreateView ( _
    pViewInfo As ClientViewInfo _
) As View
public:
virtual View^ CreateView(
    ClientViewInfo pViewInfo
) abstract
Parameters
pViewInfo(ClientViewInfo)


CreateView Method (pViewInfo, enableLayerVisibilityPerView)

CreateView Method (pViewInfo, enableLayerVisibilityPerView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »CreateView(ClientViewInfo, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public abstract View CreateView(
    ClientViewInfo pViewInfo,
    bool enableLayerVisibilityPerView
)
Public MustOverride Function CreateView ( _
    pViewInfo As ClientViewInfo, _
    enableLayerVisibilityPerView As Boolean _
) As View
public:
virtual View^ CreateView(
    ClientViewInfo pViewInfo,
    bool enableLayerVisibilityPerView
) abstract
Parameters
pViewInfo(ClientViewInfo)
enableLayerVisibilityPerView(Boolean)


DarkPalette Property

DarkPalette Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »DarkPalette
Declaration Syntax
C# Visual Basic Visual C++
public static Color[] DarkPalette { get; }
Public Shared ReadOnly Property DarkPalette As Color()
    Get
public:
static property array<Color>^ DarkPalette {
    array<Color>^ get ();
}


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Erase()()()()
Members
Icon | Member | Description
 | Erase(Int32) |
 | Erase(View) |


Erase Method (viewIndex)

Erase Method (viewIndex)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Erase(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Erase(
    int viewIndex
)
Public MustOverride Function Erase ( _
    viewIndex As Integer _
) As Boolean
public:
virtual bool Erase(
    int viewIndex
) abstract
Parameters
viewIndex(Int32)


Erase Method (pView)

Erase Method (pView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Erase(View)
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool Erase(
    View pView
)
Public MustOverride Function Erase ( _
    pView As View _
) As Boolean
public:
virtual bool Erase(
    View^ pView
) abstract
Parameters
pView(View)


EraseAll Method

EraseAll Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »EraseAll()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void EraseAll()
Public MustOverride Sub EraseAll
public:
virtual void EraseAll() abstract


GetUnmanagedObject Method

GetUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »GetUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected internal ZcGsDevice* GetUnmanagedObject()
Protected Friend Function GetUnmanagedObject As ZcGsDevice*
protected public:
ZcGsDevice* GetUnmanagedObject()


InsertView Method (viewIndex, pView)

InsertView Method (viewIndex, pView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »InsertView(Int32, View)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void InsertView(
    int viewIndex,
    View pView
)
Public MustOverride Sub InsertView ( _
    viewIndex As Integer, _
    pView As View _
)
public:
virtual void InsertView(
    int viewIndex,
    View^ pView
) abstract
Parameters
viewIndex(Int32)
pView(View)


Invalidate Method

Invalidate Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Rectangle) |
 | Invalidate()()()() |


Invalidate Method

Invalidate Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Invalidate()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Invalidate()
Public MustOverride Sub Invalidate
public:
virtual void Invalidate() abstract


Invalidate Method (screenRect)

Invalidate Method (screenRect)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Invalidate(Rectangle)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Invalidate(
    Rectangle screenRect
)
Public MustOverride Sub Invalidate ( _
    screenRect As Rectangle _
)
public:
virtual void Invalidate(
    Rectangle screenRect
) abstract
Parameters
screenRect(Rectangle)


IsValid Property

IsValid Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »IsValid
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsValid { get; }
Public MustOverride ReadOnly Property IsValid As Boolean
    Get
public:
virtual property bool IsValid {
    bool get () abstract;
}


LightPalette Property

LightPalette Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »LightPalette
Declaration Syntax
C# Visual Basic Visual C++
public static Color[] LightPalette { get; }
Public Shared ReadOnly Property LightPalette As Color()
    Get
public:
static property array<Color>^ LightPalette {
    array<Color>^ get ();
}


NumViews Property

NumViews Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »NumViews
Declaration Syntax
C# Visual Basic Visual C++
public abstract int NumViews { get; }
Public MustOverride ReadOnly Property NumViews As Integer
    Get
public:
virtual property int NumViews {
    int get () abstract;
}


OnDisplayChange Method (bitsPerPixel, xPixels, yPixels)

OnDisplayChange Method (bitsPerPixel, xPixels, yPixels)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »OnDisplayChange(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void OnDisplayChange(
    int bitsPerPixel,
    int xPixels,
    int yPixels
)
Public MustOverride Sub OnDisplayChange ( _
    bitsPerPixel As Integer, _
    xPixels As Integer, _
    yPixels As Integer _
)
public:
virtual void OnDisplayChange(
    int bitsPerPixel,
    int xPixels,
    int yPixels
) abstract
Parameters
bitsPerPixel(Int32)
xPixels(Int32)
yPixels(Int32)


OnRealizeBackgroundPalette Method

OnRealizeBackgroundPalette Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »OnRealizeBackgroundPalette()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void OnRealizeBackgroundPalette()
Public MustOverride Sub OnRealizeBackgroundPalette
public:
virtual void OnRealizeBackgroundPalette() abstract


OnRealizeForegroundPalette Method

OnRealizeForegroundPalette Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »OnRealizeForegroundPalette()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void OnRealizeForegroundPalette()
Public MustOverride Sub OnRealizeForegroundPalette
public:
virtual void OnRealizeForegroundPalette() abstract


OnSize Method

OnSize Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »OnSize()()()()
Members
Icon | Member | Description
 | OnSize(Extents2d) |
 | OnSize(Rectangle) |
 | OnSize(Size) |


OnSize Method (outputRect)

OnSize Method (outputRect)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »OnSize(Rectangle)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void OnSize(
    Rectangle outputRect
)
Public MustOverride Sub OnSize ( _
    outputRect As Rectangle _
)
public:
virtual void OnSize(
    Rectangle outputRect
) abstract
Parameters
outputRect(Rectangle)


OnSize Method (size)

OnSize Method (size)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »OnSize(Size)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void OnSize(
    Size size
)
Public MustOverride Sub OnSize ( _
    size As Size _
)
public:
virtual void OnSize(
    Size size
) abstract
Parameters
size(Size)


OnSize Method (outputRect)

OnSize Method (outputRect)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »OnSize(Extents2d)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void OnSize(
    Extents2d outputRect
)
Public MustOverride Sub OnSize ( _
    outputRect As Extents2d _
)
public:
virtual void OnSize(
    Extents2d outputRect
) abstract
Parameters
outputRect(Extents2d)


Properties Property

Properties Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Properties
Declaration Syntax
C# Visual Basic Visual C++
public abstract Dictionary Properties { get; }
Public MustOverride ReadOnly Property Properties As Dictionary
    Get
public:
virtual property Dictionary^ Properties {
    Dictionary^ get () abstract;
}


SetLogicalPalette Method (logicalPalette)

SetLogicalPalette Method (logicalPalette)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »SetLogicalPalette(array<Color>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public abstract void SetLogicalPalette(
    Color[] logicalPalette
)
Public MustOverride Sub SetLogicalPalette ( _
    logicalPalette As Color() _
)
public:
virtual void SetLogicalPalette(
    array<Color>^ logicalPalette
) abstract
Parameters
logicalPalette(array<Color>[]()[][])


Update Method

Update Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Update()()()()
Members
Icon | Member | Description
 | Update(Rectangle) |
 | Update()()()() |


Update Method

Update Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Update()()()()
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Update()
Public MustOverride Sub Update
public:
virtual void Update() abstract


Update Method (pUpdatedRect)

Update Method (pUpdatedRect)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Update(Rectangle)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Update(
    Rectangle pUpdatedRect
)
Public MustOverride Sub Update ( _
    pUpdatedRect As Rectangle _
)
public:
virtual void Update(
    Rectangle pUpdatedRect
) abstract
Parameters
pUpdatedRect(Rectangle)


UserGiContext Property

UserGiContext Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »UserGiContext
Declaration Syntax
C# Visual Basic Visual C++
public abstract Context UserGiContext { get; set; }
Public MustOverride Property UserGiContext As Context
    Get
    Set
public:
virtual property Context^ UserGiContext {
    Context^ get () abstract;
    void set (Context^ value) abstract;
}


ViewAt Method (viewIndex)

ViewAt Method (viewIndex)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »ViewAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public abstract View ViewAt(
    int viewIndex
)
Public MustOverride Function ViewAt ( _
    viewIndex As Integer _
) As View
public:
virtual View^ ViewAt(
    int viewIndex
) abstract
Parameters
viewIndex(Int32)


DrawableDescFlags Enumeration

DrawableDescFlags Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »DrawableDescFlags
Declaration Syntax
C# Visual Basic Visual C++
[MiscellaneousBitsAttribute()]
[DebugInfoInPDBAttribute]
[CLSCompliantAttribute(false)]
public enum DrawableDescFlags
<MiscellaneousBitsAttribute()> _
<DebugInfoInPDBAttribute> _
<CLSCompliantAttribute(False)> _
Public Enumeration DrawableDescFlags
[MiscellaneousBitsAttribute()]
[DebugInfoInPDBAttribute]
[CLSCompliantAttribute(false)]
public enum class DrawableDescFlags


GsToBeUnloadedEventHandler Delegate

GsToBeUnloadedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »GsToBeUnloadedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void GsToBeUnloadedEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub GsToBeUnloadedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
public delegate void GsToBeUnloadedEventHandler(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender(Object)
e(EventArgs)

Assembly: ZwManaged (Module: ZwManaged)


ImpDevice Class

ImpDevice Class
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice
Declaration Syntax
C# Visual Basic Visual C++
public class ImpDevice : Device
Public Class ImpDevice _
    Inherits Device
public ref class ImpDevice : public Device
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImpDevice(IntPtr, Boolean) |
 | Add(View) | (Overrides Device.Add(View).)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackgroundColor | (Overrides Device.BackgroundColor.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateModel()()()() | (Overrides Device.CreateModel()()()().)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateView(ClientViewInfo, Boolean) | (Overrides Device.CreateView(ClientViewInfo, Boolean).)
 | CreateView(ClientViewInfo) | (Overrides Device.CreateView(ClientViewInfo).)
 | CreateView()()()() | (Overrides Device.CreateView()()()().)
 | DeleteUnmanagedObject()()()() | (Inherited from Device.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Int32) | (Overrides Device.Erase(Int32).)
 | Erase(View) | (Overrides Device.Erase(View).)
 | EraseAll()()()() | (Overrides Device.EraseAll()()()().)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetUnmanagedObject()()()() | (Inherited from Device.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InsertView(Int32, View) | (Overrides Device.InsertView(Int32, View).)
 | Invalidate(Rectangle) | (Overrides Device.Invalidate(Rectangle).)
 | Invalidate()()()() | (Overrides Device.Invalidate()()()().)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsValid | (Overrides Device.IsValid.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumViews | (Overrides Device.NumViews.)
 | OnDisplayChange(Int32, Int32, Int32) | (Overrides Device.OnDisplayChange(Int32, Int32, Int32).)
 | OnRealizeBackgroundPalette()()()() | (Overrides Device.OnRealizeBackgroundPalette()()()().)
 | OnRealizeForegroundPalette()()()() | (Overrides Device.OnRealizeForegroundPalette()()()().)
 | OnSize(Extents2d) | (Overrides Device.OnSize(Extents2d).)
 | OnSize(Rectangle) | (Overrides Device.OnSize(Rectangle).)
 | OnSize(Size) | (Overrides Device.OnSize(Size).)
 | Properties | (Overrides Device.Properties.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SetLogicalPalette(array<Color>[]()[][]) | (Overrides Device.SetLogicalPalette(array<Color>[]()[][]).)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Update(Rectangle) | (Overrides Device.Update(Rectangle).)
 | Update()()()() | (Overrides Device.Update()()()().)
 | UserGiContext | (Overrides Device.UserGiContext.)
 | ViewAt(Int32) | (Overrides Device.ViewAt(Int32).)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Device
 |  |  |  |  | ImpDevice


ImpDevice Constructor (unmanagedPointer, autoDelete)

ImpDevice Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »ImpDevice(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal ImpDevice(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
ImpDevice(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Add Method (pView)

Add Method (pView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Add(View)
Declaration Syntax
C# Visual Basic Visual C++
public override void Add(
    View pView
)
Public Overrides Sub Add ( _
    pView As View _
)
public:
virtual void Add(
    View^ pView
) override
Parameters
pView(View)


BackgroundColor Property

BackgroundColor Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »BackgroundColor
Declaration Syntax
C# Visual Basic Visual C++
public override Color BackgroundColor { get; set; }
Public Overrides Property BackgroundColor As Color
    Get
    Set
public:
virtual property Color BackgroundColor {
    Color get () override;
    void set (Color value) override;
}


CreateModel Method

CreateModel Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »CreateModel()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override Model CreateModel()
Public Overrides Function CreateModel As Model
public:
virtual Model^ CreateModel() override


CreateView Method

CreateView Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »CreateView()()()()
Members
Icon | Member | Description
 | CreateView(ClientViewInfo, Boolean) | (Overrides Device.CreateView(ClientViewInfo, Boolean).)
 | CreateView(ClientViewInfo) | (Overrides Device.CreateView(ClientViewInfo).)
 | CreateView()()()() | (Overrides Device.CreateView()()()().)


CreateView Method

CreateView Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »CreateView()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override View CreateView()
Public Overrides Function CreateView As View
public:
virtual View^ CreateView() override


CreateView Method (pViewInfo)

CreateView Method (pViewInfo)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »CreateView(ClientViewInfo)
Declaration Syntax
C# Visual Basic Visual C++
public override View CreateView(
    ClientViewInfo pViewInfo
)
Public Overrides Function CreateView ( _
    pViewInfo As ClientViewInfo _
) As View
public:
virtual View^ CreateView(
    ClientViewInfo pViewInfo
) override
Parameters
pViewInfo(ClientViewInfo)


CreateView Method (pViewInfo, enableLayerVisibilityPerView)

CreateView Method (pViewInfo, enableLayerVisibilityPerView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »CreateView(ClientViewInfo, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public override View CreateView(
    ClientViewInfo pViewInfo,
    bool enableLayerVisibilityPerView
)
Public Overrides Function CreateView ( _
    pViewInfo As ClientViewInfo, _
    enableLayerVisibilityPerView As Boolean _
) As View
public:
virtual View^ CreateView(
    ClientViewInfo pViewInfo,
    bool enableLayerVisibilityPerView
) override
Parameters
pViewInfo(ClientViewInfo)
enableLayerVisibilityPerView(Boolean)


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Erase()()()()
Members
Icon | Member | Description
 | Erase(Int32) | (Overrides Device.Erase(Int32).)
 | Erase(View) | (Overrides Device.Erase(View).)


Erase Method (viewIndex)

Erase Method (viewIndex)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Erase(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public override bool Erase(
    int viewIndex
)
Public Overrides Function Erase ( _
    viewIndex As Integer _
) As Boolean
public:
virtual bool Erase(
    int viewIndex
) override
Parameters
viewIndex(Int32)


Erase Method (pView)

Erase Method (pView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Erase(View)
Declaration Syntax
C# Visual Basic Visual C++
public override bool Erase(
    View pView
)
Public Overrides Function Erase ( _
    pView As View _
) As Boolean
public:
virtual bool Erase(
    View^ pView
) override
Parameters
pView(View)


EraseAll Method

EraseAll Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »EraseAll()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void EraseAll()
Public Overrides Sub EraseAll
public:
virtual void EraseAll() override


InsertView Method (viewIndex, pView)

InsertView Method (viewIndex, pView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »InsertView(Int32, View)
Declaration Syntax
C# Visual Basic Visual C++
public override void InsertView(
    int viewIndex,
    View pView
)
Public Overrides Sub InsertView ( _
    viewIndex As Integer, _
    pView As View _
)
public:
virtual void InsertView(
    int viewIndex,
    View^ pView
) override
Parameters
viewIndex(Int32)
pView(View)


Invalidate Method

Invalidate Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Rectangle) | (Overrides Device.Invalidate(Rectangle).)
 | Invalidate()()()() | (Overrides Device.Invalidate()()()().)


Invalidate Method

Invalidate Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Invalidate()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Invalidate()
Public Overrides Sub Invalidate
public:
virtual void Invalidate() override


Invalidate Method (screenRect)

Invalidate Method (screenRect)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Invalidate(Rectangle)
Declaration Syntax
C# Visual Basic Visual C++
public override void Invalidate(
    Rectangle screenRect
)
Public Overrides Sub Invalidate ( _
    screenRect As Rectangle _
)
public:
virtual void Invalidate(
    Rectangle screenRect
) override
Parameters
screenRect(Rectangle)


IsValid Property

IsValid Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »IsValid
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsValid { get; }
Public Overrides ReadOnly Property IsValid As Boolean
    Get
public:
virtual property bool IsValid {
    bool get () override;
}


NumViews Property

NumViews Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »NumViews
Declaration Syntax
C# Visual Basic Visual C++
public override int NumViews { get; }
Public Overrides ReadOnly Property NumViews As Integer
    Get
public:
virtual property int NumViews {
    int get () override;
}


OnDisplayChange Method (bitsPerPixel, xPixels, yPixels)

OnDisplayChange Method (bitsPerPixel, xPixels, yPixels)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »OnDisplayChange(Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public override void OnDisplayChange(
    int bitsPerPixel,
    int xPixels,
    int yPixels
)
Public Overrides Sub OnDisplayChange ( _
    bitsPerPixel As Integer, _
    xPixels As Integer, _
    yPixels As Integer _
)
public:
virtual void OnDisplayChange(
    int bitsPerPixel,
    int xPixels,
    int yPixels
) override
Parameters
bitsPerPixel(Int32)
xPixels(Int32)
yPixels(Int32)


OnRealizeBackgroundPalette Method

OnRealizeBackgroundPalette Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »OnRealizeBackgroundPalette()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void OnRealizeBackgroundPalette()
Public Overrides Sub OnRealizeBackgroundPalette
public:
virtual void OnRealizeBackgroundPalette() override


OnRealizeForegroundPalette Method

OnRealizeForegroundPalette Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »OnRealizeForegroundPalette()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void OnRealizeForegroundPalette()
Public Overrides Sub OnRealizeForegroundPalette
public:
virtual void OnRealizeForegroundPalette() override


OnSize Method

OnSize Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »OnSize()()()()
Members
Icon | Member | Description
 | OnSize(Extents2d) | (Overrides Device.OnSize(Extents2d).)
 | OnSize(Rectangle) | (Overrides Device.OnSize(Rectangle).)
 | OnSize(Size) | (Overrides Device.OnSize(Size).)


OnSize Method (outputRect)

OnSize Method (outputRect)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »OnSize(Rectangle)
Declaration Syntax
C# Visual Basic Visual C++
public override void OnSize(
    Rectangle outputRect
)
Public Overrides Sub OnSize ( _
    outputRect As Rectangle _
)
public:
virtual void OnSize(
    Rectangle outputRect
) override
Parameters
outputRect(Rectangle)


OnSize Method (size)

OnSize Method (size)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »OnSize(Size)
Declaration Syntax
C# Visual Basic Visual C++
public override void OnSize(
    Size size
)
Public Overrides Sub OnSize ( _
    size As Size _
)
public:
virtual void OnSize(
    Size size
) override
Parameters
size(Size)


OnSize Method (outputRect)

OnSize Method (outputRect)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »OnSize(Extents2d)
Declaration Syntax
C# Visual Basic Visual C++
public override void OnSize(
    Extents2d outputRect
)
Public Overrides Sub OnSize ( _
    outputRect As Extents2d _
)
public:
virtual void OnSize(
    Extents2d outputRect
) override
Parameters
outputRect(Extents2d)


Properties Property

Properties Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Properties
Declaration Syntax
C# Visual Basic Visual C++
public override Dictionary Properties { get; }
Public Overrides ReadOnly Property Properties As Dictionary
    Get
public:
virtual property Dictionary^ Properties {
    Dictionary^ get () override;
}


SetLogicalPalette Method (logicalPalette)

SetLogicalPalette Method (logicalPalette)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »SetLogicalPalette(array<Color>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public override void SetLogicalPalette(
    Color[] logicalPalette
)
Public Overrides Sub SetLogicalPalette ( _
    logicalPalette As Color() _
)
public:
virtual void SetLogicalPalette(
    array<Color>^ logicalPalette
) override
Parameters
logicalPalette(array<Color>[]()[][])


Update Method

Update Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Update()()()()
Members
Icon | Member | Description
 | Update(Rectangle) | (Overrides Device.Update(Rectangle).)
 | Update()()()() | (Overrides Device.Update()()()().)


Update Method

Update Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Update()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Update()
Public Overrides Sub Update
public:
virtual void Update() override


Update Method (pUpdatedRect)

Update Method (pUpdatedRect)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Update(Rectangle)
Declaration Syntax
C# Visual Basic Visual C++
public override void Update(
    Rectangle pUpdatedRect
)
Public Overrides Sub Update ( _
    pUpdatedRect As Rectangle _
)
public:
virtual void Update(
    Rectangle pUpdatedRect
) override
Parameters
pUpdatedRect(Rectangle)


UserGiContext Property

UserGiContext Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »UserGiContext
Declaration Syntax
C# Visual Basic Visual C++
public override Context UserGiContext { get; set; }
Public Overrides Property UserGiContext As Context
    Get
    Set
public:
virtual property Context^ UserGiContext {
    Context^ get () override;
    void set (Context^ value) override;
}


ViewAt Method (viewIndex)

ViewAt Method (viewIndex)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »ViewAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public override View ViewAt(
    int viewIndex
)
Public Overrides Function ViewAt ( _
    viewIndex As Integer _
) As View
public:
virtual View^ ViewAt(
    int viewIndex
) override
Parameters
viewIndex(Int32)


InvalidationHint Enumeration

InvalidationHint Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »InvalidationHint
Declaration Syntax
C# Visual Basic Visual C++
public enum InvalidationHint
Public Enumeration InvalidationHint
public enum class InvalidationHint
Members
Member | Description
kInvalidateMaterials |
kInvalidateAll |
kInvalidateViewportCache |
kInvalidateIsolines |


Manager Class

Manager Class
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcGsManager")]
public class Manager : DisposableWrapper
<WrapperAttribute("AcGsManager")> _
Public Class Manager _
    Inherits DisposableWrapper
[WrapperAttribute(L"AcGsManager")]
public ref class Manager : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Manager(IntPtr) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | ConfigWasModified |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateZWCADDevice(IntPtr) |
 | CreateZWCADModel()()()() |
 | CreateZWCADOffScreenDevice()()()() |
 | CreateZWCADView(Drawable) |
 | CreateZWCADViewport(ViewportTableRecord) |
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | DisplaySize |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetDBModel()()()() |
 | GetGsView(Int32, Boolean) |
 | GetGUIDevice()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | GsToBeUnloaded |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetViewFromViewport(View, Int32) |
 | SetViewportFromView(Int32, View, Boolean, Boolean, Boolean) |
 | SetViewportFromView(Int32, View) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | ViewToBeDestroyed |
 | ViewWasCreated |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Manager

Assembly: ZwManaged (Module: ZwManaged)


Manager Constructor (unmanagedPointer)

Manager Constructor (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »Manager(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Manager(
    IntPtr unmanagedPointer
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr _
)
protected public:
Manager(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


ConfigWasModified Event

ConfigWasModified Event
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »ConfigWasModified
Declaration Syntax
C# Visual Basic Visual C++
public event ConfigWasModifiedEventHandler ConfigWasModified
Public Event ConfigWasModified As ConfigWasModifiedEventHandler
public:
 event ConfigWasModifiedEventHandler^ ConfigWasModified {
    void add (ConfigWasModifiedEventHandler^ value);
    void remove (ConfigWasModifiedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


CreateZWCADDevice Method (hwnd)

CreateZWCADDevice Method (hwnd)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »CreateZWCADDevice(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public Device CreateZWCADDevice(
    IntPtr hwnd
)
Public Function CreateZWCADDevice ( _
    hwnd As IntPtr _
) As Device
public:
Device^ CreateZWCADDevice(
    IntPtr hwnd
)
Parameters
hwnd(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


CreateZWCADModel Method

CreateZWCADModel Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »CreateZWCADModel()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Model CreateZWCADModel()
Public Function CreateZWCADModel As Model
public:
Model^ CreateZWCADModel()

Assembly: ZwManaged (Module: ZwManaged)


CreateZWCADOffScreenDevice Method

CreateZWCADOffScreenDevice Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »CreateZWCADOffScreenDevice()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Device CreateZWCADOffScreenDevice()
Public Function CreateZWCADOffScreenDevice As Device
public:
Device^ CreateZWCADOffScreenDevice()

Assembly: ZwManaged (Module: ZwManaged)


CreateZWCADView Method (drawable)

CreateZWCADView Method (drawable)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »CreateZWCADView(Drawable)
Declaration Syntax
C# Visual Basic Visual C++
public View CreateZWCADView(
    Drawable drawable
)
Public Function CreateZWCADView ( _
    drawable As Drawable _
) As View
public:
View^ CreateZWCADView(
    Drawable^ drawable
)
Parameters
drawable(Drawable)

Assembly: ZwManaged (Module: ZwManaged)


CreateZWCADViewport Method (vp)

CreateZWCADViewport Method (vp)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »CreateZWCADViewport(ViewportTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public View CreateZWCADViewport(
    ViewportTableRecord vp
)
Public Function CreateZWCADViewport ( _
    vp As ViewportTableRecord _
) As View
public:
View^ CreateZWCADViewport(
    ViewportTableRecord^ vp
)
Parameters
vp(ViewportTableRecord)

Assembly: ZwManaged (Module: ZwManaged)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override

Assembly: ZwManaged (Module: ZwManaged)


DisplaySize Property

DisplaySize Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »DisplaySize
Declaration Syntax
C# Visual Basic Visual C++
public Size DisplaySize { get; }
Public ReadOnly Property DisplaySize As Size
    Get
public:
property Size DisplaySize {
    Size get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GetDBModel Method

GetDBModel Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »GetDBModel()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Model GetDBModel()
Public Function GetDBModel As Model
public:
Model^ GetDBModel()

Assembly: ZwManaged (Module: ZwManaged)


GetGsView Method (viewportNumber, createIfNone)

GetGsView Method (viewportNumber, createIfNone)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »GetGsView(Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public View GetGsView(
    int viewportNumber,
    bool createIfNone
)
Public Function GetGsView ( _
    viewportNumber As Integer, _
    createIfNone As Boolean _
) As View
public:
View^ GetGsView(
    int viewportNumber,
    bool createIfNone
)
Parameters
viewportNumber(Int32)
createIfNone(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


GetGUIDevice Method

GetGUIDevice Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »GetGUIDevice()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Device GetGUIDevice()
Public Function GetGUIDevice As Device
public:
Device^ GetGUIDevice()

Assembly: ZwManaged (Module: ZwManaged)


GsToBeUnloaded Event

GsToBeUnloaded Event
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »GsToBeUnloaded
Declaration Syntax
C# Visual Basic Visual C++
public event GsToBeUnloadedEventHandler GsToBeUnloaded
Public Event GsToBeUnloaded As GsToBeUnloadedEventHandler
public:
 event GsToBeUnloadedEventHandler^ GsToBeUnloaded {
    void add (GsToBeUnloadedEventHandler^ value);
    void remove (GsToBeUnloadedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


SetViewFromViewport Method (view, viewportNumber)

SetViewFromViewport Method (view, viewportNumber)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »SetViewFromViewport(View, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void SetViewFromViewport(
    View view,
    int viewportNumber
)
Public Sub SetViewFromViewport ( _
    view As View, _
    viewportNumber As Integer _
)
public:
void SetViewFromViewport(
    View^ view,
    int viewportNumber
)
Parameters
view(View)
viewportNumber(Int32)

Assembly: ZwManaged (Module: ZwManaged)


SetViewportFromView Method

SetViewportFromView Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »SetViewportFromView()()()()
Members
Icon | Member | Description
 | SetViewportFromView(Int32, View, Boolean, Boolean, Boolean) |
 | SetViewportFromView(Int32, View) |

Assembly: ZwManaged (Module: ZwManaged)


SetViewportFromView Method (viewportNumber, view)

SetViewportFromView Method (viewportNumber, view)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »SetViewportFromView(Int32, View)
Declaration Syntax
C# Visual Basic Visual C++
public void SetViewportFromView(
    int viewportNumber,
    View view
)
Public Sub SetViewportFromView ( _
    viewportNumber As Integer, _
    view As View _
)
public:
void SetViewportFromView(
    int viewportNumber,
    View^ view
)
Parameters
viewportNumber(Int32)
view(View)

Assembly: ZwManaged (Module: ZwManaged)


SetViewportFromView Method (viewportNumber, view, regenRequired, rescaleRequired, syncRequired)

SetViewportFromView Method (viewportNumber, view, regenRequired, rescaleRequired, syncRequired)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »SetViewportFromView(Int32, View, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetViewportFromView(
    int viewportNumber,
    View view,
    bool regenRequired,
    bool rescaleRequired,
    bool syncRequired
)
Public Sub SetViewportFromView ( _
    viewportNumber As Integer, _
    view As View, _
    regenRequired As Boolean, _
    rescaleRequired As Boolean, _
    syncRequired As Boolean _
)
public:
void SetViewportFromView(
    int viewportNumber,
    View^ view,
    bool regenRequired,
    bool rescaleRequired,
    bool syncRequired
)
Parameters
viewportNumber(Int32)
view(View)
regenRequired(Boolean)
rescaleRequired(Boolean)
syncRequired(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


ViewToBeDestroyed Event

ViewToBeDestroyed Event
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »ViewToBeDestroyed
Declaration Syntax
C# Visual Basic Visual C++
public event ViewToBeDestroyedEventHandler ViewToBeDestroyed
Public Event ViewToBeDestroyed As ViewToBeDestroyedEventHandler
public:
 event ViewToBeDestroyedEventHandler^ ViewToBeDestroyed {
    void add (ViewToBeDestroyedEventHandler^ value);
    void remove (ViewToBeDestroyedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


ViewWasCreated Event

ViewWasCreated Event
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »ViewWasCreated
Declaration Syntax
C# Visual Basic Visual C++
public event ViewWasCreatedEventHandler ViewWasCreated
Public Event ViewWasCreated As ViewWasCreatedEventHandler
public:
 event ViewWasCreatedEventHandler^ ViewWasCreated {
    void add (ViewWasCreatedEventHandler^ value);
    void remove (ViewWasCreatedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Model Class

Model Class
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model
Declaration Syntax
C# Visual Basic Visual C++
public class Model : RXObject
Public Class Model _
    Inherits RXObject
public ref class Model : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Model(IntPtr, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Background |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Invalidate(View) |
 | Invalidate(InvalidationHint) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnAdded(Drawable, Int32) |
 | OnAdded(Drawable, Drawable) |
 | OnErased(Drawable, Int32) |
 | OnErased(Drawable, Drawable) |
 | OnModified(Drawable, Int32) |
 | OnModified(Drawable, Drawable) |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RenderModeOverride |
 | ToString()()()() | (Inherited from Object.)
 | Transform |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | VisualStyle |
 | VisualStyleId |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Model


Model Constructor (unmanagedPointer, autoDelete)

Model Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »Model(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Model(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Model(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Background Property

Background Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »Background
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Background { get; set; }
Public Property Background As ObjectId
    Get
    Set
public:
property ObjectId Background {
    ObjectId get ();
    void set (ObjectId value);
}


Invalidate Method

Invalidate Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(View) |
 | Invalidate(InvalidationHint) |


Invalidate Method (hint)

Invalidate Method (hint)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »Invalidate(InvalidationHint)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Invalidate(
    InvalidationHint hint
)
Public Overridable Sub Invalidate ( _
    hint As InvalidationHint _
)
public:
virtual void Invalidate(
    InvalidationHint hint
)
Parameters
hint(InvalidationHint)


Invalidate Method (pView)

Invalidate Method (pView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »Invalidate(View)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Invalidate(
    View pView
)
Public Overridable Sub Invalidate ( _
    pView As View _
)
public:
virtual void Invalidate(
    View^ pView
)
Parameters
pView(View)


OnAdded Method

OnAdded Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »OnAdded()()()()
Members
Icon | Member | Description
 | OnAdded(Drawable, Int32) |
 | OnAdded(Drawable, Drawable) |


OnAdded Method (pAdded, parentID)

OnAdded Method (pAdded, parentID)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »OnAdded(Drawable, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OnAdded(
    Drawable pAdded,
    int parentID
)
Public Overridable Sub OnAdded ( _
    pAdded As Drawable, _
    parentID As Integer _
)
public:
virtual void OnAdded(
    Drawable^ pAdded,
    int parentID
)
Parameters
pAdded(Drawable)
parentID(Int32)


OnAdded Method (pAdded, pParent)

OnAdded Method (pAdded, pParent)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »OnAdded(Drawable, Drawable)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OnAdded(
    Drawable pAdded,
    Drawable pParent
)
Public Overridable Sub OnAdded ( _
    pAdded As Drawable, _
    pParent As Drawable _
)
public:
virtual void OnAdded(
    Drawable^ pAdded,
    Drawable^ pParent
)
Parameters
pAdded(Drawable)
pParent(Drawable)


OnErased Method

OnErased Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »OnErased()()()()
Members
Icon | Member | Description
 | OnErased(Drawable, Int32) |
 | OnErased(Drawable, Drawable) |


OnErased Method (pErased, parentID)

OnErased Method (pErased, parentID)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »OnErased(Drawable, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OnErased(
    Drawable pErased,
    int parentID
)
Public Overridable Sub OnErased ( _
    pErased As Drawable, _
    parentID As Integer _
)
public:
virtual void OnErased(
    Drawable^ pErased,
    int parentID
)
Parameters
pErased(Drawable)
parentID(Int32)


OnErased Method (pErased, pParent)

OnErased Method (pErased, pParent)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »OnErased(Drawable, Drawable)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OnErased(
    Drawable pErased,
    Drawable pParent
)
Public Overridable Sub OnErased ( _
    pErased As Drawable, _
    pParent As Drawable _
)
public:
virtual void OnErased(
    Drawable^ pErased,
    Drawable^ pParent
)
Parameters
pErased(Drawable)
pParent(Drawable)


OnModified Method

OnModified Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »OnModified()()()()
Members
Icon | Member | Description
 | OnModified(Drawable, Int32) |
 | OnModified(Drawable, Drawable) |


OnModified Method (pModified, parentID)

OnModified Method (pModified, parentID)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »OnModified(Drawable, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OnModified(
    Drawable pModified,
    int parentID
)
Public Overridable Sub OnModified ( _
    pModified As Drawable, _
    parentID As Integer _
)
public:
virtual void OnModified(
    Drawable^ pModified,
    int parentID
)
Parameters
pModified(Drawable)
parentID(Int32)


OnModified Method (pModified, pParent)

OnModified Method (pModified, pParent)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »OnModified(Drawable, Drawable)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OnModified(
    Drawable pModified,
    Drawable pParent
)
Public Overridable Sub OnModified ( _
    pModified As Drawable, _
    pParent As Drawable _
)
public:
virtual void OnModified(
    Drawable^ pModified,
    Drawable^ pParent
)
Parameters
pModified(Drawable)
pParent(Drawable)


RenderModeOverride Property

RenderModeOverride Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »RenderModeOverride
Declaration Syntax
C# Visual Basic Visual C++
public RenderMode RenderModeOverride { set; }
Public WriteOnly Property RenderModeOverride As RenderMode
    Set
public:
property RenderMode RenderModeOverride {
    void set (RenderMode value);
}


Transform Property

Transform Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »Transform
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d Transform { get; set; }
Public Property Transform As Matrix3d
    Get
    Set
public:
property Matrix3d Transform {
    Matrix3d get ();
    void set (Matrix3d value);
}


VisualStyle Property

VisualStyle Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »VisualStyle
Declaration Syntax
C# Visual Basic Visual C++
public VisualStyle VisualStyle { get; set; }
Public Property VisualStyle As VisualStyle
    Get
    Set
public:
property VisualStyle^ VisualStyle {
    VisualStyle^ get ();
    void set (VisualStyle^ value);
}


VisualStyleId Property

VisualStyleId Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »VisualStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId VisualStyleId { get; set; }
Public Property VisualStyleId As ObjectId
    Get
    Set
public:
property ObjectId VisualStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


Projection Enumeration

Projection Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Projection
Declaration Syntax
C# Visual Basic Visual C++
public enum Projection
Public Enumeration Projection
public enum class Projection
Members
Member | Description
Perspective |
Parallel |


RenderMode Enumeration

RenderMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »RenderMode
Declaration Syntax
C# Visual Basic Visual C++
public enum RenderMode
Public Enumeration RenderMode
public enum class RenderMode
Members
Member | Description
BoundingBox |
GouraudShadedWithWireframe |
FlatShadedWithWireframe |
GouraudShaded |
FlatShaded |
HiddenLine |
Wireframe |
Optimized2D |
None |


RenderType Enumeration

RenderType Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »RenderType
Declaration Syntax
C# Visual Basic Visual C++
public enum RenderType
Public Enumeration RenderType
public enum class RenderType
Members
Member | Description
HighlightSelection |
Highlight |
Direct |
Sprite |
Main |
Count |


SelectionMode Enumeration

SelectionMode Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »SelectionMode
Declaration Syntax
C# Visual Basic Visual C++
public enum SelectionMode
Public Enumeration SelectionMode
public enum class SelectionMode
Members
Member | Description
CPoly |
WPoly |
Fence |
Crossing |
Window |


StereoParameters Structure

StereoParameters Structure
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »StereoParameters
Declaration Syntax
C# Visual Basic Visual C++
public struct StereoParameters
Public Structure StereoParameters
public value class StereoParameters
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StereoParameters(Double, Double) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | Magnitude |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Parallax |
 | ToString()()()() | (Inherited from ValueType.)


StereoParameters Constructor (magnitude, parallax)

StereoParameters Constructor (magnitude, parallax)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »StereoParameters »StereoParameters(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public StereoParameters(
    double magnitude,
    double parallax
)
Public Sub New ( _
    magnitude As Double, _
    parallax As Double _
)
public:
StereoParameters(
    double magnitude,
    double parallax
)
Parameters
magnitude(Double)
parallax(Double)


Magnitude Property

Magnitude Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »StereoParameters »Magnitude
Declaration Syntax
C# Visual Basic Visual C++
public double Magnitude { get; }
Public ReadOnly Property Magnitude As Double
    Get
public:
property double Magnitude {
    double get ();
}


Parallax Property

Parallax Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »StereoParameters »Parallax
Declaration Syntax
C# Visual Basic Visual C++
public double Parallax { get; }
Public ReadOnly Property Parallax As Double
    Get
public:
property double Parallax {
    double get ();
}


View Class

View Class
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcGsView")]
public class View : DisposableWrapper
<WrapperAttribute("AcGsView")> _
Public Class View _
    Inherits DisposableWrapper
[WrapperAttribute(L"AcGsView")]
public ref class View : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | View(ClientViewInfo, Boolean) |
 | View()()()() |
 | View(IntPtr, Boolean, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BackClip |
 | BackgroundId |
 | BeginInteractivity(Double) |
 | ClearFrozenLayers()()()() |
 | Clone(Boolean, Boolean) |
 | Clone()()()() |
 | Create(IntPtr, Boolean, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Dolly(Double, Double, Double) |
 | Dolly(Vector3d) |
 | EnableBackClip |
 | EnableDefaultLighting(Boolean, DefaultLightingType) |
 | EnableDefaultLighting(Boolean) |
 | EnableFrontClip |
 | EnableStereo |
 | EndInteractivity()()()() |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Erase(Drawable) |
 | EraseAll()()()() |
 | ExceededBounds |
 | ExtentsInView(Point3d, Point3d) |
 | FieldHeight |
 | FieldWidth |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | Flush()()()() |
 | FreezeLayer(IntPtr) |
 | FrontClip |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNumPixelsInUnitSquare(Point3d, Boolean) |
 | GetNumPixelsInUnitSquare(Point3d) |
 | GetSnapshot(Rectangle) |
 | GetType()()()() | (Inherited from Object.)
 | Hide()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Invalidate(Rectangle) |
 | Invalidate()()()() |
 | InvalidateCachedViewportGeometry()()()() |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsInteractive |
 | IsPerspective |
 | IsValid |
 | IsVisible |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mode |
 | ObjectToDeviceMatrix |
 | Orbit(Double, Double) |
 | Pan(Double, Double) |
 | PointInView(Point3d) |
 | Position |
 | ProjectionMatrix |
 | RemoveViewportClipRegion()()()() |
 | RenderToImage(Drawable, Rectangle) |
 | RenderToImage()()()() |
 | Roll(Double) |
 | ScreenMatrix |
 | SetView(Point3d, Point3d, Vector3d, Double, Double, Projection) |
 | SetView(Point3d, Point3d, Vector3d, Double, Double) |
 | SetViewportClipRegion(Int32, array<Int32>[]()[][], array<Point>[]()[][]) |
 | Show()()()() |
 | StereoParameters |
 | Target |
 | ThawLayer(IntPtr) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Update()()()() |
 | UpVector |
 | ViewingMatrix |
 | Viewport |
 | ViewportBorderProperties |
 | ViewportBorderVisibility |
 | VisualStyleId |
 | WorldToDeviceMatrix |
 | Zoom(Double) |
 | ZoomExtents(Point3d, Point3d) |
 | ZoomWindow(Point2d, Point2d) |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | View


View Constructor

View Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »View()()()()
Members
Icon | Member | Description
 | View(ClientViewInfo, Boolean) |
 | View()()()() |
 | View(IntPtr, Boolean, Boolean) |


View Constructor

View Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »View()()()()
Declaration Syntax
C# Visual Basic Visual C++
public View()
Public Sub New
public:
View()


View Constructor (unmanagedPointer, autoDelete, zwcadView)

View Constructor (unmanagedPointer, autoDelete, zwcadView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »View(IntPtr, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal View(
    IntPtr unmanagedPointer,
    bool autoDelete,
    bool zwcadView
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean, _
    zwcadView As Boolean _
)
protected public:
View(
    IntPtr unmanagedPointer,
    bool autoDelete,
    bool zwcadView
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)
zwcadView(Boolean)


View Constructor (clientViewInfo, enableLayerVisibilityPerView)

View Constructor (clientViewInfo, enableLayerVisibilityPerView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »View(ClientViewInfo, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public View(
    ClientViewInfo clientViewInfo,
    bool enableLayerVisibilityPerView
)
Public Sub New ( _
    clientViewInfo As ClientViewInfo, _
    enableLayerVisibilityPerView As Boolean _
)
public:
View(
    ClientViewInfo clientViewInfo,
    bool enableLayerVisibilityPerView
)
Parameters
clientViewInfo(ClientViewInfo)
enableLayerVisibilityPerView(Boolean)


BackClip Property

BackClip Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »BackClip
Declaration Syntax
C# Visual Basic Visual C++
public double BackClip { get; set; }
Public Property BackClip As Double
    Get
    Set
public:
property double BackClip {
    double get ();
    void set (double value);
}


BackgroundId Property

BackgroundId Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »BackgroundId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId BackgroundId { get; set; }
Public Property BackgroundId As ObjectId
    Get
    Set
public:
property ObjectId BackgroundId {
    ObjectId get ();
    void set (ObjectId value);
}


BeginInteractivity Method (frameRateInHZ)

BeginInteractivity Method (frameRateInHZ)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »BeginInteractivity(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void BeginInteractivity(
    double frameRateInHZ
)
Public Sub BeginInteractivity ( _
    frameRateInHZ As Double _
)
public:
void BeginInteractivity(
    double frameRateInHZ
)
Parameters
frameRateInHZ(Double)


ClearFrozenLayers Method

ClearFrozenLayers Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ClearFrozenLayers()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void ClearFrozenLayers()
Public Sub ClearFrozenLayers
public:
void ClearFrozenLayers()


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Clone()()()()
Members
Icon | Member | Description
 | Clone(Boolean, Boolean) |
 | Clone()()()() |


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public View Clone()
Public Function Clone As View
public:
View^ Clone()


Clone Method (cloneViewParameters, cloneGeometry)

Clone Method (cloneViewParameters, cloneGeometry)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Clone(Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public View Clone(
    bool cloneViewParameters,
    bool cloneGeometry
)
Public Function Clone ( _
    cloneViewParameters As Boolean, _
    cloneGeometry As Boolean _
) As View
public:
View^ Clone(
    bool cloneViewParameters,
    bool cloneGeometry
)
Parameters
cloneViewParameters(Boolean)
cloneGeometry(Boolean)


Create Method (unmanagedPointer, autoDelete, autoCADView)

Create Method (unmanagedPointer, autoDelete, autoCADView)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Create(IntPtr, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static View Create(
    IntPtr unmanagedPointer,
    bool autoDelete,
    bool autoCADView
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean, _
    autoCADView As Boolean _
) As View
public:
static View^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete,
    bool autoCADView
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)
autoCADView(Boolean)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


Dolly Method

Dolly Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Dolly()()()()
Members
Icon | Member | Description
 | Dolly(Double, Double, Double) |
 | Dolly(Vector3d) |


Dolly Method (x, y, z)

Dolly Method (x, y, z)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Dolly(Double, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Dolly(
    double x,
    double y,
    double z
)
Public Sub Dolly ( _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
void Dolly(
    double x,
    double y,
    double z
)
Parameters
x(Double)
y(Double)
z(Double)


Dolly Method (vector)

Dolly Method (vector)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Dolly(Vector3d)
Declaration Syntax
C# Visual Basic Visual C++
public void Dolly(
    Vector3d vector
)
Public Sub Dolly ( _
    vector As Vector3d _
)
public:
void Dolly(
    Vector3d vector
)
Parameters
vector(Vector3d)


EnableBackClip Property

EnableBackClip Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »EnableBackClip
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableBackClip { get; set; }
Public Property EnableBackClip As Boolean
    Get
    Set
public:
property bool EnableBackClip {
    bool get ();
    void set (bool value);
}


EnableDefaultLighting Method

EnableDefaultLighting Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »EnableDefaultLighting()()()()
Members
Icon | Member | Description
 | EnableDefaultLighting(Boolean, DefaultLightingType) |
 | EnableDefaultLighting(Boolean) |


EnableDefaultLighting Method (bEnable)

EnableDefaultLighting Method (bEnable)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »EnableDefaultLighting(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void EnableDefaultLighting(
    bool bEnable
)
Public Sub EnableDefaultLighting ( _
    bEnable As Boolean _
)
public:
void EnableDefaultLighting(
    bool bEnable
)
Parameters
bEnable(Boolean)


EnableDefaultLighting Method (bEnable, type)

EnableDefaultLighting Method (bEnable, type)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »EnableDefaultLighting(Boolean, DefaultLightingType)
Declaration Syntax
C# Visual Basic Visual C++
public void EnableDefaultLighting(
    bool bEnable,
    DefaultLightingType type
)
Public Sub EnableDefaultLighting ( _
    bEnable As Boolean, _
    type As DefaultLightingType _
)
public:
void EnableDefaultLighting(
    bool bEnable,
    DefaultLightingType type
)
Parameters
bEnable(Boolean)
type(DefaultLightingType)


EnableFrontClip Property

EnableFrontClip Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »EnableFrontClip
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableFrontClip { get; set; }
Public Property EnableFrontClip As Boolean
    Get
    Set
public:
property bool EnableFrontClip {
    bool get ();
    void set (bool value);
}


EnableStereo Property

EnableStereo Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »EnableStereo
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableStereo { get; set; }
Public Property EnableStereo As Boolean
    Get
    Set
public:
property bool EnableStereo {
    bool get ();
    void set (bool value);
}


EndInteractivity Method

EndInteractivity Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »EndInteractivity()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void EndInteractivity()
Public Sub EndInteractivity
public:
void EndInteractivity()


Erase Method (drawable)

Erase Method (drawable)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Erase(Drawable)
Declaration Syntax
C# Visual Basic Visual C++
public bool Erase(
    Drawable drawable
)
Public Function Erase ( _
    drawable As Drawable _
) As Boolean
public:
bool Erase(
    Drawable^ drawable
)
Parameters
drawable(Drawable)


EraseAll Method

EraseAll Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »EraseAll()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void EraseAll()
Public Sub EraseAll
public:
void EraseAll()


ExceededBounds Property

ExceededBounds Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ExceededBounds
Declaration Syntax
C# Visual Basic Visual C++
public bool ExceededBounds { get; }
Public ReadOnly Property ExceededBounds As Boolean
    Get
public:
property bool ExceededBounds {
    bool get ();
}


ExtentsInView Method (minPoint, maxPoint)

ExtentsInView Method (minPoint, maxPoint)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ExtentsInView(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool ExtentsInView(
    Point3d minPoint,
    Point3d maxPoint
)
Public Function ExtentsInView ( _
    minPoint As Point3d, _
    maxPoint As Point3d _
) As Boolean
public:
bool ExtentsInView(
    Point3d minPoint,
    Point3d maxPoint
)
Parameters
minPoint(Point3d)
maxPoint(Point3d)


FieldHeight Property

FieldHeight Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »FieldHeight
Declaration Syntax
C# Visual Basic Visual C++
public double FieldHeight { get; }
Public ReadOnly Property FieldHeight As Double
    Get
public:
property double FieldHeight {
    double get ();
}


FieldWidth Property

FieldWidth Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »FieldWidth
Declaration Syntax
C# Visual Basic Visual C++
public double FieldWidth { get; }
Public ReadOnly Property FieldWidth As Double
    Get
public:
property double FieldWidth {
    double get ();
}


Flush Method

Flush Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Flush()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Flush()
Public Sub Flush
public:
void Flush()


FreezeLayer Method (layerId)

FreezeLayer Method (layerId)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »FreezeLayer(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void FreezeLayer(
    IntPtr layerId
)
Public Sub FreezeLayer ( _
    layerId As IntPtr _
)
public:
void FreezeLayer(
    IntPtr layerId
)
Parameters
layerId(IntPtr)


FrontClip Property

FrontClip Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »FrontClip
Declaration Syntax
C# Visual Basic Visual C++
public double FrontClip { get; set; }
Public Property FrontClip As Double
    Get
    Set
public:
property double FrontClip {
    double get ();
    void set (double value);
}


GetNumPixelsInUnitSquare Method

GetNumPixelsInUnitSquare Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »GetNumPixelsInUnitSquare()()()()
Members
Icon | Member | Description
 | GetNumPixelsInUnitSquare(Point3d, Boolean) |
 | GetNumPixelsInUnitSquare(Point3d) |


GetNumPixelsInUnitSquare Method (givenWorldpt)

GetNumPixelsInUnitSquare Method (givenWorldpt)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »GetNumPixelsInUnitSquare(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetNumPixelsInUnitSquare(
    Point3d givenWorldpt
)
Public Function GetNumPixelsInUnitSquare ( _
    givenWorldpt As Point3d _
) As Point2d
public:
Point2d GetNumPixelsInUnitSquare(
    Point3d givenWorldpt
)
Parameters
givenWorldpt(Point3d)


GetNumPixelsInUnitSquare Method (givenWorldpt, includePerspective)

GetNumPixelsInUnitSquare Method (givenWorldpt, includePerspective)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »GetNumPixelsInUnitSquare(Point3d, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Point2d GetNumPixelsInUnitSquare(
    Point3d givenWorldpt,
    bool includePerspective
)
Public Function GetNumPixelsInUnitSquare ( _
    givenWorldpt As Point3d, _
    includePerspective As Boolean _
) As Point2d
public:
Point2d GetNumPixelsInUnitSquare(
    Point3d givenWorldpt,
    bool includePerspective
)
Parameters
givenWorldpt(Point3d)
includePerspective(Boolean)


GetSnapshot Method (rectangle)

GetSnapshot Method (rectangle)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »GetSnapshot(Rectangle)
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap GetSnapshot(
    Rectangle rectangle
)
Public Function GetSnapshot ( _
    rectangle As Rectangle _
) As Bitmap
public:
Bitmap^ GetSnapshot(
    Rectangle rectangle
)
Parameters
rectangle(Rectangle)


Hide Method

Hide Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Hide()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Hide()
Public Sub Hide
public:
void Hide()


Invalidate Method

Invalidate Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Rectangle) |
 | Invalidate()()()() |


Invalidate Method

Invalidate Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Invalidate()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Invalidate()
Public Sub Invalidate
public:
void Invalidate()


Invalidate Method (rect)

Invalidate Method (rect)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Invalidate(Rectangle)
Declaration Syntax
C# Visual Basic Visual C++
public void Invalidate(
    Rectangle rect
)
Public Sub Invalidate ( _
    rect As Rectangle _
)
public:
void Invalidate(
    Rectangle rect
)
Parameters
rect(Rectangle)


InvalidateCachedViewportGeometry Method

InvalidateCachedViewportGeometry Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »InvalidateCachedViewportGeometry()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void InvalidateCachedViewportGeometry()
Public Sub InvalidateCachedViewportGeometry
public:
void InvalidateCachedViewportGeometry()


IsInteractive Property

IsInteractive Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »IsInteractive
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInteractive { get; }
Public ReadOnly Property IsInteractive As Boolean
    Get
public:
property bool IsInteractive {
    bool get ();
}


IsPerspective Property

IsPerspective Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »IsPerspective
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPerspective { get; }
Public ReadOnly Property IsPerspective As Boolean
    Get
public:
property bool IsPerspective {
    bool get ();
}


IsValid Property

IsValid Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »IsValid
Declaration Syntax
C# Visual Basic Visual C++
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}


IsVisible Property

IsVisible Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »IsVisible
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible { get; }
Public ReadOnly Property IsVisible As Boolean
    Get
public:
property bool IsVisible {
    bool get ();
}


Mode Property

Mode Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Mode
Declaration Syntax
C# Visual Basic Visual C++
public RenderMode Mode { get; set; }
Public Property Mode As RenderMode
    Get
    Set
public:
property RenderMode Mode {
    RenderMode get ();
    void set (RenderMode value);
}


ObjectToDeviceMatrix Property

ObjectToDeviceMatrix Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ObjectToDeviceMatrix
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d ObjectToDeviceMatrix { get; }
Public ReadOnly Property ObjectToDeviceMatrix As Matrix3d
    Get
public:
property Matrix3d ObjectToDeviceMatrix {
    Matrix3d get ();
}


Orbit Method (x, y)

Orbit Method (x, y)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Orbit(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Orbit(
    double x,
    double y
)
Public Sub Orbit ( _
    x As Double, _
    y As Double _
)
public:
void Orbit(
    double x,
    double y
)
Parameters
x(Double)
y(Double)


Pan Method (x, y)

Pan Method (x, y)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Pan(Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Pan(
    double x,
    double y
)
Public Sub Pan ( _
    x As Double, _
    y As Double _
)
public:
void Pan(
    double x,
    double y
)
Parameters
x(Double)
y(Double)


PointInView Method (point)

PointInView Method (point)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »PointInView(Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public bool PointInView(
    Point3d point
)
Public Function PointInView ( _
    point As Point3d _
) As Boolean
public:
bool PointInView(
    Point3d point
)
Parameters
point(Point3d)


Position Property

Position Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Position
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Position { get; }
Public ReadOnly Property Position As Point3d
    Get
public:
property Point3d Position {
    Point3d get ();
}


ProjectionMatrix Property

ProjectionMatrix Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ProjectionMatrix
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d ProjectionMatrix { get; }
Public ReadOnly Property ProjectionMatrix As Matrix3d
    Get
public:
property Matrix3d ProjectionMatrix {
    Matrix3d get ();
}


RemoveViewportClipRegion Method

RemoveViewportClipRegion Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »RemoveViewportClipRegion()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveViewportClipRegion()
Public Sub RemoveViewportClipRegion
public:
void RemoveViewportClipRegion()


RenderToImage Method

RenderToImage Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »RenderToImage()()()()
Members
Icon | Member | Description
 | RenderToImage(Drawable, Rectangle) |
 | RenderToImage()()()() |


RenderToImage Method

RenderToImage Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »RenderToImage()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap RenderToImage()
Public Function RenderToImage As Bitmap
public:
Bitmap^ RenderToImage()


RenderToImage Method (settings, rectScreen)

RenderToImage Method (settings, rectScreen)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »RenderToImage(Drawable, Rectangle)
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap RenderToImage(
    Drawable settings,
    Rectangle rectScreen
)
Public Function RenderToImage ( _
    settings As Drawable, _
    rectScreen As Rectangle _
) As Bitmap
public:
Bitmap^ RenderToImage(
    Drawable^ settings,
    Rectangle rectScreen
)
Parameters
settings(Drawable)
rectScreen(Rectangle)


Roll Method (angle)

Roll Method (angle)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Roll(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Roll(
    double angle
)
Public Sub Roll ( _
    angle As Double _
)
public:
void Roll(
    double angle
)
Parameters
angle(Double)


ScreenMatrix Property

ScreenMatrix Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ScreenMatrix
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d ScreenMatrix { get; }
Public ReadOnly Property ScreenMatrix As Matrix3d
    Get
public:
property Matrix3d ScreenMatrix {
    Matrix3d get ();
}


SetView Method

SetView Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »SetView()()()()
Members
Icon | Member | Description
 | SetView(Point3d, Point3d, Vector3d, Double, Double, Projection) |
 | SetView(Point3d, Point3d, Vector3d, Double, Double) |


SetView Method (position, target, upVector, fieldWidth, fieldHeight)

SetView Method (position, target, upVector, fieldWidth, fieldHeight)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »SetView(Point3d, Point3d, Vector3d, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public void SetView(
    Point3d position,
    Point3d target,
    Vector3d upVector,
    double fieldWidth,
    double fieldHeight
)
Public Sub SetView ( _
    position As Point3d, _
    target As Point3d, _
    upVector As Vector3d, _
    fieldWidth As Double, _
    fieldHeight As Double _
)
public:
void SetView(
    Point3d position,
    Point3d target,
    Vector3d upVector,
    double fieldWidth,
    double fieldHeight
)
Parameters
position(Point3d)
target(Point3d)
upVector(Vector3d)
fieldWidth(Double)
fieldHeight(Double)


SetView Method (position, target, upVector, fieldWidth, fieldHeight, projection)

SetView Method (position, target, upVector, fieldWidth, fieldHeight, projection)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »SetView(Point3d, Point3d, Vector3d, Double, Double, Projection)
Declaration Syntax
C# Visual Basic Visual C++
public void SetView(
    Point3d position,
    Point3d target,
    Vector3d upVector,
    double fieldWidth,
    double fieldHeight,
    Projection projection
)
Public Sub SetView ( _
    position As Point3d, _
    target As Point3d, _
    upVector As Vector3d, _
    fieldWidth As Double, _
    fieldHeight As Double, _
    projection As Projection _
)
public:
void SetView(
    Point3d position,
    Point3d target,
    Vector3d upVector,
    double fieldWidth,
    double fieldHeight,
    Projection projection
)
Parameters
position(Point3d)
target(Point3d)
upVector(Vector3d)
fieldWidth(Double)
fieldHeight(Double)
projection(Projection)


SetViewportClipRegion Method (contours, counts, points)

SetViewportClipRegion Method (contours, counts, points)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »SetViewportClipRegion(Int32, array<Int32>[]()[][], array<Point>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetViewportClipRegion(
    int contours,
    int[] counts,
    Point[] points
)
Public Sub SetViewportClipRegion ( _
    contours As Integer, _
    counts As Integer(), _
    points As Point() _
)
public:
void SetViewportClipRegion(
    int contours,
    array<int>^ counts,
    array<Point>^ points
)
Parameters
contours(Int32)
counts(array<Int32>[]()[][])
points(array<Point>[]()[][])


Show Method

Show Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Show()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Show()
Public Sub Show
public:
void Show()


StereoParameters Property

StereoParameters Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »StereoParameters
Declaration Syntax
C# Visual Basic Visual C++
public StereoParameters StereoParameters { get; set; }
Public Property StereoParameters As StereoParameters
    Get
    Set
public:
property StereoParameters StereoParameters {
    StereoParameters get ();
    void set (StereoParameters value);
}


Target Property

Target Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Target
Declaration Syntax
C# Visual Basic Visual C++
public Point3d Target { get; }
Public ReadOnly Property Target As Point3d
    Get
public:
property Point3d Target {
    Point3d get ();
}


ThawLayer Method (layerId)

ThawLayer Method (layerId)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ThawLayer(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void ThawLayer(
    IntPtr layerId
)
Public Sub ThawLayer ( _
    layerId As IntPtr _
)
public:
void ThawLayer(
    IntPtr layerId
)
Parameters
layerId(IntPtr)


Update Method

Update Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Update()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Update()
Public Sub Update
public:
void Update()


UpVector Property

UpVector Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »UpVector
Declaration Syntax
C# Visual Basic Visual C++
public Vector3d UpVector { get; }
Public ReadOnly Property UpVector As Vector3d
    Get
public:
property Vector3d UpVector {
    Vector3d get ();
}


ViewingMatrix Property

ViewingMatrix Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ViewingMatrix
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d ViewingMatrix { get; }
Public ReadOnly Property ViewingMatrix As Matrix3d
    Get
public:
property Matrix3d ViewingMatrix {
    Matrix3d get ();
}


Viewport Property

Viewport Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Viewport
Declaration Syntax
C# Visual Basic Visual C++
public Rectangle Viewport { get; set; }
Public Property Viewport As Rectangle
    Get
    Set
public:
property Rectangle Viewport {
    Rectangle get ();
    void set (Rectangle value);
}


ViewportBorderProperties Property

ViewportBorderProperties Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ViewportBorderProperties
Declaration Syntax
C# Visual Basic Visual C++
public ViewportBorderProperties ViewportBorderProperties { get; set; }
Public Property ViewportBorderProperties As ViewportBorderProperties
    Get
    Set
public:
property ViewportBorderProperties ViewportBorderProperties {
    ViewportBorderProperties get ();
    void set (ViewportBorderProperties value);
}


ViewportBorderVisibility Property

ViewportBorderVisibility Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ViewportBorderVisibility
Declaration Syntax
C# Visual Basic Visual C++
public bool ViewportBorderVisibility { get; set; }
Public Property ViewportBorderVisibility As Boolean
    Get
    Set
public:
property bool ViewportBorderVisibility {
    bool get ();
    void set (bool value);
}


VisualStyleId Property

VisualStyleId Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »VisualStyleId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId VisualStyleId { get; set; }
Public Property VisualStyleId As ObjectId
    Get
    Set
public:
property ObjectId VisualStyleId {
    ObjectId get ();
    void set (ObjectId value);
}


WorldToDeviceMatrix Property

WorldToDeviceMatrix Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »WorldToDeviceMatrix
Declaration Syntax
C# Visual Basic Visual C++
public Matrix3d WorldToDeviceMatrix { get; }
Public ReadOnly Property WorldToDeviceMatrix As Matrix3d
    Get
public:
property Matrix3d WorldToDeviceMatrix {
    Matrix3d get ();
}


Zoom Method (factor)

Zoom Method (factor)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Zoom(Double)
Declaration Syntax
C# Visual Basic Visual C++
public void Zoom(
    double factor
)
Public Sub Zoom ( _
    factor As Double _
)
public:
void Zoom(
    double factor
)
Parameters
factor(Double)


ZoomExtents Method (minPoint, maxPoint)

ZoomExtents Method (minPoint, maxPoint)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ZoomExtents(Point3d, Point3d)
Declaration Syntax
C# Visual Basic Visual C++
public void ZoomExtents(
    Point3d minPoint,
    Point3d maxPoint
)
Public Sub ZoomExtents ( _
    minPoint As Point3d, _
    maxPoint As Point3d _
)
public:
void ZoomExtents(
    Point3d minPoint,
    Point3d maxPoint
)
Parameters
minPoint(Point3d)
maxPoint(Point3d)


ZoomWindow Method (lowerLeft, upperRight)

ZoomWindow Method (lowerLeft, upperRight)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »ZoomWindow(Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public void ZoomWindow(
    Point2d lowerLeft,
    Point2d upperRight
)
Public Sub ZoomWindow ( _
    lowerLeft As Point2d, _
    upperRight As Point2d _
)
public:
void ZoomWindow(
    Point2d lowerLeft,
    Point2d upperRight
)
Parameters
lowerLeft(Point2d)
upperRight(Point2d)


ViewEventArgs Class

ViewEventArgs Class
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ViewEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class ViewEventArgs : EventArgs
Public Class ViewEventArgs _
    Inherits EventArgs
public ref class ViewEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewEventArgs()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | View |
Inheritance Hierarchy
Object
 | EventArgs
 |  | ViewEventArgs

Assembly: ZwManaged (Module: ZwManaged)


ViewEventArgs Constructor

ViewEventArgs Constructor
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ViewEventArgs »ViewEventArgs()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ViewEventArgs()
Public Sub New
public:
ViewEventArgs()

Assembly: ZwManaged (Module: ZwManaged)


View Property

View Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ViewEventArgs »View
Declaration Syntax
C# Visual Basic Visual C++
public View View { get; }
Public ReadOnly Property View As View
    Get
public:
property View^ View {
    View^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ViewportBorderProperties Structure

ViewportBorderProperties Structure
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ViewportBorderProperties
Declaration Syntax
C# Visual Basic Visual C++
public struct ViewportBorderProperties
Public Structure ViewportBorderProperties
public value class ViewportBorderProperties
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ViewportBorderProperties(Color, Int32) |
 | Color |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from ValueType.)
 | Weight |


ViewportBorderProperties Constructor (color, weight)

ViewportBorderProperties Constructor (color, weight)
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ViewportBorderProperties »ViewportBorderProperties(Color, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ViewportBorderProperties(
    Color color,
    int weight
)
Public Sub New ( _
    color As Color, _
    weight As Integer _
)
public:
ViewportBorderProperties(
    Color color,
    int weight
)
Parameters
color(Color)
weight(Int32)


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ViewportBorderProperties »Color
Declaration Syntax
C# Visual Basic Visual C++
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
public:
property Color Color {
    Color get ();
}


Weight Property

Weight Property
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ViewportBorderProperties »Weight
Declaration Syntax
C# Visual Basic Visual C++
public int Weight { get; }
Public ReadOnly Property Weight As Integer
    Get
public:
property int Weight {
    int get ();
}


ViewportFlags Enumeration

ViewportFlags Enumeration
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ViewportFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum ViewportFlags
<FlagsAttribute> _
Public Enumeration ViewportFlags
[FlagsAttribute]
public enum class ViewportFlags
Members
Member | Description
DependentGeometry |
DependentViewport |


ViewToBeDestroyedEventHandler Delegate

ViewToBeDestroyedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ViewToBeDestroyedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ViewToBeDestroyedEventHandler(
    Object sender,
    ViewEventArgs e
)
Public Delegate Sub ViewToBeDestroyedEventHandler ( _
    sender As Object, _
    e As ViewEventArgs _
)
public delegate void ViewToBeDestroyedEventHandler(
    Object^ sender,
    ViewEventArgs^ e
)
Parameters
sender(Object)
e(ViewEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


ViewWasCreatedEventHandler Delegate

ViewWasCreatedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ViewWasCreatedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ViewWasCreatedEventHandler(
    Object sender,
    ViewEventArgs e
)
Public Delegate Sub ViewWasCreatedEventHandler ( _
    sender As Object, _
    e As ViewEventArgs _
)
public delegate void ViewWasCreatedEventHandler(
    Object^ sender,
    ViewEventArgs^ e
)
Parameters
sender(Object)
e(ViewEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


ZwSoft.ZwCAD.Internal Namespace

ZwSoft.ZwCAD.Internal Namespace
Namespaces »ZwSoft.ZwCAD.Internal
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.Internal
Namespace ZwSoft.ZwCAD.Internal
namespace ZwSoft.ZwCAD.Internal
Types
All Types Classes
Icon | Type | Description
 | Utils |


Utils Class

Utils Class
Namespaces »ZwSoft.ZwCAD.Internal »Utils
Declaration Syntax
C# Visual Basic Visual C++
public class Utils
Public Class Utils
public ref class Utils
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Utils()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsStartedByOLE()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SelectObjects(array<ObjectId>[]()[][]) |
 | SetFocusToDwgView()()()() |
 | SynchZcadDisplay()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Utils

Assembly: ZwManaged (Module: ZwManaged)


Utils Constructor

Utils Constructor
Namespaces »ZwSoft.ZwCAD.Internal »Utils »Utils()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Utils()
Public Sub New
public:
Utils()

Assembly: ZwManaged (Module: ZwManaged)


IsStartedByOLE Method

IsStartedByOLE Method
Namespaces »ZwSoft.ZwCAD.Internal »Utils »IsStartedByOLE()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsStartedByOLE()
Public Shared Function IsStartedByOLE As Boolean
public:
static bool IsStartedByOLE()

Assembly: ZwManaged (Module: ZwManaged)


SelectObjects Method (ids)

SelectObjects Method (ids)
Namespaces »ZwSoft.ZwCAD.Internal »Utils »SelectObjects(array<ObjectId>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public static bool SelectObjects(
    ObjectId[] ids
)
Public Shared Function SelectObjects ( _
    ids As ObjectId() _
) As Boolean
public:
static bool SelectObjects(
    array<ObjectId>^ ids
)
Parameters
ids(array< ObjectId >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


SetFocusToDwgView Method

SetFocusToDwgView Method
Namespaces »ZwSoft.ZwCAD.Internal »Utils »SetFocusToDwgView()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static void SetFocusToDwgView()
Public Shared Sub SetFocusToDwgView
public:
static void SetFocusToDwgView()

Assembly: ZwManaged (Module: ZwManaged)


SynchZcadDisplay Method

SynchZcadDisplay Method
Namespaces »ZwSoft.ZwCAD.Internal »Utils »SynchZcadDisplay()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static void SynchZcadDisplay()
Public Shared Sub SynchZcadDisplay
public:
static void SynchZcadDisplay()

Assembly: ZwManaged (Module: ZwManaged)


ZwSoft.ZwCAD.LayerManager Namespace

ZwSoft.ZwCAD.LayerManager Namespace
Namespaces »ZwSoft.ZwCAD.LayerManager
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.LayerManager
Namespace ZwSoft.ZwCAD.LayerManager
namespace ZwSoft.ZwCAD.LayerManager
Types
All Types Classes Structures Enumerations
Icon | Type | Description
 | AndExpression |
 | DialogResult |
 | LayerCollection |
 | LayerFilter |
 | LayerFilterCollection |
 | LayerFilterDisplayImages |
 | LayerFilterTree |
 | LayerGroup |
 | RelationalExpression |


AndExpression Class

AndExpression Class
Namespaces »ZwSoft.ZwCAD.LayerManager »AndExpression
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcLyAndExpr")]
public sealed class AndExpression
<WrapperAttribute("AcLyAndExpr")> _
Public NotInheritable Class AndExpression
[WrapperAttribute(L"AcLyAndExpr")]
public ref class AndExpression sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetRelationalExpressions()()()() |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
AndExpression


GetRelationalExpressions Method

GetRelationalExpressions Method
Namespaces »ZwSoft.ZwCAD.LayerManager »AndExpression »GetRelationalExpressions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RelationalExpression[] GetRelationalExpressions()
Public Function GetRelationalExpressions As RelationalExpression()
public:
array<RelationalExpression^>^ GetRelationalExpressions()


DialogResult Enumeration

DialogResult Enumeration
Namespaces »ZwSoft.ZwCAD.LayerManager »DialogResult
Declaration Syntax
C# Visual Basic Visual C++
public enum DialogResult
Public Enumeration DialogResult
public enum class DialogResult
Members
Member | Description
UseDefault |
Cancel |
OK |


LayerCollection Class

LayerCollection Class
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcArray<AcDbObjectId>")]
public sealed class LayerCollection : ICollection
<WrapperAttribute("AcArray<AcDbObjectId>")> _
Public NotInheritable Class LayerCollection _
    Implements ICollection
[WrapperAttribute(L"AcArray<AcDbObjectId>")]
public ref class LayerCollection sealed : ICollection
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(ObjectId) |
 | Clear()()()() |
 | Contains(ObjectId) |
 | CopyTo(array<ObjectId>[]()[][], Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(ObjectId) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LayerCollection


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »Add(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    ObjectId value
)
Public Sub Add ( _
    value As ObjectId _
)
public:
void Add(
    ObjectId value
)
Parameters
value(ObjectId)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »Contains(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ObjectId value
)
Public Function Contains ( _
    value As ObjectId _
) As Boolean
public:
bool Contains(
    ObjectId value
)
Parameters
value(ObjectId)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »CopyTo(array<ObjectId>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ObjectId[] array,
    int index
)
Public Sub CopyTo ( _
    array As ObjectId(), _
    index As Integer _
)
public:
void CopyTo(
    array<ObjectId>^ array,
    int index
)
Parameters
array(array< ObjectId >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (arr, index)

ICollectionCopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array arr,
    int index
)
Private Sub ICollectionCopyTo ( _
    arr As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ arr,
    int index
) sealed = ICollection::CopyTo
Parameters
arr(Array)
index(Int32)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ObjectId
    Get
public:
property ObjectId default[int index] {
    ObjectId get (int index);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »Remove(ObjectId)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ObjectId value
)
Public Sub Remove ( _
    value As ObjectId _
)
public:
void Remove(
    ObjectId value
)
Parameters
value(ObjectId)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


LayerFilter Class

LayerFilter Class
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("OdLyLayerFilter")]
public class LayerFilter : RXObject
<WrapperAttribute("OdLyLayerFilter")> _
Public Class LayerFilter _
    Inherits RXObject
[WrapperAttribute(L"OdLyLayerFilter")]
public ref class LayerFilter : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayerFilter()()()() |
 | AllowDelete |
 | AllowNested |
 | AllowRename |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(LayerFilter) |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DynamicallyGenerated |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Filter(LayerTableRecord) |
 | FilterExpression |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GenerateNested()()()() |
 | GetFilterExpressionTree()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsIdFilter |
 | IsProxy |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | NestedFilters |
 | Parent |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | LayerFilter
 |  |  |  |  | LayerGroup


LayerFilter Constructor

LayerFilter Constructor
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »LayerFilter()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LayerFilter()
Public Sub New
public:
LayerFilter()


AllowDelete Property

AllowDelete Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »AllowDelete
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowDelete { get; }
Public ReadOnly Property AllowDelete As Boolean
    Get
public:
property bool AllowDelete {
    bool get ();
}


AllowNested Property

AllowNested Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »AllowNested
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowNested { get; }
Public ReadOnly Property AllowNested As Boolean
    Get
public:
property bool AllowNested {
    bool get ();
}


AllowRename Property

AllowRename Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »AllowRename
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowRename { get; }
Public ReadOnly Property AllowRename As Boolean
    Get
public:
property bool AllowRename {
    bool get ();
}


CompareTo Method (otherFilter)

CompareTo Method (otherFilter)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »CompareTo(LayerFilter)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool CompareTo(
    LayerFilter otherFilter
)
Public Overridable Function CompareTo ( _
    otherFilter As LayerFilter _
) As Boolean
public:
virtual bool CompareTo(
    LayerFilter^ otherFilter
)
Parameters
otherFilter(LayerFilter)


DynamicallyGenerated Property

DynamicallyGenerated Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »DynamicallyGenerated
Declaration Syntax
C# Visual Basic Visual C++
public bool DynamicallyGenerated { get; }
Public ReadOnly Property DynamicallyGenerated As Boolean
    Get
public:
property bool DynamicallyGenerated {
    bool get ();
}


Filter Method (layer)

Filter Method (layer)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »Filter(LayerTableRecord)
Declaration Syntax
C# Visual Basic Visual C++
public bool Filter(
    LayerTableRecord layer
)
Public Function Filter ( _
    layer As LayerTableRecord _
) As Boolean
public:
bool Filter(
    LayerTableRecord^ layer
)
Parameters
layer(LayerTableRecord)


FilterExpression Property

FilterExpression Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »FilterExpression
Declaration Syntax
C# Visual Basic Visual C++
public string FilterExpression { get; set; }
Public Property FilterExpression As String
    Get
    Set
public:
property String^ FilterExpression {
    String^ get ();
    void set (String^ value);
}


GenerateNested Method

GenerateNested Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »GenerateNested()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateNested()
Public Sub GenerateNested
public:
void GenerateNested()


GetFilterExpressionTree Method

GetFilterExpressionTree Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »GetFilterExpressionTree()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AndExpression[] GetFilterExpressionTree()
Public Function GetFilterExpressionTree As AndExpression()
public:
array<AndExpression^>^ GetFilterExpressionTree()


IsIdFilter Property

IsIdFilter Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »IsIdFilter
Declaration Syntax
C# Visual Basic Visual C++
public bool IsIdFilter { get; }
Public ReadOnly Property IsIdFilter As Boolean
    Get
public:
property bool IsIdFilter {
    bool get ();
}


IsProxy Property

IsProxy Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »IsProxy
Declaration Syntax
C# Visual Basic Visual C++
public bool IsProxy { get; }
Public ReadOnly Property IsProxy As Boolean
    Get
public:
property bool IsProxy {
    bool get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NestedFilters Property

NestedFilters Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »NestedFilters
Declaration Syntax
C# Visual Basic Visual C++
public LayerFilterCollection NestedFilters { get; }
Public ReadOnly Property NestedFilters As LayerFilterCollection
    Get
public:
property LayerFilterCollection^ NestedFilters {
    LayerFilterCollection^ get ();
}


Parent Property

Parent Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »Parent
Declaration Syntax
C# Visual Basic Visual C++
public LayerFilter Parent { get; }
Public ReadOnly Property Parent As LayerFilter
    Get
public:
property LayerFilter^ Parent {
    LayerFilter^ get ();
}


LayerFilterCollection Class

LayerFilterCollection Class
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcArray<AcLyLayerFilter*>")]
public sealed class LayerFilterCollection : ICollection
<WrapperAttribute("AcArray<AcLyLayerFilter*>")> _
Public NotInheritable Class LayerFilterCollection _
    Implements ICollection
[WrapperAttribute(L"AcArray<AcLyLayerFilter*>")]
public ref class LayerFilterCollection sealed : ICollection
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(LayerFilter) |
 | Clear()()()() |
 | Contains(LayerFilter) |
 | CopyTo(array<LayerFilter>[]()[][], Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(LayerFilter) |
 | ICollection..::..SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LayerFilterCollection


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »Add(LayerFilter)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    LayerFilter value
)
Public Sub Add ( _
    value As LayerFilter _
)
public:
void Add(
    LayerFilter^ value
)
Parameters
value(LayerFilter)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »Contains(LayerFilter)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    LayerFilter value
)
Public Function Contains ( _
    value As LayerFilter _
) As Boolean
public:
bool Contains(
    LayerFilter^ value
)
Parameters
value(LayerFilter)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »CopyTo(array<LayerFilter>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    LayerFilter[] array,
    int index
)
Public Sub CopyTo ( _
    array As LayerFilter(), _
    index As Integer _
)
public:
void CopyTo(
    array<LayerFilter^>^ array,
    int index
)
Parameters
array(array< LayerFilter >[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed


ICollectionCopyTo Method (arr, index)

ICollectionCopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array arr,
    int index
)
Private Sub ICollectionCopyTo ( _
    arr As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ arr,
    int index
) sealed = ICollection::CopyTo
Parameters
arr(Array)
index(Int32)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public LayerFilter this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As LayerFilter
    Get
public:
property LayerFilter^ default[int index] {
    LayerFilter^ get (int index);
}
Parameters
index(Int32)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »Remove(LayerFilter)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    LayerFilter value
)
Public Sub Remove ( _
    value As LayerFilter _
)
public:
void Remove(
    LayerFilter^ value
)
Parameters
value(LayerFilter)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterCollection »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}


LayerFilterDisplayImages Structure

LayerFilterDisplayImages Structure
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterDisplayImages
Declaration Syntax
C# Visual Basic Visual C++
public struct LayerFilterDisplayImages
Public Structure LayerFilterDisplayImages
public value class LayerFilterDisplayImages
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayerFilterDisplayImages(IntPtr, Int32, Int32) |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | ImageIndex |
 | ImageListHandle |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SelectedImageIndex |
 | ToString()()()() | (Inherited from ValueType.)


LayerFilterDisplayImages Constructor (imageListHandle, imageIndex, selectedImageIndex)

LayerFilterDisplayImages Constructor (imageListHandle, imageIndex, selectedImageIndex)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterDisplayImages »LayerFilterDisplayImages(IntPtr, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public LayerFilterDisplayImages(
    IntPtr imageListHandle,
    int imageIndex,
    int selectedImageIndex
)
Public Sub New ( _
    imageListHandle As IntPtr, _
    imageIndex As Integer, _
    selectedImageIndex As Integer _
)
public:
LayerFilterDisplayImages(
    IntPtr imageListHandle,
    int imageIndex,
    int selectedImageIndex
)
Parameters
imageListHandle(IntPtr)
imageIndex(Int32)
selectedImageIndex(Int32)


ImageIndex Property

ImageIndex Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterDisplayImages »ImageIndex
Declaration Syntax
C# Visual Basic Visual C++
public int ImageIndex { get; set; }
Public Property ImageIndex As Integer
    Get
    Set
public:
property int ImageIndex {
    int get ();
    void set (int value);
}


ImageListHandle Property

ImageListHandle Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterDisplayImages »ImageListHandle
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr ImageListHandle { get; set; }
Public Property ImageListHandle As IntPtr
    Get
    Set
public:
property IntPtr ImageListHandle {
    IntPtr get ();
    void set (IntPtr value);
}


SelectedImageIndex Property

SelectedImageIndex Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterDisplayImages »SelectedImageIndex
Declaration Syntax
C# Visual Basic Visual C++
public int SelectedImageIndex { get; set; }
Public Property SelectedImageIndex As Integer
    Get
    Set
public:
property int SelectedImageIndex {
    int get ();
    void set (int value);
}


LayerFilterTree Structure

LayerFilterTree Structure
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterTree
Declaration Syntax
C# Visual Basic Visual C++
public struct LayerFilterTree
Public Structure LayerFilterTree
public value class LayerFilterTree
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayerFilterTree(LayerFilter, LayerFilter) |
 | Current |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Root |
 | ToString()()()() | (Inherited from ValueType.)


LayerFilterTree Constructor (root, current)

LayerFilterTree Constructor (root, current)
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterTree »LayerFilterTree(LayerFilter, LayerFilter)
Declaration Syntax
C# Visual Basic Visual C++
public LayerFilterTree(
    LayerFilter root,
    LayerFilter current
)
Public Sub New ( _
    root As LayerFilter, _
    current As LayerFilter _
)
public:
LayerFilterTree(
    LayerFilter^ root,
    LayerFilter^ current
)
Parameters
root(LayerFilter)
current(LayerFilter)


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterTree »Current
Declaration Syntax
C# Visual Basic Visual C++
public LayerFilter Current { get; }
Public ReadOnly Property Current As LayerFilter
    Get
public:
property LayerFilter^ Current {
    LayerFilter^ get ();
}


Root Property

Root Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilterTree »Root
Declaration Syntax
C# Visual Basic Visual C++
public LayerFilter Root { get; }
Public ReadOnly Property Root As LayerFilter
    Get
public:
property LayerFilter^ Root {
    LayerFilter^ get ();
}


LayerGroup Class

LayerGroup Class
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerGroup
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcLyLayerGroup")]
public class LayerGroup : LayerFilter
<WrapperAttribute("AcLyLayerGroup")> _
Public Class LayerGroup _
    Inherits LayerFilter
[WrapperAttribute(L"AcLyLayerGroup")]
public ref class LayerGroup : public LayerFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayerGroup()()()() |
 | AllowDelete | (Inherited from LayerFilter.)
 | AllowNested | (Inherited from LayerFilter.)
 | AllowRename | (Inherited from LayerFilter.)
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(LayerFilter) | (Inherited from LayerFilter.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DynamicallyGenerated | (Inherited from LayerFilter.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Filter(LayerTableRecord) | (Inherited from LayerFilter.)
 | FilterExpression | (Inherited from LayerFilter.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GenerateNested()()()() | (Inherited from LayerFilter.)
 | GetFilterExpressionTree()()()() | (Inherited from LayerFilter.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsIdFilter | (Inherited from LayerFilter.)
 | IsProxy | (Inherited from LayerFilter.)
 | LayerIds |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | (Inherited from LayerFilter.)
 | NestedFilters | (Inherited from LayerFilter.)
 | Parent | (Inherited from LayerFilter.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | LayerFilter
 |  |  |  |  | LayerGroup


LayerGroup Constructor

LayerGroup Constructor
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerGroup »LayerGroup()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LayerGroup()
Public Sub New
public:
LayerGroup()


LayerIds Property

LayerIds Property
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerGroup »LayerIds
Declaration Syntax
C# Visual Basic Visual C++
public LayerCollection LayerIds { get; }
Public ReadOnly Property LayerIds As LayerCollection
    Get
public:
property LayerCollection^ LayerIds {
    LayerCollection^ get ();
}


RelationalExpression Class

RelationalExpression Class
Namespaces »ZwSoft.ZwCAD.LayerManager »RelationalExpression
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcLyRelExpr")]
public sealed class RelationalExpression
<WrapperAttribute("AcLyRelExpr")> _
Public NotInheritable Class RelationalExpression
[WrapperAttribute(L"AcLyRelExpr")]
public ref class RelationalExpression sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Constant |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Variable |
Inheritance Hierarchy
Object
RelationalExpression


Constant Property

Constant Property
Namespaces »ZwSoft.ZwCAD.LayerManager »RelationalExpression »Constant
Declaration Syntax
C# Visual Basic Visual C++
public string Constant { get; }
Public ReadOnly Property Constant As String
    Get
public:
property String^ Constant {
    String^ get ();
}


Variable Property

Variable Property
Namespaces »ZwSoft.ZwCAD.LayerManager »RelationalExpression »Variable
Declaration Syntax
C# Visual Basic Visual C++
public string Variable { get; }
Public ReadOnly Property Variable As String
    Get
public:
property String^ Variable {
    String^ get ();
}


ZwSoft.ZwCAD.PlottingServices Namespace

ZwSoft.ZwCAD.PlottingServices Namespace
Namespaces »ZwSoft.ZwCAD.PlottingServices
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.PlottingServices
Namespace ZwSoft.ZwCAD.PlottingServices
namespace ZwSoft.ZwCAD.PlottingServices
Types
All Types Classes Structures Enumerations Delegates
Icon | Type | Description
 | AppPlotStatus |
 | BeginDocumentEventArgs |
 | BeginDocumentEventHandler |
 | BeginPageEventArgs |
 | BeginPageEventHandler |
 | BeginPlotEventArgs |
 | BeginPlotEventHandler |
 | CustomSizeResults |
 | DeviceType |
 | DsdData |
 | DsdEntry |
 | DsdEntryCollection |
 | DsdEntryCollectionEnumerator |
 | EndDocumentEventArgs |
 | EndDocumentEventHandler |
 | EndPageEventArgs |
 | EndPageEventHandler |
 | EndPlotEventArgs |
 | EndPlotEventHandler |
 | HostAppServices |
 | MatchingPolicy |
 | MediaBounds |
 | MergeStatus |
 | PageCancelledEventHandler |
 | PlotCancelledEventHandler |
 | PlotCancelStatus |
 | PlotConfig |
 | PlotConfigManager |
 | PlotEngine |
 | PlotFactory |
 | PlotInfo |
 | PlotInfoValidator |
 | PlotLogger |
 | PlotMessageIndex |
 | PlotPageInfo |
 | PlotProgress |
 | PlotProgressDialog |
 | PlotReactorManager |
 | PlotToFileCapability |
 | PlotType |
 | PreviewEndPlotInfo |
 | PreviewEndPlotStatus |
 | PreviewEngineFlags |
 | ProcessPlotState |
 | RefreshCode |
 | SheetCancelStatus |
 | SheetType |
 | StdConfiguration |


AppPlotStatus Enumeration

AppPlotStatus Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »AppPlotStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum AppPlotStatus
Public Enumeration AppPlotStatus
public enum class AppPlotStatus
Members
Member | Description
PlotHadSystemError |
PlotHadErrors |
PlotSuccessful |
ViewPlotLog |
PlotStart |
NoPlotYet |
PlottingMessage |
DwfFilePlotted |

Assembly: ZwManaged (Module: ZwManaged)


BeginDocumentEventArgs Class

BeginDocumentEventArgs Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginDocumentEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class BeginDocumentEventArgs : EventArgs
Public Class BeginDocumentEventArgs _
    Inherits EventArgs
public ref class BeginDocumentEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BeginDocumentEventArgs(PlotInfo, String, Int32, Boolean, String) |
 | Copies |
 | DocumentName |
 | Equals(Object) | (Inherited from Object.)
 | FileName |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotInfo |
 | PlotToFile |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeginDocumentEventArgs

Assembly: ZwManaged (Module: ZwManaged)


BeginDocumentEventArgs Constructor (plotInfo, documentName, copies, plotToFile, fileName)

BeginDocumentEventArgs Constructor (plotInfo, documentName, copies, plotToFile, fileName)
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginDocumentEventArgs »BeginDocumentEventArgs(PlotInfo, String, Int32, Boolean, String)
Declaration Syntax
C# Visual Basic Visual C++
public BeginDocumentEventArgs(
    PlotInfo plotInfo,
    string documentName,
    int copies,
    bool plotToFile,
    string fileName
)
Public Sub New ( _
    plotInfo As PlotInfo, _
    documentName As String, _
    copies As Integer, _
    plotToFile As Boolean, _
    fileName As String _
)
public:
BeginDocumentEventArgs(
    PlotInfo^ plotInfo,
    String^ documentName,
    int copies,
    bool plotToFile,
    String^ fileName
)
Parameters
plotInfo(PlotInfo)
documentName(String)
copies(Int32)
plotToFile(Boolean)
fileName(String)

Assembly: ZwManaged (Module: ZwManaged)


Copies Property

Copies Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginDocumentEventArgs »Copies
Declaration Syntax
C# Visual Basic Visual C++
public int Copies { get; }
Public ReadOnly Property Copies As Integer
    Get
public:
property int Copies {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DocumentName Property

DocumentName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginDocumentEventArgs »DocumentName
Declaration Syntax
C# Visual Basic Visual C++
public string DocumentName { get; }
Public ReadOnly Property DocumentName As String
    Get
public:
property String^ DocumentName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


FileName Property

FileName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginDocumentEventArgs »FileName
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotInfo Property

PlotInfo Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginDocumentEventArgs »PlotInfo
Declaration Syntax
C# Visual Basic Visual C++
public PlotInfo PlotInfo { get; }
Public ReadOnly Property PlotInfo As PlotInfo
    Get
public:
property PlotInfo^ PlotInfo {
    PlotInfo^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotToFile Property

PlotToFile Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginDocumentEventArgs »PlotToFile
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotToFile { get; }
Public ReadOnly Property PlotToFile As Boolean
    Get
public:
property bool PlotToFile {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


BeginDocumentEventHandler Delegate

BeginDocumentEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginDocumentEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginDocumentEventHandler(
    Object sender,
    BeginDocumentEventArgs e
)
Public Delegate Sub BeginDocumentEventHandler ( _
    sender As Object, _
    e As BeginDocumentEventArgs _
)
public delegate void BeginDocumentEventHandler(
    Object^ sender,
    BeginDocumentEventArgs^ e
)
Parameters
sender(Object)
e(BeginDocumentEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


BeginPageEventArgs Class

BeginPageEventArgs Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPageEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class BeginPageEventArgs : EventArgs
Public Class BeginPageEventArgs _
    Inherits EventArgs
public ref class BeginPageEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BeginPageEventArgs(PlotPageInfo, PlotInfo, Boolean) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LastPage |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotInfo |
 | PlotPageInfo |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeginPageEventArgs

Assembly: ZwManaged (Module: ZwManaged)


BeginPageEventArgs Constructor (plotPageInfo, plotInfo, lastPage)

BeginPageEventArgs Constructor (plotPageInfo, plotInfo, lastPage)
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPageEventArgs »BeginPageEventArgs(PlotPageInfo, PlotInfo, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public BeginPageEventArgs(
    PlotPageInfo plotPageInfo,
    PlotInfo plotInfo,
    bool lastPage
)
Public Sub New ( _
    plotPageInfo As PlotPageInfo, _
    plotInfo As PlotInfo, _
    lastPage As Boolean _
)
public:
BeginPageEventArgs(
    PlotPageInfo^ plotPageInfo,
    PlotInfo^ plotInfo,
    bool lastPage
)
Parameters
plotPageInfo(PlotPageInfo)
plotInfo(PlotInfo)
lastPage(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


LastPage Property

LastPage Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPageEventArgs »LastPage
Declaration Syntax
C# Visual Basic Visual C++
public bool LastPage { get; }
Public ReadOnly Property LastPage As Boolean
    Get
public:
property bool LastPage {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotInfo Property

PlotInfo Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPageEventArgs »PlotInfo
Declaration Syntax
C# Visual Basic Visual C++
public PlotInfo PlotInfo { get; }
Public ReadOnly Property PlotInfo As PlotInfo
    Get
public:
property PlotInfo^ PlotInfo {
    PlotInfo^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotPageInfo Property

PlotPageInfo Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPageEventArgs »PlotPageInfo
Declaration Syntax
C# Visual Basic Visual C++
public PlotPageInfo PlotPageInfo { get; }
Public ReadOnly Property PlotPageInfo As PlotPageInfo
    Get
public:
property PlotPageInfo^ PlotPageInfo {
    PlotPageInfo^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


BeginPageEventHandler Delegate

BeginPageEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPageEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginPageEventHandler(
    Object sender,
    BeginPageEventArgs e
)
Public Delegate Sub BeginPageEventHandler ( _
    sender As Object, _
    e As BeginPageEventArgs _
)
public delegate void BeginPageEventHandler(
    Object^ sender,
    BeginPageEventArgs^ e
)
Parameters
sender(Object)
e(BeginPageEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


BeginPlotEventArgs Class

BeginPlotEventArgs Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPlotEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class BeginPlotEventArgs : EventArgs
Public Class BeginPlotEventArgs _
    Inherits EventArgs
public ref class BeginPlotEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BeginPlotEventArgs(PlotProgress, PlotType) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotProgress |
 | PlotType |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeginPlotEventArgs

Assembly: ZwManaged (Module: ZwManaged)


BeginPlotEventArgs Constructor (progress, plotType)

BeginPlotEventArgs Constructor (progress, plotType)
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPlotEventArgs »BeginPlotEventArgs(PlotProgress, PlotType)
Declaration Syntax
C# Visual Basic Visual C++
public BeginPlotEventArgs(
    PlotProgress progress,
    PlotType plotType
)
Public Sub New ( _
    progress As PlotProgress, _
    plotType As PlotType _
)
public:
BeginPlotEventArgs(
    PlotProgress^ progress,
    PlotType plotType
)
Parameters
progress(PlotProgress)
plotType(PlotType)

Assembly: ZwManaged (Module: ZwManaged)


PlotProgress Property

PlotProgress Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPlotEventArgs »PlotProgress
Declaration Syntax
C# Visual Basic Visual C++
public PlotProgress PlotProgress { get; }
Public ReadOnly Property PlotProgress As PlotProgress
    Get
public:
property PlotProgress^ PlotProgress {
    PlotProgress^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotType Property

PlotType Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPlotEventArgs »PlotType
Declaration Syntax
C# Visual Basic Visual C++
public PlotType PlotType { get; }
Public ReadOnly Property PlotType As PlotType
    Get
public:
property PlotType PlotType {
    PlotType get ();
}

Assembly: ZwManaged (Module: ZwManaged)


BeginPlotEventHandler Delegate

BeginPlotEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.PlottingServices »BeginPlotEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginPlotEventHandler(
    Object sender,
    BeginPlotEventArgs e
)
Public Delegate Sub BeginPlotEventHandler ( _
    sender As Object, _
    e As BeginPlotEventArgs _
)
public delegate void BeginPlotEventHandler(
    Object^ sender,
    BeginPlotEventArgs^ e
)
Parameters
sender(Object)
e(BeginPlotEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


CustomSizeResults Enumeration

CustomSizeResults Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »CustomSizeResults
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum CustomSizeResults
<FlagsAttribute> _
Public Enumeration CustomSizeResults
[FlagsAttribute]
public enum class CustomSizeResults
Members
Member | Description
DeviceLoadFailed |
WidthAndHeightMustBePositive |
PmpFileReadOnly |
UnknownErrPmpFile |
UnknownErrPC3File |
SizeTooBig |
PC3FileReadOnly |
UnknownErrPmpDir |
PmpDirMissing |
PmpDirReadOnly |
PC3DirReadOnly |
RotationRequired |
MustCreatePC3 |
Possible |
Exception |

Assembly: ZwManaged (Module: ZwManaged)


DeviceType Enumeration

DeviceType Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »DeviceType
Declaration Syntax
C# Visual Basic Visual C++
public enum DeviceType
Public Enumeration DeviceType
public enum class DeviceType
Members
Member | Description
Uninitialized |
OneOffConfig |
PC3File |
SystemPrinter |

Assembly: ZwManaged (Module: ZwManaged)


DsdData Class

DsdData Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlDSDData")]
public sealed class DsdData : RXObject
<WrapperAttribute("AcPlDSDData")> _
Public NotInheritable Class DsdData _
    Inherits RXObject
[WrapperAttribute(L"AcPlDSDData")]
public ref class DsdData sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DsdData()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CategoryName |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copy()()()() |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyFromUnmanagedObject(IntPtr) |
 | CopyToUnmanagedObject(IntPtr) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DestinationName |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetDsdEntryCollection()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeLayerInfo |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsHomogeneous |
 | IsSheetSet |
 | LogFilePath |
 | MajorVersion |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinorVersion |
 | NoOfCopies |
 | Password |
 | PlotStampOn |
 | ProjectPath |
 | PromptForDwfName |
 | PromptForPassword |
 | PwdProtectPublishedDwf |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ReadDsd(String) |
 | SelectionSetName |
 | SetDsdEntryCollection(DsdEntryCollection) |
 | SetUnrecognizedData(StringCollection, StringCollection) |
 | SetUnrecognizedData(String, String) |
 | SheetSetName |
 | SheetType |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UnrecognizedDataSectionNames |
 | UnrecognizedDataSections |
 | WriteDsd(String) |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DsdData

Assembly: ZwManaged (Module: ZwManaged)


DsdData Constructor

DsdData Constructor
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »DsdData()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DsdData()
Public Sub New
public:
DsdData()

Assembly: ZwManaged (Module: ZwManaged)


CategoryName Property

CategoryName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »CategoryName
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryName { get; set; }
Public Property CategoryName As String
    Get
    Set
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Copy Method

Copy Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »Copy()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DsdData Copy()
Public Function Copy As DsdData
public:
DsdData^ Copy()

Assembly: ZwManaged (Module: ZwManaged)


CopyFromUnmanagedObject Method (unmanagedPointer)

CopyFromUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »CopyFromUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static DsdData CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Shared Function CopyFromUnmanagedObject ( _
    unmanagedPointer As IntPtr _
) As DsdData
public:
static DsdData^ CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


CopyToUnmanagedObject Method (unmanagedPointer)

CopyToUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »CopyToUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyToUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Sub CopyToUnmanagedObject ( _
    unmanagedPointer As IntPtr _
)
public:
void CopyToUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


DestinationName Property

DestinationName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »DestinationName
Declaration Syntax
C# Visual Basic Visual C++
public string DestinationName { get; set; }
Public Property DestinationName As String
    Get
    Set
public:
property String^ DestinationName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


GetDsdEntryCollection Method

GetDsdEntryCollection Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »GetDsdEntryCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DsdEntryCollection GetDsdEntryCollection()
Public Function GetDsdEntryCollection As DsdEntryCollection
public:
DsdEntryCollection^ GetDsdEntryCollection()

Assembly: ZwManaged (Module: ZwManaged)


IncludeLayerInfo Property

IncludeLayerInfo Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »IncludeLayerInfo
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeLayerInfo { get; set; }
Public Property IncludeLayerInfo As Boolean
    Get
    Set
public:
property bool IncludeLayerInfo {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


IsHomogeneous Property

IsHomogeneous Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »IsHomogeneous
Declaration Syntax
C# Visual Basic Visual C++
public bool IsHomogeneous { get; set; }
Public Property IsHomogeneous As Boolean
    Get
    Set
public:
property bool IsHomogeneous {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


IsSheetSet Property

IsSheetSet Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »IsSheetSet
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSheetSet { get; set; }
Public Property IsSheetSet As Boolean
    Get
    Set
public:
property bool IsSheetSet {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


LogFilePath Property

LogFilePath Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »LogFilePath
Declaration Syntax
C# Visual Basic Visual C++
public string LogFilePath { get; set; }
Public Property LogFilePath As String
    Get
    Set
public:
property String^ LogFilePath {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


MajorVersion Property

MajorVersion Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »MajorVersion
Declaration Syntax
C# Visual Basic Visual C++
public int MajorVersion { get; set; }
Public Property MajorVersion As Integer
    Get
    Set
public:
property int MajorVersion {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


MinorVersion Property

MinorVersion Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »MinorVersion
Declaration Syntax
C# Visual Basic Visual C++
public int MinorVersion { get; set; }
Public Property MinorVersion As Integer
    Get
    Set
public:
property int MinorVersion {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


NoOfCopies Property

NoOfCopies Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »NoOfCopies
Declaration Syntax
C# Visual Basic Visual C++
public int NoOfCopies { get; set; }
Public Property NoOfCopies As Integer
    Get
    Set
public:
property int NoOfCopies {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


Password Property

Password Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »Password
Declaration Syntax
C# Visual Basic Visual C++
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PlotStampOn Property

PlotStampOn Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »PlotStampOn
Declaration Syntax
C# Visual Basic Visual C++
public bool PlotStampOn { get; set; }
Public Property PlotStampOn As Boolean
    Get
    Set
public:
property bool PlotStampOn {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


ProjectPath Property

ProjectPath Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »ProjectPath
Declaration Syntax
C# Visual Basic Visual C++
public string ProjectPath { get; set; }
Public Property ProjectPath As String
    Get
    Set
public:
property String^ ProjectPath {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptForDwfName Property

PromptForDwfName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »PromptForDwfName
Declaration Syntax
C# Visual Basic Visual C++
public bool PromptForDwfName { get; set; }
Public Property PromptForDwfName As Boolean
    Get
    Set
public:
property bool PromptForDwfName {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PromptForPassword Property

PromptForPassword Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »PromptForPassword
Declaration Syntax
C# Visual Basic Visual C++
public bool PromptForPassword { get; set; }
Public Property PromptForPassword As Boolean
    Get
    Set
public:
property bool PromptForPassword {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PwdProtectPublishedDwf Property

PwdProtectPublishedDwf Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »PwdProtectPublishedDwf
Declaration Syntax
C# Visual Basic Visual C++
public bool PwdProtectPublishedDwf { get; set; }
Public Property PwdProtectPublishedDwf As Boolean
    Get
    Set
public:
property bool PwdProtectPublishedDwf {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


ReadDsd Method (fileName)

ReadDsd Method (fileName)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »ReadDsd(String)
Declaration Syntax
C# Visual Basic Visual C++
public void ReadDsd(
    string fileName
)
Public Sub ReadDsd ( _
    fileName As String _
)
public:
void ReadDsd(
    String^ fileName
)
Parameters
fileName(String)

Assembly: ZwManaged (Module: ZwManaged)


SelectionSetName Property

SelectionSetName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »SelectionSetName
Declaration Syntax
C# Visual Basic Visual C++
public string SelectionSetName { get; set; }
Public Property SelectionSetName As String
    Get
    Set
public:
property String^ SelectionSetName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


SetDsdEntryCollection Method (entries)

SetDsdEntryCollection Method (entries)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »SetDsdEntryCollection(DsdEntryCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDsdEntryCollection(
    DsdEntryCollection entries
)
Public Sub SetDsdEntryCollection ( _
    entries As DsdEntryCollection _
)
public:
void SetDsdEntryCollection(
    DsdEntryCollection^ entries
)
Parameters
entries(DsdEntryCollection)

Assembly: ZwManaged (Module: ZwManaged)


SetUnrecognizedData Method

SetUnrecognizedData Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »SetUnrecognizedData()()()()
Members
Icon | Member | Description
 | SetUnrecognizedData(StringCollection, StringCollection) |
 | SetUnrecognizedData(String, String) |

Assembly: ZwManaged (Module: ZwManaged)


SetUnrecognizedData Method (sectionNames, sectionData)

SetUnrecognizedData Method (sectionNames, sectionData)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »SetUnrecognizedData(StringCollection, StringCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUnrecognizedData(
    StringCollection sectionNames,
    StringCollection sectionData
)
Public Sub SetUnrecognizedData ( _
    sectionNames As StringCollection, _
    sectionData As StringCollection _
)
public:
void SetUnrecognizedData(
    StringCollection^ sectionNames,
    StringCollection^ sectionData
)
Parameters
sectionNames(StringCollection)
sectionData(StringCollection)

Assembly: ZwManaged (Module: ZwManaged)


SetUnrecognizedData Method (sectionName, sectionData)

SetUnrecognizedData Method (sectionName, sectionData)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »SetUnrecognizedData(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void SetUnrecognizedData(
    string sectionName,
    string sectionData
)
Public Sub SetUnrecognizedData ( _
    sectionName As String, _
    sectionData As String _
)
public:
void SetUnrecognizedData(
    String^ sectionName,
    String^ sectionData
)
Parameters
sectionName(String)
sectionData(String)

Assembly: ZwManaged (Module: ZwManaged)


SheetSetName Property

SheetSetName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »SheetSetName
Declaration Syntax
C# Visual Basic Visual C++
public string SheetSetName { get; set; }
Public Property SheetSetName As String
    Get
    Set
public:
property String^ SheetSetName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


SheetType Property

SheetType Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »SheetType
Declaration Syntax
C# Visual Basic Visual C++
public SheetType SheetType { get; set; }
Public Property SheetType As SheetType
    Get
    Set
public:
property SheetType SheetType {
    SheetType get ();
    void set (SheetType value);
}

Assembly: ZwManaged (Module: ZwManaged)


UnrecognizedDataSectionNames Property

UnrecognizedDataSectionNames Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »UnrecognizedDataSectionNames
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection UnrecognizedDataSectionNames { get; }
Public ReadOnly Property UnrecognizedDataSectionNames As StringCollection
    Get
public:
property StringCollection^ UnrecognizedDataSectionNames {
    StringCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


UnrecognizedDataSections Property

UnrecognizedDataSections Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »UnrecognizedDataSections
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection UnrecognizedDataSections { get; }
Public ReadOnly Property UnrecognizedDataSections As StringCollection
    Get
public:
property StringCollection^ UnrecognizedDataSections {
    StringCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


WriteDsd Method (fileName)

WriteDsd Method (fileName)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »WriteDsd(String)
Declaration Syntax
C# Visual Basic Visual C++
public void WriteDsd(
    string fileName
)
Public Sub WriteDsd ( _
    fileName As String _
)
public:
void WriteDsd(
    String^ fileName
)
Parameters
fileName(String)

Assembly: ZwManaged (Module: ZwManaged)


DsdEntry Class

DsdEntry Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlDSDEntry")]
public sealed class DsdEntry : RXObject
<WrapperAttribute("AcPlDSDEntry")> _
Public NotInheritable Class DsdEntry _
    Inherits RXObject
[WrapperAttribute(L"AcPlDSDEntry")]
public ref class DsdEntry sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DsdEntry()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Copy()()()() |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyFromUnmanagedObject(IntPtr) |
 | CopyToUnmanagedObject(IntPtr) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DwgName |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Layout |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Nps |
 | NpsSourceDwg |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Title |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DsdEntry

Assembly: ZwManaged (Module: ZwManaged)


DsdEntry Constructor

DsdEntry Constructor
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »DsdEntry()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DsdEntry()
Public Sub New
public:
DsdEntry()

Assembly: ZwManaged (Module: ZwManaged)


Copy Method

Copy Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »Copy()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DsdEntry Copy()
Public Function Copy As DsdEntry
public:
DsdEntry^ Copy()

Assembly: ZwManaged (Module: ZwManaged)


CopyFromUnmanagedObject Method (unmanagedPointer)

CopyFromUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »CopyFromUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static DsdEntry CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Shared Function CopyFromUnmanagedObject ( _
    unmanagedPointer As IntPtr _
) As DsdEntry
public:
static DsdEntry^ CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


CopyToUnmanagedObject Method (unmanagedPointer)

CopyToUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »CopyToUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyToUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Sub CopyToUnmanagedObject ( _
    unmanagedPointer As IntPtr _
)
public:
void CopyToUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


DwgName Property

DwgName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »DwgName
Declaration Syntax
C# Visual Basic Visual C++
public string DwgName { get; set; }
Public Property DwgName As String
    Get
    Set
public:
property String^ DwgName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Layout Property

Layout Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »Layout
Declaration Syntax
C# Visual Basic Visual C++
public string Layout { get; set; }
Public Property Layout As String
    Get
    Set
public:
property String^ Layout {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Nps Property

Nps Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »Nps
Declaration Syntax
C# Visual Basic Visual C++
public string Nps { get; set; }
Public Property Nps As String
    Get
    Set
public:
property String^ Nps {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


NpsSourceDwg Property

NpsSourceDwg Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »NpsSourceDwg
Declaration Syntax
C# Visual Basic Visual C++
public string NpsSourceDwg { get; set; }
Public Property NpsSourceDwg As String
    Get
    Set
public:
property String^ NpsSourceDwg {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Title Property

Title Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »Title
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DsdEntryCollection Class

DsdEntryCollection Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlDSDEntries")]
public class DsdEntryCollection : DisposableWrapper,
    ICollection, IEnumerable, IList
<WrapperAttribute("AcPlDSDEntries")> _
Public Class DsdEntryCollection _
    Inherits DisposableWrapper _
    Implements ICollection, IEnumerable, IList
[WrapperAttribute(L"AcPlDSDEntries")]
public ref class DsdEntryCollection : public DisposableWrapper,
    ICollection, IEnumerable, IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DsdEntryCollection()()()() |
 | DsdEntryCollection(IntPtr, Boolean) |
 | Add(Object) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clear()()()() |
 | Contains(Object) |
 | CopyFromUnmanagedObject(IntPtr) |
 | CopyTo(Array, Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(Object) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Insert(Int32, Object) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Object) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | DsdEntryCollection

Assembly: ZwManaged (Module: ZwManaged)


DsdEntryCollection Constructor

DsdEntryCollection Constructor
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »DsdEntryCollection()()()()
Members
Icon | Member | Description
 | DsdEntryCollection()()()() |
 | DsdEntryCollection(IntPtr, Boolean) |

Assembly: ZwManaged (Module: ZwManaged)


DsdEntryCollection Constructor

DsdEntryCollection Constructor
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »DsdEntryCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DsdEntryCollection()
Public Sub New
public:
DsdEntryCollection()

Assembly: ZwManaged (Module: ZwManaged)


DsdEntryCollection Constructor (unmanagedPointer, autoDelete)

DsdEntryCollection Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »DsdEntryCollection(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DsdEntryCollection(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
public:
DsdEntryCollection(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Add(
    Object value
)
Public Overridable Function Add ( _
    value As Object _
) As Integer
public:
virtual int Add(
    Object^ value
)
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()

Assembly: ZwManaged (Module: ZwManaged)


Contains Method (value)

Contains Method (value)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Contains(
    Object value
)
Public Overridable Function Contains ( _
    value As Object _
) As Boolean
public:
virtual bool Contains(
    Object^ value
)
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


CopyFromUnmanagedObject Method (unmanagedPointer)

CopyFromUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »CopyFromUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static DsdEntryCollection CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Shared Function CopyFromUnmanagedObject ( _
    unmanagedPointer As IntPtr _
) As DsdEntryCollection
public:
static DsdEntryCollection^ CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (array, size)

CopyTo Method (array, size)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyTo(
    Array array,
    int size
)
Public Overridable Sub CopyTo ( _
    array As Array, _
    size As Integer _
)
public:
virtual void CopyTo(
    Array^ array,
    int size
)
Parameters
array(Array)
size(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()

Assembly: ZwManaged (Module: ZwManaged)


IndexOf Method (value)

IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IndexOf(
    Object value
)
Public Overridable Function IndexOf ( _
    value As Object _
) As Integer
public:
virtual int IndexOf(
    Object^ value
)
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


Insert Method (index, value)

Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Insert(
    int index,
    Object value
)
Public Overridable Sub Insert ( _
    index As Integer, _
    value As Object _
)
public:
virtual void Insert(
    int index,
    Object^ value
)
Parameters
index(Int32)
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object this[
    int index
] { get; set; }
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Remove(
    Object value
)
Public Overridable Sub Remove ( _
    value As Object _
)
public:
virtual void Remove(
    Object^ value
)
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
)
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DsdEntryCollectionEnumerator Class

DsdEntryCollectionEnumerator Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollectionEnumerator
Declaration Syntax
C# Visual Basic Visual C++
public class DsdEntryCollectionEnumerator : IEnumerator
Public Class DsdEntryCollectionEnumerator _
    Implements IEnumerator
public ref class DsdEntryCollectionEnumerator : IEnumerator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DsdEntryCollectionEnumerator(DsdEntryCollection) |
 | Current |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DsdEntryCollectionEnumerator

Assembly: ZwManaged (Module: ZwManaged)


DsdEntryCollectionEnumerator Constructor (collection)

DsdEntryCollectionEnumerator Constructor (collection)
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollectionEnumerator »DsdEntryCollectionEnumerator(DsdEntryCollection)
Declaration Syntax
C# Visual Basic Visual C++
protected internal DsdEntryCollectionEnumerator(
    DsdEntryCollection collection
)
Protected Friend Sub New ( _
    collection As DsdEntryCollection _
)
protected public:
DsdEntryCollectionEnumerator(
    DsdEntryCollection^ collection
)
Parameters
collection(DsdEntryCollection)

Assembly: ZwManaged (Module: ZwManaged)


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollectionEnumerator »Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollectionEnumerator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()

Assembly: ZwManaged (Module: ZwManaged)


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollectionEnumerator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()

Assembly: ZwManaged (Module: ZwManaged)


EndDocumentEventArgs Class

EndDocumentEventArgs Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndDocumentEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class EndDocumentEventArgs : EventArgs
Public Class EndDocumentEventArgs _
    Inherits EventArgs
public ref class EndDocumentEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndDocumentEventArgs(PlotCancelStatus) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | EndDocumentEventArgs

Assembly: ZwManaged (Module: ZwManaged)


EndDocumentEventArgs Constructor (status)

EndDocumentEventArgs Constructor (status)
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndDocumentEventArgs »EndDocumentEventArgs(PlotCancelStatus)
Declaration Syntax
C# Visual Basic Visual C++
public EndDocumentEventArgs(
    PlotCancelStatus status
)
Public Sub New ( _
    status As PlotCancelStatus _
)
public:
EndDocumentEventArgs(
    PlotCancelStatus status
)
Parameters
status(PlotCancelStatus)

Assembly: ZwManaged (Module: ZwManaged)


Status Property

Status Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndDocumentEventArgs »Status
Declaration Syntax
C# Visual Basic Visual C++
public PlotCancelStatus Status { get; }
Public ReadOnly Property Status As PlotCancelStatus
    Get
public:
property PlotCancelStatus Status {
    PlotCancelStatus get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EndDocumentEventHandler Delegate

EndDocumentEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndDocumentEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void EndDocumentEventHandler(
    Object sender,
    EndDocumentEventArgs e
)
Public Delegate Sub EndDocumentEventHandler ( _
    sender As Object, _
    e As EndDocumentEventArgs _
)
public delegate void EndDocumentEventHandler(
    Object^ sender,
    EndDocumentEventArgs^ e
)
Parameters
sender(Object)
e(EndDocumentEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


EndPageEventArgs Class

EndPageEventArgs Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndPageEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class EndPageEventArgs : EventArgs
Public Class EndPageEventArgs _
    Inherits EventArgs
public ref class EndPageEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndPageEventArgs(SheetCancelStatus) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | EndPageEventArgs

Assembly: ZwManaged (Module: ZwManaged)


EndPageEventArgs Constructor (status)

EndPageEventArgs Constructor (status)
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndPageEventArgs »EndPageEventArgs(SheetCancelStatus)
Declaration Syntax
C# Visual Basic Visual C++
public EndPageEventArgs(
    SheetCancelStatus status
)
Public Sub New ( _
    status As SheetCancelStatus _
)
public:
EndPageEventArgs(
    SheetCancelStatus status
)
Parameters
status(SheetCancelStatus)

Assembly: ZwManaged (Module: ZwManaged)


Status Property

Status Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndPageEventArgs »Status
Declaration Syntax
C# Visual Basic Visual C++
public SheetCancelStatus Status { get; }
Public ReadOnly Property Status As SheetCancelStatus
    Get
public:
property SheetCancelStatus Status {
    SheetCancelStatus get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EndPageEventHandler Delegate

EndPageEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndPageEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void EndPageEventHandler(
    Object sender,
    EndPageEventArgs e
)
Public Delegate Sub EndPageEventHandler ( _
    sender As Object, _
    e As EndPageEventArgs _
)
public delegate void EndPageEventHandler(
    Object^ sender,
    EndPageEventArgs^ e
)
Parameters
sender(Object)
e(EndPageEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


EndPlotEventArgs Class

EndPlotEventArgs Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndPlotEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class EndPlotEventArgs : EventArgs
Public Class EndPlotEventArgs _
    Inherits EventArgs
public ref class EndPlotEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndPlotEventArgs(PlotCancelStatus) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | EndPlotEventArgs

Assembly: ZwManaged (Module: ZwManaged)


EndPlotEventArgs Constructor (status)

EndPlotEventArgs Constructor (status)
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndPlotEventArgs »EndPlotEventArgs(PlotCancelStatus)
Declaration Syntax
C# Visual Basic Visual C++
public EndPlotEventArgs(
    PlotCancelStatus status
)
Public Sub New ( _
    status As PlotCancelStatus _
)
public:
EndPlotEventArgs(
    PlotCancelStatus status
)
Parameters
status(PlotCancelStatus)

Assembly: ZwManaged (Module: ZwManaged)


Status Property

Status Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndPlotEventArgs »Status
Declaration Syntax
C# Visual Basic Visual C++
public PlotCancelStatus Status { get; }
Public ReadOnly Property Status As PlotCancelStatus
    Get
public:
property PlotCancelStatus Status {
    PlotCancelStatus get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EndPlotEventHandler Delegate

EndPlotEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.PlottingServices »EndPlotEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void EndPlotEventHandler(
    Object sender,
    EndPlotEventArgs e
)
Public Delegate Sub EndPlotEventHandler ( _
    sender As Object, _
    e As EndPlotEventArgs _
)
public delegate void EndPlotEventHandler(
    Object^ sender,
    EndPlotEventArgs^ e
)
Parameters
sender(Object)
e(EndPlotEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


HostAppServices Class

HostAppServices Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »HostAppServices
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlHostAppServices")]
public sealed class HostAppServices
<WrapperAttribute("AcPlHostAppServices")> _
Public NotInheritable Class HostAppServices
[WrapperAttribute(L"AcPlHostAppServices")]
public ref class HostAppServices sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotLogger |
 | ToString()()()() | (Inherited from Object.)
 | UpdatePlotJobStatus(AppPlotStatus, String) |
Inheritance Hierarchy
Object
HostAppServices

Assembly: ZwManaged (Module: ZwManaged)


PlotLogger Property

PlotLogger Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »HostAppServices »PlotLogger
Declaration Syntax
C# Visual Basic Visual C++
public static PlotLogger PlotLogger { get; }
Public Shared ReadOnly Property PlotLogger As PlotLogger
    Get
public:
static property PlotLogger^ PlotLogger {
    PlotLogger^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


UpdatePlotJobStatus Method (status, message)

UpdatePlotJobStatus Method (status, message)
Namespaces »ZwSoft.ZwCAD.PlottingServices »HostAppServices »UpdatePlotJobStatus(AppPlotStatus, String)
Declaration Syntax
C# Visual Basic Visual C++
public static void UpdatePlotJobStatus(
    AppPlotStatus status,
    string message
)
Public Shared Sub UpdatePlotJobStatus ( _
    status As AppPlotStatus, _
    message As String _
)
public:
static void UpdatePlotJobStatus(
    AppPlotStatus status,
    String^ message
)
Parameters
status(AppPlotStatus)
message(String)

Assembly: ZwManaged (Module: ZwManaged)


MatchingPolicy Enumeration

MatchingPolicy Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »MatchingPolicy
Declaration Syntax
C# Visual Basic Visual C++
public enum MatchingPolicy
Public Enumeration MatchingPolicy
public enum class MatchingPolicy
Members
Member | Description
MatchEnabledTemporaryCustom |
MatchEnabledCustom |
MatchEnabled |
MatchDisabled |

Assembly: ZwManaged (Module: ZwManaged)


MediaBounds Structure

MediaBounds Structure
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds
Declaration Syntax
C# Visual Basic Visual C++
public struct MediaBounds
Public Structure MediaBounds
public value class MediaBounds
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaBounds(Point2d, Point2d, Point2d) |
 | Equality(MediaBounds, MediaBounds) |
 | Equals(Object) | (Overrides ValueType.Equals(Object).)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Overrides ValueType.GetHashCode()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(MediaBounds, MediaBounds) |
 | IsEqualTo(MediaBounds, Tolerance) |
 | IsEqualTo(MediaBounds) |
 | LowerLeftPrintableArea |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PageSize |
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)
 | UpperRightPrintableArea |

Assembly: ZwManaged (Module: ZwManaged)


MediaBounds Constructor (pageSize, lowerLeftPrintableArea, upperRightPrintableArea)

MediaBounds Constructor (pageSize, lowerLeftPrintableArea, upperRightPrintableArea)
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »MediaBounds(Point2d, Point2d, Point2d)
Declaration Syntax
C# Visual Basic Visual C++
public MediaBounds(
    Point2d pageSize,
    Point2d lowerLeftPrintableArea,
    Point2d upperRightPrintableArea
)
Public Sub New ( _
    pageSize As Point2d, _
    lowerLeftPrintableArea As Point2d, _
    upperRightPrintableArea As Point2d _
)
public:
MediaBounds(
    Point2d pageSize,
    Point2d lowerLeftPrintableArea,
    Point2d upperRightPrintableArea
)
Parameters
pageSize(Point2d)
lowerLeftPrintableArea(Point2d)
upperRightPrintableArea(Point2d)

Assembly: ZwManaged (Module: ZwManaged)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »Equality(MediaBounds, MediaBounds)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    MediaBounds a,
    MediaBounds b
)
Public Shared Operator = ( _
    a As MediaBounds, _
    b As MediaBounds _
) As Boolean
public:
static bool operator ==(
    MediaBounds a,
    MediaBounds b
)
Parameters
a(MediaBounds)
b(MediaBounds)

Assembly: ZwManaged (Module: ZwManaged)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override sealed bool Equals(
    Object obj
)
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override sealed
Parameters
obj(Object)

Assembly: ZwManaged (Module: ZwManaged)


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed int GetHashCode()
Public Overrides NotOverridable Function GetHashCode As Integer
public:
virtual int GetHashCode() override sealed

Assembly: ZwManaged (Module: ZwManaged)


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »Inequality(MediaBounds, MediaBounds)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    MediaBounds a,
    MediaBounds b
)
Public Shared Operator <> ( _
    a As MediaBounds, _
    b As MediaBounds _
) As Boolean
public:
static bool operator !=(
    MediaBounds a,
    MediaBounds b
)
Parameters
a(MediaBounds)
b(MediaBounds)

Assembly: ZwManaged (Module: ZwManaged)


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(MediaBounds, Tolerance) |
 | IsEqualTo(MediaBounds) |

Assembly: ZwManaged (Module: ZwManaged)


IsEqualTo Method (a)

IsEqualTo Method (a)
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »IsEqualTo(MediaBounds)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    MediaBounds a
)
Public Function IsEqualTo ( _
    a As MediaBounds _
) As Boolean
public:
bool IsEqualTo(
    MediaBounds a
)
Parameters
a(MediaBounds)

Assembly: ZwManaged (Module: ZwManaged)


IsEqualTo Method (a, tolerance)

IsEqualTo Method (a, tolerance)
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »IsEqualTo(MediaBounds, Tolerance)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEqualTo(
    MediaBounds a,
    Tolerance tolerance
)
Public Function IsEqualTo ( _
    a As MediaBounds, _
    tolerance As Tolerance _
) As Boolean
public:
bool IsEqualTo(
    MediaBounds a,
    Tolerance tolerance
)
Parameters
a(MediaBounds)
tolerance(Tolerance)

Assembly: ZwManaged (Module: ZwManaged)


LowerLeftPrintableArea Property

LowerLeftPrintableArea Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »LowerLeftPrintableArea
Declaration Syntax
C# Visual Basic Visual C++
public Point2d LowerLeftPrintableArea { get; set; }
Public Property LowerLeftPrintableArea As Point2d
    Get
    Set
public:
property Point2d LowerLeftPrintableArea {
    Point2d get ();
    void set (Point2d value);
}

Assembly: ZwManaged (Module: ZwManaged)


PageSize Property

PageSize Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »PageSize
Declaration Syntax
C# Visual Basic Visual C++
public Point2d PageSize { get; set; }
Public Property PageSize As Point2d
    Get
    Set
public:
property Point2d PageSize {
    Point2d get ();
    void set (Point2d value);
}

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides ValueType.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override sealed string ToString()
Public Overrides NotOverridable Function ToString As String
public:
virtual String^ ToString() override sealed

Assembly: ZwManaged (Module: ZwManaged)


ToString Method (provider)

ToString Method (provider)
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »ToString(IFormatProvider)
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider(IFormatProvider)

Assembly: ZwManaged (Module: ZwManaged)


UpperRightPrintableArea Property

UpperRightPrintableArea Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »MediaBounds »UpperRightPrintableArea
Declaration Syntax
C# Visual Basic Visual C++
public Point2d UpperRightPrintableArea { get; set; }
Public Property UpperRightPrintableArea As Point2d
    Get
    Set
public:
property Point2d UpperRightPrintableArea {
    Point2d get ();
    void set (Point2d value);
}

Assembly: ZwManaged (Module: ZwManaged)


MergeStatus Enumeration

MergeStatus Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »MergeStatus
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum MergeStatus
<FlagsAttribute> _
Public Enumeration MergeStatus
[FlagsAttribute]
public enum class MergeStatus
Members
Member | Description
PlotType |
ShadePlotResLevel |
PlotRotation |
PlotPaperUnits |
Scale |
DrawViewportsFirst |
PrintLineWeights |
ScaleLineWeights |
CurrentStyleSheet |
PlotViewName |
PlotWindowArea |
ShadePlotCustomDpi |
ShadePlot |
PlotHidden |
PlotCentered |
ShowPlotStyles |
PlotPlotStyles |
PlotViewportBorders |
PlotOrigin |
CanonicalMediaName |
PlotPaperSize |
PlotPaperMargins |
PlotConfigurationName |
NoChanges |

Assembly: ZwManaged (Module: ZwManaged)


PageCancelledEventHandler Delegate

PageCancelledEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.PlottingServices »PageCancelledEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PageCancelledEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub PageCancelledEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
public delegate void PageCancelledEventHandler(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender(Object)
e(EventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PlotCancelledEventHandler Delegate

PlotCancelledEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotCancelledEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PlotCancelledEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub PlotCancelledEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
public delegate void PlotCancelledEventHandler(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender(Object)
e(EventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PlotCancelStatus Enumeration

PlotCancelStatus Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotCancelStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum PlotCancelStatus
Public Enumeration PlotCancelStatus
public enum class PlotCancelStatus
Members
Member | Description
CancelStatusCount |
CanceledByCancelAllButton |
CanceledByCaller |
Continue |

Assembly: ZwManaged (Module: ZwManaged)


PlotConfig Class

PlotConfig Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlPlotConfig")]
public sealed class PlotConfig : RXObject
<WrapperAttribute("AcPlPlotConfig")> _
Public NotInheritable Class PlotConfig _
    Inherits RXObject
[WrapperAttribute(L"AcPlPlotConfig")]
public ref class PlotConfig sealed : public RXObject
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CanonicalMediaNames |
 | Clone()()()() | (Inherited from RXObject.)
 | Comment |
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyFromUnmanagedObject(IntPtr) |
 | CopyToUnmanagedObject(IntPtr) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DefaultFileExtension |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DeviceName |
 | DeviceType |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DriverName |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | FullPath |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLocalMediaName(String) |
 | GetMediaBounds(String) |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsPlotToFile |
 | LocationName |
 | MaximumDeviceDotsPerInch |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotToFileCapability |
 | PortName |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RefreshMediaNameList()()()() |
 | SaveToPC3(String) |
 | ServerName |
 | TagLine |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | PlotConfig

Assembly: ZwManaged (Module: ZwManaged)


CanonicalMediaNames Property

CanonicalMediaNames Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »CanonicalMediaNames
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection CanonicalMediaNames { get; }
Public ReadOnly Property CanonicalMediaNames As StringCollection
    Get
public:
property StringCollection^ CanonicalMediaNames {
    StringCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Comment Property

Comment Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »Comment
Declaration Syntax
C# Visual Basic Visual C++
public string Comment { get; }
Public ReadOnly Property Comment As String
    Get
public:
property String^ Comment {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


CopyFromUnmanagedObject Method (unmanagedPointer)

CopyFromUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »CopyFromUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static PlotConfig CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Shared Function CopyFromUnmanagedObject ( _
    unmanagedPointer As IntPtr _
) As PlotConfig
public:
static PlotConfig^ CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


CopyToUnmanagedObject Method (unmanagedPointer)

CopyToUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »CopyToUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyToUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Sub CopyToUnmanagedObject ( _
    unmanagedPointer As IntPtr _
)
public:
void CopyToUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


DefaultFileExtension Property

DefaultFileExtension Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »DefaultFileExtension
Declaration Syntax
C# Visual Basic Visual C++
public string DefaultFileExtension { get; }
Public ReadOnly Property DefaultFileExtension As String
    Get
public:
property String^ DefaultFileExtension {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DeviceName Property

DeviceName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »DeviceName
Declaration Syntax
C# Visual Basic Visual C++
public string DeviceName { get; }
Public ReadOnly Property DeviceName As String
    Get
public:
property String^ DeviceName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DeviceType Property

DeviceType Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »DeviceType
Declaration Syntax
C# Visual Basic Visual C++
public int DeviceType { get; }
Public ReadOnly Property DeviceType As Integer
    Get
public:
property int DeviceType {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DriverName Property

DriverName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »DriverName
Declaration Syntax
C# Visual Basic Visual C++
public string DriverName { get; }
Public ReadOnly Property DriverName As String
    Get
public:
property String^ DriverName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


FullPath Property

FullPath Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »FullPath
Declaration Syntax
C# Visual Basic Visual C++
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get
public:
property String^ FullPath {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GetLocalMediaName Method (canonicalMediaName)

GetLocalMediaName Method (canonicalMediaName)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »GetLocalMediaName(String)
Declaration Syntax
C# Visual Basic Visual C++
public string GetLocalMediaName(
    string canonicalMediaName
)
Public Function GetLocalMediaName ( _
    canonicalMediaName As String _
) As String
public:
String^ GetLocalMediaName(
    String^ canonicalMediaName
)
Parameters
canonicalMediaName(String)

Assembly: ZwManaged (Module: ZwManaged)


GetMediaBounds Method (canonicalMediaName)

GetMediaBounds Method (canonicalMediaName)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »GetMediaBounds(String)
Declaration Syntax
C# Visual Basic Visual C++
public MediaBounds GetMediaBounds(
    string canonicalMediaName
)
Public Function GetMediaBounds ( _
    canonicalMediaName As String _
) As MediaBounds
public:
MediaBounds GetMediaBounds(
    String^ canonicalMediaName
)
Parameters
canonicalMediaName(String)

Assembly: ZwManaged (Module: ZwManaged)


IsPlotToFile Property

IsPlotToFile Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »IsPlotToFile
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPlotToFile { get; set; }
Public Property IsPlotToFile As Boolean
    Get
    Set
public:
property bool IsPlotToFile {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


LocationName Property

LocationName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »LocationName
Declaration Syntax
C# Visual Basic Visual C++
public string LocationName { get; }
Public ReadOnly Property LocationName As String
    Get
public:
property String^ LocationName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MaximumDeviceDotsPerInch Property

MaximumDeviceDotsPerInch Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »MaximumDeviceDotsPerInch
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumDeviceDotsPerInch { get; }
Public ReadOnly Property MaximumDeviceDotsPerInch As Integer
    Get
public:
property int MaximumDeviceDotsPerInch {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotToFileCapability Property

PlotToFileCapability Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »PlotToFileCapability
Declaration Syntax
C# Visual Basic Visual C++
public PlotToFileCapability PlotToFileCapability { get; }
Public ReadOnly Property PlotToFileCapability As PlotToFileCapability
    Get
public:
property PlotToFileCapability PlotToFileCapability {
    PlotToFileCapability get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PortName Property

PortName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »PortName
Declaration Syntax
C# Visual Basic Visual C++
public string PortName { get; }
Public ReadOnly Property PortName As String
    Get
public:
property String^ PortName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


RefreshMediaNameList Method

RefreshMediaNameList Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »RefreshMediaNameList()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RefreshMediaNameList()
Public Sub RefreshMediaNameList
public:
void RefreshMediaNameList()

Assembly: ZwManaged (Module: ZwManaged)


SaveToPC3 Method (name)

SaveToPC3 Method (name)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »SaveToPC3(String)
Declaration Syntax
C# Visual Basic Visual C++
public void SaveToPC3(
    string name
)
Public Sub SaveToPC3 ( _
    name As String _
)
public:
void SaveToPC3(
    String^ name
)
Parameters
name(String)

Assembly: ZwManaged (Module: ZwManaged)


ServerName Property

ServerName Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »ServerName
Declaration Syntax
C# Visual Basic Visual C++
public string ServerName { get; }
Public ReadOnly Property ServerName As String
    Get
public:
property String^ ServerName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


TagLine Property

TagLine Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »TagLine
Declaration Syntax
C# Visual Basic Visual C++
public string TagLine { get; }
Public ReadOnly Property TagLine As String
    Get
public:
property String^ TagLine {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotConfigManager Class

PlotConfigManager Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfigManager
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlPlotConfigManager")]
public sealed class PlotConfigManager
<WrapperAttribute("AcPlPlotConfigManager")> _
Public NotInheritable Class PlotConfigManager
[WrapperAttribute(L"AcPlPlotConfigManager")]
public ref class PlotConfigManager sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ColorDependentPlotStyles |
 | CurrentConfig |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NamedPlotStyles |
 | RefreshList(RefreshCode) |
 | SetCurrentConfig(String) |
 | StdConfigNames[([( StdConfiguration])]) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PlotConfigManager

Assembly: ZwManaged (Module: ZwManaged)


ColorDependentPlotStyles Property

ColorDependentPlotStyles Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfigManager »ColorDependentPlotStyles
Declaration Syntax
C# Visual Basic Visual C++
public static StringCollection ColorDependentPlotStyles { get; }
Public Shared ReadOnly Property ColorDependentPlotStyles As StringCollection
    Get
public:
static property StringCollection^ ColorDependentPlotStyles {
    StringCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


CurrentConfig Property

CurrentConfig Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfigManager »CurrentConfig
Declaration Syntax
C# Visual Basic Visual C++
public static PlotConfig CurrentConfig { get; }
Public Shared ReadOnly Property CurrentConfig As PlotConfig
    Get
public:
static property PlotConfig^ CurrentConfig {
    PlotConfig^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


NamedPlotStyles Property

NamedPlotStyles Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfigManager »NamedPlotStyles
Declaration Syntax
C# Visual Basic Visual C++
public static StringCollection NamedPlotStyles { get; }
Public Shared ReadOnly Property NamedPlotStyles As StringCollection
    Get
public:
static property StringCollection^ NamedPlotStyles {
    StringCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


RefreshList Method (refreshCode)

RefreshList Method (refreshCode)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfigManager »RefreshList(RefreshCode)
Declaration Syntax
C# Visual Basic Visual C++
public static void RefreshList(
    RefreshCode refreshCode
)
Public Shared Sub RefreshList ( _
    refreshCode As RefreshCode _
)
public:
static void RefreshList(
    RefreshCode refreshCode
)
Parameters
refreshCode(RefreshCode)

Assembly: ZwManaged (Module: ZwManaged)


SetCurrentConfig Method (deviceName)

SetCurrentConfig Method (deviceName)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfigManager »SetCurrentConfig(String)
Declaration Syntax
C# Visual Basic Visual C++
public static PlotConfig SetCurrentConfig(
    string deviceName
)
Public Shared Function SetCurrentConfig ( _
    deviceName As String _
) As PlotConfig
public:
static PlotConfig^ SetCurrentConfig(
    String^ deviceName
)
Parameters
deviceName(String)

Assembly: ZwManaged (Module: ZwManaged)


StdConfigNames Property (config)

StdConfigNames Property (config)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfigManager »StdConfigNames[([( StdConfiguration])])
Declaration Syntax
C# Visual Basic Visual C++
public static string this[
    StdConfiguration config
] { get; }
Public Shared ReadOnly Property StdConfigNames ( _
    config As StdConfiguration _
) As String
    Get
public:
static property String^ StdConfigNames[StdConfiguration config] {
    String^ get (StdConfiguration config);
}
Parameters
config(StdConfiguration)

Assembly: ZwManaged (Module: ZwManaged)


PlotEngine Class

PlotEngine Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlPlotEngine")]
public class PlotEngine : DisposableWrapper
<WrapperAttribute("AcPlPlotEngine")> _
Public Class PlotEngine _
    Inherits DisposableWrapper
[WrapperAttribute(L"AcPlPlotEngine")]
public ref class PlotEngine : public DisposableWrapper
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | BeginDocument(PlotInfo, String, Object, Int32, Boolean, String) |
 | BeginGenerateGraphics(Object) |
 | BeginPage(PlotPageInfo, PlotInfo, Boolean, Object) |
 | BeginPlot(PlotProgress, Object) |
 | CopyFromUnmanagedObject(IntPtr) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Destroy()()()() |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndDocument(Object) |
 | EndGenerateGraphics(Object) |
 | EndPage(Object) |
 | EndPlot(Object) |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsBackgroundPackaging |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | PlotEngine

Assembly: ZwManaged (Module: ZwManaged)


BeginDocument Method (plotInfo, documentName, parameters, copies, plotToFile, fileName)

BeginDocument Method (plotInfo, documentName, parameters, copies, plotToFile, fileName)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »BeginDocument(PlotInfo, String, Object, Int32, Boolean, String)
Declaration Syntax
C# Visual Basic Visual C++
public void BeginDocument(
    PlotInfo plotInfo,
    string documentName,
    Object parameters,
    int copies,
    bool plotToFile,
    string fileName
)
Public Sub BeginDocument ( _
    plotInfo As PlotInfo, _
    documentName As String, _
    parameters As Object, _
    copies As Integer, _
    plotToFile As Boolean, _
    fileName As String _
)
public:
void BeginDocument(
    PlotInfo^ plotInfo,
    String^ documentName,
    Object^ parameters,
    int copies,
    bool plotToFile,
    String^ fileName
)
Parameters
plotInfo(PlotInfo)
documentName(String)
parameters(Object)
copies(Int32)
plotToFile(Boolean)
fileName(String)

Assembly: ZwManaged (Module: ZwManaged)


BeginGenerateGraphics Method (parameters)

BeginGenerateGraphics Method (parameters)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »BeginGenerateGraphics(Object)
Declaration Syntax
C# Visual Basic Visual C++
public void BeginGenerateGraphics(
    Object parameters
)
Public Sub BeginGenerateGraphics ( _
    parameters As Object _
)
public:
void BeginGenerateGraphics(
    Object^ parameters
)
Parameters
parameters(Object)

Assembly: ZwManaged (Module: ZwManaged)


BeginPage Method (pageInfo, plotInfo, lastPage, parameters)

BeginPage Method (pageInfo, plotInfo, lastPage, parameters)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »BeginPage(PlotPageInfo, PlotInfo, Boolean, Object)
Declaration Syntax
C# Visual Basic Visual C++
public void BeginPage(
    PlotPageInfo pageInfo,
    PlotInfo plotInfo,
    bool lastPage,
    Object parameters
)
Public Sub BeginPage ( _
    pageInfo As PlotPageInfo, _
    plotInfo As PlotInfo, _
    lastPage As Boolean, _
    parameters As Object _
)
public:
void BeginPage(
    PlotPageInfo^ pageInfo,
    PlotInfo^ plotInfo,
    bool lastPage,
    Object^ parameters
)
Parameters
pageInfo(PlotPageInfo)
plotInfo(PlotInfo)
lastPage(Boolean)
parameters(Object)

Assembly: ZwManaged (Module: ZwManaged)


BeginPlot Method (plotProgress, parameters)

BeginPlot Method (plotProgress, parameters)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »BeginPlot(PlotProgress, Object)
Declaration Syntax
C# Visual Basic Visual C++
public void BeginPlot(
    PlotProgress plotProgress,
    Object parameters
)
Public Sub BeginPlot ( _
    plotProgress As PlotProgress, _
    parameters As Object _
)
public:
void BeginPlot(
    PlotProgress^ plotProgress,
    Object^ parameters
)
Parameters
plotProgress(PlotProgress)
parameters(Object)

Assembly: ZwManaged (Module: ZwManaged)


CopyFromUnmanagedObject Method (unmanagedPointer)

CopyFromUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »CopyFromUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static PlotEngine CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Shared Function CopyFromUnmanagedObject ( _
    unmanagedPointer As IntPtr _
) As PlotEngine
public:
static PlotEngine^ CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override

Assembly: ZwManaged (Module: ZwManaged)


Destroy Method

Destroy Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »Destroy()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Destroy()
Public Sub Destroy
public:
void Destroy()

Assembly: ZwManaged (Module: ZwManaged)


EndDocument Method (parameters)

EndDocument Method (parameters)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »EndDocument(Object)
Declaration Syntax
C# Visual Basic Visual C++
public void EndDocument(
    Object parameters
)
Public Sub EndDocument ( _
    parameters As Object _
)
public:
void EndDocument(
    Object^ parameters
)
Parameters
parameters(Object)

Assembly: ZwManaged (Module: ZwManaged)


EndGenerateGraphics Method (parameters)

EndGenerateGraphics Method (parameters)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »EndGenerateGraphics(Object)
Declaration Syntax
C# Visual Basic Visual C++
public void EndGenerateGraphics(
    Object parameters
)
Public Sub EndGenerateGraphics ( _
    parameters As Object _
)
public:
void EndGenerateGraphics(
    Object^ parameters
)
Parameters
parameters(Object)

Assembly: ZwManaged (Module: ZwManaged)


EndPage Method (parameters)

EndPage Method (parameters)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »EndPage(Object)
Declaration Syntax
C# Visual Basic Visual C++
public void EndPage(
    Object parameters
)
Public Sub EndPage ( _
    parameters As Object _
)
public:
void EndPage(
    Object^ parameters
)
Parameters
parameters(Object)

Assembly: ZwManaged (Module: ZwManaged)


EndPlot Method (parameters)

EndPlot Method (parameters)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »EndPlot(Object)
Declaration Syntax
C# Visual Basic Visual C++
public void EndPlot(
    Object parameters
)
Public Sub EndPlot ( _
    parameters As Object _
)
public:
void EndPlot(
    Object^ parameters
)
Parameters
parameters(Object)

Assembly: ZwManaged (Module: ZwManaged)


IsBackgroundPackaging Property

IsBackgroundPackaging Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »IsBackgroundPackaging
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBackgroundPackaging { get; }
Public ReadOnly Property IsBackgroundPackaging As Boolean
    Get
public:
property bool IsBackgroundPackaging {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotFactory Class

PlotFactory Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotFactory
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlPlotFactory")]
public sealed class PlotFactory
<WrapperAttribute("AcPlPlotFactory")> _
Public NotInheritable Class PlotFactory
[WrapperAttribute(L"AcPlPlotFactory")]
public ref class PlotFactory sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreatePreviewEngine(Int32) |
 | CreatePublishEngine()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProcessPlotState |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PlotFactory

Assembly: ZwManaged (Module: ZwManaged)


CreatePreviewEngine Method (nPreviewFlags)

CreatePreviewEngine Method (nPreviewFlags)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotFactory »CreatePreviewEngine(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static PlotEngine CreatePreviewEngine(
    int nPreviewFlags
)
Public Shared Function CreatePreviewEngine ( _
    nPreviewFlags As Integer _
) As PlotEngine
public:
static PlotEngine^ CreatePreviewEngine(
    int nPreviewFlags
)
Parameters
nPreviewFlags(Int32)

Assembly: ZwManaged (Module: ZwManaged)


CreatePublishEngine Method

CreatePublishEngine Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotFactory »CreatePublishEngine()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static PlotEngine CreatePublishEngine()
Public Shared Function CreatePublishEngine As PlotEngine
public:
static PlotEngine^ CreatePublishEngine()

Assembly: ZwManaged (Module: ZwManaged)


ProcessPlotState Property

ProcessPlotState Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotFactory »ProcessPlotState
Declaration Syntax
C# Visual Basic Visual C++
public static ProcessPlotState ProcessPlotState { get; }
Public Shared ReadOnly Property ProcessPlotState As ProcessPlotState
    Get
public:
static property ProcessPlotState ProcessPlotState {
    ProcessPlotState get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotInfo Class

PlotInfo Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlPlotInfo")]
public sealed class PlotInfo : RXObject
<WrapperAttribute("AcPlPlotInfo")> _
Public NotInheritable Class PlotInfo _
    Inherits RXObject
[WrapperAttribute(L"AcPlPlotInfo")]
public ref class PlotInfo sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlotInfo()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyFromUnmanagedObject(IntPtr) |
 | CopyToUnmanagedObject(IntPtr) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DeviceOverride |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsCompatibleDocument(PlotInfo) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsValidated |
 | Layout |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MergeStatus |
 | OverrideSettings |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | ValidatedConfig |
 | ValidatedSettings |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | PlotInfo

Assembly: ZwManaged (Module: ZwManaged)


PlotInfo Constructor

PlotInfo Constructor
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »PlotInfo()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PlotInfo()
Public Sub New
public:
PlotInfo()

Assembly: ZwManaged (Module: ZwManaged)


CopyFromUnmanagedObject Method (unmanagedPointer)

CopyFromUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »CopyFromUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static PlotInfo CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Shared Function CopyFromUnmanagedObject ( _
    unmanagedPointer As IntPtr _
) As PlotInfo
public:
static PlotInfo^ CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


CopyToUnmanagedObject Method (unmanagedPointer)

CopyToUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »CopyToUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyToUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Sub CopyToUnmanagedObject ( _
    unmanagedPointer As IntPtr _
)
public:
void CopyToUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


DeviceOverride Property

DeviceOverride Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »DeviceOverride
Declaration Syntax
C# Visual Basic Visual C++
public PlotConfig DeviceOverride { get; set; }
Public Property DeviceOverride As PlotConfig
    Get
    Set
public:
property PlotConfig^ DeviceOverride {
    PlotConfig^ get ();
    void set (PlotConfig^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


IsCompatibleDocument Method (info)

IsCompatibleDocument Method (info)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »IsCompatibleDocument(PlotInfo)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCompatibleDocument(
    PlotInfo info
)
Public Function IsCompatibleDocument ( _
    info As PlotInfo _
) As Boolean
public:
bool IsCompatibleDocument(
    PlotInfo^ info
)
Parameters
info(PlotInfo)

Assembly: ZwManaged (Module: ZwManaged)


IsValidated Property

IsValidated Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »IsValidated
Declaration Syntax
C# Visual Basic Visual C++
public bool IsValidated { get; }
Public ReadOnly Property IsValidated As Boolean
    Get
public:
property bool IsValidated {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Layout Property

Layout Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »Layout
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Layout { get; set; }
Public Property Layout As ObjectId
    Get
    Set
public:
property ObjectId Layout {
    ObjectId get ();
    void set (ObjectId value);
}

Assembly: ZwManaged (Module: ZwManaged)


MergeStatus Property

MergeStatus Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »MergeStatus
Declaration Syntax
C# Visual Basic Visual C++
public int MergeStatus { get; }
Public ReadOnly Property MergeStatus As Integer
    Get
public:
property int MergeStatus {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OverrideSettings Property

OverrideSettings Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »OverrideSettings
Declaration Syntax
C# Visual Basic Visual C++
public PlotSettings OverrideSettings { get; set; }
Public Property OverrideSettings As PlotSettings
    Get
    Set
public:
property PlotSettings^ OverrideSettings {
    PlotSettings^ get ();
    void set (PlotSettings^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


ValidatedConfig Property

ValidatedConfig Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »ValidatedConfig
Declaration Syntax
C# Visual Basic Visual C++
public PlotConfig ValidatedConfig { get; set; }
Public Property ValidatedConfig As PlotConfig
    Get
    Set
public:
property PlotConfig^ ValidatedConfig {
    PlotConfig^ get ();
    void set (PlotConfig^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


ValidatedSettings Property

ValidatedSettings Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »ValidatedSettings
Declaration Syntax
C# Visual Basic Visual C++
public PlotSettings ValidatedSettings { get; set; }
Public Property ValidatedSettings As PlotSettings
    Get
    Set
public:
property PlotSettings^ ValidatedSettings {
    PlotSettings^ get ();
    void set (PlotSettings^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PlotInfoValidator Class

PlotInfoValidator Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlPlotInfoValidator")]
public sealed class PlotInfoValidator : RXObject
<WrapperAttribute("AcPlPlotInfoValidator")> _
Public NotInheritable Class PlotInfoValidator _
    Inherits RXObject
[WrapperAttribute(L"AcPlPlotInfoValidator")]
public ref class PlotInfoValidator sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlotInfoValidator()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyFromUnmanagedObject(IntPtr) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DimensionalWeight |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsCustomPossible(PlotInfo) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MediaBoundsWeight |
 | MediaGroupWeight |
 | MediaMatchingPolicy |
 | MediaMatchingThreshold |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PrintableBoundsWeight |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SheetDimensionalWeight |
 | SheetMediaGroupWeight |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Validate(PlotInfo) |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | PlotInfoValidator

Assembly: ZwManaged (Module: ZwManaged)


PlotInfoValidator Constructor

PlotInfoValidator Constructor
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »PlotInfoValidator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PlotInfoValidator()
Public Sub New
public:
PlotInfoValidator()

Assembly: ZwManaged (Module: ZwManaged)


CopyFromUnmanagedObject Method (unmanagedPointer)

CopyFromUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »CopyFromUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static PlotInfoValidator CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Shared Function CopyFromUnmanagedObject ( _
    unmanagedPointer As IntPtr _
) As PlotInfoValidator
public:
static PlotInfoValidator^ CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


DimensionalWeight Property

DimensionalWeight Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »DimensionalWeight
Declaration Syntax
C# Visual Basic Visual C++
public int DimensionalWeight { get; set; }
Public Property DimensionalWeight As Integer
    Get
    Set
public:
property int DimensionalWeight {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


IsCustomPossible Method (info)

IsCustomPossible Method (info)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »IsCustomPossible(PlotInfo)
Declaration Syntax
C# Visual Basic Visual C++
public int IsCustomPossible(
    PlotInfo info
)
Public Function IsCustomPossible ( _
    info As PlotInfo _
) As Integer
public:
int IsCustomPossible(
    PlotInfo^ info
)
Parameters
info(PlotInfo)

Assembly: ZwManaged (Module: ZwManaged)


MediaBoundsWeight Property

MediaBoundsWeight Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »MediaBoundsWeight
Declaration Syntax
C# Visual Basic Visual C++
public int MediaBoundsWeight { get; set; }
Public Property MediaBoundsWeight As Integer
    Get
    Set
public:
property int MediaBoundsWeight {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


MediaGroupWeight Property

MediaGroupWeight Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »MediaGroupWeight
Declaration Syntax
C# Visual Basic Visual C++
public int MediaGroupWeight { get; set; }
Public Property MediaGroupWeight As Integer
    Get
    Set
public:
property int MediaGroupWeight {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


MediaMatchingPolicy Property

MediaMatchingPolicy Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »MediaMatchingPolicy
Declaration Syntax
C# Visual Basic Visual C++
public MatchingPolicy MediaMatchingPolicy { get; set; }
Public Property MediaMatchingPolicy As MatchingPolicy
    Get
    Set
public:
property MatchingPolicy MediaMatchingPolicy {
    MatchingPolicy get ();
    void set (MatchingPolicy value);
}

Assembly: ZwManaged (Module: ZwManaged)


MediaMatchingThreshold Property

MediaMatchingThreshold Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »MediaMatchingThreshold
Declaration Syntax
C# Visual Basic Visual C++
public int MediaMatchingThreshold { get; set; }
Public Property MediaMatchingThreshold As Integer
    Get
    Set
public:
property int MediaMatchingThreshold {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


PrintableBoundsWeight Property

PrintableBoundsWeight Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »PrintableBoundsWeight
Declaration Syntax
C# Visual Basic Visual C++
public int PrintableBoundsWeight { get; set; }
Public Property PrintableBoundsWeight As Integer
    Get
    Set
public:
property int PrintableBoundsWeight {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


SheetDimensionalWeight Property

SheetDimensionalWeight Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »SheetDimensionalWeight
Declaration Syntax
C# Visual Basic Visual C++
public int SheetDimensionalWeight { get; set; }
Public Property SheetDimensionalWeight As Integer
    Get
    Set
public:
property int SheetDimensionalWeight {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


SheetMediaGroupWeight Property

SheetMediaGroupWeight Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »SheetMediaGroupWeight
Declaration Syntax
C# Visual Basic Visual C++
public int SheetMediaGroupWeight { get; set; }
Public Property SheetMediaGroupWeight As Integer
    Get
    Set
public:
property int SheetMediaGroupWeight {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


Validate Method (info)

Validate Method (info)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »Validate(PlotInfo)
Declaration Syntax
C# Visual Basic Visual C++
public void Validate(
    PlotInfo info
)
Public Sub Validate ( _
    info As PlotInfo _
)
public:
void Validate(
    PlotInfo^ info
)
Parameters
info(PlotInfo)

Assembly: ZwManaged (Module: ZwManaged)


PlotLogger Class

PlotLogger Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlPlotLogger")]
public class PlotLogger : DisposableWrapper
<WrapperAttribute("AcPlPlotLogger")> _
Public Class PlotLogger _
    Inherits DisposableWrapper
[WrapperAttribute(L"AcPlPlotLogger")]
public ref class PlotLogger : public DisposableWrapper
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EndJob()()()() |
 | EndSheet()()()() |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | ErrorHasHappenedInJob |
 | ErrorHasHappenedInSheet |
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | LogAbortRetryIgnoreError(String) |
 | LogError(String) |
 | LogInformation(String) |
 | LogMessage(String) |
 | LogSevereError(String) |
 | LogTerminalError(String) |
 | LogWarning(String) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | StartJob()()()() |
 | StartSheet()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | WarningHasHappenedInJob |
 | WarningHasHappenedInSheet |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | PlotLogger

Assembly: ZwManaged (Module: ZwManaged)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override

Assembly: ZwManaged (Module: ZwManaged)


EndJob Method

EndJob Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »EndJob()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void EndJob()
Public Sub EndJob
public:
void EndJob()

Assembly: ZwManaged (Module: ZwManaged)


EndSheet Method

EndSheet Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »EndSheet()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void EndSheet()
Public Sub EndSheet
public:
void EndSheet()

Assembly: ZwManaged (Module: ZwManaged)


ErrorHasHappenedInJob Property

ErrorHasHappenedInJob Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »ErrorHasHappenedInJob
Declaration Syntax
C# Visual Basic Visual C++
public bool ErrorHasHappenedInJob { get; }
Public ReadOnly Property ErrorHasHappenedInJob As Boolean
    Get
public:
property bool ErrorHasHappenedInJob {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ErrorHasHappenedInSheet Property

ErrorHasHappenedInSheet Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »ErrorHasHappenedInSheet
Declaration Syntax
C# Visual Basic Visual C++
public bool ErrorHasHappenedInSheet { get; }
Public ReadOnly Property ErrorHasHappenedInSheet As Boolean
    Get
public:
property bool ErrorHasHappenedInSheet {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LogAbortRetryIgnoreError Method (message)

LogAbortRetryIgnoreError Method (message)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »LogAbortRetryIgnoreError(String)
Declaration Syntax
C# Visual Basic Visual C++
public void LogAbortRetryIgnoreError(
    string message
)
Public Sub LogAbortRetryIgnoreError ( _
    message As String _
)
public:
void LogAbortRetryIgnoreError(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


LogError Method (message)

LogError Method (message)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »LogError(String)
Declaration Syntax
C# Visual Basic Visual C++
public void LogError(
    string message
)
Public Sub LogError ( _
    message As String _
)
public:
void LogError(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


LogInformation Method (message)

LogInformation Method (message)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »LogInformation(String)
Declaration Syntax
C# Visual Basic Visual C++
public void LogInformation(
    string message
)
Public Sub LogInformation ( _
    message As String _
)
public:
void LogInformation(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


LogMessage Method (message)

LogMessage Method (message)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »LogMessage(String)
Declaration Syntax
C# Visual Basic Visual C++
public void LogMessage(
    string message
)
Public Sub LogMessage ( _
    message As String _
)
public:
void LogMessage(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


LogSevereError Method (message)

LogSevereError Method (message)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »LogSevereError(String)
Declaration Syntax
C# Visual Basic Visual C++
public void LogSevereError(
    string message
)
Public Sub LogSevereError ( _
    message As String _
)
public:
void LogSevereError(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


LogTerminalError Method (message)

LogTerminalError Method (message)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »LogTerminalError(String)
Declaration Syntax
C# Visual Basic Visual C++
public void LogTerminalError(
    string message
)
Public Sub LogTerminalError ( _
    message As String _
)
public:
void LogTerminalError(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


LogWarning Method (message)

LogWarning Method (message)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »LogWarning(String)
Declaration Syntax
C# Visual Basic Visual C++
public void LogWarning(
    string message
)
Public Sub LogWarning ( _
    message As String _
)
public:
void LogWarning(
    String^ message
)
Parameters
message(String)

Assembly: ZwManaged (Module: ZwManaged)


StartJob Method

StartJob Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »StartJob()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void StartJob()
Public Sub StartJob
public:
void StartJob()

Assembly: ZwManaged (Module: ZwManaged)


StartSheet Method

StartSheet Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »StartSheet()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void StartSheet()
Public Sub StartSheet
public:
void StartSheet()

Assembly: ZwManaged (Module: ZwManaged)


WarningHasHappenedInJob Property

WarningHasHappenedInJob Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »WarningHasHappenedInJob
Declaration Syntax
C# Visual Basic Visual C++
public bool WarningHasHappenedInJob { get; }
Public ReadOnly Property WarningHasHappenedInJob As Boolean
    Get
public:
property bool WarningHasHappenedInJob {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


WarningHasHappenedInSheet Property

WarningHasHappenedInSheet Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »WarningHasHappenedInSheet
Declaration Syntax
C# Visual Basic Visual C++
public bool WarningHasHappenedInSheet { get; }
Public ReadOnly Property WarningHasHappenedInSheet As Boolean
    Get
public:
property bool WarningHasHappenedInSheet {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotMessageIndex Enumeration

PlotMessageIndex Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotMessageIndex
Declaration Syntax
C# Visual Basic Visual C++
public enum PlotMessageIndex
Public Enumeration PlotMessageIndex
public enum class PlotMessageIndex
Members
Member | Description
MessageCount |
CancelJobButtonMessage |
CancelSheetButtonMessage |
MessageCancelingCurrent |
MessageCanceling |
SheetSetProgressCaption |
SheetProgressCaption |
SheetNameToolTip |
SheetName |
DialogTitle |
Status |

Assembly: ZwManaged (Module: ZwManaged)


PlotPageInfo Class

PlotPageInfo Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotPageInfo
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlPlotPageInfo")]
public sealed class PlotPageInfo : RXObject
<WrapperAttribute("AcPlPlotPageInfo")> _
Public NotInheritable Class PlotPageInfo _
    Inherits RXObject
[WrapperAttribute(L"AcPlPlotPageInfo")]
public ref class PlotPageInfo sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlotPageInfo()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyFromUnmanagedObject(IntPtr) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | EntityCount |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | GradientCount |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OleObjectCount |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | RasterCount |
 | ShadedViewportType |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | PlotPageInfo

Assembly: ZwManaged (Module: ZwManaged)


PlotPageInfo Constructor

PlotPageInfo Constructor
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotPageInfo »PlotPageInfo()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PlotPageInfo()
Public Sub New
public:
PlotPageInfo()

Assembly: ZwManaged (Module: ZwManaged)


CopyFromUnmanagedObject Method (unmanagedPointer)

CopyFromUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotPageInfo »CopyFromUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static PlotPageInfo CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Shared Function CopyFromUnmanagedObject ( _
    unmanagedPointer As IntPtr _
) As PlotPageInfo
public:
static PlotPageInfo^ CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


EntityCount Property

EntityCount Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotPageInfo »EntityCount
Declaration Syntax
C# Visual Basic Visual C++
public int EntityCount { get; }
Public ReadOnly Property EntityCount As Integer
    Get
public:
property int EntityCount {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GradientCount Property

GradientCount Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotPageInfo »GradientCount
Declaration Syntax
C# Visual Basic Visual C++
public int GradientCount { get; }
Public ReadOnly Property GradientCount As Integer
    Get
public:
property int GradientCount {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OleObjectCount Property

OleObjectCount Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotPageInfo »OleObjectCount
Declaration Syntax
C# Visual Basic Visual C++
public int OleObjectCount { get; }
Public ReadOnly Property OleObjectCount As Integer
    Get
public:
property int OleObjectCount {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


RasterCount Property

RasterCount Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotPageInfo »RasterCount
Declaration Syntax
C# Visual Basic Visual C++
public int RasterCount { get; }
Public ReadOnly Property RasterCount As Integer
    Get
public:
property int RasterCount {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ShadedViewportType Property

ShadedViewportType Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotPageInfo »ShadedViewportType
Declaration Syntax
C# Visual Basic Visual C++
public int ShadedViewportType { get; }
Public ReadOnly Property ShadedViewportType As Integer
    Get
public:
property int ShadedViewportType {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotProgress Class

PlotProgress Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlPlotProgress")]
public class PlotProgress : DisposableWrapper
<WrapperAttribute("AcPlPlotProgress")> _
Public Class PlotProgress _
    Inherits DisposableWrapper
[WrapperAttribute(L"AcPlPlotProgress")]
public ref class PlotProgress : public DisposableWrapper
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Heartbeat()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsPlotCancelled |
 | IsSheetCancelled |
 | IsVisible |
 | LowerPlotProgressRange |
 | LowerSheetProgressRange |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotCancelStatus |
 | PlotProgressPos |
 | SheetCancelStatus |
 | SheetProgressPos |
 | StatusMsgString |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpperPlotProgressRange |
 | UpperSheetProgressRange |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | PlotProgress
 |  |  |  | PlotProgressDialog

Assembly: ZwManaged (Module: ZwManaged)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override

Assembly: ZwManaged (Module: ZwManaged)


Heartbeat Method

Heartbeat Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »Heartbeat()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Heartbeat()
Public Sub Heartbeat
public:
void Heartbeat()

Assembly: ZwManaged (Module: ZwManaged)


IsPlotCancelled Property

IsPlotCancelled Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »IsPlotCancelled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPlotCancelled { get; }
Public ReadOnly Property IsPlotCancelled As Boolean
    Get
public:
property bool IsPlotCancelled {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsSheetCancelled Property

IsSheetCancelled Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »IsSheetCancelled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSheetCancelled { get; }
Public ReadOnly Property IsSheetCancelled As Boolean
    Get
public:
property bool IsSheetCancelled {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsVisible Property

IsVisible Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »IsVisible
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible { get; set; }
Public Property IsVisible As Boolean
    Get
    Set
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


LowerPlotProgressRange Property

LowerPlotProgressRange Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »LowerPlotProgressRange
Declaration Syntax
C# Visual Basic Visual C++
public int LowerPlotProgressRange { get; set; }
Public Property LowerPlotProgressRange As Integer
    Get
    Set
public:
property int LowerPlotProgressRange {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


LowerSheetProgressRange Property

LowerSheetProgressRange Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »LowerSheetProgressRange
Declaration Syntax
C# Visual Basic Visual C++
public int LowerSheetProgressRange { get; set; }
Public Property LowerSheetProgressRange As Integer
    Get
    Set
public:
property int LowerSheetProgressRange {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


PlotCancelStatus Property

PlotCancelStatus Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »PlotCancelStatus
Declaration Syntax
C# Visual Basic Visual C++
public PlotCancelStatus PlotCancelStatus { get; set; }
Public Property PlotCancelStatus As PlotCancelStatus
    Get
    Set
public:
property PlotCancelStatus PlotCancelStatus {
    PlotCancelStatus get ();
    void set (PlotCancelStatus value);
}

Assembly: ZwManaged (Module: ZwManaged)


PlotProgressPos Property

PlotProgressPos Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »PlotProgressPos
Declaration Syntax
C# Visual Basic Visual C++
public int PlotProgressPos { get; set; }
Public Property PlotProgressPos As Integer
    Get
    Set
public:
property int PlotProgressPos {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


SheetCancelStatus Property

SheetCancelStatus Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »SheetCancelStatus
Declaration Syntax
C# Visual Basic Visual C++
public SheetCancelStatus SheetCancelStatus { get; set; }
Public Property SheetCancelStatus As SheetCancelStatus
    Get
    Set
public:
property SheetCancelStatus SheetCancelStatus {
    SheetCancelStatus get ();
    void set (SheetCancelStatus value);
}

Assembly: ZwManaged (Module: ZwManaged)


SheetProgressPos Property

SheetProgressPos Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »SheetProgressPos
Declaration Syntax
C# Visual Basic Visual C++
public int SheetProgressPos { get; set; }
Public Property SheetProgressPos As Integer
    Get
    Set
public:
property int SheetProgressPos {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


StatusMsgString Property

StatusMsgString Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »StatusMsgString
Declaration Syntax
C# Visual Basic Visual C++
public string StatusMsgString { get; set; }
Public Property StatusMsgString As String
    Get
    Set
public:
property String^ StatusMsgString {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


UpperPlotProgressRange Property

UpperPlotProgressRange Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »UpperPlotProgressRange
Declaration Syntax
C# Visual Basic Visual C++
public int UpperPlotProgressRange { get; set; }
Public Property UpperPlotProgressRange As Integer
    Get
    Set
public:
property int UpperPlotProgressRange {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


UpperSheetProgressRange Property

UpperSheetProgressRange Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »UpperSheetProgressRange
Declaration Syntax
C# Visual Basic Visual C++
public int UpperSheetProgressRange { get; set; }
Public Property UpperSheetProgressRange As Integer
    Get
    Set
public:
property int UpperSheetProgressRange {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


PlotProgressDialog Class

PlotProgressDialog Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPlPlotProgressDialog")]
public class PlotProgressDialog : PlotProgress
<WrapperAttribute("AcPlPlotProgressDialog")> _
Public Class PlotProgressDialog _
    Inherits PlotProgress
[WrapperAttribute(L"AcPlPlotProgressDialog")]
public ref class PlotProgressDialog : public PlotProgress
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlotProgressDialog(Boolean, Int32, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides PlotProgress.DeleteUnmanagedObject()()()().)
 | Destroy()()()() |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Heartbeat()()()() | (Inherited from PlotProgress.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsPlotCancelled | (Inherited from PlotProgress.)
 | IsSheetCancelled | (Inherited from PlotProgress.)
 | IsSingleSheetPlot |
 | IsVisible | (Inherited from PlotProgress.)
 | LowerPlotProgressRange | (Inherited from PlotProgress.)
 | LowerSheetProgressRange | (Inherited from PlotProgress.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnBeginPlot()()()() |
 | OnBeginSheet()()()() |
 | OnEndPlot()()()() |
 | OnEndSheet()()()() |
 | PlotCancelStatus | (Inherited from PlotProgress.)
 | PlotMsgString[([( PlotMessageIndex])]) |
 | PlotProgressPos | (Inherited from PlotProgress.)
 | SheetCancelStatus | (Inherited from PlotProgress.)
 | SheetProgressPos | (Inherited from PlotProgress.)
 | StatusMsgString | (Inherited from PlotProgress.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | UpperPlotProgressRange | (Inherited from PlotProgress.)
 | UpperSheetProgressRange | (Inherited from PlotProgress.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | PlotProgress
 |  |  |  | PlotProgressDialog

Assembly: ZwManaged (Module: ZwManaged)


PlotProgressDialog Constructor (isPreview, sheetCount, showCancelSheetButton)

PlotProgressDialog Constructor (isPreview, sheetCount, showCancelSheetButton)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »PlotProgressDialog(Boolean, Int32, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public PlotProgressDialog(
    bool isPreview,
    int sheetCount,
    bool showCancelSheetButton
)
Public Sub New ( _
    isPreview As Boolean, _
    sheetCount As Integer, _
    showCancelSheetButton As Boolean _
)
public:
PlotProgressDialog(
    bool isPreview,
    int sheetCount,
    bool showCancelSheetButton
)
Parameters
isPreview(Boolean)
sheetCount(Int32)
showCancelSheetButton(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override

Assembly: ZwManaged (Module: ZwManaged)


Destroy Method

Destroy Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »Destroy()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Destroy()
Public Sub Destroy
public:
void Destroy()

Assembly: ZwManaged (Module: ZwManaged)


IsSingleSheetPlot Property

IsSingleSheetPlot Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »IsSingleSheetPlot
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSingleSheetPlot { get; }
Public ReadOnly Property IsSingleSheetPlot As Boolean
    Get
public:
property bool IsSingleSheetPlot {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OnBeginPlot Method

OnBeginPlot Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »OnBeginPlot()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void OnBeginPlot()
Public Sub OnBeginPlot
public:
void OnBeginPlot()

Assembly: ZwManaged (Module: ZwManaged)


OnBeginSheet Method

OnBeginSheet Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »OnBeginSheet()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void OnBeginSheet()
Public Sub OnBeginSheet
public:
void OnBeginSheet()

Assembly: ZwManaged (Module: ZwManaged)


OnEndPlot Method

OnEndPlot Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »OnEndPlot()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void OnEndPlot()
Public Sub OnEndPlot
public:
void OnEndPlot()

Assembly: ZwManaged (Module: ZwManaged)


OnEndSheet Method

OnEndSheet Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »OnEndSheet()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void OnEndSheet()
Public Sub OnEndSheet
public:
void OnEndSheet()

Assembly: ZwManaged (Module: ZwManaged)


PlotMsgString Property (index)

PlotMsgString Property (index)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »PlotMsgString[([( PlotMessageIndex])])
Declaration Syntax
C# Visual Basic Visual C++
public string this[
    PlotMessageIndex index
] { get; set; }
Public Property PlotMsgString ( _
    index As PlotMessageIndex _
) As String
    Get
    Set
public:
property String^ PlotMsgString[PlotMessageIndex index] {
    String^ get (PlotMessageIndex index);
    void set (PlotMessageIndex index, String^ value);
}
Parameters
index(PlotMessageIndex)

Assembly: ZwManaged (Module: ZwManaged)


PlotReactorManager Class

PlotReactorManager Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotReactorManager
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PlotReactorManager
Public NotInheritable Class PlotReactorManager
public ref class PlotReactorManager sealed
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlotReactorManager()()()() |
 | BeginDocument |
 | BeginPage |
 | BeginPlot |
 | EndDocument |
 | EndPage |
 | EndPlot |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PageCancelled |
 | PlotCancelled |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PlotReactorManager

Assembly: ZwManaged (Module: ZwManaged)


PlotReactorManager Constructor

PlotReactorManager Constructor
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotReactorManager »PlotReactorManager()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PlotReactorManager()
Public Sub New
public:
PlotReactorManager()

Assembly: ZwManaged (Module: ZwManaged)


BeginDocument Event

BeginDocument Event
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotReactorManager »BeginDocument
Declaration Syntax
C# Visual Basic Visual C++
public event BeginDocumentEventHandler BeginDocument
Public Event BeginDocument As BeginDocumentEventHandler
public:
 event BeginDocumentEventHandler^ BeginDocument {
    void add (BeginDocumentEventHandler^ value);
    void remove (BeginDocumentEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


BeginPage Event

BeginPage Event
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotReactorManager »BeginPage
Declaration Syntax
C# Visual Basic Visual C++
public event BeginPageEventHandler BeginPage
Public Event BeginPage As BeginPageEventHandler
public:
 event BeginPageEventHandler^ BeginPage {
    void add (BeginPageEventHandler^ value);
    void remove (BeginPageEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


BeginPlot Event

BeginPlot Event
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotReactorManager »BeginPlot
Declaration Syntax
C# Visual Basic Visual C++
public event BeginPlotEventHandler BeginPlot
Public Event BeginPlot As BeginPlotEventHandler
public:
 event BeginPlotEventHandler^ BeginPlot {
    void add (BeginPlotEventHandler^ value);
    void remove (BeginPlotEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


EndDocument Event

EndDocument Event
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotReactorManager »EndDocument
Declaration Syntax
C# Visual Basic Visual C++
public event EndDocumentEventHandler EndDocument
Public Event EndDocument As EndDocumentEventHandler
public:
 event EndDocumentEventHandler^ EndDocument {
    void add (EndDocumentEventHandler^ value);
    void remove (EndDocumentEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


EndPage Event

EndPage Event
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotReactorManager »EndPage
Declaration Syntax
C# Visual Basic Visual C++
public event EndPageEventHandler EndPage
Public Event EndPage As EndPageEventHandler
public:
 event EndPageEventHandler^ EndPage {
    void add (EndPageEventHandler^ value);
    void remove (EndPageEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


EndPlot Event

EndPlot Event
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotReactorManager »EndPlot
Declaration Syntax
C# Visual Basic Visual C++
public event EndPlotEventHandler EndPlot
Public Event EndPlot As EndPlotEventHandler
public:
 event EndPlotEventHandler^ EndPlot {
    void add (EndPlotEventHandler^ value);
    void remove (EndPlotEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PageCancelled Event

PageCancelled Event
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotReactorManager »PageCancelled
Declaration Syntax
C# Visual Basic Visual C++
public event PageCancelledEventHandler PageCancelled
Public Event PageCancelled As PageCancelledEventHandler
public:
 event PageCancelledEventHandler^ PageCancelled {
    void add (PageCancelledEventHandler^ value);
    void remove (PageCancelledEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PlotCancelled Event

PlotCancelled Event
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotReactorManager »PlotCancelled
Declaration Syntax
C# Visual Basic Visual C++
public event PlotCancelledEventHandler PlotCancelled
Public Event PlotCancelled As PlotCancelledEventHandler
public:
 event PlotCancelledEventHandler^ PlotCancelled {
    void add (PlotCancelledEventHandler^ value);
    void remove (PlotCancelledEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PlotToFileCapability Enumeration

PlotToFileCapability Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotToFileCapability
Declaration Syntax
C# Visual Basic Visual C++
public enum PlotToFileCapability
Public Enumeration PlotToFileCapability
public enum class PlotToFileCapability
Members
Member | Description
MustPlotToFile |
PlotToFileAllowed |
NoPlotToFile |

Assembly: ZwManaged (Module: ZwManaged)


PlotType Enumeration

PlotType Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotType
Declaration Syntax
C# Visual Basic Visual C++
public enum PlotType
Public Enumeration PlotType
public enum class PlotType
Members
Member | Description
BackgroundPlot |
BackgroundPackaging |
Plot |
Preview |

Assembly: ZwManaged (Module: ZwManaged)


PreviewEndPlotInfo Class

PreviewEndPlotInfo Class
Namespaces »ZwSoft.ZwCAD.PlottingServices »PreviewEndPlotInfo
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ACPL_PREVIEWENDPLOT")]
public sealed class PreviewEndPlotInfo : DisposableWrapper
<WrapperAttribute("ACPL_PREVIEWENDPLOT")> _
Public NotInheritable Class PreviewEndPlotInfo _
    Inherits DisposableWrapper
[WrapperAttribute(L"ACPL_PREVIEWENDPLOT")]
public ref class PreviewEndPlotInfo sealed : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PreviewEndPlotInfo()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CopyFromUnmanagedObject(IntPtr) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from DisposableWrapper.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | PreviewEndPlotInfo

Assembly: ZwManaged (Module: ZwManaged)


PreviewEndPlotInfo Constructor

PreviewEndPlotInfo Constructor
Namespaces »ZwSoft.ZwCAD.PlottingServices »PreviewEndPlotInfo »PreviewEndPlotInfo()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PreviewEndPlotInfo()
Public Sub New
public:
PreviewEndPlotInfo()

Assembly: ZwManaged (Module: ZwManaged)


CopyFromUnmanagedObject Method (unmanagedPointer)

CopyFromUnmanagedObject Method (unmanagedPointer)
Namespaces »ZwSoft.ZwCAD.PlottingServices »PreviewEndPlotInfo »CopyFromUnmanagedObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static PreviewEndPlotInfo CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Public Shared Function CopyFromUnmanagedObject ( _
    unmanagedPointer As IntPtr _
) As PreviewEndPlotInfo
public:
static PreviewEndPlotInfo^ CopyFromUnmanagedObject(
    IntPtr unmanagedPointer
)
Parameters
unmanagedPointer(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


Status Property

Status Property
Namespaces »ZwSoft.ZwCAD.PlottingServices »PreviewEndPlotInfo »Status
Declaration Syntax
C# Visual Basic Visual C++
public PreviewEndPlotStatus Status { get; }
Public ReadOnly Property Status As PreviewEndPlotStatus
    Get
public:
property PreviewEndPlotStatus Status {
    PreviewEndPlotStatus get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PreviewEndPlotStatus Enumeration

PreviewEndPlotStatus Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »PreviewEndPlotStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum PreviewEndPlotStatus
Public Enumeration PreviewEndPlotStatus
public enum class PreviewEndPlotStatus
Members
Member | Description
Previous |
Next |
Plot |
Cancel |
Normal |

Assembly: ZwManaged (Module: ZwManaged)


PreviewEngineFlags Enumeration

PreviewEngineFlags Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »PreviewEngineFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum PreviewEngineFlags
<FlagsAttribute> _
Public Enumeration PreviewEngineFlags
[FlagsAttribute]
public enum class PreviewEngineFlags
Members
Member | Description
PreviousSheet |
NextSheet |
Plot |

Assembly: ZwManaged (Module: ZwManaged)


ProcessPlotState Enumeration

ProcessPlotState Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »ProcessPlotState
Declaration Syntax
C# Visual Basic Visual C++
public enum ProcessPlotState
Public Enumeration ProcessPlotState
public enum class ProcessPlotState
Members
Member | Description
BackgroundPlotting |
ForegroundPlotting |
NotPlotting |

Assembly: ZwManaged (Module: ZwManaged)


RefreshCode Enumeration

RefreshCode Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »RefreshCode
Declaration Syntax
C# Visual Basic Visual C++
public enum RefreshCode
Public Enumeration RefreshCode
public enum class RefreshCode
Members
Member | Description
RefreshStyleList |
RefreshDevicesList |
All |

Assembly: ZwManaged (Module: ZwManaged)


SheetCancelStatus Enumeration

SheetCancelStatus Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »SheetCancelStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum SheetCancelStatus
Public Enumeration SheetCancelStatus
public enum class SheetCancelStatus
Members
Member | Description
SheetCancelStatusCount |
SheetCanceledByCaller |
SheetCanceledByCancelAllButton |
SheetCanceledByCancelButton |
SheetContinue |

Assembly: ZwManaged (Module: ZwManaged)


SheetType Enumeration

SheetType Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »SheetType
Declaration Syntax
C# Visual Basic Visual C++
public enum SheetType
Public Enumeration SheetType
public enum class SheetType
Members
Member | Description
OriginalDevice |
MultiDwf |
SingleDwf |
SingleDwfx |
MultiDwfx |
SinglePdf |
MultiPdf |

Assembly: ZwManaged (Module: ZwManaged)


StdConfiguration Enumeration

StdConfiguration Enumeration
Namespaces »ZwSoft.ZwCAD.PlottingServices »StdConfiguration
Declaration Syntax
C# Visual Basic Visual C++
public enum StdConfiguration
Public Enumeration StdConfiguration
public enum class StdConfiguration
Members
Member | Description
PublishToWebPng |
PublishToWebJpg |
PublishToWebDwf |
DwfEplotOptForViewing |
DwfEplotOptForPlotting |
Dwf6ePlot |
DefaultWindowsSysPrinter |
NoneDevice |

Assembly: ZwManaged (Module: ZwManaged)


ZwSoft.ZwCAD.Publishing Namespace

ZwSoft.ZwCAD.Publishing Namespace
Namespaces »ZwSoft.ZwCAD.Publishing
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.Publishing
Namespace ZwSoft.ZwCAD.Publishing
namespace ZwSoft.ZwCAD.Publishing
Types
All Types Classes Structures Delegates
Icon | Type | Description
 | AboutToBeginBackgroundPublishingEventArgs |
 | AboutToBeginBackgroundPublishingEventHandler |
 | AboutToBeginPublishingEventArgs |
 | AboutToBeginPublishingEventHandler |
 | AboutToEndPublishingEventHandler |
 | AboutToMoveFileEventHandler |
 | BeginAggregationEventArgs |
 | BeginAggregationEventHandler |
 | BeginEntityEventHandler |
 | BeginPublishingSheetEventArgs |
 | BeginPublishingSheetEventHandler |
 | BeginSheetEventHandler |
 | CancelledOrFailedPublishingEventHandler |
 | Dwf3dNavigationTreeNode |
 | Dwf3dNavigationTreeNodeCollection |
 | DwfNode |
 | EndEntityEventHandler |
 | EndPublishEventHandler |
 | EndSheetEventHandler |
 | EPlotAttribute |
 | EPlotAttributeCollection |
 | EPlotProperty |
 | EPlotPropertyBag |
 | EPlotPropertyCollection |
 | EPlotResource |
 | InitPublishOptionsDialogEventHandler |
 | OptionsDialogResult |
 | PublishEntityEventArgs |
 | Publisher |
 | PublishEventArgs |
 | PublishSheetEventArgs |
 | PublishUIEventArgs |


AboutToBeginBackgroundPublishingEventArgs Class

AboutToBeginBackgroundPublishingEventArgs Class
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginBackgroundPublishingEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class AboutToBeginBackgroundPublishingEventArgs : EventArgs
Public Class AboutToBeginBackgroundPublishingEventArgs _
    Inherits EventArgs
public ref class AboutToBeginBackgroundPublishingEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DsdData |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | JobWillPublishInBackground |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReadPrivateSection(String) |
 | ToString()()()() | (Inherited from Object.)
 | WritePrivateSection(String, IDictionaryEnumerator) |
Inheritance Hierarchy
Object
 | EventArgs
 |  | AboutToBeginBackgroundPublishingEventArgs

Assembly: ZwManaged (Module: ZwManaged)


DsdData Property

DsdData Property
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginBackgroundPublishingEventArgs »DsdData
Declaration Syntax
C# Visual Basic Visual C++
public DsdData DsdData { get; }
Public ReadOnly Property DsdData As DsdData
    Get
public:
property DsdData^ DsdData {
    DsdData^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


JobWillPublishInBackground Property

JobWillPublishInBackground Property
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginBackgroundPublishingEventArgs »JobWillPublishInBackground
Declaration Syntax
C# Visual Basic Visual C++
public bool JobWillPublishInBackground { get; }
Public ReadOnly Property JobWillPublishInBackground As Boolean
    Get
public:
property bool JobWillPublishInBackground {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ReadPrivateSection Method (sectionName)

ReadPrivateSection Method (sectionName)
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginBackgroundPublishingEventArgs »ReadPrivateSection(String)
Declaration Syntax
C# Visual Basic Visual C++
public IDictionaryEnumerator ReadPrivateSection(
    string sectionName
)
Public Function ReadPrivateSection ( _
    sectionName As String _
) As IDictionaryEnumerator
public:
IDictionaryEnumerator^ ReadPrivateSection(
    String^ sectionName
)
Parameters
sectionName(String)

Assembly: ZwManaged (Module: ZwManaged)


WritePrivateSection Method (sectionName, data)

WritePrivateSection Method (sectionName, data)
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginBackgroundPublishingEventArgs »WritePrivateSection(String, IDictionaryEnumerator)
Declaration Syntax
C# Visual Basic Visual C++
public void WritePrivateSection(
    string sectionName,
    IDictionaryEnumerator data
)
Public Sub WritePrivateSection ( _
    sectionName As String, _
    data As IDictionaryEnumerator _
)
public:
void WritePrivateSection(
    String^ sectionName,
    IDictionaryEnumerator^ data
)
Parameters
sectionName(String)
data(IDictionaryEnumerator)

Assembly: ZwManaged (Module: ZwManaged)


AboutToBeginBackgroundPublishingEventHandler Delegate

AboutToBeginBackgroundPublishingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginBackgroundPublishingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void AboutToBeginBackgroundPublishingEventHandler(
    Object sender,
    AboutToBeginBackgroundPublishingEventArgs e
)
Public Delegate Sub AboutToBeginBackgroundPublishingEventHandler ( _
    sender As Object, _
    e As AboutToBeginBackgroundPublishingEventArgs _
)
public delegate void AboutToBeginBackgroundPublishingEventHandler(
    Object^ sender,
    AboutToBeginBackgroundPublishingEventArgs^ e
)
Parameters
sender(Object)
e(AboutToBeginBackgroundPublishingEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


AboutToBeginPublishingEventArgs Class

AboutToBeginPublishingEventArgs Class
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginPublishingEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class AboutToBeginPublishingEventArgs : EventArgs
Public Class AboutToBeginPublishingEventArgs _
    Inherits EventArgs
public ref class AboutToBeginPublishingEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DsdData |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | JobWillPublishInBackground |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotLogger |
 | ReadPrivateSection(String) |
 | ToString()()()() | (Inherited from Object.)
 | WritePrivateSection(String, IDictionaryEnumerator) |
Inheritance Hierarchy
Object
 | EventArgs
 |  | AboutToBeginPublishingEventArgs

Assembly: ZwManaged (Module: ZwManaged)


DsdData Property

DsdData Property
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginPublishingEventArgs »DsdData
Declaration Syntax
C# Visual Basic Visual C++
public DsdData DsdData { get; }
Public ReadOnly Property DsdData As DsdData
    Get
public:
property DsdData^ DsdData {
    DsdData^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


JobWillPublishInBackground Property

JobWillPublishInBackground Property
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginPublishingEventArgs »JobWillPublishInBackground
Declaration Syntax
C# Visual Basic Visual C++
public bool JobWillPublishInBackground { get; }
Public ReadOnly Property JobWillPublishInBackground As Boolean
    Get
public:
property bool JobWillPublishInBackground {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotLogger Property

PlotLogger Property
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginPublishingEventArgs »PlotLogger
Declaration Syntax
C# Visual Basic Visual C++
public PlotLogger PlotLogger { get; }
Public ReadOnly Property PlotLogger As PlotLogger
    Get
public:
property PlotLogger^ PlotLogger {
    PlotLogger^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ReadPrivateSection Method (sectionName)

ReadPrivateSection Method (sectionName)
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginPublishingEventArgs »ReadPrivateSection(String)
Declaration Syntax
C# Visual Basic Visual C++
public IDictionaryEnumerator ReadPrivateSection(
    string sectionName
)
Public Function ReadPrivateSection ( _
    sectionName As String _
) As IDictionaryEnumerator
public:
IDictionaryEnumerator^ ReadPrivateSection(
    String^ sectionName
)
Parameters
sectionName(String)

Assembly: ZwManaged (Module: ZwManaged)


WritePrivateSection Method (sectionName, data)

WritePrivateSection Method (sectionName, data)
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginPublishingEventArgs »WritePrivateSection(String, IDictionaryEnumerator)
Declaration Syntax
C# Visual Basic Visual C++
public void WritePrivateSection(
    string sectionName,
    IDictionaryEnumerator data
)
Public Sub WritePrivateSection ( _
    sectionName As String, _
    data As IDictionaryEnumerator _
)
public:
void WritePrivateSection(
    String^ sectionName,
    IDictionaryEnumerator^ data
)
Parameters
sectionName(String)
data(IDictionaryEnumerator)

Assembly: ZwManaged (Module: ZwManaged)


AboutToBeginPublishingEventHandler Delegate

AboutToBeginPublishingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToBeginPublishingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void AboutToBeginPublishingEventHandler(
    Object sender,
    AboutToBeginPublishingEventArgs e
)
Public Delegate Sub AboutToBeginPublishingEventHandler ( _
    sender As Object, _
    e As AboutToBeginPublishingEventArgs _
)
public delegate void AboutToBeginPublishingEventHandler(
    Object^ sender,
    AboutToBeginPublishingEventArgs^ e
)
Parameters
sender(Object)
e(AboutToBeginPublishingEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


AboutToEndPublishingEventHandler Delegate

AboutToEndPublishingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToEndPublishingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void AboutToEndPublishingEventHandler(
    Object sender,
    PublishEventArgs e
)
Public Delegate Sub AboutToEndPublishingEventHandler ( _
    sender As Object, _
    e As PublishEventArgs _
)
public delegate void AboutToEndPublishingEventHandler(
    Object^ sender,
    PublishEventArgs^ e
)
Parameters
sender(Object)
e(PublishEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


AboutToMoveFileEventHandler Delegate

AboutToMoveFileEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »AboutToMoveFileEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void AboutToMoveFileEventHandler(
    Object sender,
    PublishEventArgs e
)
Public Delegate Sub AboutToMoveFileEventHandler ( _
    sender As Object, _
    e As PublishEventArgs _
)
public delegate void AboutToMoveFileEventHandler(
    Object^ sender,
    PublishEventArgs^ e
)
Parameters
sender(Object)
e(PublishEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


BeginAggregationEventArgs Class

BeginAggregationEventArgs Class
Namespaces »ZwSoft.ZwCAD.Publishing »BeginAggregationEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class BeginAggregationEventArgs : EventArgs
Public Class BeginAggregationEventArgs _
    Inherits EventArgs
public ref class BeginAggregationEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddGlobalPropertyRange(array<EPlotProperty>[]()[][]) |
 | AddGlobalResourceRange(array<EPlotResource>[]()[][]) |
 | DwfFileName |
 | DwfPassword |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotLogger |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeginAggregationEventArgs

Assembly: ZwManaged (Module: ZwManaged)


AddGlobalPropertyRange Method (properties)

AddGlobalPropertyRange Method (properties)
Namespaces »ZwSoft.ZwCAD.Publishing »BeginAggregationEventArgs »AddGlobalPropertyRange(array<EPlotProperty>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddGlobalPropertyRange(
    EPlotProperty[] properties
)
Public Sub AddGlobalPropertyRange ( _
    properties As EPlotProperty() _
)
public:
void AddGlobalPropertyRange(
    array<EPlotProperty^>^ properties
)
Parameters
properties(array< EPlotProperty >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


AddGlobalResourceRange Method (resources)

AddGlobalResourceRange Method (resources)
Namespaces »ZwSoft.ZwCAD.Publishing »BeginAggregationEventArgs »AddGlobalResourceRange(array<EPlotResource>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddGlobalResourceRange(
    EPlotResource[] resources
)
Public Sub AddGlobalResourceRange ( _
    resources As EPlotResource() _
)
public:
void AddGlobalResourceRange(
    array<EPlotResource^>^ resources
)
Parameters
resources(array< EPlotResource >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


DwfFileName Property

DwfFileName Property
Namespaces »ZwSoft.ZwCAD.Publishing »BeginAggregationEventArgs »DwfFileName
Declaration Syntax
C# Visual Basic Visual C++
public string DwfFileName { get; }
Public ReadOnly Property DwfFileName As String
    Get
public:
property String^ DwfFileName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DwfPassword Property

DwfPassword Property
Namespaces »ZwSoft.ZwCAD.Publishing »BeginAggregationEventArgs »DwfPassword
Declaration Syntax
C# Visual Basic Visual C++
public string DwfPassword { get; }
Public ReadOnly Property DwfPassword As String
    Get
public:
property String^ DwfPassword {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotLogger Property

PlotLogger Property
Namespaces »ZwSoft.ZwCAD.Publishing »BeginAggregationEventArgs »PlotLogger
Declaration Syntax
C# Visual Basic Visual C++
public PlotLogger PlotLogger { get; }
Public ReadOnly Property PlotLogger As PlotLogger
    Get
public:
property PlotLogger^ PlotLogger {
    PlotLogger^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


BeginAggregationEventHandler Delegate

BeginAggregationEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »BeginAggregationEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginAggregationEventHandler(
    Object sender,
    BeginAggregationEventArgs e
)
Public Delegate Sub BeginAggregationEventHandler ( _
    sender As Object, _
    e As BeginAggregationEventArgs _
)
public delegate void BeginAggregationEventHandler(
    Object^ sender,
    BeginAggregationEventArgs^ e
)
Parameters
sender(Object)
e(BeginAggregationEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


BeginEntityEventHandler Delegate

BeginEntityEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »BeginEntityEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginEntityEventHandler(
    Object sender,
    PublishEntityEventArgs e
)
Public Delegate Sub BeginEntityEventHandler ( _
    sender As Object, _
    e As PublishEntityEventArgs _
)
public delegate void BeginEntityEventHandler(
    Object^ sender,
    PublishEntityEventArgs^ e
)
Parameters
sender(Object)
e(PublishEntityEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


BeginPublishingSheetEventArgs Class

BeginPublishingSheetEventArgs Class
Namespaces »ZwSoft.ZwCAD.Publishing »BeginPublishingSheetEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class BeginPublishingSheetEventArgs : EventArgs
Public Class BeginPublishingSheetEventArgs _
    Inherits EventArgs
public ref class BeginPublishingSheetEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DsdEntry |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotLogger |
 | ToString()()()() | (Inherited from Object.)
 | UniqueId |
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeginPublishingSheetEventArgs

Assembly: ZwManaged (Module: ZwManaged)


DsdEntry Property

DsdEntry Property
Namespaces »ZwSoft.ZwCAD.Publishing »BeginPublishingSheetEventArgs »DsdEntry
Declaration Syntax
C# Visual Basic Visual C++
public DsdEntry DsdEntry { get; }
Public ReadOnly Property DsdEntry As DsdEntry
    Get
public:
property DsdEntry^ DsdEntry {
    DsdEntry^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotLogger Property

PlotLogger Property
Namespaces »ZwSoft.ZwCAD.Publishing »BeginPublishingSheetEventArgs »PlotLogger
Declaration Syntax
C# Visual Basic Visual C++
public PlotLogger PlotLogger { get; }
Public ReadOnly Property PlotLogger As PlotLogger
    Get
public:
property PlotLogger^ PlotLogger {
    PlotLogger^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


UniqueId Property

UniqueId Property
Namespaces »ZwSoft.ZwCAD.Publishing »BeginPublishingSheetEventArgs »UniqueId
Declaration Syntax
C# Visual Basic Visual C++
public string UniqueId { get; }
Public ReadOnly Property UniqueId As String
    Get
public:
property String^ UniqueId {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


BeginPublishingSheetEventHandler Delegate

BeginPublishingSheetEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »BeginPublishingSheetEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginPublishingSheetEventHandler(
    Object sender,
    BeginPublishingSheetEventArgs e
)
Public Delegate Sub BeginPublishingSheetEventHandler ( _
    sender As Object, _
    e As BeginPublishingSheetEventArgs _
)
public delegate void BeginPublishingSheetEventHandler(
    Object^ sender,
    BeginPublishingSheetEventArgs^ e
)
Parameters
sender(Object)
e(BeginPublishingSheetEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


BeginSheetEventHandler Delegate

BeginSheetEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »BeginSheetEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeginSheetEventHandler(
    Object sender,
    PublishSheetEventArgs e
)
Public Delegate Sub BeginSheetEventHandler ( _
    sender As Object, _
    e As PublishSheetEventArgs _
)
public delegate void BeginSheetEventHandler(
    Object^ sender,
    PublishSheetEventArgs^ e
)
Parameters
sender(Object)
e(PublishSheetEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


CancelledOrFailedPublishingEventHandler Delegate

CancelledOrFailedPublishingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »CancelledOrFailedPublishingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void CancelledOrFailedPublishingEventHandler(
    Object sender,
    PublishEventArgs e
)
Public Delegate Sub CancelledOrFailedPublishingEventHandler ( _
    sender As Object, _
    e As PublishEventArgs _
)
public delegate void CancelledOrFailedPublishingEventHandler(
    Object^ sender,
    PublishEventArgs^ e
)
Parameters
sender(Object)
e(PublishEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


Dwf3dNavigationTreeNode Class

Dwf3dNavigationTreeNode Class
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("Ac3dDwfNavTreeNode")]
public sealed class Dwf3dNavigationTreeNode : RXObject
<WrapperAttribute("Ac3dDwfNavTreeNode")> _
Public NotInheritable Class Dwf3dNavigationTreeNode _
    Inherits RXObject
[WrapperAttribute(L"Ac3dDwfNavTreeNode")]
public ref class Dwf3dNavigationTreeNode sealed : public RXObject
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Dwf3dNavigationTreeNode(String, Boolean, Boolean) |
 | Dwf3dNavigationTreeNode()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Children |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DisplayName |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetKeys()()()() |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsBlock |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsGroup |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SetKeys(array<Int32>[]()[][]) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Dwf3dNavigationTreeNode

Assembly: ZwManaged (Module: ZwManaged)


Dwf3dNavigationTreeNode Constructor

Dwf3dNavigationTreeNode Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »Dwf3dNavigationTreeNode()()()()
Members
Icon | Member | Description
 | Dwf3dNavigationTreeNode(String, Boolean, Boolean) |
 | Dwf3dNavigationTreeNode()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Dwf3dNavigationTreeNode Constructor

Dwf3dNavigationTreeNode Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »Dwf3dNavigationTreeNode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Dwf3dNavigationTreeNode()
Public Sub New
public:
Dwf3dNavigationTreeNode()

Assembly: ZwManaged (Module: ZwManaged)


Dwf3dNavigationTreeNode Constructor (displayName, isGroup, isBlock)

Dwf3dNavigationTreeNode Constructor (displayName, isGroup, isBlock)
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »Dwf3dNavigationTreeNode(String, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public Dwf3dNavigationTreeNode(
    string displayName,
    bool isGroup,
    bool isBlock
)
Public Sub New ( _
    displayName As String, _
    isGroup As Boolean, _
    isBlock As Boolean _
)
public:
Dwf3dNavigationTreeNode(
    String^ displayName,
    bool isGroup,
    bool isBlock
)
Parameters
displayName(String)
isGroup(Boolean)
isBlock(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


Children Property

Children Property
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »Children
Declaration Syntax
C# Visual Basic Visual C++
public Dwf3dNavigationTreeNodeCollection Children { get; }
Public ReadOnly Property Children As Dwf3dNavigationTreeNodeCollection
    Get
public:
property Dwf3dNavigationTreeNodeCollection^ Children {
    Dwf3dNavigationTreeNodeCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DisplayName Property

DisplayName Property
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »DisplayName
Declaration Syntax
C# Visual Basic Visual C++
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


GetKeys Method

GetKeys Method
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »GetKeys()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int[] GetKeys()
Public Function GetKeys As Integer()
public:
array<int>^ GetKeys()

Assembly: ZwManaged (Module: ZwManaged)


IsBlock Property

IsBlock Property
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »IsBlock
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBlock { get; set; }
Public Property IsBlock As Boolean
    Get
    Set
public:
property bool IsBlock {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


IsGroup Property

IsGroup Property
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »IsGroup
Declaration Syntax
C# Visual Basic Visual C++
public bool IsGroup { get; set; }
Public Property IsGroup As Boolean
    Get
    Set
public:
property bool IsGroup {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


SetKeys Method (keys)

SetKeys Method (keys)
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »SetKeys(array<Int32>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetKeys(
    int[] keys
)
Public Sub SetKeys ( _
    keys As Integer() _
)
public:
void SetKeys(
    array<int>^ keys
)
Parameters
keys(array<Int32>[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


Dwf3dNavigationTreeNodeCollection Class

Dwf3dNavigationTreeNodeCollection Class
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNodeCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Dwf3dNavigationTreeNodeCollection
Public NotInheritable Class Dwf3dNavigationTreeNodeCollection
public ref class Dwf3dNavigationTreeNodeCollection sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(Dwf3dNavigationTreeNode) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Dwf3dNavigationTreeNode) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Dwf3dNavigationTreeNodeCollection

Assembly: ZwManaged (Module: ZwManaged)


Add Method (node)

Add Method (node)
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNodeCollection »Add(Dwf3dNavigationTreeNode)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    Dwf3dNavigationTreeNode node
)
Public Sub Add ( _
    node As Dwf3dNavigationTreeNode _
)
public:
void Add(
    Dwf3dNavigationTreeNode^ node
)
Parameters
node(Dwf3dNavigationTreeNode)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNodeCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNodeCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Dwf3dNavigationTreeNode this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Dwf3dNavigationTreeNode
    Get
public:
property Dwf3dNavigationTreeNode^ default[int index] {
    Dwf3dNavigationTreeNode^ get (int index);
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Remove Method (node)

Remove Method (node)
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNodeCollection »Remove(Dwf3dNavigationTreeNode)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Dwf3dNavigationTreeNode node
)
Public Sub Remove ( _
    node As Dwf3dNavigationTreeNode _
)
public:
void Remove(
    Dwf3dNavigationTreeNode^ node
)
Parameters
node(Dwf3dNavigationTreeNode)

Assembly: ZwManaged (Module: ZwManaged)


DwfNode Class

DwfNode Class
Namespaces »ZwSoft.ZwCAD.Publishing »DwfNode
Declaration Syntax
C# Visual Basic Visual C++
public sealed class DwfNode
Public NotInheritable Class DwfNode
public ref class DwfNode sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DwfNode(Int32, String) |
 | DwfNode()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NodeId |
 | NodeName |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DwfNode

Assembly: ZwManaged (Module: ZwManaged)


DwfNode Constructor

DwfNode Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »DwfNode »DwfNode()()()()
Members
Icon | Member | Description
 | DwfNode(Int32, String) |
 | DwfNode()()()() |

Assembly: ZwManaged (Module: ZwManaged)


DwfNode Constructor

DwfNode Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »DwfNode »DwfNode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DwfNode()
Public Sub New
public:
DwfNode()

Assembly: ZwManaged (Module: ZwManaged)


DwfNode Constructor (nodeId, nodeName)

DwfNode Constructor (nodeId, nodeName)
Namespaces »ZwSoft.ZwCAD.Publishing »DwfNode »DwfNode(Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public DwfNode(
    int nodeId,
    string nodeName
)
Public Sub New ( _
    nodeId As Integer, _
    nodeName As String _
)
public:
DwfNode(
    int nodeId,
    String^ nodeName
)
Parameters
nodeId(Int32)
nodeName(String)

Assembly: ZwManaged (Module: ZwManaged)


NodeId Property

NodeId Property
Namespaces »ZwSoft.ZwCAD.Publishing »DwfNode »NodeId
Declaration Syntax
C# Visual Basic Visual C++
public int NodeId { get; set; }
Public Property NodeId As Integer
    Get
    Set
public:
property int NodeId {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


NodeName Property

NodeName Property
Namespaces »ZwSoft.ZwCAD.Publishing »DwfNode »NodeName
Declaration Syntax
C# Visual Basic Visual C++
public string NodeName { get; set; }
Public Property NodeName As String
    Get
    Set
public:
property String^ NodeName {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


EndEntityEventHandler Delegate

EndEntityEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »EndEntityEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void EndEntityEventHandler(
    Object sender,
    PublishEntityEventArgs e
)
Public Delegate Sub EndEntityEventHandler ( _
    sender As Object, _
    e As PublishEntityEventArgs _
)
public delegate void EndEntityEventHandler(
    Object^ sender,
    PublishEntityEventArgs^ e
)
Parameters
sender(Object)
e(PublishEntityEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


EndPublishEventHandler Delegate

EndPublishEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »EndPublishEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void EndPublishEventHandler(
    Object sender,
    PublishEventArgs e
)
Public Delegate Sub EndPublishEventHandler ( _
    sender As Object, _
    e As PublishEventArgs _
)
public delegate void EndPublishEventHandler(
    Object^ sender,
    PublishEventArgs^ e
)
Parameters
sender(Object)
e(PublishEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


EndSheetEventHandler Delegate

EndSheetEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »EndSheetEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void EndSheetEventHandler(
    Object sender,
    PublishSheetEventArgs e
)
Public Delegate Sub EndSheetEventHandler ( _
    sender As Object, _
    e As PublishSheetEventArgs _
)
public delegate void EndSheetEventHandler(
    Object^ sender,
    PublishSheetEventArgs^ e
)
Parameters
sender(Object)
e(PublishSheetEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


EPlotAttribute Class

EPlotAttribute Class
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttribute
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EPlotAttribute
Public NotInheritable Class EPlotAttribute
public ref class EPlotAttribute sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EPlotAttribute(String, String, String, String) |
 | EPlotAttribute()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | Ns |
 | NsUrl |
 | ToString()()()() | (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
EPlotAttribute

Assembly: ZwManaged (Module: ZwManaged)


EPlotAttribute Constructor

EPlotAttribute Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttribute »EPlotAttribute()()()()
Members
Icon | Member | Description
 | EPlotAttribute(String, String, String, String) |
 | EPlotAttribute()()()() |

Assembly: ZwManaged (Module: ZwManaged)


EPlotAttribute Constructor

EPlotAttribute Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttribute »EPlotAttribute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EPlotAttribute()
Public Sub New
public:
EPlotAttribute()

Assembly: ZwManaged (Module: ZwManaged)


EPlotAttribute Constructor (ns, nsUrl, name, value)

EPlotAttribute Constructor (ns, nsUrl, name, value)
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttribute »EPlotAttribute(String, String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public EPlotAttribute(
    string ns,
    string nsUrl,
    string name,
    string value
)
Public Sub New ( _
    ns As String, _
    nsUrl As String, _
    name As String, _
    value As String _
)
public:
EPlotAttribute(
    String^ ns,
    String^ nsUrl,
    String^ name,
    String^ value
)
Parameters
ns(String)
nsUrl(String)
name(String)
value(String)

Assembly: ZwManaged (Module: ZwManaged)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttribute »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Ns Property

Ns Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttribute »Ns
Declaration Syntax
C# Visual Basic Visual C++
public string Ns { get; set; }
Public Property Ns As String
    Get
    Set
public:
property String^ Ns {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


NsUrl Property

NsUrl Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttribute »NsUrl
Declaration Syntax
C# Visual Basic Visual C++
public string NsUrl { get; set; }
Public Property NsUrl As String
    Get
    Set
public:
property String^ NsUrl {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttribute »Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


EPlotAttributeCollection Class

EPlotAttributeCollection Class
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttributeCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EPlotAttributeCollection : ICollection,
    IEnumerable
Public NotInheritable Class EPlotAttributeCollection _
    Implements ICollection, IEnumerable
public ref class EPlotAttributeCollection sealed : ICollection,
    IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(EPlotAttribute) |
 | Clear()()()() |
 | CopyTo(Array, Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
EPlotAttributeCollection

Assembly: ZwManaged (Module: ZwManaged)


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttributeCollection »Add(EPlotAttribute)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    EPlotAttribute value
)
Public Sub Add ( _
    value As EPlotAttribute _
)
public:
void Add(
    EPlotAttribute^ value
)
Parameters
value(EPlotAttribute)

Assembly: ZwManaged (Module: ZwManaged)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttributeCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttributeCollection »CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Array arr,
    int index
)
Public Sub CopyTo ( _
    arr As Array, _
    index As Integer _
)
public:
virtual void CopyTo(
    Array^ arr,
    int index
) sealed
Parameters
arr(Array)
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttributeCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttributeCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed

Assembly: ZwManaged (Module: ZwManaged)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttributeCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttributeCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public EPlotAttribute this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As EPlotAttribute
    Get
    Set
public:
property EPlotAttribute^ default[int index] {
    EPlotAttribute^ get (int index);
    void set (int index, EPlotAttribute^ value);
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotAttributeCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EPlotProperty Class

EPlotProperty Class
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotProperty
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EPlotProperty
Public NotInheritable Class EPlotProperty
public ref class EPlotProperty sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EPlotProperty(String, String) |
 | EPlotProperty()()()() |
 | Category |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | Units |
 | Value |
Inheritance Hierarchy
Object
EPlotProperty

Assembly: ZwManaged (Module: ZwManaged)


EPlotProperty Constructor

EPlotProperty Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotProperty »EPlotProperty()()()()
Members
Icon | Member | Description
 | EPlotProperty(String, String) |
 | EPlotProperty()()()() |

Assembly: ZwManaged (Module: ZwManaged)


EPlotProperty Constructor

EPlotProperty Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotProperty »EPlotProperty()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EPlotProperty()
Public Sub New
public:
EPlotProperty()

Assembly: ZwManaged (Module: ZwManaged)


EPlotProperty Constructor (name, val)

EPlotProperty Constructor (name, val)
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotProperty »EPlotProperty(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public EPlotProperty(
    string name,
    string val
)
Public Sub New ( _
    name As String, _
    val As String _
)
public:
EPlotProperty(
    String^ name,
    String^ val
)
Parameters
name(String)
val(String)

Assembly: ZwManaged (Module: ZwManaged)


Category Property

Category Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotProperty »Category
Declaration Syntax
C# Visual Basic Visual C++
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotProperty »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Type Property

Type Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotProperty »Type
Declaration Syntax
C# Visual Basic Visual C++
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Units Property

Units Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotProperty »Units
Declaration Syntax
C# Visual Basic Visual C++
public string Units { get; set; }
Public Property Units As String
    Get
    Set
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotProperty »Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


EPlotPropertyBag Class

EPlotPropertyBag Class
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyBag
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EPlotPropertyBag
Public NotInheritable Class EPlotPropertyBag
public ref class EPlotPropertyBag sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EPlotPropertyBag(String, String, String) |
 | EPlotPropertyBag()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Id |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NamespaceLocation |
 | NamespaceUrl |
 | Properties |
 | References |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
EPlotPropertyBag

Assembly: ZwManaged (Module: ZwManaged)


EPlotPropertyBag Constructor

EPlotPropertyBag Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyBag »EPlotPropertyBag()()()()
Members
Icon | Member | Description
 | EPlotPropertyBag(String, String, String) |
 | EPlotPropertyBag()()()() |

Assembly: ZwManaged (Module: ZwManaged)


EPlotPropertyBag Constructor

EPlotPropertyBag Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyBag »EPlotPropertyBag()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EPlotPropertyBag()
Public Sub New
public:
EPlotPropertyBag()

Assembly: ZwManaged (Module: ZwManaged)


EPlotPropertyBag Constructor (id, namespaceUrl, namespaceLocation)

EPlotPropertyBag Constructor (id, namespaceUrl, namespaceLocation)
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyBag »EPlotPropertyBag(String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public EPlotPropertyBag(
    string id,
    string namespaceUrl,
    string namespaceLocation
)
Public Sub New ( _
    id As String, _
    namespaceUrl As String, _
    namespaceLocation As String _
)
public:
EPlotPropertyBag(
    String^ id,
    String^ namespaceUrl,
    String^ namespaceLocation
)
Parameters
id(String)
namespaceUrl(String)
namespaceLocation(String)

Assembly: ZwManaged (Module: ZwManaged)


Id Property

Id Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyBag »Id
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


NamespaceLocation Property

NamespaceLocation Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyBag »NamespaceLocation
Declaration Syntax
C# Visual Basic Visual C++
public string NamespaceLocation { get; set; }
Public Property NamespaceLocation As String
    Get
    Set
public:
property String^ NamespaceLocation {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


NamespaceUrl Property

NamespaceUrl Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyBag »NamespaceUrl
Declaration Syntax
C# Visual Basic Visual C++
public string NamespaceUrl { get; set; }
Public Property NamespaceUrl As String
    Get
    Set
public:
property String^ NamespaceUrl {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Properties Property

Properties Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyBag »Properties
Declaration Syntax
C# Visual Basic Visual C++
public EPlotPropertyCollection Properties { get; }
Public ReadOnly Property Properties As EPlotPropertyCollection
    Get
public:
property EPlotPropertyCollection^ Properties {
    EPlotPropertyCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


References Property

References Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyBag »References
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection References { get; set; }
Public Property References As StringCollection
    Get
    Set
public:
property StringCollection^ References {
    StringCollection^ get ();
    void set (StringCollection^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


EPlotPropertyCollection Class

EPlotPropertyCollection Class
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EPlotPropertyCollection : ICollection
Public NotInheritable Class EPlotPropertyCollection _
    Implements ICollection
public ref class EPlotPropertyCollection sealed : ICollection
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(EPlotProperty) |
 | Clear()()()() |
 | CopyTo(Array, Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
EPlotPropertyCollection

Assembly: ZwManaged (Module: ZwManaged)


Add Method (value)

Add Method (value)
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyCollection »Add(EPlotProperty)
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    EPlotProperty value
)
Public Sub Add ( _
    value As EPlotProperty _
)
public:
virtual void Add(
    EPlotProperty^ value
) sealed
Parameters
value(EPlotProperty)

Assembly: ZwManaged (Module: ZwManaged)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyCollection »CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed
Parameters
array(Array)
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed

Assembly: ZwManaged (Module: ZwManaged)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public EPlotProperty this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As EPlotProperty
    Get
    Set
public:
property EPlotProperty^ default[int index] {
    EPlotProperty^ get (int index);
    void set (int index, EPlotProperty^ value);
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotPropertyCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EPlotResource Class

EPlotResource Class
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotResource
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EPlotResource
Public NotInheritable Class EPlotResource
public ref class EPlotResource sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EPlotResource(String, String, String) |
 | EPlotResource()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mime |
 | Path |
 | Role |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
EPlotResource

Assembly: ZwManaged (Module: ZwManaged)


EPlotResource Constructor

EPlotResource Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotResource »EPlotResource()()()()
Members
Icon | Member | Description
 | EPlotResource(String, String, String) |
 | EPlotResource()()()() |

Assembly: ZwManaged (Module: ZwManaged)


EPlotResource Constructor

EPlotResource Constructor
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotResource »EPlotResource()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EPlotResource()
Public Sub New
public:
EPlotResource()

Assembly: ZwManaged (Module: ZwManaged)


EPlotResource Constructor (role, mime, path)

EPlotResource Constructor (role, mime, path)
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotResource »EPlotResource(String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public EPlotResource(
    string role,
    string mime,
    string path
)
Public Sub New ( _
    role As String, _
    mime As String, _
    path As String _
)
public:
EPlotResource(
    String^ role,
    String^ mime,
    String^ path
)
Parameters
role(String)
mime(String)
path(String)

Assembly: ZwManaged (Module: ZwManaged)


Mime Property

Mime Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotResource »Mime
Declaration Syntax
C# Visual Basic Visual C++
public string Mime { get; set; }
Public Property Mime As String
    Get
    Set
public:
property String^ Mime {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Path Property

Path Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotResource »Path
Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Role Property

Role Property
Namespaces »ZwSoft.ZwCAD.Publishing »EPlotResource »Role
Declaration Syntax
C# Visual Basic Visual C++
public string Role { get; set; }
Public Property Role As String
    Get
    Set
public:
property String^ Role {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


InitPublishOptionsDialogEventHandler Delegate

InitPublishOptionsDialogEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Publishing »InitPublishOptionsDialogEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void InitPublishOptionsDialogEventHandler(
    Object sender,
    PublishUIEventArgs e
)
Public Delegate Sub InitPublishOptionsDialogEventHandler ( _
    sender As Object, _
    e As PublishUIEventArgs _
)
public delegate void InitPublishOptionsDialogEventHandler(
    Object^ sender,
    PublishUIEventArgs^ e
)
Parameters
sender(Object)
e(PublishUIEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


OptionsDialogResult Structure

OptionsDialogResult Structure
Namespaces »ZwSoft.ZwCAD.Publishing »OptionsDialogResult
Declaration Syntax
C# Visual Basic Visual C++
public struct OptionsDialogResult
Public Structure OptionsDialogResult
public value class OptionsDialogResult
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DsdData |
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotConfig |
 | Status |
 | ToString()()()() | (Inherited from ValueType.)

Assembly: ZwManaged (Module: ZwManaged)


DsdData Property

DsdData Property
Namespaces »ZwSoft.ZwCAD.Publishing »OptionsDialogResult »DsdData
Declaration Syntax
C# Visual Basic Visual C++
public DsdData DsdData { get; }
Public ReadOnly Property DsdData As DsdData
    Get
public:
property DsdData^ DsdData {
    DsdData^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotConfig Property

PlotConfig Property
Namespaces »ZwSoft.ZwCAD.Publishing »OptionsDialogResult »PlotConfig
Declaration Syntax
C# Visual Basic Visual C++
public PlotConfig PlotConfig { get; }
Public ReadOnly Property PlotConfig As PlotConfig
    Get
public:
property PlotConfig^ PlotConfig {
    PlotConfig^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Status Property

Status Property
Namespaces »ZwSoft.ZwCAD.Publishing »OptionsDialogResult »Status
Declaration Syntax
C# Visual Basic Visual C++
public DialogResult Status { get; }
Public ReadOnly Property Status As DialogResult
    Get
public:
property DialogResult Status {
    DialogResult get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PublishEntityEventArgs Class

PublishEntityEventArgs Class
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class PublishEntityEventArgs : EventArgs
Public Class PublishEntityEventArgs _
    Inherits EventArgs
public ref class PublishEntityEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add3DDwfProperty(String, String, String) |
 | AddNodeToMap(ObjectId, ObjectIdCollection, Int32) |
 | AddPropertiesIds(EPlotPropertyBag, DwfNode) |
 | AddPropertyBag(EPlotPropertyBag) |
 | Cancel()()()() |
 | EffectiveBlockLayerId |
 | Entity |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | Flush()()()() |
 | GetCurrentEntityNode(ObjectIdCollection) |
 | getEntityBlockRefPath()()()() |
 | GetEntityNode(ObjectId, ObjectIdCollection) |
 | GetGraphicIDs()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNextAvailableNode()()()() |
 | GetNode(Int32) |
 | GetType()()()() | (Inherited from Object.)
 | IsCancelled |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotLogger |
 | SetCurrentNode(Int32, ObjectIdCollection) |
 | SetNodeName(Int32, String) |
 | ToString()()()() | (Inherited from Object.)
 | UniqueEntityId |
Inheritance Hierarchy
Object
 | EventArgs
 |  | PublishEntityEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Add3DDwfProperty Method (category, name, value)

Add3DDwfProperty Method (category, name, value)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »Add3DDwfProperty(String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public bool Add3DDwfProperty(
    string category,
    string name,
    string value
)
Public Function Add3DDwfProperty ( _
    category As String, _
    name As String, _
    value As String _
) As Boolean
public:
bool Add3DDwfProperty(
    String^ category,
    String^ name,
    String^ value
)
Parameters
category(String)
name(String)
value(String)

Assembly: ZwManaged (Module: ZwManaged)


AddNodeToMap Method (entityId, objIds, nodeId)

AddNodeToMap Method (entityId, objIds, nodeId)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »AddNodeToMap(ObjectId, ObjectIdCollection, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool AddNodeToMap(
    ObjectId entityId,
    ObjectIdCollection objIds,
    int nodeId
)
Public Function AddNodeToMap ( _
    entityId As ObjectId, _
    objIds As ObjectIdCollection, _
    nodeId As Integer _
) As Boolean
public:
bool AddNodeToMap(
    ObjectId entityId,
    ObjectIdCollection^ objIds,
    int nodeId
)
Parameters
entityId(ObjectId)
objIds(ObjectIdCollection)
nodeId(Int32)

Assembly: ZwManaged (Module: ZwManaged)


AddPropertiesIds Method (properties, node)

AddPropertiesIds Method (properties, node)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »AddPropertiesIds(EPlotPropertyBag, DwfNode)
Declaration Syntax
C# Visual Basic Visual C++
public bool AddPropertiesIds(
    EPlotPropertyBag properties,
    DwfNode node
)
Public Function AddPropertiesIds ( _
    properties As EPlotPropertyBag, _
    node As DwfNode _
) As Boolean
public:
bool AddPropertiesIds(
    EPlotPropertyBag^ properties,
    DwfNode^ node
)
Parameters
properties(EPlotPropertyBag)
node(DwfNode)

Assembly: ZwManaged (Module: ZwManaged)


AddPropertyBag Method (properties)

AddPropertyBag Method (properties)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »AddPropertyBag(EPlotPropertyBag)
Declaration Syntax
C# Visual Basic Visual C++
public bool AddPropertyBag(
    EPlotPropertyBag properties
)
Public Function AddPropertyBag ( _
    properties As EPlotPropertyBag _
) As Boolean
public:
bool AddPropertyBag(
    EPlotPropertyBag^ properties
)
Parameters
properties(EPlotPropertyBag)

Assembly: ZwManaged (Module: ZwManaged)


Cancel Method

Cancel Method
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »Cancel()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Cancel()
Public Sub Cancel
public:
void Cancel()

Assembly: ZwManaged (Module: ZwManaged)


EffectiveBlockLayerId Property

EffectiveBlockLayerId Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »EffectiveBlockLayerId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId EffectiveBlockLayerId { get; }
Public ReadOnly Property EffectiveBlockLayerId As ObjectId
    Get
public:
property ObjectId EffectiveBlockLayerId {
    ObjectId get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Entity Property

Entity Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »Entity
Declaration Syntax
C# Visual Basic Visual C++
public Entity Entity { get; }
Public ReadOnly Property Entity As Entity
    Get
public:
property Entity^ Entity {
    Entity^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Flush Method

Flush Method
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »Flush()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Flush()
Public Sub Flush
public:
void Flush()

Assembly: ZwManaged (Module: ZwManaged)


GetCurrentEntityNode Method (objIds)

GetCurrentEntityNode Method (objIds)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »GetCurrentEntityNode(ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DwfNode GetCurrentEntityNode(
    ObjectIdCollection objIds
)
Public Function GetCurrentEntityNode ( _
    objIds As ObjectIdCollection _
) As DwfNode
public:
DwfNode^ GetCurrentEntityNode(
    ObjectIdCollection^ objIds
)
Parameters
objIds(ObjectIdCollection)

Assembly: ZwManaged (Module: ZwManaged)


getEntityBlockRefPath Method

getEntityBlockRefPath Method
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »getEntityBlockRefPath()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ObjectIdCollection getEntityBlockRefPath()
Public Function getEntityBlockRefPath As ObjectIdCollection
public:
ObjectIdCollection^ getEntityBlockRefPath()

Assembly: ZwManaged (Module: ZwManaged)


GetEntityNode Method (entityId, objIds)

GetEntityNode Method (entityId, objIds)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »GetEntityNode(ObjectId, ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public int GetEntityNode(
    ObjectId entityId,
    ObjectIdCollection objIds
)
Public Function GetEntityNode ( _
    entityId As ObjectId, _
    objIds As ObjectIdCollection _
) As Integer
public:
int GetEntityNode(
    ObjectId entityId,
    ObjectIdCollection^ objIds
)
Parameters
entityId(ObjectId)
objIds(ObjectIdCollection)

Assembly: ZwManaged (Module: ZwManaged)


GetGraphicIDs Method

GetGraphicIDs Method
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »GetGraphicIDs()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int[] GetGraphicIDs()
Public Function GetGraphicIDs As Integer()
public:
array<int>^ GetGraphicIDs()

Assembly: ZwManaged (Module: ZwManaged)


GetNextAvailableNode Method

GetNextAvailableNode Method
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »GetNextAvailableNode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int GetNextAvailableNode()
Public Function GetNextAvailableNode As Integer
public:
int GetNextAvailableNode()

Assembly: ZwManaged (Module: ZwManaged)


GetNode Method (nodeId)

GetNode Method (nodeId)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »GetNode(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DwfNode GetNode(
    int nodeId
)
Public Function GetNode ( _
    nodeId As Integer _
) As DwfNode
public:
DwfNode^ GetNode(
    int nodeId
)
Parameters
nodeId(Int32)

Assembly: ZwManaged (Module: ZwManaged)


IsCancelled Property

IsCancelled Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »IsCancelled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCancelled { get; }
Public ReadOnly Property IsCancelled As Boolean
    Get
public:
property bool IsCancelled {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotLogger Property

PlotLogger Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »PlotLogger
Declaration Syntax
C# Visual Basic Visual C++
public PlotLogger PlotLogger { get; }
Public ReadOnly Property PlotLogger As PlotLogger
    Get
public:
property PlotLogger^ PlotLogger {
    PlotLogger^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


SetCurrentNode Method (nodeId, objIds)

SetCurrentNode Method (nodeId, objIds)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »SetCurrentNode(Int32, ObjectIdCollection)
Declaration Syntax
C# Visual Basic Visual C++
public bool SetCurrentNode(
    int nodeId,
    ObjectIdCollection objIds
)
Public Function SetCurrentNode ( _
    nodeId As Integer, _
    objIds As ObjectIdCollection _
) As Boolean
public:
bool SetCurrentNode(
    int nodeId,
    ObjectIdCollection^ objIds
)
Parameters
nodeId(Int32)
objIds(ObjectIdCollection)

Assembly: ZwManaged (Module: ZwManaged)


SetNodeName Method (nodeId, nodeName)

SetNodeName Method (nodeId, nodeName)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »SetNodeName(Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public bool SetNodeName(
    int nodeId,
    string nodeName
)
Public Function SetNodeName ( _
    nodeId As Integer, _
    nodeName As String _
) As Boolean
public:
bool SetNodeName(
    int nodeId,
    String^ nodeName
)
Parameters
nodeId(Int32)
nodeName(String)

Assembly: ZwManaged (Module: ZwManaged)


UniqueEntityId Property

UniqueEntityId Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEntityEventArgs »UniqueEntityId
Declaration Syntax
C# Visual Basic Visual C++
public string UniqueEntityId { get; }
Public ReadOnly Property UniqueEntityId As String
    Get
public:
property String^ UniqueEntityId {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Publisher Class

Publisher Class
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Publisher : MarshalByRefObject
Public NotInheritable Class Publisher _
    Inherits MarshalByRefObject
public ref class Publisher sealed : public MarshalByRefObject
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AboutToBeginBackgroundPublishing |
 | AboutToBeginPublishing |
 | AboutToEndPublishing |
 | AboutToMoveFile |
 | BeginAggregation |
 | BeginEntity |
 | BeginPublishingSheet |
 | BeginSheet |
 | CancelledOrFailedPublishing |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CurrentPublishedSheetSetPath |
 | EndEntity |
 | EndPublish |
 | EndSheet |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FireAboutToBeginBackgroundPublishing(AboutToBeginBackgroundPublishingEventArgs) |
 | FireAboutToBeginPublishing(AboutToBeginPublishingEventArgs) |
 | FireAboutToEndPublishing(PublishEventArgs) |
 | FireAboutToMoveFile(PublishEventArgs) |
 | FireBeginAggregation(BeginAggregationEventArgs) |
 | FireBeginEntity(PublishEntityEventArgs) |
 | FireBeginPublishingSheet(BeginPublishingSheetEventArgs) |
 | FireBeginSheet(PublishSheetEventArgs) |
 | FireCancelledOrFailedPublishing(PublishEventArgs) |
 | FireEndEntity(PublishEntityEventArgs) |
 | FireEndPublish(PublishEventArgs) |
 | FireEndSheet(PublishSheetEventArgs) |
 | FireInitPublishOptionsDialog(PublishUIEventArgs) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InitPublishOptionsDialog |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PublishDsd(String, PlotProgressDialog) |
 | PublishExecute(DsdData, PlotConfig) |
 | PublishSelectedLayouts(Boolean) |
 | ShowDwfOptionsDialog(DsdData, PlotConfig, String) |
 | ShowPublishDialog(DsdData, PlotConfig, StringCollection, StringCollection, String, String) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Publisher

Assembly: ZwManaged (Module: ZwManaged)


AboutToBeginBackgroundPublishing Event

AboutToBeginBackgroundPublishing Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »AboutToBeginBackgroundPublishing
Declaration Syntax
C# Visual Basic Visual C++
public event AboutToBeginBackgroundPublishingEventHandler AboutToBeginBackgroundPublishing
Public Event AboutToBeginBackgroundPublishing As AboutToBeginBackgroundPublishingEventHandler
public:
 event AboutToBeginBackgroundPublishingEventHandler^ AboutToBeginBackgroundPublishing {
    void add (AboutToBeginBackgroundPublishingEventHandler^ value);
    void remove (AboutToBeginBackgroundPublishingEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


AboutToBeginPublishing Event

AboutToBeginPublishing Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »AboutToBeginPublishing
Declaration Syntax
C# Visual Basic Visual C++
public event AboutToBeginPublishingEventHandler AboutToBeginPublishing
Public Event AboutToBeginPublishing As AboutToBeginPublishingEventHandler
public:
 event AboutToBeginPublishingEventHandler^ AboutToBeginPublishing {
    void add (AboutToBeginPublishingEventHandler^ value);
    void remove (AboutToBeginPublishingEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


AboutToEndPublishing Event

AboutToEndPublishing Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »AboutToEndPublishing
Declaration Syntax
C# Visual Basic Visual C++
public event AboutToEndPublishingEventHandler AboutToEndPublishing
Public Event AboutToEndPublishing As AboutToEndPublishingEventHandler
public:
 event AboutToEndPublishingEventHandler^ AboutToEndPublishing {
    void add (AboutToEndPublishingEventHandler^ value);
    void remove (AboutToEndPublishingEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


AboutToMoveFile Event

AboutToMoveFile Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »AboutToMoveFile
Declaration Syntax
C# Visual Basic Visual C++
public event AboutToMoveFileEventHandler AboutToMoveFile
Public Event AboutToMoveFile As AboutToMoveFileEventHandler
public:
 event AboutToMoveFileEventHandler^ AboutToMoveFile {
    void add (AboutToMoveFileEventHandler^ value);
    void remove (AboutToMoveFileEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


BeginAggregation Event

BeginAggregation Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »BeginAggregation
Declaration Syntax
C# Visual Basic Visual C++
public event BeginAggregationEventHandler BeginAggregation
Public Event BeginAggregation As BeginAggregationEventHandler
public:
 event BeginAggregationEventHandler^ BeginAggregation {
    void add (BeginAggregationEventHandler^ value);
    void remove (BeginAggregationEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


BeginEntity Event

BeginEntity Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »BeginEntity
Declaration Syntax
C# Visual Basic Visual C++
public event BeginEntityEventHandler BeginEntity
Public Event BeginEntity As BeginEntityEventHandler
public:
 event BeginEntityEventHandler^ BeginEntity {
    void add (BeginEntityEventHandler^ value);
    void remove (BeginEntityEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


BeginPublishingSheet Event

BeginPublishingSheet Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »BeginPublishingSheet
Declaration Syntax
C# Visual Basic Visual C++
public event BeginPublishingSheetEventHandler BeginPublishingSheet
Public Event BeginPublishingSheet As BeginPublishingSheetEventHandler
public:
 event BeginPublishingSheetEventHandler^ BeginPublishingSheet {
    void add (BeginPublishingSheetEventHandler^ value);
    void remove (BeginPublishingSheetEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


BeginSheet Event

BeginSheet Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »BeginSheet
Declaration Syntax
C# Visual Basic Visual C++
public event BeginSheetEventHandler BeginSheet
Public Event BeginSheet As BeginSheetEventHandler
public:
 event BeginSheetEventHandler^ BeginSheet {
    void add (BeginSheetEventHandler^ value);
    void remove (BeginSheetEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


CancelledOrFailedPublishing Event

CancelledOrFailedPublishing Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »CancelledOrFailedPublishing
Declaration Syntax
C# Visual Basic Visual C++
public event CancelledOrFailedPublishingEventHandler CancelledOrFailedPublishing
Public Event CancelledOrFailedPublishing As CancelledOrFailedPublishingEventHandler
public:
 event CancelledOrFailedPublishingEventHandler^ CancelledOrFailedPublishing {
    void add (CancelledOrFailedPublishingEventHandler^ value);
    void remove (CancelledOrFailedPublishingEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


CurrentPublishedSheetSetPath Property

CurrentPublishedSheetSetPath Property
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »CurrentPublishedSheetSetPath
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentPublishedSheetSetPath { get; }
Public ReadOnly Property CurrentPublishedSheetSetPath As String
    Get
public:
property String^ CurrentPublishedSheetSetPath {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EndEntity Event

EndEntity Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »EndEntity
Declaration Syntax
C# Visual Basic Visual C++
public event EndEntityEventHandler EndEntity
Public Event EndEntity As EndEntityEventHandler
public:
 event EndEntityEventHandler^ EndEntity {
    void add (EndEntityEventHandler^ value);
    void remove (EndEntityEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


EndPublish Event

EndPublish Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »EndPublish
Declaration Syntax
C# Visual Basic Visual C++
public event EndPublishEventHandler EndPublish
Public Event EndPublish As EndPublishEventHandler
public:
 event EndPublishEventHandler^ EndPublish {
    void add (EndPublishEventHandler^ value);
    void remove (EndPublishEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


EndSheet Event

EndSheet Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »EndSheet
Declaration Syntax
C# Visual Basic Visual C++
public event EndSheetEventHandler EndSheet
Public Event EndSheet As EndSheetEventHandler
public:
 event EndSheetEventHandler^ EndSheet {
    void add (EndSheetEventHandler^ value);
    void remove (EndSheetEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


FireAboutToBeginBackgroundPublishing Method (e)

FireAboutToBeginBackgroundPublishing Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireAboutToBeginBackgroundPublishing(AboutToBeginBackgroundPublishingEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireAboutToBeginBackgroundPublishing(
    AboutToBeginBackgroundPublishingEventArgs e
)
Public Sub FireAboutToBeginBackgroundPublishing ( _
    e As AboutToBeginBackgroundPublishingEventArgs _
)
public:
void FireAboutToBeginBackgroundPublishing(
    AboutToBeginBackgroundPublishingEventArgs^ e
)
Parameters
e(AboutToBeginBackgroundPublishingEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireAboutToBeginPublishing Method (e)

FireAboutToBeginPublishing Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireAboutToBeginPublishing(AboutToBeginPublishingEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireAboutToBeginPublishing(
    AboutToBeginPublishingEventArgs e
)
Public Sub FireAboutToBeginPublishing ( _
    e As AboutToBeginPublishingEventArgs _
)
public:
void FireAboutToBeginPublishing(
    AboutToBeginPublishingEventArgs^ e
)
Parameters
e(AboutToBeginPublishingEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireAboutToEndPublishing Method (e)

FireAboutToEndPublishing Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireAboutToEndPublishing(PublishEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireAboutToEndPublishing(
    PublishEventArgs e
)
Public Sub FireAboutToEndPublishing ( _
    e As PublishEventArgs _
)
public:
void FireAboutToEndPublishing(
    PublishEventArgs^ e
)
Parameters
e(PublishEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireAboutToMoveFile Method (e)

FireAboutToMoveFile Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireAboutToMoveFile(PublishEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireAboutToMoveFile(
    PublishEventArgs e
)
Public Sub FireAboutToMoveFile ( _
    e As PublishEventArgs _
)
public:
void FireAboutToMoveFile(
    PublishEventArgs^ e
)
Parameters
e(PublishEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireBeginAggregation Method (e)

FireBeginAggregation Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireBeginAggregation(BeginAggregationEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireBeginAggregation(
    BeginAggregationEventArgs e
)
Public Sub FireBeginAggregation ( _
    e As BeginAggregationEventArgs _
)
public:
void FireBeginAggregation(
    BeginAggregationEventArgs^ e
)
Parameters
e(BeginAggregationEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireBeginEntity Method (e)

FireBeginEntity Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireBeginEntity(PublishEntityEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireBeginEntity(
    PublishEntityEventArgs e
)
Public Sub FireBeginEntity ( _
    e As PublishEntityEventArgs _
)
public:
void FireBeginEntity(
    PublishEntityEventArgs^ e
)
Parameters
e(PublishEntityEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireBeginPublishingSheet Method (e)

FireBeginPublishingSheet Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireBeginPublishingSheet(BeginPublishingSheetEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireBeginPublishingSheet(
    BeginPublishingSheetEventArgs e
)
Public Sub FireBeginPublishingSheet ( _
    e As BeginPublishingSheetEventArgs _
)
public:
void FireBeginPublishingSheet(
    BeginPublishingSheetEventArgs^ e
)
Parameters
e(BeginPublishingSheetEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireBeginSheet Method (e)

FireBeginSheet Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireBeginSheet(PublishSheetEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireBeginSheet(
    PublishSheetEventArgs e
)
Public Sub FireBeginSheet ( _
    e As PublishSheetEventArgs _
)
public:
void FireBeginSheet(
    PublishSheetEventArgs^ e
)
Parameters
e(PublishSheetEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireCancelledOrFailedPublishing Method (e)

FireCancelledOrFailedPublishing Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireCancelledOrFailedPublishing(PublishEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireCancelledOrFailedPublishing(
    PublishEventArgs e
)
Public Sub FireCancelledOrFailedPublishing ( _
    e As PublishEventArgs _
)
public:
void FireCancelledOrFailedPublishing(
    PublishEventArgs^ e
)
Parameters
e(PublishEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireEndEntity Method (e)

FireEndEntity Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireEndEntity(PublishEntityEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireEndEntity(
    PublishEntityEventArgs e
)
Public Sub FireEndEntity ( _
    e As PublishEntityEventArgs _
)
public:
void FireEndEntity(
    PublishEntityEventArgs^ e
)
Parameters
e(PublishEntityEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireEndPublish Method (e)

FireEndPublish Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireEndPublish(PublishEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireEndPublish(
    PublishEventArgs e
)
Public Sub FireEndPublish ( _
    e As PublishEventArgs _
)
public:
void FireEndPublish(
    PublishEventArgs^ e
)
Parameters
e(PublishEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireEndSheet Method (e)

FireEndSheet Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireEndSheet(PublishSheetEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireEndSheet(
    PublishSheetEventArgs e
)
Public Sub FireEndSheet ( _
    e As PublishSheetEventArgs _
)
public:
void FireEndSheet(
    PublishSheetEventArgs^ e
)
Parameters
e(PublishSheetEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


FireInitPublishOptionsDialog Method (e)

FireInitPublishOptionsDialog Method (e)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »FireInitPublishOptionsDialog(PublishUIEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void FireInitPublishOptionsDialog(
    PublishUIEventArgs e
)
Public Sub FireInitPublishOptionsDialog ( _
    e As PublishUIEventArgs _
)
public:
void FireInitPublishOptionsDialog(
    PublishUIEventArgs^ e
)
Parameters
e(PublishUIEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


InitPublishOptionsDialog Event

InitPublishOptionsDialog Event
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »InitPublishOptionsDialog
Declaration Syntax
C# Visual Basic Visual C++
public event InitPublishOptionsDialogEventHandler InitPublishOptionsDialog
Public Event InitPublishOptionsDialog As InitPublishOptionsDialogEventHandler
public:
 event InitPublishOptionsDialogEventHandler^ InitPublishOptionsDialog {
    void add (InitPublishOptionsDialogEventHandler^ value);
    void remove (InitPublishOptionsDialogEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PublishDsd Method (dsdFile, plotProgressDialog)

PublishDsd Method (dsdFile, plotProgressDialog)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »PublishDsd(String, PlotProgressDialog)
Declaration Syntax
C# Visual Basic Visual C++
public int PublishDsd(
    string dsdFile,
    PlotProgressDialog plotProgressDialog
)
Public Function PublishDsd ( _
    dsdFile As String, _
    plotProgressDialog As PlotProgressDialog _
) As Integer
public:
int PublishDsd(
    String^ dsdFile,
    PlotProgressDialog^ plotProgressDialog
)
Parameters
dsdFile(String)
plotProgressDialog(PlotProgressDialog)

Assembly: ZwManaged (Module: ZwManaged)


PublishExecute Method (dsdData, plotConfig)

PublishExecute Method (dsdData, plotConfig)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »PublishExecute(DsdData, PlotConfig)
Declaration Syntax
C# Visual Basic Visual C++
public void PublishExecute(
    DsdData dsdData,
    PlotConfig plotConfig
)
Public Sub PublishExecute ( _
    dsdData As DsdData, _
    plotConfig As PlotConfig _
)
public:
void PublishExecute(
    DsdData^ dsdData,
    PlotConfig^ plotConfig
)
Parameters
dsdData(DsdData)
plotConfig(PlotConfig)

Assembly: ZwManaged (Module: ZwManaged)


PublishSelectedLayouts Method (bOverride)

PublishSelectedLayouts Method (bOverride)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »PublishSelectedLayouts(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void PublishSelectedLayouts(
    bool bOverride
)
Public Sub PublishSelectedLayouts ( _
    bOverride As Boolean _
)
public:
void PublishSelectedLayouts(
    bool bOverride
)
Parameters
bOverride(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


ShowDwfOptionsDialog Method (dsdData, plotConfig, optionsDialogTitle)

ShowDwfOptionsDialog Method (dsdData, plotConfig, optionsDialogTitle)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »ShowDwfOptionsDialog(DsdData, PlotConfig, String)
Declaration Syntax
C# Visual Basic Visual C++
public OptionsDialogResult ShowDwfOptionsDialog(
    DsdData dsdData,
    PlotConfig plotConfig,
    string optionsDialogTitle
)
Public Function ShowDwfOptionsDialog ( _
    dsdData As DsdData, _
    plotConfig As PlotConfig, _
    optionsDialogTitle As String _
) As OptionsDialogResult
public:
OptionsDialogResult ShowDwfOptionsDialog(
    DsdData^ dsdData,
    PlotConfig^ plotConfig,
    String^ optionsDialogTitle
)
Parameters
dsdData(DsdData)
plotConfig(PlotConfig)
optionsDialogTitle(String)

Assembly: ZwManaged (Module: ZwManaged)


ShowPublishDialog Method (dsdData, plotConfig, namePageSetups, namePageSetupPaths, optionsDialogTitle, optionsButtonText)

ShowPublishDialog Method (dsdData, plotConfig, namePageSetups, namePageSetupPaths, optionsDialogTitle, optionsButtonText)
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »ShowPublishDialog(DsdData, PlotConfig, StringCollection, StringCollection, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public void ShowPublishDialog(
    DsdData dsdData,
    PlotConfig plotConfig,
    StringCollection namePageSetups,
    StringCollection namePageSetupPaths,
    string optionsDialogTitle,
    string optionsButtonText
)
Public Sub ShowPublishDialog ( _
    dsdData As DsdData, _
    plotConfig As PlotConfig, _
    namePageSetups As StringCollection, _
    namePageSetupPaths As StringCollection, _
    optionsDialogTitle As String, _
    optionsButtonText As String _
)
public:
void ShowPublishDialog(
    DsdData^ dsdData,
    PlotConfig^ plotConfig,
    StringCollection^ namePageSetups,
    StringCollection^ namePageSetupPaths,
    String^ optionsDialogTitle,
    String^ optionsButtonText
)
Parameters
dsdData(DsdData)
plotConfig(PlotConfig)
namePageSetups(StringCollection)
namePageSetupPaths(StringCollection)
optionsDialogTitle(String)
optionsButtonText(String)

Assembly: ZwManaged (Module: ZwManaged)


PublishEventArgs Class

PublishEventArgs Class
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class PublishEventArgs : EventArgs
Public Class PublishEventArgs _
    Inherits EventArgs
public ref class PublishEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DwfFileName |
 | DwfPassword |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsMultiSheetDwf |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | TemporaryDwfFileName |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PublishEventArgs

Assembly: ZwManaged (Module: ZwManaged)


DwfFileName Property

DwfFileName Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEventArgs »DwfFileName
Declaration Syntax
C# Visual Basic Visual C++
public string DwfFileName { get; }
Public ReadOnly Property DwfFileName As String
    Get
public:
property String^ DwfFileName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DwfPassword Property

DwfPassword Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEventArgs »DwfPassword
Declaration Syntax
C# Visual Basic Visual C++
public string DwfPassword { get; }
Public ReadOnly Property DwfPassword As String
    Get
public:
property String^ DwfPassword {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsMultiSheetDwf Property

IsMultiSheetDwf Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEventArgs »IsMultiSheetDwf
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMultiSheetDwf { get; }
Public ReadOnly Property IsMultiSheetDwf As Boolean
    Get
public:
property bool IsMultiSheetDwf {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


TemporaryDwfFileName Property

TemporaryDwfFileName Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishEventArgs »TemporaryDwfFileName
Declaration Syntax
C# Visual Basic Visual C++
public string TemporaryDwfFileName { get; }
Public ReadOnly Property TemporaryDwfFileName As String
    Get
public:
property String^ TemporaryDwfFileName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PublishSheetEventArgs Class

PublishSheetEventArgs Class
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class PublishSheetEventArgs : EventArgs
Public Class PublishSheetEventArgs _
    Inherits EventArgs
public ref class PublishSheetEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddPagePropertyRange(array<EPlotProperty>[]()[][]) |
 | AddPageResourceRange(array<EPlotResource>[]()[][]) |
 | AreLinesHidden |
 | ArePlottingLineWeights |
 | AreScalingLineWeights |
 | CanonicalMediaName |
 | Configuration |
 | Database |
 | DisplayMaxX |
 | DisplayMaxY |
 | DisplayMinX |
 | DisplayMinY |
 | DrawingScale |
 | EffectivePlotOffsetX |
 | EffectivePlotOffsetXDevice |
 | EffectivePlotOffsetY |
 | EffectivePlotOffsetYDevice |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsModelLayout |
 | IsPlotJobCancelled |
 | IsScaleSpecified |
 | LayoutBoundsMaxX |
 | LayoutBoundsMaxY |
 | LayoutBoundsMinX |
 | LayoutBoundsMinY |
 | LayoutMarginMaxX |
 | LayoutMarginMaxY |
 | LayoutMarginMinX |
 | LayoutMarginMinY |
 | MaxBoundsX |
 | MaxBoundsY |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OriginX |
 | OriginY |
 | PaperScale |
 | PlotBoundsMaxX |
 | PlotBoundsMaxY |
 | PlotBoundsMinX |
 | PlotBoundsMinY |
 | PlotLayoutId |
 | PlotLogger |
 | PlotPaperUnit |
 | PlotRotation |
 | PlotToFileName |
 | PlotToFilePath |
 | PlotType |
 | PlotWindowMaxX |
 | PlotWindowMaxY |
 | PlotWindowMinX |
 | PlotWindowMinY |
 | PrintableBoundsX |
 | PrintableBoundsY |
 | PublishingTo3DDwf |
 | StepsPerInch |
 | ToString()()()() | (Inherited from Object.)
 | UniqueLayoutId |
 | ViewPlotted |
Inheritance Hierarchy
Object
 | EventArgs
 |  | PublishSheetEventArgs

Assembly: ZwManaged (Module: ZwManaged)


AddPagePropertyRange Method (properties)

AddPagePropertyRange Method (properties)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »AddPagePropertyRange(array<EPlotProperty>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddPagePropertyRange(
    EPlotProperty[] properties
)
Public Sub AddPagePropertyRange ( _
    properties As EPlotProperty() _
)
public:
void AddPagePropertyRange(
    array<EPlotProperty^>^ properties
)
Parameters
properties(array< EPlotProperty >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


AddPageResourceRange Method (resources)

AddPageResourceRange Method (resources)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »AddPageResourceRange(array<EPlotResource>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddPageResourceRange(
    EPlotResource[] resources
)
Public Sub AddPageResourceRange ( _
    resources As EPlotResource() _
)
public:
void AddPageResourceRange(
    array<EPlotResource^>^ resources
)
Parameters
resources(array< EPlotResource >[]()[][])

Assembly: ZwManaged (Module: ZwManaged)


AreLinesHidden Property

AreLinesHidden Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »AreLinesHidden
Declaration Syntax
C# Visual Basic Visual C++
public bool AreLinesHidden { get; }
Public ReadOnly Property AreLinesHidden As Boolean
    Get
public:
property bool AreLinesHidden {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ArePlottingLineWeights Property

ArePlottingLineWeights Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »ArePlottingLineWeights
Declaration Syntax
C# Visual Basic Visual C++
public bool ArePlottingLineWeights { get; }
Public ReadOnly Property ArePlottingLineWeights As Boolean
    Get
public:
property bool ArePlottingLineWeights {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


AreScalingLineWeights Property

AreScalingLineWeights Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »AreScalingLineWeights
Declaration Syntax
C# Visual Basic Visual C++
public bool AreScalingLineWeights { get; }
Public ReadOnly Property AreScalingLineWeights As Boolean
    Get
public:
property bool AreScalingLineWeights {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


CanonicalMediaName Property

CanonicalMediaName Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »CanonicalMediaName
Declaration Syntax
C# Visual Basic Visual C++
public string CanonicalMediaName { get; }
Public ReadOnly Property CanonicalMediaName As String
    Get
public:
property String^ CanonicalMediaName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Configuration Property

Configuration Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »Configuration
Declaration Syntax
C# Visual Basic Visual C++
public string Configuration { get; }
Public ReadOnly Property Configuration As String
    Get
public:
property String^ Configuration {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Database Property

Database Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »Database
Declaration Syntax
C# Visual Basic Visual C++
public Database Database { get; }
Public ReadOnly Property Database As Database
    Get
public:
property Database^ Database {
    Database^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DisplayMaxX Property

DisplayMaxX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »DisplayMaxX
Declaration Syntax
C# Visual Basic Visual C++
public double DisplayMaxX { get; }
Public ReadOnly Property DisplayMaxX As Double
    Get
public:
property double DisplayMaxX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DisplayMaxY Property

DisplayMaxY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »DisplayMaxY
Declaration Syntax
C# Visual Basic Visual C++
public double DisplayMaxY { get; }
Public ReadOnly Property DisplayMaxY As Double
    Get
public:
property double DisplayMaxY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DisplayMinX Property

DisplayMinX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »DisplayMinX
Declaration Syntax
C# Visual Basic Visual C++
public double DisplayMinX { get; }
Public ReadOnly Property DisplayMinX As Double
    Get
public:
property double DisplayMinX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DisplayMinY Property

DisplayMinY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »DisplayMinY
Declaration Syntax
C# Visual Basic Visual C++
public double DisplayMinY { get; }
Public ReadOnly Property DisplayMinY As Double
    Get
public:
property double DisplayMinY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DrawingScale Property

DrawingScale Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »DrawingScale
Declaration Syntax
C# Visual Basic Visual C++
public double DrawingScale { get; }
Public ReadOnly Property DrawingScale As Double
    Get
public:
property double DrawingScale {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EffectivePlotOffsetX Property

EffectivePlotOffsetX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »EffectivePlotOffsetX
Declaration Syntax
C# Visual Basic Visual C++
public double EffectivePlotOffsetX { get; }
Public ReadOnly Property EffectivePlotOffsetX As Double
    Get
public:
property double EffectivePlotOffsetX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EffectivePlotOffsetXDevice Property

EffectivePlotOffsetXDevice Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »EffectivePlotOffsetXDevice
Declaration Syntax
C# Visual Basic Visual C++
public int EffectivePlotOffsetXDevice { get; }
Public ReadOnly Property EffectivePlotOffsetXDevice As Integer
    Get
public:
property int EffectivePlotOffsetXDevice {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EffectivePlotOffsetY Property

EffectivePlotOffsetY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »EffectivePlotOffsetY
Declaration Syntax
C# Visual Basic Visual C++
public double EffectivePlotOffsetY { get; }
Public ReadOnly Property EffectivePlotOffsetY As Double
    Get
public:
property double EffectivePlotOffsetY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


EffectivePlotOffsetYDevice Property

EffectivePlotOffsetYDevice Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »EffectivePlotOffsetYDevice
Declaration Syntax
C# Visual Basic Visual C++
public int EffectivePlotOffsetYDevice { get; }
Public ReadOnly Property EffectivePlotOffsetYDevice As Integer
    Get
public:
property int EffectivePlotOffsetYDevice {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsModelLayout Property

IsModelLayout Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »IsModelLayout
Declaration Syntax
C# Visual Basic Visual C++
public bool IsModelLayout { get; }
Public ReadOnly Property IsModelLayout As Boolean
    Get
public:
property bool IsModelLayout {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsPlotJobCancelled Property

IsPlotJobCancelled Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »IsPlotJobCancelled
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPlotJobCancelled { get; }
Public ReadOnly Property IsPlotJobCancelled As Boolean
    Get
public:
property bool IsPlotJobCancelled {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsScaleSpecified Property

IsScaleSpecified Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »IsScaleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScaleSpecified { get; }
Public ReadOnly Property IsScaleSpecified As Boolean
    Get
public:
property bool IsScaleSpecified {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LayoutBoundsMaxX Property

LayoutBoundsMaxX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »LayoutBoundsMaxX
Declaration Syntax
C# Visual Basic Visual C++
public double LayoutBoundsMaxX { get; }
Public ReadOnly Property LayoutBoundsMaxX As Double
    Get
public:
property double LayoutBoundsMaxX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LayoutBoundsMaxY Property

LayoutBoundsMaxY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »LayoutBoundsMaxY
Declaration Syntax
C# Visual Basic Visual C++
public double LayoutBoundsMaxY { get; }
Public ReadOnly Property LayoutBoundsMaxY As Double
    Get
public:
property double LayoutBoundsMaxY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LayoutBoundsMinX Property

LayoutBoundsMinX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »LayoutBoundsMinX
Declaration Syntax
C# Visual Basic Visual C++
public double LayoutBoundsMinX { get; }
Public ReadOnly Property LayoutBoundsMinX As Double
    Get
public:
property double LayoutBoundsMinX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LayoutBoundsMinY Property

LayoutBoundsMinY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »LayoutBoundsMinY
Declaration Syntax
C# Visual Basic Visual C++
public double LayoutBoundsMinY { get; }
Public ReadOnly Property LayoutBoundsMinY As Double
    Get
public:
property double LayoutBoundsMinY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LayoutMarginMaxX Property

LayoutMarginMaxX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »LayoutMarginMaxX
Declaration Syntax
C# Visual Basic Visual C++
public double LayoutMarginMaxX { get; }
Public ReadOnly Property LayoutMarginMaxX As Double
    Get
public:
property double LayoutMarginMaxX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LayoutMarginMaxY Property

LayoutMarginMaxY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »LayoutMarginMaxY
Declaration Syntax
C# Visual Basic Visual C++
public double LayoutMarginMaxY { get; }
Public ReadOnly Property LayoutMarginMaxY As Double
    Get
public:
property double LayoutMarginMaxY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LayoutMarginMinX Property

LayoutMarginMinX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »LayoutMarginMinX
Declaration Syntax
C# Visual Basic Visual C++
public double LayoutMarginMinX { get; }
Public ReadOnly Property LayoutMarginMinX As Double
    Get
public:
property double LayoutMarginMinX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LayoutMarginMinY Property

LayoutMarginMinY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »LayoutMarginMinY
Declaration Syntax
C# Visual Basic Visual C++
public double LayoutMarginMinY { get; }
Public ReadOnly Property LayoutMarginMinY As Double
    Get
public:
property double LayoutMarginMinY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MaxBoundsX Property

MaxBoundsX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »MaxBoundsX
Declaration Syntax
C# Visual Basic Visual C++
public double MaxBoundsX { get; }
Public ReadOnly Property MaxBoundsX As Double
    Get
public:
property double MaxBoundsX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MaxBoundsY Property

MaxBoundsY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »MaxBoundsY
Declaration Syntax
C# Visual Basic Visual C++
public double MaxBoundsY { get; }
Public ReadOnly Property MaxBoundsY As Double
    Get
public:
property double MaxBoundsY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OriginX Property

OriginX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »OriginX
Declaration Syntax
C# Visual Basic Visual C++
public double OriginX { get; }
Public ReadOnly Property OriginX As Double
    Get
public:
property double OriginX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OriginY Property

OriginY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »OriginY
Declaration Syntax
C# Visual Basic Visual C++
public double OriginY { get; }
Public ReadOnly Property OriginY As Double
    Get
public:
property double OriginY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PaperScale Property

PaperScale Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PaperScale
Declaration Syntax
C# Visual Basic Visual C++
public double PaperScale { get; }
Public ReadOnly Property PaperScale As Double
    Get
public:
property double PaperScale {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotBoundsMaxX Property

PlotBoundsMaxX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotBoundsMaxX
Declaration Syntax
C# Visual Basic Visual C++
public double PlotBoundsMaxX { get; }
Public ReadOnly Property PlotBoundsMaxX As Double
    Get
public:
property double PlotBoundsMaxX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotBoundsMaxY Property

PlotBoundsMaxY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotBoundsMaxY
Declaration Syntax
C# Visual Basic Visual C++
public double PlotBoundsMaxY { get; }
Public ReadOnly Property PlotBoundsMaxY As Double
    Get
public:
property double PlotBoundsMaxY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotBoundsMinX Property

PlotBoundsMinX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotBoundsMinX
Declaration Syntax
C# Visual Basic Visual C++
public double PlotBoundsMinX { get; }
Public ReadOnly Property PlotBoundsMinX As Double
    Get
public:
property double PlotBoundsMinX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotBoundsMinY Property

PlotBoundsMinY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotBoundsMinY
Declaration Syntax
C# Visual Basic Visual C++
public double PlotBoundsMinY { get; }
Public ReadOnly Property PlotBoundsMinY As Double
    Get
public:
property double PlotBoundsMinY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotLayoutId Property

PlotLayoutId Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotLayoutId
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId PlotLayoutId { get; }
Public ReadOnly Property PlotLayoutId As ObjectId
    Get
public:
property ObjectId PlotLayoutId {
    ObjectId get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotLogger Property

PlotLogger Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotLogger
Declaration Syntax
C# Visual Basic Visual C++
public PlotLogger PlotLogger { get; }
Public ReadOnly Property PlotLogger As PlotLogger
    Get
public:
property PlotLogger^ PlotLogger {
    PlotLogger^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotPaperUnit Property

PlotPaperUnit Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotPaperUnit
Declaration Syntax
C# Visual Basic Visual C++
public PlotPaperUnit PlotPaperUnit { get; }
Public ReadOnly Property PlotPaperUnit As PlotPaperUnit
    Get
public:
property PlotPaperUnit PlotPaperUnit {
    PlotPaperUnit get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotRotation Property

PlotRotation Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotRotation
Declaration Syntax
C# Visual Basic Visual C++
public PlotRotation PlotRotation { get; }
Public ReadOnly Property PlotRotation As PlotRotation
    Get
public:
property PlotRotation PlotRotation {
    PlotRotation get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotToFileName Property

PlotToFileName Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotToFileName
Declaration Syntax
C# Visual Basic Visual C++
public string PlotToFileName { get; }
Public ReadOnly Property PlotToFileName As String
    Get
public:
property String^ PlotToFileName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotToFilePath Property

PlotToFilePath Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotToFilePath
Declaration Syntax
C# Visual Basic Visual C++
public string PlotToFilePath { get; }
Public ReadOnly Property PlotToFilePath As String
    Get
public:
property String^ PlotToFilePath {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotType Property

PlotType Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotType
Declaration Syntax
C# Visual Basic Visual C++
public PlotType PlotType { get; }
Public ReadOnly Property PlotType As PlotType
    Get
public:
property PlotType PlotType {
    PlotType get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotWindowMaxX Property

PlotWindowMaxX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotWindowMaxX
Declaration Syntax
C# Visual Basic Visual C++
public double PlotWindowMaxX { get; }
Public ReadOnly Property PlotWindowMaxX As Double
    Get
public:
property double PlotWindowMaxX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotWindowMaxY Property

PlotWindowMaxY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotWindowMaxY
Declaration Syntax
C# Visual Basic Visual C++
public double PlotWindowMaxY { get; }
Public ReadOnly Property PlotWindowMaxY As Double
    Get
public:
property double PlotWindowMaxY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotWindowMinX Property

PlotWindowMinX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotWindowMinX
Declaration Syntax
C# Visual Basic Visual C++
public double PlotWindowMinX { get; }
Public ReadOnly Property PlotWindowMinX As Double
    Get
public:
property double PlotWindowMinX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PlotWindowMinY Property

PlotWindowMinY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PlotWindowMinY
Declaration Syntax
C# Visual Basic Visual C++
public double PlotWindowMinY { get; }
Public ReadOnly Property PlotWindowMinY As Double
    Get
public:
property double PlotWindowMinY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PrintableBoundsX Property

PrintableBoundsX Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PrintableBoundsX
Declaration Syntax
C# Visual Basic Visual C++
public double PrintableBoundsX { get; }
Public ReadOnly Property PrintableBoundsX As Double
    Get
public:
property double PrintableBoundsX {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PrintableBoundsY Property

PrintableBoundsY Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PrintableBoundsY
Declaration Syntax
C# Visual Basic Visual C++
public double PrintableBoundsY { get; }
Public ReadOnly Property PrintableBoundsY As Double
    Get
public:
property double PrintableBoundsY {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PublishingTo3DDwf Property

PublishingTo3DDwf Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »PublishingTo3DDwf
Declaration Syntax
C# Visual Basic Visual C++
public bool PublishingTo3DDwf { get; }
Public ReadOnly Property PublishingTo3DDwf As Boolean
    Get
public:
property bool PublishingTo3DDwf {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


StepsPerInch Property

StepsPerInch Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »StepsPerInch
Declaration Syntax
C# Visual Basic Visual C++
public double StepsPerInch { get; }
Public ReadOnly Property StepsPerInch As Double
    Get
public:
property double StepsPerInch {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


UniqueLayoutId Property

UniqueLayoutId Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »UniqueLayoutId
Declaration Syntax
C# Visual Basic Visual C++
public string UniqueLayoutId { get; }
Public ReadOnly Property UniqueLayoutId As String
    Get
public:
property String^ UniqueLayoutId {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ViewPlotted Property

ViewPlotted Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishSheetEventArgs »ViewPlotted
Declaration Syntax
C# Visual Basic Visual C++
public string ViewPlotted { get; }
Public ReadOnly Property ViewPlotted As String
    Get
public:
property String^ ViewPlotted {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PublishUIEventArgs Class

PublishUIEventArgs Class
Namespaces »ZwSoft.ZwCAD.Publishing »PublishUIEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class PublishUIEventArgs : EventArgs
Public Class PublishUIEventArgs _
    Inherits EventArgs
public ref class PublishUIEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DsdData |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IUnknown |
 | JobWillPublishInBackground |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReadPrivateSection(String) |
 | ToString()()()() | (Inherited from Object.)
 | WritePrivateSection(String, IDictionaryEnumerator) |
Inheritance Hierarchy
Object
 | EventArgs
 |  | PublishUIEventArgs

Assembly: ZwManaged (Module: ZwManaged)


DsdData Property

DsdData Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishUIEventArgs »DsdData
Declaration Syntax
C# Visual Basic Visual C++
public DsdData DsdData { get; }
Public ReadOnly Property DsdData As DsdData
    Get
public:
property DsdData^ DsdData {
    DsdData^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IUnknown Property

IUnknown Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishUIEventArgs »IUnknown
Declaration Syntax
C# Visual Basic Visual C++
public IUnknown** IUnknown { get; }
Visual Basic does not support APIs that consume or return unsafe types.
public:
property IUnknown** IUnknown {
    IUnknown** get ();
}

Assembly: ZwManaged (Module: ZwManaged)


JobWillPublishInBackground Property

JobWillPublishInBackground Property
Namespaces »ZwSoft.ZwCAD.Publishing »PublishUIEventArgs »JobWillPublishInBackground
Declaration Syntax
C# Visual Basic Visual C++
public bool JobWillPublishInBackground { get; }
Public ReadOnly Property JobWillPublishInBackground As Boolean
    Get
public:
property bool JobWillPublishInBackground {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ReadPrivateSection Method (sectionName)

ReadPrivateSection Method (sectionName)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishUIEventArgs »ReadPrivateSection(String)
Declaration Syntax
C# Visual Basic Visual C++
public IDictionaryEnumerator ReadPrivateSection(
    string sectionName
)
Public Function ReadPrivateSection ( _
    sectionName As String _
) As IDictionaryEnumerator
public:
IDictionaryEnumerator^ ReadPrivateSection(
    String^ sectionName
)
Parameters
sectionName(String)

Assembly: ZwManaged (Module: ZwManaged)


WritePrivateSection Method (sectionName, data)

WritePrivateSection Method (sectionName, data)
Namespaces »ZwSoft.ZwCAD.Publishing »PublishUIEventArgs »WritePrivateSection(String, IDictionaryEnumerator)
Declaration Syntax
C# Visual Basic Visual C++
public void WritePrivateSection(
    string sectionName,
    IDictionaryEnumerator data
)
Public Sub WritePrivateSection ( _
    sectionName As String, _
    data As IDictionaryEnumerator _
)
public:
void WritePrivateSection(
    String^ sectionName,
    IDictionaryEnumerator^ data
)
Parameters
sectionName(String)
data(IDictionaryEnumerator)

Assembly: ZwManaged (Module: ZwManaged)


ZwSoft.ZwCAD.Runtime Namespace

ZwSoft.ZwCAD.Runtime Namespace
Namespaces »ZwSoft.ZwCAD.Runtime
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.Runtime
Namespace ZwSoft.ZwCAD.Runtime
namespace ZwSoft.ZwCAD.Runtime
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | AngularUnitFormat |
 | ExtensionLoader..::..BeforeLoadHandler |
 | CommandClassAttribute |
 | CommandFlags |
 | CommandInvokeHandler |
 | CommandMethodAttribute |
 | Converter |
 | Dictionary |
 | DictionaryIterator |
 | DisposableWrapper |
 | DistanceUnitFormat |
 | DynamicLinker |
 | DynamicLinkerEventArgs |
 | ErrorStatus |
 | Exception |
 | ExtensionApplicationAttribute |
 | ExtensionApplicationHolder |
 | ExtensionLoader |
 | ICommandLineCallable |
 | IExtensionApplication |
 | Interop |
 | LispDataType |
 | LispFunctionAttribute |
 | LispInvokeHandler |
 | Marshaler |
 | ModuleLoadAbortedEventHandler |
 | ModuleLoadedEventHandler |
 | ModuleLoadingEventHandler |
 | ModuleUnloadAbortedEventHandler |
 | ModuleUnloadedEventHandler |
 | ModuleUnloadingEventHandler |
 | NetCommandDebugHelper |
 | RXClass |
 | RXObject |
 | SecuredApplicationAttribute |
 | SystemObjects |
 | WrapperAttribute |


AngularUnitFormat Enumeration

AngularUnitFormat Enumeration
Namespaces »ZwSoft.ZwCAD.Runtime »AngularUnitFormat
Declaration Syntax
C# Visual Basic Visual C++
public enum AngularUnitFormat
Public Enumeration AngularUnitFormat
public enum class AngularUnitFormat
Members
Member | Description
Surveyor |
Radians |
Grads |
DegreesMinutesSeconds |
Degrees |
Current |

Assembly: ZwManaged (Module: ZwManaged)


CommandClassAttribute Class

CommandClassAttribute Class
Namespaces »ZwSoft.ZwCAD.Runtime »CommandClassAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = true, Inherited = false)]
public sealed class CommandClassAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple := True, Inherited := False)> _
Public NotInheritable Class CommandClassAttribute _
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple = true, Inherited = false)]
public ref class CommandClassAttribute sealed : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandClassAttribute(Type) |
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | TypeId | (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | CommandClassAttribute

Assembly: ZwManaged (Module: ZwManaged)


CommandClassAttribute Constructor (name)

CommandClassAttribute Constructor (name)
Namespaces »ZwSoft.ZwCAD.Runtime »CommandClassAttribute »CommandClassAttribute(Type)
Declaration Syntax
C# Visual Basic Visual C++
public CommandClassAttribute(
    Type name
)
Public Sub New ( _
    name As Type _
)
public:
CommandClassAttribute(
    Type^ name
)
Parameters
name(Type)

Assembly: ZwManaged (Module: ZwManaged)


Type Property

Type Property
Namespaces »ZwSoft.ZwCAD.Runtime »CommandClassAttribute »Type
Declaration Syntax
C# Visual Basic Visual C++
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


CommandFlags Enumeration

CommandFlags Enumeration
Namespaces »ZwSoft.ZwCAD.Runtime »CommandFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum CommandFlags
<FlagsAttribute> _
Public Enumeration CommandFlags
[FlagsAttribute]
public enum class CommandFlags
Members
Member | Description
Transparent |
NoHistory |
Interruptible |
Session |
DocExclusiveLock |
DocReadLock |
NoInternalLock |
NoNewStack |
Defun |
InProgress |
Undefined |
NoOem |
PlotOnly |
NoPaperSpace |
NoTileMode |
NoMultiple |
NoPerspective |
Redraw |
UsePickSet |
Modal |

Assembly: ZwManaged (Module: ZwManaged)


CommandInvokeHandler Delegate

CommandInvokeHandler Delegate
Namespaces »ZwSoft.ZwCAD.Runtime »CommandInvokeHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void CommandInvokeHandler()
Public Delegate Sub CommandInvokeHandler
public delegate void CommandInvokeHandler()

Assembly: ZwManaged (Module: ZwManaged)


CommandMethodAttribute Class

CommandMethodAttribute Class
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = true, Inherited = false)]
public sealed class CommandMethodAttribute : Attribute,
    ICommandLineCallable
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := True, Inherited := False)> _
Public NotInheritable Class CommandMethodAttribute _
    Inherits Attribute _
    Implements ICommandLineCallable
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = true, Inherited = false)]
public ref class CommandMethodAttribute sealed : public Attribute,
    ICommandLineCallable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommandMethodAttribute(String, String, String, CommandFlags, Type, String, String) |
 | CommandMethodAttribute(String, String, String, CommandFlags, Type) |
 | CommandMethodAttribute(String, String, String, CommandFlags, String) |
 | CommandMethodAttribute(String, String, String, CommandFlags) |
 | CommandMethodAttribute(String, String, CommandFlags) |
 | CommandMethodAttribute(String, CommandFlags) |
 | CommandMethodAttribute(String) |
 | ContextMenuExtensionType |
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | Flags |
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | GlobalName |
 | GroupName |
 | HelpFileName |
 | HelpTopic |
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | LocalizedNameId |
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | CommandMethodAttribute

Assembly: ZwManaged (Module: ZwManaged)


CommandMethodAttribute Constructor

CommandMethodAttribute Constructor
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »CommandMethodAttribute()()()()
Members
Icon | Member | Description
 | CommandMethodAttribute(String, String, String, CommandFlags, Type, String, String) |
 | CommandMethodAttribute(String, String, String, CommandFlags, Type) |
 | CommandMethodAttribute(String, String, String, CommandFlags, String) |
 | CommandMethodAttribute(String, String, String, CommandFlags) |
 | CommandMethodAttribute(String, String, CommandFlags) |
 | CommandMethodAttribute(String, CommandFlags) |
 | CommandMethodAttribute(String) |

Assembly: ZwManaged (Module: ZwManaged)


CommandMethodAttribute Constructor (globalName)

CommandMethodAttribute Constructor (globalName)
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »CommandMethodAttribute(String)
Declaration Syntax
C# Visual Basic Visual C++
public CommandMethodAttribute(
    string globalName
)
Public Sub New ( _
    globalName As String _
)
public:
CommandMethodAttribute(
    String^ globalName
)
Parameters
globalName(String)

Assembly: ZwManaged (Module: ZwManaged)


CommandMethodAttribute Constructor (groupName, globalName, localizedNameId, flags)

CommandMethodAttribute Constructor (groupName, globalName, localizedNameId, flags)
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »CommandMethodAttribute(String, String, String, CommandFlags)
Declaration Syntax
C# Visual Basic Visual C++
public CommandMethodAttribute(
    string groupName,
    string globalName,
    string localizedNameId,
    CommandFlags flags
)
Public Sub New ( _
    groupName As String, _
    globalName As String, _
    localizedNameId As String, _
    flags As CommandFlags _
)
public:
CommandMethodAttribute(
    String^ groupName,
    String^ globalName,
    String^ localizedNameId,
    CommandFlags flags
)
Parameters
groupName(String)
globalName(String)
localizedNameId(String)
flags(CommandFlags)

Assembly: ZwManaged (Module: ZwManaged)


CommandMethodAttribute Constructor (groupName, globalName, localizedNameId, flags, helpTopic)

CommandMethodAttribute Constructor (groupName, globalName, localizedNameId, flags, helpTopic)
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »CommandMethodAttribute(String, String, String, CommandFlags, String)
Declaration Syntax
C# Visual Basic Visual C++
public CommandMethodAttribute(
    string groupName,
    string globalName,
    string localizedNameId,
    CommandFlags flags,
    string helpTopic
)
Public Sub New ( _
    groupName As String, _
    globalName As String, _
    localizedNameId As String, _
    flags As CommandFlags, _
    helpTopic As String _
)
public:
CommandMethodAttribute(
    String^ groupName,
    String^ globalName,
    String^ localizedNameId,
    CommandFlags flags,
    String^ helpTopic
)
Parameters
groupName(String)
globalName(String)
localizedNameId(String)
flags(CommandFlags)
helpTopic(String)

Assembly: ZwManaged (Module: ZwManaged)


CommandMethodAttribute Constructor (groupName, globalName, localizedNameId, flags, contextMenuExtensionType)

CommandMethodAttribute Constructor (groupName, globalName, localizedNameId, flags, contextMenuExtensionType)
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »CommandMethodAttribute(String, String, String, CommandFlags, Type)
Declaration Syntax
C# Visual Basic Visual C++
public CommandMethodAttribute(
    string groupName,
    string globalName,
    string localizedNameId,
    CommandFlags flags,
    Type contextMenuExtensionType
)
Public Sub New ( _
    groupName As String, _
    globalName As String, _
    localizedNameId As String, _
    flags As CommandFlags, _
    contextMenuExtensionType As Type _
)
public:
CommandMethodAttribute(
    String^ groupName,
    String^ globalName,
    String^ localizedNameId,
    CommandFlags flags,
    Type^ contextMenuExtensionType
)
Parameters
groupName(String)
globalName(String)
localizedNameId(String)
flags(CommandFlags)
contextMenuExtensionType(Type)

Assembly: ZwManaged (Module: ZwManaged)


CommandMethodAttribute Constructor (groupName, globalName, localizedNameId, flags, contextMenuExtensionType, helpFileName, helpTopic)

CommandMethodAttribute Constructor (groupName, globalName, localizedNameId, flags, contextMenuExtensionType, helpFileName, helpTopic)
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »CommandMethodAttribute(String, String, String, CommandFlags, Type, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public CommandMethodAttribute(
    string groupName,
    string globalName,
    string localizedNameId,
    CommandFlags flags,
    Type contextMenuExtensionType,
    string helpFileName,
    string helpTopic
)
Public Sub New ( _
    groupName As String, _
    globalName As String, _
    localizedNameId As String, _
    flags As CommandFlags, _
    contextMenuExtensionType As Type, _
    helpFileName As String, _
    helpTopic As String _
)
public:
CommandMethodAttribute(
    String^ groupName,
    String^ globalName,
    String^ localizedNameId,
    CommandFlags flags,
    Type^ contextMenuExtensionType,
    String^ helpFileName,
    String^ helpTopic
)
Parameters
groupName(String)
globalName(String)
localizedNameId(String)
flags(CommandFlags)
contextMenuExtensionType(Type)
helpFileName(String)
helpTopic(String)

Assembly: ZwManaged (Module: ZwManaged)


CommandMethodAttribute Constructor (groupName, globalName, flags)

CommandMethodAttribute Constructor (groupName, globalName, flags)
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »CommandMethodAttribute(String, String, CommandFlags)
Declaration Syntax
C# Visual Basic Visual C++
public CommandMethodAttribute(
    string groupName,
    string globalName,
    CommandFlags flags
)
Public Sub New ( _
    groupName As String, _
    globalName As String, _
    flags As CommandFlags _
)
public:
CommandMethodAttribute(
    String^ groupName,
    String^ globalName,
    CommandFlags flags
)
Parameters
groupName(String)
globalName(String)
flags(CommandFlags)

Assembly: ZwManaged (Module: ZwManaged)


CommandMethodAttribute Constructor (globalName, flags)

CommandMethodAttribute Constructor (globalName, flags)
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »CommandMethodAttribute(String, CommandFlags)
Declaration Syntax
C# Visual Basic Visual C++
public CommandMethodAttribute(
    string globalName,
    CommandFlags flags
)
Public Sub New ( _
    globalName As String, _
    flags As CommandFlags _
)
public:
CommandMethodAttribute(
    String^ globalName,
    CommandFlags flags
)
Parameters
globalName(String)
flags(CommandFlags)

Assembly: ZwManaged (Module: ZwManaged)


ContextMenuExtensionType Property

ContextMenuExtensionType Property
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »ContextMenuExtensionType
Declaration Syntax
C# Visual Basic Visual C++
public virtual Type ContextMenuExtensionType { get; }
Public Overridable ReadOnly Property ContextMenuExtensionType As Type
    Get
public:
virtual property Type^ ContextMenuExtensionType {
    Type^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Flags Property

Flags Property
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »Flags
Declaration Syntax
C# Visual Basic Visual C++
public virtual CommandFlags Flags { get; }
Public Overridable ReadOnly Property Flags As CommandFlags
    Get
public:
virtual property CommandFlags Flags {
    CommandFlags get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GlobalName Property

GlobalName Property
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »GlobalName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GlobalName { get; }
Public Overridable ReadOnly Property GlobalName As String
    Get
public:
virtual property String^ GlobalName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GroupName Property

GroupName Property
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »GroupName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GroupName { get; }
Public Overridable ReadOnly Property GroupName As String
    Get
public:
virtual property String^ GroupName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


HelpFileName Property

HelpFileName Property
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »HelpFileName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string HelpFileName { get; }
Public Overridable ReadOnly Property HelpFileName As String
    Get
public:
virtual property String^ HelpFileName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


HelpTopic Property

HelpTopic Property
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »HelpTopic
Declaration Syntax
C# Visual Basic Visual C++
public virtual string HelpTopic { get; }
Public Overridable ReadOnly Property HelpTopic As String
    Get
public:
virtual property String^ HelpTopic {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LocalizedNameId Property

LocalizedNameId Property
Namespaces »ZwSoft.ZwCAD.Runtime »CommandMethodAttribute »LocalizedNameId
Declaration Syntax
C# Visual Basic Visual C++
public virtual string LocalizedNameId { get; }
Public Overridable ReadOnly Property LocalizedNameId As String
    Get
public:
virtual property String^ LocalizedNameId {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Converter Class

Converter Class
Namespaces »ZwSoft.ZwCAD.Runtime »Converter
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Converter
Public NotInheritable Class Converter
public ref class Converter sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AngleToString(Double, AngularUnitFormat, Int32) |
 | AngleToString(Double) |
 | DistanceToString(Double, DistanceUnitFormat, Int32) |
 | DistanceToString(Double) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RawAngleToString(Double, AngularUnitFormat, Int32) |
 | RawAngleToString(Double) |
 | StringToAngle(String, AngularUnitFormat) |
 | StringToAngle(String) |
 | StringToDistance(String, DistanceUnitFormat) |
 | StringToDistance(String) |
 | StringToRawAngle(String, AngularUnitFormat) |
 | StringToRawAngle(String) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Converter

Assembly: ZwManaged (Module: ZwManaged)


AngleToString Method

AngleToString Method
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »AngleToString()()()()
Members
Icon | Member | Description
 | AngleToString(Double, AngularUnitFormat, Int32) |
 | AngleToString(Double) |

Assembly: ZwManaged (Module: ZwManaged)


AngleToString Method (value)

AngleToString Method (value)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »AngleToString(Double)
Declaration Syntax
C# Visual Basic Visual C++
public static string AngleToString(
    double value
)
Public Shared Function AngleToString ( _
    value As Double _
) As String
public:
static String^ AngleToString(
    double value
)
Parameters
value(Double)

Assembly: ZwManaged (Module: ZwManaged)


AngleToString Method (value, units, precision)

AngleToString Method (value, units, precision)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »AngleToString(Double, AngularUnitFormat, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static string AngleToString(
    double value,
    AngularUnitFormat units,
    int precision
)
Public Shared Function AngleToString ( _
    value As Double, _
    units As AngularUnitFormat, _
    precision As Integer _
) As String
public:
static String^ AngleToString(
    double value,
    AngularUnitFormat units,
    int precision
)
Parameters
value(Double)
units(AngularUnitFormat)
precision(Int32)

Assembly: ZwManaged (Module: ZwManaged)


DistanceToString Method

DistanceToString Method
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »DistanceToString()()()()
Members
Icon | Member | Description
 | DistanceToString(Double, DistanceUnitFormat, Int32) |
 | DistanceToString(Double) |

Assembly: ZwManaged (Module: ZwManaged)


DistanceToString Method (value)

DistanceToString Method (value)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »DistanceToString(Double)
Declaration Syntax
C# Visual Basic Visual C++
public static string DistanceToString(
    double value
)
Public Shared Function DistanceToString ( _
    value As Double _
) As String
public:
static String^ DistanceToString(
    double value
)
Parameters
value(Double)

Assembly: ZwManaged (Module: ZwManaged)


DistanceToString Method (value, units, precision)

DistanceToString Method (value, units, precision)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »DistanceToString(Double, DistanceUnitFormat, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static string DistanceToString(
    double value,
    DistanceUnitFormat units,
    int precision
)
Public Shared Function DistanceToString ( _
    value As Double, _
    units As DistanceUnitFormat, _
    precision As Integer _
) As String
public:
static String^ DistanceToString(
    double value,
    DistanceUnitFormat units,
    int precision
)
Parameters
value(Double)
units(DistanceUnitFormat)
precision(Int32)

Assembly: ZwManaged (Module: ZwManaged)


RawAngleToString Method

RawAngleToString Method
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »RawAngleToString()()()()
Members
Icon | Member | Description
 | RawAngleToString(Double, AngularUnitFormat, Int32) |
 | RawAngleToString(Double) |

Assembly: ZwManaged (Module: ZwManaged)


RawAngleToString Method (value)

RawAngleToString Method (value)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »RawAngleToString(Double)
Declaration Syntax
C# Visual Basic Visual C++
public static string RawAngleToString(
    double value
)
Public Shared Function RawAngleToString ( _
    value As Double _
) As String
public:
static String^ RawAngleToString(
    double value
)
Parameters
value(Double)

Assembly: ZwManaged (Module: ZwManaged)


RawAngleToString Method (value, units, precision)

RawAngleToString Method (value, units, precision)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »RawAngleToString(Double, AngularUnitFormat, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static string RawAngleToString(
    double value,
    AngularUnitFormat units,
    int precision
)
Public Shared Function RawAngleToString ( _
    value As Double, _
    units As AngularUnitFormat, _
    precision As Integer _
) As String
public:
static String^ RawAngleToString(
    double value,
    AngularUnitFormat units,
    int precision
)
Parameters
value(Double)
units(AngularUnitFormat)
precision(Int32)

Assembly: ZwManaged (Module: ZwManaged)


StringToAngle Method

StringToAngle Method
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »StringToAngle()()()()
Members
Icon | Member | Description
 | StringToAngle(String, AngularUnitFormat) |
 | StringToAngle(String) |

Assembly: ZwManaged (Module: ZwManaged)


StringToAngle Method (value)

StringToAngle Method (value)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »StringToAngle(String)
Declaration Syntax
C# Visual Basic Visual C++
public static double StringToAngle(
    string value
)
Public Shared Function StringToAngle ( _
    value As String _
) As Double
public:
static double StringToAngle(
    String^ value
)
Parameters
value(String)

Assembly: ZwManaged (Module: ZwManaged)


StringToAngle Method (value, units)

StringToAngle Method (value, units)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »StringToAngle(String, AngularUnitFormat)
Declaration Syntax
C# Visual Basic Visual C++
public static double StringToAngle(
    string value,
    AngularUnitFormat units
)
Public Shared Function StringToAngle ( _
    value As String, _
    units As AngularUnitFormat _
) As Double
public:
static double StringToAngle(
    String^ value,
    AngularUnitFormat units
)
Parameters
value(String)
units(AngularUnitFormat)

Assembly: ZwManaged (Module: ZwManaged)


StringToDistance Method

StringToDistance Method
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »StringToDistance()()()()
Members
Icon | Member | Description
 | StringToDistance(String, DistanceUnitFormat) |
 | StringToDistance(String) |

Assembly: ZwManaged (Module: ZwManaged)


StringToDistance Method (value)

StringToDistance Method (value)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »StringToDistance(String)
Declaration Syntax
C# Visual Basic Visual C++
public static double StringToDistance(
    string value
)
Public Shared Function StringToDistance ( _
    value As String _
) As Double
public:
static double StringToDistance(
    String^ value
)
Parameters
value(String)

Assembly: ZwManaged (Module: ZwManaged)


StringToDistance Method (value, units)

StringToDistance Method (value, units)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »StringToDistance(String, DistanceUnitFormat)
Declaration Syntax
C# Visual Basic Visual C++
public static double StringToDistance(
    string value,
    DistanceUnitFormat units
)
Public Shared Function StringToDistance ( _
    value As String, _
    units As DistanceUnitFormat _
) As Double
public:
static double StringToDistance(
    String^ value,
    DistanceUnitFormat units
)
Parameters
value(String)
units(DistanceUnitFormat)

Assembly: ZwManaged (Module: ZwManaged)


StringToRawAngle Method

StringToRawAngle Method
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »StringToRawAngle()()()()
Members
Icon | Member | Description
 | StringToRawAngle(String, AngularUnitFormat) |
 | StringToRawAngle(String) |

Assembly: ZwManaged (Module: ZwManaged)


StringToRawAngle Method (value)

StringToRawAngle Method (value)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »StringToRawAngle(String)
Declaration Syntax
C# Visual Basic Visual C++
public static double StringToRawAngle(
    string value
)
Public Shared Function StringToRawAngle ( _
    value As String _
) As Double
public:
static double StringToRawAngle(
    String^ value
)
Parameters
value(String)

Assembly: ZwManaged (Module: ZwManaged)


StringToRawAngle Method (value, units)

StringToRawAngle Method (value, units)
Namespaces »ZwSoft.ZwCAD.Runtime »Converter »StringToRawAngle(String, AngularUnitFormat)
Declaration Syntax
C# Visual Basic Visual C++
public static double StringToRawAngle(
    string value,
    AngularUnitFormat units
)
Public Shared Function StringToRawAngle ( _
    value As String, _
    units As AngularUnitFormat _
) As Double
public:
static double StringToRawAngle(
    String^ value,
    AngularUnitFormat units
)
Parameters
value(String)
units(AngularUnitFormat)

Assembly: ZwManaged (Module: ZwManaged)


Dictionary Class

Dictionary Class
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcRxDictionary")]
public class Dictionary : RXObject, IDictionary
<WrapperAttribute("AcRxDictionary")> _
Public Class Dictionary _
    Inherits RXObject _
    Implements IDictionary
[WrapperAttribute(L"AcRxDictionary")]
public ref class Dictionary : public RXObject,
    IDictionary
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Dictionary(IntPtr, Boolean) |
 | At(String) |
 | At(Int32) |
 | AtKeyAndIdPut(String, Int32, RXObject) |
 | AtPut(String, RXObject, Int32%) |
 | AtPut(String, RXObject) |
 | AtPut(Int32, RXObject) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | Contains(String) |
 | Contains(Int32) |
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CopyTo(array<DictionaryEntry>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeletesObjects |
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection_CopyTo(Array, Int32) |
 | IdAt(String) |
 | IDictionary_Add(Object, Object) |
 | IDictionary_Clear()()()() |
 | IDictionary_Contains(Object) |
 | IDictionary_Item[([( Object])]) |
 | IDictionary_Remove(Object) |
 | IEnumerable_GetEnumerator()()()() |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsCaseSensitive |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsFixedSize |
 | IsReadOnly |
 | IsSorted |
 | IsSynchronized |
 | Item[([( String])]) |
 | KeyAt(Int32) |
 | Keys |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Remove(String) |
 | Remove(Int32) |
 | ResetKey(String, String) |
 | ResetKey(Int32, String) |
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Values |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Dictionary


Dictionary Constructor (unmanagedPointer, autoDelete)

Dictionary Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Dictionary(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected internal Dictionary(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Friend Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected public:
Dictionary(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


At Method

At Method
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »At()()()()
Members
Icon | Member | Description
 | At(String) |
 | At(Int32) |


At Method (id)

At Method (id)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »At(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual RXObject At(
    int id
)
Public Overridable Function At ( _
    id As Integer _
) As RXObject
public:
virtual RXObject^ At(
    int id
)
Parameters
id(Int32)


At Method (key)

At Method (key)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »At(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual RXObject At(
    string key
)
Public Overridable Function At ( _
    key As String _
) As RXObject
public:
virtual RXObject^ At(
    String^ key
)
Parameters
key(String)


AtKeyAndIdPut Method (newKey, id, value)

AtKeyAndIdPut Method (newKey, id, value)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »AtKeyAndIdPut(String, Int32, RXObject)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AtKeyAndIdPut(
    string newKey,
    int id,
    RXObject value
)
Public Overridable Sub AtKeyAndIdPut ( _
    newKey As String, _
    id As Integer, _
    value As RXObject _
)
public:
virtual void AtKeyAndIdPut(
    String^ newKey,
    int id,
    RXObject^ value
)
Parameters
newKey(String)
id(Int32)
value(RXObject)


AtPut Method

AtPut Method
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »AtPut()()()()
Members
Icon | Member | Description
 | AtPut(String, RXObject, Int32%) |
 | AtPut(String, RXObject) |
 | AtPut(Int32, RXObject) |


AtPut Method (id, value)

AtPut Method (id, value)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »AtPut(Int32, RXObject)
Declaration Syntax
C# Visual Basic Visual C++
public virtual RXObject AtPut(
    int id,
    RXObject value
)
Public Overridable Function AtPut ( _
    id As Integer, _
    value As RXObject _
) As RXObject
public:
virtual RXObject^ AtPut(
    int id,
    RXObject^ value
)
Parameters
id(Int32)
value(RXObject)


AtPut Method (key, value)

AtPut Method (key, value)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »AtPut(String, RXObject)
Declaration Syntax
C# Visual Basic Visual C++
public RXObject AtPut(
    string key,
    RXObject value
)
Public Function AtPut ( _
    key As String, _
    value As RXObject _
) As RXObject
public:
RXObject^ AtPut(
    String^ key,
    RXObject^ value
)
Parameters
key(String)
value(RXObject)


AtPut Method (key, value, retId)

AtPut Method (key, value, retId)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »AtPut(String, RXObject, Int32%)
Declaration Syntax
C# Visual Basic Visual C++
public virtual RXObject AtPut(
    string key,
    RXObject value,
    out int retId
)
Public Overridable Function AtPut ( _
    key As String, _
    value As RXObject, _
    <OutAttribute> ByRef retId As Integer _
) As RXObject
public:
virtual RXObject^ AtPut(
    String^ key,
    RXObject^ value,
    [OutAttribute] int% retId
)
Parameters
key(String)
value(RXObject)
retId(Int32%)


Contains Method

Contains Method
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Contains()()()()
Members
Icon | Member | Description
 | Contains(String) |
 | Contains(Int32) |


Contains Method (id)

Contains Method (id)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Contains(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Contains(
    int id
)
Public Overridable Function Contains ( _
    id As Integer _
) As Boolean
public:
virtual bool Contains(
    int id
)
Parameters
id(Int32)


Contains Method (key)

Contains Method (key)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Contains(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Contains(
    string key
)
Public Overridable Function Contains ( _
    key As String _
) As Boolean
public:
virtual bool Contains(
    String^ key
)
Parameters
key(String)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »CopyTo(array<DictionaryEntry>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DictionaryEntry[] array,
    int index
)
Public Sub CopyTo ( _
    array As DictionaryEntry(), _
    index As Integer _
)
public:
void CopyTo(
    array<DictionaryEntry>^ array,
    int index
)
Parameters
array(array<DictionaryEntry>[]()[][])
index(Int32)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}


DeletesObjects Property

DeletesObjects Property
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »DeletesObjects
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool DeletesObjects { get; }
Public Overridable ReadOnly Property DeletesObjects As Boolean
    Get
public:
virtual property bool DeletesObjects {
    bool get ();
}


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IDictionaryEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IDictionaryEnumerator
public:
virtual IDictionaryEnumerator^ GetEnumerator()


ICollection_CopyTo Method (array, index)

ICollection_CopyTo Method (array, index)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »ICollection_CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void ICollection_CopyTo(
    Array array,
    int index
)
Protected Overridable Sub ICollection_CopyTo ( _
    array As Array, _
    index As Integer _
)
protected:
virtual void ICollection_CopyTo(
    Array^ array,
    int index
)
Parameters
array(Array)
index(Int32)


IdAt Method (key)

IdAt Method (key)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IdAt(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual int IdAt(
    string key
)
Public Overridable Function IdAt ( _
    key As String _
) As Integer
public:
virtual int IdAt(
    String^ key
)
Parameters
key(String)


IDictionary_Add Method (key, value)

IDictionary_Add Method (key, value)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IDictionary_Add(Object, Object)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void IDictionary_Add(
    Object key,
    Object value
)
Protected Overridable Sub IDictionary_Add ( _
    key As Object, _
    value As Object _
)
protected:
virtual void IDictionary_Add(
    Object^ key,
    Object^ value
)
Parameters
key(Object)
value(Object)


IDictionary_Clear Method

IDictionary_Clear Method
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IDictionary_Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void IDictionary_Clear()
Protected Overridable Sub IDictionary_Clear
protected:
virtual void IDictionary_Clear()


IDictionary_Contains Method (key)

IDictionary_Contains Method (key)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IDictionary_Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IDictionary_Contains(
    Object key
)
Protected Overridable Function IDictionary_Contains ( _
    key As Object _
) As Boolean
protected:
virtual bool IDictionary_Contains(
    Object^ key
)
Parameters
key(Object)


IDictionary_Item Property (key)

IDictionary_Item Property (key)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IDictionary_Item[([( Object])])
Declaration Syntax
C# Visual Basic Visual C++
protected virtual Object this[
    Object key
] { get; set; }
Protected Overridable Property IDictionary_Item ( _
    key As Object _
) As Object
    Get
    Set
protected:
virtual property Object^ IDictionary_Item[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}
Parameters
key(Object)


IDictionary_Remove Method (key)

IDictionary_Remove Method (key)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IDictionary_Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void IDictionary_Remove(
    Object key
)
Protected Overridable Sub IDictionary_Remove ( _
    key As Object _
)
protected:
virtual void IDictionary_Remove(
    Object^ key
)
Parameters
key(Object)


IEnumerable_GetEnumerator Method

IEnumerable_GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IEnumerable_GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected virtual IEnumerator IEnumerable_GetEnumerator()
Protected Overridable Function IEnumerable_GetEnumerator As IEnumerator
protected:
virtual IEnumerator^ IEnumerable_GetEnumerator()


IsCaseSensitive Property

IsCaseSensitive Property
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IsCaseSensitive
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsCaseSensitive { get; }
Public Overridable ReadOnly Property IsCaseSensitive As Boolean
    Get
public:
virtual property bool IsCaseSensitive {
    bool get ();
}


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IsFixedSize { get; }
Protected Overridable ReadOnly Property IsFixedSize As Boolean
    Get
protected:
virtual property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IsReadOnly { get; }
Protected Overridable ReadOnly Property IsReadOnly As Boolean
    Get
protected:
virtual property bool IsReadOnly {
    bool get ();
}


IsSorted Property

IsSorted Property
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IsSorted
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSorted { get; }
Public Overridable ReadOnly Property IsSorted As Boolean
    Get
public:
virtual property bool IsSorted {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool IsSynchronized { get; }
Protected Overridable ReadOnly Property IsSynchronized As Boolean
    Get
protected:
virtual property bool IsSynchronized {
    bool get ();
}


Item Property (s)

Item Property (s)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Item[([( String])])
Declaration Syntax
C# Visual Basic Visual C++
public virtual RXObject this[
    string s
] { get; set; }
Public Overridable Default Property Item ( _
    s As String _
) As RXObject
    Get
    Set
public:
virtual property RXObject^ default[String^ s] {
    RXObject^ get (String^ s);
    void set (String^ s, RXObject^ value);
}
Parameters
s(String)


KeyAt Method (id)

KeyAt Method (id)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »KeyAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual string KeyAt(
    int id
)
Public Overridable Function KeyAt ( _
    id As Integer _
) As String
public:
virtual String^ KeyAt(
    int id
)
Parameters
id(Int32)


Keys Property

Keys Property
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Keys
Declaration Syntax
C# Visual Basic Visual C++
protected virtual ICollection Keys { get; }
Protected Overridable ReadOnly Property Keys As ICollection
    Get
protected:
virtual property ICollection^ Keys {
    ICollection^ get ();
}


Remove Method

Remove Method
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Remove()()()()
Members
Icon | Member | Description
 | Remove(String) |
 | Remove(Int32) |


Remove Method (id)

Remove Method (id)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Remove(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public virtual RXObject Remove(
    int id
)
Public Overridable Function Remove ( _
    id As Integer _
) As RXObject
public:
virtual RXObject^ Remove(
    int id
)
Parameters
id(Int32)


Remove Method (key)

Remove Method (key)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Remove(String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual RXObject Remove(
    string key
)
Public Overridable Function Remove ( _
    key As String _
) As RXObject
public:
virtual RXObject^ Remove(
    String^ key
)
Parameters
key(String)


ResetKey Method

ResetKey Method
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »ResetKey()()()()
Members
Icon | Member | Description
 | ResetKey(String, String) |
 | ResetKey(Int32, String) |


ResetKey Method (id, newKey)

ResetKey Method (id, newKey)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »ResetKey(Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ResetKey(
    int id,
    string newKey
)
Public Overridable Sub ResetKey ( _
    id As Integer, _
    newKey As String _
)
public:
virtual void ResetKey(
    int id,
    String^ newKey
)
Parameters
id(Int32)
newKey(String)


ResetKey Method (oldKey, newKey)

ResetKey Method (oldKey, newKey)
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »ResetKey(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ResetKey(
    string oldKey,
    string newKey
)
Public Overridable Sub ResetKey ( _
    oldKey As String, _
    newKey As String _
)
public:
virtual void ResetKey(
    String^ oldKey,
    String^ newKey
)
Parameters
oldKey(String)
newKey(String)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
protected virtual Object SyncRoot { get; }
Protected Overridable ReadOnly Property SyncRoot As Object
    Get
protected:
virtual property Object^ SyncRoot {
    Object^ get ();
}


Values Property

Values Property
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Values
Declaration Syntax
C# Visual Basic Visual C++
protected virtual ICollection Values { get; }
Protected Overridable ReadOnly Property Values As ICollection
    Get
protected:
virtual property ICollection^ Values {
    ICollection^ get ();
}


DictionaryIterator Class

DictionaryIterator Class
Namespaces »ZwSoft.ZwCAD.Runtime »DictionaryIterator
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcRxDictionaryIterator")]
public class DictionaryIterator : RXObject,
    IDictionaryEnumerator
<WrapperAttribute("ZcRxDictionaryIterator")> _
Public Class DictionaryIterator _
    Inherits RXObject _
    Implements IDictionaryEnumerator
[WrapperAttribute(L"ZcRxDictionaryIterator")]
public ref class DictionaryIterator : public RXObject,
    IDictionaryEnumerator
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Current |
 | DeleteUnmanagedObject()()()() | (Overrides RXObject.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Entry |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Key |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveNext()()()() |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | Reset()()()() |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Value |
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DictionaryIterator


Current Property

Current Property
Namespaces »ZwSoft.ZwCAD.Runtime »DictionaryIterator »Current
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.Runtime »DictionaryIterator »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


Entry Property

Entry Property
Namespaces »ZwSoft.ZwCAD.Runtime »DictionaryIterator »Entry
Declaration Syntax
C# Visual Basic Visual C++
public virtual DictionaryEntry Entry { get; }
Public Overridable ReadOnly Property Entry As DictionaryEntry
    Get
public:
virtual property DictionaryEntry Entry {
    DictionaryEntry get ();
}


Key Property

Key Property
Namespaces »ZwSoft.ZwCAD.Runtime »DictionaryIterator »Key
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Key { get; }
Public Overridable ReadOnly Property Key As Object
    Get
public:
virtual property Object^ Key {
    Object^ get ();
}


MoveNext Method

MoveNext Method
Namespaces »ZwSoft.ZwCAD.Runtime »DictionaryIterator »MoveNext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()


Reset Method

Reset Method
Namespaces »ZwSoft.ZwCAD.Runtime »DictionaryIterator »Reset()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()


Value Property

Value Property
Namespaces »ZwSoft.ZwCAD.Runtime »DictionaryIterator »Value
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Value { get; }
Public Overridable ReadOnly Property Value As Object
    Get
public:
virtual property Object^ Value {
    Object^ get ();
}


DisposableWrapper Class

DisposableWrapper Class
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper
Declaration Syntax
C# Visual Basic Visual C++
public abstract class DisposableWrapper : MarshalByRefObject,
    IDisposable
Public MustInherit Class DisposableWrapper _
    Inherits MarshalByRefObject _
    Implements IDisposable
public ref class DisposableWrapper abstract : public MarshalByRefObject,
    IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisposableWrapper(IntPtr, Boolean) |
 | DisposableWrapper()()()() |
 | AutoDelete |
 | Create(Type, IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() |
 | Dispose(Boolean) |
 | Dispose()()()() |
 | Equality(DisposableWrapper, DisposableWrapper) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()()() | (Overrides Object.Finalize()()()().)
 | GetHashCode()()()() | (Overrides Object.GetHashCode()()()().)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Inequality(DisposableWrapper, DisposableWrapper) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Document
 |  |  | Color
 |  |  | AuditInfo
 |  |  | BlockTableRecordEnumerator
 |  |  | CustomObjectSnapMode
 |  |  | DataCellCollection
 |  |  | DbHomeView
 |  |  | DBObjectCollection
 |  |  | DynamicBlockReferencePropertyCollection
 |  |  | DynamicDimensionData
 |  |  | DynamicDimensionDataCollection
 |  |  | FileDependencyManager
 |  |  | FilteredBlockIterator
 |  |  | IndexUpdateData
 |  |  | Graph
 |  |  | GraphNode
 |  |  | GraphNodeCollection
 |  |  | GripData
 |  |  | GripDataCollection
 |  |  | HyperLink
 |  |  | HyperLinkCollection
 |  |  | LoftOptions
 |  |  | MTextFragment
 |  |  | ObjectIdCollection
 |  |  | PlotSettingsValidator
 |  |  | ResultBuffer
 |  |  | RevolveOptions
 |  |  | SweepOptions
 |  |  | SymbolTableEnumerator
 |  |  | UnderlayFile
 |  |  | UnderlayItem
 |  |  | UnderlayLayer
 |  |  | Curve2dCollection
 |  |  | Curve3dCollection
 |  |  | CurveBoundary
 |  |  | Entity2d
 |  |  | Entity3d
 |  |  | IntegerCollection
 |  |  | Interval
 |  |  | KnotCollection
 |  |  | Point2dCollection
 |  |  | Point3dCollection
 |  |  | ClipBoundary
 |  |  | LinetypeCollection
 |  |  | Manager
 |  |  | View
 |  |  | DsdEntryCollection
 |  |  | PlotEngine
 |  |  | PlotLogger
 |  |  | PlotProgress
 |  |  | PreviewEndPlotInfo
 |  |  | RXObject
 |  |  | StatusBarItem
 |  |  | Window


DisposableWrapper Constructor

DisposableWrapper Constructor
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »DisposableWrapper()()()()
Members
Icon | Member | Description
 | DisposableWrapper(IntPtr, Boolean) |
 | DisposableWrapper()()()() |


DisposableWrapper Constructor

DisposableWrapper Constructor
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »DisposableWrapper()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected DisposableWrapper()
Protected Sub New
protected:
DisposableWrapper()


DisposableWrapper Constructor (unmanagedPointer, autoDelete)

DisposableWrapper Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »DisposableWrapper(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected DisposableWrapper(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
DisposableWrapper(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


AutoDelete Property

AutoDelete Property
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »AutoDelete
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDelete { get; internal set; }
Public Property AutoDelete As Boolean
    Get
    Friend Set
public:
property bool AutoDelete {
    bool get ();
    internal: void set (bool value);
}


Create Method (type, unmanagedPointer, autoDelete)

Create Method (type, unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »Create(Type, IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
[SecurityPermissionAttribute(SecurityAction.LinkDemand, Flags = SecurityPermissionFlag.UnmanagedCode)]
public static DisposableWrapper Create(
    Type type,
    IntPtr unmanagedPointer,
    bool autoDelete
)
<SecurityPermissionAttribute(SecurityAction.LinkDemand, Flags := SecurityPermissionFlag.UnmanagedCode)> _
Public Shared Function Create ( _
    type As Type, _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As DisposableWrapper
[SecurityPermissionAttribute(SecurityAction::LinkDemand, Flags = SecurityPermissionFlag::UnmanagedCode)]
public:
static DisposableWrapper^ Create(
    Type^ type,
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
type(Type)
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected abstract void DeleteUnmanagedObject()
Protected MustOverride Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() abstract


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed


Dispose Method ()

Dispose Method ()
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »Dispose(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
[HandleProcessCorruptedStateExceptionsAttribute]
protected virtual void Dispose(
    bool
)
<HandleProcessCorruptedStateExceptionsAttribute> _
Protected Overridable Sub Dispose ( _
     As Boolean _
)
[HandleProcessCorruptedStateExceptionsAttribute]
protected:
virtual void Dispose(
    bool
)
Parameters
(Boolean)


Equality Operator

Equality Operator
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »Equality(DisposableWrapper, DisposableWrapper)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    DisposableWrapper a,
    DisposableWrapper b
)
Public Shared Operator = ( _
    a As DisposableWrapper, _
    b As DisposableWrapper _
) As Boolean
public:
static bool operator ==(
    DisposableWrapper^ a,
    DisposableWrapper^ b
)
Parameters
a(DisposableWrapper)
b(DisposableWrapper)


Equals Method (obj)

Equals Method (obj)
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »Equals(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj(Object)


Finalize Method

Finalize Method
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »Finalize()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override


GetHashCode Method

GetHashCode Method
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »GetHashCode()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override


Inequality Operator

Inequality Operator
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »Inequality(DisposableWrapper, DisposableWrapper)
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    DisposableWrapper a,
    DisposableWrapper b
)
Public Shared Operator <> ( _
    a As DisposableWrapper, _
    b As DisposableWrapper _
) As Boolean
public:
static bool operator !=(
    DisposableWrapper^ a,
    DisposableWrapper^ b
)
Parameters
a(DisposableWrapper)
b(DisposableWrapper)


IsDisposed Property

IsDisposed Property
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »IsDisposed
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
property bool IsDisposed {
    bool get ();
}


UnmanagedObject Property

UnmanagedObject Property
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »UnmanagedObject
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr UnmanagedObject { get; }
Public ReadOnly Property UnmanagedObject As IntPtr
    Get
public:
property IntPtr UnmanagedObject {
    IntPtr get ();
}


DistanceUnitFormat Enumeration

DistanceUnitFormat Enumeration
Namespaces »ZwSoft.ZwCAD.Runtime »DistanceUnitFormat
Declaration Syntax
C# Visual Basic Visual C++
public enum DistanceUnitFormat
Public Enumeration DistanceUnitFormat
public enum class DistanceUnitFormat
Members
Member | Description
Fractional |
Architectural |
Engineering |
Scientific |
Decimal |
Current |

Assembly: ZwManaged (Module: ZwManaged)


DynamicLinker Class

DynamicLinker Class
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcRxDynamicLinker")]
public sealed class DynamicLinker : RXObject
<WrapperAttribute("AcRxDynamicLinker")> _
Public NotInheritable Class DynamicLinker _
    Inherits RXObject
[WrapperAttribute(L"AcRxDynamicLinker")]
public ref class DynamicLinker sealed : public RXObject
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetLoadedModules()()()() |
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsAppBusy(String) |
 | IsApplicationLocked(String) |
 | IsAppMdiAware(String) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | IsModuleLoaded(String) |
 | LoadApp(String, Boolean, Boolean) |
 | LoadModule(String, Boolean, Boolean) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModuleLoadAborted |
 | ModuleLoaded |
 | ModuleLoading |
 | ModuleUnloadAborted |
 | ModuleUnloaded |
 | ModuleUnloading |
 | ProductKey |
 | ProductLcid |
 | QueryX(RXClass) | (Inherited from RXObject.)
 | SetAppBusy(String, Boolean) |
 | ToString()()()() | (Inherited from Object.)
 | UnloadApp(String, Boolean) |
 | UnloadModule(String, Boolean) |
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | DynamicLinker


GetLoadedModules Method

GetLoadedModules Method
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »GetLoadedModules()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection GetLoadedModules()
Public Function GetLoadedModules As StringCollection
public:
StringCollection^ GetLoadedModules()


IsAppBusy Method (moduleName)

IsAppBusy Method (moduleName)
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »IsAppBusy(String)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAppBusy(
    string moduleName
)
Public Function IsAppBusy ( _
    moduleName As String _
) As Boolean
public:
bool IsAppBusy(
    String^ moduleName
)
Parameters
moduleName(String)


IsApplicationLocked Method (moduleName)

IsApplicationLocked Method (moduleName)
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »IsApplicationLocked(String)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsApplicationLocked(
    string moduleName
)
Public Function IsApplicationLocked ( _
    moduleName As String _
) As Boolean
public:
bool IsApplicationLocked(
    String^ moduleName
)
Parameters
moduleName(String)


IsAppMdiAware Method (moduleName)

IsAppMdiAware Method (moduleName)
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »IsAppMdiAware(String)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAppMdiAware(
    string moduleName
)
Public Function IsAppMdiAware ( _
    moduleName As String _
) As Boolean
public:
bool IsAppMdiAware(
    String^ moduleName
)
Parameters
moduleName(String)


IsModuleLoaded Method (fileName)

IsModuleLoaded Method (fileName)
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »IsModuleLoaded(String)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsModuleLoaded(
    string fileName
)
Public Function IsModuleLoaded ( _
    fileName As String _
) As Boolean
public:
bool IsModuleLoaded(
    String^ fileName
)
Parameters
fileName(String)


LoadApp Method (appName, printIt, asCmd)

LoadApp Method (appName, printIt, asCmd)
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »LoadApp(String, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void LoadApp(
    string appName,
    bool printIt,
    bool asCmd
)
Public Sub LoadApp ( _
    appName As String, _
    printIt As Boolean, _
    asCmd As Boolean _
)
public:
void LoadApp(
    String^ appName,
    bool printIt,
    bool asCmd
)
Parameters
appName(String)
printIt(Boolean)
asCmd(Boolean)


LoadModule Method (fileName, printIt, asCmd)

LoadModule Method (fileName, printIt, asCmd)
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »LoadModule(String, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void LoadModule(
    string fileName,
    bool printIt,
    bool asCmd
)
Public Sub LoadModule ( _
    fileName As String, _
    printIt As Boolean, _
    asCmd As Boolean _
)
public:
void LoadModule(
    String^ fileName,
    bool printIt,
    bool asCmd
)
Parameters
fileName(String)
printIt(Boolean)
asCmd(Boolean)


ModuleLoadAborted Event

ModuleLoadAborted Event
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »ModuleLoadAborted
Declaration Syntax
C# Visual Basic Visual C++
public event ModuleLoadAbortedEventHandler ModuleLoadAborted
Public Event ModuleLoadAborted As ModuleLoadAbortedEventHandler
public:
 event ModuleLoadAbortedEventHandler^ ModuleLoadAborted {
    void add (ModuleLoadAbortedEventHandler^ value);
    void remove (ModuleLoadAbortedEventHandler^ value);
}


ModuleLoaded Event

ModuleLoaded Event
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »ModuleLoaded
Declaration Syntax
C# Visual Basic Visual C++
public event ModuleLoadedEventHandler ModuleLoaded
Public Event ModuleLoaded As ModuleLoadedEventHandler
public:
 event ModuleLoadedEventHandler^ ModuleLoaded {
    void add (ModuleLoadedEventHandler^ value);
    void remove (ModuleLoadedEventHandler^ value);
}


ModuleLoading Event

ModuleLoading Event
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »ModuleLoading
Declaration Syntax
C# Visual Basic Visual C++
public event ModuleLoadingEventHandler ModuleLoading
Public Event ModuleLoading As ModuleLoadingEventHandler
public:
 event ModuleLoadingEventHandler^ ModuleLoading {
    void add (ModuleLoadingEventHandler^ value);
    void remove (ModuleLoadingEventHandler^ value);
}


ModuleUnloadAborted Event

ModuleUnloadAborted Event
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »ModuleUnloadAborted
Declaration Syntax
C# Visual Basic Visual C++
public event ModuleUnloadAbortedEventHandler ModuleUnloadAborted
Public Event ModuleUnloadAborted As ModuleUnloadAbortedEventHandler
public:
 event ModuleUnloadAbortedEventHandler^ ModuleUnloadAborted {
    void add (ModuleUnloadAbortedEventHandler^ value);
    void remove (ModuleUnloadAbortedEventHandler^ value);
}


ModuleUnloaded Event

ModuleUnloaded Event
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »ModuleUnloaded
Declaration Syntax
C# Visual Basic Visual C++
public event ModuleUnloadedEventHandler ModuleUnloaded
Public Event ModuleUnloaded As ModuleUnloadedEventHandler
public:
 event ModuleUnloadedEventHandler^ ModuleUnloaded {
    void add (ModuleUnloadedEventHandler^ value);
    void remove (ModuleUnloadedEventHandler^ value);
}


ModuleUnloading Event

ModuleUnloading Event
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »ModuleUnloading
Declaration Syntax
C# Visual Basic Visual C++
public event ModuleUnloadingEventHandler ModuleUnloading
Public Event ModuleUnloading As ModuleUnloadingEventHandler
public:
 event ModuleUnloadingEventHandler^ ModuleUnloading {
    void add (ModuleUnloadingEventHandler^ value);
    void remove (ModuleUnloadingEventHandler^ value);
}


ProductKey Property

ProductKey Property
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »ProductKey
Declaration Syntax
C# Visual Basic Visual C++
public string ProductKey { get; }
Public ReadOnly Property ProductKey As String
    Get
public:
property String^ ProductKey {
    String^ get ();
}


ProductLcid Property

ProductLcid Property
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »ProductLcid
Declaration Syntax
C# Visual Basic Visual C++
public int ProductLcid { get; }
Public ReadOnly Property ProductLcid As Integer
    Get
public:
property int ProductLcid {
    int get ();
}


SetAppBusy Method (moduleName, busyFlag)

SetAppBusy Method (moduleName, busyFlag)
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »SetAppBusy(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void SetAppBusy(
    string moduleName,
    bool busyFlag
)
Public Sub SetAppBusy ( _
    moduleName As String, _
    busyFlag As Boolean _
)
public:
void SetAppBusy(
    String^ moduleName,
    bool busyFlag
)
Parameters
moduleName(String)
busyFlag(Boolean)


UnloadApp Method (appName, asCmd)

UnloadApp Method (appName, asCmd)
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »UnloadApp(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void UnloadApp(
    string appName,
    bool asCmd
)
Public Sub UnloadApp ( _
    appName As String, _
    asCmd As Boolean _
)
public:
void UnloadApp(
    String^ appName,
    bool asCmd
)
Parameters
appName(String)
asCmd(Boolean)


UnloadModule Method (fileName, asCmd)

UnloadModule Method (fileName, asCmd)
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »UnloadModule(String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public void UnloadModule(
    string fileName,
    bool asCmd
)
Public Sub UnloadModule ( _
    fileName As String, _
    asCmd As Boolean _
)
public:
void UnloadModule(
    String^ fileName,
    bool asCmd
)
Parameters
fileName(String)
asCmd(Boolean)


DynamicLinkerEventArgs Class

DynamicLinkerEventArgs Class
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinkerEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class DynamicLinkerEventArgs : EventArgs
Public Class DynamicLinkerEventArgs _
    Inherits EventArgs
public ref class DynamicLinkerEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DynamicLinkerEventArgs(String) |
 | Equals(Object) | (Inherited from Object.)
 | FileName |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DynamicLinkerEventArgs


DynamicLinkerEventArgs Constructor (fileName)

DynamicLinkerEventArgs Constructor (fileName)
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinkerEventArgs »DynamicLinkerEventArgs(String)
Declaration Syntax
C# Visual Basic Visual C++
public DynamicLinkerEventArgs(
    string fileName
)
Public Sub New ( _
    fileName As String _
)
public:
DynamicLinkerEventArgs(
    String^ fileName
)
Parameters
fileName(String)


FileName Property

FileName Property
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinkerEventArgs »FileName
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}


ErrorStatus Enumeration

ErrorStatus Enumeration
Namespaces »ZwSoft.ZwCAD.Runtime »ErrorStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum ErrorStatus
Public Enumeration ErrorStatus
public enum class ErrorStatus
Members
Member | Description
InvalidXrefObjectId |
InvalidWindowArea |
InvalidView |
InvalidTextStyle |
InvalidSymTableFlag |
InvalidSymbolTableName |
InvalidStyle |
InvalidResultBuffer |
InvalidProfileName |
InvalidPlotInfo |
InvalidPlotArea |
InvalidOwnerObject |
InvalidOpenState |
InvalidOffset |
InvalidObjectId |
InvalidNormal |
InvalidMeshVertexIndex |
InvalidLayer |
InvalidKey |
InvalidInterfaceId |
InvalidInput |
InvalidIndex |
InvalidIdMap |
InvalidFix |
InvalidFileExtension |
InvalidFaceVertexIndex |
InvalidExtents |
InvalidEngineState |
InvalidDxfSectionName |
InvalidDxf3dPoint |
InvalidDxf2dPoint |
InvalidFileVersion |
InvalidDimStyle |
InvalidContext |
InvalidBlockName |
InvalidAxis |
InvalidAdsName |
InternetValidUrl |
InternetUserCancelledTransfer |
InternetUnknownError |
InternetTooManyOpenFiles |
InternetSharingViolation |
InternetProtocolNotSupported |
InternetOldWinInternet |
InternetOK |
InternetNoWinInternet |
InternetNotImplemented |
InternetNotAnUrl |
InternetInvalidFileHandle |
InternetInvalidAccessType |
InternetInternetSessionOpenFailed |
InternetInternetSessionConnectFailed |
InternetInternetError |
InternetInCache |
InternetHttpVersionNotSupported |
InternetHttpUriTooLong |
InternetHttpUnsupportedMedia |
InternetHttpTimedOut |
InternetHttpServiceUnavailable |
InternetHttpServerError |
InternetHttpResourceGone |
InternetHttpRequestTooLarge |
InternetHttpRequestForbidden |
InternetHttpProxyAuthorizationRequired |
InternetHttpPreconditionFailure |
InternetHttpPaymentRequired |
InternetHttpOpenRequestFailed |
InternetHttpObjectNotFound |
InternetHttpNotSupported |
InternetHttpNoAcceptableResponse |
InternetHttpLengthRequired |
InternetHttpGatewayTimeout |
InternetHttpConflict |
InternetHttpBadRequest |
InternetHttpBadMethod |
InternetHttpBadGateway |
InternetHttpAccessDenied |
InternetHardwareError |
InternetGenericException |
InternetFileOpenFailed |
InternetFileNotFound |
InternetFileGenericError |
InternetFileAccessDenied |
InternetDiskFull |
InternetDirectoryFull |
InternetCreateInternetSessionFailed |
InternetBase |
InternetBadPath |
InsertAfter |
InProcessOfCommitting |
IncompleteComplexObject |
IncompleteBlockDefinition |
IncompatiblePlotSettings |
IllegalReplacement |
IllegalEntityType |
HatchTooDense |
HandleInUse |
HandleExists |
HadMultipleReaders |
GuidNoAddress |
GraphicsNotGenerated |
GeneralModelingFailure |
FixedAllErrors |
FileTooManyOpen |
FileSystemErr |
FileSharingViolation |
FilerError |
FileNotFound |
FileMissingSections |
FileInternalErr |
FileExists |
FileAccessErr |
ExternalDataSizeExceeded |
ExplodeBeforeTransform |
ExplodeAgain |
ExcessiveItemCount |
EntityInInactiveLayout |
EndOfObject |
EndOfFile |
DxfReadAborted |
DxfPartiallyRead |
DxbReadAborted |
DxbPartiallyRead |
DwkLockFileFound |
DwgShareWriteAccess |
DwgShareReadAccess |
DwgShareDemandLoad |
DwgSentinelDoesNotMatch |
DwgRecoveredOK |
DwgObjectImproperlyRead |
DwgNotRecoverable |
DwgNeedsRecovery |
DwgNeedsAFullSave |
DuplicateRecordName |
DuplicateLayerName |
DuplicateKey |
DuplicateIndex |
DuplicateDxfField |
DuplicateBlockName |
DuplicateBlockDefinition |
DocumentSwitchDisabled |
DeviceNotFound |
DelUnableToSetCurrent |
DelUnableToFind |
DelLastLayout |
DelIsModelSpace |
DeleteEntity |
DeletedEntry |
DelDoesNotExist |
DegenerateGeometry |
DataLinkSourceNotFound |
DataLinkSourceIsWriteProtected |
DataLinkOtherError |
DataLinkNotUpdatedYet |
DataLinkNotFound |
DataLinkInvalidAdapterId |
DataLinkConnectionFailed |
DataLinkBadConnectionString |
DataLinkAdapterNotFound |
DatabaseObjectsOpen |
CustomSizeNotPossible |
CreateInvalidName |
CreateFailed |
CopyNameExists |
CopyIsModelSpace |
CopyInvalidName |
CopyFailed |
CopyDoesNotExist |
ContainerNotEmpty |
CommandWasInProgress |
CloseWasNotifying |
ClosePartialFailure |
CloseModifyAborted |
CloseFailObjectDamaged |
CantOpenFile |
CannotScaleNonUniformly |
CannotRestoreFromAcisFile |
CannotNestBlockDefinitions |
CannotExplodeEntity |
CannotChangeColumnType |
CannotChangeActiveViewport |
CannotBeResurrected |
CannotBeErasedByCaller |
BufferTooSmall |
BrokenHandle |
BlockDefInEntitySection |
BinaryDataSizeExceeded |
BadVisibilityValue |
BadUcs |
BadPlotStyleType |
BadPlotStyleNameHandle |
BadPlotStyleName |
BadPaperspaceView |
BadlyNestedAppData |
BadLineWeightValue |
BadLinetypeScale |
BadLinetypeName |
BadLayerName |
BadDxfSequence |
BadDxfFile |
BadDwgHeader |
BadColorIndex |
BadColor |
AnonymousEntry |
AmbiguousOutput |
AmbiguousInput |
AlreadyInGroup |
AlreadyInDB |
AlreadyInactive |
AlreadyActive |
XRefDependent |
WrongSubentityType |
WrongObjectType |
WrongDatabase |
WrongCellType |
WasOpenForWrite |
WasOpenForUndo |
WasOpenForRead |
WasOpenForNotify |
WasNotOpenForWrite |
WasNotifying |
WasNotForwarding |
WasNotErased |
WasErased |
Vetoed |
VertexAfterFace |
UserBreak |
UnsupportedFileFormat |
UnrecoverableErrors |
UnknownHandle |
UnknownDxfFileFormat |
UndoOperationNotAvailable |
UndoNoGroupBegin |
UndefineShapeName |
UndefinedLineType |
UndefinedDxfGroupCode |
UnableToSyncModelView |
UnableToSetViewAssociation |
UnableToSetLabelBlock |
UnableToRemoveAssociation |
UnableToGetViewAssociation |
UnableToGetLabelBlock |
TransactionOpenWhileCommandEnded |
TooManyVertices |
TooManyLineTypeElements |
TooFewVertices |
TooFewLineTypeElements |
TargetDocNotQuiescent |
SubSelectionSetEmpty |
SubentitiesStillOpen |
StringTooLong |
SomeInputDataLeftUnread |
SingularPoint |
SetFailed |
SelfReference |
SecInitializationFailure |
SecErrorWritingSignature |
SecErrorWritingFile |
SecErrorReadingFile |
SecErrorGeneratingTimestamp |
SecErrorEncryptingData |
SecErrorDecryptingData |
SecErrorComputingSignature |
SecErrorCipherNotSupported |
RowsMustMatchColumns |
RepeatEntity |
RepeatedDwgRead |
RenameLayoutAlreadyExists |
RenameIsModelSpace |
RenameInvalidName |
RenameInvalidLayoutName |
RenameDoesNotExist |
RegistryCreateError |
RegistryAccessError |
RegisteredApplicationIdNotFound |
RecordNotInTable |
ProperClassSeparatorExpected |
ProfileIsInUse |
ProfileDoesNotExist |
PolyWidthLost |
PointNotOnEntity |
PlotStyleInColorDependentMode |
PlotCancelled |
PlotAlreadyStarted |
PermanentlyErased |
PagerWriteError |
PagerError |
PageCancelled |
OwnerNotSet |
OwnerNotOpenForWrite |
OwnerNotOpenForRead |
OwnerNotInDatabase |
OutOfRange |
OutOfPagerMemory |
OutOfMemory |
OutOfDisk |
OtherObjectsBusy |
OpenFileCancelled |
OnLockedLayer |
OK |
ObsoleteFileFormat |
ObjectToBeDeleted |
ObjectIsReferenced |
NumberOfCopiesNotSupported |
NullPtr |
NullObjectPointer |
NullObjectId |
NullIterator |
NullHandle |
NullExtents |
NullEntityPointer |
NullBlockName |
NoWorkSet |
NoViewAssociation |
NotTopTransaction |
NotThatKindOfClass |
NotSupportedInDwgApi |
NotOpenForWrite |
NotOpenForRead |
NotNewlyCreated |
NotMultiPageCapable |
NotInPaperspace |
NotInitializedYet |
NotInGroup |
NotInDatabase |
NotInBlock |
NotImplementedYet |
NoThumbnailBitmap |
NotHandled |
NotFromThisDocument |
NotDxfHeaderGroupCode |
NotCurrentDatabase |
NotApplicable |
NotAnEntity |
NotAllowedForThisProxy |
NoPlotStyleTranslationTable |
NonPlanarEntity |
NonePlotDevice |
NonCoplanarGeometry |
NoMatchingMedia |
NoLayout |
NoLabelBlock |
NoInternalSpace |
NoInputFiler |
NoFileName |
NoErrorHandler |
NoDocument |
NoDatabase |
NoCurrentConfig |
NoClassId |
NoBlockBegin |
NoActiveTransactions |
NlsFileNotAvailable |
NegativeValueNotAllowed |
MustPlotToFile |
MustOpenThruOwner |
MustFirstAddBlockToDB |
MustBePositive |
MustBeNonZero |
MustBeNonNegative |
MustBe1to8 |
MustBe1to6 |
MustBe1to15 |
MustBe0to8 |
MustBe0to5 |
MustBe0to4 |
MustBe0to3 |
MustBe0to2 |
MissingSymbolTableRecord |
MissingSymbolTable |
MissingDxfSection |
MissingDxfField |
MissingBlockName |
MaxLayouts |
MakeMeProxyAndResurrect |
MakeMeProxy |
LongTransReferenceError |
LockViolation |
LockConflict |
LockChangeInProgress |
LoadFailed |
LispActive |
LeftErrorsUnfixed |
LayoutNotCurrent |
LayerGroupCodeMissing |
KeyNotFound |
IteratorDone |
IsXRefObject |
IsWriting |
IsWriteProtected |
IsReading |
IsAnEntity |


Exception Class

Exception Class
Namespaces »ZwSoft.ZwCAD.Runtime »Exception
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Exception : Exception, ISerializable
<SerializableAttribute> _
Public Class Exception _
    Inherits Exception _
    Implements ISerializable
[SerializableAttribute]
public ref class Exception : public Exception,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Exception(ErrorStatus, String, Exception) |
 | Exception(SerializationInfo, StreamingContext) |
 | Exception(ErrorStatus, String) |
 | Exception(ErrorStatus) |
 | Exception()()()() |
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorStatus |
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from Exception.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | Exception


Exception Constructor

Exception Constructor
Namespaces »ZwSoft.ZwCAD.Runtime »Exception »Exception()()()()
Members
Icon | Member | Description
 | Exception(ErrorStatus, String, Exception) |
 | Exception(SerializationInfo, StreamingContext) |
 | Exception(ErrorStatus, String) |
 | Exception(ErrorStatus) |
 | Exception()()()() |


Exception Constructor

Exception Constructor
Namespaces »ZwSoft.ZwCAD.Runtime »Exception »Exception()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Exception()
Public Sub New
public:
Exception()


Exception Constructor (info, context)

Exception Constructor (info, context)
Namespaces »ZwSoft.ZwCAD.Runtime »Exception »Exception(SerializationInfo, StreamingContext)
Declaration Syntax
C# Visual Basic Visual C++
protected Exception(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
Exception(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info(SerializationInfo)
context(StreamingContext)


Exception Constructor (es)

Exception Constructor (es)
Namespaces »ZwSoft.ZwCAD.Runtime »Exception »Exception(ErrorStatus)
Declaration Syntax
C# Visual Basic Visual C++
public Exception(
    ErrorStatus es
)
Public Sub New ( _
    es As ErrorStatus _
)
public:
Exception(
    ErrorStatus es
)
Parameters
es(ErrorStatus)


Exception Constructor (es, message)

Exception Constructor (es, message)
Namespaces »ZwSoft.ZwCAD.Runtime »Exception »Exception(ErrorStatus, String)
Declaration Syntax
C# Visual Basic Visual C++
public Exception(
    ErrorStatus es,
    string message
)
Public Sub New ( _
    es As ErrorStatus, _
    message As String _
)
public:
Exception(
    ErrorStatus es,
    String^ message
)
Parameters
es(ErrorStatus)
message(String)


Exception Constructor (es, message, innerException)

Exception Constructor (es, message, innerException)
Namespaces »ZwSoft.ZwCAD.Runtime »Exception »Exception(ErrorStatus, String, Exception)
Declaration Syntax
C# Visual Basic Visual C++
public Exception(
    ErrorStatus es,
    string message,
    Exception innerException
)
Public Sub New ( _
    es As ErrorStatus, _
    message As String, _
    innerException As Exception _
)
public:
Exception(
    ErrorStatus es,
    String^ message,
    Exception^ innerException
)
Parameters
es(ErrorStatus)
message(String)
innerException(Exception)


ErrorStatus Property

ErrorStatus Property
Namespaces »ZwSoft.ZwCAD.Runtime »Exception »ErrorStatus
Declaration Syntax
C# Visual Basic Visual C++
public ErrorStatus ErrorStatus { get; set; }
Public Property ErrorStatus As ErrorStatus
    Get
    Set
public:
property ErrorStatus ErrorStatus {
    ErrorStatus get ();
    void set (ErrorStatus value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces »ZwSoft.ZwCAD.Runtime »Exception »GetObjectData(SerializationInfo, StreamingContext)
Declaration Syntax
C# Visual Basic Visual C++
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
[SecurityPermissionAttribute(SecurityAction::Demand, SerializationFormatter = true)]
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info(SerializationInfo)
context(StreamingContext)


ExtensionApplicationAttribute Class

ExtensionApplicationAttribute Class
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionApplicationAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = false,
    Inherited = false)]
public sealed class ExtensionApplicationAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple := False,  _
    Inherited := False)> _
Public NotInheritable Class ExtensionApplicationAttribute _
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple = false,
    Inherited = false)]
public ref class ExtensionApplicationAttribute sealed : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtensionApplicationAttribute(Type) |
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | TypeId | (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | ExtensionApplicationAttribute


ExtensionApplicationAttribute Constructor (entryPointType)

ExtensionApplicationAttribute Constructor (entryPointType)
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionApplicationAttribute »ExtensionApplicationAttribute(Type)
Declaration Syntax
C# Visual Basic Visual C++
public ExtensionApplicationAttribute(
    Type entryPointType
)
Public Sub New ( _
    entryPointType As Type _
)
public:
ExtensionApplicationAttribute(
    Type^ entryPointType
)
Parameters
entryPointType(Type)


Type Property

Type Property
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionApplicationAttribute »Type
Declaration Syntax
C# Visual Basic Visual C++
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}


ExtensionApplicationHolder Class

ExtensionApplicationHolder Class
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionApplicationHolder
Declaration Syntax
C# Visual Basic Visual C++
public class ExtensionApplicationHolder : IDisposable
Public Class ExtensionApplicationHolder _
    Implements IDisposable
public ref class ExtensionApplicationHolder : IDisposable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExtensionApplicationHolder(IExtensionApplication) |
 | Dispose(Boolean) |
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ExtensionApplicationHolder


ExtensionApplicationHolder Constructor (application)

ExtensionApplicationHolder Constructor (application)
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionApplicationHolder »ExtensionApplicationHolder(IExtensionApplication)
Declaration Syntax
C# Visual Basic Visual C++
public ExtensionApplicationHolder(
    IExtensionApplication application
)
Public Sub New ( _
    application As IExtensionApplication _
)
public:
ExtensionApplicationHolder(
    IExtensionApplication^ application
)
Parameters
application(IExtensionApplication)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionApplicationHolder »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionApplicationHolder »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed


Dispose Method ()

Dispose Method ()
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionApplicationHolder »Dispose(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool
)
Protected Overridable Sub Dispose ( _
     As Boolean _
)
protected:
virtual void Dispose(
    bool
)
Parameters
(Boolean)


ExtensionLoader Class

ExtensionLoader Class
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionLoader
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ExtensionLoader : MarshalByRefObject
Public NotInheritable Class ExtensionLoader _
    Inherits MarshalByRefObject
public ref class ExtensionLoader sealed : public MarshalByRefObject
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Equals(Object) | (Inherited from Object.)
 | FileIsLoad(String) |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsLoaded(String) |
 | Load(String) |
 | Load1(String, Type, ExtensionLoader..::..BeforeLoadHandler) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | ExtensionLoader


FileIsLoad Method (fileName)

FileIsLoad Method (fileName)
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionLoader »FileIsLoad(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool FileIsLoad(
    string fileName
)
Public Shared Function FileIsLoad ( _
    fileName As String _
) As Boolean
public:
static bool FileIsLoad(
    String^ fileName
)
Parameters
fileName(String)


IsLoaded Method (fileName)

IsLoaded Method (fileName)
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionLoader »IsLoaded(String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsLoaded(
    string fileName
)
Public Shared Function IsLoaded ( _
    fileName As String _
) As Boolean
public:
static bool IsLoaded(
    String^ fileName
)
Parameters
fileName(String)


Load Method (fileName)

Load Method (fileName)
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionLoader »Load(String)
Declaration Syntax
C# Visual Basic Visual C++
[SecurityPermissionAttribute(SecurityAction.LinkDemand, Infrastructure = true)]
public static Assembly Load(
    string fileName
)
<SecurityPermissionAttribute(SecurityAction.LinkDemand, Infrastructure := True)> _
Public Shared Function Load ( _
    fileName As String _
) As Assembly
[SecurityPermissionAttribute(SecurityAction::LinkDemand, Infrastructure = true)]
public:
static Assembly^ Load(
    String^ fileName
)
Parameters
fileName(String)


Load1 Method (fileName, extensionHolderType, handler)

Load1 Method (fileName, extensionHolderType, handler)
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionLoader »Load1(String, Type, ExtensionLoader..::..BeforeLoadHandler)
Declaration Syntax
C# Visual Basic Visual C++
public static void Load1(
    string fileName,
    Type extensionHolderType,
    ExtensionLoader..::..BeforeLoadHandler handler
)
Public Shared Sub Load1 ( _
    fileName As String, _
    extensionHolderType As Type, _
    handler As ExtensionLoader..::..BeforeLoadHandler _
)
public:
static void Load1(
    String^ fileName,
    Type^ extensionHolderType,
    ExtensionLoader..::..BeforeLoadHandler^ handler
)
Parameters
fileName(String)
extensionHolderType(Type)
handler(ExtensionLoader..::..BeforeLoadHandler)


ExtensionLoader.BeforeLoadHandler Delegate

ExtensionLoader..::..BeforeLoadHandler Delegate
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionLoader »ExtensionLoader..::..BeforeLoadHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void BeforeLoadHandler(
    AssemblyName name
)
Public Delegate Sub BeforeLoadHandler ( _
    name As AssemblyName _
)
public delegate void BeforeLoadHandler(
    AssemblyName^ name
)
Parameters
name(AssemblyName)


ICommandLineCallable Interface

ICommandLineCallable Interface
Namespaces »ZwSoft.ZwCAD.Runtime »ICommandLineCallable
Declaration Syntax
C# Visual Basic Visual C++
public interface ICommandLineCallable
Public Interface ICommandLineCallable
public interface class ICommandLineCallable
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ContextMenuExtensionType |
 | Flags |
 | GlobalName |
 | GroupName |
 | HelpFileName |
 | HelpTopic |
 | LocalizedNameId |

Assembly: ZwManaged (Module: ZwManaged)


ContextMenuExtensionType Property

ContextMenuExtensionType Property
Namespaces »ZwSoft.ZwCAD.Runtime »ICommandLineCallable »ContextMenuExtensionType
Declaration Syntax
C# Visual Basic Visual C++
Type ContextMenuExtensionType { get; }
ReadOnly Property ContextMenuExtensionType As Type
    Get
property Type^ ContextMenuExtensionType {
    Type^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Flags Property

Flags Property
Namespaces »ZwSoft.ZwCAD.Runtime »ICommandLineCallable »Flags
Declaration Syntax
C# Visual Basic Visual C++
CommandFlags Flags { get; }
ReadOnly Property Flags As CommandFlags
    Get
property CommandFlags Flags {
    CommandFlags get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GlobalName Property

GlobalName Property
Namespaces »ZwSoft.ZwCAD.Runtime »ICommandLineCallable »GlobalName
Declaration Syntax
C# Visual Basic Visual C++
string GlobalName { get; }
ReadOnly Property GlobalName As String
    Get
property String^ GlobalName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GroupName Property

GroupName Property
Namespaces »ZwSoft.ZwCAD.Runtime »ICommandLineCallable »GroupName
Declaration Syntax
C# Visual Basic Visual C++
string GroupName { get; }
ReadOnly Property GroupName As String
    Get
property String^ GroupName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


HelpFileName Property

HelpFileName Property
Namespaces »ZwSoft.ZwCAD.Runtime »ICommandLineCallable »HelpFileName
Declaration Syntax
C# Visual Basic Visual C++
string HelpFileName { get; }
ReadOnly Property HelpFileName As String
    Get
property String^ HelpFileName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


HelpTopic Property

HelpTopic Property
Namespaces »ZwSoft.ZwCAD.Runtime »ICommandLineCallable »HelpTopic
Declaration Syntax
C# Visual Basic Visual C++
string HelpTopic { get; }
ReadOnly Property HelpTopic As String
    Get
property String^ HelpTopic {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LocalizedNameId Property

LocalizedNameId Property
Namespaces »ZwSoft.ZwCAD.Runtime »ICommandLineCallable »LocalizedNameId
Declaration Syntax
C# Visual Basic Visual C++
string LocalizedNameId { get; }
ReadOnly Property LocalizedNameId As String
    Get
property String^ LocalizedNameId {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IExtensionApplication Interface

IExtensionApplication Interface
Namespaces »ZwSoft.ZwCAD.Runtime »IExtensionApplication
Declaration Syntax
C# Visual Basic Visual C++
public interface IExtensionApplication
Public Interface IExtensionApplication
public interface class IExtensionApplication
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Initialize()()()() |
 | Terminate()()()() |


Initialize Method

Initialize Method
Namespaces »ZwSoft.ZwCAD.Runtime »IExtensionApplication »Initialize()()()()
Declaration Syntax
C# Visual Basic Visual C++
void Initialize()
Sub Initialize
void Initialize()


Terminate Method

Terminate Method
Namespaces »ZwSoft.ZwCAD.Runtime »IExtensionApplication »Terminate()()()()
Declaration Syntax
C# Visual Basic Visual C++
void Terminate()
Sub Terminate
void Terminate()


Interop Class

Interop Class
Namespaces »ZwSoft.ZwCAD.Runtime »Interop
Declaration Syntax
C# Visual Basic Visual C++
public static class Interop
Public NotInheritable Class Interop
public ref class Interop abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AttachUnmanagedObject(DisposableWrapper, IntPtr, Boolean) |
 | Check(Int32) |
 | CheckAdsForCancel(Int32) |
 | CheckBool(Boolean) |
 | CheckBoolean(Int32) |
 | CheckCPPErrName(Int32) |
 | CheckNull(IntPtr) |
 | CheckZds(Int32) |
 | DetachUnmanagedObject(DisposableWrapper) |
 | SetAutoDelete(DisposableWrapper, Boolean) |
 | ThrowExceptionForErrorStatus(Int32) |
Inheritance Hierarchy
Object
Interop


AttachUnmanagedObject Method (obj, unmanagedPointer, autoDelete)

AttachUnmanagedObject Method (obj, unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »AttachUnmanagedObject(DisposableWrapper, IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
[SecurityPermissionAttribute(SecurityAction.LinkDemand, Flags = SecurityPermissionFlag.UnmanagedCode)]
public static void AttachUnmanagedObject(
    DisposableWrapper obj,
    IntPtr unmanagedPointer,
    bool autoDelete
)
<SecurityPermissionAttribute(SecurityAction.LinkDemand, Flags := SecurityPermissionFlag.UnmanagedCode)> _
Public Shared Sub AttachUnmanagedObject ( _
    obj As DisposableWrapper, _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
[SecurityPermissionAttribute(SecurityAction::LinkDemand, Flags = SecurityPermissionFlag::UnmanagedCode)]
public:
static void AttachUnmanagedObject(
    DisposableWrapper^ obj,
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
obj(DisposableWrapper)
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Check Method (returnValue)

Check Method (returnValue)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »Check(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void Check(
    int returnValue
)
Public Shared Sub Check ( _
    returnValue As Integer _
)
public:
static void Check(
    int returnValue
)
Parameters
returnValue(Int32)


CheckAdsForCancel Method (returnValue)

CheckAdsForCancel Method (returnValue)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »CheckAdsForCancel(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static bool CheckAdsForCancel(
    int returnValue
)
Public Shared Function CheckAdsForCancel ( _
    returnValue As Integer _
) As Boolean
public:
static bool CheckAdsForCancel(
    int returnValue
)
Parameters
returnValue(Int32)


CheckBool Method (returnValue)

CheckBool Method (returnValue)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »CheckBool(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static void CheckBool(
    bool returnValue
)
Public Shared Sub CheckBool ( _
    returnValue As Boolean _
)
public:
static void CheckBool(
    bool returnValue
)
Parameters
returnValue(Boolean)


CheckBoolean Method (returnValue)

CheckBoolean Method (returnValue)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »CheckBoolean(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void CheckBoolean(
    int returnValue
)
Public Shared Sub CheckBoolean ( _
    returnValue As Integer _
)
public:
static void CheckBoolean(
    int returnValue
)
Parameters
returnValue(Int32)


CheckCPPErrName Method (returnValue)

CheckCPPErrName Method (returnValue)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »CheckCPPErrName(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void CheckCPPErrName(
    int returnValue
)
Public Shared Sub CheckCPPErrName ( _
    returnValue As Integer _
)
public:
static void CheckCPPErrName(
    int returnValue
)
Parameters
returnValue(Int32)


CheckNull Method (returnValue)

CheckNull Method (returnValue)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »CheckNull(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static void CheckNull(
    IntPtr returnValue
)
Public Shared Sub CheckNull ( _
    returnValue As IntPtr _
)
public:
static void CheckNull(
    IntPtr returnValue
)
Parameters
returnValue(IntPtr)


CheckZds Method (returnValue)

CheckZds Method (returnValue)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »CheckZds(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void CheckZds(
    int returnValue
)
Public Shared Sub CheckZds ( _
    returnValue As Integer _
)
public:
static void CheckZds(
    int returnValue
)
Parameters
returnValue(Int32)


DetachUnmanagedObject Method (obj)

DetachUnmanagedObject Method (obj)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »DetachUnmanagedObject(DisposableWrapper)
Declaration Syntax
C# Visual Basic Visual C++
[SecurityPermissionAttribute(SecurityAction.LinkDemand, Flags = SecurityPermissionFlag.UnmanagedCode)]
public static void DetachUnmanagedObject(
    DisposableWrapper obj
)
<SecurityPermissionAttribute(SecurityAction.LinkDemand, Flags := SecurityPermissionFlag.UnmanagedCode)> _
Public Shared Sub DetachUnmanagedObject ( _
    obj As DisposableWrapper _
)
[SecurityPermissionAttribute(SecurityAction::LinkDemand, Flags = SecurityPermissionFlag::UnmanagedCode)]
public:
static void DetachUnmanagedObject(
    DisposableWrapper^ obj
)
Parameters
obj(DisposableWrapper)


SetAutoDelete Method (obj, value)

SetAutoDelete Method (obj, value)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »SetAutoDelete(DisposableWrapper, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
[SecurityPermissionAttribute(SecurityAction.LinkDemand, Flags = SecurityPermissionFlag.UnmanagedCode)]
public static void SetAutoDelete(
    DisposableWrapper obj,
    bool value
)
<SecurityPermissionAttribute(SecurityAction.LinkDemand, Flags := SecurityPermissionFlag.UnmanagedCode)> _
Public Shared Sub SetAutoDelete ( _
    obj As DisposableWrapper, _
    value As Boolean _
)
[SecurityPermissionAttribute(SecurityAction::LinkDemand, Flags = SecurityPermissionFlag::UnmanagedCode)]
public:
static void SetAutoDelete(
    DisposableWrapper^ obj,
    bool value
)
Parameters
obj(DisposableWrapper)
value(Boolean)


ThrowExceptionForErrorStatus Method (errorStatus)

ThrowExceptionForErrorStatus Method (errorStatus)
Namespaces »ZwSoft.ZwCAD.Runtime »Interop »ThrowExceptionForErrorStatus(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void ThrowExceptionForErrorStatus(
    int errorStatus
)
Public Shared Sub ThrowExceptionForErrorStatus ( _
    errorStatus As Integer _
)
public:
static void ThrowExceptionForErrorStatus(
    int errorStatus
)
Parameters
errorStatus(Int32)


LispDataType Enumeration

LispDataType Enumeration
Namespaces »ZwSoft.ZwCAD.Runtime »LispDataType
Declaration Syntax
C# Visual Basic Visual C++
public enum LispDataType
Public Enumeration LispDataType
public enum class LispDataType
Members
Member | Description
SelectionSet |
Text |
Point3d |
ObjectId |
Angle |
Point2d |
T_atom |
Nil |
DottedPair |
ListEnd |
ListBegin |
Void |
Int32 |
Orientation |
Int16 |
Double |
None |

Assembly: ZwManaged (Module: ZwManaged)


LispFunctionAttribute Class

LispFunctionAttribute Class
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = true, Inherited = false)]
public sealed class LispFunctionAttribute : Attribute,
    ICommandLineCallable
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := True, Inherited := False)> _
Public NotInheritable Class LispFunctionAttribute _
    Inherits Attribute _
    Implements ICommandLineCallable
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = true, Inherited = false)]
public ref class LispFunctionAttribute sealed : public Attribute,
    ICommandLineCallable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LispFunctionAttribute(String, String, String, String) |
 | LispFunctionAttribute(String, String, String) |
 | LispFunctionAttribute(String, String) |
 | LispFunctionAttribute(String) |
 | ContextMenuExtensionType |
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | Flags |
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | GlobalName |
 | GroupName |
 | HelpFileName |
 | HelpTopic |
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | LocalizedNameId |
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | LispFunctionAttribute

Assembly: ZwManaged (Module: ZwManaged)


LispFunctionAttribute Constructor

LispFunctionAttribute Constructor
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »LispFunctionAttribute()()()()
Members
Icon | Member | Description
 | LispFunctionAttribute(String, String, String, String) |
 | LispFunctionAttribute(String, String, String) |
 | LispFunctionAttribute(String, String) |
 | LispFunctionAttribute(String) |

Assembly: ZwManaged (Module: ZwManaged)


LispFunctionAttribute Constructor (globalName)

LispFunctionAttribute Constructor (globalName)
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »LispFunctionAttribute(String)
Declaration Syntax
C# Visual Basic Visual C++
public LispFunctionAttribute(
    string globalName
)
Public Sub New ( _
    globalName As String _
)
public:
LispFunctionAttribute(
    String^ globalName
)
Parameters
globalName(String)

Assembly: ZwManaged (Module: ZwManaged)


LispFunctionAttribute Constructor (globalName, localizedNameId)

LispFunctionAttribute Constructor (globalName, localizedNameId)
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »LispFunctionAttribute(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public LispFunctionAttribute(
    string globalName,
    string localizedNameId
)
Public Sub New ( _
    globalName As String, _
    localizedNameId As String _
)
public:
LispFunctionAttribute(
    String^ globalName,
    String^ localizedNameId
)
Parameters
globalName(String)
localizedNameId(String)

Assembly: ZwManaged (Module: ZwManaged)


LispFunctionAttribute Constructor (globalName, localizedNameId, helpFileName)

LispFunctionAttribute Constructor (globalName, localizedNameId, helpFileName)
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »LispFunctionAttribute(String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public LispFunctionAttribute(
    string globalName,
    string localizedNameId,
    string helpFileName
)
Public Sub New ( _
    globalName As String, _
    localizedNameId As String, _
    helpFileName As String _
)
public:
LispFunctionAttribute(
    String^ globalName,
    String^ localizedNameId,
    String^ helpFileName
)
Parameters
globalName(String)
localizedNameId(String)
helpFileName(String)

Assembly: ZwManaged (Module: ZwManaged)


LispFunctionAttribute Constructor (globalName, localizedNameId, helpFileName, helpTopic)

LispFunctionAttribute Constructor (globalName, localizedNameId, helpFileName, helpTopic)
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »LispFunctionAttribute(String, String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public LispFunctionAttribute(
    string globalName,
    string localizedNameId,
    string helpFileName,
    string helpTopic
)
Public Sub New ( _
    globalName As String, _
    localizedNameId As String, _
    helpFileName As String, _
    helpTopic As String _
)
public:
LispFunctionAttribute(
    String^ globalName,
    String^ localizedNameId,
    String^ helpFileName,
    String^ helpTopic
)
Parameters
globalName(String)
localizedNameId(String)
helpFileName(String)
helpTopic(String)

Assembly: ZwManaged (Module: ZwManaged)


ContextMenuExtensionType Property

ContextMenuExtensionType Property
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »ContextMenuExtensionType
Declaration Syntax
C# Visual Basic Visual C++
public virtual Type ContextMenuExtensionType { get; }
Public Overridable ReadOnly Property ContextMenuExtensionType As Type
    Get
public:
virtual property Type^ ContextMenuExtensionType {
    Type^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Flags Property

Flags Property
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »Flags
Declaration Syntax
C# Visual Basic Visual C++
public virtual CommandFlags Flags { get; }
Public Overridable ReadOnly Property Flags As CommandFlags
    Get
public:
virtual property CommandFlags Flags {
    CommandFlags get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GlobalName Property

GlobalName Property
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »GlobalName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GlobalName { get; }
Public Overridable ReadOnly Property GlobalName As String
    Get
public:
virtual property String^ GlobalName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GroupName Property

GroupName Property
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »GroupName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GroupName { get; }
Public Overridable ReadOnly Property GroupName As String
    Get
public:
virtual property String^ GroupName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


HelpFileName Property

HelpFileName Property
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »HelpFileName
Declaration Syntax
C# Visual Basic Visual C++
public virtual string HelpFileName { get; }
Public Overridable ReadOnly Property HelpFileName As String
    Get
public:
virtual property String^ HelpFileName {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


HelpTopic Property

HelpTopic Property
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »HelpTopic
Declaration Syntax
C# Visual Basic Visual C++
public virtual string HelpTopic { get; }
Public Overridable ReadOnly Property HelpTopic As String
    Get
public:
virtual property String^ HelpTopic {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LocalizedNameId Property

LocalizedNameId Property
Namespaces »ZwSoft.ZwCAD.Runtime »LispFunctionAttribute »LocalizedNameId
Declaration Syntax
C# Visual Basic Visual C++
public virtual string LocalizedNameId { get; }
Public Overridable ReadOnly Property LocalizedNameId As String
    Get
public:
virtual property String^ LocalizedNameId {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


LispInvokeHandler Delegate

LispInvokeHandler Delegate
Namespaces »ZwSoft.ZwCAD.Runtime »LispInvokeHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate int LispInvokeHandler()
Public Delegate Function LispInvokeHandler As Integer
public delegate int LispInvokeHandler()

Assembly: ZwManaged (Module: ZwManaged)


Marshaler Class

Marshaler Class
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler
Declaration Syntax
C# Visual Basic Visual C++
public static class Marshaler
Public NotInheritable Class Marshaler
public ref class Marshaler abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BitmapInfoToBitmap(IntPtr) |
 | BitmapToBitmapInfo(Bitmap) |
 | CopyToManagedFullSubentityPath(IntPtr) |
 | CopyToUnmanagedFullSubentityPath(FullSubentityPath, IntPtr) |
 | GetInternalArray(Vector3dCollection) |
 | GetInternalArray(Vector2dCollection) |
 | GetInternalArray(Point2dCollection) |
 | GetInternalArray(IntegerCollection) |
 | GetInternalArray(DoubleCollection) |
 | ObjectToResbuf(Object, IntPtr) |
 | ObjectToZcValue(Object, IntPtr) |
 | ResbufToObject(IntPtr) |
 | ResbufToTypedValues(IntPtr) |
 | SetInternalArray(Vector3dCollection, array<Vector3d>[]()[][], Int32) |
 | SetInternalArray(Vector2dCollection, array<Vector2d>[]()[][], Int32) |
 | SetInternalArray(Point2dCollection, array<Point2d>[]()[][], Int32) |
 | SetInternalArray(IntegerCollection, array<Int32>[]()[][], Int32) |
 | SetInternalArray(DoubleCollection, array<Double>[]()[][], Int32) |
 | TypedValuesToResbuf(array<TypedValue>[]()[][]) |
 | ViewportDraw(IntPtr, Boolean) |
 | WorldDraw(IntPtr, Boolean) |
 | ZcValueToObject(IntPtr) |
Inheritance Hierarchy
Object
Marshaler


BitmapInfoToBitmap Method (bitmapInfo)

BitmapInfoToBitmap Method (bitmapInfo)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »BitmapInfoToBitmap(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static Bitmap BitmapInfoToBitmap(
    IntPtr bitmapInfo
)
Public Shared Function BitmapInfoToBitmap ( _
    bitmapInfo As IntPtr _
) As Bitmap
public:
static Bitmap^ BitmapInfoToBitmap(
    IntPtr bitmapInfo
)
Parameters
bitmapInfo(IntPtr)


BitmapToBitmapInfo Method (bitmap)

BitmapToBitmapInfo Method (bitmap)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »BitmapToBitmapInfo(Bitmap)
Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr BitmapToBitmapInfo(
    Bitmap bitmap
)
Public Shared Function BitmapToBitmapInfo ( _
    bitmap As Bitmap _
) As IntPtr
public:
static IntPtr BitmapToBitmapInfo(
    Bitmap^ bitmap
)
Parameters
bitmap(Bitmap)


CopyToManagedFullSubentityPath Method (path)

CopyToManagedFullSubentityPath Method (path)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »CopyToManagedFullSubentityPath(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static FullSubentityPath CopyToManagedFullSubentityPath(
    IntPtr path
)
Public Shared Function CopyToManagedFullSubentityPath ( _
    path As IntPtr _
) As FullSubentityPath
public:
static FullSubentityPath CopyToManagedFullSubentityPath(
    IntPtr path
)
Parameters
path(IntPtr)


CopyToUnmanagedFullSubentityPath Method (path, newPath)

CopyToUnmanagedFullSubentityPath Method (path, newPath)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »CopyToUnmanagedFullSubentityPath(FullSubentityPath, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static void CopyToUnmanagedFullSubentityPath(
    FullSubentityPath path,
    IntPtr newPath
)
Public Shared Sub CopyToUnmanagedFullSubentityPath ( _
    path As FullSubentityPath, _
    newPath As IntPtr _
)
public:
static void CopyToUnmanagedFullSubentityPath(
    FullSubentityPath path,
    IntPtr newPath
)
Parameters
path(FullSubentityPath)
newPath(IntPtr)


GetInternalArray Method

GetInternalArray Method
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »GetInternalArray()()()()
Members
Icon | Member | Description
 | GetInternalArray(Vector3dCollection) |
 | GetInternalArray(Vector2dCollection) |
 | GetInternalArray(Point2dCollection) |
 | GetInternalArray(IntegerCollection) |
 | GetInternalArray(DoubleCollection) |


GetInternalArray Method (col)

GetInternalArray Method (col)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »GetInternalArray(DoubleCollection)
Declaration Syntax
C# Visual Basic Visual C++
public static double[] GetInternalArray(
    DoubleCollection col
)
Public Shared Function GetInternalArray ( _
    col As DoubleCollection _
) As Double()
public:
static array<double>^ GetInternalArray(
    DoubleCollection^ col
)
Parameters
col(DoubleCollection)


GetInternalArray Method (col)

GetInternalArray Method (col)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »GetInternalArray(IntegerCollection)
Declaration Syntax
C# Visual Basic Visual C++
public static int[] GetInternalArray(
    IntegerCollection col
)
Public Shared Function GetInternalArray ( _
    col As IntegerCollection _
) As Integer()
public:
static array<int>^ GetInternalArray(
    IntegerCollection^ col
)
Parameters
col(IntegerCollection)


GetInternalArray Method (col)

GetInternalArray Method (col)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »GetInternalArray(Point2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public static Point2d[] GetInternalArray(
    Point2dCollection col
)
Public Shared Function GetInternalArray ( _
    col As Point2dCollection _
) As Point2d()
public:
static array<Point2d>^ GetInternalArray(
    Point2dCollection^ col
)
Parameters
col(Point2dCollection)


GetInternalArray Method (col)

GetInternalArray Method (col)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »GetInternalArray(Vector2dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector2d[] GetInternalArray(
    Vector2dCollection col
)
Public Shared Function GetInternalArray ( _
    col As Vector2dCollection _
) As Vector2d()
public:
static array<Vector2d>^ GetInternalArray(
    Vector2dCollection^ col
)
Parameters
col(Vector2dCollection)


GetInternalArray Method (col)

GetInternalArray Method (col)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »GetInternalArray(Vector3dCollection)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector3d[] GetInternalArray(
    Vector3dCollection col
)
Public Shared Function GetInternalArray ( _
    col As Vector3dCollection _
) As Vector3d()
public:
static array<Vector3d>^ GetInternalArray(
    Vector3dCollection^ col
)
Parameters
col(Vector3dCollection)


ObjectToResbuf Method (obj, rb)

ObjectToResbuf Method (obj, rb)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »ObjectToResbuf(Object, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static void ObjectToResbuf(
    Object obj,
    IntPtr rb
)
Public Shared Sub ObjectToResbuf ( _
    obj As Object, _
    rb As IntPtr _
)
public:
static void ObjectToResbuf(
    Object^ obj,
    IntPtr rb
)
Parameters
obj(Object)
rb(IntPtr)


ObjectToZcValue Method (obj, zcValueObj)

ObjectToZcValue Method (obj, zcValueObj)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »ObjectToZcValue(Object, IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static void ObjectToZcValue(
    Object obj,
    IntPtr zcValueObj
)
Public Shared Sub ObjectToZcValue ( _
    obj As Object, _
    zcValueObj As IntPtr _
)
public:
static void ObjectToZcValue(
    Object^ obj,
    IntPtr zcValueObj
)
Parameters
obj(Object)
zcValueObj(IntPtr)


ResbufToObject Method (rb)

ResbufToObject Method (rb)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »ResbufToObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static Object ResbufToObject(
    IntPtr rb
)
Public Shared Function ResbufToObject ( _
    rb As IntPtr _
) As Object
public:
static Object^ ResbufToObject(
    IntPtr rb
)
Parameters
rb(IntPtr)


ResbufToTypedValues Method (resbuf)

ResbufToTypedValues Method (resbuf)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »ResbufToTypedValues(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static TypedValue[] ResbufToTypedValues(
    IntPtr resbuf
)
Public Shared Function ResbufToTypedValues ( _
    resbuf As IntPtr _
) As TypedValue()
public:
static array<TypedValue>^ ResbufToTypedValues(
    IntPtr resbuf
)
Parameters
resbuf(IntPtr)


SetInternalArray Method

SetInternalArray Method
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »SetInternalArray()()()()
Members
Icon | Member | Description
 | SetInternalArray(Vector3dCollection, array<Vector3d>[]()[][], Int32) |
 | SetInternalArray(Vector2dCollection, array<Vector2d>[]()[][], Int32) |
 | SetInternalArray(Point2dCollection, array<Point2d>[]()[][], Int32) |
 | SetInternalArray(IntegerCollection, array<Int32>[]()[][], Int32) |
 | SetInternalArray(DoubleCollection, array<Double>[]()[][], Int32) |


SetInternalArray Method (col, newArray, count)

SetInternalArray Method (col, newArray, count)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »SetInternalArray(DoubleCollection, array<Double>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void SetInternalArray(
    DoubleCollection col,
    double[] newArray,
    int count
)
Public Shared Sub SetInternalArray ( _
    col As DoubleCollection, _
    newArray As Double(), _
    count As Integer _
)
public:
static void SetInternalArray(
    DoubleCollection^ col,
    array<double>^ newArray,
    int count
)
Parameters
col(DoubleCollection)
newArray(array<Double>[]()[][])
count(Int32)


SetInternalArray Method (col, newArray, count)

SetInternalArray Method (col, newArray, count)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »SetInternalArray(IntegerCollection, array<Int32>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void SetInternalArray(
    IntegerCollection col,
    int[] newArray,
    int count
)
Public Shared Sub SetInternalArray ( _
    col As IntegerCollection, _
    newArray As Integer(), _
    count As Integer _
)
public:
static void SetInternalArray(
    IntegerCollection^ col,
    array<int>^ newArray,
    int count
)
Parameters
col(IntegerCollection)
newArray(array<Int32>[]()[][])
count(Int32)


SetInternalArray Method (col, newArray, count)

SetInternalArray Method (col, newArray, count)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »SetInternalArray(Point2dCollection, array<Point2d>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void SetInternalArray(
    Point2dCollection col,
    Point2d[] newArray,
    int count
)
Public Shared Sub SetInternalArray ( _
    col As Point2dCollection, _
    newArray As Point2d(), _
    count As Integer _
)
public:
static void SetInternalArray(
    Point2dCollection^ col,
    array<Point2d>^ newArray,
    int count
)
Parameters
col(Point2dCollection)
newArray(array< Point2d >[]()[][])
count(Int32)


SetInternalArray Method (col, newArray, count)

SetInternalArray Method (col, newArray, count)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »SetInternalArray(Vector2dCollection, array<Vector2d>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void SetInternalArray(
    Vector2dCollection col,
    Vector2d[] newArray,
    int count
)
Public Shared Sub SetInternalArray ( _
    col As Vector2dCollection, _
    newArray As Vector2d(), _
    count As Integer _
)
public:
static void SetInternalArray(
    Vector2dCollection^ col,
    array<Vector2d>^ newArray,
    int count
)
Parameters
col(Vector2dCollection)
newArray(array< Vector2d >[]()[][])
count(Int32)


SetInternalArray Method (col, newArray, count)

SetInternalArray Method (col, newArray, count)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »SetInternalArray(Vector3dCollection, array<Vector3d>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static void SetInternalArray(
    Vector3dCollection col,
    Vector3d[] newArray,
    int count
)
Public Shared Sub SetInternalArray ( _
    col As Vector3dCollection, _
    newArray As Vector3d(), _
    count As Integer _
)
public:
static void SetInternalArray(
    Vector3dCollection^ col,
    array<Vector3d>^ newArray,
    int count
)
Parameters
col(Vector3dCollection)
newArray(array< Vector3d >[]()[][])
count(Int32)


TypedValuesToResbuf Method (values)

TypedValuesToResbuf Method (values)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »TypedValuesToResbuf(array<TypedValue>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr TypedValuesToResbuf(
    params TypedValue[] values
)
Public Shared Function TypedValuesToResbuf ( _
    ParamArray values As TypedValue() _
) As IntPtr
public:
static IntPtr TypedValuesToResbuf(
    ... array<TypedValue>^ values
)
Parameters
values(array< TypedValue >[]()[][])


ViewportDraw Method (unmanagedPointer, autoDelete)

ViewportDraw Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »ViewportDraw(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static ViewportDraw ViewportDraw(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function ViewportDraw ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As ViewportDraw
public:
static ViewportDraw^ ViewportDraw(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


WorldDraw Method (unmanagedPointer, autoDelete)

WorldDraw Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »WorldDraw(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static WorldDraw WorldDraw(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function WorldDraw ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As WorldDraw
public:
static WorldDraw^ WorldDraw(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


ZcValueToObject Method (zcValueObj)

ZcValueToObject Method (zcValueObj)
Namespaces »ZwSoft.ZwCAD.Runtime »Marshaler »ZcValueToObject(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static Object ZcValueToObject(
    IntPtr zcValueObj
)
Public Shared Function ZcValueToObject ( _
    zcValueObj As IntPtr _
) As Object
public:
static Object^ ZcValueToObject(
    IntPtr zcValueObj
)
Parameters
zcValueObj(IntPtr)


ModuleLoadAbortedEventHandler Delegate

ModuleLoadAbortedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Runtime »ModuleLoadAbortedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ModuleLoadAbortedEventHandler(
    Object sender,
    DynamicLinkerEventArgs e
)
Public Delegate Sub ModuleLoadAbortedEventHandler ( _
    sender As Object, _
    e As DynamicLinkerEventArgs _
)
public delegate void ModuleLoadAbortedEventHandler(
    Object^ sender,
    DynamicLinkerEventArgs^ e
)
Parameters
sender(Object)
e(DynamicLinkerEventArgs)


ModuleLoadedEventHandler Delegate

ModuleLoadedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Runtime »ModuleLoadedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ModuleLoadedEventHandler(
    Object sender,
    DynamicLinkerEventArgs e
)
Public Delegate Sub ModuleLoadedEventHandler ( _
    sender As Object, _
    e As DynamicLinkerEventArgs _
)
public delegate void ModuleLoadedEventHandler(
    Object^ sender,
    DynamicLinkerEventArgs^ e
)
Parameters
sender(Object)
e(DynamicLinkerEventArgs)


ModuleLoadingEventHandler Delegate

ModuleLoadingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Runtime »ModuleLoadingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ModuleLoadingEventHandler(
    Object sender,
    DynamicLinkerEventArgs e
)
Public Delegate Sub ModuleLoadingEventHandler ( _
    sender As Object, _
    e As DynamicLinkerEventArgs _
)
public delegate void ModuleLoadingEventHandler(
    Object^ sender,
    DynamicLinkerEventArgs^ e
)
Parameters
sender(Object)
e(DynamicLinkerEventArgs)


ModuleUnloadAbortedEventHandler Delegate

ModuleUnloadAbortedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Runtime »ModuleUnloadAbortedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ModuleUnloadAbortedEventHandler(
    Object sender,
    DynamicLinkerEventArgs e
)
Public Delegate Sub ModuleUnloadAbortedEventHandler ( _
    sender As Object, _
    e As DynamicLinkerEventArgs _
)
public delegate void ModuleUnloadAbortedEventHandler(
    Object^ sender,
    DynamicLinkerEventArgs^ e
)
Parameters
sender(Object)
e(DynamicLinkerEventArgs)


ModuleUnloadedEventHandler Delegate

ModuleUnloadedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Runtime »ModuleUnloadedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ModuleUnloadedEventHandler(
    Object sender,
    DynamicLinkerEventArgs e
)
Public Delegate Sub ModuleUnloadedEventHandler ( _
    sender As Object, _
    e As DynamicLinkerEventArgs _
)
public delegate void ModuleUnloadedEventHandler(
    Object^ sender,
    DynamicLinkerEventArgs^ e
)
Parameters
sender(Object)
e(DynamicLinkerEventArgs)


ModuleUnloadingEventHandler Delegate

ModuleUnloadingEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Runtime »ModuleUnloadingEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ModuleUnloadingEventHandler(
    Object sender,
    DynamicLinkerEventArgs e
)
Public Delegate Sub ModuleUnloadingEventHandler ( _
    sender As Object, _
    e As DynamicLinkerEventArgs _
)
public delegate void ModuleUnloadingEventHandler(
    Object^ sender,
    DynamicLinkerEventArgs^ e
)
Parameters
sender(Object)
e(DynamicLinkerEventArgs)


NetCommandDebugHelper Class

NetCommandDebugHelper Class
Namespaces »ZwSoft.ZwCAD.Runtime »NetCommandDebugHelper
Declaration Syntax
C# Visual Basic Visual C++
public class NetCommandDebugHelper
Public Class NetCommandDebugHelper
public ref class NetCommandDebugHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NetCommandDebugHelper()()()() |
 | AddCommand(String, Delegate) |
 | Equals(Object) | (Inherited from Object.)
 | Execute(String) |
 | Finalize()()()() | (Inherited from Object.)
 | GetAllCmdNames()()()() |
 | GetCustomCmdNames()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
NetCommandDebugHelper

Assembly: ZwManaged (Module: ZwManaged)


NetCommandDebugHelper Constructor

NetCommandDebugHelper Constructor
Namespaces »ZwSoft.ZwCAD.Runtime »NetCommandDebugHelper »NetCommandDebugHelper()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NetCommandDebugHelper()
Public Sub New
public:
NetCommandDebugHelper()

Assembly: ZwManaged (Module: ZwManaged)


AddCommand Method (cmdName, invoker)

AddCommand Method (cmdName, invoker)
Namespaces »ZwSoft.ZwCAD.Runtime »NetCommandDebugHelper »AddCommand(String, Delegate)
Declaration Syntax
C# Visual Basic Visual C++
public static void AddCommand(
    string cmdName,
    Delegate invoker
)
Public Shared Sub AddCommand ( _
    cmdName As String, _
    invoker As Delegate _
)
public:
static void AddCommand(
    String^ cmdName,
    Delegate^ invoker
)
Parameters
cmdName(String)
invoker(Delegate)

Assembly: ZwManaged (Module: ZwManaged)


Execute Method (cmdName)

Execute Method (cmdName)
Namespaces »ZwSoft.ZwCAD.Runtime »NetCommandDebugHelper »Execute(String)
Declaration Syntax
C# Visual Basic Visual C++
public static void Execute(
    string cmdName
)
Public Shared Sub Execute ( _
    cmdName As String _
)
public:
static void Execute(
    String^ cmdName
)
Parameters
cmdName(String)

Assembly: ZwManaged (Module: ZwManaged)


GetAllCmdNames Method

GetAllCmdNames Method
Namespaces »ZwSoft.ZwCAD.Runtime »NetCommandDebugHelper »GetAllCmdNames()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static List<string> GetAllCmdNames()
Public Shared Function GetAllCmdNames As List(Of String)
public:
static List<String^>^ GetAllCmdNames()

Assembly: ZwManaged (Module: ZwManaged)


GetCustomCmdNames Method

GetCustomCmdNames Method
Namespaces »ZwSoft.ZwCAD.Runtime »NetCommandDebugHelper »GetCustomCmdNames()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static List<string> GetCustomCmdNames()
Public Shared Function GetCustomCmdNames As List(Of String)
public:
static List<String^>^ GetCustomCmdNames()

Assembly: ZwManaged (Module: ZwManaged)


RXClass Class

RXClass Class
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcRxClass")]
public sealed class RXClass : RXObject
<WrapperAttribute("ZcRxClass")> _
Public NotInheritable Class RXClass _
    Inherits RXObject
[WrapperAttribute(L"ZcRxClass")]
public ref class RXClass sealed : public RXObject
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddX(RXClass, RXObject) |
 | AppName |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | ClassVersion |
 | Clone()()()() | (Inherited from RXObject.)
 | CompareTo(Object) | (Inherited from RXObject.)
 | CopyFrom(RXObject) | (Inherited from RXObject.)
 | Create()()()() |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from RXObject.)
 | DelX(RXClass) |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | DxfName |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() | (Inherited from RXObject.)
 | GetType()()()() | (Inherited from Object.)
 | GetX(RXClass) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDerivedFrom(RXClass) |
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MyParent |
 | Name |
 | ProxyFlags |
 | QueryX(RXClass) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) | (Inherited from RXObject.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | RXClass


AddX Method (runtimeClass, protocolExtension)

AddX Method (runtimeClass, protocolExtension)
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »AddX(RXClass, RXObject)
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr AddX(
    RXClass runtimeClass,
    RXObject protocolExtension
)
Public Function AddX ( _
    runtimeClass As RXClass, _
    protocolExtension As RXObject _
) As IntPtr
public:
IntPtr AddX(
    RXClass^ runtimeClass,
    RXObject^ protocolExtension
)
Parameters
runtimeClass(RXClass)
protocolExtension(RXObject)


AppName Property

AppName Property
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »AppName
Declaration Syntax
C# Visual Basic Visual C++
public string AppName { get; }
Public ReadOnly Property AppName As String
    Get
public:
property String^ AppName {
    String^ get ();
}


ClassVersion Property

ClassVersion Property
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »ClassVersion
Declaration Syntax
C# Visual Basic Visual C++
public Version ClassVersion { get; }
Public ReadOnly Property ClassVersion As Version
    Get
public:
property Version^ ClassVersion {
    Version^ get ();
}


Create Method

Create Method
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »Create()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RXObject Create()
Public Function Create As RXObject
public:
RXObject^ Create()


DelX Method (runtimeClass)

DelX Method (runtimeClass)
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »DelX(RXClass)
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr DelX(
    RXClass runtimeClass
)
Public Function DelX ( _
    runtimeClass As RXClass _
) As IntPtr
public:
IntPtr DelX(
    RXClass^ runtimeClass
)
Parameters
runtimeClass(RXClass)


DxfName Property

DxfName Property
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »DxfName
Declaration Syntax
C# Visual Basic Visual C++
public string DxfName { get; }
Public ReadOnly Property DxfName As String
    Get
public:
property String^ DxfName {
    String^ get ();
}


GetX Method (runtimeClass)

GetX Method (runtimeClass)
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »GetX(RXClass)
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr GetX(
    RXClass runtimeClass
)
Public Function GetX ( _
    runtimeClass As RXClass _
) As IntPtr
public:
IntPtr GetX(
    RXClass^ runtimeClass
)
Parameters
runtimeClass(RXClass)


IsDerivedFrom Method (runtimeClass)

IsDerivedFrom Method (runtimeClass)
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »IsDerivedFrom(RXClass)
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDerivedFrom(
    RXClass runtimeClass
)
Public Function IsDerivedFrom ( _
    runtimeClass As RXClass _
) As Boolean
public:
bool IsDerivedFrom(
    RXClass^ runtimeClass
)
Parameters
runtimeClass(RXClass)


MyParent Property

MyParent Property
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »MyParent
Declaration Syntax
C# Visual Basic Visual C++
public RXClass MyParent { get; }
Public ReadOnly Property MyParent As RXClass
    Get
public:
property RXClass^ MyParent {
    RXClass^ get ();
}


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}


ProxyFlags Property

ProxyFlags Property
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »ProxyFlags
Declaration Syntax
C# Visual Basic Visual C++
public int ProxyFlags { get; }
Public ReadOnly Property ProxyFlags As Integer
    Get
public:
property int ProxyFlags {
    int get ();
}


QueryX Method (runtimeClass)

QueryX Method (runtimeClass)
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »QueryX(RXClass)
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr QueryX(
    RXClass runtimeClass
)
Public Function QueryX ( _
    runtimeClass As RXClass _
) As IntPtr
public:
IntPtr QueryX(
    RXClass^ runtimeClass
)
Parameters
runtimeClass(RXClass)


RXObject Class

RXObject Class
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcRxObject")]
public abstract class RXObject : DisposableWrapper,
    ICloneable
<WrapperAttribute("ZcRxObject")> _
Public MustInherit Class RXObject _
    Inherits DisposableWrapper _
    Implements ICloneable
[WrapperAttribute(L"ZcRxObject")]
public ref class RXObject abstract : public DisposableWrapper,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RXObject(IntPtr, Boolean) |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Clone()()()() |
 | CompareTo(Object) |
 | CopyFrom(RXObject) |
 | Create(IntPtr, Boolean) |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetClass(Type) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetRXClass()()()() |
 | GetType()()()() | (Inherited from Object.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueryX(RXClass) |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | X(RXClass) |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | RXObject
 |  |  |  | Database
 |  |  |  | DataCell
 |  |  |  | DataColumn
 |  |  |  | DataLinkManager
 |  |  |  | DbDictionaryEnumerator
 |  |  |  | DwgFiler
 |  |  |  | DxfFiler
 |  |  |  | FieldEngine
 |  |  |  | FieldEvaluator
 |  |  |  | FieldEvaluatorLoader
 |  |  |  | FieldResult
 |  |  |  | HostApplicationServices
 |  |  |  | IdMapping
 |  |  |  | LayerStateManager
 |  |  |  | LayoutManager
 |  |  |  | MatchProperties
 |  |  |  | ObjectContext
 |  |  |  | ObjectContextCollection
 |  |  |  | ObjectContextCollectionEnumerator
 |  |  |  | ObjectContextManager
 |  |  |  | ObjectIterator
 |  |  |  | PlotStyle
 |  |  |  | PlotStyleTable
 |  |  |  | PointRef
 |  |  |  | Transaction
 |  |  |  | TransactionManager
 |  |  |  | UnderlayHost
 |  |  |  | CommonDraw
 |  |  |  | Context
 |  |  |  | DisplayStyle
 |  |  |  | Drawable
 |  |  |  | DrawableTraits
 |  |  |  | EdgeStyle
 |  |  |  | FaceStyle
 |  |  |  | Geometry
 |  |  |  | GIRasterImage
 |  |  |  | LightAttenuation
 |  |  |  | Mapper
 |  |  |  | ShadowParameters
 |  |  |  | TextStyle
 |  |  |  | Variant
 |  |  |  | Viewport
 |  |  |  | VisualStyle
 |  |  |  | Device
 |  |  |  | Model
 |  |  |  | LayerFilter
 |  |  |  | DsdData
 |  |  |  | DsdEntry
 |  |  |  | PlotConfig
 |  |  |  | PlotInfo
 |  |  |  | PlotInfoValidator
 |  |  |  | PlotPageInfo
 |  |  |  | Dwf3dNavigationTreeNode
 |  |  |  | Dictionary
 |  |  |  | DictionaryIterator
 |  |  |  | DynamicLinker
 |  |  |  | RXClass


RXObject Constructor (unmanagedPointer, autoDelete)

RXObject Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »RXObject(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected RXObject(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
RXObject(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


Clone Method

Clone Method
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »Clone()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »CompareTo(Object)
Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    Object obj
)
Public Function CompareTo ( _
    obj As Object _
) As Integer
public:
int CompareTo(
    Object^ obj
)
Parameters
obj(Object)


CopyFrom Method (source)

CopyFrom Method (source)
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »CopyFrom(RXObject)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CopyFrom(
    RXObject source
)
Public Overridable Sub CopyFrom ( _
    source As RXObject _
)
public:
virtual void CopyFrom(
    RXObject^ source
)
Parameters
source(RXObject)


Create Method (unmanagedPointer, autoDelete)

Create Method (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »Create(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static RXObject Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Public Shared Function Create ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
) As RXObject
public:
static RXObject^ Create(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override


GetClass Method (type)

GetClass Method (type)
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »GetClass(Type)
Declaration Syntax
C# Visual Basic Visual C++
public static RXClass GetClass(
    Type type
)
Public Shared Function GetClass ( _
    type As Type _
) As RXClass
public:
static RXClass^ GetClass(
    Type^ type
)
Parameters
type(Type)


GetRXClass Method

GetRXClass Method
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »GetRXClass()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RXClass GetRXClass()
Public Function GetRXClass As RXClass
public:
RXClass^ GetRXClass()


QueryX Method (protocolClass)

QueryX Method (protocolClass)
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »QueryX(RXClass)
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr QueryX(
    RXClass protocolClass
)
Public Function QueryX ( _
    protocolClass As RXClass _
) As IntPtr
public:
IntPtr QueryX(
    RXClass^ protocolClass
)
Parameters
protocolClass(RXClass)


X Method (protocolClass)

X Method (protocolClass)
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »X(RXClass)
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr X(
    RXClass protocolClass
)
Public Function X ( _
    protocolClass As RXClass _
) As IntPtr
public:
IntPtr X(
    RXClass^ protocolClass
)
Parameters
protocolClass(RXClass)


SecuredApplicationAttribute Class

SecuredApplicationAttribute Class
Namespaces »ZwSoft.ZwCAD.Runtime »SecuredApplicationAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = false,
    Inherited = false)]
public sealed class SecuredApplicationAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple := False,  _
    Inherited := False)> _
Public NotInheritable Class SecuredApplicationAttribute _
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple = false,
    Inherited = false)]
public ref class SecuredApplicationAttribute sealed : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecuredApplicationAttribute(String, String, String, String) |
 | ClientPublicKey |
 | ClientSignature |
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | License |
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OurSignature |
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | SecuredApplicationAttribute


SecuredApplicationAttribute Constructor (license, ourSignature, clientSignature, clientPublicKey)

SecuredApplicationAttribute Constructor (license, ourSignature, clientSignature, clientPublicKey)
Namespaces »ZwSoft.ZwCAD.Runtime »SecuredApplicationAttribute »SecuredApplicationAttribute(String, String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public SecuredApplicationAttribute(
    string license,
    string ourSignature,
    string clientSignature,
    string clientPublicKey
)
Public Sub New ( _
    license As String, _
    ourSignature As String, _
    clientSignature As String, _
    clientPublicKey As String _
)
public:
SecuredApplicationAttribute(
    String^ license,
    String^ ourSignature,
    String^ clientSignature,
    String^ clientPublicKey
)
Parameters
license(String)
ourSignature(String)
clientSignature(String)
clientPublicKey(String)


ClientPublicKey Property

ClientPublicKey Property
Namespaces »ZwSoft.ZwCAD.Runtime »SecuredApplicationAttribute »ClientPublicKey
Declaration Syntax
C# Visual Basic Visual C++
public string ClientPublicKey { get; }
Public ReadOnly Property ClientPublicKey As String
    Get
public:
property String^ ClientPublicKey {
    String^ get ();
}


ClientSignature Property

ClientSignature Property
Namespaces »ZwSoft.ZwCAD.Runtime »SecuredApplicationAttribute »ClientSignature
Declaration Syntax
C# Visual Basic Visual C++
public string ClientSignature { get; }
Public ReadOnly Property ClientSignature As String
    Get
public:
property String^ ClientSignature {
    String^ get ();
}


License Property

License Property
Namespaces »ZwSoft.ZwCAD.Runtime »SecuredApplicationAttribute »License
Declaration Syntax
C# Visual Basic Visual C++
public string License { get; }
Public ReadOnly Property License As String
    Get
public:
property String^ License {
    String^ get ();
}


OurSignature Property

OurSignature Property
Namespaces »ZwSoft.ZwCAD.Runtime »SecuredApplicationAttribute »OurSignature
Declaration Syntax
C# Visual Basic Visual C++
public string OurSignature { get; }
Public ReadOnly Property OurSignature As String
    Get
public:
property String^ OurSignature {
    String^ get ();
}


SystemObjects Class

SystemObjects Class
Namespaces »ZwSoft.ZwCAD.Runtime »SystemObjects
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SystemObjects
Public NotInheritable Class SystemObjects
public ref class SystemObjects sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClassDictionary |
 | DynamicLinker |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ServiceDictionary |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SystemObjects


ClassDictionary Property

ClassDictionary Property
Namespaces »ZwSoft.ZwCAD.Runtime »SystemObjects »ClassDictionary
Declaration Syntax
C# Visual Basic Visual C++
public static Dictionary ClassDictionary { get; }
Public Shared ReadOnly Property ClassDictionary As Dictionary
    Get
public:
static property Dictionary^ ClassDictionary {
    Dictionary^ get ();
}


DynamicLinker Property

DynamicLinker Property
Namespaces »ZwSoft.ZwCAD.Runtime »SystemObjects »DynamicLinker
Declaration Syntax
C# Visual Basic Visual C++
public static DynamicLinker DynamicLinker { get; }
Public Shared ReadOnly Property DynamicLinker As DynamicLinker
    Get
public:
static property DynamicLinker^ DynamicLinker {
    DynamicLinker^ get ();
}


ServiceDictionary Property

ServiceDictionary Property
Namespaces »ZwSoft.ZwCAD.Runtime »SystemObjects »ServiceDictionary
Declaration Syntax
C# Visual Basic Visual C++
public static Dictionary ServiceDictionary { get; }
Public Shared ReadOnly Property ServiceDictionary As Dictionary
    Get
public:
static property Dictionary^ ServiceDictionary {
    Dictionary^ get ();
}


WrapperAttribute Class

WrapperAttribute Class
Namespaces »ZwSoft.ZwCAD.Runtime »WrapperAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Struct|AttributeTargets.Enum, AllowMultiple = false,
    Inherited = true)]
public sealed class WrapperAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Struct Or AttributeTargets.Enum, AllowMultiple := False,  _
    Inherited := True)> _
Public NotInheritable Class WrapperAttribute _
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Struct|AttributeTargets::Enum, AllowMultiple = false,
    Inherited = true)]
public ref class WrapperAttribute sealed : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WrapperAttribute(String) |
 | Equals(Object) | (Inherited from Attribute.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
 | WrappedClass |
Inheritance Hierarchy
Object
 | Attribute
 |  | WrapperAttribute


WrapperAttribute Constructor (wrappedClass)

WrapperAttribute Constructor (wrappedClass)
Namespaces »ZwSoft.ZwCAD.Runtime »WrapperAttribute »WrapperAttribute(String)
Declaration Syntax
C# Visual Basic Visual C++
public WrapperAttribute(
    string wrappedClass
)
Public Sub New ( _
    wrappedClass As String _
)
public:
WrapperAttribute(
    String^ wrappedClass
)
Parameters
wrappedClass(String)


WrappedClass Property

WrappedClass Property
Namespaces »ZwSoft.ZwCAD.Runtime »WrapperAttribute »WrappedClass
Declaration Syntax
C# Visual Basic Visual C++
public string WrappedClass { get; set; }
Public Property WrappedClass As String
    Get
    Set
public:
property String^ WrappedClass {
    String^ get ();
    void set (String^ value);
}


ZwSoft.ZwCAD.Windows Namespace

ZwSoft.ZwCAD.Windows Namespace
Namespaces »ZwSoft.ZwCAD.Windows
Declaration Syntax
C# Visual Basic Visual C++
namespace ZwSoft.ZwCAD.Windows
Namespace ZwSoft.ZwCAD.Windows
namespace ZwSoft.ZwCAD.Windows
Types
All Types Classes Enumerations Delegates
Icon | Type | Description
 | ColorDialog |
 | ColorDialog..::..ColorTabs |
 | ContextMenuExtension |
 | DefaultPane |
 | DockSides |
 | DropTarget |
 | IconType |
 | LinetypeDialog |
 | LineWeightDialog |
 | Menu |
 | MenuItem |
 | MenuItemCollection |
 | OpenFileDialog |
 | OpenFileDialog..::..OpenFileDialogFlags |
 | OpenFileDialogFlags |
 | Palette |
 | PaletteActivatedEventArgs |
 | PaletteActivatedEventHandler |
 | PaletteAddContextMenuEventArgs |
 | PaletteAddContextMenuEventHandler |
 | PalettePersistEventArgs |
 | PalettePersistEventHandler |
 | PaletteSet |
 | PaletteSetDestroyEventHandler |
 | PaletteSetHelpEventArgs |
 | PaletteSetHelpEventHandler |
 | PaletteSetMoveEventArgs |
 | PaletteSetMoveEventHandler |
 | PaletteSetShowDockBarEventHandler |
 | PaletteSetSizeEventArgs |
 | PaletteSetSizeEventHandler |
 | PaletteSetStateEventArgs |
 | PaletteSetStateEventHandler |
 | PaletteSetStyles |
 | PaletteSetTitleBarLocation |
 | PaletteSetTitleBarLocationChangeEventHandler |
 | PaletteShowDockBarEventArgs |
 | Pane |
 | PaneCollection |
 | PaneStyles |
 | PlotStyleDialog |
 | SaveFileDialog |
 | SaveFileDialog..::..SaveFileDialogFlags |
 | SaveFileDialogFlags |
 | Window..::..State |
 | StateEventIndex |
 | StatusBar |
 | StatusBarItem |
 | StatusBarMouseDownEventArgs |
 | StatusBarMouseDownEventHandler |
 | TrayItem |
 | TrayItemCollection |
 | Visuals |
 | Window |


ColorDialog Class

ColorDialog Class
Namespaces »ZwSoft.ZwCAD.Windows »ColorDialog
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ColorDialog
Public NotInheritable Class ColorDialog
public ref class ColorDialog sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ColorDialog()()()() |
 | Color |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeByBlockByLayer |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SetDialogTabs(ColorDialog..::..ColorTabs) |
 | ShowDialog()()()() |
 | ShowModal()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ColorDialog

Assembly: ZwManaged (Module: ZwManaged)


ColorDialog Constructor

ColorDialog Constructor
Namespaces »ZwSoft.ZwCAD.Windows »ColorDialog »ColorDialog()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ColorDialog()
Public Sub New
public:
ColorDialog()

Assembly: ZwManaged (Module: ZwManaged)


Color Property

Color Property
Namespaces »ZwSoft.ZwCAD.Windows »ColorDialog »Color
Declaration Syntax
C# Visual Basic Visual C++
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


IncludeByBlockByLayer Property

IncludeByBlockByLayer Property
Namespaces »ZwSoft.ZwCAD.Windows »ColorDialog »IncludeByBlockByLayer
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeByBlockByLayer { get; set; }
Public Property IncludeByBlockByLayer As Boolean
    Get
    Set
public:
property bool IncludeByBlockByLayer {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


SetDialogTabs Method (value)

SetDialogTabs Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »ColorDialog »SetDialogTabs(ColorDialog..::..ColorTabs)
Declaration Syntax
C# Visual Basic Visual C++
public void SetDialogTabs(
    ColorDialog..::..ColorTabs value
)
Public Sub SetDialogTabs ( _
    value As ColorDialog..::..ColorTabs _
)
public:
void SetDialogTabs(
    ColorDialog..::..ColorTabs value
)
Parameters
value(ColorDialog..::..ColorTabs)

Assembly: ZwManaged (Module: ZwManaged)


ShowDialog Method

ShowDialog Method
Namespaces »ZwSoft.ZwCAD.Windows »ColorDialog »ShowDialog()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DialogResult ShowDialog()
Public Function ShowDialog As DialogResult
public:
DialogResult ShowDialog()

Assembly: ZwManaged (Module: ZwManaged)


ShowModal Method

ShowModal Method
Namespaces »ZwSoft.ZwCAD.Windows »ColorDialog »ShowModal()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<bool> ShowModal()
Public Function ShowModal As Nullable(Of Boolean)
public:
Nullable<bool> ShowModal()

Assembly: ZwManaged (Module: ZwManaged)


ColorDialog.ColorTabs Enumeration

ColorDialog..::..ColorTabs Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »ColorDialog »ColorDialog..::..ColorTabs
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum ColorTabs
<FlagsAttribute> _
Public Enumeration ColorTabs
[FlagsAttribute]
public enum class ColorTabs
Members
Member | Description
ColorBookTab |
TrueColorTab |
ACITab |

Assembly: ZwManaged (Module: ZwManaged)


ContextMenuExtension Class

ContextMenuExtension Class
Namespaces »ZwSoft.ZwCAD.Windows »ContextMenuExtension
Declaration Syntax
C# Visual Basic Visual C++
public class ContextMenuExtension : Menu,
    IDisposable
Public Class ContextMenuExtension _
    Inherits Menu _
    Implements IDisposable
public ref class ContextMenuExtension : public Menu,
    IDisposable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextMenuExtension()()()() |
 | Dispose(Boolean) |
 | Dispose()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MenuItems | (Inherited from Menu.)
 | Popup |
 | Title |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | Menu
 |  | ContextMenuExtension

Assembly: ZwManaged (Module: ZwManaged)


ContextMenuExtension Constructor

ContextMenuExtension Constructor
Namespaces »ZwSoft.ZwCAD.Windows »ContextMenuExtension »ContextMenuExtension()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ContextMenuExtension()
Public Sub New
public:
ContextMenuExtension()

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Windows »ContextMenuExtension »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Windows »ContextMenuExtension »Dispose()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method ()

Dispose Method ()
Namespaces »ZwSoft.ZwCAD.Windows »ContextMenuExtension »Dispose(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool
)
Protected Overridable Sub Dispose ( _
     As Boolean _
)
protected:
virtual void Dispose(
    bool
)
Parameters
(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


Popup Event

Popup Event
Namespaces »ZwSoft.ZwCAD.Windows »ContextMenuExtension »Popup
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Popup
Public Event Popup As EventHandler
public:
 event EventHandler^ Popup {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Title Property

Title Property
Namespaces »ZwSoft.ZwCAD.Windows »ContextMenuExtension »Title
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DefaultPane Enumeration

DefaultPane Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »DefaultPane
Declaration Syntax
C# Visual Basic Visual C++
public enum DefaultPane
Public Enumeration DefaultPane
public enum class DefaultPane
Members
Member | Description
Float |
LayoutMoreIcon |
LayoutIcon |
ModelIcon |
LayoutModelIcons |
DynamicUcs |
Paper |
PaperModel |
ViewportMaximizeNext |
ViewportMaximize |
ViewportMaximizePrevious |
Spacer |
DynamicInput |
ObjectTrack |
ObjectSnap |
Polar |
Ortho |
Snap |
CursorCoordinates |
ModeMacro |
All |
Model |
LineWeight |
Table |
Grid |

Assembly: ZwManaged (Module: ZwManaged)


DockSides Enumeration

DockSides Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »DockSides
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum DockSides
<FlagsAttribute> _
Public Enumeration DockSides
[FlagsAttribute]
public enum class DockSides
Members
Member | Description
None |
Bottom |
Right |
Top |
Left |

Assembly: ZwManaged (Module: ZwManaged)


DropTarget Class

DropTarget Class
Namespaces »ZwSoft.ZwCAD.Windows »DropTarget
Declaration Syntax
C# Visual Basic Visual C++
public abstract class DropTarget
Public MustInherit Class DropTarget
public ref class DropTarget abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DropTarget()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnDragEnter(DragEventArgs) |
 | OnDragLeave()()()() |
 | OnDragOver(DragEventArgs) |
 | OnDrop(DragEventArgs) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
DropTarget

Assembly: ZwManaged (Module: ZwManaged)


DropTarget Constructor

DropTarget Constructor
Namespaces »ZwSoft.ZwCAD.Windows »DropTarget »DropTarget()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected DropTarget()
Protected Sub New
protected:
DropTarget()

Assembly: ZwManaged (Module: ZwManaged)


OnDragEnter Method (e)

OnDragEnter Method (e)
Namespaces »ZwSoft.ZwCAD.Windows »DropTarget »OnDragEnter(DragEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OnDragEnter(
    DragEventArgs e
)
Public Overridable Sub OnDragEnter ( _
    e As DragEventArgs _
)
public:
virtual void OnDragEnter(
    DragEventArgs^ e
)
Parameters
e(DragEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


OnDragLeave Method

OnDragLeave Method
Namespaces »ZwSoft.ZwCAD.Windows »DropTarget »OnDragLeave()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OnDragLeave()
Public Overridable Sub OnDragLeave
public:
virtual void OnDragLeave()

Assembly: ZwManaged (Module: ZwManaged)


OnDragOver Method (e)

OnDragOver Method (e)
Namespaces »ZwSoft.ZwCAD.Windows »DropTarget »OnDragOver(DragEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void OnDragOver(
    DragEventArgs e
)
Public Overridable Sub OnDragOver ( _
    e As DragEventArgs _
)
public:
virtual void OnDragOver(
    DragEventArgs^ e
)
Parameters
e(DragEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


OnDrop Method (e)

OnDrop Method (e)
Namespaces »ZwSoft.ZwCAD.Windows »DropTarget »OnDrop(DragEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void OnDrop(
    DragEventArgs e
)
Public MustOverride Sub OnDrop ( _
    e As DragEventArgs _
)
public:
virtual void OnDrop(
    DragEventArgs^ e
) abstract
Parameters
e(DragEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


IconType Enumeration

IconType Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »IconType
Declaration Syntax
C# Visual Basic Visual C++
public enum IconType
Public Enumeration IconType
public enum class IconType
Members
Member | Description
None |
Information |
Critical |
Warning |

Assembly: ZwManaged (Module: ZwManaged)


LinetypeDialog Class

LinetypeDialog Class
Namespaces »ZwSoft.ZwCAD.Windows »LinetypeDialog
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LinetypeDialog
Public NotInheritable Class LinetypeDialog
public ref class LinetypeDialog sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinetypeDialog()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeByBlockByLayer |
 | Linetype |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShowDialog()()()() |
 | ShowModal()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LinetypeDialog

Assembly: ZwManaged (Module: ZwManaged)


LinetypeDialog Constructor

LinetypeDialog Constructor
Namespaces »ZwSoft.ZwCAD.Windows »LinetypeDialog »LinetypeDialog()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LinetypeDialog()
Public Sub New
public:
LinetypeDialog()

Assembly: ZwManaged (Module: ZwManaged)


IncludeByBlockByLayer Property

IncludeByBlockByLayer Property
Namespaces »ZwSoft.ZwCAD.Windows »LinetypeDialog »IncludeByBlockByLayer
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeByBlockByLayer { get; set; }
Public Property IncludeByBlockByLayer As Boolean
    Get
    Set
public:
property bool IncludeByBlockByLayer {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


Linetype Property

Linetype Property
Namespaces »ZwSoft.ZwCAD.Windows »LinetypeDialog »Linetype
Declaration Syntax
C# Visual Basic Visual C++
public ObjectId Linetype { get; set; }
Public Property Linetype As ObjectId
    Get
    Set
public:
property ObjectId Linetype {
    ObjectId get ();
    void set (ObjectId value);
}

Assembly: ZwManaged (Module: ZwManaged)


ShowDialog Method

ShowDialog Method
Namespaces »ZwSoft.ZwCAD.Windows »LinetypeDialog »ShowDialog()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DialogResult ShowDialog()
Public Function ShowDialog As DialogResult
public:
DialogResult ShowDialog()

Assembly: ZwManaged (Module: ZwManaged)


ShowModal Method

ShowModal Method
Namespaces »ZwSoft.ZwCAD.Windows »LinetypeDialog »ShowModal()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowModal()
Public Function ShowModal As Boolean
public:
bool ShowModal()

Assembly: ZwManaged (Module: ZwManaged)


LineWeightDialog Class

LineWeightDialog Class
Namespaces »ZwSoft.ZwCAD.Windows »LineWeightDialog
Declaration Syntax
C# Visual Basic Visual C++
public sealed class LineWeightDialog
Public NotInheritable Class LineWeightDialog
public ref class LineWeightDialog sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LineWeightDialog()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeByBlockByLayer |
 | LineWeight |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShowDialog()()()() |
 | ShowModal()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LineWeightDialog

Assembly: ZwManaged (Module: ZwManaged)


LineWeightDialog Constructor

LineWeightDialog Constructor
Namespaces »ZwSoft.ZwCAD.Windows »LineWeightDialog »LineWeightDialog()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LineWeightDialog()
Public Sub New
public:
LineWeightDialog()

Assembly: ZwManaged (Module: ZwManaged)


IncludeByBlockByLayer Property

IncludeByBlockByLayer Property
Namespaces »ZwSoft.ZwCAD.Windows »LineWeightDialog »IncludeByBlockByLayer
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeByBlockByLayer { get; set; }
Public Property IncludeByBlockByLayer As Boolean
    Get
    Set
public:
property bool IncludeByBlockByLayer {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


LineWeight Property

LineWeight Property
Namespaces »ZwSoft.ZwCAD.Windows »LineWeightDialog »LineWeight
Declaration Syntax
C# Visual Basic Visual C++
public LineWeight LineWeight { get; set; }
Public Property LineWeight As LineWeight
    Get
    Set
public:
property LineWeight LineWeight {
    LineWeight get ();
    void set (LineWeight value);
}

Assembly: ZwManaged (Module: ZwManaged)


ShowDialog Method

ShowDialog Method
Namespaces »ZwSoft.ZwCAD.Windows »LineWeightDialog »ShowDialog()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DialogResult ShowDialog()
Public Function ShowDialog As DialogResult
public:
DialogResult ShowDialog()

Assembly: ZwManaged (Module: ZwManaged)


ShowModal Method

ShowModal Method
Namespaces »ZwSoft.ZwCAD.Windows »LineWeightDialog »ShowModal()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowModal()
Public Function ShowModal As Boolean
public:
bool ShowModal()

Assembly: ZwManaged (Module: ZwManaged)


Menu Class

Menu Class
Namespaces »ZwSoft.ZwCAD.Windows »Menu
Declaration Syntax
C# Visual Basic Visual C++
public abstract class Menu
Public MustInherit Class Menu
public ref class Menu abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Menu()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MenuItems |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | Menu
 |  | ContextMenuExtension
 |  | MenuItem

Assembly: ZwManaged (Module: ZwManaged)


Menu Constructor

Menu Constructor
Namespaces »ZwSoft.ZwCAD.Windows »Menu »Menu()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected Menu()
Protected Sub New
protected:
Menu()

Assembly: ZwManaged (Module: ZwManaged)


MenuItems Property

MenuItems Property
Namespaces »ZwSoft.ZwCAD.Windows »Menu »MenuItems
Declaration Syntax
C# Visual Basic Visual C++
public MenuItemCollection MenuItems { get; }
Public ReadOnly Property MenuItems As MenuItemCollection
    Get
public:
property MenuItemCollection^ MenuItems {
    MenuItemCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


MenuItem Class

MenuItem Class
Namespaces »ZwSoft.ZwCAD.Windows »MenuItem
Declaration Syntax
C# Visual Basic Visual C++
public class MenuItem : Menu
Public Class MenuItem _
    Inherits Menu
public ref class MenuItem : public Menu
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MenuItem(String, Icon) |
 | MenuItem(String) |
 | Checked |
 | Click |
 | Enabled |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Icon |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MenuItems | (Inherited from Menu.)
 | Text |
 | ToString()()()() | (Inherited from Object.)
 | Visible |
Inheritance Hierarchy
Object
 | Menu
 |  | MenuItem

Assembly: ZwManaged (Module: ZwManaged)


MenuItem Constructor

MenuItem Constructor
Namespaces »ZwSoft.ZwCAD.Windows »MenuItem »MenuItem()()()()
Members
Icon | Member | Description
 | MenuItem(String, Icon) |
 | MenuItem(String) |

Assembly: ZwManaged (Module: ZwManaged)


MenuItem Constructor (value)

MenuItem Constructor (value)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItem »MenuItem(String)
Declaration Syntax
C# Visual Basic Visual C++
public MenuItem(
    string value
)
Public Sub New ( _
    value As String _
)
public:
MenuItem(
    String^ value
)
Parameters
value(String)

Assembly: ZwManaged (Module: ZwManaged)


MenuItem Constructor (value, icon)

MenuItem Constructor (value, icon)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItem »MenuItem(String, Icon)
Declaration Syntax
C# Visual Basic Visual C++
public MenuItem(
    string value,
    Icon icon
)
Public Sub New ( _
    value As String, _
    icon As Icon _
)
public:
MenuItem(
    String^ value,
    Icon^ icon
)
Parameters
value(String)
icon(Icon)

Assembly: ZwManaged (Module: ZwManaged)


Checked Property

Checked Property
Namespaces »ZwSoft.ZwCAD.Windows »MenuItem »Checked
Declaration Syntax
C# Visual Basic Visual C++
public bool Checked { get; set; }
Public Property Checked As Boolean
    Get
    Set
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


Click Event

Click Event
Namespaces »ZwSoft.ZwCAD.Windows »MenuItem »Click
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Click
Public Event Click As EventHandler
public:
 event EventHandler^ Click {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Enabled Property

Enabled Property
Namespaces »ZwSoft.ZwCAD.Windows »MenuItem »Enabled
Declaration Syntax
C# Visual Basic Visual C++
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


Icon Property

Icon Property
Namespaces »ZwSoft.ZwCAD.Windows »MenuItem »Icon
Declaration Syntax
C# Visual Basic Visual C++
public Icon Icon { get; set; }
Public Property Icon As Icon
    Get
    Set
public:
property Icon^ Icon {
    Icon^ get ();
    void set (Icon^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Text Property

Text Property
Namespaces »ZwSoft.ZwCAD.Windows »MenuItem »Text
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Visible Property

Visible Property
Namespaces »ZwSoft.ZwCAD.Windows »MenuItem »Visible
Declaration Syntax
C# Visual Basic Visual C++
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


MenuItemCollection Class

MenuItemCollection Class
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class MenuItemCollection : IList
Public NotInheritable Class MenuItemCollection _
    Implements IList
public ref class MenuItemCollection sealed : IList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MenuItemCollection(Menu) |
 | Add(MenuItem) |
 | Clear()()()() |
 | Contains(MenuItem) |
 | CopyTo(array<MenuItem>[]()[][], Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(MenuItem) |
 | Insert(Int32, MenuItem) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(MenuItem) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
MenuItemCollection

Assembly: ZwManaged (Module: ZwManaged)


MenuItemCollection Constructor (owner)

MenuItemCollection Constructor (owner)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »MenuItemCollection(Menu)
Declaration Syntax
C# Visual Basic Visual C++
public MenuItemCollection(
    Menu owner
)
Public Sub New ( _
    owner As Menu _
)
public:
MenuItemCollection(
    Menu^ owner
)
Parameters
owner(Menu)

Assembly: ZwManaged (Module: ZwManaged)


Add Method (p)

Add Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »Add(MenuItem)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MenuItem p
)
Public Function Add ( _
    p As MenuItem _
) As Integer
public:
int Add(
    MenuItem^ p
)
Parameters
p(MenuItem)

Assembly: ZwManaged (Module: ZwManaged)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Assembly: ZwManaged (Module: ZwManaged)


Contains Method (p)

Contains Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »Contains(MenuItem)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MenuItem p
)
Public Function Contains ( _
    p As MenuItem _
) As Boolean
public:
bool Contains(
    MenuItem^ p
)
Parameters
p(MenuItem)

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (a, index)

CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »CopyTo(array<MenuItem>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MenuItem[] a,
    int index
)
Public Sub CopyTo ( _
    a As MenuItem(), _
    index As Integer _
)
public:
void CopyTo(
    array<MenuItem^>^ a,
    int index
)
Parameters
a(array< MenuItem >[]()[][])
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed

Assembly: ZwManaged (Module: ZwManaged)


ICollection_CopyTo Method (a, index)

ICollection_CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array a,
    int index
)
Private Sub ICollection_CopyTo ( _
    a As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ a,
    int index
) sealed = ICollection::CopyTo
Parameters
a(Array)
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IList_IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IList_IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IList_Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IList_Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IndexOf Method (p)

IndexOf Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »IndexOf(MenuItem)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MenuItem p
)
Public Function IndexOf ( _
    p As MenuItem _
) As Integer
public:
int IndexOf(
    MenuItem^ p
)
Parameters
p(MenuItem)

Assembly: ZwManaged (Module: ZwManaged)


Insert Method (index, p)

Insert Method (index, p)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »Insert(Int32, MenuItem)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MenuItem p
)
Public Sub Insert ( _
    index As Integer, _
    p As MenuItem _
)
public:
void Insert(
    int index,
    MenuItem^ p
)
Parameters
index(Int32)
p(MenuItem)

Assembly: ZwManaged (Module: ZwManaged)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MenuItem this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MenuItem
    Get
    Set
public:
property MenuItem^ default[int index] {
    MenuItem^ get (int index);
    void set (int index, MenuItem^ value);
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »Remove(MenuItem)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MenuItem value
)
Public Sub Remove ( _
    value As MenuItem _
)
public:
void Remove(
    MenuItem^ value
)
Parameters
value(MenuItem)

Assembly: ZwManaged (Module: ZwManaged)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Windows »MenuItemCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


OpenFileDialog Class

OpenFileDialog Class
Namespaces »ZwSoft.ZwCAD.Windows »OpenFileDialog
Declaration Syntax
C# Visual Basic Visual C++
public sealed class OpenFileDialog
Public NotInheritable Class OpenFileDialog
public ref class OpenFileDialog sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenFileDialog(String, String, String, String, OpenFileDialog..::..OpenFileDialogFlags) |
 | Equals(Object) | (Inherited from Object.)
 | Filename |
 | Finalize()()()() | (Inherited from Object.)
 | GetFilenames()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShowDialog()()()() |
 | ShowModal()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
OpenFileDialog

Assembly: ZwManaged (Module: ZwManaged)


OpenFileDialog Constructor (title, defaultName, extension, dialogName, flags)

OpenFileDialog Constructor (title, defaultName, extension, dialogName, flags)
Namespaces »ZwSoft.ZwCAD.Windows »OpenFileDialog »OpenFileDialog(String, String, String, String, OpenFileDialog..::..OpenFileDialogFlags)
Declaration Syntax
C# Visual Basic Visual C++
public OpenFileDialog(
    string title,
    string defaultName,
    string extension,
    string dialogName,
    OpenFileDialog..::..OpenFileDialogFlags flags
)
Public Sub New ( _
    title As String, _
    defaultName As String, _
    extension As String, _
    dialogName As String, _
    flags As OpenFileDialog..::..OpenFileDialogFlags _
)
public:
OpenFileDialog(
    String^ title,
    String^ defaultName,
    String^ extension,
    String^ dialogName,
    OpenFileDialog..::..OpenFileDialogFlags flags
)
Parameters
title(String)
defaultName(String)
extension(String)
dialogName(String)
flags(OpenFileDialog..::..OpenFileDialogFlags)

Assembly: ZwManaged (Module: ZwManaged)


Filename Property

Filename Property
Namespaces »ZwSoft.ZwCAD.Windows »OpenFileDialog »Filename
Declaration Syntax
C# Visual Basic Visual C++
public string Filename { get; }
Public ReadOnly Property Filename As String
    Get
public:
property String^ Filename {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GetFilenames Method

GetFilenames Method
Namespaces »ZwSoft.ZwCAD.Windows »OpenFileDialog »GetFilenames()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string[] GetFilenames()
Public Function GetFilenames As String()
public:
array<String^>^ GetFilenames()

Assembly: ZwManaged (Module: ZwManaged)


ShowDialog Method

ShowDialog Method
Namespaces »ZwSoft.ZwCAD.Windows »OpenFileDialog »ShowDialog()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DialogResult ShowDialog()
Public Function ShowDialog As DialogResult
public:
DialogResult ShowDialog()

Assembly: ZwManaged (Module: ZwManaged)


ShowModal Method

ShowModal Method
Namespaces »ZwSoft.ZwCAD.Windows »OpenFileDialog »ShowModal()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowModal()
Public Function ShowModal As Boolean
public:
bool ShowModal()

Assembly: ZwManaged (Module: ZwManaged)


OpenFileDialog.OpenFileDialogFlags Enumeration

OpenFileDialog..::..OpenFileDialogFlags Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »OpenFileDialog »OpenFileDialog..::..OpenFileDialogFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum OpenFileDialogFlags
<FlagsAttribute> _
Public Enumeration OpenFileDialogFlags
[FlagsAttribute]
public enum class OpenFileDialogFlags
Members
Member | Description
AllowFoldersOnly |
NoShellExtensions |
NoFtpSites |
ForceDefaultFolder |
NoUrls |
DoNotTransferRemoteFiles |
DefaultIsFolder |
AllowAnyExtension |
SearchPathW |
AllowMultiple |

Assembly: ZwManaged (Module: ZwManaged)


OpenFileDialogFlags Enumeration

OpenFileDialogFlags Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »OpenFileDialogFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum OpenFileDialogFlags
<FlagsAttribute> _
Public Enumeration OpenFileDialogFlags
[FlagsAttribute]
public enum class OpenFileDialogFlags
Members
Member | Description
AllowFoldersOnly |
ForceDefaultFolder |
NoShellExtensions |
NoFtpSites |
DoNotTransferRemoteFiles |
DefaultIsFolder |
AllowAnyExtension |
AllowMultiple |

Assembly: ZwManaged (Module: ZwManaged)


Palette Class

Palette Class
Namespaces »ZwSoft.ZwCAD.Windows »Palette
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AdUiPalette")]
public sealed class Palette
<WrapperAttribute("AdUiPalette")> _
Public NotInheritable Class Palette
[WrapperAttribute(L"AdUiPalette")]
public ref class Palette sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | PaletteSet |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Palette

Assembly: ZwManaged (Module: ZwManaged)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.Windows »Palette »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteSet Property

PaletteSet Property
Namespaces »ZwSoft.ZwCAD.Windows »Palette »PaletteSet
Declaration Syntax
C# Visual Basic Visual C++
public PaletteSet PaletteSet { get; }
Public ReadOnly Property PaletteSet As PaletteSet
    Get
public:
property PaletteSet^ PaletteSet {
    PaletteSet^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteActivatedEventArgs Class

PaletteActivatedEventArgs Class
Namespaces »ZwSoft.ZwCAD.Windows »PaletteActivatedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PaletteActivatedEventArgs : EventArgs
Public NotInheritable Class PaletteActivatedEventArgs _
    Inherits EventArgs
public ref class PaletteActivatedEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaletteActivatedEventArgs(Palette, Palette) |
 | Activated |
 | Deactivated |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PaletteActivatedEventArgs

Assembly: ZwManaged (Module: ZwManaged)


PaletteActivatedEventArgs Constructor (activated, deactivated)

PaletteActivatedEventArgs Constructor (activated, deactivated)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteActivatedEventArgs »PaletteActivatedEventArgs(Palette, Palette)
Declaration Syntax
C# Visual Basic Visual C++
public PaletteActivatedEventArgs(
    Palette activated,
    Palette deactivated
)
Public Sub New ( _
    activated As Palette, _
    deactivated As Palette _
)
public:
PaletteActivatedEventArgs(
    Palette^ activated,
    Palette^ deactivated
)
Parameters
activated(Palette)
deactivated(Palette)

Assembly: ZwManaged (Module: ZwManaged)


Activated Property

Activated Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteActivatedEventArgs »Activated
Declaration Syntax
C# Visual Basic Visual C++
public Palette Activated { get; }
Public ReadOnly Property Activated As Palette
    Get
public:
property Palette^ Activated {
    Palette^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Deactivated Property

Deactivated Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteActivatedEventArgs »Deactivated
Declaration Syntax
C# Visual Basic Visual C++
public Palette Deactivated { get; }
Public ReadOnly Property Deactivated As Palette
    Get
public:
property Palette^ Deactivated {
    Palette^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteActivatedEventHandler Delegate

PaletteActivatedEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »PaletteActivatedEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PaletteActivatedEventHandler(
    Object sender,
    PaletteActivatedEventArgs e
)
Public Delegate Sub PaletteActivatedEventHandler ( _
    sender As Object, _
    e As PaletteActivatedEventArgs _
)
public delegate void PaletteActivatedEventHandler(
    Object^ sender,
    PaletteActivatedEventArgs^ e
)
Parameters
sender(Object)
e(PaletteActivatedEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PaletteAddContextMenuEventArgs Class

PaletteAddContextMenuEventArgs Class
Namespaces »ZwSoft.ZwCAD.Windows »PaletteAddContextMenuEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PaletteAddContextMenuEventArgs : EventArgs
Public NotInheritable Class PaletteAddContextMenuEventArgs _
    Inherits EventArgs
public ref class PaletteAddContextMenuEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaletteAddContextMenuEventArgs(List<(Of <<'(MenuItem>)>>), List<(Of <<'(Int32>)>>), Int32, Int32) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HitFlag |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Menuitems |
 | RemoveMenuItems |
 | RightClkTab |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PaletteAddContextMenuEventArgs

Assembly: ZwManaged (Module: ZwManaged)


PaletteAddContextMenuEventArgs Constructor (menuitems, removeMenuItems, nHitFlag, nRightClkTab)

PaletteAddContextMenuEventArgs Constructor (menuitems, removeMenuItems, nHitFlag, nRightClkTab)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteAddContextMenuEventArgs »PaletteAddContextMenuEventArgs(List<(Of <<'(MenuItem>)>>), List<(Of <<'(Int32>)>>), Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PaletteAddContextMenuEventArgs(
    List<MenuItem> menuitems,
    List<int> removeMenuItems,
    int nHitFlag,
    int nRightClkTab
)
Public Sub New ( _
    menuitems As List(Of MenuItem), _
    removeMenuItems As List(Of Integer), _
    nHitFlag As Integer, _
    nRightClkTab As Integer _
)
public:
PaletteAddContextMenuEventArgs(
    List<MenuItem^>^ menuitems,
    List<int>^ removeMenuItems,
    int nHitFlag,
    int nRightClkTab
)
Parameters
menuitems(List<(Of <(<' MenuItem >)>)>)
removeMenuItems(List<(Of <(<'Int32>)>)>)
nHitFlag(Int32)
nRightClkTab(Int32)

Assembly: ZwManaged (Module: ZwManaged)


HitFlag Property

HitFlag Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteAddContextMenuEventArgs »HitFlag
Declaration Syntax
C# Visual Basic Visual C++
public int HitFlag { get; }
Public ReadOnly Property HitFlag As Integer
    Get
public:
property int HitFlag {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Menuitems Property

Menuitems Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteAddContextMenuEventArgs »Menuitems
Declaration Syntax
C# Visual Basic Visual C++
public List<MenuItem> Menuitems { get; }
Public ReadOnly Property Menuitems As List(Of MenuItem)
    Get
public:
property List<MenuItem^>^ Menuitems {
    List<MenuItem^>^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


RemoveMenuItems Property

RemoveMenuItems Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteAddContextMenuEventArgs »RemoveMenuItems
Declaration Syntax
C# Visual Basic Visual C++
public List<int> RemoveMenuItems { get; }
Public ReadOnly Property RemoveMenuItems As List(Of Integer)
    Get
public:
property List<int>^ RemoveMenuItems {
    List<int>^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


RightClkTab Property

RightClkTab Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteAddContextMenuEventArgs »RightClkTab
Declaration Syntax
C# Visual Basic Visual C++
public int RightClkTab { get; }
Public ReadOnly Property RightClkTab As Integer
    Get
public:
property int RightClkTab {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteAddContextMenuEventHandler Delegate

PaletteAddContextMenuEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »PaletteAddContextMenuEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PaletteAddContextMenuEventHandler(
    Object sender,
    PaletteAddContextMenuEventArgs e
)
Public Delegate Sub PaletteAddContextMenuEventHandler ( _
    sender As Object, _
    e As PaletteAddContextMenuEventArgs _
)
public delegate void PaletteAddContextMenuEventHandler(
    Object^ sender,
    PaletteAddContextMenuEventArgs^ e
)
Parameters
sender(Object)
e(PaletteAddContextMenuEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PalettePersistEventArgs Class

PalettePersistEventArgs Class
Namespaces »ZwSoft.ZwCAD.Windows »PalettePersistEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PalettePersistEventArgs : EventArgs
Public NotInheritable Class PalettePersistEventArgs _
    Inherits EventArgs
public ref class PalettePersistEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PalettePersistEventArgs(IConfigurationSection) |
 | ConfigurationSection |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PalettePersistEventArgs

Assembly: ZwManaged (Module: ZwManaged)


PalettePersistEventArgs Constructor (configurationSection)

PalettePersistEventArgs Constructor (configurationSection)
Namespaces »ZwSoft.ZwCAD.Windows »PalettePersistEventArgs »PalettePersistEventArgs(IConfigurationSection)
Declaration Syntax
C# Visual Basic Visual C++
public PalettePersistEventArgs(
    IConfigurationSection configurationSection
)
Public Sub New ( _
    configurationSection As IConfigurationSection _
)
public:
PalettePersistEventArgs(
    IConfigurationSection^ configurationSection
)
Parameters
configurationSection(IConfigurationSection)

Assembly: ZwManaged (Module: ZwManaged)


ConfigurationSection Property

ConfigurationSection Property
Namespaces »ZwSoft.ZwCAD.Windows »PalettePersistEventArgs »ConfigurationSection
Declaration Syntax
C# Visual Basic Visual C++
public IConfigurationSection ConfigurationSection { get; }
Public ReadOnly Property ConfigurationSection As IConfigurationSection
    Get
public:
property IConfigurationSection^ ConfigurationSection {
    IConfigurationSection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PalettePersistEventHandler Delegate

PalettePersistEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »PalettePersistEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PalettePersistEventHandler(
    Object sender,
    PalettePersistEventArgs e
)
Public Delegate Sub PalettePersistEventHandler ( _
    sender As Object, _
    e As PalettePersistEventArgs _
)
public delegate void PalettePersistEventHandler(
    Object^ sender,
    PalettePersistEventArgs^ e
)
Parameters
sender(Object)
e(PalettePersistEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PaletteSet Class

PaletteSet Class
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AdUiPaletteSet")]
public class PaletteSet : Window, ICollection
<WrapperAttribute("AdUiPaletteSet")> _
Public Class PaletteSet _
    Inherits Window _
    Implements ICollection
[WrapperAttribute(L"AdUiPaletteSet")]
public ref class PaletteSet : public Window,
    ICollection
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaletteSet(String, String, Guid) |
 | PaletteSet(String, Guid) |
 | PaletteSet(String) |
 | Activate(Int32) |
 | Add(String, Control) |
 | AddVisual(String, Visual) |
 | Anchored |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | AutoRollUp |
 | Close()()()() | (Inherited from Window.)
 | CopyTo(array<Palette>[]()[][], Int32) |
 | Count |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Inherited from Window.)
 | DeviceIndependentLocation | (Inherited from Window.)
 | DeviceIndependentSize | (Inherited from Window.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Dock |
 | DockEnabled |
 | EnableTransparency(Boolean) |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Handle | (Inherited from Window.)
 | Help |
 | ICollection..::..CopyTo(Array, Int32) |
 | Icon | (Inherited from Window.)
 | InitializeFloatingPosition(Rect) |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | ICollection..::..IsSynchronized |
 | Item[([( Int32])]) |
 | KeepFocus |
 | Load |
 | Location | (Overrides Window.Location.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumSize |
 | Name |
 | Opacity |
 | PaletteActivated |
 | PaletteAddContextMenu |
 | PaletteSetDestroy |
 | PaletteSetMoved |
 | PaletteSetShowDockBar |
 | PaletteSetTitleBarLocationChange |
 | PaletteSize |
 | RecalculateDockSiteLayout()()()() |
 | Remove(Int32) |
 | RolledUp |
 | Save |
 | Saving |
 | Size | (Overrides Window.Size.)
 | SizeChanged |
 | StateChanged |
 | Style |
 | ICollection..::..SyncRoot |
 | Text | (Inherited from Window.)
 | TitleBarLocation |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Visible | (Overrides Window.Visible.)
 | WindowState | (Inherited from Window.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Window
 |  |  |  | PaletteSet

Assembly: ZwManaged (Module: ZwManaged)


PaletteSet Constructor

PaletteSet Constructor
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteSet()()()()
Members
Icon | Member | Description
 | PaletteSet(String, String, Guid) |
 | PaletteSet(String, Guid) |
 | PaletteSet(String) |

Assembly: ZwManaged (Module: ZwManaged)


PaletteSet Constructor (name)

PaletteSet Constructor (name)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteSet(String)
Declaration Syntax
C# Visual Basic Visual C++
public PaletteSet(
    string name
)
Public Sub New ( _
    name As String _
)
public:
PaletteSet(
    String^ name
)
Parameters
name(String)

Assembly: ZwManaged (Module: ZwManaged)


PaletteSet Constructor (name, toolID)

PaletteSet Constructor (name, toolID)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteSet(String, Guid)
Declaration Syntax
C# Visual Basic Visual C++
public PaletteSet(
    string name,
    Guid toolID
)
Public Sub New ( _
    name As String, _
    toolID As Guid _
)
public:
PaletteSet(
    String^ name,
    Guid toolID
)
Parameters
name(String)
toolID(Guid)

Assembly: ZwManaged (Module: ZwManaged)


PaletteSet Constructor (name, cmd, toolID)

PaletteSet Constructor (name, cmd, toolID)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteSet(String, String, Guid)
Declaration Syntax
C# Visual Basic Visual C++
public PaletteSet(
    string name,
    string cmd,
    Guid toolID
)
Public Sub New ( _
    name As String, _
    cmd As String, _
    toolID As Guid _
)
public:
PaletteSet(
    String^ name,
    String^ cmd,
    Guid toolID
)
Parameters
name(String)
cmd(String)
toolID(Guid)

Assembly: ZwManaged (Module: ZwManaged)


Activate Method (index)

Activate Method (index)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Activate(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Activate(
    int index
)
Public Sub Activate ( _
    index As Integer _
)
public:
void Activate(
    int index
)
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Add Method (name, control)

Add Method (name, control)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Add(String, Control)
Declaration Syntax
C# Visual Basic Visual C++
public Palette Add(
    string name,
    Control control
)
Public Function Add ( _
    name As String, _
    control As Control _
) As Palette
public:
Palette^ Add(
    String^ name,
    Control^ control
)
Parameters
name(String)
control(Control)

Assembly: ZwManaged (Module: ZwManaged)


AddVisual Method (name, control)

AddVisual Method (name, control)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »AddVisual(String, Visual)
Declaration Syntax
C# Visual Basic Visual C++
public Palette AddVisual(
    string name,
    Visual control
)
Public Function AddVisual ( _
    name As String, _
    control As Visual _
) As Palette
public:
Palette^ AddVisual(
    String^ name,
    Visual^ control
)
Parameters
name(String)
control(Visual)

Assembly: ZwManaged (Module: ZwManaged)


Anchored Property

Anchored Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Anchored
Declaration Syntax
C# Visual Basic Visual C++
public bool Anchored { get; }
Public ReadOnly Property Anchored As Boolean
    Get
public:
property bool Anchored {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


AutoRollUp Property

AutoRollUp Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »AutoRollUp
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoRollUp { get; set; }
Public Property AutoRollUp As Boolean
    Get
    Set
public:
property bool AutoRollUp {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (arr, index)

CopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »CopyTo(array<Palette>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Palette[] arr,
    int index
)
Public Sub CopyTo ( _
    arr As Palette(), _
    index As Integer _
)
public:
void CopyTo(
    array<Palette^>^ arr,
    int index
)
Parameters
arr(array< Palette >[]()[][])
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Dock Property

Dock Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Dock
Declaration Syntax
C# Visual Basic Visual C++
public DockSides Dock { get; set; }
Public Property Dock As DockSides
    Get
    Set
public:
property DockSides Dock {
    DockSides get ();
    void set (DockSides value);
}

Assembly: ZwManaged (Module: ZwManaged)


DockEnabled Property

DockEnabled Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »DockEnabled
Declaration Syntax
C# Visual Basic Visual C++
public DockSides DockEnabled { get; set; }
Public Property DockEnabled As DockSides
    Get
    Set
public:
property DockSides DockEnabled {
    DockSides get ();
    void set (DockSides value);
}

Assembly: ZwManaged (Module: ZwManaged)


EnableTransparency Method (value)

EnableTransparency Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »EnableTransparency(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableTransparency(
    bool value
)
Public Function EnableTransparency ( _
    value As Boolean _
) As Boolean
public:
bool EnableTransparency(
    bool value
)
Parameters
value(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()

Assembly: ZwManaged (Module: ZwManaged)


Help Event

Help Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Help
Declaration Syntax
C# Visual Basic Visual C++
public event PaletteSetHelpEventHandler Help
Public Event Help As PaletteSetHelpEventHandler
public:
 event PaletteSetHelpEventHandler^ Help {
    void add (PaletteSetHelpEventHandler^ value);
    void remove (PaletteSetHelpEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


ICollectionCopyTo Method (arr, index)

ICollectionCopyTo Method (arr, index)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array arr,
    int index
)
Private Sub ICollectionCopyTo ( _
    arr As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollectionCopyTo(
    Array^ arr,
    int index
) sealed = ICollection::CopyTo
Parameters
arr(Array)
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


InitializeFloatingPosition Method (value)

InitializeFloatingPosition Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »InitializeFloatingPosition(Rect)
Declaration Syntax
C# Visual Basic Visual C++
public void InitializeFloatingPosition(
    Rect value
)
Public Sub InitializeFloatingPosition ( _
    value As Rect _
)
public:
void InitializeFloatingPosition(
    Rect value
)
Parameters
value(Rect)

Assembly: ZwManaged (Module: ZwManaged)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »ICollection..::..IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
bool ICollection.IsSynchronized { get; }
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized
    Get
private:
virtual property bool IsSynchronized {
    bool get () sealed = ICollection::IsSynchronized::get;
}

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Palette this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Palette
    Get
public:
property Palette^ default[int index] {
    Palette^ get (int index);
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


KeepFocus Property

KeepFocus Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »KeepFocus
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool KeepFocus { get; set; }
Public Overridable Property KeepFocus As Boolean
    Get
    Set
public:
virtual property bool KeepFocus {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


Load Event

Load Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Load
Declaration Syntax
C# Visual Basic Visual C++
public event PalettePersistEventHandler Load
Public Event Load As PalettePersistEventHandler
public:
 event PalettePersistEventHandler^ Load {
    void add (PalettePersistEventHandler^ value);
    void remove (PalettePersistEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Location Property

Location Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Location
Declaration Syntax
C# Visual Basic Visual C++
public override Point Location { get; set; }
Public Overrides Property Location As Point
    Get
    Set
public:
virtual property Point Location {
    Point get () override;
    void set (Point value) override;
}

Assembly: ZwManaged (Module: ZwManaged)


MinimumSize Property

MinimumSize Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »MinimumSize
Declaration Syntax
C# Visual Basic Visual C++
public Size MinimumSize { get; set; }
Public Property MinimumSize As Size
    Get
    Set
public:
property Size MinimumSize {
    Size get ();
    void set (Size value);
}

Assembly: ZwManaged (Module: ZwManaged)


Name Property

Name Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Opacity Property

Opacity Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Opacity
Declaration Syntax
C# Visual Basic Visual C++
public int Opacity { get; set; }
Public Property Opacity As Integer
    Get
    Set
public:
property int Opacity {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteActivated Event

PaletteActivated Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteActivated
Declaration Syntax
C# Visual Basic Visual C++
public event PaletteActivatedEventHandler PaletteActivated
Public Event PaletteActivated As PaletteActivatedEventHandler
public:
 event PaletteActivatedEventHandler^ PaletteActivated {
    void add (PaletteActivatedEventHandler^ value);
    void remove (PaletteActivatedEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteAddContextMenu Event

PaletteAddContextMenu Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteAddContextMenu
Declaration Syntax
C# Visual Basic Visual C++
public event PaletteAddContextMenuEventHandler PaletteAddContextMenu
Public Event PaletteAddContextMenu As PaletteAddContextMenuEventHandler
public:
 event PaletteAddContextMenuEventHandler^ PaletteAddContextMenu {
    void add (PaletteAddContextMenuEventHandler^ value);
    void remove (PaletteAddContextMenuEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetDestroy Event

PaletteSetDestroy Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteSetDestroy
Declaration Syntax
C# Visual Basic Visual C++
public event PaletteSetDestroyEventHandler PaletteSetDestroy
Public Event PaletteSetDestroy As PaletteSetDestroyEventHandler
public:
 event PaletteSetDestroyEventHandler^ PaletteSetDestroy {
    void add (PaletteSetDestroyEventHandler^ value);
    void remove (PaletteSetDestroyEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetMoved Event

PaletteSetMoved Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteSetMoved
Declaration Syntax
C# Visual Basic Visual C++
public event PaletteSetMoveEventHandler PaletteSetMoved
Public Event PaletteSetMoved As PaletteSetMoveEventHandler
public:
 event PaletteSetMoveEventHandler^ PaletteSetMoved {
    void add (PaletteSetMoveEventHandler^ value);
    void remove (PaletteSetMoveEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetShowDockBar Event

PaletteSetShowDockBar Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteSetShowDockBar
Declaration Syntax
C# Visual Basic Visual C++
public event PaletteSetShowDockBarEventHandler PaletteSetShowDockBar
Public Event PaletteSetShowDockBar As PaletteSetShowDockBarEventHandler
public:
 event PaletteSetShowDockBarEventHandler^ PaletteSetShowDockBar {
    void add (PaletteSetShowDockBarEventHandler^ value);
    void remove (PaletteSetShowDockBarEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetTitleBarLocationChange Event

PaletteSetTitleBarLocationChange Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteSetTitleBarLocationChange
Declaration Syntax
C# Visual Basic Visual C++
public event PaletteSetTitleBarLocationChangeEventHandler PaletteSetTitleBarLocationChange
Public Event PaletteSetTitleBarLocationChange As PaletteSetTitleBarLocationChangeEventHandler
public:
 event PaletteSetTitleBarLocationChangeEventHandler^ PaletteSetTitleBarLocationChange {
    void add (PaletteSetTitleBarLocationChangeEventHandler^ value);
    void remove (PaletteSetTitleBarLocationChangeEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteSize Property

PaletteSize Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »PaletteSize
Declaration Syntax
C# Visual Basic Visual C++
public Size PaletteSize { get; }
Public ReadOnly Property PaletteSize As Size
    Get
public:
property Size PaletteSize {
    Size get ();
}

Assembly: ZwManaged (Module: ZwManaged)


RecalculateDockSiteLayout Method

RecalculateDockSiteLayout Method
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »RecalculateDockSiteLayout()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void RecalculateDockSiteLayout()
Public Sub RecalculateDockSiteLayout
public:
void RecalculateDockSiteLayout()

Assembly: ZwManaged (Module: ZwManaged)


Remove Method (index)

Remove Method (index)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Remove(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    int index
)
Public Sub Remove ( _
    index As Integer _
)
public:
void Remove(
    int index
)
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


RolledUp Property

RolledUp Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »RolledUp
Declaration Syntax
C# Visual Basic Visual C++
public bool RolledUp { get; set; }
Public Property RolledUp As Boolean
    Get
    Set
public:
property bool RolledUp {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


Save Event

Save Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Save
Declaration Syntax
C# Visual Basic Visual C++
public event PalettePersistEventHandler Save
Public Event Save As PalettePersistEventHandler
public:
 event PalettePersistEventHandler^ Save {
    void add (PalettePersistEventHandler^ value);
    void remove (PalettePersistEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Saving Event

Saving Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Saving
Declaration Syntax
C# Visual Basic Visual C++
public event PalettePersistEventHandler Saving
Public Event Saving As PalettePersistEventHandler
public:
 event PalettePersistEventHandler^ Saving {
    void add (PalettePersistEventHandler^ value);
    void remove (PalettePersistEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Size Property

Size Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Size
Declaration Syntax
C# Visual Basic Visual C++
public override Size Size { get; set; }
Public Overrides Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get () override;
    void set (Size value) override;
}

Assembly: ZwManaged (Module: ZwManaged)


SizeChanged Event

SizeChanged Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »SizeChanged
Declaration Syntax
C# Visual Basic Visual C++
public event PaletteSetSizeEventHandler SizeChanged
Public Event SizeChanged As PaletteSetSizeEventHandler
public:
 event PaletteSetSizeEventHandler^ SizeChanged {
    void add (PaletteSetSizeEventHandler^ value);
    void remove (PaletteSetSizeEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


StateChanged Event

StateChanged Event
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »StateChanged
Declaration Syntax
C# Visual Basic Visual C++
public event PaletteSetStateEventHandler StateChanged
Public Event StateChanged As PaletteSetStateEventHandler
public:
 event PaletteSetStateEventHandler^ StateChanged {
    void add (PaletteSetStateEventHandler^ value);
    void remove (PaletteSetStateEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Style Property

Style Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Style
Declaration Syntax
C# Visual Basic Visual C++
public PaletteSetStyles Style { get; set; }
Public Property Style As PaletteSetStyles
    Get
    Set
public:
property PaletteSetStyles Style {
    PaletteSetStyles get ();
    void set (PaletteSetStyles value);
}

Assembly: ZwManaged (Module: ZwManaged)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »ICollection..::..SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
Object ICollection.SyncRoot { get; }
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot
    Get
private:
virtual property Object^ SyncRoot {
    Object^ get () sealed = ICollection::SyncRoot::get;
}

Assembly: ZwManaged (Module: ZwManaged)


TitleBarLocation Property

TitleBarLocation Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »TitleBarLocation
Declaration Syntax
C# Visual Basic Visual C++
public PaletteSetTitleBarLocation TitleBarLocation { get; set; }
Public Property TitleBarLocation As PaletteSetTitleBarLocation
    Get
    Set
public:
property PaletteSetTitleBarLocation TitleBarLocation {
    PaletteSetTitleBarLocation get ();
    void set (PaletteSetTitleBarLocation value);
}

Assembly: ZwManaged (Module: ZwManaged)


Visible Property

Visible Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Visible
Declaration Syntax
C# Visual Basic Visual C++
public override bool Visible { get; set; }
Public Overrides Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get () override;
    void set (bool value) override;
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetDestroyEventHandler Delegate

PaletteSetDestroyEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetDestroyEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PaletteSetDestroyEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub PaletteSetDestroyEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
public delegate void PaletteSetDestroyEventHandler(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender(Object)
e(EventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetHelpEventArgs Class

PaletteSetHelpEventArgs Class
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetHelpEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PaletteSetHelpEventArgs : EventArgs
Public NotInheritable Class PaletteSetHelpEventArgs _
    Inherits EventArgs
public ref class PaletteSetHelpEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PaletteSetHelpEventArgs()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PaletteSetHelpEventArgs

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetHelpEventArgs Constructor

PaletteSetHelpEventArgs Constructor
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetHelpEventArgs »PaletteSetHelpEventArgs()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaletteSetHelpEventArgs()
Public Sub New
public:
PaletteSetHelpEventArgs()

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetHelpEventHandler Delegate

PaletteSetHelpEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetHelpEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PaletteSetHelpEventHandler(
    Object sender,
    PaletteSetHelpEventArgs e
)
Public Delegate Sub PaletteSetHelpEventHandler ( _
    sender As Object, _
    e As PaletteSetHelpEventArgs _
)
public delegate void PaletteSetHelpEventHandler(
    Object^ sender,
    PaletteSetHelpEventArgs^ e
)
Parameters
sender(Object)
e(PaletteSetHelpEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetMoveEventArgs Class

PaletteSetMoveEventArgs Class
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetMoveEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PaletteSetMoveEventArgs : EventArgs
Public NotInheritable Class PaletteSetMoveEventArgs _
    Inherits EventArgs
public ref class PaletteSetMoveEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaletteSetMoveEventArgs(Int32, Int32) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | X |
 | Y |
Inheritance Hierarchy
Object
 | EventArgs
 |  | PaletteSetMoveEventArgs

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetMoveEventArgs Constructor (x, y)

PaletteSetMoveEventArgs Constructor (x, y)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetMoveEventArgs »PaletteSetMoveEventArgs(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PaletteSetMoveEventArgs(
    int x,
    int y
)
Public Sub New ( _
    x As Integer, _
    y As Integer _
)
public:
PaletteSetMoveEventArgs(
    int x,
    int y
)
Parameters
x(Int32)
y(Int32)

Assembly: ZwManaged (Module: ZwManaged)


X Property

X Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetMoveEventArgs »X
Declaration Syntax
C# Visual Basic Visual C++
public int X { get; }
Public ReadOnly Property X As Integer
    Get
public:
property int X {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Y Property

Y Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetMoveEventArgs »Y
Declaration Syntax
C# Visual Basic Visual C++
public int Y { get; }
Public ReadOnly Property Y As Integer
    Get
public:
property int Y {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetMoveEventHandler Delegate

PaletteSetMoveEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetMoveEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PaletteSetMoveEventHandler(
    Object sender,
    PaletteSetMoveEventArgs e
)
Public Delegate Sub PaletteSetMoveEventHandler ( _
    sender As Object, _
    e As PaletteSetMoveEventArgs _
)
public delegate void PaletteSetMoveEventHandler(
    Object^ sender,
    PaletteSetMoveEventArgs^ e
)
Parameters
sender(Object)
e(PaletteSetMoveEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetShowDockBarEventHandler Delegate

PaletteSetShowDockBarEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetShowDockBarEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PaletteSetShowDockBarEventHandler(
    Object sender,
    PaletteShowDockBarEventArgs e
)
Public Delegate Sub PaletteSetShowDockBarEventHandler ( _
    sender As Object, _
    e As PaletteShowDockBarEventArgs _
)
public delegate void PaletteSetShowDockBarEventHandler(
    Object^ sender,
    PaletteShowDockBarEventArgs^ e
)
Parameters
sender(Object)
e(PaletteShowDockBarEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetSizeEventArgs Class

PaletteSetSizeEventArgs Class
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetSizeEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PaletteSetSizeEventArgs : EventArgs
Public NotInheritable Class PaletteSetSizeEventArgs _
    Inherits EventArgs
public ref class PaletteSetSizeEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaletteSetSizeEventArgs(Int32, Int32, Double, Double) |
 | DeviceIndependentHeight |
 | DeviceIndependentWidth |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Height |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Width |
Inheritance Hierarchy
Object
 | EventArgs
 |  | PaletteSetSizeEventArgs

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetSizeEventArgs Constructor (cx, cy, dx, dy)

PaletteSetSizeEventArgs Constructor (cx, cy, dx, dy)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetSizeEventArgs »PaletteSetSizeEventArgs(Int32, Int32, Double, Double)
Declaration Syntax
C# Visual Basic Visual C++
public PaletteSetSizeEventArgs(
    int cx,
    int cy,
    double dx,
    double dy
)
Public Sub New ( _
    cx As Integer, _
    cy As Integer, _
    dx As Double, _
    dy As Double _
)
public:
PaletteSetSizeEventArgs(
    int cx,
    int cy,
    double dx,
    double dy
)
Parameters
cx(Int32)
cy(Int32)
dx(Double)
dy(Double)

Assembly: ZwManaged (Module: ZwManaged)


DeviceIndependentHeight Property

DeviceIndependentHeight Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetSizeEventArgs »DeviceIndependentHeight
Declaration Syntax
C# Visual Basic Visual C++
public double DeviceIndependentHeight { get; }
Public ReadOnly Property DeviceIndependentHeight As Double
    Get
public:
property double DeviceIndependentHeight {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DeviceIndependentWidth Property

DeviceIndependentWidth Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetSizeEventArgs »DeviceIndependentWidth
Declaration Syntax
C# Visual Basic Visual C++
public double DeviceIndependentWidth { get; }
Public ReadOnly Property DeviceIndependentWidth As Double
    Get
public:
property double DeviceIndependentWidth {
    double get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Height Property

Height Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetSizeEventArgs »Height
Declaration Syntax
C# Visual Basic Visual C++
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
public:
property int Height {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Width Property

Width Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetSizeEventArgs »Width
Declaration Syntax
C# Visual Basic Visual C++
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
public:
property int Width {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetSizeEventHandler Delegate

PaletteSetSizeEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetSizeEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PaletteSetSizeEventHandler(
    Object sender,
    PaletteSetSizeEventArgs e
)
Public Delegate Sub PaletteSetSizeEventHandler ( _
    sender As Object, _
    e As PaletteSetSizeEventArgs _
)
public delegate void PaletteSetSizeEventHandler(
    Object^ sender,
    PaletteSetSizeEventArgs^ e
)
Parameters
sender(Object)
e(PaletteSetSizeEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetStateEventArgs Class

PaletteSetStateEventArgs Class
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetStateEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PaletteSetStateEventArgs : EventArgs
Public NotInheritable Class PaletteSetStateEventArgs _
    Inherits EventArgs
public ref class PaletteSetStateEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaletteSetStateEventArgs(StateEventIndex) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewState |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PaletteSetStateEventArgs

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetStateEventArgs Constructor (state)

PaletteSetStateEventArgs Constructor (state)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetStateEventArgs »PaletteSetStateEventArgs(StateEventIndex)
Declaration Syntax
C# Visual Basic Visual C++
public PaletteSetStateEventArgs(
    StateEventIndex state
)
Public Sub New ( _
    state As StateEventIndex _
)
public:
PaletteSetStateEventArgs(
    StateEventIndex state
)
Parameters
state(StateEventIndex)

Assembly: ZwManaged (Module: ZwManaged)


NewState Property

NewState Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetStateEventArgs »NewState
Declaration Syntax
C# Visual Basic Visual C++
public StateEventIndex NewState { get; }
Public ReadOnly Property NewState As StateEventIndex
    Get
public:
property StateEventIndex NewState {
    StateEventIndex get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetStateEventHandler Delegate

PaletteSetStateEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetStateEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PaletteSetStateEventHandler(
    Object sender,
    PaletteSetStateEventArgs e
)
Public Delegate Sub PaletteSetStateEventHandler ( _
    sender As Object, _
    e As PaletteSetStateEventArgs _
)
public delegate void PaletteSetStateEventHandler(
    Object^ sender,
    PaletteSetStateEventArgs^ e
)
Parameters
sender(Object)
e(PaletteSetStateEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetStyles Enumeration

PaletteSetStyles Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetStyles
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum PaletteSetStyles
<FlagsAttribute> _
Public Enumeration PaletteSetStyles
[FlagsAttribute]
public enum class PaletteSetStyles
Members
Member | Description
UsePaletteNameAsTitleForSingle |
ShowTabForSingle |
Snappable |
NameEditable |
ShowPropertiesMenu |
ShowAutoHideButton |
ShowCloseButton |

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetTitleBarLocation Enumeration

PaletteSetTitleBarLocation Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetTitleBarLocation
Declaration Syntax
C# Visual Basic Visual C++
public enum PaletteSetTitleBarLocation
Public Enumeration PaletteSetTitleBarLocation
public enum class PaletteSetTitleBarLocation
Members
Member | Description
Right |
Left |

Assembly: ZwManaged (Module: ZwManaged)


PaletteSetTitleBarLocationChangeEventHandler Delegate

PaletteSetTitleBarLocationChangeEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSetTitleBarLocationChangeEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void PaletteSetTitleBarLocationChangeEventHandler(
    Object sender,
    EventArgs e
)
Public Delegate Sub PaletteSetTitleBarLocationChangeEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
public delegate void PaletteSetTitleBarLocationChangeEventHandler(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender(Object)
e(EventArgs)

Assembly: ZwManaged (Module: ZwManaged)


PaletteShowDockBarEventArgs Class

PaletteShowDockBarEventArgs Class
Namespaces »ZwSoft.ZwCAD.Windows »PaletteShowDockBarEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PaletteShowDockBarEventArgs : EventArgs
Public NotInheritable Class PaletteShowDockBarEventArgs _
    Inherits EventArgs
public ref class PaletteShowDockBarEventArgs sealed : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaletteShowDockBarEventArgs(Boolean) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShowDockBar |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | PaletteShowDockBarEventArgs

Assembly: ZwManaged (Module: ZwManaged)


PaletteShowDockBarEventArgs Constructor (bShowDockBar)

PaletteShowDockBarEventArgs Constructor (bShowDockBar)
Namespaces »ZwSoft.ZwCAD.Windows »PaletteShowDockBarEventArgs »PaletteShowDockBarEventArgs(Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public PaletteShowDockBarEventArgs(
    bool bShowDockBar
)
Public Sub New ( _
    bShowDockBar As Boolean _
)
public:
PaletteShowDockBarEventArgs(
    bool bShowDockBar
)
Parameters
bShowDockBar(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


ShowDockBar Property

ShowDockBar Property
Namespaces »ZwSoft.ZwCAD.Windows »PaletteShowDockBarEventArgs »ShowDockBar
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowDockBar { get; }
Public ReadOnly Property ShowDockBar As Boolean
    Get
public:
property bool ShowDockBar {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Pane Class

Pane Class
Namespaces »ZwSoft.ZwCAD.Windows »Pane
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcPane")]
public sealed class Pane : StatusBarItem
<WrapperAttribute("AcPane")> _
Public NotInheritable Class Pane _
    Inherits StatusBarItem
[WrapperAttribute(L"AcPane")]
public ref class Pane sealed : public StatusBarItem
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Pane()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Deleted | (Inherited from StatusBarItem.)
 | DeleteUnmanagedObject()()()() | (Inherited from StatusBarItem.)
 | DisplayContextMenu(ContextMenu, Point) | (Inherited from StatusBarItem.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Enabled | (Inherited from StatusBarItem.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Icon | (Inherited from StatusBarItem.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MaximumWidth |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumWidth |
 | MouseDown | (Inherited from StatusBarItem.)
 | PointToClient(Point) | (Inherited from StatusBarItem.)
 | PointToScreen(Point) | (Inherited from StatusBarItem.)
 | Style |
 | Text |
 | ToolTipText | (Inherited from StatusBarItem.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Visible | (Inherited from StatusBarItem.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | StatusBarItem
 |  |  |  | Pane

Assembly: ZwManaged (Module: ZwManaged)


Pane Constructor

Pane Constructor
Namespaces »ZwSoft.ZwCAD.Windows »Pane »Pane()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Pane()
Public Sub New
public:
Pane()

Assembly: ZwManaged (Module: ZwManaged)


MaximumWidth Property

MaximumWidth Property
Namespaces »ZwSoft.ZwCAD.Windows »Pane »MaximumWidth
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumWidth { get; set; }
Public Property MaximumWidth As Integer
    Get
    Set
public:
property int MaximumWidth {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


MinimumWidth Property

MinimumWidth Property
Namespaces »ZwSoft.ZwCAD.Windows »Pane »MinimumWidth
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumWidth { get; set; }
Public Property MinimumWidth As Integer
    Get
    Set
public:
property int MinimumWidth {
    int get ();
    void set (int value);
}

Assembly: ZwManaged (Module: ZwManaged)


Style Property

Style Property
Namespaces »ZwSoft.ZwCAD.Windows »Pane »Style
Declaration Syntax
C# Visual Basic Visual C++
public PaneStyles Style { get; set; }
Public Property Style As PaneStyles
    Get
    Set
public:
property PaneStyles Style {
    PaneStyles get ();
    void set (PaneStyles value);
}

Assembly: ZwManaged (Module: ZwManaged)


Text Property

Text Property
Namespaces »ZwSoft.ZwCAD.Windows »Pane »Text
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PaneCollection Class

PaneCollection Class
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PaneCollection : IList
Public NotInheritable Class PaneCollection _
    Implements IList
public ref class PaneCollection sealed : IList
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(Pane) |
 | Clear()()()() |
 | Contains(Pane) |
 | CopyTo(array<Pane>[]()[][], Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(Pane) |
 | Insert(Int32, Pane) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(Pane) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PaneCollection

Assembly: ZwManaged (Module: ZwManaged)


Add Method (p)

Add Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »Add(Pane)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Pane p
)
Public Function Add ( _
    p As Pane _
) As Integer
public:
int Add(
    Pane^ p
)
Parameters
p(Pane)

Assembly: ZwManaged (Module: ZwManaged)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Assembly: ZwManaged (Module: ZwManaged)


Contains Method (p)

Contains Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »Contains(Pane)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Pane p
)
Public Function Contains ( _
    p As Pane _
) As Boolean
public:
bool Contains(
    Pane^ p
)
Parameters
p(Pane)

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (a, index)

CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »CopyTo(array<Pane>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Pane[] a,
    int index
)
Public Sub CopyTo ( _
    a As Pane(), _
    index As Integer _
)
public:
void CopyTo(
    array<Pane^>^ a,
    int index
)
Parameters
a(array< Pane >[]()[][])
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed

Assembly: ZwManaged (Module: ZwManaged)


ICollection_CopyTo Method (a, index)

ICollection_CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array a,
    int index
)
Private Sub ICollection_CopyTo ( _
    a As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ a,
    int index
) sealed = ICollection::CopyTo
Parameters
a(Array)
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IList_IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IList_IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IList_Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IList_Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IndexOf Method (p)

IndexOf Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »IndexOf(Pane)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Pane p
)
Public Function IndexOf ( _
    p As Pane _
) As Integer
public:
int IndexOf(
    Pane^ p
)
Parameters
p(Pane)

Assembly: ZwManaged (Module: ZwManaged)


Insert Method (index, p)

Insert Method (index, p)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »Insert(Int32, Pane)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Pane p
)
Public Sub Insert ( _
    index As Integer, _
    p As Pane _
)
public:
void Insert(
    int index,
    Pane^ p
)
Parameters
index(Int32)
p(Pane)

Assembly: ZwManaged (Module: ZwManaged)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Pane this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Pane
    Get
    Set
public:
property Pane^ default[int index] {
    Pane^ get (int index);
    void set (int index, Pane^ value);
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »Remove(Pane)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Pane value
)
Public Sub Remove ( _
    value As Pane _
)
public:
void Remove(
    Pane^ value
)
Parameters
value(Pane)

Assembly: ZwManaged (Module: ZwManaged)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Windows »PaneCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PaneStyles Enumeration

PaneStyles Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »PaneStyles
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum PaneStyles
<FlagsAttribute> _
Public Enumeration PaneStyles
[FlagsAttribute]
public enum class PaneStyles
Members
Member | Description
PopUp |
Command |
PopOut |
NoBorders |
Stretch |
Normal |

Assembly: ZwManaged (Module: ZwManaged)


PlotStyleDialog Class

PlotStyleDialog Class
Namespaces »ZwSoft.ZwCAD.Windows »PlotStyleDialog
Declaration Syntax
C# Visual Basic Visual C++
public sealed class PlotStyleDialog
Public NotInheritable Class PlotStyleDialog
public ref class PlotStyleDialog sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlotStyleDialog()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeByBlockByLayer |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PlotStyle |
 | ShowDialog()()()() |
 | ShowModal()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PlotStyleDialog

Assembly: ZwManaged (Module: ZwManaged)


PlotStyleDialog Constructor

PlotStyleDialog Constructor
Namespaces »ZwSoft.ZwCAD.Windows »PlotStyleDialog »PlotStyleDialog()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PlotStyleDialog()
Public Sub New
public:
PlotStyleDialog()

Assembly: ZwManaged (Module: ZwManaged)


IncludeByBlockByLayer Property

IncludeByBlockByLayer Property
Namespaces »ZwSoft.ZwCAD.Windows »PlotStyleDialog »IncludeByBlockByLayer
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeByBlockByLayer { get; set; }
Public Property IncludeByBlockByLayer As Boolean
    Get
    Set
public:
property bool IncludeByBlockByLayer {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


PlotStyle Property

PlotStyle Property
Namespaces »ZwSoft.ZwCAD.Windows »PlotStyleDialog »PlotStyle
Declaration Syntax
C# Visual Basic Visual C++
public string PlotStyle { get; set; }
Public Property PlotStyle As String
    Get
    Set
public:
property String^ PlotStyle {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


ShowDialog Method

ShowDialog Method
Namespaces »ZwSoft.ZwCAD.Windows »PlotStyleDialog »ShowDialog()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DialogResult ShowDialog()
Public Function ShowDialog As DialogResult
public:
DialogResult ShowDialog()

Assembly: ZwManaged (Module: ZwManaged)


ShowModal Method

ShowModal Method
Namespaces »ZwSoft.ZwCAD.Windows »PlotStyleDialog »ShowModal()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowModal()
Public Function ShowModal As Boolean
public:
bool ShowModal()

Assembly: ZwManaged (Module: ZwManaged)


SaveFileDialog Class

SaveFileDialog Class
Namespaces »ZwSoft.ZwCAD.Windows »SaveFileDialog
Declaration Syntax
C# Visual Basic Visual C++
public sealed class SaveFileDialog
Public NotInheritable Class SaveFileDialog
public ref class SaveFileDialog sealed
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveFileDialog(String, String, String, String, SaveFileDialog..::..SaveFileDialogFlags) |
 | Equals(Object) | (Inherited from Object.)
 | Filename |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShowDialog()()()() |
 | ShowModal()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SaveFileDialog

Assembly: ZwManaged (Module: ZwManaged)


SaveFileDialog Constructor (title, defaultName, extension, dialogName, flags)

SaveFileDialog Constructor (title, defaultName, extension, dialogName, flags)
Namespaces »ZwSoft.ZwCAD.Windows »SaveFileDialog »SaveFileDialog(String, String, String, String, SaveFileDialog..::..SaveFileDialogFlags)
Declaration Syntax
C# Visual Basic Visual C++
public SaveFileDialog(
    string title,
    string defaultName,
    string extension,
    string dialogName,
    SaveFileDialog..::..SaveFileDialogFlags flags
)
Public Sub New ( _
    title As String, _
    defaultName As String, _
    extension As String, _
    dialogName As String, _
    flags As SaveFileDialog..::..SaveFileDialogFlags _
)
public:
SaveFileDialog(
    String^ title,
    String^ defaultName,
    String^ extension,
    String^ dialogName,
    SaveFileDialog..::..SaveFileDialogFlags flags
)
Parameters
title(String)
defaultName(String)
extension(String)
dialogName(String)
flags(SaveFileDialog..::..SaveFileDialogFlags)

Assembly: ZwManaged (Module: ZwManaged)


Filename Property

Filename Property
Namespaces »ZwSoft.ZwCAD.Windows »SaveFileDialog »Filename
Declaration Syntax
C# Visual Basic Visual C++
public string Filename { get; }
Public ReadOnly Property Filename As String
    Get
public:
property String^ Filename {
    String^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


ShowDialog Method

ShowDialog Method
Namespaces »ZwSoft.ZwCAD.Windows »SaveFileDialog »ShowDialog()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DialogResult ShowDialog()
Public Function ShowDialog As DialogResult
public:
DialogResult ShowDialog()

Assembly: ZwManaged (Module: ZwManaged)


ShowModal Method

ShowModal Method
Namespaces »ZwSoft.ZwCAD.Windows »SaveFileDialog »ShowModal()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowModal()
Public Function ShowModal As Boolean
public:
bool ShowModal()

Assembly: ZwManaged (Module: ZwManaged)


SaveFileDialog.SaveFileDialogFlags Enumeration

SaveFileDialog..::..SaveFileDialogFlags Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »SaveFileDialog »SaveFileDialog..::..SaveFileDialogFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum SaveFileDialogFlags
<FlagsAttribute> _
Public Enumeration SaveFileDialogFlags
[FlagsAttribute]
public enum class SaveFileDialogFlags
Members
Member | Description
NoShellExtensions |
NoFtpSites |
ForceDefaultFolder |
NoUrls |
DoNotTransferRemoteFiles |
DoNotWarnIfFileExist |
DefaultIsFolder |
AllowAnyExtension |

Assembly: ZwManaged (Module: ZwManaged)


SaveFileDialogFlags Enumeration

SaveFileDialogFlags Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »SaveFileDialogFlags
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum SaveFileDialogFlags
<FlagsAttribute> _
Public Enumeration SaveFileDialogFlags
[FlagsAttribute]
public enum class SaveFileDialogFlags
Members
Member | Description
NoShellExtensions |
NoFtpSites |
ForceDefaultFolder |
NoUrls |
DoNotTransferRemoteFiles |
DoNotWarnIfFileExist |
DefaultIsFolder |
AllowAnyExtension |

Assembly: ZwManaged (Module: ZwManaged)


StateEventIndex Enumeration

StateEventIndex Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »StateEventIndex
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum StateEventIndex
<FlagsAttribute> _
Public Enumeration StateEventIndex
[FlagsAttribute]
public enum class StateEventIndex
Members
Member | Description
ThemeChange |
Floating |
Docking |
Show |
Hide |

Assembly: ZwManaged (Module: ZwManaged)


StatusBar Class

StatusBar Class
Namespaces »ZwSoft.ZwCAD.Windows »StatusBar
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("ZcApStatusBar")]
public sealed class StatusBar
<WrapperAttribute("ZcApStatusBar")> _
Public NotInheritable Class StatusBar
[WrapperAttribute(L"ZcApStatusBar")]
public ref class StatusBar sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CloseBubbleWindows()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDefaultPane(DefaultPane) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Panes |
 | RemoveDefaultPane(DefaultPane) |
 | ToString()()()() | (Inherited from Object.)
 | TrayItems |
 | Update()()()() |
 | Window |
Inheritance Hierarchy
Object
StatusBar

Assembly: ZwManaged (Module: ZwManaged)


CloseBubbleWindows Method

CloseBubbleWindows Method
Namespaces »ZwSoft.ZwCAD.Windows »StatusBar »CloseBubbleWindows()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void CloseBubbleWindows()
Public Sub CloseBubbleWindows
public:
void CloseBubbleWindows()

Assembly: ZwManaged (Module: ZwManaged)


GetDefaultPane Method (pane)

GetDefaultPane Method (pane)
Namespaces »ZwSoft.ZwCAD.Windows »StatusBar »GetDefaultPane(DefaultPane)
Declaration Syntax
C# Visual Basic Visual C++
public Pane GetDefaultPane(
    DefaultPane pane
)
Public Function GetDefaultPane ( _
    pane As DefaultPane _
) As Pane
public:
Pane^ GetDefaultPane(
    DefaultPane pane
)
Parameters
pane(DefaultPane)

Assembly: ZwManaged (Module: ZwManaged)


Panes Property

Panes Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBar »Panes
Declaration Syntax
C# Visual Basic Visual C++
public PaneCollection Panes { get; }
Public ReadOnly Property Panes As PaneCollection
    Get
public:
property PaneCollection^ Panes {
    PaneCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


RemoveDefaultPane Method (pane)

RemoveDefaultPane Method (pane)
Namespaces »ZwSoft.ZwCAD.Windows »StatusBar »RemoveDefaultPane(DefaultPane)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveDefaultPane(
    DefaultPane pane
)
Public Sub RemoveDefaultPane ( _
    pane As DefaultPane _
)
public:
void RemoveDefaultPane(
    DefaultPane pane
)
Parameters
pane(DefaultPane)

Assembly: ZwManaged (Module: ZwManaged)


TrayItems Property

TrayItems Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBar »TrayItems
Declaration Syntax
C# Visual Basic Visual C++
public TrayItemCollection TrayItems { get; }
Public ReadOnly Property TrayItems As TrayItemCollection
    Get
public:
property TrayItemCollection^ TrayItems {
    TrayItemCollection^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Update Method

Update Method
Namespaces »ZwSoft.ZwCAD.Windows »StatusBar »Update()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Update()
Public Sub Update
public:
void Update()

Assembly: ZwManaged (Module: ZwManaged)


Window Property

Window Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBar »Window
Declaration Syntax
C# Visual Basic Visual C++
public Window Window { get; }
Public ReadOnly Property Window As Window
    Get
public:
property Window^ Window {
    Window^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


StatusBarItem Class

StatusBarItem Class
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcStatusBarItem")]
public class StatusBarItem : DisposableWrapper
<WrapperAttribute("AcStatusBarItem")> _
Public Class StatusBarItem _
    Inherits DisposableWrapper
[WrapperAttribute(L"AcStatusBarItem")]
public ref class StatusBarItem : public DisposableWrapper
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StatusBarItem(IntPtr, Boolean) |
 | StatusBarItem()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Deleted |
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | DisplayContextMenu(ContextMenu, Point) |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Enabled |
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Icon |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MouseDown |
 | PointToClient(Point) |
 | PointToScreen(Point) |
 | ToolTipText |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Visible |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | StatusBarItem
 |  |  |  | Pane
 |  |  |  | TrayItem

Assembly: ZwManaged (Module: ZwManaged)


StatusBarItem Constructor

StatusBarItem Constructor
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »StatusBarItem()()()()
Members
Icon | Member | Description
 | StatusBarItem(IntPtr, Boolean) |
 | StatusBarItem()()()() |

Assembly: ZwManaged (Module: ZwManaged)


StatusBarItem Constructor

StatusBarItem Constructor
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »StatusBarItem()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected StatusBarItem()
Protected Sub New
protected:
StatusBarItem()

Assembly: ZwManaged (Module: ZwManaged)


StatusBarItem Constructor (unmanagedPointer, autoDelete)

StatusBarItem Constructor (unmanagedPointer, autoDelete)
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »StatusBarItem(IntPtr, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
protected StatusBarItem(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Protected Sub New ( _
    unmanagedPointer As IntPtr, _
    autoDelete As Boolean _
)
protected:
StatusBarItem(
    IntPtr unmanagedPointer,
    bool autoDelete
)
Parameters
unmanagedPointer(IntPtr)
autoDelete(Boolean)

Assembly: ZwManaged (Module: ZwManaged)


Deleted Event

Deleted Event
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »Deleted
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Deleted
Public Event Deleted As EventHandler
public:
 event EventHandler^ Deleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override

Assembly: ZwManaged (Module: ZwManaged)


DisplayContextMenu Method (menu, p)

DisplayContextMenu Method (menu, p)
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »DisplayContextMenu(ContextMenu, Point)
Declaration Syntax
C# Visual Basic Visual C++
public void DisplayContextMenu(
    ContextMenu menu,
    Point p
)
Public Sub DisplayContextMenu ( _
    menu As ContextMenu, _
    p As Point _
)
public:
void DisplayContextMenu(
    ContextMenu^ menu,
    Point p
)
Parameters
menu(ContextMenu)
p(Point)

Assembly: ZwManaged (Module: ZwManaged)


Enabled Property

Enabled Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »Enabled
Declaration Syntax
C# Visual Basic Visual C++
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


Icon Property

Icon Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »Icon
Declaration Syntax
C# Visual Basic Visual C++
public Icon Icon { get; set; }
Public Property Icon As Icon
    Get
    Set
public:
property Icon^ Icon {
    Icon^ get ();
    void set (Icon^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


MouseDown Event

MouseDown Event
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »MouseDown
Declaration Syntax
C# Visual Basic Visual C++
public event StatusBarMouseDownEventHandler MouseDown
Public Event MouseDown As StatusBarMouseDownEventHandler
public:
 event StatusBarMouseDownEventHandler^ MouseDown {
    void add (StatusBarMouseDownEventHandler^ value);
    void remove (StatusBarMouseDownEventHandler^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


PointToClient Method (p)

PointToClient Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »PointToClient(Point)
Declaration Syntax
C# Visual Basic Visual C++
public Point PointToClient(
    Point p
)
Public Function PointToClient ( _
    p As Point _
) As Point
public:
Point PointToClient(
    Point p
)
Parameters
p(Point)

Assembly: ZwManaged (Module: ZwManaged)


PointToScreen Method (p)

PointToScreen Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »PointToScreen(Point)
Declaration Syntax
C# Visual Basic Visual C++
public Point PointToScreen(
    Point p
)
Public Function PointToScreen ( _
    p As Point _
) As Point
public:
Point PointToScreen(
    Point p
)
Parameters
p(Point)

Assembly: ZwManaged (Module: ZwManaged)


ToolTipText Property

ToolTipText Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »ToolTipText
Declaration Syntax
C# Visual Basic Visual C++
public string ToolTipText { get; set; }
Public Property ToolTipText As String
    Get
    Set
public:
property String^ ToolTipText {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Visible Property

Visible Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »Visible
Declaration Syntax
C# Visual Basic Visual C++
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


StatusBarMouseDownEventArgs Class

StatusBarMouseDownEventArgs Class
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarMouseDownEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public sealed class StatusBarMouseDownEventArgs : EventArgs
Public NotInheritable Class StatusBarMouseDownEventArgs _
    Inherits EventArgs
public ref class StatusBarMouseDownEventArgs sealed : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Button |
 | DoubleClick |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | X |
 | Y |
Inheritance Hierarchy
Object
 | EventArgs
 |  | StatusBarMouseDownEventArgs

Assembly: ZwManaged (Module: ZwManaged)


Button Property

Button Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarMouseDownEventArgs »Button
Declaration Syntax
C# Visual Basic Visual C++
public MouseButtons Button { get; }
Public ReadOnly Property Button As MouseButtons
    Get
public:
property MouseButtons Button {
    MouseButtons get ();
}

Assembly: ZwManaged (Module: ZwManaged)


DoubleClick Property

DoubleClick Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarMouseDownEventArgs »DoubleClick
Declaration Syntax
C# Visual Basic Visual C++
public bool DoubleClick { get; }
Public ReadOnly Property DoubleClick As Boolean
    Get
public:
property bool DoubleClick {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


X Property

X Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarMouseDownEventArgs »X
Declaration Syntax
C# Visual Basic Visual C++
public int X { get; }
Public ReadOnly Property X As Integer
    Get
public:
property int X {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Y Property

Y Property
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarMouseDownEventArgs »Y
Declaration Syntax
C# Visual Basic Visual C++
public int Y { get; }
Public ReadOnly Property Y As Integer
    Get
public:
property int Y {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


StatusBarMouseDownEventHandler Delegate

StatusBarMouseDownEventHandler Delegate
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarMouseDownEventHandler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void StatusBarMouseDownEventHandler(
    Object sender,
    StatusBarMouseDownEventArgs e
)
Public Delegate Sub StatusBarMouseDownEventHandler ( _
    sender As Object, _
    e As StatusBarMouseDownEventArgs _
)
public delegate void StatusBarMouseDownEventHandler(
    Object^ sender,
    StatusBarMouseDownEventArgs^ e
)
Parameters
sender(Object)
e(StatusBarMouseDownEventArgs)

Assembly: ZwManaged (Module: ZwManaged)


TrayItem Class

TrayItem Class
Namespaces »ZwSoft.ZwCAD.Windows »TrayItem
Declaration Syntax
C# Visual Basic Visual C++
[WrapperAttribute("AcTrayItem")]
public sealed class TrayItem : StatusBarItem
<WrapperAttribute("AcTrayItem")> _
Public NotInheritable Class TrayItem _
    Inherits StatusBarItem
[WrapperAttribute(L"AcTrayItem")]
public ref class TrayItem sealed : public StatusBarItem
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TrayItem()()()() |
 | AutoDelete | (Inherited from DisposableWrapper.)
 | CloseBubbleWindows()()()() |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Deleted | (Inherited from StatusBarItem.)
 | DeleteUnmanagedObject()()()() | (Inherited from StatusBarItem.)
 | DisplayContextMenu(ContextMenu, Point) | (Inherited from StatusBarItem.)
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Enabled | (Inherited from StatusBarItem.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Icon | (Inherited from StatusBarItem.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MouseDown | (Inherited from StatusBarItem.)
 | PointToClient(Point) | (Inherited from StatusBarItem.)
 | PointToScreen(Point) | (Inherited from StatusBarItem.)
 | ToolTipText | (Inherited from StatusBarItem.)
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Visible | (Inherited from StatusBarItem.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | StatusBarItem
 |  |  |  | TrayItem

Assembly: ZwManaged (Module: ZwManaged)


TrayItem Constructor

TrayItem Constructor
Namespaces »ZwSoft.ZwCAD.Windows »TrayItem »TrayItem()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TrayItem()
Public Sub New
public:
TrayItem()

Assembly: ZwManaged (Module: ZwManaged)


CloseBubbleWindows Method

CloseBubbleWindows Method
Namespaces »ZwSoft.ZwCAD.Windows »TrayItem »CloseBubbleWindows()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void CloseBubbleWindows()
Public Sub CloseBubbleWindows
public:
void CloseBubbleWindows()

Assembly: ZwManaged (Module: ZwManaged)


TrayItemCollection Class

TrayItemCollection Class
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection
Declaration Syntax
C# Visual Basic Visual C++
public sealed class TrayItemCollection : IList
Public NotInheritable Class TrayItemCollection _
    Implements IList
public ref class TrayItemCollection sealed : IList
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(TrayItem) |
 | Clear()()()() |
 | Contains(TrayItem) |
 | CopyTo(array<TrayItem>[]()[][], Int32) |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ICollection..::..CopyTo(Array, Int32) |
 | IList..::..Add(Object) |
 | IList..::..Contains(Object) |
 | IList..::..IndexOf(Object) |
 | IList..::..Insert(Int32, Object) |
 | IList..::..Item[([( Int32])]) |
 | IList..::..Remove(Object) |
 | IndexOf(TrayItem) |
 | Insert(Int32, TrayItem) |
 | IsFixedSize |
 | IsReadOnly |
 | IsSynchronized |
 | Item[([( Int32])]) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Remove(TrayItem) |
 | RemoveAt(Int32) |
 | SyncRoot |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
TrayItemCollection

Assembly: ZwManaged (Module: ZwManaged)


Add Method (p)

Add Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »Add(TrayItem)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    TrayItem p
)
Public Function Add ( _
    p As TrayItem _
) As Integer
public:
int Add(
    TrayItem^ p
)
Parameters
p(TrayItem)

Assembly: ZwManaged (Module: ZwManaged)


Clear Method

Clear Method
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »Clear()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Assembly: ZwManaged (Module: ZwManaged)


Contains Method (p)

Contains Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »Contains(TrayItem)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    TrayItem p
)
Public Function Contains ( _
    p As TrayItem _
) As Boolean
public:
bool Contains(
    TrayItem^ p
)
Parameters
p(TrayItem)

Assembly: ZwManaged (Module: ZwManaged)


CopyTo Method (a, index)

CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »CopyTo(array<TrayItem>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TrayItem[] a,
    int index
)
Public Sub CopyTo ( _
    a As TrayItem(), _
    index As Integer _
)
public:
void CopyTo(
    array<TrayItem^>^ a,
    int index
)
Parameters
a(array< TrayItem >[]()[][])
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Count Property

Count Property
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »Count
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}

Assembly: ZwManaged (Module: ZwManaged)


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »GetEnumerator()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed

Assembly: ZwManaged (Module: ZwManaged)


ICollection_CopyTo Method (a, index)

ICollection_CopyTo Method (a, index)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »ICollection..::..CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
void ICollection.CopyTo(
    Array a,
    int index
)
Private Sub ICollection_CopyTo ( _
    a As Array, _
    index As Integer _
) Implements ICollection.CopyTo
private:
virtual void ICollection_CopyTo(
    Array^ a,
    int index
) sealed = ICollection::CopyTo
Parameters
a(Array)
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


IList_Add Method (value)

IList_Add Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »IList..::..Add(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.Add(
    Object value
)
Private Function IList_Add ( _
    value As Object _
) As Integer Implements IList.Add
private:
virtual int IList_Add(
    Object^ value
) sealed = IList::Add
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_Contains Method (value)

IList_Contains Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »IList..::..Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
bool IList.Contains(
    Object value
)
Private Function IList_Contains ( _
    value As Object _
) As Boolean Implements IList.Contains
private:
virtual bool IList_Contains(
    Object^ value
) sealed = IList::Contains
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_IndexOf Method (value)

IList_IndexOf Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »IList..::..IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
int IList.IndexOf(
    Object value
)
Private Function IList_IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf
private:
virtual int IList_IndexOf(
    Object^ value
) sealed = IList::IndexOf
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_Insert Method (index, value)

IList_Insert Method (index, value)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »IList..::..Insert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Insert(
    int index,
    Object value
)
Private Sub IList_Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert
private:
virtual void IList_Insert(
    int index,
    Object^ value
) sealed = IList::Insert
Parameters
index(Int32)
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IList_Item Property (index)

IList_Item Property (index)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »IList..::..Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
Object IList.this[
    int index
] { get; set; }
Private Property IList_Item ( _
    index As Integer _
) As Object Implements IList.Item
    Get
    Set
private:
virtual property Object^ IList_Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


IList_Remove Method (value)

IList_Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »IList..::..Remove(Object)
Declaration Syntax
C# Visual Basic Visual C++
void IList.Remove(
    Object value
)
Private Sub IList_Remove ( _
    value As Object _
) Implements IList.Remove
private:
virtual void IList_Remove(
    Object^ value
) sealed = IList::Remove
Parameters
value(Object)

Assembly: ZwManaged (Module: ZwManaged)


IndexOf Method (p)

IndexOf Method (p)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »IndexOf(TrayItem)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    TrayItem p
)
Public Function IndexOf ( _
    p As TrayItem _
) As Integer
public:
int IndexOf(
    TrayItem^ p
)
Parameters
p(TrayItem)

Assembly: ZwManaged (Module: ZwManaged)


Insert Method (index, p)

Insert Method (index, p)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »Insert(Int32, TrayItem)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    TrayItem p
)
Public Sub Insert ( _
    index As Integer, _
    p As TrayItem _
)
public:
void Insert(
    int index,
    TrayItem^ p
)
Parameters
index(Int32)
p(TrayItem)

Assembly: ZwManaged (Module: ZwManaged)


IsFixedSize Property

IsFixedSize Property
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
public:
virtual property bool IsFixedSize {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsReadOnly Property

IsReadOnly Property
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


IsSynchronized Property

IsSynchronized Property
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
public:
virtual property bool IsSynchronized {
    bool get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Item Property (index)

Item Property (index)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public TrayItem this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TrayItem
    Get
    Set
public:
property TrayItem^ default[int index] {
    TrayItem^ get (int index);
    void set (int index, TrayItem^ value);
}
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


Remove Method (value)

Remove Method (value)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »Remove(TrayItem)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    TrayItem value
)
Public Sub Remove ( _
    value As TrayItem _
)
public:
void Remove(
    TrayItem^ value
)
Parameters
value(TrayItem)

Assembly: ZwManaged (Module: ZwManaged)


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index(Int32)

Assembly: ZwManaged (Module: ZwManaged)


SyncRoot Property

SyncRoot Property
Namespaces »ZwSoft.ZwCAD.Windows »TrayItemCollection »SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Visuals Class

Visuals Class
Namespaces »ZwSoft.ZwCAD.Windows »Visuals
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Visuals
Public NotInheritable Class Visuals
public ref class Visuals sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ApplicationIcon |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PickBitmap |
 | PickSetBitmap |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
Visuals

Assembly: ZwManaged (Module: ZwManaged)


ApplicationIcon Property

ApplicationIcon Property
Namespaces »ZwSoft.ZwCAD.Windows »Visuals »ApplicationIcon
Declaration Syntax
C# Visual Basic Visual C++
public static Icon ApplicationIcon { get; }
Public Shared ReadOnly Property ApplicationIcon As Icon
    Get
public:
static property Icon^ ApplicationIcon {
    Icon^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PickBitmap Property

PickBitmap Property
Namespaces »ZwSoft.ZwCAD.Windows »Visuals »PickBitmap
Declaration Syntax
C# Visual Basic Visual C++
public static Image PickBitmap { get; }
Public Shared ReadOnly Property PickBitmap As Image
    Get
public:
static property Image^ PickBitmap {
    Image^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


PickSetBitmap Property

PickSetBitmap Property
Namespaces »ZwSoft.ZwCAD.Windows »Visuals »PickSetBitmap
Declaration Syntax
C# Visual Basic Visual C++
public static Image PickSetBitmap { get; }
Public Shared ReadOnly Property PickSetBitmap As Image
    Get
public:
static property Image^ PickSetBitmap {
    Image^ get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Window Class

Window Class
Namespaces »ZwSoft.ZwCAD.Windows »Window
Declaration Syntax
C# Visual Basic Visual C++
public class Window : DisposableWrapper, IWin32Window
Public Class Window _
    Inherits DisposableWrapper _
    Implements IWin32Window
public ref class Window : public DisposableWrapper,
    IWin32Window
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AutoDelete | (Inherited from DisposableWrapper.)
 | Close()()()() |
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | DeleteUnmanagedObject()()()() | (Overrides DisposableWrapper.DeleteUnmanagedObject()()()().)
 | DeviceIndependentLocation |
 | DeviceIndependentSize |
 | Dispose(Boolean) | (Inherited from DisposableWrapper.)
 | Dispose()()()() | (Inherited from DisposableWrapper.)
 | Equals(Object) | (Inherited from DisposableWrapper.)
 | Finalize()()()() | (Inherited from DisposableWrapper.)
 | GetDeviceIndependentScale(IntPtr) |
 | GetHashCode()()()() | (Inherited from DisposableWrapper.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetType()()()() | (Inherited from Object.)
 | Handle |
 | Icon |
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsDisposed | (Inherited from DisposableWrapper.)
 | Location |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Size |
 | Text |
 | ToString()()()() | (Inherited from Object.)
 | UnmanagedObject | (Inherited from DisposableWrapper.)
 | Visible |
 | WindowState |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DisposableWrapper
 |  |  | Window
 |  |  |  | PaletteSet

Assembly: ZwManaged (Module: ZwManaged)


Close Method

Close Method
Namespaces »ZwSoft.ZwCAD.Windows »Window »Close()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Close()
Public Sub Close
public:
void Close()

Assembly: ZwManaged (Module: ZwManaged)


DeleteUnmanagedObject Method

DeleteUnmanagedObject Method
Namespaces »ZwSoft.ZwCAD.Windows »Window »DeleteUnmanagedObject()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected override void DeleteUnmanagedObject()
Protected Overrides Sub DeleteUnmanagedObject
protected:
virtual void DeleteUnmanagedObject() override

Assembly: ZwManaged (Module: ZwManaged)


DeviceIndependentLocation Property

DeviceIndependentLocation Property
Namespaces »ZwSoft.ZwCAD.Windows »Window »DeviceIndependentLocation
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point DeviceIndependentLocation { get; set; }
Public Overridable Property DeviceIndependentLocation As Point
    Get
    Set
public:
virtual property Point DeviceIndependentLocation {
    Point get ();
    void set (Point value);
}

Assembly: ZwManaged (Module: ZwManaged)


DeviceIndependentSize Property

DeviceIndependentSize Property
Namespaces »ZwSoft.ZwCAD.Windows »Window »DeviceIndependentSize
Declaration Syntax
C# Visual Basic Visual C++
public virtual Size DeviceIndependentSize { get; set; }
Public Overridable Property DeviceIndependentSize As Size
    Get
    Set
public:
virtual property Size DeviceIndependentSize {
    Size get ();
    void set (Size value);
}

Assembly: ZwManaged (Module: ZwManaged)


GetDeviceIndependentScale Method (hWnd)

GetDeviceIndependentScale Method (hWnd)
Namespaces »ZwSoft.ZwCAD.Windows »Window »GetDeviceIndependentScale(IntPtr)
Declaration Syntax
C# Visual Basic Visual C++
public static Vector GetDeviceIndependentScale(
    IntPtr hWnd
)
Public Shared Function GetDeviceIndependentScale ( _
    hWnd As IntPtr _
) As Vector
public:
static Vector GetDeviceIndependentScale(
    IntPtr hWnd
)
Parameters
hWnd(IntPtr)

Assembly: ZwManaged (Module: ZwManaged)


Handle Property

Handle Property
Namespaces »ZwSoft.ZwCAD.Windows »Window »Handle
Declaration Syntax
C# Visual Basic Visual C++
public virtual IntPtr Handle { get; }
Public Overridable ReadOnly Property Handle As IntPtr
    Get
public:
virtual property IntPtr Handle {
    IntPtr get ();
}

Assembly: ZwManaged (Module: ZwManaged)


Icon Property

Icon Property
Namespaces »ZwSoft.ZwCAD.Windows »Window »Icon
Declaration Syntax
C# Visual Basic Visual C++
public virtual Icon Icon { get; set; }
Public Overridable Property Icon As Icon
    Get
    Set
public:
virtual property Icon^ Icon {
    Icon^ get ();
    void set (Icon^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Location Property

Location Property
Namespaces »ZwSoft.ZwCAD.Windows »Window »Location
Declaration Syntax
C# Visual Basic Visual C++
public virtual Point Location { get; set; }
Public Overridable Property Location As Point
    Get
    Set
public:
virtual property Point Location {
    Point get ();
    void set (Point value);
}

Assembly: ZwManaged (Module: ZwManaged)


Size Property

Size Property
Namespaces »ZwSoft.ZwCAD.Windows »Window »Size
Declaration Syntax
C# Visual Basic Visual C++
public virtual Size Size { get; set; }
Public Overridable Property Size As Size
    Get
    Set
public:
virtual property Size Size {
    Size get ();
    void set (Size value);
}

Assembly: ZwManaged (Module: ZwManaged)


Text Property

Text Property
Namespaces »ZwSoft.ZwCAD.Windows »Window »Text
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Text { get; set; }
Public Overridable Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}

Assembly: ZwManaged (Module: ZwManaged)


Visible Property

Visible Property
Namespaces »ZwSoft.ZwCAD.Windows »Window »Visible
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Visible { get; set; }
Public Overridable Property Visible As Boolean
    Get
    Set
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}

Assembly: ZwManaged (Module: ZwManaged)


WindowState Property

WindowState Property
Namespaces »ZwSoft.ZwCAD.Windows »Window »WindowState
Declaration Syntax
C# Visual Basic Visual C++
public virtual Window..::..State WindowState { get; set; }
Public Overridable Property WindowState As Window..::..State
    Get
    Set
public:
virtual property Window..::..State WindowState {
    Window..::..State get ();
    void set (Window..::..State value);
}

Assembly: ZwManaged (Module: ZwManaged)


Window.State Enumeration

Window..::..State Enumeration
Namespaces »ZwSoft.ZwCAD.Windows »Window »Window..::..State
Declaration Syntax
C# Visual Basic Visual C++
public enum State
Public Enumeration State
public enum class State
Members
Member | Description
Maximized |
Minimized |
Normal |

Assembly: ZwManaged (Module: ZwManaged)


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Item Property

Item Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResultImp »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetContinuityAtKnot Method

GetContinuityAtKnot Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetContinuityAtKnot()()()()
Members
Icon | Member | Description
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerGroup »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


ConvertFrom Method

ConvertFrom Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »ConvertFrom()()()()
Members
Icon | Member | Description
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
 | ConvertFrom(Object) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetContinuityAtKnot Method

GetContinuityAtKnot Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetContinuityAtKnot()()()()
Members
Icon | Member | Description
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(PlanarEntity, Tolerance) |
 | IsParallelTo(LinearEntity3d, Tolerance) |
 | IsParallelTo(PlanarEntity) |
 | IsParallelTo(LinearEntity3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(PlanarEntity, Tolerance) |
 | IsPerpendicularTo(LinearEntity3d, Tolerance) |
 | IsPerpendicularTo(PlanarEntity) |
 | IsPerpendicularTo(LinearEntity3d) |


BooleanSubtract Method

BooleanSubtract Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »BooleanSubtract()()()()
Members
Icon | Member | Description
 | BooleanSubtract(Surface) |
 | BooleanSubtract(Solid3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


ConvertFrom Method

ConvertFrom Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »ConvertFrom()()()()
Members
Icon | Member | Description
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
 | ConvertFrom(Object) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GeoLocationData »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraphNode »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


PushPositionTransform Method

PushPositionTransform Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »PushPositionTransform()()()()
Members
Icon | Member | Description
 | PushPositionTransform(PositionBehavior, Point3d) |
 | PushPositionTransform(PositionBehavior, Point2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


CanConvertFrom Method

CanConvertFrom Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »CanConvertFrom()()()()
Members
Icon | Member | Description
 | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter.CanConvertFrom(ITypeDescriptorContext, Type).)
 | CanConvertFrom(Type) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


CanConvertTo Method

CanConvertTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »CanConvertTo()()()()
Members
Icon | Member | Description
 | CanConvertTo(Type) |
 | CanConvertTo(ITypeDescriptorContext, Type) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Filter »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(LinearEntity2d, Tolerance) |
 | IsParallelTo(LinearEntity2d) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Windows »TrayItem »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Filter »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


CopyTo Method

CopyTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<BulgeVertex>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsValid Method

IsValid Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »IsValid()()()()
Members
Icon | Member | Description
 | IsValid(Object) |
 | IsValid(ITypeDescriptorContext, Object) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


IsColinearTo Method

IsColinearTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IsColinearTo()()()()
Members
Icon | Member | Description
 | IsColinearTo(LinearEntity3d, Tolerance) |
 | IsColinearTo(LinearEntity3d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetCreateInstanceSupported Method

GetCreateInstanceSupported Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »GetCreateInstanceSupported()()()()
Members
Icon | Member | Description
 | GetCreateInstanceSupported()()()() |
 | GetCreateInstanceSupported(ITypeDescriptorContext) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Background »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


PushModelTransform Method

PushModelTransform Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »PushModelTransform()()()()
Members
Icon | Member | Description
 | PushModelTransform(Vector3d) |
 | PushModelTransform(Matrix3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(PlanarEntity, Tolerance) |
 | IsPerpendicularTo(LinearEntity3d, Tolerance) |
 | IsPerpendicularTo(PlanarEntity) |
 | IsPerpendicularTo(LinearEntity3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


CreateInstance Method

CreateInstance Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »CreateInstance()()()()
Members
Icon | Member | Description
 | CreateInstance(IDictionary) |
 | CreateInstance(ITypeDescriptorContext, IDictionary) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


GetPropertiesSupported Method

GetPropertiesSupported Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »GetPropertiesSupported()()()()
Members
Icon | Member | Description
 | GetPropertiesSupported()()()() |
 | GetPropertiesSupported(ITypeDescriptorContext) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Windows »Pane »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Contains Method

Contains Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »Contains()()()()
Members
Icon | Member | Description
 | Contains(BulgeVertex) |
 | IList..::..Contains(Object) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


ProjectedIntersectWith Method

ProjectedIntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »ProjectedIntersectWith()()()()
Members
Icon | Member | Description
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) |
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetValue Method

GetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetValue()()()()
Members
Icon | Member | Description
 | GetValue(Int32, Int32, Int32, FormatOption) |
 | GetValue(Int32, Int32) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


ConvertToString Method

ConvertToString Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »ConvertToString()()()()
Members
Icon | Member | Description
 | ConvertToString(Object) |
 | ConvertToString(ITypeDescriptorContext, Object) |
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Add Method

Add Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »Add()()()()
Members
Icon | Member | Description
 | Add(BulgeVertex) |
 | IList..::..Add(Object) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


CreateInstance Method

CreateInstance Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »CreateInstance()()()()
Members
Icon | Member | Description
 | CreateInstance(IDictionary) |
 | CreateInstance(ITypeDescriptorContext, IDictionary) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


ClosestPointToPlanarEntity Method

ClosestPointToPlanarEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »ClosestPointToPlanarEntity()()()()
Members
Icon | Member | Description
 | ClosestPointToPlanarEntity(PlanarEntity, Tolerance) |
 | ClosestPointToPlanarEntity(PlanarEntity) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Background »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetObject Method

GetObject Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TransactionManager »GetObject()()()()
Members
Icon | Member | Description
 | GetObject(ObjectId, OpenMode, Boolean, Boolean) |
 | GetObject(ObjectId, OpenMode, Boolean) |
 | GetObject(ObjectId, OpenMode) |

Assembly: ZwManaged (Module: ZwManaged)


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Windows »StatusBarItem »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


Overlap Method

Overlap Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »Overlap()()()()
Members
Icon | Member | Description
 | Overlap(LinearEntity2d, Tolerance) |
 | Overlap(LinearEntity2d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Windows »Window »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Tolerance) |
 | IsOn(Point2d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity2d, Tolerance) |
 | IntersectWith(LinearEntity2d) |


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(PlanarEntity, Tolerance) |
 | IsParallelTo(LinearEntity3d, Tolerance) |
 | IsParallelTo(PlanarEntity) |
 | IsParallelTo(LinearEntity3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicBlockReferencePropertyCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


UpdateDataLink Method

UpdateDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »UpdateDataLink()()()()
Members
Icon | Member | Description
 | UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) |
 | UpdateDataLink(UpdateDirection, UpdateOption) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableTraits »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Tolerance) |
 | IsOn(Point2d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollectionEnumerator »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldDraw »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(PlanarEntity, Tolerance) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(PlanarEntity) |
 | IntersectWith(LinearEntity3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Runtime »ExtensionLoader »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaceHolder »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GeoLocationData »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplayStyle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextManager »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Overlap Method

Overlap Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »Overlap()()()()
Members
Icon | Member | Description
 | Overlap(LinearEntity3d, Tolerance) |
 | Overlap(LinearEntity3d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


CircularArc Method

CircularArc Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »CircularArc()()()()
Members
Icon | Member | Description
 | CircularArc(Point3d, Double, Vector3d, Vector3d, Double, ArcType) |
 | CircularArc(Point3d, Point3d, Point3d, ArcType) |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Text Method

Text Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »Text()()()()
Members
Icon | Member | Description
 | Text(Point3d, Vector3d, Vector3d, Double, Double, Double, String) |
 | Text(Point3d, Vector3d, Vector3d, String, Boolean, TextStyle) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(PlanarEntity, Tolerance) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(PlanarEntity) |
 | IntersectWith(LinearEntity3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »GetEnumerator()()()()
Members
Icon | Member | Description
 | GetEnumerator(TableEnumeratorOption) |
 | GetEnumerator()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits2 »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RenderSettingsTraits »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


ClosestPointToLinearEntity Method

ClosestPointToLinearEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »ClosestPointToLinearEntity()()()()
Members
Icon | Member | Description
 | ClosestPointToLinearEntity(LinearEntity3d, Tolerance) |
 | ClosestPointToLinearEntity(LinearEntity3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


Overlap Method

Overlap Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »Overlap()()()()
Members
Icon | Member | Description
 | Overlap(LinearEntity2d, Tolerance) |
 | Overlap(LinearEntity2d) |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Tolerance) |
 | IsOn(Point2d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


SetOverride Method

SetOverride Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »SetOverride()()()()
Members
Icon | Member | Description
 | SetOverride(Int32, Int32, Int32, CellProperties) |
 | SetOverride(Int32, Int32, GridLineType, GridProperties) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightTraits »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIterator »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetStandardValues Method

GetStandardValues Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »GetStandardValues()()()()
Members
Icon | Member | Description
 | GetStandardValues()()()() |
 | GetStandardValues(ITypeDescriptorContext) |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Filter »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetCreateInstanceSupported Method

GetCreateInstanceSupported Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »GetCreateInstanceSupported()()()()
Members
Icon | Member | Description
 | GetCreateInstanceSupported()()()() |
 | GetCreateInstanceSupported(ITypeDescriptorContext) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSetDelayMarshalled »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetStandardValues Method

GetStandardValues Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »GetStandardValues()()()()
Members
Icon | Member | Description
 | GetStandardValues()()()() |
 | GetStandardValues(ITypeDescriptorContext) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldDraw »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »IntegerCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


GetStandardValuesExclusive Method

GetStandardValuesExclusive Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »GetStandardValuesExclusive()()()()
Members
Icon | Member | Description
 | GetStandardValuesExclusive()()()() |
 | GetStandardValuesExclusive(ITypeDescriptorContext) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableEnumerator »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


CopyTo Method

CopyTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DBObjectReference>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomObjectSnapMode »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(LinearEntity2d, Tolerance) |
 | IsPerpendicularTo(LinearEntity2d) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetStandardValuesExclusive Method

GetStandardValuesExclusive Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »GetStandardValuesExclusive()()()()
Members
Icon | Member | Description
 | GetStandardValuesExclusive()()()() |
 | GetStandardValuesExclusive(ITypeDescriptorContext) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Contains Method

Contains Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »Contains()()()()
Members
Icon | Member | Description
 | Contains(String) |
 | Contains(ObjectId) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Remove Method

Remove Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »Remove()()()()
Members
Icon | Member | Description
 | Remove(DBObjectReference) |
 | IList..::..Remove(Object) |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


SetDataLink Method

SetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »SetDataLink()()()()
Members
Icon | Member | Description
 | SetDataLink(Int32, Int32, ObjectId, Boolean) |
 | SetDataLink(CellRange, ObjectId, Boolean) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Windows »TrayItem »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


GetDataLink Method

GetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetDataLink()()()()
Members
Icon | Member | Description
 | GetDataLink(Int32, Int32) |
 | GetDataLink(CellRange) |
 | GetDataLink()()()() |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaceHolder »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraph »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity2d, Tolerance) |
 | IntersectWith(LinearEntity2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdGraph »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits2 »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Colors »Color »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DisplayStyle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GeoLocationData »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLink »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerStateManager »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IndexOf Method

IndexOf Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DBObjectReference) |
 | IList..::..IndexOf(Object) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetStandardValuesSupported Method

GetStandardValuesSupported Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »GetStandardValuesSupported()()()()
Members
Icon | Member | Description
 | GetStandardValuesSupported()()()() |
 | GetStandardValuesSupported(ITypeDescriptorContext) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »View »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BooleanSubtract Method

BooleanSubtract Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »BooleanSubtract()()()()
Members
Icon | Member | Description
 | BooleanSubtract(Surface) |
 | BooleanSubtract(Solid3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIterator »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TransactionManager »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


Polyline Method

Polyline Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »Polyline()()()()
Members
Icon | Member | Description
 | Polyline(Point3dCollection, Vector3d, IntPtr) |
 | Polyline(Polyline, Int32, Int32) |
 | Polyline(Polyline) |


ConvertFromString Method

ConvertFromString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »ConvertFromString()()()()
Members
Icon | Member | Description
 | ConvertFromString(String) |
 | ConvertFromString(ITypeDescriptorContext, String) |
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


CopyFrom Method

CopyFrom Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Variant »CopyFrom()()()()
Members
Icon | Member | Description
 | CopyFrom(Variant) |
 | CopyFrom(RXObject) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetContinuityAtKnot Method

GetContinuityAtKnot Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetContinuityAtKnot()()()()
Members
Icon | Member | Description
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayHost »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetPropertiesSupported Method

GetPropertiesSupported Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »GetPropertiesSupported()()()()
Members
Icon | Member | Description
 | GetPropertiesSupported()()()() |
 | GetPropertiesSupported(ITypeDescriptorContext) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


Overlap Method

Overlap Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »Overlap()()()()
Members
Icon | Member | Description
 | Overlap(LinearEntity2d, Tolerance) |
 | Overlap(LinearEntity2d) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContext »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »TextStyle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


GetContinuityAtKnot Method

GetContinuityAtKnot Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »GetContinuityAtKnot()()()()
Members
Icon | Member | Description
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnSurface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Overlap Method

Overlap Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »Overlap()()()()
Members
Icon | Member | Description
 | Overlap(LinearEntity3d, Tolerance) |
 | Overlap(LinearEntity3d) |


CompareTo Method

CompareTo Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerGroup »CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(LayerFilter) |
 | CompareTo(Object) |


Circle Method

Circle Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »Circle()()()()
Members
Icon | Member | Description
 | Circle(Point3d, Double, Vector3d) |
 | Circle(Point3d, Point3d, Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


GetContinuityAtKnot Method

GetContinuityAtKnot Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetContinuityAtKnot()()()()
Members
Icon | Member | Description
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


SetDataLink Method

SetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »SetDataLink()()()()
Members
Icon | Member | Description
 | SetDataLink(Int32, Int32, ObjectId, Boolean) |
 | SetDataLink(CellRange, ObjectId, Boolean) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »IdMapping »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetUcs Method

SetUcs Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »SetUcs()()()()
Members
Icon | Member | Description
 | SetUcs(Point3d, Vector3d, Vector3d) |
 | SetUcs(OrthographicView) |
 | SetUcs(ObjectId) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BooleanSubtract Method

BooleanSubtract Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »BooleanSubtract()()()()
Members
Icon | Member | Description
 | BooleanSubtract(Surface) |
 | BooleanSubtract(Solid3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Material »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »GetEnumerator()()()()
Members
Icon | Member | Description
 | GetEnumerator(TableEnumeratorOption) |
 | GetEnumerator()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GeometryExtentsBestFit Method

GeometryExtentsBestFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GeometryExtentsBestFit()()()()
Members
Icon | Member | Description
 | GeometryExtentsBestFit(Matrix3d) |
 | GeometryExtentsBestFit()()()() |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PointRef »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetEnumerator Method

GetEnumerator Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »GetEnumerator()()()()
Members
Icon | Member | Description
 | GetEnumerator(TableEnumeratorOption) |
 | GetEnumerator()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataColumn »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GeoLocationData »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BooleanSubtract Method

BooleanSubtract Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »BooleanSubtract()()()()
Members
Icon | Member | Description
 | BooleanSubtract(Surface) |
 | BooleanSubtract(Solid3d) |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluatorLoader »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


IsColinearTo Method

IsColinearTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »IsColinearTo()()()()
Members
Icon | Member | Description
 | IsColinearTo(LinearEntity2d, Tolerance) |
 | IsColinearTo(LinearEntity2d) |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightAttenuation »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Material »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetDataLink Method

SetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetDataLink()()()()
Members
Icon | Member | Description
 | SetDataLink(Int32, Int32, ObjectId, Boolean) |
 | SetDataLink(CellRange, ObjectId, Boolean) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MatchProperties »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


ConvertTo Method

ConvertTo Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »ConvertTo()()()()
Members
Icon | Member | Description
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsColinearTo Method

IsColinearTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IsColinearTo()()()()
Members
Icon | Member | Description
 | IsColinearTo(LinearEntity3d, Tolerance) |
 | IsColinearTo(LinearEntity3d) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


ConvertToInvariantString Method

ConvertToInvariantString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »ConvertToInvariantString()()()()
Members
Icon | Member | Description
 | ConvertToInvariantString(Object) |
 | ConvertToInvariantString(ITypeDescriptorContext, Object) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Manager »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnUnderlayItem »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


CompareTo Method

CompareTo Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »CompareTo()()()()
Members
Icon | Member | Description
 | CompareTo(LayerFilter) |
 | CompareTo(Object) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Circle Method

Circle Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »Circle()()()()
Members
Icon | Member | Description
 | Circle(Point3d, Double, Vector3d) |
 | Circle(Point3d, Point3d, Point3d) |


GetValue Method

GetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »GetValue()()()()
Members
Icon | Member | Description
 | GetValue(Int32, Int32, Int32, FormatOption) |
 | GetValue(Int32, Int32) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


SetClipBoundary Method

SetClipBoundary Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »SetClipBoundary()()()()
Members
Icon | Member | Description
 | SetClipBoundary(ClipBoundaryType, Point2dCollection) |
 | SetClipBoundary(Vector2d) |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetProperties Method

GetProperties Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »GetProperties()()()()
Members
Icon | Member | Description
 | GetProperties(Object) |
 | GetProperties(ITypeDescriptorContext, Object) |
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) |


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


IsColinearTo Method

IsColinearTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »IsColinearTo()()()()
Members
Icon | Member | Description
 | IsColinearTo(LinearEntity2d, Tolerance) |
 | IsColinearTo(LinearEntity2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DBObject.Dispose(Boolean).)
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaceHolder »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Overlap Method

Overlap Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »Overlap()()()()
Members
Icon | Member | Description
 | Overlap(LinearEntity3d, Tolerance) |
 | Overlap(LinearEntity3d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbDictionaryEnumerator »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


ToString Method

ToString Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSetDelayMarshalled »ToString()()()()
Members
Icon | Member | Description
 | ToString(IFormatProvider) |
 | ToString()()()() | (Overrides Object.ToString()()()().)

Assembly: ZwManaged (Module: ZwManaged)


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetContinuityAtKnot Method

GetContinuityAtKnot Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetContinuityAtKnot()()()()
Members
Icon | Member | Description
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


CanConvertFrom Method

CanConvertFrom Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »CanConvertFrom()()()()
Members
Icon | Member | Description
 | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter.CanConvertFrom(ITypeDescriptorContext, Type).)
 | CanConvertFrom(Type) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


ConvertToStaticBlock Method

ConvertToStaticBlock Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »ConvertToStaticBlock()()()()
Members
Icon | Member | Description
 | ConvertToStaticBlock(String) |
 | ConvertToStaticBlock()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IsCoplanarTo Method

IsCoplanarTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IsCoplanarTo()()()()
Members
Icon | Member | Description
 | IsCoplanarTo(PlanarEntity, Tolerance) |
 | IsCoplanarTo(PlanarEntity) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayHost »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveBoundary »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftOptions »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


CanConvertTo Method

CanConvertTo Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »CanConvertTo()()()()
Members
Icon | Member | Description
 | CanConvertTo(Type) |
 | CanConvertTo(ITypeDescriptorContext, Type) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »DocumentCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »MentalRayRenderSettingsTraits »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetOverride Method

GetOverride Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »GetOverride()()()()
Members
Icon | Member | Description
 | GetOverride(Int32, Int32, Int32) |
 | GetOverride(Int32, Int32, GridLineType) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetStandardValuesSupported Method

GetStandardValuesSupported Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »GetStandardValuesSupported()()()()
Members
Icon | Member | Description
 | GetStandardValuesSupported()()()() |
 | GetStandardValuesSupported(ITypeDescriptorContext) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


CanConvertTo Method

CanConvertTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »CanConvertTo()()()()
Members
Icon | Member | Description
 | CanConvertTo(Type) |
 | CanConvertTo(ITypeDescriptorContext, Type) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


PushScaleTransform Method

PushScaleTransform Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »PushScaleTransform()()()()
Members
Icon | Member | Description
 | PushScaleTransform(ScaleBehavior, Point3d) |
 | PushScaleTransform(ScaleBehavior, Point2d) |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Graph »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayFile »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetValue Method

SetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetValue()()()()
Members
Icon | Member | Description
 | SetValue(Int32, Int32, Int32, Object, ParseOption) |
 | SetValue(Int32, Int32, Object) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Insert Method

Insert Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, BulgeVertex) |
 | IList..::..Insert(Int32, Object) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetValue Method

SetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »SetValue()()()()
Members
Icon | Member | Description
 | SetValue(Int32, Int32, Int32, Object, ParseOption) |
 | SetValue(Int32, Int32, Object) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Colors »Color »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(PlanarEntity, Tolerance) |
 | IsPerpendicularTo(LinearEntity3d, Tolerance) |
 | IsPerpendicularTo(PlanarEntity) |
 | IsPerpendicularTo(LinearEntity3d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »TransactionManager »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionDataCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyleTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(LinearEntity2d, Tolerance) |
 | IsPerpendicularTo(LinearEntity2d) |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Item Property

Item Property
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Tolerance) |
 | IsOn(Point2d) |


CopyTo Method

CopyTo Method
Namespaces »ZwSoft.ZwCAD.EditorInput »SelectionSetDelayMarshalled »CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SelectedObject>[]()[][], Int32) |
 | CopyTo(Array, Int32) |

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Runtime »DictionaryIterator »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


BooleanIntersect Method

BooleanIntersect Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »BooleanIntersect()()()()
Members
Icon | Member | Description
 | BooleanIntersect(Surface) |
 | BooleanIntersect(Solid3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Background »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotPageInfo »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgress »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


ConvertToInvariantString Method

ConvertToInvariantString Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »ConvertToInvariantString()()()()
Members
Icon | Member | Description
 | ConvertToInvariantString(Object) |
 | ConvertToInvariantString(ITypeDescriptorContext, Object) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Device »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportDraw »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point2dCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(LinearEntity2d, Tolerance) |
 | IntersectWith(LinearEntity2d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextCollectionEnumerator »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GeoLocationData »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Windows »PaletteSet »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


CircularArc Method

CircularArc Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »CircularArc()()()()
Members
Icon | Member | Description
 | CircularArc(Point3d, Double, Vector3d, Vector3d, Double, ArcType) |
 | CircularArc(Point3d, Point3d, Point3d, ArcType) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GeoLocationData »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Background »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FormattedTableData »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaceHolder »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Runtime »DisposableWrapper »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »KnotCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Filter »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(LinearEntity2d, Tolerance) |
 | IsParallelTo(LinearEntity2d) |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetPropertiesSupported Method

GetPropertiesSupported Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »GetPropertiesSupported()()()()
Members
Icon | Member | Description
 | GetPropertiesSupported()()()() |
 | GetPropertiesSupported(ITypeDescriptorContext) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetStandardValuesExclusive Method

GetStandardValuesExclusive Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »GetStandardValuesExclusive()()()()
Members
Icon | Member | Description
 | GetStandardValuesExclusive()()()() |
 | GetStandardValuesExclusive(ITypeDescriptorContext) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


CanConvertFrom Method

CanConvertFrom Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »CanConvertFrom()()()()
Members
Icon | Member | Description
 | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter.CanConvertFrom(ITypeDescriptorContext, Type).)
 | CanConvertFrom(Type) |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


UpdateDataLink Method

UpdateDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »UpdateDataLink()()()()
Members
Icon | Member | Description
 | UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) |
 | UpdateDataLink(UpdateDirection, UpdateOption) |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Filter »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Drawable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


PushModelTransform Method

PushModelTransform Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »PushModelTransform()()()()
Members
Icon | Member | Description
 | PushModelTransform(Vector3d) |
 | PushModelTransform(Matrix3d) |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettingsValidator »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »EdgeStyle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecordEnumerator »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Tolerance) |
 | IsOn(Point2d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotProgressDialog »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DBObject.Dispose(Boolean).)
 | Dispose()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PreviewEndPlotInfo »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DBObject.Dispose(Boolean).)
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


ClosestPointToPlanarEntity Method

ClosestPointToPlanarEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »ClosestPointToPlanarEntity()()()()
Members
Icon | Member | Description
 | ClosestPointToPlanarEntity(PlanarEntity, Tolerance) |
 | ClosestPointToPlanarEntity(PlanarEntity) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Filter »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContextManager »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectContext »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Plane, Tolerance) |
 | IsOn(Plane) |
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


ConvertToInvariantString Method

ConvertToInvariantString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »ConvertToInvariantString()()()()
Members
Icon | Member | Description
 | ConvertToInvariantString(Object) |
 | ConvertToInvariantString(ITypeDescriptorContext, Object) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AuditInfo »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnUnderlayItem »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PreviewEndPlotInfo »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotConfig »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Publishing »Publisher »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraph »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(PlanarEntity, Tolerance) |
 | IntersectWith(LinearEntity3d, Tolerance) |
 | IntersectWith(PlanarEntity) |
 | IntersectWith(LinearEntity3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


ToPolyline Method

ToPolyline Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »ToPolyline()()()()
Members
Icon | Member | Description
 | ToPolyline(UInt32) |
 | ToPolyline()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »FilteredBlockIterator »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


ClosestPointToLinearEntity Method

ClosestPointToLinearEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »ClosestPointToLinearEntity()()()()
Members
Icon | Member | Description
 | ClosestPointToLinearEntity(LinearEntity3d, Tolerance) |
 | ClosestPointToLinearEntity(LinearEntity3d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItem »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetStandardValuesSupported Method

GetStandardValuesSupported Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »GetStandardValuesSupported()()()()
Members
Icon | Member | Description
 | GetStandardValuesSupported()()()() |
 | GetStandardValuesSupported(ITypeDescriptorContext) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaceHolder »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


Remove Method

Remove Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »Remove()()()()
Members
Icon | Member | Description
 | Remove(String) |
 | Remove(ObjectId) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DxfFiler »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »XrefGraphNode »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Polyline Method

Polyline Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »Polyline()()()()
Members
Icon | Member | Description
 | Polyline(Point3dCollection, Vector3d, IntPtr) |
 | Polyline(Polyline, Int32, Int32) |
 | Polyline(Polyline) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayoutManager »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »ImpDevice »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »DrawableTraits »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MatchProperties »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluatorLoader »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Surface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayItem »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbHomeView »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


ProjectedIntersectWith Method

ProjectedIntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »ProjectedIntersectWith()()()()
Members
Icon | Member | Description
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) |
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


ConvertFrom Method

ConvertFrom Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »ConvertFrom()()()()
Members
Icon | Member | Description
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
 | ConvertFrom(Object) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Viewport »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xrecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImageDef »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolveOptions »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableEnumerator »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Tolerance) |
 | IsOn(Point2d) |


BooleanIntersect Method

BooleanIntersect Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »BooleanIntersect()()()()
Members
Icon | Member | Description
 | BooleanIntersect(Surface) |
 | BooleanIntersect(Solid3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Region »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetContinuityAtKnot Method

GetContinuityAtKnot Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetContinuityAtKnot()()()()
Members
Icon | Member | Description
 | GetContinuityAtKnot(Int32, Tolerance) |
 | GetContinuityAtKnot(Int32) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBPoint »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DbHomeView »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Material »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayer »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(PlanarEntity, Tolerance) |
 | IsPerpendicularTo(LinearEntity3d, Tolerance) |
 | IsPerpendicularTo(PlanarEntity) |
 | IsPerpendicularTo(LinearEntity3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Filter »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBDictionary »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


ConvertTo Method

ConvertTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »ConvertTo()()()()
Members
Icon | Member | Description
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


ConvertFromString Method

ConvertFromString Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »ConvertFromString()()()()
Members
Icon | Member | Description
 | ConvertFromString(String) |
 | ConvertFromString(ITypeDescriptorContext, String) |
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) |


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


SetOverride Method

SetOverride Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »SetOverride()()()()
Members
Icon | Member | Description
 | SetOverride(Int32, Int32, Int32, CellProperties) |
 | SetOverride(Int32, Int32, GridLineType, GridProperties) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


PushPositionTransform Method

PushPositionTransform Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »PushPositionTransform()()()()
Members
Icon | Member | Description
 | PushPositionTransform(PositionBehavior, Point3d) |
 | PushPositionTransform(PositionBehavior, Point2d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


OpenedForModify Method

OpenedForModify Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »OpenedForModify()()()()
Members
Icon | Member | Description
 | OpenedForModify(DBObject) |
 | OpenedForModify |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(PlanarEntity, Tolerance) |
 | IsParallelTo(LinearEntity3d, Tolerance) |
 | IsParallelTo(PlanarEntity) |
 | IsParallelTo(LinearEntity3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Contains Method

Contains Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »Contains()()()()
Members
Icon | Member | Description
 | Contains(DBObjectReference) |
 | IList..::..Contains(Object) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Runtime »RXClass »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsSystem »Model »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BooleanIntersect Method

BooleanIntersect Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »BooleanIntersect()()()()
Members
Icon | Member | Description
 | BooleanIntersect(Surface) |
 | BooleanIntersect(Solid3d) |


ConvertToString Method

ConvertToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »ConvertToString()()()()
Members
Icon | Member | Description
 | ConvertToString(Object) |
 | ConvertToString(ITypeDescriptorContext, Object) |
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Material »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotLogger »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OsnapPointRef »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


ConvertFromInvariantString Method

ConvertFromInvariantString Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »ConvertFromInvariantString()()()()
Members
Icon | Member | Description
 | ConvertFromInvariantString(String) |
 | ConvertFromInvariantString(ITypeDescriptorContext, String) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEvaluator »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Plane, Tolerance) |
 | IsOn(Plane) |
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(PlanarEntity, Tolerance) |
 | IsParallelTo(LinearEntity3d, Tolerance) |
 | IsParallelTo(PlanarEntity) |
 | IsParallelTo(LinearEntity3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNodeCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotSettings »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayFile »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Mapper »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment2d »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(LinearEntity2d, Tolerance) |
 | IsParallelTo(LinearEntity2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerFilter »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetValue Method

GetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »GetValue()()()()
Members
Icon | Member | Description
 | GetValue(Int32, Int32, Int32, FormatOption) |
 | GetValue(Int32, Int32) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaceHolder »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResultImp »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


ProjectedIntersectWith Method

ProjectedIntersectWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »ProjectedIntersectWith()()()()
Members
Icon | Member | Description
 | ProjectedIntersectWith(LinearEntity3d, Vector3d, Tolerance) |
 | ProjectedIntersectWith(LinearEntity3d, Vector3d) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »GIRasterImage »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MTextFragment »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


ConvertFromInvariantString Method

ConvertFromInvariantString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »ConvertFromInvariantString()()()()
Members
Icon | Member | Description
 | ConvertFromInvariantString(String) |
 | ConvertFromInvariantString(ITypeDescriptorContext, String) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HostApplicationServices »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


ConvertTo Method

ConvertTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »ConvertTo()()()()
Members
Icon | Member | Description
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »ClipBoundary2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LinetypeCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Publishing »Dwf3dNavigationTreeNode »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


ConvertToStaticBlock Method

ConvertToStaticBlock Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »ConvertToStaticBlock()()()()
Members
Icon | Member | Description
 | ConvertToStaticBlock(String) |
 | ConvertToStaticBlock()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


CopyFrom Method

CopyFrom Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »CopyFrom()()()()
Members
Icon | Member | Description
 | CopyFrom(VisualStyle) |
 | CopyFrom(RXObject) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Plane, Tolerance) |
 | IsOn(Plane) |
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Runtime »DynamicLinker »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


SetUcs Method

SetUcs Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »SetUcs()()()()
Members
Icon | Member | Description
 | SetUcs(Point3d, Vector3d, Vector3d) |
 | SetUcs(OrthographicView) |
 | SetUcs(ObjectId) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalSurface »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportDraw »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »IndexUpdateData »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundBlock2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


UpdateDataLink Method

UpdateDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »UpdateDataLink()()()()
Members
Icon | Member | Description
 | UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) |
 | UpdateDataLink(UpdateDirection, UpdateOption) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweepOptions »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfo »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetSurface »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Hatch »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SequenceEnd »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Material »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Background »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsPlanar Method

IsPlanar Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsPlanar()()()()
Members
Icon | Member | Description
 | IsPlanar(Plane%, Tolerance) |
 | IsPlanar(Plane%) |


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


DistanceTo Method

DistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »DistanceTo()()()()
Members
Icon | Member | Description
 | DistanceTo(Point3d, Tolerance) |
 | DistanceTo(Point3d) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DictionaryWithDefaultDictionary »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


GetFirstDerivative Method

GetFirstDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »GetFirstDerivative()()()()
Members
Icon | Member | Description
 | GetFirstDerivative(Double) |
 | GetFirstDerivative(Point3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Copied Method

Copied Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »Copied()()()()
Members
Icon | Member | Description
 | Copied(DBObject, DBObject) |
 | Copied |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IndexOf Method

IndexOf Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(BulgeVertex) |
 | IList..::..IndexOf(Object) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Runtime »RXObject »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point2d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point2d, Double%) |
 | IsOn(Point2d, Tolerance) |
 | IsOn(Double) |
 | IsOn(Point2d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Entity2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GroundPlaneBackground »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyObject »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableStyle »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FaceRecord »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfReference »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »Index »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotEngine »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Text Method

Text Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »Text()()()()
Members
Icon | Member | Description
 | Text(Point3d, Vector3d, Vector3d, Double, Double, Double, String) |
 | Text(Point3d, Vector3d, Vector3d, String, Boolean, TextStyle) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripDataCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetArea Method

GetArea Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetArea()()()()
Members
Icon | Member | Description
 | GetArea(Double, Double, Tolerance) |
 | GetArea(Double, Double) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Position2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3dCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetStandardValues Method

GetStandardValues Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »GetStandardValues()()()()
Members
Icon | Member | Description
 | GetStandardValues()()()() |
 | GetStandardValues(ITypeDescriptorContext) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdData »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Viewport »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line2d%, Tolerance) |
 | IsLinear(Line2d%) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


Namespaces

Namespaces
Namespaces
Namespaces
Namespace | Description
(Default Namespace) |
Microsoft.VisualC.MFC |
ZwSoft.ZwCAD.ApplicationServices |
ZwSoft.ZwCAD.Colors |
ZwSoft.ZwCAD.DatabaseServices |
ZwSoft.ZwCAD.DatabaseServices.Filters |
ZwSoft.ZwCAD.EditorInput |
ZwSoft.ZwCAD.Geometry |
ZwSoft.ZwCAD.GraphicsInterface |
ZwSoft.ZwCAD.GraphicsSystem |
ZwSoft.ZwCAD.Internal |
ZwSoft.ZwCAD.LayerManager |
ZwSoft.ZwCAD.PlottingServices |
ZwSoft.ZwCAD.Publishing |
ZwSoft.ZwCAD.Runtime |
ZwSoft.ZwCAD.Windows |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotPageInfo »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2dCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetCreateInstanceSupported Method

GetCreateInstanceSupported Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »GetCreateInstanceSupported()()()()
Members
Icon | Member | Description
 | GetCreateInstanceSupported()()()() |
 | GetCreateInstanceSupported(ITypeDescriptorContext) |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetOverride Method

GetOverride Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »GetOverride()()()()
Members
Icon | Member | Description
 | GetOverride(Int32, Int32, Int32) |
 | GetOverride(Int32, Int32, GridLineType) |


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Image »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FileDependencyManager »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »NonEntityTraits »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


PushScaleTransform Method

PushScaleTransform Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »PushScaleTransform()()()()
Members
Icon | Member | Description
 | PushScaleTransform(ScaleBehavior, Point3d) |
 | PushScaleTransform(ScaleBehavior, Point2d) |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimAssoc »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Material »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeaderStyle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Entity »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BooleanSubtract Method

BooleanSubtract Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »BooleanSubtract()()()()
Members
Icon | Member | Description
 | BooleanSubtract(Surface) |
 | BooleanSubtract(Solid3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(LinearEntity2d, Tolerance) |
 | IsPerpendicularTo(LinearEntity2d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTableRecord »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Geometry »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.ApplicationServices »Document »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialFilter »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MlineStyle »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCell »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point2d, Tolerance) |
 | GetDistanceTo(Curve2d, Tolerance) |
 | GetDistanceTo(Point2d) |
 | GetDistanceTo(Curve2d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaceHolder »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


CreateInstance Method

CreateInstance Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »CreateInstance()()()()
Members
Icon | Member | Description
 | CreateInstance(IDictionary) |
 | CreateInstance(ITypeDescriptorContext, IDictionary) |


IsLinear Method

IsLinear Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity3d »IsLinear()()()()
Members
Icon | Member | Description
 | IsLinear(Line3d%, Tolerance) |
 | IsLinear(Line3d%) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayLayer »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetValue Method

SetValue Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »SetValue()()()()
Members
Icon | Member | Description
 | SetValue(Int32, Int32, Int32, Object, ParseOption) |
 | SetValue(Int32, Int32, Object) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve2d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Group »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMesh »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Transaction »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Field »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DrawOrderTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionSettings »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »PlotInfoValidator »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetOrthoProjectEntity Method

GetOrthoProjectEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »GetOrthoProjectEntity()()()()
Members
Icon | Member | Description
 | GetOrthoProjectEntity(Plane, Tolerance) |
 | GetOrthoProjectEntity(Plane) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTableRecord »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnDefinition »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ArcDimension »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewportTableRecord »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »FaceStyle »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterVariables »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointEntity3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


ConvertFromInvariantString Method

ConvertFromInvariantString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »ConvertFromInvariantString()()()()
Members
Icon | Member | Description
 | ConvertFromInvariantString(String) |
 | ConvertFromInvariantString(ITypeDescriptorContext, String) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


IsClosedInU Method

IsClosedInU Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »IsClosedInU()()()()
Members
Icon | Member | Description
 | IsClosedInU(Tolerance) |
 | IsClosedInU()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetProjectedEntity Method

GetProjectedEntity Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »GetProjectedEntity()()()()
Members
Icon | Member | Description
 | GetProjectedEntity(Plane, Vector3d, Tolerance) |
 | GetProjectedEntity(Plane, Vector3d) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AlignedDimension »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetDataLink Method

GetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »GetDataLink()()()()
Members
Icon | Member | Description
 | GetDataLink(Int32, Int32) |
 | GetDataLink(CellRange) |
 | GetDataLink()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ResultBuffer »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Polypoint Method

Polypoint Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ViewportGeometry »Polypoint()()()()
Members
Icon | Member | Description
 | Polypoint(Point3dCollection, EntityColorCollection, Vector3dCollection, IntPtrCollection) |
 | Polypoint(Point3dCollection, Vector3dCollection, IntPtrCollection) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CurveCurveIntersector3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinetypeTable »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedTableData »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Face »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetSecondDerivative Method

GetSecondDerivative Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetSecondDerivative()()()()
Members
Icon | Member | Description
 | GetSecondDerivative(Double) |
 | GetSecondDerivative(Point3d) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ProxyEntity »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Table »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point3d, Tolerance) |
 | GetParameterOf(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolygonMeshVertex »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GradientBackground »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »VisualStyle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Runtime »DictionaryIterator »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTableRecord »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GeometryExtentsBestFit Method

GeometryExtentsBestFit Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »GeometryExtentsBestFit()()()()
Members
Icon | Member | Description
 | GeometryExtentsBestFit(Matrix3d) |
 | GeometryExtentsBestFit()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RevolvedSurface »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


IsValid Method

IsValid Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »IsValid()()()()
Members
Icon | Member | Description
 | IsValid(Object) |
 | IsValid(ITypeDescriptorContext, Object) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »LayerIndex »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LinkedData »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTable »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »RenderSettingsTraits »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsClosedInV Method

IsClosedInV Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IsClosedInV()()()()
Members
Icon | Member | Description
 | IsClosedInV(Tolerance) |
 | IsClosedInV()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Curve3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsColinearTo Method

IsColinearTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IsColinearTo()()()()
Members
Icon | Member | Description
 | IsColinearTo(LinearEntity3d, Tolerance) |
 | IsColinearTo(LinearEntity3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntry »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »LinearEntity2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DgnReference »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line3d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »ExternalBoundedSurface »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »HyperLinkCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Remove Method

Remove Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BulgeVertexCollection »Remove()()()()
Members
Icon | Member | Description
 | Remove(BulgeVertex) |
 | IList..::..Remove(Object) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


ConvertFromString Method

ConvertFromString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »ConvertFromString()()()()
Members
Icon | Member | Description
 | ConvertFromString(String) |
 | ConvertFromString(ITypeDescriptorContext, String) |
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


SetFromGeCurve Method

SetFromGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »SetFromGeCurve()()()()
Members
Icon | Member | Description
 | SetFromGeCurve(Curve3d, Vector3d, Tolerance) |
 | SetFromGeCurve(Curve3d, Vector3d) |
 | SetFromGeCurve(Curve3d, Tolerance) |
 | SetFromGeCurve(Curve3d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeDefinition »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResult »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


IsValid Method

IsValid Method
Namespaces »ZwSoft.ZwCAD.Colors »ColorConverter »IsValid()()()()
Members
Icon | Member | Description
 | IsValid(Object) |
 | IsValid(ITypeDescriptorContext, Object) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Point2d%, Tolerance) |
 | IsOn(Point3d, Point2d%) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ClipBoundary »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Has Method

Has Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RegAppTable »Has()()()()
Members
Icon | Member | Description
 | Has(String) |
 | Has(ObjectId) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SectionManager »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


GetType Method

GetType Method
Namespaces »ZwSoft.ZwCAD.Geometry »SurfaceSurfaceIntersector »GetType()()()()
Members
Icon | Member | Description
 | GetType(Int32) |
 | GetType()()()() |


GetLength Method

GetLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »Line2d »GetLength()()()()
Members
Icon | Member | Description
 | GetLength(Double, Double, Tolerance) |
 | GetLength(Double, Double) |


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »PointOnCurve3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


IsCoplanarTo Method

IsCoplanarTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IsCoplanarTo()()()()
Members
Icon | Member | Description
 | IsCoplanarTo(PlanarEntity, Tolerance) |
 | IsCoplanarTo(PlanarEntity) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LayerTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Trace »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetParameterOf Method

GetParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetParameterOf()()()()
Members
Icon | Member | Description
 | GetParameterOf(Point2d, Tolerance) |
 | GetParameterOf(Point2d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Dimension »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


IsCoplanarWith Method

IsCoplanarWith Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IsCoplanarWith()()()()
Members
Icon | Member | Description
 | IsCoplanarWith(Curve3d, Plane%, Tolerance) |
 | IsCoplanarWith(Curve3d, Plane%) |


BooleanIntersect Method

BooleanIntersect Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SweptSurface »BooleanIntersect()()()()
Members
Icon | Member | Description
 | BooleanIntersect(Surface) |
 | BooleanIntersect(Solid3d) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Point3AngularDimension »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Point3dCollection »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObject »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline3d »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »ShadowParameters »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


ConvertToString Method

ConvertToString Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »ConvertToString()()()()
Members
Icon | Member | Description
 | ConvertToString(Object) |
 | ConvertToString(ITypeDescriptorContext, Object) |
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Material »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetGeCurve Method

GetGeCurve Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »GetGeCurve()()()()
Members
Icon | Member | Description
 | GetGeCurve(Tolerance) |
 | GetGeCurve()()()() |


GetProperties Method

GetProperties Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineWeightConverter »GetProperties()()()()
Members
Icon | Member | Description
 | GetProperties(Object) |
 | GetProperties(ITypeDescriptorContext, Object) |
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldResult »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Polypoint Method

Polypoint Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »WorldGeometry »Polypoint()()()()
Members
Icon | Member | Description
 | Polypoint(Point3dCollection, EntityColorCollection, Vector3dCollection, IntPtrCollection) |
 | Polypoint(Point3dCollection, Vector3dCollection, IntPtrCollection) |


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbSurface »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


GetDataLink Method

GetDataLink Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »GetDataLink()()()()
Members
Icon | Member | Description
 | GetDataLink(Int32, Int32) |
 | GetDataLink(CellRange) |
 | GetDataLink()()()() |


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cone »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLink »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ViewTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.PlottingServices »DsdEntryCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DynamicDimensionData »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBText »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimensionLarge »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »Interval »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlaneSurface »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Runtime »Dictionary »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Curve »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Extend Method

Extend Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Line »Extend()()()()
Members
Icon | Member | Description
 | Extend(Boolean, Point3d) |
 | Extend(Double) |


GetProperties Method

GetProperties Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnitsConverter »GetProperties()()()()
Members
Icon | Member | Description
 | GetProperties(Object) |
 | GetProperties(ITypeDescriptorContext, Object) |
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Windows »Pane »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwgFiler »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TransactionManager »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Layout »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GraphNode »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Sun »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity2d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »NurbCurve2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point2d, Tolerance) |
 | GetClosestPointTo(Curve2d, Tolerance) |
 | GetClosestPointTo(Point2d) |
 | GetClosestPointTo(Curve2d) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RotatedDimension »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Body »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Add Method

Add Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »Add()()()()
Members
Icon | Member | Description
 | Add(DBObjectReference) |
 | IList..::..Add(Object) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Background »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »Sphere »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Shape »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SymbolTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMesh »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockTableRecordEnumerator »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsParallelTo Method

IsParallelTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Plane »IsParallelTo()()()()
Members
Icon | Member | Description
 | IsParallelTo(PlanarEntity, Tolerance) |
 | IsParallelTo(LinearEntity3d, Tolerance) |
 | IsParallelTo(PlanarEntity) |
 | IsParallelTo(LinearEntity3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TextStyleTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RadialDimension »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Background »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DimStyleTable »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetProjectedClosestPointTo Method

GetProjectedClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve3d »GetProjectedClosestPointTo()()()()
Members
Icon | Member | Description
 | GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) |
 | GetProjectedClosestPointTo(Point3d, Vector3d) |
 | GetProjectedClosestPointTo(Curve3d, Vector3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBVisualStyle »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


IsPerpendicularTo Method

IsPerpendicularTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »LineSegment3d »IsPerpendicularTo()()()()
Members
Icon | Member | Description
 | IsPerpendicularTo(PlanarEntity, Tolerance) |
 | IsPerpendicularTo(LinearEntity3d, Tolerance) |
 | IsPerpendicularTo(PlanarEntity) |
 | IsPerpendicularTo(LinearEntity3d) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices.Filters »SpatialIndex »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ObjectIdGraph »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


GetDistanceTo Method

GetDistanceTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetDistanceTo()()()()
Members
Icon | Member | Description
 | GetDistanceTo(Point3d, Tolerance) |
 | GetDistanceTo(Curve3d, Tolerance) |
 | GetDistanceTo(Point3d) |
 | GetDistanceTo(Curve3d) |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Torus »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »CustomObjectSnapMode »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockBegin »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Vertex2d »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PlotStyle »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetSplitCurves Method

GetSplitCurves Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetSplitCurves()()()()
Members
Icon | Member | Description
 | GetSplitCurves(Point3dCollection) |
 | GetSplitCurves(DoubleCollection) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid3d »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AttributeReference »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FieldEngine »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Double%, Tolerance) |
 | IsOn(Double, Tolerance) |
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d, Double%) |
 | IsOn(Double) |
 | IsOn(Point3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MInsertBlock »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DwfDefinition »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »OrdinateDimension »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


Insert Method

Insert Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DBObjectReferenceCollection »Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DBObjectReference) |
 | IList..::..Insert(Int32, Object) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »LightTraits »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AnnotationScale »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ole2Frame »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerGroup »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Windows »Window »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |

Assembly: ZwManaged (Module: ZwManaged)


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »SubEntityTraits »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point2d, Tolerance) |
 | GetNormalPoint(Point2d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GeoLocationData »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »AbstractViewTable »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataLinkManager »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »Context »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.EditorInput »Editor »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: ZwManaged (Module: ZwManaged)


ParameterOf Method

ParameterOf Method
Namespaces »ZwSoft.ZwCAD.Geometry »Cylinder »ParameterOf()()()()
Members
Icon | Member | Description
 | ParameterOf(Point3d, Tolerance) |
 | ParameterOf(Point3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableContent »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Section »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSamplePoints Method

GetSamplePoints Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc2d »GetSamplePoints()()()()
Members
Icon | Member | Description
 | GetSamplePoints(Double, Double, Double) |
 | GetSamplePoints(Int32) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockEnd »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.Geometry »AugmentedPolylineCurve3d »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SkyBackground »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


BooleanIntersect Method

BooleanIntersect Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »BooleanIntersect()()()()
Members
Icon | Member | Description
 | BooleanIntersect(Surface) |
 | BooleanIntersect(Solid3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetSubentityPathsAtGraphicsMarker Method

GetSubentityPathsAtGraphicsMarker Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Spline »GetSubentityPathsAtGraphicsMarker()()()()
Members
Icon | Member | Description
 | GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, array<ObjectId>[]()[][]) |
 | GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, array<ObjectId>[]()[][]) | Obsolete.


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LoftedSurface »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Helix »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Polyline2d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Vector3d, Boolean) |
 | GetClosestPointTo(Point3d, Boolean) |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Circle »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


GetObjectSaveVersion Method

GetObjectSaveVersion Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »SolidBackground »GetObjectSaveVersion()()()()
Members
Icon | Member | Description
 | GetObjectSaveVersion(DxfFiler) |
 | GetObjectSaveVersion(DwgFiler) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »LineAngularDimension2 »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


GetParameterAtLength Method

GetParameterAtLength Method
Namespaces »ZwSoft.ZwCAD.Geometry »OffsetCurve2d »GetParameterAtLength()()()()
Members
Icon | Member | Description
 | GetParameterAtLength(Double, Double, Boolean, Tolerance) |
 | GetParameterAtLength(Double, Double, Boolean) |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »GripData »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolylineVertex3d »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Solid »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve3d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity3d%, Tolerance) |
 | IsDegenerate(Entity3d%) |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »RasterImage »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


GetObjectSnapPoints Method

GetObjectSnapPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »ExtrudedSurface »GetObjectSnapPoints()()()()
Members
Icon | Member | Description
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) |
 | GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.Geometry »PlanarEntity »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Highlight Method

Highlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »Highlight()()()()
Members
Icon | Member | Description
 | Highlight(FullSubentityPath, Boolean) |
 | Highlight()()()() |


ClosestPointTo Method

ClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »BoundedPlane »ClosestPointTo()()()()
Members
Icon | Member | Description
 | ClosestPointTo(Point3d, Tolerance) |
 | ClosestPointTo(Point3d) |


GetNormalPoint Method

GetNormalPoint Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve3d »GetNormalPoint()()()()
Members
Icon | Member | Description
 | GetNormalPoint(Point3d, Tolerance) |
 | GetNormalPoint(Point3d) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DataCellCollection »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »EllipticalArc3d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity3d, Tolerance) |
 | IsEqualTo(Entity3d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UcsTableRecord »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »TableTemplate »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Leader »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Erase Method

Erase Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »Erase()()()()
Members
Icon | Member | Description
 | Erase(Boolean) |
 | Erase()()()() |


SetDatabaseDefaults Method

SetDatabaseDefaults Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »SetDatabaseDefaults()()()()
Members
Icon | Member | Description
 | SetDatabaseDefaults(Database) |
 | SetDatabaseDefaults()()()() |


IsOn Method

IsOn Method
Namespaces »ZwSoft.ZwCAD.Geometry »Position3d »IsOn()()()()
Members
Icon | Member | Description
 | IsOn(Point3d, Tolerance) |
 | IsOn(Point3d) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »CompositeCurve2d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, OffsetCurveExtensionType) |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ellipse »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »PolyFaceMeshVertex »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.LayerManager »LayerFilter »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


IsDegenerate Method

IsDegenerate Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »IsDegenerate()()()()
Members
Icon | Member | Description
 | IsDegenerate(Entity2d%, Tolerance) |
 | IsDegenerate(Entity2d%) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »FeatureControlFrame »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


MoveGripPointsAt Method

MoveGripPointsAt Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Arc »MoveGripPointsAt()()()()
Members
Icon | Member | Description
 | MoveGripPointsAt(array<IntPtr>[]()[][], Vector3d, MoveGripPointsFlags) |
 | MoveGripPointsAt(IntegerCollection, Vector3d) |


Unhighlight Method

Unhighlight Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »Unhighlight()()()()
Members
Icon | Member | Description
 | Unhighlight(FullSubentityPath, Boolean) |
 | Unhighlight()()()() |


GetClosestPointTo Method

GetClosestPointTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »SplineEntity3d »GetClosestPointTo()()()()
Members
Icon | Member | Description
 | GetClosestPointTo(Point3d, Tolerance) |
 | GetClosestPointTo(Curve3d, Tolerance) |
 | GetClosestPointTo(Point3d) |
 | GetClosestPointTo(Curve3d) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Wipeout »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


GetField Method

GetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »GetField()()()()
Members
Icon | Member | Description
 | GetField(String) |
 | GetField()()()() |


IsEqualTo Method

IsEqualTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »CubicSplineCurve2d »IsEqualTo()()()()
Members
Icon | Member | Description
 | IsEqualTo(Entity2d, Tolerance) |
 | IsEqualTo(Entity2d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »DiametricDimension »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


RemoveField Method

RemoveField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Xline »RemoveField()()()()
Members
Icon | Member | Description
 | RemoveField(String) |
 | RemoveField(ObjectId) |
 | RemoveField()()()() |


IsClosed Method

IsClosed Method
Namespaces »ZwSoft.ZwCAD.Geometry »PolylineCurve2d »IsClosed()()()()
Members
Icon | Member | Description
 | IsClosed(Tolerance) |
 | IsClosed()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Ray »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Database »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) |
 | Dispose()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Mline »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


IsColinearTo Method

IsColinearTo Method
Namespaces »ZwSoft.ZwCAD.Geometry »Ray2d »IsColinearTo()()()()
Members
Icon | Member | Description
 | IsColinearTo(LinearEntity2d, Tolerance) |
 | IsColinearTo(LinearEntity2d) |


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MLeader »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


BoundingBoxIntersectWith Method

BoundingBoxIntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »BlockReference »BoundingBoxIntersectWith()()()()
Members
Icon | Member | Description
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


SetField Method

SetField Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayDefinition »SetField()()()()
Members
Icon | Member | Description
 | SetField(String, Field) |
 | SetField(Field) |


IntersectWith Method

IntersectWith Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »Surface »IntersectWith()()()()
Members
Icon | Member | Description
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) |
 | IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete.
 | IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete.


Dispose Method

Dispose Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »MText »Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides DisposableWrapper.Dispose(Boolean).)
 | Dispose()()()() |


MemberwiseClone Method

MemberwiseClone Method
Namespaces »ZwSoft.ZwCAD.GraphicsInterface »CommonDraw »MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


GetGripPoints Method

GetGripPoints Method
Namespaces »ZwSoft.ZwCAD.DatabaseServices »UnderlayReference »GetGripPoints()()()()
Members
Icon | Member | Description
 | GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) |
 | GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) |


GetTrimmedOffset Method

GetTrimmedOffset Method
Namespaces »ZwSoft.ZwCAD.Geometry »CircularArc3d »GetTrimmedOffset()()()()
Members
Icon | Member | Description
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) |
 | GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) |