dotNET Migration Manual

Steps:

  1. Open your solution with Visual Studio (2015 or later version), change project target framework to .NET Framework 4.7.

  2. In the References tab, replace the references to “accore.dll”, "acdbmgd.dll" and "acmgd.dll" with "ZwDatabaseMgd.dll" and "ZwManaged.dll", which are in ZWCAD installation directory.

    Then change the property “Copy Local” of ZwDatabaseMgd and ZwManaged to False.

  3. If your project references to "Autodesk.AutoCAD.Interop" and "Autodesk.AutoCAD.Interop.Common", replace them with "ZWCAD.exe".

  4. In your code, replace all the namespaces "Autodesk.AutoCAD.Interop" and "Autodesk.AutoCAD.Interop.Common" with “ZWCAD”, and replace all the namespaces "Autodesk.AutoCAD.xxxx" with "ZwSoft.ZwCAD.xxxx ".

  5. If you use some objects named like Acadxxxx(for example, AcadLine), rename them as Zcadxxxx.

  6. Then you can build your solution and use “netload” in ZWCAD+ to load your compiled dll file.