ZWCAD 2020 Object Model

ZWCAD 2023 Object Model
Object | Description
3DFace Object | A 3D triangle or quadrilateral plane section.
3DPolyline Object | A 3D polyline of straight line segments.
3DSolid Object | A solid object with free-form surface support.
Application Object | An instance of the ZWCAD application.
Arc Object | A circular arc.
Attribute Object | An object appearing as a text string that describes the characteristics of an attribute reference.
AttributeReference Object | An object containing text that links to a block.
Block Object | A block definition containing a name and a set of objects.
BlockReference Object | An instance of a block definition inserted into a drawing.
Blocks Object | The collection of all blocks in the drawing.
Circle Object | A full circle.
Database Object | The contents of an XRef block.
DatabasePreferences Object | An object that specifies the settings for the current ZWCAD drawing.
Dictionaries Object | The collection of all dictionaries in the drawing.
Dictionary Object | A container object for storing and retrieving objects.
Dim3PointAngular Object | A dimension measuring the angular distance between three points.
DimAligned Object | A linear dimension, measuring the distance between two points, that is displayed parallel to the points being measured.
DimAngular Object | A dimension measuring the angular distance between two lines or between the angle of a circular arc.
DimArcLength Object | A dimension measuring the length of an arc.
DimDiametric Object | A dimension measuring the diameter of a circle or arc.
DimOrdinate Object | A dimension measuring the absolute X or Y position of a point from the origin.
DimRadial Object | A dimension measuring the radius of a circle or arc.
DimRadialLarge Object | A dimension measuring a large radius, also known as a jogged radius dimension.
DimRotated Object | A dimension that measures the distance between two points and is displayed at a given rotation.
DimStyle Object | A group of dimension settings that determines the appearance of a dimension.
DimStyles Object | The collection of all dimension styles in the drawing.
Document Object | An ZWCAD drawing.
DynamicBlockReferenceProperty | A special object to use in monitoring the DynamicBlockReferenceProperty of ZWCAD from out-of-process applications.
Ellipse Object | An elliptical arc or full ellipse.
Ellipse Object | An elliptical arc or full ellipse.
ExternalReference Object | An instance of an external reference inserted into a drawing.
FileDependency Object | Provides information about entries in the File Dependency List of a drawing file.
Group Object | A named SelectionSet object.
Groups Object | The collection of all groups in the drawing.
Hatch Object | An area fill consisting of a pattern of lines.
Hyperlink Object | object A URL and URL description.
IdPair Object | A special object for use with the CopyObjects method that contains the object IDs of both the source and destination objects.
LWPolyline Object | A 2D line with adjustable width composed of line and arc segments.
Layer Object | A logical grouping of data, similar to transparent acetate overlays on a drawing.
LayerStateManager Object | Saves and restores layer settings.
Layers Object | The collection of all layers in the drawing.
Layout Object | The plot settings and visual properties of a model space or paper space block.
Layouts Object | The collection of all layouts in the drawing.
Leader Object | An object composed of an arrowhead attached to splines or straight line segments.
Line Object | A single line segment.
LineType Object | The line characteristics consisting of combinations of dashes, dots, and spaces.
LineTypes Object | The collection of all linetypes in the drawing.
MInsertBlock Object | A rectangular array of block references.
MLeader Object | An object composed of an arrowhead attached to multiple splines or straight line segments.
MLine Object | Multiple parallel lines.
MText Object | A paragraph of alphanumeric characters that fits within a nonprinting text boundary.
MenuBar Object | A collection of PopupMenu objects representing the current ZWCAD menu bar.
MenuGroup Object | An ZWCAD menu group.
MenuGroups Object | A collection of MenuGroup objects representing all the menu groups loaded in the current ZWCAD session.
ModelSpace Object | A special Block object containing all model space entities.
Ole Object | An ZWCAD OLE object.
PViewport Object | Rectangular objects created in paper space that display views.
PaperSpace Object | A special Block object containing all the entities in the active paper space layout.
Plot Object | The set of methods and properties used for plotting layouts.
PlotConfiguration Object | A named collection of plot settings.
PlotConfigurations Object | A collection of named plot settings.
Point Object | A point marker appearing as a dot, square, circle, X, tick, or plus sign (+); or as a combination of these.
PolyfaceMesh Object | A three-dimensional polyface mesh.
PolygonMesh Object | A free-form 3D mesh.
Polyline Object | A 2D line of adjustable width or a 3D line or mesh of nonadjustable width composed of line and arc segments.
PopupMenu Object | An ZWCAD cascading menu.
PopupMenuItem Object | A single menu item on an ZWCAD pull-down menu.
PopupMenus Object | A collection of PopupMenu objects representing all the popup menus loaded in the MenuGroup.
PreferencesFiles Object | This object contains the options from the Files tab on the Options dialog.
PreferencesOutput Object | This object contains the options from the Output tab on the Options dialog.
RasterImage Object | A raster image consisting of a rectangular grid (or raster) of small squares or dots known as pixels.
Ray Object | A semi-infinite line.
Region Object | A bounded planar face consisting of lines, circles, arcs, elliptical arcs, and spline curves.
RegisteredApplication Object | An external application that has been added to the drawing.
RegisteredApplications Object | The collection of all registered applications in the drawing.
SecurityParams Object | Supplies information necessary for performing security operations on drawing files.
SelectionSet Object | A group of one or more ZWCAD objects specified for processing as a single unit.
SelectionSets Object | The collection of all selection sets in the drawing.
Shape Object | An object comprising lines, arcs, and circles defined in an SHX file.
Solid Object | A solid-filled polygon.
SortentsTable Object | Contains and manipulates draw order information.
Spline Object | A quadratic or cubic NURBS (nonuniform rational B-spline) curve.
State Object | A special object to use in monitoring the state of ZWCAD from out-of-process applications.
SummaryInfo Object | Accesses drawing properties such as the Title, Subject, Author, and Keywords properties.
Table Object | ZWCAD table object.
TableStyle Object | Adds, modifies, and deletes table styles.
Text Object | A single line of alphanumeric characters.
TextStyle Object | A named, saved collection of settings that determines the appearance of text characters.
TextStyles Object | The collection of all text styles in the drawing.
Tolerance Object | A geometric tolerance contained in a feature control frame.
Toolbar Object | An ZWCAD toolbar.
ToolbarItem Object | A single button item on an ZWCAD toolbar.
Toolbars Object | A collection of Toolbar objects representing all the toolbars loaded in the current ZWCAD session.
Trace Object | A 2D solid line of specified width.
UCS Object | A user-defined coordinate system that determines the orientation of the X, Y, and Z axes in 3D space.
UCSs Object | The collection of all user coordinate systems (UCSs) in the drawing.
Utility Object | A series of methods provided for utility purposes.
View Object | A graphical representation of a 2D drawing or 3D model from a specific location (viewpoint) in space.
Viewport Object | A bounded area that displays some portion of a drawing's model space.
Viewports Object | The collection of all viewports in the drawing.
Views Object | The collection of all views in the drawing.
XRecord Object | XRecord objects are used to store and manage arbitrary data.
Xline Object | A construction line that is infinite in both directions.
ZcCmColor Object | ZWCAD true color object.


Zcad3DFace Object Members

3DFace Object Members

A 3D triangle or quadrilateral plane section.

VBA Class Name

Zcad3DFace

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetInvisibleEdge | Gets the visibility status for the edge.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
SetInvisibleEdge | Sets the visibility of the edge.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Coordinate | Returns the coordinate of the vertex at a given index.
Coordinates | Specifies the current vertex of the 3D face
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
TrueColor | Returns the true color of the object.
VisibilityEdge1 | Determines whether 3DFace Edge 1 is visible or hidden
VisibilityEdge2 | Determines whether 3DFace Edge 2 is visible or hidden
VisibilityEdge3 | Determines whether 3DFace Edge 3 is visible or hidden
VisibilityEdge4 | Determines whether 3DFace Edge 4 is visible or hidden
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


3DFace.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


3DFace.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


3DFace.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a 3DFace object.

Return value

Object

Examples...

Copy Method example


3DFace.Delete Method

Deletes the object.

Syntax

object.Delete

object is a 3DFace object.

Examples...

Delete Method example


3DFace.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a 3DFace object.

Examples...

Erase Method example


3DFace.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


3DFace.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a 3DFace object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


3DFace.GetInvisibleEdge Method

Gets the visibility status for the edge.

Syntax

object.GetInvisibleEdge(Index)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -

Return value

Boolean


3DFace.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


3DFace.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


3DFace.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


3DFace.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


3DFace.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


3DFace.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


3DFace.SetInvisibleEdge Method

Sets the visibility of the edge.

Syntax

object.SetInvisibleEdge(Index, State)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
State | Input-only | Boolean | -

Examples...

SetInvisibleEdge Method example


3DFace.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


3DFace.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a 3DFace object.


3DFace.Application Property

Returns the application object.

Syntax

object.Application

object is a 3DFace object.

Description

Application Object; Read-only

Examples...

Application Property example


3DFace.Coordinate Property

Returns the coordinate of the vertex at a given index.

Syntax

object.Coordinate

object is a 3DFace object.

Description

Coordinate Variant; Read-write

Examples...

Coordinate Property example


3DFace.Coordinates Property

Specifies the current vertex of the 3D face

Syntax

object.Coordinates

object is a 3DFace object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


3DFace.Database Property

Returns the database object.

Syntax

object.Database

object is a 3DFace object.

Description

Database Database; Read-only


3DFace.Document Property

Returns the document object.

Syntax

object.Document

object is a 3DFace object.

Description

Document Object; Read-only


3DFace.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a 3DFace object.

Description

Handle String; Read-only


3DFace.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a 3DFace object.

Description

HasExtensionDictionary Boolean; Read-only


3DFace.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a 3DFace object.

Description

Hyperlinks Hyperlinks; Read-only


3DFace.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a 3DFace object.

Description

Layer String; Read-write

Examples...

Layer Property example


3DFace.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a 3DFace object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


3DFace.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a 3DFace object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


3DFace.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a 3DFace object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


3DFace.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a 3DFace object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


3DFace.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a 3DFace object.

Description

ObjectName String; Read-only


3DFace.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a 3DFace object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


3DFace.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a 3DFace object.

Description

PlotStyleName String; Read-write


3DFace.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a 3DFace object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


3DFace.VisibilityEdge1 Property

Determines whether 3DFace Edge 1 is visible or hidden

Syntax

object.VisibilityEdge1

object is a 3DFace object.

Description

VisibilityEdge1 Boolean; Read-write

Examples...

VisibilityEdge1 Property example


3DFace.VisibilityEdge2 Property

Determines whether 3DFace Edge 2 is visible or hidden

Syntax

object.VisibilityEdge2

object is a 3DFace object.

Description

VisibilityEdge2 Boolean; Read-write

Examples...

VisibilityEdge2 Property example


3DFace.VisibilityEdge3 Property

Determines whether 3DFace Edge 3 is visible or hidden

Syntax

object.VisibilityEdge3

object is a 3DFace object.

Description

VisibilityEdge3 Boolean; Read-write

Examples...

VisibilityEdge3 Property example


3DFace.VisibilityEdge4 Property

Determines whether 3DFace Edge 4 is visible or hidden

Syntax

object.VisibilityEdge4

object is a 3DFace object.

Description

VisibilityEdge4 Boolean; Read-write

Examples...

VisibilityEdge4 Property example


3DFace.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a 3DFace object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


3DFace.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a 3DFace object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


Zcad3DPolyline Object Members

3DPolyline Object Members

A 3D polyline of straight line segments.

VBA Class Name

Zcad3DPolyline

Methods

Name | Description
AppendVertex | Appends a vertex to the 3dPolyline.
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
Explode | Explodes the 3dPolyline.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Closed | Determines whether the 3D polyline is open or closed
Coordinate | Returns the coordinate of the vertex at a given index.
Coordinates | Specifies the current vertex of the 3D Polyline
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Length | Specifies the length of the 3D polyline
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
TrueColor | Returns the true color of the object.
Type | Specifies the type of line or surface curve fitting
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


3DPolyline.AppendVertex Method

Appends a vertex to the 3dPolyline.

Syntax

object.AppendVertex(vertex)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
vertex | Input-only | Variant | -

Examples...

AppendVertex Method example


3DPolyline.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


3DPolyline.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


3DPolyline.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a 3DPolyline object.

Return value

Object

Examples...

Copy Method example


3DPolyline.Delete Method

Deletes the object.

Syntax

object.Delete

object is a 3DPolyline object.

Examples...

Delete Method example


3DPolyline.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a 3DPolyline object.

Examples...

Erase Method example


3DPolyline.Explode Method

Explodes the 3dPolyline.

Syntax

object.Explode

object is a 3DPolyline object.

Return value

Variant

Examples...

Explode Method example


3DPolyline.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


3DPolyline.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a 3DPolyline object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


3DPolyline.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


3DPolyline.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


3DPolyline.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


3DPolyline.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


3DPolyline.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


3DPolyline.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


3DPolyline.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


3DPolyline.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a 3DPolyline object.


3DPolyline.Application Property

Returns the application object.

Syntax

object.Application

object is a 3DPolyline object.

Description

Application Object; Read-only

Examples...

Application Property example


3DPolyline.Closed Property

Determines whether the 3D polyline is open or closed

Syntax

object.Closed

object is a 3DPolyline object.

Description

Closed Boolean; Read-write

Examples...

Closed Property example


3DPolyline.Coordinate Property

Returns the coordinate of the vertex at a given index.

Syntax

object.Coordinate

object is a 3DPolyline object.

Description

Coordinate Variant; Read-write

Examples...

Coordinate Property example


3DPolyline.Coordinates Property

Specifies the current vertex of the 3D Polyline

Syntax

object.Coordinates

object is a 3DPolyline object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


3DPolyline.Database Property

Returns the database object.

Syntax

object.Database

object is a 3DPolyline object.

Description

Database Database; Read-only


3DPolyline.Document Property

Returns the document object.

Syntax

object.Document

object is a 3DPolyline object.

Description

Document Object; Read-only


3DPolyline.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a 3DPolyline object.

Description

Handle String; Read-only


3DPolyline.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a 3DPolyline object.

Description

HasExtensionDictionary Boolean; Read-only


3DPolyline.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a 3DPolyline object.

Description

Hyperlinks Hyperlinks; Read-only


3DPolyline.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a 3DPolyline object.

Description

Layer String; Read-write

Examples...

Layer Property example


3DPolyline.Length Property

Specifies the length of the 3D polyline

Syntax

object.Length

object is a 3DPolyline object.

Description

Length Double; Read-only

Examples...

Length Property example


3DPolyline.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a 3DPolyline object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


3DPolyline.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a 3DPolyline object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


3DPolyline.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a 3DPolyline object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


3DPolyline.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a 3DPolyline object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


3DPolyline.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a 3DPolyline object.

Description

ObjectName String; Read-only


3DPolyline.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a 3DPolyline object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


3DPolyline.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a 3DPolyline object.

Description

PlotStyleName String; Read-write


3DPolyline.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a 3DPolyline object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


3DPolyline.Type Property

Specifies the type of line or surface curve fitting

Syntax

object.Type

object is a 3DPolyline object.

Description

Type Zc3DPolylineType: Read-write
Can be one of the constants listed here:
zcSimple3DPoly
zcQuadSpline3DPoly
zcCubicSpline3DPoly

Examples...

Type Property example


3DPolyline.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a 3DPolyline object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


3DPolyline.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a 3DPolyline object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


Zcad3DSolid Object Members

3DSolid Object Members

A solid object with free-form surface support.

VBA Class Name

Zcad3DSolid

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Boolean | Performs a boolean operation against another 3dsolid.
CheckInterference | Check interference for the 3dsolid object.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
SectionSolid | Create a section of the 3dsolid given three points that define the plane. Returns the Section as a Region object
SliceSolid | Create a slice of the 3dsolid given three points that define the plane. Returns the resulting array of 3dSolid object.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Centroid | Returns the centroid of the 3dsolid as an array of Double.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
MomentOfInertia | Returns the moment of inertia of the 3dsolid as an array of Double.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
PrincipalDirections | Returns the principal directions of the 3dsolid as an array of Double.
PrincipalMoments | Returns the principal moments of the 3dsolid as an array of Double.
ProductOfInertia | Returns the product of inertia of the 3dsolid as an array of Double.
RadiiOfGyration | Returns the radii of gyration of the 3dsolid as an array of Double.
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.
Volume | Returns the volume of the 3dsolid as a Double.

Events

Name | Description
Modified | Happens when object is modified


3DSolid.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


3DSolid.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


3DSolid.Boolean Method

Performs a boolean operation against another 3dsolid.

Syntax

object.Boolean(Operation, SolidObject)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
Operation | Input-only | ZcBooleanType | Can be one of the constants listed here: zcUnion zcIntersection zcSubtraction
SolidObject | Input-only | 3DSolid | -


3DSolid.CheckInterference Method

Check interference for the 3dsolid object.

Syntax

object.CheckInterference(Object, CreateInterferenceSolid)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
Object | Input-only | 3DSolid | -
CreateInterferenceSolid | Input-only | Boolean | -

Return value

3DSolid

Examples...

CheckInterference Method example


3DSolid.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a 3DSolid object.

Return value

Object

Examples...

Copy Method example


3DSolid.Delete Method

Deletes the object.

Syntax

object.Delete

object is a 3DSolid object.

Examples...

Delete Method example


3DSolid.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a 3DSolid object.

Examples...

Erase Method example


3DSolid.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


3DSolid.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a 3DSolid object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


3DSolid.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


3DSolid.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


3DSolid.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


3DSolid.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


3DSolid.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


3DSolid.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


3DSolid.SectionSolid Method

Create a section of the 3dsolid given three points that define the plane. Returns the Section as a Region object

Syntax

object.SectionSolid(Point1, Point2, point3)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -
point3 | Input-only | Variant | -

Return value

Region

Examples...

SectionSolid Method example


3DSolid.SliceSolid Method

Create a slice of the 3dsolid given three points that define the plane. Returns the resulting array of 3dSolid object.

Syntax

object.SliceSolid(Point1, Point2, point3, Negative)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -
point3 | Input-only | Variant | -
Negative | Input-only | Boolean | -

Return value

3DSolid

Examples...

SliceSolid Method example


3DSolid.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


3DSolid.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a 3DSolid object.


3DSolid.Application Property

Returns the application object.

Syntax

object.Application

object is a 3DSolid object.

Description

Application Object; Read-only

Examples...

Application Property example


3DSolid.Centroid Property

Returns the centroid of the 3dsolid as an array of Double.

Syntax

object.Centroid

object is a 3DSolid object.

Description

Centroid Variant; Read-only

Examples...

Centroid Property example


3DSolid.Database Property

Returns the database object.

Syntax

object.Database

object is a 3DSolid object.

Description

Database Database; Read-only


3DSolid.Document Property

Returns the document object.

Syntax

object.Document

object is a 3DSolid object.

Description

Document Object; Read-only


3DSolid.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a 3DSolid object.

Description

Handle String; Read-only


3DSolid.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a 3DSolid object.

Description

HasExtensionDictionary Boolean; Read-only


3DSolid.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a 3DSolid object.

Description

Hyperlinks Hyperlinks; Read-only


3DSolid.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a 3DSolid object.

Description

Layer String; Read-write

Examples...

Layer Property example


3DSolid.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a 3DSolid object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


3DSolid.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a 3DSolid object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


3DSolid.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a 3DSolid object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


3DSolid.MomentOfInertia Property

Returns the moment of inertia of the 3dsolid as an array of Double.

Syntax

object.MomentOfInertia

object is a 3DSolid object.

Description

MomentOfInertia Variant; Read-only

Examples...

MomentOfInertia Property example


3DSolid.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a 3DSolid object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


3DSolid.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a 3DSolid object.

Description

ObjectName String; Read-only


3DSolid.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a 3DSolid object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


3DSolid.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a 3DSolid object.

Description

PlotStyleName String; Read-write


3DSolid.PrincipalDirections Property

Returns the principal directions of the 3dsolid as an array of Double.

Syntax

object.PrincipalDirections

object is a 3DSolid object.

Description

PrincipalDirections Variant; Read-only

Examples...

PrincipalDirections Property example


3DSolid.PrincipalMoments Property

Returns the principal moments of the 3dsolid as an array of Double.

Syntax

object.PrincipalMoments

object is a 3DSolid object.

Description

PrincipalMoments Variant; Read-only

Examples...

PrincipalMoments Property example


3DSolid.ProductOfInertia Property

Returns the product of inertia of the 3dsolid as an array of Double.

Syntax

object.ProductOfInertia

object is a 3DSolid object.

Description

ProductOfInertia Variant; Read-only

Examples...

ProductOfInertia Property example


3DSolid.RadiiOfGyration Property

Returns the radii of gyration of the 3dsolid as an array of Double.

Syntax

object.RadiiOfGyration

object is a 3DSolid object.

Description

RadiiOfGyration Variant; Read-only

Examples...

RadiiOfGyration Property example


3DSolid.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a 3DSolid object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


3DSolid.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a 3DSolid object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


3DSolid.Volume Property

Returns the volume of the 3dsolid as a Double.

Syntax

object.Volume

object is a 3DSolid object.

Description

Volume Double; Read-only

Examples...

Volume Property example


3DSolid.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a 3DSolid object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadApplication Object Members

Application Object Members

An instance of the ZWCAD application.

VBA Class Name

ZcadApplication

Methods

Name | Description
Eval | Evaluate an expression in VBA.
GetInterfaceObject | Loads and returns the specified object given its ProgId.
GetZcadState | Gets an ZcadState object to monitor the state of ZWCAD from out-of-process applications.
LoadZPVB | Loads the specified VBA project.
Quit | Quits the application.
RunMacro | Run the specified VBA macro.
UnloadZPVB | Unloads the specified VBA project.
Update | Update the graphics.
ZoomAll | Zoom extents or limits. Whichever is bigger.
ZoomCenter | Zoom center point to magnification.
ZoomExtents | Zoom to the extents of the drawing.
ZoomPickWindow | Zoom window with ZCAD interaction.
ZoomPrevious | Zooms the current viewport to its previous extents.
ZoomScaled | Scaled zoom.
ZoomWindow | Zoom window within enclosed corners.

Properties

Name | Description
ActiveDocument | Returns and sets the active document object.
Application | Returns the application object.
Caption | Returns the caption of the application window.
Documents | Returns the documents collection.
FullName | Returns the full name of the application.
HWND | Gets the window handle of the application window frame
Height | Returns and sets the height of the application window.
MenuBar | Returns the menubar object.
MenuGroups | Returns the menugroups object.
Name | Returns the name of the application.
Path | Returns the full path of the application.
Preferences | Returns the preferences object.
VBE | Returns the VBA IDE Extensibility object
Version | Returns the version of the application.
Visible | Returns and sets visibility of the application window.
Width | Returns and sets the width of the application window.
WindowLeft | Returns and sets the left edge of the application window.
WindowState | Returns or sets the application window state.
WindowTop | Returns and sets the top edge of the application window.

Events

Name | Description
AppActivate | Happens when the main frame window is activated.
AppDeactivate | Happens when the main frame window is deactivated.
BeginCommand | Happens immediately before a command is issued.
BeginFileDrop | Happens when a file is dropped in the main frame window.
BeginModal | Happens just before a modal dialog is shown.
BeginOpen | Happens immediately before a drawing is opened.
BeginPlot | Happens just before a drawing is plotted.
BeginQuit | Happens immediately before the application exits.
BeginSave | Happens immediately before the drawing is saved.
EndCommand | Happens immediately after a command is issued.
EndModal | Happens just after a modal dialog is shown.
EndOpen | Happens immediately after a drawing is opened.
EndPlot | Happens just before a drawing is plotted.
EndSave | Happens immediately after the drawing is saved.
NewDrawing | Happens just before a new drawing is created.
SysVarChanged | Happens when a system variable changes.
WindowChanged | Happens when the main frame window state changes.
WindowMovedOrResized | Happens when the main frame window is moved or resized
ZRXLoaded | Happens when an ZRX application is loaded.
ZRXUnloaded | Happens when an ZRX application is unloaded.


Application.Eval Method

Evaluate an expression in VBA.

Syntax

object.Eval(Expression)

object is a Application object.

Parameters

Name | Options | Data Type | Description
Expression | Input-only | String | -

Examples...

Eval Method example


Application.GetInterfaceObject Method

Loads and returns the specified object given its ProgId.

Syntax

object.GetInterfaceObject(ProgID)

object is a Application object.

Parameters

Name | Options | Data Type | Description
ProgID | Input-only | String | -

Return value

Object

Examples...

GetInterfaceObject Method example


Application.GetZcadState Method

Gets an ZcadState object to monitor the state of ZWCAD from out-of-process applications.

Syntax

object.GetZcadState

object is a Application object.

Return value

State


Application.LoadZPVB Method

Loads the specified VBA project.

Syntax

object.LoadZPVB(Name)

object is a Application object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -


Application.Quit Method

Quits the application.

Syntax

object.Quit

object is a Application object.

Examples...

Quit Method example


Application.RunMacro Method

Run the specified VBA macro.

Syntax

object.RunMacro(MacroPath)

object is a Application object.

Parameters

Name | Options | Data Type | Description
MacroPath | Input-only | String | -

Examples...

RunMacro Method example


Application.UnloadZPVB Method

Unloads the specified VBA project.

Syntax

object.UnloadZPVB(Name)

object is a Application object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -


Application.Update Method

Update the graphics.

Syntax

object.Update

object is a Application object.


Application.ZoomAll Method

Zoom extents or limits. Whichever is bigger.

Syntax

object.ZoomAll

object is a Application object.

Examples...

ZoomAll Method example


Application.ZoomCenter Method

Zoom center point to magnification.

Syntax

object.ZoomCenter(Center, Magnify)

object is a Application object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Magnify | Input-only | Double | -

Examples...

ZoomCenter Method example


Application.ZoomExtents Method

Zoom to the extents of the drawing.

Syntax

object.ZoomExtents

object is a Application object.

Examples...

ZoomExtents Method example


Application.ZoomPickWindow Method

Zoom window with ZCAD interaction.

Syntax

object.ZoomPickWindow

object is a Application object.

Examples...

ZoomPickWindow Method example


Application.ZoomPrevious Method

Zooms the current viewport to its previous extents.

Syntax

object.ZoomPrevious

object is a Application object.

Examples...

ZoomPrevious Method example


Application.ZoomScaled Method

Scaled zoom.

Syntax

object.ZoomScaled(scale, ScaleType)

object is a Application object.

Parameters

Name | Options | Data Type | Description
scale | Input-only | Double | -
ScaleType | Input-only | ZcZoomScaleType | Can be one of the constants listed here: zcZoomScaledAbsolute zcZoomScaledRelative zcZoomScaledRelativePSpace

Examples...

ZoomScaled Method example


Application.ZoomWindow Method

Zoom window within enclosed corners.

Syntax

object.ZoomWindow(LowerLeft, UpperRight)

object is a Application object.

Parameters

Name | Options | Data Type | Description
LowerLeft | Input-only | Variant | -
UpperRight | Input-only | Variant | -

Examples...

ZoomWindow Method example


Application.ActiveDocument Property

Returns and sets the active document object.

Syntax

object.ActiveDocument

object is a Application object.

Description

ActiveDocument Document; Read-write

Examples...

ActiveDocument Property example


Application.Application Property

Returns the application object.

Syntax

object.Application

object is a Application object.

Description

Application Application; Read-only

Examples...

Application Property example


Application.Caption Property

Returns the caption of the application window.

Syntax

object.Caption

object is a Application object.

Description

Caption String; Read-only

Examples...

Caption Property example


Application.Documents Property

Returns the documents collection.

Syntax

object.Documents

object is a Application object.

Description

Documents Documents; Read-only


Application.FullName Property

Returns the full name of the application.

Syntax

object.FullName

object is a Application object.

Description

FullName String; Read-only


Application.HWND Property

Gets the window handle of the application window frame

Syntax

object.HWND

object is a Application object.

Description

HWND LONG_PTR: alias for Long; Read-only


Application.Height Property

Returns and sets the height of the application window.

Syntax

object.Height

object is a Application object.

Description

Height Integer; Read-write


Application.MenuBar Property

Returns the menubar object.

Syntax

object.MenuBar

object is a Application object.

Description

MenuBar MenuBar; Read-only

Examples...

MenuBar Property example


Application.MenuGroups Property

Returns the menugroups object.

Syntax

object.MenuGroups

object is a Application object.

Description

MenuGroups MenuGroups; Read-only

Examples...

MenuGroups Property example


Application.Name Property

Returns the name of the application.

Syntax

object.Name

object is a Application object.

Description

Name String; Read-only

Examples...

Name Property example


Application.Path Property

Returns the full path of the application.

Syntax

object.Path

object is a Application object.

Description

Path String; Read-only

Examples...

Path Property example


Application.Preferences Property

Returns the preferences object.

Syntax

object.Preferences

object is a Application object.

Description

Preferences Preferences; Read-only


Application.VBE Property

Returns the VBA IDE Extensibility object

Syntax

object.VBE

object is a Application object.

Description

VBE Object; Read-only


Application.Version Property

Returns the version of the application.

Syntax

object.Version

object is a Application object.

Description

Version String; Read-only

Examples...

Version Property example


Application.Visible Property

Returns and sets visibility of the application window.

Syntax

object.Visible

object is a Application object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Application.Width Property

Returns and sets the width of the application window.

Syntax

object.Width

object is a Application object.

Description

Width Integer; Read-write

Examples...

Width Property example


Application.WindowLeft Property

Returns and sets the left edge of the application window.

Syntax

object.WindowLeft

object is a Application object.

Description

WindowLeft Integer; Read-write

Examples...

WindowLeft Property example


Application.WindowState Property

Returns or sets the application window state.

Syntax

object.WindowState

object is a Application object.

Description

WindowState ZcWindowState: Read-write
Can be one of the constants listed here:
zcNorm
zcMin
zcMax

Examples...

WindowState Property example


Application.WindowTop Property

Returns and sets the top edge of the application window.

Syntax

object.WindowTop

object is a Application object.

Description

WindowTop Integer; Read-write

Examples...

WindowTop Property example


Application.AppActivate Event

Happens when the main frame window is activated.

Syntax

object.AppActivate

object is a Application object.


Application.AppDeactivate Event

Happens when the main frame window is deactivated.

Syntax

object.AppDeactivate

object is a Application object.


Application.BeginCommand Event

Happens immediately before a command is issued.

Syntax

object.BeginCommand(CommandName)

object is a Application object.

Parameters

Name | Options | Data Type | Description
CommandName | Input-only | String | -

Examples...

BeginCommand Event example


Application.BeginFileDrop Event

Happens when a file is dropped in the main frame window.

Syntax

object.BeginFileDrop(FileName, Cancel)

object is a Application object.

Parameters

Name | Options | Data Type | Description
FileName | Input-only | String | -
Cancel | Input-output | Boolean | -


Application.BeginModal Event

Happens just before a modal dialog is shown.

Syntax

object.BeginModal

object is a Application object.


Application.BeginOpen Event

Happens immediately before a drawing is opened.

Syntax

object.BeginOpen(FileName)

object is a Application object.

Parameters

Name | Options | Data Type | Description
FileName | Input-output | String | -


Application.BeginPlot Event

Happens just before a drawing is plotted.

Syntax

object.BeginPlot(DrawingName)

object is a Application object.

Parameters

Name | Options | Data Type | Description
DrawingName | Input-only | String | -


Application.BeginQuit Event

Happens immediately before the application exits.

Syntax

object.BeginQuit(Cancel)

object is a Application object.

Parameters

Name | Options | Data Type | Description
Cancel | Input-output | Boolean | -


Application.BeginSave Event

Happens immediately before the drawing is saved.

Syntax

object.BeginSave(FileName)

object is a Application object.

Parameters

Name | Options | Data Type | Description
FileName | Input-only | String | -

Examples...

BeginSave Event example


Application.EndCommand Event

Happens immediately after a command is issued.

Syntax

object.EndCommand(CommandName)

object is a Application object.

Parameters

Name | Options | Data Type | Description
CommandName | Input-only | String | -


Application.EndModal Event

Happens just after a modal dialog is shown.

Syntax

object.EndModal

object is a Application object.


Application.EndOpen Event

Happens immediately after a drawing is opened.

Syntax

object.EndOpen(FileName)

object is a Application object.

Parameters

Name | Options | Data Type | Description
FileName | Input-only | String | -


Application.EndPlot Event

Happens just before a drawing is plotted.

Syntax

object.EndPlot(DrawingName)

object is a Application object.

Parameters

Name | Options | Data Type | Description
DrawingName | Input-only | String | -


Application.EndSave Event

Happens immediately after the drawing is saved.

Syntax

object.EndSave(FileName)

object is a Application object.

Parameters

Name | Options | Data Type | Description
FileName | Input-only | String | -


Application.NewDrawing Event

Happens just before a new drawing is created.

Syntax

object.NewDrawing

object is a Application object.


Application.SysVarChanged Event

Happens when a system variable changes.

Syntax

object.SysVarChanged(SysvarName, newVal)

object is a Application object.

Parameters

Name | Options | Data Type | Description
SysvarName | Input-only | String | -
newVal | Input-only | Variant | -


Application.WindowChanged Event

Happens when the main frame window state changes.

Syntax

object.WindowChanged(WindowState)

object is a Application object.

Parameters

Name | Options | Data Type | Description
WindowState | Input-only | ZcWindowState | Can be one of the constants listed here: zcNorm zcMin zcMax


Application.WindowMovedOrResized Event

Happens when the main frame window is moved or resized

Syntax

object.WindowMovedOrResized(HWNDFrame, bMoved)

object is a Application object.

Parameters

Name | Options | Data Type | Description
HWNDFrame | Input-only | Long | -
bMoved | Input-only | Boolean | -


Application.ZRXLoaded Event

Happens when an ZRX application is loaded.

Syntax

object.ZRXLoaded(AppName)

object is a Application object.

Parameters

Name | Options | Data Type | Description
AppName | Input-only | String | -


Application.ZRXUnloaded Event

Happens when an ZRX application is unloaded.

Syntax

object.ZRXUnloaded(AppName)

object is a Application object.

Parameters

Name | Options | Data Type | Description
AppName | Input-only | String | -


ZcadArc Object Members

Arc Object Members

A circular arc.

VBA Class Name

ZcadArc

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Offset | Offsets the arc to the given side.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
ArcLength | Specifies the arc length of the arc.
Area | Specifies the area of the arc when implicitly closed with a line
Center | Specifies the X, Y, and Z coordinates of the center point of the arc
Database | Returns the database object.
Document | Returns the document object.
EndAngle | Specifies the end angle of the arc
EndPoint | Specifies the X, Y, and Z coordinates of the end point of the arc
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the X, Y, and Z coordinates of the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Radius | Specifies the radius of the arc.
StartAngle | Specifies the start angle of the arc.
StartPoint | Specifies the X, Y, and Z coordinates of the start point of the arc
Thickness | Specifies the thickness of the arc.
TotalAngle | Specifies the total angle of the arc
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Arc.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Arc.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Arc.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Arc object.

Return value

Object

Examples...

Copy Method example


Arc.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Arc object.

Examples...

Delete Method example


Arc.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Arc object.

Examples...

Erase Method example


Arc.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Arc.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Arc object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Arc.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Arc.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Arc.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Arc.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Arc.Offset Method

Offsets the arc to the given side.

Syntax

object.Offset(Distance)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
Distance | Input-only | Double | -

Return value

Variant


Arc.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Arc.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Arc.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Arc.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Arc object.


Arc.Application Property

Returns the application object.

Syntax

object.Application

object is a Arc object.

Description

Application Object; Read-only

Examples...

Application Property example


Arc.ArcLength Property

Specifies the arc length of the arc.

Syntax

object.ArcLength

object is a Arc object.

Description

ArcLength ZCAD_DISTANCE: alias for Double; Read-only

Examples...

ArcLength Property example


Arc.Area Property

Specifies the area of the arc when implicitly closed with a line

Syntax

object.Area

object is a Arc object.

Description

Area Double; Read-only

Examples...

Area Property example


Arc.Center Property

Specifies the X, Y, and Z coordinates of the center point of the arc

Syntax

object.Center

object is a Arc object.

Description

Center Variant; Read-write

Examples...

Center Property example


Arc.Database Property

Returns the database object.

Syntax

object.Database

object is a Arc object.

Description

Database Database; Read-only


Arc.Document Property

Returns the document object.

Syntax

object.Document

object is a Arc object.

Description

Document Object; Read-only


Arc.EndAngle Property

Specifies the end angle of the arc

Syntax

object.EndAngle

object is a Arc object.

Description

EndAngle ZCAD_ANGLE: alias for Double; Read-write


Arc.EndPoint Property

Specifies the X, Y, and Z coordinates of the end point of the arc

Syntax

object.EndPoint

object is a Arc object.

Description

EndPoint Variant; Read-only


Arc.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Arc object.

Description

Handle String; Read-only


Arc.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Arc object.

Description

HasExtensionDictionary Boolean; Read-only


Arc.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Arc object.

Description

Hyperlinks Hyperlinks; Read-only


Arc.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Arc object.

Description

Layer String; Read-write

Examples...

Layer Property example


Arc.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Arc object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Arc.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Arc object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Arc.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Arc object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Arc.Normal Property

Specifies the X, Y, and Z coordinates of the normal direction vector.

Syntax

object.Normal

object is a Arc object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Arc.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Arc object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Arc.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Arc object.

Description

ObjectName String; Read-only


Arc.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Arc object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Arc.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Arc object.

Description

PlotStyleName String; Read-write


Arc.Radius Property

Specifies the radius of the arc.

Syntax

object.Radius

object is a Arc object.

Description

Radius Double; Read-write

Examples...

Radius Property example


Arc.StartAngle Property

Specifies the start angle of the arc.

Syntax

object.StartAngle

object is a Arc object.

Description

StartAngle ZCAD_ANGLE: alias for Double; Read-write

Examples...

StartAngle Property example


Arc.StartPoint Property

Specifies the X, Y, and Z coordinates of the start point of the arc

Syntax

object.StartPoint

object is a Arc object.

Description

StartPoint Variant; Read-only

Examples...

StartPoint Property example


Arc.Thickness Property

Specifies the thickness of the arc.

Syntax

object.Thickness

object is a Arc object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


Arc.TotalAngle Property

Specifies the total angle of the arc

Syntax

object.TotalAngle

object is a Arc object.

Description

TotalAngle ZCAD_ANGLE: alias for Double; Read-only

Examples...

TotalAngle Property example


Arc.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Arc object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Arc.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Arc object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Arc.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Arc object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadAttribute Object Members

Attribute Object Members

An object appearing as a text string that describes the characteristics of an attribute reference.

VBA Class Name

ZcadAttribute

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Alignment | Specifies the X, Y, and Z alignment point coordinates of the attribute
Application | Returns the application object.
Backward | Determines whether the text is backward or not
Constant | Specifies the constant mode of the attribute
Database | Returns the database object.
Document | Returns the document object.
FieldLength | Specifies the field length of the attribute.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Height | Specifies the height of the attribute
HorizontalAlignment | Specifies the horizontal alignment of the attribute
Hyperlinks | Specifies the hyperlink collection for the object.
InsertionPoint | Specifies the X, Y, and Z insertion point coordinates of the text
Invisible | Specifies the invisible mode of the attribute
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
LockPosition | Specifies whether the attribute may be moved relative to the geometry in the block
Mode | Specifies the mode of the attribute.
Normal | Specifies the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
ObliqueAngle | Specifies the oblique angle of the attribute
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Preset | Specifies the preset mode of the attribute
PromptString | Specifies the prompt string of the attribute
Rotation | Specifies the rotation angle of the attribute
ScaleFactor | Specifies the scale factor of the attribute
StyleName | Specifies the text style of the attribute
TagString | Specifies the tag string of the attribute
TextAlignmentPoint | Specifies the X, Y, and Z alignment points of the attribute
TextGenerationFlag | the attribute text generation flag.
TextString | Specifies the text string of the attribute
Thickness | Specifies the thickness of the attribute
TrueColor | Returns the true color of the object.
UpsideDown | Determines whether the text is upside down or not
Verify | Specifies the verify mode of the attribute
VerticalAlignment | Specifies the vertical alignment of the attribute.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Attribute.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Attribute.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Attribute.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Attribute object.

Return value

Object

Examples...

Copy Method example


Attribute.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Attribute object.

Examples...

Delete Method example


Attribute.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Attribute object.

Examples...

Erase Method example


Attribute.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Attribute.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Attribute object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Attribute.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Attribute.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Attribute.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Attribute.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Attribute.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Attribute.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Attribute.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Attribute.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Attribute object.


Attribute.Alignment Property

Specifies the X, Y, and Z alignment point coordinates of the attribute

Syntax

object.Alignment

object is a Attribute object.

Description

Alignment ZcAlignment: Read-write
Can be one of the constants listed here:
zcAlignmentLeft
zcAlignmentCenter
zcAlignmentRight
zcAlignmentAligned
zcAlignmentMiddle
zcAlignmentFit
zcAlignmentTopLeft
zcAlignmentTopCenter
zcAlignmentTopRight
zcAlignmentMiddleLeft
zcAlignmentMiddleCenter
zcAlignmentMiddleRight
zcAlignmentBottomLeft
zcAlignmentBottomCenter
zcAlignmentBottomRight

Examples...

Alignment Property example


Attribute.Application Property

Returns the application object.

Syntax

object.Application

object is a Attribute object.

Description

Application Object; Read-only

Examples...

Application Property example


Attribute.Backward Property

Determines whether the text is backward or not

Syntax

object.Backward

object is a Attribute object.

Description

Backward Boolean; Read-write

Examples...

Backward Property example


Attribute.Constant Property

Specifies the constant mode of the attribute

Syntax

object.Constant

object is a Attribute object.

Description

Constant Boolean; Read-write

Examples...

Constant Property example


Attribute.Database Property

Returns the database object.

Syntax

object.Database

object is a Attribute object.

Description

Database Database; Read-only


Attribute.Document Property

Returns the document object.

Syntax

object.Document

object is a Attribute object.

Description

Document Object; Read-only


Attribute.FieldLength Property

Specifies the field length of the attribute.

Syntax

object.FieldLength

object is a Attribute object.

Description

FieldLength Long; Read-write


Attribute.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Attribute object.

Description

Handle String; Read-only


Attribute.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Attribute object.

Description

HasExtensionDictionary Boolean; Read-only


Attribute.Height Property

Specifies the height of the attribute

Syntax

object.Height

object is a Attribute object.

Description

Height Double; Read-write


Attribute.HorizontalAlignment Property

Specifies the horizontal alignment of the attribute

Syntax

object.HorizontalAlignment

object is a Attribute object.

Description

HorizontalAlignment ZcHorizontalAlignment: Read-write
Can be one of the constants listed here:
zcHorizontalAlignmentLeft
zcHorizontalAlignmentCenter
zcHorizontalAlignmentRight
zcHorizontalAlignmentAligned
zcHorizontalAlignmentMiddle
zcHorizontalAlignmentFit


Attribute.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Attribute object.

Description

Hyperlinks Hyperlinks; Read-only


Attribute.InsertionPoint Property

Specifies the X, Y, and Z insertion point coordinates of the text

Syntax

object.InsertionPoint

object is a Attribute object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


Attribute.Invisible Property

Specifies the invisible mode of the attribute

Syntax

object.Invisible

object is a Attribute object.

Description

Invisible Boolean; Read-write

Examples...

Invisible Property example


Attribute.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Attribute object.

Description

Layer String; Read-write

Examples...

Layer Property example


Attribute.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Attribute object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Attribute.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Attribute object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Attribute.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Attribute object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Attribute.LockPosition Property

Specifies whether the attribute may be moved relative to the geometry in the block

Syntax

object.LockPosition

object is a Attribute object.

Description

LockPosition Boolean; Read-write


Attribute.Mode Property

Specifies the mode of the attribute.

Syntax

object.Mode

object is a Attribute object.

Description

Mode Long; Read-write

Examples...

Mode Property example


Attribute.Normal Property

Specifies the normal direction vector.

Syntax

object.Normal

object is a Attribute object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Attribute.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Attribute object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Attribute.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Attribute object.

Description

ObjectName String; Read-only


Attribute.ObliqueAngle Property

Specifies the oblique angle of the attribute

Syntax

object.ObliqueAngle

object is a Attribute object.

Description

ObliqueAngle ZCAD_ANGLE: alias for Double; Read-write

Examples...

ObliqueAngle Property example


Attribute.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Attribute object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Attribute.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Attribute object.

Description

PlotStyleName String; Read-write


Attribute.Preset Property

Specifies the preset mode of the attribute

Syntax

object.Preset

object is a Attribute object.

Description

Preset Boolean; Read-write

Examples...

Preset Property example


Attribute.PromptString Property

Specifies the prompt string of the attribute

Syntax

object.PromptString

object is a Attribute object.

Description

PromptString String; Read-write

Examples...

PromptString Property example


Attribute.Rotation Property

Specifies the rotation angle of the attribute

Syntax

object.Rotation

object is a Attribute object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


Attribute.ScaleFactor Property

Specifies the scale factor of the attribute

Syntax

object.ScaleFactor

object is a Attribute object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


Attribute.StyleName Property

Specifies the text style of the attribute

Syntax

object.StyleName

object is a Attribute object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


Attribute.TagString Property

Specifies the tag string of the attribute

Syntax

object.TagString

object is a Attribute object.

Description

TagString String; Read-write

Examples...

TagString Property example


Attribute.TextAlignmentPoint Property

Specifies the X, Y, and Z alignment points of the attribute

Syntax

object.TextAlignmentPoint

object is a Attribute object.

Description

TextAlignmentPoint Variant; Read-write

Examples...

TextAlignmentPoint Property example


Attribute.TextGenerationFlag Property

the attribute text generation flag.

Syntax

object.TextGenerationFlag

object is a Attribute object.

Description

TextGenerationFlag Long; Read-write

Examples...

TextGenerationFlag Property example


Attribute.TextString Property

Specifies the text string of the attribute

Syntax

object.TextString

object is a Attribute object.

Description

TextString String; Read-write

Examples...

TextString Property example


Attribute.Thickness Property

Specifies the thickness of the attribute

Syntax

object.Thickness

object is a Attribute object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


Attribute.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Attribute object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Attribute.UpsideDown Property

Determines whether the text is upside down or not

Syntax

object.UpsideDown

object is a Attribute object.

Description

UpsideDown Boolean; Read-write

Examples...

UpsideDown Property example


Attribute.Verify Property

Specifies the verify mode of the attribute

Syntax

object.Verify

object is a Attribute object.

Description

Verify Boolean; Read-write

Examples...

Verify Property example


Attribute.VerticalAlignment Property

Specifies the vertical alignment of the attribute.

Syntax

object.VerticalAlignment

object is a Attribute object.

Description

VerticalAlignment ZcVerticalAlignment: Read-write
Can be one of the constants listed here:
zcVerticalAlignmentBaseline
zcVerticalAlignmentBottom
zcVerticalAlignmentMiddle
zcVerticalAlignmentTop


Attribute.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Attribute object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Attribute.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Attribute object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadAttributeReference Object Members

AttributeReference Object Members

An object containing text that links to a block.

VBA Class Name

ZcadAttributeReference

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Alignment | Specifies the alignment of the attribute reference
Application | Returns the application object.
Backward | Determines whether the text is backward and sets the text backward
Constant | Specifies the constant mode of the attribute reference
Database | Returns the database object.
Document | Returns the document object.
FieldLength | Specifies the field length of the attribute reference
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Height | Specifies the height of the attribute reference
HorizontalAlignment | Specifies the horizontal alignment of the attribute reference
Hyperlinks | Specifies the hyperlink collection for the object.
InsertionPoint | Specifies the insertion point of the text
Invisible | Specifies the invisible mode of the attribute reference
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
ObliqueAngle | Specifies the oblique angle of the attribute reference
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Specifies the rotation angle of the attribute reference
ScaleFactor | Specifies the scale factor of the attribute reference
StyleName | Specifies the style name of the attribute reference
TagString | Specifies the tag string of the attribute reference
TextAlignmentPoint | Specifies the alignment point of the attribute reference
TextGenerationFlag | Specifies the attribute reference text generation flag
TextString | Specifies the text string of the attribute reference
Thickness | Specifies the thickness of the attribute reference
TrueColor | Returns the true color of the object.
UpsideDown | Returns whether the text is upside down and sets the text upside down
VerticalAlignment | Specifies the vertical alignment of the attribute reference
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


AttributeReference.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


AttributeReference.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


AttributeReference.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a AttributeReference object.

Return value

Object

Examples...

Copy Method example


AttributeReference.Delete Method

Deletes the object.

Syntax

object.Delete

object is a AttributeReference object.

Examples...

Delete Method example


AttributeReference.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a AttributeReference object.

Examples...

Erase Method example


AttributeReference.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


AttributeReference.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a AttributeReference object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


AttributeReference.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


AttributeReference.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


AttributeReference.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


AttributeReference.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


AttributeReference.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


AttributeReference.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


AttributeReference.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


AttributeReference.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a AttributeReference object.


AttributeReference.Alignment Property

Specifies the alignment of the attribute reference

Syntax

object.Alignment

object is a AttributeReference object.

Description

Alignment ZcAlignment: Read-write
Can be one of the constants listed here:
zcAlignmentLeft
zcAlignmentCenter
zcAlignmentRight
zcAlignmentAligned
zcAlignmentMiddle
zcAlignmentFit
zcAlignmentTopLeft
zcAlignmentTopCenter
zcAlignmentTopRight
zcAlignmentMiddleLeft
zcAlignmentMiddleCenter
zcAlignmentMiddleRight
zcAlignmentBottomLeft
zcAlignmentBottomCenter
zcAlignmentBottomRight

Examples...

Alignment Property example


AttributeReference.Application Property

Returns the application object.

Syntax

object.Application

object is a AttributeReference object.

Description

Application Object; Read-only

Examples...

Application Property example


AttributeReference.Backward Property

Determines whether the text is backward and sets the text backward

Syntax

object.Backward

object is a AttributeReference object.

Description

Backward Boolean; Read-write

Examples...

Backward Property example


AttributeReference.Constant Property

Specifies the constant mode of the attribute reference

Syntax

object.Constant

object is a AttributeReference object.

Description

Constant Boolean; Read-only

Examples...

Constant Property example


AttributeReference.Database Property

Returns the database object.

Syntax

object.Database

object is a AttributeReference object.

Description

Database Database; Read-only


AttributeReference.Document Property

Returns the document object.

Syntax

object.Document

object is a AttributeReference object.

Description

Document Object; Read-only


AttributeReference.FieldLength Property

Specifies the field length of the attribute reference

Syntax

object.FieldLength

object is a AttributeReference object.

Description

FieldLength Long; Read-write


AttributeReference.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a AttributeReference object.

Description

Handle String; Read-only


AttributeReference.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a AttributeReference object.

Description

HasExtensionDictionary Boolean; Read-only


AttributeReference.Height Property

Specifies the height of the attribute reference

Syntax

object.Height

object is a AttributeReference object.

Description

Height Double; Read-write


AttributeReference.HorizontalAlignment Property

Specifies the horizontal alignment of the attribute reference

Syntax

object.HorizontalAlignment

object is a AttributeReference object.

Description

HorizontalAlignment ZcHorizontalAlignment: Read-write
Can be one of the constants listed here:
zcHorizontalAlignmentLeft
zcHorizontalAlignmentCenter
zcHorizontalAlignmentRight
zcHorizontalAlignmentAligned
zcHorizontalAlignmentMiddle
zcHorizontalAlignmentFit


AttributeReference.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a AttributeReference object.

Description

Hyperlinks Hyperlinks; Read-only


AttributeReference.InsertionPoint Property

Specifies the insertion point of the text

Syntax

object.InsertionPoint

object is a AttributeReference object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


AttributeReference.Invisible Property

Specifies the invisible mode of the attribute reference

Syntax

object.Invisible

object is a AttributeReference object.

Description

Invisible Boolean; Read-write

Examples...

Invisible Property example


AttributeReference.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a AttributeReference object.

Description

Layer String; Read-write

Examples...

Layer Property example


AttributeReference.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a AttributeReference object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


AttributeReference.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a AttributeReference object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


AttributeReference.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a AttributeReference object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


AttributeReference.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a AttributeReference object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


AttributeReference.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a AttributeReference object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


AttributeReference.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a AttributeReference object.

Description

ObjectName String; Read-only


AttributeReference.ObliqueAngle Property

Specifies the oblique angle of the attribute reference

Syntax

object.ObliqueAngle

object is a AttributeReference object.

Description

ObliqueAngle ZCAD_ANGLE: alias for Double; Read-write

Examples...

ObliqueAngle Property example


AttributeReference.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a AttributeReference object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


AttributeReference.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a AttributeReference object.

Description

PlotStyleName String; Read-write


AttributeReference.Rotation Property

Specifies the rotation angle of the attribute reference

Syntax

object.Rotation

object is a AttributeReference object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


AttributeReference.ScaleFactor Property

Specifies the scale factor of the attribute reference

Syntax

object.ScaleFactor

object is a AttributeReference object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


AttributeReference.StyleName Property

Specifies the style name of the attribute reference

Syntax

object.StyleName

object is a AttributeReference object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


AttributeReference.TagString Property

Specifies the tag string of the attribute reference

Syntax

object.TagString

object is a AttributeReference object.

Description

TagString String; Read-write

Examples...

TagString Property example


AttributeReference.TextAlignmentPoint Property

Specifies the alignment point of the attribute reference

Syntax

object.TextAlignmentPoint

object is a AttributeReference object.

Description

TextAlignmentPoint Variant; Read-write

Examples...

TextAlignmentPoint Property example


AttributeReference.TextGenerationFlag Property

Specifies the attribute reference text generation flag

Syntax

object.TextGenerationFlag

object is a AttributeReference object.

Description

TextGenerationFlag Long; Read-write

Examples...

TextGenerationFlag Property example


AttributeReference.TextString Property

Specifies the text string of the attribute reference

Syntax

object.TextString

object is a AttributeReference object.

Description

TextString String; Read-write

Examples...

TextString Property example


AttributeReference.Thickness Property

Specifies the thickness of the attribute reference

Syntax

object.Thickness

object is a AttributeReference object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


AttributeReference.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a AttributeReference object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


AttributeReference.UpsideDown Property

Returns whether the text is upside down and sets the text upside down

Syntax

object.UpsideDown

object is a AttributeReference object.

Description

UpsideDown Boolean; Read-write

Examples...

UpsideDown Property example


AttributeReference.VerticalAlignment Property

Specifies the vertical alignment of the attribute reference

Syntax

object.VerticalAlignment

object is a AttributeReference object.

Description

VerticalAlignment ZcVerticalAlignment: Read-write
Can be one of the constants listed here:
zcVerticalAlignmentBaseline
zcVerticalAlignmentBottom
zcVerticalAlignmentMiddle
zcVerticalAlignmentTop


AttributeReference.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a AttributeReference object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


AttributeReference.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a AttributeReference object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadBlock Object Members

Block Object Members

A block definition containing a name and a set of objects.

VBA Class Name

ZcadBlock

Methods

Name | Description
Add3DFace | Creates a three dimensional face given four vertices.
Add3DPoly | Creates a three dimensional polyline entity.
AddArc | Creates an arc with center, radius, start angle and end angle.
AddAttribute | Adds an attribute definition.
AddBox | Creates a box with edges parallel to the World Coordinate System axes given the length, width and height dimensions.
AddCircle | Creates a circle given the center and radius in the current UCS.
AddCone | Creates a cone given the center, base radius and height.
AddCustomObject | Adds a custom object to the collection.
AddCylinder | Creates a cylinder given the center, base radius and height.
AddDim3PointAngular | Creates a 3 point angular dimension.
AddDimAligned | Creates an aligned dimension.
AddDimAngular | Creates an angular dimension.
AddDimDiametric | Creates a diametric dimension.
AddDimOrdinate | Creates an ordinate dimension.
AddDimRadial | Creates a radial dimension.
AddDimRotated | Creates a linear dimension.
AddEllipse | Creates an ellipse in the current UCS given the center, major and minor axes.
AddEllipticalCone | Creates a cone given the center, major and minor radii and height.
AddEllipticalCylinder | Creates a cylinder given the center, major and minor radii and height.
AddExtrudedSolid | Creates an extruded solid given the profile and a height.
AddExtrudedSolidAlongPath | Creates an extruded solid given the profile and a path.
AddHatch | Creates a hatch entity.
AddLeader | Creates a leader line.
AddLine | Adds a line to ModelSpace or PaperSpace or a block.
AddMInsertBlock | Inserts an array of blocks in the current document.
AddMLine | Inserts an mline object in the current document.
AddPoint | Creates a point entity at a given location.
AddPolyfaceMesh | Inserts polyface mesh object in the current document.
AddPolyline | Creates a polyline.
AddRaster | Creates a raster based of given image filename.
AddRay | Creates a ray passing through two given points.
AddRegion | Creates a region from the given closed curve sets.
AddRevolvedSolid | Creates a revolved solid given the profile and a revolution path.
AddShape | Creates a given shape.
AddSolid | Creates an ZWCAD solid.
AddSphere | Creates a sphere given the center and radius.
AddSpline | Creates a B-spline given n points and the end tangents.
AddTable | Creates a table at the given insertion point, given the number of rows, number of columns, row height and column width.
AddText | Creates a text entity with specified height and rotation.
AddTolerance | Creates a tolerance.
AddTorus | Creates a torus given the center, torus and tube radius.
AddTrace | Creates a trace entity with four points.
AddWedge | Creates a wedge with edges parallel to the axes given the length, width and height dimensions
AttachExternalReference | Attach an external reference to the block.
Bind | Bind the external reference.
Delete | Deletes the object.
Detach | Detach the external reference.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
InsertBlock | Inserts an instance of a block in the current document.
Item | Returns an entity in the collection.
Reload | Reload the external reference.
Unload | Unload the external reference.

Properties

Name | Description
Application | Returns the application object.
Comments | Specifies the comments you want to use to locate the drawing.
Count | Returns the number of entities in the collections.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
IsLayout | Returns a value indicating whether the block is also a layout.
IsXRef | Returns a boolean indicating whether the block is an external reference.
Layout | Returns the associated layout object.
Name | Returns and sets the name of the block.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
Origin | Returns and sets the origin of the block definition.
OwnerID | Returns the OwnerID of the object.
Path | Gets the path of the block, document, application, or external reference.
XRefDatabase | Returns a database object that defines the contents of the block.

Events

Name | Description
Modified | Happens when object is modified


Block.Add3DFace Method

Creates a three dimensional face given four vertices.

Syntax

object.Add3DFace(Point1, Point2, point3, Point4)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -
point3 | Input-only | Variant | -
Point4 | Input-only | Variant | -

Return value

3DFace

Examples...

Add3DFace Method example


Block.Add3DPoly Method

Creates a three dimensional polyline entity.

Syntax

object.Add3DPoly(PointsArray)

object is a Block object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -

Return value

3DPolyline

Examples...

Add3DPoly Method example


Block.AddArc Method

Creates an arc with center, radius, start angle and end angle.

Syntax

object.AddArc(Center, Radius, StartAngle, EndAngle)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -
StartAngle | Input-only | Double | -
EndAngle | Input-only | Double | -

Return value

Arc

Examples...

AddArc Method example


Block.AddAttribute Method

Adds an attribute definition.

Syntax

object.AddAttribute(Height, Mode, Prompt, InsertionPoint, Tag, Value)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Height | Input-only | Double | -
Mode | Input-only | ZcAttributeMode | Can be one of the constants listed here: zcAttributeModeNormal zcAttributeModeInvisible zcAttributeModeConstant zcAttributeModeVerify zcAttributeModePreset zcAttributeModeLockPosition zcAttributeModeMultipleLine
Prompt | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Tag | Input-only | String | -
Value | Input-only | String | -

Return value

Attribute

Examples...

AddAttribute Method example


Block.AddBox Method

Creates a box with edges parallel to the World Coordinate System axes given the length, width and height dimensions.

Syntax

object.AddBox(Origin, Length, Width, Height)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Origin | Input-only | Variant | -
Length | Input-only | Double | -
Width | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddBox Method example


Block.AddCircle Method

Creates a circle given the center and radius in the current UCS.

Syntax

object.AddCircle(Center, Radius)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -

Return value

Circle

Examples...

AddCircle Method example


Block.AddCone Method

Creates a cone given the center, base radius and height.

Syntax

object.AddCone(Center, BaseRadius, Height)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
BaseRadius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddCone Method example


Block.AddCustomObject Method

Adds a custom object to the collection.

Syntax

object.AddCustomObject(ClassName)

object is a Block object.

Parameters

Name | Options | Data Type | Description
ClassName | Input-only | String | -

Return value

Object


Block.AddCylinder Method

Creates a cylinder given the center, base radius and height.

Syntax

object.AddCylinder(Center, Radius, Height)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddCylinder Method example


Block.AddDim3PointAngular Method

Creates a 3 point angular dimension.

Syntax

object.AddDim3PointAngular(AngleVertex, FirstEndPoint, SecondEndPoint, TextPoint)

object is a Block object.

Parameters

Name | Options | Data Type | Description
AngleVertex | Input-only | Variant | -
FirstEndPoint | Input-only | Variant | -
SecondEndPoint | Input-only | Variant | -
TextPoint | Input-only | Variant | -

Return value

Dim3PointAngular

Examples...

AddDim3PointAngular Method example


Block.AddDimAligned Method

Creates an aligned dimension.

Syntax

object.AddDimAligned(ExtLine1Point, ExtLine2Point, TextPosition)

object is a Block object.

Parameters

Name | Options | Data Type | Description
ExtLine1Point | Input-only | Variant | -
ExtLine2Point | Input-only | Variant | -
TextPosition | Input-only | Variant | -

Return value

DimAligned

Examples...

AddDimAligned Method example


Block.AddDimAngular Method

Creates an angular dimension.

Syntax

object.AddDimAngular(AngleVertex, FirstEndPoint, SecondEndPoint, TextPoint)

object is a Block object.

Parameters

Name | Options | Data Type | Description
AngleVertex | Input-only | Variant | -
FirstEndPoint | Input-only | Variant | -
SecondEndPoint | Input-only | Variant | -
TextPoint | Input-only | Variant | -

Return value

DimAngular

Examples...

AddDimAngular Method example


Block.AddDimDiametric Method

Creates a diametric dimension.

Syntax

object.AddDimDiametric(ChordPoint, FarChordPoint, LeaderLength)

object is a Block object.

Parameters

Name | Options | Data Type | Description
ChordPoint | Input-only | Variant | -
FarChordPoint | Input-only | Variant | -
LeaderLength | Input-only | Double | -

Return value

DimDiametric

Examples...

AddDimDiametric Method example


Block.AddDimOrdinate Method

Creates an ordinate dimension.

Syntax

object.AddDimOrdinate(DefinitionPoint, LeaderEndPoint, UseXAxis)

object is a Block object.

Parameters

Name | Options | Data Type | Description
DefinitionPoint | Input-only | Variant | -
LeaderEndPoint | Input-only | Variant | -
UseXAxis | Input-only | Integer | -

Return value

DimOrdinate

Examples...

AddDimOrdinate Method example


Block.AddDimRadial Method

Creates a radial dimension.

Syntax

object.AddDimRadial(Center, ChordPoint, LeaderLength)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
ChordPoint | Input-only | Variant | -
LeaderLength | Input-only | Double | -

Return value

DimRadial

Examples...

AddDimRadial Method example


Block.AddDimRotated Method

Creates a linear dimension.

Syntax

object.AddDimRotated(ExtLine1Point, ExtLine2Point, DimLineLocation, RotationAngle)

object is a Block object.

Parameters

Name | Options | Data Type | Description
ExtLine1Point | Input-only | Variant | -
ExtLine2Point | Input-only | Variant | -
DimLineLocation | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Return value

DimRotated

Examples...

AddDimRotated Method example


Block.AddEllipse Method

Creates an ellipse in the current UCS given the center, major and minor axes.

Syntax

object.AddEllipse(Center, MajorAxis, RadiusRatio)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
MajorAxis | Input-only | Variant | -
RadiusRatio | Input-only | Double | -

Return value

Ellipse

Examples...

AddEllipse Method example


Block.AddEllipticalCone Method

Creates a cone given the center, major and minor radii and height.

Syntax

object.AddEllipticalCone(Center, MajorRadius, MinorRadius, Height)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
MajorRadius | Input-only | Double | -
MinorRadius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddEllipticalCone Method example


Block.AddEllipticalCylinder Method

Creates a cylinder given the center, major and minor radii and height.

Syntax

object.AddEllipticalCylinder(Center, MajorRadius, MinorRadius, Height)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
MajorRadius | Input-only | Double | -
MinorRadius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddEllipticalCylinder Method example


Block.AddExtrudedSolid Method

Creates an extruded solid given the profile and a height.

Syntax

object.AddExtrudedSolid(Profile, Height, TaperAngle)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Profile | Input-only | Region | -
Height | Input-only | Double | -
TaperAngle | Input-only | Double | -

Return value

3DSolid

Examples...

AddExtrudedSolid Method example


Block.AddExtrudedSolidAlongPath Method

Creates an extruded solid given the profile and a path.

Syntax

object.AddExtrudedSolidAlongPath(Profile, Path)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Profile | Input-only | Region | -
Path | Input-only | Object | -

Return value

3DSolid

Examples...

AddExtrudedSolidAlongPath Method example


Block.AddHatch Method

Creates a hatch entity.

Syntax

object.AddHatch(PatternType, PatternName, Associativity, HatchObjectType)

object is a Block object.

Parameters

Name | Options | Data Type | Description
PatternType | Input-only | Integer | -
PatternName | Input-only | String | -
Associativity | Input-only | Boolean | -
HatchObjectType | Input-only, Optional | Variant | -

Return value

Hatch

Examples...

AddHatch Method example


Block.AddLeader Method

Creates a leader line.

Syntax

object.AddLeader(PointsArray, Annotation, Type)

object is a Block object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -
Annotation | Input-only | Entity | -
Type | Input-only | ZcLeaderType | Can be one of the constants listed here: zcLineNoArrow zcSplineNoArrow zcLineWithArrow zcSplineWithArrow

Return value

Leader

Examples...

AddLeader Method example


Block.AddLine Method

Adds a line to ModelSpace or PaperSpace or a block.

Syntax

object.AddLine(StartPoint, EndPoint)

object is a Block object.

Parameters

Name | Options | Data Type | Description
StartPoint | Input-only | Variant | -
EndPoint | Input-only | Variant | -

Return value

Line

Examples...

AddLine Method example


Block.AddMInsertBlock Method

Inserts an array of blocks in the current document.

Syntax

object.AddMInsertBlock(InsertionPoint, Name, Xscale, Yscale, Zscale, Rotation, NumRows, NumColumns, RowSpacing, ColumnSpacing, Password)

object is a Block object.

Parameters

Name | Options | Data Type | Description
InsertionPoint | Input-only | Variant | -
Name | Input-only | String | -
Xscale | Input-only | Double | -
Yscale | Input-only | Double | -
Zscale | Input-only | Double | -
Rotation | Input-only | Double | -
NumRows | Input-only | Long | -
NumColumns | Input-only | Long | -
RowSpacing | Input-only | Long | -
ColumnSpacing | Input-only | Long | -
Password | Input-only, Optional | Variant | -

Return value

MInsertBlock


Block.AddMLine Method

Inserts an mline object in the current document.

Syntax

object.AddMLine(VertexList)

object is a Block object.

Parameters

Name | Options | Data Type | Description
VertexList | Input-only | Variant | -

Return value

MLine

Examples...

AddMLine Method example


Block.AddPoint Method

Creates a point entity at a given location.

Syntax

object.AddPoint(Point)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Point | Input-only | Variant | -

Return value

Point

Examples...

AddPoint Method example


Block.AddPolyfaceMesh Method

Inserts polyface mesh object in the current document.

Syntax

object.AddPolyfaceMesh(VertexList, FaceList)

object is a Block object.

Parameters

Name | Options | Data Type | Description
VertexList | Input-only | Variant | -
FaceList | Input-only | Variant | -

Return value

PolyfaceMesh

Examples...

AddPolyfaceMesh Method example


Block.AddPolyline Method

Creates a polyline.

Syntax

object.AddPolyline(VerticesList)

object is a Block object.

Parameters

Name | Options | Data Type | Description
VerticesList | Input-only | Variant | -

Return value

Polyline

Examples...

AddPolyline Method example


Block.AddRaster Method

Creates a raster based of given image filename.

Syntax

object.AddRaster(imageFileName, InsertionPoint, ScaleFactor, RotationAngle)

object is a Block object.

Parameters

Name | Options | Data Type | Description
imageFileName | Input-only | String | -
InsertionPoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -
RotationAngle | Input-only | Double | -

Return value

RasterImage

Examples...

AddRaster Method example


Block.AddRay Method

Creates a ray passing through two given points.

Syntax

object.AddRay(Point1, Point2)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Ray

Examples...

AddRay Method example


Block.AddRegion Method

Creates a region from the given closed curve sets.

Syntax

object.AddRegion(ObjectList)

object is a Block object.

Parameters

Name | Options | Data Type | Description
ObjectList | Input-only | Variant | -

Return value

Variant

Examples...

AddRegion Method example


Block.AddRevolvedSolid Method

Creates a revolved solid given the profile and a revolution path.

Syntax

object.AddRevolvedSolid(Profile, AxisPoint, AxisDir, Angle)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Profile | Input-only | Region | -
AxisPoint | Input-only | Variant | -
AxisDir | Input-only | Variant | -
Angle | Input-only | Double | -

Return value

3DSolid

Examples...

AddRevolvedSolid Method example


Block.AddShape Method

Creates a given shape.

Syntax

object.AddShape(Name, InsertionPoint, ScaleFactor, RotationAngle)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -
InsertionPoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -
RotationAngle | Input-only | Double | -

Return value

Shape

Examples...

AddShape Method example


Block.AddSolid Method

Creates an ZWCAD solid.

Syntax

object.AddSolid(Point1, Point2, point3, Point4)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -
point3 | Input-only | Variant | -
Point4 | Input-only | Variant | -

Return value

Solid

Examples...

AddSolid Method example


Block.AddSphere Method

Creates a sphere given the center and radius.

Syntax

object.AddSphere(Center, Radius)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -

Return value

3DSolid

Examples...

AddSphere Method example


Block.AddSpline Method

Creates a B-spline given n points and the end tangents.

Syntax

object.AddSpline(PointsArray, StartTangent, EndTangent)

object is a Block object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -
StartTangent | Input-only | Variant | -
EndTangent | Input-only | Variant | -

Return value

Spline

Examples...

AddSpline Method example


Block.AddTable Method

Creates a table at the given insertion point, given the number of rows, number of columns, row height and column width.

Syntax

object.AddTable(InsertionPoint, NumRows, NumColumns, RowHeight, ColWidth)

object is a Block object.

Parameters

Name | Options | Data Type | Description
InsertionPoint | Input-only | Variant | -
NumRows | Input-only | Integer | -
NumColumns | Input-only | Integer | -
RowHeight | Input-only | Double | -
ColWidth | Input-only | Double | -

Return value

Table


Block.AddText Method

Creates a text entity with specified height and rotation.

Syntax

object.AddText(TextString, InsertionPoint, Height)

object is a Block object.

Parameters

Name | Options | Data Type | Description
TextString | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Height | Input-only | Double | -

Return value

Text

Examples...

AddText Method example


Block.AddTolerance Method

Creates a tolerance.

Syntax

object.AddTolerance(Text, InsertionPoint, Direction)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Text | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Direction | Input-only | Variant | -

Return value

Tolerance

Examples...

AddTolerance Method example


Block.AddTorus Method

Creates a torus given the center, torus and tube radius.

Syntax

object.AddTorus(Center, TorusRadius, TubeRadius)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
TorusRadius | Input-only | Double | -
TubeRadius | Input-only | Double | -

Return value

3DSolid

Examples...

AddTorus Method example


Block.AddTrace Method

Creates a trace entity with four points.

Syntax

object.AddTrace(PointsArray)

object is a Block object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -

Return value

Trace

Examples...

AddTrace Method example


Block.AddWedge Method

Creates a wedge with edges parallel to the axes given the length, width and height dimensions

Syntax

object.AddWedge(Center, Length, Width, Height)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Length | Input-only | Double | -
Width | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddWedge Method example


Block.AttachExternalReference Method

Attach an external reference to the block.

Syntax

object.AttachExternalReference(PathName, Name, InsertionPoint, Xscale, Yscale, Zscale, Rotation, bOverlay, Password)

object is a Block object.

Parameters

Name | Options | Data Type | Description
PathName | Input-only | String | -
Name | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Xscale | Input-only | Double | -
Yscale | Input-only | Double | -
Zscale | Input-only | Double | -
Rotation | Input-only | Double | -
bOverlay | Input-only | Boolean | -
Password | Input-only, Optional | Variant | -

Return value

ExternalReference

Examples...

AttachExternalReference Method example


Block.Bind Method

Bind the external reference.

Syntax

object.Bind(bPrefixName)

object is a Block object.

Parameters

Name | Options | Data Type | Description
bPrefixName | Input-only | Boolean | -

Examples...

Bind Method example


Block.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Block object.

Examples...

Delete Method example


Block.Detach Method

Detach the external reference.

Syntax

object.Detach

object is a Block object.

Examples...

Detach Method example


Block.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Block object.

Examples...

Erase Method example


Block.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Block object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Block.InsertBlock Method

Inserts an instance of a block in the current document.

Syntax

object.InsertBlock(InsertionPoint, Name, Xscale, Yscale, Zscale, Rotation, Password)

object is a Block object.

Parameters

Name | Options | Data Type | Description
InsertionPoint | Input-only | Variant | -
Name | Input-only | String | -
Xscale | Input-only | Double | -
Yscale | Input-only | Double | -
Zscale | Input-only | Double | -
Rotation | Input-only | Double | -
Password | Input-only, Optional | Variant | -

Return value

BlockReference

Examples...

InsertBlock Method example


Block.Item Method

Returns an entity in the collection.

Syntax

object.Item(Index)

object is a Block object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Entity

Examples...

Item Method example


Block.Reload Method

Reload the external reference.

Syntax

object.Reload

object is a Block object.

Examples...

Reload Method example


Block.Unload Method

Unload the external reference.

Syntax

object.Unload

object is a Block object.


Block.Application Property

Returns the application object.

Syntax

object.Application

object is a Block object.

Description

Application Object; Read-only

Examples...

Application Property example


Block.Comments Property

Specifies the comments you want to use to locate the drawing.

Syntax

object.Comments

object is a Block object.

Description

Comments String; Read-write

Examples...

Comments Property example


Block.Count Property

Returns the number of entities in the collections.

Syntax

object.Count

object is a Block object.

Description

Count Long; Read-only

Examples...

Count Property example


Block.Database Property

Returns the database object.

Syntax

object.Database

object is a Block object.

Description

Database Database; Read-only


Block.Document Property

Returns the document object.

Syntax

object.Document

object is a Block object.

Description

Document Object; Read-only


Block.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Block object.

Description

Handle String; Read-only


Block.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Block object.

Description

HasExtensionDictionary Boolean; Read-only


Block.IsLayout Property

Returns a value indicating whether the block is also a layout.

Syntax

object.IsLayout

object is a Block object.

Description

IsLayout Boolean; Read-only

Examples...

IsLayout Property example


Block.IsXRef Property

Returns a boolean indicating whether the block is an external reference.

Syntax

object.IsXRef

object is a Block object.

Description

IsXRef Boolean; Read-only

Examples...

IsXRef Property example


Block.Layout Property

Returns the associated layout object.

Syntax

object.Layout

object is a Block object.

Description

Layout Layout; Read-only

Examples...

Layout Property example


Block.Name Property

Returns and sets the name of the block.

Syntax

object.Name

object is a Block object.

Description

Name String; Read-write

Examples...

Name Property example


Block.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Block object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Block.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Block object.

Description

ObjectName String; Read-only


Block.Origin Property

Returns and sets the origin of the block definition.

Syntax

object.Origin

object is a Block object.

Description

Origin Variant; Read-write

Examples...

Origin Property example


Block.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Block object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Block.Path Property

Gets the path of the block, document, application, or external reference.

Syntax

object.Path

object is a Block object.

Description

Path String; Read-write

Examples...

Path Property example


Block.XRefDatabase Property

Returns a database object that defines the contents of the block.

Syntax

object.XRefDatabase

object is a Block object.

Description

XRefDatabase Database; Read-only


Block.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Block object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadBlockReference Object Members

BlockReference Object Members

An instance of a block definition inserted into a drawing.

VBA Class Name

ZcadBlockReference

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
Explode | Explodes the block and returns the sub-entities as an array of Object
GetAttributes | Gets Attributes in the block
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetConstantAttributes | Gets constant attributes in the block
GetDynamicBlockProperties | Gets the properties of the dynamic block.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasAttributes | Returns whether the block has any attributes in it
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
InsUnits | Specifies insunits saved with the block
InsUnitsFactor | Specifies the conversion factor between block units and drawing units
InsertionPoint | Specifies X, Y, and Z coordinates for insertion point of the block
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Name | Specifies the name of the block
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Specifies the rotation angle of the block
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.
XScaleFactor | Specifies the XScale factor of the block
YScaleFactor | Specifies the Yscale factor of the block
ZScaleFactor | Specifies the ZScale factor of the block

Events

Name | Description
Modified | Happens when object is modified


BlockReference.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


BlockReference.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


BlockReference.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a BlockReference object.

Return value

Object

Examples...

Copy Method example


BlockReference.Delete Method

Deletes the object.

Syntax

object.Delete

object is a BlockReference object.

Examples...

Delete Method example


BlockReference.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a BlockReference object.

Examples...

Erase Method example


BlockReference.Explode Method

Explodes the block and returns the sub-entities as an array of Object

Syntax

object.Explode

object is a BlockReference object.

Return value

Variant

Examples...

Explode Method example


BlockReference.GetAttributes Method

Gets Attributes in the block

Syntax

object.GetAttributes

object is a BlockReference object.

Return value

Variant

Examples...

GetAttributes Method example


BlockReference.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


BlockReference.GetConstantAttributes Method

Gets constant attributes in the block

Syntax

object.GetConstantAttributes

object is a BlockReference object.

Return value

Variant

Examples...

GetConstantAttributes Method example


BlockReference.GetDynamicBlockProperties Method

Gets the properties of the dynamic block.

Syntax

object.GetDynamicBlockProperties()

object is a BlockReference object.

Return value

DynamicBlockReferenceProperty


BlockReference.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a BlockReference object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


BlockReference.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


BlockReference.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


BlockReference.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


BlockReference.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


BlockReference.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


BlockReference.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


BlockReference.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


BlockReference.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a BlockReference object.


BlockReference.Application Property

Returns the application object.

Syntax

object.Application

object is a BlockReference object.

Description

Application Object; Read-only

Examples...

Application Property example


BlockReference.Database Property

Returns the database object.

Syntax

object.Database

object is a BlockReference object.

Description

Database Database; Read-only


BlockReference.Document Property

Returns the document object.

Syntax

object.Document

object is a BlockReference object.

Description

Document Object; Read-only


BlockReference.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a BlockReference object.

Description

Handle String; Read-only


BlockReference.HasAttributes Property

Returns whether the block has any attributes in it

Syntax

object.HasAttributes

object is a BlockReference object.

Description

HasAttributes Boolean; Read-only


BlockReference.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a BlockReference object.

Description

HasExtensionDictionary Boolean; Read-only


BlockReference.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a BlockReference object.

Description

Hyperlinks Hyperlinks; Read-only


BlockReference.InsUnits Property

Specifies insunits saved with the block

Syntax

object.InsUnits

object is a BlockReference object.

Description

InsUnits String; Read-only


BlockReference.InsUnitsFactor Property

Specifies the conversion factor between block units and drawing units

Syntax

object.InsUnitsFactor

object is a BlockReference object.

Description

InsUnitsFactor Double; Read-only


BlockReference.InsertionPoint Property

Specifies X, Y, and Z coordinates for insertion point of the block

Syntax

object.InsertionPoint

object is a BlockReference object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


BlockReference.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a BlockReference object.

Description

Layer String; Read-write

Examples...

Layer Property example


BlockReference.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a BlockReference object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


BlockReference.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a BlockReference object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


BlockReference.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a BlockReference object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


BlockReference.Name Property

Specifies the name of the block

Syntax

object.Name

object is a BlockReference object.

Description

Name String; Read-write

Examples...

Name Property example


BlockReference.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a BlockReference object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


BlockReference.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a BlockReference object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


BlockReference.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a BlockReference object.

Description

ObjectName String; Read-only


BlockReference.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a BlockReference object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


BlockReference.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a BlockReference object.

Description

PlotStyleName String; Read-write


BlockReference.Rotation Property

Specifies the rotation angle of the block

Syntax

object.Rotation

object is a BlockReference object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


BlockReference.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a BlockReference object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


BlockReference.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a BlockReference object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


BlockReference.XScaleFactor Property

Specifies the XScale factor of the block

Syntax

object.XScaleFactor

object is a BlockReference object.

Description

XScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

XScaleFactor Property example


BlockReference.YScaleFactor Property

Specifies the Yscale factor of the block

Syntax

object.YScaleFactor

object is a BlockReference object.

Description

YScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

YScaleFactor Property example


BlockReference.ZScaleFactor Property

Specifies the ZScale factor of the block

Syntax

object.ZScaleFactor

object is a BlockReference object.

Description

ZScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ZScaleFactor Property example


BlockReference.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a BlockReference object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadBlocks Object Members

Blocks Object Members

The collection of all blocks in the drawing.

VBA Class Name

ZcadBlocks

Methods

Name | Description
Add | Adds a block to the blocks collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of items in the collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


Blocks.Add Method

Adds a block to the blocks collection.

Syntax

object.Add(InsertionPoint, Name)

object is a Blocks object.

Parameters

Name | Options | Data Type | Description
InsertionPoint | Input-only | Variant | -
Name | Input-only | String | -

Return value

Block

Examples...

Add Method example


Blocks.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Blocks object.

Examples...

Delete Method example


Blocks.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Blocks object.

Examples...

Erase Method example


Blocks.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Blocks object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Blocks.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a Blocks object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Block

Examples...

Item Method example


Blocks.Application Property

Returns the application object.

Syntax

object.Application

object is a Blocks object.

Description

Application Object; Read-only

Examples...

Application Property example


Blocks.Count Property

Returns the number of items in the collection.

Syntax

object.Count

object is a Blocks object.

Description

Count Long; Read-only

Examples...

Count Property example


Blocks.Database Property

Returns the database object.

Syntax

object.Database

object is a Blocks object.

Description

Database Database; Read-only


Blocks.Document Property

Returns the document object.

Syntax

object.Document

object is a Blocks object.

Description

Document Object; Read-only


Blocks.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Blocks object.

Description

Handle String; Read-only


Blocks.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Blocks object.

Description

HasExtensionDictionary Boolean; Read-only


Blocks.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Blocks object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Blocks.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Blocks object.

Description

ObjectName String; Read-only


Blocks.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Blocks object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Blocks.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Blocks object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadCircle Object Members

Circle Object Members

A full circle.

VBA Class Name

ZcadCircle

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Offset | Creates an arc by offsetting the original arc by a specified distance
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Area | Specifies the area of the circle
Center | Specifies the X, Y, and Z center coordinates of the circle
Circumference | Specifies the circumference of the circle
Database | Returns the database object.
Diameter | Specifies the diameter of the circle
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the X, Y, and Z normal direction vectors
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Radius | Specifies the radius of the circle
Thickness | Specifies the thickness of the circle
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Circle.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Circle.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Circle.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Circle object.

Return value

Object

Examples...

Copy Method example


Circle.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Circle object.

Examples...

Delete Method example


Circle.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Circle object.

Examples...

Erase Method example


Circle.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Circle.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Circle object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Circle.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Circle.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Circle.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Circle.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Circle.Offset Method

Creates an arc by offsetting the original arc by a specified distance

Syntax

object.Offset(Distance)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
Distance | Input-only | Double | -

Return value

Variant


Circle.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Circle.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Circle.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Circle.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Circle object.


Circle.Application Property

Returns the application object.

Syntax

object.Application

object is a Circle object.

Description

Application Object; Read-only

Examples...

Application Property example


Circle.Area Property

Specifies the area of the circle

Syntax

object.Area

object is a Circle object.

Description

Area Double; Read-write

Examples...

Area Property example


Circle.Center Property

Specifies the X, Y, and Z center coordinates of the circle

Syntax

object.Center

object is a Circle object.

Description

Center Variant; Read-write

Examples...

Center Property example


Circle.Circumference Property

Specifies the circumference of the circle

Syntax

object.Circumference

object is a Circle object.

Description

Circumference Double; Read-write

Examples...

Circumference Property example


Circle.Database Property

Returns the database object.

Syntax

object.Database

object is a Circle object.

Description

Database Database; Read-only


Circle.Diameter Property

Specifies the diameter of the circle

Syntax

object.Diameter

object is a Circle object.

Description

Diameter Double; Read-write


Circle.Document Property

Returns the document object.

Syntax

object.Document

object is a Circle object.

Description

Document Object; Read-only


Circle.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Circle object.

Description

Handle String; Read-only


Circle.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Circle object.

Description

HasExtensionDictionary Boolean; Read-only


Circle.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Circle object.

Description

Hyperlinks Hyperlinks; Read-only


Circle.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Circle object.

Description

Layer String; Read-write

Examples...

Layer Property example


Circle.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Circle object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Circle.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Circle object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Circle.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Circle object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Circle.Normal Property

Specifies the X, Y, and Z normal direction vectors

Syntax

object.Normal

object is a Circle object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Circle.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Circle object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Circle.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Circle object.

Description

ObjectName String; Read-only


Circle.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Circle object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Circle.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Circle object.

Description

PlotStyleName String; Read-write


Circle.Radius Property

Specifies the radius of the circle

Syntax

object.Radius

object is a Circle object.

Description

Radius Double; Read-write

Examples...

Radius Property example


Circle.Thickness Property

Specifies the thickness of the circle

Syntax

object.Thickness

object is a Circle object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


Circle.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Circle object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Circle.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Circle object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Circle.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Circle object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDatabase Object Members

Database Object Members

The contents of an XRef block.

VBA Class Name

ZcadDatabase

Methods

Name | Description
CopyObjects | Copies multiple objects in the database.
HandleToObject | Return an object given a handle. Applies to current dwg

Properties

Name | Description
Blocks | Returns the blocks collection object.
Dictionaries | Returns the dictionaries collection.
DimStyles | Returns the dimstyles collection.
ElevationModelSpace | Returns and sets the model space elevation.
ElevationPaperSpace | Returns and sets the paper space elevation.
Groups | Returns the groups collection.
Layers | Returns the layers collection.
Layouts | Returns the layouts collection.
Limits | Returns and sets the limits of the drawing boundary.
Linetypes | Returns the linetypes collection.
ModelSpace | Returns the model space block.
PaperSpace | Returns the paper space block.
PlotConfigurations | Returns the plot configurations collection.
Preferences | Returns the database preferences object.
RegisteredApplications | Returns the registered applications collection.
SummaryInfo | Returns the summary info object.
TextStyles | Returns the text styles collection.
Viewports | Returns the viewports collection.
Views | Returns the views collection.

Events

Name | Description
None | -


Database.CopyObjects Method

Copies multiple objects in the database.

Syntax

object.CopyObjects(Objects, Owner, IdPairs)

object is a Database object.

Parameters

Name | Options | Data Type | Description
Objects | Input-only | Variant | -
Owner | Input-only, Optional | Variant | -
IdPairs | Input-output, Optional | Variant | -

Return value

Variant

Examples...

CopyObjects Method example


Database.HandleToObject Method

Return an object given a handle. Applies to current dwg

Syntax

object.HandleToObject(Handle)

object is a Database object.

Parameters

Name | Options | Data Type | Description
Handle | Input-only | String | -

Return value

Object

Examples...

HandleToObject Method example


Database.Blocks Property

Returns the blocks collection object.

Syntax

object.Blocks

object is a Database object.

Description

Blocks Blocks; Read-only

Examples...

Blocks Property example


Database.Dictionaries Property

Returns the dictionaries collection.

Syntax

object.Dictionaries

object is a Database object.

Description

Dictionaries Dictionaries; Read-only


Database.DimStyles Property

Returns the dimstyles collection.

Syntax

object.DimStyles

object is a Database object.

Description

DimStyles DimStyles; Read-only


Database.ElevationModelSpace Property

Returns and sets the model space elevation.

Syntax

object.ElevationModelSpace

object is a Database object.

Description

ElevationModelSpace Double; Read-write


Database.ElevationPaperSpace Property

Returns and sets the paper space elevation.

Syntax

object.ElevationPaperSpace

object is a Database object.

Description

ElevationPaperSpace Double; Read-write


Database.Groups Property

Returns the groups collection.

Syntax

object.Groups

object is a Database object.

Description

Groups Groups; Read-only


Database.Layers Property

Returns the layers collection.

Syntax

object.Layers

object is a Database object.

Description

Layers Layers; Read-only

Examples...

Layers Property example


Database.Layouts Property

Returns the layouts collection.

Syntax

object.Layouts

object is a Database object.

Description

Layouts Layouts; Read-only

Examples...

Layouts Property example


Database.Limits Property

Returns and sets the limits of the drawing boundary.

Syntax

object.Limits

object is a Database object.

Description

Limits Variant; Read-write


Database.Linetypes Property

Returns the linetypes collection.

Syntax

object.Linetypes

object is a Database object.

Description

Linetypes LineTypes; Read-only

Examples...

Linetypes Property example


Database.ModelSpace Property

Returns the model space block.

Syntax

object.ModelSpace

object is a Database object.

Description

ModelSpace ModelSpace; Read-only

Examples...

ModelSpace Property example


Database.PaperSpace Property

Returns the paper space block.

Syntax

object.PaperSpace

object is a Database object.

Description

PaperSpace PaperSpace; Read-only

Examples...

PaperSpace Property example


Database.PlotConfigurations Property

Returns the plot configurations collection.

Syntax

object.PlotConfigurations

object is a Database object.

Description

PlotConfigurations PlotConfigurations; Read-only

Examples...

PlotConfigurations Property example


Database.Preferences Property

Returns the database preferences object.

Syntax

object.Preferences

object is a Database object.

Description

Preferences DatabasePreferences; Read-only


Database.RegisteredApplications Property

Returns the registered applications collection.

Syntax

object.RegisteredApplications

object is a Database object.

Description

RegisteredApplications RegisteredApplications; Read-only

Examples...

RegisteredApplications Property example


Database.SummaryInfo Property

Returns the summary info object.

Syntax

object.SummaryInfo

object is a Database object.

Description

SummaryInfo SummaryInfo; Read-only

Examples...

SummaryInfo Property example


Database.TextStyles Property

Returns the text styles collection.

Syntax

object.TextStyles

object is a Database object.

Description

TextStyles TextStyles; Read-only

Examples...

TextStyles Property example


Database.Viewports Property

Returns the viewports collection.

Syntax

object.Viewports

object is a Database object.

Description

Viewports Viewports; Read-only

Examples...

Viewports Property example


Database.Views Property

Returns the views collection.

Syntax

object.Views

object is a Database object.

Description

Views Views; Read-only

Examples...

Views Property example


ZcadDatabasePreferences Object Members

DatabasePreferences Object Members

An object that specifies the settings for the current ZWCAD drawing.

VBA Class Name

ZcadDatabasePreferences

Methods

Name | Description
None | -

Properties

Name | Description
AllowLongSymbolNames | Returns and sets the use of symbol names longer than 31 characters.
Application | Returns the application object.
DisplaySilhouette | Controls whether silhouette curves of solid objects are displayed in Wireframe mode.
Lineweight | Specifies the lineweight of an individual object or the default lineweight for the drawing.
MaxActiveViewports | Specifies the maximum number of active viewports.
OLELaunch | Returns and sets the launching of OLE applications for printing.
ObjectSortByPSOutput | Returns and sets the sorting of objects by postscript output order.
ObjectSortByPlotting | Returns and sets the sorting of objects by plotting order.
ObjectSortByRedraws | Returns and sets the sorting of objects by redraw order.
ObjectSortByRegens | Returns and sets the sorting of objects by regen order.
ObjectSortBySelection | Returns and sets the sorting of objects by selection order.
ObjectSortBySnap | Returns and sets the sorting of objects by snap order.
RenderSmoothness | Specifies the smoothness of shaded, rendered, and hidden line-removed objects.
SegmentPerPolyline | Specifies the number of line segments to be generated for each polyline curve.
SolidFill | Returns and sets the filling of solids.
TextFrameDisplay | Toggles the display of frames for text objects instead of displaying the text itself.
XRefEdit | Returns and sets xref editing ability.
XRefLayerVisibility | Returns and sets the visibility of layers from xrefs.

Events

Name | Description
None | -


DatabasePreferences.AllowLongSymbolNames Property

Returns and sets the use of symbol names longer than 31 characters.

Syntax

object.AllowLongSymbolNames

object is a DatabasePreferences object.

Description

AllowLongSymbolNames Boolean; Read-write


DatabasePreferences.Application Property

Returns the application object.

Syntax

object.Application

object is a DatabasePreferences object.

Description

Application Object; Read-only

Examples...

Application Property example


DatabasePreferences.DisplaySilhouette Property

Controls whether silhouette curves of solid objects are displayed in Wireframe mode.

Syntax

object.DisplaySilhouette

object is a DatabasePreferences object.

Description

DisplaySilhouette Boolean; Read-write


DatabasePreferences.Lineweight Property

Specifies the lineweight of an individual object or the default lineweight for the drawing.

Syntax

object.Lineweight

object is a DatabasePreferences object.

Description

Lineweight ZcLineWeight: Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


DatabasePreferences.MaxActiveViewports Property

Specifies the maximum number of active viewports.

Syntax

object.MaxActiveViewports

object is a DatabasePreferences object.

Description

MaxActiveViewports Long; Read-write


DatabasePreferences.OLELaunch Property

Returns and sets the launching of OLE applications for printing.

Syntax

object.OLELaunch

object is a DatabasePreferences object.

Description

OLELaunch Boolean; Read-write


DatabasePreferences.ObjectSortByPSOutput Property

Returns and sets the sorting of objects by postscript output order.

Syntax

object.ObjectSortByPSOutput

object is a DatabasePreferences object.

Description

ObjectSortByPSOutput Boolean; Read-write


DatabasePreferences.ObjectSortByPlotting Property

Returns and sets the sorting of objects by plotting order.

Syntax

object.ObjectSortByPlotting

object is a DatabasePreferences object.

Description

ObjectSortByPlotting Boolean; Read-write


DatabasePreferences.ObjectSortByRedraws Property

Returns and sets the sorting of objects by redraw order.

Syntax

object.ObjectSortByRedraws

object is a DatabasePreferences object.

Description

ObjectSortByRedraws Boolean; Read-write


DatabasePreferences.ObjectSortByRegens Property

Returns and sets the sorting of objects by regen order.

Syntax

object.ObjectSortByRegens

object is a DatabasePreferences object.

Description

ObjectSortByRegens Boolean; Read-write


DatabasePreferences.ObjectSortBySelection Property

Returns and sets the sorting of objects by selection order.

Syntax

object.ObjectSortBySelection

object is a DatabasePreferences object.

Description

ObjectSortBySelection Boolean; Read-write


DatabasePreferences.ObjectSortBySnap Property

Returns and sets the sorting of objects by snap order.

Syntax

object.ObjectSortBySnap

object is a DatabasePreferences object.

Description

ObjectSortBySnap Boolean; Read-write


DatabasePreferences.RenderSmoothness Property

Specifies the smoothness of shaded, rendered, and hidden line-removed objects.

Syntax

object.RenderSmoothness

object is a DatabasePreferences object.

Description

RenderSmoothness Double; Read-write


DatabasePreferences.SegmentPerPolyline Property

Specifies the number of line segments to be generated for each polyline curve.

Syntax

object.SegmentPerPolyline

object is a DatabasePreferences object.

Description

SegmentPerPolyline Long; Read-write


DatabasePreferences.SolidFill Property

Returns and sets the filling of solids.

Syntax

object.SolidFill

object is a DatabasePreferences object.

Description

SolidFill Boolean; Read-write


DatabasePreferences.TextFrameDisplay Property

Toggles the display of frames for text objects instead of displaying the text itself.

Syntax

object.TextFrameDisplay

object is a DatabasePreferences object.

Description

TextFrameDisplay Boolean; Read-write


DatabasePreferences.XRefEdit Property

Returns and sets xref editing ability.

Syntax

object.XRefEdit

object is a DatabasePreferences object.

Description

XRefEdit Boolean; Read-write


DatabasePreferences.XRefLayerVisibility Property

Returns and sets the visibility of layers from xrefs.

Syntax

object.XRefLayerVisibility

object is a DatabasePreferences object.

Description

XRefLayerVisibility Boolean; Read-write


ZcadDictionaries Object Members

Dictionaries Object Members

The collection of all dictionaries in the drawing.

VBA Class Name

ZcadDictionaries

Methods

Name | Description
Add | Adds a dictionary to the dictionaries collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


Dictionaries.Add Method

Adds a dictionary to the dictionaries collection.

Syntax

object.Add(Name)

object is a Dictionaries object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

Dictionary

Examples...

Add Method example


Dictionaries.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Dictionaries object.

Examples...

Delete Method example


Dictionaries.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Dictionaries object.

Examples...

Erase Method example


Dictionaries.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Dictionaries object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Dictionaries.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a Dictionaries object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Object

Examples...

Item Method example


Dictionaries.Application Property

Returns the application object.

Syntax

object.Application

object is a Dictionaries object.

Description

Application Object; Read-only

Examples...

Application Property example


Dictionaries.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a Dictionaries object.

Description

Count Long; Read-only

Examples...

Count Property example


Dictionaries.Database Property

Returns the database object.

Syntax

object.Database

object is a Dictionaries object.

Description

Database Database; Read-only


Dictionaries.Document Property

Returns the document object.

Syntax

object.Document

object is a Dictionaries object.

Description

Document Object; Read-only


Dictionaries.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Dictionaries object.

Description

Handle String; Read-only


Dictionaries.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Dictionaries object.

Description

HasExtensionDictionary Boolean; Read-only


Dictionaries.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Dictionaries object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Dictionaries.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Dictionaries object.

Description

ObjectName String; Read-only


Dictionaries.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Dictionaries object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Dictionaries.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Dictionaries object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDictionary Object Members

Dictionary Object Members

A container object for storing and retrieving objects.

VBA Class Name

ZcadDictionary

Methods

Name | Description
AddObject | Adds a named object to the dictionary.
AddXRecord | Adds an Xrecord to the dictionary.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetName | Specifies the name of an object in the dictionary.
GetObject | Specifies the named object in the dictionary.
Item | Given an Index, returns an item in the dictionary.
Remove | Removes a named object from the dictionary.
Rename | Renames an object in the dictionary.
Replace | Replaces a named object in the dictionary by a given object.

Properties

Name | Description
Application | Returns the application object.
Count | Specifies the number of items in the dictionary.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Name | Specifies the name of the dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


Dictionary.AddObject Method

Adds a named object to the dictionary.

Syntax

object.AddObject(Keyword, ObjectName)

object is a Dictionary object.

Parameters

Name | Options | Data Type | Description
Keyword | Input-only | String | -
ObjectName | Input-only | String | -

Return value

Object

Examples...

AddObject Method example


Dictionary.AddXRecord Method

Adds an Xrecord to the dictionary.

Syntax

object.AddXRecord(Keyword)

object is a Dictionary object.

Parameters

Name | Options | Data Type | Description
Keyword | Input-only | String | -

Return value

XRecord

Examples...

AddXRecord Method example


Dictionary.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Dictionary object.

Examples...

Delete Method example


Dictionary.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Dictionary object.

Examples...

Erase Method example


Dictionary.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Dictionary object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Dictionary.GetName Method

Specifies the name of an object in the dictionary.

Syntax

object.GetName(Object)

object is a Dictionary object.

Parameters

Name | Options | Data Type | Description
Object | Input-only | Object | -

Return value

String

Examples...

GetName Method example


Dictionary.GetObject Method

Specifies the named object in the dictionary.

Syntax

object.GetObject(Name)

object is a Dictionary object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

Object


Dictionary.Item Method

Given an Index, returns an item in the dictionary.

Syntax

object.Item(Index)

object is a Dictionary object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Object

Examples...

Item Method example


Dictionary.Remove Method

Removes a named object from the dictionary.

Syntax

object.Remove(Name)

object is a Dictionary object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

Object


Dictionary.Rename Method

Renames an object in the dictionary.

Syntax

object.Rename(OldName, NewName)

object is a Dictionary object.

Parameters

Name | Options | Data Type | Description
OldName | Input-only | String | -
NewName | Input-only | String | -


Dictionary.Replace Method

Replaces a named object in the dictionary by a given object.

Syntax

object.Replace(OldName, pObj)

object is a Dictionary object.

Parameters

Name | Options | Data Type | Description
OldName | Input-only | String | -
pObj | Input-only | Object | -


Dictionary.Application Property

Returns the application object.

Syntax

object.Application

object is a Dictionary object.

Description

Application Object; Read-only

Examples...

Application Property example


Dictionary.Count Property

Specifies the number of items in the dictionary.

Syntax

object.Count

object is a Dictionary object.

Description

Count Long; Read-only

Examples...

Count Property example


Dictionary.Database Property

Returns the database object.

Syntax

object.Database

object is a Dictionary object.

Description

Database Database; Read-only


Dictionary.Document Property

Returns the document object.

Syntax

object.Document

object is a Dictionary object.

Description

Document Object; Read-only


Dictionary.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Dictionary object.

Description

Handle String; Read-only


Dictionary.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Dictionary object.

Description

HasExtensionDictionary Boolean; Read-only


Dictionary.Name Property

Specifies the name of the dictionary.

Syntax

object.Name

object is a Dictionary object.

Description

Name String; Read-write

Examples...

Name Property example


Dictionary.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Dictionary object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Dictionary.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Dictionary object.

Description

ObjectName String; Read-only


Dictionary.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Dictionary object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Dictionary.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Dictionary object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDim3PointAngular Object Members

Dim3PointAngular Object Members

A dimension measuring the angular distance between three points.

VBA Class Name

ZcadDim3PointAngular

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
AngleFormat | Specifies the angle format (DIMAUNIT system variable)
AngleVertex | Specifies the angle vertex of the dimension
Application | Returns the application object.
Arrowhead1Block | Specifies the block of the first dimension arrowhead
Arrowhead1Type | Specifies type of the first dimension arrowhead (DIMBLK1 system variable)
Arrowhead2Block | Specifies the block of the second dimension arrowhead
Arrowhead2Type | Specifies type of the second dimension arrowhead (DIMBLK2 system variable)
ArrowheadSize | Specifies size of the dimension arrowhead (DIMASZ system variable)
Database | Returns the database object.
DecimalSeparator | Specifies the decimal separator for metric dimensions (DIMDSEP system variable)
DimLine1Suppress | Sets suppression of first dimension line On or Off (DIMSD1 system variable)
DimLine2Suppress | Sets suppression of second dimension line On or Off (DIMSD2 system variable)
DimLineInside | Sets drawing of dimension lines outside extension lines On or Off (DIMSOXD system variable)
DimensionLineColor | Specifies color of the dimension lines (DIMCLRD system variable)
DimensionLineWeight | Specifies lineweight for dimension lines (DIMLWD system variable)
Document | Returns the document object.
ExtLine1EndPoint | Specifies the xLine1 end point of the dimension
ExtLine1Suppress | Sets suppression of first extension line On or Off (DIMSE1 system variable)
ExtLine2EndPoint | Specifies the xLine2 end point of the dimension
ExtLine2Suppress | Sets suppression of second extension line On or Off (DIMSE2 system variable)
ExtensionLineColor | Specifies color of the extension line (DIMCLRE system variable)
ExtensionLineExtend | Specifies amount to extend extension line beyond the dimension line (DIMEXE system variable)
ExtensionLineOffset | Specifies offset of extension lines from the origin points (DIMEXO system variable)
ExtensionLineWeight | Specifies lineweight for extension lines (DIMLWE system variable)
Fit | Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)
ForceLineInside | Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
HorizontalTextPosition | Specifies horizontal dimension text position (DIMJUST system variable)
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Measurement | Specifies dimension measurement value
Normal | Returns and sets the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Returns and sets the horizontal rotation angle of the dimension
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)
SuppressLeadingZeros | Determines suppression of leading zeros for dimensions (DIMZIN system variable)
SuppressTrailingZeros | Determines suppression of trailing zeros for dimensions (DIMZIN system variable)
TextColor | Specifies the color of the dimension text (DIMCLRT system variable)
TextGap | Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)
TextHeight | Specifies text height of the dimension (DIMTXT system variable)
TextInside | Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)
TextInsideAlign | Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)
TextMovement | Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)
TextOutsideAlign | Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)
TextOverride | Specifies the text string of the dimension (overrides Measurement string)
TextPosition | Specifies the dimension text position or pick point
TextPrecision | Specifies number of precision decimal places displayed for angular dimension text
TextPrefix | Specifies the text prefix for the dimension (DIMPOST system variable)
TextRotation | Specifies the rotation angle of the dimension text
TextStyle | Specifies text style of the dimension (DIMTXSTY system variable)
TextSuffix | Specifies the text suffix for the dimension (DIMPOST system variable)
ToleranceDisplay | Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)
ToleranceHeightScale | Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)
ToleranceJustification | Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)
ToleranceLowerLimit | Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)
TolerancePrecision | Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)
ToleranceSuppressLeadingZeros | Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressTrailingZeros | Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)
ToleranceUpperLimit | Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)
TrueColor | Returns the true color of the object.
VerticalTextPosition | Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Dim3PointAngular.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Dim3PointAngular.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Dim3PointAngular.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Dim3PointAngular object.

Return value

Object

Examples...

Copy Method example


Dim3PointAngular.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Dim3PointAngular object.

Examples...

Delete Method example


Dim3PointAngular.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Dim3PointAngular object.

Examples...

Erase Method example


Dim3PointAngular.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Dim3PointAngular.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Dim3PointAngular object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Dim3PointAngular.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Dim3PointAngular.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Dim3PointAngular.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Dim3PointAngular.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Dim3PointAngular.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Dim3PointAngular.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Dim3PointAngular.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Dim3PointAngular.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Dim3PointAngular object.


Dim3PointAngular.AngleFormat Property

Specifies the angle format (DIMAUNIT system variable)

Syntax

object.AngleFormat

object is a Dim3PointAngular object.

Description

AngleFormat ZcAngleUnits: Read-write
Can be one of the constants listed here:
zcDegrees
zcDegreeMinuteSeconds
zcGrads
zcRadians

Examples...

AngleFormat Property example


Dim3PointAngular.AngleVertex Property

Specifies the angle vertex of the dimension

Syntax

object.AngleVertex

object is a Dim3PointAngular object.

Description

AngleVertex Variant; Read-write

Examples...

AngleVertex Property example


Dim3PointAngular.Application Property

Returns the application object.

Syntax

object.Application

object is a Dim3PointAngular object.

Description

Application Object; Read-only

Examples...

Application Property example


Dim3PointAngular.Arrowhead1Block Property

Specifies the block of the first dimension arrowhead

Syntax

object.Arrowhead1Block

object is a Dim3PointAngular object.

Description

Arrowhead1Block String; Read-write


Dim3PointAngular.Arrowhead1Type Property

Specifies type of the first dimension arrowhead (DIMBLK1 system variable)

Syntax

object.Arrowhead1Type

object is a Dim3PointAngular object.

Description

Arrowhead1Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


Dim3PointAngular.Arrowhead2Block Property

Specifies the block of the second dimension arrowhead

Syntax

object.Arrowhead2Block

object is a Dim3PointAngular object.

Description

Arrowhead2Block String; Read-write


Dim3PointAngular.Arrowhead2Type Property

Specifies type of the second dimension arrowhead (DIMBLK2 system variable)

Syntax

object.Arrowhead2Type

object is a Dim3PointAngular object.

Description

Arrowhead2Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


Dim3PointAngular.ArrowheadSize Property

Specifies size of the dimension arrowhead (DIMASZ system variable)

Syntax

object.ArrowheadSize

object is a Dim3PointAngular object.

Description

ArrowheadSize Double; Read-write

Examples...

ArrowheadSize Property example


Dim3PointAngular.Database Property

Returns the database object.

Syntax

object.Database

object is a Dim3PointAngular object.

Description

Database Database; Read-only


Dim3PointAngular.DecimalSeparator Property

Specifies the decimal separator for metric dimensions (DIMDSEP system variable)

Syntax

object.DecimalSeparator

object is a Dim3PointAngular object.

Description

DecimalSeparator String; Read-write


Dim3PointAngular.DimLine1Suppress Property

Sets suppression of first dimension line On or Off (DIMSD1 system variable)

Syntax

object.DimLine1Suppress

object is a Dim3PointAngular object.

Description

DimLine1Suppress Boolean; Read-write


Dim3PointAngular.DimLine2Suppress Property

Sets suppression of second dimension line On or Off (DIMSD2 system variable)

Syntax

object.DimLine2Suppress

object is a Dim3PointAngular object.

Description

DimLine2Suppress Boolean; Read-write


Dim3PointAngular.DimLineInside Property

Sets drawing of dimension lines outside extension lines On or Off (DIMSOXD system variable)

Syntax

object.DimLineInside

object is a Dim3PointAngular object.

Description

DimLineInside Boolean; Read-write


Dim3PointAngular.DimensionLineColor Property

Specifies color of the dimension lines (DIMCLRD system variable)

Syntax

object.DimensionLineColor

object is a Dim3PointAngular object.

Description

DimensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


Dim3PointAngular.DimensionLineWeight Property

Specifies lineweight for dimension lines (DIMLWD system variable)

Syntax

object.DimensionLineWeight

object is a Dim3PointAngular object.

Description

DimensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


Dim3PointAngular.Document Property

Returns the document object.

Syntax

object.Document

object is a Dim3PointAngular object.

Description

Document Object; Read-only


Dim3PointAngular.ExtLine1EndPoint Property

Specifies the xLine1 end point of the dimension

Syntax

object.ExtLine1EndPoint

object is a Dim3PointAngular object.

Description

ExtLine1EndPoint Variant; Read-write


Dim3PointAngular.ExtLine1Suppress Property

Sets suppression of first extension line On or Off (DIMSE1 system variable)

Syntax

object.ExtLine1Suppress

object is a Dim3PointAngular object.

Description

ExtLine1Suppress Boolean; Read-write


Dim3PointAngular.ExtLine2EndPoint Property

Specifies the xLine2 end point of the dimension

Syntax

object.ExtLine2EndPoint

object is a Dim3PointAngular object.

Description

ExtLine2EndPoint Variant; Read-write


Dim3PointAngular.ExtLine2Suppress Property

Sets suppression of second extension line On or Off (DIMSE2 system variable)

Syntax

object.ExtLine2Suppress

object is a Dim3PointAngular object.

Description

ExtLine2Suppress Boolean; Read-write


Dim3PointAngular.ExtensionLineColor Property

Specifies color of the extension line (DIMCLRE system variable)

Syntax

object.ExtensionLineColor

object is a Dim3PointAngular object.

Description

ExtensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


Dim3PointAngular.ExtensionLineExtend Property

Specifies amount to extend extension line beyond the dimension line (DIMEXE system variable)

Syntax

object.ExtensionLineExtend

object is a Dim3PointAngular object.

Description

ExtensionLineExtend Double; Read-write


Dim3PointAngular.ExtensionLineOffset Property

Specifies offset of extension lines from the origin points (DIMEXO system variable)

Syntax

object.ExtensionLineOffset

object is a Dim3PointAngular object.

Description

ExtensionLineOffset Double; Read-write


Dim3PointAngular.ExtensionLineWeight Property

Specifies lineweight for extension lines (DIMLWE system variable)

Syntax

object.ExtensionLineWeight

object is a Dim3PointAngular object.

Description

ExtensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


Dim3PointAngular.Fit Property

Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)

Syntax

object.Fit

object is a Dim3PointAngular object.

Description

Fit ZcDimFit: Read-write
Can be one of the constants listed here:
zcTextAndArrows
zcArrowsOnly
zcTextOnly
zcBestFit


Dim3PointAngular.ForceLineInside Property

Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)

Syntax

object.ForceLineInside

object is a Dim3PointAngular object.

Description

ForceLineInside Boolean; Read-write


Dim3PointAngular.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Dim3PointAngular object.

Description

Handle String; Read-only


Dim3PointAngular.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Dim3PointAngular object.

Description

HasExtensionDictionary Boolean; Read-only


Dim3PointAngular.HorizontalTextPosition Property

Specifies horizontal dimension text position (DIMJUST system variable)

Syntax

object.HorizontalTextPosition

object is a Dim3PointAngular object.

Description

HorizontalTextPosition ZcDimHorizontalJustification: Read-write
Can be one of the constants listed here:
zcHorzCentered
zcFirstExtensionLine
zcSecondExtensionLine
zcOverFirstExtension
zcOverSecondExtension


Dim3PointAngular.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Dim3PointAngular object.

Description

Hyperlinks Hyperlinks; Read-only


Dim3PointAngular.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Dim3PointAngular object.

Description

Layer String; Read-write

Examples...

Layer Property example


Dim3PointAngular.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Dim3PointAngular object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Dim3PointAngular.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Dim3PointAngular object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Dim3PointAngular.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Dim3PointAngular object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Dim3PointAngular.Measurement Property

Specifies dimension measurement value

Syntax

object.Measurement

object is a Dim3PointAngular object.

Description

Measurement ZCAD_ANGLE: alias for Double; Read-only

Examples...

Measurement Property example


Dim3PointAngular.Normal Property

Returns and sets the normal direction vector.

Syntax

object.Normal

object is a Dim3PointAngular object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Dim3PointAngular.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Dim3PointAngular object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Dim3PointAngular.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Dim3PointAngular object.

Description

ObjectName String; Read-only


Dim3PointAngular.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Dim3PointAngular object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Dim3PointAngular.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Dim3PointAngular object.

Description

PlotStyleName String; Read-write


Dim3PointAngular.Rotation Property

Returns and sets the horizontal rotation angle of the dimension

Syntax

object.Rotation

object is a Dim3PointAngular object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


Dim3PointAngular.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a Dim3PointAngular object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


Dim3PointAngular.StyleName Property

Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)

Syntax

object.StyleName

object is a Dim3PointAngular object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


Dim3PointAngular.SuppressLeadingZeros Property

Determines suppression of leading zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressLeadingZeros

object is a Dim3PointAngular object.

Description

SuppressLeadingZeros Boolean; Read-write

Examples...

SuppressLeadingZeros Property example


Dim3PointAngular.SuppressTrailingZeros Property

Determines suppression of trailing zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressTrailingZeros

object is a Dim3PointAngular object.

Description

SuppressTrailingZeros Boolean; Read-write

Examples...

SuppressTrailingZeros Property example


Dim3PointAngular.TextColor Property

Specifies the color of the dimension text (DIMCLRT system variable)

Syntax

object.TextColor

object is a Dim3PointAngular object.

Description

TextColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

TextColor Property example


Dim3PointAngular.TextGap Property

Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)

Syntax

object.TextGap

object is a Dim3PointAngular object.

Description

TextGap Double; Read-write

Examples...

TextGap Property example


Dim3PointAngular.TextHeight Property

Specifies text height of the dimension (DIMTXT system variable)

Syntax

object.TextHeight

object is a Dim3PointAngular object.

Description

TextHeight Double; Read-write

Examples...

TextHeight Property example


Dim3PointAngular.TextInside Property

Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInside

object is a Dim3PointAngular object.

Description

TextInside Boolean; Read-write

Examples...

TextInside Property example


Dim3PointAngular.TextInsideAlign Property

Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInsideAlign

object is a Dim3PointAngular object.

Description

TextInsideAlign Boolean; Read-write

Examples...

TextInsideAlign Property example


Dim3PointAngular.TextMovement Property

Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)

Syntax

object.TextMovement

object is a Dim3PointAngular object.

Description

TextMovement ZcDimTextMovement: Read-write
Can be one of the constants listed here:
zcDimLineWithText
zcMoveTextAddLeader
zcMoveTextNoLeader

Examples...

TextMovement Property example


Dim3PointAngular.TextOutsideAlign Property

Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)

Syntax

object.TextOutsideAlign

object is a Dim3PointAngular object.

Description

TextOutsideAlign Boolean; Read-write

Examples...

TextOutsideAlign Property example


Dim3PointAngular.TextOverride Property

Specifies the text string of the dimension (overrides Measurement string)

Syntax

object.TextOverride

object is a Dim3PointAngular object.

Description

TextOverride String; Read-write

Examples...

TextOverride Property example


Dim3PointAngular.TextPosition Property

Specifies the dimension text position or pick point

Syntax

object.TextPosition

object is a Dim3PointAngular object.

Description

TextPosition Variant; Read-write


Dim3PointAngular.TextPrecision Property

Specifies number of precision decimal places displayed for angular dimension text

Syntax

object.TextPrecision

object is a Dim3PointAngular object.

Description

TextPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TextPrecision Property example


Dim3PointAngular.TextPrefix Property

Specifies the text prefix for the dimension (DIMPOST system variable)

Syntax

object.TextPrefix

object is a Dim3PointAngular object.

Description

TextPrefix String; Read-write

Examples...

TextPrefix Property example


Dim3PointAngular.TextRotation Property

Specifies the rotation angle of the dimension text

Syntax

object.TextRotation

object is a Dim3PointAngular object.

Description

TextRotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

TextRotation Property example


Dim3PointAngular.TextStyle Property

Specifies text style of the dimension (DIMTXSTY system variable)

Syntax

object.TextStyle

object is a Dim3PointAngular object.

Description

TextStyle String; Read-write

Examples...

TextStyle Property example


Dim3PointAngular.TextSuffix Property

Specifies the text suffix for the dimension (DIMPOST system variable)

Syntax

object.TextSuffix

object is a Dim3PointAngular object.

Description

TextSuffix String; Read-write

Examples...

TextSuffix Property example


Dim3PointAngular.ToleranceDisplay Property

Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)

Syntax

object.ToleranceDisplay

object is a Dim3PointAngular object.

Description

ToleranceDisplay ZcDimToleranceMethod: Read-write
Can be one of the constants listed here:
zcTolNone
zcTolSymmetrical
zcTolDeviation
zcTolLimits
zcTolBasic

Examples...

ToleranceDisplay Property example


Dim3PointAngular.ToleranceHeightScale Property

Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)

Syntax

object.ToleranceHeightScale

object is a Dim3PointAngular object.

Description

ToleranceHeightScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ToleranceHeightScale Property example


Dim3PointAngular.ToleranceJustification Property

Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)

Syntax

object.ToleranceJustification

object is a Dim3PointAngular object.

Description

ToleranceJustification ZcDimToleranceJustify: Read-write
Can be one of the constants listed here:
zcTolBottom
zcTolMiddle
zcTolTop

Examples...

ToleranceJustification Property example


Dim3PointAngular.ToleranceLowerLimit Property

Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)

Syntax

object.ToleranceLowerLimit

object is a Dim3PointAngular object.

Description

ToleranceLowerLimit Double; Read-write

Examples...

ToleranceLowerLimit Property example


Dim3PointAngular.TolerancePrecision Property

Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)

Syntax

object.TolerancePrecision

object is a Dim3PointAngular object.

Description

TolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TolerancePrecision Property example


Dim3PointAngular.ToleranceSuppressLeadingZeros Property

Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressLeadingZeros

object is a Dim3PointAngular object.

Description

ToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

ToleranceSuppressLeadingZeros Property example


Dim3PointAngular.ToleranceSuppressTrailingZeros Property

Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressTrailingZeros

object is a Dim3PointAngular object.

Description

ToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

ToleranceSuppressTrailingZeros Property example


Dim3PointAngular.ToleranceUpperLimit Property

Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)

Syntax

object.ToleranceUpperLimit

object is a Dim3PointAngular object.

Description

ToleranceUpperLimit Double; Read-write

Examples...

ToleranceUpperLimit Property example


Dim3PointAngular.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Dim3PointAngular object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Dim3PointAngular.VerticalTextPosition Property

Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)

Syntax

object.VerticalTextPosition

object is a Dim3PointAngular object.

Description

VerticalTextPosition ZcDimVerticalJustification: Read-write
Can be one of the constants listed here:
zcVertCentered
zcAbove
zcOutside
zcJIS

Examples...

VerticalTextPosition Property example


Dim3PointAngular.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Dim3PointAngular object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Dim3PointAngular.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Dim3PointAngular object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDimAligned Object Members

DimAligned Object Members

A linear dimension, measuring the distance between two points, that is displayed parallel to the points being measured.

VBA Class Name

ZcadDimAligned

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
AltRoundDistance | Specifies distance rounding value for alternate units (DIMALTRND system variable)
AltSuppressLeadingZeros | Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroFeet | Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTTZ system variable)
AltSuppressZeroInches | Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)
AltTextPrefix | Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)
AltTextSuffix | Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)
AltTolerancePrecision | Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)
AltToleranceSuppressLeadingZeros | Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroFeet | Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroInches | Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltUnits | Sets alternate units dimensioning On or Off (DIMALT system variable)
AltUnitsFormat | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsPrecision | Specifies decimal place precision for alternate units (DIMALTD system variable)
AltUnitsScale | Specifies scale factor for alternate units (DIMALTF system variable)
Application | Returns the application object.
Arrowhead1Block | Specifies block of the first dimension arrowhead
Arrowhead1Type | Specifies the type of the first dimension arrowhead (DIMBLK1 system variable)
Arrowhead2Block | Specifies block of the second dimension arrowhead
Arrowhead2Type | Specifies the type of the second dimension arrowhead (DIMBLK2 system variable)
ArrowheadSize | Specifies the size of the dimension arrowhead (DIMASZ system variable)
Database | Returns the database object.
DecimalSeparator | Specifies the decimal separator for metric dimensions (DIMDSEP system variable)
DimLine1Suppress | Sets suppression of the first dimension line On or Off (DIMSD1 system variable)
DimLine2Suppress | Sets suppression of the second dimension line On or Off (DIMSD2 system variable)
DimLineInside | Sets drawing of dimension lines outside extension lines On or Off (DIMSOXD system variable)
DimensionLineColor | Specifies color of the dimension lines (DIMCLRD system variable)
DimensionLineExtend | Specifies amount to extend dimension lines beyond the extension line (DIMDLE system variable)
DimensionLineWeight | Specifies the lineweight for dimension lines (DIMLWD system variable)
Document | Returns the document object.
ExtLine1Point | Specifies xLine1 point of the dimension
ExtLine1Suppress | Sets suppression of the first extension line On or Off (DIMSE1 system variable)
ExtLine2Point | Specifies xLine2 point of the dimension
ExtLine2Suppress | Sets suppression of the second extension line On or Off (DIMSE2 system variable)
ExtensionLineColor | Specifies color of the extension line (DIMCLRE system variable)
ExtensionLineExtend | Specifies amount to extend the extension line beyond the dimension line (DIMEXE system variable)
ExtensionLineOffset | Specifies offset of extension lines from the origin points (DIMEXO system variable)
ExtensionLineWeight | Specifies lineweight for extension lines (DIMLWE system variable)
Fit | Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)
ForceLineInside | Forces drawing a dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)
FractionFormat | Sets fraction type (DIMFRAC system variable)
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
HorizontalTextPosition | Specifies horizontal dimension text position (DIMJUST system variable)
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
LinearScaleFactor | Specifies global scale factor for linear dimensions (DIMLFAC system variable)
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Measurement | Specifies dimension measurement value
Normal | Returns and sets the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
PrimaryUnitsPrecision | Specifies precision for primary units dimensions (DIMDEC system variable)
Rotation | Returns and sets the horizontal rotation angle of the dimension
RoundDistance | Specifies distance rounding value (DIMRND system variable)
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)
SuppressLeadingZeros | Determines suppression of leading zeros for dimensions (DIMZIN system variable)
SuppressTrailingZeros | Determines suppression of trailing zeros for dimensions (DIMZIN system variable)
SuppressZeroFeet | Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)
SuppressZeroInches | Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)
TextColor | Specifies the color of the dimension text (DIMCLRT system variable)
TextGap | Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)
TextHeight | Specifies text height of the dimension (DIMTXT system variable)
TextInside | Sets drawing of text between extension lines On or Off (DIMTIX system variable)
TextInsideAlign | Sets position of dimension text inside the extension lines On or Off (DIMTIH system variable)
TextMovement | Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)
TextOutsideAlign | Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)
TextOverride | Specifies the text string of the dimension (overrides Measurement string)
TextPosition | Specifies the dimension text position or pick point
TextPrefix | Specifies the text prefix for the dimension (DIMPOST system variable)
TextRotation | Specifies the rotation angle of the dimension text
TextStyle | Specifies text style of the dimension (DIMTXSTY system variable)
TextSuffix | Specifies the text suffix for the dimension (DIMPOST system variable)
ToleranceDisplay | Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)
ToleranceHeightScale | Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)
ToleranceJustification | Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)
ToleranceLowerLimit | Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)
TolerancePrecision | Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)
ToleranceSuppressLeadingZeros | Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressTrailingZeros | Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressZeroFeet | Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)
ToleranceSuppressZeroInches | Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)
ToleranceUpperLimit | Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)
TrueColor | Returns the true color of the object.
UnitsFormat | Specifies units format for linear dimensions (DIMLUNIT system variable)
VerticalTextPosition | Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


DimAligned.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


DimAligned.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


DimAligned.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a DimAligned object.

Return value

Object

Examples...

Copy Method example


DimAligned.Delete Method

Deletes the object.

Syntax

object.Delete

object is a DimAligned object.

Examples...

Delete Method example


DimAligned.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a DimAligned object.

Examples...

Erase Method example


DimAligned.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


DimAligned.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a DimAligned object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


DimAligned.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


DimAligned.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


DimAligned.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


DimAligned.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


DimAligned.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


DimAligned.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


DimAligned.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


DimAligned.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a DimAligned object.


DimAligned.AltRoundDistance Property

Specifies distance rounding value for alternate units (DIMALTRND system variable)

Syntax

object.AltRoundDistance

object is a DimAligned object.

Description

AltRoundDistance Double; Read-write

Examples...

AltRoundDistance Property example


DimAligned.AltSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressLeadingZeros

object is a DimAligned object.

Description

AltSuppressLeadingZeros Boolean; Read-write

Examples...

AltSuppressLeadingZeros Property example


DimAligned.AltSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressTrailingZeros

object is a DimAligned object.

Description

AltSuppressTrailingZeros Boolean; Read-write

Examples...

AltSuppressTrailingZeros Property example


DimAligned.AltSuppressZeroFeet Property

Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTTZ system variable)

Syntax

object.AltSuppressZeroFeet

object is a DimAligned object.

Description

AltSuppressZeroFeet Boolean; Read-write

Examples...

AltSuppressZeroFeet Property example


DimAligned.AltSuppressZeroInches Property

Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroInches

object is a DimAligned object.

Description

AltSuppressZeroInches Boolean; Read-write

Examples...

AltSuppressZeroInches Property example


DimAligned.AltTextPrefix Property

Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextPrefix

object is a DimAligned object.

Description

AltTextPrefix String; Read-write


DimAligned.AltTextSuffix Property

Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextSuffix

object is a DimAligned object.

Description

AltTextSuffix String; Read-write


DimAligned.AltTolerancePrecision Property

Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)

Syntax

object.AltTolerancePrecision

object is a DimAligned object.

Description

AltTolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltTolerancePrecision Property example


DimAligned.AltToleranceSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressLeadingZeros

object is a DimAligned object.

Description

AltToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

AltToleranceSuppressLeadingZeros Property example


DimAligned.AltToleranceSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressTrailingZeros

object is a DimAligned object.

Description

AltToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

AltToleranceSuppressTrailingZeros Property example


DimAligned.AltToleranceSuppressZeroFeet Property

Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroFeet

object is a DimAligned object.

Description

AltToleranceSuppressZeroFeet Boolean; Read-write

Examples...

AltToleranceSuppressZeroFeet Property example


DimAligned.AltToleranceSuppressZeroInches Property

Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroInches

object is a DimAligned object.

Description

AltToleranceSuppressZeroInches Boolean; Read-write

Examples...

AltToleranceSuppressZeroInches Property example


DimAligned.AltUnits Property

Sets alternate units dimensioning On or Off (DIMALT system variable)

Syntax

object.AltUnits

object is a DimAligned object.

Description

AltUnits Boolean; Read-write

Examples...

AltUnits Property example


DimAligned.AltUnitsFormat Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnitsFormat

object is a DimAligned object.

Description

AltUnitsFormat ZcDimUnits: Read-write
Can be one of the constants listed here:
zcDimScientific
zcDimDecimal
zcDimEngineering
zcDimArchitecturalStacked
zcDimFractionalStacked
zcDimArchitectural
zcDimFractional
zcDimWindowsDesktop

Examples...

AltUnitsFormat Property example


DimAligned.AltUnitsPrecision Property

Specifies decimal place precision for alternate units (DIMALTD system variable)

Syntax

object.AltUnitsPrecision

object is a DimAligned object.

Description

AltUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltUnitsPrecision Property example


DimAligned.AltUnitsScale Property

Specifies scale factor for alternate units (DIMALTF system variable)

Syntax

object.AltUnitsScale

object is a DimAligned object.

Description

AltUnitsScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

AltUnitsScale Property example


DimAligned.Application Property

Returns the application object.

Syntax

object.Application

object is a DimAligned object.

Description

Application Object; Read-only

Examples...

Application Property example


DimAligned.Arrowhead1Block Property

Specifies block of the first dimension arrowhead

Syntax

object.Arrowhead1Block

object is a DimAligned object.

Description

Arrowhead1Block String; Read-write


DimAligned.Arrowhead1Type Property

Specifies the type of the first dimension arrowhead (DIMBLK1 system variable)

Syntax

object.Arrowhead1Type

object is a DimAligned object.

Description

Arrowhead1Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimAligned.Arrowhead2Block Property

Specifies block of the second dimension arrowhead

Syntax

object.Arrowhead2Block

object is a DimAligned object.

Description

Arrowhead2Block String; Read-write


DimAligned.Arrowhead2Type Property

Specifies the type of the second dimension arrowhead (DIMBLK2 system variable)

Syntax

object.Arrowhead2Type

object is a DimAligned object.

Description

Arrowhead2Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimAligned.ArrowheadSize Property

Specifies the size of the dimension arrowhead (DIMASZ system variable)

Syntax

object.ArrowheadSize

object is a DimAligned object.

Description

ArrowheadSize Double; Read-write

Examples...

ArrowheadSize Property example


DimAligned.Database Property

Returns the database object.

Syntax

object.Database

object is a DimAligned object.

Description

Database Database; Read-only


DimAligned.DecimalSeparator Property

Specifies the decimal separator for metric dimensions (DIMDSEP system variable)

Syntax

object.DecimalSeparator

object is a DimAligned object.

Description

DecimalSeparator String; Read-write


DimAligned.DimLine1Suppress Property

Sets suppression of the first dimension line On or Off (DIMSD1 system variable)

Syntax

object.DimLine1Suppress

object is a DimAligned object.

Description

DimLine1Suppress Boolean; Read-write


DimAligned.DimLine2Suppress Property

Sets suppression of the second dimension line On or Off (DIMSD2 system variable)

Syntax

object.DimLine2Suppress

object is a DimAligned object.

Description

DimLine2Suppress Boolean; Read-write


DimAligned.DimLineInside Property

Sets drawing of dimension lines outside extension lines On or Off (DIMSOXD system variable)

Syntax

object.DimLineInside

object is a DimAligned object.

Description

DimLineInside Boolean; Read-write


DimAligned.DimensionLineColor Property

Specifies color of the dimension lines (DIMCLRD system variable)

Syntax

object.DimensionLineColor

object is a DimAligned object.

Description

DimensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimAligned.DimensionLineExtend Property

Specifies amount to extend dimension lines beyond the extension line (DIMDLE system variable)

Syntax

object.DimensionLineExtend

object is a DimAligned object.

Description

DimensionLineExtend Double; Read-write


DimAligned.DimensionLineWeight Property

Specifies the lineweight for dimension lines (DIMLWD system variable)

Syntax

object.DimensionLineWeight

object is a DimAligned object.

Description

DimensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimAligned.Document Property

Returns the document object.

Syntax

object.Document

object is a DimAligned object.

Description

Document Object; Read-only


DimAligned.ExtLine1Point Property

Specifies xLine1 point of the dimension

Syntax

object.ExtLine1Point

object is a DimAligned object.

Description

ExtLine1Point Variant; Read-write


DimAligned.ExtLine1Suppress Property

Sets suppression of the first extension line On or Off (DIMSE1 system variable)

Syntax

object.ExtLine1Suppress

object is a DimAligned object.

Description

ExtLine1Suppress Boolean; Read-write


DimAligned.ExtLine2Point Property

Specifies xLine2 point of the dimension

Syntax

object.ExtLine2Point

object is a DimAligned object.

Description

ExtLine2Point Variant; Read-write


DimAligned.ExtLine2Suppress Property

Sets suppression of the second extension line On or Off (DIMSE2 system variable)

Syntax

object.ExtLine2Suppress

object is a DimAligned object.

Description

ExtLine2Suppress Boolean; Read-write


DimAligned.ExtensionLineColor Property

Specifies color of the extension line (DIMCLRE system variable)

Syntax

object.ExtensionLineColor

object is a DimAligned object.

Description

ExtensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimAligned.ExtensionLineExtend Property

Specifies amount to extend the extension line beyond the dimension line (DIMEXE system variable)

Syntax

object.ExtensionLineExtend

object is a DimAligned object.

Description

ExtensionLineExtend Double; Read-write


DimAligned.ExtensionLineOffset Property

Specifies offset of extension lines from the origin points (DIMEXO system variable)

Syntax

object.ExtensionLineOffset

object is a DimAligned object.

Description

ExtensionLineOffset Double; Read-write


DimAligned.ExtensionLineWeight Property

Specifies lineweight for extension lines (DIMLWE system variable)

Syntax

object.ExtensionLineWeight

object is a DimAligned object.

Description

ExtensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimAligned.Fit Property

Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)

Syntax

object.Fit

object is a DimAligned object.

Description

Fit ZcDimFit: Read-write
Can be one of the constants listed here:
zcTextAndArrows
zcArrowsOnly
zcTextOnly
zcBestFit


DimAligned.ForceLineInside Property

Forces drawing a dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)

Syntax

object.ForceLineInside

object is a DimAligned object.

Description

ForceLineInside Boolean; Read-write


DimAligned.FractionFormat Property

Sets fraction type (DIMFRAC system variable)

Syntax

object.FractionFormat

object is a DimAligned object.

Description

FractionFormat ZcDimFractionType: Read-write
Can be one of the constants listed here:
zcHorizontal
zcDiagonal
zcNotStacked


DimAligned.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a DimAligned object.

Description

Handle String; Read-only


DimAligned.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a DimAligned object.

Description

HasExtensionDictionary Boolean; Read-only


DimAligned.HorizontalTextPosition Property

Specifies horizontal dimension text position (DIMJUST system variable)

Syntax

object.HorizontalTextPosition

object is a DimAligned object.

Description

HorizontalTextPosition ZcDimHorizontalJustification: Read-write
Can be one of the constants listed here:
zcHorzCentered
zcFirstExtensionLine
zcSecondExtensionLine
zcOverFirstExtension
zcOverSecondExtension


DimAligned.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a DimAligned object.

Description

Hyperlinks Hyperlinks; Read-only


DimAligned.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a DimAligned object.

Description

Layer String; Read-write

Examples...

Layer Property example


DimAligned.LinearScaleFactor Property

Specifies global scale factor for linear dimensions (DIMLFAC system variable)

Syntax

object.LinearScaleFactor

object is a DimAligned object.

Description

LinearScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinearScaleFactor Property example


DimAligned.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a DimAligned object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


DimAligned.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a DimAligned object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


DimAligned.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a DimAligned object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


DimAligned.Measurement Property

Specifies dimension measurement value

Syntax

object.Measurement

object is a DimAligned object.

Description

Measurement Double; Read-only

Examples...

Measurement Property example


DimAligned.Normal Property

Returns and sets the normal direction vector.

Syntax

object.Normal

object is a DimAligned object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


DimAligned.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a DimAligned object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


DimAligned.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a DimAligned object.

Description

ObjectName String; Read-only


DimAligned.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a DimAligned object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


DimAligned.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a DimAligned object.

Description

PlotStyleName String; Read-write


DimAligned.PrimaryUnitsPrecision Property

Specifies precision for primary units dimensions (DIMDEC system variable)

Syntax

object.PrimaryUnitsPrecision

object is a DimAligned object.

Description

PrimaryUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

PrimaryUnitsPrecision Property example


DimAligned.Rotation Property

Returns and sets the horizontal rotation angle of the dimension

Syntax

object.Rotation

object is a DimAligned object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


DimAligned.RoundDistance Property

Specifies distance rounding value (DIMRND system variable)

Syntax

object.RoundDistance

object is a DimAligned object.

Description

RoundDistance Double; Read-write

Examples...

RoundDistance Property example


DimAligned.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a DimAligned object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


DimAligned.StyleName Property

Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)

Syntax

object.StyleName

object is a DimAligned object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


DimAligned.SuppressLeadingZeros Property

Determines suppression of leading zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressLeadingZeros

object is a DimAligned object.

Description

SuppressLeadingZeros Boolean; Read-write

Examples...

SuppressLeadingZeros Property example


DimAligned.SuppressTrailingZeros Property

Determines suppression of trailing zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressTrailingZeros

object is a DimAligned object.

Description

SuppressTrailingZeros Boolean; Read-write

Examples...

SuppressTrailingZeros Property example


DimAligned.SuppressZeroFeet Property

Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroFeet

object is a DimAligned object.

Description

SuppressZeroFeet Boolean; Read-write

Examples...

SuppressZeroFeet Property example


DimAligned.SuppressZeroInches Property

Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroInches

object is a DimAligned object.

Description

SuppressZeroInches Boolean; Read-write

Examples...

SuppressZeroInches Property example


DimAligned.TextColor Property

Specifies the color of the dimension text (DIMCLRT system variable)

Syntax

object.TextColor

object is a DimAligned object.

Description

TextColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

TextColor Property example


DimAligned.TextGap Property

Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)

Syntax

object.TextGap

object is a DimAligned object.

Description

TextGap Double; Read-write

Examples...

TextGap Property example


DimAligned.TextHeight Property

Specifies text height of the dimension (DIMTXT system variable)

Syntax

object.TextHeight

object is a DimAligned object.

Description

TextHeight Double; Read-write

Examples...

TextHeight Property example


DimAligned.TextInside Property

Sets drawing of text between extension lines On or Off (DIMTIX system variable)

Syntax

object.TextInside

object is a DimAligned object.

Description

TextInside Boolean; Read-write

Examples...

TextInside Property example


DimAligned.TextInsideAlign Property

Sets position of dimension text inside the extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInsideAlign

object is a DimAligned object.

Description

TextInsideAlign Boolean; Read-write

Examples...

TextInsideAlign Property example


DimAligned.TextMovement Property

Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)

Syntax

object.TextMovement

object is a DimAligned object.

Description

TextMovement ZcDimTextMovement: Read-write
Can be one of the constants listed here:
zcDimLineWithText
zcMoveTextAddLeader
zcMoveTextNoLeader

Examples...

TextMovement Property example


DimAligned.TextOutsideAlign Property

Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)

Syntax

object.TextOutsideAlign

object is a DimAligned object.

Description

TextOutsideAlign Boolean; Read-write

Examples...

TextOutsideAlign Property example


DimAligned.TextOverride Property

Specifies the text string of the dimension (overrides Measurement string)

Syntax

object.TextOverride

object is a DimAligned object.

Description

TextOverride String; Read-write

Examples...

TextOverride Property example


DimAligned.TextPosition Property

Specifies the dimension text position or pick point

Syntax

object.TextPosition

object is a DimAligned object.

Description

TextPosition Variant; Read-write


DimAligned.TextPrefix Property

Specifies the text prefix for the dimension (DIMPOST system variable)

Syntax

object.TextPrefix

object is a DimAligned object.

Description

TextPrefix String; Read-write

Examples...

TextPrefix Property example


DimAligned.TextRotation Property

Specifies the rotation angle of the dimension text

Syntax

object.TextRotation

object is a DimAligned object.

Description

TextRotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

TextRotation Property example


DimAligned.TextStyle Property

Specifies text style of the dimension (DIMTXSTY system variable)

Syntax

object.TextStyle

object is a DimAligned object.

Description

TextStyle String; Read-write

Examples...

TextStyle Property example


DimAligned.TextSuffix Property

Specifies the text suffix for the dimension (DIMPOST system variable)

Syntax

object.TextSuffix

object is a DimAligned object.

Description

TextSuffix String; Read-write

Examples...

TextSuffix Property example


DimAligned.ToleranceDisplay Property

Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)

Syntax

object.ToleranceDisplay

object is a DimAligned object.

Description

ToleranceDisplay ZcDimToleranceMethod: Read-write
Can be one of the constants listed here:
zcTolNone
zcTolSymmetrical
zcTolDeviation
zcTolLimits
zcTolBasic

Examples...

ToleranceDisplay Property example


DimAligned.ToleranceHeightScale Property

Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)

Syntax

object.ToleranceHeightScale

object is a DimAligned object.

Description

ToleranceHeightScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ToleranceHeightScale Property example


DimAligned.ToleranceJustification Property

Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)

Syntax

object.ToleranceJustification

object is a DimAligned object.

Description

ToleranceJustification ZcDimToleranceJustify: Read-write
Can be one of the constants listed here:
zcTolBottom
zcTolMiddle
zcTolTop

Examples...

ToleranceJustification Property example


DimAligned.ToleranceLowerLimit Property

Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)

Syntax

object.ToleranceLowerLimit

object is a DimAligned object.

Description

ToleranceLowerLimit Double; Read-write

Examples...

ToleranceLowerLimit Property example


DimAligned.TolerancePrecision Property

Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)

Syntax

object.TolerancePrecision

object is a DimAligned object.

Description

TolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TolerancePrecision Property example


DimAligned.ToleranceSuppressLeadingZeros Property

Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressLeadingZeros

object is a DimAligned object.

Description

ToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

ToleranceSuppressLeadingZeros Property example


DimAligned.ToleranceSuppressTrailingZeros Property

Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressTrailingZeros

object is a DimAligned object.

Description

ToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

ToleranceSuppressTrailingZeros Property example


DimAligned.ToleranceSuppressZeroFeet Property

Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroFeet

object is a DimAligned object.

Description

ToleranceSuppressZeroFeet Boolean; Read-write

Examples...

ToleranceSuppressZeroFeet Property example


DimAligned.ToleranceSuppressZeroInches Property

Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroInches

object is a DimAligned object.

Description

ToleranceSuppressZeroInches Boolean; Read-write

Examples...

ToleranceSuppressZeroInches Property example


DimAligned.ToleranceUpperLimit Property

Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)

Syntax

object.ToleranceUpperLimit

object is a DimAligned object.

Description

ToleranceUpperLimit Double; Read-write

Examples...

ToleranceUpperLimit Property example


DimAligned.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a DimAligned object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


DimAligned.UnitsFormat Property

Specifies units format for linear dimensions (DIMLUNIT system variable)

Syntax

object.UnitsFormat

object is a DimAligned object.

Description

UnitsFormat ZcDimLUnits: Read-write
Can be one of the constants listed here:
zcDimLScientific
zcDimLDecimal
zcDimLEngineering
zcDimLArchitectural
zcDimLFractional
zcDimLWindowsDesktop

Examples...

UnitsFormat Property example


DimAligned.VerticalTextPosition Property

Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)

Syntax

object.VerticalTextPosition

object is a DimAligned object.

Description

VerticalTextPosition ZcDimVerticalJustification: Read-write
Can be one of the constants listed here:
zcVertCentered
zcAbove
zcOutside
zcJIS

Examples...

VerticalTextPosition Property example


DimAligned.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a DimAligned object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


DimAligned.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a DimAligned object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDimAngular Object Members

DimAngular Object Members

A dimension measuring the angular distance between two lines or between the angle of a circular arc.

VBA Class Name

ZcadDimAngular

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
AngleFormat | Specifies the angle format (DIMAUNIT system variable)
Application | Returns the application object.
Arrowhead1Block | Specifies block of the first dimension arrowhead
Arrowhead1Type | Specifies type of the first dimension arrowhead (DIMBLK1 system variable)
Arrowhead2Block | Specifies block of the second dimension arrowhead
Arrowhead2Type | Specifies type of the second dimension arrowhead (DIMBLK2 system variable)
ArrowheadSize | Specifies size of the dimension arrowhead (DIMASZ system variable)
Database | Returns the database object.
DecimalSeparator | Specifies the decimal separator for metric dimensions (DIMDSEP system variable)
DimLine1Suppress | Sets suppression of first dimension line On or Off (DIMSD1 system variable)
DimLine2Suppress | Sets suppression of second dimension line On or Off (DIMSD2 system variable)
DimLineInside | Sets drawing of dimension lines outside extension lines On or Off (DIMSOXD system variable)
DimensionLineColor | Specifies the color of the dimension lines (DIMCLRD system variable)
DimensionLineWeight | Specifies lineweight for dimension lines (DIMLWD system variable)
Document | Returns the document object.
ExtLine1EndPoint | Specifies the xLine1 end point of the dimension
ExtLine1StartPoint | Specifies the xLine1 start point of the dimension
ExtLine1Suppress | Sets suppression of first extension line On or Off (DIMSE1 system variable)
ExtLine2EndPoint | Specifies the xLine2 end point of the dimension
ExtLine2StartPoint | Specifies the xLine2 start point of the dimension
ExtLine2Suppress | Sets suppression of second extension line On or Off (DIMSE2 system variable)
ExtensionLineColor | Specifies color of the extension line (DIMCLRE system variable)
ExtensionLineExtend | Specifies amount to extend extension line beyond the dimension line (DIMEXE system variable)
ExtensionLineOffset | Specifies offset of extension lines from the origin points (DIMEXO system variable)
ExtensionLineWeight | Specifies lineweight for extension lines (DIMLWE system variable)
Fit | Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)
ForceLineInside | Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
HorizontalTextPosition | Specifies horizontal dimension text position (DIMJUST system variable)
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Measurement | Specifies dimension measurement value
Normal | Returns and sets the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Returns and sets the horizontal rotation angle of the dimension
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)
SuppressLeadingZeros | Determines suppression of leading zeros for dimensions (DIMZIN system variable)
SuppressTrailingZeros | Determines suppression of trailing zeros for dimensions (DIMZIN system variable)
TextColor | Specifies the color of the dimension text (DIMCLRT system variable)
TextGap | Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)
TextHeight | Specifies text height of the dimension (DIMTXT system variable)
TextInside | Sets drawing of text between extension lines On or Off (DIMTIX system variable)
TextInsideAlign | Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)
TextMovement | Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)
TextOutsideAlign | Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)
TextOverride | Specifies the text string of the dimension (overrides Measurement string)
TextPosition | Specifies the dimension text position or pick point
TextPrecision | Specifies number of precision decimal places displayed for angular dimension text
TextPrefix | Specifies the text prefix for the dimension (DIMPOST system variable)
TextRotation | Specifies the rotation angle of the dimension text
TextStyle | Specifies text style of the dimension (DIMTXSTY system variable)
TextSuffix | Specifies the text suffix for the dimension (DIMPOST system variable)
ToleranceDisplay | Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)
ToleranceHeightScale | Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)
ToleranceJustification | Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)
ToleranceLowerLimit | Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)
TolerancePrecision | Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)
ToleranceSuppressLeadingZeros | Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressTrailingZeros | Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)
ToleranceUpperLimit | Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)
TrueColor | Returns the true color of the object.
VerticalTextPosition | Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


DimAngular.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


DimAngular.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


DimAngular.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a DimAngular object.

Return value

Object

Examples...

Copy Method example


DimAngular.Delete Method

Deletes the object.

Syntax

object.Delete

object is a DimAngular object.

Examples...

Delete Method example


DimAngular.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a DimAngular object.

Examples...

Erase Method example


DimAngular.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


DimAngular.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a DimAngular object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


DimAngular.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


DimAngular.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


DimAngular.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


DimAngular.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


DimAngular.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


DimAngular.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


DimAngular.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


DimAngular.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a DimAngular object.


DimAngular.AngleFormat Property

Specifies the angle format (DIMAUNIT system variable)

Syntax

object.AngleFormat

object is a DimAngular object.

Description

AngleFormat ZcAngleUnits: Read-write
Can be one of the constants listed here:
zcDegrees
zcDegreeMinuteSeconds
zcGrads
zcRadians

Examples...

AngleFormat Property example


DimAngular.Application Property

Returns the application object.

Syntax

object.Application

object is a DimAngular object.

Description

Application Object; Read-only

Examples...

Application Property example


DimAngular.Arrowhead1Block Property

Specifies block of the first dimension arrowhead

Syntax

object.Arrowhead1Block

object is a DimAngular object.

Description

Arrowhead1Block String; Read-write


DimAngular.Arrowhead1Type Property

Specifies type of the first dimension arrowhead (DIMBLK1 system variable)

Syntax

object.Arrowhead1Type

object is a DimAngular object.

Description

Arrowhead1Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimAngular.Arrowhead2Block Property

Specifies block of the second dimension arrowhead

Syntax

object.Arrowhead2Block

object is a DimAngular object.

Description

Arrowhead2Block String; Read-write


DimAngular.Arrowhead2Type Property

Specifies type of the second dimension arrowhead (DIMBLK2 system variable)

Syntax

object.Arrowhead2Type

object is a DimAngular object.

Description

Arrowhead2Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimAngular.ArrowheadSize Property

Specifies size of the dimension arrowhead (DIMASZ system variable)

Syntax

object.ArrowheadSize

object is a DimAngular object.

Description

ArrowheadSize Double; Read-write

Examples...

ArrowheadSize Property example


DimAngular.Database Property

Returns the database object.

Syntax

object.Database

object is a DimAngular object.

Description

Database Database; Read-only


DimAngular.DecimalSeparator Property

Specifies the decimal separator for metric dimensions (DIMDSEP system variable)

Syntax

object.DecimalSeparator

object is a DimAngular object.

Description

DecimalSeparator String; Read-write


DimAngular.DimLine1Suppress Property

Sets suppression of first dimension line On or Off (DIMSD1 system variable)

Syntax

object.DimLine1Suppress

object is a DimAngular object.

Description

DimLine1Suppress Boolean; Read-write


DimAngular.DimLine2Suppress Property

Sets suppression of second dimension line On or Off (DIMSD2 system variable)

Syntax

object.DimLine2Suppress

object is a DimAngular object.

Description

DimLine2Suppress Boolean; Read-write


DimAngular.DimLineInside Property

Sets drawing of dimension lines outside extension lines On or Off (DIMSOXD system variable)

Syntax

object.DimLineInside

object is a DimAngular object.

Description

DimLineInside Boolean; Read-write


DimAngular.DimensionLineColor Property

Specifies the color of the dimension lines (DIMCLRD system variable)

Syntax

object.DimensionLineColor

object is a DimAngular object.

Description

DimensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimAngular.DimensionLineWeight Property

Specifies lineweight for dimension lines (DIMLWD system variable)

Syntax

object.DimensionLineWeight

object is a DimAngular object.

Description

DimensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimAngular.Document Property

Returns the document object.

Syntax

object.Document

object is a DimAngular object.

Description

Document Object; Read-only


DimAngular.ExtLine1EndPoint Property

Specifies the xLine1 end point of the dimension

Syntax

object.ExtLine1EndPoint

object is a DimAngular object.

Description

ExtLine1EndPoint Variant; Read-write


DimAngular.ExtLine1StartPoint Property

Specifies the xLine1 start point of the dimension

Syntax

object.ExtLine1StartPoint

object is a DimAngular object.

Description

ExtLine1StartPoint Variant; Read-write


DimAngular.ExtLine1Suppress Property

Sets suppression of first extension line On or Off (DIMSE1 system variable)

Syntax

object.ExtLine1Suppress

object is a DimAngular object.

Description

ExtLine1Suppress Boolean; Read-write


DimAngular.ExtLine2EndPoint Property

Specifies the xLine2 end point of the dimension

Syntax

object.ExtLine2EndPoint

object is a DimAngular object.

Description

ExtLine2EndPoint Variant; Read-write


DimAngular.ExtLine2StartPoint Property

Specifies the xLine2 start point of the dimension

Syntax

object.ExtLine2StartPoint

object is a DimAngular object.

Description

ExtLine2StartPoint Variant; Read-write


DimAngular.ExtLine2Suppress Property

Sets suppression of second extension line On or Off (DIMSE2 system variable)

Syntax

object.ExtLine2Suppress

object is a DimAngular object.

Description

ExtLine2Suppress Boolean; Read-write


DimAngular.ExtensionLineColor Property

Specifies color of the extension line (DIMCLRE system variable)

Syntax

object.ExtensionLineColor

object is a DimAngular object.

Description

ExtensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimAngular.ExtensionLineExtend Property

Specifies amount to extend extension line beyond the dimension line (DIMEXE system variable)

Syntax

object.ExtensionLineExtend

object is a DimAngular object.

Description

ExtensionLineExtend Double; Read-write


DimAngular.ExtensionLineOffset Property

Specifies offset of extension lines from the origin points (DIMEXO system variable)

Syntax

object.ExtensionLineOffset

object is a DimAngular object.

Description

ExtensionLineOffset Double; Read-write


DimAngular.ExtensionLineWeight Property

Specifies lineweight for extension lines (DIMLWE system variable)

Syntax

object.ExtensionLineWeight

object is a DimAngular object.

Description

ExtensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimAngular.Fit Property

Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)

Syntax

object.Fit

object is a DimAngular object.

Description

Fit ZcDimFit: Read-write
Can be one of the constants listed here:
zcTextAndArrows
zcArrowsOnly
zcTextOnly
zcBestFit


DimAngular.ForceLineInside Property

Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)

Syntax

object.ForceLineInside

object is a DimAngular object.

Description

ForceLineInside Boolean; Read-write


DimAngular.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a DimAngular object.

Description

Handle String; Read-only


DimAngular.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a DimAngular object.

Description

HasExtensionDictionary Boolean; Read-only


DimAngular.HorizontalTextPosition Property

Specifies horizontal dimension text position (DIMJUST system variable)

Syntax

object.HorizontalTextPosition

object is a DimAngular object.

Description

HorizontalTextPosition ZcDimHorizontalJustification: Read-write
Can be one of the constants listed here:
zcHorzCentered
zcFirstExtensionLine
zcSecondExtensionLine
zcOverFirstExtension
zcOverSecondExtension


DimAngular.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a DimAngular object.

Description

Hyperlinks Hyperlinks; Read-only


DimAngular.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a DimAngular object.

Description

Layer String; Read-write

Examples...

Layer Property example


DimAngular.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a DimAngular object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


DimAngular.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a DimAngular object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


DimAngular.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a DimAngular object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


DimAngular.Measurement Property

Specifies dimension measurement value

Syntax

object.Measurement

object is a DimAngular object.

Description

Measurement ZCAD_ANGLE: alias for Double; Read-only

Examples...

Measurement Property example


DimAngular.Normal Property

Returns and sets the normal direction vector.

Syntax

object.Normal

object is a DimAngular object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


DimAngular.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a DimAngular object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


DimAngular.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a DimAngular object.

Description

ObjectName String; Read-only


DimAngular.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a DimAngular object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


DimAngular.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a DimAngular object.

Description

PlotStyleName String; Read-write


DimAngular.Rotation Property

Returns and sets the horizontal rotation angle of the dimension

Syntax

object.Rotation

object is a DimAngular object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


DimAngular.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a DimAngular object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


DimAngular.StyleName Property

Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)

Syntax

object.StyleName

object is a DimAngular object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


DimAngular.SuppressLeadingZeros Property

Determines suppression of leading zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressLeadingZeros

object is a DimAngular object.

Description

SuppressLeadingZeros Boolean; Read-write

Examples...

SuppressLeadingZeros Property example


DimAngular.SuppressTrailingZeros Property

Determines suppression of trailing zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressTrailingZeros

object is a DimAngular object.

Description

SuppressTrailingZeros Boolean; Read-write

Examples...

SuppressTrailingZeros Property example


DimAngular.TextColor Property

Specifies the color of the dimension text (DIMCLRT system variable)

Syntax

object.TextColor

object is a DimAngular object.

Description

TextColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

TextColor Property example


DimAngular.TextGap Property

Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)

Syntax

object.TextGap

object is a DimAngular object.

Description

TextGap Double; Read-write

Examples...

TextGap Property example


DimAngular.TextHeight Property

Specifies text height of the dimension (DIMTXT system variable)

Syntax

object.TextHeight

object is a DimAngular object.

Description

TextHeight Double; Read-write

Examples...

TextHeight Property example


DimAngular.TextInside Property

Sets drawing of text between extension lines On or Off (DIMTIX system variable)

Syntax

object.TextInside

object is a DimAngular object.

Description

TextInside Boolean; Read-write

Examples...

TextInside Property example


DimAngular.TextInsideAlign Property

Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInsideAlign

object is a DimAngular object.

Description

TextInsideAlign Boolean; Read-write

Examples...

TextInsideAlign Property example


DimAngular.TextMovement Property

Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)

Syntax

object.TextMovement

object is a DimAngular object.

Description

TextMovement ZcDimTextMovement: Read-write
Can be one of the constants listed here:
zcDimLineWithText
zcMoveTextAddLeader
zcMoveTextNoLeader

Examples...

TextMovement Property example


DimAngular.TextOutsideAlign Property

Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)

Syntax

object.TextOutsideAlign

object is a DimAngular object.

Description

TextOutsideAlign Boolean; Read-write

Examples...

TextOutsideAlign Property example


DimAngular.TextOverride Property

Specifies the text string of the dimension (overrides Measurement string)

Syntax

object.TextOverride

object is a DimAngular object.

Description

TextOverride String; Read-write

Examples...

TextOverride Property example


DimAngular.TextPosition Property

Specifies the dimension text position or pick point

Syntax

object.TextPosition

object is a DimAngular object.

Description

TextPosition Variant; Read-write


DimAngular.TextPrecision Property

Specifies number of precision decimal places displayed for angular dimension text

Syntax

object.TextPrecision

object is a DimAngular object.

Description

TextPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TextPrecision Property example


DimAngular.TextPrefix Property

Specifies the text prefix for the dimension (DIMPOST system variable)

Syntax

object.TextPrefix

object is a DimAngular object.

Description

TextPrefix String; Read-write

Examples...

TextPrefix Property example


DimAngular.TextRotation Property

Specifies the rotation angle of the dimension text

Syntax

object.TextRotation

object is a DimAngular object.

Description

TextRotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

TextRotation Property example


DimAngular.TextStyle Property

Specifies text style of the dimension (DIMTXSTY system variable)

Syntax

object.TextStyle

object is a DimAngular object.

Description

TextStyle String; Read-write

Examples...

TextStyle Property example


DimAngular.TextSuffix Property

Specifies the text suffix for the dimension (DIMPOST system variable)

Syntax

object.TextSuffix

object is a DimAngular object.

Description

TextSuffix String; Read-write

Examples...

TextSuffix Property example


DimAngular.ToleranceDisplay Property

Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)

Syntax

object.ToleranceDisplay

object is a DimAngular object.

Description

ToleranceDisplay ZcDimToleranceMethod: Read-write
Can be one of the constants listed here:
zcTolNone
zcTolSymmetrical
zcTolDeviation
zcTolLimits
zcTolBasic

Examples...

ToleranceDisplay Property example


DimAngular.ToleranceHeightScale Property

Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)

Syntax

object.ToleranceHeightScale

object is a DimAngular object.

Description

ToleranceHeightScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ToleranceHeightScale Property example


DimAngular.ToleranceJustification Property

Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)

Syntax

object.ToleranceJustification

object is a DimAngular object.

Description

ToleranceJustification ZcDimToleranceJustify: Read-write
Can be one of the constants listed here:
zcTolBottom
zcTolMiddle
zcTolTop

Examples...

ToleranceJustification Property example


DimAngular.ToleranceLowerLimit Property

Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)

Syntax

object.ToleranceLowerLimit

object is a DimAngular object.

Description

ToleranceLowerLimit Double; Read-write

Examples...

ToleranceLowerLimit Property example


DimAngular.TolerancePrecision Property

Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)

Syntax

object.TolerancePrecision

object is a DimAngular object.

Description

TolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TolerancePrecision Property example


DimAngular.ToleranceSuppressLeadingZeros Property

Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressLeadingZeros

object is a DimAngular object.

Description

ToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

ToleranceSuppressLeadingZeros Property example


DimAngular.ToleranceSuppressTrailingZeros Property

Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressTrailingZeros

object is a DimAngular object.

Description

ToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

ToleranceSuppressTrailingZeros Property example


DimAngular.ToleranceUpperLimit Property

Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)

Syntax

object.ToleranceUpperLimit

object is a DimAngular object.

Description

ToleranceUpperLimit Double; Read-write

Examples...

ToleranceUpperLimit Property example


DimAngular.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a DimAngular object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


DimAngular.VerticalTextPosition Property

Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)

Syntax

object.VerticalTextPosition

object is a DimAngular object.

Description

VerticalTextPosition ZcDimVerticalJustification: Read-write
Can be one of the constants listed here:
zcVertCentered
zcAbove
zcOutside
zcJIS

Examples...

VerticalTextPosition Property example


DimAngular.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a DimAngular object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


DimAngular.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a DimAngular object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDimArcLength Object Members

DimArcLength Object Members

A dimension measuring the length of an arc.

VBA Class Name

ZcadDimArcLength

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
AltRoundDistance | Specifies distance rounding value for alternate units (DIMALTRND system variable)
AltSuppressLeadingZeros | Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroFeet | Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroInches | Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)
AltTextPrefix | Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)
AltTextSuffix | Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)
AltTolerancePrecision | Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)
AltToleranceSuppressLeadingZeros | Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroFeet | Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroInches | Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltUnits | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsFormat | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsPrecision | Specifies decimal place precision for alternate units (DIMALTD system variable)
AltUnitsScale | Specifies scale factor for alternate units (DIMALTF system variable)
Application | Returns the application object.
Arrowhead1Block | Specifies the block of the first dimension arrowhead
Arrowhead1Type | Specifies type of the first dimension arrowhead (DIMBLK1 system variable)
Arrowhead2Block | Specifies the block of the second dimension arrowhead
Arrowhead2Type | Specifies type of the second dimension arrowhead (DIMBLK2 system variable)
ArrowheadSize | Specifies size of the dimension arrowhead (DIMASZ system variable)
Database | Returns the database object.
DecimalSeparator | Specifies the decimal separator for metric dimensions (DIMDSEP system variable)
DimLine1Suppress | Sets suppression of first dimension line On or Off (DIMSD1 system variable)
DimLine2Suppress | Sets suppression of second dimension line On or Off (DIMSD2 system variable)
DimLineInside | Sets drawing of dimension lines outside extension lines On or Off (DIMSOXD system variable)
DimensionLineColor | Specifies color of the dimension lines (DIMCLRD system variable)
DimensionLineExtend | Specifies amount to extend dimension lines beyond the extension line (DIMDLE system variable)
DimensionLineWeight | Specifies lineweight for dimension lines (DIMLWD system variable)
Document | Returns the document object.
ExtLine1Suppress | Sets suppression of first extension line On or Off (DIMSE1 system variable)
ExtLine2Suppress | Sets suppression of second extension line On or Off (DIMSE2 system variable)
ExtensionLineColor | Specifies color of the extension line (DIMCLRE system variable)
ExtensionLineExtend | Specifies amount to extend extension line beyond the dimension line (DIMEXE system variable)
ExtensionLineOffset | Specifies offset of extension lines from the origin points (DIMEXO system variable)
ExtensionLineWeight | Specifies lineweight for extension lines (DIMLWE system variable)
Fit | Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)
ForceLineInside | Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)
FractionFormat | Sets fraction type (DIMFRAC system variable)
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
HorizontalTextPosition | Specifies horizontal dimension text position (DIMJUST system variable)
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
LinearScaleFactor | Specifies global scale factor for linear dimensions (DIMLFAC system variable)
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Measurement | Specifies dimension measurement value
Normal | Returns and sets the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
PrimaryUnitsPrecision | Specifies precision for primary units dimensions (DIMDEC system variable)
Rotation | Returns and sets the horizontal rotation angle of the dimension
RoundDistance | Specifies distance rounding value (DIMRND system variable)
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)
SuppressLeadingZeros | Determines suppression of leading zeros for dimensions (DIMZIN system variable)
SuppressTrailingZeros | Determines suppression of trailing zeros for dimensions (DIMZIN system variable)
SuppressZeroFeet | Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)
SuppressZeroInches | Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)
TextColor | Specifies the color of the dimension text (DIMCLRT system variable)
TextGap | Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)
TextHeight | Specifies text height of the dimension (DIMTXT system variable)
TextInside | Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)
TextInsideAlign | Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)
TextMovement | Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)
TextOutsideAlign | Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)
TextOverride | Specifies the text string of the dimension (overrides Measurement string)
TextPosition | Specifies the dimension text position or pick point
TextPrefix | Specifies the text prefix for the dimension (DIMPOST system variable)
TextRotation | Specifies the rotation angle of the dimension text
TextStyle | Specifies text style of the dimension (DIMTXSTY system variable)
TextSuffix | Specifies the text suffix for the dimension (DIMPOST system variable)
ToleranceDisplay | Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)
ToleranceHeightScale | Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)
ToleranceJustification | Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)
ToleranceLowerLimit | Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)
TolerancePrecision | Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)
ToleranceSuppressLeadingZeros | Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressTrailingZeros | Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressZeroFeet | Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)
ToleranceSuppressZeroInches | Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)
ToleranceUpperLimit | Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)
TrueColor | Returns the true color of the object.
UnitsFormat | Specifies units format for linear dimensions (DIMLUNIT system variable)
VerticalTextPosition | Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


DimArcLength.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


DimArcLength.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


DimArcLength.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a DimArcLength object.

Return value

Object

Examples...

Copy Method example


DimArcLength.Delete Method

Deletes the object.

Syntax

object.Delete

object is a DimArcLength object.

Examples...

Delete Method example


DimArcLength.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a DimArcLength object.

Examples...

Erase Method example


DimArcLength.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


DimArcLength.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a DimArcLength object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


DimArcLength.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


DimArcLength.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


DimArcLength.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


DimArcLength.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


DimArcLength.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


DimArcLength.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


DimArcLength.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


DimArcLength.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a DimArcLength object.


DimArcLength.AltRoundDistance Property

Specifies distance rounding value for alternate units (DIMALTRND system variable)

Syntax

object.AltRoundDistance

object is a DimArcLength object.

Description

AltRoundDistance Double; Read-write

Examples...

AltRoundDistance Property example


DimArcLength.AltSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressLeadingZeros

object is a DimArcLength object.

Description

AltSuppressLeadingZeros Boolean; Read-write

Examples...

AltSuppressLeadingZeros Property example


DimArcLength.AltSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressTrailingZeros

object is a DimArcLength object.

Description

AltSuppressTrailingZeros Boolean; Read-write

Examples...

AltSuppressTrailingZeros Property example


DimArcLength.AltSuppressZeroFeet Property

Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroFeet

object is a DimArcLength object.

Description

AltSuppressZeroFeet Boolean; Read-write

Examples...

AltSuppressZeroFeet Property example


DimArcLength.AltSuppressZeroInches Property

Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroInches

object is a DimArcLength object.

Description

AltSuppressZeroInches Boolean; Read-write

Examples...

AltSuppressZeroInches Property example


DimArcLength.AltTextPrefix Property

Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextPrefix

object is a DimArcLength object.

Description

AltTextPrefix String; Read-write


DimArcLength.AltTextSuffix Property

Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextSuffix

object is a DimArcLength object.

Description

AltTextSuffix String; Read-write


DimArcLength.AltTolerancePrecision Property

Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)

Syntax

object.AltTolerancePrecision

object is a DimArcLength object.

Description

AltTolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltTolerancePrecision Property example


DimArcLength.AltToleranceSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressLeadingZeros

object is a DimArcLength object.

Description

AltToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

AltToleranceSuppressLeadingZeros Property example


DimArcLength.AltToleranceSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressTrailingZeros

object is a DimArcLength object.

Description

AltToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

AltToleranceSuppressTrailingZeros Property example


DimArcLength.AltToleranceSuppressZeroFeet Property

Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroFeet

object is a DimArcLength object.

Description

AltToleranceSuppressZeroFeet Boolean; Read-write

Examples...

AltToleranceSuppressZeroFeet Property example


DimArcLength.AltToleranceSuppressZeroInches Property

Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroInches

object is a DimArcLength object.

Description

AltToleranceSuppressZeroInches Boolean; Read-write

Examples...

AltToleranceSuppressZeroInches Property example


DimArcLength.AltUnits Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnits

object is a DimArcLength object.

Description

AltUnits Boolean; Read-write

Examples...

AltUnits Property example


DimArcLength.AltUnitsFormat Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnitsFormat

object is a DimArcLength object.

Description

AltUnitsFormat ZcDimUnits: Read-write
Can be one of the constants listed here:
zcDimScientific
zcDimDecimal
zcDimEngineering
zcDimArchitecturalStacked
zcDimFractionalStacked
zcDimArchitectural
zcDimFractional
zcDimWindowsDesktop

Examples...

AltUnitsFormat Property example


DimArcLength.AltUnitsPrecision Property

Specifies decimal place precision for alternate units (DIMALTD system variable)

Syntax

object.AltUnitsPrecision

object is a DimArcLength object.

Description

AltUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltUnitsPrecision Property example


DimArcLength.AltUnitsScale Property

Specifies scale factor for alternate units (DIMALTF system variable)

Syntax

object.AltUnitsScale

object is a DimArcLength object.

Description

AltUnitsScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

AltUnitsScale Property example


DimArcLength.Application Property

Returns the application object.

Syntax

object.Application

object is a DimArcLength object.

Description

Application Object; Read-only

Examples...

Application Property example


DimArcLength.Arrowhead1Block Property

Specifies the block of the first dimension arrowhead

Syntax

object.Arrowhead1Block

object is a DimArcLength object.

Description

Arrowhead1Block String; Read-write


DimArcLength.Arrowhead1Type Property

Specifies type of the first dimension arrowhead (DIMBLK1 system variable)

Syntax

object.Arrowhead1Type

object is a DimArcLength object.

Description

Arrowhead1Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimArcLength.Arrowhead2Block Property

Specifies the block of the second dimension arrowhead

Syntax

object.Arrowhead2Block

object is a DimArcLength object.

Description

Arrowhead2Block String; Read-write


DimArcLength.Arrowhead2Type Property

Specifies type of the second dimension arrowhead (DIMBLK2 system variable)

Syntax

object.Arrowhead2Type

object is a DimArcLength object.

Description

Arrowhead2Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimArcLength.ArrowheadSize Property

Specifies size of the dimension arrowhead (DIMASZ system variable)

Syntax

object.ArrowheadSize

object is a DimArcLength object.

Description

ArrowheadSize Double; Read-write

Examples...

ArrowheadSize Property example


DimArcLength.Database Property

Returns the database object.

Syntax

object.Database

object is a DimArcLength object.

Description

Database Database; Read-only


DimArcLength.DecimalSeparator Property

Specifies the decimal separator for metric dimensions (DIMDSEP system variable)

Syntax

object.DecimalSeparator

object is a DimArcLength object.

Description

DecimalSeparator String; Read-write


DimArcLength.DimLine1Suppress Property

Sets suppression of first dimension line On or Off (DIMSD1 system variable)

Syntax

object.DimLine1Suppress

object is a DimArcLength object.

Description

DimLine1Suppress Boolean; Read-write


DimArcLength.DimLine2Suppress Property

Sets suppression of second dimension line On or Off (DIMSD2 system variable)

Syntax

object.DimLine2Suppress

object is a DimArcLength object.

Description

DimLine2Suppress Boolean; Read-write


DimArcLength.DimLineInside Property

Sets drawing of dimension lines outside extension lines On or Off (DIMSOXD system variable)

Syntax

object.DimLineInside

object is a DimArcLength object.

Description

DimLineInside Boolean; Read-write


DimArcLength.DimensionLineColor Property

Specifies color of the dimension lines (DIMCLRD system variable)

Syntax

object.DimensionLineColor

object is a DimArcLength object.

Description

DimensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimArcLength.DimensionLineExtend Property

Specifies amount to extend dimension lines beyond the extension line (DIMDLE system variable)

Syntax

object.DimensionLineExtend

object is a DimArcLength object.

Description

DimensionLineExtend Double; Read-write


DimArcLength.DimensionLineWeight Property

Specifies lineweight for dimension lines (DIMLWD system variable)

Syntax

object.DimensionLineWeight

object is a DimArcLength object.

Description

DimensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimArcLength.Document Property

Returns the document object.

Syntax

object.Document

object is a DimArcLength object.

Description

Document Object; Read-only


DimArcLength.ExtLine1Suppress Property

Sets suppression of first extension line On or Off (DIMSE1 system variable)

Syntax

object.ExtLine1Suppress

object is a DimArcLength object.

Description

ExtLine1Suppress Boolean; Read-write


DimArcLength.ExtLine2Suppress Property

Sets suppression of second extension line On or Off (DIMSE2 system variable)

Syntax

object.ExtLine2Suppress

object is a DimArcLength object.

Description

ExtLine2Suppress Boolean; Read-write


DimArcLength.ExtensionLineColor Property

Specifies color of the extension line (DIMCLRE system variable)

Syntax

object.ExtensionLineColor

object is a DimArcLength object.

Description

ExtensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimArcLength.ExtensionLineExtend Property

Specifies amount to extend extension line beyond the dimension line (DIMEXE system variable)

Syntax

object.ExtensionLineExtend

object is a DimArcLength object.

Description

ExtensionLineExtend Double; Read-write


DimArcLength.ExtensionLineOffset Property

Specifies offset of extension lines from the origin points (DIMEXO system variable)

Syntax

object.ExtensionLineOffset

object is a DimArcLength object.

Description

ExtensionLineOffset Double; Read-write


DimArcLength.ExtensionLineWeight Property

Specifies lineweight for extension lines (DIMLWE system variable)

Syntax

object.ExtensionLineWeight

object is a DimArcLength object.

Description

ExtensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimArcLength.Fit Property

Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)

Syntax

object.Fit

object is a DimArcLength object.

Description

Fit ZcDimFit: Read-write
Can be one of the constants listed here:
zcTextAndArrows
zcArrowsOnly
zcTextOnly
zcBestFit


DimArcLength.ForceLineInside Property

Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)

Syntax

object.ForceLineInside

object is a DimArcLength object.

Description

ForceLineInside Boolean; Read-write


DimArcLength.FractionFormat Property

Sets fraction type (DIMFRAC system variable)

Syntax

object.FractionFormat

object is a DimArcLength object.

Description

FractionFormat ZcDimFractionType: Read-write
Can be one of the constants listed here:
zcHorizontal
zcDiagonal
zcNotStacked


DimArcLength.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a DimArcLength object.

Description

Handle String; Read-only


DimArcLength.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a DimArcLength object.

Description

HasExtensionDictionary Boolean; Read-only


DimArcLength.HorizontalTextPosition Property

Specifies horizontal dimension text position (DIMJUST system variable)

Syntax

object.HorizontalTextPosition

object is a DimArcLength object.

Description

HorizontalTextPosition ZcDimHorizontalJustification: Read-write
Can be one of the constants listed here:
zcHorzCentered
zcFirstExtensionLine
zcSecondExtensionLine
zcOverFirstExtension
zcOverSecondExtension


DimArcLength.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a DimArcLength object.

Description

Hyperlinks Hyperlinks; Read-only


DimArcLength.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a DimArcLength object.

Description

Layer String; Read-write

Examples...

Layer Property example


DimArcLength.LinearScaleFactor Property

Specifies global scale factor for linear dimensions (DIMLFAC system variable)

Syntax

object.LinearScaleFactor

object is a DimArcLength object.

Description

LinearScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinearScaleFactor Property example


DimArcLength.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a DimArcLength object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


DimArcLength.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a DimArcLength object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


DimArcLength.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a DimArcLength object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


DimArcLength.Measurement Property

Specifies dimension measurement value

Syntax

object.Measurement

object is a DimArcLength object.

Description

Measurement Double; Read-only

Examples...

Measurement Property example


DimArcLength.Normal Property

Returns and sets the normal direction vector.

Syntax

object.Normal

object is a DimArcLength object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


DimArcLength.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a DimArcLength object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


DimArcLength.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a DimArcLength object.

Description

ObjectName String; Read-only


DimArcLength.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a DimArcLength object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


DimArcLength.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a DimArcLength object.

Description

PlotStyleName String; Read-write


DimArcLength.PrimaryUnitsPrecision Property

Specifies precision for primary units dimensions (DIMDEC system variable)

Syntax

object.PrimaryUnitsPrecision

object is a DimArcLength object.

Description

PrimaryUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

PrimaryUnitsPrecision Property example


DimArcLength.Rotation Property

Returns and sets the horizontal rotation angle of the dimension

Syntax

object.Rotation

object is a DimArcLength object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


DimArcLength.RoundDistance Property

Specifies distance rounding value (DIMRND system variable)

Syntax

object.RoundDistance

object is a DimArcLength object.

Description

RoundDistance Double; Read-write

Examples...

RoundDistance Property example


DimArcLength.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a DimArcLength object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


DimArcLength.StyleName Property

Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)

Syntax

object.StyleName

object is a DimArcLength object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


DimArcLength.SuppressLeadingZeros Property

Determines suppression of leading zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressLeadingZeros

object is a DimArcLength object.

Description

SuppressLeadingZeros Boolean; Read-write

Examples...

SuppressLeadingZeros Property example


DimArcLength.SuppressTrailingZeros Property

Determines suppression of trailing zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressTrailingZeros

object is a DimArcLength object.

Description

SuppressTrailingZeros Boolean; Read-write

Examples...

SuppressTrailingZeros Property example


DimArcLength.SuppressZeroFeet Property

Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroFeet

object is a DimArcLength object.

Description

SuppressZeroFeet Boolean; Read-write

Examples...

SuppressZeroFeet Property example


DimArcLength.SuppressZeroInches Property

Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroInches

object is a DimArcLength object.

Description

SuppressZeroInches Boolean; Read-write

Examples...

SuppressZeroInches Property example


DimArcLength.TextColor Property

Specifies the color of the dimension text (DIMCLRT system variable)

Syntax

object.TextColor

object is a DimArcLength object.

Description

TextColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

TextColor Property example


DimArcLength.TextGap Property

Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)

Syntax

object.TextGap

object is a DimArcLength object.

Description

TextGap Double; Read-write

Examples...

TextGap Property example


DimArcLength.TextHeight Property

Specifies text height of the dimension (DIMTXT system variable)

Syntax

object.TextHeight

object is a DimArcLength object.

Description

TextHeight Double; Read-write

Examples...

TextHeight Property example


DimArcLength.TextInside Property

Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInside

object is a DimArcLength object.

Description

TextInside Boolean; Read-write

Examples...

TextInside Property example


DimArcLength.TextInsideAlign Property

Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInsideAlign

object is a DimArcLength object.

Description

TextInsideAlign Boolean; Read-write

Examples...

TextInsideAlign Property example


DimArcLength.TextMovement Property

Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)

Syntax

object.TextMovement

object is a DimArcLength object.

Description

TextMovement ZcDimTextMovement: Read-write
Can be one of the constants listed here:
zcDimLineWithText
zcMoveTextAddLeader
zcMoveTextNoLeader

Examples...

TextMovement Property example


DimArcLength.TextOutsideAlign Property

Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)

Syntax

object.TextOutsideAlign

object is a DimArcLength object.

Description

TextOutsideAlign Boolean; Read-write

Examples...

TextOutsideAlign Property example


DimArcLength.TextOverride Property

Specifies the text string of the dimension (overrides Measurement string)

Syntax

object.TextOverride

object is a DimArcLength object.

Description

TextOverride String; Read-write

Examples...

TextOverride Property example


DimArcLength.TextPosition Property

Specifies the dimension text position or pick point

Syntax

object.TextPosition

object is a DimArcLength object.

Description

TextPosition Variant; Read-write


DimArcLength.TextPrefix Property

Specifies the text prefix for the dimension (DIMPOST system variable)

Syntax

object.TextPrefix

object is a DimArcLength object.

Description

TextPrefix String; Read-write

Examples...

TextPrefix Property example


DimArcLength.TextRotation Property

Specifies the rotation angle of the dimension text

Syntax

object.TextRotation

object is a DimArcLength object.

Description

TextRotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

TextRotation Property example


DimArcLength.TextStyle Property

Specifies text style of the dimension (DIMTXSTY system variable)

Syntax

object.TextStyle

object is a DimArcLength object.

Description

TextStyle String; Read-write

Examples...

TextStyle Property example


DimArcLength.TextSuffix Property

Specifies the text suffix for the dimension (DIMPOST system variable)

Syntax

object.TextSuffix

object is a DimArcLength object.

Description

TextSuffix String; Read-write

Examples...

TextSuffix Property example


DimArcLength.ToleranceDisplay Property

Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)

Syntax

object.ToleranceDisplay

object is a DimArcLength object.

Description

ToleranceDisplay ZcDimToleranceMethod: Read-write
Can be one of the constants listed here:
zcTolNone
zcTolSymmetrical
zcTolDeviation
zcTolLimits
zcTolBasic

Examples...

ToleranceDisplay Property example


DimArcLength.ToleranceHeightScale Property

Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)

Syntax

object.ToleranceHeightScale

object is a DimArcLength object.

Description

ToleranceHeightScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ToleranceHeightScale Property example


DimArcLength.ToleranceJustification Property

Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)

Syntax

object.ToleranceJustification

object is a DimArcLength object.

Description

ToleranceJustification ZcDimToleranceJustify: Read-write
Can be one of the constants listed here:
zcTolBottom
zcTolMiddle
zcTolTop

Examples...

ToleranceJustification Property example


DimArcLength.ToleranceLowerLimit Property

Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)

Syntax

object.ToleranceLowerLimit

object is a DimArcLength object.

Description

ToleranceLowerLimit Double; Read-write

Examples...

ToleranceLowerLimit Property example


DimArcLength.TolerancePrecision Property

Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)

Syntax

object.TolerancePrecision

object is a DimArcLength object.

Description

TolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TolerancePrecision Property example


DimArcLength.ToleranceSuppressLeadingZeros Property

Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressLeadingZeros

object is a DimArcLength object.

Description

ToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

ToleranceSuppressLeadingZeros Property example


DimArcLength.ToleranceSuppressTrailingZeros Property

Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressTrailingZeros

object is a DimArcLength object.

Description

ToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

ToleranceSuppressTrailingZeros Property example


DimArcLength.ToleranceSuppressZeroFeet Property

Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroFeet

object is a DimArcLength object.

Description

ToleranceSuppressZeroFeet Boolean; Read-write

Examples...

ToleranceSuppressZeroFeet Property example


DimArcLength.ToleranceSuppressZeroInches Property

Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroInches

object is a DimArcLength object.

Description

ToleranceSuppressZeroInches Boolean; Read-write

Examples...

ToleranceSuppressZeroInches Property example


DimArcLength.ToleranceUpperLimit Property

Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)

Syntax

object.ToleranceUpperLimit

object is a DimArcLength object.

Description

ToleranceUpperLimit Double; Read-write

Examples...

ToleranceUpperLimit Property example


DimArcLength.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a DimArcLength object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


DimArcLength.UnitsFormat Property

Specifies units format for linear dimensions (DIMLUNIT system variable)

Syntax

object.UnitsFormat

object is a DimArcLength object.

Description

UnitsFormat ZcDimLUnits: Read-write
Can be one of the constants listed here:
zcDimLScientific
zcDimLDecimal
zcDimLEngineering
zcDimLArchitectural
zcDimLFractional
zcDimLWindowsDesktop

Examples...

UnitsFormat Property example


DimArcLength.VerticalTextPosition Property

Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)

Syntax

object.VerticalTextPosition

object is a DimArcLength object.

Description

VerticalTextPosition ZcDimVerticalJustification: Read-write
Can be one of the constants listed here:
zcVertCentered
zcAbove
zcOutside
zcJIS

Examples...

VerticalTextPosition Property example


DimArcLength.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a DimArcLength object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


DimArcLength.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a DimArcLength object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDimDiametric Object Members

DimDiametric Object Members

A dimension measuring the diameter of a circle or arc.

VBA Class Name

ZcadDimDiametric

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
AltRoundDistance | Specifies distance rounding value for alternate units (DIMALTRND system variable)
AltSuppressLeadingZeros | Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroFeet | Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroInches | Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)
AltTextPrefix | Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)
AltTextSuffix | Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)
AltTolerancePrecision | Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)
AltToleranceSuppressLeadingZeros | Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroFeet | Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroInches | Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltUnits | Sets alternate units dimensioning On or Off (DIMALT system variable)
AltUnitsFormat | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsPrecision | Specifies decimal place precision for alternate units (DIMALTD system variable)
AltUnitsScale | Specifies scale factor for alternate units (DIMALTF system variable)
Application | Returns the application object.
Arrowhead1Block | Specifies block of the first dimension arrowhead
Arrowhead1Type | Specifies type of the first dimension arrowhead (DIMBLK1 system variable)
Arrowhead2Block | Specifies block of the second dimension arrowhead
Arrowhead2Type | Specifies type of the second dimension arrowhead (DIMBLK2 system variable)
ArrowheadSize | Specifies size of the dimension arrowhead (DIMASZ system variable)
CenterMarkSize | Specifies size of the center mark on the dimension (DIMCEN system variable)
CenterType | Specifies type of center mark on the dimension (DIMCEN system variable)
Database | Returns the database object.
DecimalSeparator | Specifies the decimal separator for metric dimensions (DIMDSEP system variable)
DimLine1Suppress | Sets suppression of first dimension line On or Off (DIMSD1 system variable)
DimLine2Suppress | Sets suppression of second dimension line On or Off (DIMSD2 system variable)
DimensionLineColor | Specifies color of the dimension lines (DIMCLRD system variable)
DimensionLineWeight | Specifies lineweight for dimension lines (DIMLWD system variable)
Document | Returns the document object.
Fit | Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)
ForceLineInside | Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)
FractionFormat | Sets fraction type (DIMFRAC system variable)
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
LeaderLength | Specifies leader length of the dimension
LinearScaleFactor | Specifies global scale factor for linear dimensions (DIMLFAC system variable)
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Measurement | Specifies dimension measurement value (DIMAUNIT system variable)
Normal | Returns and sets the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
PrimaryUnitsPrecision | Specifies precision for primary units dimensions (DIMDEC system variable)
Rotation | Returns and sets the horizontal rotation angle of the dimension
RoundDistance | Specifies distance rounding value (DIMRND system variable)
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)
SuppressLeadingZeros | Determines suppression of leading zeros for dimensions (DIMZIN system variable)
SuppressTrailingZeros | Determines suppression of trailing zeros for dimensions (DIMZIN system variable)
SuppressZeroFeet | Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)
SuppressZeroInches | Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)
TextColor | Specifies the color of the dimension text (DIMCLRT system variable)
TextGap | Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)
TextHeight | Specifies text height of the dimension (DIMTXT system variable)
TextInside | Sets drawing of text between extension lines On or Off (DIMTIX system variable)
TextInsideAlign | Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)
TextMovement | Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)
TextOutsideAlign | Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)
TextOverride | Specifies the text string of the dimension (overrides Measurement string)
TextPosition | Specifies the dimension text position or pick point
TextPrefix | Specifies the text prefix for the dimension (DIMPOST system variable)
TextRotation | Specifies the rotation angle of the dimension text
TextStyle | Specifies text style of the dimension (DIMTXSTY system variable)
TextSuffix | Specifies the text suffix for the dimension (DIMPOST system variable)
ToleranceDisplay | Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)
ToleranceHeightScale | Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)
ToleranceJustification | Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)
ToleranceLowerLimit | Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)
TolerancePrecision | Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)
ToleranceSuppressLeadingZeros | Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressTrailingZeros | Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressZeroFeet | Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)
ToleranceSuppressZeroInches | Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)
ToleranceUpperLimit | Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)
TrueColor | Returns the true color of the object.
UnitsFormat | Specifies units format for linear dimensions (DIMLUNIT system variable)
VerticalTextPosition | Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


DimDiametric.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


DimDiametric.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


DimDiametric.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a DimDiametric object.

Return value

Object

Examples...

Copy Method example


DimDiametric.Delete Method

Deletes the object.

Syntax

object.Delete

object is a DimDiametric object.

Examples...

Delete Method example


DimDiametric.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a DimDiametric object.

Examples...

Erase Method example


DimDiametric.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


DimDiametric.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a DimDiametric object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


DimDiametric.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


DimDiametric.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


DimDiametric.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


DimDiametric.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


DimDiametric.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


DimDiametric.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


DimDiametric.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


DimDiametric.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a DimDiametric object.


DimDiametric.AltRoundDistance Property

Specifies distance rounding value for alternate units (DIMALTRND system variable)

Syntax

object.AltRoundDistance

object is a DimDiametric object.

Description

AltRoundDistance Double; Read-write

Examples...

AltRoundDistance Property example


DimDiametric.AltSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressLeadingZeros

object is a DimDiametric object.

Description

AltSuppressLeadingZeros Boolean; Read-write

Examples...

AltSuppressLeadingZeros Property example


DimDiametric.AltSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressTrailingZeros

object is a DimDiametric object.

Description

AltSuppressTrailingZeros Boolean; Read-write

Examples...

AltSuppressTrailingZeros Property example


DimDiametric.AltSuppressZeroFeet Property

Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroFeet

object is a DimDiametric object.

Description

AltSuppressZeroFeet Boolean; Read-write

Examples...

AltSuppressZeroFeet Property example


DimDiametric.AltSuppressZeroInches Property

Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroInches

object is a DimDiametric object.

Description

AltSuppressZeroInches Boolean; Read-write

Examples...

AltSuppressZeroInches Property example


DimDiametric.AltTextPrefix Property

Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextPrefix

object is a DimDiametric object.

Description

AltTextPrefix String; Read-write


DimDiametric.AltTextSuffix Property

Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextSuffix

object is a DimDiametric object.

Description

AltTextSuffix String; Read-write


DimDiametric.AltTolerancePrecision Property

Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)

Syntax

object.AltTolerancePrecision

object is a DimDiametric object.

Description

AltTolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltTolerancePrecision Property example


DimDiametric.AltToleranceSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressLeadingZeros

object is a DimDiametric object.

Description

AltToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

AltToleranceSuppressLeadingZeros Property example


DimDiametric.AltToleranceSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressTrailingZeros

object is a DimDiametric object.

Description

AltToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

AltToleranceSuppressTrailingZeros Property example


DimDiametric.AltToleranceSuppressZeroFeet Property

Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroFeet

object is a DimDiametric object.

Description

AltToleranceSuppressZeroFeet Boolean; Read-write

Examples...

AltToleranceSuppressZeroFeet Property example


DimDiametric.AltToleranceSuppressZeroInches Property

Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroInches

object is a DimDiametric object.

Description

AltToleranceSuppressZeroInches Boolean; Read-write

Examples...

AltToleranceSuppressZeroInches Property example


DimDiametric.AltUnits Property

Sets alternate units dimensioning On or Off (DIMALT system variable)

Syntax

object.AltUnits

object is a DimDiametric object.

Description

AltUnits Boolean; Read-write

Examples...

AltUnits Property example


DimDiametric.AltUnitsFormat Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnitsFormat

object is a DimDiametric object.

Description

AltUnitsFormat ZcDimUnits: Read-write
Can be one of the constants listed here:
zcDimScientific
zcDimDecimal
zcDimEngineering
zcDimArchitecturalStacked
zcDimFractionalStacked
zcDimArchitectural
zcDimFractional
zcDimWindowsDesktop

Examples...

AltUnitsFormat Property example


DimDiametric.AltUnitsPrecision Property

Specifies decimal place precision for alternate units (DIMALTD system variable)

Syntax

object.AltUnitsPrecision

object is a DimDiametric object.

Description

AltUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltUnitsPrecision Property example


DimDiametric.AltUnitsScale Property

Specifies scale factor for alternate units (DIMALTF system variable)

Syntax

object.AltUnitsScale

object is a DimDiametric object.

Description

AltUnitsScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

AltUnitsScale Property example


DimDiametric.Application Property

Returns the application object.

Syntax

object.Application

object is a DimDiametric object.

Description

Application Object; Read-only

Examples...

Application Property example


DimDiametric.Arrowhead1Block Property

Specifies block of the first dimension arrowhead

Syntax

object.Arrowhead1Block

object is a DimDiametric object.

Description

Arrowhead1Block String; Read-write


DimDiametric.Arrowhead1Type Property

Specifies type of the first dimension arrowhead (DIMBLK1 system variable)

Syntax

object.Arrowhead1Type

object is a DimDiametric object.

Description

Arrowhead1Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimDiametric.Arrowhead2Block Property

Specifies block of the second dimension arrowhead

Syntax

object.Arrowhead2Block

object is a DimDiametric object.

Description

Arrowhead2Block String; Read-write


DimDiametric.Arrowhead2Type Property

Specifies type of the second dimension arrowhead (DIMBLK2 system variable)

Syntax

object.Arrowhead2Type

object is a DimDiametric object.

Description

Arrowhead2Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimDiametric.ArrowheadSize Property

Specifies size of the dimension arrowhead (DIMASZ system variable)

Syntax

object.ArrowheadSize

object is a DimDiametric object.

Description

ArrowheadSize Double; Read-write

Examples...

ArrowheadSize Property example


DimDiametric.CenterMarkSize Property

Specifies size of the center mark on the dimension (DIMCEN system variable)

Syntax

object.CenterMarkSize

object is a DimDiametric object.

Description

CenterMarkSize Double; Read-write

Examples...

CenterMarkSize Property example


DimDiametric.CenterType Property

Specifies type of center mark on the dimension (DIMCEN system variable)

Syntax

object.CenterType

object is a DimDiametric object.

Description

CenterType ZcDimCenterType: Read-write
Can be one of the constants listed here:
zcCenterMark
zcCenterLine
zcCenterNone

Examples...

CenterType Property example


DimDiametric.Database Property

Returns the database object.

Syntax

object.Database

object is a DimDiametric object.

Description

Database Database; Read-only


DimDiametric.DecimalSeparator Property

Specifies the decimal separator for metric dimensions (DIMDSEP system variable)

Syntax

object.DecimalSeparator

object is a DimDiametric object.

Description

DecimalSeparator String; Read-write


DimDiametric.DimLine1Suppress Property

Sets suppression of first dimension line On or Off (DIMSD1 system variable)

Syntax

object.DimLine1Suppress

object is a DimDiametric object.

Description

DimLine1Suppress Boolean; Read-write


DimDiametric.DimLine2Suppress Property

Sets suppression of second dimension line On or Off (DIMSD2 system variable)

Syntax

object.DimLine2Suppress

object is a DimDiametric object.

Description

DimLine2Suppress Boolean; Read-write


DimDiametric.DimensionLineColor Property

Specifies color of the dimension lines (DIMCLRD system variable)

Syntax

object.DimensionLineColor

object is a DimDiametric object.

Description

DimensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimDiametric.DimensionLineWeight Property

Specifies lineweight for dimension lines (DIMLWD system variable)

Syntax

object.DimensionLineWeight

object is a DimDiametric object.

Description

DimensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimDiametric.Document Property

Returns the document object.

Syntax

object.Document

object is a DimDiametric object.

Description

Document Object; Read-only


DimDiametric.Fit Property

Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)

Syntax

object.Fit

object is a DimDiametric object.

Description

Fit ZcDimFit: Read-write
Can be one of the constants listed here:
zcTextAndArrows
zcArrowsOnly
zcTextOnly
zcBestFit


DimDiametric.ForceLineInside Property

Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)

Syntax

object.ForceLineInside

object is a DimDiametric object.

Description

ForceLineInside Boolean; Read-write


DimDiametric.FractionFormat Property

Sets fraction type (DIMFRAC system variable)

Syntax

object.FractionFormat

object is a DimDiametric object.

Description

FractionFormat ZcDimFractionType: Read-write
Can be one of the constants listed here:
zcHorizontal
zcDiagonal
zcNotStacked


DimDiametric.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a DimDiametric object.

Description

Handle String; Read-only


DimDiametric.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a DimDiametric object.

Description

HasExtensionDictionary Boolean; Read-only


DimDiametric.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a DimDiametric object.

Description

Hyperlinks Hyperlinks; Read-only


DimDiametric.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a DimDiametric object.

Description

Layer String; Read-write

Examples...

Layer Property example


DimDiametric.LeaderLength Property

Specifies leader length of the dimension

Syntax

object.LeaderLength

object is a DimDiametric object.

Description

LeaderLength ; Write-only

Examples...

LeaderLength Property example


DimDiametric.LinearScaleFactor Property

Specifies global scale factor for linear dimensions (DIMLFAC system variable)

Syntax

object.LinearScaleFactor

object is a DimDiametric object.

Description

LinearScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinearScaleFactor Property example


DimDiametric.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a DimDiametric object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


DimDiametric.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a DimDiametric object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


DimDiametric.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a DimDiametric object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


DimDiametric.Measurement Property

Specifies dimension measurement value (DIMAUNIT system variable)

Syntax

object.Measurement

object is a DimDiametric object.

Description

Measurement Double; Read-only

Examples...

Measurement Property example


DimDiametric.Normal Property

Returns and sets the normal direction vector.

Syntax

object.Normal

object is a DimDiametric object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


DimDiametric.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a DimDiametric object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


DimDiametric.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a DimDiametric object.

Description

ObjectName String; Read-only


DimDiametric.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a DimDiametric object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


DimDiametric.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a DimDiametric object.

Description

PlotStyleName String; Read-write


DimDiametric.PrimaryUnitsPrecision Property

Specifies precision for primary units dimensions (DIMDEC system variable)

Syntax

object.PrimaryUnitsPrecision

object is a DimDiametric object.

Description

PrimaryUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

PrimaryUnitsPrecision Property example


DimDiametric.Rotation Property

Returns and sets the horizontal rotation angle of the dimension

Syntax

object.Rotation

object is a DimDiametric object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


DimDiametric.RoundDistance Property

Specifies distance rounding value (DIMRND system variable)

Syntax

object.RoundDistance

object is a DimDiametric object.

Description

RoundDistance Double; Read-write

Examples...

RoundDistance Property example


DimDiametric.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a DimDiametric object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


DimDiametric.StyleName Property

Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)

Syntax

object.StyleName

object is a DimDiametric object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


DimDiametric.SuppressLeadingZeros Property

Determines suppression of leading zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressLeadingZeros

object is a DimDiametric object.

Description

SuppressLeadingZeros Boolean; Read-write

Examples...

SuppressLeadingZeros Property example


DimDiametric.SuppressTrailingZeros Property

Determines suppression of trailing zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressTrailingZeros

object is a DimDiametric object.

Description

SuppressTrailingZeros Boolean; Read-write

Examples...

SuppressTrailingZeros Property example


DimDiametric.SuppressZeroFeet Property

Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroFeet

object is a DimDiametric object.

Description

SuppressZeroFeet Boolean; Read-write

Examples...

SuppressZeroFeet Property example


DimDiametric.SuppressZeroInches Property

Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroInches

object is a DimDiametric object.

Description

SuppressZeroInches Boolean; Read-write

Examples...

SuppressZeroInches Property example


DimDiametric.TextColor Property

Specifies the color of the dimension text (DIMCLRT system variable)

Syntax

object.TextColor

object is a DimDiametric object.

Description

TextColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

TextColor Property example


DimDiametric.TextGap Property

Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)

Syntax

object.TextGap

object is a DimDiametric object.

Description

TextGap Double; Read-write

Examples...

TextGap Property example


DimDiametric.TextHeight Property

Specifies text height of the dimension (DIMTXT system variable)

Syntax

object.TextHeight

object is a DimDiametric object.

Description

TextHeight Double; Read-write

Examples...

TextHeight Property example


DimDiametric.TextInside Property

Sets drawing of text between extension lines On or Off (DIMTIX system variable)

Syntax

object.TextInside

object is a DimDiametric object.

Description

TextInside Boolean; Read-write

Examples...

TextInside Property example


DimDiametric.TextInsideAlign Property

Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInsideAlign

object is a DimDiametric object.

Description

TextInsideAlign Boolean; Read-write

Examples...

TextInsideAlign Property example


DimDiametric.TextMovement Property

Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)

Syntax

object.TextMovement

object is a DimDiametric object.

Description

TextMovement ZcDimTextMovement: Read-write
Can be one of the constants listed here:
zcDimLineWithText
zcMoveTextAddLeader
zcMoveTextNoLeader

Examples...

TextMovement Property example


DimDiametric.TextOutsideAlign Property

Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)

Syntax

object.TextOutsideAlign

object is a DimDiametric object.

Description

TextOutsideAlign Boolean; Read-write

Examples...

TextOutsideAlign Property example


DimDiametric.TextOverride Property

Specifies the text string of the dimension (overrides Measurement string)

Syntax

object.TextOverride

object is a DimDiametric object.

Description

TextOverride String; Read-write

Examples...

TextOverride Property example


DimDiametric.TextPosition Property

Specifies the dimension text position or pick point

Syntax

object.TextPosition

object is a DimDiametric object.

Description

TextPosition Variant; Read-write


DimDiametric.TextPrefix Property

Specifies the text prefix for the dimension (DIMPOST system variable)

Syntax

object.TextPrefix

object is a DimDiametric object.

Description

TextPrefix String; Read-write

Examples...

TextPrefix Property example


DimDiametric.TextRotation Property

Specifies the rotation angle of the dimension text

Syntax

object.TextRotation

object is a DimDiametric object.

Description

TextRotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

TextRotation Property example


DimDiametric.TextStyle Property

Specifies text style of the dimension (DIMTXSTY system variable)

Syntax

object.TextStyle

object is a DimDiametric object.

Description

TextStyle String; Read-write

Examples...

TextStyle Property example


DimDiametric.TextSuffix Property

Specifies the text suffix for the dimension (DIMPOST system variable)

Syntax

object.TextSuffix

object is a DimDiametric object.

Description

TextSuffix String; Read-write

Examples...

TextSuffix Property example


DimDiametric.ToleranceDisplay Property

Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)

Syntax

object.ToleranceDisplay

object is a DimDiametric object.

Description

ToleranceDisplay ZcDimToleranceMethod: Read-write
Can be one of the constants listed here:
zcTolNone
zcTolSymmetrical
zcTolDeviation
zcTolLimits
zcTolBasic

Examples...

ToleranceDisplay Property example


DimDiametric.ToleranceHeightScale Property

Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)

Syntax

object.ToleranceHeightScale

object is a DimDiametric object.

Description

ToleranceHeightScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ToleranceHeightScale Property example


DimDiametric.ToleranceJustification Property

Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)

Syntax

object.ToleranceJustification

object is a DimDiametric object.

Description

ToleranceJustification ZcDimToleranceJustify: Read-write
Can be one of the constants listed here:
zcTolBottom
zcTolMiddle
zcTolTop

Examples...

ToleranceJustification Property example


DimDiametric.ToleranceLowerLimit Property

Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)

Syntax

object.ToleranceLowerLimit

object is a DimDiametric object.

Description

ToleranceLowerLimit Double; Read-write

Examples...

ToleranceLowerLimit Property example


DimDiametric.TolerancePrecision Property

Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)

Syntax

object.TolerancePrecision

object is a DimDiametric object.

Description

TolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TolerancePrecision Property example


DimDiametric.ToleranceSuppressLeadingZeros Property

Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressLeadingZeros

object is a DimDiametric object.

Description

ToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

ToleranceSuppressLeadingZeros Property example


DimDiametric.ToleranceSuppressTrailingZeros Property

Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressTrailingZeros

object is a DimDiametric object.

Description

ToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

ToleranceSuppressTrailingZeros Property example


DimDiametric.ToleranceSuppressZeroFeet Property

Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroFeet

object is a DimDiametric object.

Description

ToleranceSuppressZeroFeet Boolean; Read-write

Examples...

ToleranceSuppressZeroFeet Property example


DimDiametric.ToleranceSuppressZeroInches Property

Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroInches

object is a DimDiametric object.

Description

ToleranceSuppressZeroInches Boolean; Read-write

Examples...

ToleranceSuppressZeroInches Property example


DimDiametric.ToleranceUpperLimit Property

Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)

Syntax

object.ToleranceUpperLimit

object is a DimDiametric object.

Description

ToleranceUpperLimit Double; Read-write

Examples...

ToleranceUpperLimit Property example


DimDiametric.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a DimDiametric object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


DimDiametric.UnitsFormat Property

Specifies units format for linear dimensions (DIMLUNIT system variable)

Syntax

object.UnitsFormat

object is a DimDiametric object.

Description

UnitsFormat ZcDimLUnits: Read-write
Can be one of the constants listed here:
zcDimLScientific
zcDimLDecimal
zcDimLEngineering
zcDimLArchitectural
zcDimLFractional
zcDimLWindowsDesktop

Examples...

UnitsFormat Property example


DimDiametric.VerticalTextPosition Property

Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)

Syntax

object.VerticalTextPosition

object is a DimDiametric object.

Description

VerticalTextPosition ZcDimVerticalJustification: Read-write
Can be one of the constants listed here:
zcVertCentered
zcAbove
zcOutside
zcJIS

Examples...

VerticalTextPosition Property example


DimDiametric.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a DimDiametric object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


DimDiametric.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a DimDiametric object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDimOrdinate Object Members

DimOrdinate Object Members

A dimension measuring the absolute X or Y position of a point from the origin.

VBA Class Name

ZcadDimOrdinate

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
AltRoundDistance | Specifies distance rounding value for alternate units (DIMALTRND system variable)
AltSuppressLeadingZeros | Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroFeet | Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroInches | Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)
AltTextPrefix | Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)
AltTextSuffix | Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)
AltTolerancePrecision | Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)
AltToleranceSuppressLeadingZeros | Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroFeet | Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroInches | Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltUnits | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsFormat | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsPrecision | Specifies decimal place precision for alternate units (DIMALTD system variable)
AltUnitsScale | Specifies scale factor for alternate units (DIMALTF system variable)
Application | Returns the application object.
ArrowheadSize | Specifies size of the dimension arrowhead (DIMASZ system variable)
Database | Returns the database object.
DecimalSeparator | Specifies the decimal separator for metric dimensions (DIMDSEP system variable)
Document | Returns the document object.
ExtensionLineColor | Specifies color of the extension line (DIMCLRE system variable)
ExtensionLineOffset | Specifies offset of extension lines from the origin points (DIMEXO system variable)
ExtensionLineWeight | Specifies lineweight for extension lines (DIMLWE system variable)
FractionFormat | Sets fraction type (DIMFRAC system variable)
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
LinearScaleFactor | Specifies global scale factor for linear dimensions (DIMLFAC system variable)
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Measurement | Specifies dimension measurement value
Normal | Returns and sets the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
PrimaryUnitsPrecision | Specifies precision for primary units dimensions (DIMDEC system variable)
Rotation | Returns and sets the horizontal rotation angle of the dimension
RoundDistance | Specifies distance rounding value (DIMRND system variable)
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)
SuppressLeadingZeros | Determines suppression of leading zeros for dimensions (DIMZIN system variable)
SuppressTrailingZeros | Determines suppression of trailing zeros for dimensions (DIMZIN system variable)
SuppressZeroFeet | Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)
SuppressZeroInches | Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)
TextColor | Specifies the color of the dimension text (DIMCLRT system variable)
TextGap | Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)
TextHeight | Specifies text height of the dimension (DIMTXT system variable)
TextMovement | Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)
TextOverride | Specifies the text string of the dimension (overrides Measurement string)
TextPosition | Specifies the dimension text position or pick point
TextPrefix | Specifies the text prefix for the dimension (DIMPOST system variable)
TextRotation | Specifies the rotation angle of the dimension text
TextStyle | Specifies text style of the dimension (DIMTXSTY system variable)
TextSuffix | Specifies the text suffix for the dimension (DIMPOST system variable)
ToleranceDisplay | Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)
ToleranceHeightScale | Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)
ToleranceJustification | Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)
ToleranceLowerLimit | Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)
TolerancePrecision | Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)
ToleranceSuppressLeadingZeros | Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressTrailingZeros | Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressZeroFeet | Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)
ToleranceSuppressZeroInches | Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)
ToleranceUpperLimit | Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)
TrueColor | Returns the true color of the object.
UnitsFormat | Specifies units format for linear dimensions (DIMLUNIT system variable)
VerticalTextPosition | Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


DimOrdinate.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


DimOrdinate.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


DimOrdinate.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a DimOrdinate object.

Return value

Object

Examples...

Copy Method example


DimOrdinate.Delete Method

Deletes the object.

Syntax

object.Delete

object is a DimOrdinate object.

Examples...

Delete Method example


DimOrdinate.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a DimOrdinate object.

Examples...

Erase Method example


DimOrdinate.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


DimOrdinate.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a DimOrdinate object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


DimOrdinate.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


DimOrdinate.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


DimOrdinate.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


DimOrdinate.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


DimOrdinate.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


DimOrdinate.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


DimOrdinate.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


DimOrdinate.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a DimOrdinate object.


DimOrdinate.AltRoundDistance Property

Specifies distance rounding value for alternate units (DIMALTRND system variable)

Syntax

object.AltRoundDistance

object is a DimOrdinate object.

Description

AltRoundDistance Double; Read-write

Examples...

AltRoundDistance Property example


DimOrdinate.AltSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressLeadingZeros

object is a DimOrdinate object.

Description

AltSuppressLeadingZeros Boolean; Read-write

Examples...

AltSuppressLeadingZeros Property example


DimOrdinate.AltSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressTrailingZeros

object is a DimOrdinate object.

Description

AltSuppressTrailingZeros Boolean; Read-write

Examples...

AltSuppressTrailingZeros Property example


DimOrdinate.AltSuppressZeroFeet Property

Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroFeet

object is a DimOrdinate object.

Description

AltSuppressZeroFeet Boolean; Read-write

Examples...

AltSuppressZeroFeet Property example


DimOrdinate.AltSuppressZeroInches Property

Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroInches

object is a DimOrdinate object.

Description

AltSuppressZeroInches Boolean; Read-write

Examples...

AltSuppressZeroInches Property example


DimOrdinate.AltTextPrefix Property

Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextPrefix

object is a DimOrdinate object.

Description

AltTextPrefix String; Read-write


DimOrdinate.AltTextSuffix Property

Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextSuffix

object is a DimOrdinate object.

Description

AltTextSuffix String; Read-write


DimOrdinate.AltTolerancePrecision Property

Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)

Syntax

object.AltTolerancePrecision

object is a DimOrdinate object.

Description

AltTolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltTolerancePrecision Property example


DimOrdinate.AltToleranceSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressLeadingZeros

object is a DimOrdinate object.

Description

AltToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

AltToleranceSuppressLeadingZeros Property example


DimOrdinate.AltToleranceSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressTrailingZeros

object is a DimOrdinate object.

Description

AltToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

AltToleranceSuppressTrailingZeros Property example


DimOrdinate.AltToleranceSuppressZeroFeet Property

Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroFeet

object is a DimOrdinate object.

Description

AltToleranceSuppressZeroFeet Boolean; Read-write

Examples...

AltToleranceSuppressZeroFeet Property example


DimOrdinate.AltToleranceSuppressZeroInches Property

Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroInches

object is a DimOrdinate object.

Description

AltToleranceSuppressZeroInches Boolean; Read-write

Examples...

AltToleranceSuppressZeroInches Property example


DimOrdinate.AltUnits Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnits

object is a DimOrdinate object.

Description

AltUnits Boolean; Read-write

Examples...

AltUnits Property example


DimOrdinate.AltUnitsFormat Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnitsFormat

object is a DimOrdinate object.

Description

AltUnitsFormat ZcDimUnits: Read-write
Can be one of the constants listed here:
zcDimScientific
zcDimDecimal
zcDimEngineering
zcDimArchitecturalStacked
zcDimFractionalStacked
zcDimArchitectural
zcDimFractional
zcDimWindowsDesktop

Examples...

AltUnitsFormat Property example


DimOrdinate.AltUnitsPrecision Property

Specifies decimal place precision for alternate units (DIMALTD system variable)

Syntax

object.AltUnitsPrecision

object is a DimOrdinate object.

Description

AltUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltUnitsPrecision Property example


DimOrdinate.AltUnitsScale Property

Specifies scale factor for alternate units (DIMALTF system variable)

Syntax

object.AltUnitsScale

object is a DimOrdinate object.

Description

AltUnitsScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

AltUnitsScale Property example


DimOrdinate.Application Property

Returns the application object.

Syntax

object.Application

object is a DimOrdinate object.

Description

Application Object; Read-only

Examples...

Application Property example


DimOrdinate.ArrowheadSize Property

Specifies size of the dimension arrowhead (DIMASZ system variable)

Syntax

object.ArrowheadSize

object is a DimOrdinate object.

Description

ArrowheadSize Double; Read-write

Examples...

ArrowheadSize Property example


DimOrdinate.Database Property

Returns the database object.

Syntax

object.Database

object is a DimOrdinate object.

Description

Database Database; Read-only


DimOrdinate.DecimalSeparator Property

Specifies the decimal separator for metric dimensions (DIMDSEP system variable)

Syntax

object.DecimalSeparator

object is a DimOrdinate object.

Description

DecimalSeparator String; Read-write


DimOrdinate.Document Property

Returns the document object.

Syntax

object.Document

object is a DimOrdinate object.

Description

Document Object; Read-only


DimOrdinate.ExtensionLineColor Property

Specifies color of the extension line (DIMCLRE system variable)

Syntax

object.ExtensionLineColor

object is a DimOrdinate object.

Description

ExtensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimOrdinate.ExtensionLineOffset Property

Specifies offset of extension lines from the origin points (DIMEXO system variable)

Syntax

object.ExtensionLineOffset

object is a DimOrdinate object.

Description

ExtensionLineOffset Double; Read-write


DimOrdinate.ExtensionLineWeight Property

Specifies lineweight for extension lines (DIMLWE system variable)

Syntax

object.ExtensionLineWeight

object is a DimOrdinate object.

Description

ExtensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimOrdinate.FractionFormat Property

Sets fraction type (DIMFRAC system variable)

Syntax

object.FractionFormat

object is a DimOrdinate object.

Description

FractionFormat ZcDimFractionType: Read-write
Can be one of the constants listed here:
zcHorizontal
zcDiagonal
zcNotStacked


DimOrdinate.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a DimOrdinate object.

Description

Handle String; Read-only


DimOrdinate.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a DimOrdinate object.

Description

HasExtensionDictionary Boolean; Read-only


DimOrdinate.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a DimOrdinate object.

Description

Hyperlinks Hyperlinks; Read-only


DimOrdinate.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a DimOrdinate object.

Description

Layer String; Read-write

Examples...

Layer Property example


DimOrdinate.LinearScaleFactor Property

Specifies global scale factor for linear dimensions (DIMLFAC system variable)

Syntax

object.LinearScaleFactor

object is a DimOrdinate object.

Description

LinearScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinearScaleFactor Property example


DimOrdinate.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a DimOrdinate object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


DimOrdinate.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a DimOrdinate object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


DimOrdinate.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a DimOrdinate object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


DimOrdinate.Measurement Property

Specifies dimension measurement value

Syntax

object.Measurement

object is a DimOrdinate object.

Description

Measurement Double; Read-only

Examples...

Measurement Property example


DimOrdinate.Normal Property

Returns and sets the normal direction vector.

Syntax

object.Normal

object is a DimOrdinate object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


DimOrdinate.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a DimOrdinate object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


DimOrdinate.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a DimOrdinate object.

Description

ObjectName String; Read-only


DimOrdinate.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a DimOrdinate object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


DimOrdinate.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a DimOrdinate object.

Description

PlotStyleName String; Read-write


DimOrdinate.PrimaryUnitsPrecision Property

Specifies precision for primary units dimensions (DIMDEC system variable)

Syntax

object.PrimaryUnitsPrecision

object is a DimOrdinate object.

Description

PrimaryUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

PrimaryUnitsPrecision Property example


DimOrdinate.Rotation Property

Returns and sets the horizontal rotation angle of the dimension

Syntax

object.Rotation

object is a DimOrdinate object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


DimOrdinate.RoundDistance Property

Specifies distance rounding value (DIMRND system variable)

Syntax

object.RoundDistance

object is a DimOrdinate object.

Description

RoundDistance Double; Read-write

Examples...

RoundDistance Property example


DimOrdinate.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a DimOrdinate object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


DimOrdinate.StyleName Property

Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)

Syntax

object.StyleName

object is a DimOrdinate object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


DimOrdinate.SuppressLeadingZeros Property

Determines suppression of leading zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressLeadingZeros

object is a DimOrdinate object.

Description

SuppressLeadingZeros Boolean; Read-write

Examples...

SuppressLeadingZeros Property example


DimOrdinate.SuppressTrailingZeros Property

Determines suppression of trailing zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressTrailingZeros

object is a DimOrdinate object.

Description

SuppressTrailingZeros Boolean; Read-write

Examples...

SuppressTrailingZeros Property example


DimOrdinate.SuppressZeroFeet Property

Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroFeet

object is a DimOrdinate object.

Description

SuppressZeroFeet Boolean; Read-write

Examples...

SuppressZeroFeet Property example


DimOrdinate.SuppressZeroInches Property

Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroInches

object is a DimOrdinate object.

Description

SuppressZeroInches Boolean; Read-write

Examples...

SuppressZeroInches Property example


DimOrdinate.TextColor Property

Specifies the color of the dimension text (DIMCLRT system variable)

Syntax

object.TextColor

object is a DimOrdinate object.

Description

TextColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

TextColor Property example


DimOrdinate.TextGap Property

Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)

Syntax

object.TextGap

object is a DimOrdinate object.

Description

TextGap Double; Read-write

Examples...

TextGap Property example


DimOrdinate.TextHeight Property

Specifies text height of the dimension (DIMTXT system variable)

Syntax

object.TextHeight

object is a DimOrdinate object.

Description

TextHeight Double; Read-write

Examples...

TextHeight Property example


DimOrdinate.TextMovement Property

Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)

Syntax

object.TextMovement

object is a DimOrdinate object.

Description

TextMovement ZcDimTextMovement: Read-write
Can be one of the constants listed here:
zcDimLineWithText
zcMoveTextAddLeader
zcMoveTextNoLeader

Examples...

TextMovement Property example


DimOrdinate.TextOverride Property

Specifies the text string of the dimension (overrides Measurement string)

Syntax

object.TextOverride

object is a DimOrdinate object.

Description

TextOverride String; Read-write

Examples...

TextOverride Property example


DimOrdinate.TextPosition Property

Specifies the dimension text position or pick point

Syntax

object.TextPosition

object is a DimOrdinate object.

Description

TextPosition Variant; Read-write


DimOrdinate.TextPrefix Property

Specifies the text prefix for the dimension (DIMPOST system variable)

Syntax

object.TextPrefix

object is a DimOrdinate object.

Description

TextPrefix String; Read-write

Examples...

TextPrefix Property example


DimOrdinate.TextRotation Property

Specifies the rotation angle of the dimension text

Syntax

object.TextRotation

object is a DimOrdinate object.

Description

TextRotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

TextRotation Property example


DimOrdinate.TextStyle Property

Specifies text style of the dimension (DIMTXSTY system variable)

Syntax

object.TextStyle

object is a DimOrdinate object.

Description

TextStyle String; Read-write

Examples...

TextStyle Property example


DimOrdinate.TextSuffix Property

Specifies the text suffix for the dimension (DIMPOST system variable)

Syntax

object.TextSuffix

object is a DimOrdinate object.

Description

TextSuffix String; Read-write

Examples...

TextSuffix Property example


DimOrdinate.ToleranceDisplay Property

Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)

Syntax

object.ToleranceDisplay

object is a DimOrdinate object.

Description

ToleranceDisplay ZcDimToleranceMethod: Read-write
Can be one of the constants listed here:
zcTolNone
zcTolSymmetrical
zcTolDeviation
zcTolLimits
zcTolBasic

Examples...

ToleranceDisplay Property example


DimOrdinate.ToleranceHeightScale Property

Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)

Syntax

object.ToleranceHeightScale

object is a DimOrdinate object.

Description

ToleranceHeightScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ToleranceHeightScale Property example


DimOrdinate.ToleranceJustification Property

Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)

Syntax

object.ToleranceJustification

object is a DimOrdinate object.

Description

ToleranceJustification ZcDimToleranceJustify: Read-write
Can be one of the constants listed here:
zcTolBottom
zcTolMiddle
zcTolTop

Examples...

ToleranceJustification Property example


DimOrdinate.ToleranceLowerLimit Property

Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)

Syntax

object.ToleranceLowerLimit

object is a DimOrdinate object.

Description

ToleranceLowerLimit Double; Read-write

Examples...

ToleranceLowerLimit Property example


DimOrdinate.TolerancePrecision Property

Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)

Syntax

object.TolerancePrecision

object is a DimOrdinate object.

Description

TolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TolerancePrecision Property example


DimOrdinate.ToleranceSuppressLeadingZeros Property

Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressLeadingZeros

object is a DimOrdinate object.

Description

ToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

ToleranceSuppressLeadingZeros Property example


DimOrdinate.ToleranceSuppressTrailingZeros Property

Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressTrailingZeros

object is a DimOrdinate object.

Description

ToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

ToleranceSuppressTrailingZeros Property example


DimOrdinate.ToleranceSuppressZeroFeet Property

Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroFeet

object is a DimOrdinate object.

Description

ToleranceSuppressZeroFeet Boolean; Read-write

Examples...

ToleranceSuppressZeroFeet Property example


DimOrdinate.ToleranceSuppressZeroInches Property

Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroInches

object is a DimOrdinate object.

Description

ToleranceSuppressZeroInches Boolean; Read-write

Examples...

ToleranceSuppressZeroInches Property example


DimOrdinate.ToleranceUpperLimit Property

Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)

Syntax

object.ToleranceUpperLimit

object is a DimOrdinate object.

Description

ToleranceUpperLimit Double; Read-write

Examples...

ToleranceUpperLimit Property example


DimOrdinate.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a DimOrdinate object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


DimOrdinate.UnitsFormat Property

Specifies units format for linear dimensions (DIMLUNIT system variable)

Syntax

object.UnitsFormat

object is a DimOrdinate object.

Description

UnitsFormat ZcDimLUnits: Read-write
Can be one of the constants listed here:
zcDimLScientific
zcDimLDecimal
zcDimLEngineering
zcDimLArchitectural
zcDimLFractional
zcDimLWindowsDesktop

Examples...

UnitsFormat Property example


DimOrdinate.VerticalTextPosition Property

Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)

Syntax

object.VerticalTextPosition

object is a DimOrdinate object.

Description

VerticalTextPosition ZcDimVerticalJustification: Read-write
Can be one of the constants listed here:
zcVertCentered
zcAbove
zcOutside
zcJIS

Examples...

VerticalTextPosition Property example


DimOrdinate.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a DimOrdinate object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


DimOrdinate.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a DimOrdinate object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDimRadial Object Members

DimRadial Object Members

A dimension measuring the radius of a circle or arc.

VBA Class Name

ZcadDimRadial

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
AltRoundDistance | Specifies distance rounding value for alternate units (DIMALTRND system variable)
AltSuppressLeadingZeros | Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroFeet | Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroInches | Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)
AltTextPrefix | Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)
AltTextSuffix | Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)
AltTolerancePrecision | Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)
AltToleranceSuppressLeadingZeros | Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroFeet | Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroInches | Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltUnits | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsFormat | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsPrecision | Specifies decimal place precision for alternate units (DIMALTD system variable)
AltUnitsScale | Specifies scale factor for alternate units (DIMALTF system variable)
Application | Returns the application object.
ArrowheadBlock | Specifies the block of the dimension arrowhead
ArrowheadSize | Specifies size of the dimension arrowhead (DIMASZ system variable)
ArrowheadType | Specifies type of the dimension arrowhead
CenterMarkSize | Specifies size of the center mark on the dimension (DIMCEN system variable)
CenterType | Specifies type of center mark on the dimension (DIMCEN system variable)
Database | Returns the database object.
DecimalSeparator | Specifies the decimal separator for metric dimensions (DIMDSEP system variable)
DimLineSuppress | Sets the suppression of the second dimension line On or Off (DIMSD2)
DimensionLineColor | Specifies color of the dimension lines (DIMCLRD system variable)
DimensionLineWeight | Specifies lineweight for dimension lines (DIMLWD system variable)
Document | Returns the document object.
Fit | Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)
ForceLineInside | Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)
FractionFormat | Sets fraction type (DIMFRAC system variable)
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
LeaderLength | Specifies leader length of the dimension
LinearScaleFactor | Specifies global scale factor for linear dimensions (DIMLFAC system variable)
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Measurement | Specifies dimension measurement value
Normal | Returns and sets the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
PrimaryUnitsPrecision | Specifies precision for primary units dimensions (DIMDEC system variable)
Rotation | Returns and sets the horizontal rotation angle of the dimension
RoundDistance | Specifies distance rounding value (DIMRND system variable)
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)
SuppressLeadingZeros | Determines suppression of leading zeros for dimensions (DIMZIN system variable)
SuppressTrailingZeros | Determines suppression of trailing zeros for dimensions (DIMZIN system variable)
SuppressZeroFeet | Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)
SuppressZeroInches | Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)
TextColor | Specifies the color of the dimension text (DIMCLRT system variable)
TextGap | Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)
TextHeight | Specifies text height of the dimension (DIMTXT system variable)
TextInside | Sets drawing of text between extension lines On or Off (DIMTIX system variable)
TextInsideAlign | Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)
TextMovement | Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)
TextOutsideAlign | Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)
TextOverride | Specifies the text string of the dimension (overrides Measurement string)
TextPosition | Specifies the dimension text position or pick point
TextPrefix | Specifies the text prefix for the dimension (DIMPOST system variable)
TextRotation | Specifies the rotation angle of the dimension text
TextStyle | Specifies text style of the dimension (DIMTXSTY system variable)
TextSuffix | Specifies the text suffix for the dimension (DIMPOST system variable)
ToleranceDisplay | Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)
ToleranceHeightScale | Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)
ToleranceJustification | Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)
ToleranceLowerLimit | Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)
TolerancePrecision | Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)
ToleranceSuppressLeadingZeros | Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressTrailingZeros | Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressZeroFeet | Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)
ToleranceSuppressZeroInches | Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)
ToleranceUpperLimit | Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)
TrueColor | Returns the true color of the object.
UnitsFormat | Specifies units format for linear dimensions (DIMLUNIT system variable)
VerticalTextPosition | Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


DimRadial.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


DimRadial.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


DimRadial.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a DimRadial object.

Return value

Object

Examples...

Copy Method example


DimRadial.Delete Method

Deletes the object.

Syntax

object.Delete

object is a DimRadial object.

Examples...

Delete Method example


DimRadial.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a DimRadial object.

Examples...

Erase Method example


DimRadial.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


DimRadial.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a DimRadial object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


DimRadial.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


DimRadial.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


DimRadial.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


DimRadial.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


DimRadial.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


DimRadial.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


DimRadial.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


DimRadial.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a DimRadial object.


DimRadial.AltRoundDistance Property

Specifies distance rounding value for alternate units (DIMALTRND system variable)

Syntax

object.AltRoundDistance

object is a DimRadial object.

Description

AltRoundDistance Double; Read-write

Examples...

AltRoundDistance Property example


DimRadial.AltSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressLeadingZeros

object is a DimRadial object.

Description

AltSuppressLeadingZeros Boolean; Read-write

Examples...

AltSuppressLeadingZeros Property example


DimRadial.AltSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressTrailingZeros

object is a DimRadial object.

Description

AltSuppressTrailingZeros Boolean; Read-write

Examples...

AltSuppressTrailingZeros Property example


DimRadial.AltSuppressZeroFeet Property

Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroFeet

object is a DimRadial object.

Description

AltSuppressZeroFeet Boolean; Read-write

Examples...

AltSuppressZeroFeet Property example


DimRadial.AltSuppressZeroInches Property

Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroInches

object is a DimRadial object.

Description

AltSuppressZeroInches Boolean; Read-write

Examples...

AltSuppressZeroInches Property example


DimRadial.AltTextPrefix Property

Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextPrefix

object is a DimRadial object.

Description

AltTextPrefix String; Read-write


DimRadial.AltTextSuffix Property

Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextSuffix

object is a DimRadial object.

Description

AltTextSuffix String; Read-write


DimRadial.AltTolerancePrecision Property

Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)

Syntax

object.AltTolerancePrecision

object is a DimRadial object.

Description

AltTolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltTolerancePrecision Property example


DimRadial.AltToleranceSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressLeadingZeros

object is a DimRadial object.

Description

AltToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

AltToleranceSuppressLeadingZeros Property example


DimRadial.AltToleranceSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressTrailingZeros

object is a DimRadial object.

Description

AltToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

AltToleranceSuppressTrailingZeros Property example


DimRadial.AltToleranceSuppressZeroFeet Property

Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroFeet

object is a DimRadial object.

Description

AltToleranceSuppressZeroFeet Boolean; Read-write

Examples...

AltToleranceSuppressZeroFeet Property example


DimRadial.AltToleranceSuppressZeroInches Property

Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroInches

object is a DimRadial object.

Description

AltToleranceSuppressZeroInches Boolean; Read-write

Examples...

AltToleranceSuppressZeroInches Property example


DimRadial.AltUnits Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnits

object is a DimRadial object.

Description

AltUnits Boolean; Read-write

Examples...

AltUnits Property example


DimRadial.AltUnitsFormat Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnitsFormat

object is a DimRadial object.

Description

AltUnitsFormat ZcDimUnits: Read-write
Can be one of the constants listed here:
zcDimScientific
zcDimDecimal
zcDimEngineering
zcDimArchitecturalStacked
zcDimFractionalStacked
zcDimArchitectural
zcDimFractional
zcDimWindowsDesktop

Examples...

AltUnitsFormat Property example


DimRadial.AltUnitsPrecision Property

Specifies decimal place precision for alternate units (DIMALTD system variable)

Syntax

object.AltUnitsPrecision

object is a DimRadial object.

Description

AltUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltUnitsPrecision Property example


DimRadial.AltUnitsScale Property

Specifies scale factor for alternate units (DIMALTF system variable)

Syntax

object.AltUnitsScale

object is a DimRadial object.

Description

AltUnitsScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

AltUnitsScale Property example


DimRadial.Application Property

Returns the application object.

Syntax

object.Application

object is a DimRadial object.

Description

Application Object; Read-only

Examples...

Application Property example


DimRadial.ArrowheadBlock Property

Specifies the block of the dimension arrowhead

Syntax

object.ArrowheadBlock

object is a DimRadial object.

Description

ArrowheadBlock String; Read-write


DimRadial.ArrowheadSize Property

Specifies size of the dimension arrowhead (DIMASZ system variable)

Syntax

object.ArrowheadSize

object is a DimRadial object.

Description

ArrowheadSize Double; Read-write

Examples...

ArrowheadSize Property example


DimRadial.ArrowheadType Property

Specifies type of the dimension arrowhead

Syntax

object.ArrowheadType

object is a DimRadial object.

Description

ArrowheadType ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimRadial.CenterMarkSize Property

Specifies size of the center mark on the dimension (DIMCEN system variable)

Syntax

object.CenterMarkSize

object is a DimRadial object.

Description

CenterMarkSize Double; Read-write

Examples...

CenterMarkSize Property example


DimRadial.CenterType Property

Specifies type of center mark on the dimension (DIMCEN system variable)

Syntax

object.CenterType

object is a DimRadial object.

Description

CenterType ZcDimCenterType: Read-write
Can be one of the constants listed here:
zcCenterMark
zcCenterLine
zcCenterNone

Examples...

CenterType Property example


DimRadial.Database Property

Returns the database object.

Syntax

object.Database

object is a DimRadial object.

Description

Database Database; Read-only


DimRadial.DecimalSeparator Property

Specifies the decimal separator for metric dimensions (DIMDSEP system variable)

Syntax

object.DecimalSeparator

object is a DimRadial object.

Description

DecimalSeparator String; Read-write


DimRadial.DimLineSuppress Property

Sets the suppression of the second dimension line On or Off (DIMSD2)

Syntax

object.DimLineSuppress

object is a DimRadial object.

Description

DimLineSuppress Boolean; Read-write


DimRadial.DimensionLineColor Property

Specifies color of the dimension lines (DIMCLRD system variable)

Syntax

object.DimensionLineColor

object is a DimRadial object.

Description

DimensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimRadial.DimensionLineWeight Property

Specifies lineweight for dimension lines (DIMLWD system variable)

Syntax

object.DimensionLineWeight

object is a DimRadial object.

Description

DimensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimRadial.Document Property

Returns the document object.

Syntax

object.Document

object is a DimRadial object.

Description

Document Object; Read-only


DimRadial.Fit Property

Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)

Syntax

object.Fit

object is a DimRadial object.

Description

Fit ZcDimFit: Read-write
Can be one of the constants listed here:
zcTextAndArrows
zcArrowsOnly
zcTextOnly
zcBestFit


DimRadial.ForceLineInside Property

Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)

Syntax

object.ForceLineInside

object is a DimRadial object.

Description

ForceLineInside Boolean; Read-write


DimRadial.FractionFormat Property

Sets fraction type (DIMFRAC system variable)

Syntax

object.FractionFormat

object is a DimRadial object.

Description

FractionFormat ZcDimFractionType: Read-write
Can be one of the constants listed here:
zcHorizontal
zcDiagonal
zcNotStacked


DimRadial.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a DimRadial object.

Description

Handle String; Read-only


DimRadial.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a DimRadial object.

Description

HasExtensionDictionary Boolean; Read-only


DimRadial.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a DimRadial object.

Description

Hyperlinks Hyperlinks; Read-only


DimRadial.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a DimRadial object.

Description

Layer String; Read-write

Examples...

Layer Property example


DimRadial.LeaderLength Property

Specifies leader length of the dimension

Syntax

object.LeaderLength

object is a DimRadial object.

Description

LeaderLength ; Write-only

Examples...

LeaderLength Property example


DimRadial.LinearScaleFactor Property

Specifies global scale factor for linear dimensions (DIMLFAC system variable)

Syntax

object.LinearScaleFactor

object is a DimRadial object.

Description

LinearScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinearScaleFactor Property example


DimRadial.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a DimRadial object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


DimRadial.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a DimRadial object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


DimRadial.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a DimRadial object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


DimRadial.Measurement Property

Specifies dimension measurement value

Syntax

object.Measurement

object is a DimRadial object.

Description

Measurement Double; Read-only

Examples...

Measurement Property example


DimRadial.Normal Property

Returns and sets the normal direction vector.

Syntax

object.Normal

object is a DimRadial object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


DimRadial.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a DimRadial object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


DimRadial.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a DimRadial object.

Description

ObjectName String; Read-only


DimRadial.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a DimRadial object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


DimRadial.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a DimRadial object.

Description

PlotStyleName String; Read-write


DimRadial.PrimaryUnitsPrecision Property

Specifies precision for primary units dimensions (DIMDEC system variable)

Syntax

object.PrimaryUnitsPrecision

object is a DimRadial object.

Description

PrimaryUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

PrimaryUnitsPrecision Property example


DimRadial.Rotation Property

Returns and sets the horizontal rotation angle of the dimension

Syntax

object.Rotation

object is a DimRadial object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


DimRadial.RoundDistance Property

Specifies distance rounding value (DIMRND system variable)

Syntax

object.RoundDistance

object is a DimRadial object.

Description

RoundDistance Double; Read-write

Examples...

RoundDistance Property example


DimRadial.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a DimRadial object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


DimRadial.StyleName Property

Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)

Syntax

object.StyleName

object is a DimRadial object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


DimRadial.SuppressLeadingZeros Property

Determines suppression of leading zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressLeadingZeros

object is a DimRadial object.

Description

SuppressLeadingZeros Boolean; Read-write

Examples...

SuppressLeadingZeros Property example


DimRadial.SuppressTrailingZeros Property

Determines suppression of trailing zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressTrailingZeros

object is a DimRadial object.

Description

SuppressTrailingZeros Boolean; Read-write

Examples...

SuppressTrailingZeros Property example


DimRadial.SuppressZeroFeet Property

Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroFeet

object is a DimRadial object.

Description

SuppressZeroFeet Boolean; Read-write

Examples...

SuppressZeroFeet Property example


DimRadial.SuppressZeroInches Property

Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroInches

object is a DimRadial object.

Description

SuppressZeroInches Boolean; Read-write

Examples...

SuppressZeroInches Property example


DimRadial.TextColor Property

Specifies the color of the dimension text (DIMCLRT system variable)

Syntax

object.TextColor

object is a DimRadial object.

Description

TextColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

TextColor Property example


DimRadial.TextGap Property

Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)

Syntax

object.TextGap

object is a DimRadial object.

Description

TextGap Double; Read-write

Examples...

TextGap Property example


DimRadial.TextHeight Property

Specifies text height of the dimension (DIMTXT system variable)

Syntax

object.TextHeight

object is a DimRadial object.

Description

TextHeight Double; Read-write

Examples...

TextHeight Property example


DimRadial.TextInside Property

Sets drawing of text between extension lines On or Off (DIMTIX system variable)

Syntax

object.TextInside

object is a DimRadial object.

Description

TextInside Boolean; Read-write

Examples...

TextInside Property example


DimRadial.TextInsideAlign Property

Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInsideAlign

object is a DimRadial object.

Description

TextInsideAlign Boolean; Read-write

Examples...

TextInsideAlign Property example


DimRadial.TextMovement Property

Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)

Syntax

object.TextMovement

object is a DimRadial object.

Description

TextMovement ZcDimTextMovement: Read-write
Can be one of the constants listed here:
zcDimLineWithText
zcMoveTextAddLeader
zcMoveTextNoLeader

Examples...

TextMovement Property example


DimRadial.TextOutsideAlign Property

Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)

Syntax

object.TextOutsideAlign

object is a DimRadial object.

Description

TextOutsideAlign Boolean; Read-write

Examples...

TextOutsideAlign Property example


DimRadial.TextOverride Property

Specifies the text string of the dimension (overrides Measurement string)

Syntax

object.TextOverride

object is a DimRadial object.

Description

TextOverride String; Read-write

Examples...

TextOverride Property example


DimRadial.TextPosition Property

Specifies the dimension text position or pick point

Syntax

object.TextPosition

object is a DimRadial object.

Description

TextPosition Variant; Read-write


DimRadial.TextPrefix Property

Specifies the text prefix for the dimension (DIMPOST system variable)

Syntax

object.TextPrefix

object is a DimRadial object.

Description

TextPrefix String; Read-write

Examples...

TextPrefix Property example


DimRadial.TextRotation Property

Specifies the rotation angle of the dimension text

Syntax

object.TextRotation

object is a DimRadial object.

Description

TextRotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

TextRotation Property example


DimRadial.TextStyle Property

Specifies text style of the dimension (DIMTXSTY system variable)

Syntax

object.TextStyle

object is a DimRadial object.

Description

TextStyle String; Read-write

Examples...

TextStyle Property example


DimRadial.TextSuffix Property

Specifies the text suffix for the dimension (DIMPOST system variable)

Syntax

object.TextSuffix

object is a DimRadial object.

Description

TextSuffix String; Read-write

Examples...

TextSuffix Property example


DimRadial.ToleranceDisplay Property

Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)

Syntax

object.ToleranceDisplay

object is a DimRadial object.

Description

ToleranceDisplay ZcDimToleranceMethod: Read-write
Can be one of the constants listed here:
zcTolNone
zcTolSymmetrical
zcTolDeviation
zcTolLimits
zcTolBasic

Examples...

ToleranceDisplay Property example


DimRadial.ToleranceHeightScale Property

Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)

Syntax

object.ToleranceHeightScale

object is a DimRadial object.

Description

ToleranceHeightScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ToleranceHeightScale Property example


DimRadial.ToleranceJustification Property

Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)

Syntax

object.ToleranceJustification

object is a DimRadial object.

Description

ToleranceJustification ZcDimToleranceJustify: Read-write
Can be one of the constants listed here:
zcTolBottom
zcTolMiddle
zcTolTop

Examples...

ToleranceJustification Property example


DimRadial.ToleranceLowerLimit Property

Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)

Syntax

object.ToleranceLowerLimit

object is a DimRadial object.

Description

ToleranceLowerLimit Double; Read-write

Examples...

ToleranceLowerLimit Property example


DimRadial.TolerancePrecision Property

Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)

Syntax

object.TolerancePrecision

object is a DimRadial object.

Description

TolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TolerancePrecision Property example


DimRadial.ToleranceSuppressLeadingZeros Property

Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressLeadingZeros

object is a DimRadial object.

Description

ToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

ToleranceSuppressLeadingZeros Property example


DimRadial.ToleranceSuppressTrailingZeros Property

Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressTrailingZeros

object is a DimRadial object.

Description

ToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

ToleranceSuppressTrailingZeros Property example


DimRadial.ToleranceSuppressZeroFeet Property

Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroFeet

object is a DimRadial object.

Description

ToleranceSuppressZeroFeet Boolean; Read-write

Examples...

ToleranceSuppressZeroFeet Property example


DimRadial.ToleranceSuppressZeroInches Property

Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroInches

object is a DimRadial object.

Description

ToleranceSuppressZeroInches Boolean; Read-write

Examples...

ToleranceSuppressZeroInches Property example


DimRadial.ToleranceUpperLimit Property

Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)

Syntax

object.ToleranceUpperLimit

object is a DimRadial object.

Description

ToleranceUpperLimit Double; Read-write

Examples...

ToleranceUpperLimit Property example


DimRadial.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a DimRadial object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


DimRadial.UnitsFormat Property

Specifies units format for linear dimensions (DIMLUNIT system variable)

Syntax

object.UnitsFormat

object is a DimRadial object.

Description

UnitsFormat ZcDimLUnits: Read-write
Can be one of the constants listed here:
zcDimLScientific
zcDimLDecimal
zcDimLEngineering
zcDimLArchitectural
zcDimLFractional
zcDimLWindowsDesktop

Examples...

UnitsFormat Property example


DimRadial.VerticalTextPosition Property

Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)

Syntax

object.VerticalTextPosition

object is a DimRadial object.

Description

VerticalTextPosition ZcDimVerticalJustification: Read-write
Can be one of the constants listed here:
zcVertCentered
zcAbove
zcOutside
zcJIS

Examples...

VerticalTextPosition Property example


DimRadial.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a DimRadial object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


DimRadial.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a DimRadial object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDimRadialLarge Object Members

DimRadialLarge Object Members

A dimension measuring a large radius, also known as a jogged radius dimension.

VBA Class Name

ZcadDimRadialLarge

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
AltRoundDistance | Specifies distance rounding value for alternate units (DIMALTRND system variable)
AltSuppressLeadingZeros | Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroFeet | Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroInches | Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)
AltTextPrefix | Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)
AltTextSuffix | Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)
AltTolerancePrecision | Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)
AltToleranceSuppressLeadingZeros | Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroFeet | Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroInches | Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltUnits | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsFormat | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsPrecision | Specifies decimal place precision for alternate units (DIMALTD system variable)
AltUnitsScale | Specifies scale factor for alternate units (DIMALTF system variable)
Application | Returns the application object.
ArrowheadBlock | Specifies the block of the dimension arrowhead
ArrowheadSize | Specifies size of the dimension arrowhead (DIMASZ system variable)
ArrowheadType | Specifies type of the dimension arrowhead
CenterMarkSize | Specifies size of the center mark on the dimension (DIMCEN system variable)
CenterType | Specifies type of center mark on the dimension (DIMCEN system variable)
Database | Returns the database object.
DecimalSeparator | Specifies the decimal separator for metric dimensions (DIMDSEP system variable)
DimLineSuppress | Sets the suppression of the second dimension line On or Off (DIMSD2)
DimensionLineColor | Specifies color of the dimension lines (DIMCLRD system variable)
DimensionLineWeight | Specifies lineweight for dimension lines (DIMLWD system variable)
Document | Returns the document object.
Fit | Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)
ForceLineInside | Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)
FractionFormat | Sets fraction type (DIMFRAC system variable)
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
LinearScaleFactor | Specifies global scale factor for linear dimensions (DIMLFAC system variable)
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Measurement | Specifies dimension measurement value
Normal | Returns and sets the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
PrimaryUnitsPrecision | Specifies precision for primary units dimensions (DIMDEC system variable)
Rotation | Returns and sets the horizontal rotation angle of the dimension
RoundDistance | Specifies distance rounding value (DIMRND system variable)
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)
SuppressLeadingZeros | Determines suppression of leading zeros for dimensions (DIMZIN system variable)
SuppressTrailingZeros | Determines suppression of trailing zeros for dimensions (DIMZIN system variable)
SuppressZeroFeet | Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)
SuppressZeroInches | Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)
TextColor | Specifies the color of the dimension text (DIMCLRT system variable)
TextGap | Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)
TextHeight | Specifies text height of the dimension (DIMTXT system variable)
TextInside | Sets drawing of text between extension lines On or Off (DIMTIX system variable)
TextInsideAlign | Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)
TextMovement | Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)
TextOutsideAlign | Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)
TextOverride | Specifies the text string of the dimension (overrides Measurement string)
TextPosition | Specifies the dimension text position or pick point
TextPrefix | Specifies the text prefix for the dimension (DIMPOST system variable)
TextRotation | Specifies the rotation angle of the dimension text
TextStyle | Specifies text style of the dimension (DIMTXSTY system variable)
TextSuffix | Specifies the text suffix for the dimension (DIMPOST system variable)
ToleranceDisplay | Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)
ToleranceHeightScale | Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)
ToleranceJustification | Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)
ToleranceLowerLimit | Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)
TolerancePrecision | Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)
ToleranceSuppressLeadingZeros | Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressTrailingZeros | Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressZeroFeet | Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)
ToleranceSuppressZeroInches | Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)
ToleranceUpperLimit | Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)
TrueColor | Returns the true color of the object.
UnitsFormat | Specifies units format for linear dimensions (DIMLUNIT system variable)
VerticalTextPosition | Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


DimRadialLarge.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


DimRadialLarge.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


DimRadialLarge.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a DimRadialLarge object.

Return value

Object

Examples...

Copy Method example


DimRadialLarge.Delete Method

Deletes the object.

Syntax

object.Delete

object is a DimRadialLarge object.

Examples...

Delete Method example


DimRadialLarge.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a DimRadialLarge object.

Examples...

Erase Method example


DimRadialLarge.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


DimRadialLarge.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a DimRadialLarge object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


DimRadialLarge.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


DimRadialLarge.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


DimRadialLarge.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


DimRadialLarge.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


DimRadialLarge.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


DimRadialLarge.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


DimRadialLarge.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


DimRadialLarge.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a DimRadialLarge object.


DimRadialLarge.AltRoundDistance Property

Specifies distance rounding value for alternate units (DIMALTRND system variable)

Syntax

object.AltRoundDistance

object is a DimRadialLarge object.

Description

AltRoundDistance Double; Read-write

Examples...

AltRoundDistance Property example


DimRadialLarge.AltSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressLeadingZeros

object is a DimRadialLarge object.

Description

AltSuppressLeadingZeros Boolean; Read-write

Examples...

AltSuppressLeadingZeros Property example


DimRadialLarge.AltSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressTrailingZeros

object is a DimRadialLarge object.

Description

AltSuppressTrailingZeros Boolean; Read-write

Examples...

AltSuppressTrailingZeros Property example


DimRadialLarge.AltSuppressZeroFeet Property

Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroFeet

object is a DimRadialLarge object.

Description

AltSuppressZeroFeet Boolean; Read-write

Examples...

AltSuppressZeroFeet Property example


DimRadialLarge.AltSuppressZeroInches Property

Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroInches

object is a DimRadialLarge object.

Description

AltSuppressZeroInches Boolean; Read-write

Examples...

AltSuppressZeroInches Property example


DimRadialLarge.AltTextPrefix Property

Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextPrefix

object is a DimRadialLarge object.

Description

AltTextPrefix String; Read-write


DimRadialLarge.AltTextSuffix Property

Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextSuffix

object is a DimRadialLarge object.

Description

AltTextSuffix String; Read-write


DimRadialLarge.AltTolerancePrecision Property

Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)

Syntax

object.AltTolerancePrecision

object is a DimRadialLarge object.

Description

AltTolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltTolerancePrecision Property example


DimRadialLarge.AltToleranceSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressLeadingZeros

object is a DimRadialLarge object.

Description

AltToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

AltToleranceSuppressLeadingZeros Property example


DimRadialLarge.AltToleranceSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressTrailingZeros

object is a DimRadialLarge object.

Description

AltToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

AltToleranceSuppressTrailingZeros Property example


DimRadialLarge.AltToleranceSuppressZeroFeet Property

Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroFeet

object is a DimRadialLarge object.

Description

AltToleranceSuppressZeroFeet Boolean; Read-write

Examples...

AltToleranceSuppressZeroFeet Property example


DimRadialLarge.AltToleranceSuppressZeroInches Property

Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroInches

object is a DimRadialLarge object.

Description

AltToleranceSuppressZeroInches Boolean; Read-write

Examples...

AltToleranceSuppressZeroInches Property example


DimRadialLarge.AltUnits Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnits

object is a DimRadialLarge object.

Description

AltUnits Boolean; Read-write

Examples...

AltUnits Property example


DimRadialLarge.AltUnitsFormat Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnitsFormat

object is a DimRadialLarge object.

Description

AltUnitsFormat ZcDimUnits: Read-write
Can be one of the constants listed here:
zcDimScientific
zcDimDecimal
zcDimEngineering
zcDimArchitecturalStacked
zcDimFractionalStacked
zcDimArchitectural
zcDimFractional
zcDimWindowsDesktop

Examples...

AltUnitsFormat Property example


DimRadialLarge.AltUnitsPrecision Property

Specifies decimal place precision for alternate units (DIMALTD system variable)

Syntax

object.AltUnitsPrecision

object is a DimRadialLarge object.

Description

AltUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltUnitsPrecision Property example


DimRadialLarge.AltUnitsScale Property

Specifies scale factor for alternate units (DIMALTF system variable)

Syntax

object.AltUnitsScale

object is a DimRadialLarge object.

Description

AltUnitsScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

AltUnitsScale Property example


DimRadialLarge.Application Property

Returns the application object.

Syntax

object.Application

object is a DimRadialLarge object.

Description

Application Object; Read-only

Examples...

Application Property example


DimRadialLarge.ArrowheadBlock Property

Specifies the block of the dimension arrowhead

Syntax

object.ArrowheadBlock

object is a DimRadialLarge object.

Description

ArrowheadBlock String; Read-write


DimRadialLarge.ArrowheadSize Property

Specifies size of the dimension arrowhead (DIMASZ system variable)

Syntax

object.ArrowheadSize

object is a DimRadialLarge object.

Description

ArrowheadSize Double; Read-write

Examples...

ArrowheadSize Property example


DimRadialLarge.ArrowheadType Property

Specifies type of the dimension arrowhead

Syntax

object.ArrowheadType

object is a DimRadialLarge object.

Description

ArrowheadType ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimRadialLarge.CenterMarkSize Property

Specifies size of the center mark on the dimension (DIMCEN system variable)

Syntax

object.CenterMarkSize

object is a DimRadialLarge object.

Description

CenterMarkSize Double; Read-write

Examples...

CenterMarkSize Property example


DimRadialLarge.CenterType Property

Specifies type of center mark on the dimension (DIMCEN system variable)

Syntax

object.CenterType

object is a DimRadialLarge object.

Description

CenterType ZcDimCenterType: Read-write
Can be one of the constants listed here:
zcCenterMark
zcCenterLine
zcCenterNone

Examples...

CenterType Property example


DimRadialLarge.Database Property

Returns the database object.

Syntax

object.Database

object is a DimRadialLarge object.

Description

Database Database; Read-only


DimRadialLarge.DecimalSeparator Property

Specifies the decimal separator for metric dimensions (DIMDSEP system variable)

Syntax

object.DecimalSeparator

object is a DimRadialLarge object.

Description

DecimalSeparator String; Read-write


DimRadialLarge.DimLineSuppress Property

Sets the suppression of the second dimension line On or Off (DIMSD2)

Syntax

object.DimLineSuppress

object is a DimRadialLarge object.

Description

DimLineSuppress Boolean; Read-write


DimRadialLarge.DimensionLineColor Property

Specifies color of the dimension lines (DIMCLRD system variable)

Syntax

object.DimensionLineColor

object is a DimRadialLarge object.

Description

DimensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimRadialLarge.DimensionLineWeight Property

Specifies lineweight for dimension lines (DIMLWD system variable)

Syntax

object.DimensionLineWeight

object is a DimRadialLarge object.

Description

DimensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimRadialLarge.Document Property

Returns the document object.

Syntax

object.Document

object is a DimRadialLarge object.

Description

Document Object; Read-only


DimRadialLarge.Fit Property

Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)

Syntax

object.Fit

object is a DimRadialLarge object.

Description

Fit ZcDimFit: Read-write
Can be one of the constants listed here:
zcTextAndArrows
zcArrowsOnly
zcTextOnly
zcBestFit


DimRadialLarge.ForceLineInside Property

Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)

Syntax

object.ForceLineInside

object is a DimRadialLarge object.

Description

ForceLineInside Boolean; Read-write


DimRadialLarge.FractionFormat Property

Sets fraction type (DIMFRAC system variable)

Syntax

object.FractionFormat

object is a DimRadialLarge object.

Description

FractionFormat ZcDimFractionType: Read-write
Can be one of the constants listed here:
zcHorizontal
zcDiagonal
zcNotStacked


DimRadialLarge.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a DimRadialLarge object.

Description

Handle String; Read-only


DimRadialLarge.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a DimRadialLarge object.

Description

HasExtensionDictionary Boolean; Read-only


DimRadialLarge.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a DimRadialLarge object.

Description

Hyperlinks Hyperlinks; Read-only


DimRadialLarge.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a DimRadialLarge object.

Description

Layer String; Read-write

Examples...

Layer Property example


DimRadialLarge.LinearScaleFactor Property

Specifies global scale factor for linear dimensions (DIMLFAC system variable)

Syntax

object.LinearScaleFactor

object is a DimRadialLarge object.

Description

LinearScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinearScaleFactor Property example


DimRadialLarge.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a DimRadialLarge object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


DimRadialLarge.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a DimRadialLarge object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


DimRadialLarge.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a DimRadialLarge object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


DimRadialLarge.Measurement Property

Specifies dimension measurement value

Syntax

object.Measurement

object is a DimRadialLarge object.

Description

Measurement Double; Read-only

Examples...

Measurement Property example


DimRadialLarge.Normal Property

Returns and sets the normal direction vector.

Syntax

object.Normal

object is a DimRadialLarge object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


DimRadialLarge.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a DimRadialLarge object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


DimRadialLarge.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a DimRadialLarge object.

Description

ObjectName String; Read-only


DimRadialLarge.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a DimRadialLarge object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


DimRadialLarge.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a DimRadialLarge object.

Description

PlotStyleName String; Read-write


DimRadialLarge.PrimaryUnitsPrecision Property

Specifies precision for primary units dimensions (DIMDEC system variable)

Syntax

object.PrimaryUnitsPrecision

object is a DimRadialLarge object.

Description

PrimaryUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

PrimaryUnitsPrecision Property example


DimRadialLarge.Rotation Property

Returns and sets the horizontal rotation angle of the dimension

Syntax

object.Rotation

object is a DimRadialLarge object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


DimRadialLarge.RoundDistance Property

Specifies distance rounding value (DIMRND system variable)

Syntax

object.RoundDistance

object is a DimRadialLarge object.

Description

RoundDistance Double; Read-write

Examples...

RoundDistance Property example


DimRadialLarge.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a DimRadialLarge object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


DimRadialLarge.StyleName Property

Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)

Syntax

object.StyleName

object is a DimRadialLarge object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


DimRadialLarge.SuppressLeadingZeros Property

Determines suppression of leading zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressLeadingZeros

object is a DimRadialLarge object.

Description

SuppressLeadingZeros Boolean; Read-write

Examples...

SuppressLeadingZeros Property example


DimRadialLarge.SuppressTrailingZeros Property

Determines suppression of trailing zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressTrailingZeros

object is a DimRadialLarge object.

Description

SuppressTrailingZeros Boolean; Read-write

Examples...

SuppressTrailingZeros Property example


DimRadialLarge.SuppressZeroFeet Property

Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroFeet

object is a DimRadialLarge object.

Description

SuppressZeroFeet Boolean; Read-write

Examples...

SuppressZeroFeet Property example


DimRadialLarge.SuppressZeroInches Property

Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroInches

object is a DimRadialLarge object.

Description

SuppressZeroInches Boolean; Read-write

Examples...

SuppressZeroInches Property example


DimRadialLarge.TextColor Property

Specifies the color of the dimension text (DIMCLRT system variable)

Syntax

object.TextColor

object is a DimRadialLarge object.

Description

TextColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

TextColor Property example


DimRadialLarge.TextGap Property

Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)

Syntax

object.TextGap

object is a DimRadialLarge object.

Description

TextGap Double; Read-write

Examples...

TextGap Property example


DimRadialLarge.TextHeight Property

Specifies text height of the dimension (DIMTXT system variable)

Syntax

object.TextHeight

object is a DimRadialLarge object.

Description

TextHeight Double; Read-write

Examples...

TextHeight Property example


DimRadialLarge.TextInside Property

Sets drawing of text between extension lines On or Off (DIMTIX system variable)

Syntax

object.TextInside

object is a DimRadialLarge object.

Description

TextInside Boolean; Read-write

Examples...

TextInside Property example


DimRadialLarge.TextInsideAlign Property

Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInsideAlign

object is a DimRadialLarge object.

Description

TextInsideAlign Boolean; Read-write

Examples...

TextInsideAlign Property example


DimRadialLarge.TextMovement Property

Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)

Syntax

object.TextMovement

object is a DimRadialLarge object.

Description

TextMovement ZcDimTextMovement: Read-write
Can be one of the constants listed here:
zcDimLineWithText
zcMoveTextAddLeader
zcMoveTextNoLeader

Examples...

TextMovement Property example


DimRadialLarge.TextOutsideAlign Property

Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)

Syntax

object.TextOutsideAlign

object is a DimRadialLarge object.

Description

TextOutsideAlign Boolean; Read-write

Examples...

TextOutsideAlign Property example


DimRadialLarge.TextOverride Property

Specifies the text string of the dimension (overrides Measurement string)

Syntax

object.TextOverride

object is a DimRadialLarge object.

Description

TextOverride String; Read-write

Examples...

TextOverride Property example


DimRadialLarge.TextPosition Property

Specifies the dimension text position or pick point

Syntax

object.TextPosition

object is a DimRadialLarge object.

Description

TextPosition Variant; Read-write


DimRadialLarge.TextPrefix Property

Specifies the text prefix for the dimension (DIMPOST system variable)

Syntax

object.TextPrefix

object is a DimRadialLarge object.

Description

TextPrefix String; Read-write

Examples...

TextPrefix Property example


DimRadialLarge.TextRotation Property

Specifies the rotation angle of the dimension text

Syntax

object.TextRotation

object is a DimRadialLarge object.

Description

TextRotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

TextRotation Property example


DimRadialLarge.TextStyle Property

Specifies text style of the dimension (DIMTXSTY system variable)

Syntax

object.TextStyle

object is a DimRadialLarge object.

Description

TextStyle String; Read-write

Examples...

TextStyle Property example


DimRadialLarge.TextSuffix Property

Specifies the text suffix for the dimension (DIMPOST system variable)

Syntax

object.TextSuffix

object is a DimRadialLarge object.

Description

TextSuffix String; Read-write

Examples...

TextSuffix Property example


DimRadialLarge.ToleranceDisplay Property

Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)

Syntax

object.ToleranceDisplay

object is a DimRadialLarge object.

Description

ToleranceDisplay ZcDimToleranceMethod: Read-write
Can be one of the constants listed here:
zcTolNone
zcTolSymmetrical
zcTolDeviation
zcTolLimits
zcTolBasic

Examples...

ToleranceDisplay Property example


DimRadialLarge.ToleranceHeightScale Property

Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)

Syntax

object.ToleranceHeightScale

object is a DimRadialLarge object.

Description

ToleranceHeightScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ToleranceHeightScale Property example


DimRadialLarge.ToleranceJustification Property

Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)

Syntax

object.ToleranceJustification

object is a DimRadialLarge object.

Description

ToleranceJustification ZcDimToleranceJustify: Read-write
Can be one of the constants listed here:
zcTolBottom
zcTolMiddle
zcTolTop

Examples...

ToleranceJustification Property example


DimRadialLarge.ToleranceLowerLimit Property

Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)

Syntax

object.ToleranceLowerLimit

object is a DimRadialLarge object.

Description

ToleranceLowerLimit Double; Read-write

Examples...

ToleranceLowerLimit Property example


DimRadialLarge.TolerancePrecision Property

Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)

Syntax

object.TolerancePrecision

object is a DimRadialLarge object.

Description

TolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TolerancePrecision Property example


DimRadialLarge.ToleranceSuppressLeadingZeros Property

Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressLeadingZeros

object is a DimRadialLarge object.

Description

ToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

ToleranceSuppressLeadingZeros Property example


DimRadialLarge.ToleranceSuppressTrailingZeros Property

Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressTrailingZeros

object is a DimRadialLarge object.

Description

ToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

ToleranceSuppressTrailingZeros Property example


DimRadialLarge.ToleranceSuppressZeroFeet Property

Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroFeet

object is a DimRadialLarge object.

Description

ToleranceSuppressZeroFeet Boolean; Read-write

Examples...

ToleranceSuppressZeroFeet Property example


DimRadialLarge.ToleranceSuppressZeroInches Property

Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroInches

object is a DimRadialLarge object.

Description

ToleranceSuppressZeroInches Boolean; Read-write

Examples...

ToleranceSuppressZeroInches Property example


DimRadialLarge.ToleranceUpperLimit Property

Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)

Syntax

object.ToleranceUpperLimit

object is a DimRadialLarge object.

Description

ToleranceUpperLimit Double; Read-write

Examples...

ToleranceUpperLimit Property example


DimRadialLarge.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a DimRadialLarge object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


DimRadialLarge.UnitsFormat Property

Specifies units format for linear dimensions (DIMLUNIT system variable)

Syntax

object.UnitsFormat

object is a DimRadialLarge object.

Description

UnitsFormat ZcDimLUnits: Read-write
Can be one of the constants listed here:
zcDimLScientific
zcDimLDecimal
zcDimLEngineering
zcDimLArchitectural
zcDimLFractional
zcDimLWindowsDesktop

Examples...

UnitsFormat Property example


DimRadialLarge.VerticalTextPosition Property

Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)

Syntax

object.VerticalTextPosition

object is a DimRadialLarge object.

Description

VerticalTextPosition ZcDimVerticalJustification: Read-write
Can be one of the constants listed here:
zcVertCentered
zcAbove
zcOutside
zcJIS

Examples...

VerticalTextPosition Property example


DimRadialLarge.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a DimRadialLarge object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


DimRadialLarge.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a DimRadialLarge object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDimRotated Object Members

DimRotated Object Members

A dimension that measures the distance between two points and is displayed at a given rotation.

VBA Class Name

ZcadDimRotated

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
AltRoundDistance | Specifies distance rounding value for alternate units (DIMALTRND system variable)
AltSuppressLeadingZeros | Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroFeet | Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)
AltSuppressZeroInches | Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)
AltTextPrefix | Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)
AltTextSuffix | Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)
AltTolerancePrecision | Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)
AltToleranceSuppressLeadingZeros | Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressTrailingZeros | Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroFeet | Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltToleranceSuppressZeroInches | Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)
AltUnits | Specifies units format for alternate units dimensions except angular (DIMALTU system variable)
AltUnitsFormat | Specifies units format for alternate units dimensions except angular (DIMALTU system variable
AltUnitsPrecision | Specifies decimal place precision for alternate units (DIMALTD system variable)
AltUnitsScale | Specifies scale factor for alternate units (DIMALTF system variable)
Application | Returns the application object.
Arrowhead1Block | Specifies the block of the first dimension arrowhead
Arrowhead1Type | Specifies type of the first dimension arrowhead (DIMBLK1 system variable)
Arrowhead2Block | Specifies the block of the second dimension arrowhead
Arrowhead2Type | Specifies type of the second dimension arrowhead (DIMBLK2 system variable)
ArrowheadSize | Specifies size of the dimension arrowhead (DIMASZ system variable)
Database | Returns the database object.
DecimalSeparator | Specifies the decimal separator for metric dimensions (DIMDSEP system variable)
DimLine1Suppress | Sets suppression of first dimension line On or Off (DIMSD1 system variable)
DimLine2Suppress | Sets suppression of second dimension line On or Off (DIMSD2 system variable)
DimLineInside | Sets drawing of dimension lines outside extension lines On or Off (DIMSOXD system variable)
DimensionLineColor | Specifies color of the dimension lines (DIMCLRD system variable)
DimensionLineExtend | Specifies amount to extend dimension lines beyond the extension line (DIMDLE system variable)
DimensionLineWeight | Specifies lineweight for dimension lines (DIMLWD system variable)
Document | Returns the document object.
ExtLine1Suppress | Sets suppression of first extension line On or Off (DIMSE1 system variable)
ExtLine2Suppress | Sets suppression of second extension line On or Off (DIMSE2 system variable)
ExtensionLineColor | Specifies color of the extension line (DIMCLRE system variable)
ExtensionLineExtend | Specifies amount to extend extension line beyond the dimension line (DIMEXE system variable)
ExtensionLineOffset | Specifies offset of extension lines from the origin points (DIMEXO system variable)
ExtensionLineWeight | Specifies lineweight for extension lines (DIMLWE system variable)
Fit | Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)
ForceLineInside | Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)
FractionFormat | Sets fraction type (DIMFRAC system variable)
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
HorizontalTextPosition | Specifies horizontal dimension text position (DIMJUST system variable)
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
LinearScaleFactor | Specifies global scale factor for linear dimensions (DIMLFAC system variable)
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Measurement | Specifies dimension measurement value
Normal | Returns and sets the normal direction vector.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
PrimaryUnitsPrecision | Specifies precision for primary units dimensions (DIMDEC system variable)
Rotation | Returns and sets the horizontal rotation angle of the dimension
RoundDistance | Specifies distance rounding value (DIMRND system variable)
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)
SuppressLeadingZeros | Determines suppression of leading zeros for dimensions (DIMZIN system variable)
SuppressTrailingZeros | Determines suppression of trailing zeros for dimensions (DIMZIN system variable)
SuppressZeroFeet | Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)
SuppressZeroInches | Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)
TextColor | Specifies the color of the dimension text (DIMCLRT system variable)
TextGap | Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)
TextHeight | Specifies text height of the dimension (DIMTXT system variable)
TextInside | Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)
TextInsideAlign | Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)
TextMovement | Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)
TextOutsideAlign | Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)
TextOverride | Specifies the text string of the dimension (overrides Measurement string)
TextPosition | Specifies the dimension text position or pick point
TextPrefix | Specifies the text prefix for the dimension (DIMPOST system variable)
TextRotation | Specifies the rotation angle of the dimension text
TextStyle | Specifies text style of the dimension (DIMTXSTY system variable)
TextSuffix | Specifies the text suffix for the dimension (DIMPOST system variable)
ToleranceDisplay | Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)
ToleranceHeightScale | Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)
ToleranceJustification | Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)
ToleranceLowerLimit | Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)
TolerancePrecision | Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)
ToleranceSuppressLeadingZeros | Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressTrailingZeros | Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)
ToleranceSuppressZeroFeet | Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)
ToleranceSuppressZeroInches | Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)
ToleranceUpperLimit | Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)
TrueColor | Returns the true color of the object.
UnitsFormat | Specifies units format for linear dimensions (DIMLUNIT system variable)
VerticalTextPosition | Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


DimRotated.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


DimRotated.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


DimRotated.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a DimRotated object.

Return value

Object

Examples...

Copy Method example


DimRotated.Delete Method

Deletes the object.

Syntax

object.Delete

object is a DimRotated object.

Examples...

Delete Method example


DimRotated.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a DimRotated object.

Examples...

Erase Method example


DimRotated.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


DimRotated.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a DimRotated object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


DimRotated.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


DimRotated.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


DimRotated.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


DimRotated.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


DimRotated.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


DimRotated.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


DimRotated.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


DimRotated.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a DimRotated object.


DimRotated.AltRoundDistance Property

Specifies distance rounding value for alternate units (DIMALTRND system variable)

Syntax

object.AltRoundDistance

object is a DimRotated object.

Description

AltRoundDistance Double; Read-write

Examples...

AltRoundDistance Property example


DimRotated.AltSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressLeadingZeros

object is a DimRotated object.

Description

AltSuppressLeadingZeros Boolean; Read-write

Examples...

AltSuppressLeadingZeros Property example


DimRotated.AltSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressTrailingZeros

object is a DimRotated object.

Description

AltSuppressTrailingZeros Boolean; Read-write

Examples...

AltSuppressTrailingZeros Property example


DimRotated.AltSuppressZeroFeet Property

Sets suppression of zero feet for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroFeet

object is a DimRotated object.

Description

AltSuppressZeroFeet Boolean; Read-write

Examples...

AltSuppressZeroFeet Property example


DimRotated.AltSuppressZeroInches Property

Sets suppression of zero inches for alternate units dimensions On or Off (DIMALTZ system variable)

Syntax

object.AltSuppressZeroInches

object is a DimRotated object.

Description

AltSuppressZeroInches Boolean; Read-write

Examples...

AltSuppressZeroInches Property example


DimRotated.AltTextPrefix Property

Specifies text prefix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextPrefix

object is a DimRotated object.

Description

AltTextPrefix String; Read-write


DimRotated.AltTextSuffix Property

Specifies text sufffix to alternate dimensions except angular (DIMAPOST system variable)

Syntax

object.AltTextSuffix

object is a DimRotated object.

Description

AltTextSuffix String; Read-write


DimRotated.AltTolerancePrecision Property

Specifies number of decimal places for tolerance values of an alternate units dimension (DIMTDEC system variable)

Syntax

object.AltTolerancePrecision

object is a DimRotated object.

Description

AltTolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltTolerancePrecision Property example


DimRotated.AltToleranceSuppressLeadingZeros Property

Sets suppression of leading zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressLeadingZeros

object is a DimRotated object.

Description

AltToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

AltToleranceSuppressLeadingZeros Property example


DimRotated.AltToleranceSuppressTrailingZeros Property

Sets suppression of trailing zeros for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressTrailingZeros

object is a DimRotated object.

Description

AltToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

AltToleranceSuppressTrailingZeros Property example


DimRotated.AltToleranceSuppressZeroFeet Property

Sets suppression of zero feet for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroFeet

object is a DimRotated object.

Description

AltToleranceSuppressZeroFeet Boolean; Read-write

Examples...

AltToleranceSuppressZeroFeet Property example


DimRotated.AltToleranceSuppressZeroInches Property

Sets suppression of zero inches for alternate units tolerance values On or Off (DIMALTTZ system variable)

Syntax

object.AltToleranceSuppressZeroInches

object is a DimRotated object.

Description

AltToleranceSuppressZeroInches Boolean; Read-write

Examples...

AltToleranceSuppressZeroInches Property example


DimRotated.AltUnits Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable)

Syntax

object.AltUnits

object is a DimRotated object.

Description

AltUnits Boolean; Read-write

Examples...

AltUnits Property example


DimRotated.AltUnitsFormat Property

Specifies units format for alternate units dimensions except angular (DIMALTU system variable

Syntax

object.AltUnitsFormat

object is a DimRotated object.

Description

AltUnitsFormat ZcDimUnits: Read-write
Can be one of the constants listed here:
zcDimScientific
zcDimDecimal
zcDimEngineering
zcDimArchitecturalStacked
zcDimFractionalStacked
zcDimArchitectural
zcDimFractional
zcDimWindowsDesktop

Examples...

AltUnitsFormat Property example


DimRotated.AltUnitsPrecision Property

Specifies decimal place precision for alternate units (DIMALTD system variable)

Syntax

object.AltUnitsPrecision

object is a DimRotated object.

Description

AltUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

AltUnitsPrecision Property example


DimRotated.AltUnitsScale Property

Specifies scale factor for alternate units (DIMALTF system variable)

Syntax

object.AltUnitsScale

object is a DimRotated object.

Description

AltUnitsScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

AltUnitsScale Property example


DimRotated.Application Property

Returns the application object.

Syntax

object.Application

object is a DimRotated object.

Description

Application Object; Read-only

Examples...

Application Property example


DimRotated.Arrowhead1Block Property

Specifies the block of the first dimension arrowhead

Syntax

object.Arrowhead1Block

object is a DimRotated object.

Description

Arrowhead1Block String; Read-write


DimRotated.Arrowhead1Type Property

Specifies type of the first dimension arrowhead (DIMBLK1 system variable)

Syntax

object.Arrowhead1Type

object is a DimRotated object.

Description

Arrowhead1Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimRotated.Arrowhead2Block Property

Specifies the block of the second dimension arrowhead

Syntax

object.Arrowhead2Block

object is a DimRotated object.

Description

Arrowhead2Block String; Read-write


DimRotated.Arrowhead2Type Property

Specifies type of the second dimension arrowhead (DIMBLK2 system variable)

Syntax

object.Arrowhead2Type

object is a DimRotated object.

Description

Arrowhead2Type ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


DimRotated.ArrowheadSize Property

Specifies size of the dimension arrowhead (DIMASZ system variable)

Syntax

object.ArrowheadSize

object is a DimRotated object.

Description

ArrowheadSize Double; Read-write

Examples...

ArrowheadSize Property example


DimRotated.Database Property

Returns the database object.

Syntax

object.Database

object is a DimRotated object.

Description

Database Database; Read-only


DimRotated.DecimalSeparator Property

Specifies the decimal separator for metric dimensions (DIMDSEP system variable)

Syntax

object.DecimalSeparator

object is a DimRotated object.

Description

DecimalSeparator String; Read-write


DimRotated.DimLine1Suppress Property

Sets suppression of first dimension line On or Off (DIMSD1 system variable)

Syntax

object.DimLine1Suppress

object is a DimRotated object.

Description

DimLine1Suppress Boolean; Read-write


DimRotated.DimLine2Suppress Property

Sets suppression of second dimension line On or Off (DIMSD2 system variable)

Syntax

object.DimLine2Suppress

object is a DimRotated object.

Description

DimLine2Suppress Boolean; Read-write


DimRotated.DimLineInside Property

Sets drawing of dimension lines outside extension lines On or Off (DIMSOXD system variable)

Syntax

object.DimLineInside

object is a DimRotated object.

Description

DimLineInside Boolean; Read-write


DimRotated.DimensionLineColor Property

Specifies color of the dimension lines (DIMCLRD system variable)

Syntax

object.DimensionLineColor

object is a DimRotated object.

Description

DimensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimRotated.DimensionLineExtend Property

Specifies amount to extend dimension lines beyond the extension line (DIMDLE system variable)

Syntax

object.DimensionLineExtend

object is a DimRotated object.

Description

DimensionLineExtend Double; Read-write


DimRotated.DimensionLineWeight Property

Specifies lineweight for dimension lines (DIMLWD system variable)

Syntax

object.DimensionLineWeight

object is a DimRotated object.

Description

DimensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimRotated.Document Property

Returns the document object.

Syntax

object.Document

object is a DimRotated object.

Description

Document Object; Read-only


DimRotated.ExtLine1Suppress Property

Sets suppression of first extension line On or Off (DIMSE1 system variable)

Syntax

object.ExtLine1Suppress

object is a DimRotated object.

Description

ExtLine1Suppress Boolean; Read-write


DimRotated.ExtLine2Suppress Property

Sets suppression of second extension line On or Off (DIMSE2 system variable)

Syntax

object.ExtLine2Suppress

object is a DimRotated object.

Description

ExtLine2Suppress Boolean; Read-write


DimRotated.ExtensionLineColor Property

Specifies color of the extension line (DIMCLRE system variable)

Syntax

object.ExtensionLineColor

object is a DimRotated object.

Description

ExtensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


DimRotated.ExtensionLineExtend Property

Specifies amount to extend extension line beyond the dimension line (DIMEXE system variable)

Syntax

object.ExtensionLineExtend

object is a DimRotated object.

Description

ExtensionLineExtend Double; Read-write


DimRotated.ExtensionLineOffset Property

Specifies offset of extension lines from the origin points (DIMEXO system variable)

Syntax

object.ExtensionLineOffset

object is a DimRotated object.

Description

ExtensionLineOffset Double; Read-write


DimRotated.ExtensionLineWeight Property

Specifies lineweight for extension lines (DIMLWE system variable)

Syntax

object.ExtensionLineWeight

object is a DimRotated object.

Description

ExtensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


DimRotated.Fit Property

Determines what elements are moved to fit text and arrowheads in space between extension lines (DIMFIT2 system variable)

Syntax

object.Fit

object is a DimRotated object.

Description

Fit ZcDimFit: Read-write
Can be one of the constants listed here:
zcTextAndArrows
zcArrowsOnly
zcTextOnly
zcBestFit


DimRotated.ForceLineInside Property

Forces drawing dimension line between extension lines even when text is placed outside extension lines (DIMTOFL system variable)

Syntax

object.ForceLineInside

object is a DimRotated object.

Description

ForceLineInside Boolean; Read-write


DimRotated.FractionFormat Property

Sets fraction type (DIMFRAC system variable)

Syntax

object.FractionFormat

object is a DimRotated object.

Description

FractionFormat ZcDimFractionType: Read-write
Can be one of the constants listed here:
zcHorizontal
zcDiagonal
zcNotStacked


DimRotated.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a DimRotated object.

Description

Handle String; Read-only


DimRotated.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a DimRotated object.

Description

HasExtensionDictionary Boolean; Read-only


DimRotated.HorizontalTextPosition Property

Specifies horizontal dimension text position (DIMJUST system variable)

Syntax

object.HorizontalTextPosition

object is a DimRotated object.

Description

HorizontalTextPosition ZcDimHorizontalJustification: Read-write
Can be one of the constants listed here:
zcHorzCentered
zcFirstExtensionLine
zcSecondExtensionLine
zcOverFirstExtension
zcOverSecondExtension


DimRotated.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a DimRotated object.

Description

Hyperlinks Hyperlinks; Read-only


DimRotated.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a DimRotated object.

Description

Layer String; Read-write

Examples...

Layer Property example


DimRotated.LinearScaleFactor Property

Specifies global scale factor for linear dimensions (DIMLFAC system variable)

Syntax

object.LinearScaleFactor

object is a DimRotated object.

Description

LinearScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinearScaleFactor Property example


DimRotated.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a DimRotated object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


DimRotated.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a DimRotated object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


DimRotated.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a DimRotated object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


DimRotated.Measurement Property

Specifies dimension measurement value

Syntax

object.Measurement

object is a DimRotated object.

Description

Measurement Double; Read-only

Examples...

Measurement Property example


DimRotated.Normal Property

Returns and sets the normal direction vector.

Syntax

object.Normal

object is a DimRotated object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


DimRotated.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a DimRotated object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


DimRotated.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a DimRotated object.

Description

ObjectName String; Read-only


DimRotated.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a DimRotated object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


DimRotated.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a DimRotated object.

Description

PlotStyleName String; Read-write


DimRotated.PrimaryUnitsPrecision Property

Specifies precision for primary units dimensions (DIMDEC system variable)

Syntax

object.PrimaryUnitsPrecision

object is a DimRotated object.

Description

PrimaryUnitsPrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

PrimaryUnitsPrecision Property example


DimRotated.Rotation Property

Returns and sets the horizontal rotation angle of the dimension

Syntax

object.Rotation

object is a DimRotated object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


DimRotated.RoundDistance Property

Specifies distance rounding value (DIMRND system variable)

Syntax

object.RoundDistance

object is a DimRotated object.

Description

RoundDistance Double; Read-write

Examples...

RoundDistance Property example


DimRotated.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a DimRotated object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


DimRotated.StyleName Property

Specifies the current dimension style by name (for DIMSTYLE system variable use SETVAR)

Syntax

object.StyleName

object is a DimRotated object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


DimRotated.SuppressLeadingZeros Property

Determines suppression of leading zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressLeadingZeros

object is a DimRotated object.

Description

SuppressLeadingZeros Boolean; Read-write

Examples...

SuppressLeadingZeros Property example


DimRotated.SuppressTrailingZeros Property

Determines suppression of trailing zeros for dimensions (DIMZIN system variable)

Syntax

object.SuppressTrailingZeros

object is a DimRotated object.

Description

SuppressTrailingZeros Boolean; Read-write

Examples...

SuppressTrailingZeros Property example


DimRotated.SuppressZeroFeet Property

Sets suppression of zero feet for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroFeet

object is a DimRotated object.

Description

SuppressZeroFeet Boolean; Read-write

Examples...

SuppressZeroFeet Property example


DimRotated.SuppressZeroInches Property

Sets suppression of zero inches for dimensions On or Off (DIMZIN system variable)

Syntax

object.SuppressZeroInches

object is a DimRotated object.

Description

SuppressZeroInches Boolean; Read-write

Examples...

SuppressZeroInches Property example


DimRotated.TextColor Property

Specifies the color of the dimension text (DIMCLRT system variable)

Syntax

object.TextColor

object is a DimRotated object.

Description

TextColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

TextColor Property example


DimRotated.TextGap Property

Specifies distance around dimension text when dimension line breaks for dimension text (DIMGAP system variable)

Syntax

object.TextGap

object is a DimRotated object.

Description

TextGap Double; Read-write

Examples...

TextGap Property example


DimRotated.TextHeight Property

Specifies text height of the dimension (DIMTXT system variable)

Syntax

object.TextHeight

object is a DimRotated object.

Description

TextHeight Double; Read-write

Examples...

TextHeight Property example


DimRotated.TextInside Property

Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInside

object is a DimRotated object.

Description

TextInside Boolean; Read-write

Examples...

TextInside Property example


DimRotated.TextInsideAlign Property

Sets position of dimension text inside extension lines On or Off (DIMTIH system variable)

Syntax

object.TextInsideAlign

object is a DimRotated object.

Description

TextInsideAlign Boolean; Read-write

Examples...

TextInsideAlign Property example


DimRotated.TextMovement Property

Specifies position of text when it's moved, either manually or automatically (DIMTMOVE system variable)

Syntax

object.TextMovement

object is a DimRotated object.

Description

TextMovement ZcDimTextMovement: Read-write
Can be one of the constants listed here:
zcDimLineWithText
zcMoveTextAddLeader
zcMoveTextNoLeader

Examples...

TextMovement Property example


DimRotated.TextOutsideAlign Property

Sets positioning of dimension text outside extension lines On or Off (DIMTOH system variable)

Syntax

object.TextOutsideAlign

object is a DimRotated object.

Description

TextOutsideAlign Boolean; Read-write

Examples...

TextOutsideAlign Property example


DimRotated.TextOverride Property

Specifies the text string of the dimension (overrides Measurement string)

Syntax

object.TextOverride

object is a DimRotated object.

Description

TextOverride String; Read-write

Examples...

TextOverride Property example


DimRotated.TextPosition Property

Specifies the dimension text position or pick point

Syntax

object.TextPosition

object is a DimRotated object.

Description

TextPosition Variant; Read-write


DimRotated.TextPrefix Property

Specifies the text prefix for the dimension (DIMPOST system variable)

Syntax

object.TextPrefix

object is a DimRotated object.

Description

TextPrefix String; Read-write

Examples...

TextPrefix Property example


DimRotated.TextRotation Property

Specifies the rotation angle of the dimension text

Syntax

object.TextRotation

object is a DimRotated object.

Description

TextRotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

TextRotation Property example


DimRotated.TextStyle Property

Specifies text style of the dimension (DIMTXSTY system variable)

Syntax

object.TextStyle

object is a DimRotated object.

Description

TextStyle String; Read-write

Examples...

TextStyle Property example


DimRotated.TextSuffix Property

Specifies the text suffix for the dimension (DIMPOST system variable)

Syntax

object.TextSuffix

object is a DimRotated object.

Description

TextSuffix String; Read-write

Examples...

TextSuffix Property example


DimRotated.ToleranceDisplay Property

Specifies display mode of dimension tolerances to dimension text (DIMTOL system variable)

Syntax

object.ToleranceDisplay

object is a DimRotated object.

Description

ToleranceDisplay ZcDimToleranceMethod: Read-write
Can be one of the constants listed here:
zcTolNone
zcTolSymmetrical
zcTolDeviation
zcTolLimits
zcTolBasic

Examples...

ToleranceDisplay Property example


DimRotated.ToleranceHeightScale Property

Specifies scale factor for text height of tolerance values relative to dimension text height as set by DIMTXT (DIMTFAC system variable)

Syntax

object.ToleranceHeightScale

object is a DimRotated object.

Description

ToleranceHeightScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ToleranceHeightScale Property example


DimRotated.ToleranceJustification Property

Specifies vertical justification for tolerance values relative to nominal dimension text (DIMTOLJ system variable)

Syntax

object.ToleranceJustification

object is a DimRotated object.

Description

ToleranceJustification ZcDimToleranceJustify: Read-write
Can be one of the constants listed here:
zcTolBottom
zcTolMiddle
zcTolTop

Examples...

ToleranceJustification Property example


DimRotated.ToleranceLowerLimit Property

Specifies minimum (or lower) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTM system variable)

Syntax

object.ToleranceLowerLimit

object is a DimRotated object.

Description

ToleranceLowerLimit Double; Read-write

Examples...

ToleranceLowerLimit Property example


DimRotated.TolerancePrecision Property

Specifies number of decimal places for tolerance values of a dimension (DIMTDEC system variable)

Syntax

object.TolerancePrecision

object is a DimRotated object.

Description

TolerancePrecision ZcDimPrecision: Read-write
Can be one of the constants listed here:
zcDimPrecisionZero
zcDimPrecisionOne
zcDimPrecisionTwo
zcDimPrecisionThree
zcDimPrecisionFour
zcDimPrecisionFive
zcDimPrecisionSix
zcDimPrecisionSeven
zcDimPrecisionEight

Examples...

TolerancePrecision Property example


DimRotated.ToleranceSuppressLeadingZeros Property

Determines suppression of leading zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressLeadingZeros

object is a DimRotated object.

Description

ToleranceSuppressLeadingZeros Boolean; Read-write

Examples...

ToleranceSuppressLeadingZeros Property example


DimRotated.ToleranceSuppressTrailingZeros Property

Determines suppression of trailing zeros for tolerance values (DIMTZIN system variable)

Syntax

object.ToleranceSuppressTrailingZeros

object is a DimRotated object.

Description

ToleranceSuppressTrailingZeros Boolean; Read-write

Examples...

ToleranceSuppressTrailingZeros Property example


DimRotated.ToleranceSuppressZeroFeet Property

Sets suppression of zero feet for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroFeet

object is a DimRotated object.

Description

ToleranceSuppressZeroFeet Boolean; Read-write

Examples...

ToleranceSuppressZeroFeet Property example


DimRotated.ToleranceSuppressZeroInches Property

Sets suppression of zero inches for tolerance values On or Off (DIMTZIN system variable)

Syntax

object.ToleranceSuppressZeroInches

object is a DimRotated object.

Description

ToleranceSuppressZeroInches Boolean; Read-write

Examples...

ToleranceSuppressZeroInches Property example


DimRotated.ToleranceUpperLimit Property

Specifies the maximum (or upper) tolerance limit for dimension text when DIMTOL or DIMLIM is on (DIMTP system variable)

Syntax

object.ToleranceUpperLimit

object is a DimRotated object.

Description

ToleranceUpperLimit Double; Read-write

Examples...

ToleranceUpperLimit Property example


DimRotated.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a DimRotated object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


DimRotated.UnitsFormat Property

Specifies units format for linear dimensions (DIMLUNIT system variable)

Syntax

object.UnitsFormat

object is a DimRotated object.

Description

UnitsFormat ZcDimLUnits: Read-write
Can be one of the constants listed here:
zcDimLScientific
zcDimLDecimal
zcDimLEngineering
zcDimLArchitectural
zcDimLFractional
zcDimLWindowsDesktop

Examples...

UnitsFormat Property example


DimRotated.VerticalTextPosition Property

Specifies the vertical dimension text position relative to dimension line (DIMTAD system variable)

Syntax

object.VerticalTextPosition

object is a DimRotated object.

Description

VerticalTextPosition ZcDimVerticalJustification: Read-write
Can be one of the constants listed here:
zcVertCentered
zcAbove
zcOutside
zcJIS

Examples...

VerticalTextPosition Property example


DimRotated.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a DimRotated object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


DimRotated.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a DimRotated object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDimStyle Object Members

DimStyle Object Members

A group of dimension settings that determines the appearance of a dimension.

VBA Class Name

ZcadDimStyle

Methods

Name | Description
CopyFrom | Copies the dimension style data from a source object
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Name | Returns and sets the name of the dimstyle.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


DimStyle.CopyFrom Method

Copies the dimension style data from a source object

Syntax

object.CopyFrom(StyleSource)

object is a DimStyle object.

Parameters

Name | Options | Data Type | Description
StyleSource | Input-only | Object | -

Examples...

CopyFrom Method example


DimStyle.Delete Method

Deletes the object.

Syntax

object.Delete

object is a DimStyle object.

Examples...

Delete Method example


DimStyle.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a DimStyle object.

Examples...

Erase Method example


DimStyle.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a DimStyle object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


DimStyle.Application Property

Returns the application object.

Syntax

object.Application

object is a DimStyle object.

Description

Application Object; Read-only

Examples...

Application Property example


DimStyle.Database Property

Returns the database object.

Syntax

object.Database

object is a DimStyle object.

Description

Database Database; Read-only


DimStyle.Document Property

Returns the document object.

Syntax

object.Document

object is a DimStyle object.

Description

Document Object; Read-only


DimStyle.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a DimStyle object.

Description

Handle String; Read-only


DimStyle.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a DimStyle object.

Description

HasExtensionDictionary Boolean; Read-only


DimStyle.Name Property

Returns and sets the name of the dimstyle.

Syntax

object.Name

object is a DimStyle object.

Description

Name String; Read-write

Examples...

Name Property example


DimStyle.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a DimStyle object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


DimStyle.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a DimStyle object.

Description

ObjectName String; Read-only


DimStyle.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a DimStyle object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


DimStyle.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a DimStyle object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDimStyles Object Members

DimStyles Object Members

The collection of all dimension styles in the drawing.

VBA Class Name

ZcadDimStyles

Methods

Name | Description
Add | Adds a dimension style to the dimension styles collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


DimStyles.Add Method

Adds a dimension style to the dimension styles collection.

Syntax

object.Add(Name)

object is a DimStyles object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

DimStyle

Examples...

Add Method example


DimStyles.Delete Method

Deletes the object.

Syntax

object.Delete

object is a DimStyles object.

Examples...

Delete Method example


DimStyles.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a DimStyles object.

Examples...

Erase Method example


DimStyles.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a DimStyles object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


DimStyles.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a DimStyles object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

DimStyle

Examples...

Item Method example


DimStyles.Application Property

Returns the application object.

Syntax

object.Application

object is a DimStyles object.

Description

Application Object; Read-only

Examples...

Application Property example


DimStyles.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a DimStyles object.

Description

Count Long; Read-only

Examples...

Count Property example


DimStyles.Database Property

Returns the database object.

Syntax

object.Database

object is a DimStyles object.

Description

Database Database; Read-only


DimStyles.Document Property

Returns the document object.

Syntax

object.Document

object is a DimStyles object.

Description

Document Object; Read-only


DimStyles.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a DimStyles object.

Description

Handle String; Read-only


DimStyles.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a DimStyles object.

Description

HasExtensionDictionary Boolean; Read-only


DimStyles.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a DimStyles object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


DimStyles.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a DimStyles object.

Description

ObjectName String; Read-only


DimStyles.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a DimStyles object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


DimStyles.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a DimStyles object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadDocument Object Members

Document Object Members

An ZWCAD drawing.

VBA Class Name

ZcadDocument

Methods

Name | Description
Activate | Make document the active document.
AuditInfo | Evaluates the integrity of the drawing
Close | Close the drawing.
CopyObjects | Copies multiple objects in the database.
EndUndoMark | Ends the undo mark to where being mark was set.
Export | Exports the file in a different format (DXF, SAT, etc.).
GetVariable | Returns the current setting of a variable.
HandleToObject | Return an object given a handle. Applies to current dwg
Import | Imports a different format file (DXF, SAT, etc.)into ZWCAD.
LoadShapeFile | Loads the given shape file.
New | Starts a new drawing.
Open | Opens a drawing file.
PurgeAll | Removes all unused named references from the database.
Regen | Regen all viewports or active viewport
Save | Saves changes to the active drawing file.
SaveAs | Saves changes to a user specified file.
SendCommand | Sends a command string to the document.
SetVariable | Sets value to a current variable.
StartUndoMark | Starts the undo mark for subsequent automation calls.

Properties

Name | Description
Active | Is Active document or not.
ActiveDimStyle | Returns and sets the active dimstyle object.
ActiveLayer | Returns and sets the active layer object.
ActiveLayout | Returns and sets the active layout object.
ActiveLinetype | Returns and sets the active linetype object.
ActivePViewport | Returns and sets the active paperspace viewport object.
ActiveSelectionSet | Returns the active selection set object.
ActiveSpace | Like tile mode returns and sets the active space (1or0).
ActiveTextStyle | Returns and sets the active text style object.
ActiveUCS | Returns and sets the active user coordinates systems object.
ActiveViewport | Returns and sets the active viewport object.
Application | Returns the application object.
Blocks | Returns the blocks collection object.
Database | Returns the database object.
Dictionaries | Returns the dictionaries collection.
DimStyles | Returns the dimstyles collection.
ElevationModelSpace | Returns and sets the model space elevation.
ElevationPaperSpace | Returns and sets the paper space elevation.
FullName | Returns the full drawing file name.
Groups | Returns the groups collection.
HWND | Returns the HWND of the document window frame.
Height | Height of document.
Layers | Returns the layers collection.
Layouts | Returns the layouts collection.
Limits | Returns and sets the limits of the drawing boundary.
Linetypes | Returns the linetypes collection.
MSpace | Set mspace or pspace in a Layout
ModelSpace | Returns the model space block.
Name | Returns the name of the document, excluding the path.
ObjectSnapMode | Toggles to turn on or off the specified object snap mode.
PaperSpace | Returns the paper space block.
Path | Returns the path of the document, excluding the filename.
PickfirstSelectionSet | Returns the pickfirst selection set object.
Plot | Returns the plot object.
PlotConfigurations | Returns the plot configurations collection.
Preferences | Returns the database preferences object.
ReadOnly | Returns true if the file is read-only and false otherwise.
RegisteredApplications | Returns the registered applications collection.
Saved | Returns true if the document has unsaved changes.
SelectionSets | Returns the selection sets collection.
SummaryInfo | Returns the summary info object.
TextStyles | Returns the text styles collection.
Utility | Returns the utility object.
Viewports | Returns the viewports collection.
Views | Returns the views collection.
Width | Width of document.
WindowState | Current state of the document window.
WindowTitle | Returns the title of the document window.

Events

Name | Description
Activate | Happens when the drawing window is activated.
BeginClose | Happens just before a drawing is closed.
BeginCommand | Happens immediately before a command is issued.
BeginDocClose | Happens just before a drawing is closed.
BeginDoubleClick | Happens immediatly before the default double click action.
BeginPlot | Happens just before the drawing is plotted.
BeginRightClick | Happens immediatly before the default right click action.
BeginSave | Happens immediately before Zwcad saves the drawing.
BeginShortcutMenuCommand | Happens immediatly before the shortcut menu appears in command mode.
BeginShortcutMenuDefault | Happens immediatly before the shortcut menu appears in default mode.
BeginShortcutMenuEdit | Happens immediatly before the shortcut menu appears in edit mode.
BeginShortcutMenuGrip | Happens immediatly before the shortcut menu appears in grip mode.
Deactivate | Happens when the drawing window is deactivated.
EndCommand | Happens immediately after a command is issued.
EndPlot | Happens just after the drawing is plotted.
EndSave | Happens immediately after Zwcad saved the drawing.
EndShortcutMenu | Happens immediatly after the shortcut menu appears.
LayoutSwitched | Happens when the current layout space changes.
ObjectAdded | Happens when an object is added to the drawing.
ObjectErased | Happens when an object is erased from the drawing.
ObjectModified | Happens when an object is modified in the drawing.
SelectionChanged | Happens when the pickfirst selection set changes.
WindowChanged | Happens when the drawing window state changes.
WindowMovedOrResized | Happens when the drawing window is moved or resized.


Document.Activate Method

Make document the active document.

Syntax

object.Activate

object is a Document object.

Examples...

Activate Method example


Document.AuditInfo Method

Evaluates the integrity of the drawing

Syntax

object.AuditInfo(FixErr)

object is a Document object.

Parameters

Name | Options | Data Type | Description
FixErr | Input-only | Boolean | -


Document.Close Method

Close the drawing.

Syntax

object.Close(SaveChanges, FileName)

object is a Document object.

Parameters

Name | Options | Data Type | Description
SaveChanges | Input-only, Optional | Variant | -
FileName | Input-only, Optional | Variant | -

Examples...

Close Method example


Document.CopyObjects Method

Copies multiple objects in the database.

Syntax

object.CopyObjects(Objects, Owner, IdPairs)

object is a Document object.

Parameters

Name | Options | Data Type | Description
Objects | Input-only | Variant | -
Owner | Input-only, Optional | Variant | -
IdPairs | Input-output, Optional | Variant | -

Return value

Variant

Examples...

CopyObjects Method example


Document.EndUndoMark Method

Ends the undo mark to where being mark was set.

Syntax

object.EndUndoMark

object is a Document object.

Examples...

EndUndoMark Method example


Document.Export Method

Exports the file in a different format (DXF, SAT, etc.).

Syntax

object.Export(FileName, Extension, SelectionSet)

object is a Document object.

Parameters

Name | Options | Data Type | Description
FileName | Input-only | String | -
Extension | Input-only | String | -
SelectionSet | Input-only | SelectionSet | -

Examples...

Export Method example


Document.GetVariable Method

Returns the current setting of a variable.

Syntax

object.GetVariable(Name)

object is a Document object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

Variant

Examples...

GetVariable Method example


Document.HandleToObject Method

Return an object given a handle. Applies to current dwg

Syntax

object.HandleToObject(Handle)

object is a Document object.

Parameters

Name | Options | Data Type | Description
Handle | Input-only | String | -

Return value

Object

Examples...

HandleToObject Method example


Document.Import Method

Imports a different format file (DXF, SAT, etc.)into ZWCAD.

Syntax

object.Import(FileName, InsertionPoint, ScaleFactor)

object is a Document object.

Parameters

Name | Options | Data Type | Description
FileName | Input-only | String | -
InsertionPoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Return value

Object

Examples...

Import Method example


Document.LoadShapeFile Method

Loads the given shape file.

Syntax

object.LoadShapeFile(FullName)

object is a Document object.

Parameters

Name | Options | Data Type | Description
FullName | Input-only | String | -

Examples...

LoadShapeFile Method example


Document.New Method

Starts a new drawing.

Syntax

object.New(TemplateFileName)

object is a Document object.

Parameters

Name | Options | Data Type | Description
TemplateFileName | Input-only | String | -

Return value

Document


Document.Open Method

Opens a drawing file.

Syntax

object.Open(FullName, Password)

object is a Document object.

Parameters

Name | Options | Data Type | Description
FullName | Input-only | String | -
Password | Input-only, Optional | Variant | -

Return value

Document

Examples...

Open Method example


Document.PurgeAll Method

Removes all unused named references from the database.

Syntax

object.PurgeAll

object is a Document object.


Document.Regen Method

Regen all viewports or active viewport

Syntax

object.Regen(WhichViewports)

object is a Document object.

Parameters

Name | Options | Data Type | Description
WhichViewports | Input-only | ZcRegenType | Can be one of the constants listed here: zcActiveViewport zcAllViewports

Examples...

Regen Method example


Document.Save Method

Saves changes to the active drawing file.

Syntax

object.Save

object is a Document object.

Examples...

Save Method example


Document.SaveAs Method

Saves changes to a user specified file.

Syntax

object.SaveAs(FullFileName, SaveAsType, vSecurityParams)

object is a Document object.

Parameters

Name | Options | Data Type | Description
FullFileName | Input-only | String | -
SaveAsType | Input-only, Optional | Variant | -
vSecurityParams | Input-only, Optional | Variant | -

Examples...

SaveAs Method example


Document.SendCommand Method

Sends a command string to the document.

Syntax

object.SendCommand(Command)

object is a Document object.

Parameters

Name | Options | Data Type | Description
Command | Input-only | String | -

Examples...

SendCommand Method example


Document.SetVariable Method

Sets value to a current variable.

Syntax

object.SetVariable(Name, Value)

object is a Document object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -
Value | Input-only | Variant | -

Examples...

SetVariable Method example


Document.StartUndoMark Method

Starts the undo mark for subsequent automation calls.

Syntax

object.StartUndoMark

object is a Document object.

Examples...

StartUndoMark Method example


Document.Active Property

Is Active document or not.

Syntax

object.Active

object is a Document object.

Description

Active Boolean; Read-only

Examples...

Active Property example


Document.ActiveDimStyle Property

Returns and sets the active dimstyle object.

Syntax

object.ActiveDimStyle

object is a Document object.

Description

ActiveDimStyle DimStyle; Read-write

Examples...

ActiveDimStyle Property example


Document.ActiveLayer Property

Returns and sets the active layer object.

Syntax

object.ActiveLayer

object is a Document object.

Description

ActiveLayer Layer; Read-write

Examples...

ActiveLayer Property example


Document.ActiveLayout Property

Returns and sets the active layout object.

Syntax

object.ActiveLayout

object is a Document object.

Description

ActiveLayout Layout; Read-write

Examples...

ActiveLayout Property example


Document.ActiveLinetype Property

Returns and sets the active linetype object.

Syntax

object.ActiveLinetype

object is a Document object.

Description

ActiveLinetype LineType; Read-write


Document.ActivePViewport Property

Returns and sets the active paperspace viewport object.

Syntax

object.ActivePViewport

object is a Document object.

Description

ActivePViewport PViewport; Read-write

Examples...

ActivePViewport Property example


Document.ActiveSelectionSet Property

Returns the active selection set object.

Syntax

object.ActiveSelectionSet

object is a Document object.

Description

ActiveSelectionSet SelectionSet; Read-only

Examples...

ActiveSelectionSet Property example


Document.ActiveSpace Property

Like tile mode returns and sets the active space (1or0).

Syntax

object.ActiveSpace

object is a Document object.

Description

ActiveSpace ZcActiveSpace: Read-write
Can be one of the constants listed here:
zcPaperSpace
zcModelSpace

Examples...

ActiveSpace Property example


Document.ActiveTextStyle Property

Returns and sets the active text style object.

Syntax

object.ActiveTextStyle

object is a Document object.

Description

ActiveTextStyle TextStyle; Read-write

Examples...

ActiveTextStyle Property example


Document.ActiveUCS Property

Returns and sets the active user coordinates systems object.

Syntax

object.ActiveUCS

object is a Document object.

Description

ActiveUCS UCS; Read-write

Examples...

ActiveUCS Property example


Document.ActiveViewport Property

Returns and sets the active viewport object.

Syntax

object.ActiveViewport

object is a Document object.

Description

ActiveViewport Viewport; Read-write

Examples...

ActiveViewport Property example


Document.Application Property

Returns the application object.

Syntax

object.Application

object is a Document object.

Description

Application Application; Read-only

Examples...

Application Property example


Document.Blocks Property

Returns the blocks collection object.

Syntax

object.Blocks

object is a Document object.

Description

Blocks Blocks; Read-only

Examples...

Blocks Property example


Document.Database Property

Returns the database object.

Syntax

object.Database

object is a Document object.

Description

Database Database; Read-only


Document.Dictionaries Property

Returns the dictionaries collection.

Syntax

object.Dictionaries

object is a Document object.

Description

Dictionaries Dictionaries; Read-only


Document.DimStyles Property

Returns the dimstyles collection.

Syntax

object.DimStyles

object is a Document object.

Description

DimStyles DimStyles; Read-only


Document.ElevationModelSpace Property

Returns and sets the model space elevation.

Syntax

object.ElevationModelSpace

object is a Document object.

Description

ElevationModelSpace Double; Read-write


Document.ElevationPaperSpace Property

Returns and sets the paper space elevation.

Syntax

object.ElevationPaperSpace

object is a Document object.

Description

ElevationPaperSpace Double; Read-write


Document.FullName Property

Returns the full drawing file name.

Syntax

object.FullName

object is a Document object.

Description

FullName String; Read-only


Document.Groups Property

Returns the groups collection.

Syntax

object.Groups

object is a Document object.

Description

Groups Groups; Read-only


Document.HWND Property

Returns the HWND of the document window frame.

Syntax

object.HWND

object is a Document object.

Description

HWND LONG_PTR: alias for Long; Read-only


Document.Height Property

Height of document.

Syntax

object.Height

object is a Document object.

Description

Height Integer; Read-write


Document.Layers Property

Returns the layers collection.

Syntax

object.Layers

object is a Document object.

Description

Layers Layers; Read-only

Examples...

Layers Property example


Document.Layouts Property

Returns the layouts collection.

Syntax

object.Layouts

object is a Document object.

Description

Layouts Layouts; Read-only

Examples...

Layouts Property example


Document.Limits Property

Returns and sets the limits of the drawing boundary.

Syntax

object.Limits

object is a Document object.

Description

Limits Variant; Read-write


Document.Linetypes Property

Returns the linetypes collection.

Syntax

object.Linetypes

object is a Document object.

Description

Linetypes LineTypes; Read-only

Examples...

Linetypes Property example


Document.MSpace Property

Set mspace or pspace in a Layout

Syntax

object.MSpace

object is a Document object.

Description

MSpace Boolean; Read-write

Examples...

MSpace Property example


Document.ModelSpace Property

Returns the model space block.

Syntax

object.ModelSpace

object is a Document object.

Description

ModelSpace ModelSpace; Read-only

Examples...

ModelSpace Property example


Document.Name Property

Returns the name of the document, excluding the path.

Syntax

object.Name

object is a Document object.

Description

Name String; Read-only

Examples...

Name Property example


Document.ObjectSnapMode Property

Toggles to turn on or off the specified object snap mode.

Syntax

object.ObjectSnapMode

object is a Document object.

Description

ObjectSnapMode Boolean; Read-write


Document.PaperSpace Property

Returns the paper space block.

Syntax

object.PaperSpace

object is a Document object.

Description

PaperSpace PaperSpace; Read-only

Examples...

PaperSpace Property example


Document.Path Property

Returns the path of the document, excluding the filename.

Syntax

object.Path

object is a Document object.

Description

Path String; Read-only

Examples...

Path Property example


Document.PickfirstSelectionSet Property

Returns the pickfirst selection set object.

Syntax

object.PickfirstSelectionSet

object is a Document object.

Description

PickfirstSelectionSet SelectionSet; Read-only

Examples...

PickfirstSelectionSet Property example


Document.Plot Property

Returns the plot object.

Syntax

object.Plot

object is a Document object.

Description

Plot Plot; Read-only

Examples...

Plot Property example


Document.PlotConfigurations Property

Returns the plot configurations collection.

Syntax

object.PlotConfigurations

object is a Document object.

Description

PlotConfigurations PlotConfigurations; Read-only

Examples...

PlotConfigurations Property example


Document.Preferences Property

Returns the database preferences object.

Syntax

object.Preferences

object is a Document object.

Description

Preferences DatabasePreferences; Read-only


Document.ReadOnly Property

Returns true if the file is read-only and false otherwise.

Syntax

object.ReadOnly

object is a Document object.

Description

ReadOnly Boolean; Read-only

Examples...

ReadOnly Property example


Document.RegisteredApplications Property

Returns the registered applications collection.

Syntax

object.RegisteredApplications

object is a Document object.

Description

RegisteredApplications RegisteredApplications; Read-only

Examples...

RegisteredApplications Property example


Document.Saved Property

Returns true if the document has unsaved changes.

Syntax

object.Saved

object is a Document object.

Description

Saved Boolean; Read-only

Examples...

Saved Property example


Document.SelectionSets Property

Returns the selection sets collection.

Syntax

object.SelectionSets

object is a Document object.

Description

SelectionSets SelectionSets; Read-only

Examples...

SelectionSets Property example


Document.SummaryInfo Property

Returns the summary info object.

Syntax

object.SummaryInfo

object is a Document object.

Description

SummaryInfo SummaryInfo; Read-only

Examples...

SummaryInfo Property example


Document.TextStyles Property

Returns the text styles collection.

Syntax

object.TextStyles

object is a Document object.

Description

TextStyles TextStyles; Read-only

Examples...

TextStyles Property example


Document.Utility Property

Returns the utility object.

Syntax

object.Utility

object is a Document object.

Description

Utility Utility; Read-only

Examples...

Utility Property example


Document.Viewports Property

Returns the viewports collection.

Syntax

object.Viewports

object is a Document object.

Description

Viewports Viewports; Read-only

Examples...

Viewports Property example


Document.Views Property

Returns the views collection.

Syntax

object.Views

object is a Document object.

Description

Views Views; Read-only

Examples...

Views Property example


Document.Width Property

Width of document.

Syntax

object.Width

object is a Document object.

Description

Width Integer; Read-write

Examples...

Width Property example


Document.WindowState Property

Current state of the document window.

Syntax

object.WindowState

object is a Document object.

Description

WindowState ZcWindowState: Read-write
Can be one of the constants listed here:
zcNorm
zcMin
zcMax

Examples...

WindowState Property example


Document.WindowTitle Property

Returns the title of the document window.

Syntax

object.WindowTitle

object is a Document object.

Description

WindowTitle String; Read-only

Examples...

WindowTitle Property example


Document.Activate Event

Happens when the drawing window is activated.

Syntax

object.Activate

object is a Document object.


Document.BeginClose Event

Happens just before a drawing is closed.

Syntax

object.BeginClose

object is a Document object.

Examples...

BeginClose Event example


Document.BeginCommand Event

Happens immediately before a command is issued.

Syntax

object.BeginCommand(CommandName)

object is a Document object.

Parameters

Name | Options | Data Type | Description
CommandName | Input-only | String | -

Examples...

BeginCommand Event example


Document.BeginDocClose Event

Happens just before a drawing is closed.

Syntax

object.BeginDocClose(Cancel)

object is a Document object.

Parameters

Name | Options | Data Type | Description
Cancel | Input-output | Boolean | -


Document.BeginDoubleClick Event

Happens immediatly before the default double click action.

Syntax

object.BeginDoubleClick(PickPoint)

object is a Document object.

Parameters

Name | Options | Data Type | Description
PickPoint | Input-only | Variant | -

Examples...

BeginDoubleClick Event example


Document.BeginPlot Event

Happens just before the drawing is plotted.

Syntax

object.BeginPlot(DrawingName)

object is a Document object.

Parameters

Name | Options | Data Type | Description
DrawingName | Input-only | String | -


Document.BeginRightClick Event

Happens immediatly before the default right click action.

Syntax

object.BeginRightClick(PickPoint)

object is a Document object.

Parameters

Name | Options | Data Type | Description
PickPoint | Input-only | Variant | -

Examples...

BeginRightClick Event example


Document.BeginSave Event

Happens immediately before Zwcad saves the drawing.

Syntax

object.BeginSave(FileName)

object is a Document object.

Parameters

Name | Options | Data Type | Description
FileName | Input-only | String | -

Examples...

BeginSave Event example


Document.BeginShortcutMenuCommand Event

Happens immediatly before the shortcut menu appears in command mode.

Syntax

object.BeginShortcutMenuCommand(ShortcutMenu, Command)

object is a Document object.

Parameters

Name | Options | Data Type | Description
ShortcutMenu | Output-only | Object | -
Command | Input-only | String | -


Document.BeginShortcutMenuDefault Event

Happens immediatly before the shortcut menu appears in default mode.

Syntax

object.BeginShortcutMenuDefault(ShortcutMenu)

object is a Document object.

Parameters

Name | Options | Data Type | Description
ShortcutMenu | Output-only | Object | -


Document.BeginShortcutMenuEdit Event

Happens immediatly before the shortcut menu appears in edit mode.

Syntax

object.BeginShortcutMenuEdit(ShortcutMenu, SelectionSet)

object is a Document object.

Parameters

Name | Options | Data Type | Description
ShortcutMenu | Output-only | Object | -
SelectionSet | Output-only | Object | -


Document.BeginShortcutMenuGrip Event

Happens immediatly before the shortcut menu appears in grip mode.

Syntax

object.BeginShortcutMenuGrip(ShortcutMenu)

object is a Document object.

Parameters

Name | Options | Data Type | Description
ShortcutMenu | Output-only | Object | -


Document.Deactivate Event

Happens when the drawing window is deactivated.

Syntax

object.Deactivate

object is a Document object.


Document.EndCommand Event

Happens immediately after a command is issued.

Syntax

object.EndCommand(CommandName)

object is a Document object.

Parameters

Name | Options | Data Type | Description
CommandName | Input-only | String | -


Document.EndPlot Event

Happens just after the drawing is plotted.

Syntax

object.EndPlot(DrawingName)

object is a Document object.

Parameters

Name | Options | Data Type | Description
DrawingName | Input-only | String | -


Document.EndSave Event

Happens immediately after Zwcad saved the drawing.

Syntax

object.EndSave(FileName)

object is a Document object.

Parameters

Name | Options | Data Type | Description
FileName | Input-only | String | -


Document.EndShortcutMenu Event

Happens immediatly after the shortcut menu appears.

Syntax

object.EndShortcutMenu(ShortcutMenu)

object is a Document object.

Parameters

Name | Options | Data Type | Description
ShortcutMenu | Output-only | Object | -


Document.LayoutSwitched Event

Happens when the current layout space changes.

Syntax

object.LayoutSwitched(LayoutName)

object is a Document object.

Parameters

Name | Options | Data Type | Description
LayoutName | Input-only | String | -

Examples...

LayoutSwitched Event example


Document.ObjectAdded Event

Happens when an object is added to the drawing.

Syntax

object.ObjectAdded(Object)

object is a Document object.

Parameters

Name | Options | Data Type | Description
Object | Input-only | Object | -


Document.ObjectErased Event

Happens when an object is erased from the drawing.

Syntax

object.ObjectErased(ObjectID)

object is a Document object.

Parameters

Name | Options | Data Type | Description
ObjectID | Input-only | Long | -


Document.ObjectModified Event

Happens when an object is modified in the drawing.

Syntax

object.ObjectModified(Object)

object is a Document object.

Parameters

Name | Options | Data Type | Description
Object | Input-only | Object | -


Document.SelectionChanged Event

Happens when the pickfirst selection set changes.

Syntax

object.SelectionChanged

object is a Document object.

Examples...

SelectionChanged Event example


Document.WindowChanged Event

Happens when the drawing window state changes.

Syntax

object.WindowChanged(WindowState)

object is a Document object.

Parameters

Name | Options | Data Type | Description
WindowState | Input-only | ZcWindowState | Can be one of the constants listed here: zcNorm zcMin zcMax


Document.WindowMovedOrResized Event

Happens when the drawing window is moved or resized.

Syntax

object.WindowMovedOrResized(HWNDFrame, bMoved)

object is a Document object.

Parameters

Name | Options | Data Type | Description
HWNDFrame | Input-only | Long | -
bMoved | Input-only | Boolean | -


ZcadDocuments Object Members

Documents Object Members

The collection of all ZWCAD drawings that are open in the current session.

VBA Class Name

ZcadDocuments

Methods

Name | Description
Add | Adds a document to the documents collection.
Close | Closes all documents in the documents collection.
Item | Returns an element in the collection.
Open | Opens a drawing to the documents collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of elements in the collection.

Events

Name | Description
None | -


Documents.Add Method

Adds a document to the documents collection.

Syntax

object.Add(TemplateName)

object is a Documents object.

Parameters

Name | Options | Data Type | Description
TemplateName | Input-only, Optional | Variant | -

Return value

Document

Examples...

Add Method example


Documents.Close Method

Closes all documents in the documents collection.

Syntax

object.Close

object is a Documents object.

Examples...

Close Method example


Documents.Item Method

Returns an element in the collection.

Syntax

object.Item(Index)

object is a Documents object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Document

Examples...

Item Method example


Documents.Open Method

Opens a drawing to the documents collection.

Syntax

object.Open(Name, ReadOnly, Password)

object is a Documents object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -
ReadOnly | Input-only, Optional | Variant | -
Password | Input-only, Optional | Variant | -

Return value

Document

Examples...

Open Method example


Documents.Application Property

Returns the application object.

Syntax

object.Application

object is a Documents object.

Description

Application Application; Read-only

Examples...

Application Property example


Documents.Count Property

Returns the number of elements in the collection.

Syntax

object.Count

object is a Documents object.

Description

Count Long; Read-only

Examples...

Count Property example


ZcadDynamicBlockReferenceProperty Object Members

DynamicBlockReferenceProperty Object Members

A special object to use in monitoring the DynamicBlockReferenceProperty of ZWCAD from out-of-process applications.

VBA Class Name

ZcadDynamicBlockReferenceProperty

Methods

Name | Description
None | -

Properties

Name | Description
AllowedValues | Specifies the allowed values for the property.
Description | Specifies the description of an object.
PropertyName | Specifies the name for the property.
ReadOnly | Specifies if the document or property is read-only or read-write.
Show | Specifies whether the property is shown in the user interface.
UnitsType | Specifies the current display units type for the property.
Value | Specifies the current value for the property, or the object ID of the newly created cloned object.

Events

Name | Description
None | -


DynamicBlockReferenceProperty.AllowedValues Property

Specifies the allowed values for the property.

Syntax

object.AllowedValues

object is a DynamicBlockReferenceProperty object.

Description

AllowedValues Variant; Read-only


DynamicBlockReferenceProperty.Description Property

Specifies the description of an object.

Syntax

object.Description

object is a DynamicBlockReferenceProperty object.

Description

Description String; Read-only


DynamicBlockReferenceProperty.PropertyName Property

Specifies the name for the property.

Syntax

object.PropertyName

object is a DynamicBlockReferenceProperty object.

PropertyName

PropertyName String; Read-only


DynamicBlockReferenceProperty.ReadOnly Property

Specifies if the document or property is read-only or read-write.

Syntax

object.ReadOnly

object is a DynamicBlockReferenceProperty object.

ReadOnly

ReadOnly Boolean; Read-only

Examples...

ReadOnly Property example


DynamicBlockReferenceProperty.Show Property

Specifies whether the property is shown in the user interface.

Syntax

object.Show

object is a DynamicBlockReferenceProperty object.

Show

Show Boolean; Read-only


DynamicBlockReferenceProperty.UnitsType Property

Specifies the current display units type for the property.

Syntax

object.UnitsType

object is a DynamicBlockReferenceProperty object.

UnitsType

UnitsType ZcDynamicBlockReferencePropertyUnitsType enum; Read-only


DynamicBlockReferenceProperty.Value Property

Specifies the current value for the property, or the object ID of the newly created cloned object.

Syntax

object.Value

object is a DynamicBlockReferenceProperty object.

Value

Value DynamicBlockReferenceProperty objects: Variant; Read-write


ZcadEllipse Object Members

Ellipse Object Members

An elliptical arc or full ellipse.

VBA Class Name

ZcadEllipse

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Offset | method Offset
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Area | Specifies the area of the ellipse
Center | Specifies the X, Y, and Z center point coordinates of the ellipse
Database | Returns the database object.
Document | Returns the document object.
EndAngle | Specifies the end angle of the ellipse
EndParameter | Specifies the end parameter of the ellipse
EndPoint | Specifies the X, Y, and Z end point coordinates of the ellipse
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
MajorAxis | Specifies the major axis of the ellipse
MajorRadius | Specifies the major radius of the ellipse
MinorAxis | Specifies the minor axis of the ellipse
MinorRadius | Specifies the minor radius of the ellipse
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
RadiusRatio | Specifies the radius ratio of the ellipse
StartAngle | Specifies the start angle of the ellipse
StartParameter | Specifies the start parameter of the ellipse
StartPoint | Specifies the X, Y, and Z start point coordinates of the ellipse
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Ellipse.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Ellipse.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Ellipse.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Ellipse object.

Return value

Object

Examples...

Copy Method example


Ellipse.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Ellipse object.

Examples...

Delete Method example


Ellipse.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Ellipse object.

Examples...

Erase Method example


Ellipse.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Ellipse.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Ellipse object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Ellipse.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Ellipse.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Ellipse.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Ellipse.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Ellipse.Offset Method

method Offset

Syntax

object.Offset(Distance)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
Distance | Input-only | Double | -

Return value

Variant


Ellipse.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Ellipse.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Ellipse.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Ellipse.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Ellipse object.


Ellipse.Application Property

Returns the application object.

Syntax

object.Application

object is a Ellipse object.

Description

Application Object; Read-only

Examples...

Application Property example


Ellipse.Area Property

Specifies the area of the ellipse

Syntax

object.Area

object is a Ellipse object.

Description

Area Double; Read-only

Examples...

Area Property example


Ellipse.Center Property

Specifies the X, Y, and Z center point coordinates of the ellipse

Syntax

object.Center

object is a Ellipse object.

Description

Center Variant; Read-write

Examples...

Center Property example


Ellipse.Database Property

Returns the database object.

Syntax

object.Database

object is a Ellipse object.

Description

Database Database; Read-only


Ellipse.Document Property

Returns the document object.

Syntax

object.Document

object is a Ellipse object.

Description

Document Object; Read-only


Ellipse.EndAngle Property

Specifies the end angle of the ellipse

Syntax

object.EndAngle

object is a Ellipse object.

Description

EndAngle ZCAD_ANGLE: alias for Double; Read-write


Ellipse.EndParameter Property

Specifies the end parameter of the ellipse

Syntax

object.EndParameter

object is a Ellipse object.

Description

EndParameter Double; Read-write


Ellipse.EndPoint Property

Specifies the X, Y, and Z end point coordinates of the ellipse

Syntax

object.EndPoint

object is a Ellipse object.

Description

EndPoint Variant; Read-only


Ellipse.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Ellipse object.

Description

Handle String; Read-only


Ellipse.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Ellipse object.

Description

HasExtensionDictionary Boolean; Read-only


Ellipse.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Ellipse object.

Description

Hyperlinks Hyperlinks; Read-only


Ellipse.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Ellipse object.

Description

Layer String; Read-write

Examples...

Layer Property example


Ellipse.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Ellipse object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Ellipse.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Ellipse object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Ellipse.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Ellipse object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Ellipse.MajorAxis Property

Specifies the major axis of the ellipse

Syntax

object.MajorAxis

object is a Ellipse object.

Description

MajorAxis Variant; Read-write

Examples...

MajorAxis Property example


Ellipse.MajorRadius Property

Specifies the major radius of the ellipse

Syntax

object.MajorRadius

object is a Ellipse object.

Description

MajorRadius Double; Read-write

Examples...

MajorRadius Property example


Ellipse.MinorAxis Property

Specifies the minor axis of the ellipse

Syntax

object.MinorAxis

object is a Ellipse object.

Description

MinorAxis Variant; Read-only

Examples...

MinorAxis Property example


Ellipse.MinorRadius Property

Specifies the minor radius of the ellipse

Syntax

object.MinorRadius

object is a Ellipse object.

Description

MinorRadius Double; Read-write

Examples...

MinorRadius Property example


Ellipse.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a Ellipse object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Ellipse.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Ellipse object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Ellipse.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Ellipse object.

Description

ObjectName String; Read-only


Ellipse.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Ellipse object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Ellipse.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Ellipse object.

Description

PlotStyleName String; Read-write


Ellipse.RadiusRatio Property

Specifies the radius ratio of the ellipse

Syntax

object.RadiusRatio

object is a Ellipse object.

Description

RadiusRatio Double; Read-write

Examples...

RadiusRatio Property example


Ellipse.StartAngle Property

Specifies the start angle of the ellipse

Syntax

object.StartAngle

object is a Ellipse object.

Description

StartAngle ZCAD_ANGLE: alias for Double; Read-write

Examples...

StartAngle Property example


Ellipse.StartParameter Property

Specifies the start parameter of the ellipse

Syntax

object.StartParameter

object is a Ellipse object.

Description

StartParameter Double; Read-write

Examples...

StartParameter Property example


Ellipse.StartPoint Property

Specifies the X, Y, and Z start point coordinates of the ellipse

Syntax

object.StartPoint

object is a Ellipse object.

Description

StartPoint Variant; Read-only

Examples...

StartPoint Property example


Ellipse.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Ellipse object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Ellipse.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Ellipse object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Ellipse.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Ellipse object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadExternalReference Object Members

ExternalReference Object Members

An instance of an external reference inserted into a drawing.

VBA Class Name

ZcadExternalReference

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
Explode | Explodes the block and returns the sub-entities as an array of Object
GetAttributes | Gets Attributes in the block
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetConstantAttributes | Gets constant attributes in the block
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasAttributes | Returns whether the block has any attributes in it
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
InsUnits | Specifies insunits saved with the block
InsUnitsFactor | Specifies the conversion factor between block units and drawing units
InsertionPoint | Specifies X, Y, and Z coordinates for insertion point of the block
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Name | Specifies the name of the block
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
Path | Specifies the path of the external reference
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Specifies the rotation angle of the block
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.
XScaleFactor | Specifies the XScale factor of the block
YScaleFactor | Specifies the Yscale factor of the block
ZScaleFactor | Specifies the ZScale factor of the block

Events

Name | Description
Modified | Happens when object is modified


ExternalReference.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


ExternalReference.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


ExternalReference.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a ExternalReference object.

Return value

Object

Examples...

Copy Method example


ExternalReference.Delete Method

Deletes the object.

Syntax

object.Delete

object is a ExternalReference object.

Examples...

Delete Method example


ExternalReference.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a ExternalReference object.

Examples...

Erase Method example


ExternalReference.Explode Method

Explodes the block and returns the sub-entities as an array of Object

Syntax

object.Explode

object is a ExternalReference object.

Return value

Variant

Examples...

Explode Method example


ExternalReference.GetAttributes Method

Gets Attributes in the block

Syntax

object.GetAttributes

object is a ExternalReference object.

Return value

Variant

Examples...

GetAttributes Method example


ExternalReference.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


ExternalReference.GetConstantAttributes Method

Gets constant attributes in the block

Syntax

object.GetConstantAttributes

object is a ExternalReference object.

Return value

Variant

Examples...

GetConstantAttributes Method example


ExternalReference.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a ExternalReference object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


ExternalReference.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


ExternalReference.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


ExternalReference.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


ExternalReference.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


ExternalReference.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


ExternalReference.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


ExternalReference.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


ExternalReference.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a ExternalReference object.


ExternalReference.Application Property

Returns the application object.

Syntax

object.Application

object is a ExternalReference object.

Description

Application Object; Read-only

Examples...

Application Property example


ExternalReference.Database Property

Returns the database object.

Syntax

object.Database

object is a ExternalReference object.

Description

Database Database; Read-only


ExternalReference.Document Property

Returns the document object.

Syntax

object.Document

object is a ExternalReference object.

Description

Document Object; Read-only


ExternalReference.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a ExternalReference object.

Description

Handle String; Read-only


ExternalReference.HasAttributes Property

Returns whether the block has any attributes in it

Syntax

object.HasAttributes

object is a ExternalReference object.

Description

HasAttributes Boolean; Read-only


ExternalReference.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a ExternalReference object.

Description

HasExtensionDictionary Boolean; Read-only


ExternalReference.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a ExternalReference object.

Description

Hyperlinks Hyperlinks; Read-only


ExternalReference.InsUnits Property

Specifies insunits saved with the block

Syntax

object.InsUnits

object is a ExternalReference object.

Description

InsUnits String; Read-only


ExternalReference.InsUnitsFactor Property

Specifies the conversion factor between block units and drawing units

Syntax

object.InsUnitsFactor

object is a ExternalReference object.

Description

InsUnitsFactor Double; Read-only


ExternalReference.InsertionPoint Property

Specifies X, Y, and Z coordinates for insertion point of the block

Syntax

object.InsertionPoint

object is a ExternalReference object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


ExternalReference.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a ExternalReference object.

Description

Layer String; Read-write

Examples...

Layer Property example


ExternalReference.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a ExternalReference object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


ExternalReference.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a ExternalReference object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


ExternalReference.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a ExternalReference object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


ExternalReference.Name Property

Specifies the name of the block

Syntax

object.Name

object is a ExternalReference object.

Description

Name String; Read-write

Examples...

Name Property example


ExternalReference.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a ExternalReference object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


ExternalReference.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a ExternalReference object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


ExternalReference.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a ExternalReference object.

Description

ObjectName String; Read-only


ExternalReference.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a ExternalReference object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


ExternalReference.Path Property

Specifies the path of the external reference

Syntax

object.Path

object is a ExternalReference object.

Description

Path String; Read-write

Examples...

Path Property example


ExternalReference.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a ExternalReference object.

Description

PlotStyleName String; Read-write


ExternalReference.Rotation Property

Specifies the rotation angle of the block

Syntax

object.Rotation

object is a ExternalReference object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


ExternalReference.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a ExternalReference object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


ExternalReference.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a ExternalReference object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


ExternalReference.XScaleFactor Property

Specifies the XScale factor of the block

Syntax

object.XScaleFactor

object is a ExternalReference object.

Description

XScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

XScaleFactor Property example


ExternalReference.YScaleFactor Property

Specifies the Yscale factor of the block

Syntax

object.YScaleFactor

object is a ExternalReference object.

Description

YScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

YScaleFactor Property example


ExternalReference.ZScaleFactor Property

Specifies the ZScale factor of the block

Syntax

object.ZScaleFactor

object is a ExternalReference object.

Description

ZScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ZScaleFactor Property example


ExternalReference.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a ExternalReference object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadFileDependency Object Members

FileDependency Object Members

Provides information about entries in the File Dependency List of a drawing file.

VBA Class Name

ZcadFileDependency

Methods

Name | Description
None | -

Properties

Name | Description
AffectsGraphics | Returns whether the entry affects graphics.
Feature | Returns the feature.
FileName | Returns the file name.
FileSize | Returns the file size.
FoundPath | Returns the found path.
FullFileName | Returns the full file name.
Index | Returns index of the entry.
IsModified | Returns whether the entry is modified.
ReferenceCount | Returns the reference count.
TimeStamp | Returns the timestamp.

Events

Name | Description
None | -


FileDependency.AffectsGraphics Property

Returns whether the entry affects graphics.

Syntax

object.AffectsGraphics

object is a FileDependency object.

Description

AffectsGraphics Boolean; Read-only


FileDependency.Feature Property

Returns the feature.

Syntax

object.Feature

object is a FileDependency object.

Description

Feature String; Read-only


FileDependency.FileName Property

Returns the file name.

Syntax

object.FileName

object is a FileDependency object.

Description

FileName String; Read-only


FileDependency.FileSize Property

Returns the file size.

Syntax

object.FileSize

object is a FileDependency object.

Description

FileSize Long; Read-only


FileDependency.FoundPath Property

Returns the found path.

Syntax

object.FoundPath

object is a FileDependency object.

Description

FoundPath String; Read-only


FileDependency.FullFileName Property

Returns the full file name.

Syntax

object.FullFileName

object is a FileDependency object.

Description

FullFileName String; Read-only


FileDependency.Index Property

Returns index of the entry.

Syntax

object.Index

object is a FileDependency object.

Description

Index Long; Read-only


FileDependency.IsModified Property

Returns whether the entry is modified.

Syntax

object.IsModified

object is a FileDependency object.

Description

IsModified Boolean; Read-only


FileDependency.ReferenceCount Property

Returns the reference count.

Syntax

object.ReferenceCount

object is a FileDependency object.

Description

ReferenceCount Long; Read-only


FileDependency.TimeStamp Property

Returns the timestamp.

Syntax

object.TimeStamp

object is a FileDependency object.

Description

TimeStamp Long; Read-only


ZcadGroup Object Members

Group Object Members

A named SelectionSet object.

VBA Class Name

ZcadGroup

Methods

Name | Description
AppendItems | Appends items to the groups.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entities in the group.
Item | Returns an element in the group.
RemoveItems | Removes items from the group.
Update | Updates all the entities in the group.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of elements in the group.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Layer | Sets the layer for entities in the group.
Linetype | Sets the linetype for the entities in the group.
LinetypeScale | Sets the linetype for the entities in the group.
Lineweight | Sets the lineweight for the entities in the group.
Name | Returns and sets the name of the group.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Sets the plotstyle name for the entities in the group.
TrueColor | Sets the true color for entities in the group.
Visible | Turns the visibility on or off for the entities in the group.

Events

Name | Description
Modified | Happens when object is modified


Group.AppendItems Method

Appends items to the groups.

Syntax

object.AppendItems(Objects)

object is a Group object.

Parameters

Name | Options | Data Type | Description
Objects | Input-only | Variant | -

Examples...

AppendItems Method example


Group.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Group object.

Examples...

Delete Method example


Group.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Group object.

Examples...

Erase Method example


Group.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Group object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Group.Highlight Method

Highlights the entities in the group.

Syntax

object.Highlight(HighlightFlag)

object is a Group object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Group.Item Method

Returns an element in the group.

Syntax

object.Item(Index)

object is a Group object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Entity

Examples...

Item Method example


Group.RemoveItems Method

Removes items from the group.

Syntax

object.RemoveItems(Objects)

object is a Group object.

Parameters

Name | Options | Data Type | Description
Objects | Input-only | Variant | -

Examples...

RemoveItems Method example


Group.Update Method

Updates all the entities in the group.

Syntax

object.Update

object is a Group object.


Group.Application Property

Returns the application object.

Syntax

object.Application

object is a Group object.

Description

Application Object; Read-only

Examples...

Application Property example


Group.Count Property

Returns the number of elements in the group.

Syntax

object.Count

object is a Group object.

Description

Count Long; Read-only

Examples...

Count Property example


Group.Database Property

Returns the database object.

Syntax

object.Database

object is a Group object.

Description

Database Database; Read-only


Group.Document Property

Returns the document object.

Syntax

object.Document

object is a Group object.

Description

Document Object; Read-only


Group.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Group object.

Description

Handle String; Read-only


Group.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Group object.

Description

HasExtensionDictionary Boolean; Read-only


Group.Layer Property

Sets the layer for entities in the group.

Syntax

object.Layer

object is a Group object.

Description

Layer ; Write-only

Examples...

Layer Property example


Group.Linetype Property

Sets the linetype for the entities in the group.

Syntax

object.Linetype

object is a Group object.

Description

Linetype ; Write-only

Examples...

Linetype Property example


Group.LinetypeScale Property

Sets the linetype for the entities in the group.

Syntax

object.LinetypeScale

object is a Group object.

Description

LinetypeScale ; Write-only

Examples...

LinetypeScale Property example


Group.Lineweight Property

Sets the lineweight for the entities in the group.

Syntax

object.Lineweight

object is a Group object.

Description

Lineweight ; Write-only

Examples...

Lineweight Property example


Group.Name Property

Returns and sets the name of the group.

Syntax

object.Name

object is a Group object.

Description

Name String; Read-write

Examples...

Name Property example


Group.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Group object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Group.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Group object.

Description

ObjectName String; Read-only


Group.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Group object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Group.PlotStyleName Property

Sets the plotstyle name for the entities in the group.

Syntax

object.PlotStyleName

object is a Group object.

Description

PlotStyleName ; Write-only


Group.TrueColor Property

Sets the true color for entities in the group.

Syntax

object.TrueColor

object is a Group object.

Description

TrueColor ; Write-only

Examples...

TrueColor Property example


Group.Visible Property

Turns the visibility on or off for the entities in the group.

Syntax

object.Visible

object is a Group object.

Description

Visible ; Write-only

Examples...

Visible Property example


Group.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Group object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadGroups Object Members

Groups Object Members

The collection of all groups in the drawing.

VBA Class Name

ZcadGroups

Methods

Name | Description
Add | Adds a group to the groups collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


Groups.Add Method

Adds a group to the groups collection.

Syntax

object.Add(Name)

object is a Groups object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

Group

Examples...

Add Method example


Groups.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Groups object.

Examples...

Delete Method example


Groups.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Groups object.

Examples...

Erase Method example


Groups.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Groups object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Groups.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a Groups object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Group

Examples...

Item Method example


Groups.Application Property

Returns the application object.

Syntax

object.Application

object is a Groups object.

Description

Application Object; Read-only

Examples...

Application Property example


Groups.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a Groups object.

Description

Count Long; Read-only

Examples...

Count Property example


Groups.Database Property

Returns the database object.

Syntax

object.Database

object is a Groups object.

Description

Database Database; Read-only


Groups.Document Property

Returns the document object.

Syntax

object.Document

object is a Groups object.

Description

Document Object; Read-only


Groups.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Groups object.

Description

Handle String; Read-only


Groups.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Groups object.

Description

HasExtensionDictionary Boolean; Read-only


Groups.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Groups object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Groups.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Groups object.

Description

ObjectName String; Read-only


Groups.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Groups object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Groups.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Groups object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadHatch Object Members

Hatch Object Members

An area fill consisting of a pattern of lines.

VBA Class Name

ZcadHatch

Methods

Name | Description
AppendInnerLoop | Append loops to the hatch
AppendOuterLoop | Append loops to the hatch
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
Evaluate | Evaluate the hatch
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetLoopAt | Get loops at given index of the hatch
Highlight | Highlights the entity object.
InsertLoopAt | Insert loops at given index to the hatch
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
SetPattern | Set Pattern Type and Name of the hatch
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Area | Specifies the area of the hatch entity
AssociativeHatch | Determines whether the hatch is associative or not
Database | Returns the database object.
Document | Returns the document object.
Elevation | Specifies the elevation of the hatch
GradientAngle | Specifies the gradient angle
GradientCentered | Determines whether the gradient is centered or not
GradientColor1 | Specifies the gradient start color
GradientColor2 | Specifies the gradient end color
GradientName | Specifies the pattern name of the gradient
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
HatchObjectType | Sets the type of the hatch
HatchStyle | Sets the style of the hatch
Hyperlinks | Specifies the hyperlink collection for the object.
ISOPenWidth | Specifies the ISO pen width of an ISO hatch pattern
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
NumberOfLoops | Specifies the number of loops in the hatch boundary
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
Origin | Specifies the origin coordinates for the pattern of the hatch entity
OwnerID | Returns the OwnerID of the object.
PatternAngle | Specifies the pattern angle of the hatch
PatternDouble | Determines whether the hatch pattern is double or not
PatternName | Specifies the pattern name of the hatch
PatternScale | Specifies the pattern scale of the hatch
PatternSpace | Specifies the pattern space of the hatch
PatternType | Specifies the pattern type of the hatch
PlotStyleName | Specifies the plotstyle name for the object.
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Hatch.AppendInnerLoop Method

Append loops to the hatch

Syntax

object.AppendInnerLoop(ObjectArray)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
ObjectArray | Input-only | Variant | -

Examples...

AppendInnerLoop Method example


Hatch.AppendOuterLoop Method

Append loops to the hatch

Syntax

object.AppendOuterLoop(ObjectArray)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
ObjectArray | Input-only | Variant | -

Examples...

AppendOuterLoop Method example


Hatch.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Hatch.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Hatch.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Hatch object.

Return value

Object

Examples...

Copy Method example


Hatch.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Hatch object.

Examples...

Delete Method example


Hatch.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Hatch object.

Examples...

Erase Method example


Hatch.Evaluate Method

Evaluate the hatch

Syntax

object.Evaluate

object is a Hatch object.


Hatch.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Hatch.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Hatch object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Hatch.GetLoopAt Method

Get loops at given index of the hatch

Syntax

object.GetLoopAt(Index, ObjectArray)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
ObjectArray | Output-only | Variant | -


Hatch.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Hatch.InsertLoopAt Method

Insert loops at given index to the hatch

Syntax

object.InsertLoopAt(Index, LoopType, ObjectArray)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
LoopType | Input-only | ZcLoopType | Can be one of the constants listed here: zcHatchLoopTypeDefault zcHatchLoopTypeExternal zcHatchLoopTypePolyline zcHatchLoopTypeDerived zcHatchLoopTypeTextbox
ObjectArray | Input-only | Variant | -


Hatch.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Hatch.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Hatch.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Hatch.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Hatch.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Hatch.SetPattern Method

Set Pattern Type and Name of the hatch

Syntax

object.SetPattern(PatternType, PatternName)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
PatternType | Input-only | Integer | -
PatternName | Input-only | String | -

Examples...

SetPattern Method example


Hatch.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Hatch.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Hatch object.


Hatch.Application Property

Returns the application object.

Syntax

object.Application

object is a Hatch object.

Description

Application Object; Read-only

Examples...

Application Property example


Hatch.Area Property

Specifies the area of the hatch entity

Syntax

object.Area

object is a Hatch object.

Description

Area Double; Read-only

Examples...

Area Property example


Hatch.AssociativeHatch Property

Determines whether the hatch is associative or not

Syntax

object.AssociativeHatch

object is a Hatch object.

Description

AssociativeHatch Boolean; Read-write

Examples...

AssociativeHatch Property example


Hatch.Database Property

Returns the database object.

Syntax

object.Database

object is a Hatch object.

Description

Database Database; Read-only


Hatch.Document Property

Returns the document object.

Syntax

object.Document

object is a Hatch object.

Description

Document Object; Read-only


Hatch.Elevation Property

Specifies the elevation of the hatch

Syntax

object.Elevation

object is a Hatch object.

Description

Elevation Double; Read-write


Hatch.GradientAngle Property

Specifies the gradient angle

Syntax

object.GradientAngle

object is a Hatch object.

Description

GradientAngle ZCAD_ANGLE: alias for Double; Read-write


Hatch.GradientCentered Property

Determines whether the gradient is centered or not

Syntax

object.GradientCentered

object is a Hatch object.

Description

GradientCentered Boolean; Read-write


Hatch.GradientColor1 Property

Specifies the gradient start color

Syntax

object.GradientColor1

object is a Hatch object.

Description

GradientColor1 ZcCmColor; Read-write


Hatch.GradientColor2 Property

Specifies the gradient end color

Syntax

object.GradientColor2

object is a Hatch object.

Description

GradientColor2 ZcCmColor; Read-write


Hatch.GradientName Property

Specifies the pattern name of the gradient

Syntax

object.GradientName

object is a Hatch object.

Description

GradientName String; Read-write


Hatch.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Hatch object.

Description

Handle String; Read-only


Hatch.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Hatch object.

Description

HasExtensionDictionary Boolean; Read-only


Hatch.HatchObjectType Property

Sets the type of the hatch

Syntax

object.HatchObjectType

object is a Hatch object.

Description

HatchObjectType ZcHatchObjectType: Read-write
Can be one of the constants listed here:
zcHatchObject
zcGradientObject


Hatch.HatchStyle Property

Sets the style of the hatch

Syntax

object.HatchStyle

object is a Hatch object.

Description

HatchStyle ZcHatchStyle: Read-write
Can be one of the constants listed here:
zcHatchStyleNormal
zcHatchStyleOuter
zcHatchStyleIgnore


Hatch.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Hatch object.

Description

Hyperlinks Hyperlinks; Read-only


Hatch.ISOPenWidth Property

Specifies the ISO pen width of an ISO hatch pattern

Syntax

object.ISOPenWidth

object is a Hatch object.

Description

ISOPenWidth ZcISOPenWidth: Read-write
Can be one of the constants listed here:
zcPenWidth013
zcPenWidth018
zcPenWidth025
zcPenWidth035
zcPenWidth050
zcPenWidth070
zcPenWidth100
zcPenWidth140
zcPenWidth200
zcPenWidthUnk


Hatch.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Hatch object.

Description

Layer String; Read-write

Examples...

Layer Property example


Hatch.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Hatch object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Hatch.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Hatch object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Hatch.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Hatch object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Hatch.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a Hatch object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Hatch.NumberOfLoops Property

Specifies the number of loops in the hatch boundary

Syntax

object.NumberOfLoops

object is a Hatch object.

Description

NumberOfLoops Long; Read-only


Hatch.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Hatch object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Hatch.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Hatch object.

Description

ObjectName String; Read-only


Hatch.Origin Property

Specifies the origin coordinates for the pattern of the hatch entity

Syntax

object.Origin

object is a Hatch object.

Description

Origin Variant; Read-write

Examples...

Origin Property example


Hatch.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Hatch object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Hatch.PatternAngle Property

Specifies the pattern angle of the hatch

Syntax

object.PatternAngle

object is a Hatch object.

Description

PatternAngle ZCAD_ANGLE: alias for Double; Read-write

Examples...

PatternAngle Property example


Hatch.PatternDouble Property

Determines whether the hatch pattern is double or not

Syntax

object.PatternDouble

object is a Hatch object.

Description

PatternDouble Boolean; Read-write


Hatch.PatternName Property

Specifies the pattern name of the hatch

Syntax

object.PatternName

object is a Hatch object.

Description

PatternName String; Read-only

Examples...

PatternName Property example


Hatch.PatternScale Property

Specifies the pattern scale of the hatch

Syntax

object.PatternScale

object is a Hatch object.

Description

PatternScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

PatternScale Property example


Hatch.PatternSpace Property

Specifies the pattern space of the hatch

Syntax

object.PatternSpace

object is a Hatch object.

Description

PatternSpace Double; Read-write

Examples...

PatternSpace Property example


Hatch.PatternType Property

Specifies the pattern type of the hatch

Syntax

object.PatternType

object is a Hatch object.

Description

PatternType ZcPatternType: Read-only
Can be one of the constants listed here:
zcHatchPatternTypeUserDefined
zcHatchPatternTypePreDefined
zcHatchPatternTypeCustomDefined

Examples...

PatternType Property example


Hatch.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Hatch object.

Description

PlotStyleName String; Read-write


Hatch.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Hatch object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Hatch.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Hatch object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Hatch.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Hatch object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadHyperlink Object Members

Hyperlink Object Members

object A URL and URL description.

VBA Class Name

ZcadHyperlink

Methods

Name | Description
Delete | Deletes the hyperlink.

Properties

Name | Description
Application | Specifies the application object.
URL | Specifies the URL for the Hyperlink.
URLDescription | Specifies the URL description for the Hyperlink.
URLNamedLocation | Returns and sets the named location of the hyperlink.

Events

Name | Description
None | -


Hyperlink.Delete Method

Deletes the hyperlink.

Syntax

object.Delete

object is a Hyperlink object.

Examples...

Delete Method example


Hyperlink.Application Property

Specifies the application object.

Syntax

object.Application

object is a Hyperlink object.

Description

Application Object; Read-only

Examples...

Application Property example


Hyperlink.URL Property

Specifies the URL for the Hyperlink.

Syntax

object.URL

object is a Hyperlink object.

Description

URL String; Read-write

Examples...

URL Property example


Hyperlink.URLDescription Property

Specifies the URL description for the Hyperlink.

Syntax

object.URLDescription

object is a Hyperlink object.

Description

URLDescription String; Read-write

Examples...

URLDescription Property example


Hyperlink.URLNamedLocation Property

Returns and sets the named location of the hyperlink.

Syntax

object.URLNamedLocation

object is a Hyperlink object.

Description

URLNamedLocation String; Read-write

Examples...

URLNamedLocation Property example


ZcadIdPair Object Members

IdPair Object Members

A special object for use with the CopyObjects method that contains the object IDs of both the source and destination objects.

VBA Class Name

ZcadIdPair

Methods

Name | Description
None | -

Properties

Name | Description
Application | Specifies the application object.
IsCloned | Returns true if the key object has been cloned.
IsOwnerXlated | Returns true if the owner has been translated.
IsPrimary | Returns true if the key object is part of the primary set of objects cloned.
Value | Returns the object id of the cloned object.

Events

Name | Description
None | -


IdPair.Application Property

Specifies the application object.

Syntax

object.Application

object is a IdPair object.

Description

Application Object; Read-only

Examples...

Application Property example


IdPair.IsCloned Property

Returns true if the key object has been cloned.

Syntax

object.IsCloned

object is a IdPair object.

Description

IsCloned Boolean; Read-only


IdPair.IsOwnerXlated Property

Returns true if the owner has been translated.

Syntax

object.IsOwnerXlated

object is a IdPair object.

Description

IsOwnerXlated Boolean; Read-only


IdPair.IsPrimary Property

Returns true if the key object is part of the primary set of objects cloned.

Syntax

object.IsPrimary

object is a IdPair object.

Description

IsPrimary Boolean; Read-only


IdPair.Value Property

Returns the object id of the cloned object.

Syntax

object.Value

object is a IdPair object.

Description

Value LONG_PTR: alias for Long; Read-only


ZcadLWPolyline Object Members

LWPolyline Object Members

A 2D line with adjustable width composed of line and arc segments.

VBA Class Name

ZcadLWPolyline

Methods

Name | Description
AddVertex | Adds a vertex to the lightweight polyline
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
Explode | Explodes the lightweight polyline, and returns the sub-entities as an array of Object
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetBulge | Returns the vertex bulge of the lightweight polyline
GetExtensionDictionary | Returns the extension dictionary for the object.
GetWidth | Returns segment width of the lightweight polyline
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Offset | Creates a new entity object by offsetting the lightweight polyline by a given distance
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
SetBulge | Sets the vertex bulge of the lightweight polyline
SetWidth | Sets the segment width of the lightweight polyline
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Area | Specifies the area of the lightweight polyline
Closed | Specifies Closed or Open polyine
ConstantWidth | Specifies the constant width for the polyline
Coordinate | Sets the coordinate of the vertex at a given index
Coordinates | Specifies the current vertex of the lightweight polyline
Database | Returns the database object.
Document | Returns the document object.
Elevation | Specifies the elevation of the polyline (Z coordinate of current vertex)
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Length | Specifies the length of the lightweight polyline
Linetype | Specifies the linetype of the object.
LinetypeGeneration | Determines whether linetype generation is Enabled or Disabled for the polyline
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Thickness | Specifies the thickness of the lightweight polyline
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


LWPolyline.AddVertex Method

Adds a vertex to the lightweight polyline

Syntax

object.AddVertex(Index, vertex)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
vertex | Input-only | Variant | -

Examples...

AddVertex Method example


LWPolyline.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


LWPolyline.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


LWPolyline.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a LWPolyline object.

Return value

Object

Examples...

Copy Method example


LWPolyline.Delete Method

Deletes the object.

Syntax

object.Delete

object is a LWPolyline object.

Examples...

Delete Method example


LWPolyline.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a LWPolyline object.

Examples...

Erase Method example


LWPolyline.Explode Method

Explodes the lightweight polyline, and returns the sub-entities as an array of Object

Syntax

object.Explode

object is a LWPolyline object.

Return value

Variant

Examples...

Explode Method example


LWPolyline.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


LWPolyline.GetBulge Method

Returns the vertex bulge of the lightweight polyline

Syntax

object.GetBulge(Index)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -

Return value

Double

Examples...

GetBulge Method example


LWPolyline.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a LWPolyline object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


LWPolyline.GetWidth Method

Returns segment width of the lightweight polyline

Syntax

object.GetWidth(Index, StartWidth, EndWidth)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
StartWidth | Output-only | Double | -
EndWidth | Output-only | Double | -

Examples...

GetWidth Method example


LWPolyline.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


LWPolyline.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


LWPolyline.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


LWPolyline.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


LWPolyline.Offset Method

Creates a new entity object by offsetting the lightweight polyline by a given distance

Syntax

object.Offset(Distance)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
Distance | Input-only | Double | -

Return value

Variant


LWPolyline.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


LWPolyline.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


LWPolyline.SetBulge Method

Sets the vertex bulge of the lightweight polyline

Syntax

object.SetBulge(Index, bulge)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
bulge | Input-only | Double | -

Examples...

SetBulge Method example


LWPolyline.SetWidth Method

Sets the segment width of the lightweight polyline

Syntax

object.SetWidth(Index, StartWidth, EndWidth)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
StartWidth | Input-only | Double | -
EndWidth | Input-only | Double | -

Examples...

SetWidth Method example


LWPolyline.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


LWPolyline.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a LWPolyline object.


LWPolyline.Application Property

Returns the application object.

Syntax

object.Application

object is a LWPolyline object.

Description

Application Object; Read-only

Examples...

Application Property example


LWPolyline.Area Property

Specifies the area of the lightweight polyline

Syntax

object.Area

object is a LWPolyline object.

Description

Area Double; Read-only

Examples...

Area Property example


LWPolyline.Closed Property

Specifies Closed or Open polyine

Syntax

object.Closed

object is a LWPolyline object.

Description

Closed Boolean; Read-write

Examples...

Closed Property example


LWPolyline.ConstantWidth Property

Specifies the constant width for the polyline

Syntax

object.ConstantWidth

object is a LWPolyline object.

Description

ConstantWidth Double; Read-write

Examples...

ConstantWidth Property example


LWPolyline.Coordinate Property

Sets the coordinate of the vertex at a given index

Syntax

object.Coordinate

object is a LWPolyline object.

Description

Coordinate Variant; Read-write

Examples...

Coordinate Property example


LWPolyline.Coordinates Property

Specifies the current vertex of the lightweight polyline

Syntax

object.Coordinates

object is a LWPolyline object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


LWPolyline.Database Property

Returns the database object.

Syntax

object.Database

object is a LWPolyline object.

Description

Database Database; Read-only


LWPolyline.Document Property

Returns the document object.

Syntax

object.Document

object is a LWPolyline object.

Description

Document Object; Read-only


LWPolyline.Elevation Property

Specifies the elevation of the polyline (Z coordinate of current vertex)

Syntax

object.Elevation

object is a LWPolyline object.

Description

Elevation Double; Read-write


LWPolyline.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a LWPolyline object.

Description

Handle String; Read-only


LWPolyline.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a LWPolyline object.

Description

HasExtensionDictionary Boolean; Read-only


LWPolyline.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a LWPolyline object.

Description

Hyperlinks Hyperlinks; Read-only


LWPolyline.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a LWPolyline object.

Description

Layer String; Read-write

Examples...

Layer Property example


LWPolyline.Length Property

Specifies the length of the lightweight polyline

Syntax

object.Length

object is a LWPolyline object.

Description

Length Double; Read-only

Examples...

Length Property example


LWPolyline.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a LWPolyline object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


LWPolyline.LinetypeGeneration Property

Determines whether linetype generation is Enabled or Disabled for the polyline

Syntax

object.LinetypeGeneration

object is a LWPolyline object.

Description

LinetypeGeneration Boolean; Read-write

Examples...

LinetypeGeneration Property example


LWPolyline.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a LWPolyline object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


LWPolyline.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a LWPolyline object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


LWPolyline.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a LWPolyline object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


LWPolyline.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a LWPolyline object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


LWPolyline.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a LWPolyline object.

Description

ObjectName String; Read-only


LWPolyline.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a LWPolyline object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


LWPolyline.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a LWPolyline object.

Description

PlotStyleName String; Read-write


LWPolyline.Thickness Property

Specifies the thickness of the lightweight polyline

Syntax

object.Thickness

object is a LWPolyline object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


LWPolyline.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a LWPolyline object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


LWPolyline.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a LWPolyline object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


LWPolyline.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a LWPolyline object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadLayer Object Members

Layer Object Members

A logical grouping of data, similar to transparent acetate overlays on a drawing.

VBA Class Name

ZcadLayer

Methods

Name | Description
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Description | Returns and sets the description of the layer.
Document | Returns the document object.
Freeze | Freezes or thaws the layer.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
LayerOn | Turns the layer on or off.
Linetype | Returns and sets the linetype of the layer.
Lineweight | Specifies the lineweight for the object.
Lock | Locks or unlocks the layer.
Name | Returns and sets the name of the layer.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Plottable | Specifies wether the layer is plottable.
TrueColor | Returns and sets the color of the layer.
Used | returns whether the layer is in use. See GenerateUsageData.
ViewportDefault | Returns and sets whether to freeze the layer in new viewports.

Events

Name | Description
Modified | Happens when object is modified


Layer.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Layer object.

Examples...

Delete Method example


Layer.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Layer object.

Examples...

Erase Method example


Layer.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Layer object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Layer.Application Property

Returns the application object.

Syntax

object.Application

object is a Layer object.

Description

Application Object; Read-only

Examples...

Application Property example


Layer.Database Property

Returns the database object.

Syntax

object.Database

object is a Layer object.

Description

Database Database; Read-only


Layer.Description Property

Returns and sets the description of the layer.

Syntax

object.Description

object is a Layer object.

Description

Description String; Read-write


Layer.Document Property

Returns the document object.

Syntax

object.Document

object is a Layer object.

Description

Document Object; Read-only


Layer.Freeze Property

Freezes or thaws the layer.

Syntax

object.Freeze

object is a Layer object.

Description

Freeze Boolean; Read-write


Layer.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Layer object.

Description

Handle String; Read-only


Layer.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Layer object.

Description

HasExtensionDictionary Boolean; Read-only


Layer.LayerOn Property

Turns the layer on or off.

Syntax

object.LayerOn

object is a Layer object.

Description

LayerOn Boolean; Read-write

Examples...

LayerOn Property example


Layer.Linetype Property

Returns and sets the linetype of the layer.

Syntax

object.Linetype

object is a Layer object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Layer.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Layer object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Layer.Lock Property

Locks or unlocks the layer.

Syntax

object.Lock

object is a Layer object.

Description

Lock Boolean; Read-write

Examples...

Lock Property example


Layer.Name Property

Returns and sets the name of the layer.

Syntax

object.Name

object is a Layer object.

Description

Name String; Read-write

Examples...

Name Property example


Layer.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Layer object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Layer.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Layer object.

Description

ObjectName String; Read-only


Layer.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Layer object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Layer.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Layer object.

Description

PlotStyleName String; Read-write


Layer.Plottable Property

Specifies wether the layer is plottable.

Syntax

object.Plottable

object is a Layer object.

Description

Plottable Boolean; Read-write

Examples...

Plottable Property example


Layer.TrueColor Property

Returns and sets the color of the layer.

Syntax

object.TrueColor

object is a Layer object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Layer.Used Property

returns whether the layer is in use. See GenerateUsageData.

Syntax

object.Used

object is a Layer object.

Description

Used Boolean; Read-only

Examples...

Used Property example


Layer.ViewportDefault Property

Returns and sets whether to freeze the layer in new viewports.

Syntax

object.ViewportDefault

object is a Layer object.

Description

ViewportDefault Boolean; Read-write


Layer.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Layer object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadLayerStateManager Object Members

LayerStateManager Object Members

Saves and restores layer settings.

VBA Class Name

ZcadLayerStateManager

Methods

Name | Description
Delete | Deletes the specified layer state.
Export | Exports the specified layer state to the specified file.
Import | Imports all layer states from the specified file.
Rename | Renames the specified layer state.
Restore | Restores the layers to the specified state as per the layer state mask.
Save | Saves the attribute mask and the state of all layers into the specified layer state.
SetDatabase | Sets the working database.

Properties

Name | Description
Mask | Sets the mask used for restoring the specified layer state.

Events

Name | Description
None | -


LayerStateManager.Delete Method

Deletes the specified layer state.

Syntax

object.Delete(bsName)

object is a LayerStateManager object.

Parameters

Name | Options | Data Type | Description
bsName | Input-only | String | -

Examples...

Delete Method example


LayerStateManager.Export Method

Exports the specified layer state to the specified file.

Syntax

object.Export(bsName, bsFilename)

object is a LayerStateManager object.

Parameters

Name | Options | Data Type | Description
bsName | Input-only | String | -
bsFilename | Input-only | String | -

Examples...

Export Method example


LayerStateManager.Import Method

Imports all layer states from the specified file.

Syntax

object.Import(bsFilename)

object is a LayerStateManager object.

Parameters

Name | Options | Data Type | Description
bsFilename | Input-only | String | -

Examples...

Import Method example


LayerStateManager.Rename Method

Renames the specified layer state.

Syntax

object.Rename(bsName, bsNewName)

object is a LayerStateManager object.

Parameters

Name | Options | Data Type | Description
bsName | Input-only | String | -
bsNewName | Input-only | String | -


LayerStateManager.Restore Method

Restores the layers to the specified state as per the layer state mask.

Syntax

object.Restore(bsName)

object is a LayerStateManager object.

Parameters

Name | Options | Data Type | Description
bsName | Input-only | String | -


LayerStateManager.Save Method

Saves the attribute mask and the state of all layers into the specified layer state.

Syntax

object.Save(bsName, eMask)

object is a LayerStateManager object.

Parameters

Name | Options | Data Type | Description
bsName | Input-only | String | -
eMask | Input-only | ZcLayerStateMask | Can be one of the constants listed here: zcLsNone zcLsOn zcLsFrozen zcLsLocked zcLsPlot zcLsNewViewport zcLsColor zcLsLineType zcLsLineWeight zcLsPlotStyle zcLsAll

Examples...

Save Method example


LayerStateManager.SetDatabase Method

Sets the working database.

Syntax

object.SetDatabase(iHostDb)

object is a LayerStateManager object.

Parameters

Name | Options | Data Type | Description
iHostDb | Input-only | Database | -


LayerStateManager.Mask Property

Sets the mask used for restoring the specified layer state.

Syntax

object.Mask

object is a LayerStateManager object.

Description

Mask ZcLayerStateMask: Read-write
Can be one of the constants listed here:
zcLsNone
zcLsOn
zcLsFrozen
zcLsLocked
zcLsPlot
zcLsNewViewport
zcLsColor
zcLsLineType
zcLsLineWeight
zcLsPlotStyle
zcLsAll


ZcadLayers Object Members

Layers Object Members

The collection of all layers in the drawing.

VBA Class Name

ZcadLayers

Methods

Name | Description
Add | Adds a layer to the layers collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GenerateUsageData | Generates layer usage data. See also Used property of Layer.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


Layers.Add Method

Adds a layer to the layers collection.

Syntax

object.Add(Name)

object is a Layers object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

Layer

Examples...

Add Method example


Layers.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Layers object.

Examples...

Delete Method example


Layers.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Layers object.

Examples...

Erase Method example


Layers.GenerateUsageData Method

Generates layer usage data. See also Used property of Layer.

Syntax

object.GenerateUsageData

object is a Layers object.

Examples...

GenerateUsageData Method example


Layers.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Layers object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Layers.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a Layers object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Layer

Examples...

Item Method example


Layers.Application Property

Returns the application object.

Syntax

object.Application

object is a Layers object.

Description

Application Object; Read-only

Examples...

Application Property example


Layers.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a Layers object.

Description

Count Long; Read-only

Examples...

Count Property example


Layers.Database Property

Returns the database object.

Syntax

object.Database

object is a Layers object.

Description

Database Database; Read-only


Layers.Document Property

Returns the document object.

Syntax

object.Document

object is a Layers object.

Description

Document Object; Read-only


Layers.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Layers object.

Description

Handle String; Read-only


Layers.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Layers object.

Description

HasExtensionDictionary Boolean; Read-only


Layers.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Layers object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Layers.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Layers object.

Description

ObjectName String; Read-only


Layers.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Layers object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Layers.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Layers object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadLayout Object Members

Layout Object Members

The plot settings and visual properties of a model space or paper space block.

VBA Class Name

ZcadLayout

Methods

Name | Description
CopyFrom | Copies the settings from the given plot configuration.
Delete | Deletes the object.
Erase | Erases the entity object.
GetCanonicalMediaNames | Gets all available canonical media names for the specified plot device.
GetCustomScale | Returns the custom scale.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetLocaleMediaName | Gets the localized version of the canonical media name.
GetPaperMargins | Returns the paper margins.
GetPaperSize | Returns the paper size.
GetPlotDeviceNames | Gets all available plot device names.
GetPlotStyleTableNames | Gets all available plot style table names.
GetWindowToPlot | Returns the window coordinates to plot.
RefreshPlotDeviceInfo | Updates the plot, canonical media, and plot style table information to reflect the current system state.
SetCustomScale | Sets the custom scale.
SetWindowToPlot | Sets the window coordinates to plot.

Properties

Name | Description
Application | Returns the application object.
Block | Returns the block object associated with this layout.
CanonicalMediaName | Returns and sets the canonical name of the selected media.
CenterPlot | Returns and sets centering of the plot on media.
ConfigName | Returns and sets the config name (PC3 name or system printer).
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ModelType | Specifies if the plot configuration applies only to model space or to all layouts
Name | Returns and sets the name of the plot configuration.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PaperUnits | Returns and sets the display units of the plot dimensions.
PlotHidden | Returns and sets hidden-line removal.
PlotOrigin | Returns and sets the origin relative to LLC of media.
PlotRotation | Returns and sets the image orientation on the media.
PlotType | Returns and sets plot type.
PlotViewportBorders | Returns and sets the plotting of viewport borders.
PlotViewportsFirst | Returns and sets the plotting of viewports first.
PlotWithLineweights | Returns and sets the plotting of lineweights.
PlotWithPlotStyles | Returns and sets the plotting of plot styles.
ScaleLineweights | Returns and sets the scaling of lineweights.
ShowPlotStyles | Returns and sets the display of plot styles.
StandardScale | Returns and sets the standard scale.
StyleSheet | Returns and sets style sheet to use.
TabOrder | Returns and sets the tab order for the layout.
UseStandardScale | Returns and sets using of standard or custom scale.
ViewToPlot | Returns and sets the view to plot.

Events

Name | Description
Modified | Happens when object is modified


Layout.CopyFrom Method

Copies the settings from the given plot configuration.

Syntax

object.CopyFrom(pPlotConfig)

object is a Layout object.

Parameters

Name | Options | Data Type | Description
pPlotConfig | Input-only | PlotConfiguration | -

Examples...

CopyFrom Method example


Layout.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Layout object.

Examples...

Delete Method example


Layout.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Layout object.

Examples...

Erase Method example


Layout.GetCanonicalMediaNames Method

Gets all available canonical media names for the specified plot device.

Syntax

object.GetCanonicalMediaNames

object is a Layout object.

Return value

Variant


Layout.GetCustomScale Method

Returns the custom scale.

Syntax

object.GetCustomScale(Numerator, Denominator)

object is a Layout object.

Parameters

Name | Options | Data Type | Description
Numerator | Output-only | Double | -
Denominator | Output-only | Double | -

Examples...

GetCustomScale Method example


Layout.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Layout object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Layout.GetLocaleMediaName Method

Gets the localized version of the canonical media name.

Syntax

object.GetLocaleMediaName(Name)

object is a Layout object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

String

Examples...

GetLocaleMediaName Method example


Layout.GetPaperMargins Method

Returns the paper margins.

Syntax

object.GetPaperMargins(LowerLeft, UpperRight)

object is a Layout object.

Parameters

Name | Options | Data Type | Description
LowerLeft | Output-only | Variant | -
UpperRight | Output-only | Variant | -

Examples...

GetPaperMargins Method example


Layout.GetPaperSize Method

Returns the paper size.

Syntax

object.GetPaperSize(Width, Height)

object is a Layout object.

Parameters

Name | Options | Data Type | Description
Width | Output-only | Double | -
Height | Output-only | Double | -

Examples...

GetPaperSize Method example


Layout.GetPlotDeviceNames Method

Gets all available plot device names.

Syntax

object.GetPlotDeviceNames

object is a Layout object.

Return value

Variant

Examples...

GetPlotDeviceNames Method example


Layout.GetPlotStyleTableNames Method

Gets all available plot style table names.

Syntax

object.GetPlotStyleTableNames

object is a Layout object.

Return value

Variant

Examples...

GetPlotStyleTableNames Method example


Layout.GetWindowToPlot Method

Returns the window coordinates to plot.

Syntax

object.GetWindowToPlot(LowerLeft, UpperRight)

object is a Layout object.

Parameters

Name | Options | Data Type | Description
LowerLeft | Output-only | Variant | -
UpperRight | Output-only | Variant | -

Examples...

GetWindowToPlot Method example


Layout.RefreshPlotDeviceInfo Method

Updates the plot, canonical media, and plot style table information to reflect the current system state.

Syntax

object.RefreshPlotDeviceInfo

object is a Layout object.

Examples...

RefreshPlotDeviceInfo Method example


Layout.SetCustomScale Method

Sets the custom scale.

Syntax

object.SetCustomScale(Numerator, Denominator)

object is a Layout object.

Parameters

Name | Options | Data Type | Description
Numerator | Input-only | Double | -
Denominator | Input-only | Double | -

Examples...

SetCustomScale Method example


Layout.SetWindowToPlot Method

Sets the window coordinates to plot.

Syntax

object.SetWindowToPlot(LowerLeft, UpperRight)

object is a Layout object.

Parameters

Name | Options | Data Type | Description
LowerLeft | Input-only | Variant | -
UpperRight | Input-only | Variant | -


Layout.Application Property

Returns the application object.

Syntax

object.Application

object is a Layout object.

Description

Application Object; Read-only

Examples...

Application Property example


Layout.Block Property

Returns the block object associated with this layout.

Syntax

object.Block

object is a Layout object.

Description

Block Block; Read-only

Examples...

Block Property example


Layout.CanonicalMediaName Property

Returns and sets the canonical name of the selected media.

Syntax

object.CanonicalMediaName

object is a Layout object.

Description

CanonicalMediaName String; Read-write

Examples...

CanonicalMediaName Property example


Layout.CenterPlot Property

Returns and sets centering of the plot on media.

Syntax

object.CenterPlot

object is a Layout object.

Description

CenterPlot Boolean; Read-write

Examples...

CenterPlot Property example


Layout.ConfigName Property

Returns and sets the config name (PC3 name or system printer).

Syntax

object.ConfigName

object is a Layout object.

Description

ConfigName String; Read-write

Examples...

ConfigName Property example


Layout.Database Property

Returns the database object.

Syntax

object.Database

object is a Layout object.

Description

Database Database; Read-only


Layout.Document Property

Returns the document object.

Syntax

object.Document

object is a Layout object.

Description

Document Object; Read-only


Layout.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Layout object.

Description

Handle String; Read-only


Layout.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Layout object.

Description

HasExtensionDictionary Boolean; Read-only


Layout.ModelType Property

Specifies if the plot configuration applies only to model space or to all layouts

Syntax

object.ModelType

object is a Layout object.

Description

ModelType Boolean; Read-only

Examples...

ModelType Property example


Layout.Name Property

Returns and sets the name of the plot configuration.

Syntax

object.Name

object is a Layout object.

Description

Name String; Read-write

Examples...

Name Property example


Layout.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Layout object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Layout.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Layout object.

Description

ObjectName String; Read-only


Layout.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Layout object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Layout.PaperUnits Property

Returns and sets the display units of the plot dimensions.

Syntax

object.PaperUnits

object is a Layout object.

Description

PaperUnits ZcPlotPaperUnits: Read-write
Can be one of the constants listed here:
zcInches
zcMillimeters
zcPixels

Examples...

PaperUnits Property example


Layout.PlotHidden Property

Returns and sets hidden-line removal.

Syntax

object.PlotHidden

object is a Layout object.

Description

PlotHidden Boolean; Read-write

Examples...

PlotHidden Property example


Layout.PlotOrigin Property

Returns and sets the origin relative to LLC of media.

Syntax

object.PlotOrigin

object is a Layout object.

Description

PlotOrigin Variant; Read-write

Examples...

PlotOrigin Property example


Layout.PlotRotation Property

Returns and sets the image orientation on the media.

Syntax

object.PlotRotation

object is a Layout object.

Description

PlotRotation ZcPlotRotation: Read-write
Can be one of the constants listed here:
zc0degrees
zc90degrees
zc180degrees
zc270degrees

Examples...

PlotRotation Property example


Layout.PlotType Property

Returns and sets plot type.

Syntax

object.PlotType

object is a Layout object.

Description

PlotType ZcPlotType: Read-write
Can be one of the constants listed here:
zcDisplay
zcExtents
zcLimits
zcView
zcWindow
zcLayout

Examples...

PlotType Property example


Layout.PlotViewportBorders Property

Returns and sets the plotting of viewport borders.

Syntax

object.PlotViewportBorders

object is a Layout object.

Description

PlotViewportBorders Boolean; Read-write

Examples...

PlotViewportBorders Property example


Layout.PlotViewportsFirst Property

Returns and sets the plotting of viewports first.

Syntax

object.PlotViewportsFirst

object is a Layout object.

Description

PlotViewportsFirst Boolean; Read-write

Examples...

PlotViewportsFirst Property example


Layout.PlotWithLineweights Property

Returns and sets the plotting of lineweights.

Syntax

object.PlotWithLineweights

object is a Layout object.

Description

PlotWithLineweights Boolean; Read-write

Examples...

PlotWithLineweights Property example


Layout.PlotWithPlotStyles Property

Returns and sets the plotting of plot styles.

Syntax

object.PlotWithPlotStyles

object is a Layout object.

Description

PlotWithPlotStyles Boolean; Read-write

Examples...

PlotWithPlotStyles Property example


Layout.ScaleLineweights Property

Returns and sets the scaling of lineweights.

Syntax

object.ScaleLineweights

object is a Layout object.

Description

ScaleLineweights Boolean; Read-write

Examples...

ScaleLineweights Property example


Layout.ShowPlotStyles Property

Returns and sets the display of plot styles.

Syntax

object.ShowPlotStyles

object is a Layout object.

Description

ShowPlotStyles Boolean; Read-write

Examples...

ShowPlotStyles Property example


Layout.StandardScale Property

Returns and sets the standard scale.

Syntax

object.StandardScale

object is a Layout object.

Description

StandardScale ZcPlotScale: Read-write
Can be one of the constants listed here:
zcScaleToFit
zc1_128in_1ft
zc1_64in_1ft
zc1_32in_1ft
zc1_16in_1ft
zc3_32in_1ft
zc1_8in_1ft
zc3_16in_1ft
zc1_4in_1ft
zc3_8in_1ft
zc1_2in_1ft
zc3_4in_1ft
zc1in_1ft
zc3in_1ft
zc6in_1ft
zc1ft_1ft
zc1_1
zc1_2
zc1_4
zc1_5
zc1_8
zc1_10
zc1_16
zc1_20
zc1_30
zc1_40
zc1_50
zc1_100
zc2_1
zc4_1
zc8_1
zc10_1
zc100_1

Examples...

StandardScale Property example


Layout.StyleSheet Property

Returns and sets style sheet to use.

Syntax

object.StyleSheet

object is a Layout object.

Description

StyleSheet String; Read-write

Examples...

StyleSheet Property example


Layout.TabOrder Property

Returns and sets the tab order for the layout.

Syntax

object.TabOrder

object is a Layout object.

Description

TabOrder Long; Read-write

Examples...

TabOrder Property example


Layout.UseStandardScale Property

Returns and sets using of standard or custom scale.

Syntax

object.UseStandardScale

object is a Layout object.

Description

UseStandardScale Boolean; Read-write

Examples...

UseStandardScale Property example


Layout.ViewToPlot Property

Returns and sets the view to plot.

Syntax

object.ViewToPlot

object is a Layout object.

Description

ViewToPlot String; Read-write


Layout.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Layout object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadLayouts Object Members

Layouts Object Members

The collection of all layouts in the drawing.

VBA Class Name

ZcadLayouts

Methods

Name | Description
Add | Adds a layout to the layout collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


Layouts.Add Method

Adds a layout to the layout collection.

Syntax

object.Add(Name)

object is a Layouts object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

Layout

Examples...

Add Method example


Layouts.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Layouts object.

Examples...

Delete Method example


Layouts.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Layouts object.

Examples...

Erase Method example


Layouts.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Layouts object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Layouts.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a Layouts object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Layout

Examples...

Item Method example


Layouts.Application Property

Returns the application object.

Syntax

object.Application

object is a Layouts object.

Description

Application Object; Read-only

Examples...

Application Property example


Layouts.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a Layouts object.

Description

Count Long; Read-only

Examples...

Count Property example


Layouts.Database Property

Returns the database object.

Syntax

object.Database

object is a Layouts object.

Description

Database Database; Read-only


Layouts.Document Property

Returns the document object.

Syntax

object.Document

object is a Layouts object.

Description

Document Object; Read-only


Layouts.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Layouts object.

Description

Handle String; Read-only


Layouts.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Layouts object.

Description

HasExtensionDictionary Boolean; Read-only


Layouts.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Layouts object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Layouts.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Layouts object.

Description

ObjectName String; Read-only


Layouts.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Layouts object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Layouts.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Layouts object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadLeader Object Members

Leader Object Members

An object composed of an arrowhead attached to splines or straight line segments.

VBA Class Name

ZcadLeader

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
Evaluate | Evaluate the leader
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Annotation | Specifies the annotation object for the leader
Application | Returns the application object.
ArrowheadBlock | Specifies the block of the leader arrowhead
ArrowheadSize | Specifies the size of the leader arrowhead
ArrowheadType | Specifies the type of the leader arrowhead
Coordinate | Returns the coordinate of the vertex at a given index
Coordinates | Specifies the coordinates of the leader
Database | Returns the database object.
DimensionLineColor | Specifies the color of the leader lines
DimensionLineWeight | Specifies the lineweight of the leader line
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Returns the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the style name of the leader
TextGap | Specifies the distance around the dimension text that the dimension line is broken
TrueColor | Returns the true color of the object.
Type | Specifies the type of the leader
VerticalTextPosition | Specifies the vertical dimension text position
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Leader.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Leader.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Leader.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Leader object.

Return value

Object

Examples...

Copy Method example


Leader.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Leader object.

Examples...

Delete Method example


Leader.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Leader object.

Examples...

Erase Method example


Leader.Evaluate Method

Evaluate the leader

Syntax

object.Evaluate

object is a Leader object.


Leader.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Leader.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Leader object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Leader.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Leader.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Leader.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Leader.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Leader.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Leader.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Leader.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Leader.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Leader object.


Leader.Annotation Property

Specifies the annotation object for the leader

Syntax

object.Annotation

object is a Leader object.

Description

Annotation Entity; Read-write

Examples...

Annotation Property example


Leader.Application Property

Returns the application object.

Syntax

object.Application

object is a Leader object.

Description

Application Object; Read-only

Examples...

Application Property example


Leader.ArrowheadBlock Property

Specifies the block of the leader arrowhead

Syntax

object.ArrowheadBlock

object is a Leader object.

Description

ArrowheadBlock String; Read-write


Leader.ArrowheadSize Property

Specifies the size of the leader arrowhead

Syntax

object.ArrowheadSize

object is a Leader object.

Description

ArrowheadSize Double; Read-write

Examples...

ArrowheadSize Property example


Leader.ArrowheadType Property

Specifies the type of the leader arrowhead

Syntax

object.ArrowheadType

object is a Leader object.

Description

ArrowheadType ZcDimArrowheadType: Read-write
Can be one of the constants listed here:
zcArrowDefault
zcArrowClosedBlank
zcArrowClosed
zcArrowDot
zcArrowArchTick
zcArrowOblique
zcArrowOpen
zcArrowOrigin
zcArrowOrigin2
zcArrowOpen90
zcArrowOpen30
zcArrowDotSmall
zcArrowDotBlank
zcArrowSmall
zcArrowBoxBlank
zcArrowBoxFilled
zcArrowDatumBlank
zcArrowDatumFilled
zcArrowIntegral
zcArrowNone
zcArrowUserDefined


Leader.Coordinate Property

Returns the coordinate of the vertex at a given index

Syntax

object.Coordinate

object is a Leader object.

Description

Coordinate Variant; Read-write

Examples...

Coordinate Property example


Leader.Coordinates Property

Specifies the coordinates of the leader

Syntax

object.Coordinates

object is a Leader object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


Leader.Database Property

Returns the database object.

Syntax

object.Database

object is a Leader object.

Description

Database Database; Read-only


Leader.DimensionLineColor Property

Specifies the color of the leader lines

Syntax

object.DimensionLineColor

object is a Leader object.

Description

DimensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


Leader.DimensionLineWeight Property

Specifies the lineweight of the leader line

Syntax

object.DimensionLineWeight

object is a Leader object.

Description

DimensionLineWeight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault


Leader.Document Property

Returns the document object.

Syntax

object.Document

object is a Leader object.

Description

Document Object; Read-only


Leader.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Leader object.

Description

Handle String; Read-only


Leader.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Leader object.

Description

HasExtensionDictionary Boolean; Read-only


Leader.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Leader object.

Description

Hyperlinks Hyperlinks; Read-only


Leader.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Leader object.

Description

Layer String; Read-write

Examples...

Layer Property example


Leader.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Leader object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Leader.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Leader object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Leader.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Leader object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Leader.Normal Property

Returns the normal direction vector

Syntax

object.Normal

object is a Leader object.

Description

Normal Variant; Read-only

Examples...

Normal Property example


Leader.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Leader object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Leader.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Leader object.

Description

ObjectName String; Read-only


Leader.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Leader object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Leader.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Leader object.

Description

PlotStyleName String; Read-write


Leader.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a Leader object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


Leader.StyleName Property

Specifies the style name of the leader

Syntax

object.StyleName

object is a Leader object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


Leader.TextGap Property

Specifies the distance around the dimension text that the dimension line is broken

Syntax

object.TextGap

object is a Leader object.

Description

TextGap Double; Read-write

Examples...

TextGap Property example


Leader.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Leader object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Leader.Type Property

Specifies the type of the leader

Syntax

object.Type

object is a Leader object.

Description

Type ZcLeaderType: Read-write
Can be one of the constants listed here:
zcLineNoArrow
zcSplineNoArrow
zcLineWithArrow
zcSplineWithArrow

Examples...

Type Property example


Leader.VerticalTextPosition Property

Specifies the vertical dimension text position

Syntax

object.VerticalTextPosition

object is a Leader object.

Description

VerticalTextPosition ZcDimVerticalJustification: Read-write
Can be one of the constants listed here:
zcVertCentered
zcAbove
zcOutside
zcJIS

Examples...

VerticalTextPosition Property example


Leader.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Leader object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Leader.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Leader object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadLine Object Members

Line Object Members

A single line segment.

VBA Class Name

ZcadLine

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Offset | Creates a new line by offsetting the current line by a specified distance
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Angle | Specifies the angle of the line
Application | Returns the application object.
Database | Returns the database object.
Delta | Specifies the delta of the line
Document | Returns the document object.
EndPoint | Specifies the end point of the line
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Length | Specifies the length of the line
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
StartPoint | Specifies the start point of the line
Thickness | Specifies the thickness of the line
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Line.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Line object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Line.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Line object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Line.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Line object.

Return value

Object

Examples...

Copy Method example


Line.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Line object.

Examples...

Delete Method example


Line.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Line object.

Examples...

Erase Method example


Line.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Line object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Line.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Line object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Line.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Line object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Line.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Line object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Line.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Line object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Line.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Line object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Line.Offset Method

Creates a new line by offsetting the current line by a specified distance

Syntax

object.Offset(Distance)

object is a Line object.

Parameters

Name | Options | Data Type | Description
Distance | Input-only | Double | -

Return value

Variant


Line.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Line object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Line.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Line object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Line.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Line object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Line.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Line object.


Line.Angle Property

Specifies the angle of the line

Syntax

object.Angle

object is a Line object.

Description

Angle ZCAD_ANGLE: alias for Double; Read-only

Examples...

Angle Property example


Line.Application Property

Returns the application object.

Syntax

object.Application

object is a Line object.

Description

Application Object; Read-only

Examples...

Application Property example


Line.Database Property

Returns the database object.

Syntax

object.Database

object is a Line object.

Description

Database Database; Read-only


Line.Delta Property

Specifies the delta of the line

Syntax

object.Delta

object is a Line object.

Description

Delta Variant; Read-only


Line.Document Property

Returns the document object.

Syntax

object.Document

object is a Line object.

Description

Document Object; Read-only


Line.EndPoint Property

Specifies the end point of the line

Syntax

object.EndPoint

object is a Line object.

Description

EndPoint Variant; Read-write


Line.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Line object.

Description

Handle String; Read-only


Line.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Line object.

Description

HasExtensionDictionary Boolean; Read-only


Line.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Line object.

Description

Hyperlinks Hyperlinks; Read-only


Line.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Line object.

Description

Layer String; Read-write

Examples...

Layer Property example


Line.Length Property

Specifies the length of the line

Syntax

object.Length

object is a Line object.

Description

Length Double; Read-only

Examples...

Length Property example


Line.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Line object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Line.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Line object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Line.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Line object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Line.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a Line object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Line.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Line object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Line.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Line object.

Description

ObjectName String; Read-only


Line.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Line object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Line.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Line object.

Description

PlotStyleName String; Read-write


Line.StartPoint Property

Specifies the start point of the line

Syntax

object.StartPoint

object is a Line object.

Description

StartPoint Variant; Read-write

Examples...

StartPoint Property example


Line.Thickness Property

Specifies the thickness of the line

Syntax

object.Thickness

object is a Line object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


Line.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Line object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Line.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Line object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Line.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Line object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadLineType Object Members

LineType Object Members

The line characteristics consisting of combinations of dashes, dots, and spaces.

VBA Class Name

ZcadLineType

Methods

Name | Description
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Description | Returns and sets the description of the linetype.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Name | Returns and sets the name of the linetype.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


LineType.Delete Method

Deletes the object.

Syntax

object.Delete

object is a LineType object.

Examples...

Delete Method example


LineType.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a LineType object.

Examples...

Erase Method example


LineType.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a LineType object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


LineType.Application Property

Returns the application object.

Syntax

object.Application

object is a LineType object.

Description

Application Object; Read-only

Examples...

Application Property example


LineType.Database Property

Returns the database object.

Syntax

object.Database

object is a LineType object.

Description

Database Database; Read-only


LineType.Description Property

Returns and sets the description of the linetype.

Syntax

object.Description

object is a LineType object.

Description

Description String; Read-write


LineType.Document Property

Returns the document object.

Syntax

object.Document

object is a LineType object.

Description

Document Object; Read-only


LineType.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a LineType object.

Description

Handle String; Read-only


LineType.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a LineType object.

Description

HasExtensionDictionary Boolean; Read-only


LineType.Name Property

Returns and sets the name of the linetype.

Syntax

object.Name

object is a LineType object.

Description

Name String; Read-write

Examples...

Name Property example


LineType.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a LineType object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


LineType.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a LineType object.

Description

ObjectName String; Read-only


LineType.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a LineType object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


LineType.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a LineType object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadLineTypes Object Members

LineTypes Object Members

The collection of all linetypes in the drawing.

VBA Class Name

ZcadLineTypes

Methods

Name | Description
Add | Adds a linetype to the linetypes collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.
Load | Loads the definition of a linetype from a file.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


LineTypes.Add Method

Adds a linetype to the linetypes collection.

Syntax

object.Add(Name)

object is a LineTypes object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

LineType

Examples...

Add Method example


LineTypes.Delete Method

Deletes the object.

Syntax

object.Delete

object is a LineTypes object.

Examples...

Delete Method example


LineTypes.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a LineTypes object.

Examples...

Erase Method example


LineTypes.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a LineTypes object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


LineTypes.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a LineTypes object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

LineType

Examples...

Item Method example


LineTypes.Load Method

Loads the definition of a linetype from a file.

Syntax

object.Load(Name, FileName)

object is a LineTypes object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -
FileName | Input-only | String | -

Examples...

Load Method example


LineTypes.Application Property

Returns the application object.

Syntax

object.Application

object is a LineTypes object.

Description

Application Object; Read-only

Examples...

Application Property example


LineTypes.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a LineTypes object.

Description

Count Long; Read-only

Examples...

Count Property example


LineTypes.Database Property

Returns the database object.

Syntax

object.Database

object is a LineTypes object.

Description

Database Database; Read-only


LineTypes.Document Property

Returns the document object.

Syntax

object.Document

object is a LineTypes object.

Description

Document Object; Read-only


LineTypes.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a LineTypes object.

Description

Handle String; Read-only


LineTypes.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a LineTypes object.

Description

HasExtensionDictionary Boolean; Read-only


LineTypes.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a LineTypes object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


LineTypes.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a LineTypes object.

Description

ObjectName String; Read-only


LineTypes.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a LineTypes object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


LineTypes.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a LineTypes object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadMInsertBlock Object Members

MInsertBlock Object Members

A rectangular array of block references.

VBA Class Name

ZcadMInsertBlock

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
Explode | Explodes the block and returns the sub-entities as an array of Object
GetAttributes | Gets Attributes in the block
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetConstantAttributes | Gets constant attributes in the block
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
ColumnSpacing | Specifies the column spacing in the block array
Columns | Specifies the number of columns in the block array
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasAttributes | Returns whether the block has any attributes in it
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
InsUnits | Specifies insunits saved with the block
InsUnitsFactor | Specifies the conversion factor between block units and drawing units
InsertionPoint | Specifies X, Y, and Z coordinates for insertion point of the block
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Name | Specifies the name of the block
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Specifies the rotation angle of the block
RowSpacing | Specifies the row spacing in the block array
Rows | Determines the number of columns in the block array
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.
XScaleFactor | Specifies the XScale factor of the block
YScaleFactor | Specifies the Yscale factor of the block
ZScaleFactor | Specifies the ZScale factor of the block

Events

Name | Description
Modified | Happens when object is modified


MInsertBlock.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


MInsertBlock.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


MInsertBlock.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a MInsertBlock object.

Return value

Object

Examples...

Copy Method example


MInsertBlock.Delete Method

Deletes the object.

Syntax

object.Delete

object is a MInsertBlock object.

Examples...

Delete Method example


MInsertBlock.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a MInsertBlock object.

Examples...

Erase Method example


MInsertBlock.Explode Method

Explodes the block and returns the sub-entities as an array of Object

Syntax

object.Explode

object is a MInsertBlock object.

Return value

Variant

Examples...

Explode Method example


MInsertBlock.GetAttributes Method

Gets Attributes in the block

Syntax

object.GetAttributes

object is a MInsertBlock object.

Return value

Variant

Examples...

GetAttributes Method example


MInsertBlock.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


MInsertBlock.GetConstantAttributes Method

Gets constant attributes in the block

Syntax

object.GetConstantAttributes

object is a MInsertBlock object.

Return value

Variant

Examples...

GetConstantAttributes Method example


MInsertBlock.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a MInsertBlock object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


MInsertBlock.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


MInsertBlock.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


MInsertBlock.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


MInsertBlock.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


MInsertBlock.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


MInsertBlock.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


MInsertBlock.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


MInsertBlock.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a MInsertBlock object.


MInsertBlock.Application Property

Returns the application object.

Syntax

object.Application

object is a MInsertBlock object.

Description

Application Object; Read-only

Examples...

Application Property example


MInsertBlock.ColumnSpacing Property

Specifies the column spacing in the block array

Syntax

object.ColumnSpacing

object is a MInsertBlock object.

Description

ColumnSpacing Double; Read-write


MInsertBlock.Columns Property

Specifies the number of columns in the block array

Syntax

object.Columns

object is a MInsertBlock object.

Description

Columns Long; Read-write


MInsertBlock.Database Property

Returns the database object.

Syntax

object.Database

object is a MInsertBlock object.

Description

Database Database; Read-only


MInsertBlock.Document Property

Returns the document object.

Syntax

object.Document

object is a MInsertBlock object.

Description

Document Object; Read-only


MInsertBlock.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a MInsertBlock object.

Description

Handle String; Read-only


MInsertBlock.HasAttributes Property

Returns whether the block has any attributes in it

Syntax

object.HasAttributes

object is a MInsertBlock object.

Description

HasAttributes Boolean; Read-only


MInsertBlock.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a MInsertBlock object.

Description

HasExtensionDictionary Boolean; Read-only


MInsertBlock.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a MInsertBlock object.

Description

Hyperlinks Hyperlinks; Read-only


MInsertBlock.InsUnits Property

Specifies insunits saved with the block

Syntax

object.InsUnits

object is a MInsertBlock object.

Description

InsUnits String; Read-only


MInsertBlock.InsUnitsFactor Property

Specifies the conversion factor between block units and drawing units

Syntax

object.InsUnitsFactor

object is a MInsertBlock object.

Description

InsUnitsFactor Double; Read-only


MInsertBlock.InsertionPoint Property

Specifies X, Y, and Z coordinates for insertion point of the block

Syntax

object.InsertionPoint

object is a MInsertBlock object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


MInsertBlock.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a MInsertBlock object.

Description

Layer String; Read-write

Examples...

Layer Property example


MInsertBlock.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a MInsertBlock object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


MInsertBlock.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a MInsertBlock object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


MInsertBlock.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a MInsertBlock object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


MInsertBlock.Name Property

Specifies the name of the block

Syntax

object.Name

object is a MInsertBlock object.

Description

Name String; Read-write

Examples...

Name Property example


MInsertBlock.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a MInsertBlock object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


MInsertBlock.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a MInsertBlock object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


MInsertBlock.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a MInsertBlock object.

Description

ObjectName String; Read-only


MInsertBlock.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a MInsertBlock object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


MInsertBlock.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a MInsertBlock object.

Description

PlotStyleName String; Read-write


MInsertBlock.Rotation Property

Specifies the rotation angle of the block

Syntax

object.Rotation

object is a MInsertBlock object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


MInsertBlock.RowSpacing Property

Specifies the row spacing in the block array

Syntax

object.RowSpacing

object is a MInsertBlock object.

Description

RowSpacing Double; Read-write


MInsertBlock.Rows Property

Determines the number of columns in the block array

Syntax

object.Rows

object is a MInsertBlock object.

Description

Rows Long; Read-write


MInsertBlock.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a MInsertBlock object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


MInsertBlock.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a MInsertBlock object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


MInsertBlock.XScaleFactor Property

Specifies the XScale factor of the block

Syntax

object.XScaleFactor

object is a MInsertBlock object.

Description

XScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

XScaleFactor Property example


MInsertBlock.YScaleFactor Property

Specifies the Yscale factor of the block

Syntax

object.YScaleFactor

object is a MInsertBlock object.

Description

YScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

YScaleFactor Property example


MInsertBlock.ZScaleFactor Property

Specifies the ZScale factor of the block

Syntax

object.ZScaleFactor

object is a MInsertBlock object.

Description

ZScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ZScaleFactor Property example


MInsertBlock.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a MInsertBlock object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadMLeader Object Members

MLeader Object Members

An object composed of an arrowhead attached to multiple splines or straight line segments.

VBA Class Name

ZcadMLeader

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


MLeader.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


MLeader.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


MLeader.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a MLeader object.

Return value

Object

Examples...

Copy Method example


MLeader.Delete Method

Deletes the object.

Syntax

object.Delete

object is a MLeader object.

Examples...

Delete Method example


MLeader.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a MLeader object.

Examples...

Erase Method example


MLeader.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


MLeader.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a MLeader object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


MLeader.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


MLeader.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


MLeader.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


MLeader.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


MLeader.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


MLeader.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


MLeader.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


MLeader.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a MLeader object.


MLeader.Application Property

Returns the application object.

Syntax

object.Application

object is a MLeader object.

Description

Application Object; Read-only

Examples...

Application Property example


MLeader.Database Property

Returns the database object.

Syntax

object.Database

object is a MLeader object.

Description

Database Database; Read-only


MLeader.Document Property

Returns the document object.

Syntax

object.Document

object is a MLeader object.

Description

Document Object; Read-only


MLeader.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a MLeader object.

Description

Handle String; Read-only


MLeader.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a MLeader object.

Description

HasExtensionDictionary Boolean; Read-only


MLeader.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a MLeader object.

Description

Hyperlinks Hyperlinks; Read-only


MLeader.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a MLeader object.

Description

Layer String; Read-write

Examples...

Layer Property example


MLeader.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a MLeader object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


MLeader.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a MLeader object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


MLeader.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a MLeader object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


MLeader.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a MLeader object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


MLeader.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a MLeader object.

Description

ObjectName String; Read-only


MLeader.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a MLeader object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


MLeader.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a MLeader object.

Description

PlotStyleName String; Read-write


MLeader.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a MLeader object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


MLeader.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a MLeader object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


MLeader.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a MLeader object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadMLine Object Members

MLine Object Members

Multiple parallel lines.

VBA Class Name

ZcadMLine

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Coordinates | Specifies the coordinates of the MLine
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
StyleName | Specifies the Mline style name
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


MLine.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


MLine.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


MLine.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a MLine object.

Return value

Object

Examples...

Copy Method example


MLine.Delete Method

Deletes the object.

Syntax

object.Delete

object is a MLine object.

Examples...

Delete Method example


MLine.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a MLine object.

Examples...

Erase Method example


MLine.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


MLine.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a MLine object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


MLine.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


MLine.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


MLine.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


MLine.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


MLine.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


MLine.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


MLine.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


MLine.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a MLine object.


MLine.Application Property

Returns the application object.

Syntax

object.Application

object is a MLine object.

Description

Application Object; Read-only

Examples...

Application Property example


MLine.Coordinates Property

Specifies the coordinates of the MLine

Syntax

object.Coordinates

object is a MLine object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


MLine.Database Property

Returns the database object.

Syntax

object.Database

object is a MLine object.

Description

Database Database; Read-only


MLine.Document Property

Returns the document object.

Syntax

object.Document

object is a MLine object.

Description

Document Object; Read-only


MLine.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a MLine object.

Description

Handle String; Read-only


MLine.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a MLine object.

Description

HasExtensionDictionary Boolean; Read-only


MLine.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a MLine object.

Description

Hyperlinks Hyperlinks; Read-only


MLine.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a MLine object.

Description

Layer String; Read-write

Examples...

Layer Property example


MLine.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a MLine object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


MLine.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a MLine object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


MLine.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a MLine object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


MLine.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a MLine object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


MLine.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a MLine object.

Description

ObjectName String; Read-only


MLine.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a MLine object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


MLine.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a MLine object.

Description

PlotStyleName String; Read-write


MLine.StyleName Property

Specifies the Mline style name

Syntax

object.StyleName

object is a MLine object.

Description

StyleName String; Read-only

Examples...

StyleName Property example


MLine.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a MLine object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


MLine.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a MLine object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


MLine.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a MLine object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadMText Object Members

MText Object Members

A paragraph of alphanumeric characters that fits within a nonprinting text boundary.

VBA Class Name

ZcadMText

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
FieldCode | Returns the text string with field codes of the Mtext
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
AttachmentPoint | Specifies the attachment point of the Mtext
BackgroundFill | Specifies use Background Mask
Database | Returns the database object.
Document | Returns the document object.
DrawingDirection | Specifies the drawing direction of the Mtext
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Height | Specifies the height of the Mtext
Hyperlinks | Specifies the hyperlink collection for the object.
InsertionPoint | Specifies the insertion point of the Mtext
Layer | Specifies the layer of the object.
LineSpacingDistance | Specifies the line spacing distance of the Mtext
LineSpacingFactor | Specifies the line spacing factor of the Mtext
LineSpacingStyle | Specifies the line spacing style of the Mtext
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Specifies the rotation angle of the Mtext
StyleName | Specifies the style name of the Mtext
TextString | Specifies the text string of the Mtext
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.
Width | Specifies the width of the Mtext

Events

Name | Description
Modified | Happens when object is modified


MText.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a MText object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


MText.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a MText object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


MText.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a MText object.

Return value

Object

Examples...

Copy Method example


MText.Delete Method

Deletes the object.

Syntax

object.Delete

object is a MText object.

Examples...

Delete Method example


MText.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a MText object.

Examples...

Erase Method example


MText.FieldCode Method

Returns the text string with field codes of the Mtext

Syntax

object.FieldCode

object is a MText object.

Return value

String


MText.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a MText object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


MText.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a MText object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


MText.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a MText object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


MText.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a MText object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


MText.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a MText object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


MText.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a MText object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


MText.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a MText object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


MText.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a MText object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


MText.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a MText object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


MText.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a MText object.


MText.Application Property

Returns the application object.

Syntax

object.Application

object is a MText object.

Description

Application Object; Read-only

Examples...

Application Property example


MText.AttachmentPoint Property

Specifies the attachment point of the Mtext

Syntax

object.AttachmentPoint

object is a MText object.

Description

AttachmentPoint ZcAttachmentPoint: Read-write
Can be one of the constants listed here:
zcAttachmentPointTopLeft
zcAttachmentPointTopCenter
zcAttachmentPointTopRight
zcAttachmentPointMiddleLeft
zcAttachmentPointMiddleCenter
zcAttachmentPointMiddleRight
zcAttachmentPointBottomLeft
zcAttachmentPointBottomCenter
zcAttachmentPointBottomRight

Examples...

AttachmentPoint Property example


MText.BackgroundFill Property

Specifies use Background Mask

Syntax

object.BackgroundFill

object is a MText object.

Description

BackgroundFill Boolean; Read-write

Examples...

BackgroundFill Property example


MText.Database Property

Returns the database object.

Syntax

object.Database

object is a MText object.

Description

Database Database; Read-only


MText.Document Property

Returns the document object.

Syntax

object.Document

object is a MText object.

Description

Document Object; Read-only


MText.DrawingDirection Property

Specifies the drawing direction of the Mtext

Syntax

object.DrawingDirection

object is a MText object.

Description

DrawingDirection ZcDrawingDirection: Read-write
Can be one of the constants listed here:
zcLeftToRight
zcRightToLeft
zcTopToBottom
zcBottomToTop
zcByStyle


MText.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a MText object.

Description

Handle String; Read-only


MText.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a MText object.

Description

HasExtensionDictionary Boolean; Read-only


MText.Height Property

Specifies the height of the Mtext

Syntax

object.Height

object is a MText object.

Description

Height Double; Read-write


MText.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a MText object.

Description

Hyperlinks Hyperlinks; Read-only


MText.InsertionPoint Property

Specifies the insertion point of the Mtext

Syntax

object.InsertionPoint

object is a MText object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


MText.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a MText object.

Description

Layer String; Read-write

Examples...

Layer Property example


MText.LineSpacingDistance Property

Specifies the line spacing distance of the Mtext

Syntax

object.LineSpacingDistance

object is a MText object.

Description

LineSpacingDistance Double; Read-write

Examples...

LineSpacingDistance Property example


MText.LineSpacingFactor Property

Specifies the line spacing factor of the Mtext

Syntax

object.LineSpacingFactor

object is a MText object.

Description

LineSpacingFactor Double; Read-write

Examples...

LineSpacingFactor Property example


MText.LineSpacingStyle Property

Specifies the line spacing style of the Mtext

Syntax

object.LineSpacingStyle

object is a MText object.

Description

LineSpacingStyle ZcLineSpacingStyle: Read-write
Can be one of the constants listed here:
zcLineSpacingStyleAtLeast
zcLineSpacingStyleExactly

Examples...

LineSpacingStyle Property example


MText.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a MText object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


MText.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a MText object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


MText.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a MText object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


MText.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a MText object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


MText.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a MText object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


MText.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a MText object.

Description

ObjectName String; Read-only


MText.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a MText object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


MText.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a MText object.

Description

PlotStyleName String; Read-write


MText.Rotation Property

Specifies the rotation angle of the Mtext

Syntax

object.Rotation

object is a MText object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


MText.StyleName Property

Specifies the style name of the Mtext

Syntax

object.StyleName

object is a MText object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


MText.TextString Property

Specifies the text string of the Mtext

Syntax

object.TextString

object is a MText object.

Description

TextString String; Read-write

Examples...

TextString Property example


MText.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a MText object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


MText.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a MText object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


MText.Width Property

Specifies the width of the Mtext

Syntax

object.Width

object is a MText object.

Description

Width Double; Read-write

Examples...

Width Property example


MText.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a MText object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadMenuBar Object Members

MenuBar Object Members

A collection of PopupMenu objects representing the current ZWCAD menu bar.

VBA Class Name

ZcadMenuBar

Methods

Name | Description
Item | Returns an element in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of elements in the collection.
Parent | Returns the parent object.

Events

Name | Description
None | -


MenuBar.Item Method

Returns an element in the collection.

Syntax

object.Item(Index)

object is a MenuBar object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

PopupMenu

Examples...

Item Method example


MenuBar.Application Property

Returns the application object.

Syntax

object.Application

object is a MenuBar object.

Description

Application Application; Read-only

Examples...

Application Property example


MenuBar.Count Property

Returns the number of elements in the collection.

Syntax

object.Count

object is a MenuBar object.

Description

Count Long; Read-only

Examples...

Count Property example


MenuBar.Parent Property

Returns the parent object.

Syntax

object.Parent

object is a MenuBar object.

Description

Parent Application; Read-only

Examples...

Parent Property example


ZcadMenuGroup Object Members

MenuGroup Object Members

An ZWCAD menu group.

VBA Class Name

ZcadMenuGroup

Methods

Name | Description
Save | Saves the menu group.
SaveAs | Saves the menu group to a named file.
Unload | Unloads the menu group.

Properties

Name | Description
Application | Returns the application object.
MenuFileName | Returns the name of the loaded menu file.
Menus | Returns the popup menus collection object.
Name | Returns the name of the menu group.
Parent | Returns the parent object.
Toolbars | Returns the toolbars collection object.
Type | Returns the type of the menu group.

Events

Name | Description
None | -


MenuGroup.Save Method

Saves the menu group.

Syntax

object.Save(MenuFileType)

object is a MenuGroup object.

Parameters

Name | Options | Data Type | Description
MenuFileType | Input-only | ZcMenuFileType | Can be one of the constants listed here: zcMenuFileCompiled zcMenuFileSource

Examples...

Save Method example


MenuGroup.SaveAs Method

Saves the menu group to a named file.

Syntax

object.SaveAs(MenuFileName, MenuFileType)

object is a MenuGroup object.

Parameters

Name | Options | Data Type | Description
MenuFileName | Input-only | String | -
MenuFileType | Input-only | ZcMenuFileType | Can be one of the constants listed here: zcMenuFileCompiled zcMenuFileSource

Examples...

SaveAs Method example


MenuGroup.Unload Method

Unloads the menu group.

Syntax

object.Unload

object is a MenuGroup object.


MenuGroup.Application Property

Returns the application object.

Syntax

object.Application

object is a MenuGroup object.

Description

Application Application; Read-only

Examples...

Application Property example


MenuGroup.MenuFileName Property

Returns the name of the loaded menu file.

Syntax

object.MenuFileName

object is a MenuGroup object.

Description

MenuFileName String; Read-only

Examples...

MenuFileName Property example


MenuGroup.Menus Property

Returns the popup menus collection object.

Syntax

object.Menus

object is a MenuGroup object.

Description

Menus PopupMenus; Read-only

Examples...

Menus Property example


MenuGroup.Name Property

Returns the name of the menu group.

Syntax

object.Name

object is a MenuGroup object.

Description

Name String; Read-only

Examples...

Name Property example


MenuGroup.Parent Property

Returns the parent object.

Syntax

object.Parent

object is a MenuGroup object.

Description

Parent MenuGroups; Read-only

Examples...

Parent Property example


MenuGroup.Toolbars Property

Returns the toolbars collection object.

Syntax

object.Toolbars

object is a MenuGroup object.

Description

Toolbars Toolbars; Read-only

Examples...

Toolbars Property example


MenuGroup.Type Property

Returns the type of the menu group.

Syntax

object.Type

object is a MenuGroup object.

Description

Type ZcMenuGroupType: Read-only
Can be one of the constants listed here:
zcBaseMenuGroup
zcPartialMenuGroup

Examples...

Type Property example


ZcadMenuGroups Object Members

MenuGroups Object Members

A collection of MenuGroup objects representing all the menu groups loaded in the current ZWCAD session.

VBA Class Name

ZcadMenuGroups

Methods

Name | Description
Item | Returns an element in the collection.
Load | Loads the specified menu group.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of elements in the collection.
Parent | Returns the parent object.

Events

Name | Description
None | -


MenuGroups.Item Method

Returns an element in the collection.

Syntax

object.Item(Index)

object is a MenuGroups object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

MenuGroup

Examples...

Item Method example


MenuGroups.Load Method

Loads the specified menu group.

Syntax

object.Load(MenuFileName, BaseMenu)

object is a MenuGroups object.

Parameters

Name | Options | Data Type | Description
MenuFileName | Input-only | String | -
BaseMenu | Input-only, Optional | Variant | -

Return value

MenuGroup

Examples...

Load Method example


MenuGroups.Application Property

Returns the application object.

Syntax

object.Application

object is a MenuGroups object.

Description

Application Application; Read-only

Examples...

Application Property example


MenuGroups.Count Property

Returns the number of elements in the collection.

Syntax

object.Count

object is a MenuGroups object.

Description

Count Long; Read-only

Examples...

Count Property example


MenuGroups.Parent Property

Returns the parent object.

Syntax

object.Parent

object is a MenuGroups object.

Description

Parent Application; Read-only

Examples...

Parent Property example


ZcadModelSpace Object Members

ModelSpace Object Members

A special Block object containing all model space entities.

VBA Class Name

ZcadModelSpace

Methods

Name | Description
Add3DFace | Creates a three dimensional face given four vertices.
Add3DPoly | Creates a three dimensional polyline entity.
AddArc | Creates an arc with center, radius, start angle and end angle.
AddAttribute | Adds an attribute definition.
AddBox | Creates a box with edges parallel to the World Coordinate System axes given the length, width and height dimensions.
AddCircle | Creates a circle given the center and radius in the current UCS.
AddCone | Creates a cone given the center, base radius and height.
AddCustomObject | Adds a custom object to the collection.
AddCylinder | Creates a cylinder given the center, base radius and height.
AddDim3PointAngular | Creates a 3 point angular dimension.
AddDimAligned | Creates an aligned dimension.
AddDimAngular | Creates an angular dimension.
AddDimDiametric | Creates a diametric dimension.
AddDimOrdinate | Creates an ordinate dimension.
AddDimRadial | Creates a radial dimension.
AddDimRotated | Creates a linear dimension.
AddEllipse | Creates an ellipse in the current UCS given the center, major and minor axes.
AddEllipticalCone | Creates a cone given the center, major and minor radii and height.
AddEllipticalCylinder | Creates a cylinder given the center, major and minor radii and height.
AddExtrudedSolid | Creates an extruded solid given the profile and a height.
AddExtrudedSolidAlongPath | Creates an extruded solid given the profile and a path.
AddHatch | Creates a hatch entity.
AddLeader | Creates a leader line.
AddLine | Adds a line to ModelSpace or PaperSpace or a block.
AddMInsertBlock | Inserts an array of blocks in the current document.
AddMLine | Inserts an mline object in the current document.
AddPoint | Creates a point entity at a given location.
AddPolyfaceMesh | Inserts polyface mesh object in the current document.
AddPolyline | Creates a polyline.
AddRaster | Creates a raster based of given image filename.
AddRay | Creates a ray passing through two given points.
AddRegion | Creates a region from the given closed curve sets.
AddRevolvedSolid | Creates a revolved solid given the profile and a revolution path.
AddShape | Creates a given shape.
AddSolid | Creates an ZWCAD solid.
AddSphere | Creates a sphere given the center and radius.
AddSpline | Creates a B-spline given n points and the end tangents.
AddTable | Creates a table at the given insertion point, given the number of rows, number of columns, row height and column width.
AddText | Creates a text entity with specified height and rotation.
AddTolerance | Creates a tolerance.
AddTorus | Creates a torus given the center, torus and tube radius.
AddTrace | Creates a trace entity with four points.
AddWedge | Creates a wedge with edges parallel to the axes given the length, width and height dimensions
AttachExternalReference | Attach an external reference to the block.
Bind | Bind the external reference.
Delete | Deletes the object.
Detach | Detach the external reference.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
InsertBlock | Inserts an instance of a block in the current document.
Item | Returns an entity in the collection.
Reload | Reload the external reference.
Unload | Unload the external reference.

Properties

Name | Description
Application | Returns the application object.
Comments | Specifies the comments you want to use to locate the drawing.
Count | Returns the number of entities in the collections.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
IsLayout | Returns a value indicating whether the block is also a layout.
IsXRef | Returns a boolean indicating whether the block is an external reference.
Layout | Returns the associated layout object.
Name | Returns and sets the name of the block.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
Origin | Returns and sets the origin of the block definition.
OwnerID | Returns the OwnerID of the object.
Path | Gets the path of the block, document, application, or external reference.
XRefDatabase | Returns a database object that defines the contents of the block.

Events

Name | Description
Modified | Happens when object is modified


ModelSpace.Add3DFace Method

Creates a three dimensional face given four vertices.

Syntax

object.Add3DFace(Point1, Point2, point3, Point4)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -
point3 | Input-only | Variant | -
Point4 | Input-only | Variant | -

Return value

3DFace

Examples...

Add3DFace Method example


ModelSpace.Add3DPoly Method

Creates a three dimensional polyline entity.

Syntax

object.Add3DPoly(PointsArray)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -

Return value

3DPolyline

Examples...

Add3DPoly Method example


ModelSpace.AddArc Method

Creates an arc with center, radius, start angle and end angle.

Syntax

object.AddArc(Center, Radius, StartAngle, EndAngle)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -
StartAngle | Input-only | Double | -
EndAngle | Input-only | Double | -

Return value

Arc

Examples...

AddArc Method example


ModelSpace.AddAttribute Method

Adds an attribute definition.

Syntax

object.AddAttribute(Height, Mode, Prompt, InsertionPoint, Tag, Value)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Height | Input-only | Double | -
Mode | Input-only | ZcAttributeMode | Can be one of the constants listed here: zcAttributeModeNormal zcAttributeModeInvisible zcAttributeModeConstant zcAttributeModeVerify zcAttributeModePreset zcAttributeModeLockPosition zcAttributeModeMultipleLine
Prompt | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Tag | Input-only | String | -
Value | Input-only | String | -

Return value

Attribute

Examples...

AddAttribute Method example


ModelSpace.AddBox Method

Creates a box with edges parallel to the World Coordinate System axes given the length, width and height dimensions.

Syntax

object.AddBox(Origin, Length, Width, Height)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Origin | Input-only | Variant | -
Length | Input-only | Double | -
Width | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddBox Method example


ModelSpace.AddCircle Method

Creates a circle given the center and radius in the current UCS.

Syntax

object.AddCircle(Center, Radius)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -

Return value

Circle

Examples...

AddCircle Method example


ModelSpace.AddCone Method

Creates a cone given the center, base radius and height.

Syntax

object.AddCone(Center, BaseRadius, Height)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
BaseRadius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddCone Method example


ModelSpace.AddCustomObject Method

Adds a custom object to the collection.

Syntax

object.AddCustomObject(ClassName)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
ClassName | Input-only | String | -

Return value

Object


ModelSpace.AddCylinder Method

Creates a cylinder given the center, base radius and height.

Syntax

object.AddCylinder(Center, Radius, Height)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddCylinder Method example


ModelSpace.AddDim3PointAngular Method

Creates a 3 point angular dimension.

Syntax

object.AddDim3PointAngular(AngleVertex, FirstEndPoint, SecondEndPoint, TextPoint)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
AngleVertex | Input-only | Variant | -
FirstEndPoint | Input-only | Variant | -
SecondEndPoint | Input-only | Variant | -
TextPoint | Input-only | Variant | -

Return value

Dim3PointAngular

Examples...

AddDim3PointAngular Method example


ModelSpace.AddDimAligned Method

Creates an aligned dimension.

Syntax

object.AddDimAligned(ExtLine1Point, ExtLine2Point, TextPosition)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
ExtLine1Point | Input-only | Variant | -
ExtLine2Point | Input-only | Variant | -
TextPosition | Input-only | Variant | -

Return value

DimAligned

Examples...

AddDimAligned Method example


ModelSpace.AddDimAngular Method

Creates an angular dimension.

Syntax

object.AddDimAngular(AngleVertex, FirstEndPoint, SecondEndPoint, TextPoint)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
AngleVertex | Input-only | Variant | -
FirstEndPoint | Input-only | Variant | -
SecondEndPoint | Input-only | Variant | -
TextPoint | Input-only | Variant | -

Return value

DimAngular

Examples...

AddDimAngular Method example


ModelSpace.AddDimDiametric Method

Creates a diametric dimension.

Syntax

object.AddDimDiametric(ChordPoint, FarChordPoint, LeaderLength)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
ChordPoint | Input-only | Variant | -
FarChordPoint | Input-only | Variant | -
LeaderLength | Input-only | Double | -

Return value

DimDiametric

Examples...

AddDimDiametric Method example


ModelSpace.AddDimOrdinate Method

Creates an ordinate dimension.

Syntax

object.AddDimOrdinate(DefinitionPoint, LeaderEndPoint, UseXAxis)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
DefinitionPoint | Input-only | Variant | -
LeaderEndPoint | Input-only | Variant | -
UseXAxis | Input-only | Integer | -

Return value

DimOrdinate

Examples...

AddDimOrdinate Method example


ModelSpace.AddDimRadial Method

Creates a radial dimension.

Syntax

object.AddDimRadial(Center, ChordPoint, LeaderLength)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
ChordPoint | Input-only | Variant | -
LeaderLength | Input-only | Double | -

Return value

DimRadial

Examples...

AddDimRadial Method example


ModelSpace.AddDimRotated Method

Creates a linear dimension.

Syntax

object.AddDimRotated(ExtLine1Point, ExtLine2Point, DimLineLocation, RotationAngle)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
ExtLine1Point | Input-only | Variant | -
ExtLine2Point | Input-only | Variant | -
DimLineLocation | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Return value

DimRotated

Examples...

AddDimRotated Method example


ModelSpace.AddEllipse Method

Creates an ellipse in the current UCS given the center, major and minor axes.

Syntax

object.AddEllipse(Center, MajorAxis, RadiusRatio)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
MajorAxis | Input-only | Variant | -
RadiusRatio | Input-only | Double | -

Return value

Ellipse

Examples...

AddEllipse Method example


ModelSpace.AddEllipticalCone Method

Creates a cone given the center, major and minor radii and height.

Syntax

object.AddEllipticalCone(Center, MajorRadius, MinorRadius, Height)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
MajorRadius | Input-only | Double | -
MinorRadius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddEllipticalCone Method example


ModelSpace.AddEllipticalCylinder Method

Creates a cylinder given the center, major and minor radii and height.

Syntax

object.AddEllipticalCylinder(Center, MajorRadius, MinorRadius, Height)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
MajorRadius | Input-only | Double | -
MinorRadius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddEllipticalCylinder Method example


ModelSpace.AddExtrudedSolid Method

Creates an extruded solid given the profile and a height.

Syntax

object.AddExtrudedSolid(Profile, Height, TaperAngle)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Profile | Input-only | Region | -
Height | Input-only | Double | -
TaperAngle | Input-only | Double | -

Return value

3DSolid

Examples...

AddExtrudedSolid Method example


ModelSpace.AddExtrudedSolidAlongPath Method

Creates an extruded solid given the profile and a path.

Syntax

object.AddExtrudedSolidAlongPath(Profile, Path)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Profile | Input-only | Region | -
Path | Input-only | Object | -

Return value

3DSolid

Examples...

AddExtrudedSolidAlongPath Method example


ModelSpace.AddHatch Method

Creates a hatch entity.

Syntax

object.AddHatch(PatternType, PatternName, Associativity, HatchObjectType)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
PatternType | Input-only | Integer | -
PatternName | Input-only | String | -
Associativity | Input-only | Boolean | -
HatchObjectType | Input-only, Optional | Variant | -

Return value

Hatch

Examples...

AddHatch Method example


ModelSpace.AddLeader Method

Creates a leader line.

Syntax

object.AddLeader(PointsArray, Annotation, Type)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -
Annotation | Input-only | Entity | -
Type | Input-only | ZcLeaderType | Can be one of the constants listed here: zcLineNoArrow zcSplineNoArrow zcLineWithArrow zcSplineWithArrow

Return value

Leader

Examples...

AddLeader Method example


ModelSpace.AddLine Method

Adds a line to ModelSpace or PaperSpace or a block.

Syntax

object.AddLine(StartPoint, EndPoint)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
StartPoint | Input-only | Variant | -
EndPoint | Input-only | Variant | -

Return value

Line

Examples...

AddLine Method example


ModelSpace.AddMInsertBlock Method

Inserts an array of blocks in the current document.

Syntax

object.AddMInsertBlock(InsertionPoint, Name, Xscale, Yscale, Zscale, Rotation, NumRows, NumColumns, RowSpacing, ColumnSpacing, Password)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
InsertionPoint | Input-only | Variant | -
Name | Input-only | String | -
Xscale | Input-only | Double | -
Yscale | Input-only | Double | -
Zscale | Input-only | Double | -
Rotation | Input-only | Double | -
NumRows | Input-only | Long | -
NumColumns | Input-only | Long | -
RowSpacing | Input-only | Long | -
ColumnSpacing | Input-only | Long | -
Password | Input-only, Optional | Variant | -

Return value

MInsertBlock


ModelSpace.AddMLine Method

Inserts an mline object in the current document.

Syntax

object.AddMLine(VertexList)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
VertexList | Input-only | Variant | -

Return value

MLine

Examples...

AddMLine Method example


ModelSpace.AddPoint Method

Creates a point entity at a given location.

Syntax

object.AddPoint(Point)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Point | Input-only | Variant | -

Return value

Point

Examples...

AddPoint Method example


ModelSpace.AddPolyfaceMesh Method

Inserts polyface mesh object in the current document.

Syntax

object.AddPolyfaceMesh(VertexList, FaceList)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
VertexList | Input-only | Variant | -
FaceList | Input-only | Variant | -

Return value

PolyfaceMesh

Examples...

AddPolyfaceMesh Method example


ModelSpace.AddPolyline Method

Creates a polyline.

Syntax

object.AddPolyline(VerticesList)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
VerticesList | Input-only | Variant | -

Return value

Polyline

Examples...

AddPolyline Method example


ModelSpace.AddRaster Method

Creates a raster based of given image filename.

Syntax

object.AddRaster(imageFileName, InsertionPoint, ScaleFactor, RotationAngle)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
imageFileName | Input-only | String | -
InsertionPoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -
RotationAngle | Input-only | Double | -

Return value

RasterImage

Examples...

AddRaster Method example


ModelSpace.AddRay Method

Creates a ray passing through two given points.

Syntax

object.AddRay(Point1, Point2)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Ray

Examples...

AddRay Method example


ModelSpace.AddRegion Method

Creates a region from the given closed curve sets.

Syntax

object.AddRegion(ObjectList)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
ObjectList | Input-only | Variant | -

Return value

Variant

Examples...

AddRegion Method example


ModelSpace.AddRevolvedSolid Method

Creates a revolved solid given the profile and a revolution path.

Syntax

object.AddRevolvedSolid(Profile, AxisPoint, AxisDir, Angle)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Profile | Input-only | Region | -
AxisPoint | Input-only | Variant | -
AxisDir | Input-only | Variant | -
Angle | Input-only | Double | -

Return value

3DSolid

Examples...

AddRevolvedSolid Method example


ModelSpace.AddShape Method

Creates a given shape.

Syntax

object.AddShape(Name, InsertionPoint, ScaleFactor, RotationAngle)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -
InsertionPoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -
RotationAngle | Input-only | Double | -

Return value

Shape

Examples...

AddShape Method example


ModelSpace.AddSolid Method

Creates an ZWCAD solid.

Syntax

object.AddSolid(Point1, Point2, point3, Point4)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -
point3 | Input-only | Variant | -
Point4 | Input-only | Variant | -

Return value

Solid

Examples...

AddSolid Method example


ModelSpace.AddSphere Method

Creates a sphere given the center and radius.

Syntax

object.AddSphere(Center, Radius)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -

Return value

3DSolid

Examples...

AddSphere Method example


ModelSpace.AddSpline Method

Creates a B-spline given n points and the end tangents.

Syntax

object.AddSpline(PointsArray, StartTangent, EndTangent)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -
StartTangent | Input-only | Variant | -
EndTangent | Input-only | Variant | -

Return value

Spline

Examples...

AddSpline Method example


ModelSpace.AddTable Method

Creates a table at the given insertion point, given the number of rows, number of columns, row height and column width.

Syntax

object.AddTable(InsertionPoint, NumRows, NumColumns, RowHeight, ColWidth)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
InsertionPoint | Input-only | Variant | -
NumRows | Input-only | Integer | -
NumColumns | Input-only | Integer | -
RowHeight | Input-only | Double | -
ColWidth | Input-only | Double | -

Return value

Table


ModelSpace.AddText Method

Creates a text entity with specified height and rotation.

Syntax

object.AddText(TextString, InsertionPoint, Height)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
TextString | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Height | Input-only | Double | -

Return value

Text

Examples...

AddText Method example


ModelSpace.AddTolerance Method

Creates a tolerance.

Syntax

object.AddTolerance(Text, InsertionPoint, Direction)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Text | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Direction | Input-only | Variant | -

Return value

Tolerance

Examples...

AddTolerance Method example


ModelSpace.AddTorus Method

Creates a torus given the center, torus and tube radius.

Syntax

object.AddTorus(Center, TorusRadius, TubeRadius)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
TorusRadius | Input-only | Double | -
TubeRadius | Input-only | Double | -

Return value

3DSolid

Examples...

AddTorus Method example


ModelSpace.AddTrace Method

Creates a trace entity with four points.

Syntax

object.AddTrace(PointsArray)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -

Return value

Trace

Examples...

AddTrace Method example


ModelSpace.AddWedge Method

Creates a wedge with edges parallel to the axes given the length, width and height dimensions

Syntax

object.AddWedge(Center, Length, Width, Height)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Length | Input-only | Double | -
Width | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddWedge Method example


ModelSpace.AttachExternalReference Method

Attach an external reference to the block.

Syntax

object.AttachExternalReference(PathName, Name, InsertionPoint, Xscale, Yscale, Zscale, Rotation, bOverlay, Password)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
PathName | Input-only | String | -
Name | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Xscale | Input-only | Double | -
Yscale | Input-only | Double | -
Zscale | Input-only | Double | -
Rotation | Input-only | Double | -
bOverlay | Input-only | Boolean | -
Password | Input-only, Optional | Variant | -

Return value

ExternalReference

Examples...

AttachExternalReference Method example


ModelSpace.Bind Method

Bind the external reference.

Syntax

object.Bind(bPrefixName)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
bPrefixName | Input-only | Boolean | -

Examples...

Bind Method example


ModelSpace.Delete Method

Deletes the object.

Syntax

object.Delete

object is a ModelSpace object.

Examples...

Delete Method example


ModelSpace.Detach Method

Detach the external reference.

Syntax

object.Detach

object is a ModelSpace object.

Examples...

Detach Method example


ModelSpace.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a ModelSpace object.

Examples...

Erase Method example


ModelSpace.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a ModelSpace object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


ModelSpace.InsertBlock Method

Inserts an instance of a block in the current document.

Syntax

object.InsertBlock(InsertionPoint, Name, Xscale, Yscale, Zscale, Rotation, Password)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
InsertionPoint | Input-only | Variant | -
Name | Input-only | String | -
Xscale | Input-only | Double | -
Yscale | Input-only | Double | -
Zscale | Input-only | Double | -
Rotation | Input-only | Double | -
Password | Input-only, Optional | Variant | -

Return value

BlockReference

Examples...

InsertBlock Method example


ModelSpace.Item Method

Returns an entity in the collection.

Syntax

object.Item(Index)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Entity

Examples...

Item Method example


ModelSpace.Reload Method

Reload the external reference.

Syntax

object.Reload

object is a ModelSpace object.

Examples...

Reload Method example


ModelSpace.Unload Method

Unload the external reference.

Syntax

object.Unload

object is a ModelSpace object.


ModelSpace.Application Property

Returns the application object.

Syntax

object.Application

object is a ModelSpace object.

Description

Application Object; Read-only

Examples...

Application Property example


ModelSpace.Comments Property

Specifies the comments you want to use to locate the drawing.

Syntax

object.Comments

object is a ModelSpace object.

Description

Comments String; Read-write

Examples...

Comments Property example


ModelSpace.Count Property

Returns the number of entities in the collections.

Syntax

object.Count

object is a ModelSpace object.

Description

Count Long; Read-only

Examples...

Count Property example


ModelSpace.Database Property

Returns the database object.

Syntax

object.Database

object is a ModelSpace object.

Description

Database Database; Read-only


ModelSpace.Document Property

Returns the document object.

Syntax

object.Document

object is a ModelSpace object.

Description

Document Object; Read-only


ModelSpace.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a ModelSpace object.

Description

Handle String; Read-only


ModelSpace.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a ModelSpace object.

Description

HasExtensionDictionary Boolean; Read-only


ModelSpace.IsLayout Property

Returns a value indicating whether the block is also a layout.

Syntax

object.IsLayout

object is a ModelSpace object.

Description

IsLayout Boolean; Read-only

Examples...

IsLayout Property example


ModelSpace.IsXRef Property

Returns a boolean indicating whether the block is an external reference.

Syntax

object.IsXRef

object is a ModelSpace object.

Description

IsXRef Boolean; Read-only

Examples...

IsXRef Property example


ModelSpace.Layout Property

Returns the associated layout object.

Syntax

object.Layout

object is a ModelSpace object.

Description

Layout Layout; Read-only

Examples...

Layout Property example


ModelSpace.Name Property

Returns and sets the name of the block.

Syntax

object.Name

object is a ModelSpace object.

Description

Name String; Read-write

Examples...

Name Property example


ModelSpace.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a ModelSpace object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


ModelSpace.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a ModelSpace object.

Description

ObjectName String; Read-only


ModelSpace.Origin Property

Returns and sets the origin of the block definition.

Syntax

object.Origin

object is a ModelSpace object.

Description

Origin Variant; Read-write

Examples...

Origin Property example


ModelSpace.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a ModelSpace object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


ModelSpace.Path Property

Gets the path of the block, document, application, or external reference.

Syntax

object.Path

object is a ModelSpace object.

Description

Path String; Read-write

Examples...

Path Property example


ModelSpace.XRefDatabase Property

Returns a database object that defines the contents of the block.

Syntax

object.XRefDatabase

object is a ModelSpace object.

Description

XRefDatabase Database; Read-only


ModelSpace.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a ModelSpace object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadOle Object Members

Ole Object Members

An ZWCAD OLE object.

VBA Class Name

ZcadOle

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Height | Specifies the height of the OLE object box
Hyperlinks | Specifies the hyperlink collection for the object.
InsertionPoint | Specifies the origin coordinates (upper left corner) of the OLE object
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Specifies the rotation angle of the OLE object
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.
Width | Specifies the width of the OLE object box

Events

Name | Description
Modified | Happens when object is modified


Ole.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Ole.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Ole.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Ole object.

Return value

Object

Examples...

Copy Method example


Ole.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Ole object.

Examples...

Delete Method example


Ole.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Ole object.

Examples...

Erase Method example


Ole.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Ole.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Ole object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Ole.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Ole.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Ole.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Ole.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Ole.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Ole.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Ole.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Ole.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Ole object.


Ole.Application Property

Returns the application object.

Syntax

object.Application

object is a Ole object.

Description

Application Object; Read-only

Examples...

Application Property example


Ole.Database Property

Returns the database object.

Syntax

object.Database

object is a Ole object.

Description

Database Database; Read-only


Ole.Document Property

Returns the document object.

Syntax

object.Document

object is a Ole object.

Description

Document Object; Read-only


Ole.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Ole object.

Description

Handle String; Read-only


Ole.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Ole object.

Description

HasExtensionDictionary Boolean; Read-only


Ole.Height Property

Specifies the height of the OLE object box

Syntax

object.Height

object is a Ole object.

Description

Height Double; Read-write


Ole.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Ole object.

Description

Hyperlinks Hyperlinks; Read-only


Ole.InsertionPoint Property

Specifies the origin coordinates (upper left corner) of the OLE object

Syntax

object.InsertionPoint

object is a Ole object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


Ole.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Ole object.

Description

Layer String; Read-write

Examples...

Layer Property example


Ole.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Ole object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Ole.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Ole object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Ole.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Ole object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Ole.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Ole object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Ole.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Ole object.

Description

ObjectName String; Read-only


Ole.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Ole object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Ole.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Ole object.

Description

PlotStyleName String; Read-write


Ole.Rotation Property

Specifies the rotation angle of the OLE object

Syntax

object.Rotation

object is a Ole object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


Ole.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Ole object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Ole.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Ole object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Ole.Width Property

Specifies the width of the OLE object box

Syntax

object.Width

object is a Ole object.

Description

Width Double; Read-write

Examples...

Width Property example


Ole.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Ole object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadPViewport Object Members

PViewport Object Members

Rectangular objects created in paper space that display views.

VBA Class Name

ZcadPViewport

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Display | Determines whether viewport is on or off
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetGridSpacing | Specifies the grid spacing for the viewport
GetSnapSpacing | Specifies the snap spacing for the viewport
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
SetGridSpacing | Sets the grid spacing for the viewport
SetSnapSpacing | Sets the snap spacing for the viewport
SyncModelView | Updates the viewport parameters with the parameters in the associated model view.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
ArcSmoothness | Specifies the circle zoom percent for the viewport
Center | Specifies the X, Y, and Z coordinates for center of the viewport
Clipped | Toggles viewport clipping on or off
CustomScale | Specifies the custom scale for the viewport
Database | Returns the database object.
Direction | Specifies the direction of the viewport
DisplayLocked | Toggles the locked state of the viewport
Document | Returns the document object.
GridOn | Toggles the grid on or off
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Height | Specifies the height of the viewport
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
LensLength | Specifies the lens length of the viewport
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
RemoveHiddenLines | Determines whether hidden line removal is on or off
ShadePlot | Specifies the shade plot mode of the viewport
SnapBasePoint | Specifies the snap base point for the viewport
SnapOn | Toggle snap on or off
SnapRotationAngle | Specifies the snap rotation angle for the viewport
StandardScale | Specifies the standard scale for the viewport
StyleSheet | Returns the style sheet to use
Target | Specifies the target point of the viewport
TrueColor | Returns the true color of the object.
TwistAngle | Specifies the twist angle of the viewport
UCSIconAtOrigin | Toggles the display of the user coordinates systems icon at the origin on or off
UCSIconOn | Toggles the user coordinates systems icon or off
UCSPerViewport | Determines whether the UCS is saved with the viewport or not
ViewportOn | Toggles the viewport on or off
Visible | Determines whether object visibility is on or off.
Width | Specifies the width of the viewport

Events

Name | Description
Modified | Happens when object is modified


PViewport.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


PViewport.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


PViewport.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a PViewport object.

Return value

Object

Examples...

Copy Method example


PViewport.Delete Method

Deletes the object.

Syntax

object.Delete

object is a PViewport object.

Examples...

Delete Method example


PViewport.Display Method

Determines whether viewport is on or off

Syntax

object.Display(bStatus)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
bStatus | Input-only | Boolean | -

Examples...

Display Method example


PViewport.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a PViewport object.

Examples...

Erase Method example


PViewport.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


PViewport.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a PViewport object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


PViewport.GetGridSpacing Method

Specifies the grid spacing for the viewport

Syntax

object.GetGridSpacing(XSpacing, YSpacing)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
XSpacing | Output-only | Double | -
YSpacing | Output-only | Double | -

Examples...

GetGridSpacing Method example


PViewport.GetSnapSpacing Method

Specifies the snap spacing for the viewport

Syntax

object.GetSnapSpacing(XSpacing, YSpacing)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
XSpacing | Output-only | Double | -
YSpacing | Output-only | Double | -

Examples...

GetSnapSpacing Method example


PViewport.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


PViewport.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


PViewport.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


PViewport.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


PViewport.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


PViewport.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


PViewport.SetGridSpacing Method

Sets the grid spacing for the viewport

Syntax

object.SetGridSpacing(XSpacing, YSpacing)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
XSpacing | Input-only | Double | -
YSpacing | Input-only | Double | -


PViewport.SetSnapSpacing Method

Sets the snap spacing for the viewport

Syntax

object.SetSnapSpacing(XSpacing, YSpacing)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
XSpacing | Input-only | Double | -
YSpacing | Input-only | Double | -


PViewport.SyncModelView Method

Updates the viewport parameters with the parameters in the associated model view.

Syntax

object.SyncModelView

object is a PViewport object.


PViewport.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


PViewport.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a PViewport object.


PViewport.Application Property

Returns the application object.

Syntax

object.Application

object is a PViewport object.

Description

Application Object; Read-only

Examples...

Application Property example


PViewport.ArcSmoothness Property

Specifies the circle zoom percent for the viewport

Syntax

object.ArcSmoothness

object is a PViewport object.

Description

ArcSmoothness Long; Read-write


PViewport.Center Property

Specifies the X, Y, and Z coordinates for center of the viewport

Syntax

object.Center

object is a PViewport object.

Description

Center Variant; Read-write

Examples...

Center Property example


PViewport.Clipped Property

Toggles viewport clipping on or off

Syntax

object.Clipped

object is a PViewport object.

Description

Clipped Boolean; Read-only


PViewport.CustomScale Property

Specifies the custom scale for the viewport

Syntax

object.CustomScale

object is a PViewport object.

Description

CustomScale Double; Read-write

Examples...

CustomScale Property example


PViewport.Database Property

Returns the database object.

Syntax

object.Database

object is a PViewport object.

Description

Database Database; Read-only


PViewport.Direction Property

Specifies the direction of the viewport

Syntax

object.Direction

object is a PViewport object.

Description

Direction Variant; Read-write


PViewport.DisplayLocked Property

Toggles the locked state of the viewport

Syntax

object.DisplayLocked

object is a PViewport object.

Description

DisplayLocked Boolean; Read-write


PViewport.Document Property

Returns the document object.

Syntax

object.Document

object is a PViewport object.

Description

Document Object; Read-only


PViewport.GridOn Property

Toggles the grid on or off

Syntax

object.GridOn

object is a PViewport object.

Description

GridOn Boolean; Read-write


PViewport.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a PViewport object.

Description

Handle String; Read-only


PViewport.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a PViewport object.

Description

HasExtensionDictionary Boolean; Read-only


PViewport.Height Property

Specifies the height of the viewport

Syntax

object.Height

object is a PViewport object.

Description

Height Double; Read-write


PViewport.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a PViewport object.

Description

Hyperlinks Hyperlinks; Read-only


PViewport.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a PViewport object.

Description

Layer String; Read-write

Examples...

Layer Property example


PViewport.LensLength Property

Specifies the lens length of the viewport

Syntax

object.LensLength

object is a PViewport object.

Description

LensLength Double; Read-write

Examples...

LensLength Property example


PViewport.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a PViewport object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


PViewport.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a PViewport object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


PViewport.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a PViewport object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


PViewport.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a PViewport object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


PViewport.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a PViewport object.

Description

ObjectName String; Read-only


PViewport.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a PViewport object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


PViewport.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a PViewport object.

Description

PlotStyleName String; Read-write


PViewport.RemoveHiddenLines Property

Determines whether hidden line removal is on or off

Syntax

object.RemoveHiddenLines

object is a PViewport object.

Description

RemoveHiddenLines Boolean; Read-write

Examples...

RemoveHiddenLines Property example


PViewport.ShadePlot Property

Specifies the shade plot mode of the viewport

Syntax

object.ShadePlot

object is a PViewport object.

Description

ShadePlot Integer; Read-write


PViewport.SnapBasePoint Property

Specifies the snap base point for the viewport

Syntax

object.SnapBasePoint

object is a PViewport object.

Description

SnapBasePoint Variant; Read-write

Examples...

SnapBasePoint Property example


PViewport.SnapOn Property

Toggle snap on or off

Syntax

object.SnapOn

object is a PViewport object.

Description

SnapOn Boolean; Read-write


PViewport.SnapRotationAngle Property

Specifies the snap rotation angle for the viewport

Syntax

object.SnapRotationAngle

object is a PViewport object.

Description

SnapRotationAngle Double; Read-write

Examples...

SnapRotationAngle Property example


PViewport.StandardScale Property

Specifies the standard scale for the viewport

Syntax

object.StandardScale

object is a PViewport object.

Description

StandardScale ZcViewportScale: Read-write
Can be one of the constants listed here:
zcVpScaleToFit
zcVpCustomScale
zcVp1
zcVp2
zcVp3
zcVp4
zcVp5
zcVp6
zcVp7
zcVp8
zcVp9
zcVp10
zcVp11
zcVp12
zcVp13
zcVp14
zcVp15
zcVp16
zcVp17
zcVp18
zcVp19
zcVp20
zcVp21
zcVp22
zcVp23
zcVp24
zcVp25
zcVp26
zcVp27
zcVp28
zcVp29
zcVp30
zcVp31
zcVp32
zcVp33
zcVp34
zcVp35
zcVp36
zcVp37
zcVp38
zcVp39
zcVp40
zcVp41
zcVp42
zcVp43
zcVp44
zcVp45
zcVp46
zcVp47
zcVp48
zcVp49
zcVp50
zcVp51
zcVp52
zcVp53
zcVp54
zcVp55
zcVp56
zcVp57
zcVp58
zcVp59
zcVp60
zcVp61
zcVp62
zcVp63
zcVp64
zcVp65
zcVp66
zcVp67
zcVp68
zcVp69
zcVp70
zcVp71
zcVp72
zcVp73
zcVp74
zcVp75
zcVp76
zcVp77
zcVp78
zcVp79
zcVp80
zcVp81
zcVp82
zcVp83
zcVp84
zcVp85
zcVp86
zcVp87
zcVp88
zcVp89
zcVp90
zcVp91
zcVp92
zcVp93
zcVp94
zcVp95
zcVp96
zcVp97
zcVp98
zcVp99
zcVp100
zcVp1_1
zcVp1_2
zcVp1_4
zcVp1_5
zcVp1_8
zcVp1_10
zcVp1_16
zcVp1_20
zcVp1_30
zcVp1_40
zcVp1_50
zcVp1_100
zcVp2_1
zcVp4_1
zcVp8_1
zcVp10_1
zcVp100_1
zcVp1_128in_1ft
zcVp1_64in_1ft
zcVp1_32in_1ft
zcVp1_16in_1ft
zcVp3_32in_1ft
zcVp1_8in_1ft
zcVp3_16in_1ft
zcVp1_4in_1ft
zcVp3_8in_1ft
zcVp1_2in_1ft
zcVp3_4in_1ft
zcVp1in_1ft
zcVp1and1_2in_1ft
zcVp3in_1ft
zcVp6in_1ft
zcVp1ft_1ft

Examples...

StandardScale Property example


PViewport.StyleSheet Property

Returns the style sheet to use

Syntax

object.StyleSheet

object is a PViewport object.

Description

StyleSheet String; Read-write

Examples...

StyleSheet Property example


PViewport.Target Property

Specifies the target point of the viewport

Syntax

object.Target

object is a PViewport object.

Description

Target Variant; Read-write

Examples...

Target Property example


PViewport.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a PViewport object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


PViewport.TwistAngle Property

Specifies the twist angle of the viewport

Syntax

object.TwistAngle

object is a PViewport object.

Description

TwistAngle ZCAD_ANGLE: alias for Double; Read-write

Examples...

TwistAngle Property example


PViewport.UCSIconAtOrigin Property

Toggles the display of the user coordinates systems icon at the origin on or off

Syntax

object.UCSIconAtOrigin

object is a PViewport object.

Description

UCSIconAtOrigin Boolean; Read-write


PViewport.UCSIconOn Property

Toggles the user coordinates systems icon or off

Syntax

object.UCSIconOn

object is a PViewport object.

Description

UCSIconOn Boolean; Read-write


PViewport.UCSPerViewport Property

Determines whether the UCS is saved with the viewport or not

Syntax

object.UCSPerViewport

object is a PViewport object.

Description

UCSPerViewport Boolean; Read-write


PViewport.ViewportOn Property

Toggles the viewport on or off

Syntax

object.ViewportOn

object is a PViewport object.

Description

ViewportOn Boolean; Read-write


PViewport.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a PViewport object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


PViewport.Width Property

Specifies the width of the viewport

Syntax

object.Width

object is a PViewport object.

Description

Width Double; Read-write

Examples...

Width Property example


PViewport.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a PViewport object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadPaperSpace Object Members

PaperSpace Object Members

A special Block object containing all the entities in the active paper space layout.

VBA Class Name

ZcadPaperSpace

Methods

Name | Description
Add3DFace | Creates a three dimensional face given four vertices.
Add3DPoly | Creates a three dimensional polyline entity.
AddArc | Creates an arc with center, radius, start angle and end angle.
AddAttribute | Adds an attribute definition.
AddBox | Creates a box with edges parallel to the World Coordinate System axes given the length, width and height dimensions.
AddCircle | Creates a circle given the center and radius in the current UCS.
AddCone | Creates a cone given the center, base radius and height.
AddCustomObject | Adds a custom object to the collection.
AddCylinder | Creates a cylinder given the center, base radius and height.
AddDim3PointAngular | Creates a 3 point angular dimension.
AddDimAligned | Creates an aligned dimension.
AddDimAngular | Creates an angular dimension.
AddDimDiametric | Creates a diametric dimension.
AddDimOrdinate | Creates an ordinate dimension.
AddDimRadial | Creates a radial dimension.
AddDimRotated | Creates a linear dimension.
AddEllipse | Creates an ellipse in the current UCS given the center, major and minor axes.
AddEllipticalCone | Creates a cone given the center, major and minor radii and height.
AddEllipticalCylinder | Creates a cylinder given the center, major and minor radii and height.
AddExtrudedSolid | Creates an extruded solid given the profile and a height.
AddExtrudedSolidAlongPath | Creates an extruded solid given the profile and a path.
AddHatch | Creates a hatch entity.
AddLeader | Creates a leader line.
AddLine | Adds a line to ModelSpace or PaperSpace or a block.
AddMInsertBlock | Inserts an array of blocks in the current document.
AddMLine | Inserts an mline object in the current document.
AddPViewport | Create a paperspace viewport.
AddPoint | Creates a point entity at a given location.
AddPolyfaceMesh | Inserts polyface mesh object in the current document.
AddPolyline | Creates a polyline.
AddRaster | Creates a raster based of given image filename.
AddRay | Creates a ray passing through two given points.
AddRegion | Creates a region from the given closed curve sets.
AddRevolvedSolid | Creates a revolved solid given the profile and a revolution path.
AddShape | Creates a given shape.
AddSolid | Creates an ZWCAD solid.
AddSphere | Creates a sphere given the center and radius.
AddSpline | Creates a B-spline given n points and the end tangents.
AddTable | Creates a table at the given insertion point, given the number of rows, number of columns, row height and column width.
AddText | Creates a text entity with specified height and rotation.
AddTolerance | Creates a tolerance.
AddTorus | Creates a torus given the center, torus and tube radius.
AddTrace | Creates a trace entity with four points.
AddWedge | Creates a wedge with edges parallel to the axes given the length, width and height dimensions
AttachExternalReference | Attach an external reference to the block.
Bind | Bind the external reference.
Delete | Deletes the object.
Detach | Detach the external reference.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
InsertBlock | Inserts an instance of a block in the current document.
Item | Returns an entity in the collection.
Reload | Reload the external reference.
Unload | Unload the external reference.

Properties

Name | Description
Application | Returns the application object.
Comments | Specifies the comments you want to use to locate the drawing.
Count | Returns the number of entities in the collections.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
IsLayout | Returns a value indicating whether the block is also a layout.
IsXRef | Returns a boolean indicating whether the block is an external reference.
Layout | Returns the associated layout object.
Name | Returns and sets the name of the block.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
Origin | Returns and sets the origin of the block definition.
OwnerID | Returns the OwnerID of the object.
Path | Gets the path of the block, document, application, or external reference.
XRefDatabase | Returns a database object that defines the contents of the block.

Events

Name | Description
Modified | Happens when object is modified


PaperSpace.Add3DFace Method

Creates a three dimensional face given four vertices.

Syntax

object.Add3DFace(Point1, Point2, point3, Point4)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -
point3 | Input-only | Variant | -
Point4 | Input-only | Variant | -

Return value

3DFace

Examples...

Add3DFace Method example


PaperSpace.Add3DPoly Method

Creates a three dimensional polyline entity.

Syntax

object.Add3DPoly(PointsArray)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -

Return value

3DPolyline

Examples...

Add3DPoly Method example


PaperSpace.AddArc Method

Creates an arc with center, radius, start angle and end angle.

Syntax

object.AddArc(Center, Radius, StartAngle, EndAngle)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -
StartAngle | Input-only | Double | -
EndAngle | Input-only | Double | -

Return value

Arc

Examples...

AddArc Method example


PaperSpace.AddAttribute Method

Adds an attribute definition.

Syntax

object.AddAttribute(Height, Mode, Prompt, InsertionPoint, Tag, Value)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Height | Input-only | Double | -
Mode | Input-only | ZcAttributeMode | Can be one of the constants listed here: zcAttributeModeNormal zcAttributeModeInvisible zcAttributeModeConstant zcAttributeModeVerify zcAttributeModePreset zcAttributeModeLockPosition zcAttributeModeMultipleLine
Prompt | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Tag | Input-only | String | -
Value | Input-only | String | -

Return value

Attribute

Examples...

AddAttribute Method example


PaperSpace.AddBox Method

Creates a box with edges parallel to the World Coordinate System axes given the length, width and height dimensions.

Syntax

object.AddBox(Origin, Length, Width, Height)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Origin | Input-only | Variant | -
Length | Input-only | Double | -
Width | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddBox Method example


PaperSpace.AddCircle Method

Creates a circle given the center and radius in the current UCS.

Syntax

object.AddCircle(Center, Radius)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -

Return value

Circle

Examples...

AddCircle Method example


PaperSpace.AddCone Method

Creates a cone given the center, base radius and height.

Syntax

object.AddCone(Center, BaseRadius, Height)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
BaseRadius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddCone Method example


PaperSpace.AddCustomObject Method

Adds a custom object to the collection.

Syntax

object.AddCustomObject(ClassName)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
ClassName | Input-only | String | -

Return value

Object


PaperSpace.AddCylinder Method

Creates a cylinder given the center, base radius and height.

Syntax

object.AddCylinder(Center, Radius, Height)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddCylinder Method example


PaperSpace.AddDim3PointAngular Method

Creates a 3 point angular dimension.

Syntax

object.AddDim3PointAngular(AngleVertex, FirstEndPoint, SecondEndPoint, TextPoint)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
AngleVertex | Input-only | Variant | -
FirstEndPoint | Input-only | Variant | -
SecondEndPoint | Input-only | Variant | -
TextPoint | Input-only | Variant | -

Return value

Dim3PointAngular

Examples...

AddDim3PointAngular Method example


PaperSpace.AddDimAligned Method

Creates an aligned dimension.

Syntax

object.AddDimAligned(ExtLine1Point, ExtLine2Point, TextPosition)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
ExtLine1Point | Input-only | Variant | -
ExtLine2Point | Input-only | Variant | -
TextPosition | Input-only | Variant | -

Return value

DimAligned

Examples...

AddDimAligned Method example


PaperSpace.AddDimAngular Method

Creates an angular dimension.

Syntax

object.AddDimAngular(AngleVertex, FirstEndPoint, SecondEndPoint, TextPoint)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
AngleVertex | Input-only | Variant | -
FirstEndPoint | Input-only | Variant | -
SecondEndPoint | Input-only | Variant | -
TextPoint | Input-only | Variant | -

Return value

DimAngular

Examples...

AddDimAngular Method example


PaperSpace.AddDimDiametric Method

Creates a diametric dimension.

Syntax

object.AddDimDiametric(ChordPoint, FarChordPoint, LeaderLength)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
ChordPoint | Input-only | Variant | -
FarChordPoint | Input-only | Variant | -
LeaderLength | Input-only | Double | -

Return value

DimDiametric

Examples...

AddDimDiametric Method example


PaperSpace.AddDimOrdinate Method

Creates an ordinate dimension.

Syntax

object.AddDimOrdinate(DefinitionPoint, LeaderEndPoint, UseXAxis)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
DefinitionPoint | Input-only | Variant | -
LeaderEndPoint | Input-only | Variant | -
UseXAxis | Input-only | Integer | -

Return value

DimOrdinate

Examples...

AddDimOrdinate Method example


PaperSpace.AddDimRadial Method

Creates a radial dimension.

Syntax

object.AddDimRadial(Center, ChordPoint, LeaderLength)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
ChordPoint | Input-only | Variant | -
LeaderLength | Input-only | Double | -

Return value

DimRadial

Examples...

AddDimRadial Method example


PaperSpace.AddDimRotated Method

Creates a linear dimension.

Syntax

object.AddDimRotated(ExtLine1Point, ExtLine2Point, DimLineLocation, RotationAngle)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
ExtLine1Point | Input-only | Variant | -
ExtLine2Point | Input-only | Variant | -
DimLineLocation | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Return value

DimRotated

Examples...

AddDimRotated Method example


PaperSpace.AddEllipse Method

Creates an ellipse in the current UCS given the center, major and minor axes.

Syntax

object.AddEllipse(Center, MajorAxis, RadiusRatio)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
MajorAxis | Input-only | Variant | -
RadiusRatio | Input-only | Double | -

Return value

Ellipse

Examples...

AddEllipse Method example


PaperSpace.AddEllipticalCone Method

Creates a cone given the center, major and minor radii and height.

Syntax

object.AddEllipticalCone(Center, MajorRadius, MinorRadius, Height)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
MajorRadius | Input-only | Double | -
MinorRadius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddEllipticalCone Method example


PaperSpace.AddEllipticalCylinder Method

Creates a cylinder given the center, major and minor radii and height.

Syntax

object.AddEllipticalCylinder(Center, MajorRadius, MinorRadius, Height)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
MajorRadius | Input-only | Double | -
MinorRadius | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddEllipticalCylinder Method example


PaperSpace.AddExtrudedSolid Method

Creates an extruded solid given the profile and a height.

Syntax

object.AddExtrudedSolid(Profile, Height, TaperAngle)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Profile | Input-only | Region | -
Height | Input-only | Double | -
TaperAngle | Input-only | Double | -

Return value

3DSolid

Examples...

AddExtrudedSolid Method example


PaperSpace.AddExtrudedSolidAlongPath Method

Creates an extruded solid given the profile and a path.

Syntax

object.AddExtrudedSolidAlongPath(Profile, Path)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Profile | Input-only | Region | -
Path | Input-only | Object | -

Return value

3DSolid

Examples...

AddExtrudedSolidAlongPath Method example


PaperSpace.AddHatch Method

Creates a hatch entity.

Syntax

object.AddHatch(PatternType, PatternName, Associativity, HatchObjectType)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
PatternType | Input-only | Integer | -
PatternName | Input-only | String | -
Associativity | Input-only | Boolean | -
HatchObjectType | Input-only, Optional | Variant | -

Return value

Hatch

Examples...

AddHatch Method example


PaperSpace.AddLeader Method

Creates a leader line.

Syntax

object.AddLeader(PointsArray, Annotation, Type)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -
Annotation | Input-only | Entity | -
Type | Input-only | ZcLeaderType | Can be one of the constants listed here: zcLineNoArrow zcSplineNoArrow zcLineWithArrow zcSplineWithArrow

Return value

Leader

Examples...

AddLeader Method example


PaperSpace.AddLine Method

Adds a line to ModelSpace or PaperSpace or a block.

Syntax

object.AddLine(StartPoint, EndPoint)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
StartPoint | Input-only | Variant | -
EndPoint | Input-only | Variant | -

Return value

Line

Examples...

AddLine Method example


PaperSpace.AddMInsertBlock Method

Inserts an array of blocks in the current document.

Syntax

object.AddMInsertBlock(InsertionPoint, Name, Xscale, Yscale, Zscale, Rotation, NumRows, NumColumns, RowSpacing, ColumnSpacing, Password)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
InsertionPoint | Input-only | Variant | -
Name | Input-only | String | -
Xscale | Input-only | Double | -
Yscale | Input-only | Double | -
Zscale | Input-only | Double | -
Rotation | Input-only | Double | -
NumRows | Input-only | Long | -
NumColumns | Input-only | Long | -
RowSpacing | Input-only | Long | -
ColumnSpacing | Input-only | Long | -
Password | Input-only, Optional | Variant | -

Return value

MInsertBlock


PaperSpace.AddMLine Method

Inserts an mline object in the current document.

Syntax

object.AddMLine(VertexList)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
VertexList | Input-only | Variant | -

Return value

MLine

Examples...

AddMLine Method example


PaperSpace.AddPViewport Method

Create a paperspace viewport.

Syntax

object.AddPViewport(Center, Width, Height)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Width | Input-only | Double | -
Height | Input-only | Double | -

Return value

PViewport

Examples...

AddPViewport Method example


PaperSpace.AddPoint Method

Creates a point entity at a given location.

Syntax

object.AddPoint(Point)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Point | Input-only | Variant | -

Return value

Point

Examples...

AddPoint Method example


PaperSpace.AddPolyfaceMesh Method

Inserts polyface mesh object in the current document.

Syntax

object.AddPolyfaceMesh(VertexList, FaceList)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
VertexList | Input-only | Variant | -
FaceList | Input-only | Variant | -

Return value

PolyfaceMesh

Examples...

AddPolyfaceMesh Method example


PaperSpace.AddPolyline Method

Creates a polyline.

Syntax

object.AddPolyline(VerticesList)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
VerticesList | Input-only | Variant | -

Return value

Polyline

Examples...

AddPolyline Method example


PaperSpace.AddRaster Method

Creates a raster based of given image filename.

Syntax

object.AddRaster(imageFileName, InsertionPoint, ScaleFactor, RotationAngle)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
imageFileName | Input-only | String | -
InsertionPoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -
RotationAngle | Input-only | Double | -

Return value

RasterImage

Examples...

AddRaster Method example


PaperSpace.AddRay Method

Creates a ray passing through two given points.

Syntax

object.AddRay(Point1, Point2)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Ray

Examples...

AddRay Method example


PaperSpace.AddRegion Method

Creates a region from the given closed curve sets.

Syntax

object.AddRegion(ObjectList)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
ObjectList | Input-only | Variant | -

Return value

Variant

Examples...

AddRegion Method example


PaperSpace.AddRevolvedSolid Method

Creates a revolved solid given the profile and a revolution path.

Syntax

object.AddRevolvedSolid(Profile, AxisPoint, AxisDir, Angle)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Profile | Input-only | Region | -
AxisPoint | Input-only | Variant | -
AxisDir | Input-only | Variant | -
Angle | Input-only | Double | -

Return value

3DSolid

Examples...

AddRevolvedSolid Method example


PaperSpace.AddShape Method

Creates a given shape.

Syntax

object.AddShape(Name, InsertionPoint, ScaleFactor, RotationAngle)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -
InsertionPoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -
RotationAngle | Input-only | Double | -

Return value

Shape

Examples...

AddShape Method example


PaperSpace.AddSolid Method

Creates an ZWCAD solid.

Syntax

object.AddSolid(Point1, Point2, point3, Point4)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -
point3 | Input-only | Variant | -
Point4 | Input-only | Variant | -

Return value

Solid

Examples...

AddSolid Method example


PaperSpace.AddSphere Method

Creates a sphere given the center and radius.

Syntax

object.AddSphere(Center, Radius)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Radius | Input-only | Double | -

Return value

3DSolid

Examples...

AddSphere Method example


PaperSpace.AddSpline Method

Creates a B-spline given n points and the end tangents.

Syntax

object.AddSpline(PointsArray, StartTangent, EndTangent)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -
StartTangent | Input-only | Variant | -
EndTangent | Input-only | Variant | -

Return value

Spline

Examples...

AddSpline Method example


PaperSpace.AddTable Method

Creates a table at the given insertion point, given the number of rows, number of columns, row height and column width.

Syntax

object.AddTable(InsertionPoint, NumRows, NumColumns, RowHeight, ColWidth)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
InsertionPoint | Input-only | Variant | -
NumRows | Input-only | Integer | -
NumColumns | Input-only | Integer | -
RowHeight | Input-only | Double | -
ColWidth | Input-only | Double | -

Return value

Table


PaperSpace.AddText Method

Creates a text entity with specified height and rotation.

Syntax

object.AddText(TextString, InsertionPoint, Height)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
TextString | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Height | Input-only | Double | -

Return value

Text

Examples...

AddText Method example


PaperSpace.AddTolerance Method

Creates a tolerance.

Syntax

object.AddTolerance(Text, InsertionPoint, Direction)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Text | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Direction | Input-only | Variant | -

Return value

Tolerance

Examples...

AddTolerance Method example


PaperSpace.AddTorus Method

Creates a torus given the center, torus and tube radius.

Syntax

object.AddTorus(Center, TorusRadius, TubeRadius)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
TorusRadius | Input-only | Double | -
TubeRadius | Input-only | Double | -

Return value

3DSolid

Examples...

AddTorus Method example


PaperSpace.AddTrace Method

Creates a trace entity with four points.

Syntax

object.AddTrace(PointsArray)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
PointsArray | Input-only | Variant | -

Return value

Trace

Examples...

AddTrace Method example


PaperSpace.AddWedge Method

Creates a wedge with edges parallel to the axes given the length, width and height dimensions

Syntax

object.AddWedge(Center, Length, Width, Height)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Center | Input-only | Variant | -
Length | Input-only | Double | -
Width | Input-only | Double | -
Height | Input-only | Double | -

Return value

3DSolid

Examples...

AddWedge Method example


PaperSpace.AttachExternalReference Method

Attach an external reference to the block.

Syntax

object.AttachExternalReference(PathName, Name, InsertionPoint, Xscale, Yscale, Zscale, Rotation, bOverlay, Password)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
PathName | Input-only | String | -
Name | Input-only | String | -
InsertionPoint | Input-only | Variant | -
Xscale | Input-only | Double | -
Yscale | Input-only | Double | -
Zscale | Input-only | Double | -
Rotation | Input-only | Double | -
bOverlay | Input-only | Boolean | -
Password | Input-only, Optional | Variant | -

Return value

ExternalReference

Examples...

AttachExternalReference Method example


PaperSpace.Bind Method

Bind the external reference.

Syntax

object.Bind(bPrefixName)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
bPrefixName | Input-only | Boolean | -

Examples...

Bind Method example


PaperSpace.Delete Method

Deletes the object.

Syntax

object.Delete

object is a PaperSpace object.

Examples...

Delete Method example


PaperSpace.Detach Method

Detach the external reference.

Syntax

object.Detach

object is a PaperSpace object.

Examples...

Detach Method example


PaperSpace.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a PaperSpace object.

Examples...

Erase Method example


PaperSpace.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a PaperSpace object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


PaperSpace.InsertBlock Method

Inserts an instance of a block in the current document.

Syntax

object.InsertBlock(InsertionPoint, Name, Xscale, Yscale, Zscale, Rotation, Password)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
InsertionPoint | Input-only | Variant | -
Name | Input-only | String | -
Xscale | Input-only | Double | -
Yscale | Input-only | Double | -
Zscale | Input-only | Double | -
Rotation | Input-only | Double | -
Password | Input-only, Optional | Variant | -

Return value

BlockReference

Examples...

InsertBlock Method example


PaperSpace.Item Method

Returns an entity in the collection.

Syntax

object.Item(Index)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Entity

Examples...

Item Method example


PaperSpace.Reload Method

Reload the external reference.

Syntax

object.Reload

object is a PaperSpace object.

Examples...

Reload Method example


PaperSpace.Unload Method

Unload the external reference.

Syntax

object.Unload

object is a PaperSpace object.


PaperSpace.Application Property

Returns the application object.

Syntax

object.Application

object is a PaperSpace object.

Description

Application Object; Read-only

Examples...

Application Property example


PaperSpace.Comments Property

Specifies the comments you want to use to locate the drawing.

Syntax

object.Comments

object is a PaperSpace object.

Description

Comments String; Read-write

Examples...

Comments Property example


PaperSpace.Count Property

Returns the number of entities in the collections.

Syntax

object.Count

object is a PaperSpace object.

Description

Count Long; Read-only

Examples...

Count Property example


PaperSpace.Database Property

Returns the database object.

Syntax

object.Database

object is a PaperSpace object.

Description

Database Database; Read-only


PaperSpace.Document Property

Returns the document object.

Syntax

object.Document

object is a PaperSpace object.

Description

Document Object; Read-only


PaperSpace.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a PaperSpace object.

Description

Handle String; Read-only


PaperSpace.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a PaperSpace object.

Description

HasExtensionDictionary Boolean; Read-only


PaperSpace.IsLayout Property

Returns a value indicating whether the block is also a layout.

Syntax

object.IsLayout

object is a PaperSpace object.

Description

IsLayout Boolean; Read-only

Examples...

IsLayout Property example


PaperSpace.IsXRef Property

Returns a boolean indicating whether the block is an external reference.

Syntax

object.IsXRef

object is a PaperSpace object.

Description

IsXRef Boolean; Read-only

Examples...

IsXRef Property example


PaperSpace.Layout Property

Returns the associated layout object.

Syntax

object.Layout

object is a PaperSpace object.

Description

Layout Layout; Read-only

Examples...

Layout Property example


PaperSpace.Name Property

Returns and sets the name of the block.

Syntax

object.Name

object is a PaperSpace object.

Description

Name String; Read-write

Examples...

Name Property example


PaperSpace.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a PaperSpace object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


PaperSpace.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a PaperSpace object.

Description

ObjectName String; Read-only


PaperSpace.Origin Property

Returns and sets the origin of the block definition.

Syntax

object.Origin

object is a PaperSpace object.

Description

Origin Variant; Read-write

Examples...

Origin Property example


PaperSpace.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a PaperSpace object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


PaperSpace.Path Property

Gets the path of the block, document, application, or external reference.

Syntax

object.Path

object is a PaperSpace object.

Description

Path String; Read-write

Examples...

Path Property example


PaperSpace.XRefDatabase Property

Returns a database object that defines the contents of the block.

Syntax

object.XRefDatabase

object is a PaperSpace object.

Description

XRefDatabase Database; Read-only


PaperSpace.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a PaperSpace object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadPlot Object Members

Plot Object Members

The set of methods and properties used for plotting layouts.

VBA Class Name

ZcadPlot

Methods

Name | Description
DisplayPlotPreview | Bring up plot preview dialog.
PlotToDevice | Plot to a device.
PlotToFile | Plot to a file.
SetLayoutsToPlot | Specify layouts to plot
StartBatchMode | Start batch plot mode

Properties

Name | Description
Application | Returns the application object.
BatchPlotProgress | Gets batch plot progress status.
NumberOfCopies | Gets the number of copies to be plotted.
QuietErrorMode | Gets quiet error mode.

Events

Name | Description
None | -


Plot.DisplayPlotPreview Method

Bring up plot preview dialog.

Syntax

object.DisplayPlotPreview(Preview)

object is a Plot object.

Parameters

Name | Options | Data Type | Description
Preview | Input-only | ZcPreviewMode | Can be one of the constants listed here: zcPartialPreview zcFullPreview

Examples...

DisplayPlotPreview Method example


Plot.PlotToDevice Method

Plot to a device.

Syntax

object.PlotToDevice(plotConfig)

object is a Plot object.

Parameters

Name | Options | Data Type | Description
plotConfig | Input-only, Optional | Variant | -

Return value

Boolean

Examples...

PlotToDevice Method example


Plot.PlotToFile Method

Plot to a file.

Syntax

object.PlotToFile(plotFile, plotConfig)

object is a Plot object.

Parameters

Name | Options | Data Type | Description
plotFile | Input-only | String | -
plotConfig | Input-only, Optional | Variant | -

Return value

Boolean

Examples...

PlotToFile Method example


Plot.SetLayoutsToPlot Method

Specify layouts to plot

Syntax

object.SetLayoutsToPlot(layoutList)

object is a Plot object.

Parameters

Name | Options | Data Type | Description
layoutList | Input-only | Variant | -

Examples...

SetLayoutsToPlot Method example


Plot.StartBatchMode Method

Start batch plot mode

Syntax

object.StartBatchMode(entryCount)

object is a Plot object.

Parameters

Name | Options | Data Type | Description
entryCount | Input-only | Long | -


Plot.Application Property

Returns the application object.

Syntax

object.Application

object is a Plot object.

Description

Application Application; Read-only

Examples...

Application Property example


Plot.BatchPlotProgress Property

Gets batch plot progress status.

Syntax

object.BatchPlotProgress

object is a Plot object.

Description

BatchPlotProgress Boolean; Read-write


Plot.NumberOfCopies Property

Gets the number of copies to be plotted.

Syntax

object.NumberOfCopies

object is a Plot object.

Description

NumberOfCopies Long; Read-write

Examples...

NumberOfCopies Property example


Plot.QuietErrorMode Property

Gets quiet error mode.

Syntax

object.QuietErrorMode

object is a Plot object.

Description

QuietErrorMode Boolean; Read-write


ZcadPlotConfiguration Object Members

PlotConfiguration Object Members

A named collection of plot settings.

VBA Class Name

ZcadPlotConfiguration

Methods

Name | Description
CopyFrom | Copies the settings from the given plot configuration.
Delete | Deletes the object.
Erase | Erases the entity object.
GetCanonicalMediaNames | Gets all available canonical media names for the specified plot device.
GetCustomScale | Returns the custom scale.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetLocaleMediaName | Gets the localized version of the canonical media name.
GetPaperMargins | Returns the paper margins.
GetPaperSize | Returns the paper size.
GetPlotDeviceNames | Gets all available plot device names.
GetPlotStyleTableNames | Gets all available plot style table names.
GetWindowToPlot | Returns the window coordinates to plot.
RefreshPlotDeviceInfo | Updates the plot, canonical media, and plot style table information to reflect the current system state.
SetCustomScale | Sets the custom scale.
SetWindowToPlot | Sets the window coordinates to plot.

Properties

Name | Description
Application | Returns the application object.
CanonicalMediaName | Returns and sets the canonical name of the selected media.
CenterPlot | Returns and sets centering of the plot on media.
ConfigName | Returns and sets the config name (PC3 name or system printer).
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ModelType | Specifies if the plot configuration applies only to model space or to all layouts
Name | Returns and sets the name of the plot configuration.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PaperUnits | Returns and sets the display units of the plot dimensions.
PlotHidden | Returns and sets hidden-line removal.
PlotOrigin | Returns and sets the origin relative to LLC of media.
PlotRotation | Returns and sets the image orientation on the media.
PlotType | Returns and sets plot type.
PlotViewportBorders | Returns and sets the plotting of viewport borders.
PlotViewportsFirst | Returns and sets the plotting of viewports first.
PlotWithLineweights | Returns and sets the plotting of lineweights.
PlotWithPlotStyles | Returns and sets the plotting of plot styles.
ScaleLineweights | Returns and sets the scaling of lineweights.
ShowPlotStyles | Returns and sets the display of plot styles.
StandardScale | Returns and sets the standard scale.
StyleSheet | Returns and sets style sheet to use.
UseStandardScale | Returns and sets using of standard or custom scale.
ViewToPlot | Returns and sets the view to plot.

Events

Name | Description
Modified | Happens when object is modified


PlotConfiguration.CopyFrom Method

Copies the settings from the given plot configuration.

Syntax

object.CopyFrom(pPlotConfig)

object is a PlotConfiguration object.

Parameters

Name | Options | Data Type | Description
pPlotConfig | Input-only | PlotConfiguration | -

Examples...

CopyFrom Method example


PlotConfiguration.Delete Method

Deletes the object.

Syntax

object.Delete

object is a PlotConfiguration object.

Examples...

Delete Method example


PlotConfiguration.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a PlotConfiguration object.

Examples...

Erase Method example


PlotConfiguration.GetCanonicalMediaNames Method

Gets all available canonical media names for the specified plot device.

Syntax

object.GetCanonicalMediaNames

object is a PlotConfiguration object.

Return value

Variant


PlotConfiguration.GetCustomScale Method

Returns the custom scale.

Syntax

object.GetCustomScale(Numerator, Denominator)

object is a PlotConfiguration object.

Parameters

Name | Options | Data Type | Description
Numerator | Output-only | Double | -
Denominator | Output-only | Double | -

Examples...

GetCustomScale Method example


PlotConfiguration.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a PlotConfiguration object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


PlotConfiguration.GetLocaleMediaName Method

Gets the localized version of the canonical media name.

Syntax

object.GetLocaleMediaName(Name)

object is a PlotConfiguration object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

String

Examples...

GetLocaleMediaName Method example


PlotConfiguration.GetPaperMargins Method

Returns the paper margins.

Syntax

object.GetPaperMargins(LowerLeft, UpperRight)

object is a PlotConfiguration object.

Parameters

Name | Options | Data Type | Description
LowerLeft | Output-only | Variant | -
UpperRight | Output-only | Variant | -

Examples...

GetPaperMargins Method example


PlotConfiguration.GetPaperSize Method

Returns the paper size.

Syntax

object.GetPaperSize(Width, Height)

object is a PlotConfiguration object.

Parameters

Name | Options | Data Type | Description
Width | Output-only | Double | -
Height | Output-only | Double | -

Examples...

GetPaperSize Method example


PlotConfiguration.GetPlotDeviceNames Method

Gets all available plot device names.

Syntax

object.GetPlotDeviceNames

object is a PlotConfiguration object.

Return value

Variant

Examples...

GetPlotDeviceNames Method example


PlotConfiguration.GetPlotStyleTableNames Method

Gets all available plot style table names.

Syntax

object.GetPlotStyleTableNames

object is a PlotConfiguration object.

Return value

Variant

Examples...

GetPlotStyleTableNames Method example


PlotConfiguration.GetWindowToPlot Method

Returns the window coordinates to plot.

Syntax

object.GetWindowToPlot(LowerLeft, UpperRight)

object is a PlotConfiguration object.

Parameters

Name | Options | Data Type | Description
LowerLeft | Output-only | Variant | -
UpperRight | Output-only | Variant | -

Examples...

GetWindowToPlot Method example


PlotConfiguration.RefreshPlotDeviceInfo Method

Updates the plot, canonical media, and plot style table information to reflect the current system state.

Syntax

object.RefreshPlotDeviceInfo

object is a PlotConfiguration object.

Examples...

RefreshPlotDeviceInfo Method example


PlotConfiguration.SetCustomScale Method

Sets the custom scale.

Syntax

object.SetCustomScale(Numerator, Denominator)

object is a PlotConfiguration object.

Parameters

Name | Options | Data Type | Description
Numerator | Input-only | Double | -
Denominator | Input-only | Double | -

Examples...

SetCustomScale Method example


PlotConfiguration.SetWindowToPlot Method

Sets the window coordinates to plot.

Syntax

object.SetWindowToPlot(LowerLeft, UpperRight)

object is a PlotConfiguration object.

Parameters

Name | Options | Data Type | Description
LowerLeft | Input-only | Variant | -
UpperRight | Input-only | Variant | -


PlotConfiguration.Application Property

Returns the application object.

Syntax

object.Application

object is a PlotConfiguration object.

Description

Application Object; Read-only

Examples...

Application Property example


PlotConfiguration.CanonicalMediaName Property

Returns and sets the canonical name of the selected media.

Syntax

object.CanonicalMediaName

object is a PlotConfiguration object.

Description

CanonicalMediaName String; Read-write

Examples...

CanonicalMediaName Property example


PlotConfiguration.CenterPlot Property

Returns and sets centering of the plot on media.

Syntax

object.CenterPlot

object is a PlotConfiguration object.

Description

CenterPlot Boolean; Read-write

Examples...

CenterPlot Property example


PlotConfiguration.ConfigName Property

Returns and sets the config name (PC3 name or system printer).

Syntax

object.ConfigName

object is a PlotConfiguration object.

Description

ConfigName String; Read-write

Examples...

ConfigName Property example


PlotConfiguration.Database Property

Returns the database object.

Syntax

object.Database

object is a PlotConfiguration object.

Description

Database Database; Read-only


PlotConfiguration.Document Property

Returns the document object.

Syntax

object.Document

object is a PlotConfiguration object.

Description

Document Object; Read-only


PlotConfiguration.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a PlotConfiguration object.

Description

Handle String; Read-only


PlotConfiguration.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a PlotConfiguration object.

Description

HasExtensionDictionary Boolean; Read-only


PlotConfiguration.ModelType Property

Specifies if the plot configuration applies only to model space or to all layouts

Syntax

object.ModelType

object is a PlotConfiguration object.

Description

ModelType Boolean; Read-only

Examples...

ModelType Property example


PlotConfiguration.Name Property

Returns and sets the name of the plot configuration.

Syntax

object.Name

object is a PlotConfiguration object.

Description

Name String; Read-write

Examples...

Name Property example


PlotConfiguration.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a PlotConfiguration object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


PlotConfiguration.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a PlotConfiguration object.

Description

ObjectName String; Read-only


PlotConfiguration.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a PlotConfiguration object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


PlotConfiguration.PaperUnits Property

Returns and sets the display units of the plot dimensions.

Syntax

object.PaperUnits

object is a PlotConfiguration object.

Description

PaperUnits ZcPlotPaperUnits: Read-write
Can be one of the constants listed here:
zcInches
zcMillimeters
zcPixels

Examples...

PaperUnits Property example


PlotConfiguration.PlotHidden Property

Returns and sets hidden-line removal.

Syntax

object.PlotHidden

object is a PlotConfiguration object.

Description

PlotHidden Boolean; Read-write

Examples...

PlotHidden Property example


PlotConfiguration.PlotOrigin Property

Returns and sets the origin relative to LLC of media.

Syntax

object.PlotOrigin

object is a PlotConfiguration object.

Description

PlotOrigin Variant; Read-write

Examples...

PlotOrigin Property example


PlotConfiguration.PlotRotation Property

Returns and sets the image orientation on the media.

Syntax

object.PlotRotation

object is a PlotConfiguration object.

Description

PlotRotation ZcPlotRotation: Read-write
Can be one of the constants listed here:
zc0degrees
zc90degrees
zc180degrees
zc270degrees

Examples...

PlotRotation Property example


PlotConfiguration.PlotType Property

Returns and sets plot type.

Syntax

object.PlotType

object is a PlotConfiguration object.

Description

PlotType ZcPlotType: Read-write
Can be one of the constants listed here:
zcDisplay
zcExtents
zcLimits
zcView
zcWindow
zcLayout

Examples...

PlotType Property example


PlotConfiguration.PlotViewportBorders Property

Returns and sets the plotting of viewport borders.

Syntax

object.PlotViewportBorders

object is a PlotConfiguration object.

Description

PlotViewportBorders Boolean; Read-write

Examples...

PlotViewportBorders Property example


PlotConfiguration.PlotViewportsFirst Property

Returns and sets the plotting of viewports first.

Syntax

object.PlotViewportsFirst

object is a PlotConfiguration object.

Description

PlotViewportsFirst Boolean; Read-write

Examples...

PlotViewportsFirst Property example


PlotConfiguration.PlotWithLineweights Property

Returns and sets the plotting of lineweights.

Syntax

object.PlotWithLineweights

object is a PlotConfiguration object.

Description

PlotWithLineweights Boolean; Read-write

Examples...

PlotWithLineweights Property example


PlotConfiguration.PlotWithPlotStyles Property

Returns and sets the plotting of plot styles.

Syntax

object.PlotWithPlotStyles

object is a PlotConfiguration object.

Description

PlotWithPlotStyles Boolean; Read-write

Examples...

PlotWithPlotStyles Property example


PlotConfiguration.ScaleLineweights Property

Returns and sets the scaling of lineweights.

Syntax

object.ScaleLineweights

object is a PlotConfiguration object.

Description

ScaleLineweights Boolean; Read-write

Examples...

ScaleLineweights Property example


PlotConfiguration.ShowPlotStyles Property

Returns and sets the display of plot styles.

Syntax

object.ShowPlotStyles

object is a PlotConfiguration object.

Description

ShowPlotStyles Boolean; Read-write

Examples...

ShowPlotStyles Property example


PlotConfiguration.StandardScale Property

Returns and sets the standard scale.

Syntax

object.StandardScale

object is a PlotConfiguration object.

Description

StandardScale ZcPlotScale: Read-write
Can be one of the constants listed here:
zcScaleToFit
zc1_128in_1ft
zc1_64in_1ft
zc1_32in_1ft
zc1_16in_1ft
zc3_32in_1ft
zc1_8in_1ft
zc3_16in_1ft
zc1_4in_1ft
zc3_8in_1ft
zc1_2in_1ft
zc3_4in_1ft
zc1in_1ft
zc3in_1ft
zc6in_1ft
zc1ft_1ft
zc1_1
zc1_2
zc1_4
zc1_5
zc1_8
zc1_10
zc1_16
zc1_20
zc1_30
zc1_40
zc1_50
zc1_100
zc2_1
zc4_1
zc8_1
zc10_1
zc100_1

Examples...

StandardScale Property example


PlotConfiguration.StyleSheet Property

Returns and sets style sheet to use.

Syntax

object.StyleSheet

object is a PlotConfiguration object.

Description

StyleSheet String; Read-write

Examples...

StyleSheet Property example


PlotConfiguration.UseStandardScale Property

Returns and sets using of standard or custom scale.

Syntax

object.UseStandardScale

object is a PlotConfiguration object.

Description

UseStandardScale Boolean; Read-write

Examples...

UseStandardScale Property example


PlotConfiguration.ViewToPlot Property

Returns and sets the view to plot.

Syntax

object.ViewToPlot

object is a PlotConfiguration object.

Description

ViewToPlot String; Read-write


PlotConfiguration.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a PlotConfiguration object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadPlotConfigurations Object Members

PlotConfigurations Object Members

A collection of named plot settings.

VBA Class Name

ZcadPlotConfigurations

Methods

Name | Description
Add | Adds a plot configuration to the collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


PlotConfigurations.Add Method

Adds a plot configuration to the collection.

Syntax

object.Add(Name, ModelType)

object is a PlotConfigurations object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -
ModelType | Input-only, Optional | Variant | -

Return value

PlotConfiguration

Examples...

Add Method example


PlotConfigurations.Delete Method

Deletes the object.

Syntax

object.Delete

object is a PlotConfigurations object.

Examples...

Delete Method example


PlotConfigurations.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a PlotConfigurations object.

Examples...

Erase Method example


PlotConfigurations.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a PlotConfigurations object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


PlotConfigurations.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a PlotConfigurations object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

PlotConfiguration

Examples...

Item Method example


PlotConfigurations.Application Property

Returns the application object.

Syntax

object.Application

object is a PlotConfigurations object.

Description

Application Object; Read-only

Examples...

Application Property example


PlotConfigurations.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a PlotConfigurations object.

Description

Count Long; Read-only

Examples...

Count Property example


PlotConfigurations.Database Property

Returns the database object.

Syntax

object.Database

object is a PlotConfigurations object.

Description

Database Database; Read-only


PlotConfigurations.Document Property

Returns the document object.

Syntax

object.Document

object is a PlotConfigurations object.

Description

Document Object; Read-only


PlotConfigurations.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a PlotConfigurations object.

Description

Handle String; Read-only


PlotConfigurations.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a PlotConfigurations object.

Description

HasExtensionDictionary Boolean; Read-only


PlotConfigurations.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a PlotConfigurations object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


PlotConfigurations.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a PlotConfigurations object.

Description

ObjectName String; Read-only


PlotConfigurations.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a PlotConfigurations object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


PlotConfigurations.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a PlotConfigurations object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadPoint Object Members

Point Object Members

A point marker appearing as a dot, square, circle, X, tick, or plus sign (+); or as a combination of these.

VBA Class Name

ZcadPoint

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Coordinates | Specifies the coordinates of the point
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Thickness | Specifies the thickness of the point
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Point.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Point object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Point.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Point object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Point.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Point object.

Return value

Object

Examples...

Copy Method example


Point.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Point object.

Examples...

Delete Method example


Point.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Point object.

Examples...

Erase Method example


Point.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Point object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Point.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Point object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Point.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Point object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Point.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Point object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Point.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Point object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Point.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Point object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Point.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Point object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Point.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Point object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Point.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Point object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Point.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Point object.


Point.Application Property

Returns the application object.

Syntax

object.Application

object is a Point object.

Description

Application Object; Read-only

Examples...

Application Property example


Point.Coordinates Property

Specifies the coordinates of the point

Syntax

object.Coordinates

object is a Point object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


Point.Database Property

Returns the database object.

Syntax

object.Database

object is a Point object.

Description

Database Database; Read-only


Point.Document Property

Returns the document object.

Syntax

object.Document

object is a Point object.

Description

Document Object; Read-only


Point.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Point object.

Description

Handle String; Read-only


Point.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Point object.

Description

HasExtensionDictionary Boolean; Read-only


Point.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Point object.

Description

Hyperlinks Hyperlinks; Read-only


Point.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Point object.

Description

Layer String; Read-write

Examples...

Layer Property example


Point.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Point object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Point.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Point object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Point.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Point object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Point.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a Point object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Point.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Point object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Point.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Point object.

Description

ObjectName String; Read-only


Point.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Point object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Point.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Point object.

Description

PlotStyleName String; Read-write


Point.Thickness Property

Specifies the thickness of the point

Syntax

object.Thickness

object is a Point object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


Point.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Point object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Point.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Point object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Point.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Point object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadPolyfaceMesh Object Members

PolyfaceMesh Object Members

A three-dimensional polyface mesh.

VBA Class Name

ZcadPolyfaceMesh

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Coordinate | Returns the coordinate of the vertex at a given index
Coordinates | Specifies the vertices of the mesh
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
NumberOfFaces | Specifies the number of faces in the mesh
NumberOfVertices | Specifies the number of vertices in the mesh
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


PolyfaceMesh.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


PolyfaceMesh.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


PolyfaceMesh.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a PolyfaceMesh object.

Return value

Object

Examples...

Copy Method example


PolyfaceMesh.Delete Method

Deletes the object.

Syntax

object.Delete

object is a PolyfaceMesh object.

Examples...

Delete Method example


PolyfaceMesh.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a PolyfaceMesh object.

Examples...

Erase Method example


PolyfaceMesh.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


PolyfaceMesh.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a PolyfaceMesh object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


PolyfaceMesh.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


PolyfaceMesh.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


PolyfaceMesh.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


PolyfaceMesh.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


PolyfaceMesh.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


PolyfaceMesh.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


PolyfaceMesh.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


PolyfaceMesh.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a PolyfaceMesh object.


PolyfaceMesh.Application Property

Returns the application object.

Syntax

object.Application

object is a PolyfaceMesh object.

Description

Application Object; Read-only

Examples...

Application Property example


PolyfaceMesh.Coordinate Property

Returns the coordinate of the vertex at a given index

Syntax

object.Coordinate

object is a PolyfaceMesh object.

Description

Coordinate Variant; Read-write

Examples...

Coordinate Property example


PolyfaceMesh.Coordinates Property

Specifies the vertices of the mesh

Syntax

object.Coordinates

object is a PolyfaceMesh object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


PolyfaceMesh.Database Property

Returns the database object.

Syntax

object.Database

object is a PolyfaceMesh object.

Description

Database Database; Read-only


PolyfaceMesh.Document Property

Returns the document object.

Syntax

object.Document

object is a PolyfaceMesh object.

Description

Document Object; Read-only


PolyfaceMesh.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a PolyfaceMesh object.

Description

Handle String; Read-only


PolyfaceMesh.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a PolyfaceMesh object.

Description

HasExtensionDictionary Boolean; Read-only


PolyfaceMesh.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a PolyfaceMesh object.

Description

Hyperlinks Hyperlinks; Read-only


PolyfaceMesh.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a PolyfaceMesh object.

Description

Layer String; Read-write

Examples...

Layer Property example


PolyfaceMesh.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a PolyfaceMesh object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


PolyfaceMesh.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a PolyfaceMesh object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


PolyfaceMesh.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a PolyfaceMesh object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


PolyfaceMesh.NumberOfFaces Property

Specifies the number of faces in the mesh

Syntax

object.NumberOfFaces

object is a PolyfaceMesh object.

Description

NumberOfFaces Long; Read-only

Examples...

NumberOfFaces Property example


PolyfaceMesh.NumberOfVertices Property

Specifies the number of vertices in the mesh

Syntax

object.NumberOfVertices

object is a PolyfaceMesh object.

Description

NumberOfVertices Long; Read-only

Examples...

NumberOfVertices Property example


PolyfaceMesh.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a PolyfaceMesh object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


PolyfaceMesh.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a PolyfaceMesh object.

Description

ObjectName String; Read-only


PolyfaceMesh.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a PolyfaceMesh object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


PolyfaceMesh.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a PolyfaceMesh object.

Description

PlotStyleName String; Read-write


PolyfaceMesh.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a PolyfaceMesh object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


PolyfaceMesh.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a PolyfaceMesh object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


PolyfaceMesh.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a PolyfaceMesh object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadPolygonMesh Object Members

PolygonMesh Object Members

A free-form 3D mesh.

VBA Class Name

ZcadPolygonMesh

Methods

Name | Description
AppendVertex | Appends a vertex to the polygonmesh
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
Explode | Explodes the polygonmesh and returns the sub-entities as an array of object
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Coordinate | Returns the coordinate of the vertex at a given index
Coordinates | Specifies the coordinates of the polygonmesh
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
MVertexCount | Returns the M Vertex number of the polygonmesh
NDensity | Specifies N density value of the polygonmesh; valid values 2-256
NVertexCount | Specifies the N Vertex number of the polygonmesh
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
TrueColor | Returns the true color of the object.
Type | Specifies the type of the polygonmesh
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


PolygonMesh.AppendVertex Method

Appends a vertex to the polygonmesh

Syntax

object.AppendVertex(vertex)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
vertex | Input-only | Variant | -

Examples...

AppendVertex Method example


PolygonMesh.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


PolygonMesh.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


PolygonMesh.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a PolygonMesh object.

Return value

Object

Examples...

Copy Method example


PolygonMesh.Delete Method

Deletes the object.

Syntax

object.Delete

object is a PolygonMesh object.

Examples...

Delete Method example


PolygonMesh.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a PolygonMesh object.

Examples...

Erase Method example


PolygonMesh.Explode Method

Explodes the polygonmesh and returns the sub-entities as an array of object

Syntax

object.Explode

object is a PolygonMesh object.

Return value

Variant

Examples...

Explode Method example


PolygonMesh.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


PolygonMesh.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a PolygonMesh object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


PolygonMesh.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


PolygonMesh.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


PolygonMesh.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


PolygonMesh.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


PolygonMesh.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


PolygonMesh.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


PolygonMesh.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


PolygonMesh.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a PolygonMesh object.


PolygonMesh.Application Property

Returns the application object.

Syntax

object.Application

object is a PolygonMesh object.

Description

Application Object; Read-only

Examples...

Application Property example


PolygonMesh.Coordinate Property

Returns the coordinate of the vertex at a given index

Syntax

object.Coordinate

object is a PolygonMesh object.

Description

Coordinate Variant; Read-write

Examples...

Coordinate Property example


PolygonMesh.Coordinates Property

Specifies the coordinates of the polygonmesh

Syntax

object.Coordinates

object is a PolygonMesh object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


PolygonMesh.Database Property

Returns the database object.

Syntax

object.Database

object is a PolygonMesh object.

Description

Database Database; Read-only


PolygonMesh.Document Property

Returns the document object.

Syntax

object.Document

object is a PolygonMesh object.

Description

Document Object; Read-only


PolygonMesh.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a PolygonMesh object.

Description

Handle String; Read-only


PolygonMesh.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a PolygonMesh object.

Description

HasExtensionDictionary Boolean; Read-only


PolygonMesh.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a PolygonMesh object.

Description

Hyperlinks Hyperlinks; Read-only


PolygonMesh.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a PolygonMesh object.

Description

Layer String; Read-write

Examples...

Layer Property example


PolygonMesh.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a PolygonMesh object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


PolygonMesh.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a PolygonMesh object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


PolygonMesh.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a PolygonMesh object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


PolygonMesh.MVertexCount Property

Returns the M Vertex number of the polygonmesh

Syntax

object.MVertexCount

object is a PolygonMesh object.

Description

MVertexCount Long; Read-only

Examples...

MVertexCount Property example


PolygonMesh.NDensity Property

Specifies N density value of the polygonmesh; valid values 2-256

Syntax

object.NDensity

object is a PolygonMesh object.

Description

NDensity Long; Read-write


PolygonMesh.NVertexCount Property

Specifies the N Vertex number of the polygonmesh

Syntax

object.NVertexCount

object is a PolygonMesh object.

Description

NVertexCount Long; Read-only

Examples...

NVertexCount Property example


PolygonMesh.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a PolygonMesh object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


PolygonMesh.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a PolygonMesh object.

Description

ObjectName String; Read-only


PolygonMesh.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a PolygonMesh object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


PolygonMesh.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a PolygonMesh object.

Description

PlotStyleName String; Read-write


PolygonMesh.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a PolygonMesh object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


PolygonMesh.Type Property

Specifies the type of the polygonmesh

Syntax

object.Type

object is a PolygonMesh object.

Description

Type ZcPolymeshType: Read-write
Can be one of the constants listed here:
zcSimpleMesh
zcQuadSurfaceMesh
zcCubicSurfaceMesh
zcBezierSurfaceMesh

Examples...

Type Property example


PolygonMesh.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a PolygonMesh object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


PolygonMesh.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a PolygonMesh object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadPolyline Object Members

Polyline Object Members

A 2D line of adjustable width or a 3D line or mesh of nonadjustable width composed of line and arc segments.

VBA Class Name

ZcadPolyline

Methods

Name | Description
AppendVertex | Appends a vertex to the polyline
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
Explode | Explodes the polyline and returns the sub-entities as an array of Object
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetBulge | Returns the vertex bulge of the polyline
GetExtensionDictionary | Returns the extension dictionary for the object.
GetWidth | Returns segment width of the polyline
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Offset | Creates a new entity object by offsetting the polyline by a specified distance
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
SetBulge | Sets the vertex bulge of the polyline
SetWidth | Sets the segment width of the polyline
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Area | Specifies the area of the polyline
Closed | Returns whether the polyline is closed. Closes the polyline
ConstantWidth | Specifies the constant width for the polyline
Coordinate | Returns the coordinate of the vertex at a given index
Coordinates | Specifies the coordinates of the polyline
Database | Returns the database object.
Document | Returns the document object.
Elevation | Specifies the elevation of the polyline
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Length | Specifies the length of the polyline
Linetype | Specifies the linetype of the object.
LinetypeGeneration | Specifies whether linetype generation is on for the polyline. Controls linetype generation
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Thickness | Specifies the thickness of the polyline
TrueColor | Returns the true color of the object.
Type | Specifies the type of the polyline
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Polyline.AppendVertex Method

Appends a vertex to the polyline

Syntax

object.AppendVertex(vertex)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
vertex | Input-only | Variant | -

Examples...

AppendVertex Method example


Polyline.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Polyline.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Polyline.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Polyline object.

Return value

Object

Examples...

Copy Method example


Polyline.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Polyline object.

Examples...

Delete Method example


Polyline.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Polyline object.

Examples...

Erase Method example


Polyline.Explode Method

Explodes the polyline and returns the sub-entities as an array of Object

Syntax

object.Explode

object is a Polyline object.

Return value

Variant

Examples...

Explode Method example


Polyline.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Polyline.GetBulge Method

Returns the vertex bulge of the polyline

Syntax

object.GetBulge(Index)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -

Return value

Double

Examples...

GetBulge Method example


Polyline.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Polyline object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Polyline.GetWidth Method

Returns segment width of the polyline

Syntax

object.GetWidth(Index, StartWidth, EndWidth)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
StartWidth | Output-only | Double | -
EndWidth |  | Double | -

Examples...

GetWidth Method example


Polyline.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Polyline.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Polyline.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Polyline.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Polyline.Offset Method

Creates a new entity object by offsetting the polyline by a specified distance

Syntax

object.Offset(Distance)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
Distance | Input-only | Double | -

Return value

Variant


Polyline.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Polyline.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Polyline.SetBulge Method

Sets the vertex bulge of the polyline

Syntax

object.SetBulge(Index, bulge)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
bulge | Input-only | Double | -

Examples...

SetBulge Method example


Polyline.SetWidth Method

Sets the segment width of the polyline

Syntax

object.SetWidth(Index, StartWidth, EndWidth)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
StartWidth | Input-only | Double | -
EndWidth |  | Double | -

Examples...

SetWidth Method example


Polyline.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Polyline.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Polyline object.


Polyline.Application Property

Returns the application object.

Syntax

object.Application

object is a Polyline object.

Description

Application Object; Read-only

Examples...

Application Property example


Polyline.Area Property

Specifies the area of the polyline

Syntax

object.Area

object is a Polyline object.

Description

Area Double; Read-only

Examples...

Area Property example


Polyline.Closed Property

Returns whether the polyline is closed. Closes the polyline

Syntax

object.Closed

object is a Polyline object.

Description

Closed Boolean; Read-write

Examples...

Closed Property example


Polyline.ConstantWidth Property

Specifies the constant width for the polyline

Syntax

object.ConstantWidth

object is a Polyline object.

Description

ConstantWidth Double; Read-write

Examples...

ConstantWidth Property example


Polyline.Coordinate Property

Returns the coordinate of the vertex at a given index

Syntax

object.Coordinate

object is a Polyline object.

Description

Coordinate Variant; Read-write

Examples...

Coordinate Property example


Polyline.Coordinates Property

Specifies the coordinates of the polyline

Syntax

object.Coordinates

object is a Polyline object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


Polyline.Database Property

Returns the database object.

Syntax

object.Database

object is a Polyline object.

Description

Database Database; Read-only


Polyline.Document Property

Returns the document object.

Syntax

object.Document

object is a Polyline object.

Description

Document Object; Read-only


Polyline.Elevation Property

Specifies the elevation of the polyline

Syntax

object.Elevation

object is a Polyline object.

Description

Elevation Double; Read-write


Polyline.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Polyline object.

Description

Handle String; Read-only


Polyline.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Polyline object.

Description

HasExtensionDictionary Boolean; Read-only


Polyline.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Polyline object.

Description

Hyperlinks Hyperlinks; Read-only


Polyline.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Polyline object.

Description

Layer String; Read-write

Examples...

Layer Property example


Polyline.Length Property

Specifies the length of the polyline

Syntax

object.Length

object is a Polyline object.

Description

Length Double; Read-only

Examples...

Length Property example


Polyline.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Polyline object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Polyline.LinetypeGeneration Property

Specifies whether linetype generation is on for the polyline. Controls linetype generation

Syntax

object.LinetypeGeneration

object is a Polyline object.

Description

LinetypeGeneration Boolean; Read-write

Examples...

LinetypeGeneration Property example


Polyline.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Polyline object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Polyline.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Polyline object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Polyline.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a Polyline object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Polyline.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Polyline object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Polyline.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Polyline object.

Description

ObjectName String; Read-only


Polyline.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Polyline object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Polyline.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Polyline object.

Description

PlotStyleName String; Read-write


Polyline.Thickness Property

Specifies the thickness of the polyline

Syntax

object.Thickness

object is a Polyline object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


Polyline.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Polyline object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Polyline.Type Property

Specifies the type of the polyline

Syntax

object.Type

object is a Polyline object.

Description

Type ZcPolylineType: Read-write
Can be one of the constants listed here:
zcSimplePoly
zcFitCurvePoly
zcQuadSplinePoly
zcCubicSplinePoly

Examples...

Type Property example


Polyline.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Polyline object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Polyline.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Polyline object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadPopupMenu Object Members

PopupMenu Object Members

An ZWCAD cascading menu.

VBA Class Name

ZcadPopupMenu

Methods

Name | Description
AddMenuItem | Adds a popup menu item.
AddSeparator | Adds a popup menu separator.
AddSubMenu | Adds a submenu as a popup menu item.
InsertInMenuBar | Inserts the menu to ZWCAD menu bar.
Item | Returns an element in the collection.
RemoveFromMenuBar | Removes the menu from ZWCAD menu bar.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of elements in the collection.
Name | Returns and sets the name of the popup menu.
NameNoMnemonic | Returns the name of the popup menu with no underscore mnemonic.
OnMenuBar | Returns true if the menu is on the menu bar.
Parent | Returns the parent object.
TagString | Returns the tag of the popup menu.

Events

Name | Description
None | -


PopupMenu.AddMenuItem Method

Adds a popup menu item.

Syntax

object.AddMenuItem(Index, Label, Macro)

object is a PopupMenu object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -
Label | Input-only | String | -
Macro | Input-only | String | -

Return value

PopupMenuItem

Examples...

AddMenuItem Method example


PopupMenu.AddSeparator Method

Adds a popup menu separator.

Syntax

object.AddSeparator(Index)

object is a PopupMenu object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

PopupMenuItem

Examples...

AddSeparator Method example


PopupMenu.AddSubMenu Method

Adds a submenu as a popup menu item.

Syntax

object.AddSubMenu(Index, Label)

object is a PopupMenu object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -
Label | Input-only | String | -

Return value

PopupMenu

Examples...

AddSubMenu Method example


PopupMenu.InsertInMenuBar Method

Inserts the menu to ZWCAD menu bar.

Syntax

object.InsertInMenuBar(Index)

object is a PopupMenu object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Examples...

InsertInMenuBar Method example


PopupMenu.Item Method

Returns an element in the collection.

Syntax

object.Item(Index)

object is a PopupMenu object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

PopupMenuItem

Examples...

Item Method example


PopupMenu.RemoveFromMenuBar Method

Removes the menu from ZWCAD menu bar.

Syntax

object.RemoveFromMenuBar

object is a PopupMenu object.

Examples...

RemoveFromMenuBar Method example


PopupMenu.Application Property

Returns the application object.

Syntax

object.Application

object is a PopupMenu object.

Description

Application Application; Read-only

Examples...

Application Property example


PopupMenu.Count Property

Returns the number of elements in the collection.

Syntax

object.Count

object is a PopupMenu object.

Description

Count Long; Read-only

Examples...

Count Property example


PopupMenu.Name Property

Returns and sets the name of the popup menu.

Syntax

object.Name

object is a PopupMenu object.

Description

Name String; Read-write

Examples...

Name Property example


PopupMenu.NameNoMnemonic Property

Returns the name of the popup menu with no underscore mnemonic.

Syntax

object.NameNoMnemonic

object is a PopupMenu object.

Description

NameNoMnemonic String; Read-only


PopupMenu.OnMenuBar Property

Returns true if the menu is on the menu bar.

Syntax

object.OnMenuBar

object is a PopupMenu object.

Description

OnMenuBar Boolean; Read-only

Examples...

OnMenuBar Property example


PopupMenu.Parent Property

Returns the parent object.

Syntax

object.Parent

object is a PopupMenu object.

Description

Parent Object; Read-only

Examples...

Parent Property example


PopupMenu.TagString Property

Returns the tag of the popup menu.

Syntax

object.TagString

object is a PopupMenu object.

Description

TagString String; Read-only

Examples...

TagString Property example


ZcadPopupMenuItem Object Members

PopupMenuItem Object Members

A single menu item on an ZWCAD pull-down menu.

VBA Class Name

ZcadPopupMenuItem

Methods

Name | Description
Delete | Deletes the menu item.

Properties

Name | Description
Application | Returns the application object.
Caption | Returns the caption the menu item.
Check | Sets and erases check mark for the menu item.
Enable | Enables and disables the menu item.
EndSubMenuLevel | Returns and Sets the submenu level for the menu item.
HelpString | Returns and sets the help string associated the menu item.
Index | Returns the positional index of the menu item.
Label | Returns and sets the label of the menu item.
Macro | Returns and sets the macro associated the menu item.
Parent | Returns the parent object.
SubMenu | Returns the sub menu object.
TagString | Returns and sets the tag of the menu item.
Type | Returns the type of the menu item.

Events

Name | Description
None | -


PopupMenuItem.Delete Method

Deletes the menu item.

Syntax

object.Delete

object is a PopupMenuItem object.

Examples...

Delete Method example


PopupMenuItem.Application Property

Returns the application object.

Syntax

object.Application

object is a PopupMenuItem object.

Description

Application Application; Read-only

Examples...

Application Property example


PopupMenuItem.Caption Property

Returns the caption the menu item.

Syntax

object.Caption

object is a PopupMenuItem object.

Description

Caption String; Read-only

Examples...

Caption Property example


PopupMenuItem.Check Property

Sets and erases check mark for the menu item.

Syntax

object.Check

object is a PopupMenuItem object.

Description

Check Boolean; Read-write


PopupMenuItem.Enable Property

Enables and disables the menu item.

Syntax

object.Enable

object is a PopupMenuItem object.

Description

Enable Boolean; Read-write


PopupMenuItem.EndSubMenuLevel Property

Returns and Sets the submenu level for the menu item.

Syntax

object.EndSubMenuLevel

object is a PopupMenuItem object.

Description

EndSubMenuLevel Integer; Read-write


PopupMenuItem.HelpString Property

Returns and sets the help string associated the menu item.

Syntax

object.HelpString

object is a PopupMenuItem object.

Description

HelpString String; Read-write


PopupMenuItem.Index Property

Returns the positional index of the menu item.

Syntax

object.Index

object is a PopupMenuItem object.

Description

Index Integer; Read-only


PopupMenuItem.Label Property

Returns and sets the label of the menu item.

Syntax

object.Label

object is a PopupMenuItem object.

Description

Label String; Read-write


PopupMenuItem.Macro Property

Returns and sets the macro associated the menu item.

Syntax

object.Macro

object is a PopupMenuItem object.

Description

Macro String; Read-write

Examples...

Macro Property example


PopupMenuItem.Parent Property

Returns the parent object.

Syntax

object.Parent

object is a PopupMenuItem object.

Description

Parent PopupMenu; Read-only

Examples...

Parent Property example


PopupMenuItem.SubMenu Property

Returns the sub menu object.

Syntax

object.SubMenu

object is a PopupMenuItem object.

Description

SubMenu PopupMenu; Read-only


PopupMenuItem.TagString Property

Returns and sets the tag of the menu item.

Syntax

object.TagString

object is a PopupMenuItem object.

Description

TagString String; Read-write

Examples...

TagString Property example


PopupMenuItem.Type Property

Returns the type of the menu item.

Syntax

object.Type

object is a PopupMenuItem object.

Description

Type ZcMenuItemType: Read-only
Can be one of the constants listed here:
zcMenuItem
zcMenuSeparator
zcMenuSubMenu

Examples...

Type Property example


ZcadPopupMenus Object Members

PopupMenus Object Members

A collection of PopupMenu objects representing all the popup menus loaded in the MenuGroup.

VBA Class Name

ZcadPopupMenus

Methods

Name | Description
Add | Adds a popup menu.
InsertMenuInMenuBar | Inserts a popup menu to ZWCAD menu bar.
Item | Returns an element in the collection.
RemoveMenuFromMenuBar | Removes a popup menu from ZWCAD menu bar.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of elements in the collection.
Parent | Returns the parent object.

Events

Name | Description
None | -


PopupMenus.Add Method

Adds a popup menu.

Syntax

object.Add(MenuName)

object is a PopupMenus object.

Parameters

Name | Options | Data Type | Description
MenuName | Input-only | String | -

Return value

PopupMenu

Examples...

Add Method example


PopupMenus.InsertMenuInMenuBar Method

Inserts a popup menu to ZWCAD menu bar.

Syntax

object.InsertMenuInMenuBar(MenuName, Index)

object is a PopupMenus object.

Parameters

Name | Options | Data Type | Description
MenuName | Input-only | String | -
Index | Input-only | Variant | -


PopupMenus.Item Method

Returns an element in the collection.

Syntax

object.Item(Index)

object is a PopupMenus object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

PopupMenu

Examples...

Item Method example


PopupMenus.RemoveMenuFromMenuBar Method

Removes a popup menu from ZWCAD menu bar.

Syntax

object.RemoveMenuFromMenuBar(Index)

object is a PopupMenus object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Examples...

RemoveMenuFromMenuBar Method example


PopupMenus.Application Property

Returns the application object.

Syntax

object.Application

object is a PopupMenus object.

Description

Application Application; Read-only

Examples...

Application Property example


PopupMenus.Count Property

Returns the number of elements in the collection.

Syntax

object.Count

object is a PopupMenus object.

Description

Count Long; Read-only

Examples...

Count Property example


PopupMenus.Parent Property

Returns the parent object.

Syntax

object.Parent

object is a PopupMenus object.

Description

Parent MenuGroup; Read-only

Examples...

Parent Property example


ZcadPreferencesFiles Object Members

PreferencesFiles Object Members

This object contains the options from the Files tab on the Options dialog.

VBA Class Name

ZcadPreferencesFiles

Methods

Name | Description
GetProjectFilePath | Gets the Project File path for a given project Name.
SetProjectFilePath | Set the Project file path for a given project Name.

Properties

Name | Description
AltFontFile | Specifies the location of the font file to use if ZWCAD can't locate the original font and an alternate font is not specified in the font mapping file.
AltTabletMenuFile | Specifies the path for an alternate menu to swap with the standard ZWCAD tablet menu.
Application | Returns the application object.
AutoSavePath | Specifies the path for the file that is created if you enable automatic save using the AutoSaveInterval property.
ColorBookPath | Sets the Colorbook path.
ConfigFile | Gets the location of the configuration file used to store hardware device driver information.
CustomDictionary | Specifies a custom dictionary to use if you have one.
CustomIconPath | Specifies the search path for custom icons
DefaultInternetURL | Specifies the default Internet address.
EnterpriseMenuFile | Specifies the location of the enterprise menu file
FontFileMap | Specifies the location of the file that defines how ZWCAD should convert unfound fonts.
HelpFilePath | Specifies the location of the ZWCAD Help file.
LogFilePath | Specifies the location for the log file.
MainDictionary | Specifies the current dictionary to use for spell checking.
MenuFile | Set the Menu file.
PageSetupOverridesTemplateFile | Sets the default template for Page Setup overrides.
PlotLogFilePath | Sets the plot log file path.
PostScriptPrologFile | Specifies a name for a customized prolog section in the zcad.psf file.
PrintFile | Specifies an alternate name to use for the temporary plot file name.
PrintSpoolExecutable | Specifies the application to use for print spooling.
PrintSpoolerPath | Specifies the directory for the print spool files. ZWCAD writes the plot to this location.
PrinterConfigPath | Specifies the location for printer configuration files.
PrinterDescPath | Specifies the location for printer description files.
PrinterStyleSheetPath | Specifies the location for printer style sheet files.
QNewTemplateFile | Sets the default template for the QNEW command.
SupportPath | Set the Support path.
TempFilePath | Specifies the directory ZWCAD uses to store temporary files.
TemplateDwgPath | Specifies the path for the template files used by the start-up wizards.
TextEditor | Specifies the name of the text editor for the MTEXT command.
TextureMapPath | Specifies the directory in which ZWCAD searches for rendering texture maps.
ToolPalettePath | Sets the ToolPalette path.
WorkspacePath | Specifies the path for the database workspace file.

Events

Name | Description
None | -


PreferencesFiles.GetProjectFilePath Method

Gets the Project File path for a given project Name.

Syntax

object.GetProjectFilePath(ProjectName)

object is a PreferencesFiles object.

Parameters

Name | Options | Data Type | Description
ProjectName | Input-only | String | -

Return value

String


PreferencesFiles.SetProjectFilePath Method

Set the Project file path for a given project Name.

Syntax

object.SetProjectFilePath(ProjectName, ProjectFilePath)

object is a PreferencesFiles object.

Parameters

Name | Options | Data Type | Description
ProjectName | Input-only | String | -
ProjectFilePath | Input-only | String | -


PreferencesFiles.AltFontFile Property

Specifies the location of the font file to use if ZWCAD can't locate the original font and an alternate font is not specified in the font mapping file.

Syntax

object.AltFontFile

object is a PreferencesFiles object.

Description

AltFontFile String; Read-write


PreferencesFiles.AltTabletMenuFile Property

Specifies the path for an alternate menu to swap with the standard ZWCAD tablet menu.

Syntax

object.AltTabletMenuFile

object is a PreferencesFiles object.

Description

AltTabletMenuFile String; Read-write


PreferencesFiles.Application Property

Returns the application object.

Syntax

object.Application

object is a PreferencesFiles object.

Description

Application Application; Read-only


PreferencesFiles.AutoSavePath Property

Specifies the path for the file that is created if you enable automatic save using the AutoSaveInterval property.

Syntax

object.AutoSavePath

object is a PreferencesFiles object.

Description

AutoSavePath String; Read-write


PreferencesFiles.ColorBookPath Property

Sets the Colorbook path.

Syntax

object.ColorBookPath

object is a PreferencesFiles object.

Description

ColorBookPath String; Read-write


PreferencesFiles.ConfigFile Property

Gets the location of the configuration file used to store hardware device driver information.

Syntax

object.ConfigFile

object is a PreferencesFiles object.

Description

ConfigFile String; Read-only


PreferencesFiles.CustomDictionary Property

Specifies a custom dictionary to use if you have one.

Syntax

object.CustomDictionary

object is a PreferencesFiles object.

Description

CustomDictionary String; Read-write


PreferencesFiles.CustomIconPath Property

Specifies the search path for custom icons

Syntax

object.CustomIconPath

object is a PreferencesFiles object.

Description

CustomIconPath String; Read-write


PreferencesFiles.DefaultInternetURL Property

Specifies the default Internet address.

Syntax

object.DefaultInternetURL

object is a PreferencesFiles object.

Description

DefaultInternetURL String; Read-write


PreferencesFiles.EnterpriseMenuFile Property

Specifies the location of the enterprise menu file

Syntax

object.EnterpriseMenuFile

object is a PreferencesFiles object.

Description

EnterpriseMenuFile String; Read-write


PreferencesFiles.FontFileMap Property

Specifies the location of the file that defines how ZWCAD should convert unfound fonts.

Syntax

object.FontFileMap

object is a PreferencesFiles object.

Description

FontFileMap String; Read-write


PreferencesFiles.HelpFilePath Property

Specifies the location of the ZWCAD Help file.

Syntax

object.HelpFilePath

object is a PreferencesFiles object.

Description

HelpFilePath String; Read-write


PreferencesFiles.LogFilePath Property

Specifies the location for the log file.

Syntax

object.LogFilePath

object is a PreferencesFiles object.

Description

LogFilePath String; Read-write


PreferencesFiles.MainDictionary Property

Specifies the current dictionary to use for spell checking.

Syntax

object.MainDictionary

object is a PreferencesFiles object.

Description

MainDictionary String; Read-write


PreferencesFiles.MenuFile Property

Set the Menu file.

Syntax

object.MenuFile

object is a PreferencesFiles object.

Description

MenuFile String; Read-write


PreferencesFiles.PageSetupOverridesTemplateFile Property

Sets the default template for Page Setup overrides.

Syntax

object.PageSetupOverridesTemplateFile

object is a PreferencesFiles object.

Description

PageSetupOverridesTemplateFile String; Read-write


PreferencesFiles.PlotLogFilePath Property

Sets the plot log file path.

Syntax

object.PlotLogFilePath

object is a PreferencesFiles object.

Description

PlotLogFilePath String; Read-write


PreferencesFiles.PostScriptPrologFile Property

Specifies a name for a customized prolog section in the zcad.psf file.

Syntax

object.PostScriptPrologFile

object is a PreferencesFiles object.

Description

PostScriptPrologFile String; Read-write


PreferencesFiles.PrinterConfigPath Property

Specifies the location for printer configuration files.

Syntax

object.PrinterConfigPath

object is a PreferencesFiles object.

Description

PrinterConfigPath String; Read-write


PreferencesFiles.PrinterDescPath Property

Specifies the location for printer description files.

Syntax

object.PrinterDescPath

object is a PreferencesFiles object.

Description

PrinterDescPath String; Read-write


PreferencesFiles.PrinterStyleSheetPath Property

Specifies the location for printer style sheet files.

Syntax

object.PrinterStyleSheetPath

object is a PreferencesFiles object.

Description

PrinterStyleSheetPath String; Read-write


PreferencesFiles.PrintFile Property

Specifies an alternate name to use for the temporary plot file name.

Syntax

object.PrintFile

object is a PreferencesFiles object.

Description

PrintFile String; Read-write


PreferencesFiles.PrintSpoolerPath Property

Specifies the directory for the print spool files. ZWCAD writes the plot to this location.

Syntax

object.PrintSpoolerPath

object is a PreferencesFiles object.

Description

PrintSpoolerPath String; Read-write


PreferencesFiles.PrintSpoolExecutable Property

Specifies the application to use for print spooling.

Syntax

object.PrintSpoolExecutable

object is a PreferencesFiles object.

Description

PrintSpoolExecutable String; Read-write


PreferencesFiles.QNewTemplateFile Property

Sets the default template for the QNEW command.

Syntax

object.QNewTemplateFile

object is a PreferencesFiles object.

Description

QNewTemplateFile String; Read-write


PreferencesFiles.SupportPath Property

Set the Support path.

Syntax

object.SupportPath

object is a PreferencesFiles object.

Description

SupportPath String; Read-write


PreferencesFiles.TempFilePath Property

Specifies the directory ZWCAD uses to store temporary files.

Syntax

object.TempFilePath

object is a PreferencesFiles object.

Description

TempFilePath String; Read-write


PreferencesFiles.TemplateDwgPath Property

Specifies the path for the template files used by the start-up wizards.

Syntax

object.TemplateDwgPath

object is a PreferencesFiles object.

Description

TemplateDwgPath String; Read-write


PreferencesFiles.TextEditor Property

Specifies the name of the text editor for the MTEXT command.

Syntax

object.TextEditor

object is a PreferencesFiles object.

Description

TextEditor String; Read-write


PreferencesFiles.TextureMapPath Property

Specifies the directory in which ZWCAD searches for rendering texture maps.

Syntax

object.TextureMapPath

object is a PreferencesFiles object.

Description

TextureMapPath String; Read-write


PreferencesFiles.ToolPalettePath Property

Sets the ToolPalette path.

Syntax

object.ToolPalettePath

object is a PreferencesFiles object.

Description

ToolPalettePath String; Read-write


PreferencesFiles.WorkspacePath Property

Specifies the path for the database workspace file.

Syntax

object.WorkspacePath

object is a PreferencesFiles object.

Description

WorkspacePath String; Read-write


ZcadPreferencesOutput Object Members

PreferencesOutput Object Members

This object contains the options from the Output tab on the Options dialog.

VBA Class Name

ZcadPreferencesOutput

Methods

Name | Description
None | -

Properties

Name | Description
Application | Returns the application object.
AutomaticPlotLog | Determines whether to automatically save plot and publish log.
ContinuousPlotLog | Determines whether to save a continuous plot log.
DefaultOutputDevice | Specifies the default output device for new layouts and model space.
DefaultPlotStyleForLayer | Specifies the default plot style for Layer 0 for new drawings or drawings created with earlier releases of ZWCAD that have never been saved in ZWCAD 2000 or later format.
DefaultPlotStyleForObjects | Specifies the default plot style name for newly created objects.
DefaultPlotStyleTable | Specifies the default plot style table to attach to new drawings.
DefaultPlotToFilePath | Sets the default location for plot to file operations.
OLEQuality | Specifies the plot quality of OLE objects.
PlotLegacy | Toggles whether legacy plot scripts are allowed to run.
PlotPolicy | Determines whether an object's color property is associated with its plot style name when a new drawing is created.
PrinterPaperSizeAlert | Specifies whether to alert the user when a layout is configured with a paper size that is different than the default setting for the PC3 file.
PrinterSpoolAlert | Specifies whether to alert the user when the output to a device must be spooled through a system printer due to a conflict with the I/O port.
UseLastPlotSettings | Applies the plotting settings of the last successful plot.

Events

Name | Description
None | -


PreferencesOutput.Application Property

Returns the application object.

Syntax

object.Application

object is a PreferencesOutput object.

Description

Application Application; Read-only


PreferencesOutput.AutomaticPlotLog Property

Determines whether to automatically save plot and publish log.

Syntax

object.AutomaticPlotLog

object is a PreferencesOutput object.

Description

AutomaticPlotLog Boolean; Read-write


PreferencesOutput.ContinuousPlotLog Property

Determines whether to save a continuous plot log.

Syntax

object.ContinuousPlotLog

object is a PreferencesOutput object.

Description

ContinuousPlotLog Boolean; Read-write


PreferencesOutput.DefaultOutputDevice Property

Specifies the default output device for new layouts and model space.

Syntax

object.DefaultOutputDevice

object is a PreferencesOutput object.

Description

DefaultOutputDevice String; Read-write


PreferencesOutput.DefaultPlotStyleForLayer Property

Specifies the default plot style for Layer 0 for new drawings or drawings created with earlier releases of ZWCAD that have never been saved in ZWCAD 2000 or later format.

Syntax

object.DefaultPlotStyleForLayer

object is a PreferencesOutput object.

Description

DefaultPlotStyleForLayer String; Read-write


PreferencesOutput.DefaultPlotStyleForObjects Property

Specifies the default plot style name for newly created objects.

Syntax

object.DefaultPlotStyleForObjects

object is a PreferencesOutput object.

Description

DefaultPlotStyleForObjects String; Read-write


PreferencesOutput.DefaultPlotToFilePath Property

Sets the default location for plot to file operations.

Syntax

object.DefaultPlotToFilePath

object is a PreferencesOutput object.

Description

DefaultPlotToFilePath String; Read-write


PreferencesOutput.OLEQuality Property

Specifies the plot quality of OLE objects.

Syntax

object.OLEQuality

object is a PreferencesOutput object.

Description

OLEQuality ZcOleQuality: Read-write
Can be one of the constants listed here:
zcOQLineArt
zcOQText
zcOQGraphics
zcOQPhoto
zcOQHighPhoto


PreferencesOutput.PlotLegacy Property

Toggles whether legacy plot scripts are allowed to run.

Syntax

object.PlotLegacy

object is a PreferencesOutput object.

Description

PlotLegacy Boolean; Read-write


PreferencesOutput.PrinterPaperSizeAlert Property

Specifies whether to alert the user when a layout is configured with a paper size that is different than the default setting for the PC3 file.

Syntax

object.PrinterPaperSizeAlert

object is a PreferencesOutput object.

Description

PrinterPaperSizeAlert Boolean; Read-write


PreferencesOutput.PrinterSpoolAlert Property

Specifies whether to alert the user when the output to a device must be spooled through a system printer due to a conflict with the I/O port.

Syntax

object.PrinterSpoolAlert

object is a PreferencesOutput object.

Description

PrinterSpoolAlert ZcPrinterSpoolAlert: Read-write
Can be one of the constants listed here:
zcPrinterAlwaysAlert
zcPrinterAlertOnce
zcPrinterNeverAlertLogOnce
zcPrinterNeverAlert


PreferencesOutput.UseLastPlotSettings Property

Applies the plotting settings of the last successful plot.

Syntax

object.UseLastPlotSettings

object is a PreferencesOutput object.

Description

UseLastPlotSettings Boolean; Read-write


ZcadRasterImage Object Members

RasterImage Object Members

A raster image consisting of a rectangular grid (or raster) of small squares or dots known as pixels.

VBA Class Name

ZcadRasterImage

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
ClipBoundary | Set clipping boundary
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Brightness | Specifies the current brightness value of the raster image
ClippingEnabled | Enables or disables the clipping boundary of the image
Contrast | Specifies the current contrast value of the raster image
Database | Returns the database object.
Document | Returns the document object.
Fade | Specifies the current fade value of the raster image
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Height | Sets and gets the pixel height of the raster image.
Hyperlinks | Specifies the hyperlink collection for the object.
ImageFile | Specifies the path to the image file
ImageHeight | Specifies the height of the raster image
ImageVisibility | Determines whether image is visible or not
ImageWidth | Specifies the width of the raster image
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Name | Specifies the name of the image file
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
Origin | Specifies the origin coordinates (lower left corner) of the raster image
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Specifies the rotation angle of the raster image
ScaleFactor | Specifies the scale factor of the raster image
ShowRotation | Sets and gets rotated image visibility.
Transparency | Determines whether transparency for a bitonal image is on or off
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.
Width | Sets and gets the pixel width of the raster image.

Events

Name | Description
Modified | Happens when object is modified


RasterImage.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


RasterImage.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


RasterImage.ClipBoundary Method

Set clipping boundary

Syntax

object.ClipBoundary(boundry)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
boundry | Input-only | Variant | -


RasterImage.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a RasterImage object.

Return value

Object

Examples...

Copy Method example


RasterImage.Delete Method

Deletes the object.

Syntax

object.Delete

object is a RasterImage object.

Examples...

Delete Method example


RasterImage.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a RasterImage object.

Examples...

Erase Method example


RasterImage.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


RasterImage.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a RasterImage object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


RasterImage.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


RasterImage.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


RasterImage.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


RasterImage.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


RasterImage.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


RasterImage.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


RasterImage.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


RasterImage.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a RasterImage object.


RasterImage.Application Property

Returns the application object.

Syntax

object.Application

object is a RasterImage object.

Description

Application Object; Read-only

Examples...

Application Property example


RasterImage.Brightness Property

Specifies the current brightness value of the raster image

Syntax

object.Brightness

object is a RasterImage object.

Description

Brightness Long; Read-write

Examples...

Brightness Property example


RasterImage.ClippingEnabled Property

Enables or disables the clipping boundary of the image

Syntax

object.ClippingEnabled

object is a RasterImage object.

Description

ClippingEnabled Boolean; Read-write

Examples...

ClippingEnabled Property example


RasterImage.Contrast Property

Specifies the current contrast value of the raster image

Syntax

object.Contrast

object is a RasterImage object.

Description

Contrast Long; Read-write

Examples...

Contrast Property example


RasterImage.Database Property

Returns the database object.

Syntax

object.Database

object is a RasterImage object.

Description

Database Database; Read-only


RasterImage.Document Property

Returns the document object.

Syntax

object.Document

object is a RasterImage object.

Description

Document Object; Read-only


RasterImage.Fade Property

Specifies the current fade value of the raster image

Syntax

object.Fade

object is a RasterImage object.

Description

Fade Long; Read-write


RasterImage.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a RasterImage object.

Description

Handle String; Read-only


RasterImage.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a RasterImage object.

Description

HasExtensionDictionary Boolean; Read-only


RasterImage.Height Property

Sets and gets the pixel height of the raster image.

Syntax

object.Height

object is a RasterImage object.

Description

Height Double; Read-only


RasterImage.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a RasterImage object.

Description

Hyperlinks Hyperlinks; Read-only


RasterImage.ImageFile Property

Specifies the path to the image file

Syntax

object.ImageFile

object is a RasterImage object.

Description

ImageFile String; Read-write

Examples...

ImageFile Property example


RasterImage.ImageHeight Property

Specifies the height of the raster image

Syntax

object.ImageHeight

object is a RasterImage object.

Description

ImageHeight Double; Read-write

Examples...

ImageHeight Property example


RasterImage.ImageVisibility Property

Determines whether image is visible or not

Syntax

object.ImageVisibility

object is a RasterImage object.

Description

ImageVisibility Boolean; Read-write

Examples...

ImageVisibility Property example


RasterImage.ImageWidth Property

Specifies the width of the raster image

Syntax

object.ImageWidth

object is a RasterImage object.

Description

ImageWidth Double; Read-write

Examples...

ImageWidth Property example


RasterImage.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a RasterImage object.

Description

Layer String; Read-write

Examples...

Layer Property example


RasterImage.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a RasterImage object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


RasterImage.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a RasterImage object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


RasterImage.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a RasterImage object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


RasterImage.Name Property

Specifies the name of the image file

Syntax

object.Name

object is a RasterImage object.

Description

Name String; Read-write

Examples...

Name Property example


RasterImage.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a RasterImage object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


RasterImage.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a RasterImage object.

Description

ObjectName String; Read-only


RasterImage.Origin Property

Specifies the origin coordinates (lower left corner) of the raster image

Syntax

object.Origin

object is a RasterImage object.

Description

Origin Variant; Read-write

Examples...

Origin Property example


RasterImage.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a RasterImage object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


RasterImage.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a RasterImage object.

Description

PlotStyleName String; Read-write


RasterImage.Rotation Property

Specifies the rotation angle of the raster image

Syntax

object.Rotation

object is a RasterImage object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


RasterImage.ScaleFactor Property

Specifies the scale factor of the raster image

Syntax

object.ScaleFactor

object is a RasterImage object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


RasterImage.ShowRotation Property

Sets and gets rotated image visibility.

Syntax

object.ShowRotation

object is a RasterImage object.

Description

ShowRotation Boolean; Read-write

Examples...

ShowRotation Property example


RasterImage.Transparency Property

Determines whether transparency for a bitonal image is on or off

Syntax

object.Transparency

object is a RasterImage object.

Description

Transparency Boolean; Read-write

Examples...

Transparency Property example


RasterImage.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a RasterImage object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


RasterImage.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a RasterImage object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


RasterImage.Width Property

Sets and gets the pixel width of the raster image.

Syntax

object.Width

object is a RasterImage object.

Description

Width Double; Read-only

Examples...

Width Property example


RasterImage.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a RasterImage object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadRay Object Members

Ray Object Members

A semi-infinite line.

VBA Class Name

ZcadRay

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
BasePoint | Specifies the X, Y, and Z base point coordinates of the ray
Database | Returns the database object.
DirectionVector | Specifies the X, Y, and Z direction vectors of the ray
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
SecondPoint | Specifies the X, Y, and Z second point coordinates of the ray
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Ray.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Ray.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Ray.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Ray object.

Return value

Object

Examples...

Copy Method example


Ray.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Ray object.

Examples...

Delete Method example


Ray.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Ray object.

Examples...

Erase Method example


Ray.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Ray.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Ray object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Ray.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Ray.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Ray.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Ray.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Ray.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Ray.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Ray.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Ray.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Ray object.


Ray.Application Property

Returns the application object.

Syntax

object.Application

object is a Ray object.

Description

Application Object; Read-only

Examples...

Application Property example


Ray.BasePoint Property

Specifies the X, Y, and Z base point coordinates of the ray

Syntax

object.BasePoint

object is a Ray object.

Description

BasePoint Variant; Read-write

Examples...

BasePoint Property example


Ray.Database Property

Returns the database object.

Syntax

object.Database

object is a Ray object.

Description

Database Database; Read-only


Ray.DirectionVector Property

Specifies the X, Y, and Z direction vectors of the ray

Syntax

object.DirectionVector

object is a Ray object.

Description

DirectionVector Variant; Read-write


Ray.Document Property

Returns the document object.

Syntax

object.Document

object is a Ray object.

Description

Document Object; Read-only


Ray.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Ray object.

Description

Handle String; Read-only


Ray.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Ray object.

Description

HasExtensionDictionary Boolean; Read-only


Ray.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Ray object.

Description

Hyperlinks Hyperlinks; Read-only


Ray.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Ray object.

Description

Layer String; Read-write

Examples...

Layer Property example


Ray.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Ray object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Ray.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Ray object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Ray.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Ray object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Ray.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Ray object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Ray.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Ray object.

Description

ObjectName String; Read-only


Ray.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Ray object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Ray.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Ray object.

Description

PlotStyleName String; Read-write


Ray.SecondPoint Property

Specifies the X, Y, and Z second point coordinates of the ray

Syntax

object.SecondPoint

object is a Ray object.

Description

SecondPoint Variant; Read-write

Examples...

SecondPoint Property example


Ray.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Ray object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Ray.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Ray object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Ray.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Ray object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadRegion Object Members

Region Object Members

A bounded planar face consisting of lines, circles, arcs, elliptical arcs, and spline curves.

VBA Class Name

ZcadRegion

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Boolean | Perform a Boolean operation against another region.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
Explode | Explodes the region and returns the sub-entities as an array of object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Area | Specifies the area of the region
Centroid | Returns the centroid of the region as an array of Double.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
MomentOfInertia | Returns the moment of inertia of the region as an array of Double.
Normal | Returns the normal of the region.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
Perimeter | Specifies the perimeter of the region
PlotStyleName | Specifies the plotstyle name for the object.
PrincipalDirections | Returns the principal directions of the region as an array of Double.
PrincipalMoments | Returns the principal moments of the region as an array of Double.
ProductOfInertia | Returns the product of inertia of the region as an array of Double.
RadiiOfGyration | Returns the radii of gyration of the region as an array of Double.
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Region.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Region object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Region.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Region object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Region.Boolean Method

Perform a Boolean operation against another region.

Syntax

object.Boolean(Operation, Object)

object is a Region object.

Parameters

Name | Options | Data Type | Description
Operation | Input-only | ZcBooleanType | Can be one of the constants listed here: zcUnion zcIntersection zcSubtraction
Object | Input-only | Region | -


Region.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Region object.

Return value

Object

Examples...

Copy Method example


Region.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Region object.

Examples...

Delete Method example


Region.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Region object.

Examples...

Erase Method example


Region.Explode Method

Explodes the region and returns the sub-entities as an array of object.

Syntax

object.Explode

object is a Region object.

Return value

Variant

Examples...

Explode Method example


Region.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Region object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Region.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Region object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Region.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Region object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Region.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Region object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Region.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Region object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Region.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Region object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Region.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Region object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Region.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Region object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Region.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Region object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Region.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Region object.


Region.Application Property

Returns the application object.

Syntax

object.Application

object is a Region object.

Description

Application Object; Read-only

Examples...

Application Property example


Region.Area Property

Specifies the area of the region

Syntax

object.Area

object is a Region object.

Description

Area Double; Read-only

Examples...

Area Property example


Region.Centroid Property

Returns the centroid of the region as an array of Double.

Syntax

object.Centroid

object is a Region object.

Description

Centroid Variant; Read-only

Examples...

Centroid Property example


Region.Database Property

Returns the database object.

Syntax

object.Database

object is a Region object.

Description

Database Database; Read-only


Region.Document Property

Returns the document object.

Syntax

object.Document

object is a Region object.

Description

Document Object; Read-only


Region.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Region object.

Description

Handle String; Read-only


Region.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Region object.

Description

HasExtensionDictionary Boolean; Read-only


Region.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Region object.

Description

Hyperlinks Hyperlinks; Read-only


Region.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Region object.

Description

Layer String; Read-write

Examples...

Layer Property example


Region.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Region object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Region.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Region object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Region.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Region object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Region.MomentOfInertia Property

Returns the moment of inertia of the region as an array of Double.

Syntax

object.MomentOfInertia

object is a Region object.

Description

MomentOfInertia Variant; Read-only

Examples...

MomentOfInertia Property example


Region.Normal Property

Returns the normal of the region.

Syntax

object.Normal

object is a Region object.

Description

Normal Variant; Read-only

Examples...

Normal Property example


Region.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Region object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Region.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Region object.

Description

ObjectName String; Read-only


Region.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Region object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Region.Perimeter Property

Specifies the perimeter of the region

Syntax

object.Perimeter

object is a Region object.

Description

Perimeter Double; Read-only

Examples...

Perimeter Property example


Region.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Region object.

Description

PlotStyleName String; Read-write


Region.PrincipalDirections Property

Returns the principal directions of the region as an array of Double.

Syntax

object.PrincipalDirections

object is a Region object.

Description

PrincipalDirections Variant; Read-only

Examples...

PrincipalDirections Property example


Region.PrincipalMoments Property

Returns the principal moments of the region as an array of Double.

Syntax

object.PrincipalMoments

object is a Region object.

Description

PrincipalMoments Variant; Read-only

Examples...

PrincipalMoments Property example


Region.ProductOfInertia Property

Returns the product of inertia of the region as an array of Double.

Syntax

object.ProductOfInertia

object is a Region object.

Description

ProductOfInertia Double; Read-only

Examples...

ProductOfInertia Property example


Region.RadiiOfGyration Property

Returns the radii of gyration of the region as an array of Double.

Syntax

object.RadiiOfGyration

object is a Region object.

Description

RadiiOfGyration Variant; Read-only

Examples...

RadiiOfGyration Property example


Region.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Region object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Region.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Region object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Region.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Region object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadRegisteredApplication Object Members

RegisteredApplication Object Members

An external application that has been added to the drawing.

VBA Class Name

ZcadRegisteredApplication

Methods

Name | Description
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Name | Returns and sets the name of the registered application.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


RegisteredApplication.Delete Method

Deletes the object.

Syntax

object.Delete

object is a RegisteredApplication object.

Examples...

Delete Method example


RegisteredApplication.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a RegisteredApplication object.

Examples...

Erase Method example


RegisteredApplication.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a RegisteredApplication object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


RegisteredApplication.Application Property

Returns the application object.

Syntax

object.Application

object is a RegisteredApplication object.

Description

Application Object; Read-only

Examples...

Application Property example


RegisteredApplication.Database Property

Returns the database object.

Syntax

object.Database

object is a RegisteredApplication object.

Description

Database Database; Read-only


RegisteredApplication.Document Property

Returns the document object.

Syntax

object.Document

object is a RegisteredApplication object.

Description

Document Object; Read-only


RegisteredApplication.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a RegisteredApplication object.

Description

Handle String; Read-only


RegisteredApplication.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a RegisteredApplication object.

Description

HasExtensionDictionary Boolean; Read-only


RegisteredApplication.Name Property

Returns and sets the name of the registered application.

Syntax

object.Name

object is a RegisteredApplication object.

Description

Name String; Read-write

Examples...

Name Property example


RegisteredApplication.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a RegisteredApplication object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


RegisteredApplication.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a RegisteredApplication object.

Description

ObjectName String; Read-only


RegisteredApplication.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a RegisteredApplication object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


RegisteredApplication.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a RegisteredApplication object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadRegisteredApplications Object Members

RegisteredApplications Object Members

The collection of all registered applications in the drawing.

VBA Class Name

ZcadRegisteredApplications

Methods

Name | Description
Add | Registers an application in the ZwcadCAD database.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


RegisteredApplications.Add Method

Registers an application in the ZwcadCAD database.

Syntax

object.Add(Name)

object is a RegisteredApplications object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

RegisteredApplication

Examples...

Add Method example


RegisteredApplications.Delete Method

Deletes the object.

Syntax

object.Delete

object is a RegisteredApplications object.

Examples...

Delete Method example


RegisteredApplications.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a RegisteredApplications object.

Examples...

Erase Method example


RegisteredApplications.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a RegisteredApplications object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


RegisteredApplications.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a RegisteredApplications object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

RegisteredApplication

Examples...

Item Method example


RegisteredApplications.Application Property

Returns the application object.

Syntax

object.Application

object is a RegisteredApplications object.

Description

Application Object; Read-only

Examples...

Application Property example


RegisteredApplications.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a RegisteredApplications object.

Description

Count Long; Read-only

Examples...

Count Property example


RegisteredApplications.Database Property

Returns the database object.

Syntax

object.Database

object is a RegisteredApplications object.

Description

Database Database; Read-only


RegisteredApplications.Document Property

Returns the document object.

Syntax

object.Document

object is a RegisteredApplications object.

Description

Document Object; Read-only


RegisteredApplications.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a RegisteredApplications object.

Description

Handle String; Read-only


RegisteredApplications.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a RegisteredApplications object.

Description

HasExtensionDictionary Boolean; Read-only


RegisteredApplications.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a RegisteredApplications object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


RegisteredApplications.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a RegisteredApplications object.

Description

ObjectName String; Read-only


RegisteredApplications.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a RegisteredApplications object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


RegisteredApplications.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a RegisteredApplications object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadSecurityParams Object Members

SecurityParams Object Members

Supplies information necessary for performing security operations on drawing files.

VBA Class Name

ZcadSecurityParams

Methods

Name | Description
None | -

Properties

Name | Description
Action | Specifies the security-related operations to be performed.
Algorithm | Specifies the encryption algorithm identifier.
Comment | Specifies the comment to be included with the digital signature.
Issuer | Specifies the issuer name of the digital certificate.
KeyLength | Specifies the length of the encryption key.
Password | Specifies the encryption password.
ProviderName | Specifies the encryption provider name.
ProviderType | Specifies the encryption provider type.
SerialNumber | Specifies the serial number of the digital certificate.
Subject | Specifies the subject name of the digital certificate.
TimeServer | Specifies the name of the time server to be used for the digital signature.

Events

Name | Description
None | -


SecurityParams.Action Property

Specifies the security-related operations to be performed.

Syntax

object.Action

object is a SecurityParams object.

Description

Action Long; Read-write


SecurityParams.Algorithm Property

Specifies the encryption algorithm identifier.

Syntax

object.Algorithm

object is a SecurityParams object.

Description

Algorithm Long; Read-write


SecurityParams.Comment Property

Specifies the comment to be included with the digital signature.

Syntax

object.Comment

object is a SecurityParams object.

Description

Comment String; Read-write


SecurityParams.Issuer Property

Specifies the issuer name of the digital certificate.

Syntax

object.Issuer

object is a SecurityParams object.

Description

Issuer String; Read-write


SecurityParams.KeyLength Property

Specifies the length of the encryption key.

Syntax

object.KeyLength

object is a SecurityParams object.

Description

KeyLength Long; Read-write


SecurityParams.Password Property

Specifies the encryption password.

Syntax

object.Password

object is a SecurityParams object.

Description

Password String; Read-write


SecurityParams.ProviderName Property

Specifies the encryption provider name.

Syntax

object.ProviderName

object is a SecurityParams object.

Description

ProviderName String; Read-write


SecurityParams.ProviderType Property

Specifies the encryption provider type.

Syntax

object.ProviderType

object is a SecurityParams object.

Description

ProviderType Long; Read-write


SecurityParams.SerialNumber Property

Specifies the serial number of the digital certificate.

Syntax

object.SerialNumber

object is a SecurityParams object.

Description

SerialNumber String; Read-write


SecurityParams.Subject Property

Specifies the subject name of the digital certificate.

Syntax

object.Subject

object is a SecurityParams object.

Description

Subject String; Read-write

Examples...

Subject Property example


SecurityParams.TimeServer Property

Specifies the name of the time server to be used for the digital signature.

Syntax

object.TimeServer

object is a SecurityParams object.

Description

TimeServer String; Read-write


ZcadSelectionSet Object Members

SelectionSet Object Members

A group of one or more ZWCAD objects specified for processing as a single unit.

VBA Class Name

ZcadSelectionSet

Methods

Name | Description
AddItems | Adds items to the selection set.
Clear | Clears the selection set.
Delete | Deletes the object.
Erase | Erases all entities in the selection set.
Highlight | Highlights all entities in the selection set.
Item | Given an Index, returns an entity in the collection.
RemoveItems | Removes items from the selection set
Select | Selects entities given two corners and a mode, and adds them to the selection set.
SelectAtPoint | Selects entities passing through a given point and adds them to the selection set.
SelectByPolygon | Selects entities given a mode and a points list and adds them to the selection-set.
SelectOnScreen | Prompts the user to select the entities on the ZWCAD screen.
Update | Updates the graphics of all entities in the selection set.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of items in the collection.
Name | Returns the name of the selection-set.

Events

Name | Description
None | -


SelectionSet.AddItems Method

Adds items to the selection set.

Syntax

object.AddItems(pSelSet)

object is a SelectionSet object.

Parameters

Name | Options | Data Type | Description
pSelSet | Input-only | Variant | -

Examples...

AddItems Method example


SelectionSet.Clear Method

Clears the selection set.

Syntax

object.Clear

object is a SelectionSet object.

Examples...

Clear Method example


SelectionSet.Delete Method

Deletes the object.

Syntax

object.Delete

object is a SelectionSet object.

Examples...

Delete Method example


SelectionSet.Erase Method

Erases all entities in the selection set.

Syntax

object.Erase

object is a SelectionSet object.

Examples...

Erase Method example


SelectionSet.Highlight Method

Highlights all entities in the selection set.

Syntax

object.Highlight(bFlag)

object is a SelectionSet object.

Parameters

Name | Options | Data Type | Description
bFlag | Input-only | Boolean | -

Examples...

Highlight Method example


SelectionSet.Item Method

Given an Index, returns an entity in the collection.

Syntax

object.Item(Index)

object is a SelectionSet object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Entity

Examples...

Item Method example


SelectionSet.RemoveItems Method

Removes items from the selection set

Syntax

object.RemoveItems(Objects)

object is a SelectionSet object.

Parameters

Name | Options | Data Type | Description
Objects | Input-only | Variant | -

Examples...

RemoveItems Method example


SelectionSet.Select Method

Selects entities given two corners and a mode, and adds them to the selection set.

Syntax

object.Select(Mode, Point1, Point2, FilterType, FilterData)

object is a SelectionSet object.

Parameters

Name | Options | Data Type | Description
Mode | Input-only | ZcSelect | Can be one of the constants listed here: zcSelectionSetWindow zcSelectionSetCrossing zcSelectionSetFence zcSelectionSetPrevious zcSelectionSetLast zcSelectionSetAll zcSelectionSetWindowPolygon zcSelectionSetCrossingPolygon
Point1 | Input-only, Optional | Variant | -
Point2 | Input-only, Optional | Variant | -
FilterType | Input-only, Optional | Variant | -
FilterData | Input-only, Optional | Variant | -

Examples...

Select Method example


SelectionSet.SelectAtPoint Method

Selects entities passing through a given point and adds them to the selection set.

Syntax

object.SelectAtPoint(Point, FilterType, FilterData)

object is a SelectionSet object.

Parameters

Name | Options | Data Type | Description
Point | Input-only | Variant | -
FilterType | Input-only, Optional | Variant | -
FilterData | Input-only, Optional | Variant | -

Examples...

SelectAtPoint Method example


SelectionSet.SelectByPolygon Method

Selects entities given a mode and a points list and adds them to the selection-set.

Syntax

object.SelectByPolygon(Mode, PointsList, FilterType, FilterData)

object is a SelectionSet object.

Parameters

Name | Options | Data Type | Description
Mode | Input-only | ZcSelect | Can be one of the constants listed here: zcSelectionSetWindow zcSelectionSetCrossing zcSelectionSetFence zcSelectionSetPrevious zcSelectionSetLast zcSelectionSetAll zcSelectionSetWindowPolygon zcSelectionSetCrossingPolygon
PointsList | Input-only | Variant | -
FilterType | Input-only, Optional | Variant | -
FilterData | Input-only, Optional | Variant | -

Examples...

SelectByPolygon Method example


SelectionSet.SelectOnScreen Method

Prompts the user to select the entities on the ZWCAD screen.

Syntax

object.SelectOnScreen(FilterType, FilterData)

object is a SelectionSet object.

Parameters

Name | Options | Data Type | Description
FilterType | Input-only, Optional | Variant | -
FilterData | Input-only, Optional | Variant | -

Examples...

SelectOnScreen Method example


SelectionSet.Update Method

Updates the graphics of all entities in the selection set.

Syntax

object.Update

object is a SelectionSet object.


SelectionSet.Application Property

Returns the application object.

Syntax

object.Application

object is a SelectionSet object.

Description

Application Application; Read-only

Examples...

Application Property example


SelectionSet.Count Property

Returns the number of items in the collection.

Syntax

object.Count

object is a SelectionSet object.

Description

Count Long; Read-only

Examples...

Count Property example


SelectionSet.Name Property

Returns the name of the selection-set.

Syntax

object.Name

object is a SelectionSet object.

Description

Name String; Read-only

Examples...

Name Property example


ZcadSelectionSets Object Members

SelectionSets Object Members

The collection of all selection sets in the drawing.

VBA Class Name

ZcadSelectionSets

Methods

Name | Description
Add | Adds a selection set to the collection.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of items in the collection.

Events

Name | Description
None | -


SelectionSets.Add Method

Adds a selection set to the collection.

Syntax

object.Add(Name)

object is a SelectionSets object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

SelectionSet

Examples...

Add Method example


SelectionSets.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a SelectionSets object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

SelectionSet

Examples...

Item Method example


SelectionSets.Application Property

Returns the application object.

Syntax

object.Application

object is a SelectionSets object.

Description

Application Application; Read-only

Examples...

Application Property example


SelectionSets.Count Property

Returns the number of items in the collection.

Syntax

object.Count

object is a SelectionSets object.

Description

Count Long; Read-only

Examples...

Count Property example


ZcadShape Object Members

Shape Object Members

An object comprising lines, arcs, and circles defined in an SHX file.

VBA Class Name

ZcadShape

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Height | Specifies the height of the shape
Hyperlinks | Specifies the hyperlink collection for the object.
InsertionPoint | Specifies X, Y, and Z insertion point coordinates of the shape
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Name | Specifies the name of the shape
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
ObliqueAngle | Specifies the oblique angle of the shape
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Specifies the rotation angle of the shape
ScaleFactor | Specifies the width scale factor of the shape
Thickness | Specifies the thickness of the shape
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Shape.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Shape.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Shape.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Shape object.

Return value

Object

Examples...

Copy Method example


Shape.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Shape object.

Examples...

Delete Method example


Shape.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Shape object.

Examples...

Erase Method example


Shape.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Shape.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Shape object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Shape.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Shape.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Shape.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Shape.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Shape.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Shape.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Shape.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Shape.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Shape object.


Shape.Application Property

Returns the application object.

Syntax

object.Application

object is a Shape object.

Description

Application Object; Read-only

Examples...

Application Property example


Shape.Database Property

Returns the database object.

Syntax

object.Database

object is a Shape object.

Description

Database Database; Read-only


Shape.Document Property

Returns the document object.

Syntax

object.Document

object is a Shape object.

Description

Document Object; Read-only


Shape.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Shape object.

Description

Handle String; Read-only


Shape.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Shape object.

Description

HasExtensionDictionary Boolean; Read-only


Shape.Height Property

Specifies the height of the shape

Syntax

object.Height

object is a Shape object.

Description

Height Double; Read-write


Shape.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Shape object.

Description

Hyperlinks Hyperlinks; Read-only


Shape.InsertionPoint Property

Specifies X, Y, and Z insertion point coordinates of the shape

Syntax

object.InsertionPoint

object is a Shape object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


Shape.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Shape object.

Description

Layer String; Read-write

Examples...

Layer Property example


Shape.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Shape object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Shape.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Shape object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Shape.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Shape object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Shape.Name Property

Specifies the name of the shape

Syntax

object.Name

object is a Shape object.

Description

Name String; Read-write

Examples...

Name Property example


Shape.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a Shape object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Shape.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Shape object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Shape.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Shape object.

Description

ObjectName String; Read-only


Shape.ObliqueAngle Property

Specifies the oblique angle of the shape

Syntax

object.ObliqueAngle

object is a Shape object.

Description

ObliqueAngle ZCAD_ANGLE: alias for Double; Read-write

Examples...

ObliqueAngle Property example


Shape.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Shape object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Shape.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Shape object.

Description

PlotStyleName String; Read-write


Shape.Rotation Property

Specifies the rotation angle of the shape

Syntax

object.Rotation

object is a Shape object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


Shape.ScaleFactor Property

Specifies the width scale factor of the shape

Syntax

object.ScaleFactor

object is a Shape object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


Shape.Thickness Property

Specifies the thickness of the shape

Syntax

object.Thickness

object is a Shape object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


Shape.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Shape object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Shape.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Shape object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Shape.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Shape object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadSolid Object Members

Solid Object Members

A solid-filled polygon.

VBA Class Name

ZcadSolid

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Coordinate | Returns the coordinate of the vertex at a given index
Coordinates | Specifies the current vertex of the solid
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Thickness | Specifies the thickness of the solid
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Solid.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Solid.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Solid.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Solid object.

Return value

Object

Examples...

Copy Method example


Solid.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Solid object.

Examples...

Delete Method example


Solid.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Solid object.

Examples...

Erase Method example


Solid.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Solid.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Solid object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Solid.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Solid.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Solid.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Solid.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Solid.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Solid.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Solid.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Solid.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Solid object.


Solid.Application Property

Returns the application object.

Syntax

object.Application

object is a Solid object.

Description

Application Object; Read-only

Examples...

Application Property example


Solid.Coordinate Property

Returns the coordinate of the vertex at a given index

Syntax

object.Coordinate

object is a Solid object.

Description

Coordinate Variant; Read-write

Examples...

Coordinate Property example


Solid.Coordinates Property

Specifies the current vertex of the solid

Syntax

object.Coordinates

object is a Solid object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


Solid.Database Property

Returns the database object.

Syntax

object.Database

object is a Solid object.

Description

Database Database; Read-only


Solid.Document Property

Returns the document object.

Syntax

object.Document

object is a Solid object.

Description

Document Object; Read-only


Solid.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Solid object.

Description

Handle String; Read-only


Solid.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Solid object.

Description

HasExtensionDictionary Boolean; Read-only


Solid.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Solid object.

Description

Hyperlinks Hyperlinks; Read-only


Solid.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Solid object.

Description

Layer String; Read-write

Examples...

Layer Property example


Solid.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Solid object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Solid.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Solid object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Solid.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Solid object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Solid.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a Solid object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Solid.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Solid object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Solid.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Solid object.

Description

ObjectName String; Read-only


Solid.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Solid object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Solid.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Solid object.

Description

PlotStyleName String; Read-write


Solid.Thickness Property

Specifies the thickness of the solid

Syntax

object.Thickness

object is a Solid object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


Solid.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Solid object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Solid.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Solid object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Solid.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Solid object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadSortentsTable Object Members

SortentsTable Object Members

Contains and manipulates draw order information.

VBA Class Name

ZcadSortentsTable

Methods

Name | Description
Block | Returns the Block this Sortents Table belongs to.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetFullDrawOrder | Returns all objects in the block, sorted by draw order, bottommost first.
GetRelativeDrawOrder | Returns specified objects, sorted by draw order, bottommost first.
MoveAbove | Moves objects above target in draw order.
MoveBelow | Moves objects below target in draw order.
MoveToBottom | Moves objects to bottom of draw order.
MoveToTop | Moves objects to top of draw order.
SetRelativeDrawOrder | Sets the relative draw order of the objects to the order specified, bottommost first.
SwapOrder | Swaps draw order position for two objects.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


SortentsTable.Block Method

Returns the Block this Sortents Table belongs to.

Syntax

object.Block

object is a SortentsTable object.

Return value

Block


SortentsTable.Delete Method

Deletes the object.

Syntax

object.Delete

object is a SortentsTable object.

Examples...

Delete Method example


SortentsTable.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a SortentsTable object.

Examples...

Erase Method example


SortentsTable.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a SortentsTable object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


SortentsTable.GetFullDrawOrder Method

Returns all objects in the block, sorted by draw order, bottommost first.

Syntax

object.GetFullDrawOrder(Objects, honorSortentsSysvar)

object is a SortentsTable object.

Parameters

Name | Options | Data Type | Description
Objects | Output-only | Variant | -
honorSortentsSysvar | Input-only | Boolean | -


SortentsTable.GetRelativeDrawOrder Method

Returns specified objects, sorted by draw order, bottommost first.

Syntax

object.GetRelativeDrawOrder(Objects, honorSortentsSysvar)

object is a SortentsTable object.

Parameters

Name | Options | Data Type | Description
Objects | Output-only | Variant | -
honorSortentsSysvar | Input-only | Boolean | -


SortentsTable.MoveAbove Method

Moves objects above target in draw order.

Syntax

object.MoveAbove(Objects, Target)

object is a SortentsTable object.

Parameters

Name | Options | Data Type | Description
Objects | Input-only | Variant | -
Target | Input-only | Entity | -


SortentsTable.MoveBelow Method

Moves objects below target in draw order.

Syntax

object.MoveBelow(Objects, Target)

object is a SortentsTable object.

Parameters

Name | Options | Data Type | Description
Objects | Input-only | Variant | -
Target | Input-only | Entity | -


SortentsTable.MoveToBottom Method

Moves objects to bottom of draw order.

Syntax

object.MoveToBottom(Objects)

object is a SortentsTable object.

Parameters

Name | Options | Data Type | Description
Objects | Input-only | Variant | -


SortentsTable.MoveToTop Method

Moves objects to top of draw order.

Syntax

object.MoveToTop(Objects)

object is a SortentsTable object.

Parameters

Name | Options | Data Type | Description
Objects | Input-only | Variant | -


SortentsTable.SetRelativeDrawOrder Method

Sets the relative draw order of the objects to the order specified, bottommost first.

Syntax

object.SetRelativeDrawOrder(Objects)

object is a SortentsTable object.

Parameters

Name | Options | Data Type | Description
Objects | Input-only | Variant | -


SortentsTable.SwapOrder Method

Swaps draw order position for two objects.

Syntax

object.SwapOrder(Object1, Object2)

object is a SortentsTable object.

Parameters

Name | Options | Data Type | Description
Object1 | Input-only | Entity | -
Object2 | Input-only | Entity | -


SortentsTable.Application Property

Returns the application object.

Syntax

object.Application

object is a SortentsTable object.

Description

Application Object; Read-only

Examples...

Application Property example


SortentsTable.Database Property

Returns the database object.

Syntax

object.Database

object is a SortentsTable object.

Description

Database Database; Read-only


SortentsTable.Document Property

Returns the document object.

Syntax

object.Document

object is a SortentsTable object.

Description

Document Object; Read-only


SortentsTable.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a SortentsTable object.

Description

Handle String; Read-only


SortentsTable.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a SortentsTable object.

Description

HasExtensionDictionary Boolean; Read-only


SortentsTable.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a SortentsTable object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


SortentsTable.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a SortentsTable object.

Description

ObjectName String; Read-only


SortentsTable.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a SortentsTable object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


SortentsTable.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a SortentsTable object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadSpline Object Members

Spline Object Members

A quadratic or cubic NURBS (nonuniform rational B-spline) curve.

VBA Class Name

ZcadSpline

Methods

Name | Description
AddFitPoint | Adds the fit point to the spline at a given index
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
DeleteFitPoint | Deletes the fit point of the spline at a given index
ElevateOrder | Elevates the order of the spline
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetControlPoint | Returns the control point of the spline at a given index
GetExtensionDictionary | Returns the extension dictionary for the object.
GetFitPoint | Returns the fit point of the spline at a given index
GetWeight | Returns the weight of the spline at a given control point index
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Offset | Creates a new entity object by offsetting the spline by a given value
PurgeFitData | Purges the fit data of the spline
Reverse | Reverses the direction of the spline
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
SetControlPoint | Sets the indexed control point of the spline at a specified point
SetFitPoint | Sets the indexed fit point of the spline at a specified point
SetWeight | Sets the weight of the spline at a given control point index
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Area | Specifies the area of the spline
Closed | Determines whether the spline is closed
ControlPoints | Specifies the current control point of the spline
Database | Returns the database object.
Degree | Specifies the degree of the spline
Document | Returns the document object.
EndTangent | Specifies the X, Y, and Z coordinates for end tangent of the spline
FitPoints | Specifies the current fit point of the spline
FitTolerance | Specifies the fit tolerance of the spline
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
IsPeriodic | Returns the whether the spline is periodic
IsPlanar | Determines the whether the spline is planar
IsRational | Returns the whether the spline is rational
Knots | Specifies the knot vector of the spline
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
NumberOfControlPoints | Specifies the number of control points of the spline
NumberOfFitPoints | Specifies the number of fit points of the spline
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.
Weights | Specifies the weight vector of the spline

Events

Name | Description
Modified | Happens when object is modified


Spline.AddFitPoint Method

Adds the fit point to the spline at a given index

Syntax

object.AddFitPoint(Index, fitPoint)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
fitPoint | Input-only | Variant | -


Spline.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Spline.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Spline.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Spline object.

Return value

Object

Examples...

Copy Method example


Spline.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Spline object.

Examples...

Delete Method example


Spline.DeleteFitPoint Method

Deletes the fit point of the spline at a given index

Syntax

object.DeleteFitPoint(Index)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -


Spline.ElevateOrder Method

Elevates the order of the spline

Syntax

object.ElevateOrder(Order)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Order | Input-only | Integer | -


Spline.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Spline object.

Examples...

Erase Method example


Spline.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Spline.GetControlPoint Method

Returns the control point of the spline at a given index

Syntax

object.GetControlPoint(Index)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -

Return value

Variant

Examples...

GetControlPoint Method example


Spline.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Spline object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Spline.GetFitPoint Method

Returns the fit point of the spline at a given index

Syntax

object.GetFitPoint(Index)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -

Return value

Variant

Examples...

GetFitPoint Method example


Spline.GetWeight Method

Returns the weight of the spline at a given control point index

Syntax

object.GetWeight(Index)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -

Return value

Double


Spline.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Spline.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Spline.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Spline.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Spline.Offset Method

Creates a new entity object by offsetting the spline by a given value

Syntax

object.Offset(Distance)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Distance | Input-only | Double | -

Return value

Variant


Spline.PurgeFitData Method

Purges the fit data of the spline

Syntax

object.PurgeFitData

object is a Spline object.

Examples...

PurgeFitData Method example


Spline.Reverse Method

Reverses the direction of the spline

Syntax

object.Reverse

object is a Spline object.

Examples...

Reverse Method example


Spline.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Spline.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Spline.SetControlPoint Method

Sets the indexed control point of the spline at a specified point

Syntax

object.SetControlPoint(Index, controlPoint)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
controlPoint | Input-only | Variant | -

Examples...

SetControlPoint Method example


Spline.SetFitPoint Method

Sets the indexed fit point of the spline at a specified point

Syntax

object.SetFitPoint(Index, fitPoint)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
fitPoint | Input-only | Variant | -


Spline.SetWeight Method

Sets the weight of the spline at a given control point index

Syntax

object.SetWeight(Index, weight)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
weight | Input-only | Double | -


Spline.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Spline.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Spline object.


Spline.Application Property

Returns the application object.

Syntax

object.Application

object is a Spline object.

Description

Application Object; Read-only

Examples...

Application Property example


Spline.Area Property

Specifies the area of the spline

Syntax

object.Area

object is a Spline object.

Description

Area Double; Read-only

Examples...

Area Property example


Spline.Closed Property

Determines whether the spline is closed

Syntax

object.Closed

object is a Spline object.

Description

Closed Boolean; Read-only

Examples...

Closed Property example


Spline.ControlPoints Property

Specifies the current control point of the spline

Syntax

object.ControlPoints

object is a Spline object.

Description

ControlPoints Variant; Read-write

Examples...

ControlPoints Property example


Spline.Database Property

Returns the database object.

Syntax

object.Database

object is a Spline object.

Description

Database Database; Read-only


Spline.Degree Property

Specifies the degree of the spline

Syntax

object.Degree

object is a Spline object.

Description

Degree Long; Read-only


Spline.Document Property

Returns the document object.

Syntax

object.Document

object is a Spline object.

Description

Document Object; Read-only


Spline.EndTangent Property

Specifies the X, Y, and Z coordinates for end tangent of the spline

Syntax

object.EndTangent

object is a Spline object.

Description

EndTangent Variant; Read-write


Spline.FitPoints Property

Specifies the current fit point of the spline

Syntax

object.FitPoints

object is a Spline object.

Description

FitPoints Variant; Read-write


Spline.FitTolerance Property

Specifies the fit tolerance of the spline

Syntax

object.FitTolerance

object is a Spline object.

Description

FitTolerance Double; Read-write


Spline.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Spline object.

Description

Handle String; Read-only


Spline.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Spline object.

Description

HasExtensionDictionary Boolean; Read-only


Spline.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Spline object.

Description

Hyperlinks Hyperlinks; Read-only


Spline.IsPeriodic Property

Returns the whether the spline is periodic

Syntax

object.IsPeriodic

object is a Spline object.

Description

IsPeriodic Boolean; Read-only

Examples...

IsPeriodic Property example


Spline.IsPlanar Property

Determines the whether the spline is planar

Syntax

object.IsPlanar

object is a Spline object.

Description

IsPlanar Boolean; Read-only

Examples...

IsPlanar Property example


Spline.IsRational Property

Returns the whether the spline is rational

Syntax

object.IsRational

object is a Spline object.

Description

IsRational Boolean; Read-only

Examples...

IsRational Property example


Spline.Knots Property

Specifies the knot vector of the spline

Syntax

object.Knots

object is a Spline object.

Description

Knots Variant; Read-write

Examples...

Knots Property example


Spline.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Spline object.

Description

Layer String; Read-write

Examples...

Layer Property example


Spline.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Spline object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Spline.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Spline object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Spline.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Spline object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Spline.NumberOfControlPoints Property

Specifies the number of control points of the spline

Syntax

object.NumberOfControlPoints

object is a Spline object.

Description

NumberOfControlPoints Long; Read-only

Examples...

NumberOfControlPoints Property example


Spline.NumberOfFitPoints Property

Specifies the number of fit points of the spline

Syntax

object.NumberOfFitPoints

object is a Spline object.

Description

NumberOfFitPoints Long; Read-only

Examples...

NumberOfFitPoints Property example


Spline.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Spline object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Spline.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Spline object.

Description

ObjectName String; Read-only


Spline.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Spline object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Spline.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Spline object.

Description

PlotStyleName String; Read-write


Spline.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Spline object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Spline.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Spline object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Spline.Weights Property

Specifies the weight vector of the spline

Syntax

object.Weights

object is a Spline object.

Description

Weights Variant; Read-write


Spline.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Spline object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadState Object Members

State Object Members

A special object to use in monitoring the state of ZWCAD from out-of-process applications.

VBA Class Name

ZcadState

Methods

Name | Description
None | -

Properties

Name | Description
Application | Returns the application object.
IsQuiescent | Specifies if ZWCAD is idle and accepting out of process Automation requests.

Events

Name | Description
None | -


State.Application Property

Returns the application object.

Syntax

object.Application

object is a State object.

Description

Application Application; Read-only

Examples...

Application Property example


State.IsQuiescent Property

Specifies if ZWCAD is idle and accepting out of process Automation requests.

Syntax

object.IsQuiescent

object is a State object.

Description

IsQuiescent Boolean; Read-only

Examples...

IsQuiescent Property example


ZcadSummaryInfo Object Members

SummaryInfo Object Members

Accesses drawing properties such as the Title, Subject, Author, and Keywords properties.

VBA Class Name

ZcadSummaryInfo

Methods

Name | Description
AddCustomInfo | Adds a new custom field at the end of the existing list of custom fields.
GetCustomByIndex | Gets the key and value of the custom field specified its index.
GetCustomByKey | Returns the number of custom information fields that have been set.
NumCustomInfo | Returns the number of custom information fields that have been set.
RemoveCustomByIndex | Removes a custom field (key and value) indicated by the index. Note, index range is from one to the number of custom fields.
RemoveCustomByKey | Removes a custom field (key and value) indicated by the key.
SetCustomByIndex | Sets set the key and value of the custom field specified by the index. Note, index range is from one to the number of custom fields.
SetCustomByKey | Sets set the value of the custom field specified by the key.

Properties

Name | Description
Author | Returns the value of the author field.
Comments | Returns the value of the comments field.
HyperlinkBase | Returns the value of the hyperlink base path field.
Keywords | Returns the value of the keywords field.
LastSavedBy | Returns the login name of the user to last save this database by using the LOGINNAME sysvar, or NULL if it has not been set.
RevisionNumber | Returns the value of the revision number field, which is a string.
Subject | Returns the value of the subject field.
Title | Returns the value of the title field.

Events

Name | Description
None | -


SummaryInfo.AddCustomInfo Method

Adds a new custom field at the end of the existing list of custom fields.

Syntax

object.AddCustomInfo(key, Value)

object is a SummaryInfo object.

Parameters

Name | Options | Data Type | Description
key | Input-only | String | -
Value | Input-only | String | -

Examples...

AddCustomInfo Method example


SummaryInfo.GetCustomByIndex Method

Gets the key and value of the custom field specified its index.

Syntax

object.GetCustomByIndex(Index, pKey, pValue)

object is a SummaryInfo object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
pKey | Output-only | String | -
pValue | Output-only | String | -

Examples...

GetCustomByIndex Method example


SummaryInfo.GetCustomByKey Method

Returns the number of custom information fields that have been set.

Syntax

object.GetCustomByKey(key, pValue)

object is a SummaryInfo object.

Parameters

Name | Options | Data Type | Description
key | Input-only | String | -
pValue | Output-only | String | -

Examples...

GetCustomByKey Method example


SummaryInfo.NumCustomInfo Method

Returns the number of custom information fields that have been set.

Syntax

object.NumCustomInfo

object is a SummaryInfo object.

Return value

Integer


SummaryInfo.RemoveCustomByIndex Method

Removes a custom field (key and value) indicated by the index. Note, index range is from one to the number of custom fields.

Syntax

object.RemoveCustomByIndex(Index)

object is a SummaryInfo object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -

Examples...

RemoveCustomByIndex Method example


SummaryInfo.RemoveCustomByKey Method

Removes a custom field (key and value) indicated by the key.

Syntax

object.RemoveCustomByKey(key)

object is a SummaryInfo object.

Parameters

Name | Options | Data Type | Description
key | Input-only | String | -

Examples...

RemoveCustomByKey Method example


SummaryInfo.SetCustomByIndex Method

Sets set the key and value of the custom field specified by the index. Note, index range is from one to the number of custom fields.

Syntax

object.SetCustomByIndex(Index, key, Value)

object is a SummaryInfo object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Integer | -
key | Input-only | String | -
Value | Input-only | String | -

Examples...

SetCustomByIndex Method example


SummaryInfo.SetCustomByKey Method

Sets set the value of the custom field specified by the key.

Syntax

object.SetCustomByKey(key, Value)

object is a SummaryInfo object.

Parameters

Name | Options | Data Type | Description
key | Input-only | String | -
Value | Input-only | String | -

Examples...

SetCustomByKey Method example


SummaryInfo.Author Property

Returns the value of the author field.

Syntax

object.Author

object is a SummaryInfo object.

Description

Author String; Read-write

Examples...

Author Property example


SummaryInfo.Comments Property

Returns the value of the comments field.

Syntax

object.Comments

object is a SummaryInfo object.

Description

Comments String; Read-write

Examples...

Comments Property example


SummaryInfo.HyperlinkBase Property

Returns the value of the hyperlink base path field.

Syntax

object.HyperlinkBase

object is a SummaryInfo object.

Description

HyperlinkBase String; Read-write


SummaryInfo.Keywords Property

Returns the value of the keywords field.

Syntax

object.Keywords

object is a SummaryInfo object.

Description

Keywords String; Read-write

Examples...

Keywords Property example


SummaryInfo.LastSavedBy Property

Returns the login name of the user to last save this database by using the LOGINNAME sysvar, or NULL if it has not been set.

Syntax

object.LastSavedBy

object is a SummaryInfo object.

Description

LastSavedBy String; Read-write

Examples...

LastSavedBy Property example


SummaryInfo.RevisionNumber Property

Returns the value of the revision number field, which is a string.

Syntax

object.RevisionNumber

object is a SummaryInfo object.

Description

RevisionNumber String; Read-write

Examples...

RevisionNumber Property example


SummaryInfo.Subject Property

Returns the value of the subject field.

Syntax

object.Subject

object is a SummaryInfo object.

Description

Subject String; Read-write

Examples...

Subject Property example


SummaryInfo.Title Property

Returns the value of the title field.

Syntax

object.Title

object is a SummaryInfo object.

Description

Title String; Read-write

Examples...

Title Property example


ZcadTable Object Members

Table Object Members

ZWCAD table object.

VBA Class Name

ZcadTable

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
ClearSubSelection | Removes a subselection set of cells from a table.
ClearTableStyleOverrides | Clears the tableStyleOverrides.
Copy | Copies the entity object.
Delete | Deletes the object.
DeleteCellContent | Deletes the cell content for the specified row and coluumn.
DeleteColumns | deletes the column(s) from the specified column index.
DeleteRows | deletes the row(s) from the specified row index.
Erase | Erases the entity object.
GenerateLayout | Generate layout.
GetAlignment | Returns the cell alignment for the specified row type.
GetAttachmentPoint | Gets the attachment point for the specified row and column.
GetAutoScale | Returns the auto scale flag value for the specified row and column.
GetBackgroundColor | Returns the background true color value for the specified row type.
GetBackgroundColorNone | Returns the backgroundColorNone flag value for the specified row type.
GetBlockAttributeValue | Returns the attribute value from the Specified block cell for the attribute definition object contained in the block.
GetBlockRotation | Returns the block rotation for the specified row and column.
GetBlockScale | Returns the block scale value for the specified row and column.
GetBlockTableRecordId | Returns the block table record id associated to the block-type cell.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetCellAlignment | Returns the alignment for the specified row and column.
GetCellBackgroundColor | Returns the background true color value for the specified row and column.
GetCellBackgroundColorNone | Returns the backgroundColorNone flag value for the specified row and column.
GetCellContentColor | Returns the true color value for the specified row and column.
GetCellExtents | Gets the cell extents for the specified row and column.
GetCellGridColor | Returns the gridColor value for the given edge of specified row and column.
GetCellGridLineWeight | Returns the gridLineWeight value for the given edge of specified row and column.
GetCellGridVisibility | Returns the gridVisibility value for the given edge of specified row and column.
GetCellStyleOverrides | Returns the cellStyleOverrides.
GetCellTextHeight | Returns the text height for the specified row and column.
GetCellTextStyle | Returns the text style name for the specified row and column.
GetCellType | Gets the cell type for the specified row and column.
GetColumnWidth | Returns the column width for the specified column.
GetContentColor | Returns the true color value for the specified row type.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetFieldId | Returns the field object id associated to the specifed cell.
GetGridColor | Returns the gridColor value for the specified gridLineType and row type.
GetGridLineWeight | Returns the gridLineWeight value for the specified gridLineType and row type.
GetGridVisibility | Returns the gridVisibility value for the specified gridLineType and row type.
GetMinimumColumnWidth | Gets the minimum column width for the specified column.
GetMinimumRowHeight | Gets the minimum row height for the specified row.
GetRowHeight | Returns the row height for the specified row.
GetRowType | Gets the row type for the specified row.
GetSubSelection | Returns the row and column indexes of the cells in a subselection set.
GetText | Returns the text value value for the specified row and column.
GetTextHeight | Returns the text height for the specified row type.
GetTextRotation | Returns the text rotation for the specified row and column.
GetTextStyle | Returns the text style name for the specified row type.
Highlight | Highlights the entity object.
HitTest | Hit test.
InsertColumns | Inserts the column(s) of specified width.
InsertRows | Inserts the row(s) of specified height.
IntersectWith | Intersects with the input entity object.
IsMergedCell | is Merged Cell.
MergeCells | merge cells.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
RecomputeTableBlock | Recompute TableBlock.
ReselectSubRegion | Re select SubRegion.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
Select | Selects objects and places them into a selection set.
SelectSubRegion | Select SubRegion.
SetAlignment | Sets the cell alignment for the specified row types.
SetAutoScale | Sets the auto scale flag value for the specified row and column.
SetBackgroundColor | Sets the background true color value for the specified row types.
SetBackgroundColorNone | Sets the backgroundColorNone flag value for the specified row types.
SetBlockAttributeValue | Sets the attribute value to the Specified block cell for the attribute definition object contained in the block.
SetBlockRotation | Sets the block rotation for the specified row and column.
SetBlockScale | Sets the block scale value for the specified row and column.
SetBlockTableRecordId | Sets the block table record id associated to the block-type cell.
SetCellAlignment | Sets the cell alignment for the specified row and column.
SetCellBackgroundColor | Sets the background true color value for the specified row and column.
SetCellBackgroundColorNone | Sets the backgroundColorNone flag value for the specified row and column.
SetCellContentColor | Sets the true color value for the specified row and column.
SetCellGridColor | Sets the gridColor value for the given edges of specified row and column.
SetCellGridLineWeight | Sets the gridLineWeight value for the given edges of specified row and column.
SetCellGridVisibility | Sets the gridVisibility value for the given edges of specified row and column.
SetCellTextHeight | Sets the text height for the specified row and column.
SetCellTextStyle | Sets the text style name for the specified row and column.
SetCellType | Sets the cell type for the specified row and column.
SetColumnWidth | Sets the column width for the specified column.
SetContentColor | Sets the true color value for the specified row types.
SetFieldId | Sets the field object id in the specifed cell.
SetGridColor | Sets the gridColor value for the specified gridLineType(s) and row type(s).
SetGridLineWeight | Sets the gridLineWeight value for the specified gridLineType(s) and row type(s).
SetGridVisibility | Sets the gridVisibility value for the specified gridLineType(s) and row type(s).
SetRowHeight | Sets the row height for the specified row.
SetSubSelection | Sets the row and column indices of the cells in a subselection set.
SetText | Sets the text value value for the specified row and column.
SetTextHeight | Sets the text height for the specified row types.
SetTextRotation | Sets the text rotation for the specified row and column.
SetTextStyle | Sets the text style name for the specified row types.
TransformBy | Performs the specified transformation on the entity object.
UnmergeCells | Unmerge cells.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
ColumnWidth | Sets the uniform column width for all the columns in the table.
Columns | Specifies the columns in the Table
Database | Returns the database object.
Direction | Specifies the direction vector of the table
Document | Returns the document object.
FlowDirection | Specifies the Table flow direction
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
HasSubSelection | Specifies whether the table contains a subselection set.
HeaderSuppressed | Returns and sets the header suppressed flag value.
Height | Specifies the Table height
HorzCellMargin | Specifies the horizontal distance between text and edge of cell
Hyperlinks | Specifies the hyperlink collection for the object.
InsertionPoint | Specifies the insertion point of the table
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
MinimumTableHeight | Gets the minimum height for the table.
MinimumTableWidth | Gets the minimum width for the table.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
RowHeight | Sets the uniform row height for all the rows in the table.
Rows | Specifies the rows in the Table
StyleName | Specifies the style name of the Table
TableStyleOverrides | Returns the tableStyleOverrides.
TitleSuppressed | Returns and sets the title suppressed flag value.
TrueColor | Returns the true color of the object.
VertCellMargin | Specifies the vertical distance between text and edge of cell
Visible | Determines whether object visibility is on or off.
Width | Specifies the Table width

Events

Name | Description
Modified | Happens when object is modified


Table.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Table object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Table.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Table object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Table.ClearSubSelection Method

Removes a subselection set of cells from a table.

Syntax

object.ClearSubSelection

object is a Table object.


Table.ClearTableStyleOverrides Method

Clears the tableStyleOverrides.

Syntax

object.ClearTableStyleOverrides(flag)

object is a Table object.

Parameters

Name | Options | Data Type | Description
flag | Input-only | Integer | -


Table.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Table object.

Return value

Object

Examples...

Copy Method example


Table.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Table object.

Examples...

Delete Method example


Table.DeleteCellContent Method

Deletes the cell content for the specified row and coluumn.

Syntax

object.DeleteCellContent(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -


Table.DeleteColumns Method

deletes the column(s) from the specified column index.

Syntax

object.DeleteColumns(col, cols)

object is a Table object.

Parameters

Name | Options | Data Type | Description
col | Input-only | Integer | -
cols | Input-only | Integer | -


Table.DeleteRows Method

deletes the row(s) from the specified row index.

Syntax

object.DeleteRows(row, Rows)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
Rows | Input-only | Integer | -


Table.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Table object.

Examples...

Erase Method example


Table.GenerateLayout Method

Generate layout.

Syntax

object.GenerateLayout

object is a Table object.


Table.GetAlignment Method

Returns the cell alignment for the specified row type.

Syntax

object.GetAlignment(rowType)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

ZcCellAlignment


Table.GetAttachmentPoint Method

Gets the attachment point for the specified row and column.

Syntax

object.GetAttachmentPoint(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

Variant


Table.GetAutoScale Method

Returns the auto scale flag value for the specified row and column.

Syntax

object.GetAutoScale(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

Boolean


Table.GetBackgroundColor Method

Returns the background true color value for the specified row type.

Syntax

object.GetBackgroundColor(rowType)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

ZcCmColor


Table.GetBackgroundColorNone Method

Returns the backgroundColorNone flag value for the specified row type.

Syntax

object.GetBackgroundColorNone(rowType)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

Boolean


Table.GetBlockAttributeValue Method

Returns the attribute value from the Specified block cell for the attribute definition object contained in the block.

Syntax

object.GetBlockAttributeValue(row, col, attdefId)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
attdefId | Input-only | LONG_PTR | alias for Long

Return value

String


Table.GetBlockRotation Method

Returns the block rotation for the specified row and column.

Syntax

object.GetBlockRotation(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

Double


Table.GetBlockScale Method

Returns the block scale value for the specified row and column.

Syntax

object.GetBlockScale(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

Double


Table.GetBlockTableRecordId Method

Returns the block table record id associated to the block-type cell.

Syntax

object.GetBlockTableRecordId(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

LONG_PTR


Table.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Table object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Table.GetCellAlignment Method

Returns the alignment for the specified row and column.

Syntax

object.GetCellAlignment(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

ZcCellAlignment


Table.GetCellBackgroundColor Method

Returns the background true color value for the specified row and column.

Syntax

object.GetCellBackgroundColor(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

ZcCmColor


Table.GetCellBackgroundColorNone Method

Returns the backgroundColorNone flag value for the specified row and column.

Syntax

object.GetCellBackgroundColorNone(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

Boolean


Table.GetCellContentColor Method

Returns the true color value for the specified row and column.

Syntax

object.GetCellContentColor(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

ZcCmColor


Table.GetCellExtents Method

Gets the cell extents for the specified row and column.

Syntax

object.GetCellExtents(row, col, bOuterCell)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
bOuterCell | Input-only | Boolean | -

Return value

Variant


Table.GetCellGridColor Method

Returns the gridColor value for the given edge of specified row and column.

Syntax

object.GetCellGridColor(row, col, edge)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
edge | Input-only | ZcCellEdgeMask | Can be one of the constants listed here: zcTopMask zcRightMask zcBottomMask zcLeftMask

Return value

ZcCmColor


Table.GetCellGridLineWeight Method

Returns the gridLineWeight value for the given edge of specified row and column.

Syntax

object.GetCellGridLineWeight(row, col, edge)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
edge | Input-only | ZcCellEdgeMask | Can be one of the constants listed here: zcTopMask zcRightMask zcBottomMask zcLeftMask

Return value

ZCAD_LWEIGHT


Table.GetCellGridVisibility Method

Returns the gridVisibility value for the given edge of specified row and column.

Syntax

object.GetCellGridVisibility(row, col, edge)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
edge | Input-only | ZcCellEdgeMask | Can be one of the constants listed here: zcTopMask zcRightMask zcBottomMask zcLeftMask

Return value

Boolean


Table.GetCellStyleOverrides Method

Returns the cellStyleOverrides.

Syntax

object.GetCellStyleOverrides(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

Variant


Table.GetCellTextHeight Method

Returns the text height for the specified row and column.

Syntax

object.GetCellTextHeight(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

Double


Table.GetCellTextStyle Method

Returns the text style name for the specified row and column.

Syntax

object.GetCellTextStyle(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

String


Table.GetCellType Method

Gets the cell type for the specified row and column.

Syntax

object.GetCellType(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

ZcCellType


Table.GetColumnWidth Method

Returns the column width for the specified column.

Syntax

object.GetColumnWidth(col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
col | Input-only | Integer | -

Return value

Double


Table.GetContentColor Method

Returns the true color value for the specified row type.

Syntax

object.GetContentColor(rowType)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

ZcCmColor


Table.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Table object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Table.GetFieldId Method

Returns the field object id associated to the specifed cell.

Syntax

object.GetFieldId(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

LONG_PTR


Table.GetGridColor Method

Returns the gridColor value for the specified gridLineType and row type.

Syntax

object.GetGridColor(gridLineType, rowType)

object is a Table object.

Parameters

Name | Options | Data Type | Description
gridLineType | Input-only | ZcGridLineType | Can be one of the constants listed here: zcInvalidGridLine zcHorzTop zcHorzInside zcHorzBottom zcVertLeft zcVertInside zcVertRight
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

ZcCmColor


Table.GetGridLineWeight Method

Returns the gridLineWeight value for the specified gridLineType and row type.

Syntax

object.GetGridLineWeight(gridLineType, rowType)

object is a Table object.

Parameters

Name | Options | Data Type | Description
gridLineType | Input-only | ZcGridLineType | Can be one of the constants listed here: zcInvalidGridLine zcHorzTop zcHorzInside zcHorzBottom zcVertLeft zcVertInside zcVertRight
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

ZCAD_LWEIGHT


Table.GetGridVisibility Method

Returns the gridVisibility value for the specified gridLineType and row type.

Syntax

object.GetGridVisibility(gridLineType, rowType)

object is a Table object.

Parameters

Name | Options | Data Type | Description
gridLineType | Input-only | ZcGridLineType | Can be one of the constants listed here: zcInvalidGridLine zcHorzTop zcHorzInside zcHorzBottom zcVertLeft zcVertInside zcVertRight
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

Boolean


Table.GetMinimumColumnWidth Method

Gets the minimum column width for the specified column.

Syntax

object.GetMinimumColumnWidth(col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
col | Input-only | Integer | -

Return value

Double


Table.GetMinimumRowHeight Method

Gets the minimum row height for the specified row.

Syntax

object.GetMinimumRowHeight(row)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -

Return value

Double


Table.GetRowHeight Method

Returns the row height for the specified row.

Syntax

object.GetRowHeight(row)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -

Return value

Double


Table.GetRowType Method

Gets the row type for the specified row.

Syntax

object.GetRowType(row)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -

Return value

ZcRowType


Table.GetSubSelection Method

Returns the row and column indexes of the cells in a subselection set.

Syntax

object.GetSubSelection(rowMin, rowMax, colMin, colMax)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowMin | Output-only | Integer | -
rowMax | Output-only | Integer | -
colMin | Output-only | Integer | -
colMax | Output-only | Integer | -


Table.GetText Method

Returns the text value value for the specified row and column.

Syntax

object.GetText(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

String


Table.GetTextHeight Method

Returns the text height for the specified row type.

Syntax

object.GetTextHeight(rowType)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

Double


Table.GetTextRotation Method

Returns the text rotation for the specified row and column.

Syntax

object.GetTextRotation(row, col)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -

Return value

ZcRotationAngle


Table.GetTextStyle Method

Returns the text style name for the specified row type.

Syntax

object.GetTextStyle(rowType)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

String


Table.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Table object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Table.HitTest Method

Hit test.

Syntax

object.HitTest(wpt, wviewVec, resultRowIndex, resultColumnIndex)

object is a Table object.

Parameters

Name | Options | Data Type | Description
wpt | Input-only | Variant | -
wviewVec | Input-only | Variant | -
resultRowIndex | Output-only | Integer | -
resultColumnIndex | Output-only | Integer | -

Return value

Boolean


Table.InsertColumns Method

Inserts the column(s) of specified width.

Syntax

object.InsertColumns(col, Width, cols)

object is a Table object.

Parameters

Name | Options | Data Type | Description
col | Input-only | Integer | -
Width | Input-only | Double | -
cols | Input-only | Integer | -


Table.InsertRows Method

Inserts the row(s) of specified height.

Syntax

object.InsertRows(row, Height, Rows)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
Height | Input-only | Double | -
Rows | Input-only | Integer | -


Table.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Table object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Table.IsMergedCell Method

is Merged Cell.

Syntax

object.IsMergedCell(row, col, minRow, maxRow, minCol, maxCol)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
minRow | Output-only | Integer | -
maxRow | Output-only | Integer | -
minCol | Output-only | Integer | -
maxCol | Output-only | Integer | -

Return value

Boolean


Table.MergeCells Method

merge cells.

Syntax

object.MergeCells(minRow, maxRow, minCol, maxCol)

object is a Table object.

Parameters

Name | Options | Data Type | Description
minRow | Input-only | Integer | -
maxRow | Input-only | Integer | -
minCol | Input-only | Integer | -
maxCol | Input-only | Integer | -


Table.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Table object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Table.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Table object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Table.RecomputeTableBlock Method

Recompute TableBlock.

Syntax

object.RecomputeTableBlock(bForceUpdate)

object is a Table object.

Parameters

Name | Options | Data Type | Description
bForceUpdate | Input-only | Boolean | -


Table.ReselectSubRegion Method

Re select SubRegion.

Syntax

object.ReselectSubRegion

object is a Table object.


Table.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Table object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Table.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Table object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Table.Select Method

Selects objects and places them into a selection set.

Syntax

object.Select(wpt, wvwVec, wvwxVec, wxaper, wyaper, allowOutside, resultRowIndex, resultColumnIndex)

object is a Table object.

Parameters

Name | Options | Data Type | Description
wpt | Input-only | Variant | -
wvwVec | Input-only | Variant | -
wvwxVec | Input-only | Variant | -
wxaper | Input-only | Double | -
wyaper | Input-only | Double | -
allowOutside | Input-only | Boolean | -
resultRowIndex | Output-only | Integer | -
resultColumnIndex | Output-only | Integer | -

Examples...

Select Method example


Table.SelectSubRegion Method

Select SubRegion.

Syntax

object.SelectSubRegion(wpt1, wpt2, wvwVec, wvwxVec, seltype, bIncludeCurrentSelection, rowMin, rowMax, colMin, colMax)

object is a Table object.

Parameters

Name | Options | Data Type | Description
wpt1 | Input-only | Variant | -
wpt2 | Input-only | Variant | -
wvwVec | Input-only | Variant | -
wvwxVec | Input-only | Variant | -
seltype | Input-only | ZcSelectType | Can be one of the constants listed here: zcTableSelectWindow zcTableSelectCrossing
bIncludeCurrentSelection | Input-only | Boolean | -
rowMin | Output-only | Integer | -
rowMax | Output-only | Integer | -
colMin | Output-only | Integer | -
colMax | Output-only | Integer | -


Table.SetAlignment Method

Sets the cell alignment for the specified row types.

Syntax

object.SetAlignment(rowTypes, cellAlignment)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
cellAlignment | Input-only | ZcCellAlignment | Can be one of the constants listed here: zcTopLeft zcTopCenter zcTopRight zcMiddleLeft zcMiddleCenter zcMiddleRight zcBottomLeft zcBottomCenter zcBottomRight


Table.SetAutoScale Method

Sets the auto scale flag value for the specified row and column.

Syntax

object.SetAutoScale(row, col, bValue)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
bValue | Input-only | Boolean | -


Table.SetBackgroundColor Method

Sets the background true color value for the specified row types.

Syntax

object.SetBackgroundColor(rowTypes, pColor)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
pColor | Input-only | ZcCmColor | -


Table.SetBackgroundColorNone Method

Sets the backgroundColorNone flag value for the specified row types.

Syntax

object.SetBackgroundColorNone(rowTypes, bValue)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
bValue | Input-only | Boolean | -


Table.SetBlockAttributeValue Method

Sets the attribute value to the Specified block cell for the attribute definition object contained in the block.

Syntax

object.SetBlockAttributeValue(row, col, attdefId, bstrValue)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
attdefId | Input-only | LONG_PTR | alias for Long
bstrValue | Input-only | String | -


Table.SetBlockRotation Method

Sets the block rotation for the specified row and column.

Syntax

object.SetBlockRotation(row, col, blkRotation)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
blkRotation | Input-only | Double | -


Table.SetBlockScale Method

Sets the block scale value for the specified row and column.

Syntax

object.SetBlockScale(row, col, blkScale)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
blkScale | Input-only | Double | -


Table.SetBlockTableRecordId Method

Sets the block table record id associated to the block-type cell.

Syntax

object.SetBlockTableRecordId(row, col, blkId, bAutoFit)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
blkId | Input-only | LONG_PTR | alias for Long
bAutoFit | Input-only | Boolean | -


Table.SetCellAlignment Method

Sets the cell alignment for the specified row and column.

Syntax

object.SetCellAlignment(row, col, cellAlignment)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
cellAlignment | Input-only | ZcCellAlignment | Can be one of the constants listed here: zcTopLeft zcTopCenter zcTopRight zcMiddleLeft zcMiddleCenter zcMiddleRight zcBottomLeft zcBottomCenter zcBottomRight


Table.SetCellBackgroundColor Method

Sets the background true color value for the specified row and column.

Syntax

object.SetCellBackgroundColor(row, col, pColor)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
pColor | Input-only | ZcCmColor | -


Table.SetCellBackgroundColorNone Method

Sets the backgroundColorNone flag value for the specified row and column.

Syntax

object.SetCellBackgroundColorNone(row, col, bValue)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
bValue | Input-only | Boolean | -


Table.SetCellContentColor Method

Sets the true color value for the specified row and column.

Syntax

object.SetCellContentColor(row, col, pColor)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
pColor | Input-only | ZcCmColor | -


Table.SetCellGridColor Method

Sets the gridColor value for the given edges of specified row and column.

Syntax

object.SetCellGridColor(row, col, edges, pColor)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
edges | Input-only | Integer | -
pColor | Input-only | ZcCmColor | -


Table.SetCellGridLineWeight Method

Sets the gridLineWeight value for the given edges of specified row and column.

Syntax

object.SetCellGridLineWeight(row, col, edges, Lineweight)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
edges | Input-only | Integer | -
Lineweight | Input-only | ZCAD_LWEIGHT | alias for ZcLineWeight enum; Can be one of the constants listed here: zcLnWt000 zcLnWt005 zcLnWt009 zcLnWt013 zcLnWt015 zcLnWt018 zcLnWt020 zcLnWt025 zcLnWt030 zcLnWt035 zcLnWt040 zcLnWt050 zcLnWt053 zcLnWt060 zcLnWt070 zcLnWt080 zcLnWt090 zcLnWt100 zcLnWt106 zcLnWt120 zcLnWt140 zcLnWt158 zcLnWt200 zcLnWt211 zcLnWtByLayer zcLnWtByBlock zcLnWtByLwDefault


Table.SetCellGridVisibility Method

Sets the gridVisibility value for the given edges of specified row and column.

Syntax

object.SetCellGridVisibility(row, col, edges, bValue)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
edges | Input-only | Integer | -
bValue | Input-only | Boolean | -


Table.SetCellTextHeight Method

Sets the text height for the specified row and column.

Syntax

object.SetCellTextHeight(row, col, TextHeight)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
TextHeight | Input-only | Double | -


Table.SetCellTextStyle Method

Sets the text style name for the specified row and column.

Syntax

object.SetCellTextStyle(row, col, bstrName)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
bstrName | Input-only | String | -


Table.SetCellType Method

Sets the cell type for the specified row and column.

Syntax

object.SetCellType(row, col, CellType)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
CellType | Input-only | ZcCellType | Can be one of the constants listed here: zcUnknownCell zcTextCell zcBlockCell


Table.SetColumnWidth Method

Sets the column width for the specified column.

Syntax

object.SetColumnWidth(col, Width)

object is a Table object.

Parameters

Name | Options | Data Type | Description
col | Input-only | Integer | -
Width | Input-only | Double | -


Table.SetContentColor Method

Sets the true color value for the specified row types.

Syntax

object.SetContentColor(rowTypes, pColor)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
pColor | Input-only | ZcCmColor | -


Table.SetFieldId Method

Sets the field object id in the specifed cell.

Syntax

object.SetFieldId(row, col, fieldId)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
fieldId | Input-only | LONG_PTR | alias for Long


Table.SetGridColor Method

Sets the gridColor value for the specified gridLineType(s) and row type(s).

Syntax

object.SetGridColor(gridLineTypes, rowTypes, pColor)

object is a Table object.

Parameters

Name | Options | Data Type | Description
gridLineTypes | Input-only | Integer | -
rowTypes | Input-only | Integer | -
pColor | Input-only | ZcCmColor | -


Table.SetGridLineWeight Method

Sets the gridLineWeight value for the specified gridLineType(s) and row type(s).

Syntax

object.SetGridLineWeight(gridLineTypes, rowTypes, Lineweight)

object is a Table object.

Parameters

Name | Options | Data Type | Description
gridLineTypes | Input-only | Integer | -
rowTypes | Input-only | Integer | -
Lineweight | Input-only | ZCAD_LWEIGHT | alias for ZcLineWeight enum; Can be one of the constants listed here: zcLnWt000 zcLnWt005 zcLnWt009 zcLnWt013 zcLnWt015 zcLnWt018 zcLnWt020 zcLnWt025 zcLnWt030 zcLnWt035 zcLnWt040 zcLnWt050 zcLnWt053 zcLnWt060 zcLnWt070 zcLnWt080 zcLnWt090 zcLnWt100 zcLnWt106 zcLnWt120 zcLnWt140 zcLnWt158 zcLnWt200 zcLnWt211 zcLnWtByLayer zcLnWtByBlock zcLnWtByLwDefault


Table.SetGridVisibility Method

Sets the gridVisibility value for the specified gridLineType(s) and row type(s).

Syntax

object.SetGridVisibility(gridLineTypes, rowTypes, bValue)

object is a Table object.

Parameters

Name | Options | Data Type | Description
gridLineTypes | Input-only | Integer | -
rowTypes | Input-only | Integer | -
bValue | Input-only | Boolean | -


Table.SetRowHeight Method

Sets the row height for the specified row.

Syntax

object.SetRowHeight(row, Height)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
Height | Input-only | Double | -


Table.SetSubSelection Method

Sets the row and column indices of the cells in a subselection set.

Syntax

object.SetSubSelection(rowMin, rowMax, colMin, colMax)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowMin | Input-only | Integer | -
rowMax | Input-only | Integer | -
colMin | Input-only | Integer | -
colMax | Input-only | Integer | -


Table.SetText Method

Sets the text value value for the specified row and column.

Syntax

object.SetText(row, col, pStr)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
pStr | Input-only | String | -


Table.SetTextHeight Method

Sets the text height for the specified row types.

Syntax

object.SetTextHeight(rowTypes, TextHeight)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
TextHeight | Input-only | Double | -


Table.SetTextRotation Method

Sets the text rotation for the specified row and column.

Syntax

object.SetTextRotation(row, col, TextRotation)

object is a Table object.

Parameters

Name | Options | Data Type | Description
row | Input-only | Integer | -
col | Input-only | Integer | -
TextRotation | Input-only | ZcRotationAngle | Can be one of the constants listed here: zcDegreesUnknown zcDegrees000 zcDegrees090 zcDegrees180 zcDegrees270


Table.SetTextStyle Method

Sets the text style name for the specified row types.

Syntax

object.SetTextStyle(rowTypes, bstrName)

object is a Table object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
bstrName | Input-only | String | -


Table.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Table object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Table.UnmergeCells Method

Unmerge cells.

Syntax

object.UnmergeCells(minRow, maxRow, minCol, maxCol)

object is a Table object.

Parameters

Name | Options | Data Type | Description
minRow | Input-only | Integer | -
maxRow | Input-only | Integer | -
minCol | Input-only | Integer | -
maxCol | Input-only | Integer | -


Table.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Table object.


Table.Application Property

Returns the application object.

Syntax

object.Application

object is a Table object.

Description

Application Object; Read-only

Examples...

Application Property example


Table.ColumnWidth Property

Sets the uniform column width for all the columns in the table.

Syntax

object.ColumnWidth

object is a Table object.

Description

ColumnWidth ; Write-only


Table.Columns Property

Specifies the columns in the Table

Syntax

object.Columns

object is a Table object.

Description

Columns Integer; Read-write


Table.Database Property

Returns the database object.

Syntax

object.Database

object is a Table object.

Description

Database Database; Read-only


Table.Direction Property

Specifies the direction vector of the table

Syntax

object.Direction

object is a Table object.

Description

Direction Variant; Read-write


Table.Document Property

Returns the document object.

Syntax

object.Document

object is a Table object.

Description

Document Object; Read-only


Table.FlowDirection Property

Specifies the Table flow direction

Syntax

object.FlowDirection

object is a Table object.

Description

FlowDirection ZcTableDirection: Read-write
Can be one of the constants listed here:
zcTableTopToBottom
zcTableBottomToTop


Table.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Table object.

Description

Handle String; Read-only


Table.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Table object.

Description

HasExtensionDictionary Boolean; Read-only


Table.HasSubSelection Property

Specifies whether the table contains a subselection set.

Syntax

object.HasSubSelection

object is a Table object.

Description

HasSubSelection Boolean; Read-only


Table.HeaderSuppressed Property

Returns and sets the header suppressed flag value.

Syntax

object.HeaderSuppressed

object is a Table object.

Description

HeaderSuppressed Boolean; Read-write


Table.Height Property

Specifies the Table height

Syntax

object.Height

object is a Table object.

Description

Height Double; Read-write


Table.HorzCellMargin Property

Specifies the horizontal distance between text and edge of cell

Syntax

object.HorzCellMargin

object is a Table object.

Description

HorzCellMargin Double; Read-write


Table.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Table object.

Description

Hyperlinks Hyperlinks; Read-only


Table.InsertionPoint Property

Specifies the insertion point of the table

Syntax

object.InsertionPoint

object is a Table object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


Table.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Table object.

Description

Layer String; Read-write

Examples...

Layer Property example


Table.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Table object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Table.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Table object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Table.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Table object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Table.MinimumTableHeight Property

Gets the minimum height for the table.

Syntax

object.MinimumTableHeight

object is a Table object.

Description

MinimumTableHeight Double; Read-only


Table.MinimumTableWidth Property

Gets the minimum width for the table.

Syntax

object.MinimumTableWidth

object is a Table object.

Description

MinimumTableWidth Double; Read-only


Table.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Table object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Table.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Table object.

Description

ObjectName String; Read-only


Table.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Table object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Table.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Table object.

Description

PlotStyleName String; Read-write


Table.RowHeight Property

Sets the uniform row height for all the rows in the table.

Syntax

object.RowHeight

object is a Table object.

Description

RowHeight ; Write-only


Table.Rows Property

Specifies the rows in the Table

Syntax

object.Rows

object is a Table object.

Description

Rows Integer; Read-write


Table.StyleName Property

Specifies the style name of the Table

Syntax

object.StyleName

object is a Table object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


Table.TableStyleOverrides Property

Returns the tableStyleOverrides.

Syntax

object.TableStyleOverrides

object is a Table object.

Description

TableStyleOverrides Variant; Read-only


Table.TitleSuppressed Property

Returns and sets the title suppressed flag value.

Syntax

object.TitleSuppressed

object is a Table object.

Description

TitleSuppressed Boolean; Read-write


Table.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Table object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Table.VertCellMargin Property

Specifies the vertical distance between text and edge of cell

Syntax

object.VertCellMargin

object is a Table object.

Description

VertCellMargin Double; Read-write


Table.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Table object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Table.Width Property

Specifies the Table width

Syntax

object.Width

object is a Table object.

Description

Width Double; Read-write

Examples...

Width Property example


Table.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Table object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadTableStyle Object Members

TableStyle Object Members

Adds, modifies, and deletes table styles.

VBA Class Name

ZcadTableStyle

Methods

Name | Description
Delete | Deletes the object.
Erase | Erases the entity object.
GetAlignment | Returns the cell alignment for the specified row type.
GetBackgroundColor | Returns the background true color value for the specified row type.
GetBackgroundColorNone | Returns the backgroundColorNone flag value for the specified row type.
GetColor | Returns the true color value for the specified row type.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetGridColor | Returns the gridColor value for the specified gridLineType and row type.
GetGridLineWeight | Returns the gridLineWeight value for the specified gridLineType and row type.
GetGridVisibility | Returns the gridVisibility value for the specified gridLineType and row type.
GetTextHeight | Returns the text height for the specified row type.
GetTextStyle | Returns the text style name for the specified row type.
SetAlignment | Sets the cell alignment for the specified row types.
SetBackgroundColor | Sets the background true color value for the specified row types.
SetBackgroundColorNone | Sets the backgroundColorNone flag value for the specified row types.
SetColor | Sets the true color value for the specified row types.
SetGridColor | Sets the gridColor value for the specified gridLineType(s) and row type(s).
SetGridLineWeight | Sets the gridLineWeight value for the specified gridLineType(s) and row type(s).
SetGridVisibility | Sets the gridVisibility value for the specified gridLineType(s) and row type(s).
SetTextHeight | Sets the text height for the specified row types.
SetTextStyle | Sets the text style name for the specified row types.

Properties

Name | Description
Application | Returns the application object.
BitFlags | Returns and sets the bit flag values.
Database | Returns the database object.
Description | Returns and sets the description of the tablestyle.
Document | Returns the document object.
FlowDirection | Returns and sets the table flow direction value.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
HeaderSuppressed | Returns and sets the header suppressed flag value.
HorzCellMargin | Returns and sets the horizontal cell margin value.
Name | Returns and sets the name of the tablestyle.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
TitleSuppressed | Returns and sets the title suppressed flag value.
VertCellMargin | Returns and sets the vertical cell margin value.

Events

Name | Description
Modified | Happens when object is modified


TableStyle.Delete Method

Deletes the object.

Syntax

object.Delete

object is a TableStyle object.

Examples...

Delete Method example


TableStyle.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a TableStyle object.

Examples...

Erase Method example


TableStyle.GetAlignment Method

Returns the cell alignment for the specified row type.

Syntax

object.GetAlignment(rowType)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

ZcCellAlignment


TableStyle.GetBackgroundColor Method

Returns the background true color value for the specified row type.

Syntax

object.GetBackgroundColor(rowType)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

ZcCmColor


TableStyle.GetBackgroundColorNone Method

Returns the backgroundColorNone flag value for the specified row type.

Syntax

object.GetBackgroundColorNone(rowType)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

Boolean


TableStyle.GetColor Method

Returns the true color value for the specified row type.

Syntax

object.GetColor(rowType)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

ZcCmColor


TableStyle.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a TableStyle object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


TableStyle.GetGridColor Method

Returns the gridColor value for the specified gridLineType and row type.

Syntax

object.GetGridColor(gridLineType, rowType)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
gridLineType | Input-only | ZcGridLineType | Can be one of the constants listed here: zcInvalidGridLine zcHorzTop zcHorzInside zcHorzBottom zcVertLeft zcVertInside zcVertRight
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

ZcCmColor


TableStyle.GetGridLineWeight Method

Returns the gridLineWeight value for the specified gridLineType and row type.

Syntax

object.GetGridLineWeight(gridLineType, rowType)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
gridLineType | Input-only | ZcGridLineType | Can be one of the constants listed here: zcInvalidGridLine zcHorzTop zcHorzInside zcHorzBottom zcVertLeft zcVertInside zcVertRight
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

ZCAD_LWEIGHT


TableStyle.GetGridVisibility Method

Returns the gridVisibility value for the specified gridLineType and row type.

Syntax

object.GetGridVisibility(gridLineType, rowType)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
gridLineType | Input-only | ZcGridLineType | Can be one of the constants listed here: zcInvalidGridLine zcHorzTop zcHorzInside zcHorzBottom zcVertLeft zcVertInside zcVertRight
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

Boolean


TableStyle.GetTextHeight Method

Returns the text height for the specified row type.

Syntax

object.GetTextHeight(rowType)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

Double


TableStyle.GetTextStyle Method

Returns the text style name for the specified row type.

Syntax

object.GetTextStyle(rowType)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowType | Input-only | ZcRowType | Can be one of the constants listed here: zcUnknownRow zcDataRow zcTitleRow zcHeaderRow

Return value

String


TableStyle.SetAlignment Method

Sets the cell alignment for the specified row types.

Syntax

object.SetAlignment(rowTypes, cellAlignment)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
cellAlignment | Input-only | ZcCellAlignment | Can be one of the constants listed here: zcTopLeft zcTopCenter zcTopRight zcMiddleLeft zcMiddleCenter zcMiddleRight zcBottomLeft zcBottomCenter zcBottomRight


TableStyle.SetBackgroundColor Method

Sets the background true color value for the specified row types.

Syntax

object.SetBackgroundColor(rowTypes, pColor)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
pColor | Input-only | ZcCmColor | -


TableStyle.SetBackgroundColorNone Method

Sets the backgroundColorNone flag value for the specified row types.

Syntax

object.SetBackgroundColorNone(rowTypes, bValue)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
bValue | Input-only | Boolean | -


TableStyle.SetColor Method

Sets the true color value for the specified row types.

Syntax

object.SetColor(rowTypes, pColor)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
pColor | Input-only | ZcCmColor | -


TableStyle.SetGridColor Method

Sets the gridColor value for the specified gridLineType(s) and row type(s).

Syntax

object.SetGridColor(gridLineTypes, rowTypes, pColor)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
gridLineTypes | Input-only | Integer | -
rowTypes | Input-only | Integer | -
pColor | Input-only | ZcCmColor | -


TableStyle.SetGridLineWeight Method

Sets the gridLineWeight value for the specified gridLineType(s) and row type(s).

Syntax

object.SetGridLineWeight(gridLineTypes, rowTypes, Lineweight)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
gridLineTypes | Input-only | Integer | -
rowTypes | Input-only | Integer | -
Lineweight | Input-only | ZCAD_LWEIGHT | alias for ZcLineWeight enum; Can be one of the constants listed here: zcLnWt000 zcLnWt005 zcLnWt009 zcLnWt013 zcLnWt015 zcLnWt018 zcLnWt020 zcLnWt025 zcLnWt030 zcLnWt035 zcLnWt040 zcLnWt050 zcLnWt053 zcLnWt060 zcLnWt070 zcLnWt080 zcLnWt090 zcLnWt100 zcLnWt106 zcLnWt120 zcLnWt140 zcLnWt158 zcLnWt200 zcLnWt211 zcLnWtByLayer zcLnWtByBlock zcLnWtByLwDefault


TableStyle.SetGridVisibility Method

Sets the gridVisibility value for the specified gridLineType(s) and row type(s).

Syntax

object.SetGridVisibility(gridLineTypes, rowTypes, bValue)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
gridLineTypes | Input-only | Integer | -
rowTypes | Input-only | Integer | -
bValue | Input-only | Boolean | -


TableStyle.SetTextHeight Method

Sets the text height for the specified row types.

Syntax

object.SetTextHeight(rowTypes, TextHeight)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
TextHeight | Input-only | Double | -


TableStyle.SetTextStyle Method

Sets the text style name for the specified row types.

Syntax

object.SetTextStyle(rowTypes, bstrName)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
rowTypes | Input-only | Integer | -
bstrName | Input-only | String | -


TableStyle.Application Property

Returns the application object.

Syntax

object.Application

object is a TableStyle object.

Description

Application Object; Read-only

Examples...

Application Property example


TableStyle.BitFlags Property

Returns and sets the bit flag values.

Syntax

object.BitFlags

object is a TableStyle object.

Description

BitFlags Long; Read-write


TableStyle.Database Property

Returns the database object.

Syntax

object.Database

object is a TableStyle object.

Description

Database Database; Read-only


TableStyle.Description Property

Returns and sets the description of the tablestyle.

Syntax

object.Description

object is a TableStyle object.

Description

Description String; Read-write


TableStyle.Document Property

Returns the document object.

Syntax

object.Document

object is a TableStyle object.

Description

Document Object; Read-only


TableStyle.FlowDirection Property

Returns and sets the table flow direction value.

Syntax

object.FlowDirection

object is a TableStyle object.

Description

FlowDirection ZcTableDirection: Read-write
Can be one of the constants listed here:
zcTableTopToBottom
zcTableBottomToTop


TableStyle.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a TableStyle object.

Description

Handle String; Read-only


TableStyle.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a TableStyle object.

Description

HasExtensionDictionary Boolean; Read-only


TableStyle.HeaderSuppressed Property

Returns and sets the header suppressed flag value.

Syntax

object.HeaderSuppressed

object is a TableStyle object.

Description

HeaderSuppressed Boolean; Read-write


TableStyle.HorzCellMargin Property

Returns and sets the horizontal cell margin value.

Syntax

object.HorzCellMargin

object is a TableStyle object.

Description

HorzCellMargin Double; Read-write


TableStyle.Name Property

Returns and sets the name of the tablestyle.

Syntax

object.Name

object is a TableStyle object.

Description

Name String; Read-write

Examples...

Name Property example


TableStyle.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a TableStyle object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


TableStyle.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a TableStyle object.

Description

ObjectName String; Read-only


TableStyle.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a TableStyle object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


TableStyle.TitleSuppressed Property

Returns and sets the title suppressed flag value.

Syntax

object.TitleSuppressed

object is a TableStyle object.

Description

TitleSuppressed Boolean; Read-write


TableStyle.VertCellMargin Property

Returns and sets the vertical cell margin value.

Syntax

object.VertCellMargin

object is a TableStyle object.

Description

VertCellMargin Double; Read-write


TableStyle.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a TableStyle object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadText Object Members

Text Object Members

A single line of alphanumeric characters.

VBA Class Name

ZcadText

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
FieldCode | Returns a text string containing field codes.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Alignment | Specifies the alignment of the text
Application | Returns the application object.
Backward | Determines whether the text is backward or not
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Height | Specifies the height of the text
HorizontalAlignment | Specifies the horizontal alignment of the text
Hyperlinks | Specifies the hyperlink collection for the object.
InsertionPoint | Specifies the X, Y, and Z insertion point coordinates of the text
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
ObliqueAngle | Specifies the oblique angle of the text
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Rotation | Specifies the rotation angle of the text
ScaleFactor | Specifies the width scale factor of the text
StyleName | Specifies the style name of the text
TextAlignmentPoint | Specifies the X, Y, and Z alignment point coordinates of the text
TextGenerationFlag | Return and set the text generation flag
TextString | Specifies the text string of the text
Thickness | Specifies the thickness of the text
TrueColor | Returns the true color of the object.
UpsideDown | Specifies whether the text is upside down or not
VerticalAlignment | Specifies the vertical alignment of the text
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Text.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Text object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Text.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Text object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Text.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Text object.

Return value

Object

Examples...

Copy Method example


Text.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Text object.

Examples...

Delete Method example


Text.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Text object.

Examples...

Erase Method example


Text.FieldCode Method

Returns a text string containing field codes.

Syntax

object.FieldCode

object is a Text object.

Return value

String


Text.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Text object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Text.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Text object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Text.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Text object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Text.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Text object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Text.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Text object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Text.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Text object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Text.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Text object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Text.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Text object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Text.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Text object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Text.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Text object.


Text.Alignment Property

Specifies the alignment of the text

Syntax

object.Alignment

object is a Text object.

Description

Alignment ZcAlignment: Read-write
Can be one of the constants listed here:
zcAlignmentLeft
zcAlignmentCenter
zcAlignmentRight
zcAlignmentAligned
zcAlignmentMiddle
zcAlignmentFit
zcAlignmentTopLeft
zcAlignmentTopCenter
zcAlignmentTopRight
zcAlignmentMiddleLeft
zcAlignmentMiddleCenter
zcAlignmentMiddleRight
zcAlignmentBottomLeft
zcAlignmentBottomCenter
zcAlignmentBottomRight

Examples...

Alignment Property example


Text.Application Property

Returns the application object.

Syntax

object.Application

object is a Text object.

Description

Application Object; Read-only

Examples...

Application Property example


Text.Backward Property

Determines whether the text is backward or not

Syntax

object.Backward

object is a Text object.

Description

Backward Boolean; Read-write

Examples...

Backward Property example


Text.Database Property

Returns the database object.

Syntax

object.Database

object is a Text object.

Description

Database Database; Read-only


Text.Document Property

Returns the document object.

Syntax

object.Document

object is a Text object.

Description

Document Object; Read-only


Text.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Text object.

Description

Handle String; Read-only


Text.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Text object.

Description

HasExtensionDictionary Boolean; Read-only


Text.Height Property

Specifies the height of the text

Syntax

object.Height

object is a Text object.

Description

Height Double; Read-write


Text.HorizontalAlignment Property

Specifies the horizontal alignment of the text

Syntax

object.HorizontalAlignment

object is a Text object.

Description

HorizontalAlignment ZcHorizontalAlignment: Read-write
Can be one of the constants listed here:
zcHorizontalAlignmentLeft
zcHorizontalAlignmentCenter
zcHorizontalAlignmentRight
zcHorizontalAlignmentAligned
zcHorizontalAlignmentMiddle
zcHorizontalAlignmentFit


Text.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Text object.

Description

Hyperlinks Hyperlinks; Read-only


Text.InsertionPoint Property

Specifies the X, Y, and Z insertion point coordinates of the text

Syntax

object.InsertionPoint

object is a Text object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


Text.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Text object.

Description

Layer String; Read-write

Examples...

Layer Property example


Text.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Text object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Text.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Text object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Text.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Text object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Text.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a Text object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Text.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Text object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Text.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Text object.

Description

ObjectName String; Read-only


Text.ObliqueAngle Property

Specifies the oblique angle of the text

Syntax

object.ObliqueAngle

object is a Text object.

Description

ObliqueAngle ZCAD_ANGLE: alias for Double; Read-write

Examples...

ObliqueAngle Property example


Text.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Text object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Text.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Text object.

Description

PlotStyleName String; Read-write


Text.Rotation Property

Specifies the rotation angle of the text

Syntax

object.Rotation

object is a Text object.

Description

Rotation ZCAD_ANGLE: alias for Double; Read-write

Examples...

Rotation Property example


Text.ScaleFactor Property

Specifies the width scale factor of the text

Syntax

object.ScaleFactor

object is a Text object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


Text.StyleName Property

Specifies the style name of the text

Syntax

object.StyleName

object is a Text object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


Text.TextAlignmentPoint Property

Specifies the X, Y, and Z alignment point coordinates of the text

Syntax

object.TextAlignmentPoint

object is a Text object.

Description

TextAlignmentPoint Variant; Read-write

Examples...

TextAlignmentPoint Property example


Text.TextGenerationFlag Property

Return and set the text generation flag

Syntax

object.TextGenerationFlag

object is a Text object.

Description

TextGenerationFlag Long; Read-write

Examples...

TextGenerationFlag Property example


Text.TextString Property

Specifies the text string of the text

Syntax

object.TextString

object is a Text object.

Description

TextString String; Read-write

Examples...

TextString Property example


Text.Thickness Property

Specifies the thickness of the text

Syntax

object.Thickness

object is a Text object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


Text.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Text object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Text.UpsideDown Property

Specifies whether the text is upside down or not

Syntax

object.UpsideDown

object is a Text object.

Description

UpsideDown Boolean; Read-write

Examples...

UpsideDown Property example


Text.VerticalAlignment Property

Specifies the vertical alignment of the text

Syntax

object.VerticalAlignment

object is a Text object.

Description

VerticalAlignment ZcVerticalAlignment: Read-write
Can be one of the constants listed here:
zcVerticalAlignmentBaseline
zcVerticalAlignmentBottom
zcVerticalAlignmentMiddle
zcVerticalAlignmentTop


Text.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Text object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Text.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Text object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadTextStyle Object Members

TextStyle Object Members

A named, saved collection of settings that determines the appearance of text characters.

VBA Class Name

ZcadTextStyle

Methods

Name | Description
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetFont | Returns the font definition data for the text.
SetFont | Sets the font definition data for the text.

Properties

Name | Description
Application | Returns the application object.
BigFontFile | Returns and sets the big font file name.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Height | Returns and sets the height of the text.
LastHeight | Returns the last height used for the text.
Name | Returns the name of the style.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
ObliqueAngle | Returns and sets the oblique angle of the text.
OwnerID | Returns the OwnerID of the object.
TextGenerationFlag | Returns and sets the text generation flag.
Width | Returns and sets the width of the text.

Events

Name | Description
Modified | Happens when object is modified


TextStyle.Delete Method

Deletes the object.

Syntax

object.Delete

object is a TextStyle object.

Examples...

Delete Method example


TextStyle.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a TextStyle object.

Examples...

Erase Method example


TextStyle.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a TextStyle object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


TextStyle.GetFont Method

Returns the font definition data for the text.

Syntax

object.GetFont(TypeFace, Bold, Italic, Charset, PitchAndFamily)

object is a TextStyle object.

Parameters

Name | Options | Data Type | Description
TypeFace | Output-only | String | -
Bold | Output-only | Boolean | -
Italic | Output-only | Boolean | -
Charset | Output-only | Long | -
PitchAndFamily | Output-only | Long | -


TextStyle.SetFont Method

Sets the font definition data for the text.

Syntax

object.SetFont(TypeFace, Bold, Italic, Charset, PitchAndFamily)

object is a TextStyle object.

Parameters

Name | Options | Data Type | Description
TypeFace | Input-only | String | -
Bold | Input-only | Boolean | -
Italic | Input-only | Boolean | -
Charset | Input-only | Long | -
PitchAndFamily | Input-only | Long | -


TextStyle.Application Property

Returns the application object.

Syntax

object.Application

object is a TextStyle object.

Description

Application Object; Read-only

Examples...

Application Property example


TextStyle.BigFontFile Property

Returns and sets the big font file name.

Syntax

object.BigFontFile

object is a TextStyle object.

Description

BigFontFile String; Read-write

Examples...

BigFontFile Property example


TextStyle.Database Property

Returns the database object.

Syntax

object.Database

object is a TextStyle object.

Description

Database Database; Read-only


TextStyle.Document Property

Returns the document object.

Syntax

object.Document

object is a TextStyle object.

Description

Document Object; Read-only


TextStyle.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a TextStyle object.

Description

Handle String; Read-only


TextStyle.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a TextStyle object.

Description

HasExtensionDictionary Boolean; Read-only


TextStyle.Height Property

Returns and sets the height of the text.

Syntax

object.Height

object is a TextStyle object.

Description

Height Double; Read-write


TextStyle.LastHeight Property

Returns the last height used for the text.

Syntax

object.LastHeight

object is a TextStyle object.

Description

LastHeight Double; Read-write


TextStyle.Name Property

Returns the name of the style.

Syntax

object.Name

object is a TextStyle object.

Description

Name String; Read-only

Examples...

Name Property example


TextStyle.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a TextStyle object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


TextStyle.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a TextStyle object.

Description

ObjectName String; Read-only


TextStyle.ObliqueAngle Property

Returns and sets the oblique angle of the text.

Syntax

object.ObliqueAngle

object is a TextStyle object.

Description

ObliqueAngle ZCAD_ANGLE: alias for Double; Read-write

Examples...

ObliqueAngle Property example


TextStyle.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a TextStyle object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


TextStyle.TextGenerationFlag Property

Returns and sets the text generation flag.

Syntax

object.TextGenerationFlag

object is a TextStyle object.

Description

TextGenerationFlag Long; Read-write

Examples...

TextGenerationFlag Property example


TextStyle.Width Property

Returns and sets the width of the text.

Syntax

object.Width

object is a TextStyle object.

Description

Width Double; Read-write

Examples...

Width Property example


TextStyle.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a TextStyle object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadTextStyles Object Members

TextStyles Object Members

The collection of all text styles in the drawing.

VBA Class Name

ZcadTextStyles

Methods

Name | Description
Add | Adds a text style to the text styles collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


TextStyles.Add Method

Adds a text style to the text styles collection.

Syntax

object.Add(Name)

object is a TextStyles object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

TextStyle

Examples...

Add Method example


TextStyles.Delete Method

Deletes the object.

Syntax

object.Delete

object is a TextStyles object.

Examples...

Delete Method example


TextStyles.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a TextStyles object.

Examples...

Erase Method example


TextStyles.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a TextStyles object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


TextStyles.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a TextStyles object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

TextStyle

Examples...

Item Method example


TextStyles.Application Property

Returns the application object.

Syntax

object.Application

object is a TextStyles object.

Description

Application Object; Read-only

Examples...

Application Property example


TextStyles.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a TextStyles object.

Description

Count Long; Read-only

Examples...

Count Property example


TextStyles.Database Property

Returns the database object.

Syntax

object.Database

object is a TextStyles object.

Description

Database Database; Read-only


TextStyles.Document Property

Returns the document object.

Syntax

object.Document

object is a TextStyles object.

Description

Document Object; Read-only


TextStyles.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a TextStyles object.

Description

Handle String; Read-only


TextStyles.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a TextStyles object.

Description

HasExtensionDictionary Boolean; Read-only


TextStyles.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a TextStyles object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


TextStyles.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a TextStyles object.

Description

ObjectName String; Read-only


TextStyles.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a TextStyles object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


TextStyles.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a TextStyles object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadTolerance Object Members

Tolerance Object Members

A geometric tolerance contained in a feature control frame.

VBA Class Name

ZcadTolerance

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
DimensionLineColor | Specifies the color of the dimension lines
DirectionVector | Specifies the direction vector of the tolerance
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
InsertionPoint | Specifies the X, Y, and Z coordinates for insertion point of the tolerance
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
ScaleFactor | Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets
StyleName | Specifies the style name of the tolerance
TextColor | Specifies the color of the dimension text
TextHeight | Specifies the text height of the tolerance
TextString | Specifies the text string of the tolerance
TextStyle | Specifies the text style of the tolerance
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Tolerance.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Tolerance.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Tolerance.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Tolerance object.

Return value

Object

Examples...

Copy Method example


Tolerance.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Tolerance object.

Examples...

Delete Method example


Tolerance.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Tolerance object.

Examples...

Erase Method example


Tolerance.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Tolerance.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Tolerance object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Tolerance.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Tolerance.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Tolerance.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Tolerance.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Tolerance.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Tolerance.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Tolerance.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Tolerance.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Tolerance object.


Tolerance.Application Property

Returns the application object.

Syntax

object.Application

object is a Tolerance object.

Description

Application Object; Read-only

Examples...

Application Property example


Tolerance.Database Property

Returns the database object.

Syntax

object.Database

object is a Tolerance object.

Description

Database Database; Read-only


Tolerance.DimensionLineColor Property

Specifies the color of the dimension lines

Syntax

object.DimensionLineColor

object is a Tolerance object.

Description

DimensionLineColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


Tolerance.DirectionVector Property

Specifies the direction vector of the tolerance

Syntax

object.DirectionVector

object is a Tolerance object.

Description

DirectionVector Variant; Read-write


Tolerance.Document Property

Returns the document object.

Syntax

object.Document

object is a Tolerance object.

Description

Document Object; Read-only


Tolerance.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Tolerance object.

Description

Handle String; Read-only


Tolerance.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Tolerance object.

Description

HasExtensionDictionary Boolean; Read-only


Tolerance.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Tolerance object.

Description

Hyperlinks Hyperlinks; Read-only


Tolerance.InsertionPoint Property

Specifies the X, Y, and Z coordinates for insertion point of the tolerance

Syntax

object.InsertionPoint

object is a Tolerance object.

Description

InsertionPoint Variant; Read-write

Examples...

InsertionPoint Property example


Tolerance.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Tolerance object.

Description

Layer String; Read-write

Examples...

Layer Property example


Tolerance.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Tolerance object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Tolerance.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Tolerance object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Tolerance.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Tolerance object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Tolerance.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a Tolerance object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Tolerance.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Tolerance object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Tolerance.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Tolerance object.

Description

ObjectName String; Read-only


Tolerance.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Tolerance object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Tolerance.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Tolerance object.

Description

PlotStyleName String; Read-write


Tolerance.ScaleFactor Property

Specifies the overall scale factor applied to properties that specify sizes, distances, or offsets

Syntax

object.ScaleFactor

object is a Tolerance object.

Description

ScaleFactor ZCAD_NOUNITS: alias for Double; Read-write

Examples...

ScaleFactor Property example


Tolerance.StyleName Property

Specifies the style name of the tolerance

Syntax

object.StyleName

object is a Tolerance object.

Description

StyleName String; Read-write

Examples...

StyleName Property example


Tolerance.TextColor Property

Specifies the color of the dimension text

Syntax

object.TextColor

object is a Tolerance object.

Description

TextColor ZCAD_COLOR: alias for ZcColor enum; Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

TextColor Property example


Tolerance.TextHeight Property

Specifies the text height of the tolerance

Syntax

object.TextHeight

object is a Tolerance object.

Description

TextHeight Double; Read-write

Examples...

TextHeight Property example


Tolerance.TextString Property

Specifies the text string of the tolerance

Syntax

object.TextString

object is a Tolerance object.

Description

TextString String; Read-write

Examples...

TextString Property example


Tolerance.TextStyle Property

Specifies the text style of the tolerance

Syntax

object.TextStyle

object is a Tolerance object.

Description

TextStyle String; Read-write

Examples...

TextStyle Property example


Tolerance.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Tolerance object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Tolerance.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Tolerance object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Tolerance.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Tolerance object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadToolbar Object Members

Toolbar Object Members

An ZWCAD toolbar.

VBA Class Name

ZcadToolbar

Methods

Name | Description
AddSeparator | Adds a toolbar separator.
AddToolbarButton | Adds a toolbar item.
Delete | Deletes the toolbar.
Dock | Docks the toolbar to the given side.
Float | Floats the toolbar to the given location.
Item | Returns an element in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of elements in the collection.
DockStatus | Returns dock state of the toolbar.
FloatingRows | Returns and sets floating toolbar number of rows.
Height | Returns the height of the toolbar window.
HelpString | Returns and sets toolbar help string.
LargeButtons | Returns button size of the toolbar.
Name | Returns and sets the name of the toolbar.
Parent | Returns the parent object.
TagString | Returns the tag of the toolbar.
Visible | Returns and sets visibility of the toolbar.
Width | Returns the width of the toolbar window.

Events

Name | Description
None | -


Toolbar.AddSeparator Method

Adds a toolbar separator.

Syntax

object.AddSeparator(Index)

object is a Toolbar object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

ToolbarItem

Examples...

AddSeparator Method example


Toolbar.AddToolbarButton Method

Adds a toolbar item.

Syntax

object.AddToolbarButton(Index, Name, HelpString, Macro, FlyoutButton)

object is a Toolbar object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -
Name | Input-only | String | -
HelpString | Input-only | String | -
Macro | Input-only | String | -
FlyoutButton | Input-only, Optional | Variant | -

Return value

ToolbarItem

Examples...

AddToolbarButton Method example


Toolbar.Delete Method

Deletes the toolbar.

Syntax

object.Delete

object is a Toolbar object.

Examples...

Delete Method example


Toolbar.Dock Method

Docks the toolbar to the given side.

Syntax

object.Dock(Side)

object is a Toolbar object.

Parameters

Name | Options | Data Type | Description
Side | Input-only | ZcToolbarDockStatus | Can be one of the constants listed here: zcToolbarDockTop zcToolbarDockBottom zcToolbarDockLeft zcToolbarDockRight zcToolbarFloating


Toolbar.Float Method

Floats the toolbar to the given location.

Syntax

object.Float(top, left, NumberFloatRows)

object is a Toolbar object.

Parameters

Name | Options | Data Type | Description
top | Input-only | Integer | -
left | Input-only | Integer | -
NumberFloatRows | Input-only | Integer | -


Toolbar.Item Method

Returns an element in the collection.

Syntax

object.Item(Index)

object is a Toolbar object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

ToolbarItem

Examples...

Item Method example


Toolbar.Application Property

Returns the application object.

Syntax

object.Application

object is a Toolbar object.

Description

Application Application; Read-only

Examples...

Application Property example


Toolbar.Count Property

Returns the number of elements in the collection.

Syntax

object.Count

object is a Toolbar object.

Description

Count Long; Read-only

Examples...

Count Property example


Toolbar.DockStatus Property

Returns dock state of the toolbar.

Syntax

object.DockStatus

object is a Toolbar object.

Description

DockStatus ZcToolbarDockStatus: Read-only
Can be one of the constants listed here:
zcToolbarDockTop
zcToolbarDockBottom
zcToolbarDockLeft
zcToolbarDockRight
zcToolbarFloating


Toolbar.FloatingRows Property

Returns and sets floating toolbar number of rows.

Syntax

object.FloatingRows

object is a Toolbar object.

Description

FloatingRows Integer; Read-write


Toolbar.Height Property

Returns the height of the toolbar window.

Syntax

object.Height

object is a Toolbar object.

Description

Height Integer; Read-only


Toolbar.HelpString Property

Returns and sets toolbar help string.

Syntax

object.HelpString

object is a Toolbar object.

Description

HelpString String; Read-write


Toolbar.LargeButtons Property

Returns button size of the toolbar.

Syntax

object.LargeButtons

object is a Toolbar object.

Description

LargeButtons Boolean; Read-only

Examples...

LargeButtons Property example


Toolbar.Name Property

Returns and sets the name of the toolbar.

Syntax

object.Name

object is a Toolbar object.

Description

Name String; Read-write

Examples...

Name Property example


Toolbar.Parent Property

Returns the parent object.

Syntax

object.Parent

object is a Toolbar object.

Description

Parent Object; Read-only

Examples...

Parent Property example


Toolbar.TagString Property

Returns the tag of the toolbar.

Syntax

object.TagString

object is a Toolbar object.

Description

TagString String; Read-only

Examples...

TagString Property example


Toolbar.Visible Property

Returns and sets visibility of the toolbar.

Syntax

object.Visible

object is a Toolbar object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Toolbar.Width Property

Returns the width of the toolbar window.

Syntax

object.Width

object is a Toolbar object.

Description

Width Integer; Read-only

Examples...

Width Property example


ZcadToolbarItem Object Members

ToolbarItem Object Members

A single button item on an ZWCAD toolbar.

VBA Class Name

ZcadToolbarItem

Methods

Name | Description
AttachToolbarToFlyout | Attaches a flyout toolbar to the button.
Delete | Deletes the toolbar item.
GetBitmaps | Gets the toolbar button bitmaps.
SetBitmaps | Sets the toolbar button bitmaps.

Properties

Name | Description
Application | Returns the application object.
Flyout | Returns the flyout toolbar object.
HelpString | Returns and sets the toolbar item help string.
Index | Returns the positional index of the toolbar item.
Macro | Returns and sets the macro associated the toolbar item.
Name | Returns and sets the name of the toolbar button.
Parent | Returns the parent object.
TagString | Returns and sets the tag of the toolbar item.
Type | Returns the type of the toolbar item.

Events

Name | Description
None | -


ToolbarItem.AttachToolbarToFlyout Method

Attaches a flyout toolbar to the button.

Syntax

object.AttachToolbarToFlyout(MenuGroupName, ToolbarName)

object is a ToolbarItem object.

Parameters

Name | Options | Data Type | Description
MenuGroupName | Input-only | String | -
ToolbarName | Input-only | String | -

Examples...

AttachToolbarToFlyout Method example


ToolbarItem.Delete Method

Deletes the toolbar item.

Syntax

object.Delete

object is a ToolbarItem object.

Examples...

Delete Method example


ToolbarItem.GetBitmaps Method

Gets the toolbar button bitmaps.

Syntax

object.GetBitmaps(SmallIconName, LargeIconName)

object is a ToolbarItem object.

Parameters

Name | Options | Data Type | Description
SmallIconName | Output-only | String | -
LargeIconName | Output-only | String | -


ToolbarItem.SetBitmaps Method

Sets the toolbar button bitmaps.

Syntax

object.SetBitmaps(SmallIconName, LargeIconName)

object is a ToolbarItem object.

Parameters

Name | Options | Data Type | Description
SmallIconName | Input-only | String | -
LargeIconName | Input-only | String | -


ToolbarItem.Application Property

Returns the application object.

Syntax

object.Application

object is a ToolbarItem object.

Description

Application Application; Read-only

Examples...

Application Property example


ToolbarItem.Flyout Property

Returns the flyout toolbar object.

Syntax

object.Flyout

object is a ToolbarItem object.

Description

Flyout Toolbar; Read-only


ToolbarItem.HelpString Property

Returns and sets the toolbar item help string.

Syntax

object.HelpString

object is a ToolbarItem object.

Description

HelpString String; Read-write


ToolbarItem.Index Property

Returns the positional index of the toolbar item.

Syntax

object.Index

object is a ToolbarItem object.

Description

Index Integer; Read-only


ToolbarItem.Macro Property

Returns and sets the macro associated the toolbar item.

Syntax

object.Macro

object is a ToolbarItem object.

Description

Macro String; Read-write

Examples...

Macro Property example


ToolbarItem.Name Property

Returns and sets the name of the toolbar button.

Syntax

object.Name

object is a ToolbarItem object.

Description

Name String; Read-write

Examples...

Name Property example


ToolbarItem.Parent Property

Returns the parent object.

Syntax

object.Parent

object is a ToolbarItem object.

Description

Parent Toolbar; Read-only

Examples...

Parent Property example


ToolbarItem.TagString Property

Returns and sets the tag of the toolbar item.

Syntax

object.TagString

object is a ToolbarItem object.

Description

TagString String; Read-write

Examples...

TagString Property example


ToolbarItem.Type Property

Returns the type of the toolbar item.

Syntax

object.Type

object is a ToolbarItem object.

Description

Type ZcToolbarItemType: Read-only
Can be one of the constants listed here:
zcToolbarButton
zcToolbarSeparator
zcToolbarControl
zcToolbarFlyout

Examples...

Type Property example


ZcadToolbars Object Members

Toolbars Object Members

A collection of Toolbar objects representing all the toolbars loaded in the current ZWCAD session.

VBA Class Name

ZcadToolbars

Methods

Name | Description
Add | Adds a toolbar.
Item | Returns an element in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns the number of elements in the collection.
LargeButtons | Returns and sets button size of toolbars.
Parent | Returns the parent object.

Events

Name | Description
None | -


Toolbars.Add Method

Adds a toolbar.

Syntax

object.Add(ToolbarName)

object is a Toolbars object.

Parameters

Name | Options | Data Type | Description
ToolbarName | Input-only | String | -

Return value

Toolbar

Examples...

Add Method example


Toolbars.Item Method

Returns an element in the collection.

Syntax

object.Item(Index)

object is a Toolbars object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Toolbar

Examples...

Item Method example


Toolbars.Application Property

Returns the application object.

Syntax

object.Application

object is a Toolbars object.

Description

Application Application; Read-only

Examples...

Application Property example


Toolbars.Count Property

Returns the number of elements in the collection.

Syntax

object.Count

object is a Toolbars object.

Description

Count Long; Read-only

Examples...

Count Property example


Toolbars.LargeButtons Property

Returns and sets button size of toolbars.

Syntax

object.LargeButtons

object is a Toolbars object.

Description

LargeButtons Boolean; Read-write

Examples...

LargeButtons Property example


Toolbars.Parent Property

Returns the parent object.

Syntax

object.Parent

object is a Toolbars object.

Description

Parent MenuGroup; Read-only

Examples...

Parent Property example


ZcadTrace Object Members

Trace Object Members

A 2D solid line of specified width.

VBA Class Name

ZcadTrace

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
Coordinate | Returns the coordinate of the vertex at a given index
Coordinates | Specifies the coordinates of the trace
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
Normal | Specifies the normal direction vector
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
Thickness | Specifies the thickness of the trace
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Trace.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Trace.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Trace.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Trace object.

Return value

Object

Examples...

Copy Method example


Trace.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Trace object.

Examples...

Delete Method example


Trace.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Trace object.

Examples...

Erase Method example


Trace.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Trace.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Trace object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Trace.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Trace.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Trace.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Trace.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Trace.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Trace.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Trace.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Trace.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Trace object.


Trace.Application Property

Returns the application object.

Syntax

object.Application

object is a Trace object.

Description

Application Object; Read-only

Examples...

Application Property example


Trace.Coordinate Property

Returns the coordinate of the vertex at a given index

Syntax

object.Coordinate

object is a Trace object.

Description

Coordinate Variant; Read-write

Examples...

Coordinate Property example


Trace.Coordinates Property

Specifies the coordinates of the trace

Syntax

object.Coordinates

object is a Trace object.

Description

Coordinates Variant; Read-write

Examples...

Coordinates Property example


Trace.Database Property

Returns the database object.

Syntax

object.Database

object is a Trace object.

Description

Database Database; Read-only


Trace.Document Property

Returns the document object.

Syntax

object.Document

object is a Trace object.

Description

Document Object; Read-only


Trace.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Trace object.

Description

Handle String; Read-only


Trace.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Trace object.

Description

HasExtensionDictionary Boolean; Read-only


Trace.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Trace object.

Description

Hyperlinks Hyperlinks; Read-only


Trace.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Trace object.

Description

Layer String; Read-write

Examples...

Layer Property example


Trace.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Trace object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Trace.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Trace object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Trace.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Trace object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Trace.Normal Property

Specifies the normal direction vector

Syntax

object.Normal

object is a Trace object.

Description

Normal Variant; Read-write

Examples...

Normal Property example


Trace.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Trace object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Trace.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Trace object.

Description

ObjectName String; Read-only


Trace.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Trace object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Trace.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Trace object.

Description

PlotStyleName String; Read-write


Trace.Thickness Property

Specifies the thickness of the trace

Syntax

object.Thickness

object is a Trace object.

Description

Thickness Double; Read-write

Examples...

Thickness Property example


Trace.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Trace object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Trace.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Trace object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Trace.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Trace object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadUCS Object Members

UCS Object Members

A user-defined coordinate system that determines the orientation of the X, Y, and Z axes in 3D space.

VBA Class Name

ZcadUCS

Methods

Name | Description
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetUCSMatrix | Returns the transformation matrix associated with the UCS.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Name | Returns and sets the name of the UCS.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
Origin | Returns and sets the origin of the UCS.
OwnerID | Returns the OwnerID of the object.
XVector | Returns and sets the X axis vector of the UCS.
YVector | Returns and sets the Y axis vector of the UCS.

Events

Name | Description
Modified | Happens when object is modified


UCS.Delete Method

Deletes the object.

Syntax

object.Delete

object is a UCS object.

Examples...

Delete Method example


UCS.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a UCS object.

Examples...

Erase Method example


UCS.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a UCS object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


UCS.GetUCSMatrix Method

Returns the transformation matrix associated with the UCS.

Syntax

object.GetUCSMatrix

object is a UCS object.

Return value

Variant

Examples...

GetUCSMatrix Method example


UCS.Application Property

Returns the application object.

Syntax

object.Application

object is a UCS object.

Description

Application Object; Read-only

Examples...

Application Property example


UCS.Database Property

Returns the database object.

Syntax

object.Database

object is a UCS object.

Description

Database Database; Read-only


UCS.Document Property

Returns the document object.

Syntax

object.Document

object is a UCS object.

Description

Document Object; Read-only


UCS.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a UCS object.

Description

Handle String; Read-only


UCS.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a UCS object.

Description

HasExtensionDictionary Boolean; Read-only


UCS.Name Property

Returns and sets the name of the UCS.

Syntax

object.Name

object is a UCS object.

Description

Name String; Read-write

Examples...

Name Property example


UCS.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a UCS object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


UCS.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a UCS object.

Description

ObjectName String; Read-only


UCS.Origin Property

Returns and sets the origin of the UCS.

Syntax

object.Origin

object is a UCS object.

Description

Origin Variant; Read-write

Examples...

Origin Property example


UCS.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a UCS object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


UCS.XVector Property

Returns and sets the X axis vector of the UCS.

Syntax

object.XVector

object is a UCS object.

Description

XVector Variant; Read-write

Examples...

XVector Property example


UCS.YVector Property

Returns and sets the Y axis vector of the UCS.

Syntax

object.YVector

object is a UCS object.

Description

YVector Variant; Read-write

Examples...

YVector Property example


UCS.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a UCS object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadUCSs Object Members

UCSs Object Members

The collection of all user coordinate systems (UCSs) in the drawing.

VBA Class Name

ZcadUCSs

Methods

Name | Description
Add | Adds a UCS to the UCS collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


UCSs.Add Method

Adds a UCS to the UCS collection.

Syntax

object.Add(Origin, XAxisPoint, YAxisPoint, Name)

object is a UCSs object.

Parameters

Name | Options | Data Type | Description
Origin | Input-only | Variant | -
XAxisPoint | Input-only | Variant | -
YAxisPoint | Input-only | Variant | -
Name | Input-only | String | -

Return value

UCS

Examples...

Add Method example


UCSs.Delete Method

Deletes the object.

Syntax

object.Delete

object is a UCSs object.

Examples...

Delete Method example


UCSs.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a UCSs object.

Examples...

Erase Method example


UCSs.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a UCSs object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


UCSs.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a UCSs object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

UCS

Examples...

Item Method example


UCSs.Application Property

Returns the application object.

Syntax

object.Application

object is a UCSs object.

Description

Application Object; Read-only

Examples...

Application Property example


UCSs.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a UCSs object.

Description

Count Long; Read-only

Examples...

Count Property example


UCSs.Database Property

Returns the database object.

Syntax

object.Database

object is a UCSs object.

Description

Database Database; Read-only


UCSs.Document Property

Returns the document object.

Syntax

object.Document

object is a UCSs object.

Description

Document Object; Read-only


UCSs.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a UCSs object.

Description

Handle String; Read-only


UCSs.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a UCSs object.

Description

HasExtensionDictionary Boolean; Read-only


UCSs.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a UCSs object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


UCSs.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a UCSs object.

Description

ObjectName String; Read-only


UCSs.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a UCSs object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


UCSs.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a UCSs object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadUtility Object Members

Utility Object Members

A series of methods provided for utility purposes.

VBA Class Name

ZcadUtility

Methods

Name | Description
AngleFromXAxis | Returns the angle of the line from the X-axis.
AngleToReal | Converts angle to real.
AngleToString | Converts angle to string.
CreateTypedArray | Returns a variant containing an array of typed arguments.
DistanceToReal | Converts distance to real.
GetAngle | Returns the angle specified. Considers the setting of ANGBASE variable.
GetCorner | Returns two corners of a rectangle.
GetDistance | Returns the distance.
GetEntity | Returns the point selected and the object at that point.
GetInput | Returns an input string.
GetInteger | Returns an integer.
GetKeyword | Returns an keyword.
GetOrientation | Returns the angle specified. Ignores the setting of ANGBASE variable.
GetPoint | Returns the selected point.
GetReal | Returns an real number.
GetRemoteFile | Downloads file from a remote server on the Internet.
GetString | Returns an string.
GetSubEntity | Returns the point selected and the object or subentity at that point.
InitializeUserInput | Initialize get functions.
IsRemoteFile | Returns a boolean indicating whether the specified file was downloaded from the Internet.
IsURL | Returns a boolean indicating whether the input string is a valid URL.
LaunchBrowserDialog | Launches the Web Browser Dialog.
PolarPoint | Returns the point at specified angle and distance from a given point.
Prompt | Prompts the message at the Zwcad command window.
PutRemoteFile | Uploads file to a remote server on the Internet.
RealToString | Converts real to string.
TranslateCoordinates | Translates a point from one coordinate system to another coordinate system.

Properties

Name | Description
None | -

Events

Name | Description
None | -


Utility.AngleFromXAxis Method

Returns the angle of the line from the X-axis.

Syntax

object.AngleFromXAxis(StartPoint, EndPoint)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
StartPoint | Input-only | Variant | -
EndPoint | Input-only | Variant | -

Return value

Double

Examples...

AngleFromXAxis Method example


Utility.AngleToReal Method

Converts angle to real.

Syntax

object.AngleToReal(Angle, Unit)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Angle | Input-only | String | -
Unit | Input-only | ZcAngleUnits | Can be one of the constants listed here: zcDegrees zcDegreeMinuteSeconds zcGrads zcRadians

Return value

Double

Examples...

AngleToReal Method example


Utility.AngleToString Method

Converts angle to string.

Syntax

object.AngleToString(Angle, Unit, precision)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Angle | Input-only | Double | -
Unit | Input-only | ZcAngleUnits | Can be one of the constants listed here: zcDegrees zcDegreeMinuteSeconds zcGrads zcRadians
precision | Input-only | Integer | -

Return value

String

Examples...

AngleToString Method example


Utility.CreateTypedArray Method

Returns a variant containing an array of typed arguments.

Syntax

object.CreateTypedArray(varArr, Type, inArgs)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
varArr | Output-only | Variant | -
Type | Input-only | Integer | -
inArgs | Input-only | Array | -


Utility.DistanceToReal Method

Converts distance to real.

Syntax

object.DistanceToReal(Distance, Unit)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Distance | Input-only | String | -
Unit | Input-only | ZcUnits | Can be one of the constants listed here: zcDefaultUnits zcScientific zcDecimal zcEngineering zcArchitectural zcFractional

Return value

Double

Examples...

DistanceToReal Method example


Utility.GetAngle Method

Returns the angle specified. Considers the setting of ANGBASE variable.

Syntax

object.GetAngle(Point, Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Point | Input-only, Optional | Variant | -
Prompt | Input-only, Optional | Variant | -

Return value

Double

Examples...

GetAngle Method example


Utility.GetCorner Method

Returns two corners of a rectangle.

Syntax

object.GetCorner(Point, Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Point | Input-only | Variant | -
Prompt | Input-only, Optional | Variant | -

Return value

Variant

Examples...

GetCorner Method example


Utility.GetDistance Method

Returns the distance.

Syntax

object.GetDistance(Point, Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Point | Input-only, Optional | Variant | -
Prompt | Input-only, Optional | Variant | -

Return value

Double

Examples...

GetDistance Method example


Utility.GetEntity Method

Returns the point selected and the object at that point.

Syntax

object.GetEntity(Object, PickedPoint, Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Object | Output-only | Object | -
PickedPoint | Output-only | Variant | -
Prompt | Input-only, Optional | Variant | -

Examples...

GetEntity Method example


Utility.GetInput Method

Returns an input string.

Syntax

object.GetInput

object is a Utility object.

Return value

String

Examples...

GetInput Method example


Utility.GetInteger Method

Returns an integer.

Syntax

object.GetInteger(Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Prompt | Input-only, Optional | Variant | -

Return value

Integer

Examples...

GetInteger Method example


Utility.GetKeyword Method

Returns an keyword.

Syntax

object.GetKeyword(Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Prompt | Input-only, Optional | Variant | -

Return value

String

Examples...

GetKeyword Method example


Utility.GetOrientation Method

Returns the angle specified. Ignores the setting of ANGBASE variable.

Syntax

object.GetOrientation(Point, Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Point | Input-only, Optional | Variant | -
Prompt | Input-only, Optional | Variant | -

Return value

Double

Examples...

GetOrientation Method example


Utility.GetPoint Method

Returns the selected point.

Syntax

object.GetPoint(Point, Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Point | Input-only, Optional | Variant | -
Prompt | Input-only, Optional | Variant | -

Return value

Variant

Examples...

GetPoint Method example


Utility.GetReal Method

Returns an real number.

Syntax

object.GetReal(Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Prompt | Input-only, Optional | Variant | -

Return value

Double

Examples...

GetReal Method example


Utility.GetRemoteFile Method

Downloads file from a remote server on the Internet.

Syntax

object.GetRemoteFile(URL, LocalFile, IgnoreCache)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
URL | Input-only | String | -
LocalFile | Output-only | String | -
IgnoreCache | Input-only | Boolean | -


Utility.GetString Method

Returns an string.

Syntax

object.GetString(HasSpaces, Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
HasSpaces | Input-only | Integer | -
Prompt | Input-only, Optional | Variant | -

Return value

String

Examples...

GetString Method example


Utility.GetSubEntity Method

Returns the point selected and the object or subentity at that point.

Syntax

object.GetSubEntity(Object, PickedPoint, transMatrix, ContextData, Prompt)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Object | Output-only | Object | -
PickedPoint | Output-only | Variant | -
transMatrix | Output-only | Variant | -
ContextData | Output-only | Variant | -
Prompt | Input-only, Optional | Variant | -

Examples...

GetSubEntity Method example


Utility.InitializeUserInput Method

Initialize get functions.

Syntax

object.InitializeUserInput(Bits, KeyWordList)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Bits | Input-only | Integer | -
KeyWordList | Input-only, Optional | Variant | -


Utility.IsRemoteFile Method

Returns a boolean indicating whether the specified file was downloaded from the Internet.

Syntax

object.IsRemoteFile(LocalFile, URL)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
LocalFile | Input-only | String | -
URL | Output-only | String | -

Return value

Boolean


Utility.IsURL Method

Returns a boolean indicating whether the input string is a valid URL.

Syntax

object.IsURL(URL)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
URL | Input-only | String | -

Return value

Boolean


Utility.LaunchBrowserDialog Method

Launches the Web Browser Dialog.

Syntax

object.LaunchBrowserDialog(SelectedURL, DialogTitle, OpenButtonCaption, StartPageURL, RegistryRootKey, OpenButtonAlwaysEnabled)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
SelectedURL | Output-only | String | -
DialogTitle | Input-only | String | -
OpenButtonCaption | Input-only | String | -
StartPageURL | Input-only | String | -
RegistryRootKey | Input-only | String | -
OpenButtonAlwaysEnabled | Input-only | Boolean | -

Return value

Boolean


Utility.PolarPoint Method

Returns the point at specified angle and distance from a given point.

Syntax

object.PolarPoint(Point, Angle, Distance)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Point | Input-only | Variant | -
Angle | Input-only | Double | -
Distance | Input-only | Double | -

Return value

Variant

Examples...

PolarPoint Method example


Utility.Prompt Method

Prompts the message at the Zwcad command window.

Syntax

object.Prompt(Message)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Message | Input-only | String | -

Examples...

Prompt Method example


Utility.PutRemoteFile Method

Uploads file to a remote server on the Internet.

Syntax

object.PutRemoteFile(URL, LocalFile)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
URL | Input-only | String | -
LocalFile | Input-only | String | -


Utility.RealToString Method

Converts real to string.

Syntax

object.RealToString(Value, Unit, precision)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Value | Input-only | Double | -
Unit | Input-only | ZcUnits | Can be one of the constants listed here: zcDefaultUnits zcScientific zcDecimal zcEngineering zcArchitectural zcFractional
precision | Input-only | Integer | -

Return value

String

Examples...

RealToString Method example


Utility.TranslateCoordinates Method

Translates a point from one coordinate system to another coordinate system.

Syntax

object.TranslateCoordinates(Point, FromCoordSystem, ToCoordSystem, Displacement, OCSNormal)

object is a Utility object.

Parameters

Name | Options | Data Type | Description
Point | Input-only | Variant | -
FromCoordSystem | Input-only | ZcCoordinateSystem | Can be one of the constants listed here: zcWorld zcUCS zcDisplayDCS zcPaperSpaceDCS zcOCS
ToCoordSystem | Input-only | ZcCoordinateSystem | Can be one of the constants listed here: zcWorld zcUCS zcDisplayDCS zcPaperSpaceDCS zcOCS
Displacement | Input-only | Integer | -
OCSNormal | Input-only, Optional | Variant | -

Return value

Variant

Examples...

TranslateCoordinates Method example


ZcadView Object Members

View Object Members

A graphical representation of a 2D drawing or 3D model from a specific location (viewpoint) in space.

VBA Class Name

ZcadView

Methods

Name | Description
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.

Properties

Name | Description
Application | Returns the application object.
CategoryName | Returns and sets the name of the category of the view.
Center | Returns and sets the center point of the view.
Database | Returns the database object.
Direction | Returns and sets view direction from target.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
HasVpAssociation | Specifies whether the view is associated with a paperspace viewport.
Height | Returns and sets the height of the view.
LayerState | Returns and sets the name of the layer state of the view.
Name | Returns and sets the name of the view.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
Target | Returns and sets the target point of the view.
Width | Returns and sets the width of the view.

Events

Name | Description
Modified | Happens when object is modified


View.Delete Method

Deletes the object.

Syntax

object.Delete

object is a View object.

Examples...

Delete Method example


View.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a View object.

Examples...

Erase Method example


View.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a View object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


View.Application Property

Returns the application object.

Syntax

object.Application

object is a View object.

Description

Application Object; Read-only

Examples...

Application Property example


View.CategoryName Property

Returns and sets the name of the category of the view.

Syntax

object.CategoryName

object is a View object.

Description

CategoryName String; Read-write


View.Center Property

Returns and sets the center point of the view.

Syntax

object.Center

object is a View object.

Description

Center Variant; Read-write

Examples...

Center Property example


View.Database Property

Returns the database object.

Syntax

object.Database

object is a View object.

Description

Database Database; Read-only


View.Direction Property

Returns and sets view direction from target.

Syntax

object.Direction

object is a View object.

Description

Direction Variant; Read-write


View.Document Property

Returns the document object.

Syntax

object.Document

object is a View object.

Description

Document Object; Read-only


View.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a View object.

Description

Handle String; Read-only


View.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a View object.

Description

HasExtensionDictionary Boolean; Read-only


View.HasVpAssociation Property

Specifies whether the view is associated with a paperspace viewport.

Syntax

object.HasVpAssociation

object is a View object.

Description

HasVpAssociation Boolean; Read-write


View.Height Property

Returns and sets the height of the view.

Syntax

object.Height

object is a View object.

Description

Height Double; Read-write


View.LayerState Property

Returns and sets the name of the layer state of the view.

Syntax

object.LayerState

object is a View object.

Description

LayerState String; Read-write


View.Name Property

Returns and sets the name of the view.

Syntax

object.Name

object is a View object.

Description

Name String; Read-write

Examples...

Name Property example


View.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a View object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


View.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a View object.

Description

ObjectName String; Read-only


View.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a View object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


View.Target Property

Returns and sets the target point of the view.

Syntax

object.Target

object is a View object.

Description

Target Variant; Read-write

Examples...

Target Property example


View.Width Property

Returns and sets the width of the view.

Syntax

object.Width

object is a View object.

Description

Width Double; Read-write

Examples...

Width Property example


View.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a View object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadViewport Object Members

Viewport Object Members

A bounded area that displays some portion of a drawing's model space.

VBA Class Name

ZcadViewport

Methods

Name | Description
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetGridSpacing | Returns the grid spacing for the viewport.
GetSnapSpacing | Returns the snap spacing for the viewport.
SetGridSpacing | Sets the grid spacing for the viewport.
SetSnapSpacing | Sets the snap spacing for the viewport.
SetView | Sets the view in a viewport to a saved view.
Split | Splits viewport. Takes a constant.

Properties

Name | Description
Application | Returns the application object.
ArcSmoothness | Returns and sets the circle zoom percent for the viewport.
Center | Returns and sets the center point of the view.
Database | Returns the database object.
Direction | Returns and sets view direction from target.
Document | Returns the document object.
GridOn | Toggles the grid on or off.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Height | Returns and sets the height of the view.
LowerLeftCorner | Return lower left corner. Readonly.
Name | Returns and sets the name of the viewport.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OrthoOn | Toggle ortho on or off.
OwnerID | Returns the OwnerID of the object.
SnapBasePoint | Returns and sets the snap base point for the viewport.
SnapOn | Toggle snap on or off.
SnapRotationAngle | Returns and sets the snap rotation angle for the viewport.
Target | Returns and sets the target point of the view.
UCSIconAtOrigin | Toggles the display of the user coordinates systems icon at the origin on or off.
UCSIconOn | Toggle the user coordinates systems icon on or off.
UpperRightCorner | Return Upper right corner. Readonly.
Width | Returns and sets the width of the view.

Events

Name | Description
Modified | Happens when object is modified


Viewport.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Viewport object.

Examples...

Delete Method example


Viewport.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Viewport object.

Examples...

Erase Method example


Viewport.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Viewport object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Viewport.GetGridSpacing Method

Returns the grid spacing for the viewport.

Syntax

object.GetGridSpacing(XSpacing, YSpacing)

object is a Viewport object.

Parameters

Name | Options | Data Type | Description
XSpacing | Output-only | Double | -
YSpacing | Output-only | Double | -

Examples...

GetGridSpacing Method example


Viewport.GetSnapSpacing Method

Returns the snap spacing for the viewport.

Syntax

object.GetSnapSpacing(XSpacing, YSpacing)

object is a Viewport object.

Parameters

Name | Options | Data Type | Description
XSpacing | Output-only | Double | -
YSpacing | Output-only | Double | -

Examples...

GetSnapSpacing Method example


Viewport.SetGridSpacing Method

Sets the grid spacing for the viewport.

Syntax

object.SetGridSpacing(XSpacing, YSpacing)

object is a Viewport object.

Parameters

Name | Options | Data Type | Description
XSpacing | Input-only | Double | -
YSpacing | Input-only | Double | -


Viewport.SetSnapSpacing Method

Sets the snap spacing for the viewport.

Syntax

object.SetSnapSpacing(XSpacing, YSpacing)

object is a Viewport object.

Parameters

Name | Options | Data Type | Description
XSpacing | Input-only | Double | -
YSpacing | Input-only | Double | -


Viewport.SetView Method

Sets the view in a viewport to a saved view.

Syntax

object.SetView(View)

object is a Viewport object.

Parameters

Name | Options | Data Type | Description
View | Input-only | View | -

Examples...

SetView Method example


Viewport.Split Method

Splits viewport. Takes a constant.

Syntax

object.Split(NumWins)

object is a Viewport object.

Parameters

Name | Options | Data Type | Description
NumWins | Input-only | ZcViewportSplitType | Can be one of the constants listed here: zcViewport2Horizontal zcViewport2Vertical zcViewport3Left zcViewport3Right zcViewport3Horizontal zcViewport3Vertical zcViewport3Above zcViewport3Below zcViewport4


Viewport.Application Property

Returns the application object.

Syntax

object.Application

object is a Viewport object.

Description

Application Object; Read-only

Examples...

Application Property example


Viewport.ArcSmoothness Property

Returns and sets the circle zoom percent for the viewport.

Syntax

object.ArcSmoothness

object is a Viewport object.

Description

ArcSmoothness Long; Read-write


Viewport.Center Property

Returns and sets the center point of the view.

Syntax

object.Center

object is a Viewport object.

Description

Center Variant; Read-write

Examples...

Center Property example


Viewport.Database Property

Returns the database object.

Syntax

object.Database

object is a Viewport object.

Description

Database Database; Read-only


Viewport.Direction Property

Returns and sets view direction from target.

Syntax

object.Direction

object is a Viewport object.

Description

Direction Variant; Read-write


Viewport.Document Property

Returns the document object.

Syntax

object.Document

object is a Viewport object.

Description

Document Object; Read-only


Viewport.GridOn Property

Toggles the grid on or off.

Syntax

object.GridOn

object is a Viewport object.

Description

GridOn Boolean; Read-write


Viewport.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Viewport object.

Description

Handle String; Read-only


Viewport.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Viewport object.

Description

HasExtensionDictionary Boolean; Read-only


Viewport.Height Property

Returns and sets the height of the view.

Syntax

object.Height

object is a Viewport object.

Description

Height Double; Read-write


Viewport.LowerLeftCorner Property

Return lower left corner. Readonly.

Syntax

object.LowerLeftCorner

object is a Viewport object.

Description

LowerLeftCorner Variant; Read-only

Examples...

LowerLeftCorner Property example


Viewport.Name Property

Returns and sets the name of the viewport.

Syntax

object.Name

object is a Viewport object.

Description

Name String; Read-write

Examples...

Name Property example


Viewport.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Viewport object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Viewport.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Viewport object.

Description

ObjectName String; Read-only


Viewport.OrthoOn Property

Toggle ortho on or off.

Syntax

object.OrthoOn

object is a Viewport object.

Description

OrthoOn Boolean; Read-write


Viewport.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Viewport object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Viewport.SnapBasePoint Property

Returns and sets the snap base point for the viewport.

Syntax

object.SnapBasePoint

object is a Viewport object.

Description

SnapBasePoint Variant; Read-write

Examples...

SnapBasePoint Property example


Viewport.SnapOn Property

Toggle snap on or off.

Syntax

object.SnapOn

object is a Viewport object.

Description

SnapOn Boolean; Read-write


Viewport.SnapRotationAngle Property

Returns and sets the snap rotation angle for the viewport.

Syntax

object.SnapRotationAngle

object is a Viewport object.

Description

SnapRotationAngle ZCAD_ANGLE: alias for Double; Read-write

Examples...

SnapRotationAngle Property example


Viewport.Target Property

Returns and sets the target point of the view.

Syntax

object.Target

object is a Viewport object.

Description

Target Variant; Read-write

Examples...

Target Property example


Viewport.UCSIconAtOrigin Property

Toggles the display of the user coordinates systems icon at the origin on or off.

Syntax

object.UCSIconAtOrigin

object is a Viewport object.

Description

UCSIconAtOrigin Boolean; Read-write


Viewport.UCSIconOn Property

Toggle the user coordinates systems icon on or off.

Syntax

object.UCSIconOn

object is a Viewport object.

Description

UCSIconOn Boolean; Read-write


Viewport.UpperRightCorner Property

Return Upper right corner. Readonly.

Syntax

object.UpperRightCorner

object is a Viewport object.

Description

UpperRightCorner Variant; Read-only

Examples...

UpperRightCorner Property example


Viewport.Width Property

Returns and sets the width of the view.

Syntax

object.Width

object is a Viewport object.

Description

Width Double; Read-write

Examples...

Width Property example


Viewport.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Viewport object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadViewports Object Members

Viewports Object Members

The collection of all viewports in the drawing.

VBA Class Name

ZcadViewports

Methods

Name | Description
Add | Adds a view to the views collection.
Delete | Deletes the object.
DeleteConfiguration | Deletes a viewport configuration by name.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


Viewports.Add Method

Adds a view to the views collection.

Syntax

object.Add(Name)

object is a Viewports object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

Viewport

Examples...

Add Method example


Viewports.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Viewports object.

Examples...

Delete Method example


Viewports.DeleteConfiguration Method

Deletes a viewport configuration by name.

Syntax

object.DeleteConfiguration(Name)

object is a Viewports object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -


Viewports.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Viewports object.

Examples...

Erase Method example


Viewports.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Viewports object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Viewports.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a Viewports object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

Viewport

Examples...

Item Method example


Viewports.Application Property

Returns the application object.

Syntax

object.Application

object is a Viewports object.

Description

Application Object; Read-only

Examples...

Application Property example


Viewports.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a Viewports object.

Description

Count Long; Read-only

Examples...

Count Property example


Viewports.Database Property

Returns the database object.

Syntax

object.Database

object is a Viewports object.

Description

Database Database; Read-only


Viewports.Document Property

Returns the document object.

Syntax

object.Document

object is a Viewports object.

Description

Document Object; Read-only


Viewports.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Viewports object.

Description

Handle String; Read-only


Viewports.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Viewports object.

Description

HasExtensionDictionary Boolean; Read-only


Viewports.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Viewports object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Viewports.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Viewports object.

Description

ObjectName String; Read-only


Viewports.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Viewports object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Viewports.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Viewports object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadViews Object Members

Views Object Members

The collection of all views in the drawing.

VBA Class Name

ZcadViews

Methods

Name | Description
Add | Adds a view to the views collection.
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Item | Given an Index, returns an item in the collection.

Properties

Name | Description
Application | Returns the application object.
Count | Returns number of items in collection.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.

Events

Name | Description
Modified | Happens when object is modified


Views.Add Method

Adds a view to the views collection.

Syntax

object.Add(Name)

object is a Views object.

Parameters

Name | Options | Data Type | Description
Name | Input-only | String | -

Return value

View

Examples...

Add Method example


Views.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Views object.

Examples...

Delete Method example


Views.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Views object.

Examples...

Erase Method example


Views.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Views object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Views.Item Method

Given an Index, returns an item in the collection.

Syntax

object.Item(Index)

object is a Views object.

Parameters

Name | Options | Data Type | Description
Index | Input-only | Variant | -

Return value

View

Examples...

Item Method example


Views.Application Property

Returns the application object.

Syntax

object.Application

object is a Views object.

Description

Application Object; Read-only

Examples...

Application Property example


Views.Count Property

Returns number of items in collection.

Syntax

object.Count

object is a Views object.

Description

Count Long; Read-only

Examples...

Count Property example


Views.Database Property

Returns the database object.

Syntax

object.Database

object is a Views object.

Description

Database Database; Read-only


Views.Document Property

Returns the document object.

Syntax

object.Document

object is a Views object.

Description

Document Object; Read-only


Views.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Views object.

Description

Handle String; Read-only


Views.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Views object.

Description

HasExtensionDictionary Boolean; Read-only


Views.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Views object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Views.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Views object.

Description

ObjectName String; Read-only


Views.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Views object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Views.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Views object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadXRecord Object Members

XRecord Object Members

XRecord objects are used to store and manage arbitrary data.

VBA Class Name

ZcadXRecord

Methods

Name | Description
Delete | Deletes the object.
Erase | Erases the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
GetXRecordData | Specifies the extended data for the object.
SetXRecordData | Specifies the extended data for the object.

Properties

Name | Description
Application | Returns the application object.
Database | Returns the database object.
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Name | Specifies the name of the xrecord.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
TranslateIDs | Specifies translation of any contained object ids.

Events

Name | Description
Modified | Happens when object is modified


XRecord.Delete Method

Deletes the object.

Syntax

object.Delete

object is a XRecord object.

Examples...

Delete Method example


XRecord.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a XRecord object.

Examples...

Erase Method example


XRecord.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a XRecord object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


XRecord.GetXRecordData Method

Specifies the extended data for the object.

Syntax

object.GetXRecordData(XRecordDataType, XRecordDataValue)

object is a XRecord object.

Parameters

Name | Options | Data Type | Description
XRecordDataType | Output-only | Variant | -
XRecordDataValue | Output-only | Variant | -

Examples...

GetXRecordData Method example


XRecord.SetXRecordData Method

Specifies the extended data for the object.

Syntax

object.SetXRecordData(XRecordDataType, XRecordDataValue)

object is a XRecord object.

Parameters

Name | Options | Data Type | Description
XRecordDataType | Input-only | Variant | -
XRecordDataValue | Input-only | Variant | -

Examples...

SetXRecordData Method example


XRecord.Application Property

Returns the application object.

Syntax

object.Application

object is a XRecord object.

Description

Application Object; Read-only

Examples...

Application Property example


XRecord.Database Property

Returns the database object.

Syntax

object.Database

object is a XRecord object.

Description

Database Database; Read-only


XRecord.Document Property

Returns the document object.

Syntax

object.Document

object is a XRecord object.

Description

Document Object; Read-only


XRecord.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a XRecord object.

Description

Handle String; Read-only


XRecord.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a XRecord object.

Description

HasExtensionDictionary Boolean; Read-only


XRecord.Name Property

Specifies the name of the xrecord.

Syntax

object.Name

object is a XRecord object.

Description

Name String; Read-write

Examples...

Name Property example


XRecord.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a XRecord object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


XRecord.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a XRecord object.

Description

ObjectName String; Read-only


XRecord.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a XRecord object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


XRecord.TranslateIDs Property

Specifies translation of any contained object ids.

Syntax

object.TranslateIDs

object is a XRecord object.

Description

TranslateIDs Boolean; Read-write

Examples...

TranslateIDs Property example


XRecord.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a XRecord object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadXline Object Members

Xline Object Members

A construction line that is infinite in both directions.

VBA Class Name

ZcadXline

Methods

Name | Description
ArrayPolar | Creates an array of selected objects in a polar pattern.
ArrayRectangular | Creates an array of selected objects in a rectangular pattern.
Copy | Copies the entity object.
Delete | Deletes the object.
Erase | Erases the entity object.
GetBoundingBox | Returns the min and max point of the bounding box of the entity object.
GetExtensionDictionary | Returns the extension dictionary for the object.
Highlight | Highlights the entity object.
IntersectWith | Intersects with the input entity object.
Mirror | Mirrors selected objects about a line.
Move | Moves the entity object from source to destination.
Offset | Creates a new entity object by offsetting the Xline by a specified distance
Rotate | Rotates the entity object about a point.
ScaleEntity | Scale the entity object with respect to the base point and the scale factor.
TransformBy | Performs the specified transformation on the entity object.
Update | Updates the graphics of the entity object.

Properties

Name | Description
Application | Returns the application object.
BasePoint | Specifies the X, Y, and Z coordinates for base point of the Xline
Database | Returns the database object.
DirectionVector | Specifies the X, Y, and Z coordinates for direction vector of the Xline
Document | Returns the document object.
Handle | Returns the handle of the object.
HasExtensionDictionary | Returns true if the object has an extension dictionary.
Hyperlinks | Specifies the hyperlink collection for the object.
Layer | Specifies the layer of the object.
Linetype | Specifies the linetype of the object.
LinetypeScale | Specifies the linetype scale of the object.
Lineweight | Specifies the lineweight for the object.
ObjectID | Returns the ObjectID of the object.
ObjectName | Returns the class name of the object.
OwnerID | Returns the OwnerID of the object.
PlotStyleName | Specifies the plotstyle name for the object.
SecondPoint | Specifies the X, Y, and Z coordinates for second point of the Xline
TrueColor | Returns the true color of the object.
Visible | Determines whether object visibility is on or off.

Events

Name | Description
Modified | Happens when object is modified


Xline.ArrayPolar Method

Creates an array of selected objects in a polar pattern.

Syntax

object.ArrayPolar(NumberOfObjects, AngleToFill, CenterPoint)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
NumberOfObjects | Input-only | Integer | -
AngleToFill | Input-only | Double | -
CenterPoint | Input-only | Variant | -

Return value

Variant

Examples...

ArrayPolar Method example


Xline.ArrayRectangular Method

Creates an array of selected objects in a rectangular pattern.

Syntax

object.ArrayRectangular(NumberOfRows, NumberOfColumns, NumberOfLevels, DistBetweenRows, DistBetweenCols, DistBetweenLevels)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
NumberOfRows | Input-only | Integer | -
NumberOfColumns | Input-only | Integer | -
NumberOfLevels | Input-only | Integer | -
DistBetweenRows | Input-only | Double | -
DistBetweenCols | Input-only | Double | -
DistBetweenLevels | Input-only | Double | -

Return value

Variant

Examples...

ArrayRectangular Method example


Xline.Copy Method

Copies the entity object.

Syntax

object.Copy

object is a Xline object.

Return value

Object

Examples...

Copy Method example


Xline.Delete Method

Deletes the object.

Syntax

object.Delete

object is a Xline object.

Examples...

Delete Method example


Xline.Erase Method

Erases the entity object.

Syntax

object.Erase

object is a Xline object.

Examples...

Erase Method example


Xline.GetBoundingBox Method

Returns the min and max point of the bounding box of the entity object.

Syntax

object.GetBoundingBox(MinPoint, MaxPoint)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
MinPoint | Output-only | Variant | -
MaxPoint | Output-only | Variant | -

Examples...

GetBoundingBox Method example


Xline.GetExtensionDictionary Method

Returns the extension dictionary for the object.

Syntax

object.GetExtensionDictionary

object is a Xline object.

Return value

Dictionary

Examples...

GetExtensionDictionary Method example


Xline.Highlight Method

Highlights the entity object.

Syntax

object.Highlight(HighlightFlag)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
HighlightFlag | Input-only | Boolean | -

Examples...

Highlight Method example


Xline.IntersectWith Method

Intersects with the input entity object.

Syntax

object.IntersectWith(IntersectObject, option)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
IntersectObject | Input-only | Object | -
option | Input-only | ZcExtendOption | Can be one of the constants listed here: zcExtendNone zcExtendThisEntity zcExtendOtherEntity zcExtendBoth

Return value

Variant


Xline.Mirror Method

Mirrors selected objects about a line.

Syntax

object.Mirror(Point1, Point2)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
Point1 | Input-only | Variant | -
Point2 | Input-only | Variant | -

Return value

Object

Examples...

Mirror Method example


Xline.Move Method

Moves the entity object from source to destination.

Syntax

object.Move(FromPoint, ToPoint)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
FromPoint | Input-only | Variant | -
ToPoint | Input-only | Variant | -

Examples...

Move Method example


Xline.Offset Method

Creates a new entity object by offsetting the Xline by a specified distance

Syntax

object.Offset(Distance)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
Distance | Input-only | Double | -

Return value

Variant


Xline.Rotate Method

Rotates the entity object about a point.

Syntax

object.Rotate(BasePoint, RotationAngle)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
RotationAngle | Input-only | Double | -

Examples...

Rotate Method example


Xline.ScaleEntity Method

Scale the entity object with respect to the base point and the scale factor.

Syntax

object.ScaleEntity(BasePoint, ScaleFactor)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
BasePoint | Input-only | Variant | -
ScaleFactor | Input-only | Double | -

Examples...

ScaleEntity Method example


Xline.TransformBy Method

Performs the specified transformation on the entity object.

Syntax

object.TransformBy(TransformationMatrix)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
TransformationMatrix | Input-only | Variant | -

Examples...

TransformBy Method example


Xline.Update Method

Updates the graphics of the entity object.

Syntax

object.Update

object is a Xline object.


Xline.Application Property

Returns the application object.

Syntax

object.Application

object is a Xline object.

Description

Application Object; Read-only

Examples...

Application Property example


Xline.BasePoint Property

Specifies the X, Y, and Z coordinates for base point of the Xline

Syntax

object.BasePoint

object is a Xline object.

Description

BasePoint Variant; Read-write

Examples...

BasePoint Property example


Xline.Database Property

Returns the database object.

Syntax

object.Database

object is a Xline object.

Description

Database Database; Read-only


Xline.DirectionVector Property

Specifies the X, Y, and Z coordinates for direction vector of the Xline

Syntax

object.DirectionVector

object is a Xline object.

Description

DirectionVector Variant; Read-write


Xline.Document Property

Returns the document object.

Syntax

object.Document

object is a Xline object.

Description

Document Object; Read-only


Xline.Handle Property

Returns the handle of the object.

Syntax

object.Handle

object is a Xline object.

Description

Handle String; Read-only


Xline.HasExtensionDictionary Property

Returns true if the object has an extension dictionary.

Syntax

object.HasExtensionDictionary

object is a Xline object.

Description

HasExtensionDictionary Boolean; Read-only


Xline.Hyperlinks Property

Specifies the hyperlink collection for the object.

Syntax

object.Hyperlinks

object is a Xline object.

Description

Hyperlinks Hyperlinks; Read-only


Xline.Layer Property

Specifies the layer of the object.

Syntax

object.Layer

object is a Xline object.

Description

Layer String; Read-write

Examples...

Layer Property example


Xline.Linetype Property

Specifies the linetype of the object.

Syntax

object.Linetype

object is a Xline object.

Description

Linetype String; Read-write

Examples...

Linetype Property example


Xline.LinetypeScale Property

Specifies the linetype scale of the object.

Syntax

object.LinetypeScale

object is a Xline object.

Description

LinetypeScale ZCAD_NOUNITS: alias for Double; Read-write

Examples...

LinetypeScale Property example


Xline.Lineweight Property

Specifies the lineweight for the object.

Syntax

object.Lineweight

object is a Xline object.

Description

Lineweight ZCAD_LWEIGHT: alias for ZcLineWeight enum; Read-write
Can be one of the constants listed here:
zcLnWt000
zcLnWt005
zcLnWt009
zcLnWt013
zcLnWt015
zcLnWt018
zcLnWt020
zcLnWt025
zcLnWt030
zcLnWt035
zcLnWt040
zcLnWt050
zcLnWt053
zcLnWt060
zcLnWt070
zcLnWt080
zcLnWt090
zcLnWt100
zcLnWt106
zcLnWt120
zcLnWt140
zcLnWt158
zcLnWt200
zcLnWt211
zcLnWtByLayer
zcLnWtByBlock
zcLnWtByLwDefault

Examples...

Lineweight Property example


Xline.ObjectID Property

Returns the ObjectID of the object.

Syntax

object.ObjectID

object is a Xline object.

Description

ObjectID LONG_PTR: alias for Long; Read-only

Examples...

ObjectID Property example


Xline.ObjectName Property

Returns the class name of the object.

Syntax

object.ObjectName

object is a Xline object.

Description

ObjectName String; Read-only


Xline.OwnerID Property

Returns the OwnerID of the object.

Syntax

object.OwnerID

object is a Xline object.

Description

OwnerID LONG_PTR: alias for Long; Read-only


Xline.PlotStyleName Property

Specifies the plotstyle name for the object.

Syntax

object.PlotStyleName

object is a Xline object.

Description

PlotStyleName String; Read-write


Xline.SecondPoint Property

Specifies the X, Y, and Z coordinates for second point of the Xline

Syntax

object.SecondPoint

object is a Xline object.

Description

SecondPoint Variant; Read-write

Examples...

SecondPoint Property example


Xline.TrueColor Property

Returns the true color of the object.

Syntax

object.TrueColor

object is a Xline object.

Description

TrueColor ZcCmColor; Read-write

Examples...

TrueColor Property example


Xline.Visible Property

Determines whether object visibility is on or off.

Syntax

object.Visible

object is a Xline object.

Description

Visible Boolean; Read-write

Examples...

Visible Property example


Xline.Modified Event

Happens when object is modified

Syntax

object.Modified(pObject)

object is a Xline object.

Parameters

Name | Options | Data Type | Description
pObject | Input-only | Object | -


ZcadZcCmColor Object Members

ZcCmColor Object Members

ZWCAD true color object.

VBA Class Name

ZcadZcCmColor

Methods

Name | Description
Delete | Deletes the true color.
SetColorBookColor | Sets the color to a color from a color book.
SetNames | Specifies the color name and book name of the color.
SetRGB | Specifies the RGB values of the true color.

Properties

Name | Description
Blue | Specifies the blue component of the true color.
BookName | Specifies the book name (if any) of the color.
ColorIndex | Specifies the color index.
ColorMethod | Specifies the color method.
ColorName | Specifies the name (if any) of the color.
EntityColor | Specifies the ZwCmEntityColor of the true color.
Green | Specifies the green component of the true color.
Red | Specifies the red component of the true color.

Events

Name | Description
None | -


ZcCmColor.Delete Method

Deletes the true color.

Syntax

object.Delete

object is a ZcCmColor object.

Examples...

Delete Method example


ZcCmColor.SetColorBookColor Method

Sets the color to a color from a color book.

Syntax

object.SetColorBookColor(BookName, ColorName)

object is a ZcCmColor object.

Parameters

Name | Options | Data Type | Description
BookName | Input-only | String | -
ColorName | Input-only | String | -

Examples...

SetColorBookColor Method example


ZcCmColor.SetNames Method

Specifies the color name and book name of the color.

Syntax

object.SetNames(ColorName, BookName)

object is a ZcCmColor object.

Parameters

Name | Options | Data Type | Description
ColorName | Input-only | String | -
BookName | Input-only | String | -

Examples...

SetNames Method example


ZcCmColor.SetRGB Method

Specifies the RGB values of the true color.

Syntax

object.SetRGB(Red, Green, Blue)

object is a ZcCmColor object.

Parameters

Name | Options | Data Type | Description
Red | Input-only | Long | -
Green | Input-only | Long | -
Blue | Input-only | Long | -

Examples...

SetRGB Method example


ZcCmColor.Blue Property

Specifies the blue component of the true color.

Syntax

object.Blue

object is a ZcCmColor object.

Description

Blue Long; Read-only

Examples...

Blue Property example


ZcCmColor.BookName Property

Specifies the book name (if any) of the color.

Syntax

object.BookName

object is a ZcCmColor object.

Description

BookName String; Read-only

Examples...

BookName Property example


ZcCmColor.ColorIndex Property

Specifies the color index.

Syntax

object.ColorIndex

object is a ZcCmColor object.

Description

ColorIndex ZcColor: Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer

Examples...

ColorIndex Property example


ZcCmColor.ColorMethod Property

Specifies the color method.

Syntax

object.ColorMethod

object is a ZcCmColor object.

Description

ColorMethod ZcColorMethod: Read-write
Can be one of the constants listed here:
zcColorMethodByLayer
zcColorMethodByBlock
zcColorMethodByRGB
zcColorMethodByACI
zcColorMethodForeground


ZcCmColor.ColorName Property

Specifies the name (if any) of the color.

Syntax

object.ColorName

object is a ZcCmColor object.

Description

ColorName String; Read-only

Examples...

ColorName Property example


ZcCmColor.EntityColor Property

Specifies the ZwCmEntityColor of the true color.

Syntax

object.EntityColor

object is a ZcCmColor object.

Description

EntityColor Long; Read-write


ZcCmColor.Green Property

Specifies the green component of the true color.

Syntax

object.Green

object is a ZcCmColor object.

Description

Green Long; Read-only


ZcCmColor.Red Property

Specifies the red component of the true color.

Syntax

object.Red

object is a ZcCmColor object.

Description

Red Long; Read-only

Examples...

Red Property example


BeginSave Event Example
Private Sub ZcadDocument_BeginSave(ByVal FileName As String)
    ' This example intercepts a drawing BeginSave event.

    ' This event is triggered immediately after ZWCAD receives a command to save a drawing.

    ' Use the "FileName" variable to determine where the drawing file to be saved.

    MsgBox "A drawing is about to be saved to: " & FileName

End Sub


BeginClose Event Example
Private Sub ZcadDocument_BeginClose()

    ' This example intercepts a drawing BeginClose event.
    '
    ' This event is triggered when a drawing receives a request to close.
    '
    ' To trigger this example event: close an open drawing.

    MsgBox "A drawing has just been closed!"

End Sub


BeginCommand Event Example
Private Sub ZcadDocument_BeginCommand(ByVal CommandName As String)
    ' This example intercepts a drawing BeginCommand event.

    ' This event is triggered immediately after the command is issued, but before it completes.

    ' Use the "CommandName" variable to determine which command was started.
    MsgBox "A drawing has just been issued a " & CommandName & " command."

End Sub


BeginDoubleClick Event Example
Private Sub ZcadDocument_BeginDoubleClick(ByVal PickPoint As Variant)
    ' This example intercepts a drawing BeginDoubleClick event.

    ' This event is triggered after the user double-clicks the object in a drawing.

    ' Use the "PickPoint" variable to determine where on the drawing the user double-clicked.

    MsgBox "A drawing has just been double-clicked at:" & vbCrLf & _
            PickPoint(0) & vbCrLf & _
            PickPoint(1) & vbCrLf & _
            PickPoint(2)

End Sub


BeginLisp Event Example
Private Sub ZcadDocument_BeginLisp(ByVal FirstLine As String)

    ' This example intercepts a drawing BeginLisp event.
    '
    ' This event is triggered when a drawing receives
    ' a request to evaluate a LISP expression.
    '
    ' To trigger this example event: Start the evaluation of a LISP expression

    ' Use the "FirstLine" variable to determine which LISP expression is running
    MsgBox "A LISP expression has just started to be evaluated.  The first line of the expression is: " & FirstLine

End Sub


BeginRightClick Event Example
Private Sub ZcadDocument_BeginRightClick(ByVal PickPoint As Variant)
    ' This example intercepts a drawing BeginRightClick event.

    ' This event is triggered after the user right-clicks the object in a drawing.

    ' Use the "PickPoint" variable to determine where on the drawing the user right-clicked.

    MsgBox "A drawing has just been right-clicked at:" & vbCrLf & _
            PickPoint(0) & vbCrLf & _
            PickPoint(1) & vbCrLf & _
            PickPoint(2)

End Sub


LayoutSwitched Event Example
Private Sub ZcadDocument_LayoutSwitched(ByVal LayoutName As String)
    ' This example intercepts a drawing LayoutSwitched event.
    '
    ' This event is triggered when the user switches to a different drawing layout view.
    '
    ' To trigger this example event: Open a drawing and change its layout view
    '
    ' For example: Switch the drawing from Model view to Layout1 view

    ' Use the "LayoutName" variable to determine the which layout view you changed to

    MsgBox "You just have changed the drawing layout to: " & LayoutName

End Sub


SelectionChanged Event Example
Private Sub ZwcadDocument_SelectionChanged()
    ' This example intercepts a drawing SelectionChanged event.

    ' This event is triggered when the current pick first selection set has changed.

    MsgBox "The selection set in a drawing was just changed!"

End Sub


Activate Method Example
Sub Example_Activate()
    ' This example creates three new documents and activates each document in turn.
    Dim docu1 As ZcadDocument
    Dim docu2 As ZcadDocument
    Dim docu3 As ZcadDocument

    Set docu1 = ThisDrawing.Application.Documents.Add
    Set docu2 = ThisDrawing.Application.Documents.Add
    Set docu3 = ThisDrawing.Application.Documents.Add
    Dim document As ZcadDocument

    For Each document In ThisDrawing.Application.Documents
        document.Activate
        MsgBox "document " & document.Name & " is active."
    Next document

End Sub


Add Method Example
Sub Example_Add()
    ' This example adds a block, dictionary, dimension style,
    ' group, layer, registered application, selection set,
    ' textstyle, view, viewport ,UCS and Document using the Add method.

    GoSub Block
    GoSub Dictionary
    GoSub Dimensionstyle
    GoSub Group
    GoSub Layer
    GoSub RegisterApp
    GoSub SelectionSet
    GoSub TextStyle
    GoSub View
    GoSub Viewport
    GoSub UCS
    GoSub Docu
    Exit Sub

Block:

    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 5#: insertionPnt(1) = 6#: insertionPnt(2) = 0#

    ' Add the block to the blocks collection
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "New_Block")
    MsgBox blockObj.Name & " has been added."
    Return

Dictionary:
    ' Create a new dictionary called "New_Dictionary"
    Dim dictObj As ZcadDictionary
    Set dictObj = ThisDrawing.Dictionaries.Add("New_Dictionary")
    MsgBox dictObj.Name & " has been added.", , "Add Example"
    Return

Dimensionstyle:
    ' Create a new dimension style called "New_Dimstyle" in current drawing
    Dim DimStyleObj As ZcadDimStyle
    Set DimStyleObj = ThisDrawing.DimStyles.Add("New_Dimstyle")
    MsgBox DimStyleObj.Name & " has been added.", , "Add Example"
    Return

Group:
    ' Create a new group called "New_Group" in current drawing
    Dim groupObj As ZcadGroup
    Set groupObj = ThisDrawing.Groups.Add("New_Group")
    MsgBox groupObj.Name & " has been added.", , "Add Example"
    Return

Layer:
    ' This example creates a new layer called "New_Layer"
    Dim layerObj As ZcadLayer
    Set layerObj = ThisDrawing.Layers.Add("New_Layer")
    ThisDrawing.ActiveLayer = layerObj
    MsgBox layerObj.Name & " has been added." & vbCrLf & _
            "LayerOn Status: " & layerObj.LayerOn & vbCrLf & _
            "Freeze Status: " & layerObj.Freeze & vbCrLf & _
            "Lock Status: " & layerObj.Lock & vbCrLf & _
            "Color: " & layerObj.color, , "Add Example"
    Return

RegisterApp:
    ' Create a registered application named "New_RegApp" in current drawing
    Dim RegAppObj As ZcadRegisteredApplication
    Set RegAppObj = ThisDrawing.RegisteredApplications.Add("New_RegApp")
    MsgBox RegAppObj.Name & " has been added.", , "Add Example"
    Return

SelectionSet:
    ' Create a selectionset named "New_SelectionSet" in current drawing
    Dim ssetObj As ZcadSelectionSet
    Set ssetObj = ThisDrawing.SelectionSets.Add("New_SelectionSet")
    MsgBox ssetObj.Name & " has been added." & vbCrLf & _
           "The number of items in the selection set is " & ssetObj.Count _
           , , "Add Example"
    Return

TextStyle:
    ' Create a textstyle named "New_Textstyle" in current drawing
    Dim txtStyleObj As ZcadTextStyle
    Set txtStyleObj = ThisDrawing.TextStyles.Add("New_Textstyle")
    MsgBox txtStyleObj.Name & " has been added." & vbCrLf & _
           "Height: " & txtStyleObj.Height & vbCrLf & _
           "Width: " & txtStyleObj.Width, , "Add Example"
    Return

View:
    ' Create a view named "New_View" in current drawing
    Dim viewObj As ZcadView
    Set viewObj = ThisDrawing.Views.Add("New_View")
    MsgBox viewObj.Name & " has been added." & vbCrLf & _
           "Height: " & viewObj.Height & vbCrLf & _
           "Width: " & viewObj.Width, , "Add Example"
    Return

Viewport:
    ' Create a viewport named "New_Viewport" in current drawing
    Dim vportObj As ZcadViewport
    Set vportObj = ThisDrawing.Viewports.Add("New_Viewport")
    MsgBox vportObj.Name & " has been added." & vbCrLf & _
           "GridOn Status: " & vportObj.GridOn & vbCrLf & _
           "OrthoOn Status: " & vportObj.OrthoOn & vbCrLf & _
           "SnapOn Status: " & vportObj.SnapOn, , "Add Example"
    Return

UCS:
    ' Create a UCS named "New_UCS" in current drawing
    Dim ucsObj As ZcadUCS
    Dim origin(0 To 2) As Double
    Dim xAxisPnt(0 To 2) As Double
    Dim yAxisPnt(0 To 2) As Double

    ' Define the UCS
    origin(0) = 10#: origin(1) = 10#: origin(2) = 1#
    xAxisPnt(0) = 15#: xAxisPnt(1) = 10#: xAxisPnt(2) = 1#
    yAxisPnt(0) = 10#: yAxisPnt(1) = 20#: yAxisPnt(2) = 1#
    Set ucsObj = ThisDrawing.UserCoordinateSystems.Add(origin, xAxisPnt, yAxisPnt, "New_UCS")
    MsgBox ucsObj.Name & " has been added." & vbCrLf & _
            "Origin: " & ucsObj.origin(0) & ", " & ucsObj.origin(1) _
            & ", " & ucsObj.origin(2), , "Add Example"
    Return

Docu:
    Dim Doc As ZcadDocument
    Set Doc = ThisDrawing.Application.Documents.Add("")
    MsgBox Doc.Name & " has been added.", , "Add Example"

    Return

End Sub


Add3DFace Method Example
Sub Example_Add3DFace()
    ' This example creates a 3D face in model space.

    Dim faceObj As Zcad3DFace
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim point3(0 To 2) As Double
    Dim point4(0 To 2) As Double

    ' Define the four coordinates of the face
    point1(0) = 1#: point1(1) = 1#: point1(2) = 0#
    point2(0) = 5#: point2(1) = 0#: point2(2) = 10#
    point3(0) = 3#: point3(1) = 20#: point3(2) = 0#
    point4(0) = 6#: point4(1) = 6#: point4(2) = 20#

    ' Create the 3DFace object in model space
    Set faceObj = ThisDrawing.ModelSpace.Add3DFace(point1, point2, point3, point4)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents

End Sub


Add3DMesh Method Example
Sub Example_Add3DMesh()
    ' This example creates a 4 X 4 polygonmesh in model space.

    Dim meshObj As ZcadPolygonMesh
    Dim mSize, nSize, count As Integer
    Dim Points(0 To 47) As Double

    ' Create the matrix of points
    Points(0) = 1: Points(1) = 0: Points(2) = 0
    Points(3) = 3: Points(4) = 0: Points(5) = 1
    Points(6) = 4: Points(7) = 0: Points(8) = 0
    Points(9) = 6: Points(10) = 0: Points(11) = 1
    Points(12) = 1: Points(13) = 4: Points(14) = 0
    Points(15) = 3: Points(16) = 2: Points(17) = 1
    Points(18) = 4: Points(19) = 2: Points(20) = 0
    Points(21) = 6: Points(22) = 2: Points(23) = 1
    Points(24) = 1: Points(25) = 6: Points(26) = 0
    Points(27) = 3: Points(28) = 4: Points(29) = 1
    Points(30) = 4: Points(31) = 4: Points(32) = 0
    Points(33) = 6: Points(34) = 4: Points(35) = 0
    Points(36) = 1: Points(37) = 8: Points(38) = 0
    Points(39) = 3: Points(40) = 6: Points(41) = 1
    Points(42) = 4: Points(43) = 6: Points(44) = 0
    Points(45) = 6: Points(46) = 6: Points(47) = 0

    mSize = 4: nSize = 4

    ' Creates a 3Dmesh in model space
    Set meshObj = ThisDrawing.ModelSpace.Add3DMesh(mSize, nSize, Points)

    ' Change the viewing direction of the viewport to better see the polygonmesh
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents

End Sub


Add3DPoly Method Example
Sub Example_Add3DPoly()

    ' Create a 3DPolyline in model space
    Dim polyObj As Zcad3DPolyline
    Dim Points(0 To 8) As Double
    Points(0) = 1: Points(1) = 1: Points(2) = 0
    Points(3) = 13: Points(4) = 25: Points(5) = 10
    Points(6) = 23: Points(7) = 40: Points(8) = 30
    Set polyObj = ThisDrawing.ModelSpace.Add3DPoly(Points)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddArc Method Example
Sub Example_AddArc()
    ' This example creates an arc in model space.

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    ' Define the Arc
    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 30 * 3.1415926 / 180#
    endAngle = 270 * 3.1415926 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddAttribute Method Example
Sub Example_AddAttribute()
    ' This example creates an attribute definition in model space.

    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String

    ' Define the attribute definition
    height = 10#
    mode = zcAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 100#: insertionPoint(1) = 100#: insertionPoint(2) = 0
    tag = "New Tag"
    value = "New Value"

    ' Create the attribute definition object in model space
    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddBox Method Example
Sub Example_AddBox()
    ' This example creates a box in model space.

    Dim boxObj As Zcad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double

    ' Define the box
    center(0) = 4#: center(1) = 4#: center(2) = 0
    length = 10#: width = 5: height = 20#

    ' Create the box object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)

    ' Change the viewing direction of the viewport to better see the box
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


AddCircle Method Example
Sub Example_AddCircle()
    ' This example creates a circle in model space.

    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double

    ' Define the circle
    centerPoint(0) = 10#: centerPoint(1) = 10#: centerPoint(2) = 0#
    radius = 10#

    ' Create the Circle object in model space
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddCone Method Example
Sub Example_AddCone()
    ' This example creates a cone in model space.

    Dim coneObj As Zcad3DSolid
    Dim radius As Double
    Dim center(0 To 2) As Double
    Dim height As Double

    ' Define the cone
    center(0) = 10#: center(1) = 10#: center(2) = 0#
    radius = 10#
    height = 30#

    ' Create the Cone (3DSolid) object in model space
    Set coneObj = ThisDrawing.ModelSpace.AddCone(center, radius, height)

    ' Change the viewing direction of the viewport to better see the cone
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


AddCustomInfo Method Example
Sub Example_AddCustomInfo()

    Dim Key As String
    Dim Value As String
    Dim Key1 As String
    Dim Value1 As String
    Dim CustomProperty As String
    Dim PropertyValue As String
    Dim CustomProperty1 As String
    Dim PropertyValue1 As String

    CustomProperty = "ZWCAD"
    PropertyValue = "Test"
    CustomProperty1 = "ZW"
    PropertyValue1 = "Test1"

    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty, PropertyValue
    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty1, PropertyValue1
    ThisDrawing.SummaryInfo.GetCustomByIndex 0, Key, Value
    Key1 = CustomProperty1
    ThisDrawing.SummaryInfo.GetCustomByKey Key1, Value1
    MsgBox "The custom drawing properties are " & vbCrLf & _
            "First property name = " & Key & vbCrLf & _
            "First property value = " & Value & vbCrLf & _
            "Second property name = " & Key1 & vbCrLf & _
            "Second property value = " & Value1 & vbCrLf

End Sub


AddCylinder Method Example
Sub Example_AddCylinder()
    ' This example creates a cylinder in model space.

    Dim cylinderObj As Zcad3DSolid
    Dim radius As Double
    Dim center(0 To 2) As Double
    Dim height As Double

    ' Define the cylinder
    center(0) = 2#: center(1) = 3#: center(2) = 0#
    radius = 10#
    height = 30#

    ' Create the Cylinder (3DSolid) object in model space
    Set cylinderObj = ThisDrawing.ModelSpace.AddCylinder(center, radius, height)

    ' Change the viewing direction of the viewport to better see the cylinder
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


AddDim3PointAngular Method Example
Sub Example_AddDim3PointAngular()

     ' Create the new Dim3PointAngular object in model space
    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    AngleVertex(0) = 1: AngleVertex(1) = 1: AngleVertex(2) = 0
    FirstPoint(0) = 3: FirstPoint(1) = 3: FirstPoint(2) = 0
    SecondPoint(0) = 15: SecondPoint(1) = 24: SecondPoint(2) = 0
    TextPoint(0) = 25: TextPoint(1) = 25: TextPoint(2) = 0

    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddDimAligned Method Example
Sub Example_AddDimAligned()
    ' This example creates an aligned dimension in model space.

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 20#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddDimAngular Method Example
Sub Example_AddDimAngular()
    ' This example creates an angular dimension in model space.

    Dim dimObj As ZcadDimAngular
    Dim angVert(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double
    Dim SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the dimension
    angVert(0) = 0#: angVert(1) = 0#: angVert(2) = 0#
    FirstPoint(0) = 11#: FirstPoint(1) = 7#: FirstPoint(2) = 0#
    SecondPoint(0) = 20#: SecondPoint(1) = 23#: SecondPoint(2) = 0#
    TextPoint(0) = 25#: TextPoint(1) = 25#: TextPoint(2) = 0#

    ' Create the angular dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAngular(angVert, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddDimDiametric Method Example
Sub Example_AddDimDiametric()
    ' This example creates a diametric dimension in model space.

    Dim dimObj As ZcadDimDiametric
    Dim chordPoint(0 To 2) As Double
    Dim farChordPoint(0 To 2) As Double
    Dim leaderLength As Double

    ' Define the dimension
    chordPoint(0) = 5#: chordPoint(1) = 5#: chordPoint(2) = 0#
    farChordPoint(0) = 15#: farChordPoint(1) = 15#: farChordPoint(2) = 0#
    leaderLength = 5#

    ' Create the diametric dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimDiametric(chordPoint, farChordPoint, leaderLength)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddDimOrdinate Method Example
Sub Example_AddDimOrdinate()
    ' This example creates an ordinate dimension in model space.

    Dim dimObj As ZcadDimOrdinate
    Dim definingPoint(0 To 2) As Double
    Dim leaderEndPoint(0 To 2) As Double
    Dim useXAxis As Boolean

    ' Define the dimension
    definingPoint(0) = 2: definingPoint(1) = 6#: definingPoint(2) = 0#
    leaderEndPoint(0) = 20#: leaderEndPoint(1) = 20#: leaderEndPoint(2) = 0#
    useXAxis = False

    ' Create an ordinate dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimOrdinate(definingPoint, leaderEndPoint, useXAxis)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddDimRadial Method Example
Sub Example_AddDimRadial()
    ' This example creates a radial dimension in model space.

    Dim dimObj As ZcadDimRadial
    Dim center(0 To 2) As Double
    Dim chordPoint(0 To 2) As Double
    Dim leaderLen As Integer

    ' Define the dimension
    center(0) = 0#: center(1) = 0#: center(2) = 0#
    chordPoint(0) = 5#: chordPoint(1) = 5#: chordPoint(2) = 0#
    leaderLen = 10

    ' Create the radial dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimRadial(center, chordPoint, leaderLen)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddDimRotated Method Example
Sub Example_AddDimRotated()
    ' This example creates a rotated dimension in model space.

    Dim dimObj As ZcadDimRotated
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    Dim rotAngle As Double

    point1(0) = 1#: point1(1) = 3#: point1(2) = 0#
    point2(0) = 10#: point2(1) = 12#: point2(2) = 0#
    location(0) = 0#: location(1) = 0#: location(2) = 0#
    rotAngle = 45
    rotAngle = rotAngle * 3.141592 / 180#

    Set dimObj = ThisDrawing.ModelSpace.AddDimRotated(point1, point2, location, rotAngle)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddEllipse Method Example
Sub Example_AddEllipse()
    ' This example creates an ellipse in model space.

    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double
    center(0) = 10#: center(1) = 10#: center(2) = 0#
    majAxis(0) = 15: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.75

    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddEllipticalCone Method Example
Sub Example_AddEllipticalCone()
    ' This example creates an elliptical cone in model space.

    Dim coneObj As Zcad3DSolid
    Dim center(0 To 2) As Double
    Dim majorRadius As Double
    Dim minorRadius As Double
    Dim height As Double

    ' Define the elliptical cone
    center(0) = 2#: center(1) = 2#: center(2) = 0#
    majorRadius = 15#
    minorRadius = 10#
    height = 30#

    ' Create the elliptical cone in model space
    Set coneObj = ThisDrawing.ModelSpace.AddEllipticalCone(center, majorRadius, minorRadius, height)

    ' Change the viewing direction of the viewport to better see the cone
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


AddEllipticalCylinder Method Example
Sub Example_AddEllipticalCylinder()
    ' This example creates an elliptical cylinder in model space.

    Dim cylinderObj As Zcad3DSolid
    Dim center(0 To 2) As Double
    Dim majorRadius As Double
    Dim minorRadius As Double
    Dim height As Double

    ' Define the elliptical cylinder
    center(0) = 1#: center(1) = 1#: center(2) = 0#
    majorRadius = 6#
    minorRadius = 1.5
    height = 30#

    ' Create the elliptical cylinder in model space
    Set cylinderObj = ThisDrawing.ModelSpace.AddEllipticalCylinder(center, majorRadius, minorRadius, height)

    ' Change the viewing direction of the viewport to better see the cylinder
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


AddExtrudedSolid Method Example
Sub Example_AddExtrudedSolid()
    ' This example extrudes a solid from a region.
    ' The region is created from an arc and a line.

    Dim curves(0 To 1) As ZcadEntity
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double
    centerPoint(0) = 1#: centerPoint(1) = 1#: centerPoint(2) = 0#
    radius = 6#
    startAngle = 0
    endAngle = 3.141592
    Set curves(0) = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    Dim arcObj As ZcadArc
    Set arcObj = curves(0)
    ' Define the line
    Set curves(1) = ThisDrawing.ModelSpace.AddLine(arcObj.StartPoint, arcObj.EndPoint)

    ' Create the region
    Dim regionObj As Variant
    regionObj = ThisDrawing.ModelSpace.AddRegion(curves)

    ' Define the extrusion
    Dim height As Double
    Dim taperAngle As Double
    height = 10
    taperAngle = 30 / 180 * 3.1415926

    ' Create the solid
    Dim solidObj As Zcad3DSolid
    Set solidObj = ThisDrawing.ModelSpace.AddExtrudedSolid(regionObj(0), height, taperAngle)

    ' Change the viewing direction of the viewport
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


AddExtrudedSolidAlongPath Method Example
Sub Example_AddExtrudedSolidAlongPath()
    ' This example extrudes a solid from a region
    ' along a path defined by a line
    ' The region is created from a circle

    Dim curves(0 To 0) As ZcadEntity

    ' Define the circle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double

    centerPoint(0) = 1#: centerPoint(1) = 1#: centerPoint(2) = 0#
    radius = 10#
    Set curves(0) = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)

    ' Create the region
    Dim regionObj As Variant
    regionObj = ThisDrawing.ModelSpace.AddRegion(curves)

    ' Define the extrusion path

    Dim startpnt(0 To 2) As Double
    Dim endpnt(0 To 2) As Double

    startpnt(0) = 10: startpnt(1) = 10: startpnt(2) = 5
    endpnt(0) = 10: endpnt(1) = 10: endpnt(2) = 0

    Dim lineObj As ZcadLine
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startpnt, endpnt)
    Dim solidObj As Zcad3DSolid
    Set solidObj = ThisDrawing.ModelSpace.AddExtrudedSolidAlongPath(regionObj(0), lineObj)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddHatch Method Example
Sub Example_AddHatch()

    Dim hatchobj As ZcadHatch
    Dim patternname As String
    Dim patterntype As Long
    Dim bassociativity As Boolean

    ' Define the hatch
    patternname = "ANSI31"
    patterntype = zcHatchPatternTypePreDefined
    bassociativity = True

    ' Create the associative hatch object
    Set hatchobj = ThisDrawing.ModelSpace.AddHatch(patterntype, patternname, bassociativity)

    ' Create the lightweightPolyline as the outer loop for the hatch
    Dim outerloop As ZcadLWPolyline
    Dim object(0 To 0) As ZcadEntity
    Dim points(0 To 7) As Double

    points(0) = 10: points(1) = 10
    points(2) = 20: points(3) = 10
    points(4) = 20: points(5) = 20
    points(6) = 10: points(7) = 20

    Set outerloop = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)
    outerloop.Closed = True
    outerloop.Update
    Set object(0) = outerloop

    ' Append the outer loop to the hatch
    hatchobj.AppendOuterLoop (object)

    ' Set the scale of the hatch pattern
    hatchobj.PatternScale = 0.5
    hatchobj.Update
    hatchobj.Evaluate
    ThisDrawing.Regen zcActiveViewport

End Sub


AddItems Method Example
Sub Example_AddItems()

    ' Create the new selection set
    Dim ssetObj As ZcadSelectionSet
    Set ssetObj = ThisDrawing.SelectionSets.Add("TEST")

    ' Create a line object in model space
    Dim lineObj As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
    startPoint(0) = 100: startPoint(1) = 18: startPoint(2) = 0
    endPoint(0) = 200: endPoint(1) = 120: endPoint(2) = 0
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)

    ' Create a circle object in model space
    Dim circObj As ZcadCircle
    Dim centerPt(0 To 2) As Double
    Dim radius As Double
    centerPt(0) = 20: centerPt(1) = 30: centerPt(2) = 0
    radius = 100
    Set circObj = ThisDrawing.ModelSpace.AddCircle(centerPt, radius)

    ' Create an ellipse object in model space
    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.75
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)

    ReDim ssobjs(0 To ThisDrawing.ModelSpace.count - 1) As ZcadEntity
    Dim I As Integer
    For I = 0 To ThisDrawing.ModelSpace.count - 1
        Set ssobjs(I) = ThisDrawing.ModelSpace.Item(I)
    Next

    ' Add the array of objects to the selection set
    ssetObj.AddItems ssobjs
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll
    MsgBox ssetObj.count

End Sub


AddLeader Method Example
Sub Example_AddLeader()
    ' This example creates a leader in model space.

    Dim leaderObj As ZcadLeader
    Dim Points(0 To 5) As Double
    Dim leaderType As Integer
    Dim annotation As ZcadEntity
    Points(0) = 1: Points(1) = 1
    Points(2) = 10: Points(3) = 10
    Points(4) = 15: Points(5) = 20

    leaderType = zcLineWithArrow
    Set annotation = Nothing

    ' Create the leader object in model space
    Set leaderObj = ThisDrawing.ModelSpace.AddLeader(Points, annotation, leaderType)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddLightWeightPolyline Method Example
Sub Example_AddLightWeightPolyline()
    ' This example creates a lightweight polyline in model space.

    Dim plineObj As ZcadLWPolyline
    Dim Points(0 To 9) As Double

    Points(0) = 2: Points(1) = 3
    Points(2) = 8: Points(3) = 20
    Points(4) = 10: Points(5) = 25
    Points(6) = 20: Points(7) = 27
    Points(8) = 30: Points(9) = 40

    ' Create a lightweight Polyline object in model space
    Set plineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(Points)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddLine Method Example
Sub Example_AddLine()
    ' This example adds a line in model space

    Dim lineObj As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    ' Define the start and end points for the line
    startPoint(0) = 2#: startPoint(1) = 9#: startPoint(2) = 0#
    endPoint(0) = 50#: endPoint(1) = 60#: endPoint(2) = 0#

    ' Create the line in model space
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    ThisDrawing.Application.ZoomAll

End Sub


AddMenuItem Method Example
Sub Example_AddMenuItem()
    ' This example creates a new menu called TestMenu and inserts a menu item into it.
    ' Then it displayed on the menu bar.

    Dim currMenuGroup As ZcadMenuGroup
    Dim newMenu As ZcadPopupMenu, newMenuItem As ZcadPopupMenuItem
    Dim openMacro As String

    On Error GoTo ERRORTRAP

    ' Use MenuGroups property to obtain reference to main ZWCAD menu
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new menu in this group
    Set newMenu = currMenuGroup.Menus.Add("TestMenu")

    ' Add a menu item to the new menu and
    ' assign an Open macro (VBA equivalent of: " _open ")
    openMacro = Chr(95) & "open" & Chr(32)

    Set newMenuItem = newMenu.AddMenuItem(newMenu.Count + 1, "Open", openMacro)

    ' Display the menu on the menu bar
    newMenu.InsertInMenuBar (ThisDrawing.Application.MenuBar.Count + 1)

    MsgBox "A new menu has been added to the ZWCAD menu system!"

    Exit Sub

ERRORTRAP:
    MsgBox "The following error has occurred: " & Err.Description
End Sub


AddMline Method Example
Sub Example_AddMLine()
   ' This example adds an Mline in model space

    Dim mLineObj As ZcadMLine
    Dim vertexList(0 To 5) As Double
    vertexList(0) = 4: vertexList(1) = 7
    vertexList(2) = 30: vertexList(3) = 60
    vertexList(4) = 50: vertexList(5) = 90

    ' Create the line in model space
    Set mLineObj = ThisDrawing.ModelSpace.AddMLine(vertexList)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddMText Method Example
Sub Example_AddMtext()
    ' This example creates an MText object in model space.

    Dim MTextObj As ZcadMText
    Dim corner(0 To 2) As Double
    Dim width As Double
    Dim text As String
    corner(0) = 10#: corner(1) = 10#: corner(2) = 0#
    width = 50
    text = "This is the test String"

    ' Creates the mtext Object
    Set MTextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddObject Method Example

Sub Example_AddObject()
    ' This example creates a dictionary and adds
    ' a custom object to that dictionary.

    Dim dictObj As ZcadDictionary
    Set dictObj = ThisDrawing.Dictionaries.Add("TEST")

    Dim keyName As String
    Dim className As String
    Dim customObj As Object

    keyName = "keyword"
    className = "CMyZrxObject"
    Set customObj = dictObj.AddObject(keyName, className)

End Sub


AddPoint Method Example
Sub Example_AddPointEntity()

    Dim pointObj As ZcadPoint
    Dim location(0 To 2) As Double
    Dim temp As Integer
    location(0) = 100#: location(1) = 200#: location(2) = 0#

    Set pointObj = ThisDrawing.ModelSpace.AddPoint(location)
    temp = ThisDrawing.GetVariable("PDMODE")
    ThisDrawing.SetVariable "PDMODE", 35
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.SetVariable "PDMODE", temp
    ThisDrawing.Regen zcActiveViewport

End Sub


AddPolyfaceMesh Method Example

Sub Example_AddPolyfaceMesh()

    Dim vertexList(0 To 17) As Double
    vertexList(0) = 4: vertexList(1) = 7: vertexList(2) = 0
    vertexList(3) = 5: vertexList(4) = 7: vertexList(5) = 0
    vertexList(6) = 6: vertexList(7) = 7: vertexList(8) = 1
    vertexList(9) = 4: vertexList(10) = 10: vertexList(11) = 0
    vertexList(12) = 5: vertexList(13) = 10: vertexList(14) = 0
    vertexList(15) = 6: vertexList(16) = 10: vertexList(17) = 0
    Dim FaceList(0 To 7) As Integer

    FaceList(0) = 1
    FaceList(1) = 2
    FaceList(2) = 5
    FaceList(3) = 4
    FaceList(4) = 2
    FaceList(5) = 3
    FaceList(6) = 6
    FaceList(7) = 5

    Dim obj As ZcadPolyfaceMesh
    Set obj = ThisDrawing.ModelSpace.AddPolyfaceMesh(vertexList, FaceList)

    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddPolyline Method Example
Sub Example_AddPolyline()
    ' This example creates a polyline in model space.

    Dim plineObj As ZcadPolyline
    Dim points(0 To 14) As Double

    points(0) = 2: points(1) = 1: points(2) = 0
    points(3) = 3: points(4) = 10: points(5) = 0
    points(6) = 23: points(7) = 12: points(8) = 0
    points(9) = 33: points(10) = 22: points(11) = 0
    points(12) = 40: points(13) = 32: points(14) = 0

    Set plineObj = ThisDrawing.ModelSpace.AddPolyline(points)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

End Sub


AddPViewport Method Example
Sub Example_AddPViewport()
    ' This example creates a new paper space viewport

    Dim pviewportObj As ZcadPViewport
    Dim center(0 To 2) As Double
    Dim width As Double
    Dim height As Double

    ' Define the paper space viewport
    center(0) = 3: center(1) = 3: center(2) = 0
    width = 40
    height = 40
    ' Change from model space to paper space
    ThisDrawing.ActiveSpace = zcPaperSpace

    ' Create the paper space viewport
    Set pviewportObj = ThisDrawing.PaperSpace.AddPViewport(center, width, height)
    ThisDrawing.Regen zcActiveViewport

End Sub


AddRaster Method Example
Sub Example_AddRaster()

    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "C:\boot\123.jpg"
    insertionPoint(0) = 100#: insertionPoint(1) = 100#: insertionPoint(2) = 0#
    scalefactor = 1#
    rotationAngle = 0

    On Error Resume Next
    ' Creates a raster image in model space
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)

    If Err.Description = "File error" Then
        MsgBox imageName & " could not be found."
        Exit Sub
    End If
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddRay Method Example
Sub Example_AddRay()
    ' This example creates a ray in model space.

    Dim rayObj As ZcadRay
    Dim basePoint(0 To 2) As Double
    Dim SecondPoint(0 To 2) As Double

    ' Define the ray
    basePoint(0) = 30#: basePoint(1) = 20#: basePoint(2) = 0#
    SecondPoint(0) = 40#: SecondPoint(1) = 50#: SecondPoint(2) = 0#

    ' Creates a Ray object in model space
    Set rayObj = ThisDrawing.ModelSpace.AddRay(basePoint, SecondPoint)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddRegion Method Example

Sub Example_AddRegion()
    ' This example creates a region from an arc and a line.

    Dim curves(0 To 1) As ZcadEntity
    Dim arcObj As ZcadArc

    ' Define the arc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double
    centerPoint(0) = 100#: centerPoint(1) = 100#: centerPoint(2) = 0#
    radius = 10#
    startAngle = 0
    endAngle = 3.141592
    Set curves(0) = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)

    Set arcObj = curves(0)
    ' Define the line

    Set curves(1) = ThisDrawing.ModelSpace.AddLine(arcObj.startPoint, arcObj.endPoint)

    ' Create the region
    Dim regionObj As Variant
    regionObj = ThisDrawing.ModelSpace.AddRegion(curves)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

 End Sub


AddRevolvedSolid Method Example
Sub Example_AddRevolvedSolid()
    ' This example creates a solid from a region
    ' rotated around an axis.
    ' The region is created from an arc and a line.
    Dim curves(0 To 1) As ZcadEntity

    ' Define the arc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double
    centerPoint(0) = 5#: centerPoint(1) = 3#: centerPoint(2) = 0#
    radius = 2#
    startAngle = 0
    endAngle = 3.141592
    Set curves(0) = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    Dim arcobj As ZcadArc

    Set arcobj = curves(0)
    ' Define the line
    Set curves(1) = ThisDrawing.ModelSpace.AddLine(arcobj.startPoint, arcobj.endPoint)

    ' Create the region
    Dim regionObj As Variant
    regionObj = ThisDrawing.ModelSpace.AddRegion(curves)
    MsgBox "Revolve the region to create the solid.", , "AddRevolvedSolid Example"

    ' Define the rotation axis
    Dim axisPt(0 To 2) As Double
    Dim axisDir(0 To 2) As Double
    Dim angle As Double
    axisPt(0) = 7: axisPt(1) = 2.5: axisPt(2) = 0
    axisDir(0) = 1: axisDir(1) = 1: axisDir(2) = 3
    angle = 6.28

    ' Create the solid
    Dim solidObj As Zcad3DSolid
    Set solidObj = ThisDrawing.ModelSpace.AddRevolvedSolid(regionObj(0), axisPt, axisDir, angle)
    ThisDrawing.Regen zcActiveViewport

     ' Change the viewing direction of the viewport
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    MsgBox "Solid created.", , "AddRevolvedSolid Example"

End Sub


AddSeparator Method Example
Sub Example_AddSeparator()

    Dim currMenuGroup As ZcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)
    Dim newMenu As ZcadPopupMenu
    Set newMenu = currMenuGroup.Menus.Add("TestMenu")
    Dim newMenuItem1 As ZcadPopupMenuItem
    Dim newMenuItem2 As ZcadPopupMenuItem
    Dim newMenuItem3 As ZcadPopupMenuItem
    Dim newMenuItem4 As ZcadPopupMenuItem
    Dim FileSubMenu As ZcadPopupMenu

    Set newMenuItem1 = newMenu.AddMenuItem(0, "a&R", "aaa")
    Set newMenuItem2 = newMenu.AddMenuItem(1, "b", "bbb" & Chr(32))
    Set newMenuItem3 = newMenu.AddMenuItem(2, "c", "ccc" & Chr(32))
    Set newMenuItem4 = newMenu.AddMenuItem(3, "d", "a" & Chr(13))
    Set FileSubMenu = newMenu.AddSubMenu(4, "NewFile")
    newMenu.AddSeparator (2)
    FileSubMenu.AddMenuItem 0, "e", "eee" & Chr(32)
    FileSubMenu.AddMenuItem 1, "f", "eee" & Chr(32)
    FileSubMenu.AddMenuItem 2, "g", "eee" & Chr(32)
    FileSubMenu.AddSeparator (2)

    newMenu.InsertInMenuBar (ThisDrawing.Application.MenuBar.count + 1)

End Sub


AddShape Method Example
Sub Example_AddShape()

    On Error GoTo ERRORHANDLER
    ThisDrawing.LoadShapeFile ("E:\Program Files\Support\LZWCAD.SHX")
    Dim shapeObj As ZcadShape
    Dim shapeName As String
    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotation As Double

    shapeName = "ZXD"
    insertionPoint(0) = 3#: insertionPoint(1) = 3#: insertionPoint(2) = 0#
    scalefactor = 1#
    rotation = 0#
    Set shapeObj = ThisDrawing.ModelSpace.AddShape(shapeName, insertionPoint, scalefactor, rotation)
    shapeObj.Update
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll
    Exit Sub

ERRORHANDLER:
    MsgBox "Cannot find the shape file.", , "AddShape Example"

End Sub


AddSolid Method Example
Sub Example_AddSolid()
    ' This example creates a solid in model space.

    Dim solidObj As ZcadSolid
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim point3(0 To 2) As Double
    Dim point4(0 To 2) As Double

    ' Define the solid
    point1(0) = 1#: point1(1) = 1#: point1(2) = 0#
    point2(0) = 6#: point2(1) = 3#: point2(2) = 0#
    point3(0) = 7#: point3(1) = 8#: point3(2) = 0#
    point4(0) = 3#: point4(1) = 9#: point4(2) = 0#

    ' Create the solid object in model space
    Set solidObj = ThisDrawing.ModelSpace.AddSolid(point1, point2, point3, point4)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddSphere Method Example
Sub Example_AddSphere()
    ' This example creates a sphere in model space.

    Dim sphereObj As Zcad3DSolid
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double

    centerPoint(0) = 5#: centerPoint(1) = 5#: centerPoint(2) = 0#
    radius = 20#
    Set sphereObj = ThisDrawing.ModelSpace.AddSphere(centerPoint, radius)

    ' Change the viewing direction of the viewport
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


AddSpline Method Example
Sub Example_AddSpline()
    ' This example creates a spline object in model space.

    Dim splineObj As ZcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim fitPoints(0 To 8) As Double

    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    fitPoints(0) = 1: fitPoints(1) = 1: fitPoints(2) = 0
    fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0
    fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0

    Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddSubMenu Method Example
Sub Example_AddSubMenu()
    ' This example creates a new menu called TestMenu and inserts a submenu item called NewFile.
    ' It then creates a menu item, called open, on the submenu.

    ' The menu is then displayed on the menu bar.
    ' To remove the menu after execution of this macro, use the Customize Menu
    ' option from the Tools menu.

    Dim currMenuGroup As ZcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new menu
    Dim newMenu As ZcadPopupMenu
    Set newMenu = currMenuGroup.Menus.Add("TestMenu11")

    ' Add the submenu
    Dim FileSubMenu As ZcadPopupMenu
    Set FileSubMenu = newMenu.AddSubMenu(0, "NewFile")

    ' Add a menu item to the sub menu
    Dim newMenuItem As ZcadPopupMenuItem
    Dim openMacro As String

    ' Assign the macro string the VB equivalent of " _open "
    openMacro = Chr(95) & "open" & Chr(32)

    Set newMenuItem = FileSubMenu.AddMenuItem(newMenu.Count + 1, "Open", openMacro)

    ' Display the menu on the menu bar
    newMenu.InsertInMenuBar (ThisDrawing.Application.MenuBar.Count + 1)

End Sub


AddText Method Example
Sub Example_AddText()
    ' This example creates a text object in model space.

    Dim textObj As ZcadText
    Dim textString As String
    Dim insertionPoint(0 To 2) As Double
    Dim height As Double

    ' Define the text object
    textString = "ABCD"
    insertionPoint(0) = 2: insertionPoint(1) = 8: insertionPoint(2) = 0
    height = 10

    ' Create the text object in model space
    Set textObj = ThisDrawing.ModelSpace.AddText(textString, insertionPoint, height)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddTolerance Method Example
Sub Example_AddTolerance()
    ' This example creates a tolerance object in model space.

    Dim toleranceObj As ZcadTolerance
    Dim textString As String
    Dim insertionPoint(0 To 2) As Double
    Dim direction(0 To 2) As Double

    ' Define the tolerance object
    textString = "Here is the Test"
    insertionPoint(0) = 15#: insertionPoint(1) = 5#: insertionPoint(2) = 0#
    direction(0) = 1#: direction(1) = 1#: direction(2) = 0#

    ' Create the tolerance object in model space
    Set toleranceObj = ThisDrawing.ModelSpace.AddTolerance(textString, insertionPoint, direction)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddToolbarButton Method Example
Sub Example_AddToolbarButton()

    Dim currMenuGroup As ZcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new toolbar
    Dim newToolBar As ZcadToolbar
    Dim newToolBar1 As ZcadToolbar
    Set newToolBar = currMenuGroup.Toolbars.Add("TestToolbar")
    Set newToolBar1 = currMenuGroup.Toolbars.Add("test")

    ' Add a button to the new toolbar
    Dim newButton1 As ZcadToolbarItem
    Dim newButton2 As ZcadToolbarItem
    Dim newButton3 As ZcadToolbarItem
    Dim newButton4 As ZcadToolbarItem
    Dim newButton5 As ZcadToolbarItem
    Dim temp As ZcadToolbarItem
    Dim newMenuSeparator  As ZcadToolbarItem
    Dim openMacro As String
    ' Assign the macro string the VB equivalent of " _open "
    openMacro = Chr(95) & "open" & Chr(32)

    Set newButton1 = newToolBar.AddToolbarButton(0, "NewButton1", "Open", openMacro, True)
    Set newButton2 = newToolBar.AddToolbarButton(1, "NewButton2", "Open a ", openMacro, False)
    Set newButton3 = newToolBar.AddToolbarButton(2, "NewButton3", "Open a file ", openMacro, False)
    Set temp = newToolBar.AddSeparator(1)
    Set newButton4 = newToolBar1.AddToolbarButton(0, "NewButton4", " file.", "123", True)
    Set newButton5 = newToolBar1.AddToolbarButton(1, "NewButton5", "sdfs", "1234", True)
    newButton1.AttachToolbarToFlyout "Custom", "test"

End Sub


AddTorus Method Example
Sub Example_AddTorus()
    ' This example creates a torus in model space.

    Dim torusObj As Zcad3DSolid
    Dim centerPoint(0 To 2) As Double
    Dim torusRadius As Double
    Dim tubeRadius As Double

    ' Define the torus
    centerPoint(0) = 2: centerPoint(1) = 5: centerPoint(2) = 0
    torusRadius = 20
    tubeRadius = 5

    ' Create the torus
    Set torusObj = ThisDrawing.ModelSpace.AddTorus(centerPoint, torusRadius, tubeRadius)

    ' Change the viewing direction of the viewport
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


AddTrace Method Example
Sub Example_AddTrace()
    ' This example creates a trace in model space.

    Dim traceObj As ZcadTrace
    Dim tracePts(0 To 11) As Double

    tracePts(0) = 2: tracePts(1) = 1: tracePts(2) = 0
    tracePts(3) = 3: tracePts(4) = 3: tracePts(5) = 0
    tracePts(6) = 4: tracePts(7) = 3: tracePts(8) = 0
    tracePts(9) = 5: tracePts(10) = 1: tracePts(11) = 0

    ' Turn on the system variable (FILLMODE)
    ' to fill the outline of the trace
    ThisDrawing.SetVariable "FILLMODE", 1

    ' Create the trace object in model space
    Set traceObj = ThisDrawing.ModelSpace.AddTrace(tracePts)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddVertex Method Example

Sub Example_AddVertex()

    Dim lwplineObj As ZcadLWPolyline
    Dim points(0 To 5) As Double

    ' Create the polyline in model space
    points(0) = 3: points(1) = 7
    points(2) = 9: points(3) = 2
    points(4) = 3: points(5) = 5
    Set lwplineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Add the vertex 4, 1, 0.", , "AddVertex Example"

    Dim newVertex(0 To 1) As Double
    newVertex(0) = 4: newVertex(1) = 1
    lwplineObj.AddVertex 1, newVertex
    lwplineObj.Update
    ThisDrawing.Application.ZoomExtents
    MsgBox "The vertex 4, 1, 0 has been added.", , "AddVertex Example"

End Sub


AddWedge Method Example
Sub Example_AddWedge()
    ' This example creates a wedge in model space.

    Dim wedgeObj As Zcad3DSolid
    Dim center(0 To 2) As Double
    Dim length As Double
    Dim width As Double
    Dim height As Double

    ' Define the wedge
    center(0) = 6#: center(1) = 5#: center(2) = 0
    length = 9#: width = 12#: height = 25#

    ' Create the wedge in model space
    Set wedgeObj = ThisDrawing.ModelSpace.AddWedge(center, length, width, height)

    ' Change the viewing direction of the viewport
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


AddXLine Method Example
Sub Example_AddXline()

    Dim Xlineobj As ZcadXline
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 15#: endPoint(1) = 5#: endPoint(2) = 0#
    Set Xlineobj = ThisDrawing.ModelSpace.AddXline(startPoint, endPoint)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


AddXRecord Method Example
Sub Example_AddXRecord()

    Dim DictionaryObject As ZcadDictionary, XRecordObject As ZcadXRecord
    Set DictionaryObject = ThisDrawing.Dictionaries.Add("Test")
    Set XRecordObject = DictionaryObject.AddXRecord("XRECORD")

End Sub


AngleFromXAxis Method Example
Sub Example_AngleFromXAxis()

    Dim pt1(0 To 2) As Double
    Dim pt2(0 To 2) As Double
    Dim retAngle As Double
    pt1(0) = 2: pt1(1) = 2: pt1(2) = 0
    pt2(0) = 200: pt2(1) = 200: pt2(2) = 0
    retAngle = ThisDrawing.Utility.AngleFromXAxis(pt1, pt2)
    MsgBox "The angle in radians between the X axis and the line is " & retAngle, , "AngleFromXAxis Example"

End Sub


AngleToReal Method Example
Sub Example_AngleToReal()

    Dim angAsStr As String
    Dim unit As Integer
    Dim angAsReal As Double

    ' Convert the angle given in degrees unit to a real
    angAsStr = "45"
    unit = zcDegrees
    angAsReal = ThisDrawing.Utility.AngleToReal(angAsStr, unit)
    MsgBox "45 degrees converts to " & angAsReal & " radians.", , "AngleAsReal Example"

End Sub


AngleToString Method Example
Sub Example_AngleToString()
    ' This example converts a radian value to several different
    ' strings representing the value in different units.

    Dim angAsRad As Double
    Dim unit As Integer
    Dim precision As Long
    Dim angAsString As String
    angAsRad = 0.785398163397448
    unit = zcDegrees
    precision = 6
    angAsString = ThisDrawing.Utility.AngleToString(angAsRad, unit, precision)
    MsgBox "0.785398163397448 radians =  " & angAsString & " degrees", , "AngleAsString Example"

End Sub


AppendInnerLoop Method Example

Sub Example_AppendInnerLoop()

    Dim hatchobj As ZcadHatch
    Dim patternname As String
    Dim patterntype As Long
    Dim bassociativity As Boolean
    patternname = "ANSI31"
    patterntype = zcHatchPatternTypePreDefined
    bassociativity = True
    Set hatchobj = ThisDrawing.ModelSpace.AddHatch(patterntype, patternname, bassociativity)
    Dim outerloop(0 To 1) As ZcadEntity
    Dim center(0 To 2) As Double
    Dim arcobj As ZcadArc
    Dim startangle As Double
    Dim endangle As Double
    center(0) = 5
    center(1) = 3
    center(2) = 0
    startangle = 0
    endangle = 3.141592

    Set outerloop(0) = ThisDrawing.ModelSpace.AddArc(center, 3, starangle, endangle)
    Set arcobj = outerloop(0)
    Set outerloop(1) = ThisDrawing.ModelSpace.AddLine(arcobj.StartPoint, arcobj.EndPoint)
    hatchobj.AppendOuterLoop (outerloop)
    ThisDrawing.Regen zcActiveViewport

    Dim innerloop(0) As ZcadEntity
    center(0) = 5
    center(1) = 4.5
    center(2) = 0
    Set innerloop(0) = ThisDrawing.ModelSpace.AddCircle(center, 0.5)
    hatchobj.AppendInnerLoop (innerloop)
    hatchobj.PatternScale = 0.1
    hatchobj.PatternAngle = 1.57
    hatchobj.Evaluate
    ThisDrawing.Regen zcActiveViewport

End Sub


AppendItems Method Example
Sub Example_AppendItems()

    ' Create the new group
    Dim groupObj As ZcadGroup
    Set groupObj = ThisDrawing.Groups.Add("test")

    ' Create a line object in model space
    Dim lineObj As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
    startPoint(0) = 0: startPoint(1) = 0: startPoint(2) = 0
    endPoint(0) = 100: endPoint(1) = 100: endPoint(2) = 0
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    lineObj.Update

    ' Create a circle object in model space
    Dim circObj As ZcadCircle
    Dim centerPt(0 To 2) As Double
    Dim radius As Double
    centerPt(0) = 0: centerPt(1) = 0: centerPt(2) = 0
    radius = 100
    Set circObj = ThisDrawing.ModelSpace.AddCircle(centerPt, radius)
    circObj.Update
    ThisDrawing.Application.ZoomAll

    ReDim appendObjs(0 To ThisDrawing.ModelSpace.Count - 1) As ZcadEntity
    Dim I As Integer
    For I = 0 To ThisDrawing.ModelSpace.Count - 1
        Set appendObjs(I) = ThisDrawing.ModelSpace.Item(I)
    Next

    groupObj.AppendItems appendObjs
    ThisDrawing.Regen zcActiveViewport

End Sub


AppendOuterLoop Method Example
Sub Example_AppendOuterLoop()

    Dim hatchobj As ZcadHatch
    Dim patternname As String
    Dim patterntype As Long
    Dim bassociativity As Boolean
    patternname = "SOLID"
    patterntype = zcHatchPatternTypePreDefined
    bassociativity = True
    Set hatchobj = ThisDrawing.ModelSpace.AddHatch(patterntype, patternname, bassociativity)
    Dim outerloop As ZcadLWPolyline
    Dim object(0 To 0) As ZcadEntity
    Dim points(0 To 5) As Double
    points(0) = 1: points(1) = 1
    points(2) = 3: points(3) = 3
    points(4) = 2: points(5) = 1.5

    Set outerloop = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)
    outerloop.Closed = True
    outerloop.Update
    Set object(0) = outerloop
    hatchobj.AppendOuterLoop (object)
    hatchobj.Evaluate
    ThisDrawing.Regen zcActiveViewport

End Sub


AppendVertex Method Example
Sub Example_AppendVertex()

    Dim polyObj As Zcad3DPolyline
    Dim Points(0 To 8) As Double
    Points(0) = 0: Points(1) = 0: Points(2) = 0
    Points(3) = 10: Points(4) = 10: Points(5) = 10
    Points(6) = 20: Points(7) = 20: Points(8) = 20

    ' Create a 3DPolyline in model space
    Set polyObj = ThisDrawing.ModelSpace.Add3DPoly(Points)
    ThisDrawing.Regen zcActiveViewport

    Dim newVertex(0 To 2) As Double
    newVertex(0) = 30
    newVertex(1) = 50
    newVertex(2) = 0
    polyObj.AppendVertex newVertex
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The vertex 30, 50, 0 as been appended.", , "AppendVertex Example"

End Sub


ArrayPolar Method Example
Sub Example_ArrayPolar()
    ' This example creates a 3DFACE and then performs a polar array
    ' on that 3DFACE.

    ' Create the 3DFACE
    Dim faceObj As Zcad3DFace
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim point3(0 To 2) As Double
    Dim point4(0 To 2) As Double

    ' Define the four coordinates of the face
    point1(0) = 1#: point1(1) = 1#: point1(2) = 0#
    point2(0) = 5#: point2(1) = 1#: point2(2) = 1#
    point3(0) = 1#: point3(1) = 10#: point3(2) = 0#
    point4(0) = 5#: point4(1) = 5#: point4(2) = 1#

    ' Create the 3DFace object in model space
    Set faceObj = ThisDrawing.ModelSpace.Add3DFace(point1, point2, point3, point4)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll
    MsgBox "Perform the polar array on the 3DFace.", , "ArrayPolar Example"

    ' Define the polar array
    Dim noOfObjects As Integer
    Dim angleToFill As Double
    Dim basePnt(0 To 2) As Double
    Dim st(0 To 2) As Double
    noOfObjects = 4
    angleToFill = 3.14
    basePnt(0) = 50#: basePnt(1) = 50#: basePnt(2) = 0#

    ' The following example will create 4 copies of an object
    ' by rotating and copying it about the point (50,50,0).
    Dim retObj As Variant
    retObj = faceObj.ArrayPolar(noOfObjects, angleToFill, basePnt)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll
    MsgBox "Polar array completed.", , "ArrayPolar Example"

 End Sub


ArrayRectangular Method Example
Sub Example_ArrayRectangular()

    ' Create the 3DFACE
    Dim faceObj As Zcad3DFace
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim point3(0 To 2) As Double
    Dim point4(0 To 2) As Double

    ' Define the four coordinates of the face
    point1(0) = 1#: point1(1) = 1#: point1(2) = 0#
    point2(0) = 5#: point2(1) = 1#: point2(2) = 1#
    point3(0) = 1#: point3(1) = 10#: point3(2) = 0#
    point4(0) = 5#: point4(1) = 5#: point4(2) = 1#

    ' Create the 3DFace object in model space
    Set faceObj = ThisDrawing.ModelSpace.Add3DFace(point1, point2, point3, point4)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll
    MsgBox "Perform the rectangular array on the 3DFACE.", , "ArrayRectangular Example"

    ' Define the rectangular array
    Dim numberOfRows As Long
    Dim numberOfColumns As Long
    Dim numberOfLevels As Long
    Dim distanceBwtnRows As Double
    Dim distanceBwtnColumns As Double
    Dim distanceBwtnLevels As Double
    numberOfRows = 5
    numberOfColumns = 5
    numberOfLevels = 2
    distanceBwtnRows = 10
    distanceBwtnColumns = 10
    distanceBwtnLevels = 1

    ' Create the array of objects
    Dim retObj As Variant
    retObj = faceObj.ArrayRectangular(numberOfRows, numberOfColumns, numberOfLevels, distanceBwtnRows, distanceBwtnColumns, distanceBwtnLevels)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll
    MsgBox "Rectangular array completed.", , "ArrayRectangular Example"

 End Sub


AttachExternalReference Method Example
Sub Example_AttachExternalReference()

    Dim InsertPoint(0 To 2) As Double
    Dim insertedBlock As ZcadExternalReference
    Dim PathName As String
    InsertPoint(0) = 100: InsertPoint(1) = 100: InsertPoint(2) = 0
    PathName = "C:\boot\123.dwg"
    Set insertedBlock = ThisDrawing.ModelSpace.AttachExternalReference(PathName, "TEST", InsertPoint, 1, 1, 1, 0, False)
    ThisDrawing.Regen zcActiveViewport

End Sub


AttachToolbarToFlyout Method Example
Sub Example_AttachToolbarToFlyout()

    Dim currMenuGroup As ZcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    '  Create the first toolbar
    Dim FirstToolbar As ZcadToolbar
    Set FirstToolbar = currMenuGroup.Toolbars. _
                                Add("FirstToolbar")

    ' Add a button to the first toolbar
    Dim FlyoutButton As ZcadToolbarItem
    Set FlyoutButton = FirstToolbar.AddToolbarButton(0, "Flyout", "Demonstrates a flyout button", _
             "OPEN", True)

    ' Create the second toolbar. The second toolbar will been linked the first toobbar by the flyout button
    Dim SecondToolbar As ZcadToolbar
    Set SecondToolbar = currMenuGroup.Toolbars.Add("SecondToolbar")

    ' Add a button to the second toolbar
    Dim newButton As ZcadToolbarItem
    Dim openMacro As String

    ' Assign the macro string the VB equivalent of " _open "
    openMacro = Chr(95) & "open" & Chr(32)
    Set newButton = SecondToolbar.AddToolbarButton(0, "NewButton", "Open a file.", openMacro, False)

    ' Link the second toolbar as the flyout for the first toolbar button
    FlyoutButton.AttachToolbarToFlyout currMenuGroup.Name, SecondToolbar.Name

    ' Display the first toolbar and hide the second one
    FirstToolbar.Visible = True
    SecondToolbar.Visible = False

End Sub


Bind Method Example
Sub Example_Bind()

    Dim InsertPoint(0 To 2) As Double
    Dim insertedBlock As ZcadExternalReference
    Dim PathName As String
    InsertPoint(0) = 100: InsertPoint(1) = 100: InsertPoint(2) = 0
    PathName = "C:\boot\123.dwg"

    Set insertedBlock = ThisDrawing.ModelSpace.AttachExternalReference(PathName, "XREF_IMAGE", InsertPoint, 1, 1, 1, 0, False)
    insertedBlock.Update
    ThisDrawing.Blocks.Item(insertedBlock.Name).Bind False
    ThisDrawing.Regen zcActiveViewport

End Sub


CheckInterference Method Example

Sub Example_CheckInterference()

    Dim boxObj As Zcad3DSolid
    Dim boxLength As Double, boxWidth As Double, boxHeight As Double
    Dim boxCenter(0 To 2) As Double
    boxCenter(0) = 5#: boxCenter(1) = 5#: boxCenter(2) = 0
    boxLength = 10#: boxWidth = 7: boxHeight = 10#

    ' Create the box (3DSolid) object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(boxCenter, boxLength, boxWidth, boxHeight)
    boxObj.Color = zcBlue
    boxObj.Update

    ' Define the cylinder
    Dim cylinderObj As Zcad3DSolid
    Dim cylinderCenter(0 To 2) As Double
    Dim cylinderRadius As Double
    Dim cylinderHeight As Double
    cylinderCenter(0) = 0#: cylinderCenter(1) = 0#: cylinderCenter(2) = 0#
    cylinderRadius = 5#
    cylinderHeight = 20#

    ' Create the Cylinder (3DSolid) object in model space
    Set cylinderObj = ThisDrawing.ModelSpace.AddCylinder(cylinderCenter, cylinderRadius, cylinderHeight)
    cylinderObj.Color = zcGreen
    cylinderObj.Update

    ' Find the interference between the two solids and create a new solid from it
    Dim solidObj As Zcad3DSolid
    Set solidObj = boxObj.CheckInterference(cylinderObj, True)
    solidObj.Color = zcRed

    ' Change the viewing direction of the viewport
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


Clear Method Example
Sub Example_Clear()

    Dim ssetobj As ZcadSelectionSet
    Set ssetobj = ThisDrawing.SelectionSets.Add("Test")

    ssetobj.SelectOnScreen
    MsgBox "Before delete,The SelectionSet of count is " & ssetobj.Count
    ssetobj.Clear
    MsgBox "After delete,The SelectionSet of count is " & ssetobj.Count

End Sub


Close Method Example
Sub Example_Close()
    ' This example cycles through the documents collection
    ' and closes all open documents using the Close method.

    Dim DOC As ZcadDocument

    ' If there are no open documents, then exit
    If ThisDrawing.Application.Documents.Count = 0 Then
        MsgBox "There are no open documents!"
        Exit Sub
    End If

    ' Close all open documents
    For Each DOC In ThisDrawing.Application.Documents
        If MsgBox("Do you wish to close the document: " & DOC.Name, vbYesNo + vbQuestion) = vbYes Then
            If DOC.FullName <> "" Then
                DOC.Close
            Else
                MsgBox DOC.Name & " has not been saved yet, so it will not be closed."
            End If
        End If
    Next

End Sub


Copy Method Example
Sub Example_Copy()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 20 * 3.141592 / 180#: endAngle = 200 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents
    MsgBox "Copy the arc.", , "Copy Example"

    ' Copy the arc
    Dim copyarcObj As ZcadArc
    Set copyarcObj = arcObj.Copy()
    copyarcObj.Update

    ' Define the points that make up the move vector
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    point1(0) = 0: point1(1) = 0: point1(2) = 0
    point2(0) = 2: point2(1) = 2: point2(2) = 0
    MsgBox "Move the copied arc 2 units in the X direction and Y direction.", , "Copy Example"

    ' Move the arc and color it
    copyarcObj.Move point1, point2
    copyarcObj.Color = zcBlue
    copyarcObj.Update
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents
    MsgBox "Move completed.", , "Copy Example"

End Sub


CopyFrom Method Example
Sub Example_CopyFrom()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration
    Dim NewPC1 As ZcadPlotConfiguration, NewPC2 As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' Add NewPC1 and customize some of the properties
    Set NewPC1 = PlotConfigurations.Add("NEW_CONFIGURATION1")
        NewPC1.PlotRotation = zc270degrees
        NewPC1.PlotHidden = True
        NewPC1.PaperUnits = zcMillimeters

    ' Add NewPC2 and leave default values intact
    Set NewPC2 = PlotConfigurations.Add("NEW_CONFIGURATION2")

    ' Show NewPC2 settings before we copy information from NewPC1
    GoSub SETTINGS

    ' Copy setting information from NewPC1 to NewPC2
    NewPC2.CopyFrom NewPC1

    ' Show NewPC2 settings after we copy information from NewPC1
    GoSub SETTINGS

    Exit Sub

SETTINGS:
    MsgBox "The settings for NEW_CONFIGURATION2 are: " & vbCrLf & _
            "Plot Rotation: " & NewPC2.PlotRotation & vbCrLf & _
            "Plot Hidden: " & NewPC2.PlotHidden & vbCrLf & _
            "Paper Units: " & NewPC2.PaperUnits

    Return

End Sub


CopyObjects Method Example
Sub Example_CopyObjects()

    Dim DOC1 As ZcadDocument, DOC2 As ZcadDocument
    Dim circleObj1 As ZcadCircle, circleObj2 As ZcadCircle
    Dim circleObj1Copy As ZcadCircle, circleObj2Copy As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius1 As Double, radius2 As Double
    Dim radius1Copy As Double, radius2Copy As Double
    Dim objCollection(0 To 1) As ZcadEntity
    Dim Mspace As ZcadModelSpace
    Dim retObjects As Variant

    ' Define the Circle object
    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    radius1 = 10#: radius2 = 70#
    radius1Copy = 100#: radius2Copy = 200#

    ' Create a new document
    Set DOC1 = ThisDrawing.Application.Documents.Add
    Set DOC2 = ThisDrawing.Application.Documents.Item(0)

    Set Mspace = DOC2.ModelSpace
    ' Add two circles to the document
    Set circleObj1 = DOC1.ModelSpace.AddCircle(centerPoint, radius1)
    Set circleObj2 = DOC1.ModelSpace.AddCircle(centerPoint, radius2)
    ThisDrawing.Application.ZoomAll

    Set objCollection(0) = circleObj1
    Set objCollection(1) = circleObj2

    retObjects = DOC1.CopyObjects(objCollection, Mspace)

    ' Get newly created object and apply new properties to the copies
    Set circleObj1Copy = retObjects(0)
    Set circleObj2Copy = retObjects(1)
    circleObj1Copy.radius = radius1Copy
    circleObj2Copy.radius = radius2Copy
    ThisDrawing.Application.ZoomAll
    MsgBox "Circles copied."

End Sub


DecimalSeparator Method Example
Sub Example_DecimalSeparator()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim oldSeparator As String, newSeparator As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 21: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 36: TextPoint(1) = 36: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    DimPointAngularObj.TextPrecision = zcDimPrecisionThree
    ThisDrawing.Regen zcActiveViewport

    ' Read and display current decimal separator
    MsgBox "The decimal separator for this object is currently set to: [" & DimPointAngularObj.DecimalSeparator & "]"
    oldSeparator = DimPointAngularObj.DecimalSeparator
    newSeparator = InputBox("Enter a new decimal separator", "Change Decimal Separator", oldSeparator)

    If newSeparator = "" Then
        Exit Sub
    Else
    End If
    DimPointAngularObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The decimal separator for this object is now set to: [" & DimPointAngularObj.DecimalSeparator & "]"

End Sub


Degree Method Example
Sub Example_Degree()
    ' This example creates a spline and returns the degree
    ' of the spline's polynomial representation.

    Dim splineObj As ZcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim Points(0 To 8) As Double

    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    Points(0) = 3: Points(1) = 7: Points(2) = 0
    Points(3) = 9: Points(4) = 2: Points(5) = 0
    Points(6) = 13: Points(7) = 5: Points(8) = 0
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(Points, startTan, endTan)

    ThisDrawing.Regen zcActiveViewport
    MsgBox "The degree of this Spline's polynomial representation is: " & splineObj.Degree, vbInformation
End Sub


Delete Method Example
Sub Example_Delete()
    ' This example creates an arc and then deleted

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "create the arc", , "Example_Delete"
    arcObj.Delete
    ThisDrawing.Regen zcActiveViewport
    MsgBox "deleted arc ", , "Example_Delete"

End Sub


Delta Method Example
Sub Example_Delta()
    ' This example adds a line in model space and returns the delta of the new line

    Dim lineObj As ZcadLine
    Dim lineDelta As Variant
    Dim startPoint(0 To 2) As Double, endPoint(0 To 2) As Double

    ' Define the start and end points for the line
    startPoint(0) = 100: startPoint(1) = 100: startPoint(2) = 0
    endPoint(0) = 200: endPoint(1) = 200: endPoint(2) = 0

    ' Create the line in model space
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)

    ' Display the delta of the new line
    lineDelta = lineObj.Delta
    MsgBox "The delta of the new Line is: " & vbCrLf & _
                                            "DeltaX:" & lineDelta(0) & vbCrLf & _
                                            "DeltaY:" & lineDelta(1) & vbCrLf & _
                                            "DeltaZ:" & lineDelta(2)
    ThisDrawing.Application.ZoomExtents

End Sub


Description Method Example
Sub Example_Description()

    Dim currDescription As String
    currDescription = ThisDrawing.ActiveLinetype.Description
    MsgBox "The description of the active LineType is: " & currDescription, vbInformation, "Description Example"

    ' Change the description of the active linetype
    ThisDrawing.ActiveLinetype.Description = "My favorite LineType"
    MsgBox "The new description of the active LineType is: " & ThisDrawing.ActiveLinetype.Description, vbInformation, "Description Example"

    ' Reset the description of the active linetype
    ThisDrawing.ActiveLinetype.Description = currDescription
    MsgBox "The description of the active LineType is reset to: " & ThisDrawing.ActiveLinetype.Description, vbInformation, "Description Example"

End Sub


Detach Method Example
Sub Example_Detach()
    On Error Resume Next
    Dim xrefHome As ZcadBlock
    Dim xrefInserted As ZcadExternalReference
    Dim insertionPnt(0 To 2) As Double
    Dim PathName As String
    insertionPnt(0) = 100
    insertionPnt(1) = 100
    insertionPnt(2) = 0
    PathName = "c:\boot\123.dwg"

    ' Add the external reference
    Set xrefInserted = ThisDrawing.ModelSpace. _
            AttachExternalReference(PathName, "Test", _
            insertionPnt, 1, 1, 1, 0, False)

    MsgBox "The external reference is attached."
    ThisDrawing.Blocks.Item(xrefInserted.Name).Detach
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The external reference is detached."
End Sub


Diameter Method Example
Sub Example_Diameter()
    ' This example creates a Circle object in model space and
    ' returns the diameter of the new Circle

    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double

    ' Define the new Circle object
    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    radius = 100#

    ' Create the Circle object in model space
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents
    MsgBox "The diameter of the new Circle is: " & circleObj.Diameter

End Sub


Dictionaries Method Example
Sub Example_Dictionaries()

    Dim dict As ZcadDictionary
    Set dict = ThisDrawing.Dictionaries.Add("TEST")
    MsgBox "A new dictionary called " & dict.Name & " has been added to the dictionaries collection.", vbInformation, "Dictionaries Example"

End Sub


DimensionLineColor Method Example
Sub Example_DimensionLineColor()
    ' This example creates a Dim3PointAngular object in model space
    ' and changes the dimension line color to red using the DimensionLineColor property

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 23: FirstPoint(1) = 14: FirstPoint(2) = 0
    SecondPoint(0) = 22: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 23: TextPoint(1) = 20: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport

    ' Read and display current dimension line color
    MsgBox "The dimension line color for this object is currently set to: " & DimPointAngularObj.DimensionLineColor

    ' Change the dimension line color
    DimPointAngularObj.DimensionLineColor = zcRed
    DimPointAngularObj.Update

    ' Read and display current dimension line color
    MsgBox "The dimension line color for this object is now set to: " & DimPointAngularObj.DimensionLineColor & " (Red)"

End Sub


DimensionlineExtend Method Example
Sub Example_DimensionlineExtend()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 20#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.Arrowhead1Type = zcArrowOblique
    dimObj.Arrowhead2Type = zcArrowOblique
    dimObj.DimensionLineExtend = 3
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents

End Sub


DimensionLineWeight Method Example
Sub Example_DimensionLineWeight()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim oldLWSetting As Boolean
    Dim CurrentSetting As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 11: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 16: TextPoint(1) = 16: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport

    ' Read and display current dimension lineweight
    CurrentSetting = DimPointAngularObj.DimensionLineWeight
    Select Case CurrentSetting
        Case zcLnWtByLayer: CurrentSetting = "By Layer"
        Case zcLnWtByBlock: CurrentSetting = "By Block"
        Case zcLnWtByLwDefault: CurrentSetting = "By Default"
        Case Else
    End Select

    MsgBox "The dimension lineweight setting for this object is currently set to: " & CurrentSetting

    ' Change the dimension lineweight
    DimPointAngularObj.DimensionLineWeight = zcLnWt200
    DimPointAngularObj.Update
    MsgBox "The dimension lineweight setting for this object is now set to: " & DimPointAngularObj.DimensionLineWeight

End Sub


DimensionStyles Method Example
Sub Example_DimensionStyles()

    Dim dimStyle As ZcadDimStyle
    Set dimStyle = ThisDrawing.DimStyles.Add("TEST")
    MsgBox "A new dimension style called " & dimStyle.Name & " has been added to the Dimstyles collection.", vbInformation, "Dimstyles Example"

End Sub


DimLine1Suppress Method Example
Sub Example_DimLine1Suppress()
    ' This example creates a Dim3PointAngular object in model space
    ' and suppresses the dimension lines

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim Line1Suppressed As String, Line2Suppressed As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 50: TextPoint(1) = 80: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport

    ' Read and display current line suppression information
    Line1Suppressed = IIf(DimPointAngularObj.DimLine1Suppress, "is suppressed", "is not suppressed")
    Line2Suppressed = IIf(DimPointAngularObj.DimLine2Suppress, "is suppressed", "is not suppressed")

    MsgBox "Line one of the dimension " & Line1Suppressed & vbCrLf & _
           "Line two of the dimension " & Line2Suppressed

    ' Suppress line one of the dimension
    DimPointAngularObj.DimLine1Suppress = True
    DimPointAngularObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Line one of the dimension is now suppressed"

End Sub


DimLine2Suppress Method Example
Sub Example_DimLine2Suppress()
    ' This example creates a Dim3PointAngular object in model space
    ' and suppresses the dimension lines using DimensionLine2Suppress properties

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim Line1Suppressed As String, Line2Suppressed As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 50: TextPoint(1) = 80: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport

    ' Read and display current line suppression information
    Line1Suppressed = IIf(DimPointAngularObj.DimLine2Suppress, "is suppressed", "is not suppressed")
    Line2Suppressed = IIf(DimPointAngularObj.DimLine2Suppress, "is suppressed", "is not suppressed")

    MsgBox "Line one of the dimension " & Line1Suppressed & vbCrLf & _
           "Line two of the dimension " & Line2Suppressed

    ' Suppress line two of the dimension
    DimPointAngularObj.DimLine2Suppress = True
    DimPointAngularObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Line two of the dimension is now suppressed"

End Sub


DimLineInside Method Example
Sub Example_DimLineInside()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim CurrentValue As String

    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 11: SecondPoint(1) = 5: SecondPoint(2) = 0
    TextPoint(0) = 18: TextPoint(1) = 10: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport

    ' Read and display current line suppression information
    CurrentValue = IIf(DimPointAngularObj.DimLineInside, "are not", "are")
    MsgBox "Dimension lines " & CurrentValue & " allowed outside the extension lines"

    ' Suppress the display of dimension lines outside the extension lines
    DimPointAngularObj.DimLineInside = True
    DimPointAngularObj.Update
    MsgBox "Dimension lines are not allowed outside the extension lines"

End Sub


DimLineSuppress Method Example
Sub Example_DimLineSuppress()

    Dim dimObj As ZcadDimRadial
    Dim center(0 To 2) As Double
    Dim chordPoint(0 To 2) As Double
    Dim leaderLen As Integer

    ' Define the dimension
    center(0) = 1: center(1) = 1: center(2) = 0
    chordPoint(0) = 10: chordPoint(1) = 10: chordPoint(2) = 0
    leaderLen = 5

    ' Create the radial dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimRadial(center, chordPoint, leaderLen)
    ThisDrawing.Application.ZoomExtents
    MsgBox "The radial dimension has been created.", vbInformation

    dimObj.DimLineSuppress = Not (dimObj.DimLineSuppress)
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The radial dimension appearance has been modified.", vbInformation

End Sub


Direction Method Example
Sub Example_Direction()

    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    centerPoint(0) = 100#: centerPoint(1) = 100#: centerPoint(2) = 0#
    radius = 100#

    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)
    circleObj.Thickness = 100
    circleObj.Update

    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

End Sub


DirectionVector Method Example
Sub Example_DirectionVector()

    ' Create the ray
    Dim rayObj As ZcadRay
    Dim p1(0 To 2) As Double
    Dim p2(0 To 2) As Double
    p1(0) = 2#: p1(1) = 2#: p1(2) = 0#
    p2(0) = 8#: p2(1) = 9#: p2(2) = 0#

    Set rayObj = ThisDrawing.ModelSpace.AddRay(p1, p2)
    Dim Vector As Variant
    Vector = rayObj.DirectionVector
    MsgBox "this Ray 's directionvector is" & Vector(0) & "," & Vector(1) & "," & Vector(2)

    Vector(0) = -1#: Vector(1) = -1#: Vector(2) = 0
    rayObj.DirectionVector = Vector
    rayObj.Update
    Vector = rayObj.DirectionVector
    ThisDrawing.Regen zcActiveViewport
    MsgBox "this Ray 's directionvector is" & Vector(0) & "," & Vector(1) & "," & Vector(2)

End Sub


Display Method Example
Sub Example_DisplayMethod()
    ' This example creates a paper space viewport.

    Dim newPViewport As ZcadPViewport
    Dim centerPoint(0 To 2) As Double
    Dim height As Double
    Dim width As Double
    height = 30#
    width = 40#
    centerPoint(0) = 30#: centerPoint(1) = 30#: centerPoint(2) = 0#

    ' Create a paper space Viewport object
    ThisDrawing.ActiveSpace = zcPaperSpace
    Set newPViewport = ThisDrawing.PaperSpace.AddPViewport(centerPoint, width, height)
    ThisDrawing.Regen zcActiveViewport
    newPViewport.Display True

End Sub


DisplayPlotPreview Method Example
Sub Example_DisplayPlotPreview()

    ' Create the circle
    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 2: center(1) = 2: center(2) = 0
    radius = 100#
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(center, radius)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents
    ThisDrawing.Plot.DisplayPlotPreview zcFullPreview

End Sub


DistanceToReal Method Example
Sub Example_DistanceToReal()
    ' This example passes several different distances in
    ' different units to be converted to real values.

    Dim distAsString As String
    Dim unit As Long
    Dim distAsReal As Double

    ' Convert the distance to a real in scientific units
    unit = zcScientific
    distAsString = "1.75E+01"
    distAsReal = ThisDrawing.Utility.DistanceToReal(distAsString, unit)
    MsgBox "1.75E+01 converts to " & distAsReal & " in scientific units.", , "DistanceToReal Example"

    ' Convert the distance to a real in decimal units
    unit = zcDecimal
    distAsString = "17.5"
    distAsReal = ThisDrawing.Utility.DistanceToReal(distAsString, unit)
    MsgBox "1.75 converts to " & distAsReal & " in decimal units.", , "DistanceToReal Example"

    ' Convert the distance to a real in engineering units
    unit = zcEngineering
    distAsString = "1'-5.50"""
    distAsReal = ThisDrawing.Utility.DistanceToReal(distAsString, unit)
    MsgBox "1'-5.50"" converts to " & distAsReal & " in engineering units.", , "DistanceToReal Example"

    ' Convert the distance to a real in architectural units
    unit = zcArchitectural
    distAsString = "1'-5 1/2"""
    distAsReal = ThisDrawing.Utility.DistanceToReal(distAsString, unit)
    MsgBox "1'-5 1/2"" converts to " & distAsReal & " in architectural units.", , "DistanceToReal Example"

    ' Convert the distance to a real in fractional units
    unit = zcFractional
    distAsString = "17 1/2"
    distAsReal = ThisDrawing.Utility.DistanceToReal(distAsString, unit)
    MsgBox "17 1/2"" converts to " & distAsReal & " in fractional units.", , "DistanceToReal Example"

End Sub


Document Method Example
Sub Example_Document()
    ' This example creates an arc in model space and then
    ' finds the name of the document that the arc resides in.

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 20#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Application.ZoomAll
    Dim currDoc As ZcadDocument
    Set currDoc = arcObj.Document
    MsgBox "The arc resides in: " & currDoc.Name

End Sub


Documents Method Example
Sub Example_Documents()

    Dim document As ZcadDocument
    Dim msg As String
    msg = vbCrLf

    For Each document In ThisDrawing.Application.Documents
        msg = msg & document.Name & vbCrLf
    Next

    ' Display loaded document information
    If ThisDrawing.Application.Documents.Count > 0 Then
        MsgBox "The loaded documents are: " & msg
    Else
        MsgBox "There are no loaded documents!"
    End If

End Sub


DrawingDirection Method Example
Sub Example_DrawingDirection()

    Dim mtextObj As ZcadMText
    Dim width As Double
    Dim text As String
    Dim corner(0 To 2) As Double

    corner(0) = 100#: corner(1) = 100#: corner(2) = 0#
    width = 100
    text = "This is a text String."
    Set mtextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)
    mtextObj.Height = 10
    mtextObj.Update
    ThisDrawing.Regen zcActiveViewport

    mtextObj.DrawingDirection = zcLeftToRight
    mtextObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The DrawingDirection of the text is left to right.", vbInformation, "DrawingDirection Example"

    mtextObj.DrawingDirection = zcTopToBottom
    mtextObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The DrawingDirection of the text is top to bottom.", vbInformation, "DrawingDirection Example"

End Sub


Elevation Method Example
Sub Example_Elevation()

    Dim plineObj As ZcadLWPolyline
    Dim Points(0 To 7) As Double

    Points(0) = 1: Points(1) = 1
    Points(2) = 1: Points(3) = 2
    Points(4) = 3: Points(5) = 2
    Points(6) = 4: Points(7) = 4

    Set plineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(Points)
    MsgBox "Elevation is:" & "  " & plineObj.Elevation, , "Example Elevation"
    plineObj.Elevation = 2
    plineObj.Update
    MsgBox " Elevation is Now:" & "  " & plineObj.Elevation, , "Example Elevation"

End Sub


ElevationModelSpace Method Example
Sub Example_ElevationModelSpace()

    Dim currElevation As Double
    currElevation = ThisDrawing.ElevationModelSpace
    MsgBox "The current model space elevation is " & ThisDrawing.ElevationModelSpace, vbInformation, "ElevationModelSpace Example"

    ' Change the elevation
    ThisDocument.ElevationModelSpace = currElevation + 10
    MsgBox "The new model space elevation is " & ThisDrawing.ElevationModelSpace, vbInformation, "ElevationModelSpace Example"

    ' Reset the elevation to its original value
    ThisDrawing.ElevationModelSpace = currElevation
    MsgBox "The model space elevation is reset to " & ThisDocument.ElevationModelSpace, vbInformation, "ElevationModelSpace Example"

End Sub


ElevationPaperSpace Method Example
Sub Example_ElevationPaperSpace()
    ' This example changes the paper space elevation of the current document
    ' and then resets it to the original value.

    Dim currElevation As Double

    currElevation = ThisDrawing.ElevationPaperSpace
    MsgBox "The current paper space elevation is " & ThisDrawing.ElevationPaperSpace, vbInformation, "ElevationpaperSpace Example"

    ' Change the elevation
    ThisDrawing.ElevationPaperSpace = currElevation + 10
    MsgBox "The new paper space elevation is " & ThisDrawing.ElevationPaperSpace, vbInformation, "ElevationpaperSpace Example"

    ' Reset the elevation to its original value
    ThisDrawing.ElevationPaperSpace = currElevation
    MsgBox "The paper space elevation is reset to " & ThisDrawing.ElevationPaperSpace, vbInformation, "ElevationPaperSpace Example"

End Sub


EndAngle Method Example
Sub Example_EndAngle()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 15#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents

    'Enter an end angle of 270 degrees
    arcObj.endAngle = 270 * (3.14 / 180)
    arcObj.Update
    MsgBox "This arc has a start angle of " & " and the end angle of " & arcObj.endAngle * (180 / 3.14) & " degrees.", vbInformation, "EndAngle Example"

End Sub


EndCommand Method Example
Private Sub ZwcadDocument_EndCommand(ByVal CommandName As String)
    ' This example intercepts a drawing EndCommand event.

    ' This event is triggered immediately after finishing a command.

    ' Use the "CommandName" variable to determine which command was finished.

    MsgBox "A drawing has just finished a " & CommandName & " command."

End Sub


EndLisp Method Example
Private Sub ZwcadDocument_EndLisp()
    ' This example intercepts a drawing EndLisp event.
    '
    ' This event is triggered when a drawing finishes
    ' the evaluation of a LISP expression.
    '
    ' To trigger this example event: Start the evaluation of a LISP expression and
    ' wait for it to finish being evaluated

    MsgBox "A LISP expression has just finished being evaluated!"

End Sub


EndParameter Method Example
Sub Example_EndParameter()
    ' This example creates an ellipse and enters the start and
    ' end parameters to create an elliptical arc.

    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double

    ' Create an ellipse in model space
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)

    ' Enter a start parameter of 0, and an end parameter of 6.28
    ellObj.StartParameter = 0
    ellObj.EndParameter = 6.28
    ellObj.Update

    ' Find the start and end parameters for the ellipse
    MsgBox "The ellipse has a start parameter of " & ellObj.StartParameter & " and an end parameter of " & ellObj.EndParameter, vbInformation, "EndParameter Example"

End Sub


EndPlot Method Example
Private Sub ZcadDocument_EndPlot(ByVal DrawingName As String)
    ' This example intercepts a drawing EndPlot event.

    ' This event is triggered after a document finishes a plot request.

    ' Use the "DrawingName" variable to determine which drawing has just been printed.

    MsgBox DrawingName & " has just been printed!"

End Sub


EndPoint Method Example
Sub Example_EndPoint()
    ' This example creates an arc arc and then
    ' finds the coordinates of its start and end points.

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 55#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Application.ZoomAll

    ' Find the start and endpoints for the arc
    Dim startpoint As Variant, endpoint As Variant
    startpoint = arcObj.startpoint
    endpoint = arcObj.endpoint
    MsgBox "This arc has a start point of " & startpoint(0) & ", " & startpoint(1) & ", " & startpoint(2) & " and an endpoint of " & endpoint(0) & ", " & endpoint(1) & ", " & endpoint(2), vbInformation, "EndPoint Example"

End Sub


EndTangent Method Example
Sub Example_EndTangent()

    ' Create the spline
    Dim msg As String
    Dim plineObj As ZcadSpline
    Dim points(0 To 8) As Double

    points(0) = 1: points(1) = 1: points(2) = 0
    points(3) = 5: points(4) = 5: points(5) = 0
    points(6) = 10: points(7) = 0: points(8) = 0
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    Set plineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    ThisDrawing.Application.ZoomAll
        GoSub GETPOINTS
    MsgBox "The EndTangent for the spline is " & msg, vbInformation, "EndTangent Example"

    ' Change the end tangent of Spline to (1.5,0.707,2)
    Dim newTan(0 To 2) As Double
    newTan(0) = 1.5: newTan(1) = 0.707: newTan(2) = 2
    plineObj.EndTangent = newTan
    plineObj.Update
    ThisDrawing.Regen zcActiveViewport
    GoSub GETPOINTS
    MsgBox "The EndTangent has been changed to " & msg, vbInformation, "EndTangent Example"
    Exit Sub

GETPOINTS:
    msg = ""
    ' Get the coordinates from the end tangent
    msg = Format(plineObj.EndTangent(0), "0.###") & ", " & Format(plineObj.EndTangent(1), "0.###") & ", " & Format(plineObj.EndTangent(2), "0.###") & ","
    msg = VBA.Left(msg, Len(msg) - 1)
    Return

End Sub


EndUndoMark Method Example
Sub Example_EndUndoMark()

    Dim line As ZcadLine
    Dim stPnt(0 To 2) As Double
    Dim endPnt(0 To 2) As Double
    stPnt(0) = 10: stPnt(1) = 20: stPnt(2) = 0
    endPnt(0) = 20: endPnt(1) = 30: endPnt(2) = 0

    ' Create the lines
    Dim j As Integer
    For j = 0 To 3
        ThisDrawing.StartUndoMark
        Set line = ThisDrawing.ModelSpace.AddLine(stPnt, endPnt)
        stPnt(0) = stPnt(0) + 3
        endPnt(0) = endPnt(0) + 3
        ThisDrawing.EndUndoMark
    Next

End Sub


EntityColor Method Example
Sub Example_EntityColor()

    Dim fcolor As ZcadZcCmColor
    Set fcolor = ZcadApplication.GetInterfaceObject("ZWCAD.ZcCmColor")
    Call fcolor.SetRGB(30, 100, 200)

    Dim line As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#

    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    ThisDrawing.Application.ZoomAll
    line.TrueColor = fcolor
    line.Update
    fcolor.EntityColor = -1032157808
    line.TrueColor = fcolor
    line.Update
    Dim retcolor As ZcadZcCmColor
    Set retcolor = fcolor
    MsgBox fcolor.EntityColor
    MsgBox "Red = " & retcolor.Red
    MsgBox "Green = " & retcolor.Green
    MsgBox "Blue = " & retcolor.Blue

End Sub


EntityName Method Example
Sub Example_EntityName()

    Dim lwplineObj As ZcadLWPolyline
    Dim points(0 To 5) As Double

    ' Establish the points for the Polyline

    points(0) = 3: points(1) = 7
    points(2) = 9: points(3) = 2
    points(4) = 3: points(5) = 5

    ' Create the polyline in model space
    Set lwplineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

    ' Create a circle object in model space
    Dim circObj As ZcadCircle
    Dim centerPt(0 To 2) As Double
    Dim radius As Double
    centerPt(0) = 20: centerPt(1) = 30: centerPt(2) = 0
    radius = 3
    Set circObj = ThisDrawing.ModelSpace.AddCircle(centerPt, radius)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

    Dim entName As String
    Dim entry As ZcadEntity
    For Each entry In ThisDrawing.ModelSpace
        entName = entry.EntityName
        entry.Highlight (True)
        MsgBox "The name of this entity is " & entName, vbInformation, "EntityName Example"
        entry.Highlight (False)
    Next

End Sub


EntityType Method Example
Sub Example_EntityType()

    Dim lwplineObj As ZcadLWPolyline
    Dim points(0 To 5) As Double

    ' Establish the points for the Polyline

    points(0) = 3: points(1) = 7
    points(2) = 9: points(3) = 2
    points(4) = 3: points(5) = 5

    ' Create the polyline in model space
    Set lwplineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

    ' Create a circle object in model space
    Dim circObj As ZcadCircle
    Dim centerPt(0 To 2) As Double
    Dim radius As Double
    centerPt(0) = 20: centerPt(1) = 30: centerPt(2) = 0
    radius = 3
    Set circObj = ThisDrawing.ModelSpace.AddCircle(centerPt, radius)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

    Dim entObjectID As Long
    Dim entry As ZcadEntity
    For Each entry In ThisDrawing.ModelSpace
        entObjectID = entry.EntityType
        entry.Highlight (True)
        MsgBox "The EntityType of this entity is " & entObjectID, vbInformation, "EntityType Example"
        entry.Highlight (False)
    Next

End Sub


Erase Method Example
Sub Example_Erase()
    ' This example creates an arc and then Erase

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Application.ZoomAll
    MsgBox "create the arc", , "Example_Erase"
    arcObj.Erase
    MsgBox "Erase arc ", , "Example_Erase"

End Sub


Eval Method Example
Sub Example_Eval()
    ' This example shows how to use Eval to run a VBA code fragment
    ' without creating modules and functions.

    Dim VBACode As String

    ' Create VBA code fragment
    VBACode = "MsgBox ""VBA code fragment"""

    ' Use Eval method to calculate the small VBA script
    Eval (VBACode)
End Sub


Explode Method Example
Sub Example_Explode()

    Dim polyObj As Zcad3DPolyline
    Dim Points(0 To 11) As Double

    Points(0) = 0: Points(1) = 0: Points(2) = 0
    Points(3) = 10: Points(4) = 10: Points(5) = 10
    Points(6) = 30: Points(7) = 20: Points(8) = 20
    Points(9) = 100: Points(10) = 20: Points(11) = 20
    ' Create a 3DPolyline in model space
    Set polyObj = ThisDrawing.ModelSpace.Add3DPoly(Points)
    ThisDrawing.Regen zcActiveViewport

    ' Explode the 3DPolyline
    MsgBox "Explode the 3DPolyline?", , "Explode Example "

    Dim explodedObjects As Variant
    explodedObjects = polyObj.Explode

    ' Loop through the exploded objects
    Dim I As Integer
    For I = 0 To UBound(explodedObjects)
        MsgBox "Exploded Object " & I & ": " & explodedObjects(I).EntityName, , "Explode Example"
        explodedObjects(I).color = zcBlue
        explodedObjects(I).Update
    Next

End Sub


Export Method Example
Sub Example_Export()

    ' Define the name for the exported file
    Dim exportFile As String
    exportFile = "C:\Test"

    ' Create an empty selection set
    Dim sset As Variant
    Set sset = ThisDrawing.SelectionSets.Add("Test")

    ' Export the current document to the file specified above.
    ThisDrawing.Export exportFile, "DXF", sset

End Sub


ExtensionLineColor Method Example
Sub Example_ExtensionLineColor()
    ' This example creates a Dim3PointAngular object in model space
    ' and changes the ExtensionLineColor color to red using the ExtensionLineColor property

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 11: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 16: TextPoint(1) = 16: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    ' Read and display current ExtensionLineColor
    MsgBox "The dimension ExtensionLineColor for this object is currently set to: " & DimPointAngularObj.ExtensionLineColor

    ' Change the color
    DimPointAngularObj.ExtensionLineColor = zcRed
    DimPointAngularObj.Update

    MsgBox "The dimension ExtensionLineColor for this object is now set to: " & DimPointAngularObj.ExtensionLineColor & " (Red)"

End Sub


ExtensionLineExtend Method Example
Sub Example_ExtensionLineExtend()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    ' Read and display current ExtensionLineExtend
    MsgBox "The dimension ExtensionLineExtend for this object is currently set to: " & DimPointAngularObj.ExtensionLineExtend

    ' Change the dimension line color
    DimPointAngularObj.ExtensionLineExtend = 5
    DimPointAngularObj.Update
    MsgBox "The dimension ExtensionLineExtend  for this object is now set to: " & DimPointAngularObj.ExtensionLineExtend

End Sub


ExtensionLineOffset Method Example
Sub Example_ExtensionLineOffset()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 11: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 16: TextPoint(1) = 16: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    ' Read and display current ExtensionLineOffset
    MsgBox "The dimension ExtensionLineOffset for this object is currently set to: " & DimPointAngularObj.ExtensionLineOffset

    ' Change the dimension line color
    DimPointAngularObj.ExtensionLineOffset = 2
    DimPointAngularObj.Update
    MsgBox "The dimension ExtensionLineOffset  for this object is now set to: " & DimPointAngularObj.ExtensionLineOffset
End Sub


ExtensionLineWeight Method Example
Sub Example_ExtensionLineWeight()
    ' This example creates a Dim3PointAngular object in model space
    ' and changes the extension lineweight to a thicker value
    ' using the ExtensionLineWeight property

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim CurrentSetting As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 11: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 16: TextPoint(1) = 16: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    ' Read and display current dimension lineweight
    CurrentSetting = DimPointAngularObj.ExtensionLineWeight
    Select Case CurrentSetting
        Case zcLnWtByLayer: CurrentSetting = "By Layer"
        Case zcLnWtByBlock: CurrentSetting = "By Block"
        Case zcLnWtByLwDefault: CurrentSetting = "By Default"
        Case Else
    End Select

    MsgBox "The dimension ExtensionLineWeight setting for this object is currently set to: " & CurrentSetting

    ' Change the dimension lineweight
    DimPointAngularObj.ExtensionLineWeight = zcLnWt060
    DimPointAngularObj.Update

    ' Read and display current dimension lineweight
    MsgBox "The dimension ExtensionLineWeight setting for this object is now set to: " & DimPointAngularObj.ExtensionLineWeight

End Sub


ExtLine1EndPoint Method Example
Sub Example_ExtLine1EndPoint()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 11: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 16: TextPoint(1) = 16: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    MsgBox "The current value of ExtLine1EndPoint is " & DimPointAngularObj.ExtLine1EndPoint(0) & ", " & DimPointAngularObj.ExtLine1EndPoint(1) & ", " & DimPointAngularObj.ExtLine1EndPoint(2), vbInformation, "ExtLine1EndPoint Example"

    ' Change the endpoint of the first extension line
    SecondPoint(0) = 5: SecondPoint(1) = 3: SecondPoint(2) = 0
    DimPointAngularObj.ExtLine1EndPoint = SecondPoint
    DimPointAngularObj.Update
    MsgBox "The new value of ExtLine1EndPoint is " & DimPointAngularObj.ExtLine1EndPoint(0) & ", " & DimPointAngularObj.ExtLine1EndPoint(1) & ", " & DimPointAngularObj.ExtLine1EndPoint(2), vbInformation, "ExtLine1EndPoint Example"

End Sub


ExtLine1Point Method Example
Sub Example_ExtLine1Point()
    ' This example creates an aligned dimension and then changes the
    ' ExtLine1Point property for that dimension.

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 10#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ThisDrawing.Application.ZoomAll
    MsgBox "The current value for ExtLine1Point is " & dimObj.ExtLine1Point(0) & ", " & dimObj.ExtLine1Point(1) & ", " & dimObj.ExtLine1Point(2), vbInformation, "ExtLine1Point Example"

    Dim tmpPoint(0 To 2) As Double
  ' Change the endpoint of the first extension line
    tmpPoint(0) = 2: tmpPoint(1) = 5: tmpPoint(2) = 0
    dimObj.ExtLine1Point = tmpPoint
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The new value for ExtLine1Point is " & dimObj.ExtLine1Point(0) & ", " & dimObj.ExtLine1Point(1) & ", " & dimObj.ExtLine1Point(2), vbInformation, "ExtLine1Point Example"

End Sub


ExtLine1Suppress Method Example
Sub Example_ExtLine1Suppress()
    ' This example creates a Dim3PointAngular object in model space
    ' and suppresses the extension lines using the ExtLine1Suppress
    ' and ExtLine2Suppress properties

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim Line1Suppressed As String, Line2Suppressed As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 1: AngleVertex(1) = 1: AngleVertex(2) = 0
    FirstPoint(0) = 13: FirstPoint(1) = 14: FirstPoint(2) = 0
    SecondPoint(0) = 12: SecondPoint(1) = 5: SecondPoint(2) = 0
    TextPoint(0) = 20: TextPoint(1) = 20: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Application.ZoomAll

    ' Read and display current extension line suppression information
    Line1Suppressed = IIf(DimPointAngularObj.ExtLine1Suppress, "is suppressed", "is not suppressed")
    Line2Suppressed = IIf(DimPointAngularObj.ExtLine2Suppress, "is suppressed", "is not suppressed")

    MsgBox "Line one of the extension " & Line1Suppressed & vbCrLf & _
           "Line two of the extension " & Line2Suppressed

    ' Suppress line one of the extension
    DimPointAngularObj.ExtLine1Suppress = True
    DimPointAngularObj.Update
    MsgBox "Line one of the extension is now suppressed"

    ' Suppress line two of the extension
    DimPointAngularObj.ExtLine2Suppress = True
    DimPointAngularObj.Update
    MsgBox "Line two of the extension is now suppressed"

    ' Turn both extension lines back on
    DimPointAngularObj.ExtLine1Suppress = False
    DimPointAngularObj.ExtLine2Suppress = False
    DimPointAngularObj.Update
    ThisDrawing.Regen zcAllViewports
    MsgBox "Both extension lines are now visible again"

End Sub


ExtLine2EndPoint Method Example
Sub Example_ExtLine2EndPoint()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 10: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 16: TextPoint(1) = 16: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    MsgBox "The current value of ExtLine2EndPoint is " & DimPointAngularObj.ExtLine2EndPoint(0) & ", " & DimPointAngularObj.ExtLine2EndPoint(1) & ", " & DimPointAngularObj.ExtLine2EndPoint(2), vbInformation, "ExtLine2EndPoint Example"

    ' Change the endpoint of the first extension line
    SecondPoint(0) = 12: SecondPoint(1) = 3: SecondPoint(2) = 0
    DimPointAngularObj.ExtLine2EndPoint = SecondPoint
    DimPointAngularObj.Update
    MsgBox "The new value of ExtLine2EndPoint is " & DimPointAngularObj.ExtLine2EndPoint(0) & ", " & DimPointAngularObj.ExtLine2EndPoint(1) & ", " & DimPointAngularObj.ExtLine2EndPoint(2), vbInformation, "ExtLine2EndPoint Example"

End Sub


ExtLine2Point Method Example
Sub Example_ExtLine2Point()
    ' This example creates an aligned dimension and then changes the
    ' ExtLine2Point property for that dimension.

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 10#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ThisDrawing.Application.ZoomAll
    MsgBox "The current value for ExtLine2Point is " & dimObj.ExtLine2Point(0) & ", " & dimObj.ExtLine2Point(1) & ", " & dimObj.ExtLine2Point(2), vbInformation, "ExtLine2Point Example"

    ' Change the endpoint of the second extension line
    point1(0) = 12: point1(1) = 5: point1(2) = 0
    dimObj.ExtLine2Point = point1
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The new value for ExtLine2Point is " & dimObj.ExtLine2Point(0) & ", " & dimObj.ExtLine2Point(1) & ", " & dimObj.ExtLine2Point(2), vbInformation, "ExtLine2Point Example"

End Sub


ExtLine2Suppress Method Example
Sub Example_ExtLine2Suppress()
    ' This example creates a Dim3PointAngular object in model space
    ' and suppresses the extension lines using the ExtLine1Suppress
    ' and ExtLine2Suppress properties

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim Line1Suppressed As String, Line2Suppressed As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 3: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Application.ZoomAll

    ' Read and display current extension line suppression information
    Line1Suppressed = IIf(DimPointAngularObj.ExtLine1Suppress, "is suppressed", "is not suppressed")
    Line2Suppressed = IIf(DimPointAngularObj.ExtLine2Suppress, "is suppressed", "is not suppressed")

    MsgBox "Line one of the extension " & Line1Suppressed & vbCrLf & _
           "Line two of the extension " & Line2Suppressed

    ' Suppress line one of the extension
    DimPointAngularObj.ExtLine1Suppress = True
    DimPointAngularObj.Update
    MsgBox "Line one of the extension is now suppressed"

    ' Suppress line two of the extension
    DimPointAngularObj.ExtLine2Suppress = True
    DimPointAngularObj.Update
    MsgBox "Line two of the extension is now suppressed"

    ' Turn both extension lines back on
    DimPointAngularObj.ExtLine1Suppress = False
    DimPointAngularObj.ExtLine2Suppress = False
    DimPointAngularObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Both extension lines are now visible again"

End Sub


Fade Method Example
Sub Example_Fade()

    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "C:\boot\123.jpg"
    insertionPoint(0) = 100#: insertionPoint(1) = 100#: insertionPoint(2) = 0#
    scalefactor = 1
    rotationAngle = 0
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)
    rasterObj.Fade = 30
    rasterObj.Update
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


FieldLength Method Example
Sub Example_FieldLength()
    ' This example creates an attribute definition in model space.

    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String

    ' Define the attribute definition
    height = 1#
    mode = zcAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "New Tag"
    value = "New Value"

    ' Create the attribute definition object in model space
    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    ThisDrawing.Regen zcActiveViewport
    Dim currlength As Integer
    currlength = attributeObj.FieldLength
    MsgBox "The FieldLength of the attribute is " & attributeObj.FieldLength, vbInformation, "FieldLength Example"

    attributeObj.FieldLength = currlength + 2
    MsgBox "The new FieldLength of the attribute is " & attributeObj.FieldLength, vbInformation, "FieldLength Example"

    attributeObj.FieldLength = currlength
    attributeObj.Update
    MsgBox "The FieldLength of the attribute is " & attributeObj.FieldLength, vbInformation, "FieldLength Example"

End Sub


Fit Method Example
Sub Example_Fit()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim Line1Suppressed As String, Line2Suppressed As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 11: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 16: TextPoint(1) = 16: TextPoint(2) = 0

   ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport
    ' Read and display current dimension line fit information
    Select Case DimPointAngularObj.Fit
        Case zcTextAndArrows:   CurrentFit = "Text and Arrows"
        Case zcArrowsOnly:      CurrentFit = "Arrows Only"
        Case zcTextOnly:        CurrentFit = "Text Only"
        Case zcBestFit:         CurrentFit = "Best Fit"
    End Select
    MsgBox "The current dimension fit is set to: " & CurrentFit

    ' Change the fit to arrows only
    DimPointAngularObj.Fit = zcArrowsOnly
    DimPointAngularObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The dimension fit has been changed to arrows only"

    ' Change the fit to text only
    DimPointAngularObj.Fit = zcTextOnly
    DimPointAngularObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The dimension fit has been changed to text only"

    ' Change the fit to Text and Arrows
    DimPointAngularObj.Fit = zcTextAndArrows
    DimPointAngularObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The dimension fit has been changed to Text and Arrows"

End Sub


FitPoints Method Example
Sub Example_FitPoints()
   ' This example creates a Spline object in model space, reads the fit points
   ' of the Spline and then modifies the fit points of the Spline.

    Dim splineObj As ZcadSpline
    Dim startTan(0 To 2) As Double, endTan(0 To 2) As Double
    Dim FPoints(0 To 8) As Double
    Dim UserMessage As String
    Dim fitPoints As Variant
    Dim iCount As Long, iPoint As Integer
    Dim NewFP(0 To 2) As Double

    ' Define the Spline object
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    FPoints(0) = 0: FPoints(1) = 0: FPoints(2) = 0
    FPoints(3) = 5:   FPoints(4) = 5: FPoints(5) = 0
    FPoints(6) = 10: FPoints(7) = 0: FPoints(8) = 0

    ' Create new Spline object
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(FPoints, startTan, endTan)
    ThisDrawing.Regen zcActiveViewport

    ' Display fit points for this Spline
    GoSub DISPLAYPOINTS

    ' Modify an existing fit point for this Spline
    fitPoints(0) = 3
    splineObj.fitPoints = fitPoints

    ' Now add a new fit point
    NewFP(0) = 15: NewFP(1) = 4: NewFP(2) = 0
    splineObj.AddFitPoint splineObj.NumberOfFitPoints + 1, NewFP

    splineObj.color = zcBlue
    ThisDrawing.Regen zcActiveViewport

    ' Display new fit points for this Spline
    GoSub DISPLAYPOINTS

    Exit Sub

DISPLAYPOINTS:
    fitPoints = splineObj.fitPoints

    ' Display in groups of three
    UserMessage = ""
    iPoint = 0
    For iCount = 0 To UBound(fitPoints) Step 3
        iPoint = iPoint + 1
        UserMessage = UserMessage & iPoint & ")" & vbTab
        UserMessage = UserMessage & fitPoints(iCount)
        UserMessage = UserMessage & ", " & fitPoints(iCount + 1)
        UserMessage = UserMessage & ", " & fitPoints(iCount + 2)
        UserMessage = UserMessage & vbCrLf
    Next

    MsgBox "The " & splineObj.NumberOfFitPoints & " Spline fit points are: " & vbCrLf & vbCrLf & UserMessage

    Return
End Sub


FitTolerance Method Example
Sub Example_FitTolerance()
    ' This example creates a spline object in model space.
    ' It then changes the FitTolerance property of that spline.

    ' Create the spline
    Dim splineObj As ZcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim fitPoints(0 To 8) As Double

    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    fitPoints(0) = 1: fitPoints(1) = 1: fitPoints(2) = 0
    fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0
    fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0

    Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan)
    splineObj.Update

    ' Find the current FitTolerance value
    Dim currFitTolerance As Double
    currFitTolerance = splineObj.FitTolerance
    MsgBox "The current FitTolerance is " & currFitTolerance, vbInformation, "FitTolerance Example"

    ' Change the fit tolerance value
    splineObj.FitTolerance = 5
    splineObj.Update
    MsgBox "The FitTolerance is now " & splineObj.FitTolerance, vbInformation, "FitTolerance Example"

End Sub


FontFile Method Example
Sub Example_FontFile()

    Dim textStyle1 As ZcadTextStyle
    Dim currFontFile As String
    Dim newFontFile As String

    Set textStyle1 = ThisDrawing.ActiveTextStyle

    ' Retrieve the current FontFile value
    currFontFile = textStyle1.fontFile
    MsgBox "The current value for FontFile is " & currFontFile, vbInformation, "FontFile Example"

    ' Change the value for FontFile
    newFontFile = "C:\Program Files\ZWCAD 2023\Fonts\simplex.shx"
    textStyle1.fontFile = newFontFile
    MsgBox "The new value for FontFile is " & textStyle1.fontFile, vbInformation, "FontFile Example"

End Sub


ForceLineInside Method Example
Sub Example_ForceLineInside()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim CurrentValue As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 5: TextPoint(1) = 6: TextPoint(2) = 0

      ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    DimPointAngularObj.Update
    ThisDrawing.Application.ZoomAll

    ' Read and display current line suppression information
    CurrentValue = IIf(DimPointAngularObj.ForceLineInside, "are", "are not")
    MsgBox "Dimension lines " & CurrentValue & " forced between the extension lines"

    ' Do not force the display of dimension lines between the extension lines (default)
    DimPointAngularObj.ForceLineInside = False
    DimPointAngularObj.Update
    ThisDrawing.Regen zcAllViewports
    MsgBox "Dimension lines are not forced between the extension lines"

End Sub


FractionFormat Method Example
Sub Example_FractionFormat()
    'This example creates an aligned dimension in model space and
    ' uses FractionFormat to cycle through some fractional formats
    ' for the dimension.
    ' * Note the appearance of the "1/2" component of the dimension

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 7.5: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)

    dimObj.UnitsFormat = zcDimLArchitectural
    dimObj.FractionFormat = zcDiagonal
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The dimension format is now set to diagonal"

    dimObj.FractionFormat = zcHorizontal
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The dimension format is now set to horizontal"

    dimObj.FractionFormat = zcNotStacked
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The dimension format is now set to Change format to NotStacked"

End Sub


Freeze Method Example
Sub Example_Freeze()

    Dim layerObj As ZcadLayer
    Set layerObj = ThisDrawing.Layers.Add("Freeze")

    GoSub test
    layerObj.Freeze = Not (layerObj.Freeze)

    GoSub test
    Exit Sub

test:
    If layerObj.Freeze Then
        MsgBox "Layer " & layerObj.Name & " is frozen.", , "Freeze Example"
    Else
        MsgBox "Layer " & layerObj.Name & " is thawed.", , "Freeze Example"
    End If
    Return

End Sub


FullName Method Example
Sub Example_FullName()
    ' Find the full name of current document file including path.
    ' (If the document has not been saved, this name will be blank.)

    Dim docName As String
    docName = ThisDrawing.FullName
    MsgBox "The full name of the current drawing is " & docName, , "FullName Example"

    ' Find the full name of application
    Dim appName As String
    appName = ThisDrawing.Application.FullName
    MsgBox "The full name of the current application is " & appName, , "FullName Example"

End Sub


GenerateUsageData Method Example
Sub Example_GenerateUsageData()

    Dim MyLayers As ZcadLayers
    Set MyLayers = ThisDrawing.Layers
    MyLayers.GenerateUsageData
    Dim MyLayerObj As ZcadLayer
    For Each MyLayerObj In ThisDrawing.Layers
    MsgBox (MyLayerObj.Used)
    Next MyLayerObj

End Sub


GetAcadState Method Example
Sub Example_GetAcadState()

    Dim State As ZcadState
    Set State = Application.GetZcadState
    If State.IsQuiescent Then
        MsgBox "ZWCAD is quiescent."
    Else
        MsgBox "ZWCAD is not quiescent."
    End If

End Sub


GetAngle Method Example
Sub Example_GetAngle()
    ' This example demonstrates 4 different ways to retrieve
    ' an angle from the user using the GetAngle method.

    Dim retAngle As Double

    ' Return the angle in radians with a prompt
    retAngle = ThisDrawing.Utility.GetAngle(, "Enter an angle: ")
    MsgBox "The angle entered was " & retAngle, , "GetAngle Example"

    ' Return the angle in radians without any prompt
    retAngle = ThisDrawing.Utility.GetAngle()
    MsgBox "The angle entered was " & retAngle, , "GetAngle Example"

    ' Return the angle in radians with a prompt and an angle base point
    Dim basePnt(0 To 2) As Double
    basePnt(0) = 2#: basePnt(1) = 2#: basePnt(2) = 0#
    retAngle = ThisDrawing.Utility.GetAngle(basePnt, "Enter an angle: ")
    MsgBox "The angle entered was " & retAngle, , "GetAngle Example"

    ' Return the angle in radians with an angle base point but no prompt
    retAngle = ThisDrawing.Utility.GetAngle(basePnt)
    MsgBox "The angle entered was " & retAngle, , "GetAngle Example"

End Sub


GetAttributes Method Example
Sub Example_GetAttributes()

    ' Create the block
    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 0#: insertionPnt(1) = 0#: insertionPnt(2) = 0#
    On Error Resume Next

    Dim newBlock As ZcadBlock
    BlockObjName = "New_blockName"
    Err.Clear
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, BlockObjName)
    If Err <> 0 Then
      ThisDrawing.Blocks.Item(BlockObjName).Delete
      Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, BlockObjName)
    End If

    ' Define the attribute definition
    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As ZcAttributeMode
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String
    height = 1#
    mode = zcAttributeModeVerify
    prompt = "Attribute Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "Attribute Tag"
    value = "Attribute Value"

    ' Create the attribute definition object in model space
    Set attributeObj = blockObj.AddAttribute(height, mode, prompt, insertionPoint, tag, value)

    On Error GoTo 0
    ' Insert the block
    Dim blockRefObj As ZcadBlockReference
    insertionPnt(0) = 100#: insertionPnt(1) = 100#: insertionPnt(2) = 0
    Set blockRefObj = ThisDrawing.ModelSpace.InsertBlock(insertionPnt, BlockObjName, 1#, 1#, 1#, 0)
    ThisDrawing.Regen zcActiveViewport

    ' Get the attributes for the block reference
    Dim varAttributes As Variant
    varAttributes = blockRefObj.GetAttributes
    Dim temp As String
    Dim i As Integer
    For i = LBound(varAttributes) To UBound(varAttributes)
        temp = temp + "Tag: " & varAttributes(i).TagString & vbCrLf & "Value: " & varAttributes(i).TextString
    Next

    MsgBox temp

    Dim newvarAttributes As Variant
    newvarAttributes = blockRefObj.GetAttributes
    newvarAttributes(0).TextString = "New_test"
    temp = ""
    For i = LBound(varAttributes) To UBound(varAttributes)
      temp = temp + "Tag: " & newvarAttributes(i).TagString & vbCrLf & "Value: " & newvarAttributes(i).TextString
    Next

    MsgBox temp

End Sub


GetBoundingBox Method Example
Sub Example_GetBoundingBox()
    ' This example creates an arc in model space. It then finds the
    ' bounding box for the arc and displays the corners of the box.

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double
    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Application.ZoomAll
    Dim minExt As Variant
    Dim maxExt As Variant
    arcObj.GetBoundingBox minExt, maxExt

    ' Print the min and max extents
    MsgBox "The extents of the bounding box for the arc are:" & vbCrLf _
         & "Min Extent: " & minExt(0) & "," & minExt(1) & "," & minExt(2) _
         & vbCrLf & "Max Extent: " & maxExt(0) & "," & maxExt(1) & "," & maxExt(2), vbInformation, "GetBoundingBox Example"

End Sub


GetBulge Method Example
Sub Example_GetBulge()

    Dim lwplineObj As ZcadLWPolyline
    Dim points(0 To 5) As Double

    ' Establish the points for the Polyline
    points(0) = 3: points(1) = 7
    points(2) = 9: points(3) = 2
    points(4) = 3: points(5) = 5

    ' Create the polyline in model space
    Set lwplineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)
    ThisDrawing.Application.ZoomAll

    ' Find the bulge of the third segment
    Dim currentBulge As Double
    currentBulge = lwplineObj.GetBulge(0)
    MsgBox "The bulge for the third segment is " & lwplineObj.GetBulge(0), , "GetBulge Example"

    ' Change the bulge of the third segment
    lwplineObj.SetBulge 0, -0.5
    lwplineObj.Update
    MsgBox "The bulge for the third segment is now " & lwplineObj.GetBulge(0), , "GetBulge Example"

End Sub


GetConstantAttributes Method Example
Sub Example_GetConstantAttributes()

    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 0#: insertionPnt(1) = 0#: insertionPnt(2) = 0#
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "New_Block")

    ' Define the attribute definition
    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim tag As String
    Dim value As String
    height = 1#
    mode = zcAttributeModeConstant
    prompt = "Constant Prompt"
    insertionPnt(0) = 5#: insertionPnt(1) = 5#: insertionPnt(2) = 0#
    tag = "Constant Tag"
    value = "Constant Value"

    ' Create the attribute definition object on the block
    Set attributeObj = blockObj.AddAttribute(height, mode, prompt, insertionPnt, tag, value)
    ZoomAll

    ' Insert the block into the drawing
    Dim blockRefObj As ZcadBlockReference
    insertionPnt(0) = 2#: insertionPnt(1) = 2#: insertionPnt(2) = 0
    Set blockRefObj = ThisDrawing.ModelSpace.InsertBlock(insertionPnt, "New_Block", 1#, 1#, 1#, 0)

    ' Get the constant attribute definition from the block
    Dim queryAttribute As Variant
    queryAttribute = blockRefObj.GetConstantAttributes
    Dim count As Integer
    count = UBound(queryAttribute) - LBound(queryAttribute) + 1
    MsgBox "The block reference has " & count & " constant attributes."

End Sub


GetControlPoint Method Example
Sub Example_GetControlPoint()

    ' Create the spline
    Dim splineObj As ZcadSpline
    Dim points(0 To 8) As Double

    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 1: points(1) = 1: points(2) = 0
    points(3) = 5: points(4) = 5: points(5) = 0
    points(6) = 10: points(7) = 0: points(8) = 0
    ' Create the spline in model space
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)

    ' Display the coordinates of the first control point
    Dim controlPoint As Variant
    controlPoint = splineObj.GetControlPoint(0)
    MsgBox "Control point 1 is at " & controlPoint(0) & ", " & controlPoint(1) & ", " & controlPoint(2), , "GetControlPoint Example"

    ' Change the coordinate of the first fit point
    controlPoint(0) = 0: controlPoint(1) = 3: controlPoint(2) = 0
    splineObj.SetControlPoint 0, controlPoint
    splineObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "Control point 1 is now at " & controlPoint(0) & ", " & controlPoint(1) & ", " & controlPoint(2), , "GetControlPoint Example"

End Sub


GetCorner Method Example
Sub Example_GetCorner()
    ' This example provides a base point and prompts the user to
    ' input the second point to make a rectangle.

    Dim returnPnt As Variant
    Dim basePnt(0 To 2) As Double
    basePnt(0) = 2#: basePnt(1) = 2#: basePnt(2) = 0#

    ' Prompt the user to pick second point and returns the point
    returnPnt = ThisDrawing.Utility.GetCorner(basePnt, "Enter Other corner: ")

    ' Display the point picked
    MsgBox "The point picked was " & returnPnt(0) & ", " & returnPnt(1) & ", " & returnPnt(2), , "GetCorner Example"

End Sub


GetCustomByIndex Method Example
Sub Example_GetCustomByIndex()

    Dim Key As String
    Dim Value As String
    Dim Key1 As String
    Dim Value1 As String
    Dim CustomProperty As String
    Dim PropertyValue As String
    Dim CustomProperty1 As String
    Dim PropertyValue1 As String

    CustomProperty = "ZWCAD"
    PropertyValue = "Test"
    CustomProperty1 = "ZW"
    PropertyValue1 = "Test1"
    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty, PropertyValue
    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty1, PropertyValue1
    ThisDrawing.SummaryInfo.GetCustomByIndex 0, Key, Value
    Key1 = CustomProperty1
   ThisDrawing.SummaryInfo.GetCustomByKey Key1, Value1

    MsgBox "The custom drawing properties are " & vbCrLf & _
            "First property name = " & Key & vbCrLf & _
            "First property value = " & Value & vbCrLf & _
            "Second property name = " & Key1 & vbCrLf & _
            "Second property value = " & Value1 & vbCrLf

End Sub


GetCustomByKey Method Example
Sub Example_GetCustomByKey()

    Dim Key As String
    Dim Value As String
    Dim Key1 As String
    Dim Value1 As String
    Dim CustomProperty As String
    Dim PropertyValue As String
    Dim CustomProperty1 As String
    Dim PropertyValue1 As String

    CustomProperty = "ZWCAD"
    PropertyValue = "Test"
    CustomProperty1 = "ZW"
    PropertyValue1 = "Test1"

    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty, PropertyValue
    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty1, PropertyValue1
    ThisDrawing.SummaryInfo.GetCustomByIndex 0, Key, Value
    Key1 = CustomProperty1
    ThisDrawing.SummaryInfo.GetCustomByKey Key1, Value1
    MsgBox "The custom drawing properties are " & vbCrLf & _
            "First property name = " & Key & vbCrLf & _
            "First property value = " & Value & vbCrLf & _
            "Second property name = " & Key1 & vbCrLf & _
            "Second property value = " & Value1 & vbCrLf

End Sub


GetCustomScale Method Example
Sub Example_GetCustomScale()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "Test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    Dim msg As String
    Dim Numerator As Double, Denominator As Double
    Dim Measurement As String

    ' Display current scale information
    GoSub DISPLAY_SCALE_INFO

    ' Modify scale
    Numerator = 2
    Denominator = 4
    PlotConfiguration.SetCustomScale Numerator, Denominator
    ThisDrawing.Regen zcAllViewports

    ' Display new scale information
    GoSub DISPLAY_SCALE_INFO

    Exit Sub

DISPLAY_SCALE_INFO:

    msg = vbCrLf & vbCrLf
    msg = msg & PlotConfiguration.Name & vbCrLf

    ' Get scale information
    PlotConfiguration.GetCustomScale Numerator, Denominator

    ' Are we using inches or millimeters
    Measurement = IIf(PlotConfiguration.PaperUnits = zcInches, " inch(es)", " millimeter(s)")

    ' Format for display
    msg = msg & vbTab & "Contains " & Numerator & Measurement & vbCrLf
    msg = msg & vbTab & "Contains " & Denominator & " Drawing units" & vbCrLf

    ' Display custom scale information
    MsgBox "Custom scale information for the current drawing is: " & msg
    Return

End Sub


GetDistance Method Example
Sub Example_GetDistance()
    ' This example returns the distance entered by the user.

    Dim returnDist As Double
    Dim basePnt(0 To 2) As Double
    basePnt(0) = 0#: basePnt(1) = 0#: basePnt(2) = 0#

    ' Return the value entered by user. A prompt is provided.
    returnDist = ThisDrawing.Utility.GetDistance(, "Enter distance: ")
    MsgBox "The distance entered was " & returnDist & vbCrLf & _
            "(Enter the next value without prompting.)", , "GetDistance Example"

    ' Return the value entered by user. No prompt is provided.
    returnDist = ThisDrawing.Utility.GetDistance()
    MsgBox "The distance entered was " & returnDist, , "GetDistance Example"

    ' Return the value entered by user. A base point and prompt are provided.
    returnDist = ThisDrawing.Utility.GetDistance(basePnt, "Enter a distance: ")
    MsgBox "The distance entered was " & returnDist, , "GetDistance Example"

End Sub


GetEntity Method Example
Sub Example_GetEntity()

    ' Create a Ray object in model space
    Dim rayObj As ZcadRay
    Dim basePoint(0 To 2) As Double
    Dim SecondPoint(0 To 2) As Double
    basePoint(0) = 3#: basePoint(1) = 3#: basePoint(2) = 0#
    SecondPoint(0) = 1#: SecondPoint(1) = 3#: SecondPoint(2) = 0#
    Set rayObj = ThisDrawing.ModelSpace.AddRay(basePoint, SecondPoint)

    ' Create a line object in model space
    Dim lineObj As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
    startPoint(0) = 0: startPoint(1) = 0: startPoint(2) = 0
    endPoint(0) = 2: endPoint(1) = 2: endPoint(2) = 0
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)

    ' Create a circle object in model space
    Dim circObj As ZcadCircle
    Dim centerPt(0 To 2) As Double
    Dim radius As Double
    centerPt(0) = 0: centerPt(1) = 0: centerPt(2) = 0
    radius = 10
    Set circObj = ThisDrawing.ModelSpace.AddCircle(centerPt, radius)
    ThisDrawing.Regen zcActiveViewport

    ' Begin the selection
    Dim returnObj As ZcadEntity
    Dim basePnt As Variant
    On Error Resume Next

    ' The following example waits for a selection from the user
RETRY:
    ThisDrawing.Utility.GetEntity returnObj, basePnt, "Select an object"

    If Err <> 0 Then
        Err.Clear
        MsgBox "Program ended.", , "GetEntity Example"
        Exit Sub
    Else
        returnObj.Update
        MsgBox "The object type is: " & returnObj.EntityName, , "GetEntity Example"
        returnObj.Update
    End If

    GoTo RETRY

End Sub


GetExtensionDictionary Method Example
Sub Example_GetExtensionDictionary()
    ' This example creates a Circle object in model space and
    ' adds a new Extension Dictionary to the Circle object

    Dim EDictionary As ZcadDictionary
    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double

    ' Define the Circle object
    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    radius = 5#

    ' Create the Circle object in model space
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)
    ThisDrawing.Application.ZoomAll
    MsgBox "Circle object Extension Dictionary state before: " & circleObj.HasExtensionDictionary

    ' Create an Extension Dictionary for the new Circle
    Set EDictionary = circleObj.GetExtensionDictionary
    MsgBox "Circle object Extension Dictionary state after: " & circleObj.HasExtensionDictionary
End Sub


GetFitPoint Method Example
Sub Example_GetFitPoint()

    ' Create the spline
    Dim splineObj As ZcadSpline
    Dim points(0 To 8) As Double

    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 13: points(7) = 5: points(8) = 0

    ' Create the spline in model space
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

    ' Display the coordinates of the fit points
    Dim fitPoint As Variant
    Dim index As Integer
    For index = 0 To splineObj.NumberOfFitPoints - 1
        fitPoint = splineObj.GetFitPoint(index)
        MsgBox "Fit point " & index + 1 & " is at " & fitPoint(0) & ", " & fitPoint(1) & ", " & fitPoint(2), , "GetFitPoint Example"
    Next

End Sub


GetGridSpacing Method Example
Sub Example_GetGridSpacing()

    Dim viewportObj As ZcadViewport
    Set viewportObj = ThisDrawing.ActiveViewport
    viewportObj.GridOn = True
    ThisDrawing.ActiveViewport = viewportObj
    Dim XSpacing As Double
    Dim YSpacing As Double
    viewportObj.GetGridSpacing XSpacing, YSpacing
    MsgBox "X =" & XSpacing & ", Y =" & YSpacing, , "GetGridSpacing Example"

End Sub


GetInput Method Example
Sub Example_GetInput()
    ' This example prompts for user input of a point. By using the
    ' InitializeUserInput method to define a keyword list, the example can also
    ' return keywords entered by the user.
    On Error Resume Next

    ' Define the valid keywords
    Dim keywordList As String
    keywordList = "Keyword1 Testword2"

    ' Call InitializeUserInput to set up the keywords
    ThisDrawing.Utility.InitializeUserInput 128, keywordList

    ' Get the user input
    Dim returnPnt As Variant
    returnPnt = ThisDrawing.Utility.GetPoint(, "Enter a point(Keyword1, Testword2): ")
    If Err Then
         If StrComp(Err.Description, "User input is a keyword", 1) = 0 Then
         ' One of the keywords was entered
             Dim inputString As String
             Err.Clear
             inputString = ThisDrawing.Utility.GetInput
             MsgBox "You entered the keyword: " & inputString
         Else
             MsgBox "Error selecting the point: " & Err.Description
             Err.Clear
         End If
    Else
        ' Display point coordinates
        MsgBox "The WCS of the point is: " & returnPnt(0) & ", " & returnPnt(1) & ", " & returnPnt(2), , "GetInput Example"
    End If

End Sub


GetInteger Method Example
Sub Example_GetInteger()
    ' This example returns the integer entered by the user.

    Dim returnInt As Integer
    ' Return the value entered by user. A prompt is provided.
    returnInt = ThisDrawing.Utility.GetInteger("Enter an integer: ")
    MsgBox "The integer entered was " & returnInt & vbCrLf & _
            "(Enter the next value without prompting.)", , "GetInteger Example"

    ' Return the value entered by user. No prompt is provided.
    returnInt = ThisDrawing.Utility.GetInteger()
    MsgBox "The integer entered was " & returnInt, , "GetInteger Example"

End Sub


GetInterfaceObject Method Example
Sub Example_GetInterfaceObject()

    Dim obj As Object
    Set obj = ThisDrawing.Application.GetInterfaceObject("mscomdlg.commondialog.1")
    obj.MaxFileSize = 32727
    obj.Flags = 1574404
    obj.ShowOpen
    Dim filename As String
    filename = obj.filename
    MsgBox filename

End Sub


GetKeyword Method Example
Sub Example_GetKeyword()
    ' This example uses Getkeyword to return a keyword entered by the user.
    ' InitializeUserInput establishes the valid keywords.

    ' Define the list of valid keywords
    Dim kwordList As String
    kwordList = "Width Height Depth"
    ThisDrawing.Utility.InitializeUserInput 1, kwordList

    ' Prompt the user to input any of the keywords. Return "Width", "Height" or "Depth" in
    ' the returnString variable depending on whether the user input "W", "H" or "D".
    Dim returnString As String
    returnString = ThisDrawing.Utility.GetKeyword("Enter a keyword (Height)(Width)(Depth): ")
    MsgBox "You entered " & returnString, , "GetKeyword Example"

End Sub


GetLocaleMediaName Method Example
Sub Example_GetLocaleMediaName()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "Test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    ' Refresh the current plot information for
    ' this session.
    PlotConfiguration.RefreshPlotDeviceInfo

    ' List all the valid device names for the system
    Dim plotDevices As Variant
    plotDevices = PlotConfiguration.GetPlotDeviceNames()

    Dim x As Integer
    For x = LBound(plotDevices) To UBound(plotDevices)
        MsgBox plotDevices(x)
    Next

    ' List all the media names and their localized version
    Dim mediaNames As Variant
    PlotConfiguration.ConfigName = "HP 910"
    mediaNames = PlotConfiguration.GetCanonicalMediaNames()

    For x = LBound(mediaNames) To UBound(mediaNames)
        MsgBox mediaNames(x)
        MsgBox PlotConfiguration.GetLocaleMediaName(mediaNames(x))
    Next

End Sub


GetName Method Example
Sub Example_GetName()
    ' This example creates a dictionary and adds
    ' a custom object to that dictionary. It then
    ' finds the name of the object in the dictionary.

    Dim dictObj As ZcadDictionary
    Set dictObj = ThisDrawing.Dictionaries.Add("TEST_DICTIONARY")

    ' Create the custom object in the dictionary
    Dim keyName As String
    Dim className As String
    Dim customObj As Object
    keyName = "food4"
    className = "ZcDbDictionary"
    Set customObj = dictObj.AddObject(keyName, className)

    ' Find the keyword name of an object in the dictionary
    keyName = dictObj.GetName(customObj)
    MsgBox keyName

End Sub


GetOrientation Method Example
Sub Example_GetOrientation()
    ' This example uses the GetOrientation method to demonstrate three different ways to retrieve
    ' an orientation from the user.

    Dim retOrientation As Double

    ' Return the Orientation in radians with a prompt
    retOrientation = ThisDrawing.Utility.GetOrientation(, "Enter an Orientation: ")
    MsgBox "The Orientation entered was " & retOrientation & vbCrLf & _
            "(Enter the next value without prompting.)", , "GetOrientation Example"

    ' Return the Orientation in radians without any prompt
    retOrientation = ThisDrawing.Utility.GetOrientation()
    MsgBox "The Orientation entered was " & retOrientation, , "GetOrientation Example"

    ' Return the Orientation in radians with a prompt and an Orientation base point
    Dim basePnt(0 To 2) As Double
    basePnt(0) = 2#: basePnt(1) = 2#: basePnt(2) = 0#
    retOrientation = ThisDrawing.Utility.GetOrientation(basePnt, "Enter an Orientation: ")
    MsgBox "The Orientation entered was " & retOrientation, , "GetOrientation Example"

End Sub


GetPaperMargins Method Example
Sub Example_GetPaperMargins()
    ' This example will access the Layouts collection for the current drawing
    ' and list the plot size based on the margins returned from the GetPaperMargins
    ' property for each Layout except model space.

    Dim Layouts As ZcadLayouts, Layout As ZcadLayout
    Dim msg As String
    Dim Measurement As String
    Dim MarginLowerLeft As Variant, MarginUpperRight As Variant

    Dim PaperHeight As Double, PaperWidth As Double
    Dim PlotHeight As Double, PlotWidth As Double

    ' Get layouts collection from document object
    Set Layouts = ThisDrawing.Layouts

    msg = vbCrLf & vbCrLf   ' Start with a space

    ' Get the margin information of every layout in this drawing

    For Each Layout In Layouts
        ' Skip model space
        If Layout.Name = "Model" Then GoTo NEXT_LAYOUT
        ThisDrawing.ActiveLayout = Layout

        msg = msg & Layout.Name & vbCrLf

        ' Get paper size and margin information
        Layout.GetPaperMargins MarginLowerLeft, MarginUpperRight
        Layout.GetPaperSize PaperWidth, PaperHeight

        ' Do plot area calculations

        PlotWidth = PaperWidth - (MarginUpperRight(0) - MarginLowerLeft(0))
        PlotHeight = PaperHeight - (MarginUpperRight(1) - MarginLowerLeft(1))

        ' Are we using inches or millimeters
        Measurement = " millimeter(s)"

        ' Format for display
        msg = msg & vbTab & "The paper size for this layout is: " & PaperWidth & " X " & PaperHeight & Measurement & vbCrLf & vbCrLf

        msg = msg & vbTab & "The paper margins are: " & vbCrLf & _
                            vbTab & vbTab & "Left" & vbTab & "(" & MarginLowerLeft(0) & ")" & Measurement & vbCrLf & _
                            vbTab & vbTab & "Right" & vbTab & "(" & MarginUpperRight(0) & ")" & Measurement & vbCrLf & _
                            vbTab & vbTab & "Top" & vbTab & "(" & MarginUpperRight(1) & ")" & Measurement & vbCrLf & _
                            vbTab & vbTab & "Bottom" & vbTab & "(" & MarginLowerLeft(1) & ")" & Measurement & vbCrLf & vbCrLf
        msg = msg & vbTab & "The paper plot area for this layout is: " & PlotWidth & " X " & PlotHeight & Measurement & vbCrLf

        msg = msg & "_____________________" & vbCrLf

NEXT_LAYOUT:
    Next

    ' Display paper size and margin information
    MsgBox "Paper plot information for the current drawing is: " & msg

End Sub


GetPaperSize Method Example
Sub Example_GetPaperSize()
    ' This example gets the width and height of the default
    ' paper size for your system.

    Dim PaperWidth As Double
    Dim PaperHeight As Double

    ThisDrawing.ActiveLayout.GetPaperSize PaperWidth, PaperHeight

    MsgBox "The default paper size is " & vbCrLf & _
            "Width : " & PaperWidth & vbCrLf & _
            "Height: " & PaperHeight

End Sub


GetPlotDeviceNames Method Example
Sub Example_GetPlotDeviceNames()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "Test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    ' Refresh the current plot information for
    ' this session.
    PlotConfiguration.RefreshPlotDeviceInfo

    ' List all the valid device names for the system
    Dim plotDevices As Variant
    plotDevices = PlotConfiguration.GetPlotDeviceNames()

    Dim x As Integer
    For x = LBound(plotDevices) To UBound(plotDevices)
        MsgBox plotDevices(x)
    Next

End Sub


GetPlotStyleTableNames Method Example
Sub Example_GetPlotStyleTableNames()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "Test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    ' Refresh the current plot information for
    ' this session.
    PlotConfiguration.RefreshPlotDeviceInfo

    ' List all the valid device names for the system
    Dim plotDevices As Variant
    plotDevices = PlotConfiguration.GetPlotDeviceNames()

    Dim x As Integer
    For x = LBound(plotDevices) To UBound(plotDevices)
        MsgBox plotDevices(x)
    Next

    Dim styleNames As Variant
    styleNames = PlotConfiguration.GetPlotStyleTableNames()

    For x = LBound(styleNames) To UBound(styleNames)
        MsgBox styleNames(x)
    Next

End Sub


GetPoint Method Example
Sub Example_GetPoint()
    ' This example returns a point entered by the user.

    Dim returnPnt As Variant

    ' Return a point using a prompt
    returnPnt = ThisDrawing.Utility.GetPoint(, "Enter a point: ")
    MsgBox "The WCS of the point is: " & returnPnt(0) & ", " & returnPnt(1) & ", " & returnPnt(2) & vbCrLf & _
            "(Enter the next value without prompting.)", , "GetPoint Example"

    ' Return a point, no prompt
    returnPnt = ThisDrawing.Utility.GetPoint
    MsgBox "The WCS of the point is: " & returnPnt(0) & ", " & returnPnt(1) & ", " & returnPnt(2), , "GetPoint Example"

    ' Return a point using a base point and a prompt
    Dim basePnt(0 To 2) As Double
    basePnt(0) = 2#: basePnt(1) = 2#: basePnt(2) = 0#
    returnPnt = ThisDrawing.Utility.GetPoint(basePnt, "Enter a point: ")
    MsgBox "The WCS of the point is: " & returnPnt(0) & ", " & returnPnt(1) & ", " & returnPnt(2)

    ' Create a line from the base point and the last point entered
    Dim lineObj As ZcadLine
    Set lineObj = ThisDrawing.ModelSpace.AddLine(basePnt, returnPnt)
    ZoomAll

End Sub


GetReal Method Example
Sub Example_GetReal()
    ' This example returns the Real entered by the user.

    Dim returnReal As Double

    ' Return the value entered by user. A prompt is provided.
    returnReal = ThisDrawing.Utility.GetReal("Enter an Real: ")
    MsgBox "The real entered was " & returnReal & vbCrLf & _
            "(Enter the next value without prompting.)", , "GetReal Example"

    ' Return the value entered by user. No prompt is provided.
    returnReal = ThisDrawing.Utility.GetReal()
    MsgBox "The real entered was " & returnReal, , "GetReal Example"

End Sub


GetSnapSpacing Method Example
Sub Example_GetSnapSpacing()

    Dim viewportObj As ZcadViewport
    Set viewportObj = ThisDrawing.ActiveViewport
    viewportObj.GridOn = True
    ThisDrawing.ActiveViewport = viewportObj
    Dim XSpacing As Double
    Dim YSpacing As Double
    viewportObj.GetSnapSpacing XSpacing, YSpacing
    MsgBox "X =" & XSpacing & ", Y =" & YSpacing, , "GetSnapSpacing Example"

End Sub


GetString Method Example
Sub Example_GetString()
    ' This example demonstrates different ways of returning a string
    ' entered by a user.

    Dim returnString As String

    ' Prompt & Input cannot contain blanks
    returnString = ThisDrawing.Utility.GetString(False, "Enter text (a space or  terminates input): ")
    MsgBox "The string entered was '" & returnString & "'", , "GetString Example"

    ' Prompt & Input can contain blanks
    returnString = ThisDrawing.Utility.GetString(True, "Enter text ( terminates input):")
    MsgBox "The string entered was '" & returnString & "'", , "GetString Example"

    ' Prompt & Input can contain blanks, but not an empty string
    Dim NoNull As Integer
    NoNull = 1    ' Disallow null
    ThisDrawing.Utility.InitializeUserInput NoNull
    returnString = ThisDrawing.Utility.GetString(True, "Enter text ( terminates input): ")
    MsgBox "The string entered was '" & returnString & "'", , "GetString Example"

End Sub


GetSubEntity Method Example
Sub Example_GetSubEntity()
    ' This example prompts the user to select on object on the screen with a mouse click,
    ' and returns some information about the selected object.

    Dim Object As Object
    Dim PickedPoint As Variant, TransMatrix As Variant, ContextData As Variant
    Dim HasContextData As String

    On Error GoTo NOT_ENTITY

TRYAGAIN:

    MsgBox "Use the mouse to click on an object in the current drawing after dismissing this dialog box."

    ' Get information about selected object
    ThisDrawing.Utility.GetSubEntity Object, PickedPoint, TransMatrix, ContextData

    ' Process and display selected object properties
    HasContextData = IIf(VarType(ContextData) = vbEmpty, " does not ", " does ")

    MsgBox "The object you chose was an: " & TypeName(Object) & vbCrLf & _
            "Your point of selection was: " & PickedPoint(0) & ", " & _
                                              PickedPoint(1) & ", " & _
                                              PickedPoint(2) & vbCrLf & _
            "This object" & HasContextData & "have nested objects."

    Exit Sub

NOT_ENTITY:
    ' If you click on empty space or do not select an entity,
    ' this error will be generated
    If MsgBox("You have not selected an object.  Click OK to try again.", _
               vbOKCancel & vbInformation) = vbOK Then
        Resume TRYAGAIN
    End If
End Sub


GetUCSMatrix Method Example
Sub Example_GetUCSMatrix()

    Dim ucsObj As ZcadUCS
    Dim origin(0 To 2) As Double
    Dim xAxisPoint(0 To 2) As Double
    Dim yAxisPoint(0 To 2) As Double

    origin(0) = 2: origin(1) = 2: origin(2) = 0
    xAxisPoint(0) = 3: xAxisPoint(1) = 2: xAxisPoint(2) = 0
    yAxisPoint(0) = 2: yAxisPoint(1) = 3: yAxisPoint(2) = 0

    Set ucsObj = ThisDrawing.UserCoordinateSystems.Add(origin, xAxisPoint, yAxisPoint, "UCS11")
    ThisDrawing.ActiveUCS = ucsObj
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

    ' Create a circle using WCS coordinates
    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 5: center(1) = 5: center(2) = 0
    radius = 10
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(center, radius)
    ZoomAll

    ' Get the UCS transformation matrix
    Dim TransMatrix As Variant
    TransMatrix = ucsObj.GetUCSMatrix()

    ' Transform the circle to the UCS coordinates
    MsgBox "Transform the circle.", , "GetUCSMatrix"
    circleObj.TransformBy (TransMatrix)
    circleObj.Update

    MsgBox "The circle is transformed.", , "GetUCSMatrix"

End Sub


GetVariable Method Example
Sub Example_GetVariable()
    ' This example finds the current setting of the
    ' system variable FILLMODE.

    Dim sysVarName As String
    Dim varData As Variant
    sysVarName = "FILLMODE"
    varData = ThisDrawing.GetVariable(sysVarName)
    MsgBox sysVarName & " = " & varData, , "GetVariable Example"

End Sub


GetWidth Method Example
Sub Example_GetWidth()

    Dim lwplineObj As ZcadLWPolyline
    Dim points(0 To 5) As Double

    ' Establish the points for the Polyline
    points(0) = 3: points(1) = 7
    points(2) = 9: points(3) = 2
    points(4) = 3: points(5) = 5

    ' Create the polyline in model space
    Set lwplineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)

    ' Get the width of 1st segment of the polyline
    Dim StartWidth As Double, EndWidth As Double
    lwplineObj.GetWidth 0, StartWidth, EndWidth
    MsgBox "Startwidth:" & StartWidth & vbCrLf & "EndWidth:" & EndWidth

    ' Set the width of 1st segment of the polyline
    lwplineObj.SetWidth 0, 0.5, 1
    lwplineObj.Update

    ThisDrawing.Application.ZoomAll

End Sub


GetWindowToPlot Method Example
Sub Example_GetWindowToPlot()

    Dim X1 As Variant
    Dim X2 As Variant
    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "Test"
    End If
    Set PlotConfiguration = PlotConfigurations(0)
    Dim point1 As Variant, point2 As Variant

    ' Get first point in window
    point1 = ThisDrawing.Utility.GetPoint(, "Click the lower-left of the window to plot.")

    ' Get second point in window
    point2 = ThisDrawing.Utility.GetPoint(, "Click the upper-right of the window to plot.")
    ReDim Preserve point1(0 To 1)
    ReDim Preserve point2(0 To 1)

    ' Send information about window to current layout
    ThisDrawing.ActiveLayout.SetWindowToPlot point1, point2

    ' Read back window information
    ThisDrawing.ActiveLayout.GetWindowToPlot X1, X2

    MsgBox "Press any key to plot the following window:" & vbCrLf & vbCrLf & _
           "Lower Left: " & X1(0) & ", " & X1(1) & vbCrLf & _
           "Upper Right: " & X2(0) & ", " & X2(1)

    ' Make sure the instruction is to plot a view, not some other plot style
    ThisDrawing.ActiveLayout.PlotType = zcWindow

    ' Send Plot To Window
    ThisDrawing.Plot.DisplayPlotPreview zcFullPreview

End Sub


GetXData Method Example
Sub Example_SetAndGetXData()
    ' This example creates an arc and attaches extended data to that arc.

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230# * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Application.ZoomAll

    ' Initialize all the xdata values. Note that first data in the list should be
    ' application name and first datatype code should be 1001
    Dim DataType(0 To 9) As Integer
    Dim Data(0 To 9) As Variant
    Dim reals3(0 To 2) As Double
    Dim worldPos(0 To 2) As Double

    DataType(0) = 1001: Data(0) = "Test_Application"
    DataType(1) = 1000: Data(1) = "This is a test for xdata"
    DataType(2) = 1003: Data(2) = "0"
    DataType(3) = 1040: Data(3) = 1.23479137438413E+40
    DataType(4) = 1041: Data(4) = 1237324938
    DataType(5) = 1070: Data(5) = 32767
    DataType(6) = 1071: Data(6) = 32767
    DataType(7) = 1042: Data(7) = 10

    reals3(0) = -100.23: reals3(1) = 100.23: reals3(2) = -20
    DataType(8) = 1010: Data(8) = reals3

    worldPos(0) = 200.23: worldPos(1) = 200.23: worldPos(2) = -10
    DataType(9) = 1011: Data(9) = worldPos

    ' Attach the xdata to the arc
    arcObj.SetXData DataType, Data

    ' Return the xdata for the arc
    Dim xdataOut As Variant
    Dim xtypeOut As Variant
    arcObj.GetXData "", xtypeOut, xdataOut

End Sub


GetXRecordData Method Example
Sub Example_GetXRecordData()

    Dim TrackingDictionary As ZcadDictionary, TrackingXRecord As ZcadXRecord
    Dim XRecordDataType As Variant, XRecordData As Variant
    Dim XRDT As Variant, XRD As Variant
    Dim ArraySize As Long
    Dim msg As String

    Const test = 1
    Const DICTIONARY_NAME = "TestDictionary"
    Const XRECORD_NAME = "TestXRecord"
    Set TrackingDictionary = ThisDrawing.Dictionaries.Add(DICTIONARY_NAME)
    Set TrackingXRecord = TrackingDictionary.AddXRecord(XRECORD_NAME)

    ReDim XRecordDataType(0 To ArraySize) As Integer
    ReDim XRecordData(0 To ArraySize) As Variant

    XRecordDataType(ArraySize) = test
    XRecordData(ArraySize) = CStr(Time)
    TrackingXRecord.SetXRecordData XRecordDataType, XRecordData
    TrackingXRecord.GetXRecordData XRDT, XRD
    MsgBox "XRecordData is :" & XRD(0)

End Sub


Green Method Example
Sub Example_Green()

    ' This example draws a line and returns the RGB values
    Dim fcolor As ZcadZcCmColor
    Set fcolor = ZcadApplication.GetInterfaceObject("ZWCAD.ZcCmColor")
    Call fcolor.SetRGB(30, 100, 200)

    Dim line As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#

    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    line.TrueColor = fcolor
    line.Update
    ThisDrawing.Application.ZoomAll

    Dim retcolor As ZcadZcCmColor
    Set retcolor = line.TrueColor
    MsgBox "Green = " & retcolor.Green

End Sub


Groups Method Example
Sub Example_Groups()

    Dim testGroup As ZcadGroup
    Set testGroup = ThisDrawing.Groups.Add("TEST")
    MsgBox "A new group called " & testGroup.Name & " has been added to the Groups collection.", vbInformation, "Groups Example"

End Sub


Handle Method Example
Sub Example_Handle()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)

    ' Define the circle
    Dim circleobj As ZcadCircle
    Dim pt(0 To 2) As Double
    Dim r As Double
    pt(0) = 5
    pt(1) = 5
    pt(2) = 0
    r = 10
    Set circleobj = ThisDrawing.ModelSpace.AddCircle(pt, r)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

    Dim entHandle As String
    Dim entry As ZcadEntity
    For Each entry In ThisDrawing.ModelSpace
        entHandle = entry.Handle
        entry.Highlight (True)
        MsgBox "The handle of this object is " & entHandle, vbInformation, "Handle Example"
        entry.Highlight (False)
    Next

End Sub


HandleToObject Method Example
Sub Example_HandleToObject()

    Dim splineObj As ZcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim Points(0 To 8) As Double

    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    Points(0) = 1: Points(1) = 1: Points(2) = 0
    Points(3) = 3: Points(4) = 4: Points(5) = 0
    Points(6) = 7: Points(7) = 9: Points(8) = 0

    Set splineObj = ThisDrawing.ModelSpace.AddSpline(Points, startTan, endTan)

    ' Find the handle of the spline
    Dim handle As String
    handle = splineObj.handle
    MsgBox "The handle of the Spline is: " & splineObj.handle, , "HandleToObject Example"

    ' Find an object from a given handle
    Dim tempObj As Object
    Set tempObj = ThisDrawing.HandleToObject(handle)
    tempObj.color = zcBlue
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll
    MsgBox "The Spline is now blue.", , "ObjectIDToObject Example"

End Sub


HasAttributes Method Example
Sub Example_HasAttributes()
    ' This example first creates a block without attributes.
    ' It then inserts the block and checks whether it has attributes.
    ' It then adds attributes to the block and inserts it again.
    ' Then it checks the new block reference for attributes.

    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 0#: insertionPnt(1) = 0#: insertionPnt(2) = 0#
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "Testblock")

    ' Add a circle to the block
    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 0: center(1) = 0: center(2) = 0
    radius = 100
    Set circleObj = blockObj.AddCircle(center, radius)

    ' Insert the block
    Dim blockRefObj As ZcadBlockReference
    insertionPnt(0) = 100#: insertionPnt(1) = 100#: insertionPnt(2) = 0
    Set blockRefObj = ThisDrawing.ModelSpace.InsertBlock(insertionPnt, "Testblock", 1#, 1#, 1#, 0)
    ThisDrawing.Application.ZoomAll

    MsgBox "This block reference " & IIf(blockRefObj.HasAttributes, "has attributes.", "does not have attributes."), , "Has Attributes Example"

    ' Add attributes to the block definition.
    ' Define the attribute definition.
    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String
    height = 1#
    mode = zcAttributeModeVerify
    prompt = "Attribute Prompt"
    insertionPoint(0) = 1#: insertionPoint(1) = 1#: insertionPoint(2) = 0
    tag = "Attribute Tag"
    value = "Attribute Value"

    ' Create the attribute definition
    Set attributeObj = blockObj.AddAttribute(height, mode, prompt, insertionPoint, tag, value)

    ' Insert the block again
    Dim blockRefObj2 As ZcadBlockReference
    insertionPnt(0) = 10#: insertionPnt(1) = 10#: insertionPnt(2) = 0
    Set blockRefObj2 = ThisDrawing.ModelSpace.InsertBlock(insertionPnt, "Testblock", 1#, 1#, 1#, 0)

    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "The first block reference " & IIf(blockRefObj.HasAttributes, "has attributes.", "does not have attributes.") & vbCrLf & _
            "The second block reference " & IIf(blockRefObj2.HasAttributes, "has attributes.", "does not have attributes."), , "Has Attributes Example"

End Sub


HasExtensionDictionary Method Example
Sub Example_HasExtensionDictionary()
    ' This example will iterate through each object in the current drawing and
    ' determine whether that object has an associated Extension Dictionary

    Dim DrawingObject As ZcadEntity
    Dim ExtensionDictionaryResults As String

    ' Make sure this drawing contains objects before continuing
    If ThisDrawing.ModelSpace.Count = 0 Then
        MsgBox "There are no objects in the current drawing."
        Exit Sub
    End If

    For Each DrawingObject In ThisDrawing.ModelSpace
        ' Determine whether object contains Extension Dictionary
        Select Case DrawingObject.HasExtensionDictionary
            Case True
                ExtensionDictionaryResults = ExtensionDictionaryResults & DrawingObject.Name & " has an associated Extension Dictionary" & vbCrLf
            Case False
                ExtensionDictionaryResults = ExtensionDictionaryResults & DrawingObject.Name & " does not have an associated Extension Dictionary" & vbCrLf
        End Select
    Next

    MsgBox ExtensionDictionaryResults

End Sub


HatchStyle Method Example
Sub Example_HatchStyle()

    Dim hatchobj As ZcadHatch
    Dim patternname As String
    Dim patterntype As Long
    Dim bassociativity As Boolean

    ' Define the hatch
    patternname = "ANSI31"
    patterntype = zcHatchPatternTypePreDefined
    bassociativity = True

    ' Create the associative hatch object
    Set hatchobj = ThisDrawing.ModelSpace.AddHatch(patterntype, patternname, bassociativity)

    ' Create the outer loop for the hatch
    Dim outerloop(0 To 1) As ZcadEntity
    Dim center(0 To 2) As Double
    Dim arcobj As ZcadArc
    Dim startangle As Double
    Dim endangle As Double

    center(0) = 5
    center(1) = 3
    center(2) = 0
    startangle = 0
    endangle = 3.141592

    Set outerloop(0) = ThisDrawing.ModelSpace.AddArc(center, 3, starangle, endangle)
    Set arcobj = outerloop(0)
    Set outerloop(1) = ThisDrawing.ModelSpace.AddLine(arcobj.StartPoint, arcobj.EndPoint)

    ' Append the outer loop to the hatch
    hatchobj.AppendOuterLoop (outerloop)

    ' Create the inner loop for the hatch
    Dim innerloop1(0) As ZcadEntity
    Dim innerloop2(0) As ZcadEntity
    center(0) = 5
    center(1) = 4.5
    center(2) = 0

    Set innerloop1(0) = ThisDrawing.ModelSpace.AddCircle(center, 0.5)
    Set innerloop2(0) = ThisDrawing.ModelSpace.AddCircle(center, 1)

    ' Append the inner loop to the hatch
    hatchobj.AppendInnerLoop (innerloop1)
    hatchobj.AppendInnerLoop (innerloop2)

    ' Set the scale of the hatch pattern
    hatchobj.PatternScale = 0.1

    ' Set the angle of the hatch pattern
    hatchobj.PatternAngle = 1.57

    ' Set the hatch style to normal
    hatchobj.HatchStyle = zcHatchStyleNormal

    hatchobj.Evaluate
    ThisDrawing.Regen zcActiveViewport

End Sub


Height Method Example
Sub Example_Height()
    ' This example creates a text object in model space.
    ' It then changes the height of the text object.

    Dim mtextObj As ZcadMText
    Dim width As Double
    Dim text As String
    Dim corner(0 To 2) As Double

    corner(0) = 3#: corner(1) = 3#: corner(2) = 0#
    width = 3
    text = "This is a text String."
    ' Creates a MText object in model space
    Set mtextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)
    mtextObj.Height = 5
    mtextObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The mtext height is " & mtextObj.Height, vbInformation, "Height Example"

    ' Change the value of the Height to 0.5
    mtextObj.Height = 0.5
    mtextObj.Update
    MsgBox "The text height is set to " & mtextObj.Height, vbInformation, "Height Example"

End Sub


HelpString Method Example
Sub Example_HelpString()

    Dim currMenuGroup As ZcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new menu
    Dim newMenu As ZcadPopupMenu
    Set newMenu = currMenuGroup.Menus.Add("TestMenu")

    ' Add a menu item to the new menu
    Dim newMenuItem As ZcadPopupMenuItem
    Dim openMacro As String

    ' Assign the macro string the VB equivalent of " _open "
    openMacro = Chr(95) & "open" & Chr(32)

    Set newMenuItem = newMenu.AddMenuItem(newMenu.Count + 1, "Open", openMacro)

    ' Display the menu on the menu bar
    newMenu.InsertInMenuBar (ThisDrawing.Application.MenuBar.Count + 1)

    MsgBox newMenuItem.HelpString
    newMenuItem.HelpString = "Open a file"
    MsgBox newMenuItem.HelpString

End Sub


Highlight Method Example
Sub Example_Highlight()
    ' This example creates several objects in model space.
    ' It then iterates through model space, highlights each
    ' object, and displays its Entity Name.

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)

    Dim lineObj As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    ' Define the start and end points for the line
    startPoint(0) = 2#: startPoint(1) = 9#: startPoint(2) = 0#
    endPoint(0) = 50#: endPoint(1) = 60#: endPoint(2) = 0#

    ' Create the line in model space
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)

    Dim circleObj As ZcadCircle
    Dim centerPoint1(0 To 2) As Double
    Dim radius1 As Double

    ' Define the circle
    centerPoint1(0) = 10#: centerPoint1(1) = 10#: centerPoint1(2) = 0#
    radius1 = 10#

    ' Create the Circle object in model space
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint1, radius1)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

    ' Iterate through the model space collection and
    ' highlight each object.
    Dim entName As String
    Dim entry As ZcadEntity
    For Each entry In ThisDrawing.ModelSpace
        entName = entry.EntityName
        entry.Highlight (True)
        MsgBox "The name of this object is " & entName, vbInformation, "Highlight Example"
        entry.Highlight (False)
    Next

End Sub


HorizontalTextPosition Method Example
Sub Example_HorizontalTextPosition()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim CurrentValue As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 11: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 16: TextPoint(1) = 16: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

    ' Read and display current text position
    Select Case DimPointAngularObj.HorizontalTextPosition
        Case zcHorzCentered:        CurrentValue = "centered"
        Case zcFirstExtensionLine:  CurrentValue = "aligned to first extension line"
        Case zcSecondExtensionLine: CurrentValue = "aligned to second extension line"
        Case zcOverFirstExtension:  CurrentValue = "aligned over first extension line"
        Case zcOverSecondExtension: CurrentValue = "aligned over second extension line"
    End Select
    MsgBox "The dimension is " & CurrentValue

    ' Force the alignment of the dimension text to the first extension line
    DimPointAngularObj.HorizontalTextPosition = zcFirstExtensionLine
    DimPointAngularObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "Dimension text is now aligned to the first extension line"

End Sub


HWND Method Example
Sub Example_HWND()

    If Documents.Count = 0 Then
        MsgBox "There are no open documents!"
        Exit Sub
    End If
    MsgBox "The HWND of the active document is: " & ActiveDocument.HWND

End Sub


HyperlinkBase Method Example
Sub Example_HyperlinkBase()

    ThisDrawing.SummaryInfo.Author = "Eason"
    ThisDrawing.SummaryInfo.Comments = "Developer Help documentation"
    ThisDrawing.SummaryInfo.HyperlinkBase = "http://www.zwsoft.com"
    ThisDrawing.SummaryInfo.Keywords = "VBA"
    ThisDrawing.SummaryInfo.LastSavedBy = "JD"
    ThisDrawing.SummaryInfo.RevisionNumber = "2023"
    ThisDrawing.SummaryInfo.Subject = "VBA COM"
    ThisDrawing.SummaryInfo.Title = "ZWCAD2023"

    Author = ThisDrawing.SummaryInfo.Author
    Comments = ThisDrawing.SummaryInfo.Comments
    HLB = ThisDrawing.SummaryInfo.HyperlinkBase
    KW = ThisDrawing.SummaryInfo.Keywords
    LSB = ThisDrawing.SummaryInfo.LastSavedBy
    RN = ThisDrawing.SummaryInfo.RevisionNumber
    Subject = ThisDrawing.SummaryInfo.Subject
    Title = ThisDrawing.SummaryInfo.Title
    MsgBox "The standard drawing properties are " & vbCrLf & _
            "Author = " & Author & vbCrLf & _
            "Comments = " & Comments & vbCrLf & _
            "HyperlinkBase = " & HLB & vbCrLf & _
            "Keywords = " & KW & vbCrLf & _
            "LastSavedBy = " & LSB & vbCrLf & _
            "RevisionNumber = " & RN & vbCrLf & _
            "Subject = " & Subject & vbCrLf & _
            "Title = " & Title & vbCrLf

End Sub


Import Method Example
Sub Example_Import()

    ' Create the circle for visual representation
    Dim circleObj As ZcadCircle
    Dim centerPt(0 To 2) As Double
    Dim radius As Double
    centerPt(0) = 100: centerPt(1) = 100: centerPt(2) = 0
    radius = 100
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPt, radius)
    circleObj.color = zcRed
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Create an empty selection set
    Dim sset As ZcadSelectionSet
    Set sset = ThisDrawing.SelectionSets.Add("TEST")

    ' Export the current drawing to the file specified above.
    Dim exportFile As String
    exportFile = "C:\test\test"
    ThisDrawing.Export exportFile, "DXF", sset

    ' Open a new drawing
    Dim zcad As ZcadApplication
    Dim newdoc As ZcadDocument
    Set newdoc = ThisDrawing.Application.Documents.Add

    ' Define the import
    Dim importFile As String
    Dim InsertPoint(0 To 2) As Double
    Dim scalefactor As Double
    importFile = "c:\test\test.dxf"
    InsertPoint(0) = 0#: InsertPoint(1) = 0#: InsertPoint(2) = 0#
    scalefactor = 1.5

    ' Import the file
    newdoc.Import importFile, InsertPoint, scalefactor

End Sub


InsertBlock Method Example
Sub Example_InsertBlock()

    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 0#: insertionPnt(1) = 0#: insertionPnt(2) = 0#
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "Testblock")

    ' Add a circle to the block
    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 0: center(1) = 0: center(2) = 0
    radius = 100
    Set circleObj = blockObj.AddCircle(center, radius)

    ' Insert the block
    Dim blockRefObj As ZcadBlockReference
    insertionPnt(0) = 100#: insertionPnt(1) = 100#: insertionPnt(2) = 0
    Set blockRefObj = ThisDrawing.ModelSpace.InsertBlock(insertionPnt, "Testblock", 1#, 1#, 1#, 0)
    ZoomAll

End Sub


InsertInMenuBar Method Example
Sub Example_InsertInMenuBar()
    ' This example creates a new menu called TestMenu and inserts a menu item into it.
    ' Then it displayed on the menu bar.

    Dim currMenuGroup As ZcadMenuGroup
    Dim newMenu As ZcadPopupMenu, newMenuItem As ZcadPopupMenuItem
    Dim openMacro As String

    On Error GoTo ERRORTRAP

    ' Use MenuGroups property to obtain reference to main zcad+ menu
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new menu in this group
    Set newMenu = currMenuGroup.Menus.Add("TestMenu")

    ' Add a menu item to the new menu and
    ' assign an Open macro (VBA equivalent of: " _open ")
    openMacro = Chr(95) & "open" & Chr(32)

    Set newMenuItem = newMenu.AddMenuItem(newMenu.Count + 1, "Open", openMacro)

    ' Display the menu on the menu bar
    newMenu.InsertInMenuBar (ThisDrawing.Application.MenuBar.Count + 1)

    MsgBox "A new menu has been added to the zcad+ menu system!"

    Exit Sub

ERRORTRAP:
    MsgBox "The following error has occurred: " & Err.Description
End Sub


Item Method Example
Sub Example_Item()

    Dim Layers As ZcadLayers
    Dim str As String
    Set Layers = ThisDrawing.Layers
    For I = 0 To Layers.Count - 1
        str = str + Layers.Item(I).Name & vbCrLf
    Next I
    MsgBox str

End Sub


Load Method Example
Sub Example_Load()
    ' This example attempts to load the linetype "CENTER" from
    ' the zwcad.lin file

    Dim linetypeName As String
    linetypeName = "CENTER"

    ' Load "CENTER" line type from zwcad.lin file
    On Error Resume Next
    ThisDrawing.Linetypes.Load linetypeName, "zwcad.lin"

End Sub


LoadShapeFile Method Example
Sub Example_LoadShapeFile()
    ' This example loads a shape file

    Dim shapeFileToLoad As String
    shapeFileToLoad = "c:\Program Files\ZWCAD 2023\Fonts\ltypeshp.shx"

    ' Load the shape file

    ThisDrawing.LoadShapeFile shapeFileToLoad

End Sub


Mirror Method Example
Sub Example_Mirror()

    Dim lineObj As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    ' Define the start and end points for the line
    startPoint(0) = 50#: startPoint(1) = 50#: startPoint(2) = 0#
    endPoint(0) = 100#: endPoint(1) = 100#: endPoint(2) = 0#

    ' Create the line in model space
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    ThisDrawing.Regen

    ' Define the mirror axis
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    point1(0) = 120
    point1(1) = 120
    point1(2) = 0
    point2(0) = 120
    point2(1) = 10
    point2(2) = 0

    ' Mirror the line
    Dim mirrorObj As ZcadLine
    Set mirrorObj = lineObj.Mirror(point1, point2)
    mirrorObj.color = zcBlue
    mirrorObj.Update
    ThisDrawing.Regen
    ZoomAll
    MsgBox "Mirror completed.", , "Mirror Example"

End Sub


Mirror3D Method Example
Sub Example_Mirror3D()
    ' This example creates a Circle in model space, and mirrors the Circle about a plane.

    ' Create the Circle.
    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double

    ' Define the circle
    centerPoint(0) = 10#: centerPoint(1) = 10#: centerPoint(2) = 0#
    radius = 30#

    ' Create the Circle object in model space
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Define the mirroring plane with three points
    Dim mirrorPt1(0 To 2) As Double
    Dim mirrorPt2(0 To 2) As Double
    Dim mirrorPt3(0 To 2) As Double
    mirrorPt1(0) = 100: mirrorPt1(1) = 0: mirrorPt1(2) = 0
    mirrorPt2(0) = 100: mirrorPt2(1) = 200: mirrorPt2(2) = 0
    mirrorPt3(0) = 100: mirrorPt3(1) = 200: mirrorPt3(2) = 200

    ' Mirror the Circle
    Dim mirrorarcObj As ZcadCircle
    Set mirrorarcObj = circleObj.Mirror3D(mirrorPt1, mirrorPt2, mirrorPt3)
    mirrorarcObj.color = zcBlue
    mirrorarcObj.Update

    ' Change the viewing direction of the viewport
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

End Sub


Move Method Example
Sub Example_Move()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    ' Convert the angles in degrees to angles in radians
    startAngleInRadian = startAngleInDegree
    endAngleInRadian = endAngleInDegree
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ZoomAll

    ' Define the points that make up the move vector
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    point1(0) = 0: point1(1) = 0: point1(2) = 0
    point2(0) = 2: point2(1) = 0: point2(2) = 0
    MsgBox "Move the arc 2 units in the X direction.", , "Move Example"

    ' Move the arc
    arcObj.Move point1, point2
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "Move completed.", , "Move Example"

End Sub


Name Method Example
Sub Example_New()

    ThisDrawing.New "zwcad.dwt"

End Sub


ObjectIDToObject Method Example
Sub Example_ObjectIDToObject()
    ' This example creates a spline in model space, and returns the
    ' handle for the spline. Then the spline is returned from the handle and colored.

    ' Create the spline
    Dim splineObj As ZcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim fitPoints(0 To 8) As Double

    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    fitPoints(0) = 1: fitPoints(1) = 1: fitPoints(2) = 0
    fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0
    fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan)

    ZoomAll

    ' Find the objectID of the spline
    Dim objectID As Long
    objectID = splineObj.objectID
    MsgBox "The objectID of the Spline is: " & splineObj.objectID, , "ObjectIDToObject Example"

    ' Find an object from a given objectID
    Dim tempObj As Object
    Set tempObj = ThisDrawing.ObjectIdToObject(objectID)

    ' Now use the newly initialized object variable to color the object
    ' Now use the newly initialized object variable to color the object
    Dim color As ZcadZcCmColor
    Set color = ZcadApplication.GetInterfaceObject("ZWCAD.ZcCmColor")
    Call color.SetRGB(80, 100, 244)

    tempObj.TrueColor = color

    ThisDrawing.Regen zcActiveViewport
    MsgBox "The Spline is now blue.", , "ObjectIDToObject Example"

End Sub


Open Method Example
Sub Example_Open()
    ' The following example opens "C:\ABC.dwg" file.
    ' This document may not exist on your system. Change the document
    ' path and name to reflect a valid ZWCAD document on your system.

    ThisDrawing.Application.Documents.Open ("C:\test.dwg")

End Sub


PlotToDevice Method Example
Sub Example_PlotToDevice()

  Dim currentplot As ZcadPlot
  Set currentplot = ThisDrawing.Plot
  ThisDrawing.ActiveLayout.ConfigName = "PDFCreator"
  ThisDrawing.ActiveLayout.CanonicalMediaName = "A4"
  ThisDrawing.ActiveLayout.StandardScale = zcScaleToFit
  ThisDrawing.Application.ZoomExtents
  currentplot.PlotToDevice

 End Sub


PlotToFile Method Example
Sub Example_PlotToFile()

    Dim currentplot As ZcadPlot
    Set currentplot = ThisDrawing.Plot
    ThisDrawing.ModelSpace.Layout.ConfigName = "DWG TO PDF.pc5"
    ThisDrawing.ModelSpace.Layout.CanonicalMediaName = "ISO_A3_(420.00_x_297.00_MM)"
    ThisDrawing.Application.ZoomExtents
    currentplot.PlotToFile ("D:\")

 End Sub


PolarPoint Method Example
Sub Example_PolarPoint()
    ' This example finds the coordinate of a point that is a given
    ' distance and angle from a base point.

    Dim polarPnt As Variant
    Dim basePnt(0 To 2) As Double
    Dim angle As Double
    Dim distance As Double

    basePnt(0) = 2#: basePnt(1) = 2#: basePnt(2) = 0#
    angle = 0.7
    distance = 5
    polarPnt = ThisDrawing.Utility.PolarPoint(basePnt, angle, distance)

    ' Create a line from the base point to the polar point
    Dim lineObj As ZcadLine
    Set lineObj = ThisDrawing.ModelSpace.AddLine(basePnt, polarPnt)
    ThisDrawing.Regen zcActiveViewport

End Sub


Prompt Method Example
Sub Example_Prompt()
    ' This example will use the Utility object to display a prompt to the
    ' ZWCAD command line.  To see the results after running the example,
    ' switch to ZWCAD and look at the command line.

    ThisDrawing.Utility.prompt "Press any key..."

End Sub


PurgeFitData Method Example
Sub Example_PurgeFitData()

    Dim plineObj As ZcadSpline
    Dim points(0 To 8) As Double

    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 10: points(7) = 0: points(8) = 0

    ' Create the spline in model space
    Set plineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)

    MsgBox "Before the purge there are " & plineObj.NumberOfFitPoints & " fit points.", , "PurgeFitData Example"

    ' Purge the fit data
    plineObj.PurgeFitData
    plineObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "After the purge there are " & plineObj.NumberOfFitPoints & " fit points.", , "PurgeFitData Example"

End Sub


Quit Method Example
Sub Example_Quit()
    ' Warning: This example will quit ZWCAD and VBA.

    ThisDrawing.Application.Quit

End Sub


RealToString Method Example
Sub Example_RealToString()
    ' This example converts values in a given format to their string equivalents.

    Dim unit As Long
    Dim valueAsStr As String
    Dim precision As Integer
    Dim valueAsReal As Double
    precision = 6

    ' Convert a real value 10.5 using Scientific mode to a String
    unit = zcScientific
    valueAsStr = ThisDrawing.Utility.RealToString(10.5, unit, precision)
    MsgBox "10.5 in scientific format is " & valueAsStr, , "RealToString Example"

    ' Convert a real value 10.5 using Decimal mode to a String
    unit = zcDecimal
    valueAsStr = ThisDrawing.Utility.RealToString(10.5, unit, precision)
    MsgBox "10.5 in decimal format is " & valueAsStr, , "RealToString Example"

    ' Convert a real value 10.5 using Engineering mode to a String
    unit = zcEngineering
    valueAsStr = ThisDrawing.Utility.RealToString(10.5, unit, precision)
    MsgBox "10.5 in engineering format is " & valueAsStr, , "RealToString Example"

    ' Convert a real value 10.5 using Architectural mode to a String
    unit = zcArchitectural
    valueAsStr = ThisDrawing.Utility.RealToString(10.5, unit, precision)
    MsgBox "10.5 in architectural format is " & valueAsStr, , "RealToString Example"

    ' Converts a real value 10.5 using fractional mode to a String
    unit = zcFractional
    valueAsStr = ThisDrawing.Utility.RealToString(10.5, unit, precision)
    MsgBox "10.5 in fractional format is " & valueAsStr, , "RealToString Example"

End Sub


RefreshPlotDeviceInfo Method Example
Sub Example_RefreshPlotDeviceInfo()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    ' Refresh the current plot information for
    ' this session.
    PlotConfiguration.RefreshPlotDeviceInfo

    ' List all the valid device names for the system
    Dim plotDevices As Variant
    plotDevices = PlotConfiguration.GetPlotDeviceNames()

    Dim x As Integer
    For x = LBound(plotDevices) To UBound(plotDevices)
        MsgBox plotDevices(x)
    Next

    ' List all the entries in the plot style table
    Dim styleNames As Variant
    styleNames = PlotConfiguration.GetPlotStyleTableNames()

    For x = LBound(styleNames) To UBound(styleNames)
        MsgBox styleNames(x)
    Next

End Sub


Regen Method Example
Sub Example_Regen()
    ' The following example regenerates the complete document
    ThisDrawing.Regen zcAllViewports

    ' The following example regenerates the active viewport in the current document
    ThisDrawing.Regen zcActiveViewport

End Sub


Reload Method Example
Sub Example_Reload()

    On Error Resume Next
    Dim InsertPoint(0 To 2) As Double
    Dim insertedBlock As ZcadExternalReference
    Dim tempBlock As ZcadBlock
    Dim msg As String, PathName As String

    InsertPoint(0) = 100: InsertPoint(1) = 100: InsertPoint(2) = 0
    PathName = "E:\123.dwg"
    Set insertedBlock = ThisDrawing.ModelSpace.AttachExternalReference(PathName, "XREF_IMAGE", InsertPoint, 1, 1, 1, 0, False)
    ThisDrawing.Blocks.Item(insertedBlock.Name).Reload
    ThisDrawing.ActiveViewport.ZoomAll
End Sub


RemoveCustomByIndex Method Example
Sub Example_RemoveCustomByIndex()

    Dim Key As String
    Dim Value As String
    Dim Key1 As String
    Dim Value1 As String
    Dim CustomProperty As String
    Dim PropertyValue As String
    Dim CustomProperty1 As String
    Dim PropertyValue1 As String

    CustomProperty = "ZWCAD"
    PropertyValue = "Test"
    CustomProperty1 = "ZW"
    PropertyValue1 = "Test1"

    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty, PropertyValue
    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty1, PropertyValue1
    ThisDrawing.SummaryInfo.RemoveCustomByIndex (0)
    ThisDrawing.SummaryInfo.GetCustomByIndex 0, Key, Value
    Key1 = CustomProperty1
    ThisDrawing.SummaryInfo.GetCustomByKey Key1, Value1

    MsgBox "The custom drawing properties are " & vbCrLf & _
            "First property name = " & Key & vbCrLf & _
            "First property value = " & Value & vbCrLf & _
            "Second property name = " & Key1 & vbCrLf & _
            "Second property value = " & Value1 & vbCrLf

End Sub


RemoveCustomByKey Method Example
Sub Example_RemoveCustomByKey()

    Dim Key As String
    Dim Value As String
    Dim Key1 As String
    Dim Value1 As String
    Dim CustomProperty As String
    Dim PropertyValue As String
    Dim CustomProperty1 As String
    Dim PropertyValue1 As String

    CustomProperty = "ZWCAD"
    PropertyValue = "Test"
    CustomProperty1 = "ZW"
    PropertyValue1 = "Test1"

    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty, PropertyValue
    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty1, PropertyValue1
    Key1 = CustomProperty1
    ThisDrawing.SummaryInfo.RemoveCustomByKey (Key1)
    ThisDrawing.SummaryInfo.GetCustomByIndex 0, Key, Value
    MsgBox ThisDrawing.SummaryInfo.NumCustomInfo

End Sub


RemoveFromMenuBar Method Example
Sub Example_RemoveFromMenuBar()
    ' This example creates a new menu called TestMenu and inserts a menu item
    ' into it. The menu is then displayed on the menu bar, and then
    ' removed from the menu bar.

    Dim currMenuGroup As ZcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new menu
    Dim newMenu As ZcadPopupMenu
    Set newMenu = currMenuGroup.Menus.Add("TestMenu")

    ' Add a menu item to the new menu
    Dim newMenuItem As ZcadPopupMenuItem
    Dim openMacro As String
    ' Assign the macro string the VB equivalent of " _open "
    openMacro = Chr(95) & "open" & Chr(32)

    Set newMenuItem = newMenu.AddMenuItem(newMenu.Count + 1, "Open", openMacro)

    ' Display the menu on the menu bar
    newMenu.InsertInMenuBar (ThisDrawing.Application.MenuBar.Count + 1)
    GoSub QUERYMENU

    ' Remove the menu from the menu bar
    newMenu.RemoveFromMenuBar
    GoSub QUERYMENU
    Exit Sub

QUERYMENU:
    If newMenu.OnMenuBar Then
        MsgBox "The menu called " & newMenu.Name & " is on the menu bar."
    Else
        MsgBox "The menu called " & newMenu.Name & " is not on the menu bar."
    End If
    Return

End Sub


RemoveItems Method Example
Sub Example_RemoveItems()

    Dim gr As ZcadGroup
    If ThisDrawing.Groups.Count > 0 Then
        Set gr = ThisDrawing.Groups.Item(0)
        Else
        Set gr = ThisDrawing.Groups.Add("New_Group")
    End If

    If gr.Count < 1 Then
        MsgBox "No More Item in this Group"
        Exit Sub
    End If

    Dim rent As ZcadEntity
    Dim Str As String

    Dim rents(0 To 1) As ZcadEntity
    Set rents(0) = gr.Item(0)
    Set rents(1) = gr.Item(1)

    GoSub test

    MsgBox "Now We are Removeing ths first two Entities"
    gr.RemoveItems rents
    gr.Update

    GoSub test
    Exit Sub

test:
    Str = "The remaining Entities in this Group are: "
    For I = 0 To gr.Count - 1
        Set rent = gr.Item(I)
        Str = Str & rent.EntityName & " ,"
    Next
    MsgBox Str
    Return

End Sub


RemoveMenuFromMenuBar Method Example
Sub Example_RemoveMenuFromMenuBar()
    ' This example creates a new menu called TestMenu and inserts a menu item
    ' into it. The menu is displayed on the menu bar, and then
    ' removed from the menu bar.

    Dim currMenuGroup As ZcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new menu
    Dim newMenu As ZcadPopupMenu
    Set newMenu = currMenuGroup.Menus.Add("TestMenu")

    ' Add a menu item to the new menu
    Dim newMenuItem As ZcadPopupMenuItem
    Dim openMacro As String
    ' Assign the macro string the VB equivalent of "ESC ESC _open "
    openMacro = Chr(3) & Chr(3) & Chr(95) & "open" & Chr(32)

    Set newMenuItem = newMenu.AddMenuItem(newMenu.Count + 1, "Open", openMacro)

    ' Display the menu on the menu bar
    newMenu.InsertInMenuBar (ThisDrawing.Application.MenuBar.Count + 1)
    GoSub QUERYMENU

    ' Remove the menu from the menu bar
    currMenuGroup.Menus.RemoveMenuFromMenuBar ("TestMenu")
    GoSub QUERYMENU
    Exit Sub

QUERYMENU:
    If newMenu.OnMenuBar Then
        MsgBox "The menu called " & newMenu.Name & " is on the menu bar."
    Else
        MsgBox "The menu called " & newMenu.Name & " is not on the menu bar."
    End If
    Return

End Sub


Reverse Method Example
Sub Example_Reverse()

    Dim splineObj As ZcadSpline
    Dim points(0 To 8) As Double
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 13: points(7) = 5: points(8) = 0

    ' Create the spline in model space
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    splineObj.Update
    splineObj.Reverse

    ' Get the coordinates from the first control point
    Dim GetControlPoints As Variant
    GetControlPoints = splineObj.GetControlPoint(0)
    MsgBox GetControlPoints(0) & ", " & GetControlPoints(1) & "," & GetControlPoints(2)

End Sub


Rotate Method Example
Sub Example_Rotate()

    Dim plineObj As ZcadLWPolyline
    Dim Points(0 To 5) As Double
    Dim tmpPt(0 To 2) As Double

    Points(0) = 2: Points(1) = 3
    Points(2) = 8: Points(3) = 20
    Points(4) = 100: Points(5) = 100

    Set plineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(Points)
    ThisDrawing.Regen zcActiveViewport

    ' Define the rotation
    Dim basePoint(0 To 2) As Double
    Dim rotationAngle As Double
    basePoint(0) = 100: basePoint(1) = 100: basePoint(2) = 0
    rotationAngle = 3.1415926

    plineObj.Rotate basePoint, rotationAngle
    plineObj.color = zcRed
    plineObj.Update
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "Rotation completed.", , "Rotate Example"

End Sub


Rotate3D Method Example
Sub Example_Rotate3D()

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport

    ' Define the rotation axis with two points
    Dim rotatePt1(0 To 2) As Double
    Dim rotatePt2(0 To 2) As Double
    Dim rotateAngle As Double

    rotatePt1(0) = 8: rotatePt1(1) = 9: rotatePt1(2) = 0
    rotatePt2(0) = 8: rotatePt2(1) = -3: rotatePt2(2) = 0
    rotateAngle = 40
    rotateAngle = rotateAngle * 3.141592 / 180#

    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

    ' Rotate the arc
    arcObj.Rotate3D rotatePt1, rotatePt2, rotateAngle
    arcObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The arc is rotated 40 degrees.", , "Rotate3D Example"

End Sub


RunMacro Method Example
Sub Example_RunMacro()
    ' This example loads a ZVB file and runs a macro
    ' contained in the file using the RunMacro method.
    '
    ' This example uses a ZVB file named drawline.zvb.
    ' You should change the example to use a file on your computer.
    '
    ' * Note: If you open a ZVB file and then run the example to load it, there will be an error
    ' when the ZVB file is unloaded.

    Dim FileName As String

    FileName = "d:\AddLine.zvb"

    ' Load a sample VPBA project ZVB file
    ThisDrawing.Application.LoadZVB FileName

    ' Run the drawline sample macro
    ThisDrawing.Application.RunMacro "Example_AddLine"

    ' Unload the drawline VBA project ZVB file now.
    ThisDrawing.Application.UnloadZVB FileName

    MsgBox "The ZVB file has been run!"

End Sub


Save Method Example
Sub Example_Save()
    ' The following example saves current document

    ThisDrawing.Save

End Sub


SaveAs Method Example
Sub Example_SaveAs()
    ' The following example saves current document as "test.dwg"

    ThisDrawing.SaveAs ("test.dwg")

End Sub


ScaleEntity Method Example
Sub Example_ScaleEntity()
    ' This example creates an arc
    ' and then scales that arc.

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport

    MsgBox "Scale the arc by 0.5", , "ScaleEntity Example"

    ' Define the scale
    Dim basePoint(0 To 2) As Double
    Dim scalefactor As Double
    basePoint(0) = 2: basePoint(1) = 2: basePoint(2) = 0
    scalefactor = 0.5

    ' Scale the arc
    arcObj.ScaleEntity basePoint, scalefactor
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "Scale completed.", , "ScaleEntity Example"

End Sub


SectionSolid Method Example
Sub Example_SectionSolid()

    Dim boxObj As Zcad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double
    center(0) = 5#: center(1) = 5#: center(2) = 0
    length = 5#: width = 7: height = 10#
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)

    Dim pt1(0 To 2) As Double
    Dim pt2(0 To 2) As Double
    Dim pt3(0 To 2) As Double
    pt1(0) = 2.5: pt1(1) = 8.5: pt1(2) = 10
    pt2(0) = 7.5: pt2(1) = 8.5: pt2(2) = 0
    pt3(0) = 7.5: pt3(1) = 1.5: pt3(2) = 0

    Dim sectionobj As ZcadRegion
    Set settionobj = boxObj.SectionSolid(pt1, pt2, pt3)
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ThisDrawing.Regen zcActiveViewport

End Sub


Select Method Example
Sub Example_Select()
    ' This example creates a selection set to select only line in the current drawing

    ' Create the selection set
    Dim objssline As ZcadSelectionSet
    Set objssline = ThisDrawing.SelectionSets.Add("TEST")

    ' Set the filter
    Dim FilterType(0) As Integer
    Dim FilterData(0) As Variant

    FilterType(0) = 0
    FilterData(0) = "Line"

    ' Select all lines in the current drawing by filter
    objssline.Select zcSelectionSetAll, , , FilterType, FilterData

End Sub


SelectAtPoint Method Example
Sub Example_SelectAtPoint()

    Dim ssetObj As ZcadSelectionSet
    Set ssetObj = ThisDrawing.SelectionSets.Add("TEST")
    Dim point(0 To 2) As Double
    point(0) = 100: point(1) = 100: point(2) = 0
    ssetObj.SelectAtPoint point

End Sub


SelectByPolygon Method Example
Sub Example_SelectByPolygon()

    Dim ssetObj As ZcadSelectionSet
    Set ssetObj = ThisDrawing.SelectionSets.Add("TEST")

    Dim mode As Integer
    Dim pointsArray(0 To 5) As Double

    mode = zcSelectionSetFence
    pointsArray(0) = 100: pointsArray(1) = 80: pointsArray(2) = 0
    pointsArray(3) = 200: pointsArray(4) = 80: pointsArray(5) = 0

    ssetObj.SelectByPolygon mode, pointsArray

End Sub


SelectOnScreen Method Example
Sub Example_SelectOnScreen()

    ' Create the selection set
    Dim ssetObj As ZcadSelectionSet
    Set ssetObj = ThisDrawing.SelectionSets.Add("TEST")

    ' Add objects to a selection set by prompting user to select on the screen
    ssetObj.SelectOnScreen

End Sub


SendCommand Method Example
Sub Example_SendCommand()

    ThisDrawing.SendCommand "_Circle" & vbCr & "100,100,0" & vbCr & "100" & vbCr

    ' Refresh view
    ThisDrawing.Regen zcActiveViewport
    MsgBox "A circle command has been sent to the command line of the current drawing."

End Sub


SetBulge Method Example
Sub Example_SetBulge()
    ' This example creates a polyline in model space.
    ' It then finds and changes the bulge for a given segment.

    Dim lwplineObj As ZcadLWPolyline
    Dim points(0 To 5) As Double

    ' Establish the points for the Polyline
    points(0) = 3: points(1) = 7
    points(2) = 9: points(3) = 2
    points(4) = 13: points(5) = 5

    ' Create the polyline in model space
    Set lwplineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)

    ' Find the bulge of the third segment
    Dim currentBulge As Double
    currentBulge = lwplineObj.GetBulge(1)
    MsgBox "The bulge for the first segment is " & lwplineObj.GetBulge(1), , "SetBulge Example"

    ' Change the bulge of the third segment
    lwplineObj.SetBulge 1, -0.5
    lwplineObj.Update
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "The bulge for the first segment is now " & lwplineObj.GetBulge(1), , "SetBulge Example"

End Sub


SetColorBookColor Method Example
Sub Example_SetColorBookColor()

    ' This example draws a line and specifies a color name
    ' from an existing color book.

    Dim FirstColor As ZcadZcCmColor
    Set FirstColor = ZcadApplication.GetInterfaceObject("ZWCAD.ZcCmColor")

    Call FirstColor.SetRGB(80, 100, 244)

    Dim line As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#

    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    line.TrueColor = FirstColor
    line.Update
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    Call FirstColor.SetColorBookColor("RAL CLASSIC", "RAL 1000")
    line.TrueColor = FirstColor
    line.Update

 End Sub


SetControlPoint Method Example
Sub Example_SetControlPoint()

    ' Create the spline
    Dim plineObj As ZcadSpline
    Dim points(0 To 8) As Double

    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline

    points(0) = 1: points(1) = 1: points(2) = 0
    points(3) = 5: points(4) = 5: points(5) = 0
    points(6) = 10: points(7) = 0: points(8) = 0
    ' Create the spline in model space
    Set plineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    ZoomAll

    ' Display the coordinates of the first control point
    Dim controlPoint As Variant
    controlPoint = plineObj.GetControlPoint(0)
    MsgBox "Control point 1 is at " & controlPoint(0) & ", " & controlPoint(1) & ", " & controlPoint(2), , "SetControlPoint Example"

    ' Change the coordinates of the first fit point
    controlPoint(0) = 0: controlPoint(1) = 3: controlPoint(2) = 0
    plineObj.SetControlPoint 0, controlPoint
    plineObj.Update
    MsgBox "Control point 1 is now at " & controlPoint(0) & ", " & controlPoint(1) & ", " & controlPoint(2), , "SetControlPoint Example"

End Sub


SetCustomByIndex Method Example
Sub Example_SetCustomByIndex()

    Dim Key As String
    Dim Value As String
    Dim CustomProperty As String
    Dim PropertyValue As String
    Dim CustomProperty1 As String
    Dim PropertyValue1 As String

    CustomProperty = "ZWCAD"
    PropertyValue = "Test"
    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty, PropertyValue
    ThisDrawing.SummaryInfo.SetCustomByIndex 0, "AB", "CD"
    ThisDrawing.SummaryInfo.GetCustomByIndex 0, Key, Value
    MsgBox "The custom drawing properties are " & vbCrLf & _
            "property name = " & Key & vbCrLf & _
            "property value = " & Value & vbCrLf
End Sub


SetCustomByKey Method Example
Sub Example_SetCustomByKey()

    Dim Value As String
    Dim pvalue As String
    Dim CustomProperty As String
    Dim PropertyValue As String
    Dim CustomProperty1 As String
    Dim PropertyValue1 As String
    CustomProperty = "ZWCAD"
    PropertyValue = "Test"

    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty, PropertyValue
    Value = "ABC"
    ThisDrawing.SummaryInfo.SetCustomByKey CustomProperty, Value
    ThisDrawing.SummaryInfo.GetCustomByKey CustomProperty, pvalue
    MsgBox "The custom drawing properties are " & vbCrLf & _
            " pvalue = " & pvalue & vbCrLf

End Sub


SetCustomScale Method Example
Sub Example_SetCustomScale()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "Test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    Dim msg As String
    Dim Numerator As Double, Denominator As Double
    Dim Measurement As String

    ' Display current scale information
    GoSub DISPLAY_SCALE_INFO

    ' Modify scale
    Numerator = 2
    Denominator = 4
    PlotConfiguration.SetCustomScale Numerator, Denominator
    ThisDrawing.Regen zcAllViewports

    ' Display new scale information
    GoSub DISPLAY_SCALE_INFO

    Exit Sub

DISPLAY_SCALE_INFO:

    msg = vbCrLf & vbCrLf
    msg = msg & PlotConfiguration.Name & vbCrLf

    ' Get scale information
    PlotConfiguration.GetCustomScale Numerator, Denominator

    ' Are we using inches or millimeters
    Measurement = IIf(PlotConfiguration.PaperUnits = zcInches, " inch(es)", " millimeter(s)")

    ' Format for display
    msg = msg & vbTab & "Contains " & Numerator & Measurement & vbCrLf
    msg = msg & vbTab & "Contains " & Denominator & " Drawing units" & vbCrLf

    ' Display custom scale information
    MsgBox "Custom scale information for the current drawing is: " & msg
    Return

End Sub


SetInvisibleEdge Method Example
Sub Example_SetInvisibleEdge()
    ' This example creates a 3D face in model space.
    ' It then toggles the visibility of the all edge.

    Dim faceObj As Zcad3DFace
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim point3(0 To 2) As Double
    Dim point4(0 To 2) As Double

    ' Define the four coordinates of the face
    point1(0) = 1#: point1(1) = 1#: point1(2) = 0#
    point2(0) = 5#: point2(1) = 0#: point2(2) = 10#
    point3(0) = 3#: point3(1) = 20#: point3(2) = 0#
    point4(0) = 6#: point4(1) = 6#: point4(2) = 20#

    ' Create the 3DFace object in model space
    Set faceObj = ThisDrawing.ModelSpace.Add3DFace(point1, point2, point3, point4)
    ThisDrawing.Regen zcActiveViewport
    ZoomExtents

    ' Find the current visibility status of the first edge of the face
    Dim visStatus As Boolean
    For I = 0 To 3
        visStatus = faceObj.GetInvisibleEdge(I)
        MsgBox "The " & I + 1 & " edge is currently " & IIf(faceObj.GetInvisibleEdge(I), "visible.", "invisible."), , "SetInvisibleEdge Example"

        ' Toggle the visibility of the first edge of the face
        faceObj.SetInvisibleEdge I, Not (visStatus)
        ThisDrawing.Regen zcActiveViewport
        MsgBox "The " & I + 1 & " edge is now " & IIf(faceObj.GetInvisibleEdge(I), "visible.", "invisible."), , "SetInvisibleEdge Example"
    Next

End Sub


SetLayoutsToPlot Method Example
Sub Example_SetLayoutsToPlot()
    ' This example plots the layouts of a drawing.

    Dim oPlot As ZcadPlot
    Dim AddedLayouts() As String
    Dim LayoutList As Variant
    Dim oLayout As ZcadLayout
    Dim ArraySize As Integer

    For Each oLayout In ThisDrawing.Layouts
        ArraySize = ArraySize + 1
        ReDim Preserve AddedLayouts(1 To ArraySize)
        AddedLayouts(ArraySize) = oLayout.Name
    Next

    LayoutList = AddedLayouts
    Set oPlot = ThisDrawing.Plot
    oPlot.SetLayoutsToPlot LayoutList
    oPlot.PlotToDevice "DWG TO PDF.PC5"

End Sub


SetNames Method Example
Sub Example_SetNames()
    'This example draws a circle and
    'returns the color name and color book name of the color.

    Dim col As New ZcadZcCmColor
    Call col.SetRGB(120, 170, 230)
    Call col.SetNames("MyColor", "MyColorBook")

    Dim cir As ZcadCircle
    Dim pt(0 To 2) As Double
    Dim r As Double

    r = 100#
    pt(0) = 0
    pt(1) = 0
    pt(2) = 0

    Set cir = ThisDrawing.ModelSpace.AddCircle(pt, r)
    cir.TrueColor = col
    cir.Update
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    MsgBox "BookName=" & col.BookName
    MsgBox "ColorName=" & col.ColorName

End Sub


SetPattern Method Example
Sub Example_SetPattern()
    ' This example creates an associative hatch in model space.
    ' The hatch pattern is then changed.

    Dim hatchObj As ZcadHatch
    Dim patternName As String
    Dim PatternType As Long
    Dim bAssociativity As Boolean

    ' Define the hatch
    patternName = "ANSI31"
    PatternType = 0
    bAssociativity = True

    ' Create the associative Hatch object
    Set hatchObj = ThisDrawing.ModelSpace.AddHatch(PatternType, patternName, bAssociativity)

    ' Create the outer loop for the hatch.
    ' An arc and a line are used to create a closed loop.

    Dim outerLoop(0 To 1) As ZcadEntity
    Dim center(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double
    center(0) = 5: center(1) = 3: center(2) = 0
    radius = 3
    startAngle = 0
    endAngle = 3.141592
    Set outerLoop(0) = ThisDrawing.ModelSpace.AddArc(center, radius, startAngle, endAngle)
    Set outerLoop(1) = ThisDrawing.ModelSpace.AddLine(outerLoop(0).startpoint, outerLoop(0).endpoint)

    ' Append the outer loop to the hatch object
    hatchObj.AppendOuterLoop (outerLoop)

    ' Append the first circle as one inner loop
    Dim innerLoop1(0) As ZcadEntity
    center(0) = 5: center(1) = 4.5: center(2) = 0
    radius = 1
    Set innerLoop1(0) = ThisDrawing.ModelSpace.AddCircle(center, radius)
    hatchObj.AppendInnerLoop (innerLoop1)

    ' Append the second circle as the other inner loop
    Dim innerLoop2(0) As ZcadEntity
    radius = 0.5
    Set innerLoop2(0) = ThisDrawing.ModelSpace.AddCircle(center, radius)
    hatchObj.AppendInnerLoop (innerLoop2)

    ' Evaluate and display the hatch
    hatchObj.Evaluate
    ZoomAll

    ' Find the name of the hatch pattern
    patternName = hatchObj.patternName
    MsgBox "The hatch pattern is " & hatchObj.patternName, , "SetPattern Example"

    ' Change the hatch pattern
    hatchObj.SetPattern acHatchPatternTypePreDefined, "BRICK"
    hatchObj.Evaluate
    ThisDrawing.Regen True
    MsgBox "The hatch pattern is now " & hatchObj.patternName, , "SetPattern Example"

End Sub


SetRGB Method Example
Sub Example_SetRGB()

    ' This example draws a line and returns the RGB values
    Dim fcolor As ZcadZcCmColor
    Set fcolor = ZcadApplication.GetInterfaceObject("ZWCAD.ZcCmColor")
    Call fcolor.SetRGB(30, 100, 200)

    Dim line As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#
    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    line.TrueColor = fcolor
    line.Update
    Dim retcolor As ZcadZcCmColor
    Set retcolor = line.TrueColor

    MsgBox "Red = " & retcolor.Red
    MsgBox "Green = " & retcolor.Green
    MsgBox "Blue = " & retcolor.Blue

End Sub


SetVariable Method Example
Sub Example_SetVariable()

    Dim sysVarName As String
    Dim sysVarData As Variant
    sysVarName = "FILEDIA"
    sysVarData = 1
    ThisDrawing.SetVariable sysVarName, sysVarData

    ' Check the variable using GetVariable
    sysVarData = ThisDrawing.GetVariable(sysVarName)
    MsgBox sysVarName & " = " & sysVarData, , "SetVariable Example"

End Sub


SetView Method Example
Sub Example_SetView()
    ' This example creates a new view
    ' It then changes the active viewport to
    ' the newly created view.

    ' First, open a sample drawing
    ThisDrawing.Application.Documents.Open "d:\test.dwg"

    ' Create a new view
    Dim viewObj As ZcadView
    Set viewObj = ThisDrawing.Views.Add("TESTVIEW")

    ' Set the view characteristics
    viewObj.Center(0) = 374: viewObj.Center(1) = 313
    viewObj.Width = 450
    viewObj.Height = 354

    ' Get the current active viewport
    Dim viewportObj As ZcadViewport
    Set viewportObj = ThisDrawing.ActiveViewport
    MsgBox "Change to the saved view.", , "SetView Example"

    ' Set the view in the viewport
    viewportObj.SetView viewObj
    ThisDrawing.ActiveViewport = viewportObj
    ThisDrawing.Regen zcActiveViewport

End Sub


SetWidth Method Example
Sub Example_SetWidth()

    Dim lwplineObj As ZcadLWPolyline
    Dim points(0 To 5) As Double

    ' Establish the points for the Polyline
    points(0) = 3: points(1) = 7
    points(2) = 9: points(3) = 2
    points(4) = 13: points(5) = 5

    ' Create the polyline in model space
    Set lwplineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)

    ' Get the width of 1st segment of the polyline
    Dim StartWidth As Double, EndWidth As Double
    lwplineObj.GetWidth 0, StartWidth, EndWidth
    MsgBox "Startwidth:" & StartWidth & vbCrLf & "EndWidth:" & EndWidth

    ' Set the width of 1st segment of the polyline
    lwplineObj.SetWidth 0, 0.5, 1
    lwplineObj.Update
    ZoomAll

End Sub


SetXData Method Example
Sub Example_SetXdata()
    ' This example creates a line and attaches extended data to that line.

    ' Create the line
    Dim lineObj As ZcadLine
    Dim startPt(0 To 2) As Double, endPt(0 To 2) As Double
    startPt(0) = 1#: startPt(1) = 1#: startPt(2) = 0#
    endPt(0) = 5#: endPt(1) = 5#: endPt(2) = 0#
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPt, endPt)
    ZoomAll

    ' Initialize all the xdata values. Note that first data in the list should be
    ' application name and first datatype code should be 1001
    Dim DataType(0 To 9) As Integer
    Dim Data(0 To 9) As Variant
    Dim reals3(0 To 2) As Double
    Dim worldPos(0 To 2) As Double

    DataType(0) = 1001: Data(0) = "Test_Application"
    DataType(1) = 1000: Data(1) = "This is a test for xdata"

    DataType(2) = 1003: Data(2) = "0"                   ' layer
    DataType(3) = 1040: Data(3) = 1.23479137438413E+40  ' real
    DataType(4) = 1041: Data(4) = 1237324938            ' distance
    DataType(5) = 1070: Data(5) = 32767                 ' 16 bit Integer
    DataType(6) = 1071: Data(6) = 32767                 ' 32 bit Integer
    DataType(7) = 1042: Data(7) = 10                    ' scaleFactor

    reals3(0) = -2.95: reals3(1) = 100: reals3(2) = -20
    DataType(8) = 1010: Data(8) = reals3                ' real

    worldPos(0) = 4: worldPos(1) = 400.99999999: worldPos(2) = 2.798989
    DataType(9) = 1011: Data(9) = worldPos              ' world space position

    ' Attach the xdata to the line
    lineObj.SetXData DataType, Data

    ' Return the xdata for the line
    Dim xdataOut As Variant
    Dim xtypeOut As Variant
    lineObj.GetXData "", xtypeOut, xdataOut

End Sub


SetXRecordData Method Example
Sub Example_SetXRecordData()

    Dim TrackingDictionary As ZcadDictionary, TrackingXRecord As ZcadXRecord
    Dim XRecordDataType As Variant, XRecordData As Variant
    Dim ArraySize As Long
    Dim msg As String

    Const test = 0
    Const DICTIONARY_NAME = "TestDictionary"
    Const XRECORD_NAME = "TestXRecord"
    Set TrackingDictionary = ThisDrawing.Dictionaries.Add(DICTIONARY_NAME)
    Set TrackingXRecord = TrackingDictionary.AddXRecord(XRECORD_NAME)

    ReDim XRecordDataType(0 To ArraySize) As Integer
    ReDim XRecordData(0 To ArraySize) As Variant

    XRecordDataType(ArraySize) = test
    XRecordData(ArraySize) = CStr(Time)
    TrackingXRecord.SetXRecordData XRecordDataType, XRecordData
    Data = XRecordData(ArraySize)
    msg = msg & Data & vbCrLf
    MsgBox "The data in the XRecord is: " & vbCrLf & vbCrLf & msg, vbInformation

End Sub


SliceSolid Method Example
Sub Example_SliceSolid()
    ' This example creates a box in model space.
    ' It then slices the box based on a plane defined by three points.
    ' The slice is returned as a 3Dsolid.

    Dim boxObj As Zcad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double

    ' Define the box
    center(0) = 5#: center(1) = 5#: center(2) = 0
    length = 5#: width = 7: height = 10#

    ' Create the box (3DSolid) object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)

    ' Define the section plane with three points
    Dim slicePt1(0 To 2) As Double
    Dim slicePt2(0 To 2) As Double
    Dim slicePt3(0 To 2) As Double

    slicePt1(0) = 1.5: slicePt1(1) = 7.5: slicePt1(2) = 0
    slicePt2(0) = 1.5: slicePt2(1) = 7.5: slicePt2(2) = 10
    slicePt3(0) = 8.5: slicePt3(1) = 2.5: slicePt3(2) = 10

    ' Slice the box
    Dim sliceObj As Zcad3DSolid
    Set sliceObj = boxObj.SliceSolid(slicePt1, slicePt2, slicePt3, True)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Change the viewing direction of the viewport to better see the box
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

End Sub


StartUndoMark Method Example
Sub Example_StartUndoMark()

    Dim line As ZcadLine
    Dim stPnt(0 To 2) As Double
    Dim endPnt(0 To 2) As Double
    stPnt(0) = 10: stPnt(1) = 20: stPnt(2) = 0
    endPnt(0) = 20: endPnt(1) = 30: endPnt(2) = 0

    ' Create the lines
    Dim j As Integer
    For j = 0 To 3
        ThisDrawing.StartUndoMark
        Set line = ThisDrawing.ModelSpace.AddLine(stPnt, endPnt)
        stPnt(0) = stPnt(0) + 3
        endPnt(0) = endPnt(0) + 3
        ThisDrawing.EndUndoMark
    Next

End Sub


TransformBy Method Example
Sub Example_TransformBy()
    ' This example creates an arc and rotates it 90 degrees
    ' using a transformation matrix.

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ZoomAll

    ' Initialize the transMat variable with a transformation matrix
    ' that will rotate an object by 90 degrees about the point(0,0,0)
    Dim transMat(0 To 3, 0 To 3) As Double
    transMat(0, 0) = 0#: transMat(0, 1) = -1#: transMat(0, 2) = 0#: transMat(0, 3) = 0#
    transMat(1, 0) = 1#: transMat(1, 1) = 0#: transMat(1, 2) = 0#: transMat(1, 3) = 0#
    transMat(2, 0) = 0#: transMat(2, 1) = 0#: transMat(2, 2) = 1#: transMat(2, 3) = 0#
    transMat(3, 0) = 0#: transMat(3, 1) = 0#: transMat(3, 2) = 0#: transMat(3, 3) = 1#

    ' Transform the arc using the defined transformation matrix
    MsgBox "Transform the arc.", , "TransformBy Example"
    arcObj.TransformBy transMat
    ZoomAll
    MsgBox "The arc is transformed.", , "TransformBy Example"

End Sub


TranslateCoordinates Method Example
Sub Example_TranslateCoordinates()

    Dim ucsObj As ZcadUCS
    Dim origin(0 To 2) As Double
    Dim xAxisPnt(0 To 2) As Double
    Dim yAxisPnt(0 To 2) As Double

    ' Define the UCS
    origin(0) = 10#: origin(1) = 10#: origin(2) = 2#
    xAxisPnt(0) = 20#: xAxisPnt(1) = 10#: xAxisPnt(2) = 2#
    yAxisPnt(0) = 10#: yAxisPnt(1) = 16#: yAxisPnt(2) = 2#

    Set ucsObj = ThisDrawing.UserCoordinateSystems.Add(origin, xAxisPnt, yAxisPnt, "Test1")
    ThisDrawing.ActiveViewport.UCSIconOn = True
    ThisDrawing.ActiveViewport.UCSIconAtOrigin = True
    ThisDrawing.ActiveUCS = ucsObj
    Dim pointWCS As Variant
    pointWCS = ThisDrawing.Utility.GetPoint(, "Enter a point to translate:")
    Dim pointUCS As Variant
    pointUCS = ThisDrawing.Utility.TranslateCoordinates(pointWCS, zcWorld, zcUCS, False)

    MsgBox "The point has the following coordinates:" & vbCrLf & _
            "WCS: " & pointWCS(0) & ", " & pointWCS(1) & ", " & pointWCS(2) & vbCrLf & _
            "UCS: " & pointUCS(0) & ", " & pointUCS(1) & ", " & pointUCS(2), , "TranslateCoordinates Example"

End Sub


VBE Method Example
Sub Example_VBE()
    ' This example uses the VBA IDE extensibility model to dynamically
    ' create a VBA subroutine. After running this example, see the first line of code
    ' in the VBA IDE code window to see a new subroutine. Then
    ' remove the new subroutine before continuing.

    Dim VBEModel As Object
    Dim newRoutine As String

    Set VBEModel = VBE  ' Get the VBE object

    ' Define new subroutine to be added. This could be created dynamically from user feedback.
    newRoutine = "Sub Dynamic_Procedure()" & vbCrLf
    newRoutine = newRoutine & vbTab & "MsgBox ""New subroutine.""" & vbCrLf
    newRoutine = newRoutine & "End Sub" & vbCrLf

    ' Insert new subroutine
    VBEModel.CodePanes(1).CodeModule.InsertLines 1, newRoutine
    MsgBox "A new subroutine was added called Dynamic_Procedure."

End Sub


WBlock Method Example
Sub Example_WBlock()

    Dim rayObj As ZcadRay
    Dim basePoint(0 To 2) As Double
    Dim SecondPoint(0 To 2) As Double
    basePoint(0) = 3#: basePoint(1) = 3#: basePoint(2) = 0#
    SecondPoint(0) = 1#: SecondPoint(1) = 3#: SecondPoint(2) = 0#
    Set rayObj = ThisDrawing.ModelSpace.AddRay(basePoint, SecondPoint)

    ' Create a polyline object in model space
    Dim plineObj As ZcadLWPolyline
    Dim points(0 To 3) As Double

    points(0) = 1: points(1) = 4
    points(2) = 3: points(3) = 6

    Set plineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)
    plineObj.Closed = True

    ' Create a line object in model space
    Dim lineObj As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
    startPoint(0) = 0: startPoint(1) = 0: startPoint(2) = 0
    endPoint(0) = 2: endPoint(1) = 2: endPoint(2) = 0
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)

    ' Create a circle object in model space
    Dim circObj As ZcadCircle
    Dim centerPt(0 To 2) As Double
    Dim radius As Double
    centerPt(0) = 20: centerPt(1) = 30: centerPt(2) = 0
    radius = 3
    Set circObj = ThisDrawing.ModelSpace.AddCircle(centerPt, radius)

    ' Create an ellipse object in model space
    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)

    ' Create a selection set
    Dim ssetObj As ZcadSelectionSet
    Set ssetObj = ThisDrawing.SelectionSets.Add("WBLOCKSET")

    ' Iterate through the model space collection and add
    ' each item found to an array of objects
    ReDim objsInModelSpace(0 To ThisDrawing.ModelSpace.Count - 1) As ZcadEntity
    Dim I As Integer
    For I = 0 To ThisDrawing.ModelSpace.Count - 1
        Set objsInModelSpace(I) = ThisDrawing.ModelSpace.Item(I)
    Next
    ThisDrawing.Regen zcActiveViewport
    ' Add the array of objects into the selection set
    ssetObj.AddItems objsInModelSpace

    ' Output the selection set to a new file
    ThisDrawing.Wblock "C:\test\test.dwg", ssetObj

End Sub


ZoomAll Method Example
Sub Example_ZoomAll()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#
    endAngle = 230 * 3.141592 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Perform a ZoomAll", , "ZoomWindow Example"
    ThisDrawing.Application.ZoomAll

End Sub


ZoomCenter Method Example
Sub Example_ZoomCenter()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#
    endAngle = 230 * 3.141592 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
       MsgBox "Perform a ZoomCenter using:" & vbCrLf & _
           "Center 10, 10, 0" & vbCrLf & _
           "Magnification: 20", , "ZoomWindow Example"
    Dim zcenter(0 To 2) As Double
    Dim magnification As Double
    zcenter(0) = 10: zcenter(1) = 10: zcenter(2) = 0
    magnification = 20
    ThisDrawing.Application.ZoomCenter zcenter, magnification

End Sub


ZoomExtents Method Example
Sub Example_ZoomExtents()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#
    endAngle = 230 * 3.141592 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Perform a ZoomExtents", , "ZoomExtents Example"
    ThisDrawing.Application.ZoomExtents

End Sub


ZoomPickWindow Method Example
Sub Example_ZoomPickWindow()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#
    endAngle = 230 * 3.141592 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Perform a ZoomPickWindow", , "ZoomPickWindow Example"
    ThisDrawing.Application.ZoomPickWindow

End Sub


ZoomPrevious Method Example
Sub Example_ZoomPrevious()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#
    endAngle = 230 * 3.141592 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Perform a ZoomPrevious", , "ZoomPrevious Example"
    ThisDrawing.Application.ZoomPrevious

End Sub


ZoomScaled Method Example
Sub Example_ZoomScaled()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#
    endAngle = 230 * 3.141592 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Perform a ZoomScaled", , "ZoomScaled Example"
    ThisDrawing.Application.ZoomScaled 3, zcZoomScaledAbsolute

End Sub


ZoomWindow Method Example
Sub Example_ZoomWindow()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#
    endAngle = 230 * 3.141592 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Perform a ZoomWindow using the following coordinates:" & vbCrLf & _
           "2, 8, 0" & vbCrLf & _
           "12, 36, 0", , "ZoomWindow Example"

    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    point1(0) = 2: point1(1) = 8: point1(2) = 0
    point2(0) = 12: point2(1) = 36: point2(2) = 0
    ThisDrawing.Application.ZoomWindow point1, point2

End Sub


Active Property Example
Sub Example_Active()
    ' This example creates two new Documents and determines
    ' which of the documents is the active document.

    Dim docu1 As ZcadDocument
    Dim docu2 As ZcadDocument
    Set docu1 = ThisDrawing.Application.Documents.Add
    Set docu2 = ThisDrawing.Application.Documents.Add

    Dim Status As String
    Dim document As ZcadDocument
    For Each document In ThisDrawing.Application.Documents
    If document.Active Then
            Status = Status & document.Name & " is active." & vbCrLf
    Else
            Status = Status & document.Name & " is not active." & vbCrLf
    End If
    Next document
    MsgBox Status

End Sub


ActiveDimStyle Property Example
Sub Example_ActiveDimStyle()
    ' This example returns the current dimension style
    ' and then sets a new style.
    ' Finally, it returns the style to the previous setting.
    Dim newDimStyle As ZcadDimStyle
    Dim currDimStyle As ZcadDimStyle

    ' Return current dimension style of active document
    Set currDimStyle = ThisDrawing.ActiveDimStyle
    MsgBox "The current dimension style is " & currDimStyle.Name, vbInformation, "ActiveDimStyle Example"

    ' Create a dimension style and makes it current
    Set newDimStyle = ThisDrawing.DimStyles.Add("TestDimStyle")
    ThisDrawing.ActiveDimStyle = newDimStyle
    MsgBox "The new dimension style is " & newDimStyle.Name, vbInformation, "ActiveDimStyle Example"

    ' Reset the dimension style to its previous setting
    ThisDrawing.ActiveDimStyle = currDimStyle
    MsgBox "The dimension style is reset to " & currDimStyle.Name, vbInformation, "ActiveDimStyle Example"

End Sub


ActiveDocument Property Example
Sub Example_ActiveDocument()

   'This example returns the name of  activedocument
    Dim activeDoc As ZcadDocument
    Set activeDoc = ThisDrawing.Application.ActiveDocument
    MsgBox "The active document is: " & activeDoc.Name, vbInformation, "ActiveDocument Example"

End Sub


ActiveLayer Property Example
Sub Example_ActiveLayer()
    ' This example returns the current layer
    ' and then adds a new layer.
    ' Finally, it returns the layer to the previous setting.
    Dim currLayer As ZcadLayer
    Dim newLayer As ZcadLayer

    ' Return the current layer of the active document
    Set currLayer = ThisDrawing.ActiveLayer
    MsgBox "The current layer is " & currLayer.Name, vbInformation, "ActiveLayer Example"

    ' Create a Layer and make it the active layer
    Set newLayer = ThisDrawing.Layers.Add("TestLayer")
    ThisDrawing.ActiveLayer = newLayer
    MsgBox "The new layer is " & newLayer.Name, vbInformation, "ActiveLayer Example"

    ' Reset the layer to its previous setting
    ThisDrawing.ActiveLayer = currLayer
    MsgBox "The active layer is reset to " & currLayer.Name, vbInformation, "ActiveLayer Example"

End Sub


ActiveLayout Property Example
Sub Example_ActiveLayout()
    ' This example cycles through the documents collection
    ' and uses the ActiveLayout object to list the active layout
    ' for all open documents.

    Dim DOC As ZcadDocument
    Dim msg As String

    ' If there are no open documents, then exit
    If Documents.Count = 0 Then
        MsgBox "There are no open documents!"
        Exit Sub
    End If

    ' Start with a space
    msg = vbCrLf & vbCrLf

    ' Cycle through documents and determine the active layout name using the
    ' ActiveLayout property of the document object
    For Each DOC In Documents
        msg = msg & DOC.WindowTitle & ": " & DOC.ActiveLayout.Name
    Next

    ' Display results
    MsgBox "The active layouts for the open drawings are: " & msg

End Sub


ActivePViewport Property Example
Sub Example_ActivePViewport()
    'This example creates a paper space Viewport object

    Dim newPViewport As ZcadPViewport
    Dim centerPoint(0 To 2) As Double
    Dim height As Double
    Dim width As Double
    height = 15#
    width = 25#
    centerPoint(0) = 5#: centerPoint(1) = 5#: centerPoint(2) = 0#

    ThisDrawing.ActiveSpace = zcPaperSpace
    Set newPViewport = ThisDrawing.PaperSpace.AddPViewport(centerPoint, width, height)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents
    newPViewport.Display True
    ThisDrawing.MSpace = True
    ThisDrawing.ActivePViewport = newPViewport

End Sub


ActiveSelectionSet Property Example

Sub Example_ActiveSelectionSet()

    ' The following example returns current selection set from current document
    Dim sset As ZcadSelectionSet
    Set sset = ThisDrawing.ActiveSelectionSet
    MsgBox "The Activeselection name is " & sset.Name

End Sub


ActiveSpace Property Example
Sub Example_ActiveSpace()

    MsgBox "TILEMODE = " & ThisDrawing.ActiveSpace, vbInformation, "ActiveSpace Example"

    ' Changes active document to paper space
    ThisDrawing.ActiveSpace = zcPaperSpace
    MsgBox "TILEMODE = " & ThisDrawing.ActiveSpace, vbInformation, "ActiveSpace Example"

    ' Changes active document to model space
    ThisDrawing.ActiveSpace = zcModelSpace
    MsgBox "TILEMODE = " & ThisDrawing.ActiveSpace, vbInformation, "ActiveSpace Example"

End Sub


ActiveTextStyle Property Example
Sub Example_ActiveTextStyle()
    ' This example returns the current text style
    ' and then sets a new style.
    ' Finally, it returns the style to the previous setting

    Dim newTextStyle As ZcadTextStyle
    Dim currTextStyle As ZcadTextStyle

    ' Return current text style of active document
    Set currTextStyle = ThisDrawing.ActiveTextStyle
    MsgBox "The current text style is " & currTextStyle.Name, vbInformation, "ActiveTextStyle Example"

    ' Create a text style and make it current
    Set newTextStyle = ThisDrawing.TextStyles.Add("TestStyle")
    ThisDrawing.ActiveTextStyle = newTextStyle
    MsgBox "The new text style is " & newTextStyle.Name, vbInformation, "ActiveTextStyle Example"

    ' Reset the text style to its previous setting
    ThisDrawing.ActiveTextStyle = currTextStyle
    MsgBox "The text style is reset to " & currTextStyle.Name, vbInformation, "ActiveTextStyle Example"

End Sub


ActiveUCS Property Example
Sub Example_ActiveUCS()
    'This example creates a UCS and make it current

    Dim newUCS As ZcadUCS
    Dim origin(0 To 2) As Double
    Dim xAxis(0 To 2) As Double
    Dim yAxis(0 To 2) As Double

    origin(0) = 0: origin(1) = 0: origin(2) = 0
    xAxis(0) = 5: xAxis(1) = 5: xAxis(2) = 0
    yAxis(0) = -5: yAxis(1) = 5: yAxis(2) = 0
    Set newUCS = ThisDrawing.UserCoordinateSystems.Add(origin, xAxis, yAxis, "TestUCS")
    ThisDrawing.ActiveUCS = newUCS
    MsgBox "The new UCS is " & newUCS.Name, vbInformation, "ActiveUCS Example"

End Sub


ActiveViewport Property Example

Sub Example_ActiveViewport()

    Dim currViewport As ZcadViewport
    Dim newViewport As ZcadViewport

    ' Returns current viewport of active document
    Set currViewport = ThisDrawing.ActiveViewport
    MsgBox "The current viewport is " & currViewport.Name, vbInformation, "ActiveViewport Example"

    ' Create a new viewport and make it active
    Set newViewport = ThisDrawing.Viewports.Add("TEST")
    ThisDrawing.ActiveViewport = newViewport
    MsgBox "The new active viewport is " & newViewport.Name, vbInformation, "ActiveViewport Example"

End Sub


Alignment Property Example

Sub Example_Alignment()
    ' This example creates an attribute object in model space and
    ' demonstrates setting the alignment of the new text string

    Dim attributeobj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double, alignmentPoint(0 To 2) As Double
    Dim oldPDMODE As Integer
    Dim pointObj As ZcadPoint
    Dim tag As String
    Dim value As String

    ' Define the new attribute defintion
    height = 0.5
    mode = zcAttributeModeVerify
    prompt = "New Prompt"
    tag = "New Tag"
    value = "New value"
    insertionPoint(0) = 3: insertionPoint(1) = 3: insertionPoint(2) = 0
    alignmentPoint(0) = 3: alignmentPoint(1) = 3: alignmentPoint(2) = 0

    ' Create the attribute definition object in model space
    Set attributeobj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    ThisDrawing.Regen zcActiveViewport
    oldPDMODE = ThisDrawing.GetVariable("PDMODE")

    Set pointObj = ThisDrawing.ModelSpace.AddPoint(alignmentPoint)

    ThisDrawing.SetVariable "PDMODE", 2
    ThisDrawing.Application.ZoomAll

    attributeobj.Alignment = zcAlignmentRight
    attributeobj.TextAlignmentPoint = alignmentPoint
    MsgBox "The attribute object is now aligned to the right of the alignment point"

    ' Reset point style
    ThisDrawing.SetVariable "PDMODE", oldPDMODE

End Sub


AltRoundDistance Property Example
Sub Example_AltRoundDistance()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 10.123: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.AltUnits = True
    dimObj.Update
    MsgBox "Press any key to round the alternate dimension unit display to .5"

    dimObj.AltRoundDistance = 0.5
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Alternate dimension units have been rounded to: " & dimObj.AltRoundDistance

End Sub


AltSuppressLeadingZeros Property Example
Sub Example_AltSuppressLeadingZeros()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 5.01: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.AltUnits = True
    dimObj.Update

Toggle:
    Select Case MsgBox("Press OK to toggle the display of leading zeros in the alternate dimension", vbOKCancel)
        Case vbOK
            ' Toggle the display of leading zeros for the alternate dimension value
            dimObj.AltSuppressLeadingZeros = Not (dimObj.AltSuppressLeadingZeros)
            dimObj.Update
            ThisDrawing.Application.ZoomExtents
        Case vbCancel
            Exit Sub
    End Select

    GoTo Toggle
End Sub


AltSuppressTrailingZeros Property Example
Sub Example_AltSuppressTrailingZeros()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 7: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.AltUnits = True
    dimObj.AltUnitsScale = 5
    dimObj.Update
    ThisDrawing.Application.ZoomExtents

Toggle:
    Select Case MsgBox("Press OK to toggle the display of trailing zeros in the alternate dimension", vbOKCancel)
        Case vbOK
            dimObj.AltSuppressTrailingZeros = Not (dimObj.AltSuppressTrailingZeros)
            dimObj.Update
            ThisDrawing.Application.ZoomExtents
        Case vbCancel
            Exit Sub
    End Select

    GoTo Toggle
End Sub


AltSuppressZeroFeet Property Example
Sub Example_AltSuppressZeroFeet()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)

    dimObj.AltUnits = True
    dimObj.AltUnitsFormat = zcDimLArchitectural
    dimObj.AltUnitsScale = 2
    dimObj.Update
    ThisDrawing.Application.ZoomExtents

Toggle:
    Select Case MsgBox("Press OK to suppress or view the display of zero feet in the alternate dimension", vbOKCancel)
        Case vbOK
            dimObj.AltSuppressZeroFeet = Not (dimObj.AltSuppressZeroFeet)
            dimObj.Update
            ThisDrawing.Application.ZoomExtents
        Case vbCancel
            Exit Sub
    End Select

    GoTo Toggle
End Sub


AltSuppressZeroInches Property Example
Sub Example_AltSuppressZeroInches()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 12: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.AltUnits = True
    dimObj.AltUnitsFormat = zcDimLArchitectural
    dimObj.AltUnitsScale = 4
    dimObj.Update
    ThisDrawing.Application.ZoomExtents

Toggle:
    Select Case MsgBox("Press OK to suppress or view the display of zero inches in the alternate dimension", vbOKCancel)
        Case vbOK
            dimObj.AltSuppressZeroInches = Not (dimObj.AltSuppressZeroInches)
            dimObj.Update
            ThisDrawing.Application.ZoomExtents
        Case vbCancel
            Exit Sub
    End Select

    GoTo Toggle
End Sub


AltTolerancePrecision Property Example

Sub Example_AltTolerancePrecision()
    ' This example creates an aligned dimension in model space and
    ' uses AltTolerancePrecision to allow the user to change the
    ' precision of the alternate dimension tolerance

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    Dim oldTolerance As String, newTolerance As String

    ' Define the dimension
    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5.12345678: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)

    ' Enable alternate unit display
    dimObj.AltUnits = True
    dimObj.ToleranceDisplay = zcTolLimits
    dimObj.Update
    ThisDrawing.Application.ZoomAll

    ' Store old tolerance value as default for input box
    oldTolerance = dimObj.AltTolerancePrecision

    ' Allow the user to change the precision for the alternate dimension tolerance
    newTolerance = InputBox("Enter a new tolerance precision for the alternate dimension. The value must range from 0 to 8.", "Alternate Dimension Tolerance Precision", oldTolerance)

    Select Case newTolerance
        Case 0: newTolerance = zcDimPrecisionZero
        Case 1: newTolerance = zcDimPrecisionOne
        Case 2: newTolerance = zcDimPrecisionTwo
        Case 3: newTolerance = zcDimPrecisionThree
        Case 4: newTolerance = zcDimPrecisionFour
        Case 5: newTolerance = zcDimPrecisionFive
        Case 6: newTolerance = zcDimPrecisionSix
        Case 7: newTolerance = zcDimPrecisionSeven
        Case 8: newTolerance = zcDimPrecisionEight
        Case Else
            MsgBox "The alternate tolerance precision has not been changed."
            Exit Sub
    End Select

    dimObj.AltTolerancePrecision = newTolerance   ' Commit changes to tolerance precision

    dimObj.Update
    ThisDrawing.Application.ZoomAll

    ' Read back and display the alternate dimension tolerance precision
    newTolerance = dimObj.AltTolerancePrecision
    MsgBox "The tolerance precision has been set to " & newTolerance & " decimal places"

End Sub


AltToleranceSuppressLeadingZeros Property Example
Sub Example_AltToleranceSuppressLeadingZeros()
    ' This example creates an aligned dimension in model space and
    ' uses AltToleranceSuppressLeadingZeros to toggle the display of leading zeros
    ' in the alternate dimension tolerance display

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 6.01: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)

    ' Set up alternate unit tolerance display
    dimObj.AltUnits = True
    dimObj.ToleranceDisplay = zcTolLimits
    dimObj.Update
    ThisDrawing.Application.ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle the display of leading zeros in the alternate dimension tolerance", vbOKCancel)
        Case vbOK
         ' Toggle the display of leading zeros for the alternate dimension tolerance value
            dimObj.AltToleranceSuppressLeadingZeros = Not (dimObj.AltToleranceSuppressLeadingZeros)
            dimObj.Update
            ThisDrawing.Application.ZoomAll

        Case vbCancel
            Exit Sub
    End Select

    GoTo Toggle
End Sub


AltToleranceSuppressTrailingZeros Property Example
Sub Example_AltToleranceSuppressTrailingZeros()
    ' This example creates an aligned dimension in model space and
    ' uses AltToleranceSuppressTrailingZeros to toggle the display of trailing zeros
    ' in the alternate dimension tolerance display

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 7: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)

    ' Set up alternate unit tolerance display
    dimObj.AltUnits = True
    dimObj.ToleranceDisplay = zcTolLimits
    dimObj.AltUnitsScale = 2
    dimObj.Update
    ThisDrawing.Application.ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle the display of trailing zeros in the alternate dimension tolerance", vbOKCancel)
        Case vbOK
            ' Toggle the display of trailing zeros for the alternate dimension tolerance value
            dimObj.AltToleranceSuppressTrailingZeros = Not (dimObj.AltToleranceSuppressTrailingZeros)
            dimObj.Update
            ThisDrawing.Application.ZoomAll
        Case vbCancel
            Exit Sub
    End Select

    GoTo Toggle

End Sub


AltToleranceSuppressZeroFeet Property Example
Sub Example_AltToleranceSuppressZeroFeet()
    ' This example creates an aligned dimension in model space and
    ' uses AltToleranceSuppressZeroFeet to suppress or view the display of
    ' zero feet in the alternate dimension tolerance display

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)

    ' Set up alternate unit tolerance display
    dimObj.AltUnits = True
    dimObj.ToleranceDisplay = zcTolLimits

    ' Set the dimension display to a style that works with AltToleranceSuppressZeroFeet
    dimObj.AltUnitsFormat = zcDimLArchitectural
    dimObj.AltUnitsScale = 2    ' Set the alternate unit scale to be a multiple of 2
    dimObj.Update
    ThisDrawing.Application.ZoomAll

Toggle:
    Select Case MsgBox("Press OK to suppress or view the display of zero feet in the alternate dimension tolerance", vbOKCancel)
        Case vbOK
            ' Toggle the display of zero feet for the alternate dimension value
            dimObj.AltToleranceSuppressZeroFeet = Not (dimObj.AltToleranceSuppressZeroFeet)
            dimObj.Update
            ThisDrawing.Application.ZoomAll

        Case vbCancel
            Exit Sub
    End Select

    GoTo Toggle

End Sub


AltToleranceSuppressZeroInches Property Example
Sub Example_AltToleranceSuppressZeroInches()
    ' This example creates an aligned dimension in model space and
    ' uses AltToleranceSuppressZeroInches to suppress or view the display of
    ' zero inches in the alternate dimension tolerance display

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 12: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)

    ' Set up alternate unit tolerance display
    dimObj.AltUnits = True
    dimObj.ToleranceDisplay = zcTolLimits

    ' Set the dimension display to a style that works with AltToleranceSuppressZeroInches
    dimObj.AltUnitsFormat = zcDimLArchitectural
    dimObj.AltUnitsScale = 2    ' Set the alternate unit scale to be a multiple of 2
    dimObj.Update
    ThisDrawing.Application.ZoomAll

Toggle:
    Select Case MsgBox("Press OK to suppress or view the display of zero inches in the alternate dimension tolerance", vbOKCancel)
        Case vbOK
            ' Toggle the display of zero inches for the alternate dimension tolerance value
           dimObj.AltToleranceSuppressZeroInches = Not (dimObj.AltToleranceSuppressZeroInches)
           dimObj.Update
           ThisDrawing.Application.ZoomAll

        Case vbCancel
            Exit Sub
    End Select

    GoTo Toggle

End Sub


AltUnits Property Example
Sub Example_AltUnits()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.Update
    ThisDrawing.Application.ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle the display of alternate dimensions", vbOKCancel)
        Case vbOK

            dimObj.AltUnits = Not (dimObj.AltUnits)
            dimObj.Update
             ThisDrawing.Application.ZoomAll
        Case vbCancel
            Exit Sub
    End Select

    If dimObj.AltUnits Then
        MsgBox "Alternate units display is on."
    Else
        MsgBox "Alternate units display is off."
    End If

    GoTo Toggle

End Sub


AltUnitsFormat Property Example
Sub Example_AltUnitsFormat()
    ' This example creates an aligned dimension in model space and
    ' uses AltUnitsFormat to cycle through some common unit formats
    ' for the alternate dimension

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5.12345678: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.Update
    ThisDrawing.Application.ZoomAll

    ' Enable unit display of alternate units
    dimObj.AltUnits = True
    dimObj.AltUnitsFormat = zcDimScientific
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The alternate dimension units are now set to Scientific"

    dimObj.AltUnitsFormat = zcDimDecimal
    dimObj.Update
    ThisDrawing.Application.ZoomAll

    MsgBox "The alternate dimension units are now set to Decimal"

    dimObj.AltUnitsFormat = zcDimArchitectural
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The alternate dimension units are now set to Architectural"

    dimObj.AltUnitsFormat = zcDimWindowsDesktop
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The alternate dimension units are now set to Windows Desktop"

End Sub


AltUnitsPrecision Property Example
Sub Example_AltUnitsPrecision()
    ' This example creates an aligned dimension in model space and
    ' uses AltUnitsPrecision to allow the user to change the
    ' precision of the alternate dimension

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    Dim oldPrecision As String, newPrecision As String

    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5.12345678: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.AltUnits = True
    dimObj.Update
    ThisDrawing.Application.ZoomAll

    ' Store old Precision value as default for input box
    oldPrecision = dimObj.AltUnitsPrecision

    ' Allow the user to change the precision for the alternate dimension
    newPrecision = InputBox("Enter a new precision for the alternate dimension.  The value must range from 0 to 8.", "Alternate Dimension Precision", oldPrecision)

    Select Case newPrecision
        Case 0: newPrecision = zcDimPrecisionZero
        Case 1: newPrecision = zcDimPrecisionOne
        Case 2: newPrecision = zcDimPrecisionTwo
        Case 3: newPrecision = zcDimPrecisionThree
        Case 4: newPrecision = zcDimPrecisionFour
        Case 5: newPrecision = zcDimPrecisionFive
        Case 6: newPrecision = zcDimPrecisionSix
        Case 7: newPrecision = zcDimPrecisionSeven
        Case 8: newPrecision = zcDimPrecisionEight
        Case Else

            MsgBox "The alternate precision has not been changed."
            Exit Sub
    End Select

    dimObj.AltUnitsPrecision = newPrecision
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    newPrecision = dimObj.AltUnitsPrecision
    MsgBox "The alternate dimension precision has been set to " & newPrecision & " decimal places"

End Sub


AltUnitsScale Property Example
Sub Example_AltUnitsScale()
    ' This example creates an aligned dimension in model space and
    ' uses AltUnitsScale to cycle through some common scales
    ' for the alternate dimension

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    dimObj.AltUnits = True
    dimObj.AltUnitsScale = 1
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The alternate dimension units are now set to inches"

    dimObj.AltUnitsScale = 25.4
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The alternate dimension units are now set to millimeters"

    dimObj.AltUnitsScale = 2.54
    dimObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The alternate dimension units are now set to centimeters"

End Sub


Angle Property Example
Sub Example_Angle()
    ' This example adds a line in model space and returns the angle of the new line

    Dim lineObj As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    ' Define the start and end points for the line
    startPoint(0) = 2#: startPoint(1) = 9#: startPoint(2) = 0#
    endPoint(0) = 50#: endPoint(1) = 60#: endPoint(2) = 0#

    ' Create the line in model space
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents
    MsgBox "The angle of the new Line is: " & lineObj.Angle

End Sub


AngleFormat Property Example
Sub Example_AngleFormat()
    ' This example creates a Dim3PointAngular object in model space
    ' and sets its Angle Format to some common values

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2)   As Double

    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 1: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 3: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 15: TextPoint(1) = 15: TextPoint(2) = 0

    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    DimPointAngularObj.Update

    DimPointAngularObj.AngleFormat = zcRadians
    DimPointAngularObj.Update
    MsgBox "The angle format of the new Dim3PointAngular object is now set to radians"

End Sub


AngleVertex Property Example
Sub Example_AngleVertex()
    ' This example creates a Dim3PointAngular object in model space
    ' and then alters its angle vertex

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double, NewAngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2)  As Double
    Dim CurrentVertex As Variant

    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    NewAngleVertex(0) = 1: NewAngleVertex(1) = 1: NewAngleVertex(2) = 0
    FirstPoint(0) = 5: FirstPoint(1) = 5: FirstPoint(2) = 0
    SecondPoint(0) = 30: SecondPoint(1) = 0: SecondPoint(2) = 0
    TextPoint(0) = 35: TextPoint(1) = 35: TextPoint(2) = 0

    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    DimPointAngularObj.Update
    ThisDrawing.Application.ZoomAll

    ' Display current vertex
    CurrentVertex = DimPointAngularObj.AngleVertex
    MsgBox "The angle vertex of the new object is set to:" & vbCrLf & _
            CurrentVertex(0) & vbCrLf & _
            CurrentVertex(1) & vbCrLf & _
            CurrentVertex(2)

    ' Alter vertex setting for this object
    DimPointAngularObj.AngleVertex = NewAngleVertex
    DimPointAngularObj.Update

    ' Display new vertex settings
    CurrentVertex = DimPointAngularObj.AngleVertex
    MsgBox "The angle vertex of the object has been reset to:" & vbCrLf & _
            CurrentVertex(0) & vbCrLf & _
            CurrentVertex(1) & vbCrLf & _
            CurrentVertex(2)

End Sub


Annotation Property Example
Sub Example_Annotation()

    Dim MTextObj As ZcadMText
    Dim insertionPoint(0 To 2) As Double
    Dim width As Double
    Dim textString As String
    textString = "Test"
    insertionPoint(0) = 25: insertionPoint(1) = 35: insertionPoint(2) = 0
    width = 10
    Set MTextObj = ThisDrawing.ModelSpace.AddMText(insertionPoint, width, textString)

    Dim leaderObj As ZcadLeader
    Dim leaderType As Integer
    Dim points(0 To 8) As Double
    Dim annotationObject As Object
    points(0) = 1: points(1) = 1: points(2) = 0
    points(3) = 6: points(4) = 6: points(5) = 0
    points(6) = 20: points(7) = 30: points(8) = 0

    leaderType = zcLineWithArrow
    Set annotationObject = MTextObj
    Set leaderObj = ThisDrawing.ModelSpace.AddLeader(points, annotationObject, leaderType)
    ThisDrawing.Regen zcActiveViewport

    Dim msg As String
    msg = IIf(leaderObj.Annotation Is Nothing, "does not have", "has")
    MsgBox "The new Leader object " & msg & " an associated Annotation object."

End Sub


Application Property Example
Sub Example_Application()
    ' This example creates a arc and then uses the
    ' Application property of the arc to return the
    ' application name.

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    ' Define the Arc
    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 30 * 3.1415926 / 180#
    endAngle = 270 * 3.1415926 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)

    ' Return the application for the object
    Set myApp = arcObj.Application

    ' Display the name of the application
    MsgBox "The application name is: " & myApp.Name, vbInformation, "Application Example"

End Sub


ArcLength Property Example
Sub Example_ArcLength()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 30 * 3.1415926 / 180#
    endAngle = 270 * 3.1415926 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport

    MsgBox "The length of the new Arc is: " & arcObj.ArcLength

End Sub


Area Property Example
Sub Example_Area()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    ' Define the Arc
    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 30 * 3.1415926 / 180#
    endAngle = 270 * 3.1415926 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    Dim arcArea As Double
    arcArea = arcObj.Area
    MsgBox "The Area of the Arc is: " & arcArea, vbInformation, "Area Example"

End Sub


ArrowheadSize Property Example
Sub Example_ArrowHeadSize()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim BlockName As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 1: AngleVertex(1) = 1: AngleVertex(2) = 0
    FirstPoint(0) = 3: FirstPoint(1) = 3: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 5: SecondPoint(2) = 0
    TextPoint(0) = 10: TextPoint(1) = 6: TextPoint(2) = 0

    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The arrowhead size for this object is currently set to: " & DimPointAngularObj.ArrowheadSize

    DimPointAngularObj.ArrowheadSize = 5
    DimPointAngularObj.Update
    MsgBox "The arrowhead size for this object is now set to: " & DimPointAngularObj.ArrowheadSize

End Sub


AssociativeHatch Property Example
Sub Example_AssociativeHatch()

    Dim hatchobj As ZcadHatch
    Dim patternname As String
    Dim patterntype As Long
    Dim bassociativity As Boolean
    patternname = "ANSI31"
    patterntype = zcHatchPatternTypePreDefined
    bassociativity = True
    Set hatchobj = ThisDrawing.ModelSpace.AddHatch(patterntype, patternname, bassociativity)

    Dim outerloop(0 To 1) As ZcadEntity
    Dim center(0 To 2) As Double
    Dim arcobj As ZcadArc
    Dim startangle As Double
    Dim endangle As Double
    center(0) = 5
    center(1) = 3
    center(2) = 0
    startangle = 0
    endangle = 3.141592

    Set outerloop(0) = ThisDrawing.ModelSpace.AddArc(center, 3, starangle, endangle)
    Set arcobj = outerloop(0)
    Set outerloop(1) = ThisDrawing.ModelSpace.AddLine(arcobj.startPoint, arcobj.endPoint)
    hatchobj.AppendOuterLoop (outerloop)
    ThisDrawing.Regen zcActiveViewport

    Dim innerloop(0) As ZcadEntity
    center(0) = 5
    center(1) = 4.5
    center(2) = 0
    Set innerloop(0) = ThisDrawing.ModelSpace.AddCircle(center, 0.5)
    hatchobj.AppendInnerLoop (innerloop)
    hatchobj.PatternScale = 0.1
    hatchobj.PatternAngle = 1.57
    hatchobj.Evaluate
    MsgBox hatchobj.AssociativeHatch
    ThisDrawing.Regen zcActiveViewport

End Sub


AttachmentPoint Property Example
Sub Example_AttachmentPoint()

    Dim mtextObj As ZcadMText
    Dim width As Double
    Dim text As String
    Dim count As Integer
    Dim attachPoint As String
    Dim corner(0 To 2) As Double

    corner(0) = 100#: corner(1) = 100#: corner(2) = 0#
    width = 10
    text = "Test Mtext word"
    Set mtextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

    For count = 1 To 9

        mtextObj.AttachmentPoint = count
        attachPoint = Choose(mtextObj.AttachmentPoint, "TopLeft", "TopCenter", "TopRight", "MiddleLeft", "MiddleCenter", "MiddleRight", "BottomLeft", "BottomCenter", "BottomRight")
        mtextObj.Update
        ThisDrawing.Regen zcActiveViewport
        MsgBox "The attachment point of the MText is now: " & attachPoint, vbInformation, "AttachmentPoint Example"

    Next

End Sub


Author Property Example
Sub Example_Author()

    ThisDrawing.SummaryInfo.Author = "Eason"
    ThisDrawing.SummaryInfo.Comments = "Developer Help documentation"
    ThisDrawing.SummaryInfo.HyperlinkBase = "http://www.zwsoft.com"
    ThisDrawing.SummaryInfo.Keywords = "VBA"
    ThisDrawing.SummaryInfo.LastSavedBy = "JD"
    ThisDrawing.SummaryInfo.RevisionNumber = "2023"
    ThisDrawing.SummaryInfo.Subject = "VBA COM"
    ThisDrawing.SummaryInfo.Title = "ZWCAD2023"

    Author = ThisDrawing.SummaryInfo.Author
    Comments = ThisDrawing.SummaryInfo.Comments
    HLB = ThisDrawing.SummaryInfo.HyperlinkBase
    KW = ThisDrawing.SummaryInfo.Keywords
    LSB = ThisDrawing.SummaryInfo.LastSavedBy
    RN = ThisDrawing.SummaryInfo.RevisionNumber
    Subject = ThisDrawing.SummaryInfo.Subject
    Title = ThisDrawing.SummaryInfo.Title
    MsgBox "The standard drawing properties are " & vbCrLf & _
            "Author = " & Author & vbCrLf & _
            "Comments = " & Comments & vbCrLf & _
            "HyperlinkBase = " & HLB & vbCrLf & _
            "Keywords = " & KW & vbCrLf & _
            "LastSavedBy = " & LSB & vbCrLf & _
            "RevisionNumber = " & RN & vbCrLf & _
            "Subject = " & Subject & vbCrLf & _
            "Title = " & Title & vbCrLf

End Sub


BackgroundFill Property Example
Sub Example_BackgroundFill()

    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 0
    center(1) = 0
    center(2) = 0
    radius = 20
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(center, radius)
    ThisDrawing.Regen zcActiveViewport

    Dim MTextObj As ZcadMText
    Dim width As Double
    Dim text As String
    width = 50
    text = "This is the text for the MText object"
    Set MTextObj = ThisDrawing.ModelSpace.AddMText(center, width, text)
    ThisDrawing.Regen zcActiveViewport
    MTextObj.BackgroundFill = True

End Sub


Backward Property Example
Sub Example_Backward()
    ' This example creates an attribute definition in model space.

    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String

    height = 20#
    mode = zcAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "New Tag"
    value = "New Value"

    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    attributeObj.Backward = True
    attributeObj.Update
    MsgBox "The attribute definition object is now backward"
    ThisDrawing.Application.ZoomAll

End Sub


BasePoint Property Example
Sub Example_BasePoint()

    Dim basePoint(0 To 2) As Double
    Dim directionVec(0 To 2) As Double
    Dim rayObj As ZcadRay
    Dim msg As String
    Dim newSecondPoint(0 To 2) As Double
    basePoint(0) = 1: basePoint(1) = 3: basePoint(2) = 0
    directionVec(0) = 5:    directionVec(1) = 5: directionVec(2) = 0
    Set rayObj = ThisDrawing.ModelSpace.AddRay(basePoint, directionVec)
    ThisDrawing.Regen zcActiveViewport

    newSecondPoint(0) = 4: newSecondPoint(1) = 2: newSecondPoint(2) = 0
    rayObj.basePoint = newSecondPoint
    msg = "X Vaule is: " & rayObj.basePoint(0) & vbCrLf & _
          "Y Vaule is: " & rayObj.basePoint(1) & vbCrLf & _
          "Z Vaule is: " & rayObj.basePoint(2)
    rayObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "Change the Base point of the new Ray to: " & vbCrLf & msg, vbInformation

End Sub


BigFontFile Property Example
Sub Example_BigFontFile()

    Dim textStyle As ZcadTextStyle
    Dim currBigFontFile As String
    Dim newBigFontFile As String

    Set textStyle = ThisDrawing.ActiveTextStyle

    ' Retrieve the current BigFontFile value
    currBigFontFile = textStyle.BigFontFile
    MsgBox "The current value for BigFontFile is " & currBigFontFile, vbInformation, "BigFontFile Example"

    ' Change the value for BigFontFile
    newBigFontFile = "X:\Program Files\ZWCAD 2023\fonts\gbcbig.shx"
    textStyle.BigFontFile = newBigFontFile
    MsgBox "The new value for BigFontFile is " & newBigFontFile, vbInformation, "BigFontFile Example"

End Sub


Block Property Example

Sub Example_Block()
    ' This example finds the name of the block associated with a layout.

    Dim xBlock As ZcadBlock
    Set xBlock = ThisDrawing.ActiveLayout.Block
    MsgBox "The active layout corresponds to block: " & xBlock.Name

End Sub


Blocks Property Example
Sub Example_Blocks()

    Dim newBlock As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 0#: insertionPnt(1) = 0#: insertionPnt(2) = 0#

    ' Add the new block into the Blocks collection
    Set newBlock = ThisDrawing.Blocks.Add(insertionPnt, "TEST")
    MsgBox "A block called " & newBlock.Name & " has been added to the blocks collection", vbInformation, "Blocks Example"

End Sub


Blue Property Example

Sub Example_Blue()

    ' This example draws a line and returns the RGB values
    Dim fcolor As ZcadZcCmColor
    Set fcolor = ZcadApplication.GetInterfaceObject("ZWCAD.ZcCmColor")
    Call fcolor.SetRGB(30, 100, 200)

    Dim line As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#

    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    ThisDrawing.Regen zcActiveViewport
    line.TrueColor = fcolor
    line.Update
    Dim retcolor As ZcadZcCmColor
    Set retcolor = line.TrueColor
    MsgBox "Blue = " & retcolor.Blue

End Sub


BookName Property Example
Sub Example_BookName()

    ' This example draws a line and specifies a color name
    ' from an existing color book.

    Dim FirstColor As ZcadZcCmColor
    Set FirstColor = ZcadApplication.GetInterfaceObject("ZWCAD.ZcCmColor")

    Call FirstColor.SetRGB(80, 100, 244)

    Dim line As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#

    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    line.TrueColor = FirstColor
    line.Update
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll
    Call FirstColor.SetColorBookColor("RAL CLASSIC", "RAL 1000")
    line.TrueColor = FirstColor
    line.Update
    MsgBox "BookName=" & FirstColor.BookName

End Sub


Brightness Property Example
Sub Example_Brightness()

    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "C:\boot\123.jpg"
    insertionPoint(0) = 100#: insertionPoint(1) = 100#: insertionPoint(2) = 0#
    scalefactor = 1
    rotationAngle = 0
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)
    rasterObj.Brightness = 30
    rasterObj.Update
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


CanonicalMediaName Property Example
Sub Example_CanonicalMediaName()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    If PlotConfigurations.count = 0 Then
      Set PlotConfiguration = PlotConfigurations.Add("test")
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    Dim MediaName As String
    MediaName = PlotConfiguration.CanonicalMediaName

    If MediaName = "" Then
        MsgBox "There is no media set for the active layout."
    Else
        MsgBox "The media for the active layout is: " & MediaName
    End If

End Sub


Caption Property Example
Sub Example_Caption()
    ' This example returns the caption for the current
    ' ZWCAD session.

    ' Get the Caption property
    Dim strCaption As String
    strCaption = ThisDrawing.Application.Caption
    MsgBox "The caption for this session is " & strCaption, , "Caption Example"

End Sub


Center Property Example
Sub Example_Center()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 30 * 3.1415926 / 180#
    endAngle = 270 * 3.1415926 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The center point of the Arc is " & centerPoint(0) & ", " & centerPoint(1) & ", " & centerPoint(2), vbInformation, "Center Example"

    ' Change the center point of the Arc
    Dim newCenterPt(0 To 2) As Double
    newCenterPt(0) = 100: newCenterPt(1) = 100: newCenterPt(2) = 0
    arcObj.center = newCenterPt
    arcObj.Update

    Dim centerPt As Variant
    centerPt = arcObj.center
    MsgBox "The center point of the Arc is " & centerPt(0) & ", " & centerPt(1) & ", " & centerPt(2), vbInformation, "Center Example"

End Sub


CenterMarkSize Property Example
Sub Example_CenterMarkSize()
    ' This example creates a diametric dimension in model space.
    ' It then changes the type of center for the dimension to
    ' center mark, and adjusts the size of the center mark.

    Dim dimObj As ZcadDimDiametric
    Dim chordPoint(0 To 2) As Double
    Dim farChordPoint(0 To 2) As Double
    Dim leaderLength As Double

    ' Define the dimension
    chordPoint(0) = 5#: chordPoint(1) = 3#: chordPoint(2) = 0#
    farChordPoint(0) = 5#: farChordPoint(1) = 10#: farChordPoint(2) = 0#
    leaderLength = 1#

    ' Create the diametric dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimDiametric(chordPoint, farChordPoint, leaderLength)
    dimObj.Update

    ' Change the center type to center mark and set the size of the center mark
    dimObj.CenterType = zcCenterMark
    dimObj.CenterMarkSize = 2
    dimObj.Update
    MsgBox "The center mark size is: " & dimObj.CenterMarkSize

    dimObj.CenterMarkSize = dimObj.CenterMarkSize * 2
    dimObj.Update
    MsgBox "The center mark size is: " & dimObj.CenterMarkSize

End Sub


CenterPlot Property Example
Sub Example_CenterPlot()
    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.count = 0 Then
        '*** Customize the new configuration to your satisfaction ***
        PlotConfigurations.Add "NEW_CONFIGURATION"
    End If

    Set PlotConfiguration = PlotConfigurations(0)
    PlotConfiguration.PlotType = zcDisplay
    PlotConfiguration.CenterPlot = True 'Not PlotConfiguration.CenterPlot

    If PlotConfiguration.CenterPlot Then
        MsgBox PlotConfiguration.Name & "  IsCentered"
    Else
        MsgBox PlotConfiguration.Name & "  Not IsCentered"
    End If
End Sub


CenterType Property Example
Sub Example_CenterType()
    ' This example creates a diametric dimension in model space.
    ' It then changes the type of center for the dimension.

    Dim dimObj As ZcadDimDiametric
    Dim chordPoint(0 To 2) As Double
    Dim farChordPoint(0 To 2) As Double
    Dim leaderLength As Double

    ' Define the dimension
    chordPoint(0) = 5#: chordPoint(1) = 3#: chordPoint(2) = 0#
    farChordPoint(0) = 5#: farChordPoint(1) = 15#: farChordPoint(2) = 0#
    leaderLength = 2#

    ' Create the diametric dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimDiametric(chordPoint, farChordPoint, leaderLength)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents

    ' Change the center type to center mark
    dimObj.CenterType = zcCenterMark
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The dimension center type is set to center mark."

    ' Change the center type to center line
    dimObj.CenterType = zcCenterLine
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The dimension center type is set to center line."

    ' Set the center to be none
    dimObj.CenterType = zcCenterNone
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The dimension center type is set to none."

End Sub


Centroid Property Example
Sub Example_Centroid()
    ' This example creates a box in model space.
    ' It then returns the Centroid for that box.

    Dim boxObj As Zcad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double

    ' Define the box
    center(0) = 5#: center(1) = 5#: center(2) = 0
    length = 5#: width = 7: height = 10#

    ' Create the box (3DSolid) object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents

    ' Return the Centroid for the box
    Dim Centroid As Variant
    Centroid = boxObj.Centroid
    MsgBox "The Centroid for the box is " & Centroid(0) & ", " & Centroid(1) & ", " & Centroid(2), , "Centroid Example"

End Sub


Circumference Property Example
Sub Example_Circumference()
    ' This example creates a Circle object in model space and
    ' returns the circumference of the Circle

    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double

    ' Define the circle
    centerPoint(0) = 10#: centerPoint(1) = 10#: centerPoint(2) = 0#
    radius = 20#

    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents
    MsgBox "The circumference of the new Circle is: " & circleObj.Circumference

End Sub


ClippingEnabled Property Example
Sub Example_ClippingEnabled()

    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "C:\boot\123.jpg"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0#
    scalefactor = 1
    rotationAngle = 0
    On Error Resume Next
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)
    If Err.Number <> 0 Then
    Exit Sub
    End If
    Dim points(0 To 11) As Double
    points(0) = 5: points(1) = 5: points(2) = 0
    points(3) = 65: points(4) = 69: points(5) = 0
    points(6) = 68: points(7) = -8: points(8) = 0
    points(9) = 5: points(10) = 5: points(11) = 0
    rasterObj.ClipBoundary points
    rasterObj.ClippingEnabled = False
    rasterObj.Update
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


Closed Property Example
Sub Example_Closed()

    Dim polyObj As Zcad3DPolyline
    Dim closedState As String
    Dim Points(0 To 8) As Double
    Points(0) = 1: Points(1) = 2: Points(2) = 0
    Points(3) = 3: Points(4) = 7: Points(5) = 0
    Points(6) = 10: Points(7) = 3: Points(8) = 0

    ' Create a 3DPolyline in model space
    Set polyObj = ThisDrawing.ModelSpace.Add3DPoly(Points)
    ThisDrawing.Regen zcActiveViewport

    ' Set the closed property to True
    polyObj.Closed = True      ' Close 3DPolyline
    ThisDrawing.Regen zcActiveViewport
    GoSub DISPLAY

    ' Open the 3DPolyline by setting the closed property to False
    polyObj.Closed = False      ' Open 3DPolyline
    ThisDrawing.Regen zcActiveViewport
    GoSub DISPLAY

    Exit Sub

DISPLAY:
    ' Retrieve and display the Closed property
    closedState = IIf(polyObj.Closed, "Closed", "Open")
    MsgBox "The new 3DPolyline is: " & closedState, vbInformation, "Closed Example"
    Return
End Sub


Color Property Example
Sub Example_Color()

    Dim lwplineObj As ZcadLWPolyline
    Dim points(0 To 5) As Double
    points(0) = 3: points(1) = 7
    points(2) = 9: points(3) = 2
    points(4) = 3: points(5) = 5

    ' Create the polyline in model space
    Set lwplineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(points)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomExtents

    MsgBox "The Polyline of color is :" & lwplineObj.Color
    lwplineObj.Color = zcRed
    lwplineObj.Update
    MsgBox "The Polyline of color is :" & lwplineObj.Color

End Sub


ColorIndex Property Example
Sub Example_ColorIndex()

    Dim colorobj As New ZcadZcCmColor
    Call colorobj.SetRGB(125, 175, 200)

    Dim circleobj As ZcadCircle
    Dim pt(0 To 2) As Double
    Dim radius As Double
    pt(0) = 0
    pt(1) = 0
    pt(2) = 0
    radius = 100
    Set circleobj = ThisDrawing.ModelSpace.AddCircle(pt, radius)
    circleobj.TrueColor = colorobj
    circleobj.Update
    ThisDrawing.Regen zcActiveViewport

    If colorobj.ColorMethod = ZwCAD.zcColorMethodByRGB Then
    MsgBox "The Closest ColorIndex is " & colorobj.ColorIndex
    End If

End Sub


ColorName Property Example
Sub Example_Colorname()

    ' This example draws a line and specifies a color name
    ' from an existing color book.

    Dim FirstColor As ZcadZcCmColor
    Set FirstColor = Library.CreateTrueColor
    Call FirstColor.SetRGB(80, 100, 244)

    Dim line As ZcadLine
    Dim startPoint (0 To 2) As Double
    Dim endPoint (0 To 2) As Double

    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#

    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    line.TrueColor = FirstColor
    line.Update
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll
    Call FirstColor.SetColorBookColor("RAL CLASSIC", "RAL 1000")
    line.TrueColor = FirstColor
    line.Update
    MsgBox "ColorName=" & FirstColor.ColorName

 End Sub


Comments Property Example
Sub Example_Comments()

    ThisDrawing.SummaryInfo.Author = "Eason"
    ThisDrawing.SummaryInfo.Comments = "Developer Help documentation"
    ThisDrawing.SummaryInfo.HyperlinkBase = "http://www.zwsoft.com"
    ThisDrawing.SummaryInfo.Keywords = "VBA"
    ThisDrawing.SummaryInfo.LastSavedBy = "JD"
    ThisDrawing.SummaryInfo.RevisionNumber = "2023"
    ThisDrawing.SummaryInfo.Subject = "VBA COM"
    ThisDrawing.SummaryInfo.Title = "ZWCAD2023"

    Author = ThisDrawing.SummaryInfo.Author
    Comments = ThisDrawing.SummaryInfo.Comments
    HLB = ThisDrawing.SummaryInfo.HyperlinkBase
    KW = ThisDrawing.SummaryInfo.Keywords
    LSB = ThisDrawing.SummaryInfo.LastSavedBy
    RN = ThisDrawing.SummaryInfo.RevisionNumber
    Subject = ThisDrawing.SummaryInfo.Subject
    Title = ThisDrawing.SummaryInfo.Title
    MsgBox "The standard drawing properties are " & vbCrLf & _
            "Author = " & Author & vbCrLf & _
            "Comments = " & Comments & vbCrLf & _
            "HyperlinkBase = " & HLB & vbCrLf & _
            "Keywords = " & KW & vbCrLf & _
            "LastSavedBy = " & LSB & vbCrLf & _
            "RevisionNumber = " & RN & vbCrLf & _
            "Subject = " & Subject & vbCrLf & _
            "Title = " & Title & vbCrLf

End Sub


ConfigName Property Example
Sub Example_ConfigName()
    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.count = 0 Then
        '*** Customize the new configuration to your satisfaction ***
        PlotConfigurations.Add "NEW_CONFIGURATION"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    PlotConfiguration.ConfigName = "DWG TO PDF.pc5"

    MsgBox PlotConfiguration.ConfigName
End Sub


Constant Property Example
Sub Example_Constant()

    ' Create the block
    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 0#: insertionPnt(1) = 0#: insertionPnt(2) = 0#
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "TESTBLOCK")

    ' Define the attribute definition
    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String
    height = 1#
    mode = zcAttributeModeVerify
    prompt = "Attribute Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "Attribute Tag"
    value = "Attribute Value"
    ' Create the attribute definition object in model space
    Set attributeObj = blockObj.AddAttribute(height, mode, prompt, insertionPoint, tag, value)

GoSub QUERYSTATUS

    ' Change the attribute
    attributeObj.Constant = Not attributeObj.Constant
    GoSub QUERYSTATUS

    Exit Sub

QUERYSTATUS:
    If attributeObj.Constant Then
        MsgBox "The attribute is a constant attribute."
    Else
        MsgBox "The attribute is not a constant attribute."
    End If
    Return

End Sub


ConstantWidth Property Example
Sub Example_ConstantWidth()

    Dim plineObj As ZcadLWPolyline
    Dim Points(0 To 9) As Double

    Points(0) = 1: Points(1) = 1
    Points(2) = 1: Points(3) = 2
    Points(4) = 2: Points(5) = 2
    Points(6) = 3: Points(7) = 2
    Points(8) = 4: Points(9) = 4
    Set plineObj = ThisDrawing.ModelSpace.AddLightWeightPolyline(Points)
    MsgBox "ConstantWidth is:" & "  " & plineObj.ConstantWidth, , "Example ConstantWidth"
    plineObj.ConstantWidth = 2
    plineObj.Update
    MsgBox "ConstantWidth is Now:" & "  " & plineObj.ConstantWidth, , "Example ConstantWidth"

End Sub


Contrast Property Example
Sub Example_Contrast()

    On Error Resume Next
    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "C:\boot\123.jpg"
    insertionPoint(0) = 100#: insertionPoint(1) = 100#: insertionPoint(2) = 0#
    scalefactor = 1
    rotationAngle = 0
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)
    If Err.Number = 0 Then
    Exit Sub
    End If
    rasterObj.Contrast = 30
    rasterObj.Update
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll

End Sub


ControlPoints Property Example
Sub Example_ControlPoints()

    ' Create the spline
    Dim splineObj As ZcadSpline
    Dim points(0 To 8) As Double

    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 13: points(7) = 5: points(8) = 0

    ' Create the spline in model space
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    splineObj.Update
    ThisDrawing.Application.ZoomAll

    ' Display the coordinates of the first control point
    Dim ControlPoints As Variant
    ControlPoints = splineObj.ControlPoints
    MsgBox "Control point 1 is at " & ControlPoints(0) & ", " & ControlPoints(1) & ", " & ControlPoints(2), , "ControlPoints Example"

    ' Change the coordinate of the first control point
    ControlPoints(0) = 0: ControlPoints(1) = 3: ControlPoints(2) = 0
    splineObj.ControlPoints = ControlPoints
    splineObj.Update
    ThisDrawing.Application.ZoomAll

    MsgBox "Control point 1 is now at " & ControlPoints(0) & ", " & ControlPoints(1) & ", " & ControlPoints(2), , "ControlPoints Example"

End Sub


Coordinate Property Example
Sub Example_Coordinate()

    ' This example creates a 3DPolyline in model space and
    ' queries and changes the coordinate in the first index position.
    Dim polyObj As Zcad3DPolyline
    Dim Points(0 To 8) As Double

    Points(0) = 1: Points(1) = 2: Points(2) = 0
    Points(3) = 3: Points(4) = 7: Points(5) = 10
    Points(6) = 10: Points(7) = 3: Points(8) = 0

    ' Create a 3DPolyline in model space
    Set polyObj = ThisDrawing.ModelSpace.Add3DPoly(Points)
    ThisDrawing.Regen zcActiveViewport

    ' Find the coordinate in the first index position
    Dim coord As Variant
    coord = polyObj.Coordinate(0)
    MsgBox "The coordinate in the first index position of the 3DPolyline is: " & coord(0) & ", " & coord(1) & ", " & coord(2) & ""

    ' Change the coordinate
    coord(0) = 2
    coord(1) = 2
    coord(2) = 0
    polyObj.Coordinate(0) = coord
    polyObj.Update
    coord = polyObj.Coordinate(0)

    ' Query the new coordinate
    MsgBox "The coordinate in the first index position of the 3DPolyline is now: " & coord(0) & ", " & coord(1) & ", " & coord(2) & ""
    ThisDrawing.Regen zcActiveViewport

  End Sub


Coordinates Property Example
Sub Example_Coordinates()

    ' Create Polyline
    Dim plineObj As ZcadPolyline
    Dim points(0 To 5) As Double

    points(0) = 1: points(1) = 1: points(2) = 0
    points(3) = 2: points(4) = 2: points(5) = 0

    Set plineObj = ThisDrawing.ModelSpace.AddPolyline(points)
    ThisDrawing.Regen zcActiveViewport
    Dim coord As Variant
    coord = plineObj.Coordinates
    MsgBox "The coordinate in the first index position of the Polyline is: " & coord(0) & ", " & coord(1) & ", " & coord(2) & ""

    ' Change the coordinate
    coord(0) = 10
    coord(1) = 3
    coord(2) = 0
    plineObj.Coordinates = coord
    plineObj.Update
    coord = plineObj.Coordinates
    MsgBox "The coordinate in the first index position of the Polyline is: " & coord(0) & ", " & coord(1) & ", " & coord(2) & ""

End Sub


Count Property Example
Sub Example_Count()

    MsgBox "There are " & ThisDrawing.Layers.Count & " layer(s) in the drawing."
    MsgBox "There are " & ThisDrawing.ModelSpace.Count & " object(s) in ModelSpace."

End Sub


CustomScale Property Example
Sub Example_CustomScale()

    Dim pviewportObj As ZcadPViewport
    Dim center(0 To 2) As Double
    Dim width As Double
    Dim height As Double

    ' Define the paper space viewport
    center(0) = 3: center(1) = 3: center(2) = 0
    width = 40
    height = 40

    ' Change from model space to paper space
    ThisDrawing.ActiveSpace = zcPaperSpace

    ' Create the paper space viewport
    Set pviewportObj = ThisDrawing.PaperSpace.AddPViewport(center, width, height)
    MsgBox "The scale of the new PViewport is: " & pviewportObj.CustomScale
    pviewportObj.CustomScale = 0.5
    pviewportObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The scale of the new PViewport has been changed to: " & pviewportObj.CustomScale

End Sub


ImageFile Property Example
Sub Example_ImageFile()

    On Error Resume Next
    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "C:\boot\123.jpg"
    insertionPoint(0) = 100#: insertionPoint(1) = 100#: insertionPoint(2) = 0#
    scalefactor = 1
    rotationAngle = 0
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.ActiveViewport.ZoomAll
    MsgBox rasterObj.ImageFile

End Sub


ImageHeight Property Example
Sub Example_ImageHeight()

    On Error Resume Next
    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "C:\boot\123.jpg"
    insertionPoint(0) = 100#: insertionPoint(1) = 100#: insertionPoint(2) = 0#
    scalefactor = 1
    rotationAngle = 0
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.ActiveViewport.ZoomAll
    MsgBox rasterObj.ImageHeight

End Sub


ImageVisibility Property Example
Sub Example_ImageVisibility()

    On Error Resume Next
    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "C:\boot\123.jpg"
    insertionPoint(0) = 100#: insertionPoint(1) = 100#: insertionPoint(2) = 0#
    scalefactor = 1
    rotationAngle = 0
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.ActiveViewport.ZoomAll
    MsgBox rasterObj.ImageVisibility

End Sub


ImageWidth Property Example
Sub Example_ImageWidth()

    On Error Resume Next
    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "C:\boot\123.jpg"
    insertionPoint(0) = 100#: insertionPoint(1) = 100#: insertionPoint(2) = 0#
    scalefactor = 1
    rotationAngle = 0
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.ActiveViewport.ZoomAll
    MsgBox rasterObj.ImageWidth

End Sub


InsertionPoint Property Example
Sub Example_InsertionPoint()
    ' This example creates a text object in model space.
    ' It then changes the insertion point of the text object.

    Dim mtextObj As ZcadMText
    Dim width As Double
    Dim text As String
    Dim corner(0 To 2) As Double

    corner(0) = 3#: corner(1) = 3#: corner(2) = 0#
    width = 3
    text = "This is a text String."
    ' Creates a MText object in model space
    Set mtextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)
    mtextObj.Height = 1
    mtextObj.Update
    ZoomAll

    ' Return the current value of the insertion point
    Dim currInsertionPoint As Variant
    currInsertionPoint = mtextObj.insertionPoint
    MsgBox "The insertion point of the text is " & currInsertionPoint(0) & ", " & currInsertionPoint(1) & ", " & currInsertionPoint(2), vbInformation, "InsertionPoint Example"

    ' Change the insertion point of the text object and
    ' update the display of the text object.
    Dim insertionPoint(0 To 2) As Double
    insertionPoint(0) = 1: insertionPoint(1) = 1: insertionPoint(2) = 0
    mtextObj.insertionPoint = insertionPoint
    mtextObj.Update
    MsgBox "The new insertion point of the text is " & mtextObj.insertionPoint(0) & ", " & mtextObj.insertionPoint(1) & ", " & mtextObj.insertionPoint(2), vbInformation, "InsertionPoint Example"

End Sub


IntersectWith Property Example
Sub Example_IntersectWith()
    ' This example creates an arc and arc and finds the points at
    ' which they intersect.

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim pt(0 To 2) As Double
    Dim startAngle As Double, endAngle As Double
    Dim r As Double
    r = 5
    startAngle = 0
    endAngle = 3.14
    pt(0) = 2#: pt(1) = 2#: pt(1) = 0#
    Set arcObj = ThisDrawing.ModelSpace.AddArc(pt, r, startAngle, endAngle)

    ' Create the circle
    Dim circleObj As ZcadCircle
    Dim centerPt(0 To 2) As Double
    Dim radius As Double
    centerPt(0) = 3: centerPt(1) = 3: centerPt(2) = 0
    radius = 5
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPt, radius)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Find the intersection points between the arc and the circle
    Dim intPoints As Variant
    intPoints = arcObj.IntersectWith(circleObj, zcExtendNone)

    ' Print all the intersection points
    Dim I As Integer, j As Integer, k As Integer
    Dim str As String
    If VarType(intPoints) <> vbEmpty Then
        For I = LBound(intPoints) To UBound(intPoints)
            str = "Intersection Point[" & k & "] is: " & intPoints(j) & "," & intPoints(j + 1) & "," & intPoints(j + 2)
            MsgBox str
            str = ""
            I = I + 2
            j = j + 3
            k = k + 1
        Next
    End If

End Sub


Invisible Property Example
Sub Example_Invisible()

    On Error Resume Next
    ' Create the block
    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 0#: insertionPnt(1) = 0#: insertionPnt(2) = 0#
    Err.Clear
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "TESTBLOCK")
    If Err > 0 Then
        ThisDrawing.Blocks.Item("TESTBLOCK").Delete
        Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "TESTBLOCK")
    End If

    ' Define the attribute definition
    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String
    height = 1#
    mode = zcAttributeModeVerify
    prompt = "Attribute Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "Attribute Tag"
    value = "Attribute Value"

    ' Create the attribute definition object in model space
    Set attributeObj = blockObj.AddAttribute(height, mode, prompt, insertionPoint, tag, value)

    ' Insert the block
    Dim blockRefObj As ZcadBlockReference
    insertionPnt(0) = 2#: insertionPnt(1) = 2#: insertionPnt(2) = 0
    Set blockRefObj = ThisDrawing.ModelSpace.InsertBlock(insertionPnt, "TESTBLOCK", 1#, 1#, 1#, 0)
    ZoomAll

    ' Get the attributes
    Dim newAttributes As Variant
    newAttributes = blockRefObj.GetAttributes

    newAttributes(0).Invisible = False
    newAttributes(0).Update
    ZoomAll
    MsgBox "Visible...."
    newAttributes(0).Invisible = True
    newAttributes(0).Update
    MsgBox "Invisible...."
    ZoomAll

End Sub


IsLayout Property Example
Sub Example_IsLayout()

    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim InsertPoint(0 To 2) As Double
    Dim radius As Double
    Dim newBlock As ZcadBlock
    Dim tempBlock As ZcadBlock
    Dim msg As String

    ' Define the Circle object that will be inserted into the block
    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    InsertPoint(0) = 1: InsertPoint(1) = 1: InsertPoint(2) = 0
    radius = 0.5
    Dim BlockObjName As String
    BlockObjName = "abc"
    Set newBlock = ThisDrawing.Blocks.Add(centerPoint, BlockObjName)
    Set circleObj = newBlock.AddCircle(centerPoint, radius)
    Dim insertedBlock As ZcadBlockReference
    Set insertedBlock = ThisDrawing.ModelSpace.InsertBlock(InsertPoint, BlockObjName, 1, 1, 1, 0)
    ZoomAll
    msg = vbCrLf & vbCrLf

    For Each tempBlock In ThisDrawing.Blocks
        If Not (tempBlock.IsXRef) And Not (tempBlock.IsLayout) Then

            msg = msg & tempBlock.Name & ": Simple"
        ElseIf tempBlock.IsXRef Then

            msg = msg & tempBlock.Name & ": External Reference"

        ElseIf tempBlock.IsLayout Then

           msg = msg & tempBlock.Name & " and Contains Layout Geometry"

    End If
        msg = msg & vbCrLf
    Next

    MsgBox "Blocks in this drawing have the following styles: " & msg

End Sub


IsPeriodic Property Example
Sub Example_IsPeriodic()
    ' This example creates a Spline object in model space and
    ' determines if the Spline is periodic

    Dim plineObj As ZcadSpline
    Dim points(0 To 8) As Double
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 13: points(7) = 5: points(8) = 0

    ' Create the spline in model space
    Set plineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    Dim usermessage As String
    ' Display whether or not new Spline is periodic
    usermessage = IIf(plineObj.IsPeriodic, "is periodic", "is not periodic")
    MsgBox "The new Spline " & usermessage

End Sub


IsPlanar Property Example
Sub Example_IsPlanar()

    Dim plineObj As ZcadSpline
    Dim points(0 To 8) As Double
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 13: points(7) = 5: points(8) = 0

    ' Create the spline in model space
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Display whether or not new Spline is planar
    usermessage = IIf(splineObj.IsPlanar, "is planar", "is not planar")
    MsgBox "The new Spline " & usermessage

End Sub


IsQuiescent Property Example
Sub Example_IsQuiescent()

    Dim State As ZcadState
    Set State = Application.GetZcadState
    If State.IsQuiescent Then
        MsgBox "ZWCAD is quiescent."
    Else
        MsgBox "ZWCAD is not quiescent."
    End If

End Sub


IsRational Property Example
Sub Example_IsRational()
    ' This example creates a spline object in model space.
    ' It then determines whether the spline is rational or non-rational
    ' based on the IsRational property.

    ' Create the spline
    Dim plineObj As ZcadSpline
    Dim points(0 To 8) As Double
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 13: points(7) = 5: points(8) = 0

    ' Create the spline in model space
    Set plineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Display a message according to the IsRational value for the spline.
    If plineObj.IsRational Then
        MsgBox "The newly created Spline is a rational Spline", , "IsRational Example"
    Else
        MsgBox "The newly created Spline is a non-rational Spline", , "IsRational Example"
    End If

End Sub


IsXRef Property Example
Sub Example_IsXRef()

    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim InsertPoint(0 To 2) As Double
    Dim radius As Double
    Dim newBlock As ZcadBlock
    Dim tempBlock As ZcadBlock
    Dim msg As String

    ' Define the Circle object that will be inserted into the block
    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    InsertPoint(0) = 1: InsertPoint(1) = 1: InsertPoint(2) = 0
    radius = 0.5
    Dim BlockObjName As String
    BlockObjName = "abc"
    Set newBlock = ThisDrawing.Blocks.Add(centerPoint, BlockObjName)
    Set circleObj = newBlock.AddCircle(centerPoint, radius)
    Dim insertedBlock As ZcadBlockReference
    Set insertedBlock = ThisDrawing.ModelSpace.InsertBlock(InsertPoint, BlockObjName, 1, 1, 1, 0)
    ZoomAll
    msg = vbCrLf & vbCrLf
    For Each tempBlock In ThisDrawing.Blocks
        If Not (tempBlock.IsXRef) And Not (tempBlock.IsLayout) Then

            msg = msg & tempBlock.Name & ": Simple"
        ElseIf tempBlock.IsXRef Then

            msg = msg & tempBlock.Name & ": External Reference"

        ElseIf tempBlock.IsLayout Then

           msg = msg & tempBlock.Name & " and Contains Layout Geometry"

    End If
        msg = msg & vbCrLf
    Next
    MsgBox "Blocks in this drawing have the following styles: " & msg

End Sub


Keywords Property Example
Sub Example_Keywords()

    ThisDrawing.SummaryInfo.Author = "Eason"
    ThisDrawing.SummaryInfo.Comments = "Developer Help documentation"
    ThisDrawing.SummaryInfo.HyperlinkBase = "http://www.zwsoft.com"
    ThisDrawing.SummaryInfo.Keywords = "VBA"
    ThisDrawing.SummaryInfo.LastSavedBy = "JD"
    ThisDrawing.SummaryInfo.RevisionNumber = "2023"
    ThisDrawing.SummaryInfo.Subject = "VBA COM"
    ThisDrawing.SummaryInfo.Title = "zcad2023"

    Author = ThisDrawing.SummaryInfo.Author
    Comments = ThisDrawing.SummaryInfo.Comments
    HLB = ThisDrawing.SummaryInfo.HyperlinkBase
    KW = ThisDrawing.SummaryInfo.Keywords
    LSB = ThisDrawing.SummaryInfo.LastSavedBy
    RN = ThisDrawing.SummaryInfo.RevisionNumber
    Subject = ThisDrawing.SummaryInfo.Subject
    Title = ThisDrawing.SummaryInfo.Title
    MsgBox "The standard drawing properties are " & vbCrLf & _
            "Author = " & Author & vbCrLf & _
            "Comments = " & Comments & vbCrLf & _
            "HyperlinkBase = " & HLB & vbCrLf & _
            "Keywords = " & KW & vbCrLf & _
            "LastSavedBy = " & LSB & vbCrLf & _
            "RevisionNumber = " & RN & vbCrLf & _
            "Subject = " & Subject & vbCrLf & _
            "Title = " & Title & vbCrLf

End Sub


Knots Property Example
Sub Example_Knots()

    Dim splineObj As ZcadSpline
    Dim points(0 To 8) As Double
    Dim knotVector As Variant
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double

    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 3: points(7) = 5: points(8) = 0
    ' Create the spline in model space
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Display the knot vector of the new Spline
    knotVector = splineObj.Knots
    MsgBox "The knot vector of the new Spline is: " & vbCrLf & _
                                            knotVector(0) & vbCrLf & _
                                            knotVector(1) & vbCrLf & _
                                            knotVector(2)

End Sub


LargeButtons Property Example
Sub Example_LargeButtons()
    ' This example uses MenuGroups to obtain a reference to the zcad+ main menu.
    ' It then creates a new Toolbar (TestMenu) and inserts a ToolBarButton
    ' into it.  It then sets the LargeButtons property to change the visible style
    ' of all the system Toolbars

    Dim CurrSize As Boolean, ButtonSize As String
    Dim Toolbars As ZcadToolbars

    ' Make the system Toolbar buttons bigger
    Set Toolbars = ThisDrawing.Application.MenuGroups.Item(0).Toolbars

    ' Get current size
    CurrSize = Toolbars.LargeButtons

    ' Display current Toolbar size
    GoSub DISPLAY

    ' Toggle Toolbar size
    Toolbars.LargeButtons = Not (Toolbars.LargeButtons)

    ' Display current Toolbar size
    GoSub DISPLAY

    ' Reset to original value
    Toolbars.LargeButtons = CurrSize

    ' Display current Toolbar size
    GoSub DISPLAY

    Exit Sub

DISPLAY:
    ' Display button style
    ButtonSize = IIf(Toolbars.LargeButtons, "Large", "Normal size")
    MsgBox "We are displaying " & ButtonSize & " buttons.", vbInformation

    Return
End Sub


LastSavedBy Property Example
Sub Example_LastSavedBy()

    ThisDrawing.SummaryInfo.Author = "Eason"
    ThisDrawing.SummaryInfo.Comments = "Developer Help documentation"
    ThisDrawing.SummaryInfo.HyperlinkBase = "http://www.zwsoft.com"
    ThisDrawing.SummaryInfo.Keywords = "VBA"
    ThisDrawing.SummaryInfo.LastSavedBy = "JD"
    ThisDrawing.SummaryInfo.RevisionNumber = "2023"
    ThisDrawing.SummaryInfo.Subject = "VBA COM"
    ThisDrawing.SummaryInfo.Title = "zcad2023"

    Author = ThisDrawing.SummaryInfo.Author
    Comments = ThisDrawing.SummaryInfo.Comments
    HLB = ThisDrawing.SummaryInfo.HyperlinkBase
    KW = ThisDrawing.SummaryInfo.Keywords
    LSB = ThisDrawing.SummaryInfo.LastSavedBy
    RN = ThisDrawing.SummaryInfo.RevisionNumber
    Subject = ThisDrawing.SummaryInfo.Subject
    Title = ThisDrawing.SummaryInfo.Title
    MsgBox "The standard drawing properties are " & vbCrLf & _
            "Author = " & Author & vbCrLf & _
            "Comments = " & Comments & vbCrLf & _
            "HyperlinkBase = " & HLB & vbCrLf & _
            "Keywords = " & KW & vbCrLf & _
            "LastSavedBy = " & LSB & vbCrLf & _
            "RevisionNumber = " & RN & vbCrLf & _
            "Subject = " & Subject & vbCrLf & _
            "Title = " & Title & vbCrLf

End Sub


Layer Property Example
Sub Example_Layer()
    ' This example creates a new layer named "ABC" (colored blue).
    ' It then creates an arc and assigns it to layer "ABC"

    ' Create new layer
    Dim layerObj As ZcadLayer
    Set layerObj = ThisDrawing.Layers.Add("ABC")
    layerObj.color = zcRed

    ' Create arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 50#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "The arc has been created on layer " & arcObj.Layer, , "Layer Example"

    arcObj.Layer = "ABC"
    arcObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The arc is now on layer " & arcObj.Layer, , "Layer Example"

End Sub


LayerOn Property Example
Sub Example_LayerOn()

    Dim layerObj As ZcadLayer
    Set layerObj = ThisDrawing.Layers.Add("LayerOn")
    GoSub Test
    layerObj.LayerOn = Not (layerObj.LayerOn)
    GoSub Test
    Exit Sub

Test:
    If layerObj.LayerOn Then
        MsgBox "Layer " & layerObj.Name & " is turned on.", , "LayerOn Example"
    Else
        MsgBox "Layer " & layerObj.Name & " is turned off.", , "LayerOn Example"
    End If
    Return

End Sub


Layers Property Example
Sub Example_Layers()

    Dim testlayer As ZcadLayer
    Set testlayer = ThisDrawing.Layers.Add("TEST")
    MsgBox "A new layer called " & testlayer.Name & " has been added to the Layers collection.", vbInformation, "Layers Example"

End Sub


Layout Property Example
Sub Example_Layout()

    Dim Layout As ZcadLayout
    Set Layout = ThisDrawing.ModelSpace.Layout
    MsgBox "We now have access to the properties and methods of the model space Layout object!"
    MsgBox "The name of the model space Layout is: " & Layout.Name

End Sub


Layouts Property Example
Sub Example_Layouts()

    Dim Layouts As ZcadLayouts, Layout As ZcadLayout
    Dim msg As String
    Set Layouts = ThisDrawing.Layouts
    msg = vbCrLf

    For Each Layout In Layouts
        msg = msg & Layout.Name & vbCrLf
    Next

    MsgBox "There are " & Layouts.Count & " layouts in " & _
            ThisDrawing.WindowTitle & ":" & msg

End Sub


LeaderLength Property Example
Sub Example_LeaderLength()
    ' This example creates a diametric dimension
    ' and returns the LeaderLength for that dimension.

    Dim dimObj As ZcadDimDiametric
    Dim chordPoint(0 To 2) As Double
    Dim farChordPoint(0 To 2) As Double
    Dim leaderLength As Double

    ' Define the dimension
    chordPoint(0) = 5#: chordPoint(1) = 3#: chordPoint(2) = 0#
    farChordPoint(0) = 5#: farChordPoint(1) = 5#: farChordPoint(2) = 0#
    leaderLength = 20#

    ' Create the diametric dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimDiametric(chordPoint, farChordPoint, leaderLength)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

End Sub


length Property Example
Sub Example_length()

    Dim polyObj As Zcad3DPolyline
    Dim Points(0 To 8) As Double

    Points(0) = 0: Points(1) = 0: Points(2) = 0
    Points(3) = 10: Points(4) = 15: Points(5) = 10
    Points(6) = 20: Points(7) = 20: Points(8) = 20

    ' Create a 3DPolyline in model space
    Set polyObj = ThisDrawing.ModelSpace.Add3DPoly(Points)
    ZoomAll
    MsgBox "The length of the new 3DPolyline is: " & polyObj.Length

End Sub


LensLength Property Example
Sub Example_LensLength()

    Dim pviewportObj As ZcadPViewport
    Dim center(0 To 2) As Double
    Dim width As Double
    Dim height As Double

    ' Define the paper space viewport
    center(0) = 3: center(1) = 3: center(2) = 0
    width = 40
    height = 40

    ' Change from model space to paper space
    ThisDrawing.ActiveSpace = zcPaperSpace

    ' Create the paper space viewport
    Set pviewportObj = ThisDrawing.PaperSpace.AddPViewport(center, width, height)
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.Application.ZoomAll
    MsgBox "The lens length of the paperspace viewport is " & pviewportObj.LensLength, , "LensLength Example"

End Sub


LinearScaleFactor Property Example
Sub Example_LinearScaleFactor()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 10#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.LinearScaleFactor = 10
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox dimObj.LinearScaleFactor

End Sub


LineSpacingDistance Property Example
Sub Example_LineSpacingDistance()

    Dim MTextObj As ZcadMText
    Dim width As Double
    Dim text As String
    Dim CurrentDistance As Double
    Dim corner(0 To 2) As Double
    corner(0) = 100
    corner(1) = 10
    corner(2) = 0
    width = 50
    text = "This is the text for the MText object"

    ' Creates the MText Object
    Set MTextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)

    ' Find the current LineSpacingDistance
    CurrentDistance = MTextObj.LineSpacingDistance
    MsgBox "The LineSpacingDistance for the MText object is: " & CurrentDistance

    ' Change the LineSpacingDistance
    MTextObj.LineSpacingDistance = 1
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The LineSpacingDistance for the MText object is: " & MTextObj.LineSpacingDistance

    ' Reset the LineSpacingDistance
    MTextObj.LineSpacingDistance = CurrentDistance
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The LineSpacingDistance for the MText object is: " & MTextObj.LineSpacingDistance

End Sub


LineSpacingFactor Property Example
Sub Example_LineSpacingFactor()

    Dim MTextObj As ZcadMText
    Dim corner(0 To 2) As Double
    Dim width As Double
    Dim text As String
    corner(0) = 100#: corner(1) = 100#: corner(2) = 0#
    width = 100
    text = "This is the text String for the mtext Object"

    ' Creates the MText Object
    Set MTextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)

    ' Find the current LineSpacingFactor
    Dim currFactor As Double
    currFactor = MTextObj.LineSpacingFactor
    MsgBox "The LineSpacingFactor for the MText object is: " & currFactor

    ' Change the LineSpacingFactor
    MTextObj.LineSpacingFactor = 4
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The LineSpacingFactor for the MText object is: " & MTextObj.LineSpacingFactor

    ' Reset the LineSpacingFactor
    MTextObj.LineSpacingFactor = currFactor
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The LineSpacingFactor for the MText object is: " & MTextObj.LineSpacingFactor

End Sub


LineSpacingStyle Property Example
Sub Example_LineSpacingStyle()

    Dim MTextObj As ZcadMText
    Dim corner(0 To 2) As Double
    Dim width As Double
    Dim text As String
    corner(0) = 0#: corner(1) = 10#: corner(2) = 0#
    width = 40
    text = "This is the text String for the mtext Object"

    ' Creates the mtext Object
    Set MTextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)

    Dim currStyle As Integer
    currStyle = MTextObj.LineSpacingStyle
    MsgBox "The LineSpacingStyle for the MText object is: " & currStyle

    MTextObj.LineSpacingStyle = zcLineSpacingStyleExactly
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The LineSpacingStyle for the MText object is: " & MTextObj.LineSpacingStyle

    MTextObj.LineSpacingStyle = currStyle
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The LineSpacingStyle for the MText object is: " & MTextObj.LineSpacingStyle

End Sub


linetype Property Example
Sub Example_linetype()

    ' Search the arctypes collection for the DashDot linetype.
    Dim entry As ZcadLineType
    Dim found As Boolean
    found = False
    For Each entry In ThisDrawing.Linetypes
        If StrComp(entry.Name, "DASHDOT", 1) = 0 Then
            found = True
            Exit For
        End If
    Next
    If Not (found) Then ThisDrawing.Linetypes.Load "DASHDOT", "zwcad.lin"

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ZoomAll

    ' Change the arctype of the arc
    arcObj.Linetype = "DASHDOT"
    arcObj.Update
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

End Sub


LinetypeGeneration Property Example
Sub Example_LinetypeGeneration()

    Dim plineObj As ZcadPolyline
    Dim points(0 To 8) As Double

    ' Define the 2D polyline points
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 3: points(7) = 5: points(8) = 0

    ' Create a lightweight Polyline object in model space
    Set plineObj = ThisDrawing.ModelSpace.AddPolyline(points)
    ZoomAll

    ' Find the current linetype generation for the polyline
    MsgBox "The linetype generation for the polyline is: " & plineObj.LinetypeGeneration

    ' Change the linetype generation
    plineObj.LinetypeGeneration = Not plineObj.LinetypeGeneration
    plineObj.Update
    MsgBox "The linetype generation for the polyline is now: " & plineObj.LinetypeGeneration

End Sub


Linetypes Property Example
Sub Example_Linetypes()

    Dim entry As ZcadLineType
    Dim msg As String

    For Each entry In ThisDrawing.Linetypes
        msg = msg & entry.Name & vbCrLf
    Next
    MsgBox "The linetypes available in this document are:" & vbCrLf & msg, vbInformation, "Linetypes Example"

End Sub


linetypeScale Property Example
Sub Example_linetypeScale()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ZoomAll

    Dim currLTScale As Double
    currLTScale = arcObj.LinetypeScale
    MsgBox "The linetype scale for the arc is:" & arcObj.LinetypeScale, vbInformation, "linetypes Example"

    ' Set the arctype scale of an arc to 5
    arcObj.LinetypeScale = 5
    arcObj.Update
    MsgBox "The new linetype scale for the arc is:" & arcObj.LinetypeScale, vbInformation, "linetypes Example"

    ' Reset the arctype scale of an arc to what is was before
    arcObj.LinetypeScale = currLTScale
    arcObj.Update
    MsgBox "The linetype scale for the arc is reset to:" & arcObj.LinetypeScale, vbInformation, "linetypes Example"

End Sub


lineWeight Property Example
Sub Example_lineWeight()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 25#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ZoomAll

    ' Find the arcweight for the arc
    MsgBox "The current lineweight for the arc is " & arcObj.Lineweight

    ' Change the arcweight for the arc
    arcObj.Lineweight = zcLnWt211
    arcObj.Update
    MsgBox "The current lineweight for the arc is " & arcObj.Lineweight

End Sub


LocaleID Property Example
Sub Example_LocaleID()
    ' This code retrieves the Locale ID and displays it in a message box
    MsgBox "The locale ID is " & ThisDrawing.Application.LocaleId, , "LocaleID Example"

End Sub


Lock Property Example
Sub Example_Lock()

    Dim layerObj As ZcadLayer
    Set layerObj = ThisDrawing.Layers.Add("Lock")
    GoSub Test
    layerObj.Lock = Not (layerObj.Lock)

    GoSub Test
    Exit Sub

Test:
    If layerObj.Lock Then
        MsgBox "Layer " & layerObj.Name & " is locked.", , "Lock Example"
    Else
        MsgBox "Layer " & layerObj.Name & " is unlocked.", , "Lock Example"
    End If
    Return

End Sub


LowerLeftCorner Property Example
Sub Example_LowerLeftCorner()

    Dim newViewport As ZcadViewport
    Set newViewport = ThisDrawing.Viewports.Add("TESTVIEWPORT")

    ThisDrawing.ActiveViewport = newViewport

    Dim entry As ZcadViewport
    Dim lowerLeft As Variant
    For Each entry In ThisDrawing.Viewports
        entry.GridOn = True
        ThisDrawing.ActiveViewport = entry
        lowerLeft = entry.LowerLeftCorner
        MsgBox "The lower left corner of this viewport is " & lowerLeft(0) & ", " & lowerLeft(1), , "LowerLeftCorner Example"
        entry.GridOn = False
    Next

End Sub


Macro Property Example
Sub Example_Macro()
    ' This example creates a new menu called TestMenu and inserts a menu item
    ' into it. The menu is then displayed on the menu bar.
    ' To remove the menu after execution of this macro, use the Customize Menu
    ' option from the Tools menu.

    Dim currMenuGroup As ZcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new menu
    Dim newMenu As ZcadPopupMenu
    Set newMenu = currMenuGroup.Menus.Add("TestMenu")

    ' Add a menu item to the new menu
    Dim newMenuItem As ZcadPopupMenuItem
    Dim openMacro As String
    ' Assign the macro string the VB equivalent of " _open "
    openMacro = Chr(95) & "open" & Chr(32)

    Set newMenuItem = newMenu.AddMenuItem(newMenu.Count + 1, "Open", openMacro)

    ' Display the menu on the menu bar
    newMenu.InsertInMenuBar (ThisDrawing.Application.MenuBar.Count + 1)

    MsgBox "The macro for the Open menu item is: " & newMenuItem.Macro

End Sub


MajorAxis Property Example
Sub Example_MajorAxis()
    ' This example creates an ellipse and finds the major axis
    ' for that ellipse. It then changes the major axis for the ellipse.

    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double

    ' Create an ellipse in model space
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10#: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)
    MsgBox "The ellipse has a major axis of " & majAxis(0) & ", " & majAxis(1) & ", " & majAxis(2), vbInformation, "MajorAxis Example"

    ' Change the major axis of the ellipse
    majAxis(0) = 15: majAxis(1) = 15: majAxis(2) = 0
    ellObj.MajorAxis = majAxis
    ellObj.Update
    ZoomAll

    ' Query the major axis of an Ellipse
    Dim retMajAxis As Variant
    retMajAxis = ellObj.MajorAxis
    MsgBox "The ellipse has been udpated with the major axis " & retMajAxis(0) & ", " & retMajAxis(1) & ", " & retMajAxis(2), vbInformation, "MajorAxis Example"

End Sub


MajorRadius Property Example
Sub Example_MajorRadius()
    ' This example creates an Ellipse in model space and displays
    ' both the Major radius and the Minor radius of the new Ellipse

    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double

    ' Create an ellipse in model space
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10#: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Display radius information
    MsgBox "The major radius of the new Ellipse is: " & ellObj.MajorRadius & vbCrLf & _
           "The minor radius of the new Ellipse is: " & ellObj.MinorRadius

End Sub


MClose Property Example
Sub Example_MClose()

    Dim meshObj As ZcadPolygonMesh
    Dim points(0 To 47) As Double
    Dim M As Integer, N As Integer

    ' Create the matrix of points
    points(0) = 0: points(1) = 0: points(2) = 0
    points(3) = 2: points(4) = 0: points(5) = 1
    points(6) = 4: points(7) = 0: points(8) = 0
    points(9) = 6: points(10) = 0: points(11) = 1
    points(12) = 0: points(13) = 2: points(14) = 0
    points(15) = 2: points(16) = 2: points(17) = 1
    points(18) = 4: points(19) = 2: points(20) = 0
    points(21) = 6: points(22) = 2: points(23) = 1
    points(24) = 0: points(25) = 6: points(26) = 0
    points(27) = 2: points(28) = 4: points(29) = 1
    points(30) = 4: points(31) = 4: points(32) = 0
    points(33) = 6: points(34) = 4: points(35) = 0
    points(36) = 0: points(37) = 6: points(38) = 0
    points(39) = 2: points(40) = 6: points(41) = 1
    points(42) = 4: points(43) = 6: points(44) = 0
    points(45) = 6: points(46) = 6: points(47) = 0

    M = 4
    N = 4

    ' Creates a 3Dmesh in model space
    Set meshObj = ThisDrawing.ModelSpace.Add3DMesh(M, N, points)

    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Change the viewing direction of the viewport to better see the polygonmesh
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

    ' Close the 3Dmesh in the M direction
    MsgBox "The polymesh is " & IIf(meshObj.MClose, "closed", "open") & " in the 'M' direction.", , "MClose Example"
    meshObj.MClose = True
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The polymesh is " & IIf(meshObj.MClose, "closed", "open") & " in the 'M' direction.", , "MClose Example"

End Sub


Measurement Property Example
Sub Example_Measurement()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 0: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 4: SecondPoint(1) = 0: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "The current measurement of the new dimension is: " & DimPointAngularObj.Measurement, vbInformation, "Dimension Example"

End Sub


MenuBar Property Example
Sub Example_MenuBar()

    ' This example cycles through the MenuBar collection
    ' and lists the loaded menu items.

    Dim msg As String
    msg = ""

    For i = 0 To ThisDrawing.Application.MenuBar.Count - 1

        msg = msg + ThisDrawing.Application.MenuBar.Item(i).Name + vbCrLf

    Next

    MsgBox msg

End Sub


MenuFileName Property Example
Sub Example_MenuFileName()
    ' This example finds the file name for all loaded menu groups.

    Dim fileNames As String
    Dim menuGroup As ZcadMenuGroup

    fileNames = ""
    For Each menuGroup In ThisDrawing.Application.MenuGroups
        fileNames = fileNames & menuGroup.Name & "  " & menuGroup.MenuFileName & vbCrLf
    Next menuGroup
    MsgBox fileNames

End Sub


MenuGroups Property Example
Sub Example_MenuGroups()
    ' This example creates a new menu called TestMenu and inserts a menu item into it.
    ' Then it displayed on the menu bar.

    Dim currMenuGroup As ZcadMenuGroup
    Dim newMenu As ZcadPopupMenu, newMenuItem As ZcadPopupMenuItem
    Dim openMacro As String

    On Error GoTo ERRORTRAP

    ' Use MenuGroups property to obtain reference to main zcad+ menu
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new menu in this group
    Set newMenu = currMenuGroup.Menus.Add("TestMenu")

    ' Add a menu item to the new menu and
    ' assign an Open macro (VBA equivalent of: "_open ")
    openMacro = Chr(95) & "open" & Chr(32)

    Set newMenuItem = newMenu.AddMenuItem(newMenu.Count + 1, "Open", openMacro)

    ' Display the menu on the menu bar
    newMenu.InsertInMenuBar (ThisDrawing.Application.MenuBar.Count + 1)

    MsgBox "A new menu has been added to the zcad+ menu system!"

    Exit Sub

ERRORTRAP:
    MsgBox "The following error has occurred: " & Err.Description

End Sub


Menus Property Example
Sub Example_Menus()

    Dim menuCollection As ZcadPopupMenus
    Dim menu As ZcadPopupMenu

    Set menuCollection = ThisDrawing.Application.MenuGroups.Item(0).Menus
    MsgBox menuCollection.Count

End Sub


MinorAxis Property Example
Sub Example_MinorAxis()

    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double

    ' Create an ellipse in model space
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "The ellipse has a minor axis of " & ellObj.MinorAxis(0) & ", " & ellObj.MinorAxis(1) & ", " & ellObj.MinorAxis(2), vbInformation, "MinorAxis Example"

End Sub


MinorRadius Property Example
Sub Example_MinorRadius()
    ' This example creates an Ellipse in model space and displays
    ' both the Major radius and the Minor radius of the new Ellipse

    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double

    ' Create an ellipse in model space
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10#: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Display radius information
    MsgBox "The major radius of the new Ellipse is: " & ellObj.MajorRadius & vbCrLf & _
           "The minor radius of the new Ellipse is: " & ellObj.MinorRadius

End Sub


Mode Property Example
Sub Example_Mode()

    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String

    ' Define the attribute definition
    height = 1#
    mode = zcAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0#
    tag = "New Tag"
    value = "New Value"

    ' Create the attribute definition object in model space
    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    Dim currMode As Integer
    Dim constant As String
    currMode = attributeObj.mode
    GoSub GETCONSTANT
    MsgBox "The Mode of the attribute is " & constant, vbInformation, "Mode Example"

    attributeObj.mode = zcAttributeModeInvisible
    GoSub GETCONSTANT
    attributeObj.Update
    MsgBox "The new Mode of the attribute is " & constant, vbInformation, "Mode Example"

    attributeObj.mode = currMode
    GoSub GETCONSTANT
    attributeObj.Update
    MsgBox "The Mode of the attribute is reset to " & constant, vbInformation, "Mode Example"
    Exit Sub

GETCONSTANT:
    ' Get the constant that corresponds to the current mode
    constant = Choose(attributeObj.mode, "zcAttributeModeInvisible", "zcAttributeModeConstant", "", "zcAttributeModeVerify", "", "", "", "zcAttributeModePreset")
    Return

End Sub


ModelSpace Property Example
Sub Example_ModelSpace()

    ' Define the line
    Dim lineObj As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
    startPoint(0) = 0: startPoint(1) = 0: startPoint(2) = 0
    endPoint(0) = 4: endPoint(1) = 4: endPoint(2) = 0

    Dim Mspace As ZcadModelSpace
    Set Mspace = ThisDrawing.ModelSpace
    Set lineObj = Mspace.AddLine(startPoint, endPoint)

    ' Define a circle
    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 4: center(1) = 4: center(2) = 0
    radius = 1
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(center, radius)
    ThisDrawing.Regen
    ZoomAll

End Sub


ModelType Property Example
Sub Example_ModelType()
    ' This example creates a plot configuration object
    ' and then finds the ModelType for the object.

    Dim PlotConfigObj As ZcadPlotConfiguration

    ' Creates the MText Object
    Set PlotConfigObj = ThisDrawing.PlotConfigurations.Add("NewPlotConfiguration")

    ' Find the current ModelType
    Dim currModelType As Boolean
    currModelType = PlotConfigObj.ModelType
    MsgBox "The ModelType for the object is: " & currModelType

End Sub


MomentOfInertia Property Example
Sub Example_MomentOfInertia()
    ' This example creates a box in model space.
    ' It then returns the MomentOfInertia for that box.

    Dim boxObj As Zcad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double

    ' Define the box
    center(0) = 100#: center(1) = 100#: center(2) = 0
    length = 30#: width = 50: height = 100#

    ' Create the box (3DSolid) object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Change the viewing direction of the viewport to better see the box
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

    ' Return the MomentOfInertia for the box
    Dim momentOfInertia As Variant
    momentOfInertia = boxObj.momentOfInertia
    MsgBox "The MomentOfInertia for the box is " & momentOfInertia(0) & ", " & momentOfInertia(1) & ", " & momentOfInertia(2), , "MomentOfInertia Example"

End Sub


MSpace Property Example
Sub Example_MSpace()

    Dim pviewportObj As ZcadPViewport
    Dim center(0 To 2) As Double
    Dim width As Double
    Dim height As Double

    ' Define the paper space viewport
    center(0) = 3: center(1) = 3: center(2) = 0
    width = 40
    height = 40

    ' Change from model space to paperspace
    ThisDrawing.ActiveSpace = zcPaperSpace

    ' Create the paper space viewport
    Set pviewportObj = ThisDrawing.PaperSpace.AddPViewport(center, width, height)
    pviewportObj.Display True
    ThisDrawing.MSpace = True
    ThisDrawing.ActivePViewport = pviewportObj
    ThisDrawing.Regen zcAllViewports

    ' Find the current MSpace value
    MsgBox "The ability to edit model space from this PViewport is " & IIf(ThisDrawing.MSpace, "on.", "off."), , "MSpace Example"

    ' Toggle the setting of MSpace
    ThisDrawing.MSpace = False
    MsgBox "The ability to edit model space from this PViewport is now " & IIf(ThisDrawing.MSpace, "on.", "off."), , "MSpace Example"

End Sub


MVertexCount Property Example
Sub Example_MVertexCount()

    Dim plineObj As ZcadPolygonMesh
    Dim points(0 To 47) As Double
    Dim M As Integer, N As Integer

    points(0) = 0: points(1) = 0: points(2) = 0
    points(3) = 2: points(4) = 0: points(5) = 1
    points(6) = 4: points(7) = 0: points(8) = 0
    points(9) = 6: points(10) = 0: points(11) = 1
    points(12) = 0: points(13) = 2: points(14) = 0
    points(15) = 2: points(16) = 2: points(17) = 1
    points(18) = 4: points(19) = 2: points(20) = 0
    points(21) = 6: points(22) = 2: points(23) = 1
    points(24) = 0: points(25) = 4: points(26) = 0
    points(27) = 2: points(28) = 4: points(29) = 1
    points(30) = 4: points(31) = 4: points(32) = 0
    points(33) = 6: points(34) = 4: points(35) = 0
    points(36) = 0: points(37) = 6: points(38) = 0
    points(39) = 2: points(40) = 6: points(41) = 1
    points(42) = 4: points(43) = 6: points(44) = 0
    points(45) = 6: points(46) = 6: points(47) = 0

    M = 8
    N = 2
    Set plineObj = ThisDrawing.ModelSpace.Add3DMesh(M, N, points)

    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    MsgBox plineObj.MVertexCount

End Sub


Name Property Example
Sub Example_Name()

    Dim app As ZcadApplication
    Set app = ThisDrawing.Application
    MsgBox "the application is " & app.Name

End Sub


NClose Property Example
Sub Example_NClose()

    Dim meshObj  As ZcadPolygonMesh
    Dim points(0 To 47) As Double
    Dim M As Integer, N As Integer

    ' Create the matrix of points
    points(0) = 0: points(1) = 0: points(2) = 0
    points(3) = 2: points(4) = 0: points(5) = 1
    points(6) = 4: points(7) = 0: points(8) = 0
    points(9) = 6: points(10) = 0: points(11) = 1
    points(12) = 0: points(13) = 2: points(14) = 0
    points(15) = 2: points(16) = 2: points(17) = 1
    points(18) = 4: points(19) = 2: points(20) = 0
    points(21) = 6: points(22) = 2: points(23) = 1
    points(24) = 0: points(25) = 4: points(26) = 0
    points(27) = 2: points(28) = 4: points(29) = 1
    points(30) = 4: points(31) = 4: points(32) = 0
    points(33) = 6: points(34) = 4: points(35) = 0
    points(36) = 0: points(37) = 6: points(38) = 0
    points(39) = 2: points(40) = 6: points(41) = 1
    points(42) = 4: points(43) = 6: points(44) = 0
    points(45) = 6: points(46) = 6: points(47) = 0

    M = 4
    N = 4

    ' Creates a 3Dmesh in model space
    Set meshObj = ThisDrawing.ModelSpace.Add3DMesh(M, N, points)

    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Change the viewing direction of the viewport to better see the polygonmesh
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

    ' Close the 3Dmesh in the N direction
    MsgBox "The polymesh is " & IIf(meshObj.NClose, "closed", "open") & " in the 'N' direction.", , "NClose Example"
    meshObj.NClose = True
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The polymesh is " & IIf(meshObj.NClose, "closed", "open") & " in the 'N' direction.", , "NClose Example"

End Sub


Normal Property Example
Sub Example_Normal()
    ' This example creates a circle in model space.
    ' It then finds the current normal to that circle
    ' and changes the normal.

    ' Define a circle
    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 100: center(1) = 100: center(2) = 0
    radius = 10

    ' Add the circle to model space
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(center, radius)
    circleObj.Update
    ZoomAll

    ' Find the normal for the circle
    Dim currNormal As Variant
    currNormal = circleObj.Normal
    MsgBox "The current normal for the circle is " & circleObj.Normal(0) & ", " & circleObj.Normal(1) & ", " & circleObj.Normal(2), , "Normal Example"

    ' Change the normal for the circle
    Dim newNormal(0 To 2) As Double
    newNormal(0) = 1: newNormal(1) = 1: newNormal(2) = -1
    circleObj.Normal = newNormal
    circleObj.Update
    MsgBox "The current normal for the circle is " & circleObj.Normal(0) & ", " & circleObj.Normal(1) & ", " & circleObj.Normal(2), , "Normal Example"

End Sub


NumberOfControlPoints Property Example
Sub Example_NumberOfControlPoints()

    ' Create the spline
    Dim splineObj As ZcadSpline
    Dim points(0 To 8) As Double

    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 13: points(7) = 5: points(8) = 0

    ' Create the spline in model space
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "The Spline has " & splineObj.NumberOfControlPoints & " control points.", , "NumberOfControlPoints Example"

End Sub


NumberOfCopies Property Example
Sub Example_NumberOfCopies()
    ' This example plots the layouts of a drawing.

    Dim oPlot As ZcadPlot
    Dim AddedLayouts() As String
    Dim LayoutList As Variant
    Dim oLayout As ZcadLayout
    Dim ArraySize As Integer

    For Each oLayout In ThisDrawing.Layouts
        ArraySize = ArraySize + 1
        ReDim Preserve AddedLayouts(1 To ArraySize)
        AddedLayouts(ArraySize) = oLayout.Name
    Next

    LayoutList = AddedLayouts
    Set oPlot = ThisDrawing.Plot
    oPlot.SetLayoutsToPlot LayoutList
    oPlot.NumberOfCopies = 2
    oPlot.PlotToDevice

End Sub


NumberOfFaces Property Example
Sub Example_NumberOfFaces()

    Dim vertexList(0 To 17) As Double

    vertexList(0) = 5: vertexList(1) = 8: vertexList(2) = 0
    vertexList(3) = 6: vertexList(4) = 8: vertexList(5) = 0
    vertexList(6) = 7: vertexList(7) = 8: vertexList(8) = 0
    vertexList(9) = 5: vertexList(10) = 6: vertexList(11) = 0
    vertexList(12) = 6: vertexList(13) = 6: vertexList(14) = 0
    vertexList(15) = 7: vertexList(16) = 6: vertexList(17) = 1

    Dim FaceList(0 To 7) As Integer
    FaceList(0) = 1
    FaceList(1) = 2
    FaceList(2) = 5
    FaceList(3) = 4
    FaceList(4) = 2
    FaceList(5) = 3
    FaceList(6) = 6
    FaceList(7) = 5

    Dim obj As ZcadPolyfaceMesh
    Set obj = ThisDrawing.ModelSpace.AddPolyfaceMesh(vertexList, FaceList)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "NumberOfFaces:" & vbCrLf & obj.NumberOfFaces, , "NumberOfFaces Example"

End Sub


NumberOfFitPoints Property Example
Sub Example_NumberOfFitPoints()

    ' Create the spline
    Dim splineObj As ZcadSpline
    Dim points(0 To 8) As Double

    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    ' Establish the points for the spline
    points(0) = 3: points(1) = 7: points(2) = 0
    points(3) = 9: points(4) = 2: points(5) = 0
    points(6) = 3: points(7) = 5: points(8) = 0

    ' Create the spline in model space
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    MsgBox "The Spline has " & splineObj.NumberOfFitPoints & " fit points.", , "NumberOfFitPoints Example"

End Sub


NumberOfVertices Property Example
Sub Example_NumberOfVertices()

    Dim vertexList(0 To 17) As Double
    vertexList(0) = 5: vertexList(1) = 8: vertexList(2) = 0
    vertexList(3) = 6: vertexList(4) = 8: vertexList(5) = 0
    vertexList(6) = 7: vertexList(7) = 8: vertexList(8) = 0
    vertexList(9) = 5: vertexList(10) = 6: vertexList(11) = 0
    vertexList(12) = 6: vertexList(13) = 6: vertexList(14) = 0
    vertexList(15) = 7: vertexList(16) = 6: vertexList(17) = 1

    Dim FaceList(0 To 7) As Integer
    FaceList(0) = 1
    FaceList(1) = 2
    FaceList(2) = 5
    FaceList(3) = 4
    FaceList(4) = 2
    FaceList(5) = 3
    FaceList(6) = 6
    FaceList(7) = 5

    Dim obj As ZcadPolyfaceMesh
    Set obj = ThisDrawing.ModelSpace.AddPolyfaceMesh(vertexList, FaceList)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox "NumberOfVertices:" & vbCrLf & obj.NumberOfVertices, , "NumberOfVertices Example"

End Sub


NumCustomInfo Property Example
Sub Example_NumCustomInfo()

    Dim Key As String
    Dim Value As String
    Dim Key1 As String
    Dim Value1 As String
    Dim CustomProperty As String
    Dim PropertyValue As String
    Dim CustomProperty1 As String
    Dim PropertyValue1 As String

    CustomProperty = "zcad+"
    PropertyValue = "Test"
    CustomProperty1 = "ZW"
    PropertyValue1 = "Test1"
    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty, PropertyValue
    ThisDrawing.SummaryInfo.AddCustomInfo CustomProperty1, PropertyValue1
    MsgBox ThisDrawing.SummaryInfo.NumCustomInfo

End Sub


NVertexCount Property Example
Sub Example_NVertexCount()

    Dim plineObj As ZcadPolygonMesh
    Dim points(0 To 47) As Double
    Dim M As Integer, N As Integer

    points(0) = 1: points(1) = 1: points(2) = 0
    points(3) = 10: points(4) = 1: points(5) = 0
    points(6) = 1: points(7) = 2: points(8) = 0
    points(9) = 10: points(10) = 2: points(11) = 0
    points(12) = 1: points(13) = 3: points(14) = 0
    points(15) = 10: points(16) = 3: points(17) = 0
    points(18) = 1: points(19) = 4: points(20) = 0
    points(21) = 10: points(22) = 4: points(23) = 0
    points(24) = 1: points(25) = 5: points(26) = 0
    points(27) = 10: points(28) = 5: points(29) = 0
    points(30) = 1: points(31) = 6: points(32) = 0
    points(33) = 10: points(34) = 6: points(35) = 0
    points(36) = 1: points(37) = 7: points(38) = 0
    points(39) = 10: points(40) = 7: points(41) = 0
    points(42) = 1: points(43) = 8: points(44) = 0
    points(45) = 10: points(46) = 8: points(47) = 0

    M = 8
    N = 2
    Set plineObj = ThisDrawing.ModelSpace.Add3DMesh(M, N, points)

    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    MsgBox plineObj.NVertexCount

End Sub


ObjectID Property Example
Sub Example_ObjectID()

    ' Create a Ray object in model space
    Dim rayObj As ZcadRay
    Dim basePoint(0 To 2) As Double
    Dim SecondPoint(0 To 2) As Double
    basePoint(0) = 3#: basePoint(1) = 3#: basePoint(2) = 0#
    SecondPoint(0) = 1#: SecondPoint(1) = 3#: SecondPoint(2) = 0#
    Set rayObj = ThisDrawing.ModelSpace.AddRay(basePoint, SecondPoint)
    rayObj.Update

    ' Create a Line object in model space
    Dim lineObj As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
    startPoint(0) = 0: startPoint(1) = 0: startPoint(2) = 0
    endPoint(0) = 2: endPoint(1) = 2: endPoint(2) = 0
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    lineObj.Update

    ' Create a Circle object in model space
    Dim circObj As ZcadCircle
    Dim centerPt(0 To 2) As Double
    Dim radius As Double
    centerPt(0) = 5: centerPt(1) = 3: centerPt(2) = 0
    radius = 3
    Set circObj = ThisDrawing.ModelSpace.AddCircle(centerPt, radius)
    circObj.Update

    ' Create an Ellipse object in model space
    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10#: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)
    ellObj.Update
    ZoomAll

    ' Iterate through the model space collection and display
    ' the ObjectID of each object found.
    Dim entObjectID As Long
    Dim entry As ZcadEntity
    For Each entry In ThisDrawing.ModelSpace
        entObjectID = entry.ObjectID
        entry.Highlight (True)
        MsgBox "The ObjectID of " & entry.EntityName & " is " & entObjectID, vbInformation, "ObjectID Example"
        entry.Highlight (False)
    Next

End Sub


ObliqueAngle Property Example
Sub Example_ObliqueAngle()

    Dim textObj As ZcadText
    Dim text As String
    Dim insertionPoint(0 To 2) As Double
    Dim height As Double

    ' Define the text object
    text = "Hello, World."
    insertionPoint(0) = 2: insertionPoint(1) = 2: insertionPoint(2) = 0
    height = 0.5

    ' Create the text object in model space
    Set textObj = ThisDrawing.ModelSpace.AddText(text, insertionPoint, height)
    MsgBox "The ObliqueAngle is " & textObj.ObliqueAngle, vbInformation, "ObliqueAngle Example"

    ' Change the value of the ObliqueAngle to 45 degrees (.707 radians)
    textObj.ObliqueAngle = 0.707
    textObj.Update
    ZoomAll
    MsgBox "The ObliqueAngle is set to " & textObj.ObliqueAngle, vbInformation, "ObliqueAngle Example"

End Sub


OnMenuBar Property Example
Sub Example_OnMenuBar()
    ' This example creates a new menu called TestMenu and inserts a menu item
    ' into it. The menu is then displayed on the menu bar, and then
    ' removed from the menu bar.

    Dim currMenuGroup As ZcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new menu
    Dim newMenu As ZcadPopupMenu
    Set newMenu = currMenuGroup.Menus.Add("TestMenu")

    ' Add a menu item to the new menu
    Dim newMenuItem As ZcadPopupMenuItem
    Dim openMacro As String
    ' Assign the macro string the VB equivalent of " _open "
    openMacro = Chr(95) & "open" & Chr(32)

    Set newMenuItem = newMenu.AddMenuItem(newMenu.Count + 1, "Open", openMacro)

    ' Display the menu on the menu bar
    newMenu.InsertInMenuBar (ThisDrawing.Application.MenuBar.Count + 1)
    GoSub QUERYMENU

    ' Remove the menu from the menu bar
    currMenuGroup.Menus.RemoveMenuFromMenuBar ("TestMenu")
    GoSub QUERYMENU
    Exit Sub

QUERYMENU:
    If newMenu.OnMenuBar Then
        MsgBox "The menu called " & newMenu.Name & " is on the menu bar."
    Else
        MsgBox "The menu called " & newMenu.Name & " is not on the menu bar."
    End If
    Return

End Sub


Origin Property Example
Sub Example_Origin()

    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 10#: insertionPnt(1) = 11#: insertionPnt(2) = 0#
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "CircleBlock")

     ' Display the current origin for the block
    MsgBox "The origin of the BLock is: " & blockObj.Origin(0) & ", " & blockObj.Origin(1) & ", " & blockObj.Origin(2), , "Origin Example"

    ' Change the origin of the block
    Dim Origin(0 To 2) As Double
    Origin(0) = 0: Origin(1) = 0: Origin(2) = 0
    blockObj.Origin = Origin

    ' Display the new origin for the block
    MsgBox "The origin of the block is now: " & blockObj.Origin(0) & ", " & blockObj.Origin(1) & ", " & blockObj.Origin(2), , "Origin Example"

    ' Add a circle to the block
    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 0: center(1) = 0: center(2) = 0
    radius = 10
    Set circleObj = blockObj.AddCircle(center, radius)

    ' Insert the block
    Dim blockRefObj As ZcadBlockReference
    insertionPnt(0) = 2#: insertionPnt(1) = 2#: insertionPnt(2) = 0
    Set blockRefObj = ThisDrawing.ModelSpace.InsertBlock(insertionPnt, "CircleBlock", 1#, 1#, 1#, 0)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

End Sub


PaperSpace Property Example
Sub Example_PaperSpace()

    Dim point(0 To 2) As Double
    Dim r As Double
    r = 100
    point(0) = 100
    point(1) = 100
    point(2) = 0
    Dim pspace As ZcadPaperSpace
    Set pspace = ThisDrawing.PaperSpace
    Dim circleobj As ZcadCircle
    Set circleobj = pspace.AddCircle(point, r)
    circleobj.color = zcRed
    ThisDrawing.Regen zcActiveViewport
    ThisDrawing.ActiveSpace = zcPaperSpace

End Sub


PaperUnits Property Example
Sub Example_PaperUnits()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "Test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    ' Using inches or millimeters?
    Dim Measurement As String
    Measurement = IIf(PlotConfiguration.PaperUnits = zcInches, " inches", " millimeters")
    MsgBox "PlotConfiguration PaperUnits: " & Measurement

End Sub


Parent Property Example
Sub Example_Parent()
    ' This example creates a new toolbar and then finds the parent toolbar.
    ' To remove the toolbar after execution of this macro, use the Customize Menu
    ' option from the Tools menu.

    Dim currMenuGroup As ZcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    ' Create the new toolbar
    Dim newToolBar As ZcadToolbar
    Set newToolBar = currMenuGroup.Toolbars.Add("TestTools")

    ' Add a button to the new toolbar.
    ' All three buttons will have the same macro attached.
    Dim newButton1 As ZcadToolbarItem
    Dim openMacro As String

    ' Assign the macro string the VB equivalent of "ESC ESC _open "
    openMacro = Chr(3) & Chr(3) & Chr(95) & "open" & Chr(32)

    Set newButton1 = newToolBar.AddToolbarButton("", "OpenFile", "Open a file.", openMacro)

    ' Display the toolbar
    newToolBar.Visible = True

    ' Find the parent toolbar for the toolbar button
    MsgBox "The " & newButton1.Name & " button is on the " & newButton1.Parent.Name & " toolbar."
End Sub


Path Property Example
Sub Example_Path()

    Dim app As ZcadApplication
    Set app = ThisDrawing.Application
    MsgBox "the application is " & app.Path

End Sub


PatternAngle Property Example
Sub Example_PatternAngle()

    Dim hatchobj As ZcadHatch
    Dim patternname As String
    Dim patterntype As Long
    Dim bassociativity As Boolean

    ' Define the hatch
    patternname = "ANSI33"
    patterntype = zcHatchPatternTypePreDefined
    bassociativity = True

    ' Create the associative hatch object
    Set hatchobj = ThisDrawing.ModelSpace.AddHatch(patterntype, patternname, bassociativity)

    ' Create the outer loop for the hatch
    Dim outerloop(0 To 1) As ZcadEntity
    Dim center(0 To 2) As Double
    Dim arcobj As ZcadArc
    Dim startangle As Double
    Dim endangle As Double

    center(0) = 5
    center(1) = 3
    center(2) = 0
    startangle = 0
    endangle = 3.141592

    Set outerloop(0) = ThisDrawing.ModelSpace.AddArc(center, 3, starangle, endangle)
    Set arcobj = outerloop(0)
    Set outerloop(1) = ThisDrawing.ModelSpace.AddLine(arcobj.startpoint, arcobj.endpoint)

    ' Append the outer loop to the hatch
    hatchobj.AppendOuterLoop (outerloop)

    ' Create the inner loop for the hatch
    Dim innerloop(0) As ZcadEntity
    center(0) = 5
    center(1) = 4.5
    center(2) = 0
    Set innerloop(0) = ThisDrawing.ModelSpace.AddCircle(center, 1)

    ' Append the inner loop to the hatch
    hatchobj.AppendInnerLoop (innerloop)

    ' Set the scale of the hatch pattern
    hatchobj.PatternScale = 0.1

    ' Find the angle of the hatch pattern
    Dim patternAngle As Double
    patternAngle = hatchobj.patternAngle
    MsgBox "The angle of the hatch pattern is " & hatchobj.patternAngle, , "PatternAngle Example"

    ' Change the angle of the hatch pattern
    hatchobj.patternAngle = 1.57
    hatchobj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The angle of the hatch pattern is now " & hatchobj.patternAngle, , "PatternAngle Example"

End Sub


PatternName Property Example
Sub Example_PatternName()

    Dim hatchobj As ZcadHatch
    Dim patternName As String
    Dim patterntype As Long
    Dim bassociativity As Boolean

    ' Define the hatch
    patternName = "ANSI33"
    patterntype = zcHatchPatternTypePreDefined
    bassociativity = True

    ' Create the associative hatch object
    Set hatchobj = ThisDrawing.ModelSpace.AddHatch(patterntype, patternName, bassociativity)

    ' Create the outer loop for the hatch
    Dim outerloop(0 To 1) As ZcadEntity
    Dim center(0 To 2) As Double
    Dim arcobj As ZcadArc
    Dim startangle As Double
    Dim endangle As Double

    center(0) = 5
    center(1) = 3
    center(2) = 0
    startangle = 0
    endangle = 3.141592

    Set outerloop(0) = ThisDrawing.ModelSpace.AddArc(center, 3, starangle, endangle)
    Set arcobj = outerloop(0)
    Set outerloop(1) = ThisDrawing.ModelSpace.AddLine(arcobj.startpoint, arcobj.endpoint)

    ' Append the outer loop to the hatch
    hatchobj.AppendOuterLoop (outerloop)

    ' Create the inner loop for the hatch
    Dim innerloop(0) As ZcadEntity
    center(0) = 5
    center(1) = 4.5
    center(2) = 0
    Set innerloop(0) = ThisDrawing.ModelSpace.AddCircle(center, 1)

    ' Append the inner loop to the hatch
    hatchobj.AppendInnerLoop (innerloop)

    ' Set the scale of the hatch pattern
    hatchobj.PatternScale = 0.1

    ' Find the name of the hatch pattern
    patternName = hatchobj.patternName
    MsgBox "The angle of the hatch pattern is " & hatchobj.patternName, , "patternName Example"

    ThisDrawing.Regen zcActiveViewport

End Sub


PatternScale Property Example
Sub Example_PatternScale()

    Dim hatchobj As ZcadHatch
    Dim patternName As String
    Dim patterntype As Long
    Dim bassociativity As Boolean

    ' Define the hatch
    patternName = "ANSI33"
    patterntype = zcHatchPatternTypePreDefined
    bassociativity = True

    ' Create the associative hatch object
    Set hatchobj = ThisDrawing.ModelSpace.AddHatch(patterntype, patternName, bassociativity)

    ' Create the outer loop for the hatch
    Dim outerloop(0 To 1) As ZcadEntity
    Dim center(0 To 2) As Double
    Dim arcobj As ZcadArc
    Dim startangle As Double
    Dim endangle As Double

    center(0) = 5
    center(1) = 3
    center(2) = 0
    startangle = 0
    endangle = 3.141592

    Set outerloop(0) = ThisDrawing.ModelSpace.AddArc(center, 3, starangle, endangle)
    Set arcobj = outerloop(0)
    Set outerloop(1) = ThisDrawing.ModelSpace.AddLine(arcobj.startpoint, arcobj.endpoint)

    ' Append the outer loop to the hatch
    hatchobj.AppendOuterLoop (outerloop)

    ' Create the inner loop for the hatch
    Dim innerloop(0) As ZcadEntity
    center(0) = 5
    center(1) = 4.5
    center(2) = 0
    Set innerloop(0) = ThisDrawing.ModelSpace.AddCircle(center, 1)

    ' Append the inner loop to the hatch
    hatchobj.AppendInnerLoop (innerloop)

    ' Find the scale of the hatch pattern
    Dim PatternScale As Double
    PatternScale = hatchobj.PatternScale
    MsgBox "The scale of the hatch pattern is " & hatchobj.PatternScale, , "PatternScale Example"

    ' Change the scale of the hatch pattern
    hatchobj.PatternScale = 0.1
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The scale of the hatch pattern is now " & hatchobj.PatternScale, , "PatternScale Example"

End Sub


PatternSpace Property Example
Sub Example_PatternSpace()

    Dim hatchobj As ZcadHatch
    Dim patternName As String
    Dim patterntype As Long
    Dim bassociativity As Boolean

    ' Define the hatch
    patternName = "ANSI33"
    patterntype = zcHatchPatternTypePreDefined
    bassociativity = True

    ' Create the associative hatch object
    Set hatchobj = ThisDrawing.ModelSpace.AddHatch(patterntype, patternName, bassociativity)

    ' Create the outer loop for the hatch
    Dim outerloop(0 To 1) As ZcadEntity
    Dim center(0 To 2) As Double
    Dim arcobj As ZcadArc
    Dim startangle As Double
    Dim endangle As Double

    center(0) = 5
    center(1) = 3
    center(2) = 0
    startangle = 0
    endangle = 3.141592

    Set outerloop(0) = ThisDrawing.ModelSpace.AddArc(center, 3, starangle, endangle)
    Set arcobj = outerloop(0)
    Set outerloop(1) = ThisDrawing.ModelSpace.AddLine(arcobj.StartPoint, arcobj.EndPoint)

    ' Append the outer loop to the hatch
    hatchobj.AppendOuterLoop (outerloop)

    ' Create the inner loop for the hatch
    Dim innerloop(0) As ZcadEntity
    center(0) = 5
    center(1) = 4.5
    center(2) = 0
    Set innerloop(0) = ThisDrawing.ModelSpace.AddCircle(center, 1)

    ' Append the inner loop to the hatch
    hatchobj.AppendInnerLoop (innerloop)

    ' Find the space of the hatch pattern
    Dim patternSpace As Double
    patternSpace = hatchobj.patternSpace
    MsgBox "The spacing of the hatch pattern is " & hatchobj.patternSpace, , "PatternSpace Example"

    ' Change the spacing of the hatch pattern
    hatchobj.patternSpace = patternSpace + 2
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The spacing of the hatch pattern is now " & hatchobj.patternSpace, , "PatternSpace Example"

End Sub


PatternType Property Example
Sub Example_PatternType()

    Dim hatchobj As ZcadHatch
    Dim patternname As String
    Dim patterntype As Long
    Dim bassociativity As Boolean

    ' Define the hatch
    patternname = "ANSI31"
    patterntype = zcHatchPatternTypePreDefined
    bassociativity = True

    ' Create the associative hatch object
    Set hatchobj = ThisDrawing.ModelSpace.AddHatch(patterntype, patternname, bassociativity)

    ' Create the outer loop for the hatch
    Dim outerloop(0 To 1) As ZcadEntity
    Dim center(0 To 2) As Double
    Dim arcobj As ZcadArc
    Dim startangle As Double
    Dim endangle As Double

    center(0) = 5
    center(1) = 3
    center(2) = 0
    startangle = 0
    endangle = 3.141592

    Set outerloop(0) = ThisDrawing.ModelSpace.AddArc(center, 3, starangle, endangle)
    Set arcobj = outerloop(0)
    Set outerloop(1) = ThisDrawing.ModelSpace.AddLine(arcobj.startpoint, arcobj.endpoint)

    ' Append the outer loop to the hatch
    hatchobj.AppendOuterLoop (outerloop)

    ' Create the inner loop for the hatch
    Dim innerloop(0) As ZcadEntity
    center(0) = 5
    center(1) = 4.5
    center(2) = 0
    Set innerloop(0) = ThisDrawing.ModelSpace.AddCircle(center, 1)

    ' Append the inner loop to the hatch
    hatchobj.AppendInnerLoop (innerloop)

    ' Find the type of the hatch
    MsgBox "The type of hatch pattern is " & Choose(hatchobj.patterntype + 1, _
    "zcHatchPatternTypeUserDefined", "zcHatchPatternTypePreDefined", "zcHatchPatternTypeCustomDefined"), , "PatternType Example"

    ThisDrawing.Regen zcActiveViewport

End Sub


Perimeter Property Example
Sub Example_Perimeter()

    Dim curves(0 To 1) As ZcadEntity
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double
    centerPoint(0) = 5#: centerPoint(1) = 3#: centerPoint(2) = 0#
    radius = 2#
    startAngle = 0
    endAngle = 3.141592
    Set curves(0) = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)

    Set arcObj = curves(0)
    Dim p1 As Variant
    Dim p2 As Variant
    p1 = arcObj.StartPoint
    p2 = arcObj.EndPoint
    Set curves(1) = ThisDrawing.ModelSpace.AddLine(p1, p2)

    Dim regionObj As Variant
    regionObj = ThisDrawing.ModelSpace.AddRegion(curves)
    Dim pt As Double
    pt = regionObj(0).Perimeter

    MsgBox "The perimeter of the region is " & pt, , "Perimeter Example"
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

End Sub


PickfirstSelectionSet Property Example
Sub Example_PickfirstSelectionSet()
    ' This example lists all the objects in the pickfirst selection set.
    ' Before running this example, create some objects in the active
    ' drawing and select those objects. The objects currently selected
    ' in the active drawing will be returned in the pickfirst selection set.

    Dim sset As ZcadSelectionSet
    Dim ssobject As ZcadEntity
    Dim msg As String
    msg = vbCrLf

    Set sset = ThisDrawing.PickfirstSelectionSet
    For Each ssobject In sset
        msg = msg & vbCrLf & ssobject.EntityName
    Next ssobject
    MsgBox "The Pickfirst selection set contains: " & msg

End Sub


Plot Property Example
Sub Example_Plot()

    Dim currentplot As ZcadPlot
    Set currentplot = ThisDrawing.Plot

    ThisDrawing.ActiveLayout.ConfigName = "Adobe PDF"
    ThisDrawing.ActiveLayout.CanonicalMediaName = "A4"

    ThisDrawing.ActiveLayout.StandardScale = zcScaleToFit
    ThisDrawing.Application.ZoomExtents
    currentplot.PlotToDevice

End Sub


PlotConfigurations Property Example
Sub Example_PlotConfigurations()
    ' This example will access the PlotConfigurations collection for the current drawing,
    ' add a plot configuration, and list basic information about the
    ' plot configurations in the drawing.

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration
    Dim msg As String

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        ' Customize the new configuration to your satisfaction
        PlotConfigurations.Add "NEW_CONFIGURATION"
    End If

    msg = vbCrLf & vbCrLf   ' Start with a space

    ' Get the names of the plot configurations in this drawing
    For Each PlotConfiguration In PlotConfigurations
        msg = msg & PlotConfiguration.Name & vbCrLf
    Next

    ' Display a list of available plot configurations
    MsgBox "There are " & PlotConfigurations.Count & " plot configuration(s) in " & _
            ThisDrawing.WindowTitle & ":" & msg
End Sub


PlotHidden Property Example
Sub Example_PlotHidden()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "NEW_CONFIGURATION"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "PlotConfiguration PlotHidden: " & PlotConfiguration.PlotHidden

End Sub


PlotOrigin Property Example
Sub Example_PlotOrigin()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "Test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    Dim ptOldOrigin As Variant
    Dim ptNewOrigin(0 To 1) As Double

    ptOldOrigin = PlotConfiguration.PlotOrigin
    MsgBox "Old PlotOrigin: " & ptOldOrigin(0) & "," & ptOldOrigin(1)

    ptNewOrigin(0) = ptOldOrigin(0) + 20
    ptNewOrigin(1) = ptOldOrigin(1) - 20
    PlotConfiguration.PlotOrigin = ptNewOrigin
    MsgBox "New PlotOrigin: " & ptNewOrigin(0) & "," & ptNewOrigin(1)

End Sub


PlotRotation Property Example
Sub Example_PlotRotation()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "NEW_CONFIGURATION"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "Old PlotRotation: " & PlotConfiguration.PlotRotation

    PlotConfiguration.PlotRotation = zc180degrees

    MsgBox "New PlotRotation: " & PlotConfiguration.PlotRotation

End Sub


Plottable Property Example
Sub Example_Plottable()

    Dim layerobject As ZcadLayer
    Set layerobject = ThisDrawing.ActiveLayer
    If layerobject.Plottable Then
    MsgBox layerobject.Name & " " & "Layer will plot" & vbCrLf
    End If

End Sub


PlotType Property Example
Sub Example_PlotType()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "Old PlotType: " & PlotConfiguration.PlotType

    PlotConfiguration.PlotType = zcDisplay

    MsgBox "New PlotType: " & PlotConfiguration.PlotType

End Sub


PlotViewportBorders Property Example
Sub Example_PlotViewportBorders()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "Old PlotViewportBorders: " & PlotConfiguration.PlotViewportBorders

    PlotConfiguration.PlotViewportBorders = Not PlotConfiguration.PlotViewportBorders

    MsgBox "New PlotViewportBorders: " & PlotConfiguration.PlotViewportBorders

End Sub


PlotViewportsFirst Property Example
Sub Example_PlotViewportsFirst()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "Old PlotViewportsFirst: " & PlotConfiguration.PlotViewportsFirst

    PlotConfiguration.PlotViewportsFirst = Not PlotConfiguration.PlotViewportsFirst

    MsgBox "New PlotViewportsFirst: " & PlotConfiguration.PlotViewportsFirst

End Sub


PlotWithLineweights Property Example
Sub Example_PlotWithLineweights()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)
    MsgBox "Old PlotWithLineweights: " & PlotConfiguration.PlotWithLineweights
    PlotConfiguration.PlotWithLineweights = Not PlotConfiguration.PlotWithLineweights
    MsgBox "New PlotWithLineweights: " & PlotConfiguration.PlotWithLineweights

End Sub


PlotWithPlotStyles Property Example
Sub Example_PlotWithPlotStyles()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "Old PlotWithPlotStyles: " & PlotConfiguration.PlotWithPlotStyles

    PlotConfiguration.PlotWithPlotStyles = Not PlotConfiguration.PlotWithPlotStyles

    MsgBox "New PlotWithLineweights: " & PlotConfiguration.PlotWithPlotStyles

End Sub


Preset Property Example
Sub Example_Preset()

    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String

    ' Define the attribute definition
    height = 1#
    mode = zcAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "New Tag"
    value = "New Value"

    ' Create the attribute definition object in model space
    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    attributeObj.Preset = True
    attributeObj.Update
    ZoomAll

End Sub


PrimaryUnitsPrecision Property Example
Sub Example_PrimaryUnitsPrecision()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    Dim oldPrecision As String, newPrecision As String

    ' Define the dimension
    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5.234578916: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)

    ' Enable and setup tolerance display
    dimObj.ToleranceDisplay = zcTolSymmetrical
    dimObj.ToleranceLowerLimit = -0.0001
    dimObj.ToleranceUpperLimit = 0.003
    dimObj.Update
    ZoomAll

    ' Store old precision value as default for input box
    oldPrecision = dimObj.PrimaryUnitsPrecision

    ' Allow the user to change the precision for the dimension and dimension tolerance
    newPrecision = InputBox("Enter a new precision for the dimension and tolerances.  The value must range from 0 to 8.", "Change Precision", oldPrecision)

    Select Case newPrecision
        Case 0: newPrecision = zcDimPrecisionZero
        Case 1: newPrecision = zcDimPrecisionOne
        Case 2: newPrecision = zcDimPrecisionTwo
        Case 3: newPrecision = zcDimPrecisionThree
        Case 4: newPrecision = zcDimPrecisionFour
        Case 5: newPrecision = zcDimPrecisionFive
        Case 6: newPrecision = zcDimPrecisionSix
        Case 7: newPrecision = zcDimPrecisionSeven
        Case 8: newPrecision = zcDimPrecisionEight
        Case Else
            MsgBox "The precision has not been changed."
            Exit Sub
    End Select

    ' Change the dimension and tolerance precision
    dimObj.TolerancePrecision = newPrecision
    dimObj.PrimaryUnitsPrecision = newPrecision
    dimObj.Update
    ZoomAll

    ' Read back and display the dimension and dimension tolerance precision
    newPrecision = dimObj.PrimaryUnitsPrecision
    MsgBox "The precision has been set to " & newPrecision & " decimal places"

End Sub


PrincipalDirections Property Example
Sub Example_PrincipalDirections()

    ' This example creates a box in model space
    ' It then returns the PrincipalDirections for that box
    Dim boxObj As Zcad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double

    ' Define the box
    center(0) = 5#: center(1) = 5#: center(2) = 0
    length = 5#: width = 7: height = 10#

    ' Create the box (3DSolid) object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)
    ThisDrawing.Regen zcActiveViewport

    ' Change the viewing direction of the viewport to better see the box
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

    ' Return the PrincipalDirections for the box
    Dim PrincipalDirections As Variant
    PrincipalDirections = boxObj.PrincipalDirections
    MsgBox "The PrincipalDirections for the box are " & PrincipalDirections(0) & ", " & PrincipalDirections(1) & ", " & PrincipalDirections(2), , "PrincipalDirections Example"

End Sub


PrincipalMoments Property Example
Sub Example_PrincipalMoments()

    ' This example creates a box in model space
    ' It then returns the PrincipalMoments for that box
    Dim boxObj As Zcad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double

    ' Define the box
    center(0) = 5#: center(1) = 5#: center(2) = 0
    length = 5#: width = 7: height = 10#

    ' Create the box (3DSolid) object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)
    ThisDrawing.Regen zcActiveViewport

    ' Change the viewing direction of the viewport to better see the box
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

    ' Return the PrincipalMoments for the box
    Dim PrincipalMoments As Variant
    PrincipalMoments = boxObj.PrincipalMoments
    MsgBox "The PrincipalMoments for the box are " & PrincipalMoments(0) & ", " & PrincipalMoments(1) & ", " & PrincipalMoments(2), , "PrincipalMoments Example"

End Sub


ProductOfInertia Property Example
Sub Example_ProductOfInertia()
    ' This example creates a box in model space.
    ' It then returns the ProductOfInertia for that box.

    Dim boxObj As Zcad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double

    ' Define the box
    center(0) = 100#: center(1) = 100#: center(2) = 0
    length = 30#: width = 50: height = 100#

    ' Create the box (3DSolid) object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Change the viewing direction of the viewport to better see the box
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

    ' Return the ProductOfInertia for the box
    Dim ProductOfInertia As Variant
    ProductOfInertia = boxObj.ProductOfInertia
    MsgBox "The ProductOfInertia for the box is " & ProductOfInertia(0) & ", " & ProductOfInertia(1) & ", " & ProductOfInertia(2), , "ProductOfInertia Example"

End Sub


PromptString Property Example
Sub Example_PromptString()

    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String
    Dim pstring As String

    ' Define the attribute definition
    height = 1#
    mode = zcAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "New Tag"
    value = "New Value"

    ' Create the attribute definition object in model space
    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    pstring = attributeObj.PromptString
    attributeObj.Update
    ZoomAll
    MsgBox "The PromptString is  " & pstring, vbInformation, "PromptString Example"

End Sub


RadiiOfGyration Property Example
Sub Example_RadiiOfGyration()
    ' This example creates a box in model space.
    ' It then returns the RadiiOfGyration for that box.

    Dim boxObj As Zcad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double

    ' Define the box
    center(0) = 100#: center(1) = 100#: center(2) = 0
    length = 30#: width = 50: height = 100#

    ' Create the box (3DSolid) object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

    ' Change the viewing direction of the viewport to better see the box
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

    ' Return the RadiiOfGyration for the box
    Dim RadiiOfGyration As Variant
    RadiiOfGyration = boxObj.RadiiOfGyration
    MsgBox "The RadiiOfGyration for the box is " & RadiiOfGyration(0) & ", " & RadiiOfGyration(1) & ", " & RadiiOfGyration(2), , "RadiiOfGyration Example"

End Sub


Radius Property Example
Sub Example_Radius()
    ' This example creates an arc in model space.
    ' It then returns the radius of the arc.

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    ' Define the circle
    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#
    endAngle = 230 * 3.141592 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ZoomAll

    ' Find the radius of the arc
    MsgBox "The radius of the arc is " & arcObj.radius, , "Radius Example"
    arcObj.radius = 20
    arcObj.Update
    MsgBox "The New radius of the arc is " & arcObj.radius, , "Radius Example"

End Sub


RadiusRatio Property Example
Sub Example_RadiusRatio()

    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double

    ' Create an ellipse in model space
    center(0) = 0#: center(1) = 0#: center(2) = 0#
    majAxis(0) = 10: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)

    ' Set the radius ratio of the ellipse
    ellObj.RadiusRatio = 0.75
    ellObj.Update
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

End Sub


ReadOnly Property Example
Sub Example_ReadOnly()
    ' This example shows if current document file is read only or not

    If ThisDrawing.ReadOnly Then
        MsgBox "The current document file is read only.", , "ReadOnly Example"
    Else
        MsgBox "The current document file is read-write.", , "ReadOnly Example"
    End If

End Sub


Red Property Example
Sub Example_Red()
    ' This example draws a line and returns the RGB values

    Dim fcolor As ZcadZcCmColor
    Set fcolor = ZcadApplication.GetInterfaceObject("ZWCAD.ZcCmColor")
    Call fcolor.SetRGB(30, 100, 200)

    Dim line As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double

    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#

    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    line.TrueColor = fcolor
    line.Update

    Dim retcolor As ZcadZcCmColor
    Set retcolor = line.TrueColor
    MsgBox "Red = " & retcolor.Red

End Sub


RegisteredApplications Property Example
Sub Example_RegisteredApplications()
    ' This example finds the current RegisteredApplications collection and
    ' adds a new RegisteredApplication to that collection.

    Dim RegAppColl As ZcadRegisteredApplications
    Set RegAppColl = ThisDrawing.RegisteredApplications

    ' Create a RegisteredApp named "TEST" in the current drawing
    Dim RegAppObj As ZcadRegisteredApplication
    Set RegAppObj = RegAppColl.Add("TEST")
MsgBox "A new registered application called " & RegAppObj.Name & " has been added to the Registered Applications collection.", vbInformation, "RegisteredApplications Example"

End Sub


RemoveHiddenLines Property Example
Sub Example_RemoveHiddenLines()

    Dim pviewportObj As ZcadPViewport
    Dim center(0 To 2) As Double
    Dim width As Double
    Dim height As Double

    ' Define the paper space viewport
    center(0) = 3: center(1) = 3: center(2) = 0
    width = 40
    height = 40

    ' Change from model space to paper space
    ThisDrawing.ActiveSpace = zcPaperSpace

    ' Create the paper space viewport
    Set pviewportObj = ThisDrawing.PaperSpace.AddPViewport(center, width, height)
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The value of the RemoveHiddenLines property for the paperspace viewport is " & pviewportObj.RemoveHiddenLines, , "RemoveHiddenLines Example"

End Sub


RevisionNumber Property Example
Sub Example_RevisionNumber()

    ThisDrawing.SummaryInfo.Author = "Eason"
    ThisDrawing.SummaryInfo.Comments = "Developer Help documentation"
    ThisDrawing.SummaryInfo.HyperlinkBase = "http://www.zwsoft.com"
    ThisDrawing.SummaryInfo.Keywords = "VBA"
    ThisDrawing.SummaryInfo.LastSavedBy = "JD"
    ThisDrawing.SummaryInfo.RevisionNumber = "2023"
    ThisDrawing.SummaryInfo.Subject = "VBA COM"
    ThisDrawing.SummaryInfo.Title = "ZWCAD2023"

    Author = ThisDrawing.SummaryInfo.Author
    Comments = ThisDrawing.SummaryInfo.Comments
    HLB = ThisDrawing.SummaryInfo.HyperlinkBase
    KW = ThisDrawing.SummaryInfo.Keywords
    LSB = ThisDrawing.SummaryInfo.LastSavedBy
    RN = ThisDrawing.SummaryInfo.RevisionNumber
    Subject = ThisDrawing.SummaryInfo.Subject
    Title = ThisDrawing.SummaryInfo.Title
    MsgBox "The standard drawing properties are " & vbCrLf & _
            "Author = " & Author & vbCrLf & _
            "Comments = " & Comments & vbCrLf & _
            "HyperlinkBase = " & HLB & vbCrLf & _
            "Keywords = " & KW & vbCrLf & _
            "LastSavedBy = " & LSB & vbCrLf & _
            "RevisionNumber = " & RN & vbCrLf & _
            "Subject = " & Subject & vbCrLf & _
            "Title = " & Title & vbCrLf

End Sub


Rotation Property Example
Sub Example_Rotation()

    Dim mtextObj As ZcadMText
    Dim width As Double
    Dim text As String
    Dim corner(0 To 2) As Double

    corner(0) = 3#: corner(1) = 3#: corner(2) = 0#
    width = 3
    text = "This is a text String."
    ' Creates a MText object in model space
    Set mtextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)
    mtextObj.height = 1
    mtextObj.Update
    ZoomAll

    MsgBox "The Rotation is " & mtextObj.Rotation, vbInformation, "Rotation Example"

    mtextObj.Rotation = 0.707
    mtextObj.Update
    ZoomAll
    MsgBox "The Rotation is set to " & mtextObj.Rotation, vbInformation, "Rotation Example"

End Sub


RoundDistance Property Example
Sub Example_RoundDistance()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 10.1523: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.Update
    ZoomAll
    MsgBox "Press any key to round the dimension unit display to 0.1"

    ' Round the distance of the dimension to 0.1 of a unit
    dimObj.RoundDistance = 0.1
    dimObj.Update
    ZoomAll
    MsgBox "Dimension units have been rounded to: " & dimObj.RoundDistance

End Sub


Saved Property Example
Sub Example_Saved()
    ' This example checks to see if the current document has been modified.

    If Not ThisDrawing.Saved Then
        MsgBox "document has been modified! Use the Save or SaveAs method to save the document.", , "Saved Example"
    Else
        MsgBox "document has not been modified since the last save.", , "Saved Example"
    End If

End Sub


ScaleFactor Property Example
Sub Example_ScaleFactor()
    ' This example creates a text object in model space.
    ' It then finds the current scale factor and changes it.

    Dim textObj As ZcadText
    Dim text As String
    Dim insertionPoint(0 To 2) As Double
    Dim height As Double

    ' Define the text object
    text = "Hello, World."
    insertionPoint(0) = 2: insertionPoint(1) = 2: insertionPoint(2) = 0
    height = 0.5

    ' Create the text object in model space
    Set textObj = ThisDrawing.ModelSpace.AddText(text, insertionPoint, height)
    ZoomAll

    ' Find the current scale factor for the text object
    Dim currScaleFactor As Double
    currScaleFactor = textObj.scalefactor
    MsgBox "The scale factor of the text is " & textObj.scalefactor, , "ScaleFactor Example"

    ' Change the scale factor for the text object
    textObj.scalefactor = currScaleFactor + 3
    textObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The scale factor of the text is now " & textObj.scalefactor, , "ScaleFactor Example"

End Sub


ScaleLineweights Property Example
Sub Example_ScaleLineweights()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "Old ScaleLineweights: " & PlotConfiguration.ScaleLineweights

    PlotConfiguration.ScaleLineweights = Not PlotConfiguration.ScaleLineweights

    MsgBox "New ScaleLineweights: " & PlotConfiguration.ScaleLineweights

End Sub


SecondPoint Property Example
Sub Example_SecondPoint()

    Dim basePoint(0 To 2) As Double
    Dim directionVec(0 To 2) As Double
    Dim rayObj As ZcadRay
    Dim currSecondPoint(0 To 2) As Double
    Dim msg As String
    Dim newSecondPoint(0 To 2) As Double
    basePoint(0) = 1: basePoint(1) = 3: basePoint(2) = 0
    directionVec(0) = 5:    directionVec(1) = 5: directionVec(2) = 0
    Set rayObj = ThisDrawing.ModelSpace.AddRay(basePoint, directionVec)
    rayObj.Update

    newSecondPoint(0) = 4: newSecondPoint(1) = 2: newSecondPoint(2) = 0
    rayObj.SecondPoint = newSecondPoint
    msg = rayObj.SecondPoint(0) & vbCrLf & _
          rayObj.SecondPoint(1) & vbCrLf & _
          rayObj.SecondPoint(2)
    rayObj.Update
    MsgBox "We've just changed the second point of the new Ray to: " & vbCrLf & msg, vbInformation

End Sub


SelectionSets Property Example
Sub Example_SelectionSets()

    Dim SSetColl As ZcadSelectionSets
    Set SSetColl = ThisDrawing.SelectionSets
    Dim ssetObj As ZcadSelectionSet
    Set ssetObj = SSetColl.Add("TEST")
    MsgBox "A new SelectionSet called " & ssetObj.Name & " has been added to the SelectionSets collection.", vbInformation, "SelectionSets Example"

End Sub


ShowPlotStyles Property Example
Sub Example_ShowPlotStyles()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "Old ShowPlotStyles: " & PlotConfiguration.ShowPlotStyles

    PlotConfiguration.ShowPlotStyles = Not PlotConfiguration.ShowPlotStyles

    MsgBox "New ShowPlotStyles: " & PlotConfiguration.ShowPlotStyles

End Sub


ShowRotation Property Example
Sub Example_ShowRotation()

    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "d:\123.jpg"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0#
    scalefactor = 1#
    rotationAngle = 0

    ' Creates a raster image in model space
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)
    ZoomAll

    MsgBox "show rotation"
    rasterObj.ShowRotation = True
    rotationAngle = 30 * 3.1415926 / 180
    rasterObj.Rotate insertionPoint, rotationAngle
    rasterObj.Update
    ZoomAll

End Sub


SnapBasePoint Property Example
Sub Example_SnapBasePoint()

    Dim viewportObj As ZcadViewport
    Set viewportObj = ThisDrawing.Viewports.Add("NewViewport11111")

    Dim currSnapPnt As Variant
    currSnapPnt = viewportObj.SnapBasePoint
    MsgBox "The current model space snap base point is " & viewportObj.SnapBasePoint(0) & ", " & viewportObj.SnapBasePoint(1), , "SnapBasePoint Example"

    Dim newSnapPn(0 To 1) As Double
    newSnapPn(0) = 5#: newSnapPn(1) = 5#
    viewportObj.SnapBasePoint = newSnapPn
    MsgBox "The new model space snap base point is " & viewportObj.SnapBasePoint(0) & ", " & viewportObj.SnapBasePoint(1), , "SnapBasePoint Example"

End Sub


SnapRotationAngle Property Example
Sub Example_SnapRotationAngle()

    ' Create a new model space viewport
    Dim viewportObj As ZcadViewport
    Set viewportObj = ThisDrawing.Viewports.Add("NewViewport")

    ' Find the current snap rotation angle
    Dim currSnapAngle As Double
    currSnapAngle = viewportObj.SnapRotationAngle
    MsgBox "The current model space snap rotation angle is " & viewportObj.SnapRotationAngle, , "SnapRotationAngle Example"

    ' Change the snap rotation angle
    viewportObj.SnapRotationAngle = 1.5
    ThisDrawing.ActiveViewport = viewportObj
    MsgBox "The new model space snap rotation angle is " & viewportObj.SnapRotationAngle, , "SnapRotationAngle Example"

End Sub


StandardScale Property Example
Sub Example_StandardScale()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "Old StandardScale: " & PlotConfiguration.StandardScale

    PlotConfiguration.StandardScale = zcScaleToFit

    MsgBox "New StandardScale: " & PlotConfiguration.StandardScale

End Sub


StartAngle Property Example
Sub Example_StartAngle()
    ' This example creates an arc and enters the start and
    ' end angles to create an elliptical arc.

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double
    Dim endAngle As Double

    ' Define the circle
    centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#
    endAngle = 230 * 3.141592 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcActiveViewport

    'Enter a start angle of 45 degrees
    arcObj.startAngle = 45 * (3.14 / 180)
    arcObj.Update
    MsgBox "The arc has a start angle of " & arcObj.startAngle * (180 / 3.14) & " degrees.", vbInformation, "StartAngle Example"

End Sub


StartParameter Property Example
Sub Example_StartParameter()
    ' This example creates an ellipse and enters the start and
    ' end parameters to create an elliptical arc.

    Dim ellObj As ZcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double

    ' Create an ellipse in model space
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)

    ' Enter a start parameter of 0.785, and an end parameter of 6.28
    ellObj.StartParameter = 0.785
    ellObj.EndParameter = 6.28
    ellObj.Update

    ' Find the start and end parameters for the ellipse
    MsgBox "The ellipse has a start parameter of " & ellObj.StartParameter & " and an end parameter of " & ellObj.EndParameter, vbInformation, "EndParameter Example"

End Sub


StartPoint Property Example
Sub Example_StartPoint()
    ' This example creates an arc and then
    ' finds the coordinates of its start point and endpoint.

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ZoomAll

    ' Find the start and endpoints for the arc
    Dim startpoint As Variant, endpoint As Variant
    startpoint = arcObj.startpoint
    endpoint = arcObj.endpoint
    MsgBox "This ellipse has a start point of " & startpoint(0) & ", " & startpoint(1) & ", " & startpoint(2) & _
                           " and an endpoint of " & endpoint(0) & ", " & endpoint(1) & ", " & endpoint(2), vbInformation, "StartPoint Example"

End Sub


StartTangent Property Example
Sub Example_StartTangent()
    ' This example creates a spline. It then queries the current setting for
    ' the StartTangent, and then changes the StartTangent to a new value.

    ' Create the spline
    Dim msg As String
    Dim plineObj As ZcadSpline
    Dim points(0 To 8) As Double

    points(0) = 1: points(1) = 1: points(2) = 0
    points(3) = 5: points(4) = 5: points(5) = 0
    points(6) = 10: points(7) = 0: points(8) = 0

    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0

    Set plineObj = ThisDrawing.ModelSpace.AddSpline(points, startTan, endTan)

    GoSub GETPOINTS
    MsgBox "The StartTangent for the spline is " & msg, vbInformation, "StartTangent Example"

    ' Change the end tangent of Spline to (1.5,0.707,2)
    Dim newTan(0 To 2) As Double
    newTan(0) = 1.5: newTan(1) = 0.707: newTan(2) = 2
    plineObj.StartTangent = newTan
    plineObj.Update
    ThisDrawing.Regen zcActiveViewport

    GoSub GETPOINTS
    MsgBox "The StartTangent has been changed to " & msg, vbInformation, "StartTangent Example"
    Exit Sub

GETPOINTS:
    msg = ""

    ' Get the coordinates from the end tangent
    msg = Format(plineObj.StartTangent(0), "0.###") & ", " & Format(plineObj.StartTangent(1), "0.###") & ", " & _
          Format(plineObj.StartTangent(2), "0.###") & ","
    msg = VBA.Left(msg, Len(msg) - 1)
    Return

End Sub


StatusID Property Example
Sub Example_StatusID()
    ' This example displays the setting of StatusID.

    Dim currStatusID As Boolean
    currStatusID = ThisDrawing.Application.StatusId(ThisDrawing.ActiveViewport)
    MsgBox "The statusID of the active viewort is: " & currStatusID, , "StatusID Example"

End Sub


StyleName Property Example
Sub Example_StyleName()

    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String

    ' Define the attribute definition
    height = 1#
    mode = zcAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "New Tag"
    value = "New Value"

    ' Create the attribute definition object in model space
    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    attributeObj.Update
    MsgBox attributeObj.StyleName
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

End Sub


StyleSheet Property Example
Sub Example_StyleSheet()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "Old StyleSheet: " & PlotConfiguration.StyleSheet

    PlotConfiguration.StyleSheet = "zwcad.ctb"

    MsgBox "New StyleSheet: " & PlotConfiguration.StyleSheet

End Sub


Subject Property Example
Sub Example_Subject()

    ThisDrawing.SummaryInfo.Author = "Eason"
    ThisDrawing.SummaryInfo.Comments = "Developer Help documentation"
    ThisDrawing.SummaryInfo.HyperlinkBase = "http://www.zwsoft.com"
    ThisDrawing.SummaryInfo.Keywords = "VBA"
    ThisDrawing.SummaryInfo.LastSavedBy = "JD"
    ThisDrawing.SummaryInfo.RevisionNumber = "2023"
    ThisDrawing.SummaryInfo.Subject = "VBA COM"
    ThisDrawing.SummaryInfo.Title = "ZWCAD2023"

    Author = ThisDrawing.SummaryInfo.Author
    Comments = ThisDrawing.SummaryInfo.Comments
    HLB = ThisDrawing.SummaryInfo.HyperlinkBase
    KW = ThisDrawing.SummaryInfo.Keywords
    LSB = ThisDrawing.SummaryInfo.LastSavedBy
    RN = ThisDrawing.SummaryInfo.RevisionNumber
    Subject = ThisDrawing.SummaryInfo.Subject
    Title = ThisDrawing.SummaryInfo.Title
    MsgBox "The standard drawing properties are " & vbCrLf & _
            "Author = " & Author & vbCrLf & _
            "Comments = " & Comments & vbCrLf & _
            "HyperlinkBase = " & HLB & vbCrLf & _
            "Keywords = " & KW & vbCrLf & _
            "LastSavedBy = " & LSB & vbCrLf & _
            "RevisionNumber = " & RN & vbCrLf & _
            "Subject = " & Subject & vbCrLf & _
            "Title = " & Title & vbCrLf

End Sub


SummaryInfo Property Example
Sub Example_SummaryInfo()
    ' This example shows how to access drawing properties

    ' Add and display standard properties
    ThisDrawing.SummaryInfo.Author = "John Doe"
    ThisDrawing.SummaryInfo.Comments = "Includes all ten levels of Building Five"
    ThisDrawing.SummaryInfo.HyperlinkBase = "http://www.zwsoft.com"
    ThisDrawing.SummaryInfo.Keywords = "Building Complex"
    ThisDrawing.SummaryInfo.LastSavedBy = "JD"
    ThisDrawing.SummaryInfo.RevisionNumber = "4"
    ThisDrawing.SummaryInfo.Subject = "Plan for Building Five"
    ThisDrawing.SummaryInfo.Title = "Building Five"

    Author = ThisDrawing.SummaryInfo.Author
    Comments = ThisDrawing.SummaryInfo.Comments
    HLB = ThisDrawing.SummaryInfo.HyperlinkBase
    KW = ThisDrawing.SummaryInfo.Keywords
    LSB = ThisDrawing.SummaryInfo.LastSavedBy
    RN = ThisDrawing.SummaryInfo.RevisionNumber
    Subject = ThisDrawing.SummaryInfo.Subject
    Title = ThisDrawing.SummaryInfo.Title
    MsgBox "The standard drawing properties are " & vbCrLf & _
            "Author = " & Author & vbCrLf & _
            "Comments = " & Comments & vbCrLf & _
            "HyperlinkBase = " & HLB & vbCrLf & _
            "Keywords = " & KW & vbCrLf & _
            "LastSavedBy = " & LSB & vbCrLf & _
            "RevisionNumber = " & RN & vbCrLf & _
            "Subject = " & Subject & vbCrLf & _
            "Title = " & Title & vbCrLf

    ' Add and display custom properties
    Dim Key0 As String
    Dim Value0 As String
    Dim Key1 As String
    Dim Value1 As String
    Dim CustomPropertyBranch As String
    Dim PropertyBranchValue As String
    Dim CustomPropertyZone As String
    Dim PropertyZoneValue As String

    CustomPropertyBranch = "Branch"
    PropertyBranchValue = "Main"
    CustomPropertyZone = "Zone"
    PropertyZoneValue = "Industrial"

    ' Add custom properties
    If (ThisDrawing.SummaryInfo.NumCustomInfo >= 1) Then
        ThisDrawing.SummaryInfo.SetCustomByIndex 0, CustomPropertyBranch, PropertyBranchValue
    Else
        ThisDrawing.SummaryInfo.AddCustomInfo CustomPropertyBranch, PropertyBranchValue
    End If

    If (ThisDrawing.SummaryInfo.NumCustomInfo >= 2) Then
         ThisDrawing.SummaryInfo.SetCustomByKey CustomPropertyBranch, "Satellite"
    Else
         ThisDrawing.SummaryInfo.AddCustomInfo CustomPropertyZone, PropertyZoneValue
    End If

    'Get custom properties
    ThisDrawing.SummaryInfo.GetCustomByIndex 0, Key0, Value0
    Key1 = CustomPropertyZone
    ThisDrawing.SummaryInfo.GetCustomByKey Key1, Value1

    MsgBox "The custom drawing properties are " & vbCrLf & _
            "First property name = " & Key0 & vbCrLf & _
            "First property value = " & Value0 & vbCrLf & _
            "Second property name = " & Key1 & vbCrLf & _
            "Second property value = " & Value1 & vbCrLf
End Sub


SuppressLeadingZeros Property Example
Sub Example_SuppressLeadingZeros()

   ' This example creates an aligned dimension in model space.
    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 5.02: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle the display of leading zeros in the dimension", vbOKCancel)
        Case vbOK
            ' Toggle the display of leading zeros for the dimension value
         dimObj.SuppressLeadingZeros = Not (dimObj.SuppressLeadingZeros)
         dimObj.Update
         ZoomAll
        Case vbCancel
            Exit Sub
    End Select
    GoTo Toggle

End Sub


SuppressTrailingZeros Property Example
Sub Example_SuppressTrailingZeros()

    ' This example creates an aligned dimension in model space.
    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 6#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.SuppressTrailingZeros = False
    dimObj.Update
    ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle the display of trailing zeros in the dimension", vbOKCancel)
        Case vbOK
            ' Toggle the display of trailing zeros for the dimension value
         dimObj.SuppressTrailingZeros = Not (dimObj.SuppressTrailingZeros)
         dimObj.Update
         ThisDrawing.Regen zcActiveViewport
        Case vbCancel
            Exit Sub
    End Select
    GoTo Toggle

End Sub


SuppressZeroFeet Property Example
Sub Example_SuppressZeroFeet()

    ' This example creates an aligned dimension in model space.
    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 6#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.UnitsFormat = zcDimLArchitectural
    dimObj.Update
    ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle the display of trailing zeros in the dimension", vbOKCancel)
        Case vbOK
         dimObj.SuppressZeroFeet = Not (dimObj.SuppressZeroFeet)
         dimObj.Update
         ThisDrawing.Regen zcActiveViewport
        Case vbCancel
            Exit Sub
    End Select
    GoTo Toggle

End Sub


SuppressZeroInches Property Example
Sub Example_SuppressZeroInches()

    ' This example creates an aligned dimension in model space.
    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 0#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 12#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.UnitsFormat = zcDimLArchitectural
    dimObj.Update
    ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle the display of trailing zeros in the dimension", vbOKCancel)
        Case vbOK
         dimObj.SuppressZeroInches = Not (dimObj.SuppressZeroInches)
         dimObj.Update
         ThisDrawing.Regen zcActiveViewport
        Case vbCancel
            Exit Sub
    End Select
    GoTo Toggle

End Sub


TabOrder Property Example
Sub Example_TabOrder()

    Dim Layout1 As ZcadLayout, Layout2 As ZcadLayout
    Dim msg As String
    Set Layout1 = ThisDrawing.Layouts.Add("Z VIEW")
    Set Layout2 = ThisDrawing.Layouts.Add("A VIEW")

    Layout2.TabOrder = 1
    Layout1.TabOrder = 2
    ThisDrawing.Layouts(1).TabOrder = 3
    ThisDrawing.Layouts(2).TabOrder = 4
    msg = "The tab order is now set to: " & vbCrLf & vbCrLf

    For TabCount = 0 To (ThisDrawing.Layouts.Count - 1)

        TabName = ThisDrawing.Layouts(TabCount).Name
        TabOrder = ThisDrawing.Layouts(TabCount).TabOrder
        msg = msg & "(" & TabOrder & ")" & vbTab & TabName & vbCrLf
   Next

        MsgBox msg, vbInformation

End Sub


TagString Property Example
Sub Example_TagString()

    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String
    Dim pstring As String

    ' Define the attribute definition
    height = 1#
    mode = zcAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0
    tag = "New Tag"
    value = "New Value"

    ' Create the attribute definition object in model space
    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    pstring = attributeObj.TagString
    attributeObj.Update
    ZWCAD.ZoomAll
    MsgBox "The TagString is  " & pstring, vbInformation, "PromptString Example"

End Sub


Target Property Example
Sub Example_Target()
    ' This example changes the target for a model space viewport.

    ' Create a new model space viewport
    Dim viewportObj As ZcadViewport
    Set viewportObj = ThisDrawing.Viewports.Add("NewViewport")

    ' Add a circle
    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 0: center(1) = 0: center(2) = 0
    radius = 1
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(center, radius)

    ' Find the current target
    Dim currTarget As Variant
    currTarget = viewportObj.Target
    MsgBox "The current target is " & viewportObj.Target(0) & ", " & viewportObj.Target(1) & ", " & viewportObj.Target(2), , "Target Example"

    ' Change the target
    Dim newTarget(0 To 2) As Double
    newTarget(0) = 2#: newTarget(1) = 2#: newTarget(2) = 0
    viewportObj.Target = newTarget
    ThisDrawing.ActiveViewport = viewportObj
    ThisDrawing.Regen zcAllViewports
    MsgBox "The new target is " & viewportObj.Target(0) & ", " & viewportObj.Target(1) & ", " & viewportObj.Target(2), , "Target Example"

End Sub


TextAlignmentPoint Property Example
Sub Example_TextAlignmentPoint()

    Dim textObj As ZcadText
    Dim text As String
    Dim insertionPoint(0 To 2) As Double
    Dim height As Double

    ' Define the text object
    text = "Hello, World."
    insertionPoint(0) = 2: insertionPoint(1) = 2: insertionPoint(2) = 0
    height = 0.5

    ' Create the text object in model space
    Set textObj = ThisDrawing.ModelSpace.AddText(text, insertionPoint, height)
    ZWCAD.ZoomAll
    MsgBox "The TextAlignmentPoint is set to the default " & textObj.TextAlignmentPoint(0) & ", " & textObj.TextAlignmentPoint(1) & ", " & textObj.TextAlignmentPoint(2), vbInformation, "TextAlignmentPoint Example"

    Dim alignmentPoint(0 To 2) As Double
    alignmentPoint(0) = 5: alignmentPoint(1) = 3: alignmentPoint(2) = 0
    textObj.Alignment = zcAlignmentRight
    textObj.TextAlignmentPoint = alignmentPoint
    textObj.Update
    ZWCAD.ZoomAll
    MsgBox "The TextAlignmentPoint is set to " & textObj.TextAlignmentPoint(0) & ", " & textObj.TextAlignmentPoint(1) & ", " & textObj.TextAlignmentPoint(2) & vbCrLf & "The Alignment is set to zczcAlignmentRight", vbInformation, "TextAlignmentPoint Example"

End Sub


TextColor Property Example
Sub Example_TextColor()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ZWCAD.ZoomAll

    ' Read and display current dimension text color
    MsgBox "The dimension text color for this object is currently set to: " & DimPointAngularObj.TextColor

    ' Change the dimension text color
    DimPointAngularObj.TextColor = zcRed
    DimPointAngularObj.Update
    ZWCAD.ZoomAll

    ' Read and display current dimension text color
    MsgBox "The dimension text color for this object is now set to: " & DimPointAngularObj.TextColor & " (Red)"

End Sub


TextGap Property Example
Sub Example_TextGap()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 12: FirstPoint(1) = 12: FirstPoint(2) = 0
    SecondPoint(0) = 11: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 16: TextPoint(1) = 16: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    DimPointAngularObj.Update
    ZWCAD.ZoomAll

    ' Read and display current dimension gap
    MsgBox "The dimension gap for this object is currently set to: " & DimPointAngularObj.TextGap

    ' Increase the distance of the dimension gap
    DimPointAngularObj.TextGap = 10
    DimPointAngularObj.Update

    ' Read and display current dimension gap
    MsgBox "The dimension gap for this object is now set to: " & DimPointAngularObj.TextGap

End Sub


TextGenerationFlag Property Example
Sub Example_TextGenerationFlag()

    Dim textObj As ZcadText
    Dim text As String
    Dim insertionPoint(0 To 2) As Double
    Dim height As Double

    ' Define the text object
    text = "Test"
    insertionPoint(0) = 100: insertionPoint(1) = 100: insertionPoint(2) = 0
    height = 10

    ' Create the text object in model space
    Set textObj = ThisDrawing.ModelSpace.AddText(text, insertionPoint, height)
    ZWCAD.ZoomAll
    MsgBox "The TextGenerationFlag has not been set.", vbInformation, "TextGenerationFlag Example"

    ' Change the value of the TextGenerationFlag
    textObj.TextGenerationFlag = zcTextFlagBackward
    textObj.Update
    ZWCAD.ZoomAll
    MsgBox "The TextGenerationFlag is set to zcTextFlagBackward.", vbInformation, "TextGenerationFlag Example"

    textObj.TextGenerationFlag = zcTextFlagUpsideDown
    textObj.Update
    ZWCAD.ZoomAll
    MsgBox "The TextGenerationFlag is set to zcTextFlagUpsideDown.", vbInformation, "TextGenerationFlag Example"

    textObj.TextGenerationFlag = zcTextFlagBackward + zcTextFlagUpsideDown
    textObj.Update
    ZWCAD.ZoomAll
    MsgBox "The TextGenerationFlag is set to zcTextFlagUpsideDown & zcTextFlagBackward.", vbInformation, "TextGenerationFlag Example"

End Sub


TextHeight Property Example
Sub Example_TextHeight()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    DimPointAngularObj.Update
    ZWCAD.ZoomAll

    ' Read and display current dimension text height
    MsgBox "The dimension text height for this object is currently set to: " & DimPointAngularObj.TextHeight

    ' Increase the distance of the dimension gap
    DimPointAngularObj.TextHeight = 10
    DimPointAngularObj.Update
    ThisDrawing.Regen zcAllViewports

    ' Read and display current dimension text height
    MsgBox "The dimension text height for this object is now set to: " & DimPointAngularObj.TextHeight

End Sub


TextInside Property Example
Sub Example_TextInside()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    DimPointAngularObj.TextInside = False
    DimPointAngularObj.Update
    ZWCAD.ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle forcing the dimension text inside the extension lines", vbOKCancel)
        Case vbOK
            ' Toggle forcing the dimension text inside the extension lines
            DimPointAngularObj.TextInside = Not (DimPointAngularObj.TextInside)
            DimPointAngularObj.Update
            ' Read and display the new dimension TextInside value
            CurrentValue = IIf(DimPointAngularObj.TextInside, "is now", "is not")
            MsgBox "The dimension text " & CurrentValue & " forced inside the extension lines"

        Case vbCancel
            Exit Sub
    End Select
    GoTo Toggle

End Sub


TextInsideAlign Property Example
Sub Example_TextInsideAlign()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    DimPointAngularObj.TextInside = True
    DimPointAngularObj.Update
    ZWCAD.ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle the TextInsideAlign value for this dimension", vbOKCancel)
        Case vbOK
            ' Toggle the TextInsideAlign value for this dimension
            DimPointAngularObj.TextInsideAlign = Not (DimPointAngularObj.TextInsideAlign)
            DimPointAngularObj.Update
            ZoomAll
            ' Read and display the new dimension TextInsideAlign value
            MsgBox "TextInsideAlign is currently set to: " & DimPointAngularObj.TextInsideAlign

        Case vbCancel
            Exit Sub
    End Select
    GoTo Toggle

End Sub


TextMovement Property Example
Sub Example_TextMovement()

    Dim dimpointangularobj As ZcadDim3PointAngular, dimpointangularobj1 As ZcadDim3PointAngular
    Dim dimpointangularobj2 As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double, AngleVertex1(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double, FirstPoint1(0 To 2) As Double, SecondPoint1(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double, TextPoint1(0 To 2) As Double
    Dim anglevertex2(0 To 2) As Double
    Dim firstpoint2(0 To 2) As Double, secondpoint2(0 To 2) As Double
    Dim TextPoint2(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    AngleVertex1(0) = 5: AngleVertex1(1) = 5: AngleVertex1(2) = 0
    FirstPoint1(0) = 2: FirstPoint1(1) = 2: FirstPoint1(2) = 0
    SecondPoint1(0) = 1: SecondPoint1(1) = 4: SecondPoint1(2) = 0
    TextPoint1(0) = 20: TextPoint1(1) = 20: TextPoint1(2) = 0

    anglevertex2(0) = 0: anglevertex2(1) = 0: anglevertex2(2) = 0
    firstpoint2(0) = 2: firstpoint2(1) = 2: firstpoint2(2) = 0
    secondpoint2(0) = 1: secondpoint2(1) = 4: secondpoint2(2) = 0
    TextPoint2(0) = 30: TextPoint2(1) = 30: TextPoint2(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set dimpointangularobj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    Set dimpointangularobj1 = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex1, FirstPoint1, SecondPoint1, TextPoint1)
    Set dimpointangularobj2 = ThisDrawing.ModelSpace.AddDim3PointAngular(anglevertex2, firstpoint2, SecondPoint1, TextPoint2)
    dimpointangularobj.TextColor = zcBlue
    dimpointangularobj1.TextColor = zcRed
    dimpointangularobj2.TextColor = zcGreen
    dimpointangularobj.Update
    dimpointangularobj1.Update
    dimpointangularobj2.Update

    ' Set the text movement of the new dimensions to different values
    dimpointangularobj.TextMovement = zcMoveTextNoLeader
    dimpointangularobj1.TextMovement = zcDimLineWithText
    dimpointangularobj2.TextMovement = zcMoveTextAddLeader
    dimpointangularobj.Update
    dimpointangularobj1.Update
    dimpointangularobj2.Update

End Sub


TextOutsideAlign Property Example
Sub Example_TextOutsideAlign()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle the TextOutsideAlign value for this dimension", vbOKCancel)
        Case vbOK
            ' Toggle the TextOutsideAlign value for this dimension
            DimPointAngularObj.TextOutsideAlign = Not (DimPointAngularObj.TextOutsideAlign)
            DimPointAngularObj.Update
            ThisDrawing.Regen zcActiveViewport

            ' Read and display the new dimension TextOutsideAlign value
            MsgBox "TextOutsideAlign is currently set to: " & DimPointAngularObj.TextOutsideAlign

        Case vbCancel
            Exit Sub
    End Select
    GoTo Toggle

End Sub


TextOverride Property Example
Sub Example_TextOverride()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ZoomAll
    MsgBox "The initial text string for the dimension contains only the dimension value.", vbInformation, "TextOverride Example"

    ' Change the text string for the dimension
    DimPointAngularObj.TextOverride = "The value is <>"
    DimPointAngularObj.Update
    MsgBox "The text string for the dimension has been replaced. However, the dimension value is still represented.", vbInformation, "TextOverride Example"
    ZoomAll

    ' Reset the text string for the dimension
    DimPointAngularObj.TextOverride = ""
    DimPointAngularObj.Update
    MsgBox "The text string for the dimension is reset.", vbInformation, "TextOverride Example"

End Sub


TextPrecision Property Example
Sub Example_TextPrecision()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ZoomAll

    ' Increase the distance of the dimension gap
    DimPointAngularObj.TextPrecision = zcDimPrecisionFive
    DimPointAngularObj.Update
    ZoomAll

    ' Read and display current dimension text precision
    MsgBox "The dimension text precision is now set to: " & DimPointAngularObj.TextPrecision

End Sub


TextPrefix Property Example
Sub Example_TextPrefix()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ZoomAll

    Dim prefix As String

    ' Allow the user to change the text prefix for the dimension
    prefix = InputBox("Enter a new text prefix for the dimension", "Set Dimension Prefix", "PREFIX:")
    DimPointAngularObj.TextPrefix = prefix   ' Commit changes to prefix
    DimPointAngularObj.Update
    ThisDrawing.Regen zcAllViewports

    ' Read back and display the dimension text prefix
    prefix = DimPointAngularObj.TextPrefix
    If prefix <> "" Then
        MsgBox "The prefix of the dimension has been changed to: " & prefix
    Else
        MsgBox "The prefix of the dimension has been removed"
    End If

End Sub


TextRotation Property Example
Sub Example_TextRotation()
    ' This example creates an angular dimension in model space.
    ' Then change its TextRotation property.

    Dim dimObj As ZcadDimAngular
    Dim angVert(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double
    Dim SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the dimension
    angVert(0) = 0#: angVert(1) = 0#: angVert(2) = 0#
    FirstPoint(0) = 11#: FirstPoint(1) = 7#: FirstPoint(2) = 0#
    SecondPoint(0) = 20#: SecondPoint(1) = 23#: SecondPoint(2) = 0#
    TextPoint(0) = 25#: TextPoint(1) = 25#: TextPoint(2) = 0#

    ' Create the angular dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAngular(angVert, FirstPoint, SecondPoint, TextPoint)
    dimObj.Update

    MsgBox "The current text rotation angle for the dimension is " & dimObj.TextRotation & " radians.", vbInformation, "TextRotation Example"

    ' Change the text rotation angle to 45 degrees (.707 radians)
    dimObj.TextRotation = 0.707
    dimObj.Update

    MsgBox "The new text rotation angle for the dimension is " & dimObj.TextRotation & " radians.", vbInformation, "TextRotation Example"

End Sub


TextString Property Example
Sub Example_TextString()
    ' This example creates a text object in model space.
    ' It then returns the text string for that object.

    Dim mtextObj As ZcadMText
    Dim width As Double
    Dim text As String
    Dim corner(0 To 2) As Double

    corner(0) = 3#: corner(1) = 3#: corner(2) = 0#
    width = 3
    text = "This is a text String."

    ' Creates a MText object in model space
    Set mtextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)
    mtextObj.Height = 1
    mtextObj.Update
    ZoomAll

    ' Return the current text string for the object
    text = mtextObj.TextString
    MsgBox "The TextString property equals: " & text, vbInformation, "TextString Example"

End Sub


TextStyle Property Example
Sub Example_TextStyle()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ZoomAll

    ' Create new text style
    Dim newtext As ZcadTextStyle
    Set newtext = ThisDrawing.TextStyles.Add("MYSTYLE")
    newtext.Height = 5

    ' Read and display the current text style for this dimension
    MsgBox "The text style is currently set to: " & DimPointAngularObj.TextStyle

    ' Change the text style to use the new style we created
    DimPointAngularObj.TextStyle = "MYSTYLE"
    DimPointAngularObj.Update
    ZoomAll

    ' Read and display the current text style for this dimension
    MsgBox "The text style of this dimension is now set to: " & DimPointAngularObj.TextStyle

End Sub


TextStyles Property Example
Sub Example_TextStyles()

    Dim TextColl As ZcadTextStyles
    Set TextColl = ThisDrawing.TextStyles

    ' Create a Text style named "TEST" in the current document
    Dim textStyle As ZcadTextStyle
    Set textStyle = TextColl.Add("TEST")
    MsgBox "A new Text style called " & textStyle.Name & " has been added to the Textstyles collection.", vbInformation, "Textstyles Example"

End Sub


TextSuffix Property Example
Sub Example_TextSuffix()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim suffix As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    ZoomAll

    ' Allow the user to change the text suffix for the dimension
    suffix = InputBox("Enter a new text suffix for the dimension", "Set Dimension Suffix", ":SUFFIX")
    DimPointAngularObj.TextSuffix = suffix   ' Commit changes to suffix

    DimPointAngularObj.Update

    ' Read back and display the dimension text suffix
    suffix = DimPointAngularObj.TextSuffix
    If suffix <> "" Then
        MsgBox "The suffix of the dimension has been changed to: " & suffix
    Else
        MsgBox "The suffix of the dimension has been removed"
    End If

End Sub


Thickness Property Example
Sub Example_Thickness()
    ' This example creates an arc in model space
    ' and changes the thickness of the arc.

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ZoomAll

    ' Find the current thickness of the arc
    Dim currThickness As Double
    currThickness = arcObj.Thickness
    MsgBox "The thickness of the arc is " & arcObj.Thickness, vbInformation, "Thickness Example"

    ' Change the thickness of the arc
    arcObj.Thickness = currThickness + 3
    arcObj.Update

    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport

    MsgBox "The thickness of the arc is now " & arcObj.Thickness, vbInformation, "Thickness Example"

End Sub


Title Property Example
Sub Example_Title()

    ThisDrawing.SummaryInfo.Author = "Eason"
    ThisDrawing.SummaryInfo.Comments = "Developer Help documentation"
    ThisDrawing.SummaryInfo.HyperlinkBase = "http://www.zwsoft.com"
    ThisDrawing.SummaryInfo.Keywords = "VBA"
    ThisDrawing.SummaryInfo.LastSavedBy = "JD"
    ThisDrawing.SummaryInfo.RevisionNumber = "2023"
    ThisDrawing.SummaryInfo.Subject = "VBA COM"
    ThisDrawing.SummaryInfo.Title = "ZWCAD2023"

    Author = ThisDrawing.SummaryInfo.Author
    Comments = ThisDrawing.SummaryInfo.Comments
    HLB = ThisDrawing.SummaryInfo.HyperlinkBase
    KW = ThisDrawing.SummaryInfo.Keywords
    LSB = ThisDrawing.SummaryInfo.LastSavedBy
    RN = ThisDrawing.SummaryInfo.RevisionNumber
    Subject = ThisDrawing.SummaryInfo.Subject
    Title = ThisDrawing.SummaryInfo.Title
    MsgBox "The standard drawing properties are " & vbCrLf & _
            "Author = " & Author & vbCrLf & _
            "Comments = " & Comments & vbCrLf & _
            "HyperlinkBase = " & HLB & vbCrLf & _
            "Keywords = " & KW & vbCrLf & _
            "LastSavedBy = " & LSB & vbCrLf & _
            "RevisionNumber = " & RN & vbCrLf & _
            "Subject = " & Subject & vbCrLf & _
            "Title = " & Title & vbCrLf

End Sub


ToleranceDisplay Property Example
Sub Example_ToleranceDisplay()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim CurrentDisplay As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ZoomAll

    ' Read and display the current tolerance display for this dimension
    CurrentDisplay = IIf(DimPointAngularObj.ToleranceDisplay = acTolNone, "Hidden", "Visible")
    MsgBox "The tolerance display is currently: " & CurrentDisplay

    ' Toggle the tolerance display for this dimension
    If DimPointAngularObj.ToleranceDisplay = zcTolNone Then
        DimPointAngularObj.ToleranceDisplay = zcTolSymmetrical
        CurrentDisplay = "Symmetrical"
    Else
        DimPointAngularObj.ToleranceDisplay = zcTolNone
        CurrentDisplay = "None"
    End If

    DimPointAngularObj.Update
    ThisDrawing.Regen zcAllViewports

    ' Display the current tolerance display for this dimension
    MsgBox "The tolerance display is now set to: " & CurrentDisplay

End Sub


ToleranceHeightScale Property Example
Sub Example_ToleranceHeightScale()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    ' Turn on the tolerance display
    DimPointAngularObj.ToleranceDisplay = zcTolSymmetrical
    DimPointAngularObj.Update
    ZoomAll

Increase:
    ' Read and display the current tolerance height scale for this dimension
    If MsgBox("The tolerance height scale is currently set to: " & DimPointAngularObj.ToleranceHeightScale & vbCrLf & _
               "Press OK to increase, or cancel to finish", vbOKCancel) = vbCancel Then

        Exit Sub
    End If

    ' Increase the tolerance height scale for this dimension
    DimPointAngularObj.ToleranceHeightScale = DimPointAngularObj.ToleranceHeightScale + 1
    DimPointAngularObj.Update
    ThisDrawing.Regen zcAllViewports
    GoTo Increase

End Sub


ToleranceJustification Property Example
Sub Example_ToleranceJustification()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim CurrentDisplay As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    ' Turn on the tolerance display
    DimPointAngularObj.ToleranceDisplay = zcTolSymmetrical
    DimPointAngularObj.TextHeight = 1
    DimPointAngularObj.ToleranceHeightScale = 0.25
    DimPointAngularObj.Update
    ZoomAll

    ' Read and display the current tolerance justification for this dimension
    Select Case DimPointAngularObj.ToleranceJustification
        Case zcTolBottom: CurrentDisplay = "Bottom"
        Case zcTolTop: CurrentDisplay = "Top"
        Case zcTolMiddle: CurrentDisplay = "Middle"
    End Select

    MsgBox "The tolerance justification is currently: " & CurrentDisplay

    ' Set the tolerance justification for this dimension
    DimPointAngularObj.ToleranceJustification = zcTolTop
    DimPointAngularObj.Update
    ZoomAll

    ' Display the current tolerance justification for this dimension
    MsgBox "The tolerance display is now set to: Bottom"

End Sub


ToleranceLowerLimit Property Example
Sub Example_ToleranceLowerLimit()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    Dim CurrentDisplay As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    ' Turn on the tolerance display
    DimPointAngularObj.ToleranceDisplay = zcTolSymmetrical

    ' Read and display the tolerance limits for the dimension
    MsgBox "The tolerance lower limit is set to: " & DimPointAngularObj.ToleranceLowerLimit & vbCrLf & _
           "The tolerance upper limit is set to: " & DimPointAngularObj.ToleranceUpperLimit

    ' Adjust the tolerance limits for this dimension
    DimPointAngularObj.ToleranceLowerLimit = 0.0001
    DimPointAngularObj.ToleranceUpperLimit = 0.005

    DimPointAngularObj.Update
    ZoomAll

    ' Read and display the tolerance limits for the dimension
    MsgBox "The tolerance lower limit is now set to: " & DimPointAngularObj.ToleranceLowerLimit & vbCrLf & _
           "The tolerance upper limit is now set to: " & DimPointAngularObj.ToleranceUpperLimit

End Sub


TolerancePrecision Property Example
Sub Example_TolerancePrecision()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim oldTolerance As String, newTolerance As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    ' Enable and setup tolerance display
    DimPointAngularObj.ToleranceDisplay = zcTolSymmetrical
    DimPointAngularObj.ToleranceLowerLimit = -0.0001
    DimPointAngularObj.ToleranceUpperLimit = 0.005
    DimPointAngularObj.Update
    ZoomAll

    ' Store old tolerance value as default for input box
    oldTolerance = DimPointAngularObj.TolerancePrecision

    ' Allow the user to change the precision for the dimension tolerance
    newTolerance = InputBox("Enter a new tolerance precision for the dimension.  The value must range from 0 to 8.", "Dimension Tolerance Precision", oldTolerance)

    Select Case newTolerance
        Case 0: newTolerance = zcDimPrecisionZero
        Case 1: newTolerance = zcDimPrecisionOne
        Case 2: newTolerance = zcDimPrecisionTwo
        Case 3: newTolerance = zcDimPrecisionThree
        Case 4: newTolerance = zcDimPrecisionFour
        Case 5: newTolerance = zcDimPrecisionFive
        Case 6: newTolerance = zcDimPrecisionSix
        Case 7: newTolerance = zcDimPrecisionSeven
        Case 8: newTolerance = zcDimPrecisionEight
        Case Else
            MsgBox "The tolerance precision has not been changed."
            Exit Sub
    End Select

    DimPointAngularObj.TolerancePrecision = newTolerance   ' Commit changes to tolerance precision
    DimPointAngularObj.Update

    ThisDrawing.Regen zcAllViewports

    ' Read back and display the dimension tolerance precision
    newTolerance = DimPointAngularObj.TolerancePrecision
    MsgBox "The tolerance precision has been set to " & newTolerance & " decimal places"

End Sub


ToleranceSuppressLeadingZeros Property Example
Sub Example_ToleranceSuppressLeadingZeros()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 7#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 8#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.ToleranceDisplay = zcTolSymmetrical
    dimObj.ToleranceLowerLimit = -0.002
    dimObj.ToleranceUpperLimit = 0.002
    dimObj.ToleranceSuppressLeadingZeros = True
    dimObj.ToleranceSuppressTrailingZeros = False
    dimObj.Update
    ThisDrawing.Regen zcAllViewports
    ZoomAll

End Sub


ToleranceSuppressTrailingZeros Property Example
Sub Example_ToleranceSuppressTrailingZeros()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 7#: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 8#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.ToleranceDisplay = zcTolSymmetrical
    dimObj.ToleranceLowerLimit = -0.002
    dimObj.ToleranceUpperLimit = 0.002
    dimObj.ToleranceSuppressTrailingZeros = True
    dimObj.Update
    ThisDrawing.Regen zcAllViewports
    ZoomAll

End Sub


ToleranceSuppressZeroFeet Property Example
Sub Example_ToleranceSuppressZeroFeet()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 6.01: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 8#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.UnitsFormat = zcDimLArchitectural
    dimObj.ToleranceDisplay = zcTolLimits
    dimObj.ToleranceLowerLimit = -0.0002
    dimObj.ToleranceUpperLimit = 0.0002
    dimObj.ToleranceSuppressZeroFeet = True
    dimObj.Update
    ThisDrawing.Regen zcAllViewports
    ZoomAll

End Sub


ToleranceSuppressZeroInches Property Example
Sub Example_ToleranceSuppressZeroInches()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 6.01: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 8#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.UnitsFormat = zcDimLArchitectural
    dimObj.ToleranceDisplay = zcTolLimits
    dimObj.ToleranceLowerLimit = -95#
    dimObj.ToleranceUpperLimit = 95#
    dimObj.ToleranceSuppressZeroInches = True
    dimObj.Update
    ThisDrawing.Regen zcAllViewports
    ZoomAll

End Sub


ToleranceUpperLimit Property Example
Sub Example_ToleranceUpperLimit()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double

    Dim CurrentDisplay As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)

    ' Turn on the tolerance display
    DimPointAngularObj.ToleranceDisplay = zcTolSymmetrical

    ' Read and display the tolerance limits for the dimension
    MsgBox "The tolerance lower limit is set to: " & DimPointAngularObj.ToleranceLowerLimit & vbCrLf & _
          "The tolerance upper limit is set to: " & DimPointAngularObj.ToleranceUpperLimit

    ' Adjust the tolerance limits for this dimension
    DimPointAngularObj.ToleranceLowerLimit = 0.0001
    DimPointAngularObj.ToleranceUpperLimit = 0.005
    DimPointAngularObj.Update
    ZoomAll

    ' Read and display the tolerance limits for the dimension
    MsgBox "The tolerance lower limit is now set to: " & DimPointAngularObj.ToleranceLowerLimit & vbCrLf & _
           "The tolerance upper limit is now set to: " & DimPointAngularObj.ToleranceUpperLimit

End Sub


Toolbars Property Example
Sub Example_Toolbars()

    Dim toolbarCollection As ZcadToolbars
    Dim toolbar As ZcadToolbar

    Set toolbarCollection = ThisDrawing.Application.MenuGroups.Item(0).Toolbars
    MsgBox toolbarCollection.Count

End Sub


TotalAngle Property Example
Sub Example_TotalAngle()
    ' This example creates an Arc in model space and
    ' returns the total angle of the new Arc

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    radius = 5#
    startAngle = 60 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    ' Create the arc object in model space
    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ThisDrawing.Regen zcAllViewports

    ' Return length of new arc
    MsgBox "The total angle of the new Arc is: " & arcObj.TotalAngle

End Sub


TranslateIDs Property Example
Sub Example_TranslateIDs()

    Dim TrackingDictionary As ZcadDictionary, TrackingXRecord As ZcadXRecord
    Dim currobject As Boolean

    Set TrackingDictionary = ThisDrawing.Dictionaries.Add("Test")
    Set TrackingXRecord = TrackingDictionary.AddXRecord("XRECORD")
    currobject = TrackingXRecord.TranslateIDs

    MsgBox "The current setting of the TranslateIDs is :  " & currobject
    TrackingXRecord.TranslateIDs = Not TrackingXRecord.TranslateIDs
    MsgBox "The new setting for the TranslateIDs is : " & TrackingXRecord.TranslateIDs

End Sub


Transparency Property Example
Sub Example_Transparency()

    Dim insertionPoint(0 To 2) As Double
    Dim scalefactor As Double
    Dim rotationAngle As Double
    Dim imageName As String
    Dim rasterObj As ZcadRasterImage
    imageName = "D:\boot\123.jpg"
    insertionPoint(0) = 5#: insertionPoint(1) = 5#: insertionPoint(2) = 0#
    scalefactor = 1#
    rotationAngle = 0

    ' Creates a raster image in model space
    Set rasterObj = ThisDrawing.ModelSpace.AddRaster(imageName, insertionPoint, scalefactor, rotationAngle)
    rasterObj.Transparency = True
    rasterObj.Update
    ThisDrawing.Regen zcAllViewports
    MsgBox IIf(rasterObj.Transparency, "The Transparency is now set to True", "The Transparency is now set to False")

End Sub


TrueColor Property Example
Sub Example_TrueColor()
    ' This example draws a line and returns the RGB values

    Dim color As ZcadZcCmColor
    Set color = ZcadApplication.GetInterfaceObject("ZWCAD.ZcCmColor")
    color.SetRGB 80, 100, 244

    Dim line As ZcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#

    Set line = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    line.TrueColor = color
    line.Update

    Dim retcolor As ZcadZcCmColor
    Set retcolor = line.TrueColor
    MsgBox "Red = " & retcolor.Red
    MsgBox "Green = " & retcolor.Green
    MsgBox "Blue = " & retcolor.Blue

End Sub


TwistAngle Property Example
Sub Example_twistAngle()

    Dim pviewportObj As ZcadPViewport
    Dim center(0 To 2) As Double
    Dim width As Double
    Dim height As Double

    ' Define the paper space viewport
    center(0) = 3: center(1) = 3: center(2) = 0
    width = 40
    height = 40

    ' Change from model space to paper space
    ThisDrawing.ActiveSpace = zcPaperSpace

    ' Create the paper space viewport
    Set pviewportObj = ThisDrawing.PaperSpace.AddPViewport(center, width, height)
    ThisDrawing.Regen zcAllViewports
    MsgBox "The twist angle of the paper space viewport is " & pviewportObj.TwistAngle, , "twistAngle Example"

End Sub


Type Property Example
Sub Example_Type()

    Dim leaderObj As ZcadLeader
    Dim Points(0 To 8) As Double
    Dim leaderType As Integer
    Dim annotation As ZcadEntity

    Points(0) = 0: Points(1) = 0: Points(2) = 0
    Points(3) = 4: Points(4) = 4: Points(5) = 0
    Points(6) = 4: Points(7) = 5: Points(8) = 0

    leaderType = zcLineWithArrow
    Set annotation = Nothing

    Set leaderObj = ThisDrawing.ModelSpace.AddLeader(Points, annotation, zcLineNoArrow)
    MsgBox leaderObj.Type
    ThisDrawing.Regen zcAllViewports
    ZoomAll

End Sub


UnitsFormat Property Example
Sub Example_UnitsFormat()

    Dim dimObj As ZcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double

    ' Define the dimension
    point1(0) = 5#: point1(1) = 5#: point1(2) = 0#
    point2(0) = 10.6: point2(1) = 5#: point2(2) = 0#
    location(0) = 5#: location(1) = 7#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.Update

    dimObj.UnitsFormat = zcDimLScientific     ' Change format to Scientific
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The dimension units are now set to Scientific"

    dimObj.UnitsFormat = zcDimLDecimal        ' Change format to Decimal
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The dimension units are now set to Decimal"

    dimObj.UnitsFormat = zcDimLArchitectural  ' Change format to Architectural
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The dimension units are now set to Architectural"

    dimObj.UnitsFormat = zcDimLWindowsDesktop ' Change format to WindowsDesktop
    dimObj.Update
    ThisDrawing.Regen zcActiveViewport
    MsgBox "The dimension units are now set to Windows Desktop"

End Sub


Unload Property Example
Sub Example_Unload()

    Dim InsertPoint(0 To 2) As Double
    Dim insertedBlock As ZcadExternalReference
    Dim tempBlock As ZcadBlock
    Dim msg As String, PathName As String

    InsertPoint(0) = 100: InsertPoint(1) = 100: InsertPoint(2) = 0
    PathName = "D:\123.dwg"
    Set insertedBlock = ThisDrawing.ModelSpace.AttachExternalReference(PathName, _
    "XREF_IMAGE", InsertPoint, 1, 1, 1, 0, False)
    ThisDrawing.Blocks.Item(insertedBlock.Name).Unload
    ZoomAll

End Sub


Update Property Example
Sub Example_Update()

    ' Create the arc
    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ZoomAll
    MsgBox "Before the update.", , "Update Example"

    ' The following code draws an object in zcad+ window
    arcObj.color = zcBlue
    arcObj.Update
    MsgBox "After the update.", , "Update Example"

End Sub


UpperRightCorner Property Example
Sub Example_UpperRightCorner()

    Dim newViewport As ZcadViewport
    Set newViewport = ThisDrawing.Viewports.Add("TESTVIEWPORT")
    ThisDrawing.ActiveViewport = newViewport

    Dim entry As ZcadViewport
    Dim UpperRight As Variant
    For Each entry In ThisDrawing.Viewports
        entry.GridOn = True
        ThisDrawing.ActiveViewport = entry
         UpperRight = entry.UpperRightCorner
        MsgBox "The upper right corner of this viewport is " & UpperRight(0) & ", " & UpperRight(1), , "UpperRightCorner Example"
        entry.GridOn = False
    Next

End Sub


UpsideDown Property Example
Sub Example_UpsideDown()

    Dim textObj As ZcadText
    Dim textString As String
    Dim insertionPoint(0 To 2) As Double
    Dim height As Double

    ' Define the new Text object
    textString = "Hello, World."
    insertionPoint(0) = 3: insertionPoint(1) = 3: insertionPoint(2) = 0
    height = 0.5

    ' Create the Text object in model space
    Set textObj = ThisDrawing.ModelSpace.AddText(textString, insertionPoint, height)
    ThisDrawing.Application.ZoomAll
    MsgBox "The Text oject is now right side up"

    textObj.UpsideDown = True
    textObj.Update
    ThisDrawing.Application.ZoomAll
    MsgBox "The Text object is now upside down"

End Sub


URL Property Example
Sub Example_URL()

    Dim Hyperlinks As ZcadHyperlinks
    Dim Hyperlink As ZcadHyperlink
    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim list As String

    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    radius = 100#
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)
    ThisDrawing.Application.ZoomAll

    Set Hyperlinks = circleObj.Hyperlinks
    Set Hyperlink = Hyperlinks.Add("zcad+")
    Hyperlink.URL = "www.zwsoft.com"
    Hyperlink.URLDescription = "ZWCAD Main Site"
    Hyperlink.URLNamedLocation = "C:\boot"

    list = list & "____________________________________" & vbCrLf
    list = list & "URL: " & Hyperlink.URL & vbCrLf
    list = list & "URL Description: " & Hyperlink.URLDescription & vbCrLf
    list = list & "URL Named Location: " & Hyperlink.URLNamedLocation & vbCrLf
    MsgBox "The circle has " & Hyperlinks.Count & " Hyperlink: " & vbCrLf & list

End Sub


URLDescription Property Example
Sub Example_URLDescription()

    Dim Hyperlinks As ZcadHyperlinks
    Dim Hyperlink As ZcadHyperlink
    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim list As String

    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    radius = 100#
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)
    ThisDrawing.Application.ZoomAll

    Set Hyperlinks = circleObj.Hyperlinks
    Set Hyperlink = Hyperlinks.Add("zcad+")
    Hyperlink.URL = "www.zwsoft.com"
    Hyperlink.URLDescription = "ZWCAD Main Site"
    Hyperlink.URLNamedLocation = "C:\boot"

    list = list & "____________________________________" & vbCrLf
    list = list & "URL: " & Hyperlink.URL & vbCrLf
    list = list & "URL Description: " & Hyperlink.URLDescription & vbCrLf
    list = list & "URL Named Location: " & Hyperlink.URLNamedLocation & vbCrLf
    MsgBox "The circle has " & Hyperlinks.Count & " Hyperlink: " & vbCrLf & list

End Sub


URLNamedLocation Property Example
Sub Example_URLNamedLocation()

    Dim Hyperlinks As ZcadHyperlinks
    Dim Hyperlink As ZcadHyperlink
    Dim circleObj As ZcadCircle
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim list As String

    centerPoint(0) = 0: centerPoint(1) = 0: centerPoint(2) = 0
    radius = 100#
    Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius)
    ThisDrawing.Application.ZoomAll

    Set Hyperlinks = circleObj.Hyperlinks
    Set Hyperlink = Hyperlinks.Add("zcad+")
    Hyperlink.URL = "www.zwsoft.com"
    Hyperlink.URLDescription = "ZWCAD Main Site"
    Hyperlink.URLNamedLocation = "C:\boot"

    list = list & "____________________________________" & vbCrLf
    list = list & "URL: " & Hyperlink.URL & vbCrLf
    list = list & "URL Description: " & Hyperlink.URLDescription & vbCrLf
    list = list & "URL Named Location: " & Hyperlink.URLNamedLocation & vbCrLf
    MsgBox "The circle has " & Hyperlinks.Count & " Hyperlink: " & vbCrLf & list

End Sub


Used Property Example
Sub Example_Used()

    Dim MyLayers As ZcadLayers
    Set MyLayers = ThisDrawing.Layers
    MyLayers.GenerateUsageData
    Dim MyLayerObj As ZcadLayer
    For Each MyLayerObj In ThisDrawing.Layers
      MsgBox MyLayerObj.Used
    Next MyLayerObj

End Sub


UserCoordinateSystems Property Example
Sub Example_UserCoordinateSystems()

    Dim UCSColl As ZcadUCSs
    Set UCSColl = ThisDrawing.UserCoordinateSystems

    ' Create a UCS named "TEST" in the current document
    Dim ucsObj As ZcadUCS
    Dim origin(0 To 2) As Double
    Dim xAxisPnt(0 To 2) As Double
    Dim yAxisPnt(0 To 2) As Double

    ' Define the UCS
    origin(0) = 4#: origin(1) = 5#: origin(2) = 3#
    xAxisPnt(0) = 5#: xAxisPnt(1) = 5#: xAxisPnt(2) = 3#
    yAxisPnt(0) = 4#: yAxisPnt(1) = 6#: yAxisPnt(2) = 3#

    ' Add the UCS to the UserCoordinatesSystems collection
    Set ucsObj = UCSColl.Add(origin, xAxisPnt, yAxisPnt, "TEST")
    MsgBox "A new UCS called " & ucsObj.Name & " has been added to the UserCoordinateSystems collection.", vbInformation, "UserCoordinateSystems Example"

End Sub


UseStandardScale Property Example
Sub Example_UseStandardScale()

    Dim PlotConfigurations As ZcadPlotConfigurations
    Dim PlotConfiguration As ZcadPlotConfiguration

    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations

    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.Count = 0 Then
        PlotConfigurations.Add "test"
    End If

    Set PlotConfiguration = PlotConfigurations(0)

    MsgBox "Old UseStandardScale: " & PlotConfiguration.UseStandardScale

    PlotConfiguration.UseStandardScale = Not PlotConfiguration.UseStandardScale

    MsgBox "New UseStandardScale: " & PlotConfiguration.UseStandardScale

End Sub


Utility Property Example
Sub Example_Utility()

    Dim obj As Variant
    Dim utilObj As Object
    Set utilObj = ThisDrawing.Utility
    obj = utilObj.GetPoint(, "Enter a point: ")
    MsgBox obj(0)

End Sub


Verify Property Example
Sub Example_Verify()

    Dim attributeObj As ZcadAttribute
    Dim height As Double
    Dim mode As Long
    Dim prompt As String
    Dim insertionPoint(0 To 2) As Double
    Dim tag As String
    Dim value As String

    ' Define the attribute definition
    height = 10#
    mode = zcAttributeModeVerify
    prompt = "New Prompt"
    insertionPoint(0) = 100#: insertionPoint(1) = 100#: insertionPoint(2) = 0
    tag = "New Tag"
    value = "New Value"

    ' Create the attribute definition object in model space
    Set attributeObj = ThisDrawing.ModelSpace.AddAttribute(height, mode, prompt, insertionPoint, tag, value)
    ThisDrawing.Regen zcActiveViewport
    ZoomAll
    MsgBox attributeObj.Verify

End Sub


Version Property Example
Sub Example_Version()
    ' This example returns zcad+ version as a string

    Dim version As String
    version = ThisDrawing.Application.version
    MsgBox "This is ZWCAD Version " & version, , "Version Example"

End Sub


VerticalTextPosition Property Example
Sub Example_VerticalTextPosition()

    Dim DimPointAngularObj As ZcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim CurrentValue As String

    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ZoomAll

    ' Read and display current text position
    Select Case DimPointAngularObj.VerticalTextPosition
        Case zcVertCentered:    CurrentValue = "centered"
        Case zcAbove:           CurrentValue = "above"
        Case zcOutside:         CurrentValue = "outside"
        Case zcJIS:             CurrentValue = "to Japanesee industrial standards"
    End Select

    MsgBox "The vertical position of the dimension is: " & CurrentValue

    ' Change the position of the dimension text to be centered with the extension lines
    DimPointAngularObj.VerticalTextPosition = zcVertCentered
    DimPointAngularObj.Update
    ThisDrawing.Regen zcAllViewports
    MsgBox "Dimension text is now Centered with the extension lines"

End Sub


Viewports Property Example
Sub Example_Viewports()

    Dim viewportColl As ZcadViewports
    Set viewportColl = ThisDrawing.Viewports
    Dim viewportObj As ZcadViewport
    Set viewportObj = viewportColl.Add("TEST")
    MsgBox "A new viewport called " & viewportObj.Name & " has been added to the Viewports collection.", vbInformation, "Viewports Example"

End Sub


Views Property Example
Sub Example_Views()

    Dim viewColl As ZcadViews
    Set viewColl = ThisDrawing.Views
    Dim viewObj As ZcadView
    Set viewObj = viewColl.Add("TEST")
    MsgBox "A new view called " & viewObj.Name & " has been added to the views collection.", vbInformation, "Views Example"

End Sub


VisibilityEdge1 Property Example
Sub Example_VisibilityEdge1()
    ' This example creates a 3D Face in model space and allows the user to
    ' control the visibility of the edges

    Dim Face3DObj As Zcad3DFace
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim point3(0 To 2) As Double
    Dim point4(0 To 2) As Double

    ' Define the solid
    point1(0) = 0#: point1(1) = 1#: point1(2) = 0#
    point2(0) = 5#: point2(1) = 1#: point2(2) = 0#
    point3(0) = 8#: point3(1) = 8#: point3(2) = 0#
    point4(0) = 4#: point4(1) = 6#: point4(2) = 0#

    ' Create the solid object in model space
    Set Face3DObj = ThisDrawing.ModelSpace.Add3DFace(point1, point2, point3, point4)
    Face3DObj.Update
    ZoomAll

    Dim Edge1Msg As String, Edge2Msg As String, _
        Edge3Msg As String, Edge4Msg As String

    ' Display information about the visibility of the edges for this object
DisplayEdgeInformation:
    Edge1Msg = IIf(Face3DObj.VisibilityEdge1, "Edge1 of the new 3DFace is visible", "Edge1 of the new 3DFace is not visible")
    Edge2Msg = IIf(Face3DObj.VisibilityEdge2, "Edge2 of the new 3DFace is visible", "Edge2 of the new 3DFace is not visible")
    Edge3Msg = IIf(Face3DObj.VisibilityEdge3, "Edge3 of the new 3DFace is visible", "Edge3 of the new 3DFace is not visible")
    Edge4Msg = IIf(Face3DObj.VisibilityEdge4, "Edge4 of the new 3DFace is visible", "Edge4 of the new 3DFace is not visible")

    MsgBox Edge1Msg & vbCrLf & _
           Edge2Msg & vbCrLf & _
           Edge3Msg & vbCrLf & _
           Edge4Msg

    ' Allow user to toggle the visibility of one of the edges
    Select Case InputBox("Which edge of the 3DFace would you like to toggle the visibility of?", "Toggle Edge Visibility", 1)
        Case "1": Face3DObj.VisibilityEdge1 = Not (Face3DObj.VisibilityEdge1)
        Case "2": Face3DObj.VisibilityEdge2 = Not (Face3DObj.VisibilityEdge2)
        Case "3": Face3DObj.VisibilityEdge3 = Not (Face3DObj.VisibilityEdge3)
        Case "4": Face3DObj.VisibilityEdge4 = Not (Face3DObj.VisibilityEdge4)
        Case "":  Exit Sub
        Case Else: MsgBox "You must enter the number of an edge (1-4)", vbInformation
    End Select
      Face3DObj.Update
    ' Refresh view
    ThisDrawing.Regen zcActiveViewport

    ' Return to display information about the edges
    GoTo DisplayEdgeInformation

End Sub


VisibilityEdge2 Property Example
Sub Example_VisibilityEdge2()
    ' This example creates a 3D Face in model space and allows the user to
    ' control the visibility of the edges

    Dim Face3DObj As Zcad3DFace
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim point3(0 To 2) As Double
    Dim point4(0 To 2) As Double

    ' Define the solid
    point1(0) = 0#: point1(1) = 1#: point1(2) = 0#
    point2(0) = 5#: point2(1) = 1#: point2(2) = 0#
    point3(0) = 8#: point3(1) = 8#: point3(2) = 0#
    point4(0) = 4#: point4(1) = 6#: point4(2) = 0#

    ' Create the solid object in model space
    Set Face3DObj = ThisDrawing.ModelSpace.Add3DFace(point1, point2, point3, point4)
    Face3DObj.Update
    ZoomAll

    Dim Edge1Msg As String, Edge2Msg As String, _
        Edge3Msg As String, Edge4Msg As String

    ' Display information about the visibility of the edges for this object
DisplayEdgeInformation:
    Edge1Msg = IIf(Face3DObj.VisibilityEdge1, "Edge1 of the new 3DFace is visible", "Edge1 of the new 3DFace is not visible")
    Edge2Msg = IIf(Face3DObj.VisibilityEdge2, "Edge2 of the new 3DFace is visible", "Edge2 of the new 3DFace is not visible")
    Edge3Msg = IIf(Face3DObj.VisibilityEdge3, "Edge3 of the new 3DFace is visible", "Edge3 of the new 3DFace is not visible")
    Edge4Msg = IIf(Face3DObj.VisibilityEdge4, "Edge4 of the new 3DFace is visible", "Edge4 of the new 3DFace is not visible")

    MsgBox Edge1Msg & vbCrLf & _
           Edge2Msg & vbCrLf & _
           Edge3Msg & vbCrLf & _
           Edge4Msg

    ' Allow user to toggle the visibility of one of the edges
    Select Case InputBox("Which edge of the 3DFace would you like to toggle the visibility of?", "Toggle Edge Visibility", 1)
        Case "1": Face3DObj.VisibilityEdge1 = Not (Face3DObj.VisibilityEdge1)
        Case "2": Face3DObj.VisibilityEdge2 = Not (Face3DObj.VisibilityEdge2)
        Case "3": Face3DObj.VisibilityEdge3 = Not (Face3DObj.VisibilityEdge3)
        Case "4": Face3DObj.VisibilityEdge4 = Not (Face3DObj.VisibilityEdge4)
        Case "":  Exit Sub
        Case Else: MsgBox "You must enter the number of an edge (1-4)", vbInformation
    End Select
      Face3DObj.Update
    ' Refresh view
    ThisDrawing.Regen zcActiveViewport

    ' Return to display information about the edges
    GoTo DisplayEdgeInformation

End Sub


VisibilityEdge3 Property Example
Sub Example_VisibilityEdge3()
    ' This example creates a 3D Face in model space and allows the user to
    ' control the visibility of the edges

    Dim Face3DObj As Zcad3DFace
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim point3(0 To 2) As Double
    Dim point4(0 To 2) As Double

    ' Define the solid
    point1(0) = 0#: point1(1) = 1#: point1(2) = 0#
    point2(0) = 5#: point2(1) = 1#: point2(2) = 0#
    point3(0) = 8#: point3(1) = 8#: point3(2) = 0#
    point4(0) = 4#: point4(1) = 6#: point4(2) = 0#

    ' Create the solid object in model space
    Set Face3DObj = ThisDrawing.ModelSpace.Add3DFace(point1, point2, point3, point4)
    Face3DObj.Update
    ZoomAll

    Dim Edge1Msg As String, Edge2Msg As String, _
        Edge3Msg As String, Edge4Msg As String

    ' Display information about the visibility of the edges for this object
DisplayEdgeInformation:
    Edge1Msg = IIf(Face3DObj.VisibilityEdge1, "Edge1 of the new 3DFace is visible", "Edge1 of the new 3DFace is not visible")
    Edge2Msg = IIf(Face3DObj.VisibilityEdge2, "Edge2 of the new 3DFace is visible", "Edge2 of the new 3DFace is not visible")
    Edge3Msg = IIf(Face3DObj.VisibilityEdge3, "Edge3 of the new 3DFace is visible", "Edge3 of the new 3DFace is not visible")
    Edge4Msg = IIf(Face3DObj.VisibilityEdge4, "Edge4 of the new 3DFace is visible", "Edge4 of the new 3DFace is not visible")

    MsgBox Edge1Msg & vbCrLf & _
           Edge2Msg & vbCrLf & _
           Edge3Msg & vbCrLf & _
           Edge4Msg

    ' Allow user to toggle the visibility of one of the edges
    Select Case InputBox("Which edge of the 3DFace would you like to toggle the visibility of?", "Toggle Edge Visibility", 1)
        Case "1": Face3DObj.VisibilityEdge1 = Not (Face3DObj.VisibilityEdge1)
        Case "2": Face3DObj.VisibilityEdge2 = Not (Face3DObj.VisibilityEdge2)
        Case "3": Face3DObj.VisibilityEdge3 = Not (Face3DObj.VisibilityEdge3)
        Case "4": Face3DObj.VisibilityEdge4 = Not (Face3DObj.VisibilityEdge4)
        Case "":  Exit Sub
        Case Else: MsgBox "You must enter the number of an edge (1-4)", vbInformation
    End Select
      Face3DObj.Update
    ' Refresh view
    ThisDrawing.Regen zcActiveViewport

    ' Return to display information about the edges
    GoTo DisplayEdgeInformation

End Sub


VisibilityEdge4 Property Example
Sub Example_VisibilityEdge4()
    ' This example creates a 3D Face in model space and allows the user to
    ' control the visibility of the edges

    Dim Face3DObj As Zcad3DFace
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim point3(0 To 2) As Double
    Dim point4(0 To 2) As Double

    ' Define the solid
    point1(0) = 0#: point1(1) = 1#: point1(2) = 0#
    point2(0) = 5#: point2(1) = 1#: point2(2) = 0#
    point3(0) = 8#: point3(1) = 8#: point3(2) = 0#
    point4(0) = 4#: point4(1) = 6#: point4(2) = 0#

    ' Create the solid object in model space
    Set Face3DObj = ThisDrawing.ModelSpace.Add3DFace(point1, point2, point3, point4)
    Face3DObj.Update
    ZoomAll

    Dim Edge1Msg As String, Edge2Msg As String, _
        Edge3Msg As String, Edge4Msg As String

    ' Display information about the visibility of the edges for this object
DisplayEdgeInformation:
    Edge1Msg = IIf(Face3DObj.VisibilityEdge1, "Edge1 of the new 3DFace is visible", "Edge1 of the new 3DFace is not visible")
    Edge2Msg = IIf(Face3DObj.VisibilityEdge2, "Edge2 of the new 3DFace is visible", "Edge2 of the new 3DFace is not visible")
    Edge3Msg = IIf(Face3DObj.VisibilityEdge3, "Edge3 of the new 3DFace is visible", "Edge3 of the new 3DFace is not visible")
    Edge4Msg = IIf(Face3DObj.VisibilityEdge4, "Edge4 of the new 3DFace is visible", "Edge4 of the new 3DFace is not visible")

    MsgBox Edge1Msg & vbCrLf & _
           Edge2Msg & vbCrLf & _
           Edge3Msg & vbCrLf & _
           Edge4Msg

    ' Allow user to toggle the visibility of one of the edges
    Select Case InputBox("Which edge of the 3DFace would you like to toggle the visibility of?", "Toggle Edge Visibility", 1)
        Case "1": Face3DObj.VisibilityEdge1 = Not (Face3DObj.VisibilityEdge1)
        Case "2": Face3DObj.VisibilityEdge2 = Not (Face3DObj.VisibilityEdge2)
        Case "3": Face3DObj.VisibilityEdge3 = Not (Face3DObj.VisibilityEdge3)
        Case "4": Face3DObj.VisibilityEdge4 = Not (Face3DObj.VisibilityEdge4)
        Case "":  Exit Sub
        Case Else: MsgBox "You must enter the number of an edge (1-4)", vbInformation
    End Select
      Face3DObj.Update
    ' Refresh view
    ThisDrawing.Regen zcActiveViewport

    ' Return to display information about the edges
    GoTo DisplayEdgeInformation

End Sub


Visible Property Example
Sub Example_Visible()

    Dim arcObj As ZcadArc
    Dim centerPoint(0 To 2) As Double
    Dim radius As Double
    Dim startAngle As Double, endAngle As Double

    ' Define the Arc
    centerPoint(0) = 2#: centerPoint(1) = 2#: centerPoint(2) = 0#
    radius = 5#
    startAngle = 10 * 3.141592 / 180#: endAngle = 230 * 3.141592 / 180#

    Set arcObj = ThisDrawing.ModelSpace.AddArc(centerPoint, radius, startAngle, endAngle)
    ZoomAll

    Dim response As Integer
    response = MsgBox("Do you want the new arc to be visible?", vbYesNoCancel + vbQuestion)
    Select Case response
    Case vbYes
        arcObj.Visible = True
    Case vbNo
        arcObj.Visible = False
    Case vbCancel
        Exit Sub
    End Select
    arcObj.Update

End Sub


Volume Property Example
Sub Example_Volume()

    Dim boxObj As Zcad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double

    ' Define the box
    center(0) = 5#: center(1) = 5#: center(2) = 0
    length = 5#: width = 7: height = 10#

    ' Create the box (3DSolid) object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)

    ' Change the viewing direction of the viewport to better see the box
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.Direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ZoomAll

    ' Return the Volume for the box
    Dim Volume As Double
    Volume = boxObj.Volume
    MsgBox "The Volume for the box is " & Volume, , "Volume Example"

End Sub


Width Property Example
Sub Example_Width()

    Dim mtextObj As ZcadMText
    Dim width As Double
    Dim text As String
    Dim corner(0 To 2) As Double

    corner(0) = 3#: corner(1) = 3#: corner(2) = 0#
    width = 3
    text = "This is a text String."
    ' Creates a MText object in model space
    Set mtextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text)
    mtextObj.Height = 1
    mtextObj.Update
    ZoomAll

    ' Find the current width of the mtext object
    width = mtextObj.width
    MsgBox "The current width of the mtext object is " & mtextObj.width, , "Width Example"

    ' Change the width of the mtext object
    mtextObj.width = width / 2
    mtextObj.Update
    MsgBox "The new width of the mtext object is " & mtextObj.width, , "Width Example"
    Dim app As ZcadApplication
    Set app = ThisDrawing.Application
    MsgBox "the application's width is  " & app.width

End Sub


WindowLeft Property Example
Sub Example_WindowLeft()

    ' Find the current value of the WindowLeft property
    Dim currWindowLeft As Integer
    currWindowLeft = ThisDrawing.Application.WindowLeft
    MsgBox "The current value of WindowLeft is " & ThisDrawing.Application.WindowLeft, , "WindowLeft Example"

    ' Change the value of WindowLeft
    ThisDrawing.Application.WindowLeft = currWindowLeft + 50
    MsgBox "The new value of WindowLeft is " & ThisDrawing.Application.WindowLeft, , "WindowLeft Example"

    ' Reset the value of WindowLeft
    ThisDrawing.Application.WindowLeft = currWindowLeft
    MsgBox "The value of WindowLeft has been reset to " & ThisDrawing.Application.WindowLeft, , "WindowLeft Example"

End Sub


WindowState Property Example
Sub Example_WindowState()
    ' This example reads and displays the current window state of the zcad+ application.

    Dim CurrentState As String

    ' Use the "WindowState" variable to determine the window state of zcad+
    Select Case WindowState
        Case zcMin: CurrentState = "Minimized"
        Case zcMax: CurrentState = "Maximized"
        Case zcNorm: CurrentState = "Normal Size"
    End Select

    ' Display window state
    MsgBox "ZWCAD is now: " & CurrentState

End Sub


WindowTitle Property Example
Sub Example_WindowTitle()

    Dim DOC As ZcadDocument
    Dim msg As String

    If Documents.Count = 0 Then
        MsgBox "There are no open documents!"
        Exit Sub
    End If

    msg = vbCrLf & vbCrLf

    For Each DOC In Documents
        msg = msg & DOC.WindowTitle & vbCr
    Next
    MsgBox "The open document titles are: " & msg

End Sub


WindowTop Property Example
Sub Example_WindowTop()

    ' Find the current value of the WindowTop property
    Dim currWindowTop As Integer
    currWindowTop = ThisDrawing.Application.WindowTop
    MsgBox "The current value of WindowTop is " & ThisDrawing.Application.WindowTop, , "WindowTop Example"

    ' Change the value of WindowTop
    ThisDrawing.Application.WindowTop = currWindowTop + 50
    MsgBox "The new value of WindowTop is " & ThisDrawing.Application.WindowTop, , "WindowTop Example"

    ' Reset the value of WindowTop
    ThisDrawing.Application.WindowTop = currWindowTop
    MsgBox "The value of WindowTop has been reset to " & ThisDrawing.Application.WindowTop, , "WindowTop Example"

End Sub


XScaleFactor Property Example
Sub Example_XScaleFactor()
    ' This example creates a block containing a circle.
    ' It then inserts the block and changes the XScaleFactor.

    ' Create the block
    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 0#: insertionPnt(1) = 0#: insertionPnt(2) = 0#
    On Error Resume Next
    Err.Clear
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "CircleBlock")
    If Err <> 0 Then
        ThisDrawing.Blocks.Item("CircleBlock").Delete
        Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "CircleBlock")
    End If

    ' Add a circle to the block
    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 0: center(1) = 0: center(2) = 0
    radius = 1
    Set circleObj = blockObj.AddCircle(center, radius)

    ' Insert the block
    Dim blockRefObj As ZcadBlockReference
    insertionPnt(0) = 2#: insertionPnt(1) = 2#: insertionPnt(2) = 0
    Set blockRefObj = ThisDrawing.ModelSpace.InsertBlock(insertionPnt, "CircleBlock", 1#, 1#, 1#, 0)

    ' Find the current XScaleFactor for the block reference
    Dim currXScaleFactor As Double
    currXScaleFactor = blockRefObj.XScaleFactor
    ZoomAll
    MsgBox "The current XScaleFactor for the block reference is " & blockRefObj.XScaleFactor, , "XScaleFactor Example"

    ' Change the XScaleFactor for the block reference
    blockRefObj.XScaleFactor = currXScaleFactor + 8
    blockRefObj.Update
    ZoomAll
    MsgBox "The new XScaleFactor for the block reference is " & blockRefObj.XScaleFactor, , "XScaleFactor Example"

End Sub


XVector Property Example
Sub Example_XVector()

    Dim u As ZcadUCS
    Dim Origin(0 To 2) As Double
    Dim xAxisPnt(0 To 2) As Double
    Dim yAxisPnt(0 To 2) As Double

    Origin(0) = 4#: Origin(1) = 5#: Origin(2) = 3#
    xAxisPnt(0) = 5#: xAxisPnt(1) = 5#: xAxisPnt(2) = 3#
    yAxisPnt(0) = 4#: yAxisPnt(1) = 6#: yAxisPnt(2) = 3#

    Set u = ThisDrawing.UserCoordinateSystems.Add(Origin, xAxisPnt, yAxisPnt, "TEST")
    MsgBox "The XVector is:" & u.XVector(0) & "," & u.XVector(1) & "," & u.XVector(2)

End Sub


YScaleFactor Property Example
Sub Example_YScaleFactor()
    ' This example creates a block containing a circle.
    ' It then inserts the block and changes the YScaleFactor.

    ' Create the block
    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 0#: insertionPnt(1) = 0#: insertionPnt(2) = 0#
    On Error Resume Next
    Err.Clear
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "CircleBlock")
    If Err <> 0 Then
      ThisDrawing.Blocks.Item("CircleBlock").Delete
      Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "CircleBlock")
    End If
    ' Add a circle to the block
    Dim circleObj As ZcadCircle

    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 0: center(1) = 0: center(2) = 0
    radius = 1
    Set circleObj = blockObj.AddCircle(center, radius)

    ' Insert the block
    Dim blockRefObj As ZcadBlockReference
    insertionPnt(0) = 2#: insertionPnt(1) = 2#: insertionPnt(2) = 0
    Set blockRefObj = ThisDrawing.ModelSpace.InsertBlock(insertionPnt, "CircleBlock", 1#, 1#, 1#, 0)

    ' Find the current YScaleFactor for the block reference
    Dim currYScaleFactor As Double
    currYScaleFactor = blockRefObj.YScaleFactor
    ZoomAll
    MsgBox "The current YScaleFactor for the block reference is " & blockRefObj.YScaleFactor, , "YScaleFactor Example"

    ' Change the YScaleFactor for the block reference
    blockRefObj.YScaleFactor = currYScaleFactor + 2
    blockRefObj.Update
    ZoomAll
    MsgBox "The new YScaleFactor for the block reference is " & blockRefObj.YScaleFactor, , "YScaleFactor Example"

End Sub


YVector Property Example
Sub Example_YVector()

    Dim u As ZcadUCS
    Dim Origin(0 To 2) As Double
    Dim xAxisPnt(0 To 2) As Double
    Dim yAxisPnt(0 To 2) As Double
    Origin(0) = 4#: Origin(1) = 5#: Origin(2) = 3#
    xAxisPnt(0) = 5#: xAxisPnt(1) = 5#: xAxisPnt(2) = 3#
    yAxisPnt(0) = 4#: yAxisPnt(1) = 6#: yAxisPnt(2) = 3#
    Set u = ThisDrawing.UserCoordinateSystems.Add(Origin, xAxisPnt, yAxisPnt, "TEST")
    MsgBox "The YVector is:" & u.YVector(0) & "," & u.YVector(1) & "," & u.YVector(2)

End Sub


ZScaleFactor Property Example
Sub Example_ZScaleFactor()
    ' This example creates a block containing a circle.
    ' It then inserts the block and changes the ZScaleFactor.

    ' Create the block
    Dim blockObj As ZcadBlock
    Dim insertionPnt(0 To 2) As Double
    insertionPnt(0) = 0#: insertionPnt(1) = 0#: insertionPnt(2) = 0#
    On Error Resume Next
    Err.Clear
    Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "CircleBlock")
    If Err <> 0 Then
        ThisDrawing.Blocks.Item("CircleBlock").Delete
        Set blockObj = ThisDrawing.Blocks.Add(insertionPnt, "CircleBlock")
    End If

    ' Add a circle to the block
    Dim circleObj As ZcadCircle
    Dim center(0 To 2) As Double
    Dim radius As Double
    center(0) = 0: center(1) = 0: center(2) = 0
    radius = 1
    Set circleObj = blockObj.AddCircle(center, radius)

    ' Insert the block
    Dim blockRefObj As ZcadBlockReference
    insertionPnt(0) = 2#: insertionPnt(1) = 2#: insertionPnt(2) = 0
    Set blockRefObj = ThisDrawing.ModelSpace.InsertBlock(insertionPnt, "CircleBlock", 1#, 1#, 1#, 0)

    ' Find the current ZScaleFactor for the block reference
    Dim currZScaleFactor As Double
    currZScaleFactor = blockRefObj.ZScaleFactor
    ZoomAll
    MsgBox "The current ZScaleFactor for the block reference is " & blockRefObj.ZScaleFactor, , "ZScaleFactor Example"

    ' Change the ZScaleFactor for the block reference
    blockRefObj.ZScaleFactor = currZScaleFactor + 2
    blockRefObj.Update
    ZoomAll
    MsgBox "The new ZScaleFactor for the block reference is " & blockRefObj.ZScaleFactor, , "ZScaleFactor Example"

End Sub


CmColor.Delete Method

Deletes the true color.

Syntax

object.Delete

object is a CmColor object.


CmColor.SetColorBookColor Method

Sets the color to a color from a color book.

Syntax

object.SetColorBookColor(BookName, ColorName)

object is a CmColor object.

Parameters

Name | Options | Data Type | Description
BookName | Input-only | String | -
ColorName | Input-only | String | -


CmColor.SetNames Method

Specifies the color name and book name of the color.

Syntax

object.SetNames(ColorName, BookName)

object is a CmColor object.

Parameters

Name | Options | Data Type | Description
ColorName | Input-only | String | -
BookName | Input-only | String | -


CmColor.SetRGB Method

Specifies the RGB values of the true color.

Syntax

object.SetRGB(Red, Green, Blue)

object is a CmColor object.

Parameters

Name | Options | Data Type | Description
Red | Input-only | Long | -
Green | Input-only | Long | -
Blue | Input-only | Long | -


PreferencesProfiles.CopyProfile Method

Copies the specified profile.

Syntax

object.CopyProfile(oldProfileName, newProfileName)

object is a PreferencesProfiles object.

Parameters

Name | Options | Data Type | Description
oldProfileName | Input-only | String | -
newProfileName | Input-only | String | -


PreferencesProfiles.DeleteProfile Method

Deletes the specified profile.

Syntax

object.DeleteProfile(ProfileName)

object is a PreferencesProfiles object.

Parameters

Name | Options | Data Type | Description
ProfileName | Input-only | String | -


PreferencesProfiles.ExportProfile Method

Exports the active profile so it can be shared with other users.

Syntax

object.ExportProfile(ProfileName, RegFile)

object is a PreferencesProfiles object.

Parameters

Name | Options | Data Type | Description
ProfileName | Input-only | String | -
RegFile | Input-only | String | -


PreferencesProfiles.GetAllProfileNames Method

Gets all available profiles for the system.

Syntax

object.GetAllProfileNames(pNames)

object is a PreferencesProfiles object.

Parameters

Name | Options | Data Type | Description
pNames | Output-only | Variant | -


PreferencesProfiles.ImportProfile Method

Imports a profile created by another user.

Syntax

object.ImportProfile(ProfileName, RegFile, IncludePathInfo)

object is a PreferencesProfiles object.

Parameters

Name | Options | Data Type | Description
ProfileName | Input-only | String | -
RegFile | Input-only | String | -
IncludePathInfo | Input-only | Boolean | -


PreferencesProfiles.RenameProfile Method

Renames the specified profile.

Syntax

object.RenameProfile(origProfileName, newProfileName)

object is a PreferencesProfiles object.

Parameters

Name | Options | Data Type | Description
origProfileName | Input-only | String | -
newProfileName | Input-only | String | -


PreferencesProfiles.ResetProfile Method

Resets the value in the specified profile to its default values.

Syntax

object.ResetProfile(Profile)

object is a PreferencesProfiles object.

Parameters

Name | Options | Data Type | Description
Profile | Input-only | String | -


ZcadZcCmColor Object Members

CmColor Object Members

ZWCAD true color object.

VBA Class Name

ZcadZcCmColor

Methods

Name | Description
Delete | Deletes the true color.
SetColorBookColor | Sets the color to a color from a color book.
SetNames | Specifies the color name and book name of the color.
SetRGB | Specifies the RGB values of the true color.

Properties

Name | Description
Blue | Specifies the blue component of the true color.
BookName | Specifies the book name (if any) of the color.
ColorIndex | Specifies the color index.
ColorMethod | Specifies the color method.
ColorName | Specifies the name (if any) of the color.
EntityColor | Specifies the ZwCmEntityColor of the true color.
Green | Specifies the green component of the true color.
Red | Specifies the red component of the true color.

Events

Name | Description
None | -


ZcadPreferences Object Members

Preferences Object Members

This object specifies the current ZWCAD settings.

VBA Class Name

ZcadPreferences

Methods

Name | Description
None | -

Properties

Name | Description
Application | Returns the application object.
Display | Returns the display preferences object.
Drafting | Returns the drafting preferences object.
Files | Returns the file preferences object.
OpenSave | Returns the open/save preferences object.
Output | Returns the output preferences object.
Profiles | Returns the profiles preferences object.
Selection | Returns the selection preferences object.
System | Returns the system preferences object.
User | Returns the user preferences object.

Events

Name | Description
None | -


ZcadPreferencesDisplay Object Members

PreferencesDisplay Object Members

This object contains the options from the Display tab on the Options dialog.

VBA Class Name

ZcadPreferencesDisplay

Methods

Name | Description
None | -

Properties

Name | Description
Application | Returns the application object.
AutoTrackingVecColor | Specifies the color of the auto tracking vector.
CursorSize | Specifies the crosshairs size as a percentage of the screen size.
DisplayLayoutTabs | Specifies whether to display the Model and layout tabs in the drawing editor.
DisplayScreenMenu | Specifies whether to display the screen menu on the right side of the drawing window.
DisplayScrollBars | Specifies whether to display scroll bars at the bottom and right sides of the drawing window.
DockedVisibleLines | Specifies the number of lines of text to display in the command window.
GraphicsWinLayoutBackgrndColor | Specifies the background color for the paper space layouts.
GraphicsWinModelBackgrndColor | Specifies the background color for the model space window.
HistoryLines | Specifies the number of lines of text in the text window to keep in memory.
ImageFrameHighlight | Controls the display of raster images during selection.
LayoutCreateViewport | Toggles the automatic creation of a viewport for new layouts.
LayoutCrosshairColor | Specifies the color of the crosshairs and text for paper space layouts.
LayoutDisplayMargins | Toggles the display of margins in layouts.
LayoutDisplayPaper | Toggles the display of the paper background in layouts.
LayoutDisplayPaperShadow | Toggles the display of the paper background shadow in layouts.
LayoutShowPlotSetup | Toggles the display of the Plot Setup dialog when a new layout is created.
ModelCrosshairColor | Specifies the color of the crosshairs and text for model space.
ShowRasterImage | Controls the display of raster images during real-time pan and zooms.
TextFont | Specifies the font for new text.
TextFontSize | Specifies the font size for new text.
TextFontStyle | Specifies the font style for new text.
TextWinBackgrndColor | Specifies the background color for the text window.
TextWinTextColor | Specifies the text color for the text window.
TrueColorImages | Determines if raster and render images are displayed at true color or palletized color.
XRefFadeIntensity | Controls the dimming intensity for XRefs.

Events

Name | Description
None | -


ZcadPreferencesDrafting Object Members

PreferencesDrafting Object Members

This object contains the options from the Drafting tab on the Options dialog.

VBA Class Name

ZcadPreferencesDrafting

Methods

Name | Description
None | -

Properties

Name | Description
AlignmentPointAcquisition | Specifies how AutoAlignment points are acquired.
Application | Returns the application object.
AutoSnapAperture | Toggles the display of the AutoSnap aperture.
AutoSnapApertureSize | Specifies the size of the AutoSnap aperture.
AutoSnapMagnet | Toggles the AutoSnap magnet.
AutoSnapMarker | Toggles the AutoSnap marker.
AutoSnapMarkerColor | Specifies the color of the AutoSnap marker.
AutoSnapMarkerSize | Specifies the size of the AutoSnap marker.
AutoTrackTooltip | Toggles the display of the AutoTrack tooltips.
FullScreenTrackingVector | Toggles the display of full-screen tracking vectors.
PolarTrackingVector | Toggles the display of polar tracking vectors.

Events

Name | Description
None | -


ZcadPreferencesOpenSave Object Members

PreferencesOpenSave Object Members

This object contains options from the Open and Save tab on the Options dialog.

VBA Class Name

ZcadPreferencesOpenSave

Methods

Name | Description
None | -

Properties

Name | Description
Application | Returns the application object.
AutoAudit | Specifies whether ZWCAD should perform an audit after you render a DXFIN or DXBIN interchange command.
AutoSaveInterval | Specifies an automatic save interval in minutes.
CreateBackup | Specifies the use of a backup file.
FullCRCValidation | Specifies whether a cyclic redundancy check (CRC) should be performed each time an object is read into the drawing.
IncrementalSavePercent | Specifies the percentage of wasted space allowed in a drawing file.
LogFileOn | Specifies whether the contents of the text window are written to a log file.
MRUNumber | Specifies the number of most recently used files that is shown in the File menu.
ProxyImage | Controls the display of objects in a drawing that were created in a third-party application.
SaveAsType | Specifies the drawing type for saving the drawing.
SavePreviewThumbnail | Specifies if BMP preview images are saved with the drawing.
ShowProxyDialogBox | Specifies if ZWCAD displays a warning message when you open a drawing that contains custom objects.
TempFileExtension | Specifies the extension for temporary files.

Events

Name | Description
None | -


ZcadPreferencesProfiles Object Members

PreferencesProfiles Object Members

This object contains the options from the Profiles tab on the Options dialog.

VBA Class Name

ZcadPreferencesProfiles

Methods

Name | Description
CopyProfile | Copies the specified profile.
DeleteProfile | Deletes the specified profile.
ExportProfile | Exports the active profile so it can be shared with other users.
GetAllProfileNames | Gets all available profiles for the system.
ImportProfile | Imports a profile created by another user.
RenameProfile | Renames the specified profile.
ResetProfile | Resets the value in the specified profile to its default values.

Properties

Name | Description
ActiveProfile | Specifies the active profile for the ZWCAD session.
Application | Returns the application object.

Events

Name | Description
None | -


ZcadPreferencesSelection Object Members

PreferencesSelection Object Members

This object contains the options from the Selection tab on the Options dialog.

VBA Class Name

ZcadPreferencesSelection

Methods

Name | Description
None | -

Properties

Name | Description
Application | Returns the application object.
DisplayGrips | Controls the display of selection set grips for the Stretch, Move, Rotate, Scale, and Mirror grip modes.
DisplayGripsWithinBlocks | Controls the assignment of grips within blocks.
GripColorSelected | Specifies the color of selected grips.
GripColorUnselected | Specifies the color of unselected grips.
GripSize | Specifies the size of grips.
PickAdd | Determines if objects are added to the selection set using the SHIFT key.
PickAuto | Controls automatic windowing at the Select Objects prompt.
PickBoxSize | Specifies the size of the object selection target.
PickDrag | Controls the method of drawing a selection window.
PickFirst | Determines if you select objects before (noun-verb selection) or after you issue a command.
PickGroup | Determines if picking a single object in a group selects the entire group.

Events

Name | Description
None | -


ZcadPreferencesSystem Object Members

PreferencesSystem Object Members

This object contains the options from the System tab on the Options dialog.

VBA Class Name

ZcadPreferencesSystem

Methods

Name | Description
None | -

Properties

Name | Description
Application | Returns the application object.
BeepOnError | Specifies if ZWCAD should sound an alarm beep when it detects an invalid entry.
DisplayOLEScale | Determines whether the OLE scaling dialog is displayed when OLE objects are inserted into a drawing.
EnableStartupDialog | Specifies whether a startup dialog box is displayed when ZWCAD is launched or a new drawing is created.
LoadZcadLspInAllDocuments | Specifies whether zcad.lsp is loaded at startup or with each drawing.
ShowWarningMessages | Resets all dialog boxes that have the "Don't Display This Warning Again" check box so they display again.
SingleDocumentMode | Determines if ZWCAD runs in single- or multiple-document mode.
StoreSQLIndex | Determines if the SQL index is stored in the drawing.
TablesReadOnly | Determines whether to open database tables in read-only mode.

Events

Name | Description
None | -


ZcadPreferencesUser Object Members

PreferencesUser Object Members

This object contains the options from the User tab on the Options dialog.

VBA Class Name

ZcadPreferencesUser

Methods

Name | Description
None | -

Properties

Name | Description
ADCInsertUnitsDefaultSource | Determines the units to use automatically for objects in DesignCenter for a source drawing that does not have assigned insert units.
ADCInsertUnitsDefaultTarget | Determines the units to use automatically for objects in DesignCenter for a target drawing that does not have assigned insert units.
Application | Returns the application object.
HyperlinkDisplayCursor | Toggles the display of the hyperlink cursor and shortcut menu.
HyperlinkDisplayTooltip | Toggles the display of hyperlink tooltips.
KeyboardAccelerator | Specifies the Windows standard or ZWCAD classic keyboard.
KeyboardPriority | Controls how ZWCAD responds to the input of coordinate data.
SCMCommandMode | Determines right-click functionality in the drawing area while in Command mode, which means that a command is currently in progress.
SCMDefaultMode | Determines right-click functionality in the drawing area while in Default mode, which means that no objects are selected and no commands are in progress.
SCMEditMode | Determines right-click functionality in the drawing area while in Edit mode, which means that one or more objects are selected and no commands are in progress.
SCMTimeMode | Controls time-sensitive right-click behavior.
SCMTimeValue | Controls time-sensitive right-click behavior by setting the duration of the long click that displays a shortcut menu.
ShortCutMenuDisplay | Controls whether right-clicking in the drawing area displays a shortcut menu or issues ENTER.

Events

Name | Description
None | -


CmColor.Blue Property

Specifies the blue component of the true color.

Syntax

object.Blue

object is a CmColor object.

Description

Blue Long; Read-only


CmColor.BookName Property

Specifies the book name (if any) of the color.

Syntax

object.BookName

object is a CmColor object.

Description

BookName String; Read-only


CmColor.ColorIndex Property

Specifies the color index.

Syntax

object.ColorIndex

object is a CmColor object.

Description

ColorIndex ZcColor: Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


CmColor.ColorMethod Property

Specifies the color method.

Syntax

object.ColorMethod

object is a CmColor object.

Description

ColorMethod ZcColorMethod: Read-write
Can be one of the constants listed here:
zcColorMethodByLayer
zcColorMethodByBlock
zcColorMethodByRGB
zcColorMethodByACI
zcColorMethodForeground


CmColor.ColorName Property

Specifies the name (if any) of the color.

Syntax

object.ColorName

object is a CmColor object.

Description

ColorName String; Read-only


CmColor.EntityColor Property

Specifies the ZwCmEntityColor of the true color.

Syntax

object.EntityColor

object is a CmColor object.

Description

EntityColor Long; Read-write


CmColor.Green Property

Specifies the green component of the true color.

Syntax

object.Green

object is a CmColor object.

Description

Green Long; Read-only


CmColor.Red Property

Specifies the red component of the true color.

Syntax

object.Red

object is a CmColor object.

Description

Red Long; Read-only


Preferences.Application Property

Returns the application object.

Syntax

object.Application

object is a Preferences object.

Description

Application Application; Read-only


Preferences.Display Property

Returns the display preferences object.

Syntax

object.Display

object is a Preferences object.

Description

Display PreferencesDisplay; Read-only


Preferences.Drafting Property

Returns the drafting preferences object.

Syntax

object.Drafting

object is a Preferences object.

Description

Drafting PreferencesDrafting; Read-only


Preferences.Files Property

Returns the file preferences object.

Syntax

object.Files

object is a Preferences object.

Description

Files PreferencesFiles; Read-only


Preferences.OpenSave Property

Returns the open/save preferences object.

Syntax

object.OpenSave

object is a Preferences object.

Description

OpenSave PreferencesOpenSave; Read-only


Preferences.Output Property

Returns the output preferences object.

Syntax

object.Output

object is a Preferences object.

Description

Output PreferencesOutput; Read-only


Preferences.Profiles Property

Returns the profiles preferences object.

Syntax

object.Profiles

object is a Preferences object.

Description

Profiles PreferencesProfiles; Read-only


Preferences.Selection Property

Returns the selection preferences object.

Syntax

object.Selection

object is a Preferences object.

Description

Selection PreferencesSelection; Read-only


Preferences.System Property

Returns the system preferences object.

Syntax

object.System

object is a Preferences object.

Description

System PreferencesSystem; Read-only


Preferences.User Property

Returns the user preferences object.

Syntax

object.User

object is a Preferences object.

Description

User PreferencesUser; Read-only


PreferencesDisplay.Application Property

Returns the application object.

Syntax

object.Application

object is a PreferencesDisplay object.

Description

Application Application; Read-only


PreferencesDisplay.AutoTrackingVecColor Property

Specifies the color of the auto tracking vector.

Syntax

object.AutoTrackingVecColor

object is a PreferencesDisplay object.

Description

AutoTrackingVecColor OLE_COLOR; Read-write


PreferencesDisplay.CursorSize Property

Specifies the crosshairs size as a percentage of the screen size.

Syntax

object.CursorSize

object is a PreferencesDisplay object.

Description

CursorSize Integer; Read-write


PreferencesDisplay.DisplayLayoutTabs Property

Specifies whether to display the Model and layout tabs in the drawing editor.

Syntax

object.DisplayLayoutTabs

object is a PreferencesDisplay object.

Description

DisplayLayoutTabs Boolean; Read-write


PreferencesDisplay.DisplayScreenMenu Property

Specifies whether to display the screen menu on the right side of the drawing window.

Syntax

object.DisplayScreenMenu

object is a PreferencesDisplay object.

Description

DisplayScreenMenu Boolean; Read-write


PreferencesDisplay.DisplayScrollBars Property

Specifies whether to display scroll bars at the bottom and right sides of the drawing window.

Syntax

object.DisplayScrollBars

object is a PreferencesDisplay object.

Description

DisplayScrollBars Boolean; Read-write


PreferencesDisplay.DockedVisibleLines Property

Specifies the number of lines of text to display in the command window.

Syntax

object.DockedVisibleLines

object is a PreferencesDisplay object.

Description

DockedVisibleLines Integer; Read-write


PreferencesDisplay.GraphicsWinLayoutBackgrndColor Property

Specifies the background color for the paper space layouts.

Syntax

object.GraphicsWinLayoutBackgrndColor

object is a PreferencesDisplay object.

Description

GraphicsWinLayoutBackgrndColor OLE_COLOR; Read-write


PreferencesDisplay.GraphicsWinModelBackgrndColor Property

Specifies the background color for the model space window.

Syntax

object.GraphicsWinModelBackgrndColor

object is a PreferencesDisplay object.

Description

GraphicsWinModelBackgrndColor OLE_COLOR; Read-write


PreferencesDisplay.HistoryLines Property

Specifies the number of lines of text in the text window to keep in memory.

Syntax

object.HistoryLines

object is a PreferencesDisplay object.

Description

HistoryLines Integer; Read-write


PreferencesDisplay.ImageFrameHighlight Property

Controls the display of raster images during selection.

Syntax

object.ImageFrameHighlight

object is a PreferencesDisplay object.

Description

ImageFrameHighlight Boolean; Read-write


PreferencesDisplay.LayoutCreateViewport Property

Toggles the automatic creation of a viewport for new layouts.

Syntax

object.LayoutCreateViewport

object is a PreferencesDisplay object.

Description

LayoutCreateViewport Boolean; Read-write


PreferencesDisplay.LayoutCrosshairColor Property

Specifies the color of the crosshairs and text for paper space layouts.

Syntax

object.LayoutCrosshairColor

object is a PreferencesDisplay object.

Description

LayoutCrosshairColor OLE_COLOR; Read-write


PreferencesDisplay.LayoutDisplayMargins Property

Toggles the display of margins in layouts.

Syntax

object.LayoutDisplayMargins

object is a PreferencesDisplay object.

Description

LayoutDisplayMargins Boolean; Read-write


PreferencesDisplay.LayoutDisplayPaper Property

Toggles the display of the paper background in layouts.

Syntax

object.LayoutDisplayPaper

object is a PreferencesDisplay object.

Description

LayoutDisplayPaper Boolean; Read-write


PreferencesDisplay.LayoutDisplayPaperShadow Property

Toggles the display of the paper background shadow in layouts.

Syntax

object.LayoutDisplayPaperShadow

object is a PreferencesDisplay object.

Description

LayoutDisplayPaperShadow Boolean; Read-write


PreferencesDisplay.LayoutShowPlotSetup Property

Toggles the display of the Plot Setup dialog when a new layout is created.

Syntax

object.LayoutShowPlotSetup

object is a PreferencesDisplay object.

Description

LayoutShowPlotSetup Boolean; Read-write


PreferencesDisplay.ModelCrosshairColor Property

Specifies the color of the crosshairs and text for model space.

Syntax

object.ModelCrosshairColor

object is a PreferencesDisplay object.

Description

ModelCrosshairColor OLE_COLOR; Read-write


PreferencesDisplay.ShowRasterImage Property

Controls the display of raster images during real-time pan and zooms.

Syntax

object.ShowRasterImage

object is a PreferencesDisplay object.

Description

ShowRasterImage Boolean; Read-write


PreferencesDisplay.TextFont Property

Specifies the font for new text.

Syntax

object.TextFont

object is a PreferencesDisplay object.

Description

TextFont String; Read-write


PreferencesDisplay.TextFontSize Property

Specifies the font size for new text.

Syntax

object.TextFontSize

object is a PreferencesDisplay object.

Description

TextFontSize Integer; Read-write


PreferencesDisplay.TextFontStyle Property

Specifies the font style for new text.

Syntax

object.TextFontStyle

object is a PreferencesDisplay object.

Description

TextFontStyle ZcTextFontStyle: Read-write
Can be one of the constants listed here:
zcFontRegular
zcFontItalic
zcFontBold
zcFontBoldItalic


PreferencesDisplay.TextWinBackgrndColor Property

Specifies the background color for the text window.

Syntax

object.TextWinBackgrndColor

object is a PreferencesDisplay object.

Description

TextWinBackgrndColor OLE_COLOR; Read-write


PreferencesDisplay.TextWinTextColor Property

Specifies the text color for the text window.

Syntax

object.TextWinTextColor

object is a PreferencesDisplay object.

Description

TextWinTextColor OLE_COLOR; Read-write


PreferencesDisplay.TrueColorImages Property

Determines if raster and render images are displayed at true color or palletized color.

Syntax

object.TrueColorImages

object is a PreferencesDisplay object.

Description

TrueColorImages Boolean; Read-write


PreferencesDisplay.XRefFadeIntensity Property

Controls the dimming intensity for XRefs.

Syntax

object.XRefFadeIntensity

object is a PreferencesDisplay object.

Description

XRefFadeIntensity Long; Read-write


PreferencesDrafting.AlignmentPointAcquisition Property

Specifies how AutoAlignment points are acquired.

Syntax

object.AlignmentPointAcquisition

object is a PreferencesDrafting object.

Description

AlignmentPointAcquisition ZcAlignmentPointAcquisition: Read-write
Can be one of the constants listed here:
zcAlignPntAcquisitionAutomatic
zcAlignPntAcquisitionShiftToAcquire


PreferencesDrafting.Application Property

Returns the application object.

Syntax

object.Application

object is a PreferencesDrafting object.

Description

Application Application; Read-only


PreferencesDrafting.AutoSnapAperture Property

Toggles the display of the AutoSnap aperture.

Syntax

object.AutoSnapAperture

object is a PreferencesDrafting object.

Description

AutoSnapAperture Boolean; Read-write


PreferencesDrafting.AutoSnapApertureSize Property

Specifies the size of the AutoSnap aperture.

Syntax

object.AutoSnapApertureSize

object is a PreferencesDrafting object.

Description

AutoSnapApertureSize Long; Read-write


PreferencesDrafting.AutoSnapMagnet Property

Toggles the AutoSnap magnet.

Syntax

object.AutoSnapMagnet

object is a PreferencesDrafting object.

Description

AutoSnapMagnet Boolean; Read-write


PreferencesDrafting.AutoSnapMarker Property

Toggles the AutoSnap marker.

Syntax

object.AutoSnapMarker

object is a PreferencesDrafting object.

Description

AutoSnapMarker Boolean; Read-write


PreferencesDrafting.AutoSnapMarkerColor Property

Specifies the color of the AutoSnap marker.

Syntax

object.AutoSnapMarkerColor

object is a PreferencesDrafting object.

Description

AutoSnapMarkerColor ZcColor: Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


PreferencesDrafting.AutoSnapMarkerSize Property

Specifies the size of the AutoSnap marker.

Syntax

object.AutoSnapMarkerSize

object is a PreferencesDrafting object.

Description

AutoSnapMarkerSize Long; Read-write


PreferencesDrafting.AutoTrackTooltip Property

Toggles the display of the AutoTrack tooltips.

Syntax

object.AutoTrackTooltip

object is a PreferencesDrafting object.

Description

AutoTrackTooltip Boolean; Read-write


PreferencesDrafting.FullScreenTrackingVector Property

Toggles the display of full-screen tracking vectors.

Syntax

object.FullScreenTrackingVector

object is a PreferencesDrafting object.

Description

FullScreenTrackingVector Boolean; Read-write


PreferencesDrafting.PolarTrackingVector Property

Toggles the display of polar tracking vectors.

Syntax

object.PolarTrackingVector

object is a PreferencesDrafting object.

Description

PolarTrackingVector Boolean; Read-write


PreferencesFiles.DriversPath Property

Set the Drivers path.

Syntax

object.DriversPath

object is a PreferencesFiles object.

Description

DriversPath String; Read-write


PreferencesOpenSave.Application Property

Returns the application object.

Syntax

object.Application

object is a PreferencesOpenSave object.

Description

Application Application; Read-only


PreferencesOpenSave.AutoAudit Property

Specifies whether ZWCAD should perform an audit after you render a DXFIN or DXBIN interchange command.

Syntax

object.AutoAudit

object is a PreferencesOpenSave object.

Description

AutoAudit Boolean; Read-write


PreferencesOpenSave.AutoSaveInterval Property

Specifies an automatic save interval in minutes.

Syntax

object.AutoSaveInterval

object is a PreferencesOpenSave object.

Description

AutoSaveInterval Integer; Read-write


PreferencesOpenSave.CreateBackup Property

Specifies the use of a backup file.

Syntax

object.CreateBackup

object is a PreferencesOpenSave object.

Description

CreateBackup Boolean; Read-write


PreferencesOpenSave.FullCRCValidation Property

Specifies whether a cyclic redundancy check (CRC) should be performed each time an object is read into the drawing.

Syntax

object.FullCRCValidation

object is a PreferencesOpenSave object.

Description

FullCRCValidation Boolean; Read-write


PreferencesOpenSave.IncrementalSavePercent Property

Specifies the percentage of wasted space allowed in a drawing file.

Syntax

object.IncrementalSavePercent

object is a PreferencesOpenSave object.

Description

IncrementalSavePercent Integer; Read-write


PreferencesOpenSave.LogFileOn Property

Specifies whether the contents of the text window are written to a log file.

Syntax

object.LogFileOn

object is a PreferencesOpenSave object.

Description

LogFileOn Boolean; Read-write


PreferencesOpenSave.MRUNumber Property

Specifies the number of most recently used files that is shown in the File menu.

Syntax

object.MRUNumber

object is a PreferencesOpenSave object.

Description

MRUNumber Long; Read-only


PreferencesOpenSave.ProxyImage Property

Controls the display of objects in a drawing that were created in a third-party application.

Syntax

object.ProxyImage

object is a PreferencesOpenSave object.

Description

ProxyImage ZcProxyImage: Read-write
Can be one of the constants listed here:
zcProxyNotShow
zcProxyShow
zcProxyBoundingBox


PreferencesOpenSave.SaveAsType Property

Specifies the drawing type for saving the drawing.

Syntax

object.SaveAsType

object is a PreferencesOpenSave object.

Description

SaveAsType ZcSaveAsType: Read-write
Can be one of the constants listed here:
zcUnknown
zcR12_dxf
zcR13_dwg
zcR13_dxf
zcR14_dwg
zcR14_dxf
ac2000_dwg
ac2000_dxf
ac2000_Template
ac2004_dwg
ac2004_dxf
ac2004_Template
ac2007_dwg
ac2007_dxf
ac2007_Template
zcNative
zcR15_dwg
zcR15_dxf
zcR15_Template
zcR18_dwg
zcR18_dxf
zcR18_Template


PreferencesOpenSave.SavePreviewThumbnail Property

Specifies if BMP preview images are saved with the drawing.

Syntax

object.SavePreviewThumbnail

object is a PreferencesOpenSave object.

Description

SavePreviewThumbnail Boolean; Read-write


PreferencesOpenSave.ShowProxyDialogBox Property

Specifies if ZWCAD displays a warning message when you open a drawing that contains custom objects.

Syntax

object.ShowProxyDialogBox

object is a PreferencesOpenSave object.

Description

ShowProxyDialogBox Boolean; Read-write


PreferencesOpenSave.TempFileExtension Property

Specifies the extension for temporary files.

Syntax

object.TempFileExtension

object is a PreferencesOpenSave object.

Description

TempFileExtension String; Read-write


PreferencesOutput.DefaultPlotStyleTable Property

Specifies the default plot style table to attach to new drawings.

Syntax

object.DefaultPlotStyleTable

object is a PreferencesOutput object.

Description

DefaultPlotStyleTable String; Read-write


PreferencesOutput.PlotPolicy Property

Determines whether an object's color property is associated with its plot style name when a new drawing is created.

Syntax

object.PlotPolicy

object is a PreferencesOutput object.

Description

PlotPolicy ZcPlotPolicy: Read-write
Can be one of the constants listed here:
zcPolicyNamed
zcPolicyLegacy


PreferencesProfiles.ActiveProfile Property

Specifies the active profile for the ZWCAD session.

Syntax

object.ActiveProfile

object is a PreferencesProfiles object.

Description

ActiveProfile String; Read-write


PreferencesProfiles.Application Property

Returns the application object.

Syntax

object.Application

object is a PreferencesProfiles object.

Description

Application Application; Read-only


PreferencesSelection.Application Property

Returns the application object.

Syntax

object.Application

object is a PreferencesSelection object.

Description

Application Application; Read-only


PreferencesSelection.DisplayGrips Property

Controls the display of selection set grips for the Stretch, Move, Rotate, Scale, and Mirror grip modes.

Syntax

object.DisplayGrips

object is a PreferencesSelection object.

Description

DisplayGrips Boolean; Read-write


PreferencesSelection.DisplayGripsWithinBlocks Property

Controls the assignment of grips within blocks.

Syntax

object.DisplayGripsWithinBlocks

object is a PreferencesSelection object.

Description

DisplayGripsWithinBlocks Boolean; Read-write


PreferencesSelection.GripColorSelected Property

Specifies the color of selected grips.

Syntax

object.GripColorSelected

object is a PreferencesSelection object.

Description

GripColorSelected ZcColor: Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


PreferencesSelection.GripColorUnselected Property

Specifies the color of unselected grips.

Syntax

object.GripColorUnselected

object is a PreferencesSelection object.

Description

GripColorUnselected ZcColor: Read-write
Can be one of the constants listed here:
zcByBlock
zcRed
zcYellow
zcGreen
zcCyan
zcBlue
zcMagenta
zcWhite
zcByLayer


PreferencesSelection.GripSize Property

Specifies the size of grips.

Syntax

object.GripSize

object is a PreferencesSelection object.

Description

GripSize Long; Read-write


PreferencesSelection.PickAdd Property

Determines if objects are added to the selection set using the SHIFT key.

Syntax

object.PickAdd

object is a PreferencesSelection object.

Description

PickAdd Boolean; Read-write


PreferencesSelection.PickAuto Property

Controls automatic windowing at the Select Objects prompt.

Syntax

object.PickAuto

object is a PreferencesSelection object.

Description

PickAuto Boolean; Read-write


PreferencesSelection.PickBoxSize Property

Specifies the size of the object selection target.

Syntax

object.PickBoxSize

object is a PreferencesSelection object.

Description

PickBoxSize Long; Read-write


PreferencesSelection.PickDrag Property

Controls the method of drawing a selection window.

Syntax

object.PickDrag

object is a PreferencesSelection object.

Description

PickDrag Boolean; Read-write


PreferencesSelection.PickFirst Property

Determines if you select objects before (noun-verb selection) or after you issue a command.

Syntax

object.PickFirst

object is a PreferencesSelection object.

Description

PickFirst Boolean; Read-write


PreferencesSelection.PickGroup Property

Determines if picking a single object in a group selects the entire group.

Syntax

object.PickGroup

object is a PreferencesSelection object.

Description

PickGroup Boolean; Read-write


PreferencesSystem.Application Property

Returns the application object.

Syntax

object.Application

object is a PreferencesSystem object.

Description

Application Application; Read-only


PreferencesSystem.BeepOnError Property

Specifies if ZWCAD should sound an alarm beep when it detects an invalid entry.

Syntax

object.BeepOnError

object is a PreferencesSystem object.

Description

BeepOnError Boolean; Read-write


PreferencesSystem.DisplayOLEScale Property

Determines whether the OLE scaling dialog is displayed when OLE objects are inserted into a drawing.

Syntax

object.DisplayOLEScale

object is a PreferencesSystem object.

Description

DisplayOLEScale Boolean; Read-write


PreferencesSystem.EnableStartupDialog Property

Specifies whether a startup dialog box is displayed when ZWCAD is launched or a new drawing is created.

Syntax

object.EnableStartupDialog

object is a PreferencesSystem object.

Description

EnableStartupDialog Boolean; Read-write


PreferencesSystem.LoadZcadLspInAllDocuments Property

Specifies whether zcad.lsp is loaded at startup or with each drawing.

Syntax

object.LoadZcadLspInAllDocuments

object is a PreferencesSystem object.

Description

LoadZcadLspInAllDocuments Boolean; Read-write


PreferencesSystem.ShowWarningMessages Property

Resets all dialog boxes that have the "Don't Display This Warning Again" check box so they display again.

Syntax

object.ShowWarningMessages

object is a PreferencesSystem object.

Description

ShowWarningMessages Boolean; Read-write


PreferencesSystem.SingleDocumentMode Property

Determines if ZWCAD runs in single- or multiple-document mode.

Syntax

object.SingleDocumentMode

object is a PreferencesSystem object.

Description

SingleDocumentMode Boolean; Read-write


PreferencesSystem.StoreSQLIndex Property

Determines if the SQL index is stored in the drawing.

Syntax

object.StoreSQLIndex

object is a PreferencesSystem object.

Description

StoreSQLIndex Boolean; Read-write


PreferencesSystem.TablesReadOnly Property

Determines whether to open database tables in read-only mode.

Syntax

object.TablesReadOnly

object is a PreferencesSystem object.

Description

TablesReadOnly Boolean; Read-write


PreferencesUser.ADCInsertUnitsDefaultSource Property

Determines the units to use automatically for objects in DesignCenter for a source drawing that does not have assigned insert units.

Syntax

object.ADCInsertUnitsDefaultSource

object is a PreferencesUser object.

Description

ADCInsertUnitsDefaultSource ZcInsertUnits: Read-write
Can be one of the constants listed here:
zcInsertUnitsUnitless
zcInsertUnitsInches
zcInsertUnitsFeet
zcInsertUnitsMiles
zcInsertUnitsMillimeters
zcInsertUnitsCentimeters
zcInsertUnitsMeters
zcInsertUnitsKilometers
zcInsertUnitsMicroinches
zcInsertUnitsMils
zcInsertUnitsYards
zcInsertUnitsAngstroms
zcInsertUnitsNanometers
zcInsertUnitsMicrons
zcInsertUnitsDecimeters
zcInsertUnitsDecameters
zcInsertUnitsHectometers
zcInsertUnitsGigameters
zcInsertUnitsAstronomicalUnits
zcInsertUnitsLightYears
zcInsertUnitsParsecs


PreferencesUser.ADCInsertUnitsDefaultTarget Property

Determines the units to use automatically for objects in DesignCenter for a target drawing that does not have assigned insert units.

Syntax

object.ADCInsertUnitsDefaultTarget

object is a PreferencesUser object.

Description

ADCInsertUnitsDefaultTarget ZcInsertUnits: Read-write
Can be one of the constants listed here:
zcInsertUnitsUnitless
zcInsertUnitsInches
zcInsertUnitsFeet
zcInsertUnitsMiles
zcInsertUnitsMillimeters
zcInsertUnitsCentimeters
zcInsertUnitsMeters
zcInsertUnitsKilometers
zcInsertUnitsMicroinches
zcInsertUnitsMils
zcInsertUnitsYards
zcInsertUnitsAngstroms
zcInsertUnitsNanometers
zcInsertUnitsMicrons
zcInsertUnitsDecimeters
zcInsertUnitsDecameters
zcInsertUnitsHectometers
zcInsertUnitsGigameters
zcInsertUnitsAstronomicalUnits
zcInsertUnitsLightYears
zcInsertUnitsParsecs


PreferencesUser.Application Property

Returns the application object.

Syntax

object.Application

object is a PreferencesUser object.

Description

Application Application; Read-only


PreferencesUser.HyperlinkDisplayCursor Property

Toggles the display of the hyperlink cursor and shortcut menu.

Syntax

object.HyperlinkDisplayCursor

object is a PreferencesUser object.

Description

HyperlinkDisplayCursor Boolean; Read-write


PreferencesUser.HyperlinkDisplayTooltip Property

Toggles the display of hyperlink tooltips.

Syntax

object.HyperlinkDisplayTooltip

object is a PreferencesUser object.

Description

HyperlinkDisplayTooltip Boolean; Read-write


PreferencesUser.KeyboardAccelerator Property

Specifies the Windows standard or ZWCAD classic keyboard.

Syntax

object.KeyboardAccelerator

object is a PreferencesUser object.

Description

KeyboardAccelerator ZcKeyboardAccelerator: Read-write
Can be one of the constants listed here:
zcPreferenceClassic
zcPreferenceCustom


PreferencesUser.KeyboardPriority Property

Controls how ZWCAD responds to the input of coordinate data.

Syntax

object.KeyboardPriority

object is a PreferencesUser object.

Description

KeyboardPriority ZcKeyboardPriority: Read-write
Can be one of the constants listed here:
zcKeyboardRunningObjSnap
zcKeyboardEntry
zcKeyboardEntryExceptScripts


PreferencesUser.SCMCommandMode Property

Determines right-click functionality in the drawing area while in Command mode, which means that a command is currently in progress.

Syntax

object.SCMCommandMode

object is a PreferencesUser object.

Description

SCMCommandMode ZcDrawingAreaSCMCommand: Read-write
Can be one of the constants listed here:
zcEnter
zcEnableSCMOptions
zcEnableSCM


PreferencesUser.SCMDefaultMode Property

Determines right-click functionality in the drawing area while in Default mode, which means that no objects are selected and no commands are in progress.

Syntax

object.SCMDefaultMode

object is a PreferencesUser object.

Description

SCMDefaultMode ZcDrawingAreaSCMDefault: Read-write
Can be one of the constants listed here:
zcRepeatLastCommand
zcSCM


PreferencesUser.SCMEditMode Property

Determines right-click functionality in the drawing area while in Edit mode, which means that one or more objects are selected and no commands are in progress.

Syntax

object.SCMEditMode

object is a PreferencesUser object.

Description

SCMEditMode ZcDrawingAreaSCMEdit: Read-write
Can be one of the constants listed here:
zcEdRepeatLastCommand
zcEdSCM


PreferencesUser.SCMTimeMode Property

Controls time-sensitive right-click behavior.

Syntax

object.SCMTimeMode

object is a PreferencesUser object.

Description

SCMTimeMode Boolean; Read-write


PreferencesUser.SCMTimeValue Property

Controls time-sensitive right-click behavior by setting the duration of the long click that displays a shortcut menu.

Syntax

object.SCMTimeValue

object is a PreferencesUser object.

Description

SCMTimeValue Integer; Read-write


PreferencesUser.ShortCutMenuDisplay Property

Controls whether right-clicking in the drawing area displays a shortcut menu or issues ENTER.

Syntax

object.ShortCutMenuDisplay

object is a PreferencesUser object.

Description

ShortCutMenuDisplay Boolean; Read-write